Revit 2010 API
LocationCurve Members
LocationCurve Class Constructors Methods Properties See Also

The LocationCurve type exposes the following members.

Constructors

Name | Description
LocationCurve | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Move | Move the element within the project by a specified vector. (Inherited from Location.)
Rotate | Rotate the element within the project by a specified number of degrees around a given axis. (Inherited from Location.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Curve | Provides the ability to get and set the curve of a curve based element.
ElementsAtJoin | Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
JoinType | Get/change the type of the join at the specified end.

See Also

LocationCurve Class
Autodesk.Revit Namespace