Revit 2010 API
Materials..::.AddSteel Method
Materials Class Example See Also
Add a steel material with the given name .

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialSteel AddSteel(
    string name
)
Visual Basic (Declaration)
Public Function AddSteel ( _
    name As String _
) As MaterialSteel
Visual C++
public:
MaterialSteel^ AddSteel(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the steel material to be added.

Return Value

The pointer to the added steel material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

Examples

CopyC#
private MaterialSteel AddSteel(Document document)
{
    string newName = "mySteelMaterial";
    MaterialSteel mySteel = document.Settings.Materials.AddSteel(newName);

    if (null != mySteel)
    {
        MessageBox.Show("Steel material added successfully!", "Revit");
    }

    return mySteel;
}
CopyVB.NET
Private Function AddSteel(ByVal document As Document) As MaterialSteel
    Dim newName As String = "mySteelMaterial"
    Dim mySteel As MaterialSteel = document.Settings.Materials.AddSteel(newName)

    If mySteel IsNot Nothing Then
        MessageBox.Show("Steel material added successfully!", "Revit")
    End If

    Return mySteel
End Function

See Also

Materials Class
Autodesk.Revit Namespace