Revit 2010 API
PlanCircuit Members
PlanCircuit Class Constructors Methods Properties See Also

The PlanCircuit type exposes the following members.

Constructors

Name | Description
PlanCircuit | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Area | The enclosed area of the circuit.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsRoomLocated | Reports whether there is a room located in this circuit.
SideNum | The number of sides in the circuit.

See Also

PlanCircuit Class
Autodesk.Revit Namespace