Revit 2010 API
Element Methods
Element Class See Also

The Element type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element.
GetMaterialVolume | Get the volume of the given material on this element.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Element Class
Autodesk.Revit Namespace