Revit 2010 API
Document..::.NewGutter Method (GutterType, Reference)
Document Class See Also
Creates a gutter along a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Gutter NewGutter(
    GutterType GutterType,
    Reference reference
)
Visual Basic (Declaration)
Public Function NewGutter ( _
    GutterType As GutterType, _
    reference As Reference _
) As Gutter
Visual C++
public:
Gutter^ NewGutter(
    GutterType^ GutterType,
    Reference^ reference
)

Parameters

GutterType
Type: Autodesk.Revit.Symbols..::.GutterType
The type of the gutter to create
reference
Type: Autodesk.Revit.Geometry..::.Reference
A planar line or arc that represents the place where you want to place the gutter.

Return Value

If successful a new gutter object within the project, otherwise Nothing.

See Also

Document Class
NewGutter Overload
Autodesk.Revit.Creation Namespace