Revit 2010 API
Application..::.NewProfiledWallCreationData Method (CurveArray, WallType, Level, Boolean, XYZ)
Application Class See Also
Creates an object which wraps the arguments of NewWall() for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProfiledWallCreationData NewProfiledWallCreationData(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic (Declaration)
Public Function NewProfiledWallCreationData ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
) As ProfiledWallCreationData
Visual C++
public:
ProfiledWallCreationData^ NewProfiledWallCreationData(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.Symbols..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.
normal
Type: Autodesk.Revit.Geometry..::.XYZ
A vector that must be perpendicular to the profile which dictates which side of the wall is considered.

See Also

Application Class
NewProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace