Revit 2010 API
Category..::.AllowsVisibilityControl Property
Category Class See Also
Whether the visibility can be controlled by the user for this category in this view.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool AllowsVisibilityControl[
    View view
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowsVisibilityControl ( _
    view As View _
) As Boolean
Visual C++
public:
property bool AllowsVisibilityControl[View^ view] {
    bool get (View^ view);
}

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view where visibility control might be allowed.

Remarks

There are some categories in Revit that are hidden to users in the Object Styles and Visibility dialog. Their visibility cannot be controlled for a particular view. This property identifies if the category allows visibility control (and thus allows the Visible property to be set).

See Also

Category Class
Autodesk.Revit Namespace