Revit 2010 API
HermiteSpline Properties
HermiteSpline Class See Also

The HermiteSpline type exposes the following members.

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
ControlPoints | The control points of the Hermite spline.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
IsPeriodic | Returns whether the Hermite spline is periodic or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve. (Inherited from Curve.)
Parameters | Returns the params of the Hermite spline.
Period | The period of this curve. (Inherited from Curve.)
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Tangents | Returns the tangents of the Hermite spline.
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

HermiteSpline Class
Autodesk.Revit.Geometry Namespace