Revit 2010 API
Form Members
Form Class Constructors Methods Properties See Also

The Form type exposes the following members.

Constructors

Name | Description
Form | For Internal Use Only.

Methods

Name | Description
AddEdge | Overloaded.
AddProfile | Add a profile into the form, by a specified edge/param.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanManipulateProfile | Tell if a profile can be deleted/moved/rotated.
CanManipulateSubElement | Tell if a sub element can be deleted/moved/rotated/scaled.
ConstrainProfiles | Constrain form profiles using the specified profile as master. This is an advanced version of property "AreProfilesConstrained", allowing specify the master profile.
DeleteProfile | Delete a profile of the form.
DeleteSubElement | Delete a face/edge/curve/vertex of the form, specified by a reference.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetControlPoints | Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).
GetCurvesAndEdgesReference | Given a point, return all edges and curves that it is lying on.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetPathCurveIndexByCurveReference | Given a reference to certain curve in the path, return its index.
GetProfileAndCurveLoopIndexFromReference | Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsAutoCreaseEdge | Tell if an edge is an auto-crease on a top/bottom cap face.
IsBeginningFace | Given a face, tell if it is a beginning cap face.
IsConnectingEdge | Tell if an edge is a connecting edge on a side face. Connecting edges connect vertices on different profiles.
IsCurveReference | Tell if the pick is the reference to a curve of the form.
IsEdgeReference | Tell if the pick is the reference to an edge of the form.
IsEndFace | Given a face, tell if it is an end cap face.
IsFaceReference | Tell if the pick is the reference to a face of the form.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsProfileEdge | Tell if an edge or curve is generated from a profile.
IsReferenceOnlyProfile | Tell if the profile is made by referencing existing geometry in the Revit model.
IsSideFace | Given a face, tell if it is a side face.
IsVertexReference | Tell if the pick is the reference to a vertex of the form.
MoveProfile | Move a profile of the form, specified by a reference, and an offset vector.
MoveSubElement | Move a face/edge/curve/vertex of the form, specified by a reference, and an offset vector.
RotateProfile | Rotate a profile of the form, by a specified number of degrees around a given axis.
RotateSubElement | Rotate a face/edge/curve/vertex of the form, by a specified number of degrees around a given axis.
ScaleProfile | Scale a profile of the form, by a specified origin and scale factor.
ScaleSubElement | Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AreProfilesConstrained | Get/set if the form's profiles are constrained.
BaseOffset | Retrieve/set the base offset of the form object. It is only valid for locked form.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
CurveLoopReferencesOnProfile | The curve references in certain curve loop, specified by profile index and curve loop index.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HasOneOrMoreReferenceProfiles | Tell if the form has any reference profile.
HasOpenGeometry | Tell if the form has an open geometry.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInXRayMode | Get/set if the form is in X-Ray mode.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PathCurveCount | The number of curves in the form path.
PathCurveReference | The curve reference in the path, specified by curve index.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProfileCount | The number of profiles in the form.
ProfileCurveLoopCount | The number of curve loops in certain profile, specified by profile index.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory. (Inherited from GenericForm.)
TopOffset | Retrieve/set the top offset of the form object. It is only valid for locked form.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Form Class
Autodesk.Revit.Elements Namespace