Revit 2010 API
InternalDefinition Members
InternalDefinition Class Constructors Methods Properties See Also

The InternalDefinition type exposes the following members.

Constructors

Name | Description
InternalDefinition | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BuiltInParameter | Identifies if the parameter is a BuiltIn parameter.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | The user-visible name for the parameter. (Overrides Definition..::.Name.)
ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition..::.ParameterGroup.)
ParameterType | Returns the user-visible interpretation of the parameter data. (Overrides Definition..::.ParameterType.)

See Also

InternalDefinition Class
Autodesk.Revit.Parameters Namespace