Revit 2010 API
ItemFactoryBase..::.NewDetailCurve Method
ItemFactoryBase Class See Also
Creates a new detail curve element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DetailCurve NewDetailCurve(
    View view,
    Curve geometryCurve
)
Visual Basic (Declaration)
Public Function NewDetailCurve ( _
    view As View, _
    geometryCurve As Curve _
) As DetailCurve
Visual C++
public:
DetailCurve^ NewDetailCurve(
    View^ view,
    Curve^ geometryCurve
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the detail curve is to be visible.
geometryCurve
Type: Autodesk.Revit.Geometry..::.Curve
The internal geometry curve for detail curve. It should be a bound curve.

Return Value

If successful a new detail curve element. Otherwise null pointer.

Remarks

Different type of detail curve element will be returned according to the type of geometry curve.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace