Revit 2010 API
ReferencePoint..::.GetCoordinateSystem Method
ReferencePoint Class See Also
The position and orientation of the ReferencePoint.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Transform GetCoordinateSystem()
Visual Basic (Declaration)
Public Function GetCoordinateSystem As Transform
Visual C++
public:
Transform^ GetCoordinateSystem()

Remarks

The position of the point is given by CoordinateSystem.Origin, and the orientation is specified by the three unit vectors CoordinateSystem.BasisX, BasisY, BasisZ.

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace