Revit 2010 API
SpacingRule..::.SetLayoutMinimumSpacing Method
SpacingRule Class See Also
Set the Layout property to MinimumSpacing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetLayoutMinimumSpacing(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
Visual Basic (Declaration)
Public Sub SetLayoutMinimumSpacing ( _
    distance As Double, _
    just As SpacingRuleJustification, _
    gridlinesRotation As Double, _
    offset As Double _
)
Visual C++
public:
void SetLayoutMinimumSpacing(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)

Parameters

distance
Type: System..::.Double
just
Type: Autodesk.Revit.Enums..::.SpacingRuleJustification
gridlinesRotation
Type: System..::.Double
offset
Type: System..::.Double

Remarks

When changing the Layout to MinimumSpacing, you must also simultaneously set the Distance, Justification, GridlinesRotation, and Offset properties.

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace