Revit 2010 API
CurtainCell Members
CurtainCell Class Constructors Methods Properties See Also

The CurtainCell type exposes the following members.

Constructors

Name | Description
CurtainCell | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurveLoops | The cell boundaries on the reference face.The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
PlanarizedCurveLoops | The planarized curve loops for cell boundaries.The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

See Also

CurtainCell Class
Autodesk.Revit.Elements Namespace