Revit 2010 API
AreaLoad Properties
AreaLoad Class See Also

The AreaLoad type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | Returns the geometric curve within a geometric loop that defines the area.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Force | Returns the three dimensional force applied to one of the points for the area load.
Force1 | Returns the three dimensional force applied to the point 1 of the area load.
Force2 | Returns the three dimensional force applied to the point 2 of the area load.
Force3 | Returns the three dimensional force applied to the point 3 of the area load.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HostElement | The host element for the load. (Inherited from LoadBase.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
NumCurves | Returns the number of curves within a geometric loop that defines the area.
NumLoops | Returns the number of geometric curve loops that define the area.
NumRefPoints | Returns the total number of reference points for the area load.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RefPoint | Retrieve the physical location of the reference point.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace