Revit 2010 API
WireType Members
WireType Class Constructors Methods Properties See Also

The WireType type exposes the following members.

Constructors

Name | Description
WireType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Conduit | Get of set conduit type of wire type.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Insulation | Get of set insulation type.
IsInUse | Indicate whether the wire type is in use.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaxSize | Get of set max size of wire type.
Name | set name for a symbol (Inherited from Symbol.)
NeutralMultiplier | Get of set neutral multiplier type of wire type.
NeutralRequired | Get of set whether the neutral point is required.
NeutralSize | Get of set maximum neutral size of wire type.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
TemperatureRating | Get of set temperature rating type of wire type.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
WireMaterial | Get of set material type of wire type.

See Also

WireType Class
Autodesk.Revit.MEP Namespace