Revit 2010 API
MaterialGeneric Members
MaterialGeneric Class Constructors Methods Properties See Also

The MaterialGeneric type exposes the following members.

Constructors

Name | Description
MaterialGeneric | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this generic material element. (Overrides Material..::.Duplicate(String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Behavior | Get or set the material behavior type of the generic material.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DampingRatio | Get or set the damping ratio of the generic material.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MinimumYieldStress | Get or set the minimum yield stress of the generic material.
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PoissonModulusX | Get or set the x component of the Poisson modulus of the generic material.
PoissonModulusY | Get or set the y component of the Poisson modulus of the generic material.
PoissonModulusZ | Get or set the z component of the Poisson modulus of the generic material.
ReductionFactor | Get or set the reduction factor for shear of the generic material.
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
ShearModulusX | Get or set the x component of the shear modulus of the generic material.
ShearModulusY | Get or set the y component of the shear modulus of the generic material.
ShearModulusZ | Get or set the z component of the shear modulus of the generic material.
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the generic material.
ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the generic material.
ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the generic material.
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UnitWeight | Get or set the unit weight of the generic material.
YoungModulusX | Get or set the x component of the Young modulus of the generic material.
YoungModulusY | Get or set the y component of the Young modulus of the generic material.
YoungModulusZ | Get or set the z component of the Young modulus of the generic material.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace