Revit 2010 API
WireMaterialType Methods
WireMaterialType Class See Also

The WireMaterialType type exposes the following members.

Methods

Name | Description
AddGroundConductorSize | Add new electrical ground conductor size type into this material type.
AddTemperatureRatingType | Add a new temperature rating type into material type.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveGroundConductorSize | Remove an existing ground conductor size from this material type.
RemoveTemperatureRatingType | Remove an existing temperature rating type from this material type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireMaterialType Class
Autodesk.Revit.MEP Namespace