Revit 2010 API
BuildingSiteExportOptions Members
BuildingSiteExportOptions Class Constructors Methods Properties See Also

The BuildingSiteExportOptions type exposes the following members.

Constructors

Name | Description
BuildingSiteExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AreaPerPerson | Custom value for Area Per Person value.
PropertyLine | Optional property Line to export; it may be null.
PropertyLineOffset | Property Line Offset. Default is 0.0.
TotalGrossArea | Custom value for the total area.
TotalOccupancy | Custom value for the total occupancy.

See Also

BuildingSiteExportOptions Class
Autodesk.Revit Namespace