Revit 2010 API
FamilyInstance Methods
FamilyInstance Class See Also

The FamilyInstance type exposes the following members.

Methods

Name | Description
AddCoping | Adds a coping (cut) to a steel beam.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
FlipFromToRoom | Change the room to which the door or window is opened.
flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
GetCopings | Lists the elements currently used as coping cutters for this element.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveCoping | Removes a coping (cut) from a steel beam.
rotate | The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true.
SetCopings | Specify the set of coping cutters on this element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace