Revit 2010 API
AnalyticalModel3D Members
AnalyticalModel3D Class Constructors Methods Properties See Also

The AnalyticalModel3D type exposes the following members.

Constructors

Name | Description
AnalyticalModel3D | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Curves | Returns curves that define the Analytical Model of the associated Element.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModel3D Class
Autodesk.Revit.Structural Namespace