Revit 2010 API
FamilyItemFactory..::.NewSweptBlendForm Method
FamilyItemFactory Class See Also
Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Form NewSweptBlendForm(
    bool isSolid,
    ReferenceArray path,
    ReferenceArrayArray profiles
)
Visual Basic (Declaration)
Public Function NewSweptBlendForm ( _
    isSolid As Boolean, _
    path As ReferenceArray, _
    profiles As ReferenceArrayArray _
) As Form
Visual C++
public:
Form^ NewSweptBlendForm(
    bool isSolid,
    ReferenceArray^ path,
    ReferenceArrayArray^ profiles
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Form is Solid or Void.
path
Type: Autodesk.Revit.Geometry..::.ReferenceArray
The path of the swept blend. The path should be 2D, where all input curves lie in one plane. If there’s more than one profile, the path should be a single curve. It’s required to reference existing geometry.
profiles
Type: Autodesk.Revit.Geometry..::.ReferenceArrayArray
The profile set of the newly created swept blend. Each profile should consist of only one curve loop. The input profile must be in one plane.

Return Value

If creation was successful new form is returned.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace