Revit 2010 API
Location Members
Location Class Constructors Methods Properties See Also

The Location type exposes the following members.

Constructors

Name | Description
Location | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Move | Move the element within the project by a specified vector.
Rotate | Rotate the element within the project by a specified number of degrees around a given axis.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Location Class
Autodesk.Revit Namespace