Revit 2010 API
FamilyManager..::.AddParameter Method (String, BuiltInParameterGroup, ParameterType, Boolean)
FamilyManager Class See Also
Add a new family parameter with a given name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyParameter AddParameter(
    string parameterName,
    BuiltInParameterGroup parameterGroup,
    ParameterType parameterType,
    bool isInstance
)
Visual Basic (Declaration)
Public Function AddParameter ( _
    parameterName As String, _
    parameterGroup As BuiltInParameterGroup, _
    parameterType As ParameterType, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ AddParameter(
    String^ parameterName,
    BuiltInParameterGroup parameterGroup,
    ParameterType parameterType,
    bool isInstance
)

Parameters

parameterName
Type: System..::.String
The name of the new family parameter.
parameterGroup
Type: Autodesk.Revit.Parameters..::.BuiltInParameterGroup
The group to which the family parameter belongs.
parameterType
Type: Autodesk.Revit.Parameters..::.ParameterType
The type of new family parameter.
isInstance
Type: System..::.Boolean
Indicates if the new family parameter is instance or type.

Return Value

If creation was successful the new parameter is returned, otherwise an exception with failure information will be thrown.

Remarks

This method can work even without any family type, but it cannot be assigned the value via FamilyManager.Set methods when there is no current type.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"parameterName"-is null.
System..::.ArgumentException | Thrown when the input argument-"parameterName"-is already in use, or when the input argument -"parameterType" is an invalid type. Also thrown when "parameterType" is FamilyType; to add a parameter of this type use the AddParameter method that accepts a category instead.
System..::.InvalidOperationException | Thrown when the family parameter creation failed.

See Also

FamilyManager Class
AddParameter Overload
Autodesk.Revit Namespace