Revit 2010 API
RebarShape..::.GetCurvesForBrowser Method
RebarShape Class See Also
Generate curves for the shape, as used in the shape browser.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray GetCurvesForBrowser()
Visual Basic (Declaration)
Public Function GetCurvesForBrowser As CurveArray
Visual C++
public:
CurveArray^ GetCurvesForBrowser()

Return Value

An array of curves representing the shape with its default parameters.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace