Revit 2010 API
PipingSystem Properties
PipingSystem Class See Also

The PipingSystem type exposes the following members.

Properties

Name | Description
BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Flow | The system flow.
FluidDensity | The system fluid density.
FluidTemperature | The system fluid temperature.
FluidType | The system fluid type.
FluidViscosity | The system fluid viscosity.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsWellConnected | Indicates if the system is well connected or not.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PipingNetwork | Pipes and fittings which are contained in this system.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
StaticPressure | The system static pressure.
SystemType | The type of this piping system.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PipingSystem Class
Autodesk.Revit.MEP Namespace