Revit 2010 API
Document..::.NewFascia Method (FasciaType, ReferenceArray)
Document Class See Also
Creates a fascia along a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Fascia NewFascia(
    FasciaType FasciaType,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewFascia ( _
    FasciaType As FasciaType, _
    references As ReferenceArray _
) As Fascia
Visual C++
public:
Fascia^ NewFascia(
    FasciaType^ FasciaType,
    ReferenceArray^ references
)

Parameters

FasciaType
Type: Autodesk.Revit.Symbols..::.FasciaType
The type of the fascia to create
references
Type: Autodesk.Revit.Geometry..::.ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the fascia.

Return Value

If successful a new fascia object within the project, otherwise Nothing.

See Also

Document Class
NewFascia Overload
Autodesk.Revit.Creation Namespace