Revit 2010 API
Selection Members
Selection Class Constructors Methods Properties See Also

The Selection type exposes the following members.

Constructors

Name | Description
Selection | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
PickOne | Allows the user to select one element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WindowSelect | Allows the user to select elements by a rectangle.

Properties

Name | Description
Elements | The elements that are currently selected.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
StatusbarTip | The message displayed in the status bar tip when prompting the user to make a selection.

See Also

Selection Class
Autodesk.Revit Namespace