Revit 2010 API
DividedSurface Methods
DividedSurface Class See Also

The DividedSurface type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetGridNodeLocation | Specify whether a particular grid node is interior to the surface, on the boundary, or outside the boundary.
GetGridNodeReference | Get a reference to the geometric point associated with a grid node.
GetGridNodeUV | Get the position of a grid node in UV coordinates in the surface.
GetGridSegmentReference | Get a reference to a line segment connecting two adjacent grid nodes.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetTileFamilyInstance | Get a reference to a tile element associated with a given seed node.
GetTileReference | Get a reference to one of the tile surfaces associated with a given seed node.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsSeedNode | Reports whether a grid node is a "seed node," a node that is associated with one or more tiles.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace