Revit 2010 API
BeamSystemTypeSet Members
BeamSystemTypeSet Class Constructors Methods Properties See Also

The BeamSystemTypeSet type exposes the following members.

Constructors

Name | Description
BeamSystemTypeSet | Initializes a new instance of the BeamSystemTypeSet class

Methods

Name | Description
Clear | Removes every BeamSystem type from the set, rendering it empty.
Contains | Tests for the existence of a BeamSystem type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified BeamSystem type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified BeamSystem type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of BeamSystem types that are in the set.

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace