Revit 2010 API
Truss Methods
Truss Class See Also

The Truss type exposes the following members.

Methods

Name | Description
AttachTopChord | Attach truss's top to a specified element,the element should be a roof or floor.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
DetachTopChord | Detach the truss's top from a specified element.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetTrussMemberInfo | Query if a given element is a member of a truss,its lock status and its usage,etc.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveProfile | Remove the profile of a truss.
SetProfile | Add or modify the profile of a truss.
TogglePinMember | Pin/Unpin a truss member.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Truss Class
Autodesk.Revit.Elements Namespace