Revit 2010 API
CitySetIterator..::.Reset Method
CitySetIterator Class See Also
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CitySetIterator Class
Autodesk.Revit.Site Namespace