Revit 2010 API
PointOnEdgeFaceIntersection..::.SetFaceReference Method
PointOnEdgeFaceIntersection Class See Also
Change the face reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetFaceReference(
    Reference reference
)
Visual Basic (Declaration)
Public Sub SetFaceReference ( _
    reference As Reference _
)
Visual C++
public:
void SetFaceReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.Geometry..::.Reference

Remarks

The referenced element may be any model element, including FamilyInstance or FormElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_SURFACE, and the surface must be of type Plane. The Reference's UVPoint property is ignored.

See Also

PointOnEdgeFaceIntersection Class
Autodesk.Revit.Elements Namespace