Revit 2010 API
RibbonPanel Members
RibbonPanel Class Methods Properties See Also

The RibbonPanel type exposes the following members.

Methods

Name | Description
AddButton | Adds a button to the panel.
AddPulldownButton | Adds a PulldownButton to the panel.
AddPushButton | Adds a PushButton to the panel.
AddSeparator | Adds a new Separator to the panel.
AddStackedButtons | Overloaded.
AddToPulldown | Adds a pushbutton to the existing PulldownButton.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Returns a value whether the panel equals to another panel. (Overrides Object..::.Equals(Object).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the RibbonPanel can respond to user interaction.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Items | Gets the collection of RibbonItems assigned to the RibbonPanel.
Name | Gets or sets the name of the RibbonPanel.
Title | Gets or sets the text of the RibbonPanel.
Visible | Gets or sets a value indicating whether the RibbonPanel is displayed.

See Also

RibbonPanel Class
Autodesk.Revit Namespace