Revit 2010 API
MessageBoxData Members
MessageBoxData Class Constructors Methods Properties See Also

The MessageBoxData type exposes the following members.

Constructors

Name | Description
MessageBoxData | Initializes a new instance of the MessageBoxData class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxData.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DialogType | An integer that describes the standard windows type of the dialog box.
HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxData.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Message | The message that has been displayed in the dialog box.

See Also

MessageBoxData Class
Autodesk.Revit.Events Namespace