Revit 2010 API
Mullion Properties
Mullion Class See Also

The Mullion type exposes the following members.

Properties

Name | Description
AsFamilyInstance | This property is used to get family instance within project.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
LocationCurve | This method get the curve location of the current Mullion.
Lock | Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.
Lockable | Get - to get whether the Mullion can be lock or unlock.
Materials | Get all materials present in the element. (Inherited from Element.)
MullionType | The MullionType style of this Mullion. Get - to access type of mullion Set - change type of mullion. If the mullion is locked, InvalidOperationException exception will be thrown.
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Mullion Class
Autodesk.Revit.Elements Namespace