Revit 2010 API
RebarShape Methods
RebarShape Class See Also

The RebarShape type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllowed | Check whether a bar type can be used with this RebarShape. Bar types are allowed by default.
GetAllRebarShapeParameters | List all shape parameters used by all the existing RebarShapes in the document.
GetCurvesForBrowser | Generate curves for the shape, as used in the shape browser.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
NewDefinitionByArc | Create a shape definition by arc, and associate it with this shape.
NewDefinitionBySegments | Create a shape definition by segments, and associate it with this shape.
SetAllowed | Specify which bar types can be used with this RebarShape. Bar types are allowed by default.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace