Revit 2010 API
DialogBoxShowingEventArgs Members
DialogBoxShowingEventArgs Class Constructors Methods Properties See Also

The DialogBoxShowingEventArgs type exposes the following members.

Constructors

Name | Description
DialogBoxShowingEventArgs | Initializes a new instance of the DialogBoxShowingEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
HelpId | An ID that represents the dialog that has been displayed.

See Also

DialogBoxShowingEventArgs Class
Autodesk.Revit.Events Namespace