Revit 2010 API
Parameter..::.Set Method (String)
Parameter Class Example See Also
Sets the parameter to a new string of text.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Set(
    string value
)
Visual Basic (Declaration)
Public Function Set ( _
    value As String _
) As Boolean
Visual C++
public:
bool Set(
    String^ value
)

Parameters

value
Type: System..::.String
The new text value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as a String.

Examples

CopyC#
void AddInstanceComment(Wall wall)
{
    // Get the comment parameter of the element instance
    Parameter commentPara = wall.get_Parameter(BuiltInParameter.ALL_MODEL_INSTANCE_COMMENTS);
    if (null != commentPara)
    {
        // Add a greeting string to the comment
        commentPara.Set("Hello Everyone.");
    }
}
CopyVB.NET
Private Sub AddInstanceComment(ByVal wall As Wall)
    ' Get the comment parameter of the element instance
    Dim commentPara As Parameter = wall.Parameter(BuiltInParameter.ALL_MODEL_INSTANCE_COMMENTS)
    If commentPara IsNot Nothing Then
        ' Add a greeting string to the comment
        commentPara.[Set]("Hello Everyone.")
    End If
End Sub

See Also

Parameter Class
Set Overload
Autodesk.Revit Namespace