Revit 2010 API
AnalyticalSupportData Members
AnalyticalSupportData Class Constructors Methods Properties See Also

The AnalyticalSupportData type exposes the following members.

Constructors

Name | Description
AnalyticalSupportData | Initializes a new instance of the AnalyticalSupportData class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
InfoArray | Gets support information array for Element.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Supported | Test to see if the Element is supported.

See Also

AnalyticalSupportData Class
Autodesk.Revit.Structural Namespace