Revit 2010 API
Fascia Methods
Fascia Class See Also

The Fascia type exposes the following members.

Methods

Name | Description
AddSegment | Add segments to the fascia. (Overrides HostedSweep..::.AddSegment(Reference).)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

See Also

Fascia Class
Autodesk.Revit.Elements Namespace