Revit 2010 API
ProfiledWallCreationData Constructor (CurveArray, Boolean)
ProfiledWallCreationData Class See Also
Initializes a new instance of the ProfiledWallCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProfiledWallCreationData(
    CurveArray profile,
    bool structural
)
Visual Basic (Declaration)
Public Sub New ( _
    profile As CurveArray, _
    structural As Boolean _
)
Visual C++
public:
ProfiledWallCreationData(
    CurveArray^ profile,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

See Also

ProfiledWallCreationData Class
ProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace