Revit 2010 API
DividedSurface Members
DividedSurface Class Constructors Methods Properties See Also

The DividedSurface type exposes the following members.

Constructors

Name | Description
DividedSurface | Initializes a new instance of the DividedSurface class

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetGridNodeLocation | Specify whether a particular grid node is interior to the surface, on the boundary, or outside the boundary.
GetGridNodeReference | Get a reference to the geometric point associated with a grid node.
GetGridNodeUV | Get the position of a grid node in UV coordinates in the surface.
GetGridSegmentReference | Get a reference to a line segment connecting two adjacent grid nodes.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetTileFamilyInstance | Get a reference to a tile element associated with a given seed node.
GetTileReference | Get a reference to one of the tile surfaces associated with a given seed node.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsSeedNode | Reports whether a grid node is a "seed node," a node that is associated with one or more tiles.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllGridRotation | Angle of rotation applied to the U- and V- directions together.
BorderTile | Determines the handling of tiles that overlap the surface's boundary.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ComponentRotation | The rotation of the pattern by a multiple of 90 degrees.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Host | The element whose surface has been divided.
HostReference | A reference to the divided face on the host.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsComponentFlipped | Whether the pattern is flipped.
IsComponentMirrored | Whether the pattern is mirror-imaged.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
NumberOfUGridlines | Get the number of U-gridlines used on the surface.
NumberOfVGridlines | Get the number of V-gridlines used on the surface.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the U-direction.
USpacingRule | Access to the rule for laying out the first series of equidistant parallel lines on the surface.
VPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the V-direction.
VSpacingRule | Access to the rule for laying out the second series of equidistant parallel lines on the surface.

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace