Revit 2010 API
Document..::.NewLineBoundaryConditions Method (Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)
Document Class Example See Also
Creates a new Line BoundaryConditions element on a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundaryConditions NewLineBoundaryConditions(
    Reference reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)
Visual Basic (Declaration)
Public Function NewLineBoundaryConditions ( _
    reference As Reference, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double, _
    X_Rotation As TranslationRotationValue, _
    X_RotationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewLineBoundaryConditions(
    Reference^ reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)

Parameters

reference
Type: Autodesk.Revit.Geometry..::.Reference
The Geometry reference to a Beam's, Wall's, Wall Foundation's, Slab's or Slab Foundation's analytical line.
X_Translation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".
X_Rotation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the option for rotation about the X axis.
X_RotationSpringModulus
Type: System..::.Double
Rotation Spring Modulus for X axis. Ignored if X_Rotation is not "Spring"

Return Value

If successful, NewLineBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 1 - "Line". Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
bool CreateLineConditionWithReference(FamilyInstance column, Autodesk.Revit.Creation.Document docCreation)
{
    if (Autodesk.Revit.Structural.Enums.StructuralType.Column != column.StructuralType)
    {
        throw new Exception("This sample only work for columns.");
    }

    // Get the line reference for the column analytical model
    Reference lineReference = null;
    AnalyticalModelFrame analytical = column.AnalyticalModel as AnalyticalModelFrame;
    lineReference = analytical.Curve.Reference;
    if (null == lineReference)
    {
        throw new Exception("Unable to get reference line for selected column.");
    }

    // Create line Boundary Conditions for the column
    BoundaryConditions condition = docCreation.NewLineBoundaryConditions(lineReference, TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0);
    return (null != condition);
}
CopyVB.NET
Private Function CreateLineConditionWithReference(ByVal column As Autodesk.Revit.Elements.FamilyInstance, ByVal docCreation As Autodesk.Revit.Creation.Document) As Boolean
    If Autodesk.Revit.Structural.Enums.StructuralType.Column <> column.StructuralType Then
        Throw New Exception("This sample only work for columns.")
    End If

    ' Get the line reference for the column analytical model
    Dim lineReference As Reference = Nothing
    Dim analytical As AnalyticalModelFrame = TryCast(column.AnalyticalModel, AnalyticalModelFrame)
    lineReference = analytical.Curve.Reference
    If lineReference Is Nothing Then
        Throw New Exception("Unable to get reference line for selected column.")
    End If

    ' Create line Boundary Conditions for the column
    Dim condition As Autodesk.Revit.Elements.BoundaryConditions = docCreation.NewLineBoundaryConditions(lineReference, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
    0, TranslationRotationValue.Fixed, 0)
    Return (condition IsNot Nothing)
End Function

See Also

Document Class
NewLineBoundaryConditions Overload
Autodesk.Revit.Creation Namespace