Revit 2010 API
TemperatureRatingType Methods
TemperatureRatingType Class See Also

The TemperatureRatingType type exposes the following members.

Methods

Name | Description
AddCorrectionFactor | Add a new electrical correction factor type to this temperature rating type.
AddInsulationType | Add a new kind of insulation type into this temperature rating type.
AddWireSize | Add a new kind of wire size type into this temperature rating type.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveCorrectionFactor | Remove an existing correction factor from this temperature rating type in Revit MEP project.
RemoveInsulationType | Remove an existing insulation type from this temperature rating type.
RemoveWireSize | Remove an existing wire size type from this temperature rating type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace