Revit 2010 API
Asset Members
Asset Class Constructors Methods Properties See Also

The Asset type exposes the following members.

Constructors

Name | Description
Asset | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssetType | Get the object's AssetPropertyType
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Overloaded. Gets a property by an identifier.
LibraryName | Get the library name
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Size | Gets the number of the AssetProperty(s) in the object. (Inherited from AssetProperties.)
Title | Get the asset's title
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)

See Also

Asset Class
Autodesk.Revit.Utility Namespace