Revit 2010 API
MaterialConcrete..::.ThermalExpansionCoefficientY Property
MaterialConcrete Class See Also
Get or set the y component of the thermal expansion coefficient of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientY { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientY As Double
Visual C++
public:
property double ThermalExpansionCoefficientY {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the y component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace