Revit 2010 API
TemperatureRatingType Members
TemperatureRatingType Class Constructors Methods Properties See Also

The TemperatureRatingType type exposes the following members.

Constructors

Name | Description
TemperatureRatingType | Initializes a new instance of the TemperatureRatingType class

Methods

Name | Description
AddCorrectionFactor | Add a new electrical correction factor type to this temperature rating type.
AddInsulationType | Add a new kind of insulation type into this temperature rating type.
AddWireSize | Add a new kind of wire size type into this temperature rating type.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveCorrectionFactor | Remove an existing correction factor from this temperature rating type in Revit MEP project.
RemoveInsulationType | Remove an existing insulation type from this temperature rating type.
RemoveWireSize | Remove an existing wire size type from this temperature rating type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CorrectionFactors | Get all correction factors defined in this temperature rating type and its corresponding material type.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
InsulationTypes | Get all insulation types defined in this temperature rating type and its corresponding material type.
IsInUse | Indicate whether the temperature rating type is in use.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaterialType | Get the material type information which this temperature rating type belongs to.
Name | Get name of temperature rating type. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
WireSizes | Get all electrical wire sizes defined in this temperature rating type and its corresponding material type.

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace