Revit 2010 API
AnnotationSymbol Methods
AnnotationSymbol Class See Also

The AnnotationSymbol type exposes the following members.

Methods

Name | Description
addLeader | add a leader to this annotation symbol.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
duplicate | Duplicate this annotation symbol.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
removeLeader | remove a leader of this annotation symbol.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnnotationSymbol Class
Autodesk.Revit.Elements Namespace