Revit 2010 API
Application Methods
Application Class See Also

The Application type exposes the following members.

Methods

Name | Description
CreateRibbonPanel | Create a new RibbonPanel.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractPartAtomFromFamilyFile | Writes a PartAtom XML from the contents of a family file.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRibbonPanels | Get all the custom Panels on Add-Ins tab of Revit.
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewFamilyDocument | New family document, including family, titleblock, and annotation symbol
NewProjectDocument | New project document
NewProjectTemplateDocument | New project template document
OpenDocumentFile | Overloaded. Opens a document from disk.
OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Application Class
Autodesk.Revit Namespace