Revit 2010 API
CurtainGrid..::.AddGridLine Method
CurtainGrid Class See Also
Add a grid line to the curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainGridLine AddGridLine(
    bool isUGridLine,
    XYZ position,
    bool oneSegmentOnly
)
Visual Basic (Declaration)
Public Function AddGridLine ( _
    isUGridLine As Boolean, _
    position As XYZ, _
    oneSegmentOnly As Boolean _
) As CurtainGridLine
Visual C++
public:
CurtainGridLine^ AddGridLine(
    bool isUGridLine,
    XYZ^ position,
    bool oneSegmentOnly
)

Parameters

isUGridLine
Type: System..::.Boolean
If true, a U-direction grid line will be added. Otherwise, a V-direction grid line will be added.
position
Type: Autodesk.Revit.Geometry..::.XYZ
The position of the grid line.
oneSegmentOnly
Type: System..::.Boolean
If it is true, only one segment is added. Otherwise, all segments will be added for the grid line.

Return Value

The created grid line is returned if the operation is successful. Otherwise, null is returned.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if the position for the grid line is out of range.

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace