Revit 2010 API
FamilyInstance Members
FamilyInstance Class Constructors Methods Properties See Also

The FamilyInstance type exposes the following members.

Constructors

Name | Description
FamilyInstance | For Internal Use Only.

Methods

Name | Description
AddCoping | Adds a coping (cut) to a steel beam.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
FlipFromToRoom | Change the room to which the door or window is opened.
flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
GetCopings | Lists the elements currently used as coping cutters for this element.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveCoping | Removes a coping (cut) from a steel beam.
rotate | The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true.
SetCopings | Specify the set of coping cutters on this element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AnalyticalModel | Retrieves the structural analytical model for the family instance.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped.
CanFlipHand | Property to test whether the orientation of family instance hand can be flipped.
CanRotate | Property to test whether the family instance can be rotated by 180 degree.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation.
FacingFlipped | Property to test whether the orientation of family instance facing is flipped.
FacingOrientation | Property to get the orientation of family instance facing.
FromRoom | Overloaded. The room from which the door or window is opened.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HandFlipped | Property to test whether the orientation of family instance hand is flipped.
HandOrientation | Property to get the orientation of family instance hand.
Host | If the instance is contained within another element, this property returns the containing element.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsSlantedColumn | Indicates if the family instance is a slanted column.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an instance within project. (Overrides Element..::.Location.)
Material | This property returns the physical material from which the instance is made.
Materials | Get all materials present in the element. (Inherited from Element.)
MEPModel | Retrieves the MEP model for the family instance.
Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Room | Overloaded. The room in which the instance is located.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Space | Overloaded. The space in which the instance is located.
StructuralType | Provides the primary structural type of the instance, such as beam or column etc.
StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc.
SubComponents | Property to get the sub componets of current family instance.
SuperComponent | Property to get the super componet of current family instance.
Symbol | Returns or changes the FamilySymbol object that represents the type of the instance.
ToRoom | Overloaded. The room to which the door or window is opened.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace