Revit 2010 API
ViewSheetSetting Members
ViewSheetSetting Class Constructors Methods Properties See Also

The ViewSheetSetting type exposes the following members.

Constructors

Name | Description
ViewSheetSetting | For Internal Use Only.

Methods

Name | Description
Delete | Delete the current view sheet set, and make the In-Session set as the current one.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Rename | Rename the current view sheet set.
Revert | Revert the current view sheet set.
Save | Save the changes for the current view sheet set.
SaveAs | Save the current view sheet set to another view sheet set with the specified name.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AvailableViews | All views that can be printed.
CurrentViewSheetSet | The current view sheet set of PrintSetup.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace