Revit 2010 API
Document..::.Mirror Method (ElementSet, Reference)
Document Class See Also
Mirrors several elements about a reference.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Mirror(
    ElementSet elements,
    Reference reference
)
Visual Basic (Declaration)
Public Function Mirror ( _
    elements As ElementSet, _
    reference As Reference _
) As Boolean
Visual C++
public:
bool Mirror(
    ElementSet^ elements,
    Reference^ reference
)

Parameters

elements
Type: Autodesk.Revit..::.ElementSet
A set of elements that are to be mirrored.
reference
Type: Autodesk.Revit.Geometry..::.Reference
The reference by which the elements will mirror.

Return Value

If the elements are mirrored successfully then the method returns true.

See Also

Document Class
Mirror Overload
Autodesk.Revit Namespace