Revit 2010 API
LightingDevice Members
LightingDevice Class Constructors Methods Properties See Also

The LightingDevice type exposes the following members.

Constructors

Name | Description
LightingDevice | For Internal Use Only

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LightingDevice Class
Autodesk.Revit.MEP Namespace