Revit 2010 API
CurveArrayIterator..::.Reset Method
CurveArrayIterator Class See Also
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurveArrayIterator Class
Autodesk.Revit.Geometry Namespace