Revit 2010 API
View..::.Print Method (Boolean)
View Class See Also
Print this view with default print settings and view template.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Print(
    bool useCurrentPrintSettings
)
Visual Basic (Declaration)
Public Sub Print ( _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print(
    bool useCurrentPrintSettings
)

Parameters

useCurrentPrintSettings
Type: System..::.Boolean
If true, print the view with the current print settings; otherwise with the print settings of the document.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the view cannot be printed.

See Also

View Class
Print Overload
Autodesk.Revit.Elements Namespace