Revit 2010 API
Connector..::.ConnectTo Method
Connector Class See Also
Make connection between two connectors.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ConnectTo(
    Connector connector
)
Visual Basic (Declaration)
Public Sub ConnectTo ( _
    connector As Connector _
)
Visual C++
public:
void ConnectTo(
    Connector^ connector
)

Parameters

connector
Type: Autodesk.Revit.MEP..::.Connector
Indicate the connector will be connected to.

Remarks

Connection success may create a new Fitting between two connectors, if necessary.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when argument is null.
System..::.ArgumentException | Argument is invalid.
System..::.InvalidOperationException | Thrown when two connectors with different domain types. Thrown when these two connectors fail to connect each other. Thrown when connection already exists.

See Also

Connector Class
Autodesk.Revit.MEP Namespace