Revit 2010 API
PrintManager Properties
PrintManager Class See Also

The PrintManager type exposes the following members.

Properties

Name | Description
Collate | Indicates whether to collate of the current print.
CombinedFile | Indicates whether to combine multiple selected views/sheets into a single file.
CopyNumber | The copy number.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsVirtual | The virtual type in Autodesk Revit.
PaperSizes | Get all print sizes of current printer.
PaperSources | Get all print sources of current printer.
PrinterName | The name of the current printer.
PrintOrderReverse | Indicates whether to reverse the print order of the current print.
PrintRange | The print range.
PrintSetup | The PrintSetup which manages the print settings of current doucment.
PrintToFile | Indicates whether to print to file.
PrintToFileName | The file name when printing to file.
ViewSheetSetting | The ViewSheetSetting which manages the view/sheet set information of current document, and you can change the default view/sheet set for current project.

See Also

PrintManager Class
Autodesk.Revit Namespace