Revit 2010 API
FamilyItemFactory..::.NewSweptBlend Method (Boolean, Reference, SweepProfile, SweepProfile)
FamilyItemFactory Class See Also
Adds a new swept blend into the family document, using a selected reference as the path.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SweptBlend NewSweptBlend(
    bool isSolid,
    Reference path,
    SweepProfile bottomProfile,
    SweepProfile topProfile
)
Visual Basic (Declaration)
Public Function NewSweptBlend ( _
    isSolid As Boolean, _
    path As Reference, _
    bottomProfile As SweepProfile, _
    topProfile As SweepProfile _
) As SweptBlend
Visual C++
public:
SweptBlend^ NewSweptBlend(
    bool isSolid,
    Reference^ path,
    SweepProfile^ bottomProfile,
    SweepProfile^ topProfile
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the swept blend is Solid or Void.
path
Type: Autodesk.Revit.Geometry..::.Reference
The path of the swept blend. The path might be a reference of single curve or edge obtained from existing geometry. Or the path can be a single sketched curve, and the curve is not required to reference existing geometry.
bottomProfile
Type: Autodesk.Revit..::.SweepProfile
The bottom profile of the newly created Swept blend. It should consist of only one curve loop. the input profile must be in one plane.
topProfile
Type: Autodesk.Revit..::.SweepProfile
The top profile of the newly created Swept blend. It should consist of only one curve loop. the input profile must be in one plane.

Return Value

If creation was successful the new Swept blend is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a swept blend in a family document. The swept blend will trace from bottom profile to the top along the path. Revit will determine an appropriate default mapping for the vertices of the two profiles. If the input profile is to be a cyclic profile (curve or ellipse) it must be split into at least two segments, so that Revit can find vertices to use for mapping the swept blend.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input arguments-path/bottomProfile/topProfile-are null.
System..::.ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile is null.
System..::.ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile contains nothing or more than one curve loops.
System..::.ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a family symbol based profile and the family symbol profile is null.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewSweptBlend Overload
Autodesk.Revit.Creation Namespace