Revit 2010 API
MaterialSteel Class
Members Example See Also
Represents a steel material element in an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MaterialSteel : Material
Visual Basic (Declaration)
Public Class MaterialSteel _
    Inherits Material
Visual C++
public ref class MaterialSteel : public Material

Remarks

MaterialSteel is a child class of Material.

Examples

CopyC#
private void MaterialSteelInformation(MaterialSteel mySteel)
{
    StringBuilder message = new StringBuilder("Material Steel : " + mySteel.Name);

    //behaviour of the material
    Autodesk.Revit.Enums.MaterialBehaviourType behaviour = mySteel.Behavior;
    message.Append("Behavior: " + behaviour);
    double dampingRatio = mySteel.DampingRatio;
    message.Append("Damping Ratio: " + dampingRatio);
    double minimumTensileStrength = mySteel.MinimumTensileStrength;
    message.Append("Minimum tensile strength: " + minimumTensileStrength);
    double minimumYieldStress = mySteel.MinimumYieldStress;
    message.Append("Minimum yield stress: " + minimumYieldStress);

    double poissonModulusX = mySteel.PoissonModulusX;
    message.Append("Poisson Ratio X: " + poissonModulusX);
    double poissonModulusY = mySteel.PoissonModulusY;
    message.Append("Poisson Ratio Y: " + poissonModulusY);
    double poissonModulusZ = mySteel.PoissonModulusZ;
    message.Append("Poisson Ratio Z: " + poissonModulusZ);

    double reductionFactor = mySteel.ReductionFactor;

    double shearModulusX = mySteel.ShearModulusX;
    message.Append("Shear modulus X: " + shearModulusX);
    double shearModulusY = mySteel.ShearModulusY;
    message.Append("Shear modulus Y: " + shearModulusY);
    double shearModulusZ = mySteel.ShearModulusZ;
    message.Append("Shear modulus Z: " + shearModulusZ);

    double thermalExpansionCoefficientX = mySteel.ThermalExpansionCoefficientX;
    message.Append("Thermal Expansion coefficient X: " + thermalExpansionCoefficientX);
    double thermalExpansionCoefficientY = mySteel.ThermalExpansionCoefficientY;
    message.Append("Thermal Expansion coefficient Y: " + thermalExpansionCoefficientY);
    double thermalExpansionCoefficientZ = mySteel.ThermalExpansionCoefficientZ;
    message.Append("Thermal Expansion coefficient Z: " + thermalExpansionCoefficientZ);

    double unitWeight = mySteel.UnitWeight;
    message.Append("Unit Weight: " + unitWeight);

    double youngModulusX = mySteel.YoungModulusX;
    message.Append("Young modulus X: " + youngModulusX);
    double youngModulusY = mySteel.YoungModulusY;
    message.Append("Young modulus Y: " + youngModulusY);
    double youngModulusZ = mySteel.YoungModulusZ;
    message.Append("Young modulus Z: " + youngModulusZ);

    MessageBox.Show(message.ToString(), "Revit");
}
CopyVB.NET
Private Sub MaterialSteelInformation(ByVal mySteel As MaterialSteel)
    Dim message As New StringBuilder("Material Steel : " & mySteel.Name)

    'behaviour of the material
    Dim behaviour As Autodesk.Revit.Enums.MaterialBehaviourType = mySteel.Behavior
    message.Append("Behavior: " & behaviour)
    Dim dampingRatio As Double = mySteel.DampingRatio
    message.Append("Damping Ratio: " & dampingRatio)
    Dim minimumTensileStrength As Double = mySteel.MinimumTensileStrength
    message.Append("Minimum tensile strength: " & minimumTensileStrength)
    Dim minimumYieldStress As Double = mySteel.MinimumYieldStress
    message.Append("Minimum yield stress: " & minimumYieldStress)

    Dim poissonModulusX As Double = mySteel.PoissonModulusX
    message.Append("Poisson Ratio X: " & poissonModulusX)
    Dim poissonModulusY As Double = mySteel.PoissonModulusY
    message.Append("Poisson Ratio Y: " & poissonModulusY)
    Dim poissonModulusZ As Double = mySteel.PoissonModulusZ
    message.Append("Poisson Ratio Z: " & poissonModulusZ)

    Dim reductionFactor As Double = mySteel.ReductionFactor

    Dim shearModulusX As Double = mySteel.ShearModulusX
    message.Append("Shear modulus X: " & shearModulusX)
    Dim shearModulusY As Double = mySteel.ShearModulusY
    message.Append("Shear modulus Y: " & shearModulusY)
    Dim shearModulusZ As Double = mySteel.ShearModulusZ
    message.Append("Shear modulus Z: " & shearModulusZ)

    Dim thermalExpansionCoefficientX As Double = mySteel.ThermalExpansionCoefficientX
    message.Append("Thermal Expansion coefficient X: " & thermalExpansionCoefficientX)
    Dim thermalExpansionCoefficientY As Double = mySteel.ThermalExpansionCoefficientY
    message.Append("Thermal Expansion coefficient Y: " & thermalExpansionCoefficientY)
    Dim thermalExpansionCoefficientZ As Double = mySteel.ThermalExpansionCoefficientZ
    message.Append("Thermal Expansion coefficient Z: " & thermalExpansionCoefficientZ)

    Dim unitWeight As Double = mySteel.UnitWeight
    message.Append("Unit Weight: " & unitWeight)

    Dim youngModulusX As Double = mySteel.YoungModulusX
    message.Append("Young modulus X: " & youngModulusX)
    Dim youngModulusY As Double = mySteel.YoungModulusY
    message.Append("Young modulus Y: " & youngModulusY)
    Dim youngModulusZ As Double = mySteel.YoungModulusZ
    message.Append("Young modulus Z: " & youngModulusZ)

    MessageBox.Show(message.ToString(), "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Material
Autodesk.Revit.Elements..::.MaterialSteel

See Also

MaterialSteel Members
Autodesk.Revit.Elements Namespace