Revit 2010 API
PipeConnector..::.Shape Property
PipeConnector Class See Also
The shape of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ConnectorProfileType Shape { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Shape As ConnectorProfileType
Visual C++
public:
virtual property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}

Implements

IConnector..::.Shape

Remarks

A pipe connector's shape is always round.

See Also

PipeConnector Class
Autodesk.Revit.MEP Namespace