Revit 2010 API
Ellipse Properties
Ellipse Class See Also

The Ellipse type exposes the following members.

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Center | Returns the center of the ellipse.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve. (Inherited from Curve.)
Normal | Returns the normal to the plane in which the ellipse is defined.
Period | The period of this curve. (Inherited from Curve.)
RadiusX | Returns the X vector radius of the ellipse.
RadiusY | Returns the Y vector radius of the ellipse.
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Ellipse Class
Autodesk.Revit.Geometry Namespace