Revit 2010 API
LayoutRuleFixedNumber Class
Members Example See Also
This class indicate the layout rule of a Beam System is Fixed-Number.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LayoutRuleFixedNumber : LayoutRule
Visual Basic (Declaration)
Public Class LayoutRuleFixedNumber _
    Inherits LayoutRule
Visual C++
public ref class LayoutRuleFixedNumber : public LayoutRule

Remarks

To use this type of LayoutRule, only the number of the beams must be set.

Examples

CopyC#
private bool LayoutRuleFixedNumberInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.Elements.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class
    LayoutRuleFixedNumber myLayoutRuleFixedNumber =
                        new LayoutRuleFixedNumber(8);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedNumber;

    LayoutRuleFixedNumber fixedNumber = beamSystem.LayoutRule as LayoutRuleFixedNumber;

    if (null == fixedNumber)
    {
        return false;
    }
    //try to get the property value of the beamsystem LayoutRule
    int numberOfLines = fixedNumber.NumberOfLines;

    message += "\nNew BeamSystem layout rule: " + fixedNumber;
    message += "\nNew BeamSystem number of beams: " + numberOfLines;

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);

    return true;
}
CopyVB.NET
Private Function LayoutRuleFixedNumberInformation(ByVal beamSystem As BeamSystem) As Boolean
    'get the layoutRule of the beamsystem
    Dim layoutRule As Autodesk.Revit.Elements.LayoutRule = beamSystem.LayoutRule

    Dim message As String = "BeamSystem layout rule : " & layoutRule.ToString

    'create a new instance of the LayoutRuleClearSpacing class
    Dim myLayoutRuleFixedNumber As New LayoutRuleFixedNumber(8)

    'set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedNumber

    Dim fixedNumber As LayoutRuleFixedNumber = TryCast(beamSystem.LayoutRule, LayoutRuleFixedNumber)

    If fixedNumber Is Nothing Then
        Return False
    End If
    'try to get the property value of the beamsystem LayoutRule
    Dim numberOfLines As Integer = fixedNumber.NumberOfLines

    message += vbLf & "New BeamSystem layout rule: " & fixedNumber.ToString
    message += vbLf & "New BeamSystem number of beams: " & numberOfLines

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)

    Return True
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.LayoutRule
Autodesk.Revit.Elements..::.LayoutRuleFixedNumber

See Also

LayoutRuleFixedNumber Members
Autodesk.Revit.Elements Namespace