Revit 2010 API
SpacingRule Members
SpacingRule Class Constructors Methods Properties See Also

The SpacingRule type exposes the following members.

Constructors

Name | Description
SpacingRule | Initializes a new instance of the SpacingRule class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetLayoutFixedDistance | Set the Layout property to FixedDistance.
SetLayoutFixedNumber | Set the Layout property to FixedNumber.
SetLayoutMaximumSpacing | Set the Layout property to MaximumSpacing.
SetLayoutMinimumSpacing | Set the Layout property to MinimumSpacing.
SetLayoutNone | Set the Layout property to None.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BeltMeasurement | On a curved surface, BeltMeasurement specifies where the grid's distances are measured.
Distance | The exact distance between layout lines.
GridlinesRotation | An additional rotation to be applied to this set of grid lines.
HasBeltMeasurement | True if the gridlines are not parallel due to surface curvature, and the BeltMeasurement property therefore applies.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Justification | The justification of the lines within the region.
Layout | A choice of several gridline layout rules.
Number | The exact number of lines in the region.
Offset | An additional offset applied to the first gridline.

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace