Revit 2010 API
AssetPropertyEnum Members
AssetPropertyEnum Class Constructors Methods Properties See Also

The AssetPropertyEnum type exposes the following members.

Constructors

Name | Description
AssetPropertyEnum | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyEnum Class
Autodesk.Revit.Utility Namespace