Revit 2010 API
Instance Members
Instance Class Constructors Methods Properties See Also

The Instance type exposes the following members.

Constructors

Name | Description
Instance | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInstanceGeometry | Overloaded.
GetSymbolGeometry | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Symbol | The symbol element that this object is referring to.
SymbolGeometry | The geometric representation of the symbol which generates this instance.
Transform | The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Instance Class
Autodesk.Revit.Geometry Namespace