Revit 2010 API
Application..::.NewFamilyInstanceCreationData Method (Face, Line, FamilySymbol)
Application Class See Also
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Face face,
    Line position,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    face As Face, _
    position As Line, _
    symbol As FamilySymbol _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    Face^ face,
    Line^ position,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.Geometry..::.Face
A face of a geometry object.
position
Type: Autodesk.Revit.Geometry..::.Line
A line on the face defining where the symbol is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace