Revit 2010 API
HermiteSpline Members
HermiteSpline Class Constructors Methods Properties See Also

The HermiteSpline type exposes the following members.

Constructors

Name | Description
HermiteSpline | For Internal Use Only.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
ControlPoints | The control points of the Hermite spline.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
IsPeriodic | Returns whether the Hermite spline is periodic or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve. (Inherited from Curve.)
Parameters | Returns the params of the Hermite spline.
Period | The period of this curve. (Inherited from Curve.)
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Tangents | Returns the tangents of the Hermite spline.
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

HermiteSpline Class
Autodesk.Revit.Geometry Namespace