Revit 2010 API
Application Members
Application Class Constructors Methods Properties See Also

The Application type exposes the following members.

Constructors

Name | Description
Application | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
LibraryPaths | Retrieves path information for where content is stored on disk.
SharedParametersFilename | Contains the fully qualified path to a shared parameters file.

See Also

Application Class
Autodesk.Revit.Options Namespace