Revit 2010 API
RebarShape Members
RebarShape Class Constructors Methods Properties See Also

The RebarShape type exposes the following members.

Constructors

Name | Description
RebarShape | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllowed | Check whether a bar type can be used with this RebarShape. Bar types are allowed by default.
GetAllRebarShapeParameters | List all shape parameters used by all the existing RebarShapes in the document.
GetCurvesForBrowser | Generate curves for the shape, as used in the shape browser.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
NewDefinitionByArc | Create a shape definition by arc, and associate it with this shape.
NewDefinitionBySegments | Create a shape definition by segments, and associate it with this shape.
SetAllowed | Specify which bar types can be used with this RebarShape. Bar types are allowed by default.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Definition | Get the shape definition object associated with this shape.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HookAngle | Get and set the hook angle.
HookOrientation | Get and set the hook orientation.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RebarStyle | Access the rebar style.
SameShapeIgnoringHooks | Test whether two shapes have equivalent definitions.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SimpleArc | Check whether this shape consists of a single arc, possibly with hooks.
SimpleLine | Check whether this shape consists of a single straight segment, possibly with hooks.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace