Revit 2010 API
HermiteFace Members
HermiteFace Class Constructors Methods Properties See Also

The HermiteFace type exposes the following members.

Constructors

Name | Description
HermiteFace | For Internal Use Only.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
MixedDerivs | Mixed derivatives of the surface.
Params | Parameters of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Points | Interpolation points of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Tangents | Tangents of the surface.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

HermiteFace Class
Autodesk.Revit.Geometry Namespace