Revit 2010 API
View Members
View Class Constructors Methods Properties See Also

The View type exposes the following members.

Constructors

Name | Description
View | For Internal Use Only.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
getVisibility | Checks if elements of the given category are set to be visible in this view.
Hide | Sets the elements to be hidden in the view.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view.
CropBoxActive | Whether or not the the Crop Box/Region is active for the view.
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view.
CutColorOverrideByElement | Override the cut lines' color by Element in this view.
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view.
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Set of all elements that will be drawn in the view.
GenLevel | The level for the view.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen.
Outline | The bounds of the view in paper space (in inches).
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view.
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view.
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view.
RightDirection | The direction towards the right side of the screen.
Scale | The scale of the view.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen.
ViewDirection | The direction towards the viewer.
ViewName | The name of the view.
ViewType | The type of the view.

See Also

View Class
Autodesk.Revit.Elements Namespace