Major enhancements and modifications affecting the Revit API

New Revit user interface

Autodesk Revit 2010 offers a new user-interface system based on Ribbons. The API has been modified to support customization of the Ribbon user-interface in a similar manner to what was supported in previous releases for toolbars and menus.

External commands registered directly to Revit via the Revit.ini file are now located on the “Add-ins” tab under the “External commands” pulldown. No code changes are required to move the buttons to this location. The Add-ins tab will be automatically displayed if any external command is registered with Revit.

External applications can register and lay out panels on the Add-ins tab of the Ribbon. Custom panels may be given an application-specified name, and may contain:

  • Pushbuttons – a single button with label and icon, which invokes a command when pressed
  • Pulldown buttons – a button with label and icon which opens a menu with different choices when pressed.
  • Separators – a vertical line separating panel components

Pushbuttons and Pulldown buttons may be created as large size, or stacked in sets of 2 or 3.

The API for creating Ribbon Panels is completely different from the Toolbar and Menubar API. External applications which added content to the toolbars and menus will need to be modified to create Ribbon panel(s) instead.

Family Creation API

The Family Creation API provides programmatic access for creation and modification of the contents of Revit Family documents. Geometric data, Family Types, and other information that can be specified through the Revit Family Editor can now be specified via the API. As a result of this project, API external commands are now displayed while editing a family document in the Family Editor. API access to in-place family editing is still restricted. The project introduces the class Autodesk.Revit.FamilyManager, which allows access to family types and parameters. Using this class you can add and remove types, add and remove family and shared parameters, set the value for parameters in different family types, and define formulas to drive parameter values.

The Category and Categories classes have been enhanced and a new GraphicsStyle class has been created to provide control of the appearance of Revit families.

The new class FamilyItemFactory provides the ability to create elements in families. Access this class through the Document.FamilyCreate property. It includes the following methods:

· NewBlend

· NewDimension

· NewDuctConnector (in Revit MEP only)

· NewElectricalConnector (in Revit MEP only)

· NewExtrusion

· NewFamilyInstance

· NewModelText

· NewPipeConnector (in Revit MEP only)

· NewRevolution

· NewSketchPlane

· NewSweep

· NewSweptBlend

· NewSymbolicCurve

· NewTextNote

The new class ItemFactoryBase provides the ability to create elements both in project and family documents and includes the NewAlignment method.

New document methods - Document.LoadFamily and Document.EditFamily - are introduced to bring families from the Family Editor to the Project environment and vice versa. These methods can be used to examine the contents of the family in terms of its elements, parameters and types; as a result, the properties of Family which access the contents have been removed (Family.SolidForms, Family.VoidForms, Family.Components, Family.LoadedSymbols, Family.Others).

New Events

The Revit API offers totally revamped events which allow an application to subscribe to events taking place in the Revit user interface or in API workflows. In all of the new events, events now occur before and after various triggering actions (known as "pre" and "post" events). Many of the new pre-events are cancellable, offering the API application the ability to prevent the event from taking place based on criteria it cares about. (It is the responsibility of the event subscriber to inform the user of the reason for the cancellation).

Events that existed before release 2010 have been marked Obsolete. You should use the new events added in this release to cover situations like:

  1. Document creation
  2. Document opening
  3. Document saving
  4. Document saving as (new filename)
  5. Document closing
  6. Dialog box showing

The dialog box showing event has been restructured to support notification by Revit when task dialogs are shown.

The new events added in Revit 2010 are:

a. File export

b. File import

c. View printing

d. Document printing

e. View activating

f. Document synchronize with central

API for new Massing functionality

Revit 2010 introduces new conceptual design functionality for creation of complex geometry. Intuitive and flexible form-making is supported by the addition of new objects: points and spline curves that pass through these points. The resulting surfaces can be divided, patterned, and panelized to create buildable forms with persistent parametric relationships.

The following classes provide the API user with access to this functionality:

· CurveByPoints

· CurveByPointsArray

· DividedSurface

· DividedSurfaceData

· Form

· ReferencePoint

· ReferencePointArray

· TilePatterns

· TilePattern

Other methods and properties added to support this functionality are:

· ModelCurve.ChangeToReferenceLine()

· FamilyCreate.NewLevel(double)

· Family.IsCurtainPanelFamily

· Family.CurtainPanelHorizontalSpacing

· Family.CurtainPanelVerticalSpacing

· Family.CurtainPanelTilePattern

· SketchPlane.PlaneReference

· Level.PlaneReference

The following classes cannot be used in 2010 Mass families. Instead, equivalent geometry can be created with the Form class.

· Blend

· Extrusion

· Revolution

· Sweep

· SweptBlend

MEP API for ducts and pipes

This project provides read/write access to HVAC and Piping data in a Revit model including:

a. Traversing ducts, pipes, fittings, and connectors in a system

b. Adding, removing, and changing ducts, pipes, and other equipment

c. Getting and setting system properties

d. Determining if the system is well-connected

The following classes have new methods and properties related to duct and pipes:

· Autodesk.Revit.MEP.Connector

· Autodesk.Revit.Elements.MechanicalSystem

· Autodesk.Revit.Elements.PipingSystem

Elements related to duct and pipe systems can be created using new methods on Autodesk.Revit.Creation.Document:

· NewCrossFitting

· NewDuct

· NewElbowFitting

· NewFlexDuct

· NewFlexPipe

· NewMechanicalSystem

· NewPipe

· NewPipingSystem

· NewTakeoffFitting

· NewTeeFitting

· NewTransitionFitting

· NewUnionFitting

All MEP-related classes have been moved into the MEP namespace from namespaces such as Elements and Symbols.

Upgrade to .NET Framework version 3.5

Revit now uses Microsoft .NET Framework version 3.5. Applications compiled using .NET 2.0 should continue to work unless they are affected by other changes in the Revit 2010 API.

Small enhancements & API interface changes

Parameters

The new property Autodesk.Revit.Parameters.InternalDefinition.BuiltInParameter provides access to the enumerated type for the parameter, if it is a built-in parameter. The property makes it easier to locate a built-in parameter value based on the name of the parameter shown in the Revit UI.

Rooms and Spaces

The new method Autodesk.Revit.Elements.Room.IsPointInRoom()determines if a 3D point is in the volume of a room.

The new method Autodesk.Revit.Elements.Space.IsPointInSpace()determines if a 3D point is in the volume of a space.

The new methods Autodesk.Revit.Document. GetRoomAtPoint() and GetSpaceAtPoint() find the Room or Space that encloses a given 3D point within the project.

The new property Autodesk.Revit.Elements.FamilyInstance.Space allows an API application to determine what in which Space an air terminal or other family instance exists in Revit MEP.

Grids

The new method Autodesk.Revit.Elements.Grid.ExtendToAllLevels() method allows grids to intersect all levels of a project.

The method Autodesk.Revit.Creation.Document.NewGrid will throw an exception if given an unbounded line.

Batch creation methods (NewWalls, NewGrids, etc.)

If one of the elements which is supposed to be created can't be created the entire the operation will be properly rolled back.

Rebar

NewRebar:StartHookOrientation and EndHookOrientation arguments were changed to an enum. Rebar.SetLayoutRuleWithoutExaminingHost value type was changed to an enum.

Structural framing

Beams created with an offset from their level now have their analytical model aligned with the physical geometry of the beam.

Curved beams can be created in the vertical plane.

Categories

Internal categories that are not directly exposed through the Revit UI can be accessed via the API. This makes it possible to add shared parameters to Materials using Revit API.

The new Category.AllowsBoundParameters property indicates if a category can have shared or project parameter. When category.AllowsBoundParameters is false, it may not be bound to shared parameters using the BindingMap.

Category. AllowsVisibilityControl(view) indicates if the visibility of a category can be controlled in a given view.

Sketch

Autodesk.Revit.Elements.Sketch.CurveLoop now returns CurveArrayArray instead of CurveArray. If the sketch contains multiple loops, the output will be segregated into separate CurveArrays within the output.

Revit session properties

The new Autodesk.Revit.Application.Language property identifies the language used in the current session of Revit.

The new Autodesk.Revit.Application.Product property identifies the the Revit vertical application (Building, Structure, MEP) via an enumerated type.

External Commands and Applications

Revit now offers improved diagnostics when Revit is unable to run an external application or command listed in the Revit.ini file. A popup message will explain the problem. If the problem is related to an exception caught from the application, the popup will include the exception stack trace.

Revit no longer silently renumbers the Revit.ini file entries when they fail to load or start. An option in the popup message will allow a user to permanently disable a failed API application.

HostedSweep

In the Autodesk.Revit.Elements.HostedSweep class the new abstract method AddSegment() allows applications to write generic code that operates upon all hosted sweep types (gutter, fascia, or slab edge).

VolumeCalculationOptions

The Autodesk.Revit.VolumeCalculationOptions.VolumeComputationEnbale field was removed. Use the property VolumeComputationEnable instead.

Curtain Systems

Autodesk.Revit.Elements.CurtainGridLine new property ExistingSegmentCurves allows access to the existing segments in the grid line (excluding those which have been removed).

Autodesk.Revit.Elements.Mullion now provides access to its locaction via the LocationCurve property.

Output Arguments from API methods

Output arguments are now marked with the [Out] attribute. Methods changed include:

· Application.GetAllTopMenus

· ControlledApplication.GetAllTopMenus

· Document.Import - both overloads

· Face.Intersect

· Curve.Intersect

· Curve.IsInside

· Face.IsInside

· Document.LoadFamily

· Document.LoadFamilySymbol

Where previously these output arguments were declared as “reference”. In C#, where these arguments were passed using the “ref” keyword, this should now be “out”.

Visual Studio Tools for Applications (VSTA) 2.0

Revit's macro functionality is now based on VSTA 2.0. More information about VSTA and version 2.0 are available on Microsoft's MSDN Developer Center at http://msdn.microsoft.com/en-us/vsx2008/products/bb933739.aspx

Find references in the direction of a ray

This new method returns a reference array of all references found when moving through the Revit model from a specified point at a specified direction.

Syntax:
public ReferenceArray FindReferencesByDirection(XYZ pOrigin, XYZ pDirection, View3D pView)

Reference parsing

The Autodesk.Revit.Geometry.Reference class now offers properties to extract the element, geometry object, transform, point, and parameters of the referenced item.

Element Hiding

To allow hiding and un-hiding of elements via the API, the methods View.Hide(ElementSet) and View.Unhide(ElementSet) have been added. The properties Element.IsHidden(View) and Element.CanBeHidden(View) return a boolean value that indicates if an element is current hidden and if it can be hidden.

Parameter.Set return value when value is unchanged

Previously, Revit returned False if the input value for Parameter.Set was the same as the current value. Revit now returns True in this case.

NoConditionType removed for Spaces

The NoConditionType enum has been removed as an option for Spaces. All spaces must have a ConditionType value and the default is HeatedAndCooled. A user wishing to specify an unconditioned space may use the value ConditionType::Unconditioned.

Detail Curves use sketch plane of their view

NewDetailCurve and NewDetailCurveArray no longer require specification of a sketch plane. The sketch plane of the view is used.

SketchPlane property added to View class

The property View.SketchPlane has been created to return a view's sketch plane.

Export family data to XML for Autodesk Seek integration

The method ExtractPartAtomFromFamilyFile will open a family file and create an XML file with data used by Autodesk Seek for content search.

Exceptions when parameters are disabled

Set and Get for the following parameters may now result in exceptions when the parameter is disabled for the specified object: View.Scale, RoofBase.FasciaDepth, FootPrintRoof.SlopeAngle

New options for export to DWF

The new option DWF2DExportOptions.ExportFormat allows specification of the paper format for the DWF.

The new option DWF2DExportOptions.PortraitLayout allows specification of the layout for the DWF.

The new option DWF2DExportOptions.ImageFormat allows specification of the format for the exported image in the DWF.

The new option DWF2DExportOptions.ImageQuality allows specification of the format for the exported image in the DWF.

The new option DWF2DExportOptions.StopOnError and DWF3DExportOptions.StopOnError controls whether or not the export process stops when an error is generated during export of one view, or whether Revit attempts to continue the export for other pending views.

New option for export to FBX

The new option FBXExportOptions.StopOnError controls whether or not the export process stops when an error is generated during export of one view, or whether Revit attempts to continue the export for other pending views.

New method for export to DGN

The new method Document.Export(String, String, ViewSet, DGNExportOptions) exports a Revit project exports a model into DGN format.

New method for export to Civil3D

The new method Document.Export(String, String, View3D, ViewPlan, BuildingSiteExportOptions) exports a Revit project exports a model in the format of Civil Engineering design applications.

New method for import from gbXML

The new method Document.Import(String, GBXMLImportOptions) imports a Green-Building XML file into Revit.

New method for import from Inventor

The new method Document.Import(String, InventorImportOptions) imports an Inventor file into Revit. The Inventor file must be a .adsk file exported from Inventor for the purposes of transfer to Revit.

Document.Application property

The new property Document.Application returns the Application object which contains this document.

New element collector properties

Two new methods for collecting elements have been added.

  • int Elements[Filter, ElementArray] - Collects all elements which satisfy specified filter within the document.
  • int Elements[Type, ElementArray] - Collects all elements which satisfy specified type within the document.

These methods are similar to previously existing methods accepting a System.Collection.Generics.ICollection<Element>.

ImportInstance elements

A new element sub-type ImportInstance represents external geometry content such as DWG that has been imported to Revit. This element type is also output from the Import() methods, however, those methods have not been updated to specific output this new type. You can downcast the output to this sub-type.

The ImportInstance element types offers the ability to access and modify the Visibility and Pinned parameters.

LocationCurve.ElementsAtJoin

This property has changed type since Revit release 2009. The property now returns an ElementArray, instead of List<Element>.

Element material quantities

The API provides access to the material quantities for a material in a given element. These values are the same values calculated by Revit to show in material takeoff schedules. In some cases the value may be approximate. Access these values through:

  • Category.HasMaterialQuantities
  • Element.Materials
  • Element.GetMaterialArea()
  • Element.GetMaterialVolume()

Instance.Transformed[Transform] and geometry of Instances

This property has been removed. Obtain the transformed geometry of the instance using Instance.GetInstanceGeometry(), Instance.GetSymbolGeometry(Transform) and Instance.GetInstanceGeometry(Transform)

PlaceGroup()

The method Autodesk.Revit.Creation.Document.PlaceGroup() has been modified to correctly interpret the coordinates of the input point in the coordinates of the document. Previously it interpreted the points in the coordinates of the group, which were not accessible.

gbXMLParamElem.ShadingSurfaces

This property has been removed and replaced with gbXMLParamElem.ExportComplexity with a wider variety of options.

Creating topography surfaces

The new methods

  • Autodesk.Revit.Creation.Document.NewTopographySurface()
  • Autodesk.Revit.Elements.TopographySurface.AddPoints()

allow you to create and populate topography surface elements in projects.

Changes to Printing

The workflows used to change print settings via the PrintManager class have changed. Previously, changes to settings happened immediately and would be visible in the Revit Print dialogs and applicable to all API printing activities. In the 2010 API, you must commit the changes you have made to the PrintManager, PrintSettings and PrintParameters classes by one of these methods:

  1. Calling PrintManager.SubmitPrint to execute a print job.
  2. Calling PrintManager.Apply to save settings without executing a print job.

The properties PrintSetup.PaperSizes and PrintSetup.PaperSources have moved to the PrintManager class.

A new option has been added to PrintParameters: ReplaceHalftoneWithThinLines.

Geometry extraction

A new option Autodesk.Revit.Geometry.Options.IncludeNonVisibleObjects has been added. Use this option to instruct Revit to include GeometryObjects whose Visibility type is something other than ‘Visible’ when extracting geometry from Revit. Objects which appear in this category include MEP Duct lining and insulation and joined geometry currently selected and highlighted in the Revit User Interface. When this option is not set (the default) only visible geometry is extracted, the same as in Revit 2009.

The geometry extraction API uses new algorithms to extract the faces and edges from a solid. The handles to these faces and edges are no longer maintained centrally (which means they are not suitable to be used as an index for collections like a Dictionary or Map). The new algorithm also changes the order in which the faces are returned, thus they may not be returned in the same order as in Revit 2009.

Additional enums

Several enums have been added to the Revit API to assist developers with interpretation of the values of certain BuiltInParameter types:

  • Autodesk.Revit.Enums.AnalyzesAsType – For the parameter STRUCTURAL_ANALYZES_AS
  • Autodesk.Revit.Enums.SlantedOrVerticalColumnType – For the parameter SLANTED_COLUMN_TYPE_PARAM
  • Autodesk.Revit.Enums.StickSymbolJustification – For the parameter STRUCTURAL_STICK_SYMBOL_LOCATION
  • Autodesk.Revit.Enums.StructuralReleaseType – For the parameter STRUCTURAL_END_RELEASE_TYPE
  • Autodesk.Revit.Enums.WallFunction – For the parameter WALL_ATTR_EXTERIOR


Revit API Reference

[image]

Revit 2010 API
Revit API Reference
Send Feedback

Namespaces

Namespace | Description
Autodesk.Revit |
Autodesk.Revit.Areas |
Autodesk.Revit.Collections |
Autodesk.Revit.Creation |
Autodesk.Revit.Editor |
Autodesk.Revit.Elements |
Autodesk.Revit.Enums |
Autodesk.Revit.Events |
Autodesk.Revit.Geometry |
Autodesk.Revit.MEP |
Autodesk.Revit.MEP.Enums |
Autodesk.Revit.Options |
Autodesk.Revit.Parameters |
Autodesk.Revit.Rooms |
Autodesk.Revit.Site |
Autodesk.Revit.Spaces |
Autodesk.Revit.Structural |
Autodesk.Revit.Structural.Enums |
Autodesk.Revit.Symbols |
Autodesk.Revit.Utility |

Send comments on this topic to Autodesk


Autodesk.Revit Namespace

[image]

Revit 2010 API
Autodesk.Revit Namespace
Send Feedback

Classes

Class | Description
ACADExportOptions | Export options specific to AutoCAD file formats.
ACADImportOptions | Import options specific to AutoCAD file formats.
APIObject | Supports all objects in the Autodesk Revit API hierarchy.
Application | Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.
BuildingSiteExportOptions | Building Site Export options.
ButtonData | Base class used to contain information necessary to construct a button in the Ribbon.
CADExportOptions | Generic CAD Export options.
CADImportOptions | Generic CAD Import options.
Categories | The Categories object is a map that contains all the top-level Category objects within the Document.
Category | Represents the category or subcategory to which an element belongs.
CategoryFilter | Represents a filter to filter elements with specific category.
CategoryNameMap | A map that contains a mapping of category name to its category object.
CategoryNameMapIterator | An iterator to a category name map.
CategorySet | A set that can contains Category objects.
CategorySetIterator | An iterator to a category set.
Color | Represents a color in Autodesk Revit.
Construction | Construction definition for Project Information.
ControlledApplication | Represents the Autodesk Revit Application with no access to documents. It provides options and other application wide data and settings for external applications OnStartup/OnShutdown.
CurveLoopsProfile | Represents a curve loop based profile for sweep or swept blend elements.
DGNExportOptions | DGN Export options.
DimensionSegment | A segment of a dimension within the Autodesk Revit project.
DimensionSegmentArray | An array that can contain any number of DimensionSegment objects.
DimensionSegmentArrayIterator | An iterator to an array of DimensionSegment objects..
Document | An object that represents an open Autodesk Revit project.
DocumentSet | A set that can contain any documents.
DocumentSetIterator | An iterator to a set of documents.
DWF2DExportOptions | DWF2D Export options.
DWF3DExportOptions | DWF3D Export options.
DWFExportOptions | DWF Export options.
DWFX2DExportOptions | DWFX2D Export options.
DWFX3DExportOptions | DWFX3D Export options.
DWGExportOptions | DWG Export options.
DWGImportOptions | Import options specific to AutoCAD's DWG file formats.
Element | Supports all classes that are persistent within the Autodesk Revit project providing low-level services to derived classes.
ElementArray | An array that contains element objects.
ElementArrayIterator | An iterator to an element array.
ElementIdSet | A set that can contain Element Ids.
ElementIdSetIterator | An iterator to a element id set.
ElementIterator | An iterator object that enable access to every element within the Autodesk Revit project.
ElementSet | A set that contains element objects.
ElementSetIterator | An iterator to an element set.
ExternalApplicationArray | An array that can contain any number of IExternalApplication objects.
ExternalApplicationArrayIterator | An iterator to an array of IExternalApplication objects..
ExternalCommandData | A class contains reference to Application and View which are needed by external command.
FamilyElementVisibility | Provides access to the visibility parameters of family elements in family document.
FamilyFilter | A filter object that used to filter family elements which satisfy specified criterion, filter elements via specifying family name.
FamilyManager | The family manager object to manage the family types and parameters in family document.
FamilyParameter | The family parameter object.
FamilyParameterSet | A set that contains FamilyParameter objects.
FamilyParameterSetIterator | An iterator to a FamilyParameter set.
FamilySymbolProfile | Represents a family symbol based profile for sweep or swept blend elements.
FamilyType | The family type object provides read access to the values of family parameters for this type.
FamilyTypeSet | A set that contains FamilyType objects.
FamilyTypeSetIterator | An iterator to a FamilyType set.
FBXExportOptions | 3D-Studio Max (FBX) Export options.
FillPatternSet | A set that contains FillPatterns.
FillPatternSetIterator | An iterator to a FillPattern set.
Filter | Base class that represents all filters of other sub classes (such as TypeFilter, CategoryFilter, FamilyFilter, SymbolFilter, ParameterFilter, InstanceUsageFilter, WallUsageFilter, MaterialFilter or StructuralTypeFilter), this filter can be used to create single filter or filters combination. User can use overloaded &&, || and ! operators to create combination of filters. e.g. FamilyFilter && SymbolFilter && ParameterFilter, (FamilyFilter1 || FamilyFilter2) && ParameterFilter. Use this filter to retrieve elements which satisfy specified filter criterion within current document.
FilterCriterion | An object that defines the criteria as the filter for retrieving certain needed elements.
FormArray | An array that contains form objects.
FormArrayIterator | An iterator to a form array.
FormatOptions | Contains the Unit information of current user selection of Unit within the project.
GBXMLExportOptions | Green-Building XML Export options.
GBXMLImportOptions | Import options for Green-Building XML format.
GenericImportOptions | Generic Import options.
ImageImportOptions | Import options specific image (bitmap) formats.
InstanceUsageFilter | Represents a filter to filter elements with the given InstanceUsage/StructuralUsage.
InventorImportOptions | Import options for Inventor format.
Leader | An object that represents a Leader within the Autodesk Revit project.
LeaderArray | An array that can contain any number of leaders.
LeaderArrayIterator | An iterator to an array of leaders.
LinePatternSet | A set that can contain any number of line patterns.
LinePatternSetIterator | An iterator to a set.
Location | Provides location functionality for all elements.
LocationCurve | Provides location functionality for all elements that are based upon a curve.
LocationPoint | Provides location functionality for all elements that have a single insertion point.
LogicAndFilter | The LogicAndFilter is used to implement Logic-AND operation of Filters.
LogicNotFilter | The LogicNotFilter is used to implement Logic-NOT operation of Filters.
LogicOrFilter | The LogicOrFilter is used to implement Logic-OR operation of Filters.
MaterialFilter | Represents a filter to filter elements with the given material.
Materials | A set of materials that provides access to the materials in an Autodesk Revit project.
MaterialSet | An set that contains materials.
MaterialSetIterator | An iterator to a material set.
MEPSpaceConstruction | Construction definition for Space.
ObjectFactory | For Internal Use Only.
PaperSize | An object that represents a Paper Size of Print Setup within the Autodesk Revit project.
PaperSizeSet | A set that can contain any number of paper size objects.
PaperSizeSetIterator | An iterator to a set of paper size objects.
PaperSource | An object that represents a Paper Source of Print Setup within the Autodesk Revit project.
PaperSourceSet | A set that can contain any number of paper source objects.
PaperSourceSetIterator | An iterator to a set of paper source objects.
Parameter | The parameter object contains the value data assigned to that parameter.
ParameterFilter | To filter elements with specific parameter criterion.
ParameterMap | A map that can contain a mapping of a parameter name (a String) to a parameter.
ParameterMapIterator | An iterator to a map relating a parameter name (the key, a String) to a parameter.
ParameterSet | A set that contains parameters.
ParameterSetIterator | An iterator to a parameter set.
ParameterStorage | An object that contains details for the value of a parameter. This class is mainly used with the class FilterCriterion to retrieve Elements according to certain criteria.
PlanCircuit | An object that represents an enclosed area in a plan view within the Autodesk Revit project.
PlanCircuitSet | A set that can contain any number of plan circuit objects.
PlanCircuitSetIterator | An iterator to a set of plan circuit objects.
PlanTopology | An object that represents a Plan Topology within the Autodesk Revit project.
PlanTopologySet | A set that can contain any number of plan topology objects.
PlanTopologySetIterator | An iterator to a set of plan topology objects.
PostedError | A class that holds information about a posted error.
PostedErrorArray | An array that can contain any number of posted errors.
PostedErrorArrayIterator | A class that holds an array of posted errors.
PrintManager | The PrintManager object is used to configure the global print settings.
PrintParameters | An object that contains settings used for printing the document.
PrintSetup | Represents the Print Setup (File->Print Setup...) within Autodesk Revit.
PulldownButton | The RibbonItem object represents an item on RibbonPanel. It can be a push-button or a pull-down that contains the information for creating one RibbonItem.
PulldownButtonData | This class contains information necessary to construct a pulldown button in the Ribbon.
PushButton | The RibbonItem object represents an item on a RibbonPanel. It can be a push-button or a pull-down which contains the information for creating one RibbonItem.
PushButtonData | This class contains information necessary to construct a push button in the Ribbon.
RevitUIFamilyLoadOptions | Allows you to use Revit's dialog boxes to let the user respond to questions that arise during loading of families.
RibbonItem | The RibbonItem object represents an item on RibbonPanel, can be a push-button or a pull-down which should contain the information for creating one RibbonItem.
RibbonPanel | The Panel object represents a panel in AddIns tab, which should contains an array of RibbonItems.
Selection | Contains the current user selection of elements within the project.
SelElementSet | This class contains the current user selection of elements within the project.
Settings | The settings object provides access to general components of the Autodesk Revit application, such as Categories.
StructuralTypeFilter | A Filter object that represents StructuralType, used to retrieve family instances whose structural type is specified structural type.
SuspendUpdating | Temporarily delay Revit's automatic updating and consistency operations.
SweepProfile | Represents a profile for sweep or swept blend elements.
Symbol | Base class for all Symbols and Types within Autodesk Revit.
SymbolFilter | A filter object that used to filter symbol elements which satisfy specified criterion, filter elements by specifying symbol name.
TilePatterns | The TilePatterns object is an interface for retrieving the TilePattern objects within the Document.
TrussMemberInfo | Provides access to the information of a truss member in Autodesk Revit.
TypeFilter | Represents a filter to filter elements with the given type.
VertexIndexPair | Represents a connection between vertices in the top and bottom profile of a blend.
VertexIndexPairArray |
VertexIndexPairArrayIterator |
ViewSheetSetting | Represents the View/Sheet Set (File->Print) within Autodesk Revit.
VolumeCalculationOptions | This class provides access to options related to room volume and area computations.
VolumeCalculationSetting | This class provides access to settings related to room volume and area computations.
WallUsageFilter | A Filter object that represents Structural WallUsage, used to retrieve Wall elements whose structural WallUsage is specified WallUsage type.

Structures

Structure | Description
ElementId | The ElementId object is used as a unique identification for an element within a single project.

Interfaces

Interface | Description
IExtension | An interface that supports the additonal operation for Extension Status
IExternalApplication | An interface that when support provides additional applications within Autodesk Revit implemented by external applications.
IExternalCommand | An interface that when support provides additional commands within Autodesk Revit implemented by external applications.
IFamilyLoadOptions | An interface class which provide the callback for family load options.

Enumerations

Enumeration | Description
BuiltInCategory | A list of all the built in categories within Revit.
FamilyElementVisibilityType | Indicates the Visiblity type of generic forms.
FamilySource | Describes which version of the family to be loaded.
IExternalApplication..::.Result | Informs Autodesk Revit of the status of your application after execution.
IExternalCommand..::.Result | Informs Autodesk Revit of the status of your command after execution.
JoinType | The type of join at the end of an element. The join type affects only the graphic treatment, i.e. cleaning of the end, not the physical join behavior.
RibbonItem..::.RibbonItemType | An enumerate type listing all the toolbar item styles.


ACADExportOptions Class

[image]

Revit 2010 API
ACADExportOptions Class
Members See Also Send Feedback
Export options specific to AutoCAD file formats.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ACADExportOptions : CADExportOptions
Visual Basic (Declaration)
Public MustInherit Class ACADExportOptions _
    Inherits CADExportOptions
Visual C++
public ref class ACADExportOptions abstract : public CADExportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.CADExportOptions
Autodesk.Revit..::.ACADExportOptions
Autodesk.Revit..::.DWGExportOptions

See Also

ACADExportOptions Members
Autodesk.Revit Namespace


ACADExportOptions Members

[image] [image]

Revit 2010 API
ACADExportOptions Members
ACADExportOptions Class Methods Properties See Also Send Feedback

The ACADExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExportingAreas | Whether to also export areas and rooms' geometry.
ExportOfSolids | Mode of exporting solids in 3D views.
FileVersion | AutoCAD file version.
ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views.
LayerMapping | Name of a layer settings standard or filename (with custom layer settings).
LineScaling | LineType scaling mode.
PropOverrides | How to export overriden object styles.
SharedCoords | Whether to use shared coordinate system or a project's. internal origin.
TargetUnit | Type of units in the target CAD format.

See Also

ACADExportOptions Class
Autodesk.Revit Namespace


ACADExportOptions Methods

[image] [image]

Revit 2010 API
ACADExportOptions Methods
ACADExportOptions Class See Also Send Feedback

The ACADExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ACADExportOptions Class
Autodesk.Revit Namespace


ACADExportOptions Properties

[image] [image]

Revit 2010 API
ACADExportOptions Properties
ACADExportOptions Class See Also Send Feedback

The ACADExportOptions type exposes the following members.

Properties

Name | Description
ExportingAreas | Whether to also export areas and rooms' geometry.
ExportOfSolids | Mode of exporting solids in 3D views.
FileVersion | AutoCAD file version.
ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views.
LayerMapping | Name of a layer settings standard or filename (with custom layer settings).
LineScaling | LineType scaling mode.
PropOverrides | How to export overriden object styles.
SharedCoords | Whether to use shared coordinate system or a project's. internal origin.
TargetUnit | Type of units in the target CAD format.

See Also

ACADExportOptions Class
Autodesk.Revit Namespace


ExportingAreas Property

[image]

Revit 2010 API
ACADExportOptions..::.ExportingAreas Property
ACADExportOptions Class See Also Send Feedback
Whether to also export areas and rooms' geometry.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool ExportingAreas { get; set; }
Visual Basic (Declaration)
Public Property ExportingAreas As Boolean
Visual C++
public:
property bool ExportingAreas {
    bool get ();
    void set (bool value);
}

See Also

ACADExportOptions Class
Autodesk.Revit Namespace


ExportOfSolids Property

[image]

Revit 2010 API
ACADExportOptions..::.ExportOfSolids Property
ACADExportOptions Class See Also Send Feedback
Mode of exporting solids in 3D views.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SolidGeometry ExportOfSolids { get; set; }
Visual Basic (Declaration)
Public Property ExportOfSolids As SolidGeometry
Visual C++
public:
property SolidGeometry ExportOfSolids {
    SolidGeometry get ();
    void set (SolidGeometry value);
}

See Also

ACADExportOptions Class
Autodesk.Revit Namespace


FileVersion Property

[image]

Revit 2010 API
ACADExportOptions..::.FileVersion Property
ACADExportOptions Class See Also Send Feedback
AutoCAD file version.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ACADVersion FileVersion { get; set; }
Visual Basic (Declaration)
Public Property FileVersion As ACADVersion
Visual C++
public:
property ACADVersion FileVersion {
    ACADVersion get ();
    void set (ACADVersion value);
}

See Also

ACADExportOptions Class
Autodesk.Revit Namespace


ForcedHLR Property

[image]

Revit 2010 API
ACADExportOptions..::.ForcedHLR Property
ACADExportOptions Class See Also Send Feedback
Whether to enforce Hidden Lines Removal in 3D views.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool ForcedHLR { get; set; }
Visual Basic (Declaration)
Public Property ForcedHLR As Boolean
Visual C++
public:
property bool ForcedHLR {
    bool get ();
    void set (bool value);
}

See Also

ACADExportOptions Class
Autodesk.Revit Namespace


LayerMapping Property

[image]

Revit 2010 API
ACADExportOptions..::.LayerMapping Property
ACADExportOptions Class See Also Send Feedback
Name of a layer settings standard or filename (with custom layer settings).

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string LayerMapping { get; set; }
Visual Basic (Declaration)
Public Property LayerMapping As String
Visual C++
public:
property String^ LayerMapping {
    String^ get ();
    void set (String^ value);
}

Remarks

Valid standards are: AIA, CP83, BS1192, and ISO13567.

See Also

ACADExportOptions Class
Autodesk.Revit Namespace


LineScaling Property

[image]

Revit 2010 API
ACADExportOptions..::.LineScaling Property
ACADExportOptions Class See Also Send Feedback
LineType scaling mode.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LineScaling LineScaling { get; set; }
Visual Basic (Declaration)
Public Property LineScaling As LineScaling
Visual C++
public:
property LineScaling LineScaling {
    LineScaling get ();
    void set (LineScaling value);
}

See Also

ACADExportOptions Class
Autodesk.Revit Namespace


PropOverrides Property

[image]

Revit 2010 API
ACADExportOptions..::.PropOverrides Property
ACADExportOptions Class See Also Send Feedback
How to export overriden object styles.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PropOverrideMode PropOverrides { get; set; }
Visual Basic (Declaration)
Public Property PropOverrides As PropOverrideMode
Visual C++
public:
property PropOverrideMode PropOverrides {
    PropOverrideMode get ();
    void set (PropOverrideMode value);
}

See Also

ACADExportOptions Class
Autodesk.Revit Namespace


SharedCoords Property

[image]

Revit 2010 API
ACADExportOptions..::.SharedCoords Property
ACADExportOptions Class See Also Send Feedback
Whether to use shared coordinate system or a project's. internal origin.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SharedCoords { get; set; }
Visual Basic (Declaration)
Public Property SharedCoords As Boolean
Visual C++
public:
property bool SharedCoords {
    bool get ();
    void set (bool value);
}

See Also

ACADExportOptions Class
Autodesk.Revit Namespace


TargetUnit Property

[image]

Revit 2010 API
ACADExportOptions..::.TargetUnit Property
ACADExportOptions Class See Also Send Feedback
Type of units in the target CAD format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ExportUnit TargetUnit { get; set; }
Visual Basic (Declaration)
Public Property TargetUnit As ExportUnit
Visual C++
public:
property ExportUnit TargetUnit {
    ExportUnit get ();
    void set (ExportUnit value);
}

See Also

ACADExportOptions Class
Autodesk.Revit Namespace


ACADImportOptions Class

[image]

Revit 2010 API
ACADImportOptions Class
Members See Also Send Feedback
Import options specific to AutoCAD file formats.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ACADImportOptions : CADImportOptions
Visual Basic (Declaration)
Public MustInherit Class ACADImportOptions _
    Inherits CADImportOptions
Visual C++
public ref class ACADImportOptions abstract : public CADImportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.GenericImportOptions
Autodesk.Revit..::.CADImportOptions
Autodesk.Revit..::.ACADImportOptions
Autodesk.Revit..::.DWGImportOptions

See Also

ACADImportOptions Members
Autodesk.Revit Namespace


ACADImportOptions Members

[image] [image]

Revit 2010 API
ACADImportOptions Members
ACADImportOptions Class Methods Properties See Also Send Feedback

The ACADImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColorMode | Color mode for the import. (Inherited from CADImportOptions.)
CustomScale | Scaling the import. (Inherited from CADImportOptions.)
LayerSelection | The layers collection for import.
LineWeights | A Byte array of line weights for the DWG/DXF Color number.
OrientToView | Place the import at the same orientation as the current view. (Inherited from CADImportOptions.)
Placement | Where to place the import. (Inherited from CADImportOptions.)
RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only. (Inherited from CADImportOptions.)
Unit | The unit of measure for imported geometry. (Inherited from CADImportOptions.)
View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)
VisibleLayersOnly | Only import the visible layers.

See Also

ACADImportOptions Class
Autodesk.Revit Namespace


ACADImportOptions Methods

[image] [image]

Revit 2010 API
ACADImportOptions Methods
ACADImportOptions Class See Also Send Feedback

The ACADImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ACADImportOptions Class
Autodesk.Revit Namespace


ACADImportOptions Properties

[image] [image]

Revit 2010 API
ACADImportOptions Properties
ACADImportOptions Class See Also Send Feedback

The ACADImportOptions type exposes the following members.

Properties

Name | Description
ColorMode | Color mode for the import. (Inherited from CADImportOptions.)
CustomScale | Scaling the import. (Inherited from CADImportOptions.)
LayerSelection | The layers collection for import.
LineWeights | A Byte array of line weights for the DWG/DXF Color number.
OrientToView | Place the import at the same orientation as the current view. (Inherited from CADImportOptions.)
Placement | Where to place the import. (Inherited from CADImportOptions.)
RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only. (Inherited from CADImportOptions.)
Unit | The unit of measure for imported geometry. (Inherited from CADImportOptions.)
View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)
VisibleLayersOnly | Only import the visible layers.

See Also

ACADImportOptions Class
Autodesk.Revit Namespace


LayerSelection Property

[image]

Revit 2010 API
ACADImportOptions..::.LayerSelection Property
ACADImportOptions Class See Also Send Feedback
The layers collection for import.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public StringCollection LayerSelection { get; set; }
Visual Basic (Declaration)
Public Property LayerSelection As StringCollection
Visual C++
public:
property StringCollection^ LayerSelection {
    StringCollection^ get ();
    void set (StringCollection^ value);
}

Remarks

Specify the names of layers and levels to import.

See Also

ACADImportOptions Class
Autodesk.Revit Namespace


LineWeights Property

[image]

Revit 2010 API
ACADImportOptions..::.LineWeights Property
ACADImportOptions Class See Also Send Feedback
A Byte array of line weights for the DWG/DXF Color number.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public byte[] LineWeights { get; set; }
Visual Basic (Declaration)
Public Property LineWeights As Byte()
Visual C++
public:
property array<unsigned char>^ LineWeights {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Remarks

Import pen numbers from a DWG or DXF file and map them to a line weight.

See Also

ACADImportOptions Class
Autodesk.Revit Namespace


VisibleLayersOnly Property

[image]

Revit 2010 API
ACADImportOptions..::.VisibleLayersOnly Property
ACADImportOptions Class See Also Send Feedback
Only import the visible layers.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool VisibleLayersOnly { get; set; }
Visual Basic (Declaration)
Public Property VisibleLayersOnly As Boolean
Visual C++
public:
property bool VisibleLayersOnly {
    bool get ();
    void set (bool value);
}

Remarks

If this option is set to true, only visible layers are imported.

See Also

ACADImportOptions Class
Autodesk.Revit Namespace


APIObject Class

[image]

Revit 2010 API
APIObject Class
Members See Also Send Feedback
Supports all objects in the Autodesk Revit API hierarchy.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class APIObject : IDisposable
Visual Basic (Declaration)
Public Class APIObject _
    Implements IDisposable
Visual C++
public ref class APIObject : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Application
Autodesk.Revit.Areas..::.BoundarySegment
Autodesk.Revit.Areas..::.BoundarySegmentArray
Autodesk.Revit.Areas..::.BoundarySegmentArrayArray
Autodesk.Revit.Areas..::.BoundarySegmentArrayArrayIterator
Autodesk.Revit.Areas..::.BoundarySegmentArrayIterator
Autodesk.Revit..::.Category
Autodesk.Revit..::.CategoryNameMap
Autodesk.Revit..::.CategoryNameMapIterator
Autodesk.Revit..::.CategorySet
Autodesk.Revit..::.CategorySetIterator
Autodesk.Revit.Collections..::.Array
Autodesk.Revit.Collections..::.ArrayIterator
Autodesk.Revit.Collections..::.DefinitionBindingMap
Autodesk.Revit.Collections..::.DefinitionBindingMapIterator
Autodesk.Revit.Collections..::.Map
Autodesk.Revit.Collections..::.MapIterator
Autodesk.Revit.Collections..::.Set
Autodesk.Revit.Collections..::.SetIterator
Autodesk.Revit.Collections..::.StringStringMap
Autodesk.Revit.Collections..::.StringStringMapIterator
Autodesk.Revit..::.Color
Autodesk.Revit.Creation..::.Application
Autodesk.Revit.Creation..::.Filter
Autodesk.Revit.Creation..::.ItemFactoryBase
Autodesk.Revit..::.DimensionSegment
Autodesk.Revit..::.DimensionSegmentArray
Autodesk.Revit..::.DimensionSegmentArrayIterator
Autodesk.Revit..::.Document
Autodesk.Revit..::.DocumentSet
Autodesk.Revit..::.DocumentSetIterator
Autodesk.Revit.Editor..::.SlabShapeCreaseArray
Autodesk.Revit.Editor..::.SlabShapeCreaseArrayIterator
Autodesk.Revit.Editor..::.SlabShapeVertexArray
Autodesk.Revit.Editor..::.SlabShapeVertexArrayIterator
Autodesk.Revit..::.Element
Autodesk.Revit..::.ElementArray
Autodesk.Revit..::.ElementArrayIterator
Autodesk.Revit..::.ElementIdSet
Autodesk.Revit..::.ElementIdSetIterator
Autodesk.Revit..::.ElementIterator
Autodesk.Revit.Elements..::.CombinableElementArray
Autodesk.Revit.Elements..::.CombinableElementArrayIterator
Autodesk.Revit.Elements..::.CurtainCell
Autodesk.Revit.Elements..::.CurtainCellSet
Autodesk.Revit.Elements..::.CurtainCellSetIterator
Autodesk.Revit.Elements..::.CurtainGrid
Autodesk.Revit.Elements..::.CurtainGridSet
Autodesk.Revit.Elements..::.CurtainGridSetIterator
Autodesk.Revit.Elements..::.CurveByPointsArray
Autodesk.Revit.Elements..::.CurveByPointsArrayIterator
Autodesk.Revit.Elements..::.DetailCurveArray
Autodesk.Revit.Elements..::.DetailCurveArrayIterator
Autodesk.Revit.Elements..::.DividedSurfaceData
Autodesk.Revit.Elements..::.GenericFormSet
Autodesk.Revit.Elements..::.GenericFormSetIterator
Autodesk.Revit.Elements..::.GeomCombinationSet
Autodesk.Revit.Elements..::.GeomCombinationSetIterator
Autodesk.Revit.Elements..::.GroupSet
Autodesk.Revit.Elements..::.GroupSetIterator
Autodesk.Revit.Elements..::.LayoutRule
Autodesk.Revit.Elements..::.LoadCaseArray
Autodesk.Revit.Elements..::.LoadCaseArrayIterator
Autodesk.Revit.Elements..::.LoadCaseSet
Autodesk.Revit.Elements..::.LoadCaseSetIterator
Autodesk.Revit.Elements..::.LoadCombinationArray
Autodesk.Revit.Elements..::.LoadCombinationArrayIterator
Autodesk.Revit.Elements..::.LoadUsageArray
Autodesk.Revit.Elements..::.LoadUsageArrayIterator
Autodesk.Revit.Elements..::.ModelCurveArrArray
Autodesk.Revit.Elements..::.ModelCurveArrArrayIterator
Autodesk.Revit.Elements..::.ModelCurveArray
Autodesk.Revit.Elements..::.ModelCurveArrayIterator
Autodesk.Revit.Elements..::.PhaseArray
Autodesk.Revit.Elements..::.PhaseArrayIterator
Autodesk.Revit.Elements..::.RebarHostData
Autodesk.Revit.Elements..::.ReferencePointArray
Autodesk.Revit.Elements..::.ReferencePointArrayIterator
Autodesk.Revit.Elements..::.SketchSet
Autodesk.Revit.Elements..::.SketchSetIterator
Autodesk.Revit.Elements..::.SpaceSet
Autodesk.Revit.Elements..::.SpaceSetIterator
Autodesk.Revit.Elements..::.SpacingRule
Autodesk.Revit.Elements..::.ViewSet
Autodesk.Revit.Elements..::.ViewSetIterator
Autodesk.Revit.Elements..::.ViewSheetSets
Autodesk.Revit.Elements..::.ViewSheetSetsIterator
Autodesk.Revit..::.ElementSet
Autodesk.Revit..::.ElementSetIterator
Autodesk.Revit.Events..::.DialogBoxData
Autodesk.Revit..::.ExternalApplicationArray
Autodesk.Revit..::.ExternalApplicationArrayIterator
Autodesk.Revit..::.ExternalCommandData
Autodesk.Revit..::.FamilyElementVisibility
Autodesk.Revit..::.FamilyManager
Autodesk.Revit..::.FamilyParameter
Autodesk.Revit..::.FamilyParameterSet
Autodesk.Revit..::.FamilyParameterSetIterator
Autodesk.Revit..::.FamilyType
Autodesk.Revit..::.FamilyTypeSet
Autodesk.Revit..::.FamilyTypeSetIterator
Autodesk.Revit..::.FillPatternSet
Autodesk.Revit..::.FillPatternSetIterator
Autodesk.Revit..::.Filter
Autodesk.Revit..::.FilterCriterion
Autodesk.Revit..::.FormArray
Autodesk.Revit..::.FormArrayIterator
Autodesk.Revit..::.FormatOptions
Autodesk.Revit.Geometry..::.BoundingBoxXYZ
Autodesk.Revit.Geometry..::.CurveArrArray
Autodesk.Revit.Geometry..::.CurveArrArrayIterator
Autodesk.Revit.Geometry..::.CurveArray
Autodesk.Revit.Geometry..::.CurveArrayIterator
Autodesk.Revit.Geometry..::.DoubleArray
Autodesk.Revit.Geometry..::.DoubleArrayIterator
Autodesk.Revit.Geometry..::.EdgeArray
Autodesk.Revit.Geometry..::.EdgeArrayArray
Autodesk.Revit.Geometry..::.EdgeArrayArrayIterator
Autodesk.Revit.Geometry..::.EdgeArrayIterator
Autodesk.Revit.Geometry..::.FaceArray
Autodesk.Revit.Geometry..::.FaceArrayIterator
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.GeometryObjectArray
Autodesk.Revit.Geometry..::.GeometryObjectArrayIterator
Autodesk.Revit.Geometry..::.InstanceArray
Autodesk.Revit.Geometry..::.InstanceArrayIterator
Autodesk.Revit.Geometry..::.IntersectionResult
Autodesk.Revit.Geometry..::.IntersectionResultArray
Autodesk.Revit.Geometry..::.IntersectionResultArrayIterator
Autodesk.Revit.Geometry..::.MeshArray
Autodesk.Revit.Geometry..::.MeshArrayIterator
Autodesk.Revit.Geometry..::.MeshTriangle
Autodesk.Revit.Geometry..::.Options
Autodesk.Revit.Geometry..::.Plane
Autodesk.Revit.Geometry..::.Reference
Autodesk.Revit.Geometry..::.ReferenceArray
Autodesk.Revit.Geometry..::.ReferenceArrayArray
Autodesk.Revit.Geometry..::.ReferenceArrayArrayIterator
Autodesk.Revit.Geometry..::.ReferenceArrayIterator
Autodesk.Revit.Geometry..::.SolidArray
Autodesk.Revit.Geometry..::.SolidArrayIterator
Autodesk.Revit.Geometry..::.Transform
Autodesk.Revit.Geometry..::.UVArray
Autodesk.Revit.Geometry..::.UVArrayIterator
Autodesk.Revit.Geometry..::.XYZArray
Autodesk.Revit.Geometry..::.XYZArrayIterator
Autodesk.Revit..::.Leader
Autodesk.Revit..::.LeaderArray
Autodesk.Revit..::.LeaderArrayIterator
Autodesk.Revit..::.LinePatternSet
Autodesk.Revit..::.LinePatternSetIterator
Autodesk.Revit..::.Location
Autodesk.Revit..::.MaterialSet
Autodesk.Revit..::.MaterialSetIterator
Autodesk.Revit.MEP..::.ConduitTypeSet
Autodesk.Revit.MEP..::.ConduitTypeSetIterator
Autodesk.Revit.MEP..::.Connector
Autodesk.Revit.MEP..::.ConnectorManager
Autodesk.Revit.MEP..::.ConnectorSet
Autodesk.Revit.MEP..::.ConnectorSetIterator
Autodesk.Revit.MEP..::.CorrectionFactor
Autodesk.Revit.MEP..::.CorrectionFactorSet
Autodesk.Revit.MEP..::.CorrectionFactorSetIterator
Autodesk.Revit.MEP..::.DemandFactorData
Autodesk.Revit.MEP..::.DemandFactorDataSet
Autodesk.Revit.MEP..::.DemandFactorDataSetIterator
Autodesk.Revit.MEP..::.DistributionSysTypeSet
Autodesk.Revit.MEP..::.DistributionSysTypeSetIterator
Autodesk.Revit.MEP..::.ElectricalSetting
Autodesk.Revit.MEP..::.ElectricalSystemSet
Autodesk.Revit.MEP..::.ElectricalSystemSetIterator
Autodesk.Revit.MEP..::.GroundConductorSize
Autodesk.Revit.MEP..::.GroundConductorSizeSet
Autodesk.Revit.MEP..::.GroundConductorSizeSetIterator
Autodesk.Revit.MEP..::.InsulationTypeSet
Autodesk.Revit.MEP..::.InsulationTypeSetIterator
Autodesk.Revit.MEP..::.MEPModel
Autodesk.Revit.MEP..::.TemperatureRatingTypeSet
Autodesk.Revit.MEP..::.TemperatureRatingTypeSetIterator
Autodesk.Revit.MEP..::.VoltageTypeSet
Autodesk.Revit.MEP..::.VoltageTypeSetIterator
Autodesk.Revit.MEP..::.WireMaterialTypeSet
Autodesk.Revit.MEP..::.WireMaterialTypeSetIterator
Autodesk.Revit.MEP..::.WireSet
Autodesk.Revit.MEP..::.WireSetIterator
Autodesk.Revit.MEP..::.WireSize
Autodesk.Revit.MEP..::.WireSizeSet
Autodesk.Revit.MEP..::.WireSizeSetIterator
Autodesk.Revit.MEP..::.WireTypeSet
Autodesk.Revit.MEP..::.WireTypeSetIterator
Autodesk.Revit.Options..::.Application
Autodesk.Revit..::.PaperSize
Autodesk.Revit..::.PaperSizeSet
Autodesk.Revit..::.PaperSizeSetIterator
Autodesk.Revit..::.PaperSource
Autodesk.Revit..::.PaperSourceSet
Autodesk.Revit..::.PaperSourceSetIterator
Autodesk.Revit..::.Parameter
Autodesk.Revit..::.ParameterMap
Autodesk.Revit..::.ParameterMapIterator
Autodesk.Revit.Parameters..::.Binding
Autodesk.Revit.Parameters..::.Definition
Autodesk.Revit.Parameters..::.DefinitionFile
Autodesk.Revit.Parameters..::.DefinitionGroup
Autodesk.Revit.Parameters..::.DefinitionGroupsBase
Autodesk.Revit.Parameters..::.DefinitionGroupsBaseIterator
Autodesk.Revit.Parameters..::.DefinitionsBase
Autodesk.Revit.Parameters..::.DefinitionsBaseIterator
Autodesk.Revit.Parameters..::.ParameterListItem
Autodesk.Revit.Parameters..::.ParameterListItemArray
Autodesk.Revit.Parameters..::.ParameterListItemArrayIterator
Autodesk.Revit..::.ParameterSet
Autodesk.Revit..::.ParameterSetIterator
Autodesk.Revit..::.ParameterStorage
Autodesk.Revit..::.PlanCircuit
Autodesk.Revit..::.PlanCircuitSet
Autodesk.Revit..::.PlanCircuitSetIterator
Autodesk.Revit..::.PlanTopology
Autodesk.Revit..::.PlanTopologySet
Autodesk.Revit..::.PlanTopologySetIterator
Autodesk.Revit..::.PostedError
Autodesk.Revit..::.PostedErrorArray
Autodesk.Revit..::.PostedErrorArrayIterator
Autodesk.Revit..::.PrintManager
Autodesk.Revit..::.PrintParameters
Autodesk.Revit..::.PrintSetup
Autodesk.Revit..::.RibbonItem
Autodesk.Revit..::.RibbonPanel
Autodesk.Revit.Rooms..::.BoundarySegment
Autodesk.Revit.Rooms..::.BoundarySegmentArray
Autodesk.Revit.Rooms..::.BoundarySegmentArrayArray
Autodesk.Revit.Rooms..::.BoundarySegmentArrayArrayIterator
Autodesk.Revit.Rooms..::.BoundarySegmentArrayIterator
Autodesk.Revit..::.Selection
Autodesk.Revit..::.Settings
Autodesk.Revit.Site..::.City
Autodesk.Revit.Site..::.CitySet
Autodesk.Revit.Site..::.CitySetIterator
Autodesk.Revit.Site..::.ProjectLocationSet
Autodesk.Revit.Site..::.ProjectLocationSetIterator
Autodesk.Revit.Site..::.ProjectPosition
Autodesk.Revit.Spaces..::.BoundarySegment
Autodesk.Revit.Spaces..::.BoundarySegmentArray
Autodesk.Revit.Spaces..::.BoundarySegmentArrayArray
Autodesk.Revit.Spaces..::.BoundarySegmentArrayArrayIterator
Autodesk.Revit.Spaces..::.BoundarySegmentArrayIterator
Autodesk.Revit.Structural..::.AnalyticalModel
Autodesk.Revit.Structural..::.AnalyticalSupportData
Autodesk.Revit.Structural..::.AnalyticalSupportInfo
Autodesk.Revit.Structural..::.AnalyticalSupportInfoArray
Autodesk.Revit.Structural..::.AnalyticalSupportInfoArrayIterator
Autodesk.Revit.Structural..::.BarDescription
Autodesk.Revit.Structural..::.CompoundStructure
Autodesk.Revit.Structural..::.CompoundStructureLayer
Autodesk.Revit.Structural..::.CompoundStructureLayerArray
Autodesk.Revit.Structural..::.CompoundStructureLayerArrayIterator
Autodesk.Revit..::.SuspendUpdating
Autodesk.Revit..::.SweepProfile
Autodesk.Revit.Symbols..::.AnnotationSymbolTypeSet
Autodesk.Revit.Symbols..::.AnnotationSymbolTypeSetIterator
Autodesk.Revit.Symbols..::.AreaLoadTypeSet
Autodesk.Revit.Symbols..::.AreaLoadTypeSetIterator
Autodesk.Revit.Symbols..::.AreaTagTypeSet
Autodesk.Revit.Symbols..::.AreaTagTypeSetIterator
Autodesk.Revit.Symbols..::.BeamSystemTypeSet
Autodesk.Revit.Symbols..::.BeamSystemTypeSetIterator
Autodesk.Revit.Symbols..::.ContFootingTypeSet
Autodesk.Revit.Symbols..::.ContFootingTypeSetIterator
Autodesk.Revit.Symbols..::.CurtainSystemTypeSet
Autodesk.Revit.Symbols..::.CurtainSystemTypeSetIterator
Autodesk.Revit.Symbols..::.DimensionTypeSet
Autodesk.Revit.Symbols..::.DimensionTypeSetIterator
Autodesk.Revit.Symbols..::.FamilySymbolSet
Autodesk.Revit.Symbols..::.FamilySymbolSetIterator
Autodesk.Revit.Symbols..::.FasciaTypeSet
Autodesk.Revit.Symbols..::.FasciaTypeSetIterator
Autodesk.Revit.Symbols..::.FloorTypeSet
Autodesk.Revit.Symbols..::.FloorTypeSetIterator
Autodesk.Revit.Symbols..::.GridTypeSet
Autodesk.Revit.Symbols..::.GridTypeSetIterator
Autodesk.Revit.Symbols..::.GutterTypeSet
Autodesk.Revit.Symbols..::.GutterTypeSetIterator
Autodesk.Revit.Symbols..::.LevelTypeSet
Autodesk.Revit.Symbols..::.LevelTypeSetIterator
Autodesk.Revit.Symbols..::.LineLoadTypeSet
Autodesk.Revit.Symbols..::.LineLoadTypeSetIterator
Autodesk.Revit.Symbols..::.LoadTypeBaseSet
Autodesk.Revit.Symbols..::.LoadTypeBaseSetIterator
Autodesk.Revit.Symbols..::.MEPBuildingConstructionSet
Autodesk.Revit.Symbols..::.MEPBuildingConstructionSetIterator
Autodesk.Revit.Symbols..::.MullionTypeSet
Autodesk.Revit.Symbols..::.MullionTypeSetIterator
Autodesk.Revit.Symbols..::.PanelTypeSet
Autodesk.Revit.Symbols..::.PanelTypeSetIterator
Autodesk.Revit.Symbols..::.PointLoadTypeSet
Autodesk.Revit.Symbols..::.PointLoadTypeSetIterator
Autodesk.Revit.Symbols..::.RebarBarTypeSet
Autodesk.Revit.Symbols..::.RebarBarTypeSetIterator
Autodesk.Revit.Symbols..::.RebarCoverTypeSet
Autodesk.Revit.Symbols..::.RebarCoverTypeSetIterator
Autodesk.Revit.Symbols..::.RebarHookTypeSet
Autodesk.Revit.Symbols..::.RebarHookTypeSetIterator
Autodesk.Revit.Symbols..::.RebarShapeDefinition
Autodesk.Revit.Symbols..::.RebarShapeSet
Autodesk.Revit.Symbols..::.RebarShapeSetIterator
Autodesk.Revit.Symbols..::.RoofTypeSet
Autodesk.Revit.Symbols..::.RoofTypeSetIterator
Autodesk.Revit.Symbols..::.RoomTagTypeSet
Autodesk.Revit.Symbols..::.RoomTagTypeSetIterator
Autodesk.Revit.Symbols..::.SlabEdgeTypeSet
Autodesk.Revit.Symbols..::.SlabEdgeTypeSetIterator
Autodesk.Revit.Symbols..::.SpaceTagTypeSet
Autodesk.Revit.Symbols..::.SpaceTagTypeSetIterator
Autodesk.Revit.Symbols..::.SpotDimensionTypeSet
Autodesk.Revit.Symbols..::.SpotDimensionTypeSetIterator
Autodesk.Revit.Symbols..::.TextNoteTypeSet
Autodesk.Revit.Symbols..::.TextNoteTypeSetIterator
Autodesk.Revit.Symbols..::.TrussTypeSet
Autodesk.Revit.Symbols..::.TrussTypeSetIterator
Autodesk.Revit.Symbols..::.WallTypeSet
Autodesk.Revit.Symbols..::.WallTypeSetIterator
Autodesk.Revit..::.TilePatterns
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetSet
Autodesk.Revit.Utility..::.AssetSetIterator
Autodesk.Revit..::.VertexIndexPairArray
Autodesk.Revit..::.VertexIndexPairArrayIterator
Autodesk.Revit..::.ViewSheetSetting

See Also

APIObject Members
Autodesk.Revit Namespace


APIObject Members

[image] [image]

Revit 2010 API
APIObject Members
APIObject Class Constructors Methods Properties See Also Send Feedback

The APIObject type exposes the following members.

Constructors

Name | Description
APIObject | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable.

See Also

APIObject Class
Autodesk.Revit Namespace


APIObject Constructor

[image]

Revit 2010 API
APIObject Constructor
APIObject Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public APIObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
APIObject()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

APIObject Class
Autodesk.Revit Namespace


APIObject Methods

[image] [image]

Revit 2010 API
APIObject Methods
APIObject Class See Also Send Feedback

The APIObject type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

APIObject Class
Autodesk.Revit Namespace


Dispose Method

[image]

Revit 2010 API
APIObject..::.Dispose Method
APIObject Class See Also Send Feedback
Causes the object to release immediately any resources it may be utilizing.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

Remarks

This method is usually called implicitly by the programming language when the object is destroyed. After calling this method the object will no longer work correctly.

See Also

APIObject Class
Autodesk.Revit Namespace


APIObject Properties

[image] [image]

Revit 2010 API
APIObject Properties
APIObject Class See Also Send Feedback

The APIObject type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable.

See Also

APIObject Class
Autodesk.Revit Namespace


IsReadOnly Property

[image]

Revit 2010 API
APIObject..::.IsReadOnly Property
APIObject Class Example See Also Send Feedback
Identifies if the object is read-only or modifiable.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

If true, the object may not be modified. If false, the object's contents may be modified.

Examples

CopyC#
Document project = application.ActiveDocument;
Settings settings = project.Settings;
MessageBox.Show("Categories: " + settings.Categories.IsReadOnly.ToString());
MessageBox.Show("Materials: " + settings.Materials.IsReadOnly.ToString());
CopyVB.NET
Dim project As Document = application.ActiveDocument
Dim settings As Settings = project.Settings
MessageBox.Show("Categories: " & settings.Categories.IsReadOnly.ToString())
MessageBox.Show("Materials: " & settings.Materials.IsReadOnly.ToString())

See Also

APIObject Class
Autodesk.Revit Namespace


Application Class

[image]

Revit 2010 API
Application Class
Members Example See Also Send Feedback
Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Application : APIObject
Visual Basic (Declaration)
Public Class Application _
    Inherits APIObject
Visual C++
public ref class Application : public APIObject

Examples

CopyC#
string versionInfo = application.VersionBuild + "\n"
                    + application.VersionName + "\n"
                    + application.VersionNumber;
CopyVB.NET
Dim versionInfo As String = ((application.VersionBuild & vbLf) + application.VersionName & vbLf) + application.VersionNumber

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Application

See Also

Application Members
Autodesk.Revit Namespace


Application Members

[image] [image]

Revit 2010 API
Application Members
Application Class Constructors Methods Properties Events See Also Send Feedback

The Application type exposes the following members.

Constructors

Name | Description
Application | For Internal Use Only.

Methods

Name | Description
CreateRibbonPanel | Create a new RibbonPanel.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractPartAtomFromFamilyFile | Writes a PartAtom XML from the contents of a family file.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRibbonPanels | Get all the custom Panels on Add-Ins tab of Revit.
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewFamilyDocument | New family document, including family, titleblock, and annotation symbol
NewProjectDocument | New project document
NewProjectTemplateDocument | New project template document
OpenDocumentFile | Overloaded. Opens a document from disk.
OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActiveDocument | Provides access to an object that represents the currently active project.
Assets |
Cities | Returns a set of all the known city locations within Revit.
Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Documents | Returns a set of documents within Revit.
IsQuiescent | Returns if the current application is quiescent.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Language | The language used in the current session of Revit.
LoadedApplications | Returns an array of successfully loaded external applications.
ObjectFactory | Provides an object that can be used to create other instances of Autodesk Revit API objects.
Options | Provides access to an object that represents the application wide settings available in Autodesk Revit.
Product | The product type for the current session of Revit.
RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
VersionBuild | Returns the internal build number of the Autodesk Revit application.
VersionName | Returns the name of the Revit application.
VersionNumber | Return the primary version of the Revit application.

Events

Name | Description
ApplicationClosing | Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
DialogBoxShowing | Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
DocumentClosed | Subscribe to the DocumentClosed event to be notified immediately after Revit has finished closing a document.
DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central file.
DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central file.
FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
OnDialogBox | Obsolete. This event is deprecated since Revit version 2010. Please use DialogBoxShowing event instead. Subscribe to the OnDialogBox event to be notified when an Autodesk Revit dialog box is displayed during an API external command.
OnDocumentClosed | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentClosed event instead. Subscribe to the OnDocumentClosed event to be notified after a document is closed.
OnDocumentNewed | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentCreated event instead. Subscribe to the OnDocumentNewed event to be notified after a new document has been created.
OnDocumentOpened | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentOpened event instead. Subscribe to the OnDocumentOpened event to be notified when a document is opened.
OnDocumentSaved | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentSaved event instead. Subscribe to the OnDocumentSaved event to be notified after a document is saved.
OnDocumentSavedAs | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentSavedAs event instead. Subscribe to the OnDocumentSavedAs event to be notified after a document is saved as a file with another name.
ViewActivated | Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
ViewActivating | Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.
ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

Application Class
Autodesk.Revit Namespace


Application Constructor

[image]

Revit 2010 API
Application Constructor
Application Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Application()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Application()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Application Class
Autodesk.Revit Namespace


Application Methods

[image] [image]

Revit 2010 API
Application Methods
Application Class See Also Send Feedback

The Application type exposes the following members.

Methods

Name | Description
CreateRibbonPanel | Create a new RibbonPanel.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractPartAtomFromFamilyFile | Writes a PartAtom XML from the contents of a family file.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRibbonPanels | Get all the custom Panels on Add-Ins tab of Revit.
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewFamilyDocument | New family document, including family, titleblock, and annotation symbol
NewProjectDocument | New project document
NewProjectTemplateDocument | New project template document
OpenDocumentFile | Overloaded. Opens a document from disk.
OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Application Class
Autodesk.Revit Namespace


CreateRibbonPanel Method

[image]

Revit 2010 API
Application..::.CreateRibbonPanel Method
Application Class See Also Send Feedback
Create a new RibbonPanel.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
    string panelName
)
Visual Basic (Declaration)
Public Overridable Function CreateRibbonPanel ( _
    panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
    String^ panelName
)

Parameters

panelName
Type: System..::.String

Remarks

This method will create a custom panel appending to the Revit AddIns tab. This method is not supported in VSTA.

Exceptions

Exception | Condition
System..::.ArgumentNullException | panelName is null.
System..::.ArgumentException | panelName is Empty.
System..::.InvalidOperationException | If more than 100 panels were created.

See Also

Application Class
Autodesk.Revit Namespace


ExtractPartAtomFromFamilyFile Method

[image]

Revit 2010 API
Application..::.ExtractPartAtomFromFamilyFile Method
Application Class See Also Send Feedback
Writes a PartAtom XML from the contents of a family file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ExtractPartAtomFromFamilyFile(
    string familyFilePath,
    string xmlFilePath
)
Visual Basic (Declaration)
Public Sub ExtractPartAtomFromFamilyFile ( _
    familyFilePath As String, _
    xmlFilePath As String _
)
Visual C++
public:
void ExtractPartAtomFromFamilyFile(
    String^ familyFilePath,
    String^ xmlFilePath
)

Parameters

familyFilePath
Type: System..::.String
The family file to be processed.
xmlFilePath
Type: System..::.String
The xml file to be saved.

Remarks

If there is a TXT type catalog next to the family file (a TXT file with the same name as the RFA file), the function will read it as well and process its contents into PartAtom.

Exceptions

Exception | Condition
System..::.ArgumentException | If 'familyFilePath' or 'xmlFilePath' is a null object or an empty string.
System..::.InvalidOperationException | If failed to extract PartAtom from the family file.

See Also

Application Class
Autodesk.Revit Namespace


GetRibbonPanels Method

[image]

Revit 2010 API
Application..::.GetRibbonPanels Method
Application Class See Also Send Feedback
Get all the custom Panels on Add-Ins tab of Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual List<RibbonPanel> GetRibbonPanels()
Visual Basic (Declaration)
Public Overridable Function GetRibbonPanels As List(Of RibbonPanel)
Visual C++
public:
virtual List<RibbonPanel^>^ GetRibbonPanels()

Remarks

The build-in panels won't be included. This method is not supported in VSTA.

See Also

Application Class
Autodesk.Revit Namespace


NewFamilyDocument Method

[image]

Revit 2010 API
Application..::.NewFamilyDocument Method
Application Class Example See Also Send Feedback
New family document, including family, titleblock, and annotation symbol

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Document NewFamilyDocument(
    string templateFileName
)
Visual Basic (Declaration)
Public Overridable Function NewFamilyDocument ( _
    templateFileName As String _
) As Document
Visual C++
public:
virtual Document^ NewFamilyDocument(
    String^ templateFileName
)

Parameters

templateFileName
Type: System..::.String
The template file name.

Remarks

It is correspond to the File->New->Family.../TitleBlock.../Annotation Symbol....

Examples

CopyC#
// create a new family document using Generic Model.rft template
string templateFileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Templates\Generic Model.rft";
Document familyDocument = application.NewFamilyDocument(templateFileName);
if (null == familyDocument)
{
    throw new Exception("Cannot open family document");
}
CopyVB.NET
' create a new family document using Generic Model.rft template
Dim templateFileName As String = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Templates\Generic Model.rft"
Dim familyDocument As Document = application.NewFamilyDocument(templateFileName)
If familyDocument Is Nothing Then
    Throw New Exception("Cannot open family document")
End If

Exceptions

Exception | Condition
System..::.ArgumentException | if 'templateFileName' is a null object or an empty string.
System..::.InvalidOperationException | if can not new a family document.

See Also

Application Class
Autodesk.Revit Namespace


NewProjectDocument Method

[image]

Revit 2010 API
Application..::.NewProjectDocument Method
Application Class See Also Send Feedback
New project document

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Document NewProjectDocument(
    string templateFileName
)
Visual Basic (Declaration)
Public Overridable Function NewProjectDocument ( _
    templateFileName As String _
) As Document
Visual C++
public:
virtual Document^ NewProjectDocument(
    String^ templateFileName
)

Parameters

templateFileName
Type: System..::.String
The template file name.

Remarks

This API command corresponds to the user-interface command File->New->Project....

Exceptions

Exception | Condition
System..::.ArgumentException | if 'templateFileName' is a null object or an empty string.
System..::.InvalidOperationException | if can not new a project document.

See Also

Application Class
Autodesk.Revit Namespace


NewProjectTemplateDocument Method

[image]

Revit 2010 API
Application..::.NewProjectTemplateDocument Method
Application Class See Also Send Feedback
New project template document

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Document NewProjectTemplateDocument(
    string templateFilename
)
Visual Basic (Declaration)
Public Overridable Function NewProjectTemplateDocument ( _
    templateFilename As String _
) As Document
Visual C++
public:
virtual Document^ NewProjectTemplateDocument(
    String^ templateFilename
)

Parameters

templateFilename
Type: System..::.String
The template file name.

Remarks

It is correspond to the File->New->Project....

Exceptions

Exception | Condition
System..::.ArgumentException | if 'templateFileName' is a null object or an empty string.
System..::.InvalidOperationException | if can not new a project template document.

See Also

Application Class
Autodesk.Revit Namespace


OpenDocumentFile Method

[image] [image]

Revit 2010 API
Application..::.OpenDocumentFile Method
Application Class See Also Send Feedback
Opens a document from disk.

Overload List

Name | Description
OpenDocumentFile(String) | Opens a document from disk.
OpenDocumentFile(String, PostedErrorArray) | Opens a document from disk.

See Also

Application Class
Application Members
Autodesk.Revit Namespace


OpenDocumentFile Method (String)

[image]

Revit 2010 API
Application..::.OpenDocumentFile Method (String)
Application Class See Also Send Feedback
Opens a document from disk.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Document OpenDocumentFile(
    string fileName
)
Visual Basic (Declaration)
Public Overridable Function OpenDocumentFile ( _
    fileName As String _
) As Document
Visual C++
public:
virtual Document^ OpenDocumentFile(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The file to be opened.

Remarks

It is correspond to the File->Open....

Exceptions

Exception | Condition
System..::.ArgumentException | if 'fileName' is a null object or an empty string.
System..::.InvalidOperationException | if can not open a file.

See Also

Application Class
OpenDocumentFile Overload
Autodesk.Revit Namespace


OpenDocumentFile Method (String, PostedErrorArray)

[image]

Revit 2010 API
Application..::.OpenDocumentFile Method (String, PostedErrorArray)
Application Class See Also Send Feedback
Opens a document from disk.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Document OpenDocumentFile(
    string fileName,
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Overridable Function OpenDocumentFile ( _
    fileName As String, _
    postedErrors As PostedErrorArray _
) As Document
Visual C++
public:
virtual Document^ OpenDocumentFile(
    String^ fileName,
    PostedErrorArray^ postedErrors
)

Parameters

fileName
Type: System..::.String
The file to be opened.
postedErrors
Type: Autodesk.Revit..::.PostedErrorArray
Would contain list of failures posted during the process.

Remarks

This method corresponds to the File->Open... menu command.

The 'postedErrors' parameter is used only when running Revit in UI-less mode.

Exceptions

Exception | Condition
System..::.ArgumentException | if 'fileName' is a null object or an empty string.
System..::.InvalidOperationException | if can not open a file.

See Also

Application Class
OpenDocumentFile Overload
Autodesk.Revit Namespace


OpenSharedParameterFile Method

[image]

Revit 2010 API
Application..::.OpenSharedParameterFile Method
Application Class See Also Send Feedback
Enables access to shared parameter groups and definitions that are maintained on disk.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DefinitionFile OpenSharedParameterFile()
Visual Basic (Declaration)
Public Function OpenSharedParameterFile As DefinitionFile
Visual C++
public:
DefinitionFile^ OpenSharedParameterFile()

Return Value

An object that represents a shared parameters file.

Remarks

This function is used to return an object that represents a Revit shared parameters file that exists on disk. Revit can use only one shared parameters file at any one time. The filename for the shared parameters file can be set in the Revit Application Options object. If the file does not exist and error will be created and an empty reference will be returned.

See Also

Application Class
Autodesk.Revit Namespace


Application Properties

[image] [image]

Revit 2010 API
Application Properties
Application Class See Also Send Feedback

The Application type exposes the following members.

Properties

Name | Description
ActiveDocument | Provides access to an object that represents the currently active project.
Assets |
Cities | Returns a set of all the known city locations within Revit.
Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Documents | Returns a set of documents within Revit.
IsQuiescent | Returns if the current application is quiescent.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Language | The language used in the current session of Revit.
LoadedApplications | Returns an array of successfully loaded external applications.
ObjectFactory | Provides an object that can be used to create other instances of Autodesk Revit API objects.
Options | Provides access to an object that represents the application wide settings available in Autodesk Revit.
Product | The product type for the current session of Revit.
RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
VersionBuild | Returns the internal build number of the Autodesk Revit application.
VersionName | Returns the name of the Revit application.
VersionNumber | Return the primary version of the Revit application.

See Also

Application Class
Autodesk.Revit Namespace


ActiveDocument Property

[image]

Revit 2010 API
Application..::.ActiveDocument Property
Application Class See Also Send Feedback
Provides access to an object that represents the currently active project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Document ActiveDocument { get; set; }
Visual Basic (Declaration)
Public Overridable Property ActiveDocument As Document
Visual C++
public:
virtual property Document^ ActiveDocument {
    Document^ get ();
    void set (Document^ value);
}

Remarks

External API commands can access this property in read-oly mode only! The ability to modify the property is reserved for future implementations.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when attempting to modify the property.

See Also

Application Class
Autodesk.Revit Namespace


Assets Property

[image]

Revit 2010 API
Application..::.Assets Property
Application Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AssetSet Assets[
    AssetType
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Assets ( _
     As AssetType _
) As AssetSet
Visual C++
public:
property AssetSet^ Assets[AssetType ] {
    AssetSet^ get (AssetType );
}

Parameters

Type: Autodesk.Revit.Enums..::.AssetType

See Also

Application Class
Autodesk.Revit Namespace


Cities Property

[image]

Revit 2010 API
Application..::.Cities Property
Application Class Example See Also Send Feedback
Returns a set of all the known city locations within Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CitySet Cities { get; }
Visual Basic (Declaration)
Public ReadOnly Property Cities As CitySet
Visual C++
public:
property CitySet^ Cities {
    CitySet^ get ();
}

Remarks

Each city has information about longitude, latitude etc.

Examples

CopyC#
// Get all revit support cities
Autodesk.Revit.Site.CitySet cities = application.Cities;

// Set all Revit support cities into an ArrayList
System.Collections.ArrayList cityList = new System.Collections.ArrayList();
foreach (Autodesk.Revit.Site.City city in cities)
{
    cityList.Add(city);
}
CopyVB.NET
' Get all revit support cities
Dim cities As Autodesk.Revit.Site.CitySet = application.Cities

' Set all Revit support cities into an ArrayList
Dim cityList As New System.Collections.ArrayList()
For Each city As Autodesk.Revit.Site.City In cities
    cityList.Add(city)
Next

See Also

Application Class
Autodesk.Revit Namespace


Create Property

[image]

Revit 2010 API
Application..::.Create Property
Application Class See Also Send Feedback
Provides an object that can be used to create new instances of Autodesk Revit API objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Application Create { get; }
Visual Basic (Declaration)
Public ReadOnly Property Create As Application
Visual C++
public:
property Application^ Create {
    Application^ get ();
}

Remarks

The Create property returns an object that is used to create application wide utility and geometric objects within the Autodesk Revit API, such as arrays, sets, lines. This object should be used when you wish to create an object within the Autodesk Revit application memory, rather than your own application's memory. If you are performing your own memory management techniques then it is advisable to create any utility objects via the Create object. For example: Instead of Dim set As New Autodesk_Revit_ElementSet do Set set = application.Create.NewElementSet()

See Also

Application Class
Autodesk.Revit Namespace


Documents Property

[image]

Revit 2010 API
Application..::.Documents Property
Application Class See Also Send Feedback
Returns a set of documents within Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DocumentSet Documents { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Documents As DocumentSet
Visual C++
public:
virtual property DocumentSet^ Documents {
    DocumentSet^ get ();
}

Remarks

This property can be used for the user to find all the document inside Revit.

See Also

Application Class
Autodesk.Revit Namespace


IsQuiescent Property

[image]

Revit 2010 API
Application..::.IsQuiescent Property
Application Class See Also Send Feedback
Returns if the current application is quiescent.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsQuiescent { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsQuiescent As Boolean
Visual C++
public:
property bool IsQuiescent {
    bool get ();
}

Remarks

This property can be used check if the current application is quiescent. If any document in of the current application is in editing mode or the In-place family is being edited, it returns false. Otherwise, true will be returned.

See Also

Application Class
Autodesk.Revit Namespace


Language Property

[image]

Revit 2010 API
Application..::.Language Property
Application Class See Also Send Feedback
The language used in the current session of Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LanguageType Language { get; }
Visual Basic (Declaration)
Public ReadOnly Property Language As LanguageType
Visual C++
public:
property LanguageType Language {
    LanguageType get ();
}

Remarks

Use this property to determine the language used by Revit; this can allow your application to load the appropriate resources.

See Also

Application Class
Autodesk.Revit Namespace


LoadedApplications Property

[image]

Revit 2010 API
Application..::.LoadedApplications Property
Application Class See Also Send Feedback
Returns an array of successfully loaded external applications.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ExternalApplicationArray LoadedApplications { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property LoadedApplications As ExternalApplicationArray
Visual C++
public:
virtual property ExternalApplicationArray^ LoadedApplications {
    ExternalApplicationArray^ get ();
}

Remarks

This property can be used by your application to find all successfully loaded external applications when Revit starts.

See Also

Application Class
Autodesk.Revit Namespace


ObjectFactory Property

[image]

Revit 2010 API
Application..::.ObjectFactory Property
Application Class See Also Send Feedback
Provides an object that can be used to create other instances of Autodesk Revit API objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ObjectFactory ObjectFactory { get; }
Visual Basic (Declaration)
Public ReadOnly Property ObjectFactory As ObjectFactory
Visual C++
public:
property ObjectFactory^ ObjectFactory {
    ObjectFactory^ get ();
}

Remarks

Returns an object factory object that can create other objects. This property is available for advanced use cases only. For general purpose creation of Autodesk Revit API objects use the Application.Create object.

See Also

Application Class
Autodesk.Revit Namespace


Options Property

[image]

Revit 2010 API
Application..::.Options Property
Application Class See Also Send Feedback
Provides access to an object that represents the application wide settings available in Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Application Options { get; }
Visual Basic (Declaration)
Public ReadOnly Property Options As Application
Visual C++
public:
property Application^ Options {
    Application^ get ();
}

Remarks

This property return the Revit Options object which exposes some of the options available in the Revit Options dialog available from the Settings, Options – menu.

See Also

Application Class
Autodesk.Revit Namespace


Product Property

[image]

Revit 2010 API
Application..::.Product Property
Application Class See Also Send Feedback
The product type for the current session of Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProductType Product { get; }
Visual Basic (Declaration)
Public ReadOnly Property Product As ProductType
Visual C++
public:
property ProductType Product {
    ProductType get ();
}

See Also

Application Class
Autodesk.Revit Namespace


RecordingJournalFilename Property

[image]

Revit 2010 API
Application..::.RecordingJournalFilename Property
Application Class See Also Send Feedback
Retrieve the name of the journal file the Revit is currently recording to.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string RecordingJournalFilename { get; }
Visual Basic (Declaration)
Public ReadOnly Property RecordingJournalFilename As String
Visual C++
public:
property String^ RecordingJournalFilename {
    String^ get ();
}

Remarks

As Revit operates it keeps a log of operations that the user performs within a file, known as a journal file.These files are useful for providing information about the actions performed in a session and the state of Revit when a problem occurs. These files are included during error reporting to Autodesk.

See Also

Application Class
Autodesk.Revit Namespace


VersionBuild Property

[image]

Revit 2010 API
Application..::.VersionBuild Property
Application Class See Also Send Feedback
Returns the internal build number of the Autodesk Revit application.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string VersionBuild { get; }
Visual Basic (Declaration)
Public ReadOnly Property VersionBuild As String
Visual C++
public:
property String^ VersionBuild {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Autodesk Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Autodesk Revit.

See Also

Application Class
Autodesk.Revit Namespace


VersionName Property

[image]

Revit 2010 API
Application..::.VersionName Property
Application Class See Also Send Feedback
Returns the name of the Revit application.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string VersionName { get; }
Visual Basic (Declaration)
Public ReadOnly Property VersionName As String
Visual C++
public:
property String^ VersionName {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.

See Also

Application Class
Autodesk.Revit Namespace


VersionNumber Property

[image]

Revit 2010 API
Application..::.VersionNumber Property
Application Class See Also Send Feedback
Return the primary version of the Revit application.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string VersionNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property VersionNumber As String
Visual C++
public:
property String^ VersionNumber {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.

See Also

Application Class
Autodesk.Revit Namespace


Application Events

[image] [image]

Revit 2010 API
Application Events
Application Class See Also Send Feedback

The Application type exposes the following members.

Events

Name | Description
ApplicationClosing | Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
DialogBoxShowing | Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
DocumentClosed | Subscribe to the DocumentClosed event to be notified immediately after Revit has finished closing a document.
DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central file.
DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central file.
FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
OnDialogBox | Obsolete. This event is deprecated since Revit version 2010. Please use DialogBoxShowing event instead. Subscribe to the OnDialogBox event to be notified when an Autodesk Revit dialog box is displayed during an API external command.
OnDocumentClosed | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentClosed event instead. Subscribe to the OnDocumentClosed event to be notified after a document is closed.
OnDocumentNewed | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentCreated event instead. Subscribe to the OnDocumentNewed event to be notified after a new document has been created.
OnDocumentOpened | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentOpened event instead. Subscribe to the OnDocumentOpened event to be notified when a document is opened.
OnDocumentSaved | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentSaved event instead. Subscribe to the OnDocumentSaved event to be notified after a document is saved.
OnDocumentSavedAs | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentSavedAs event instead. Subscribe to the OnDocumentSavedAs event to be notified after a document is saved as a file with another name.
ViewActivated | Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
ViewActivating | Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.
ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

Application Class
Autodesk.Revit Namespace


ApplicationClosing Event

[image]

Revit 2010 API
Application..::.ApplicationClosing Event
Application Class See Also Send Feedback
Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<ApplicationClosingEventArgs> ApplicationClosing
Visual Basic (Declaration)
Public Event ApplicationClosing As EventHandler(Of ApplicationClosingEventArgs)
Visual C++
public:
 event EventHandler<ApplicationClosingEventArgs^>^ ApplicationClosing {
    void add (EventHandler<ApplicationClosingEventArgs^>^ value);
    void remove (EventHandler<ApplicationClosingEventArgs^>^ value);
}

Remarks

This event is raised when the Revit application is just about to be closed.

Event is not cancellable. The 'Cancellable' property of event’s argument is always 'false'.

No document may be modified at the time of the event.

The sender object of this event is Application object.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


DialogBoxShowing Event

[image]

Revit 2010 API
Application..::.DialogBoxShowing Event
Application Class See Also Send Feedback
Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DialogBoxShowingEventArgs> DialogBoxShowing
Visual Basic (Declaration)
Public Event DialogBoxShowing As EventHandler(Of DialogBoxShowingEventArgs)
Visual C++
public:
 event EventHandler<DialogBoxShowingEventArgs^>^ DialogBoxShowing {
    void add (EventHandler<DialogBoxShowingEventArgs^>^ value);
    void remove (EventHandler<DialogBoxShowingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to show a dialog box or a message box.

Event is not cancellable. The 'Cancellable' property of event’s argument is always 'false'.

Depending on the type of the dialog that is being shown, the event's argument's type varies as follows: When it is a dialog box, the event’s argument is an object of DialogBoxShowingEventArgs. When it is a message box, the event’s argument is an object of MessageBoxShowingEventArgs,which is subclass of DialogBoxShowingEventArgs. When it is a task dialog, the event’s argument is an object of TaskDialogShowingEventArgs,which is subclass of DialogBoxShowingEventArgs.

No document may be modified during this event.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

The DialogBoxShowing event is meant to replace the older OnDialogBox event, which is now Obsolete.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


DocumentClosed Event

[image]

Revit 2010 API
Application..::.DocumentClosed Event
Application Class See Also Send Feedback
Subscribe to the DocumentClosed event to be notified immediately after Revit has finished closing a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentClosedEventArgs> DocumentClosed
Visual Basic (Declaration)
Public Event DocumentClosed As EventHandler(Of DocumentClosedEventArgs)
Visual C++
public:
 event EventHandler<DocumentClosedEventArgs^>^ DocumentClosed {
    void add (EventHandler<DocumentClosedEventArgs^>^ value);
    void remove (EventHandler<DocumentClosedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished closing a document. It is raised even when document closing failed or was cancelled (during DocumentClosing event).

This event is not cancellable, for the process of closing document has already been finished.

The closed document cannot be modified, in fact, user has no way to access it in the event handler.

The DocumentClosed event is meant to replace the older OnDocumentClosed event, which is now Obsolete.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


DocumentClosing Event

[image]

Revit 2010 API
Application..::.DocumentClosing Event
Application Class See Also Send Feedback
Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentClosingEventArgs> DocumentClosing
Visual Basic (Declaration)
Public Event DocumentClosing As EventHandler(Of DocumentClosingEventArgs)
Visual C++
public:
 event EventHandler<DocumentClosingEventArgs^>^ DocumentClosing {
    void add (EventHandler<DocumentClosingEventArgs^>^ value);
    void remove (EventHandler<DocumentClosingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to close a document.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to 'true' to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may not be modified during this event.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentClosed event will be raised immediately after document is closed.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


DocumentCreated Event

[image]

Revit 2010 API
Application..::.DocumentCreated Event
Application Class See Also Send Feedback
Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentCreatedEventArgs> DocumentCreated
Visual Basic (Declaration)
Public Event DocumentCreated As EventHandler(Of DocumentCreatedEventArgs)
Visual C++
public:
 event EventHandler<DocumentCreatedEventArgs^>^ DocumentCreated {
    void add (EventHandler<DocumentCreatedEventArgs^>^ value);
    void remove (EventHandler<DocumentCreatedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished creating a new document. It is raised even when document creation failed or was cancelled (during DocumentCreating event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not. This event is not cancellable, for the process of document creation has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

The DocumentCreated event is meant to replace the older OnDocumentNewed event, which is now Obsolete.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


DocumentCreating Event

[image]

Revit 2010 API
Application..::.DocumentCreating Event
Application Class See Also Send Feedback
Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentCreatingEventArgs> DocumentCreating
Visual Basic (Declaration)
Public Event DocumentCreating As EventHandler(Of DocumentCreatingEventArgs)
Visual C++
public:
 event EventHandler<DocumentCreatingEventArgs^>^ DocumentCreating {
    void add (EventHandler<DocumentCreatingEventArgs^>^ value);
    void remove (EventHandler<DocumentCreatingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to create a new document.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to 'true'. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document cannot be modified, for it is not created yet at the time of the event.

Please be aware that the following API functions are not available for the current document during this event:

  • NewProjectDocument(String)
  • NewFamilyDocument(String)
  • NewProjectTemplateDocument(String)
  • OpenDocumentFile(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentCreated event will be raised immediately after document creation is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


DocumentOpened Event

[image]

Revit 2010 API
Application..::.DocumentOpened Event
Application Class See Also Send Feedback
Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentOpenedEventArgs> DocumentOpened
Visual Basic (Declaration)
Public Event DocumentOpened As EventHandler(Of DocumentOpenedEventArgs)
Visual C++
public:
 event EventHandler<DocumentOpenedEventArgs^>^ DocumentOpened {
    void add (EventHandler<DocumentOpenedEventArgs^>^ value);
    void remove (EventHandler<DocumentOpenedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished opening a document. It is raised even when document opening failed or was cancelled (during DocumentOpening event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of opening document has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

The DocumentOpened event is meant to replace the older OnDocumentOpened event, which is now Obsolete.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


DocumentOpening Event

[image]

Revit 2010 API
Application..::.DocumentOpening Event
Application Class See Also Send Feedback
Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentOpeningEventArgs> DocumentOpening
Visual Basic (Declaration)
Public Event DocumentOpening As EventHandler(Of DocumentOpeningEventArgs)
Visual C++
public:
 event EventHandler<DocumentOpeningEventArgs^>^ DocumentOpening {
    void add (EventHandler<DocumentOpeningEventArgs^>^ value);
    void remove (EventHandler<DocumentOpeningEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to open a document.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to 'true'. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document cannot be modified, for it is not opened yet at the time of the event.

Another DocumentOpened event will be raised immediately after document is opened.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


DocumentPrinted Event

[image]

Revit 2010 API
Application..::.DocumentPrinted Event
Application Class See Also Send Feedback
Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentPrintedEventArgs> DocumentPrinted
Visual Basic (Declaration)
Public Event DocumentPrinted As EventHandler(Of DocumentPrintedEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintedEventArgs^>^ DocumentPrinted {
    void add (EventHandler<DocumentPrintedEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view or ViewSet of the document. It is raised even when document printing failed or was cancelled (during DocumentPriting event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of printing has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


DocumentPrinting Event

[image]

Revit 2010 API
Application..::.DocumentPrinting Event
Application Class See Also Send Feedback
Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentPrintingEventArgs> DocumentPrinting
Visual Basic (Declaration)
Public Event DocumentPrinting As EventHandler(Of DocumentPrintingEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintingEventArgs^>^ DocumentPrinting {
    void add (EventHandler<DocumentPrintingEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view or ViewSet of the document.

This event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to 'true'. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Export(String, String, GBXMLExportOptions) and similar overloads.
  • Autodesk.Revit.Document.Print()
  • Print()()() and similar overloads.
  • SubmitPrint()()() and similar overloads.
  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

After this event, for each view being printed,ViewPrinting and ViewPrinted events will be raised. Another event DocumentPrinted will be raised immediately after document printing is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


DocumentSaved Event

[image]

Revit 2010 API
Application..::.DocumentSaved Event
Application Class See Also Send Feedback
Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentSavedEventArgs> DocumentSaved
Visual Basic (Declaration)
Public Event DocumentSaved As EventHandler(Of DocumentSavedEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedEventArgs^>^ DocumentSaved {
    void add (EventHandler<DocumentSavedEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving a document. Note that the first save of a newly created document will raise DocumentSavedAs rather than the DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSaving event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

The DocumentSaved event is meant to replace the older OnDocumentSaved event, which is now Obsolete.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


DocumentSavedAs Event

[image]

Revit 2010 API
Application..::.DocumentSavedAs Event
Application Class See Also Send Feedback
Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentSavedAsEventArgs> DocumentSavedAs
Visual Basic (Declaration)
Public Event DocumentSavedAs As EventHandler(Of DocumentSavedAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedAsEventArgs^>^ DocumentSavedAs {
    void add (EventHandler<DocumentSavedAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedAsEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving document with a new file name. Note that the first save of a newly created document will raise DocumentSavedAs rather than DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSavingAs event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

The DocumentSavedAs event is meant to replace the older OnDocumentSavedAs event, which is now Obsolete.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


DocumentSaving Event

[image]

Revit 2010 API
Application..::.DocumentSaving Event
Application Class See Also Send Feedback
Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentSavingEventArgs> DocumentSaving
Visual Basic (Declaration)
Public Event DocumentSaving As EventHandler(Of DocumentSavingEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingEventArgs^>^ DocumentSaving {
    void add (EventHandler<DocumentSavingEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document. Note that the first save of a newly created document will raise DocumentSavingAs rather than the DocumentSaving event.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to 'true' to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSaved will be raised immediately after the document has been saved.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


DocumentSavingAs Event

[image]

Revit 2010 API
Application..::.DocumentSavingAs Event
Application Class See Also Send Feedback
Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentSavingAsEventArgs> DocumentSavingAs
Visual Basic (Declaration)
Public Event DocumentSavingAs As EventHandler(Of DocumentSavingAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingAsEventArgs^>^ DocumentSavingAs {
    void add (EventHandler<DocumentSavingAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingAsEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document with a new file name. Note that the first save of a newly created document will raise DocumentSavingAs rather than DocumentSaving event.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to 'true' to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSavedAs will be raised immediately after the document has been saved with a new file name.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


DocumentSynchronizedWithCentral Event

[image]

Revit 2010 API
Application..::.DocumentSynchronizedWithCentral Event
Application Class See Also Send Feedback
Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentSynchronizedWithCentralEventArgs> DocumentSynchronizedWithCentral
Visual Basic (Declaration)
Public Event DocumentSynchronizedWithCentral As EventHandler(Of DocumentSynchronizedWithCentralEventArgs)
Visual C++
public:
 event EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ DocumentSynchronizedWithCentral {
    void add (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished synchronizing a document with central file. It is raised even when document synchronizing with central file failed or was cancelled (during DocumentSynchronizingWithCentral event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of synchronizing a document with central file has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


DocumentSynchronizingWithCentral Event

[image]

Revit 2010 API
Application..::.DocumentSynchronizingWithCentral Event
Application Class See Also Send Feedback
Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentSynchronizingWithCentralEventArgs> DocumentSynchronizingWithCentral
Visual Basic (Declaration)
Public Event DocumentSynchronizingWithCentral As EventHandler(Of DocumentSynchronizingWithCentralEventArgs)
Visual C++
public:
 event EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ DocumentSynchronizingWithCentral {
    void add (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to synchronize a document with central file.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to 'true'. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentSynchronizedWithCentral event will be raised immediately after document synchronizing with central file is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


FileExported Event

[image]

Revit 2010 API
Application..::.FileExported Event
Application Class See Also Send Feedback
Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<FileExportedEventArgs> FileExported
Visual Basic (Declaration)
Public Event FileExported As EventHandler(Of FileExportedEventArgs)
Visual C++
public:
 event EventHandler<FileExportedEventArgs^>^ FileExported {
    void add (EventHandler<FileExportedEventArgs^>^ value);
    void remove (EventHandler<FileExportedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished exporting files of formats supported by the API. It is raised even when file exporting failed or was cancelled (during FileExporting event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not. If export is a part of ‘Publish to Buzzsaw’ command which consists of two parts – export of a document followed by publishing it to a BuzzSaw server, the event status only reflects the result of the Export action. The publishing part of the command could still be cancelled or could fail after FileExported event is raised.

This event is not cancellable, for the process of exporting file has already been finished.

If the Export action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


FileExporting Event

[image]

Revit 2010 API
Application..::.FileExporting Event
Application Class See Also Send Feedback
Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<FileExportingEventArgs> FileExporting
Visual Basic (Declaration)
Public Event FileExporting As EventHandler(Of FileExportingEventArgs)
Visual C++
public:
 event EventHandler<FileExportingEventArgs^>^ FileExporting {
    void add (EventHandler<FileExportingEventArgs^>^ value);
    void remove (EventHandler<FileExportingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to export files of formats supported by the API.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to 'true'. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Export(String, String, GBXMLExportOptions) and similar overloads.
  • Autodesk.Revit.Document.Print()
  • Print()()() and similar overloads.
  • SubmitPrint()()() and similar overloads.
  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileExported event will be raised immediately after file exporting is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


FileImported Event

[image]

Revit 2010 API
Application..::.FileImported Event
Application Class See Also Send Feedback
Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<FileImportedEventArgs> FileImported
Visual Basic (Declaration)
Public Event FileImported As EventHandler(Of FileImportedEventArgs)
Visual C++
public:
 event EventHandler<FileImportedEventArgs^>^ FileImported {
    void add (EventHandler<FileImportedEventArgs^>^ value);
    void remove (EventHandler<FileImportedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished importing a file of format supported by the API. It is raised even when file importing failed or was cancelled (during FileImporting event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of importing has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


FileImporting Event

[image]

Revit 2010 API
Application..::.FileImporting Event
Application Class See Also Send Feedback
Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<FileImportingEventArgs> FileImporting
Visual Basic (Declaration)
Public Event FileImporting As EventHandler(Of FileImportingEventArgs)
Visual C++
public:
 event EventHandler<FileImportingEventArgs^>^ FileImporting {
    void add (EventHandler<FileImportingEventArgs^>^ value);
    void remove (EventHandler<FileImportingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to import a file of format supported by the API.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to 'true'. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event. A transaction is already created at the time of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Import(String, GBXMLImportOptions) and similar overloads.
  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileImported event will be raised immediately after file importing is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


OnDialogBox Event

[image]

Revit 2010 API
Application..::.OnDialogBox Event
Application Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DialogBoxShowing event instead. Subscribe to the OnDialogBox event to be notified when an Autodesk Revit dialog box is displayed during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DialogBoxShowing event instead.")]
public event DialogBoxEventHandler OnDialogBox
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DialogBoxShowing event instead.")> _
Public Event OnDialogBox As DialogBoxEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DialogBoxShowing event instead.")]
public:
 event DialogBoxEventHandler^ OnDialogBox {
    void add (DialogBoxEventHandler^ value);
    void remove (DialogBoxEventHandler^ value);
}

Remarks

Sometimes an Autodesk Revit dialog box may be displayed during an API command. By subscribing to this event the application will be notified of such an event and can perform an action, such as dismissing the dialog automatically.

See Also

Application Class
Autodesk.Revit Namespace


OnDocumentClosed Event

[image]

Revit 2010 API
Application..::.OnDocumentClosed Event
Application Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentClosed event instead. Subscribe to the OnDocumentClosed event to be notified after a document is closed.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentClosed event instead.")]
public event DocumentClosedEventHandler OnDocumentClosed
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentClosed event instead.")> _
Public Event OnDocumentClosed As DocumentClosedEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentClosed event instead.")]
public:
 event DocumentClosedEventHandler^ OnDocumentClosed {
    void add (DocumentClosedEventHandler^ value);
    void remove (DocumentClosedEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document has been closed during an API command. By subscribing to this event the application will be notified after such an event and can perform an action in response.

See Also

Application Class
Autodesk.Revit Namespace


OnDocumentNewed Event

[image]

Revit 2010 API
Application..::.OnDocumentNewed Event
Application Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentCreated event instead. Subscribe to the OnDocumentNewed event to be notified after a new document has been created.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentCreated event instead.")]
public event DocumentNewedEventHandler OnDocumentNewed
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentCreated event instead.")> _
Public Event OnDocumentNewed As DocumentNewedEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentCreated event instead.")]
public:
 event DocumentNewedEventHandler^ OnDocumentNewed {
    void add (DocumentNewedEventHandler^ value);
    void remove (DocumentNewedEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a new document has been created. By subscribing to this event the application will be notified after such an event and can perform an action in response.

See Also

Application Class
Autodesk.Revit Namespace


OnDocumentOpened Event

[image]

Revit 2010 API
Application..::.OnDocumentOpened Event
Application Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentOpened event instead. Subscribe to the OnDocumentOpened event to be notified when a document is opened.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentOpened event instead.")]
public event DocumentOpenedEventHandler OnDocumentOpened
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentOpened event instead.")> _
Public Event OnDocumentOpened As DocumentOpenedEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentOpened event instead.")]
public:
 event DocumentOpenedEventHandler^ OnDocumentOpened {
    void add (DocumentOpenedEventHandler^ value);
    void remove (DocumentOpenedEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document has been opened. By subscribing to this event the application will be notified after such an event and can perform an action in response.

See Also

Application Class
Autodesk.Revit Namespace


OnDocumentSaved Event

[image]

Revit 2010 API
Application..::.OnDocumentSaved Event
Application Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentSaved event instead. Subscribe to the OnDocumentSaved event to be notified after a document is saved.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSaved event instead.")]
public event DocumentSavedEventHandler OnDocumentSaved
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSaved event instead.")> _
Public Event OnDocumentSaved As DocumentSavedEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentSaved event instead.")]
public:
 event DocumentSavedEventHandler^ OnDocumentSaved {
    void add (DocumentSavedEventHandler^ value);
    void remove (DocumentSavedEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document has been saved. By subscribing to this event the application will be notified after such an event and can perform an action in response.

See Also

Application Class
Autodesk.Revit Namespace


OnDocumentSavedAs Event

[image]

Revit 2010 API
Application..::.OnDocumentSavedAs Event
Application Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentSavedAs event instead. Subscribe to the OnDocumentSavedAs event to be notified after a document is saved as a file with another name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSavedAs event instead.")]
public event DocumentSavedAsEventHandler OnDocumentSavedAs
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSavedAs event instead.")> _
Public Event OnDocumentSavedAs As DocumentSavedAsEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentSavedAs event instead.")]
public:
 event DocumentSavedAsEventHandler^ OnDocumentSavedAs {
    void add (DocumentSavedAsEventHandler^ value);
    void remove (DocumentSavedAsEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document has been saved to a file with another name. By subscribing to this event the application will be notified after such an event and can perform an action in response.

See Also

Application Class
Autodesk.Revit Namespace


ViewActivated Event

[image]

Revit 2010 API
Application..::.ViewActivated Event
Application Class See Also Send Feedback
Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<ViewActivatedEventArgs> ViewActivated
Visual Basic (Declaration)
Public Event ViewActivated As EventHandler(Of ViewActivatedEventArgs)
Visual C++
public:
 event EventHandler<ViewActivatedEventArgs^>^ ViewActivated {
    void add (EventHandler<ViewActivatedEventArgs^>^ value);
    void remove (EventHandler<ViewActivatedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished activating a view of the document. It is raised even when view activating failed or was cancelled (during ViewActivating event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of view activating has already been finished.

The document may not be modified during this event.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


ViewActivating Event

[image]

Revit 2010 API
Application..::.ViewActivating Event
Application Class See Also Send Feedback
Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<ViewActivatingEventArgs> ViewActivating
Visual Basic (Declaration)
Public Event ViewActivating As EventHandler(Of ViewActivatingEventArgs)
Visual C++
public:
 event EventHandler<ViewActivatingEventArgs^>^ ViewActivating {
    void add (EventHandler<ViewActivatingEventArgs^>^ value);
    void remove (EventHandler<ViewActivatingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to activate a view of the document.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to 'true'. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may not be modified during this event.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another ViewActivated event will be raised immediately after view activating is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


ViewPrinted Event

[image]

Revit 2010 API
Application..::.ViewPrinted Event
Application Class See Also Send Feedback
Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<ViewPrintedEventArgs> ViewPrinted
Visual Basic (Declaration)
Public Event ViewPrinted As EventHandler(Of ViewPrintedEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintedEventArgs^>^ ViewPrinted {
    void add (EventHandler<ViewPrintedEventArgs^>^ value);
    void remove (EventHandler<ViewPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view of the document. It is raised even when view printing failed.

Check the 'Status' field in event’s argument to see whether the action was successful or not.

This event is not cancellable, for the process of view printing has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


ViewPrinting Event

[image]

Revit 2010 API
Application..::.ViewPrinting Event
Application Class See Also Send Feedback
Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<ViewPrintingEventArgs> ViewPrinting
Visual Basic (Declaration)
Public Event ViewPrinting As EventHandler(Of ViewPrintingEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintingEventArgs^>^ ViewPrinting {
    void add (EventHandler<ViewPrintingEventArgs^>^ value);
    void remove (EventHandler<ViewPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view of the document.

Event is not cancellable. The 'Cancellable' property of event’s argument is always 'false'.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Export(String, String, GBXMLExportOptions) and similar overloads.
  • Autodesk.Revit.Document.Print()
  • Print()()() and similar overloads.
  • SubmitPrint()()() and similar overloads.
  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewPrinted will be raised immediately after view printing is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace


BuildingSiteExportOptions Class

[image]

Revit 2010 API
BuildingSiteExportOptions Class
Members See Also Send Feedback
Building Site Export options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BuildingSiteExportOptions
Visual Basic (Declaration)
Public Class BuildingSiteExportOptions
Visual C++
public ref class BuildingSiteExportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.BuildingSiteExportOptions

See Also

BuildingSiteExportOptions Members
Autodesk.Revit Namespace


BuildingSiteExportOptions Members

[image] [image]

Revit 2010 API
BuildingSiteExportOptions Members
BuildingSiteExportOptions Class Constructors Methods Properties See Also Send Feedback

The BuildingSiteExportOptions type exposes the following members.

Constructors

Name | Description
BuildingSiteExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AreaPerPerson | Custom value for Area Per Person value.
PropertyLine | Optional property Line to export; it may be null.
PropertyLineOffset | Property Line Offset. Default is 0.0.
TotalGrossArea | Custom value for the total area.
TotalOccupancy | Custom value for the total occupancy.

See Also

BuildingSiteExportOptions Class
Autodesk.Revit Namespace


BuildingSiteExportOptions Constructor

[image]

Revit 2010 API
BuildingSiteExportOptions Constructor
BuildingSiteExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BuildingSiteExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BuildingSiteExportOptions()

See Also

BuildingSiteExportOptions Class
Autodesk.Revit Namespace


BuildingSiteExportOptions Methods

[image] [image]

Revit 2010 API
BuildingSiteExportOptions Methods
BuildingSiteExportOptions Class See Also Send Feedback

The BuildingSiteExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BuildingSiteExportOptions Class
Autodesk.Revit Namespace


BuildingSiteExportOptions Properties

[image] [image]

Revit 2010 API
BuildingSiteExportOptions Properties
BuildingSiteExportOptions Class See Also Send Feedback

The BuildingSiteExportOptions type exposes the following members.

Properties

Name | Description
AreaPerPerson | Custom value for Area Per Person value.
PropertyLine | Optional property Line to export; it may be null.
PropertyLineOffset | Property Line Offset. Default is 0.0.
TotalGrossArea | Custom value for the total area.
TotalOccupancy | Custom value for the total occupancy.

See Also

BuildingSiteExportOptions Class
Autodesk.Revit Namespace


AreaPerPerson Property

[image]

Revit 2010 API
BuildingSiteExportOptions..::.AreaPerPerson Property
BuildingSiteExportOptions Class See Also Send Feedback
Custom value for Area Per Person value.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double AreaPerPerson { get; set; }
Visual Basic (Declaration)
Public Property AreaPerPerson As Double
Visual C++
public:
property double AreaPerPerson {
    double get ();
    void set (double value);
}

Remarks

If specified value > 0.0, the value will be used instead of the default value calculated internally.

See Also

BuildingSiteExportOptions Class
Autodesk.Revit Namespace


PropertyLine Property

[image]

Revit 2010 API
BuildingSiteExportOptions..::.PropertyLine Property
BuildingSiteExportOptions Class See Also Send Feedback
Optional property Line to export; it may be null.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PropertyLine PropertyLine { get; set; }
Visual Basic (Declaration)
Public Property PropertyLine As PropertyLine
Visual C++
public:
property PropertyLine^ PropertyLine {
    PropertyLine^ get ();
    void set (PropertyLine^ value);
}

See Also

BuildingSiteExportOptions Class
Autodesk.Revit Namespace


PropertyLineOffset Property

[image]

Revit 2010 API
BuildingSiteExportOptions..::.PropertyLineOffset Property
BuildingSiteExportOptions Class See Also Send Feedback
Property Line Offset. Default is 0.0.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double PropertyLineOffset { get; set; }
Visual Basic (Declaration)
Public Property PropertyLineOffset As Double
Visual C++
public:
property double PropertyLineOffset {
    double get ();
    void set (double value);
}

Remarks

Is only used if property line is also specified.

See Also

BuildingSiteExportOptions Class
Autodesk.Revit Namespace


TotalGrossArea Property

[image]

Revit 2010 API
BuildingSiteExportOptions..::.TotalGrossArea Property
BuildingSiteExportOptions Class See Also Send Feedback
Custom value for the total area.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double TotalGrossArea { get; set; }
Visual Basic (Declaration)
Public Property TotalGrossArea As Double
Visual C++
public:
property double TotalGrossArea {
    double get ();
    void set (double value);
}

Remarks

If specified value > 0.0, the value will be used instead of the default value calculated internally.

See Also

BuildingSiteExportOptions Class
Autodesk.Revit Namespace


TotalOccupancy Property

[image]

Revit 2010 API
BuildingSiteExportOptions..::.TotalOccupancy Property
BuildingSiteExportOptions Class See Also Send Feedback
Custom value for the total occupancy.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int TotalOccupancy { get; set; }
Visual Basic (Declaration)
Public Property TotalOccupancy As Integer
Visual C++
public:
property int TotalOccupancy {
    int get ();
    void set (int value);
}

Remarks

If specified value > 0, the value will be used instead of the default value calculated internally.

See Also

BuildingSiteExportOptions Class
Autodesk.Revit Namespace


BuiltInCategory Enumeration

[image]

Revit 2010 API
BuiltInCategory Enumeration
See Also Send Feedback
A list of all the built in categories within Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum BuiltInCategory
Visual Basic (Declaration)
Public Enumeration BuiltInCategory
Visual C++
public enum class BuiltInCategory

Members

Member name | Description
OST_IOSTilePatternGrid |
OST_ControlLocal |
OST_ControlAxisZ |
OST_ControlAxisY |
OST_ControlAxisX |
OST_XRayConstrainedProfileEdge |
OST_XRayImplicitPathCurve |
OST_XRayPathPoint |
OST_XRayPathCurve |
OST_XRaySideEdge |
OST_XRayProfileEdge |
OST_ReferencePoints_HiddenLines |
OST_ReferencePoints_Lines |
OST_ReferencePoints_Planes |
OST_ReferencePoints_Points |
OST_ReferencePoints |
OST_IOSNavWheelPivotBall |
OST_IOSRoomComputationHeight |
OST_IOSRoomUpperLowerLines |
OST_IOSDragBoxInverted |
OST_IOSDragBox |
OST_Phases |
OST_IOS_GeoSite |
OST_IOS_GeoLocations |
OST_EPS_Future |
OST_EPS_Temporary |
OST_EPS_New |
OST_EPS_Demolished |
OST_EPS_Existing |
OST_IOSMeasureLineScreenSize |
OST_IOSRebarSystemSpanSymbolCtrl |
OST_IOSRoomTagToRoomLines |
OST_IOSAttachedDetailGroups |
OST_IOSDetailGroups |
OST_IOSModelGroups |
OST_IOSSuspendedSketch |
OST_IOSWallCoreBoundary |
OST_IOSMeasureLine |
OST_IOSArrays |
OST_Curtain_Systems |
OST_IOSBBoxScreenSize |
OST_IOSSlabShapeEditorPointInterior |
OST_IOSSlabShapeEditorPointBoundary |
OST_IOSSlabShapeEditorBoundary |
OST_IOSSlabShapeEditorAutoCrease |
OST_IOSSlabShapeEditorExplitCrease |
OST_IOSNotSilhouette |
OST_IOSRoomPerimeterLines |
OST_IOSCuttingGeometry |
OST_IOSCrashGraphics |
OST_IOSGroups |
OST_IOSGhost |
OST_IOSThinPixel_DashDot |
OST_IOSThinPixel_Dash |
OST_IOSThinPixel_Dot |
OST_IOSThinPixel |
OST_IOSFlipControl |
OST_IOSSketchGrid |
OST_IOSSuspendedSketch_obsolete |
OST_IOSFreeSnapLine |
OST_IOSDatumPlane |
OST_IOSConstructionLine |
OST_IOSAlignmentGraphics |
OST_IOSAligningLine |
OST_IOSBackedUpElements |
OST_IOSRegeneratedElements |
OST_IOSRegenerationFailure |
OST_IOS |
OST_CutOutlines |
OST_StructuralTrussStickSymbols |
OST_StructuralTrussHiddenLines |
OST_TrussChord |
OST_TrussWeb |
OST_TrussBottomChordCurve |
OST_TrussTopChordCurve |
OST_TrussVertWebCurve |
OST_TrussDiagWebCurve |
OST_Truss |
OST_TrussDummy |
OST_MassHiddenLines |
OST_CurtaSystemHiddenLines |
OST_OBSOLETE_ElemArrayHiddenLines |
OST_EntourageHiddenLines |
OST_PlantingHiddenLines |
OST_SpecialityEquipmentHiddenLines |
OST_TopographyHiddenLines |
OST_StructuralFramingSystemHiddenLines |
OST_SiteHiddenLines |
OST_RoadsHiddenLines |
OST_ParkingHiddenLines |
OST_PlumbingFixturesHiddenLines |
OST_MechanicalEquipmentHiddenLines |
OST_LightingFixturesHiddenLines |
OST_FurnitureSystemsHiddenLines |
OST_ElectricalFixturesHiddenLines |
OST_ElectricalEquipmentHiddenLines |
OST_CaseworkHiddenLines |
OST_DetailComponentsHiddenLines |
OST_ShaftOpeningHiddenLines |
OST_GenericModelHiddenLines |
OST_CurtainWallMullionsHiddenLines |
OST_CurtainWallPanelsHiddenLines |
OST_RampsHiddenLines |
OST_StairsRailingHiddenLines |
OST_StairsHiddenLines |
OST_ColumnsHiddenLines |
OST_FurnitureHiddenLines |
OST_LinesHiddenLines |
OST_CeilingsHiddenLines |
OST_RoofsHiddenLines |
OST_DoorsHiddenLines |
OST_WindowsHiddenLines |
OST_StructConnectionTags |
OST_StructWeldLines |
OST_StructConnections |
OST_AreaReinTags |
OST_RebarTags |
OST_CoverType |
OST_RebarShape |
OST_PathReinBoundary |
OST_PathReinTags |
OST_PathReinSpanSymbol |
OST_PathRein |
OST_Cage |
OST_AreaReinXVisibility |
OST_AreaReinBoundary |
OST_AreaReinSpanSymbol |
OST_AreaReinSketchOverride |
OST_AreaRein |
OST_RebarLines |
OST_RebarSketchLines |
OST_Rebar |
OST_DuctLinings |
OST_DuctInsulations |
OST_PipeInsulations |
OST_HVAC_Load_Schedules |
OST_HVAC_Load_Building_Types |
OST_HVAC_Load_Space_Types |
OST_HVAC_Zones_Reference_Visibility |
OST_HVAC_Zones_InteriorFill_Visibility |
OST_HVAC_Zones_ColorFill |
OST_ZoneTags |
OST_LayoutPath_Bases |
OST_WireTemperatureRatings |
OST_WireInsulations |
OST_WireMaterials |
OST_HVAC_Zones_Reference |
OST_HVAC_Zones_InteriorFill |
OST_HVAC_Zones_Boundary |
OST_HVAC_Zones |
OST_Fluids |
OST_PipeSchedules |
OST_PipeMaterials |
OST_PipeConnections |
OST_EAConstructions |
OST_SwitchSystem |
OST_SprinklerTags |
OST_Sprinklers |
OST_RouteCurveBranch |
OST_RouteCurveMain |
OST_RouteCurve |
OST_GbXML_Opening |
OST_GbXML_SType_Underground |
OST_GbXML_SType_Shade |
OST_GbXML_SType_Exterior |
OST_GbXML_SType_Interior |
OST_GbXMLFaces |
OST_WireHomeRunArrows |
OST_LightingDeviceTags |
OST_LightingDevices |
OST_FireAlarmDeviceTags |
OST_FireAlarmDevices |
OST_DataDeviceTags |
OST_DataDevices |
OST_CommunicationDeviceTags |
OST_CommunicationDevices |
OST_SecurityDeviceTags |
OST_SecurityDevices |
OST_NurseCallDeviceTags |
OST_NurseCallDevices |
OST_TelephoneDeviceTags |
OST_TelephoneDevices |
OST_WireTickMarks |
OST_PipeFittingInsulation |
OST_PipeFittingCenterLine |
OST_FlexPipeCurvesInsulation |
OST_PipeCurvesInsulation |
OST_PipeCurvesDrop |
OST_DuctFittingLining |
OST_DuctFittingInsulation |
OST_DuctFittingCenterLine |
OST_FlexDuctCurvesInsulation |
OST_DuctCurvesLining |
OST_DuctCurvesInsulation |
OST_DuctCurvesDrop |
OST_DuctFittingTags |
OST_PipeFittingTags |
OST_PipeColorFills |
OST_PipeColorFillLegends |
OST_WireTags |
OST_PipeAccessoryTags |
OST_PipeAccessory |
OST_PipeCurvesRiseDrop |
OST_FlexPipeCurvesPattern |
OST_FlexPipeCurvesContour |
OST_FlexPipeCurvesCenterLine |
OST_FlexPipeCurves |
OST_PipeFitting |
OST_FlexPipeTags |
OST_PipeTags |
OST_PipeCurvesContour |
OST_PipeCurvesCenterLine |
OST_PipeCurves |
OST_PipingSystem |
OST_ElectricalDemandFactor |
OST_ElecDistributionSys |
OST_ElectricalVoltage |
OST_Wire |
OST_ElectricalCircuitTags |
OST_ElectricalCircuit |
OST_DuctCurvesRiseDrop |
OST_FlexDuctCurvesPattern |
OST_FlexDuctCurvesContour |
OST_FlexDuctCurvesCenterLine |
OST_FlexDuctCurves |
OST_DuctAccessoryTags |
OST_DuctAccessory |
OST_DuctSystem |
OST_DuctTerminalTags |
OST_DuctTerminal |
OST_DuctFitting |
OST_FlexDuctTags |
OST_DuctTags |
OST_DuctCurvesContour |
OST_DuctCurvesCenterLine |
OST_DuctCurves |
OST_DuctColorFills |
OST_DuctColorFillLegends |
OST_ConnectorElemZAxis |
OST_ConnectorElemYAxis |
OST_ConnectorElemXAxis |
OST_ConnectorElem |
OST_DesignOptions |
OST_DesignOptionSets |
OST_StructuralBracePlanReps |
OST_StructuralConnections |
OST_StructuralAnnotations |
OST_RevisionCloudTags |
OST_Revisions |
OST_RevisionClouds |
OST_EditCutProfile |
OST_GridHeads |
OST_LevelHeads |
OST_DecalType |
OST_DecalElement |
OST_VolumeOfInterest |
OST_BoundaryConditions |
OST_InternalAreaLoadTags |
OST_InternalLineLoadTags |
OST_InternalPointLoadTags |
OST_AreaLoadTags |
OST_LineLoadTags |
OST_PointLoadTags |
OST_LoadCasesSeismic |
OST_LoadCasesTemperature |
OST_LoadCasesAccidental |
OST_LoadCasesRoofLive |
OST_LoadCasesSnow |
OST_LoadCasesWind |
OST_LoadCasesLive |
OST_LoadCasesDead |
OST_LoadCases |
OST_InternalAreaLoads |
OST_InternalLineLoads |
OST_InternalPointLoads |
OST_InternalLoads |
OST_AreaLoads |
OST_LineLoads |
OST_PointLoads |
OST_Loads |
OST_BeamSystemTags |
OST_FootingSpanDirectionSymbol |
OST_SpanDirectionSymbol |
OST_SpotSlopesSymbols |
OST_SpotCoordinateSymbols |
OST_SpotElevSymbols |
OST_TrussTags |
OST_KeynoteTags |
OST_DetailComponentTags |
OST_MaterialTags |
OST_FloorTags |
OST_CurtaSystemTags |
OST_HostFinTags |
OST_StairTags |
OST_MultiCategoryTags |
OST_PlantingTags |
OST_AreaTags |
OST_StructuralFoundationTags |
OST_StructuralColumnTags |
OST_ParkingTags |
OST_SiteTags |
OST_StructuralFramingTags |
OST_SpecialityEquipmentTags |
OST_GenericModelTags |
OST_CurtainWallPanelTags |
OST_WallTags |
OST_PlumbingFixtureTags |
OST_MechanicalEquipmentTags |
OST_LightingFixtureTags |
OST_FurnitureSystemTags |
OST_FurnitureTags |
OST_ElectricalFixtureTags |
OST_ElectricalEquipmentTags |
OST_CeilingTags |
OST_CaseworkTags |
OST_Tags |
OST_PreviewLegendComponents |
OST_LegendComponents |
OST_ScheduleGraphics |
OST_RasterImages |
OST_ColorFillSchema |
OST_RoomColorFill |
OST_ColorFillLegends |
OST_AnnotationCropSpecial |
OST_CropBoundarySpecial |
OST_AnnotationCrop |
OST_CalloutLeaderLine |
OST_CalloutBoundary |
OST_CalloutHeads |
OST_Callouts |
OST_CropBoundary |
OST_Elev |
OST_AxisZ |
OST_AxisY |
OST_AxisX |
OST_ReferenceLines |
OST_CLines |
OST_Lights |
OST_ViewportLabel |
OST_Viewports |
OST_Camera_Lines |
OST_Cameras |
OST_MEPSpaceTags |
OST_RoomTags |
OST_DoorTags |
OST_WindowTags |
OST_SectionHeadWideLines |
OST_SectionHeadMediumLines |
OST_SectionHeadThinLines |
OST_SectionHeads |
OST_ContourLabels |
OST_RenderRegions |
OST_SectionBox |
OST_TextNotes |
OST_Catalogs |
OST_DirectionEdgeLines |
OST_CenterLines |
OST_LinesBeyond |
OST_HiddenLines |
OST_DemolishedLines |
OST_OverheadLines |
OST_TitleBlockWideLines |
OST_TitleBlockMediumLines |
OST_TitleBlockThinLines |
OST_TitleBlocks |
OST_Views |
OST_Viewers |
OST_RoofTags |
OST_SpotSlopes |
OST_SpotCoordinates |
OST_SpotElevations |
OST_Constraints |
OST_WeakDims |
OST_Dimensions |
OST_DatumLevels |
OST_Levels |
OST_Grids |
OST_BrokenSectionLine |
OST_SectionLine |
OST_Sections |
OST_MEPSpaceColorFill |
OST_MEPSpaceReference |
OST_MEPSpaceInteriorFill |
OST_MEPSpaceReferenceVisibility |
OST_MEPSpaceInteriorFillVisibility |
OST_MEPSpaces |
OST_StackedWalls |
OST_StackedWalls_Obsolete_IdInWrongRange |
OST_MassAreaFaceTags |
OST_HostTemplate |
OST_MassFaceSplitter |
OST_MassCutter |
OST_ZoningEnvelope |
OST_MassTags |
OST_MassSurface |
OST_MassAreaFaces |
OST_Mass |
OST_MassTags_Obsolete_IdInWrongRange |
OST_MassSurface_Obsolete_IdInWrongRange |
OST_MassAreaFaces_Obsolete_IdInWrongRange |
OST_Mass_Obsolete_IdInWrongRange |
OST_ZoneSchemes |
OST_AreaSchemes |
OST_Areas |
OST_ProjectInformation |
OST_Sheets |
OST_ProfileFamilies |
OST_DetailComponents |
OST_RoofSoffit |
OST_EdgeSlab |
OST_Gutter |
OST_Fascia |
OST_Entourage |
OST_Planting |
OST_StructuralStiffenerTags |
OST_StructuralStiffener |
OST_FootingAnalyticalGeometry |
OST_RvtLinks |
OST_Automatic |
OST_SpecialityEquipment |
OST_ColumnAnalyticalRigidLinks |
OST_SecondaryTopographyContours |
OST_TopographyContours |
OST_TopographySurface |
OST_Topography |
OST_StructuralTruss |
OST_StructuralColumnStickSymbols |
OST_HiddenStructuralColumnLines |
OST_AnalyticalRigidLinks |
OST_ColumnAnalyticalGeometry |
OST_FramingAnalyticalGeometry |
OST_StructuralColumns |
OST_HiddenStructuralFramingLines |
OST_KickerBracing |
OST_StructuralFramingSystem |
OST_VerticalBracing |
OST_HorizontalBracing |
OST_Purlin |
OST_Joist |
OST_Girder |
OST_StructuralFramingOther |
OST_StructuralFraming |
OST_HiddenStructuralFoundationLines |
OST_StructuralFoundation |
OST_BasePointAxisZ |
OST_BasePointAxisY |
OST_BasePointAxisX |
OST_SharedBasePoint |
OST_ProjectBasePoint |
OST_SiteRegion |
OST_SitePropertyLineSegmentTags |
OST_SitePropertyLineSegment |
OST_SitePropertyTags |
OST_SitePointBoundary |
OST_SiteProperty |
OST_BuildingPad |
OST_SitePoint |
OST_SiteSurface |
OST_Site |
OST_HiddenBuildingUnitLines |
OST_BuildingUnits |
OST_Sewer |
OST_Roads |
OST_Property |
OST_Parking |
OST_PlumbingFixtures |
OST_MechanicalEquipment |
OST_LightingFixtureSource |
OST_LightingFixtures |
OST_FurnitureSystems |
OST_ElectricalFixtures |
OST_ElectricalEquipment |
OST_Casework |
OST_GenericModel |
OST_GenericAnnotation |
OST_Materials |
OST_AreaReport_Arc_Minus |
OST_AreaReport_Arc_Plus |
OST_AreaReport_Boundary |
OST_AreaReport_Triangle |
OST_CurtaSystemFaceManager |
OST_CurtaSystem |
OST_DetailArray |
OST_ModelArray |
OST_HostFinHF |
OST_HostFinWall |
OST_HostFinCeiling |
OST_HostFinRoof |
OST_HostFinFloor |
OST_HostFin |
OST_ReferenceViewer |
OST_ReferenceViewerSymbol |
OST_ImportObjectStyles |
OST_ModelText |
OST_MaskingRegion |
OST_Matchline |
OST_FaceSplitter |
OST_PlanRegion |
OST_FilledRegion |
OST_MassingProjectionOutlines |
OST_MassingCutOutlines |
OST_Massing |
OST_Reveals |
OST_Cornices |
OST_RampsDownArrow |
OST_RampsUpArrow |
OST_RampsDownText |
OST_RampsUpText |
OST_RampsStringerAboveCut |
OST_RampsStringer |
OST_RampsAboveCut |
OST_RampsIncomplete |
OST_Ramps |
OST_RailingBalusterRailCut |
OST_RailingBalusterRail |
OST_Railings |
OST_CurtainGridsCurtaSystem |
OST_CurtainGridsSystem |
OST_CurtainGridsWall |
OST_CurtainGridsRoof |
OST_CurtainGrids |
OST_CurtainWallMullionsCut |
OST_CurtainWallMullions |
OST_CurtainWallPanels |
OST_AreaReference |
OST_AreaInteriorFill |
OST_RoomReference |
OST_RoomInteriorFill |
OST_AreaColorFill |
OST_AreaReferenceVisibility |
OST_AreaInteriorFillVisibility |
OST_RoomReferenceVisibility |
OST_RoomInteriorFillVisibility |
OST_Rooms |
OST_Fixtures |
OST_StairsRailingTags |
OST_StairsRailingAboveCut |
OST_StairsRailingRail |
OST_StairsRailingBaluster |
OST_StairsRailing |
OST_StairsDownArrow |
OST_StairsUpArrow |
OST_StairsDownText |
OST_StairsUpText |
OST_StairsStringerAboveCut |
OST_StairsStringer |
OST_StairsAboveCut |
OST_StairsIncomplete |
OST_Stairs |
OST_Columns |
OST_Furniture |
OST_Extrusions |
OST_FillPatterns |
OST_DividedSurfaceBelt |
OST_TilePatterns |
OST_AlwaysExcludedInAllViews |
OST_DividedSurface_TransparentFace |
OST_DividedSurface_PreDividedSurface |
OST_DividedSurface_PatternFill |
OST_DividedSurface_PatternLines |
OST_DividedSurface_Gridlines |
OST_DividedSurface_Nodes |
OST_DividedSurface |
OST_MEPSpaceSeparationLines |
OST_AreaPolylines |
OST_RoomPolylines |
OST_InstanceDrivenLineStyle |
OST_StickSymbols_Obsolete_IdInWrongRange |
OST_RemovedGridSeg |
OST_RemovedGridSeg_Obsolete_IdInWrongRange |
OST_RepeatingDetailLines |
OST_AreaSchemeLines |
OST_GenericLines |
OST_InsulationLines |
OST_CloudLines |
OST_StairsLandingCenterLines |
OST_StairsRunLines |
OST_StairsRiserLines |
OST_StairsBoundaryLines |
OST_AreaSeparationLines |
OST_AxisOfRotation |
OST_InvisibleLines |
OST_SketchLines |
OST_CurvesWideLines |
OST_CurvesMediumLines |
OST_CurvesThinLines |
OST_Curves |
OST_Lines |
OST_CeilingsSurfacePattern |
OST_CeilingsProjection |
OST_CeilingsCut |
OST_Ceilings |
OST_RoofsSurfacePattern |
OST_RoofsProjection |
OST_RoofsCut |
OST_Roofs |
OST_FloorsAnalyticalGeometry |
OST_FloorsSurfacePattern |
OST_FloorsProjection |
OST_FloorsCut |
OST_Floors |
OST_DoorsGlassProjection |
OST_DoorsGlassCut |
OST_DoorsFrameMullionProjection |
OST_DoorsFrameMullionCut |
OST_DoorsOpeningProjection |
OST_DoorsOpeningCut |
OST_DoorsPanelProjection |
OST_DoorsPanelCut |
OST_Doors |
OST_WindowsOpeningProjection |
OST_WindowsOpeningCut |
OST_WindowsSillHeadProjection |
OST_WindowsSillHeadCut |
OST_WindowsFrameMullionProjection |
OST_WindowsFrameMullionCut |
OST_WindowsGlassProjection |
OST_WindowsGlassCut |
OST_Windows |
OST_ColumnOpening |
OST_StructuralFramingOpening |
OST_ShaftOpening |
OST_CeilingOpening |
OST_FloorOpening |
OST_DormerOpeningIncomplete |
OST_RoofOpening |
OST_SWallRectOpening |
OST_ArcWallRectOpening |
OST_WallRefPlanes |
OST_WallRefPlanes_Obsolete_IdInWrongRange |
OST_CeilingsCutPattern |
OST_CeilingsDefault |
OST_CeilingsFinish2 |
OST_CeilingsFinish1 |
OST_CeilingsSubstrate |
OST_CeilingsInsulation |
OST_CeilingsStructure |
OST_CeilingsMembrane |
OST_FloorsInteriorEdges |
OST_FloorsCutPattern |
OST_HiddenFloorLines |
OST_FloorsDefault |
OST_FloorsFinish2 |
OST_FloorsFinish1 |
OST_FloorsSubstrate |
OST_FloorsInsulation |
OST_FloorsStructure |
OST_FloorsMembrane |
OST_RoofsInteriorEdges |
OST_RoofsCutPattern |
OST_RoofsDefault |
OST_RoofsFinish2 |
OST_RoofsFinish1 |
OST_RoofsSubstrate |
OST_RoofsInsulation |
OST_RoofsStructure |
OST_RoofsMembrane |
OST_WallsCutPattern |
OST_HiddenWallLines |
OST_WallsDefault |
OST_WallsFinish2 |
OST_WallsFinish1 |
OST_WallsSubstrate |
OST_WallsInsulation |
OST_WallsStructure |
OST_WallsMembrane |
OST_WallsSurfacePattern |
OST_WallsAnalyticalGeometry |
OST_WallsProjectionOutlines |
OST_WallsCutOutlines |
OST_Walls |
OST_MatchSiteComponent |
OST_MatchProfile |
OST_MatchDetail |
OST_MatchAnnotation |
OST_MatchModel |
OST_MatchAll |
INVALID |

See Also

Autodesk.Revit Namespace


ButtonData Class

[image]

Revit 2010 API
ButtonData Class
Members See Also Send Feedback
Base class used to contain information necessary to construct a button in the Ribbon.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ButtonData
Visual Basic (Declaration)
Public Class ButtonData
Visual C++
public ref class ButtonData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.ButtonData
Autodesk.Revit..::.PulldownButtonData
Autodesk.Revit..::.PushButtonData

See Also

ButtonData Members
Autodesk.Revit Namespace


ButtonData Members

[image] [image]

Revit 2010 API
ButtonData Members
ButtonData Class Methods Properties See Also Send Feedback

The ButtonData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Image | The image of the button.
LargeImage | The large image of the button.
Name | The name of the button.
Text | The user-visible text of the button.
ToolTip | The description that appears as a ToolTip for the button.

See Also

ButtonData Class
Autodesk.Revit Namespace


ButtonData Methods

[image] [image]

Revit 2010 API
ButtonData Methods
ButtonData Class See Also Send Feedback

The ButtonData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ButtonData Class
Autodesk.Revit Namespace


ButtonData Properties

[image] [image]

Revit 2010 API
ButtonData Properties
ButtonData Class See Also Send Feedback

The ButtonData type exposes the following members.

Properties

Name | Description
Image | The image of the button.
LargeImage | The large image of the button.
Name | The name of the button.
Text | The user-visible text of the button.
ToolTip | The description that appears as a ToolTip for the button.

See Also

ButtonData Class
Autodesk.Revit Namespace


Image Property

[image]

Revit 2010 API
ButtonData..::.Image Property
ButtonData Class See Also Send Feedback
The image of the button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ImageSource Image { get; set; }
Visual Basic (Declaration)
Public Property Image As ImageSource
Visual C++
public:
property ImageSource^ Image {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the button if it is a part of a stacked set, or if it is promoted to the Quick Access Toolbar. The best size is 16 x 16 pixels; if larger, the image will NOT be adjusted to fit the toolbar button.

See Also

ButtonData Class
Autodesk.Revit Namespace


LargeImage Property

[image]

Revit 2010 API
ButtonData..::.LargeImage Property
ButtonData Class See Also Send Feedback
The large image of the button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ImageSource LargeImage { get; set; }
Visual Basic (Declaration)
Public Property LargeImage As ImageSource
Visual C++
public:
property ImageSource^ LargeImage {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the button in the Ribbon panel if the button is not a part of a stacked set. It will also be shown on a push button added to a pulldown button. The best size is 32 x 32 pixels; if larger, the image will be adjusted to fit the button.

See Also

ButtonData Class
Autodesk.Revit Namespace


Name Property

[image]

Revit 2010 API
ButtonData..::.Name Property
ButtonData Class See Also Send Feedback
The name of the button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when setting the value to null.
System..::.ArgumentException | Thrown when setting the value to an empty string.

See Also

ButtonData Class
Autodesk.Revit Namespace


Text Property

[image]

Revit 2010 API
ButtonData..::.Text Property
ButtonData Class See Also Send Feedback
The user-visible text of the button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when setting the value to null.
System..::.ArgumentException | Thrown when setting the value to an empty string, or when the value contains invalid characters.

See Also

ButtonData Class
Autodesk.Revit Namespace


ToolTip Property

[image]

Revit 2010 API
ButtonData..::.ToolTip Property
ButtonData Class See Also Send Feedback
The description that appears as a ToolTip for the button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string ToolTip { get; set; }
Visual Basic (Declaration)
Public Property ToolTip As String
Visual C++
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}

Remarks

The text that is displayed when the cursor is over the button.

See Also

ButtonData Class
Autodesk.Revit Namespace


CADExportOptions Class

[image]

Revit 2010 API
CADExportOptions Class
Members See Also Send Feedback
Generic CAD Export options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class CADExportOptions
Visual Basic (Declaration)
Public MustInherit Class CADExportOptions
Visual C++
public ref class CADExportOptions abstract

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.CADExportOptions
Autodesk.Revit..::.ACADExportOptions
Autodesk.Revit..::.DGNExportOptions
Autodesk.Revit..::.DWFExportOptions

See Also

CADExportOptions Members
Autodesk.Revit Namespace


CADExportOptions Members

[image] [image]

Revit 2010 API
CADExportOptions Members
CADExportOptions Class Methods See Also Send Feedback

The CADExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CADExportOptions Class
Autodesk.Revit Namespace


CADExportOptions Methods

[image] [image]

Revit 2010 API
CADExportOptions Methods
CADExportOptions Class See Also Send Feedback

The CADExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CADExportOptions Class
Autodesk.Revit Namespace


CADImportOptions Class

[image]

Revit 2010 API
CADImportOptions Class
Members See Also Send Feedback
Generic CAD Import options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class CADImportOptions : GenericImportOptions
Visual Basic (Declaration)
Public MustInherit Class CADImportOptions _
    Inherits GenericImportOptions
Visual C++
public ref class CADImportOptions abstract : public GenericImportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.GenericImportOptions
Autodesk.Revit..::.CADImportOptions
Autodesk.Revit..::.ACADImportOptions

See Also

CADImportOptions Members
Autodesk.Revit Namespace


CADImportOptions Members

[image] [image]

Revit 2010 API
CADImportOptions Members
CADImportOptions Class Methods Properties See Also Send Feedback

The CADImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColorMode | Color mode for the import.
CustomScale | Scaling the import.
OrientToView | Place the import at the same orientation as the current view.
Placement | Where to place the import.
RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only.
Unit | The unit of measure for imported geometry.
View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)

See Also

CADImportOptions Class
Autodesk.Revit Namespace


CADImportOptions Methods

[image] [image]

Revit 2010 API
CADImportOptions Methods
CADImportOptions Class See Also Send Feedback

The CADImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CADImportOptions Class
Autodesk.Revit Namespace


CADImportOptions Properties

[image] [image]

Revit 2010 API
CADImportOptions Properties
CADImportOptions Class See Also Send Feedback

The CADImportOptions type exposes the following members.

Properties

Name | Description
ColorMode | Color mode for the import.
CustomScale | Scaling the import.
OrientToView | Place the import at the same orientation as the current view.
Placement | Where to place the import.
RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only.
Unit | The unit of measure for imported geometry.
View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)

See Also

CADImportOptions Class
Autodesk.Revit Namespace


ColorMode Property

[image]

Revit 2010 API
CADImportOptions..::.ColorMode Property
CADImportOptions Class See Also Send Feedback
Color mode for the import.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ImportColorMode ColorMode { get; set; }
Visual Basic (Declaration)
Public Property ColorMode As ImportColorMode
Visual C++
public:
property ImportColorMode ColorMode {
    ImportColorMode get ();
    void set (ImportColorMode value);
}

Remarks

Three modes are supported. Black and White, Preserve Colors, and Invert Colors.

See Also

CADImportOptions Class
Autodesk.Revit Namespace


CustomScale Property

[image]

Revit 2010 API
CADImportOptions..::.CustomScale Property
CADImportOptions Class See Also Send Feedback
Scaling the import.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double CustomScale { get; set; }
Visual Basic (Declaration)
Public Property CustomScale As Double
Visual C++
public:
property double CustomScale {
    double get ();
    void set (double value);
}

Remarks

If this is defined and a valid value (> 0.0), it takes preference over units.

See Also

CADImportOptions Class
Autodesk.Revit Namespace


OrientToView Property

[image]

Revit 2010 API
CADImportOptions..::.OrientToView Property
CADImportOptions Class See Also Send Feedback
Place the import at the same orientation as the current view.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool OrientToView { get; set; }
Visual Basic (Declaration)
Public Property OrientToView As Boolean
Visual C++
public:
property bool OrientToView {
    bool get ();
    void set (bool value);
}

Remarks

This option is available only for non-view-specific imports.

See Also

CADImportOptions Class
Autodesk.Revit Namespace


Placement Property

[image]

Revit 2010 API
CADImportOptions..::.Placement Property
CADImportOptions Class See Also Send Feedback
Where to place the import.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ImportPlacement Placement { get; set; }
Visual Basic (Declaration)
Public Property Placement As ImportPlacement
Visual C++
public:
property ImportPlacement Placement {
    ImportPlacement get ();
    void set (ImportPlacement value);
}

Remarks

Set this option to place the view at the origin or the center, or a shared coordinates.

See Also

CADImportOptions Class
Autodesk.Revit Namespace


ThisViewOnly Property

[image]

Revit 2010 API
CADImportOptions..::.ThisViewOnly Property
CADImportOptions Class See Also Send Feedback
Imports dwg, dgn, and dxf drawings into the active view only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool ThisViewOnly { get; set; }
Visual Basic (Declaration)
Public Property ThisViewOnly As Boolean
Visual C++
public:
property bool ThisViewOnly {
    bool get ();
    void set (bool value);
}

Remarks

This option is not available in 3D views.

See Also

CADImportOptions Class
Autodesk.Revit Namespace


Unit Property

[image]

Revit 2010 API
CADImportOptions..::.Unit Property
CADImportOptions Class See Also Send Feedback
The unit of measure for imported geometry.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ImportUnit Unit { get; set; }
Visual Basic (Declaration)
Public Property Unit As ImportUnit
Visual C++
public:
property ImportUnit Unit {
    ImportUnit get ();
    void set (ImportUnit value);
}

Remarks

Units are used to calculate the import scale unless scale is defined explicitly using CustomScale, in which case Units will be ignored.

Feet, inches, meters, centimeters, decimeters, millimeters are all supported. If Default unit is set, Revit will read and use the units from the file. If units are not available or accessible there, Revit will default to inches.

See Also

CADImportOptions Class
Autodesk.Revit Namespace


Categories Class

[image]

Revit 2010 API
Categories Class
Members Example See Also Send Feedback
The Categories object is a map that contains all the top-level Category objects within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Categories : CategoryNameMap
Visual Basic (Declaration)
Public Class Categories _
    Inherits CategoryNameMap
Visual C++
public ref class Categories : public CategoryNameMap

Remarks

Use this object to retrieve categories by name or by BuiltInCategory id.

Examples

CopyC#
// Get settings of current document
Settings documentSettings = document.Settings;

// Get all categories of current document
Categories groups = documentSettings.Categories;

// Show the number of all the categories to the user
String prompt = "Number of all categories in current Revit document:" + groups.Size;

// get Floor category according to OST_Floors and show its name
Category floorCategory = groups.get_Item(BuiltInCategory.OST_Floors);
prompt += floorCategory.Name;

// Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);
CopyVB.NET
' Get settings of current document
Dim documentSettings As Settings = document.Settings

' Get all categories of current document
Dim groups As Categories = documentSettings.Categories

' Show the number of all the categories to the user
Dim prompt As String = "Number of all categories in current Revit document:" & groups.Size

' get Floor category according to OST_Floors and show its name
Dim floorCategory As Autodesk.Revit.Category = groups.Item(BuiltInCategory.OST_Floors)
prompt += floorCategory.Name

' Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.CategoryNameMap
Autodesk.Revit..::.Categories

See Also

Categories Members
Autodesk.Revit Namespace


Categories Members

[image] [image]

Revit 2010 API
Categories Members
Categories Class Constructors Methods Properties See Also Send Feedback

The Categories type exposes the following members.

Constructors

Name | Description
Categories | For Internal Use Only.

Methods

Name | Description
Clear | Removes every category from the map, rendering it empty. (Inherited from CategoryNameMap.)
Contains | Identifies if a category which has the specified name is in the list of top-level categories. (Overrides CategoryNameMap..::.Contains(String).)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a category with the specified name from the map. (Inherited from CategoryNameMap.)
ForwardIterator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMap..::.ForwardIterator()()().)
GetEnumerator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMap..::.GetEnumerator()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Inserts the specified category with the specified name into the map. (Overrides CategoryNameMap..::.Insert(String, Category).)
NewSubcategory | Add a new subcategory into the Autodesk Revit document.
ReverseIterator | Retrieves a backward moving iterator to the map. (Overrides CategoryNameMap..::.ReverseIterator()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Whether or not the list of top-level categories is empty. (Overrides CategoryNameMap..::.IsEmpty.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Overloaded. Retrieves a category object matching an identifier.
Size | The total number of top-level categories in the document. (Overrides CategoryNameMap..::.Size.)

See Also

Categories Class
Autodesk.Revit Namespace


Categories Constructor

[image]

Revit 2010 API
Categories Constructor
Categories Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Categories()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Categories()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Categories Class
Autodesk.Revit Namespace


Categories Methods

[image] [image]

Revit 2010 API
Categories Methods
Categories Class See Also Send Feedback

The Categories type exposes the following members.

Methods

Name | Description
Clear | Removes every category from the map, rendering it empty. (Inherited from CategoryNameMap.)
Contains | Identifies if a category which has the specified name is in the list of top-level categories. (Overrides CategoryNameMap..::.Contains(String).)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a category with the specified name from the map. (Inherited from CategoryNameMap.)
ForwardIterator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMap..::.ForwardIterator()()().)
GetEnumerator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMap..::.GetEnumerator()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Inserts the specified category with the specified name into the map. (Overrides CategoryNameMap..::.Insert(String, Category).)
NewSubcategory | Add a new subcategory into the Autodesk Revit document.
ReverseIterator | Retrieves a backward moving iterator to the map. (Overrides CategoryNameMap..::.ReverseIterator()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Categories Class
Autodesk.Revit Namespace


Contains Method

[image]

Revit 2010 API
Categories..::.Contains Method
Categories Class See Also Send Feedback
Identifies if a category which has the specified name is in the list of top-level categories.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override bool Contains(
    string name
)
Visual Basic (Declaration)
Public Overrides Function Contains ( _
    name As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ name
) override

Parameters

name
Type: System..::.String
The name of the category to be retrieved.

Field Value

Whether the category exists in the list of top-level categories.

See Also

Categories Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
Categories..::.ForwardIterator Method
Categories Class See Also Send Feedback
Retrieves a forward moving iterator to the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override CategoryNameMapIterator ForwardIterator()
Visual Basic (Declaration)
Public Overrides Function ForwardIterator As CategoryNameMapIterator
Visual C++
public:
virtual CategoryNameMapIterator^ ForwardIterator() override

Return Value

A forward moving iterator to the map.

See Also

Categories Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
Categories..::.GetEnumerator Method
Categories Class See Also Send Feedback
Retrieves a forward moving iterator to the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overrides Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() override

Return Value

A forward moving iterator to the map.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

Categories Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
Categories..::.Insert Method
Categories Class See Also Send Feedback
Inserts the specified category with the specified name into the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override bool Insert(
    string key,
    Category item
)
Visual Basic (Declaration)
Public Overrides Function Insert ( _
    key As String, _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Insert(
    String^ key,
    Category^ item
) override

Parameters

key
Type: System..::.String
The name to be used for inserting the category into the map.
item
Type: Autodesk.Revit..::.Category
The category to be inserted into the map.

Return Value

Returns whether the category was inserted into the map.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Always thrown; this list is read only.

See Also

Categories Class
Autodesk.Revit Namespace


NewSubcategory Method

[image]

Revit 2010 API
Categories..::.NewSubcategory Method
Categories Class Example See Also Send Feedback
Add a new subcategory into the Autodesk Revit document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Category NewSubcategory(
    Category parentCategory,
    string name
)
Visual Basic (Declaration)
Public Function NewSubcategory ( _
    parentCategory As Category, _
    name As String _
) As Category
Visual C++
public:
Category^ NewSubcategory(
    Category^ parentCategory,
    String^ name
)

Parameters

parentCategory
Type: Autodesk.Revit..::.Category
The parent category.
name
Type: System..::.String
The new category name.

Return Value

If successful, the newly created subcategory is returned, otherwise an exception with error information will be thrown.

Examples

CopyC#
public void AssignSubCategory(Document document, GenericForm extrusion)
{
    // create a new subcategory
    Category cat = document.OwnerFamily.FamilyCategory;
    Category subCat = document.Settings.Categories.NewSubcategory(cat, "NewSubCat");

    // create a new material and assign it to the subcategory
    MaterialWood woodMaterial = document.Settings.Materials.AddWood("Wood Material");
    subCat.Material = woodMaterial;

    // assign the subcategory to the element
    extrusion.Subcategory = subCat;
}
CopyVB.NET
Public Sub AssignSubCategory(ByVal document As Document, ByVal extrusion As GenericForm)
    ' create a new subcategory
    Dim cat As Autodesk.Revit.Category = document.OwnerFamily.FamilyCategory
    Dim subCat As Autodesk.Revit.Category = document.Settings.Categories.NewSubcategory(cat, "NewSubCat")

    ' create a new material and assign it to the subcategory
    Dim woodMaterial As MaterialWood = document.Settings.Materials.AddWood("Wood Material")
    subCat.Material = woodMaterial

    ' assign the subcategory to the element
    extrusion.Subcategory = subCat
End Sub

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"parentCategory" or "name"-is null.
System..::.ArgumentException | Thrown when the input argument-"parentCategory"-cannot add subcategory. Thrown when the input argument-"name"-is an illegal name.
System..::.InvalidOperationException | Thrown when subcategory creation failed.

See Also

Categories Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
Categories..::.ReverseIterator Method
Categories Class See Also Send Feedback
Retrieves a backward moving iterator to the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override CategoryNameMapIterator ReverseIterator()
Visual Basic (Declaration)
Public Overrides Function ReverseIterator As CategoryNameMapIterator
Visual C++
public:
virtual CategoryNameMapIterator^ ReverseIterator() override

Return Value

A backward moving iterator to the map.

See Also

Categories Class
Autodesk.Revit Namespace


Categories Properties

[image] [image]

Revit 2010 API
Categories Properties
Categories Class See Also Send Feedback

The Categories type exposes the following members.

Properties

Name | Description
IsEmpty | Whether or not the list of top-level categories is empty. (Overrides CategoryNameMap..::.IsEmpty.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Overloaded. Retrieves a category object matching an identifier.
Size | The total number of top-level categories in the document. (Overrides CategoryNameMap..::.Size.)

See Also

Categories Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
Categories..::.IsEmpty Property
Categories Class See Also Send Feedback
Whether or not the list of top-level categories is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get () override;
}

See Also

Categories Class
Autodesk.Revit Namespace


Item Property

[image] [image]

Revit 2010 API
Categories..::.Item Property
Categories Class See Also Send Feedback
Retrieves a category object matching an identifier.

Overload List

Name | Description
Item[([(BuiltInCategory])]) | Retrieves a category object corresponding to a BuiltInCategory id.
Item[([(String])]) | Gets a category which has the specified name from this list of top-level categories. (Overrides CategoryNameMap..::.Item[([(String])]).)

See Also

Categories Class
Categories Members
Autodesk.Revit Namespace


Item Property (BuiltInCategory)

[image]

Revit 2010 API
Categories..::.Item Property (BuiltInCategory)
Categories Class See Also Send Feedback
Retrieves a category object corresponding to a BuiltInCategory id.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Category Item[
    BuiltInCategory categoryId
] { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Item ( _
    categoryId As BuiltInCategory _
) As Category
Visual C++
public:
virtual property Category^ Item[BuiltInCategory categoryId] {
    Category^ get (BuiltInCategory categoryId);
}

Parameters

categoryId
Type: Autodesk.Revit..::.BuiltInCategory

Remarks

Unlike the method that obtains categories by name, this routine will obtain the handle even of built-in subcategories.

See Also

Categories Class
Item Overload
Autodesk.Revit Namespace


Item Property (String)

[image]

Revit 2010 API
Categories..::.Item Property (String)
Categories Class See Also Send Feedback
Gets a category which has the specified name from this list of top-level categories.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override Category Item[
    string name
] { get; set; }
Visual Basic (Declaration)
Public Overrides Property Item ( _
    name As String _
) As Category
Visual C++
public:
virtual property Category^ Item[String^ name] {
    Category^ get (String^ name) override;
    void set (String^ name, Category^ value) override;
}

Parameters

name
Type: System..::.String
The name of the category to be retrieved.

Field Value

The category with the specified name.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the category list does not contain the category with this name. Thrown when trying to set an item to this list of categories; this list is read only.

See Also

Categories Class
Item Overload
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
Categories..::.Size Property
Categories Class See Also Send Feedback
The total number of top-level categories in the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override int Size { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get () override;
}

See Also

Categories Class
Autodesk.Revit Namespace


Category Class

[image]

Revit 2010 API
Category Class
Members Example See Also Send Feedback
Represents the category or subcategory to which an element belongs.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Category : APIObject
Visual Basic (Declaration)
Public Class Category _
    Inherits APIObject
Visual C++
public ref class Category : public APIObject

Remarks

Categories are an import tool within Revit for identifying the inferred type of an element, such as anything in the Walls category should be considered as a wall. The API exposes access to the built in categories within Revit via the Document.Settings.Categories property.

Examples

CopyC#
Element selectedElement = null;
foreach (Element e in document.Selection.Elements)
{
    selectedElement = e;
    break;  // just get one selected element
}

// Get the category instance from the Category property
Category category = selectedElement.Category;

BuiltInCategory enumCategory = (BuiltInCategory)category.Id.Value;

// Format the prompt string, which contains the category information
String prompt = "The category information of the selected element is: ";
prompt += "\n\tName:\t" + category.Name;   // Name information

prompt += "\n\tId:\t" + enumCategory.ToString();    // Id information
prompt += "\n\tParent:\t";
if (null == category.Parent)
{
    prompt += "No Parent Category";   // Parent information, it may be null
}
else
{
    prompt += category.Parent.Name;
}

prompt += "\n\tSubCategories:"; // SubCategories information,
CategoryNameMap subCategories = category.SubCategories;
if (null == subCategories || 0 == subCategories.Size) // It may be null or has no item in it
{
    prompt += "No SubCategories;";
}
else
{
    foreach (Category ii in subCategories)
    {
        prompt += "\n\t\t" + ii.Name;
    }
}

// Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);
CopyVB.NET
Dim selectedElement As Autodesk.Revit.Element = Nothing
For Each e As Autodesk.Revit.Element In document.Selection.Elements
    selectedElement = e
    Exit For
    ' just get one selected element
Next

' Get the category instance from the Category property
Dim category As Autodesk.Revit.Category = selectedElement.Category

Dim enumCategory As BuiltInCategory = DirectCast(category.Id.Value, BuiltInCategory)

' Format the prompt string, which contains the category information
Dim prompt As String = "The category information of the selected element is: "
prompt += vbLf & vbTab & "Name:" & vbTab & category.Name
' Name information
prompt += vbLf & vbTab & "Id:" & vbTab & enumCategory.ToString()
' Id information
prompt += vbLf & vbTab & "Parent:" & vbTab
If category.Parent Is Nothing Then
    prompt += "No Parent Category"
    ' Parent information, it may be null
Else
    prompt += category.Parent.Name
End If

prompt += vbLf & vbTab & "SubCategories:"
' SubCategories information,
Dim subCategories As CategoryNameMap = category.SubCategories
If subCategories Is Nothing OrElse 0 = subCategories.Size Then
    ' It may be null or has no item in it
    prompt += "No SubCategories;"
Else
    For Each ii As Autodesk.Revit.Category In subCategories
        prompt += vbLf & vbTab & vbTab & ii.Name
    Next
End If

' Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Category

See Also

Category Members
Autodesk.Revit Namespace


Category Members

[image] [image]

Revit 2010 API
Category Members
Category Class Constructors Methods Properties See Also Send Feedback

The Category type exposes the following members.

Constructors

Name | Description
Category | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetGraphicsStyle | Gets the graphics style associated with this category for the given graphics style type.
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetLineWeight | Retrieves the line weight assigned to the category for the given graphics style type.
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetLineWeight | Sets the line weight for the given graphics style type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowsBoundParameters | To check if the category can have project parameters.
AllowsVisibilityControl | Whether the visibility can be controlled by the user for this category in this view.
CanAddSubcategory | Indicates if subcategories can be assigned to the category.
HasMaterialQuantities | Identifies if elements of the category are able to report what materials they contain in what quantities.
Id | Returns the category id associated with the category object.
IsCuttable | Indicates if the category is cuttable or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
LineColor | The color of lines shown for elements of this category.
Material | Retrieve or change the material of the category.
Name | The category name.
Parent | Returns the parent category of this category.
SubCategories | Returns a map containing all of the subcategories of this category.
Visible | Retrieve or change the visible of the category in the active view.

See Also

Category Class
Autodesk.Revit Namespace


Category Constructor

[image]

Revit 2010 API
Category Constructor
Category Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Category()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Category()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Category Class
Autodesk.Revit Namespace


Category Methods

[image] [image]

Revit 2010 API
Category Methods
Category Class See Also Send Feedback

The Category type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetGraphicsStyle | Gets the graphics style associated with this category for the given graphics style type.
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetLineWeight | Retrieves the line weight assigned to the category for the given graphics style type.
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetLineWeight | Sets the line weight for the given graphics style type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Category Class
Autodesk.Revit Namespace


GetGraphicsStyle Method

[image]

Revit 2010 API
Category..::.GetGraphicsStyle Method
Category Class See Also Send Feedback
Gets the graphics style associated with this category for the given graphics style type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GraphicsStyle GetGraphicsStyle(
    GraphicsStyleType graphicsStyleType
)
Visual Basic (Declaration)
Public Function GetGraphicsStyle ( _
    graphicsStyleType As GraphicsStyleType _
) As GraphicsStyle
Visual C++
public:
GraphicsStyle^ GetGraphicsStyle(
    GraphicsStyleType graphicsStyleType
)

Parameters

graphicsStyleType
Type: Autodesk.Revit.Elements..::.GraphicsStyleType
The type of graphics style.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the input argument-"graphicsStyleType"-is out of range.

See Also

Category Class
Autodesk.Revit Namespace


GetHashCode Method

[image]

Revit 2010 API
Category..::.GetHashCode Method
Category Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

Category Class
Autodesk.Revit Namespace


GetLineWeight Method

[image]

Revit 2010 API
Category..::.GetLineWeight Method
Category Class See Also Send Feedback
Retrieves the line weight assigned to the category for the given graphics style type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Nullable<int> GetLineWeight(
    GraphicsStyleType graphicsStyleType
)
Visual Basic (Declaration)
Public Function GetLineWeight ( _
    graphicsStyleType As GraphicsStyleType _
) As Nullable(Of Integer)
Visual C++
public:
Nullable<int> GetLineWeight(
    GraphicsStyleType graphicsStyleType
)

Parameters

graphicsStyleType
Type: Autodesk.Revit.Elements..::.GraphicsStyleType
The type of graphics style.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the input argument-"graphicsStyleType"-is out of range.

See Also

Category Class
Autodesk.Revit Namespace


SetLineWeight Method

[image]

Revit 2010 API
Category..::.SetLineWeight Method
Category Class See Also Send Feedback
Sets the line weight for the given graphics style type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetLineWeight(
    int lineWeight,
    GraphicsStyleType graphicsStyleType
)
Visual Basic (Declaration)
Public Sub SetLineWeight ( _
    lineWeight As Integer, _
    graphicsStyleType As GraphicsStyleType _
)
Visual C++
public:
void SetLineWeight(
    int lineWeight,
    GraphicsStyleType graphicsStyleType
)

Parameters

lineWeight
Type: System..::.Int32
graphicsStyleType
Type: Autodesk.Revit.Elements..::.GraphicsStyleType
The type of graphics style.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the input argument-"lineWeigh" or "graphicsStyleType"-is out of range.

See Also

Category Class
Autodesk.Revit Namespace


Category Properties

[image] [image]

Revit 2010 API
Category Properties
Category Class See Also Send Feedback

The Category type exposes the following members.

Properties

Name | Description
AllowsBoundParameters | To check if the category can have project parameters.
AllowsVisibilityControl | Whether the visibility can be controlled by the user for this category in this view.
CanAddSubcategory | Indicates if subcategories can be assigned to the category.
HasMaterialQuantities | Identifies if elements of the category are able to report what materials they contain in what quantities.
Id | Returns the category id associated with the category object.
IsCuttable | Indicates if the category is cuttable or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
LineColor | The color of lines shown for elements of this category.
Material | Retrieve or change the material of the category.
Name | The category name.
Parent | Returns the parent category of this category.
SubCategories | Returns a map containing all of the subcategories of this category.
Visible | Retrieve or change the visible of the category in the active view.

See Also

Category Class
Autodesk.Revit Namespace


AllowsBoundParameters Property

[image]

Revit 2010 API
Category..::.AllowsBoundParameters Property
Category Class See Also Send Feedback
To check if the category can have project parameters.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool AllowsBoundParameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowsBoundParameters As Boolean
Visual C++
public:
property bool AllowsBoundParameters {
    bool get ();
}

See Also

Category Class
Autodesk.Revit Namespace


AllowsVisibilityControl Property

[image]

Revit 2010 API
Category..::.AllowsVisibilityControl Property
Category Class See Also Send Feedback
Whether the visibility can be controlled by the user for this category in this view.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool AllowsVisibilityControl[
    View view
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowsVisibilityControl ( _
    view As View _
) As Boolean
Visual C++
public:
property bool AllowsVisibilityControl[View^ view] {
    bool get (View^ view);
}

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view where visibility control might be allowed.

Remarks

There are some categories in Revit that are hidden to users in the Object Styles and Visibility dialog. Their visibility cannot be controlled for a particular view. This property identifies if the category allows visibility control (and thus allows the Visible property to be set).

See Also

Category Class
Autodesk.Revit Namespace


CanAddSubcategory Property

[image]

Revit 2010 API
Category..::.CanAddSubcategory Property
Category Class See Also Send Feedback
Indicates if subcategories can be assigned to the category.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool CanAddSubcategory { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanAddSubcategory As Boolean
Visual C++
public:
property bool CanAddSubcategory {
    bool get ();
}

See Also

Category Class
Autodesk.Revit Namespace


HasMaterialQuantities Property

[image]

Revit 2010 API
Category..::.HasMaterialQuantities Property
Category Class See Also Send Feedback
Identifies if elements of the category are able to report what materials they contain in what quantities.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool HasMaterialQuantities { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasMaterialQuantities As Boolean
Visual C++
public:
property bool HasMaterialQuantities {
    bool get ();
}

Remarks

Get materials via the Element' property Materials; Get quantities via methods GetMaterialArea and GetMaterialVolume.

See Also

Category Class
Autodesk.Revit Namespace


Id Property

[image]

Revit 2010 API
Category..::.Id Property
Category Class See Also Send Feedback
Returns the category id associated with the category object.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementId Id { get; }
Visual Basic (Declaration)
Public ReadOnly Property Id As ElementId
Visual C++
public:
property ElementId Id {
    ElementId get ();
}

See Also

Category Class
Autodesk.Revit Namespace


IsCuttable Property

[image]

Revit 2010 API
Category..::.IsCuttable Property
Category Class See Also Send Feedback
Indicates if the category is cuttable or not.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsCuttable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCuttable As Boolean
Visual C++
public:
property bool IsCuttable {
    bool get ();
}

See Also

Category Class
Autodesk.Revit Namespace


LineColor Property

[image]

Revit 2010 API
Category..::.LineColor Property
Category Class See Also Send Feedback
The color of lines shown for elements of this category.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Color LineColor { get; set; }
Visual Basic (Declaration)
Public Property LineColor As Color
Visual C++
public:
property Color^ LineColor {
    Color^ get ();
    void set (Color^ value);
}

See Also

Category Class
Autodesk.Revit Namespace


Material Property

[image]

Revit 2010 API
Category..::.Material Property
Category Class See Also Send Feedback
Retrieve or change the material of the category.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Material Material { get; set; }
Visual Basic (Declaration)
Public Property Material As Material
Visual C++
public:
property Material^ Material {
    Material^ get ();
    void set (Material^ value);
}

Remarks

If this category doesn't have a material,then nullptr will be returned by the get method.

See Also

Category Class
Autodesk.Revit Namespace


Name Property

[image]

Revit 2010 API
Category..::.Name Property
Category Class See Also Send Feedback
The category name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

Category Class
Autodesk.Revit Namespace


Parent Property

[image]

Revit 2010 API
Category..::.Parent Property
Category Class See Also Send Feedback
Returns the parent category of this category.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Category Parent { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parent As Category
Visual C++
public:
property Category^ Parent {
    Category^ get ();
}

Remarks

If this category a not a subcategory then Nothing will be returned.

See Also

Category Class
Autodesk.Revit Namespace


SubCategories Property

[image]

Revit 2010 API
Category..::.SubCategories Property
Category Class See Also Send Feedback
Returns a map containing all of the subcategories of this category.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CategoryNameMap SubCategories { get; }
Visual Basic (Declaration)
Public ReadOnly Property SubCategories As CategoryNameMap
Visual C++
public:
property CategoryNameMap^ SubCategories {
    CategoryNameMap^ get ();
}

Remarks

If the category has no subcategories then an empty map will be returned.

See Also

Category Class
Autodesk.Revit Namespace


Visible Property

[image]

Revit 2010 API
Category..::.Visible Property
Category Class See Also Send Feedback
Retrieve or change the visible of the category in the active view.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Visible[
    View view
] { get; set; }
Visual Basic (Declaration)
Public Property Visible ( _
    view As View _
) As Boolean
Visual C++
public:
property bool Visible[View^ view] {
    bool get (View^ view);
    void set (View^ view, bool value);
}

Parameters

view
Type: Autodesk.Revit.Elements..::.View
Check the category if it is visible in this view.

See Also

Category Class
Autodesk.Revit Namespace


CategoryFilter Class

[image]

Revit 2010 API
CategoryFilter Class
Members See Also Send Feedback
Represents a filter to filter elements with specific category.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CategoryFilter : Filter
Visual Basic (Declaration)
Public Class CategoryFilter _
    Inherits Filter
Visual C++
public ref class CategoryFilter : public Filter

Remarks

The category filter object is used to filter all the elements in the document of which the category is the appointed one.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Filter
Autodesk.Revit..::.CategoryFilter

See Also

CategoryFilter Members
Autodesk.Revit Namespace


CategoryFilter Members

[image] [image]

Revit 2010 API
CategoryFilter Members
CategoryFilter Class Constructors Methods Properties See Also Send Feedback

The CategoryFilter type exposes the following members.

Constructors

Name | Description
CategoryFilter | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CategoryFilter Class
Autodesk.Revit Namespace


CategoryFilter Constructor

[image]

Revit 2010 API
CategoryFilter Constructor
CategoryFilter Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CategoryFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CategoryFilter()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CategoryFilter Class
Autodesk.Revit Namespace


CategoryFilter Methods

[image] [image]

Revit 2010 API
CategoryFilter Methods
CategoryFilter Class See Also Send Feedback

The CategoryFilter type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CategoryFilter Class
Autodesk.Revit Namespace


CategoryFilter Properties

[image] [image]

Revit 2010 API
CategoryFilter Properties
CategoryFilter Class See Also Send Feedback

The CategoryFilter type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CategoryFilter Class
Autodesk.Revit Namespace


CategoryNameMap Class

[image]

Revit 2010 API
CategoryNameMap Class
Members See Also Send Feedback
A map that contains a mapping of category name to its category object.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CategoryNameMap : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class CategoryNameMap _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CategoryNameMap : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.CategoryNameMap
Autodesk.Revit..::.Categories

See Also

CategoryNameMap Members
Autodesk.Revit Namespace


CategoryNameMap Members

[image] [image]

Revit 2010 API
CategoryNameMap Members
CategoryNameMap Class Constructors Methods Properties See Also Send Feedback

The CategoryNameMap type exposes the following members.

Constructors

Name | Description
CategoryNameMap | Initializes a new instance of the CategoryNameMap class

Methods

Name | Description
Clear | Removes every category from the map, rendering it empty.
Contains | Tests for the existence of a category with that name within the map.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a category with the specified name from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified category with the specified name into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a category at a specified name within the map.
Size | Returns the number of categories that are in the map.

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


CategoryNameMap Constructor

[image]

Revit 2010 API
CategoryNameMap Constructor
CategoryNameMap Class See Also Send Feedback
Initializes a new instance of the CategoryNameMap class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CategoryNameMap()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CategoryNameMap()

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


CategoryNameMap Methods

[image] [image]

Revit 2010 API
CategoryNameMap Methods
CategoryNameMap Class See Also Send Feedback

The CategoryNameMap type exposes the following members.

Methods

Name | Description
Clear | Removes every category from the map, rendering it empty.
Contains | Tests for the existence of a category with that name within the map.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a category with the specified name from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified category with the specified name into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
CategoryNameMap..::.Clear Method
CategoryNameMap Class See Also Send Feedback
Removes every category from the map, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


Contains Method

[image]

Revit 2010 API
CategoryNameMap..::.Contains Method
CategoryNameMap Class See Also Send Feedback
Tests for the existence of a category with that name within the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    string key
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
)

Parameters

key
Type: System..::.String
The category name to be searched for.

Return Value

The Contains method returns True if the name is within the map, otherwise False.

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


Erase Method

[image]

Revit 2010 API
CategoryNameMap..::.Erase Method
CategoryNameMap Class See Also Send Feedback
Removes a category with the specified name from the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    string key
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    key As String _
) As Integer
Visual C++
public:
virtual int Erase(
    String^ key
)

Parameters

key
Type: System..::.String
The name of the category to be erased.

Return Value

The number of categories that were erased from the map.

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
CategoryNameMap..::.ForwardIterator Method
CategoryNameMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CategoryNameMapIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CategoryNameMapIterator
Visual C++
public:
virtual CategoryNameMapIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the map.

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
CategoryNameMap..::.GetEnumerator Method
CategoryNameMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the map.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
CategoryNameMap..::.Insert Method
CategoryNameMap Class See Also Send Feedback
Insert the specified category with the specified name into the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    string key,
    Category item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As String, _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Insert(
    String^ key,
    Category^ item
)

Parameters

key
Type: System..::.String
The name to be used for inserting the category into the map.
item
Type: Autodesk.Revit..::.Category
The category to be inserted into the map.

Return Value

Returns whether the category was inserted into the map.

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
CategoryNameMap..::.ReverseIterator Method
CategoryNameMap Class See Also Send Feedback
Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CategoryNameMapIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CategoryNameMapIterator
Visual C++
public:
virtual CategoryNameMapIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the map.

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


CategoryNameMap Properties

[image] [image]

Revit 2010 API
CategoryNameMap Properties
CategoryNameMap Class See Also Send Feedback

The CategoryNameMap type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a category at a specified name within the map.
Size | Returns the number of categories that are in the map.

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
CategoryNameMap..::.IsEmpty Property
CategoryNameMap Class See Also Send Feedback
Test to see if the map is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the map is empty then True will be returned, otherwise False.

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


Item Property

[image]

Revit 2010 API
CategoryNameMap..::.Item Property
CategoryNameMap Class See Also Send Feedback
Gets or sets a category at a specified name within the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Category Item[
    string key
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    key As String _
) As Category
Visual C++
public:
virtual property Category^ Item[String^ key] {
    Category^ get (String^ key);
    void set (String^ key, Category^ value);
}

Parameters

key
Type: System..::.String
The name of the category to be set or retrieved.

Return Value

Returns the category at the specified name.

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
CategoryNameMap..::.Size Property
CategoryNameMap Class See Also Send Feedback
Returns the number of categories that are in the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CategoryNameMap Class
Autodesk.Revit Namespace


CategoryNameMapIterator Class

[image]

Revit 2010 API
CategoryNameMapIterator Class
Members See Also Send Feedback
An iterator to a category name map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class CategoryNameMapIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CategoryNameMapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CategoryNameMapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.CategoryNameMapIterator

See Also

CategoryNameMapIterator Members
Autodesk.Revit Namespace


CategoryNameMapIterator Members

[image] [image]

Revit 2010 API
CategoryNameMapIterator Members
CategoryNameMapIterator Class Constructors Methods Properties See Also Send Feedback

The CategoryNameMapIterator type exposes the following members.

Constructors

Name | Description
CategoryNameMapIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the category that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Key | Retrieves the category name that is the current focus of the iterator.

See Also

CategoryNameMapIterator Class
Autodesk.Revit Namespace


CategoryNameMapIterator Constructor

[image]

Revit 2010 API
CategoryNameMapIterator Constructor
CategoryNameMapIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CategoryNameMapIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CategoryNameMapIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CategoryNameMapIterator Class
Autodesk.Revit Namespace


CategoryNameMapIterator Methods

[image] [image]

Revit 2010 API
CategoryNameMapIterator Methods
CategoryNameMapIterator Class See Also Send Feedback

The CategoryNameMapIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CategoryNameMapIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
CategoryNameMapIterator..::.MoveNext Method
CategoryNameMapIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CategoryNameMapIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
CategoryNameMapIterator..::.Reset Method
CategoryNameMapIterator Class See Also Send Feedback
Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CategoryNameMapIterator Class
Autodesk.Revit Namespace


CategoryNameMapIterator Properties

[image] [image]

Revit 2010 API
CategoryNameMapIterator Properties
CategoryNameMapIterator Class See Also Send Feedback

The CategoryNameMapIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the category that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Key | Retrieves the category name that is the current focus of the iterator.

See Also

CategoryNameMapIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
CategoryNameMapIterator..::.Current Property
CategoryNameMapIterator Class See Also Send Feedback
Retrieves the category that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CategoryNameMapIterator Class
Autodesk.Revit Namespace


Key Property

[image]

Revit 2010 API
CategoryNameMapIterator..::.Key Property
CategoryNameMapIterator Class See Also Send Feedback
Retrieves the category name that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual string Key { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Key As String
Visual C++
public:
virtual property String^ Key {
    String^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

CategoryNameMapIterator Class
Autodesk.Revit Namespace


CategorySet Class

[image]

Revit 2010 API
CategorySet Class
Members See Also Send Feedback
A set that can contains Category objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CategorySet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class CategorySet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CategorySet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.CategorySet

See Also

CategorySet Members
Autodesk.Revit Namespace


CategorySet Members

[image] [image]

Revit 2010 API
CategorySet Members
CategorySet Class Constructors Methods Properties See Also Send Feedback

The CategorySet type exposes the following members.

Constructors

Name | Description
CategorySet | Initializes a new instance of the CategorySet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of a category within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified category from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified category into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of categories that are in the set.

See Also

CategorySet Class
Autodesk.Revit Namespace


CategorySet Constructor

[image]

Revit 2010 API
CategorySet Constructor
CategorySet Class See Also Send Feedback
Initializes a new instance of the CategorySet class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CategorySet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CategorySet()

See Also

CategorySet Class
Autodesk.Revit Namespace


CategorySet Methods

[image] [image]

Revit 2010 API
CategorySet Methods
CategorySet Class See Also Send Feedback

The CategorySet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of a category within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified category from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified category into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CategorySet Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
CategorySet..::.Clear Method
CategorySet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CategorySet Class
Autodesk.Revit Namespace


Contains Method

[image]

Revit 2010 API
CategorySet..::.Contains Method
CategorySet Class See Also Send Feedback
Tests for the existence of a category within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    Category item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Category^ item
)

Parameters

item
Type: Autodesk.Revit..::.Category
The category to be searched for.

Return Value

The Contains method returns True if the category is within the set, otherwise False.

See Also

CategorySet Class
Autodesk.Revit Namespace


Erase Method

[image]

Revit 2010 API
CategorySet..::.Erase Method
CategorySet Class See Also Send Feedback
Removes a specified category from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    Category item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Category _
) As Integer
Visual C++
public:
virtual int Erase(
    Category^ item
)

Parameters

item
Type: Autodesk.Revit..::.Category
The category to be erased.

Return Value

The number of items that were erased from the set.

See Also

CategorySet Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
CategorySet..::.ForwardIterator Method
CategorySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CategorySetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CategorySetIterator
Visual C++
public:
virtual CategorySetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

CategorySet Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
CategorySet..::.GetEnumerator Method
CategorySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CategorySet Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
CategorySet..::.Insert Method
CategorySet Class See Also Send Feedback
Insert the specified category into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    Category item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Category^ item
)

Parameters

item
Type: Autodesk.Revit..::.Category
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

CategorySet Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
CategorySet..::.ReverseIterator Method
CategorySet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CategorySetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CategorySetIterator
Visual C++
public:
virtual CategorySetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

CategorySet Class
Autodesk.Revit Namespace


CategorySet Properties

[image] [image]

Revit 2010 API
CategorySet Properties
CategorySet Class See Also Send Feedback

The CategorySet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of categories that are in the set.

See Also

CategorySet Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
CategorySet..::.IsEmpty Property
CategorySet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CategorySet Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
CategorySet..::.Size Property
CategorySet Class See Also Send Feedback
Returns the number of categories that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CategorySet Class
Autodesk.Revit Namespace


CategorySetIterator Class

[image]

Revit 2010 API
CategorySetIterator Class
Members See Also Send Feedback
An iterator to a category set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class CategorySetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CategorySetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CategorySetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.CategorySetIterator

See Also

CategorySetIterator Members
Autodesk.Revit Namespace


CategorySetIterator Members

[image] [image]

Revit 2010 API
CategorySetIterator Members
CategorySetIterator Class Constructors Methods Properties See Also Send Feedback

The CategorySetIterator type exposes the following members.

Constructors

Name | Description
CategorySetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CategorySetIterator Class
Autodesk.Revit Namespace


CategorySetIterator Constructor

[image]

Revit 2010 API
CategorySetIterator Constructor
CategorySetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CategorySetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CategorySetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CategorySetIterator Class
Autodesk.Revit Namespace


CategorySetIterator Methods

[image] [image]

Revit 2010 API
CategorySetIterator Methods
CategorySetIterator Class See Also Send Feedback

The CategorySetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CategorySetIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
CategorySetIterator..::.MoveNext Method
CategorySetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CategorySetIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
CategorySetIterator..::.Reset Method
CategorySetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CategorySetIterator Class
Autodesk.Revit Namespace


CategorySetIterator Properties

[image] [image]

Revit 2010 API
CategorySetIterator Properties
CategorySetIterator Class See Also Send Feedback

The CategorySetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CategorySetIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
CategorySetIterator..::.Current Property
CategorySetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CategorySetIterator Class
Autodesk.Revit Namespace


Color Class

[image]

Revit 2010 API
Color Class
Members See Also Send Feedback
Represents a color in Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Color : APIObject
Visual Basic (Declaration)
Public Class Color _
    Inherits APIObject
Visual C++
public ref class Color : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Color

See Also

Color Members
Autodesk.Revit Namespace


Color Members

[image] [image]

Revit 2010 API
Color Members
Color Class Constructors Methods Properties See Also Send Feedback

The Color type exposes the following members.

Constructors

Name | Description
Color | Overloaded.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Blue | Get or set the blue channel of the color.
Green | Get or set the green channel of the color.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Red | Get or set the red channel of the color.

See Also

Color Class
Autodesk.Revit Namespace


Color Constructor

[image] [image]

Revit 2010 API
Color Constructor
Color Class See Also Send Feedback

Overload List

Name | Description
Color()()() | For Internal Use Only.
Color(Byte, Byte, Byte) | Constructor that takes the red, green and blue channels of the color.

See Also

Color Class
Color Members
Autodesk.Revit Namespace


Color Constructor

[image]

Revit 2010 API
Color Constructor
Color Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Color()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Color()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Color Class
Color Overload
Autodesk.Revit Namespace


Color Constructor (Byte, Byte, Byte)

[image]

Revit 2010 API
Color Constructor (Byte, Byte, Byte)
Color Class See Also Send Feedback
Constructor that takes the red, green and blue channels of the color.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Color(
    byte red,
    byte green,
    byte blue
)
Visual Basic (Declaration)
Public Sub New ( _
    red As Byte, _
    green As Byte, _
    blue As Byte _
)
Visual C++
public:
Color(
    unsigned char red,
    unsigned char green,
    unsigned char blue
)

Parameters

red
Type: System..::.Byte
The red channel of the color that ranges from 0 to 255.
green
Type: System..::.Byte
The green channel of the color that ranges from 0 to 255.
blue
Type: System..::.Byte
The blue channel of the color that ranges from 0 to 255.

See Also

Color Class
Color Overload
Autodesk.Revit Namespace


Color Methods

[image] [image]

Revit 2010 API
Color Methods
Color Class See Also Send Feedback

The Color type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Color Class
Autodesk.Revit Namespace


Color Properties

[image] [image]

Revit 2010 API
Color Properties
Color Class See Also Send Feedback

The Color type exposes the following members.

Properties

Name | Description
Blue | Get or set the blue channel of the color.
Green | Get or set the green channel of the color.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Red | Get or set the red channel of the color.

See Also

Color Class
Autodesk.Revit Namespace


Blue Property

[image]

Revit 2010 API
Color..::.Blue Property
Color Class See Also Send Feedback
Get or set the blue channel of the color.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public byte Blue { get; set; }
Visual Basic (Declaration)
Public Property Blue As Byte
Visual C++
public:
property unsigned char Blue {
    unsigned char get ();
    void set (unsigned char value);
}

Remarks

If the color is read-only, InvalidOperationException will be thrown if trying to set the blue channel.

See Also

Color Class
Autodesk.Revit Namespace


Green Property

[image]

Revit 2010 API
Color..::.Green Property
Color Class See Also Send Feedback
Get or set the green channel of the color.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public byte Green { get; set; }
Visual Basic (Declaration)
Public Property Green As Byte
Visual C++
public:
property unsigned char Green {
    unsigned char get ();
    void set (unsigned char value);
}

Remarks

If the color is read-only, InvalidOperationException will be thrown if trying to set the green channel.

See Also

Color Class
Autodesk.Revit Namespace


Red Property

[image]

Revit 2010 API
Color..::.Red Property
Color Class See Also Send Feedback
Get or set the red channel of the color.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public byte Red { get; set; }
Visual Basic (Declaration)
Public Property Red As Byte
Visual C++
public:
property unsigned char Red {
    unsigned char get ();
    void set (unsigned char value);
}

Remarks

If the color is read-only, InvalidOperationException will be thrown if trying to set the red channel.

See Also

Color Class
Autodesk.Revit Namespace


Construction Class

[image]

Revit 2010 API
Construction Class
Members See Also Send Feedback
Construction definition for Project Information.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Construction
Visual Basic (Declaration)
Public Class Construction
Visual C++
public ref class Construction

Remarks

This is used to define the information in Constructions.xml.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.Construction

See Also

Construction Members
Autodesk.Revit Namespace


Construction Members

[image] [image]

Revit 2010 API
Construction Members
Construction Class Constructors Methods Properties See Also Send Feedback

The Construction type exposes the following members.

Constructors

Name | Description
Construction | For Internal Use Only.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Id | Get the id of the Construction.
Name | Get the name of the Construction.

See Also

Construction Class
Autodesk.Revit Namespace


Construction Constructor

[image]

Revit 2010 API
Construction Constructor
Construction Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Construction()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Construction()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Construction Class
Autodesk.Revit Namespace


Construction Methods

[image] [image]

Revit 2010 API
Construction Methods
Construction Class See Also Send Feedback

The Construction type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Construction Class
Autodesk.Revit Namespace


Construction Properties

[image] [image]

Revit 2010 API
Construction Properties
Construction Class See Also Send Feedback

The Construction type exposes the following members.

Properties

Name | Description
Id | Get the id of the Construction.
Name | Get the name of the Construction.

See Also

Construction Class
Autodesk.Revit Namespace


Id Property

[image]

Revit 2010 API
Construction..::.Id Property
Construction Class See Also Send Feedback
Get the id of the Construction.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Id { get; }
Visual Basic (Declaration)
Public ReadOnly Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
}

Remarks

This property is used to get the id of the Construction.

See Also

Construction Class
Autodesk.Revit Namespace


Name Property

[image]

Revit 2010 API
Construction..::.Name Property
Construction Class See Also Send Feedback
Get the name of the Construction.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

Remarks

This property is used to get the name of the Construction.

See Also

Construction Class
Autodesk.Revit Namespace


ControlledApplication Class

[image]

Revit 2010 API
ControlledApplication Class
Members See Also Send Feedback
Represents the Autodesk Revit Application with no access to documents. It provides options and other application wide data and settings for external applications OnStartup/OnShutdown.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ControlledApplication
Visual Basic (Declaration)
Public Class ControlledApplication
Visual C++
public ref class ControlledApplication

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.ControlledApplication

See Also

ControlledApplication Members
Autodesk.Revit Namespace


ControlledApplication Members

[image] [image]

Revit 2010 API
ControlledApplication Members
ControlledApplication Class Constructors Methods Properties Events See Also Send Feedback

The ControlledApplication type exposes the following members.

Constructors

Name | Description
ControlledApplication | For Internal Use Only.

Methods

Name | Description
CreateRibbonPanel | Create a new RibbonPanel.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRibbonPanels | Get all the custom Panels on Add-Ins tab of Revit.
GetType | Gets the Type of the current instance. (Inherited from Object.)
OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cities | Returns a set of all the known city locations within Revit.
Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
IsQuiescent | Returns if the current application is quiescent.
Language | The language used in the Revit application.
LoadedApplications | Returns an array of successfully loaded external applications.
Options | Provides access to an object that represents the application wide settings available in Autodesk Revit.
Product | The product type for the Revit application.
VersionBuild | Returns the internal build number of the Revit application.
VersionName | Returns the name of the Revit application.
VersionNumber | Return the primary version of the Revit application.

Events

Name | Description
ApplicationClosing | Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
DialogBoxShowing | Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
DocumentClosed | Subscribe to the DocumentClosed event to be notified immediately after Revit has finished closing a document.
DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central file.
DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central file.
FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
OnDialogBox | Obsolete. This event is deprecated since Revit version 2010. Please use DialogBoxShowing event instead. Subscribe to the OnDialogBox event to be notified when a Reivt dialog box is displayed during an API external command.
OnDocumentClosed | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentClosed event instead. Subscribe to the OnDocumentClosed event to be notified when a document is closed during an API external command.
OnDocumentNewed | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentCreated event instead. Subscribe to the OnDocumentNewed event to be notified when a new document is created during an API external command.
OnDocumentOpened | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentOpened event instead. Subscribe to the OnDocumentOpened event to be notified when a document is opened during an API external command.
OnDocumentSaved | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentSaved event instead. Subscribe to the OnDocumentSaved event to be notified when a document is saved during an API external command.
OnDocumentSavedAs | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentSavedAs event instead. Subscribe to the OnDocumentSavedAs event to be notified when a document is saved as a file with another name during an API external command.
ViewActivated | Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
ViewActivating | Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.
ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


ControlledApplication Constructor

[image]

Revit 2010 API
ControlledApplication Constructor
ControlledApplication Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ControlledApplication()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ControlledApplication()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


ControlledApplication Methods

[image] [image]

Revit 2010 API
ControlledApplication Methods
ControlledApplication Class See Also Send Feedback

The ControlledApplication type exposes the following members.

Methods

Name | Description
CreateRibbonPanel | Create a new RibbonPanel.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRibbonPanels | Get all the custom Panels on Add-Ins tab of Revit.
GetType | Gets the Type of the current instance. (Inherited from Object.)
OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ControlledApplication Class
Autodesk.Revit Namespace


CreateRibbonPanel Method

[image]

Revit 2010 API
ControlledApplication..::.CreateRibbonPanel Method
ControlledApplication Class Example See Also Send Feedback
Create a new RibbonPanel.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
    string panelName
)
Visual Basic (Declaration)
Public Overridable Function CreateRibbonPanel ( _
    panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
    String^ panelName
)

Parameters

panelName
Type: System..::.String

Remarks

This method will create a custom panel appending to the Revit AddIns tab.

Examples

CopyC#
public IExternalApplication.Result OnStartup(ControlledApplication application)
{
    // add new ribbon panel
    RibbonPanel ribbonPanel = application.CreateRibbonPanel("NewRibbonPanel");

    //Create a push button in the ribbon panel “NewRibbonPanel”
    //the add-in application “HelloWorld” will be triggered when button is pushed

    PushButton pushButton = ribbonPanel.AddPushButton("HelloWorld", "HelloWorld", @"D:\HelloWorld.dll", "HelloWorld.CsHelloWorld");

    // Set the large image shown on button
    Uri uriImage = new Uri(@"D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png");
    BitmapImage largeImage = new BitmapImage(uriImage);
    pushButton.LargeImage = largeImage;

    return IExternalApplication.Result.Succeeded;
}
CopyVB.NET
Public Function OnStartup(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnStartup
    ' add new ribbon panel
    Dim ribbonPanel As RibbonPanel = application.CreateRibbonPanel("NewRibbonPanel")

    'Create a push button in the ribbon panel “NewRibbonPanel”
    'the add-in application “HelloWorld” will be triggered when button is pushed

    Dim pushButton As PushButton = ribbonPanel.AddPushButton("HelloWorld", "HelloWorld", "D:\HelloWorld.dll", "HelloWorld.CsHelloWorld")

    ' Set the large image shown on button
    Dim uriImage As New Uri("D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png")
    Dim largeImage As New BitmapImage(uriImage)
    pushButton.LargeImage = largeImage

    Return IExternalApplication.Result.Succeeded
End Function

Exceptions

Exception | Condition
System..::.ArgumentNullException | panelName is null.
System..::.ArgumentException | panelName is Empty.
System..::.InvalidOperationException | If more than 100 panels were created.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


GetRibbonPanels Method

[image]

Revit 2010 API
ControlledApplication..::.GetRibbonPanels Method
ControlledApplication Class See Also Send Feedback
Get all the custom Panels on Add-Ins tab of Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual List<RibbonPanel> GetRibbonPanels()
Visual Basic (Declaration)
Public Overridable Function GetRibbonPanels As List(Of RibbonPanel)
Visual C++
public:
virtual List<RibbonPanel^>^ GetRibbonPanels()

Remarks

The build-in panels won't be included.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


OpenSharedParameterFile Method

[image]

Revit 2010 API
ControlledApplication..::.OpenSharedParameterFile Method
ControlledApplication Class See Also Send Feedback
Enables access to shared parameter groups and definitions that are maintained on disk.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DefinitionFile OpenSharedParameterFile()
Visual Basic (Declaration)
Public Function OpenSharedParameterFile As DefinitionFile
Visual C++
public:
DefinitionFile^ OpenSharedParameterFile()

Return Value

An object that represents a shared parameters file.

Remarks

This function is used to return an object that represents a Revit shared parameters file that exists on disk. Revit can use only one shared parameters file at any one time. The filename for the shared parameters file can be set in the Revit Application Options object. If the file does not exist and error will be created and an empty reference will be returned.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


ControlledApplication Properties

[image] [image]

Revit 2010 API
ControlledApplication Properties
ControlledApplication Class See Also Send Feedback

The ControlledApplication type exposes the following members.

Properties

Name | Description
Cities | Returns a set of all the known city locations within Revit.
Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
IsQuiescent | Returns if the current application is quiescent.
Language | The language used in the Revit application.
LoadedApplications | Returns an array of successfully loaded external applications.
Options | Provides access to an object that represents the application wide settings available in Autodesk Revit.
Product | The product type for the Revit application.
VersionBuild | Returns the internal build number of the Revit application.
VersionName | Returns the name of the Revit application.
VersionNumber | Return the primary version of the Revit application.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


Cities Property

[image]

Revit 2010 API
ControlledApplication..::.Cities Property
ControlledApplication Class See Also Send Feedback
Returns a set of all the known city locations within Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CitySet Cities { get; }
Visual Basic (Declaration)
Public ReadOnly Property Cities As CitySet
Visual C++
public:
property CitySet^ Cities {
    CitySet^ get ();
}

Remarks

Each city has information about longitude, latitude etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


Create Property

[image]

Revit 2010 API
ControlledApplication..::.Create Property
ControlledApplication Class See Also Send Feedback
Provides an object that can be used to create new instances of Autodesk Revit API objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Application Create { get; }
Visual Basic (Declaration)
Public ReadOnly Property Create As Application
Visual C++
public:
property Application^ Create {
    Application^ get ();
}

Remarks

The Create property returns an object that is used to create application wide utility and geometric objects within the Autodesk Revit API, such as arrays, sets, lines. This object should be used when you wish to create an object within the Autodesk Revit application memory, rather than your own application's memory. If you are performing your own memory management techniques then it is advisable to create any utility objects via the Create object. For example: Instead of Dim set As New Autodesk_Revit_ElementSet do Set set = application.Create.NewElementSet()

See Also

ControlledApplication Class
Autodesk.Revit Namespace


IsQuiescent Property

[image]

Revit 2010 API
ControlledApplication..::.IsQuiescent Property
ControlledApplication Class See Also Send Feedback
Returns if the current application is quiescent.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsQuiescent { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsQuiescent As Boolean
Visual C++
public:
property bool IsQuiescent {
    bool get ();
}

Remarks

This property can be used check if the current application is quiescent. If any document in of the current application is in editing mode or the In-place family is being edited, it returns false. Otherwise, true will be returned.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


Language Property

[image]

Revit 2010 API
ControlledApplication..::.Language Property
ControlledApplication Class See Also Send Feedback
The language used in the Revit application.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LanguageType Language { get; }
Visual Basic (Declaration)
Public ReadOnly Property Language As LanguageType
Visual C++
public:
property LanguageType Language {
    LanguageType get ();
}

Remarks

Use this property to determine the language used by Revit; this can allow your application to load the appropriate resources.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


LoadedApplications Property

[image]

Revit 2010 API
ControlledApplication..::.LoadedApplications Property
ControlledApplication Class See Also Send Feedback
Returns an array of successfully loaded external applications.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ExternalApplicationArray LoadedApplications { get; }
Visual Basic (Declaration)
Public ReadOnly Property LoadedApplications As ExternalApplicationArray
Visual C++
public:
property ExternalApplicationArray^ LoadedApplications {
    ExternalApplicationArray^ get ();
}

Remarks

This property can be used by your application to find all successfully loaded external applications when Revit starts.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


Options Property

[image]

Revit 2010 API
ControlledApplication..::.Options Property
ControlledApplication Class See Also Send Feedback
Provides access to an object that represents the application wide settings available in Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Application Options { get; }
Visual Basic (Declaration)
Public ReadOnly Property Options As Application
Visual C++
public:
property Application^ Options {
    Application^ get ();
}

Remarks

This property return the Revit Options object which exposes some of the options available in the Revit Options dialog available from the Settings, Options – menu.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


Product Property

[image]

Revit 2010 API
ControlledApplication..::.Product Property
ControlledApplication Class See Also Send Feedback
The product type for the Revit application.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProductType Product { get; }
Visual Basic (Declaration)
Public ReadOnly Property Product As ProductType
Visual C++
public:
property ProductType Product {
    ProductType get ();
}

See Also

ControlledApplication Class
Autodesk.Revit Namespace


VersionBuild Property

[image]

Revit 2010 API
ControlledApplication..::.VersionBuild Property
ControlledApplication Class See Also Send Feedback
Returns the internal build number of the Revit application.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string VersionBuild { get; }
Visual Basic (Declaration)
Public ReadOnly Property VersionBuild As String
Visual C++
public:
property String^ VersionBuild {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


VersionName Property

[image]

Revit 2010 API
ControlledApplication..::.VersionName Property
ControlledApplication Class See Also Send Feedback
Returns the name of the Revit application.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string VersionName { get; }
Visual Basic (Declaration)
Public ReadOnly Property VersionName As String
Visual C++
public:
property String^ VersionName {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


VersionNumber Property

[image]

Revit 2010 API
ControlledApplication..::.VersionNumber Property
ControlledApplication Class See Also Send Feedback
Return the primary version of the Revit application.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string VersionNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property VersionNumber As String
Visual C++
public:
property String^ VersionNumber {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


ControlledApplication Events

[image] [image]

Revit 2010 API
ControlledApplication Events
ControlledApplication Class See Also Send Feedback

The ControlledApplication type exposes the following members.

Events

Name | Description
ApplicationClosing | Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
DialogBoxShowing | Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
DocumentClosed | Subscribe to the DocumentClosed event to be notified immediately after Revit has finished closing a document.
DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central file.
DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central file.
FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
OnDialogBox | Obsolete. This event is deprecated since Revit version 2010. Please use DialogBoxShowing event instead. Subscribe to the OnDialogBox event to be notified when a Reivt dialog box is displayed during an API external command.
OnDocumentClosed | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentClosed event instead. Subscribe to the OnDocumentClosed event to be notified when a document is closed during an API external command.
OnDocumentNewed | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentCreated event instead. Subscribe to the OnDocumentNewed event to be notified when a new document is created during an API external command.
OnDocumentOpened | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentOpened event instead. Subscribe to the OnDocumentOpened event to be notified when a document is opened during an API external command.
OnDocumentSaved | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentSaved event instead. Subscribe to the OnDocumentSaved event to be notified when a document is saved during an API external command.
OnDocumentSavedAs | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentSavedAs event instead. Subscribe to the OnDocumentSavedAs event to be notified when a document is saved as a file with another name during an API external command.
ViewActivated | Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
ViewActivating | Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.
ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


ApplicationClosing Event

[image]

Revit 2010 API
ControlledApplication..::.ApplicationClosing Event
ControlledApplication Class See Also Send Feedback
Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<ApplicationClosingEventArgs> ApplicationClosing
Visual Basic (Declaration)
Public Event ApplicationClosing As EventHandler(Of ApplicationClosingEventArgs)
Visual C++
public:
 event EventHandler<ApplicationClosingEventArgs^>^ ApplicationClosing {
    void add (EventHandler<ApplicationClosingEventArgs^>^ value);
    void remove (EventHandler<ApplicationClosingEventArgs^>^ value);
}

Remarks

This event is raised when the Revit application is just about to be closed.

Event is not cancellable. The 'Cancellable' property of event’s argument is always 'false'.

No document may be modified at the time of the event.

The sender object of this event is ControlledApplication object.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


DialogBoxShowing Event

[image]

Revit 2010 API
ControlledApplication..::.DialogBoxShowing Event
ControlledApplication Class Example See Also Send Feedback
Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DialogBoxShowingEventArgs> DialogBoxShowing
Visual Basic (Declaration)
Public Event DialogBoxShowing As EventHandler(Of DialogBoxShowingEventArgs)
Visual C++
public:
 event EventHandler<DialogBoxShowingEventArgs^>^ DialogBoxShowing {
    void add (EventHandler<DialogBoxShowingEventArgs^>^ value);
    void remove (EventHandler<DialogBoxShowingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to show a dialog box or a message box.

Event is not cancellable. The 'Cancellable' property of event’s argument is always 'false'.

Depending on the type of the dialog that is being shown, the event's argument's type varies as follows: When it is a dialog box, the event’s argument is an object of DialogBoxShowingEventArgs. When it is a message box, the event’s argument is an object of MessageBoxShowingEventArgs,which is subclass of DialogBoxShowingEventArgs. When it is a task dialog, the event’s argument is an object of TaskDialogShowingEventArgs,which is subclass of DialogBoxShowingEventArgs.

No document may be modified during this event.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

The DialogBoxShowing event is meant to replace the older OnDialogBox event, which is now Obsolete.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

Examples

CopyC#
public class Application_DialogBoxShowing : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public IExternalApplication.Result OnStartup(ControlledApplication application)
    {
        // Register related events
        application.DialogBoxShowing += new EventHandler<Autodesk.Revit.Events.DialogBoxShowingEventArgs>(AppDialogShowing);
        return IExternalApplication.Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public IExternalApplication.Result OnShutdown(ControlledApplication application)
    {
        // unregister events
        application.DialogBoxShowing -= new EventHandler<Autodesk.Revit.Events.DialogBoxShowingEventArgs>(AppDialogShowing);
        return IExternalApplication.Result.Succeeded;
    }

    /// <summary>
    /// The DialogBoxShowing event handler, which allow you to do some work before the dialog shows
    /// </summary>
    void AppDialogShowing(object sender, Autodesk.Revit.Events.DialogBoxShowingEventArgs args)
    {
        // Get the help id of the showing dialog
        int dialogId = args.HelpId;

        // Format the prompt information string
        String promptInfo = "A revit dialog will be opened.\n";
        promptInfo += "The help id of this dialog is " + dialogId.ToString() + "\n";
        promptInfo += "If you don't want the dialog to open, please press cancel button";

        // Show the prompt message, and allow the user to close the dialog directly.
        DialogResult result = MessageBox.Show(promptInfo, "Revit", MessageBoxButtons.OKCancel);
        if (DialogResult.Cancel == result)
        {
            // Do not show the revit dialog
            args.OverrideResult(1);
        }
        else
        {
            // Continue to show the revit dialog
            args.OverrideResult(0);
        }
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_DialogBoxShowing
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.DialogBoxShowing, AddressOf AppDialogShowing
        Return IExternalApplication.Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.DialogBoxShowing, AddressOf AppDialogShowing
        Return IExternalApplication.Result.Succeeded
    End Function

    ' <summary>
    ' The DialogBoxShowing event handler, which allow you to do some work before the dialog shows
    ' </summary>
    Private Sub AppDialogShowing(ByVal sender As Object, ByVal args As Autodesk.Revit.Events.DialogBoxShowingEventArgs)
        ' Get the help id of the showing dialog
        Dim dialogId As Integer = args.HelpId

        ' Format the prompt information string
        Dim promptInfo As String = "A revit dialog will be opened." & vbLf
        promptInfo += "The help id of this dialog is " & dialogId.ToString() & vbLf
        promptInfo += "If you don't want the dialog to open, please press cancel button"

        ' Show the prompt message, and allow the user to close the dialog directly.
        Dim result As DialogResult = MessageBox.Show(promptInfo, "Revit", MessageBoxButtons.OKCancel)
        If DialogResult.Cancel = result Then
            ' Do not show the revit dialog
            args.OverrideResult(1)
        Else
            ' Continue to show the revit dialog
            args.OverrideResult(0)
        End If
    End Sub
End Class

See Also

ControlledApplication Class
Autodesk.Revit Namespace


DocumentClosed Event

[image]

Revit 2010 API
ControlledApplication..::.DocumentClosed Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentClosed event to be notified immediately after Revit has finished closing a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentClosedEventArgs> DocumentClosed
Visual Basic (Declaration)
Public Event DocumentClosed As EventHandler(Of DocumentClosedEventArgs)
Visual C++
public:
 event EventHandler<DocumentClosedEventArgs^>^ DocumentClosed {
    void add (EventHandler<DocumentClosedEventArgs^>^ value);
    void remove (EventHandler<DocumentClosedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished closing a document. It is raised even when document closing failed or was cancelled (during DocumentClosing event).

This event is not cancellable, for the process of closing document has already been finished.

The closed document cannot be modified, in fact, user has no way to access it in the event handler.

The DocumentClosed event is meant to replace the older OnDocumentClosed event, which is now Obsolete.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


DocumentClosing Event

[image]

Revit 2010 API
ControlledApplication..::.DocumentClosing Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentClosingEventArgs> DocumentClosing
Visual Basic (Declaration)
Public Event DocumentClosing As EventHandler(Of DocumentClosingEventArgs)
Visual C++
public:
 event EventHandler<DocumentClosingEventArgs^>^ DocumentClosing {
    void add (EventHandler<DocumentClosingEventArgs^>^ value);
    void remove (EventHandler<DocumentClosingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to close a document.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to 'true' to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may not be modified during this event.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentClosed event will be raised immediately after document is closed.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


DocumentCreated Event

[image]

Revit 2010 API
ControlledApplication..::.DocumentCreated Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentCreatedEventArgs> DocumentCreated
Visual Basic (Declaration)
Public Event DocumentCreated As EventHandler(Of DocumentCreatedEventArgs)
Visual C++
public:
 event EventHandler<DocumentCreatedEventArgs^>^ DocumentCreated {
    void add (EventHandler<DocumentCreatedEventArgs^>^ value);
    void remove (EventHandler<DocumentCreatedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished creating a new document. It is raised even when document creation failed or was cancelled (during DocumentCreating event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not. This event is not cancellable, for the process of document creation has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

The DocumentCreated event is meant to replace the older OnDocumentNewed event, which is now Obsolete.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


DocumentCreating Event

[image]

Revit 2010 API
ControlledApplication..::.DocumentCreating Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentCreatingEventArgs> DocumentCreating
Visual Basic (Declaration)
Public Event DocumentCreating As EventHandler(Of DocumentCreatingEventArgs)
Visual C++
public:
 event EventHandler<DocumentCreatingEventArgs^>^ DocumentCreating {
    void add (EventHandler<DocumentCreatingEventArgs^>^ value);
    void remove (EventHandler<DocumentCreatingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to create a new document.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to 'true'. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document cannot be modified, for it is not created yet at the time of the event.

Please be aware that the following API functions are not available for the current document during this event:

  • NewProjectDocument(String)
  • NewFamilyDocument(String)
  • NewProjectTemplateDocument(String)
  • OpenDocumentFile(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentCreated event will be raised immediately after document creation is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


DocumentOpened Event

[image]

Revit 2010 API
ControlledApplication..::.DocumentOpened Event
ControlledApplication Class Example See Also Send Feedback
Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentOpenedEventArgs> DocumentOpened
Visual Basic (Declaration)
Public Event DocumentOpened As EventHandler(Of DocumentOpenedEventArgs)
Visual C++
public:
 event EventHandler<DocumentOpenedEventArgs^>^ DocumentOpened {
    void add (EventHandler<DocumentOpenedEventArgs^>^ value);
    void remove (EventHandler<DocumentOpenedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished opening a document. It is raised even when document opening failed or was cancelled (during DocumentOpening event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of opening document has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

The DocumentOpened event is meant to replace the older OnDocumentOpened event, which is now Obsolete.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

Examples

CopyC#
public class Application_DocumentOpened : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement this method to subscribe to event.
    /// </summary>
    public IExternalApplication.Result OnStartup(ControlledApplication application)
    {
        try
        {
            // Register event.
            application.DocumentOpened += new EventHandler
                <Autodesk.Revit.Events.DocumentOpenedEventArgs>(application_DocumentOpened);
        }
        catch (Exception)
        {
            return IExternalApplication.Result.Failed;
        }

        return IExternalApplication.Result.Succeeded;
    }

    /// <summary>
    /// Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    /// </summary>
    public IExternalApplication.Result OnShutdown(ControlledApplication application)
    {
        // remove the event.
        application.DocumentOpened -= application_DocumentOpened;
        return IExternalApplication.Result.Succeeded;
    }

    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentOpened class description
    /// </TrivialCode>

    /// <description>
    /// This sample demonstrates how to subscribe to the DocumentOpened event and modify the model in the event handler method.
    /// </description>
    /// <summary>
    /// This is the event handler. We modify the model.
    /// </summary>
    /// <param name="sender">Event sender.</param>
    /// <param name="args"></param>
    public void application_DocumentOpened(object sender, DocumentOpenedEventArgs args)
    {
        // get document from event args.
        Document doc = args.Document;

        // Following code snippet demonstrates support of DocumentOpened event to modify the model.
        // Because DocumentOpened supports model changes, it allows user to update document data.
        // Here, this sample assigns a specified value to ProjectInformation.Address property.
        // User can change other properties of document or create(delete) something as he likes.
        //
        // Please note that ProjectInformation property is empty for family document.
        // So please don't run this sample on family document.
        doc.ProjectInformation.Address =
            "United States - Massachusetts - Waltham - 1560 Trapelo Road";
    }

    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_DocumentOpened
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement this method to subscribe to event.
    ' </summary>
    Public Function OnStartup(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnStartup
        Try
            ' Register event.
            AddHandler application.DocumentOpened, AddressOf application_DocumentOpened
        Catch generatedExceptionName As Exception
            Return IExternalApplication.Result.Failed
        End Try

        Return IExternalApplication.Result.Succeeded
    End Function

    ' <summary>
    ' Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    ' </summary>
    Public Function OnShutdown(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnShutdown
        ' remove the event.
        RemoveHandler application.DocumentOpened, AddressOf application_DocumentOpened
        Return IExternalApplication.Result.Succeeded
    End Function

    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentOpened class description
    ' </TrivialCode>

    ' <description>
    ' This sample demonstrates how to subscribe to the DocumentOpened event and modify the model in the event handler method.
    ' </description>
    ' <summary>
    ' This is the event handler. We modify the model.
    ' </summary>
    ' <param name="sender">Event sender.</param>
    ' <param name="args"></param>
    Public Sub application_DocumentOpened(ByVal sender As Object, ByVal args As Autodesk.Revit.Events.DocumentOpenedEventArgs)
        ' get document from event args.
        Dim doc As Document = args.Document

        ' Following code snippet demonstrates support of DocumentOpened event to modify the model.
        ' Because DocumentOpened supports model changes, it allows user to update document data.
        ' Here, this sample assigns a specified value to ProjectInformation.Address property.
        ' User can change other properties of document or create(delete) something as he likes.
        '
        ' Please note that ProjectInformation property is empty for family document.
        ' So please don't run this sample on family document.
        doc.ProjectInformation.Address = "United States - Massachusetts - Waltham - 610 Lincoln St"
    End Sub
End Class

' </ExampleMethod>

See Also

ControlledApplication Class
Autodesk.Revit Namespace


DocumentOpening Event

[image]

Revit 2010 API
ControlledApplication..::.DocumentOpening Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentOpeningEventArgs> DocumentOpening
Visual Basic (Declaration)
Public Event DocumentOpening As EventHandler(Of DocumentOpeningEventArgs)
Visual C++
public:
 event EventHandler<DocumentOpeningEventArgs^>^ DocumentOpening {
    void add (EventHandler<DocumentOpeningEventArgs^>^ value);
    void remove (EventHandler<DocumentOpeningEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to open a document.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to 'true'. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document cannot be modified, for it is not opened yet at the time of the event.

Another DocumentOpened event will be raised immediately after document is opened.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


DocumentPrinted Event

[image]

Revit 2010 API
ControlledApplication..::.DocumentPrinted Event
ControlledApplication Class Example See Also Send Feedback
Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentPrintedEventArgs> DocumentPrinted
Visual Basic (Declaration)
Public Event DocumentPrinted As EventHandler(Of DocumentPrintedEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintedEventArgs^>^ DocumentPrinted {
    void add (EventHandler<DocumentPrintedEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view or ViewSet of the document. It is raised even when document printing failed or was cancelled (during DocumentPriting event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of printing has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

Examples

CopyC#
public class Application_DocumentPrinted : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public IExternalApplication.Result OnStartup(ControlledApplication application)
    {
        // Register related events
        application.DocumentPrinted += new EventHandler<Autodesk.Revit.Events.DocumentPrintedEventArgs>(AppDocumentPrinted);
        return IExternalApplication.Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public IExternalApplication.Result OnShutdown(ControlledApplication application)
    {
        // unregister events
        application.DocumentPrinted -= new EventHandler<Autodesk.Revit.Events.DocumentPrintedEventArgs>(AppDocumentPrinted);
        return IExternalApplication.Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentPrinted class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for DocumentPrinted event, it will display some event arguments.
    /// </summary>
    public void AppDocumentPrinted(object sender, Autodesk.Revit.Events.DocumentPrintedEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("DocumentPrintedEventArgs Parameters ------>");
        info.AppendLine("    Event Status      : " + args.Status.ToString());
        info.AppendLine("    Event Cancellable : " + args.Cancellable);
        //
        // PrintedViews
        if (null == args.FailedViews || 0 == args.PrintedViews.Size)
        {
            info.AppendLine("    Views been printed: <null>");
        }
        else
        {
            info.AppendLine("    Views been printed: ");
            DumpViewsInfo(args.PrintedViews, "      ", ref info);
        }
        //
        // FailedViews
        if (null == args.FailedViews || 0 == args.FailedViews.Size)
        {
            info.AppendLine("    Views failed: <null>");
        }
        else
        {
            info.AppendLine("    Views Failed : ");
            DumpViewsInfo(args.FailedViews, "      ", ref info);
        }

        MessageBox.Show(info.ToString(), "DocumentPrinted Info");
    }

    /// <summary>
    /// Dump information of views: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="views">Views to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewsInfo(ViewSet views, String prefix, ref StringBuilder info)
    {
        int index = 0;
        ViewSetIterator vsi = views.ForwardIterator();
        vsi.Reset();
        while (vsi.MoveNext())
        {
            Autodesk.Revit.Elements.View curView = vsi.Current as Autodesk.Revit.Elements.View;
            if (null != curView)
            {
                DumpViewInfo(curView, String.Format("{0}#{1}", prefix, index++), ref info);
            }
        }
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.Elements.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.Value, view.ViewName, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_DocumentPrinted
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.DocumentPrinted, AddressOf AppDocumentPrinted
        Return IExternalApplication.Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.DocumentPrinted, AddressOf AppDocumentPrinted
        Return IExternalApplication.Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentPrinted class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for DocumentPrinted event, it will display some event arguments.
    ' </summary>
    Public Sub AppDocumentPrinted(ByVal sender As Object, ByVal args As Autodesk.Revit.Events.DocumentPrintedEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("DocumentPrintedEventArgs Parameters ------>")
        info.AppendLine(" Event Status : " & args.Status.ToString())
        info.AppendLine(" Event Cancellable : " & args.Cancellable)
        '
        ' PrintedViews
        If args.FailedViews Is Nothing OrElse 0 = args.PrintedViews.Size Then
            info.AppendLine(" Views been printed: <null>")
        Else
            info.AppendLine(" Views been printed: ")
            DumpViewsInfo(args.PrintedViews, " ", info)
        End If
        '
        ' FailedViews
        If args.FailedViews Is Nothing OrElse 0 = args.FailedViews.Size Then
            info.AppendLine(" Views failed: <null>")
        Else
            info.AppendLine(" Views Failed : ")
            DumpViewsInfo(args.FailedViews, " ", info)
        End If

        MessageBox.Show(info.ToString(), "DocumentPrinted Info")
    End Sub

    ' <summary>
    ' Dump information of views: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="views">Views to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewsInfo(ByVal views As ViewSet, ByVal prefix As String, ByRef info As StringBuilder)
        Dim index As Integer = 0
        Dim vsi As ViewSetIterator = views.ForwardIterator()
        vsi.Reset()
        While vsi.MoveNext()
            Dim curView As Autodesk.Revit.Elements.View = TryCast(vsi.Current, Autodesk.Revit.Elements.View)
            If curView IsNot Nothing Then
                DumpViewInfo(curView, [String].Format("{0}#{1}", prefix, System.Math.Max(System.Threading.Interlocked.Increment(index), index - 1)), info)
            End If
        End While
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(ByVal view As Autodesk.Revit.Elements.View, ByVal prefix As String, ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.Value, view.ViewName, view.ViewType))
    End Sub
End Class

See Also

ControlledApplication Class
Autodesk.Revit Namespace


DocumentPrinting Event

[image]

Revit 2010 API
ControlledApplication..::.DocumentPrinting Event
ControlledApplication Class Example See Also Send Feedback
Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentPrintingEventArgs> DocumentPrinting
Visual Basic (Declaration)
Public Event DocumentPrinting As EventHandler(Of DocumentPrintingEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintingEventArgs^>^ DocumentPrinting {
    void add (EventHandler<DocumentPrintingEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view or ViewSet of the document.

This event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to 'true'. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Export(String, String, GBXMLExportOptions) and similar overloads.
  • Autodesk.Revit.Document.Print()
  • Print()()() and similar overloads.
  • SubmitPrint()()() and similar overloads.
  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

After this event, for each view being printed,ViewPrinting and ViewPrinted events will be raised. Another event DocumentPrinted will be raised immediately after document printing is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

Examples

CopyC#
public class Application_DocumentPrinting : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public IExternalApplication.Result OnStartup(ControlledApplication application)
    {
        // Register related events
        application.DocumentPrinting += new EventHandler<Autodesk.Revit.Events.DocumentPrintingEventArgs>(AppDocumentPrinting);
        return IExternalApplication.Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public IExternalApplication.Result OnShutdown(ControlledApplication application)
    {
        // unregister events
        application.DocumentPrinting -= new EventHandler<Autodesk.Revit.Events.DocumentPrintingEventArgs>(AppDocumentPrinting);
        return IExternalApplication.Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentPrinting class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for DocumentPrinting event, it will display some event arguments.
    /// </summary>
    public void AppDocumentPrinting(object sender, Autodesk.Revit.Events.DocumentPrintingEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("DocumentPrintingEventArgs Parameters ------>");

        info.AppendLine("    Event Cancellable   : " + args.Cancellable);
        info.AppendLine("    Views to be printed : "); // Views
        DumpViewsInfo(args.Views, "    ", ref info);

        MessageBox.Show(info.ToString(), "DocumentPrinting Info");
    }

    /// <summary>
    /// Dump information of views: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="views">Views to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewsInfo(ViewSet views, String prefix, ref StringBuilder info)
    {
        int index = 0;
        ViewSetIterator vsi = views.ForwardIterator();
        vsi.Reset();
        while (vsi.MoveNext())
        {
            Autodesk.Revit.Elements.View curView = vsi.Current as Autodesk.Revit.Elements.View;
            if (null != curView)
            {
                DumpViewInfo(curView, String.Format("{0}#{1}", prefix, index++), ref info);
            }
        }
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line sent to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.Elements.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.Value, view.ViewName, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_DocumentPrinting
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.DocumentPrinting, AddressOf AppDocumentPrinting
        Return IExternalApplication.Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.DocumentPrinting, AddressOf AppDocumentPrinting
        Return IExternalApplication.Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentPrinting class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for DocumentPrinting event, it will display some event arguments.
    ' </summary>
    Public Sub AppDocumentPrinting(ByVal sender As Object, ByVal args As Autodesk.Revit.Events.DocumentPrintingEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("DocumentPrintingEventArgs Parameters ------>")

        info.AppendLine(" Event Cancellable : " & args.Cancellable)
        info.AppendLine(" Views to be printed : ")
        ' Views
        DumpViewsInfo(args.Views, " ", info)

        MessageBox.Show(info.ToString(), "DocumentPrinting Info")
    End Sub

    ' <summary>
    ' Dump information of views: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="views">Views to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewsInfo(ByVal views As ViewSet, ByVal prefix As String, ByRef info As StringBuilder)
        Dim index As Integer = 0
        Dim vsi As ViewSetIterator = views.ForwardIterator()
        vsi.Reset()
        While vsi.MoveNext()
            Dim curView As Autodesk.Revit.Elements.View = TryCast(vsi.Current, Autodesk.Revit.Elements.View)
            If curView IsNot Nothing Then
                DumpViewInfo(curView, [String].Format("{0}#{1}", prefix, System.Math.Max(System.Threading.Interlocked.Increment(index), index - 1)), info)
            End If
        End While
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line sent to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(ByVal view As Autodesk.Revit.Elements.View, ByVal prefix As String, ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.Value, view.ViewName, view.ViewType))
    End Sub
End Class

See Also

ControlledApplication Class
Autodesk.Revit Namespace


DocumentSaved Event

[image]

Revit 2010 API
ControlledApplication..::.DocumentSaved Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentSavedEventArgs> DocumentSaved
Visual Basic (Declaration)
Public Event DocumentSaved As EventHandler(Of DocumentSavedEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedEventArgs^>^ DocumentSaved {
    void add (EventHandler<DocumentSavedEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving a document. Note that the first save of a newly created document will raise DocumentSavedAs rather than the DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSaving event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

The DocumentSaved event is meant to replace the older OnDocumentSaved event, which is now Obsolete.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


DocumentSavedAs Event

[image]

Revit 2010 API
ControlledApplication..::.DocumentSavedAs Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentSavedAsEventArgs> DocumentSavedAs
Visual Basic (Declaration)
Public Event DocumentSavedAs As EventHandler(Of DocumentSavedAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedAsEventArgs^>^ DocumentSavedAs {
    void add (EventHandler<DocumentSavedAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedAsEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving document with a new file name. Note that the first save of a newly created document will raise DocumentSavedAs rather than DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSavingAs event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

The DocumentSavedAs event is meant to replace the older OnDocumentSavedAs event, which is now Obsolete.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


DocumentSaving Event

[image]

Revit 2010 API
ControlledApplication..::.DocumentSaving Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentSavingEventArgs> DocumentSaving
Visual Basic (Declaration)
Public Event DocumentSaving As EventHandler(Of DocumentSavingEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingEventArgs^>^ DocumentSaving {
    void add (EventHandler<DocumentSavingEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document. Note that the first save of a newly created document will raise DocumentSavingAs rather than the DocumentSaving event.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to 'true' to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSaved will be raised immediately after the document has been saved.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


DocumentSavingAs Event

[image]

Revit 2010 API
ControlledApplication..::.DocumentSavingAs Event
ControlledApplication Class Example See Also Send Feedback
Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentSavingAsEventArgs> DocumentSavingAs
Visual Basic (Declaration)
Public Event DocumentSavingAs As EventHandler(Of DocumentSavingAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingAsEventArgs^>^ DocumentSavingAs {
    void add (EventHandler<DocumentSavingAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingAsEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document with a new file name. Note that the first save of a newly created document will raise DocumentSavingAs rather than DocumentSaving event.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to 'true' to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSavedAs will be raised immediately after the document has been saved with a new file name.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

Examples

CopyC#
public class DocumentSavingAs : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// This method subscribes to DocumentSavingAs event.
    /// </summary>
    public IExternalApplication.Result OnStartup(ControlledApplication application)
    {
        application.DocumentSavingAs += new EventHandler<DocumentSavingAsEventArgs>(CheckProjectStatusInitial);
        return IExternalApplication.Result.Succeeded;
    }

    /// <summary>
    /// Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    /// </summary>
    public IExternalApplication.Result OnShutdown(ControlledApplication application)
    {
        // unregister subscribed event
        application.DocumentSavingAs -= new EventHandler<DocumentSavingAsEventArgs>(CheckProjectStatusInitial);
        return IExternalApplication.Result.Succeeded;
    }

    /// <summary>
    /// Event handler method for DocumentSavingAs event. This method will check the "Project Status" value,
    /// if it is null or empty string cancel the save as process.
    /// </summary>
    /// <param name="sender">The source of the event.</param>
    /// <param name="args">Event arguments that contains the event data.</param>
    private void CheckProjectStatusInitial(Object sender, DocumentSavingAsEventArgs args)
    {
        Document doc = args.Document;
        ProjectInfo proInfo = doc.ProjectInformation;

        // Project information is only available for project document.
        if (null != proInfo)
        {
            if (string.IsNullOrEmpty(proInfo.Status))
            {
                // cancel the save as process.
                args.Cancel = true;
                MessageBox.Show("Status project parameter is not set.  Save is aborted.");
            }
        }
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class DocumentSavingAs
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' This method subscribes to DocumentSavingAs event.
    ' </summary>
    Public Function OnStartup(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnStartup
        AddHandler application.DocumentSavingAs, AddressOf CheckProjectStatusInitial
        Return IExternalApplication.Result.Succeeded
    End Function

    ' <summary>
    ' Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    ' </summary>
    Public Function OnShutdown(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnShutdown
        ' unregister subscribed event
        RemoveHandler application.DocumentSavingAs, AddressOf CheckProjectStatusInitial
        Return IExternalApplication.Result.Succeeded
    End Function

    ' <summary>
    ' Event handler method for DocumentSavingAs event. This method will check the "Project Status" value,
    ' if it is null or empty string cancel the save as process.
    ' </summary>
    ' <param name="sender">The source of the event.</param>
    ' <param name="args">Event arguments that contains the event data.</param>
    Private Sub CheckProjectStatusInitial(ByVal sender As Object, ByVal args As Autodesk.Revit.Events.DocumentSavingAsEventArgs)
        Dim doc As Document = args.Document
        Dim proInfo As Autodesk.Revit.Elements.ProjectInfo = doc.ProjectInformation

        ' Project information is only available for project document.
        If proInfo IsNot Nothing Then
            If String.IsNullOrEmpty(proInfo.Status) Then
                ' cancel the save as process.
                args.Cancel = True
            End If
        End If
    End Sub
End Class

See Also

ControlledApplication Class
Autodesk.Revit Namespace


DocumentSynchronizedWithCentral Event

[image]

Revit 2010 API
ControlledApplication..::.DocumentSynchronizedWithCentral Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentSynchronizedWithCentralEventArgs> DocumentSynchronizedWithCentral
Visual Basic (Declaration)
Public Event DocumentSynchronizedWithCentral As EventHandler(Of DocumentSynchronizedWithCentralEventArgs)
Visual C++
public:
 event EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ DocumentSynchronizedWithCentral {
    void add (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished synchronizing a document with central file. It is raised even when document synchronizing with central file failed or was cancelled (during DocumentSynchronizingWithCentral event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of synchronizing a document with central file has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


DocumentSynchronizingWithCentral Event

[image]

Revit 2010 API
ControlledApplication..::.DocumentSynchronizingWithCentral Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentSynchronizingWithCentralEventArgs> DocumentSynchronizingWithCentral
Visual Basic (Declaration)
Public Event DocumentSynchronizingWithCentral As EventHandler(Of DocumentSynchronizingWithCentralEventArgs)
Visual C++
public:
 event EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ DocumentSynchronizingWithCentral {
    void add (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to synchronize a document with central file.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to 'true'. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentSynchronizedWithCentral event will be raised immediately after document synchronizing with central file is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


FileExported Event

[image]

Revit 2010 API
ControlledApplication..::.FileExported Event
ControlledApplication Class See Also Send Feedback
Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<FileExportedEventArgs> FileExported
Visual Basic (Declaration)
Public Event FileExported As EventHandler(Of FileExportedEventArgs)
Visual C++
public:
 event EventHandler<FileExportedEventArgs^>^ FileExported {
    void add (EventHandler<FileExportedEventArgs^>^ value);
    void remove (EventHandler<FileExportedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished exporting files of formats supported by the API. It is raised even when file exporting failed or was cancelled (during FileExporting event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not. If export is a part of ‘Publish to Buzzsaw’ command which consists of two parts – export of a document followed by publishing it to a BuzzSaw server, the event status only reflects the result of the Export action. The publishing part of the command could still be cancelled or could fail after FileExported event is raised.

This event is not cancellable, for the process of exporting file has already been finished.

If the Export action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


FileExporting Event

[image]

Revit 2010 API
ControlledApplication..::.FileExporting Event
ControlledApplication Class See Also Send Feedback
Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<FileExportingEventArgs> FileExporting
Visual Basic (Declaration)
Public Event FileExporting As EventHandler(Of FileExportingEventArgs)
Visual C++
public:
 event EventHandler<FileExportingEventArgs^>^ FileExporting {
    void add (EventHandler<FileExportingEventArgs^>^ value);
    void remove (EventHandler<FileExportingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to export files of formats supported by the API.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to 'true'. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Export(String, String, GBXMLExportOptions) and similar overloads.
  • Autodesk.Revit.Document.Print()
  • Print()()() and similar overloads.
  • SubmitPrint()()() and similar overloads.
  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileExported event will be raised immediately after file exporting is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


FileImported Event

[image]

Revit 2010 API
ControlledApplication..::.FileImported Event
ControlledApplication Class See Also Send Feedback
Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<FileImportedEventArgs> FileImported
Visual Basic (Declaration)
Public Event FileImported As EventHandler(Of FileImportedEventArgs)
Visual C++
public:
 event EventHandler<FileImportedEventArgs^>^ FileImported {
    void add (EventHandler<FileImportedEventArgs^>^ value);
    void remove (EventHandler<FileImportedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished importing a file of format supported by the API. It is raised even when file importing failed or was cancelled (during FileImporting event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of importing has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


FileImporting Event

[image]

Revit 2010 API
ControlledApplication..::.FileImporting Event
ControlledApplication Class See Also Send Feedback
Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<FileImportingEventArgs> FileImporting
Visual Basic (Declaration)
Public Event FileImporting As EventHandler(Of FileImportingEventArgs)
Visual C++
public:
 event EventHandler<FileImportingEventArgs^>^ FileImporting {
    void add (EventHandler<FileImportingEventArgs^>^ value);
    void remove (EventHandler<FileImportingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to import a file of format supported by the API.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to 'true'. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event. A transaction is already created at the time of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Import(String, GBXMLImportOptions) and similar overloads.
  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileImported event will be raised immediately after file importing is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


OnDialogBox Event

[image]

Revit 2010 API
ControlledApplication..::.OnDialogBox Event
ControlledApplication Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DialogBoxShowing event instead. Subscribe to the OnDialogBox event to be notified when a Reivt dialog box is displayed during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DialogBoxShowing event instead.")]
public event DialogBoxEventHandler OnDialogBox
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DialogBoxShowing event instead.")> _
Public Event OnDialogBox As DialogBoxEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DialogBoxShowing event instead.")]
public:
 event DialogBoxEventHandler^ OnDialogBox {
    void add (DialogBoxEventHandler^ value);
    void remove (DialogBoxEventHandler^ value);
}

Remarks

Sometimes a Revit dialog box may be displayed during an API external application. By subscribing to this event you application will be notified of such an event and perform an action, such as causing the dialog to be ok'd or cancelled etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


OnDocumentClosed Event

[image]

Revit 2010 API
ControlledApplication..::.OnDocumentClosed Event
ControlledApplication Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentClosed event instead. Subscribe to the OnDocumentClosed event to be notified when a document is closed during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentClosed event instead.")]
public event DocumentClosedEventHandler OnDocumentClosed
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentClosed event instead.")> _
Public Event OnDocumentClosed As DocumentClosedEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentClosed event instead.")]
public:
 event DocumentClosedEventHandler^ OnDocumentClosed {
    void add (DocumentClosedEventHandler^ value);
    void remove (DocumentClosedEventHandler^ value);
}

Remarks

Sometimes a document will be closed during an API command. By subscribing to this event your application will be notified of such an event and perform an action, such as do some external checking etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


OnDocumentNewed Event

[image]

Revit 2010 API
ControlledApplication..::.OnDocumentNewed Event
ControlledApplication Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentCreated event instead. Subscribe to the OnDocumentNewed event to be notified when a new document is created during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentCreated event instead.")]
public event DocumentNewedEventHandler OnDocumentNewed
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentCreated event instead.")> _
Public Event OnDocumentNewed As DocumentNewedEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentCreated event instead.")]
public:
 event DocumentNewedEventHandler^ OnDocumentNewed {
    void add (DocumentNewedEventHandler^ value);
    void remove (DocumentNewedEventHandler^ value);
}

Remarks

Sometimes a new document will be created during an API command. By subscribing to this event your application will be notified of such an event and perform an action, such as create some elements for this document etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


OnDocumentOpened Event

[image]

Revit 2010 API
ControlledApplication..::.OnDocumentOpened Event
ControlledApplication Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentOpened event instead. Subscribe to the OnDocumentOpened event to be notified when a document is opened during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentOpened event instead.")]
public event DocumentOpenedEventHandler OnDocumentOpened
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentOpened event instead.")> _
Public Event OnDocumentOpened As DocumentOpenedEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentOpened event instead.")]
public:
 event DocumentOpenedEventHandler^ OnDocumentOpened {
    void add (DocumentOpenedEventHandler^ value);
    void remove (DocumentOpenedEventHandler^ value);
}

Remarks

Sometimes a document will be opened during an API command. By subscribing to this event your application will be notified of such an event and perform an action, such as get some elements from the opened document etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


OnDocumentSaved Event

[image]

Revit 2010 API
ControlledApplication..::.OnDocumentSaved Event
ControlledApplication Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentSaved event instead. Subscribe to the OnDocumentSaved event to be notified when a document is saved during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSaved event instead.")]
public event DocumentSavedEventHandler OnDocumentSaved
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSaved event instead.")> _
Public Event OnDocumentSaved As DocumentSavedEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentSaved event instead.")]
public:
 event DocumentSavedEventHandler^ OnDocumentSaved {
    void add (DocumentSavedEventHandler^ value);
    void remove (DocumentSavedEventHandler^ value);
}

Remarks

Sometimes a document will be saved during an API command. By subscribing to this event your application will be notified of such an event and perform an action, such as do some external checking etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


OnDocumentSavedAs Event

[image]

Revit 2010 API
ControlledApplication..::.OnDocumentSavedAs Event
ControlledApplication Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentSavedAs event instead. Subscribe to the OnDocumentSavedAs event to be notified when a document is saved as a file with another name during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSavedAs event instead.")]
public event DocumentSavedAsEventHandler OnDocumentSavedAs
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSavedAs event instead.")> _
Public Event OnDocumentSavedAs As DocumentSavedAsEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentSavedAs event instead.")]
public:
 event DocumentSavedAsEventHandler^ OnDocumentSavedAs {
    void add (DocumentSavedAsEventHandler^ value);
    void remove (DocumentSavedAsEventHandler^ value);
}

Remarks

Sometimes a document will be saved to a file with another name during an API command. By subscribing to this event your application will be notified of such an event and perform an action, such as do some external checking etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


ViewActivated Event

[image]

Revit 2010 API
ControlledApplication..::.ViewActivated Event
ControlledApplication Class See Also Send Feedback
Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<ViewActivatedEventArgs> ViewActivated
Visual Basic (Declaration)
Public Event ViewActivated As EventHandler(Of ViewActivatedEventArgs)
Visual C++
public:
 event EventHandler<ViewActivatedEventArgs^>^ ViewActivated {
    void add (EventHandler<ViewActivatedEventArgs^>^ value);
    void remove (EventHandler<ViewActivatedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished activating a view of the document. It is raised even when view activating failed or was cancelled (during ViewActivating event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of view activating has already been finished.

The document may not be modified during this event.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


ViewActivating Event

[image]

Revit 2010 API
ControlledApplication..::.ViewActivating Event
ControlledApplication Class See Also Send Feedback
Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<ViewActivatingEventArgs> ViewActivating
Visual Basic (Declaration)
Public Event ViewActivating As EventHandler(Of ViewActivatingEventArgs)
Visual C++
public:
 event EventHandler<ViewActivatingEventArgs^>^ ViewActivating {
    void add (EventHandler<ViewActivatingEventArgs^>^ value);
    void remove (EventHandler<ViewActivatingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to activate a view of the document.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to 'true'. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may not be modified during this event.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another ViewActivated event will be raised immediately after view activating is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace


ViewPrinted Event

[image]

Revit 2010 API
ControlledApplication..::.ViewPrinted Event
ControlledApplication Class Example See Also Send Feedback
Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<ViewPrintedEventArgs> ViewPrinted
Visual Basic (Declaration)
Public Event ViewPrinted As EventHandler(Of ViewPrintedEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintedEventArgs^>^ ViewPrinted {
    void add (EventHandler<ViewPrintedEventArgs^>^ value);
    void remove (EventHandler<ViewPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view of the document. It is raised even when view printing failed.

Check the 'Status' field in event’s argument to see whether the action was successful or not.

This event is not cancellable, for the process of view printing has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

Examples

CopyC#
public class Application_ViewPrinted : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public IExternalApplication.Result OnStartup(ControlledApplication application)
    {
        // Register related events
        application.ViewPrinted += new EventHandler<Autodesk.Revit.Events.ViewPrintedEventArgs>(AppViewPrinted);
        return IExternalApplication.Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public IExternalApplication.Result OnShutdown(ControlledApplication application)
    {
        // unregister events
        application.ViewPrinted -= new EventHandler<Autodesk.Revit.Events.ViewPrintedEventArgs>(AppViewPrinted);
        return IExternalApplication.Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For ViewPrinted class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for ViewPrinting event, it will dump some event arguments.
    /// </summary>
    public void AppViewPrinted(object sender, Autodesk.Revit.Events.ViewPrintedEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("ViewPrintedEventArgs Parameters ------>");
        info.AppendLine("    Event Status        : " + args.Status);
        info.AppendLine("    TotalViews          : " + args.TotalViews);
        info.AppendLine("    View Index          : " + args.Index);
        info.AppendLine("    View Information    :");
        DumpViewInfo(args.View, "      ", ref info);

        MessageBox.Show(info.ToString(), "ViewPrinted Info");
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box string.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.Elements.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.Value, view.ViewName, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_ViewPrinted
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ViewPrinted, AddressOf AppViewPrinted
        Return IExternalApplication.Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ViewPrinted, AddressOf AppViewPrinted
        Return IExternalApplication.Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For ViewPrinted class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for ViewPrinting event, it will dump some event arguments.
    ' </summary>
    Public Sub AppViewPrinted(ByVal sender As Object, ByVal args As Autodesk.Revit.Events.ViewPrintedEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("ViewPrintedEventArgs Parameters ------>")
        info.AppendLine(" Event Status : " & args.Status)
        info.AppendLine(" TotalViews : " & args.TotalViews)
        info.AppendLine(" View Index : " & args.Index)
        info.AppendLine(" View Information :")
        DumpViewInfo(args.View, " ", info)

        MessageBox.Show(info.ToString(), "ViewPrinted Info")
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box string.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(ByVal view As Autodesk.Revit.Elements.View, ByVal prefix As String, ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.Value, view.ViewName, view.ViewType))
    End Sub
End Class

See Also

ControlledApplication Class
Autodesk.Revit Namespace


ViewPrinting Event

[image]

Revit 2010 API
ControlledApplication..::.ViewPrinting Event
ControlledApplication Class Example See Also Send Feedback
Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<ViewPrintingEventArgs> ViewPrinting
Visual Basic (Declaration)
Public Event ViewPrinting As EventHandler(Of ViewPrintingEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintingEventArgs^>^ ViewPrinting {
    void add (EventHandler<ViewPrintingEventArgs^>^ value);
    void remove (EventHandler<ViewPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view of the document.

Event is not cancellable. The 'Cancellable' property of event’s argument is always 'false'.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Export(String, String, GBXMLExportOptions) and similar overloads.
  • Autodesk.Revit.Document.Print()
  • Print()()() and similar overloads.
  • SubmitPrint()()() and similar overloads.
  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewPrinted will be raised immediately after view printing is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

Examples

CopyC#
public class Application_ViewPrinting : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public IExternalApplication.Result OnStartup(ControlledApplication application)
    {
        // Register related events
        application.ViewPrinting += new EventHandler<Autodesk.Revit.Events.ViewPrintingEventArgs>(AppViewPrinting);
        return IExternalApplication.Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public IExternalApplication.Result OnShutdown(ControlledApplication application)
    {
        // unregister events
        application.ViewPrinting -= new EventHandler<Autodesk.Revit.Events.ViewPrintingEventArgs>(AppViewPrinting);
        return IExternalApplication.Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For ViewPrinting class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for ViewPrinting event, it will display some event arguments.
    /// </summary>
    public void AppViewPrinting(object sender, Autodesk.Revit.Events.ViewPrintingEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("ViewPrintingEventArgs Parameters ------>");
        info.AppendLine("    Event Cancellable   : " + args.Cancellable);
        info.AppendLine("    TotalViews          : " + args.TotalViews);
        info.AppendLine("    View Index          : " + args.Index);
        info.AppendLine("    View Information    :"); // View
        DumpViewInfo(args.View, "      ", ref info);

        MessageBox.Show(info.ToString(), "ViewPrinting Info");
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box string.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.Elements.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.Value, view.ViewName, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_ViewPrinting
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ViewPrinting, AddressOf AppViewPrinting
        Return IExternalApplication.Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ViewPrinting, AddressOf AppViewPrinting
        Return IExternalApplication.Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For ViewPrinting class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for ViewPrinting event, it will display some event arguments.
    ' </summary>
    Public Sub AppViewPrinting(ByVal sender As Object, ByVal args As Autodesk.Revit.Events.ViewPrintingEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("ViewPrintingEventArgs Parameters ------>")
        info.AppendLine(" Event Cancellable : " & args.Cancellable)
        info.AppendLine(" TotalViews : " & args.TotalViews)
        info.AppendLine(" View Index : " & args.Index)
        info.AppendLine(" View Information :")
        ' View
        DumpViewInfo(args.View, " ", info)

        MessageBox.Show(info.ToString(), "ViewPrinting Info")
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box string.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(ByVal view As Autodesk.Revit.Elements.View, ByVal prefix As String, ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.Value, view.ViewName, view.ViewType))
    End Sub
End Class

See Also

ControlledApplication Class
Autodesk.Revit Namespace


CurveLoopsProfile Class

[image]

Revit 2010 API
CurveLoopsProfile Class
Members See Also Send Feedback
Represents a curve loop based profile for sweep or swept blend elements.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CurveLoopsProfile : SweepProfile
Visual Basic (Declaration)
Public Class CurveLoopsProfile _
    Inherits SweepProfile
Visual C++
public ref class CurveLoopsProfile : public SweepProfile

Remarks

Use objects of this type in methods as NewSweep and NewSweptBlend to create the profile.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.SweepProfile
Autodesk.Revit..::.CurveLoopsProfile

See Also

CurveLoopsProfile Members
Autodesk.Revit Namespace


CurveLoopsProfile Members

[image] [image]

Revit 2010 API
CurveLoopsProfile Members
CurveLoopsProfile Class Constructors Methods Properties See Also Send Feedback

The CurveLoopsProfile type exposes the following members.

Constructors

Name | Description
CurveLoopsProfile | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Profile | Returns the curve loops of the profile.

See Also

CurveLoopsProfile Class
Autodesk.Revit Namespace


CurveLoopsProfile Constructor

[image]

Revit 2010 API
CurveLoopsProfile Constructor
CurveLoopsProfile Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveLoopsProfile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurveLoopsProfile()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurveLoopsProfile Class
Autodesk.Revit Namespace


CurveLoopsProfile Methods

[image] [image]

Revit 2010 API
CurveLoopsProfile Methods
CurveLoopsProfile Class See Also Send Feedback

The CurveLoopsProfile type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveLoopsProfile Class
Autodesk.Revit Namespace


CurveLoopsProfile Properties

[image] [image]

Revit 2010 API
CurveLoopsProfile Properties
CurveLoopsProfile Class See Also Send Feedback

The CurveLoopsProfile type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Profile | Returns the curve loops of the profile.

See Also

CurveLoopsProfile Class
Autodesk.Revit Namespace


Profile Property

[image]

Revit 2010 API
CurveLoopsProfile..::.Profile Property
CurveLoopsProfile Class See Also Send Feedback
Returns the curve loops of the profile.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArrArray Profile { get; set; }
Visual Basic (Declaration)
Public Property Profile As CurveArrArray
Visual C++
public:
property CurveArrArray^ Profile {
    CurveArrArray^ get ();
    void set (CurveArrArray^ value);
}

Remarks

This property is used to retrieve the curve loops of profile.

See Also

CurveLoopsProfile Class
Autodesk.Revit Namespace


DGNExportOptions Class

[image]

Revit 2010 API
DGNExportOptions Class
Members See Also Send Feedback
DGN Export options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DGNExportOptions : CADExportOptions
Visual Basic (Declaration)
Public Class DGNExportOptions _
    Inherits CADExportOptions
Visual C++
public ref class DGNExportOptions : public CADExportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.CADExportOptions
Autodesk.Revit..::.DGNExportOptions

See Also

DGNExportOptions Members
Autodesk.Revit Namespace


DGNExportOptions Members

[image] [image]

Revit 2010 API
DGNExportOptions Members
DGNExportOptions Class Constructors Methods Properties See Also Send Feedback

The DGNExportOptions type exposes the following members.

Constructors

Name | Description
DGNExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExportOfSolids | Mode of exporting solids in 3D views.
LayerMapping | Name of a layer settings standard or filename (with custom layer settings).
TemplateFile | The template file for DGN export.

See Also

DGNExportOptions Class
Autodesk.Revit Namespace


DGNExportOptions Constructor

[image]

Revit 2010 API
DGNExportOptions Constructor
DGNExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DGNExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DGNExportOptions()

See Also

DGNExportOptions Class
Autodesk.Revit Namespace


DGNExportOptions Methods

[image] [image]

Revit 2010 API
DGNExportOptions Methods
DGNExportOptions Class See Also Send Feedback

The DGNExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DGNExportOptions Class
Autodesk.Revit Namespace


DGNExportOptions Properties

[image] [image]

Revit 2010 API
DGNExportOptions Properties
DGNExportOptions Class See Also Send Feedback

The DGNExportOptions type exposes the following members.

Properties

Name | Description
ExportOfSolids | Mode of exporting solids in 3D views.
LayerMapping | Name of a layer settings standard or filename (with custom layer settings).
TemplateFile | The template file for DGN export.

See Also

DGNExportOptions Class
Autodesk.Revit Namespace


ExportOfSolids Property

[image]

Revit 2010 API
DGNExportOptions..::.ExportOfSolids Property
DGNExportOptions Class See Also Send Feedback
Mode of exporting solids in 3D views.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SolidGeometry ExportOfSolids { get; set; }
Visual Basic (Declaration)
Public Property ExportOfSolids As SolidGeometry
Visual C++
public:
property SolidGeometry ExportOfSolids {
    SolidGeometry get ();
    void set (SolidGeometry value);
}

See Also

DGNExportOptions Class
Autodesk.Revit Namespace


LayerMapping Property

[image]

Revit 2010 API
DGNExportOptions..::.LayerMapping Property
DGNExportOptions Class See Also Send Feedback
Name of a layer settings standard or filename (with custom layer settings).

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string LayerMapping { get; set; }
Visual Basic (Declaration)
Public Property LayerMapping As String
Visual C++
public:
property String^ LayerMapping {
    String^ get ();
    void set (String^ value);
}

Remarks

Valid standards are: AIA, CP83, BS1192, and ISO13567.

See Also

DGNExportOptions Class
Autodesk.Revit Namespace


TemplateFile Property

[image]

Revit 2010 API
DGNExportOptions..::.TemplateFile Property
DGNExportOptions Class See Also Send Feedback
The template file for DGN export.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string TemplateFile { get; set; }
Visual Basic (Declaration)
Public Property TemplateFile As String
Visual C++
public:
property String^ TemplateFile {
    String^ get ();
    void set (String^ value);
}

Remarks

It must be a .dgn template, and it's optional, can be empty.

See Also

DGNExportOptions Class
Autodesk.Revit Namespace


DimensionSegment Class

[image]

Revit 2010 API
DimensionSegment Class
Members See Also Send Feedback
A segment of a dimension within the Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DimensionSegment : APIObject
Visual Basic (Declaration)
Public Class DimensionSegment _
    Inherits APIObject
Visual C++
public ref class DimensionSegment : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.DimensionSegment

See Also

DimensionSegment Members
Autodesk.Revit Namespace


DimensionSegment Members

[image] [image]

Revit 2010 API
DimensionSegment Members
DimensionSegment Class Constructors Methods Properties See Also Send Feedback

The DimensionSegment type exposes the following members.

Constructors

Name | Description
DimensionSegment | Initializes a new instance of the DimensionSegment class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsLocked | Indicates if this segment is locked.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Origin | The segment origin.
Value | The length of the segment.
ValueString | The displayed value shown for the dimension segment.

See Also

DimensionSegment Class
Autodesk.Revit Namespace


DimensionSegment Constructor

[image]

Revit 2010 API
DimensionSegment Constructor
DimensionSegment Class See Also Send Feedback
Initializes a new instance of the DimensionSegment class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DimensionSegment()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DimensionSegment()

See Also

DimensionSegment Class
Autodesk.Revit Namespace


DimensionSegment Methods

[image] [image]

Revit 2010 API
DimensionSegment Methods
DimensionSegment Class See Also Send Feedback

The DimensionSegment type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionSegment Class
Autodesk.Revit Namespace


DimensionSegment Properties

[image] [image]

Revit 2010 API
DimensionSegment Properties
DimensionSegment Class See Also Send Feedback

The DimensionSegment type exposes the following members.

Properties

Name | Description
IsLocked | Indicates if this segment is locked.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Origin | The segment origin.
Value | The length of the segment.
ValueString | The displayed value shown for the dimension segment.

See Also

DimensionSegment Class
Autodesk.Revit Namespace


IsLocked Property

[image]

Revit 2010 API
DimensionSegment..::.IsLocked Property
DimensionSegment Class See Also Send Feedback
Indicates if this segment is locked.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsLocked { get; set; }
Visual Basic (Declaration)
Public Property IsLocked As Boolean
Visual C++
public:
property bool IsLocked {
    bool get ();
    void set (bool value);
}

Remarks

This property always returns false if the dimension is a radial or spot dimension. This property cannot be set if the segment has been labeled, or the dimension shape is a radial or spot dimension.

See Also

DimensionSegment Class
Autodesk.Revit Namespace


Origin Property

[image]

Revit 2010 API
DimensionSegment..::.Origin Property
DimensionSegment Class See Also Send Feedback
The segment origin.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

Remarks

The origin will be the midpoint of the line that makes up the segment.

See Also

DimensionSegment Class
Autodesk.Revit Namespace


Value Property

[image]

Revit 2010 API
DimensionSegment..::.Value Property
DimensionSegment Class See Also Send Feedback
The length of the segment.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Nullable<double> Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Nullable(Of Double)
Visual C++
public:
property Nullable<double> Value {
    Nullable<double> get ();
}

See Also

DimensionSegment Class
Autodesk.Revit Namespace


ValueString Property

[image]

Revit 2010 API
DimensionSegment..::.ValueString Property
DimensionSegment Class See Also Send Feedback
The displayed value shown for the dimension segment.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string ValueString { get; }
Visual Basic (Declaration)
Public ReadOnly Property ValueString As String
Visual C++
public:
property String^ ValueString {
    String^ get ();
}

See Also

DimensionSegment Class
Autodesk.Revit Namespace


DimensionSegmentArray Class

[image]

Revit 2010 API
DimensionSegmentArray Class
Members See Also Send Feedback
An array that can contain any number of DimensionSegment objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DimensionSegmentArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class DimensionSegmentArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DimensionSegmentArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.DimensionSegmentArray

See Also

DimensionSegmentArray Members
Autodesk.Revit Namespace


DimensionSegmentArray Members

[image] [image]

Revit 2010 API
DimensionSegmentArray Members
DimensionSegmentArray Class Constructors Methods Properties See Also Send Feedback

The DimensionSegmentArray type exposes the following members.

Constructors

Name | Description
DimensionSegmentArray | Initializes a new instance of the DimensionSegmentArray class

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

DimensionSegmentArray Class
Autodesk.Revit Namespace


DimensionSegmentArray Constructor

[image]

Revit 2010 API
DimensionSegmentArray Constructor
DimensionSegmentArray Class See Also Send Feedback
Initializes a new instance of the DimensionSegmentArray class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DimensionSegmentArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DimensionSegmentArray()

See Also

DimensionSegmentArray Class
Autodesk.Revit Namespace


DimensionSegmentArray Methods

[image] [image]

Revit 2010 API
DimensionSegmentArray Methods
DimensionSegmentArray Class See Also Send Feedback

The DimensionSegmentArray type exposes the following members.

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionSegmentArray Class
Autodesk.Revit Namespace


Append Method

[image]

Revit 2010 API
DimensionSegmentArray..::.Append Method
DimensionSegmentArray Class See Also Send Feedback
Add the item to the end of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    DimensionSegment item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As DimensionSegment _
)
Visual C++
public:
virtual void Append(
    DimensionSegment^ item
)

Parameters

item
Type: Autodesk.Revit..::.DimensionSegment
The item to be added.

See Also

DimensionSegmentArray Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
DimensionSegmentArray..::.Clear Method
DimensionSegmentArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DimensionSegmentArray Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
DimensionSegmentArray..::.ForwardIterator Method
DimensionSegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DimensionSegmentArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DimensionSegmentArrayIterator
Visual C++
public:
virtual DimensionSegmentArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

DimensionSegmentArray Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
DimensionSegmentArray..::.GetEnumerator Method
DimensionSegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DimensionSegmentArray Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
DimensionSegmentArray..::.Insert Method
DimensionSegmentArray Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    DimensionSegment item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As DimensionSegment, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    DimensionSegment^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit..::.DimensionSegment
The item to be inserted into the array.
index
Type: System..::.Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

DimensionSegmentArray Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
DimensionSegmentArray..::.ReverseIterator Method
DimensionSegmentArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DimensionSegmentArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DimensionSegmentArrayIterator
Visual C++
public:
virtual DimensionSegmentArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

DimensionSegmentArray Class
Autodesk.Revit Namespace


DimensionSegmentArray Properties

[image] [image]

Revit 2010 API
DimensionSegmentArray Properties
DimensionSegmentArray Class See Also Send Feedback

The DimensionSegmentArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

DimensionSegmentArray Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
DimensionSegmentArray..::.IsEmpty Property
DimensionSegmentArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

DimensionSegmentArray Class
Autodesk.Revit Namespace


Item Property

[image]

Revit 2010 API
DimensionSegmentArray..::.Item Property
DimensionSegmentArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DimensionSegment Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As DimensionSegment
Visual C++
public:
virtual property DimensionSegment^ Item[int index] {
    DimensionSegment^ get (int index);
    void set (int index, DimensionSegment^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

DimensionSegmentArray Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
DimensionSegmentArray..::.Size Property
DimensionSegmentArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DimensionSegmentArray Class
Autodesk.Revit Namespace


DimensionSegmentArrayIterator Class

[image]

Revit 2010 API
DimensionSegmentArrayIterator Class
Members See Also Send Feedback
An iterator to an array of DimensionSegment objects..

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class DimensionSegmentArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class DimensionSegmentArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DimensionSegmentArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.DimensionSegmentArrayIterator

See Also

DimensionSegmentArrayIterator Members
Autodesk.Revit Namespace


DimensionSegmentArrayIterator Members

[image] [image]

Revit 2010 API
DimensionSegmentArrayIterator Members
DimensionSegmentArrayIterator Class Constructors Methods Properties See Also Send Feedback

The DimensionSegmentArrayIterator type exposes the following members.

Constructors

Name | Description
DimensionSegmentArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DimensionSegmentArrayIterator Class
Autodesk.Revit Namespace


DimensionSegmentArrayIterator Constructor

[image]

Revit 2010 API
DimensionSegmentArrayIterator Constructor
DimensionSegmentArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DimensionSegmentArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DimensionSegmentArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DimensionSegmentArrayIterator Class
Autodesk.Revit Namespace


DimensionSegmentArrayIterator Methods

[image] [image]

Revit 2010 API
DimensionSegmentArrayIterator Methods
DimensionSegmentArrayIterator Class See Also Send Feedback

The DimensionSegmentArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionSegmentArrayIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
DimensionSegmentArrayIterator..::.MoveNext Method
DimensionSegmentArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DimensionSegmentArrayIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
DimensionSegmentArrayIterator..::.Reset Method
DimensionSegmentArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DimensionSegmentArrayIterator Class
Autodesk.Revit Namespace


DimensionSegmentArrayIterator Properties

[image] [image]

Revit 2010 API
DimensionSegmentArrayIterator Properties
DimensionSegmentArrayIterator Class See Also Send Feedback

The DimensionSegmentArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DimensionSegmentArrayIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
DimensionSegmentArrayIterator..::.Current Property
DimensionSegmentArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DimensionSegmentArrayIterator Class
Autodesk.Revit Namespace


Document Class

[image]

Revit 2010 API
Document Class
Members See Also Send Feedback
An object that represents an open Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Document : APIObject
Visual Basic (Declaration)
Public Class Document _
    Inherits APIObject
Visual C++
public ref class Document : public APIObject

Remarks

The Document object represents an Autodesk Revit project. Revit can have multiple projects open and multiple views to those projects. The active or top most view will be the active project and hence the active document which is available from the Application object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Document

See Also

Document Members
Autodesk.Revit Namespace


Document Members

[image] [image]

Revit 2010 API
Document Members
Document Class Constructors Methods Properties Events See Also Send Feedback

The Document type exposes the following members.

Constructors

Name | Description
Document | For Internal Use Only.

Methods

Name | Description
AbortTransaction | Aborts a transaction for specified document.
Array | Overloaded. Creates an array of one or more elements.
ArrayWithoutAssociate | Overloaded. Creates an array of one or more elements where the elements created will not be grouped and associated.
BeginTransaction | Overloaded. Begins a transaction to encompass a set of changes.
Close | Overloaded. Closes the document.
CombineElements | Combine a set of combinable elements into a geometry combination.
Delete | Overloaded. Deletes one or more elements from the document.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
EditFamily | Edits a family loaded in the document.
EndTransaction | Overloaded. Ends a transaction with an attempt to commit the set of changes.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded. Exports the document to another file format.
FindReferencesByDirection | Finds the references that intersect a line extended in a certain direction from an origin point.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRoomAtPoint | Overloaded. Gets a room containing the point.
GetSpaceAtPoint | Overloaded. Gets a space containing the point.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Import | Overloaded. Imports the contents of an external file into the document.
LoadFamily | Overloaded. Loads a family and all its types/symbols.
LoadFamilySymbol | Overloaded. Loads only a specified family type/symbol from a family file into the document.
Mirror | Overloaded. Mirrors one or more elements.
Move | Overloaded. Moves one or more elements within the document by a specified vector.
Print | Overloaded. Prints a set of views.
Rotate | Overloaded. Rotates one or more elements within the document by a specified number of degrees around a given axis.
Save | Overloaded. Saves the document.
SaveAs | Overloaded. Saves the document to a new file name.
SeparateElements | Separate a set of combinable elements out of combinations they currently belong to.
ShowElements | Overloaded. Shows one or more elements by zoom to fit.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActiveProjectLocation | Retrieve the active project location.
ActiveView | The document's active view.
AnnotationSymbolTypes | Retrieves an object that contains all the annotation types that are currently loaded into the project.
Application | Returns the Application in which the Document resides.
BeamSystemTypes | Retrieves an object that contains all of beam system types that are currently loaded into the project.
ContFootingTypes | Retrieves an object that contains all of continuous footing types that are currently loaded into the project.
Create | An object that can be used to create new instances of Autodesk Revit API elements within a project.
CurtainSystemTypes | This property is used to retrieve all the CurtainSystem types in current system.
DeckProfiles | Returns an object that contains all of the avaible deck profiles currently loaded to this project.
DimensionTypes | Retrieves an object that contains all of dimension types that are currently loaded into the project.
DisplayUnitSystem | Provides access to display unit type with in the document.
ElectricalEquipmentTypes | Returns an object that contains all of the avaible electrical equipment types currently loaded to this project.
Element | Overloaded. Retrieves an element from the document given an identifier.
Elements | Overloaded. Provides access to a set of elements from the document.
FamilyCreate | An object that can be used to create new instances of Autodesk Revit API elements within a family document.
FamilyManager | The family manager object provides access to family types and parameters.
FasciaTypes | Retrieves an object that contains all the Fascia types that are currently loaded into the project.
FilterTypeSupported | Boolean value which indicates whether the specified builtin parameter supports the specifed filter type.
FloorTypes | Retrieves an object that contains all the floor types that are currently loaded into the project.
GridTypes | Retrieves an object that contains all of Grid types that are currently loaded into the project.
GutterTypes | Retrieves an object that contains all the Gutter types that are currently loaded into the project.
IsFamilyDocument | Identifies if the current document is a family document.
IsModifiable | The document's state of modifiability.
IsModified | The state of changes made to the document.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsReadOnlyFile | Signals whether the document was opened in read-only mode or not.
IsWorkshared | Identifies if worksets have been enabled in the document.
LevelTypes | Retrieves an object that contains all the level types that are currently loaded into the project.
LightingDeviceTypes | Returns an object that contains all of the avaible lighting device types currently loaded to this project.
LightingFixtureTypes | Returns an object that contains all of the avaible lighting fixture types currently loaded to this project.
MechanicalEquipmentTypes | Returns an object that contains all of the avaible mechanical equipment types currently loaded to this project.
MullionTypes | This property is used to retrieve all the mullion types in current system.
OwnerFamily | Get the Family of this Family Document.
PanelTypes | Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.
ParameterBindings | Retrieves an object from which mappings between parameter definitions and categories can be found.
PathName | Call this function to get the fully qualified path of the document's disk file.
Phases | Retrieves all the object that represent phases within the project.
PlanTopologies | Overloaded. Gets the PlanTopologies of the current project.
PlanTopology | Overloaded. Gets the PlanTopology of a given level.
PrintManager | Retrieve the PrintManager of current project.
PrintSettings | Retrieve all Print Settings of current project.
ProjectInformation | Return the Project Information of the current project.
ProjectLocations | Retrieve all the project locations associated with this project
ProjectUnit | Provides access to Project Unit Setting with in the document.
ReactionsAreUpToDate | Reports if the analytical model has regenerated in a document with reaction loads.
RebarBarTypes | Retrieves an object that contains all the rebar bar types that are currently loaded into the project.
RebarCoverTypes | Retrieves an object that contains all the rebar cover types that are currently loaded into the project.
RebarHookTypes | Retrieves an object that contains all the rebar hook types that are currently loaded into the project.
RebarShapes | Retrieves an object that contains all the rebar shape types that are currently loaded into the project.
RoofTypes | Retrieves an object that contains all the roof types that are currently loaded into the project.
RoomTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
Selection | Retrieve the currently selected Elements in Autodesk Revit.
Settings | Provides access to general application settings, such as Categories.
SiteLocation | Returns the site location information.
SlabEdgeTypes | Retrieves an object that contains all the SlabEdge types that are currently loaded into the project.
SpaceTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
SpotDimensionTypes | Retrieves an object that contains all of SpotDimension types that are currently loaded into the project.
TextNoteTypes | Retrieves an object that contains all of TextNote types that are currently loaded into the project.
Title | Call this function to get the project's title, which is usually derived from the project's filename.
TitleBlocks | Titleblocks currently loaded into the document.
TrussTypes | Retrieves an object that contains all the truss types that are currently loaded into the project.
TypeOfStorage | Get the storage type of the specified builtin parameter.
ViewSheetSets | The view sheet sets stored in the document.
WallTypes | Retrieves an object that contains all the wall types that are currently loaded into the project.
WorksharingCentralFilename | The name and path of the central file name for a workshared document.

Events

Name | Description
DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving document.
DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save the document.
DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
OnClose | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentClosing event instead. Subscribe to the OnClose event to be notified before the current document is closed.
OnSave | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentSaving event instead. Subscribe to the OnSave event to be notified before a document is saved.
OnSaveAs | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentSavingAs event instead. Subscribe to the OnSaveAs event to be notified before the current document is saved as a file with another name.
ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

Document Class
Autodesk.Revit Namespace


Document Constructor

[image]

Revit 2010 API
Document Constructor
Document Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Document()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Document()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Document Class
Autodesk.Revit Namespace


Document Methods

[image] [image]

Revit 2010 API
Document Methods
Document Class See Also Send Feedback

The Document type exposes the following members.

Methods

Name | Description
AbortTransaction | Aborts a transaction for specified document.
Array | Overloaded. Creates an array of one or more elements.
ArrayWithoutAssociate | Overloaded. Creates an array of one or more elements where the elements created will not be grouped and associated.
BeginTransaction | Overloaded. Begins a transaction to encompass a set of changes.
Close | Overloaded. Closes the document.
CombineElements | Combine a set of combinable elements into a geometry combination.
Delete | Overloaded. Deletes one or more elements from the document.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
EditFamily | Edits a family loaded in the document.
EndTransaction | Overloaded. Ends a transaction with an attempt to commit the set of changes.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded. Exports the document to another file format.
FindReferencesByDirection | Finds the references that intersect a line extended in a certain direction from an origin point.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRoomAtPoint | Overloaded. Gets a room containing the point.
GetSpaceAtPoint | Overloaded. Gets a space containing the point.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Import | Overloaded. Imports the contents of an external file into the document.
LoadFamily | Overloaded. Loads a family and all its types/symbols.
LoadFamilySymbol | Overloaded. Loads only a specified family type/symbol from a family file into the document.
Mirror | Overloaded. Mirrors one or more elements.
Move | Overloaded. Moves one or more elements within the document by a specified vector.
Print | Overloaded. Prints a set of views.
Rotate | Overloaded. Rotates one or more elements within the document by a specified number of degrees around a given axis.
Save | Overloaded. Saves the document.
SaveAs | Overloaded. Saves the document to a new file name.
SeparateElements | Separate a set of combinable elements out of combinations they currently belong to.
ShowElements | Overloaded. Shows one or more elements by zoom to fit.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Document Class
Autodesk.Revit Namespace


AbortTransaction Method

[image]

Revit 2010 API
Document..::.AbortTransaction Method
Document Class See Also Send Feedback
Aborts a transaction for specified document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AbortTransaction()
Visual Basic (Declaration)
Public Sub AbortTransaction
Visual C++
public:
void AbortTransaction()

Remarks

All the operations after last BeginTransaction will be discarded.

See Also

Document Class
Autodesk.Revit Namespace


Array Method

[image] [image]

Revit 2010 API
Document..::.Array Method
Document Class See Also Send Feedback
Creates an array of one or more elements.

Overload List

Name | Description
Array(Element, Int32, Boolean, XYZ) | Creates an array of an element using a specified number.
Array(Element, Int32, Boolean, Double) | Creates a radial array of an element using a specified number of degrees.
Array(ElementId%, Int32, Boolean, XYZ) | Creates an array of an element, specified by id, using a specified number.
Array(ElementId%, Int32, Boolean, Double) | Creates a radial array of an element, specified by id, using a specified number of degrees.
Array(ElementIdSet, Int32, Boolean, XYZ) | Creates an array of several elements, specified by ids, using a specified number.
Array(ElementIdSet, Int32, Boolean, Double) | Creates a radial array of several elements, specified by id, using a specified number of degrees.
Array(ElementSet, Int32, Boolean, XYZ) | Creates an array of several elements using a specified number.
Array(ElementSet, Int32, Boolean, Double) | Creates a radial array of several elements using a specified number of degrees.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Array Method (Element, Int32, Boolean, XYZ)

[image]

Revit 2010 API
Document..::.Array Method (Element, Int32, Boolean, XYZ)
Document Class See Also Send Feedback
Creates an array of an element using a specified number.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LinearArray Array(
    Element element,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function Array ( _
    element As Element, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As LinearArray
Visual C++
public:
LinearArray^ Array(
    Element^ element,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

element
Type: Autodesk.Revit..::.Element
The element that is to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a LinearArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns null. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Array Overload
Autodesk.Revit Namespace


Array Method (Element, Int32, Boolean, Double)

[image]

Revit 2010 API
Document..::.Array Method (Element, Int32, Boolean, Double)
Document Class See Also Send Feedback
Creates a radial array of an element using a specified number of degrees.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RadialArray Array(
    Element element,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function Array ( _
    element As Element, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As RadialArray
Visual C++
public:
RadialArray^ Array(
    Element^ element,
    int number,
    bool moveToLast,
    double angle
)

Parameters

element
Type: Autodesk.Revit..::.Element
The element that is to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Type: System..::.Double
The number of degrees, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a RadialArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns null. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Array Overload
Autodesk.Revit Namespace


Array Method (ElementId, Int32, Boolean, XYZ)

[image]

Revit 2010 API
Document..::.Array Method (ElementId%, Int32, Boolean, XYZ)
Document Class See Also Send Feedback
Creates an array of an element, specified by id, using a specified number.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LinearArray Array(
    ref ElementId elementId,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function Array ( _
    ByRef elementId As ElementId, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As LinearArray
Visual C++
public:
LinearArray^ Array(
    ElementId% elementId,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

elementId
Type: Autodesk.Revit..::.ElementId %
The id for an element that is to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a LinearArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns null. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Array Overload
Autodesk.Revit Namespace


Array Method (ElementId, Int32, Boolean, Double)

[image]

Revit 2010 API
Document..::.Array Method (ElementId%, Int32, Boolean, Double)
Document Class See Also Send Feedback
Creates a radial array of an element, specified by id, using a specified number of degrees.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RadialArray Array(
    ref ElementId elementId,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function Array ( _
    ByRef elementId As ElementId, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As RadialArray
Visual C++
public:
RadialArray^ Array(
    ElementId% elementId,
    int number,
    bool moveToLast,
    double angle
)

Parameters

elementId
Type: Autodesk.Revit..::.ElementId %
The id for an element that is to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Type: System..::.Double
The number of degrees, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a RadialArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns null. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Array Overload
Autodesk.Revit Namespace


Array Method (ElementIdSet, Int32, Boolean, XYZ)

[image]

Revit 2010 API
Document..::.Array Method (ElementIdSet, Int32, Boolean, XYZ)
Document Class See Also Send Feedback
Creates an array of several elements, specified by ids, using a specified number.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LinearArray Array(
    ElementIdSet elementIds,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function Array ( _
    elementIds As ElementIdSet, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As LinearArray
Visual C++
public:
LinearArray^ Array(
    ElementIdSet^ elementIds,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

elementIds
Type: Autodesk.Revit..::.ElementIdSet
A set of ids for elements that are to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a LinearArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns null. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Array Overload
Autodesk.Revit Namespace


Array Method (ElementIdSet, Int32, Boolean, Double)

[image]

Revit 2010 API
Document..::.Array Method (ElementIdSet, Int32, Boolean, Double)
Document Class See Also Send Feedback
Creates a radial array of several elements, specified by id, using a specified number of degrees.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RadialArray Array(
    ElementIdSet elementIds,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function Array ( _
    elementIds As ElementIdSet, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As RadialArray
Visual C++
public:
RadialArray^ Array(
    ElementIdSet^ elementIds,
    int number,
    bool moveToLast,
    double angle
)

Parameters

elementIds
Type: Autodesk.Revit..::.ElementIdSet
A set of ids for elements that are to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Type: System..::.Double
The number of degrees, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a RadialArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns null. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Array Overload
Autodesk.Revit Namespace


Array Method (ElementSet, Int32, Boolean, XYZ)

[image]

Revit 2010 API
Document..::.Array Method (ElementSet, Int32, Boolean, XYZ)
Document Class See Also Send Feedback
Creates an array of several elements using a specified number.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LinearArray Array(
    ElementSet elements,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function Array ( _
    elements As ElementSet, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As LinearArray
Visual C++
public:
LinearArray^ Array(
    ElementSet^ elements,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

elements
Type: Autodesk.Revit..::.ElementSet
A set of elements that are to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a LinearArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns null. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Array Overload
Autodesk.Revit Namespace


Array Method (ElementSet, Int32, Boolean, Double)

[image]

Revit 2010 API
Document..::.Array Method (ElementSet, Int32, Boolean, Double)
Document Class See Also Send Feedback
Creates a radial array of several elements using a specified number of degrees.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RadialArray Array(
    ElementSet elements,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function Array ( _
    elements As ElementSet, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As RadialArray
Visual C++
public:
RadialArray^ Array(
    ElementSet^ elements,
    int number,
    bool moveToLast,
    double angle
)

Parameters

elements
Type: Autodesk.Revit..::.ElementSet
A set of elements that are to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Type: System..::.Double
The number of degrees, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a RadialArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns null. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
Array Overload
Autodesk.Revit Namespace


ArrayWithoutAssociate Method

[image] [image]

Revit 2010 API
Document..::.ArrayWithoutAssociate Method
Document Class See Also Send Feedback
Creates an array of one or more elements where the elements created will not be grouped and associated.

Overload List

Name | Description
ArrayWithoutAssociate(Element, Int32, Boolean, XYZ) | Creates an array of an element using a specified number where the elements created will not be grouped and associated.
ArrayWithoutAssociate(Element, Int32, Boolean, Double) | Creates a radial array of an element using a specified number of degrees where the elements created will not be grouped and associated.
ArrayWithoutAssociate(ElementId%, Int32, Boolean, XYZ) | Creates an array of an element, specified by id, using a specified number where the elements created will not be grouped and associated.
ArrayWithoutAssociate(ElementId%, Int32, Boolean, Double) | Creates a radial array of an element, specified by id, using a specified number of degrees where the elements created will not be grouped and associated.
ArrayWithoutAssociate(ElementIdSet, Int32, Boolean, XYZ) | Creates an array of several elements, specified by ids, using a specified number where the elements created will not be grouped and associated.
ArrayWithoutAssociate(ElementIdSet, Int32, Boolean, Double) | Creates a radial array of several elements, specified by id, using a specified number of degrees where the elements created will not be grouped and associated.
ArrayWithoutAssociate(ElementSet, Int32, Boolean, XYZ) | Creates an array of several elements using a specified number where the elements created will not be grouped and associated.
ArrayWithoutAssociate(ElementSet, Int32, Boolean, Double) | Creates a radial array of several elements using a specified number of degrees where the elements created will not be grouped and associated.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


ArrayWithoutAssociate Method (Element, Int32, Boolean, XYZ)

[image]

Revit 2010 API
Document..::.ArrayWithoutAssociate Method (Element, Int32, Boolean, XYZ)
Document Class See Also Send Feedback
Creates an array of an element using a specified number where the elements created will not be grouped and associated.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    Element element,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    element As Element, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate(
    Element^ element,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

element
Type: Autodesk.Revit..::.Element
The element that is to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
ArrayWithoutAssociate Overload
Autodesk.Revit Namespace


ArrayWithoutAssociate Method (Element, Int32, Boolean, Double)

[image]

Revit 2010 API
Document..::.ArrayWithoutAssociate Method (Element, Int32, Boolean, Double)
Document Class See Also Send Feedback
Creates a radial array of an element using a specified number of degrees where the elements created will not be grouped and associated.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    Element element,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    element As Element, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate(
    Element^ element,
    int number,
    bool moveToLast,
    double angle
)

Parameters

element
Type: Autodesk.Revit..::.Element
The element that is to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Type: System..::.Double
The number of degrees, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
ArrayWithoutAssociate Overload
Autodesk.Revit Namespace


ArrayWithoutAssociate Method (ElementId, Int32, Boolean, XYZ)

[image]

Revit 2010 API
Document..::.ArrayWithoutAssociate Method (ElementId%, Int32, Boolean, XYZ)
Document Class See Also Send Feedback
Creates an array of an element, specified by id, using a specified number where the elements created will not be grouped and associated.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    ref ElementId elementId,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    ByRef elementId As ElementId, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate(
    ElementId% elementId,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

elementId
Type: Autodesk.Revit..::.ElementId %
The id for an element that is to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
ArrayWithoutAssociate Overload
Autodesk.Revit Namespace


ArrayWithoutAssociate Method (ElementId, Int32, Boolean, Double)

[image]

Revit 2010 API
Document..::.ArrayWithoutAssociate Method (ElementId%, Int32, Boolean, Double)
Document Class See Also Send Feedback
Creates a radial array of an element, specified by id, using a specified number of degrees where the elements created will not be grouped and associated.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    ref ElementId elementId,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    ByRef elementId As ElementId, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate(
    ElementId% elementId,
    int number,
    bool moveToLast,
    double angle
)

Parameters

elementId
Type: Autodesk.Revit..::.ElementId %
The id for an element that is to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Type: System..::.Double
The number of degrees, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
ArrayWithoutAssociate Overload
Autodesk.Revit Namespace


ArrayWithoutAssociate Method (ElementIdSet, Int32, Boolean, XYZ)

[image]

Revit 2010 API
Document..::.ArrayWithoutAssociate Method (ElementIdSet, Int32, Boolean, XYZ)
Document Class See Also Send Feedback
Creates an array of several elements, specified by ids, using a specified number where the elements created will not be grouped and associated.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    ElementIdSet elementIds,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    elementIds As ElementIdSet, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate(
    ElementIdSet^ elementIds,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

elementIds
Type: Autodesk.Revit..::.ElementIdSet
A set of ids for elements that are to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
ArrayWithoutAssociate Overload
Autodesk.Revit Namespace


ArrayWithoutAssociate Method (ElementIdSet, Int32, Boolean, Double)

[image]

Revit 2010 API
Document..::.ArrayWithoutAssociate Method (ElementIdSet, Int32, Boolean, Double)
Document Class See Also Send Feedback
Creates a radial array of several elements, specified by id, using a specified number of degrees where the elements created will not be grouped and associated.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    ElementIdSet elementIds,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    elementIds As ElementIdSet, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate(
    ElementIdSet^ elementIds,
    int number,
    bool moveToLast,
    double angle
)

Parameters

elementIds
Type: Autodesk.Revit..::.ElementIdSet
A set of ids for elements that are to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Type: System..::.Double
The number of degrees, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
ArrayWithoutAssociate Overload
Autodesk.Revit Namespace


ArrayWithoutAssociate Method (ElementSet, Int32, Boolean, XYZ)

[image]

Revit 2010 API
Document..::.ArrayWithoutAssociate Method (ElementSet, Int32, Boolean, XYZ)
Document Class See Also Send Feedback
Creates an array of several elements using a specified number where the elements created will not be grouped and associated.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    ElementSet elements,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    elements As ElementSet, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate(
    ElementSet^ elements,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

elements
Type: Autodesk.Revit..::.ElementSet
A set of elements that are to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
ArrayWithoutAssociate Overload
Autodesk.Revit Namespace


ArrayWithoutAssociate Method (ElementSet, Int32, Boolean, Double)

[image]

Revit 2010 API
Document..::.ArrayWithoutAssociate Method (ElementSet, Int32, Boolean, Double)
Document Class See Also Send Feedback
Creates a radial array of several elements using a specified number of degrees where the elements created will not be grouped and associated.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    ElementSet elements,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    elements As ElementSet, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate(
    ElementSet^ elements,
    int number,
    bool moveToLast,
    double angle
)

Parameters

elements
Type: Autodesk.Revit..::.ElementSet
A set of elements that are to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Type: System..::.Double
The number of degrees, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
ArrayWithoutAssociate Overload
Autodesk.Revit Namespace


BeginTransaction Method

[image] [image]

Revit 2010 API
Document..::.BeginTransaction Method
Document Class See Also Send Feedback
Begins a transaction to encompass a set of changes.

Overload List

Name | Description
BeginTransaction()()() | Begins a transaction to encompass a set of changes.
BeginTransaction(PostedErrorArray) | Begins a transaction to encompass a set of changes.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


BeginTransaction Method

[image]

Revit 2010 API
Document..::.BeginTransaction Method
Document Class Example See Also Send Feedback
Begins a transaction to encompass a set of changes.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool BeginTransaction()
Visual Basic (Declaration)
Public Function BeginTransaction As Boolean
Visual C++
public:
bool BeginTransaction()

Return Value

true is returned if the transaction is started successfully, otherwise false will be returned.

Remarks

To begin a new transaction before a series of operation can ensure all the following operations will be done in same transaction, which can avoid inconsistency.

Examples

CopyC#
// Get the document
Autodesk.Revit.Document document = application.ActiveDocument;

// Create a geometry line in revit application
XYZ Point1 = new XYZ(0, 0, 0);
XYZ Point2 = new XYZ(10, 0, 0);
XYZ Point3 = new XYZ(10, 10, 0);
XYZ Point4 = new XYZ(0, 10, 0);

// Transient Elements,so they are not managed by transactions
document.BeginTransaction();
Line geomLine1 = application.Create.NewLine(Point1, Point2, true);
Line geomLine2 = application.Create.NewLine(Point4, Point3, true);
Line geomLine3 = application.Create.NewLine(Point1, Point4, true);

// Create a geometry plane in revit application
XYZ origin = new XYZ(0, 0, 0);
XYZ normal = new XYZ(1, 1, 0);
Plane geomPlane = application.Create.NewPlane(normal, origin);

// Create a sketch plane in current document
SketchPlane sketch = document.Create.NewSketchPlane(geomPlane);

// non-transient elements,so they are grouped into transaction as atomic user actions
document.BeginTransaction();
// Create a ModelLine element using the created geometry line and sketch plane
ModelLine line1 = document.Create.NewModelCurve(geomLine1, sketch) as ModelLine;
ModelLine line2 = document.Create.NewModelCurve(geomLine2, sketch) as ModelLine;
ModelLine line3 = document.Create.NewModelCurve(geomLine3, sketch) as ModelLine;

if (DialogResult.OK == MessageBox.Show("Click OK to call EndTransaction, otherwise AbortTransaction.", "Revit", MessageBoxButtons.OKCancel))
{
    document.EndTransaction();
}
else
{
    document.AbortTransaction();
}
CopyVB.NET
' Get the document
Dim document As Autodesk.Revit.Document = application.ActiveDocument

' Create a geometry line in revit application
Dim Point1 As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
Dim Point2 As New Autodesk.Revit.Geometry.XYZ(10, 0, 0)
Dim Point3 As New Autodesk.Revit.Geometry.XYZ(10, 10, 0)
Dim Point4 As New Autodesk.Revit.Geometry.XYZ(0, 10, 0)

' Transient Elements,so they are not managed by transactions
document.BeginTransaction()
Dim geomLine1 As Line = application.Create.NewLine(Point1, Point2, True)
Dim geomLine2 As Line = application.Create.NewLine(Point4, Point3, True)
Dim geomLine3 As Line = application.Create.NewLine(Point1, Point4, True)

' Create a geometry plane in revit application
Dim origin As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
Dim normal As New Autodesk.Revit.Geometry.XYZ(1, 1, 0)
Dim geomPlane As Autodesk.Revit.Geometry.Plane = application.Create.NewPlane(normal, origin)

' Create a sketch plane in current document
Dim sketch As Autodesk.Revit.Elements.SketchPlane = document.Create.NewSketchPlane(geomPlane)

' non-transient elements,so they are grouped into transaction as atomic user actions
document.BeginTransaction()
' Create a ModelLine element using the created geometry line and sketch plane
Dim line1 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine1, sketch), ModelLine)
Dim line2 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine2, sketch), ModelLine)
Dim line3 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine3, sketch), ModelLine)

If DialogResult.OK = MessageBox.Show("Click OK to call EndTransaction, otherwise AbortTransaction.", "Revit", MessageBoxButtons.OKCancel) Then
    document.EndTransaction()
Else
    document.AbortTransaction()
End If

See Also

Document Class
BeginTransaction Overload
Autodesk.Revit Namespace


BeginTransaction Method (PostedErrorArray)

[image]

Revit 2010 API
Document..::.BeginTransaction Method (PostedErrorArray)
Document Class See Also Send Feedback
Begins a transaction to encompass a set of changes.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool BeginTransaction(
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function BeginTransaction ( _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool BeginTransaction(
    PostedErrorArray^ postedErrors
)

Parameters

postedErrors
Type: Autodesk.Revit..::.PostedErrorArray
Would contain list of failures posted during the process.

Return Value

true is returned if the transaction is started successfully, otherwise false will be returned.

Remarks

To begin a new transaction before a series of operation can ensure all the following operations will be done in same transaction, which can avoid inconsistency.

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
BeginTransaction Overload
Autodesk.Revit Namespace


Close Method

[image] [image]

Revit 2010 API
Document..::.Close Method
Document Class See Also Send Feedback
Closes the document.

Overload List

Name | Description
Close()()() | Closes the document with the possibility to ask the user whether or not to save.
Close(PostedErrorArray) | Closes the document with the possibility to ask the user whether or not to save.
Close(Boolean) | Closes the document with the option to save.
Close(Boolean, PostedErrorArray) | Closes the document with the option to save.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Close Method

[image]

Revit 2010 API
Document..::.Close Method
Document Class See Also Send Feedback
Closes the document with the possibility to ask the user whether or not to save.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Close()
Visual Basic (Declaration)
Public Function Close As Boolean
Visual C++
public:
bool Close()

Return Value

Returns 'false' if either closing procedure fails or if saving of a modified document failed. Also returns 'false' if closing is cancelled by an external application during 'DocumentClosing' event. When function succeeds, 'true' is returned.

Remarks

This function can not be called on the active document.

If the document is modified, the user will be asked if the document should be saved.

See Also

Document Class
Close Overload
Autodesk.Revit Namespace


Close Method (PostedErrorArray)

[image]

Revit 2010 API
Document..::.Close Method (PostedErrorArray)
Document Class See Also Send Feedback
Closes the document with the possibility to ask the user whether or not to save.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Close(
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function Close ( _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool Close(
    PostedErrorArray^ postedErrors
)

Parameters

postedErrors
Type: Autodesk.Revit..::.PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns 'false' if either closing procedure fails or if saving of a modified document failed. Also returns 'false' if closing is cancelled by an external application during 'DocumentClosing' event. When function succeeds, 'true' is returned.

Remarks

This function can not be called on the active document.

If the document is modified, the user will be asked if the document should be saved.

The 'postedErrors' parameter is used only when running Revit in UI-less mode.

See Also

Document Class
Close Overload
Autodesk.Revit Namespace


Close Method (Boolean)

[image]

Revit 2010 API
Document..::.Close Method (Boolean)
Document Class See Also Send Feedback
Closes the document with the option to save.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Close(
    bool saveModified
)
Visual Basic (Declaration)
Public Function Close ( _
    saveModified As Boolean _
) As Boolean
Visual C++
public:
bool Close(
    bool saveModified
)

Parameters

saveModified
Type: System..::.Boolean
Indicates if the current document should be saved before close operation.

Return Value

Returns 'false' if closing procedure fails or if saving of a modified document was requested (saveModified = 'true') but failed. Also returns 'false' if closing is cancelled by an external application during 'DocumentClosing' event. When function succeeds, 'true' is returned.

Remarks

This function can not be called on the active document. If the user tries to close the active document with this function, it will return false.

See Also

Document Class
Close Overload
Autodesk.Revit Namespace


Close Method (Boolean, PostedErrorArray)

[image]

Revit 2010 API
Document..::.Close Method (Boolean, PostedErrorArray)
Document Class See Also Send Feedback
Closes the document with the option to save.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Close(
    bool saveModified,
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function Close ( _
    saveModified As Boolean, _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool Close(
    bool saveModified,
    PostedErrorArray^ postedErrors
)

Parameters

saveModified
Type: System..::.Boolean
Indicates if the current document should be saved before close operation.
postedErrors
Type: Autodesk.Revit..::.PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns 'false' if closing procedure fails or if saving of a modified document was requested (saveModified = 'true') but failed. Also returns 'false' if closing is cancelled by an external application during 'DocumentClosing' event. When function succeeds, 'true' is returned.

Remarks

This function can not be called on the active document. If the user tries to close the active document with this function, it will return false.

The 'postedErrors' parameter is used only when running Revit in UI-less mode.

See Also

Document Class
Close Overload
Autodesk.Revit Namespace


CombineElements Method

[image]

Revit 2010 API
Document..::.CombineElements Method
Document Class See Also Send Feedback
Combine a set of combinable elements into a geometry combination.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GeomCombination CombineElements(
    CombinableElementArray members
)
Visual Basic (Declaration)
Public Function CombineElements ( _
    members As CombinableElementArray _
) As GeomCombination
Visual C++
public:
GeomCombination^ CombineElements(
    CombinableElementArray^ members
)

Parameters

members
Type: Autodesk.Revit.Elements..::.CombinableElementArray
A list of combinable elements to be combined.

Return Value

If successful, the newly created geometry combination is returned, otherwise an exception with error information will be thrown.

Remarks

If one or more existing geometry combinations are included as input, the return value may be one of those pre-existing combinations. The rest of the pre-existing geometry combinations will be consumed into the new combination; those handles are no longer valid.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument is null.
System..::.ArgumentException | Thrown when members contains less than two elements. Thrown when members contains null elements.
System..::.InvalidOperationException | Thrown when creation of the combination failed.

See Also

Document Class
Autodesk.Revit Namespace


Delete Method

[image] [image]

Revit 2010 API
Document..::.Delete Method
Document Class See Also Send Feedback
Deletes one or more elements from the document.

Overload List

Name | Description
Delete(Element) | Deletes an element from the document.
Delete(ElementId%) | Deletes an element from the document given the id of that element.
Delete(ElementIdSet) | Deletes several elements from the document given their ids.
Delete(ElementSet) | Deletes several elements from the document.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Delete Method (Element)

[image]

Revit 2010 API
Document..::.Delete Method (Element)
Document Class Example See Also Send Feedback
Deletes an element from the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementIdSet Delete(
    Element element
)
Visual Basic (Declaration)
Public Function Delete ( _
    element As Element _
) As ElementIdSet
Visual C++
public:
ElementIdSet^ Delete(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit..::.Element
The element that is to be deleted.

Remarks

This method will delete the element and any elements that are totally dependent upon that element. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

Examples

CopyC#
private void DeleteElement(Autodesk.Revit.Document document, Element element)
{
    // Delete a selected element.
    ElementIdSet deletedIdSet = document.Delete(element);

    if (0 == deletedIdSet.Size)
    {
        throw new Exception("Deleting the selected element in revit failed.");
    }

    String prompt = "The selected element has been removed and ";
    prompt += deletedIdSet.Size - 1;
    prompt += " more dependent elements have also been removed.";

    // Give the user some information
    MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);

}
CopyVB.NET
Private Sub DeleteElement(ByVal document As Autodesk.Revit.Document, ByVal element As Autodesk.Revit.Element)
    ' Delete a selected element.
    Dim deletedIdSet As ElementIdSet = document.Delete(element)

    If 0 = deletedIdSet.Size Then
        Throw New Exception("Deleting the selected element in revit failed.")
    End If

    Dim prompt As String = "The selected element has been removed and "
    prompt += deletedIdSet.Size - 1
    prompt += " more dependent elements have also been removed."

    ' Give the user some information
    MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)
End Sub

See Also

Document Class
Delete Overload
Autodesk.Revit Namespace


Delete Method (ElementId)

[image]

Revit 2010 API
Document..::.Delete Method (ElementId%)
Document Class Example See Also Send Feedback
Deletes an element from the document given the id of that element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementIdSet Delete(
    ref ElementId id
)
Visual Basic (Declaration)
Public Function Delete ( _
    ByRef id As ElementId _
) As ElementIdSet
Visual C++
public:
ElementIdSet^ Delete(
    ElementId% id
)

Parameters

id
Type: Autodesk.Revit..::.ElementId %
The ElementId for the element that is to be deleted.

Remarks

This method will delete the element and any elements that are totally dependent upon that element. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

Examples

CopyC#
private void DeleteElement(Autodesk.Revit.Document document, Element element)
{
    // Delete an element via its id
    ElementId elementId = element.Id;
    ElementIdSet deletedIdSet = document.Delete(ref elementId);

    if (0 == deletedIdSet.Size)
    {
        throw new Exception("Deleting the selected element in revit failed.");
    }

    String prompt = "The selected element has been removed and ";
    prompt += deletedIdSet.Size - 1;
    prompt += " more dependent elements have also been removed.";

    // Give the user some information
    MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
' Delete an element via its id
Dim elementId As Autodesk.Revit.ElementId = element.Id
Dim deletedIdSet As ElementIdSet = document.Delete(elementId)

If 0 = deletedIdSet.Size Then
    Throw New Exception("Deleting the selected element in revit failed.")
End If

Dim prompt As String = "The selected element has been removed and "
prompt += deletedIdSet.Size - 1
prompt += " more dependent elements have also been removed."

' Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)

See Also

Document Class
Delete Overload
Autodesk.Revit Namespace


Delete Method (ElementIdSet)

[image]

Revit 2010 API
Document..::.Delete Method (ElementIdSet)
Document Class Example See Also Send Feedback
Deletes several elements from the document given their ids.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementIdSet Delete(
    ElementIdSet ids
)
Visual Basic (Declaration)
Public Function Delete ( _
    ids As ElementIdSet _
) As ElementIdSet
Visual C++
public:
ElementIdSet^ Delete(
    ElementIdSet^ ids
)

Parameters

ids
Type: Autodesk.Revit..::.ElementIdSet
A set of element ids for the elements that are to be deleted.

Remarks

This method will delete the elements and any other elements that are totally dependent upon those elements. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

Examples

CopyC#
// Delete all the selected elements via the set of element ids.
ElementIdSet idSelection = new ElementIdSet();
foreach (Autodesk.Revit.Element elem in document.Selection.Elements)
{
    ElementId id = elem.Id;
    idSelection.Insert(ref id);
}
ElementIdSet deletedIdSet = document.Delete(idSelection);

if (0 == deletedIdSet.Size)
{
    throw new Exception("Deleting the selected elements in revit failed.");
}

MessageBox.Show("The selected element has been removed.", "Revit");
CopyVB.NET
' Delete all the selected elements via the set of element ids.
Dim idSelection As New ElementIdSet()
For Each elem As Autodesk.Revit.Element In document.Selection.Elements
    Dim id As Autodesk.Revit.ElementId = elem.Id
    idSelection.Insert(id)
Next
Dim deletedIdSet As ElementIdSet = document.Delete(idSelection)

If 0 = deletedIdSet.Size Then
    Throw New Exception("Deleting the selected elements in revit failed.")
End If

MessageBox.Show("The selected element has been removed.", "Revit")

See Also

Document Class
Delete Overload
Autodesk.Revit Namespace


Delete Method (ElementSet)

[image]

Revit 2010 API
Document..::.Delete Method (ElementSet)
Document Class Example See Also Send Feedback
Deletes several elements from the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementIdSet Delete(
    ElementSet elements
)
Visual Basic (Declaration)
Public Function Delete ( _
    elements As ElementSet _
) As ElementIdSet
Visual C++
public:
ElementIdSet^ Delete(
    ElementSet^ elements
)

Parameters

elements
Type: Autodesk.Revit..::.ElementSet
A set of elements that are to be deleted.

Remarks

This method will delete the elements and any other elements that are totally dependent upon those elements. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

Examples

CopyC#
// Delete all the selected elements via the set of elements
ElementSet elementSet = document.Selection.Elements;
ElementIdSet deletedIdSet = document.Delete(elementSet);

if (0 == deletedIdSet.Size)
{
    throw new Exception("Deleting the selected elements in revit failed.");
}

MessageBox.Show("The selected element has been removed.", "Revit");
CopyVB.NET
' Delete all the selected elements via the set of elements
Dim elementSet As ElementSet = document.Selection.Elements
Dim deletedIdSet As ElementIdSet = document.Delete(elementSet)

If 0 = deletedIdSet.Size Then
    Throw New Exception("Deleting the selected elements in revit failed.")
End If

MessageBox.Show("The selected element has been removed.", "Revit")

See Also

Document Class
Delete Overload
Autodesk.Revit Namespace


EditFamily Method

[image]

Revit 2010 API
Document..::.EditFamily Method
Document Class Example See Also Send Feedback
Edits a family loaded in the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Document EditFamily(
    Family loadedFamily
)
Visual Basic (Declaration)
Public Function EditFamily ( _
    loadedFamily As Family _
) As Document
Visual C++
public:
Document^ EditFamily(
    Family^ loadedFamily
)

Parameters

loadedFamily
Type: Autodesk.Revit.Elements..::.Family
The loaded family in current document.

Return Value

Returns the reference of the document of the family.

Remarks

This creates an independent copy of the family for editing. To apply the changes to the family stored in the document, use LoadFamily.

Examples

CopyC#
public void GetLoadedSymbols(Autodesk.Revit.Document document, FamilyInstance familyInstance)
{
    if (null != familyInstance.Symbol)
    {
        // Get family associated with this
        Family family = familyInstance.Symbol.Family;

        // Get Family document for family
        Document familyDoc = document.EditFamily(family);
        if (null != familyDoc && familyDoc.IsFamilyDocument == true)
        {
            String loadedFamilies = "FamilySymbols in " + family.Name + ":\n";

            ElementIterator itrFamilySymbols = familyDoc.get_Elements(typeof(FamilySymbol));

            itrFamilySymbols.Reset();

            while (itrFamilySymbols.MoveNext())
            {
                FamilySymbol fs = itrFamilySymbols.Current as FamilySymbol;

                loadedFamilies += "\t" + fs.Name + "\n";
            }

            MessageBox.Show(loadedFamilies, "Revit");
        }
    }
}
CopyVB.NET
Public Sub GetLoadedSymbols(ByVal document As Autodesk.Revit.Document, ByVal familyInstance As Autodesk.Revit.Elements.FamilyInstance)
    If familyInstance.Symbol IsNot Nothing Then
        ' Get family associated with this
        Dim family As Autodesk.Revit.Elements.Family = familyInstance.Symbol.Family

        ' Get Family document for family
        Dim familyDoc As Document = document.EditFamily(family)
        If familyDoc IsNot Nothing AndAlso familyDoc.IsFamilyDocument = True Then
            Dim loadedFamilies As String = "FamilySymbols in " & family.Name & ":" & vbLf

            Dim itrFamilySymbols As ElementIterator = familyDoc.Elements(GetType(Autodesk.Revit.Symbols.FamilySymbol))

            itrFamilySymbols.Reset()

            While itrFamilySymbols.MoveNext()
                Dim fs As Autodesk.Revit.Symbols.FamilySymbol = TryCast(itrFamilySymbols.Current, Autodesk.Revit.Symbols.FamilySymbol)

                loadedFamilies += vbTab & fs.Name & vbLf
            End While

            MessageBox.Show(loadedFamilies, "Revit")
        End If
    End If
End Sub

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"loadedFamily"-is null.
System..::.ArgumentException | Thrown when the input argument-"loadedFamily"-is an in-place family.
System..::.InvalidOperationException | Thrown when the family is already being edited.

See Also

Document Class
Autodesk.Revit Namespace


EndTransaction Method

[image] [image]

Revit 2010 API
Document..::.EndTransaction Method
Document Class See Also Send Feedback
Ends a transaction with an attempt to commit the set of changes.

Overload List

Name | Description
EndTransaction()()() | Ends a transaction with an attempt to commit the set of changes.
EndTransaction(PostedErrorArray) | Ends a transaction with an attempt to commit the set of changes.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


EndTransaction Method

[image]

Revit 2010 API
Document..::.EndTransaction Method
Document Class See Also Send Feedback
Ends a transaction with an attempt to commit the set of changes.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool EndTransaction()
Visual Basic (Declaration)
Public Function EndTransaction As Boolean
Visual C++
public:
bool EndTransaction()

Return Value

true is returned if the transaction is ended successfully, otherwise false will be returned.

Remarks

The transaction can ensure all the operations between BeginTransaction and EndTransaction can be fulfilled at one time successfully.

See Also

Document Class
EndTransaction Overload
Autodesk.Revit Namespace


EndTransaction Method (PostedErrorArray)

[image]

Revit 2010 API
Document..::.EndTransaction Method (PostedErrorArray)
Document Class See Also Send Feedback
Ends a transaction with an attempt to commit the set of changes.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool EndTransaction(
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function EndTransaction ( _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool EndTransaction(
    PostedErrorArray^ postedErrors
)

Parameters

postedErrors
Type: Autodesk.Revit..::.PostedErrorArray
Would contain list of failures posted during the process.

Return Value

true is returned if the transaction is ended successfully, otherwise false will be returned.

Remarks

The transaction can ensure all the operations between BeginTransaction and EndTransaction can be fulfilled at one time successfully.

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
EndTransaction Overload
Autodesk.Revit Namespace


Export Method

[image] [image]

Revit 2010 API
Document..::.Export Method
Document Class See Also Send Feedback
Exports the document to another file format.

Overload List

Name | Description
Export(String, String, GBXMLExportOptions) | Exports the document in Green-Building XML format.
Export(String, String, ViewSet, DGNExportOptions) | Exports the current view or a selection of views in DGN format.
Export(String, String, ViewSet, DWF2DExportOptions) | Exports the current view or a selection of views in DWF-2D format.
Export(String, String, ViewSet, DWF3DExportOptions) | Exports the current view or a selection of views in DWF-3D format.
Export(String, String, ViewSet, DWFX2DExportOptions) | Exports the current view or a selection of views in DWFX-2D format.
Export(String, String, ViewSet, DWFX3DExportOptions) | Exports the current view or a selection of views in DWFX-3D format.
Export(String, String, ViewSet, DWGExportOptions) | Exports the current view or a selection of views in DWG format.
Export(String, String, ViewSet, FBXExportOptions) | Exports the document in 3D-Studio Max (FBX) format.
Export(String, String, View3D, ViewPlan, BuildingSiteExportOptions) | Exports the document in the format of Civil Engineering design applications.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Export Method (String, String, GBXMLExportOptions)

[image]

Revit 2010 API
Document..::.Export Method (String, String, GBXMLExportOptions)
Document Class See Also Send Feedback
Exports the document in Green-Building XML format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    GBXMLExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    options As GBXMLExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    GBXMLExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::.String
Either the name of a single file or a prefix for a set of files. If nullptr or empty, automatic naming will be used.
options
Type: Autodesk.Revit..::.GBXMLExportOptions
Options applicable to the gbXML format.

Return Value

True if successful, otherwise False.

Remarks

Though the 'options' argument is not currently used, an object still must be provided (may be null).

See Also

Document Class
Export Overload
Autodesk.Revit Namespace


Export Method (String, String, ViewSet, DGNExportOptions)

[image]

Revit 2010 API
Document..::.Export Method (String, String, ViewSet, DGNExportOptions)
Document Class See Also Send Feedback
Exports the current view or a selection of views in DGN format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DGNExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As DGNExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    DGNExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::.String
Either the name of a single file or a prefix for a set of files. If nullptr or empty, automatic naming will be used.
views
Type: Autodesk.Revit.Elements..::.ViewSet
Selection of views to be exported. If nullptr or empty, only the active view will be exported.
options
Type: Autodesk.Revit..::.DGNExportOptions
Various options applicable to the DGN format. If nullptr, all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

All the views must be printable for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

See Also

Document Class
Export Overload
Autodesk.Revit Namespace


Export Method (String, String, ViewSet, DWF2DExportOptions)

[image]

Revit 2010 API
Document..::.Export Method (String, String, ViewSet, DWF2DExportOptions)
Document Class See Also Send Feedback
Exports the current view or a selection of views in DWF-2D format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DWF2DExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As DWF2DExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    DWF2DExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::.String
Either the name of a single file or a prefix for a set of files. If nullptr or empty, automatic naming will be used.
views
Type: Autodesk.Revit.Elements..::.ViewSet
Selection of views to be exported. If nullptr or empty, only the active view will be exported.
options
Type: Autodesk.Revit..::.DWF2DExportOptions
Various options applicable to the DWF format. If nullptr, all options will be set to their respective default values.

Return Value

Function returns true only if all specified views are exported successfully. The function returns false if exporting of any view fails, even if some views might have been exported successfully.

Remarks

All the views must be printable in order for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

See Also

Document Class
Export Overload
Autodesk.Revit Namespace


Export Method (String, String, ViewSet, DWF3DExportOptions)

[image]

Revit 2010 API
Document..::.Export Method (String, String, ViewSet, DWF3DExportOptions)
Document Class See Also Send Feedback
Exports the current view or a selection of views in DWF-3D format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DWF3DExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As DWF3DExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    DWF3DExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::.String
Either the name of a single file or a prefix for a set of files. If nullptr or empty, automatic naming will be used.
views
Type: Autodesk.Revit.Elements..::.ViewSet
Selection of 3D views to be exported. If nullptr or empty, only the active 3D view will be exported.
options
Type: Autodesk.Revit..::.DWF3DExportOptions
Various options applicable to the DWF format. If nullptr, all options will be set to their respective default values.

Return Value

Function returns true only if all specified views are exported successfully. The function returns false if exporting of any view fails, even if some views might have been exported successfully.

Remarks

All the views must be 3D views in order for the Export to succeed.

See Also

Document Class
Export Overload
Autodesk.Revit Namespace


Export Method (String, String, ViewSet, DWFX2DExportOptions)

[image]

Revit 2010 API
Document..::.Export Method (String, String, ViewSet, DWFX2DExportOptions)
Document Class See Also Send Feedback
Exports the current view or a selection of views in DWFX-2D format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DWFX2DExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As DWFX2DExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    DWFX2DExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::.String
Either the name of a single file or a prefix for a set of files. If nullptr or empty, automatic naming will be used.
views
Type: Autodesk.Revit.Elements..::.ViewSet
Selection of views to be exported. If nullptr or empty, only the active view will be exported.
options
Type: Autodesk.Revit..::.DWFX2DExportOptions
Various options applicable to the DWFX format. If nullptr, all options will be set to their respective default values.

Return Value

Function returns true only if all specified views are exported successfully. The function returns false if exporting of any view fails, even if some views might have been exported successfully.

Remarks

All the views must be printable in order for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

See Also

Document Class
Export Overload
Autodesk.Revit Namespace


Export Method (String, String, ViewSet, DWFX3DExportOptions)

[image]

Revit 2010 API
Document..::.Export Method (String, String, ViewSet, DWFX3DExportOptions)
Document Class See Also Send Feedback
Exports the current view or a selection of views in DWFX-3D format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DWFX3DExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As DWFX3DExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    DWFX3DExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::.String
Either the name of a single file or a prefix for a set of files. If nullptr or empty, automatic naming will be used.
views
Type: Autodesk.Revit.Elements..::.ViewSet
Selection of 3D views to be exported. If nullptr or empty, only the active 3D view will be exported.
options
Type: Autodesk.Revit..::.DWFX3DExportOptions
Various options applicable to the DWFX format. If nullptr, all options will be set to their respective default values.

Return Value

Function returns true only if all specified views are exported successfully. The function returns false if exporting of any view fails, even if some views might have been exported successfully.

Remarks

All the views must be 3D views in order for the Export to succeed.

See Also

Document Class
Export Overload
Autodesk.Revit Namespace


Export Method (String, String, ViewSet, DWGExportOptions)

[image]

Revit 2010 API
Document..::.Export Method (String, String, ViewSet, DWGExportOptions)
Document Class See Also Send Feedback
Exports the current view or a selection of views in DWG format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DWGExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As DWGExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    DWGExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::.String
Either the name of a single file or a prefix for a set of files. If nullptr or empty, automatic naming will be used.
views
Type: Autodesk.Revit.Elements..::.ViewSet
Selection of views to be exported. If nullptr or empty, only the active view will be exported.
options
Type: Autodesk.Revit..::.DWGExportOptions
Various options applicable to the DWG format. If nullptr, all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

All the views must be printable for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

See Also

Document Class
Export Overload
Autodesk.Revit Namespace


Export Method (String, String, ViewSet, FBXExportOptions)

[image]

Revit 2010 API
Document..::.Export Method (String, String, ViewSet, FBXExportOptions)
Document Class See Also Send Feedback
Exports the document in 3D-Studio Max (FBX) format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    FBXExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As FBXExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    FBXExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::.String
Either the name of a single file or a prefix for a set of files. If nullptr or empty, automatic naming will be used.
views
Type: Autodesk.Revit.Elements..::.ViewSet
options
Type: Autodesk.Revit..::.FBXExportOptions
Options applicable to the FBX format.

Return Value

Function returns true only if all specified views are exported successfully. The function returns false if exporting of any view fails, even if some views might have been exported successfully.

Remarks

Though the 'options' argument is not currently used, an object still must be provided (may be null).

See Also

Document Class
Export Overload
Autodesk.Revit Namespace


Export Method (String, String, View3D, ViewPlan, BuildingSiteExportOptions)

[image]

Revit 2010 API
Document..::.Export Method (String, String, View3D, ViewPlan, BuildingSiteExportOptions)
Document Class See Also Send Feedback
Exports the document in the format of Civil Engineering design applications.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    View3D view,
    ViewPlan grossAreaPlan,
    BuildingSiteExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    view As View3D, _
    grossAreaPlan As ViewPlan, _
    options As BuildingSiteExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    View3D^ view,
    ViewPlan^ grossAreaPlan,
    BuildingSiteExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file will be exported. The folder must exist.
name
Type: System..::.String
The name for the exported civil file. If nullptr or empty, automatic naming will be used."
view
Type: Autodesk.Revit.Elements..::.View3D
3D View to be exported. If nullptr or empty, the active view will be exported. If the active view is not a 3D view, an ArgumentException will be thrown.
grossAreaPlan
Type: Autodesk.Revit.Elements..::.ViewPlan
All the areas on the view plan will be exported, it must be 'Gross Building' area plan. It must not be null. To check whether its area scheme is Gross Building, use IsGrossBuildingArea property of AreaScheme.
options
Type: Autodesk.Revit..::.BuildingSiteExportOptions
Various options applicable to the format of Civil Engineering design applications. If nullptr, all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

See Also

Document Class
Export Overload
Autodesk.Revit Namespace


FindReferencesByDirection Method

[image]

Revit 2010 API
Document..::.FindReferencesByDirection Method
Document Class See Also Send Feedback
Finds the references that intersect a line extended in a certain direction from an origin point.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferenceArray FindReferencesByDirection(
    XYZ pOrigin,
    XYZ pDirection,
    View3D pView
)
Visual Basic (Declaration)
Public Function FindReferencesByDirection ( _
    pOrigin As XYZ, _
    pDirection As XYZ, _
    pView As View3D _
) As ReferenceArray
Visual C++
public:
ReferenceArray^ FindReferencesByDirection(
    XYZ^ pOrigin,
    XYZ^ pDirection,
    View3D^ pView
)

Parameters

pOrigin
Type: Autodesk.Revit.Geometry..::.XYZ
The origin of the line.
pDirection
Type: Autodesk.Revit.Geometry..::.XYZ
The direction.
pView
Type: Autodesk.Revit.Elements..::.View3D
The 3D view used to determine the geometry for intersection. If the view has specific geometry (section cuts, visibility changes due to detail level or hidden categories) this will affect the results.

Return Value

An array of references for items the line intersects.

Remarks

This method finds both elements and geometric references which intersect the ray. Some element references returned will not have a corresponding geometric object which is also intersected (for example, rays passing through openings in walls will intersect the wall and the opening element). If you are interested only in true physical intersections you should discard all references whose GeometryObject is of type Element.

References will be found and returned from either the positive or negative direction along the line. Use the reference's ProximityParameter to sort the results or exclude references found in the opposite direction to the given direction.

This method will return intersections encountered only in the main document. Intersections in linked files will not be returned.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when pOrigin, pDirection or pView is nullptr.

See Also

Document Class
Autodesk.Revit Namespace


GetRoomAtPoint Method

[image] [image]

Revit 2010 API
Document..::.GetRoomAtPoint Method
Document Class See Also Send Feedback
Gets a room containing the point.

Overload List

Name | Description
GetRoomAtPoint(XYZ) | Gets a room containing the point.
GetRoomAtPoint(XYZ, Phase) | Gets a room containing the point.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


GetRoomAtPoint Method (XYZ)

[image]

Revit 2010 API
Document..::.GetRoomAtPoint Method (XYZ)
Document Class See Also Send Feedback
Gets a room containing the point.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Room GetRoomAtPoint(
    XYZ point
)
Visual Basic (Declaration)
Public Function GetRoomAtPoint ( _
    point As XYZ _
) As Room
Visual C++
public:
Room^ GetRoomAtPoint(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
Point to be checked.

Return Value

The room containing the point.

Remarks

Surveys only the rooms from the final phase of the project. The first one found will be returned. If there is no room containing the point, it returns null.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the point is nullptr.
System..::.ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.

See Also

Document Class
GetRoomAtPoint Overload
Autodesk.Revit Namespace


GetRoomAtPoint Method (XYZ, Phase)

[image]

Revit 2010 API
Document..::.GetRoomAtPoint Method (XYZ, Phase)
Document Class See Also Send Feedback
Gets a room containing the point.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Room GetRoomAtPoint(
    XYZ point,
    Phase phase
)
Visual Basic (Declaration)
Public Function GetRoomAtPoint ( _
    point As XYZ, _
    phase As Phase _
) As Room
Visual C++
public:
Room^ GetRoomAtPoint(
    XYZ^ point,
    Phase^ phase
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
Point to be checked.
phase
Type: Autodesk.Revit.Elements..::.Phase
Phase in which the room exists.

Return Value

The room containing the point.

Remarks

If phase is null, it will get the room of the last phase.The first one found will be returned. If there is no room containing the point, it returns null.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the point is nullptr.
System..::.ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.

See Also

Document Class
GetRoomAtPoint Overload
Autodesk.Revit Namespace


GetSpaceAtPoint Method

[image] [image]

Revit 2010 API
Document..::.GetSpaceAtPoint Method
Document Class See Also Send Feedback
Gets a space containing the point.

Overload List

Name | Description
GetSpaceAtPoint(XYZ) | Gets a space containing the point.
GetSpaceAtPoint(XYZ, Phase) | Gets a space containing the point.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


GetSpaceAtPoint Method (XYZ)

[image]

Revit 2010 API
Document..::.GetSpaceAtPoint Method (XYZ)
Document Class See Also Send Feedback
Gets a space containing the point.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Space GetSpaceAtPoint(
    XYZ point
)
Visual Basic (Declaration)
Public Function GetSpaceAtPoint ( _
    point As XYZ _
) As Space
Visual C++
public:
Space^ GetSpaceAtPoint(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
Point to be checked.

Return Value

The space containing the point.

Remarks

Surveys only the spaces from the final phase of the project. The first one found will be returned. If there is no space containing the point, it returns null.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the point is nullptr.
System..::.ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.

See Also

Document Class
GetSpaceAtPoint Overload
Autodesk.Revit Namespace


GetSpaceAtPoint Method (XYZ, Phase)

[image]

Revit 2010 API
Document..::.GetSpaceAtPoint Method (XYZ, Phase)
Document Class See Also Send Feedback
Gets a space containing the point.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Space GetSpaceAtPoint(
    XYZ point,
    Phase phase
)
Visual Basic (Declaration)
Public Function GetSpaceAtPoint ( _
    point As XYZ, _
    phase As Phase _
) As Space
Visual C++
public:
Space^ GetSpaceAtPoint(
    XYZ^ point,
    Phase^ phase
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
Point to be checked.
phase
Type: Autodesk.Revit.Elements..::.Phase
Phase in which the space exists.

Return Value

The space containing the point.

Remarks

If phase is null, it will get the space of the last phase.The first one found will be returned. If there is no space containing the point, it returns null.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the point is nullptr.
System..::.ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.

See Also

Document Class
GetSpaceAtPoint Overload
Autodesk.Revit Namespace


Import Method

[image] [image]

Revit 2010 API
Document..::.Import Method
Document Class See Also Send Feedback
Imports the contents of an external file into the document.

Overload List

Name | Description
Import(String, GBXMLImportOptions) | Imports a Green-Building XML file into the document.
Import(String, InventorImportOptions) | Imports an Inventor file into the document.
Import(String, DWGImportOptions, Element%) | Imports a DWG file into the document.
Import(String, ImageImportOptions, Element%) | Imports an image (a bitmap) into the document.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Import Method (String, GBXMLImportOptions)

[image]

Revit 2010 API
Document..::.Import Method (String, GBXMLImportOptions)
Document Class See Also Send Feedback
Imports a Green-Building XML file into the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Import(
    string file,
    GBXMLImportOptions options
)
Visual Basic (Declaration)
Public Function Import ( _
    file As String, _
    options As GBXMLImportOptions _
) As Boolean
Visual C++
public:
bool Import(
    String^ file,
    GBXMLImportOptions^ options
)

Parameters

file
Type: System..::.String
Full path of the file to import. File must exist.
options
Type: Autodesk.Revit..::.GBXMLImportOptions
Various options applicable to GBXml import.If nullptr, all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

This method is available only in MEP. Though the 'options' argument is not currently used, an object still must be provided (may be null). The method will return 'false' if not succeed. e.g when the input xml file does not contain any result elements.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when file argument is null or empty.
System.IO..::.FileNotFoundException | Thrown when the file specified does not exist.
System..::.ArgumentException | Thrown when no file is specified or if the file is not a valid gbXML file or does not contain any result elements.

See Also

Document Class
Import Overload
Autodesk.Revit Namespace


Import Method (String, InventorImportOptions)

[image]

Revit 2010 API
Document..::.Import Method (String, InventorImportOptions)
Document Class See Also Send Feedback
Imports an Inventor file into the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Import(
    string file,
    InventorImportOptions options
)
Visual Basic (Declaration)
Public Function Import ( _
    file As String, _
    options As InventorImportOptions _
) As Boolean
Visual C++
public:
bool Import(
    String^ file,
    InventorImportOptions^ options
)

Parameters

file
Type: System..::.String
Full path of the file to import. File must exist.
options
Type: Autodesk.Revit..::.InventorImportOptions
Various options applicable to Inventor import. If nullptr, all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

A file with "adsk" extension is expected. Though the 'options' argument is not currently used, an object still must be provided (may be null).

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when 'file' argument is null or empty.
System.IO..::.FileNotFoundException | Thrown when the file specified does not exist.
System..::.ArgumentException | Thrown when the file is not an inventor file.

See Also

Document Class
Import Overload
Autodesk.Revit Namespace


Import Method (String, DWGImportOptions, Element)

[image]

Revit 2010 API
Document..::.Import Method (String, DWGImportOptions, Element%)
Document Class See Also Send Feedback
Imports a DWG file into the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Import(
    string file,
    DWGImportOptions options,
    out Element element
)
Visual Basic (Declaration)
Public Function Import ( _
    file As String, _
    options As DWGImportOptions, _
    <OutAttribute> ByRef element As Element _
) As Boolean
Visual C++
public:
bool Import(
    String^ file,
    DWGImportOptions^ options,
    [OutAttribute] Element^% element
)

Parameters

file
Type: System..::.String
Full path of the file to import. File must exist.
options
Type: Autodesk.Revit..::.DWGImportOptions
Various options applicable to the DWG format. If nullptr, all options will be set to their respective default values.
element
Type: Autodesk.Revit..::.Element %
The imported instance after a successful import. It could be used for further manipulating of that instance.

Return Value

True if successful, otherwise False.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when importing into 3D view but ThisViewOnly property is set to 'true' in options. Thrown when the file to be imported is not an existing DWG file.

See Also

Document Class
Import Overload
Autodesk.Revit Namespace


Import Method (String, ImageImportOptions, Element)

[image]

Revit 2010 API
Document..::.Import Method (String, ImageImportOptions, Element%)
Document Class See Also Send Feedback
Imports an image (a bitmap) into the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Import(
    string file,
    ImageImportOptions options,
    out Element element
)
Visual Basic (Declaration)
Public Function Import ( _
    file As String, _
    options As ImageImportOptions, _
    <OutAttribute> ByRef element As Element _
) As Boolean
Visual C++
public:
bool Import(
    String^ file,
    ImageImportOptions^ options,
    [OutAttribute] Element^% element
)

Parameters

file
Type: System..::.String
Full path of the file to import. File must exist.
options
Type: Autodesk.Revit..::.ImageImportOptions
Various options applicable to an image. If nullptr, all options will be set to their respective default values.
element
Type: Autodesk.Revit..::.Element %
The imported instance after a successful import. It could be used for further manipulating of that instance.

Return Value

True if successful, otherwise False.

See Also

Document Class
Import Overload
Autodesk.Revit Namespace


LoadFamily Method

[image] [image]

Revit 2010 API
Document..::.LoadFamily Method
Document Class See Also Send Feedback
Loads a family and all its types/symbols.

Overload List

Name | Description
LoadFamily(Document) | Loads the contents of this family document into another document.
LoadFamily(String) | Loads an entire family and all its types/symbols into the document.
LoadFamily(Document, IFamilyLoadOptions) | Loads the contents of this family document into another document.
LoadFamily(String, Family%) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


LoadFamily Method (Document)

[image]

Revit 2010 API
Document..::.LoadFamily Method (Document)
Document Class See Also Send Feedback
Loads the contents of this family document into another document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Family LoadFamily(
    Document targetDocument
)
Visual Basic (Declaration)
Public Function LoadFamily ( _
    targetDocument As Document _
) As Family
Visual C++
public:
Family^ LoadFamily(
    Document^ targetDocument
)

Parameters

targetDocument
Type: Autodesk.Revit..::.Document
The target document where the family will be loaded.

Return Value

Returns the reference of the family in the target document.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"targetDocument"-is null.
System..::.InvalidOperationException | Thrown when the current document is not a family document, or the target document doesn't support load of this family, or this family was found in the target document already and need to solve the conflict, or a shared family in this family was found in the target document already and need to choose the source version.

See Also

Document Class
LoadFamily Overload
Autodesk.Revit Namespace


LoadFamily Method (String)

[image]

Revit 2010 API
Document..::.LoadFamily Method (String)
Document Class See Also Send Feedback
Loads an entire family and all its types/symbols into the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool LoadFamily(
    string filename
)
Visual Basic (Declaration)
Public Function LoadFamily ( _
    filename As String _
) As Boolean
Visual C++
public:
bool LoadFamily(
    String^ filename
)

Parameters

filename
Type: System..::.String
The fully qualified filename of the Family file, usually ending in .rfa.

Return Value

Returns True if the entire family was loaded successfully into the project, otherwise false.

Remarks

Loading an entire family may take a considerable amount of time and memory. It is recommended that you use LoadFamilySymbol and only load those symbols that you need. The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods.

Exceptions

Exception | Condition
System..::.ArgumentNullException | filename is null.

See Also

Document Class
LoadFamily Overload
Autodesk.Revit Namespace


LoadFamily Method (Document, IFamilyLoadOptions)

[image]

Revit 2010 API
Document..::.LoadFamily Method (Document, IFamilyLoadOptions)
Document Class See Also Send Feedback
Loads the contents of this family document into another document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Family LoadFamily(
    Document targetDocument,
    IFamilyLoadOptions familyLoadOptions
)
Visual Basic (Declaration)
Public Function LoadFamily ( _
    targetDocument As Document, _
    familyLoadOptions As IFamilyLoadOptions _
) As Family
Visual C++
public:
Family^ LoadFamily(
    Document^ targetDocument,
    IFamilyLoadOptions^ familyLoadOptions
)

Parameters

targetDocument
Type: Autodesk.Revit..::.Document
The target document which the family will be loaded into.
familyLoadOptions
Type: Autodesk.Revit..::.IFamilyLoadOptions
The interface implementation to use when loading the family into document.

Return Value

Returns the reference of the family in the target document.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"targetDocument" or "familyLoadOptions"-is null.
System..::.InvalidOperationException | Thrown when the current document is not a family document, or the target document doesn't support load of this family. or the load was cancelled due to the response from one of the interface methods.

See Also

Document Class
LoadFamily Overload
Autodesk.Revit Namespace


LoadFamily Method (String, Family)

[image]

Revit 2010 API
Document..::.LoadFamily Method (String, Family%)
Document Class Example See Also Send Feedback
Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool LoadFamily(
    string filename,
    out Family family
)
Visual Basic (Declaration)
Public Function LoadFamily ( _
    filename As String, _
    <OutAttribute> ByRef family As Family _
) As Boolean
Visual C++
public:
bool LoadFamily(
    String^ filename,
    [OutAttribute] Family^% family
)

Parameters

filename
Type: System..::.String
The fully qualified filename of the Family file, usually ending in .rfa.
family
Type: Autodesk.Revit.Elements..::.Family %
A reference to the family that was loaded if successful, otherwise Nothing.

Return Value

Returns True if the entire family was loaded successfully into the project, otherwise false.

Remarks

Loading an entire family may take a considerable amount of time and memory. It is recommended that you use LoadFamilySymbol and only load those symbols that you need. The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods.

Examples

CopyC#
// Get the revit library path.
String libraryPath = application.Options.LibraryPaths.get_Item("Imperial Library");
if (String.IsNullOrEmpty(libraryPath))
{
    libraryPath = "c:\\";   // If not have, use a default path.
}

// Allow the user to select a family file.
OpenFileDialog openFileDialog1 = new OpenFileDialog();
openFileDialog1.InitialDirectory = libraryPath;
openFileDialog1.Filter = "Family Files (*.rfa)|*.rfa";

// Load the family file using LoadFamily method and then give information.
if (DialogResult.OK == openFileDialog1.ShowDialog())
{
    Autodesk.Revit.Elements.Family family = null;
    if (document.LoadFamily(openFileDialog1.FileName, out family))
    {
        String name = family.Name;
        MessageBox.Show("Family file has been loaded. Its name is " + name, "Revit");
    }
    else
    {
        MessageBox.Show("Can't load the family file.", "Revit");
    }
}
CopyVB.NET
' Get the revit library path.
Dim libraryPath As String = application.Options.LibraryPaths.Item("Imperial Library")
If [String].IsNullOrEmpty(libraryPath) Then
    libraryPath = "c:\"
    ' If not have, use a default path.
End If

' Allow the user to select a family file.
Dim openFileDialog1 As New OpenFileDialog()
openFileDialog1.InitialDirectory = libraryPath
openFileDialog1.Filter = "Family Files (*.rfa)|*.rfa"

' Load the family file using LoadFamily method and then give information.
If DialogResult.OK = openFileDialog1.ShowDialog() Then
    Dim family As Autodesk.Revit.Elements.Family = Nothing
    If document.LoadFamily(openFileDialog1.FileName, family) Then
        Dim name As String = family.Name
        MessageBox.Show("Family file has been loaded. Its name is " & name, "Revit")
    Else
        MessageBox.Show("Can't load the family file.", "Revit")
    End If
End If

Exceptions

Exception | Condition
System..::.ArgumentNullException | filename is null.

See Also

Document Class
LoadFamily Overload
Autodesk.Revit Namespace


LoadFamilySymbol Method

[image] [image]

Revit 2010 API
Document..::.LoadFamilySymbol Method
Document Class See Also Send Feedback
Loads only a specified family type/symbol from a family file into the document.

Overload List

Name | Description
LoadFamilySymbol(String, String) | Loads only a specified family type/symbol from a family file into the document.
LoadFamilySymbol(String, String, FamilySymbol%) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


LoadFamilySymbol Method (String, String)

[image]

Revit 2010 API
Document..::.LoadFamilySymbol Method (String, String)
Document Class See Also Send Feedback
Loads only a specified family type/symbol from a family file into the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool LoadFamilySymbol(
    string filename,
    string name
)
Visual Basic (Declaration)
Public Function LoadFamilySymbol ( _
    filename As String, _
    name As String _
) As Boolean
Visual C++
public:
bool LoadFamilySymbol(
    String^ filename,
    String^ name
)

Parameters

filename
Type: System..::.String
The fully qualified filename of the Family file, usually ending in .rfa.
name
Type: System..::.String
The name of the type/symbol to be loaded, such as "W11x14".

Return Value

Returns True if the family type/symbol was loaded successfully into the project, otherwise false.

Remarks

The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods. The name of the family type/symbol is the same name as returned by the Name property on the FamilySymbol object.

Exceptions

Exception | Condition
System..::.ArgumentNullException | filename or name is null.

See Also

Document Class
LoadFamilySymbol Overload
Autodesk.Revit Namespace


LoadFamilySymbol Method (String, String, FamilySymbol)

[image]

Revit 2010 API
Document..::.LoadFamilySymbol Method (String, String, FamilySymbol%)
Document Class See Also Send Feedback
Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool LoadFamilySymbol(
    string filename,
    string name,
    out FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function LoadFamilySymbol ( _
    filename As String, _
    name As String, _
    <OutAttribute> ByRef symbol As FamilySymbol _
) As Boolean
Visual C++
public:
bool LoadFamilySymbol(
    String^ filename,
    String^ name,
    [OutAttribute] FamilySymbol^% symbol
)

Parameters

filename
Type: System..::.String
The fully qualified filename of the Family file, usually ending in .rfa.
name
Type: System..::.String
The name of the type/symbol to be loaded, such as "W11x14".
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol %
A reference to the family symbol that was loaded if successful, otherwise Nothing.

Return Value

Returns True if the family type/symbol was loaded successfully into the project, otherwise false.

Remarks

The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods. The name of the family type/symbol is the same name as returned by the Name property on the FamilySymbol object.

Exceptions

Exception | Condition
System..::.ArgumentNullException | filename or name is null.

See Also

Document Class
LoadFamilySymbol Overload
Autodesk.Revit Namespace


Mirror Method

[image] [image]

Revit 2010 API
Document..::.Mirror Method
Document Class See Also Send Feedback
Mirrors one or more elements.

Overload List

Name | Description
Mirror(Element, Reference) | Mirrors an element about a reference.
Mirror(ElementId%, Reference) | Mirrors an element, specified by id, about a reference.
Mirror(ElementIdSet, Reference) | Mirrors several elements, specified by ids, about a reference.
Mirror(ElementSet, Line) | Mirrors several elements about an arbitrary geometric line.
Mirror(ElementSet, Reference) | Mirrors several elements about a reference.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Mirror Method (Element, Reference)

[image]

Revit 2010 API
Document..::.Mirror Method (Element, Reference)
Document Class Example See Also Send Feedback
Mirrors an element about a reference.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Mirror(
    Element element,
    Reference reference
)
Visual Basic (Declaration)
Public Function Mirror ( _
    element As Element, _
    reference As Reference _
) As Boolean
Visual C++
public:
bool Mirror(
    Element^ element,
    Reference^ reference
)

Parameters

element
Type: Autodesk.Revit..::.Element
A element that is to be mirrored.
reference
Type: Autodesk.Revit.Geometry..::.Reference
The reference by which the elements will mirror.

Return Value

If the elements are mirrored successfully then the method returns true.

Examples

CopyC#
public void MirrorColumn(Autodesk.Revit.Document document, FamilyInstance column)
{
    AnalyticalModelFrame analytical = column.AnalyticalModel as AnalyticalModelFrame;
    Reference lineReference = analytical.Curve.Reference;
    document.Mirror(column, lineReference);

    //The selected element is changed after the Mirror operation.
    foreach (Autodesk.Revit.Elements.FamilyInstance newColumn in document.Selection.Elements)
    {
        bool isMirror = newColumn.Mirrored;

        MessageBox.Show("Column is mirrored: " + isMirror, "Revit");

        //Offset the new column
        XYZ translationVec = new XYZ(10, 20, 30);
        newColumn.Location.Move(translationVec);
    }
}
CopyVB.NET
Public Sub MirrorColumn(ByVal document As Autodesk.Revit.Document, ByVal column As Autodesk.Revit.Elements.FamilyInstance)
    Dim analytical As AnalyticalModelFrame = TryCast(column.AnalyticalModel, AnalyticalModelFrame)
    Dim lineReference As Reference = analytical.Curve.Reference
    document.Mirror(column, lineReference)

    'The selected element is changed after the Mirror operation.
    For Each newColumn As Autodesk.Revit.Elements.FamilyInstance In document.Selection.Elements
        Dim isMirror As Boolean = newColumn.Mirrored

        MessageBox.Show("Column is mirrored: " & isMirror, "Revit")

        'Offset the new column
        Dim translationVec As New Autodesk.Revit.Geometry.XYZ(10, 20, 30)
        newColumn.Location.Move(translationVec)
    Next
End Sub

See Also

Document Class
Mirror Overload
Autodesk.Revit Namespace


Mirror Method (ElementId, Reference)

[image]

Revit 2010 API
Document..::.Mirror Method (ElementId%, Reference)
Document Class See Also Send Feedback
Mirrors an element, specified by id, about a reference.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Mirror(
    ref ElementId id,
    Reference reference
)
Visual Basic (Declaration)
Public Function Mirror ( _
    ByRef id As ElementId, _
    reference As Reference _
) As Boolean
Visual C++
public:
bool Mirror(
    ElementId% id,
    Reference^ reference
)

Parameters

id
Type: Autodesk.Revit..::.ElementId %
The ElementId for the element that is to be mirrored.
reference
Type: Autodesk.Revit.Geometry..::.Reference
The reference by which the elements will mirror.

Return Value

If the elements are mirrored successfully then the method returns true.

See Also

Document Class
Mirror Overload
Autodesk.Revit Namespace


Mirror Method (ElementIdSet, Reference)

[image]

Revit 2010 API
Document..::.Mirror Method (ElementIdSet, Reference)
Document Class See Also Send Feedback
Mirrors several elements, specified by ids, about a reference.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Mirror(
    ElementIdSet ids,
    Reference reference
)
Visual Basic (Declaration)
Public Function Mirror ( _
    ids As ElementIdSet, _
    reference As Reference _
) As Boolean
Visual C++
public:
bool Mirror(
    ElementIdSet^ ids,
    Reference^ reference
)

Parameters

ids
Type: Autodesk.Revit..::.ElementIdSet
A set of elements that are to be mirrored.
reference
Type: Autodesk.Revit.Geometry..::.Reference
The reference by which the elements will mirror.

Return Value

If the elements are mirrored successfully then the method returns true.

See Also

Document Class
Mirror Overload
Autodesk.Revit Namespace


Mirror Method (ElementSet, Line)

[image]

Revit 2010 API
Document..::.Mirror Method (ElementSet, Line)
Document Class See Also Send Feedback
Mirrors several elements about an arbitrary geometric line.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Mirror(
    ElementSet elements,
    Line line
)
Visual Basic (Declaration)
Public Function Mirror ( _
    elements As ElementSet, _
    line As Line _
) As Boolean
Visual C++
public:
bool Mirror(
    ElementSet^ elements,
    Line^ line
)

Parameters

elements
Type: Autodesk.Revit..::.ElementSet
A set of elements that are to be mirrored.
line
Type: Autodesk.Revit.Geometry..::.Line
The line by which the elements will mirror.

Return Value

If the elements are mirrored successfully then the method returns true.

See Also

Document Class
Mirror Overload
Autodesk.Revit Namespace


Mirror Method (ElementSet, Reference)

[image]

Revit 2010 API
Document..::.Mirror Method (ElementSet, Reference)
Document Class See Also Send Feedback
Mirrors several elements about a reference.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Mirror(
    ElementSet elements,
    Reference reference
)
Visual Basic (Declaration)
Public Function Mirror ( _
    elements As ElementSet, _
    reference As Reference _
) As Boolean
Visual C++
public:
bool Mirror(
    ElementSet^ elements,
    Reference^ reference
)

Parameters

elements
Type: Autodesk.Revit..::.ElementSet
A set of elements that are to be mirrored.
reference
Type: Autodesk.Revit.Geometry..::.Reference
The reference by which the elements will mirror.

Return Value

If the elements are mirrored successfully then the method returns true.

See Also

Document Class
Mirror Overload
Autodesk.Revit Namespace


Move Method

[image] [image]

Revit 2010 API
Document..::.Move Method
Document Class See Also Send Feedback
Moves one or more elements within the document by a specified vector.

Overload List

Name | Description
Move(Element, XYZ) | Moves an element within the document by a specified vector.
Move(ElementId%, XYZ) | Moves an element, specified by id, within the document by a specified vector.
Move(ElementIdSet, XYZ) | Moves several elements, specified by a set of ids, within the document by a specified vector.
Move(ElementSet, XYZ) | Moves several elements within the document by a specified vector.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Move Method (Element, XYZ)

[image]

Revit 2010 API
Document..::.Move Method (Element, XYZ)
Document Class Example See Also Send Feedback
Moves an element within the document by a specified vector.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Move(
    Element element,
    XYZ translationVec
)
Visual Basic (Declaration)
Public Function Move ( _
    element As Element, _
    translationVec As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    Element^ element,
    XYZ^ translationVec
)

Parameters

element
Type: Autodesk.Revit..::.Element
The element that is to be moved.
translationVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector by which the element is to be moved.

Return Value

If the element is moved successfully then the method return True, otherwise False.

Remarks

The move method is used to move an element within the project. Other elements may also be moved when this element is moved, for example: if the element is level, all the elements on that level will also be moved.

Examples

CopyC#
public void MoveColumn(Autodesk.Revit.Document document, FamilyInstance column)
{
    // get the column current location
    LocationPoint columnLocation = column.Location as LocationPoint;

    XYZ oldPlace = columnLocation.Point;

    // Move the column to new location.
    XYZ newPlace = new XYZ(10, 20, 30);
    document.Move(column, newPlace);

    // now get the column's new location
    columnLocation = column.Location as LocationPoint;
    XYZ newActual = columnLocation.Point;

    string info = "Original Z location: " + oldPlace.Z +
                  "\nNew Z location: " + newActual.Z;

    MessageBox.Show(info);
}
CopyVB.NET
Public Sub MoveColumn(ByVal document As Autodesk.Revit.Document, ByVal column As Autodesk.Revit.Elements.FamilyInstance)
    ' get the column current location
    Dim columnLocation As LocationPoint = TryCast(column.Location, LocationPoint)

    Dim oldPlace As Autodesk.Revit.Geometry.XYZ = columnLocation.Point

    ' Move the column to new location.
    Dim newPlace As New Autodesk.Revit.Geometry.XYZ(10, 20, 30)
    document.Move(column, newPlace)

    ' now get the column's new location
    columnLocation = TryCast(column.Location, LocationPoint)
    Dim newActual As Autodesk.Revit.Geometry.XYZ = columnLocation.Point

    Dim info As String = ("Original Z location: " & oldPlace.Z & vbLf & "New Z location: ") + newActual.Z

    MessageBox.Show(info)
End Sub

See Also

Document Class
Move Overload
Autodesk.Revit Namespace


Move Method (ElementId, XYZ)

[image]

Revit 2010 API
Document..::.Move Method (ElementId%, XYZ)
Document Class See Also Send Feedback
Moves an element, specified by id, within the document by a specified vector.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Move(
    ref ElementId id,
    XYZ translationVec
)
Visual Basic (Declaration)
Public Function Move ( _
    ByRef id As ElementId, _
    translationVec As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    ElementId% id,
    XYZ^ translationVec
)

Parameters

id
Type: Autodesk.Revit..::.ElementId %
The ElementId for the element that is to be moved.
translationVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector by which the element is to be moved.

Return Value

If the element is moved successfully then the method return True, otherwise False.

Remarks

The move method is used to move an element within the project. Other elements may also be moved when this element is moved, for example: if the element is wall and it contains windows, the windows will also be moved.

See Also

Document Class
Move Overload
Autodesk.Revit Namespace


Move Method (ElementIdSet, XYZ)

[image]

Revit 2010 API
Document..::.Move Method (ElementIdSet, XYZ)
Document Class See Also Send Feedback
Moves several elements, specified by a set of ids, within the document by a specified vector.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Move(
    ElementIdSet ids,
    XYZ translationVec
)
Visual Basic (Declaration)
Public Function Move ( _
    ids As ElementIdSet, _
    translationVec As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    ElementIdSet^ ids,
    XYZ^ translationVec
)

Parameters

ids
Type: Autodesk.Revit..::.ElementIdSet
A set of element ids specifying which elements are to be moved.
translationVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector by which the elements are to be moved.

Return Value

If the elements are moved successfully then the method returns True, otherwise False.

Remarks

The move method is used to move several elements within the project. Other elements may also be moved when these elements are moved, for example: if the elements are structural columns, all the beams joined to those columns will also be moved or resized.

See Also

Document Class
Move Overload
Autodesk.Revit Namespace


Move Method (ElementSet, XYZ)

[image]

Revit 2010 API
Document..::.Move Method (ElementSet, XYZ)
Document Class See Also Send Feedback
Moves several elements within the document by a specified vector.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Move(
    ElementSet elements,
    XYZ translationVec
)
Visual Basic (Declaration)
Public Function Move ( _
    elements As ElementSet, _
    translationVec As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    ElementSet^ elements,
    XYZ^ translationVec
)

Parameters

elements
Type: Autodesk.Revit..::.ElementSet
A set of element which are to be moved.
translationVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector by which the elements are to be moved.

Return Value

If the elements are moved successfully then the method returns True, otherwise False.

Remarks

The move method is used to move several elements within the project. Other elements may also be moved when these elements are moved, for example: if the elements are floors, the openings within those floors will also be moved.

See Also

Document Class
Move Overload
Autodesk.Revit Namespace


Print Method

[image] [image]

Revit 2010 API
Document..::.Print Method
Document Class See Also Send Feedback
Prints a set of views.

Overload List

Name | Description
Print(ViewSet) | Prints a set of views with default view template and default print settings.
Print(ViewSet, View) | Prints a set of views with a specified view template and default print settings.
Print(ViewSet, Boolean) | Prints a set of views with default view template and default print settings.
Print(ViewSet, View, Boolean) | Prints a set of views with a specified view template and default print settings.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Print Method (ViewSet)

[image]

Revit 2010 API
Document..::.Print Method (ViewSet)
Document Class See Also Send Feedback
Prints a set of views with default view template and default print settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Print(
    ViewSet views
)
Visual Basic (Declaration)
Public Sub Print ( _
    views As ViewSet _
)
Visual C++
public:
void Print(
    ViewSet^ views
)

Parameters

views
Type: Autodesk.Revit.Elements..::.ViewSet
The set of views which need to be printed.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
System..::.ArgumentNullException | Thrown when the view set to be printed is null.
System..::.ArgumentException | Thrown when the view set contains a null element.
System..::.ApplicationException | Thrown when at least one view from the view set could not be printed.
System..::.OperationCanceledException | Thrown when print is cancelled by event handler.

See Also

Document Class
Print Overload
Autodesk.Revit Namespace


Print Method (ViewSet, View)

[image]

Revit 2010 API
Document..::.Print Method (ViewSet, View)
Document Class See Also Send Feedback
Prints a set of views with a specified view template and default print settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Print(
    ViewSet views,
    View viewTemplate
)
Visual Basic (Declaration)
Public Sub Print ( _
    views As ViewSet, _
    viewTemplate As View _
)
Visual C++
public:
void Print(
    ViewSet^ views,
    View^ viewTemplate
)

Parameters

views
Type: Autodesk.Revit.Elements..::.ViewSet
The set of views which need to be printed.
viewTemplate
Type: Autodesk.Revit.Elements..::.View
The view template which apply to the set of views.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
System..::.ArgumentNullException | Thrown when the view set to be printed is null.
System..::.ArgumentException | Thrown when the view set contains a null element.
System..::.ApplicationException | Thrown when at least one view from the view set could not be printed.
System..::.OperationCanceledException | Thrown when print is cancelled by event handler.

See Also

Document Class
Print Overload
Autodesk.Revit Namespace


Print Method (ViewSet, Boolean)

[image]

Revit 2010 API
Document..::.Print Method (ViewSet, Boolean)
Document Class See Also Send Feedback
Prints a set of views with default view template and default print settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Print(
    ViewSet views,
    bool useCurrentPrintSettings
)
Visual Basic (Declaration)
Public Sub Print ( _
    views As ViewSet, _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print(
    ViewSet^ views,
    bool useCurrentPrintSettings
)

Parameters

views
Type: Autodesk.Revit.Elements..::.ViewSet
The set of views which need to be printed.
useCurrentPrintSettings
Type: System..::.Boolean
If true, print the view with the current print setting, otherwise with the print setting of the document of the view.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
System..::.ArgumentNullException | Thrown when the view set to be printed is null.
System..::.ArgumentException | Thrown when the view set contains a null element.
System..::.ApplicationException | Thrown when at least one view from the view set could not be printed.
System..::.OperationCanceledException | Thrown when print is cancelled by event handler.

See Also

Document Class
Print Overload
Autodesk.Revit Namespace


Print Method (ViewSet, View, Boolean)

[image]

Revit 2010 API
Document..::.Print Method (ViewSet, View, Boolean)
Document Class See Also Send Feedback
Prints a set of views with a specified view template and default print settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Print(
    ViewSet views,
    View viewTemplate,
    bool useCurrentPrintSettings
)
Visual Basic (Declaration)
Public Sub Print ( _
    views As ViewSet, _
    viewTemplate As View, _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print(
    ViewSet^ views,
    View^ viewTemplate,
    bool useCurrentPrintSettings
)

Parameters

views
Type: Autodesk.Revit.Elements..::.ViewSet
The set of views which need to be printed.
viewTemplate
Type: Autodesk.Revit.Elements..::.View
The view template which apply to the set of views.
useCurrentPrintSettings
Type: System..::.Boolean
If true, print the view with the current print setting, otherwise with the print setting of the document of the view.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
System..::.ArgumentNullException | Thrown when the view set to be printed is null.
System..::.ArgumentException | Thrown when the view set contains a null element.
System..::.ApplicationException | Thrown when at least one view from the view set could not be printed.
System..::.OperationCanceledException | Thrown when print is cancelled by event handler.

See Also

Document Class
Print Overload
Autodesk.Revit Namespace


Rotate Method

[image] [image]

Revit 2010 API
Document..::.Rotate Method
Document Class See Also Send Feedback
Rotates one or more elements within the document by a specified number of degrees around a given axis.

Overload List

Name | Description
Rotate(Element, Line, Double) | Rotates an element within the document by a specified number of degrees around a given axis.
Rotate(ElementId%, Line, Double) | Rotates an element, specified by id, within the document by a specified number of degrees around a given axis.
Rotate(ElementIdSet, Line, Double) | Rotates several elements, specified by a set of ids, within the document by a specified number of degrees around a given axis.
Rotate(ElementSet, Line, Double) | Rotates several elements within the document by a specified number of degrees around a given axis.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Rotate Method (Element, Line, Double)

[image]

Revit 2010 API
Document..::.Rotate Method (Element, Line, Double)
Document Class Example See Also Send Feedback
Rotates an element within the document by a specified number of degrees around a given axis.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Rotate(
    Element element,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    element As Element, _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate(
    Element^ element,
    Line^ axis,
    double angle
)

Parameters

element
Type: Autodesk.Revit..::.Element
The element that is to be rotated.
axis
Type: Autodesk.Revit.Geometry..::.Line
A line that represents the axis of rotation, which can be either bounded or unbounded line.
angle
Type: System..::.Double
The number of degrees, in radians, by which the element is to be rotated around the specified axis.

Return Value

If the element is rotate successfully then the method returns True, otherwise False.

Remarks

The rotate method is used to rotate an element within the project. Other elements may also be rotated when this element is rotated because they are dependent upon the element being rotated. The line used as the axis can be created by using the Application.Create object and its methods.

Examples

CopyC#
public bool RotateColumn(Autodesk.Revit.Document document, Autodesk.Revit.Element element)
{
    XYZ point1 = new XYZ(10, 20, 0);
    XYZ point2 = new XYZ(10, 20, 30);
    // The axis should be a bound line.
    Line axis = document.Application.Create.NewLineBound(point1, point2);
    bool successful = document.Rotate(element, axis, Math.PI / 3.0);

    return successful;
}
CopyVB.NET
Public Function RotateColumn(ByVal document As Autodesk.Revit.Document, ByVal element As Autodesk.Revit.Element) As Boolean
    Dim point1 As New Autodesk.Revit.Geometry.XYZ(10, 20, 0)
    Dim point2 As New Autodesk.Revit.Geometry.XYZ(10, 20, 30)
    ' The axis should be a bound line.
    Dim axis As Line = document.Application.Create.NewLineBound(point1, point2)
    Dim successful As Boolean = document.Rotate(element, axis, Math.PI / 3.0R)

    Return successful
End Function

See Also

Document Class
Rotate Overload
Autodesk.Revit Namespace


Rotate Method (ElementId, Line, Double)

[image]

Revit 2010 API
Document..::.Rotate Method (ElementId%, Line, Double)
Document Class See Also Send Feedback
Rotates an element, specified by id, within the document by a specified number of degrees around a given axis.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Rotate(
    ref ElementId id,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    ByRef id As ElementId, _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate(
    ElementId% id,
    Line^ axis,
    double angle
)

Parameters

id
Type: Autodesk.Revit..::.ElementId %
The ElementId for the element that is to be rotated.
axis
Type: Autodesk.Revit.Geometry..::.Line
A line that represents the axis of rotation, which can be either bounded or unbounded line.
angle
Type: System..::.Double
The number of degrees, in radians, by which the element is to be rotated around the specified axis.

Return Value

If the element is rotate successfully then the method returns True, otherwise False.

Remarks

The rotate method is used to rotate an element within the project. Other elements may also be rotated when this element is rotated because they are dependent upon the element being rotated. The line used as the axis can be created by using the Application.Create object and its methods.

See Also

Document Class
Rotate Overload
Autodesk.Revit Namespace


Rotate Method (ElementIdSet, Line, Double)

[image]

Revit 2010 API
Document..::.Rotate Method (ElementIdSet, Line, Double)
Document Class See Also Send Feedback
Rotates several elements, specified by a set of ids, within the document by a specified number of degrees around a given axis.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Rotate(
    ElementIdSet ids,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    ids As ElementIdSet, _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate(
    ElementIdSet^ ids,
    Line^ axis,
    double angle
)

Parameters

ids
Type: Autodesk.Revit..::.ElementIdSet
The set of ids for the elements that are to be rotated.
axis
Type: Autodesk.Revit.Geometry..::.Line
A line that represents the axis of rotation, which can be either bounded or unbounded line.
angle
Type: System..::.Double
The number of degrees, in radians, by which the elements are to be rotated around the specified axis.

Return Value

If the elements are rotate successfully then the method returns True, otherwise False.

Remarks

The rotate method is used to rotate several elements within the project. Other elements may also be rotated when these elements are rotated because they are dependent upon the elements being rotated. A line used as the axis can be created by using the Application.Create object and its methods.

See Also

Document Class
Rotate Overload
Autodesk.Revit Namespace


Rotate Method (ElementSet, Line, Double)

[image]

Revit 2010 API
Document..::.Rotate Method (ElementSet, Line, Double)
Document Class See Also Send Feedback
Rotates several elements within the document by a specified number of degrees around a given axis.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Rotate(
    ElementSet elements,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    elements As ElementSet, _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate(
    ElementSet^ elements,
    Line^ axis,
    double angle
)

Parameters

elements
Type: Autodesk.Revit..::.ElementSet
A set of elements that are to be rotated.
axis
Type: Autodesk.Revit.Geometry..::.Line
A line that represents the axis of rotation, which can be either bounded or unbounded line.
angle
Type: System..::.Double
The number of degrees, in radians, by which the elements are to be rotated around the specified axis.

Return Value

If the elements are rotate successfully then the method returns True, otherwise False.

Remarks

The rotate method is used to rotate several elements within the project. Other elements may also be rotated when these elements are rotated because they are dependent upon the elements being rotated. A line used as the axis can be created by using the Application.Create object and its methods.

See Also

Document Class
Rotate Overload
Autodesk.Revit Namespace


Save Method

[image] [image]

Revit 2010 API
Document..::.Save Method
Document Class See Also Send Feedback
Saves the document.

Overload List

Name | Description
Save()()() | Saves the document.
Save(PostedErrorArray) | Saves the document.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Save Method

[image]

Revit 2010 API
Document..::.Save Method
Document Class See Also Send Feedback
Saves the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Save()
Visual Basic (Declaration)
Public Function Save As Boolean
Visual C++
public:
bool Save()

Return Value

Returns 'false' if save operation fails. Also returns 'false' if saving is cancelled by an external application during 'DocumentSaving' event. When function succeeds, 'true' is returned.

Remarks

The trial version of Revit doesn't support this function. If the user tries to call this function in a trial version, InvalidOperationException will be thrown.

See Also

Document Class
Save Overload
Autodesk.Revit Namespace


Save Method (PostedErrorArray)

[image]

Revit 2010 API
Document..::.Save Method (PostedErrorArray)
Document Class See Also Send Feedback
Saves the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Save(
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function Save ( _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool Save(
    PostedErrorArray^ postedErrors
)

Parameters

postedErrors
Type: Autodesk.Revit..::.PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns 'false' if save operation fails. Also returns 'false' if saving is cancelled by an external application during 'DocumentSaving' event. When function succeeds, 'true' is returned.

Remarks

The trial version of Revit doesn't support this function. If the user tries to call this function in a trial version, InvalidOperationException will be thrown.

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
Save Overload
Autodesk.Revit Namespace


SaveAs Method

[image] [image]

Revit 2010 API
Document..::.SaveAs Method
Document Class See Also Send Feedback
Saves the document to a new file name.

Overload List

Name | Description
SaveAs()()() | Saves the document to a file name obtained from the Revit user.
SaveAs(PostedErrorArray) | Saves the document to a file name obtained from the Revit user.
SaveAs(String) | Saves the document to a given file name.
SaveAs(String, PostedErrorArray) | Saves the document to a given file name.
SaveAs(String, Boolean) | Saves the document to a given file name with the option to change the document's name in Revit.
SaveAs(String, Boolean, PostedErrorArray) | Saves the document to a given file name with the option to change the document's name in Revit.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


SaveAs Method

[image]

Revit 2010 API
Document..::.SaveAs Method
Document Class See Also Send Feedback
Saves the document to a file name obtained from the Revit user.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SaveAs()
Visual Basic (Declaration)
Public Function SaveAs As Boolean
Visual C++
public:
bool SaveAs()

Return Value

Returns 'false' if save operation fails. Also returns 'false' if saving as is cancelled by an external application during 'DocumentSavingAs' event. When function succeeds, 'true' is returned.

Remarks

Because the argument list is null, a SaveAs dialog will be shown to query the file name.

See Also

Document Class
SaveAs Overload
Autodesk.Revit Namespace


SaveAs Method (PostedErrorArray)

[image]

Revit 2010 API
Document..::.SaveAs Method (PostedErrorArray)
Document Class See Also Send Feedback
Saves the document to a file name obtained from the Revit user.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SaveAs(
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool SaveAs(
    PostedErrorArray^ postedErrors
)

Parameters

postedErrors
Type: Autodesk.Revit..::.PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns 'false' if save operation fails. Also returns 'false' if saving as is cancelled by an external application during 'DocumentSavingAs' event. When function succeeds, 'true' is returned.

Remarks

Because the argument list is null, a SaveAs dialog will be shown to query the file name.

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
SaveAs Overload
Autodesk.Revit Namespace


SaveAs Method (String)

[image]

Revit 2010 API
Document..::.SaveAs Method (String)
Document Class See Also Send Feedback
Saves the document to a given file name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SaveAs(
    string fileName
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    fileName As String _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
File name to be saved as.

Return Value

Returns 'false' if save operation fails. Also returns 'false' if saving as is cancelled by an external application during 'DocumentSavingAs' event. When function succeeds, 'true' is returned.

Remarks

None.

See Also

Document Class
SaveAs Overload
Autodesk.Revit Namespace


SaveAs Method (String, PostedErrorArray)

[image]

Revit 2010 API
Document..::.SaveAs Method (String, PostedErrorArray)
Document Class See Also Send Feedback
Saves the document to a given file name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SaveAs(
    string fileName,
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    fileName As String, _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ fileName,
    PostedErrorArray^ postedErrors
)

Parameters

fileName
Type: System..::.String
File name to be saved as.
postedErrors
Type: Autodesk.Revit..::.PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns 'false' if save operation fails. Also returns 'false' if saving as is cancelled by an external application during 'DocumentSavingAs' event. When function succeeds, 'true' is returned.

Remarks

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
SaveAs Overload
Autodesk.Revit Namespace


SaveAs Method (String, Boolean)

[image]

Revit 2010 API
Document..::.SaveAs Method (String, Boolean)
Document Class See Also Send Feedback
Saves the document to a given file name with the option to change the document's name in Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SaveAs(
    string fileName,
    bool changeDocumentFilename
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    fileName As String, _
    changeDocumentFilename As Boolean _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ fileName,
    bool changeDocumentFilename
)

Parameters

fileName
Type: System..::.String
File name and path to be saved as.
changeDocumentFilename
Type: System..::.Boolean
Indicates if the current file name on the title bar of Revit will be changed accordingly.

Return Value

Returns 'false' if save operation fails. Also returns 'false' if saving as is cancelled by an external application during 'DocumentSavingAs' event. When function succeeds, 'true' is returned.

Remarks

None.

See Also

Document Class
SaveAs Overload
Autodesk.Revit Namespace


SaveAs Method (String, Boolean, PostedErrorArray)

[image]

Revit 2010 API
Document..::.SaveAs Method (String, Boolean, PostedErrorArray)
Document Class See Also Send Feedback
Saves the document to a given file name with the option to change the document's name in Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SaveAs(
    string fileName,
    bool changeDocumentFilename,
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    fileName As String, _
    changeDocumentFilename As Boolean, _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ fileName,
    bool changeDocumentFilename,
    PostedErrorArray^ postedErrors
)

Parameters

fileName
Type: System..::.String
File name to be saved as.
changeDocumentFilename
Type: System..::.Boolean
Indicates if the current file name on the title bar of Revit will be changed accordingly.
postedErrors
Type: Autodesk.Revit..::.PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns 'false' if save operation fails. Also returns 'false' if saving as is cancelled by an external application during 'DocumentSavingAs' event. When function succeeds, 'true' is returned.

Remarks

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
SaveAs Overload
Autodesk.Revit Namespace


SeparateElements Method

[image]

Revit 2010 API
Document..::.SeparateElements Method
Document Class See Also Send Feedback
Separate a set of combinable elements out of combinations they currently belong to.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SeparateElements(
    CombinableElementArray members
)
Visual Basic (Declaration)
Public Sub SeparateElements ( _
    members As CombinableElementArray _
)
Visual C++
public:
void SeparateElements(
    CombinableElementArray^ members
)

Parameters

members
Type: Autodesk.Revit.Elements..::.CombinableElementArray
A list of combinable elements to be separated.

Remarks

If geometry combination elements are passed as input, they will be completely separated and deleted. If generic forms that happen to belong to combination elements are passed, these forms will be removed from their geometry combination. The handles of geometry combinations completely removed by this operation are no longer valid.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument is null.
System..::.ArgumentException | Thrown when members is empty. Thrown when members contains null elements.
System..::.InvalidOperationException | Thrown when separation failed.

See Also

Document Class
Autodesk.Revit Namespace


ShowElements Method

[image] [image]

Revit 2010 API
Document..::.ShowElements Method
Document Class See Also Send Feedback
Shows one or more elements by zoom to fit.

Overload List

Name | Description
ShowElements(Element) | Shows the element by zoom to fit.
ShowElements(ElementId%) | Shows the element by zoom to fit.
ShowElements(ElementIdSet) | Shows the elements by zoom to fit.
ShowElements(ElementSet) | Shows the elements by zoom to fit.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


ShowElements Method (Element)

[image]

Revit 2010 API
Document..::.ShowElements Method (Element)
Document Class See Also Send Feedback
Shows the element by zoom to fit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ShowElements(
    Element element
)
Visual Basic (Declaration)
Public Sub ShowElements ( _
    element As Element _
)
Visual C++
public:
void ShowElements(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit..::.Element
Element that will be shown.

Remarks

Places the element in the center of screen by moving the view.

See Also

Document Class
ShowElements Overload
Autodesk.Revit Namespace


ShowElements Method (ElementId)

[image]

Revit 2010 API
Document..::.ShowElements Method (ElementId%)
Document Class See Also Send Feedback
Shows the element by zoom to fit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ShowElements(
    ref ElementId elementId
)
Visual Basic (Declaration)
Public Sub ShowElements ( _
    ByRef elementId As ElementId _
)
Visual C++
public:
void ShowElements(
    ElementId% elementId
)

Parameters

elementId
Type: Autodesk.Revit..::.ElementId %
Element id that will be shown.

Remarks

Places the element in the center of screen by moving the view.

See Also

Document Class
ShowElements Overload
Autodesk.Revit Namespace


ShowElements Method (ElementIdSet)

[image]

Revit 2010 API
Document..::.ShowElements Method (ElementIdSet)
Document Class See Also Send Feedback
Shows the elements by zoom to fit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ShowElements(
    ElementIdSet elementIds
)
Visual Basic (Declaration)
Public Sub ShowElements ( _
    elementIds As ElementIdSet _
)
Visual C++
public:
void ShowElements(
    ElementIdSet^ elementIds
)

Parameters

elementIds
Type: Autodesk.Revit..::.ElementIdSet
The set of element ids which will be shown.

Remarks

Places all the elements on the screen by moving the view.

See Also

Document Class
ShowElements Overload
Autodesk.Revit Namespace


ShowElements Method (ElementSet)

[image]

Revit 2010 API
Document..::.ShowElements Method (ElementSet)
Document Class See Also Send Feedback
Shows the elements by zoom to fit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ShowElements(
    ElementSet elements
)
Visual Basic (Declaration)
Public Sub ShowElements ( _
    elements As ElementSet _
)
Visual C++
public:
void ShowElements(
    ElementSet^ elements
)

Parameters

elements
Type: Autodesk.Revit..::.ElementSet
The set of elements that will be shown.

Remarks

Places all the elements on the screen by moving the view.

See Also

Document Class
ShowElements Overload
Autodesk.Revit Namespace


Document Properties

[image] [image]

Revit 2010 API
Document Properties
Document Class See Also Send Feedback

The Document type exposes the following members.

Properties

Name | Description
ActiveProjectLocation | Retrieve the active project location.
ActiveView | The document's active view.
AnnotationSymbolTypes | Retrieves an object that contains all the annotation types that are currently loaded into the project.
Application | Returns the Application in which the Document resides.
BeamSystemTypes | Retrieves an object that contains all of beam system types that are currently loaded into the project.
ContFootingTypes | Retrieves an object that contains all of continuous footing types that are currently loaded into the project.
Create | An object that can be used to create new instances of Autodesk Revit API elements within a project.
CurtainSystemTypes | This property is used to retrieve all the CurtainSystem types in current system.
DeckProfiles | Returns an object that contains all of the avaible deck profiles currently loaded to this project.
DimensionTypes | Retrieves an object that contains all of dimension types that are currently loaded into the project.
DisplayUnitSystem | Provides access to display unit type with in the document.
ElectricalEquipmentTypes | Returns an object that contains all of the avaible electrical equipment types currently loaded to this project.
Element | Overloaded. Retrieves an element from the document given an identifier.
Elements | Overloaded. Provides access to a set of elements from the document.
FamilyCreate | An object that can be used to create new instances of Autodesk Revit API elements within a family document.
FamilyManager | The family manager object provides access to family types and parameters.
FasciaTypes | Retrieves an object that contains all the Fascia types that are currently loaded into the project.
FilterTypeSupported | Boolean value which indicates whether the specified builtin parameter supports the specifed filter type.
FloorTypes | Retrieves an object that contains all the floor types that are currently loaded into the project.
GridTypes | Retrieves an object that contains all of Grid types that are currently loaded into the project.
GutterTypes | Retrieves an object that contains all the Gutter types that are currently loaded into the project.
IsFamilyDocument | Identifies if the current document is a family document.
IsModifiable | The document's state of modifiability.
IsModified | The state of changes made to the document.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsReadOnlyFile | Signals whether the document was opened in read-only mode or not.
IsWorkshared | Identifies if worksets have been enabled in the document.
LevelTypes | Retrieves an object that contains all the level types that are currently loaded into the project.
LightingDeviceTypes | Returns an object that contains all of the avaible lighting device types currently loaded to this project.
LightingFixtureTypes | Returns an object that contains all of the avaible lighting fixture types currently loaded to this project.
MechanicalEquipmentTypes | Returns an object that contains all of the avaible mechanical equipment types currently loaded to this project.
MullionTypes | This property is used to retrieve all the mullion types in current system.
OwnerFamily | Get the Family of this Family Document.
PanelTypes | Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.
ParameterBindings | Retrieves an object from which mappings between parameter definitions and categories can be found.
PathName | Call this function to get the fully qualified path of the document's disk file.
Phases | Retrieves all the object that represent phases within the project.
PlanTopologies | Overloaded. Gets the PlanTopologies of the current project.
PlanTopology | Overloaded. Gets the PlanTopology of a given level.
PrintManager | Retrieve the PrintManager of current project.
PrintSettings | Retrieve all Print Settings of current project.
ProjectInformation | Return the Project Information of the current project.
ProjectLocations | Retrieve all the project locations associated with this project
ProjectUnit | Provides access to Project Unit Setting with in the document.
ReactionsAreUpToDate | Reports if the analytical model has regenerated in a document with reaction loads.
RebarBarTypes | Retrieves an object that contains all the rebar bar types that are currently loaded into the project.
RebarCoverTypes | Retrieves an object that contains all the rebar cover types that are currently loaded into the project.
RebarHookTypes | Retrieves an object that contains all the rebar hook types that are currently loaded into the project.
RebarShapes | Retrieves an object that contains all the rebar shape types that are currently loaded into the project.
RoofTypes | Retrieves an object that contains all the roof types that are currently loaded into the project.
RoomTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
Selection | Retrieve the currently selected Elements in Autodesk Revit.
Settings | Provides access to general application settings, such as Categories.
SiteLocation | Returns the site location information.
SlabEdgeTypes | Retrieves an object that contains all the SlabEdge types that are currently loaded into the project.
SpaceTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
SpotDimensionTypes | Retrieves an object that contains all of SpotDimension types that are currently loaded into the project.
TextNoteTypes | Retrieves an object that contains all of TextNote types that are currently loaded into the project.
Title | Call this function to get the project's title, which is usually derived from the project's filename.
TitleBlocks | Titleblocks currently loaded into the document.
TrussTypes | Retrieves an object that contains all the truss types that are currently loaded into the project.
TypeOfStorage | Get the storage type of the specified builtin parameter.
ViewSheetSets | The view sheet sets stored in the document.
WallTypes | Retrieves an object that contains all the wall types that are currently loaded into the project.
WorksharingCentralFilename | The name and path of the central file name for a workshared document.

See Also

Document Class
Autodesk.Revit Namespace


ActiveProjectLocation Property

[image]

Revit 2010 API
Document..::.ActiveProjectLocation Property
Document Class See Also Send Feedback
Retrieve the active project location.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProjectLocation ActiveProjectLocation { get; set; }
Visual Basic (Declaration)
Public Property ActiveProjectLocation As ProjectLocation
Visual C++
public:
property ProjectLocation^ ActiveProjectLocation {
    ProjectLocation^ get ();
    void set (ProjectLocation^ value);
}

Remarks

Getting this property returns the currently active project location that the user is currently working with. Setting this property can be used to change the active project location.

See Also

Document Class
Autodesk.Revit Namespace


ActiveView Property

[image]

Revit 2010 API
Document..::.ActiveView Property
Document Class Example See Also Send Feedback
The document's active view.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public View ActiveView { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActiveView As View
Visual C++
public:
property View^ ActiveView {
    View^ get ();
}

Field Value

The active view is the view that last had focus in the UI. null if no view is considered active.

Examples

CopyC#
// Get the active view of the current document.
Autodesk.Revit.Elements.View view = document.ActiveView;

// Get the class type of the active view, and format the prompt string
String prompt = "Revit is currently in ";
if (view is Autodesk.Revit.Elements.View3D)
{
    prompt += "3D view.";
}
else if (view is Autodesk.Revit.Elements.ViewSection)
{
    prompt += "section view.";
}
else if (view is Autodesk.Revit.Elements.ViewSheet)
{
    prompt += "sheet view.";
}
else if (view is Autodesk.Revit.Elements.ViewDrafting)
{
    prompt += "drafting view.";
}
else
{
    prompt += "normal view, the view name is " + view.Name;
}

// Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);
CopyVB.NET
' Get the active view of the current document.
Dim view As Autodesk.Revit.Elements.View = document.ActiveView

' Get the class type of the active view, and format the prompt string
Dim prompt As String = "Revit is currently in "
If TypeOf view Is Autodesk.Revit.Elements.View3D Then
    prompt += "3D view."
ElseIf TypeOf view Is Autodesk.Revit.Elements.ViewSection Then
    prompt += "section view."
ElseIf TypeOf view Is Autodesk.Revit.Elements.ViewSheet Then
    prompt += "sheet view."
ElseIf TypeOf view Is Autodesk.Revit.Elements.ViewDrafting Then
    prompt += "drafting view."
Else
    prompt += "normal view, the view name is " & view.Name
End If

' Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)

See Also

Document Class
Autodesk.Revit Namespace


AnnotationSymbolTypes Property

[image]

Revit 2010 API
Document..::.AnnotationSymbolTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the annotation types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnnotationSymbolTypeSet AnnotationSymbolTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property AnnotationSymbolTypes As AnnotationSymbolTypeSet
Visual C++
public:
property AnnotationSymbolTypeSet^ AnnotationSymbolTypes {
    AnnotationSymbolTypeSet^ get ();
}

Remarks

This property returns a set of AnnotationSymbol objects. These objects can be used change the type of an Annotation from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


Application Property

[image]

Revit 2010 API
Document..::.Application Property
Document Class See Also Send Feedback
Returns the Application in which the Document resides.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Application Application { get; }
Visual Basic (Declaration)
Public ReadOnly Property Application As Application
Visual C++
public:
property Application^ Application {
    Application^ get ();
}

See Also

Document Class
Autodesk.Revit Namespace


BeamSystemTypes Property

[image]

Revit 2010 API
Document..::.BeamSystemTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of beam system types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BeamSystemTypeSet BeamSystemTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property BeamSystemTypes As BeamSystemTypeSet
Visual C++
public:
property BeamSystemTypeSet^ BeamSystemTypes {
    BeamSystemTypeSet^ get ();
}

Remarks

This property returns a set of BeamSystemType objects. These objects can be used change the type of a BeamSystem from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


ContFootingTypes Property

[image]

Revit 2010 API
Document..::.ContFootingTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of continuous footing types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ContFootingTypeSet ContFootingTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContFootingTypes As ContFootingTypeSet
Visual C++
public:
property ContFootingTypeSet^ ContFootingTypes {
    ContFootingTypeSet^ get ();
}

Remarks

This property returns a set of ContFootingType objects. These objects can be used change the type of a ContFooting from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


Create Property

[image]

Revit 2010 API
Document..::.Create Property
Document Class See Also Send Feedback
An object that can be used to create new instances of Autodesk Revit API elements within a project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Document Create { get; }
Visual Basic (Declaration)
Public ReadOnly Property Create As Document
Visual C++
public:
property Document^ Create {
    Document^ get ();
}

Field Value

This object is used to create new instances of project elements within the Autodesk Revit API, such as FamilyInstances or groups.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the current document is family document.

See Also

Document Class
Autodesk.Revit Namespace


CurtainSystemTypes Property

[image]

Revit 2010 API
Document..::.CurtainSystemTypes Property
Document Class See Also Send Feedback
This property is used to retrieve all the CurtainSystem types in current system.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainSystemTypeSet CurtainSystemTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurtainSystemTypes As CurtainSystemTypeSet
Visual C++
public:
property CurtainSystemTypeSet^ CurtainSystemTypes {
    CurtainSystemTypeSet^ get ();
}

Remarks

This property returns a set of CurtainSystemType objects. These objects can be used change the type of a CurtainSystem from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


DeckProfiles Property

[image]

Revit 2010 API
Document..::.DeckProfiles Property
Document Class See Also Send Feedback
Returns an object that contains all of the avaible deck profiles currently loaded to this project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbolSet DeckProfiles { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeckProfiles As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ DeckProfiles {
    FamilySymbolSet^ get ();
}

Remarks

The DeckProfiles property returns an object that contains the deck profiles which can be used to change the profile of a layer within a compound structure object.

See Also

Document Class
Autodesk.Revit Namespace


DimensionTypes Property

[image]

Revit 2010 API
Document..::.DimensionTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of dimension types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DimensionTypeSet DimensionTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property DimensionTypes As DimensionTypeSet
Visual C++
public:
property DimensionTypeSet^ DimensionTypes {
    DimensionTypeSet^ get ();
}

Remarks

This property returns a set of DimensionType objects. These objects can be used change the type of a Dimension from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


DisplayUnitSystem Property

[image]

Revit 2010 API
Document..::.DisplayUnitSystem Property
Document Class See Also Send Feedback
Provides access to display unit type with in the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DisplayUnit DisplayUnitSystem { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayUnitSystem As DisplayUnit
Visual C++
public:
property DisplayUnit DisplayUnitSystem {
    DisplayUnit get ();
}

Remarks

Return the display unit type, metric or imperial.

See Also

Document Class
Autodesk.Revit Namespace


ElectricalEquipmentTypes Property

[image]

Revit 2010 API
Document..::.ElectricalEquipmentTypes Property
Document Class See Also Send Feedback
Returns an object that contains all of the avaible electrical equipment types currently loaded to this project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbolSet ElectricalEquipmentTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElectricalEquipmentTypes As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ ElectricalEquipmentTypes {
    FamilySymbolSet^ get ();
}

Remarks

The ElectricalEquipmentTypes property returns an object that contains the electrical equipment types which can be used to change the type of an electrical equipment from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


Element Property

[image] [image]

Revit 2010 API
Document..::.Element Property
Document Class See Also Send Feedback
Retrieves an element from the document given an identifier.

Overload List

Name | Description
Element[([(ElementId%])]) | Retrieves an element from the document given a Revit element id.
Element[([(String])]) | Retrieves an element from the document given a unique id string.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Element Property (ElementId)

[image]

Revit 2010 API
Document..::.Element Property (ElementId%)
Document Class See Also Send Feedback
Retrieves an element from the document given a Revit element id.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element Element[
    ref ElementId id
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Element ( _
    ByRef id As ElementId _
) As Element
Visual C++
public:
property Element^ Element[ElementId% id] {
    Element^ get (ElementId% id);
}

Parameters

id
Type: Autodesk.Revit..::.ElementId %
The ElementId of the element to be retrieved from the Document.

Remarks

Returns the element corresponding to the id that was passed. The Element property is used to retrieve a known Element from the Revit database within the Document. If the Element specified by the ElementId does not exist then an empty reference will be returned.

See Also

Document Class
Element Overload
Autodesk.Revit Namespace


Element Property (String)

[image]

Revit 2010 API
Document..::.Element Property (String)
Document Class See Also Send Feedback
Retrieves an element from the document given a unique id string.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element Element[
    string
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Element ( _
     As String _
) As Element
Visual C++
public:
property Element^ Element[String^ ] {
    Element^ get (String^ );
}

Parameters

Type: System..::.String

Remarks

Returns the element corresponding to the unique id that was passed. The Element property is used to retrieve a known Element from the Revit database within the Document. If the Element specified by the uniqueId does not exist then an empty reference will be returned.

See Also

Document Class
Element Overload
Autodesk.Revit Namespace


Elements Property

[image] [image]

Revit 2010 API
Document..::.Elements Property
Document Class See Also Send Feedback
Provides access to a set of elements from the document.

Overload List

Name | Description
Elements | Provides access to all elements within the Document.
Elements[([(Filter])]) | Provides access to all elements which satisfy specified filter within the Document.
Elements[([(Type])]) | Provides access to all elements of specified type from the document.
Elements[([(Filter, ElementArray])]) | Collects all elements which satisfy specified filter within the Document.
Elements[([(Filter, ICollection<(Of <(Element>)>)])]) | Collects all elements which satisfy specified filter within the Document.
Elements[([(Type, ElementArray])]) | Collects all elements which satisfy specified type within the Document.
Elements[([(Type, ICollection<(Of <(Element>)>)])]) | Collects all elements which satisfy specified type within the Document.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


Elements Property

[image]

Revit 2010 API
Document..::.Elements Property
Document Class Example See Also Send Feedback
Provides access to all elements within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementIterator Elements { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements As ElementIterator
Visual C++
public:
property ElementIterator^ Elements {
    ElementIterator^ get ();
}

Remarks

Returns a forward moving iterator that will traverse the entire Autodesk Revit element database. The Elements property provides an iterator that enables iteration of the entire Revit database of Elements. The iterator supports the standard COM iterator methods and behavior of IEnumerator.

Examples

CopyC#
// Get all the walls in current document.
System.Collections.ArrayList walls = new System.Collections.ArrayList();

ElementIterator iterator = document.Elements;
iterator.Reset();
while (iterator.MoveNext())
{
    if (iterator.Current is Autodesk.Revit.Elements.Wall)
    {
        walls.Add(iterator.Current);
    }
}

// Format the prompt string
String prompt = null;
if (0 == walls.Count)   // if there are not any wall
{
    prompt = "No walls in current document.";
}
else
{
    prompt = "The ids of the walls in the current document are:";
    foreach (Autodesk.Revit.Elements.Wall wall in walls)
    {
        // output the id of the walls
        prompt += "\n\t" + wall.Id.Value;
    }
}

// Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);
CopyVB.NET
' Get all the walls in current document.
Dim walls As New System.Collections.ArrayList()

Dim iterator As ElementIterator = document.Elements
iterator.Reset()
While iterator.MoveNext()
    If TypeOf iterator.Current Is Autodesk.Revit.Elements.Wall Then
        walls.Add(iterator.Current)
    End If
End While

' Format the prompt string
Dim prompt As String = Nothing
If 0 = walls.Count Then
    ' if there are not any wall
    prompt = "No walls in current document."
Else
    prompt = "The ids of the walls in the current document are:"
    For Each wall As Autodesk.Revit.Elements.Wall In walls
        ' output the id of the walls
        prompt += vbLf & vbTab & wall.Id.Value
    Next
End If

' Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)

See Also

Document Class
Elements Overload
Autodesk.Revit Namespace


Elements Property (Filter)

[image]

Revit 2010 API
Document..::.Elements Property (Filter)
Document Class Example See Also Send Feedback
Provides access to all elements which satisfy specified filter within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementIterator Elements[
    Filter filter
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements ( _
    filter As Filter _
) As ElementIterator
Visual C++
public:
property ElementIterator^ Elements[Filter^ filter] {
    ElementIterator^ get (Filter^ filter);
}

Parameters

filter
Type: Autodesk.Revit..::.Filter
Filter specified by user.

Remarks

The input filter parameter can be one of: TypeFilter, CategoryFilter, FamilyFilter, SymbolFilter, ParameterFilter, InstanceUsageFilter, WallUsageFilter, MaterialFilter or StructuralTypeFilter; This filter can be combination of more than one filters by using logical And and Or filters.

Examples

CopyC#
// Create a Filter to get all the doors in the document
Autodesk.Revit.Creation.Filter filterCreator = document.Application.Create.Filter;
TypeFilter familyInstanceFilter = filterCreator.NewTypeFilter(typeof(FamilyInstance), true);
CategoryFilter doorsCategoryfilter = filterCreator.NewCategoryFilter(BuiltInCategory.OST_Doors);
Filter doorInstancesFilter = filterCreator.NewLogicAndFilter(familyInstanceFilter, doorsCategoryfilter);

// Apply the filter to the elements in the active document
ElementIterator iterator = document.get_Elements(doorInstancesFilter);

String prompt = "The ids of the doors in the current document are:";
iterator.Reset();
while (iterator.MoveNext())
{
    FamilyInstance door = iterator.Current as FamilyInstance;
    // output the id of the doors
    prompt += "\n\t" + door.Id.Value;
}

// Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);
CopyVB.NET
' Create a Filter to get all the doors in the document
Dim filterCreator As Autodesk.Revit.Creation.Filter = document.Application.Create.Filter
Dim familyInstanceFilter As TypeFilter = filterCreator.NewTypeFilter(GetType(Autodesk.Revit.Elements.FamilyInstance), True)
Dim doorsCategoryfilter As CategoryFilter = filterCreator.NewCategoryFilter(BuiltInCategory.OST_Doors)
Dim doorInstancesFilter As Filter = filterCreator.NewLogicAndFilter(familyInstanceFilter, doorsCategoryfilter)

' Apply the filter to the elements in the active document
Dim iterator As ElementIterator = document.Elements(doorInstancesFilter)

Dim prompt As String = "The ids of the doors in the current document are:"
iterator.Reset()
While iterator.MoveNext()
    Dim door As Autodesk.Revit.Elements.FamilyInstance = TryCast(iterator.Current, Autodesk.Revit.Elements.FamilyInstance)
    ' output the id of the doors
    prompt += vbLf & vbTab & door.Id.Value
End While

' Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter of Filter is null.

See Also

Document Class
Elements Overload
Autodesk.Revit Namespace


Elements Property (Type)

[image]

Revit 2010 API
Document..::.Elements Property (Type)
Document Class Example See Also Send Feedback
Provides access to all elements of specified type from the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementIterator Elements[
    Type
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements ( _
     As Type _
) As ElementIterator
Visual C++
public:
property ElementIterator^ Elements[Type^ ] {
    ElementIterator^ get (Type^ );
}

Parameters

Type: System..::.Type

Remarks

Returns a forward moving iterator that will traverse the entire Autodesk Revit element database. The Elements property provides an iterator that enables iteration of the entire Revit database of Elements of specified type. The iterator supports the standard COM iterator methods and behavior of IEnumerator.

Examples

CopyC#
ElementIterator iterator = document.get_Elements(typeof(Wall));
String prompt = "The walls in the current document are:\n";
iterator.Reset();
while (iterator.MoveNext())
{
    Element e = iterator.Current as Element;
    prompt += e.Name + "\n";
}
MessageBox.Show(prompt, "Revit");
CopyVB.NET
Dim iterator As ElementIterator = document.Elements(GetType(Wall))
Dim prompt As String = "The walls in the current document are:" & vbLf
iterator.Reset()
While iterator.MoveNext()
    Dim e As Autodesk.Revit.Element = TryCast(iterator.Current, Autodesk.Revit.Element)
    prompt += e.Name & vbLf
End While
MessageBox.Show(prompt, "Revit")

See Also

Document Class
Elements Overload
Autodesk.Revit Namespace


Elements Property (Filter, ElementArray)

[image]

Revit 2010 API
Document..::.Elements Property (Filter, ElementArray)
Document Class See Also Send Feedback
Collects all elements which satisfy specified filter within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Elements[
    Filter filter,
    ElementArray elementArray
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements ( _
    filter As Filter, _
    elementArray As ElementArray _
) As Integer
Visual C++
public:
property int Elements[Filter^ filter, ElementArray^ elementArray] {
    int get (Filter^ filter, ElementArray^ elementArray);
}

Parameters

filter
Type: Autodesk.Revit..::.Filter
Filter used to determine the elements to add.
elementArray
Type: Autodesk.Revit..::.ElementArray
An array of elements which contains the elements found.

Remarks

The input filter parameter can be one of: TypeFilter, CategoryFilter, FamilyFilter, SymbolFilter, ParameterFilter, InstanceUsageFilter, WallUsageFilter, MaterialFilter or StructuralTypeFilter; This filter can be combination of more than one filters by using logical And and Or filters. If the element array provided already contains elements, new elements added to the element array will be checked against the contents of the element array, and elements already in the input will not be added to the element array again. Because of the overhead required to perform these checks, to obtain the best performance from this property pass an empty element array.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter of filter or elementArray is null.

See Also

Document Class
Elements Overload
Autodesk.Revit Namespace


Elements Property (Filter, ICollection(Element))

[image]

Revit 2010 API
Document..::.Elements Property (Filter, ICollection<(Of <(Element>)>))
Document Class See Also Send Feedback
Collects all elements which satisfy specified filter within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Elements[
    Filter filter,
    ICollection<Element> collection
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements ( _
    filter As Filter, _
    collection As ICollection(Of Element) _
) As Integer
Visual C++
public:
property int Elements[Filter^ filter, ICollection<Element^>^ collection] {
    int get (Filter^ filter, ICollection<Element^>^ collection);
}

Parameters

filter
Type: Autodesk.Revit..::.Filter
Filter used to determine the elements to add.
collection
Type: System.Collections.Generic..::.ICollection <(Of <( Element >)>)
An element collection to contain the elements found.

Remarks

The input filter parameter can be one of: TypeFilter, CategoryFilter, FamilyFilter, SymbolFilter, ParameterFilter, InstanceUsageFilter, WallUsageFilter, MaterialFilter or StructuralTypeFilter; This filter can be combination of more than one filters by using logical And and Or filters. If the collection provided already contains elements, new elements added to the collection will be checked against the contents of the collection, and elements already in the input will not be added to the collection again. Because of the overhead required to perform these checks, to obtain the best performance from this property pass an empty collection. This method is not supported in VSTA, use the variation accepting an ElementArray instead.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter of filter or collection is null.

See Also

Document Class
Elements Overload
Autodesk.Revit Namespace


Elements Property (Type, ElementArray)

[image]

Revit 2010 API
Document..::.Elements Property (Type, ElementArray)
Document Class Example See Also Send Feedback
Collects all elements which satisfy specified type within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Elements[
    Type type,
    ElementArray elementArray
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements ( _
    type As Type, _
    elementArray As ElementArray _
) As Integer
Visual C++
public:
property int Elements[Type^ type, ElementArray^ elementArray] {
    int get (Type^ type, ElementArray^ elementArray);
}

Parameters

type
Type: System..::.Type
Type used to determine the elements to add.
elementArray
Type: Autodesk.Revit..::.ElementArray
An array of elements which contains the elements found.

Remarks

If the element array provided already contains elements, new elements added to the element array will be checked against the contents of the element array, and elements already in the input will not be added to the element array again. Because of the overhead required to perform these checks, to obtain the best performance from this property pass an empty element array. This method won't find elements whose type is derived from the specified type.

Examples

CopyC#
ElementArray levelArray = new ElementArray();
int levels = document.get_Elements(typeof(Level), levelArray);

if (null != levelArray)
{
    string prompt = "There are " + levels + " levels in the project.\n";
    foreach (Element level in levelArray)
    {
        prompt += level.Name + "\n";
    }

    MessageBox.Show(prompt, "Revit");
}
CopyVB.NET
Dim levelArray As New ElementArray()
Dim levels As Integer = document.Elements(GetType(Autodesk.Revit.Elements.Level), levelArray)

If levelArray IsNot Nothing Then
    Dim prompt As String = "There are " & levels & " levels in the project." & vbLf
    For Each level As Autodesk.Revit.Element In levelArray
        prompt += level.Name & vbLf
    Next

    MessageBox.Show(prompt, "Revit")
End If

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter of type or elementArray is null.

See Also

Document Class
Elements Overload
Autodesk.Revit Namespace


Elements Property (Type, ICollection(Element))

[image]

Revit 2010 API
Document..::.Elements Property (Type, ICollection<(Of <(Element>)>))
Document Class See Also Send Feedback
Collects all elements which satisfy specified type within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Elements[
    Type type,
    ICollection<Element> collection
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements ( _
    type As Type, _
    collection As ICollection(Of Element) _
) As Integer
Visual C++
public:
property int Elements[Type^ type, ICollection<Element^>^ collection] {
    int get (Type^ type, ICollection<Element^>^ collection);
}

Parameters

type
Type: System..::.Type
Type used to determine the elements to add.
collection
Type: System.Collections.Generic..::.ICollection <(Of <( Element >)>)
An element collection to contain the elements found.

Remarks

If the collection provided already contains elements, new elements added to the collection will be checked against the contents of the collection, and elements already in the input will not be added to the collection again. Because of the overhead required to perform these checks, to obtain the best performance from this property pass an empty collection. This method won't find elements whose type is derived from the specified type. This method is not supported in VSTA, use the variation accepting an ElementArray instead.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter of type or collection is null.

See Also

Document Class
Elements Overload
Autodesk.Revit Namespace


FamilyCreate Property

[image]

Revit 2010 API
Document..::.FamilyCreate Property
Document Class See Also Send Feedback
An object that can be used to create new instances of Autodesk Revit API elements within a family document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyItemFactory FamilyCreate { get; }
Visual Basic (Declaration)
Public ReadOnly Property FamilyCreate As FamilyItemFactory
Visual C++
public:
property FamilyItemFactory^ FamilyCreate {
    FamilyItemFactory^ get ();
}

Field Value

This object is used to create new instances of family elements within the Autodesk Revit API, such as Extrusion or Reference lines.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the current document is project document.

See Also

Document Class
Autodesk.Revit Namespace


FamilyManager Property

[image]

Revit 2010 API
Document..::.FamilyManager Property
Document Class See Also Send Feedback
The family manager object provides access to family types and parameters.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyManager FamilyManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property FamilyManager As FamilyManager
Visual C++
public:
property FamilyManager^ FamilyManager {
    FamilyManager^ get ();
}

Remarks

This property is available when the document is a family document.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the current document is project document.

See Also

Document Class
Autodesk.Revit Namespace


FasciaTypes Property

[image]

Revit 2010 API
Document..::.FasciaTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the Fascia types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FasciaTypeSet FasciaTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property FasciaTypes As FasciaTypeSet
Visual C++
public:
property FasciaTypeSet^ FasciaTypes {
    FasciaTypeSet^ get ();
}

Remarks

This property returns a set of FasciaType objects. These objects can be used change the type of a floor from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


FilterTypeSupported Property

[image]

Revit 2010 API
Document..::.FilterTypeSupported Property
Document Class See Also Send Feedback
Boolean value which indicates whether the specified builtin parameter supports the specifed filter type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool FilterTypeSupported[
    BuiltInParameter ,
    CriteriaFilterType
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property FilterTypeSupported ( _
     As BuiltInParameter, _
     As CriteriaFilterType _
) As Boolean
Visual C++
public:
property bool FilterTypeSupported[BuiltInParameter , CriteriaFilterType ] {
    bool get (BuiltInParameter , CriteriaFilterType );
}

Parameters

Type: Autodesk.Revit.Parameters..::.BuiltInParameter
Type: Autodesk.Revit.Enums..::.CriteriaFilterType

Remarks

This property is useful in element retrieval. It can be used to provide correct options of filter types for the FilterCriterion object.

See Also

Document Class
Autodesk.Revit Namespace


FloorTypes Property

[image]

Revit 2010 API
Document..::.FloorTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the floor types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FloorTypeSet FloorTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property FloorTypes As FloorTypeSet
Visual C++
public:
property FloorTypeSet^ FloorTypes {
    FloorTypeSet^ get ();
}

Remarks

This property returns a set of FloorType objects. These objects can be used change the type of a floor from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


GridTypes Property

[image]

Revit 2010 API
Document..::.GridTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of Grid types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GridTypeSet GridTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property GridTypes As GridTypeSet
Visual C++
public:
property GridTypeSet^ GridTypes {
    GridTypeSet^ get ();
}

Remarks

This property returns a set of Grid objects. These objects can be used change the type of a Grid from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


GutterTypes Property

[image]

Revit 2010 API
Document..::.GutterTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the Gutter types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GutterTypeSet GutterTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property GutterTypes As GutterTypeSet
Visual C++
public:
property GutterTypeSet^ GutterTypes {
    GutterTypeSet^ get ();
}

Remarks

This property returns a set of GutterType objects. These objects can be used change the type of a floor from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


IsFamilyDocument Property

[image]

Revit 2010 API
Document..::.IsFamilyDocument Property
Document Class See Also Send Feedback
Identifies if the current document is a family document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsFamilyDocument { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFamilyDocument As Boolean
Visual C++
public:
property bool IsFamilyDocument {
    bool get ();
}

See Also

Document Class
Autodesk.Revit Namespace


IsModifiable Property

[image]

Revit 2010 API
Document..::.IsModifiable Property
Document Class See Also Send Feedback
The document's state of modifiability.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsModifiable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsModifiable As Boolean
Visual C++
public:
property bool IsModifiable {
    bool get ();
}

Field Value

True if the document is currently in a state of accepting modifications, False otherwise.

Remarks

This is not a permanent state such as, for example IsReadOnlyFile. Regardless of the mode a document is opened with, it can sometimes be in a state at which no modifications may be allowed to it. Though this is rather a rare situation, it can happen, most likely during model regeneration or some events. An attempt to modify a non-modifiable document will result in an exception.

See Also

Document Class
Autodesk.Revit Namespace


IsModified Property

[image]

Revit 2010 API
Document..::.IsModified Property
Document Class See Also Send Feedback
The state of changes made to the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsModified { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsModified As Boolean
Visual C++
public:
property bool IsModified {
    bool get ();
}

Field Value

True if the document has been modified since it was opened or saved, False otherwise.

See Also

Document Class
Autodesk.Revit Namespace


IsReadOnlyFile Property

[image]

Revit 2010 API
Document..::.IsReadOnlyFile Property
Document Class See Also Send Feedback
Signals whether the document was opened in read-only mode or not.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsReadOnlyFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnlyFile As Boolean
Visual C++
public:
property bool IsReadOnlyFile {
    bool get ();
}

Remarks

A document would be opened in read-only mode when, for example, at the time of opening it was already being used by another Revit user.

Although it is still possible to modify documents opened in read-only mode, any attempt to save them would naturally fail. Therefore any changes to the document would have to be saved using the SaveAs method.

See Also

Document Class
Autodesk.Revit Namespace


IsWorkshared Property

[image]

Revit 2010 API
Document..::.IsWorkshared Property
Document Class See Also Send Feedback
Identifies if worksets have been enabled in the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsWorkshared { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsWorkshared As Boolean
Visual C++
public:
property bool IsWorkshared {
    bool get ();
}

Field Value

True if the document is using worksets, false if it is working with a local file.

See Also

Document Class
Autodesk.Revit Namespace


LevelTypes Property

[image]

Revit 2010 API
Document..::.LevelTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the level types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LevelTypeSet LevelTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property LevelTypes As LevelTypeSet
Visual C++
public:
property LevelTypeSet^ LevelTypes {
    LevelTypeSet^ get ();
}

Remarks

This property returns a set of level objects. These objects can be used change the type of a level from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


LightingDeviceTypes Property

[image]

Revit 2010 API
Document..::.LightingDeviceTypes Property
Document Class See Also Send Feedback
Returns an object that contains all of the avaible lighting device types currently loaded to this project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbolSet LightingDeviceTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property LightingDeviceTypes As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ LightingDeviceTypes {
    FamilySymbolSet^ get ();
}

Remarks

The LightingDeviceTypes property returns an object that contains the lighting device types which can be used to change the type of a lighting device from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


LightingFixtureTypes Property

[image]

Revit 2010 API
Document..::.LightingFixtureTypes Property
Document Class See Also Send Feedback
Returns an object that contains all of the avaible lighting fixture types currently loaded to this project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbolSet LightingFixtureTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property LightingFixtureTypes As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ LightingFixtureTypes {
    FamilySymbolSet^ get ();
}

Remarks

The LightingFixtureTypes property returns an object that contains the lighting fixture types which can be used to change the type of a lighting fixture from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


MechanicalEquipmentTypes Property

[image]

Revit 2010 API
Document..::.MechanicalEquipmentTypes Property
Document Class See Also Send Feedback
Returns an object that contains all of the avaible mechanical equipment types currently loaded to this project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbolSet MechanicalEquipmentTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property MechanicalEquipmentTypes As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ MechanicalEquipmentTypes {
    FamilySymbolSet^ get ();
}

Remarks

The MechanicalEquipmentTypes property returns an object that contains the mechanical equipment types which can be used to change the type of a mechanical equipment from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


MullionTypes Property

[image]

Revit 2010 API
Document..::.MullionTypes Property
Document Class See Also Send Feedback
This property is used to retrieve all the mullion types in current system.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MullionTypeSet MullionTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property MullionTypes As MullionTypeSet
Visual C++
public:
property MullionTypeSet^ MullionTypes {
    MullionTypeSet^ get ();
}

Remarks

This property returns a set of MullionType objects. These objects can be used change the type of a mullion from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


OwnerFamily Property

[image]

Revit 2010 API
Document..::.OwnerFamily Property
Document Class Example See Also Send Feedback
Get the Family of this Family Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Family OwnerFamily { get; }
Visual Basic (Declaration)
Public ReadOnly Property OwnerFamily As Family
Visual C++
public:
property Family^ OwnerFamily {
    Family^ get ();
}

Remarks

Only available if the current document is family document.

Examples

CopyC#
string categoryName = familyDoc.OwnerFamily.FamilyCategory.Name;
CopyVB.NET
Dim categoryName As String = familyDoc.OwnerFamily.FamilyCategory.Name

See Also

Document Class
Autodesk.Revit Namespace


PanelTypes Property

[image]

Revit 2010 API
Document..::.PanelTypes Property
Document Class See Also Send Feedback
Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PanelTypeSet PanelTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property PanelTypes As PanelTypeSet
Visual C++
public:
property PanelTypeSet^ PanelTypes {
    PanelTypeSet^ get ();
}

Remarks

This property returns a set of panelType objects. These objects can be used change the type of a panel from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


ParameterBindings Property

[image]

Revit 2010 API
Document..::.ParameterBindings Property
Document Class See Also Send Feedback
Retrieves an object from which mappings between parameter definitions and categories can be found.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BindingMap ParameterBindings { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParameterBindings As BindingMap
Visual C++
public:
property BindingMap^ ParameterBindings {
    BindingMap^ get ();
}

Remarks

Returns a mapping between parameter definitions and parameter bindings. New bindings can be added to the Revit Document by using this object.

See Also

Document Class
Autodesk.Revit Namespace


PathName Property

[image]

Revit 2010 API
Document..::.PathName Property
Document Class Example See Also Send Feedback
Call this function to get the fully qualified path of the document's disk file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string PathName { get; }
Visual Basic (Declaration)
Public ReadOnly Property PathName As String
Visual C++
public:
property String^ PathName {
    String^ get ();
}

Remarks

The project's fully qualified path. This string is empty if the project has not been saved or does not have a disk file associated with it.

Examples

CopyC#
string docPathName = document.PathName;
CopyVB.NET
Dim docPathName As String = document.PathName

See Also

Document Class
Autodesk.Revit Namespace


Phases Property

[image]

Revit 2010 API
Document..::.Phases Property
Document Class Example See Also Send Feedback
Retrieves all the object that represent phases within the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PhaseArray Phases { get; }
Visual Basic (Declaration)
Public ReadOnly Property Phases As PhaseArray
Visual C++
public:
property PhaseArray^ Phases {
    PhaseArray^ get ();
}

Remarks

The phases returned are in order of earliest phase first, through to latest phase last.

Examples

CopyC#
void Getinfo_Phase(Document doc)
{
    // Get the phase array which contains all the phases.
    PhaseArray phases = doc.Phases;
    // Format the prompt string which identifies all supported phases in the current document.
    String prompt = null;
    if (0 != phases.Size)
    {
        prompt = "All the phases in current document list as follow:";
        foreach (Phase ii in phases)
        {
            prompt += "\n\t" + ii.Name;
        }
    }
    else
    {
        prompt = "There are no phases in current document.";
    }
    // Give the user the information.
    MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Private Sub Getinfo_Phase(ByVal doc As Document)
    ' Get the phase array which contains all the phases.
    Dim phases As PhaseArray = doc.Phases
    ' Format the prompt string which identifies all supported phases in the current document.
    Dim prompt As String = Nothing
    If 0 <> phases.Size Then
        prompt = "All the phases in current document list as follow:"
        For Each ii As Phase In phases
            prompt += vbLf & vbTab & ii.Name
        Next
    Else
        prompt = "There are no phases in current document."
    End If
    ' Give the user the information.
    MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)
End Sub

See Also

Document Class
Autodesk.Revit Namespace


PlanTopologies Property

[image] [image]

Revit 2010 API
Document..::.PlanTopologies Property
Document Class See Also Send Feedback
Gets the PlanTopologies of the current project.

Overload List

Name | Description
PlanTopologies | Get the PlanTopologies of the current project in the last phase.
PlanTopologies[([(Phase])]) | Gets the PlanTopologies of the current project in a given phase.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


PlanTopologies Property

[image]

Revit 2010 API
Document..::.PlanTopologies Property
Document Class See Also Send Feedback
Get the PlanTopologies of the current project in the last phase.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PlanTopologySet PlanTopologies { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlanTopologies As PlanTopologySet
Visual C++
public:
property PlanTopologySet^ PlanTopologies {
    PlanTopologySet^ get ();
}

See Also

Document Class
PlanTopologies Overload
Autodesk.Revit Namespace


PlanTopologies Property (Phase)

[image]

Revit 2010 API
Document..::.PlanTopologies Property (Phase)
Document Class See Also Send Feedback
Gets the PlanTopologies of the current project in a given phase.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PlanTopologySet PlanTopologies[
    Phase phase
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlanTopologies ( _
    phase As Phase _
) As PlanTopologySet
Visual C++
public:
property PlanTopologySet^ PlanTopologies[Phase^ phase] {
    PlanTopologySet^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.Elements..::.Phase
The phase of the Plan Topology.

Remarks

The Plan Topologies you get here is in the phase you assigned.

See Also

Document Class
PlanTopologies Overload
Autodesk.Revit Namespace


PlanTopology Property

[image] [image]

Revit 2010 API
Document..::.PlanTopology Property
Document Class See Also Send Feedback
Gets the PlanTopology of a given level.

Overload List

Name | Description
PlanTopology[([(Level])]) | Get the PlanTopology of a given level in the last phase.
PlanTopology[([(Level, Phase])]) | Get the PlanTopology of a given level in a given phase.

See Also

Document Class
Document Members
Autodesk.Revit Namespace


PlanTopology Property (Level)

[image]

Revit 2010 API
Document..::.PlanTopology Property (Level)
Document Class See Also Send Feedback
Get the PlanTopology of a given level in the last phase.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PlanTopology PlanTopology[
    Level level
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlanTopology ( _
    level As Level _
) As PlanTopology
Visual C++
public:
property PlanTopology^ PlanTopology[Level^ level] {
    PlanTopology^ get (Level^ level);
}

Parameters

level
Type: Autodesk.Revit.Elements..::.Level
The level of the Plan Topology.

See Also

Document Class
PlanTopology Overload
Autodesk.Revit Namespace


PlanTopology Property (Level, Phase)

[image]

Revit 2010 API
Document..::.PlanTopology Property (Level, Phase)
Document Class See Also Send Feedback
Get the PlanTopology of a given level in a given phase.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PlanTopology PlanTopology[
    Level level,
    Phase phase
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlanTopology ( _
    level As Level, _
    phase As Phase _
) As PlanTopology
Visual C++
public:
property PlanTopology^ PlanTopology[Level^ level, Phase^ phase] {
    PlanTopology^ get (Level^ level, Phase^ phase);
}

Parameters

level
Type: Autodesk.Revit.Elements..::.Level
The level of the Plan Topology.
phase
Type: Autodesk.Revit.Elements..::.Phase
The phase of the Plan Topology.

Remarks

The Plan Topology you get here is in the phase you assigned.

See Also

Document Class
PlanTopology Overload
Autodesk.Revit Namespace


PrintManager Property

[image]

Revit 2010 API
Document..::.PrintManager Property
Document Class See Also Send Feedback
Retrieve the PrintManager of current project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PrintManager PrintManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintManager As PrintManager
Visual C++
public:
property PrintManager^ PrintManager {
    PrintManager^ get ();
}

See Also

Document Class
Autodesk.Revit Namespace


PrintSettings Property

[image]

Revit 2010 API
Document..::.PrintSettings Property
Document Class See Also Send Feedback
Retrieve all Print Settings of current project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet PrintSettings { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintSettings As ElementSet
Visual C++
public:
property ElementSet^ PrintSettings {
    ElementSet^ get ();
}

See Also

Document Class
Autodesk.Revit Namespace


ProjectInformation Property

[image]

Revit 2010 API
Document..::.ProjectInformation Property
Document Class See Also Send Feedback
Return the Project Information of the current project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProjectInfo ProjectInformation { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectInformation As ProjectInfo
Visual C++
public:
property ProjectInfo^ ProjectInformation {
    ProjectInfo^ get ();
}

Return Value

Revit::Elements::ProjectInfo

See Also

Document Class
Autodesk.Revit Namespace


ProjectLocations Property

[image]

Revit 2010 API
Document..::.ProjectLocations Property
Document Class See Also Send Feedback
Retrieve all the project locations associated with this project

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProjectLocationSet ProjectLocations { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectLocations As ProjectLocationSet
Visual C++
public:
property ProjectLocationSet^ ProjectLocations {
    ProjectLocationSet^ get ();
}

Remarks

This property returns all the locations of the project. A project can have one site location but many project locations within that site. Each project location object is an offset and rotation from the site location.

See Also

Document Class
Autodesk.Revit Namespace


ProjectUnit Property

[image]

Revit 2010 API
Document..::.ProjectUnit Property
Document Class See Also Send Feedback
Provides access to Project Unit Setting with in the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProjectUnit ProjectUnit { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectUnit As ProjectUnit
Visual C++
public:
property ProjectUnit^ ProjectUnit {
    ProjectUnit^ get ();
}

Remarks

Return the Project Unit Setting items.

See Also

Document Class
Autodesk.Revit Namespace


ReactionsAreUpToDate Property

[image]

Revit 2010 API
Document..::.ReactionsAreUpToDate Property
Document Class See Also Send Feedback
Reports if the analytical model has regenerated in a document with reaction loads.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool ReactionsAreUpToDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReactionsAreUpToDate As Boolean
Visual C++
public:
property bool ReactionsAreUpToDate {
    bool get ();
}

Remarks

Revit sets this property to False after regeneration of the analytical model if the document contains loads that have isReaction=True. This results in a user-visible warning that exists until there are no longer loads with isReaction=True.

See Also

Document Class
Autodesk.Revit Namespace


RebarBarTypes Property

[image]

Revit 2010 API
Document..::.RebarBarTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the rebar bar types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarBarTypeSet RebarBarTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RebarBarTypes As RebarBarTypeSet
Visual C++
public:
property RebarBarTypeSet^ RebarBarTypes {
    RebarBarTypeSet^ get ();
}

Remarks

This property returns a set of rebarbartype objects. These objects can be used change the type of a rebar from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


RebarCoverTypes Property

[image]

Revit 2010 API
Document..::.RebarCoverTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the rebar cover types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarCoverTypeSet RebarCoverTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RebarCoverTypes As RebarCoverTypeSet
Visual C++
public:
property RebarCoverTypeSet^ RebarCoverTypes {
    RebarCoverTypeSet^ get ();
}

Remarks

This property returns a set of RebarCoverType objects.

See Also

Document Class
Autodesk.Revit Namespace


RebarHookTypes Property

[image]

Revit 2010 API
Document..::.RebarHookTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the rebar hook types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarHookTypeSet RebarHookTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RebarHookTypes As RebarHookTypeSet
Visual C++
public:
property RebarHookTypeSet^ RebarHookTypes {
    RebarHookTypeSet^ get ();
}

Remarks

This property returns a set of rebarhooktype objects.

See Also

Document Class
Autodesk.Revit Namespace


RebarShapes Property

[image]

Revit 2010 API
Document..::.RebarShapes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the rebar shape types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarShapeSet RebarShapes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RebarShapes As RebarShapeSet
Visual C++
public:
property RebarShapeSet^ RebarShapes {
    RebarShapeSet^ get ();
}

Remarks

This property returns a set of RebarShape objects.

See Also

Document Class
Autodesk.Revit Namespace


RoofTypes Property

[image]

Revit 2010 API
Document..::.RoofTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the roof types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RoofTypeSet RoofTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RoofTypes As RoofTypeSet
Visual C++
public:
property RoofTypeSet^ RoofTypes {
    RoofTypeSet^ get ();
}

Remarks

This property returns a set of RoofType objects.

See Also

Document Class
Autodesk.Revit Namespace


RoomTagTypes Property

[image]

Revit 2010 API
Document..::.RoomTagTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of RoomTag types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RoomTagTypeSet RoomTagTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RoomTagTypes As RoomTagTypeSet
Visual C++
public:
property RoomTagTypeSet^ RoomTagTypes {
    RoomTagTypeSet^ get ();
}

Remarks

This property returns a set of RoomTag objects. These objects can be used change the type of a RoomTag from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


Selection Property

[image]

Revit 2010 API
Document..::.Selection Property
Document Class Example See Also Send Feedback
Retrieve the currently selected Elements in Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Selection Selection { get; }
Visual Basic (Declaration)
Public ReadOnly Property Selection As Selection
Visual C++
public:
property Selection^ Selection {
    Selection^ get ();
}

Remarks

Returns an object that represents the active selection. The Selection property returns an object that represents the active selection when the command was started.

Examples

CopyC#
public class Document_Selection : IExternalCommand
{
    public IExternalCommand.Result Execute(ExternalCommandData commandData,
        ref string message, ElementSet elements)
    {
        try
        {
            // Select some elements in Revit before invoking this command

            // Get the handle of current document.
            Document document = commandData.Application.ActiveDocument;

            // Get the element selection of current document.
            Selection selection = document.Selection;
            ElementSet collection = selection.Elements;

            if (0 == collection.Size)
            {
                // If no elements selected.
                MessageBox.Show("You haven't selected any elements.", "Revit");
            }
            else
            {
                String info = "Ids of selected elements in the document are: ";
                foreach (Element elem in collection)
                {
                    info += "\n\t" + elem.Id.Value;
                }

                MessageBox.Show(info, "Revit", MessageBoxButtons.OK);
            }
        }
        catch (Exception e)
        {
            message = e.Message;
            return IExternalCommand.Result.Failed;
        }

        return IExternalCommand.Result.Succeeded;
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Document_Selection
    Implements IExternalCommand
    Public Function Execute(ByVal commandData As ExternalCommandData, ByRef message As String, ByVal elements As ElementSet) As IExternalCommand.Result Implements IExternalCommand.Execute
        Try
            ' Select some elements in Revit before invoking this command

            ' Get the handle of current document.
            Dim document As Document = commandData.Application.ActiveDocument

            ' Get the element selection of current document.
            Dim selection As Autodesk.Revit.Selection = document.Selection
            Dim collection As ElementSet = selection.Elements

            If 0 = collection.Size Then
                ' If no elements selected.
                MessageBox.Show("You haven't selected any elements.", "Revit")
            Else
                Dim info As String = "Ids of selected elements in the document are: "
                For Each elem As Autodesk.Revit.Element In collection
                    info += vbLf & vbTab & elem.Id.Value
                Next

                MessageBox.Show(info, "Revit", MessageBoxButtons.OK)
            End If
        Catch e As Exception
            message = e.Message
            Return IExternalCommand.Result.Failed
        End Try

        Return IExternalCommand.Result.Succeeded
    End Function
End Class

See Also

Document Class
Autodesk.Revit Namespace


Settings Property

[image]

Revit 2010 API
Document..::.Settings Property
Document Class See Also Send Feedback
Provides access to general application settings, such as Categories.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Settings Settings { get; }
Visual Basic (Declaration)
Public ReadOnly Property Settings As Settings
Visual C++
public:
property Settings^ Settings {
    Settings^ get ();
}

Remarks

Returns an object that provides access to various settings within Autodesk Revit. The Settings property returns an object that provides access to the categories within the Autodesk Revit project.

See Also

Document Class
Autodesk.Revit Namespace


SiteLocation Property

[image]

Revit 2010 API
Document..::.SiteLocation Property
Document Class See Also Send Feedback
Returns the site location information.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SiteLocation SiteLocation { get; }
Visual Basic (Declaration)
Public ReadOnly Property SiteLocation As SiteLocation
Visual C++
public:
property SiteLocation^ SiteLocation {
    SiteLocation^ get ();
}

Remarks

The SiteLocation property returns an object that contains the site location for the entire project.

See Also

Document Class
Autodesk.Revit Namespace


SlabEdgeTypes Property

[image]

Revit 2010 API
Document..::.SlabEdgeTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the SlabEdge types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabEdgeTypeSet SlabEdgeTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property SlabEdgeTypes As SlabEdgeTypeSet
Visual C++
public:
property SlabEdgeTypeSet^ SlabEdgeTypes {
    SlabEdgeTypeSet^ get ();
}

Remarks

This property returns a set of SlabEdgeType objects. These objects can be used change the type of a floor from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


SpaceTagTypes Property

[image]

Revit 2010 API
Document..::.SpaceTagTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of RoomTag types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpaceTagTypeSet SpaceTagTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property SpaceTagTypes As SpaceTagTypeSet
Visual C++
public:
property SpaceTagTypeSet^ SpaceTagTypes {
    SpaceTagTypeSet^ get ();
}

Remarks

This property returns a set of RoomTag objects. These objects can be used change the type of a RoomTag from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


SpotDimensionTypes Property

[image]

Revit 2010 API
Document..::.SpotDimensionTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of SpotDimension types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpotDimensionTypeSet SpotDimensionTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property SpotDimensionTypes As SpotDimensionTypeSet
Visual C++
public:
property SpotDimensionTypeSet^ SpotDimensionTypes {
    SpotDimensionTypeSet^ get ();
}

Remarks

This property returns a set of SpotDimensionType objects. These objects can be used change the type of a SpotDimension from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


TextNoteTypes Property

[image]

Revit 2010 API
Document..::.TextNoteTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of TextNote types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TextNoteTypeSet TextNoteTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextNoteTypes As TextNoteTypeSet
Visual C++
public:
property TextNoteTypeSet^ TextNoteTypes {
    TextNoteTypeSet^ get ();
}

Remarks

This property returns a set of TextNote objects. These objects can be used change the type of a TextNote from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


Title Property

[image]

Revit 2010 API
Document..::.Title Property
Document Class See Also Send Feedback
Call this function to get the project's title, which is usually derived from the project's filename.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

Remarks

Returns the document's title.

See Also

Document Class
Autodesk.Revit Namespace


TitleBlocks Property

[image]

Revit 2010 API
Document..::.TitleBlocks Property
Document Class See Also Send Feedback
Titleblocks currently loaded into the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbolSet TitleBlocks { get; }
Visual Basic (Declaration)
Public ReadOnly Property TitleBlocks As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ TitleBlocks {
    FamilySymbolSet^ get ();
}

Remarks

A titleblock is a symbol that defines the layout of a drafting sheet.

See Also

Document Class
Autodesk.Revit Namespace


TrussTypes Property

[image]

Revit 2010 API
Document..::.TrussTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the truss types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TrussTypeSet TrussTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property TrussTypes As TrussTypeSet
Visual C++
public:
property TrussTypeSet^ TrussTypes {
    TrussTypeSet^ get ();
}

Remarks

This property returns a set of TrussType objects.

See Also

Document Class
Autodesk.Revit Namespace


TypeOfStorage Property

[image]

Revit 2010 API
Document..::.TypeOfStorage Property
Document Class See Also Send Feedback
Get the storage type of the specified builtin parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public StorageType TypeOfStorage[
    BuiltInParameter
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property TypeOfStorage ( _
     As BuiltInParameter _
) As StorageType
Visual C++
public:
property StorageType TypeOfStorage[BuiltInParameter ] {
    StorageType get (BuiltInParameter );
}

Parameters

Type: Autodesk.Revit.Parameters..::.BuiltInParameter

Remarks

This property is useful in element retrieval. It can be used to create a ParameterStorage object with a correct storage type for the FilterCriterion object.

See Also

Document Class
Autodesk.Revit Namespace


ViewSheetSets Property

[image]

Revit 2010 API
Document..::.ViewSheetSets Property
Document Class See Also Send Feedback
The view sheet sets stored in the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSheetSets ViewSheetSets { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewSheetSets As ViewSheetSets
Visual C++
public:
property ViewSheetSets^ ViewSheetSets {
    ViewSheetSets^ get ();
}

Field Value

A group of the available view sheet sets.

See Also

Document Class
Autodesk.Revit Namespace


WallTypes Property

[image]

Revit 2010 API
Document..::.WallTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the wall types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WallTypeSet WallTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property WallTypes As WallTypeSet
Visual C++
public:
property WallTypeSet^ WallTypes {
    WallTypeSet^ get ();
}

Remarks

This property returns a set of WallType objects. These objects can be used change the type of a wall from one type to another.

See Also

Document Class
Autodesk.Revit Namespace


WorksharingCentralFilename Property

[image]

Revit 2010 API
Document..::.WorksharingCentralFilename Property
Document Class See Also Send Feedback
The name and path of the central file name for a workshared document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string WorksharingCentralFilename { get; }
Visual Basic (Declaration)
Public ReadOnly Property WorksharingCentralFilename As String
Visual C++
public:
property String^ WorksharingCentralFilename {
    String^ get ();
}

Field Value

The name and path of the central file, or "" if the file is not workshared.

See Also

Document Class
Autodesk.Revit Namespace


Document Events

[image] [image]

Revit 2010 API
Document Events
Document Class See Also Send Feedback

The Document type exposes the following members.

Events

Name | Description
DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving document.
DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save the document.
DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
OnClose | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentClosing event instead. Subscribe to the OnClose event to be notified before the current document is closed.
OnSave | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentSaving event instead. Subscribe to the OnSave event to be notified before a document is saved.
OnSaveAs | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentSavingAs event instead. Subscribe to the OnSaveAs event to be notified before the current document is saved as a file with another name.
ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

Document Class
Autodesk.Revit Namespace


DocumentClosing Event

[image]

Revit 2010 API
Document..::.DocumentClosing Event
Document Class See Also Send Feedback
Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentClosingEventArgs> DocumentClosing
Visual Basic (Declaration)
Public Event DocumentClosing As EventHandler(Of DocumentClosingEventArgs)
Visual C++
public:
 event EventHandler<DocumentClosingEventArgs^>^ DocumentClosing {
    void add (EventHandler<DocumentClosingEventArgs^>^ value);
    void remove (EventHandler<DocumentClosingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to close a document. This document-level event precedes the application-level event of the same name.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to 'true' to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may not be modified during this event.

Please be aware that the following API functions are not available for current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another Revit::Application::DocumentClosed event will be raised immediately after document is closed. The DocumentClosing event is meant to replace the older OnClose event, which is now Obsolete.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Document Class
Autodesk.Revit Namespace


DocumentPrinted Event

[image]

Revit 2010 API
Document..::.DocumentPrinted Event
Document Class See Also Send Feedback
Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentPrintedEventArgs> DocumentPrinted
Visual Basic (Declaration)
Public Event DocumentPrinted As EventHandler(Of DocumentPrintedEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintedEventArgs^>^ DocumentPrinted {
    void add (EventHandler<DocumentPrintedEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view or ViewSet of the document. This document-level event precedes the application-level event of the same name. It is raised even when document printing failed or was cancelled (during DocumentPriting event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of printing has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need for creating another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Document Class
Autodesk.Revit Namespace


DocumentPrinting Event

[image]

Revit 2010 API
Document..::.DocumentPrinting Event
Document Class See Also Send Feedback
Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentPrintingEventArgs> DocumentPrinting
Visual Basic (Declaration)
Public Event DocumentPrinting As EventHandler(Of DocumentPrintingEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintingEventArgs^>^ DocumentPrinting {
    void add (EventHandler<DocumentPrintingEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view or ViewSet of the document. This document-level event precedes the application-level event of the same name.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to 'true'. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need for creating another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for current document during this event:

  • Export(String, String, GBXMLExportOptions) and similar overloads.
  • Autodesk::Revit::Document::Print
  • Print()()() and similar overloads.
  • SubmitPrint()()() and similar overloads.
  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

After this event,for each view being printed,Autodesk::Revit::Application::ViewPrinting and Autodesk::Revit::Application::ViewPrinted events will be raised. Another event DocumentPrinted will be raised immediately after document printing is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Document Class
Autodesk.Revit Namespace


DocumentSaved Event

[image]

Revit 2010 API
Document..::.DocumentSaved Event
Document Class See Also Send Feedback
Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentSavedEventArgs> DocumentSaved
Visual Basic (Declaration)
Public Event DocumentSaved As EventHandler(Of DocumentSavedEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedEventArgs^>^ DocumentSaved {
    void add (EventHandler<DocumentSavedEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving document. This document-level event precedes the application-level event of the same name. Note that the first save of a newly created document will raise DocumentSavedAs rather than DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSaving event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need for creating another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Document Class
Autodesk.Revit Namespace


DocumentSavedAs Event

[image]

Revit 2010 API
Document..::.DocumentSavedAs Event
Document Class See Also Send Feedback
Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentSavedAsEventArgs> DocumentSavedAs
Visual Basic (Declaration)
Public Event DocumentSavedAs As EventHandler(Of DocumentSavedAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedAsEventArgs^>^ DocumentSavedAs {
    void add (EventHandler<DocumentSavedAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedAsEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving document with a new file name. This document-level event precedes the application-level event of the same name. Note that the first save of a newly created document will raise DocumentSavedAs rather than DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSavingAs event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need for creating another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Document Class
Autodesk.Revit Namespace


DocumentSaving Event

[image]

Revit 2010 API
Document..::.DocumentSaving Event
Document Class See Also Send Feedback
Subscribe to the DocumentSaving event to be notified when Revit is just about to save the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentSavingEventArgs> DocumentSaving
Visual Basic (Declaration)
Public Event DocumentSaving As EventHandler(Of DocumentSavingEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingEventArgs^>^ DocumentSaving {
    void add (EventHandler<DocumentSavingEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document. This document-level event precedes the application-level event of the same name. Note that the first save of a newly created document will raise DocumentSavingAs rather than DocumentSaving event.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to 'true' to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need for creating another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSaved will be raised immediately after the document has been saved. The DocumentSaving event is meant to replace the older OnSave event, which is now Obsolete.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Document Class
Autodesk.Revit Namespace


DocumentSavingAs Event

[image]

Revit 2010 API
Document..::.DocumentSavingAs Event
Document Class See Also Send Feedback
Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentSavingAsEventArgs> DocumentSavingAs
Visual Basic (Declaration)
Public Event DocumentSavingAs As EventHandler(Of DocumentSavingAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingAsEventArgs^>^ DocumentSavingAs {
    void add (EventHandler<DocumentSavingAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingAsEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document with a new file name. This document-level event precedes the application-level event of the same name. Note that the first save of a newly created document will raise DocumentSavingAs rather than DocumentSaving event.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to 'true' to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need for creating another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSavedAs will be raised immediately after the document has been saved with a new file name. The DocumentSavingAs event is meant to replace the older OnSaveAs event, which is now Obsolete.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Document Class
Autodesk.Revit Namespace


OnClose Event

[image]

Revit 2010 API
Document..::.OnClose Event
Document Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentClosing event instead. Subscribe to the OnClose event to be notified before the current document is closed.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentClosing event instead.")]
public event DocumentCloseEventHandler OnClose
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentClosing event instead.")> _
Public Event OnClose As DocumentCloseEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentClosing event instead.")]
public:
 event DocumentCloseEventHandler^ OnClose {
    void add (DocumentCloseEventHandler^ value);
    void remove (DocumentCloseEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document will be closed. By subscribing to this event the application will be notified before such an event and can perform an action in response.

See Also

Document Class
Autodesk.Revit Namespace


OnSave Event

[image]

Revit 2010 API
Document..::.OnSave Event
Document Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentSaving event instead. Subscribe to the OnSave event to be notified before a document is saved.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSaving event instead.")]
public event DocumentSaveEventHandler OnSave
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSaving event instead.")> _
Public Event OnSave As DocumentSaveEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentSaving event instead.")]
public:
 event DocumentSaveEventHandler^ OnSave {
    void add (DocumentSaveEventHandler^ value);
    void remove (DocumentSaveEventHandler^ value);
}

Remarks

Sometimes an application needs to know when the document will be saved. By subscribing to this event the application will be notified before such an event and can perform an action in response.

See Also

Document Class
Autodesk.Revit Namespace


OnSaveAs Event

[image]

Revit 2010 API
Document..::.OnSaveAs Event
Document Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentSavingAs event instead. Subscribe to the OnSaveAs event to be notified before the current document is saved as a file with another name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSavingAs event instead.")]
public event DocumentSaveAsEventHandler OnSaveAs
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSavingAs event instead.")> _
Public Event OnSaveAs As DocumentSaveAsEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentSavingAs event instead.")]
public:
 event DocumentSaveAsEventHandler^ OnSaveAs {
    void add (DocumentSaveAsEventHandler^ value);
    void remove (DocumentSaveAsEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document will be saved as a file with another name. By subscribing to this event the application will be notified before such an event and can perform an action in response.

See Also

Document Class
Autodesk.Revit Namespace


ViewPrinted Event

[image]

Revit 2010 API
Document..::.ViewPrinted Event
Document Class See Also Send Feedback
Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<ViewPrintedEventArgs> ViewPrinted
Visual Basic (Declaration)
Public Event ViewPrinted As EventHandler(Of ViewPrintedEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintedEventArgs^>^ ViewPrinted {
    void add (EventHandler<ViewPrintedEventArgs^>^ value);
    void remove (EventHandler<ViewPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view of the document. This document-level event precedes the application-level event of the same name. It is raised even when view printing failed.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of view printing has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need for creating another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Document Class
Autodesk.Revit Namespace


ViewPrinting Event

[image]

Revit 2010 API
Document..::.ViewPrinting Event
Document Class See Also Send Feedback
Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<ViewPrintingEventArgs> ViewPrinting
Visual Basic (Declaration)
Public Event ViewPrinting As EventHandler(Of ViewPrintingEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintingEventArgs^>^ ViewPrinting {
    void add (EventHandler<ViewPrintingEventArgs^>^ value);
    void remove (EventHandler<ViewPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view of the document. This document-level event precedes the application-level event of the same name.

Event is not cancellable. The 'Cancellable' property of event’s argument is always 'false'.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need for creating another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for current document during this event:

  • Export(String, String, GBXMLExportOptions) and similar overloads.
  • Autodesk::Revit::Document::Print
  • Print()()() and similar overloads.
  • SubmitPrint()()() and similar overloads.
  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewPrinted will be raised immediately after view printing is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Document Class
Autodesk.Revit Namespace


DocumentSet Class

[image]

Revit 2010 API
DocumentSet Class
Members See Also Send Feedback
A set that can contain any documents.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DocumentSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class DocumentSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DocumentSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.DocumentSet

See Also

DocumentSet Members
Autodesk.Revit Namespace


DocumentSet Members

[image] [image]

Revit 2010 API
DocumentSet Members
DocumentSet Class Constructors Methods Properties See Also Send Feedback

The DocumentSet type exposes the following members.

Constructors

Name | Description
DocumentSet | Initializes a new instance of the DocumentSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

DocumentSet Class
Autodesk.Revit Namespace


DocumentSet Constructor

[image]

Revit 2010 API
DocumentSet Constructor
DocumentSet Class See Also Send Feedback
Initializes a new instance of the DocumentSet class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DocumentSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentSet()

See Also

DocumentSet Class
Autodesk.Revit Namespace


DocumentSet Methods

[image] [image]

Revit 2010 API
DocumentSet Methods
DocumentSet Class See Also Send Feedback

The DocumentSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSet Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
DocumentSet..::.Clear Method
DocumentSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DocumentSet Class
Autodesk.Revit Namespace


Contains Method

[image]

Revit 2010 API
DocumentSet..::.Contains Method
DocumentSet Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    Document item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Document _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Document^ item
)

Parameters

item
Type: Autodesk.Revit..::.Document
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

DocumentSet Class
Autodesk.Revit Namespace


Erase Method

[image]

Revit 2010 API
DocumentSet..::.Erase Method
DocumentSet Class See Also Send Feedback
Removes a specified object from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    Document item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Document _
) As Integer
Visual C++
public:
virtual int Erase(
    Document^ item
)

Parameters

item
Type: Autodesk.Revit..::.Document
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

DocumentSet Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
DocumentSet..::.ForwardIterator Method
DocumentSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DocumentSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DocumentSetIterator
Visual C++
public:
virtual DocumentSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

DocumentSet Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
DocumentSet..::.GetEnumerator Method
DocumentSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DocumentSet Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
DocumentSet..::.Insert Method
DocumentSet Class See Also Send Feedback
Insert the specified item into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    Document item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Document _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Document^ item
)

Parameters

item
Type: Autodesk.Revit..::.Document
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

DocumentSet Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
DocumentSet..::.ReverseIterator Method
DocumentSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DocumentSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DocumentSetIterator
Visual C++
public:
virtual DocumentSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

DocumentSet Class
Autodesk.Revit Namespace


DocumentSet Properties

[image] [image]

Revit 2010 API
DocumentSet Properties
DocumentSet Class See Also Send Feedback

The DocumentSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

DocumentSet Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
DocumentSet..::.IsEmpty Property
DocumentSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

DocumentSet Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
DocumentSet..::.Size Property
DocumentSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DocumentSet Class
Autodesk.Revit Namespace


DocumentSetIterator Class

[image]

Revit 2010 API
DocumentSetIterator Class
Members See Also Send Feedback
An iterator to a set of documents.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class DocumentSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class DocumentSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DocumentSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.DocumentSetIterator

See Also

DocumentSetIterator Members
Autodesk.Revit Namespace


DocumentSetIterator Members

[image] [image]

Revit 2010 API
DocumentSetIterator Members
DocumentSetIterator Class Constructors Methods Properties See Also Send Feedback

The DocumentSetIterator type exposes the following members.

Constructors

Name | Description
DocumentSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DocumentSetIterator Class
Autodesk.Revit Namespace


DocumentSetIterator Constructor

[image]

Revit 2010 API
DocumentSetIterator Constructor
DocumentSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DocumentSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DocumentSetIterator Class
Autodesk.Revit Namespace


DocumentSetIterator Methods

[image] [image]

Revit 2010 API
DocumentSetIterator Methods
DocumentSetIterator Class See Also Send Feedback

The DocumentSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
DocumentSetIterator..::.MoveNext Method
DocumentSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DocumentSetIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
DocumentSetIterator..::.Reset Method
DocumentSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DocumentSetIterator Class
Autodesk.Revit Namespace


DocumentSetIterator Properties

[image] [image]

Revit 2010 API
DocumentSetIterator Properties
DocumentSetIterator Class See Also Send Feedback

The DocumentSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DocumentSetIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
DocumentSetIterator..::.Current Property
DocumentSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DocumentSetIterator Class
Autodesk.Revit Namespace


DWF2DExportOptions Class

[image]

Revit 2010 API
DWF2DExportOptions Class
Members See Also Send Feedback
DWF2D Export options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DWF2DExportOptions : DWFExportOptions
Visual Basic (Declaration)
Public Class DWF2DExportOptions _
    Inherits DWFExportOptions
Visual C++
public ref class DWF2DExportOptions : public DWFExportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.CADExportOptions
Autodesk.Revit..::.DWFExportOptions
Autodesk.Revit..::.DWF2DExportOptions
Autodesk.Revit..::.DWFX2DExportOptions

See Also

DWF2DExportOptions Members
Autodesk.Revit Namespace


DWF2DExportOptions Members

[image] [image]

Revit 2010 API
DWF2DExportOptions Members
DWF2DExportOptions Class Constructors Methods Properties See Also Send Feedback

The DWF2DExportOptions type exposes the following members.

Constructors

Name | Description
DWF2DExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from DWFExportOptions.)
ExportObjectData | Whether to include properties associated with elements. (Inherited from DWFExportOptions.)
ImageFormat | Controls the compression level of images embeded.
ImageQuality | Image quality level when compressed raster format(JPEG) is used.
MergedViews | Whether to merge all views in one file. (Inherited from DWFExportOptions.)
PaperFormat | Standard paper format.
PortraitLayout | Paper orientation - Portrait/Landscape.
StopOnError | Whether export process should stop when a view fails to export. (Inherited from DWFExportOptions.)

See Also

DWF2DExportOptions Class
Autodesk.Revit Namespace


DWF2DExportOptions Constructor

[image]

Revit 2010 API
DWF2DExportOptions Constructor
DWF2DExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DWF2DExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DWF2DExportOptions()

See Also

DWF2DExportOptions Class
Autodesk.Revit Namespace


DWF2DExportOptions Methods

[image] [image]

Revit 2010 API
DWF2DExportOptions Methods
DWF2DExportOptions Class See Also Send Feedback

The DWF2DExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DWF2DExportOptions Class
Autodesk.Revit Namespace


DWF2DExportOptions Properties

[image] [image]

Revit 2010 API
DWF2DExportOptions Properties
DWF2DExportOptions Class See Also Send Feedback

The DWF2DExportOptions type exposes the following members.

Properties

Name | Description
ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from DWFExportOptions.)
ExportObjectData | Whether to include properties associated with elements. (Inherited from DWFExportOptions.)
ImageFormat | Controls the compression level of images embeded.
ImageQuality | Image quality level when compressed raster format(JPEG) is used.
MergedViews | Whether to merge all views in one file. (Inherited from DWFExportOptions.)
PaperFormat | Standard paper format.
PortraitLayout | Paper orientation - Portrait/Landscape.
StopOnError | Whether export process should stop when a view fails to export. (Inherited from DWFExportOptions.)

See Also

DWF2DExportOptions Class
Autodesk.Revit Namespace


ImageFormat Property

[image]

Revit 2010 API
DWF2DExportOptions..::.ImageFormat Property
DWF2DExportOptions Class See Also Send Feedback
Controls the compression level of images embeded.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DWFImageFormat ImageFormat { get; set; }
Visual Basic (Declaration)
Public Property ImageFormat As DWFImageFormat
Visual C++
public:
property DWFImageFormat ImageFormat {
    DWFImageFormat get ();
    void set (DWFImageFormat value);
}

Remarks

ImageQuality is ignored when ImageFormat is set to "PNG"-the standard format.

See Also

DWF2DExportOptions Class
Autodesk.Revit Namespace


ImageQuality Property

[image]

Revit 2010 API
DWF2DExportOptions..::.ImageQuality Property
DWF2DExportOptions Class See Also Send Feedback
Image quality level when compressed raster format(JPEG) is used.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DWFImageQuality ImageQuality { get; set; }
Visual Basic (Declaration)
Public Property ImageQuality As DWFImageQuality
Visual C++
public:
property DWFImageQuality ImageQuality {
    DWFImageQuality get ();
    void set (DWFImageQuality value);
}

Remarks

The default value is Default.

See Also

DWF2DExportOptions Class
Autodesk.Revit Namespace


PaperFormat Property

[image]

Revit 2010 API
DWF2DExportOptions..::.PaperFormat Property
DWF2DExportOptions Class See Also Send Feedback
Standard paper format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ExportPaperFormat PaperFormat { get; set; }
Visual Basic (Declaration)
Public Property PaperFormat As ExportPaperFormat
Visual C++
public:
property ExportPaperFormat PaperFormat {
    ExportPaperFormat get ();
    void set (ExportPaperFormat value);
}

See Also

DWF2DExportOptions Class
Autodesk.Revit Namespace


PortraitLayout Property

[image]

Revit 2010 API
DWF2DExportOptions..::.PortraitLayout Property
DWF2DExportOptions Class See Also Send Feedback
Paper orientation - Portrait/Landscape.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool PortraitLayout { get; set; }
Visual Basic (Declaration)
Public Property PortraitLayout As Boolean
Visual C++
public:
property bool PortraitLayout {
    bool get ();
    void set (bool value);
}

See Also

DWF2DExportOptions Class
Autodesk.Revit Namespace


DWF3DExportOptions Class

[image]

Revit 2010 API
DWF3DExportOptions Class
Members See Also Send Feedback
DWF3D Export options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DWF3DExportOptions : DWFExportOptions
Visual Basic (Declaration)
Public Class DWF3DExportOptions _
    Inherits DWFExportOptions
Visual C++
public ref class DWF3DExportOptions : public DWFExportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.CADExportOptions
Autodesk.Revit..::.DWFExportOptions
Autodesk.Revit..::.DWF3DExportOptions
Autodesk.Revit..::.DWFX3DExportOptions

See Also

DWF3DExportOptions Members
Autodesk.Revit Namespace


DWF3DExportOptions Members

[image] [image]

Revit 2010 API
DWF3DExportOptions Members
DWF3DExportOptions Class Constructors Methods Properties See Also Send Feedback

The DWF3DExportOptions type exposes the following members.

Constructors

Name | Description
DWF3DExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from DWFExportOptions.)
ExportObjectData | Whether to include properties associated with elements. (Inherited from DWFExportOptions.)
MergedViews | Whether to merge all views in one file. (Inherited from DWFExportOptions.)
StopOnError | Whether export process should stop when a view fails to export. (Inherited from DWFExportOptions.)

See Also

DWF3DExportOptions Class
Autodesk.Revit Namespace


DWF3DExportOptions Constructor

[image]

Revit 2010 API
DWF3DExportOptions Constructor
DWF3DExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DWF3DExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DWF3DExportOptions()

See Also

DWF3DExportOptions Class
Autodesk.Revit Namespace


DWF3DExportOptions Methods

[image] [image]

Revit 2010 API
DWF3DExportOptions Methods
DWF3DExportOptions Class See Also Send Feedback

The DWF3DExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DWF3DExportOptions Class
Autodesk.Revit Namespace


DWF3DExportOptions Properties

[image] [image]

Revit 2010 API
DWF3DExportOptions Properties
DWF3DExportOptions Class See Also Send Feedback

The DWF3DExportOptions type exposes the following members.

Properties

Name | Description
ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from DWFExportOptions.)
ExportObjectData | Whether to include properties associated with elements. (Inherited from DWFExportOptions.)
MergedViews | Whether to merge all views in one file. (Inherited from DWFExportOptions.)
StopOnError | Whether export process should stop when a view fails to export. (Inherited from DWFExportOptions.)

See Also

DWF3DExportOptions Class
Autodesk.Revit Namespace


DWFExportOptions Class

[image]

Revit 2010 API
DWFExportOptions Class
Members See Also Send Feedback
DWF Export options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DWFExportOptions : CADExportOptions
Visual Basic (Declaration)
Public Class DWFExportOptions _
    Inherits CADExportOptions
Visual C++
public ref class DWFExportOptions : public CADExportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.CADExportOptions
Autodesk.Revit..::.DWFExportOptions
Autodesk.Revit..::.DWF2DExportOptions
Autodesk.Revit..::.DWF3DExportOptions

See Also

DWFExportOptions Members
Autodesk.Revit Namespace


DWFExportOptions Members

[image] [image]

Revit 2010 API
DWFExportOptions Members
DWFExportOptions Class Constructors Methods Properties See Also Send Feedback

The DWFExportOptions type exposes the following members.

Constructors

Name | Description
DWFExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExportingAreas | Whether to also export areas and rooms' geometry.
ExportObjectData | Whether to include properties associated with elements.
MergedViews | Whether to merge all views in one file.
StopOnError | Whether export process should stop when a view fails to export.

See Also

DWFExportOptions Class
Autodesk.Revit Namespace


DWFExportOptions Constructor

[image]

Revit 2010 API
DWFExportOptions Constructor
DWFExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DWFExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DWFExportOptions()

See Also

DWFExportOptions Class
Autodesk.Revit Namespace


DWFExportOptions Methods

[image] [image]

Revit 2010 API
DWFExportOptions Methods
DWFExportOptions Class See Also Send Feedback

The DWFExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DWFExportOptions Class
Autodesk.Revit Namespace


DWFExportOptions Properties

[image] [image]

Revit 2010 API
DWFExportOptions Properties
DWFExportOptions Class See Also Send Feedback

The DWFExportOptions type exposes the following members.

Properties

Name | Description
ExportingAreas | Whether to also export areas and rooms' geometry.
ExportObjectData | Whether to include properties associated with elements.
MergedViews | Whether to merge all views in one file.
StopOnError | Whether export process should stop when a view fails to export.

See Also

DWFExportOptions Class
Autodesk.Revit Namespace


ExportingAreas Property

[image]

Revit 2010 API
DWFExportOptions..::.ExportingAreas Property
DWFExportOptions Class See Also Send Feedback
Whether to also export areas and rooms' geometry.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool ExportingAreas { get; set; }
Visual Basic (Declaration)
Public Property ExportingAreas As Boolean
Visual C++
public:
property bool ExportingAreas {
    bool get ();
    void set (bool value);
}

See Also

DWFExportOptions Class
Autodesk.Revit Namespace


ExportObjectData Property

[image]

Revit 2010 API
DWFExportOptions..::.ExportObjectData Property
DWFExportOptions Class See Also Send Feedback
Whether to include properties associated with elements.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool ExportObjectData { get; set; }
Visual Basic (Declaration)
Public Property ExportObjectData As Boolean
Visual C++
public:
property bool ExportObjectData {
    bool get ();
    void set (bool value);
}

Remarks

ExportObjectData must be enabled (true) in order to also enable exporting rooms and areas (ExportingAreas). If ExportObjectData is disabled, the ExportingAreas property will be ignored.

See Also

DWFExportOptions Class
Autodesk.Revit Namespace


MergedViews Property

[image]

Revit 2010 API
DWFExportOptions..::.MergedViews Property
DWFExportOptions Class See Also Send Feedback
Whether to merge all views in one file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool MergedViews { get; set; }
Visual Basic (Declaration)
Public Property MergedViews As Boolean
Visual C++
public:
property bool MergedViews {
    bool get ();
    void set (bool value);
}

See Also

DWFExportOptions Class
Autodesk.Revit Namespace


StopOnError Property

[image]

Revit 2010 API
DWFExportOptions..::.StopOnError Property
DWFExportOptions Class See Also Send Feedback
Whether export process should stop when a view fails to export.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool StopOnError { get; set; }
Visual Basic (Declaration)
Public Property StopOnError As Boolean
Visual C++
public:
property bool StopOnError {
    bool get ();
    void set (bool value);
}

Remarks

If set to false, the export would continue until all views are processed. This option has an effect only when a set of more than one view is specified.

See Also

DWFExportOptions Class
Autodesk.Revit Namespace


DWFX2DExportOptions Class

[image]

Revit 2010 API
DWFX2DExportOptions Class
Members See Also Send Feedback
DWFX2D Export options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DWFX2DExportOptions : DWF2DExportOptions
Visual Basic (Declaration)
Public Class DWFX2DExportOptions _
    Inherits DWF2DExportOptions
Visual C++
public ref class DWFX2DExportOptions : public DWF2DExportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.CADExportOptions
Autodesk.Revit..::.DWFExportOptions
Autodesk.Revit..::.DWF2DExportOptions
Autodesk.Revit..::.DWFX2DExportOptions

See Also

DWFX2DExportOptions Members
Autodesk.Revit Namespace


DWFX2DExportOptions Members

[image] [image]

Revit 2010 API
DWFX2DExportOptions Members
DWFX2DExportOptions Class Constructors Methods Properties See Also Send Feedback

The DWFX2DExportOptions type exposes the following members.

Constructors

Name | Description
DWFX2DExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from DWFExportOptions.)
ExportObjectData | Whether to include properties associated with elements. (Inherited from DWFExportOptions.)
ImageFormat | Controls the compression level of images embeded. (Inherited from DWF2DExportOptions.)
ImageQuality | Image quality level when compressed raster format(JPEG) is used. (Inherited from DWF2DExportOptions.)
MergedViews | Whether to merge all views in one file. (Inherited from DWFExportOptions.)
PaperFormat | Standard paper format. (Inherited from DWF2DExportOptions.)
PortraitLayout | Paper orientation - Portrait/Landscape. (Inherited from DWF2DExportOptions.)
StopOnError | Whether export process should stop when a view fails to export. (Inherited from DWFExportOptions.)

See Also

DWFX2DExportOptions Class
Autodesk.Revit Namespace


DWFX2DExportOptions Constructor

[image]

Revit 2010 API
DWFX2DExportOptions Constructor
DWFX2DExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DWFX2DExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DWFX2DExportOptions()

See Also

DWFX2DExportOptions Class
Autodesk.Revit Namespace


DWFX2DExportOptions Methods

[image] [image]

Revit 2010 API
DWFX2DExportOptions Methods
DWFX2DExportOptions Class See Also Send Feedback

The DWFX2DExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DWFX2DExportOptions Class
Autodesk.Revit Namespace


DWFX2DExportOptions Properties

[image] [image]

Revit 2010 API
DWFX2DExportOptions Properties
DWFX2DExportOptions Class See Also Send Feedback

The DWFX2DExportOptions type exposes the following members.

Properties

Name | Description
ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from DWFExportOptions.)
ExportObjectData | Whether to include properties associated with elements. (Inherited from DWFExportOptions.)
ImageFormat | Controls the compression level of images embeded. (Inherited from DWF2DExportOptions.)
ImageQuality | Image quality level when compressed raster format(JPEG) is used. (Inherited from DWF2DExportOptions.)
MergedViews | Whether to merge all views in one file. (Inherited from DWFExportOptions.)
PaperFormat | Standard paper format. (Inherited from DWF2DExportOptions.)
PortraitLayout | Paper orientation - Portrait/Landscape. (Inherited from DWF2DExportOptions.)
StopOnError | Whether export process should stop when a view fails to export. (Inherited from DWFExportOptions.)

See Also

DWFX2DExportOptions Class
Autodesk.Revit Namespace


DWFX3DExportOptions Class

[image]

Revit 2010 API
DWFX3DExportOptions Class
Members See Also Send Feedback
DWFX3D Export options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DWFX3DExportOptions : DWF3DExportOptions
Visual Basic (Declaration)
Public Class DWFX3DExportOptions _
    Inherits DWF3DExportOptions
Visual C++
public ref class DWFX3DExportOptions : public DWF3DExportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.CADExportOptions
Autodesk.Revit..::.DWFExportOptions
Autodesk.Revit..::.DWF3DExportOptions
Autodesk.Revit..::.DWFX3DExportOptions

See Also

DWFX3DExportOptions Members
Autodesk.Revit Namespace


DWFX3DExportOptions Members

[image] [image]

Revit 2010 API
DWFX3DExportOptions Members
DWFX3DExportOptions Class Constructors Methods Properties See Also Send Feedback

The DWFX3DExportOptions type exposes the following members.

Constructors

Name | Description
DWFX3DExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from DWFExportOptions.)
ExportObjectData | Whether to include properties associated with elements. (Inherited from DWFExportOptions.)
MergedViews | Whether to merge all views in one file. (Inherited from DWFExportOptions.)
StopOnError | Whether export process should stop when a view fails to export. (Inherited from DWFExportOptions.)

See Also

DWFX3DExportOptions Class
Autodesk.Revit Namespace


DWFX3DExportOptions Constructor

[image]

Revit 2010 API
DWFX3DExportOptions Constructor
DWFX3DExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DWFX3DExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DWFX3DExportOptions()

See Also

DWFX3DExportOptions Class
Autodesk.Revit Namespace


DWFX3DExportOptions Methods

[image] [image]

Revit 2010 API
DWFX3DExportOptions Methods
DWFX3DExportOptions Class See Also Send Feedback

The DWFX3DExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DWFX3DExportOptions Class
Autodesk.Revit Namespace


DWFX3DExportOptions Properties

[image] [image]

Revit 2010 API
DWFX3DExportOptions Properties
DWFX3DExportOptions Class See Also Send Feedback

The DWFX3DExportOptions type exposes the following members.

Properties

Name | Description
ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from DWFExportOptions.)
ExportObjectData | Whether to include properties associated with elements. (Inherited from DWFExportOptions.)
MergedViews | Whether to merge all views in one file. (Inherited from DWFExportOptions.)
StopOnError | Whether export process should stop when a view fails to export. (Inherited from DWFExportOptions.)

See Also

DWFX3DExportOptions Class
Autodesk.Revit Namespace


DWGExportOptions Class

[image]

Revit 2010 API
DWGExportOptions Class
Members See Also Send Feedback
DWG Export options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DWGExportOptions : ACADExportOptions
Visual Basic (Declaration)
Public Class DWGExportOptions _
    Inherits ACADExportOptions
Visual C++
public ref class DWGExportOptions : public ACADExportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.CADExportOptions
Autodesk.Revit..::.ACADExportOptions
Autodesk.Revit..::.DWGExportOptions

See Also

DWGExportOptions Members
Autodesk.Revit Namespace


DWGExportOptions Members

[image] [image]

Revit 2010 API
DWGExportOptions Members
DWGExportOptions Class Constructors Methods Properties See Also Send Feedback

The DWGExportOptions type exposes the following members.

Constructors

Name | Description
DWGExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from ACADExportOptions.)
ExportOfSolids | Mode of exporting solids in 3D views. (Inherited from ACADExportOptions.)
FileVersion | AutoCAD file version. (Inherited from ACADExportOptions.)
ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views. (Inherited from ACADExportOptions.)
LayerMapping | Name of a layer settings standard or filename (with custom layer settings). (Inherited from ACADExportOptions.)
LineScaling | LineType scaling mode. (Inherited from ACADExportOptions.)
MergedViews | Whether to merge all views in one file (via XRefs).
PropOverrides | How to export overriden object styles. (Inherited from ACADExportOptions.)
SharedCoords | Whether to use shared coordinate system or a project's. internal origin. (Inherited from ACADExportOptions.)
TargetUnit | Type of units in the target CAD format. (Inherited from ACADExportOptions.)

See Also

DWGExportOptions Class
Autodesk.Revit Namespace


DWGExportOptions Constructor

[image]

Revit 2010 API
DWGExportOptions Constructor
DWGExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DWGExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DWGExportOptions()

See Also

DWGExportOptions Class
Autodesk.Revit Namespace


DWGExportOptions Methods

[image] [image]

Revit 2010 API
DWGExportOptions Methods
DWGExportOptions Class See Also Send Feedback

The DWGExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DWGExportOptions Class
Autodesk.Revit Namespace


DWGExportOptions Properties

[image] [image]

Revit 2010 API
DWGExportOptions Properties
DWGExportOptions Class See Also Send Feedback

The DWGExportOptions type exposes the following members.

Properties

Name | Description
ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from ACADExportOptions.)
ExportOfSolids | Mode of exporting solids in 3D views. (Inherited from ACADExportOptions.)
FileVersion | AutoCAD file version. (Inherited from ACADExportOptions.)
ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views. (Inherited from ACADExportOptions.)
LayerMapping | Name of a layer settings standard or filename (with custom layer settings). (Inherited from ACADExportOptions.)
LineScaling | LineType scaling mode. (Inherited from ACADExportOptions.)
MergedViews | Whether to merge all views in one file (via XRefs).
PropOverrides | How to export overriden object styles. (Inherited from ACADExportOptions.)
SharedCoords | Whether to use shared coordinate system or a project's. internal origin. (Inherited from ACADExportOptions.)
TargetUnit | Type of units in the target CAD format. (Inherited from ACADExportOptions.)

See Also

DWGExportOptions Class
Autodesk.Revit Namespace


MergedViews Property

[image]

Revit 2010 API
DWGExportOptions..::.MergedViews Property
DWGExportOptions Class See Also Send Feedback
Whether to merge all views in one file (via XRefs).

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool MergedViews { get; set; }
Visual Basic (Declaration)
Public Property MergedViews As Boolean
Visual C++
public:
property bool MergedViews {
    bool get ();
    void set (bool value);
}

See Also

DWGExportOptions Class
Autodesk.Revit Namespace


DWGImportOptions Class

[image]

Revit 2010 API
DWGImportOptions Class
Members See Also Send Feedback
Import options specific to AutoCAD's DWG file formats.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DWGImportOptions : ACADImportOptions
Visual Basic (Declaration)
Public Class DWGImportOptions _
    Inherits ACADImportOptions
Visual C++
public ref class DWGImportOptions : public ACADImportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.GenericImportOptions
Autodesk.Revit..::.CADImportOptions
Autodesk.Revit..::.ACADImportOptions
Autodesk.Revit..::.DWGImportOptions

See Also

DWGImportOptions Members
Autodesk.Revit Namespace


DWGImportOptions Members

[image] [image]

Revit 2010 API
DWGImportOptions Members
DWGImportOptions Class Constructors Methods Properties See Also Send Feedback

The DWGImportOptions type exposes the following members.

Constructors

Name | Description
DWGImportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColorMode | Color mode for the import. (Inherited from CADImportOptions.)
CustomScale | Scaling the import. (Inherited from CADImportOptions.)
LayerSelection | The layers collection for import. (Inherited from ACADImportOptions.)
LineWeights | A Byte array of line weights for the DWG/DXF Color number. (Inherited from ACADImportOptions.)
OrientToView | Place the import at the same orientation as the current view. (Inherited from CADImportOptions.)
Placement | Where to place the import. (Inherited from CADImportOptions.)
RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only. (Inherited from CADImportOptions.)
Unit | The unit of measure for imported geometry. (Inherited from CADImportOptions.)
View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)
VisibleLayersOnly | Only import the visible layers. (Inherited from ACADImportOptions.)

See Also

DWGImportOptions Class
Autodesk.Revit Namespace


DWGImportOptions Constructor

[image]

Revit 2010 API
DWGImportOptions Constructor
DWGImportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DWGImportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DWGImportOptions()

See Also

DWGImportOptions Class
Autodesk.Revit Namespace


DWGImportOptions Methods

[image] [image]

Revit 2010 API
DWGImportOptions Methods
DWGImportOptions Class See Also Send Feedback

The DWGImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DWGImportOptions Class
Autodesk.Revit Namespace


DWGImportOptions Properties

[image] [image]

Revit 2010 API
DWGImportOptions Properties
DWGImportOptions Class See Also Send Feedback

The DWGImportOptions type exposes the following members.

Properties

Name | Description
ColorMode | Color mode for the import. (Inherited from CADImportOptions.)
CustomScale | Scaling the import. (Inherited from CADImportOptions.)
LayerSelection | The layers collection for import. (Inherited from ACADImportOptions.)
LineWeights | A Byte array of line weights for the DWG/DXF Color number. (Inherited from ACADImportOptions.)
OrientToView | Place the import at the same orientation as the current view. (Inherited from CADImportOptions.)
Placement | Where to place the import. (Inherited from CADImportOptions.)
RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only. (Inherited from CADImportOptions.)
Unit | The unit of measure for imported geometry. (Inherited from CADImportOptions.)
View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)
VisibleLayersOnly | Only import the visible layers. (Inherited from ACADImportOptions.)

See Also

DWGImportOptions Class
Autodesk.Revit Namespace


Element Class

[image]

Revit 2010 API
Element Class
Members See Also Send Feedback
Supports all classes that are persistent within the Autodesk Revit project providing low-level services to derived classes.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Element : APIObject
Visual Basic (Declaration)
Public Class Element _
    Inherits APIObject
Visual C++
public ref class Element : public APIObject

Remarks

The Element object is base class for all elements that can persist inside the Autodesk Revit project database. Element objects can be retrieved from the Document.Element or Document.Elements properties.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Areas..::.AreaScheme
Autodesk.Revit.Elements..::.Alignment
Autodesk.Revit.Elements..::.AnnotationSymbol
Autodesk.Revit.Elements..::.Area
Autodesk.Revit.Elements..::.AreaReinforcement
Autodesk.Revit.Elements..::.AreaReinforcementCurve
Autodesk.Revit.Elements..::.AreaTag
Autodesk.Revit.Elements..::.BaseArray
Autodesk.Revit.Elements..::.BasePoint
Autodesk.Revit.Elements..::.BeamSystem
Autodesk.Revit.Elements..::.BoundaryConditions
Autodesk.Revit.Elements..::.CombinableElement
Autodesk.Revit.Elements..::.Control
Autodesk.Revit.Elements..::.CurveElement
Autodesk.Revit.Elements..::.DesignOption
Autodesk.Revit.Elements..::.Dimension
Autodesk.Revit.Elements..::.DividedSurface
Autodesk.Revit.Elements..::.FamilyBase
Autodesk.Revit.Elements..::.FillPattern
Autodesk.Revit.Elements..::.gbXMLParamElem
Autodesk.Revit.Elements..::.GraphicsStyle
Autodesk.Revit.Elements..::.Grid
Autodesk.Revit.Elements..::.Group
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.ImportInstance
Autodesk.Revit.Elements..::.IndependentTag
Autodesk.Revit.Elements..::.Instance
Autodesk.Revit.Elements..::.Level
Autodesk.Revit.Elements..::.LinePattern
Autodesk.Revit.Elements..::.LoadBase
Autodesk.Revit.Elements..::.LoadCase
Autodesk.Revit.Elements..::.LoadCombination
Autodesk.Revit.Elements..::.LoadNature
Autodesk.Revit.Elements..::.LoadUsage
Autodesk.Revit.Elements..::.Material
Autodesk.Revit.Elements..::.ModelText
Autodesk.Revit.Elements..::.Mullion
Autodesk.Revit.Elements..::.Opening
Autodesk.Revit.Elements..::.Panel
Autodesk.Revit.Elements..::.PathReinforcement
Autodesk.Revit.Elements..::.Phase
Autodesk.Revit.Elements..::.PrintSetting
Autodesk.Revit.Elements..::.ProjectInfo
Autodesk.Revit.Elements..::.ProjectUnit
Autodesk.Revit.Elements..::.PropertyLine
Autodesk.Revit.Elements..::.Rebar
Autodesk.Revit.Elements..::.ReferencePlane
Autodesk.Revit.Elements..::.ReferencePoint
Autodesk.Revit.Elements..::.Room
Autodesk.Revit.Elements..::.RoomTag
Autodesk.Revit.Elements..::.SketchBase
Autodesk.Revit.Elements..::.SketchPlane
Autodesk.Revit.Elements..::.Space
Autodesk.Revit.Elements..::.SpaceTag
Autodesk.Revit.Elements..::.TextElement
Autodesk.Revit.Elements..::.TopographySurface
Autodesk.Revit.Elements..::.Truss
Autodesk.Revit.Elements..::.View
Autodesk.Revit.Elements..::.ViewSheetSet
Autodesk.Revit.Elements..::.Zone
Autodesk.Revit.MEP..::.ConduitType
Autodesk.Revit.MEP..::.DuctConnector
Autodesk.Revit.MEP..::.ElectricalConnector
Autodesk.Revit.MEP..::.InsulationType
Autodesk.Revit.MEP..::.MEPSystem
Autodesk.Revit.MEP..::.PipeConnector
Autodesk.Revit.MEP..::.TemperatureRatingType
Autodesk.Revit.MEP..::.WireMaterialType
Autodesk.Revit..::.Symbol

See Also

Element Members
Autodesk.Revit Namespace


Element Members

[image] [image]

Revit 2010 API
Element Members
Element Class Constructors Methods Properties See Also Send Feedback

The Element type exposes the following members.

Constructors

Name | Description
Element | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element.
GetMaterialVolume | Get the volume of the given material on this element.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element.
Category | Retrieves a Category object that represents the category or sub category in which the element resides.
DesignOption | Returns the design option to which the element belongs.
Document | Returns the Document in which the Element resides.
Geometry | Retrieves the geometric representation of the element.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned.
Location | This property is used to find the physical location of an element within a project.
Materials | Get all materials present in the element.
Name | Returns a human readable name for the Element.
ObjectType | Returns the instance type of this object.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element.
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element.
PhaseCreated | An object representing the phase when the element is created.
PhaseDemolished | An object representing the phase for when the element is to be demolished.
Pinned | Identifies if the element has been pinned to prevent changes.
SimilarObjectTypes | Returns the types being similar to the current instance.
UniqueId | A stable unique identifier for an element within the document.

See Also

Element Class
Autodesk.Revit Namespace


Element Constructor

[image]

Revit 2010 API
Element Constructor
Element Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Element()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Element Class
Autodesk.Revit Namespace


Element Methods

[image] [image]

Revit 2010 API
Element Methods
Element Class See Also Send Feedback

The Element type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element.
GetMaterialVolume | Get the volume of the given material on this element.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Element Class
Autodesk.Revit Namespace


CanBeHidden Method

[image]

Revit 2010 API
Element..::.CanBeHidden Method
Element Class See Also Send Feedback
Indicates if the element can be hidden in the view.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool CanBeHidden(
    View pView
)
Visual Basic (Declaration)
Public Function CanBeHidden ( _
    pView As View _
) As Boolean
Visual C++
public:
bool CanBeHidden(
    View^ pView
)

Parameters

pView
Type: Autodesk.Revit.Elements..::.View

Return Value

If the element is not permitted to be hidden, false is returned.

Remarks

See discussion for some types of elements which may not be hidden.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when argument is null.

See Also

Element Class
Autodesk.Revit Namespace


GetDividedSurfaceData Method

[image]

Revit 2010 API
Element..::.GetDividedSurfaceData Method
Element Class See Also Send Feedback
Get an interface to the divided surfaces on this element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DividedSurfaceData GetDividedSurfaceData()
Visual Basic (Declaration)
Public Function GetDividedSurfaceData As DividedSurfaceData
Visual C++
public:
DividedSurfaceData^ GetDividedSurfaceData()

Return Value

An object that can be used to find information about this element's divided surfaces. Divided surfaces are only supported in Conceptual Massing families; outside of that environment, this method returns null.

Remarks

Divided surfaces are supported on the following element types: Form, GeomCombination, FamilyInstance, and ImportInstance.

See Also

Element Class
Autodesk.Revit Namespace


GetMaterialArea Method

[image]

Revit 2010 API
Element..::.GetMaterialArea Method
Element Class See Also Send Feedback
Get the area of the given material on this element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double GetMaterialArea(
    Material material
)
Visual Basic (Declaration)
Public Function GetMaterialArea ( _
    material As Material _
) As Double
Visual C++
public:
double GetMaterialArea(
    Material^ material
)

Parameters

material
Type: Autodesk.Revit.Elements..::.Material

Return Value

The area, or 0.0 if the input material is not a member of Materials.

Remarks

This value is calculated by Revit to show in material takeoff schedules. In some cases the value may be approximate.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The input material was null.
System..::.ArgumentException | The material comes from a different document than this element.

See Also

Element Class
Autodesk.Revit Namespace


GetMaterialVolume Method

[image]

Revit 2010 API
Element..::.GetMaterialVolume Method
Element Class See Also Send Feedback
Get the volume of the given material on this element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double GetMaterialVolume(
    Material material
)
Visual Basic (Declaration)
Public Function GetMaterialVolume ( _
    material As Material _
) As Double
Visual C++
public:
double GetMaterialVolume(
    Material^ material
)

Parameters

material
Type: Autodesk.Revit.Elements..::.Material

Return Value

The volume, or 0.0 if the input material is not a member of Materials.

Remarks

This value is calculated by Revit to show in material takeoff schedules. In some cases the value may be approximate.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The input material was null.
System..::.ArgumentException | The material comes from a different document than this element.

See Also

Element Class
Autodesk.Revit Namespace


IsHidden Method

[image]

Revit 2010 API
Element..::.IsHidden Method
Element Class See Also Send Feedback
Identifies if the element has been permanently hidden in the view.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsHidden(
    View pView
)
Visual Basic (Declaration)
Public Function IsHidden ( _
    pView As View _
) As Boolean
Visual C++
public:
bool IsHidden(
    View^ pView
)

Parameters

pView
Type: Autodesk.Revit.Elements..::.View

Remarks

This does not determine if the element is hidden as a result of temporary hide/isolate, view sectioning, view crop box, or other operations that can cause elements not to be visible. To hide or unhide an element, use the Hide() and Unhide() method of View.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when argument is null.

See Also

Element Class
Autodesk.Revit Namespace


Element Properties

[image] [image]

Revit 2010 API
Element Properties
Element Class See Also Send Feedback

The Element type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element.
Category | Retrieves a Category object that represents the category or sub category in which the element resides.
DesignOption | Returns the design option to which the element belongs.
Document | Returns the Document in which the Element resides.
Geometry | Retrieves the geometric representation of the element.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned.
Location | This property is used to find the physical location of an element within a project.
Materials | Get all materials present in the element.
Name | Returns a human readable name for the Element.
ObjectType | Returns the instance type of this object.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element.
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element.
PhaseCreated | An object representing the phase when the element is created.
PhaseDemolished | An object representing the phase for when the element is to be demolished.
Pinned | Identifies if the element has been pinned to prevent changes.
SimilarObjectTypes | Returns the types being similar to the current instance.
UniqueId | A stable unique identifier for an element within the document.

See Also

Element Class
Autodesk.Revit Namespace


BoundingBox Property

[image]

Revit 2010 API
Element..::.BoundingBox Property
Element Class Example See Also Send Feedback
Retrieves a box that circumscribes all geometry of the element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundingBoxXYZ BoundingBox[
    View
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property BoundingBox ( _
     As View _
) As BoundingBoxXYZ
Visual C++
public:
property BoundingBoxXYZ^ BoundingBox[View^ ] {
    BoundingBoxXYZ^ get (View^ );
}

Parameters

Type: Autodesk.Revit.Elements..::.View

Remarks

Pass in a view to query view-specific (e.g., cut) geometry or null for model geometry. If view box is not known, will return model box; if model box is not known, will return null.

Examples

CopyC#
private void GetElementBoundingBox(Autodesk.Revit.Document document, Autodesk.Revit.Element element)
{
    // Get the BoundingBox instance for current view.
    BoundingBoxXYZ box = element.get_BoundingBox(document.ActiveView);
    if (null == box)
    {
        throw new Exception("Selected element doesn't contain a bounding box.");
    }

    string info = "Bounding box is enabled: " + box.Enabled.ToString();

    // Give the user some information.
    MessageBox.Show(info, "Revit");
}
CopyVB.NET
Private Sub GetElementBoundingBox(ByVal document As Autodesk.Revit.Document, ByVal element As Autodesk.Revit.Element)
    ' Get the BoundingBox instance for current view.
    Dim box As BoundingBoxXYZ = element.BoundingBox(document.ActiveView)
    If box Is Nothing Then
        Throw New Exception("Selected element doesn't contain a bounding box.")
    End If

    Dim info As String = "Bounding box is enabled: " & box.Enabled.ToString()

    ' Give the user some information.
    MessageBox.Show(info, "Revit")
End Sub

See Also

Element Class
Autodesk.Revit Namespace


Category Property

[image]

Revit 2010 API
Element..::.Category Property
Element Class See Also Send Feedback
Retrieves a Category object that represents the category or sub category in which the element resides.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Category Category { get; }
Visual Basic (Declaration)
Public ReadOnly Property Category As Category
Visual C++
public:
property Category^ Category {
    Category^ get ();
}

Remarks

All category objects can be retrieved from the application by using the Categories property of the Application.Settings object.

See Also

Element Class
Autodesk.Revit Namespace


DesignOption Property

[image]

Revit 2010 API
Element..::.DesignOption Property
Element Class Example See Also Send Feedback
Returns the design option to which the element belongs.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DesignOption DesignOption { get; }
Visual Basic (Declaration)
Public ReadOnly Property DesignOption As DesignOption
Visual C++
public:
property DesignOption^ DesignOption {
    DesignOption^ get ();
}

Remarks

If the element is not in a design option, i.e. in the main model, then this property will return Nothing.

Examples

CopyC#
void Getinfo_DesignOption(Document document)
{
    // Get the selected Elements in the Active Document
    ElementSet selection = document.Selection.Elements;

    foreach (Autodesk.Revit.Element element in selection)
    {
        //Use the DesignOption property of Element
        if (element.DesignOption != null)
        {
            MessageBox.Show(element.DesignOption.Name.ToString());
        }
    }
}
CopyVB.NET
Private Sub Getinfo_DesignOption(ByVal document As Document)
    ' Get the selected Elements in the Active Document
    Dim selection As ElementSet = document.Selection.Elements

    For Each element As Autodesk.Revit.Element In selection
        'Use the DesignOption property of Element
        If element.DesignOption IsNot Nothing Then
            MessageBox.Show(element.DesignOption.Name.ToString())
        End If
    Next
End Sub

See Also

Element Class
Autodesk.Revit Namespace


Document Property

[image]

Revit 2010 API
Element..::.Document Property
Element Class See Also Send Feedback
Returns the Document in which the Element resides.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

Remarks

All elements are contained within a document. An element can be retrieved from this document by using the id that is returned by the element's id property.

See Also

Element Class
Autodesk.Revit Namespace


Geometry Property

[image]

Revit 2010 API
Element..::.Geometry Property
Element Class Example See Also Send Feedback
Retrieves the geometric representation of the element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element Geometry[
    Options options
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Geometry ( _
    options As Options _
) As Element
Visual C++
public:
property Element^ Geometry[Options^ options] {
    Element^ get (Options^ options);
}

Parameters

options
Type: Autodesk.Revit.Geometry..::.Options
User preferences for parsing of geometry.

Field Value

An element that provides access to the geometry of the element.

Remarks

This call will retrieve 3d representation of the element. Nothing will be returned for symbols, annotations or details. This involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical.

Geometry objects provided from this method are obtained directly from the element. When the element is changed for any reason, the geometry will be recalculated by Revit and geometry objects obtained before the change are likely to no longer be valid. If you need to preserve geometry information obtained an element even after changes to that element, you should copy the geometry objects or save the properties independently.

If you require that the geometry items obtained contain valid Reference objects, be sure to set the CalculateReferences property of the options.

Examples

CopyC#
public void GetCurvesFromABeam(Autodesk.Revit.Elements.FamilyInstance beam,
                               Autodesk.Revit.Geometry.Options options)
{
    Autodesk.Revit.Geometry.Element geomElem = beam.get_Geometry(options);

    Autodesk.Revit.Geometry.CurveArray curves = new CurveArray();
    Autodesk.Revit.Geometry.SolidArray solids = new SolidArray();

    //Find all solids and insert them into solid array
    AddCurvesAndSolids(geomElem, ref curves, ref solids);
}

private void AddCurvesAndSolids(Autodesk.Revit.Geometry.Element geomElem,
                                ref Autodesk.Revit.Geometry.CurveArray curves,
                                ref Autodesk.Revit.Geometry.SolidArray solids)
{
    foreach (Autodesk.Revit.Geometry.GeometryObject geomObj in geomElem.Objects)
    {
        Autodesk.Revit.Geometry.Curve curve = geomObj as Autodesk.Revit.Geometry.Curve;
        if (null != curve)
        {
            curves.Append(curve);
            continue;
        }
        Autodesk.Revit.Geometry.Solid solid = geomObj as Autodesk.Revit.Geometry.Solid;
        if (null != solid)
        {
            solids.Append(solid);
            continue;
        }
        //If this GeometryObject is Instance, call AddCurvesAndSolids
        Autodesk.Revit.Geometry.Instance geomInst = geomObj as Autodesk.Revit.Geometry.Instance;
        if (null != geomInst)
        {
            Autodesk.Revit.Geometry.Element transformedGeomElem
              = geomInst.GetInstanceGeometry(geomInst.Transform);
            AddCurvesAndSolids(transformedGeomElem, ref curves, ref solids);
        }
    }
}
CopyVB.NET
Public Sub GetCurvesFromABeam(ByVal beam As Autodesk.Revit.Elements.FamilyInstance, ByVal options As Autodesk.Revit.Geometry.Options)
    Dim geomElem As Autodesk.Revit.Geometry.Element = beam.Geometry(options)

    Dim curves As Autodesk.Revit.Geometry.CurveArray = New CurveArray()
    Dim solids As Autodesk.Revit.Geometry.SolidArray = New SolidArray()

    'Find all solids and insert them into solid array
    AddCurvesAndSolids(geomElem, curves, solids)
End Sub

Private Sub AddCurvesAndSolids(ByVal geomElem As Autodesk.Revit.Geometry.Element, ByRef curves As Autodesk.Revit.Geometry.CurveArray, ByRef solids As Autodesk.Revit.Geometry.SolidArray)
    For Each geomObj As Autodesk.Revit.Geometry.GeometryObject In geomElem.Objects
        Dim curve As Autodesk.Revit.Geometry.Curve = TryCast(geomObj, Autodesk.Revit.Geometry.Curve)
        If curve IsNot Nothing Then
            curves.Append(curve)
            Continue For
        End If
        Dim solid As Autodesk.Revit.Geometry.Solid = TryCast(geomObj, Autodesk.Revit.Geometry.Solid)
        If solid IsNot Nothing Then
            solids.Append(solid)
            Continue For
        End If
        'If this GeometryObject is Instance, call AddCurvesAndSolids
        Dim geomInst As Autodesk.Revit.Geometry.Instance = TryCast(geomObj, Autodesk.Revit.Geometry.Instance)
        If geomInst IsNot Nothing Then
            Dim transformedGeomElem As Autodesk.Revit.Geometry.Element = geomInst.GetInstanceGeometry(geomInst.Transform)
            AddCurvesAndSolids(transformedGeomElem, curves, solids)
        End If
    Next
End Sub

See Also

Element Class
Autodesk.Revit Namespace


Group Property

[image]

Revit 2010 API
Element..::.Group Property
Element Class Example See Also Send Feedback
Return to group to which an element belongs. If it is not in a group then this will return Nothing.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Group Group { get; }
Visual Basic (Declaration)
Public ReadOnly Property Group As Group
Visual C++
public:
property Group^ Group {
    Group^ get ();
}

Examples

CopyC#
private void ShowGroupInformation(Autodesk.Revit.Document document, Autodesk.Revit.Element element)
{
    // Get group information for the selected element
    String prompt = null;
    Autodesk.Revit.Elements.Group group = element.Group;
    if (null == group)
    {
        prompt = "The element isn't in any group.";
    }
    else
    {
        prompt = "The element " + element.Id.Value + " is in a group.";
        prompt += "\nThe group id is " + group.Id.Value;
        prompt += "\nThe group's category is " + group.Category.Name;
        prompt += "\nAll group contained element ids are:";
        Autodesk.Revit.ElementArray groupMembers = group.Members;
        foreach (Autodesk.Revit.Element e in groupMembers)
        {
            prompt += "\n\t" + e.Id.Value;
        }
    }

    MessageBox.Show(prompt);
}
CopyVB.NET
Private Sub ShowGroupInformation(ByVal document As Autodesk.Revit.Document, ByVal element As Autodesk.Revit.Element)
    ' Get group information for the selected element
    Dim prompt As String = Nothing
    Dim group As Autodesk.Revit.Elements.Group = element.Group
    If group Is Nothing Then
        prompt = "The element isn't in any group."
    Else
        prompt = "The element " & element.Id.Value & " is in a group."
        prompt += vbLf & "The group id is " & group.Id.Value
        prompt += vbLf & "The group's category is " & group.Category.Name
        prompt += vbLf & "All group contained element ids are:"
        Dim groupMembers As Autodesk.Revit.ElementArray = group.Members
        For Each e As Autodesk.Revit.Element In groupMembers
            prompt += vbLf & vbTab & e.Id.Value
        Next
    End If

    MessageBox.Show(prompt)
End Sub

See Also

Element Class
Autodesk.Revit Namespace


Id Property

[image]

Revit 2010 API
Element..::.Id Property
Element Class Example See Also Send Feedback
Provides a way of uniquely identifying an Element within an Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementId Id { get; }
Visual Basic (Declaration)
Public ReadOnly Property Id As ElementId
Visual C++
public:
property ElementId Id {
    ElementId get ();
}

Remarks

Returns an ElementId object containing the project wide unique identifier for this Element. The identifier with the ElementId is only unique for the project, it is not unique across separate Autodesk Revit projects.

Examples

CopyC#
private void CheckElementId(Autodesk.Revit.Document document, Autodesk.Revit.Element element)
{
    // Get the id of the element
    ElementId selectedId = element.Id;
    int idInteger = selectedId.Value;

    // create a new id and set the value
    ElementId id = new ElementId();
    id.Value = idInteger;

    // Get the element
    Autodesk.Revit.Element first = document.get_Element(ref id);

    // And get the element using the original Id (they should be the same)
    Autodesk.Revit.Element second = document.get_Element(ref selectedId);

    String prompt = "Get an element twice. They should be the same element.";
    // Use the Equal method to check two elements. It is not a good way.
    bool isSame = first.Equals(second);
    prompt += "\nUsing Equal method on elements, the result is: " + isSame;
    isSame = first.Id.Equals(second.Id);
    prompt += "\nUsing Equal method on element's Id properties, the result is: " + isSame;

    MessageBox.Show(prompt);
}
CopyVB.NET
Private Sub CheckElementId(ByVal document As Autodesk.Revit.Document, ByVal element As Autodesk.Revit.Element)
    ' Get the id of the element
    Dim selectedId As Autodesk.Revit.ElementId = element.Id
    Dim idInteger As Integer = selectedId.Value

    ' create a new id and set the value
    Dim id As New Autodesk.Revit.ElementId()
    id.Value = idInteger

    ' Get the element
    Dim first As Autodesk.Revit.Element = document.Element(id)

    ' And get the element using the original Id (they should be the same)
    Dim second As Autodesk.Revit.Element = document.Element(selectedId)

    Dim prompt As String = "Get an element twice. They should be the same element."
    ' Use the Equal method to check two elements. It is not a good way.
    Dim isSame As Boolean = first.Equals(second)
    prompt += vbLf & "Using Equal method on elements, the result is: " & isSame
    isSame = first.Id.Equals(second.Id)
    prompt += vbLf & "Using Equal method on element's Id properties, the result is: " & isSame

    MessageBox.Show(prompt)
End Sub

See Also

Element Class
Autodesk.Revit Namespace


Level Property

[image]

Revit 2010 API
Element..::.Level Property
Element Class Example See Also Send Feedback
If the element is level based then level to which the element is assigned is returned.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Level Level { get; }
Visual Basic (Declaration)
Public ReadOnly Property Level As Level
Visual C++
public:
property Level^ Level {
    Level^ get ();
}

Remarks

A number of elements use a level as a base reference, such as a column.

Examples

CopyC#
private void GetLevelInformation(Autodesk.Revit.Element element)
{
    // Get the level object to which the element is assigned.
    Level level = element.Level;
    if (null == level)
    {
        MessageBox.Show("The element isn't based on a level.", "Revit");
    }
    else
    {
        // Format the prompt information(Name and elevation)
        String prompt = "The element is based on a level.";
        prompt += "\nThe level name is:  " + level.Name;
        prompt += "\nThe level elevation is:  " + level.Elevation;

        // Show the information to the user.
        MessageBox.Show(prompt, "Revit");
    }
}
CopyVB.NET
Private Sub GetLevelInformation(ByVal element As Autodesk.Revit.Element)
    ' Get the level object to which the element is assigned.
    Dim level As Autodesk.Revit.Elements.Level = element.Level
    If level Is Nothing Then
        MessageBox.Show("The element isn't based on a level.", "Revit")
    Else
        ' Format the prompt information(Name and elevation)
        Dim prompt As String = "The element is based on a level."
        prompt += vbLf & "The level name is: " & level.Name
        prompt += vbLf & "The level elevation is: " & level.Elevation

        ' Show the information to the user.
        MessageBox.Show(prompt, "Revit")
    End If
End Sub

See Also

Element Class
Autodesk.Revit Namespace


Location Property

[image]

Revit 2010 API
Element..::.Location Property
Element Class Example See Also Send Feedback
This property is used to find the physical location of an element within a project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Location Location { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get ();
}

Remarks

The Location property returns an object that can be used to find the location of an object within the project. An object may have a point location, such as a table or may have a line location. A wall is an example of an element that has a line location.

Examples

CopyC#
void GetLocationInformation(Autodesk.Revit.Element element)
{
    // Get the Location property and judge whether it exists
    Autodesk.Revit.Location position = element.Location;

    String prompt = null;
    if (null == position)
    {
        prompt = "No location can be found in element.";
    }
    else
    {
        // If the location is a point location, give the user information
        Autodesk.Revit.LocationPoint positionPoint = position as Autodesk.Revit.LocationPoint;
        if (null != positionPoint)
        {
            prompt = "Element has a point location.";
        }
        else
        {

            // If the location is a curve location, give the user information
            Autodesk.Revit.LocationCurve positionCurve = position as Autodesk.Revit.LocationCurve;
            if (null != positionCurve)
            {
                prompt = "Element has a curve location.";
            }
        }
    }

    if (null != prompt)
    {
        MessageBox.Show(prompt, "Revit");
    }
}
CopyVB.NET
Private Sub GetLocationInformation(ByVal element As Autodesk.Revit.Element)
    ' Get the Location property and judge whether it exists
    Dim position As Autodesk.Revit.Location = element.Location

    Dim prompt As String = Nothing
    If position Is Nothing Then
        prompt = "No location can be found in element."
    Else
        ' If the location is a point location, give the user information
        Dim positionPoint As Autodesk.Revit.LocationPoint = TryCast(position, Autodesk.Revit.LocationPoint)
        If positionPoint IsNot Nothing Then
            prompt = "Element has a point location."
        Else

            ' If the location is a curve location, give the user information
            Dim positionCurve As Autodesk.Revit.LocationCurve = TryCast(position, Autodesk.Revit.LocationCurve)
            If positionCurve IsNot Nothing Then
                prompt = "Element has a curve location."
            End If
        End If
    End If

    If prompt IsNot Nothing Then
        MessageBox.Show(prompt, "Revit")
    End If
End Sub

See Also

Element Class
Autodesk.Revit Namespace


Materials Property

[image]

Revit 2010 API
Element..::.Materials Property
Element Class See Also Send Feedback
Get all materials present in the element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialSet Materials { get; }
Visual Basic (Declaration)
Public ReadOnly Property Materials As MaterialSet
Visual C++
public:
property MaterialSet^ Materials {
    MaterialSet^ get ();
}

Remarks

The set will be empty for elements where the HasMaterialQuantities property of the element's Category is false. The set will also be empty for elements whose category supports material quantities (the HasMaterialQuantities property of the element's Category is true), but where the element has not been assigned materials.

See Also

Element Class
Autodesk.Revit Namespace


Name Property

[image]

Revit 2010 API
Element..::.Name Property
Element Class See Also Send Feedback
Returns a human readable name for the Element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual string Name { get; set; }
Visual Basic (Declaration)
Public Overridable Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Element Class
Autodesk.Revit Namespace


ObjectType Property

[image]

Revit 2010 API
Element..::.ObjectType Property
Element Class Example See Also Send Feedback
Returns the instance type of this object.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Symbol ObjectType { get; set; }
Visual Basic (Declaration)
Public Property ObjectType As Symbol
Visual C++
public:
property Symbol^ ObjectType {
    Symbol^ get ();
    void set (Symbol^ value);
}

Remarks

The type of the object returned by this method depends upon the type of this instance, for example - if this object is a wall then a wall type object will be returned. Not all objects have an instance type in which case Nothing is returned.

Examples

CopyC#
void GetStairType(Autodesk.Revit.Document document)
{
    // Create a Filter to get all the stairs in the document
    Autodesk.Revit.Creation.Filter filterCreator = document.Application.Create.Filter;
    // Stairs are type Element, so we don't need to include derived types
    TypeFilter elementOnlyFilter = filterCreator.NewTypeFilter(typeof(Element), false);
    CategoryFilter stairsCategoryfilter = filterCreator.NewCategoryFilter(BuiltInCategory.OST_Stairs);
    Filter stairsFilter = filterCreator.NewLogicAndFilter(elementOnlyFilter, stairsCategoryfilter);

    // Apply the filter to the elements in the active document
    ElementIterator iterator = document.get_Elements(stairsFilter);

    iterator.Reset();
    while (iterator.MoveNext())
    {
        Element stair = iterator.Current as Element;

        if (null == stair.ObjectType)
        {
            MessageBox.Show("No symbol found in stair element: " + stair.Name, "Revit");
        }
        else
        {
            string info = "Stair type is: " + stair.ObjectType.Name;
            MessageBox.Show(info, "Revit");
        }
    }
}
CopyVB.NET
Private Sub GetStairType(ByVal document As Autodesk.Revit.Document)
    ' Create a Filter to get all the stairs in the document
    Dim filterCreator As Autodesk.Revit.Creation.Filter = document.Application.Create.Filter
    ' Stairs are type Element, so we don't need to include derived types
    Dim elementOnlyFilter As TypeFilter = filterCreator.NewTypeFilter(GetType(Autodesk.Revit.Element), False)
    Dim stairsCategoryfilter As CategoryFilter = filterCreator.NewCategoryFilter(BuiltInCategory.OST_Stairs)
    Dim stairsFilter As Filter = filterCreator.NewLogicAndFilter(elementOnlyFilter, stairsCategoryfilter)

    ' Apply the filter to the elements in the active document
    Dim iterator As ElementIterator = document.Elements(stairsFilter)

    iterator.Reset()
    While iterator.MoveNext()
        Dim stair As Autodesk.Revit.Element = TryCast(iterator.Current, Autodesk.Revit.Element)

        If stair.ObjectType Is Nothing Then
            MessageBox.Show("No symbol found in stair element: " & stair.Name, "Revit")
        Else
            Dim info As String = "Stair type is: " & stair.ObjectType.Name
            MessageBox.Show(info, "Revit")
        End If
    End While
End Sub

See Also

Element Class
Autodesk.Revit Namespace


Parameter Property

[image] [image]

Revit 2010 API
Element..::.Parameter Property
Element Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id.
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition.
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter.
Parameter[([(String])]) | Retrieves a parameter from the element given its name.

See Also

Element Class
Element Members
Autodesk.Revit Namespace


Parameter Property (BuiltInParameter)

[image]

Revit 2010 API
Element..::.Parameter Property (BuiltInParameter)
Element Class Example See Also Send Feedback
Retrieves a parameter from the element given a parameter id.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Parameter Parameter[
    BuiltInParameter parameterId
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    parameterId As BuiltInParameter _
) As Parameter
Visual C++
public:
property Parameter^ Parameter[BuiltInParameter parameterId] {
    Parameter^ get (BuiltInParameter parameterId);
}

Parameters

parameterId
Type: Autodesk.Revit.Parameters..::.BuiltInParameter
The built in parameter id of the parameter to be retrieved.

Remarks

Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. This method uses a built in parameter id to access the parameter. Autodesk Revit has a large number of built in parameters that are available via an enumerated type.

Examples

CopyC#
public Parameter FindWithBuiltinParameterID(Wall wall)
{
    //Use the WALL_BASE_OFFSET paramametId
    // to get the base offset parameter of the wall.
    BuiltInParameter paraIndex = BuiltInParameter.WALL_BASE_OFFSET;
    Parameter parameter = wall.get_Parameter(paraIndex);

    return parameter;
}
CopyVB.NET
Public Function FindWithBuiltinParameterID(ByVal wall As Wall) As Parameter
    'Use the WALL_BASE_OFFSET paramametId
    ' to get the base offset parameter of the wall.
    Dim paraIndex As BuiltInParameter = BuiltInParameter.WALL_BASE_OFFSET
    Dim parameter As Parameter = wall.Parameter(paraIndex)

    Return parameter
End Function

See Also

Element Class
Parameter Overload
Autodesk.Revit Namespace


Parameter Property (Definition)

[image]

Revit 2010 API
Element..::.Parameter Property (Definition)
Element Class See Also Send Feedback
Retrieves a parameter from the element based on its definition.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Parameter Parameter[
    Definition definition
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    definition As Definition _
) As Parameter
Visual C++
public:
property Parameter^ Parameter[Definition^ definition] {
    Parameter^ get (Definition^ definition);
}

Parameters

definition
Type: Autodesk.Revit.Parameters..::.Definition
The internal or external definition of the parameter.

Remarks

Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. An element can only have one instance of a parameter with a specific definition. By using this method you can retrieve that parameter based on definition.

See Also

Element Class
Parameter Overload
Autodesk.Revit Namespace


Parameter Property (Guid)

[image]

Revit 2010 API
Element..::.Parameter Property (Guid)
Element Class See Also Send Feedback
Retrieves a parameter from the element given a GUID for a shared parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Parameter Parameter[
    Guid guid
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    guid As Guid _
) As Parameter
Visual C++
public:
property Parameter^ Parameter[Guid guid] {
    Parameter^ get (Guid guid);
}

Parameters

guid
Type: System..::.Guid
The unique id associated with the shared parameter.

Remarks

Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. This method is used to retrieve a parameter for a known shared parameter. When a shared parameter is created it is assigned a Guid which will not change. This guid can be used to retrieve the piece of data from the element at a later time.

See Also

Element Class
Parameter Overload
Autodesk.Revit Namespace


Parameter Property (String)

[image]

Revit 2010 API
Element..::.Parameter Property (String)
Element Class See Also Send Feedback
Retrieves a parameter from the element given its name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Parameter Parameter[
    string paramName
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    paramName As String _
) As Parameter
Visual C++
public:
property Parameter^ Parameter[String^ paramName] {
    Parameter^ get (String^ paramName);
}

Parameters

paramName
Type: System..::.String
The name of the parameter to be retrieved.

See Also

Element Class
Parameter Overload
Autodesk.Revit Namespace


Parameters Property

[image]

Revit 2010 API
Element..::.Parameters Property
Element Class Example See Also Send Feedback
Retrieves a set containing all of the parameters that are contained within the element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterSet Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterSet
Visual C++
public:
property ParameterSet^ Parameters {
    ParameterSet^ get ();
}

Remarks

The Parameters property contains a set of all the parameters that the element supports. These parameters are displayed in the Element properties dialog in the Autodesk Revit interface. These parameters can be retrieved and set via the parameter objects stored in this set.

Examples

CopyC#
void GetElementParameterInformation(Document document, Element element)
{
    // Format the prompt information string
    String prompt = "Show parameters in selected Element:";

    StringBuilder st = new StringBuilder();
    // iterate element's parameters
    foreach (Parameter para in element.Parameters)
    {
        st.AppendLine(GetParameterInformation(para, document));
    }

    // Give the user some information
    MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);
}

String GetParameterInformation(Parameter para, Document document)
{
    string defName = para.Definition.Name + @"\t";
    // Use different method to get parameter data according to the storage type
    switch (para.StorageType)
    {
        case StorageType.Double:
            //covert the number into Metric
            defName += " : " + para.AsValueString();
            break;
        case StorageType.ElementId:
            //find out the name of the element
            ElementId id = para.AsElementId();
            if (id.Value >= 0)
            {
                defName += " : " + document.get_Element(ref id).Name;
            }
            else
            {
                defName += " : " + id.Value.ToString();
            }
            break;
        case StorageType.Integer:
            if (ParameterType.YesNo == para.Definition.ParameterType)
            {
                if (para.AsInteger() == 0)
                {
                    defName += " : " + "False";
                }
                else
                {
                    defName += " : " + "True";
                }
            }
            else
            {
                defName += " : " + para.AsInteger().ToString();
            }
            break;
        case StorageType.String:
            defName += " : " + para.AsString();
            break;
        default:
            defName = "Unexposed parameter.";
            break;
    }

    return defName;
}
CopyVB.NET
Private Sub GetElementParameterInformation(ByVal document As Document, ByVal element As Autodesk.Revit.Element)
    ' Format the prompt information string
    Dim prompt As String = "Show parameters in selected Element:"

    Dim st As New StringBuilder()
    ' iterate element's parameters
    For Each para As Parameter In element.Parameters
        st.AppendLine(GetParameterInformation(para, document))
    Next

    ' Give the user some information
    MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)
End Sub

Private Function GetParameterInformation(ByVal para As Parameter, ByVal document As Document) As String
    Dim defName As String = para.Definition.Name & "\t"
    ' Use different method to get parameter data according to the storage type
    Select Case para.StorageType
        Case StorageType.[Double]
            'covert the number into Metric
            defName += " : " & para.AsValueString()
            Exit Select
        Case StorageType.ElementId
            'find out the name of the element
            Dim id As Autodesk.Revit.ElementId = para.AsElementId()
            If id.Value >= 0 Then
                defName += " : " & document.Element(id).Name
            Else
                defName += " : " & id.Value.ToString()
            End If
            Exit Select
        Case StorageType.[Integer]
            If ParameterType.YesNo = para.Definition.ParameterType Then
                If para.AsInteger() = 0 Then
                    defName += " : " & "False"
                Else
                    defName += " : " & "True"
                End If
            Else
                defName += " : " & para.AsInteger().ToString()
            End If
            Exit Select
        Case StorageType.[String]
            defName += " : " & para.AsString()
            Exit Select
        Case Else
            defName = "Unexposed parameter."
            Exit Select
    End Select

    Return defName
End Function

See Also

Element Class
Autodesk.Revit Namespace


ParametersMap Property

[image]

Revit 2010 API
Element..::.ParametersMap Property
Element Class See Also Send Feedback
Retrieves a map containing all of the parameters that are contained within the element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterMap ParametersMap { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParametersMap As ParameterMap
Visual C++
public:
property ParameterMap^ ParametersMap {
    ParameterMap^ get ();
}

Remarks

The Parameters can be rapidly accessed by parameter name as a key. These parameters are displayed in the Element properties dialog in the Autodesk Revit interface. These parameters can be retrieved and set via the parameter objects stored in this map.

See Also

Element Class
Autodesk.Revit Namespace


PhaseCreated Property

[image]

Revit 2010 API
Element..::.PhaseCreated Property
Element Class Example See Also Send Feedback
An object representing the phase when the element is created.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Phase PhaseCreated { get; }
Visual Basic (Declaration)
Public ReadOnly Property PhaseCreated As Phase
Visual C++
public:
property Phase^ PhaseCreated {
    Phase^ get ();
}

Remarks

Elements always have a phase for when they are created.

Examples

CopyC#
void ShowPhaseCreatedName(Element element)
{
    // Get the Phase Create property, and assert it should not be null
    Autodesk.Revit.Elements.Phase phaseCreated = element.PhaseCreated;
    if (null == phaseCreated)
    {
        throw new Exception("Elements always have a phase for when they are created.");
    }
    else
    {
        // Show the Phase Create name to the user.
        String prompt = "The phase created is: " + phaseCreated.Name;
        MessageBox.Show(prompt, "Revit");
    }
}
CopyVB.NET
Private Sub ShowPhaseCreatedName(ByVal element As Autodesk.Revit.Element)
    ' Get the Phase Create property, and assert it should not be null
    Dim phaseCreated As Autodesk.Revit.Elements.Phase = element.PhaseCreated
    If phaseCreated Is Nothing Then
        Throw New Exception("Elements always have a phase for when they are created.")
    Else
        ' Show the Phase Create name to the user.
        Dim prompt As String = "The phase created is: " & phaseCreated.Name
        MessageBox.Show(prompt, "Revit")
    End If
End Sub

See Also

Element Class
Autodesk.Revit Namespace


PhaseDemolished Property

[image]

Revit 2010 API
Element..::.PhaseDemolished Property
Element Class Example See Also Send Feedback
An object representing the phase for when the element is to be demolished.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Phase PhaseDemolished { get; }
Visual Basic (Declaration)
Public ReadOnly Property PhaseDemolished As Phase
Visual C++
public:
property Phase^ PhaseDemolished {
    Phase^ get ();
}

Remarks

The element may not have a demolition phase. If it does not then this property will return nothing.

Examples

CopyC#
void ShowPhaseDemolishedName(Element element)
{
    // Get the Phase Demolished property, and check whether it be null
    Autodesk.Revit.Elements.Phase phaseDemolished = element.PhaseDemolished;
    if (null == phaseDemolished)
    {
        MessageBox.Show("This Element doesn't have Phase Demolished parameter.", "Revit");
    }
    else
    {
        // Show the Phase Demolished name to the user.
        String prompt = "The phase demolished is: " + phaseDemolished.Name;
        MessageBox.Show(prompt, "Revit");
    }
}
CopyVB.NET
Private Sub ShowPhaseDemolishedName(ByVal element As Autodesk.Revit.Element)
    ' Get the Phase Demolished property, and check whether it be null
    Dim phaseDemolished As Autodesk.Revit.Elements.Phase = element.PhaseDemolished
    If phaseDemolished Is Nothing Then
        MessageBox.Show("This Element doesn't have Phase Demolished parameter.", "Revit")
    Else
        ' Show the Phase Demolished name to the user.
        Dim prompt As String = "The phase demolished is: " & phaseDemolished.Name
        MessageBox.Show(prompt, "Revit")
    End If
End Sub

See Also

Element Class
Autodesk.Revit Namespace


Pinned Property

[image]

Revit 2010 API
Element..::.Pinned Property
Element Class See Also Send Feedback
Identifies if the element has been pinned to prevent changes.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Pinned { get; }
Visual Basic (Declaration)
Public ReadOnly Property Pinned As Boolean
Visual C++
public:
property bool Pinned {
    bool get ();
}

Remarks

An element which is pinned may not be moved, and warnings will be issued when an attempt is made to delete it.

See Also

Element Class
Autodesk.Revit Namespace


SimilarObjectTypes Property

[image]

Revit 2010 API
Element..::.SimilarObjectTypes Property
Element Class See Also Send Feedback
Returns the types being similar to the current instance.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ElementSet SimilarObjectTypes { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property SimilarObjectTypes As ElementSet
Visual C++
public:
virtual property ElementSet^ SimilarObjectTypes {
    ElementSet^ get ();
}

Remarks

The returned types include all the similar types to current instance, which means the type of the current instance can be swapped to the type included in the returned set.

See Also

Element Class
Autodesk.Revit Namespace


UniqueId Property

[image]

Revit 2010 API
Element..::.UniqueId Property
Element Class Example See Also Send Feedback
A stable unique identifier for an element within the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string UniqueId { get; }
Visual Basic (Declaration)
Public ReadOnly Property UniqueId As String
Visual C++
public:
property String^ UniqueId {
    String^ get ();
}

Remarks

The UniqueId can be used to store an identifier in and external database and then be used to retrieve the exact same element in the future if it still exists. This id can be passed the Document's Element property to retrieve the element. The UniqueId is stable across upgrades and workset operations such as save to central whereas the ElementId property may change.

Examples

CopyC#
private void CheckElementUniqueId(Autodesk.Revit.Document document, Autodesk.Revit.Element element)
{
    String uniqueId = element.UniqueId;

    // Get the element using the UniqueId
    Autodesk.Revit.Element elem = document.get_Element(uniqueId);

    String prompt = "UniqueId of element is: " + uniqueId;
    prompt += "\nUniqueID of elem is: " + elem.UniqueId;
}
CopyVB.NET
Private Sub CheckElementUniqueId(ByVal document As Autodesk.Revit.Document, ByVal element As Autodesk.Revit.Element)
    Dim uniqueId As String = element.UniqueId

    ' Get the element using the UniqueId
    Dim elem As Autodesk.Revit.Element = document.Element(uniqueId)

    Dim prompt As String = "UniqueId of element is: " & uniqueId
    prompt += vbLf & "UniqueID of elem is: " & elem.UniqueId
End Sub

See Also

Element Class
Autodesk.Revit Namespace


ElementArray Class

[image]

Revit 2010 API
ElementArray Class
Members See Also Send Feedback
An array that contains element objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ElementArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ElementArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ElementArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.ElementArray

See Also

ElementArray Members
Autodesk.Revit Namespace


ElementArray Members

[image] [image]

Revit 2010 API
ElementArray Members
ElementArray Class Constructors Methods Properties See Also Send Feedback

The ElementArray type exposes the following members.

Constructors

Name | Description
ElementArray | Initializes a new instance of the ElementArray class

Methods

Name | Description
Append | Add the element to the end of the array.
Clear | Removes every element from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an element at a specified index within the array.
Size | Returns the number of elements that are in the array.

See Also

ElementArray Class
Autodesk.Revit Namespace


ElementArray Constructor

[image]

Revit 2010 API
ElementArray Constructor
ElementArray Class See Also Send Feedback
Initializes a new instance of the ElementArray class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementArray()

See Also

ElementArray Class
Autodesk.Revit Namespace


ElementArray Methods

[image] [image]

Revit 2010 API
ElementArray Methods
ElementArray Class See Also Send Feedback

The ElementArray type exposes the following members.

Methods

Name | Description
Append | Add the element to the end of the array.
Clear | Removes every element from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementArray Class
Autodesk.Revit Namespace


Append Method

[image]

Revit 2010 API
ElementArray..::.Append Method
ElementArray Class See Also Send Feedback
Add the element to the end of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    Element item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Element _
)
Visual C++
public:
virtual void Append(
    Element^ item
)

Parameters

item
Type: Autodesk.Revit..::.Element
The element to be added.

See Also

ElementArray Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
ElementArray..::.Clear Method
ElementArray Class See Also Send Feedback
Removes every element from the array, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ElementArray Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
ElementArray..::.ForwardIterator Method
ElementArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ElementArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ElementArrayIterator
Visual C++
public:
virtual ElementArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ElementArray Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
ElementArray..::.GetEnumerator Method
ElementArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ElementArray Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
ElementArray..::.Insert Method
ElementArray Class See Also Send Feedback
Insert the specified element into the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    Element item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Element, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Element^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit..::.Element
The element to be inserted into the array.
index
Type: System..::.Int32
The element will be inserted before this index.

Return Value

Returns whether the element was inserted into the array.

See Also

ElementArray Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
ElementArray..::.ReverseIterator Method
ElementArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ElementArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ElementArrayIterator
Visual C++
public:
virtual ElementArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ElementArray Class
Autodesk.Revit Namespace


ElementArray Properties

[image] [image]

Revit 2010 API
ElementArray Properties
ElementArray Class See Also Send Feedback

The ElementArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an element at a specified index within the array.
Size | Returns the number of elements that are in the array.

See Also

ElementArray Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
ElementArray..::.IsEmpty Property
ElementArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ElementArray Class
Autodesk.Revit Namespace


Item Property

[image]

Revit 2010 API
ElementArray..::.Item Property
ElementArray Class See Also Send Feedback
Gets or sets an element at a specified index within the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Element Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Element
Visual C++
public:
virtual property Element^ Item[int index] {
    Element^ get (int index);
    void set (int index, Element^ value);
}

Parameters

index
Type: System..::.Int32
The index of the element to be set or retrieved.

Return Value

Returns the element at the specified index.

See Also

ElementArray Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
ElementArray..::.Size Property
ElementArray Class See Also Send Feedback
Returns the number of elements that are in the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ElementArray Class
Autodesk.Revit Namespace


ElementArrayIterator Class

[image]

Revit 2010 API
ElementArrayIterator Class
Members See Also Send Feedback
An iterator to an element array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ElementArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ElementArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ElementArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.ElementArrayIterator

See Also

ElementArrayIterator Members
Autodesk.Revit Namespace


ElementArrayIterator Members

[image] [image]

Revit 2010 API
ElementArrayIterator Members
ElementArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ElementArrayIterator type exposes the following members.

Constructors

Name | Description
ElementArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementArrayIterator Class
Autodesk.Revit Namespace


ElementArrayIterator Constructor

[image]

Revit 2010 API
ElementArrayIterator Constructor
ElementArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElementArrayIterator Class
Autodesk.Revit Namespace


ElementArrayIterator Methods

[image] [image]

Revit 2010 API
ElementArrayIterator Methods
ElementArrayIterator Class See Also Send Feedback

The ElementArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementArrayIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
ElementArrayIterator..::.MoveNext Method
ElementArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ElementArrayIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
ElementArrayIterator..::.Reset Method
ElementArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ElementArrayIterator Class
Autodesk.Revit Namespace


ElementArrayIterator Properties

[image] [image]

Revit 2010 API
ElementArrayIterator Properties
ElementArrayIterator Class See Also Send Feedback

The ElementArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementArrayIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
ElementArrayIterator..::.Current Property
ElementArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ElementArrayIterator Class
Autodesk.Revit Namespace


ElementId Structure

[image]

Revit 2010 API
ElementId Structure
Members See Also Send Feedback
The ElementId object is used as a unique identification for an element within a single project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[SerializableAttribute]
public struct ElementId
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure ElementId
Visual C++
[SerializableAttribute]
public value class ElementId

Remarks

The Value within the ElementId is only unique with a single project. It is not unique across several projects. The Id can be used to retrieve a specific element from the database when needed. However ids are subject to change during an Autodesk Revit session and as such should not be retained and used across repeated calls to external commands. If a manner is needed to uniquely identify an element beyond this limitation then a shared parameter should be added to the element containing a unique identifier managed by the external application.

See Also

ElementId Members
Autodesk.Revit Namespace


ElementId Members

[image] [image]

Revit 2010 API
ElementId Members
ElementId Structure Methods Fields See Also Send Feedback

The ElementId type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
Value | Provides the value of the element id as an integer.

See Also

ElementId Structure
Autodesk.Revit Namespace


ElementId Fields

[image] [image]

Revit 2010 API
ElementId Fields
ElementId Structure See Also Send Feedback

The ElementId type exposes the following members.

Fields

Name | Description
Value | Provides the value of the element id as an integer.

See Also

ElementId Structure
Autodesk.Revit Namespace


Value Field

[image]

Revit 2010 API
ElementId..::.Value Field
ElementId Structure See Also Send Feedback
Provides the value of the element id as an integer.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Value
Visual Basic (Declaration)
Public Value As Integer
Visual C++
public:
int Value

See Also

ElementId Structure
Autodesk.Revit Namespace


ElementId Methods

[image] [image]

Revit 2010 API
ElementId Methods
ElementId Structure See Also Send Feedback

The ElementId type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

ElementId Structure
Autodesk.Revit Namespace


ElementIdSet Class

[image]

Revit 2010 API
ElementIdSet Class
Members See Also Send Feedback
A set that can contain Element Ids.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ElementIdSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ElementIdSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ElementIdSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.ElementIdSet

See Also

ElementIdSet Members
Autodesk.Revit Namespace


ElementIdSet Members

[image] [image]

Revit 2010 API
ElementIdSet Members
ElementIdSet Class Constructors Methods Properties See Also Send Feedback

The ElementIdSet type exposes the following members.

Constructors

Name | Description
ElementIdSet | Initializes a new instance of the ElementIdSet class

Methods

Name | Description
Clear | Removes every element id from the set, rendering it empty.
Contains | Tests for the existence of an element id within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified element id from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element id into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of element ids that are in the set.

See Also

ElementIdSet Class
Autodesk.Revit Namespace


ElementIdSet Constructor

[image]

Revit 2010 API
ElementIdSet Constructor
ElementIdSet Class See Also Send Feedback
Initializes a new instance of the ElementIdSet class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementIdSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementIdSet()

See Also

ElementIdSet Class
Autodesk.Revit Namespace


ElementIdSet Methods

[image] [image]

Revit 2010 API
ElementIdSet Methods
ElementIdSet Class See Also Send Feedback

The ElementIdSet type exposes the following members.

Methods

Name | Description
Clear | Removes every element id from the set, rendering it empty.
Contains | Tests for the existence of an element id within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified element id from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element id into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementIdSet Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
ElementIdSet..::.Clear Method
ElementIdSet Class See Also Send Feedback
Removes every element id from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ElementIdSet Class
Autodesk.Revit Namespace


Contains Method

[image]

Revit 2010 API
ElementIdSet..::.Contains Method
ElementIdSet Class See Also Send Feedback
Tests for the existence of an element id within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    ref ElementId item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    ByRef item As ElementId _
) As Boolean
Visual C++
public:
virtual bool Contains(
    ElementId% item
)

Parameters

item
Type: Autodesk.Revit..::.ElementId %
The item to be searched for.

Return Value

The Contains method returns True if the element id is within the set, otherwise False.

See Also

ElementIdSet Class
Autodesk.Revit Namespace


Erase Method

[image]

Revit 2010 API
ElementIdSet..::.Erase Method
ElementIdSet Class See Also Send Feedback
Removes a specified element id from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    ref ElementId item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    ByRef item As ElementId _
) As Integer
Visual C++
public:
virtual int Erase(
    ElementId% item
)

Parameters

item
Type: Autodesk.Revit..::.ElementId %
The element id to be erased.

Return Value

The number of element ids that were erased from the set.

See Also

ElementIdSet Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
ElementIdSet..::.ForwardIterator Method
ElementIdSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ElementIdSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ElementIdSetIterator
Visual C++
public:
virtual ElementIdSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ElementIdSet Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
ElementIdSet..::.GetEnumerator Method
ElementIdSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ElementIdSet Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
ElementIdSet..::.Insert Method
ElementIdSet Class See Also Send Feedback
Insert the specified element id into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    ref ElementId item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    ByRef item As ElementId _
) As Boolean
Visual C++
public:
virtual bool Insert(
    ElementId% item
)

Parameters

item
Type: Autodesk.Revit..::.ElementId %
The element id to be inserted into the set.

Return Value

Returns whether the element id was inserted into the set.

See Also

ElementIdSet Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
ElementIdSet..::.ReverseIterator Method
ElementIdSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ElementIdSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ElementIdSetIterator
Visual C++
public:
virtual ElementIdSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ElementIdSet Class
Autodesk.Revit Namespace


ElementIdSet Properties

[image] [image]

Revit 2010 API
ElementIdSet Properties
ElementIdSet Class See Also Send Feedback

The ElementIdSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of element ids that are in the set.

See Also

ElementIdSet Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
ElementIdSet..::.IsEmpty Property
ElementIdSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ElementIdSet Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
ElementIdSet..::.Size Property
ElementIdSet Class See Also Send Feedback
Returns the number of element ids that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ElementIdSet Class
Autodesk.Revit Namespace


ElementIdSetIterator Class

[image]

Revit 2010 API
ElementIdSetIterator Class
Members See Also Send Feedback
An iterator to a element id set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ElementIdSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ElementIdSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ElementIdSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.ElementIdSetIterator

See Also

ElementIdSetIterator Members
Autodesk.Revit Namespace


ElementIdSetIterator Members

[image] [image]

Revit 2010 API
ElementIdSetIterator Members
ElementIdSetIterator Class Constructors Methods Properties See Also Send Feedback

The ElementIdSetIterator type exposes the following members.

Constructors

Name | Description
ElementIdSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementIdSetIterator Class
Autodesk.Revit Namespace


ElementIdSetIterator Constructor

[image]

Revit 2010 API
ElementIdSetIterator Constructor
ElementIdSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementIdSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementIdSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElementIdSetIterator Class
Autodesk.Revit Namespace


ElementIdSetIterator Methods

[image] [image]

Revit 2010 API
ElementIdSetIterator Methods
ElementIdSetIterator Class See Also Send Feedback

The ElementIdSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementIdSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
ElementIdSetIterator..::.MoveNext Method
ElementIdSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ElementIdSetIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
ElementIdSetIterator..::.Reset Method
ElementIdSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ElementIdSetIterator Class
Autodesk.Revit Namespace


ElementIdSetIterator Properties

[image] [image]

Revit 2010 API
ElementIdSetIterator Properties
ElementIdSetIterator Class See Also Send Feedback

The ElementIdSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementIdSetIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
ElementIdSetIterator..::.Current Property
ElementIdSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ElementIdSetIterator Class
Autodesk.Revit Namespace


ElementIterator Class

[image]

Revit 2010 API
ElementIterator Class
Members Example See Also Send Feedback
An iterator object that enable access to every element within the Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ElementIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public Class ElementIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ElementIterator : public APIObject,
    IEnumerator

Remarks

The Autodesk Revit may contain a very large number of elements so iteration can be very time consuming. The elements that are accessible by this iterator are not only the visible elements within the project, but also those that cannot be seen, such as family types, wall types, group types etc. This is a forward seeking iterator.

Examples

CopyC#
info = "Levels in document:\n";
ElementIterator elemItor = document.get_Elements(typeof(Level));
elemItor.Reset();
while (elemItor.MoveNext())
{
    Autodesk.Revit.Element elem = elemItor.Current as Autodesk.Revit.Element;
    // you needn�t check null for elem
    info += elem.Name + "\n";
}

MessageBox.Show(info, "Revit");
CopyVB.NET
info = "Levels in document:" & vbLf
Dim elemItor As ElementIterator = document.Elements(GetType(Autodesk.Revit.Elements.Level))
elemItor.Reset()
While elemItor.MoveNext()
    Dim elem As Autodesk.Revit.Element = TryCast(elemItor.Current, Autodesk.Revit.Element)
    ' you needn’t check null for elem
    info += elem.Name & vbLf
End While

MessageBox.Show(info, "Revit")

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.ElementIterator

See Also

ElementIterator Members
Autodesk.Revit Namespace


ElementIterator Members

[image] [image]

Revit 2010 API
ElementIterator Members
ElementIterator Class Constructors Methods Properties See Also Send Feedback

The ElementIterator type exposes the following members.

Constructors

Name | Description
ElementIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one element forward.
Reset | Bring the iterator back to the start of the database.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | The object that represents the current element in the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementIterator Class
Autodesk.Revit Namespace


ElementIterator Constructor

[image]

Revit 2010 API
ElementIterator Constructor
ElementIterator Class See Also Send Feedback
For Internal Use Only.
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElementIterator Class
Autodesk.Revit Namespace


ElementIterator Methods

[image] [image]

Revit 2010 API
ElementIterator Methods
ElementIterator Class See Also Send Feedback

The ElementIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one element forward.
Reset | Bring the iterator back to the start of the database.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
ElementIterator..::.MoveNext Method
ElementIterator Class See Also Send Feedback
Move the iterator one element forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one element and the Current property will return a valid Element. False will be returned it the iterator has reached the end of the project database.

Implements

IEnumerator..::.MoveNext()()()

See Also

ElementIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
ElementIterator..::.Reset Method
ElementIterator Class See Also Send Feedback
Bring the iterator back to the start of the database.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the Autodesk Revit project database in line with the definition of IEnumerator. Note that you must call MoveNext before the first element can be accessed via the Current property.

See Also

ElementIterator Class
Autodesk.Revit Namespace


ElementIterator Properties

[image] [image]

Revit 2010 API
ElementIterator Properties
ElementIterator Class See Also Send Feedback

The ElementIterator type exposes the following members.

Properties

Name | Description
Current | The object that represents the current element in the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
ElementIterator..::.Current Property
ElementIterator Class See Also Send Feedback
The object that represents the current element in the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Field Value

This object will be derived from Autodesk.Revit.Element.

Implements

IEnumerator..::.Current

Remarks

In order for this property to return a valid element after the iterator is first obtained or reset, the iterator must have MoveNext called upon it once.

See Also

ElementIterator Class
Autodesk.Revit Namespace


ElementSet Class

[image]

Revit 2010 API
ElementSet Class
Members Example See Also Send Feedback
A set that contains element objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ElementSet : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class ElementSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ElementSet : public APIObject,
    IEnumerable

Examples

CopyC#
ElementSet elems = document.Selection.Elements;

string info = "Selected elements:\n";
foreach (Autodesk.Revit.Element elem in elems)
{
    info += elem.Name + "\n";
}

MessageBox.Show(info, "Revit");
CopyVB.NET
Dim elems As ElementSet = document.Selection.Elements

Dim info As String = "Selected elements:" & vbLf
For Each elem As Autodesk.Revit.Element In elems
    info += elem.Name & vbLf
Next

MessageBox.Show(info, "Revit")

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.ElementSet
Autodesk.Revit..::.SelElementSet

See Also

ElementSet Members
Autodesk.Revit Namespace


ElementSet Members

[image] [image]

Revit 2010 API
ElementSet Members
ElementSet Class Constructors Methods Properties See Also Send Feedback

The ElementSet type exposes the following members.

Constructors

Name | Description
ElementSet | Initializes a new instance of the ElementSet class

Methods

Name | Description
Clear | Removes every item element the set, rendering it empty.
Contains | Tests for the existence of an element within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified element from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of elements that are in the set.

See Also

ElementSet Class
Autodesk.Revit Namespace


ElementSet Constructor

[image]

Revit 2010 API
ElementSet Constructor
ElementSet Class See Also Send Feedback
Initializes a new instance of the ElementSet class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementSet()

See Also

ElementSet Class
Autodesk.Revit Namespace


ElementSet Methods

[image] [image]

Revit 2010 API
ElementSet Methods
ElementSet Class See Also Send Feedback

The ElementSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item element the set, rendering it empty.
Contains | Tests for the existence of an element within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified element from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementSet Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
ElementSet..::.Clear Method
ElementSet Class See Also Send Feedback
Removes every item element the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ElementSet Class
Autodesk.Revit Namespace


Contains Method

[image]

Revit 2010 API
ElementSet..::.Contains Method
ElementSet Class See Also Send Feedback
Tests for the existence of an element within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    Element item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Element _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Element^ item
)

Parameters

item
Type: Autodesk.Revit..::.Element
The element to be searched for.

Return Value

The Contains method returns True if the element is within the set, otherwise False.

See Also

ElementSet Class
Autodesk.Revit Namespace


Erase Method

[image]

Revit 2010 API
ElementSet..::.Erase Method
ElementSet Class See Also Send Feedback
Removes a specified element from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    Element item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Element _
) As Integer
Visual C++
public:
virtual int Erase(
    Element^ item
)

Parameters

item
Type: Autodesk.Revit..::.Element
The element to be erased.

Return Value

The number of elements that were erased from the set.

See Also

ElementSet Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
ElementSet..::.ForwardIterator Method
ElementSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ElementSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ElementSetIterator
Visual C++
public:
virtual ElementSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ElementSet Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
ElementSet..::.GetEnumerator Method
ElementSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ElementSet Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
ElementSet..::.Insert Method
ElementSet Class See Also Send Feedback
Insert the specified element into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    Element item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Element _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Element^ item
)

Parameters

item
Type: Autodesk.Revit..::.Element
The element to be inserted into the set.

Return Value

Returns whether the element was inserted into the set.

See Also

ElementSet Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
ElementSet..::.ReverseIterator Method
ElementSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ElementSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ElementSetIterator
Visual C++
public:
virtual ElementSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ElementSet Class
Autodesk.Revit Namespace


ElementSet Properties

[image] [image]

Revit 2010 API
ElementSet Properties
ElementSet Class See Also Send Feedback

The ElementSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of elements that are in the set.

See Also

ElementSet Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
ElementSet..::.IsEmpty Property
ElementSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ElementSet Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
ElementSet..::.Size Property
ElementSet Class See Also Send Feedback
Returns the number of elements that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ElementSet Class
Autodesk.Revit Namespace


ElementSetIterator Class

[image]

Revit 2010 API
ElementSetIterator Class
Members See Also Send Feedback
An iterator to an element set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ElementSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ElementSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ElementSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.ElementSetIterator

See Also

ElementSetIterator Members
Autodesk.Revit Namespace


ElementSetIterator Members

[image] [image]

Revit 2010 API
ElementSetIterator Members
ElementSetIterator Class Constructors Methods Properties See Also Send Feedback

The ElementSetIterator type exposes the following members.

Constructors

Name | Description
ElementSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementSetIterator Class
Autodesk.Revit Namespace


ElementSetIterator Constructor

[image]

Revit 2010 API
ElementSetIterator Constructor
ElementSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElementSetIterator Class
Autodesk.Revit Namespace


ElementSetIterator Methods

[image] [image]

Revit 2010 API
ElementSetIterator Methods
ElementSetIterator Class See Also Send Feedback

The ElementSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
ElementSetIterator..::.MoveNext Method
ElementSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ElementSetIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
ElementSetIterator..::.Reset Method
ElementSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ElementSetIterator Class
Autodesk.Revit Namespace


ElementSetIterator Properties

[image] [image]

Revit 2010 API
ElementSetIterator Properties
ElementSetIterator Class See Also Send Feedback

The ElementSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementSetIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
ElementSetIterator..::.Current Property
ElementSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ElementSetIterator Class
Autodesk.Revit Namespace


ExternalApplicationArray Class

[image]

Revit 2010 API
ExternalApplicationArray Class
Members See Also Send Feedback
An array that can contain any number of IExternalApplication objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ExternalApplicationArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ExternalApplicationArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ExternalApplicationArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.ExternalApplicationArray

See Also

ExternalApplicationArray Members
Autodesk.Revit Namespace


ExternalApplicationArray Members

[image] [image]

Revit 2010 API
ExternalApplicationArray Members
ExternalApplicationArray Class Constructors Methods Properties See Also Send Feedback

The ExternalApplicationArray type exposes the following members.

Constructors

Name | Description
ExternalApplicationArray | Initializes a new instance of the ExternalApplicationArray class

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


ExternalApplicationArray Constructor

[image]

Revit 2010 API
ExternalApplicationArray Constructor
ExternalApplicationArray Class See Also Send Feedback
Initializes a new instance of the ExternalApplicationArray class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ExternalApplicationArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExternalApplicationArray()

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


ExternalApplicationArray Methods

[image] [image]

Revit 2010 API
ExternalApplicationArray Methods
ExternalApplicationArray Class See Also Send Feedback

The ExternalApplicationArray type exposes the following members.

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


Append Method

[image]

Revit 2010 API
ExternalApplicationArray..::.Append Method
ExternalApplicationArray Class See Also Send Feedback
Add the item to the end of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    IExternalApplication item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As IExternalApplication _
)
Visual C++
public:
virtual void Append(
    IExternalApplication^ item
)

Parameters

item
Type: Autodesk.Revit..::.IExternalApplication
The item to be added.

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
ExternalApplicationArray..::.Clear Method
ExternalApplicationArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
ExternalApplicationArray..::.ForwardIterator Method
ExternalApplicationArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ExternalApplicationArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ExternalApplicationArrayIterator
Visual C++
public:
virtual ExternalApplicationArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
ExternalApplicationArray..::.GetEnumerator Method
ExternalApplicationArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
ExternalApplicationArray..::.Insert Method
ExternalApplicationArray Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    IExternalApplication item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As IExternalApplication, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    IExternalApplication^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit..::.IExternalApplication
The item to be inserted into the array.
index
Type: System..::.Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
ExternalApplicationArray..::.ReverseIterator Method
ExternalApplicationArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ExternalApplicationArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ExternalApplicationArrayIterator
Visual C++
public:
virtual ExternalApplicationArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


ExternalApplicationArray Properties

[image] [image]

Revit 2010 API
ExternalApplicationArray Properties
ExternalApplicationArray Class See Also Send Feedback

The ExternalApplicationArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
ExternalApplicationArray..::.IsEmpty Property
ExternalApplicationArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


Item Property

[image]

Revit 2010 API
ExternalApplicationArray..::.Item Property
ExternalApplicationArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IExternalApplication Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As IExternalApplication
Visual C++
public:
virtual property IExternalApplication^ Item[int index] {
    IExternalApplication^ get (int index);
    void set (int index, IExternalApplication^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
ExternalApplicationArray..::.Size Property
ExternalApplicationArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ExternalApplicationArray Class
Autodesk.Revit Namespace


ExternalApplicationArrayIterator Class

[image]

Revit 2010 API
ExternalApplicationArrayIterator Class
Members See Also Send Feedback
An iterator to an array of IExternalApplication objects..

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ExternalApplicationArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ExternalApplicationArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ExternalApplicationArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.ExternalApplicationArrayIterator

See Also

ExternalApplicationArrayIterator Members
Autodesk.Revit Namespace


ExternalApplicationArrayIterator Members

[image] [image]

Revit 2010 API
ExternalApplicationArrayIterator Members
ExternalApplicationArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ExternalApplicationArrayIterator type exposes the following members.

Constructors

Name | Description
ExternalApplicationArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit Namespace


ExternalApplicationArrayIterator Constructor

[image]

Revit 2010 API
ExternalApplicationArrayIterator Constructor
ExternalApplicationArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ExternalApplicationArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExternalApplicationArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit Namespace


ExternalApplicationArrayIterator Methods

[image] [image]

Revit 2010 API
ExternalApplicationArrayIterator Methods
ExternalApplicationArrayIterator Class See Also Send Feedback

The ExternalApplicationArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
ExternalApplicationArrayIterator..::.MoveNext Method
ExternalApplicationArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
ExternalApplicationArrayIterator..::.Reset Method
ExternalApplicationArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit Namespace


ExternalApplicationArrayIterator Properties

[image] [image]

Revit 2010 API
ExternalApplicationArrayIterator Properties
ExternalApplicationArrayIterator Class See Also Send Feedback

The ExternalApplicationArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
ExternalApplicationArrayIterator..::.Current Property
ExternalApplicationArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit Namespace


ExternalCommandData Class

[image]

Revit 2010 API
ExternalCommandData Class
Members See Also Send Feedback
A class contains reference to Application and View which are needed by external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ExternalCommandData : APIObject
Visual Basic (Declaration)
Public Class ExternalCommandData _
    Inherits APIObject
Visual C++
public ref class ExternalCommandData : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.ExternalCommandData

See Also

ExternalCommandData Members
Autodesk.Revit Namespace


ExternalCommandData Members

[image] [image]

Revit 2010 API
ExternalCommandData Members
ExternalCommandData Class Constructors Methods Properties See Also Send Feedback

The ExternalCommandData type exposes the following members.

Constructors

Name | Description
ExternalCommandData | Initializes a new instance of the ExternalCommandData class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Application | Retrieves an object that represents the current Application for external command.
Data | A data map that can be used to read and write data to the Autodesk Revit journal file.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
View | Retrieves an object that represents the View external command work on.

See Also

ExternalCommandData Class
Autodesk.Revit Namespace


ExternalCommandData Constructor

[image]

Revit 2010 API
ExternalCommandData Constructor
ExternalCommandData Class See Also Send Feedback
Initializes a new instance of the ExternalCommandData class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ExternalCommandData()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExternalCommandData()

See Also

ExternalCommandData Class
Autodesk.Revit Namespace


ExternalCommandData Methods

[image] [image]

Revit 2010 API
ExternalCommandData Methods
ExternalCommandData Class See Also Send Feedback

The ExternalCommandData type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalCommandData Class
Autodesk.Revit Namespace


ExternalCommandData Properties

[image] [image]

Revit 2010 API
ExternalCommandData Properties
ExternalCommandData Class See Also Send Feedback

The ExternalCommandData type exposes the following members.

Properties

Name | Description
Application | Retrieves an object that represents the current Application for external command.
Data | A data map that can be used to read and write data to the Autodesk Revit journal file.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
View | Retrieves an object that represents the View external command work on.

See Also

ExternalCommandData Class
Autodesk.Revit Namespace


Application Property

[image]

Revit 2010 API
ExternalCommandData..::.Application Property
ExternalCommandData Class See Also Send Feedback
Retrieves an object that represents the current Application for external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Application Application { get; set; }
Visual Basic (Declaration)
Public Property Application As Application
Visual C++
public:
property Application^ Application {
    Application^ get ();
    void set (Application^ value);
}

See Also

ExternalCommandData Class
Autodesk.Revit Namespace


Data Property

[image]

Revit 2010 API
ExternalCommandData..::.Data Property
ExternalCommandData Class Example See Also Send Feedback
A data map that can be used to read and write data to the Autodesk Revit journal file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public StringStringMap Data { get; set; }
Visual Basic (Declaration)
Public Property Data As StringStringMap
Visual C++
public:
property StringStringMap^ Data {
    StringStringMap^ get ();
    void set (StringStringMap^ value);
}

Remarks

The data map is a string to string map that can be used to store data in the Revit journal file at the end of execution of the external command. If the command is then executed from the journal file during playback this data is then passed to the external command in this Data property so the external command can execute with this passed data in a UI-less mode, hence providing non interactive journal playback for automated testing purposes. For more information on Revit's journaling features contact the Autodesk Developer Network.

Examples

CopyC#
void WriteJournalData(ExternalCommandData commandData)
{
    // Get the StringStringMap class which can write data into.
    Autodesk.Revit.Collections.StringStringMap dataMap = commandData.Data;
    dataMap.Clear();

    // Begin to add the support data
    dataMap.Insert("Name", "Autodesk.Revit");
    dataMap.Insert("Information", "This is an example.");
    dataMap.Insert("Greeting", "Hello Everyone.");
}

/// <summary>
/// This sample shows how to get data from journal file.
/// </summary>
void ReadJournalData(ExternalCommandData commandData)
{
    // Get the StringStringMap class which can write data into.
    Autodesk.Revit.Collections.StringStringMap dataMap = commandData.Data;

    // Begin to get the support data.
    String prompt = "Name: " + dataMap.get_Item("Name");
    prompt += "\nInformation: " + dataMap.get_Item("Information");
    prompt += "\nGreeting: " + dataMap.get_Item("Greeting");

    MessageBox.Show(prompt, "Revit");
}
CopyVB.NET
Private Sub WriteJournalData(ByVal commandData As ExternalCommandData)
    ' Get the StringStringMap class which can write data into.
    Dim dataMap As Autodesk.Revit.Collections.StringStringMap = commandData.Data
    dataMap.Clear()

    ' Begin to add the support data
    dataMap.Insert("Name", "Autodesk.Revit")
    dataMap.Insert("Information", "This is an example.")
    dataMap.Insert("Greeting", "Hello Everyone.")
End Sub

' <summary>
' This sample shows how to get data from journal file.
' </summary>
Private Sub ReadJournalData(ByVal commandData As ExternalCommandData)
    ' Get the StringStringMap class which can write data into.
    Dim dataMap As Autodesk.Revit.Collections.StringStringMap = commandData.Data

    ' Begin to get the support data.
    Dim prompt As String = "Name: " & dataMap.Item("Name")
    prompt += vbLf & "Information: " & dataMap.Item("Information")
    prompt += vbLf & "Greeting: " & dataMap.Item("Greeting")

    MessageBox.Show(prompt, "Revit")
End Sub

See Also

ExternalCommandData Class
Autodesk.Revit Namespace


View Property

[image]

Revit 2010 API
ExternalCommandData..::.View Property
ExternalCommandData Class See Also Send Feedback
Retrieves an object that represents the View external command work on.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public View View { get; set; }
Visual Basic (Declaration)
Public Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
    void set (View^ value);
}

See Also

ExternalCommandData Class
Autodesk.Revit Namespace


FamilyElementVisibility Class

[image]

Revit 2010 API
FamilyElementVisibility Class
Members Example See Also Send Feedback
Provides access to the visibility parameters of family elements in family document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FamilyElementVisibility : APIObject
Visual Basic (Declaration)
Public Class FamilyElementVisibility _
    Inherits APIObject
Visual C++
public ref class FamilyElementVisibility : public APIObject

Examples

CopyC#
public void CreateAndSetVisibility(Autodesk.Revit.Document familyDocument, SketchPlane sketchPlane)
{
    // create a new ModelCurve in the family document
    XYZ p0 = new XYZ(1, 1, 0);
    XYZ p1 = new XYZ(5, 1, 0);
    Line line1 = familyDocument.Application.Create.NewLineBound(p0, p1);

    ModelCurve modelCurve1 = familyDocument.FamilyCreate.NewModelCurve(line1, sketchPlane);

    // create a new ModelText along ModelCurve line
    ModelText text = familyDocument.FamilyCreate.NewModelText("Hello World", null, sketchPlane, p0, Autodesk.Revit.Enums.HorizontalAlign.Center, 0.1);

    // set visibility for text
    FamilyElementVisibility textVisibility = new FamilyElementVisibility(FamilyElementVisibilityType.Model);
    textVisibility.IsShownInTopBottom = false;
    text.SetVisibility(textVisibility);

    // set visibility for line
    FamilyElementVisibility curveVisibility = new FamilyElementVisibility(FamilyElementVisibilityType.Model);
    curveVisibility.IsShownInCoarse = false;
    modelCurve1.SetVisibility(curveVisibility);

}
CopyVB.NET
Public Sub CreateAndSetVisibility(ByVal familyDocument As Autodesk.Revit.Document, ByVal sketchPlane As Autodesk.Revit.Elements.SketchPlane)
    ' create a new ModelCurve in the family document
    Dim p0 As New Autodesk.Revit.Geometry.XYZ(1, 1, 0)
    Dim p1 As New Autodesk.Revit.Geometry.XYZ(5, 1, 0)
    Dim line1 As Line = familyDocument.Application.Create.NewLineBound(p0, p1)

    Dim modelCurve1 As ModelCurve = familyDocument.FamilyCreate.NewModelCurve(line1, sketchPlane)

    ' create a new ModelText along ModelCurve line
    Dim text As ModelText = familyDocument.FamilyCreate.NewModelText("Hello World", Nothing, sketchPlane, p0, Autodesk.Revit.Enums.HorizontalAlign.Center, 0.1)

    ' set visibility for text
    Dim textVisibility As New FamilyElementVisibility(FamilyElementVisibilityType.Model)
    textVisibility.IsShownInTopBottom = False
    text.SetVisibility(textVisibility)

    ' set visibility for line
    Dim curveVisibility As New FamilyElementVisibility(FamilyElementVisibilityType.Model)
    curveVisibility.IsShownInCoarse = False
    modelCurve1.SetVisibility(curveVisibility)

End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.FamilyElementVisibility

See Also

FamilyElementVisibility Members
Autodesk.Revit Namespace


FamilyElementVisibility Members

[image] [image]

Revit 2010 API
FamilyElementVisibility Members
FamilyElementVisibility Class Constructors Methods Properties See Also Send Feedback

The FamilyElementVisibility type exposes the following members.

Constructors

Name | Description
FamilyElementVisibility | Initializes a new instance of the FamilyElementVisibility class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsShownInCoarse | Indicates if the instance is display with Coarse detail level in the view of project document.
IsShownInFine | Indicates if the instance is display with Fine detail level in the view of project document.
IsShownInFrontBack | Indicates if the instance is display in Front/Back view of project document.
IsShownInLeftRight | Indicates if the instance is display in Left/Right view of project document.
IsShownInMedium | Indicates if the instance is display with Medium detail level in the view of project document.
IsShownInPlanRCPCut | Indicates if the instance is displayed when cut in Plan/RCP (if the category permits).
IsShownInTopBottom | Indicates if the instance is display in Plan/RCP view of project document.
IsShownOnlyWhenCut | Indicates if the instance is displayed only if it has been cut.
VisibilityType | Indicates if the instance is Model or View specific.

See Also

FamilyElementVisibility Class
Autodesk.Revit Namespace


FamilyElementVisibility Constructor

[image]

Revit 2010 API
FamilyElementVisibility Constructor
FamilyElementVisibility Class See Also Send Feedback
Initializes a new instance of the FamilyElementVisibility class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyElementVisibility(
    FamilyElementVisibilityType visibilityType
)
Visual Basic (Declaration)
Public Sub New ( _
    visibilityType As FamilyElementVisibilityType _
)
Visual C++
public:
FamilyElementVisibility(
    FamilyElementVisibilityType visibilityType
)

Parameters

visibilityType
Type: Autodesk.Revit..::.FamilyElementVisibilityType

See Also

FamilyElementVisibility Class
Autodesk.Revit Namespace


FamilyElementVisibility Methods

[image] [image]

Revit 2010 API
FamilyElementVisibility Methods
FamilyElementVisibility Class See Also Send Feedback

The FamilyElementVisibility type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyElementVisibility Class
Autodesk.Revit Namespace


FamilyElementVisibility Properties

[image] [image]

Revit 2010 API
FamilyElementVisibility Properties
FamilyElementVisibility Class See Also Send Feedback

The FamilyElementVisibility type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsShownInCoarse | Indicates if the instance is display with Coarse detail level in the view of project document.
IsShownInFine | Indicates if the instance is display with Fine detail level in the view of project document.
IsShownInFrontBack | Indicates if the instance is display in Front/Back view of project document.
IsShownInLeftRight | Indicates if the instance is display in Left/Right view of project document.
IsShownInMedium | Indicates if the instance is display with Medium detail level in the view of project document.
IsShownInPlanRCPCut | Indicates if the instance is displayed when cut in Plan/RCP (if the category permits).
IsShownInTopBottom | Indicates if the instance is display in Plan/RCP view of project document.
IsShownOnlyWhenCut | Indicates if the instance is displayed only if it has been cut.
VisibilityType | Indicates if the instance is Model or View specific.

See Also

FamilyElementVisibility Class
Autodesk.Revit Namespace


IsShownInCoarse Property

[image]

Revit 2010 API
FamilyElementVisibility..::.IsShownInCoarse Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is display with Coarse detail level in the view of project document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsShownInCoarse { get; set; }
Visual Basic (Declaration)
Public Property IsShownInCoarse As Boolean
Visual C++
public:
property bool IsShownInCoarse {
    bool get ();
    void set (bool value);
}

Remarks

This property cannot be set to false if the other two detail levels are also false.

See Also

FamilyElementVisibility Class
Autodesk.Revit Namespace


IsShownInFine Property

[image]

Revit 2010 API
FamilyElementVisibility..::.IsShownInFine Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is display with Fine detail level in the view of project document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsShownInFine { get; set; }
Visual Basic (Declaration)
Public Property IsShownInFine As Boolean
Visual C++
public:
property bool IsShownInFine {
    bool get ();
    void set (bool value);
}

Remarks

This property cannot be set to false if the other two detail levels are also false.

See Also

FamilyElementVisibility Class
Autodesk.Revit Namespace


IsShownInFrontBack Property

[image]

Revit 2010 API
FamilyElementVisibility..::.IsShownInFrontBack Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is display in Front/Back view of project document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsShownInFrontBack { get; set; }
Visual Basic (Declaration)
Public Property IsShownInFrontBack As Boolean
Visual C++
public:
property bool IsShownInFrontBack {
    bool get ();
    void set (bool value);
}

Remarks

This property matters for objects whose visibility type is Model.

See Also

FamilyElementVisibility Class
Autodesk.Revit Namespace


IsShownInLeftRight Property

[image]

Revit 2010 API
FamilyElementVisibility..::.IsShownInLeftRight Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is display in Left/Right view of project document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsShownInLeftRight { get; set; }
Visual Basic (Declaration)
Public Property IsShownInLeftRight As Boolean
Visual C++
public:
property bool IsShownInLeftRight {
    bool get ();
    void set (bool value);
}

Remarks

This property matters for objects whose visibility type is Model.

See Also

FamilyElementVisibility Class
Autodesk.Revit Namespace


IsShownInMedium Property

[image]

Revit 2010 API
FamilyElementVisibility..::.IsShownInMedium Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is display with Medium detail level in the view of project document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsShownInMedium { get; set; }
Visual Basic (Declaration)
Public Property IsShownInMedium As Boolean
Visual C++
public:
property bool IsShownInMedium {
    bool get ();
    void set (bool value);
}

Remarks

This property cannot be set to false if the other two detail levels are also false.

See Also

FamilyElementVisibility Class
Autodesk.Revit Namespace


IsShownInPlanRCPCut Property

[image]

Revit 2010 API
FamilyElementVisibility..::.IsShownInPlanRCPCut Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is displayed when cut in Plan/RCP (if the category permits).

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsShownInPlanRCPCut { get; set; }
Visual Basic (Declaration)
Public Property IsShownInPlanRCPCut As Boolean
Visual C++
public:
property bool IsShownInPlanRCPCut {
    bool get ();
    void set (bool value);
}

Remarks

controls whether the Model Family Element is shown when a FamilyInstance of that Family is cut in a Plan/RCP view, i.e. the cut plane passes through the bbox of the instance. It only has a meaning for categories that are "cut in the symbol". For non-cuttable categories it is always false and for ones that are "cuttable in the instance" it is the same as the IsShownInTopBottom.

See Also

FamilyElementVisibility Class
Autodesk.Revit Namespace


IsShownInTopBottom Property

[image]

Revit 2010 API
FamilyElementVisibility..::.IsShownInTopBottom Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is display in Plan/RCP view of project document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsShownInTopBottom { get; set; }
Visual Basic (Declaration)
Public Property IsShownInTopBottom As Boolean
Visual C++
public:
property bool IsShownInTopBottom {
    bool get ();
    void set (bool value);
}

Remarks

This property matters for objects whose visibility type is Model.

See Also

FamilyElementVisibility Class
Autodesk.Revit Namespace


IsShownOnlyWhenCut Property

[image]

Revit 2010 API
FamilyElementVisibility..::.IsShownOnlyWhenCut Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is displayed only if it has been cut.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsShownOnlyWhenCut { get; set; }
Visual Basic (Declaration)
Public Property IsShownOnlyWhenCut As Boolean
Visual C++
public:
property bool IsShownOnlyWhenCut {
    bool get ();
    void set (bool value);
}

Remarks

This property matters for objects which visibility type is ViewSpecific.

See Also

FamilyElementVisibility Class
Autodesk.Revit Namespace


VisibilityType Property

[image]

Revit 2010 API
FamilyElementVisibility..::.VisibilityType Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is Model or View specific.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyElementVisibilityType VisibilityType { get; }
Visual Basic (Declaration)
Public ReadOnly Property VisibilityType As FamilyElementVisibilityType
Visual C++
public:
property FamilyElementVisibilityType VisibilityType {
    FamilyElementVisibilityType get ();
}

See Also

FamilyElementVisibility Class
Autodesk.Revit Namespace


FamilyElementVisibilityType Enumeration

[image]

Revit 2010 API
FamilyElementVisibilityType Enumeration
See Also Send Feedback
Indicates the Visiblity type of generic forms.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum FamilyElementVisibilityType
Visual Basic (Declaration)
Public Enumeration FamilyElementVisibilityType
Visual C++
public enum class FamilyElementVisibilityType

Members

Member name | Description
Model | The element will be displayed in 3D views and model other model views.
ViewSpecific | The element will be displayed only in the view where it is created. This applies to items like detail components, annotations, and view-specific imports.

Remarks

Use this enum in NewExtrusion, NewBlend, NewRevolution, NewSweep, and NewSweptBlend methods to indicate the visibility type of new forms.

See Also

Autodesk.Revit Namespace


FamilyFilter Class

[image]

Revit 2010 API
FamilyFilter Class
Members See Also Send Feedback
A filter object that used to filter family elements which satisfy specified criterion, filter elements via specifying family name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FamilyFilter : Filter
Visual Basic (Declaration)
Public Class FamilyFilter _
    Inherits Filter
Visual C++
public ref class FamilyFilter : public Filter

Remarks

The filtered elements include: Family type elements, Symbol type elements, FamilyInstance type elements and other types instances(such as Door, Wall, etc) whose family is specified family. These elements should belong to main model, active design option or primary design option.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Filter
Autodesk.Revit..::.FamilyFilter

See Also

FamilyFilter Members
Autodesk.Revit Namespace


FamilyFilter Members

[image] [image]

Revit 2010 API
FamilyFilter Members
FamilyFilter Class Constructors Methods Properties See Also Send Feedback

The FamilyFilter type exposes the following members.

Constructors

Name | Description
FamilyFilter | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyFilter Class
Autodesk.Revit Namespace


FamilyFilter Constructor

[image]

Revit 2010 API
FamilyFilter Constructor
FamilyFilter Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilyFilter()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilyFilter Class
Autodesk.Revit Namespace


FamilyFilter Methods

[image] [image]

Revit 2010 API
FamilyFilter Methods
FamilyFilter Class See Also Send Feedback

The FamilyFilter type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyFilter Class
Autodesk.Revit Namespace


FamilyFilter Properties

[image] [image]

Revit 2010 API
FamilyFilter Properties
FamilyFilter Class See Also Send Feedback

The FamilyFilter type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyFilter Class
Autodesk.Revit Namespace


FamilyManager Class

[image]

Revit 2010 API
FamilyManager Class
Members See Also Send Feedback
The family manager object to manage the family types and parameters in family document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FamilyManager : APIObject
Visual Basic (Declaration)
Public Class FamilyManager _
    Inherits APIObject
Visual C++
public ref class FamilyManager : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.FamilyManager

See Also

FamilyManager Members
Autodesk.Revit Namespace


FamilyManager Members

[image] [image]

Revit 2010 API
FamilyManager Members
FamilyManager Class Constructors Methods Properties See Also Send Feedback

The FamilyManager type exposes the following members.

Constructors

Name | Description
FamilyManager | For Internal Use Only.

Methods

Name | Description
AddParameter | Overloaded. Add a new parameter to the family.
AssociateElementParameterToFamilyParameter | Associates or disassociates the element parameter to an existing family parameter.
CanElementParameterBeAssociated | Indicates if this element parameter can be associated with a family parameter.
DeleteCurrentType | Remove the current family type.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAssociatedFamilyParameter | Gets the associated family parameter of an element parameter.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsParameterLockable | For Conceptual Mass and Curtain Panel families, indicate whether the specified parameter can be locked.
IsParameterLocked | For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.
MakeInstance | Set the family parameter as an instance parameter.
MakeType | Set the family parameter as a type parameter.
NewType | Add a new family type with a given name and makes it be the current type.
RemoveParameter | Remove an existing family parameter from the family.
RenameCurrentType | Rename the current family type.
Set | Overloaded. Set the value of a family parameter of the current family type.
SetFormula | Set the formula of a family parameter.
SetParameterLocked | For Conceptual Mass and Curtain Panel families, lock or unlock a dimension-driving parameter.
SetValueString | Set the string value of a family parameter of the current family type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurrentType | The current family type.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Parameter | Overloaded. Obtains a parameter based on an identifier.
Parameters | All family parameters in this family.
Types | All family types in the family.

See Also

FamilyManager Class
Autodesk.Revit Namespace


FamilyManager Constructor

[image]

Revit 2010 API
FamilyManager Constructor
FamilyManager Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyManager()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilyManager()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilyManager Class
Autodesk.Revit Namespace


FamilyManager Methods

[image] [image]

Revit 2010 API
FamilyManager Methods
FamilyManager Class See Also Send Feedback

The FamilyManager type exposes the following members.

Methods

Name | Description
AddParameter | Overloaded. Add a new parameter to the family.
AssociateElementParameterToFamilyParameter | Associates or disassociates the element parameter to an existing family parameter.
CanElementParameterBeAssociated | Indicates if this element parameter can be associated with a family parameter.
DeleteCurrentType | Remove the current family type.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAssociatedFamilyParameter | Gets the associated family parameter of an element parameter.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsParameterLockable | For Conceptual Mass and Curtain Panel families, indicate whether the specified parameter can be locked.
IsParameterLocked | For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.
MakeInstance | Set the family parameter as an instance parameter.
MakeType | Set the family parameter as a type parameter.
NewType | Add a new family type with a given name and makes it be the current type.
RemoveParameter | Remove an existing family parameter from the family.
RenameCurrentType | Rename the current family type.
Set | Overloaded. Set the value of a family parameter of the current family type.
SetFormula | Set the formula of a family parameter.
SetParameterLocked | For Conceptual Mass and Curtain Panel families, lock or unlock a dimension-driving parameter.
SetValueString | Set the string value of a family parameter of the current family type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyManager Class
Autodesk.Revit Namespace


AddParameter Method

[image] [image]

Revit 2010 API
FamilyManager..::.AddParameter Method
FamilyManager Class See Also Send Feedback
Add a new parameter to the family.

Overload List

Name | Description
AddParameter(ExternalDefinition, BuiltInParameterGroup, Boolean) | Add a new shared parameter to the family.
AddParameter(String, BuiltInParameterGroup, Category, Boolean) | Add a new family type parameter to control the type of a nested family within another family.
AddParameter(String, BuiltInParameterGroup, ParameterType, Boolean) | Add a new family parameter with a given name.

See Also

FamilyManager Class
FamilyManager Members
Autodesk.Revit Namespace


AddParameter Method (ExternalDefinition, BuiltInParameterGroup, Boolean)

[image]

Revit 2010 API
FamilyManager..::.AddParameter Method (ExternalDefinition, BuiltInParameterGroup, Boolean)
FamilyManager Class See Also Send Feedback
Add a new shared parameter to the family.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyParameter AddParameter(
    ExternalDefinition familyDefinition,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)
Visual Basic (Declaration)
Public Function AddParameter ( _
    familyDefinition As ExternalDefinition, _
    parameterGroup As BuiltInParameterGroup, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ AddParameter(
    ExternalDefinition^ familyDefinition,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)

Parameters

familyDefinition
Type: Autodesk.Revit.Parameters..::.ExternalDefinition
The definition of the loaded shared parameter.
parameterGroup
Type: Autodesk.Revit.Parameters..::.BuiltInParameterGroup
The group to which the family parameter belongs.
isInstance
Type: System..::.Boolean
Indicates if the new parameter is instance or type.

Return Value

If creation was successful the new shared parameter is returned, otherwise an exception with failure information will be thrown.

Remarks

This method can work even without any family type, but it cannot be assigned the value via FamilyManager.Set methods when there is no current type.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the shared family parameter creation is not supported.

See Also

FamilyManager Class
AddParameter Overload
Autodesk.Revit Namespace


AddParameter Method (String, BuiltInParameterGroup, Category, Boolean)

[image]

Revit 2010 API
FamilyManager..::.AddParameter Method (String, BuiltInParameterGroup, Category, Boolean)
FamilyManager Class See Also Send Feedback
Add a new family type parameter to control the type of a nested family within another family.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyParameter AddParameter(
    string parameterName,
    BuiltInParameterGroup parameterGroup,
    Category familyCategory,
    bool isInstance
)
Visual Basic (Declaration)
Public Function AddParameter ( _
    parameterName As String, _
    parameterGroup As BuiltInParameterGroup, _
    familyCategory As Category, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ AddParameter(
    String^ parameterName,
    BuiltInParameterGroup parameterGroup,
    Category^ familyCategory,
    bool isInstance
)

Parameters

parameterName
Type: System..::.String
The name of the new family parameter.
parameterGroup
Type: Autodesk.Revit.Parameters..::.BuiltInParameterGroup
The group to which the family parameter belongs.
familyCategory
Type: Autodesk.Revit..::.Category
The category to which the new family parameter binds.
isInstance
Type: System..::.Boolean
Indicates if the new family parameter is instance or type.

Return Value

If creation was successful the new parameter is returned, otherwise an exception with failure information will be thrown.

Remarks

This method can work even without any family type, but it cannot be assigned the value via FamilyManager.Set methods when there is no current type.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"parameterName"-is null.
System..::.ArgumentException | Thrown when the input argument-"parameterName"-is already in use, or the input argument-"familyCategory"-is illegal to bind with parameter.
System..::.InvalidOperationException | Thrown when the required family of familyCategory is not existing in current document, , or when the creation failed.

See Also

FamilyManager Class
AddParameter Overload
Autodesk.Revit Namespace


AddParameter Method (String, BuiltInParameterGroup, ParameterType, Boolean)

[image]

Revit 2010 API
FamilyManager..::.AddParameter Method (String, BuiltInParameterGroup, ParameterType, Boolean)
FamilyManager Class See Also Send Feedback
Add a new family parameter with a given name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyParameter AddParameter(
    string parameterName,
    BuiltInParameterGroup parameterGroup,
    ParameterType parameterType,
    bool isInstance
)
Visual Basic (Declaration)
Public Function AddParameter ( _
    parameterName As String, _
    parameterGroup As BuiltInParameterGroup, _
    parameterType As ParameterType, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ AddParameter(
    String^ parameterName,
    BuiltInParameterGroup parameterGroup,
    ParameterType parameterType,
    bool isInstance
)

Parameters

parameterName
Type: System..::.String
The name of the new family parameter.
parameterGroup
Type: Autodesk.Revit.Parameters..::.BuiltInParameterGroup
The group to which the family parameter belongs.
parameterType
Type: Autodesk.Revit.Parameters..::.ParameterType
The type of new family parameter.
isInstance
Type: System..::.Boolean
Indicates if the new family parameter is instance or type.

Return Value

If creation was successful the new parameter is returned, otherwise an exception with failure information will be thrown.

Remarks

This method can work even without any family type, but it cannot be assigned the value via FamilyManager.Set methods when there is no current type.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"parameterName"-is null.
System..::.ArgumentException | Thrown when the input argument-"parameterName"-is already in use, or when the input argument -"parameterType" is an invalid type. Also thrown when "parameterType" is FamilyType; to add a parameter of this type use the AddParameter method that accepts a category instead.
System..::.InvalidOperationException | Thrown when the family parameter creation failed.

See Also

FamilyManager Class
AddParameter Overload
Autodesk.Revit Namespace


AssociateElementParameterToFamilyParameter Method

[image]

Revit 2010 API
FamilyManager..::.AssociateElementParameterToFamilyParameter Method
FamilyManager Class See Also Send Feedback
Associates or disassociates the element parameter to an existing family parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AssociateElementParameterToFamilyParameter(
    Parameter elementParameter,
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Sub AssociateElementParameterToFamilyParameter ( _
    elementParameter As Parameter, _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void AssociateElementParameterToFamilyParameter(
    Parameter^ elementParameter,
    FamilyParameter^ familyParameter
)

Parameters

elementParameter
Type: Autodesk.Revit..::.Parameter
The parameter of an element in family.
familyParameter
Type: Autodesk.Revit..::.FamilyParameter
The existing family parameter. If the input to this argument is null, it will disassociate the element parameter from any family parameters.

Remarks

The parameter types of these two input parameter should be same, if not an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"elementParameter"-is null.
System..::.ArgumentException | Thrown when the input argument-"elementParameter" or "familyParameter"-is an invalid parameter, or the input argument-"elementParameter"-cannot be associated.
System..::.InvalidOperationException | Thrown when the family parameter binding failed.

See Also

FamilyManager Class
Autodesk.Revit Namespace


CanElementParameterBeAssociated Method

[image]

Revit 2010 API
FamilyManager..::.CanElementParameterBeAssociated Method
FamilyManager Class See Also Send Feedback
Indicates if this element parameter can be associated with a family parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool CanElementParameterBeAssociated(
    Parameter elementParameter
)
Visual Basic (Declaration)
Public Function CanElementParameterBeAssociated ( _
    elementParameter As Parameter _
) As Boolean
Visual C++
public:
bool CanElementParameterBeAssociated(
    Parameter^ elementParameter
)

Parameters

elementParameter
Type: Autodesk.Revit..::.Parameter

See Also

FamilyManager Class
Autodesk.Revit Namespace


DeleteCurrentType Method

[image]

Revit 2010 API
FamilyManager..::.DeleteCurrentType Method
FamilyManager Class See Also Send Feedback
Remove the current family type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void DeleteCurrentType()
Visual Basic (Declaration)
Public Sub DeleteCurrentType
Visual C++
public:
void DeleteCurrentType()

Remarks

If successfully removed, the first available type will become the current type, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when there is only one family type in current document.

See Also

FamilyManager Class
Autodesk.Revit Namespace


GetAssociatedFamilyParameter Method

[image]

Revit 2010 API
FamilyManager..::.GetAssociatedFamilyParameter Method
FamilyManager Class See Also Send Feedback
Gets the associated family parameter of an element parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyParameter GetAssociatedFamilyParameter(
    Parameter elementParameter
)
Visual Basic (Declaration)
Public Function GetAssociatedFamilyParameter ( _
    elementParameter As Parameter _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ GetAssociatedFamilyParameter(
    Parameter^ elementParameter
)

Parameters

elementParameter
Type: Autodesk.Revit..::.Parameter
The parameter of an element in family.

Return Value

Returns the associated family parameter if there is an association between them, returns null if not.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"elementParameter"-is null.

See Also

FamilyManager Class
Autodesk.Revit Namespace


IsParameterLockable Method

[image]

Revit 2010 API
FamilyManager..::.IsParameterLockable Method
FamilyManager Class See Also Send Feedback
For Conceptual Mass and Curtain Panel families, indicate whether the specified parameter can be locked.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsParameterLockable(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function IsParameterLockable ( _
    familyParameter As FamilyParameter _
) As Boolean
Visual C++
public:
bool IsParameterLockable(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter

Return Value

True if the family is a Conceptual Mass or Curtain Panel Family and the parameter drives one or more dimensions; false otherwise.

See Also

FamilyManager Class
Autodesk.Revit Namespace


IsParameterLocked Method

[image]

Revit 2010 API
FamilyManager..::.IsParameterLocked Method
FamilyManager Class See Also Send Feedback
For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsParameterLocked(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function IsParameterLocked ( _
    familyParameter As FamilyParameter _
) As Boolean
Visual C++
public:
bool IsParameterLocked(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter

Return Value

True if the parameter is lockable and is locked; false otherwise.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if this family is not a Conceptual Mass or Curtain Panel family.

See Also

FamilyManager Class
Autodesk.Revit Namespace


MakeInstance Method

[image]

Revit 2010 API
FamilyManager..::.MakeInstance Method
FamilyManager Class See Also Send Feedback
Set the family parameter as an instance parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void MakeInstance(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Sub MakeInstance ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void MakeInstance(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.
System..::.InvalidOperationException | Thrown when there is Type family parameter driven by this parameter.

See Also

FamilyManager Class
Autodesk.Revit Namespace


MakeType Method

[image]

Revit 2010 API
FamilyManager..::.MakeType Method
FamilyManager Class See Also Send Feedback
Set the family parameter as a type parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void MakeType(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Sub MakeType ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void MakeType(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.

See Also

FamilyManager Class
Autodesk.Revit Namespace


NewType Method

[image]

Revit 2010 API
FamilyManager..::.NewType Method
FamilyManager Class Example See Also Send Feedback
Add a new family type with a given name and makes it be the current type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyType NewType(
    string typeName
)
Visual Basic (Declaration)
Public Function NewType ( _
    typeName As String _
) As FamilyType
Visual C++
public:
FamilyType^ NewType(
    String^ typeName
)

Parameters

typeName
Type: System..::.String
The name of new family type.

Examples

CopyC#
public void EditFamilyTypes(Document document, FamilyInstance familyInstance)
{
    // example works best when familyInstance is a rectangular concrete element
    if (null != familyInstance.Symbol)
    {
        // Get family associated with this
        Family family = familyInstance.Symbol.Family;

        // Get Family document for family
        Document familyDoc = document.EditFamily(family);
        if (null != familyDoc)
        {
            FamilyManager familyManager = familyDoc.FamilyManager;

            // add a new type and edit its parameters
            FamilyType newFamilyType = familyManager.NewType("2X2");

            // look for 'b' and 'h' parameters and set them to 2 feet
            FamilyParameter familyParam = familyManager.get_Parameter("b");
            if (null != familyParam)
            {
                familyManager.Set(familyParam, 2.0);
            }
            familyParam = familyManager.get_Parameter("h");
            if (null != familyParam)
            {
                familyManager.Set(familyParam, 2.0);
            }

            // now update the Revit project with Family which has a new type
            family = familyDoc.LoadFamily(document);
            // find the new type and assign it to FamilyInstance
            FamilySymbolSetIterator symbolsItor = family.Symbols.ForwardIterator();
            symbolsItor.Reset();
            while (symbolsItor.MoveNext())
            {
                FamilySymbol familySymbol = symbolsItor.Current as FamilySymbol;
                if (familySymbol.Name == "2X2")
                {
                    familyInstance.Symbol = familySymbol;
                    break;
                }
            }
        }
    }
}
CopyVB.NET
Public Sub EditFamilyTypes(ByVal document As Document, ByVal familyInstance As Autodesk.Revit.Elements.FamilyInstance)
    ' example works best when familyInstance is a rectangular concrete element
    If familyInstance.Symbol IsNot Nothing Then
        ' Get family associated with this
        Dim family As Autodesk.Revit.Elements.Family = familyInstance.Symbol.Family

        ' Get Family document for family
        Dim familyDoc As Document = document.EditFamily(family)
        If familyDoc IsNot Nothing AndAlso familyDoc.IsFamilyDocument = True Then
            Dim familyManager As FamilyManager = familyDoc.FamilyManager

            ' add a new type and edit its parameters
            Dim newFamilyType As FamilyType = familyManager.NewType("50X50")

            ' look for 'b' and 'h' parameters and set them to 50
            Dim familyParam As FamilyParameter = familyManager.Parameter("b")
            If familyParam IsNot Nothing Then
                familyManager.[Set](familyParam, 50.0R)
            End If
            familyParam = familyManager.Parameter("h")
            If familyParam IsNot Nothing Then
                familyManager.[Set](familyParam, 50.0R)
            End If

            ' now update the Revit project with Family which has a new type
            family = familyDoc.LoadFamily(document)
            ' find the new type and assign it to FamilyInstance
            Dim symbolsItor As FamilySymbolSetIterator = family.Symbols.ForwardIterator()
            symbolsItor.Reset()
            While symbolsItor.MoveNext()
                Dim familySymbol As Autodesk.Revit.Symbols.FamilySymbol = TryCast(symbolsItor.Current, Autodesk.Revit.Symbols.FamilySymbol)
                If familySymbol.Name = "50X50" Then
                    familyInstance.Symbol = familySymbol
                    Exit While
                End If
            End While
        End If
    End If
End Sub

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"typeName"-is null.
System..::.ArgumentException | Thrown when the input argument-"typeName"-is already in use.
System..::.InvalidOperationException | Thrown when the famiy type creation failed.

See Also

FamilyManager Class
Autodesk.Revit Namespace


RemoveParameter Method

[image]

Revit 2010 API
FamilyManager..::.RemoveParameter Method
FamilyManager Class See Also Send Feedback
Remove an existing family parameter from the family.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveParameter(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Sub RemoveParameter ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void RemoveParameter(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter
The family parameter.

Remarks

Only family and shared parameters may be removed, built-in parameters may not be removed. If the parameter is used in any formulas, those formulas will be automatically removed along with the parameter.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.
System..::.InvalidOperationException | Thrown when the family parameter deletion failed.

See Also

FamilyManager Class
Autodesk.Revit Namespace


RenameCurrentType Method

[image]

Revit 2010 API
FamilyManager..::.RenameCurrentType Method
FamilyManager Class See Also Send Feedback
Rename the current family type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RenameCurrentType(
    string typeName
)
Visual Basic (Declaration)
Public Sub RenameCurrentType ( _
    typeName As String _
)
Visual C++
public:
void RenameCurrentType(
    String^ typeName
)

Parameters

typeName
Type: System..::.String
The new name of the current family type.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"typeName"-is null.
System..::.ArgumentException | Thrown when the input argument-"typeName"-is already in use.
System..::.InvalidOperationException | Thrown when the famiy type rename failed.

See Also

FamilyManager Class
Autodesk.Revit Namespace


Set Method

[image] [image]

Revit 2010 API
FamilyManager..::.Set Method
FamilyManager Class See Also Send Feedback
Set the value of a family parameter of the current family type.

Overload List

Name | Description
Set(FamilyParameter, ElementId%) | Set the ElementId value of a family parameter of the current family type.
Set(FamilyParameter, Double) | Set the double value of a family parameter of the current family type.
Set(FamilyParameter, Int32) | Set the integer value of a family parameter of the current family type.
Set(FamilyParameter, String) | Set the string value of a family parameter of the current family type.

See Also

FamilyManager Class
FamilyManager Members
Autodesk.Revit Namespace


Set Method (FamilyParameter, ElementId)

[image]

Revit 2010 API
FamilyManager..::.Set Method (FamilyParameter, ElementId%)
FamilyManager Class See Also Send Feedback
Set the ElementId value of a family parameter of the current family type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Set(
    FamilyParameter familyParameter,
    ref ElementId value
)
Visual Basic (Declaration)
Public Sub Set ( _
    familyParameter As FamilyParameter, _
    ByRef value As ElementId _
)
Visual C++
public:
void Set(
    FamilyParameter^ familyParameter,
    ElementId% value
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter
The family parameter of current type.
value
Type: Autodesk.Revit..::.ElementId %
The new value for family parameter.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter.
System..::.ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
System..::.InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid.

See Also

FamilyManager Class
Set Overload
Autodesk.Revit Namespace


Set Method (FamilyParameter, Double)

[image]

Revit 2010 API
FamilyManager..::.Set Method (FamilyParameter, Double)
FamilyManager Class See Also Send Feedback
Set the double value of a family parameter of the current family type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Set(
    FamilyParameter familyParameter,
    double value
)
Visual Basic (Declaration)
Public Sub Set ( _
    familyParameter As FamilyParameter, _
    value As Double _
)
Visual C++
public:
void Set(
    FamilyParameter^ familyParameter,
    double value
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter
The family parameter of current type.
value
Type: System..::.Double
The new value for family parameter.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter.
System..::.ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
System..::.InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid.

See Also

FamilyManager Class
Set Overload
Autodesk.Revit Namespace


Set Method (FamilyParameter, Int32)

[image]

Revit 2010 API
FamilyManager..::.Set Method (FamilyParameter, Int32)
FamilyManager Class See Also Send Feedback
Set the integer value of a family parameter of the current family type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Set(
    FamilyParameter familyParameter,
    int value
)
Visual Basic (Declaration)
Public Sub Set ( _
    familyParameter As FamilyParameter, _
    value As Integer _
)
Visual C++
public:
void Set(
    FamilyParameter^ familyParameter,
    int value
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter
The family parameter of current type.
value
Type: System..::.Int32
The new value for family parameter.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter.
System..::.ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
System..::.InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid.

See Also

FamilyManager Class
Set Overload
Autodesk.Revit Namespace


Set Method (FamilyParameter, String)

[image]

Revit 2010 API
FamilyManager..::.Set Method (FamilyParameter, String)
FamilyManager Class See Also Send Feedback
Set the string value of a family parameter of the current family type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Set(
    FamilyParameter familyParameter,
    string value
)
Visual Basic (Declaration)
Public Sub Set ( _
    familyParameter As FamilyParameter, _
    value As String _
)
Visual C++
public:
void Set(
    FamilyParameter^ familyParameter,
    String^ value
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter
The family parameter of current type.
value
Type: System..::.String
The new value for family parameter.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter.
System..::.ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
System..::.InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid.

See Also

FamilyManager Class
Set Overload
Autodesk.Revit Namespace


SetFormula Method

[image]

Revit 2010 API
FamilyManager..::.SetFormula Method
FamilyManager Class See Also Send Feedback
Set the formula of a family parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetFormula(
    FamilyParameter familyParameter,
    string formula
)
Visual Basic (Declaration)
Public Sub SetFormula ( _
    familyParameter As FamilyParameter, _
    formula As String _
)
Visual C++
public:
void SetFormula(
    FamilyParameter^ familyParameter,
    String^ formula
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter
The family parameter.
formula
Type: System..::.String
The formula string, input null to clean the formula of the parameter.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.InvalidOperationException | Thrown when the parameter cannot be assigned a formula, or the operation make a circular chain of references among the formulas.

See Also

FamilyManager Class
Autodesk.Revit Namespace


SetParameterLocked Method

[image]

Revit 2010 API
FamilyManager..::.SetParameterLocked Method
FamilyManager Class See Also Send Feedback
For Conceptual Mass and Curtain Panel families, lock or unlock a dimension-driving parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetParameterLocked(
    FamilyParameter familyParameter,
    bool locked
)
Visual Basic (Declaration)
Public Sub SetParameterLocked ( _
    familyParameter As FamilyParameter, _
    locked As Boolean _
)
Visual C++
public:
void SetParameterLocked(
    FamilyParameter^ familyParameter,
    bool locked
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter
locked
Type: System..::.Boolean

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if this family is not a Conceptual Mass or Curtain Panel family.
System..::.ArgumentException | Thrown if the parameter is not lockable.

See Also

FamilyManager Class
Autodesk.Revit Namespace


SetValueString Method

[image]

Revit 2010 API
FamilyManager..::.SetValueString Method
FamilyManager Class See Also Send Feedback
Set the string value of a family parameter of the current family type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetValueString(
    FamilyParameter familyParameter,
    string value
)
Visual Basic (Declaration)
Public Sub SetValueString ( _
    familyParameter As FamilyParameter, _
    value As String _
)
Visual C++
public:
void SetValueString(
    FamilyParameter^ familyParameter,
    String^ value
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter
The family parameter of current type.
value
Type: System..::.String
The new value string for family parameter.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the input argument-"familyParameter" or "value"-is null.
System..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter. or the input argument-"value"-is an illegal string.
System..::.ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
System..::.InvalidOperationException | Thrown when the family parameter is determined by formula, or it is not a value type, or the current family type is invalid.

See Also

FamilyManager Class
Autodesk.Revit Namespace


FamilyManager Properties

[image] [image]

Revit 2010 API
FamilyManager Properties
FamilyManager Class See Also Send Feedback

The FamilyManager type exposes the following members.

Properties

Name | Description
CurrentType | The current family type.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Parameter | Overloaded. Obtains a parameter based on an identifier.
Parameters | All family parameters in this family.
Types | All family types in the family.

See Also

FamilyManager Class
Autodesk.Revit Namespace


CurrentType Property

[image]

Revit 2010 API
FamilyManager..::.CurrentType Property
FamilyManager Class See Also Send Feedback
The current family type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyType CurrentType { get; set; }
Visual Basic (Declaration)
Public Property CurrentType As FamilyType
Visual C++
public:
property FamilyType^ CurrentType {
    FamilyType^ get ();
    void set (FamilyType^ value);
}

Remarks

Only the current family type is editable using the methods in FamilyManager. If you want to modify the properties of any family type, it must be set to be the current type first. This value will be null if there is no type in the family. In order to modify parameter values, you will need to create one using NewType(String).

See Also

FamilyManager Class
Autodesk.Revit Namespace


Parameter Property

[image] [image]

Revit 2010 API
FamilyManager..::.Parameter Property
FamilyManager Class See Also Send Feedback
Obtains a parameter based on an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Obtains the parameter of this type with a given parameter id.
Parameter[([(Definition])]) | Obtains the parameter of this type with a given definition.
Parameter[([(Guid])]) | Obtains the parameter of this type with a given GUID for a shared parameter.
Parameter[([(String])]) | Obtains the parameter of this type with a given name.

See Also

FamilyManager Class
FamilyManager Members
Autodesk.Revit Namespace


Parameter Property (BuiltInParameter)

[image]

Revit 2010 API
FamilyManager..::.Parameter Property (BuiltInParameter)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given parameter id.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyParameter Parameter[
    BuiltInParameter parameterId
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    parameterId As BuiltInParameter _
) As FamilyParameter
Visual C++
public:
property FamilyParameter^ Parameter[BuiltInParameter parameterId] {
    FamilyParameter^ get (BuiltInParameter parameterId);
}

Parameters

parameterId
Type: Autodesk.Revit.Parameters..::.BuiltInParameter

Remarks

Returns null if the parameter is not found.

See Also

FamilyManager Class
Parameter Overload
Autodesk.Revit Namespace


Parameter Property (Definition)

[image]

Revit 2010 API
FamilyManager..::.Parameter Property (Definition)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given definition.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyParameter Parameter[
    Definition definition
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    definition As Definition _
) As FamilyParameter
Visual C++
public:
property FamilyParameter^ Parameter[Definition^ definition] {
    FamilyParameter^ get (Definition^ definition);
}

Parameters

definition
Type: Autodesk.Revit.Parameters..::.Definition

Remarks

Returns null if the parameter is not found.

See Also

FamilyManager Class
Parameter Overload
Autodesk.Revit Namespace


Parameter Property (Guid)

[image]

Revit 2010 API
FamilyManager..::.Parameter Property (Guid)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given GUID for a shared parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyParameter Parameter[
    Guid guid
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    guid As Guid _
) As FamilyParameter
Visual C++
public:
property FamilyParameter^ Parameter[Guid guid] {
    FamilyParameter^ get (Guid guid);
}

Parameters

guid
Type: System..::.Guid

Remarks

Returns null if the parameter is not found. This method is used to retrieve a family parameter for a known shared parameter. When a shared parameter is created it is ssigned a Guid awhich will not change. This guid can be used to retrieve the piece of data from the element at a later time.

See Also

FamilyManager Class
Parameter Overload
Autodesk.Revit Namespace


Parameter Property (String)

[image]

Revit 2010 API
FamilyManager..::.Parameter Property (String)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyParameter Parameter[
    string parameterName
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    parameterName As String _
) As FamilyParameter
Visual C++
public:
property FamilyParameter^ Parameter[String^ parameterName] {
    FamilyParameter^ get (String^ parameterName);
}

Parameters

parameterName
Type: System..::.String

Remarks

Returns null if the parameter is not found.

See Also

FamilyManager Class
Parameter Overload
Autodesk.Revit Namespace


Parameters Property

[image]

Revit 2010 API
FamilyManager..::.Parameters Property
FamilyManager Class See Also Send Feedback
All family parameters in this family.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyParameterSet Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As FamilyParameterSet
Visual C++
public:
property FamilyParameterSet^ Parameters {
    FamilyParameterSet^ get ();
}

Remarks

These parameters will include the 'family parameter', 'shared parameter' and 'builtIn parameter' binding to the family types. Some parameters might be created as placeholders without a currently assigned value.

See Also

FamilyManager Class
Autodesk.Revit Namespace


Types Property

[image]

Revit 2010 API
FamilyManager..::.Types Property
FamilyManager Class Example See Also Send Feedback
All family types in the family.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyTypeSet Types { get; }
Visual Basic (Declaration)
Public ReadOnly Property Types As FamilyTypeSet
Visual C++
public:
property FamilyTypeSet^ Types {
    FamilyTypeSet^ get ();
}

Examples

CopyC#
public void GetFamilyTypesInFamily(Document familyDoc)
{
    if (familyDoc.IsFamilyDocument == true)
    {
        FamilyManager familyManager = familyDoc.FamilyManager;

        // get types in family
        string types = "Family Types: ";
        FamilyTypeSet familyTypes = familyManager.Types;
        FamilyTypeSetIterator familyTypesItor = familyTypes.ForwardIterator();
        familyTypesItor.Reset();
        while (familyTypesItor.MoveNext())
        {
            FamilyType familyType = familyTypesItor.Current as FamilyType;
            types += "\n" + familyType.Name;
        }
        MessageBox.Show(types, "Revit");
    }
}
CopyVB.NET
Public Sub GetFamilyTypesInFamily(ByVal familyDoc As Document)
    If familyDoc.IsFamilyDocument = True Then
        Dim familyManager As FamilyManager = familyDoc.FamilyManager

        ' get types in family
        Dim types As String = "Family Types: "
        Dim familyTypes As FamilyTypeSet = familyManager.Types
        Dim familyTypesItor As FamilyTypeSetIterator = familyTypes.ForwardIterator()
        familyTypesItor.Reset()
        While familyTypesItor.MoveNext()
            Dim familyType As FamilyType = TryCast(familyTypesItor.Current, FamilyType)
            types += vbLf & familyType.Name
        End While
        MessageBox.Show(types, "Revit")
    End If
End Sub

See Also

FamilyManager Class
Autodesk.Revit Namespace


FamilyParameter Class

[image]

Revit 2010 API
FamilyParameter Class
Members See Also Send Feedback
The family parameter object.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FamilyParameter : APIObject
Visual Basic (Declaration)
Public Class FamilyParameter _
    Inherits APIObject
Visual C++
public ref class FamilyParameter : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.FamilyParameter

See Also

FamilyParameter Members
Autodesk.Revit Namespace


FamilyParameter Members

[image] [image]

Revit 2010 API
FamilyParameter Members
FamilyParameter Class Constructors Methods Properties See Also Send Feedback

The FamilyParameter type exposes the following members.

Constructors

Name | Description
FamilyParameter | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssociatedParameters | The parameters from elements in the family which are associated to this parameter.
CanAssignFormula | Indicates if this parameter can be assigned a formula.
Definition | The definition.
DisplayUnitType | The display unit type.
Formula | The formula.
IsDeterminedByFormula | Indicates if the parameter is determined by formula.
IsInstance | Indicates if the parameter is instance or type.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
StorageType | The storage type describes the type that is used internally within the parameter to store its value.

See Also

FamilyParameter Class
Autodesk.Revit Namespace


FamilyParameter Constructor

[image]

Revit 2010 API
FamilyParameter Constructor
FamilyParameter Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyParameter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilyParameter()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilyParameter Class
Autodesk.Revit Namespace


FamilyParameter Methods

[image] [image]

Revit 2010 API
FamilyParameter Methods
FamilyParameter Class See Also Send Feedback

The FamilyParameter type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyParameter Class
Autodesk.Revit Namespace


FamilyParameter Properties

[image] [image]

Revit 2010 API
FamilyParameter Properties
FamilyParameter Class See Also Send Feedback

The FamilyParameter type exposes the following members.

Properties

Name | Description
AssociatedParameters | The parameters from elements in the family which are associated to this parameter.
CanAssignFormula | Indicates if this parameter can be assigned a formula.
Definition | The definition.
DisplayUnitType | The display unit type.
Formula | The formula.
IsDeterminedByFormula | Indicates if the parameter is determined by formula.
IsInstance | Indicates if the parameter is instance or type.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
StorageType | The storage type describes the type that is used internally within the parameter to store its value.

See Also

FamilyParameter Class
Autodesk.Revit Namespace


AssociatedParameters Property

[image]

Revit 2010 API
FamilyParameter..::.AssociatedParameters Property
FamilyParameter Class See Also Send Feedback
The parameters from elements in the family which are associated to this parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterSet AssociatedParameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssociatedParameters As ParameterSet
Visual C++
public:
property ParameterSet^ AssociatedParameters {
    ParameterSet^ get ();
}

See Also

FamilyParameter Class
Autodesk.Revit Namespace


CanAssignFormula Property

[image]

Revit 2010 API
FamilyParameter..::.CanAssignFormula Property
FamilyParameter Class See Also Send Feedback
Indicates if this parameter can be assigned a formula.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool CanAssignFormula { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanAssignFormula As Boolean
Visual C++
public:
property bool CanAssignFormula {
    bool get ();
}

See Also

FamilyParameter Class
Autodesk.Revit Namespace


Definition Property

[image]

Revit 2010 API
FamilyParameter..::.Definition Property
FamilyParameter Class See Also Send Feedback
The definition.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Definition Definition { get; }
Visual Basic (Declaration)
Public ReadOnly Property Definition As Definition
Visual C++
public:
property Definition^ Definition {
    Definition^ get ();
}

See Also

FamilyParameter Class
Autodesk.Revit Namespace


DisplayUnitType Property

[image]

Revit 2010 API
FamilyParameter..::.DisplayUnitType Property
FamilyParameter Class See Also Send Feedback
The display unit type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DisplayUnitType DisplayUnitType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayUnitType As DisplayUnitType
Visual C++
public:
property DisplayUnitType DisplayUnitType {
    DisplayUnitType get ();
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if this parameter is not of value type.

See Also

FamilyParameter Class
Autodesk.Revit Namespace


Formula Property

[image]

Revit 2010 API
FamilyParameter..::.Formula Property
FamilyParameter Class See Also Send Feedback
The formula.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Formula { get; }
Visual Basic (Declaration)
Public ReadOnly Property Formula As String
Visual C++
public:
property String^ Formula {
    String^ get ();
}

Remarks

Returns null if there is no formula governing this parameter.

See Also

FamilyParameter Class
Autodesk.Revit Namespace


IsDeterminedByFormula Property

[image]

Revit 2010 API
FamilyParameter..::.IsDeterminedByFormula Property
FamilyParameter Class See Also Send Feedback
Indicates if the parameter is determined by formula.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsDeterminedByFormula { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDeterminedByFormula As Boolean
Visual C++
public:
property bool IsDeterminedByFormula {
    bool get ();
}

Remarks

The parameter is read only if it is determined by formula.

See Also

FamilyParameter Class
Autodesk.Revit Namespace


IsInstance Property

[image]

Revit 2010 API
FamilyParameter..::.IsInstance Property
FamilyParameter Class See Also Send Feedback
Indicates if the parameter is instance or type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsInstance { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInstance As Boolean
Visual C++
public:
property bool IsInstance {
    bool get ();
}

See Also

FamilyParameter Class
Autodesk.Revit Namespace


StorageType Property

[image]

Revit 2010 API
FamilyParameter..::.StorageType Property
FamilyParameter Class See Also Send Feedback
The storage type describes the type that is used internally within the parameter to store its value.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public StorageType StorageType { get; }
Visual Basic (Declaration)
Public ReadOnly Property StorageType As StorageType
Visual C++
public:
property StorageType StorageType {
    StorageType get ();
}

Remarks

The property will return one of the following possibilities: String, Integer, Double or ElementId. Based on the value of this property the correct access and set methods should be used to retrieve and set the parameter's data value.

See Also

FamilyParameter Class
Autodesk.Revit Namespace


FamilyParameterSet Class

[image]

Revit 2010 API
FamilyParameterSet Class
Members See Also Send Feedback
A set that contains FamilyParameter objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FamilyParameterSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class FamilyParameterSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FamilyParameterSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.FamilyParameterSet

See Also

FamilyParameterSet Members
Autodesk.Revit Namespace


FamilyParameterSet Members

[image] [image]

Revit 2010 API
FamilyParameterSet Members
FamilyParameterSet Class Constructors Methods Properties See Also Send Feedback

The FamilyParameterSet type exposes the following members.

Constructors

Name | Description
FamilyParameterSet | Initializes a new instance of the FamilyParameterSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

FamilyParameterSet Class
Autodesk.Revit Namespace


FamilyParameterSet Constructor

[image]

Revit 2010 API
FamilyParameterSet Constructor
FamilyParameterSet Class See Also Send Feedback
Initializes a new instance of the FamilyParameterSet class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyParameterSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilyParameterSet()

See Also

FamilyParameterSet Class
Autodesk.Revit Namespace


FamilyParameterSet Methods

[image] [image]

Revit 2010 API
FamilyParameterSet Methods
FamilyParameterSet Class See Also Send Feedback

The FamilyParameterSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyParameterSet Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
FamilyParameterSet..::.Clear Method
FamilyParameterSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FamilyParameterSet Class
Autodesk.Revit Namespace


Contains Method

[image]

Revit 2010 API
FamilyParameterSet..::.Contains Method
FamilyParameterSet Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    FamilyParameter item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As FamilyParameter _
) As Boolean
Visual C++
public:
virtual bool Contains(
    FamilyParameter^ item
)

Parameters

item
Type: Autodesk.Revit..::.FamilyParameter

See Also

FamilyParameterSet Class
Autodesk.Revit Namespace


Erase Method

[image]

Revit 2010 API
FamilyParameterSet..::.Erase Method
FamilyParameterSet Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    FamilyParameter item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As FamilyParameter _
) As Integer
Visual C++
public:
virtual int Erase(
    FamilyParameter^ item
)

Parameters

item
Type: Autodesk.Revit..::.FamilyParameter

See Also

FamilyParameterSet Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
FamilyParameterSet..::.ForwardIterator Method
FamilyParameterSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual FamilyParameterSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As FamilyParameterSetIterator
Visual C++
public:
virtual FamilyParameterSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

FamilyParameterSet Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
FamilyParameterSet..::.GetEnumerator Method
FamilyParameterSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

FamilyParameterSet Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
FamilyParameterSet..::.Insert Method
FamilyParameterSet Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    FamilyParameter item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As FamilyParameter _
) As Boolean
Visual C++
public:
virtual bool Insert(
    FamilyParameter^ item
)

Parameters

item
Type: Autodesk.Revit..::.FamilyParameter

See Also

FamilyParameterSet Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
FamilyParameterSet..::.ReverseIterator Method
FamilyParameterSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual FamilyParameterSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As FamilyParameterSetIterator
Visual C++
public:
virtual FamilyParameterSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

FamilyParameterSet Class
Autodesk.Revit Namespace


FamilyParameterSet Properties

[image] [image]

Revit 2010 API
FamilyParameterSet Properties
FamilyParameterSet Class See Also Send Feedback

The FamilyParameterSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

FamilyParameterSet Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
FamilyParameterSet..::.IsEmpty Property
FamilyParameterSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FamilyParameterSet Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
FamilyParameterSet..::.Size Property
FamilyParameterSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FamilyParameterSet Class
Autodesk.Revit Namespace


FamilyParameterSetIterator Class

[image]

Revit 2010 API
FamilyParameterSetIterator Class
Members See Also Send Feedback
An iterator to a FamilyParameter set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class FamilyParameterSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class FamilyParameterSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FamilyParameterSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.FamilyParameterSetIterator

See Also

FamilyParameterSetIterator Members
Autodesk.Revit Namespace


FamilyParameterSetIterator Members

[image] [image]

Revit 2010 API
FamilyParameterSetIterator Members
FamilyParameterSetIterator Class Constructors Methods Properties See Also Send Feedback

The FamilyParameterSetIterator type exposes the following members.

Constructors

Name | Description
FamilyParameterSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyParameterSetIterator Class
Autodesk.Revit Namespace


FamilyParameterSetIterator Constructor

[image]

Revit 2010 API
FamilyParameterSetIterator Constructor
FamilyParameterSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyParameterSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilyParameterSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilyParameterSetIterator Class
Autodesk.Revit Namespace


FamilyParameterSetIterator Methods

[image] [image]

Revit 2010 API
FamilyParameterSetIterator Methods
FamilyParameterSetIterator Class See Also Send Feedback

The FamilyParameterSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyParameterSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
FamilyParameterSetIterator..::.MoveNext Method
FamilyParameterSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FamilyParameterSetIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
FamilyParameterSetIterator..::.Reset Method
FamilyParameterSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FamilyParameterSetIterator Class
Autodesk.Revit Namespace


FamilyParameterSetIterator Properties

[image] [image]

Revit 2010 API
FamilyParameterSetIterator Properties
FamilyParameterSetIterator Class See Also Send Feedback

The FamilyParameterSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyParameterSetIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
FamilyParameterSetIterator..::.Current Property
FamilyParameterSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FamilyParameterSetIterator Class
Autodesk.Revit Namespace


FamilySource Enumeration

[image]

Revit 2010 API
FamilySource Enumeration
See Also Send Feedback
Describes which version of the family to be loaded.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum FamilySource
Visual Basic (Declaration)
Public Enumeration FamilySource
Visual C++
public enum class FamilySource

Members

Member name | Description
Family | Loading the family from current family document.
Project | Loading the family from target project document.

See Also

Autodesk.Revit Namespace


FamilySymbolProfile Class

[image]

Revit 2010 API
FamilySymbolProfile Class
Members See Also Send Feedback
Represents a family symbol based profile for sweep or swept blend elements.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FamilySymbolProfile : SweepProfile
Visual Basic (Declaration)
Public Class FamilySymbolProfile _
    Inherits SweepProfile
Visual C++
public ref class FamilySymbolProfile : public SweepProfile

Remarks

Use objects of this type in methods as NewSweep and NewSweptBlend to create the profile.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.SweepProfile
Autodesk.Revit..::.FamilySymbolProfile

See Also

FamilySymbolProfile Members
Autodesk.Revit Namespace


FamilySymbolProfile Members

[image] [image]

Revit 2010 API
FamilySymbolProfile Members
FamilySymbolProfile Class Constructors Methods Properties See Also Send Feedback

The FamilySymbolProfile type exposes the following members.

Constructors

Name | Description
FamilySymbolProfile | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Angle | The angle of the rotation of the profile in radians.
IsFlipped | Indicates if the symbol profile is flipped or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Profile | Returns the family symbol of the profile.
XOffset | The offset of the profile to the origin of the sketch plane in the X direction.
YOffset | The offset of the profile to the origin of the sketch plane in the Y direction.

See Also

FamilySymbolProfile Class
Autodesk.Revit Namespace


FamilySymbolProfile Constructor

[image]

Revit 2010 API
FamilySymbolProfile Constructor
FamilySymbolProfile Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbolProfile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilySymbolProfile()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilySymbolProfile Class
Autodesk.Revit Namespace


FamilySymbolProfile Methods

[image] [image]

Revit 2010 API
FamilySymbolProfile Methods
FamilySymbolProfile Class See Also Send Feedback

The FamilySymbolProfile type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilySymbolProfile Class
Autodesk.Revit Namespace


FamilySymbolProfile Properties

[image] [image]

Revit 2010 API
FamilySymbolProfile Properties
FamilySymbolProfile Class See Also Send Feedback

The FamilySymbolProfile type exposes the following members.

Properties

Name | Description
Angle | The angle of the rotation of the profile in radians.
IsFlipped | Indicates if the symbol profile is flipped or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Profile | Returns the family symbol of the profile.
XOffset | The offset of the profile to the origin of the sketch plane in the X direction.
YOffset | The offset of the profile to the origin of the sketch plane in the Y direction.

See Also

FamilySymbolProfile Class
Autodesk.Revit Namespace


Angle Property

[image]

Revit 2010 API
FamilySymbolProfile..::.Angle Property
FamilySymbolProfile Class See Also Send Feedback
The angle of the rotation of the profile in radians.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Double
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

See Also

FamilySymbolProfile Class
Autodesk.Revit Namespace


IsFlipped Property

[image]

Revit 2010 API
FamilySymbolProfile..::.IsFlipped Property
FamilySymbolProfile Class See Also Send Feedback
Indicates if the symbol profile is flipped or not.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsFlipped { get; set; }
Visual Basic (Declaration)
Public Property IsFlipped As Boolean
Visual C++
public:
property bool IsFlipped {
    bool get ();
    void set (bool value);
}

See Also

FamilySymbolProfile Class
Autodesk.Revit Namespace


Profile Property

[image]

Revit 2010 API
FamilySymbolProfile..::.Profile Property
FamilySymbolProfile Class See Also Send Feedback
Returns the family symbol of the profile.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbol Profile { get; set; }
Visual Basic (Declaration)
Public Property Profile As FamilySymbol
Visual C++
public:
property FamilySymbol^ Profile {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

The symbol must of the category BuiltInCategory::OST_ProfileFamilies.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the argument is null.
System..::.ArgumentException | Thrown when the category of argument is not BuiltInCategory::OST_ProfileFamilies.

See Also

FamilySymbolProfile Class
Autodesk.Revit Namespace


XOffset Property

[image]

Revit 2010 API
FamilySymbolProfile..::.XOffset Property
FamilySymbolProfile Class See Also Send Feedback
The offset of the profile to the origin of the sketch plane in the X direction.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double XOffset { get; set; }
Visual Basic (Declaration)
Public Property XOffset As Double
Visual C++
public:
property double XOffset {
    double get ();
    void set (double value);
}

See Also

FamilySymbolProfile Class
Autodesk.Revit Namespace


YOffset Property

[image]

Revit 2010 API
FamilySymbolProfile..::.YOffset Property
FamilySymbolProfile Class See Also Send Feedback
The offset of the profile to the origin of the sketch plane in the Y direction.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double YOffset { get; set; }
Visual Basic (Declaration)
Public Property YOffset As Double
Visual C++
public:
property double YOffset {
    double get ();
    void set (double value);
}

See Also

FamilySymbolProfile Class
Autodesk.Revit Namespace


FamilyType Class

[image]

Revit 2010 API
FamilyType Class
Members See Also Send Feedback
The family type object provides read access to the values of family parameters for this type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FamilyType : APIObject
Visual Basic (Declaration)
Public Class FamilyType _
    Inherits APIObject
Visual C++
public ref class FamilyType : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.FamilyType

See Also

FamilyType Members
Autodesk.Revit Namespace


FamilyType Members

[image] [image]

Revit 2010 API
FamilyType Members
FamilyType Class Constructors Methods Properties See Also Send Feedback

The FamilyType type exposes the following members.

Constructors

Name | Description
FamilyType | For Internal Use Only.

Methods

Name | Description
AsDouble | Provides access to the double precision number of the given family parameter.
AsElementId | Provides access to the ElementId stored in the given family parameter.
AsInteger | Provides access to the integer number of the given family parameter.
AsString | Provides access to the string contents of the given family parameter.
AsValueString | Provides access to value as a string with unit in the given family parameter.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasValue | Indicates if this family parameter has an assigned value or not.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | The name of the family type.

See Also

FamilyType Class
Autodesk.Revit Namespace


FamilyType Constructor

[image]

Revit 2010 API
FamilyType Constructor
FamilyType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilyType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilyType Class
Autodesk.Revit Namespace


FamilyType Methods

[image] [image]

Revit 2010 API
FamilyType Methods
FamilyType Class See Also Send Feedback

The FamilyType type exposes the following members.

Methods

Name | Description
AsDouble | Provides access to the double precision number of the given family parameter.
AsElementId | Provides access to the ElementId stored in the given family parameter.
AsInteger | Provides access to the integer number of the given family parameter.
AsString | Provides access to the string contents of the given family parameter.
AsValueString | Provides access to value as a string with unit in the given family parameter.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasValue | Indicates if this family parameter has an assigned value or not.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyType Class
Autodesk.Revit Namespace


AsDouble Method

[image]

Revit 2010 API
FamilyType..::.AsDouble Method
FamilyType Class See Also Send Feedback
Provides access to the double precision number of the given family parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Nullable<double> AsDouble(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function AsDouble ( _
    familyParameter As FamilyParameter _
) As Nullable(Of Double)
Visual C++
public:
Nullable<double> AsDouble(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter

Return Value

The double value contained in the parameter. Returns a nullable object without value if the storage type of the input argument is not double type or this parameter has no value.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,

See Also

FamilyType Class
Autodesk.Revit Namespace


AsElementId Method

[image]

Revit 2010 API
FamilyType..::.AsElementId Method
FamilyType Class See Also Send Feedback
Provides access to the ElementId stored in the given family parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementId AsElementId(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function AsElementId ( _
    familyParameter As FamilyParameter _
) As ElementId
Visual C++
public:
ElementId AsElementId(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter

Return Value

The ElementId contained in the parameter.Returns an invalid element id if the storage type of the input argument is ElementId type or this parameter has no value.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,

See Also

FamilyType Class
Autodesk.Revit Namespace


AsInteger Method

[image]

Revit 2010 API
FamilyType..::.AsInteger Method
FamilyType Class See Also Send Feedback
Provides access to the integer number of the given family parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Nullable<int> AsInteger(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function AsInteger ( _
    familyParameter As FamilyParameter _
) As Nullable(Of Integer)
Visual C++
public:
Nullable<int> AsInteger(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter

Return Value

The integer value contained in the parameter. Returns a nullable object without value if the storage type of the input argument is not integer type or this parameter has no value.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,

See Also

FamilyType Class
Autodesk.Revit Namespace


AsString Method

[image]

Revit 2010 API
FamilyType..::.AsString Method
FamilyType Class See Also Send Feedback
Provides access to the string contents of the given family parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string AsString(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function AsString ( _
    familyParameter As FamilyParameter _
) As String
Visual C++
public:
String^ AsString(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter

Return Value

The string contained in the parameter. Returns null if the storage type of the input argument is not string type or this parameter has no value.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,

See Also

FamilyType Class
Autodesk.Revit Namespace


AsValueString Method

[image]

Revit 2010 API
FamilyType..::.AsValueString Method
FamilyType Class See Also Send Feedback
Provides access to value as a string with unit in the given family parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string AsValueString(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function AsValueString ( _
    familyParameter As FamilyParameter _
) As String
Visual C++
public:
String^ AsValueString(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter

Return Value

The string that represents the parameter value with unit.

Remarks

The method only applies to parameters of value types. If the parameter has no value or does not contain a numeric value, the method returns a null pointer.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.ArgumentException | Thrown if the input argument-"familyParameter"-is invalid.

See Also

FamilyType Class
Autodesk.Revit Namespace


HasValue Method

[image]

Revit 2010 API
FamilyType..::.HasValue Method
FamilyType Class See Also Send Feedback
Indicates if this family parameter has an assigned value or not.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool HasValue(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function HasValue ( _
    familyParameter As FamilyParameter _
) As Boolean
Visual C++
public:
bool HasValue(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.ArgumentException | Thrown if the input argument-"familyParameter"-is invalid.

See Also

FamilyType Class
Autodesk.Revit Namespace


FamilyType Properties

[image] [image]

Revit 2010 API
FamilyType Properties
FamilyType Class See Also Send Feedback

The FamilyType type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | The name of the family type.

See Also

FamilyType Class
Autodesk.Revit Namespace


Name Property

[image]

Revit 2010 API
FamilyType..::.Name Property
FamilyType Class See Also Send Feedback
The name of the family type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

FamilyType Class
Autodesk.Revit Namespace


FamilyTypeSet Class

[image]

Revit 2010 API
FamilyTypeSet Class
Members See Also Send Feedback
A set that contains FamilyType objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FamilyTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class FamilyTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FamilyTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.FamilyTypeSet

See Also

FamilyTypeSet Members
Autodesk.Revit Namespace


FamilyTypeSet Members

[image] [image]

Revit 2010 API
FamilyTypeSet Members
FamilyTypeSet Class Constructors Methods Properties See Also Send Feedback

The FamilyTypeSet type exposes the following members.

Constructors

Name | Description
FamilyTypeSet | Initializes a new instance of the FamilyTypeSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

FamilyTypeSet Class
Autodesk.Revit Namespace


FamilyTypeSet Constructor

[image]

Revit 2010 API
FamilyTypeSet Constructor
FamilyTypeSet Class See Also Send Feedback
Initializes a new instance of the FamilyTypeSet class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilyTypeSet()

See Also

FamilyTypeSet Class
Autodesk.Revit Namespace


FamilyTypeSet Methods

[image] [image]

Revit 2010 API
FamilyTypeSet Methods
FamilyTypeSet Class See Also Send Feedback

The FamilyTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyTypeSet Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
FamilyTypeSet..::.Clear Method
FamilyTypeSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FamilyTypeSet Class
Autodesk.Revit Namespace


Contains Method

[image]

Revit 2010 API
FamilyTypeSet..::.Contains Method
FamilyTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    FamilyType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As FamilyType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    FamilyType^ item
)

Parameters

item
Type: Autodesk.Revit..::.FamilyType

See Also

FamilyTypeSet Class
Autodesk.Revit Namespace


Erase Method

[image]

Revit 2010 API
FamilyTypeSet..::.Erase Method
FamilyTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    FamilyType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As FamilyType _
) As Integer
Visual C++
public:
virtual int Erase(
    FamilyType^ item
)

Parameters

item
Type: Autodesk.Revit..::.FamilyType

See Also

FamilyTypeSet Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
FamilyTypeSet..::.ForwardIterator Method
FamilyTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual FamilyTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As FamilyTypeSetIterator
Visual C++
public:
virtual FamilyTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

FamilyTypeSet Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
FamilyTypeSet..::.GetEnumerator Method
FamilyTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

FamilyTypeSet Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
FamilyTypeSet..::.Insert Method
FamilyTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    FamilyType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As FamilyType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    FamilyType^ item
)

Parameters

item
Type: Autodesk.Revit..::.FamilyType

See Also

FamilyTypeSet Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
FamilyTypeSet..::.ReverseIterator Method
FamilyTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual FamilyTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As FamilyTypeSetIterator
Visual C++
public:
virtual FamilyTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

FamilyTypeSet Class
Autodesk.Revit Namespace


FamilyTypeSet Properties

[image] [image]

Revit 2010 API
FamilyTypeSet Properties
FamilyTypeSet Class See Also Send Feedback

The FamilyTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

FamilyTypeSet Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
FamilyTypeSet..::.IsEmpty Property
FamilyTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FamilyTypeSet Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
FamilyTypeSet..::.Size Property
FamilyTypeSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FamilyTypeSet Class
Autodesk.Revit Namespace


FamilyTypeSetIterator Class

[image]

Revit 2010 API
FamilyTypeSetIterator Class
Members See Also Send Feedback
An iterator to a FamilyType set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class FamilyTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class FamilyTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FamilyTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.FamilyTypeSetIterator

See Also

FamilyTypeSetIterator Members
Autodesk.Revit Namespace


FamilyTypeSetIterator Members

[image] [image]

Revit 2010 API
FamilyTypeSetIterator Members
FamilyTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The FamilyTypeSetIterator type exposes the following members.

Constructors

Name | Description
FamilyTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyTypeSetIterator Class
Autodesk.Revit Namespace


FamilyTypeSetIterator Constructor

[image]

Revit 2010 API
FamilyTypeSetIterator Constructor
FamilyTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilyTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilyTypeSetIterator Class
Autodesk.Revit Namespace


FamilyTypeSetIterator Methods

[image] [image]

Revit 2010 API
FamilyTypeSetIterator Methods
FamilyTypeSetIterator Class See Also Send Feedback

The FamilyTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyTypeSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
FamilyTypeSetIterator..::.MoveNext Method
FamilyTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FamilyTypeSetIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
FamilyTypeSetIterator..::.Reset Method
FamilyTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FamilyTypeSetIterator Class
Autodesk.Revit Namespace


FamilyTypeSetIterator Properties

[image] [image]

Revit 2010 API
FamilyTypeSetIterator Properties
FamilyTypeSetIterator Class See Also Send Feedback

The FamilyTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyTypeSetIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
FamilyTypeSetIterator..::.Current Property
FamilyTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FamilyTypeSetIterator Class
Autodesk.Revit Namespace


FBXExportOptions Class

[image]

Revit 2010 API
FBXExportOptions Class
Members See Also Send Feedback
3D-Studio Max (FBX) Export options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FBXExportOptions
Visual Basic (Declaration)
Public Class FBXExportOptions
Visual C++
public ref class FBXExportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.FBXExportOptions

See Also

FBXExportOptions Members
Autodesk.Revit Namespace


FBXExportOptions Members

[image] [image]

Revit 2010 API
FBXExportOptions Members
FBXExportOptions Class Constructors Methods Properties See Also Send Feedback

The FBXExportOptions type exposes the following members.

Constructors

Name | Description
FBXExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
StopOnError | Whether export process should stop when a view fails to export.

See Also

FBXExportOptions Class
Autodesk.Revit Namespace


FBXExportOptions Constructor

[image]

Revit 2010 API
FBXExportOptions Constructor
FBXExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FBXExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FBXExportOptions()

See Also

FBXExportOptions Class
Autodesk.Revit Namespace


FBXExportOptions Methods

[image] [image]

Revit 2010 API
FBXExportOptions Methods
FBXExportOptions Class See Also Send Feedback

The FBXExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FBXExportOptions Class
Autodesk.Revit Namespace


FBXExportOptions Properties

[image] [image]

Revit 2010 API
FBXExportOptions Properties
FBXExportOptions Class See Also Send Feedback

The FBXExportOptions type exposes the following members.

Properties

Name | Description
StopOnError | Whether export process should stop when a view fails to export.

See Also

FBXExportOptions Class
Autodesk.Revit Namespace


StopOnError Property

[image]

Revit 2010 API
FBXExportOptions..::.StopOnError Property
FBXExportOptions Class See Also Send Feedback
Whether export process should stop when a view fails to export.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool StopOnError { get; set; }
Visual Basic (Declaration)
Public Property StopOnError As Boolean
Visual C++
public:
property bool StopOnError {
    bool get ();
    void set (bool value);
}

Remarks

If set to false, the export would continue until all views are processed. This option has an effect only when a set of more than one view is specified.

See Also

FBXExportOptions Class
Autodesk.Revit Namespace


FillPatternSet Class

[image]

Revit 2010 API
FillPatternSet Class
Members See Also Send Feedback
A set that contains FillPatterns.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FillPatternSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class FillPatternSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FillPatternSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.FillPatternSet

See Also

FillPatternSet Members
Autodesk.Revit Namespace


FillPatternSet Members

[image] [image]

Revit 2010 API
FillPatternSet Members
FillPatternSet Class Constructors Methods Properties See Also Send Feedback

The FillPatternSet type exposes the following members.

Constructors

Name | Description
FillPatternSet | Initializes a new instance of the FillPatternSet class

Methods

Name | Description
Clear | Removes every fill pattern from the set, rendering it empty.
Contains | Tests for the existence of a fill pattern within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified fill pattern from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified fill pattern into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of fill patterns that are in the set.

See Also

FillPatternSet Class
Autodesk.Revit Namespace


FillPatternSet Constructor

[image]

Revit 2010 API
FillPatternSet Constructor
FillPatternSet Class See Also Send Feedback
Initializes a new instance of the FillPatternSet class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FillPatternSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FillPatternSet()

See Also

FillPatternSet Class
Autodesk.Revit Namespace


FillPatternSet Methods

[image] [image]

Revit 2010 API
FillPatternSet Methods
FillPatternSet Class See Also Send Feedback

The FillPatternSet type exposes the following members.

Methods

Name | Description
Clear | Removes every fill pattern from the set, rendering it empty.
Contains | Tests for the existence of a fill pattern within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified fill pattern from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified fill pattern into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FillPatternSet Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
FillPatternSet..::.Clear Method
FillPatternSet Class See Also Send Feedback
Removes every fill pattern from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FillPatternSet Class
Autodesk.Revit Namespace


Contains Method

[image]

Revit 2010 API
FillPatternSet..::.Contains Method
FillPatternSet Class See Also Send Feedback
Tests for the existence of a fill pattern within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    FillPattern item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As FillPattern _
) As Boolean
Visual C++
public:
virtual bool Contains(
    FillPattern^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.FillPattern
The fill pattern to be searched for.

Return Value

The Contains method returns True if the fill pattern is within the set, otherwise False.

See Also

FillPatternSet Class
Autodesk.Revit Namespace


Erase Method

[image]

Revit 2010 API
FillPatternSet..::.Erase Method
FillPatternSet Class See Also Send Feedback
Removes a specified fill pattern from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    FillPattern item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As FillPattern _
) As Integer
Visual C++
public:
virtual int Erase(
    FillPattern^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.FillPattern
The fill pattern to be erased.

Return Value

The number of fill patterns that were erased from the set.

See Also

FillPatternSet Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
FillPatternSet..::.ForwardIterator Method
FillPatternSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual FillPatternSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As FillPatternSetIterator
Visual C++
public:
virtual FillPatternSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

FillPatternSet Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
FillPatternSet..::.GetEnumerator Method
FillPatternSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

FillPatternSet Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
FillPatternSet..::.Insert Method
FillPatternSet Class See Also Send Feedback
Insert the specified fill pattern into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    FillPattern item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As FillPattern _
) As Boolean
Visual C++
public:
virtual bool Insert(
    FillPattern^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.FillPattern
The fill pattern to be inserted into the set.

Return Value

Returns whether the fill pattern was inserted into the set.

See Also

FillPatternSet Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
FillPatternSet..::.ReverseIterator Method
FillPatternSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual FillPatternSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As FillPatternSetIterator
Visual C++
public:
virtual FillPatternSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

FillPatternSet Class
Autodesk.Revit Namespace


FillPatternSet Properties

[image] [image]

Revit 2010 API
FillPatternSet Properties
FillPatternSet Class See Also Send Feedback

The FillPatternSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of fill patterns that are in the set.

See Also

FillPatternSet Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
FillPatternSet..::.IsEmpty Property
FillPatternSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FillPatternSet Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
FillPatternSet..::.Size Property
FillPatternSet Class See Also Send Feedback
Returns the number of fill patterns that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FillPatternSet Class
Autodesk.Revit Namespace


FillPatternSetIterator Class

[image]

Revit 2010 API
FillPatternSetIterator Class
Members See Also Send Feedback
An iterator to a FillPattern set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class FillPatternSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class FillPatternSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FillPatternSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.FillPatternSetIterator

See Also

FillPatternSetIterator Members
Autodesk.Revit Namespace


FillPatternSetIterator Members

[image] [image]

Revit 2010 API
FillPatternSetIterator Members
FillPatternSetIterator Class Constructors Methods Properties See Also Send Feedback

The FillPatternSetIterator type exposes the following members.

Constructors

Name | Description
FillPatternSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FillPatternSetIterator Class
Autodesk.Revit Namespace


FillPatternSetIterator Constructor

[image]

Revit 2010 API
FillPatternSetIterator Constructor
FillPatternSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FillPatternSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FillPatternSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FillPatternSetIterator Class
Autodesk.Revit Namespace


FillPatternSetIterator Methods

[image] [image]

Revit 2010 API
FillPatternSetIterator Methods
FillPatternSetIterator Class See Also Send Feedback

The FillPatternSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FillPatternSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
FillPatternSetIterator..::.MoveNext Method
FillPatternSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FillPatternSetIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
FillPatternSetIterator..::.Reset Method
FillPatternSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FillPatternSetIterator Class
Autodesk.Revit Namespace


FillPatternSetIterator Properties

[image] [image]

Revit 2010 API
FillPatternSetIterator Properties
FillPatternSetIterator Class See Also Send Feedback

The FillPatternSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FillPatternSetIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
FillPatternSetIterator..::.Current Property
FillPatternSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FillPatternSetIterator Class
Autodesk.Revit Namespace


Filter Class

[image]

Revit 2010 API
Filter Class
Members See Also Send Feedback
Base class that represents all filters of other sub classes (such as TypeFilter, CategoryFilter, FamilyFilter, SymbolFilter, ParameterFilter, InstanceUsageFilter, WallUsageFilter, MaterialFilter or StructuralTypeFilter), this filter can be used to create single filter or filters combination. User can use overloaded &&, || and ! operators to create combination of filters. e.g. FamilyFilter && SymbolFilter && ParameterFilter, (FamilyFilter1 || FamilyFilter2) && ParameterFilter. Use this filter to retrieve elements which satisfy specified filter criterion within current document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class Filter : APIObject
Visual Basic (Declaration)
Public MustInherit Class Filter _
    Inherits APIObject
Visual C++
public ref class Filter abstract : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Filter
Autodesk.Revit..::.CategoryFilter
Autodesk.Revit..::.FamilyFilter
Autodesk.Revit..::.InstanceUsageFilter
Autodesk.Revit..::.LogicAndFilter
Autodesk.Revit..::.LogicNotFilter
Autodesk.Revit..::.LogicOrFilter
Autodesk.Revit..::.MaterialFilter
Autodesk.Revit..::.ParameterFilter
Autodesk.Revit..::.StructuralTypeFilter
Autodesk.Revit..::.SymbolFilter
Autodesk.Revit..::.TypeFilter
Autodesk.Revit..::.WallUsageFilter

See Also

Filter Members
Autodesk.Revit Namespace


Filter Members

[image] [image]

Revit 2010 API
Filter Members
Filter Class Constructors Methods Properties See Also Send Feedback

The Filter type exposes the following members.

Constructors

Name | Description
Filter | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
LogicalAnd | Overload operator && for new Logic-AND filter.
LogicalNot | Overload operator ! for new Logic-Not filter.
LogicalOr | Overload operator || for new Logic-OR filter.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Filter Class
Autodesk.Revit Namespace


Filter Constructor

[image]

Revit 2010 API
Filter Constructor
Filter Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Filter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Filter()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Filter Class
Autodesk.Revit Namespace


Filter Methods

[image] [image]

Revit 2010 API
Filter Methods
Filter Class See Also Send Feedback

The Filter type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
LogicalAnd | Overload operator && for new Logic-AND filter.
LogicalNot | Overload operator ! for new Logic-Not filter.
LogicalOr | Overload operator || for new Logic-OR filter.

See Also

Filter Class
Autodesk.Revit Namespace


LogicalAnd Operator

[image]

Revit 2010 API
Filter..::.LogicalAnd Operator
Filter Class See Also Send Feedback
Overload operator && for new Logic-AND filter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
C# does not support this operator.
Visual Basic (Declaration)
Visual Basic does not support this operator.
Visual C++
Visual C++ does not support this operator.

Parameters

leftFilter
Type: Autodesk.Revit..::.Filter
leftFilter which is left operand of Logic-AND operator.
rightFilter
Type: Autodesk.Revit..::.Filter
rightFilter which is right operand of Logic-AND operator.

Return Value

Returns a new LogicAndFilter object.

See Also

Filter Class
Autodesk.Revit Namespace


LogicalNot Operator

[image]

Revit 2010 API
Filter..::.LogicalNot Operator
Filter Class See Also Send Feedback
Overload operator ! for new Logic-Not filter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static LogicNotFilter operator !(
    Filter subFilter
)
Visual Basic (Declaration)
Public Shared Operator Not ( _
    subFilter As Filter _
) As LogicNotFilter
Visual C++
public:
static LogicNotFilter^ operator !(
    Filter^ subFilter
)

Parameters

subFilter
Type: Autodesk.Revit..::.Filter
subFilter which is an operand of Logic-NOT operator.

Return Value

Returns a new LogicNotFilter object.

See Also

Filter Class
Autodesk.Revit Namespace


LogicalOr Operator

[image]

Revit 2010 API
Filter..::.LogicalOr Operator
Filter Class See Also Send Feedback
Overload operator || for new Logic-OR filter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
C# does not support this operator.
Visual Basic (Declaration)
Visual Basic does not support this operator.
Visual C++
Visual C++ does not support this operator.

Parameters

leftFilter
Type: Autodesk.Revit..::.Filter
leftFilter which is left operand of Logic-OR operator.
rightFilter
Type: Autodesk.Revit..::.Filter
rightFilter which is right operand of Logic-OR operator.

Return Value

Returns a new LogicOrFilter object.

See Also

Filter Class
Autodesk.Revit Namespace


Filter Properties

[image] [image]

Revit 2010 API
Filter Properties
Filter Class See Also Send Feedback

The Filter type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Filter Class
Autodesk.Revit Namespace


FilterCriterion Class

[image]

Revit 2010 API
FilterCriterion Class
Members See Also Send Feedback
An object that defines the criteria as the filter for retrieving certain needed elements.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FilterCriterion : APIObject
Visual Basic (Declaration)
Public Class FilterCriterion _
    Inherits APIObject
Visual C++
public ref class FilterCriterion : public APIObject

Remarks

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.FilterCriterion

See Also

FilterCriterion Members
Autodesk.Revit Namespace


FilterCriterion Members

[image] [image]

Revit 2010 API
FilterCriterion Members
FilterCriterion Class Constructors Methods Properties See Also Send Feedback

The FilterCriterion type exposes the following members.

Constructors

Name | Description
FilterCriterion | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FilterType | Gets or sets the filter type of this criterion.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Parameter | Gets or sets the parameter of this criterion by builtin parameter.
ParameterID | Gets or sets the parameter of this criterion by parameter id.
ParameterValue | Gets or sets the parameter value of this criterion.

See Also

FilterCriterion Class
Autodesk.Revit Namespace


FilterCriterion Constructor

[image]

Revit 2010 API
FilterCriterion Constructor
FilterCriterion Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FilterCriterion()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FilterCriterion()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FilterCriterion Class
Autodesk.Revit Namespace


FilterCriterion Methods

[image] [image]

Revit 2010 API
FilterCriterion Methods
FilterCriterion Class See Also Send Feedback

The FilterCriterion type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterCriterion Class
Autodesk.Revit Namespace


FilterCriterion Properties

[image] [image]

Revit 2010 API
FilterCriterion Properties
FilterCriterion Class See Also Send Feedback

The FilterCriterion type exposes the following members.

Properties

Name | Description
FilterType | Gets or sets the filter type of this criterion.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Parameter | Gets or sets the parameter of this criterion by builtin parameter.
ParameterID | Gets or sets the parameter of this criterion by parameter id.
ParameterValue | Gets or sets the parameter value of this criterion.

See Also

FilterCriterion Class
Autodesk.Revit Namespace


FilterType Property

[image]

Revit 2010 API
FilterCriterion..::.FilterType Property
FilterCriterion Class See Also Send Feedback
Gets or sets the filter type of this criterion.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CriteriaFilterType FilterType { get; set; }
Visual Basic (Declaration)
Public Property FilterType As CriteriaFilterType
Visual C++
public:
property CriteriaFilterType FilterType {
    CriteriaFilterType get ();
    void set (CriteriaFilterType value);
}

Remarks

The filter type defines the relationship between the parameter of certain element and the parameter value which is specified by the property of ParameterValue.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the Filter Criterion is internally marked as read-only.

See Also

FilterCriterion Class
Autodesk.Revit Namespace


Parameter Property

[image]

Revit 2010 API
FilterCriterion..::.Parameter Property
FilterCriterion Class See Also Send Feedback
Gets or sets the parameter of this criterion by builtin parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BuiltInParameter Parameter { get; set; }
Visual Basic (Declaration)
Public Property Parameter As BuiltInParameter
Visual C++
public:
property BuiltInParameter Parameter {
    BuiltInParameter get ();
    void set (BuiltInParameter value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the Filter Criterion is internally marked as read-only.

See Also

FilterCriterion Class
Autodesk.Revit Namespace


ParameterID Property

[image]

Revit 2010 API
FilterCriterion..::.ParameterID Property
FilterCriterion Class See Also Send Feedback
Gets or sets the parameter of this criterion by parameter id.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementId ParameterID { get; set; }
Visual Basic (Declaration)
Public Property ParameterID As ElementId
Visual C++
public:
property ElementId ParameterID {
    ElementId get ();
    void set (ElementId value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the Filter Criterion is internally marked as read-only.

See Also

FilterCriterion Class
Autodesk.Revit Namespace


ParameterValue Property

[image]

Revit 2010 API
FilterCriterion..::.ParameterValue Property
FilterCriterion Class See Also Send Feedback
Gets or sets the parameter value of this criterion.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterStorage ParameterValue { get; set; }
Visual Basic (Declaration)
Public Property ParameterValue As ParameterStorage
Visual C++
public:
property ParameterStorage^ ParameterValue {
    ParameterStorage^ get ();
    void set (ParameterStorage^ value);
}

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter of ParameterStorage is null.
System..::.InvalidOperationException | Thrown when the Filter Criterion is internally marked as read-only.

See Also

FilterCriterion Class
Autodesk.Revit Namespace


FormArray Class

[image]

Revit 2010 API
FormArray Class
Members See Also Send Feedback
An array that contains form objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FormArray : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class FormArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FormArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.FormArray

See Also

FormArray Members
Autodesk.Revit Namespace


FormArray Members

[image] [image]

Revit 2010 API
FormArray Members
FormArray Class Constructors Methods Properties See Also Send Feedback

The FormArray type exposes the following members.

Constructors

Name | Description
FormArray | Initializes a new instance of the FormArray class

Methods

Name | Description
Append |
Clear | Removes every form from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a form at a specified index within the array.
Size | Returns the number of forms that are in the array.

See Also

FormArray Class
Autodesk.Revit Namespace


FormArray Constructor

[image]

Revit 2010 API
FormArray Constructor
FormArray Class See Also Send Feedback
Initializes a new instance of the FormArray class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FormArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FormArray()

See Also

FormArray Class
Autodesk.Revit Namespace


FormArray Methods

[image] [image]

Revit 2010 API
FormArray Methods
FormArray Class See Also Send Feedback

The FormArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every form from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormArray Class
Autodesk.Revit Namespace


Append Method

[image]

Revit 2010 API
FormArray..::.Append Method
FormArray Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    Form item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Form _
)
Visual C++
public:
virtual void Append(
    Form^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.Form

See Also

FormArray Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
FormArray..::.Clear Method
FormArray Class See Also Send Feedback
Removes every form from the array, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FormArray Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
FormArray..::.ForwardIterator Method
FormArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual FormArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As FormArrayIterator
Visual C++
public:
virtual FormArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

FormArray Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
FormArray..::.GetEnumerator Method
FormArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

FormArray Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
FormArray..::.Insert Method
FormArray Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    Form item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Form, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Form^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Elements..::.Form
index
Type: System..::.Int32

See Also

FormArray Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
FormArray..::.ReverseIterator Method
FormArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual FormArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As FormArrayIterator
Visual C++
public:
virtual FormArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

FormArray Class
Autodesk.Revit Namespace


FormArray Properties

[image] [image]

Revit 2010 API
FormArray Properties
FormArray Class See Also Send Feedback

The FormArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a form at a specified index within the array.
Size | Returns the number of forms that are in the array.

See Also

FormArray Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
FormArray..::.IsEmpty Property
FormArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

FormArray Class
Autodesk.Revit Namespace


Item Property

[image]

Revit 2010 API
FormArray..::.Item Property
FormArray Class See Also Send Feedback
Gets or sets a form at a specified index within the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Form Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Form
Visual C++
public:
virtual property Form^ Item[int index] {
    Form^ get (int index);
    void set (int index, Form^ value);
}

Parameters

index
Type: System..::.Int32
The index of the form to be set or retrieved.

Return Value

Returns the form at the specified index.

See Also

FormArray Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
FormArray..::.Size Property
FormArray Class See Also Send Feedback
Returns the number of forms that are in the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FormArray Class
Autodesk.Revit Namespace


FormArrayIterator Class

[image]

Revit 2010 API
FormArrayIterator Class
Members See Also Send Feedback
An iterator to a form array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class FormArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class FormArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FormArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.FormArrayIterator

See Also

FormArrayIterator Members
Autodesk.Revit Namespace


FormArrayIterator Members

[image] [image]

Revit 2010 API
FormArrayIterator Members
FormArrayIterator Class Constructors Methods Properties See Also Send Feedback

The FormArrayIterator type exposes the following members.

Constructors

Name | Description
FormArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FormArrayIterator Class
Autodesk.Revit Namespace


FormArrayIterator Constructor

[image]

Revit 2010 API
FormArrayIterator Constructor
FormArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FormArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FormArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FormArrayIterator Class
Autodesk.Revit Namespace


FormArrayIterator Methods

[image] [image]

Revit 2010 API
FormArrayIterator Methods
FormArrayIterator Class See Also Send Feedback

The FormArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormArrayIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
FormArrayIterator..::.MoveNext Method
FormArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FormArrayIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
FormArrayIterator..::.Reset Method
FormArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FormArrayIterator Class
Autodesk.Revit Namespace


FormArrayIterator Properties

[image] [image]

Revit 2010 API
FormArrayIterator Properties
FormArrayIterator Class See Also Send Feedback

The FormArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FormArrayIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
FormArrayIterator..::.Current Property
FormArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FormArrayIterator Class
Autodesk.Revit Namespace


FormatOptions Class

[image]

Revit 2010 API
FormatOptions Class
Members See Also Send Feedback
Contains the Unit information of current user selection of Unit within the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FormatOptions : APIObject
Visual Basic (Declaration)
Public Class FormatOptions _
    Inherits APIObject
Visual C++
public ref class FormatOptions : public APIObject

Remarks

The FormatOptions contains 5 item. Rounding and UnitSymbol properties depend on the Units propery.All these three properties provided set function, but it is more rigid on input.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.FormatOptions

See Also

FormatOptions Members
Autodesk.Revit Namespace


FormatOptions Members

[image] [image]

Revit 2010 API
FormatOptions Members
FormatOptions Class Constructors Methods Properties See Also Send Feedback

The FormatOptions type exposes the following members.

Constructors

Name | Description
FormatOptions | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Group | Retrieves the Group of Units Type that are currently selected.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Retrieves the Name of Units Type that are currently selected.
Rounding | Retrieves the Rounding/Accuracy of Units Type that are currently selected.
Units | Retrieves the Units Type that are currently selected.
Unitsymbol | Retrieves the Unit Symbol of Units Type that are currently selected.

See Also

FormatOptions Class
Autodesk.Revit Namespace


FormatOptions Constructor

[image]

Revit 2010 API
FormatOptions Constructor
FormatOptions Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FormatOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FormatOptions()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FormatOptions Class
Autodesk.Revit Namespace


FormatOptions Methods

[image] [image]

Revit 2010 API
FormatOptions Methods
FormatOptions Class See Also Send Feedback

The FormatOptions type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormatOptions Class
Autodesk.Revit Namespace


FormatOptions Properties

[image] [image]

Revit 2010 API
FormatOptions Properties
FormatOptions Class See Also Send Feedback

The FormatOptions type exposes the following members.

Properties

Name | Description
Group | Retrieves the Group of Units Type that are currently selected.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Retrieves the Name of Units Type that are currently selected.
Rounding | Retrieves the Rounding/Accuracy of Units Type that are currently selected.
Units | Retrieves the Units Type that are currently selected.
Unitsymbol | Retrieves the Unit Symbol of Units Type that are currently selected.

See Also

FormatOptions Class
Autodesk.Revit Namespace


Group Property

[image]

Revit 2010 API
FormatOptions..::.Group Property
FormatOptions Class See Also Send Feedback
Retrieves the Group of Units Type that are currently selected.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UnitGroup Group { get; }
Visual Basic (Declaration)
Public ReadOnly Property Group As UnitGroup
Visual C++
public:
property UnitGroup Group {
    UnitGroup get ();
}

Remarks

Commond or Structural, etc.

See Also

FormatOptions Class
Autodesk.Revit Namespace


Name Property

[image]

Revit 2010 API
FormatOptions..::.Name Property
FormatOptions Class See Also Send Feedback
Retrieves the Name of Units Type that are currently selected.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

Remarks

Get the Name of Units Type that are currently selected.

See Also

FormatOptions Class
Autodesk.Revit Namespace


Rounding Property

[image]

Revit 2010 API
FormatOptions..::.Rounding Property
FormatOptions Class See Also Send Feedback
Retrieves the Rounding/Accuracy of Units Type that are currently selected.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Rounding { get; set; }
Visual Basic (Declaration)
Public Property Rounding As Double
Visual C++
public:
property double Rounding {
    double get ();
    void set (double value);
}

Remarks

You can set a non-negative double value to Rounding property, if there is no this type in UI Combox, it will show us Custom value. and if you input a negative value, it will correct to 1.

See Also

FormatOptions Class
Autodesk.Revit Namespace


Units Property

[image]

Revit 2010 API
FormatOptions..::.Units Property
FormatOptions Class See Also Send Feedback
Retrieves the Units Type that are currently selected.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DisplayUnitType Units { get; set; }
Visual Basic (Declaration)
Public Property Units As DisplayUnitType
Visual C++
public:
property DisplayUnitType Units {
    DisplayUnitType get ();
    void set (DisplayUnitType value);
}

Remarks

The Units property returns the Units Type that were selected at the Format Options Dialog.

See Also

FormatOptions Class
Autodesk.Revit Namespace


Unitsymbol Property

[image]

Revit 2010 API
FormatOptions..::.Unitsymbol Property
FormatOptions Class See Also Send Feedback
Retrieves the Unit Symbol of Units Type that are currently selected.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UnitSymbolType Unitsymbol { get; set; }
Visual Basic (Declaration)
Public Property Unitsymbol As UnitSymbolType
Visual C++
public:
property UnitSymbolType Unitsymbol {
    UnitSymbolType get ();
    void set (UnitSymbolType value);
}

Remarks

You can set or get Unit Symbol of Units Type that are currently selected. If current DisplayUnitType do NOT support Unit Symbol and you have inputed as well, it will throw an InvalidOperationException. If current DisplayUnitType support, and you set a unfit enum value, it will throw an ArgumentOutOfRangeException.

See Also

FormatOptions Class
Autodesk.Revit Namespace


GBXMLExportOptions Class

[image]

Revit 2010 API
GBXMLExportOptions Class
Members See Also Send Feedback
Green-Building XML Export options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class GBXMLExportOptions
Visual Basic (Declaration)
Public Class GBXMLExportOptions
Visual C++
public ref class GBXMLExportOptions

Remarks

Not used currently. Reserved for future use

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.GBXMLExportOptions

See Also

GBXMLExportOptions Members
Autodesk.Revit Namespace


GBXMLExportOptions Members

[image] [image]

Revit 2010 API
GBXMLExportOptions Members
GBXMLExportOptions Class Constructors Methods See Also Send Feedback

The GBXMLExportOptions type exposes the following members.

Constructors

Name | Description
GBXMLExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GBXMLExportOptions Class
Autodesk.Revit Namespace


GBXMLExportOptions Constructor

[image]

Revit 2010 API
GBXMLExportOptions Constructor
GBXMLExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GBXMLExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GBXMLExportOptions()

See Also

GBXMLExportOptions Class
Autodesk.Revit Namespace


GBXMLExportOptions Methods

[image] [image]

Revit 2010 API
GBXMLExportOptions Methods
GBXMLExportOptions Class See Also Send Feedback

The GBXMLExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GBXMLExportOptions Class
Autodesk.Revit Namespace


GBXMLImportOptions Class

[image]

Revit 2010 API
GBXMLImportOptions Class
Members See Also Send Feedback
Import options for Green-Building XML format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class GBXMLImportOptions
Visual Basic (Declaration)
Public Class GBXMLImportOptions
Visual C++
public ref class GBXMLImportOptions

Remarks

Not used currently. Reserved for future use.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.GBXMLImportOptions

See Also

GBXMLImportOptions Members
Autodesk.Revit Namespace


GBXMLImportOptions Members

[image] [image]

Revit 2010 API
GBXMLImportOptions Members
GBXMLImportOptions Class Constructors Methods See Also Send Feedback

The GBXMLImportOptions type exposes the following members.

Constructors

Name | Description
GBXMLImportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GBXMLImportOptions Class
Autodesk.Revit Namespace


GBXMLImportOptions Constructor

[image]

Revit 2010 API
GBXMLImportOptions Constructor
GBXMLImportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GBXMLImportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GBXMLImportOptions()

See Also

GBXMLImportOptions Class
Autodesk.Revit Namespace


GBXMLImportOptions Methods

[image] [image]

Revit 2010 API
GBXMLImportOptions Methods
GBXMLImportOptions Class See Also Send Feedback

The GBXMLImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GBXMLImportOptions Class
Autodesk.Revit Namespace


GenericImportOptions Class

[image]

Revit 2010 API
GenericImportOptions Class
Members See Also Send Feedback
Generic Import options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class GenericImportOptions
Visual Basic (Declaration)
Public MustInherit Class GenericImportOptions
Visual C++
public ref class GenericImportOptions abstract

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.GenericImportOptions
Autodesk.Revit..::.CADImportOptions
Autodesk.Revit..::.ImageImportOptions

See Also

GenericImportOptions Members
Autodesk.Revit Namespace


GenericImportOptions Members

[image] [image]

Revit 2010 API
GenericImportOptions Members
GenericImportOptions Class Methods Properties See Also Send Feedback

The GenericImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
RefPoint | Reference point (in Revit) to which the image is going to be inserted.
View | A view into which the image is going to be imported.

See Also

GenericImportOptions Class
Autodesk.Revit Namespace


GenericImportOptions Methods

[image] [image]

Revit 2010 API
GenericImportOptions Methods
GenericImportOptions Class See Also Send Feedback

The GenericImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GenericImportOptions Class
Autodesk.Revit Namespace


GenericImportOptions Properties

[image] [image]

Revit 2010 API
GenericImportOptions Properties
GenericImportOptions Class See Also Send Feedback

The GenericImportOptions type exposes the following members.

Properties

Name | Description
RefPoint | Reference point (in Revit) to which the image is going to be inserted.
View | A view into which the image is going to be imported.

See Also

GenericImportOptions Class
Autodesk.Revit Namespace


RefPoint Property

[image]

Revit 2010 API
GenericImportOptions..::.RefPoint Property
GenericImportOptions Class See Also Send Feedback
Reference point (in Revit) to which the image is going to be inserted.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ RefPoint { get; set; }
Visual Basic (Declaration)
Public Property RefPoint As XYZ
Visual C++
public:
property XYZ^ RefPoint {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

If null, the image will be inserted to the Revit's origin.

See Also

GenericImportOptions Class
Autodesk.Revit Namespace


View Property

[image]

Revit 2010 API
GenericImportOptions..::.View Property
GenericImportOptions Class See Also Send Feedback
A view into which the image is going to be imported.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public View View { get; set; }
Visual Basic (Declaration)
Public Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
    void set (View^ value);
}

Remarks

If null, the document's active view will be used.

See Also

GenericImportOptions Class
Autodesk.Revit Namespace


IExtension Interface

[image]

Revit 2010 API
IExtension Interface
Members See Also Send Feedback
An interface that supports the additonal operation for Extension Status

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public interface IExtension
Visual Basic (Declaration)
Public Interface IExtension
Visual C++
public interface class IExtension

Remarks

See Also

IExtension Members
Autodesk.Revit Namespace


IExtension Members

[image] [image]

Revit 2010 API
IExtension Members
IExtension Interface Properties See Also Send Feedback

The IExtension type exposes the following members.

Properties

Name | Description
Extended | Retrieves or set the extension status at the end
HasMiter | Retrieves the miter status at the end
IsMiterLocked | Retrieves or set the miter locked status at the end.
SymbolicExtended | Retrieves or set the symbolic extension status at the end

See Also

IExtension Interface
Autodesk.Revit Namespace


IExtension Properties

[image] [image]

Revit 2010 API
IExtension Properties
IExtension Interface See Also Send Feedback

The IExtension type exposes the following members.

Properties

Name | Description
Extended | Retrieves or set the extension status at the end
HasMiter | Retrieves the miter status at the end
IsMiterLocked | Retrieves or set the miter locked status at the end.
SymbolicExtended | Retrieves or set the symbolic extension status at the end

See Also

IExtension Interface
Autodesk.Revit Namespace


Extended Property

[image]

Revit 2010 API
IExtension..::.Extended Property
IExtension Interface See Also Send Feedback
Retrieves or set the extension status at the end

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
bool Extended[
    int index
] { get; set; }
Visual Basic (Declaration)
Property Extended ( _
    index As Integer _
) As Boolean
Visual C++
property bool Extended[int index] {
    bool get (int index);
    void set (int index, bool value);
}

Parameters

index
Type: System..::.Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, if the beam extension status is changed, other status such as the symbolic extension status, miter status, miter locked status, and other beams extension status will be changed automatically at the same time. This change can protect that a join can have up to two extended beams, if there are two extended beams at the join, they shall be mitered.

See Also

IExtension Interface
Autodesk.Revit Namespace


HasMiter Property

[image]

Revit 2010 API
IExtension..::.HasMiter Property
IExtension Interface See Also Send Feedback
Retrieves the miter status at the end

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
bool HasMiter[
    int index
] { get; }
Visual Basic (Declaration)
ReadOnly Property HasMiter ( _
    index As Integer _
) As Boolean
Visual C++
property bool HasMiter[int index] {
    bool get (int index);
}

Parameters

index
Type: System..::.Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, this can check whether the beam is mitered with other beams at the end

See Also

IExtension Interface
Autodesk.Revit Namespace


IsMiterLocked Property

[image]

Revit 2010 API
IExtension..::.IsMiterLocked Property
IExtension Interface See Also Send Feedback
Retrieves or set the miter locked status at the end.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
bool IsMiterLocked[
    int index
] { get; set; }
Visual Basic (Declaration)
Property IsMiterLocked ( _
    index As Integer _
) As Boolean
Visual C++
property bool IsMiterLocked[int index] {
    bool get (int index);
    void set (int index, bool value);
}

Parameters

index
Type: System..::.Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, only if the beam is extended and is mitered with other beams at the end, it can be locked. Otherwise, the setting is invalid

See Also

IExtension Interface
Autodesk.Revit Namespace


SymbolicExtended Property

[image]

Revit 2010 API
IExtension..::.SymbolicExtended Property
IExtension Interface See Also Send Feedback
Retrieves or set the symbolic extension status at the end

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
bool SymbolicExtended[
    int index
] { get; set; }
Visual Basic (Declaration)
Property SymbolicExtended ( _
    index As Integer _
) As Boolean
Visual C++
property bool SymbolicExtended[int index] {
    bool get (int index);
    void set (int index, bool value);
}

Parameters

index
Type: System..::.Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, symbolic extension setting only works when the beam is extended, mitered, and miter locked at the end. Otherwise the setting is invalid

See Also

IExtension Interface
Autodesk.Revit Namespace


IExternalApplication Interface

[image]

Revit 2010 API
IExternalApplication Interface
Members See Also Send Feedback
An interface that when support provides additional applications within Autodesk Revit implemented by external applications.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public interface IExternalApplication
Visual Basic (Declaration)
Public Interface IExternalApplication
Visual C++
public interface class IExternalApplication

Remarks

To add an external application to Autodesk Revit the developer should implement an object that supports the IExternalApplication interface.

See Also

IExternalApplication Members
Autodesk.Revit Namespace


IExternalApplication Members

[image] [image]

Revit 2010 API
IExternalApplication Members
IExternalApplication Interface Methods See Also Send Feedback

The IExternalApplication type exposes the following members.

Methods

Name | Description
OnShutdown | Provide an interface for the user to do some extra work when Revit closes.
OnStartup | Provide an interface for the user to do some extra work when Revit starts.

See Also

IExternalApplication Interface
Autodesk.Revit Namespace


IExternalApplication Methods

[image] [image]

Revit 2010 API
IExternalApplication Methods
IExternalApplication Interface See Also Send Feedback

The IExternalApplication type exposes the following members.

Methods

Name | Description
OnShutdown | Provide an interface for the user to do some extra work when Revit closes.
OnStartup | Provide an interface for the user to do some extra work when Revit starts.

See Also

IExternalApplication Interface
Autodesk.Revit Namespace


OnShutdown Method

[image]

Revit 2010 API
IExternalApplication..::.OnShutdown Method
IExternalApplication Interface See Also Send Feedback
Provide an interface for the user to do some extra work when Revit closes.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
IExternalApplication..::.Result OnShutdown(
    ControlledApplication application
)
Visual Basic (Declaration)
Function OnShutdown ( _
    application As ControlledApplication _
) As IExternalApplication..::.Result
Visual C++
IExternalApplication..::.Result OnShutdown(
    ControlledApplication^ application
)

Parameters

application
Type: Autodesk.Revit..::.ControlledApplication
The application is being shut down.

Return Value

Indicates if the external application completes its work successfully.

Remarks

If the user implements the interface for an exteranl application, the task within OnShutdown will be executed when Revit closes.

See Also

IExternalApplication Interface
Autodesk.Revit Namespace


OnStartup Method

[image]

Revit 2010 API
IExternalApplication..::.OnStartup Method
IExternalApplication Interface See Also Send Feedback
Provide an interface for the user to do some extra work when Revit starts.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
IExternalApplication..::.Result OnStartup(
    ControlledApplication application
)
Visual Basic (Declaration)
Function OnStartup ( _
    application As ControlledApplication _
) As IExternalApplication..::.Result
Visual C++
IExternalApplication..::.Result OnStartup(
    ControlledApplication^ application
)

Parameters

application
Type: Autodesk.Revit..::.ControlledApplication
The application is being started.

Return Value

Indicates if the external application completes its work successfully.

Remarks

If the user implements the interface for an exteranl application, the task within OnStartup will be executed when Revit starts.

See Also

IExternalApplication Interface
Autodesk.Revit Namespace


IExternalApplication.Result Enumeration

[image]

Revit 2010 API
IExternalApplication..::.Result Enumeration
IExternalApplication Interface See Also Send Feedback
Informs Autodesk Revit of the status of your application after execution.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum Result
Visual Basic (Declaration)
Public Enumeration Result
Visual C++
public enum class Result

Members

Member name | Description
Cancelled | Signifies that the external application is cancelled.
Succeeded | The external application completed successfully. Autodesk Revit will keep this object during the entire Revit session.
Failed | The external application was unable to complete its task.

See Also

Autodesk.Revit Namespace


IExternalCommand Interface

[image]

Revit 2010 API
IExternalCommand Interface
Members Example See Also Send Feedback
An interface that when support provides additional commands within Autodesk Revit implemented by external applications.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public interface IExternalCommand
Visual Basic (Declaration)
Public Interface IExternalCommand
Visual C++
public interface class IExternalCommand

Remarks

To add an external command to Autodesk Revit the developer should implement an object that supports the IExternalCommand interface.

Examples

CopyC#
public IExternalCommand.Result Execute(ExternalCommandData commandData,
    ref string message, ElementSet elements)
{
    try
    {
        Document doc = commandData.Application.ActiveDocument;

        // Delete selected elements
        ElementIdSet ids = doc.Delete(doc.Selection.Elements);

        DialogResult result = MessageBox.Show(
           "Click Yes to return Succeeded. Selected members will be deleted.\n" +
           "Click No to return Failed.  Selected members will not be deleted.\n" +
           "Click Cancel to return Cancelled.  Selected members will not be deleted.",
           "Revit", MessageBoxButtons.YesNoCancel);

        if (DialogResult.Yes == result)
        {
            return IExternalCommand.Result.Succeeded;
        }
        else if (DialogResult.No == result)
        {
            elements = doc.Selection.Elements;
            message = "Failed to delete selection.";
            return IExternalCommand.Result.Failed;
        }
        else
        {
            return IExternalCommand.Result.Cancelled;
        }
    }
    catch
    {
        message = "Unexpected Exception thrown.";
        return IExternalCommand.Result.Failed;
    }

}
CopyVB.NET
Public Function Execute(ByVal commandData As ExternalCommandData, ByRef message As String, ByVal elements As ElementSet) As IExternalCommand.Result Implements IExternalCommand.Execute
    Try
        Dim doc As Document = commandData.Application.ActiveDocument

        ' Delete selected elements
        Dim ids As ElementIdSet = doc.Delete(doc.Selection.Elements)

        Dim result As DialogResult = MessageBox.Show("Click Yes to return Succeeded. Selected members will be deleted." & vbLf & "Click No to return Failed. Selected members will not be deleted." & vbLf & "Click Cancel to return Cancelled. Selected members will not be deleted.", "Revit", MessageBoxButtons.YesNoCancel)

        If DialogResult.Yes = result Then
            Return IExternalCommand.Result.Succeeded
        ElseIf DialogResult.No = result Then
            elements = doc.Selection.Elements
            message = "Failed to delete selection."
            Return IExternalCommand.Result.Failed
        Else
            Return IExternalCommand.Result.Cancelled
        End If
    Catch
        message = "Unexpected Exception thrown."
        Return IExternalCommand.Result.Failed
    End Try

End Function

See Also

IExternalCommand Members
Autodesk.Revit Namespace


IExternalCommand Members

[image] [image]

Revit 2010 API
IExternalCommand Members
IExternalCommand Interface Methods See Also Send Feedback

The IExternalCommand type exposes the following members.

Methods

Name | Description
Execute | Overload this method to implement and external command within Revit.

See Also

IExternalCommand Interface
Autodesk.Revit Namespace


IExternalCommand Methods

[image] [image]

Revit 2010 API
IExternalCommand Methods
IExternalCommand Interface See Also Send Feedback

The IExternalCommand type exposes the following members.

Methods

Name | Description
Execute | Overload this method to implement and external command within Revit.

See Also

IExternalCommand Interface
Autodesk.Revit Namespace


Execute Method

[image]

Revit 2010 API
IExternalCommand..::.Execute Method
IExternalCommand Interface See Also Send Feedback
Overload this method to implement and external command within Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
IExternalCommand..::.Result Execute(
    ExternalCommandData commandData,
    out string message,
    ElementSet elements
)
Visual Basic (Declaration)
Function Execute ( _
    commandData As ExternalCommandData, _
    <OutAttribute> ByRef message As String, _
    <OutAttribute> elements As ElementSet _
) As IExternalCommand..::.Result
Visual C++
IExternalCommand..::.Result Execute(
    ExternalCommandData^ commandData,
    [InAttribute] [OutAttribute] String^% message,
    [InAttribute] [OutAttribute] ElementSet^ elements
)

Parameters

commandData
Type: Autodesk.Revit..::.ExternalCommandData
An ExternalCommandData object which contains reference to Application and View needed by external command.
message
Type: System..::.String %
Error message can be returned by external command. This will be displayed only if the command status was "Failed". There is a limit of 1023 characters for this message; strings longer than this will be truncated.
elements
Type: Autodesk.Revit..::.ElementSet
Element set indicating problem elements to display in the failure dialog. This will be used only if the command status was "Failed".

Return Value

The result indicates if the execution fails, succeeds, or was canceled by user. If it does not succeed, Revit will undo any changes made by the external command.

See Also

IExternalCommand Interface
Autodesk.Revit Namespace


IExternalCommand.Result Enumeration

[image]

Revit 2010 API
IExternalCommand..::.Result Enumeration
IExternalCommand Interface See Also Send Feedback
Informs Autodesk Revit of the status of your command after execution.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum Result
Visual Basic (Declaration)
Public Enumeration Result
Visual C++
public enum class Result

Members

Member name | Description
Succeeded | The external command completed successfully. Autodesk Revit will keep any changes made by the external command.
Failed | The external command was unable to complete its task. Autodesk Revit should undo any operations that the external command performed and signal a failure.
Cancelled | Signifies that the user cancelled the external command. Autodesk Revit should undo any changes made by the external command but not signal a failure.

See Also

Autodesk.Revit Namespace


IFamilyLoadOptions Interface

[image]

Revit 2010 API
IFamilyLoadOptions Interface
Members See Also Send Feedback
An interface class which provide the callback for family load options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public interface IFamilyLoadOptions
Visual Basic (Declaration)
Public Interface IFamilyLoadOptions
Visual C++
public interface class IFamilyLoadOptions

See Also

IFamilyLoadOptions Members
Autodesk.Revit Namespace


IFamilyLoadOptions Members

[image] [image]

Revit 2010 API
IFamilyLoadOptions Members
IFamilyLoadOptions Interface Methods See Also Send Feedback

The IFamilyLoadOptions type exposes the following members.

Methods

Name | Description
OnFamilyFound | This is the method called when the family was found in the target document already.
OnSharedFamilyFound | This is the method called when the shared family was found in the target document already.

See Also

IFamilyLoadOptions Interface
Autodesk.Revit Namespace


IFamilyLoadOptions Methods

[image] [image]

Revit 2010 API
IFamilyLoadOptions Methods
IFamilyLoadOptions Interface See Also Send Feedback

The IFamilyLoadOptions type exposes the following members.

Methods

Name | Description
OnFamilyFound | This is the method called when the family was found in the target document already.
OnSharedFamilyFound | This is the method called when the shared family was found in the target document already.

See Also

IFamilyLoadOptions Interface
Autodesk.Revit Namespace


OnFamilyFound Method

[image]

Revit 2010 API
IFamilyLoadOptions..::.OnFamilyFound Method
IFamilyLoadOptions Interface See Also Send Feedback
This is the method called when the family was found in the target document already.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
bool OnFamilyFound(
    bool familyInUse,
    ref bool overwriteParameterValues
)
Visual Basic (Declaration)
Function OnFamilyFound ( _
    familyInUse As Boolean, _
    ByRef overwriteParameterValues As Boolean _
) As Boolean
Visual C++
bool OnFamilyFound(
    bool familyInUse,
    bool% overwriteParameterValues
)

Parameters

familyInUse
Type: System..::.Boolean
Indicates if at least one instance of the family is placed in the project or not.
overwriteParameterValues
Type: System..::.Boolean %
This is a boolean argument by reference which determines if overwrite the parameter values of existing types or not. The default value is false, and it can be overwritten if you want to change the behavior.

Return Value

Return true to continue loading the family, false to cancel.

See Also

IFamilyLoadOptions Interface
Autodesk.Revit Namespace


OnSharedFamilyFound Method

[image]

Revit 2010 API
IFamilyLoadOptions..::.OnSharedFamilyFound Method
IFamilyLoadOptions Interface See Also Send Feedback
This is the method called when the shared family was found in the target document already.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
bool OnSharedFamilyFound(
    Family sharedFamily,
    bool familyInUse,
    ref FamilySource source,
    ref bool overwriteParameterValues
)
Visual Basic (Declaration)
Function OnSharedFamilyFound ( _
    sharedFamily As Family, _
    familyInUse As Boolean, _
    ByRef source As FamilySource, _
    ByRef overwriteParameterValues As Boolean _
) As Boolean
Visual C++
bool OnSharedFamilyFound(
    Family^ sharedFamily,
    bool familyInUse,
    FamilySource% source,
    bool% overwriteParameterValues
)

Parameters

sharedFamily
Type: Autodesk.Revit.Elements..::.Family
The shared family in the current family document.
familyInUse
Type: System..::.Boolean
Indicates if at least one instance of the family is placed in the project or not.
source
Type: Autodesk.Revit..::.FamilySource %
This is an output enum argument which indicates if the family will load from the project or the current family.
overwriteParameterValues
Type: System..::.Boolean %
This is an output boolean argument which indicates if overwrite the parameter values of existing types.

Return Value

Return true to continue loading the family, false to cancel.

See Also

IFamilyLoadOptions Interface
Autodesk.Revit Namespace


ImageImportOptions Class

[image]

Revit 2010 API
ImageImportOptions Class
Members See Also Send Feedback
Import options specific image (bitmap) formats.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ImageImportOptions : GenericImportOptions
Visual Basic (Declaration)
Public Class ImageImportOptions _
    Inherits GenericImportOptions
Visual C++
public ref class ImageImportOptions : public GenericImportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.GenericImportOptions
Autodesk.Revit..::.ImageImportOptions

See Also

ImageImportOptions Members
Autodesk.Revit Namespace


ImageImportOptions Members

[image] [image]

Revit 2010 API
ImageImportOptions Members
ImageImportOptions Class Constructors Methods Properties See Also Send Feedback

The ImageImportOptions type exposes the following members.

Constructors

Name | Description
ImageImportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Placement | Placement mode defines by which point is the image goind to be inserted.
RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
Resolution | Resolution [ppi] of the image to be imported.
View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)

See Also

ImageImportOptions Class
Autodesk.Revit Namespace


ImageImportOptions Constructor

[image]

Revit 2010 API
ImageImportOptions Constructor
ImageImportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ImageImportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ImageImportOptions()

See Also

ImageImportOptions Class
Autodesk.Revit Namespace


ImageImportOptions Methods

[image] [image]

Revit 2010 API
ImageImportOptions Methods
ImageImportOptions Class See Also Send Feedback

The ImageImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageImportOptions Class
Autodesk.Revit Namespace


ImageImportOptions Properties

[image] [image]

Revit 2010 API
ImageImportOptions Properties
ImageImportOptions Class See Also Send Feedback

The ImageImportOptions type exposes the following members.

Properties

Name | Description
Placement | Placement mode defines by which point is the image goind to be inserted.
RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
Resolution | Resolution [ppi] of the image to be imported.
View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)

See Also

ImageImportOptions Class
Autodesk.Revit Namespace


Placement Property

[image]

Revit 2010 API
ImageImportOptions..::.Placement Property
ImageImportOptions Class See Also Send Feedback
Placement mode defines by which point is the image goind to be inserted.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoxPlacement Placement { get; set; }
Visual Basic (Declaration)
Public Property Placement As BoxPlacement
Visual C++
public:
property BoxPlacement Placement {
    BoxPlacement get ();
    void set (BoxPlacement value);
}

See Also

ImageImportOptions Class
Autodesk.Revit Namespace


Resolution Property

[image]

Revit 2010 API
ImageImportOptions..::.Resolution Property
ImageImportOptions Class See Also Send Feedback
Resolution [ppi] of the image to be imported.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ushort Resolution { get; set; }
Visual Basic (Declaration)
Public Property Resolution As UShort
Visual C++
public:
property unsigned short Resolution {
    unsigned short get ();
    void set (unsigned short value);
}

See Also

ImageImportOptions Class
Autodesk.Revit Namespace


InstanceUsageFilter Class

[image]

Revit 2010 API
InstanceUsageFilter Class
Members See Also Send Feedback
Represents a filter to filter elements with the given InstanceUsage/StructuralUsage.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class InstanceUsageFilter : Filter
Visual Basic (Declaration)
Public Class InstanceUsageFilter _
    Inherits Filter
Visual C++
public ref class InstanceUsageFilter : public Filter

Remarks

The InstanceUsageFilter object is to filter all the elements with the given InstanceUsage/StructuralUsage in the active document. FamilyInstance (only brace and beam) has the property StructuralUsage.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Filter
Autodesk.Revit..::.InstanceUsageFilter

See Also

InstanceUsageFilter Members
Autodesk.Revit Namespace


InstanceUsageFilter Members

[image] [image]

Revit 2010 API
InstanceUsageFilter Members
InstanceUsageFilter Class Constructors Methods Properties See Also Send Feedback

The InstanceUsageFilter type exposes the following members.

Constructors

Name | Description
InstanceUsageFilter | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InstanceUsageFilter Class
Autodesk.Revit Namespace


InstanceUsageFilter Constructor

[image]

Revit 2010 API
InstanceUsageFilter Constructor
InstanceUsageFilter Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InstanceUsageFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InstanceUsageFilter()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

InstanceUsageFilter Class
Autodesk.Revit Namespace


InstanceUsageFilter Methods

[image] [image]

Revit 2010 API
InstanceUsageFilter Methods
InstanceUsageFilter Class See Also Send Feedback

The InstanceUsageFilter type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstanceUsageFilter Class
Autodesk.Revit Namespace


InstanceUsageFilter Properties

[image] [image]

Revit 2010 API
InstanceUsageFilter Properties
InstanceUsageFilter Class See Also Send Feedback

The InstanceUsageFilter type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InstanceUsageFilter Class
Autodesk.Revit Namespace


InventorImportOptions Class

[image]

Revit 2010 API
InventorImportOptions Class
Members See Also Send Feedback
Import options for Inventor format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class InventorImportOptions
Visual Basic (Declaration)
Public Class InventorImportOptions
Visual C++
public ref class InventorImportOptions

Remarks

Not used currently. Reserved for future use.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.InventorImportOptions

See Also

InventorImportOptions Members
Autodesk.Revit Namespace


InventorImportOptions Members

[image] [image]

Revit 2010 API
InventorImportOptions Members
InventorImportOptions Class Constructors Methods See Also Send Feedback

The InventorImportOptions type exposes the following members.

Constructors

Name | Description
InventorImportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InventorImportOptions Class
Autodesk.Revit Namespace


InventorImportOptions Constructor

[image]

Revit 2010 API
InventorImportOptions Constructor
InventorImportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InventorImportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InventorImportOptions()

See Also

InventorImportOptions Class
Autodesk.Revit Namespace


InventorImportOptions Methods

[image] [image]

Revit 2010 API
InventorImportOptions Methods
InventorImportOptions Class See Also Send Feedback

The InventorImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InventorImportOptions Class
Autodesk.Revit Namespace


JoinType Enumeration

[image]

Revit 2010 API
JoinType Enumeration
See Also Send Feedback
The type of join at the end of an element. The join type affects only the graphic treatment, i.e. cleaning of the end, not the physical join behavior.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum JoinType
Visual Basic (Declaration)
Public Enumeration JoinType
Visual C++
public enum class JoinType

Members

Member name | Description
Extension | Extension Join
SquareOff | Square-off Join
Miter | Miter Join
Abut | Abut Join
None | No join type

See Also

Autodesk.Revit Namespace


Leader Class

[image]

Revit 2010 API
Leader Class
Members See Also Send Feedback
An object that represents a Leader within the Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Leader : APIObject
Visual Basic (Declaration)
Public Class Leader _
    Inherits APIObject
Visual C++
public ref class Leader : public APIObject

Remarks

This object derived from the APIObject base object. It can be used access the properties of a Leader.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Leader

See Also

Leader Members
Autodesk.Revit Namespace


Leader Members

[image] [image]

Revit 2010 API
Leader Members
Leader Class Constructors Methods Properties See Also Send Feedback

The Leader type exposes the following members.

Constructors

Name | Description
Leader | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Elbow | Retrieves and sets the Elbow point of the Leader.
End | Retrieves and sets the End point of the Leader.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Leader Class
Autodesk.Revit Namespace


Leader Constructor

[image]

Revit 2010 API
Leader Constructor
Leader Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Leader()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Leader()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Leader Class
Autodesk.Revit Namespace


Leader Methods

[image] [image]

Revit 2010 API
Leader Methods
Leader Class See Also Send Feedback

The Leader type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Leader Class
Autodesk.Revit Namespace


Leader Properties

[image] [image]

Revit 2010 API
Leader Properties
Leader Class See Also Send Feedback

The Leader type exposes the following members.

Properties

Name | Description
Elbow | Retrieves and sets the Elbow point of the Leader.
End | Retrieves and sets the End point of the Leader.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Leader Class
Autodesk.Revit Namespace


Elbow Property

[image]

Revit 2010 API
Leader..::.Elbow Property
Leader Class See Also Send Feedback
Retrieves and sets the Elbow point of the Leader.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Elbow { get; set; }
Visual Basic (Declaration)
Public Property Elbow As XYZ
Visual C++
public:
property XYZ^ Elbow {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The Elbow point of the specified Leader object can be taken and set with this Elbow property.

See Also

Leader Class
Autodesk.Revit Namespace


End Property

[image]

Revit 2010 API
Leader..::.End Property
Leader Class See Also Send Feedback
Retrieves and sets the End point of the Leader.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ End { get; set; }
Visual Basic (Declaration)
Public Property End As XYZ
Visual C++
public:
property XYZ^ End {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The End point of the specified Leader object can be taken and set with this End property.

See Also

Leader Class
Autodesk.Revit Namespace


LeaderArray Class

[image]

Revit 2010 API
LeaderArray Class
Members See Also Send Feedback
An array that can contain any number of leaders.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LeaderArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class LeaderArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LeaderArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.LeaderArray

See Also

LeaderArray Members
Autodesk.Revit Namespace


LeaderArray Members

[image] [image]

Revit 2010 API
LeaderArray Members
LeaderArray Class Constructors Methods Properties See Also Send Feedback

The LeaderArray type exposes the following members.

Constructors

Name | Description
LeaderArray | Initializes a new instance of the LeaderArray class

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

LeaderArray Class
Autodesk.Revit Namespace


LeaderArray Constructor

[image]

Revit 2010 API
LeaderArray Constructor
LeaderArray Class See Also Send Feedback
Initializes a new instance of the LeaderArray class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LeaderArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LeaderArray()

See Also

LeaderArray Class
Autodesk.Revit Namespace


LeaderArray Methods

[image] [image]

Revit 2010 API
LeaderArray Methods
LeaderArray Class See Also Send Feedback

The LeaderArray type exposes the following members.

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LeaderArray Class
Autodesk.Revit Namespace


Append Method

[image]

Revit 2010 API
LeaderArray..::.Append Method
LeaderArray Class See Also Send Feedback
Add the item to the end of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    Leader item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Leader _
)
Visual C++
public:
virtual void Append(
    Leader^ item
)

Parameters

item
Type: Autodesk.Revit..::.Leader
The item to be added.

See Also

LeaderArray Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
LeaderArray..::.Clear Method
LeaderArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LeaderArray Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
LeaderArray..::.ForwardIterator Method
LeaderArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual LeaderArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LeaderArrayIterator
Visual C++
public:
virtual LeaderArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

LeaderArray Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
LeaderArray..::.GetEnumerator Method
LeaderArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

LeaderArray Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
LeaderArray..::.Insert Method
LeaderArray Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    Leader item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Leader, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Leader^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit..::.Leader
The item to be inserted into the array.
index
Type: System..::.Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

LeaderArray Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
LeaderArray..::.ReverseIterator Method
LeaderArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual LeaderArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LeaderArrayIterator
Visual C++
public:
virtual LeaderArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

LeaderArray Class
Autodesk.Revit Namespace


LeaderArray Properties

[image] [image]

Revit 2010 API
LeaderArray Properties
LeaderArray Class See Also Send Feedback

The LeaderArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

LeaderArray Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
LeaderArray..::.IsEmpty Property
LeaderArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

LeaderArray Class
Autodesk.Revit Namespace


Item Property

[image]

Revit 2010 API
LeaderArray..::.Item Property
LeaderArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Leader Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Leader
Visual C++
public:
virtual property Leader^ Item[int index] {
    Leader^ get (int index);
    void set (int index, Leader^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

LeaderArray Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
LeaderArray..::.Size Property
LeaderArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LeaderArray Class
Autodesk.Revit Namespace


LeaderArrayIterator Class

[image]

Revit 2010 API
LeaderArrayIterator Class
Members See Also Send Feedback
An iterator to an array of leaders.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class LeaderArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class LeaderArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LeaderArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.LeaderArrayIterator

See Also

LeaderArrayIterator Members
Autodesk.Revit Namespace


LeaderArrayIterator Members

[image] [image]

Revit 2010 API
LeaderArrayIterator Members
LeaderArrayIterator Class Constructors Methods Properties See Also Send Feedback

The LeaderArrayIterator type exposes the following members.

Constructors

Name | Description
LeaderArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LeaderArrayIterator Class
Autodesk.Revit Namespace


LeaderArrayIterator Constructor

[image]

Revit 2010 API
LeaderArrayIterator Constructor
LeaderArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LeaderArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LeaderArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LeaderArrayIterator Class
Autodesk.Revit Namespace


LeaderArrayIterator Methods

[image] [image]

Revit 2010 API
LeaderArrayIterator Methods
LeaderArrayIterator Class See Also Send Feedback

The LeaderArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LeaderArrayIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
LeaderArrayIterator..::.MoveNext Method
LeaderArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LeaderArrayIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
LeaderArrayIterator..::.Reset Method
LeaderArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LeaderArrayIterator Class
Autodesk.Revit Namespace


LeaderArrayIterator Properties

[image] [image]

Revit 2010 API
LeaderArrayIterator Properties
LeaderArrayIterator Class See Also Send Feedback

The LeaderArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LeaderArrayIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
LeaderArrayIterator..::.Current Property
LeaderArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LeaderArrayIterator Class
Autodesk.Revit Namespace


LinePatternSet Class

[image]

Revit 2010 API
LinePatternSet Class
Members See Also Send Feedback
A set that can contain any number of line patterns.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LinePatternSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class LinePatternSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LinePatternSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.LinePatternSet

See Also

LinePatternSet Members
Autodesk.Revit Namespace


LinePatternSet Members

[image] [image]

Revit 2010 API
LinePatternSet Members
LinePatternSet Class Constructors Methods Properties See Also Send Feedback

The LinePatternSet type exposes the following members.

Constructors

Name | Description
LinePatternSet | Initializes a new instance of the LinePatternSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

LinePatternSet Class
Autodesk.Revit Namespace


LinePatternSet Constructor

[image]

Revit 2010 API
LinePatternSet Constructor
LinePatternSet Class See Also Send Feedback
Initializes a new instance of the LinePatternSet class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LinePatternSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LinePatternSet()

See Also

LinePatternSet Class
Autodesk.Revit Namespace


LinePatternSet Methods

[image] [image]

Revit 2010 API
LinePatternSet Methods
LinePatternSet Class See Also Send Feedback

The LinePatternSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinePatternSet Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
LinePatternSet..::.Clear Method
LinePatternSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LinePatternSet Class
Autodesk.Revit Namespace


Contains Method

[image]

Revit 2010 API
LinePatternSet..::.Contains Method
LinePatternSet Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    LinePattern item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As LinePattern _
) As Boolean
Visual C++
public:
virtual bool Contains(
    LinePattern^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.LinePattern
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

LinePatternSet Class
Autodesk.Revit Namespace


Erase Method

[image]

Revit 2010 API
LinePatternSet..::.Erase Method
LinePatternSet Class See Also Send Feedback
Removes a specified object from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    LinePattern item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As LinePattern _
) As Integer
Visual C++
public:
virtual int Erase(
    LinePattern^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.LinePattern
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

LinePatternSet Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
LinePatternSet..::.ForwardIterator Method
LinePatternSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual LinePatternSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LinePatternSetIterator
Visual C++
public:
virtual LinePatternSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

LinePatternSet Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
LinePatternSet..::.GetEnumerator Method
LinePatternSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

LinePatternSet Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
LinePatternSet..::.Insert Method
LinePatternSet Class See Also Send Feedback
Insert the specified item into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    LinePattern item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As LinePattern _
) As Boolean
Visual C++
public:
virtual bool Insert(
    LinePattern^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.LinePattern
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

LinePatternSet Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
LinePatternSet..::.ReverseIterator Method
LinePatternSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual LinePatternSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LinePatternSetIterator
Visual C++
public:
virtual LinePatternSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

LinePatternSet Class
Autodesk.Revit Namespace


LinePatternSet Properties

[image] [image]

Revit 2010 API
LinePatternSet Properties
LinePatternSet Class See Also Send Feedback

The LinePatternSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

LinePatternSet Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
LinePatternSet..::.IsEmpty Property
LinePatternSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

LinePatternSet Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
LinePatternSet..::.Size Property
LinePatternSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LinePatternSet Class
Autodesk.Revit Namespace


LinePatternSetIterator Class

[image]

Revit 2010 API
LinePatternSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class LinePatternSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class LinePatternSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LinePatternSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.LinePatternSetIterator

See Also

LinePatternSetIterator Members
Autodesk.Revit Namespace


LinePatternSetIterator Members

[image] [image]

Revit 2010 API
LinePatternSetIterator Members
LinePatternSetIterator Class Constructors Methods Properties See Also Send Feedback

The LinePatternSetIterator type exposes the following members.

Constructors

Name | Description
LinePatternSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LinePatternSetIterator Class
Autodesk.Revit Namespace


LinePatternSetIterator Constructor

[image]

Revit 2010 API
LinePatternSetIterator Constructor
LinePatternSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LinePatternSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LinePatternSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LinePatternSetIterator Class
Autodesk.Revit Namespace


LinePatternSetIterator Methods

[image] [image]

Revit 2010 API
LinePatternSetIterator Methods
LinePatternSetIterator Class See Also Send Feedback

The LinePatternSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinePatternSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
LinePatternSetIterator..::.MoveNext Method
LinePatternSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LinePatternSetIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
LinePatternSetIterator..::.Reset Method
LinePatternSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LinePatternSetIterator Class
Autodesk.Revit Namespace


LinePatternSetIterator Properties

[image] [image]

Revit 2010 API
LinePatternSetIterator Properties
LinePatternSetIterator Class See Also Send Feedback

The LinePatternSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LinePatternSetIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
LinePatternSetIterator..::.Current Property
LinePatternSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LinePatternSetIterator Class
Autodesk.Revit Namespace


Location Class

[image]

Revit 2010 API
Location Class
Members Example See Also Send Feedback
Provides location functionality for all elements.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Location : APIObject
Visual Basic (Declaration)
Public Class Location _
    Inherits APIObject
Visual C++
public ref class Location : public APIObject

Remarks

The location object provides the ability to translate and rotate elements. More detailed location information and control can be found by using the derivatives of this object, such as LocationPoint or LocationCurve.

Examples

CopyC#
void ShowLocationUsage(Autodesk.Revit.Application application, Wall wall)
{
    // Get the location instance.
    Autodesk.Revit.Location position = wall.Location;

    // Check whether the wall is pinned.
    if (wall.Pinned)
    {
        throw new Exception("The wall has been pinned.");
    }

    // Move the wall location, it provides same fuction as Move method of Document class.
    Autodesk.Revit.Geometry.XYZ direction = new Autodesk.Revit.Geometry.XYZ(10, 0, 0);
    bool result = position.Move(direction);
    if (!result)
    {
        throw new Exception("Move wall location failed.");
    }

    // Rotate the wall location, it provides same fuction as Rotate method of Document class.
    XYZ axisStart = new XYZ(0, 0, 0);
    XYZ axisEnd = new XYZ(0, 0, 1);
    Line axis = application.Create.NewLineUnbound(axisStart, axisEnd);
    result = position.Rotate(axis, 30);
    if (!result)
    {
        throw new Exception("Rotate wall location failed.");
    }
}
CopyVB.NET
Private Sub ShowLocationUsage(ByVal application As Autodesk.Revit.Application, ByVal wall As Wall)
    ' Get the location instance.
    Dim position As Autodesk.Revit.Location = wall.Location

    ' Check whether the wall is pinned.
    If wall.Pinned Then
        Throw New Exception("The wall has been pinned.")
    End If

    ' Move the wall location, it provides same fuction as Move method of Document class.
    Dim direction As New Autodesk.Revit.Geometry.XYZ(10, 0, 0)
    Dim result As Boolean = position.Move(direction)
    If Not result Then
        Throw New Exception("Move wall location failed.")
    End If

    ' Rotate the wall location, it provides same fuction as Rotate method of Document class.
    Dim axisStart As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
    Dim axisEnd As New Autodesk.Revit.Geometry.XYZ(0, 0, 1)
    Dim axis As Line = application.Create.NewLineUnbound(axisStart, axisEnd)
    result = position.Rotate(axis, 30)
    If Not result Then
        Throw New Exception("Rotate wall location failed.")
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Location
Autodesk.Revit..::.LocationCurve
Autodesk.Revit..::.LocationPoint

See Also

Location Members
Autodesk.Revit Namespace


Location Members

[image] [image]

Revit 2010 API
Location Members
Location Class Constructors Methods Properties See Also Send Feedback

The Location type exposes the following members.

Constructors

Name | Description
Location | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Move | Move the element within the project by a specified vector.
Rotate | Rotate the element within the project by a specified number of degrees around a given axis.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Location Class
Autodesk.Revit Namespace


Location Constructor

[image]

Revit 2010 API
Location Constructor
Location Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Location()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Location()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Location Class
Autodesk.Revit Namespace


Location Methods

[image] [image]

Revit 2010 API
Location Methods
Location Class See Also Send Feedback

The Location type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Move | Move the element within the project by a specified vector.
Rotate | Rotate the element within the project by a specified number of degrees around a given axis.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Location Class
Autodesk.Revit Namespace


Move Method

[image]

Revit 2010 API
Location..::.Move Method
Location Class Example See Also Send Feedback
Move the element within the project by a specified vector.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Move(
    XYZ translation
)
Visual Basic (Declaration)
Public Function Move ( _
    translation As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    XYZ^ translation
)

Parameters

translation
Type: Autodesk.Revit.Geometry..::.XYZ
The vector by which the element is to be moved.

Return Value

If the element is moved successfully then the method return True, otherwise False.

Remarks

The move method is used to move an element within the project. Other elements may also be moved when this element is moved, for example: if the element is wall and it contains windows, the windows will also be moved.

Examples

CopyC#
bool MoveUsingLocationCurve(Autodesk.Revit.Application application, Wall wall)
{
    LocationCurve wallLine = wall.Location as LocationCurve;
    XYZ translationVec = new XYZ(10, 20, 0);
    return (wallLine.Move(translationVec));
}
CopyVB.NET
Private Function MoveUsingLocationCurve(ByVal application As Autodesk.Revit.Application, ByVal wall As Wall) As Boolean
    Dim wallLine As LocationCurve = TryCast(wall.Location, LocationCurve)
    Dim translationVec As New Autodesk.Revit.Geometry.XYZ(10, 20, 0)
    Return (wallLine.Move(translationVec))
End Function

See Also

Location Class
Autodesk.Revit Namespace


Rotate Method

[image]

Revit 2010 API
Location..::.Rotate Method
Location Class Example See Also Send Feedback
Rotate the element within the project by a specified number of degrees around a given axis.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Rotate(
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate(
    Line^ axis,
    double angle
)

Parameters

axis
Type: Autodesk.Revit.Geometry..::.Line
An unbounded line that represents the axis of rotation.
angle
Type: System..::.Double
The number of degrees, in radians, by which the element is to be rotated around the specified axis.

Return Value

If the element is rotate successfully then the method returns True, otherwise False.

Remarks

The rotate method is used to rotate an element within the project. Other elements may also be rotated when this element is rotated because they are dependent upon the element being rotated. An unbounded line for the axis can be created by using the Application.Create object and its methods.

Examples

CopyC#
bool LocationRotate(Autodesk.Revit.Application application, Autodesk.Revit.Element element)
{
    bool rotated = false;
    // Rotate the element via its location curve.
    LocationCurve curve = element.Location as LocationCurve;
    if (null != curve)
    {
        Curve line = curve.Curve;
        XYZ aa = line.get_EndPoint(0);
        XYZ cc = new XYZ(aa.X, aa.Y, aa.Z + 10);
        Line axis = application.Create.NewLineBound(aa, cc);
        rotated = curve.Rotate(axis, Math.PI / 2.0);
    }

    return rotated;
}
CopyVB.NET
Private Function LocationRotate(ByVal application As Autodesk.Revit.Application, ByVal element As Autodesk.Revit.Element) As Boolean
    Dim rotated As Boolean = False
    ' Rotate the element via its location curve.
    Dim curve As LocationCurve = TryCast(element.Location, LocationCurve)
    If curve IsNot Nothing Then
        Dim line As Curve = curve.Curve
        Dim aa As Autodesk.Revit.Geometry.XYZ = line.EndPoint(0)
        Dim cc As New Autodesk.Revit.Geometry.XYZ(aa.X, aa.Y, aa.Z + 10)
        Dim axis As Line = application.Create.NewLineBound(aa, cc)
        rotated = curve.Rotate(axis, Math.PI / 2.0R)
    End If

    Return rotated
End Function

See Also

Location Class
Autodesk.Revit Namespace


Location Properties

[image] [image]

Revit 2010 API
Location Properties
Location Class See Also Send Feedback

The Location type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Location Class
Autodesk.Revit Namespace


LocationCurve Class

[image]

Revit 2010 API
LocationCurve Class
Members See Also Send Feedback
Provides location functionality for all elements that are based upon a curve.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LocationCurve : Location
Visual Basic (Declaration)
Public Class LocationCurve _
    Inherits Location
Visual C++
public ref class LocationCurve : public Location

Remarks

The location line objects adds additional functionality to its base location object class. This includes reading and writing the curve contained within the element.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Location
Autodesk.Revit..::.LocationCurve

See Also

LocationCurve Members
Autodesk.Revit Namespace


LocationCurve Members

[image] [image]

Revit 2010 API
LocationCurve Members
LocationCurve Class Constructors Methods Properties See Also Send Feedback

The LocationCurve type exposes the following members.

Constructors

Name | Description
LocationCurve | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Move | Move the element within the project by a specified vector. (Inherited from Location.)
Rotate | Rotate the element within the project by a specified number of degrees around a given axis. (Inherited from Location.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Curve | Provides the ability to get and set the curve of a curve based element.
ElementsAtJoin | Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
JoinType | Get/change the type of the join at the specified end.

See Also

LocationCurve Class
Autodesk.Revit Namespace


LocationCurve Constructor

[image]

Revit 2010 API
LocationCurve Constructor
LocationCurve Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LocationCurve()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LocationCurve()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LocationCurve Class
Autodesk.Revit Namespace


LocationCurve Methods

[image] [image]

Revit 2010 API
LocationCurve Methods
LocationCurve Class See Also Send Feedback

The LocationCurve type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Move | Move the element within the project by a specified vector. (Inherited from Location.)
Rotate | Rotate the element within the project by a specified number of degrees around a given axis. (Inherited from Location.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LocationCurve Class
Autodesk.Revit Namespace


LocationCurve Properties

[image] [image]

Revit 2010 API
LocationCurve Properties
LocationCurve Class See Also Send Feedback

The LocationCurve type exposes the following members.

Properties

Name | Description
Curve | Provides the ability to get and set the curve of a curve based element.
ElementsAtJoin | Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
JoinType | Get/change the type of the join at the specified end.

See Also

LocationCurve Class
Autodesk.Revit Namespace


Curve Property

[image]

Revit 2010 API
LocationCurve..::.Curve Property
LocationCurve Class Example See Also Send Feedback
Provides the ability to get and set the curve of a curve based element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve Curve { get; set; }
Visual Basic (Declaration)
Public Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
    void set (Curve^ value);
}

Remarks

This property can be used to set the location of curve based element to any desired position. Many elements are curve based. Some examples are walls, beams and braces.

Examples

CopyC#
void MoveUsingCurveParam(Autodesk.Revit.Application application, Wall wall)
{
    LocationCurve wallLine = wall.Location as LocationCurve;
    XYZ p1 = XYZ.Zero;
    XYZ p2 = new XYZ(10, 20, 0);
    Line newWallLine = application.Create.NewLineBound(p1, p2);

    // Change the wall line to a new line.
    wallLine.Curve = newWallLine;
}
CopyVB.NET
Private Sub MoveUsingCurveParam(ByVal application As Autodesk.Revit.Application, ByVal wall As Wall)
    Dim wallLine As LocationCurve = TryCast(wall.Location, LocationCurve)
    Dim p1 As Autodesk.Revit.Geometry.XYZ = Autodesk.Revit.Geometry.XYZ.Zero
    Dim p2 As New Autodesk.Revit.Geometry.XYZ(10, 20, 0)
    Dim newWallLine As Line = application.Create.NewLineBound(p1, p2)

    ' Change the wall line to a new line.
    wallLine.Curve = newWallLine
End Sub

See Also

LocationCurve Class
Autodesk.Revit Namespace


ElementsAtJoin Property

[image]

Revit 2010 API
LocationCurve..::.ElementsAtJoin Property
LocationCurve Class See Also Send Feedback
Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementArray ElementsAtJoin[
    int end
] { get; set; }
Visual Basic (Declaration)
Public Property ElementsAtJoin ( _
    end As Integer _
) As ElementArray
Visual C++
public:
property ElementArray^ ElementsAtJoin[int end] {
    ElementArray^ get (int end);
    void set (int end, ElementArray^ value);
}

Parameters

end
Type: System..::.Int32
The end at which the join occurs.

Remarks

The list of elements is expected to be a permutation of the elements already in the join at the end. It is expected that no new elements will be introduced, and existing ones will not be removed.

See Also

LocationCurve Class
Autodesk.Revit Namespace


JoinType Property

[image]

Revit 2010 API
LocationCurve..::.JoinType Property
LocationCurve Class See Also Send Feedback
Get/change the type of the join at the specified end.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public JoinType JoinType[
    int end
] { get; set; }
Visual Basic (Declaration)
Public Property JoinType ( _
    end As Integer _
) As JoinType
Visual C++
public:
property JoinType JoinType[int end] {
    JoinType get (int end);
    void set (int end, JoinType value);
}

Parameters

end
Type: System..::.Int32
The end of the location curve driver under question.

Remarks

This property allows to get join type of wall and concrete beam and to set wall's join type. The new join type is expected to be different from the current one for this end.

Exceptions

Exception | Condition
System..::.NotSupportedException | The element is neither a wall nor a concrete beam when it tries to get the property. The element is not a wall when it tries to set the property.
System..::.InvalidOperationException | A failure occurred while attempting to set the new type.

See Also

LocationCurve Class
Autodesk.Revit Namespace


LocationPoint Class

[image]

Revit 2010 API
LocationPoint Class
Members Example See Also Send Feedback
Provides location functionality for all elements that have a single insertion point.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LocationPoint : Location
Visual Basic (Declaration)
Public Class LocationPoint _
    Inherits Location
Visual C++
public ref class LocationPoint : public Location

Remarks

The location point objects adds additional functionality to its base location object class. This includes setting the elements location to a specific point and retrieving its rotation around its insertion point.

Examples

CopyC#
void LocationInformation(LocationPoint position)
{
    String prompt = "The selected column location information:";
    prompt += "\nPoint:  (" + position.Point.X + ", "
            + position.Point.Y + ", " + position.Point.Z + ")";
    prompt += "\nRotation: " + position.Rotation;

    MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);
}

bool LocationRotate(Autodesk.Revit.Application application, Autodesk.Revit.Element element)
{
    bool rotated = false;
    LocationPoint location = element.Location as LocationPoint;

    if (null != location)
    {
        XYZ aa = location.Point;
        XYZ cc = new XYZ(aa.X, aa.Y, aa.Z + 10);
        Line axis = application.Create.NewLineBound(aa, cc);
        rotated = location.Rotate(axis, Math.PI / 2.0);
    }

    return rotated;
}
CopyVB.NET
Private Sub LocationInformation(ByVal position As LocationPoint)
    Dim prompt As String = "The selected column location information:"
    prompt += ((vbLf & "Point: (" & position.Point.X & ", ") + position.Point.Y & ", ") + position.Point.Z & ")"
    prompt += vbLf & "Rotation: " & position.Rotation

    MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)
End Sub

Private Function LocationRotate(ByVal application As Autodesk.Revit.Application, ByVal element As Autodesk.Revit.Element) As Boolean
    Dim rotated As Boolean = False
    Dim location As LocationPoint = TryCast(element.Location, LocationPoint)

    If location IsNot Nothing Then
        Dim aa As Autodesk.Revit.Geometry.XYZ = location.Point
        Dim cc As New Autodesk.Revit.Geometry.XYZ(aa.X, aa.Y, aa.Z + 10)
        Dim axis As Line = application.Create.NewLineBound(aa, cc)
        rotated = location.Rotate(axis, Math.PI / 2.0R)
    End If

    Return rotated
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Location
Autodesk.Revit..::.LocationPoint

See Also

LocationPoint Members
Autodesk.Revit Namespace


LocationPoint Members

[image] [image]

Revit 2010 API
LocationPoint Members
LocationPoint Class Constructors Methods Properties See Also Send Feedback

The LocationPoint type exposes the following members.

Constructors

Name | Description
LocationPoint | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Move | Move the element within the project by a specified vector. (Inherited from Location.)
Rotate | Rotate the element within the project by a specified number of degrees around a given axis. (Inherited from Location.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Point | Get and set the physical location of the element.
Rotation | Retrieve the angle of rotation around the insertion point.

See Also

LocationPoint Class
Autodesk.Revit Namespace


LocationPoint Constructor

[image]

Revit 2010 API
LocationPoint Constructor
LocationPoint Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LocationPoint()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LocationPoint()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LocationPoint Class
Autodesk.Revit Namespace


LocationPoint Methods

[image] [image]

Revit 2010 API
LocationPoint Methods
LocationPoint Class See Also Send Feedback

The LocationPoint type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Move | Move the element within the project by a specified vector. (Inherited from Location.)
Rotate | Rotate the element within the project by a specified number of degrees around a given axis. (Inherited from Location.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LocationPoint Class
Autodesk.Revit Namespace


LocationPoint Properties

[image] [image]

Revit 2010 API
LocationPoint Properties
LocationPoint Class See Also Send Feedback

The LocationPoint type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Point | Get and set the physical location of the element.
Rotation | Retrieve the angle of rotation around the insertion point.

See Also

LocationPoint Class
Autodesk.Revit Namespace


Point Property

[image]

Revit 2010 API
LocationPoint..::.Point Property
LocationPoint Class Example See Also Send Feedback
Get and set the physical location of the element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Point { get; set; }
Visual Basic (Declaration)
Public Property Point As XYZ
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
    void set (XYZ^ value);
}

Examples

CopyC#
void LocationMove(FamilyInstance column)
{
    LocationPoint columnPoint = column.Location as LocationPoint;
    if (null != columnPoint)
    {
        XYZ newLocation = new XYZ(10, 20, 0);
        // Move the column to the new location
        columnPoint.Point = newLocation;
    }
}
CopyVB.NET
Private Sub LocationMove(ByVal column As Autodesk.Revit.Elements.FamilyInstance)
    Dim columnPoint As LocationPoint = TryCast(column.Location, LocationPoint)
    If columnPoint IsNot Nothing Then
        Dim newLocation As New Autodesk.Revit.Geometry.XYZ(10, 20, 0)
        ' Move the column to the new location
        columnPoint.Point = newLocation
    End If
End Sub

See Also

LocationPoint Class
Autodesk.Revit Namespace


Rotation Property

[image]

Revit 2010 API
LocationPoint..::.Rotation Property
LocationPoint Class See Also Send Feedback
Retrieve the angle of rotation around the insertion point.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Rotation { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rotation As Double
Visual C++
public:
property double Rotation {
    double get ();
}

See Also

LocationPoint Class
Autodesk.Revit Namespace


LogicAndFilter Class

[image]

Revit 2010 API
LogicAndFilter Class
Members See Also Send Feedback
The LogicAndFilter is used to implement Logic-AND operation of Filters.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LogicAndFilter : Filter
Visual Basic (Declaration)
Public Class LogicAndFilter _
    Inherits Filter
Visual C++
public ref class LogicAndFilter : public Filter

Remarks

This filter represents a combined filter consists of two sub-filters by Logic-AND relationship, use it to filter elements which satisfy both sub-filters.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Filter
Autodesk.Revit..::.LogicAndFilter

See Also

LogicAndFilter Members
Autodesk.Revit Namespace


LogicAndFilter Members

[image] [image]

Revit 2010 API
LogicAndFilter Members
LogicAndFilter Class Constructors Methods Properties See Also Send Feedback

The LogicAndFilter type exposes the following members.

Constructors

Name | Description
LogicAndFilter | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
LeftFilter | Get Filter which is left operand of Logic-AND operation
RightFilter | Get Filter which is right operand of Logic-AND operation

See Also

LogicAndFilter Class
Autodesk.Revit Namespace


LogicAndFilter Constructor

[image]

Revit 2010 API
LogicAndFilter Constructor
LogicAndFilter Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LogicAndFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LogicAndFilter()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LogicAndFilter Class
Autodesk.Revit Namespace


LogicAndFilter Methods

[image] [image]

Revit 2010 API
LogicAndFilter Methods
LogicAndFilter Class See Also Send Feedback

The LogicAndFilter type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogicAndFilter Class
Autodesk.Revit Namespace


LogicAndFilter Properties

[image] [image]

Revit 2010 API
LogicAndFilter Properties
LogicAndFilter Class See Also Send Feedback

The LogicAndFilter type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
LeftFilter | Get Filter which is left operand of Logic-AND operation
RightFilter | Get Filter which is right operand of Logic-AND operation

See Also

LogicAndFilter Class
Autodesk.Revit Namespace


LeftFilter Property

[image]

Revit 2010 API
LogicAndFilter..::.LeftFilter Property
LogicAndFilter Class See Also Send Feedback
Get Filter which is left operand of Logic-AND operation

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Filter LeftFilter { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeftFilter As Filter
Visual C++
public:
property Filter^ LeftFilter {
    Filter^ get ();
}

See Also

LogicAndFilter Class
Autodesk.Revit Namespace


RightFilter Property

[image]

Revit 2010 API
LogicAndFilter..::.RightFilter Property
LogicAndFilter Class See Also Send Feedback
Get Filter which is right operand of Logic-AND operation

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Filter RightFilter { get; }
Visual Basic (Declaration)
Public ReadOnly Property RightFilter As Filter
Visual C++
public:
property Filter^ RightFilter {
    Filter^ get ();
}

See Also

LogicAndFilter Class
Autodesk.Revit Namespace


LogicNotFilter Class

[image]

Revit 2010 API
LogicNotFilter Class
Members See Also Send Feedback
The LogicNotFilter is used to implement Logic-NOT operation of Filters.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LogicNotFilter : Filter
Visual Basic (Declaration)
Public Class LogicNotFilter _
    Inherits Filter
Visual C++
public ref class LogicNotFilter : public Filter

Remarks

This filter represents a combined filter consists of one sub-filter by Logic-NOT relationship, use it to filter elements which don't satisfy the sub-filter.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Filter
Autodesk.Revit..::.LogicNotFilter

See Also

LogicNotFilter Members
Autodesk.Revit Namespace


LogicNotFilter Members

[image] [image]

Revit 2010 API
LogicNotFilter Members
LogicNotFilter Class Constructors Methods Properties See Also Send Feedback

The LogicNotFilter type exposes the following members.

Constructors

Name | Description
LogicNotFilter | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
SubFilter | Get Filter which is operand of Logic-NOT operation

See Also

LogicNotFilter Class
Autodesk.Revit Namespace


LogicNotFilter Constructor

[image]

Revit 2010 API
LogicNotFilter Constructor
LogicNotFilter Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LogicNotFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LogicNotFilter()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LogicNotFilter Class
Autodesk.Revit Namespace


LogicNotFilter Methods

[image] [image]

Revit 2010 API
LogicNotFilter Methods
LogicNotFilter Class See Also Send Feedback

The LogicNotFilter type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogicNotFilter Class
Autodesk.Revit Namespace


LogicNotFilter Properties

[image] [image]

Revit 2010 API
LogicNotFilter Properties
LogicNotFilter Class See Also Send Feedback

The LogicNotFilter type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
SubFilter | Get Filter which is operand of Logic-NOT operation

See Also

LogicNotFilter Class
Autodesk.Revit Namespace


SubFilter Property

[image]

Revit 2010 API
LogicNotFilter..::.SubFilter Property
LogicNotFilter Class See Also Send Feedback
Get Filter which is operand of Logic-NOT operation

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Filter SubFilter { get; }
Visual Basic (Declaration)
Public ReadOnly Property SubFilter As Filter
Visual C++
public:
property Filter^ SubFilter {
    Filter^ get ();
}

See Also

LogicNotFilter Class
Autodesk.Revit Namespace


LogicOrFilter Class

[image]

Revit 2010 API
LogicOrFilter Class
Members See Also Send Feedback
The LogicOrFilter is used to implement Logic-OR operation of Filters.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LogicOrFilter : Filter
Visual Basic (Declaration)
Public Class LogicOrFilter _
    Inherits Filter
Visual C++
public ref class LogicOrFilter : public Filter

Remarks

This filter represents a combined filter consists of two sub-filters by Logic-OR relationship, use it to filter elements which satisfy one of two sub-filters.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Filter
Autodesk.Revit..::.LogicOrFilter

See Also

LogicOrFilter Members
Autodesk.Revit Namespace


LogicOrFilter Members

[image] [image]

Revit 2010 API
LogicOrFilter Members
LogicOrFilter Class Constructors Methods Properties See Also Send Feedback

The LogicOrFilter type exposes the following members.

Constructors

Name | Description
LogicOrFilter | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
LeftFilter | Get Filter which is left operand of Logic-OR operation.
RightFilter | Get Filter which is right operand of Logic-OR operation

See Also

LogicOrFilter Class
Autodesk.Revit Namespace


LogicOrFilter Constructor

[image]

Revit 2010 API
LogicOrFilter Constructor
LogicOrFilter Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LogicOrFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LogicOrFilter()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LogicOrFilter Class
Autodesk.Revit Namespace


LogicOrFilter Methods

[image] [image]

Revit 2010 API
LogicOrFilter Methods
LogicOrFilter Class See Also Send Feedback

The LogicOrFilter type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogicOrFilter Class
Autodesk.Revit Namespace


LogicOrFilter Properties

[image] [image]

Revit 2010 API
LogicOrFilter Properties
LogicOrFilter Class See Also Send Feedback

The LogicOrFilter type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
LeftFilter | Get Filter which is left operand of Logic-OR operation.
RightFilter | Get Filter which is right operand of Logic-OR operation

See Also

LogicOrFilter Class
Autodesk.Revit Namespace


LeftFilter Property

[image]

Revit 2010 API
LogicOrFilter..::.LeftFilter Property
LogicOrFilter Class See Also Send Feedback
Get Filter which is left operand of Logic-OR operation.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Filter LeftFilter { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeftFilter As Filter
Visual C++
public:
property Filter^ LeftFilter {
    Filter^ get ();
}

See Also

LogicOrFilter Class
Autodesk.Revit Namespace


RightFilter Property

[image]

Revit 2010 API
LogicOrFilter..::.RightFilter Property
LogicOrFilter Class See Also Send Feedback
Get Filter which is right operand of Logic-OR operation

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Filter RightFilter { get; }
Visual Basic (Declaration)
Public ReadOnly Property RightFilter As Filter
Visual C++
public:
property Filter^ RightFilter {
    Filter^ get ();
}

See Also

LogicOrFilter Class
Autodesk.Revit Namespace


MaterialFilter Class

[image]

Revit 2010 API
MaterialFilter Class
Members See Also Send Feedback
Represents a filter to filter elements with the given material.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MaterialFilter : Filter
Visual Basic (Declaration)
Public Class MaterialFilter _
    Inherits Filter
Visual C++
public ref class MaterialFilter : public Filter

Remarks

The MaterialFilter object is to filter all the elements with the given material in the active document. Both FamilyInstance and FamilySymbol with the material property will be searched through.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Filter
Autodesk.Revit..::.MaterialFilter

See Also

MaterialFilter Members
Autodesk.Revit Namespace


MaterialFilter Members

[image] [image]

Revit 2010 API
MaterialFilter Members
MaterialFilter Class Constructors Methods Properties See Also Send Feedback

The MaterialFilter type exposes the following members.

Constructors

Name | Description
MaterialFilter | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MaterialFilter Class
Autodesk.Revit Namespace


MaterialFilter Constructor

[image]

Revit 2010 API
MaterialFilter Constructor
MaterialFilter Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MaterialFilter()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MaterialFilter Class
Autodesk.Revit Namespace


MaterialFilter Methods

[image] [image]

Revit 2010 API
MaterialFilter Methods
MaterialFilter Class See Also Send Feedback

The MaterialFilter type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaterialFilter Class
Autodesk.Revit Namespace


MaterialFilter Properties

[image] [image]

Revit 2010 API
MaterialFilter Properties
MaterialFilter Class See Also Send Feedback

The MaterialFilter type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MaterialFilter Class
Autodesk.Revit Namespace


Materials Class

[image]

Revit 2010 API
Materials Class
Members See Also Send Feedback
A set of materials that provides access to the materials in an Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Materials : MaterialSet
Visual Basic (Declaration)
Public Class Materials _
    Inherits MaterialSet
Visual C++
public ref class Materials : public MaterialSet

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.MaterialSet
Autodesk.Revit..::.Materials

See Also

Materials Members
Autodesk.Revit Namespace


Materials Members

[image] [image]

Revit 2010 API
Materials Members
Materials Class Constructors Methods Properties See Also Send Feedback

The Materials type exposes the following members.

Constructors

Name | Description
Materials | For Internal Use Only.

Methods

Name | Description
AddConcrete | Add a concrete material with the given name .
AddGeneric | Add a generic material with the given name .
AddOther | Add an other material with the given name .
AddSteel | Add a steel material with the given name .
AddWood | Add a wood material with the given name .
Clear | Removes every material from the set, rendering it empty. (Inherited from MaterialSet.)
Contains | Overloaded. Checks if the material set contains the material with the specified identifier.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified material from the set. (Inherited from MaterialSet.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from MaterialSet.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from MaterialSet.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified material into the set. (Inherited from MaterialSet.)
Remove | Remove the material with the speicified name .
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from MaterialSet.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from MaterialSet.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Overloaded. Gets the material with the specified identifier.
Size | Returns the number of materials that are in the set. (Inherited from MaterialSet.)

See Also

Materials Class
Autodesk.Revit Namespace


Materials Constructor

[image]

Revit 2010 API
Materials Constructor
Materials Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Materials()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Materials()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Materials Class
Autodesk.Revit Namespace


Materials Methods

[image] [image]

Revit 2010 API
Materials Methods
Materials Class See Also Send Feedback

The Materials type exposes the following members.

Methods

Name | Description
AddConcrete | Add a concrete material with the given name .
AddGeneric | Add a generic material with the given name .
AddOther | Add an other material with the given name .
AddSteel | Add a steel material with the given name .
AddWood | Add a wood material with the given name .
Clear | Removes every material from the set, rendering it empty. (Inherited from MaterialSet.)
Contains | Overloaded. Checks if the material set contains the material with the specified identifier.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified material from the set. (Inherited from MaterialSet.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from MaterialSet.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from MaterialSet.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified material into the set. (Inherited from MaterialSet.)
Remove | Remove the material with the speicified name .
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from MaterialSet.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Materials Class
Autodesk.Revit Namespace


AddConcrete Method

[image]

Revit 2010 API
Materials..::.AddConcrete Method
Materials Class Example See Also Send Feedback
Add a concrete material with the given name .

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialConcrete AddConcrete(
    string name
)
Visual Basic (Declaration)
Public Function AddConcrete ( _
    name As String _
) As MaterialConcrete
Visual C++
public:
MaterialConcrete^ AddConcrete(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the concrete material to be added.

Return Value

The pointer to the added concrete material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

Examples

CopyC#
private MaterialConcrete AddConcrete(Document document)
{
    string newName = "myConcreteMaterial";
    MaterialConcrete myConcrete = document.Settings.Materials.AddConcrete(newName);

    if (document.Settings.Materials.Contains(newName) == true)
    {
        MessageBox.Show("Concrete material added successfully!", "Revit");
    }

    return myConcrete;
}
CopyVB.NET
Private Function AddConcrete(ByVal document As Document) As MaterialConcrete
    Dim newName As String = "myConcreteMaterial"
    Dim myConcrete As MaterialConcrete = document.Settings.Materials.AddConcrete(newName)

    If document.Settings.Materials.Contains(newName) = True Then
        MessageBox.Show("Concrete material added successfully!", "Revit")
    End If

    Return myConcrete
End Function

See Also

Materials Class
Autodesk.Revit Namespace


AddGeneric Method

[image]

Revit 2010 API
Materials..::.AddGeneric Method
Materials Class Example See Also Send Feedback
Add a generic material with the given name .

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialGeneric AddGeneric(
    string name
)
Visual Basic (Declaration)
Public Function AddGeneric ( _
    name As String _
) As MaterialGeneric
Visual C++
public:
MaterialGeneric^ AddGeneric(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the generic material to be added.

Return Value

The pointer to the added generic material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

Examples

CopyC#
private MaterialGeneric AddGeneric(Document document)
{
    string newName = "myGenericMaterial";
    MaterialGeneric myGeneric = document.Settings.Materials.AddGeneric(newName);

    if (null != myGeneric)
    {
        MessageBox.Show("Generic material added successfully!", "Revit");
    }

    return myGeneric;
}
CopyVB.NET
Private Function AddGeneric(ByVal document As Document) As MaterialGeneric
    Dim newName As String = "myGenericMaterial"
    Dim myGeneric As MaterialGeneric = document.Settings.Materials.AddGeneric(newName)

    If myGeneric IsNot Nothing Then
        MessageBox.Show("Generic material added successfully!", "Revit")
    End If

    Return myGeneric
End Function

See Also

Materials Class
Autodesk.Revit Namespace


AddOther Method

[image]

Revit 2010 API
Materials..::.AddOther Method
Materials Class Example See Also Send Feedback
Add an other material with the given name .

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialOther AddOther(
    string name
)
Visual Basic (Declaration)
Public Function AddOther ( _
    name As String _
) As MaterialOther
Visual C++
public:
MaterialOther^ AddOther(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the other material to be added.

Return Value

The pointer to the added other material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

Examples

CopyC#
private bool CreateOtherMaterial(Autodesk.Revit.Document document)
{
    string oldName = "myOtherMaterial";
    MaterialOther myOther = document.Settings.Materials.AddOther(oldName);
    if (null == myOther)
    {
        return false;
    }

    //try to duplicate a new instance using duplicate method
    //make sure the name of new material is unique in MaterailSet
    string newName = "new" + myOther.Name;
    MaterialOther newOther = myOther.Duplicate(newName) as MaterialOther;
    if (null == newOther)
    {
        MessageBox.Show("Failed to duplicate an other material!");
        return false;
    }
    else
    {
        MessageBox.Show("Duplicated other material.");
    }

    // Remove the original created material
    document.Settings.Materials.Remove(oldName);

    if (document.Settings.Materials.Contains(oldName) == false)
    {
        MessageBox.Show("Material (myOtherMaterial) removed successfully!", "Revit");
    }

    return true;
}
CopyVB.NET
Private Function CreateOtherMaterial(ByVal document As Autodesk.Revit.Document) As Boolean
    Dim oldName As String = "myOtherMaterial"
    Dim myOther As MaterialOther = document.Settings.Materials.AddOther(oldName)
    If myOther Is Nothing Then
        Return False
    End If

    'try to duplicate a new instance using duplicate method
    'make sure the name of new material is unique in MaterailSet
    Dim newName As String = "new" & myOther.Name
    Dim newOther As MaterialOther = TryCast(myOther.Duplicate(newName), MaterialOther)
    If newOther Is Nothing Then
        MessageBox.Show("Failed to duplicate an other material!")
        Return False
    Else
        MessageBox.Show("Duplicated other material.")
    End If

    ' Remove the original created material
    document.Settings.Materials.Remove(oldName)

    If document.Settings.Materials.Contains(oldName) = False Then
        MessageBox.Show("Material (myOtherMaterial) removed successfully!", "Revit")
    End If

    Return True
End Function

See Also

Materials Class
Autodesk.Revit Namespace


AddSteel Method

[image]

Revit 2010 API
Materials..::.AddSteel Method
Materials Class Example See Also Send Feedback
Add a steel material with the given name .

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialSteel AddSteel(
    string name
)
Visual Basic (Declaration)
Public Function AddSteel ( _
    name As String _
) As MaterialSteel
Visual C++
public:
MaterialSteel^ AddSteel(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the steel material to be added.

Return Value

The pointer to the added steel material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

Examples

CopyC#
private MaterialSteel AddSteel(Document document)
{
    string newName = "mySteelMaterial";
    MaterialSteel mySteel = document.Settings.Materials.AddSteel(newName);

    if (null != mySteel)
    {
        MessageBox.Show("Steel material added successfully!", "Revit");
    }

    return mySteel;
}
CopyVB.NET
Private Function AddSteel(ByVal document As Document) As MaterialSteel
    Dim newName As String = "mySteelMaterial"
    Dim mySteel As MaterialSteel = document.Settings.Materials.AddSteel(newName)

    If mySteel IsNot Nothing Then
        MessageBox.Show("Steel material added successfully!", "Revit")
    End If

    Return mySteel
End Function

See Also

Materials Class
Autodesk.Revit Namespace


AddWood Method

[image]

Revit 2010 API
Materials..::.AddWood Method
Materials Class Example See Also Send Feedback
Add a wood material with the given name .

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialWood AddWood(
    string name
)
Visual Basic (Declaration)
Public Function AddWood ( _
    name As String _
) As MaterialWood
Visual C++
public:
MaterialWood^ AddWood(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the wood material to be added.

Return Value

The pointer to the added wood material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

Examples

CopyC#
private MaterialWood AddWood(Document document)
{
    string newName = "myWoodMaterial";
    MaterialWood myWood = document.Settings.Materials.AddWood(newName);

    if (null != myWood)
    {
        MessageBox.Show("Wood material added successfully!", "Revit");
    }

    return myWood;
}
CopyVB.NET
Private Function AddWood(ByVal document As Document) As MaterialWood
    Dim newName As String = "myWoodMaterial"
    Dim myWood As MaterialWood = document.Settings.Materials.AddWood(newName)

    If myWood IsNot Nothing Then
        MessageBox.Show("Wood material added successfully!", "Revit")
    End If

    Return myWood
End Function

See Also

Materials Class
Autodesk.Revit Namespace


Contains Method

[image] [image]

Revit 2010 API
Materials..::.Contains Method
Materials Class See Also Send Feedback
Checks if the material set contains the material with the specified identifier.

Overload List

Name | Description
Contains(ElementId) | Checks if the material set contains the material with the specified ID.
Contains(String) | Checks if the material set contains the material with the specified name .
Contains(Material) | Tests for the existence of a material within the set. (Inherited from MaterialSet.)

See Also

Materials Class
Materials Members
Autodesk.Revit Namespace


Contains Method (ElementId)

[image]

Revit 2010 API
Materials..::.Contains Method (ElementId)
Materials Class See Also Send Feedback
Checks if the material set contains the material with the specified ID.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Contains(
    ElementId itemId
)
Visual Basic (Declaration)
Public Function Contains ( _
    itemId As ElementId _
) As Boolean
Visual C++
public:
bool Contains(
    ElementId itemId
)

Parameters

itemId
Type: Autodesk.Revit..::.ElementId
The ID of the material to be found.

Return Value

Returns true if the material set contains the material with the specified ID, and false if not.

See Also

Materials Class
Contains Overload
Autodesk.Revit Namespace


Contains Method (String)

[image]

Revit 2010 API
Materials..::.Contains Method (String)
Materials Class See Also Send Feedback
Checks if the material set contains the material with the specified name .

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Contains(
    string name
)
Visual Basic (Declaration)
Public Function Contains ( _
    name As String _
) As Boolean
Visual C++
public:
bool Contains(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the material to found.

Return Value

Returns true if the material set contains the material with the specified name, and returns false if not.

See Also

Materials Class
Contains Overload
Autodesk.Revit Namespace


Remove Method

[image]

Revit 2010 API
Materials..::.Remove Method
Materials Class See Also Send Feedback
Remove the material with the speicified name .

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Remove(
    string matName
)
Visual Basic (Declaration)
Public Sub Remove ( _
    matName As String _
)
Visual C++
public:
void Remove(
    String^ matName
)

Parameters

matName
Type: System..::.String
The name of the material to be removed.

See Also

Materials Class
Autodesk.Revit Namespace


Materials Properties

[image] [image]

Revit 2010 API
Materials Properties
Materials Class See Also Send Feedback

The Materials type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from MaterialSet.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Overloaded. Gets the material with the specified identifier.
Size | Returns the number of materials that are in the set. (Inherited from MaterialSet.)

See Also

Materials Class
Autodesk.Revit Namespace


Item Property

[image] [image]

Revit 2010 API
Materials..::.Item Property
Materials Class See Also Send Feedback
Gets the material with the specified identifier.

Overload List

Name | Description
Item[([(ElementId])]) | Gets the material with the specified ID.
Item[([(String])]) | Gets the material with the specified name.

See Also

Materials Class
Materials Members
Autodesk.Revit Namespace


Item Property (ElementId)

[image]

Revit 2010 API
Materials..::.Item Property (ElementId)
Materials Class See Also Send Feedback
Gets the material with the specified ID.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Material Item[
    ElementId itemId
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Item ( _
    itemId As ElementId _
) As Material
Visual C++
public:
property Material^ Item[ElementId itemId] {
    Material^ get (ElementId itemId);
}

Parameters

itemId
Type: Autodesk.Revit..::.ElementId
The ID of the material to be found.

Remarks

If the material with the specified ID does not exist, null pointer will be returned.

See Also

Materials Class
Item Overload
Autodesk.Revit Namespace


Item Property (String)

[image]

Revit 2010 API
Materials..::.Item Property (String)
Materials Class Example See Also Send Feedback
Gets the material with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Material Item[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Item ( _
    name As String _
) As Material
Visual C++
public:
property Material^ Item[String^ name] {
    Material^ get (String^ name);
}

Parameters

name
Type: System..::.String
The name of the material to be found.

Remarks

If the material with the specified name does not exist, null pointer will be returned.

Examples

CopyC#
Materials materials = document.Settings.Materials;
Material floorMaterial = null;
string floorMaterialName = "Default Floor";
floorMaterial = materials.get_Item(floorMaterialName);
if (null != floorMaterial)
{
    MessageBox.Show("Material found.", "Revit");
}
CopyVB.NET
Dim materials As Materials = document.Settings.Materials
Dim floorMaterial As Autodesk.Revit.Elements.Material = Nothing
Dim floorMaterialName As String = "Default Floor"
floorMaterial = materials.Item(floorMaterialName)
If floorMaterial IsNot Nothing Then
    MessageBox.Show("Material found.", "Revit")
End If

See Also

Materials Class
Item Overload
Autodesk.Revit Namespace


MaterialSet Class

[image]

Revit 2010 API
MaterialSet Class
Members See Also Send Feedback
An set that contains materials.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MaterialSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class MaterialSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class MaterialSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.MaterialSet
Autodesk.Revit..::.Materials

See Also

MaterialSet Members
Autodesk.Revit Namespace


MaterialSet Members

[image] [image]

Revit 2010 API
MaterialSet Members
MaterialSet Class Constructors Methods Properties See Also Send Feedback

The MaterialSet type exposes the following members.

Constructors

Name | Description
MaterialSet | Initializes a new instance of the MaterialSet class

Methods

Name | Description
Clear | Removes every material from the set, rendering it empty.
Contains | Tests for the existence of a material within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified material from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified material into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of materials that are in the set.

See Also

MaterialSet Class
Autodesk.Revit Namespace


MaterialSet Constructor

[image]

Revit 2010 API
MaterialSet Constructor
MaterialSet Class See Also Send Feedback
Initializes a new instance of the MaterialSet class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MaterialSet()

See Also

MaterialSet Class
Autodesk.Revit Namespace


MaterialSet Methods

[image] [image]

Revit 2010 API
MaterialSet Methods
MaterialSet Class See Also Send Feedback

The MaterialSet type exposes the following members.

Methods

Name | Description
Clear | Removes every material from the set, rendering it empty.
Contains | Tests for the existence of a material within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified material from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified material into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaterialSet Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
MaterialSet..::.Clear Method
MaterialSet Class See Also Send Feedback
Removes every material from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

MaterialSet Class
Autodesk.Revit Namespace


Contains Method

[image]

Revit 2010 API
MaterialSet..::.Contains Method
MaterialSet Class See Also Send Feedback
Tests for the existence of a material within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    Material item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Material _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Material^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.Material
The material to be searched for.

Return Value

The Contains method returns True if the material is within the set, otherwise False.

See Also

MaterialSet Class
Autodesk.Revit Namespace


Erase Method

[image]

Revit 2010 API
MaterialSet..::.Erase Method
MaterialSet Class See Also Send Feedback
Removes a specified material from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    Material item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Material _
) As Integer
Visual C++
public:
virtual int Erase(
    Material^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.Material
The material to be erased.

Return Value

The number of materials that were erased from the set.

See Also

MaterialSet Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
MaterialSet..::.ForwardIterator Method
MaterialSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual MaterialSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As MaterialSetIterator
Visual C++
public:
virtual MaterialSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

MaterialSet Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
MaterialSet..::.GetEnumerator Method
MaterialSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

MaterialSet Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
MaterialSet..::.Insert Method
MaterialSet Class See Also Send Feedback
Insert the specified material into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    Material item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Material _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Material^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.Material
The material to be inserted into the set.

Return Value

Returns whether the material was inserted into the set.

See Also

MaterialSet Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
MaterialSet..::.ReverseIterator Method
MaterialSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual MaterialSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As MaterialSetIterator
Visual C++
public:
virtual MaterialSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

MaterialSet Class
Autodesk.Revit Namespace


MaterialSet Properties

[image] [image]

Revit 2010 API
MaterialSet Properties
MaterialSet Class See Also Send Feedback

The MaterialSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of materials that are in the set.

See Also

MaterialSet Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
MaterialSet..::.IsEmpty Property
MaterialSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

MaterialSet Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
MaterialSet..::.Size Property
MaterialSet Class See Also Send Feedback
Returns the number of materials that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

MaterialSet Class
Autodesk.Revit Namespace


MaterialSetIterator Class

[image]

Revit 2010 API
MaterialSetIterator Class
Members See Also Send Feedback
An iterator to a material set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class MaterialSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class MaterialSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class MaterialSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.MaterialSetIterator

See Also

MaterialSetIterator Members
Autodesk.Revit Namespace


MaterialSetIterator Members

[image] [image]

Revit 2010 API
MaterialSetIterator Members
MaterialSetIterator Class Constructors Methods Properties See Also Send Feedback

The MaterialSetIterator type exposes the following members.

Constructors

Name | Description
MaterialSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MaterialSetIterator Class
Autodesk.Revit Namespace


MaterialSetIterator Constructor

[image]

Revit 2010 API
MaterialSetIterator Constructor
MaterialSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MaterialSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MaterialSetIterator Class
Autodesk.Revit Namespace


MaterialSetIterator Methods

[image] [image]

Revit 2010 API
MaterialSetIterator Methods
MaterialSetIterator Class See Also Send Feedback

The MaterialSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaterialSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
MaterialSetIterator..::.MoveNext Method
MaterialSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

MaterialSetIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
MaterialSetIterator..::.Reset Method
MaterialSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

MaterialSetIterator Class
Autodesk.Revit Namespace


MaterialSetIterator Properties

[image] [image]

Revit 2010 API
MaterialSetIterator Properties
MaterialSetIterator Class See Also Send Feedback

The MaterialSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MaterialSetIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
MaterialSetIterator..::.Current Property
MaterialSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

MaterialSetIterator Class
Autodesk.Revit Namespace


MEPSpaceConstruction Class

[image]

Revit 2010 API
MEPSpaceConstruction Class
Members See Also Send Feedback
Construction definition for Space.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MEPSpaceConstruction
Visual Basic (Declaration)
Public Class MEPSpaceConstruction
Visual C++
public ref class MEPSpaceConstruction

Remarks

This is used to define the information in Constructions.xml.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.MEPSpaceConstruction

See Also

MEPSpaceConstruction Members
Autodesk.Revit Namespace


MEPSpaceConstruction Members

[image] [image]

Revit 2010 API
MEPSpaceConstruction Members
MEPSpaceConstruction Class Constructors Methods Properties See Also Send Feedback

The MEPSpaceConstruction type exposes the following members.

Constructors

Name | Description
MEPSpaceConstruction | For Internal Use Only.

Methods

Name | Description
DeleteConstruction | Remove an existing construction from Space constructions.
DuplicateConstruction | Create a new construction for Space constructions.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewConstruction | Create a new construction for Space constructions.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurrentConstruction | Get all the Building Constructions according to the specific Construction type.
SpaceConstructions | Return all the Space constructions of current space.

See Also

MEPSpaceConstruction Class
Autodesk.Revit Namespace


MEPSpaceConstruction Constructor

[image]

Revit 2010 API
MEPSpaceConstruction Constructor
MEPSpaceConstruction Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MEPSpaceConstruction()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MEPSpaceConstruction()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MEPSpaceConstruction Class
Autodesk.Revit Namespace


MEPSpaceConstruction Methods

[image] [image]

Revit 2010 API
MEPSpaceConstruction Methods
MEPSpaceConstruction Class See Also Send Feedback

The MEPSpaceConstruction type exposes the following members.

Methods

Name | Description
DeleteConstruction | Remove an existing construction from Space constructions.
DuplicateConstruction | Create a new construction for Space constructions.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewConstruction | Create a new construction for Space constructions.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPSpaceConstruction Class
Autodesk.Revit Namespace


DeleteConstruction Method

[image]

Revit 2010 API
MEPSpaceConstruction..::.DeleteConstruction Method
MEPSpaceConstruction Class See Also Send Feedback
Remove an existing construction from Space constructions.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void DeleteConstruction(
    MEPBuildingConstruction pCurrentConstruction
)
Visual Basic (Declaration)
Public Sub DeleteConstruction ( _
    pCurrentConstruction As MEPBuildingConstruction _
)
Visual C++
public:
void DeleteConstruction(
    MEPBuildingConstruction^ pCurrentConstruction
)

Parameters

pCurrentConstruction
Type: Autodesk.Revit.Symbols..::.MEPBuildingConstruction
The Construction will be deleted.

See Also

MEPSpaceConstruction Class
Autodesk.Revit Namespace


DuplicateConstruction Method

[image]

Revit 2010 API
MEPSpaceConstruction..::.DuplicateConstruction Method
MEPSpaceConstruction Class See Also Send Feedback
Create a new construction for Space constructions.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MEPBuildingConstruction DuplicateConstruction(
    MEPBuildingConstruction pCurrentConstruction,
    string pName
)
Visual Basic (Declaration)
Public Function DuplicateConstruction ( _
    pCurrentConstruction As MEPBuildingConstruction, _
    pName As String _
) As MEPBuildingConstruction
Visual C++
public:
MEPBuildingConstruction^ DuplicateConstruction(
    MEPBuildingConstruction^ pCurrentConstruction,
    String^ pName
)

Parameters

pCurrentConstruction
Type: Autodesk.Revit.Symbols..::.MEPBuildingConstruction
The existing construction to be duplicated.
pName
Type: System..::.String
The name of the new construction.

Remarks

If the name is same with the existing one, an exception will be thrown.

See Also

MEPSpaceConstruction Class
Autodesk.Revit Namespace


NewConstruction Method

[image]

Revit 2010 API
MEPSpaceConstruction..::.NewConstruction Method
MEPSpaceConstruction Class See Also Send Feedback
Create a new construction for Space constructions.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MEPBuildingConstruction NewConstruction(
    string pName
)
Visual Basic (Declaration)
Public Function NewConstruction ( _
    pName As String _
) As MEPBuildingConstruction
Visual C++
public:
MEPBuildingConstruction^ NewConstruction(
    String^ pName
)

Parameters

pName
Type: System..::.String
The name of the new Construction.

Remarks

If the name is same as an existing one, an exception will be thrown.

See Also

MEPSpaceConstruction Class
Autodesk.Revit Namespace


MEPSpaceConstruction Properties

[image] [image]

Revit 2010 API
MEPSpaceConstruction Properties
MEPSpaceConstruction Class See Also Send Feedback

The MEPSpaceConstruction type exposes the following members.

Properties

Name | Description
CurrentConstruction | Get all the Building Constructions according to the specific Construction type.
SpaceConstructions | Return all the Space constructions of current space.

See Also

MEPSpaceConstruction Class
Autodesk.Revit Namespace


CurrentConstruction Property

[image]

Revit 2010 API
MEPSpaceConstruction..::.CurrentConstruction Property
MEPSpaceConstruction Class See Also Send Feedback
Get all the Building Constructions according to the specific Construction type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MEPBuildingConstruction CurrentConstruction { get; set; }
Visual Basic (Declaration)
Public Property CurrentConstruction As MEPBuildingConstruction
Visual C++
public:
property MEPBuildingConstruction^ CurrentConstruction {
    MEPBuildingConstruction^ get ();
    void set (MEPBuildingConstruction^ value);
}

Remarks

This property is used to get or set the Building Service of the Project Information.

See Also

MEPSpaceConstruction Class
Autodesk.Revit Namespace


SpaceConstructions Property

[image]

Revit 2010 API
MEPSpaceConstruction..::.SpaceConstructions Property
MEPSpaceConstruction Class See Also Send Feedback
Return all the Space constructions of current space.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MEPBuildingConstructionSet SpaceConstructions { get; }
Visual Basic (Declaration)
Public ReadOnly Property SpaceConstructions As MEPBuildingConstructionSet
Visual C++
public:
property MEPBuildingConstructionSet^ SpaceConstructions {
    MEPBuildingConstructionSet^ get ();
}

Remarks

If the name is same with the existing one, an exception will be thrown.

See Also

MEPSpaceConstruction Class
Autodesk.Revit Namespace


ObjectFactory Class

[image]

Revit 2010 API
ObjectFactory Class
Members See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ObjectFactory : IDisposable
Visual Basic (Declaration)
Public Class ObjectFactory _
    Implements IDisposable
Visual C++
public ref class ObjectFactory : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.ObjectFactory

See Also

ObjectFactory Members
Autodesk.Revit Namespace


ObjectFactory Members

[image] [image]

Revit 2010 API
ObjectFactory Members
ObjectFactory Class Constructors Methods See Also Send Feedback

The ObjectFactory type exposes the following members.

Constructors

Name | Description
ObjectFactory | For Internal Use Only.

Methods

Name | Description
CreateInstance | For Internal Use Only.
Dispose | For Internal Use Only.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInstance | For Internal Use Only.
GetType | Gets the Type of the current instance. (Inherited from Object.)
RemoveInstance | For Internal Use Only.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObjectFactory Class
Autodesk.Revit Namespace


ObjectFactory Constructor

[image]

Revit 2010 API
ObjectFactory Constructor
ObjectFactory Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ObjectFactory()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ObjectFactory()

Return Value

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ObjectFactory Class
Autodesk.Revit Namespace


ObjectFactory Methods

[image] [image]

Revit 2010 API
ObjectFactory Methods
ObjectFactory Class See Also Send Feedback

The ObjectFactory type exposes the following members.

Methods

Name | Description
CreateInstance | For Internal Use Only.
Dispose | For Internal Use Only.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInstance | For Internal Use Only.
GetType | Gets the Type of the current instance. (Inherited from Object.)
RemoveInstance | For Internal Use Only.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObjectFactory Class
Autodesk.Revit Namespace


CreateInstance Method

[image]

Revit 2010 API
ObjectFactory..::.CreateInstance Method
ObjectFactory Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public APIObject CreateInstance(
    IntPtr pRuntimeClass,
    IntPtr pData,
    IntPtr tag
)
Visual Basic (Declaration)
Public Function CreateInstance ( _
    pRuntimeClass As IntPtr, _
    pData As IntPtr, _
    tag As IntPtr _
) As APIObject
Visual C++
public:
APIObject^ CreateInstance(
    IntPtr pRuntimeClass,
    IntPtr pData,
    IntPtr tag
)

Parameters

pRuntimeClass
Type: System..::.IntPtr
pData
Type: System..::.IntPtr
tag
Type: System..::.IntPtr

Return Value

See Also

ObjectFactory Class
Autodesk.Revit Namespace


Dispose Method

[image]

Revit 2010 API
ObjectFactory..::.Dispose Method
ObjectFactory Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

ObjectFactory Class
Autodesk.Revit Namespace


GetInstance Method

[image]

Revit 2010 API
ObjectFactory..::.GetInstance Method
ObjectFactory Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public APIObject GetInstance(
    IntPtr pRuntimeClass,
    IntPtr pData,
    IntPtr tag
)
Visual Basic (Declaration)
Public Function GetInstance ( _
    pRuntimeClass As IntPtr, _
    pData As IntPtr, _
    tag As IntPtr _
) As APIObject
Visual C++
public:
APIObject^ GetInstance(
    IntPtr pRuntimeClass,
    IntPtr pData,
    IntPtr tag
)

Parameters

pRuntimeClass
Type: System..::.IntPtr
pData
Type: System..::.IntPtr
tag
Type: System..::.IntPtr

Return Value

See Also

ObjectFactory Class
Autodesk.Revit Namespace


RemoveInstance Method

[image]

Revit 2010 API
ObjectFactory..::.RemoveInstance Method
ObjectFactory Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveInstance(
    IntPtr tag
)
Visual Basic (Declaration)
Public Sub RemoveInstance ( _
    tag As IntPtr _
)
Visual C++
public:
void RemoveInstance(
    IntPtr tag
)

Parameters

tag
Type: System..::.IntPtr

See Also

ObjectFactory Class
Autodesk.Revit Namespace


PaperSize Class

[image]

Revit 2010 API
PaperSize Class
Members See Also Send Feedback
An object that represents a Paper Size of Print Setup within the Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PaperSize : APIObject
Visual Basic (Declaration)
Public Class PaperSize _
    Inherits APIObject
Visual C++
public ref class PaperSize : public APIObject

Remarks

This object derived from the APIObject base object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.PaperSize

See Also

PaperSize Members
Autodesk.Revit Namespace


PaperSize Members

[image] [image]

Revit 2010 API
PaperSize Members
PaperSize Class Constructors Methods Properties See Also Send Feedback

The PaperSize type exposes the following members.

Constructors

Name | Description
PaperSize | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Retrieve the paper size name of current project.

See Also

PaperSize Class
Autodesk.Revit Namespace


PaperSize Constructor

[image]

Revit 2010 API
PaperSize Constructor
PaperSize Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PaperSize()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaperSize()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PaperSize Class
Autodesk.Revit Namespace


PaperSize Methods

[image] [image]

Revit 2010 API
PaperSize Methods
PaperSize Class See Also Send Feedback

The PaperSize type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaperSize Class
Autodesk.Revit Namespace


PaperSize Properties

[image] [image]

Revit 2010 API
PaperSize Properties
PaperSize Class See Also Send Feedback

The PaperSize type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Retrieve the paper size name of current project.

See Also

PaperSize Class
Autodesk.Revit Namespace


Name Property

[image]

Revit 2010 API
PaperSize..::.Name Property
PaperSize Class See Also Send Feedback
Retrieve the paper size name of current project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

PaperSize Class
Autodesk.Revit Namespace


PaperSizeSet Class

[image]

Revit 2010 API
PaperSizeSet Class
Members See Also Send Feedback
A set that can contain any number of paper size objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PaperSizeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class PaperSizeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PaperSizeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.PaperSizeSet

See Also

PaperSizeSet Members
Autodesk.Revit Namespace


PaperSizeSet Members

[image] [image]

Revit 2010 API
PaperSizeSet Members
PaperSizeSet Class Constructors Methods Properties See Also Send Feedback

The PaperSizeSet type exposes the following members.

Constructors

Name | Description
PaperSizeSet | Initializes a new instance of the PaperSizeSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


PaperSizeSet Constructor

[image]

Revit 2010 API
PaperSizeSet Constructor
PaperSizeSet Class See Also Send Feedback
Initializes a new instance of the PaperSizeSet class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PaperSizeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaperSizeSet()

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


PaperSizeSet Methods

[image] [image]

Revit 2010 API
PaperSizeSet Methods
PaperSizeSet Class See Also Send Feedback

The PaperSizeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
PaperSizeSet..::.Clear Method
PaperSizeSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


Contains Method

[image]

Revit 2010 API
PaperSizeSet..::.Contains Method
PaperSizeSet Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    PaperSize item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As PaperSize _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PaperSize^ item
)

Parameters

item
Type: Autodesk.Revit..::.PaperSize
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


Erase Method

[image]

Revit 2010 API
PaperSizeSet..::.Erase Method
PaperSizeSet Class See Also Send Feedback
Removes a specified object from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    PaperSize item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As PaperSize _
) As Integer
Visual C++
public:
virtual int Erase(
    PaperSize^ item
)

Parameters

item
Type: Autodesk.Revit..::.PaperSize
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
PaperSizeSet..::.ForwardIterator Method
PaperSizeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual PaperSizeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PaperSizeSetIterator
Visual C++
public:
virtual PaperSizeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
PaperSizeSet..::.GetEnumerator Method
PaperSizeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
PaperSizeSet..::.Insert Method
PaperSizeSet Class See Also Send Feedback
Insert the specified item into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    PaperSize item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As PaperSize _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PaperSize^ item
)

Parameters

item
Type: Autodesk.Revit..::.PaperSize
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
PaperSizeSet..::.ReverseIterator Method
PaperSizeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual PaperSizeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PaperSizeSetIterator
Visual C++
public:
virtual PaperSizeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


PaperSizeSet Properties

[image] [image]

Revit 2010 API
PaperSizeSet Properties
PaperSizeSet Class See Also Send Feedback

The PaperSizeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
PaperSizeSet..::.IsEmpty Property
PaperSizeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
PaperSizeSet..::.Size Property
PaperSizeSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PaperSizeSet Class
Autodesk.Revit Namespace


PaperSizeSetIterator Class

[image]

Revit 2010 API
PaperSizeSetIterator Class
Members See Also Send Feedback
An iterator to a set of paper size objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class PaperSizeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class PaperSizeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PaperSizeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.PaperSizeSetIterator

See Also

PaperSizeSetIterator Members
Autodesk.Revit Namespace


PaperSizeSetIterator Members

[image] [image]

Revit 2010 API
PaperSizeSetIterator Members
PaperSizeSetIterator Class Constructors Methods Properties See Also Send Feedback

The PaperSizeSetIterator type exposes the following members.

Constructors

Name | Description
PaperSizeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PaperSizeSetIterator Class
Autodesk.Revit Namespace


PaperSizeSetIterator Constructor

[image]

Revit 2010 API
PaperSizeSetIterator Constructor
PaperSizeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PaperSizeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaperSizeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PaperSizeSetIterator Class
Autodesk.Revit Namespace


PaperSizeSetIterator Methods

[image] [image]

Revit 2010 API
PaperSizeSetIterator Methods
PaperSizeSetIterator Class See Also Send Feedback

The PaperSizeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaperSizeSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
PaperSizeSetIterator..::.MoveNext Method
PaperSizeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PaperSizeSetIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
PaperSizeSetIterator..::.Reset Method
PaperSizeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PaperSizeSetIterator Class
Autodesk.Revit Namespace


PaperSizeSetIterator Properties

[image] [image]

Revit 2010 API
PaperSizeSetIterator Properties
PaperSizeSetIterator Class See Also Send Feedback

The PaperSizeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PaperSizeSetIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
PaperSizeSetIterator..::.Current Property
PaperSizeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PaperSizeSetIterator Class
Autodesk.Revit Namespace


PaperSource Class

[image]

Revit 2010 API
PaperSource Class
Members See Also Send Feedback
An object that represents a Paper Source of Print Setup within the Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PaperSource : APIObject
Visual Basic (Declaration)
Public Class PaperSource _
    Inherits APIObject
Visual C++
public ref class PaperSource : public APIObject

Remarks

This object derived from the APIObject base object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.PaperSource

See Also

PaperSource Members
Autodesk.Revit Namespace


PaperSource Members

[image] [image]

Revit 2010 API
PaperSource Members
PaperSource Class Constructors Methods Properties See Also Send Feedback

The PaperSource type exposes the following members.

Constructors

Name | Description
PaperSource | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Retrieve the paper source name of current project.

See Also

PaperSource Class
Autodesk.Revit Namespace


PaperSource Constructor

[image]

Revit 2010 API
PaperSource Constructor
PaperSource Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PaperSource()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaperSource()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PaperSource Class
Autodesk.Revit Namespace


PaperSource Methods

[image] [image]

Revit 2010 API
PaperSource Methods
PaperSource Class See Also Send Feedback

The PaperSource type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaperSource Class
Autodesk.Revit Namespace


PaperSource Properties

[image] [image]

Revit 2010 API
PaperSource Properties
PaperSource Class See Also Send Feedback

The PaperSource type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Retrieve the paper source name of current project.

See Also

PaperSource Class
Autodesk.Revit Namespace


Name Property

[image]

Revit 2010 API
PaperSource..::.Name Property
PaperSource Class See Also Send Feedback
Retrieve the paper source name of current project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

PaperSource Class
Autodesk.Revit Namespace


PaperSourceSet Class

[image]

Revit 2010 API
PaperSourceSet Class
Members See Also Send Feedback
A set that can contain any number of paper source objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PaperSourceSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class PaperSourceSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PaperSourceSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.PaperSourceSet

See Also

PaperSourceSet Members
Autodesk.Revit Namespace


PaperSourceSet Members

[image] [image]

Revit 2010 API
PaperSourceSet Members
PaperSourceSet Class Constructors Methods Properties See Also Send Feedback

The PaperSourceSet type exposes the following members.

Constructors

Name | Description
PaperSourceSet | Initializes a new instance of the PaperSourceSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


PaperSourceSet Constructor

[image]

Revit 2010 API
PaperSourceSet Constructor
PaperSourceSet Class See Also Send Feedback
Initializes a new instance of the PaperSourceSet class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PaperSourceSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaperSourceSet()

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


PaperSourceSet Methods

[image] [image]

Revit 2010 API
PaperSourceSet Methods
PaperSourceSet Class See Also Send Feedback

The PaperSourceSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
PaperSourceSet..::.Clear Method
PaperSourceSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


Contains Method

[image]

Revit 2010 API
PaperSourceSet..::.Contains Method
PaperSourceSet Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    PaperSource item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As PaperSource _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PaperSource^ item
)

Parameters

item
Type: Autodesk.Revit..::.PaperSource
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


Erase Method

[image]

Revit 2010 API
PaperSourceSet..::.Erase Method
PaperSourceSet Class See Also Send Feedback
Removes a specified object from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    PaperSource item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As PaperSource _
) As Integer
Visual C++
public:
virtual int Erase(
    PaperSource^ item
)

Parameters

item
Type: Autodesk.Revit..::.PaperSource
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
PaperSourceSet..::.ForwardIterator Method
PaperSourceSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual PaperSourceSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PaperSourceSetIterator
Visual C++
public:
virtual PaperSourceSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
PaperSourceSet..::.GetEnumerator Method
PaperSourceSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
PaperSourceSet..::.Insert Method
PaperSourceSet Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    PaperSource item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As PaperSource _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PaperSource^ item
)

Parameters

item
Type: Autodesk.Revit..::.PaperSource

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
PaperSourceSet..::.ReverseIterator Method
PaperSourceSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual PaperSourceSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PaperSourceSetIterator
Visual C++
public:
virtual PaperSourceSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


PaperSourceSet Properties

[image] [image]

Revit 2010 API
PaperSourceSet Properties
PaperSourceSet Class See Also Send Feedback

The PaperSourceSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
PaperSourceSet..::.IsEmpty Property
PaperSourceSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
PaperSourceSet..::.Size Property
PaperSourceSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PaperSourceSet Class
Autodesk.Revit Namespace


PaperSourceSetIterator Class

[image]

Revit 2010 API
PaperSourceSetIterator Class
Members See Also Send Feedback
An iterator to a set of paper source objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class PaperSourceSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class PaperSourceSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PaperSourceSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.PaperSourceSetIterator

See Also

PaperSourceSetIterator Members
Autodesk.Revit Namespace


PaperSourceSetIterator Members

[image] [image]

Revit 2010 API
PaperSourceSetIterator Members
PaperSourceSetIterator Class Constructors Methods Properties See Also Send Feedback

The PaperSourceSetIterator type exposes the following members.

Constructors

Name | Description
PaperSourceSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PaperSourceSetIterator Class
Autodesk.Revit Namespace


PaperSourceSetIterator Constructor

[image]

Revit 2010 API
PaperSourceSetIterator Constructor
PaperSourceSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PaperSourceSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaperSourceSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PaperSourceSetIterator Class
Autodesk.Revit Namespace


PaperSourceSetIterator Methods

[image] [image]

Revit 2010 API
PaperSourceSetIterator Methods
PaperSourceSetIterator Class See Also Send Feedback

The PaperSourceSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaperSourceSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
PaperSourceSetIterator..::.MoveNext Method
PaperSourceSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PaperSourceSetIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
PaperSourceSetIterator..::.Reset Method
PaperSourceSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PaperSourceSetIterator Class
Autodesk.Revit Namespace


PaperSourceSetIterator Properties

[image] [image]

Revit 2010 API
PaperSourceSetIterator Properties
PaperSourceSetIterator Class See Also Send Feedback

The PaperSourceSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PaperSourceSetIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
PaperSourceSetIterator..::.Current Property
PaperSourceSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PaperSourceSetIterator Class
Autodesk.Revit Namespace


Parameter Class

[image]

Revit 2010 API
Parameter Class
Members See Also Send Feedback
The parameter object contains the value data assigned to that parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Parameter : APIObject
Visual Basic (Declaration)
Public Class Parameter _
    Inherits APIObject
Visual C++
public ref class Parameter : public APIObject

Remarks

The piece of data contained within the parameter can be either a Double, Integer, String or ElementId. The parameter object can be retrieved from any Element object using either a built in id, definition object or shared parameter guid. All Elements within Autodesk Revit contain Parameters. These are options that can be accessed in a generic fashion. Revit contains many built in parameter types but users and now developers, via the API, can add their own parameters in the form of shared parameters. The developer should become familiar with the Revit user interface for added and managing parameters and shared parameters before using this API. The user interface components can be found in the following locations: Element Properties dialog, Shared Parameters dialog (available from the File menu), Project Parameters dialog (available from the Settings menu), Family Types dialog (available from the Settings menu when editing a family). There are several relationships between the objects that make up the APIs exposure of parameters. The parameter object contains the data value. Parameter objects can be retrieved from Elements if you know its built-in id, its definition or its shared parameter guid. Each parameter has a definition. New parameters can be added to Elements by adding a ParameterBinding object to the Document object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Parameter

See Also

Parameter Members
Autodesk.Revit Namespace


Parameter Members

[image] [image]

Revit 2010 API
Parameter Members
Parameter Class Constructors Methods Properties See Also Send Feedback

The Parameter type exposes the following members.

Constructors

Name | Description
Parameter | For Internal Use Only.

Methods

Name | Description
AsDouble | Provides access to the double precision number within the parameter.
AsElementId | Provides access to the ElementId stored within the parameter.
AsInteger | Provides access to the integer number within the parameter.
AsString | Provides access to the string contents of the parameter.
AsValueString | Get the parameter value as a string with unit.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Set | Overloaded. Sets the parameter to a new value.
SetValueString | Set the parameter value according to the input string.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Definition | Returns the Definition object that describes the data type, name and other details of the parameter.
DisplayUnitType | Get the display unit type of the parameter object.
Element | The element to which this parameter belongs.
IsReadOnly | Get the readonly property of the parameter. (Overrides APIObject..::.IsReadOnly.)
StorageType | Describes the type that is used internally within the parameter to store its value.

See Also

Parameter Class
Autodesk.Revit Namespace


Parameter Constructor

[image]

Revit 2010 API
Parameter Constructor
Parameter Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Parameter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Parameter()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Parameter Class
Autodesk.Revit Namespace


Parameter Methods

[image] [image]

Revit 2010 API
Parameter Methods
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Methods

Name | Description
AsDouble | Provides access to the double precision number within the parameter.
AsElementId | Provides access to the ElementId stored within the parameter.
AsInteger | Provides access to the integer number within the parameter.
AsString | Provides access to the string contents of the parameter.
AsValueString | Get the parameter value as a string with unit.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Set | Overloaded. Sets the parameter to a new value.
SetValueString | Set the parameter value according to the input string.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Parameter Class
Autodesk.Revit Namespace


AsDouble Method

[image]

Revit 2010 API
Parameter..::.AsDouble Method
Parameter Class See Also Send Feedback
Provides access to the double precision number within the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double AsDouble()
Visual Basic (Declaration)
Public Function AsDouble As Double
Visual C++
public:
double AsDouble()

Return Value

The double value contained in the parameter.

Remarks

The AsDouble method should only be used if the StorageType property returns that the internal contents of the parameter is a double.

See Also

Parameter Class
Autodesk.Revit Namespace


AsElementId Method

[image]

Revit 2010 API
Parameter..::.AsElementId Method
Parameter Class See Also Send Feedback
Provides access to the ElementId stored within the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementId AsElementId()
Visual Basic (Declaration)
Public Function AsElementId As ElementId
Visual C++
public:
ElementId AsElementId()

Return Value

The ElementId contained in the parameter.

Remarks

The AsElementId method should only be used if the StorageType property returns that the internal contents of the parameter is an ElementId.

See Also

Parameter Class
Autodesk.Revit Namespace


AsInteger Method

[image]

Revit 2010 API
Parameter..::.AsInteger Method
Parameter Class See Also Send Feedback
Provides access to the integer number within the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int AsInteger()
Visual Basic (Declaration)
Public Function AsInteger As Integer
Visual C++
public:
int AsInteger()

Return Value

The integer value contained in the parameter.

Remarks

The AsInteger method should only be used if the StorageType property returns that the internal contents of the parameter is an integer.

See Also

Parameter Class
Autodesk.Revit Namespace


AsString Method

[image]

Revit 2010 API
Parameter..::.AsString Method
Parameter Class See Also Send Feedback
Provides access to the string contents of the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string AsString()
Visual Basic (Declaration)
Public Function AsString As String
Visual C++
public:
String^ AsString()

Return Value

The string contained in the parameter.

Remarks

The AsString method should only be used if the StorageType property returns that the internal contents of the parameter is a string.

See Also

Parameter Class
Autodesk.Revit Namespace


AsValueString Method

[image]

Revit 2010 API
Parameter..::.AsValueString Method
Parameter Class Example See Also Send Feedback
Get the parameter value as a string with unit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string AsValueString()
Visual Basic (Declaration)
Public Function AsValueString As String
Visual C++
public:
String^ AsValueString()

Return Value

The string that represents the parameter value.

Remarks

The method only applies to parameters of value types. If the parameter is not a value, the method returns a null pointer.

Examples

CopyC#
String ShowValueParameterInformation(Parameter attribute)
{
    string paramValue = null;
    switch (attribute.StorageType)
    {
        case Autodesk.Revit.Parameters.StorageType.Integer:
            if (Autodesk.Revit.Parameters.ParameterType.YesNo
                                == attribute.Definition.ParameterType)
            {
                paramValue = null;
            }
            else
            {
                paramValue = attribute.AsValueString();
            }
            break;
        case Autodesk.Revit.Parameters.StorageType.Double:
            paramValue = attribute.AsValueString();
            break;
        default:
            paramValue = null;
            break;
    }

    return paramValue;
}
CopyVB.NET
Private Function ShowValueParameterInformation(ByVal attribute As Parameter) As String
    Dim paramValue As String = Nothing
    Select Case attribute.StorageType
        Case Autodesk.Revit.Parameters.StorageType.[Integer]
            If Autodesk.Revit.Parameters.ParameterType.YesNo = attribute.Definition.ParameterType Then
                paramValue = Nothing
            Else
                paramValue = attribute.AsValueString()
            End If
            Exit Select
        Case Autodesk.Revit.Parameters.StorageType.[Double]
            paramValue = attribute.AsValueString()
            Exit Select
        Case Else
            paramValue = Nothing
            Exit Select
    End Select

    Return paramValue
End Function

See Also

Parameter Class
Autodesk.Revit Namespace


Set Method

[image] [image]

Revit 2010 API
Parameter..::.Set Method
Parameter Class See Also Send Feedback
Sets the parameter to a new value.

Overload List

Name | Description
Set(ElementId%) | Sets the parameter to a new element id.
Set(Double) | Sets the parameter to a new real number value.
Set(Int32) | Sets the parameter to a new integer value.
Set(String) | Sets the parameter to a new string of text.

See Also

Parameter Class
Parameter Members
Autodesk.Revit Namespace


Set Method (ElementId)

[image]

Revit 2010 API
Parameter..::.Set Method (ElementId%)
Parameter Class See Also Send Feedback
Sets the parameter to a new element id.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Set(
    ref ElementId value
)
Visual Basic (Declaration)
Public Function Set ( _
    ByRef value As ElementId _
) As Boolean
Visual C++
public:
bool Set(
    ElementId% value
)

Parameters

value
Type: Autodesk.Revit..::.ElementId %
The new element id to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as an ElementId.

See Also

Parameter Class
Set Overload
Autodesk.Revit Namespace


Set Method (Double)

[image]

Revit 2010 API
Parameter..::.Set Method (Double)
Parameter Class Example See Also Send Feedback
Sets the parameter to a new real number value.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Set(
    double value
)
Visual Basic (Declaration)
Public Function Set ( _
    value As Double _
) As Boolean
Visual C++
public:
bool Set(
    double value
)

Parameters

value
Type: System..::.Double
The new double value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as a Double.

Examples

CopyC#
public bool SetParameter(Parameter parameter, double value)
{
    bool result = false;
    //if the parameter is readonly, you can�t change the value of it
    if (null != parameter && !parameter.IsReadOnly)
    {
        StorageType parameterType = parameter.StorageType;
        if (StorageType.Double != parameterType)
        {
            throw new Exception("The storagetypes of value and parameter are different!");
        }
        //If successful, the result is true
        result = parameter.Set(value);
    }

    return result;
}
CopyVB.NET
Public Function SetParameter(ByVal parameter As Parameter, ByVal value As Double) As Boolean
    Dim result As Boolean = False
    'if the parameter is readonly, you can’t change the value of it
    If parameter IsNot Nothing AndAlso Not parameter.IsReadOnly Then
        Dim parameterType As StorageType = parameter.StorageType
        If StorageType.[Double] <> parameterType Then
            Throw New Exception("The storagetypes of value and parameter are different!")
        End If
        'If successful, the result is true
        result = parameter.[Set](value)
    End If

    Return result
End Function

See Also

Parameter Class
Set Overload
Autodesk.Revit Namespace


Set Method (Int32)

[image]

Revit 2010 API
Parameter..::.Set Method (Int32)
Parameter Class See Also Send Feedback
Sets the parameter to a new integer value.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Set(
    int value
)
Visual Basic (Declaration)
Public Function Set ( _
    value As Integer _
) As Boolean
Visual C++
public:
bool Set(
    int value
)

Parameters

value
Type: System..::.Int32
The new integer value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as an integer.

See Also

Parameter Class
Set Overload
Autodesk.Revit Namespace


Set Method (String)

[image]

Revit 2010 API
Parameter..::.Set Method (String)
Parameter Class Example See Also Send Feedback
Sets the parameter to a new string of text.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Set(
    string value
)
Visual Basic (Declaration)
Public Function Set ( _
    value As String _
) As Boolean
Visual C++
public:
bool Set(
    String^ value
)

Parameters

value
Type: System..::.String
The new text value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as a String.

Examples

CopyC#
void AddInstanceComment(Wall wall)
{
    // Get the comment parameter of the element instance
    Parameter commentPara = wall.get_Parameter(BuiltInParameter.ALL_MODEL_INSTANCE_COMMENTS);
    if (null != commentPara)
    {
        // Add a greeting string to the comment
        commentPara.Set("Hello Everyone.");
    }
}
CopyVB.NET
Private Sub AddInstanceComment(ByVal wall As Wall)
    ' Get the comment parameter of the element instance
    Dim commentPara As Parameter = wall.Parameter(BuiltInParameter.ALL_MODEL_INSTANCE_COMMENTS)
    If commentPara IsNot Nothing Then
        ' Add a greeting string to the comment
        commentPara.[Set]("Hello Everyone.")
    End If
End Sub

See Also

Parameter Class
Set Overload
Autodesk.Revit Namespace


SetValueString Method

[image]

Revit 2010 API
Parameter..::.SetValueString Method
Parameter Class Example See Also Send Feedback
Set the parameter value according to the input string.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SetValueString(
    string valueString
)
Visual Basic (Declaration)
Public Function SetValueString ( _
    valueString As String _
) As Boolean
Visual C++
public:
bool SetValueString(
    String^ valueString
)

Parameters

valueString
Type: System..::.String
The string that represents the parameter value.

Return Value

Indicates whether the parameter value is successfully set.

Remarks

The method only applies to parameters of value types.

Examples

CopyC#
public bool SetWithValueString(Parameter foundParameter)
{
    bool result = false;
    if (!foundParameter.IsReadOnly)
    {
        //If successful, the result is true
        result = foundParameter.SetValueString("-22\'3\"");
    }
    return result;
}
CopyVB.NET
Public Function SetWithValueString(ByVal foundParameter As Parameter) As Boolean
    Dim result As Boolean = False
    If Not foundParameter.IsReadOnly Then
        'If successful, the result is true
        result = foundParameter.SetValueString("-22'3""")
    End If
    Return result
End Function

See Also

Parameter Class
Autodesk.Revit Namespace


Parameter Properties

[image] [image]

Revit 2010 API
Parameter Properties
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Properties

Name | Description
Definition | Returns the Definition object that describes the data type, name and other details of the parameter.
DisplayUnitType | Get the display unit type of the parameter object.
Element | The element to which this parameter belongs.
IsReadOnly | Get the readonly property of the parameter. (Overrides APIObject..::.IsReadOnly.)
StorageType | Describes the type that is used internally within the parameter to store its value.

See Also

Parameter Class
Autodesk.Revit Namespace


Definition Property

[image]

Revit 2010 API
Parameter..::.Definition Property
Parameter Class See Also Send Feedback
Returns the Definition object that describes the data type, name and other details of the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Definition Definition { get; }
Visual Basic (Declaration)
Public ReadOnly Property Definition As Definition
Visual C++
public:
property Definition^ Definition {
    Definition^ get ();
}

See Also

Parameter Class
Autodesk.Revit Namespace


DisplayUnitType Property

[image]

Revit 2010 API
Parameter..::.DisplayUnitType Property
Parameter Class See Also Send Feedback
Get the display unit type of the parameter object.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DisplayUnitType DisplayUnitType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayUnitType As DisplayUnitType
Visual C++
public:
property DisplayUnitType DisplayUnitType {
    DisplayUnitType get ();
}

Return Value

The display unit type of the parameter.

Remarks

The property only applies to parameters of value types.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if this parameter is not of value type.

See Also

Parameter Class
Autodesk.Revit Namespace


Element Property

[image]

Revit 2010 API
Parameter..::.Element Property
Parameter Class See Also Send Feedback
The element to which this parameter belongs.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element Element { get; }
Visual Basic (Declaration)
Public ReadOnly Property Element As Element
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

See Also

Parameter Class
Autodesk.Revit Namespace


IsReadOnly Property

[image]

Revit 2010 API
Parameter..::.IsReadOnly Property
Parameter Class See Also Send Feedback
Get the readonly property of the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override bool IsReadOnly { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () override;
}

Remarks

This function can be used to check if the parameter is read-only.

See Also

Parameter Class
Autodesk.Revit Namespace


StorageType Property

[image]

Revit 2010 API
Parameter..::.StorageType Property
Parameter Class See Also Send Feedback
Describes the type that is used internally within the parameter to store its value.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public StorageType StorageType { get; }
Visual Basic (Declaration)
Public ReadOnly Property StorageType As StorageType
Visual C++
public:
property StorageType StorageType {
    StorageType get ();
}

Remarks

The property will return one of the following possibilities: String, Integer, Double or ElementId. Based on the value of this property the correct access and set methods should be used to retrieve and set the parameter's data value.

See Also

Parameter Class
Autodesk.Revit Namespace


ParameterFilter Class

[image]

Revit 2010 API
ParameterFilter Class
Members See Also Send Feedback
To filter elements with specific parameter criterion.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ParameterFilter : Filter
Visual Basic (Declaration)
Public Class ParameterFilter _
    Inherits Filter
Visual C++
public ref class ParameterFilter : public Filter

Remarks

The parameter filter object is used to filter all the elements in the document which meet the given parameter criterion.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Filter
Autodesk.Revit..::.ParameterFilter

See Also

ParameterFilter Members
Autodesk.Revit Namespace


ParameterFilter Members

[image] [image]

Revit 2010 API
ParameterFilter Members
ParameterFilter Class Constructors Methods Properties See Also Send Feedback

The ParameterFilter type exposes the following members.

Constructors

Name | Description
ParameterFilter | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ParameterFilter Class
Autodesk.Revit Namespace


ParameterFilter Constructor

[image]

Revit 2010 API
ParameterFilter Constructor
ParameterFilter Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterFilter()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ParameterFilter Class
Autodesk.Revit Namespace


ParameterFilter Methods

[image] [image]

Revit 2010 API
ParameterFilter Methods
ParameterFilter Class See Also Send Feedback

The ParameterFilter type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterFilter Class
Autodesk.Revit Namespace


ParameterFilter Properties

[image] [image]

Revit 2010 API
ParameterFilter Properties
ParameterFilter Class See Also Send Feedback

The ParameterFilter type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ParameterFilter Class
Autodesk.Revit Namespace


ParameterMap Class

[image]

Revit 2010 API
ParameterMap Class
Members See Also Send Feedback
A map that can contain a mapping of a parameter name (a String) to a parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ParameterMap : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ParameterMap _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ParameterMap : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.ParameterMap

See Also

ParameterMap Members
Autodesk.Revit Namespace


ParameterMap Members

[image] [image]

Revit 2010 API
ParameterMap Members
ParameterMap Class Constructors Methods Properties See Also Send Feedback

The ParameterMap type exposes the following members.

Constructors

Name | Description
ParameterMap | Initializes a new instance of the ParameterMap class

Methods

Name | Description
Clear | Removes every item from the map, rendering it empty.
Contains | Tests for the existence of a key within the map.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a object with the specified key from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item with the specified key into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified key within the map.
Size | Returns the number of objects that are in the map.

See Also

ParameterMap Class
Autodesk.Revit Namespace


ParameterMap Constructor

[image]

Revit 2010 API
ParameterMap Constructor
ParameterMap Class See Also Send Feedback
Initializes a new instance of the ParameterMap class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterMap()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterMap()

See Also

ParameterMap Class
Autodesk.Revit Namespace


ParameterMap Methods

[image] [image]

Revit 2010 API
ParameterMap Methods
ParameterMap Class See Also Send Feedback

The ParameterMap type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the map, rendering it empty.
Contains | Tests for the existence of a key within the map.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a object with the specified key from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item with the specified key into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterMap Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
ParameterMap..::.Clear Method
ParameterMap Class See Also Send Feedback
Removes every item from the map, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ParameterMap Class
Autodesk.Revit Namespace


Contains Method

[image]

Revit 2010 API
ParameterMap..::.Contains Method
ParameterMap Class See Also Send Feedback
Tests for the existence of a key within the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    string key
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
)

Parameters

key
Type: System..::.String
The key to be searched for.

Return Value

The Contains method returns True if the key is within the map, otherwise False.

See Also

ParameterMap Class
Autodesk.Revit Namespace


Erase Method

[image]

Revit 2010 API
ParameterMap..::.Erase Method
ParameterMap Class See Also Send Feedback
Removes a object with the specified key from the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    string key
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    key As String _
) As Integer
Visual C++
public:
virtual int Erase(
    String^ key
)

Parameters

key
Type: System..::.String
The key of the item to be erased.

Return Value

The number of items that were erased from the map.

See Also

ParameterMap Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
ParameterMap..::.ForwardIterator Method
ParameterMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ParameterMapIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ParameterMapIterator
Visual C++
public:
virtual ParameterMapIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the map.

See Also

ParameterMap Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
ParameterMap..::.GetEnumerator Method
ParameterMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the map.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ParameterMap Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
ParameterMap..::.Insert Method
ParameterMap Class See Also Send Feedback
Insert the specified item with the specified key into the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    string key,
    Parameter item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As String, _
    item As Parameter _
) As Boolean
Visual C++
public:
virtual bool Insert(
    String^ key,
    Parameter^ item
)

Parameters

key
Type: System..::.String
The key to be used for inserting the item into the map.
item
Type: Autodesk.Revit..::.Parameter
The item to be inserted into the map.

Return Value

Returns whether the item was inserted into the map.

See Also

ParameterMap Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
ParameterMap..::.ReverseIterator Method
ParameterMap Class See Also Send Feedback
Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ParameterMapIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ParameterMapIterator
Visual C++
public:
virtual ParameterMapIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the map.

See Also

ParameterMap Class
Autodesk.Revit Namespace


ParameterMap Properties

[image] [image]

Revit 2010 API
ParameterMap Properties
ParameterMap Class See Also Send Feedback

The ParameterMap type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified key within the map.
Size | Returns the number of objects that are in the map.

See Also

ParameterMap Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
ParameterMap..::.IsEmpty Property
ParameterMap Class See Also Send Feedback
Test to see if the map is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the map is empty then True will be returned, otherwise False.

See Also

ParameterMap Class
Autodesk.Revit Namespace


Item Property

[image]

Revit 2010 API
ParameterMap..::.Item Property
ParameterMap Class See Also Send Feedback
Gets or sets an item at a specified key within the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Parameter Item[
    string key
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    key As String _
) As Parameter
Visual C++
public:
virtual property Parameter^ Item[String^ key] {
    Parameter^ get (String^ key);
    void set (String^ key, Parameter^ value);
}

Parameters

key
Type: System..::.String
The key of the item to be set or retrieved.

Return Value

Returns the object at the specified key.

See Also

ParameterMap Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
ParameterMap..::.Size Property
ParameterMap Class See Also Send Feedback
Returns the number of objects that are in the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ParameterMap Class
Autodesk.Revit Namespace


ParameterMapIterator Class

[image]

Revit 2010 API
ParameterMapIterator Class
Members See Also Send Feedback
An iterator to a map relating a parameter name (the key, a String) to a parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ParameterMapIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ParameterMapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ParameterMapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.ParameterMapIterator

See Also

ParameterMapIterator Members
Autodesk.Revit Namespace


ParameterMapIterator Members

[image] [image]

Revit 2010 API
ParameterMapIterator Members
ParameterMapIterator Class Constructors Methods Properties See Also Send Feedback

The ParameterMapIterator type exposes the following members.

Constructors

Name | Description
ParameterMapIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Key | Retrieves the key that is the current focus of the iterator.

See Also

ParameterMapIterator Class
Autodesk.Revit Namespace


ParameterMapIterator Constructor

[image]

Revit 2010 API
ParameterMapIterator Constructor
ParameterMapIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterMapIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterMapIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ParameterMapIterator Class
Autodesk.Revit Namespace


ParameterMapIterator Methods

[image] [image]

Revit 2010 API
ParameterMapIterator Methods
ParameterMapIterator Class See Also Send Feedback

The ParameterMapIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterMapIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
ParameterMapIterator..::.MoveNext Method
ParameterMapIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ParameterMapIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
ParameterMapIterator..::.Reset Method
ParameterMapIterator Class See Also Send Feedback
Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ParameterMapIterator Class
Autodesk.Revit Namespace


ParameterMapIterator Properties

[image] [image]

Revit 2010 API
ParameterMapIterator Properties
ParameterMapIterator Class See Also Send Feedback

The ParameterMapIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Key | Retrieves the key that is the current focus of the iterator.

See Also

ParameterMapIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
ParameterMapIterator..::.Current Property
ParameterMapIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ParameterMapIterator Class
Autodesk.Revit Namespace


Key Property

[image]

Revit 2010 API
ParameterMapIterator..::.Key Property
ParameterMapIterator Class See Also Send Feedback
Retrieves the key that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual string Key { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Key As String
Visual C++
public:
virtual property String^ Key {
    String^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

ParameterMapIterator Class
Autodesk.Revit Namespace


ParameterSet Class

[image]

Revit 2010 API
ParameterSet Class
Members See Also Send Feedback
A set that contains parameters.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ParameterSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ParameterSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ParameterSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.ParameterSet

See Also

ParameterSet Members
Autodesk.Revit Namespace


ParameterSet Members

[image] [image]

Revit 2010 API
ParameterSet Members
ParameterSet Class Constructors Methods Properties See Also Send Feedback

The ParameterSet type exposes the following members.

Constructors

Name | Description
ParameterSet | Initializes a new instance of the ParameterSet class

Methods

Name | Description
Clear | Removes every parameter from the set, rendering it empty.
Contains | Tests for the existence of a parameter within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified parameter from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified parameter into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of parameters that are in the set.

See Also

ParameterSet Class
Autodesk.Revit Namespace


ParameterSet Constructor

[image]

Revit 2010 API
ParameterSet Constructor
ParameterSet Class See Also Send Feedback
Initializes a new instance of the ParameterSet class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterSet()

See Also

ParameterSet Class
Autodesk.Revit Namespace


ParameterSet Methods

[image] [image]

Revit 2010 API
ParameterSet Methods
ParameterSet Class See Also Send Feedback

The ParameterSet type exposes the following members.

Methods

Name | Description
Clear | Removes every parameter from the set, rendering it empty.
Contains | Tests for the existence of a parameter within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified parameter from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified parameter into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterSet Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
ParameterSet..::.Clear Method
ParameterSet Class See Also Send Feedback
Removes every parameter from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ParameterSet Class
Autodesk.Revit Namespace


Contains Method

[image]

Revit 2010 API
ParameterSet..::.Contains Method
ParameterSet Class See Also Send Feedback
Tests for the existence of a parameter within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    Parameter item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Parameter _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Parameter^ item
)

Parameters

item
Type: Autodesk.Revit..::.Parameter
The parameter to be searched for.

Return Value

The Contains method returns True if the parameter is within the set, otherwise False.

See Also

ParameterSet Class
Autodesk.Revit Namespace


Erase Method

[image]

Revit 2010 API
ParameterSet..::.Erase Method
ParameterSet Class See Also Send Feedback
Removes a specified parameter from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    Parameter item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Parameter _
) As Integer
Visual C++
public:
virtual int Erase(
    Parameter^ item
)

Parameters

item
Type: Autodesk.Revit..::.Parameter
The parameter to be erased.

Return Value

The number of parameters that were erased from the set.

See Also

ParameterSet Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
ParameterSet..::.ForwardIterator Method
ParameterSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ParameterSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ParameterSetIterator
Visual C++
public:
virtual ParameterSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ParameterSet Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
ParameterSet..::.GetEnumerator Method
ParameterSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ParameterSet Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
ParameterSet..::.Insert Method
ParameterSet Class See Also Send Feedback
Insert the specified parameter into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    Parameter item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Parameter _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Parameter^ item
)

Parameters

item
Type: Autodesk.Revit..::.Parameter
The parameter to be inserted into the set.

Return Value

Returns whether the parameter was inserted into the set.

See Also

ParameterSet Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
ParameterSet..::.ReverseIterator Method
ParameterSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ParameterSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ParameterSetIterator
Visual C++
public:
virtual ParameterSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ParameterSet Class
Autodesk.Revit Namespace


ParameterSet Properties

[image] [image]

Revit 2010 API
ParameterSet Properties
ParameterSet Class See Also Send Feedback

The ParameterSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of parameters that are in the set.

See Also

ParameterSet Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
ParameterSet..::.IsEmpty Property
ParameterSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ParameterSet Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
ParameterSet..::.Size Property
ParameterSet Class See Also Send Feedback
Returns the number of parameters that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ParameterSet Class
Autodesk.Revit Namespace


ParameterSetIterator Class

[image]

Revit 2010 API
ParameterSetIterator Class
Members See Also Send Feedback
An iterator to a parameter set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ParameterSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ParameterSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ParameterSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.ParameterSetIterator

See Also

ParameterSetIterator Members
Autodesk.Revit Namespace


ParameterSetIterator Members

[image] [image]

Revit 2010 API
ParameterSetIterator Members
ParameterSetIterator Class Constructors Methods Properties See Also Send Feedback

The ParameterSetIterator type exposes the following members.

Constructors

Name | Description
ParameterSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ParameterSetIterator Class
Autodesk.Revit Namespace


ParameterSetIterator Constructor

[image]

Revit 2010 API
ParameterSetIterator Constructor
ParameterSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ParameterSetIterator Class
Autodesk.Revit Namespace


ParameterSetIterator Methods

[image] [image]

Revit 2010 API
ParameterSetIterator Methods
ParameterSetIterator Class See Also Send Feedback

The ParameterSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
ParameterSetIterator..::.MoveNext Method
ParameterSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ParameterSetIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
ParameterSetIterator..::.Reset Method
ParameterSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ParameterSetIterator Class
Autodesk.Revit Namespace


ParameterSetIterator Properties

[image] [image]

Revit 2010 API
ParameterSetIterator Properties
ParameterSetIterator Class See Also Send Feedback

The ParameterSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ParameterSetIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
ParameterSetIterator..::.Current Property
ParameterSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ParameterSetIterator Class
Autodesk.Revit Namespace


ParameterStorage Class

[image]

Revit 2010 API
ParameterStorage Class
Members See Also Send Feedback
An object that contains details for the value of a parameter. This class is mainly used with the class FilterCriterion to retrieve Elements according to certain criteria.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ParameterStorage : APIObject
Visual Basic (Declaration)
Public Class ParameterStorage _
    Inherits APIObject
Visual C++
public ref class ParameterStorage : public APIObject

Remarks

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.ParameterStorage

See Also

ParameterStorage Members
Autodesk.Revit Namespace


ParameterStorage Members

[image] [image]

Revit 2010 API
ParameterStorage Members
ParameterStorage Class Constructors Methods Properties See Also Send Feedback

The ParameterStorage type exposes the following members.

Constructors

Name | Description
ParameterStorage | For Internal Use Only.

Methods

Name | Description
AsDouble | Provides access to the double precision number within the parameter.
AsElementId | Provides access to the ElementId stored within the parameter.
AsInteger | Provides access to the integer number within the parameter.
AsString | Provides access to the string contents of the parameter.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Set | Overloaded. Sets the parameter.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | (Overrides APIObject..::.IsReadOnly.)
StorageType | Describes the type that contains parameter's value.

See Also

ParameterStorage Class
Autodesk.Revit Namespace


ParameterStorage Constructor

[image]

Revit 2010 API
ParameterStorage Constructor
ParameterStorage Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterStorage()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterStorage()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ParameterStorage Class
Autodesk.Revit Namespace


ParameterStorage Methods

[image] [image]

Revit 2010 API
ParameterStorage Methods
ParameterStorage Class See Also Send Feedback

The ParameterStorage type exposes the following members.

Methods

Name | Description
AsDouble | Provides access to the double precision number within the parameter.
AsElementId | Provides access to the ElementId stored within the parameter.
AsInteger | Provides access to the integer number within the parameter.
AsString | Provides access to the string contents of the parameter.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Set | Overloaded. Sets the parameter.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterStorage Class
Autodesk.Revit Namespace


AsDouble Method

[image]

Revit 2010 API
ParameterStorage..::.AsDouble Method
ParameterStorage Class See Also Send Feedback
Provides access to the double precision number within the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual double AsDouble()
Visual Basic (Declaration)
Public Overridable Function AsDouble As Double
Visual C++
public:
virtual double AsDouble()

Return Value

The double value contained in the parameter.

Remarks

The AsDouble method should only be used if the StorageType property returns that the internal contents of the parameter is a double.

Exceptions

Exception | Condition
InvalidOperationException..::.InvalidOperationException()()() | Thrown when the StorageType is not Double

See Also

ParameterStorage Class
Autodesk.Revit Namespace


AsElementId Method

[image]

Revit 2010 API
ParameterStorage..::.AsElementId Method
ParameterStorage Class See Also Send Feedback
Provides access to the ElementId stored within the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ElementId AsElementId()
Visual Basic (Declaration)
Public Overridable Function AsElementId As ElementId
Visual C++
public:
virtual ElementId AsElementId()

Return Value

The ElementId contained in the parameter.

Remarks

The AsElementId method should only be used if the StorageType property returns that the internal contents of the parameter is an ElementId.

Exceptions

Exception | Condition
InvalidOperationException..::.InvalidOperationException()()() | Thrown when the StorageType is not ElementId

See Also

ParameterStorage Class
Autodesk.Revit Namespace


AsInteger Method

[image]

Revit 2010 API
ParameterStorage..::.AsInteger Method
ParameterStorage Class See Also Send Feedback
Provides access to the integer number within the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int AsInteger()
Visual Basic (Declaration)
Public Overridable Function AsInteger As Integer
Visual C++
public:
virtual int AsInteger()

Return Value

The integer value contained in the parameter.

Remarks

The AsInteger method should only be used if the StorageType property returns that the internal contents of the parameter is an integer.

Exceptions

Exception | Condition
InvalidOperationException..::.InvalidOperationException()()() | Thrown when the StorageType is not Integer

See Also

ParameterStorage Class
Autodesk.Revit Namespace


AsString Method

[image]

Revit 2010 API
ParameterStorage..::.AsString Method
ParameterStorage Class See Also Send Feedback
Provides access to the string contents of the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual string AsString()
Visual Basic (Declaration)
Public Overridable Function AsString As String
Visual C++
public:
virtual String^ AsString()

Return Value

The string contained in the parameter.

Remarks

The AsString method should only be used if the StorageType property returns that the internal contents of the parameter is a string.

Exceptions

Exception | Condition
InvalidOperationException..::.InvalidOperationException()()() | Thrown when the StorageType is not String

See Also

ParameterStorage Class
Autodesk.Revit Namespace


Set Method

[image] [image]

Revit 2010 API
ParameterStorage..::.Set Method
ParameterStorage Class See Also Send Feedback
Sets the parameter.

Overload List

Name | Description
Set(ElementId%) | Sets the parameter to a new element id.
Set(Double) | Sets the parameter to a new real number value.
Set(Int32) | Sets the parameter to a new integer value.
Set(String) | Sets the parameter to a new string of text.

See Also

ParameterStorage Class
ParameterStorage Members
Autodesk.Revit Namespace


Set Method (ElementId)

[image]

Revit 2010 API
ParameterStorage..::.Set Method (ElementId%)
ParameterStorage Class See Also Send Feedback
Sets the parameter to a new element id.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Set(
    ref ElementId value
)
Visual Basic (Declaration)
Public Overridable Function Set ( _
    ByRef value As ElementId _
) As Boolean
Visual C++
public:
virtual bool Set(
    ElementId% value
)

Parameters

value
Type: Autodesk.Revit..::.ElementId %
The new element id to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as an ElementId.

See Also

ParameterStorage Class
Set Overload
Autodesk.Revit Namespace


Set Method (Double)

[image]

Revit 2010 API
ParameterStorage..::.Set Method (Double)
ParameterStorage Class See Also Send Feedback
Sets the parameter to a new real number value.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Set(
    double value
)
Visual Basic (Declaration)
Public Overridable Function Set ( _
    value As Double _
) As Boolean
Visual C++
public:
virtual bool Set(
    double value
)

Parameters

value
Type: System..::.Double
The new double value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as a Double.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown System::ArgumentNullException when the value is infinite.

See Also

ParameterStorage Class
Set Overload
Autodesk.Revit Namespace


Set Method (Int32)

[image]

Revit 2010 API
ParameterStorage..::.Set Method (Int32)
ParameterStorage Class See Also Send Feedback
Sets the parameter to a new integer value.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Set(
    int value
)
Visual Basic (Declaration)
Public Overridable Function Set ( _
    value As Integer _
) As Boolean
Visual C++
public:
virtual bool Set(
    int value
)

Parameters

value
Type: System..::.Int32
The new integer value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as an integer.

See Also

ParameterStorage Class
Set Overload
Autodesk.Revit Namespace


Set Method (String)

[image]

Revit 2010 API
ParameterStorage..::.Set Method (String)
ParameterStorage Class See Also Send Feedback
Sets the parameter to a new string of text.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Set(
    string value
)
Visual Basic (Declaration)
Public Overridable Function Set ( _
    value As String _
) As Boolean
Visual C++
public:
virtual bool Set(
    String^ value
)

Parameters

value
Type: System..::.String
The new text value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as a String.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown System::ArgumentNullException when the value is null.

See Also

ParameterStorage Class
Set Overload
Autodesk.Revit Namespace


ParameterStorage Properties

[image] [image]

Revit 2010 API
ParameterStorage Properties
ParameterStorage Class See Also Send Feedback

The ParameterStorage type exposes the following members.

Properties

Name | Description
IsReadOnly | (Overrides APIObject..::.IsReadOnly.)
StorageType | Describes the type that contains parameter's value.

See Also

ParameterStorage Class
Autodesk.Revit Namespace


IsReadOnly Property

[image]

Revit 2010 API
ParameterStorage..::.IsReadOnly Property
ParameterStorage Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override bool IsReadOnly { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () override;
}

See Also

ParameterStorage Class
Autodesk.Revit Namespace


StorageType Property

[image]

Revit 2010 API
ParameterStorage..::.StorageType Property
ParameterStorage Class See Also Send Feedback
Describes the type that contains parameter's value.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public StorageType StorageType { get; }
Visual Basic (Declaration)
Public ReadOnly Property StorageType As StorageType
Visual C++
public:
property StorageType StorageType {
    StorageType get ();
}

Remarks

The parameter's value stored here is not associated to the contents of a particular Element while the value stored in the class Parameter is; The property will return one of the following possibilities: String, Integer, Double or ElementId. Based on the value of this property the correct access and set methods should be used to retrieve and set the parameter's data value.

See Also

ParameterStorage Class
Autodesk.Revit Namespace


PlanCircuit Class

[image]

Revit 2010 API
PlanCircuit Class
Members See Also Send Feedback
An object that represents an enclosed area in a plan view within the Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PlanCircuit : APIObject
Visual Basic (Declaration)
Public Class PlanCircuit _
    Inherits APIObject
Visual C++
public ref class PlanCircuit : public APIObject

Remarks

Plan circuits are enclosed regions as seen on a plan view. They are used to determine the boundary extents of rooms based on the placement of walls. In the Autodesk Revit API, you can use plan circuits to create new rooms.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.PlanCircuit

See Also

PlanCircuit Members
Autodesk.Revit Namespace


PlanCircuit Members

[image] [image]

Revit 2010 API
PlanCircuit Members
PlanCircuit Class Constructors Methods Properties See Also Send Feedback

The PlanCircuit type exposes the following members.

Constructors

Name | Description
PlanCircuit | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Area | The enclosed area of the circuit.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsRoomLocated | Reports whether there is a room located in this circuit.
SideNum | The number of sides in the circuit.

See Also

PlanCircuit Class
Autodesk.Revit Namespace


PlanCircuit Constructor

[image]

Revit 2010 API
PlanCircuit Constructor
PlanCircuit Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PlanCircuit()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PlanCircuit()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PlanCircuit Class
Autodesk.Revit Namespace


PlanCircuit Methods

[image] [image]

Revit 2010 API
PlanCircuit Methods
PlanCircuit Class See Also Send Feedback

The PlanCircuit type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlanCircuit Class
Autodesk.Revit Namespace


PlanCircuit Properties

[image] [image]

Revit 2010 API
PlanCircuit Properties
PlanCircuit Class See Also Send Feedback

The PlanCircuit type exposes the following members.

Properties

Name | Description
Area | The enclosed area of the circuit.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsRoomLocated | Reports whether there is a room located in this circuit.
SideNum | The number of sides in the circuit.

See Also

PlanCircuit Class
Autodesk.Revit Namespace


Area Property

[image]

Revit 2010 API
PlanCircuit..::.Area Property
PlanCircuit Class See Also Send Feedback
The enclosed area of the circuit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Area { get; }
Visual Basic (Declaration)
Public ReadOnly Property Area As Double
Visual C++
public:
property double Area {
    double get ();
}

See Also

PlanCircuit Class
Autodesk.Revit Namespace


IsRoomLocated Property

[image]

Revit 2010 API
PlanCircuit..::.IsRoomLocated Property
PlanCircuit Class See Also Send Feedback
Reports whether there is a room located in this circuit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsRoomLocated { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsRoomLocated As Boolean
Visual C++
public:
property bool IsRoomLocated {
    bool get ();
}

Field Value

True if there is a room located in this circuit on the circuit's level, false if there is no room located in this circuit on the circuit's level.

See Also

PlanCircuit Class
Autodesk.Revit Namespace


SideNum Property

[image]

Revit 2010 API
PlanCircuit..::.SideNum Property
PlanCircuit Class See Also Send Feedback
The number of sides in the circuit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int SideNum { get; }
Visual Basic (Declaration)
Public ReadOnly Property SideNum As Integer
Visual C++
public:
property int SideNum {
    int get ();
}

See Also

PlanCircuit Class
Autodesk.Revit Namespace


PlanCircuitSet Class

[image]

Revit 2010 API
PlanCircuitSet Class
Members See Also Send Feedback
A set that can contain any number of plan circuit objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PlanCircuitSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class PlanCircuitSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PlanCircuitSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.PlanCircuitSet

See Also

PlanCircuitSet Members
Autodesk.Revit Namespace


PlanCircuitSet Members

[image] [image]

Revit 2010 API
PlanCircuitSet Members
PlanCircuitSet Class Constructors Methods Properties See Also Send Feedback

The PlanCircuitSet type exposes the following members.

Constructors

Name | Description
PlanCircuitSet | Initializes a new instance of the PlanCircuitSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


PlanCircuitSet Constructor

[image]

Revit 2010 API
PlanCircuitSet Constructor
PlanCircuitSet Class See Also Send Feedback
Initializes a new instance of the PlanCircuitSet class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PlanCircuitSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PlanCircuitSet()

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


PlanCircuitSet Methods

[image] [image]

Revit 2010 API
PlanCircuitSet Methods
PlanCircuitSet Class See Also Send Feedback

The PlanCircuitSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
PlanCircuitSet..::.Clear Method
PlanCircuitSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


Contains Method

[image]

Revit 2010 API
PlanCircuitSet..::.Contains Method
PlanCircuitSet Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    PlanCircuit item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As PlanCircuit _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PlanCircuit^ item
)

Parameters

item
Type: Autodesk.Revit..::.PlanCircuit
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


Erase Method

[image]

Revit 2010 API
PlanCircuitSet..::.Erase Method
PlanCircuitSet Class See Also Send Feedback
Removes a specified object from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    PlanCircuit item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As PlanCircuit _
) As Integer
Visual C++
public:
virtual int Erase(
    PlanCircuit^ item
)

Parameters

item
Type: Autodesk.Revit..::.PlanCircuit
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
PlanCircuitSet..::.ForwardIterator Method
PlanCircuitSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual PlanCircuitSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PlanCircuitSetIterator
Visual C++
public:
virtual PlanCircuitSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
PlanCircuitSet..::.GetEnumerator Method
PlanCircuitSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
PlanCircuitSet..::.Insert Method
PlanCircuitSet Class See Also Send Feedback
Insert the specified item into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    PlanCircuit item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As PlanCircuit _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PlanCircuit^ item
)

Parameters

item
Type: Autodesk.Revit..::.PlanCircuit
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
PlanCircuitSet..::.ReverseIterator Method
PlanCircuitSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual PlanCircuitSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PlanCircuitSetIterator
Visual C++
public:
virtual PlanCircuitSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


PlanCircuitSet Properties

[image] [image]

Revit 2010 API
PlanCircuitSet Properties
PlanCircuitSet Class See Also Send Feedback

The PlanCircuitSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
PlanCircuitSet..::.IsEmpty Property
PlanCircuitSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
PlanCircuitSet..::.Size Property
PlanCircuitSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PlanCircuitSet Class
Autodesk.Revit Namespace


PlanCircuitSetIterator Class

[image]

Revit 2010 API
PlanCircuitSetIterator Class
Members See Also Send Feedback
An iterator to a set of plan circuit objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class PlanCircuitSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class PlanCircuitSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PlanCircuitSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.PlanCircuitSetIterator

See Also

PlanCircuitSetIterator Members
Autodesk.Revit Namespace


PlanCircuitSetIterator Members

[image] [image]

Revit 2010 API
PlanCircuitSetIterator Members
PlanCircuitSetIterator Class Constructors Methods Properties See Also Send Feedback

The PlanCircuitSetIterator type exposes the following members.

Constructors

Name | Description
PlanCircuitSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PlanCircuitSetIterator Class
Autodesk.Revit Namespace


PlanCircuitSetIterator Constructor

[image]

Revit 2010 API
PlanCircuitSetIterator Constructor
PlanCircuitSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PlanCircuitSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PlanCircuitSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PlanCircuitSetIterator Class
Autodesk.Revit Namespace


PlanCircuitSetIterator Methods

[image] [image]

Revit 2010 API
PlanCircuitSetIterator Methods
PlanCircuitSetIterator Class See Also Send Feedback

The PlanCircuitSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlanCircuitSetIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
PlanCircuitSetIterator..::.MoveNext Method
PlanCircuitSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PlanCircuitSetIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
PlanCircuitSetIterator..::.Reset Method
PlanCircuitSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PlanCircuitSetIterator Class
Autodesk.Revit Namespace


PlanCircuitSetIterator Properties

[image] [image]

Revit 2010 API
PlanCircuitSetIterator Properties
PlanCircuitSetIterator Class See Also Send Feedback

The PlanCircuitSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PlanCircuitSetIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
PlanCircuitSetIterator..::.Current Property
PlanCircuitSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PlanCircuitSetIterator Class
Autodesk.Revit Namespace


PlanTopology Class

[image]

Revit 2010 API
PlanTopology Class
Members See Also Send Feedback
An object that represents a Plan Topology within the Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PlanTopology : APIObject
Visual Basic (Declaration)
Public Class PlanTopology _
    Inherits APIObject
Visual C++
public ref class PlanTopology : public APIObject

Remarks

This object derived from the APIObject base object. It can be used access the properties of a Plan Topology.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.PlanTopology

See Also

PlanTopology Members
Autodesk.Revit Namespace


PlanTopology Members

[image] [image]

Revit 2010 API
PlanTopology Members
PlanTopology Class Constructors Methods Properties See Also Send Feedback

The PlanTopology type exposes the following members.

Constructors

Name | Description
PlanTopology | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Circuits | Retrieves Circuits of the PlanTopology.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | Retrieves Level of the PlanTopology.
Phase | Retrieves the phase of the PlanTopology.
Rooms | Retrieves rooms of the PlanTopology in the last phase.

See Also

PlanTopology Class
Autodesk.Revit Namespace


PlanTopology Constructor

[image]

Revit 2010 API
PlanTopology Constructor
PlanTopology Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PlanTopology()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PlanTopology()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PlanTopology Class
Autodesk.Revit Namespace


PlanTopology Methods

[image] [image]

Revit 2010 API
PlanTopology Methods
PlanTopology Class See Also Send Feedback

The PlanTopology type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlanTopology Class
Autodesk.Revit Namespace


PlanTopology Properties

[image] [image]

Revit 2010 API
PlanTopology Properties
PlanTopology Class See Also Send Feedback

The PlanTopology type exposes the following members.

Properties

Name | Description
Circuits | Retrieves Circuits of the PlanTopology.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | Retrieves Level of the PlanTopology.
Phase | Retrieves the phase of the PlanTopology.
Rooms | Retrieves rooms of the PlanTopology in the last phase.

See Also

PlanTopology Class
Autodesk.Revit Namespace


Circuits Property

[image]

Revit 2010 API
PlanTopology..::.Circuits Property
PlanTopology Class See Also Send Feedback
Retrieves Circuits of the PlanTopology.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PlanCircuitSet Circuits { get; }
Visual Basic (Declaration)
Public ReadOnly Property Circuits As PlanCircuitSet
Visual C++
public:
property PlanCircuitSet^ Circuits {
    PlanCircuitSet^ get ();
}

See Also

PlanTopology Class
Autodesk.Revit Namespace


Level Property

[image]

Revit 2010 API
PlanTopology..::.Level Property
PlanTopology Class See Also Send Feedback
Retrieves Level of the PlanTopology.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Level Level { get; }
Visual Basic (Declaration)
Public ReadOnly Property Level As Level
Visual C++
public:
property Level^ Level {
    Level^ get ();
}

See Also

PlanTopology Class
Autodesk.Revit Namespace


Phase Property

[image]

Revit 2010 API
PlanTopology..::.Phase Property
PlanTopology Class See Also Send Feedback
Retrieves the phase of the PlanTopology.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Phase Phase { get; }
Visual Basic (Declaration)
Public ReadOnly Property Phase As Phase
Visual C++
public:
property Phase^ Phase {
    Phase^ get ();
}

See Also

PlanTopology Class
Autodesk.Revit Namespace


Rooms Property

[image]

Revit 2010 API
PlanTopology..::.Rooms Property
PlanTopology Class See Also Send Feedback
Retrieves rooms of the PlanTopology in the last phase.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet Rooms { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rooms As ElementSet
Visual C++
public:
property ElementSet^ Rooms {
    ElementSet^ get ();
}

Remarks

The Rooms you get here is in the phase of PlanTopology and the current design option.

See Also

PlanTopology Class
Autodesk.Revit Namespace


PlanTopologySet Class

[image]

Revit 2010 API
PlanTopologySet Class
Members See Also Send Feedback
A set that can contain any number of plan topology objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PlanTopologySet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class PlanTopologySet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PlanTopologySet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.PlanTopologySet

See Also

PlanTopologySet Members
Autodesk.Revit Namespace


PlanTopologySet Members

[image] [image]

Revit 2010 API
PlanTopologySet Members
PlanTopologySet Class Constructors Methods Properties See Also Send Feedback

The PlanTopologySet type exposes the following members.

Constructors

Name | Description
PlanTopologySet | Initializes a new instance of the PlanTopologySet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


PlanTopologySet Constructor

[image]

Revit 2010 API
PlanTopologySet Constructor
PlanTopologySet Class See Also Send Feedback
Initializes a new instance of the PlanTopologySet class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PlanTopologySet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PlanTopologySet()

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


PlanTopologySet Methods

[image] [image]

Revit 2010 API
PlanTopologySet Methods
PlanTopologySet Class See Also Send Feedback

The PlanTopologySet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
PlanTopologySet..::.Clear Method
PlanTopologySet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


Contains Method

[image]

Revit 2010 API
PlanTopologySet..::.Contains Method
PlanTopologySet Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    PlanTopology item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As PlanTopology _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PlanTopology^ item
)

Parameters

item
Type: Autodesk.Revit..::.PlanTopology
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


Erase Method

[image]

Revit 2010 API
PlanTopologySet..::.Erase Method
PlanTopologySet Class See Also Send Feedback
Removes a specified object from the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    PlanTopology item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As PlanTopology _
) As Integer
Visual C++
public:
virtual int Erase(
    PlanTopology^ item
)

Parameters

item
Type: Autodesk.Revit..::.PlanTopology
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
PlanTopologySet..::.ForwardIterator Method
PlanTopologySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual PlanTopologySetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PlanTopologySetIterator
Visual C++
public:
virtual PlanTopologySetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
PlanTopologySet..::.GetEnumerator Method
PlanTopologySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
PlanTopologySet..::.Insert Method
PlanTopologySet Class See Also Send Feedback
Insert the specified item into the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    PlanTopology item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As PlanTopology _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PlanTopology^ item
)

Parameters

item
Type: Autodesk.Revit..::.PlanTopology
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
PlanTopologySet..::.ReverseIterator Method
PlanTopologySet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual PlanTopologySetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PlanTopologySetIterator
Visual C++
public:
virtual PlanTopologySetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


PlanTopologySet Properties

[image] [image]

Revit 2010 API
PlanTopologySet Properties
PlanTopologySet Class See Also Send Feedback

The PlanTopologySet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
PlanTopologySet..::.IsEmpty Property
PlanTopologySet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
PlanTopologySet..::.Size Property
PlanTopologySet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PlanTopologySet Class
Autodesk.Revit Namespace


PlanTopologySetIterator Class

[image]

Revit 2010 API
PlanTopologySetIterator Class
Members See Also Send Feedback
An iterator to a set of plan topology objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class PlanTopologySetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class PlanTopologySetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PlanTopologySetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.PlanTopologySetIterator

See Also

PlanTopologySetIterator Members
Autodesk.Revit Namespace


PlanTopologySetIterator Members

[image] [image]

Revit 2010 API
PlanTopologySetIterator Members
PlanTopologySetIterator Class Constructors Methods Properties See Also Send Feedback

The PlanTopologySetIterator type exposes the following members.

Constructors

Name | Description
PlanTopologySetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PlanTopologySetIterator Class
Autodesk.Revit Namespace


PlanTopologySetIterator Constructor

[image]

Revit 2010 API
PlanTopologySetIterator Constructor
PlanTopologySetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PlanTopologySetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PlanTopologySetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PlanTopologySetIterator Class
Autodesk.Revit Namespace


PlanTopologySetIterator Methods

[image] [image]

Revit 2010 API
PlanTopologySetIterator Methods
PlanTopologySetIterator Class See Also Send Feedback

The PlanTopologySetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlanTopologySetIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
PlanTopologySetIterator..::.MoveNext Method
PlanTopologySetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PlanTopologySetIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
PlanTopologySetIterator..::.Reset Method
PlanTopologySetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PlanTopologySetIterator Class
Autodesk.Revit Namespace


PlanTopologySetIterator Properties

[image] [image]

Revit 2010 API
PlanTopologySetIterator Properties
PlanTopologySetIterator Class See Also Send Feedback

The PlanTopologySetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PlanTopologySetIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
PlanTopologySetIterator..::.Current Property
PlanTopologySetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PlanTopologySetIterator Class
Autodesk.Revit Namespace


PostedError Class

[image]

Revit 2010 API
PostedError Class
Members See Also Send Feedback
A class that holds information about a posted error.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PostedError : APIObject
Visual Basic (Declaration)
Public Class PostedError _
    Inherits APIObject
Visual C++
public ref class PostedError : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.PostedError

See Also

PostedError Members
Autodesk.Revit Namespace


PostedError Members

[image] [image]

Revit 2010 API
PostedError Members
PostedError Class Constructors Methods Properties See Also Send Feedback

The PostedError type exposes the following members.

Constructors

Name | Description
PostedError | Copy constructor

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
ErrorType | Type of the error.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Message | Message associated with the error.

See Also

PostedError Class
Autodesk.Revit Namespace


PostedError Constructor

[image]

Revit 2010 API
PostedError Constructor
PostedError Class See Also Send Feedback
Copy constructor

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PostedError(
    PostedError pe
)
Visual Basic (Declaration)
Public Sub New ( _
    pe As PostedError _
)
Visual C++
public:
PostedError(
    PostedError^ pe
)

Parameters

pe
Type: Autodesk.Revit..::.PostedError

See Also

PostedError Class
Autodesk.Revit Namespace


PostedError Methods

[image] [image]

Revit 2010 API
PostedError Methods
PostedError Class See Also Send Feedback

The PostedError type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

See Also

PostedError Class
Autodesk.Revit Namespace


Equals Method

[image] [image]

Revit 2010 API
PostedError..::.Equals Method
PostedError Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(PostedError) | Tests equality
Equals(PostedError, PostedError) | Tests equality - static method

See Also

PostedError Class
PostedError Members
Autodesk.Revit Namespace


Equals Method (PostedError)

[image]

Revit 2010 API
PostedError..::.Equals Method (PostedError)
PostedError Class See Also Send Feedback
Tests equality

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Equals(
    PostedError pe
)
Visual Basic (Declaration)
Public Function Equals ( _
    pe As PostedError _
) As Boolean
Visual C++
public:
bool Equals(
    PostedError^ pe
)

Parameters

pe
Type: Autodesk.Revit..::.PostedError

See Also

PostedError Class
Equals Overload
Autodesk.Revit Namespace


Equals Method (PostedError, PostedError)

[image]

Revit 2010 API
PostedError..::.Equals Method (PostedError, PostedError)
PostedError Class See Also Send Feedback
Tests equality - static method

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static bool Equals(
    PostedError lhs,
    PostedError rhs
)
Visual Basic (Declaration)
Public Shared Function Equals ( _
    lhs As PostedError, _
    rhs As PostedError _
) As Boolean
Visual C++
public:
static bool Equals(
    PostedError^ lhs,
    PostedError^ rhs
)

Parameters

lhs
Type: Autodesk.Revit..::.PostedError
rhs
Type: Autodesk.Revit..::.PostedError

See Also

PostedError Class
Equals Overload
Autodesk.Revit Namespace


ToString Method

[image]

Revit 2010 API
PostedError..::.ToString Method
PostedError Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

PostedError Class
Autodesk.Revit Namespace


PostedError Properties

[image] [image]

Revit 2010 API
PostedError Properties
PostedError Class See Also Send Feedback

The PostedError type exposes the following members.

Properties

Name | Description
ErrorType | Type of the error.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Message | Message associated with the error.

See Also

PostedError Class
Autodesk.Revit Namespace


ErrorType Property

[image]

Revit 2010 API
PostedError..::.ErrorType Property
PostedError Class See Also Send Feedback
Type of the error.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PostedErrorType ErrorType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ErrorType As PostedErrorType
Visual C++
public:
property PostedErrorType ErrorType {
    PostedErrorType get ();
}

Remarks

The type indentifies the severity of a posted error. The lowest level is a 'Warning', which can be safely ignored in most cases, to 'Fatal Error', which should probably never be ignored

See Also

PostedError Class
Autodesk.Revit Namespace


Message Property

[image]

Revit 2010 API
PostedError..::.Message Property
PostedError Class See Also Send Feedback
Message associated with the error.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Message { get; }
Visual Basic (Declaration)
Public ReadOnly Property Message As String
Visual C++
public:
property String^ Message {
    String^ get ();
}

Remarks

This message may localized for the target language version.

See Also

PostedError Class
Autodesk.Revit Namespace


PostedErrorArray Class

[image]

Revit 2010 API
PostedErrorArray Class
Members See Also Send Feedback
An array that can contain any number of posted errors.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PostedErrorArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class PostedErrorArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PostedErrorArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.PostedErrorArray

See Also

PostedErrorArray Members
Autodesk.Revit Namespace


PostedErrorArray Members

[image] [image]

Revit 2010 API
PostedErrorArray Members
PostedErrorArray Class Constructors Methods Properties See Also Send Feedback

The PostedErrorArray type exposes the following members.

Constructors

Name | Description
PostedErrorArray | Initializes a new instance of the PostedErrorArray class

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


PostedErrorArray Constructor

[image]

Revit 2010 API
PostedErrorArray Constructor
PostedErrorArray Class See Also Send Feedback
Initializes a new instance of the PostedErrorArray class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PostedErrorArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PostedErrorArray()

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


PostedErrorArray Methods

[image] [image]

Revit 2010 API
PostedErrorArray Methods
PostedErrorArray Class See Also Send Feedback

The PostedErrorArray type exposes the following members.

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


Append Method

[image]

Revit 2010 API
PostedErrorArray..::.Append Method
PostedErrorArray Class See Also Send Feedback
Add the item to the end of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    PostedError item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As PostedError _
)
Visual C++
public:
virtual void Append(
    PostedError^ item
)

Parameters

item
Type: Autodesk.Revit..::.PostedError
The item to be added.

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
PostedErrorArray..::.Clear Method
PostedErrorArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
PostedErrorArray..::.ForwardIterator Method
PostedErrorArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual PostedErrorArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PostedErrorArrayIterator
Visual C++
public:
virtual PostedErrorArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
PostedErrorArray..::.GetEnumerator Method
PostedErrorArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
PostedErrorArray..::.Insert Method
PostedErrorArray Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    PostedError item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As PostedError, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    PostedError^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit..::.PostedError
The item to be inserted into the array.
index
Type: System..::.Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
PostedErrorArray..::.ReverseIterator Method
PostedErrorArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual PostedErrorArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PostedErrorArrayIterator
Visual C++
public:
virtual PostedErrorArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


PostedErrorArray Properties

[image] [image]

Revit 2010 API
PostedErrorArray Properties
PostedErrorArray Class See Also Send Feedback

The PostedErrorArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
PostedErrorArray..::.IsEmpty Property
PostedErrorArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


Item Property

[image]

Revit 2010 API
PostedErrorArray..::.Item Property
PostedErrorArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual PostedError Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As PostedError
Visual C++
public:
virtual property PostedError^ Item[int index] {
    PostedError^ get (int index);
    void set (int index, PostedError^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
PostedErrorArray..::.Size Property
PostedErrorArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PostedErrorArray Class
Autodesk.Revit Namespace


PostedErrorArrayIterator Class

[image]

Revit 2010 API
PostedErrorArrayIterator Class
Members See Also Send Feedback
A class that holds an array of posted errors.
An iterator to an array of posted errors.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class PostedErrorArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class PostedErrorArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PostedErrorArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.PostedErrorArrayIterator

See Also

PostedErrorArrayIterator Members
Autodesk.Revit Namespace


PostedErrorArrayIterator Members

[image] [image]

Revit 2010 API
PostedErrorArrayIterator Members
PostedErrorArrayIterator Class Constructors Methods Properties See Also Send Feedback

The PostedErrorArrayIterator type exposes the following members.

Constructors

Name | Description
PostedErrorArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PostedErrorArrayIterator Class
Autodesk.Revit Namespace


PostedErrorArrayIterator Constructor

[image]

Revit 2010 API
PostedErrorArrayIterator Constructor
PostedErrorArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PostedErrorArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PostedErrorArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PostedErrorArrayIterator Class
Autodesk.Revit Namespace


PostedErrorArrayIterator Methods

[image] [image]

Revit 2010 API
PostedErrorArrayIterator Methods
PostedErrorArrayIterator Class See Also Send Feedback

The PostedErrorArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PostedErrorArrayIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
PostedErrorArrayIterator..::.MoveNext Method
PostedErrorArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PostedErrorArrayIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
PostedErrorArrayIterator..::.Reset Method
PostedErrorArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PostedErrorArrayIterator Class
Autodesk.Revit Namespace


PostedErrorArrayIterator Properties

[image] [image]

Revit 2010 API
PostedErrorArrayIterator Properties
PostedErrorArrayIterator Class See Also Send Feedback

The PostedErrorArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PostedErrorArrayIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
PostedErrorArrayIterator..::.Current Property
PostedErrorArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PostedErrorArrayIterator Class
Autodesk.Revit Namespace


PrintManager Class

[image]

Revit 2010 API
PrintManager Class
Members See Also Send Feedback
The PrintManager object is used to configure the global print settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PrintManager : APIObject
Visual Basic (Declaration)
Public Class PrintManager _
    Inherits APIObject
Visual C++
public ref class PrintManager : public APIObject

Remarks

Global print settings include PrintToFile, CombinedFile, PrintToFileName, PrintRange, CopyNumber, PrintOrderReverse, Collate. Once PrintManager is acquired from a document, changes of its global print setting properties are not automatically applied toward the global print setting. Should the local setting be used, the user needs to call the Apply method. If the user calls SubmitPrint methods, not only that printing will use the current state of properties of the (local) print manager, but the setting will also be applied to the global settings.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.PrintManager

See Also

PrintManager Members
Autodesk.Revit Namespace


PrintManager Members

[image] [image]

Revit 2010 API
PrintManager Members
PrintManager Class Constructors Methods Properties See Also Send Feedback

The PrintManager type exposes the following members.

Constructors

Name | Description
PrintManager | For Internal Use Only.

Methods

Name | Description
Apply | Apply the local print settings to global for all documents.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SelectNewPrintDriver | Select a new printer.
SubmitPrint | Overloaded. Print with the current PrintManager settings.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Collate | Indicates whether to collate of the current print.
CombinedFile | Indicates whether to combine multiple selected views/sheets into a single file.
CopyNumber | The copy number.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsVirtual | The virtual type in Autodesk Revit.
PaperSizes | Get all print sizes of current printer.
PaperSources | Get all print sources of current printer.
PrinterName | The name of the current printer.
PrintOrderReverse | Indicates whether to reverse the print order of the current print.
PrintRange | The print range.
PrintSetup | The PrintSetup which manages the print settings of current doucment.
PrintToFile | Indicates whether to print to file.
PrintToFileName | The file name when printing to file.
ViewSheetSetting | The ViewSheetSetting which manages the view/sheet set information of current document, and you can change the default view/sheet set for current project.

See Also

PrintManager Class
Autodesk.Revit Namespace


PrintManager Constructor

[image]

Revit 2010 API
PrintManager Constructor
PrintManager Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PrintManager()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PrintManager()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PrintManager Class
Autodesk.Revit Namespace


PrintManager Methods

[image] [image]

Revit 2010 API
PrintManager Methods
PrintManager Class See Also Send Feedback

The PrintManager type exposes the following members.

Methods

Name | Description
Apply | Apply the local print settings to global for all documents.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SelectNewPrintDriver | Select a new printer.
SubmitPrint | Overloaded. Print with the current PrintManager settings.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrintManager Class
Autodesk.Revit Namespace


Apply Method

[image]

Revit 2010 API
PrintManager..::.Apply Method
PrintManager Class See Also Send Feedback
Apply the local print settings to global for all documents.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Apply()
Visual Basic (Declaration)
Public Sub Apply
Visual C++
public:
void Apply()

Remarks

This method will change the settings for the current printer to match what is set in the Print Manager. When the user attempts to print with this printer in the future, the changes made by the API session will be visible.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when this operation is not allowed in the current application mode, or the print resource is occupied by others.

See Also

PrintManager Class
Autodesk.Revit Namespace


SelectNewPrintDriver Method

[image]

Revit 2010 API
PrintManager..::.SelectNewPrintDriver Method
PrintManager Class See Also Send Feedback
Select a new printer.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SelectNewPrintDriver(
    string strPrinterName
)
Visual Basic (Declaration)
Public Sub SelectNewPrintDriver ( _
    strPrinterName As String _
)
Visual C++
public:
void SelectNewPrintDriver(
    String^ strPrinterName
)

Parameters

strPrinterName
Type: System..::.String
The name string of new printer.

Remarks

This property is the global print setting property for all documents.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-strPrinterName-is null.
System..::.InvalidOperationException | Thrown when the assigned new printer is invalid, or the print resource is occupied by others.

See Also

PrintManager Class
Autodesk.Revit Namespace


SubmitPrint Method

[image] [image]

Revit 2010 API
PrintManager..::.SubmitPrint Method
PrintManager Class See Also Send Feedback
Print with the current PrintManager settings.

Overload List

Name | Description
SubmitPrint()()() | Print the views and sheets defined in the current local PrintManager settings.
SubmitPrint(View) | Print a view with the current PrintManager settings.

See Also

PrintManager Class
PrintManager Members
Autodesk.Revit Namespace


SubmitPrint Method

[image]

Revit 2010 API
PrintManager..::.SubmitPrint Method
PrintManager Class See Also Send Feedback
Print the views and sheets defined in the current local PrintManager settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SubmitPrint()
Visual Basic (Declaration)
Public Function SubmitPrint As Boolean
Visual C++
public:
bool SubmitPrint()

Return Value

Returns 'true' if successful, otherwise returns 'false'.

Remarks

PrintManager will apply the local settings to global and print the view/views/sheets which user defined with the current settings.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when this operation is not allowed in the current application mode, or the print resource is occupied by others.

See Also

PrintManager Class
SubmitPrint Overload
Autodesk.Revit Namespace


SubmitPrint Method (View)

[image]

Revit 2010 API
PrintManager..::.SubmitPrint Method (View)
PrintManager Class See Also Send Feedback
Print a view with the current PrintManager settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SubmitPrint(
    View view
)
Visual Basic (Declaration)
Public Function SubmitPrint ( _
    view As View _
) As Boolean
Visual C++
public:
bool SubmitPrint(
    View^ view
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The User-assigned view.

Return Value

Returns 'true' if successful, otherwise returns 'false'.

Remarks

PrintManager will apply the local settings to global and print the user-assigned view with the current settings.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when this operation is not allowed in the current application mode, or the print resource is occupied by others.

See Also

PrintManager Class
SubmitPrint Overload
Autodesk.Revit Namespace


PrintManager Properties

[image] [image]

Revit 2010 API
PrintManager Properties
PrintManager Class See Also Send Feedback

The PrintManager type exposes the following members.

Properties

Name | Description
Collate | Indicates whether to collate of the current print.
CombinedFile | Indicates whether to combine multiple selected views/sheets into a single file.
CopyNumber | The copy number.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsVirtual | The virtual type in Autodesk Revit.
PaperSizes | Get all print sizes of current printer.
PaperSources | Get all print sources of current printer.
PrinterName | The name of the current printer.
PrintOrderReverse | Indicates whether to reverse the print order of the current print.
PrintRange | The print range.
PrintSetup | The PrintSetup which manages the print settings of current doucment.
PrintToFile | Indicates whether to print to file.
PrintToFileName | The file name when printing to file.
ViewSheetSetting | The ViewSheetSetting which manages the view/sheet set information of current document, and you can change the default view/sheet set for current project.

See Also

PrintManager Class
Autodesk.Revit Namespace


Collate Property

[image]

Revit 2010 API
PrintManager..::.Collate Property
PrintManager Class See Also Send Feedback
Indicates whether to collate of the current print.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Collate { get; set; }
Visual Basic (Declaration)
Public Property Collate As Boolean
Visual C++
public:
property bool Collate {
    bool get ();
    void set (bool value);
}

Remarks

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when there is only one view or only one copy in the current settings.

See Also

PrintManager Class
Autodesk.Revit Namespace


CombinedFile Property

[image]

Revit 2010 API
PrintManager..::.CombinedFile Property
PrintManager Class See Also Send Feedback
Indicates whether to combine multiple selected views/sheets into a single file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool CombinedFile { get; set; }
Visual Basic (Declaration)
Public Property CombinedFile As Boolean
Visual C++
public:
property bool CombinedFile {
    bool get ();
    void set (bool value);
}

Remarks

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the current printer is not a virtual printer.

See Also

PrintManager Class
Autodesk.Revit Namespace


CopyNumber Property

[image]

Revit 2010 API
PrintManager..::.CopyNumber Property
PrintManager Class See Also Send Feedback
The copy number.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int CopyNumber { get; set; }
Visual Basic (Declaration)
Public Property CopyNumber As Integer
Visual C++
public:
property int CopyNumber {
    int get ();
    void set (int value);
}

Remarks

Returns 0 if current printer does not support CopyNumber property. The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

See Also

PrintManager Class
Autodesk.Revit Namespace


IsVirtual Property

[image]

Revit 2010 API
PrintManager..::.IsVirtual Property
PrintManager Class See Also Send Feedback
The virtual type in Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public VirtualPrinterType IsVirtual { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsVirtual As VirtualPrinterType
Visual C++
public:
property VirtualPrinterType IsVirtual {
    VirtualPrinterType get ();
}

See Also

PrintManager Class
Autodesk.Revit Namespace


PaperSizes Property

[image]

Revit 2010 API
PrintManager..::.PaperSizes Property
PrintManager Class See Also Send Feedback
Get all print sizes of current printer.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PaperSizeSet PaperSizes { get; }
Visual Basic (Declaration)
Public ReadOnly Property PaperSizes As PaperSizeSet
Visual C++
public:
property PaperSizeSet^ PaperSizes {
    PaperSizeSet^ get ();
}

Remarks

These are the valid paper sizes for the current printer.

See Also

PrintManager Class
Autodesk.Revit Namespace


PaperSources Property

[image]

Revit 2010 API
PrintManager..::.PaperSources Property
PrintManager Class See Also Send Feedback
Get all print sources of current printer.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PaperSourceSet PaperSources { get; }
Visual Basic (Declaration)
Public ReadOnly Property PaperSources As PaperSourceSet
Visual C++
public:
property PaperSourceSet^ PaperSources {
    PaperSourceSet^ get ();
}

Remarks

These are the valid paper source for the current printer.

See Also

PrintManager Class
Autodesk.Revit Namespace


PrinterName Property

[image]

Revit 2010 API
PrintManager..::.PrinterName Property
PrintManager Class See Also Send Feedback
The name of the current printer.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string PrinterName { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrinterName As String
Visual C++
public:
property String^ PrinterName {
    String^ get ();
}

See Also

PrintManager Class
Autodesk.Revit Namespace


PrintOrderReverse Property

[image]

Revit 2010 API
PrintManager..::.PrintOrderReverse Property
PrintManager Class See Also Send Feedback
Indicates whether to reverse the print order of the current print.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool PrintOrderReverse { get; set; }
Visual Basic (Declaration)
Public Property PrintOrderReverse As Boolean
Visual C++
public:
property bool PrintOrderReverse {
    bool get ();
    void set (bool value);
}

Remarks

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

See Also

PrintManager Class
Autodesk.Revit Namespace


PrintRange Property

[image]

Revit 2010 API
PrintManager..::.PrintRange Property
PrintManager Class See Also Send Feedback
The print range.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PrintRange PrintRange { get; set; }
Visual Basic (Declaration)
Public Property PrintRange As PrintRange
Visual C++
public:
property PrintRange PrintRange {
    PrintRange get ();
    void set (PrintRange value);
}

Remarks

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the argument is out of range.

See Also

PrintManager Class
Autodesk.Revit Namespace


PrintSetup Property

[image]

Revit 2010 API
PrintManager..::.PrintSetup Property
PrintManager Class See Also Send Feedback
The PrintSetup which manages the print settings of current doucment.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PrintSetup PrintSetup { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintSetup As PrintSetup
Visual C++
public:
property PrintSetup^ PrintSetup {
    PrintSetup^ get ();
}

Remarks

PrintSetup is an interface cluster just like File->Print->Settings->Setup or File->Print Setup in UI.

See Also

PrintManager Class
Autodesk.Revit Namespace


PrintToFile Property

[image]

Revit 2010 API
PrintManager..::.PrintToFile Property
PrintManager Class See Also Send Feedback
Indicates whether to print to file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool PrintToFile { get; set; }
Visual Basic (Declaration)
Public Property PrintToFile As Boolean
Visual C++
public:
property bool PrintToFile {
    bool get ();
    void set (bool value);
}

Remarks

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

See Also

PrintManager Class
Autodesk.Revit Namespace


PrintToFileName Property

[image]

Revit 2010 API
PrintManager..::.PrintToFileName Property
PrintManager Class See Also Send Feedback
The file name when printing to file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string PrintToFileName { get; set; }
Visual Basic (Declaration)
Public Property PrintToFileName As String
Visual C++
public:
property String^ PrintToFileName {
    String^ get ();
    void set (String^ value);
}

Remarks

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input file name is null.
System..::.ArgumentException | Thrown when the input file name is an invalid string.

See Also

PrintManager Class
Autodesk.Revit Namespace


ViewSheetSetting Property

[image]

Revit 2010 API
PrintManager..::.ViewSheetSetting Property
PrintManager Class See Also Send Feedback
The ViewSheetSetting which manages the view/sheet set information of current document, and you can change the default view/sheet set for current project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSheetSetting ViewSheetSetting { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewSheetSetting As ViewSheetSetting
Visual C++
public:
property ViewSheetSetting^ ViewSheetSetting {
    ViewSheetSetting^ get ();
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the print range is not selected views/sheets.

See Also

PrintManager Class
Autodesk.Revit Namespace


PrintParameters Class

[image]

Revit 2010 API
PrintParameters Class
Members See Also Send Feedback
An object that contains settings used for printing the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PrintParameters : APIObject
Visual Basic (Declaration)
Public Class PrintParameters _
    Inherits APIObject
Visual C++
public ref class PrintParameters : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.PrintParameters

See Also

PrintParameters Members
Autodesk.Revit Namespace


PrintParameters Members

[image] [image]

Revit 2010 API
PrintParameters Members
PrintParameters Class Constructors Methods Properties See Also Send Feedback

The PrintParameters type exposes the following members.

Constructors

Name | Description
PrintParameters | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColorDepth | The color depth type.
HiddenLineViews | The hidden line views type.
HideCropBoundaries | Indicates whether to hide crop boundaries when printing.
HideReforWorkPlanes | Indicates whether to hide referenc/work planes when printing.
HideScopeBoxes | Indicates whether to hide scope boxes when printing.
HideUnreferencedViewTages | Indicates whether to hide unreferenced view tages when printing.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
MarginType | The print margin type.
PageOrientation | The Page Orientation of the Print Setting.
PaperPlacement | The paper placement type.
PaperSize | The page size.
PaperSource | The page source.
RasterQuality | The raster quality type.
ReplaceHalftoneWithThinLines | Indicates whether to replace halftone with thin lines when printing.
UserDefinedMarginX | The User defined X value of offset from left bottom corner.
UserDefinedMarginY | The User defined Y value of offset from left bottom corner
ViewLinksinBlue | Indicates whether to view links in blue when printing.
Zoom | The zoom value to a percentage of the original size.
ZoomType | The zoom type.

See Also

PrintParameters Class
Autodesk.Revit Namespace


PrintParameters Constructor

[image]

Revit 2010 API
PrintParameters Constructor
PrintParameters Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PrintParameters()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PrintParameters()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PrintParameters Class
Autodesk.Revit Namespace


PrintParameters Methods

[image] [image]

Revit 2010 API
PrintParameters Methods
PrintParameters Class See Also Send Feedback

The PrintParameters type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrintParameters Class
Autodesk.Revit Namespace


PrintParameters Properties

[image] [image]

Revit 2010 API
PrintParameters Properties
PrintParameters Class See Also Send Feedback

The PrintParameters type exposes the following members.

Properties

Name | Description
ColorDepth | The color depth type.
HiddenLineViews | The hidden line views type.
HideCropBoundaries | Indicates whether to hide crop boundaries when printing.
HideReforWorkPlanes | Indicates whether to hide referenc/work planes when printing.
HideScopeBoxes | Indicates whether to hide scope boxes when printing.
HideUnreferencedViewTages | Indicates whether to hide unreferenced view tages when printing.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
MarginType | The print margin type.
PageOrientation | The Page Orientation of the Print Setting.
PaperPlacement | The paper placement type.
PaperSize | The page size.
PaperSource | The page source.
RasterQuality | The raster quality type.
ReplaceHalftoneWithThinLines | Indicates whether to replace halftone with thin lines when printing.
UserDefinedMarginX | The User defined X value of offset from left bottom corner.
UserDefinedMarginY | The User defined Y value of offset from left bottom corner
ViewLinksinBlue | Indicates whether to view links in blue when printing.
Zoom | The zoom value to a percentage of the original size.
ZoomType | The zoom type.

See Also

PrintParameters Class
Autodesk.Revit Namespace


ColorDepth Property

[image]

Revit 2010 API
PrintParameters..::.ColorDepth Property
PrintParameters Class See Also Send Feedback
The color depth type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ColorDepthType ColorDepth { get; set; }
Visual Basic (Declaration)
Public Property ColorDepth As ColorDepthType
Visual C++
public:
property ColorDepthType ColorDepth {
    ColorDepthType get ();
    void set (ColorDepthType value);
}

See Also

PrintParameters Class
Autodesk.Revit Namespace


HiddenLineViews Property

[image]

Revit 2010 API
PrintParameters..::.HiddenLineViews Property
PrintParameters Class See Also Send Feedback
The hidden line views type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public HiddenLineViewsType HiddenLineViews { get; set; }
Visual Basic (Declaration)
Public Property HiddenLineViews As HiddenLineViewsType
Visual C++
public:
property HiddenLineViewsType HiddenLineViews {
    HiddenLineViewsType get ();
    void set (HiddenLineViewsType value);
}

See Also

PrintParameters Class
Autodesk.Revit Namespace


HideCropBoundaries Property

[image]

Revit 2010 API
PrintParameters..::.HideCropBoundaries Property
PrintParameters Class See Also Send Feedback
Indicates whether to hide crop boundaries when printing.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool HideCropBoundaries { get; set; }
Visual Basic (Declaration)
Public Property HideCropBoundaries As Boolean
Visual C++
public:
property bool HideCropBoundaries {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class
Autodesk.Revit Namespace


HideReforWorkPlanes Property

[image]

Revit 2010 API
PrintParameters..::.HideReforWorkPlanes Property
PrintParameters Class See Also Send Feedback
Indicates whether to hide referenc/work planes when printing.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool HideReforWorkPlanes { get; set; }
Visual Basic (Declaration)
Public Property HideReforWorkPlanes As Boolean
Visual C++
public:
property bool HideReforWorkPlanes {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class
Autodesk.Revit Namespace


HideScopeBoxes Property

[image]

Revit 2010 API
PrintParameters..::.HideScopeBoxes Property
PrintParameters Class See Also Send Feedback
Indicates whether to hide scope boxes when printing.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool HideScopeBoxes { get; set; }
Visual Basic (Declaration)
Public Property HideScopeBoxes As Boolean
Visual C++
public:
property bool HideScopeBoxes {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class
Autodesk.Revit Namespace


HideUnreferencedViewTages Property

[image]

Revit 2010 API
PrintParameters..::.HideUnreferencedViewTages Property
PrintParameters Class See Also Send Feedback
Indicates whether to hide unreferenced view tages when printing.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool HideUnreferencedViewTages { get; set; }
Visual Basic (Declaration)
Public Property HideUnreferencedViewTages As Boolean
Visual C++
public:
property bool HideUnreferencedViewTages {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class
Autodesk.Revit Namespace


MarginType Property

[image]

Revit 2010 API
PrintParameters..::.MarginType Property
PrintParameters Class See Also Send Feedback
The print margin type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MarginType MarginType { get; set; }
Visual Basic (Declaration)
Public Property MarginType As MarginType
Visual C++
public:
property MarginType MarginType {
    MarginType get ();
    void set (MarginType value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the input argument is out of range.
System..::.InvalidOperationException | Thrown if the PaperPlacement is not Margins type.

See Also

PrintParameters Class
Autodesk.Revit Namespace


PageOrientation Property

[image]

Revit 2010 API
PrintParameters..::.PageOrientation Property
PrintParameters Class See Also Send Feedback
The Page Orientation of the Print Setting.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PageOrientationType PageOrientation { get; set; }
Visual Basic (Declaration)
Public Property PageOrientation As PageOrientationType
Visual C++
public:
property PageOrientationType PageOrientation {
    PageOrientationType get ();
    void set (PageOrientationType value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the input argument is out of range.

See Also

PrintParameters Class
Autodesk.Revit Namespace


PaperPlacement Property

[image]

Revit 2010 API
PrintParameters..::.PaperPlacement Property
PrintParameters Class See Also Send Feedback
The paper placement type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PaperPlacementType PaperPlacement { get; set; }
Visual Basic (Declaration)
Public Property PaperPlacement As PaperPlacementType
Visual C++
public:
property PaperPlacementType PaperPlacement {
    PaperPlacementType get ();
    void set (PaperPlacementType value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the input argument is out of range.

See Also

PrintParameters Class
Autodesk.Revit Namespace


PaperSize Property

[image]

Revit 2010 API
PrintParameters..::.PaperSize Property
PrintParameters Class See Also Send Feedback
The page size.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PaperSize PaperSize { get; set; }
Visual Basic (Declaration)
Public Property PaperSize As PaperSize
Visual C++
public:
property PaperSize^ PaperSize {
    PaperSize^ get ();
    void set (PaperSize^ value);
}

Remarks

User can select the candidate via PaperSizes and then set the Page source of the Print Setting.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument is null.
System..::.ArgumentException | Thrown when the input argument is invalid for current printer.

See Also

PrintParameters Class
Autodesk.Revit Namespace


PaperSource Property

[image]

Revit 2010 API
PrintParameters..::.PaperSource Property
PrintParameters Class See Also Send Feedback
The page source.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PaperSource PaperSource { get; set; }
Visual Basic (Declaration)
Public Property PaperSource As PaperSource
Visual C++
public:
property PaperSource^ PaperSource {
    PaperSource^ get ();
    void set (PaperSource^ value);
}

Remarks

User can select the candidate via PaperSources and then set the Page source of the Print Setting.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument is null.
System..::.ArgumentException | Thrown when the input argument is invalid for current printer.

See Also

PrintParameters Class
Autodesk.Revit Namespace


RasterQuality Property

[image]

Revit 2010 API
PrintParameters..::.RasterQuality Property
PrintParameters Class See Also Send Feedback
The raster quality type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RasterQualityType RasterQuality { get; set; }
Visual Basic (Declaration)
Public Property RasterQuality As RasterQualityType
Visual C++
public:
property RasterQualityType RasterQuality {
    RasterQualityType get ();
    void set (RasterQualityType value);
}

See Also

PrintParameters Class
Autodesk.Revit Namespace


ReplaceHalftoneWithThinLines Property

[image]

Revit 2010 API
PrintParameters..::.ReplaceHalftoneWithThinLines Property
PrintParameters Class See Also Send Feedback
Indicates whether to replace halftone with thin lines when printing.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool ReplaceHalftoneWithThinLines { get; set; }
Visual Basic (Declaration)
Public Property ReplaceHalftoneWithThinLines As Boolean
Visual C++
public:
property bool ReplaceHalftoneWithThinLines {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class
Autodesk.Revit Namespace


UserDefinedMarginX Property

[image]

Revit 2010 API
PrintParameters..::.UserDefinedMarginX Property
PrintParameters Class See Also Send Feedback
The User defined X value of offset from left bottom corner.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double UserDefinedMarginX { get; set; }
Visual Basic (Declaration)
Public Property UserDefinedMarginX As Double
Visual C++
public:
property double UserDefinedMarginX {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if PaperPlacement is not Margins and MarginType is not User defined type.

See Also

PrintParameters Class
Autodesk.Revit Namespace


UserDefinedMarginY Property

[image]

Revit 2010 API
PrintParameters..::.UserDefinedMarginY Property
PrintParameters Class See Also Send Feedback
The User defined Y value of offset from left bottom corner

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double UserDefinedMarginY { get; set; }
Visual Basic (Declaration)
Public Property UserDefinedMarginY As Double
Visual C++
public:
property double UserDefinedMarginY {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if PaperPlacement is not Margins and MarginType is not User defined type.

See Also

PrintParameters Class
Autodesk.Revit Namespace


ViewLinksinBlue Property

[image]

Revit 2010 API
PrintParameters..::.ViewLinksinBlue Property
PrintParameters Class See Also Send Feedback
Indicates whether to view links in blue when printing.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool ViewLinksinBlue { get; set; }
Visual Basic (Declaration)
Public Property ViewLinksinBlue As Boolean
Visual C++
public:
property bool ViewLinksinBlue {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class
Autodesk.Revit Namespace


Zoom Property

[image]

Revit 2010 API
PrintParameters..::.Zoom Property
PrintParameters Class See Also Send Feedback
The zoom value to a percentage of the original size.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Zoom { get; set; }
Visual Basic (Declaration)
Public Property Zoom As Integer
Visual C++
public:
property int Zoom {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if current ZoomType is not Zoom type.
System..::.ArgumentOutOfRangeException | Thrown if input zoom value less than 1.

See Also

PrintParameters Class
Autodesk.Revit Namespace


ZoomType Property

[image]

Revit 2010 API
PrintParameters..::.ZoomType Property
PrintParameters Class See Also Send Feedback
The zoom type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ZoomType ZoomType { get; set; }
Visual Basic (Declaration)
Public Property ZoomType As ZoomType
Visual C++
public:
property ZoomType ZoomType {
    ZoomType get ();
    void set (ZoomType value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the input argument is out of range.

See Also

PrintParameters Class
Autodesk.Revit Namespace


PrintSetup Class

[image]

Revit 2010 API
PrintSetup Class
Members See Also Send Feedback
Represents the Print Setup (File->Print Setup...) within Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PrintSetup : APIObject
Visual Basic (Declaration)
Public Class PrintSetup _
    Inherits APIObject
Visual C++
public ref class PrintSetup : public APIObject

Remarks

The Print Setup object can only get from PrintManager object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.PrintSetup

See Also

PrintSetup Members
Autodesk.Revit Namespace


PrintSetup Members

[image] [image]

Revit 2010 API
PrintSetup Members
PrintSetup Class Constructors Methods Properties See Also Send Feedback

The PrintSetup type exposes the following members.

Constructors

Name | Description
PrintSetup | For Internal Use Only.

Methods

Name | Description
Delete | Delete the current print setting, and make the In-Session setting as the current one.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Rename | Rename the current print setting with the specified name.
Revert | Revert the current print setting.
Save | Save the changes for the current print setting.
SaveAs | Save the current print setting to another print setting with the specified name.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurrentPrintSetting | The current Print Setting of Print Setup.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PrintSetup Class
Autodesk.Revit Namespace


PrintSetup Constructor

[image]

Revit 2010 API
PrintSetup Constructor
PrintSetup Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PrintSetup()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PrintSetup()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PrintSetup Class
Autodesk.Revit Namespace


PrintSetup Methods

[image] [image]

Revit 2010 API
PrintSetup Methods
PrintSetup Class See Also Send Feedback

The PrintSetup type exposes the following members.

Methods

Name | Description
Delete | Delete the current print setting, and make the In-Session setting as the current one.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Rename | Rename the current print setting with the specified name.
Revert | Revert the current print setting.
Save | Save the changes for the current print setting.
SaveAs | Save the current print setting to another print setting with the specified name.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrintSetup Class
Autodesk.Revit Namespace


Delete Method

[image]

Revit 2010 API
PrintSetup..::.Delete Method
PrintSetup Class See Also Send Feedback
Delete the current print setting, and make the In-Session setting as the current one.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Delete()
Visual Basic (Declaration)
Public Function Delete As Boolean
Visual C++
public:
bool Delete()

Return Value

Returns false if Delete operation fails, otherwise, returns true.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the current print setting is In-Session.

See Also

PrintSetup Class
Autodesk.Revit Namespace


Rename Method

[image]

Revit 2010 API
PrintSetup..::.Rename Method
PrintSetup Class See Also Send Feedback
Rename the current print setting with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Rename(
    string newName
)
Visual Basic (Declaration)
Public Function Rename ( _
    newName As String _
) As Boolean
Visual C++
public:
bool Rename(
    String^ newName
)

Parameters

newName
Type: System..::.String
print setting name to be renamed as.

Return Value

Returns false if Rename operation fails, otherwise, returns true.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the input newName already exists in current print setting list.

See Also

PrintSetup Class
Autodesk.Revit Namespace


Revert Method

[image]

Revit 2010 API
PrintSetup..::.Revert Method
PrintSetup Class See Also Send Feedback
Revert the current print setting.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Revert()
Visual Basic (Declaration)
Public Sub Revert
Visual C++
public:
void Revert()

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the current print setting is In-Session.

See Also

PrintSetup Class
Autodesk.Revit Namespace


Save Method

[image]

Revit 2010 API
PrintSetup..::.Save Method
PrintSetup Class See Also Send Feedback
Save the changes for the current print setting.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Save()
Visual Basic (Declaration)
Public Function Save As Boolean
Visual C++
public:
bool Save()

Return Value

Returns false if save operation fails, otherwise, returns true.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the current print setting is In-Session or the current print setting has not changed.

See Also

PrintSetup Class
Autodesk.Revit Namespace


SaveAs Method

[image]

Revit 2010 API
PrintSetup..::.SaveAs Method
PrintSetup Class See Also Send Feedback
Save the current print setting to another print setting with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SaveAs(
    string newName
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    newName As String _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ newName
)

Parameters

newName
Type: System..::.String
print setting name to be saved as.

Return Value

Returns false if saveas operation fails, otherwise, returns true.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the input newName already exists in current print setting list.

See Also

PrintSetup Class
Autodesk.Revit Namespace


PrintSetup Properties

[image] [image]

Revit 2010 API
PrintSetup Properties
PrintSetup Class See Also Send Feedback

The PrintSetup type exposes the following members.

Properties

Name | Description
CurrentPrintSetting | The current Print Setting of Print Setup.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PrintSetup Class
Autodesk.Revit Namespace


CurrentPrintSetting Property

[image]

Revit 2010 API
PrintSetup..::.CurrentPrintSetting Property
PrintSetup Class See Also Send Feedback
The current Print Setting of Print Setup.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PrintSetting CurrentPrintSetting { get; set; }
Visual Basic (Declaration)
Public Property CurrentPrintSetting As PrintSetting
Visual C++
public:
property PrintSetting^ CurrentPrintSetting {
    PrintSetting^ get ();
    void set (PrintSetting^ value);
}

See Also

PrintSetup Class
Autodesk.Revit Namespace


PulldownButton Class

[image]

Revit 2010 API
PulldownButton Class
Members See Also Send Feedback
The RibbonItem object represents an item on RibbonPanel. It can be a push-button or a pull-down that contains the information for creating one RibbonItem.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PulldownButton : RibbonItem
Visual Basic (Declaration)
Public Class PulldownButton _
    Inherits RibbonItem
Visual C++
public ref class PulldownButton : public RibbonItem

Remarks

All the properties and methods are not supported in VSTA.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.RibbonItem
Autodesk.Revit..::.PulldownButton

See Also

PulldownButton Members
Autodesk.Revit Namespace


PulldownButton Members

[image] [image]

Revit 2010 API
PulldownButton Members
PulldownButton Class Constructors Methods Properties See Also Send Feedback

The PulldownButton type exposes the following members.

Constructors

Name | Description
PulldownButton | Initializes a new instance of the PulldownButton class

Methods

Name | Description
AddItem | Adds a new pushbutton to the pulldown button and associates it to an ExternalCommand.
AddPushButton | Adds a new pushbutton to the pulldown button and associates it with an ExternalCommand.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Returns a value whether the RibbonItem equals to another RibbonItem. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the button is enabled. (Inherited from RibbonItem.)
Image | The image shown on the pulldown button.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Items | The collection of items assigned to the pulldown button.
ItemText | Gets or sets the text displayed on the button. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LargeImage | The large image shown on the pulldown button.
Name | Gets the name of the button.
ToolTip | The description that appears as a ToolTip for the button. (Inherited from RibbonItem.)

See Also

PulldownButton Class
Autodesk.Revit Namespace


PulldownButton Constructor

[image]

Revit 2010 API
PulldownButton Constructor
PulldownButton Class See Also Send Feedback
Initializes a new instance of the PulldownButton class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PulldownButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PulldownButton()

See Also

PulldownButton Class
Autodesk.Revit Namespace


PulldownButton Methods

[image] [image]

Revit 2010 API
PulldownButton Methods
PulldownButton Class See Also Send Feedback

The PulldownButton type exposes the following members.

Methods

Name | Description
AddItem | Adds a new pushbutton to the pulldown button and associates it to an ExternalCommand.
AddPushButton | Adds a new pushbutton to the pulldown button and associates it with an ExternalCommand.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Returns a value whether the RibbonItem equals to another RibbonItem. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PulldownButton Class
Autodesk.Revit Namespace


AddItem Method

[image]

Revit 2010 API
PulldownButton..::.AddItem Method
PulldownButton Class See Also Send Feedback
Adds a new pushbutton to the pulldown button and associates it to an ExternalCommand.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PushButton AddItem(
    string text,
    string assembly,
    string className
)
Visual Basic (Declaration)
Public Function AddItem ( _
    text As String, _
    assembly As String, _
    className As String _
) As PushButton
Visual C++
public:
PushButton^ AddItem(
    String^ text,
    String^ assembly,
    String^ className
)

Parameters

text
Type: System..::.String
The user-visible text for the new push button.
assembly
Type: System..::.String
The path to the assembly containing the ExternalCommand.
className
Type: System..::.String
The name of the class (implementing IExternalCommand) to execute when the button is pressed.

Return Value

The newly added pushbutton.

Remarks

The new button will display its large image if PushButton.LargeImage is set.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when text, assembly or className is null.
System..::.ArgumentException | Thrown when text, assembly or className is empty, or text contains an invalid character.

See Also

PulldownButton Class
Autodesk.Revit Namespace


AddPushButton Method

[image]

Revit 2010 API
PulldownButton..::.AddPushButton Method
PulldownButton Class See Also Send Feedback
Adds a new pushbutton to the pulldown button and associates it with an ExternalCommand.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PushButton AddPushButton(
    PushButtonData buttonData
)
Visual Basic (Declaration)
Public Function AddPushButton ( _
    buttonData As PushButtonData _
) As PushButton
Visual C++
public:
PushButton^ AddPushButton(
    PushButtonData^ buttonData
)

Parameters

buttonData
Type: Autodesk.Revit..::.PushButtonData
An object containing the data needed to construct the pushbutton.

Return Value

The newly added pushbutton.

Remarks

The new button will display its large image if PushButton.LargeImage is set.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when buttonData is null.
System..::.ArgumentException | Thrown when buttonData.Name and buttonData.Text are not identical.

See Also

PulldownButton Class
Autodesk.Revit Namespace


PulldownButton Properties

[image] [image]

Revit 2010 API
PulldownButton Properties
PulldownButton Class See Also Send Feedback

The PulldownButton type exposes the following members.

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the button is enabled. (Inherited from RibbonItem.)
Image | The image shown on the pulldown button.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Items | The collection of items assigned to the pulldown button.
ItemText | Gets or sets the text displayed on the button. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LargeImage | The large image shown on the pulldown button.
Name | Gets the name of the button.
ToolTip | The description that appears as a ToolTip for the button. (Inherited from RibbonItem.)

See Also

PulldownButton Class
Autodesk.Revit Namespace


Image Property

[image]

Revit 2010 API
PulldownButton..::.Image Property
PulldownButton Class See Also Send Feedback
The image shown on the pulldown button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ImageSource Image { get; set; }
Visual Basic (Declaration)
Public Property Image As ImageSource
Visual C++
public:
property ImageSource^ Image {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the button if it is a part of a stacked set or if it is promoted to the Quick Access Toolbar. The image should be 16 x 16 pixels. If it is larger it will NOT be adjusted to fit the toolbar button.

See Also

PulldownButton Class
Autodesk.Revit Namespace


Items Property

[image]

Revit 2010 API
PulldownButton..::.Items Property
PulldownButton Class See Also Send Feedback
The collection of items assigned to the pulldown button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public List<RibbonItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As List(Of RibbonItem)
Visual C++
public:
property List<RibbonItem^>^ Items {
    List<RibbonItem^>^ get ();
}

Remarks

The Items property is a zero-based indexed collection used to hold the menu items assigned to the PulldownButton. Because the property is read-only, it can not be assigned a collection of menu items directly.

See Also

PulldownButton Class
Autodesk.Revit Namespace


LargeImage Property

[image]

Revit 2010 API
PulldownButton..::.LargeImage Property
PulldownButton Class See Also Send Feedback
The large image shown on the pulldown button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ImageSource LargeImage { get; set; }
Visual Basic (Declaration)
Public Property LargeImage As ImageSource
Visual C++
public:
property ImageSource^ LargeImage {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the button in the Ribbon panel if the button is not a part of a stacked set. The image should be 32 x 32 pixels. If the image is larger, it will be adjusted to fit the button.

See Also

PulldownButton Class
Autodesk.Revit Namespace


Name Property

[image]

Revit 2010 API
PulldownButton..::.Name Property
PulldownButton Class See Also Send Feedback
Gets the name of the button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

PulldownButton Class
Autodesk.Revit Namespace


PulldownButtonData Class

[image]

Revit 2010 API
PulldownButtonData Class
Members See Also Send Feedback
This class contains information necessary to construct a pulldown button in the Ribbon.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PulldownButtonData : ButtonData
Visual Basic (Declaration)
Public Class PulldownButtonData _
    Inherits ButtonData
Visual C++
public ref class PulldownButtonData : public ButtonData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.ButtonData
Autodesk.Revit..::.PulldownButtonData

See Also

PulldownButtonData Members
Autodesk.Revit Namespace


PulldownButtonData Members

[image] [image]

Revit 2010 API
PulldownButtonData Members
PulldownButtonData Class Constructors Methods Properties See Also Send Feedback

The PulldownButtonData type exposes the following members.

Constructors

Name | Description
PulldownButtonData | Constructs a new instance of PulldownButtonData.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Image | The image of the button. (Inherited from ButtonData.)
LargeImage | The large image of the button. (Inherited from ButtonData.)
Name | The name of the button. (Inherited from ButtonData.)
Text | The user-visible text of the button. (Inherited from ButtonData.)
ToolTip | The description that appears as a ToolTip for the button. (Inherited from ButtonData.)

See Also

PulldownButtonData Class
Autodesk.Revit Namespace


PulldownButtonData Constructor

[image]

Revit 2010 API
PulldownButtonData Constructor
PulldownButtonData Class See Also Send Feedback
Constructs a new instance of PulldownButtonData.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PulldownButtonData(
    string name,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    text As String _
)
Visual C++
public:
PulldownButtonData(
    String^ name,
    String^ text
)

Parameters

name
Type: System..::.String
The internal name of the new button.
text
Type: System..::.String

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when null is passed for one or more arguments.
System..::.ArgumentException | Thrown when an empty string is passed for one or more arguments.

See Also

PulldownButtonData Class
Autodesk.Revit Namespace


PulldownButtonData Methods

[image] [image]

Revit 2010 API
PulldownButtonData Methods
PulldownButtonData Class See Also Send Feedback

The PulldownButtonData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PulldownButtonData Class
Autodesk.Revit Namespace


PulldownButtonData Properties

[image] [image]

Revit 2010 API
PulldownButtonData Properties
PulldownButtonData Class See Also Send Feedback

The PulldownButtonData type exposes the following members.

Properties

Name | Description
Image | The image of the button. (Inherited from ButtonData.)
LargeImage | The large image of the button. (Inherited from ButtonData.)
Name | The name of the button. (Inherited from ButtonData.)
Text | The user-visible text of the button. (Inherited from ButtonData.)
ToolTip | The description that appears as a ToolTip for the button. (Inherited from ButtonData.)

See Also

PulldownButtonData Class
Autodesk.Revit Namespace


PushButton Class

[image]

Revit 2010 API
PushButton Class
Members See Also Send Feedback
The RibbonItem object represents an item on a RibbonPanel. It can be a push-button or a pull-down which contains the information for creating one RibbonItem.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PushButton : RibbonItem
Visual Basic (Declaration)
Public Class PushButton _
    Inherits RibbonItem
Visual C++
public ref class PushButton : public RibbonItem

Remarks

All the properties and methods are not supported in VSTA.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.RibbonItem
Autodesk.Revit..::.PushButton

See Also

PushButton Members
Autodesk.Revit Namespace


PushButton Members

[image] [image]

Revit 2010 API
PushButton Members
PushButton Class Constructors Methods Properties See Also Send Feedback

The PushButton type exposes the following members.

Constructors

Name | Description
PushButton | Initializes a new instance of the PushButton class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Returns a value whether the RibbonItem equals to another RibbonItem. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssemblyName | The assembly path of the button.
ClassName | The name of the class containing the implementation for the command.
Enabled | Gets or sets a value indicating whether the button is enabled. (Inherited from RibbonItem.)
Image | The image of the button.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
ItemText | Gets or sets the text displayed on the button. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LargeImage | The large image shown on the button.
Name | The name of the button.
ToolTip | The description that appears as a ToolTip for the button. (Inherited from RibbonItem.)

See Also

PushButton Class
Autodesk.Revit Namespace


PushButton Constructor

[image]

Revit 2010 API
PushButton Constructor
PushButton Class See Also Send Feedback
Initializes a new instance of the PushButton class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PushButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PushButton()

See Also

PushButton Class
Autodesk.Revit Namespace


PushButton Methods

[image] [image]

Revit 2010 API
PushButton Methods
PushButton Class See Also Send Feedback

The PushButton type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Returns a value whether the RibbonItem equals to another RibbonItem. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PushButton Class
Autodesk.Revit Namespace


PushButton Properties

[image] [image]

Revit 2010 API
PushButton Properties
PushButton Class See Also Send Feedback

The PushButton type exposes the following members.

Properties

Name | Description
AssemblyName | The assembly path of the button.
ClassName | The name of the class containing the implementation for the command.
Enabled | Gets or sets a value indicating whether the button is enabled. (Inherited from RibbonItem.)
Image | The image of the button.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
ItemText | Gets or sets the text displayed on the button. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LargeImage | The large image shown on the button.
Name | The name of the button.
ToolTip | The description that appears as a ToolTip for the button. (Inherited from RibbonItem.)

See Also

PushButton Class
Autodesk.Revit Namespace


AssemblyName Property

[image]

Revit 2010 API
PushButton..::.AssemblyName Property
PushButton Class See Also Send Feedback
The assembly path of the button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string AssemblyName { get; set; }
Visual Basic (Declaration)
Public Property AssemblyName As String
Visual C++
public:
property String^ AssemblyName {
    String^ get ();
    void set (String^ value);
}

Remarks

The path of the assembly which contains the corresponding external command.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when setting the value to null.
System..::.ArgumentException | Thrown when setting the value to an empty string.

See Also

PushButton Class
Autodesk.Revit Namespace


ClassName Property

[image]

Revit 2010 API
PushButton..::.ClassName Property
PushButton Class See Also Send Feedback
The name of the class containing the implementation for the command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string ClassName { get; set; }
Visual Basic (Declaration)
Public Property ClassName As String
Visual C++
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}

Remarks

The class name which implements the interface IExternalCommand.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when setting the value to null.
System..::.ArgumentException | Thrown when setting the value to an empty string.

See Also

PushButton Class
Autodesk.Revit Namespace


Image Property

[image]

Revit 2010 API
PushButton..::.Image Property
PushButton Class See Also Send Feedback
The image of the button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ImageSource Image { get; set; }
Visual Basic (Declaration)
Public Property Image As ImageSource
Visual C++
public:
property ImageSource^ Image {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the button if it is a part of a stacked set or if it is promoted to the Quick Access Toolbar. The image should be 16 x 16 pixels. If the image is larger it will NOT be adjusted to fit the button.

See Also

PushButton Class
Autodesk.Revit Namespace


LargeImage Property

[image]

Revit 2010 API
PushButton..::.LargeImage Property
PushButton Class See Also Send Feedback
The large image shown on the button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ImageSource LargeImage { get; set; }
Visual Basic (Declaration)
Public Property LargeImage As ImageSource
Visual C++
public:
property ImageSource^ LargeImage {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the button in the Ribbon panel if the button is not a part of a stacked set. It will also be shown if the button is added to a pulldown button. The image should be 32 x 32 pixels. If the image is larger it will be adjusted to fit the button.

See Also

PushButton Class
Autodesk.Revit Namespace


Name Property

[image]

Revit 2010 API
PushButton..::.Name Property
PushButton Class See Also Send Feedback
The name of the button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

PushButton Class
Autodesk.Revit Namespace


PushButtonData Class

[image]

Revit 2010 API
PushButtonData Class
Members See Also Send Feedback
This class contains information necessary to construct a push button in the Ribbon.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PushButtonData : ButtonData
Visual Basic (Declaration)
Public Class PushButtonData _
    Inherits ButtonData
Visual C++
public ref class PushButtonData : public ButtonData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.ButtonData
Autodesk.Revit..::.PushButtonData

See Also

PushButtonData Members
Autodesk.Revit Namespace


PushButtonData Members

[image] [image]

Revit 2010 API
PushButtonData Members
PushButtonData Class Constructors Methods Properties See Also Send Feedback

The PushButtonData type exposes the following members.

Constructors

Name | Description
PushButtonData | Constructs a new instance of PushButtonData.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssemblyName | The assembly path of the button.
ClassName | The name of the class containing the implementation for the command.
Image | The image of the button. (Inherited from ButtonData.)
LargeImage | The large image of the button. (Inherited from ButtonData.)
Name | The name of the button. (Inherited from ButtonData.)
Text | The user-visible text of the button. (Inherited from ButtonData.)
ToolTip | The description that appears as a ToolTip for the button. (Inherited from ButtonData.)

See Also

PushButtonData Class
Autodesk.Revit Namespace


PushButtonData Constructor

[image]

Revit 2010 API
PushButtonData Constructor
PushButtonData Class See Also Send Feedback
Constructs a new instance of PushButtonData.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PushButtonData(
    string name,
    string text,
    string assemblyName,
    string className
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    text As String, _
    assemblyName As String, _
    className As String _
)
Visual C++
public:
PushButtonData(
    String^ name,
    String^ text,
    String^ assemblyName,
    String^ className
)

Parameters

name
Type: System..::.String
The internal name of the new button.
text
Type: System..::.String
The user visible text seen on the new button.
assemblyName
Type: System..::.String
The assembly path of the button.
className
Type: System..::.String
The name of the class containing the implementation for the command.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when null is passed for one or more arguments.
System..::.ArgumentException | Thrown when an empty string is passed for one or more arguments.

See Also

PushButtonData Class
Autodesk.Revit Namespace


PushButtonData Methods

[image] [image]

Revit 2010 API
PushButtonData Methods
PushButtonData Class See Also Send Feedback

The PushButtonData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PushButtonData Class
Autodesk.Revit Namespace


PushButtonData Properties

[image] [image]

Revit 2010 API
PushButtonData Properties
PushButtonData Class See Also Send Feedback

The PushButtonData type exposes the following members.

Properties

Name | Description
AssemblyName | The assembly path of the button.
ClassName | The name of the class containing the implementation for the command.
Image | The image of the button. (Inherited from ButtonData.)
LargeImage | The large image of the button. (Inherited from ButtonData.)
Name | The name of the button. (Inherited from ButtonData.)
Text | The user-visible text of the button. (Inherited from ButtonData.)
ToolTip | The description that appears as a ToolTip for the button. (Inherited from ButtonData.)

See Also

PushButtonData Class
Autodesk.Revit Namespace


AssemblyName Property

[image]

Revit 2010 API
PushButtonData..::.AssemblyName Property
PushButtonData Class See Also Send Feedback
The assembly path of the button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string AssemblyName { get; set; }
Visual Basic (Declaration)
Public Property AssemblyName As String
Visual C++
public:
property String^ AssemblyName {
    String^ get ();
    void set (String^ value);
}

Remarks

The path of the assembly which contains the corresponding external command.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when setting the value to null.
System..::.ArgumentException | Thrown when setting the value to an empty string.

See Also

PushButtonData Class
Autodesk.Revit Namespace


ClassName Property

[image]

Revit 2010 API
PushButtonData..::.ClassName Property
PushButtonData Class See Also Send Feedback
The name of the class containing the implementation for the command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string ClassName { get; set; }
Visual Basic (Declaration)
Public Property ClassName As String
Visual C++
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}

Remarks

The class name which implements the interface IExternalCommand.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when setting the value to null.
System..::.ArgumentException | Thrown when setting the value to an empty string.

See Also

PushButtonData Class
Autodesk.Revit Namespace


RevitUIFamilyLoadOptions Class

[image]

Revit 2010 API
RevitUIFamilyLoadOptions Class
Members See Also Send Feedback
Allows you to use Revit's dialog boxes to let the user respond to questions that arise during loading of families.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RevitUIFamilyLoadOptions : IFamilyLoadOptions
Visual Basic (Declaration)
Public Class RevitUIFamilyLoadOptions _
    Implements IFamilyLoadOptions
Visual C++
public ref class RevitUIFamilyLoadOptions : IFamilyLoadOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.RevitUIFamilyLoadOptions

See Also

RevitUIFamilyLoadOptions Members
Autodesk.Revit Namespace


RevitUIFamilyLoadOptions Members

[image] [image]

Revit 2010 API
RevitUIFamilyLoadOptions Members
RevitUIFamilyLoadOptions Class Constructors Methods See Also Send Feedback

The RevitUIFamilyLoadOptions type exposes the following members.

Constructors

Name | Description
RevitUIFamilyLoadOptions | Initializes a new instance of the RevitUIFamilyLoadOptions class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnFamilyFound | Implements the interface method by using the Revit dialog box to handle this situation.
OnSharedFamilyFound | Implements the interface method by using the Revit dialog box to handle this situation.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitUIFamilyLoadOptions Class
Autodesk.Revit Namespace


RevitUIFamilyLoadOptions Constructor

[image]

Revit 2010 API
RevitUIFamilyLoadOptions Constructor
RevitUIFamilyLoadOptions Class See Also Send Feedback
Initializes a new instance of the RevitUIFamilyLoadOptions class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RevitUIFamilyLoadOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RevitUIFamilyLoadOptions()

See Also

RevitUIFamilyLoadOptions Class
Autodesk.Revit Namespace


RevitUIFamilyLoadOptions Methods

[image] [image]

Revit 2010 API
RevitUIFamilyLoadOptions Methods
RevitUIFamilyLoadOptions Class See Also Send Feedback

The RevitUIFamilyLoadOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnFamilyFound | Implements the interface method by using the Revit dialog box to handle this situation.
OnSharedFamilyFound | Implements the interface method by using the Revit dialog box to handle this situation.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitUIFamilyLoadOptions Class
Autodesk.Revit Namespace


OnFamilyFound Method

[image]

Revit 2010 API
RevitUIFamilyLoadOptions..::.OnFamilyFound Method
RevitUIFamilyLoadOptions Class See Also Send Feedback
Implements the interface method by using the Revit dialog box to handle this situation.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool OnFamilyFound(
    bool familyInUse,
    ref bool overwriteParameterValues
)
Visual Basic (Declaration)
Public Overridable Function OnFamilyFound ( _
    familyInUse As Boolean, _
    ByRef overwriteParameterValues As Boolean _
) As Boolean
Visual C++
public:
virtual bool OnFamilyFound(
    bool familyInUse,
    bool% overwriteParameterValues
)

Parameters

familyInUse
Type: System..::.Boolean
overwriteParameterValues
Type: System..::.Boolean %

Implements

IFamilyLoadOptions..::.OnFamilyFound(Boolean, Boolean%)

Remarks

A Revit dialog box will be shown with the question about the conflict between families. The user may choose the response. If the response is to cancel the load of the family, an exception will be thrown from LoadFamily

See Also

RevitUIFamilyLoadOptions Class
Autodesk.Revit Namespace


OnSharedFamilyFound Method

[image]

Revit 2010 API
RevitUIFamilyLoadOptions..::.OnSharedFamilyFound Method
RevitUIFamilyLoadOptions Class See Also Send Feedback
Implements the interface method by using the Revit dialog box to handle this situation.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool OnSharedFamilyFound(
    Family sharedFamily,
    bool familyInUse,
    ref FamilySource source,
    ref bool overwriteParameterValues
)
Visual Basic (Declaration)
Public Overridable Function OnSharedFamilyFound ( _
    sharedFamily As Family, _
    familyInUse As Boolean, _
    ByRef source As FamilySource, _
    ByRef overwriteParameterValues As Boolean _
) As Boolean
Visual C++
public:
virtual bool OnSharedFamilyFound(
    Family^ sharedFamily,
    bool familyInUse,
    FamilySource% source,
    bool% overwriteParameterValues
)

Parameters

sharedFamily
Type: Autodesk.Revit.Elements..::.Family
familyInUse
Type: System..::.Boolean
source
Type: Autodesk.Revit..::.FamilySource %
overwriteParameterValues
Type: System..::.Boolean %

Implements

IFamilyLoadOptions..::.OnSharedFamilyFound(Family, Boolean, FamilySource%, Boolean%)

Remarks

A Revit dialog box will be shown with the question about the conflict between shared families versions in target document and current family. The user may choose the response. If the response is to cancel the load of the family, an exception will be thrown from LoadFamily

See Also

RevitUIFamilyLoadOptions Class
Autodesk.Revit Namespace


RibbonItem Class

[image]

Revit 2010 API
RibbonItem Class
Members See Also Send Feedback
The RibbonItem object represents an item on RibbonPanel, can be a push-button or a pull-down which should contain the information for creating one RibbonItem.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RibbonItem : APIObject
Visual Basic (Declaration)
Public Class RibbonItem _
    Inherits APIObject
Visual C++
public ref class RibbonItem : public APIObject

Remarks

All the properties and methods are not supported in VSTA.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.RibbonItem
Autodesk.Revit..::.PulldownButton
Autodesk.Revit..::.PushButton

See Also

RibbonItem Members
Autodesk.Revit Namespace


RibbonItem Members

[image] [image]

Revit 2010 API
RibbonItem Members
RibbonItem Class Constructors Methods Properties See Also Send Feedback

The RibbonItem type exposes the following members.

Constructors

Name | Description
RibbonItem | Initializes a new instance of the RibbonItem class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Returns a value whether the RibbonItem equals to another RibbonItem. (Overrides Object..::.Equals(Object).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the button is enabled.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
ItemText | Gets or sets the text displayed on the button.
ItemType | Gets the item type.
ToolTip | The description that appears as a ToolTip for the button.

See Also

RibbonItem Class
Autodesk.Revit Namespace


RibbonItem Constructor

[image]

Revit 2010 API
RibbonItem Constructor
RibbonItem Class See Also Send Feedback
Initializes a new instance of the RibbonItem class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RibbonItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RibbonItem()

See Also

RibbonItem Class
Autodesk.Revit Namespace


RibbonItem Methods

[image] [image]

Revit 2010 API
RibbonItem Methods
RibbonItem Class See Also Send Feedback

The RibbonItem type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Returns a value whether the RibbonItem equals to another RibbonItem. (Overrides Object..::.Equals(Object).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RibbonItem Class
Autodesk.Revit Namespace


Equals Method

[image]

Revit 2010 API
RibbonItem..::.Equals Method
RibbonItem Class See Also Send Feedback
Returns a value whether the RibbonItem equals to another RibbonItem.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
Another panel object.

See Also

RibbonItem Class
Autodesk.Revit Namespace


RibbonItem Properties

[image] [image]

Revit 2010 API
RibbonItem Properties
RibbonItem Class See Also Send Feedback

The RibbonItem type exposes the following members.

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the button is enabled.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
ItemText | Gets or sets the text displayed on the button.
ItemType | Gets the item type.
ToolTip | The description that appears as a ToolTip for the button.

See Also

RibbonItem Class
Autodesk.Revit Namespace


Enabled Property

[image]

Revit 2010 API
RibbonItem..::.Enabled Property
RibbonItem Class See Also Send Feedback
Gets or sets a value indicating whether the button is enabled.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Remarks

When the Enabled property is set to false, the button cannot be clicked, and the item's appearance changes. The Image and Text assigned to the button appear grayed out. If the relevant external command cannot be executed, set Enabled = true won't take effect.

See Also

RibbonItem Class
Autodesk.Revit Namespace


ItemText Property

[image]

Revit 2010 API
RibbonItem..::.ItemText Property
RibbonItem Class See Also Send Feedback
Gets or sets the text displayed on the button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual string ItemText { get; set; }
Visual Basic (Declaration)
Public Overridable Property ItemText As String
Visual C++
public:
virtual property String^ ItemText {
    String^ get ();
    void set (String^ value);
}

Remarks

The text can be changed at run time. Null or empty string is not allowed. If the item is a button in a pulldown, its name will also be changed, because these items' name and text must be the same.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when set the text to empty or to the string contains "%".
System..::.ArgumentNullException | Thrown when set the text to null.

See Also

RibbonItem Class
Autodesk.Revit Namespace


ItemType Property

[image]

Revit 2010 API
RibbonItem..::.ItemType Property
RibbonItem Class See Also Send Feedback
Gets the item type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RibbonItem..::.RibbonItemType ItemType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemType As RibbonItem..::.RibbonItemType
Visual C++
public:
property RibbonItem..::.RibbonItemType ItemType {
    RibbonItem..::.RibbonItemType get ();
}

Remarks

Push button or Pull-down button or Menu item.

See Also

RibbonItem Class
Autodesk.Revit Namespace


ToolTip Property

[image]

Revit 2010 API
RibbonItem..::.ToolTip Property
RibbonItem Class See Also Send Feedback
The description that appears as a ToolTip for the button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string ToolTip { get; set; }
Visual Basic (Declaration)
Public Property ToolTip As String
Visual C++
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}

Remarks

The text that is displayed when the mouse pointer moves over the button.

See Also

RibbonItem Class
Autodesk.Revit Namespace


RibbonItem.RibbonItemType Enumeration

[image]

Revit 2010 API
RibbonItem..::.RibbonItemType Enumeration
RibbonItem Class See Also Send Feedback
An enumerate type listing all the toolbar item styles.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum RibbonItemType
Visual Basic (Declaration)
Public Enumeration RibbonItemType
Visual C++
public enum class RibbonItemType

Members

Member name | Description
PulldownButton | A button with a pull-down menu list.
PushButton | A standard button with text and image.

See Also

Autodesk.Revit Namespace


RibbonPanel Class

[image]

Revit 2010 API
RibbonPanel Class
Members Example See Also Send Feedback
The Panel object represents a panel in AddIns tab, which should contains an array of RibbonItems.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RibbonPanel : APIObject
Visual Basic (Declaration)
Public Class RibbonPanel _
    Inherits APIObject
Visual C++
public ref class RibbonPanel : public APIObject

Remarks

All the properties and methods are not supported in VSTA.

Examples

CopyC#
public IExternalApplication.Result OnStartup(ControlledApplication application)
{
    // add new ribbon panel
    RibbonPanel ribbonPanel = application.CreateRibbonPanel("NewRibbonPanel");

    //Create a push button in the ribbon panel �NewRibbonPanel�
    string assembly = @"D:\Sample\HelloWorld\bin\Debug\Hello.dll";
    PushButton pushButton = ribbonPanel.AddPushButton("Hello Button", "Hello Button", assembly, "Hello.HelloButton");

    // create bitmap image for button
    Uri uriImage = new Uri(@"D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png");
    BitmapImage largeImage = new BitmapImage(uriImage);

    // assign bitmap to button
    pushButton.LargeImage = largeImage;

    // assign a small bitmap to button which is used if command
    // is moved to Quick Access Toolbar
    Uri uriSmallImage = new Uri(@"D:\Sample\HelloWorld\bin\Debug\39-Globe_16x16.png");
    BitmapImage smallImage = new BitmapImage(uriSmallImage);

    // assign small image to button
    pushButton.Image = smallImage;

    // add a vertical separator bar to the panel
    ribbonPanel.AddSeparator();

    // define 3 new buttons to be added as stacked buttons
    PushButtonData buttonRed = new PushButtonData("Hello Red", "Hello Red", assembly, "Hello.HelloRed");
    buttonRed.Image = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Red.bmp"));
    PushButtonData buttonBlue = new PushButtonData("Hello Blue", "Hello Blue", assembly, "Hello.HelloBlue");
    buttonBlue.Image = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Blue.bmp"));
    PushButtonData buttonGreen = new PushButtonData("Hello Green", "Hello Green", assembly, "Hello.HelloGreen");
    buttonGreen.Image = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Green.bmp"));

    // add 3 stacked buttons to the panel
    ribbonPanel.AddStackedButtons(buttonRed, buttonBlue, buttonGreen);

    // add a pull-down button to the panel
    PulldownButton pulldownButton = ribbonPanel.AddPulldownButton("Hello", "Hello 123");
    pulldownButton.LargeImage = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Hello.bmp"));

    // add some menu items to the pull-down button and assign bitmaps to them
    PushButton buttonOne = pulldownButton.AddItem("Hello One", assembly, "Hello.HelloOne");
    buttonOne.LargeImage = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\One.bmp"));
    PushButton buttonTwo = pulldownButton.AddItem("Hello Two", assembly, "Hello.HelloTwo");
    buttonTwo.LargeImage = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Two.bmp"));
    PushButton buttonThree = pulldownButton.AddItem("Hello Three", assembly, "Hello.HelloThree");
    buttonThree.LargeImage = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Three.bmp"));

    return IExternalApplication.Result.Succeeded;
}
CopyVB.NET
Public Function OnStartup(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnStartup
    ' add new ribbon panel
    Dim ribbonPanel As RibbonPanel = application.CreateRibbonPanel("NewRibbonPanel")

    'Create a push button in the ribbon panel “NewRibbonPanel”
    Dim assembly As String = "D:\Sample\HelloWorld\bin\Debug\Hello.dll"
    Dim pushButton As PushButton = ribbonPanel.AddPushButton("Hello Button", "Hello Button", assembly, "Hello.HelloButton")

    ' create bitmap image for button
    Dim uriImage As New Uri("D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png")
    Dim largeImage As New BitmapImage(uriImage)

    ' assign bitmap to button
    pushButton.LargeImage = largeImage

    ' assign a small bitmap to button which is used if command
    ' is moved to Quick Access Toolbar
    Dim uriSmallImage As New Uri("D:\Sample\HelloWorld\bin\Debug\39-Globe_16x16.png")
    Dim smallImage As New BitmapImage(uriSmallImage)

    ' assign small image to button
    pushButton.Image = smallImage

    ' add a vertical separator bar to the panel
    ribbonPanel.AddSeparator()

    ' define 3 new buttons to be added as stacked buttons
    Dim buttonRed As New PushButtonData("Hello Red", "Hello Red", assembly, "Hello.HelloRed")
    buttonRed.Image = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Red.bmp"))
    Dim buttonBlue As New PushButtonData("Hello Blue", "Hello Blue", assembly, "Hello.HelloBlue")
    buttonBlue.Image = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Blue.bmp"))
    Dim buttonGreen As New PushButtonData("Hello Green", "Hello Green", assembly, "Hello.HelloGreen")
    buttonGreen.Image = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Green.bmp"))

    ' add 3 stacked buttons to the panel
    ribbonPanel.AddStackedButtons(buttonRed, buttonBlue, buttonGreen)

    ' add a pull-down button to the panel
    Dim pulldownButton As PulldownButton = ribbonPanel.AddPulldownButton("Hello", "Hello 123")
    pulldownButton.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Hello.bmp"))

    ' add some menu items to the pull-down button and assign bitmaps to them
    Dim buttonOne As PushButton = pulldownButton.AddItem("Hello One", assembly, "Hello.HelloOne")
    buttonOne.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\One.bmp"))
    Dim buttonTwo As PushButton = pulldownButton.AddItem("Hello Two", assembly, "Hello.HelloTwo")
    buttonTwo.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Two.bmp"))
    Dim buttonThree As PushButton = pulldownButton.AddItem("Hello Three", assembly, "Hello.HelloThree")
    buttonThree.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Three.bmp"))

    Return IExternalApplication.Result.Succeeded
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.RibbonPanel

See Also

RibbonPanel Members
Autodesk.Revit Namespace


RibbonPanel Members

[image] [image]

Revit 2010 API
RibbonPanel Members
RibbonPanel Class Methods Properties See Also Send Feedback

The RibbonPanel type exposes the following members.

Methods

Name | Description
AddButton | Adds a button to the panel.
AddPulldownButton | Adds a PulldownButton to the panel.
AddPushButton | Adds a PushButton to the panel.
AddSeparator | Adds a new Separator to the panel.
AddStackedButtons | Overloaded.
AddToPulldown | Adds a pushbutton to the existing PulldownButton.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Returns a value whether the panel equals to another panel. (Overrides Object..::.Equals(Object).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the RibbonPanel can respond to user interaction.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Items | Gets the collection of RibbonItems assigned to the RibbonPanel.
Name | Gets or sets the name of the RibbonPanel.
Title | Gets or sets the text of the RibbonPanel.
Visible | Gets or sets a value indicating whether the RibbonPanel is displayed.

See Also

RibbonPanel Class
Autodesk.Revit Namespace


RibbonPanel Methods

[image] [image]

Revit 2010 API
RibbonPanel Methods
RibbonPanel Class See Also Send Feedback

The RibbonPanel type exposes the following members.

Methods

Name | Description
AddButton | Adds a button to the panel.
AddPulldownButton | Adds a PulldownButton to the panel.
AddPushButton | Adds a PushButton to the panel.
AddSeparator | Adds a new Separator to the panel.
AddStackedButtons | Overloaded.
AddToPulldown | Adds a pushbutton to the existing PulldownButton.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Returns a value whether the panel equals to another panel. (Overrides Object..::.Equals(Object).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RibbonPanel Class
Autodesk.Revit Namespace


AddButton Method

[image]

Revit 2010 API
RibbonPanel..::.AddButton Method
RibbonPanel Class See Also Send Feedback
Adds a button to the panel.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RibbonItem AddButton(
    ButtonData buttonData
)
Visual Basic (Declaration)
Public Function AddButton ( _
    buttonData As ButtonData _
) As RibbonItem
Visual C++
public:
RibbonItem^ AddButton(
    ButtonData^ buttonData
)

Parameters

buttonData
Type: Autodesk.Revit..::.ButtonData
Data containing information about the new button.

Return Value

The added button.

Remarks

The new button will either be a PushButton or PulldownButton, depending upon the type of data passed in. The new button will be created as a large-size vertical button in the panel.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when buttonData is null.

See Also

RibbonPanel Class
Autodesk.Revit Namespace


AddPulldownButton Method

[image]

Revit 2010 API
RibbonPanel..::.AddPulldownButton Method
RibbonPanel Class See Also Send Feedback
Adds a PulldownButton to the panel.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PulldownButton AddPulldownButton(
    string name,
    string text
)
Visual Basic (Declaration)
Public Function AddPulldownButton ( _
    name As String, _
    text As String _
) As PulldownButton
Visual C++
public:
PulldownButton^ AddPulldownButton(
    String^ name,
    String^ text
)

Parameters

name
Type: System..::.String
The name of the button.
text
Type: System..::.String
The text of the button.

Return Value

The added PulldownButton.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the name or text is null.
System..::.ArgumentException | Thrown when the name or text is empty.

See Also

RibbonPanel Class
Autodesk.Revit Namespace


AddPushButton Method

[image]

Revit 2010 API
RibbonPanel..::.AddPushButton Method
RibbonPanel Class See Also Send Feedback
Adds a PushButton to the panel.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PushButton AddPushButton(
    string name,
    string text,
    string assembly,
    string className
)
Visual Basic (Declaration)
Public Function AddPushButton ( _
    name As String, _
    text As String, _
    assembly As String, _
    className As String _
) As PushButton
Visual C++
public:
PushButton^ AddPushButton(
    String^ name,
    String^ text,
    String^ assembly,
    String^ className
)

Parameters

name
Type: System..::.String
The name of the button.
text
Type: System..::.String
The text of the button.
assembly
Type: System..::.String
The assembly path which contains the corresponding external command.
className
Type: System..::.String
The class name which implements the interface IExternalCommand.

Return Value

The added PushButton.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the name, text, assembly or classname is null.
System..::.ArgumentException | Thrown when the name, text, assembly or classname is empty or text contains an invalid character.

See Also

RibbonPanel Class
Autodesk.Revit Namespace


AddSeparator Method

[image]

Revit 2010 API
RibbonPanel..::.AddSeparator Method
RibbonPanel Class See Also Send Feedback
Adds a new Separator to the panel.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddSeparator()
Visual Basic (Declaration)
Public Sub AddSeparator
Visual C++
public:
void AddSeparator()

See Also

RibbonPanel Class
Autodesk.Revit Namespace


AddStackedButtons Method

[image] [image]

Revit 2010 API
RibbonPanel..::.AddStackedButtons Method
RibbonPanel Class See Also Send Feedback

Overload List

Name | Description
AddStackedButtons(ButtonData, ButtonData) | Adds two stacked buttons to the panel.
AddStackedButtons(ButtonData, ButtonData, ButtonData) | Adds three stacked buttons to the panel.

See Also

RibbonPanel Class
RibbonPanel Members
Autodesk.Revit Namespace


AddStackedButtons Method (ButtonData, ButtonData)

[image]

Revit 2010 API
RibbonPanel..::.AddStackedButtons Method (ButtonData, ButtonData)
RibbonPanel Class See Also Send Feedback
Adds two stacked buttons to the panel.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public List<RibbonItem> AddStackedButtons(
    ButtonData button1,
    ButtonData button2
)
Visual Basic (Declaration)
Public Function AddStackedButtons ( _
    button1 As ButtonData, _
    button2 As ButtonData _
) As List(Of RibbonItem)
Visual C++
public:
List<RibbonItem^>^ AddStackedButtons(
    ButtonData^ button1,
    ButtonData^ button2
)

Parameters

button1
Type: Autodesk.Revit..::.ButtonData
Data containing information about the first button.
button2
Type: Autodesk.Revit..::.ButtonData
Data containing information about the second button.

Return Value

A collection containing the added buttons.

Remarks

Each new button will either be a PushButton or PulldownButton, depending upon the type of data passed in for each argument. The new buttons will be created as small-size horizontal buttons, with the first stacked on top of the second in the panel.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when button1 or button2 is null.

See Also

RibbonPanel Class
AddStackedButtons Overload
Autodesk.Revit Namespace


AddStackedButtons Method (ButtonData, ButtonData, ButtonData)

[image]

Revit 2010 API
RibbonPanel..::.AddStackedButtons Method (ButtonData, ButtonData, ButtonData)
RibbonPanel Class See Also Send Feedback
Adds three stacked buttons to the panel.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public List<RibbonItem> AddStackedButtons(
    ButtonData button1,
    ButtonData button2,
    ButtonData button3
)
Visual Basic (Declaration)
Public Function AddStackedButtons ( _
    button1 As ButtonData, _
    button2 As ButtonData, _
    button3 As ButtonData _
) As List(Of RibbonItem)
Visual C++
public:
List<RibbonItem^>^ AddStackedButtons(
    ButtonData^ button1,
    ButtonData^ button2,
    ButtonData^ button3
)

Parameters

button1
Type: Autodesk.Revit..::.ButtonData
Data containing information about the first button.
button2
Type: Autodesk.Revit..::.ButtonData
Data containing information about the second button.
button3
Type: Autodesk.Revit..::.ButtonData
Data containing information about the third button.

Return Value

A collection containing the added buttons.

Remarks

Each new button will either be a PushButton or PulldownButton, depending upon the type of data passed in for each argument. The new buttons will be created as small-size horizontal buttons, with the first stacked on top of the second in the panel.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when button1, button2 or button3 is null.

See Also

RibbonPanel Class
AddStackedButtons Overload
Autodesk.Revit Namespace


AddToPulldown Method

[image]

Revit 2010 API
RibbonPanel..::.AddToPulldown Method
RibbonPanel Class See Also Send Feedback
Adds a pushbutton to the existing PulldownButton.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PushButton AddToPulldown(
    string pulldownName,
    string text,
    string assembly,
    string className
)
Visual Basic (Declaration)
Public Function AddToPulldown ( _
    pulldownName As String, _
    text As String, _
    assembly As String, _
    className As String _
) As PushButton
Visual C++
public:
PushButton^ AddToPulldown(
    String^ pulldownName,
    String^ text,
    String^ assembly,
    String^ className
)

Parameters

pulldownName
Type: System..::.String
The name of the PulldownButton.
text
Type: System..::.String
The text of the menu item.
assembly
Type: System..::.String
The assembly path which contains the corresponding external command.
className
Type: System..::.String
The class name which implements the interface IExternalCommand.

Return Value

The added pushbutton.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when pulldownName, text, assembly or classname is null.
System..::.ArgumentException | Thrown when pulldownName, text, assembly or classname is empty, or when the pulldown cannot be found in the panel.

See Also

RibbonPanel Class
Autodesk.Revit Namespace


Equals Method

[image]

Revit 2010 API
RibbonPanel..::.Equals Method
RibbonPanel Class See Also Send Feedback
Returns a value whether the panel equals to another panel.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
Another panel object.

See Also

RibbonPanel Class
Autodesk.Revit Namespace


RibbonPanel Properties

[image] [image]

Revit 2010 API
RibbonPanel Properties
RibbonPanel Class See Also Send Feedback

The RibbonPanel type exposes the following members.

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the RibbonPanel can respond to user interaction.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Items | Gets the collection of RibbonItems assigned to the RibbonPanel.
Name | Gets or sets the name of the RibbonPanel.
Title | Gets or sets the text of the RibbonPanel.
Visible | Gets or sets a value indicating whether the RibbonPanel is displayed.

See Also

RibbonPanel Class
Autodesk.Revit Namespace


Enabled Property

[image]

Revit 2010 API
RibbonPanel..::.Enabled Property
RibbonPanel Class See Also Send Feedback
Gets or sets a value indicating whether the RibbonPanel can respond to user interaction.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Remarks

With the Enabled property, you can enable or disable controls at run time.

See Also

RibbonPanel Class
Autodesk.Revit Namespace


Items Property

[image]

Revit 2010 API
RibbonPanel..::.Items Property
RibbonPanel Class See Also Send Feedback
Gets the collection of RibbonItems assigned to the RibbonPanel.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public List<RibbonItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As List(Of RibbonItem)
Visual C++
public:
property List<RibbonItem^>^ Items {
    List<RibbonItem^>^ get ();
}

Remarks

The Items property is a zero-based indexed collection used to hold the button items assigned to the RibbonPanel. Because the property is read-only, it can not be assigned a collection of RibbonPanel items directly. Items can be added by using the methods AddItem.

See Also

RibbonPanel Class
Autodesk.Revit Namespace


Name Property

[image]

Revit 2010 API
RibbonPanel..::.Name Property
RibbonPanel Class See Also Send Feedback
Gets or sets the name of the RibbonPanel.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

The name will be displayed on the panel if the Text is not set.

See Also

RibbonPanel Class
Autodesk.Revit Namespace


Title Property

[image]

Revit 2010 API
RibbonPanel..::.Title Property
RibbonPanel Class See Also Send Feedback
Gets or sets the text of the RibbonPanel.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Remarks

If user doesn’t set this property, the default value is its Name.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the title contains angle bracket.

See Also

RibbonPanel Class
Autodesk.Revit Namespace


Visible Property

[image]

Revit 2010 API
RibbonPanel..::.Visible Property
RibbonPanel Class See Also Send Feedback
Gets or sets a value indicating whether the RibbonPanel is displayed.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

Remarks

True if the RibbonPanel is displayed; otherwise, false. The default is true.

See Also

RibbonPanel Class
Autodesk.Revit Namespace


Selection Class

[image]

Revit 2010 API
Selection Class
Members See Also Send Feedback
Contains the current user selection of elements within the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Selection : APIObject
Visual Basic (Declaration)
Public Class Selection _
    Inherits APIObject
Visual C++
public ref class Selection : public APIObject

Remarks

The Selection object is used to retrieve the current user selected elements when an external API command is executed.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Selection

See Also

Selection Members
Autodesk.Revit Namespace


Selection Members

[image] [image]

Revit 2010 API
Selection Members
Selection Class Constructors Methods Properties See Also Send Feedback

The Selection type exposes the following members.

Constructors

Name | Description
Selection | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
PickOne | Allows the user to select one element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WindowSelect | Allows the user to select elements by a rectangle.

Properties

Name | Description
Elements | The elements that are currently selected.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
StatusbarTip | The message displayed in the status bar tip when prompting the user to make a selection.

See Also

Selection Class
Autodesk.Revit Namespace


Selection Constructor

[image]

Revit 2010 API
Selection Constructor
Selection Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Selection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Selection()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Selection Class
Autodesk.Revit Namespace


Selection Methods

[image] [image]

Revit 2010 API
Selection Methods
Selection Class See Also Send Feedback

The Selection type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
PickOne | Allows the user to select one element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WindowSelect | Allows the user to select elements by a rectangle.

See Also

Selection Class
Autodesk.Revit Namespace


PickOne Method

[image]

Revit 2010 API
Selection..::.PickOne Method
Selection Class Example See Also Send Feedback
Allows the user to select one element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool PickOne()
Visual Basic (Declaration)
Public Function PickOne As Boolean
Visual C++
public:
bool PickOne()

Return Value

True if the user selected an element, false if the user selected elsewhere in the UI

Remarks

One more element will be added to the active set of selected elements if user selects an element that is not in the active set of selected elements.

Examples

CopyC#
Selection choices = document.Selection;
// Pick one object from Revit.
bool hasPickOne = choices.PickOne();
if (true == hasPickOne)
{
    MessageBox.Show("One element added to Selection.", "Revit");
}
CopyVB.NET
Dim choices As Autodesk.Revit.Selection = document.Selection
' Pick one object from Revit.
Dim hasPickOne As Boolean = choices.PickOne()
If True = hasPickOne Then
    MessageBox.Show("One element added to Selection.", "Revit")
End If

See Also

Selection Class
Autodesk.Revit Namespace


WindowSelect Method

[image]

Revit 2010 API
Selection..::.WindowSelect Method
Selection Class Example See Also Send Feedback
Allows the user to select elements by a rectangle.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool WindowSelect()
Visual Basic (Declaration)
Public Function WindowSelect As Boolean
Visual C++
public:
bool WindowSelect()

Return Value

True if the user selected one or more elements, false if the user selected elsewhere in the UI

Remarks

Newly selected elements will be added to the active set of selected elements.

Examples

CopyC#
int selectionCount = choices.Elements.Size;
// Choose objects from Revit.
bool hasPickSome = choices.WindowSelect();
if (true == hasPickSome)
{
    int newSelectionCount = choices.Elements.Size;
    string prompt = string.Format("{0} elements added to Selection.", newSelectionCount - selectionCount);
    MessageBox.Show(prompt, "Revit");
}
CopyVB.NET
Dim selectionCount As Integer = choices.Elements.Size
' Choose objects from Revit.
Dim hasPickSome As Boolean = choices.WindowSelect()
If True = hasPickSome Then
    Dim newSelectionCount As Integer = choices.Elements.Size
    Dim prompt As String = String.Format("{0} elements added to Selection.", newSelectionCount - selectionCount)
    MessageBox.Show(prompt, "Revit")
End If

See Also

Selection Class
Autodesk.Revit Namespace


Selection Properties

[image] [image]

Revit 2010 API
Selection Properties
Selection Class See Also Send Feedback

The Selection type exposes the following members.

Properties

Name | Description
Elements | The elements that are currently selected.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
StatusbarTip | The message displayed in the status bar tip when prompting the user to make a selection.

See Also

Selection Class
Autodesk.Revit Namespace


Elements Property

[image]

Revit 2010 API
Selection..::.Elements Property
Selection Class Example See Also Send Feedback
The elements that are currently selected.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SelElementSet Elements { get; set; }
Visual Basic (Declaration)
Public Property Elements As SelElementSet
Visual C++
public:
property SelElementSet^ Elements {
    SelElementSet^ get ();
    void set (SelElementSet^ value);
}

Field Value

The set of elements that are actively selected.

Remarks

This set will contain the results after the user makes selections due to a PickOne or WindowSelect call.

Examples

CopyC#
private void ChangeSelection(Document document)
{
    // Get selected elements form current document.
    Autodesk.Revit.SelElementSet collection = document.Selection.Elements;

    // Display current number of selected elements
    MessageBox.Show("Number of selected elements: " + collection.Size.ToString());

    //Create a new SelElementSet
    SelElementSet newSelectedElementSet = document.Application.Create.NewSelElementSet();

    // Add wall into the created element set.
    foreach (Autodesk.Revit.Element elements in collection)
    {
        if (elements is Wall)
        {
            newSelectedElementSet.Add(elements);
        }
    }

    // Set the created element set as current select element set.
    document.Selection.Elements = newSelectedElementSet;

    // Give the user some information.
    if (0 != newSelectedElementSet.Size)
    {
        MessageBox.Show(document.Selection.Elements.Size.ToString() + " Walls are selected!");
    }
    else
    {
        MessageBox.Show("No Walls have been selected!");
    }
}
CopyVB.NET
Private Sub ChangeSelection(ByVal document As Document)
    ' Get selected elements form current document.
    Dim collection As Autodesk.Revit.SelElementSet = document.Selection.Elements

    ' Display current number of selected elements
    MessageBox.Show("Number of selected elements: " & collection.Size.ToString())

    'Create a new SelElementSet
    Dim newSelectedElementSet As SelElementSet = document.Application.Create.NewSelElementSet()

    ' Add wall into the created element set.
    For Each elements As Autodesk.Revit.Element In collection
        If TypeOf elements Is Wall Then
            newSelectedElementSet.Add(elements)
        End If
    Next

    ' Set the created element set as current select element set.
    document.Selection.Elements = newSelectedElementSet

    ' Give the user some information.
    If 0 <> newSelectedElementSet.Size Then
        MessageBox.Show(document.Selection.Elements.Size.ToString() & " Walls are selected!")
    Else
        MessageBox.Show("No Walls have been selected!")
    End If
End Sub

See Also

Selection Class
Autodesk.Revit Namespace


StatusbarTip Property

[image]

Revit 2010 API
Selection..::.StatusbarTip Property
Selection Class See Also Send Feedback
The message displayed in the status bar tip when prompting the user to make a selection.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string StatusbarTip { get; set; }
Visual Basic (Declaration)
Public Property StatusbarTip As String
Visual C++
public:
property String^ StatusbarTip {
    String^ get ();
    void set (String^ value);
}

Field Value

The message is displayed in the status bar at the bottom of the Autodesk Revit UI.

See Also

Selection Class
Autodesk.Revit Namespace


SelElementSet Class

[image]

Revit 2010 API
SelElementSet Class
Members See Also Send Feedback
This class contains the current user selection of elements within the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SelElementSet : ElementSet
Visual Basic (Declaration)
Public Class SelElementSet _
    Inherits ElementSet
Visual C++
public ref class SelElementSet : public ElementSet

Remarks

Because the ModScope is transfered into the constructor, the SelElementSet can be used to Add or Remove element from the selected element set directly.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.ElementSet
Autodesk.Revit..::.SelElementSet

See Also

SelElementSet Members
Autodesk.Revit Namespace


SelElementSet Members

[image] [image]

Revit 2010 API
SelElementSet Members
SelElementSet Class Constructors Methods Properties See Also Send Feedback

The SelElementSet type exposes the following members.

Constructors

Name | Description
SelElementSet | For Internal Use Only.

Methods

Name | Description
Add | Add an element into the selected element set.
Clear | Clear the selected element set. (Overrides ElementSet..::.Clear()()().)
Contains | Tests for the existence of an element within the set. (Inherited from ElementSet.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Remove an element from the selected element set. (Overrides ElementSet..::.Erase(Element).)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element into the set. (Inherited from ElementSet.)
Remove | Remove an element from the selected element set.
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from ElementSet.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from ElementSet.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of elements that are in the set. (Inherited from ElementSet.)

See Also

SelElementSet Class
Autodesk.Revit Namespace


SelElementSet Constructor

[image]

Revit 2010 API
SelElementSet Constructor
SelElementSet Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SelElementSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SelElementSet()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SelElementSet Class
Autodesk.Revit Namespace


SelElementSet Methods

[image] [image]

Revit 2010 API
SelElementSet Methods
SelElementSet Class See Also Send Feedback

The SelElementSet type exposes the following members.

Methods

Name | Description
Add | Add an element into the selected element set.
Clear | Clear the selected element set. (Overrides ElementSet..::.Clear()()().)
Contains | Tests for the existence of an element within the set. (Inherited from ElementSet.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Remove an element from the selected element set. (Overrides ElementSet..::.Erase(Element).)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element into the set. (Inherited from ElementSet.)
Remove | Remove an element from the selected element set.
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from ElementSet.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelElementSet Class
Autodesk.Revit Namespace


Add Method

[image]

Revit 2010 API
SelElementSet..::.Add Method
SelElementSet Class See Also Send Feedback
Add an element into the selected element set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Add(
    Element element
)
Visual Basic (Declaration)
Public Overridable Sub Add ( _
    element As Element _
)
Visual C++
public:
virtual void Add(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit..::.Element
The element to be added.

Remarks

This function will add the specified element to the selected element set, just like the element is picked from the UI.

See Also

SelElementSet Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
SelElementSet..::.Clear Method
SelElementSet Class See Also Send Feedback
Clear the selected element set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override void Clear()
Visual Basic (Declaration)
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

Remarks

All the elements in the selected element set will be removed and no element will be highlighted after the operation.

See Also

SelElementSet Class
Autodesk.Revit Namespace


Erase Method

[image]

Revit 2010 API
SelElementSet..::.Erase Method
SelElementSet Class See Also Send Feedback
Remove an element from the selected element set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override int Erase(
    Element element
)
Visual Basic (Declaration)
Public Overrides Function Erase ( _
    element As Element _
) As Integer
Visual C++
public:
virtual int Erase(
    Element^ element
) override

Parameters

element
Type: Autodesk.Revit..::.Element
The element to be removed.

Return Value

Returns count of the elements to be erased from the selected element set.

Remarks

This function will do same task as Remove.

See Also

SelElementSet Class
Autodesk.Revit Namespace


Remove Method

[image]

Revit 2010 API
SelElementSet..::.Remove Method
SelElementSet Class See Also Send Feedback
Remove an element from the selected element set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Remove(
    Element element
)
Visual Basic (Declaration)
Public Overridable Sub Remove ( _
    element As Element _
)
Visual C++
public:
virtual void Remove(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit..::.Element
The element to be removed.

Remarks

This function will remove the specified from the selected element set, just like de-select it from the UI.

See Also

SelElementSet Class
Autodesk.Revit Namespace


SelElementSet Properties

[image] [image]

Revit 2010 API
SelElementSet Properties
SelElementSet Class See Also Send Feedback

The SelElementSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from ElementSet.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of elements that are in the set. (Inherited from ElementSet.)

See Also

SelElementSet Class
Autodesk.Revit Namespace


Settings Class

[image]

Revit 2010 API
Settings Class
Members Example See Also Send Feedback
The settings object provides access to general components of the Autodesk Revit application, such as Categories.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Settings : APIObject
Visual Basic (Declaration)
Public Class Settings _
    Inherits APIObject
Visual C++
public ref class Settings : public APIObject

Examples

CopyC#
// Get some of the settings information, inluding categories, Materials and FillPatterns
Settings settings = document.Settings;

// Format the prompt information string
String prompt = "Setting information: ";
prompt += "\nNumber of Categories: " + settings.Categories.Size;
prompt += "\nNumber of Materials: " + settings.Materials.Size;
prompt += "\nNumber of Fill Patterns: " + settings.FillPatterns.Size;
prompt += "\nNumber of Line Patterns: " + settings.LinePatterns.Size;

// Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);
CopyVB.NET
' Get some of the settings information, inluding categories, Materials and FillPatterns
Dim settings As Settings = document.Settings

' Format the prompt information string
Dim prompt As String = "Setting information: "
prompt += vbLf & "Number of Categories: " & settings.Categories.Size
prompt += vbLf & "Number of Materials: " & settings.Materials.Size
prompt += vbLf & "Number of Fill Patterns: " & settings.FillPatterns.Size
prompt += vbLf & "Number of Line Patterns: " & settings.LinePatterns.Size

' Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Settings

See Also

Settings Members
Autodesk.Revit Namespace


Settings Members

[image] [image]

Revit 2010 API
Settings Members
Settings Class Constructors Methods Properties See Also Send Feedback

The Settings type exposes the following members.

Constructors

Name | Description
Settings | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Categories | Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.
ElectricalSetting | Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.
FillPatterns | Retrieves an object that provides access to all the FillPatterns contained in the Autodesk Revit application and project.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
LinePatterns | Retrieves an object that provides access to all the LinePatterns contained in the Autodesk Revit application and project.
Materials | Retrieves an object that provides access to all the Materials contained in the Autodesk Revit application and project.
TilePatterns | Retrieves an object that provides access to the TilePattern objects in the document.
VolumeCalculationSetting | Retrieves an object that provides access to Volume Calculation Setting in the Autodesk Revit application and project.

See Also

Settings Class
Autodesk.Revit Namespace


Settings Constructor

[image]

Revit 2010 API
Settings Constructor
Settings Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Settings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Settings()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Settings Class
Autodesk.Revit Namespace


Settings Methods

[image] [image]

Revit 2010 API
Settings Methods
Settings Class See Also Send Feedback

The Settings type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Settings Class
Autodesk.Revit Namespace


Settings Properties

[image] [image]

Revit 2010 API
Settings Properties
Settings Class See Also Send Feedback

The Settings type exposes the following members.

Properties

Name | Description
Categories | Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.
ElectricalSetting | Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.
FillPatterns | Retrieves an object that provides access to all the FillPatterns contained in the Autodesk Revit application and project.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
LinePatterns | Retrieves an object that provides access to all the LinePatterns contained in the Autodesk Revit application and project.
Materials | Retrieves an object that provides access to all the Materials contained in the Autodesk Revit application and project.
TilePatterns | Retrieves an object that provides access to the TilePattern objects in the document.
VolumeCalculationSetting | Retrieves an object that provides access to Volume Calculation Setting in the Autodesk Revit application and project.

See Also

Settings Class
Autodesk.Revit Namespace


Categories Property

[image]

Revit 2010 API
Settings..::.Categories Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Categories Categories { get; }
Visual Basic (Declaration)
Public ReadOnly Property Categories As Categories
Visual C++
public:
property Categories^ Categories {
    Categories^ get ();
}

See Also

Settings Class
Autodesk.Revit Namespace


ElectricalSetting Property

[image]

Revit 2010 API
Settings..::.ElectricalSetting Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElectricalSetting ElectricalSetting { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElectricalSetting As ElectricalSetting
Visual C++
public:
property ElectricalSetting^ ElectricalSetting {
    ElectricalSetting^ get ();
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Electrical settings can be accessed only if Revit MEP product is available.

See Also

Settings Class
Autodesk.Revit Namespace


FillPatterns Property

[image]

Revit 2010 API
Settings..::.FillPatterns Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to all the FillPatterns contained in the Autodesk Revit application and project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FillPatternSet FillPatterns { get; }
Visual Basic (Declaration)
Public ReadOnly Property FillPatterns As FillPatternSet
Visual C++
public:
property FillPatternSet^ FillPatterns {
    FillPatternSet^ get ();
}

See Also

Settings Class
Autodesk.Revit Namespace


LinePatterns Property

[image]

Revit 2010 API
Settings..::.LinePatterns Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to all the LinePatterns contained in the Autodesk Revit application and project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LinePatternSet LinePatterns { get; }
Visual Basic (Declaration)
Public ReadOnly Property LinePatterns As LinePatternSet
Visual C++
public:
property LinePatternSet^ LinePatterns {
    LinePatternSet^ get ();
}

See Also

Settings Class
Autodesk.Revit Namespace


Materials Property

[image]

Revit 2010 API
Settings..::.Materials Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to all the Materials contained in the Autodesk Revit application and project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Materials Materials { get; }
Visual Basic (Declaration)
Public ReadOnly Property Materials As Materials
Visual C++
public:
property Materials^ Materials {
    Materials^ get ();
}

See Also

Settings Class
Autodesk.Revit Namespace


TilePatterns Property

[image]

Revit 2010 API
Settings..::.TilePatterns Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to the TilePattern objects in the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TilePatterns TilePatterns { get; }
Visual Basic (Declaration)
Public ReadOnly Property TilePatterns As TilePatterns
Visual C++
public:
property TilePatterns^ TilePatterns {
    TilePatterns^ get ();
}

See Also

Settings Class
Autodesk.Revit Namespace


VolumeCalculationSetting Property

[image]

Revit 2010 API
Settings..::.VolumeCalculationSetting Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to Volume Calculation Setting in the Autodesk Revit application and project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public VolumeCalculationSetting VolumeCalculationSetting { get; }
Visual Basic (Declaration)
Public ReadOnly Property VolumeCalculationSetting As VolumeCalculationSetting
Visual C++
public:
property VolumeCalculationSetting^ VolumeCalculationSetting {
    VolumeCalculationSetting^ get ();
}

See Also

Settings Class
Autodesk.Revit Namespace


StructuralTypeFilter Class

[image]

Revit 2010 API
StructuralTypeFilter Class
Members See Also Send Feedback
A Filter object that represents StructuralType, used to retrieve family instances whose structural type is specified structural type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class StructuralTypeFilter : Filter
Visual Basic (Declaration)
Public Class StructuralTypeFilter _
    Inherits Filter
Visual C++
public ref class StructuralTypeFilter : public Filter

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Filter
Autodesk.Revit..::.StructuralTypeFilter

See Also

StructuralTypeFilter Members
Autodesk.Revit Namespace


StructuralTypeFilter Members

[image] [image]

Revit 2010 API
StructuralTypeFilter Members
StructuralTypeFilter Class Constructors Methods Properties See Also Send Feedback

The StructuralTypeFilter type exposes the following members.

Constructors

Name | Description
StructuralTypeFilter | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

StructuralTypeFilter Class
Autodesk.Revit Namespace


StructuralTypeFilter Constructor

[image]

Revit 2010 API
StructuralTypeFilter Constructor
StructuralTypeFilter Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public StructuralTypeFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StructuralTypeFilter()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

StructuralTypeFilter Class
Autodesk.Revit Namespace


StructuralTypeFilter Methods

[image] [image]

Revit 2010 API
StructuralTypeFilter Methods
StructuralTypeFilter Class See Also Send Feedback

The StructuralTypeFilter type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StructuralTypeFilter Class
Autodesk.Revit Namespace


StructuralTypeFilter Properties

[image] [image]

Revit 2010 API
StructuralTypeFilter Properties
StructuralTypeFilter Class See Also Send Feedback

The StructuralTypeFilter type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

StructuralTypeFilter Class
Autodesk.Revit Namespace


SuspendUpdating Class

[image]

Revit 2010 API
SuspendUpdating Class
Members Example See Also Send Feedback
Temporarily delay Revit's automatic updating and consistency operations.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SuspendUpdating : APIObject
Visual Basic (Declaration)
Public Class SuspendUpdating _
    Inherits APIObject
Visual C++
public ref class SuspendUpdating : public APIObject

Remarks

Creating an instance of this object will cause Autodesk Revit to suspend certain updating and consistency operations, thereby enabling increased performance of large changes via the API. After the object is disposed, updating will take place if required. The object should be disposed explicitly using the Dispose method to ensure known points of consistency within your application. Note that while this object is active the Revit model data may be inconsistent hence values retrieved cannot necessarily be trusted. The object may be nested and the Nested property will return if such an object is already nested. During nesting the final updating will only happen when all SuspendUpdating objects are disposed. Currently suspend updating functionality works primarily with object transformation operations such as move and rotate. Note: This functionality is not available through the Revit COM API. Following methods(properties) support SuspendUpdating:
  • Autodesk.Revit.Document.Move
  • Autodesk.Revit.Document.Rotate
  • Autodesk.Revit.Document.Mirror
  • Autodesk.Revit.Location.Move
  • Autodesk.Revit.Location.Rotate
  • Autodesk.Revit.Creation.Document.NewAnnotationSymbol
  • Autodesk.Revit.Elements.FamilyInstance.flipHand
  • Autodesk.Revit.Elements.FamilyInstance.flipFacing
  • Autodesk.Revit.Elements.FamilyInstance.rotate
  • Autodesk.Revit.Elements.FamilyInstance.FlipFromToRoom
  • Autodesk.Revit.Elements.CurtainGridLine.Move
  • property Autodesk.Revit.LocationPoint.Point.set
  • property Autodesk.Revit.Elements.FamilyInstance.Symbol.set
  • property Autodesk.Revit.Elements.FamilyInstance.StructuralUsage.set
  • property Autodesk.Revit.Elements.Wall.WallType.set
  • property Autodesk.Revit.Elements.TextNote.Coord.set
  • property Autodesk.Revit.Elements.TextNote.Width.set
  • property Autodesk.Revit.Elements.IndependentTag.TagHeadPosition.set
  • property Autodesk.Revit.Elements.IndependentTag.LeaderElbow.set
  • property Autodesk.Revit.Elements.IndependentTag.LeaderEnd.set
  • property Autodesk.Revit.Leader.End.set
  • property Autodesk.Revit.Leader.Elbow.set
  • property Autodesk.Revit.Elements.CurtainGrid.Grid1Justification.set
  • property Autodesk.Revit.Elements.CurtainGrid.Grid1Angle.set
  • property Autodesk.Revit.Elements.CurtainGrid.Grid1Offset.set
  • property Autodesk.Revit.Elements.CurtainGrid.Grid2Justification.set
  • property Autodesk.Revit.Elements.CurtainGrid.Grid2Angle.set
  • property Autodesk.Revit.Elements.CurtainGrid.Grid2Offset.set

Examples

CopyC#
public void MoveElements(Autodesk.Revit.Document document)
{
    Selection choices = document.Selection;
    ElementSet collection = choices.Elements;
    // Using statement defines a scope at the end of which the suspandUpdating
    // object is disposed.
    using (SuspendUpdating aSuspendUpdating = new SuspendUpdating(document))
    {
        // Suspend these operations.
        foreach (FamilyInstance element in collection)
        {
            MoveRotateElement(document, element);
        }
    }
    // Move() operations only update when aSuspendUpdating and
    // bSuspendUpdating (in MoveRotateElement()) are disposed
}

private bool MoveRotateElement(Document document, Autodesk.Revit.Element elem)
{
    // Operations suspended until SuspendUpdating object is disposed
    using (SuspendUpdating bSuspendUpdating = new SuspendUpdating(document))
    {
        // Move Element
        XYZ translation3D = new XYZ(0.0, 0.0, 0.0);
        bool successful1 = document.Move(elem, translation3D);

        // Rotate Element
        XYZ point1 = new XYZ(10, 20, 0);
        XYZ point2 = new XYZ(10, 20, 30);
        Line axis = document.Application.Create.NewLineUnbound(point1, point2);
        bool successful2 = document.Rotate(elem, axis, Math.PI / 3.0);

        return (successful1 && successful2);
    }
}
CopyVB.NET
Public Sub MoveElements(ByVal document As Autodesk.Revit.Document)
    Dim choices As Autodesk.Revit.Selection = document.Selection
    Dim collection As ElementSet = choices.Elements
    ' Using statement defines a scope at the end of which the suspandUpdating
    ' object is disposed.
    Using aSuspendUpdating As New SuspendUpdating(document)
        ' Suspend these operations.
        For Each element As Autodesk.Revit.Elements.FamilyInstance In collection
            MoveRotateElement(document, element)
        Next
    End Using
    ' Move() operations only update when aSuspendUpdating and
    ' bSuspendUpdating (in MoveRotateElement()) are disposed
End Sub

Private Function MoveRotateElement(ByVal document As Document, ByVal elem As Autodesk.Revit.Element) As Boolean
    ' Operations suspended until SuspendUpdating object is disposed
    Using bSuspendUpdating As New SuspendUpdating(document)
        ' Move Element
        Dim translation3D As New Autodesk.Revit.Geometry.XYZ(0.0R, 0.0R, 0.0R)
        Dim successful1 As Boolean = document.Move(elem, translation3D)

        ' Rotate Element
        Dim point1 As New Autodesk.Revit.Geometry.XYZ(10, 20, 0)
        Dim point2 As New Autodesk.Revit.Geometry.XYZ(10, 20, 30)
        Dim axis As Line = document.Application.Create.NewLineUnbound(point1, point2)
        Dim successful2 As Boolean = document.Rotate(elem, axis, Math.PI / 3.0R)

        Return (successful1 AndAlso successful2)
    End Using
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.SuspendUpdating

See Also

SuspendUpdating Members
Autodesk.Revit Namespace


SuspendUpdating Members

[image] [image]

Revit 2010 API
SuspendUpdating Members
SuspendUpdating Class Constructors Methods Properties See Also Send Feedback

The SuspendUpdating type exposes the following members.

Constructors

Name | Description
SuspendUpdating | Create a new instance of the SuspendUpdating object and begin suspension of consistency updates.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Nested | A property that reports if updating has already been suspended before

See Also

SuspendUpdating Class
Autodesk.Revit Namespace


SuspendUpdating Constructor

[image]

Revit 2010 API
SuspendUpdating Constructor
SuspendUpdating Class See Also Send Feedback
Create a new instance of the SuspendUpdating object and begin suspension of consistency updates.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SuspendUpdating(
    Document document
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document _
)
Visual C++
public:
SuspendUpdating(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit..::.Document
The document for which updating will be suspended.

Remarks

During suspension of updating, consistency will not be maintained. When all SuspendUpdating objects have been disposed, Revit will make the document consistent again.

See Also

SuspendUpdating Class
Autodesk.Revit Namespace


SuspendUpdating Methods

[image] [image]

Revit 2010 API
SuspendUpdating Methods
SuspendUpdating Class See Also Send Feedback

The SuspendUpdating type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SuspendUpdating Class
Autodesk.Revit Namespace


SuspendUpdating Properties

[image] [image]

Revit 2010 API
SuspendUpdating Properties
SuspendUpdating Class See Also Send Feedback

The SuspendUpdating type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Nested | A property that reports if updating has already been suspended before

See Also

SuspendUpdating Class
Autodesk.Revit Namespace


Nested Property

[image]

Revit 2010 API
SuspendUpdating..::.Nested Property
SuspendUpdating Class See Also Send Feedback
A property that reports if updating has already been suspended before

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Nested { get; }
Visual Basic (Declaration)
Public ReadOnly Property Nested As Boolean
Visual C++
public:
property bool Nested {
    bool get ();
}

Remarks

This property can be used to detect that the SuspendUpdating object has been created during the lifetime of another SuspendUpdating object and hence the document will not be made consistent which this object is disposed.

See Also

SuspendUpdating Class
Autodesk.Revit Namespace


SweepProfile Class

[image]

Revit 2010 API
SweepProfile Class
Members See Also Send Feedback
Represents a profile for sweep or swept blend elements.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SweepProfile : APIObject
Visual Basic (Declaration)
Public Class SweepProfile _
    Inherits APIObject
Visual C++
public ref class SweepProfile : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.SweepProfile
Autodesk.Revit..::.CurveLoopsProfile
Autodesk.Revit..::.FamilySymbolProfile

See Also

SweepProfile Members
Autodesk.Revit Namespace


SweepProfile Members

[image] [image]

Revit 2010 API
SweepProfile Members
SweepProfile Class Methods Properties See Also Send Feedback

The SweepProfile type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SweepProfile Class
Autodesk.Revit Namespace


SweepProfile Methods

[image] [image]

Revit 2010 API
SweepProfile Methods
SweepProfile Class See Also Send Feedback

The SweepProfile type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SweepProfile Class
Autodesk.Revit Namespace


SweepProfile Properties

[image] [image]

Revit 2010 API
SweepProfile Properties
SweepProfile Class See Also Send Feedback

The SweepProfile type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SweepProfile Class
Autodesk.Revit Namespace


Symbol Class

[image]

Revit 2010 API
Symbol Class
Members See Also Send Feedback
Base class for all Symbols and Types within Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Symbol : Element
Visual Basic (Declaration)
Public Class Symbol _
    Inherits Element
Visual C++
public ref class Symbol : public Element

Remarks

Symbols are usually non user visible elements that define instances. For example a wall type is a symbol that is not visible until an instance of the wall is created.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.DemandFactor
Autodesk.Revit.MEP..::.DistributionSysType
Autodesk.Revit.MEP..::.FluidType
Autodesk.Revit.MEP..::.MEPCurveType
Autodesk.Revit.MEP..::.PipeConnectionType
Autodesk.Revit.MEP..::.PipeMaterialType
Autodesk.Revit.MEP..::.PipeScheduleType
Autodesk.Revit.MEP..::.VoltageType
Autodesk.Revit.MEP..::.WireType
Autodesk.Revit.Site..::.SiteLocation
Autodesk.Revit.Symbols..::.AreaReinforcementType
Autodesk.Revit.Symbols..::.BeamSystemType
Autodesk.Revit.Symbols..::.DimensionType
Autodesk.Revit.Symbols..::.GroupType
Autodesk.Revit.Symbols..::.HostObjAttributes
Autodesk.Revit.Symbols..::.InsertableObject
Autodesk.Revit.Symbols..::.LevelType
Autodesk.Revit.Symbols..::.LineAndTextAttrSymbol
Autodesk.Revit.Symbols..::.LoadTypeBase
Autodesk.Revit.Symbols..::.MEPBuildingConstruction
Autodesk.Revit.Symbols..::.ModelTextType
Autodesk.Revit.Symbols..::.PathReinforcementType
Autodesk.Revit.Symbols..::.RebarBarType
Autodesk.Revit.Symbols..::.RebarCoverType
Autodesk.Revit.Symbols..::.RebarHookType
Autodesk.Revit.Symbols..::.RebarShape
Autodesk.Revit.Symbols..::.TilePattern
Autodesk.Revit.Symbols..::.TrussType

See Also

Symbol Members
Autodesk.Revit Namespace


Symbol Members

[image] [image]

Revit 2010 API
Symbol Members
Symbol Class Constructors Methods Properties See Also Send Feedback

The Symbol type exposes the following members.

Constructors

Name | Description
Symbol | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Symbol Class
Autodesk.Revit Namespace


Symbol Constructor

[image]

Revit 2010 API
Symbol Constructor
Symbol Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Symbol()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Symbol()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Symbol Class
Autodesk.Revit Namespace


Symbol Methods

[image] [image]

Revit 2010 API
Symbol Methods
Symbol Class See Also Send Feedback

The Symbol type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Symbol Class
Autodesk.Revit Namespace


Duplicate Method

[image]

Revit 2010 API
Symbol..::.Duplicate Method
Symbol Class See Also Send Feedback
Duplicate this object.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Symbol Duplicate(
    string name
)
Visual Basic (Declaration)
Public Function Duplicate ( _
    name As String _
) As Symbol
Visual C++
public:
Symbol^ Duplicate(
    String^ name
)

Parameters

name
Type: System..::.String
The new name that will be assigned to the duplicated object.

Return Value

If successful the duplicated object is returned, otherwise Nothing.

Remarks

This method attempts to duplicate the object and assign it the specified name. In some cases the name must be unique, i.e. not already exist in the project. If the name is required to be unique and the name is not a System.ArgumentException will be thrown. If for some reason the object cannot be duplicated a System.NullReferenceException will be thrown.

See Also

Symbol Class
Autodesk.Revit Namespace


Symbol Properties

[image] [image]

Revit 2010 API
Symbol Properties
Symbol Class See Also Send Feedback

The Symbol type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Symbol Class
Autodesk.Revit Namespace


Name Property

[image]

Revit 2010 API
Symbol..::.Name Property
Symbol Class See Also Send Feedback
set name for a symbol

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

this method will assign the symbol a new name, and then notify object brower to fresh name

See Also

Symbol Class
Autodesk.Revit Namespace


Parameter Property

[image] [image]

Revit 2010 API
Symbol..::.Parameter Property
Symbol Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Symbol Class
Symbol Members
Autodesk.Revit Namespace


SymbolFilter Class

[image]

Revit 2010 API
SymbolFilter Class
Members See Also Send Feedback
A filter object that used to filter symbol elements which satisfy specified criterion, filter elements by specifying symbol name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SymbolFilter : Filter
Visual Basic (Declaration)
Public Class SymbolFilter _
    Inherits Filter
Visual C++
public ref class SymbolFilter : public Filter

Remarks

The filtered elements include: Symbol type elements, FamilyInstance type elements and other types instances(such as Door, Wall, etc) whose symbol is specified symbol. These elements should belong to main model, active design option or primary design option.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Filter
Autodesk.Revit..::.SymbolFilter

See Also

SymbolFilter Members
Autodesk.Revit Namespace


SymbolFilter Members

[image] [image]

Revit 2010 API
SymbolFilter Members
SymbolFilter Class Constructors Methods Properties See Also Send Feedback

The SymbolFilter type exposes the following members.

Constructors

Name | Description
SymbolFilter | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SymbolFilter Class
Autodesk.Revit Namespace


SymbolFilter Constructor

[image]

Revit 2010 API
SymbolFilter Constructor
SymbolFilter Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SymbolFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SymbolFilter()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SymbolFilter Class
Autodesk.Revit Namespace


SymbolFilter Methods

[image] [image]

Revit 2010 API
SymbolFilter Methods
SymbolFilter Class See Also Send Feedback

The SymbolFilter type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SymbolFilter Class
Autodesk.Revit Namespace


SymbolFilter Properties

[image] [image]

Revit 2010 API
SymbolFilter Properties
SymbolFilter Class See Also Send Feedback

The SymbolFilter type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SymbolFilter Class
Autodesk.Revit Namespace


TilePatterns Class

[image]

Revit 2010 API
TilePatterns Class
Members See Also Send Feedback
The TilePatterns object is an interface for retrieving the TilePattern objects within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class TilePatterns : APIObject
Visual Basic (Declaration)
Public Class TilePatterns _
    Inherits APIObject
Visual C++
public ref class TilePatterns : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.TilePatterns

See Also

TilePatterns Members
Autodesk.Revit Namespace


TilePatterns Members

[image] [image]

Revit 2010 API
TilePatterns Members
TilePatterns Class Constructors Methods Properties See Also Send Feedback

The TilePatterns type exposes the following members.

Constructors

Name | Description
TilePatterns | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTilePattern | Retrieve a TilePattern object from a built-in type.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TilePatterns Class
Autodesk.Revit Namespace


TilePatterns Constructor

[image]

Revit 2010 API
TilePatterns Constructor
TilePatterns Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TilePatterns()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TilePatterns()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TilePatterns Class
Autodesk.Revit Namespace


TilePatterns Methods

[image] [image]

Revit 2010 API
TilePatterns Methods
TilePatterns Class See Also Send Feedback

The TilePatterns type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTilePattern | Retrieve a TilePattern object from a built-in type.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TilePatterns Class
Autodesk.Revit Namespace


GetTilePattern Method

[image]

Revit 2010 API
TilePatterns..::.GetTilePattern Method
TilePatterns Class See Also Send Feedback
Retrieve a TilePattern object from a built-in type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TilePattern GetTilePattern(
    TilePatternsBuiltIn tilePatternBuiltIn
)
Visual Basic (Declaration)
Public Function GetTilePattern ( _
    tilePatternBuiltIn As TilePatternsBuiltIn _
) As TilePattern
Visual C++
public:
TilePattern^ GetTilePattern(
    TilePatternsBuiltIn tilePatternBuiltIn
)

Parameters

tilePatternBuiltIn
Type: Autodesk.Revit.Enums..::.TilePatternsBuiltIn

Return Value

A TilePattern object, or null if the document is not a Massing Family.

See Also

TilePatterns Class
Autodesk.Revit Namespace


TilePatterns Properties

[image] [image]

Revit 2010 API
TilePatterns Properties
TilePatterns Class See Also Send Feedback

The TilePatterns type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TilePatterns Class
Autodesk.Revit Namespace


TrussMemberInfo Class

[image]

Revit 2010 API
TrussMemberInfo Class
Members See Also Send Feedback
Provides access to the information of a truss member in Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class TrussMemberInfo
Visual Basic (Declaration)
Public Class TrussMemberInfo
Visual C++
public ref class TrussMemberInfo

Remarks

A struct TrussMemberInfo that contains an element's host truss,whether lock to the truss,usage type,etc.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.TrussMemberInfo

See Also

TrussMemberInfo Members
Autodesk.Revit Namespace


TrussMemberInfo Members

[image] [image]

Revit 2010 API
TrussMemberInfo Members
TrussMemberInfo Class Constructors Methods Properties See Also Send Feedback

The TrussMemberInfo type exposes the following members.

Constructors

Name | Description
TrussMemberInfo | For Internal Use Only.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
hostTrussId | The host truss' ElementId of the member.
lockedToTruss | Whether the member locked to the host truss.
memberTypeKey | Kind of the member in the truss.

See Also

TrussMemberInfo Class
Autodesk.Revit Namespace


TrussMemberInfo Constructor

[image]

Revit 2010 API
TrussMemberInfo Constructor
TrussMemberInfo Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TrussMemberInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrussMemberInfo()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TrussMemberInfo Class
Autodesk.Revit Namespace


TrussMemberInfo Methods

[image] [image]

Revit 2010 API
TrussMemberInfo Methods
TrussMemberInfo Class See Also Send Feedback

The TrussMemberInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrussMemberInfo Class
Autodesk.Revit Namespace


TrussMemberInfo Properties

[image] [image]

Revit 2010 API
TrussMemberInfo Properties
TrussMemberInfo Class See Also Send Feedback

The TrussMemberInfo type exposes the following members.

Properties

Name | Description
hostTrussId | The host truss' ElementId of the member.
lockedToTruss | Whether the member locked to the host truss.
memberTypeKey | Kind of the member in the truss.

See Also

TrussMemberInfo Class
Autodesk.Revit Namespace


hostTrussId Property

[image]

Revit 2010 API
TrussMemberInfo..::.hostTrussId Property
TrussMemberInfo Class See Also Send Feedback
The host truss' ElementId of the member.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementId hostTrussId { get; set; }
Visual Basic (Declaration)
Public Property hostTrussId As ElementId
Visual C++
public:
property ElementId hostTrussId {
    ElementId get ();
    void set (ElementId value);
}

See Also

TrussMemberInfo Class
Autodesk.Revit Namespace


lockedToTruss Property

[image]

Revit 2010 API
TrussMemberInfo..::.lockedToTruss Property
TrussMemberInfo Class See Also Send Feedback
Whether the member locked to the host truss.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool lockedToTruss { get; set; }
Visual Basic (Declaration)
Public Property lockedToTruss As Boolean
Visual C++
public:
property bool lockedToTruss {
    bool get ();
    void set (bool value);
}

See Also

TrussMemberInfo Class
Autodesk.Revit Namespace


memberTypeKey Property

[image]

Revit 2010 API
TrussMemberInfo..::.memberTypeKey Property
TrussMemberInfo Class See Also Send Feedback
Kind of the member in the truss.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TrussMemberType memberTypeKey { get; set; }
Visual Basic (Declaration)
Public Property memberTypeKey As TrussMemberType
Visual C++
public:
property TrussMemberType memberTypeKey {
    TrussMemberType get ();
    void set (TrussMemberType value);
}

See Also

TrussMemberInfo Class
Autodesk.Revit Namespace


TypeFilter Class

[image]

Revit 2010 API
TypeFilter Class
Members See Also Send Feedback
Represents a filter to filter elements with the given type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class TypeFilter : Filter
Visual Basic (Declaration)
Public Class TypeFilter _
    Inherits Filter
Visual C++
public ref class TypeFilter : public Filter

Remarks

The TypeFilter object is to filter all the elements with the given type in the active document. You can specify whether its derived classes will be filtered out or not. By default, this filter will not retrieve derived classes objects.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Filter
Autodesk.Revit..::.TypeFilter

See Also

TypeFilter Members
Autodesk.Revit Namespace


TypeFilter Members

[image] [image]

Revit 2010 API
TypeFilter Members
TypeFilter Class Constructors Methods Properties See Also Send Feedback

The TypeFilter type exposes the following members.

Constructors

Name | Description
TypeFilter | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TypeFilter Class
Autodesk.Revit Namespace


TypeFilter Constructor

[image]

Revit 2010 API
TypeFilter Constructor
TypeFilter Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TypeFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TypeFilter()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TypeFilter Class
Autodesk.Revit Namespace


TypeFilter Methods

[image] [image]

Revit 2010 API
TypeFilter Methods
TypeFilter Class See Also Send Feedback

The TypeFilter type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TypeFilter Class
Autodesk.Revit Namespace


TypeFilter Properties

[image] [image]

Revit 2010 API
TypeFilter Properties
TypeFilter Class See Also Send Feedback

The TypeFilter type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TypeFilter Class
Autodesk.Revit Namespace


VertexIndexPair Class

[image]

Revit 2010 API
VertexIndexPair Class
Members See Also Send Feedback
Represents a connection between vertices in the top and bottom profile of a blend.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class VertexIndexPair
Visual Basic (Declaration)
Public Class VertexIndexPair
Visual C++
public ref class VertexIndexPair

Remarks

Use objects of this type in Blend.VertexConnectionMap and SweptBlend.VertexConnectionMap to get/set the vertex connection map.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.VertexIndexPair

See Also

VertexIndexPair Members
Autodesk.Revit Namespace


VertexIndexPair Members

[image] [image]

Revit 2010 API
VertexIndexPair Members
VertexIndexPair Class Constructors Methods Properties See Also Send Feedback

The VertexIndexPair type exposes the following members.

Constructors

Name | Description
VertexIndexPair | Initializes a new instance of the VertexIndexPair class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bottom | The index of the vertex pair from the bottom profile.
Top | The index of the vertex pair from the top profile.

See Also

VertexIndexPair Class
Autodesk.Revit Namespace


VertexIndexPair Constructor

[image]

Revit 2010 API
VertexIndexPair Constructor
VertexIndexPair Class See Also Send Feedback
Initializes a new instance of the VertexIndexPair class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public VertexIndexPair(
    int iTop,
    int iBottom
)
Visual Basic (Declaration)
Public Sub New ( _
    iTop As Integer, _
    iBottom As Integer _
)
Visual C++
public:
VertexIndexPair(
    int iTop,
    int iBottom
)

Parameters

iTop
Type: System..::.Int32
iBottom
Type: System..::.Int32

See Also

VertexIndexPair Class
Autodesk.Revit Namespace


VertexIndexPair Methods

[image] [image]

Revit 2010 API
VertexIndexPair Methods
VertexIndexPair Class See Also Send Feedback

The VertexIndexPair type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VertexIndexPair Class
Autodesk.Revit Namespace


VertexIndexPair Properties

[image] [image]

Revit 2010 API
VertexIndexPair Properties
VertexIndexPair Class See Also Send Feedback

The VertexIndexPair type exposes the following members.

Properties

Name | Description
Bottom | The index of the vertex pair from the bottom profile.
Top | The index of the vertex pair from the top profile.

See Also

VertexIndexPair Class
Autodesk.Revit Namespace


Bottom Property

[image]

Revit 2010 API
VertexIndexPair..::.Bottom Property
VertexIndexPair Class See Also Send Feedback
The index of the vertex pair from the bottom profile.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Bottom { get; set; }
Visual Basic (Declaration)
Public Property Bottom As Integer
Visual C++
public:
property int Bottom {
    int get ();
    void set (int value);
}

See Also

VertexIndexPair Class
Autodesk.Revit Namespace


Top Property

[image]

Revit 2010 API
VertexIndexPair..::.Top Property
VertexIndexPair Class See Also Send Feedback
The index of the vertex pair from the top profile.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Top { get; set; }
Visual Basic (Declaration)
Public Property Top As Integer
Visual C++
public:
property int Top {
    int get ();
    void set (int value);
}

See Also

VertexIndexPair Class
Autodesk.Revit Namespace


VertexIndexPairArray Class

[image]

Revit 2010 API
VertexIndexPairArray Class
Members See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class VertexIndexPairArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class VertexIndexPairArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class VertexIndexPairArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.VertexIndexPairArray

See Also

VertexIndexPairArray Members
Autodesk.Revit Namespace


VertexIndexPairArray Members

[image] [image]

Revit 2010 API
VertexIndexPairArray Members
VertexIndexPairArray Class Constructors Methods Properties See Also Send Feedback

The VertexIndexPairArray type exposes the following members.

Constructors

Name | Description
VertexIndexPairArray | Initializes a new instance of the VertexIndexPairArray class

Methods

Name | Description
Append |
Clear |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item |
Size |

See Also

VertexIndexPairArray Class
Autodesk.Revit Namespace


VertexIndexPairArray Constructor

[image]

Revit 2010 API
VertexIndexPairArray Constructor
VertexIndexPairArray Class See Also Send Feedback
Initializes a new instance of the VertexIndexPairArray class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public VertexIndexPairArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VertexIndexPairArray()

See Also

VertexIndexPairArray Class
Autodesk.Revit Namespace


VertexIndexPairArray Methods

[image] [image]

Revit 2010 API
VertexIndexPairArray Methods
VertexIndexPairArray Class See Also Send Feedback

The VertexIndexPairArray type exposes the following members.

Methods

Name | Description
Append |
Clear |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VertexIndexPairArray Class
Autodesk.Revit Namespace


Append Method

[image]

Revit 2010 API
VertexIndexPairArray..::.Append Method
VertexIndexPairArray Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    VertexIndexPair item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As VertexIndexPair _
)
Visual C++
public:
virtual void Append(
    VertexIndexPair^ item
)

Parameters

item
Type: Autodesk.Revit..::.VertexIndexPair

See Also

VertexIndexPairArray Class
Autodesk.Revit Namespace


Clear Method

[image]

Revit 2010 API
VertexIndexPairArray..::.Clear Method
VertexIndexPairArray Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

VertexIndexPairArray Class
Autodesk.Revit Namespace


ForwardIterator Method

[image]

Revit 2010 API
VertexIndexPairArray..::.ForwardIterator Method
VertexIndexPairArray Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual VertexIndexPairArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As VertexIndexPairArrayIterator
Visual C++
public:
virtual VertexIndexPairArrayIterator^ ForwardIterator()

See Also

VertexIndexPairArray Class
Autodesk.Revit Namespace


GetEnumerator Method

[image]

Revit 2010 API
VertexIndexPairArray..::.GetEnumerator Method
VertexIndexPairArray Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::.GetEnumerator()()()

See Also

VertexIndexPairArray Class
Autodesk.Revit Namespace


Insert Method

[image]

Revit 2010 API
VertexIndexPairArray..::.Insert Method
VertexIndexPairArray Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    VertexIndexPair item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As VertexIndexPair, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    VertexIndexPair^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit..::.VertexIndexPair
index
Type: System..::.Int32

See Also

VertexIndexPairArray Class
Autodesk.Revit Namespace


ReverseIterator Method

[image]

Revit 2010 API
VertexIndexPairArray..::.ReverseIterator Method
VertexIndexPairArray Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual VertexIndexPairArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As VertexIndexPairArrayIterator
Visual C++
public:
virtual VertexIndexPairArrayIterator^ ReverseIterator()

See Also

VertexIndexPairArray Class
Autodesk.Revit Namespace


VertexIndexPairArray Properties

[image] [image]

Revit 2010 API
VertexIndexPairArray Properties
VertexIndexPairArray Class See Also Send Feedback

The VertexIndexPairArray type exposes the following members.

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item |
Size |

See Also

VertexIndexPairArray Class
Autodesk.Revit Namespace


IsEmpty Property

[image]

Revit 2010 API
VertexIndexPairArray..::.IsEmpty Property
VertexIndexPairArray Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

VertexIndexPairArray Class
Autodesk.Revit Namespace


Item Property

[image]

Revit 2010 API
VertexIndexPairArray..::.Item Property
VertexIndexPairArray Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual VertexIndexPair Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As VertexIndexPair
Visual C++
public:
virtual property VertexIndexPair^ Item[int index] {
    VertexIndexPair^ get (int index);
    void set (int index, VertexIndexPair^ value);
}

Parameters

index
Type: System..::.Int32

See Also

VertexIndexPairArray Class
Autodesk.Revit Namespace


Size Property

[image]

Revit 2010 API
VertexIndexPairArray..::.Size Property
VertexIndexPairArray Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

VertexIndexPairArray Class
Autodesk.Revit Namespace


VertexIndexPairArrayIterator Class

[image]

Revit 2010 API
VertexIndexPairArrayIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class VertexIndexPairArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class VertexIndexPairArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class VertexIndexPairArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.VertexIndexPairArrayIterator

See Also

VertexIndexPairArrayIterator Members
Autodesk.Revit Namespace


VertexIndexPairArrayIterator Members

[image] [image]

Revit 2010 API
VertexIndexPairArrayIterator Members
VertexIndexPairArrayIterator Class Constructors Methods Properties See Also Send Feedback

The VertexIndexPairArrayIterator type exposes the following members.

Constructors

Name | Description
VertexIndexPairArrayIterator | Initializes a new instance of the VertexIndexPairArrayIterator class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

VertexIndexPairArrayIterator Class
Autodesk.Revit Namespace


VertexIndexPairArrayIterator Constructor

[image]

Revit 2010 API
VertexIndexPairArrayIterator Constructor
VertexIndexPairArrayIterator Class See Also Send Feedback
Initializes a new instance of the VertexIndexPairArrayIterator class

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public VertexIndexPairArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VertexIndexPairArrayIterator()

See Also

VertexIndexPairArrayIterator Class
Autodesk.Revit Namespace


VertexIndexPairArrayIterator Methods

[image] [image]

Revit 2010 API
VertexIndexPairArrayIterator Methods
VertexIndexPairArrayIterator Class See Also Send Feedback

The VertexIndexPairArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VertexIndexPairArrayIterator Class
Autodesk.Revit Namespace


MoveNext Method

[image]

Revit 2010 API
VertexIndexPairArrayIterator..::.MoveNext Method
VertexIndexPairArrayIterator Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::.MoveNext()()()

See Also

VertexIndexPairArrayIterator Class
Autodesk.Revit Namespace


Reset Method

[image]

Revit 2010 API
VertexIndexPairArrayIterator..::.Reset Method
VertexIndexPairArrayIterator Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

See Also

VertexIndexPairArrayIterator Class
Autodesk.Revit Namespace


VertexIndexPairArrayIterator Properties

[image] [image]

Revit 2010 API
VertexIndexPairArrayIterator Properties
VertexIndexPairArrayIterator Class See Also Send Feedback

The VertexIndexPairArrayIterator type exposes the following members.

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

VertexIndexPairArrayIterator Class
Autodesk.Revit Namespace


Current Property

[image]

Revit 2010 API
VertexIndexPairArrayIterator..::.Current Property
VertexIndexPairArrayIterator Class See Also Send Feedback

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

See Also

VertexIndexPairArrayIterator Class
Autodesk.Revit Namespace


ViewSheetSetting Class

[image]

Revit 2010 API
ViewSheetSetting Class
Members See Also Send Feedback
Represents the View/Sheet Set (File->Print) within Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ViewSheetSetting : APIObject
Visual Basic (Declaration)
Public Class ViewSheetSetting _
    Inherits APIObject
Visual C++
public ref class ViewSheetSetting : public APIObject

Remarks

The View/Sheet Setting object is derived from the Element object and as such contains all the properties and methods of that object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.ViewSheetSetting

See Also

ViewSheetSetting Members
Autodesk.Revit Namespace


ViewSheetSetting Members

[image] [image]

Revit 2010 API
ViewSheetSetting Members
ViewSheetSetting Class Constructors Methods Properties See Also Send Feedback

The ViewSheetSetting type exposes the following members.

Constructors

Name | Description
ViewSheetSetting | For Internal Use Only.

Methods

Name | Description
Delete | Delete the current view sheet set, and make the In-Session set as the current one.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Rename | Rename the current view sheet set.
Revert | Revert the current view sheet set.
Save | Save the changes for the current view sheet set.
SaveAs | Save the current view sheet set to another view sheet set with the specified name.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AvailableViews | All views that can be printed.
CurrentViewSheetSet | The current view sheet set of PrintSetup.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace


ViewSheetSetting Constructor

[image]

Revit 2010 API
ViewSheetSetting Constructor
ViewSheetSetting Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSheetSetting()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewSheetSetting()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace


ViewSheetSetting Methods

[image] [image]

Revit 2010 API
ViewSheetSetting Methods
ViewSheetSetting Class See Also Send Feedback

The ViewSheetSetting type exposes the following members.

Methods

Name | Description
Delete | Delete the current view sheet set, and make the In-Session set as the current one.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Rename | Rename the current view sheet set.
Revert | Revert the current view sheet set.
Save | Save the changes for the current view sheet set.
SaveAs | Save the current view sheet set to another view sheet set with the specified name.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace


Delete Method

[image]

Revit 2010 API
ViewSheetSetting..::.Delete Method
ViewSheetSetting Class See Also Send Feedback
Delete the current view sheet set, and make the In-Session set as the current one.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Delete()
Visual Basic (Declaration)
Public Function Delete As Boolean
Visual C++
public:
bool Delete()

Return Value

Returns false if Delete operation fails, otherwise, returns true.

Remarks

If the current view sheet set is In-Session, an InvalidOperationException will be thrown.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the current view sheet set is In-Session.

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace


Rename Method

[image]

Revit 2010 API
ViewSheetSetting..::.Rename Method
ViewSheetSetting Class See Also Send Feedback
Rename the current view sheet set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Rename(
    string newName
)
Visual Basic (Declaration)
Public Function Rename ( _
    newName As String _
) As Boolean
Visual C++
public:
bool Rename(
    String^ newName
)

Parameters

newName
Type: System..::.String
View sheet set name to be renamed as.

Return Value

Returns false if Rename operation fails, otherwise, returns true.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the input name is already existed in current view sheet set list.

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace


Revert Method

[image]

Revit 2010 API
ViewSheetSetting..::.Revert Method
ViewSheetSetting Class See Also Send Feedback
Revert the current view sheet set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Revert()
Visual Basic (Declaration)
Public Sub Revert
Visual C++
public:
void Revert()

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the current view sheet set is In-Session.

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace


Save Method

[image]

Revit 2010 API
ViewSheetSetting..::.Save Method
ViewSheetSetting Class See Also Send Feedback
Save the changes for the current view sheet set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Save()
Visual Basic (Declaration)
Public Function Save As Boolean
Visual C++
public:
bool Save()

Return Value

Returns false if save operation fails, otherwise, returns true.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the current view sheet set is In-Session or the current view sheet set is unchanged.

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace


SaveAs Method

[image]

Revit 2010 API
ViewSheetSetting..::.SaveAs Method
ViewSheetSetting Class See Also Send Feedback
Save the current view sheet set to another view sheet set with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SaveAs(
    string newName
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    newName As String _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ newName
)

Parameters

newName
Type: System..::.String
View sheet set name to be saved as.

Return Value

Returns false if saveas operation fails, otherwise, returns true.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the input name is already existed in current view sheet set list.

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace


ViewSheetSetting Properties

[image] [image]

Revit 2010 API
ViewSheetSetting Properties
ViewSheetSetting Class See Also Send Feedback

The ViewSheetSetting type exposes the following members.

Properties

Name | Description
AvailableViews | All views that can be printed.
CurrentViewSheetSet | The current view sheet set of PrintSetup.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace


AvailableViews Property

[image]

Revit 2010 API
ViewSheetSetting..::.AvailableViews Property
ViewSheetSetting Class See Also Send Feedback
All views that can be printed.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSet AvailableViews { get; }
Visual Basic (Declaration)
Public ReadOnly Property AvailableViews As ViewSet
Visual C++
public:
property ViewSet^ AvailableViews {
    ViewSet^ get ();
}

Remarks

Users can select the view/sheet from this view set to printing.

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace


CurrentViewSheetSet Property

[image]

Revit 2010 API
ViewSheetSetting..::.CurrentViewSheetSet Property
ViewSheetSetting Class See Also Send Feedback
The current view sheet set of PrintSetup.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSheetSet CurrentViewSheetSet { get; set; }
Visual Basic (Declaration)
Public Property CurrentViewSheetSet As ViewSheetSet
Visual C++
public:
property ViewSheetSet^ CurrentViewSheetSet {
    ViewSheetSet^ get ();
    void set (ViewSheetSet^ value);
}

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace


VolumeCalculationOptions Class

[image]

Revit 2010 API
VolumeCalculationOptions Class
Members See Also Send Feedback
This class provides access to options related to room volume and area computations.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class VolumeCalculationOptions
Visual Basic (Declaration)
Public Class VolumeCalculationOptions
Visual C++
public ref class VolumeCalculationOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.VolumeCalculationOptions

See Also

VolumeCalculationOptions Members
Autodesk.Revit Namespace


VolumeCalculationOptions Members

[image] [image]

Revit 2010 API
VolumeCalculationOptions Members
VolumeCalculationOptions Class Constructors Methods Properties See Also Send Feedback

The VolumeCalculationOptions type exposes the following members.

Constructors

Name | Description
VolumeCalculationOptions | Creates a new instance of the volume calculation options.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
RoomAreaBoundaryLocation | The location used to calculate area and volume from room boundaries.
VolumeComputationEnable | True to enable volume computation in Revit. False to disable it.

See Also

VolumeCalculationOptions Class
Autodesk.Revit Namespace


VolumeCalculationOptions Constructor

[image]

Revit 2010 API
VolumeCalculationOptions Constructor
VolumeCalculationOptions Class See Also Send Feedback
Creates a new instance of the volume calculation options.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public VolumeCalculationOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VolumeCalculationOptions()

See Also

VolumeCalculationOptions Class
Autodesk.Revit Namespace


VolumeCalculationOptions Methods

[image] [image]

Revit 2010 API
VolumeCalculationOptions Methods
VolumeCalculationOptions Class See Also Send Feedback

The VolumeCalculationOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VolumeCalculationOptions Class
Autodesk.Revit Namespace


VolumeCalculationOptions Properties

[image] [image]

Revit 2010 API
VolumeCalculationOptions Properties
VolumeCalculationOptions Class See Also Send Feedback

The VolumeCalculationOptions type exposes the following members.

Properties

Name | Description
RoomAreaBoundaryLocation | The location used to calculate area and volume from room boundaries.
VolumeComputationEnable | True to enable volume computation in Revit. False to disable it.

See Also

VolumeCalculationOptions Class
Autodesk.Revit Namespace


RoomAreaBoundaryLocation Property

[image]

Revit 2010 API
VolumeCalculationOptions..::.RoomAreaBoundaryLocation Property
VolumeCalculationOptions Class See Also Send Feedback
The location used to calculate area and volume from room boundaries.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundaryLocationType RoomAreaBoundaryLocation { get; set; }
Visual Basic (Declaration)
Public Property RoomAreaBoundaryLocation As BoundaryLocationType
Visual C++
public:
property BoundaryLocationType RoomAreaBoundaryLocation {
    BoundaryLocationType get ();
    void set (BoundaryLocationType value);
}

See Also

VolumeCalculationOptions Class
Autodesk.Revit Namespace


VolumeComputationEnable Property

[image]

Revit 2010 API
VolumeCalculationOptions..::.VolumeComputationEnable Property
VolumeCalculationOptions Class Example See Also Send Feedback
True to enable volume computation in Revit. False to disable it.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool VolumeComputationEnable { get; set; }
Visual Basic (Declaration)
Public Property VolumeComputationEnable As Boolean
Visual C++
public:
property bool VolumeComputationEnable {
    bool get ();
    void set (bool value);
}

Examples

CopyC#
public void GetRoomDimensions(Document doc, Room room)
{
    String roominfo = "Room dimensions:\n";
    // turn on volume calculations:
    doc.Settings.VolumeCalculationSetting.VolumeCalculationOptions.VolumeComputationEnable = true;
    roominfo += "Vol: " + room.Volume + "\n";
    roominfo += "Area: " + room.Area + "\n";
    roominfo += "Perimiter: " + room.Perimeter + "\n";
    roominfo += "Unbounded height: " + room.UnboundedHeight + "\n";
    MessageBox.Show(roominfo);
}
CopyVB.NET
Public Sub GetRoomDimensions(ByVal doc As Document, ByVal room As Room)
    Dim roominfo As String = "Room dimensions:" & vbLf
    ' turn on volume calculations:
    doc.Settings.VolumeCalculationSetting.VolumeCalculationOptions.VolumeComputationEnable = True
    roominfo += "Vol: " & room.Volume & vbLf
    roominfo += "Area: " & room.Area & vbLf
    roominfo += "Perimiter: " & room.Perimeter & vbLf
    roominfo += "Unbounded height: " & room.UnboundedHeight & vbLf
    MessageBox.Show(roominfo)
End Sub

See Also

VolumeCalculationOptions Class
Autodesk.Revit Namespace


VolumeCalculationSetting Class

[image]

Revit 2010 API
VolumeCalculationSetting Class
Members See Also Send Feedback
This class provides access to settings related to room volume and area computations.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class VolumeCalculationSetting
Visual Basic (Declaration)
Public Class VolumeCalculationSetting
Visual C++
public ref class VolumeCalculationSetting

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.VolumeCalculationSetting

See Also

VolumeCalculationSetting Members
Autodesk.Revit Namespace


VolumeCalculationSetting Members

[image] [image]

Revit 2010 API
VolumeCalculationSetting Members
VolumeCalculationSetting Class Constructors Methods Properties See Also Send Feedback

The VolumeCalculationSetting type exposes the following members.

Constructors

Name | Description
VolumeCalculationSetting | For Internal Use Only.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
VolumeCalculationOptions | Retrieve or change the application settings related to automatic calculation of room volumes.

See Also

VolumeCalculationSetting Class
Autodesk.Revit Namespace


VolumeCalculationSetting Constructor

[image]

Revit 2010 API
VolumeCalculationSetting Constructor
VolumeCalculationSetting Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public VolumeCalculationSetting()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VolumeCalculationSetting()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

VolumeCalculationSetting Class
Autodesk.Revit Namespace


VolumeCalculationSetting Methods

[image] [image]

Revit 2010 API
VolumeCalculationSetting Methods
VolumeCalculationSetting Class See Also Send Feedback

The VolumeCalculationSetting type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VolumeCalculationSetting Class
Autodesk.Revit Namespace


VolumeCalculationSetting Properties

[image] [image]

Revit 2010 API
VolumeCalculationSetting Properties
VolumeCalculationSetting Class See Also Send Feedback

The VolumeCalculationSetting type exposes the following members.

Properties

Name | Description
VolumeCalculationOptions | Retrieve or change the application settings related to automatic calculation of room volumes.

See Also

VolumeCalculationSetting Class
Autodesk.Revit Namespace


VolumeCalculationOptions Property

[image]

Revit 2010 API
VolumeCalculationSetting..::.VolumeCalculationOptions Property
VolumeCalculationSetting Class See Also Send Feedback
Retrieve or change the application settings related to automatic calculation of room volumes.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public VolumeCalculationOptions VolumeCalculationOptions { get; set; }
Visual Basic (Declaration)
Public Property VolumeCalculationOptions As VolumeCalculationOptions
Visual C++
public:
property VolumeCalculationOptions^ VolumeCalculationOptions {
    VolumeCalculationOptions^ get ();
    void set (VolumeCalculationOptions^ value);
}

See Also

VolumeCalculationSetting Class
Autodesk.Revit Namespace


WallUsageFilter Class

[image]

Revit 2010 API
WallUsageFilter Class
Members See Also Send Feedback
A Filter object that represents Structural WallUsage, used to retrieve Wall elements whose structural WallUsage is specified WallUsage type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class WallUsageFilter : Filter
Visual Basic (Declaration)
Public Class WallUsageFilter _
    Inherits Filter
Visual C++
public ref class WallUsageFilter : public Filter

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Filter
Autodesk.Revit..::.WallUsageFilter

See Also

WallUsageFilter Members
Autodesk.Revit Namespace


WallUsageFilter Members

[image] [image]

Revit 2010 API
WallUsageFilter Members
WallUsageFilter Class Constructors Methods Properties See Also Send Feedback

The WallUsageFilter type exposes the following members.

Constructors

Name | Description
WallUsageFilter | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WallUsageFilter Class
Autodesk.Revit Namespace


WallUsageFilter Constructor

[image]

Revit 2010 API
WallUsageFilter Constructor
WallUsageFilter Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WallUsageFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WallUsageFilter()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

WallUsageFilter Class
Autodesk.Revit Namespace


WallUsageFilter Methods

[image] [image]

Revit 2010 API
WallUsageFilter Methods
WallUsageFilter Class See Also Send Feedback

The WallUsageFilter type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WallUsageFilter Class
Autodesk.Revit Namespace


WallUsageFilter Properties

[image] [image]

Revit 2010 API
WallUsageFilter Properties
WallUsageFilter Class See Also Send Feedback

The WallUsageFilter type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WallUsageFilter Class
Autodesk.Revit Namespace


Autodesk.Revit.Areas Namespace

[image]

Revit 2010 API
Autodesk.Revit.Areas Namespace
Send Feedback

Classes

Class | Description
AreaScheme | The area scheme associated with a particular area plan.
BoundarySegment | An object that represents a segment of an area boundary.
BoundarySegmentArray | An array that contains boundary segments.
BoundarySegmentArrayArray | An array that contains boundary segment arrays.
BoundarySegmentArrayArrayIterator | An iterator to a array of boundary segment arrays.
BoundarySegmentArrayIterator | An iterator to a boundary segment array.


AreaScheme Class

[image]

Revit 2010 API
AreaScheme Class
Members See Also Send Feedback
The area scheme associated with a particular area plan.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AreaScheme : Element
Visual Basic (Declaration)
Public Class AreaScheme _
    Inherits Element
Visual C++
public ref class AreaScheme : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Areas..::.AreaScheme

See Also

AreaScheme Members
Autodesk.Revit.Areas Namespace


AreaScheme Members

[image] [image]

Revit 2010 API
AreaScheme Members
AreaScheme Class Constructors Methods Properties See Also Send Feedback

The AreaScheme type exposes the following members.

Constructors

Name | Description
AreaScheme | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsGrossBuildingArea | Indicates if the area scheme is a Gross Building Area scheme.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaScheme Class
Autodesk.Revit.Areas Namespace


AreaScheme Constructor

[image]

Revit 2010 API
AreaScheme Constructor
AreaScheme Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaScheme()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaScheme()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaScheme Class
Autodesk.Revit.Areas Namespace


AreaScheme Methods

[image] [image]

Revit 2010 API
AreaScheme Methods
AreaScheme Class See Also Send Feedback

The AreaScheme type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaScheme Class
Autodesk.Revit.Areas Namespace


AreaScheme Properties

[image] [image]

Revit 2010 API
AreaScheme Properties
AreaScheme Class See Also Send Feedback

The AreaScheme type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsGrossBuildingArea | Indicates if the area scheme is a Gross Building Area scheme.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaScheme Class
Autodesk.Revit.Areas Namespace


IsGrossBuildingArea Property

[image]

Revit 2010 API
AreaScheme..::.IsGrossBuildingArea Property
AreaScheme Class See Also Send Feedback
Indicates if the area scheme is a Gross Building Area scheme.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsGrossBuildingArea { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsGrossBuildingArea As Boolean
Visual C++
public:
property bool IsGrossBuildingArea {
    bool get ();
}

See Also

AreaScheme Class
Autodesk.Revit.Areas Namespace


Parameter Property

[image] [image]

Revit 2010 API
AreaScheme..::.Parameter Property
AreaScheme Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AreaScheme Class
AreaScheme Members
Autodesk.Revit.Areas Namespace


BoundarySegment Class

[image]

Revit 2010 API
BoundarySegment Class
Members See Also Send Feedback
An object that represents a segment of an area boundary.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BoundarySegment : APIObject
Visual Basic (Declaration)
Public Class BoundarySegment _
    Inherits APIObject
Visual C++
public ref class BoundarySegment : public APIObject

Remarks

These objects define the the exterior boundary of an area. The geometry of the segment can be retrieved along with the element that is responsible for producing that boundary.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Areas..::.BoundarySegment

See Also

BoundarySegment Members
Autodesk.Revit.Areas Namespace


BoundarySegment Members

[image] [image]

Revit 2010 API
BoundarySegment Members
BoundarySegment Class Constructors Methods Properties See Also Send Feedback

The BoundarySegment type exposes the following members.

Constructors

Name | Description
BoundarySegment | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Curve | Get the curve that is formed by the element that defines the edge of this area.
Document | Provides the document in which the element that created this segment resides.
Element | Retrieve the element that is responsible for producing this boundary segment.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment Class
Autodesk.Revit.Areas Namespace


BoundarySegment Constructor

[image]

Revit 2010 API
BoundarySegment Constructor
BoundarySegment Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundarySegment()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegment()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegment Class
Autodesk.Revit.Areas Namespace


BoundarySegment Methods

[image] [image]

Revit 2010 API
BoundarySegment Methods
BoundarySegment Class See Also Send Feedback

The BoundarySegment type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegment Class
Autodesk.Revit.Areas Namespace


BoundarySegment Properties

[image] [image]

Revit 2010 API
BoundarySegment Properties
BoundarySegment Class See Also Send Feedback

The BoundarySegment type exposes the following members.

Properties

Name | Description
Curve | Get the curve that is formed by the element that defines the edge of this area.
Document | Provides the document in which the element that created this segment resides.
Element | Retrieve the element that is responsible for producing this boundary segment.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment Class
Autodesk.Revit.Areas Namespace


Curve Property

[image]

Revit 2010 API
BoundarySegment..::.Curve Property
BoundarySegment Class See Also Send Feedback
Get the curve that is formed by the element that defines the edge of this area.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

BoundarySegment Class
Autodesk.Revit.Areas Namespace


Document Property

[image]

Revit 2010 API
BoundarySegment..::.Document Property
BoundarySegment Class See Also Send Feedback
Provides the document in which the element that created this segment resides.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

BoundarySegment Class
Autodesk.Revit.Areas Namespace


Element Property

[image]

Revit 2010 API
BoundarySegment..::.Element Property
BoundarySegment Class See Also Send Feedback
Retrieve the element that is responsible for producing this boundary segment.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element Element { get; }
Visual Basic (Declaration)
Public ReadOnly Property Element As Element
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

Remarks

The element property is useful for finding all the elements that bound a specific area.

See Also

BoundarySegment Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArray Class

[image]

Revit 2010 API
BoundarySegmentArray Class
Members See Also Send Feedback
An array that contains boundary segments.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BoundarySegmentArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class BoundarySegmentArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class BoundarySegmentArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Areas..::.BoundarySegmentArray

See Also

BoundarySegmentArray Members
Autodesk.Revit.Areas Namespace


BoundarySegmentArray Members

[image] [image]

Revit 2010 API
BoundarySegmentArray Members
BoundarySegmentArray Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Constructors

Name | Description
BoundarySegmentArray | Initializes a new instance of the BoundarySegmentArray class

Methods

Name | Description
Append | Add the boundary segment to the end of the array.
Clear | Removes every boundary segment from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified boundary segment into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment at a specified index within the array.
Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArray Constructor

[image]

Revit 2010 API
BoundarySegmentArray Constructor
BoundarySegmentArray Class See Also Send Feedback
Initializes a new instance of the BoundarySegmentArray class

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundarySegmentArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArray()

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArray Methods

[image] [image]

Revit 2010 API
BoundarySegmentArray Methods
BoundarySegmentArray Class See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Methods

Name | Description
Append | Add the boundary segment to the end of the array.
Clear | Removes every boundary segment from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified boundary segment into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


Append Method

[image]

Revit 2010 API
BoundarySegmentArray..::.Append Method
BoundarySegmentArray Class See Also Send Feedback
Add the boundary segment to the end of the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    BoundarySegment item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As BoundarySegment _
)
Visual C++
public:
virtual void Append(
    BoundarySegment^ item
)

Parameters

item
Type: Autodesk.Revit.Areas..::.BoundarySegment
The boundary segment to be added.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


Clear Method

[image]

Revit 2010 API
BoundarySegmentArray..::.Clear Method
BoundarySegmentArray Class See Also Send Feedback
Removes every boundary segment from the array, rendering it empty.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


ForwardIterator Method

[image]

Revit 2010 API
BoundarySegmentArray..::.ForwardIterator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


GetEnumerator Method

[image]

Revit 2010 API
BoundarySegmentArray..::.GetEnumerator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


Insert Method

[image]

Revit 2010 API
BoundarySegmentArray..::.Insert Method
BoundarySegmentArray Class See Also Send Feedback
Insert the specified boundary segment into the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    BoundarySegment item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As BoundarySegment, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    BoundarySegment^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Areas..::.BoundarySegment
The boundary segment to be inserted into the array.
index
Type: System..::.Int32
The boundary segment will be inserted before this index.

Return Value

Returns whether the boundary segment was inserted into the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


ReverseIterator Method

[image]

Revit 2010 API
BoundarySegmentArray..::.ReverseIterator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArray Properties

[image] [image]

Revit 2010 API
BoundarySegmentArray Properties
BoundarySegmentArray Class See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment at a specified index within the array.
Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


IsEmpty Property

[image]

Revit 2010 API
BoundarySegmentArray..::.IsEmpty Property
BoundarySegmentArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


Item Property

[image]

Revit 2010 API
BoundarySegmentArray..::.Item Property
BoundarySegmentArray Class See Also Send Feedback
Gets or sets a boundary segment at a specified index within the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual BoundarySegment Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegment
Visual C++
public:
virtual property BoundarySegment^ Item[int index] {
    BoundarySegment^ get (int index);
    void set (int index, BoundarySegment^ value);
}

Parameters

index
Type: System..::.Int32
The index of the boundary segment to be set or retrieved.

Return Value

Returns the boundary segment at the specified index.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


Size Property

[image]

Revit 2010 API
BoundarySegmentArray..::.Size Property
BoundarySegmentArray Class See Also Send Feedback
Returns the number of boundary segments that are in the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayArray Class

[image]

Revit 2010 API
BoundarySegmentArrayArray Class
Members See Also Send Feedback
An array that contains boundary segment arrays.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BoundarySegmentArrayArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class BoundarySegmentArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class BoundarySegmentArrayArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Areas..::.BoundarySegmentArrayArray

See Also

BoundarySegmentArrayArray Members
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayArray Members

[image] [image]

Revit 2010 API
BoundarySegmentArrayArray Members
BoundarySegmentArrayArray Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Constructors

Name | Description
BoundarySegmentArrayArray | Initializes a new instance of the BoundarySegmentArrayArray class

Methods

Name | Description
Append | Add the boundary segment array to the end of the array.
Clear | Removes every boundary segment array from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified boundary segment array into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment array at a specified index within the array.
Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayArray Constructor

[image]

Revit 2010 API
BoundarySegmentArrayArray Constructor
BoundarySegmentArrayArray Class See Also Send Feedback
Initializes a new instance of the BoundarySegmentArrayArray class

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundarySegmentArrayArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayArray()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayArray Methods

[image] [image]

Revit 2010 API
BoundarySegmentArrayArray Methods
BoundarySegmentArrayArray Class See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Methods

Name | Description
Append | Add the boundary segment array to the end of the array.
Clear | Removes every boundary segment array from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified boundary segment array into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


Append Method

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.Append Method
BoundarySegmentArrayArray Class See Also Send Feedback
Add the boundary segment array to the end of the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    BoundarySegmentArray item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As BoundarySegmentArray _
)
Visual C++
public:
virtual void Append(
    BoundarySegmentArray^ item
)

Parameters

item
Type: Autodesk.Revit.Areas..::.BoundarySegmentArray
The boundary segment array to be added.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


Clear Method

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.Clear Method
BoundarySegmentArrayArray Class See Also Send Feedback
Removes every boundary segment array from the array, rendering it empty.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


ForwardIterator Method

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.ForwardIterator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


GetEnumerator Method

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.GetEnumerator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


Insert Method

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.Insert Method
BoundarySegmentArrayArray Class See Also Send Feedback
Insert the specified boundary segment array into the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    BoundarySegmentArray item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As BoundarySegmentArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    BoundarySegmentArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Areas..::.BoundarySegmentArray
The boundary segment array to be inserted into the array.
index
Type: System..::.Int32
The boundary segment array will be inserted before this index.

Return Value

Returns whether the boundary segment array was inserted into the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


ReverseIterator Method

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.ReverseIterator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayArray Properties

[image] [image]

Revit 2010 API
BoundarySegmentArrayArray Properties
BoundarySegmentArrayArray Class See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment array at a specified index within the array.
Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


IsEmpty Property

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.IsEmpty Property
BoundarySegmentArrayArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


Item Property

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.Item Property
BoundarySegmentArrayArray Class See Also Send Feedback
Gets or sets a boundary segment array at a specified index within the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual BoundarySegmentArray Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegmentArray
Visual C++
public:
virtual property BoundarySegmentArray^ Item[int index] {
    BoundarySegmentArray^ get (int index);
    void set (int index, BoundarySegmentArray^ value);
}

Parameters

index
Type: System..::.Int32
The index of the boundary segment array to be set or retrieved.

Return Value

Returns the boundary segment array at the specified index.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


Size Property

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.Size Property
BoundarySegmentArrayArray Class See Also Send Feedback
Returns the number of boundary segment arrays that are in the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayArrayIterator Class

[image]

Revit 2010 API
BoundarySegmentArrayArrayIterator Class
Members See Also Send Feedback
An iterator to a array of boundary segment arrays.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class BoundarySegmentArrayArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class BoundarySegmentArrayArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Areas..::.BoundarySegmentArrayArrayIterator

See Also

BoundarySegmentArrayArrayIterator Members
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayArrayIterator Members

[image] [image]

Revit 2010 API
BoundarySegmentArrayArrayIterator Members
BoundarySegmentArrayArrayIterator Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Constructors

Name | Description
BoundarySegmentArrayArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayArrayIterator Constructor

[image]

Revit 2010 API
BoundarySegmentArrayArrayIterator Constructor
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundarySegmentArrayArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayArrayIterator Methods

[image] [image]

Revit 2010 API
BoundarySegmentArrayArrayIterator Methods
BoundarySegmentArrayArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Areas Namespace


MoveNext Method

[image]

Revit 2010 API
BoundarySegmentArrayArrayIterator..::.MoveNext Method
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Areas Namespace


Reset Method

[image]

Revit 2010 API
BoundarySegmentArrayArrayIterator..::.Reset Method
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayArrayIterator Properties

[image] [image]

Revit 2010 API
BoundarySegmentArrayArrayIterator Properties
BoundarySegmentArrayArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Areas Namespace


Current Property

[image]

Revit 2010 API
BoundarySegmentArrayArrayIterator..::.Current Property
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayIterator Class

[image]

Revit 2010 API
BoundarySegmentArrayIterator Class
Members See Also Send Feedback
An iterator to a boundary segment array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class BoundarySegmentArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class BoundarySegmentArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Areas..::.BoundarySegmentArrayIterator

See Also

BoundarySegmentArrayIterator Members
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayIterator Members

[image] [image]

Revit 2010 API
BoundarySegmentArrayIterator Members
BoundarySegmentArrayIterator Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Constructors

Name | Description
BoundarySegmentArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayIterator Constructor

[image]

Revit 2010 API
BoundarySegmentArrayIterator Constructor
BoundarySegmentArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundarySegmentArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayIterator Methods

[image] [image]

Revit 2010 API
BoundarySegmentArrayIterator Methods
BoundarySegmentArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Areas Namespace


MoveNext Method

[image]

Revit 2010 API
BoundarySegmentArrayIterator..::.MoveNext Method
BoundarySegmentArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Areas Namespace


Reset Method

[image]

Revit 2010 API
BoundarySegmentArrayIterator..::.Reset Method
BoundarySegmentArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Areas Namespace


BoundarySegmentArrayIterator Properties

[image] [image]

Revit 2010 API
BoundarySegmentArrayIterator Properties
BoundarySegmentArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Areas Namespace


Current Property

[image]

Revit 2010 API
BoundarySegmentArrayIterator..::.Current Property
BoundarySegmentArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Areas Namespace


Autodesk.Revit.Collections Namespace

[image]

Revit 2010 API
Autodesk.Revit.Collections Namespace
Send Feedback

Classes

Class | Description
Array | An array that can contain any type of object.
ArrayIterator | An iterator to a array.
DefinitionBindingMap | A map that contains mappings of parameter definitions to parameter bindings.
DefinitionBindingMapIterator | An iterator to a parameter definition to parameter bindings map.
Map | A map that can contain a mapping of any type of object to any other type of object.
MapIterator | An iterator to a map.
Set | A set that can contain any type of object.
SetIterator | An iterator to a set.
StringStringMap | A map that can contain a mapping of a string to another string.
StringStringMapIterator | An iterator to a string to string map.


Array Class

[image]

Revit 2010 API
Array Class
Members See Also Send Feedback
An array that can contain any type of object.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Array : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class Array _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class Array : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Collections..::.Array

See Also

Array Members
Autodesk.Revit.Collections Namespace


Array Members

[image] [image]

Revit 2010 API
Array Members
Array Class Constructors Methods Properties See Also Send Feedback

The Array type exposes the following members.

Constructors

Name | Description
Array | Initializes a new instance of the Array class

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

Array Class
Autodesk.Revit.Collections Namespace


Array Constructor

[image]

Revit 2010 API
Array Constructor
Array Class See Also Send Feedback
Initializes a new instance of the Array class

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Array()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Array()

See Also

Array Class
Autodesk.Revit.Collections Namespace


Array Methods

[image] [image]

Revit 2010 API
Array Methods
Array Class See Also Send Feedback

The Array type exposes the following members.

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Array Class
Autodesk.Revit.Collections Namespace


Append Method

[image]

Revit 2010 API
Array..::.Append Method
Array Class See Also Send Feedback
Add the item to the end of the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    Object item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Object _
)
Visual C++
public:
virtual void Append(
    Object^ item
)

Parameters

item
Type: System..::.Object
The item to be added.

See Also

Array Class
Autodesk.Revit.Collections Namespace


Clear Method

[image]

Revit 2010 API
Array..::.Clear Method
Array Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

Array Class
Autodesk.Revit.Collections Namespace


ForwardIterator Method

[image]

Revit 2010 API
Array..::.ForwardIterator Method
Array Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ArrayIterator
Visual C++
public:
virtual ArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

Array Class
Autodesk.Revit.Collections Namespace


GetEnumerator Method

[image]

Revit 2010 API
Array..::.GetEnumerator Method
Array Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

Array Class
Autodesk.Revit.Collections Namespace


Insert Method

[image]

Revit 2010 API
Array..::.Insert Method
Array Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    Object item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Object, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Object^ item,
    int index
)

Parameters

item
Type: System..::.Object
The item to be inserted into the array.
index
Type: System..::.Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

Array Class
Autodesk.Revit.Collections Namespace


ReverseIterator Method

[image]

Revit 2010 API
Array..::.ReverseIterator Method
Array Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ArrayIterator
Visual C++
public:
virtual ArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

Array Class
Autodesk.Revit.Collections Namespace


Array Properties

[image] [image]

Revit 2010 API
Array Properties
Array Class See Also Send Feedback

The Array type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

Array Class
Autodesk.Revit.Collections Namespace


IsEmpty Property

[image]

Revit 2010 API
Array..::.IsEmpty Property
Array Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

Array Class
Autodesk.Revit.Collections Namespace


Item Property

[image]

Revit 2010 API
Array..::.Item Property
Array Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Object
Visual C++
public:
virtual property Object^ Item[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

Array Class
Autodesk.Revit.Collections Namespace


Size Property

[image]

Revit 2010 API
Array..::.Size Property
Array Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

Array Class
Autodesk.Revit.Collections Namespace


ArrayIterator Class

[image]

Revit 2010 API
ArrayIterator Class
Members See Also Send Feedback
An iterator to a array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Collections..::.ArrayIterator

See Also

ArrayIterator Members
Autodesk.Revit.Collections Namespace


ArrayIterator Members

[image] [image]

Revit 2010 API
ArrayIterator Members
ArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ArrayIterator type exposes the following members.

Constructors

Name | Description
ArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ArrayIterator Class
Autodesk.Revit.Collections Namespace


ArrayIterator Constructor

[image]

Revit 2010 API
ArrayIterator Constructor
ArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ArrayIterator Class
Autodesk.Revit.Collections Namespace


ArrayIterator Methods

[image] [image]

Revit 2010 API
ArrayIterator Methods
ArrayIterator Class See Also Send Feedback

The ArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ArrayIterator Class
Autodesk.Revit.Collections Namespace


MoveNext Method

[image]

Revit 2010 API
ArrayIterator..::.MoveNext Method
ArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ArrayIterator Class
Autodesk.Revit.Collections Namespace


Reset Method

[image]

Revit 2010 API
ArrayIterator..::.Reset Method
ArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ArrayIterator Class
Autodesk.Revit.Collections Namespace


ArrayIterator Properties

[image] [image]

Revit 2010 API
ArrayIterator Properties
ArrayIterator Class See Also Send Feedback

The ArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ArrayIterator Class
Autodesk.Revit.Collections Namespace


Current Property

[image]

Revit 2010 API
ArrayIterator..::.Current Property
ArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ArrayIterator Class
Autodesk.Revit.Collections Namespace


DefinitionBindingMap Class

[image]

Revit 2010 API
DefinitionBindingMap Class
Members See Also Send Feedback
A map that contains mappings of parameter definitions to parameter bindings.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DefinitionBindingMap : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class DefinitionBindingMap _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DefinitionBindingMap : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Collections..::.DefinitionBindingMap
Autodesk.Revit.Parameters..::.BindingMap

See Also

DefinitionBindingMap Members
Autodesk.Revit.Collections Namespace


DefinitionBindingMap Members

[image] [image]

Revit 2010 API
DefinitionBindingMap Members
DefinitionBindingMap Class Constructors Methods Properties See Also Send Feedback

The DefinitionBindingMap type exposes the following members.

Constructors

Name | Description
DefinitionBindingMap | Initializes a new instance of the DefinitionBindingMap class

Methods

Name | Description
Clear | Removes every binding from the map, rendering it empty.
Contains | Tests for the existence of a definition within the map.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a binding with the specified definition from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified binding with the specified definition into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a parameter binding for a specified parameter definition within the map.
Size | Returns the number of bindings that are in the map.

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


DefinitionBindingMap Constructor

[image]

Revit 2010 API
DefinitionBindingMap Constructor
DefinitionBindingMap Class See Also Send Feedback
Initializes a new instance of the DefinitionBindingMap class

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DefinitionBindingMap()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionBindingMap()

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


DefinitionBindingMap Methods

[image] [image]

Revit 2010 API
DefinitionBindingMap Methods
DefinitionBindingMap Class See Also Send Feedback

The DefinitionBindingMap type exposes the following members.

Methods

Name | Description
Clear | Removes every binding from the map, rendering it empty.
Contains | Tests for the existence of a definition within the map.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a binding with the specified definition from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified binding with the specified definition into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


Clear Method

[image]

Revit 2010 API
DefinitionBindingMap..::.Clear Method
DefinitionBindingMap Class See Also Send Feedback
Removes every binding from the map, rendering it empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


Contains Method

[image]

Revit 2010 API
DefinitionBindingMap..::.Contains Method
DefinitionBindingMap Class See Also Send Feedback
Tests for the existence of a definition within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    Definition key
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    key As Definition _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Definition^ key
)

Parameters

key
Type: Autodesk.Revit.Parameters..::.Definition
The definition to be searched for.

Return Value

The Contains method returns True if the definition is within the map, otherwise False.

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


Erase Method

[image]

Revit 2010 API
DefinitionBindingMap..::.Erase Method
DefinitionBindingMap Class See Also Send Feedback
Removes a binding with the specified definition from the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    Definition key
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    key As Definition _
) As Integer
Visual C++
public:
virtual int Erase(
    Definition^ key
)

Parameters

key
Type: Autodesk.Revit.Parameters..::.Definition
The definition of the binding to be erased.

Return Value

The number of bindings that were erased from the map.

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


ForwardIterator Method

[image]

Revit 2010 API
DefinitionBindingMap..::.ForwardIterator Method
DefinitionBindingMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DefinitionBindingMapIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DefinitionBindingMapIterator
Visual C++
public:
virtual DefinitionBindingMapIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the map.

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


GetEnumerator Method

[image]

Revit 2010 API
DefinitionBindingMap..::.GetEnumerator Method
DefinitionBindingMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the map.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


Insert Method

[image]

Revit 2010 API
DefinitionBindingMap..::.Insert Method
DefinitionBindingMap Class See Also Send Feedback
Insert the specified binding with the specified definition into the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    Definition key,
    Binding item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As Definition, _
    item As Binding _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Definition^ key,
    Binding^ item
)

Parameters

key
Type: Autodesk.Revit.Parameters..::.Definition
The definition to be used for inserting the binding into the map.
item
Type: Autodesk.Revit.Parameters..::.Binding
The binding to be inserted into the map.

Return Value

Returns whether the binding was inserted into the map.

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


ReverseIterator Method

[image]

Revit 2010 API
DefinitionBindingMap..::.ReverseIterator Method
DefinitionBindingMap Class See Also Send Feedback
Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DefinitionBindingMapIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DefinitionBindingMapIterator
Visual C++
public:
virtual DefinitionBindingMapIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the map.

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


DefinitionBindingMap Properties

[image] [image]

Revit 2010 API
DefinitionBindingMap Properties
DefinitionBindingMap Class See Also Send Feedback

The DefinitionBindingMap type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a parameter binding for a specified parameter definition within the map.
Size | Returns the number of bindings that are in the map.

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


IsEmpty Property

[image]

Revit 2010 API
DefinitionBindingMap..::.IsEmpty Property
DefinitionBindingMap Class See Also Send Feedback
Test to see if the map is empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the map is empty then True will be returned, otherwise False.

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


Item Property

[image]

Revit 2010 API
DefinitionBindingMap..::.Item Property
DefinitionBindingMap Class See Also Send Feedback
Gets or sets a parameter binding for a specified parameter definition within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Binding Item[
    Definition key
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    key As Definition _
) As Binding
Visual C++
public:
virtual property Binding^ Item[Definition^ key] {
    Binding^ get (Definition^ key);
    void set (Definition^ key, Binding^ value);
}

Parameters

key
Type: Autodesk.Revit.Parameters..::.Definition
The parameter definition of the binding to be set or retrieved.

Return Value

Returns the binding for the specified definition.

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


Size Property

[image]

Revit 2010 API
DefinitionBindingMap..::.Size Property
DefinitionBindingMap Class See Also Send Feedback
Returns the number of bindings that are in the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace


DefinitionBindingMapIterator Class

[image]

Revit 2010 API
DefinitionBindingMapIterator Class
Members See Also Send Feedback
An iterator to a parameter definition to parameter bindings map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class DefinitionBindingMapIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class DefinitionBindingMapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DefinitionBindingMapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Collections..::.DefinitionBindingMapIterator

See Also

DefinitionBindingMapIterator Members
Autodesk.Revit.Collections Namespace


DefinitionBindingMapIterator Members

[image] [image]

Revit 2010 API
DefinitionBindingMapIterator Members
DefinitionBindingMapIterator Class Constructors Methods Properties See Also Send Feedback

The DefinitionBindingMapIterator type exposes the following members.

Constructors

Name | Description
DefinitionBindingMapIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the binding that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Key | Retrieves the definition that is the current focus of the iterator.

See Also

DefinitionBindingMapIterator Class
Autodesk.Revit.Collections Namespace


DefinitionBindingMapIterator Constructor

[image]

Revit 2010 API
DefinitionBindingMapIterator Constructor
DefinitionBindingMapIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DefinitionBindingMapIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionBindingMapIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DefinitionBindingMapIterator Class
Autodesk.Revit.Collections Namespace


DefinitionBindingMapIterator Methods

[image] [image]

Revit 2010 API
DefinitionBindingMapIterator Methods
DefinitionBindingMapIterator Class See Also Send Feedback

The DefinitionBindingMapIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionBindingMapIterator Class
Autodesk.Revit.Collections Namespace


MoveNext Method

[image]

Revit 2010 API
DefinitionBindingMapIterator..::.MoveNext Method
DefinitionBindingMapIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DefinitionBindingMapIterator Class
Autodesk.Revit.Collections Namespace


Reset Method

[image]

Revit 2010 API
DefinitionBindingMapIterator..::.Reset Method
DefinitionBindingMapIterator Class See Also Send Feedback
Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DefinitionBindingMapIterator Class
Autodesk.Revit.Collections Namespace


DefinitionBindingMapIterator Properties

[image] [image]

Revit 2010 API
DefinitionBindingMapIterator Properties
DefinitionBindingMapIterator Class See Also Send Feedback

The DefinitionBindingMapIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the binding that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Key | Retrieves the definition that is the current focus of the iterator.

See Also

DefinitionBindingMapIterator Class
Autodesk.Revit.Collections Namespace


Current Property

[image]

Revit 2010 API
DefinitionBindingMapIterator..::.Current Property
DefinitionBindingMapIterator Class See Also Send Feedback
Retrieves the binding that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DefinitionBindingMapIterator Class
Autodesk.Revit.Collections Namespace


Key Property

[image]

Revit 2010 API
DefinitionBindingMapIterator..::.Key Property
DefinitionBindingMapIterator Class See Also Send Feedback
Retrieves the definition that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Definition Key { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Key As Definition
Visual C++
public:
virtual property Definition^ Key {
    Definition^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

DefinitionBindingMapIterator Class
Autodesk.Revit.Collections Namespace


Map Class

[image]

Revit 2010 API
Map Class
Members See Also Send Feedback
A map that can contain a mapping of any type of object to any other type of object.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Map : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class Map _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class Map : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Collections..::.Map

See Also

Map Members
Autodesk.Revit.Collections Namespace


Map Members

[image] [image]

Revit 2010 API
Map Members
Map Class Constructors Methods Properties See Also Send Feedback

The Map type exposes the following members.

Constructors

Name | Description
Map | Initializes a new instance of the Map class

Methods

Name | Description
Clear | Removes every item from the map, rendering it empty.
Contains | Tests for the existence of a key within the map.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a object with the specified key from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item with the specified key into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified key within the map.
Size | Returns the number of objects that are in the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace


Map Constructor

[image]

Revit 2010 API
Map Constructor
Map Class See Also Send Feedback
Initializes a new instance of the Map class

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Map()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Map()

See Also

Map Class
Autodesk.Revit.Collections Namespace


Map Methods

[image] [image]

Revit 2010 API
Map Methods
Map Class See Also Send Feedback

The Map type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the map, rendering it empty.
Contains | Tests for the existence of a key within the map.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a object with the specified key from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item with the specified key into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Map Class
Autodesk.Revit.Collections Namespace


Clear Method

[image]

Revit 2010 API
Map..::.Clear Method
Map Class See Also Send Feedback
Removes every item from the map, rendering it empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

Map Class
Autodesk.Revit.Collections Namespace


Contains Method

[image]

Revit 2010 API
Map..::.Contains Method
Map Class See Also Send Feedback
Tests for the existence of a key within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    Object key
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    key As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ key
)

Parameters

key
Type: System..::.Object
The key to be searched for.

Return Value

The Contains method returns True if the key is within the map, otherwise False.

See Also

Map Class
Autodesk.Revit.Collections Namespace


Erase Method

[image]

Revit 2010 API
Map..::.Erase Method
Map Class See Also Send Feedback
Removes a object with the specified key from the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    Object key
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    key As Object _
) As Integer
Visual C++
public:
virtual int Erase(
    Object^ key
)

Parameters

key
Type: System..::.Object
The key of the item to be erased.

Return Value

The number of items that were erased from the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace


ForwardIterator Method

[image]

Revit 2010 API
Map..::.ForwardIterator Method
Map Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual MapIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As MapIterator
Visual C++
public:
virtual MapIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace


GetEnumerator Method

[image]

Revit 2010 API
Map..::.GetEnumerator Method
Map Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the map.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

Map Class
Autodesk.Revit.Collections Namespace


Insert Method

[image]

Revit 2010 API
Map..::.Insert Method
Map Class See Also Send Feedback
Insert the specified item with the specified key into the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    Object key,
    Object item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As Object, _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Object^ key,
    Object^ item
)

Parameters

key
Type: System..::.Object
The key to be used for inserting the item into the map.
item
Type: System..::.Object
The item to be inserted into the map.

Return Value

Returns whether the item was inserted into the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace


ReverseIterator Method

[image]

Revit 2010 API
Map..::.ReverseIterator Method
Map Class See Also Send Feedback
Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual MapIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As MapIterator
Visual C++
public:
virtual MapIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace


Map Properties

[image] [image]

Revit 2010 API
Map Properties
Map Class See Also Send Feedback

The Map type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified key within the map.
Size | Returns the number of objects that are in the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace


IsEmpty Property

[image]

Revit 2010 API
Map..::.IsEmpty Property
Map Class See Also Send Feedback
Test to see if the map is empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the map is empty then True will be returned, otherwise False.

See Also

Map Class
Autodesk.Revit.Collections Namespace


Item Property

[image]

Revit 2010 API
Map..::.Item Property
Map Class See Also Send Feedback
Gets or sets an item at a specified key within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Item[
    Object key
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    key As Object _
) As Object
Visual C++
public:
virtual property Object^ Item[Object^ key] {
    Object^ get (Object^ key);
    void set (Object^ key, Object^ value);
}

Parameters

key
Type: System..::.Object
The key of the item to be set or retrieved.

Return Value

Returns the object at the specified key.

See Also

Map Class
Autodesk.Revit.Collections Namespace


Size Property

[image]

Revit 2010 API
Map..::.Size Property
Map Class See Also Send Feedback
Returns the number of objects that are in the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

Map Class
Autodesk.Revit.Collections Namespace


MapIterator Class

[image]

Revit 2010 API
MapIterator Class
Members See Also Send Feedback
An iterator to a map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class MapIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class MapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class MapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Collections..::.MapIterator

See Also

MapIterator Members
Autodesk.Revit.Collections Namespace


MapIterator Members

[image] [image]

Revit 2010 API
MapIterator Members
MapIterator Class Constructors Methods Properties See Also Send Feedback

The MapIterator type exposes the following members.

Constructors

Name | Description
MapIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Key | Retrieves the key that is the current focus of the iterator.

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


MapIterator Constructor

[image]

Revit 2010 API
MapIterator Constructor
MapIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MapIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MapIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


MapIterator Methods

[image] [image]

Revit 2010 API
MapIterator Methods
MapIterator Class See Also Send Feedback

The MapIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


MoveNext Method

[image]

Revit 2010 API
MapIterator..::.MoveNext Method
MapIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


Reset Method

[image]

Revit 2010 API
MapIterator..::.Reset Method
MapIterator Class See Also Send Feedback
Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


MapIterator Properties

[image] [image]

Revit 2010 API
MapIterator Properties
MapIterator Class See Also Send Feedback

The MapIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Key | Retrieves the key that is the current focus of the iterator.

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


Current Property

[image]

Revit 2010 API
MapIterator..::.Current Property
MapIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


Key Property

[image]

Revit 2010 API
MapIterator..::.Key Property
MapIterator Class See Also Send Feedback
Retrieves the key that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Key { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Key As Object
Visual C++
public:
virtual property Object^ Key {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


Set Class

[image]

Revit 2010 API
Set Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Set : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class Set _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class Set : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Collections..::.Set

See Also

Set Members
Autodesk.Revit.Collections Namespace


Set Members

[image] [image]

Revit 2010 API
Set Members
Set Class Constructors Methods Properties See Also Send Feedback

The Set type exposes the following members.

Constructors

Name | Description
Set | Initializes a new instance of the Set class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

Set Class
Autodesk.Revit.Collections Namespace


Set Constructor

[image]

Revit 2010 API
Set Constructor
Set Class See Also Send Feedback
Initializes a new instance of the Set class

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Set()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Set()

See Also

Set Class
Autodesk.Revit.Collections Namespace


Set Methods

[image] [image]

Revit 2010 API
Set Methods
Set Class See Also Send Feedback

The Set type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Set Class
Autodesk.Revit.Collections Namespace


Clear Method

[image]

Revit 2010 API
Set..::.Clear Method
Set Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

Set Class
Autodesk.Revit.Collections Namespace


Contains Method

[image]

Revit 2010 API
Set..::.Contains Method
Set Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::.Object
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

Set Class
Autodesk.Revit.Collections Namespace


Erase Method

[image]

Revit 2010 API
Set..::.Erase Method
Set Class See Also Send Feedback
Removes a specified object from the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    Object item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Erase(
    Object^ item
)

Parameters

item
Type: System..::.Object
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

Set Class
Autodesk.Revit.Collections Namespace


ForwardIterator Method

[image]

Revit 2010 API
Set..::.ForwardIterator Method
Set Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual SetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SetIterator
Visual C++
public:
virtual SetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

Set Class
Autodesk.Revit.Collections Namespace


GetEnumerator Method

[image]

Revit 2010 API
Set..::.GetEnumerator Method
Set Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

Set Class
Autodesk.Revit.Collections Namespace


Insert Method

[image]

Revit 2010 API
Set..::.Insert Method
Set Class See Also Send Feedback
Insert the specified item into the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    Object item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Object^ item
)

Parameters

item
Type: System..::.Object
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

Set Class
Autodesk.Revit.Collections Namespace


ReverseIterator Method

[image]

Revit 2010 API
Set..::.ReverseIterator Method
Set Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual SetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SetIterator
Visual C++
public:
virtual SetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

Set Class
Autodesk.Revit.Collections Namespace


Set Properties

[image] [image]

Revit 2010 API
Set Properties
Set Class See Also Send Feedback

The Set type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

Set Class
Autodesk.Revit.Collections Namespace


IsEmpty Property

[image]

Revit 2010 API
Set..::.IsEmpty Property
Set Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

Set Class
Autodesk.Revit.Collections Namespace


Size Property

[image]

Revit 2010 API
Set..::.Size Property
Set Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

Set Class
Autodesk.Revit.Collections Namespace


SetIterator Class

[image]

Revit 2010 API
SetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class SetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class SetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Collections..::.SetIterator

See Also

SetIterator Members
Autodesk.Revit.Collections Namespace


SetIterator Members

[image] [image]

Revit 2010 API
SetIterator Members
SetIterator Class Constructors Methods Properties See Also Send Feedback

The SetIterator type exposes the following members.

Constructors

Name | Description
SetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SetIterator Class
Autodesk.Revit.Collections Namespace


SetIterator Constructor

[image]

Revit 2010 API
SetIterator Constructor
SetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SetIterator Class
Autodesk.Revit.Collections Namespace


SetIterator Methods

[image] [image]

Revit 2010 API
SetIterator Methods
SetIterator Class See Also Send Feedback

The SetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetIterator Class
Autodesk.Revit.Collections Namespace


MoveNext Method

[image]

Revit 2010 API
SetIterator..::.MoveNext Method
SetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SetIterator Class
Autodesk.Revit.Collections Namespace


Reset Method

[image]

Revit 2010 API
SetIterator..::.Reset Method
SetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SetIterator Class
Autodesk.Revit.Collections Namespace


SetIterator Properties

[image] [image]

Revit 2010 API
SetIterator Properties
SetIterator Class See Also Send Feedback

The SetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SetIterator Class
Autodesk.Revit.Collections Namespace


Current Property

[image]

Revit 2010 API
SetIterator..::.Current Property
SetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SetIterator Class
Autodesk.Revit.Collections Namespace


StringStringMap Class

[image]

Revit 2010 API
StringStringMap Class
Members See Also Send Feedback
A map that can contain a mapping of a string to another string.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class StringStringMap : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class StringStringMap _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class StringStringMap : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Collections..::.StringStringMap

See Also

StringStringMap Members
Autodesk.Revit.Collections Namespace


StringStringMap Members

[image] [image]

Revit 2010 API
StringStringMap Members
StringStringMap Class Constructors Methods Properties See Also Send Feedback

The StringStringMap type exposes the following members.

Constructors

Name | Description
StringStringMap | Initializes a new instance of the StringStringMap class

Methods

Name | Description
Clear | Removes every string from the map, rendering it empty.
Contains | Tests for the existence of a string key within the map.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes an item with the specified string key from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item with the specified key into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a string item at a specified string key within the map.
Size | Returns the number of strings that are in the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


StringStringMap Constructor

[image]

Revit 2010 API
StringStringMap Constructor
StringStringMap Class See Also Send Feedback
Initializes a new instance of the StringStringMap class

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public StringStringMap()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StringStringMap()

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


StringStringMap Methods

[image] [image]

Revit 2010 API
StringStringMap Methods
StringStringMap Class See Also Send Feedback

The StringStringMap type exposes the following members.

Methods

Name | Description
Clear | Removes every string from the map, rendering it empty.
Contains | Tests for the existence of a string key within the map.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes an item with the specified string key from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item with the specified key into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Clear Method

[image]

Revit 2010 API
StringStringMap..::.Clear Method
StringStringMap Class See Also Send Feedback
Removes every string from the map, rendering it empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Contains Method

[image]

Revit 2010 API
StringStringMap..::.Contains Method
StringStringMap Class See Also Send Feedback
Tests for the existence of a string key within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    string key
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
)

Parameters

key
Type: System..::.String
The key to be searched for.

Return Value

The Contains method returns True if the string key is within the map, otherwise False.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Erase Method

[image]

Revit 2010 API
StringStringMap..::.Erase Method
StringStringMap Class See Also Send Feedback
Removes an item with the specified string key from the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    string key
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    key As String _
) As Integer
Visual C++
public:
virtual int Erase(
    String^ key
)

Parameters

key
Type: System..::.String
The string key of the item to be erased.

Return Value

The number of items that were erased from the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


ForwardIterator Method

[image]

Revit 2010 API
StringStringMap..::.ForwardIterator Method
StringStringMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual StringStringMapIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As StringStringMapIterator
Visual C++
public:
virtual StringStringMapIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


GetEnumerator Method

[image]

Revit 2010 API
StringStringMap..::.GetEnumerator Method
StringStringMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the map.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Insert Method

[image]

Revit 2010 API
StringStringMap..::.Insert Method
StringStringMap Class See Also Send Feedback
Insert the specified item with the specified key into the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    string key,
    string item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As String, _
    item As String _
) As Boolean
Visual C++
public:
virtual bool Insert(
    String^ key,
    String^ item
)

Parameters

key
Type: System..::.String
The key to be used for inserting the item into the map.
item
Type: System..::.String
The item to be inserted into the map.

Return Value

Returns whether the item was inserted into the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


ReverseIterator Method

[image]

Revit 2010 API
StringStringMap..::.ReverseIterator Method
StringStringMap Class See Also Send Feedback
Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual StringStringMapIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As StringStringMapIterator
Visual C++
public:
virtual StringStringMapIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


StringStringMap Properties

[image] [image]

Revit 2010 API
StringStringMap Properties
StringStringMap Class See Also Send Feedback

The StringStringMap type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a string item at a specified string key within the map.
Size | Returns the number of strings that are in the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


IsEmpty Property

[image]

Revit 2010 API
StringStringMap..::.IsEmpty Property
StringStringMap Class See Also Send Feedback
Test to see if the map is empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the map is empty then True will be returned, otherwise False.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Item Property

[image]

Revit 2010 API
StringStringMap..::.Item Property
StringStringMap Class See Also Send Feedback
Gets or sets a string item at a specified string key within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual string Item[
    string key
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    key As String _
) As String
Visual C++
public:
virtual property String^ Item[String^ key] {
    String^ get (String^ key);
    void set (String^ key, String^ value);
}

Parameters

key
Type: System..::.String
The string key of the string item to be set or retrieved.

Return Value

Returns the string item at the specified string key.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Size Property

[image]

Revit 2010 API
StringStringMap..::.Size Property
StringStringMap Class See Also Send Feedback
Returns the number of strings that are in the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


StringStringMapIterator Class

[image]

Revit 2010 API
StringStringMapIterator Class
Members See Also Send Feedback
An iterator to a string to string map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class StringStringMapIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class StringStringMapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class StringStringMapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Collections..::.StringStringMapIterator

See Also

StringStringMapIterator Members
Autodesk.Revit.Collections Namespace


StringStringMapIterator Members

[image] [image]

Revit 2010 API
StringStringMapIterator Members
StringStringMapIterator Class Constructors Methods Properties See Also Send Feedback

The StringStringMapIterator type exposes the following members.

Constructors

Name | Description
StringStringMapIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the string item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Key | Retrieves the string key that is the current focus of the iterator.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


StringStringMapIterator Constructor

[image]

Revit 2010 API
StringStringMapIterator Constructor
StringStringMapIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public StringStringMapIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StringStringMapIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


StringStringMapIterator Methods

[image] [image]

Revit 2010 API
StringStringMapIterator Methods
StringStringMapIterator Class See Also Send Feedback

The StringStringMapIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


MoveNext Method

[image]

Revit 2010 API
StringStringMapIterator..::.MoveNext Method
StringStringMapIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


Reset Method

[image]

Revit 2010 API
StringStringMapIterator..::.Reset Method
StringStringMapIterator Class See Also Send Feedback
Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


StringStringMapIterator Properties

[image] [image]

Revit 2010 API
StringStringMapIterator Properties
StringStringMapIterator Class See Also Send Feedback

The StringStringMapIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the string item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Key | Retrieves the string key that is the current focus of the iterator.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


Current Property

[image]

Revit 2010 API
StringStringMapIterator..::.Current Property
StringStringMapIterator Class See Also Send Feedback
Retrieves the string item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


Key Property

[image]

Revit 2010 API
StringStringMapIterator..::.Key Property
StringStringMapIterator Class See Also Send Feedback
Retrieves the string key that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual string Key { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Key As String
Visual C++
public:
virtual property String^ Key {
    String^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


Autodesk.Revit.Creation Namespace

[image]

Revit 2010 API
Autodesk.Revit.Creation Namespace
Send Feedback

Classes

Class | Description
Application | The Application Creation object is used to create new instances of utility objects.
AreaCreationData | A class which wraps the arguments of Area for batch creation
Document | The Document Creation object is used to create new instances of elements within the Autodesk Revit project.
FamilyInstanceCreationData | A class which wraps the arguments of FamilyInstance for batch creation.
FamilyItemFactory | The Family Item Factory object is used to create new instances of elements within the Autodesk Revit Family.
Filter | The Filter creation object is used to create new instances of element filter utility objects.
ItemFactoryBase | The ItemFactoryBase object is used to create new instances of elements within the Autodesk Revit document.
ProfiledWallCreationData | A class which wraps the arguments of Wall for batch creation
RectangularWallCreationData | A class which wraps the arguments of Wall for batch creation
RoomCreationData | A class which wraps the arguments of Room for batch creation.
TextNoteCreationData | A class which wraps the arguments of TextNote for batch creation

Enumerations

Enumeration | Description
Document..::.eRefFace | Indicates the reference face. The Opening will be created at the direction perpendicular to the reference face.


Application Class

[image]

Revit 2010 API
Application Class
Members See Also Send Feedback
The Application Creation object is used to create new instances of utility objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Application : APIObject
Visual Basic (Declaration)
Public Class Application _
    Inherits APIObject
Visual C++
public ref class Application : public APIObject

Remarks

General purpose objects can be generated by this creation object. Creating objects via this object ensures that they will be correctly constructed and will reside in the Autodesk Revit memory space.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Creation..::.Application

See Also

Application Members
Autodesk.Revit.Creation Namespace


Application Members

[image] [image]

Revit 2010 API
Application Members
Application Class Constructors Methods Properties See Also Send Feedback

The Application type exposes the following members.

Constructors

Name | Description
Application | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewArc | Overloaded. Creates a new geometric arc object.
NewAreaCreationData | Creates an object which wraps the arguments of Area for batch creation.
NewArray | Creates a new instance of a generic Array.
NewBoundingBoxUV | Overloaded. Creates a two-dimensional rectangle.
NewBoundingBoxXYZ | Creates a three-dimensional rectangular box.
NewBuildingSiteExportOptions | Creates Building Site Export options.
NewCategorySet | Creates a new instance of a set specifically for holding category objects.
NewColor | Returns a new color object.
NewCombinableElementArray | Returns an array that can hold combinable element objects.
NewCurveArrArray | Creates an empty array that can store geometric curve loops.
NewCurveArray | Creates an empty array that can store geometric curves.
NewCurveLoopsProfile | Creates a new CurveLoopsProfile object.
NewDGNExportOptions | Creates DGN Export options.
NewDoubleArray | Creates a new instance of a double array.
NewDWF2DExportOptions | Creates DWF2D Export options.
NewDWF3DExportOptions | Creates DWF3D Export options.
NewDWFX2DExportOptions | Creates DWFX2D Export options.
NewDWFX3DExportOptions | Creates DWFX3D Export options.
NewDWGExportOptions | Creates DWG Export options.
NewDWGImportOptions | Creates DWG Import options.
NewElementArray | Returns an array that can hold element objects.
NewElementId | Creates a new ElementId object.
NewElementIdSet | Creates a new instance of a set specifically for holding element ids.
NewElementSet | Creates a new instance of a set specifically for holding elements.
NewEllipse | Creates a new geometric ellipse object.
NewFaceArray | Creates a new instance of a face array.
NewFamilyInstanceCreationData | Overloaded. Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
NewFamilySymbolProfile | Creates a new FamilySymbolProfile object.
NewFBXExportOptions | Creates 3D-Studio Max (FBX) Export options.
NewFillPatternSet | Returns a set that can hold fill pattern objects.
NewGBXMLExportOptions | Creates Green-Building XML Export options.
NewGBXMLImportOptions | Creates Green-Building XML Import options.
NewGeometryOptions | Creates an object to specify user preferences in parsing of geometry.
NewHermiteSpline | Creates a new geometric Hermite spline object.
NewImageImportOptions | Creates Image Import options.
NewInstanceBinding | Overloaded. Creates a new instance binding object.
NewIntersectionResultArray | Creates a new instance of an IntersectionResult array.
NewInventorImportOptions | Creates Inventor Import options.
NewLine | Creates a new bound or unbounded geometric line object.
NewLineBound | Creates a new bounded geometric line object.
NewLinePatternSet | Returns a set that can hold line pattern objects.
NewLineUnbound | Creates a new unbounded geometric line object.
NewLoadCaseArray | Creates a new instance of a LoadCase array.
NewLoadCombinationArray | Creates a new instance of a LoadCombination array.
NewLoadUsageArray | Creates a new instance of a LoadUsage array.
NewMap | Creates a new instance of a generic Map.
NewMaterialSet | Create a new instance of MaterialSet.
NewNurbSpline | Creates a new geometric nurbSpline object.
NewParameterListItemArray | Returns an array that can hold list items of external list parameter.
NewPlane | Overloaded. Creates a new geometric plane object.
NewPoint | Creates a new geometric point object.
NewPointOnEdge | Create a PointOnEdge object which is used to define the placement of a ReferencePoint.
NewPointOnEdgeEdgeIntersection | Construct a PointOnEdgeEdgeIntersection object which is used to define the placement of a ReferencePoint given two references to edge.
NewPointOnEdgeFaceIntersection | Construct a PointOnEdgeFaceIntersection object which is used to define the placement of a ReferencePoint given a references to edge and a reference to face.
NewPointOnFace | Construct a PointOnFace object which is used to define the placement of a ReferencePoint given a reference and a location on the face.
NewPointOnPlane | Construct a PointOnPlane object which is used to define the placement of a ReferencePoint from its property values.
NewPostedErrorArray | Creates an array to store instances of PostedError.
NewProfiledWallCreationData | Overloaded. Creates an object which wraps the arguments of NewWall() for batch creation.
NewProjectPosition | Creates a new project position object.
NewRectangularWallCreationData | Overloaded. Creates an object which wraps the arguments of NewWall() for batch creation.
NewReferenceArray | Creates a new instance of a reference array.
NewRoomCreationData | Creates an object which wraps the arguments of NewRoom() for batch creation.
NewSelElementSet | Creates a new instance of a set specifically for holding selected elements.
NewSet | Creates a new instance of a generic Set.
NewSpaceSet | Creates a new instance of a space set.
NewStringStringMap | Creates a new map that maps one string to another string.
NewSuspendUpdating | Creates a new instance of the SuspendUpdating object and begin suspension of consistency updates.
NewTextNoteCreationData | Overloaded. Creates an object which wraps the arguments of NewTextNote() for batch creation.
NewTypeBinding | Overloaded. Creates a new type binding object.
NewUV | Overloaded. Creates a UV object representing coordinates in 2-space.
NewVertexIndexPair | Creates a new VertexIndexPair object.
NewVertexIndexPairArray | Returns an array that can hold VertexIndexPair objects.
NewViewSet | Creates a new instance of a View set.
NewVolumeCalculationOptions | Creates options related to room volume and area computations.
NewXYZ | Overloaded. Creates a XYZ object representing coordinates in 3-space.
NewXYZArray | Generate an empty array that can hold XYZ point objects.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Filter | Gives access to an object for creating different types of filters.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Application Class
Autodesk.Revit.Creation Namespace


Application Constructor

[image]

Revit 2010 API
Application Constructor
Application Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Application()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Application()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Application Class
Autodesk.Revit.Creation Namespace


Application Methods

[image] [image]

Revit 2010 API
Application Methods
Application Class See Also Send Feedback

The Application type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewArc | Overloaded. Creates a new geometric arc object.
NewAreaCreationData | Creates an object which wraps the arguments of Area for batch creation.
NewArray | Creates a new instance of a generic Array.
NewBoundingBoxUV | Overloaded. Creates a two-dimensional rectangle.
NewBoundingBoxXYZ | Creates a three-dimensional rectangular box.
NewBuildingSiteExportOptions | Creates Building Site Export options.
NewCategorySet | Creates a new instance of a set specifically for holding category objects.
NewColor | Returns a new color object.
NewCombinableElementArray | Returns an array that can hold combinable element objects.
NewCurveArrArray | Creates an empty array that can store geometric curve loops.
NewCurveArray | Creates an empty array that can store geometric curves.
NewCurveLoopsProfile | Creates a new CurveLoopsProfile object.
NewDGNExportOptions | Creates DGN Export options.
NewDoubleArray | Creates a new instance of a double array.
NewDWF2DExportOptions | Creates DWF2D Export options.
NewDWF3DExportOptions | Creates DWF3D Export options.
NewDWFX2DExportOptions | Creates DWFX2D Export options.
NewDWFX3DExportOptions | Creates DWFX3D Export options.
NewDWGExportOptions | Creates DWG Export options.
NewDWGImportOptions | Creates DWG Import options.
NewElementArray | Returns an array that can hold element objects.
NewElementId | Creates a new ElementId object.
NewElementIdSet | Creates a new instance of a set specifically for holding element ids.
NewElementSet | Creates a new instance of a set specifically for holding elements.
NewEllipse | Creates a new geometric ellipse object.
NewFaceArray | Creates a new instance of a face array.
NewFamilyInstanceCreationData | Overloaded. Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
NewFamilySymbolProfile | Creates a new FamilySymbolProfile object.
NewFBXExportOptions | Creates 3D-Studio Max (FBX) Export options.
NewFillPatternSet | Returns a set that can hold fill pattern objects.
NewGBXMLExportOptions | Creates Green-Building XML Export options.
NewGBXMLImportOptions | Creates Green-Building XML Import options.
NewGeometryOptions | Creates an object to specify user preferences in parsing of geometry.
NewHermiteSpline | Creates a new geometric Hermite spline object.
NewImageImportOptions | Creates Image Import options.
NewInstanceBinding | Overloaded. Creates a new instance binding object.
NewIntersectionResultArray | Creates a new instance of an IntersectionResult array.
NewInventorImportOptions | Creates Inventor Import options.
NewLine | Creates a new bound or unbounded geometric line object.
NewLineBound | Creates a new bounded geometric line object.
NewLinePatternSet | Returns a set that can hold line pattern objects.
NewLineUnbound | Creates a new unbounded geometric line object.
NewLoadCaseArray | Creates a new instance of a LoadCase array.
NewLoadCombinationArray | Creates a new instance of a LoadCombination array.
NewLoadUsageArray | Creates a new instance of a LoadUsage array.
NewMap | Creates a new instance of a generic Map.
NewMaterialSet | Create a new instance of MaterialSet.
NewNurbSpline | Creates a new geometric nurbSpline object.
NewParameterListItemArray | Returns an array that can hold list items of external list parameter.
NewPlane | Overloaded. Creates a new geometric plane object.
NewPoint | Creates a new geometric point object.
NewPointOnEdge | Create a PointOnEdge object which is used to define the placement of a ReferencePoint.
NewPointOnEdgeEdgeIntersection | Construct a PointOnEdgeEdgeIntersection object which is used to define the placement of a ReferencePoint given two references to edge.
NewPointOnEdgeFaceIntersection | Construct a PointOnEdgeFaceIntersection object which is used to define the placement of a ReferencePoint given a references to edge and a reference to face.
NewPointOnFace | Construct a PointOnFace object which is used to define the placement of a ReferencePoint given a reference and a location on the face.
NewPointOnPlane | Construct a PointOnPlane object which is used to define the placement of a ReferencePoint from its property values.
NewPostedErrorArray | Creates an array to store instances of PostedError.
NewProfiledWallCreationData | Overloaded. Creates an object which wraps the arguments of NewWall() for batch creation.
NewProjectPosition | Creates a new project position object.
NewRectangularWallCreationData | Overloaded. Creates an object which wraps the arguments of NewWall() for batch creation.
NewReferenceArray | Creates a new instance of a reference array.
NewRoomCreationData | Creates an object which wraps the arguments of NewRoom() for batch creation.
NewSelElementSet | Creates a new instance of a set specifically for holding selected elements.
NewSet | Creates a new instance of a generic Set.
NewSpaceSet | Creates a new instance of a space set.
NewStringStringMap | Creates a new map that maps one string to another string.
NewSuspendUpdating | Creates a new instance of the SuspendUpdating object and begin suspension of consistency updates.
NewTextNoteCreationData | Overloaded. Creates an object which wraps the arguments of NewTextNote() for batch creation.
NewTypeBinding | Overloaded. Creates a new type binding object.
NewUV | Overloaded. Creates a UV object representing coordinates in 2-space.
NewVertexIndexPair | Creates a new VertexIndexPair object.
NewVertexIndexPairArray | Returns an array that can hold VertexIndexPair objects.
NewViewSet | Creates a new instance of a View set.
NewVolumeCalculationOptions | Creates options related to room volume and area computations.
NewXYZ | Overloaded. Creates a XYZ object representing coordinates in 3-space.
NewXYZArray | Generate an empty array that can hold XYZ point objects.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewArc Method

[image] [image]

Revit 2010 API
Application..::.NewArc Method
Application Class See Also Send Feedback
Creates a new geometric arc object.

Overload List

Name | Description
NewArc(XYZ, XYZ, XYZ) | Creates a new geometric arc object based on three points.
NewArc(Plane, Double, Double, Double) | Creates a new geometric arc object based on plane, radius, and angles.
NewArc(XYZ, Double, Double, Double, XYZ, XYZ) | Creates a new geometric arc object based on center, radius, unit vectors, and angles.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewArc Method (XYZ, XYZ, XYZ)

[image]

Revit 2010 API
Application..::.NewArc Method (XYZ, XYZ, XYZ)
Application Class Example See Also Send Feedback
Creates a new geometric arc object based on three points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Arc NewArc(
    XYZ end0,
    XYZ end1,
    XYZ pointOnCurve
)
Visual Basic (Declaration)
Public Function NewArc ( _
    end0 As XYZ, _
    end1 As XYZ, _
    pointOnCurve As XYZ _
) As Arc
Visual C++
public:
Arc^ NewArc(
    XYZ^ end0,
    XYZ^ end1,
    XYZ^ pointOnCurve
)

Parameters

end0
Type: Autodesk.Revit.Geometry..::.XYZ
The start point of the arc.
end1
Type: Autodesk.Revit.Geometry..::.XYZ
The end point of the arc.
pointOnCurve
Type: Autodesk.Revit.Geometry..::.XYZ
A point on the arc.

Remarks

Examples

CopyC#
// Create a new arc using two ends and a point on the curve
XYZ end0 = new XYZ(1, 0, 0);    // start point of the arc
XYZ end1 = new XYZ(10, 10, 10); // end point of the arc
XYZ pointOnCurve = new XYZ(10, 0, 0);   // point along arc

Arc arc = application.Create.NewArc(end0, end1, pointOnCurve);
CopyVB.NET
' Create a new arc using two ends and a point on the curve
Dim end0 As New Autodesk.Revit.Geometry.XYZ(1, 0, 0)
' start point of the arc
Dim end1 As New Autodesk.Revit.Geometry.XYZ(10, 10, 10)
' end point of the arc
Dim pointOnCurve As New Autodesk.Revit.Geometry.XYZ(10, 0, 0)
' point along arc
Dim arc As Arc = application.Create.NewArc(end0, end1, pointOnCurve)

See Also

Application Class
NewArc Overload
Autodesk.Revit.Creation Namespace


NewArc Method (Plane, Double, Double, Double)

[image]

Revit 2010 API
Application..::.NewArc Method (Plane, Double, Double, Double)
Application Class Example See Also Send Feedback
Creates a new geometric arc object based on plane, radius, and angles.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Arc NewArc(
    Plane plane,
    double radius,
    double startAngle,
    double endAngle
)
Visual Basic (Declaration)
Public Function NewArc ( _
    plane As Plane, _
    radius As Double, _
    startAngle As Double, _
    endAngle As Double _
) As Arc
Visual C++
public:
Arc^ NewArc(
    Plane^ plane,
    double radius,
    double startAngle,
    double endAngle
)

Parameters

plane
Type: Autodesk.Revit.Geometry..::.Plane
The plane which the arc resides in. The plane's origin is the center of the arc.
radius
Type: System..::.Double
startAngle
Type: System..::.Double
The start angle of the arc (in radians).
endAngle
Type: System..::.Double
The end angle of the arc (in radians).

Remarks

Examples

CopyC#
Arc CreateArcByGivingPlane(Autodesk.Revit.Application application, Plane plane)
{
    // Create an arc which is placed on the plane and whose center is the plane's origin
    double radius = 10;
    double startAngle = 0;      // The unit is radian
    double endAngle = 2 * Math.PI;        // this arc will be a circle
    return application.Create.NewArc(plane, radius, startAngle, endAngle);
}
CopyVB.NET
Private Function CreateArcByGivingPlane(ByVal application As Autodesk.Revit.Application, ByVal plane As Autodesk.Revit.Geometry.Plane) As Arc
    ' Create an arc which is placed on the plane and whose center is the plane's origin
    Dim radius As Double = 10
    Dim startAngle As Double = 0
    ' The unit is radian
    Dim endAngle As Double = 2 * Math.PI
    ' this arc will be a circle
    Return application.Create.NewArc(plane, radius, startAngle, endAngle)
End Function

See Also

Application Class
NewArc Overload
Autodesk.Revit.Creation Namespace


NewArc Method (XYZ, Double, Double, Double, XYZ, XYZ)

[image]

Revit 2010 API
Application..::.NewArc Method (XYZ, Double, Double, Double, XYZ, XYZ)
Application Class Example See Also Send Feedback
Creates a new geometric arc object based on center, radius, unit vectors, and angles.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Arc NewArc(
    XYZ center,
    double radius,
    double startAngle,
    double endAngle,
    XYZ xAxis,
    XYZ yAxis
)
Visual Basic (Declaration)
Public Function NewArc ( _
    center As XYZ, _
    radius As Double, _
    startAngle As Double, _
    endAngle As Double, _
    xAxis As XYZ, _
    yAxis As XYZ _
) As Arc
Visual C++
public:
Arc^ NewArc(
    XYZ^ center,
    double radius,
    double startAngle,
    double endAngle,
    XYZ^ xAxis,
    XYZ^ yAxis
)

Parameters

center
Type: Autodesk.Revit.Geometry..::.XYZ
The center of the arc.
radius
Type: System..::.Double
The radius of the arc.
startAngle
Type: System..::.Double
The start angle of the arc (in radians).
endAngle
Type: System..::.Double
The end angle of the arc (in radians).
xAxis
Type: Autodesk.Revit.Geometry..::.XYZ
The x axis to define the arc plane. Must be normalized.
yAxis
Type: Autodesk.Revit.Geometry..::.XYZ
The y axis to define the arc plane. Must be normalized.

Remarks

Examples

CopyC#
// Create a new arc defined by its center, radios, angles and 2 axes
double radius = 10;
double startAngle = 0;      // In radian
double endAngle = Math.PI;        // In radian
XYZ center = new XYZ(5, 0, 0);
XYZ xAxis = new XYZ(1, 0, 0);   // The x axis to define the arc plane. Must be normalized
XYZ yAxis = new XYZ(0, 1, 0);   // The y axis to define the arc plane. Must be normalized

Arc arc = application.Create.NewArc(center, radius, startAngle, endAngle, xAxis, yAxis);
CopyVB.NET
' Create a new arc defined by its center, radios, angles and 2 axes
Dim radius As Double = 10
Dim startAngle As Double = 0
' In radian
Dim endAngle As Double = Math.PI
' In radian
Dim center As New Autodesk.Revit.Geometry.XYZ(5, 0, 0)
Dim xAxis As New Autodesk.Revit.Geometry.XYZ(1, 0, 0)
' The x axis to define the arc plane. Must be normalized
Dim yAxis As New Autodesk.Revit.Geometry.XYZ(0, 1, 0)
' The y axis to define the arc plane. Must be normalized
Dim arc As Arc = application.Create.NewArc(center, radius, startAngle, endAngle, xAxis, yAxis)

See Also

Application Class
NewArc Overload
Autodesk.Revit.Creation Namespace


NewAreaCreationData Method

[image]

Revit 2010 API
Application..::.NewAreaCreationData Method
Application Class See Also Send Feedback
Creates an object which wraps the arguments of Area for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaCreationData NewAreaCreationData(
    ViewPlan areaView,
    UV point
)
Visual Basic (Declaration)
Public Function NewAreaCreationData ( _
    areaView As ViewPlan, _
    point As UV _
) As AreaCreationData
Visual C++
public:
AreaCreationData^ NewAreaCreationData(
    ViewPlan^ areaView,
    UV^ point
)

Parameters

areaView
Type: Autodesk.Revit.Elements..::.ViewPlan
The view of area element.
point
Type: Autodesk.Revit.Geometry..::.UV
A point which lies in an enclosed region of area boundary where the new area will reside.

Return Value

The object containing the data needed for area creation.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewArray Method

[image]

Revit 2010 API
Application..::.NewArray Method
Application Class See Also Send Feedback
Creates a new instance of a generic Array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Array NewArray()
Visual Basic (Declaration)
Public Function NewArray As Array
Visual C++
public:
Array^ NewArray()

Return Value

Returns a new instance of a generic Array.

Remarks

Generic arrays can hold any type of object.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewBoundingBoxUV Method

[image] [image]

Revit 2010 API
Application..::.NewBoundingBoxUV Method
Application Class See Also Send Feedback
Creates a two-dimensional rectangle.

Overload List

Name | Description
NewBoundingBoxUV()()() | Creates an empty two-dimensional rectangle.
NewBoundingBoxUV(Double, Double, Double, Double) | Creates a two-dimensional rectangle with supplied values.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewBoundingBoxUV Method

[image]

Revit 2010 API
Application..::.NewBoundingBoxUV Method
Application Class See Also Send Feedback
Creates an empty two-dimensional rectangle.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundingBoxUV NewBoundingBoxUV()
Visual Basic (Declaration)
Public Function NewBoundingBoxUV As BoundingBoxUV
Visual C++
public:
BoundingBoxUV^ NewBoundingBoxUV()

See Also

Application Class
NewBoundingBoxUV Overload
Autodesk.Revit.Creation Namespace


NewBoundingBoxUV Method (Double, Double, Double, Double)

[image]

Revit 2010 API
Application..::.NewBoundingBoxUV Method (Double, Double, Double, Double)
Application Class See Also Send Feedback
Creates a two-dimensional rectangle with supplied values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundingBoxUV NewBoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)
Visual Basic (Declaration)
Public Function NewBoundingBoxUV ( _
    min_u As Double, _
    min_v As Double, _
    max_u As Double, _
    max_v As Double _
) As BoundingBoxUV
Visual C++
public:
BoundingBoxUV^ NewBoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)

Parameters

min_u
Type: System..::.Double
The first coordinate of min.
min_v
Type: System..::.Double
The second coordinate of min.
max_u
Type: System..::.Double
The first coordinate of max.
max_v
Type: System..::.Double
The second coordinate of max.

See Also

Application Class
NewBoundingBoxUV Overload
Autodesk.Revit.Creation Namespace


NewBoundingBoxXYZ Method

[image]

Revit 2010 API
Application..::.NewBoundingBoxXYZ Method
Application Class See Also Send Feedback
Creates a three-dimensional rectangular box.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundingBoxXYZ NewBoundingBoxXYZ()
Visual Basic (Declaration)
Public Function NewBoundingBoxXYZ As BoundingBoxXYZ
Visual C++
public:
BoundingBoxXYZ^ NewBoundingBoxXYZ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewBuildingSiteExportOptions Method

[image]

Revit 2010 API
Application..::.NewBuildingSiteExportOptions Method
Application Class See Also Send Feedback
Creates Building Site Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BuildingSiteExportOptions NewBuildingSiteExportOptions()
Visual Basic (Declaration)
Public Function NewBuildingSiteExportOptions As BuildingSiteExportOptions
Visual C++
public:
BuildingSiteExportOptions^ NewBuildingSiteExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewCategorySet Method

[image]

Revit 2010 API
Application..::.NewCategorySet Method
Application Class See Also Send Feedback
Creates a new instance of a set specifically for holding category objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CategorySet NewCategorySet()
Visual Basic (Declaration)
Public Function NewCategorySet As CategorySet
Visual C++
public:
CategorySet^ NewCategorySet()

Return Value

Returns a new instance of a Category Set.

Remarks

This type of set is used during the creation of instance and type bindings.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewColor Method

[image]

Revit 2010 API
Application..::.NewColor Method
Application Class Example See Also Send Feedback
Returns a new color object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Color NewColor()
Visual Basic (Declaration)
Public Function NewColor As Color
Visual C++
public:
Color^ NewColor()

Return Value

The new color oject.

Examples

CopyC#
Color NewColorInfo(Autodesk.Revit.Creation.Application appCreation)
{
    // Create a new color
    Autodesk.Revit.Color color = appCreation.NewColor();

    // Set its RGB values
    color.Red = (byte)127;
    color.Green = (byte)64;
    color.Blue = (byte)32;

    // Display the color info
    StringBuilder info = new StringBuilder();
    info.AppendLine("Red:\t" + color.Red.ToString());
    info.AppendLine("Green:\t" + color.Green.ToString());
    info.AppendLine("Blue:\t" + color.Blue.ToString());

    MessageBox.Show(info.ToString(), "Color information");

    return color;
}
CopyVB.NET
Private Function NewColorInfo(ByVal appCreation As Autodesk.Revit.Creation.Application) As Color
    ' Create a new color
    Dim color As Autodesk.Revit.Color = appCreation.NewColor()

    ' Set its RGB values
    color.Red = CByte(127)
    color.Green = CByte(64)
    color.Blue = CByte(32)

    ' Display the color info
    Dim info As New StringBuilder()
    info.AppendLine("Red:" & vbTab & color.Red.ToString())
    info.AppendLine("Green:" & vbTab & color.Green.ToString())
    info.AppendLine("Blue:" & vbTab & color.Blue.ToString())

    MessageBox.Show(info.ToString(), "Color information")

    Return color
End Function

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewCombinableElementArray Method

[image]

Revit 2010 API
Application..::.NewCombinableElementArray Method
Application Class See Also Send Feedback
Returns an array that can hold combinable element objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CombinableElementArray NewCombinableElementArray()
Visual Basic (Declaration)
Public Function NewCombinableElementArray As CombinableElementArray
Visual C++
public:
CombinableElementArray^ NewCombinableElementArray()

Return Value

An empty array that can contain any CombinableElement derived objects.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewCurveArrArray Method

[image]

Revit 2010 API
Application..::.NewCurveArrArray Method
Application Class See Also Send Feedback
Creates an empty array that can store geometric curve loops.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArrArray NewCurveArrArray()
Visual Basic (Declaration)
Public Function NewCurveArrArray As CurveArrArray
Visual C++
public:
CurveArrArray^ NewCurveArrArray()

Return Value

The empty array of curve loops.

Remarks

Use the return of this method in methods as NewExtrusion and NewSweep to create geometry.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewCurveArray Method

[image]

Revit 2010 API
Application..::.NewCurveArray Method
Application Class See Also Send Feedback
Creates an empty array that can store geometric curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray NewCurveArray()
Visual Basic (Declaration)
Public Function NewCurveArray As CurveArray
Visual C++
public:
CurveArray^ NewCurveArray()

Return Value

Returns an empty array that can hold geometric curves.

Remarks

This method can be used to create an array that can hold any curve type object. This array can be then passed to methods, such as NewAreaLoad, to represent the geometry for the boundary of the load.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewCurveLoopsProfile Method

[image]

Revit 2010 API
Application..::.NewCurveLoopsProfile Method
Application Class See Also Send Feedback
Creates a new CurveLoopsProfile object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveLoopsProfile NewCurveLoopsProfile(
    CurveArrArray curveLoops
)
Visual Basic (Declaration)
Public Function NewCurveLoopsProfile ( _
    curveLoops As CurveArrArray _
) As CurveLoopsProfile
Visual C++
public:
CurveLoopsProfile^ NewCurveLoopsProfile(
    CurveArrArray^ curveLoops
)

Parameters

curveLoops
Type: Autodesk.Revit.Geometry..::.CurveArrArray
The curve loops of the Profile.

Return Value

The new CurveLoopsProfile object.

Remarks

Use the return of this methods as NewSweep and NewSweptBlend to create generic forms.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the argument is Null.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDGNExportOptions Method

[image]

Revit 2010 API
Application..::.NewDGNExportOptions Method
Application Class See Also Send Feedback
Creates DGN Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DGNExportOptions NewDGNExportOptions()
Visual Basic (Declaration)
Public Function NewDGNExportOptions As DGNExportOptions
Visual C++
public:
DGNExportOptions^ NewDGNExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDoubleArray Method

[image]

Revit 2010 API
Application..::.NewDoubleArray Method
Application Class See Also Send Feedback
Creates a new instance of a double array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DoubleArray NewDoubleArray()
Visual Basic (Declaration)
Public Function NewDoubleArray As DoubleArray
Visual C++
public:
DoubleArray^ NewDoubleArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDWF2DExportOptions Method

[image]

Revit 2010 API
Application..::.NewDWF2DExportOptions Method
Application Class See Also Send Feedback
Creates DWF2D Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DWF2DExportOptions NewDWF2DExportOptions()
Visual Basic (Declaration)
Public Function NewDWF2DExportOptions As DWF2DExportOptions
Visual C++
public:
DWF2DExportOptions^ NewDWF2DExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDWF3DExportOptions Method

[image]

Revit 2010 API
Application..::.NewDWF3DExportOptions Method
Application Class See Also Send Feedback
Creates DWF3D Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DWF3DExportOptions NewDWF3DExportOptions()
Visual Basic (Declaration)
Public Function NewDWF3DExportOptions As DWF3DExportOptions
Visual C++
public:
DWF3DExportOptions^ NewDWF3DExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDWFX2DExportOptions Method

[image]

Revit 2010 API
Application..::.NewDWFX2DExportOptions Method
Application Class See Also Send Feedback
Creates DWFX2D Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DWFX2DExportOptions NewDWFX2DExportOptions()
Visual Basic (Declaration)
Public Function NewDWFX2DExportOptions As DWFX2DExportOptions
Visual C++
public:
DWFX2DExportOptions^ NewDWFX2DExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDWFX3DExportOptions Method

[image]

Revit 2010 API
Application..::.NewDWFX3DExportOptions Method
Application Class See Also Send Feedback
Creates DWFX3D Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DWFX3DExportOptions NewDWFX3DExportOptions()
Visual Basic (Declaration)
Public Function NewDWFX3DExportOptions As DWFX3DExportOptions
Visual C++
public:
DWFX3DExportOptions^ NewDWFX3DExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDWGExportOptions Method

[image]

Revit 2010 API
Application..::.NewDWGExportOptions Method
Application Class See Also Send Feedback
Creates DWG Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DWGExportOptions NewDWGExportOptions()
Visual Basic (Declaration)
Public Function NewDWGExportOptions As DWGExportOptions
Visual C++
public:
DWGExportOptions^ NewDWGExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDWGImportOptions Method

[image]

Revit 2010 API
Application..::.NewDWGImportOptions Method
Application Class See Also Send Feedback
Creates DWG Import options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DWGImportOptions NewDWGImportOptions()
Visual Basic (Declaration)
Public Function NewDWGImportOptions As DWGImportOptions
Visual C++
public:
DWGImportOptions^ NewDWGImportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewElementArray Method

[image]

Revit 2010 API
Application..::.NewElementArray Method
Application Class See Also Send Feedback
Returns an array that can hold element objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementArray NewElementArray()
Visual Basic (Declaration)
Public Function NewElementArray As ElementArray
Visual C++
public:
ElementArray^ NewElementArray()

Return Value

An empty array that can contain any Autodesk Revit element derived objects.

Remarks

The array returned by this method can be used as a general purpose tool for holding ordered lists of any type of element.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewElementId Method

[image]

Revit 2010 API
Application..::.NewElementId Method
Application Class See Also Send Feedback
Creates a new ElementId object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementId NewElementId()
Visual Basic (Declaration)
Public Function NewElementId As ElementId
Visual C++
public:
ElementId NewElementId()

Return Value

The new ElementId object.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewElementIdSet Method

[image]

Revit 2010 API
Application..::.NewElementIdSet Method
Application Class See Also Send Feedback
Creates a new instance of a set specifically for holding element ids.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementIdSet NewElementIdSet()
Visual Basic (Declaration)
Public Function NewElementIdSet As ElementIdSet
Visual C++
public:
ElementIdSet^ NewElementIdSet()

Return Value

Returns a new Element Id Set.

Remarks

This is a general purpose set for passing element ids to and from methods.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewElementSet Method

[image]

Revit 2010 API
Application..::.NewElementSet Method
Application Class See Also Send Feedback
Creates a new instance of a set specifically for holding elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewElementSet()
Visual Basic (Declaration)
Public Function NewElementSet As ElementSet
Visual C++
public:
ElementSet^ NewElementSet()

Return Value

Returns a new Element Set.

Remarks

This is a general purpose set for passing elements to and from methods.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewEllipse Method

[image]

Revit 2010 API
Application..::.NewEllipse Method
Application Class See Also Send Feedback
Creates a new geometric ellipse object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Ellipse NewEllipse(
    XYZ center,
    double radX,
    double radY,
    XYZ xVec,
    XYZ yVec,
    double param0,
    double param1
)
Visual Basic (Declaration)
Public Function NewEllipse ( _
    center As XYZ, _
    radX As Double, _
    radY As Double, _
    xVec As XYZ, _
    yVec As XYZ, _
    param0 As Double, _
    param1 As Double _
) As Ellipse
Visual C++
public:
Ellipse^ NewEllipse(
    XYZ^ center,
    double radX,
    double radY,
    XYZ^ xVec,
    XYZ^ yVec,
    double param0,
    double param1
)

Parameters

center
Type: Autodesk.Revit.Geometry..::.XYZ
The center of the ellipse.
radX
Type: System..::.Double
The x vector radius of the ellipse.Shoud be >0.
radY
Type: System..::.Double
The y vector radius of the ellipse.Shoud be >0.
xVec
Type: Autodesk.Revit.Geometry..::.XYZ
The x axis to define the ellipse plane.
yVec
Type: Autodesk.Revit.Geometry..::.XYZ
The y axis to define the ellipse plane.xVec must be orthogonal with yVec.
param0
Type: System..::.Double
The start angle of the ellipse. Must less than Param1,and greater than -2*PI.
param1
Type: System..::.Double
The end angle of the ellipse. Must greater than Param0,and less than 2*PI.

Remarks

The PI represents the value used in Revit internal code, it's accuracy is not the same as MSDN, it's value is 3.14159265358979.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFaceArray Method

[image]

Revit 2010 API
Application..::.NewFaceArray Method
Application Class See Also Send Feedback
Creates a new instance of a face array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FaceArray NewFaceArray()
Visual Basic (Declaration)
Public Function NewFaceArray As FaceArray
Visual C++
public:
FaceArray^ NewFaceArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method

[image] [image]

Revit 2010 API
Application..::.NewFamilyInstanceCreationData Method
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Overload List

Name | Description
NewFamilyInstanceCreationData(Face, Line, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
NewFamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
NewFamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
NewFamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
NewFamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
NewFamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (Face, Line, FamilySymbol)

[image]

Revit 2010 API
Application..::.NewFamilyInstanceCreationData Method (Face, Line, FamilySymbol)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Face face,
    Line position,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    face As Face, _
    position As Line, _
    symbol As FamilySymbol _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    Face^ face,
    Line^ position,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.Geometry..::.Face
A face of a geometry object.
position
Type: Autodesk.Revit.Geometry..::.Line
A line on the face defining where the symbol is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, StructuralType)

[image]

Revit 2010 API
Application..::.NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
Specify if the family instance is structural.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (Curve, FamilySymbol, Level, StructuralType)

[image]

Revit 2010 API
Application..::.NewFamilyInstanceCreationData Method (Curve, FamilySymbol, Level, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    curve As Curve, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
The curve where the instance is based.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.Elements..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (Face, XYZ, XYZ, FamilySymbol)

[image]

Revit 2010 API
Application..::.NewFamilyInstanceCreationData Method (Face, XYZ, XYZ, FamilySymbol)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Face face,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    face As Face, _
    location As XYZ, _
    referenceDirection As XYZ, _
    symbol As FamilySymbol _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    Face^ face,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.Geometry..::.Face
A face of a geometry object.
location
Type: Autodesk.Revit.Geometry..::.XYZ
Point on the face where the instance is to be placed.
referenceDirection
Type: Autodesk.Revit.Geometry..::.XYZ
A vector that defines the direction of the family instance.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Element, StructuralType)

[image]

Revit 2010 API
Application..::.NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Element, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit..::.Element
The object into which the family instance is to be inserted, often known as the host.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Level, StructuralType)

[image]

Revit 2010 API
Application..::.NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Level, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.Elements..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Element, Level, StructuralType)

[image]

Revit 2010 API
Application..::.NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Element, Level, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit..::.Element
The object into which the family instance is to be inserted, often known as the host.
level
Type: Autodesk.Revit.Elements..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)

[image]

Revit 2010 API
Application..::.NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    XYZ referenceDirection,
    Element host,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    referenceDirection As XYZ, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    XYZ^ referenceDirection,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
referenceDirection
Type: Autodesk.Revit.Geometry..::.XYZ
A vector that dictates the direction of certain family instances.
host
Type: Autodesk.Revit..::.Element
The object into which the family instance is to be inserted, often known as the host.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilySymbolProfile Method

[image]

Revit 2010 API
Application..::.NewFamilySymbolProfile Method
Application Class See Also Send Feedback
Creates a new FamilySymbolProfile object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbolProfile NewFamilySymbolProfile(
    FamilySymbol familySymbol
)
Visual Basic (Declaration)
Public Function NewFamilySymbolProfile ( _
    familySymbol As FamilySymbol _
) As FamilySymbolProfile
Visual C++
public:
FamilySymbolProfile^ NewFamilySymbolProfile(
    FamilySymbol^ familySymbol
)

Parameters

familySymbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
The family symbol of the Profile.

Return Value

The new FamilySymbolProfile object.

Remarks

Use the return of this methods as NewSweep and NewSweptBlend to create generic forms.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the argument fmailySymbol is Null.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFBXExportOptions Method

[image]

Revit 2010 API
Application..::.NewFBXExportOptions Method
Application Class See Also Send Feedback
Creates 3D-Studio Max (FBX) Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FBXExportOptions NewFBXExportOptions()
Visual Basic (Declaration)
Public Function NewFBXExportOptions As FBXExportOptions
Visual C++
public:
FBXExportOptions^ NewFBXExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFillPatternSet Method

[image]

Revit 2010 API
Application..::.NewFillPatternSet Method
Application Class See Also Send Feedback
Returns a set that can hold fill pattern objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FillPatternSet NewFillPatternSet()
Visual Basic (Declaration)
Public Function NewFillPatternSet As FillPatternSet
Visual C++
public:
FillPatternSet^ NewFillPatternSet()

Return Value

An empty set that can contain fill pattern objects.

Remarks

The set returned by this method can be used as a container for holding fill patterns.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewGBXMLExportOptions Method

[image]

Revit 2010 API
Application..::.NewGBXMLExportOptions Method
Application Class See Also Send Feedback
Creates Green-Building XML Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GBXMLExportOptions NewGBXMLExportOptions()
Visual Basic (Declaration)
Public Function NewGBXMLExportOptions As GBXMLExportOptions
Visual C++
public:
GBXMLExportOptions^ NewGBXMLExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewGBXMLImportOptions Method

[image]

Revit 2010 API
Application..::.NewGBXMLImportOptions Method
Application Class See Also Send Feedback
Creates Green-Building XML Import options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GBXMLImportOptions NewGBXMLImportOptions()
Visual Basic (Declaration)
Public Function NewGBXMLImportOptions As GBXMLImportOptions
Visual C++
public:
GBXMLImportOptions^ NewGBXMLImportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewGeometryOptions Method

[image]

Revit 2010 API
Application..::.NewGeometryOptions Method
Application Class Example See Also Send Feedback
Creates an object to specify user preferences in parsing of geometry.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Options NewGeometryOptions()
Visual Basic (Declaration)
Public Function NewGeometryOptions As Options
Visual C++
public:
Options^ NewGeometryOptions()

Return Value

Examples

CopyC#
Autodesk.Revit.Geometry.Options geomOption = application.Create.NewGeometryOptions();
if (null != geomOption)
{
    geomOption.ComputeReferences = true;
    geomOption.DetailLevel = Autodesk.Revit.Geometry.Options.DetailLevels.Fine;

    // Either the DetailLevel or the View can be set, but not both
    //geomOption.View = commandData.Application.ActiveDocument.ActiveView;

    MessageBox.Show("Geometry Option created successfully.", "Revit");
}
CopyVB.NET
Dim geomOption As Autodesk.Revit.Geometry.Options = application.Create.NewGeometryOptions()
If geomOption IsNot Nothing Then
    geomOption.ComputeReferences = True
    geomOption.DetailLevel = Autodesk.Revit.Geometry.Options.DetailLevels.Fine

    ' Either the DetailLevel or the View can be set, but not both
    'geomOption.View = commandData.Application.ActiveDocument.ActiveView;

    MessageBox.Show("Geometry Option created successfully.", "Revit")
End If

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewHermiteSpline Method

[image]

Revit 2010 API
Application..::.NewHermiteSpline Method
Application Class See Also Send Feedback
Creates a new geometric Hermite spline object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public HermiteSpline NewHermiteSpline(
    XYZArray ctrlPoints,
    bool bPeriodic
)
Visual Basic (Declaration)
Public Function NewHermiteSpline ( _
    ctrlPoints As XYZArray, _
    bPeriodic As Boolean _
) As HermiteSpline
Visual C++
public:
HermiteSpline^ NewHermiteSpline(
    XYZArray^ ctrlPoints,
    bool bPeriodic
)

Parameters

ctrlPoints
Type: Autodesk.Revit.Geometry..::.XYZArray
The control points of the Hermite spline.
bPeriodic
Type: System..::.Boolean
True if the Hermite spline is to be periodic.

Remarks

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewImageImportOptions Method

[image]

Revit 2010 API
Application..::.NewImageImportOptions Method
Application Class See Also Send Feedback
Creates Image Import options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ImageImportOptions NewImageImportOptions()
Visual Basic (Declaration)
Public Function NewImageImportOptions As ImageImportOptions
Visual C++
public:
ImageImportOptions^ NewImageImportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewInstanceBinding Method

[image] [image]

Revit 2010 API
Application..::.NewInstanceBinding Method
Application Class See Also Send Feedback
Creates a new instance binding object.

Overload List

Name | Description
NewInstanceBinding()()() | Creates a new empty instance binding object.
NewInstanceBinding(CategorySet) | Creates a new instance binding object containing the categories passed as a parameter.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewInstanceBinding Method

[image]

Revit 2010 API
Application..::.NewInstanceBinding Method
Application Class See Also Send Feedback
Creates a new empty instance binding object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InstanceBinding NewInstanceBinding()
Visual Basic (Declaration)
Public Function NewInstanceBinding As InstanceBinding
Visual C++
public:
InstanceBinding^ NewInstanceBinding()

Return Value

Returns a new instance binding object.

Remarks

Instance binding objects are used for attaching shared parameter definitions to all instances of an element within a category. Categories can be added to the instance binding via the Categories property of the InstanceBinding object

See Also

Application Class
NewInstanceBinding Overload
Autodesk.Revit.Creation Namespace


NewInstanceBinding Method (CategorySet)

[image]

Revit 2010 API
Application..::.NewInstanceBinding Method (CategorySet)
Application Class See Also Send Feedback
Creates a new instance binding object containing the categories passed as a parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InstanceBinding NewInstanceBinding(
    CategorySet categorySet
)
Visual Basic (Declaration)
Public Function NewInstanceBinding ( _
    categorySet As CategorySet _
) As InstanceBinding
Visual C++
public:
InstanceBinding^ NewInstanceBinding(
    CategorySet^ categorySet
)

Parameters

categorySet
Type: Autodesk.Revit..::.CategorySet
A set of categories that will be added to the binding.

Return Value

Returns a new instance binding object.

Remarks

Instance binding objects are used for attaching shared parameter definitions to all instances of an element within a category.

See Also

Application Class
NewInstanceBinding Overload
Autodesk.Revit.Creation Namespace


NewIntersectionResultArray Method

[image]

Revit 2010 API
Application..::.NewIntersectionResultArray Method
Application Class See Also Send Feedback
Creates a new instance of an IntersectionResult array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public IntersectionResultArray NewIntersectionResultArray()
Visual Basic (Declaration)
Public Function NewIntersectionResultArray As IntersectionResultArray
Visual C++
public:
IntersectionResultArray^ NewIntersectionResultArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewInventorImportOptions Method

[image]

Revit 2010 API
Application..::.NewInventorImportOptions Method
Application Class See Also Send Feedback
Creates Inventor Import options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InventorImportOptions NewInventorImportOptions()
Visual Basic (Declaration)
Public Function NewInventorImportOptions As InventorImportOptions
Visual C++
public:
InventorImportOptions^ NewInventorImportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLine Method

[image]

Revit 2010 API
Application..::.NewLine Method
Application Class Example See Also Send Feedback
Creates a new bound or unbounded geometric line object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Line NewLine(
    XYZ point,
    XYZ endOrDirection,
    bool bound
)
Visual Basic (Declaration)
Public Function NewLine ( _
    point As XYZ, _
    endOrDirection As XYZ, _
    bound As Boolean _
) As Line
Visual C++
public:
Line^ NewLine(
    XYZ^ point,
    XYZ^ endOrDirection,
    bool bound
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
A start point or a point through which the line will pass.
endOrDirection
Type: Autodesk.Revit.Geometry..::.XYZ
An end point of a vector for the direction of the line.
bound
Type: System..::.Boolean
Set to True if you wish the line to be bound or False is the line is to be infinite.

Return Value

Returns a new bounded or unbounded line object.

Remarks

If the bound parameter is False then the point parameter is considered to be a point on the line and the endOrDirection parameter is considered to be a directional vector. If the bound parameter is True then the point parameter is considered to be the start of the line and the endOrDirection parameter is considered to be the end of the line.

Examples

CopyC#
XYZ startPoint = new XYZ(0, 0, 0);
XYZ endPoint = new XYZ(10, 10, 10);

// Create unbound line
Line line1 = application.Create.NewLine(startPoint, endPoint, false);

// Create bound line
Line line2 = application.Create.NewLine(startPoint, endPoint, true);
CopyVB.NET
Dim startPoint As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
Dim endPoint As New Autodesk.Revit.Geometry.XYZ(10, 10, 10)

' Create unbound line
Dim line1 As Line = application.Create.NewLine(startPoint, endPoint, False)

' Create bound line
Dim line2 As Line = application.Create.NewLine(startPoint, endPoint, True)

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLineBound Method

[image]

Revit 2010 API
Application..::.NewLineBound Method
Application Class Example See Also Send Feedback
Creates a new bounded geometric line object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Line NewLineBound(
    XYZ start,
    XYZ end
)
Visual Basic (Declaration)
Public Function NewLineBound ( _
    start As XYZ, _
    end As XYZ _
) As Line
Visual C++
public:
Line^ NewLineBound(
    XYZ^ start,
    XYZ^ end
)

Parameters

start
Type: Autodesk.Revit.Geometry..::.XYZ
A start point for the line.
end
Type: Autodesk.Revit.Geometry..::.XYZ
An end point for the line.

Return Value

Returns a new bounded line object.

Remarks

The new line is bounded and has the start parameter as the start point and the end parameter as the end point.

Examples

CopyC#
// define start and end for bound line
XYZ startPoint = new XYZ(0, 0, 0);
XYZ endPoint = new XYZ(10, 10, 10);

// create line
Line line = application.Create.NewLineBound(startPoint, endPoint);
CopyVB.NET
' define start and end for bound line
Dim startPoint As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
Dim endPoint As New Autodesk.Revit.Geometry.XYZ(10, 10, 10)

' create line
Dim line As Line = application.Create.NewLineBound(startPoint, endPoint)

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLinePatternSet Method

[image]

Revit 2010 API
Application..::.NewLinePatternSet Method
Application Class See Also Send Feedback
Returns a set that can hold line pattern objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LinePatternSet NewLinePatternSet()
Visual Basic (Declaration)
Public Function NewLinePatternSet As LinePatternSet
Visual C++
public:
LinePatternSet^ NewLinePatternSet()

Return Value

An empty set that can contain line pattern objects.

Remarks

The set returned by this method can be used as a container for holding line patterns.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLineUnbound Method

[image]

Revit 2010 API
Application..::.NewLineUnbound Method
Application Class Example See Also Send Feedback
Creates a new unbounded geometric line object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Line NewLineUnbound(
    XYZ point,
    XYZ direction
)
Visual Basic (Declaration)
Public Function NewLineUnbound ( _
    point As XYZ, _
    direction As XYZ _
) As Line
Visual C++
public:
Line^ NewLineUnbound(
    XYZ^ point,
    XYZ^ direction
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
A point through which the line will pass.
direction
Type: Autodesk.Revit.Geometry..::.XYZ
A vector for the direction of the line.

Return Value

Returns a new unbounded line object.

Remarks

The line returned will be infinite in length and pass through the point provided in the specified direction. This method is useful for generating an axis around which an element can be rotated.

Examples

CopyC#
// define start point and direction for unbound line
XYZ startPoint = new XYZ(0, 0, 0);
XYZ directionPt = new XYZ(10, 10, 10);

// create line
Line line = application.Create.NewLineUnbound(startPoint, directionPt);
CopyVB.NET
' define start point and direction for unbound line
Dim startPoint As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
Dim directionPt As New Autodesk.Revit.Geometry.XYZ(10, 10, 10)

' create line
Dim line As Line = application.Create.NewLineUnbound(startPoint, directionPt)

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLoadCaseArray Method

[image]

Revit 2010 API
Application..::.NewLoadCaseArray Method
Application Class See Also Send Feedback
Creates a new instance of a LoadCase array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadCaseArray NewLoadCaseArray()
Visual Basic (Declaration)
Public Function NewLoadCaseArray As LoadCaseArray
Visual C++
public:
LoadCaseArray^ NewLoadCaseArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLoadCombinationArray Method

[image]

Revit 2010 API
Application..::.NewLoadCombinationArray Method
Application Class See Also Send Feedback
Creates a new instance of a LoadCombination array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadCombinationArray NewLoadCombinationArray()
Visual Basic (Declaration)
Public Function NewLoadCombinationArray As LoadCombinationArray
Visual C++
public:
LoadCombinationArray^ NewLoadCombinationArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLoadUsageArray Method

[image]

Revit 2010 API
Application..::.NewLoadUsageArray Method
Application Class See Also Send Feedback
Creates a new instance of a LoadUsage array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadUsageArray NewLoadUsageArray()
Visual Basic (Declaration)
Public Function NewLoadUsageArray As LoadUsageArray
Visual C++
public:
LoadUsageArray^ NewLoadUsageArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewMap Method

[image]

Revit 2010 API
Application..::.NewMap Method
Application Class See Also Send Feedback
Creates a new instance of a generic Map.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Map NewMap()
Visual Basic (Declaration)
Public Function NewMap As Map
Visual C++
public:
Map^ NewMap()

Return Value

Returns a new instance of a generic Map.

Remarks

Generic maps can link any type of object to any other type of object.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewMaterialSet Method

[image]

Revit 2010 API
Application..::.NewMaterialSet Method
Application Class See Also Send Feedback
Create a new instance of MaterialSet.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialSet NewMaterialSet()
Visual Basic (Declaration)
Public Function NewMaterialSet As MaterialSet
Visual C++
public:
MaterialSet^ NewMaterialSet()

Return Value

The newly created MaterialSet instance.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewNurbSpline Method

[image]

Revit 2010 API
Application..::.NewNurbSpline Method
Application Class See Also Send Feedback
Creates a new geometric nurbSpline object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public NurbSpline NewNurbSpline(
    XYZArray ctrlPoints,
    DoubleArray weights,
    DoubleArray knots,
    int nDegree,
    bool bClosed,
    bool bRational
)
Visual Basic (Declaration)
Public Function NewNurbSpline ( _
    ctrlPoints As XYZArray, _
    weights As DoubleArray, _
    knots As DoubleArray, _
    nDegree As Integer, _
    bClosed As Boolean, _
    bRational As Boolean _
) As NurbSpline
Visual C++
public:
NurbSpline^ NewNurbSpline(
    XYZArray^ ctrlPoints,
    DoubleArray^ weights,
    DoubleArray^ knots,
    int nDegree,
    bool bClosed,
    bool bRational
)

Parameters

ctrlPoints
Type: Autodesk.Revit.Geometry..::.XYZArray
The control points of the nurbSpline.
weights
Type: Autodesk.Revit.Geometry..::.DoubleArray
The weights of the nurbSpline.
knots
Type: Autodesk.Revit.Geometry..::.DoubleArray
The knots of the nurbSpline.
nDegree
Type: System..::.Int32
The degree of the nurbSpline.
bClosed
Type: System..::.Boolean
The nurbSpline is closed or not.
bRational
Type: System..::.Boolean
The nurbSpline is rational or no rational.

Remarks

If bRational is true,the size of ctrlPoints must equal to weights's,otherwise throw ArgumentException. There is a rule like that the size of knots equals to the sum of nDegree, ctrlPoints.size and 1, and the first nDegree+1 elements in the knots always are zero.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewParameterListItemArray Method

[image]

Revit 2010 API
Application..::.NewParameterListItemArray Method
Application Class See Also Send Feedback
Returns an array that can hold list items of external list parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterListItemArray NewParameterListItemArray()
Visual Basic (Declaration)
Public Function NewParameterListItemArray As ParameterListItemArray
Visual C++
public:
ParameterListItemArray^ NewParameterListItemArray()

Return Value

An empty array that contain list items whose type is Revit::Parameters::ParameterListItem.

Remarks

The array returned by this method can be used as a general purpose tool for holding ordered list items.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPlane Method

[image] [image]

Revit 2010 API
Application..::.NewPlane Method
Application Class See Also Send Feedback
Creates a new geometric plane object.

Overload List

Name | Description
NewPlane(CurveArray) | Creates a new geometric plane from a loop of planar curves.
NewPlane(XYZ, XYZ) | Creates a new geometric plane object based on a normal vector and an origin.
NewPlane(XYZ, XYZ, XYZ) | Creates a new geometric plane object based on two coordinate vectors and an origin.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewPlane Method (CurveArray)

[image]

Revit 2010 API
Application..::.NewPlane Method (CurveArray)
Application Class See Also Send Feedback
Creates a new geometric plane from a loop of planar curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Plane NewPlane(
    CurveArray curveloop
)
Visual Basic (Declaration)
Public Function NewPlane ( _
    curveloop As CurveArray _
) As Plane
Visual C++
public:
Plane^ NewPlane(
    CurveArray^ curveloop
)

Parameters

curveloop
Type: Autodesk.Revit.Geometry..::.CurveArray
The closed loop of planar curves to locate plane.

Return Value

If successful a new geometric plane will be returned. Otherwise null pointer.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the input curve loop is null or empty.
System..::.ArgumentException | Thrown when the input curve loop does not lie in a plane.
System..::.ArgumentException | Thrown when the input curve loop is not closed.

See Also

Application Class
NewPlane Overload
Autodesk.Revit.Creation Namespace


NewPlane Method (XYZ, XYZ)

[image]

Revit 2010 API
Application..::.NewPlane Method (XYZ, XYZ)
Application Class Example See Also Send Feedback
Creates a new geometric plane object based on a normal vector and an origin.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Plane NewPlane(
    XYZ norm,
    XYZ origin
)
Visual Basic (Declaration)
Public Function NewPlane ( _
    norm As XYZ, _
    origin As XYZ _
) As Plane
Visual C++
public:
Plane^ NewPlane(
    XYZ^ norm,
    XYZ^ origin
)

Parameters

norm
Type: Autodesk.Revit.Geometry..::.XYZ
Z vector of the plane coordinate system.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
Origin of the plane coordinate system.

Return Value

Returns a new plane object.

Examples

CopyC#
// Create a geometry plane in revit application
XYZ normal = XYZ.BasisZ;    // use basis of the z-axis (0,0,1) for normal vector
XYZ origin = XYZ.Zero;  // origin is (0,0,0)
Plane geomPlane = application.Create.NewPlane(normal, origin);
CopyVB.NET
' Create a geometry plane in revit application
Dim normal As Autodesk.Revit.Geometry.XYZ = Autodesk.Revit.Geometry.XYZ.BasisZ
' use basis of the z-axis (0,0,1) for normal vector
Dim origin As Autodesk.Revit.Geometry.XYZ = Autodesk.Revit.Geometry.XYZ.Zero
' origin is (0,0,0)
Dim geomPlane As Autodesk.Revit.Geometry.Plane = application.Create.NewPlane(normal, origin)

See Also

Application Class
NewPlane Overload
Autodesk.Revit.Creation Namespace


NewPlane Method (XYZ, XYZ, XYZ)

[image]

Revit 2010 API
Application..::.NewPlane Method (XYZ, XYZ, XYZ)
Application Class See Also Send Feedback
Creates a new geometric plane object based on two coordinate vectors and an origin.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Plane NewPlane(
    XYZ xVec,
    XYZ yVec,
    XYZ origin
)
Visual Basic (Declaration)
Public Function NewPlane ( _
    xVec As XYZ, _
    yVec As XYZ, _
    origin As XYZ _
) As Plane
Visual C++
public:
Plane^ NewPlane(
    XYZ^ xVec,
    XYZ^ yVec,
    XYZ^ origin
)

Parameters

xVec
Type: Autodesk.Revit.Geometry..::.XYZ
X vector of the plane coordinate system.
yVec
Type: Autodesk.Revit.Geometry..::.XYZ
Y vector of the plane coordinate system.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
Origin of the plane coordinate system.

Return Value

Returns a new plane object.

See Also

Application Class
NewPlane Overload
Autodesk.Revit.Creation Namespace


NewPoint Method

[image]

Revit 2010 API
Application..::.NewPoint Method
Application Class See Also Send Feedback
Creates a new geometric point object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Point NewPoint(
    XYZ coord
)
Visual Basic (Declaration)
Public Function NewPoint ( _
    coord As XYZ _
) As Point
Visual C++
public:
Point^ NewPoint(
    XYZ^ coord
)

Parameters

coord
Type: Autodesk.Revit.Geometry..::.XYZ
The coordinates of the point.

Remarks

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPointOnEdge Method

[image]

Revit 2010 API
Application..::.NewPointOnEdge Method
Application Class See Also Send Feedback
Create a PointOnEdge object which is used to define the placement of a ReferencePoint.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PointOnEdge NewPointOnEdge(
    Reference edgeReference,
    double edgeParam
)
Visual Basic (Declaration)
Public Function NewPointOnEdge ( _
    edgeReference As Reference, _
    edgeParam As Double _
) As PointOnEdge
Visual C++
public:
PointOnEdge^ NewPointOnEdge(
    Reference^ edgeReference,
    double edgeParam
)

Parameters

edgeReference
Type: Autodesk.Revit.Geometry..::.Reference
The reference whose edge the object will be created on.
edgeParam
Type: System..::.Double
The parameter on the edge.

Return Value

If creation was successful then a new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument edgeReference is null or edgeParam is not a valid dobule value.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPointOnEdgeEdgeIntersection Method

[image]

Revit 2010 API
Application..::.NewPointOnEdgeEdgeIntersection Method
Application Class See Also Send Feedback
Construct a PointOnEdgeEdgeIntersection object which is used to define the placement of a ReferencePoint given two references to edge.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PointOnEdgeEdgeIntersection NewPointOnEdgeEdgeIntersection(
    Reference edgeReference1,
    Reference edgeReference2
)
Visual Basic (Declaration)
Public Function NewPointOnEdgeEdgeIntersection ( _
    edgeReference1 As Reference, _
    edgeReference2 As Reference _
) As PointOnEdgeEdgeIntersection
Visual C++
public:
PointOnEdgeEdgeIntersection^ NewPointOnEdgeEdgeIntersection(
    Reference^ edgeReference1,
    Reference^ edgeReference2
)

Parameters

edgeReference1
Type: Autodesk.Revit.Geometry..::.Reference
The first edge reference.
edgeReference2
Type: Autodesk.Revit.Geometry..::.Reference
The second edge reference.

Return Value

A new PointOnEdgeEdgeIntersection object.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument edgeReference1 or edgeReference2 is null.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPointOnEdgeFaceIntersection Method

[image]

Revit 2010 API
Application..::.NewPointOnEdgeFaceIntersection Method
Application Class See Also Send Feedback
Construct a PointOnEdgeFaceIntersection object which is used to define the placement of a ReferencePoint given a references to edge and a reference to face.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PointOnEdgeFaceIntersection NewPointOnEdgeFaceIntersection(
    Reference edgeReference,
    Reference faceReference,
    bool orientWithEdge
)
Visual Basic (Declaration)
Public Function NewPointOnEdgeFaceIntersection ( _
    edgeReference As Reference, _
    faceReference As Reference, _
    orientWithEdge As Boolean _
) As PointOnEdgeFaceIntersection
Visual C++
public:
PointOnEdgeFaceIntersection^ NewPointOnEdgeFaceIntersection(
    Reference^ edgeReference,
    Reference^ faceReference,
    bool orientWithEdge
)

Parameters

edgeReference
Type: Autodesk.Revit.Geometry..::.Reference
The edge reference.
faceReference
Type: Autodesk.Revit.Geometry..::.Reference
The face reference.
orientWithEdge
Type: System..::.Boolean

Return Value

A new PointOnEdgeFaceIntersection object.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument edgeReference or faceReference is null.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPointOnFace Method

[image]

Revit 2010 API
Application..::.NewPointOnFace Method
Application Class See Also Send Feedback
Construct a PointOnFace object which is used to define the placement of a ReferencePoint given a reference and a location on the face.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PointOnFace NewPointOnFace(
    Reference faceReference,
    UV uv
)
Visual Basic (Declaration)
Public Function NewPointOnFace ( _
    faceReference As Reference, _
    uv As UV _
) As PointOnFace
Visual C++
public:
PointOnFace^ NewPointOnFace(
    Reference^ faceReference,
    UV^ uv
)

Parameters

faceReference
Type: Autodesk.Revit.Geometry..::.Reference
The reference whose face the object will be created on.
uv
Type: Autodesk.Revit.Geometry..::.UV
A 2-dimensional position.

Return Value

A new PointOnFace object.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument faceReference or uv is null.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPointOnPlane Method

[image]

Revit 2010 API
Application..::.NewPointOnPlane Method
Application Class See Also Send Feedback
Construct a PointOnPlane object which is used to define the placement of a ReferencePoint from its property values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PointOnPlane NewPointOnPlane(
    Reference planeReference,
    UV position,
    UV xvec,
    double offset
)
Visual Basic (Declaration)
Public Function NewPointOnPlane ( _
    planeReference As Reference, _
    position As UV, _
    xvec As UV, _
    offset As Double _
) As PointOnPlane
Visual C++
public:
PointOnPlane^ NewPointOnPlane(
    Reference^ planeReference,
    UV^ position,
    UV^ xvec,
    double offset
)

Parameters

planeReference
Type: Autodesk.Revit.Geometry..::.Reference
A reference to some plane in the document. (Note: the reference must satisfy IsValidPlaneReference(), but this is not checked until this PointOnPlane object is assigned to a ReferencePoint.)
position
Type: Autodesk.Revit.Geometry..::.UV
Coordinates of the point's projection onto the plane; see the Position property.
xvec
Type: Autodesk.Revit.Geometry..::.UV
The direction of the point's X-coordinate vector in the plane's coordinates; see the XVec property. Optional; default value is (1, 0).
offset
Type: System..::.Double
Signed offset from the plane; see the Offset property.

Return Value

A new PointOnPlane object with 2-dimensional Position, XVec, and Offset properties set to match the given 3-dimensional arguments.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument planeReference or position or xvec is null or offset is not a valid double value.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPostedErrorArray Method

[image]

Revit 2010 API
Application..::.NewPostedErrorArray Method
Application Class See Also Send Feedback
Creates an array to store instances of PostedError.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PostedErrorArray NewPostedErrorArray()
Visual Basic (Declaration)
Public Function NewPostedErrorArray As PostedErrorArray
Visual C++
public:
PostedErrorArray^ NewPostedErrorArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewProfiledWallCreationData Method

[image] [image]

Revit 2010 API
Application..::.NewProfiledWallCreationData Method
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation.

Overload List

Name | Description
NewProfiledWallCreationData(CurveArray, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation
NewProfiledWallCreationData(CurveArray, WallType, Level, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation
NewProfiledWallCreationData(CurveArray, WallType, Level, Boolean, XYZ) | Creates an object which wraps the arguments of NewWall() for batch creation

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewProfiledWallCreationData Method (CurveArray, Boolean)

[image]

Revit 2010 API
Application..::.NewProfiledWallCreationData Method (CurveArray, Boolean)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProfiledWallCreationData NewProfiledWallCreationData(
    CurveArray profile,
    bool structural
)
Visual Basic (Declaration)
Public Function NewProfiledWallCreationData ( _
    profile As CurveArray, _
    structural As Boolean _
) As ProfiledWallCreationData
Visual C++
public:
ProfiledWallCreationData^ NewProfiledWallCreationData(
    CurveArray^ profile,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

See Also

Application Class
NewProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace


NewProfiledWallCreationData Method (CurveArray, WallType, Level, Boolean)

[image]

Revit 2010 API
Application..::.NewProfiledWallCreationData Method (CurveArray, WallType, Level, Boolean)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProfiledWallCreationData NewProfiledWallCreationData(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Function NewProfiledWallCreationData ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean _
) As ProfiledWallCreationData
Visual C++
public:
ProfiledWallCreationData^ NewProfiledWallCreationData(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.Symbols..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

See Also

Application Class
NewProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace


NewProfiledWallCreationData Method (CurveArray, WallType, Level, Boolean, XYZ)

[image]

Revit 2010 API
Application..::.NewProfiledWallCreationData Method (CurveArray, WallType, Level, Boolean, XYZ)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProfiledWallCreationData NewProfiledWallCreationData(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic (Declaration)
Public Function NewProfiledWallCreationData ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
) As ProfiledWallCreationData
Visual C++
public:
ProfiledWallCreationData^ NewProfiledWallCreationData(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.Symbols..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.
normal
Type: Autodesk.Revit.Geometry..::.XYZ
A vector that must be perpendicular to the profile which dictates which side of the wall is considered.

See Also

Application Class
NewProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace


NewProjectPosition Method

[image]

Revit 2010 API
Application..::.NewProjectPosition Method
Application Class See Also Send Feedback
Creates a new project position object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProjectPosition NewProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)
Visual Basic (Declaration)
Public Function NewProjectPosition ( _
    ew As Double, _
    ns As Double, _
    elevation As Double, _
    angle As Double _
) As ProjectPosition
Visual C++
public:
ProjectPosition^ NewProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)

Parameters

ew
Type: System..::.Double
East to West offset in feet.
ns
Type: System..::.Double
North to South offset in feet.
elevation
Type: System..::.Double
Elevation above sea level in feet.
angle
Type: System..::.Double
Rotation angle away from true north in the range of -PI to +PI.

Remarks

This object contains offset information and is used by the project location object for setting the project location relative to the site location. Measurements are in feet and radians.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewRectangularWallCreationData Method

[image] [image]

Revit 2010 API
Application..::.NewRectangularWallCreationData Method
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation.

Overload List

Name | Description
NewRectangularWallCreationData(Curve, Level, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation
NewRectangularWallCreationData(Curve, WallType, Level, Double, Double, Boolean, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewRectangularWallCreationData Method (Curve, Level, Boolean)

[image]

Revit 2010 API
Application..::.NewRectangularWallCreationData Method (Curve, Level, Boolean)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RectangularWallCreationData NewRectangularWallCreationData(
    Curve curve,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Function NewRectangularWallCreationData ( _
    curve As Curve, _
    level As Level, _
    structural As Boolean _
) As RectangularWallCreationData
Visual C++
public:
RectangularWallCreationData^ NewRectangularWallCreationData(
    Curve^ curve,
    Level^ level,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
An arc or line representing the base line of the wall.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

See Also

Application Class
NewRectangularWallCreationData Overload
Autodesk.Revit.Creation Namespace


NewRectangularWallCreationData Method (Curve, WallType, Level, Double, Double, Boolean, Boolean)

[image]

Revit 2010 API
Application..::.NewRectangularWallCreationData Method (Curve, WallType, Level, Double, Double, Boolean, Boolean)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RectangularWallCreationData NewRectangularWallCreationData(
    Curve curve,
    WallType wallType,
    Level level,
    double height,
    double offset,
    bool flip,
    bool structural
)
Visual Basic (Declaration)
Public Function NewRectangularWallCreationData ( _
    curve As Curve, _
    wallType As WallType, _
    level As Level, _
    height As Double, _
    offset As Double, _
    flip As Boolean, _
    structural As Boolean _
) As RectangularWallCreationData
Visual C++
public:
RectangularWallCreationData^ NewRectangularWallCreationData(
    Curve^ curve,
    WallType^ wallType,
    Level^ level,
    double height,
    double offset,
    bool flip,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
An arc or line representing the base line of the wall.
wallType
Type: Autodesk.Revit.Symbols..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the wall is to be placed.
height
Type: System..::.Double
The height of the wall.
offset
Type: System..::.Double
An offset distance, in feet from the specified baseline. The wall will be placed that distance from the baseline.
flip
Type: System..::.Boolean
Change which side of the wall is considered to be the inside and outside of the wall.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

See Also

Application Class
NewRectangularWallCreationData Overload
Autodesk.Revit.Creation Namespace


NewReferenceArray Method

[image]

Revit 2010 API
Application..::.NewReferenceArray Method
Application Class See Also Send Feedback
Creates a new instance of a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferenceArray NewReferenceArray()
Visual Basic (Declaration)
Public Function NewReferenceArray As ReferenceArray
Visual C++
public:
ReferenceArray^ NewReferenceArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewRoomCreationData Method

[image]

Revit 2010 API
Application..::.NewRoomCreationData Method
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewRoom() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RoomCreationData NewRoomCreationData(
    Level level,
    UV point
)
Visual Basic (Declaration)
Public Function NewRoomCreationData ( _
    level As Level, _
    point As UV _
) As RoomCreationData
Visual C++
public:
RoomCreationData^ NewRoomCreationData(
    Level^ level,
    UV^ point
)

Parameters

level
Type: Autodesk.Revit.Elements..::.Level
- The level on which the room is to exist.
point
Type: Autodesk.Revit.Geometry..::.UV
A 2D point the dictates the location on that specified level.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewSelElementSet Method

[image]

Revit 2010 API
Application..::.NewSelElementSet Method
Application Class See Also Send Feedback
Creates a new instance of a set specifically for holding selected elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SelElementSet NewSelElementSet()
Visual Basic (Declaration)
Public Function NewSelElementSet As SelElementSet
Visual C++
public:
SelElementSet^ NewSelElementSet()

Return Value

Returns a new Element Set.

Remarks

If the user wants to change the selected Element with the API, the instance SelElementSet must be created to do the operation of Add and Remove.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewSet Method

[image]

Revit 2010 API
Application..::.NewSet Method
Application Class See Also Send Feedback
Creates a new instance of a generic Set.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Set NewSet()
Visual Basic (Declaration)
Public Function NewSet As Set
Visual C++
public:
Set^ NewSet()

Return Value

Returns a new instance of a generic Set.

Remarks

Generic sets can hold any type of object.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewSpaceSet Method

[image]

Revit 2010 API
Application..::.NewSpaceSet Method
Application Class See Also Send Feedback
Creates a new instance of a space set.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpaceSet NewSpaceSet()
Visual Basic (Declaration)
Public Function NewSpaceSet As SpaceSet
Visual C++
public:
SpaceSet^ NewSpaceSet()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewStringStringMap Method

[image]

Revit 2010 API
Application..::.NewStringStringMap Method
Application Class See Also Send Feedback
Creates a new map that maps one string to another string.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public StringStringMap NewStringStringMap()
Visual Basic (Declaration)
Public Function NewStringStringMap As StringStringMap
Visual C++
public:
StringStringMap^ NewStringStringMap()

Return Value

A map that maps one string to another.

Remarks

This is a general purpose string to string mapping which can be used for generating Autodesk Revit library paths.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewSuspendUpdating Method

[image]

Revit 2010 API
Application..::.NewSuspendUpdating Method
Application Class See Also Send Feedback
Creates a new instance of the SuspendUpdating object and begin suspension of consistency updates.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SuspendUpdating NewSuspendUpdating(
    Document document
)
Visual Basic (Declaration)
Public Function NewSuspendUpdating ( _
    document As Document _
) As SuspendUpdating
Visual C++
public:
SuspendUpdating^ NewSuspendUpdating(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit..::.Document
The document for which updating will be suspended.

Remarks

During suspension of updating, consistency will not be maintained. When all SuspendUpdating objects have been disposed, Revit will make the document consistent again.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the argument document is Null.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewTextNoteCreationData Method

[image] [image]

Revit 2010 API
Application..::.NewTextNoteCreationData Method
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewTextNote() for batch creation.

Overload List

Name | Description
NewTextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates an object which wraps the arguments of NewTextNote() for batch creation.
NewTextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates an object which wraps the arguments of NewTextNote() for batch creation.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewTextNoteCreationData Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)

[image]

Revit 2010 API
Application..::.NewTextNoteCreationData Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewTextNote() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TextNoteCreationData NewTextNoteCreationData(
    View theView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ leaderEnd,
    XYZ leaderElbow,
    string strText
)
Visual Basic (Declaration)
Public Function NewTextNoteCreationData ( _
    theView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    leaderType As TextNoteLeaderTypes, _
    leaderStyle As TextNoteLeaderStyles, _
    leaderEnd As XYZ, _
    leaderElbow As XYZ, _
    strText As String _
) As TextNoteCreationData
Visual C++
public:
TextNoteCreationData^ NewTextNoteCreationData(
    View^ theView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ^ leaderEnd,
    XYZ^ leaderElbow,
    String^ strText
)

Parameters

theView
Type: Autodesk.Revit.Elements..::.View
The view where the text note object will be visible.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The origin of the text note.
baseVec
Type: Autodesk.Revit.Geometry..::.XYZ
The horizontal direction for text in the text note.
upVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vertical direction for text in the text note.
lineWidth
Type: System..::.Double
The width of the rectangle bounding the note text.
textAlign
Type: Autodesk.Revit.Enums..::.TextAlignFlags
Flags indicating the alignment of the note. This should be a bitwise OR including one of TEF_ALIGN_TOP, TEF_ALIGN_MIDDLE and TEF_ALIGN_BOTTOM and one of TEF_ALIGN_LEFT, TEF_ALIGN_CENTER and TEF_ALIGN_RIGHT. The defaults for this flag are TEF_ALIGN_TOP | TEF_ALIGN_LEFT.
leaderType
Type: Autodesk.Revit.Enums..::.TextNoteLeaderTypes
The type and alignment of the leader for the note.
leaderStyle
Type: Autodesk.Revit.Enums..::.TextNoteLeaderStyles
The style for the leader.
leaderEnd
Type: Autodesk.Revit.Geometry..::.XYZ
The end point for the leader.
leaderElbow
Type: Autodesk.Revit.Geometry..::.XYZ
The elbow point for the leader.
strText
Type: System..::.String
Text to display in the text note. Include new line characters to force a multiple line note to be created. Notes may also wrap automatically based on the width of the note rectangle.

See Also

Application Class
NewTextNoteCreationData Overload
Autodesk.Revit.Creation Namespace


NewTextNoteCreationData Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)

[image]

Revit 2010 API
Application..::.NewTextNoteCreationData Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewTextNote() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TextNoteCreationData NewTextNoteCreationData(
    View theView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    string strText
)
Visual Basic (Declaration)
Public Function NewTextNoteCreationData ( _
    theView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    strText As String _
) As TextNoteCreationData
Visual C++
public:
TextNoteCreationData^ NewTextNoteCreationData(
    View^ theView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    String^ strText
)

Parameters

theView
Type: Autodesk.Revit.Elements..::.View
The view where the text note object will be visible.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The origin of the text note.
baseVec
Type: Autodesk.Revit.Geometry..::.XYZ
The horizontal direction for text in the text note.
upVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vertical direction for text in the text note.
lineWidth
Type: System..::.Double
The width of the rectangle bounding the note text.
textAlign
Type: Autodesk.Revit.Enums..::.TextAlignFlags
Flags indicating the alignment of the note. This should be a bitwise OR including one of TEF_ALIGN_TOP, TEF_ALIGN_MIDDLE and TEF_ALIGN_BOTTOM and one of TEF_ALIGN_LEFT, TEF_ALIGN_CENTER and TEF_ALIGN_RIGHT. The defaults for this flag are TEF_ALIGN_TOP | TEF_ALIGN_LEFT.
strText
Type: System..::.String
Text to display in the text note. Include new line characters to force a multiple line note to be created. Notes may also wrap automatically based on the width of the note rectangle.

See Also

Application Class
NewTextNoteCreationData Overload
Autodesk.Revit.Creation Namespace


NewTypeBinding Method

[image] [image]

Revit 2010 API
Application..::.NewTypeBinding Method
Application Class See Also Send Feedback
Creates a new type binding object.

Overload List

Name | Description
NewTypeBinding()()() | Creates a new empty type binding object.
NewTypeBinding(CategorySet) | Creates a new type binding object containing the categories passed as a parameter.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewTypeBinding Method

[image]

Revit 2010 API
Application..::.NewTypeBinding Method
Application Class See Also Send Feedback
Creates a new empty type binding object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TypeBinding NewTypeBinding()
Visual Basic (Declaration)
Public Function NewTypeBinding As TypeBinding
Visual C++
public:
TypeBinding^ NewTypeBinding()

Return Value

Returns a new type binding object.

Remarks

Type binding objects are used for attaching shared parameter definitions to a type within a category. Categories can be added to the instance binding via the Categories property of the InstanceBinding object

See Also

Application Class
NewTypeBinding Overload
Autodesk.Revit.Creation Namespace


NewTypeBinding Method (CategorySet)

[image]

Revit 2010 API
Application..::.NewTypeBinding Method (CategorySet)
Application Class See Also Send Feedback
Creates a new type binding object containing the categories passed as a parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TypeBinding NewTypeBinding(
    CategorySet categorySet
)
Visual Basic (Declaration)
Public Function NewTypeBinding ( _
    categorySet As CategorySet _
) As TypeBinding
Visual C++
public:
TypeBinding^ NewTypeBinding(
    CategorySet^ categorySet
)

Parameters

categorySet
Type: Autodesk.Revit..::.CategorySet
A set of categories that will be added to the binding.

Return Value

Returns a new type binding object.

Remarks

Type binding objects are used for attaching shared parameter definitions to a type within a category.

See Also

Application Class
NewTypeBinding Overload
Autodesk.Revit.Creation Namespace


NewUV Method

[image] [image]

Revit 2010 API
Application..::.NewUV Method
Application Class See Also Send Feedback
Creates a UV object representing coordinates in 2-space.

Overload List

Name | Description
NewUV()()() | Creates a UV object at the origin.
NewUV(UV) | Creates a UV object by copying the supplied UV object.
NewUV(Double, Double) | Creates a UV object representing coordinates in 2-space with supplied values.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewUV Method

[image]

Revit 2010 API
Application..::.NewUV Method
Application Class See Also Send Feedback
Creates a UV object at the origin.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV NewUV()
Visual Basic (Declaration)
Public Function NewUV As UV
Visual C++
public:
UV^ NewUV()

See Also

Application Class
NewUV Overload
Autodesk.Revit.Creation Namespace


NewUV Method (UV)

[image]

Revit 2010 API
Application..::.NewUV Method (UV)
Application Class See Also Send Feedback
Creates a UV object by copying the supplied UV object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV NewUV(
    UV uv
)
Visual Basic (Declaration)
Public Function NewUV ( _
    uv As UV _
) As UV
Visual C++
public:
UV^ NewUV(
    UV^ uv
)

Parameters

uv
Type: Autodesk.Revit.Geometry..::.UV
The supplied UV object

See Also

Application Class
NewUV Overload
Autodesk.Revit.Creation Namespace


NewUV Method (Double, Double)

[image]

Revit 2010 API
Application..::.NewUV Method (Double, Double)
Application Class See Also Send Feedback
Creates a UV object representing coordinates in 2-space with supplied values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV NewUV(
    double u,
    double v
)
Visual Basic (Declaration)
Public Function NewUV ( _
    u As Double, _
    v As Double _
) As UV
Visual C++
public:
UV^ NewUV(
    double u,
    double v
)

Parameters

u
Type: System..::.Double
The first coordinate.
v
Type: System..::.Double
The second coordinate.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when setting an infinite number to the U or V property.

See Also

Application Class
NewUV Overload
Autodesk.Revit.Creation Namespace


NewVertexIndexPair Method

[image]

Revit 2010 API
Application..::.NewVertexIndexPair Method
Application Class See Also Send Feedback
Creates a new VertexIndexPair object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public VertexIndexPair NewVertexIndexPair(
    int iTop,
    int iBottom
)
Visual Basic (Declaration)
Public Function NewVertexIndexPair ( _
    iTop As Integer, _
    iBottom As Integer _
) As VertexIndexPair
Visual C++
public:
VertexIndexPair^ NewVertexIndexPair(
    int iTop,
    int iBottom
)

Parameters

iTop
Type: System..::.Int32
The index of the vertex pair from the top profile of a blend.
iBottom
Type: System..::.Int32
The index of the vertex pair from the bottom profile of a blend.

Return Value

The new VertexIndexPair object.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewVertexIndexPairArray Method

[image]

Revit 2010 API
Application..::.NewVertexIndexPairArray Method
Application Class See Also Send Feedback
Returns an array that can hold VertexIndexPair objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public VertexIndexPairArray NewVertexIndexPairArray()
Visual Basic (Declaration)
Public Function NewVertexIndexPairArray As VertexIndexPairArray
Visual C++
public:
VertexIndexPairArray^ NewVertexIndexPairArray()

Return Value

The new VertexIndexPairArray objects.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewViewSet Method

[image]

Revit 2010 API
Application..::.NewViewSet Method
Application Class See Also Send Feedback
Creates a new instance of a View set.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSet NewViewSet()
Visual Basic (Declaration)
Public Function NewViewSet As ViewSet
Visual C++
public:
ViewSet^ NewViewSet()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewVolumeCalculationOptions Method

[image]

Revit 2010 API
Application..::.NewVolumeCalculationOptions Method
Application Class See Also Send Feedback
Creates options related to room volume and area computations.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public VolumeCalculationOptions NewVolumeCalculationOptions()
Visual Basic (Declaration)
Public Function NewVolumeCalculationOptions As VolumeCalculationOptions
Visual C++
public:
VolumeCalculationOptions^ NewVolumeCalculationOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewXYZ Method

[image] [image]

Revit 2010 API
Application..::.NewXYZ Method
Application Class See Also Send Feedback
Creates a XYZ object representing coordinates in 3-space.

Overload List

Name | Description
NewXYZ()()() | Creates a XYZ object at the origin.
NewXYZ(XYZ) | Creates a XYZ object by copying the supplied XYZ object.
NewXYZ(Double, Double, Double) | Creates a XYZ object representing coordinates in 3-space with supplied values.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewXYZ Method

[image]

Revit 2010 API
Application..::.NewXYZ Method
Application Class See Also Send Feedback
Creates a XYZ object at the origin.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ NewXYZ()
Visual Basic (Declaration)
Public Function NewXYZ As XYZ
Visual C++
public:
XYZ^ NewXYZ()

See Also

Application Class
NewXYZ Overload
Autodesk.Revit.Creation Namespace


NewXYZ Method (XYZ)

[image]

Revit 2010 API
Application..::.NewXYZ Method (XYZ)
Application Class See Also Send Feedback
Creates a XYZ object by copying the supplied XYZ object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ NewXYZ(
    XYZ xyz
)
Visual Basic (Declaration)
Public Function NewXYZ ( _
    xyz As XYZ _
) As XYZ
Visual C++
public:
XYZ^ NewXYZ(
    XYZ^ xyz
)

Parameters

xyz
Type: Autodesk.Revit.Geometry..::.XYZ
The supplied XYZ object

See Also

Application Class
NewXYZ Overload
Autodesk.Revit.Creation Namespace


NewXYZ Method (Double, Double, Double)

[image]

Revit 2010 API
Application..::.NewXYZ Method (Double, Double, Double)
Application Class See Also Send Feedback
Creates a XYZ object representing coordinates in 3-space with supplied values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ NewXYZ(
    double x,
    double y,
    double z
)
Visual Basic (Declaration)
Public Function NewXYZ ( _
    x As Double, _
    y As Double, _
    z As Double _
) As XYZ
Visual C++
public:
XYZ^ NewXYZ(
    double x,
    double y,
    double z
)

Parameters

x
Type: System..::.Double
The first coordinate.
y
Type: System..::.Double
The second coordinate.
z
Type: System..::.Double
The third coordinate.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when setting an infinite number to the X, Y or Z property.

See Also

Application Class
NewXYZ Overload
Autodesk.Revit.Creation Namespace


NewXYZArray Method

[image]

Revit 2010 API
Application..::.NewXYZArray Method
Application Class Example See Also Send Feedback
Generate an empty array that can hold XYZ point objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZArray NewXYZArray()
Visual Basic (Declaration)
Public Function NewXYZArray As XYZArray
Visual C++
public:
XYZArray^ NewXYZArray()

Return Value

An empty array capable of holding XYZ points or vectors.

Remarks

This method can be used to create an array that can be used for representing ordered points, such as those for the outline of a piece of geometry..

Examples

CopyC#
XYZArray xyzArray = application.Create.NewXYZArray();

// Append points to the array
int count = 20;
for (int ii = 0; ii < count; ++ii)
{
    XYZ xyz = new XYZ(ii, ii * ii, 0);
    xyzArray.Append(xyz);
}
CopyVB.NET
Dim xyzArray As XYZArray = application.Create.NewXYZArray()

' Append points to the array
Dim count As Integer = 20
For ii As Integer = 0 To count - 1
    Dim xyz As New Autodesk.Revit.Geometry.XYZ(ii, ii * ii, 0)
    xyzArray.Append(xyz)
Next

See Also

Application Class
Autodesk.Revit.Creation Namespace


Application Properties

[image] [image]

Revit 2010 API
Application Properties
Application Class See Also Send Feedback

The Application type exposes the following members.

Properties

Name | Description
Filter | Gives access to an object for creating different types of filters.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Application Class
Autodesk.Revit.Creation Namespace


Filter Property

[image]

Revit 2010 API
Application..::.Filter Property
Application Class See Also Send Feedback
Gives access to an object for creating different types of filters.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Filter Filter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filter As Filter
Visual C++
public:
property Filter^ Filter {
    Filter^ get ();
}

Field Value

The object to use for creating new filters.

See Also

Application Class
Autodesk.Revit.Creation Namespace


AreaCreationData Class

[image]

Revit 2010 API
AreaCreationData Class
Members See Also Send Feedback
A class which wraps the arguments of Area for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AreaCreationData
Visual Basic (Declaration)
Public Class AreaCreationData
Visual C++
public ref class AreaCreationData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Creation..::.AreaCreationData

See Also

AreaCreationData Members
Autodesk.Revit.Creation Namespace


AreaCreationData Members

[image] [image]

Revit 2010 API
AreaCreationData Members
AreaCreationData Class Constructors Methods Properties See Also Send Feedback

The AreaCreationData type exposes the following members.

Constructors

Name | Description
AreaCreationData | The data needed to create a new area

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
TagPoint | Specify the location of the area tag.

See Also

AreaCreationData Class
Autodesk.Revit.Creation Namespace


AreaCreationData Constructor

[image]

Revit 2010 API
AreaCreationData Constructor
AreaCreationData Class See Also Send Feedback
The data needed to create a new area

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaCreationData(
    ViewPlan areaView,
    UV point
)
Visual Basic (Declaration)
Public Sub New ( _
    areaView As ViewPlan, _
    point As UV _
)
Visual C++
public:
AreaCreationData(
    ViewPlan^ areaView,
    UV^ point
)

Parameters

areaView
Type: Autodesk.Revit.Elements..::.ViewPlan
The view of area element.
point
Type: Autodesk.Revit.Geometry..::.UV
The point which lies in the enclosed region of AreaBoundaryLines to put the new created Area

See Also

AreaCreationData Class
Autodesk.Revit.Creation Namespace


AreaCreationData Methods

[image] [image]

Revit 2010 API
AreaCreationData Methods
AreaCreationData Class See Also Send Feedback

The AreaCreationData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaCreationData Class
Autodesk.Revit.Creation Namespace


AreaCreationData Properties

[image] [image]

Revit 2010 API
AreaCreationData Properties
AreaCreationData Class See Also Send Feedback

The AreaCreationData type exposes the following members.

Properties

Name | Description
TagPoint | Specify the location of the area tag.

See Also

AreaCreationData Class
Autodesk.Revit.Creation Namespace


TagPoint Property

[image]

Revit 2010 API
AreaCreationData..::.TagPoint Property
AreaCreationData Class See Also Send Feedback
Specify the location of the area tag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV TagPoint { get; set; }
Visual Basic (Declaration)
Public Property TagPoint As UV
Visual C++
public:
property UV^ TagPoint {
    UV^ get ();
    void set (UV^ value);
}

See Also

AreaCreationData Class
Autodesk.Revit.Creation Namespace


Document Class

[image]

Revit 2010 API
Document Class
Members See Also Send Feedback
The Document Creation object is used to create new instances of elements within the Autodesk Revit project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Document : ItemFactoryBase
Visual Basic (Declaration)
Public Class Document _
    Inherits ItemFactoryBase
Visual C++
public ref class Document : public ItemFactoryBase

Remarks

The Document Creation object is a utility object that is used to create new instances of elements within the Autodesk Revit project. This object, available from the Document.Create property should be used to create elements instead of using New. This object ensures that the elements created are added to the document correctly. The object can create a limited number of types, which is expected to increase as the API matures.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Creation..::.ItemFactoryBase
Autodesk.Revit.Creation..::.Document

See Also

Document Members
Autodesk.Revit.Creation Namespace


Document Members

[image] [image]

Revit 2010 API
Document Members
Document Class Constructors Methods Properties See Also Send Feedback

The Document type exposes the following members.

Constructors

Name | Description
Document | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase.)
NewAnnotationSymbol | Add a new instance of an Annotation Symbol into the Autodesk Revit document, using a location and a symbol. (Inherited from ItemFactoryBase.)
NewArea | Creates a new area
NewAreaBoundaryConditions | Overloaded. Creates a new Area BoundaryConditions element.
NewAreaBoundaryLine | Creates a new boundary line as an Area border.
NewAreaLoad | Overloaded. Creates a new area load in the project.
NewAreaReinforcement | Creates a new instance of an Area Reinforcement element within the project
NewAreas | Creates new areas
NewAreaTag | Creates a new area tag.
NewAreaViewPlan | Creates a new view for the new area.
NewBeamSystem | Overloaded. Creates a new BeamSystem.
NewCrossFitting | Add a new family instance of a cross fitting into the Autodesk Revit document, using four connectors.
NewCurtainSystem | Overloaded. Creates a new CurtainSystem element.
NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase.)
NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase.)
NewDimension | Overloaded. Creates a new linear dimension object.
NewDuct | Overloaded. Adds a new duct into the document.
NewElbowFitting | Add a new family instance of an elbow fitting into the Autodesk Revit document, using two connectors.
NewElectricalSystem | Overloaded. Creates a new MEP Electrical System element.
NewExtrusionRoof | Creates a new Extrusion Roof.
NewFamilyInstance | Overloaded. Inserts a new instance of a family into the document. Inserts a new instance of a family into the document.
NewFamilyInstances | Creates Family instances within the document. (Inherited from ItemFactoryBase.)
NewFascia | Overloaded. Creates a fascia.
NewFlexDuct | Overloaded. Adds a new duct into the document.
NewFlexPipe | Overloaded. Adds a new flex pipe into the document.
NewFloor | Overloaded. Creates a floor within the project.
NewFootPrintRoof | Creates a new FootPrintRoof element.
NewFoundationSlab | Creates a foundation slab within the project with the given horizontal profile and floor style on the specified level.
NewFoundationWall | Creates a new continuous footing object.
NewGrid | Overloaded. Creates a new grid line.
NewGrids | Creates new grid lines.
NewGroup | Creates a new type of group. (Inherited from ItemFactoryBase.)
NewGutter | Overloaded. Creates a gutter.
NewLevel | Creates a new level. (Inherited from ItemFactoryBase.)
NewLineBoundaryConditions | Overloaded. Creates a new Line BoundaryConditions element.
NewLineLoad | Overloaded. Creates a new line load within the project.
NewLoadCase | Creates a new instance of a LoadCase element within the project.
NewLoadCombination | Creates a new instance of a LoadCombination element within the project.
NewLoadNature | Creates a new instance of a LoadNature element within the project.
NewLoadUsage | Creates a new instance of a LoadUsage element within the project.
NewMechanicalSystem | Creates a new MEP mechanical system element.
NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase.)
NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase.)
NewOpening | Overloaded. Creates a new opening.
NewPathReinforcement | Creates a new instance of a Path Reinforcement element within the project
NewPipe | Overloaded. Adds a new pipe into the document.
NewPipingSystem | Creates a new MEP piping system element.
NewPointBoundaryConditions | Creates a new Point BoundaryConditions Element.
NewPointLoad | Overloaded. Creates a new point load within the project.
NewRebar | Overloaded. Creates a new instance of a Rebar element within the project.
NewRebarShape | Creates a new instance of a Rebar Shape, which defines the shape of the rebar.
NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
NewRoom | Overloaded. Creates a new room.
NewRoomBoundaryLines | Creates a new boundary line as an Room border.
NewRooms | Overloaded. Creates one or more rooms.
NewRoomTag | Creates a new RoomTag.
NewSketchPlane | Overloaded. Creates a new sketch plane.
NewSlab | Creates a slab within the project with the given horizontal profile using the default floor style.
NewSlabEdge | Overloaded. Creates a slab edge.
NewSpace | Overloaded. Creates a new space.
NewSpaceBoundaryLines | Creates a new boundary line as an Space border.
NewSpaces | Overloaded. Creates one or more spaces.
NewSpaceTag | Creates a new SpaceTag.
NewSpotCoordinate | Generate a new spot coordinate object within the project.
NewSpotElevation | Generate a new spot elevation object within the project.
NewTag | Creates a new IndependentTag Element.
NewTakeoffFitting | Add a new family instance of an takeoff fitting into the Autodesk Revit document, using one connector and one MEP curve.
NewTeeFitting | Add a new family instance of a tee fitting into the Autodesk Revit document, using three connectors.
NewTextNote | Overloaded. Creates a new TextNote object.
NewTextNotes | Creates TextNotes with the specified data. (Inherited from ItemFactoryBase.)
NewTopographySurface | Creates a new TopographySurface element in the document, and initializes it with a set of points.
NewTransitionFitting | Add a new family instance of an transition fitting into the Autodesk Revit document, using two connectors.
NewTruss | Creates a New Truss.
NewUnionFitting | Add a new family instance of an union fitting into the Autodesk Revit document, using two connectors.
NewView3D | Creates a new 3D view. (Inherited from ItemFactoryBase.)
NewViewDrafting | Creates a new drafting view.
NewViewPlan | Creates a plan view based on the specified level. (Inherited from ItemFactoryBase.)
NewViewSection | Creates a new section view. (Inherited from ItemFactoryBase.)
NewViewSheet | Creates a new sheet view.
NewWall | Overloaded. Creates a new wall within the project.
NewWalls | Overloaded. Creates walls within the project.
NewWire | Creates a new wire element.
NewZone | Creates a new Zone element.
PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Document Class
Autodesk.Revit.Creation Namespace


Document Constructor

[image]

Revit 2010 API
Document Constructor
Document Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Document()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Document()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Document Class
Autodesk.Revit.Creation Namespace


Document Methods

[image] [image]

Revit 2010 API
Document Methods
Document Class See Also Send Feedback

The Document type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase.)
NewAnnotationSymbol | Add a new instance of an Annotation Symbol into the Autodesk Revit document, using a location and a symbol. (Inherited from ItemFactoryBase.)
NewArea | Creates a new area
NewAreaBoundaryConditions | Overloaded. Creates a new Area BoundaryConditions element.
NewAreaBoundaryLine | Creates a new boundary line as an Area border.
NewAreaLoad | Overloaded. Creates a new area load in the project.
NewAreaReinforcement | Creates a new instance of an Area Reinforcement element within the project
NewAreas | Creates new areas
NewAreaTag | Creates a new area tag.
NewAreaViewPlan | Creates a new view for the new area.
NewBeamSystem | Overloaded. Creates a new BeamSystem.
NewCrossFitting | Add a new family instance of a cross fitting into the Autodesk Revit document, using four connectors.
NewCurtainSystem | Overloaded. Creates a new CurtainSystem element.
NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase.)
NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase.)
NewDimension | Overloaded. Creates a new linear dimension object.
NewDuct | Overloaded. Adds a new duct into the document.
NewElbowFitting | Add a new family instance of an elbow fitting into the Autodesk Revit document, using two connectors.
NewElectricalSystem | Overloaded. Creates a new MEP Electrical System element.
NewExtrusionRoof | Creates a new Extrusion Roof.
NewFamilyInstance | Overloaded. Inserts a new instance of a family into the document. Inserts a new instance of a family into the document.
NewFamilyInstances | Creates Family instances within the document. (Inherited from ItemFactoryBase.)
NewFascia | Overloaded. Creates a fascia.
NewFlexDuct | Overloaded. Adds a new duct into the document.
NewFlexPipe | Overloaded. Adds a new flex pipe into the document.
NewFloor | Overloaded. Creates a floor within the project.
NewFootPrintRoof | Creates a new FootPrintRoof element.
NewFoundationSlab | Creates a foundation slab within the project with the given horizontal profile and floor style on the specified level.
NewFoundationWall | Creates a new continuous footing object.
NewGrid | Overloaded. Creates a new grid line.
NewGrids | Creates new grid lines.
NewGroup | Creates a new type of group. (Inherited from ItemFactoryBase.)
NewGutter | Overloaded. Creates a gutter.
NewLevel | Creates a new level. (Inherited from ItemFactoryBase.)
NewLineBoundaryConditions | Overloaded. Creates a new Line BoundaryConditions element.
NewLineLoad | Overloaded. Creates a new line load within the project.
NewLoadCase | Creates a new instance of a LoadCase element within the project.
NewLoadCombination | Creates a new instance of a LoadCombination element within the project.
NewLoadNature | Creates a new instance of a LoadNature element within the project.
NewLoadUsage | Creates a new instance of a LoadUsage element within the project.
NewMechanicalSystem | Creates a new MEP mechanical system element.
NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase.)
NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase.)
NewOpening | Overloaded. Creates a new opening.
NewPathReinforcement | Creates a new instance of a Path Reinforcement element within the project
NewPipe | Overloaded. Adds a new pipe into the document.
NewPipingSystem | Creates a new MEP piping system element.
NewPointBoundaryConditions | Creates a new Point BoundaryConditions Element.
NewPointLoad | Overloaded. Creates a new point load within the project.
NewRebar | Overloaded. Creates a new instance of a Rebar element within the project.
NewRebarShape | Creates a new instance of a Rebar Shape, which defines the shape of the rebar.
NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
NewRoom | Overloaded. Creates a new room.
NewRoomBoundaryLines | Creates a new boundary line as an Room border.
NewRooms | Overloaded. Creates one or more rooms.
NewRoomTag | Creates a new RoomTag.
NewSketchPlane | Overloaded. Creates a new sketch plane.
NewSlab | Creates a slab within the project with the given horizontal profile using the default floor style.
NewSlabEdge | Overloaded. Creates a slab edge.
NewSpace | Overloaded. Creates a new space.
NewSpaceBoundaryLines | Creates a new boundary line as an Space border.
NewSpaces | Overloaded. Creates one or more spaces.
NewSpaceTag | Creates a new SpaceTag.
NewSpotCoordinate | Generate a new spot coordinate object within the project.
NewSpotElevation | Generate a new spot elevation object within the project.
NewTag | Creates a new IndependentTag Element.
NewTakeoffFitting | Add a new family instance of an takeoff fitting into the Autodesk Revit document, using one connector and one MEP curve.
NewTeeFitting | Add a new family instance of a tee fitting into the Autodesk Revit document, using three connectors.
NewTextNote | Overloaded. Creates a new TextNote object.
NewTextNotes | Creates TextNotes with the specified data. (Inherited from ItemFactoryBase.)
NewTopographySurface | Creates a new TopographySurface element in the document, and initializes it with a set of points.
NewTransitionFitting | Add a new family instance of an transition fitting into the Autodesk Revit document, using two connectors.
NewTruss | Creates a New Truss.
NewUnionFitting | Add a new family instance of an union fitting into the Autodesk Revit document, using two connectors.
NewView3D | Creates a new 3D view. (Inherited from ItemFactoryBase.)
NewViewDrafting | Creates a new drafting view.
NewViewPlan | Creates a plan view based on the specified level. (Inherited from ItemFactoryBase.)
NewViewSection | Creates a new section view. (Inherited from ItemFactoryBase.)
NewViewSheet | Creates a new sheet view.
NewWall | Overloaded. Creates a new wall within the project.
NewWalls | Overloaded. Creates walls within the project.
NewWire | Creates a new wire element.
NewZone | Creates a new Zone element.
PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewArea Method

[image]

Revit 2010 API
Document..::.NewArea Method
Document Class See Also Send Feedback
Creates a new area

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Area NewArea(
    ViewPlan areaView,
    UV point
)
Visual Basic (Declaration)
Public Function NewArea ( _
    areaView As ViewPlan, _
    point As UV _
) As Area
Visual C++
public:
Area^ NewArea(
    ViewPlan^ areaView,
    UV^ point
)

Parameters

areaView
Type: Autodesk.Revit.Elements..::.ViewPlan
The view of area element.
point
Type: Autodesk.Revit.Geometry..::.UV
The point which lies in the enclosed region of AreaBoundaryLines to put the new created Area

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaBoundaryConditions Method

[image] [image]

Revit 2010 API
Document..::.NewAreaBoundaryConditions Method
Document Class See Also Send Feedback
Creates a new Area BoundaryConditions element.

Overload List

Name | Description
NewAreaBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a host element.
NewAreaBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a reference.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewAreaBoundaryConditions Method (Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)

[image]

Revit 2010 API
Document..::.NewAreaBoundaryConditions Method (Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)
Document Class Example See Also Send Feedback
Creates a new Area BoundaryConditions element on a host element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundaryConditions NewAreaBoundaryConditions(
    Element hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)
Visual Basic (Declaration)
Public Function NewAreaBoundaryConditions ( _
    hostElement As Element, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewAreaBoundaryConditions(
    Element^ hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)

Parameters

hostElement
Type: Autodesk.Revit..::.Element
A Wall, Slab or Slab Foundation to host the boundary conditions.
X_Translation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".

Return Value

If successful, NewAreaBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 2 - "Area". Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
bool CreateAreaConditionWithElement(Wall wall, Autodesk.Revit.Creation.Document docCreation)
{
    // Create Area Boundary Conditions using a given Wall and defaulting to fixed in all directions
    BoundaryConditions condition = docCreation.NewAreaBoundaryConditions(wall, TranslationRotationValue.Fixed, 0,
                                                                               TranslationRotationValue.Fixed, 0,
                                                                               TranslationRotationValue.Fixed, 0);
    return (null != condition);
}
CopyVB.NET
Private Function CreateAreaConditionWithElement(ByVal wall As Wall, ByVal docCreation As Autodesk.Revit.Creation.Document) As Boolean
    ' Create Area Boundary Conditions using a given Wall and defaulting to fixed in all directions
    Dim condition As Autodesk.Revit.Elements.BoundaryConditions = docCreation.NewAreaBoundaryConditions(wall, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
    0)
    Return (condition IsNot Nothing)
End Function

See Also

Document Class
NewAreaBoundaryConditions Overload
Autodesk.Revit.Creation Namespace


NewAreaBoundaryConditions Method (Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)

[image]

Revit 2010 API
Document..::.NewAreaBoundaryConditions Method (Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)
Document Class Example See Also Send Feedback
Creates a new Area BoundaryConditions element on a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundaryConditions NewAreaBoundaryConditions(
    Reference reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)
Visual Basic (Declaration)
Public Function NewAreaBoundaryConditions ( _
    reference As Reference, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewAreaBoundaryConditions(
    Reference^ reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)

Parameters

reference
Type: Autodesk.Revit.Geometry..::.Reference
The Geometry reference obtained from a Wall, Slab or Slab Foundation.
X_Translation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".

Return Value

If successful, NewAreaBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 2 - "Area". Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
 bool CreateAreaConditionWithReference(Wall wall, Autodesk.Revit.Creation.Document docCreation)
 {
     // Get the Geometry reference to the wall
     Reference profileReference = null;
     AnalyticalModelWall analytical = wall.AnalyticalModel as AnalyticalModelWall;
     if (null == analytical)
     {
         return false; // the profile reference can't be retrieved.
     }

     // loop through the curves of the wall and get the first one as a reference
     foreach (Curve curve in analytical.Curves)
     {
         profileReference = curve.Reference;
         if (null != profileReference)
         {
             break;
         }
     }

     BoundaryConditions condition = null;
     // Create the Area Boundary Conditions if we have a profileReference
     if (null != profileReference)
     {
         // Create Area Boundary Conditions with profile reference.
         condition = docCreation.NewAreaBoundaryConditions(profileReference, TranslationRotationValue.Fixed, 0,
                                                                             TranslationRotationValue.Fixed, 0,
                                                                             TranslationRotationValue.Fixed, 0);
     }
     return (null != condition);
}
CopyVB.NET
Private Function CreateAreaConditionWithReference(ByVal wall As Wall, ByVal docCreation As Autodesk.Revit.Creation.Document) As Boolean
    ' Get the Geometry reference to the wall
    Dim profileReference As Reference = Nothing
    Dim analytical As AnalyticalModelWall = TryCast(wall.AnalyticalModel, AnalyticalModelWall)
    If analytical Is Nothing Then
        Return False
        ' the profile reference can't be retrieved.
    End If

    ' loop through the curves of the wall and get the first one as a reference
    For Each curve As Curve In analytical.Curves
        profileReference = curve.Reference
        If profileReference IsNot Nothing Then
            Exit For
        End If
    Next

    Dim condition As Autodesk.Revit.Elements.BoundaryConditions = Nothing
    ' Create the Area Boundary Conditions if we have a profileReference
    If profileReference IsNot Nothing Then
        ' Create Area Boundary Conditions with profile reference.
        condition = docCreation.NewAreaBoundaryConditions(profileReference, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
        0)
    End If
    Return (condition IsNot Nothing)
End Function

See Also

Document Class
NewAreaBoundaryConditions Overload
Autodesk.Revit.Creation Namespace


NewAreaBoundaryLine Method

[image]

Revit 2010 API
Document..::.NewAreaBoundaryLine Method
Document Class See Also Send Feedback
Creates a new boundary line as an Area border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelCurve NewAreaBoundaryLine(
    SketchPlane sketchPlane,
    Curve geometryCurve,
    ViewPlan areaView
)
Visual Basic (Declaration)
Public Function NewAreaBoundaryLine ( _
    sketchPlane As SketchPlane, _
    geometryCurve As Curve, _
    areaView As ViewPlan _
) As ModelCurve
Visual C++
public:
ModelCurve^ NewAreaBoundaryLine(
    SketchPlane^ sketchPlane,
    Curve^ geometryCurve,
    ViewPlan^ areaView
)

Parameters

sketchPlane
Type: Autodesk.Revit.Elements..::.SketchPlane
The sketch plane.
geometryCurve
Type: Autodesk.Revit.Geometry..::.Curve
The geometry curve on which the boundary line are
areaView
Type: Autodesk.Revit.Elements..::.ViewPlan
The View for the new Area

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaLoad Method

[image] [image]

Revit 2010 API
Document..::.NewAreaLoad Method
Document Class See Also Send Feedback
Creates a new area load in the project.

Overload List

Name | Description
NewAreaLoad(Element, XYZ, Boolean, AreaLoadType) | Creates a new uniform hosted area load with polygonal shape within the project.
NewAreaLoad(XYZArray, XYZ, Boolean, AreaLoadType) | Creates a new uniform unhosted area load with polygonal shape within the project.
NewAreaLoad(CurveArray, array<Int32>[]()[], array<Int32>[]()[], XYZArray, Boolean, AreaLoadType) | Creates a new unhosted area load with variable forces at the vertices within the project.
NewAreaLoad(CurveArray, array<Int32>[]()[], array<Int32>[]()[], XYZ, XYZ, XYZ, Boolean, AreaLoadType) | Creates a new unhosted area load with variable forces at the vertices within the project.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewAreaLoad Method (Element, XYZ, Boolean, AreaLoadType)

[image]

Revit 2010 API
Document..::.NewAreaLoad Method (Element, XYZ, Boolean, AreaLoadType)
Document Class See Also Send Feedback
Creates a new uniform hosted area load with polygonal shape within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaLoad NewAreaLoad(
    Element host,
    XYZ force,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic (Declaration)
Public Function NewAreaLoad ( _
    host As Element, _
    force As XYZ, _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad(
    Element^ host,
    XYZ^ force,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

host
Type: Autodesk.Revit..::.Element
The host element (Floor or Wall) of the AreaLoad application.
force
Type: Autodesk.Revit.Geometry..::.XYZ
The 3d area force applied to the first reference point.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.Symbols..::.AreaLoadType
The symbol of the AreaLoad.

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
NewAreaLoad Overload
Autodesk.Revit.Creation Namespace


NewAreaLoad Method (XYZArray, XYZ, Boolean, AreaLoadType)

[image]

Revit 2010 API
Document..::.NewAreaLoad Method (XYZArray, XYZ, Boolean, AreaLoadType)
Document Class See Also Send Feedback
Creates a new uniform unhosted area load with polygonal shape within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaLoad NewAreaLoad(
    XYZArray points,
    XYZ force,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic (Declaration)
Public Function NewAreaLoad ( _
    points As XYZArray, _
    force As XYZ, _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad(
    XYZArray^ points,
    XYZ^ force,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

points
Type: Autodesk.Revit.Geometry..::.XYZArray
Vertexes of AreaLoad shape polygon.
force
Type: Autodesk.Revit.Geometry..::.XYZ
The applied 3d area force.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.Symbols..::.AreaLoadType
The symbol of the AreaLoad.

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
NewAreaLoad Overload
Autodesk.Revit.Creation Namespace


NewAreaLoad Method (CurveArray, Int32[], Int32[], XYZArray, Boolean, AreaLoadType)

[image]

Revit 2010 API
Document..::.NewAreaLoad Method (CurveArray, array<Int32>[]()[], array<Int32>[]()[], XYZArray, Boolean, AreaLoadType)
Document Class See Also Send Feedback
Creates a new unhosted area load with variable forces at the vertices within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaLoad NewAreaLoad(
    CurveArray curvesArr,
    int[] refPntIdxs,
    int[] ends,
    XYZArray forces,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic (Declaration)
Public Function NewAreaLoad ( _
    curvesArr As CurveArray, _
    refPntIdxs As Integer(), _
    ends As Integer(), _
    forces As XYZArray, _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad(
    CurveArray^ curvesArr,
    array<int>^ refPntIdxs,
    array<int>^ ends,
    XYZArray^ forces,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

curvesArr
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of curves that define the shape of the area load curves.
refPntIdxs
Type: array< System..::.Int32 >[]()[]
The indices of the curves in curvesArr that will be used to define the reference points for the load.
ends
Type: array< System..::.Int32 >[]()[]
Identifies which of the curve end points should be used for the reference points, for each member of refPntIdxs. The value should be 0 for the start point or 1 for the end point of the curve.
forces
Type: Autodesk.Revit.Geometry..::.XYZArray
The 3d area forces applied to each of the reference points in the refPntIdxs array.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.Symbols..::.AreaLoadType
The symbol of the AreaLoad.

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application. The size of the refPntIdxs, ends, and forces arrays must be the same, and a maximum of 3 values is permitted.

See Also

Document Class
NewAreaLoad Overload
Autodesk.Revit.Creation Namespace


NewAreaLoad Method (CurveArray, Int32[], Int32[], XYZ, XYZ, XYZ, Boolean, AreaLoadType)

[image]

Revit 2010 API
Document..::.NewAreaLoad Method (CurveArray, array<Int32>[]()[], array<Int32>[]()[], XYZ, XYZ, XYZ, Boolean, AreaLoadType)
Document Class See Also Send Feedback
Creates a new unhosted area load with variable forces at the vertices within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaLoad NewAreaLoad(
    CurveArray curvesArr,
    int[] refPntIdxs,
    int[] ends,
    XYZ force0,
    XYZ force1,
    XYZ force2,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic (Declaration)
Public Function NewAreaLoad ( _
    curvesArr As CurveArray, _
    refPntIdxs As Integer(), _
    ends As Integer(), _
    force0 As XYZ, _
    force1 As XYZ, _
    force2 As XYZ, _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad(
    CurveArray^ curvesArr,
    array<int>^ refPntIdxs,
    array<int>^ ends,
    XYZ^ force0,
    XYZ^ force1,
    XYZ^ force2,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

curvesArr
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of curves that define the shape of the area load.
refPntIdxs
Type: array< System..::.Int32 >[]()[]
The indices of the curves in curvesArr that will be used to define the reference points for the load.
ends
Type: array< System..::.Int32 >[]()[]
Identifies which of the curve end points should be used for the reference points, for each member of refPntIdxs. The value should be 0 for the start point or 1 for the end point of the curve.
force0
Type: Autodesk.Revit.Geometry..::.XYZ
The 3d area force applied to the first reference point.
force1
Type: Autodesk.Revit.Geometry..::.XYZ
The 3d area force applied to the second reference point. Ignored if only one or two reference points are supplied.
force2
Type: Autodesk.Revit.Geometry..::.XYZ
The 3d area force applied to the third reference point. Ignored if only one or two reference points are supplied.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.Symbols..::.AreaLoadType
The symbol of the AreaLoad.

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application. The size of the refPntIdxs and ends arrays must be the same, and a maximum of 3 values is permitted.

See Also

Document Class
NewAreaLoad Overload
Autodesk.Revit.Creation Namespace


NewAreaReinforcement Method

[image]

Revit 2010 API
Document..::.NewAreaReinforcement Method
Document Class Example See Also Send Feedback
Creates a new instance of an Area Reinforcement element within the project

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaReinforcement NewAreaReinforcement(
    Element host,
    CurveArray curves,
    XYZ direction
)
Visual Basic (Declaration)
Public Function NewAreaReinforcement ( _
    host As Element, _
    curves As CurveArray, _
    direction As XYZ _
) As AreaReinforcement
Visual C++
public:
AreaReinforcement^ NewAreaReinforcement(
    Element^ host,
    CurveArray^ curves,
    XYZ^ direction
)

Parameters

host
Type: Autodesk.Revit..::.Element
The element to which the Area Reinforcement belongs. The element must be a structural floor or wall.
curves
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of curves that define the boundary of the area. They must belong to the top face of the floor or the exterior face of the wall.
direction
Type: Autodesk.Revit.Geometry..::.XYZ

Return Value

If successful, NewAreaReinforcement returns an object for the newly created Rebar. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
AreaReinforcement CreateAreaReinforcementInWall(Wall wall, Autodesk.Revit.Creation.Document docCreation)
{
    // Get the wall analytical profile whose curves will define the boundary of the the area reinforcement
    AnalyticalModelWall analytical = wall.AnalyticalModel as AnalyticalModelWall;
    if (null == analytical)
    {
        throw new Exception("Can't get AnalyticalModel from the selected wall");
    }

    CurveArray curves = analytical.Curves;

    //define the Major Direction of AreaReinforcement,
    //we get direction of first Line on the Wall as the Major Direction
    Line firstLine = (Line)(curves.get_Item(0));
    XYZ majorDirection = new XYZ(
        firstLine.get_EndPoint(1).X - firstLine.get_EndPoint(0).X,
        firstLine.get_EndPoint(1).Y - firstLine.get_EndPoint(0).Y,
        firstLine.get_EndPoint(1).Z - firstLine.get_EndPoint(0).Z);

    // Create the area reinforcement
    AreaReinforcement rein = docCreation.NewAreaReinforcement(wall, curves, majorDirection);

    return rein;
}
CopyVB.NET
Private Function CreateAreaReinforcementInWall(ByVal wall As Wall, ByVal docCreation As Autodesk.Revit.Creation.Document) As AreaReinforcement
    ' Get the wall analytical profile whose curves will define the boundary of the the area reinforcement
    Dim analytical As AnalyticalModelWall = TryCast(wall.AnalyticalModel, AnalyticalModelWall)
    If analytical Is Nothing Then
        Throw New Exception("Can't get AnalyticalModel from the selected wall")
    End If

    Dim curves As CurveArray = analytical.Curves

    'define the Major Direction of AreaReinforcement,
    'we get direction of first Line on the Wall as the Major Direction
    Dim firstLine As Line = DirectCast((curves.Item(0)), Line)
    Dim majorDirection As New Autodesk.Revit.Geometry.XYZ(firstLine.EndPoint(1).X - firstLine.EndPoint(0).X, firstLine.EndPoint(1).Y - firstLine.EndPoint(0).Y, firstLine.EndPoint(1).Z - firstLine.EndPoint(0).Z)

    ' Create the area reinforcement
    Dim rein As AreaReinforcement = docCreation.NewAreaReinforcement(wall, curves, majorDirection)

    Return rein
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreas Method

[image]

Revit 2010 API
Document..::.NewAreas Method
Document Class See Also Send Feedback
Creates new areas

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewAreas(
    List<AreaCreationData> dataList
)
Visual Basic (Declaration)
Public Function NewAreas ( _
    dataList As List(Of AreaCreationData) _
) As ElementSet
Visual C++
public:
ElementSet^ NewAreas(
    List<AreaCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::.List <(Of <( AreaCreationData >)>)
A list of AreaCreationData which wraps the creation arguments of the areas to be created.

Return Value

If successful an Element Set which contains the areas should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
System..::.ArgumentNullException | If AreaCreationData's areaPoint is null object.
System..::.InvalidOperationException | If the area cannot be created successfully or the phase is invalid or regeneration fails at the end of the batch creation.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaTag Method

[image]

Revit 2010 API
Document..::.NewAreaTag Method
Document Class See Also Send Feedback
Creates a new area tag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaTag NewAreaTag(
    ViewPlan areaView,
    Area room,
    UV point
)
Visual Basic (Declaration)
Public Function NewAreaTag ( _
    areaView As ViewPlan, _
    room As Area, _
    point As UV _
) As AreaTag
Visual C++
public:
AreaTag^ NewAreaTag(
    ViewPlan^ areaView,
    Area^ room,
    UV^ point
)

Parameters

areaView
Type: Autodesk.Revit.Elements..::.ViewPlan
The area view
room
Type: Autodesk.Revit.Elements..::.Area
point
Type: Autodesk.Revit.Geometry..::.UV
The position of the area tag

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaViewPlan Method

[image]

Revit 2010 API
Document..::.NewAreaViewPlan Method
Document Class See Also Send Feedback
Creates a new view for the new area.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewPlan NewAreaViewPlan(
    string pViewName,
    Level pLevel,
    AreaElemType areaElemType
)
Visual Basic (Declaration)
Public Function NewAreaViewPlan ( _
    pViewName As String, _
    pLevel As Level, _
    areaElemType As AreaElemType _
) As ViewPlan
Visual C++
public:
ViewPlan^ NewAreaViewPlan(
    String^ pViewName,
    Level^ pLevel,
    AreaElemType areaElemType
)

Parameters

pViewName
Type: System..::.String
The name of new created view
pLevel
Type: Autodesk.Revit.Elements..::.Level
areaElemType
Type: Autodesk.Revit.Enums..::.AreaElemType
The type of area element

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewBeamSystem Method

[image] [image]

Revit 2010 API
Document..::.NewBeamSystem Method
Document Class See Also Send Feedback
Creates a new BeamSystem.

Overload List

Name | Description
NewBeamSystem(CurveArray) | Creates a new BeamSystem with specified profile curves.
NewBeamSystem(CurveArray, XYZ) | Creates a new BeamSystem with specified profile curves and direction.
NewBeamSystem(CurveArray, SketchPlane, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewBeamSystem Method (CurveArray)

[image]

Revit 2010 API
Document..::.NewBeamSystem Method (CurveArray)
Document Class Example See Also Send Feedback
Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BeamSystem NewBeamSystem(
    CurveArray profile
)
Visual Basic (Declaration)
Public Function NewBeamSystem ( _
    profile As CurveArray _
) As BeamSystem
Visual C++
public:
BeamSystem^ NewBeamSystem(
    CurveArray^ profile
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
The profile is the profile of the BeamSystem.

Return Value

If successful a new BeamSystem object will be returned, otherwise nothing. Suitable exceptions will be fired if the parameters are invalid.

Remarks

Other properties are set to default value and can be set later. Such as level, elevation, direction, etc.

Examples

CopyC#
// Build a profile for the beam system creation
XYZ first = new XYZ(0, 0, 0);
XYZ second = new XYZ(40, 0, 0);
XYZ third = new XYZ(40, 25, 0);
XYZ fourth = new XYZ(0, 25, 0);
CurveArray profile = new CurveArray();
profile.Append(Line.get_Bound(first, second));
profile.Append(Line.get_Bound(second, third));
profile.Append(Line.get_Bound(third, fourth));
profile.Append(Line.get_Bound(fourth, first));

// Create a beam system
BeamSystem beamSystem = document.Create.NewBeamSystem(profile);
if (null != beamSystem)
{
    // Change some properties, such as elevation
    Parameter elevationPara = beamSystem.get_Parameter(BuiltInParameter.INSTANCE_ELEVATION_PARAM);
    if (null != elevationPara)
    {
        elevationPara.Set(10.0);
    }
}
CopyVB.NET
' Build a profile for the beam system creation
Dim first As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
Dim second As New Autodesk.Revit.Geometry.XYZ(40, 0, 0)
Dim third As New Autodesk.Revit.Geometry.XYZ(40, 25, 0)
Dim fourth As New Autodesk.Revit.Geometry.XYZ(0, 25, 0)
Dim profile As New CurveArray()
profile.Append(Line.Bound(first, second))
profile.Append(Line.Bound(second, third))
profile.Append(Line.Bound(third, fourth))
profile.Append(Line.Bound(fourth, first))

' Create a beam system
Dim beamSystem As BeamSystem = document.Create.NewBeamSystem(profile)
If beamSystem IsNot Nothing Then
    ' Change some properties, such as elevation
    Dim elevationPara As Parameter = beamSystem.Parameter(BuiltInParameter.INSTANCE_ELEVATION_PARAM)
    If elevationPara IsNot Nothing Then
        elevationPara.[Set](10.0R)
    End If
End If

See Also

Document Class
NewBeamSystem Overload
Autodesk.Revit.Creation Namespace


NewBeamSystem Method (CurveArray, XYZ)

[image]

Revit 2010 API
Document..::.NewBeamSystem Method (CurveArray, XYZ)
Document Class See Also Send Feedback
Creates a new BeamSystem with specified profile curves and direction.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BeamSystem NewBeamSystem(
    CurveArray profile,
    XYZ direction
)
Visual Basic (Declaration)
Public Function NewBeamSystem ( _
    profile As CurveArray, _
    direction As XYZ _
) As BeamSystem
Visual C++
public:
BeamSystem^ NewBeamSystem(
    CurveArray^ profile,
    XYZ^ direction
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
The profile is the profile of the BeamSystem.
direction
Type: Autodesk.Revit.Geometry..::.XYZ
The direction is the direction of the BeamSystem.

Return Value

If successful a new BeamSystem object will be returned, otherwise nothing. Suitable exceptions will be fired if the parameters are invalid.

Remarks

Other properties are set to default value and can be set later. Such as level, elevation, direction, etc.

See Also

Document Class
NewBeamSystem Overload
Autodesk.Revit.Creation Namespace


NewBeamSystem Method (CurveArray, SketchPlane, XYZ, Boolean)

[image]

Revit 2010 API
Document..::.NewBeamSystem Method (CurveArray, SketchPlane, XYZ, Boolean)
Document Class See Also Send Feedback
Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BeamSystem NewBeamSystem(
    CurveArray profile,
    SketchPlane sketchPlane,
    XYZ direction,
    bool is3d
)
Visual Basic (Declaration)
Public Function NewBeamSystem ( _
    profile As CurveArray, _
    sketchPlane As SketchPlane, _
    direction As XYZ, _
    is3d As Boolean _
) As BeamSystem
Visual C++
public:
BeamSystem^ NewBeamSystem(
    CurveArray^ profile,
    SketchPlane^ sketchPlane,
    XYZ^ direction,
    bool is3d
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
The profile of the BeamSystem.
sketchPlane
Type: Autodesk.Revit.Elements..::.SketchPlane
The work plane of the BeamSystem.
direction
Type: Autodesk.Revit.Geometry..::.XYZ
The direction is the direction of the BeamSystem.
is3d
Type: System..::.Boolean
If the BeamSystem is 3D, the sketchPlane must be a level, or an exception will be thrown.

Return Value

If successful a new BeamSystem object will be returned, otherwise nothing. Suitable exceptions will be fired if the parameters are invalid.

Remarks

Other properties are set to default value and can be set later. Such as level, elevation, direction, etc.

See Also

Document Class
NewBeamSystem Overload
Autodesk.Revit.Creation Namespace


NewCrossFitting Method

[image]

Revit 2010 API
Document..::.NewCrossFitting Method
Document Class See Also Send Feedback
Add a new family instance of a cross fitting into the Autodesk Revit document, using four connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance NewCrossFitting(
    Connector connector1,
    Connector connector2,
    Connector connector3,
    Connector connector4
)
Visual Basic (Declaration)
Public Function NewCrossFitting ( _
    connector1 As Connector, _
    connector2 As Connector, _
    connector3 As Connector, _
    connector4 As Connector _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewCrossFitting(
    Connector^ connector1,
    Connector^ connector2,
    Connector^ connector3,
    Connector^ connector4
)

Parameters

connector1
Type: Autodesk.Revit.MEP..::.Connector
The first connector to be connected to the cross.
connector2
Type: Autodesk.Revit.MEP..::.Connector
The second connector to be connected to the cross.
connector3
Type: Autodesk.Revit.MEP..::.Connector
The third connector to be connected to the cross.
connector4
Type: Autodesk.Revit.MEP..::.Connector
The fourth connector to be connected to the cross.

Return Value

If creation was successful then an family instance to the new object is returned, and the transition fitting will be added at the connectors’ end if necessary, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument connector1, connector2, connector3, or connector4 is null.
System..::.ArgumentException | Thrown when the connectors cannot be used for cross creation. For example, they cannot be from the same element, they must be of the same domain, and the owner of the connectors should be a (flex) duct or pipe.
System..::.InvalidOperationException | Thrown when cross fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewCurtainSystem Method

[image] [image]

Revit 2010 API
Document..::.NewCurtainSystem Method
Document Class See Also Send Feedback
Creates a new CurtainSystem element.

Overload List

Name | Description
NewCurtainSystem(FaceArray, CurtainSystemType) | Creates a new CurtainSystem element from a set of faces.
NewCurtainSystem(ReferenceArray, CurtainSystemType) | Creates a new CurtainSystem element from a set of face references.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewCurtainSystem Method (FaceArray, CurtainSystemType)

[image]

Revit 2010 API
Document..::.NewCurtainSystem Method (FaceArray, CurtainSystemType)
Document Class See Also Send Feedback
Creates a new CurtainSystem element from a set of faces.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainSystem NewCurtainSystem(
    FaceArray faces,
    CurtainSystemType curtainSystemType
)
Visual Basic (Declaration)
Public Function NewCurtainSystem ( _
    faces As FaceArray, _
    curtainSystemType As CurtainSystemType _
) As CurtainSystem
Visual C++
public:
CurtainSystem^ NewCurtainSystem(
    FaceArray^ faces,
    CurtainSystemType^ curtainSystemType
)

Parameters

faces
Type: Autodesk.Revit.Geometry..::.FaceArray
The faces new CurtainSystem will be created on.
curtainSystemType
Type: Autodesk.Revit.Symbols..::.CurtainSystemType
The Type of CurtainSystem to be created.

Return Value

The CurtainSystem created will be returned when the operation succeeds.

Remarks

The input faces will be copied during the operations so that they can be any faces.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown in following cases: The input argument faces or curtainSystemType is null. The size of faces is zero.
System..::.InvalidOperationException | Thrown when the CurtainSystem cannot be created or regenerate fails.

See Also

Document Class
NewCurtainSystem Overload
Autodesk.Revit.Creation Namespace


NewCurtainSystem Method (ReferenceArray, CurtainSystemType)

[image]

Revit 2010 API
Document..::.NewCurtainSystem Method (ReferenceArray, CurtainSystemType)
Document Class See Also Send Feedback
Creates a new CurtainSystem element from a set of face references.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewCurtainSystem(
    ReferenceArray faces,
    CurtainSystemType curtainSystemType
)
Visual Basic (Declaration)
Public Function NewCurtainSystem ( _
    faces As ReferenceArray, _
    curtainSystemType As CurtainSystemType _
) As ElementSet
Visual C++
public:
ElementSet^ NewCurtainSystem(
    ReferenceArray^ faces,
    CurtainSystemType^ curtainSystemType
)

Parameters

faces
Type: Autodesk.Revit.Geometry..::.ReferenceArray
The faces new CurtainSystem will be created on.
curtainSystemType
Type: Autodesk.Revit.Symbols..::.CurtainSystemType
The Type of CurtainSystem to be created.

Return Value

A set of CurtainSystems will be returned when the operation succeeds.

Remarks

The faces can belong to different masses or generic models. The number of CurtainSystems will be equal to the number of masses and generic models.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown in following cases: The input argument faces or curtainSystemType is null. The size of faces is zero.
System..::.InvalidOperationException | Thrown when the CurtainSystem cannot be created, for example, the input faces don't belong to same mass or generic model. Or regenerate fails.

See Also

Document Class
NewCurtainSystem Overload
Autodesk.Revit.Creation Namespace


NewDimension Method

[image] [image]

Revit 2010 API
Document..::.NewDimension Method
Document Class See Also Send Feedback
Creates a new linear dimension object.

Overload List

Name | Description
NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. (Inherited from ItemFactoryBase.)
NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. (Inherited from ItemFactoryBase.)

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewDuct Method

[image] [image]

Revit 2010 API
Document..::.NewDuct Method
Document Class See Also Send Feedback
Adds a new duct into the document.

Overload List

Name | Description
NewDuct(XYZ, XYZ, DuctType) | Adds a new duct into the document, using two points and duct type.
NewDuct(XYZ, Connector, DuctType) | Adds a new duct into the document, using a point, connector and duct type.
NewDuct(Connector, Connector, DuctType) | Adds a new duct into the document, using two connectors and duct type.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewDuct Method (XYZ, XYZ, DuctType)

[image]

Revit 2010 API
Document..::.NewDuct Method (XYZ, XYZ, DuctType)
Document Class See Also Send Feedback
Adds a new duct into the document, using two points and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Duct NewDuct(
    XYZ point1,
    XYZ point2,
    DuctType ductType
)
Visual Basic (Declaration)
Public Function NewDuct ( _
    point1 As XYZ, _
    point2 As XYZ, _
    ductType As DuctType _
) As Duct
Visual C++
public:
Duct^ NewDuct(
    XYZ^ point1,
    XYZ^ point2,
    DuctType^ ductType
)

Parameters

point1
Type: Autodesk.Revit.Geometry..::.XYZ
The first point of the duct.
point2
Type: Autodesk.Revit.Geometry..::.XYZ
The second point of the duct.
ductType
Type: Autodesk.Revit.MEP..::.DuctType
The type of the duct.

Return Value

If creation was successful then a new duct is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument point1 or point2 is null.
System..::.InvalidOperationException | Thrown when the duct cannot be created or regenerate fails.

See Also

Document Class
NewDuct Overload
Autodesk.Revit.Creation Namespace


NewDuct Method (XYZ, Connector, DuctType)

[image]

Revit 2010 API
Document..::.NewDuct Method (XYZ, Connector, DuctType)
Document Class See Also Send Feedback
Adds a new duct into the document, using a point, connector and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Duct NewDuct(
    XYZ point,
    Connector connector,
    DuctType ductType
)
Visual Basic (Declaration)
Public Function NewDuct ( _
    point As XYZ, _
    connector As Connector, _
    ductType As DuctType _
) As Duct
Visual C++
public:
Duct^ NewDuct(
    XYZ^ point,
    Connector^ connector,
    DuctType^ ductType
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
The first point of the duct.
connector
Type: Autodesk.Revit.MEP..::.Connector
The connector to be connected to the duct.
ductType
Type: Autodesk.Revit.MEP..::.DuctType
The type of the duct.

Return Value

If creation was successful then a new duct is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connector is a fitting or equipment connector of the correct domain, and if the connector’s direction matches the direction of the duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector if necessary. If the connector's type, domain, or direction does not match the direction of the duct to be created, the position of the input connector will govern the endpoints of the duct, but no connection will be established.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument point or connector is null.
System..::.InvalidOperationException | Thrown when the duct cannot be created or regenerate fails.

See Also

Document Class
NewDuct Overload
Autodesk.Revit.Creation Namespace


NewDuct Method (Connector, Connector, DuctType)

[image]

Revit 2010 API
Document..::.NewDuct Method (Connector, Connector, DuctType)
Document Class See Also Send Feedback
Adds a new duct into the document, using two connectors and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Duct NewDuct(
    Connector connector1,
    Connector connector2,
    DuctType ductType
)
Visual Basic (Declaration)
Public Function NewDuct ( _
    connector1 As Connector, _
    connector2 As Connector, _
    ductType As DuctType _
) As Duct
Visual C++
public:
Duct^ NewDuct(
    Connector^ connector1,
    Connector^ connector2,
    DuctType^ ductType
)

Parameters

connector1
Type: Autodesk.Revit.MEP..::.Connector
The first connector to be connected to the duct.
connector2
Type: Autodesk.Revit.MEP..::.Connector
The second connector to be connected to the duct.
ductType
Type: Autodesk.Revit.MEP..::.DuctType
The type of the duct.

Return Value

If creation was successful then a new duct is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connectors are fitting or equipment connectors of the correct domain, and if the connectors’ direction match the direction of the duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, or direction does not match the direction of the duct to be created, the position of the input connectors will govern the endpoints of the duct, but no connection will be established.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument connector1 or connector2 is null.
System..::.InvalidOperationException | Thrown when the duct cannot be created or regenerate fails.

See Also

Document Class
NewDuct Overload
Autodesk.Revit.Creation Namespace


NewElbowFitting Method

[image]

Revit 2010 API
Document..::.NewElbowFitting Method
Document Class See Also Send Feedback
Add a new family instance of an elbow fitting into the Autodesk Revit document, using two connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance NewElbowFitting(
    Connector connector1,
    Connector connector2
)
Visual Basic (Declaration)
Public Function NewElbowFitting ( _
    connector1 As Connector, _
    connector2 As Connector _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewElbowFitting(
    Connector^ connector1,
    Connector^ connector2
)

Parameters

connector1
Type: Autodesk.Revit.MEP..::.Connector
The first connector to be connected to the elbow.
connector2
Type: Autodesk.Revit.MEP..::.Connector
The second connector to be connected to the elbow.

Return Value

If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument connector1 or connector2 is null.
System..::.ArgumentException | Thrown when the connectors cannot be used for the elbow creation. For example, they cannot be from the same element, they must be of the same domain, and the angle between them must fall within the valid range (typically 2 to 95 degrees).
System..::.InvalidOperationException | Thrown when elbow fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewElectricalSystem Method

[image] [image]

Revit 2010 API
Document..::.NewElectricalSystem Method
Document Class See Also Send Feedback
Creates a new MEP Electrical System element.

Overload List

Name | Description
NewElectricalSystem(ElementSet, ElectricalSystemType) | Creates a new MEP Electrical System element from a set of electrical components.
NewElectricalSystem(Connector, ElectricalSystemType) | Creates a new MEP Electrical System element from an unused Connector.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewElectricalSystem Method (ElementSet, ElectricalSystemType)

[image]

Revit 2010 API
Document..::.NewElectricalSystem Method (ElementSet, ElectricalSystemType)
Document Class See Also Send Feedback
Creates a new MEP Electrical System element from a set of electrical components.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElectricalSystem NewElectricalSystem(
    ElementSet electComponents,
    ElectricalSystemType elecSysType
)
Visual Basic (Declaration)
Public Function NewElectricalSystem ( _
    electComponents As ElementSet, _
    elecSysType As ElectricalSystemType _
) As ElectricalSystem
Visual C++
public:
ElectricalSystem^ NewElectricalSystem(
    ElementSet^ electComponents,
    ElectricalSystemType elecSysType
)

Parameters

electComponents
Type: Autodesk.Revit..::.ElementSet
The electrical components in this system.
elecSysType
Type: Autodesk.Revit.MEP.Enums..::.ElectricalSystemType
The System Type of electrical system.

Return Value

If successful a new MEP Electrical System element within the project, otherwise Nothing.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter Value is null.
System..::.ArgumentOutOfRangeException | Thrown when the elecSysType parameter Value is out of the range of ElectricalSystemType.
System..::.InvalidOperationException | Thrown when the electrical system cannot be created by these input electrical components.

See Also

Document Class
NewElectricalSystem Overload
Autodesk.Revit.Creation Namespace


NewElectricalSystem Method (Connector, ElectricalSystemType)

[image]

Revit 2010 API
Document..::.NewElectricalSystem Method (Connector, ElectricalSystemType)
Document Class See Also Send Feedback
Creates a new MEP Electrical System element from an unused Connector.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElectricalSystem NewElectricalSystem(
    Connector connector,
    ElectricalSystemType elecSysType
)
Visual Basic (Declaration)
Public Function NewElectricalSystem ( _
    connector As Connector, _
    elecSysType As ElectricalSystemType _
) As ElectricalSystem
Visual C++
public:
ElectricalSystem^ NewElectricalSystem(
    Connector^ connector,
    ElectricalSystemType elecSysType
)

Parameters

connector
Type: Autodesk.Revit.MEP..::.Connector
The Connector to create this Electrical System.
elecSysType
Type: Autodesk.Revit.MEP.Enums..::.ElectricalSystemType
The System Type of electrical system.

Return Value

If successful a new MEP Electrical System element within the project, otherwise Nothing.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter Value is null.
System..::.ArgumentOutOfRangeException | Thrown when the elecSysType parameter Value is out of the range of ElectricalSystemType.
System..::.InvalidOperationException | Thrown when the electrical system cannot be created by these input connector.

See Also

Document Class
NewElectricalSystem Overload
Autodesk.Revit.Creation Namespace


NewExtrusionRoof Method

[image]

Revit 2010 API
Document..::.NewExtrusionRoof Method
Document Class See Also Send Feedback
Creates a new Extrusion Roof.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ExtrusionRoof NewExtrusionRoof(
    CurveArray profile,
    ReferencePlane refPlane,
    Level level,
    RoofType roofType,
    double extrusionStart,
    double extrusionEnd
)
Visual Basic (Declaration)
Public Function NewExtrusionRoof ( _
    profile As CurveArray, _
    refPlane As ReferencePlane, _
    level As Level, _
    roofType As RoofType, _
    extrusionStart As Double, _
    extrusionEnd As Double _
) As ExtrusionRoof
Visual C++
public:
ExtrusionRoof^ NewExtrusionRoof(
    CurveArray^ profile,
    ReferencePlane^ refPlane,
    Level^ level,
    RoofType^ roofType,
    double extrusionStart,
    double extrusionEnd
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
The profile of the extrusion roof.
refPlane
Type: Autodesk.Revit.Elements..::.ReferencePlane
The work plane for the extrusion roof.
level
Type: Autodesk.Revit.Elements..::.Level
The level of the extrusion roof.
roofType
Type: Autodesk.Revit.Symbols..::.RoofType
Type of the extrusion roof.
extrusionStart
Type: System..::.Double
Start the extrusion.
extrusionEnd
Type: System..::.Double
End the extrusion.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method

[image] [image]

Revit 2010 API
Document..::.NewFamilyInstance Method
Document Class See Also Send Feedback
Inserts a new instance of a family into the document.
Inserts a new instance of a family into the document.

Overload List

Name | Description
NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase.)
NewFamilyInstance(Curve, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a curve, type/symbol and reference level.
NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol and a base level.
NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase.)
NewFamilyInstance(XYZ, FamilySymbol, Element, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.
NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase.)

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (Curve, FamilySymbol, Level, StructuralType)

[image]

Revit 2010 API
Document..::.NewFamilyInstance Method (Curve, FamilySymbol, Level, StructuralType)
Document Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a curve, type/symbol and reference level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    curve As Curve, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
The curve where the instance is based.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.Elements..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise Nothing.

Remarks

This method is used to insert one family instance into another element along the geometry of a curve. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must be one that supports insertion of instances otherwise this method will fail. All levels within the document can be found by iterating over the entire document and searching for objects of type Autodesk.Revit.Elements.Level.

Examples

CopyC#
// get the active view's level for beam creation
Level level = document.Application.ActiveDocument.ActiveView.Level;

// load a family symbol from file
FamilySymbol gotSymbol = null;
String fileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Structural\Framing\Steel\W-Wide Flange.rfa";
String name = "W10X54";

FamilyInstance instance = null;

if (document.LoadFamilySymbol(fileName, name, out gotSymbol))
{
    // look for a model line in the list of selected elements
    ElementSet sel = document.Selection.Elements;
    ModelLine modelLine = null;
    foreach (Autodesk.Revit.Element elem in sel)
    {
        if (elem is ModelLine)
        {
            modelLine = elem as ModelLine;
            break;
        }
    }
    if (null != modelLine)
    {
        // create a new beam
        instance = document.Create.NewFamilyInstance(modelLine.GeometryCurve, gotSymbol,
                                                      level, StructuralType.Beam);
    }
    else
    {
        throw new Exception("Please select a model line before invoking this command");
    }

}
else
{
    throw new Exception("Couldn't load " + fileName);
}
CopyVB.NET
' get the active view's level for beam creation
Dim level As Autodesk.Revit.Elements.Level = document.Application.ActiveDocument.ActiveView.Level

' load a family symbol from file
Dim gotSymbol As Autodesk.Revit.Symbols.FamilySymbol = Nothing
Dim fileName As String = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Structural\Framing\Steel\W-Wide Flange.rfa"
Dim name As String = "W10X54"

Dim instance As Autodesk.Revit.Elements.FamilyInstance = Nothing

If document.LoadFamilySymbol(fileName, name, gotSymbol) Then
    ' look for a model line in the list of selected elements
    Dim sel As ElementSet = document.Selection.Elements
    Dim modelLine As ModelLine = Nothing
    For Each elem As Autodesk.Revit.Element In sel
        If TypeOf elem Is ModelLine Then
            modelLine = TryCast(elem, ModelLine)
            Exit For
        End If
    Next
    If modelLine IsNot Nothing Then
        ' create a new beam
        instance = document.Create.NewFamilyInstance(modelLine.GeometryCurve, gotSymbol, level, StructuralType.Beam)
    Else
        Throw New Exception("Please select a model line before invoking this command")
    End If

Else
    Throw New Exception("Couldn't load " & fileName)
End If

See Also

Document Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, Level, StructuralType)

[image]

Revit 2010 API
Document..::.NewFamilyInstance Method (XYZ, FamilySymbol, Level, StructuralType)
Document Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol and a base level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.Elements..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise Nothing.

Remarks

This method is used to add a family instance that doesn't require a host element, but that can be associated to a level. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

All levels within the document can be found by iterating over the entire document and searching for objects of type Autodesk.Revit.Elements.Level.

Some families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Examples

CopyC#
FamilyInstance CreateColumn(Autodesk.Revit.Document document, Level level)
{
    // Get a Column type from revit
    FamilySymbol columnType = null;
    ElementIterator iter = document.get_Elements(typeof(FamilySymbol));;
    iter.Reset();
    while (iter.MoveNext())
    {
        columnType = iter.Current as FamilySymbol;
        if (null != columnType && null != columnType.Category)
        {
            if ("Structural Columns" == columnType.Category.Name)
            {
                break;
            }
        }
    }

    FamilyInstance instance;
    if (null != columnType)
    {
        // Create a column at the origin
        XYZ origin = new XYZ(0, 0, 0);

        instance = document.Create.NewFamilyInstance(origin, columnType, level,
                                                      StructuralType.Column);
    }
    else
    {
        throw new Exception("No column types found.");
    }

    return instance;
}
CopyVB.NET
Private Function CreateColumn(ByVal document As Autodesk.Revit.Document, ByVal level As Autodesk.Revit.Elements.Level) As Autodesk.Revit.Elements.FamilyInstance
    ' Get a Column type from revit
    Dim columnType As Autodesk.Revit.Symbols.FamilySymbol = Nothing
    Dim iter As ElementIterator = document.Elements(GetType(Autodesk.Revit.Symbols.FamilySymbol))

    iter.Reset()
    While iter.MoveNext()
        columnType = TryCast(iter.Current, Autodesk.Revit.Symbols.FamilySymbol)
        If columnType IsNot Nothing AndAlso columnType.Category IsNot Nothing Then
            If "Structural Columns" = columnType.Category.Name Then
                Exit While
            End If
        End If
    End While

    Dim instance As Autodesk.Revit.Elements.FamilyInstance
    If columnType IsNot Nothing Then
        ' Create a column at the origin
        Dim origin As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)

        instance = document.Create.NewFamilyInstance(origin, columnType, level, StructuralType.Column)
    Else
        Throw New Exception("No column types found.")
    End If

    Return instance
End Function

See Also

Document Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, Element, Level, StructuralType)

[image]

Revit 2010 API
Document..::.NewFamilyInstance Method (XYZ, FamilySymbol, Element, Level, StructuralType)
Document Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the instance is to be placed on the specified level.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit..::.Element
A host object into which the instance will be embedded
level
Type: Autodesk.Revit.Elements..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise Nothing.

Remarks

This form of NewFamilyInstance is the most commonly used in Autodesk Revit since there are a large number of elements that use levels, such as Walls, Columns etc. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

All levels within the document can be found by iterating over the entire document and searching for objects of type Autodesk.Revit.Elements.Level.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Examples

CopyC#
void CreateDoorsInWall(Autodesk.Revit.Document document, Wall wall)
{
    String fileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Doors\Single-Decorative 2.rfa";

    Family family = null;
    if (!document.LoadFamily(fileName, out family))
    {
        throw new Exception("Unable to load " + fileName);
    }

    // get the active view's level for beam creation
    Level level = document.Application.ActiveDocument.ActiveView.Level;

    FamilySymbolSetIterator symbolItor = family.Symbols.ForwardIterator();
    double x = 0, y = 0, z = 0;
    while (symbolItor.MoveNext())
    {
        FamilySymbol symbol = symbolItor.Current as FamilySymbol;
        XYZ location = new XYZ(x, y, z);
        FamilyInstance instance = document.Create.NewFamilyInstance(location, symbol, wall, level, StructuralType.NonStructural);
        x += 10;
        y += 10;
        z += 1.5;
    }
}
CopyVB.NET
Private Sub CreateDoorsInWall(ByVal document As Autodesk.Revit.Document, ByVal wall As Wall)
    Dim fileName As String = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Doors\Single-Decorative 2.rfa"

    Dim family As Autodesk.Revit.Elements.Family = Nothing
    If Not document.LoadFamily(fileName, family) Then
        Throw New Exception("Unable to load " & fileName)
    End If

    ' get the active view's level for beam creation
    Dim level As Autodesk.Revit.Elements.Level = document.Application.ActiveDocument.ActiveView.Level

    Dim symbolItor As FamilySymbolSetIterator = family.Symbols.ForwardIterator()
    Dim x As Double = 0, y As Double = 0, z As Double = 0
    While symbolItor.MoveNext()
        Dim symbol As Autodesk.Revit.Symbols.FamilySymbol = TryCast(symbolItor.Current, Autodesk.Revit.Symbols.FamilySymbol)
        Dim location As New Autodesk.Revit.Geometry.XYZ(x, y, z)
        Dim instance As Autodesk.Revit.Elements.FamilyInstance = document.Create.NewFamilyInstance(location, symbol, wall, level, StructuralType.NonStructural)
        x += 10
        y += 10
        z += 1.5
    End While
End Sub

See Also

Document Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFascia Method

[image] [image]

Revit 2010 API
Document..::.NewFascia Method
Document Class See Also Send Feedback
Creates a fascia.

Overload List

Name | Description
NewFascia(FasciaType, Reference) | Creates a fascia along a reference.
NewFascia(FasciaType, ReferenceArray) | Creates a fascia along a reference array.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewFascia Method (FasciaType, Reference)

[image]

Revit 2010 API
Document..::.NewFascia Method (FasciaType, Reference)
Document Class See Also Send Feedback
Creates a fascia along a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Fascia NewFascia(
    FasciaType FasciaType,
    Reference reference
)
Visual Basic (Declaration)
Public Function NewFascia ( _
    FasciaType As FasciaType, _
    reference As Reference _
) As Fascia
Visual C++
public:
Fascia^ NewFascia(
    FasciaType^ FasciaType,
    Reference^ reference
)

Parameters

FasciaType
Type: Autodesk.Revit.Symbols..::.FasciaType
The type of the fascia to create
reference
Type: Autodesk.Revit.Geometry..::.Reference
A planar line or arc that represents the place where you want to place the fascia.

Return Value

If successful a new fascia object within the project, otherwise Nothing.

See Also

Document Class
NewFascia Overload
Autodesk.Revit.Creation Namespace


NewFascia Method (FasciaType, ReferenceArray)

[image]

Revit 2010 API
Document..::.NewFascia Method (FasciaType, ReferenceArray)
Document Class See Also Send Feedback
Creates a fascia along a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Fascia NewFascia(
    FasciaType FasciaType,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewFascia ( _
    FasciaType As FasciaType, _
    references As ReferenceArray _
) As Fascia
Visual C++
public:
Fascia^ NewFascia(
    FasciaType^ FasciaType,
    ReferenceArray^ references
)

Parameters

FasciaType
Type: Autodesk.Revit.Symbols..::.FasciaType
The type of the fascia to create
references
Type: Autodesk.Revit.Geometry..::.ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the fascia.

Return Value

If successful a new fascia object within the project, otherwise Nothing.

See Also

Document Class
NewFascia Overload
Autodesk.Revit.Creation Namespace


NewFlexDuct Method

[image] [image]

Revit 2010 API
Document..::.NewFlexDuct Method
Document Class See Also Send Feedback
Adds a new duct into the document.

Overload List

Name | Description
NewFlexDuct(XYZArray, FlexDuctType) | Adds a new flex duct into the document, using a point array and duct type.
NewFlexDuct(Connector, XYZArray, FlexDuctType) | Adds a new flex duct into the document, using a connector, point array and duct type.
NewFlexDuct(Connector, Connector, FlexDuctType) | Adds a new flex duct into the document, using two connector, and duct type.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewFlexDuct Method (XYZArray, FlexDuctType)

[image]

Revit 2010 API
Document..::.NewFlexDuct Method (XYZArray, FlexDuctType)
Document Class See Also Send Feedback
Adds a new flex duct into the document, using a point array and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlexDuct NewFlexDuct(
    XYZArray points,
    FlexDuctType ductType
)
Visual Basic (Declaration)
Public Function NewFlexDuct ( _
    points As XYZArray, _
    ductType As FlexDuctType _
) As FlexDuct
Visual C++
public:
FlexDuct^ NewFlexDuct(
    XYZArray^ points,
    FlexDuctType^ ductType
)

Parameters

points
Type: Autodesk.Revit.Geometry..::.XYZArray
The point array indicating the path of the flex duct, including the end points.
ductType
Type: Autodesk.Revit.MEP..::.FlexDuctType
The type of the flex duct.

Return Value

If creation was successful then a new flex duct is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument points is null.
System..::.InvalidOperationException | Thrown when the flex duct cannot be created or regenerate fails.

See Also

Document Class
NewFlexDuct Overload
Autodesk.Revit.Creation Namespace


NewFlexDuct Method (Connector, XYZArray, FlexDuctType)

[image]

Revit 2010 API
Document..::.NewFlexDuct Method (Connector, XYZArray, FlexDuctType)
Document Class See Also Send Feedback
Adds a new flex duct into the document, using a connector, point array and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlexDuct NewFlexDuct(
    Connector connector,
    XYZArray points,
    FlexDuctType ductType
)
Visual Basic (Declaration)
Public Function NewFlexDuct ( _
    connector As Connector, _
    points As XYZArray, _
    ductType As FlexDuctType _
) As FlexDuct
Visual C++
public:
FlexDuct^ NewFlexDuct(
    Connector^ connector,
    XYZArray^ points,
    FlexDuctType^ ductType
)

Parameters

connector
Type: Autodesk.Revit.MEP..::.Connector
The connector to be connected to the duct, including the end points.
points
Type: Autodesk.Revit.Geometry..::.XYZArray
The point array indicating the path of the flex duct.
ductType
Type: Autodesk.Revit.MEP..::.FlexDuctType
The type of the flex duct.

Return Value

If creation was successful then a new flex duct is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connector is a fitting or equipment connector of the correct domain, and if the connector’s direction matches the direction of the flex duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument connector or points is null.
System..::.InvalidOperationException | Thrown when the flex duct cannot be created or regenerate fails.

See Also

Document Class
NewFlexDuct Overload
Autodesk.Revit.Creation Namespace


NewFlexDuct Method (Connector, Connector, FlexDuctType)

[image]

Revit 2010 API
Document..::.NewFlexDuct Method (Connector, Connector, FlexDuctType)
Document Class See Also Send Feedback
Adds a new flex duct into the document, using two connector, and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlexDuct NewFlexDuct(
    Connector connector1,
    Connector connector2,
    FlexDuctType ductType
)
Visual Basic (Declaration)
Public Function NewFlexDuct ( _
    connector1 As Connector, _
    connector2 As Connector, _
    ductType As FlexDuctType _
) As FlexDuct
Visual C++
public:
FlexDuct^ NewFlexDuct(
    Connector^ connector1,
    Connector^ connector2,
    FlexDuctType^ ductType
)

Parameters

connector1
Type: Autodesk.Revit.MEP..::.Connector
The first connector to be connected to the duct.
connector2
Type: Autodesk.Revit.MEP..::.Connector
The second connector to be connected to the duct.
ductType
Type: Autodesk.Revit.MEP..::.FlexDuctType
The type of the flex duct.

Return Value

If creation was successful then a new flex duct is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connectors are fitting or equipment connectors of the correct domain, and if the connectors’ direction match the direction of the flex duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument connector1 or connector2 is null.
System..::.InvalidOperationException | Thrown when the flex duct cannot be created or regenerate fails.

See Also

Document Class
NewFlexDuct Overload
Autodesk.Revit.Creation Namespace


NewFlexPipe Method

[image] [image]

Revit 2010 API
Document..::.NewFlexPipe Method
Document Class See Also Send Feedback
Adds a new flex pipe into the document.

Overload List

Name | Description
NewFlexPipe(XYZArray, FlexPipeType) | Adds a new flex pipe into the document, using a point array and pipe type.
NewFlexPipe(Connector, XYZArray, FlexPipeType) | Adds a new flex pipe into the document, using a connector, point array and pipe type.
NewFlexPipe(Connector, Connector, FlexPipeType) | Adds a new flex pipe into the document, using two connector, and flex pipe type.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewFlexPipe Method (XYZArray, FlexPipeType)

[image]

Revit 2010 API
Document..::.NewFlexPipe Method (XYZArray, FlexPipeType)
Document Class See Also Send Feedback
Adds a new flex pipe into the document, using a point array and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlexPipe NewFlexPipe(
    XYZArray points,
    FlexPipeType pipeType
)
Visual Basic (Declaration)
Public Function NewFlexPipe ( _
    points As XYZArray, _
    pipeType As FlexPipeType _
) As FlexPipe
Visual C++
public:
FlexPipe^ NewFlexPipe(
    XYZArray^ points,
    FlexPipeType^ pipeType
)

Parameters

points
Type: Autodesk.Revit.Geometry..::.XYZArray
The point array indicating the path of the flex pipe, including the end points.
pipeType
Type: Autodesk.Revit.MEP..::.FlexPipeType
The type of the flex pipe.

Return Value

If creation was successful then a new flex pipe is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument points is null.
System..::.InvalidOperationException | Thrown when the flex pipe cannot be created or regenerate fails.

See Also

Document Class
NewFlexPipe Overload
Autodesk.Revit.Creation Namespace


NewFlexPipe Method (Connector, XYZArray, FlexPipeType)

[image]

Revit 2010 API
Document..::.NewFlexPipe Method (Connector, XYZArray, FlexPipeType)
Document Class See Also Send Feedback
Adds a new flex pipe into the document, using a connector, point array and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlexPipe NewFlexPipe(
    Connector connector,
    XYZArray points,
    FlexPipeType pipeType
)
Visual Basic (Declaration)
Public Function NewFlexPipe ( _
    connector As Connector, _
    points As XYZArray, _
    pipeType As FlexPipeType _
) As FlexPipe
Visual C++
public:
FlexPipe^ NewFlexPipe(
    Connector^ connector,
    XYZArray^ points,
    FlexPipeType^ pipeType
)

Parameters

connector
Type: Autodesk.Revit.MEP..::.Connector
The connector to be connected to the flex pipe, including the end points.
points
Type: Autodesk.Revit.Geometry..::.XYZArray
The point array indicating the path of the flex duct.
pipeType
Type: Autodesk.Revit.MEP..::.FlexPipeType
The type of the flex pipe.

Return Value

If creation was successful then a new flex pipe is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connector is a fitting or equipment connector of the correct domain, and if the connector’s direction matches the direction of the flex pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument connector or points is null.
System..::.InvalidOperationException | Thrown when the flex pipe cannot be created or regenerate fails.

See Also

Document Class
NewFlexPipe Overload
Autodesk.Revit.Creation Namespace


NewFlexPipe Method (Connector, Connector, FlexPipeType)

[image]

Revit 2010 API
Document..::.NewFlexPipe Method (Connector, Connector, FlexPipeType)
Document Class See Also Send Feedback
Adds a new flex pipe into the document, using two connector, and flex pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlexPipe NewFlexPipe(
    Connector connector1,
    Connector connector2,
    FlexPipeType pipeType
)
Visual Basic (Declaration)
Public Function NewFlexPipe ( _
    connector1 As Connector, _
    connector2 As Connector, _
    pipeType As FlexPipeType _
) As FlexPipe
Visual C++
public:
FlexPipe^ NewFlexPipe(
    Connector^ connector1,
    Connector^ connector2,
    FlexPipeType^ pipeType
)

Parameters

connector1
Type: Autodesk.Revit.MEP..::.Connector
The first connector to be connected to the pipe.
connector2
Type: Autodesk.Revit.MEP..::.Connector
The second connector to be connected to the pipe.
pipeType
Type: Autodesk.Revit.MEP..::.FlexPipeType
The type of the flex pipe.

Return Value

If creation was successful then a new flex pipe is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connectors are fitting or equipment connectors of the correct domain, and if the connectors’ direction match the direction of the flex pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connectors, no connection will be established.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument connector1 or connector2 is null.
System..::.InvalidOperationException | Thrown when the flex pipe cannot be created or regenerate fails.

See Also

Document Class
NewFlexPipe Overload
Autodesk.Revit.Creation Namespace


NewFloor Method

[image] [image]

Revit 2010 API
Document..::.NewFloor Method
Document Class See Also Send Feedback
Creates a floor within the project.

Overload List

Name | Description
NewFloor(CurveArray, Boolean) | Creates a floor within the project with the given horizontal profile using the default floor style.
NewFloor(CurveArray, FloorType, Level, Boolean) | Creates a floor within the project with the given horizontal profile and floor style on the specified level.
NewFloor(CurveArray, FloorType, Level, Boolean, XYZ) | Creates a floor within the project with the given horizontal profile and floor style on the specified level with the specified normal vector.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewFloor Method (CurveArray, Boolean)

[image]

Revit 2010 API
Document..::.NewFloor Method (CurveArray, Boolean)
Document Class See Also Send Feedback
Creates a floor within the project with the given horizontal profile using the default floor style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Floor NewFloor(
    CurveArray profile,
    bool structural
)
Visual Basic (Declaration)
Public Function NewFloor ( _
    profile As CurveArray, _
    structural As Boolean _
) As Floor
Visual C++
public:
Floor^ NewFloor(
    CurveArray^ profile,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of planar lines and arcs that represent the horizontal profile of the floor.
structural
Type: System..::.Boolean
If set, specifies that the floor is structural in nature.

Return Value

If successful a new floor object within the project, otherwise Nothing.

See Also

Document Class
NewFloor Overload
Autodesk.Revit.Creation Namespace


NewFloor Method (CurveArray, FloorType, Level, Boolean)

[image]

Revit 2010 API
Document..::.NewFloor Method (CurveArray, FloorType, Level, Boolean)
Document Class See Also Send Feedback
Creates a floor within the project with the given horizontal profile and floor style on the specified level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Floor NewFloor(
    CurveArray profile,
    FloorType floorType,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Function NewFloor ( _
    profile As CurveArray, _
    floorType As FloorType, _
    level As Level, _
    structural As Boolean _
) As Floor
Visual C++
public:
Floor^ NewFloor(
    CurveArray^ profile,
    FloorType^ floorType,
    Level^ level,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of planar lines and arcs that represent the horizontal profile of the floor.
floorType
Type: Autodesk.Revit.Symbols..::.FloorType
A floor type to be used by the new floor instead of the default type.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the floor is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the floor is structural in nature.

Return Value

if successful, a new floor object within the project, otherwise Nothing.

Remarks

The Face formed by profile should be suitable to create floor, otherwise an exception thrown.

See Also

Document Class
NewFloor Overload
Autodesk.Revit.Creation Namespace


NewFloor Method (CurveArray, FloorType, Level, Boolean, XYZ)

[image]

Revit 2010 API
Document..::.NewFloor Method (CurveArray, FloorType, Level, Boolean, XYZ)
Document Class Example See Also Send Feedback
Creates a floor within the project with the given horizontal profile and floor style on the specified level with the specified normal vector.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Floor NewFloor(
    CurveArray profile,
    FloorType floorType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic (Declaration)
Public Function NewFloor ( _
    profile As CurveArray, _
    floorType As FloorType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
) As Floor
Visual C++
public:
Floor^ NewFloor(
    CurveArray^ profile,
    FloorType^ floorType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of planar lines and arcs that represent the horizontal profile of the floor.
floorType
Type: Autodesk.Revit.Symbols..::.FloorType
A floor type to be used by the new floor instead of the default type.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the floor is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the floor is structural in nature.
normal
Type: Autodesk.Revit.Geometry..::.XYZ
A vector that must be perpendicular to the profile which dictates which side of the floor is considered to be upper and down.

Return Value

if successful, a new floor object within the project, otherwise Nothing.

Remarks

The Face formed by profile should be suitable to create floor, otherwise an exception thrown.

Examples

CopyC#
Floor CreateFloor(Autodesk.Revit.Application application, Level level)
{
    // Get the revit document
    Autodesk.Revit.Document document = application.ActiveDocument;

    // Get the application creation object
    Autodesk.Revit.Creation.Application appCreation = application.Create;

    // Get a floor type for floor creation
    FloorType floorType = null;
    FloorTypeSet floorTypes = document.FloorTypes;
    FloorTypeSetIterator iter = floorTypes.ForwardIterator();
    iter.Reset();
    while (iter.MoveNext())
    {
        floorType = iter.Current as FloorType;
        if (null != floorType)
        {
            break;
        }
    }

    // Build a floor profile for the floor creation
    XYZ first = new XYZ(0, 0, 0);
    XYZ second = new XYZ(20, 0, 0);
    XYZ third = new XYZ(20, 15, 0);
    XYZ fourth = new XYZ(0, 15, 0);
    CurveArray profile = new CurveArray();
    profile.Append(appCreation.NewLineBound(first, second));
    profile.Append(appCreation.NewLineBound(second, third));
    profile.Append(appCreation.NewLineBound(third, fourth));
    profile.Append(appCreation.NewLineBound(fourth, first));

    // The normal vector (0,0,1) that must be perpendicular to the profile.
    XYZ normal = XYZ.BasisZ;

    return document.Create.NewFloor(profile, floorType, level, true, normal);
}
CopyVB.NET
Private Function CreateFloor(ByVal application As Autodesk.Revit.Application, ByVal level As Autodesk.Revit.Elements.Level) As Autodesk.Revit.Elements.Floor
    ' Get the revit document
    Dim document As Autodesk.Revit.Document = application.ActiveDocument

    ' Get the application creation object
    Dim appCreation As Autodesk.Revit.Creation.Application = application.Create

    ' Get a floor type for floor creation
    Dim floorType As FloorType = Nothing
    Dim floorTypes As FloorTypeSet = document.FloorTypes
    Dim iter As FloorTypeSetIterator = floorTypes.ForwardIterator()
    iter.Reset()
    While iter.MoveNext()
        floorType = TryCast(iter.Current, FloorType)
        If floorType IsNot Nothing Then
            Exit While
        End If
    End While

    ' Build a floor profile for the floor creation
    Dim first As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
    Dim second As New Autodesk.Revit.Geometry.XYZ(20, 0, 0)
    Dim third As New Autodesk.Revit.Geometry.XYZ(20, 15, 0)
    Dim fourth As New Autodesk.Revit.Geometry.XYZ(0, 15, 0)
    Dim profile As New CurveArray()
    profile.Append(appCreation.NewLineBound(first, second))
    profile.Append(appCreation.NewLineBound(second, third))
    profile.Append(appCreation.NewLineBound(third, fourth))
    profile.Append(appCreation.NewLineBound(fourth, first))

    ' The normal vector (0,0,1) that must be perpendicular to the profile.
    Dim normal As Autodesk.Revit.Geometry.XYZ = Autodesk.Revit.Geometry.XYZ.BasisZ

    Return document.Create.NewFloor(profile, floorType, level, True, normal)
End Function

See Also

Document Class
NewFloor Overload
Autodesk.Revit.Creation Namespace


NewFootPrintRoof Method

[image]

Revit 2010 API
Document..::.NewFootPrintRoof Method
Document Class Example See Also Send Feedback
Creates a new FootPrintRoof element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FootPrintRoof NewFootPrintRoof(
    CurveArray footPrint,
    Level level,
    RoofType roofType,
    ElementIdSet footPrintToModelCurvesMapping
)
Visual Basic (Declaration)
Public Function NewFootPrintRoof ( _
    footPrint As CurveArray, _
    level As Level, _
    roofType As RoofType, _
    footPrintToModelCurvesMapping As ElementIdSet _
) As FootPrintRoof
Visual C++
public:
FootPrintRoof^ NewFootPrintRoof(
    CurveArray^ footPrint,
    Level^ level,
    RoofType^ roofType,
    ElementIdSet^ footPrintToModelCurvesMapping
)

Parameters

footPrint
Type: Autodesk.Revit.Geometry..::.CurveArray
The footprint of the FootPrintRoof.
level
Type: Autodesk.Revit.Elements..::.Level
The level of the FootPrintRoof.
roofType
Type: Autodesk.Revit.Symbols..::.RoofType
Type of the FootPrintRoof.
footPrintToModelCurvesMapping
Type: Autodesk.Revit..::.ElementIdSet
Map footprint to Model Curves.

Examples

CopyC#
// Before invoking this sample, select some walls to add a roof over.
// Make sure there is a level named "Roof" in the document.

// find the Roof level
Level level = null;
ElementIterator elemItor = document.get_Elements(typeof(Level));
elemItor.Reset();
while (elemItor.MoveNext())
{
    Level currentLevel = elemItor.Current as Level;
    if (currentLevel.Name == "Roof")
    {
        level = currentLevel;
    }
}

RoofType rooftype = null;
// select the first rooftype
foreach (RoofType rt in document.RoofTypes)
{
    rooftype = rt;
    break;
}

// Get the handle of the application
Autodesk.Revit.Application application = document.Application;

// Define the footprint for the roof based on user selection
CurveArray footprint = application.Create.NewCurveArray();

if (document.Selection.Elements.Size != 0)
{
    foreach (Autodesk.Revit.Element element in document.Selection.Elements)
    {
        Wall wall = element as Wall;
        if (wall != null)
        {
            LocationCurve wallCurve = wall.Location as LocationCurve;
            footprint.Append(wallCurve.Curve);
            continue;
        }

        ModelCurve modelCurve = element as ModelCurve;
        if (modelCurve != null)
        {
            footprint.Append(modelCurve.GeometryCurve);
        }
    }

}
else
{
    throw new Exception("You should select a curve loop, or a wall loop, or loops combination \nof walls and curves to create a footprint roof.");
}

FootPrintRoof footprintRoof = document.Create.NewFootPrintRoof(footprint, level, rooftype, application.Create.NewElementIdSet());
CopyVB.NET
' Before invoking this sample, select some walls to add a roof over.
' Make sure there is a level named "Roof" in the document.

' find the Roof level
Dim level As Autodesk.Revit.Elements.Level = Nothing
Dim elemItor As ElementIterator = document.Elements(GetType(Autodesk.Revit.Elements.Level))
elemItor.Reset()
While elemItor.MoveNext()
    Dim currentLevel As Autodesk.Revit.Elements.Level = TryCast(elemItor.Current, Autodesk.Revit.Elements.Level)
    If currentLevel.Name = "Roof" Then
        level = currentLevel
    End If
End While

Dim rooftype As RoofType = Nothing
' select the first rooftype
For Each rt As RoofType In document.RoofTypes
    rooftype = rt
    Exit For
Next

' Get the handle of the application
Dim application As Autodesk.Revit.Application = document.Application

' Define the footprint for the roof based on user selection
Dim footprint As CurveArray = application.Create.NewCurveArray()

If document.Selection.Elements.Size <> 0 Then
    For Each element As Autodesk.Revit.Element In document.Selection.Elements
        Dim wall As Wall = TryCast(element, Wall)
        If wall IsNot Nothing Then
            Dim wallCurve As LocationCurve = TryCast(wall.Location, LocationCurve)
            footprint.Append(wallCurve.Curve)
            Continue For
        End If

        Dim modelCurve As ModelCurve = TryCast(element, ModelCurve)
        If modelCurve IsNot Nothing Then
            footprint.Append(modelCurve.GeometryCurve)
        End If
    Next

Else
    Throw New Exception("You should select a curve loop, or a wall loop, or loops combination " & vbLf & "of walls and curves to create a footprint roof.")
End If

Dim footprintRoof As FootPrintRoof = document.Create.NewFootPrintRoof(footprint, level, rooftype, application.Create.NewElementIdSet())

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFoundationSlab Method

[image]

Revit 2010 API
Document..::.NewFoundationSlab Method
Document Class See Also Send Feedback
Creates a foundation slab within the project with the given horizontal profile and floor style on the specified level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Floor NewFoundationSlab(
    CurveArray profile,
    FloorType floorType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic (Declaration)
Public Function NewFoundationSlab ( _
    profile As CurveArray, _
    floorType As FloorType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
) As Floor
Visual C++
public:
Floor^ NewFoundationSlab(
    CurveArray^ profile,
    FloorType^ floorType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of planar lines and arcs that represent the horizontal profile of the floor.
floorType
Type: Autodesk.Revit.Symbols..::.FloorType
A floor type to be used by the new floor instead of the default type.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the floor is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the floor is structural in nature.
normal
Type: Autodesk.Revit.Geometry..::.XYZ
A vector that must be perpendicular to the profile which dictates which side of the floor is considered to be upper and down.

Return Value

if successful, a new foundation slab object within the project, otherwise Nothing.

Remarks

The Face formed by profile should be suitable to create floor, otherwise an exception thrown.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFoundationWall Method

[image]

Revit 2010 API
Document..::.NewFoundationWall Method
Document Class See Also Send Feedback
Creates a new continuous footing object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ContFooting NewFoundationWall(
    ContFootingType contFootingType,
    Wall wall
)
Visual Basic (Declaration)
Public Function NewFoundationWall ( _
    contFootingType As ContFootingType, _
    wall As Wall _
) As ContFooting
Visual C++
public:
ContFooting^ NewFoundationWall(
    ContFootingType^ contFootingType,
    Wall^ wall
)

Parameters

contFootingType
Type: Autodesk.Revit.Symbols..::.ContFootingType
The ContFooting type.
wall
Type: Autodesk.Revit.Elements..::.Wall
The Wall to append a ContFooting.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewGrid Method

[image] [image]

Revit 2010 API
Document..::.NewGrid Method
Document Class See Also Send Feedback
Creates a new grid line.

Overload List

Name | Description
NewGrid(Arc) | Creates a new radial grid line.
NewGrid(Line) | Creates a new linear grid line.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewGrid Method (Arc)

[image]

Revit 2010 API
Document..::.NewGrid Method (Arc)
Document Class Example See Also Send Feedback
Creates a new radial grid line.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Grid NewGrid(
    Arc arc
)
Visual Basic (Declaration)
Public Function NewGrid ( _
    arc As Arc _
) As Grid
Visual C++
public:
Grid^ NewGrid(
    Arc^ arc
)

Parameters

arc
Type: Autodesk.Revit.Geometry..::.Arc
An arc object that represents the location of the new grid line.

Return Value

The newly created grid line.

Remarks

The arc should be on a horizontal plane.

Examples

CopyC#
// Create the geometry arc which the grid locates
XYZ end0 = new XYZ(0, 0, 0);
XYZ end1 = new XYZ(10, 40, 0);
XYZ pointOnCurve = new XYZ(5, 7, 0);
Arc geomArc = document.Application.Create.NewArc(end0, end1, pointOnCurve);

// Create a grid using the geometry arc
Grid arcGrid = document.Create.NewGrid(geomArc);

if (null == arcGrid)
{
    throw new Exception("Create a new curved grid failed.");
}

// Modify the name of the created grid
arcGrid.Name = "New Name2";
CopyVB.NET
' Create the geometry arc which the grid locates
Dim end0 As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
Dim end1 As New Autodesk.Revit.Geometry.XYZ(10, 40, 0)
Dim pointOnCurve As New Autodesk.Revit.Geometry.XYZ(5, 7, 0)
Dim geomArc As Arc = document.Application.Create.NewArc(end0, end1, pointOnCurve)

' Create a grid using the geometry arc
Dim arcGrid As Autodesk.Revit.Elements.Grid = document.Create.NewGrid(geomArc)

If arcGrid Is Nothing Then
    Throw New Exception("Create a new curved grid failed.")
End If

' Modify the name of the created grid
arcGrid.Name = "New Name2"

See Also

Document Class
NewGrid Overload
Autodesk.Revit.Creation Namespace


NewGrid Method (Line)

[image]

Revit 2010 API
Document..::.NewGrid Method (Line)
Document Class Example See Also Send Feedback
Creates a new linear grid line.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Grid NewGrid(
    Line line
)
Visual Basic (Declaration)
Public Function NewGrid ( _
    line As Line _
) As Grid
Visual C++
public:
Grid^ NewGrid(
    Line^ line
)

Parameters

line
Type: Autodesk.Revit.Geometry..::.Line
A line object which represents the location of the grid line.

Return Value

The newly created grid line.

Remarks

The line should be on a horizontal plane.

Examples

CopyC#
// Create the geometry line which the grid locates
XYZ start = new XYZ(0, 0, 0);
XYZ end = new XYZ(30, 30, 0);
Line geomLine = Line.get_Bound(start, end);

// Create a grid using the geometry line
Grid lineGrid = document.Create.NewGrid(geomLine);

if (null == lineGrid)
{
    throw new Exception("Create a new straight grid failed.");
}

// Modify the name of the created grid
lineGrid.Name = "New Name1";
CopyVB.NET
' Create the geometry line which the grid locates
Dim start As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
Dim [end] As New Autodesk.Revit.Geometry.XYZ(30, 30, 0)
Dim geomLine As Line = Line.Bound(start, [end])

' Create a grid using the geometry line
Dim lineGrid As Autodesk.Revit.Elements.Grid = document.Create.NewGrid(geomLine)

If lineGrid Is Nothing Then
    Throw New Exception("Create a new straight grid failed.")
End If

' Modify the name of the created grid
lineGrid.Name = "New Name1"

See Also

Document Class
NewGrid Overload
Autodesk.Revit.Creation Namespace


NewGrids Method

[image]

Revit 2010 API
Document..::.NewGrids Method
Document Class See Also Send Feedback
Creates new grid lines.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewGrids(
    CurveArray curves
)
Visual Basic (Declaration)
Public Function NewGrids ( _
    curves As CurveArray _
) As ElementSet
Visual C++
public:
ElementSet^ NewGrids(
    CurveArray^ curves
)

Parameters

curves
Type: Autodesk.Revit.Geometry..::.CurveArray
The curves which represent the new grid lines. These curves must be lines or bounded arcs.

Return Value

An Element set that contains the Grids.

Remarks

All input curves should lie on horizontal planes.

Exceptions

Exception | Condition
System..::.ArgumentException | If the curve is an unbounded arc (a circle).
System..::.ArgumentNullException | If any curve supplied in the input is null.
System..::.InvalidOperationException | If any grid line is not created successfully or regeneration fails at the end of the batch creation.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewGutter Method

[image] [image]

Revit 2010 API
Document..::.NewGutter Method
Document Class See Also Send Feedback
Creates a gutter.

Overload List

Name | Description
NewGutter(GutterType, Reference) | Creates a gutter along a reference.
NewGutter(GutterType, ReferenceArray) | Creates a gutter along a reference array.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewGutter Method (GutterType, Reference)

[image]

Revit 2010 API
Document..::.NewGutter Method (GutterType, Reference)
Document Class See Also Send Feedback
Creates a gutter along a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Gutter NewGutter(
    GutterType GutterType,
    Reference reference
)
Visual Basic (Declaration)
Public Function NewGutter ( _
    GutterType As GutterType, _
    reference As Reference _
) As Gutter
Visual C++
public:
Gutter^ NewGutter(
    GutterType^ GutterType,
    Reference^ reference
)

Parameters

GutterType
Type: Autodesk.Revit.Symbols..::.GutterType
The type of the gutter to create
reference
Type: Autodesk.Revit.Geometry..::.Reference
A planar line or arc that represents the place where you want to place the gutter.

Return Value

If successful a new gutter object within the project, otherwise Nothing.

See Also

Document Class
NewGutter Overload
Autodesk.Revit.Creation Namespace


NewGutter Method (GutterType, ReferenceArray)

[image]

Revit 2010 API
Document..::.NewGutter Method (GutterType, ReferenceArray)
Document Class See Also Send Feedback
Creates a gutter along a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Gutter NewGutter(
    GutterType GutterType,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewGutter ( _
    GutterType As GutterType, _
    references As ReferenceArray _
) As Gutter
Visual C++
public:
Gutter^ NewGutter(
    GutterType^ GutterType,
    ReferenceArray^ references
)

Parameters

GutterType
Type: Autodesk.Revit.Symbols..::.GutterType
The type of the gutter to create
references
Type: Autodesk.Revit.Geometry..::.ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the gutter.

Return Value

If successful a new gutter object within the project, otherwise Nothing.

See Also

Document Class
NewGutter Overload
Autodesk.Revit.Creation Namespace


NewLineBoundaryConditions Method

[image] [image]

Revit 2010 API
Document..::.NewLineBoundaryConditions Method
Document Class See Also Send Feedback
Creates a new Line BoundaryConditions element.

Overload List

Name | Description
NewLineBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a host element.
NewLineBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a reference.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewLineBoundaryConditions Method (Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)

[image]

Revit 2010 API
Document..::.NewLineBoundaryConditions Method (Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)
Document Class Example See Also Send Feedback
Creates a new Line BoundaryConditions element on a host element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundaryConditions NewLineBoundaryConditions(
    Element hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)
Visual Basic (Declaration)
Public Function NewLineBoundaryConditions ( _
    hostElement As Element, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double, _
    X_Rotation As TranslationRotationValue, _
    X_RotationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewLineBoundaryConditions(
    Element^ hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)

Parameters

hostElement
Type: Autodesk.Revit..::.Element
A Beam.
X_Translation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".
X_Rotation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the option for rotation about the X axis.
X_RotationSpringModulus
Type: System..::.Double
Rotation Spring Modulus for X axis. Ignored if X_Rotation is not "Spring"

Return Value

If successful, NewLineBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 1 - "Line". Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
bool CreateLineConditionsWithElement(FamilyInstance column, Autodesk.Revit.Creation.Document docCreation)
{
    if (Autodesk.Revit.Structural.Enums.StructuralType.Column != column.StructuralType)
    {
        throw new Exception("This sample only works for columns.");
    }

    // Create the new line boundary conditions
    BoundaryConditions condition = docCreation.NewLineBoundaryConditions(column, TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0);
    return (null != condition);
}
CopyVB.NET
Private Function CreateLineConditionsWithElement(ByVal column As Autodesk.Revit.Elements.FamilyInstance, ByVal docCreation As Autodesk.Revit.Creation.Document) As Boolean
    If Autodesk.Revit.Structural.Enums.StructuralType.Column <> column.StructuralType Then
        Throw New Exception("This sample only works for columns.")
    End If

    ' Create the new line boundary conditions
    Dim condition As Autodesk.Revit.Elements.BoundaryConditions = docCreation.NewLineBoundaryConditions(column, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
    0, TranslationRotationValue.Fixed, 0)
    Return (condition IsNot Nothing)
End Function

See Also

Document Class
NewLineBoundaryConditions Overload
Autodesk.Revit.Creation Namespace


NewLineBoundaryConditions Method (Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)

[image]

Revit 2010 API
Document..::.NewLineBoundaryConditions Method (Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)
Document Class Example See Also Send Feedback
Creates a new Line BoundaryConditions element on a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundaryConditions NewLineBoundaryConditions(
    Reference reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)
Visual Basic (Declaration)
Public Function NewLineBoundaryConditions ( _
    reference As Reference, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double, _
    X_Rotation As TranslationRotationValue, _
    X_RotationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewLineBoundaryConditions(
    Reference^ reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)

Parameters

reference
Type: Autodesk.Revit.Geometry..::.Reference
The Geometry reference to a Beam's, Wall's, Wall Foundation's, Slab's or Slab Foundation's analytical line.
X_Translation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".
X_Rotation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the option for rotation about the X axis.
X_RotationSpringModulus
Type: System..::.Double
Rotation Spring Modulus for X axis. Ignored if X_Rotation is not "Spring"

Return Value

If successful, NewLineBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 1 - "Line". Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
bool CreateLineConditionWithReference(FamilyInstance column, Autodesk.Revit.Creation.Document docCreation)
{
    if (Autodesk.Revit.Structural.Enums.StructuralType.Column != column.StructuralType)
    {
        throw new Exception("This sample only work for columns.");
    }

    // Get the line reference for the column analytical model
    Reference lineReference = null;
    AnalyticalModelFrame analytical = column.AnalyticalModel as AnalyticalModelFrame;
    lineReference = analytical.Curve.Reference;
    if (null == lineReference)
    {
        throw new Exception("Unable to get reference line for selected column.");
    }

    // Create line Boundary Conditions for the column
    BoundaryConditions condition = docCreation.NewLineBoundaryConditions(lineReference, TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0);
    return (null != condition);
}
CopyVB.NET
Private Function CreateLineConditionWithReference(ByVal column As Autodesk.Revit.Elements.FamilyInstance, ByVal docCreation As Autodesk.Revit.Creation.Document) As Boolean
    If Autodesk.Revit.Structural.Enums.StructuralType.Column <> column.StructuralType Then
        Throw New Exception("This sample only work for columns.")
    End If

    ' Get the line reference for the column analytical model
    Dim lineReference As Reference = Nothing
    Dim analytical As AnalyticalModelFrame = TryCast(column.AnalyticalModel, AnalyticalModelFrame)
    lineReference = analytical.Curve.Reference
    If lineReference Is Nothing Then
        Throw New Exception("Unable to get reference line for selected column.")
    End If

    ' Create line Boundary Conditions for the column
    Dim condition As Autodesk.Revit.Elements.BoundaryConditions = docCreation.NewLineBoundaryConditions(lineReference, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
    0, TranslationRotationValue.Fixed, 0)
    Return (condition IsNot Nothing)
End Function

See Also

Document Class
NewLineBoundaryConditions Overload
Autodesk.Revit.Creation Namespace


NewLineLoad Method

[image] [image]

Revit 2010 API
Document..::.NewLineLoad Method
Document Class See Also Send Feedback
Creates a new line load within the project.

Overload List

Name | Description
NewLineLoad(XYZ, XYZ, XYZ, XYZ, XYZ, XYZ, Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new unhosted line load within the project using data at two points.
NewLineLoad(Element, XYZArray, XYZArray, Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new hosted line load within the project using data at two points.
NewLineLoad(Reference, XYZArray, XYZArray, Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new hosted line load within the project using data at an array of points.
NewLineLoad(XYZArray, XYZArray, XYZArray, Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new unhosted line load within the project using data at an array of points.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewLineLoad Method (XYZ, XYZ, XYZ, XYZ, XYZ, XYZ, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)

[image]

Revit 2010 API
Document..::.NewLineLoad Method (XYZ, XYZ, XYZ, XYZ, XYZ, XYZ, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)
Document Class See Also Send Feedback
Creates a new unhosted line load within the project using data at two points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LineLoad NewLineLoad(
    XYZ point,
    XYZ force,
    XYZ moment,
    XYZ point1,
    XYZ force1,
    XYZ moment1,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewLineLoad ( _
    point As XYZ, _
    force As XYZ, _
    moment As XYZ, _
    point1 As XYZ, _
    force1 As XYZ, _
    moment1 As XYZ, _
    uniform As Boolean, _
    projected As Boolean, _
    isReaction As Boolean, _
    symbol As LineLoadType, _
    plane As SketchPlane _
) As LineLoad
Visual C++
public:
LineLoad^ NewLineLoad(
    XYZ^ point,
    XYZ^ force,
    XYZ^ moment,
    XYZ^ point1,
    XYZ^ force1,
    XYZ^ moment1,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
The first point of the LineLoad application.
force
Type: Autodesk.Revit.Geometry..::.XYZ
The applied 3d linear force in the first point.
moment
Type: Autodesk.Revit.Geometry..::.XYZ
The applied 3d linear moment in the first point.
point1
Type: Autodesk.Revit.Geometry..::.XYZ
The second point of the LineLoad application.
force1
Type: Autodesk.Revit.Geometry..::.XYZ
The applied 3d linear force in the second point.
moment1
Type: Autodesk.Revit.Geometry..::.XYZ
The applied 3d linear moment in the second point.
uniform
Type: System..::.Boolean
Set to True if you wish to create the uniform load.
projected
Type: System..::.Boolean
Set to True if you wish to create the projected load.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.Symbols..::.LineLoadType
The symbol of the LineLoad.
plane
Type: Autodesk.Revit.Elements..::.SketchPlane
Indicate the work plane of the LineLoad.

Return Value

If successful, NewLineLOad returns an object for the newly created LineLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
NewLineLoad Overload
Autodesk.Revit.Creation Namespace


NewLineLoad Method (Element, XYZArray, XYZArray, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)

[image]

Revit 2010 API
Document..::.NewLineLoad Method (Element, XYZArray, XYZArray, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)
Document Class See Also Send Feedback
Creates a new hosted line load within the project using data at two points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LineLoad NewLineLoad(
    Element host,
    XYZArray forces,
    XYZArray moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewLineLoad ( _
    host As Element, _
    forces As XYZArray, _
    moments As XYZArray, _
    uniform As Boolean, _
    projected As Boolean, _
    isReaction As Boolean, _
    symbol As LineLoadType, _
    plane As SketchPlane _
) As LineLoad
Visual C++
public:
LineLoad^ NewLineLoad(
    Element^ host,
    XYZArray^ forces,
    XYZArray^ moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

host
Type: Autodesk.Revit..::.Element
The host element (Beam, Brace or Column) of the LineLoad application.
forces
Type: Autodesk.Revit.Geometry..::.XYZArray
The applied 3d linear forces in the end points.
moments
Type: Autodesk.Revit.Geometry..::.XYZArray
The applied 3d linear moments in the end points.
uniform
Type: System..::.Boolean
Set to True if you wish to create the uniform load.
projected
Type: System..::.Boolean
Set to True if you wish to create the projected load.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.Symbols..::.LineLoadType
The symbol of the LineLoad.
plane
Type: Autodesk.Revit.Elements..::.SketchPlane
Indicate the work plane of the LineLoad.

Return Value

If successful, NewLineLOad returns an object for the newly created LineLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
NewLineLoad Overload
Autodesk.Revit.Creation Namespace


NewLineLoad Method (Reference, XYZArray, XYZArray, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)

[image]

Revit 2010 API
Document..::.NewLineLoad Method (Reference, XYZArray, XYZArray, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)
Document Class See Also Send Feedback
Creates a new hosted line load within the project using data at an array of points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LineLoad NewLineLoad(
    Reference reference,
    XYZArray forces,
    XYZArray moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewLineLoad ( _
    reference As Reference, _
    forces As XYZArray, _
    moments As XYZArray, _
    uniform As Boolean, _
    projected As Boolean, _
    isReaction As Boolean, _
    symbol As LineLoadType, _
    plane As SketchPlane _
) As LineLoad
Visual C++
public:
LineLoad^ NewLineLoad(
    Reference^ reference,
    XYZArray^ forces,
    XYZArray^ moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

reference
Type: Autodesk.Revit.Geometry..::.Reference
The Geometry reference to Beam's, Brace's, Column's, Wall's, Wall Foundation's, Slab's or Slab Foundation's analytical lines.
forces
Type: Autodesk.Revit.Geometry..::.XYZArray
The applied 3d linear forces in the end points.
moments
Type: Autodesk.Revit.Geometry..::.XYZArray
The applied 3d linear moments in the end points.
uniform
Type: System..::.Boolean
Set to True if you wish to create the uniform load.
projected
Type: System..::.Boolean
Set to True if you wish to create the projected load.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.Symbols..::.LineLoadType
The symbol of the LineLoad.
plane
Type: Autodesk.Revit.Elements..::.SketchPlane
Indicate the work plane of the LineLoad.

Return Value

If successful, NewLineLOad returns an object for the newly created LineLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
NewLineLoad Overload
Autodesk.Revit.Creation Namespace


NewLineLoad Method (XYZArray, XYZArray, XYZArray, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)

[image]

Revit 2010 API
Document..::.NewLineLoad Method (XYZArray, XYZArray, XYZArray, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)
Document Class See Also Send Feedback
Creates a new unhosted line load within the project using data at an array of points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LineLoad NewLineLoad(
    XYZArray points,
    XYZArray forces,
    XYZArray moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewLineLoad ( _
    points As XYZArray, _
    forces As XYZArray, _
    moments As XYZArray, _
    uniform As Boolean, _
    projected As Boolean, _
    isReaction As Boolean, _
    symbol As LineLoadType, _
    plane As SketchPlane _
) As LineLoad
Visual C++
public:
LineLoad^ NewLineLoad(
    XYZArray^ points,
    XYZArray^ forces,
    XYZArray^ moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

points
Type: Autodesk.Revit.Geometry..::.XYZArray
The end points of the LineLoad application.
forces
Type: Autodesk.Revit.Geometry..::.XYZArray
The applied 3d linear forces in the end points.
moments
Type: Autodesk.Revit.Geometry..::.XYZArray
The applied 3d linear moments in the end points.
uniform
Type: System..::.Boolean
Set to True if you wish to create the uniform load.
projected
Type: System..::.Boolean
Set to True if you wish to create the projected load.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.Symbols..::.LineLoadType
The symbol of the LineLoad.
plane
Type: Autodesk.Revit.Elements..::.SketchPlane
Indicate the work plane of the LineLoad.

Return Value

If successful, NewLineLoad returns an object for the newly created LineLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
NewLineLoad Overload
Autodesk.Revit.Creation Namespace


NewLoadCase Method

[image]

Revit 2010 API
Document..::.NewLoadCase Method
Document Class Example See Also Send Feedback
Creates a new instance of a LoadCase element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadCase NewLoadCase(
    string name,
    LoadNature nature,
    Category category
)
Visual Basic (Declaration)
Public Function NewLoadCase ( _
    name As String, _
    nature As LoadNature, _
    category As Category _
) As LoadCase
Visual C++
public:
LoadCase^ NewLoadCase(
    String^ name,
    LoadNature^ nature,
    Category^ category
)

Parameters

name
Type: System..::.String
The not empty name for the Load Case Element to create.
nature
Type: Autodesk.Revit.Elements..::.LoadNature
The Load Case nature.
category
Type: Autodesk.Revit..::.Category
The Load Case category.

Return Value

If successful, NewLoadCase and there isn’t the Load Case Element with the same name returns an object for the newly created LoadCase. If such element exist and match desired one (has the same nature and number), returns existing element. Otherwise nothing is returned.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
LoadCase CreateLoadCase(Autodesk.Revit.Document document, Category category, LoadNature nature)
{
    // Create a load case
    // Category should be of type OST_LoadCases
    LoadCase loadCase = document.Create.NewLoadCase("new case", nature, category);
    if (null == loadCase)
    {
        throw new Exception("Create a new load case failed.");
    }

    // Give the user some information
    MessageBox.Show("Successfully created a load case.", "Revit");

    return loadCase;
}
CopyVB.NET
Private Function CreateLoadCase(ByVal document As Autodesk.Revit.Document, ByVal category As Autodesk.Revit.Category, ByVal nature As LoadNature) As LoadCase
    ' Create a load case
    ' Category should be of type OST_LoadCases
    Dim loadCase As LoadCase = document.Create.NewLoadCase("new case", nature, category)
    If loadCase Is Nothing Then
        Throw New Exception("Create a new load case failed.")
    End If

    ' Give the user some information
    MessageBox.Show("Successfully created a load case.", "Revit")

    Return loadCase
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewLoadCombination Method

[image]

Revit 2010 API
Document..::.NewLoadCombination Method
Document Class Example See Also Send Feedback
Creates a new instance of a LoadCombination element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadCombination NewLoadCombination(
    string name,
    int typeInd,
    int stateInd,
    double[] factors,
    LoadCaseArray cases,
    LoadCombinationArray combinations,
    LoadUsageArray usages
)
Visual Basic (Declaration)
Public Function NewLoadCombination ( _
    name As String, _
    typeInd As Integer, _
    stateInd As Integer, _
    factors As Double(), _
    cases As LoadCaseArray, _
    combinations As LoadCombinationArray, _
    usages As LoadUsageArray _
) As LoadCombination
Visual C++
public:
LoadCombination^ NewLoadCombination(
    String^ name,
    int typeInd,
    int stateInd,
    array<double>^ factors,
    LoadCaseArray^ cases,
    LoadCombinationArray^ combinations,
    LoadUsageArray^ usages
)

Parameters

name
Type: System..::.String
The not empty name for the Load Combination Element to create.
typeInd
Type: System..::.Int32
LoadCombination Type Index: 0-Combination, 1-Envelope.
stateInd
Type: System..::.Int32
LoadCombination State Index: 0-Servicebility, 1-Ultimate.
factors
Type: array< System..::.Double >[]()[]
Factors array for Load Combination formula.
cases
Type: Autodesk.Revit.Elements..::.LoadCaseArray
Load Cases array for Load Combination formula.
combinations
Type: Autodesk.Revit.Elements..::.LoadCombinationArray
Load Combinations array for Load Combination formula.
usages
Type: Autodesk.Revit.Elements..::.LoadUsageArray
Load Usages array.

Return Value

If successful, NewLoadCombination and there isn’t the Load Combination Element with the same name returns an object for the newly created LoadCombination. If such element exist and match desired one (has the same formula and the same usages set), returns existing element. Otherwise nothing is returned.

Remarks

Factors and Load Combinations arrays have the same dimension (n). The Load Combination formula is equal to: factors[0]*cases[0]*factors[1]*cases[1]*. . . factors[n]*cases[n]. This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
LoadCombination CreateLoadCombination(Autodesk.Revit.Document document, LoadCaseArray loadCases, LoadUsageArray loadUsages)
{
    // Create the factor array for load combination creation
    double[] factorArray = new double[loadCases.Size];
    for (int ii = 0; ii < loadCases.Size; ii++)
    {
        factorArray[ii] = ii + 1;
    }

    // Create a new load combination
    int typeInd = 0;    // Combination
    int stateInd = 0;   // Servicebility
    LoadCombinationArray combinations = new LoadCombinationArray();

    LoadCombination loadCombination = document.Create.NewLoadCombination("New combination",
                                                        typeInd, stateInd, factorArray, loadCases,
                                                        combinations, loadUsages);
    if (null == loadCombination)
    {
        throw new Exception("Create a load combination failed.");
    }

    // Give the user some information
    MessageBox.Show("Load combination created successfully.", "Revit");

    return loadCombination;
}
CopyVB.NET
Private Function CreateLoadCombination(ByVal document As Autodesk.Revit.Document, ByVal loadCases As LoadCaseArray, ByVal loadUsages As LoadUsageArray) As LoadCombination
    ' Create the factor array for load combination creation
    Dim factorArray As Double() = New Double(loadCases.Size - 1) {}
    For ii As Integer = 0 To loadCases.Size - 1
        factorArray(ii) = ii + 1
    Next

    ' Create a new load combination
    Dim typeInd As Integer = 0
    ' Combination
    Dim stateInd As Integer = 0
    ' Servicebility
    Dim combinations As New LoadCombinationArray()

    Dim loadCombination As LoadCombination = document.Create.NewLoadCombination("New combination", typeInd, stateInd, factorArray, loadCases, combinations, _
    loadUsages)
    If loadCombination Is Nothing Then
        Throw New Exception("Create a load combination failed.")
    End If

    ' Give the user some information
    MessageBox.Show("Load combination created successfully.", "Revit")

    Return loadCombination
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewLoadNature Method

[image]

Revit 2010 API
Document..::.NewLoadNature Method
Document Class Example See Also Send Feedback
Creates a new instance of a LoadNature element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadNature NewLoadNature(
    string name
)
Visual Basic (Declaration)
Public Function NewLoadNature ( _
    name As String _
) As LoadNature
Visual C++
public:
LoadNature^ NewLoadNature(
    String^ name
)

Parameters

name
Type: System..::.String
The name for the Load Nature Element to create.

Return Value

If successful and there isn’t the Load Nature Element with the same name NewLoadNature returns an object for the newly created LoadNature. If such element exist it returns existing element. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
// Create a new load nature.
LoadNature nature = document.Create.NewLoadNature("New Nature");
if (null == nature)
{
    throw new Exception("Create a new load nature failed.");
}
CopyVB.NET
' Create a new load nature.
Dim nature As LoadNature = document.Create.NewLoadNature("New Nature")
If nature Is Nothing Then
    Throw New Exception("Create a new load nature failed.")
End If

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewLoadUsage Method

[image]

Revit 2010 API
Document..::.NewLoadUsage Method
Document Class Example See Also Send Feedback
Creates a new instance of a LoadUsage element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadUsage NewLoadUsage(
    string name
)
Visual Basic (Declaration)
Public Function NewLoadUsage ( _
    name As String _
) As LoadUsage
Visual C++
public:
LoadUsage^ NewLoadUsage(
    String^ name
)

Parameters

name
Type: System..::.String
The not empty name for the Load Usage Element to create.

Return Value

If successful and there isn’t the Load Usage Element with the same name NewLoadUsage returns an object for the newly created LoadUsage. If such element exist it returns existing element. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
// Create some Load usages and add them into an array
LoadUsage usage1 = document.Create.NewLoadUsage("Usage one");
LoadUsage usage2 = document.Create.NewLoadUsage("Usage two");

if (null == usage1 || null == usage2)
{
    throw new Exception("Create new load usage failed.");
}

LoadUsageArray loadUsages = new LoadUsageArray();
loadUsages.Append(usage1);
loadUsages.Append(usage2);
CopyVB.NET
' Create some Load usages and add them into an array
Dim usage1 As LoadUsage = document.Create.NewLoadUsage("Usage one")
Dim usage2 As LoadUsage = document.Create.NewLoadUsage("Usage two")

If usage1 Is Nothing OrElse usage2 Is Nothing Then
    Throw New Exception("Create new load usage failed.")
End If

Dim loadUsages As New LoadUsageArray()
loadUsages.Append(usage1)
loadUsages.Append(usage2)

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewMechanicalSystem Method

[image]

Revit 2010 API
Document..::.NewMechanicalSystem Method
Document Class See Also Send Feedback
Creates a new MEP mechanical system element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MechanicalSystem NewMechanicalSystem(
    Connector baseEquipmentConnector,
    ConnectorSet connectors,
    DuctSystemType ductSystemType
)
Visual Basic (Declaration)
Public Function NewMechanicalSystem ( _
    baseEquipmentConnector As Connector, _
    connectors As ConnectorSet, _
    ductSystemType As DuctSystemType _
) As MechanicalSystem
Visual C++
public:
MechanicalSystem^ NewMechanicalSystem(
    Connector^ baseEquipmentConnector,
    ConnectorSet^ connectors,
    DuctSystemType ductSystemType
)

Parameters

baseEquipmentConnector
Type: Autodesk.Revit.MEP..::.Connector
One connector within base equipment which is used to connect with the system. The base equipment is optional for the system, so this argument may be null. The baseEquipmentConnector should not be included in the connectors.
connectors
Type: Autodesk.Revit.MEP..::.ConnectorSet
Connectors that will connect to the system. The owner elements of these connectors will be added into system as its elements.
ductSystemType
Type: Autodesk.Revit.MEP.Enums..::.DuctSystemType
The system type.

Return Value

If creation was successful then an instance of mechanical system is returned, otherwise an exception with information will be thrown.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when calling this function outside of the Autodesk Revit MEP product.
System..::.ArgumentNullException | Thrown when the input connectors parameter value is null.
System..::.ArgumentOutOfRangeException | Thrown when the ductSystemType parameter is out of permitted scope.
System..::.ArgumentException | Thrown when some connectors can't be used to create the mechanical system. All the input connectors and base equipment connector should match system type and domain with the system, and they should not have been used in another system. The owner of BaseConnector should be a mechanical equipment, and the owner of other connectors should be a mechanical equipment or air terminal.
System..::.InvalidOperationException | Thrown when the mechanical system creation failed.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewOpening Method

[image] [image]

Revit 2010 API
Document..::.NewOpening Method
Document Class See Also Send Feedback
Creates a new opening.

Overload List

Name | Description
NewOpening(Element, CurveArray, Document..::.eRefFace) | Creates a new opening in a beam, brace and column.
NewOpening(Element, CurveArray, Boolean) | Creates a new opening in a roof, floor and ceiling.
NewOpening(Level, Level, CurveArray) | Creates a new shaft opening between a set of levels.
NewOpening(Wall, XYZ, XYZ) | Creates a rectangular opening on a wall.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewOpening Method (Element, CurveArray, Document.eRefFace)

[image]

Revit 2010 API
Document..::.NewOpening Method (Element, CurveArray, Document..::.eRefFace)
Document Class See Also Send Feedback
Creates a new opening in a beam, brace and column.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Opening NewOpening(
    Element famInstElement,
    CurveArray profile,
    Document..::.eRefFace iFace
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    famInstElement As Element, _
    profile As CurveArray, _
    iFace As Document..::.eRefFace _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Element^ famInstElement,
    CurveArray^ profile,
    Document..::.eRefFace iFace
)

Parameters

famInstElement
Type: Autodesk.Revit..::.Element
host element of the opening, can be a beam, brace and column.
profile
Type: Autodesk.Revit.Geometry..::.CurveArray
profile of the opening.
iFace
Type: Autodesk.Revit.Creation..::.Document..::.eRefFace
face on which opening is based on.

Return Value

If successful, an Opening object is returned.

Remarks

This method forms opening on a beam, brace and column.

See Also

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace


NewOpening Method (Element, CurveArray, Boolean)

[image]

Revit 2010 API
Document..::.NewOpening Method (Element, CurveArray, Boolean)
Document Class See Also Send Feedback
Creates a new opening in a roof, floor and ceiling.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Opening NewOpening(
    Element hostElement,
    CurveArray profile,
    bool bPerpendicularFace
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    hostElement As Element, _
    profile As CurveArray, _
    bPerpendicularFace As Boolean _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Element^ hostElement,
    CurveArray^ profile,
    bool bPerpendicularFace
)

Parameters

hostElement
Type: Autodesk.Revit..::.Element
Host element of the opening, can be a roof,floor or ceiling.
profile
Type: Autodesk.Revit.Geometry..::.CurveArray
Profile of the opening.
bPerpendicularFace
Type: System..::.Boolean
True if the profile is cut perpendicular to the intersecting face of the host. False if the profile is cut vertically.

Return Value

If successful, an Opening object is returned.

See Also

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace


NewOpening Method (Level, Level, CurveArray)

[image]

Revit 2010 API
Document..::.NewOpening Method (Level, Level, CurveArray)
Document Class See Also Send Feedback
Creates a new shaft opening between a set of levels.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Opening NewOpening(
    Level bottomLevel,
    Level topLevel,
    CurveArray profile
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    bottomLevel As Level, _
    topLevel As Level, _
    profile As CurveArray _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Level^ bottomLevel,
    Level^ topLevel,
    CurveArray^ profile
)

Parameters

bottomLevel
Type: Autodesk.Revit.Elements..::.Level
bottom level
topLevel
Type: Autodesk.Revit.Elements..::.Level
top level
profile
Type: Autodesk.Revit.Geometry..::.CurveArray
profile of the opening.

Return Value

If successful, an Opening object is returned.

Remarks

This method forms an opening on floor, ceiling and roof. Make sure topLevel is higher than bottomLevel, otherwise an exception will be returned.

See Also

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace


NewOpening Method (Wall, XYZ, XYZ)

[image]

Revit 2010 API
Document..::.NewOpening Method (Wall, XYZ, XYZ)
Document Class See Also Send Feedback
Creates a rectangular opening on a wall.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Opening NewOpening(
    Wall wall,
    XYZ pntStart,
    XYZ pntEnd
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    wall As Wall, _
    pntStart As XYZ, _
    pntEnd As XYZ _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Wall^ wall,
    XYZ^ pntStart,
    XYZ^ pntEnd
)

Parameters

wall
Type: Autodesk.Revit.Elements..::.Wall
Host element of the opening.
pntStart
Type: Autodesk.Revit.Geometry..::.XYZ
One corner of the rectangle.
pntEnd
Type: Autodesk.Revit.Geometry..::.XYZ
The opposite corner of the rectangle.

Return Value

If successful, an Opening object is returned.

See Also

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace


NewPathReinforcement Method

[image]

Revit 2010 API
Document..::.NewPathReinforcement Method
Document Class Example See Also Send Feedback
Creates a new instance of a Path Reinforcement element within the project

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PathReinforcement NewPathReinforcement(
    Element host,
    CurveArray curves,
    bool flip
)
Visual Basic (Declaration)
Public Function NewPathReinforcement ( _
    host As Element, _
    curves As CurveArray, _
    flip As Boolean _
) As PathReinforcement
Visual C++
public:
PathReinforcement^ NewPathReinforcement(
    Element^ host,
    CurveArray^ curves,
    bool flip
)

Parameters

host
Type: Autodesk.Revit..::.Element
The element to which the Path Reinforcement belongs. The element must be a structural floor or wall.
curves
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of curves forming a chain. Bars will be placed orthogonal to the chain with their hook ends near the chain, offset by the side cover setting. The curves must belong to the top face of the floor or the exterior face of the wall.
flip
Type: System..::.Boolean
A flag controlling the bars relative to the curves. If the curves are given in order and with consistent orientation, the bars will lie to the right of the chain if flip=false, to the left if flip=true, when viewed from above the floor or outside the wall.

Return Value

If successful, NewPathReinforcement returns an object for the newly created Rebar. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
PathReinforcement CreatePathReinforcement(Autodesk.Revit.Document document, Wall wall)
{
    // Create a geometry line in the selected wall as the path
    CurveArray curves = new CurveArray();
    LocationCurve location = wall.Location as LocationCurve;
    XYZ start = location.Curve.get_EndPoint(0);
    XYZ end = location.Curve.get_EndPoint(1);
    end.Z = end.Z;
    curves.Append(document.Application.Create.NewLineBound(start, end));

    // Begin to create the path reinforcement
    PathReinforcement rein = document.Create.NewPathReinforcement(wall, curves, true);
    if (null == rein)
    {
        throw new Exception("Create path reinforcement failed.");
    }

    // Give the user some information
    MessageBox.Show("Create path reinforcement succeed.", "Revit");

    return rein;
}
CopyVB.NET
Private Function CreatePathReinforcement(ByVal document As Autodesk.Revit.Document, ByVal wall As Wall) As PathReinforcement
    ' Create a geometry line in the selected wall as the path
    Dim curves As New CurveArray()
    Dim location As LocationCurve = TryCast(wall.Location, LocationCurve)
    Dim start As Autodesk.Revit.Geometry.XYZ = location.Curve.EndPoint(0)
    Dim [end] As Autodesk.Revit.Geometry.XYZ = location.Curve.EndPoint(1)
    [end].Z = [end].Z
    curves.Append(document.Application.Create.NewLineBound(start, [end]))

    ' Begin to create the path reinforcement
    Dim rein As PathReinforcement = document.Create.NewPathReinforcement(wall, curves, True)
    If rein Is Nothing Then
        Throw New Exception("Create path reinforcement failed.")
    End If

    ' Give the user some information
    MessageBox.Show("Create path reinforcement succeed.", "Revit")

    Return rein
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewPipe Method

[image] [image]

Revit 2010 API
Document..::.NewPipe Method
Document Class See Also Send Feedback
Adds a new pipe into the document.

Overload List

Name | Description
NewPipe(XYZ, XYZ, PipeType) | Adds a new pipe into the document, using two points and pipe type.
NewPipe(XYZ, Connector, PipeType) | Adds a new pipe into the document, using a point, connector and pipe type.
NewPipe(Connector, Connector, PipeType) | Adds a new pipe into the document, using two connectors and duct type.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewPipe Method (XYZ, XYZ, PipeType)

[image]

Revit 2010 API
Document..::.NewPipe Method (XYZ, XYZ, PipeType)
Document Class See Also Send Feedback
Adds a new pipe into the document, using two points and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Pipe NewPipe(
    XYZ point1,
    XYZ point2,
    PipeType pipeType
)
Visual Basic (Declaration)
Public Function NewPipe ( _
    point1 As XYZ, _
    point2 As XYZ, _
    pipeType As PipeType _
) As Pipe
Visual C++
public:
Pipe^ NewPipe(
    XYZ^ point1,
    XYZ^ point2,
    PipeType^ pipeType
)

Parameters

point1
Type: Autodesk.Revit.Geometry..::.XYZ
The first point of the pipe.
point2
Type: Autodesk.Revit.Geometry..::.XYZ
The second point of the pipe.
pipeType
Type: Autodesk.Revit.MEP..::.PipeType
The type of the pipe.

Return Value

If creation was successful then a new pipe is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument point1 or point2 is null.
System..::.InvalidOperationException | Thrown when the pipe cannot be created or regenerate fails.

See Also

Document Class
NewPipe Overload
Autodesk.Revit.Creation Namespace


NewPipe Method (XYZ, Connector, PipeType)

[image]

Revit 2010 API
Document..::.NewPipe Method (XYZ, Connector, PipeType)
Document Class See Also Send Feedback
Adds a new pipe into the document, using a point, connector and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Pipe NewPipe(
    XYZ point,
    Connector connector,
    PipeType pipeType
)
Visual Basic (Declaration)
Public Function NewPipe ( _
    point As XYZ, _
    connector As Connector, _
    pipeType As PipeType _
) As Pipe
Visual C++
public:
Pipe^ NewPipe(
    XYZ^ point,
    Connector^ connector,
    PipeType^ pipeType
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
The first point of the pipe.
connector
Type: Autodesk.Revit.MEP..::.Connector
The connector to be connected to the pipe.
pipeType
Type: Autodesk.Revit.MEP..::.PipeType
The type of the pipe.

Return Value

If creation was successful then a new pipe is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connector is a fitting or equipment connector of the correct domain, and if the connector’s direction matches the direction of the pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector if necessary. If the connector's type, domain, or direction does not match the direction of the duct to be created, the position of the input connector will govern the endpoints of the pipe, but no connection will be established.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument point or connector is null.
System..::.InvalidOperationException | Thrown when the pipe cannot be created or regenerate fails.

See Also

Document Class
NewPipe Overload
Autodesk.Revit.Creation Namespace


NewPipe Method (Connector, Connector, PipeType)

[image]

Revit 2010 API
Document..::.NewPipe Method (Connector, Connector, PipeType)
Document Class See Also Send Feedback
Adds a new pipe into the document, using two connectors and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Pipe NewPipe(
    Connector connector1,
    Connector connector2,
    PipeType pipeType
)
Visual Basic (Declaration)
Public Function NewPipe ( _
    connector1 As Connector, _
    connector2 As Connector, _
    pipeType As PipeType _
) As Pipe
Visual C++
public:
Pipe^ NewPipe(
    Connector^ connector1,
    Connector^ connector2,
    PipeType^ pipeType
)

Parameters

connector1
Type: Autodesk.Revit.MEP..::.Connector
The first connector to be connected to the pipe.
connector2
Type: Autodesk.Revit.MEP..::.Connector
The second connector to be connected to the pipe.
pipeType
Type: Autodesk.Revit.MEP..::.PipeType
The type of the pipe.

Return Value

If creation was successful then a new pipe is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connectors are fitting or equipment connectors of the correct domain, and if the connectors’ direction match the direction of the pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, or direction does not match the direction of the duct to be created, the position of the input connectors will govern the endpoints of the pipe, but no connection will be established.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument connector1 or connector2 is null.
System..::.InvalidOperationException | Thrown when the pipe cannot be created or regenerate fails.

See Also

Document Class
NewPipe Overload
Autodesk.Revit.Creation Namespace


NewPipingSystem Method

[image]

Revit 2010 API
Document..::.NewPipingSystem Method
Document Class See Also Send Feedback
Creates a new MEP piping system element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipingSystem NewPipingSystem(
    Connector baseEquipmentConnector,
    ConnectorSet connectors,
    PipeSystemType pipingSystemType
)
Visual Basic (Declaration)
Public Function NewPipingSystem ( _
    baseEquipmentConnector As Connector, _
    connectors As ConnectorSet, _
    pipingSystemType As PipeSystemType _
) As PipingSystem
Visual C++
public:
PipingSystem^ NewPipingSystem(
    Connector^ baseEquipmentConnector,
    ConnectorSet^ connectors,
    PipeSystemType pipingSystemType
)

Parameters

baseEquipmentConnector
Type: Autodesk.Revit.MEP..::.Connector
One connector within base equipment which is used to connect with the system. The base equipment is optional for the system, so this argument may be null. The baseEquipmentConnector should not be included in the connectors.
connectors
Type: Autodesk.Revit.MEP..::.ConnectorSet
Connectors that will connect to the system. The owner elements of these connectors will be added into system as its elements.
pipingSystemType
Type: Autodesk.Revit.MEP.Enums..::.PipeSystemType
The System type.

Return Value

If creation was successful then an instance of piping system is returned, otherwise an exception with information will be thrown.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when calling this function outside of the Autodesk Revit MEP product.
System..::.ArgumentNullException | Thrown when the connectors parameter value is null.
System..::.ArgumentOutOfRangeException | Thrown when the pipingSystemType parameter value is out of permitted scope.
System..::.ArgumentException | Thrown when some connectors can't be used to create the mechanical system. All the input connectors and base equipment connector should match system type and domain with the system, and they should not have been used in another system.
System..::.InvalidOperationException | Thrown when the piping system creation failed.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewPointBoundaryConditions Method

[image]

Revit 2010 API
Document..::.NewPointBoundaryConditions Method
Document Class Example See Also Send Feedback
Creates a new Point BoundaryConditions Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundaryConditions NewPointBoundaryConditions(
    Reference reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus,
    TranslationRotationValue Y_Rotation,
    double Y_RotationSpringModulus,
    TranslationRotationValue Z_Rotation,
    double Z_RotationSpringModulus
)
Visual Basic (Declaration)
Public Function NewPointBoundaryConditions ( _
    reference As Reference, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double, _
    X_Rotation As TranslationRotationValue, _
    X_RotationSpringModulus As Double, _
    Y_Rotation As TranslationRotationValue, _
    Y_RotationSpringModulus As Double, _
    Z_Rotation As TranslationRotationValue, _
    Z_RotationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewPointBoundaryConditions(
    Reference^ reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus,
    TranslationRotationValue Y_Rotation,
    double Y_RotationSpringModulus,
    TranslationRotationValue Z_Rotation,
    double Z_RotationSpringModulus
)

Parameters

reference
Type: Autodesk.Revit.Geometry..::.Reference
A Geometry reference to a Beam's, Brace's or Column's analytical line end.
X_Translation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".
X_Rotation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the option for rotation about the X axis.
X_RotationSpringModulus
Type: System..::.Double
Rotation Spring Modulus for X axis. Ignored if X_Rotation is not "Spring".
Y_Rotation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the option for rotation about the Y axis.
Y_RotationSpringModulus
Type: System..::.Double
Rotation Spring Modulus for Y axis. Ignored if Y_Rotation is not "Spring".
Z_Rotation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the option for rotation about the Z axis.
Z_RotationSpringModulus
Type: System..::.Double
Rotation Spring Modulus for Z axis. Ignored if Y_Rotation is not "Spring".

Return Value

If successful, NewPointBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 0 - "Point". Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
bool CreatePointBoundaryCondition(Autodesk.Revit.Document document, FamilyInstance column)
{
    // Get the start point reference of the column
    Reference startReference = null;
    AnalyticalModelFrame analyticalModel = column.AnalyticalModel as AnalyticalModelFrame;

    if (null != analyticalModel)
    {
        startReference = analyticalModel.Curve.get_EndPointReference(0);
    }
    else
    {
        throw new Exception("Cannot get end point for selected column");
    }

    // Get the revit creation document
    Autodesk.Revit.Creation.Document docCreation = document.Create;

    // Create the Point Boundary Conditions for the start point
    BoundaryConditions condition = docCreation.NewPointBoundaryConditions(startReference,
                                                                          TranslationRotationValue.Fixed, 0,
                                                                          TranslationRotationValue.Fixed, 0,
                                                                          TranslationRotationValue.Fixed, 0,
                                                                          TranslationRotationValue.Fixed, 0,
                                                                          TranslationRotationValue.Fixed, 0,
                                                                          TranslationRotationValue.Fixed, 0);
    if (null == condition)
    {
        throw new Exception("Can't create the point boundary condition for selected column start point.");
    }

    // Give the user some information
    MessageBox.Show("Point boundary condition created successfully.", "Revit");

    return (null != condition);
}
CopyVB.NET
Private Function CreatePointBoundaryCondition(ByVal document As Autodesk.Revit.Document, ByVal column As Autodesk.Revit.Elements.FamilyInstance) As Boolean
    ' Get the start point reference of the column
    Dim startReference As Reference = Nothing
    Dim analyticalModel As AnalyticalModelFrame = TryCast(column.AnalyticalModel, AnalyticalModelFrame)

    If analyticalModel IsNot Nothing Then
        startReference = analyticalModel.Curve.EndPointReference(0)
    Else
        Throw New Exception("Cannot get end point for selected column")
    End If

    ' Get the revit creation document
    Dim docCreation As Autodesk.Revit.Creation.Document = document.Create

    ' Create the Point Boundary Conditions for the start point
    Dim condition As Autodesk.Revit.Elements.BoundaryConditions = docCreation.NewPointBoundaryConditions(startReference, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
    0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
    0)
    If condition Is Nothing Then
        Throw New Exception("Can't create the point boundary condition for selected column start point.")
    End If

    ' Give the user some information
    MessageBox.Show("Point boundary condition created successfully.", "Revit")

    Return (condition IsNot Nothing)
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewPointLoad Method

[image] [image]

Revit 2010 API
Document..::.NewPointLoad Method
Document Class See Also Send Feedback
Creates a new point load within the project.

Overload List

Name | Description
NewPointLoad(Reference, XYZ, XYZ, Boolean, PointLoadType, SketchPlane) | Creates a new hosted point load within the project.
NewPointLoad(XYZ, XYZ, XYZ, Boolean, PointLoadType, SketchPlane) | Creates a new unhosted point load within the project.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewPointLoad Method (Reference, XYZ, XYZ, Boolean, PointLoadType, SketchPlane)

[image]

Revit 2010 API
Document..::.NewPointLoad Method (Reference, XYZ, XYZ, Boolean, PointLoadType, SketchPlane)
Document Class See Also Send Feedback
Creates a new hosted point load within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PointLoad NewPointLoad(
    Reference reference,
    XYZ force,
    XYZ moment,
    bool isReaction,
    PointLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewPointLoad ( _
    reference As Reference, _
    force As XYZ, _
    moment As XYZ, _
    isReaction As Boolean, _
    symbol As PointLoadType, _
    plane As SketchPlane _
) As PointLoad
Visual C++
public:
PointLoad^ NewPointLoad(
    Reference^ reference,
    XYZ^ force,
    XYZ^ moment,
    bool isReaction,
    PointLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

reference
Type: Autodesk.Revit.Geometry..::.Reference
The Geometry reference to Beam's, Brace's, Column's, analytical line's end.
force
Type: Autodesk.Revit.Geometry..::.XYZ
The 3d force.
moment
Type: Autodesk.Revit.Geometry..::.XYZ
The 3d moment.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.Symbols..::.PointLoadType
The symbol of the PointLoad.
plane
Type: Autodesk.Revit.Elements..::.SketchPlane
Indicate the work plane of the PointLoad.

Return Value

If successful, NewPointLoad returns an object for the newly created PointLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
NewPointLoad Overload
Autodesk.Revit.Creation Namespace


NewPointLoad Method (XYZ, XYZ, XYZ, Boolean, PointLoadType, SketchPlane)

[image]

Revit 2010 API
Document..::.NewPointLoad Method (XYZ, XYZ, XYZ, Boolean, PointLoadType, SketchPlane)
Document Class Example See Also Send Feedback
Creates a new unhosted point load within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PointLoad NewPointLoad(
    XYZ point,
    XYZ force,
    XYZ moment,
    bool isReaction,
    PointLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewPointLoad ( _
    point As XYZ, _
    force As XYZ, _
    moment As XYZ, _
    isReaction As Boolean, _
    symbol As PointLoadType, _
    plane As SketchPlane _
) As PointLoad
Visual C++
public:
PointLoad^ NewPointLoad(
    XYZ^ point,
    XYZ^ force,
    XYZ^ moment,
    bool isReaction,
    PointLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
The point of the PointLoad application.
force
Type: Autodesk.Revit.Geometry..::.XYZ
The 3d force.
moment
Type: Autodesk.Revit.Geometry..::.XYZ
The 3d moment.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.Symbols..::.PointLoadType
The symbol of the PointLoad.
plane
Type: Autodesk.Revit.Elements..::.SketchPlane
Indicate the work plane of the PointLoad.

Return Value

If successful, NewPointLoad returns an object for the newly created PointLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
//Define the location at which the PointLoad is applied.
XYZ point = new XYZ(0, 0, 4);
//Define the 3d force.
XYZ force = new XYZ(0, 0, -1);
//Define the 3d moment.
XYZ moment = new XYZ(0, 0, 0);
//Set to True if you wish to create the reaction
System.Boolean isReaction = true;

PointLoad pointLoad = document.Create.NewPointLoad(point, force, moment, isReaction, null, null);
CopyVB.NET
'Define the location at which the PointLoad is applied.
Dim point As New Autodesk.Revit.Geometry.XYZ(0, 0, 4)
'Define the 3d force.
Dim force As New Autodesk.Revit.Geometry.XYZ(0, 0, -1)
'Define the 3d moment.
Dim moment As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
'Set to True if you wish to create the reaction
Dim isReaction As Boolean = True

Dim pointLoad As Autodesk.Revit.Elements.PointLoad = document.Create.NewPointLoad(point, force, moment, isReaction, Nothing, Nothing)

See Also

Document Class
NewPointLoad Overload
Autodesk.Revit.Creation Namespace


NewRebar Method

[image] [image]

Revit 2010 API
Document..::.NewRebar Method
Document Class See Also Send Feedback
Creates a new instance of a Rebar element within the project.

Overload List

Name | Description
NewRebar(RebarStyle, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, CurveArray, RebarHookOrientation, RebarHookOrientation, Boolean, Boolean) | Creates a new instance of a Rebar element within the project.
NewRebar(RebarShape, RebarBarType, Element, XYZ, XYZ, XYZ) | Creates a new Rebar, as an instance of a RebarShape. The instance will have the default shape parameters from the RebarShape, and its location is based on the bounding box of the shape in the shape definition. Hooks are removed from the shape before computing its bounding box. If appropriate hooks can be found in the document, they will be assigned arbitrarily.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewRebar Method (RebarStyle, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, CurveArray, RebarHookOrientation, RebarHookOrientation, Boolean, Boolean)

[image]

Revit 2010 API
Document..::.NewRebar Method (RebarStyle, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, CurveArray, RebarHookOrientation, RebarHookOrientation, Boolean, Boolean)
Document Class Example See Also Send Feedback
Creates a new instance of a Rebar element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Rebar NewRebar(
    RebarStyle style,
    RebarBarType rebarType,
    RebarHookType startHook,
    RebarHookType endHook,
    Element host,
    XYZ norm,
    CurveArray curves,
    RebarHookOrientation startHookOrient,
    RebarHookOrientation endHookOrient,
    bool useExistingShapeIfPossible,
    bool createNewShape
)
Visual Basic (Declaration)
Public Function NewRebar ( _
    style As RebarStyle, _
    rebarType As RebarBarType, _
    startHook As RebarHookType, _
    endHook As RebarHookType, _
    host As Element, _
    norm As XYZ, _
    curves As CurveArray, _
    startHookOrient As RebarHookOrientation, _
    endHookOrient As RebarHookOrientation, _
    useExistingShapeIfPossible As Boolean, _
    createNewShape As Boolean _
) As Rebar
Visual C++
public:
Rebar^ NewRebar(
    RebarStyle style,
    RebarBarType^ rebarType,
    RebarHookType^ startHook,
    RebarHookType^ endHook,
    Element^ host,
    XYZ^ norm,
    CurveArray^ curves,
    RebarHookOrientation startHookOrient,
    RebarHookOrientation endHookOrient,
    bool useExistingShapeIfPossible,
    bool createNewShape
)

Parameters

style
Type: Autodesk.Revit.Structural.Enums..::.RebarStyle
The usage of the bar, "standard" or "stirrup/tie".
rebarType
Type: Autodesk.Revit.Symbols..::.RebarBarType
The element of RebarBarType that defines bar diameter, bend radius and material of the rebar.
startHook
Type: Autodesk.Revit.Symbols..::.RebarHookType
The element of RebarHookType that defines the hook angle and radius to be inserted before the first curve of the rebar. If this parameter is null, it means to create a rebar with NONE hook type.
endHook
Type: Autodesk.Revit.Symbols..::.RebarHookType
The element of RebarHookType that defines the hook angle and radius to be inserted after the last curve segment of the rebar. If this parameter is null, it means to create a rebar with NONE hook type.
host
Type: Autodesk.Revit..::.Element
The element to which the rebar belongs. The element must be a structural wall, floor, beam, brace, foundation or structural column.
norm
Type: Autodesk.Revit.Geometry..::.XYZ
The normal to the plane that the rebar curves lie on.
curves
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of curves that define the shape of the rebar curves. They must belong to the plane defined by the normal and origin. Bends and hooks should not be included in the array of curves.
startHookOrient
Type: Autodesk.Revit.Structural.Enums..::.RebarHookOrientation
Defines the orientation of the hook plane at the start of the rebar with respect to the orientation of the first curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
endHookOrient
Type: Autodesk.Revit.Structural.Enums..::.RebarHookOrientation
Defines the orientation of the hook plane at the end of the rebar with respect to the orientation of the last curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
useExistingShapeIfPossible
Type: System..::.Boolean
Attempts to assign a RebarShape from those existing in the document. If no shape matches, NewRebar returns null or creates a new shape, according to the parameter createNewShape. When both parameters are "true", the behavior is the same as sketching rebar in the UI. At least one of these parameters must be "true".
createNewShape
Type: System..::.Boolean
Creates a shape in the document to match the curves, hooks, and style specified, and assigns it to the new rebar instance. Shape creation will not succeed unless one or more other shapes already exist in the document, and these shapes have enough shape parameters to define a shape for these curves.

Return Value

If successful, NewRebar returns an object for the newly created Rebar. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
 Rebar CreateRebar(Autodesk.Revit.Document document, FamilyInstance column, RebarBarType barType, RebarHookType hookType)
{
    // Define the rebar geometry information - Line rebar
    LocationPoint location = column.Location as LocationPoint;
    XYZ origin = location.Point;
    XYZ normal = new XYZ(1, 0, 0);
    XYZ rebarLineEnd = new XYZ(origin.X, origin.Y, origin.Z + 9);
    Line rebarLine = document.Application.Create.NewLineBound(origin, rebarLineEnd);

    // Create the line rebar
    CurveArray curves = new CurveArray();
    curves.Append(rebarLine);

    Rebar rebar = document.Create.NewRebar(Autodesk.Revit.Structural.Enums.RebarStyle.Standard, barType, hookType, hookType,
                        column, origin, curves, RebarHookOrientation.Right, RebarHookOrientation.Left, true, true);

    if (null != rebar)
    {
        // set specific layout for new rebar
        Parameter paramLayout = rebar.get_Parameter(BuiltInParameter.REBAR_ELEM_LAYOUT_RULE);
        paramLayout.Set(1); // 1 = Fixed Number
        Parameter paramNum = rebar.get_Parameter(BuiltInParameter.REBAR_ELEM_QUANTITY_OF_BARS);
        paramNum.Set(10);
        rebar.ArrayLength = 1.5;
    }

    return rebar;
}
CopyVB.NET
Private Function CreateRebar(ByVal document As Autodesk.Revit.Document, ByVal column As Autodesk.Revit.Elements.FamilyInstance, ByVal barType As Autodesk.Revit.Symbols.RebarBarType, ByVal hookType As Autodesk.Revit.Symbols.RebarHookType) As Autodesk.Revit.Elements.Rebar
    ' Define the rebar geometry information - Line rebar
    Dim location As LocationPoint = TryCast(column.Location, LocationPoint)
    Dim origin As Autodesk.Revit.Geometry.XYZ = location.Point
    Dim normal As New Autodesk.Revit.Geometry.XYZ(1, 0, 0)
    Dim rebarLineEnd As New Autodesk.Revit.Geometry.XYZ(origin.X, origin.Y, origin.Z + 9)
    Dim rebarLine As Line = document.Application.Create.NewLineBound(origin, rebarLineEnd)

    ' Create the line rebar
    Dim curves As New CurveArray()
    curves.Append(rebarLine)

    Dim rebar As Autodesk.Revit.Elements.Rebar = document.Create.NewRebar(Autodesk.Revit.Structural.Enums.RebarStyle.Standard, barType, hookType, hookType, column, origin, _
    curves, Autodesk.Revit.Structural.Enums.RebarHookOrientation.Right, Autodesk.Revit.Structural.Enums.RebarHookOrientation.Left, True, True)

    If rebar IsNot Nothing Then
        ' set specific layout for new rebar
        Dim paramLayout As Parameter = rebar.Parameter(BuiltInParameter.REBAR_ELEM_LAYOUT_RULE)
        paramLayout.[Set](1)
        ' 1 = Fixed Number
        Dim paramNum As Parameter = rebar.Parameter(BuiltInParameter.REBAR_ELEM_QUANTITY_OF_BARS)
        paramNum.[Set](10)
        rebar.ArrayLength = 1.5
    End If

    Return rebar
End Function

See Also

Document Class
NewRebar Overload
Autodesk.Revit.Creation Namespace


NewRebar Method (RebarShape, RebarBarType, Element, XYZ, XYZ, XYZ)

[image]

Revit 2010 API
Document..::.NewRebar Method (RebarShape, RebarBarType, Element, XYZ, XYZ, XYZ)
Document Class See Also Send Feedback
Creates a new Rebar, as an instance of a RebarShape. The instance will have the default shape parameters from the RebarShape, and its location is based on the bounding box of the shape in the shape definition. Hooks are removed from the shape before computing its bounding box. If appropriate hooks can be found in the document, they will be assigned arbitrarily.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Rebar NewRebar(
    RebarShape rebarShape,
    RebarBarType rebarType,
    Element host,
    XYZ origin,
    XYZ xVec,
    XYZ yVec
)
Visual Basic (Declaration)
Public Function NewRebar ( _
    rebarShape As RebarShape, _
    rebarType As RebarBarType, _
    host As Element, _
    origin As XYZ, _
    xVec As XYZ, _
    yVec As XYZ _
) As Rebar
Visual C++
public:
Rebar^ NewRebar(
    RebarShape^ rebarShape,
    RebarBarType^ rebarType,
    Element^ host,
    XYZ^ origin,
    XYZ^ xVec,
    XYZ^ yVec
)

Parameters

rebarShape
Type: Autodesk.Revit.Symbols..::.RebarShape
The shape type of the Rebar.
rebarType
Type: Autodesk.Revit.Symbols..::.RebarBarType
The element of RebarBarType that defines bar diameter, bend radius and material of the rebar.
host
Type: Autodesk.Revit..::.Element
The element to which the rebar belongs. The element must be a structural wall, floor, beam, brace, foundation or structural column.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The lower-left corner of the shape's bounding box will be placed at this point in the project.
xVec
Type: Autodesk.Revit.Geometry..::.XYZ
The x-axis in the shape definition will be mapped to this direction in the project.
yVec
Type: Autodesk.Revit.Geometry..::.XYZ
The y-axis in the shape definition will be mapped to this direction in the project.

See Also

Document Class
NewRebar Overload
Autodesk.Revit.Creation Namespace


NewRebarShape Method

[image]

Revit 2010 API
Document..::.NewRebarShape Method
Document Class See Also Send Feedback
Creates a new instance of a Rebar Shape, which defines the shape of the rebar.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarShape NewRebarShape()
Visual Basic (Declaration)
Public Function NewRebarShape As RebarShape
Visual C++
public:
RebarShape^ NewRebarShape()

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewRoom Method

[image] [image]

Revit 2010 API
Document..::.NewRoom Method
Document Class See Also Send Feedback
Creates a new room.

Overload List

Name | Description
NewRoom(Phase) | Creates a new unplaced room and with an assigned phase.
NewRoom(Level, UV) | Creates a new room on a level at a specified point.
NewRoom(Room, PlanCircuit) | Creates a new room within the confines of a plan circuit, or places an unplaced room within the confines of the plan circuit.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewRoom Method (Phase)

[image]

Revit 2010 API
Document..::.NewRoom Method (Phase)
Document Class See Also Send Feedback
Creates a new unplaced room and with an assigned phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Room NewRoom(
    Phase phase
)
Visual Basic (Declaration)
Public Function NewRoom ( _
    phase As Phase _
) As Room
Visual C++
public:
Room^ NewRoom(
    Phase^ phase
)

Parameters

phase
Type: Autodesk.Revit.Elements..::.Phase
The phase in which the room is to exist.

Return Value

If successful the new room , otherwise null.

See Also

Document Class
NewRoom Overload
Autodesk.Revit.Creation Namespace


NewRoom Method (Level, UV)

[image]

Revit 2010 API
Document..::.NewRoom Method (Level, UV)
Document Class Example See Also Send Feedback
Creates a new room on a level at a specified point.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Room NewRoom(
    Level level,
    UV point
)
Visual Basic (Declaration)
Public Function NewRoom ( _
    level As Level, _
    point As UV _
) As Room
Visual C++
public:
Room^ NewRoom(
    Level^ level,
    UV^ point
)

Parameters

level
Type: Autodesk.Revit.Elements..::.Level
The level on which the room is to exist.
point
Type: Autodesk.Revit.Geometry..::.UV
A 2D point that dictates the location of the room on that specified level.

Return Value

If successful a the new room will be returned, otherwise null.

Examples

CopyC#
Room CreateRoom(Autodesk.Revit.Document document, Level level)
{
    // Create a UV structure which determines the room location
    UV roomLocation = new UV(0, 0);

    // Create a new room
    Room room = document.Create.NewRoom(level, roomLocation);
    if (null == room)
    {
        throw new Exception("Create a new room failed.");
    }

    return room;
}
CopyVB.NET
Private Function CreateRoom(ByVal document As Autodesk.Revit.Document, ByVal level As Autodesk.Revit.Elements.Level) As Room
    ' Create a UV structure which determines the room location
    Dim roomLocation As New Autodesk.Revit.Geometry.UV(0, 0)

    ' Create a new room
    Dim room As Room = document.Create.NewRoom(level, roomLocation)
    If room Is Nothing Then
        Throw New Exception("Create a new room failed.")
    End If

    Return room
End Function

See Also

Document Class
NewRoom Overload
Autodesk.Revit.Creation Namespace


NewRoom Method (Room, PlanCircuit)

[image]

Revit 2010 API
Document..::.NewRoom Method (Room, PlanCircuit)
Document Class Example See Also Send Feedback
Creates a new room within the confines of a plan circuit, or places an unplaced room within the confines of the plan circuit.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Room NewRoom(
    Room room,
    PlanCircuit circuit
)
Visual Basic (Declaration)
Public Function NewRoom ( _
    room As Room, _
    circuit As PlanCircuit _
) As Room
Visual C++
public:
Room^ NewRoom(
    Room^ room,
    PlanCircuit^ circuit
)

Parameters

room
Type: Autodesk.Revit.Elements..::.Room
The room which you want to locate in the circuit. Pass null to create a new room.
circuit
Type: Autodesk.Revit..::.PlanCircuit
The circuit in which you want to locate a room.

Return Value

If successful the room is returned, otherwise null.

Examples

CopyC#
Room InsertNewRoomInPlanCircuit(Autodesk.Revit.Document document, Level level, Phase newConstructionPhase)
{
    // create room using Phase
    Room newScheduleRoom = document.Create.NewRoom(newConstructionPhase);

    // set the Room Number and Name
    string newRoomNumber = "101";
    string newRoomName = "Class Room 1";
    newScheduleRoom.Name = newRoomName;
    newScheduleRoom.Number = newRoomNumber;

    // Get a PlanCircuit
    PlanCircuit planCircuit = null;
    // first get the plan topology for given level
    PlanTopology planTopology = document.get_PlanTopology(level);

    // Iterate circuits in this plan topology
    foreach (PlanCircuit circuit in planTopology.Circuits)
    {
        // get the first circuit we find
        if (null != circuit)
        {
            planCircuit = circuit;
            break;
        }
    }

    Room newRoom2 = null;
    if (null != planCircuit)
    {
        // The input room must exist only in the room schedule, meaning that it does not display in any plan view.
        newRoom2 = document.Create.NewRoom(newScheduleRoom, planCircuit);
        // a model room with the same name and number is created in the view where the PlanCircuit is located
        if (null != newRoom2)
        {
            // Give the user some information
            MessageBox.Show("Room placed in Plan Circuit successfully.", "Revit");
        }
    }

    return newRoom2;
}
CopyVB.NET
Private Function InsertNewRoomInPlanCircuit(ByVal document As Autodesk.Revit.Document, ByVal level As Autodesk.Revit.Elements.Level, ByVal newConstructionPhase As Phase) As Room
    ' create room using Phase
    Dim newScheduleRoom As Room = document.Create.NewRoom(newConstructionPhase)

    ' set the Room Number and Name
    Dim newRoomNumber As String = "101"
    Dim newRoomName As String = "Class Room 1"
    newScheduleRoom.Name = newRoomName
    newScheduleRoom.Number = newRoomNumber

    ' Get a PlanCircuit
    Dim planCircuit As Autodesk.Revit.PlanCircuit = Nothing
    ' first get the plan topology for given level
    Dim planTopology As Autodesk.Revit.PlanTopology = document.PlanTopology(level)

    ' Iterate circuits in this plan topology
    For Each circuit As Autodesk.Revit.PlanCircuit In planTopology.Circuits
        ' get the first circuit we find
        If circuit IsNot Nothing Then
            planCircuit = circuit
            Exit For
        End If
    Next

    Dim newRoom2 As Room = Nothing
    If planCircuit IsNot Nothing Then
        ' The input room must exist only in the room schedule, meaning that it does not display in any plan view.
        newRoom2 = document.Create.NewRoom(newScheduleRoom, planCircuit)
        ' a model room with the same name and number is created in the view where the PlanCircuit is located
        If newRoom2 IsNot Nothing Then
            ' Give the user some information
            MessageBox.Show("Room placed in Plan Circuit successfully.", "Revit")
        End If
    End If

    Return newRoom2
End Function

Exceptions

Exception | Condition
System..::.InvalidOperationException | If the existing room is already placed.

See Also

Document Class
NewRoom Overload
Autodesk.Revit.Creation Namespace


NewRoomBoundaryLines Method

[image]

Revit 2010 API
Document..::.NewRoomBoundaryLines Method
Document Class See Also Send Feedback
Creates a new boundary line as an Room border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelCurveArray NewRoomBoundaryLines(
    SketchPlane sketchPlane,
    CurveArray curves,
    View view
)
Visual Basic (Declaration)
Public Function NewRoomBoundaryLines ( _
    sketchPlane As SketchPlane, _
    curves As CurveArray, _
    view As View _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ NewRoomBoundaryLines(
    SketchPlane^ sketchPlane,
    CurveArray^ curves,
    View^ view
)

Parameters

sketchPlane
Type: Autodesk.Revit.Elements..::.SketchPlane
The sketch plan
curves
Type: Autodesk.Revit.Geometry..::.CurveArray
The geometry curves on which the boundary lines are
view
Type: Autodesk.Revit.Elements..::.View
The View for the new Room

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewRooms Method

[image] [image]

Revit 2010 API
Document..::.NewRooms Method
Document Class See Also Send Feedback
Creates one or more rooms.

Overload List

Name | Description
NewRooms(Level) | Creates new rooms in each plan circuit found in the given level in the last phase.
NewRooms(List<(Of <(RoomCreationData>)>)) | Creates new rooms using the specified placement data.
NewRooms(Level, Phase) | Creates new rooms in each plan circuit found in the given level in the given phase.
NewRooms(Phase, Int32) | Creates new unplaced rooms in the given phase.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewRooms Method (Level)

[image]

Revit 2010 API
Document..::.NewRooms Method (Level)
Document Class See Also Send Feedback
Creates new rooms in each plan circuit found in the given level in the last phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewRooms(
    Level level
)
Visual Basic (Declaration)
Public Function NewRooms ( _
    level As Level _
) As ElementSet
Visual C++
public:
ElementSet^ NewRooms(
    Level^ level
)

Parameters

level
Type: Autodesk.Revit.Elements..::.Level
The level from which the circuits are found.

Return Value

If successful an Element set which contain the rooms created should be returned, otherwise null.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved.
System..::.InvalidOperationException | If the phase is invalid, or regeneration fails at the end of the creation.

See Also

Document Class
NewRooms Overload
Autodesk.Revit.Creation Namespace


NewRooms Method (List(RoomCreationData))

[image]

Revit 2010 API
Document..::.NewRooms Method (List<(Of <(RoomCreationData>)>))
Document Class See Also Send Feedback
Creates new rooms using the specified placement data.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewRooms(
    List<RoomCreationData> dataList
)
Visual Basic (Declaration)
Public Function NewRooms ( _
    dataList As List(Of RoomCreationData) _
) As ElementSet
Visual C++
public:
ElementSet^ NewRooms(
    List<RoomCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::.List <(Of <( RoomCreationData >)>)
A list of RoomCreationData which wraps the creation arguments of the rooms to be created.

Return Value

If successful an ElementSet contains the rooms should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
System..::.ArgumentNullException | One or more of the RoomCreationData's level or point is null.
System..::.InvalidOperationException | The relevant room tag is not created successfully, or regeneration fails at the end of the batch creation.

See Also

Document Class
NewRooms Overload
Autodesk.Revit.Creation Namespace


NewRooms Method (Level, Phase)

[image]

Revit 2010 API
Document..::.NewRooms Method (Level, Phase)
Document Class See Also Send Feedback
Creates new rooms in each plan circuit found in the given level in the given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewRooms(
    Level level,
    Phase phase
)
Visual Basic (Declaration)
Public Function NewRooms ( _
    level As Level, _
    phase As Phase _
) As ElementSet
Visual C++
public:
ElementSet^ NewRooms(
    Level^ level,
    Phase^ phase
)

Parameters

level
Type: Autodesk.Revit.Elements..::.Level
The level from which the circuits are found.
phase
Type: Autodesk.Revit.Elements..::.Phase
The phase on which the room is to exist.

Return Value

If successful an Element set which contains the rooms should be returned, otherwise the exception will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved.
System..::.InvalidOperationException | If the phase is invalid, or regeneration fails at the end of the creation.

See Also

Document Class
NewRooms Overload
Autodesk.Revit.Creation Namespace


NewRooms Method (Phase, Int32)

[image]

Revit 2010 API
Document..::.NewRooms Method (Phase, Int32)
Document Class See Also Send Feedback
Creates new unplaced rooms in the given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewRooms(
    Phase phase,
    int count
)
Visual Basic (Declaration)
Public Function NewRooms ( _
    phase As Phase, _
    count As Integer _
) As ElementSet
Visual C++
public:
ElementSet^ NewRooms(
    Phase^ phase,
    int count
)

Parameters

phase
Type: Autodesk.Revit.Elements..::.Phase
The phase on which the rooms are to exist.
count
Type: System..::.Int32
The number of the rooms to be created.

Return Value

If successful an Element set which contain the rooms should be returned, otherwise the exception will be thrown.

Exceptions

Exception | Condition
System..::.InvalidOperationException | If the room can not be created successfully or regeneration fails at the end of the creation.

See Also

Document Class
NewRooms Overload
Autodesk.Revit.Creation Namespace


NewRoomTag Method

[image]

Revit 2010 API
Document..::.NewRoomTag Method
Document Class Example See Also Send Feedback
Creates a new RoomTag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RoomTag NewRoomTag(
    Room room,
    UV point,
    View view
)
Visual Basic (Declaration)
Public Function NewRoomTag ( _
    room As Room, _
    point As UV, _
    view As View _
) As RoomTag
Visual C++
public:
RoomTag^ NewRoomTag(
    Room^ room,
    UV^ point,
    View^ view
)

Parameters

room
Type: Autodesk.Revit.Elements..::.Room
The Room which the tag refers.
point
Type: Autodesk.Revit.Geometry..::.UV
A 2D point that dictates the location on the level of the room.
view
Type: Autodesk.Revit.Elements..::.View
The view where the tag will lie.

Return Value

If successful a RoomTag object will be returned, otherwise nothing. Suitable exceptions will be fired if the parameters are invalid.

Examples

CopyC#
RoomTag CreateRoomTag(Autodesk.Revit.Document document, Room room)
{
    // Create a UV structure which determine the room tag location
    UV roomTagLocation = new UV(0, 0);

    // Create a new room tag in the created room
    RoomTag roomTag = document.Create.NewRoomTag(room, roomTagLocation, null);
    if (null == roomTag)
    {
        throw new Exception("Create a new room tag failed.");
    }

    // Give the user some information
    MessageBox.Show("Room tag created successfully.", "Revit");

    return roomTag;
}
CopyVB.NET
Private Function CreateRoomTag(ByVal document As Autodesk.Revit.Document, ByVal room As Room) As Autodesk.Revit.Elements.RoomTag
    ' Create a UV structure which determine the room tag location
    Dim roomTagLocation As New Autodesk.Revit.Geometry.UV(0, 0)

    ' Create a new room tag in the created room
    Dim roomTag As Autodesk.Revit.Elements.RoomTag = document.Create.NewRoomTag(room, roomTagLocation, Nothing)
    If roomTag Is Nothing Then
        Throw New Exception("Create a new room tag failed.")
    End If

    ' Give the user some information
    MessageBox.Show("Room tag created successfully.", "Revit")

    Return roomTag
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSketchPlane Method

[image] [image]

Revit 2010 API
Document..::.NewSketchPlane Method
Document Class See Also Send Feedback
Creates a new sketch plane.

Overload List

Name | Description
NewSketchPlane(PlanarFace) | Creates a new sketch plane on a planar face of existing geometry. (Inherited from ItemFactoryBase.)
NewSketchPlane(Plane) | Creates a new sketch plane from an arbitrary geometric plane. (Inherited from ItemFactoryBase.)

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewSlab Method

[image]

Revit 2010 API
Document..::.NewSlab Method
Document Class See Also Send Feedback
Creates a slab within the project with the given horizontal profile using the default floor style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Floor NewSlab(
    CurveArray profile,
    Level level,
    Line slopedArrow,
    double slope,
    bool isStructural
)
Visual Basic (Declaration)
Public Function NewSlab ( _
    profile As CurveArray, _
    level As Level, _
    slopedArrow As Line, _
    slope As Double, _
    isStructural As Boolean _
) As Floor
Visual C++
public:
Floor^ NewSlab(
    CurveArray^ profile,
    Level^ level,
    Line^ slopedArrow,
    double slope,
    bool isStructural
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of planar lines and arcs that represent the horizontal profile of the slab.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the slab is to be placed.
slopedArrow
Type: Autodesk.Revit.Geometry..::.Line
A line use to control the sloped angle of the slab. It should be in the same face with profile.
slope
Type: System..::.Double
The slope.
isStructural
Type: System..::.Boolean
If set, specifies that the floor is structural in nature.

Return Value

If successful a new floor object within the project, otherwise Nothing.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSlabEdge Method

[image] [image]

Revit 2010 API
Document..::.NewSlabEdge Method
Document Class See Also Send Feedback
Creates a slab edge.

Overload List

Name | Description
NewSlabEdge(SlabEdgeType, Reference) | Creates a slab edge along a reference.
NewSlabEdge(SlabEdgeType, ReferenceArray) | Creates a slab edge along a reference array.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewSlabEdge Method (SlabEdgeType, Reference)

[image]

Revit 2010 API
Document..::.NewSlabEdge Method (SlabEdgeType, Reference)
Document Class See Also Send Feedback
Creates a slab edge along a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabEdge NewSlabEdge(
    SlabEdgeType SlabEdgeType,
    Reference reference
)
Visual Basic (Declaration)
Public Function NewSlabEdge ( _
    SlabEdgeType As SlabEdgeType, _
    reference As Reference _
) As SlabEdge
Visual C++
public:
SlabEdge^ NewSlabEdge(
    SlabEdgeType^ SlabEdgeType,
    Reference^ reference
)

Parameters

SlabEdgeType
Type: Autodesk.Revit.Symbols..::.SlabEdgeType
The type of the slab edge to create
reference
Type: Autodesk.Revit.Geometry..::.Reference
A planar line or arc that represents the place where you want to place the slab edge.

Return Value

If successful a new slab edge object within the project, otherwise Nothing.

See Also

Document Class
NewSlabEdge Overload
Autodesk.Revit.Creation Namespace


NewSlabEdge Method (SlabEdgeType, ReferenceArray)

[image]

Revit 2010 API
Document..::.NewSlabEdge Method (SlabEdgeType, ReferenceArray)
Document Class See Also Send Feedback
Creates a slab edge along a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabEdge NewSlabEdge(
    SlabEdgeType SlabEdgeType,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewSlabEdge ( _
    SlabEdgeType As SlabEdgeType, _
    references As ReferenceArray _
) As SlabEdge
Visual C++
public:
SlabEdge^ NewSlabEdge(
    SlabEdgeType^ SlabEdgeType,
    ReferenceArray^ references
)

Parameters

SlabEdgeType
Type: Autodesk.Revit.Symbols..::.SlabEdgeType
The type of the slab edge to create
references
Type: Autodesk.Revit.Geometry..::.ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the slab edge.

Return Value

If successful a new slab edge object within the project, otherwise Nothing.

See Also

Document Class
NewSlabEdge Overload
Autodesk.Revit.Creation Namespace


NewSpace Method

[image] [image]

Revit 2010 API
Document..::.NewSpace Method
Document Class See Also Send Feedback
Creates a new space.

Overload List

Name | Description
NewSpace(Phase) | Creates a new unplaced space on a given phase.
NewSpace(Level, UV) | Creates a new space element on the given level at the given location.
NewSpace(Level, Phase, UV) | Creates a new space element on the given level, at the given location, and assigned to the given phase.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewSpace Method (Phase)

[image]

Revit 2010 API
Document..::.NewSpace Method (Phase)
Document Class See Also Send Feedback
Creates a new unplaced space on a given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Space NewSpace(
    Phase phase
)
Visual Basic (Declaration)
Public Function NewSpace ( _
    phase As Phase _
) As Space
Visual C++
public:
Space^ NewSpace(
    Phase^ phase
)

Parameters

phase
Type: Autodesk.Revit.Elements..::.Phase
The phase in which the space is to exist.

Return Value

If successful the new space should be returned, otherwise null.

See Also

Document Class
NewSpace Overload
Autodesk.Revit.Creation Namespace


NewSpace Method (Level, UV)

[image]

Revit 2010 API
Document..::.NewSpace Method (Level, UV)
Document Class See Also Send Feedback
Creates a new space element on the given level at the given location.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Space NewSpace(
    Level level,
    UV point
)
Visual Basic (Declaration)
Public Function NewSpace ( _
    level As Level, _
    point As UV _
) As Space
Visual C++
public:
Space^ NewSpace(
    Level^ level,
    UV^ point
)

Parameters

level
Type: Autodesk.Revit.Elements..::.Level
The level on which the space is to exist.
point
Type: Autodesk.Revit.Geometry..::.UV
A 2D point that dictates the location on that specified level.

Return Value

If successful the new space element is returned, otherwise null.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when level or point is null.
System..::.InvalidOperationException | Thrown when the space cannot be created.

See Also

Document Class
NewSpace Overload
Autodesk.Revit.Creation Namespace


NewSpace Method (Level, Phase, UV)

[image]

Revit 2010 API
Document..::.NewSpace Method (Level, Phase, UV)
Document Class See Also Send Feedback
Creates a new space element on the given level, at the given location, and assigned to the given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Space NewSpace(
    Level level,
    Phase phase,
    UV point
)
Visual Basic (Declaration)
Public Function NewSpace ( _
    level As Level, _
    phase As Phase, _
    point As UV _
) As Space
Visual C++
public:
Space^ NewSpace(
    Level^ level,
    Phase^ phase,
    UV^ point
)

Parameters

level
Type: Autodesk.Revit.Elements..::.Level
The level on which the room is to exist.
phase
Type: Autodesk.Revit.Elements..::.Phase
The phase in which the room is to exist.
point
Type: Autodesk.Revit.Geometry..::.UV
A 2D point that dictates the location on that specified level.

Return Value

If successful a new Space element within the project, otherwise null.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when level, phase or point is null.
System..::.InvalidOperationException | Thrown when the space cannot be created.

See Also

Document Class
NewSpace Overload
Autodesk.Revit.Creation Namespace


NewSpaceBoundaryLines Method

[image]

Revit 2010 API
Document..::.NewSpaceBoundaryLines Method
Document Class See Also Send Feedback
Creates a new boundary line as an Space border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelCurveArray NewSpaceBoundaryLines(
    SketchPlane sketchPlane,
    CurveArray curves,
    View view
)
Visual Basic (Declaration)
Public Function NewSpaceBoundaryLines ( _
    sketchPlane As SketchPlane, _
    curves As CurveArray, _
    view As View _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ NewSpaceBoundaryLines(
    SketchPlane^ sketchPlane,
    CurveArray^ curves,
    View^ view
)

Parameters

sketchPlane
Type: Autodesk.Revit.Elements..::.SketchPlane
The sketch plan
curves
Type: Autodesk.Revit.Geometry..::.CurveArray
The geometry curves on which the boundary lines are
view
Type: Autodesk.Revit.Elements..::.View
The View for the new Space

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSpaces Method

[image] [image]

Revit 2010 API
Document..::.NewSpaces Method
Document Class See Also Send Feedback
Creates one or more spaces.

Overload List

Name | Description
NewSpaces(Phase, Int32) | Creates a set of new unplaced spaces on a given phase.
NewSpaces(Level, Phase, View) | Creates new spaces on the available plan circuits of a the given level.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewSpaces Method (Phase, Int32)

[image]

Revit 2010 API
Document..::.NewSpaces Method (Phase, Int32)
Document Class See Also Send Feedback
Creates a set of new unplaced spaces on a given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewSpaces(
    Phase phase,
    int count
)
Visual Basic (Declaration)
Public Function NewSpaces ( _
    phase As Phase, _
    count As Integer _
) As ElementSet
Visual C++
public:
ElementSet^ NewSpaces(
    Phase^ phase,
    int count
)

Parameters

phase
Type: Autodesk.Revit.Elements..::.Phase
The phase in which the spaces are to exist.
count
Type: System..::.Int32

Return Value

If successful, a set if new unplaced spaces are be returned, otherwise null.

See Also

Document Class
NewSpaces Overload
Autodesk.Revit.Creation Namespace


NewSpaces Method (Level, Phase, View)

[image]

Revit 2010 API
Document..::.NewSpaces Method (Level, Phase, View)
Document Class See Also Send Feedback
Creates new spaces on the available plan circuits of a the given level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewSpaces(
    Level level,
    Phase phase,
    View view
)
Visual Basic (Declaration)
Public Function NewSpaces ( _
    level As Level, _
    phase As Phase, _
    view As View _
) As ElementSet
Visual C++
public:
ElementSet^ NewSpaces(
    Level^ level,
    Phase^ phase,
    View^ view
)

Parameters

level
Type: Autodesk.Revit.Elements..::.Level
The level on which the spaces is to exist.
phase
Type: Autodesk.Revit.Elements..::.Phase
The phase in which the spaces is to exist.
view
Type: Autodesk.Revit.Elements..::.View
The view on which the space tags for the spaces are to display.

Return Value

If successful an Element set which contains the rooms should be returned, otherwise the exception will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The view of the relevant level can not be retrieved.
System..::.InvalidOperationException | The phase is invalid or regeneration fails at the end of the creation.

See Also

Document Class
NewSpaces Overload
Autodesk.Revit.Creation Namespace


NewSpaceTag Method

[image]

Revit 2010 API
Document..::.NewSpaceTag Method
Document Class See Also Send Feedback
Creates a new SpaceTag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpaceTag NewSpaceTag(
    Space space,
    UV point,
    View view
)
Visual Basic (Declaration)
Public Function NewSpaceTag ( _
    space As Space, _
    point As UV, _
    view As View _
) As SpaceTag
Visual C++
public:
SpaceTag^ NewSpaceTag(
    Space^ space,
    UV^ point,
    View^ view
)

Parameters

space
Type: Autodesk.Revit.Elements..::.Space
The Space which the tag refers.
point
Type: Autodesk.Revit.Geometry..::.UV
A 2D point that dictates the location on the level of the space.
view
Type: Autodesk.Revit.Elements..::.View
The view where the tag will lie.

Return Value

If successful a SpaceTag object will be returned, otherwise nothing. Suitable exceptions will be fired if the parameters are invalid.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSpotCoordinate Method

[image]

Revit 2010 API
Document..::.NewSpotCoordinate Method
Document Class See Also Send Feedback
Generate a new spot coordinate object within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpotDimension NewSpotCoordinate(
    View view,
    Reference reference,
    XYZ origin,
    XYZ bend,
    XYZ end,
    XYZ refPt,
    bool hasLeader
)
Visual Basic (Declaration)
Public Function NewSpotCoordinate ( _
    view As View, _
    reference As Reference, _
    origin As XYZ, _
    bend As XYZ, _
    end As XYZ, _
    refPt As XYZ, _
    hasLeader As Boolean _
) As SpotDimension
Visual C++
public:
SpotDimension^ NewSpotCoordinate(
    View^ view,
    Reference^ reference,
    XYZ^ origin,
    XYZ^ bend,
    XYZ^ end,
    XYZ^ refPt,
    bool hasLeader
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the spot coordinate is to be visible.
reference
Type: Autodesk.Revit.Geometry..::.Reference
The reference to which the spot coordinate is to be bound.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The point which the spot coordinate evaluate.
bend
Type: Autodesk.Revit.Geometry..::.XYZ
The bend point for the spot coordinate.
end
Type: Autodesk.Revit.Geometry..::.XYZ
The end point for the spot coordinate.
refPt
Type: Autodesk.Revit.Geometry..::.XYZ
The actual point on the reference which the spot coordinate evaluate.
hasLeader
Type: System..::.Boolean
Indicate if it has leader or not.

Return Value

If successful a new spot dimension object, otherwise Nothing.

Remarks

If the origin point is not on the reference, it'll be projected to the reference automatically. And the refPt is projected point. If the reference is not valid or the point cannot be projected to reference correctly, an exception will be thrown

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSpotElevation Method

[image]

Revit 2010 API
Document..::.NewSpotElevation Method
Document Class See Also Send Feedback
Generate a new spot elevation object within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpotDimension NewSpotElevation(
    View view,
    Reference reference,
    XYZ origin,
    XYZ bend,
    XYZ end,
    XYZ refPt,
    bool hasLeader
)
Visual Basic (Declaration)
Public Function NewSpotElevation ( _
    view As View, _
    reference As Reference, _
    origin As XYZ, _
    bend As XYZ, _
    end As XYZ, _
    refPt As XYZ, _
    hasLeader As Boolean _
) As SpotDimension
Visual C++
public:
SpotDimension^ NewSpotElevation(
    View^ view,
    Reference^ reference,
    XYZ^ origin,
    XYZ^ bend,
    XYZ^ end,
    XYZ^ refPt,
    bool hasLeader
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the spot elevation is to be visible.
reference
Type: Autodesk.Revit.Geometry..::.Reference
The reference to which the spot elevation is to be bound.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The point which the spot elevation evaluate.
bend
Type: Autodesk.Revit.Geometry..::.XYZ
The bend point for the spot elevation.
end
Type: Autodesk.Revit.Geometry..::.XYZ
The end point for the spot elevation.
refPt
Type: Autodesk.Revit.Geometry..::.XYZ
The actual point on the reference which the spot elevation evaluate.
hasLeader
Type: System..::.Boolean
Indicate if it has leader or not.

Return Value

If successful a new spot dimension object, otherwise Nothing.

Remarks

If the origin point is not on the reference, it'll be projected to the reference automatically. And the refPt is the projected point. If the reference is not valid or the point cannot be projected to reference correctly, an exception will be thrown

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTag Method

[image]

Revit 2010 API
Document..::.NewTag Method
Document Class Example See Also Send Feedback
Creates a new IndependentTag Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public IndependentTag NewTag(
    View dbview,
    Element objelem,
    bool leader,
    TagMode tagmode,
    TagOrientation tagorn,
    XYZ pnt
)
Visual Basic (Declaration)
Public Function NewTag ( _
    dbview As View, _
    objelem As Element, _
    leader As Boolean, _
    tagmode As TagMode, _
    tagorn As TagOrientation, _
    pnt As XYZ _
) As IndependentTag
Visual C++
public:
IndependentTag^ NewTag(
    View^ dbview,
    Element^ objelem,
    bool leader,
    TagMode tagmode,
    TagOrientation tagorn,
    XYZ^ pnt
)

Parameters

dbview
Type: Autodesk.Revit.Elements..::.View
The view in which the dimension is to be visible.
objelem
Type: Autodesk.Revit..::.Element
The host object of tag
leader
Type: System..::.Boolean
whether have leader
tagmode
Type: Autodesk.Revit.Enums..::.TagMode
the mode of tag. Add by Category, add by Multi-Category and add by material
tagorn
Type: Autodesk.Revit.Enums..::.TagOrientation
The Orientation of the Tag
pnt
Type: Autodesk.Revit.Geometry..::.XYZ
The position of the Tag

Return Value

If successful, an IndependentTag object is returned.

Remarks

This method forms an Tag tie to the host object.

Examples

CopyC#
private IndependentTag CreateIndependentTag(Autodesk.Revit.Document document, Wall wall)
{
    // make sure active view is not a 3D view
    Autodesk.Revit.Elements.View view = document.ActiveView;

    // define tag mode and tag orientation for new tag
    TagMode tagMode = TagMode.TM_ADDBY_CATEGORY;
    TagOrientation tagorn = TagOrientation.TAG_HORIZONTAL;

    // Add the tag to the middle of the wall
    LocationCurve wallLoc = wall.Location as LocationCurve;
    XYZ wallStart = wallLoc.Curve.get_EndPoint(0);
    XYZ wallEnd = wallLoc.Curve.get_EndPoint(1);
    XYZ wallMid = wallLoc.Curve.Evaluate(0.5, true);

    IndependentTag newTag = document.Create.NewTag(view, wall, true, tagMode, tagorn, wallMid);
    if (null == newTag)
    {
        throw new Exception("Create IndependentTag Failed.");
    }

    // newTag.TagText is read-only, so we change the Type Mark type parameter to
    // set the tag text.  The label parameter for the tag family determines
    // what type parameter is used for the tag text.

    WallType type = wall.WallType;

    Parameter foundParameter = type.get_Parameter("Type Mark");
    bool result = foundParameter.Set("Hello");

    // set leader mode free
    // otherwise leader end point move with elbow point

    newTag.LeaderMode = LeaderEndCondition.LEC_FREE;
    XYZ elbowPnt = wallMid + new XYZ(5.0, 5.0, 0.0);
    newTag.LeaderElbow = elbowPnt;
    XYZ headerPnt = wallMid + new XYZ(10.0, 10.0, 0.0);
    newTag.TagHeadPosition = headerPnt;

    return newTag;
}
CopyVB.NET
Private Function CreateIndependentTag(ByVal document As Autodesk.Revit.Document, ByVal wall As Wall) As Autodesk.Revit.Elements.IndependentTag
    ' make sure active view is not a 3D view
    Dim view As Autodesk.Revit.Elements.View = document.ActiveView

    ' define tag mode and tag orientation for new tag
    Dim tagMode__1 As TagMode = TagMode.TM_ADDBY_CATEGORY
    Dim tagorn As Autodesk.Revit.Enums.TagOrientation = Autodesk.Revit.Enums.TagOrientation.TAG_HORIZONTAL

    ' Add the tag to the middle of the wall
    Dim wallLoc As LocationCurve = TryCast(wall.Location, LocationCurve)
    Dim wallStart As Autodesk.Revit.Geometry.XYZ = wallLoc.Curve.EndPoint(0)
    Dim wallEnd As Autodesk.Revit.Geometry.XYZ = wallLoc.Curve.EndPoint(1)
    Dim wallMid As Autodesk.Revit.Geometry.XYZ = wallLoc.Curve.Evaluate(0.5, True)

    Dim newTag As Autodesk.Revit.Elements.IndependentTag = document.Create.NewTag(view, wall, True, tagMode__1, tagorn, wallMid)
    If newTag Is Nothing Then
        Throw New Exception("Create IndependentTag Failed.")
    End If

    ' newTag.TagText is read-only, so we change the Type Mark type parameter to
    ' set the tag text. The label parameter for the tag family determines
    ' what type parameter is used for the tag text.

    Dim type As Autodesk.Revit.Symbols.WallType = wall.WallType

    Dim foundParameter As Parameter = type.Parameter("Type Mark")
    Dim result As Boolean = foundParameter.[Set]("Hello")

    ' set leader mode free
    ' otherwise leader end point move with elbow point

    newTag.LeaderMode = Autodesk.Revit.Enums.LeaderEndCondition.LEC_FREE
    Dim elbowPnt As Autodesk.Revit.Geometry.XYZ = wallMid + New Autodesk.Revit.Geometry.XYZ(5.0R, 5.0R, 0.0R)
    newTag.LeaderElbow = elbowPnt
    Dim headerPnt As Autodesk.Revit.Geometry.XYZ = wallMid + New Autodesk.Revit.Geometry.XYZ(10.0R, 10.0R, 0.0R)
    newTag.TagHeadPosition = headerPnt

    Return newTag
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTakeoffFitting Method

[image]

Revit 2010 API
Document..::.NewTakeoffFitting Method
Document Class See Also Send Feedback
Add a new family instance of an takeoff fitting into the Autodesk Revit document, using one connector and one MEP curve.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance NewTakeoffFitting(
    Connector connector,
    MEPCurve curve
)
Visual Basic (Declaration)
Public Function NewTakeoffFitting ( _
    connector As Connector, _
    curve As MEPCurve _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewTakeoffFitting(
    Connector^ connector,
    MEPCurve^ curve
)

Parameters

connector
Type: Autodesk.Revit.MEP..::.Connector
The connector to be connected to the takeoff.
curve
Type: Autodesk.Revit.MEP..::.MEPCurve
The duct or pipe which is the trunk for the takeoff.

Return Value

If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument connector1 or curve is null.
System..::.ArgumentException | Thrown when the connector and the curve cannot be used for takeoff creation. For example, they must be of the same domain, the curve must be a duct or pipe, and the owner of the connector should be (flex) duct or pipe.
System..::.InvalidOperationException | Thrown when takeoff fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTeeFitting Method

[image]

Revit 2010 API
Document..::.NewTeeFitting Method
Document Class See Also Send Feedback
Add a new family instance of a tee fitting into the Autodesk Revit document, using three connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance NewTeeFitting(
    Connector connector1,
    Connector connector2,
    Connector connector3
)
Visual Basic (Declaration)
Public Function NewTeeFitting ( _
    connector1 As Connector, _
    connector2 As Connector, _
    connector3 As Connector _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewTeeFitting(
    Connector^ connector1,
    Connector^ connector2,
    Connector^ connector3
)

Parameters

connector1
Type: Autodesk.Revit.MEP..::.Connector
The first connector to be connected to the tee.
connector2
Type: Autodesk.Revit.MEP..::.Connector
The second connector to be connected to the tee.
connector3
Type: Autodesk.Revit.MEP..::.Connector
The third connector to be connected to the tee. This should be connected to the branch of the tee.

Return Value

If creation was successful then an family instance to the new object is returned, and the transition fitting will be added at the connectors’ end if necessary, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument connector1, connector2 or connector3 is null.
System..::.ArgumentException | Thrown when the connectors cannot be used for the tee creation. For example, they cannot be from the same element, they must be of the same domain, and the owner of the connectors should be a (flex) duct or pipe.
System..::.InvalidOperationException | Thrown when tee fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTextNote Method

[image] [image]

Revit 2010 API
Document..::.NewTextNote Method
Document Class See Also Send Feedback
Creates a new TextNote object.

Overload List

Name | Description
NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates a new text note with a single leader. (Inherited from ItemFactoryBase.)
NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates a new TextNote object without a leader. (Inherited from ItemFactoryBase.)

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewTopographySurface Method

[image]

Revit 2010 API
Document..::.NewTopographySurface Method
Document Class See Also Send Feedback
Creates a new TopographySurface element in the document, and initializes it with a set of points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TopographySurface NewTopographySurface(
    XYZArray points
)
Visual Basic (Declaration)
Public Function NewTopographySurface ( _
    points As XYZArray _
) As TopographySurface
Visual C++
public:
TopographySurface^ NewTopographySurface(
    XYZArray^ points
)

Parameters

points
Type: Autodesk.Revit.Geometry..::.XYZArray
An array of initial points for the surface.

Return Value

The TopographySurface element.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when input argument 'points' is null.
System..::.ArgumentException | Thrown when points.Size is less than 3, to create a TopographySurface needs at least 3 points.
System..::.InvalidOperationException | Thrown when regeneration fails.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTransitionFitting Method

[image]

Revit 2010 API
Document..::.NewTransitionFitting Method
Document Class See Also Send Feedback
Add a new family instance of an transition fitting into the Autodesk Revit document, using two connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance NewTransitionFitting(
    Connector connector1,
    Connector connector2
)
Visual Basic (Declaration)
Public Function NewTransitionFitting ( _
    connector1 As Connector, _
    connector2 As Connector _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewTransitionFitting(
    Connector^ connector1,
    Connector^ connector2
)

Parameters

connector1
Type: Autodesk.Revit.MEP..::.Connector
The first connector to be connected to the transition.
connector2
Type: Autodesk.Revit.MEP..::.Connector
The second connector to be connected to the transition.

Return Value

If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument connector1 or connector2 is null.
System..::.ArgumentException | Thrown when the connectors cannot be used for transition creation. For example, they cannot be from the same element, they must be of the same domain, and the owner of connector1 should be a (flex) duct or pipe.
System..::.InvalidOperationException | Thrown when transition fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTruss Method

[image]

Revit 2010 API
Document..::.NewTruss Method
Document Class Example See Also Send Feedback
Creates a New Truss.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Truss NewTruss(
    TrussType trussType,
    SketchPlane sketchPlane,
    Curve baseCurve,
    View dbView
)
Visual Basic (Declaration)
Public Function NewTruss ( _
    trussType As TrussType, _
    sketchPlane As SketchPlane, _
    baseCurve As Curve, _
    dbView As View _
) As Truss
Visual C++
public:
Truss^ NewTruss(
    TrussType^ trussType,
    SketchPlane^ sketchPlane,
    Curve^ baseCurve,
    View^ dbView
)

Parameters

trussType
Type: Autodesk.Revit.Symbols..::.TrussType
The type for truss.
sketchPlane
Type: Autodesk.Revit.Elements..::.SketchPlane
The sketch plane the truss is going to be reside in.It could be nullptr.
baseCurve
Type: Autodesk.Revit.Geometry..::.Curve
The curve that represents truss's base curve. It must be a line, must not be a vertical line, must be within the sketch plane if sketchPlane is valid.
dbView
Type: Autodesk.Revit.Elements..::.View
The DBView where truss's tag going to be placed. A valid dbViewId must be a Plan view or RPlan view, or an elevation view paralleling to the truss base curve.

Examples

CopyC#
Truss CreateTruss(Autodesk.Revit.Document document, FamilyInstance column1, FamilyInstance column2)
{
    //sketchPlane
    XYZ origin = new XYZ(0, 0, 0);
    XYZ xDirection = new XYZ(1, 0, 0);
    XYZ yDirection = new XYZ(0, 1, 0);
    Plane plane = document.Application.Create.NewPlane(xDirection, yDirection, origin);
    SketchPlane sketchPlane = document.Create.NewSketchPlane(plane);

    //new base Line - use line that spans two selected columns
    AnalyticalModelFrame frame1 = column1.AnalyticalModel as AnalyticalModelFrame;
    XYZ centerPoint1 = (frame1.Curve as Line).get_EndPoint(0);

    AnalyticalModelFrame frame2 = column2.AnalyticalModel as AnalyticalModelFrame;
    XYZ centerPoint2 = (frame2.Curve as Line).get_EndPoint(0);

    XYZ startPoint = new XYZ(centerPoint1.X, centerPoint1.Y, 0);
    XYZ endPoint = new XYZ(centerPoint2.X, centerPoint2.Y, 0);
    Autodesk.Revit.Geometry.Line baseLine = null;

    try
    {
        baseLine = document.Application.Create.NewLineBound(startPoint, endPoint);
    }
    catch (System.ArgumentException)
    {
        throw new Exception("Selected columns are too close to create truss.");
    }

    // use the active view for where the truss's tag will be placed; View used in
    // NewTruss should be plan or elevation view parallel to the truss's base line
    Autodesk.Revit.Elements.View view = document.ActiveView;

    // Get a truss type for the truss
    TrussType trussType = null;
    foreach (TrussType currentType in document.TrussTypes)
    {
        if (null != currentType)
        {
            trussType = currentType;
            break;
        }
    }

    Truss truss = null;
    if (null != trussType)
    {
        truss = document.Create.NewTruss(trussType, sketchPlane, baseLine, view);
    }
    else
    {
        throw new Exception("No truss types found in document.");
    }

    return truss;
}
CopyVB.NET
Private Function CreateTruss(ByVal document As Autodesk.Revit.Document, ByVal column1 As Autodesk.Revit.Elements.FamilyInstance, ByVal column2 As Autodesk.Revit.Elements.FamilyInstance) As Truss
    'sketchPlane
    Dim origin As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
    Dim xDirection As New Autodesk.Revit.Geometry.XYZ(1, 0, 0)
    Dim yDirection As New Autodesk.Revit.Geometry.XYZ(0, 1, 0)
    Dim plane As Autodesk.Revit.Geometry.Plane = document.Application.Create.NewPlane(xDirection, yDirection, origin)
    Dim sketchPlane As Autodesk.Revit.Elements.SketchPlane = document.Create.NewSketchPlane(plane)

    'new base Line - use line that spans two selected columns
    Dim frame1 As AnalyticalModelFrame = TryCast(column1.AnalyticalModel, AnalyticalModelFrame)
    Dim centerPoint1 As Autodesk.Revit.Geometry.XYZ = TryCast(frame1.Curve, Line).EndPoint(0)

    Dim frame2 As AnalyticalModelFrame = TryCast(column2.AnalyticalModel, AnalyticalModelFrame)
    Dim centerPoint2 As Autodesk.Revit.Geometry.XYZ = TryCast(frame2.Curve, Line).EndPoint(0)

    Dim startPoint As New Autodesk.Revit.Geometry.XYZ(centerPoint1.X, centerPoint1.Y, 0)
    Dim endPoint As New Autodesk.Revit.Geometry.XYZ(centerPoint2.X, centerPoint2.Y, 0)
    Dim baseLine As Autodesk.Revit.Geometry.Line = Nothing

    Try
        baseLine = document.Application.Create.NewLineBound(startPoint, endPoint)
    Catch generatedExceptionName As System.ArgumentException
        Throw New Exception("Selected columns are too close to create truss.")
    End Try

    ' use the active view for where the truss's tag will be placed; View used in
    ' NewTruss should be plan or elevation view parallel to the truss's base line
    Dim view As Autodesk.Revit.Elements.View = document.ActiveView

    ' Get a truss type for the truss
    Dim trussType As TrussType = Nothing
    For Each currentType As TrussType In document.TrussTypes
        If currentType IsNot Nothing Then
            trussType = currentType
            Exit For
        End If
    Next

    Dim truss As Truss = Nothing
    If trussType IsNot Nothing Then
        truss = document.Create.NewTruss(trussType, sketchPlane, baseLine, view)
    Else
        Throw New Exception("No truss types found in document.")
    End If

    Return truss
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewUnionFitting Method

[image]

Revit 2010 API
Document..::.NewUnionFitting Method
Document Class See Also Send Feedback
Add a new family instance of an union fitting into the Autodesk Revit document, using two connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance NewUnionFitting(
    Connector connector1,
    Connector connector2
)
Visual Basic (Declaration)
Public Function NewUnionFitting ( _
    connector1 As Connector, _
    connector2 As Connector _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewUnionFitting(
    Connector^ connector1,
    Connector^ connector2
)

Parameters

connector1
Type: Autodesk.Revit.MEP..::.Connector
The first connector to be connected to the union.
connector2
Type: Autodesk.Revit.MEP..::.Connector
The second connector to be connected to the union.

Return Value

If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument connector1 or connector2 is null.
System..::.ArgumentException | Thrown when the connectors cannot be used for union creation. For example, they cannot be from the same element, they must be of the same domain and and shape, and the owner of the connector1 should be a (flex) duct or pipe.
System..::.InvalidOperationException | Thrown when union fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewViewDrafting Method

[image]

Revit 2010 API
Document..::.NewViewDrafting Method
Document Class Example See Also Send Feedback
Creates a new drafting view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewDrafting NewViewDrafting()
Visual Basic (Declaration)
Public Function NewViewDrafting As ViewDrafting
Visual C++
public:
ViewDrafting^ NewViewDrafting()

Return Value

The newly created drafting view.

Examples

CopyC#
// Create a new ViewDrafting instance
ViewDrafting view = document.Create.NewViewDrafting();
view.ViewName = "MyViewDrafting";

// Set the CropBox
BoundingBoxXYZ boundingBox = new BoundingBoxXYZ();
boundingBox.Max = new XYZ(100, 100, 50);
boundingBox.Min = new XYZ(-100, -100, -50);
view.CropBox = boundingBox;

// Use current view as template
view.ApplyTemplate(document.ActiveView);
CopyVB.NET
' Create a new ViewDrafting instance
Dim view As ViewDrafting = document.Create.NewViewDrafting()
view.ViewName = "MyViewDrafting"

' Set the CropBox
Dim boundingBox As New BoundingBoxXYZ()
boundingBox.Max = New Autodesk.Revit.Geometry.XYZ(100, 100, 50)
boundingBox.Min = New Autodesk.Revit.Geometry.XYZ(-100, -100, -50)
view.CropBox = boundingBox

' Use current view as template
view.ApplyTemplate(document.ActiveView)

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewViewSheet Method

[image]

Revit 2010 API
Document..::.NewViewSheet Method
Document Class Example See Also Send Feedback
Creates a new sheet view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSheet NewViewSheet(
    FamilySymbol titleBlock
)
Visual Basic (Declaration)
Public Function NewViewSheet ( _
    titleBlock As FamilySymbol _
) As ViewSheet
Visual C++
public:
ViewSheet^ NewViewSheet(
    FamilySymbol^ titleBlock
)

Parameters

titleBlock
Type: Autodesk.Revit.Symbols..::.FamilySymbol
The titleblock family symbol to apply to this sheet.

Return Value

The newly created sheet view.

Remarks

Use the TitleBlocks property of Document to choose a titleblock.

Examples

CopyC#
private void CreateSheetView(Autodesk.Revit.Document document, View3D view3D)
{

    // Get an available title block from document
    FamilySymbolSet fsSet = document.TitleBlocks;
    if (fsSet.Size == 0)
    {
        throw new Exception("No title blocks");
    }

    FamilySymbol fs = null;
    foreach (FamilySymbol f in fsSet)
    {
        if (null != f)
        {
            fs = f;
            break;
        }
    }

    // Create a sheet view
    ViewSheet viewSheet = document.Create.NewViewSheet(fs);
    if (null == viewSheet)
    {
        throw new Exception("Failed to create new ViewSheet.");
    }

    // Add passed in view onto the center of the sheet
    UV location = new UV((viewSheet.Outline.Max.U - viewSheet.Outline.Min.U) / 2,
                         (viewSheet.Outline.Max.V - viewSheet.Outline.Min.V) / 2);

    viewSheet.AddView(view3D, location);

    // Print the sheet out
    if (viewSheet.CanBePrinted)
    {
        if (MessageBox.Show("Print the sheet?", "Revit", MessageBoxButtons.YesNo) == DialogResult.Yes)
        {
            viewSheet.Print();
        }
    }
}
CopyVB.NET
Private Sub CreateSheetView(ByVal document As Autodesk.Revit.Document, ByVal view3D As View3D)

    ' Get an available title block from document
    Dim fsSet As FamilySymbolSet = document.TitleBlocks
    If fsSet.Size = 0 Then
        Throw New Exception("No title blocks")
    End If

    Dim fs As Autodesk.Revit.Symbols.FamilySymbol = Nothing
    For Each f As Autodesk.Revit.Symbols.FamilySymbol In fsSet
        If f IsNot Nothing Then
            fs = f
            Exit For
        End If
    Next

    ' Create a sheet view
    Dim viewSheet As ViewSheet = document.Create.NewViewSheet(fs)
    If viewSheet Is Nothing Then
        Throw New Exception("Failed to create new ViewSheet.")
    End If

    ' Add passed in view onto the center of the sheet
    Dim location As New Autodesk.Revit.Geometry.UV((viewSheet.Outline.Max.U - viewSheet.Outline.Min.U) / 2, (viewSheet.Outline.Max.V - viewSheet.Outline.Min.V) / 2)

    viewSheet.AddView(view3D, location)

    ' Print the sheet out
    If viewSheet.CanBePrinted Then
        If MessageBox.Show("Print the sheet?", "Revit", MessageBoxButtons.YesNo) = DialogResult.Yes Then
            viewSheet.Print()
        End If
    End If
End Sub

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewWall Method

[image] [image]

Revit 2010 API
Document..::.NewWall Method
Document Class See Also Send Feedback
Creates a new wall within the project.

Overload List

Name | Description
NewWall(CurveArray, Boolean) | Creates a non rectangular profile wall within the project using the default wall type.
NewWall(Curve, Level, Boolean) | Creates a new rectangular profile wall within the project using the default wall style.
NewWall(CurveArray, WallType, Level, Boolean) | Creates a non rectangular profile wall within the project using the specified wall type.
NewWall(CurveArray, WallType, Level, Boolean, XYZ) | Creates a non rectangular profile wall within the project using the specified wall type and normal vector.
NewWall(Curve, WallType, Level, Double, Double, Boolean, Boolean) | Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewWall Method (CurveArray, Boolean)

[image]

Revit 2010 API
Document..::.NewWall Method (CurveArray, Boolean)
Document Class See Also Send Feedback
Creates a non rectangular profile wall within the project using the default wall type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Wall NewWall(
    CurveArray profile,
    bool structural
)
Visual Basic (Declaration)
Public Function NewWall ( _
    profile As CurveArray, _
    structural As Boolean _
) As Wall
Visual C++
public:
Wall^ NewWall(
    CurveArray^ profile,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise Nothing.

See Also

Document Class
NewWall Overload
Autodesk.Revit.Creation Namespace


NewWall Method (Curve, Level, Boolean)

[image]

Revit 2010 API
Document..::.NewWall Method (Curve, Level, Boolean)
Document Class Example See Also Send Feedback
Creates a new rectangular profile wall within the project using the default wall style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Wall NewWall(
    Curve curve,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Function NewWall ( _
    curve As Curve, _
    level As Level, _
    structural As Boolean _
) As Wall
Visual C++
public:
Wall^ NewWall(
    Curve^ curve,
    Level^ level,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
An arc or line representing the base line of the wall.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise Nothing.

Examples

CopyC#
public Wall CreateWallUsingCurve1(Autodesk.Revit.Document document, Level level)
{
    // Build a location line for the wall creation
    XYZ start = new XYZ(0, 0, 0);
    XYZ end = new XYZ(10, 10, 0);
    Line geomLine = document.Application.Create.NewLineBound(start, end);

    // Create a wall using the location line
    return document.Create.NewWall(geomLine, level, true);
}
CopyVB.NET
Public Function CreateWallUsingCurve1(ByVal document As Autodesk.Revit.Document, ByVal level As Autodesk.Revit.Elements.Level) As Wall
    ' Build a location line for the wall creation
    Dim start As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
    Dim [end] As New Autodesk.Revit.Geometry.XYZ(10, 10, 0)
    Dim geomLine As Line = document.Application.Create.NewLineBound(start, [end])

    ' Create a wall using the location line
    Return document.Create.NewWall(geomLine, level, True)
End Function

See Also

Document Class
NewWall Overload
Autodesk.Revit.Creation Namespace


NewWall Method (CurveArray, WallType, Level, Boolean)

[image]

Revit 2010 API
Document..::.NewWall Method (CurveArray, WallType, Level, Boolean)
Document Class See Also Send Feedback
Creates a non rectangular profile wall within the project using the specified wall type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Wall NewWall(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Function NewWall ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean _
) As Wall
Visual C++
public:
Wall^ NewWall(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.Symbols..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise Nothing.

See Also

Document Class
NewWall Overload
Autodesk.Revit.Creation Namespace


NewWall Method (CurveArray, WallType, Level, Boolean, XYZ)

[image]

Revit 2010 API
Document..::.NewWall Method (CurveArray, WallType, Level, Boolean, XYZ)
Document Class Example See Also Send Feedback
Creates a non rectangular profile wall within the project using the specified wall type and normal vector.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Wall NewWall(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic (Declaration)
Public Function NewWall ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
) As Wall
Visual C++
public:
Wall^ NewWall(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.Symbols..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.
normal
Type: Autodesk.Revit.Geometry..::.XYZ
A vector that must be perpendicular to the profile which dictates which side of the wall is considered to be inside and outside.

Return Value

If successful a new wall object within the project, otherwise Nothing.

Examples

CopyC#
public Wall CreateWallUsingProfile(Autodesk.Revit.Document document, Level level, WallType wallType)
{
    // Build a wall profile for the wall creation
    XYZ first = new XYZ(0, 0, 0);
    XYZ second = new XYZ(20, 0, 0);
    XYZ third = new XYZ(20, 0, 15);
    XYZ fourth = new XYZ(0, 0, 15);
    CurveArray profile = new CurveArray();

    // Get application creation object
    Autodesk.Revit.Creation.Application appCreation = document.Application.Create;

    profile.Append(appCreation.NewLineBound(first, second));
    profile.Append(appCreation.NewLineBound(second, third));
    profile.Append(appCreation.NewLineBound(third, fourth));
    profile.Append(appCreation.NewLineBound(fourth, first));

    XYZ normal = new XYZ(0, 1, 0);

    // Create a wall
    return document.Create.NewWall(profile, wallType, level, true, normal);
}
CopyVB.NET
Public Function CreateWallUsingProfile(ByVal document As Autodesk.Revit.Document, ByVal level As Autodesk.Revit.Elements.Level, ByVal wallType As Autodesk.Revit.Symbols.WallType) As Wall
    ' Build a wall profile for the wall creation
    Dim first As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
    Dim second As New Autodesk.Revit.Geometry.XYZ(20, 0, 0)
    Dim third As New Autodesk.Revit.Geometry.XYZ(20, 0, 15)
    Dim fourth As New Autodesk.Revit.Geometry.XYZ(0, 0, 15)
    Dim profile As New CurveArray()

    ' Get application creation object
    Dim appCreation As Autodesk.Revit.Creation.Application = document.Application.Create

    profile.Append(appCreation.NewLineBound(first, second))
    profile.Append(appCreation.NewLineBound(second, third))
    profile.Append(appCreation.NewLineBound(third, fourth))
    profile.Append(appCreation.NewLineBound(fourth, first))

    Dim normal As New Autodesk.Revit.Geometry.XYZ(0, 1, 0)

    ' Create a wall
    Return document.Create.NewWall(profile, wallType, level, True, normal)
End Function

See Also

Document Class
NewWall Overload
Autodesk.Revit.Creation Namespace


NewWall Method (Curve, WallType, Level, Double, Double, Boolean, Boolean)

[image]

Revit 2010 API
Document..::.NewWall Method (Curve, WallType, Level, Double, Double, Boolean, Boolean)
Document Class Example See Also Send Feedback
Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Wall NewWall(
    Curve curve,
    WallType wallType,
    Level level,
    double height,
    double offset,
    bool flip,
    bool structural
)
Visual Basic (Declaration)
Public Function NewWall ( _
    curve As Curve, _
    wallType As WallType, _
    level As Level, _
    height As Double, _
    offset As Double, _
    flip As Boolean, _
    structural As Boolean _
) As Wall
Visual C++
public:
Wall^ NewWall(
    Curve^ curve,
    WallType^ wallType,
    Level^ level,
    double height,
    double offset,
    bool flip,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
An arc or line representing the base line of the wall.
wallType
Type: Autodesk.Revit.Symbols..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the wall is to be placed.
height
Type: System..::.Double
The height of the wall other than the default height.
offset
Type: System..::.Double
Modifies the wall's Base Offset parameter to detemine its vertical placement.
flip
Type: System..::.Boolean
Change which side of the wall is considered to be the inside and outside of the wall.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise Nothing.

Examples

CopyC#
public Wall CreateWallUsingCurve2(Autodesk.Revit.Document document, Level level, WallType wallType)
{
    // Build a location line for the wall creation
    XYZ start = new XYZ(0, 0, 0);
    XYZ end = new XYZ(10, 10, 0);
    Line geomLine = document.Application.Create.NewLineBound(start, end);

    // Determine the other parameters
    double height = 15;
    double offset = 3;

    // Create a wall using the location line and wall type
    return document.Create.NewWall(geomLine, wallType, level, height, offset, true, true);
}
CopyVB.NET
Public Function CreateWallUsingCurve2(ByVal document As Autodesk.Revit.Document, ByVal level As Autodesk.Revit.Elements.Level, ByVal wallType As Autodesk.Revit.Symbols.WallType) As Wall
    ' Build a location line for the wall creation
    Dim start As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
    Dim [end] As New Autodesk.Revit.Geometry.XYZ(10, 10, 0)
    Dim geomLine As Line = document.Application.Create.NewLineBound(start, [end])

    ' Determine the other parameters
    Dim height As Double = 15
    Dim offset As Double = 3

    ' Create a wall using the location line and wall type
    Return document.Create.NewWall(geomLine, wallType, level, height, offset, True, _
    True)
End Function

See Also

Document Class
NewWall Overload
Autodesk.Revit.Creation Namespace


NewWalls Method

[image] [image]

Revit 2010 API
Document..::.NewWalls Method
Document Class See Also Send Feedback
Creates walls within the project.

Overload List

Name | Description
NewWalls(List<(Of <(ProfiledWallCreationData>)>)) | Creates profile walls within the project.
NewWalls(List<(Of <(RectangularWallCreationData>)>)) | Creates rectangular walls within the project.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewWalls Method (List(ProfiledWallCreationData))

[image]

Revit 2010 API
Document..::.NewWalls Method (List<(Of <(ProfiledWallCreationData>)>))
Document Class See Also Send Feedback
Creates profile walls within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewWalls(
    List<ProfiledWallCreationData> dataList
)
Visual Basic (Declaration)
Public Function NewWalls ( _
    dataList As List(Of ProfiledWallCreationData) _
) As ElementSet
Visual C++
public:
ElementSet^ NewWalls(
    List<ProfiledWallCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::.List <(Of <( ProfiledWallCreationData >)>)
A list of ProfiledWallCreationData which wraps the creation arguments of the walls to be created.

Return Value

If the creation is successful an ElementSet which contains the walls should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
System..::.ArgumentException | If ProfiledWallCreationData's profile is null object.
System..::.InvalidOperationException | If regeneration fails at the end of the batch creation.

See Also

Document Class
NewWalls Overload
Autodesk.Revit.Creation Namespace


NewWalls Method (List(RectangularWallCreationData))

[image]

Revit 2010 API
Document..::.NewWalls Method (List<(Of <(RectangularWallCreationData>)>))
Document Class See Also Send Feedback
Creates rectangular walls within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewWalls(
    List<RectangularWallCreationData> dataList
)
Visual Basic (Declaration)
Public Function NewWalls ( _
    dataList As List(Of RectangularWallCreationData) _
) As ElementSet
Visual C++
public:
ElementSet^ NewWalls(
    List<RectangularWallCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::.List <(Of <( RectangularWallCreationData >)>)
A list of RectangularWallCreationData which wraps the creation arguments of the walls to be created.

Return Value

If the creation is successful an ElementSet which contains the walls should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
System..::.ArgumentException | Either of 'curve', 'wallType', 'level' or 'height' is less than 0, or the 'curve' is not horizontal, or the neither of the curve's type is CURVE_TYPE_LINE or CURVE_TYPE_ARC.
System..::.InvalidOperationException | If regeneration fails at the end of the batch creation.

See Also

Document Class
NewWalls Overload
Autodesk.Revit.Creation Namespace


NewWire Method

[image]

Revit 2010 API
Document..::.NewWire Method
Document Class See Also Send Feedback
Creates a new wire element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Wire NewWire(
    Curve curve,
    View view,
    Connector startConnector,
    Connector endConnector,
    WireType wireType,
    WiringType wiringType
)
Visual Basic (Declaration)
Public Function NewWire ( _
    curve As Curve, _
    view As View, _
    startConnector As Connector, _
    endConnector As Connector, _
    wireType As WireType, _
    wiringType As WiringType _
) As Wire
Visual C++
public:
Wire^ NewWire(
    Curve^ curve,
    View^ view,
    Connector^ startConnector,
    Connector^ endConnector,
    WireType^ wireType,
    WiringType wiringType
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
The base line of the wire.
view
Type: Autodesk.Revit.Elements..::.View
The view in which the wire is to be visible.
startConnector
Type: Autodesk.Revit.MEP..::.Connector
The connector which connects with the start point connector of wire, if it is null, the start point connects with nothing.
endConnector
Type: Autodesk.Revit.MEP..::.Connector
The connector which connects with the end point connector of wire, if it is null, the end point connects with nothing.
wireType
Type: Autodesk.Revit.MEP..::.WireType
Specify wire type of new created wire.
wiringType
Type: Autodesk.Revit.MEP.Enums..::.WiringType
Specify wiring type(Arc or chamfer) of new created wire.

Return Value

If successful a new wire element within the project, otherwise Nothing.

Exceptions

Exception | Condition
System..::.InvalidOperationException | An InvalidOperationException will to be thrown when Revit MEP product is unavailable.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewZone Method

[image]

Revit 2010 API
Document..::.NewZone Method
Document Class See Also Send Feedback
Creates a new Zone element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Zone NewZone(
    Level level,
    Phase phase
)
Visual Basic (Declaration)
Public Function NewZone ( _
    level As Level, _
    phase As Phase _
) As Zone
Visual C++
public:
Zone^ NewZone(
    Level^ level,
    Phase^ phase
)

Parameters

level
Type: Autodesk.Revit.Elements..::.Level
The level on which the Zone is to exist.
phase
Type: Autodesk.Revit.Elements..::.Phase
The associative phase on which the Zone is to exist.

Return Value

If successful a new Zone element within the project, otherwise Nothing.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter Value is null.
System..::.InvalidOperationException | Thrown when the electrical system cannot be created by these input phase and level.

See Also

Document Class
Autodesk.Revit.Creation Namespace


Document Properties

[image] [image]

Revit 2010 API
Document Properties
Document Class See Also Send Feedback

The Document type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Document Class
Autodesk.Revit.Creation Namespace


Document.eRefFace Enumeration

[image]

Revit 2010 API
Document..::.eRefFace Enumeration
Document Class See Also Send Feedback
Indicates the reference face. The Opening will be created at the direction perpendicular to the reference face.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum eRefFace
Visual Basic (Declaration)
Public Enumeration eRefFace
Visual C++
public enum class eRefFace

Members

Member name | Description
CenterZ | The reference face is at the middle of the element in the direction of z-axis and its normal is parallel to z-axis.
CenterY | The reference face is at the middle of the element in the direction of y-axis and its normal is parallel to y-axis.
CenterX | The reference face is at the middle of the element in the direction of x-axis and its normal is parallel to x-axis.

Remarks

Direction of the opening.

See Also

Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Class

[image]

Revit 2010 API
FamilyInstanceCreationData Class
Members See Also Send Feedback
A class which wraps the arguments of FamilyInstance for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FamilyInstanceCreationData
Visual Basic (Declaration)
Public Class FamilyInstanceCreationData
Visual C++
public ref class FamilyInstanceCreationData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Creation..::.FamilyInstanceCreationData

See Also

FamilyInstanceCreationData Members
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Members

[image] [image]

Revit 2010 API
FamilyInstanceCreationData Members
FamilyInstanceCreationData Class Constructors Methods Properties See Also Send Feedback

The FamilyInstanceCreationData type exposes the following members.

Constructors

Name | Description
FamilyInstanceCreationData | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Axis | Get or set the axis of the FamilyInstance
RotateAngle | Get or set the rotate angle of the FamilyInstance

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor

[image] [image]

Revit 2010 API
FamilyInstanceCreationData Constructor
FamilyInstanceCreationData Class See Also Send Feedback

Overload List

Name | Description
FamilyInstanceCreationData(Face, Line, FamilySymbol) | Initializes a new instance of the FamilyInstanceCreationData class
FamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
FamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
FamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) | Initializes a new instance of the FamilyInstanceCreationData class
FamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
FamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
FamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
FamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Members
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (Face, Line, FamilySymbol)

[image]

Revit 2010 API
FamilyInstanceCreationData Constructor (Face, Line, FamilySymbol)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    Face face,
    Line position,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Sub New ( _
    face As Face, _
    position As Line, _
    symbol As FamilySymbol _
)
Visual C++
public:
FamilyInstanceCreationData(
    Face^ face,
    Line^ position,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.Geometry..::.Face
A face of a geometry object.
position
Type: Autodesk.Revit.Geometry..::.Line
A line on the face defining where the symbol is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, StructuralType)

[image]

Revit 2010 API
FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
Specify if the family instance is structural.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (Curve, FamilySymbol, Level, StructuralType)

[image]

Revit 2010 API
FamilyInstanceCreationData Constructor (Curve, FamilySymbol, Level, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    curve As Curve, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
The curve where the instance is based.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.Elements..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (Face, XYZ, XYZ, FamilySymbol)

[image]

Revit 2010 API
FamilyInstanceCreationData Constructor (Face, XYZ, XYZ, FamilySymbol)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    Face face,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Sub New ( _
    face As Face, _
    location As XYZ, _
    referenceDirection As XYZ, _
    symbol As FamilySymbol _
)
Visual C++
public:
FamilyInstanceCreationData(
    Face^ face,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.Geometry..::.Face
A face of a geometry object.
location
Type: Autodesk.Revit.Geometry..::.XYZ
Point on the face where the instance is to be placed.
referenceDirection
Type: Autodesk.Revit.Geometry..::.XYZ
A vector that defines the direction of the family instance.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Element, StructuralType)

[image]

Revit 2010 API
FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Element, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit..::.Element
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Level, StructuralType)

[image]

Revit 2010 API
FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Level, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.Elements..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Element, Level, StructuralType)

[image]

Revit 2010 API
FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Element, Level, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    level As Level, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit..::.Element
The object into which the FamilyInstance is to be inserted, often known as the host.
level
Type: Autodesk.Revit.Elements..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, XYZ, Element, StructuralType)

[image]

Revit 2010 API
FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, XYZ, Element, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    XYZ referenceDirection,
    Element host,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    referenceDirection As XYZ, _
    host As Element, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    XYZ^ referenceDirection,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
referenceDirection
Type: Autodesk.Revit.Geometry..::.XYZ
A vector that dictates the direction of certain family instances.
host
Type: Autodesk.Revit..::.Element
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Methods

[image] [image]

Revit 2010 API
FamilyInstanceCreationData Methods
FamilyInstanceCreationData Class See Also Send Feedback

The FamilyInstanceCreationData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Properties

[image] [image]

Revit 2010 API
FamilyInstanceCreationData Properties
FamilyInstanceCreationData Class See Also Send Feedback

The FamilyInstanceCreationData type exposes the following members.

Properties

Name | Description
Axis | Get or set the axis of the FamilyInstance
RotateAngle | Get or set the rotate angle of the FamilyInstance

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


Axis Property

[image]

Revit 2010 API
FamilyInstanceCreationData..::.Axis Property
FamilyInstanceCreationData Class See Also Send Feedback
Get or set the axis of the FamilyInstance

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Line Axis { get; set; }
Visual Basic (Declaration)
Public Property Axis As Line
Visual C++
public:
property Line^ Axis {
    Line^ get ();
    void set (Line^ value);
}

Remarks

The element property will be the axis while performing the rotation.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


RotateAngle Property

[image]

Revit 2010 API
FamilyInstanceCreationData..::.RotateAngle Property
FamilyInstanceCreationData Class See Also Send Feedback
Get or set the rotate angle of the FamilyInstance

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double RotateAngle { get; set; }
Visual Basic (Declaration)
Public Property RotateAngle As Double
Visual C++
public:
property double RotateAngle {
    double get ();
    void set (double value);
}

Remarks

The FamilyInstance will rotate this angle when the instance is created.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory Class

[image]

Revit 2010 API
FamilyItemFactory Class
Members See Also Send Feedback
The Family Item Factory object is used to create new instances of elements within the Autodesk Revit Family.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FamilyItemFactory : ItemFactoryBase
Visual Basic (Declaration)
Public Class FamilyItemFactory _
    Inherits ItemFactoryBase
Visual C++
public ref class FamilyItemFactory : public ItemFactoryBase

Remarks

The Family Item Factory object is a utility object that is used to create new instances of elements within the Autodesk Revit Family Document. This object, available from the Autodesk.Revit.Document.FamilyCreate property should be used to create elements instead of using New. This object ensures that the elements created are added to the family document correctly. The object can create a limited number of types, which is expected to increase as the API matures.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Creation..::.ItemFactoryBase
Autodesk.Revit.Creation..::.FamilyItemFactory

See Also

FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


FamilyItemFactory Members

[image] [image]

Revit 2010 API
FamilyItemFactory Members
FamilyItemFactory Class Constructors Methods Properties See Also Send Feedback

The FamilyItemFactory type exposes the following members.

Constructors

Name | Description
FamilyItemFactory | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase.)
NewAngularDimension | Overloaded. Creates a new angular dimension object.
NewAnnotationSymbol | Add a new instance of an Annotation Symbol into the Autodesk Revit document, using a location and a symbol. (Inherited from ItemFactoryBase.)
NewArcLengthDimension | Overloaded. Creates a new arc length dimension object.
NewBlend | Add a new Blend instance into the Autodesk Revit family document.
NewControl | Add a new control into the Autodesk Revit family document.
NewCurveByPoints | Create a 3d curve through two or more points in an Autodesk Revit family document.
NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase.)
NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase.)
NewDimension | Overloaded. Creates a new linear dimension object.
NewDividedSurface | Create a DividedSurface element on one surface of another element.
NewDuctConnector | Add a new duct connector into the Autodesk Revit family document.
NewElectricalConnector | Add a new Electrical connector into the Autodesk Revit family document.
NewExtrusion | Add a new Extrusion instance into the Autodesk Revit family document.
NewExtrusionForm | Create new Form element by Extrude operation, and add it into the Autodesk Revit family document.
NewFamilyInstance | Overloaded. Inserts a new instance of a family into the document.
NewFamilyInstances | Creates Family instances within the document. (Inherited from ItemFactoryBase.)
NewFormByCap | Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.
NewFormByThickenSingleSurface | Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.
NewGroup | Creates a new type of group. (Inherited from ItemFactoryBase.)
NewLevel | Creates a new level. (Inherited from ItemFactoryBase.)
NewLinearDimension | Overloaded. Creates a new linear dimension object.
NewLoftForm | Create new Form element by Loft operation, and add it into the Autodesk Revit family document.
NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase.)
NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase.)
NewModelText | Create a model text in the Autodesk Revit family document.
NewOpening | Create an opening to cut the wall or ceiling.
NewPipeConnector | Add a new pipe connector into the Autodesk Revit family document.
NewRadialDimension | Overloaded. Creates a new radial dimension object.
NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
NewReferencePoint | Overloaded. Creates a reference point.
NewRevolution | Add a new Revolution instance into the Autodesk Revit family document.
NewRevolveForms | Create new Form elements by revolve operation, and add them into the Autodesk Revit family document.
NewSketchPlane | Overloaded. Creates a new sketch plane.
NewSweep | Overloaded. Adds a new sweep form to the family document.
NewSweptBlend | Overloaded. Adds a new swept blend into the family document.
NewSweptBlendForm | Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.
NewSymbolicCurve | Create a symbolic curve in an Autodesk Revit family document.
NewTextNote | Overloaded. Creates a new TextNote object.
NewTextNotes | Creates TextNotes with the specified data. (Inherited from ItemFactoryBase.)
NewView3D | Creates a new 3D view. (Inherited from ItemFactoryBase.)
NewViewPlan | Creates a plan view based on the specified level. (Inherited from ItemFactoryBase.)
NewViewSection | Creates a new section view. (Inherited from ItemFactoryBase.)
PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory Constructor

[image]

Revit 2010 API
FamilyItemFactory Constructor
FamilyItemFactory Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyItemFactory()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilyItemFactory()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory Methods

[image] [image]

Revit 2010 API
FamilyItemFactory Methods
FamilyItemFactory Class See Also Send Feedback

The FamilyItemFactory type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase.)
NewAngularDimension | Overloaded. Creates a new angular dimension object.
NewAnnotationSymbol | Add a new instance of an Annotation Symbol into the Autodesk Revit document, using a location and a symbol. (Inherited from ItemFactoryBase.)
NewArcLengthDimension | Overloaded. Creates a new arc length dimension object.
NewBlend | Add a new Blend instance into the Autodesk Revit family document.
NewControl | Add a new control into the Autodesk Revit family document.
NewCurveByPoints | Create a 3d curve through two or more points in an Autodesk Revit family document.
NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase.)
NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase.)
NewDimension | Overloaded. Creates a new linear dimension object.
NewDividedSurface | Create a DividedSurface element on one surface of another element.
NewDuctConnector | Add a new duct connector into the Autodesk Revit family document.
NewElectricalConnector | Add a new Electrical connector into the Autodesk Revit family document.
NewExtrusion | Add a new Extrusion instance into the Autodesk Revit family document.
NewExtrusionForm | Create new Form element by Extrude operation, and add it into the Autodesk Revit family document.
NewFamilyInstance | Overloaded. Inserts a new instance of a family into the document.
NewFamilyInstances | Creates Family instances within the document. (Inherited from ItemFactoryBase.)
NewFormByCap | Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.
NewFormByThickenSingleSurface | Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.
NewGroup | Creates a new type of group. (Inherited from ItemFactoryBase.)
NewLevel | Creates a new level. (Inherited from ItemFactoryBase.)
NewLinearDimension | Overloaded. Creates a new linear dimension object.
NewLoftForm | Create new Form element by Loft operation, and add it into the Autodesk Revit family document.
NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase.)
NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase.)
NewModelText | Create a model text in the Autodesk Revit family document.
NewOpening | Create an opening to cut the wall or ceiling.
NewPipeConnector | Add a new pipe connector into the Autodesk Revit family document.
NewRadialDimension | Overloaded. Creates a new radial dimension object.
NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
NewReferencePoint | Overloaded. Creates a reference point.
NewRevolution | Add a new Revolution instance into the Autodesk Revit family document.
NewRevolveForms | Create new Form elements by revolve operation, and add them into the Autodesk Revit family document.
NewSketchPlane | Overloaded. Creates a new sketch plane.
NewSweep | Overloaded. Adds a new sweep form to the family document.
NewSweptBlend | Overloaded. Adds a new swept blend into the family document.
NewSweptBlendForm | Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.
NewSymbolicCurve | Create a symbolic curve in an Autodesk Revit family document.
NewTextNote | Overloaded. Creates a new TextNote object.
NewTextNotes | Creates TextNotes with the specified data. (Inherited from ItemFactoryBase.)
NewView3D | Creates a new 3D view. (Inherited from ItemFactoryBase.)
NewViewPlan | Creates a plan view based on the specified level. (Inherited from ItemFactoryBase.)
NewViewSection | Creates a new section view. (Inherited from ItemFactoryBase.)
PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewAngularDimension Method

[image] [image]

Revit 2010 API
FamilyItemFactory..::.NewAngularDimension Method
FamilyItemFactory Class See Also Send Feedback
Creates a new angular dimension object.

Overload List

Name | Description
NewAngularDimension(View, Arc, Reference, Reference) | Creates a new angular dimension object using the default dimension type.
NewAngularDimension(View, Arc, Reference, Reference, DimensionType) | Creates a new angular dimension object using the specified dimension type.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewAngularDimension Method (View, Arc, Reference, Reference)

[image]

Revit 2010 API
FamilyItemFactory..::.NewAngularDimension Method (View, Arc, Reference, Reference)
FamilyItemFactory Class See Also Send Feedback
Creates a new angular dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Dimension NewAngularDimension(
    View view,
    Arc arc,
    Reference firstRef,
    Reference secondRef
)
Visual Basic (Declaration)
Public Function NewAngularDimension ( _
    view As View, _
    arc As Arc, _
    firstRef As Reference, _
    secondRef As Reference _
) As Dimension
Visual C++
public:
Dimension^ NewAngularDimension(
    View^ view,
    Arc^ arc,
    Reference^ firstRef,
    Reference^ secondRef
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the dimension is to be visible.
arc
Type: Autodesk.Revit.Geometry..::.Arc
The extension arc of the dimension.
firstRef
Type: Autodesk.Revit.Geometry..::.Reference
The first geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
secondRef
Type: Autodesk.Revit.Geometry..::.Reference
The second geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.

Return Value

If creation was successful the new angular dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The currently user set default style is used for the created dimension.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when any input argument is null.
System..::.ArgumentException | Thrown when the argument is invalid.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewAngularDimension Overload
Autodesk.Revit.Creation Namespace


NewAngularDimension Method (View, Arc, Reference, Reference, DimensionType)

[image]

Revit 2010 API
FamilyItemFactory..::.NewAngularDimension Method (View, Arc, Reference, Reference, DimensionType)
FamilyItemFactory Class See Also Send Feedback
Creates a new angular dimension object using the specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Dimension NewAngularDimension(
    View view,
    Arc arc,
    Reference firstRef,
    Reference secondRef,
    DimensionType dimensionType
)
Visual Basic (Declaration)
Public Function NewAngularDimension ( _
    view As View, _
    arc As Arc, _
    firstRef As Reference, _
    secondRef As Reference, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewAngularDimension(
    View^ view,
    Arc^ arc,
    Reference^ firstRef,
    Reference^ secondRef,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the dimension is to be visible.
arc
Type: Autodesk.Revit.Geometry..::.Arc
The extension arc of the dimension.
firstRef
Type: Autodesk.Revit.Geometry..::.Reference
The first geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
secondRef
Type: Autodesk.Revit.Geometry..::.Reference
The second geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
dimensionType
Type: Autodesk.Revit.Symbols..::.DimensionType
The dimension style to be used for the dimension.

Return Value

If creation was successful the new angular dimension is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when any input argument is null.
System..::.ArgumentException | Thrown when the argument firstRef/secondRef/dimensionType is invalid.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewAngularDimension Overload
Autodesk.Revit.Creation Namespace


NewArcLengthDimension Method

[image] [image]

Revit 2010 API
FamilyItemFactory..::.NewArcLengthDimension Method
FamilyItemFactory Class See Also Send Feedback
Creates a new arc length dimension object.

Overload List

Name | Description
NewArcLengthDimension(View, Arc, Reference, Reference, Reference) | Creates a new arc length dimension object using the default dimension type.
NewArcLengthDimension(View, Arc, Reference, Reference, Reference, DimensionType) | Creates a new arc length dimension object using the specified dimension type.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewArcLengthDimension Method (View, Arc, Reference, Reference, Reference)

[image]

Revit 2010 API
FamilyItemFactory..::.NewArcLengthDimension Method (View, Arc, Reference, Reference, Reference)
FamilyItemFactory Class Example See Also Send Feedback
Creates a new arc length dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Dimension NewArcLengthDimension(
    View view,
    Arc arc,
    Reference arcRef,
    Reference firstRef,
    Reference secondRef
)
Visual Basic (Declaration)
Public Function NewArcLengthDimension ( _
    view As View, _
    arc As Arc, _
    arcRef As Reference, _
    firstRef As Reference, _
    secondRef As Reference _
) As Dimension
Visual C++
public:
Dimension^ NewArcLengthDimension(
    View^ view,
    Arc^ arc,
    Reference^ arcRef,
    Reference^ firstRef,
    Reference^ secondRef
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the dimension is to be visible.
arc
Type: Autodesk.Revit.Geometry..::.Arc
The extension arc of the dimension.
arcRef
Type: Autodesk.Revit.Geometry..::.Reference
Geometric reference of the arc to which the dimension is to be bound. This reference must be parallel to the extension arc.
firstRef
Type: Autodesk.Revit.Geometry..::.Reference
The first geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
secondRef
Type: Autodesk.Revit.Geometry..::.Reference
The second geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.

Return Value

If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The currently user set default style is used for the created dimension.

Examples

CopyC#
public Dimension CreateArcDimension(Document document, SketchPlane sketchPlane)
{
    Autodesk.Revit.Creation.Application appCreate = document.Application.Create;
    Line gLine1 = appCreate.NewLine(new XYZ(0, 2, 0), new XYZ(2, 2, 0), true);
    Line gLine2 = appCreate.NewLine(new XYZ(0, 2, 0), new XYZ(2, 4, 0), true);
    Arc arctoDim = appCreate.NewArc(new XYZ(1, 2, 0), new XYZ(-1, 2, 0), new XYZ(0, 3, 0));
    Arc arcofDim = appCreate.NewArc(new XYZ(0, 3, 0), new XYZ(1, 2, 0), new XYZ(0.8, 2.8, 0));

    Autodesk.Revit.Creation.FamilyItemFactory creationFamily = document.FamilyCreate;
    ModelCurve modelCurve1 = creationFamily.NewModelCurve(gLine1, sketchPlane);
    ModelCurve modelCurve2 = creationFamily.NewModelCurve(gLine2, sketchPlane);
    ModelCurve modelCurve3 = creationFamily.NewModelCurve(arctoDim, sketchPlane);
    //get their reference
    Reference ref1 = modelCurve1.GeometryCurve.Reference;
    Reference ref2 = modelCurve2.GeometryCurve.Reference;
    Reference arcRef = modelCurve3.GeometryCurve.Reference;

    Dimension newArcDim = creationFamily.NewArcLengthDimension(document.ActiveView, arcofDim, arcRef, ref1, ref2);
    if (newArcDim == null)
    {
        throw new Exception("Failed to create new arc length dimension.");
    }

    return newArcDim;
}
CopyVB.NET
Public Function CreateArcDimension(ByVal document As Document, ByVal sketchPlane As Autodesk.Revit.Elements.SketchPlane) As Autodesk.Revit.Elements.Dimension
    Dim appCreate As Autodesk.Revit.Creation.Application = document.Application.Create
    Dim gLine1 As Line = appCreate.NewLine(New Autodesk.Revit.Geometry.XYZ(0, 2, 0), _
                                           New Autodesk.Revit.Geometry.XYZ(2, 2, 0), True)
    Dim gLine2 As Line = appCreate.NewLine(New Autodesk.Revit.Geometry.XYZ(0, 2, 0), _
                                           New Autodesk.Revit.Geometry.XYZ(2, 4, 0), True)
    Dim arctoDim As Arc = appCreate.NewArc(New Autodesk.Revit.Geometry.XYZ(1, 2, 0), _
                                           New Autodesk.Revit.Geometry.XYZ(-1, 2, 0), _
                                           New Autodesk.Revit.Geometry.XYZ(0, 3, 0))
    Dim arcofDim As Arc = appCreate.NewArc(New Autodesk.Revit.Geometry.XYZ(0, 3, 0), _
                                           New Autodesk.Revit.Geometry.XYZ(1, 2, 0), _
                                           New Autodesk.Revit.Geometry.XYZ(0.8, 2.8, 0))

    Dim creationFamily As Autodesk.Revit.Creation.FamilyItemFactory = document.FamilyCreate
    Dim modelCurve1 As ModelCurve = creationFamily.NewModelCurve(gLine1, sketchPlane)
    Dim modelCurve2 As ModelCurve = creationFamily.NewModelCurve(gLine2, sketchPlane)
    Dim modelCurve3 As ModelCurve = creationFamily.NewModelCurve(arctoDim, sketchPlane)
    'get their reference
    Dim ref1 As Reference = modelCurve1.GeometryCurve.Reference
    Dim ref2 As Reference = modelCurve2.GeometryCurve.Reference
    Dim arcRef As Reference = modelCurve3.GeometryCurve.Reference

    Dim newArcDim As Autodesk.Revit.Elements.Dimension = creationFamily.NewArcLengthDimension(document.ActiveView, arcofDim, arcRef, ref1, ref2)
    If newArcDim Is Nothing Then
        Throw New Exception("Failed to create new arc length dimension.")
    End If

    Return newArcDim
End Function

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when any input argument is null.
System..::.ArgumentException | Thrown when the argument arcRef/ref1/ref2 is invalid.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewArcLengthDimension Overload
Autodesk.Revit.Creation Namespace


NewArcLengthDimension Method (View, Arc, Reference, Reference, Reference, DimensionType)

[image]

Revit 2010 API
FamilyItemFactory..::.NewArcLengthDimension Method (View, Arc, Reference, Reference, Reference, DimensionType)
FamilyItemFactory Class See Also Send Feedback
Creates a new arc length dimension object using the specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Dimension NewArcLengthDimension(
    View view,
    Arc arc,
    Reference arcRef,
    Reference firstRef,
    Reference secondRef,
    DimensionType dimensionType
)
Visual Basic (Declaration)
Public Function NewArcLengthDimension ( _
    view As View, _
    arc As Arc, _
    arcRef As Reference, _
    firstRef As Reference, _
    secondRef As Reference, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewArcLengthDimension(
    View^ view,
    Arc^ arc,
    Reference^ arcRef,
    Reference^ firstRef,
    Reference^ secondRef,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the dimension is to be visible.
arc
Type: Autodesk.Revit.Geometry..::.Arc
The extension arc of the dimension.
arcRef
Type: Autodesk.Revit.Geometry..::.Reference
Geometric reference of the arc to which the dimension is to be bound. This reference must be parallel to the extension arc.
firstRef
Type: Autodesk.Revit.Geometry..::.Reference
The first geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
secondRef
Type: Autodesk.Revit.Geometry..::.Reference
The second geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
dimensionType
Type: Autodesk.Revit.Symbols..::.DimensionType
The dimension style to be used for the dimension.

Return Value

If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when any input argument is null.
System..::.ArgumentException | Thrown when the argument arcRef/ref1/ref2/dimensionType is invalid.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewArcLengthDimension Overload
Autodesk.Revit.Creation Namespace


NewBlend Method

[image]

Revit 2010 API
FamilyItemFactory..::.NewBlend Method
FamilyItemFactory Class Example See Also Send Feedback
Add a new Blend instance into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Blend NewBlend(
    bool isSolid,
    CurveArray topProfile,
    CurveArray baseProfile,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Function NewBlend ( _
    isSolid As Boolean, _
    topProfile As CurveArray, _
    baseProfile As CurveArray, _
    sketchPlane As SketchPlane _
) As Blend
Visual C++
public:
Blend^ NewBlend(
    bool isSolid,
    CurveArray^ topProfile,
    CurveArray^ baseProfile,
    SketchPlane^ sketchPlane
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Blend is Solid or Void.
topProfile
Type: Autodesk.Revit.Geometry..::.CurveArray
The top blend section. It should consist of only one curve loop. The input profile must be in one plane.
baseProfile
Type: Autodesk.Revit.Geometry..::.CurveArray
The base blend section. It should consist of only one curve loop. The input profile must be in one plane.
sketchPlane
Type: Autodesk.Revit.Elements..::.SketchPlane
The sketch plane for the base profile. Use this to associate the base of the blend to geometry from another element. Optional, it can be null if you want Revit to derive a new sketch plane from the geometry of the base profile.

Return Value

If creation was successful the new blend is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a blend in a family document. The blend will be extended between the two independent pieces of geometry. Revit will determine an appropriate default mapping for the vertices of the two profiles. The two input profiles must be parallel. If the input profile is to be a cyclic profile (curve or ellipse) it must be split into at least two segments, so that Revit can find vertices to use for mapping the blend.

Examples

CopyC#
private Blend CreateBlend(Autodesk.Revit.Application application, SketchPlane sketchPlane)
{
    Blend blend = null;

    // make sure we have a family document
    Document familyDocument = application.ActiveDocument;
    if (true == familyDocument.IsFamilyDocument)
    {
        // Define top and base profiles for the blend
        CurveArray topProfile = new CurveArray();
        CurveArray baseProfile = new CurveArray();

        // create rectangular base profile
        XYZ p00 = XYZ.Zero;
        XYZ p01 = new XYZ(10, 0, 0);
        XYZ p02 = new XYZ(10, 10, 0);
        XYZ p03 = new XYZ(0, 10, 0);
        Line line01 = application.Create.NewLineBound(p00, p01);
        Line line02 = application.Create.NewLineBound(p01, p02);
        Line line03 = application.Create.NewLineBound(p02, p03);
        Line line04 = application.Create.NewLineBound(p03, p00);

        baseProfile.Append(line01);
        baseProfile.Append(line02);
        baseProfile.Append(line03);
        baseProfile.Append(line04);

        // create rectangular top profile
        XYZ p10 = new XYZ(5, 2, 10);
        XYZ p11 = new XYZ(8, 5, 10);
        XYZ p12 = new XYZ(5, 8, 10);
        XYZ p13 = new XYZ(2, 5, 10);
        Line line11 = application.Create.NewLineBound(p10, p11);
        Line line12 = application.Create.NewLineBound(p11, p12);
        Line line13 = application.Create.NewLineBound(p12, p13);
        Line line14 = application.Create.NewLineBound(p13, p10);

        topProfile.Append(line11);
        topProfile.Append(line12);
        topProfile.Append(line13);
        topProfile.Append(line14);

        // now create solid rectangular blend
        blend = familyDocument.FamilyCreate.NewBlend(true, topProfile, baseProfile, sketchPlane);

        if (null != blend)
        {
            // move to proper place
            XYZ transPoint1 = new XYZ(0, 11, 0);
            familyDocument.Move(blend, transPoint1);
        }
        else
        {
            throw new Exception("Create new Blend failed.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }

    return blend;
}
CopyVB.NET
Private Function CreateBlend(ByVal application As Autodesk.Revit.Application, ByVal sketchPlane As Autodesk.Revit.Elements.SketchPlane) As Blend
    Dim blend As Blend = Nothing

    ' make sure we have a family document
    Dim familyDocument As Document = application.ActiveDocument
    If True = familyDocument.IsFamilyDocument Then
        ' Define top and base profiles for the blend
        Dim topProfile As New CurveArray()
        Dim baseProfile As New CurveArray()

        ' create rectangular base profile
        Dim p00 As Autodesk.Revit.Geometry.XYZ = Autodesk.Revit.Geometry.XYZ.Zero
        Dim p01 As New Autodesk.Revit.Geometry.XYZ(10, 0, 0)
        Dim p02 As New Autodesk.Revit.Geometry.XYZ(10, 10, 0)
        Dim p03 As New Autodesk.Revit.Geometry.XYZ(0, 10, 0)
        Dim line01 As Line = application.Create.NewLineBound(p00, p01)
        Dim line02 As Line = application.Create.NewLineBound(p01, p02)
        Dim line03 As Line = application.Create.NewLineBound(p02, p03)
        Dim line04 As Line = application.Create.NewLineBound(p03, p00)

        baseProfile.Append(line01)
        baseProfile.Append(line02)
        baseProfile.Append(line03)
        baseProfile.Append(line04)

        ' create rectangular top profile
        Dim p10 As New Autodesk.Revit.Geometry.XYZ(5, 2, 10)
        Dim p11 As New Autodesk.Revit.Geometry.XYZ(8, 5, 10)
        Dim p12 As New Autodesk.Revit.Geometry.XYZ(5, 8, 10)
        Dim p13 As New Autodesk.Revit.Geometry.XYZ(2, 5, 10)
        Dim line11 As Line = application.Create.NewLineBound(p10, p11)
        Dim line12 As Line = application.Create.NewLineBound(p11, p12)
        Dim line13 As Line = application.Create.NewLineBound(p12, p13)
        Dim line14 As Line = application.Create.NewLineBound(p13, p10)

        topProfile.Append(line11)
        topProfile.Append(line12)
        topProfile.Append(line13)
        topProfile.Append(line14)

        ' now create solid rectangular blend
        blend = familyDocument.FamilyCreate.NewBlend(True, topProfile, baseProfile, sketchPlane)

        If blend IsNot Nothing Then
            ' move to proper place
            Dim transPoint1 As New Autodesk.Revit.Geometry.XYZ(0, 11, 0)
            familyDocument.Move(blend, transPoint1)
        Else
            Throw New Exception("Create new Blend failed.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If

    Return blend
End Function

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the argument is invalid.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewControl Method

[image]

Revit 2010 API
FamilyItemFactory..::.NewControl Method
FamilyItemFactory Class See Also Send Feedback
Add a new control into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Control NewControl(
    ControlShape controlShape,
    View view,
    XYZ origin
)
Visual Basic (Declaration)
Public Function NewControl ( _
    controlShape As ControlShape, _
    view As View, _
    origin As XYZ _
) As Control
Visual C++
public:
Control^ NewControl(
    ControlShape controlShape,
    View^ view,
    XYZ^ origin
)

Parameters

controlShape
Type: Autodesk.Revit.Elements..::.ControlShape
The shape of the control.
view
Type: Autodesk.Revit.Elements..::.View
The view in which the control is to be visible. It must be a FloorPlan view or a CeilingPlan view.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The origin of the control.

Return Value

If successful, the newly created control is returned, otherwise an exception with error information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"view" or "position"-is null.
System..::.ArgumentException | Thrown when the input argument-"view"-is invalid.
System..::.ArgumentOutOfRangeException | Thrown when the input argument-"controlType"-is out of range.
System..::.InvalidOperationException | Thrown when control creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewCurveByPoints Method

[image]

Revit 2010 API
FamilyItemFactory..::.NewCurveByPoints Method
FamilyItemFactory Class See Also Send Feedback
Create a 3d curve through two or more points in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveByPoints NewCurveByPoints(
    ReferencePointArray points
)
Visual Basic (Declaration)
Public Function NewCurveByPoints ( _
    points As ReferencePointArray _
) As CurveByPoints
Visual C++
public:
CurveByPoints^ NewCurveByPoints(
    ReferencePointArray^ points
)

Parameters

points
Type: Autodesk.Revit.Elements..::.ReferencePointArray
Two or more PointElements. The curve will interpolate these points.

Return Value

The newly created curve.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when points is null.
System..::.ArgumentException | Thrown when points does not contain at least two PointElements.
System..::.InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewDimension Method

[image] [image]

Revit 2010 API
FamilyItemFactory..::.NewDimension Method
FamilyItemFactory Class See Also Send Feedback
Creates a new linear dimension object.

Overload List

Name | Description
NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. (Inherited from ItemFactoryBase.)
NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. (Inherited from ItemFactoryBase.)

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewDividedSurface Method

[image]

Revit 2010 API
FamilyItemFactory..::.NewDividedSurface Method
FamilyItemFactory Class See Also Send Feedback
Create a DividedSurface element on one surface of another element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DividedSurface NewDividedSurface(
    Reference hostReference
)
Visual Basic (Declaration)
Public Function NewDividedSurface ( _
    hostReference As Reference _
) As DividedSurface
Visual C++
public:
DividedSurface^ NewDividedSurface(
    Reference^ hostReference
)

Parameters

hostReference
Type: Autodesk.Revit.Geometry..::.Reference
Reference to a surface on an existing element. The element must be one of the following: Form, GeomCombination, FamilyInstance, or ImportInstance.

Return Value

The newly created DividedSurface element.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when surface is not a reference to a surface, or when the referenced element does not support divided surfaces.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewDuctConnector Method

[image]

Revit 2010 API
FamilyItemFactory..::.NewDuctConnector Method
FamilyItemFactory Class See Also Send Feedback
Add a new duct connector into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DuctConnector NewDuctConnector(
    Reference planarFaceReference,
    DuctSystemType systemType
)
Visual Basic (Declaration)
Public Function NewDuctConnector ( _
    planarFaceReference As Reference, _
    systemType As DuctSystemType _
) As DuctConnector
Visual C++
public:
DuctConnector^ NewDuctConnector(
    Reference^ planarFaceReference,
    DuctSystemType systemType
)

Parameters

planarFaceReference
Type: Autodesk.Revit.Geometry..::.Reference
A reference to a planar face where the connector will be placed.
systemType
Type: Autodesk.Revit.MEP.Enums..::.DuctSystemType
Indicates the system type of this new duct connector.

Return Value

If creation was successful the new Duct Connector is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a duct connector in a family document. The duct connector will be placed at the centroid of the planar face.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the argument planarFaceReference is invalid.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewElectricalConnector Method

[image]

Revit 2010 API
FamilyItemFactory..::.NewElectricalConnector Method
FamilyItemFactory Class See Also Send Feedback
Add a new Electrical connector into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElectricalConnector NewElectricalConnector(
    Reference planarFaceReference,
    ElectricalSystemType systemType
)
Visual Basic (Declaration)
Public Function NewElectricalConnector ( _
    planarFaceReference As Reference, _
    systemType As ElectricalSystemType _
) As ElectricalConnector
Visual C++
public:
ElectricalConnector^ NewElectricalConnector(
    Reference^ planarFaceReference,
    ElectricalSystemType systemType
)

Parameters

planarFaceReference
Type: Autodesk.Revit.Geometry..::.Reference
A reference to a planar face where the connector will be placed.
systemType
Type: Autodesk.Revit.MEP.Enums..::.ElectricalSystemType
Indicates the system type of this new Electrical connector.

Return Value

If creation was successful the new Electrical Connector is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates an Electrical Connector in a family document. The electrical connector will be placed at the centroid of the planar face.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the argument planarFaceReference is invalid.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewExtrusion Method

[image]

Revit 2010 API
FamilyItemFactory..::.NewExtrusion Method
FamilyItemFactory Class Example See Also Send Feedback
Add a new Extrusion instance into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Extrusion NewExtrusion(
    bool isSolid,
    CurveArrArray profile,
    SketchPlane sketchPlane,
    double end
)
Visual Basic (Declaration)
Public Function NewExtrusion ( _
    isSolid As Boolean, _
    profile As CurveArrArray, _
    sketchPlane As SketchPlane, _
    end As Double _
) As Extrusion
Visual C++
public:
Extrusion^ NewExtrusion(
    bool isSolid,
    CurveArrArray^ profile,
    SketchPlane^ sketchPlane,
    double end
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Extrusion is Solid or Void.
profile
Type: Autodesk.Revit.Geometry..::.CurveArrArray
The profile of the newly created Extrusion. This may contain more than one curve loop. Each loop must be a fully closed curve loop and the loops may not intersect. All input curves must lie in the same plane. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy reqiurements for sketches used in extrusions.
sketchPlane
Type: Autodesk.Revit.Elements..::.SketchPlane
The sketch plane for the extrusion. The direction of extrusion is determined by the normal for the sketch plane. To extrude in the other direction set the end value to negative.
end
Type: System..::.Double
The length of the extrusion.

Return Value

If creation was successful the new Extrusion is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates an extrusion in a family document. The extrusion will be extended perpendicular to the sketch plane of the extrusion profile.

Examples

CopyC#
private Extrusion CreateExtrusion(Autodesk.Revit.Document document, SketchPlane sketchPlane)
{
    Extrusion rectExtrusion = null;

    // make sure we have a family document
    if (true == document.IsFamilyDocument)
    {
        // define the profile for the extrusion
        CurveArrArray curveArrArray = new CurveArrArray();
        CurveArray curveArray1 = new CurveArray();
        CurveArray curveArray2 = new CurveArray();
        CurveArray curveArray3 = new CurveArray();

        // create a rectangular profile
        XYZ p0 = XYZ.Zero;
        XYZ p1 = new XYZ(10, 0, 0);
        XYZ p2 = new XYZ(10, 10, 0);
        XYZ p3 = new XYZ(0, 10, 0);
        Line line1 = document.Application.Create.NewLineBound(p0, p1);
        Line line2 = document.Application.Create.NewLineBound(p1, p2);
        Line line3 = document.Application.Create.NewLineBound(p2, p3);
        Line line4 = document.Application.Create.NewLineBound(p3, p0);
        curveArray1.Append(line1);
        curveArray1.Append(line2);
        curveArray1.Append(line3);
        curveArray1.Append(line4);

        curveArrArray.Append(curveArray1);

        // create solid rectangular extrusion
        rectExtrusion = document.FamilyCreate.NewExtrusion(true, curveArrArray, sketchPlane, 10);

        if (null != rectExtrusion)
        {
            // move extrusion to proper place
            XYZ transPoint1 = new XYZ(-16, 0, 0);
            document.Move(rectExtrusion, transPoint1);
        }
        else
        {
            throw new Exception("Create new Extrusion failed.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }

    return rectExtrusion;
}
CopyVB.NET
Private Function CreateExtrusion(ByVal document As Autodesk.Revit.Document, ByVal sketchPlane As Autodesk.Revit.Elements.SketchPlane) As Extrusion
    Dim rectExtrusion As Extrusion = Nothing

    ' make sure we have a family document
    If True = document.IsFamilyDocument Then
        ' define the profile for the extrusion
        Dim curveArrArray As New CurveArrArray()
        Dim curveArray1 As New CurveArray()
        Dim curveArray2 As New CurveArray()
        Dim curveArray3 As New CurveArray()

        ' create a rectangular profile
        Dim p0 As Autodesk.Revit.Geometry.XYZ = Autodesk.Revit.Geometry.XYZ.Zero
        Dim p1 As New Autodesk.Revit.Geometry.XYZ(10, 0, 0)
        Dim p2 As New Autodesk.Revit.Geometry.XYZ(10, 10, 0)
        Dim p3 As New Autodesk.Revit.Geometry.XYZ(0, 10, 0)
        Dim line1 As Line = document.Application.Create.NewLineBound(p0, p1)
        Dim line2 As Line = document.Application.Create.NewLineBound(p1, p2)
        Dim line3 As Line = document.Application.Create.NewLineBound(p2, p3)
        Dim line4 As Line = document.Application.Create.NewLineBound(p3, p0)
        curveArray1.Append(line1)
        curveArray1.Append(line2)
        curveArray1.Append(line3)
        curveArray1.Append(line4)

        curveArrArray.Append(curveArray1)

        ' create solid rectangular extrusion
        rectExtrusion = document.FamilyCreate.NewExtrusion(True, curveArrArray, sketchPlane, 10)

        If rectExtrusion IsNot Nothing Then
            ' move extrusion to proper place
            Dim transPoint1 As New Autodesk.Revit.Geometry.XYZ(-16, 0, 0)
            document.Move(rectExtrusion, transPoint1)
        Else
            Throw New Exception("Create new Extrusion failed.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If

    Return rectExtrusion
End Function

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the input argument-profile-is null or empty array.
System..::.ArgumentNullException | Thrown when the input argument-sketchPlane-is null.
System..::.ArgumentException | Thrown when the input argument-sketchPlane-is an invalid sketch plane.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewExtrusionForm Method

[image]

Revit 2010 API
FamilyItemFactory..::.NewExtrusionForm Method
FamilyItemFactory Class See Also Send Feedback
Create new Form element by Extrude operation, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Form NewExtrusionForm(
    bool isSolid,
    ReferenceArray profile,
    XYZ direction
)
Visual Basic (Declaration)
Public Function NewExtrusionForm ( _
    isSolid As Boolean, _
    profile As ReferenceArray, _
    direction As XYZ _
) As Form
Visual C++
public:
Form^ NewExtrusionForm(
    bool isSolid,
    ReferenceArray^ profile,
    XYZ^ direction
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Form is Solid or Void.
profile
Type: Autodesk.Revit.Geometry..::.ReferenceArray
The profile of extrusion. It should consist of only one curve loop. The input profile must be in one plane.
direction
Type: Autodesk.Revit.Geometry..::.XYZ
The direction of extrusion, with its length the length of the extrusion. The direction must be perpendicular to the plane determined by profile. The length of vector must be non-zero.

Return Value

If creation was successful new form is returned.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method

[image] [image]

Revit 2010 API
FamilyItemFactory..::.NewFamilyInstance Method
FamilyItemFactory Class See Also Send Feedback
Inserts a new instance of a family into the document.

Overload List

Name | Description
NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase.)
NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase.)
NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase.)

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewFormByCap Method

[image]

Revit 2010 API
FamilyItemFactory..::.NewFormByCap Method
FamilyItemFactory Class See Also Send Feedback
Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Form NewFormByCap(
    bool isSolid,
    ReferenceArray profile
)
Visual Basic (Declaration)
Public Function NewFormByCap ( _
    isSolid As Boolean, _
    profile As ReferenceArray _
) As Form
Visual C++
public:
Form^ NewFormByCap(
    bool isSolid,
    ReferenceArray^ profile
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Form is Solid or Void.
profile
Type: Autodesk.Revit.Geometry..::.ReferenceArray
The profile of the newly created cap. It should consist of only one curve loop. The input profile must be in one plane.

Return Value

If creation was successful new form is returned.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewFormByThickenSingleSurface Method

[image]

Revit 2010 API
FamilyItemFactory..::.NewFormByThickenSingleSurface Method
FamilyItemFactory Class See Also Send Feedback
Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Form NewFormByThickenSingleSurface(
    bool isSolid,
    Form singleSurfaceForm,
    XYZ thickenDir
)
Visual Basic (Declaration)
Public Function NewFormByThickenSingleSurface ( _
    isSolid As Boolean, _
    singleSurfaceForm As Form, _
    thickenDir As XYZ _
) As Form
Visual C++
public:
Form^ NewFormByThickenSingleSurface(
    bool isSolid,
    Form^ singleSurfaceForm,
    XYZ^ thickenDir
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Form is Solid or Void.
singleSurfaceForm
Type: Autodesk.Revit.Elements..::.Form
The single-surface form element. It can have one top/bottom face or one side face.
thickenDir
Type: Autodesk.Revit.Geometry..::.XYZ
The offset of capped solid.

Return Value

This function will modify the input singleSurfaceForm and return the same element.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewLinearDimension Method

[image] [image]

Revit 2010 API
FamilyItemFactory..::.NewLinearDimension Method
FamilyItemFactory Class See Also Send Feedback
Creates a new linear dimension object.

Overload List

Name | Description
NewLinearDimension(View, Line, ReferenceArray) | Generate a new linear dimension object using the default dimension type.
NewLinearDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension type.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewLinearDimension Method (View, Line, ReferenceArray)

[image]

Revit 2010 API
FamilyItemFactory..::.NewLinearDimension Method (View, Line, ReferenceArray)
FamilyItemFactory Class Example See Also Send Feedback
Generate a new linear dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Dimension NewLinearDimension(
    View view,
    Line line,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewLinearDimension ( _
    view As View, _
    line As Line, _
    references As ReferenceArray _
) As Dimension
Visual C++
public:
Dimension^ NewLinearDimension(
    View^ view,
    Line^ line,
    ReferenceArray^ references
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the dimension is to be visible.
line
Type: Autodesk.Revit.Geometry..::.Line
The extension line of the dimension.
references
Type: Autodesk.Revit.Geometry..::.ReferenceArray
An array of geometric references to which the dimension is to be bound. You must supply at least two references, and all references supplied must be parallel to each other and perpendicular to the extension line.

Return Value

If creation was successful the new linear dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The currently user set default style is used for the created dimension.

Examples

CopyC#
public Dimension CreateLinearDimension(Document document)
{
    // first create two lines
    XYZ pt1 = new XYZ(5, 5, 0);
    XYZ pt2 = new XYZ(5, 10, 0);
    Line line = document.Application.Create.NewLine(pt1, pt2, true);
    Plane plane = document.Application.Create.NewPlane(pt1.Cross(pt2), pt2);
    SketchPlane skplane = document.FamilyCreate.NewSketchPlane(plane);
    ModelCurve modelcurve1 = document.FamilyCreate.NewModelCurve(line, skplane);

    pt1 = new XYZ(10, 5, 0);
    pt2 = new XYZ(10, 10, 0);
    line = document.Application.Create.NewLine(pt1, pt2, true);
    plane = document.Application.Create.NewPlane(pt1.Cross(pt2), pt2);
    skplane = document.FamilyCreate.NewSketchPlane(plane);
    ModelCurve modelcurve2 = document.FamilyCreate.NewModelCurve(line, skplane);

    // now create a linear dimension between them
    ReferenceArray ra = new ReferenceArray();
    ra.Append(modelcurve1.GeometryCurve.Reference);
    ra.Append(modelcurve2.GeometryCurve.Reference);

    pt1 = new XYZ(5, 10, 0);
    pt2 = new XYZ(10, 10, 0);
    line = document.Application.Create.NewLine(pt1, pt2, true);

    Dimension dim = document.FamilyCreate.NewLinearDimension(document.ActiveView, line, ra);

    // create a label for the dimension called "width"
    FamilyParameter param = document.FamilyManager.AddParameter("width",
        Autodesk.Revit.Parameters.BuiltInParameterGroup.PG_CONSTRAINTS,
        Autodesk.Revit.Parameters.ParameterType.Length, false);

    dim.Label = param;

    return dim;
}
CopyVB.NET
Public Function CreateLinearDimension(ByVal document As Document) As Autodesk.Revit.Elements.Dimension
    ' first create two lines
    Dim pt1 As New Autodesk.Revit.Geometry.XYZ(5, 5, 0)
    Dim pt2 As New Autodesk.Revit.Geometry.XYZ(5, 10, 0)
    Dim line As Line = document.Application.Create.NewLine(pt1, pt2, True)
    Dim plane As Autodesk.Revit.Geometry.Plane = document.Application.Create.NewPlane(pt1.Cross(pt2), pt2)
    Dim skplane As Autodesk.Revit.Elements.SketchPlane = document.FamilyCreate.NewSketchPlane(plane)
    Dim modelcurve1 As ModelCurve = document.FamilyCreate.NewModelCurve(line, skplane)

    pt1 = New Autodesk.Revit.Geometry.XYZ(10, 5, 0)
    pt2 = New Autodesk.Revit.Geometry.XYZ(10, 10, 0)
    line = document.Application.Create.NewLine(pt1, pt2, True)
    plane = document.Application.Create.NewPlane(pt1.Cross(pt2), pt2)
    skplane = document.FamilyCreate.NewSketchPlane(plane)
    Dim modelcurve2 As ModelCurve = document.FamilyCreate.NewModelCurve(line, skplane)

    ' now create a linear dimension between them
    Dim ra As New ReferenceArray()
    ra.Append(modelcurve1.GeometryCurve.Reference)
    ra.Append(modelcurve2.GeometryCurve.Reference)

    pt1 = New Autodesk.Revit.Geometry.XYZ(5, 10, 0)
    pt2 = New Autodesk.Revit.Geometry.XYZ(10, 10, 0)
    line = document.Application.Create.NewLine(pt1, pt2, True)

    Dim [dim] As Autodesk.Revit.Elements.Dimension = document.FamilyCreate.NewLinearDimension(document.ActiveView, line, ra)

    ' create a label for the dimension called "width"
    Dim param As FamilyParameter = document.FamilyManager.AddParameter("width", Autodesk.Revit.Parameters.BuiltInParameterGroup.PG_CONSTRAINTS, Autodesk.Revit.Parameters.ParameterType.Length, False)

    [dim].Label = param

    Return [dim]
End Function

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when any input argument is null.
System..::.ArgumentException | Thrown when the argument "references" is invalid.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewLinearDimension Overload
Autodesk.Revit.Creation Namespace


NewLinearDimension Method (View, Line, ReferenceArray, DimensionType)

[image]

Revit 2010 API
FamilyItemFactory..::.NewLinearDimension Method (View, Line, ReferenceArray, DimensionType)
FamilyItemFactory Class See Also Send Feedback
Creates a new linear dimension object using the specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Dimension NewLinearDimension(
    View view,
    Line line,
    ReferenceArray references,
    DimensionType dimensionType
)
Visual Basic (Declaration)
Public Function NewLinearDimension ( _
    view As View, _
    line As Line, _
    references As ReferenceArray, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewLinearDimension(
    View^ view,
    Line^ line,
    ReferenceArray^ references,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the dimension is to be visible.
line
Type: Autodesk.Revit.Geometry..::.Line
The extension line of the dimension.
references
Type: Autodesk.Revit.Geometry..::.ReferenceArray
An array of geometric references to which the dimension is to be bound. You must supply at least two references, and all references supplied must be parallel to each other and perpendicular to the extension line.
dimensionType
Type: Autodesk.Revit.Symbols..::.DimensionType
The dimension style to be used for the dimension.

Return Value

If creation was successful the new linear dimension is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when any input argument is null.
System..::.ArgumentException | Thrown when the argument is invalid.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewLinearDimension Overload
Autodesk.Revit.Creation Namespace


NewLoftForm Method

[image]

Revit 2010 API
FamilyItemFactory..::.NewLoftForm Method
FamilyItemFactory Class See Also Send Feedback
Create new Form element by Loft operation, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Form NewLoftForm(
    bool isSolid,
    ReferenceArrayArray profiles
)
Visual Basic (Declaration)
Public Function NewLoftForm ( _
    isSolid As Boolean, _
    profiles As ReferenceArrayArray _
) As Form
Visual C++
public:
Form^ NewLoftForm(
    bool isSolid,
    ReferenceArrayArray^ profiles
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Form is Solid or Void.
profiles
Type: Autodesk.Revit.Geometry..::.ReferenceArrayArray
The profile set of the newly created loft. Each profile should consist of only one curve loop. The input profile must be in one plane.

Return Value

If creation was successful form is are returned.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewModelText Method

[image]

Revit 2010 API
FamilyItemFactory..::.NewModelText Method
FamilyItemFactory Class See Also Send Feedback
Create a model text in the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelText NewModelText(
    string text,
    ModelTextType modelTextType,
    SketchPlane sketchPlane,
    XYZ position,
    HorizontalAlign horizontalAlign,
    double depth
)
Visual Basic (Declaration)
Public Function NewModelText ( _
    text As String, _
    modelTextType As ModelTextType, _
    sketchPlane As SketchPlane, _
    position As XYZ, _
    horizontalAlign As HorizontalAlign, _
    depth As Double _
) As ModelText
Visual C++
public:
ModelText^ NewModelText(
    String^ text,
    ModelTextType^ modelTextType,
    SketchPlane^ sketchPlane,
    XYZ^ position,
    HorizontalAlign horizontalAlign,
    double depth
)

Parameters

text
Type: System..::.String
The text to be displayed.
modelTextType
Type: Autodesk.Revit.Symbols..::.ModelTextType
The type of model text. If this parameter is null, the default type will be used.
sketchPlane
Type: Autodesk.Revit.Elements..::.SketchPlane
The sketch plane of the model text. The direction of model text is determined by the normal of the sketch plane. To extrude in the other direction set the depth value to negative.
position
Type: Autodesk.Revit.Geometry..::.XYZ
The position of the model text. The position must lie in the sketch plane.
horizontalAlign
Type: Autodesk.Revit.Enums..::.HorizontalAlign
The horizontal alignment.
depth
Type: System..::.Double
The depth of the model text.

Return Value

If successful, the newly created model text is returned, otherwise an exception with error information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument text, sketchPlane or XYZ is null.
System..::.ArgumentException | Thrown when input argument text is an empty string. Thrown when input argument horizontalAlign or depth is invalid.
System..::.InvalidOperationException | Thrown when model text creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewOpening Method

[image]

Revit 2010 API
FamilyItemFactory..::.NewOpening Method
FamilyItemFactory Class See Also Send Feedback
Create an opening to cut the wall or ceiling.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Opening NewOpening(
    Element host,
    CurveArray profile
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    host As Element, _
    profile As CurveArray _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Element^ host,
    CurveArray^ profile
)

Parameters

host
Type: Autodesk.Revit..::.Element
Host elements that new opening would lie in. The host can only be a wall or a ceiling.
profile
Type: Autodesk.Revit.Geometry..::.CurveArray
The profile of the newly created opening. This may contain more than one curve loop. Each loop must be a fully closed curve loop and the loops may not intersect. The profiles will be projected into the host plane.

Return Value

If successful, the newly created opening is returned, otherwise an exception with error information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument host or profile is null.
System..::.ArgumentException | Thrown when host isn't a wall or a ceiling. Thrown when profile doesn't contain any loops.
System..::.InvalidOperationException | Thrown when opening creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewPipeConnector Method

[image]

Revit 2010 API
FamilyItemFactory..::.NewPipeConnector Method
FamilyItemFactory Class See Also Send Feedback
Add a new pipe connector into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeConnector NewPipeConnector(
    Reference planarFaceReference,
    PipeSystemType systemType
)
Visual Basic (Declaration)
Public Function NewPipeConnector ( _
    planarFaceReference As Reference, _
    systemType As PipeSystemType _
) As PipeConnector
Visual C++
public:
PipeConnector^ NewPipeConnector(
    Reference^ planarFaceReference,
    PipeSystemType systemType
)

Parameters

planarFaceReference
Type: Autodesk.Revit.Geometry..::.Reference
A reference to a planar face where the connector will be placed.
systemType
Type: Autodesk.Revit.MEP.Enums..::.PipeSystemType
Indicates the system type of this new Pipe connector.

Return Value

If creation was successful the new pipe connector is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a Pipe Connector in a family document. The pipe connector will be placed at the centroid of the planar face.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the argument planarFaceReference is invalid.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewRadialDimension Method

[image] [image]

Revit 2010 API
FamilyItemFactory..::.NewRadialDimension Method
FamilyItemFactory Class See Also Send Feedback
Creates a new radial dimension object.

Overload List

Name | Description
NewRadialDimension(View, Reference, XYZ) | Creates a new radial dimension object using the default dimension type.
NewRadialDimension(View, Reference, XYZ, DimensionType) | Generate a new radial dimension object using a specified dimension type.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewRadialDimension Method (View, Reference, XYZ)

[image]

Revit 2010 API
FamilyItemFactory..::.NewRadialDimension Method (View, Reference, XYZ)
FamilyItemFactory Class See Also Send Feedback
Creates a new radial dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Dimension NewRadialDimension(
    View view,
    Reference arcRef,
    XYZ origin
)
Visual Basic (Declaration)
Public Function NewRadialDimension ( _
    view As View, _
    arcRef As Reference, _
    origin As XYZ _
) As Dimension
Visual C++
public:
Dimension^ NewRadialDimension(
    View^ view,
    Reference^ arcRef,
    XYZ^ origin
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the dimension is to be visible.
arcRef
Type: Autodesk.Revit.Geometry..::.Reference
Geometric reference of the arc to which the dimension is to be bound.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The point where the witness line of the radial dimension will lie.

Return Value

If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The currently user set default style is used for the created dimension.

Remarks

The dimension will be created on default place.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when any input argument is null.
System..::.ArgumentException | Thrown when the argument arcRef is invalid.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewRadialDimension Overload
Autodesk.Revit.Creation Namespace


NewRadialDimension Method (View, Reference, XYZ, DimensionType)

[image]

Revit 2010 API
FamilyItemFactory..::.NewRadialDimension Method (View, Reference, XYZ, DimensionType)
FamilyItemFactory Class See Also Send Feedback
Generate a new radial dimension object using a specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Dimension NewRadialDimension(
    View view,
    Reference arcRef,
    XYZ origin,
    DimensionType dimensionType
)
Visual Basic (Declaration)
Public Function NewRadialDimension ( _
    view As View, _
    arcRef As Reference, _
    origin As XYZ, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewRadialDimension(
    View^ view,
    Reference^ arcRef,
    XYZ^ origin,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the dimension is to be visible.
arcRef
Type: Autodesk.Revit.Geometry..::.Reference
Geometric reference of the arc to which the dimension is to be bound.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The point where the witness line of the radial dimension will lie.
dimensionType
Type: Autodesk.Revit.Symbols..::.DimensionType
The dimension style to be used for the dimension.

Return Value

If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The dimension will be created on default place.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when any input argument is null.
System..::.ArgumentException | Thrown when the argument arcRef/dimensionType is invalid.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewRadialDimension Overload
Autodesk.Revit.Creation Namespace


NewReferencePoint Method

[image] [image]

Revit 2010 API
FamilyItemFactory..::.NewReferencePoint Method
FamilyItemFactory Class See Also Send Feedback
Creates a reference point.

Overload List

Name | Description
NewReferencePoint(PointElementReference) | Create a reference point on an existing reference in an Autodesk Revit family document.
NewReferencePoint(Transform) | Create a reference point at a given location and with a given coordinate system in an Autodesk Revit family document.
NewReferencePoint(XYZ) | Create a reference point at a given location in an Autodesk Revit family document.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewReferencePoint Method (PointElementReference)

[image]

Revit 2010 API
FamilyItemFactory..::.NewReferencePoint Method (PointElementReference)
FamilyItemFactory Class See Also Send Feedback
Create a reference point on an existing reference in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferencePoint NewReferencePoint(
    PointElementReference
)
Visual Basic (Declaration)
Public Function NewReferencePoint ( _
     As PointElementReference _
) As ReferencePoint
Visual C++
public:
ReferencePoint^ NewReferencePoint(
    PointElementReference^
)

Parameters

Type: Autodesk.Revit.Elements..::.PointElementReference

Return Value

The newly created ReferencePoint.

Remarks

The location and coordinate system of the point is determined by the particular PointReference subclass, and the point will remain constrained to that reference.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the argument is null.
System..::.InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.

See Also

FamilyItemFactory Class
NewReferencePoint Overload
Autodesk.Revit.Creation Namespace


NewReferencePoint Method (Transform)

[image]

Revit 2010 API
FamilyItemFactory..::.NewReferencePoint Method (Transform)
FamilyItemFactory Class See Also Send Feedback
Create a reference point at a given location and with a given coordinate system in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferencePoint NewReferencePoint(
    Transform
)
Visual Basic (Declaration)
Public Function NewReferencePoint ( _
     As Transform _
) As ReferencePoint
Visual C++
public:
ReferencePoint^ NewReferencePoint(
    Transform^
)

Parameters

Type: Autodesk.Revit.Geometry..::.Transform

Return Value

The newly created ReferencePoint.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the argument is null.
System..::.InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.

See Also

FamilyItemFactory Class
NewReferencePoint Overload
Autodesk.Revit.Creation Namespace


NewReferencePoint Method (XYZ)

[image]

Revit 2010 API
FamilyItemFactory..::.NewReferencePoint Method (XYZ)
FamilyItemFactory Class See Also Send Feedback
Create a reference point at a given location in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferencePoint NewReferencePoint(
    XYZ
)
Visual Basic (Declaration)
Public Function NewReferencePoint ( _
     As XYZ _
) As ReferencePoint
Visual C++
public:
ReferencePoint^ NewReferencePoint(
    XYZ^
)

Parameters

Type: Autodesk.Revit.Geometry..::.XYZ

Return Value

The newly created ReferencePoint.

Remarks

The ReferencePoint will have a default coordinate system corresponding to the global coordinate system.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the argument is null.
System..::.InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.

See Also

FamilyItemFactory Class
NewReferencePoint Overload
Autodesk.Revit.Creation Namespace


NewRevolution Method

[image]

Revit 2010 API
FamilyItemFactory..::.NewRevolution Method
FamilyItemFactory Class Example See Also Send Feedback
Add a new Revolution instance into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Revolution NewRevolution(
    bool isSolid,
    CurveArrArray profile,
    SketchPlane sketchPlane,
    Line axis,
    double startAngle,
    double endAngle
)
Visual Basic (Declaration)
Public Function NewRevolution ( _
    isSolid As Boolean, _
    profile As CurveArrArray, _
    sketchPlane As SketchPlane, _
    axis As Line, _
    startAngle As Double, _
    endAngle As Double _
) As Revolution
Visual C++
public:
Revolution^ NewRevolution(
    bool isSolid,
    CurveArrArray^ profile,
    SketchPlane^ sketchPlane,
    Line^ axis,
    double startAngle,
    double endAngle
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Revolution is Solid or Void.
profile
Type: Autodesk.Revit.Geometry..::.CurveArrArray
The profile of the newly created revolution. This may contain more than one curve loop. Each loop must be a fully closed curve loop and the loops must not intersect. All loops must lie in the same plane. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy reqiurements for sketches used in extrusions.
sketchPlane
Type: Autodesk.Revit.Elements..::.SketchPlane
The sketch plane for the revolution. The direction of revolution is determined by the normal for the sketch plane.
axis
Type: Autodesk.Revit.Geometry..::.Line
The axis of revolution. This axis must lie in the same plane as the curve loops.
startAngle
Type: System..::.Double
The start angle of Revolution in radians.
endAngle
Type: System..::.Double
The end angle of Revolution in radians.

Return Value

If creation was successful the new revolution is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates an Revolution in a family document. The Revolution will be rotated the plane of the Revolution profile about the Axis.

Examples

CopyC#
private Revolution CreateRevolution(Autodesk.Revit.Document document, SketchPlane sketchPlane)
{
    Revolution revolution = null;

    // make sure we have a family document
    if (true == document.IsFamilyDocument)
    {
        // Define a profile for the revolution
        CurveArrArray curveArrArray = new CurveArrArray();
        CurveArray curveArray = new CurveArray();

        // create a rectangular profile for the revolution
        XYZ p0 = XYZ.Zero;
        XYZ p1 = new XYZ(10, 0, 0);
        XYZ p2 = new XYZ(10, 10, 0);
        XYZ p3 = new XYZ(0, 10, 0);
        Line line1 = document.Application.Create.NewLineBound(p0, p1);
        Line line2 = document.Application.Create.NewLineBound(p1, p2);
        Line line3 = document.Application.Create.NewLineBound(p2, p3);
        Line line4 = document.Application.Create.NewLineBound(p3, p0);

        XYZ pp = new XYZ(1, -1, 0);
        Line axis1 = document.Application.Create.NewLineBound(XYZ.Zero, pp);
        curveArray.Append(line1);
        curveArray.Append(line2);
        curveArray.Append(line3);
        curveArray.Append(line4);

        curveArrArray.Append(curveArray);

        // create solid rectangular revolution
        revolution = document.FamilyCreate.NewRevolution(true, curveArrArray, sketchPlane, axis1, -Math.PI, 0);

        if (null != revolution)
        {
            // move to proper place
            XYZ transPoint1 = new XYZ(0, 32, 0);
            document.Move(revolution, transPoint1);
        }
        else
        {
            throw new Exception("Create a new Revolution failed.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }

    return revolution;
}
CopyVB.NET
Private Function CreateRevolution(ByVal document As Autodesk.Revit.Document, ByVal sketchPlane As Autodesk.Revit.Elements.SketchPlane) As Revolution
    Dim revolution As Revolution = Nothing

    ' make sure we have a family document
    If True = document.IsFamilyDocument Then
        ' Define a profile for the revolution
        Dim curveArrArray As New CurveArrArray()
        Dim curveArray As New CurveArray()

        ' create a rectangular profile for the revolution
        Dim p0 As Autodesk.Revit.Geometry.XYZ = Autodesk.Revit.Geometry.XYZ.Zero
        Dim p1 As New Autodesk.Revit.Geometry.XYZ(10, 0, 0)
        Dim p2 As New Autodesk.Revit.Geometry.XYZ(10, 10, 0)
        Dim p3 As New Autodesk.Revit.Geometry.XYZ(0, 10, 0)
        Dim line1 As Line = document.Application.Create.NewLineBound(p0, p1)
        Dim line2 As Line = document.Application.Create.NewLineBound(p1, p2)
        Dim line3 As Line = document.Application.Create.NewLineBound(p2, p3)
        Dim line4 As Line = document.Application.Create.NewLineBound(p3, p0)

        Dim pp As New Autodesk.Revit.Geometry.XYZ(1, -1, 0)
        Dim axis1 As Line = document.Application.Create.NewLineBound(Autodesk.Revit.Geometry.XYZ.Zero, pp)
        curveArray.Append(line1)
        curveArray.Append(line2)
        curveArray.Append(line3)
        curveArray.Append(line4)

        curveArrArray.Append(curveArray)

        ' create solid rectangular revolution
        revolution = document.FamilyCreate.NewRevolution(True, curveArrArray, sketchPlane, axis1, -Math.PI, 0)

        If revolution IsNot Nothing Then
            ' move to proper place
            Dim transPoint1 As New Autodesk.Revit.Geometry.XYZ(0, 32, 0)
            document.Move(revolution, transPoint1)
        Else
            Throw New Exception("Create a new Revolution failed.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If

    Return revolution
End Function

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the input argument-profile-is null or empty array.
System..::.ArgumentNullException | Thrown when the input argument-sketchPlane-is null.
System..::.ArgumentException | Thrown when the input argument-sketchPlane-is an invalid sketch plane.
System..::.ArgumentNullException | Thrown when the input argument-axis-is null.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewRevolveForms Method

[image]

Revit 2010 API
FamilyItemFactory..::.NewRevolveForms Method
FamilyItemFactory Class See Also Send Feedback
Create new Form elements by revolve operation, and add them into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FormArray NewRevolveForms(
    bool isSolid,
    ReferenceArray profile,
    Reference axis,
    double startAngle,
    double endAngle
)
Visual Basic (Declaration)
Public Function NewRevolveForms ( _
    isSolid As Boolean, _
    profile As ReferenceArray, _
    axis As Reference, _
    startAngle As Double, _
    endAngle As Double _
) As FormArray
Visual C++
public:
FormArray^ NewRevolveForms(
    bool isSolid,
    ReferenceArray^ profile,
    Reference^ axis,
    double startAngle,
    double endAngle
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Form is Solid or Void.
profile
Type: Autodesk.Revit.Geometry..::.ReferenceArray
The profile of the newly created revolution. It should consist of only one curve loop. The input profile must be in one plane.
axis
Type: Autodesk.Revit.Geometry..::.Reference
The axis of revolution. This axis must lie in the same plane as the curve loops.
startAngle
Type: System..::.Double
The start angle of Revolution in radians.
endAngle
Type: System..::.Double
The end angle of Revolution in radians.

Return Value

If creation was successful new forms are returned.

Remarks

Typically this operation produces only a single form, but some combinations of arguments will create multiple froms from a single profile.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewSketchPlane Method

[image] [image]

Revit 2010 API
FamilyItemFactory..::.NewSketchPlane Method
FamilyItemFactory Class See Also Send Feedback
Creates a new sketch plane.

Overload List

Name | Description
NewSketchPlane(PlanarFace) | Creates a new sketch plane on a planar face of existing geometry. (Inherited from ItemFactoryBase.)
NewSketchPlane(Plane) | Creates a new sketch plane from an arbitrary geometric plane. (Inherited from ItemFactoryBase.)

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewSweep Method

[image] [image]

Revit 2010 API
FamilyItemFactory..::.NewSweep Method
FamilyItemFactory Class See Also Send Feedback
Adds a new sweep form to the family document.

Overload List

Name | Description
NewSweep(Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form into the family document, using an array of selected references as a 3D path.
NewSweep(Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form to the family document, using a path of curve elements.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewSweep Method (Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation)

[image]

Revit 2010 API
FamilyItemFactory..::.NewSweep Method (Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation)
FamilyItemFactory Class See Also Send Feedback
Adds a new sweep form into the family document, using an array of selected references as a 3D path.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Sweep NewSweep(
    bool isSolid,
    ReferenceArray path,
    SweepProfile profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)
Visual Basic (Declaration)
Public Function NewSweep ( _
    isSolid As Boolean, _
    path As ReferenceArray, _
    profile As SweepProfile, _
    profileLocationCurveIndex As Integer, _
    profilePlaneLocation As ProfilePlaneLocation _
) As Sweep
Visual C++
public:
Sweep^ NewSweep(
    bool isSolid,
    ReferenceArray^ path,
    SweepProfile^ profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Sweep is Solid or Void.
path
Type: Autodesk.Revit.Geometry..::.ReferenceArray
The path of the sweep. The path should be reference of curve or edge obtained from existing geometry.
profile
Type: Autodesk.Revit..::.SweepProfile
The profile of the newly created Sweep. This may contain more than one curve loop or a profile family. Each loop must be a fully closed curve loop and the loops must not intersect. All loops must lie in the same plane. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy reqiurements for sketches used in extrusions.
profileLocationCurveIndex
Type: System..::.Int32
The index of the path curves. The curve upon which the profile plane will be determined.
profilePlaneLocation
Type: Autodesk.Revit.Elements..::.ProfilePlaneLocation
The location on the profileLocationCurve where the profile plane will be determined.

Return Value

If creation was successful the new Sweep is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a sweep in a family document. The sweep will trace the profile along the path.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the input argument-path-is null or empty.
System..::.ArgumentNullException | Thrown when the input argument-profile-is null.
System..::.ArgumentOutOfRangeException | Thrown when the input argument-profileLocationCurveIndex-is out of index bounds.
System..::.ArgumentOutOfRangeException | Thrown when the input argument-profilePlaneLocation-does not exist in ProfilePlaneLocation enumeration.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewSweep Overload
Autodesk.Revit.Creation Namespace


NewSweep Method (Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation)

[image]

Revit 2010 API
FamilyItemFactory..::.NewSweep Method (Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation)
FamilyItemFactory Class Example See Also Send Feedback
Adds a new sweep form to the family document, using a path of curve elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Sweep NewSweep(
    bool isSolid,
    CurveArray path,
    SketchPlane pathPlane,
    SweepProfile profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)
Visual Basic (Declaration)
Public Function NewSweep ( _
    isSolid As Boolean, _
    path As CurveArray, _
    pathPlane As SketchPlane, _
    profile As SweepProfile, _
    profileLocationCurveIndex As Integer, _
    profilePlaneLocation As ProfilePlaneLocation _
) As Sweep
Visual C++
public:
Sweep^ NewSweep(
    bool isSolid,
    CurveArray^ path,
    SketchPlane^ pathPlane,
    SweepProfile^ profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Sweep is Solid or Void.
path
Type: Autodesk.Revit.Geometry..::.CurveArray
The path of the sweep. The path should be 2D, where all input curves lie in one plane, and the curves are not required to reference existing geometry.
pathPlane
Type: Autodesk.Revit.Elements..::.SketchPlane
The sketch plane for the path. Use this when you want to create a 2D path that resides on an existing planar face. Optional, can be null for 3D paths or for 2D paths where the path should not reference an existing face.
profile
Type: Autodesk.Revit..::.SweepProfile
The profile of the newly created Sweep. This may contain more than one curve loop or a profile family. Each loop must be a fully closed curve loop and the loops must not intersect. All loops must lie in the same plane. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy reqiurements for sketches used in extrusions.
profileLocationCurveIndex
Type: System..::.Int32
The index of the path curves. The curve upon which the profile plane will be determined.
profilePlaneLocation
Type: Autodesk.Revit.Elements..::.ProfilePlaneLocation
The location on the profileLocationCurve where the profile plane will be determined.

Return Value

If creation was successful the new Sweep is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a sweep in a family document. The sweep will trace the profile along the path.

Examples

CopyC#
private Sweep CreateSweep(Autodesk.Revit.Document document, SketchPlane sketchPlane)
{
    Sweep sweep = null;

    // make sure we have a family document
    if (true == document.IsFamilyDocument)
    {
        // Define a profile for the sweep
        CurveArrArray arrarr = new CurveArrArray();
        CurveArray arr = new CurveArray();

        // Create an ovoid profile
        XYZ pnt1 = new XYZ(0, 0, 0);
        XYZ pnt2 = new XYZ(2, 0, 0);
        XYZ pnt3 = new XYZ(1, 1, 0);
        arr.Append(document.Application.Create.NewArc(pnt2, 1.0d, 0.0d, 180.0d, XYZ.BasisX, XYZ.BasisY));
        arr.Append(document.Application.Create.NewArc(pnt1, pnt3, pnt2));
        arrarr.Append(arr);
        SweepProfile profile = document.Application.Create.NewCurveLoopsProfile(arrarr);

        // Create a path for the sweep
        XYZ pnt4 = new XYZ(10, 0, 0);
        XYZ pnt5 = new XYZ(0, 10, 0);
        Curve curve = document.Application.Create.NewLineBound(pnt4, pnt5);

        CurveArray curves = new CurveArray();
        curves.Append(curve);

        // create a solid ovoid sweep
        sweep = document.FamilyCreate.NewSweep(true, curves, sketchPlane, profile, 0, ProfilePlaneLocation.Start);

        if (null != sweep)
        {
            // move to proper place
            XYZ transPoint1 = new XYZ(11, 0, 0);
            document.Move(sweep, transPoint1);
        }
        else
        {
            throw new Exception("Failed to create a new Sweep.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }

    return sweep;
}
CopyVB.NET
Private Function CreateSweep(ByVal document As Autodesk.Revit.Document, ByVal sketchPlane As Autodesk.Revit.Elements.SketchPlane) As Sweep
    Dim sweep As Sweep = Nothing

    ' make sure we have a family document
    If True = document.IsFamilyDocument Then
        ' Define a profile for the sweep
        Dim arrarr As New CurveArrArray()
        Dim arr As New CurveArray()

        ' Create an ovoid profile
        Dim pnt1 As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
        Dim pnt2 As New Autodesk.Revit.Geometry.XYZ(2, 0, 0)
        Dim pnt3 As New Autodesk.Revit.Geometry.XYZ(1, 1, 0)
        arr.Append(document.Application.Create.NewArc(pnt2, 1.0R, 0.0R, 180.0R, Autodesk.Revit.Geometry.XYZ.BasisX, Autodesk.Revit.Geometry.XYZ.BasisY))
        arr.Append(document.Application.Create.NewArc(pnt1, pnt3, pnt2))
        arrarr.Append(arr)
        Dim profile As SweepProfile = document.Application.Create.NewCurveLoopsProfile(arrarr)

        ' Create a path for the sweep
        Dim pnt4 As New Autodesk.Revit.Geometry.XYZ(10, 0, 0)
        Dim pnt5 As New Autodesk.Revit.Geometry.XYZ(0, 10, 0)
        Dim curve As Curve = document.Application.Create.NewLineBound(pnt4, pnt5)

        Dim curves As New CurveArray()
        curves.Append(curve)

        ' create a solid ovoid sweep
        sweep = document.FamilyCreate.NewSweep(True, curves, sketchPlane, profile, 0, ProfilePlaneLocation.Start)

        If sweep IsNot Nothing Then
            ' move to proper place
            Dim transPoint1 As New Autodesk.Revit.Geometry.XYZ(11, 0, 0)
            document.Move(sweep, transPoint1)
        Else
            Throw New Exception("Failed to create a new Sweep.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If

    Return sweep
End Function

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the input argument-path-is null or empty.
System..::.ArgumentNullException | Thrown when the input argument-profile-is null.
System..::.ArgumentOutOfRangeException | Thrown when the input argument-profileLocationCurveIndex-is out of index bounds.
System..::.ArgumentOutOfRangeException | Thrown when the input argument-profilePlaneLocation-does not exist in ProfilePlaneLocation enumeration.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewSweep Overload
Autodesk.Revit.Creation Namespace


NewSweptBlend Method

[image] [image]

Revit 2010 API
FamilyItemFactory..::.NewSweptBlend Method
FamilyItemFactory Class See Also Send Feedback
Adds a new swept blend into the family document.

Overload List

Name | Description
NewSweptBlend(Boolean, Reference, SweepProfile, SweepProfile) | Adds a new swept blend into the family document, using a selected reference as the path.
NewSweptBlend(Boolean, Curve, SketchPlane, SweepProfile, SweepProfile) | Add a new swept blend into the family document, using a curve as the path.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewSweptBlend Method (Boolean, Reference, SweepProfile, SweepProfile)

[image]

Revit 2010 API
FamilyItemFactory..::.NewSweptBlend Method (Boolean, Reference, SweepProfile, SweepProfile)
FamilyItemFactory Class See Also Send Feedback
Adds a new swept blend into the family document, using a selected reference as the path.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SweptBlend NewSweptBlend(
    bool isSolid,
    Reference path,
    SweepProfile bottomProfile,
    SweepProfile topProfile
)
Visual Basic (Declaration)
Public Function NewSweptBlend ( _
    isSolid As Boolean, _
    path As Reference, _
    bottomProfile As SweepProfile, _
    topProfile As SweepProfile _
) As SweptBlend
Visual C++
public:
SweptBlend^ NewSweptBlend(
    bool isSolid,
    Reference^ path,
    SweepProfile^ bottomProfile,
    SweepProfile^ topProfile
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the swept blend is Solid or Void.
path
Type: Autodesk.Revit.Geometry..::.Reference
The path of the swept blend. The path might be a reference of single curve or edge obtained from existing geometry. Or the path can be a single sketched curve, and the curve is not required to reference existing geometry.
bottomProfile
Type: Autodesk.Revit..::.SweepProfile
The bottom profile of the newly created Swept blend. It should consist of only one curve loop. the input profile must be in one plane.
topProfile
Type: Autodesk.Revit..::.SweepProfile
The top profile of the newly created Swept blend. It should consist of only one curve loop. the input profile must be in one plane.

Return Value

If creation was successful the new Swept blend is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a swept blend in a family document. The swept blend will trace from bottom profile to the top along the path. Revit will determine an appropriate default mapping for the vertices of the two profiles. If the input profile is to be a cyclic profile (curve or ellipse) it must be split into at least two segments, so that Revit can find vertices to use for mapping the swept blend.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input arguments-path/bottomProfile/topProfile-are null.
System..::.ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile is null.
System..::.ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile contains nothing or more than one curve loops.
System..::.ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a family symbol based profile and the family symbol profile is null.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewSweptBlend Overload
Autodesk.Revit.Creation Namespace


NewSweptBlend Method (Boolean, Curve, SketchPlane, SweepProfile, SweepProfile)

[image]

Revit 2010 API
FamilyItemFactory..::.NewSweptBlend Method (Boolean, Curve, SketchPlane, SweepProfile, SweepProfile)
FamilyItemFactory Class Example See Also Send Feedback
Add a new swept blend into the family document, using a curve as the path.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SweptBlend NewSweptBlend(
    bool isSolid,
    Curve path,
    SketchPlane pathPlane,
    SweepProfile bottomProfile,
    SweepProfile topProfile
)
Visual Basic (Declaration)
Public Function NewSweptBlend ( _
    isSolid As Boolean, _
    path As Curve, _
    pathPlane As SketchPlane, _
    bottomProfile As SweepProfile, _
    topProfile As SweepProfile _
) As SweptBlend
Visual C++
public:
SweptBlend^ NewSweptBlend(
    bool isSolid,
    Curve^ path,
    SketchPlane^ pathPlane,
    SweepProfile^ bottomProfile,
    SweepProfile^ topProfile
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the swept blend is Solid or Void.
path
Type: Autodesk.Revit.Geometry..::.Curve
The path of the swept blend. The path should be a single curve. Or the path can be a single sketched curve, and the curve is not required to reference existing geometry.
pathPlane
Type: Autodesk.Revit.Elements..::.SketchPlane
The sketch plane for the path. Use this when you want to create a 2D path that resides on an existing planar face. Optional, can be null for a path curve obtained from geometry or for 2D paths where the path should not reference an existing edge.
bottomProfile
Type: Autodesk.Revit..::.SweepProfile
The bottom profile of the newly created Swept blend. It should consist of only one curve loop. the input profile must be in one plane.
topProfile
Type: Autodesk.Revit..::.SweepProfile
The top profile of the newly created Swept blend. It should consist of only one curve loop. the input profile must be in one plane.

Return Value

If creation was successful the new Swept blend is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a swept blend in a family document. The swept blend will trace from bottom profile to the top along the path. Revit will determine an appropriate default mapping for the vertices of the two profiles. If the input profile is to be a cyclic profile (curve or ellipse) it must be split into at least two segments, so that Revit can find vertices to use for mapping the swept blend.

Examples

CopyC#
private SweptBlend CreateSweptBlend(Autodesk.Revit.Document document, SketchPlane sketchPlane)
{
    SweptBlend newSweptBlend = null;

    // make sure we have a family document
    if (true == document.IsFamilyDocument)
    {
        // Create top and bottom profiles and path curve
        XYZ pnt1 = new XYZ(0, 0, 0);
        XYZ pnt2 = new XYZ(1, 0, 0);
        XYZ pnt3 = new XYZ(1, 1, 0);
        XYZ pnt4 = new XYZ(0, 1, 0);
        XYZ pnt5 = new XYZ(0, 0, 1);

        CurveArrArray arrarr1 = new CurveArrArray();
        CurveArray arr1 = new CurveArray();
        arr1.Append(document.Application.Create.NewLineBound(pnt1, pnt2));
        arr1.Append(document.Application.Create.NewLineBound(pnt2, pnt3));
        arr1.Append(document.Application.Create.NewLineBound(pnt3, pnt4));
        arr1.Append(document.Application.Create.NewLineBound(pnt4, pnt1));
        arrarr1.Append(arr1);

        XYZ pnt6 = new XYZ(0.5, 0, 0);
        XYZ pnt7 = new XYZ(1, 0.5, 0);
        XYZ pnt8 = new XYZ(0.5, 1, 0);
        XYZ pnt9 = new XYZ(0, 0.5, 0);
        CurveArrArray arrarr2 = new CurveArrArray();
        CurveArray arr2 = new CurveArray();
        arr2.Append(document.Application.Create.NewLineBound(pnt6, pnt7));
        arr2.Append(document.Application.Create.NewLineBound(pnt7, pnt8));
        arr2.Append(document.Application.Create.NewLineBound(pnt8, pnt9));
        arr2.Append(document.Application.Create.NewLineBound(pnt9, pnt6));
        arrarr2.Append(arr2);

        SweepProfile bottomProfile = document.Application.Create.NewCurveLoopsProfile(arrarr1);
        SweepProfile topProfile = document.Application.Create.NewCurveLoopsProfile(arrarr2);

        XYZ pnt10 = new XYZ(5, 0, 0);
        XYZ pnt11 = new XYZ(0, 20, 0);
        Curve curve = document.Application.Create.NewLineBound(pnt10, pnt11);

        // here create rectangular swept blend
        newSweptBlend = document.FamilyCreate.NewSweptBlend(true, curve, sketchPlane, bottomProfile, topProfile);
        if (null != newSweptBlend)
        {
            // move to proper place
            XYZ transPoint1 = new XYZ(11, 32, 0);
            document.Move(newSweptBlend, transPoint1);
        }
        else
        {
            throw new Exception("Failed to create new SweptBlend.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }
    return newSweptBlend;
}
CopyVB.NET
Private Function CreateSweptBlend(ByVal document As Autodesk.Revit.Document, ByVal sketchPlane As Autodesk.Revit.Elements.SketchPlane) As SweptBlend
    Dim newSweptBlend As SweptBlend = Nothing

    ' make sure we have a family document
    If True = document.IsFamilyDocument Then
        ' Create top and bottom profiles and path curve
        Dim pnt1 As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
        Dim pnt2 As New Autodesk.Revit.Geometry.XYZ(1, 0, 0)
        Dim pnt3 As New Autodesk.Revit.Geometry.XYZ(1, 1, 0)
        Dim pnt4 As New Autodesk.Revit.Geometry.XYZ(0, 1, 0)
        Dim pnt5 As New Autodesk.Revit.Geometry.XYZ(0, 0, 1)

        Dim arrarr1 As New CurveArrArray()
        Dim arr1 As New CurveArray()
        arr1.Append(document.Application.Create.NewLineBound(pnt1, pnt2))
        arr1.Append(document.Application.Create.NewLineBound(pnt2, pnt3))
        arr1.Append(document.Application.Create.NewLineBound(pnt3, pnt4))
        arr1.Append(document.Application.Create.NewLineBound(pnt4, pnt1))
        arrarr1.Append(arr1)

        Dim pnt6 As New Autodesk.Revit.Geometry.XYZ(0.5, 0, 0)
        Dim pnt7 As New Autodesk.Revit.Geometry.XYZ(1, 0.5, 0)
        Dim pnt8 As New Autodesk.Revit.Geometry.XYZ(0.5, 1, 0)
        Dim pnt9 As New Autodesk.Revit.Geometry.XYZ(0, 0.5, 0)
        Dim arrarr2 As New CurveArrArray()
        Dim arr2 As New CurveArray()
        arr2.Append(document.Application.Create.NewLineBound(pnt6, pnt7))
        arr2.Append(document.Application.Create.NewLineBound(pnt7, pnt8))
        arr2.Append(document.Application.Create.NewLineBound(pnt8, pnt9))
        arr2.Append(document.Application.Create.NewLineBound(pnt9, pnt6))
        arrarr2.Append(arr2)

        Dim bottomProfile As SweepProfile = document.Application.Create.NewCurveLoopsProfile(arrarr1)
        Dim topProfile As SweepProfile = document.Application.Create.NewCurveLoopsProfile(arrarr2)

        Dim pnt10 As New Autodesk.Revit.Geometry.XYZ(5, 0, 0)
        Dim pnt11 As New Autodesk.Revit.Geometry.XYZ(0, 20, 0)
        Dim curve As Curve = document.Application.Create.NewLineBound(pnt10, pnt11)

        ' here create rectangular swept blend
        newSweptBlend = document.FamilyCreate.NewSweptBlend(True, curve, sketchPlane, bottomProfile, topProfile)
        If newSweptBlend IsNot Nothing Then
            ' move to proper place
            Dim transPoint1 As New Autodesk.Revit.Geometry.XYZ(11, 32, 0)
            document.Move(newSweptBlend, transPoint1)
        Else
            Throw New Exception("Failed to create new SweptBlend.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If
    Return newSweptBlend
End Function

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input arguments-path/bottomProfile/topProfile-are null.
System..::.ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile is null.
System..::.ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile contains nothing or more than one curve loops.
System..::.ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a family symbol based profile and the family symbol profile is null.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewSweptBlend Overload
Autodesk.Revit.Creation Namespace


NewSweptBlendForm Method

[image]

Revit 2010 API
FamilyItemFactory..::.NewSweptBlendForm Method
FamilyItemFactory Class See Also Send Feedback
Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Form NewSweptBlendForm(
    bool isSolid,
    ReferenceArray path,
    ReferenceArrayArray profiles
)
Visual Basic (Declaration)
Public Function NewSweptBlendForm ( _
    isSolid As Boolean, _
    path As ReferenceArray, _
    profiles As ReferenceArrayArray _
) As Form
Visual C++
public:
Form^ NewSweptBlendForm(
    bool isSolid,
    ReferenceArray^ path,
    ReferenceArrayArray^ profiles
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Form is Solid or Void.
path
Type: Autodesk.Revit.Geometry..::.ReferenceArray
The path of the swept blend. The path should be 2D, where all input curves lie in one plane. If there’s more than one profile, the path should be a single curve. It’s required to reference existing geometry.
profiles
Type: Autodesk.Revit.Geometry..::.ReferenceArrayArray
The profile set of the newly created swept blend. Each profile should consist of only one curve loop. The input profile must be in one plane.

Return Value

If creation was successful new form is returned.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewSymbolicCurve Method

[image]

Revit 2010 API
FamilyItemFactory..::.NewSymbolicCurve Method
FamilyItemFactory Class See Also Send Feedback
Create a symbolic curve in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SymbolicCurve NewSymbolicCurve(
    Curve curve,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Function NewSymbolicCurve ( _
    curve As Curve, _
    sketchPlane As SketchPlane _
) As SymbolicCurve
Visual C++
public:
SymbolicCurve^ NewSymbolicCurve(
    Curve^ curve,
    SketchPlane^ sketchPlane
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
The geometry curve of the newly created symbolic curve.
sketchPlane
Type: Autodesk.Revit.Elements..::.SketchPlane
The sketch plane for the symbolic curve.

Return Value

The newly created symbolic curve.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when argument is null.
System..::.InvalidOperationException | Thrown when regeneration failed. Thrown when symbolic curve creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewTextNote Method

[image] [image]

Revit 2010 API
FamilyItemFactory..::.NewTextNote Method
FamilyItemFactory Class See Also Send Feedback
Creates a new TextNote object.

Overload List

Name | Description
NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates a new text note with a single leader. (Inherited from ItemFactoryBase.)
NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates a new TextNote object without a leader. (Inherited from ItemFactoryBase.)

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


FamilyItemFactory Properties

[image] [image]

Revit 2010 API
FamilyItemFactory Properties
FamilyItemFactory Class See Also Send Feedback

The FamilyItemFactory type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


Filter Class

[image]

Revit 2010 API
Filter Class
Members See Also Send Feedback
The Filter creation object is used to create new instances of element filter utility objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Filter : APIObject
Visual Basic (Declaration)
Public Class Filter _
    Inherits APIObject
Visual C++
public ref class Filter : public APIObject

Remarks

Elements filter related objects can be generated by this creation object. Creating objects via this object ensures that they will be correctly constructed and will reside in the Autodesk Revit memory space.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Creation..::.Filter

See Also

Filter Members
Autodesk.Revit.Creation Namespace


Filter Members

[image] [image]

Revit 2010 API
Filter Members
Filter Class Constructors Methods Properties See Also Send Feedback

The Filter type exposes the following members.

Constructors

Name | Description
Filter | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewCategoryFilter | Overloaded. Creates a new category filter object.
NewFamilyFilter | Creates a FamilyFilter object.
NewInstanceUsageFilter | Creates an InstanceUsageFilter object.
NewLogicAndFilter | Creates a new LogicAndFilter object.
NewLogicNotFilter | Creates a new LogicNotFilter object.
NewLogicOrFilter | Creates a new LogicOrFilter object.
NewMaterialFilter | Creates a MaterialFilter object.
NewParameterFilter | Overloaded. Creates a new parameter filter.
NewStructuralTypeFilter | Creates a StructuralTypeFilter object.
NewSymbolFilter | Creates a SymbolFilter object.
NewTypeFilter | Overloaded. Creates a new TypeFilter object.
NewWallUsageFilter | Creates a new WallUsageFilter object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Filter Class
Autodesk.Revit.Creation Namespace


Filter Constructor

[image]

Revit 2010 API
Filter Constructor
Filter Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Filter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Filter()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


Filter Methods

[image] [image]

Revit 2010 API
Filter Methods
Filter Class See Also Send Feedback

The Filter type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewCategoryFilter | Overloaded. Creates a new category filter object.
NewFamilyFilter | Creates a FamilyFilter object.
NewInstanceUsageFilter | Creates an InstanceUsageFilter object.
NewLogicAndFilter | Creates a new LogicAndFilter object.
NewLogicNotFilter | Creates a new LogicNotFilter object.
NewLogicOrFilter | Creates a new LogicOrFilter object.
NewMaterialFilter | Creates a MaterialFilter object.
NewParameterFilter | Overloaded. Creates a new parameter filter.
NewStructuralTypeFilter | Creates a StructuralTypeFilter object.
NewSymbolFilter | Creates a SymbolFilter object.
NewTypeFilter | Overloaded. Creates a new TypeFilter object.
NewWallUsageFilter | Creates a new WallUsageFilter object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewCategoryFilter Method

[image] [image]

Revit 2010 API
Filter..::.NewCategoryFilter Method
Filter Class See Also Send Feedback
Creates a new category filter object.

Overload List

Name | Description
NewCategoryFilter(BuiltInCategory) | Creates a new category filter object related to a built-in category id.
NewCategoryFilter(Category) | Creates a new category filter object.

See Also

Filter Class
Filter Members
Autodesk.Revit.Creation Namespace


NewCategoryFilter Method (BuiltInCategory)

[image]

Revit 2010 API
Filter..::.NewCategoryFilter Method (BuiltInCategory)
Filter Class See Also Send Feedback
Creates a new category filter object related to a built-in category id.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CategoryFilter NewCategoryFilter(
    BuiltInCategory builtInCat
)
Visual Basic (Declaration)
Public Function NewCategoryFilter ( _
    builtInCat As BuiltInCategory _
) As CategoryFilter
Visual C++
public:
CategoryFilter^ NewCategoryFilter(
    BuiltInCategory builtInCat
)

Parameters

builtInCat
Type: Autodesk.Revit..::.BuiltInCategory
Filter elements by the built-in category.

Return Value

Returns a new category filter object with given built-in category.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
NewCategoryFilter Overload
Autodesk.Revit.Creation Namespace


NewCategoryFilter Method (Category)

[image]

Revit 2010 API
Filter..::.NewCategoryFilter Method (Category)
Filter Class See Also Send Feedback
Creates a new category filter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CategoryFilter NewCategoryFilter(
    Category category
)
Visual Basic (Declaration)
Public Function NewCategoryFilter ( _
    category As Category _
) As CategoryFilter
Visual C++
public:
CategoryFilter^ NewCategoryFilter(
    Category^ category
)

Parameters

category
Type: Autodesk.Revit..::.Category
Filter elements by the category related to a category.

Return Value

Returns a new category filter object with given category.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter is invalid.

See Also

Filter Class
NewCategoryFilter Overload
Autodesk.Revit.Creation Namespace


NewFamilyFilter Method

[image]

Revit 2010 API
Filter..::.NewFamilyFilter Method
Filter Class See Also Send Feedback
Creates a FamilyFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyFilter NewFamilyFilter(
    string familyName
)
Visual Basic (Declaration)
Public Function NewFamilyFilter ( _
    familyName As String _
) As FamilyFilter
Visual C++
public:
FamilyFilter^ NewFamilyFilter(
    String^ familyName
)

Parameters

familyName
Type: System..::.String
Filter elements by the family name.

Return Value

Returns a new family filter object with given family.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the familyName is nullptr or empty.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewInstanceUsageFilter Method

[image]

Revit 2010 API
Filter..::.NewInstanceUsageFilter Method
Filter Class See Also Send Feedback
Creates an InstanceUsageFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InstanceUsageFilter NewInstanceUsageFilter(
    InstanceUsage instanceUsage
)
Visual Basic (Declaration)
Public Function NewInstanceUsageFilter ( _
    instanceUsage As InstanceUsage _
) As InstanceUsageFilter
Visual C++
public:
InstanceUsageFilter^ NewInstanceUsageFilter(
    InstanceUsage instanceUsage
)

Parameters

instanceUsage
Type: Autodesk.Revit.Structural.Enums..::.InstanceUsage
Filter elements by the instance usage.

Return Value

Returns a new instance usage filter object with given instance usage.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewLogicAndFilter Method

[image]

Revit 2010 API
Filter..::.NewLogicAndFilter Method
Filter Class Example See Also Send Feedback
Creates a new LogicAndFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LogicAndFilter NewLogicAndFilter(
    Filter leftFilter,
    Filter rightFilter
)
Visual Basic (Declaration)
Public Function NewLogicAndFilter ( _
    leftFilter As Filter, _
    rightFilter As Filter _
) As LogicAndFilter
Visual C++
public:
LogicAndFilter^ NewLogicAndFilter(
    Filter^ leftFilter,
    Filter^ rightFilter
)

Parameters

leftFilter
Type: Autodesk.Revit..::.Filter
leftFilter is left operand of logic-and operator
rightFilter
Type: Autodesk.Revit..::.Filter
rightFilter is right operand of logic-and operator

Return Value

Returns a new LogicAndFilter object.

Examples

CopyC#
// get Filter Creation object
Autodesk.Revit.Creation.Filter filterCreator = document.Application.Create.Filter;

// Create a type filter for FamilyInstance, including derived types
TypeFilter familyInstanceFilter = filterCreator.NewTypeFilter(typeof(FamilyInstance), true);

// Create a category filter for Doors
CategoryFilter doorsCategoryfilter = filterCreator.NewCategoryFilter(BuiltInCategory.OST_Doors);

// Create a logic And filter for all Door FamilyInstances
Filter doorInstancesFilter = filterCreator.NewLogicAndFilter(familyInstanceFilter, doorsCategoryfilter);

// Apply the filter to the elements in the active document
ElementIterator iter = document.get_Elements(doorInstancesFilter);
CopyVB.NET
' get Filter Creation object
Dim filterCreator As Autodesk.Revit.Creation.Filter = document.Application.Create.Filter

' Create a type filter for FamilyInstance, including derived types
Dim familyInstanceFilter As TypeFilter = filterCreator.NewTypeFilter(GetType(Autodesk.Revit.Elements.FamilyInstance), True)

' Create a category filter for Doors
Dim doorsCategoryfilter As CategoryFilter = filterCreator.NewCategoryFilter(BuiltInCategory.OST_Doors)

' Create a logic And filter for all Door FamilyInstances
Dim doorInstancesFilter As Filter = filterCreator.NewLogicAndFilter(familyInstanceFilter, doorsCategoryfilter)

' Apply the filter to the elements in the active document
Dim iter As ElementIterator = document.Elements(doorInstancesFilter)

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter is nullptr.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewLogicNotFilter Method

[image]

Revit 2010 API
Filter..::.NewLogicNotFilter Method
Filter Class See Also Send Feedback
Creates a new LogicNotFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LogicNotFilter NewLogicNotFilter(
    Filter subFilter
)
Visual Basic (Declaration)
Public Function NewLogicNotFilter ( _
    subFilter As Filter _
) As LogicNotFilter
Visual C++
public:
LogicNotFilter^ NewLogicNotFilter(
    Filter^ subFilter
)

Parameters

subFilter
Type: Autodesk.Revit..::.Filter
subFilter is an operand of logic-not operator

Return Value

Returns a new LogicNotFilter object.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter is nullptr.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewLogicOrFilter Method

[image]

Revit 2010 API
Filter..::.NewLogicOrFilter Method
Filter Class See Also Send Feedback
Creates a new LogicOrFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LogicOrFilter NewLogicOrFilter(
    Filter leftFilter,
    Filter rightFilter
)
Visual Basic (Declaration)
Public Function NewLogicOrFilter ( _
    leftFilter As Filter, _
    rightFilter As Filter _
) As LogicOrFilter
Visual C++
public:
LogicOrFilter^ NewLogicOrFilter(
    Filter^ leftFilter,
    Filter^ rightFilter
)

Parameters

leftFilter
Type: Autodesk.Revit..::.Filter
leftFilter is left operand of logic-or operator.
rightFilter
Type: Autodesk.Revit..::.Filter
rightFilter is right operand of logic-or operator.

Return Value

Returns a new LogicOrFilter object.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter is nullptr.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewMaterialFilter Method

[image]

Revit 2010 API
Filter..::.NewMaterialFilter Method
Filter Class See Also Send Feedback
Creates a MaterialFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialFilter NewMaterialFilter(
    Material material
)
Visual Basic (Declaration)
Public Function NewMaterialFilter ( _
    material As Material _
) As MaterialFilter
Visual C++
public:
MaterialFilter^ NewMaterialFilter(
    Material material
)

Parameters

material
Type: Autodesk.Revit.Structural.Enums..::.Material
Filter elements by the material.

Return Value

Returns a new material filter object with given material.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewParameterFilter Method

[image] [image]

Revit 2010 API
Filter..::.NewParameterFilter Method
Filter Class See Also Send Feedback
Creates a new parameter filter.

Overload List

Name | Description
NewParameterFilter(BuiltInParameter, CriteriaFilterType, ElementId) | Creates a parameter filter object based on an ElementId built-in parameter type.
NewParameterFilter(BuiltInParameter, CriteriaFilterType, Double) | Creates a parameter filter object based on a double built-in parameter type.
NewParameterFilter(BuiltInParameter, CriteriaFilterType, Int32) | Creates a parameter filter object based on an integer built-in parameter type.
NewParameterFilter(BuiltInParameter, CriteriaFilterType, String) | Creates a parameter filter object based on a string built-in parameter type.
NewParameterFilter(String, CriteriaFilterType, ElementId) | Creates a parameter filter object based on the name of an ElementId parameter.
NewParameterFilter(String, CriteriaFilterType, Double) | Creates a parameter filter object based on the name of a double parameter.
NewParameterFilter(String, CriteriaFilterType, Int32) | Creates a parameter filter object based on the name of an integer parameter .
NewParameterFilter(String, CriteriaFilterType, String) | Creates a parameter filter object based on the name of a string parameter.

See Also

Filter Class
Filter Members
Autodesk.Revit.Creation Namespace


NewParameterFilter Method (BuiltInParameter, CriteriaFilterType, ElementId)

[image]

Revit 2010 API
Filter..::.NewParameterFilter Method (BuiltInParameter, CriteriaFilterType, ElementId)
Filter Class See Also Send Feedback
Creates a parameter filter object based on an ElementId built-in parameter type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterFilter NewParameterFilter(
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    ElementId parameterValue
)
Visual Basic (Declaration)
Public Function NewParameterFilter ( _
    builtinParameter As BuiltInParameter, _
    filterType As CriteriaFilterType, _
    parameterValue As ElementId _
) As ParameterFilter
Visual C++
public:
ParameterFilter^ NewParameterFilter(
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    ElementId parameterValue
)

Parameters

builtinParameter
Type: Autodesk.Revit.Parameters..::.BuiltInParameter
The built in parameter id of the parameter to be retrieved.
filterType
Type: Autodesk.Revit.Enums..::.CriteriaFilterType
The relationship between element's parameter value and the specified value.
parameterValue
Type: Autodesk.Revit..::.ElementId
The parameter value that is stored as ElementId.

Return Value

Returns a new parameter filter object with given element id.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
NewParameterFilter Overload
Autodesk.Revit.Creation Namespace


NewParameterFilter Method (BuiltInParameter, CriteriaFilterType, Double)

[image]

Revit 2010 API
Filter..::.NewParameterFilter Method (BuiltInParameter, CriteriaFilterType, Double)
Filter Class See Also Send Feedback
Creates a parameter filter object based on a double built-in parameter type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterFilter NewParameterFilter(
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    double parameterValue
)
Visual Basic (Declaration)
Public Function NewParameterFilter ( _
    builtinParameter As BuiltInParameter, _
    filterType As CriteriaFilterType, _
    parameterValue As Double _
) As ParameterFilter
Visual C++
public:
ParameterFilter^ NewParameterFilter(
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    double parameterValue
)

Parameters

builtinParameter
Type: Autodesk.Revit.Parameters..::.BuiltInParameter
The built in parameter id of the parameter to be retrieved.
filterType
Type: Autodesk.Revit.Enums..::.CriteriaFilterType
The relationship between element's parameter value and the specified value.
parameterValue
Type: System..::.Double
The parameter value that is stored as Double.

Return Value

Returns a new parameter filter object with given Double value.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.
System..::.NotFiniteNumberException | Thrown when the parameterValue is infinite values, such as double.NegativeInfinite.
System..::.ArgumentException | Thrown when the parameterValue is not number, such as double.Nan.

See Also

Filter Class
NewParameterFilter Overload
Autodesk.Revit.Creation Namespace


NewParameterFilter Method (BuiltInParameter, CriteriaFilterType, Int32)

[image]

Revit 2010 API
Filter..::.NewParameterFilter Method (BuiltInParameter, CriteriaFilterType, Int32)
Filter Class See Also Send Feedback
Creates a parameter filter object based on an integer built-in parameter type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterFilter NewParameterFilter(
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    int parameterValue
)
Visual Basic (Declaration)
Public Function NewParameterFilter ( _
    builtinParameter As BuiltInParameter, _
    filterType As CriteriaFilterType, _
    parameterValue As Integer _
) As ParameterFilter
Visual C++
public:
ParameterFilter^ NewParameterFilter(
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    int parameterValue
)

Parameters

builtinParameter
Type: Autodesk.Revit.Parameters..::.BuiltInParameter
The built-in parameter id of the parameter to be retrieved.
filterType
Type: Autodesk.Revit.Enums..::.CriteriaFilterType
The relationship between element's parameter value and the specified value.
parameterValue
Type: System..::.Int32
The parameter value that is stored as Integer.

Return Value

Returns a new parameter filter object with given Integer value.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
NewParameterFilter Overload
Autodesk.Revit.Creation Namespace


NewParameterFilter Method (BuiltInParameter, CriteriaFilterType, String)

[image]

Revit 2010 API
Filter..::.NewParameterFilter Method (BuiltInParameter, CriteriaFilterType, String)
Filter Class See Also Send Feedback
Creates a parameter filter object based on a string built-in parameter type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterFilter NewParameterFilter(
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    string parameterValue
)
Visual Basic (Declaration)
Public Function NewParameterFilter ( _
    builtinParameter As BuiltInParameter, _
    filterType As CriteriaFilterType, _
    parameterValue As String _
) As ParameterFilter
Visual C++
public:
ParameterFilter^ NewParameterFilter(
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    String^ parameterValue
)

Parameters

builtinParameter
Type: Autodesk.Revit.Parameters..::.BuiltInParameter
The built in parameter id of the parameter to be retrieved.
filterType
Type: Autodesk.Revit.Enums..::.CriteriaFilterType
The relationship between element's parameter value and the specified value.
parameterValue
Type: System..::.String
The parameter value that is stored as String.

Return Value

Returns a new parameter filter object with given string.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.
System..::.ArgumentNullException | Thrown when the parameterValue is nullptr.

See Also

Filter Class
NewParameterFilter Overload
Autodesk.Revit.Creation Namespace


NewParameterFilter Method (String, CriteriaFilterType, ElementId)

[image]

Revit 2010 API
Filter..::.NewParameterFilter Method (String, CriteriaFilterType, ElementId)
Filter Class See Also Send Feedback
Creates a parameter filter object based on the name of an ElementId parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterFilter NewParameterFilter(
    string paramDefName,
    CriteriaFilterType filterType,
    ElementId parameterValue
)
Visual Basic (Declaration)
Public Function NewParameterFilter ( _
    paramDefName As String, _
    filterType As CriteriaFilterType, _
    parameterValue As ElementId _
) As ParameterFilter
Visual C++
public:
ParameterFilter^ NewParameterFilter(
    String^ paramDefName,
    CriteriaFilterType filterType,
    ElementId parameterValue
)

Parameters

paramDefName
Type: System..::.String
The user visible name of the parameter to be retrieved.
filterType
Type: Autodesk.Revit.Enums..::.CriteriaFilterType
The relationship between element's parameter value and the specified value.
parameterValue
Type: Autodesk.Revit..::.ElementId
The parameter value that is stored as ElementId.

Return Value

Returns a new parameter filter object with given element id.

Remarks

Retrieves a parameter by parameter name to create the parameter filter object. Each name of parameters are displayed in the Element properties dialog in the Autodesk Revit interface and some invisible shared parameters can be used here.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.
System..::.ArgumentNullException | Thrown when the paramDefName is nullptr.

See Also

Filter Class
NewParameterFilter Overload
Autodesk.Revit.Creation Namespace


NewParameterFilter Method (String, CriteriaFilterType, Double)

[image]

Revit 2010 API
Filter..::.NewParameterFilter Method (String, CriteriaFilterType, Double)
Filter Class See Also Send Feedback
Creates a parameter filter object based on the name of a double parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterFilter NewParameterFilter(
    string paramDefName,
    CriteriaFilterType filterType,
    double parameterValue
)
Visual Basic (Declaration)
Public Function NewParameterFilter ( _
    paramDefName As String, _
    filterType As CriteriaFilterType, _
    parameterValue As Double _
) As ParameterFilter
Visual C++
public:
ParameterFilter^ NewParameterFilter(
    String^ paramDefName,
    CriteriaFilterType filterType,
    double parameterValue
)

Parameters

paramDefName
Type: System..::.String
The user visible name of the parameter to be retrieved.
filterType
Type: Autodesk.Revit.Enums..::.CriteriaFilterType
The relationship between element's parameter value and the specified value.
parameterValue
Type: System..::.Double
The parameter value that is stored as Double.

Return Value

Returns a new parameter filter object with given Double value.

Remarks

Retrieves a parameter by parameter name to create the parameter filter object. Each name of parameters are displayed in the Element properties dialog in the Autodesk Revit interface and some invisible shared parameters can be used here.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.
System..::.ArgumentNullException | Thrown when the paramDefName is nullptr.
System..::.NotFiniteNumberException | Thrown when the parameterValue is infinite values, such as double.NegativeInfinite.
System..::.ArgumentException | Thrown when the parameterValue is not number, such as double.Nan.

See Also

Filter Class
NewParameterFilter Overload
Autodesk.Revit.Creation Namespace


NewParameterFilter Method (String, CriteriaFilterType, Int32)

[image]

Revit 2010 API
Filter..::.NewParameterFilter Method (String, CriteriaFilterType, Int32)
Filter Class See Also Send Feedback
Creates a parameter filter object based on the name of an integer parameter .

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterFilter NewParameterFilter(
    string paramDefName,
    CriteriaFilterType filterType,
    int parameterValue
)
Visual Basic (Declaration)
Public Function NewParameterFilter ( _
    paramDefName As String, _
    filterType As CriteriaFilterType, _
    parameterValue As Integer _
) As ParameterFilter
Visual C++
public:
ParameterFilter^ NewParameterFilter(
    String^ paramDefName,
    CriteriaFilterType filterType,
    int parameterValue
)

Parameters

paramDefName
Type: System..::.String
The user visible name of the parameter to be retrieved.
filterType
Type: Autodesk.Revit.Enums..::.CriteriaFilterType
The relationship between element's parameter value and the specified value.
parameterValue
Type: System..::.Int32
The parameter value that is stored as Integer.

Return Value

Returns a new parameter filter object with given Integer value.

Remarks

Retrieves a parameter by parameter name to create the parameter filter object. Each name of parameters are displayed in the Element properties dialog in the Autodesk Revit interface and some invisible shared parameters can be used here.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.
System..::.ArgumentNullException | Thrown when the paramDefName is nullptr.

See Also

Filter Class
NewParameterFilter Overload
Autodesk.Revit.Creation Namespace


NewParameterFilter Method (String, CriteriaFilterType, String)

[image]

Revit 2010 API
Filter..::.NewParameterFilter Method (String, CriteriaFilterType, String)
Filter Class See Also Send Feedback
Creates a parameter filter object based on the name of a string parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterFilter NewParameterFilter(
    string paramDefName,
    CriteriaFilterType filterType,
    string parameterValue
)
Visual Basic (Declaration)
Public Function NewParameterFilter ( _
    paramDefName As String, _
    filterType As CriteriaFilterType, _
    parameterValue As String _
) As ParameterFilter
Visual C++
public:
ParameterFilter^ NewParameterFilter(
    String^ paramDefName,
    CriteriaFilterType filterType,
    String^ parameterValue
)

Parameters

paramDefName
Type: System..::.String
The user visible name of the parameter to be retrieved.
filterType
Type: Autodesk.Revit.Enums..::.CriteriaFilterType
The relationship between element's parameter value and the specified value.
parameterValue
Type: System..::.String
The parameter value that is stored as String.

Return Value

Returns a new parameter filter object with given string.

Remarks

Retrieves a parameter by parameter name to create the parameter filter object. Each name of parameters are displayed in the Element properties dialog in the Autodesk Revit interface and some invisible shared parameters can be used here.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.
System..::.ArgumentNullException | Thrown when the paramDefName or parameterValue is nullptr.

See Also

Filter Class
NewParameterFilter Overload
Autodesk.Revit.Creation Namespace


NewStructuralTypeFilter Method

[image]

Revit 2010 API
Filter..::.NewStructuralTypeFilter Method
Filter Class See Also Send Feedback
Creates a StructuralTypeFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public StructuralTypeFilter NewStructuralTypeFilter(
    StructuralType structType
)
Visual Basic (Declaration)
Public Function NewStructuralTypeFilter ( _
    structType As StructuralType _
) As StructuralTypeFilter
Visual C++
public:
StructuralTypeFilter^ NewStructuralTypeFilter(
    StructuralType structType
)

Parameters

structType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
Filter elements by the structural type.

Return Value

Returns a new structural type filter object with given structural type.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewSymbolFilter Method

[image]

Revit 2010 API
Filter..::.NewSymbolFilter Method
Filter Class See Also Send Feedback
Creates a SymbolFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SymbolFilter NewSymbolFilter(
    string symbolName
)
Visual Basic (Declaration)
Public Function NewSymbolFilter ( _
    symbolName As String _
) As SymbolFilter
Visual C++
public:
SymbolFilter^ NewSymbolFilter(
    String^ symbolName
)

Parameters

symbolName
Type: System..::.String
Filter elements by the symbol name.

Return Value

Returns a new symbol filter object with given symbol.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the symbolName is nullptr or empty.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


NewTypeFilter Method

[image] [image]

Revit 2010 API
Filter..::.NewTypeFilter Method
Filter Class See Also Send Feedback
Creates a new TypeFilter object.

Overload List

Name | Description
NewTypeFilter(Type) | Creates a new TypeFilter object which filters based on exact type.
NewTypeFilter(Type, Boolean) | Creates a new TypeFilter object with the option to find elements derived from the type.

See Also

Filter Class
Filter Members
Autodesk.Revit.Creation Namespace


NewTypeFilter Method (Type)

[image]

Revit 2010 API
Filter..::.NewTypeFilter Method (Type)
Filter Class See Also Send Feedback
Creates a new TypeFilter object which filters based on exact type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TypeFilter NewTypeFilter(
    Type givenType
)
Visual Basic (Declaration)
Public Function NewTypeFilter ( _
    givenType As Type _
) As TypeFilter
Visual C++
public:
TypeFilter^ NewTypeFilter(
    Type^ givenType
)

Parameters

givenType
Type: System..::.Type
Filter elements by the given type.

Return Value

Returns a new type filter object within given type.

Remarks

It will not find out the elements which is given type's derived classes.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified givenType is nullptr.

See Also

Filter Class
NewTypeFilter Overload
Autodesk.Revit.Creation Namespace


NewTypeFilter Method (Type, Boolean)

[image]

Revit 2010 API
Filter..::.NewTypeFilter Method (Type, Boolean)
Filter Class See Also Send Feedback
Creates a new TypeFilter object with the option to find elements derived from the type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TypeFilter NewTypeFilter(
    Type givenType,
    bool includeDerivedTypes
)
Visual Basic (Declaration)
Public Function NewTypeFilter ( _
    givenType As Type, _
    includeDerivedTypes As Boolean _
) As TypeFilter
Visual C++
public:
TypeFilter^ NewTypeFilter(
    Type^ givenType,
    bool includeDerivedTypes
)

Parameters

givenType
Type: System..::.Type
Filter elements by the given type.
includeDerivedTypes
Type: System..::.Boolean
Indicates if find out the elements which are given type's derived classes or not. If includeDerivedTypes is true, will filter derived class elements; false, don't filter derived class elements.

Return Value

Returns a new type filter object within given type.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified givenType is nullptr.

See Also

Filter Class
NewTypeFilter Overload
Autodesk.Revit.Creation Namespace


NewWallUsageFilter Method

[image]

Revit 2010 API
Filter..::.NewWallUsageFilter Method
Filter Class See Also Send Feedback
Creates a new WallUsageFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WallUsageFilter NewWallUsageFilter(
    WallUsage wallUsage
)
Visual Basic (Declaration)
Public Function NewWallUsageFilter ( _
    wallUsage As WallUsage _
) As WallUsageFilter
Visual C++
public:
WallUsageFilter^ NewWallUsageFilter(
    WallUsage wallUsage
)

Parameters

wallUsage
Type: Autodesk.Revit.Structural.Enums..::.WallUsage
Filter elements by the wall usage.

Return Value

Returns a new wall usage filter object with given wall usage.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace


Filter Properties

[image] [image]

Revit 2010 API
Filter Properties
Filter Class See Also Send Feedback

The Filter type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Filter Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase Class

[image]

Revit 2010 API
ItemFactoryBase Class
Members See Also Send Feedback
The ItemFactoryBase object is used to create new instances of elements within the Autodesk Revit document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ItemFactoryBase : APIObject
Visual Basic (Declaration)
Public Class ItemFactoryBase _
    Inherits APIObject
Visual C++
public ref class ItemFactoryBase : public APIObject

Remarks

The ItemFactoryBase object is a utility object that is used to create new instances of elements within the Autodesk Revit document. this class hold common methods used in both project document and family document.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Creation..::.ItemFactoryBase
Autodesk.Revit.Creation..::.Document
Autodesk.Revit.Creation..::.FamilyItemFactory

See Also

ItemFactoryBase Members
Autodesk.Revit.Creation Namespace


ItemFactoryBase Members

[image] [image]

Revit 2010 API
ItemFactoryBase Members
ItemFactoryBase Class Constructors Methods Properties See Also Send Feedback

The ItemFactoryBase type exposes the following members.

Constructors

Name | Description
ItemFactoryBase | Initializes a new instance of the ItemFactoryBase class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewAlignment | Add a new locked alignment into the Autodesk Revit document.
NewAnnotationSymbol | Add a new instance of an Annotation Symbol into the Autodesk Revit document, using a location and a symbol.
NewDetailCurve | Creates a new detail curve element.
NewDetailCurveArray | Creates an array of new detail curve elements.
NewDimension | Overloaded. Creates a new linear dimension object.
NewFamilyInstance | Overloaded. Inserts a new instance of a family into the document.
NewFamilyInstances | Creates Family instances within the document.
NewGroup | Creates a new type of group.
NewLevel | Creates a new level.
NewModelCurve | Creates a new model line element.
NewModelCurveArray | Creates an array of new model line elements.
NewReferencePlane | Creates a new instance of ReferencePlane.
NewReferencePlane2 | Creates a new instance of ReferencePlane.
NewSketchPlane | Overloaded. Creates a new sketch plane.
NewTextNote | Overloaded. Creates a new TextNote object.
NewTextNotes | Creates TextNotes with the specified data.
NewView3D | Creates a new 3D view.
NewViewPlan | Creates a plan view based on the specified level.
NewViewSection | Creates a new section view.
PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase Constructor

[image]

Revit 2010 API
ItemFactoryBase Constructor
ItemFactoryBase Class See Also Send Feedback
Initializes a new instance of the ItemFactoryBase class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ItemFactoryBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ItemFactoryBase()

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase Methods

[image] [image]

Revit 2010 API
ItemFactoryBase Methods
ItemFactoryBase Class See Also Send Feedback

The ItemFactoryBase type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewAlignment | Add a new locked alignment into the Autodesk Revit document.
NewAnnotationSymbol | Add a new instance of an Annotation Symbol into the Autodesk Revit document, using a location and a symbol.
NewDetailCurve | Creates a new detail curve element.
NewDetailCurveArray | Creates an array of new detail curve elements.
NewDimension | Overloaded. Creates a new linear dimension object.
NewFamilyInstance | Overloaded. Inserts a new instance of a family into the document.
NewFamilyInstances | Creates Family instances within the document.
NewGroup | Creates a new type of group.
NewLevel | Creates a new level.
NewModelCurve | Creates a new model line element.
NewModelCurveArray | Creates an array of new model line elements.
NewReferencePlane | Creates a new instance of ReferencePlane.
NewReferencePlane2 | Creates a new instance of ReferencePlane.
NewSketchPlane | Overloaded. Creates a new sketch plane.
NewTextNote | Overloaded. Creates a new TextNote object.
NewTextNotes | Creates TextNotes with the specified data.
NewView3D | Creates a new 3D view.
NewViewPlan | Creates a plan view based on the specified level.
NewViewSection | Creates a new section view.
PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewAlignment Method

[image]

Revit 2010 API
ItemFactoryBase..::.NewAlignment Method
ItemFactoryBase Class See Also Send Feedback
Add a new locked alignment into the Autodesk Revit document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Alignment NewAlignment(
    View view,
    Reference reference1,
    Reference reference2
)
Visual Basic (Declaration)
Public Function NewAlignment ( _
    view As View, _
    reference1 As Reference, _
    reference2 As Reference _
) As Alignment
Visual C++
public:
Alignment^ NewAlignment(
    View^ view,
    Reference^ reference1,
    Reference^ reference2
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view that determines the orientation of the alignment.
reference1
Type: Autodesk.Revit.Geometry..::.Reference
The first reference.
reference2
Type: Autodesk.Revit.Geometry..::.Reference
The second reference.

Return Value

If creation was successful the new locked alignment is returned, otherwise an exception with failure information will be thrown.

Remarks

These two references must be one of the following combinations:
  • 2 planar faces
  • 2 lines
  • line and point
  • 2 arcs
  • 2 cylindrical faces
These references must be already geometrically aligned (this function will not force them to become aligned).

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"view" or "headerReference" or "otherReference"-is null.
System..::.ArgumentException | Thrown when the input argument-"headerReference" or "otherReference"-is invalid.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewAnnotationSymbol Method

[image]

Revit 2010 API
ItemFactoryBase..::.NewAnnotationSymbol Method
ItemFactoryBase Class See Also Send Feedback
Add a new instance of an Annotation Symbol into the Autodesk Revit document, using a location and a symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnnotationSymbol NewAnnotationSymbol(
    XYZ location,
    AnnotationSymbolType annotationSymbolType,
    View specView
)
Visual Basic (Declaration)
Public Function NewAnnotationSymbol ( _
    location As XYZ, _
    annotationSymbolType As AnnotationSymbolType, _
    specView As View _
) As AnnotationSymbol
Visual C++
public:
AnnotationSymbol^ NewAnnotationSymbol(
    XYZ^ location,
    AnnotationSymbolType^ annotationSymbolType,
    View^ specView
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the annotation symbol is to be placed.
annotationSymbolType
Type: Autodesk.Revit.Symbols..::.AnnotationSymbolType
A annotation symbol type object that represents the type of the instance that is to be inserted.
specView
Type: Autodesk.Revit.Elements..::.View
a 2D view which display the annotation symbol.

Return Value

If creation was successful then an instance to the new object is returned, otherwise Nothing.

Remarks

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewDetailCurve Method

[image]

Revit 2010 API
ItemFactoryBase..::.NewDetailCurve Method
ItemFactoryBase Class See Also Send Feedback
Creates a new detail curve element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DetailCurve NewDetailCurve(
    View view,
    Curve geometryCurve
)
Visual Basic (Declaration)
Public Function NewDetailCurve ( _
    view As View, _
    geometryCurve As Curve _
) As DetailCurve
Visual C++
public:
DetailCurve^ NewDetailCurve(
    View^ view,
    Curve^ geometryCurve
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the detail curve is to be visible.
geometryCurve
Type: Autodesk.Revit.Geometry..::.Curve
The internal geometry curve for detail curve. It should be a bound curve.

Return Value

If successful a new detail curve element. Otherwise null pointer.

Remarks

Different type of detail curve element will be returned according to the type of geometry curve.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewDetailCurveArray Method

[image]

Revit 2010 API
ItemFactoryBase..::.NewDetailCurveArray Method
ItemFactoryBase Class See Also Send Feedback
Creates an array of new detail curve elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DetailCurveArray NewDetailCurveArray(
    View view,
    CurveArray geometryCurveArray
)
Visual Basic (Declaration)
Public Function NewDetailCurveArray ( _
    view As View, _
    geometryCurveArray As CurveArray _
) As DetailCurveArray
Visual C++
public:
DetailCurveArray^ NewDetailCurveArray(
    View^ view,
    CurveArray^ geometryCurveArray
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the detail curves are to be visible.
geometryCurveArray
Type: Autodesk.Revit.Geometry..::.CurveArray
An array containing the internal geometry curves for detail lines. The curve in array should be bound curve.

Return Value

If successful an array of new detail curve elements. Otherwise null pointer.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewDimension Method

[image] [image]

Revit 2010 API
ItemFactoryBase..::.NewDimension Method
ItemFactoryBase Class See Also Send Feedback
Creates a new linear dimension object.

Overload List

Name | Description
NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style.
NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style.

See Also

ItemFactoryBase Class
ItemFactoryBase Members
Autodesk.Revit.Creation Namespace


NewDimension Method (View, Line, ReferenceArray)

[image]

Revit 2010 API
ItemFactoryBase..::.NewDimension Method (View, Line, ReferenceArray)
ItemFactoryBase Class Example See Also Send Feedback
Creates a new linear dimension object using the default dimension style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Dimension NewDimension(
    View view,
    Line line,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewDimension ( _
    view As View, _
    line As Line, _
    references As ReferenceArray _
) As Dimension
Visual C++
public:
Dimension^ NewDimension(
    View^ view,
    Line^ line,
    ReferenceArray^ references
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the dimension is to be visible.
line
Type: Autodesk.Revit.Geometry..::.Line
The line drawn for the dimension.
references
Type: Autodesk.Revit.Geometry..::.ReferenceArray
An array of geometric references to which the dimension is to be bound.

Return Value

If successful a new dimension object, otherwise Nothing.

Remarks

The currently user set default style is used for the created dimension.

Examples

CopyC#
Dimension CreateNewDimensionAlongLine(Autodesk.Revit.Document document, Line line)
{
    // Use the Start and End points of our line as the references
    // Line must come from something in Revit, such as a beam
    ReferenceArray references = new ReferenceArray();
    references.Append(line.get_EndPointReference(0));
    references.Append(line.get_EndPointReference(1));

    // create the new dimension
    Dimension dimension = document.Create.NewDimension(document.ActiveView,
                                                        line, references);
    return dimension;
}
CopyVB.NET
Private Function CreateNewDimensionAlongLine(ByVal document As Autodesk.Revit.Document, ByVal line As Line) As Autodesk.Revit.Elements.Dimension
    ' Use the Start and End points of our line as the references
    ' Line must come from something in Revit, such as a beam
    Dim references As New ReferenceArray()
    references.Append(line.EndPointReference(0))
    references.Append(line.EndPointReference(1))

    ' create the new dimension
    Dim dimension As Autodesk.Revit.Elements.Dimension = document.Create.NewDimension(document.ActiveView, line, references)
    Return dimension
End Function

See Also

ItemFactoryBase Class
NewDimension Overload
Autodesk.Revit.Creation Namespace


NewDimension Method (View, Line, ReferenceArray, DimensionType)

[image]

Revit 2010 API
ItemFactoryBase..::.NewDimension Method (View, Line, ReferenceArray, DimensionType)
ItemFactoryBase Class See Also Send Feedback
Creates a new linear dimension object using the specified dimension style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Dimension NewDimension(
    View view,
    Line line,
    ReferenceArray references,
    DimensionType dimensionType
)
Visual Basic (Declaration)
Public Function NewDimension ( _
    view As View, _
    line As Line, _
    references As ReferenceArray, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewDimension(
    View^ view,
    Line^ line,
    ReferenceArray^ references,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the dimension is to be visible.
line
Type: Autodesk.Revit.Geometry..::.Line
The line drawn for the dimension.
references
Type: Autodesk.Revit.Geometry..::.ReferenceArray
An array of geometric references to which the dimension is to be bound.
dimensionType
Type: Autodesk.Revit.Symbols..::.DimensionType
The dimension style to be used for the dimension.

Return Value

If successful a new dimension object, otherwise Nothing.

See Also

ItemFactoryBase Class
NewDimension Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method

[image] [image]

Revit 2010 API
ItemFactoryBase..::.NewFamilyInstance Method
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family into the document.

Overload List

Name | Description
NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.
NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol.
NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.
NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.
NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.

See Also

ItemFactoryBase Class
ItemFactoryBase Members
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (Face, Line, FamilySymbol)

[image]

Revit 2010 API
ItemFactoryBase..::.NewFamilyInstance Method (Face, Line, FamilySymbol)
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Face face,
    Line position,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    face As Face, _
    position As Line, _
    symbol As FamilySymbol _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Face^ face,
    Line^ position,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.Geometry..::.Face
A face of a geometry object.
position
Type: Autodesk.Revit.Geometry..::.Line
A line on the face defining where the symbol is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

Return Value

An instance of the new object if creation was successful, otherwise Nothing(null).

Remarks

Use this method to insert one family instance on a face of another element, using a line on the face to define the position and direction of the new symbol.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must support insertion of instances, otherwise this method will fail. If the instance fails to be created an exception may be thrown.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, StructuralType)

[image]

Revit 2010 API
ItemFactoryBase..::.NewFamilyInstance Method (XYZ, FamilySymbol, StructuralType)
ItemFactoryBase Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a location and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise Nothing.

Remarks

Use this method to insert a family instance that does not require a host element or level.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Examples

CopyC#
String fileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Furniture\Table-Dining Round w Chairs.rfa";

// try to load family
Family family = null;
if (!document.LoadFamily(fileName, out family))
{
    throw new Exception("Unable to load " + fileName);
}

// Loop through table symbols and add a new table for each
FamilySymbolSetIterator symbolItor = family.Symbols.ForwardIterator();
double x = 0.0, y = 0.0;
while (symbolItor.MoveNext())
{
    FamilySymbol symbol = symbolItor.Current as FamilySymbol;
    XYZ location = new XYZ(x, y, 10.0);
    // Do not use the overloaded NewFamilyInstance() method that contains
    // the Level argument, otherwise Revit cannot show the instances
    // correctly in 3D View, for the table is not level-based component.
    FamilyInstance instance = document.Create.NewFamilyInstance(location, symbol, StructuralType.NonStructural);
    x += 10.0;
}
CopyVB.NET
Dim fileName As String = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Furniture\Table-Dining Round w Chairs.rfa"

' try to load family
Dim family As Autodesk.Revit.Elements.Family = Nothing
If Not document.LoadFamily(fileName, family) Then
    Throw New Exception("Unable to load " & fileName)
End If

' Loop through table symbols and add a new table for each
Dim symbolItor As FamilySymbolSetIterator = family.Symbols.ForwardIterator()
Dim x As Double = 0.0R, y As Double = 0.0R
While symbolItor.MoveNext()
    Dim symbol As Autodesk.Revit.Symbols.FamilySymbol = TryCast(symbolItor.Current, Autodesk.Revit.Symbols.FamilySymbol)
    Dim location As New Autodesk.Revit.Geometry.XYZ(x, y, 10.0R)
    ' Do not use the overloaded NewFamilyInstance() method that contains
    ' the Level argument, otherwise Revit cannot show the instances
    ' correctly in 3D View, for the table is not level-based component.
    Dim instance As Autodesk.Revit.Elements.FamilyInstance = document.Create.NewFamilyInstance(location, symbol, StructuralType.NonStructural)
    x += 10.0R
End While

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (Face, XYZ, XYZ, FamilySymbol)

[image]

Revit 2010 API
ItemFactoryBase..::.NewFamilyInstance Method (Face, XYZ, XYZ, FamilySymbol)
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Face face,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    face As Face, _
    location As XYZ, _
    referenceDirection As XYZ, _
    symbol As FamilySymbol _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Face^ face,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.Geometry..::.Face
A face of a geometry object.
location
Type: Autodesk.Revit.Geometry..::.XYZ
Point on the face where the instance is to be placed.
referenceDirection
Type: Autodesk.Revit.Geometry..::.XYZ
A vector that defines the direction of the family instance.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

Return Value

An instance of the new object if creation was successful, otherwise Nothing(null).

Remarks

Use this method to insert one family instance on a face of another element, using a point on the face and a vector to define the position and direction of the new symbol.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must support insertion of instances, otherwise this method will fail. If the instances fails to be created an exception may be thrown.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted, these linear family instances can have their endpoints changed by using the instance's Element.Location property.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, Element, StructuralType)

[image]

Revit 2010 API
ItemFactoryBase..::.NewFamilyInstance Method (XYZ, FamilySymbol, Element, StructuralType)
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit..::.Element
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise Nothing.

Remarks

This method is used to insert one family instance into another element, such as inserting a window into a wall. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must be one that supports insertion of instances otherwise this method will fail.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)

[image]

Revit 2010 API
ItemFactoryBase..::.NewFamilyInstance Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)
ItemFactoryBase Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    XYZ referenceDirection,
    Element host,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    referenceDirection As XYZ, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    XYZ^ referenceDirection,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
referenceDirection
Type: Autodesk.Revit.Geometry..::.XYZ
A vector that dictates the direction of certains family instances.
host
Type: Autodesk.Revit..::.Element
A host object into which the instance will be embedded
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise Nothing.

Remarks

This method allows you to create FamilyInstance objects that require both a location and direction. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Examples

CopyC#
String fileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Furniture\Bed-Box.rfa";

Autodesk.Revit.Elements.Family family = null;
if (!document.LoadFamily(fileName, out family))
{
    throw new Exception("Couldn't load " + fileName);
}

Floor floor = null;

ElementIterator elemItor = document.get_Elements(typeof(Floor));
elemItor.Reset();
while (elemItor.MoveNext())
{
    Floor currentFloor = elemItor.Current as Floor;
    if (null != currentFloor)
    {
        floor = currentFloor;
        break;
    }
}

if (null != floor)
{
    FamilySymbolSetIterator symbolItor = family.Symbols.ForwardIterator();
    int x = 0, y = 0;
    int i = 0;
    while (symbolItor.MoveNext())
    {
        FamilySymbol symbol = symbolItor.Current as FamilySymbol;
        XYZ location = new XYZ(x, y, 0);
        XYZ direction = new XYZ();
        switch (i % 3)
        {
            case 0:
                direction = new XYZ(1, 1, 0);
                break;
            case 1:
                direction = new XYZ(0, 1, 1);
                break;
            case 2:
                direction = new XYZ(1, 0, 1);
                break;
        }
        FamilyInstance instance = document.Create.NewFamilyInstance(location, symbol, direction, floor, StructuralType.NonStructural);
        x += 10;
        i++;
    }
}
else
{
    throw new Exception("Please open a model with at least one floor element before invoking this command.");
}
CopyVB.NET
Dim fileName As String = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Furniture\Bed-Box.rfa"

Dim family As Autodesk.Revit.Elements.Family = Nothing
If Not document.LoadFamily(fileName, family) Then
    Throw New Exception("Couldn't load " & fileName)
End If

Dim floor As Autodesk.Revit.Elements.Floor = Nothing

Dim elemItor As ElementIterator = document.Elements(GetType(Autodesk.Revit.Elements.Floor))
elemItor.Reset()
While elemItor.MoveNext()
    Dim currentFloor As Autodesk.Revit.Elements.Floor = TryCast(elemItor.Current, Autodesk.Revit.Elements.Floor)
    If currentFloor IsNot Nothing Then
        floor = currentFloor
        Exit While
    End If
End While

If floor IsNot Nothing Then
    Dim symbolItor As FamilySymbolSetIterator = family.Symbols.ForwardIterator()
    Dim x As Integer = 0, y As Integer = 0
    Dim i As Integer = 0
    While symbolItor.MoveNext()
        Dim symbol As Autodesk.Revit.Symbols.FamilySymbol = TryCast(symbolItor.Current, Autodesk.Revit.Symbols.FamilySymbol)
        Dim location As New Autodesk.Revit.Geometry.XYZ(x, y, 0)
        Dim direction As New Autodesk.Revit.Geometry.XYZ()
        Select Case i Mod 3
            Case 0
                direction = New Autodesk.Revit.Geometry.XYZ(1, 1, 0)
                Exit Select
            Case 1
                direction = New Autodesk.Revit.Geometry.XYZ(0, 1, 1)
                Exit Select
            Case 2
                direction = New Autodesk.Revit.Geometry.XYZ(1, 0, 1)
                Exit Select
        End Select
        Dim instance As Autodesk.Revit.Elements.FamilyInstance = document.Create.NewFamilyInstance(location, symbol, direction, floor, StructuralType.NonStructural)
        x += 10
        i += 1
    End While
Else
    Throw New Exception("Please open a model with at least one floor element before invoking this command.")
End If

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstances Method

[image]

Revit 2010 API
ItemFactoryBase..::.NewFamilyInstances Method
ItemFactoryBase Class Example See Also Send Feedback
Creates Family instances within the document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewFamilyInstances(
    List<FamilyInstanceCreationData> dataList
)
Visual Basic (Declaration)
Public Function NewFamilyInstances ( _
    dataList As List(Of FamilyInstanceCreationData) _
) As ElementSet
Visual C++
public:
ElementSet^ NewFamilyInstances(
    List<FamilyInstanceCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::.List <(Of <( FamilyInstanceCreationData >)>)
A list of FamilyInstanceCreationData which wraps the creation arguments of the families to be created.

Return Value

If the creation is successful an ElementSet which contains the Family instances should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Examples

CopyC#
ElementSet BatchCreateColumns(Autodesk.Revit.Document document, Level level)
{
    List<FamilyInstanceCreationData> fiCreationDatas = new List<FamilyInstanceCreationData>();

    ElementSet elementSet = null;

    //Try to get a FamilySymbol
    FamilySymbol familySymbol = null;
    ElementIterator iter = document.get_Elements(typeof(FamilySymbol));
    iter.Reset();
    while (iter.MoveNext())
    {
        familySymbol = iter.Current as FamilySymbol;
        if (null != familySymbol && null != familySymbol.Category)
        {
            if ("Structural Columns" == familySymbol.Category.Name)
            {
                break;
            }
        }
    }

    if (null != familySymbol)
    {
        //Create 10 FamilyInstanceCreationData items for batch creation
        for (int i = 1; i < 11; i++)
        {
            XYZ location = new XYZ(i * 10, 100, 0);
            FamilyInstanceCreationData fiCreationData =
                new FamilyInstanceCreationData(location, familySymbol, level, Autodesk.Revit.Structural.Enums.StructuralType.Column);

            if (null != fiCreationData)
            {
                fiCreationDatas.Add(fiCreationData);
            }
        }

        if (fiCreationDatas.Count > 0)
        {
            // Create Columns
            elementSet = document.Create.NewFamilyInstances(fiCreationDatas);
        }
        else
        {
            throw new Exception("Batch creation failed.");
        }
    }
    else
    {
        throw new Exception("No column types found.");
    }

    return elementSet;
}
CopyVB.NET
Private Function BatchCreateColumns(ByVal document As Autodesk.Revit.Document, ByVal level As Autodesk.Revit.Elements.Level) As ElementSet

    Dim fiCreationDatas As New List(Of FamilyInstanceCreationData)()

    Dim elementSet As ElementSet = Nothing

    'Try to get a FamilySymbol
    Dim familySymbol As Autodesk.Revit.Symbols.FamilySymbol = Nothing
    Dim iter As ElementIterator = document.Elements(GetType(Autodesk.Revit.Symbols.FamilySymbol))
    iter.Reset()
    While iter.MoveNext()
        familySymbol = TryCast(iter.Current, Autodesk.Revit.Symbols.FamilySymbol)
        If familySymbol IsNot Nothing AndAlso familySymbol.Category IsNot Nothing Then
            If "Structural Columns" = familySymbol.Category.Name Then
                Exit While
            End If
        End If
    End While

    If familySymbol IsNot Nothing Then
        'Create 10 FamilyInstanceCreationData items for batch creation
        For i As Integer = 1 To 10
            Dim location As New Autodesk.Revit.Geometry.XYZ(i * 10, 100, 0)
            Dim fiCreationData As New FamilyInstanceCreationData(location, familySymbol, level, Autodesk.Revit.Structural.Enums.StructuralType.Column)

            If fiCreationData IsNot Nothing Then
                fiCreationDatas.Add(fiCreationData)
            End If
        Next

        If fiCreationDatas.Count > 0 Then
            ' Create Columns
            elementSet = document.Create.NewFamilyInstances(fiCreationDatas)
        Else
            Throw New Exception("Batch creation failed.")
        End If
    Else
        Throw New Exception("No column types found.")
    End If

    Return elementSet
End Function

Exceptions

Exception | Condition
System..::.ArgumentNullException | If FamilyInstanceCreationData's 'curve' or 'symbol' member is constructed with null object.
System..::.InvalidOperationException | If regeneration fails at the end of the batch creation.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewGroup Method

[image]

Revit 2010 API
ItemFactoryBase..::.NewGroup Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new type of group.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Group NewGroup(
    ElementSet elements
)
Visual Basic (Declaration)
Public Function NewGroup ( _
    elements As ElementSet _
) As Group
Visual C++
public:
Group^ NewGroup(
    ElementSet^ elements
)

Parameters

elements
Type: Autodesk.Revit..::.ElementSet
A set of elements which will be made into the new group.

Return Value

A new instance of a group containing the elements specified.

Remarks

  • The new group may contain more members than just the set input to this method. Elements which are closely connected with the inputs (such as sketch and sketch plane) will also be added to the group.
  • Initially the group will have a generic name, such as Group 1. This can be changed by changing the name of the group type as follows: newGroup.GroupType.Name = newName.

Examples

CopyC#
Group group = null;

ElementSet selection = document.Selection.Elements;
if (selection.Size > 0)
{
    // Group all selected elements
    group = document.Create.NewGroup(selection);

}
CopyVB.NET
Dim group As Group = Nothing

Dim selection As ElementSet = document.Selection.Elements
If selection.Size > 0 Then
    ' Group all selected elements
    group = document.Create.NewGroup(selection)

Else

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewLevel Method

[image]

Revit 2010 API
ItemFactoryBase..::.NewLevel Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Level NewLevel(
    double elevation
)
Visual Basic (Declaration)
Public Function NewLevel ( _
    elevation As Double _
) As Level
Visual C++
public:
Level^ NewLevel(
    double elevation
)

Parameters

elevation
Type: System..::.Double
The elevation to apply to the new level.

Return Value

The newly created level.

Remarks

Default level attributes will apply to this new model.

Examples

CopyC#
Level CreateLevel(Autodesk.Revit.Document document)
{
    // The elevation to apply to the new level
    double elevation = 20.0;

    // Begin to create a level
    Level level = document.Create.NewLevel(elevation);
    if (null == level)
    {
        throw new Exception("Create a new level failed.");
    }

    // Change the level name
    level.Name = "New level";

    return level;
}
CopyVB.NET
Private Function CreateLevel(ByVal document As Autodesk.Revit.Document) As Autodesk.Revit.Elements.Level
    ' The elevation to apply to the new level
    Dim elevation As Double = 20.0R

    ' Begin to create a level
    Dim level As Autodesk.Revit.Elements.Level = document.Create.NewLevel(elevation)
    If level Is Nothing Then
        Throw New Exception("Create a new level failed.")
    End If

    ' Change the level name
    level.Name = "New level"

    Return level
End Function

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewModelCurve Method

[image]

Revit 2010 API
ItemFactoryBase..::.NewModelCurve Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new model line element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelCurve NewModelCurve(
    Curve geometryCurve,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Function NewModelCurve ( _
    geometryCurve As Curve, _
    sketchPlane As SketchPlane _
) As ModelCurve
Visual C++
public:
ModelCurve^ NewModelCurve(
    Curve^ geometryCurve,
    SketchPlane^ sketchPlane
)

Parameters

geometryCurve
Type: Autodesk.Revit.Geometry..::.Curve
The internal geometry curve for model line.
sketchPlane
Type: Autodesk.Revit.Elements..::.SketchPlane
The sketch plane this new model line resides in.

Return Value

If successful a new model line element. Otherwise null pointer.

Remarks

Different type of model curve element will be returned according to the type of geometry curve.

Examples

CopyC#
// get handle to application from document
Autodesk.Revit.Application application = document.Application;

// Create a geometry line in revit application
XYZ startPoint = new XYZ(0, 0, 0);
XYZ endPoint = new XYZ(10, 10, 0);
Line geomLine = application.Create.NewLine(startPoint, endPoint, true);

// Create a geometry arc in revit application
XYZ end0 = new XYZ(1, 0, 0);
XYZ end1 = new XYZ(10, 10, 10);
XYZ pointOnCurve = new XYZ(10, 0, 0);
Arc geomArc = application.Create.NewArc(end0, end1, pointOnCurve);

// Create a geometry plane in revit application
XYZ origin = new XYZ(0, 0, 0);
XYZ normal = new XYZ(1, 1, 0);
Plane geomPlane = application.Create.NewPlane(normal, origin);

// Create a sketch plane in current document
SketchPlane sketch = document.Create.NewSketchPlane(geomPlane);

// Create a ModelLine element using the created geometry line and sketch plane
ModelLine line = document.Create.NewModelCurve(geomLine, sketch) as ModelLine;

// Create a ModelArc element using the created geometry arc and sketch plane
ModelArc arc = document.Create.NewModelCurve(geomArc, sketch) as ModelArc;
CopyVB.NET
' get handle to application from document
Dim application As Autodesk.Revit.Application = document.Application

' Create a geometry line in revit application
Dim startPoint As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
Dim endPoint As New Autodesk.Revit.Geometry.XYZ(10, 10, 0)
Dim geomLine As Line = application.Create.NewLine(startPoint, endPoint, True)

' Create a geometry arc in revit application
Dim end0 As New Autodesk.Revit.Geometry.XYZ(1, 0, 0)
Dim end1 As New Autodesk.Revit.Geometry.XYZ(10, 10, 10)
Dim pointOnCurve As New Autodesk.Revit.Geometry.XYZ(10, 0, 0)
Dim geomArc As Arc = application.Create.NewArc(end0, end1, pointOnCurve)

' Create a geometry plane in revit application
Dim origin As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
Dim normal As New Autodesk.Revit.Geometry.XYZ(1, 1, 0)
Dim geomPlane As Autodesk.Revit.Geometry.Plane = application.Create.NewPlane(normal, origin)

' Create a sketch plane in current document
Dim sketch As Autodesk.Revit.Elements.SketchPlane = document.Create.NewSketchPlane(geomPlane)

' Create a ModelLine element using the created geometry line and sketch plane
Dim line As ModelLine = TryCast(document.Create.NewModelCurve(geomLine, sketch), ModelLine)

' Create a ModelArc element using the created geometry arc and sketch plane
Dim arc As ModelArc = TryCast(document.Create.NewModelCurve(geomArc, sketch), ModelArc)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewModelCurveArray Method

[image]

Revit 2010 API
ItemFactoryBase..::.NewModelCurveArray Method
ItemFactoryBase Class See Also Send Feedback
Creates an array of new model line elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelCurveArray NewModelCurveArray(
    CurveArray geometryCurveArray,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Function NewModelCurveArray ( _
    geometryCurveArray As CurveArray, _
    sketchPlane As SketchPlane _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ NewModelCurveArray(
    CurveArray^ geometryCurveArray,
    SketchPlane^ sketchPlane
)

Parameters

geometryCurveArray
Type: Autodesk.Revit.Geometry..::.CurveArray
An array containing the internal geometry curves for model lines.
sketchPlane
Type: Autodesk.Revit.Elements..::.SketchPlane

Return Value

If successful an array of new model line elements. Otherwise null pointer.

Remarks

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewReferencePlane Method

[image]

Revit 2010 API
ItemFactoryBase..::.NewReferencePlane Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new instance of ReferencePlane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferencePlane NewReferencePlane(
    XYZ bubbleEnd,
    XYZ freeEnd,
    XYZ cutVec,
    View pView
)
Visual Basic (Declaration)
Public Function NewReferencePlane ( _
    bubbleEnd As XYZ, _
    freeEnd As XYZ, _
    cutVec As XYZ, _
    pView As View _
) As ReferencePlane
Visual C++
public:
ReferencePlane^ NewReferencePlane(
    XYZ^ bubbleEnd,
    XYZ^ freeEnd,
    XYZ^ cutVec,
    View^ pView
)

Parameters

bubbleEnd
Type: Autodesk.Revit.Geometry..::.XYZ
The bubble end applied to reference plane.
freeEnd
Type: Autodesk.Revit.Geometry..::.XYZ
The free end applied to reference plane.
cutVec
Type: Autodesk.Revit.Geometry..::.XYZ
The cut vector apply to reference plane, should perpendicular to the vector (bubbleEnd-freeEnd).
pView
Type: Autodesk.Revit.Elements..::.View
The specific view apply to the Reference plane.

Return Value

The newly created reference plane.

Examples

CopyC#
// Define data for reference plane creation
XYZ bubbleEnd = new XYZ(1, 0, 0);   // bubble end applied to reference plane
XYZ freeEnd = new XYZ(-5, 0, 0);    // free end applied to reference plane
// Cut vector should be perpendicular to bubbleEnd-freeEnd vector
XYZ cutVec = new XYZ(0, 0, 1);  // cut vector applied to reference plane

// Create the reference plane, applying the active view
ReferencePlane refPlane = document.Create.NewReferencePlane(bubbleEnd, freeEnd, cutVec, document.ActiveView);
CopyVB.NET
' Define data for reference plane creation
Dim bubbleEnd As New Autodesk.Revit.Geometry.XYZ(1, 0, 0)
' bubble end applied to reference plane
Dim freeEnd As New Autodesk.Revit.Geometry.XYZ(-5, 0, 0)
' free end applied to reference plane
' Cut vector should be perpendicular to bubbleEnd-freeEnd vector
Dim cutVec As New Autodesk.Revit.Geometry.XYZ(0, 0, 1)
' cut vector applied to reference plane
' Create the reference plane, applying the active view
Dim refPlane As ReferencePlane = document.Create.NewReferencePlane(bubbleEnd, freeEnd, cutVec, document.ActiveView)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewReferencePlane2 Method

[image]

Revit 2010 API
ItemFactoryBase..::.NewReferencePlane2 Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new instance of ReferencePlane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferencePlane NewReferencePlane2(
    XYZ bubbleEnd,
    XYZ freeEnd,
    XYZ thirdPnt,
    View pView
)
Visual Basic (Declaration)
Public Function NewReferencePlane2 ( _
    bubbleEnd As XYZ, _
    freeEnd As XYZ, _
    thirdPnt As XYZ, _
    pView As View _
) As ReferencePlane
Visual C++
public:
ReferencePlane^ NewReferencePlane2(
    XYZ^ bubbleEnd,
    XYZ^ freeEnd,
    XYZ^ thirdPnt,
    View^ pView
)

Parameters

bubbleEnd
Type: Autodesk.Revit.Geometry..::.XYZ
The bubble end applied to reference plane.
freeEnd
Type: Autodesk.Revit.Geometry..::.XYZ
The free end applied to reference plane.
thirdPnt
Type: Autodesk.Revit.Geometry..::.XYZ
A third point needed to define the reference plane.
pView
Type: Autodesk.Revit.Elements..::.View
The specific view apply to the Reference plane.

Return Value

The newly created reference plane.

Examples

CopyC#
// Build now data before creation
XYZ bubbleEnd = new XYZ(1, 0, 0);   // bubble end applied to reference plane
XYZ freeEnd = new XYZ(-5, 0, 0);    // free end applied to reference plane
// Third point should not be on the bubbleEnd-freeEnd line
XYZ thirdPnt = new XYZ(0, 15, 0);   // 3rd point to define reference plane

// Create the reference plane in X-Y, applying the active view
ReferencePlane refPlane = document.Create.NewReferencePlane2(bubbleEnd, freeEnd, thirdPnt, document.ActiveView);
CopyVB.NET
' Build now data before creation
Dim bubbleEnd As New Autodesk.Revit.Geometry.XYZ(1, 0, 0)
' bubble end applied to reference plane
Dim freeEnd As New Autodesk.Revit.Geometry.XYZ(-5, 0, 0)
' free end applied to reference plane
' Third point should not be on the bubbleEnd-freeEnd line
Dim thirdPnt As New Autodesk.Revit.Geometry.XYZ(0, 15, 0)
' 3rd point to define reference plane
' Create the reference plane in X-Y, applying the active view
Dim refPlane As ReferencePlane = document.Create.NewReferencePlane2(bubbleEnd, freeEnd, thirdPnt, document.ActiveView)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewSketchPlane Method

[image] [image]

Revit 2010 API
ItemFactoryBase..::.NewSketchPlane Method
ItemFactoryBase Class See Also Send Feedback
Creates a new sketch plane.

Overload List

Name | Description
NewSketchPlane(PlanarFace) | Creates a new sketch plane on a planar face of existing geometry.
NewSketchPlane(Plane) | Creates a new sketch plane from an arbitrary geometric plane.

See Also

ItemFactoryBase Class
ItemFactoryBase Members
Autodesk.Revit.Creation Namespace


NewSketchPlane Method (PlanarFace)

[image]

Revit 2010 API
ItemFactoryBase..::.NewSketchPlane Method (PlanarFace)
ItemFactoryBase Class See Also Send Feedback
Creates a new sketch plane on a planar face of existing geometry.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SketchPlane NewSketchPlane(
    PlanarFace planarFace
)
Visual Basic (Declaration)
Public Function NewSketchPlane ( _
    planarFace As PlanarFace _
) As SketchPlane
Visual C++
public:
SketchPlane^ NewSketchPlane(
    PlanarFace^ planarFace
)

Parameters

planarFace
Type: Autodesk.Revit.Geometry..::.PlanarFace
The geometry planar face to locate sketch plane.

Return Value

If successful a new sketch plane will be returned. otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the argument is null.
System..::.ArgumentException | Thrown when the argument is an invalid object, or reference of the argument is null, or the host of this face is invalid.

See Also

ItemFactoryBase Class
NewSketchPlane Overload
Autodesk.Revit.Creation Namespace


NewSketchPlane Method (Plane)

[image]

Revit 2010 API
ItemFactoryBase..::.NewSketchPlane Method (Plane)
ItemFactoryBase Class Example See Also Send Feedback
Creates a new sketch plane from an arbitrary geometric plane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SketchPlane NewSketchPlane(
    Plane geometryPlane
)
Visual Basic (Declaration)
Public Function NewSketchPlane ( _
    geometryPlane As Plane _
) As SketchPlane
Visual C++
public:
SketchPlane^ NewSketchPlane(
    Plane^ geometryPlane
)

Parameters

geometryPlane
Type: Autodesk.Revit.Geometry..::.Plane
The geometry plane to locate sketch plane.

Return Value

If successful a new sketch plane will be returned. Otherwise null pointer.

Remarks

Examples

CopyC#
public static SketchPlane CreateSketchPlane(Autodesk.Revit.Document document, Plane plane)
{
    SketchPlane sketchPlane = null;

    // create a sketch plane using Geometry.Plane
    sketchPlane = document.FamilyCreate.NewSketchPlane(plane);

    // throw exception if creation failed
    if (null == sketchPlane)
    {
        throw new Exception("Create the sketch plane failed.");
    }

    return sketchPlane;
}
CopyVB.NET
Public Shared Function CreateSketchPlane(ByVal document As Autodesk.Revit.Document, ByVal plane As Autodesk.Revit.Geometry.Plane) As Autodesk.Revit.Elements.SketchPlane
    Dim sketchPlane As Autodesk.Revit.Elements.SketchPlane = Nothing

    ' create a sketch plane using Geometry.Plane
    sketchPlane = document.FamilyCreate.NewSketchPlane(plane)

    ' throw exception if creation failed
    If sketchPlane Is Nothing Then
        Throw New Exception("Create the sketch plane failed.")
    End If

    Return sketchPlane
End Function

See Also

ItemFactoryBase Class
NewSketchPlane Overload
Autodesk.Revit.Creation Namespace


NewTextNote Method

[image] [image]

Revit 2010 API
ItemFactoryBase..::.NewTextNote Method
ItemFactoryBase Class See Also Send Feedback
Creates a new TextNote object.

Overload List

Name | Description
NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates a new text note with a single leader.
NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates a new TextNote object without a leader.

See Also

ItemFactoryBase Class
ItemFactoryBase Members
Autodesk.Revit.Creation Namespace


NewTextNote Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)

[image]

Revit 2010 API
ItemFactoryBase..::.NewTextNote Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)
ItemFactoryBase Class See Also Send Feedback
Creates a new text note with a single leader.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TextNote NewTextNote(
    View pView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ leaderEnd,
    XYZ leaderElbow,
    string strText
)
Visual Basic (Declaration)
Public Function NewTextNote ( _
    pView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    leaderType As TextNoteLeaderTypes, _
    leaderStyle As TextNoteLeaderStyles, _
    leaderEnd As XYZ, _
    leaderElbow As XYZ, _
    strText As String _
) As TextNote
Visual C++
public:
TextNote^ NewTextNote(
    View^ pView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ^ leaderEnd,
    XYZ^ leaderElbow,
    String^ strText
)

Parameters

pView
Type: Autodesk.Revit.Elements..::.View
The view where the text note object will be visible.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The origin of the text note.
baseVec
Type: Autodesk.Revit.Geometry..::.XYZ
The horizontal direction for text in the text note.
upVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vertical direction for text in the text note.
lineWidth
Type: System..::.Double
The width of the rectangle bounding the note text.
textAlign
Type: Autodesk.Revit.Enums..::.TextAlignFlags
Flags indicating the alignment of the note. This should be a bitwise OR including one of TEF_ALIGN_TOP, TEF_ALIGN_MIDDLE and TEF_ALIGN_BOTTOM and one of TEF_ALIGN_LEFT, TEF_ALIGN_CENTER and TEF_ALIGN_RIGHT. The defaults for this flag are TEF_ALIGN_TOP | TEF_ALIGN_LEFT.
leaderType
Type: Autodesk.Revit.Enums..::.TextNoteLeaderTypes
The type and alignment of the leader for the note.
leaderStyle
Type: Autodesk.Revit.Enums..::.TextNoteLeaderStyles
The style of the leader for the note.
leaderEnd
Type: Autodesk.Revit.Geometry..::.XYZ
The end point for the leader.
leaderElbow
Type: Autodesk.Revit.Geometry..::.XYZ
The elbow point for the leader.
strText
Type: System..::.String
Text to display in the text note. Include new line characters to force a multiple line note to be created. Notes may also wrap automatically based on the width of the note rectangle.

Return Value

If successful, a TextNote object is returned.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when (1) Any one of pView, origin, baseVec, upVec, strText is null. (2)leaderEnd is null when leaderStyle != Autodesk::Revit::Enums::TextNoteLeaderStyles::LCS_NONE. (3)leaderElbow is null when leaderStyle == Autodesk::Revit::Enums::TextNoteLeaderStyles::LCS_TWO_SEG_LINE.
System..::.NotFiniteNumberException | Thrown when lineWidth is not a finite number.
System..::.ArgumentOutOfRangeException | Thrown when (1) textAlign is not a valid Autodesk::Revit::Enums::TextAlignFlags or it is not a valid bitwise OR of Autodesk::Revit::Enums::TextAlignFlags. (2) leaderStyle is not a valid Autodesk::Revit::Enums::TextNoteLeaderTypes or leaderType is not a valid Autodesk::Revit::Enums::TextNoteLeaderTypes when leaderStyle != Autodesk::Revit::Enums::TextNoteLeaderStyles::LCS_NONE
System..::.InvalidOperationException | If the regeneration fails when creating the text note.

See Also

ItemFactoryBase Class
NewTextNote Overload
Autodesk.Revit.Creation Namespace


NewTextNote Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)

[image]

Revit 2010 API
ItemFactoryBase..::.NewTextNote Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)
ItemFactoryBase Class See Also Send Feedback
Creates a new TextNote object without a leader.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TextNote NewTextNote(
    View pView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    string strText
)
Visual Basic (Declaration)
Public Function NewTextNote ( _
    pView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    strText As String _
) As TextNote
Visual C++
public:
TextNote^ NewTextNote(
    View^ pView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    String^ strText
)

Parameters

pView
Type: Autodesk.Revit.Elements..::.View
The view where the text note object will be visible.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The origin of the text note.
baseVec
Type: Autodesk.Revit.Geometry..::.XYZ
The horizontal direction for text in the text note.
upVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vertical direction for text in the text note.
lineWidth
Type: System..::.Double
The width of the rectangle bounding the note text.
textAlign
Type: Autodesk.Revit.Enums..::.TextAlignFlags
Flags indicating the alignment of the note. This should be a bitwise OR including one of TEF_ALIGN_TOP, TEF_ALIGN_MIDDLE and TEF_ALIGN_BOTTOM and one of TEF_ALIGN_LEFT, TEF_ALIGN_CENTER and TEF_ALIGN_RIGHT. The defaults for this flag are TEF_ALIGN_TOP | TEF_ALIGN_LEFT.
strText
Type: System..::.String
Text to display in the text note. Include new line characters to force a multiple line note to be created. Notes may also wrap automatically based on the width of the note rectangle.

Return Value

If successful, a TextNote object is returned.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when any one of pView, origin, baseVec, upVec, strText is null.
System..::.NotFiniteNumberException | Thrown when the input lineWidth is not a finite number.
System..::.ArgumentOutOfRangeException | Thrown when the input textAlign is not a valid Autodesk::Revit::Enums::TextAlignFlags or it is not a valid bitwise OR of the align flags.
System..::.InvalidOperationException | If the regeneration fails when creating the text note.

See Also

ItemFactoryBase Class
NewTextNote Overload
Autodesk.Revit.Creation Namespace


NewTextNotes Method

[image]

Revit 2010 API
ItemFactoryBase..::.NewTextNotes Method
ItemFactoryBase Class See Also Send Feedback
Creates TextNotes with the specified data.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewTextNotes(
    List<TextNoteCreationData> dataList
)
Visual Basic (Declaration)
Public Function NewTextNotes ( _
    dataList As List(Of TextNoteCreationData) _
) As ElementSet
Visual C++
public:
ElementSet^ NewTextNotes(
    List<TextNoteCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::.List <(Of <( TextNoteCreationData >)>)
A list of TextNoteCreationData which wraps the creation arguments of the TextNotes to be created.

Return Value

If the creation is successful an ElementSet which contains the TextNotes should be returned, otherwise System::InvalidOperationException will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when (1) Any one of theView, origin, baseVec, upVec, strText in TextNoteCreationData is null. (2) Any one of leaderEnd is null in TextNoteCreationData when leaderStyle != Autodesk::Revit::Enums::TextNoteLeaderStyles::LCS_NONE . (3) Any one of leaderElbow is null TextNoteCreationData when leaderStyle == Autodesk::Revit::Enums::TextNoteLeaderStyles::LCS_TWO_SEG_LINE.
System..::.NotFiniteNumberException | Thrown when one lineWidth in textNoteCreationData is not a finite number.
System..::.ArgumentOutOfRangeException | Thrown when (1) Any one textAlign in TextNoteCreationData is not a valid Autodesk::Revit::Enums::TextAlignFlags or it is not a valid bitwise OR of Autodesk::Revit::Enums::TextAlignFlags. (2) Any one leaderStyle in TextNoteCreationData is not a valid Autodesk::Revit::Enums::TextNoteLeaderTypes or any one leaderType in TextNoteCreationData is not a valid Autodesk::Revit::Enums::TextNoteLeaderTypes when leaderStyle != Autodesk::Revit::Enums::TextNoteLeaderStyles::LCS_NONE
System..::.InvalidOperationException | If the phase is invalid or regeneration fails at the end of the batch creation.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewView3D Method

[image]

Revit 2010 API
ItemFactoryBase..::.NewView3D Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new 3D view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public View3D NewView3D(
    XYZ viewDirection
)
Visual Basic (Declaration)
Public Function NewView3D ( _
    viewDirection As XYZ _
) As View3D
Visual C++
public:
View3D^ NewView3D(
    XYZ^ viewDirection
)

Parameters

viewDirection
Type: Autodesk.Revit.Geometry..::.XYZ
The view direction - the vector pointing towards the eye.

Return Value

The newly created 3D view.

Examples

CopyC#
// Create a new View3D
XYZ direction = new XYZ(1, 1, 1);
View3D view3D = document.Create.NewView3D(direction);
if (null == view3D)
{
    throw new Exception("Failed to create new View3D");
}
CopyVB.NET
' Create a new View3D
Dim direction As New Autodesk.Revit.Geometry.XYZ(1, 1, 1)
Dim view3D As View3D = document.Create.NewView3D(direction)
If view3D Is Nothing Then
    Throw New Exception("Failed to create new View3D")
End If

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewViewPlan Method

[image]

Revit 2010 API
ItemFactoryBase..::.NewViewPlan Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a plan view based on the specified level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewPlan NewViewPlan(
    string pViewName,
    Level pLevel,
    ViewType viewType
)
Visual Basic (Declaration)
Public Function NewViewPlan ( _
    pViewName As String, _
    pLevel As Level, _
    viewType As ViewType _
) As ViewPlan
Visual C++
public:
ViewPlan^ NewViewPlan(
    String^ pViewName,
    Level^ pLevel,
    ViewType viewType
)

Parameters

pViewName
Type: System..::.String
The name for the new plan view, must be unique or null pointer.
pLevel
Type: Autodesk.Revit.Elements..::.Level
The level on which the plan view is to be associated.
viewType
Type: Autodesk.Revit.Enums..::.ViewType
The type of plan view to be created, must be Floor Plan or Ceiling Plan (Structural Plan in Structure).

Return Value

if successful, a new plan view object within the project, otherwise Nothing.

Remarks

if pViewName is null, the pLevel's name will be use as new plan view's name. if the name is not unique, an Exception will be thrown.

Examples

CopyC#
// Create a Level and a Floor Plan based on it
double elevation = 10.0;
Level level1 = document.Create.NewLevel(elevation);
ViewPlan floorView = document.Create.NewViewPlan(null, level1, ViewType.FloorPlan);

// Create another Level and a Ceiling Plan based on it
elevation += 10.0;
Level level2 = document.Create.NewLevel(elevation);
ViewPlan ceilingView = document.Create.NewViewPlan(null, level2, ViewType.CeilingPlan);
CopyVB.NET
' Create a Level and a Floor Plan based on it
Dim elevation As Double = 10.0R
Dim level1 As Autodesk.Revit.Elements.Level = document.Create.NewLevel(elevation)
Dim floorView As ViewPlan = document.Create.NewViewPlan(Nothing, level1, Autodesk.Revit.Enums.ViewType.FloorPlan)

' Create another Level and a Ceiling Plan based on it
elevation += 10.0R
Dim level2 As Autodesk.Revit.Elements.Level = document.Create.NewLevel(elevation)
Dim ceilingView As ViewPlan = document.Create.NewViewPlan(Nothing, level2, Autodesk.Revit.Enums.ViewType.CeilingPlan)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewViewSection Method

[image]

Revit 2010 API
ItemFactoryBase..::.NewViewSection Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new section view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSection NewViewSection(
    BoundingBoxXYZ box
)
Visual Basic (Declaration)
Public Function NewViewSection ( _
    box As BoundingBoxXYZ _
) As ViewSection
Visual C++
public:
ViewSection^ NewViewSection(
    BoundingBoxXYZ^ box
)

Parameters

box
Type: Autodesk.Revit.Geometry..::.BoundingBoxXYZ
The orientation and bounds of the view. The X direction of the box is right on screen; Y, up; Z, towards the user.

Return Value

The newly created section view.

Examples

CopyC#
// Get a BoundingBoxXYZ instance from revit
BoundingBoxXYZ box = document.ActiveView.CropBox;
if (null == box)
{
    throw new Exception("No BoundingBoxXYZ instance found.");
}

// Create a new view section.
ViewSection viewSection = document.Create.NewViewSection(box);
CopyVB.NET
' Get a BoundingBoxXYZ instance from revit
Dim box As BoundingBoxXYZ = document.ActiveView.CropBox
If box Is Nothing Then
    Throw New Exception("No BoundingBoxXYZ instance found.")
End If

' Create a new view section.
Dim viewSection As ViewSection = document.Create.NewViewSection(box)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


PlaceGroup Method

[image]

Revit 2010 API
ItemFactoryBase..::.PlaceGroup Method
ItemFactoryBase Class See Also Send Feedback
Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Group PlaceGroup(
    XYZ location,
    GroupType groupType
)
Visual Basic (Declaration)
Public Function PlaceGroup ( _
    location As XYZ, _
    groupType As GroupType _
) As Group
Visual C++
public:
Group^ PlaceGroup(
    XYZ^ location,
    GroupType^ groupType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the group is to be placed.
groupType
Type: Autodesk.Revit.Symbols..::.GroupType
A GroupType object that represents the type of group that is to be placed.

Return Value

If creation was successful then an instance to the new group is returned, otherwise Nothing.

Remarks

This method is used to place a new instance of an existing group type within the document. The group's origin will placed at the point specified by the location. All group types within the document can be found by iterating over the document and looking for elements of type Autodesk.Revit.Symbols.GroupType.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase Properties

[image] [image]

Revit 2010 API
ItemFactoryBase Properties
ItemFactoryBase Class See Also Send Feedback

The ItemFactoryBase type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Class

[image]

Revit 2010 API
ProfiledWallCreationData Class
Members See Also Send Feedback
A class which wraps the arguments of Wall for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ProfiledWallCreationData
Visual Basic (Declaration)
Public Class ProfiledWallCreationData
Visual C++
public ref class ProfiledWallCreationData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Creation..::.ProfiledWallCreationData

See Also

ProfiledWallCreationData Members
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Members

[image] [image]

Revit 2010 API
ProfiledWallCreationData Members
ProfiledWallCreationData Class Constructors Methods See Also Send Feedback

The ProfiledWallCreationData type exposes the following members.

Constructors

Name | Description
ProfiledWallCreationData | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfiledWallCreationData Class
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Constructor

[image] [image]

Revit 2010 API
ProfiledWallCreationData Constructor
ProfiledWallCreationData Class See Also Send Feedback

Overload List

Name | Description
ProfiledWallCreationData(CurveArray, Boolean) | Initializes a new instance of the ProfiledWallCreationData class
ProfiledWallCreationData(CurveArray, WallType, Level, Boolean) | Initializes a new instance of the ProfiledWallCreationData class
ProfiledWallCreationData(CurveArray, WallType, Level, Boolean, XYZ) | Initializes a new instance of the ProfiledWallCreationData class

See Also

ProfiledWallCreationData Class
ProfiledWallCreationData Members
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Constructor (CurveArray, Boolean)

[image]

Revit 2010 API
ProfiledWallCreationData Constructor (CurveArray, Boolean)
ProfiledWallCreationData Class See Also Send Feedback
Initializes a new instance of the ProfiledWallCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProfiledWallCreationData(
    CurveArray profile,
    bool structural
)
Visual Basic (Declaration)
Public Sub New ( _
    profile As CurveArray, _
    structural As Boolean _
)
Visual C++
public:
ProfiledWallCreationData(
    CurveArray^ profile,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

See Also

ProfiledWallCreationData Class
ProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Constructor (CurveArray, WallType, Level, Boolean)

[image]

Revit 2010 API
ProfiledWallCreationData Constructor (CurveArray, WallType, Level, Boolean)
ProfiledWallCreationData Class See Also Send Feedback
Initializes a new instance of the ProfiledWallCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProfiledWallCreationData(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Sub New ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean _
)
Visual C++
public:
ProfiledWallCreationData(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.Symbols..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

See Also

ProfiledWallCreationData Class
ProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Constructor (CurveArray, WallType, Level, Boolean, XYZ)

[image]

Revit 2010 API
ProfiledWallCreationData Constructor (CurveArray, WallType, Level, Boolean, XYZ)
ProfiledWallCreationData Class See Also Send Feedback
Initializes a new instance of the ProfiledWallCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProfiledWallCreationData(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic (Declaration)
Public Sub New ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
)
Visual C++
public:
ProfiledWallCreationData(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.Symbols..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.
normal
Type: Autodesk.Revit.Geometry..::.XYZ
A vector that must be perpendicular to the profile which dictates which side of the wall is considered.

See Also

ProfiledWallCreationData Class
ProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Methods

[image] [image]

Revit 2010 API
ProfiledWallCreationData Methods
ProfiledWallCreationData Class See Also Send Feedback

The ProfiledWallCreationData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfiledWallCreationData Class
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Class

[image]

Revit 2010 API
RectangularWallCreationData Class
Members See Also Send Feedback
A class which wraps the arguments of Wall for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RectangularWallCreationData
Visual Basic (Declaration)
Public Class RectangularWallCreationData
Visual C++
public ref class RectangularWallCreationData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Creation..::.RectangularWallCreationData

See Also

RectangularWallCreationData Members
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Members

[image] [image]

Revit 2010 API
RectangularWallCreationData Members
RectangularWallCreationData Class Constructors Methods See Also Send Feedback

The RectangularWallCreationData type exposes the following members.

Constructors

Name | Description
RectangularWallCreationData | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RectangularWallCreationData Class
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Constructor

[image] [image]

Revit 2010 API
RectangularWallCreationData Constructor
RectangularWallCreationData Class See Also Send Feedback

Overload List

Name | Description
RectangularWallCreationData(Curve, Level, Boolean) | Initializes a new instance of the RectangularWallCreationData class
RectangularWallCreationData(Curve, WallType, Level, Double, Double, Boolean, Boolean) | Initializes a new instance of the RectangularWallCreationData class

See Also

RectangularWallCreationData Class
RectangularWallCreationData Members
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Constructor (Curve, Level, Boolean)

[image]

Revit 2010 API
RectangularWallCreationData Constructor (Curve, Level, Boolean)
RectangularWallCreationData Class See Also Send Feedback
Initializes a new instance of the RectangularWallCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RectangularWallCreationData(
    Curve curve,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Sub New ( _
    curve As Curve, _
    level As Level, _
    structural As Boolean _
)
Visual C++
public:
RectangularWallCreationData(
    Curve^ curve,
    Level^ level,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
An arc or line representing the base line of the wall.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

See Also

RectangularWallCreationData Class
RectangularWallCreationData Overload
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Constructor (Curve, WallType, Level, Double, Double, Boolean, Boolean)

[image]

Revit 2010 API
RectangularWallCreationData Constructor (Curve, WallType, Level, Double, Double, Boolean, Boolean)
RectangularWallCreationData Class See Also Send Feedback
Initializes a new instance of the RectangularWallCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RectangularWallCreationData(
    Curve curve,
    WallType wallType,
    Level level,
    double height,
    double offset,
    bool flip,
    bool structural
)
Visual Basic (Declaration)
Public Sub New ( _
    curve As Curve, _
    wallType As WallType, _
    level As Level, _
    height As Double, _
    offset As Double, _
    flip As Boolean, _
    structural As Boolean _
)
Visual C++
public:
RectangularWallCreationData(
    Curve^ curve,
    WallType^ wallType,
    Level^ level,
    double height,
    double offset,
    bool flip,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
An arc or line representing the base line of the wall.
wallType
Type: Autodesk.Revit.Symbols..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the wall is to be placed.
height
Type: System..::.Double
The height of the wall.
offset
Type: System..::.Double
An offset distance, in feet from the specified baseline. The wall will be placed that distance from the baseline.
flip
Type: System..::.Boolean
Change which side of the wall is considered to be the inside and outside of the wall.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

See Also

RectangularWallCreationData Class
RectangularWallCreationData Overload
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Methods

[image] [image]

Revit 2010 API
RectangularWallCreationData Methods
RectangularWallCreationData Class See Also Send Feedback

The RectangularWallCreationData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RectangularWallCreationData Class
Autodesk.Revit.Creation Namespace


RoomCreationData Class

[image]

Revit 2010 API
RoomCreationData Class
Members See Also Send Feedback
A class which wraps the arguments of Room for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RoomCreationData
Visual Basic (Declaration)
Public Class RoomCreationData
Visual C++
public ref class RoomCreationData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Creation..::.RoomCreationData

See Also

RoomCreationData Members
Autodesk.Revit.Creation Namespace


RoomCreationData Members

[image] [image]

Revit 2010 API
RoomCreationData Members
RoomCreationData Class Constructors Methods Properties See Also Send Feedback

The RoomCreationData type exposes the following members.

Constructors

Name | Description
RoomCreationData | Initializes a new instance of the RoomCreationData class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
TagPoint | Get or set the location of room tag.

See Also

RoomCreationData Class
Autodesk.Revit.Creation Namespace


RoomCreationData Constructor

[image]

Revit 2010 API
RoomCreationData Constructor
RoomCreationData Class See Also Send Feedback
Initializes a new instance of the RoomCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RoomCreationData(
    Level level,
    UV point
)
Visual Basic (Declaration)
Public Sub New ( _
    level As Level, _
    point As UV _
)
Visual C++
public:
RoomCreationData(
    Level^ level,
    UV^ point
)

Parameters

level
Type: Autodesk.Revit.Elements..::.Level
- The level on which the room is to exist.
point
Type: Autodesk.Revit.Geometry..::.UV
A 2D point the dictates the location on that specified level.

See Also

RoomCreationData Class
Autodesk.Revit.Creation Namespace


RoomCreationData Methods

[image] [image]

Revit 2010 API
RoomCreationData Methods
RoomCreationData Class See Also Send Feedback

The RoomCreationData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoomCreationData Class
Autodesk.Revit.Creation Namespace


RoomCreationData Properties

[image] [image]

Revit 2010 API
RoomCreationData Properties
RoomCreationData Class See Also Send Feedback

The RoomCreationData type exposes the following members.

Properties

Name | Description
TagPoint | Get or set the location of room tag.

See Also

RoomCreationData Class
Autodesk.Revit.Creation Namespace


TagPoint Property

[image]

Revit 2010 API
RoomCreationData..::.TagPoint Property
RoomCreationData Class See Also Send Feedback
Get or set the location of room tag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV TagPoint { get; set; }
Visual Basic (Declaration)
Public Property TagPoint As UV
Visual C++
public:
property UV^ TagPoint {
    UV^ get ();
    void set (UV^ value);
}

See Also

RoomCreationData Class
Autodesk.Revit.Creation Namespace


TextNoteCreationData Class

[image]

Revit 2010 API
TextNoteCreationData Class
Members See Also Send Feedback
A class which wraps the arguments of TextNote for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class TextNoteCreationData
Visual Basic (Declaration)
Public Class TextNoteCreationData
Visual C++
public ref class TextNoteCreationData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Creation..::.TextNoteCreationData

See Also

TextNoteCreationData Members
Autodesk.Revit.Creation Namespace


TextNoteCreationData Members

[image] [image]

Revit 2010 API
TextNoteCreationData Members
TextNoteCreationData Class Constructors Methods See Also Send Feedback

The TextNoteCreationData type exposes the following members.

Constructors

Name | Description
TextNoteCreationData | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextNoteCreationData Class
Autodesk.Revit.Creation Namespace


TextNoteCreationData Constructor

[image] [image]

Revit 2010 API
TextNoteCreationData Constructor
TextNoteCreationData Class See Also Send Feedback

Overload List

Name | Description
TextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Initializes a new instance of the TextNoteCreationData class
TextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Initializes a new instance of the TextNoteCreationData class

See Also

TextNoteCreationData Class
TextNoteCreationData Members
Autodesk.Revit.Creation Namespace


TextNoteCreationData Constructor (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)

[image]

Revit 2010 API
TextNoteCreationData Constructor (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)
TextNoteCreationData Class See Also Send Feedback
Initializes a new instance of the TextNoteCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TextNoteCreationData(
    View theView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ leaderEnd,
    XYZ leaderElbow,
    string strText
)
Visual Basic (Declaration)
Public Sub New ( _
    theView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    leaderType As TextNoteLeaderTypes, _
    leaderStyle As TextNoteLeaderStyles, _
    leaderEnd As XYZ, _
    leaderElbow As XYZ, _
    strText As String _
)
Visual C++
public:
TextNoteCreationData(
    View^ theView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ^ leaderEnd,
    XYZ^ leaderElbow,
    String^ strText
)

Parameters

theView
Type: Autodesk.Revit.Elements..::.View
The view where the text note object will be visible.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The origin of the text note.
baseVec
Type: Autodesk.Revit.Geometry..::.XYZ
The horizontal direction for text in the text note.
upVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vertical direction for text in the text note.
lineWidth
Type: System..::.Double
The width of the rectangle bounding the note text.
textAlign
Type: Autodesk.Revit.Enums..::.TextAlignFlags
Flags indicating the alignment of the note. This should be a bitwise OR including one of TEF_ALIGN_TOP, TEF_ALIGN_MIDDLE and TEF_ALIGN_BOTTOM and one of TEF_ALIGN_LEFT, TEF_ALIGN_CENTER and TEF_ALIGN_RIGHT. The defaults for this flag are TEF_ALIGN_TOP | TEF_ALIGN_LEFT.
leaderType
Type: Autodesk.Revit.Enums..::.TextNoteLeaderTypes
The type and alignment of the leader for the note.
leaderStyle
Type: Autodesk.Revit.Enums..::.TextNoteLeaderStyles
The style for the leader.
leaderEnd
Type: Autodesk.Revit.Geometry..::.XYZ
The end point for the leader.
leaderElbow
Type: Autodesk.Revit.Geometry..::.XYZ
The elbow point for the leader.
strText
Type: System..::.String
Text to display in the text note. Include new line characters to force a multiple line note to be created. Notes may also wrap automatically based on the width of the note rectangle.

See Also

TextNoteCreationData Class
TextNoteCreationData Overload
Autodesk.Revit.Creation Namespace


TextNoteCreationData Constructor (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)

[image]

Revit 2010 API
TextNoteCreationData Constructor (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)
TextNoteCreationData Class See Also Send Feedback
Initializes a new instance of the TextNoteCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TextNoteCreationData(
    View theView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    string strText
)
Visual Basic (Declaration)
Public Sub New ( _
    theView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    strText As String _
)
Visual C++
public:
TextNoteCreationData(
    View^ theView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    String^ strText
)

Parameters

theView
Type: Autodesk.Revit.Elements..::.View
The view where the text note object will be visible.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The origin of the text note.
baseVec
Type: Autodesk.Revit.Geometry..::.XYZ
The horizontal direction for text in the text note.
upVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vertical direction for text in the text note.
lineWidth
Type: System..::.Double
The width of the rectangle bounding the note text.
textAlign
Type: Autodesk.Revit.Enums..::.TextAlignFlags
Flags indicating the alignment of the note. This should be a bitwise OR including one of TEF_ALIGN_TOP, TEF_ALIGN_MIDDLE and TEF_ALIGN_BOTTOM and one of TEF_ALIGN_LEFT, TEF_ALIGN_CENTER and TEF_ALIGN_RIGHT. The defaults for this flag are TEF_ALIGN_TOP | TEF_ALIGN_LEFT.
strText
Type: System..::.String
Text to display in the text note. Include new line characters to force a multiple line note to be created. Notes may also wrap automatically based on the width of the note rectangle.

See Also

TextNoteCreationData Class
TextNoteCreationData Overload
Autodesk.Revit.Creation Namespace


TextNoteCreationData Methods

[image] [image]

Revit 2010 API
TextNoteCreationData Methods
TextNoteCreationData Class See Also Send Feedback

The TextNoteCreationData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextNoteCreationData Class
Autodesk.Revit.Creation Namespace


Autodesk.Revit.Editor Namespace

[image]

Revit 2010 API
Autodesk.Revit.Editor Namespace
Send Feedback

Classes

Class | Description
SlabShapeCrease | A crease used in Slab Shape Editing.
SlabShapeCreaseArray | An array that can contain any number of creases used in Slab Shape Editing.
SlabShapeCreaseArrayIterator | An iterator to an array of creases used for Slab Shape Editing.
SlabShapeEditor | An object used for Slab Shape Editing.
SlabShapeVertex | A vertex used in Slab Shape Editing.
SlabShapeVertexArray | An array that can contain any number of vertices used in Slab Shape Editing.
SlabShapeVertexArrayIterator | An iterator to an array of vertices used for Slab Shape Editing.


SlabShapeCrease Class

[image]

Revit 2010 API
SlabShapeCrease Class
Members See Also Send Feedback
A crease used in Slab Shape Editing.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SlabShapeCrease
Visual Basic (Declaration)
Public Class SlabShapeCrease
Visual C++
public ref class SlabShapeCrease

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Editor..::.SlabShapeCrease

See Also

SlabShapeCrease Members
Autodesk.Revit.Editor Namespace


SlabShapeCrease Members

[image] [image]

Revit 2010 API
SlabShapeCrease Members
SlabShapeCrease Class Constructors Methods Properties See Also Send Feedback

The SlabShapeCrease type exposes the following members.

Constructors

Name | Description
SlabShapeCrease | For Internal Use Only.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CreaseType | The type of the crease.
Curve | The geometry of the crease.
EndPoints | The vertices of the crease.

See Also

SlabShapeCrease Class
Autodesk.Revit.Editor Namespace


SlabShapeCrease Constructor

[image]

Revit 2010 API
SlabShapeCrease Constructor
SlabShapeCrease Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabShapeCrease()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabShapeCrease()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabShapeCrease Class
Autodesk.Revit.Editor Namespace


SlabShapeCrease Methods

[image] [image]

Revit 2010 API
SlabShapeCrease Methods
SlabShapeCrease Class See Also Send Feedback

The SlabShapeCrease type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeCrease Class
Autodesk.Revit.Editor Namespace


SlabShapeCrease Properties

[image] [image]

Revit 2010 API
SlabShapeCrease Properties
SlabShapeCrease Class See Also Send Feedback

The SlabShapeCrease type exposes the following members.

Properties

Name | Description
CreaseType | The type of the crease.
Curve | The geometry of the crease.
EndPoints | The vertices of the crease.

See Also

SlabShapeCrease Class
Autodesk.Revit.Editor Namespace


CreaseType Property

[image]

Revit 2010 API
SlabShapeCrease..::.CreaseType Property
SlabShapeCrease Class See Also Send Feedback
The type of the crease.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabShapeCreaseType CreaseType { get; }
Visual Basic (Declaration)
Public ReadOnly Property CreaseType As SlabShapeCreaseType
Visual C++
public:
property SlabShapeCreaseType CreaseType {
    SlabShapeCreaseType get ();
}

See Also

SlabShapeCrease Class
Autodesk.Revit.Editor Namespace


Curve Property

[image]

Revit 2010 API
SlabShapeCrease..::.Curve Property
SlabShapeCrease Class See Also Send Feedback
The geometry of the crease.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

SlabShapeCrease Class
Autodesk.Revit.Editor Namespace


EndPoints Property

[image]

Revit 2010 API
SlabShapeCrease..::.EndPoints Property
SlabShapeCrease Class See Also Send Feedback
The vertices of the crease.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabShapeVertexArray EndPoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndPoints As SlabShapeVertexArray
Visual C++
public:
property SlabShapeVertexArray^ EndPoints {
    SlabShapeVertexArray^ get ();
}

See Also

SlabShapeCrease Class
Autodesk.Revit.Editor Namespace


SlabShapeCreaseArray Class

[image]

Revit 2010 API
SlabShapeCreaseArray Class
Members See Also Send Feedback
An array that can contain any number of creases used in Slab Shape Editing.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SlabShapeCreaseArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class SlabShapeCreaseArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SlabShapeCreaseArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Editor..::.SlabShapeCreaseArray

See Also

SlabShapeCreaseArray Members
Autodesk.Revit.Editor Namespace


SlabShapeCreaseArray Members

[image] [image]

Revit 2010 API
SlabShapeCreaseArray Members
SlabShapeCreaseArray Class Constructors Methods Properties See Also Send Feedback

The SlabShapeCreaseArray type exposes the following members.

Constructors

Name | Description
SlabShapeCreaseArray | Initializes a new instance of the SlabShapeCreaseArray class

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


SlabShapeCreaseArray Constructor

[image]

Revit 2010 API
SlabShapeCreaseArray Constructor
SlabShapeCreaseArray Class See Also Send Feedback
Initializes a new instance of the SlabShapeCreaseArray class

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabShapeCreaseArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabShapeCreaseArray()

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


SlabShapeCreaseArray Methods

[image] [image]

Revit 2010 API
SlabShapeCreaseArray Methods
SlabShapeCreaseArray Class See Also Send Feedback

The SlabShapeCreaseArray type exposes the following members.

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


Append Method

[image]

Revit 2010 API
SlabShapeCreaseArray..::.Append Method
SlabShapeCreaseArray Class See Also Send Feedback
Add the item to the end of the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    SlabShapeCrease item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As SlabShapeCrease _
)
Visual C++
public:
virtual void Append(
    SlabShapeCrease^ item
)

Parameters

item
Type: Autodesk.Revit.Editor..::.SlabShapeCrease
The item to be added.

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


Clear Method

[image]

Revit 2010 API
SlabShapeCreaseArray..::.Clear Method
SlabShapeCreaseArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


ForwardIterator Method

[image]

Revit 2010 API
SlabShapeCreaseArray..::.ForwardIterator Method
SlabShapeCreaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual SlabShapeCreaseArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SlabShapeCreaseArrayIterator
Visual C++
public:
virtual SlabShapeCreaseArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


GetEnumerator Method

[image]

Revit 2010 API
SlabShapeCreaseArray..::.GetEnumerator Method
SlabShapeCreaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


Insert Method

[image]

Revit 2010 API
SlabShapeCreaseArray..::.Insert Method
SlabShapeCreaseArray Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    SlabShapeCrease item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As SlabShapeCrease, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    SlabShapeCrease^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Editor..::.SlabShapeCrease
The item to be inserted into the array.
index
Type: System..::.Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


ReverseIterator Method

[image]

Revit 2010 API
SlabShapeCreaseArray..::.ReverseIterator Method
SlabShapeCreaseArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual SlabShapeCreaseArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SlabShapeCreaseArrayIterator
Visual C++
public:
virtual SlabShapeCreaseArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


SlabShapeCreaseArray Properties

[image] [image]

Revit 2010 API
SlabShapeCreaseArray Properties
SlabShapeCreaseArray Class See Also Send Feedback

The SlabShapeCreaseArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


IsEmpty Property

[image]

Revit 2010 API
SlabShapeCreaseArray..::.IsEmpty Property
SlabShapeCreaseArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


Item Property

[image]

Revit 2010 API
SlabShapeCreaseArray..::.Item Property
SlabShapeCreaseArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual SlabShapeCrease Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As SlabShapeCrease
Visual C++
public:
virtual property SlabShapeCrease^ Item[int index] {
    SlabShapeCrease^ get (int index);
    void set (int index, SlabShapeCrease^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


Size Property

[image]

Revit 2010 API
SlabShapeCreaseArray..::.Size Property
SlabShapeCreaseArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SlabShapeCreaseArray Class
Autodesk.Revit.Editor Namespace


SlabShapeCreaseArrayIterator Class

[image]

Revit 2010 API
SlabShapeCreaseArrayIterator Class
Members See Also Send Feedback
An iterator to an array of creases used for Slab Shape Editing.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class SlabShapeCreaseArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class SlabShapeCreaseArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SlabShapeCreaseArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Editor..::.SlabShapeCreaseArrayIterator

See Also

SlabShapeCreaseArrayIterator Members
Autodesk.Revit.Editor Namespace


SlabShapeCreaseArrayIterator Members

[image] [image]

Revit 2010 API
SlabShapeCreaseArrayIterator Members
SlabShapeCreaseArrayIterator Class Constructors Methods Properties See Also Send Feedback

The SlabShapeCreaseArrayIterator type exposes the following members.

Constructors

Name | Description
SlabShapeCreaseArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabShapeCreaseArrayIterator Class
Autodesk.Revit.Editor Namespace


SlabShapeCreaseArrayIterator Constructor

[image]

Revit 2010 API
SlabShapeCreaseArrayIterator Constructor
SlabShapeCreaseArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabShapeCreaseArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabShapeCreaseArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabShapeCreaseArrayIterator Class
Autodesk.Revit.Editor Namespace


SlabShapeCreaseArrayIterator Methods

[image] [image]

Revit 2010 API
SlabShapeCreaseArrayIterator Methods
SlabShapeCreaseArrayIterator Class See Also Send Feedback

The SlabShapeCreaseArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeCreaseArrayIterator Class
Autodesk.Revit.Editor Namespace


MoveNext Method

[image]

Revit 2010 API
SlabShapeCreaseArrayIterator..::.MoveNext Method
SlabShapeCreaseArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SlabShapeCreaseArrayIterator Class
Autodesk.Revit.Editor Namespace


Reset Method

[image]

Revit 2010 API
SlabShapeCreaseArrayIterator..::.Reset Method
SlabShapeCreaseArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SlabShapeCreaseArrayIterator Class
Autodesk.Revit.Editor Namespace


SlabShapeCreaseArrayIterator Properties

[image] [image]

Revit 2010 API
SlabShapeCreaseArrayIterator Properties
SlabShapeCreaseArrayIterator Class See Also Send Feedback

The SlabShapeCreaseArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabShapeCreaseArrayIterator Class
Autodesk.Revit.Editor Namespace


Current Property

[image]

Revit 2010 API
SlabShapeCreaseArrayIterator..::.Current Property
SlabShapeCreaseArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SlabShapeCreaseArrayIterator Class
Autodesk.Revit.Editor Namespace


SlabShapeEditor Class

[image]

Revit 2010 API
SlabShapeEditor Class
Members See Also Send Feedback
An object used for Slab Shape Editing.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SlabShapeEditor
Visual Basic (Declaration)
Public Class SlabShapeEditor
Visual C++
public ref class SlabShapeEditor

Remarks

The SlabShapeEditor can be obtained from a slab object, such as a roof or floor.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Editor..::.SlabShapeEditor

See Also

SlabShapeEditor Members
Autodesk.Revit.Editor Namespace


SlabShapeEditor Members

[image] [image]

Revit 2010 API
SlabShapeEditor Members
SlabShapeEditor Class Constructors Methods Properties See Also Send Feedback

The SlabShapeEditor type exposes the following members.

Constructors

Name | Description
SlabShapeEditor | For Internal Use Only.

Methods

Name | Description
DrawPoint | Adds a point to the corresponding slab, roof or floor.
DrawSplitLine | Draws a split line on the corresponding slab, roof or floor.
Enable | Enables the slab shape editing functionality.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ModifySubElement | Overloaded. Manipulates an entity on the corresponding slab, roof or floor.
PickSupport | Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.
ResetSlabShape | Removes the modifications made during editing and resets the element geometry back to the un-modified state.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEnabled | Identifies if the slab shape editing functionality is enabled.
SlabShapeCreases | All of the creases that can be edited.
SlabShapeVertices | All of the vertices that can be edited.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


SlabShapeEditor Constructor

[image]

Revit 2010 API
SlabShapeEditor Constructor
SlabShapeEditor Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabShapeEditor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabShapeEditor()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


SlabShapeEditor Methods

[image] [image]

Revit 2010 API
SlabShapeEditor Methods
SlabShapeEditor Class See Also Send Feedback

The SlabShapeEditor type exposes the following members.

Methods

Name | Description
DrawPoint | Adds a point to the corresponding slab, roof or floor.
DrawSplitLine | Draws a split line on the corresponding slab, roof or floor.
Enable | Enables the slab shape editing functionality.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ModifySubElement | Overloaded. Manipulates an entity on the corresponding slab, roof or floor.
PickSupport | Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.
ResetSlabShape | Removes the modifications made during editing and resets the element geometry back to the un-modified state.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


DrawPoint Method

[image]

Revit 2010 API
SlabShapeEditor..::.DrawPoint Method
SlabShapeEditor Class See Also Send Feedback
Adds a point to the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabShapeVertex DrawPoint(
    XYZ location
)
Visual Basic (Declaration)
Public Function DrawPoint ( _
    location As XYZ _
) As SlabShapeVertex
Visual C++
public:
SlabShapeVertex^ DrawPoint(
    XYZ^ location
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The location of the point.

Return Value

The newly created vertex.

Remarks

If the input location is not on the top face of the slab, this function will return null. Drawing a point on boundary crease may increase the number of creases.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the location is nullptr.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


DrawSplitLine Method

[image]

Revit 2010 API
SlabShapeEditor..::.DrawSplitLine Method
SlabShapeEditor Class See Also Send Feedback
Draws a split line on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabShapeCreaseArray DrawSplitLine(
    SlabShapeVertex startVertex,
    SlabShapeVertex endVertex
)
Visual Basic (Declaration)
Public Function DrawSplitLine ( _
    startVertex As SlabShapeVertex, _
    endVertex As SlabShapeVertex _
) As SlabShapeCreaseArray
Visual C++
public:
SlabShapeCreaseArray^ DrawSplitLine(
    SlabShapeVertex^ startVertex,
    SlabShapeVertex^ endVertex
)

Parameters

startVertex
Type: Autodesk.Revit.Editor..::.SlabShapeVertex
The vertex to start the split line.
endVertex
Type: Autodesk.Revit.Editor..::.SlabShapeVertex
The vertex to end the split line.

Return Value

The newly created creases.

Remarks

Drawing a split line may result in multiple creases, for example when the line crosses existing creases or boundary edges.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input vertex is nullptr.
System..::.ArgumentException | Thrown when the input vertex is invalid.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


Enable Method

[image]

Revit 2010 API
SlabShapeEditor..::.Enable Method
SlabShapeEditor Class See Also Send Feedback
Enables the slab shape editing functionality.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Enable()
Visual Basic (Declaration)
Public Sub Enable
Visual C++
public:
void Enable()

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


ModifySubElement Method

[image] [image]

Revit 2010 API
SlabShapeEditor..::.ModifySubElement Method
SlabShapeEditor Class See Also Send Feedback
Manipulates an entity on the corresponding slab, roof or floor.

Overload List

Name | Description
ModifySubElement(SlabShapeCrease, Double) | Manipulates the crease on the corresponding slab, roof or floor.
ModifySubElement(SlabShapeVertex, Double) | Manipulates the vertex on the corresponding slab, roof or floor.

See Also

SlabShapeEditor Class
SlabShapeEditor Members
Autodesk.Revit.Editor Namespace


ModifySubElement Method (SlabShapeCrease, Double)

[image]

Revit 2010 API
SlabShapeEditor..::.ModifySubElement Method (SlabShapeCrease, Double)
SlabShapeEditor Class See Also Send Feedback
Manipulates the crease on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ModifySubElement(
    SlabShapeCrease crease,
    double offset
)
Visual Basic (Declaration)
Public Sub ModifySubElement ( _
    crease As SlabShapeCrease, _
    offset As Double _
)
Visual C++
public:
void ModifySubElement(
    SlabShapeCrease^ crease,
    double offset
)

Parameters

crease
Type: Autodesk.Revit.Editor..::.SlabShapeCrease
The crease.
offset
Type: System..::.Double
The new value of the crease offset, which is the average of offsets of its ends.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the crease is nullptr.
System..::.ArgumentException | Thrown when the crease is invalid.

See Also

SlabShapeEditor Class
ModifySubElement Overload
Autodesk.Revit.Editor Namespace


ModifySubElement Method (SlabShapeVertex, Double)

[image]

Revit 2010 API
SlabShapeEditor..::.ModifySubElement Method (SlabShapeVertex, Double)
SlabShapeEditor Class See Also Send Feedback
Manipulates the vertex on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ModifySubElement(
    SlabShapeVertex vertex,
    double offset
)
Visual Basic (Declaration)
Public Sub ModifySubElement ( _
    vertex As SlabShapeVertex, _
    offset As Double _
)
Visual C++
public:
void ModifySubElement(
    SlabShapeVertex^ vertex,
    double offset
)

Parameters

vertex
Type: Autodesk.Revit.Editor..::.SlabShapeVertex
The vertex.
offset
Type: System..::.Double
The new value of the vertex offset.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the vertex is nullptr.
System..::.ArgumentException | Thrown when the vertex is invalid.

See Also

SlabShapeEditor Class
ModifySubElement Overload
Autodesk.Revit.Editor Namespace


PickSupport Method

[image]

Revit 2010 API
SlabShapeEditor..::.PickSupport Method
SlabShapeEditor Class See Also Send Feedback
Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void PickSupport(
    Line gLine
)
Visual Basic (Declaration)
Public Sub PickSupport ( _
    gLine As Line _
)
Visual C++
public:
void PickSupport(
    Line^ gLine
)

Parameters

gLine
Type: Autodesk.Revit.Geometry..::.Line
A line from a support element such as a beam.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input line is nullptr.
System..::.ArgumentException | Thrown when the input line is invalid.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


ResetSlabShape Method

[image]

Revit 2010 API
SlabShapeEditor..::.ResetSlabShape Method
SlabShapeEditor Class Example See Also Send Feedback
Removes the modifications made during editing and resets the element geometry back to the un-modified state.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ResetSlabShape()
Visual Basic (Declaration)
Public Sub ResetSlabShape
Visual C++
public:
void ResetSlabShape()

Remarks

Calling this method will reset the slab back to its original state and disable Slab Shape Editing. If further editing is needed, call Enable again.

Examples

CopyC#
private void ResetSlabShapes(Autodesk.Revit.Document document)
{
    Selection choices = document.Selection;
    ElementSet collection = choices.Elements;
    foreach (Autodesk.Revit.Element elem in collection)
    {
        Floor floor = elem as Floor;
        if (floor != null)
        {
            SlabShapeEditor slabShapeEditor = floor.SlabShapeEditor;
            slabShapeEditor.ResetSlabShape();
        }
    }

}
CopyVB.NET
Private Sub ResetSlabShapes(ByVal document As Autodesk.Revit.Document)
    Dim choices As Autodesk.Revit.Selection = document.Selection
    Dim collection As ElementSet = choices.Elements
    For Each elem As Autodesk.Revit.Element In collection
        Dim floor As Autodesk.Revit.Elements.Floor = TryCast(elem, Autodesk.Revit.Elements.Floor)
        If floor IsNot Nothing Then
            Dim slabShapeEditor As SlabShapeEditor = floor.SlabShapeEditor
            slabShapeEditor.ResetSlabShape()
        End If
    Next

End Sub

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


SlabShapeEditor Properties

[image] [image]

Revit 2010 API
SlabShapeEditor Properties
SlabShapeEditor Class See Also Send Feedback

The SlabShapeEditor type exposes the following members.

Properties

Name | Description
IsEnabled | Identifies if the slab shape editing functionality is enabled.
SlabShapeCreases | All of the creases that can be edited.
SlabShapeVertices | All of the vertices that can be edited.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


IsEnabled Property

[image]

Revit 2010 API
SlabShapeEditor..::.IsEnabled Property
SlabShapeEditor Class See Also Send Feedback
Identifies if the slab shape editing functionality is enabled.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsEnabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEnabled As Boolean
Visual C++
public:
property bool IsEnabled {
    bool get ();
}

Remarks

If true, the creases and vertices are accessible and modifiable. If false, no creases and vertices are accessible.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


SlabShapeCreases Property

[image]

Revit 2010 API
SlabShapeEditor..::.SlabShapeCreases Property
SlabShapeEditor Class See Also Send Feedback
All of the creases that can be edited.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabShapeCreaseArray SlabShapeCreases { get; }
Visual Basic (Declaration)
Public ReadOnly Property SlabShapeCreases As SlabShapeCreaseArray
Visual C++
public:
property SlabShapeCreaseArray^ SlabShapeCreases {
    SlabShapeCreaseArray^ get ();
}

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


SlabShapeVertices Property

[image]

Revit 2010 API
SlabShapeEditor..::.SlabShapeVertices Property
SlabShapeEditor Class See Also Send Feedback
All of the vertices that can be edited.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabShapeVertexArray SlabShapeVertices { get; }
Visual Basic (Declaration)
Public ReadOnly Property SlabShapeVertices As SlabShapeVertexArray
Visual C++
public:
property SlabShapeVertexArray^ SlabShapeVertices {
    SlabShapeVertexArray^ get ();
}

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace


SlabShapeVertex Class

[image]

Revit 2010 API
SlabShapeVertex Class
Members See Also Send Feedback
A vertex used in Slab Shape Editing.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SlabShapeVertex
Visual Basic (Declaration)
Public Class SlabShapeVertex
Visual C++
public ref class SlabShapeVertex

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Editor..::.SlabShapeVertex

See Also

SlabShapeVertex Members
Autodesk.Revit.Editor Namespace


SlabShapeVertex Members

[image] [image]

Revit 2010 API
SlabShapeVertex Members
SlabShapeVertex Class Constructors Methods Properties See Also Send Feedback

The SlabShapeVertex type exposes the following members.

Constructors

Name | Description
SlabShapeVertex | For Internal Use Only.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Position | The positon of the vertex.
VertexType | The type of the vertex.

See Also

SlabShapeVertex Class
Autodesk.Revit.Editor Namespace


SlabShapeVertex Constructor

[image]

Revit 2010 API
SlabShapeVertex Constructor
SlabShapeVertex Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabShapeVertex()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabShapeVertex()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabShapeVertex Class
Autodesk.Revit.Editor Namespace


SlabShapeVertex Methods

[image] [image]

Revit 2010 API
SlabShapeVertex Methods
SlabShapeVertex Class See Also Send Feedback

The SlabShapeVertex type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeVertex Class
Autodesk.Revit.Editor Namespace


SlabShapeVertex Properties

[image] [image]

Revit 2010 API
SlabShapeVertex Properties
SlabShapeVertex Class See Also Send Feedback

The SlabShapeVertex type exposes the following members.

Properties

Name | Description
Position | The positon of the vertex.
VertexType | The type of the vertex.

See Also

SlabShapeVertex Class
Autodesk.Revit.Editor Namespace


Position Property

[image]

Revit 2010 API
SlabShapeVertex..::.Position Property
SlabShapeVertex Class See Also Send Feedback
The positon of the vertex.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Position { get; }
Visual Basic (Declaration)
Public ReadOnly Property Position As XYZ
Visual C++
public:
property XYZ^ Position {
    XYZ^ get ();
}

See Also

SlabShapeVertex Class
Autodesk.Revit.Editor Namespace


VertexType Property

[image]

Revit 2010 API
SlabShapeVertex..::.VertexType Property
SlabShapeVertex Class See Also Send Feedback
The type of the vertex.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabShapeVertexType VertexType { get; }
Visual Basic (Declaration)
Public ReadOnly Property VertexType As SlabShapeVertexType
Visual C++
public:
property SlabShapeVertexType VertexType {
    SlabShapeVertexType get ();
}

See Also

SlabShapeVertex Class
Autodesk.Revit.Editor Namespace


SlabShapeVertexArray Class

[image]

Revit 2010 API
SlabShapeVertexArray Class
Members See Also Send Feedback
An array that can contain any number of vertices used in Slab Shape Editing.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SlabShapeVertexArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class SlabShapeVertexArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SlabShapeVertexArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Editor..::.SlabShapeVertexArray

See Also

SlabShapeVertexArray Members
Autodesk.Revit.Editor Namespace


SlabShapeVertexArray Members

[image] [image]

Revit 2010 API
SlabShapeVertexArray Members
SlabShapeVertexArray Class Constructors Methods Properties See Also Send Feedback

The SlabShapeVertexArray type exposes the following members.

Constructors

Name | Description
SlabShapeVertexArray | Initializes a new instance of the SlabShapeVertexArray class

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


SlabShapeVertexArray Constructor

[image]

Revit 2010 API
SlabShapeVertexArray Constructor
SlabShapeVertexArray Class See Also Send Feedback
Initializes a new instance of the SlabShapeVertexArray class

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabShapeVertexArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabShapeVertexArray()

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


SlabShapeVertexArray Methods

[image] [image]

Revit 2010 API
SlabShapeVertexArray Methods
SlabShapeVertexArray Class See Also Send Feedback

The SlabShapeVertexArray type exposes the following members.

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


Append Method

[image]

Revit 2010 API
SlabShapeVertexArray..::.Append Method
SlabShapeVertexArray Class See Also Send Feedback
Add the item to the end of the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    SlabShapeVertex item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As SlabShapeVertex _
)
Visual C++
public:
virtual void Append(
    SlabShapeVertex^ item
)

Parameters

item
Type: Autodesk.Revit.Editor..::.SlabShapeVertex
The item to be added.

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


Clear Method

[image]

Revit 2010 API
SlabShapeVertexArray..::.Clear Method
SlabShapeVertexArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


ForwardIterator Method

[image]

Revit 2010 API
SlabShapeVertexArray..::.ForwardIterator Method
SlabShapeVertexArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual SlabShapeVertexArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SlabShapeVertexArrayIterator
Visual C++
public:
virtual SlabShapeVertexArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


GetEnumerator Method

[image]

Revit 2010 API
SlabShapeVertexArray..::.GetEnumerator Method
SlabShapeVertexArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


Insert Method

[image]

Revit 2010 API
SlabShapeVertexArray..::.Insert Method
SlabShapeVertexArray Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    SlabShapeVertex item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As SlabShapeVertex, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    SlabShapeVertex^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Editor..::.SlabShapeVertex
The item to be inserted into the array.
index
Type: System..::.Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


ReverseIterator Method

[image]

Revit 2010 API
SlabShapeVertexArray..::.ReverseIterator Method
SlabShapeVertexArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual SlabShapeVertexArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SlabShapeVertexArrayIterator
Visual C++
public:
virtual SlabShapeVertexArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


SlabShapeVertexArray Properties

[image] [image]

Revit 2010 API
SlabShapeVertexArray Properties
SlabShapeVertexArray Class See Also Send Feedback

The SlabShapeVertexArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


IsEmpty Property

[image]

Revit 2010 API
SlabShapeVertexArray..::.IsEmpty Property
SlabShapeVertexArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


Item Property

[image]

Revit 2010 API
SlabShapeVertexArray..::.Item Property
SlabShapeVertexArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual SlabShapeVertex Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As SlabShapeVertex
Visual C++
public:
virtual property SlabShapeVertex^ Item[int index] {
    SlabShapeVertex^ get (int index);
    void set (int index, SlabShapeVertex^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


Size Property

[image]

Revit 2010 API
SlabShapeVertexArray..::.Size Property
SlabShapeVertexArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SlabShapeVertexArray Class
Autodesk.Revit.Editor Namespace


SlabShapeVertexArrayIterator Class

[image]

Revit 2010 API
SlabShapeVertexArrayIterator Class
Members See Also Send Feedback
An iterator to an array of vertices used for Slab Shape Editing.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class SlabShapeVertexArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class SlabShapeVertexArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SlabShapeVertexArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Editor..::.SlabShapeVertexArrayIterator

See Also

SlabShapeVertexArrayIterator Members
Autodesk.Revit.Editor Namespace


SlabShapeVertexArrayIterator Members

[image] [image]

Revit 2010 API
SlabShapeVertexArrayIterator Members
SlabShapeVertexArrayIterator Class Constructors Methods Properties See Also Send Feedback

The SlabShapeVertexArrayIterator type exposes the following members.

Constructors

Name | Description
SlabShapeVertexArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabShapeVertexArrayIterator Class
Autodesk.Revit.Editor Namespace


SlabShapeVertexArrayIterator Constructor

[image]

Revit 2010 API
SlabShapeVertexArrayIterator Constructor
SlabShapeVertexArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabShapeVertexArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabShapeVertexArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabShapeVertexArrayIterator Class
Autodesk.Revit.Editor Namespace


SlabShapeVertexArrayIterator Methods

[image] [image]

Revit 2010 API
SlabShapeVertexArrayIterator Methods
SlabShapeVertexArrayIterator Class See Also Send Feedback

The SlabShapeVertexArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeVertexArrayIterator Class
Autodesk.Revit.Editor Namespace


MoveNext Method

[image]

Revit 2010 API
SlabShapeVertexArrayIterator..::.MoveNext Method
SlabShapeVertexArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SlabShapeVertexArrayIterator Class
Autodesk.Revit.Editor Namespace


Reset Method

[image]

Revit 2010 API
SlabShapeVertexArrayIterator..::.Reset Method
SlabShapeVertexArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SlabShapeVertexArrayIterator Class
Autodesk.Revit.Editor Namespace


SlabShapeVertexArrayIterator Properties

[image] [image]

Revit 2010 API
SlabShapeVertexArrayIterator Properties
SlabShapeVertexArrayIterator Class See Also Send Feedback

The SlabShapeVertexArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabShapeVertexArrayIterator Class
Autodesk.Revit.Editor Namespace


Current Property

[image]

Revit 2010 API
SlabShapeVertexArrayIterator..::.Current Property
SlabShapeVertexArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SlabShapeVertexArrayIterator Class
Autodesk.Revit.Editor Namespace


Autodesk.Revit.Elements Namespace

[image]

Revit 2010 API
Autodesk.Revit.Elements Namespace
Send Feedback

Classes

Class | Description
Alignment | A locked alignment element in Autodesk Revit.
AnnotationSymbol | This object represents a symbol of the Generic Annotation.
Area | Provides access to the area topology in Autodesk Revit.
AreaLoad | An object that represents a force applied across an area.
AreaReinforcement | An object that represents an Area Reinforcement within the Autodesk Revit project.
AreaReinforcementCurve | An object that specifies the type of a floor in Autodesk Revit.
AreaTag | Provides access to the area topology in Autodesk Revit.
BaseArray | An abstract base class that represents an array within the Revit project.
BasePoint | Represents kinds of BasePoints.
BeamSystem | An object that represents a BeamSystem within the Autodesk Revit project.
Blend | A blend solid or void form.
BoundaryConditions | An object that represents a force applied across an area.
CeilingAndFloor | A base class that provides support for all ceiling and floor objects.
CombinableElement | An element that can be added to a geometry combination.
CombinableElementArray | An array that contains CombinableElement objects.
CombinableElementArrayIterator | An iterator to an CombinableElement array.
ContFooting | An object that represents a Continuous Footing within Autodesk Revit.
Control | A control in Autodesk Revit family document.
CurtainCell | Represents a CurtainCell within Autodesk Revit.
CurtainCellSet | A set that can contain any type of object.
CurtainCellSetIterator | An iterator to a set.
CurtainGrid | Represents a curtain grid element within Autodesk Revit.
CurtainGridLine | Represents a CurtainGridLine within Autodesk Revit.
CurtainGridSet | A set that can contain any type of object.
CurtainGridSetIterator | An iterator to a set.
CurtainSystem | Provides access to the CurtainSystem object in Autodesk Revit.
CurtainSystemBase | Provides access to the CurtainSystemBase object in Autodesk Revit.
CurveByPoints | A curve interpolating two or more points.
CurveByPointsArray |
CurveByPointsArrayIterator |
CurveElement |
DesignOption | An element that represents a design alternative.
DetailArc | Represents a DetailArc within Autodesk Revit.
DetailCurve |
DetailCurveArray | An array that can contain any type of object.
DetailCurveArrayIterator | An iterator to a array.
DetailEllipse | Represents a DetailEllipse within Autodesk Revit.
DetailLine | Represents a DetailLine within Autodesk Revit.
DetailNurbSpline | Represents a DetailNurbSpline within Autodesk Revit.
Dimension | An object that represents a dimension within the Revit project.
DividedSurface | An element that represents a mesh on another element's surface and a tile pattern built on that mesh.
DividedSurfaceData | An interface to the divided surfaces on an element.
Extrusion | A extrusion solid or void form.
ExtrusionRoof | Represents some kinds of Extrusion Roofs.
Family | The Family object is a Symbol that defines an entire family.
FamilyBase | A base class for all Family objects.
FamilyInstance | This object represents a single instance of a family type, such as a single I beam.
Fascia | An object that represents a fascia within the Autodesk Revit project.
FillPattern | Represents a fill pattern element within an Autodesk Revit project.
Floor | An object that represents a Floor within the Autodesk Revit project.
FootPrintRoof | Represents kinds of FootPrintRoofs.
Form | An object that represents a Form within the Autodesk Revit Massing Family.
gbXMLParamElem | An object that represents the gbXML Parameters within the Autodesk Revit project.
GenericForm | Provides access to the Generic Form model in Autodesk Revit.
GenericFormSet | A set that can contain any type of object.
GenericFormSetIterator | An iterator to a set.
GeomCombination | An element created by Join and Cut operations applied to combinable elements in an Autodesk Revit family document.
GeomCombinationSet | A set that contains GeomCombination objects.
GeomCombinationSetIterator | An iterator to a GeomCombination set.
GraphicsStyle | The graphics style instance in Autodesk Revit document.
Grid | Represents a single grid line within Autodesk Revit.
Group | This object represents a group of elements within the project.
GroupSet | An set that contains groups.
GroupSetIterator | An iterator to a group set.
Gutter | An object that represents a gutter within the Autodesk Revit project.
HostedSweep | An object that represents a roof within the Autodesk Revit project.
HostObject | A base class that provides support for all objects that can host other objects, such as a wall.
ImportInstance | An element created during an import operation in Autodesk Revit.
IndependentTag | Represents an IndependentTag within Autodesk Revit.
InsertableInstance | A base class that provides support insertable instances.
Instance | A base class for all instance objects.
LayoutRule | The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.
LayoutRuleClearSpacing | This class indicate the layout rule of a Beam System is Clear-Spacing.
LayoutRuleFixedDistance | This class indicate the layout rule of a Beam System is Fixed-Distance.
LayoutRuleFixedNumber | This class indicate the layout rule of a Beam System is Fixed-Number.
LayoutRuleMaximumSpacing | This class indicate the layout rule of a Beam System is Max-Spacing.
Level | Represents a Level line within Autodesk Revit.
LinearArray | An object that represents an Array created linearly within the Revit project.
LineLoad | An object that represents a force/moment applied in a linear manner.
LinePattern | Represents a line pattern element within an Autodesk Revit project.
LoadBase | The LoadBase object is the base class for all load objects within the Autodesk Revit API.
LoadCase | This object represents a load case within the project.
LoadCaseArray | An array that contains load case objects.
LoadCaseArrayIterator | An iterator to an load case array.
LoadCaseSet | A set that contains load cases.
LoadCaseSetIterator | An iterator to a load case set.
LoadCombination | An object that represents a load combination.
LoadCombinationArray | An array that can contain any type of object.
LoadCombinationArrayIterator | An iterator to a array.
LoadNature | A structural Load nature object.
LoadUsage | This object represents a load case within the project.
LoadUsageArray | An array that contains load usage objects.
LoadUsageArrayIterator | An iterator to an load usage array.
Material | Represents a material element within an Autodesk Revit project.
MaterialConcrete | Represents a concrete material element in an Autodesk Revit project.
MaterialGeneric | Represents a generic material element in an Autodesk Revit project.
MaterialOther | Represents a material element other than concrete, generic, wood and steel in an Autodesk Revit project.
MaterialSteel | Represents a steel material element in an Autodesk Revit project.
MaterialWood | Represents a wood material element in an Autodesk Revit project.
ModelArc | Represents a ModelArc within Autodesk Revit.
ModelCurve |
ModelCurveArrArray | An array that can contain any type of object.
ModelCurveArrArrayIterator | An iterator to a array.
ModelCurveArray | An array that contains model curves.
ModelCurveArrayIterator | An iterator to a model curve array.
ModelEllipse | Represents a ModelEllipse within Autodesk Revit.
ModelHermiteSpline | Represents a ModelHermiteSpline within Autodesk Revit.
ModelLine | Represents a ModelLine within Autodesk Revit.
ModelNurbSpline | Represents a ModelNurbSpline within Autodesk Revit.
ModelText | A model text element in an Autodesk Revit family document.
Mullion | Represents a CurtainGrid within Autodesk Revit.
Opening | An opening in an Autodesk Revit project or family document.
Panel | This object represents a curtain panel.
Path3d | Provides access to the Generic 3D path object in Autodesk Revit.
PathReinforcement | An object that represents an Path Reinforcement within the Autodesk Revit project.
Phase | Represents a phase in the life of a building.
PhaseArray | An array that contains phase objects.
PhaseArrayIterator | An iterator to a phase array.
PointElementReference | Base class for objects defining a way to constrain a ReferencePoint to one or more other objects in a document.
PointLoad | An object that represents a force/moment applied to a single point.
PointOnEdge | Define a ReferencePoint relative to a referenceable edge or curve on another element.
PointOnEdgeEdgeIntersection | Define a ReferencePoint at the intersection of two referenceable lines.
PointOnEdgeFaceIntersection | Define a ReferencePoint at the intersection of a referenceable edge or curve and a referenceable face.
PointOnFace | Define a ReferencePoint relative to a Face.
PointOnPlane | Define a ReferencePoint relative to a planar reference.
PrintSetting | Represents the Print Setup (File->Print Setup...) within Autodesk Revit.
ProjectInfo | An object that represents a Project Information within the Autodesk Revit project.
ProjectUnit | Provides access to the Project Unit... in Autodesk Revit.
PropertyLine | Represents kinds of PropertyLines.
RadialArray | An object that represents an Array created radially within the Revit project.
Rebar | An object that represents Rebar.
RebarHostData | Interface to rebar-specific data stored in each valid rebar host element. The cover parameters listed below are an alternative interface to the CoverType property. Each parameter simply gets or sets the cover setting associated with one or more particular faces of the host: CLEAR_COVER_EXTERIOR (walls only) CLEAR_COVER_INTERIOR (walls only) CLEAR_COVER_OTHER (all hosts except in-place families and stairs) CLEAR_COVER (in-place families and stairs) CLEAR_COVER_TOP (all hosts except walls, in-place families, and stairs) CLEAR_COVER_BOTTOM (all hosts except walls, in-place families, and stairs) RebarHostData can only be created by the factory function "getRebarHostData()" applied to an element that can be a rebar host.
ReferencePlane | Represents a reference plane of Autodesk Revit.
ReferencePoint | A reference point in an Autodesk Revit family.
ReferencePointArray |
ReferencePointArrayIterator |
Revolution | A revolution solid or void form.
RoofBase | Represents all kinds of Roofs.
Room | Provides access to the room topology in Autodesk Revit.
RoomTag | Provides access to the room tag in Autodesk Revit.
Sketch | Provides access to the Sketch in Autodesk Revit.
SketchBase | Provides access to the SketchBase in Autodesk Revit.
SketchPlane | Represents a sketch plane or work plane within Autodesk Revit.
SketchSet | A set that can contain any type of object.
SketchSetIterator | An iterator to a set.
SlabEdge | An object that represents a slab edge within the Autodesk Revit project.
Space | Provides access to the space topology in Autodesk Revit.
SpaceSet | A set that can contain any type of object.
SpaceSetIterator | An iterator to a set.
SpaceTag | Provides access to the space tag in Autodesk Revit.
SpacingRule | A rule for specifying a set of equidistant, parallel gridlines within a region.
SpotDimension | An object that represents a spot dimension within the Revit project.
Sweep | A sweep solid or void form.
SweptBlend | A swept blend solid or void form.
SymbolicCurve |
TextElement | Represents the TextElment.
TextNote | Provides access to the TextNote object in Autodesk Revit.
TopographySurface | An object that is used to represent a topography surface.
Truss | Represents all kinds of Trusses.
View | Base class for all types of views in Autodesk Revit.
View3D | A freely-oriented orthographic or perspective view of the model.
ViewDrafting | A drafting view allows the user to draw graphics without including them in the model.
ViewPlan | A plan represents for floor plan or ceiling plan.
ViewSection | A section view cuts through the model to expose its interior structure.
ViewSet | A set that contains views.
ViewSetIterator | An iterator to a view set.
ViewSheet | A sheet is a view used to prepare a finished printout. It contains other views and a titleblock.
ViewSheetSet | Represents all kinds of ViewSheetSets.
ViewSheetSets | A set that can contain any type of object.
ViewSheetSetsIterator | An iterator to a set.
Wall | Represents all of the different kinds of walls Autodesk Revit.
Zone | Provides access to the Zone Element in Autodesk Revit.

Structures

Structure | Description
GridNode | An identifier for a grid node location within a DividedSurface.

Enumerations

Enumeration | Description
AlignmentShape | An enumerate type listing two shapes of alignment that Autodesk Revit supports.
ControlShape | An enumerate type listing four shapes of control that Autodesk Revit supports.
ExportComplexity | An enumerate type listing all complexity of gbXML export.
GraphicsStyleType | Describes the type of graphics style.
ProfilePlaneLocation | Indicates the location of Sweep profile plane on the path curve.


Alignment Class

[image]

Revit 2010 API
Alignment Class
Members See Also Send Feedback
A locked alignment element in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Alignment : Element
Visual Basic (Declaration)
Public Class Alignment _
    Inherits Element
Visual C++
public ref class Alignment : public Element

Remarks

This class represents a locked alignment. You can unlock the alignment between two items by deleting this element.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Alignment

See Also

Alignment Members
Autodesk.Revit.Elements Namespace


Alignment Members

[image] [image]

Revit 2010 API
Alignment Members
Alignment Class Constructors Methods Properties See Also Send Feedback

The Alignment type exposes the following members.

Constructors

Name | Description
Alignment | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
References | The references to which the alignment is attached.
Shape | The alignment shape.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Alignment Class
Autodesk.Revit.Elements Namespace


Alignment Constructor

[image]

Revit 2010 API
Alignment Constructor
Alignment Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Alignment()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Alignment()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Alignment Class
Autodesk.Revit.Elements Namespace


Alignment Methods

[image] [image]

Revit 2010 API
Alignment Methods
Alignment Class See Also Send Feedback

The Alignment type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Alignment Class
Autodesk.Revit.Elements Namespace


Alignment Properties

[image] [image]

Revit 2010 API
Alignment Properties
Alignment Class See Also Send Feedback

The Alignment type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
References | The references to which the alignment is attached.
Shape | The alignment shape.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Alignment Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Alignment..::.Parameter Property
Alignment Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Alignment Class
Alignment Members
Autodesk.Revit.Elements Namespace


References Property

[image]

Revit 2010 API
Alignment..::.References Property
Alignment Class See Also Send Feedback
The references to which the alignment is attached.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferenceArray References { get; }
Visual Basic (Declaration)
Public ReadOnly Property References As ReferenceArray
Visual C++
public:
property ReferenceArray^ References {
    ReferenceArray^ get ();
}

See Also

Alignment Class
Autodesk.Revit.Elements Namespace


Shape Property

[image]

Revit 2010 API
Alignment..::.Shape Property
Alignment Class See Also Send Feedback
The alignment shape.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AlignmentShape Shape { get; }
Visual Basic (Declaration)
Public ReadOnly Property Shape As AlignmentShape
Visual C++
public:
property AlignmentShape Shape {
    AlignmentShape get ();
}

See Also

Alignment Class
Autodesk.Revit.Elements Namespace


AlignmentShape Enumeration

[image]

Revit 2010 API
AlignmentShape Enumeration
See Also Send Feedback
An enumerate type listing two shapes of alignment that Autodesk Revit supports.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum AlignmentShape
Visual Basic (Declaration)
Public Enumeration AlignmentShape
Visual C++
public enum class AlignmentShape

Members

Member name | Description
Linear | Linear shape alignment.
Arc | Arc shape alignment.

See Also

Autodesk.Revit.Elements Namespace


AnnotationSymbol Class

[image]

Revit 2010 API
AnnotationSymbol Class
Members See Also Send Feedback
This object represents a symbol of the Generic Annotation.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AnnotationSymbol : Element
Visual Basic (Declaration)
Public Class AnnotationSymbol _
    Inherits Element
Visual C++
public ref class AnnotationSymbol : public Element

Remarks

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.AnnotationSymbol

See Also

AnnotationSymbol Members
Autodesk.Revit.Elements Namespace


AnnotationSymbol Members

[image] [image]

Revit 2010 API
AnnotationSymbol Members
AnnotationSymbol Class Constructors Methods Properties See Also Send Feedback

The AnnotationSymbol type exposes the following members.

Constructors

Name | Description
AnnotationSymbol | For Internal Use Only.

Methods

Name | Description
addLeader | add a leader to this annotation symbol.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
duplicate | Duplicate this annotation symbol.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
removeLeader | remove a leader of this annotation symbol.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AnnotationSymbolType | The AnnotationSymbol style of this AnnotationSymbol.
AsFamilyInstance | This property is used to get family instance within project.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Leaders | Get all the leaders of this annotation symbol.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an instance within project. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AnnotationSymbol Class
Autodesk.Revit.Elements Namespace


AnnotationSymbol Constructor

[image]

Revit 2010 API
AnnotationSymbol Constructor
AnnotationSymbol Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnnotationSymbol()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnnotationSymbol()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnnotationSymbol Class
Autodesk.Revit.Elements Namespace


AnnotationSymbol Methods

[image] [image]

Revit 2010 API
AnnotationSymbol Methods
AnnotationSymbol Class See Also Send Feedback

The AnnotationSymbol type exposes the following members.

Methods

Name | Description
addLeader | add a leader to this annotation symbol.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
duplicate | Duplicate this annotation symbol.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
removeLeader | remove a leader of this annotation symbol.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnnotationSymbol Class
Autodesk.Revit.Elements Namespace


addLeader Method

[image]

Revit 2010 API
AnnotationSymbol..::.addLeader Method
AnnotationSymbol Class See Also Send Feedback
add a leader to this annotation symbol.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void addLeader()
Visual Basic (Declaration)
Public Sub addLeader
Visual C++
public:
void addLeader()

See Also

AnnotationSymbol Class
Autodesk.Revit.Elements Namespace


duplicate Method

[image]

Revit 2010 API
AnnotationSymbol..::.duplicate Method
AnnotationSymbol Class See Also Send Feedback
Duplicate this annotation symbol.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnnotationSymbol duplicate()
Visual Basic (Declaration)
Public Function duplicate As AnnotationSymbol
Visual C++
public:
AnnotationSymbol^ duplicate()

Return Value

Pointer to the new annotation symbol.

See Also

AnnotationSymbol Class
Autodesk.Revit.Elements Namespace


removeLeader Method

[image]

Revit 2010 API
AnnotationSymbol..::.removeLeader Method
AnnotationSymbol Class See Also Send Feedback
remove a leader of this annotation symbol.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void removeLeader()
Visual Basic (Declaration)
Public Sub removeLeader
Visual C++
public:
void removeLeader()

See Also

AnnotationSymbol Class
Autodesk.Revit.Elements Namespace


AnnotationSymbol Properties

[image] [image]

Revit 2010 API
AnnotationSymbol Properties
AnnotationSymbol Class See Also Send Feedback

The AnnotationSymbol type exposes the following members.

Properties

Name | Description
AnnotationSymbolType | The AnnotationSymbol style of this AnnotationSymbol.
AsFamilyInstance | This property is used to get family instance within project.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Leaders | Get all the leaders of this annotation symbol.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an instance within project. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AnnotationSymbol Class
Autodesk.Revit.Elements Namespace


AnnotationSymbolType Property

[image]

Revit 2010 API
AnnotationSymbol..::.AnnotationSymbolType Property
AnnotationSymbol Class See Also Send Feedback
The AnnotationSymbol style of this AnnotationSymbol.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnnotationSymbolType AnnotationSymbolType { get; set; }
Visual Basic (Declaration)
Public Property AnnotationSymbolType As AnnotationSymbolType
Visual C++
public:
property AnnotationSymbolType^ AnnotationSymbolType {
    AnnotationSymbolType^ get ();
    void set (AnnotationSymbolType^ value);
}

Remarks

The AnnotationSymbolType property can be used to retrieve the kind of the wall. This property can also be used to change the type of an annotation by setting it to a different type. All the annotation symbol types in the project can be found using the Document.AnnotationSymbolTypes property.

See Also

AnnotationSymbol Class
Autodesk.Revit.Elements Namespace


AsFamilyInstance Property

[image]

Revit 2010 API
AnnotationSymbol..::.AsFamilyInstance Property
AnnotationSymbol Class See Also Send Feedback
This property is used to get family instance within project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance AsFamilyInstance { get; }
Visual Basic (Declaration)
Public ReadOnly Property AsFamilyInstance As FamilyInstance
Visual C++
public:
property FamilyInstance^ AsFamilyInstance {
    FamilyInstance^ get ();
}

Remarks

The AsFamilyInstance property returns an family instance that can be used to stand for this annotation within the project.

See Also

AnnotationSymbol Class
Autodesk.Revit.Elements Namespace


Leaders Property

[image]

Revit 2010 API
AnnotationSymbol..::.Leaders Property
AnnotationSymbol Class See Also Send Feedback
Get all the leaders of this annotation symbol.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LeaderArray Leaders { get; }
Visual Basic (Declaration)
Public ReadOnly Property Leaders As LeaderArray
Visual C++
public:
property LeaderArray^ Leaders {
    LeaderArray^ get ();
}

Return Value

The Leaders property returns a leader array that contains all the leaders of this annotation symbol.

See Also

AnnotationSymbol Class
Autodesk.Revit.Elements Namespace


Location Property

[image]

Revit 2010 API
AnnotationSymbol..::.Location Property
AnnotationSymbol Class See Also Send Feedback
This property is used to find the physical location of an instance within project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

The Location property returns an object that can be used to find the location of an instance within the project.

See Also

AnnotationSymbol Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
AnnotationSymbol..::.Parameter Property
AnnotationSymbol Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AnnotationSymbol Class
AnnotationSymbol Members
Autodesk.Revit.Elements Namespace


Area Class

[image]

Revit 2010 API
Area Class
Members See Also Send Feedback
Provides access to the area topology in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Area : Element
Visual Basic (Declaration)
Public Class Area _
    Inherits Element
Visual C++
public ref class Area : public Element

Remarks

The area object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Area

See Also

Area Members
Autodesk.Revit.Elements Namespace


Area Members

[image] [image]

Revit 2010 API
Area Members
Area Class Constructors Methods Properties See Also Send Feedback

The Area type exposes the following members.

Constructors

Name | Description
Area | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AreaScheme | The area scheme.
Boundary | Returns the boundary of the area.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | get a location point object. The point within the location object should be get/set. This is the location of the area within the level. The Z location should be the elevation of the level and not changeable. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get or Set the Name of the area. (Overrides Element..::.Name.)
Number | Get or Set the Name of the Number.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Area Class
Autodesk.Revit.Elements Namespace


Area Constructor

[image]

Revit 2010 API
Area Constructor
Area Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Area()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Area()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Area Class
Autodesk.Revit.Elements Namespace


Area Methods

[image] [image]

Revit 2010 API
Area Methods
Area Class See Also Send Feedback

The Area type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Area Class
Autodesk.Revit.Elements Namespace


Area Properties

[image] [image]

Revit 2010 API
Area Properties
Area Class See Also Send Feedback

The Area type exposes the following members.

Properties

Name | Description
AreaScheme | The area scheme.
Boundary | Returns the boundary of the area.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | get a location point object. The point within the location object should be get/set. This is the location of the area within the level. The Z location should be the elevation of the level and not changeable. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get or Set the Name of the area. (Overrides Element..::.Name.)
Number | Get or Set the Name of the Number.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Area Class
Autodesk.Revit.Elements Namespace


AreaScheme Property

[image]

Revit 2010 API
Area..::.AreaScheme Property
Area Class See Also Send Feedback
The area scheme.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaScheme AreaScheme { get; }
Visual Basic (Declaration)
Public ReadOnly Property AreaScheme As AreaScheme
Visual C++
public:
property AreaScheme^ AreaScheme {
    AreaScheme^ get ();
}

See Also

Area Class
Autodesk.Revit.Elements Namespace


Boundary Property

[image]

Revit 2010 API
Area..::.Boundary Property
Area Class See Also Send Feedback
Returns the boundary of the area.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundarySegmentArrayArray Boundary { get; }
Visual Basic (Declaration)
Public ReadOnly Property Boundary As BoundarySegmentArrayArray
Visual C++
public:
property BoundarySegmentArrayArray^ Boundary {
    BoundarySegmentArrayArray^ get ();
}

Remarks

This property is used to retrieve the segments that constitute the boundary of the area. Each area may have several regions, each of which have several segments hence the data is returned in the form of an array of boundary segment arrays. See the Area.BoundarySegment object for more details about the segments that make up the area topology.

See Also

Area Class
Autodesk.Revit.Elements Namespace


Location Property

[image]

Revit 2010 API
Area..::.Location Property
Area Class See Also Send Feedback
get a location point object. The point within the location object should be get/set. This is the location of the area within the level. The Z location should be the elevation of the level and not changeable.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

See Also

Area Class
Autodesk.Revit.Elements Namespace


Name Property

[image]

Revit 2010 API
Area..::.Name Property
Area Class See Also Send Feedback
Get or Set the Name of the area.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

This property is used to get or set the Name of the area.

See Also

Area Class
Autodesk.Revit.Elements Namespace


Number Property

[image]

Revit 2010 API
Area..::.Number Property
Area Class See Also Send Feedback
Get or Set the Name of the Number.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Number { get; set; }
Visual Basic (Declaration)
Public Property Number As String
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Number of the area.

See Also

Area Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Area..::.Parameter Property
Area Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Area Class
Area Members
Autodesk.Revit.Elements Namespace


AreaLoad Class

[image]

Revit 2010 API
AreaLoad Class
Members Example See Also Send Feedback
An object that represents a force applied across an area.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AreaLoad : LoadBase
Visual Basic (Declaration)
Public Class AreaLoad _
    Inherits LoadBase
Visual C++
public ref class AreaLoad : public LoadBase

Examples

CopyC#
public void GetInfo_AreaLoad(AreaLoad areaLoad)
{
    string message = "AreaLoad Force : ";
    // Get areaload force1 position
    message += "\nAreaLoad Force1 position :(" + areaLoad.Force1.X + ", "
        + areaLoad.Force1.Y + ", " + areaLoad.Force1.Z + ")";
    // Get areaload force2 position
    message += "\nAreaLoad Force2 position :(" + areaLoad.Force2.X + ", "
        + areaLoad.Force2.Y + ", " + areaLoad.Force2.Z + ")";
    // Get areaload force3 position
    message += "\nAreaLoad Force3 position :(" + areaLoad.Force3.X + ", "
        + areaLoad.Force3.Y + ", " + areaLoad.Force3.Z + ")";

    // Get loop number
    message += "\nLoop number is :" + areaLoad.NumLoops;
    for (int i = 0; i < areaLoad.NumLoops; i++)
    {
        // Get curve number
        message += "\nCurve number is : " + areaLoad.get_NumCurves(i);
        for (int j = 0; j < areaLoad.get_NumCurves(i); j++)
        {
            Autodesk.Revit.Geometry.Curve curve = areaLoad.get_Curve(i, j);
            // Get curve start point
            message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
                + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
            // Get curve end point
            message += "; Curve end point:(" + curve.get_EndPoint(1).X + ", "
                + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
        }
    }

    // Get ref points information
    for (int k = 0; k < areaLoad.NumRefPoints; k++)
    {
        // Get areaload Ref point
        message += "\nAreaLoad Ref point :(" + areaLoad.get_RefPoint(k).X + ", "
            + areaLoad.get_RefPoint(k).Y + ", " + areaLoad.get_RefPoint(k).Z + ")";
    }
    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_AreaLoad(ByVal areaLoad As Autodesk.Revit.Elements.AreaLoad)
    Dim message As String = "AreaLoad Force : "
    ' Get areaload force1 position
    message += ((vbLf & "AreaLoad Force1 position :(" & areaLoad.Force1.X & ", ") + areaLoad.Force1.Y & ", ") + areaLoad.Force1.Z & ")"
    ' Get areaload force2 position
    message += ((vbLf & "AreaLoad Force2 position :(" & areaLoad.Force2.X & ", ") + areaLoad.Force2.Y & ", ") + areaLoad.Force2.Z & ")"
    ' Get areaload force3 position
    message += ((vbLf & "AreaLoad Force3 position :(" & areaLoad.Force3.X & ", ") + areaLoad.Force3.Y & ", ") + areaLoad.Force3.Z & ")"

    ' Get loop number
    message += vbLf & "Loop number is :" & areaLoad.NumLoops
    For i As Integer = 0 To areaLoad.NumLoops - 1
        ' Get curve number
        message += vbLf & "Curve number is : " & areaLoad.NumCurves(i)
        For j As Integer = 0 To areaLoad.NumCurves(i) - 1
            Dim curve As Autodesk.Revit.Geometry.Curve = areaLoad.Curve(i, j)
            ' Get curve start point
            message += ((vbLf & "Curve start point:(" & curve.EndPoint(0).X & ", ") + curve.EndPoint(0).Y & ", ") + curve.EndPoint(0).Z & ")"
            ' Get curve end point
            message += (("; Curve end point:(" & curve.EndPoint(1).X & ", ") + curve.EndPoint(1).Y & ", ") + curve.EndPoint(1).Z & ")"
        Next
    Next

    ' Get ref points information
    For k As Integer = 0 To areaLoad.NumRefPoints - 1
        ' Get areaload Ref point
        message += ((vbLf & "AreaLoad Ref point :(" & areaLoad.RefPoint(k).X & ", ") + areaLoad.RefPoint(k).Y & ", ") + areaLoad.RefPoint(k).Z & ")"
    Next
    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.LoadBase
Autodesk.Revit.Elements..::.AreaLoad

See Also

AreaLoad Members
Autodesk.Revit.Elements Namespace


AreaLoad Members

[image] [image]

Revit 2010 API
AreaLoad Members
AreaLoad Class Constructors Methods Properties See Also Send Feedback

The AreaLoad type exposes the following members.

Constructors

Name | Description
AreaLoad | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | Returns the geometric curve within a geometric loop that defines the area.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Force | Returns the three dimensional force applied to one of the points for the area load.
Force1 | Returns the three dimensional force applied to the point 1 of the area load.
Force2 | Returns the three dimensional force applied to the point 2 of the area load.
Force3 | Returns the three dimensional force applied to the point 3 of the area load.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HostElement | The host element for the load. (Inherited from LoadBase.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
NumCurves | Returns the number of curves within a geometric loop that defines the area.
NumLoops | Returns the number of geometric curve loops that define the area.
NumRefPoints | Returns the total number of reference points for the area load.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RefPoint | Retrieve the physical location of the reference point.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


AreaLoad Constructor

[image]

Revit 2010 API
AreaLoad Constructor
AreaLoad Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaLoad()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaLoad()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


AreaLoad Methods

[image] [image]

Revit 2010 API
AreaLoad Methods
AreaLoad Class See Also Send Feedback

The AreaLoad type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


AreaLoad Properties

[image] [image]

Revit 2010 API
AreaLoad Properties
AreaLoad Class See Also Send Feedback

The AreaLoad type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | Returns the geometric curve within a geometric loop that defines the area.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Force | Returns the three dimensional force applied to one of the points for the area load.
Force1 | Returns the three dimensional force applied to the point 1 of the area load.
Force2 | Returns the three dimensional force applied to the point 2 of the area load.
Force3 | Returns the three dimensional force applied to the point 3 of the area load.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HostElement | The host element for the load. (Inherited from LoadBase.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
NumCurves | Returns the number of curves within a geometric loop that defines the area.
NumLoops | Returns the number of geometric curve loops that define the area.
NumRefPoints | Returns the total number of reference points for the area load.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RefPoint | Retrieve the physical location of the reference point.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


Curve Property

[image]

Revit 2010 API
AreaLoad..::.Curve Property
AreaLoad Class See Also Send Feedback
Returns the geometric curve within a geometric loop that defines the area.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve Curve[
    int loopIndex,
    int curveIndex
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve ( _
    loopIndex As Integer, _
    curveIndex As Integer _
) As Curve
Visual C++
public:
property Curve^ Curve[int loopIndex, int curveIndex] {
    Curve^ get (int loopIndex, int curveIndex);
}

Parameters

loopIndex
Type: System..::.Int32
The index of the geometric loop.
curveIndex
Type: System..::.Int32
The index curve within the loop.

Remarks

The loop index should be between 0 and less than NumLoops. The curve index should be between 0 and less than NumCurves(loopIndex).

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


Force Property

[image]

Revit 2010 API
AreaLoad..::.Force Property
AreaLoad Class See Also Send Feedback
Returns the three dimensional force applied to one of the points for the area load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Force[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Force ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Force[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32
The index of the point to return.

Remarks

The index should be between 0 and less than NumRefPoints. The force is measured in Kg / Sec*Feet.

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


Force1 Property

[image]

Revit 2010 API
AreaLoad..::.Force1 Property
AreaLoad Class See Also Send Feedback
Returns the three dimensional force applied to the point 1 of the area load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Force1 { get; }
Visual Basic (Declaration)
Public ReadOnly Property Force1 As XYZ
Visual C++
public:
property XYZ^ Force1 {
    XYZ^ get ();
}

Remarks

The force is measured in Kg / Sec*Feet.

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


Force2 Property

[image]

Revit 2010 API
AreaLoad..::.Force2 Property
AreaLoad Class See Also Send Feedback
Returns the three dimensional force applied to the point 2 of the area load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Force2 { get; }
Visual Basic (Declaration)
Public ReadOnly Property Force2 As XYZ
Visual C++
public:
property XYZ^ Force2 {
    XYZ^ get ();
}

Remarks

The force is measured in Kg / Sec*Feet.

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


Force3 Property

[image]

Revit 2010 API
AreaLoad..::.Force3 Property
AreaLoad Class See Also Send Feedback
Returns the three dimensional force applied to the point 3 of the area load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Force3 { get; }
Visual Basic (Declaration)
Public ReadOnly Property Force3 As XYZ
Visual C++
public:
property XYZ^ Force3 {
    XYZ^ get ();
}

Remarks

The force is measured in Kg / Sec*Feet.

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


NumCurves Property

[image]

Revit 2010 API
AreaLoad..::.NumCurves Property
AreaLoad Class See Also Send Feedback
Returns the number of curves within a geometric loop that defines the area.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NumCurves[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumCurves ( _
    index As Integer _
) As Integer
Visual C++
public:
property int NumCurves[int index] {
    int get (int index);
}

Parameters

index
Type: System..::.Int32
The index of the geometric loop.

Remarks

The index should be between 0 and less than NumLoops.

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


NumLoops Property

[image]

Revit 2010 API
AreaLoad..::.NumLoops Property
AreaLoad Class See Also Send Feedback
Returns the number of geometric curve loops that define the area.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NumLoops { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumLoops As Integer
Visual C++
public:
property int NumLoops {
    int get ();
}

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


NumRefPoints Property

[image]

Revit 2010 API
AreaLoad..::.NumRefPoints Property
AreaLoad Class See Also Send Feedback
Returns the total number of reference points for the area load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NumRefPoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumRefPoints As Integer
Visual C++
public:
property int NumRefPoints {
    int get ();
}

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
AreaLoad..::.Parameter Property
AreaLoad Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AreaLoad Class
AreaLoad Members
Autodesk.Revit.Elements Namespace


RefPoint Property

[image]

Revit 2010 API
AreaLoad..::.RefPoint Property
AreaLoad Class See Also Send Feedback
Retrieve the physical location of the reference point.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ RefPoint[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property RefPoint ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ RefPoint[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32
The index of the point to return.

Remarks

The index should be between 0 and less than NumRefPoints.

See Also

AreaLoad Class
Autodesk.Revit.Elements Namespace


AreaReinforcement Class

[image]

Revit 2010 API
AreaReinforcement Class
Members Example See Also Send Feedback
An object that represents an Area Reinforcement within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AreaReinforcement : Element
Visual Basic (Declaration)
Public Class AreaReinforcement _
    Inherits Element
Visual C++
public ref class AreaReinforcement : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Area Reinforcement element is available only in the Autodesk Revit Structure product.

Examples

CopyC#
public void GetInfo_AreaReinforcement(AreaReinforcement areaReinforcement)
{
    string message = "AreaReinforcement : ";

    // Show the AreaReinforcement Type information
    //message += "\nType : " + areaReinforcement.AreaReinforcementType.Name;

    // Show the AreaReinforcement bar information
    message += "\nNumber of distinct bar shapes : " + areaReinforcement.NumBarDescriptions;

    for (int i = 0; i < areaReinforcement.NumBarDescriptions; i++)
    {
        message += "\nBar Description " + i;
        message += "\n\tBar count : " +
                          areaReinforcement.get_BarDescription(i).Count;
        message += "\n\tBar type name : " +
                          areaReinforcement.get_BarDescription(i).BarType.Name;
        message += "\n\tBar layer index : " +
                          areaReinforcement.get_BarDescription(i).Layer;
        message += "\n\tBar length : " +
                          areaReinforcement.get_BarDescription(i).Length;
    }

    // Show the AreaReinforcement Curves information
    message += "\nArea Reinforcement has " + areaReinforcement.Curves.Size + " boundary curves.";

    foreach (Autodesk.Revit.Element ii in areaReinforcement.Curves)
    {
        AreaReinforcementCurve reinCurve = ii as AreaReinforcementCurve;
        if (null == reinCurve)
        {
            continue;
        }
        Curve curve = reinCurve.Curve; // get the location curve
        XYZ start = curve.get_EndPoint(0);  // get the start point of the curve
        XYZ end = curve.get_EndPoint(1);    // get the end point of the curve
        message += "\nCurve: Start point (" + start.X + ", " + start.Y + ", " + start.Z + ")";
        message += "\n       End point (" + end.X + ", " + end.Y + ", " + end.Z + ")";
    }

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_AreaReinforcement(ByVal areaReinforcement As AreaReinforcement)
    Dim message As String = "AreaReinforcement : "

    ' Show the AreaReinforcement Type information
    'message += "\nType : " + areaReinforcement.AreaReinforcementType.Name;

    ' Show the AreaReinforcement bar information
    message += vbLf & "Number of distinct bar shapes : " & areaReinforcement.NumBarDescriptions

    For i As Integer = 0 To areaReinforcement.NumBarDescriptions - 1
        message += vbLf & "Bar Description " & i
        message += vbLf & vbTab & "Bar count : " & areaReinforcement.BarDescription(i).Count
        message += vbLf & vbTab & "Bar type name : " & areaReinforcement.BarDescription(i).BarType.Name
        message += vbLf & vbTab & "Bar layer index : " & areaReinforcement.BarDescription(i).Layer
        message += vbLf & vbTab & "Bar length : " & areaReinforcement.BarDescription(i).Length
    Next

    ' Show the AreaReinforcement Curves information
    message += vbLf & "Area Reinforcement has " & areaReinforcement.Curves.Size & " boundary curves."

    For Each ii As Autodesk.Revit.Element In areaReinforcement.Curves
        Dim reinCurve As AreaReinforcementCurve = TryCast(ii, AreaReinforcementCurve)
        If reinCurve Is Nothing Then
            Continue For
        End If
        Dim curve As Curve = reinCurve.Curve
        ' get the location curve
        Dim start As Autodesk.Revit.Geometry.XYZ = curve.EndPoint(0)
        ' get the start point of the curve
        Dim [end] As Autodesk.Revit.Geometry.XYZ = curve.EndPoint(1)
        ' get the end point of the curve
        message += ((vbLf & "Curve: Start point (" & start.X & ", ") + start.Y & ", ") + start.Z & ")"
        message += ((vbLf & " End point (" & [end].X & ", ") + [end].Y & ", ") + [end].Z & ")"
    Next

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.AreaReinforcement

See Also

AreaReinforcement Members
Autodesk.Revit.Elements Namespace


AreaReinforcement Members

[image] [image]

Revit 2010 API
AreaReinforcement Members
AreaReinforcement Class Constructors Methods Properties See Also Send Feedback

The AreaReinforcement type exposes the following members.

Constructors

Name | Description
AreaReinforcement | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AreaReinforcementType | Retrieves the type of the Area Reinforcement.
BarDescription | Retrieves the Bar Table property of an Area Reinforcement element.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curves | Retrieves the array of curves forming the boundary of the Area Reinforcement.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Direction | Retrieve or change the Major Direction of the Area Reinforcement.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
NumBarDescriptions | Retrieves the number of distinct bar shapes.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaReinforcement Class
Autodesk.Revit.Elements Namespace


AreaReinforcement Constructor

[image]

Revit 2010 API
AreaReinforcement Constructor
AreaReinforcement Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaReinforcement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaReinforcement()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaReinforcement Class
Autodesk.Revit.Elements Namespace


AreaReinforcement Methods

[image] [image]

Revit 2010 API
AreaReinforcement Methods
AreaReinforcement Class See Also Send Feedback

The AreaReinforcement type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaReinforcement Class
Autodesk.Revit.Elements Namespace


AreaReinforcement Properties

[image] [image]

Revit 2010 API
AreaReinforcement Properties
AreaReinforcement Class See Also Send Feedback

The AreaReinforcement type exposes the following members.

Properties

Name | Description
AreaReinforcementType | Retrieves the type of the Area Reinforcement.
BarDescription | Retrieves the Bar Table property of an Area Reinforcement element.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curves | Retrieves the array of curves forming the boundary of the Area Reinforcement.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Direction | Retrieve or change the Major Direction of the Area Reinforcement.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
NumBarDescriptions | Retrieves the number of distinct bar shapes.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaReinforcement Class
Autodesk.Revit.Elements Namespace


AreaReinforcementType Property

[image]

Revit 2010 API
AreaReinforcement..::.AreaReinforcementType Property
AreaReinforcement Class See Also Send Feedback
Retrieves the type of the Area Reinforcement.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaReinforcementType AreaReinforcementType { get; }
Visual Basic (Declaration)
Public ReadOnly Property AreaReinforcementType As AreaReinforcementType
Visual C++
public:
property AreaReinforcementType^ AreaReinforcementType {
    AreaReinforcementType^ get ();
}

See Also

AreaReinforcement Class
Autodesk.Revit.Elements Namespace


BarDescription Property

[image]

Revit 2010 API
AreaReinforcement..::.BarDescription Property
AreaReinforcement Class See Also Send Feedback
Retrieves the Bar Table property of an Area Reinforcement element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BarDescription BarDescription[
    int idx
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarDescription ( _
    idx As Integer _
) As BarDescription
Visual C++
public:
property BarDescription^ BarDescription[int idx] {
    BarDescription^ get (int idx);
}

Parameters

idx
Type: System..::.Int32
Index of a Bar Description.

See Also

AreaReinforcement Class
Autodesk.Revit.Elements Namespace


Curves Property

[image]

Revit 2010 API
AreaReinforcement..::.Curves Property
AreaReinforcement Class See Also Send Feedback
Retrieves the array of curves forming the boundary of the Area Reinforcement.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementArray Curves { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curves As ElementArray
Visual C++
public:
property ElementArray^ Curves {
    ElementArray^ get ();
}

Remarks

Each element in the array is of type AreaReinforcementCurve. Each element has a Curve property to retrieve the geometric curve, together with some Parameters allowing the developer to override the clear cover side, hook type, and hook direction of each layer of bars terminating at the curve.

See Also

AreaReinforcement Class
Autodesk.Revit.Elements Namespace


Direction Property

[image]

Revit 2010 API
AreaReinforcement..::.Direction Property
AreaReinforcement Class See Also Send Feedback
Retrieve or change the Major Direction of the Area Reinforcement.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Direction { get; }
Visual Basic (Declaration)
Public ReadOnly Property Direction As XYZ
Visual C++
public:
property XYZ^ Direction {
    XYZ^ get ();
}

See Also

AreaReinforcement Class
Autodesk.Revit.Elements Namespace


NumBarDescriptions Property

[image]

Revit 2010 API
AreaReinforcement..::.NumBarDescriptions Property
AreaReinforcement Class See Also Send Feedback
Retrieves the number of distinct bar shapes.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NumBarDescriptions { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumBarDescriptions As Integer
Visual C++
public:
property int NumBarDescriptions {
    int get ();
}

See Also

AreaReinforcement Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
AreaReinforcement..::.Parameter Property
AreaReinforcement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AreaReinforcement Class
AreaReinforcement Members
Autodesk.Revit.Elements Namespace


AreaReinforcementCurve Class

[image]

Revit 2010 API
AreaReinforcementCurve Class
Members Example See Also Send Feedback
An object that specifies the type of a floor in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AreaReinforcementCurve : Element
Visual Basic (Declaration)
Public Class AreaReinforcementCurve _
    Inherits Element
Visual C++
public ref class AreaReinforcementCurve : public Element

Remarks

The structural layers of the floor can be accessed via this object.

Examples

CopyC#
public void GetInfo_AreaReinforcementCurve(AreaReinforcement areaReinforcement)
{
    string message = "Area Reinforcement Curves : ";

    // Get area reinforcement curves by iterating the Curves property
    foreach (Element ii in areaReinforcement.Curves)
    {
        AreaReinforcementCurve areaReinforcementCurve = ii as AreaReinforcementCurve;
        if (null == areaReinforcementCurve)
        {
            continue;
        }
        Autodesk.Revit.Geometry.Curve curve = areaReinforcementCurve.Curve;

        // Get curve start point
        message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
                       + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        // Get curve end point
        message += "\nCurve end point:(" + curve.get_EndPoint(1).X + ", "
                       + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
    }

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_AreaReinforcementCurve(ByVal areaReinforcement As AreaReinforcement)
    Dim message As String = "Area Reinforcement Curves : "

    ' Get area reinforcement curves by iterating the Curves property
    For Each ii As Autodesk.Revit.Element In areaReinforcement.Curves
        Dim areaReinforcementCurve As AreaReinforcementCurve = TryCast(ii, AreaReinforcementCurve)
        If areaReinforcementCurve Is Nothing Then
            Continue For
        End If
        Dim curve As Autodesk.Revit.Geometry.Curve = areaReinforcementCurve.Curve

        ' Get curve start point
        message += ((vbLf & "Curve start point:(" & curve.EndPoint(0).X & ", ") + curve.EndPoint(0).Y & ", ") + curve.EndPoint(0).Z & ")"
        ' Get curve end point
        message += ((vbLf & "Curve end point:(" & curve.EndPoint(1).X & ", ") + curve.EndPoint(1).Y & ", ") + curve.EndPoint(1).Z & ")"
    Next

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.AreaReinforcementCurve

See Also

AreaReinforcementCurve Members
Autodesk.Revit.Elements Namespace


AreaReinforcementCurve Members

[image] [image]

Revit 2010 API
AreaReinforcementCurve Members
AreaReinforcementCurve Class Constructors Methods Properties See Also Send Feedback

The AreaReinforcementCurve type exposes the following members.

Constructors

Name | Description
AreaReinforcementCurve | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | Returns the 3D curve forming part of the boundary of an Area Reinforcement element.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaReinforcementCurve Class
Autodesk.Revit.Elements Namespace


AreaReinforcementCurve Constructor

[image]

Revit 2010 API
AreaReinforcementCurve Constructor
AreaReinforcementCurve Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaReinforcementCurve()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaReinforcementCurve()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaReinforcementCurve Class
Autodesk.Revit.Elements Namespace


AreaReinforcementCurve Methods

[image] [image]

Revit 2010 API
AreaReinforcementCurve Methods
AreaReinforcementCurve Class See Also Send Feedback

The AreaReinforcementCurve type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaReinforcementCurve Class
Autodesk.Revit.Elements Namespace


AreaReinforcementCurve Properties

[image] [image]

Revit 2010 API
AreaReinforcementCurve Properties
AreaReinforcementCurve Class See Also Send Feedback

The AreaReinforcementCurve type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | Returns the 3D curve forming part of the boundary of an Area Reinforcement element.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaReinforcementCurve Class
Autodesk.Revit.Elements Namespace


Curve Property

[image]

Revit 2010 API
AreaReinforcementCurve..::.Curve Property
AreaReinforcementCurve Class See Also Send Feedback
Returns the 3D curve forming part of the boundary of an Area Reinforcement element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

AreaReinforcementCurve Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
AreaReinforcementCurve..::.Parameter Property
AreaReinforcementCurve Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AreaReinforcementCurve Class
AreaReinforcementCurve Members
Autodesk.Revit.Elements Namespace


AreaTag Class

[image]

Revit 2010 API
AreaTag Class
Members See Also Send Feedback
Provides access to the area topology in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AreaTag : Element
Visual Basic (Declaration)
Public Class AreaTag _
    Inherits Element
Visual C++
public ref class AreaTag : public Element

Remarks

The areaTag object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.AreaTag

See Also

AreaTag Members
Autodesk.Revit.Elements Namespace


AreaTag Members

[image] [image]

Revit 2010 API
AreaTag Members
AreaTag Class Constructors Methods Properties See Also Send Feedback

The AreaTag type exposes the following members.

Constructors

Name | Description
AreaTag | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Area | Returns the area that the tag is associated with.
AreaTagType | get/set the type.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Leader | get/set the display attribute of Leader.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | get a location point object. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Retrieve or Change the name associated with the AreaTag. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
View | Returns the view in which the tag was place.

See Also

AreaTag Class
Autodesk.Revit.Elements Namespace


AreaTag Constructor

[image]

Revit 2010 API
AreaTag Constructor
AreaTag Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaTag()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaTag()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaTag Class
Autodesk.Revit.Elements Namespace


AreaTag Methods

[image] [image]

Revit 2010 API
AreaTag Methods
AreaTag Class See Also Send Feedback

The AreaTag type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaTag Class
Autodesk.Revit.Elements Namespace


AreaTag Properties

[image] [image]

Revit 2010 API
AreaTag Properties
AreaTag Class See Also Send Feedback

The AreaTag type exposes the following members.

Properties

Name | Description
Area | Returns the area that the tag is associated with.
AreaTagType | get/set the type.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Leader | get/set the display attribute of Leader.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | get a location point object. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Retrieve or Change the name associated with the AreaTag. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
View | Returns the view in which the tag was place.

See Also

AreaTag Class
Autodesk.Revit.Elements Namespace


Area Property

[image]

Revit 2010 API
AreaTag..::.Area Property
AreaTag Class See Also Send Feedback
Returns the area that the tag is associated with.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Area Area { get; }
Visual Basic (Declaration)
Public ReadOnly Property Area As Area
Visual C++
public:
property Area^ Area {
    Area^ get ();
}

Remarks

get the area that the tag is associated with

See Also

AreaTag Class
Autodesk.Revit.Elements Namespace


AreaTagType Property

[image]

Revit 2010 API
AreaTag..::.AreaTagType Property
AreaTag Class See Also Send Feedback
get/set the type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaTagType AreaTagType { get; set; }
Visual Basic (Declaration)
Public Property AreaTagType As AreaTagType
Visual C++
public:
property AreaTagType^ AreaTagType {
    AreaTagType^ get ();
    void set (AreaTagType^ value);
}

Remarks

get/set the type for the current AreaTag.

See Also

AreaTag Class
Autodesk.Revit.Elements Namespace


Leader Property

[image]

Revit 2010 API
AreaTag..::.Leader Property
AreaTag Class See Also Send Feedback
get/set the display attribute of Leader.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Leader { get; set; }
Visual Basic (Declaration)
Public Property Leader As Boolean
Visual C++
public:
property bool Leader {
    bool get ();
    void set (bool value);
}

Remarks

get/set, will be true if the leader is displayed otherwise false.

See Also

AreaTag Class
Autodesk.Revit.Elements Namespace


Location Property

[image]

Revit 2010 API
AreaTag..::.Location Property
AreaTag Class See Also Send Feedback
get a location point object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

The point within the location object should be get/set. This is the location of the area within the level. The Z location should be the elevation of the level and not changeable.

See Also

AreaTag Class
Autodesk.Revit.Elements Namespace


Name Property

[image]

Revit 2010 API
AreaTag..::.Name Property
AreaTag Class See Also Send Feedback
Retrieve or Change the name associated with the AreaTag.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The property inherited from element is hidden, a System.InvalidOperationException is thrown.

See Also

AreaTag Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
AreaTag..::.Parameter Property
AreaTag Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AreaTag Class
AreaTag Members
Autodesk.Revit.Elements Namespace


View Property

[image]

Revit 2010 API
AreaTag..::.View Property
AreaTag Class See Also Send Feedback
Returns the view in which the tag was place.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public View View { get; }
Visual Basic (Declaration)
Public ReadOnly Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
}

Remarks

get the view in which the tag was placed.

See Also

AreaTag Class
Autodesk.Revit.Elements Namespace


BaseArray Class

[image]

Revit 2010 API
BaseArray Class
Members See Also Send Feedback
An abstract base class that represents an array within the Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class BaseArray : Element
Visual Basic (Declaration)
Public MustInherit Class BaseArray _
    Inherits Element
Visual C++
public ref class BaseArray abstract : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.BaseArray
Autodesk.Revit.Elements..::.LinearArray
Autodesk.Revit.Elements..::.RadialArray

See Also

BaseArray Members
Autodesk.Revit.Elements Namespace


BaseArray Members

[image] [image]

Revit 2010 API
BaseArray Members
BaseArray Class Constructors Methods Properties See Also Send Feedback

The BaseArray type exposes the following members.

Constructors

Name | Description
BaseArray | Initializes a new instance of the BaseArray class

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CopyMembers | Retrieve the copied members of the Array.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Overrides Element..::.Name.)
NumMembers | Retrieve or Change the number of the arrayed members.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
OrigMembers | Retrieve the original members of the Array.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

BaseArray Class
Autodesk.Revit.Elements Namespace


BaseArray Constructor

[image]

Revit 2010 API
BaseArray Constructor
BaseArray Class See Also Send Feedback
Initializes a new instance of the BaseArray class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BaseArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BaseArray()

See Also

BaseArray Class
Autodesk.Revit.Elements Namespace


BaseArray Methods

[image] [image]

Revit 2010 API
BaseArray Methods
BaseArray Class See Also Send Feedback

The BaseArray type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseArray Class
Autodesk.Revit.Elements Namespace


BaseArray Properties

[image] [image]

Revit 2010 API
BaseArray Properties
BaseArray Class See Also Send Feedback

The BaseArray type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CopyMembers | Retrieve the copied members of the Array.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Overrides Element..::.Name.)
NumMembers | Retrieve or Change the number of the arrayed members.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
OrigMembers | Retrieve the original members of the Array.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

BaseArray Class
Autodesk.Revit.Elements Namespace


CopyMembers Property

[image]

Revit 2010 API
BaseArray..::.CopyMembers Property
BaseArray Class See Also Send Feedback
Retrieve the copied members of the Array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract ElementArray CopyMembers { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property CopyMembers As ElementArray
Visual C++
public:
virtual property ElementArray^ CopyMembers {
    ElementArray^ get () abstract;
}

See Also

BaseArray Class
Autodesk.Revit.Elements Namespace


Name Property

[image]

Revit 2010 API
BaseArray..::.Name Property
BaseArray Class See Also Send Feedback
Get and Set the Name property

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The method set is override to forbid the user to change the Name. When the user tries to call the method set for BaseArray object, an InvalidOperationException will be thrown.

See Also

BaseArray Class
Autodesk.Revit.Elements Namespace


NumMembers Property

[image]

Revit 2010 API
BaseArray..::.NumMembers Property
BaseArray Class See Also Send Feedback
Retrieve or Change the number of the arrayed members.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract int NumMembers { get; set; }
Visual Basic (Declaration)
Public MustOverride Property NumMembers As Integer
Visual C++
public:
virtual property int NumMembers {
    int get () abstract;
    void set (int value) abstract;
}

See Also

BaseArray Class
Autodesk.Revit.Elements Namespace


OrigMembers Property

[image]

Revit 2010 API
BaseArray..::.OrigMembers Property
BaseArray Class See Also Send Feedback
Retrieve the original members of the Array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract ElementArray OrigMembers { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property OrigMembers As ElementArray
Visual C++
public:
virtual property ElementArray^ OrigMembers {
    ElementArray^ get () abstract;
}

See Also

BaseArray Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
BaseArray..::.Parameter Property
BaseArray Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

BaseArray Class
BaseArray Members
Autodesk.Revit.Elements Namespace


BasePoint Class

[image]

Revit 2010 API
BasePoint Class
Members See Also Send Feedback
Represents kinds of BasePoints.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BasePoint : Element
Visual Basic (Declaration)
Public Class BasePoint _
    Inherits Element
Visual C++
public ref class BasePoint : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.BasePoint

See Also

BasePoint Members
Autodesk.Revit.Elements Namespace


BasePoint Members

[image] [image]

Revit 2010 API
BasePoint Members
BasePoint Class Constructors Methods Properties See Also Send Feedback

The BasePoint type exposes the following members.

Constructors

Name | Description
BasePoint | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsShared | Indicates whether the base point is shared.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

BasePoint Class
Autodesk.Revit.Elements Namespace


BasePoint Constructor

[image]

Revit 2010 API
BasePoint Constructor
BasePoint Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BasePoint()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BasePoint()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BasePoint Class
Autodesk.Revit.Elements Namespace


BasePoint Methods

[image] [image]

Revit 2010 API
BasePoint Methods
BasePoint Class See Also Send Feedback

The BasePoint type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BasePoint Class
Autodesk.Revit.Elements Namespace


BasePoint Properties

[image] [image]

Revit 2010 API
BasePoint Properties
BasePoint Class See Also Send Feedback

The BasePoint type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsShared | Indicates whether the base point is shared.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

BasePoint Class
Autodesk.Revit.Elements Namespace


IsShared Property

[image]

Revit 2010 API
BasePoint..::.IsShared Property
BasePoint Class See Also Send Feedback
Indicates whether the base point is shared.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsShared { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsShared As Boolean
Visual C++
public:
property bool IsShared {
    bool get ();
}

See Also

BasePoint Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
BasePoint..::.Parameter Property
BasePoint Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

BasePoint Class
BasePoint Members
Autodesk.Revit.Elements Namespace


BeamSystem Class

[image]

Revit 2010 API
BeamSystem Class
Members Example See Also Send Feedback
An object that represents a BeamSystem within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BeamSystem : Element
Visual Basic (Declaration)
Public Class BeamSystem _
    Inherits Element
Visual C++
public ref class BeamSystem : public Element

Remarks

This object derived from the Element base object. It can be used access the properties of a BeamSystem, such as elevation, level etc. All the beams belongs to a BeamSystem can be got and there is a static method to find out the BeamSystem to which the beam belongs.

Examples

CopyC#
public void GetInfo_BeamSystemType(BeamSystem beamSystem)
{
    string message = "BeamSystem : ";
    // Get BeamSystem type name
    message += "\nBeamSystem type name : " + beamSystem.BeamSystemType.Name;

    // Rename the BeamSystem type used by this BeamSystem
    beamSystem.BeamSystemType.Name = "TestBeamSystemTypeName";
    // Get BeamSystem type name
    message += "\nBeamSystem type name after set: " + beamSystem.BeamSystemType.Name;

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_BeamSystemType(ByVal beamSystem As BeamSystem)
    Dim message As String = "BeamSystem : "
    ' Get BeamSystem type name
    message += vbLf & "BeamSystem type name : " & beamSystem.BeamSystemType.Name

    ' Rename the BeamSystem type used by this BeamSystem
    beamSystem.BeamSystemType.Name = "TestBeamSystemTypeName"
    ' Get BeamSystem type name
    message += vbLf & "BeamSystem type name after set: " & beamSystem.BeamSystemType.Name

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.BeamSystem

See Also

BeamSystem Members
Autodesk.Revit.Elements Namespace


BeamSystem Members

[image] [image]

Revit 2010 API
BeamSystem Members
BeamSystem Class Constructors Methods Properties See Also Send Feedback

The BeamSystem type exposes the following members.

Constructors

Name | Description
BeamSystem | For Internal Use Only.

Methods

Name | Description
BeamBelongsTo | Find out the BeamSystem to which the beam belongs.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllBeams | Get all the beams of the BeamSystem.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BeamSystemType | Retrieve or change the type of the BeamSystem.
BeamType | Retrieve or change the Beam Type of the BeamSystem.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Direction | Retrieve or change the Direction of the BeamSystem.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elevation | Retrieve or change the Elevation of the BeamSystem.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
LayoutRule | Retrieve or change the LayoutRule of the BeamSystem.
Level | Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Profile | Retrieve or set the profile of the BeamSystem.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


BeamSystem Constructor

[image]

Revit 2010 API
BeamSystem Constructor
BeamSystem Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BeamSystem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamSystem()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


BeamSystem Methods

[image] [image]

Revit 2010 API
BeamSystem Methods
BeamSystem Class See Also Send Feedback

The BeamSystem type exposes the following members.

Methods

Name | Description
BeamBelongsTo | Find out the BeamSystem to which the beam belongs.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllBeams | Get all the beams of the BeamSystem.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


BeamBelongsTo Method

[image]

Revit 2010 API
BeamSystem..::.BeamBelongsTo Method
BeamSystem Class See Also Send Feedback
Find out the BeamSystem to which the beam belongs.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static BeamSystem BeamBelongsTo(
    FamilyInstance beam
)
Visual Basic (Declaration)
Public Shared Function BeamBelongsTo ( _
    beam As FamilyInstance _
) As BeamSystem
Visual C++
public:
static BeamSystem^ BeamBelongsTo(
    FamilyInstance^ beam
)

Parameters

beam
Type: Autodesk.Revit.Elements..::.FamilyInstance
The beam want to ask.

Return Value

The BeamSystem.

Remarks

Beam is a FamilyInstance.

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


GetAllBeams Method

[image]

Revit 2010 API
BeamSystem..::.GetAllBeams Method
BeamSystem Class See Also Send Feedback
Get all the beams of the BeamSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet GetAllBeams()
Visual Basic (Declaration)
Public Function GetAllBeams As ElementSet
Visual C++
public:
ElementSet^ GetAllBeams()

Return Value

The beams.

Remarks

Beam is a FamilyInstance.

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


BeamSystem Properties

[image] [image]

Revit 2010 API
BeamSystem Properties
BeamSystem Class See Also Send Feedback

The BeamSystem type exposes the following members.

Properties

Name | Description
BeamSystemType | Retrieve or change the type of the BeamSystem.
BeamType | Retrieve or change the Beam Type of the BeamSystem.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Direction | Retrieve or change the Direction of the BeamSystem.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elevation | Retrieve or change the Elevation of the BeamSystem.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
LayoutRule | Retrieve or change the LayoutRule of the BeamSystem.
Level | Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Profile | Retrieve or set the profile of the BeamSystem.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


BeamSystemType Property

[image]

Revit 2010 API
BeamSystem..::.BeamSystemType Property
BeamSystem Class Example See Also Send Feedback
Retrieve or change the type of the BeamSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BeamSystemType BeamSystemType { get; set; }
Visual Basic (Declaration)
Public Property BeamSystemType As BeamSystemType
Visual C++
public:
property BeamSystemType^ BeamSystemType {
    BeamSystemType^ get ();
    void set (BeamSystemType^ value);
}

Examples

CopyC#
public void GetInfo_BeamSystemType(BeamSystem beamSystem)
{
    string message = "BeamSystem : ";
    // Get BeamSystem type name
    message += "\nBeamSystem type name : " + beamSystem.BeamSystemType.Name;

    // Rename the BeamSystem type used by this BeamSystem
    beamSystem.BeamSystemType.Name = "TestBeamSystemTypeName";
    // Get BeamSystem type name
    message += "\nBeamSystem type name after set: " + beamSystem.BeamSystemType.Name;

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_BeamSystemType(ByVal beamSystem As BeamSystem)
    Dim message As String = "BeamSystem : "
    ' Get BeamSystem type name
    message += vbLf & "BeamSystem type name : " & beamSystem.BeamSystemType.Name

    ' Rename the BeamSystem type used by this BeamSystem
    beamSystem.BeamSystemType.Name = "TestBeamSystemTypeName"
    ' Get BeamSystem type name
    message += vbLf & "BeamSystem type name after set: " & beamSystem.BeamSystemType.Name

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


BeamType Property

[image]

Revit 2010 API
BeamSystem..::.BeamType Property
BeamSystem Class Example See Also Send Feedback
Retrieve or change the Beam Type of the BeamSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbol BeamType { get; set; }
Visual Basic (Declaration)
Public Property BeamType As FamilySymbol
Visual C++
public:
property FamilySymbol^ BeamType {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Examples

CopyC#
public void GetInfo_BeamType(BeamSystem beamSystem)
{
    string message = "BeamSystem : ";
    // Get BeamSystem type name
    message += "\nBeam type name : " + beamSystem.BeamType.Name;
    // Get BeamSystem type material
    message += "\nBeam type material : " + beamSystem.BeamType.Material;
    // Get BeamSystem family name
    message += "\nBeam family name : " + beamSystem.BeamType.Family.Name;

    // Rename BeamType used by this BeamSystem
    beamSystem.BeamType.Name = "TestBeamTypeName";
    // Rename the Family used by the BeamType that is used by this BeamSystem
    beamSystem.BeamType.Family.Name = "TestBeamTypeFamilyName";

    // Get BeamSystem type name
    message += "\nBeam type name after set : " + beamSystem.BeamType.Name;
    // Get BeamSystem family name
    message += "\nBeam family name after set : " + beamSystem.BeamType.Family.Name;

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_BeamType(ByVal beamSystem As BeamSystem)
    Dim message As String = "BeamSystem : "
    ' Get BeamSystem type name
    message += vbLf & "Beam type name : " & beamSystem.BeamType.Name
    ' Get BeamSystem type material
    message += vbLf & "Beam type material : " & beamSystem.BeamType.Material
    ' Get BeamSystem family name
    message += vbLf & "Beam family name : " & beamSystem.BeamType.Family.Name

    ' Rename BeamType used by this BeamSystem
    beamSystem.BeamType.Name = "TestBeamTypeName"
    ' Rename the Family used by the BeamType that is used by this BeamSystem
    beamSystem.BeamType.Family.Name = "TestBeamTypeFamilyName"

    ' Get BeamSystem type name
    message += vbLf & "Beam type name after set : " & beamSystem.BeamType.Name
    ' Get BeamSystem family name
    message += vbLf & "Beam family name after set : " & beamSystem.BeamType.Family.Name

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


Direction Property

[image]

Revit 2010 API
BeamSystem..::.Direction Property
BeamSystem Class See Also Send Feedback
Retrieve or change the Direction of the BeamSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Direction { get; }
Visual Basic (Declaration)
Public ReadOnly Property Direction As XYZ
Visual C++
public:
property XYZ^ Direction {
    XYZ^ get ();
}

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


Elevation Property

[image]

Revit 2010 API
BeamSystem..::.Elevation Property
BeamSystem Class See Also Send Feedback
Retrieve or change the Elevation of the BeamSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Elevation { get; set; }
Visual Basic (Declaration)
Public Property Elevation As Double
Visual C++
public:
property double Elevation {
    double get ();
    void set (double value);
}

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


LayoutRule Property

[image]

Revit 2010 API
BeamSystem..::.LayoutRule Property
BeamSystem Class See Also Send Feedback
Retrieve or change the LayoutRule of the BeamSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LayoutRule LayoutRule { get; set; }
Visual Basic (Declaration)
Public Property LayoutRule As LayoutRule
Visual C++
public:
property LayoutRule^ LayoutRule {
    LayoutRule^ get ();
    void set (LayoutRule^ value);
}

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


Level Property

[image]

Revit 2010 API
BeamSystem..::.Level Property
BeamSystem Class See Also Send Feedback
Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Level Level { get; set; }
Visual Basic (Declaration)
Public Property Level As Level
Visual C++
public:
property Level^ Level {
    Level^ get ();
    void set (Level^ value);
}

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
BeamSystem..::.Parameter Property
BeamSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

BeamSystem Class
BeamSystem Members
Autodesk.Revit.Elements Namespace


Profile Property

[image]

Revit 2010 API
BeamSystem..::.Profile Property
BeamSystem Class See Also Send Feedback
Retrieve or set the profile of the BeamSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray Profile { get; set; }
Visual Basic (Declaration)
Public Property Profile As CurveArray
Visual C++
public:
property CurveArray^ Profile {
    CurveArray^ get ();
    void set (CurveArray^ value);
}

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace


Blend Class

[image]

Revit 2010 API
Blend Class
Members See Also Send Feedback
A blend solid or void form.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Blend : GenericForm
Visual Basic (Declaration)
Public Class Blend _
    Inherits GenericForm
Visual C++
public ref class Blend : public GenericForm

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CombinableElement
Autodesk.Revit.Elements..::.GenericForm
Autodesk.Revit.Elements..::.Blend

See Also

Blend Members
Autodesk.Revit.Elements Namespace


Blend Members

[image] [image]

Revit 2010 API
Blend Members
Blend Class Constructors Methods Properties See Also Send Feedback

The Blend type exposes the following members.

Constructors

Name | Description
Blend | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BottomOffset | The offset of the bottom end of the blend relative to the sketch plane.
BottomProfile | The curves which make up the bottom profile of the sketch.
BottomSketch | Returns the Bottom Sketch of the Blend.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory. (Inherited from GenericForm.)
TopOffset | The offset of the top end of the blend relative to the sketch plane.
TopProfile | The curves which make up the top profile of the sketch.
TopSketch | Returns the Top Sketch of the Blend.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Blend Class
Autodesk.Revit.Elements Namespace


Blend Constructor

[image]

Revit 2010 API
Blend Constructor
Blend Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Blend()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Blend()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Blend Class
Autodesk.Revit.Elements Namespace


Blend Methods

[image] [image]

Revit 2010 API
Blend Methods
Blend Class See Also Send Feedback

The Blend type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Blend Class
Autodesk.Revit.Elements Namespace


GetVertexConnectionMap Method

[image]

Revit 2010 API
Blend..::.GetVertexConnectionMap Method
Blend Class See Also Send Feedback
Gets the mapping between the vertices in the top and bottom profiles.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public VertexIndexPairArray GetVertexConnectionMap()
Visual Basic (Declaration)
Public Function GetVertexConnectionMap As VertexIndexPairArray
Visual C++
public:
VertexIndexPairArray^ GetVertexConnectionMap()

Remarks

Each vertex refers to the start point of the curve from the top and bottom profiles.

See Also

Blend Class
Autodesk.Revit.Elements Namespace


SetVertexConnectionMap Method

[image]

Revit 2010 API
Blend..::.SetVertexConnectionMap Method
Blend Class See Also Send Feedback
Sets the mapping between the vertices in the top and bottom profiles.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetVertexConnectionMap(
    VertexIndexPairArray vertexMap
)
Visual Basic (Declaration)
Public Sub SetVertexConnectionMap ( _
    vertexMap As VertexIndexPairArray _
)
Visual C++
public:
void SetVertexConnectionMap(
    VertexIndexPairArray^ vertexMap
)

Parameters

vertexMap
Type: Autodesk.Revit..::.VertexIndexPairArray

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"vertexMap"-is null.
System..::.ArgumentException | Thrown if the input argument-"vertexMap"-is empty.
System..::.InvalidOperationException | Thrown when the document failed to regenerate.

See Also

Blend Class
Autodesk.Revit.Elements Namespace


Blend Properties

[image] [image]

Revit 2010 API
Blend Properties
Blend Class See Also Send Feedback

The Blend type exposes the following members.

Properties

Name | Description
BottomOffset | The offset of the bottom end of the blend relative to the sketch plane.
BottomProfile | The curves which make up the bottom profile of the sketch.
BottomSketch | Returns the Bottom Sketch of the Blend.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory. (Inherited from GenericForm.)
TopOffset | The offset of the top end of the blend relative to the sketch plane.
TopProfile | The curves which make up the top profile of the sketch.
TopSketch | Returns the Top Sketch of the Blend.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Blend Class
Autodesk.Revit.Elements Namespace


BottomOffset Property

[image]

Revit 2010 API
Blend..::.BottomOffset Property
Blend Class See Also Send Feedback
The offset of the bottom end of the blend relative to the sketch plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double BottomOffset { get; set; }
Visual Basic (Declaration)
Public Property BottomOffset As Double
Visual C++
public:
property double BottomOffset {
    double get ();
    void set (double value);
}

See Also

Blend Class
Autodesk.Revit.Elements Namespace


BottomProfile Property

[image]

Revit 2010 API
Blend..::.BottomProfile Property
Blend Class See Also Send Feedback
The curves which make up the bottom profile of the sketch.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArrArray BottomProfile { get; }
Visual Basic (Declaration)
Public ReadOnly Property BottomProfile As CurveArrArray
Visual C++
public:
property CurveArrArray^ BottomProfile {
    CurveArrArray^ get ();
}

Remarks

The indices of the curves in this array match the indices used in the vertex connection map.

See Also

Blend Class
Autodesk.Revit.Elements Namespace


BottomSketch Property

[image]

Revit 2010 API
Blend..::.BottomSketch Property
Blend Class See Also Send Feedback
Returns the Bottom Sketch of the Blend.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Sketch BottomSketch { get; }
Visual Basic (Declaration)
Public ReadOnly Property BottomSketch As Sketch
Visual C++
public:
property Sketch^ BottomSketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the Bottom Sketch of the Blend.

See Also

Blend Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Blend..::.Parameter Property
Blend Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Blend Class
Blend Members
Autodesk.Revit.Elements Namespace


TopOffset Property

[image]

Revit 2010 API
Blend..::.TopOffset Property
Blend Class See Also Send Feedback
The offset of the top end of the blend relative to the sketch plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double TopOffset { get; set; }
Visual Basic (Declaration)
Public Property TopOffset As Double
Visual C++
public:
property double TopOffset {
    double get ();
    void set (double value);
}

See Also

Blend Class
Autodesk.Revit.Elements Namespace


TopProfile Property

[image]

Revit 2010 API
Blend..::.TopProfile Property
Blend Class See Also Send Feedback
The curves which make up the top profile of the sketch.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArrArray TopProfile { get; }
Visual Basic (Declaration)
Public ReadOnly Property TopProfile As CurveArrArray
Visual C++
public:
property CurveArrArray^ TopProfile {
    CurveArrArray^ get ();
}

Remarks

The indices of the curves in this array match the indices used in the vertex connection map.

See Also

Blend Class
Autodesk.Revit.Elements Namespace


TopSketch Property

[image]

Revit 2010 API
Blend..::.TopSketch Property
Blend Class See Also Send Feedback
Returns the Top Sketch of the Blend.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Sketch TopSketch { get; }
Visual Basic (Declaration)
Public ReadOnly Property TopSketch As Sketch
Visual C++
public:
property Sketch^ TopSketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the Top Sketch of the Blend.

See Also

Blend Class
Autodesk.Revit.Elements Namespace


BoundaryConditions Class

[image]

Revit 2010 API
BoundaryConditions Class
Members Example See Also Send Feedback
An object that represents a force applied across an area.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BoundaryConditions : Element
Visual Basic (Declaration)
Public Class BoundaryConditions _
    Inherits Element
Visual C++
public ref class BoundaryConditions : public Element

Examples

CopyC#
public void GetInfo_BoundaryConditions(BoundaryConditions boundaryConditions)
{
    string message = "BoundaryConditions : ";

    Parameter param = boundaryConditions.get_Parameter(BuiltInParameter.BOUNDARY_CONDITIONS_TYPE);
    switch (param.AsInteger())
    {
        case 0:
            XYZ point = boundaryConditions.Point;
            message += "\nThis BoundaryConditions is a Point Boundary Conditions.";
            message += "\nLocation point: (" + point.X + ", "
                        + point.Y + ", " + point.Z + ")";
            break;
        case 1:
            message += "\nThis BoundaryConditions is a Line Boundary Conditions.";
            Curve curve = boundaryConditions.get_Curve(0);
            // Get curve start point
            message += "\nLocation Line: start point: (" + curve.get_EndPoint(0).X + ", "
                    + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
            // Get curve end point
            message += ";  end point:(" + curve.get_EndPoint(1).X + ", "
                    + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
            break;
        case 2:
            message += "\nThis BoundaryConditions is an Area Boundary Conditions.";
            for (int i = 0; i < boundaryConditions.NumCurves; i++)
            {
                Autodesk.Revit.Geometry.Curve areaCurve = boundaryConditions.get_Curve(i);
                // Get curve start point
                message += "\nCurve start point:(" + areaCurve.get_EndPoint(0).X + ", "
                     + areaCurve.get_EndPoint(0).Y + ", " + areaCurve.get_EndPoint(0).Z + ")";
                // Get curve end point
                message += "; Curve end point:(" + areaCurve.get_EndPoint(1).X + ", "
                     + areaCurve.get_EndPoint(1).Y + ", " + areaCurve.get_EndPoint(1).Z + ")";
            }
            break;
        default:
            break;
    }

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_BoundaryConditions(ByVal boundaryConditions As Autodesk.Revit.Elements.BoundaryConditions)
    Dim message As String = "BoundaryConditions : "

    Dim param As Parameter = boundaryConditions.Parameter(BuiltInParameter.BOUNDARY_CONDITIONS_TYPE)
    Select Case param.AsInteger()
        Case 0
            Dim point As Autodesk.Revit.Geometry.XYZ = boundaryConditions.Point
            message += vbLf & "This BoundaryConditions is a Point Boundary Conditions."
            message += ((vbLf & "Location point: (" & point.X & ", ") + point.Y & ", ") + point.Z & ")"
            Exit Select
        Case 1
            message += vbLf & "This BoundaryConditions is a Line Boundary Conditions."
            Dim curve As Curve = boundaryConditions.Curve(0)
            ' Get curve start point
            message += ((vbLf & "Location Line: start point: (" & curve.EndPoint(0).X & ", ") + curve.EndPoint(0).Y & ", ") + curve.EndPoint(0).Z & ")"
            ' Get curve end point
            message += (("; end point:(" & curve.EndPoint(1).X & ", ") + curve.EndPoint(1).Y & ", ") + curve.EndPoint(1).Z & ")"
            Exit Select
        Case 2
            message += vbLf & "This BoundaryConditions is an Area Boundary Conditions."
            For i As Integer = 0 To boundaryConditions.NumCurves - 1
                Dim areaCurve As Autodesk.Revit.Geometry.Curve = boundaryConditions.Curve(i)
                ' Get curve start point
                message += ((vbLf & "Curve start point:(" & areaCurve.EndPoint(0).X & ", ") + areaCurve.EndPoint(0).Y & ", ") + areaCurve.EndPoint(0).Z & ")"
                ' Get curve end point
                message += (("; Curve end point:(" & areaCurve.EndPoint(1).X & ", ") + areaCurve.EndPoint(1).Y & ", ") + areaCurve.EndPoint(1).Z & ")"
            Next
            Exit Select
        Case Else
            Exit Select
    End Select

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.BoundaryConditions

See Also

BoundaryConditions Members
Autodesk.Revit.Elements Namespace


BoundaryConditions Members

[image] [image]

Revit 2010 API
BoundaryConditions Members
BoundaryConditions Class Constructors Methods Properties See Also Send Feedback

The BoundaryConditions type exposes the following members.

Constructors

Name | Description
BoundaryConditions | For Internal Use Only.

Methods

Name | Description
associateWithLoad | Sets the ElementId of Load to associate.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssociatedLoad | Retrieve the AssociatedLoad.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | Returns the geometric curve within a geometric loop that defines the area.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HostElement | Retrieve the HostElementId.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
NumCurves | Returns the number of curves represent the Boundary Conditions Element.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Point | If successful, returns the point represetns Boundary Conditions.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace


BoundaryConditions Constructor

[image]

Revit 2010 API
BoundaryConditions Constructor
BoundaryConditions Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundaryConditions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundaryConditions()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace


BoundaryConditions Methods

[image] [image]

Revit 2010 API
BoundaryConditions Methods
BoundaryConditions Class See Also Send Feedback

The BoundaryConditions type exposes the following members.

Methods

Name | Description
associateWithLoad | Sets the ElementId of Load to associate.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace


associateWithLoad Method

[image]

Revit 2010 API
BoundaryConditions..::.associateWithLoad Method
BoundaryConditions Class See Also Send Feedback
Sets the ElementId of Load to associate.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool associateWithLoad(
    ref ElementId elementToAssociateId
)
Visual Basic (Declaration)
Public Function associateWithLoad ( _
    ByRef elementToAssociateId As ElementId _
) As Boolean
Visual C++
public:
bool associateWithLoad(
    ElementId% elementToAssociateId
)

Parameters

elementToAssociateId
Type: Autodesk.Revit..::.ElementId %
The the ElementId of Load to associate.

Return Value

If the ElementId was set returns true. Otherwise returns false.

Remarks

ElementId may be set if the internal Load with the elementToAssociateId exist and it's type fit the BoundaryConditions type only.

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace


BoundaryConditions Properties

[image] [image]

Revit 2010 API
BoundaryConditions Properties
BoundaryConditions Class See Also Send Feedback

The BoundaryConditions type exposes the following members.

Properties

Name | Description
AssociatedLoad | Retrieve the AssociatedLoad.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | Returns the geometric curve within a geometric loop that defines the area.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HostElement | Retrieve the HostElementId.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
NumCurves | Returns the number of curves represent the Boundary Conditions Element.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Point | If successful, returns the point represetns Boundary Conditions.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace


AssociatedLoad Property

[image]

Revit 2010 API
BoundaryConditions..::.AssociatedLoad Property
BoundaryConditions Class See Also Send Feedback
Retrieve the AssociatedLoad.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element AssociatedLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssociatedLoad As Element
Visual C++
public:
property Element^ AssociatedLoad {
    Element^ get ();
}

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace


Curve Property

[image]

Revit 2010 API
BoundaryConditions..::.Curve Property
BoundaryConditions Class See Also Send Feedback
Returns the geometric curve within a geometric loop that defines the area.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve Curve[
    int curveIndex
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve ( _
    curveIndex As Integer _
) As Curve
Visual C++
public:
property Curve^ Curve[int curveIndex] {
    Curve^ get (int curveIndex);
}

Parameters

curveIndex
Type: System..::.Int32
The index curve in the BoundaryConditions.

Return Value

If successful, returns the curve pointer. Otherwise returns nullptr.

Remarks

The curve index should be between 0 and NumCurves-1.

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace


HostElement Property

[image]

Revit 2010 API
BoundaryConditions..::.HostElement Property
BoundaryConditions Class See Also Send Feedback
Retrieve the HostElementId.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element HostElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property HostElement As Element
Visual C++
public:
property Element^ HostElement {
    Element^ get ();
}

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace


NumCurves Property

[image]

Revit 2010 API
BoundaryConditions..::.NumCurves Property
BoundaryConditions Class See Also Send Feedback
Returns the number of curves represent the Boundary Conditions Element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NumCurves { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumCurves As Integer
Visual C++
public:
property int NumCurves {
    int get ();
}

Remarks

For Point Boundary Conditions returns 0, for Line Boundary Conditions returns 1, for Area Boundary Conditions returns value > 0.

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
BoundaryConditions..::.Parameter Property
BoundaryConditions Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

BoundaryConditions Class
BoundaryConditions Members
Autodesk.Revit.Elements Namespace


Point Property

[image]

Revit 2010 API
BoundaryConditions..::.Point Property
BoundaryConditions Class See Also Send Feedback
If successful, returns the point represetns Boundary Conditions.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Point { get; }
Visual Basic (Declaration)
Public ReadOnly Property Point As XYZ
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
}

Remarks

Returns the point if the BoundaryConditionsType == 0 - point. Otherwise returns default XYZ().

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace


CeilingAndFloor Class

[image]

Revit 2010 API
CeilingAndFloor Class
Members See Also Send Feedback
A base class that provides support for all ceiling and floor objects.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CeilingAndFloor : HostObject
Visual Basic (Declaration)
Public Class CeilingAndFloor _
    Inherits HostObject
Visual C++
public ref class CeilingAndFloor : public HostObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.CeilingAndFloor

See Also

CeilingAndFloor Members
Autodesk.Revit.Elements Namespace


CeilingAndFloor Members

[image] [image]

Revit 2010 API
CeilingAndFloor Members
CeilingAndFloor Class Constructors Methods Properties See Also Send Feedback

The CeilingAndFloor type exposes the following members.

Constructors

Name | Description
CeilingAndFloor | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CeilingAndFloor Class
Autodesk.Revit.Elements Namespace


CeilingAndFloor Constructor

[image]

Revit 2010 API
CeilingAndFloor Constructor
CeilingAndFloor Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CeilingAndFloor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CeilingAndFloor()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CeilingAndFloor Class
Autodesk.Revit.Elements Namespace


CeilingAndFloor Methods

[image] [image]

Revit 2010 API
CeilingAndFloor Methods
CeilingAndFloor Class See Also Send Feedback

The CeilingAndFloor type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CeilingAndFloor Class
Autodesk.Revit.Elements Namespace


CeilingAndFloor Properties

[image] [image]

Revit 2010 API
CeilingAndFloor Properties
CeilingAndFloor Class See Also Send Feedback

The CeilingAndFloor type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CeilingAndFloor Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
CeilingAndFloor..::.Parameter Property
CeilingAndFloor Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

CeilingAndFloor Class
CeilingAndFloor Members
Autodesk.Revit.Elements Namespace


CombinableElement Class

[image]

Revit 2010 API
CombinableElement Class
Members See Also Send Feedback
An element that can be added to a geometry combination.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CombinableElement : Element
Visual Basic (Declaration)
Public Class CombinableElement _
    Inherits Element
Visual C++
public ref class CombinableElement : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CombinableElement
Autodesk.Revit.Elements..::.GenericForm
Autodesk.Revit.Elements..::.GeomCombination

See Also

CombinableElement Members
Autodesk.Revit.Elements Namespace


CombinableElement Members

[image] [image]

Revit 2010 API
CombinableElement Members
CombinableElement Class Constructors Methods Properties See Also Send Feedback

The CombinableElement type exposes the following members.

Constructors

Name | Description
CombinableElement | For internal use only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CombinableElement Class
Autodesk.Revit.Elements Namespace


CombinableElement Constructor

[image]

Revit 2010 API
CombinableElement Constructor
CombinableElement Class See Also Send Feedback
For internal use only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CombinableElement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CombinableElement()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CombinableElement Class
Autodesk.Revit.Elements Namespace


CombinableElement Methods

[image] [image]

Revit 2010 API
CombinableElement Methods
CombinableElement Class See Also Send Feedback

The CombinableElement type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CombinableElement Class
Autodesk.Revit.Elements Namespace


CombinableElement Properties

[image] [image]

Revit 2010 API
CombinableElement Properties
CombinableElement Class See Also Send Feedback

The CombinableElement type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CombinableElement Class
Autodesk.Revit.Elements Namespace


Combinations Property

[image]

Revit 2010 API
CombinableElement..::.Combinations Property
CombinableElement Class See Also Send Feedback
The geometry combinations that this element belongs to.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GeomCombinationSet Combinations { get; }
Visual Basic (Declaration)
Public ReadOnly Property Combinations As GeomCombinationSet
Visual C++
public:
property GeomCombinationSet^ Combinations {
    GeomCombinationSet^ get ();
}

Remarks

If this combinable element does not belong to any geometry combination, this value is an empty collection. A solid combinable element may belong to at most one combination, while a void combinable element may belong to multiple combinations.

See Also

CombinableElement Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
CombinableElement..::.Parameter Property
CombinableElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

CombinableElement Class
CombinableElement Members
Autodesk.Revit.Elements Namespace


CombinableElementArray Class

[image]

Revit 2010 API
CombinableElementArray Class
Members See Also Send Feedback
An array that contains CombinableElement objects.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CombinableElementArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class CombinableElementArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CombinableElementArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.CombinableElementArray

See Also

CombinableElementArray Members
Autodesk.Revit.Elements Namespace


CombinableElementArray Members

[image] [image]

Revit 2010 API
CombinableElementArray Members
CombinableElementArray Class Constructors Methods Properties See Also Send Feedback

The CombinableElementArray type exposes the following members.

Constructors

Name | Description
CombinableElementArray | Initializes a new instance of the CombinableElementArray class

Methods

Name | Description
Append |
Clear | Removes every CombinableElement from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a CombinableElement at a specified index within the array.
Size | Returns the number of CombinableElements that are in the array.

See Also

CombinableElementArray Class
Autodesk.Revit.Elements Namespace


CombinableElementArray Constructor

[image]

Revit 2010 API
CombinableElementArray Constructor
CombinableElementArray Class See Also Send Feedback
Initializes a new instance of the CombinableElementArray class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CombinableElementArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CombinableElementArray()

See Also

CombinableElementArray Class
Autodesk.Revit.Elements Namespace


CombinableElementArray Methods

[image] [image]

Revit 2010 API
CombinableElementArray Methods
CombinableElementArray Class See Also Send Feedback

The CombinableElementArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every CombinableElement from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CombinableElementArray Class
Autodesk.Revit.Elements Namespace


Append Method

[image]

Revit 2010 API
CombinableElementArray..::.Append Method
CombinableElementArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    CombinableElement item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As CombinableElement _
)
Visual C++
public:
virtual void Append(
    CombinableElement^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.CombinableElement

See Also

CombinableElementArray Class
Autodesk.Revit.Elements Namespace


Clear Method

[image]

Revit 2010 API
CombinableElementArray..::.Clear Method
CombinableElementArray Class See Also Send Feedback
Removes every CombinableElement from the array, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CombinableElementArray Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

[image]

Revit 2010 API
CombinableElementArray..::.ForwardIterator Method
CombinableElementArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CombinableElementArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CombinableElementArrayIterator
Visual C++
public:
virtual CombinableElementArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

CombinableElementArray Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

[image]

Revit 2010 API
CombinableElementArray..::.GetEnumerator Method
CombinableElementArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CombinableElementArray Class
Autodesk.Revit.Elements Namespace


Insert Method

[image]

Revit 2010 API
CombinableElementArray..::.Insert Method
CombinableElementArray Class See Also Send Feedback
Insert the specified element into the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    CombinableElement item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As CombinableElement, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    CombinableElement^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Elements..::.CombinableElement
The CombinableElement to be inserted into the array.
index
Type: System..::.Int32
The CombinableElement will be inserted before this index.

Return Value

Returns whether the CombinableElement was inserted into the array.

See Also

CombinableElementArray Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

[image]

Revit 2010 API
CombinableElementArray..::.ReverseIterator Method
CombinableElementArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CombinableElementArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CombinableElementArrayIterator
Visual C++
public:
virtual CombinableElementArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

CombinableElementArray Class
Autodesk.Revit.Elements Namespace


CombinableElementArray Properties

[image] [image]

Revit 2010 API
CombinableElementArray Properties
CombinableElementArray Class See Also Send Feedback

The CombinableElementArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a CombinableElement at a specified index within the array.
Size | Returns the number of CombinableElements that are in the array.

See Also

CombinableElementArray Class
Autodesk.Revit.Elements Namespace


IsEmpty Property

[image]

Revit 2010 API
CombinableElementArray..::.IsEmpty Property
CombinableElementArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

CombinableElementArray Class
Autodesk.Revit.Elements Namespace


Item Property

[image]

Revit 2010 API
CombinableElementArray..::.Item Property
CombinableElementArray Class See Also Send Feedback
Gets or sets a CombinableElement at a specified index within the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CombinableElement Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As CombinableElement
Visual C++
public:
virtual property CombinableElement^ Item[int index] {
    CombinableElement^ get (int index);
    void set (int index, CombinableElement^ value);
}

Parameters

index
Type: System..::.Int32
The index of the CombinableElement to be set or retrieved.

Return Value

Returns the CombinableElement at the specified index.

See Also

CombinableElementArray Class
Autodesk.Revit.Elements Namespace


Size Property

[image]

Revit 2010 API
CombinableElementArray..::.Size Property
CombinableElementArray Class See Also Send Feedback
Returns the number of CombinableElements that are in the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CombinableElementArray Class
Autodesk.Revit.Elements Namespace


CombinableElementArrayIterator Class

[image]

Revit 2010 API
CombinableElementArrayIterator Class
Members See Also Send Feedback
An iterator to an CombinableElement array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class CombinableElementArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CombinableElementArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CombinableElementArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.CombinableElementArrayIterator

See Also

CombinableElementArrayIterator Members
Autodesk.Revit.Elements Namespace


CombinableElementArrayIterator Members

[image] [image]

Revit 2010 API
CombinableElementArrayIterator Members
CombinableElementArrayIterator Class Constructors Methods Properties See Also Send Feedback

The CombinableElementArrayIterator type exposes the following members.

Constructors

Name | Description
CombinableElementArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CombinableElementArrayIterator Class
Autodesk.Revit.Elements Namespace


CombinableElementArrayIterator Constructor

[image]

Revit 2010 API
CombinableElementArrayIterator Constructor
CombinableElementArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CombinableElementArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CombinableElementArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CombinableElementArrayIterator Class
Autodesk.Revit.Elements Namespace


CombinableElementArrayIterator Methods

[image] [image]

Revit 2010 API
CombinableElementArrayIterator Methods
CombinableElementArrayIterator Class See Also Send Feedback

The CombinableElementArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CombinableElementArrayIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

[image]

Revit 2010 API
CombinableElementArrayIterator..::.MoveNext Method
CombinableElementArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CombinableElementArrayIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

[image]

Revit 2010 API
CombinableElementArrayIterator..::.Reset Method
CombinableElementArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CombinableElementArrayIterator Class
Autodesk.Revit.Elements Namespace


CombinableElementArrayIterator Properties

[image] [image]

Revit 2010 API
CombinableElementArrayIterator Properties
CombinableElementArrayIterator Class See Also Send Feedback

The CombinableElementArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CombinableElementArrayIterator Class
Autodesk.Revit.Elements Namespace


Current Property

[image]

Revit 2010 API
CombinableElementArrayIterator..::.Current Property
CombinableElementArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CombinableElementArrayIterator Class
Autodesk.Revit.Elements Namespace


ContFooting Class

[image]

Revit 2010 API
ContFooting Class
Members Example See Also Send Feedback
An object that represents a Continuous Footing within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ContFooting : HostObject
Visual Basic (Declaration)
Public Class ContFooting _
    Inherits HostObject
Visual C++
public ref class ContFooting : public HostObject

Examples

CopyC#
public void GetInfo_ContFooting(ContFooting contFooting)
{
    string message = "Wall Foundation : ";

    // Get Analytical model
    if (null != contFooting.AnalyticalModel)
    {
        message += "\nAnalytical model : " + contFooting.AnalyticalModel;
    }

    // Get Footing type name
    message += "\nFooting type name is : " + contFooting.FootingType.Name;

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_ContFooting(ByVal contFooting As Autodesk.Revit.Elements.ContFooting)
    Dim message As String = "Wall Foundation : "

    ' Get Analytical model
    If contFooting.AnalyticalModel IsNot Nothing Then
        message += vbLf & "Analytical model : " & contFooting.AnalyticalModel.ToString
    End If

    ' Get Footing type name
    message += vbLf & "Footing type name is : " & contFooting.FootingType.Name

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.ContFooting

See Also

ContFooting Members
Autodesk.Revit.Elements Namespace


ContFooting Members

[image] [image]

Revit 2010 API
ContFooting Members
ContFooting Class Constructors Methods Properties See Also Send Feedback

The ContFooting type exposes the following members.

Constructors

Name | Description
ContFooting | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AnalyticalModel | Retrieves the structural analytical model for this footing.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FootingType | Retrieves an object that represents the type of the footing.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ContFooting Class
Autodesk.Revit.Elements Namespace


ContFooting Constructor

[image]

Revit 2010 API
ContFooting Constructor
ContFooting Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ContFooting()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ContFooting()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ContFooting Class
Autodesk.Revit.Elements Namespace


ContFooting Methods

[image] [image]

Revit 2010 API
ContFooting Methods
ContFooting Class See Also Send Feedback

The ContFooting type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContFooting Class
Autodesk.Revit.Elements Namespace


ContFooting Properties

[image] [image]

Revit 2010 API
ContFooting Properties
ContFooting Class See Also Send Feedback

The ContFooting type exposes the following members.

Properties

Name | Description
AnalyticalModel | Retrieves the structural analytical model for this footing.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FootingType | Retrieves an object that represents the type of the footing.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ContFooting Class
Autodesk.Revit.Elements Namespace


AnalyticalModel Property

[image]

Revit 2010 API
ContFooting..::.AnalyticalModel Property
ContFooting Class See Also Send Feedback
Retrieves the structural analytical model for this footing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalModel AnalyticalModel { get; }
Visual Basic (Declaration)
Public ReadOnly Property AnalyticalModel As AnalyticalModel
Visual C++
public:
property AnalyticalModel^ AnalyticalModel {
    AnalyticalModel^ get ();
}

Remarks

If the footing has a structural analytical model it is returned by this method, otherwise Nothing is returned. For this kind of footing, the analytical model returned by this method can be cast to type Autodesk.Revit.Structural.AnalyticalModel3D to be able to access details about the footing. This property will only function with the Autodesk Revit Structure product.

See Also

ContFooting Class
Autodesk.Revit.Elements Namespace


FootingType Property

[image]

Revit 2010 API
ContFooting..::.FootingType Property
ContFooting Class See Also Send Feedback
Retrieves an object that represents the type of the footing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ContFootingType FootingType { get; set; }
Visual Basic (Declaration)
Public Property FootingType As ContFootingType
Visual C++
public:
property ContFootingType^ FootingType {
    ContFootingType^ get ();
    void set (ContFootingType^ value);
}

Remarks

The footing type can be used to access the multi layered structure of a footing.

See Also

ContFooting Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
ContFooting..::.Parameter Property
ContFooting Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ContFooting Class
ContFooting Members
Autodesk.Revit.Elements Namespace


Control Class

[image]

Revit 2010 API
Control Class
Members See Also Send Feedback
A control in Autodesk Revit family document.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Control : Element
Visual Basic (Declaration)
Public Class Control _
    Inherits Element
Visual C++
public ref class Control : public Element

Remarks

The object represents a variety of different shapes of controls in family document. The different shapes of controls can handle the family instance in different ways.
  • A vertical/horizontal arrow control rotates the instance by 180 degrees.
  • A double vertical arrow control mirrors the instance geometry vertically.
  • A double horizontal arrow control mirrors the instance geometry horizontally.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Control

See Also

Control Members
Autodesk.Revit.Elements Namespace


Control Members

[image] [image]

Revit 2010 API
Control Members
Control Class Constructors Methods Properties See Also Send Feedback

The Control type exposes the following members.

Constructors

Name | Description
Control | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Origin | The control origin.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Shape | The control shape.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
View | The view.

See Also

Control Class
Autodesk.Revit.Elements Namespace


Control Constructor

[image]

Revit 2010 API
Control Constructor
Control Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Control()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Control()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Control Class
Autodesk.Revit.Elements Namespace


Control Methods

[image] [image]

Revit 2010 API
Control Methods
Control Class See Also Send Feedback

The Control type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Control Class
Autodesk.Revit.Elements Namespace


Control Properties

[image] [image]

Revit 2010 API
Control Properties
Control Class See Also Send Feedback

The Control type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Origin | The control origin.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Shape | The control shape.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
View | The view.

See Also

Control Class
Autodesk.Revit.Elements Namespace


Origin Property

[image]

Revit 2010 API
Control..::.Origin Property
Control Class See Also Send Feedback
The control origin.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

Control Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Control..::.Parameter Property
Control Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Control Class
Control Members
Autodesk.Revit.Elements Namespace


Shape Property

[image]

Revit 2010 API
Control..::.Shape Property
Control Class See Also Send Feedback
The control shape.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ControlShape Shape { get; }
Visual Basic (Declaration)
Public ReadOnly Property Shape As ControlShape
Visual C++
public:
property ControlShape Shape {
    ControlShape get ();
}

See Also

Control Class
Autodesk.Revit.Elements Namespace


View Property

[image]

Revit 2010 API
Control..::.View Property
Control Class See Also Send Feedback
The view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public View View { get; }
Visual Basic (Declaration)
Public ReadOnly Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
}

See Also

Control Class
Autodesk.Revit.Elements Namespace


ControlShape Enumeration

[image]

Revit 2010 API
ControlShape Enumeration
See Also Send Feedback
An enumerate type listing four shapes of control that Autodesk Revit supports.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ControlShape
Visual Basic (Declaration)
Public Enumeration ControlShape
Visual C++
public enum class ControlShape

Members

Member name | Description
DoubleHorizontalArrow | Double horizontal arrow.
DoubleVerticalArrow | Double vertical arrow.
HorizontalArrow | Horizontal arrow.
VerticalArrow | Vertical arrow.

See Also

Autodesk.Revit.Elements Namespace


CurtainCell Class

[image]

Revit 2010 API
CurtainCell Class
Members See Also Send Feedback
Represents a CurtainCell within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CurtainCell : APIObject
Visual Basic (Declaration)
Public Class CurtainCell _
    Inherits APIObject
Visual C++
public ref class CurtainCell : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.CurtainCell

See Also

CurtainCell Members
Autodesk.Revit.Elements Namespace


CurtainCell Members

[image] [image]

Revit 2010 API
CurtainCell Members
CurtainCell Class Constructors Methods Properties See Also Send Feedback

The CurtainCell type exposes the following members.

Constructors

Name | Description
CurtainCell | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurveLoops | The cell boundaries on the reference face.The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
PlanarizedCurveLoops | The planarized curve loops for cell boundaries.The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

See Also

CurtainCell Class
Autodesk.Revit.Elements Namespace


CurtainCell Constructor

[image]

Revit 2010 API
CurtainCell Constructor
CurtainCell Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainCell()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainCell()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainCell Class
Autodesk.Revit.Elements Namespace


CurtainCell Methods

[image] [image]

Revit 2010 API
CurtainCell Methods
CurtainCell Class See Also Send Feedback

The CurtainCell type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainCell Class
Autodesk.Revit.Elements Namespace


CurtainCell Properties

[image] [image]

Revit 2010 API
CurtainCell Properties
CurtainCell Class See Also Send Feedback

The CurtainCell type exposes the following members.

Properties

Name | Description
CurveLoops | The cell boundaries on the reference face.The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
PlanarizedCurveLoops | The planarized curve loops for cell boundaries.The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

See Also

CurtainCell Class
Autodesk.Revit.Elements Namespace


CurveLoops Property

[image]

Revit 2010 API
CurtainCell..::.CurveLoops Property
CurtainCell Class See Also Send Feedback
The cell boundaries on the reference face.The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArrArray CurveLoops { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurveLoops As CurveArrArray
Visual C++
public:
property CurveArrArray^ CurveLoops {
    CurveArrArray^ get ();
}

See Also

CurtainCell Class
Autodesk.Revit.Elements Namespace


PlanarizedCurveLoops Property

[image]

Revit 2010 API
CurtainCell..::.PlanarizedCurveLoops Property
CurtainCell Class See Also Send Feedback
The planarized curve loops for cell boundaries.The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArrArray PlanarizedCurveLoops { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlanarizedCurveLoops As CurveArrArray
Visual C++
public:
property CurveArrArray^ PlanarizedCurveLoops {
    CurveArrArray^ get ();
}

See Also

CurtainCell Class
Autodesk.Revit.Elements Namespace


CurtainCellSet Class

[image]

Revit 2010 API
CurtainCellSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CurtainCellSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class CurtainCellSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurtainCellSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.CurtainCellSet

See Also

CurtainCellSet Members
Autodesk.Revit.Elements Namespace


CurtainCellSet Members

[image] [image]

Revit 2010 API
CurtainCellSet Members
CurtainCellSet Class Constructors Methods Properties See Also Send Feedback

The CurtainCellSet type exposes the following members.

Constructors

Name | Description
CurtainCellSet | Initializes a new instance of the CurtainCellSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


CurtainCellSet Constructor

[image]

Revit 2010 API
CurtainCellSet Constructor
CurtainCellSet Class See Also Send Feedback
Initializes a new instance of the CurtainCellSet class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainCellSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainCellSet()

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


CurtainCellSet Methods

[image] [image]

Revit 2010 API
CurtainCellSet Methods
CurtainCellSet Class See Also Send Feedback

The CurtainCellSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


Clear Method

[image]

Revit 2010 API
CurtainCellSet..::.Clear Method
CurtainCellSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


Contains Method

[image]

Revit 2010 API
CurtainCellSet..::.Contains Method
CurtainCellSet Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    CurtainCell item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As CurtainCell _
) As Boolean
Visual C++
public:
virtual bool Contains(
    CurtainCell^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.CurtainCell

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


Erase Method

[image]

Revit 2010 API
CurtainCellSet..::.Erase Method
CurtainCellSet Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    CurtainCell item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As CurtainCell _
) As Integer
Visual C++
public:
virtual int Erase(
    CurtainCell^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.CurtainCell

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

[image]

Revit 2010 API
CurtainCellSet..::.ForwardIterator Method
CurtainCellSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CurtainCellSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CurtainCellSetIterator
Visual C++
public:
virtual CurtainCellSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

[image]

Revit 2010 API
CurtainCellSet..::.GetEnumerator Method
CurtainCellSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


Insert Method

[image]

Revit 2010 API
CurtainCellSet..::.Insert Method
CurtainCellSet Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    CurtainCell item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As CurtainCell _
) As Boolean
Visual C++
public:
virtual bool Insert(
    CurtainCell^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.CurtainCell

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

[image]

Revit 2010 API
CurtainCellSet..::.ReverseIterator Method
CurtainCellSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CurtainCellSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CurtainCellSetIterator
Visual C++
public:
virtual CurtainCellSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


CurtainCellSet Properties

[image] [image]

Revit 2010 API
CurtainCellSet Properties
CurtainCellSet Class See Also Send Feedback

The CurtainCellSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


IsEmpty Property

[image]

Revit 2010 API
CurtainCellSet..::.IsEmpty Property
CurtainCellSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


Size Property

[image]

Revit 2010 API
CurtainCellSet..::.Size Property
CurtainCellSet Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurtainCellSet Class
Autodesk.Revit.Elements Namespace


CurtainCellSetIterator Class

[image]

Revit 2010 API
CurtainCellSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class CurtainCellSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CurtainCellSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CurtainCellSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.CurtainCellSetIterator

See Also

CurtainCellSetIterator Members
Autodesk.Revit.Elements Namespace


CurtainCellSetIterator Members

[image] [image]

Revit 2010 API
CurtainCellSetIterator Members
CurtainCellSetIterator Class Constructors Methods Properties See Also Send Feedback

The CurtainCellSetIterator type exposes the following members.

Constructors

Name | Description
CurtainCellSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainCellSetIterator Class
Autodesk.Revit.Elements Namespace


CurtainCellSetIterator Constructor

[image]

Revit 2010 API
CurtainCellSetIterator Constructor
CurtainCellSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainCellSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainCellSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainCellSetIterator Class
Autodesk.Revit.Elements Namespace


CurtainCellSetIterator Methods

[image] [image]

Revit 2010 API
CurtainCellSetIterator Methods
CurtainCellSetIterator Class See Also Send Feedback

The CurtainCellSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainCellSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

[image]

Revit 2010 API
CurtainCellSetIterator..::.MoveNext Method
CurtainCellSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurtainCellSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

[image]

Revit 2010 API
CurtainCellSetIterator..::.Reset Method
CurtainCellSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurtainCellSetIterator Class
Autodesk.Revit.Elements Namespace


CurtainCellSetIterator Properties

[image] [image]

Revit 2010 API
CurtainCellSetIterator Properties
CurtainCellSetIterator Class See Also Send Feedback

The CurtainCellSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainCellSetIterator Class
Autodesk.Revit.Elements Namespace


Current Property

[image]

Revit 2010 API
CurtainCellSetIterator..::.Current Property
CurtainCellSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurtainCellSetIterator Class
Autodesk.Revit.Elements Namespace


CurtainGrid Class

[image]

Revit 2010 API
CurtainGrid Class
Members See Also Send Feedback
Represents a curtain grid element within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CurtainGrid : APIObject
Visual Basic (Declaration)
Public Class CurtainGrid _
    Inherits APIObject
Visual C++
public ref class CurtainGrid : public APIObject

Remarks

This element is obtained from a curtain wall,curtain system or curtain roof. A curtain wall has only one curtain grid, while a curtain system or curtain roof may have several curtain grids.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.CurtainGrid

See Also

CurtainGrid Members
Autodesk.Revit.Elements Namespace


CurtainGrid Members

[image] [image]

Revit 2010 API
CurtainGrid Members
CurtainGrid Class Constructors Methods Properties See Also Send Feedback

The CurtainGrid type exposes the following members.

Constructors

Name | Description
CurtainGrid | For Internal Use Only.

Methods

Name | Description
AddGridLine | Add a grid line to the curtain grid.
ChangePanelType | Change the type of a curtain panel.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCell | Get the specified cell located by the intersection of the grid lines.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPanel | Get the specified panel located by the intersection of the grid lines.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cells | Get all the cells owned by this curtain grid.
Grid1Angle | The angle for the U grid line pattern of the curtain grid.
Grid1Justification | The justification for the U grid line pattern of the curtain grid.
Grid1Offset | The offset for the U grid line pattern of the curtain grid.
Grid2Angle | The angle for V grid line pattern of the curtain grid.
Grid2Justification | The justification for the V grid line pattern of the curtain grid.
Grid2Offset | The offset for V grid line pattern of the curtain grid.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Mullions | Get all the mullions of the curtain grid. The elements in this set are instances of Mullion.
NumPanels | The number of panels.
NumULines | Get the number of grid lines in the U direction.
NumVLines | Get the number of grid lines in the V direction.
Panels | All the panels of the curtain grid.
UGridLines | All grid lines in the U direction.
UnlockedMullions | Get all the unlocked mullions of of the curtain grid.
UnlockedPanels | Get all the unlocked panels of the curtain grid.
VGridLines | All grid lines in the V direction.

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


CurtainGrid Constructor

[image]

Revit 2010 API
CurtainGrid Constructor
CurtainGrid Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainGrid()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainGrid()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


CurtainGrid Methods

[image] [image]

Revit 2010 API
CurtainGrid Methods
CurtainGrid Class See Also Send Feedback

The CurtainGrid type exposes the following members.

Methods

Name | Description
AddGridLine | Add a grid line to the curtain grid.
ChangePanelType | Change the type of a curtain panel.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCell | Get the specified cell located by the intersection of the grid lines.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPanel | Get the specified panel located by the intersection of the grid lines.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


AddGridLine Method

[image]

Revit 2010 API
CurtainGrid..::.AddGridLine Method
CurtainGrid Class See Also Send Feedback
Add a grid line to the curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainGridLine AddGridLine(
    bool isUGridLine,
    XYZ position,
    bool oneSegmentOnly
)
Visual Basic (Declaration)
Public Function AddGridLine ( _
    isUGridLine As Boolean, _
    position As XYZ, _
    oneSegmentOnly As Boolean _
) As CurtainGridLine
Visual C++
public:
CurtainGridLine^ AddGridLine(
    bool isUGridLine,
    XYZ^ position,
    bool oneSegmentOnly
)

Parameters

isUGridLine
Type: System..::.Boolean
If true, a U-direction grid line will be added. Otherwise, a V-direction grid line will be added.
position
Type: Autodesk.Revit.Geometry..::.XYZ
The position of the grid line.
oneSegmentOnly
Type: System..::.Boolean
If it is true, only one segment is added. Otherwise, all segments will be added for the grid line.

Return Value

The created grid line is returned if the operation is successful. Otherwise, null is returned.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if the position for the grid line is out of range.

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


ChangePanelType Method

[image]

Revit 2010 API
CurtainGrid..::.ChangePanelType Method
CurtainGrid Class See Also Send Feedback
Change the type of a curtain panel.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element ChangePanelType(
    Element panel,
    Symbol newSymbol
)
Visual Basic (Declaration)
Public Function ChangePanelType ( _
    panel As Element, _
    newSymbol As Symbol _
) As Element
Visual C++
public:
Element^ ChangePanelType(
    Element^ panel,
    Symbol^ newSymbol
)

Parameters

panel
Type: Autodesk.Revit..::.Element
The panel to be changed, it can be a type of Panel or Wall.
newSymbol
Type: Autodesk.Revit..::.Symbol
The new symbol, it may be of PanelType or WallType when the panel is hosted in a curtain wall. The new symbol can only be of type PanelType if the Panel is hosted in a curtain system.

Return Value

If operation succeeds, the modified panel element is returned.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown if the input input symbol can't be used for the panel.
System..::.InvalidOperationException | Thrown when the type change failed.

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


GetCell Method

[image]

Revit 2010 API
CurtainGrid..::.GetCell Method
CurtainGrid Class See Also Send Feedback
Get the specified cell located by the intersection of the grid lines.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainCell GetCell(
    ref ElementId uGridLineId,
    ref ElementId vGridLineId
)
Visual Basic (Declaration)
Public Function GetCell ( _
    ByRef uGridLineId As ElementId, _
    ByRef vGridLineId As ElementId _
) As CurtainCell
Visual C++
public:
CurtainCell^ GetCell(
    ElementId% uGridLineId,
    ElementId% vGridLineId
)

Parameters

uGridLineId
Type: Autodesk.Revit..::.ElementId %
The id of a grid line in the U-direction used to locate the cell.
vGridLineId
Type: Autodesk.Revit..::.ElementId %
The id of a grid line in the V-direction used to locate the cell.

Return Value

The cell.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown if the grid line ids are not part of this curtain grid.

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


GetPanel Method

[image]

Revit 2010 API
CurtainGrid..::.GetPanel Method
CurtainGrid Class See Also Send Feedback
Get the specified panel located by the intersection of the grid lines.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Panel GetPanel(
    ref ElementId uGridLineId,
    ref ElementId vGridLineId
)
Visual Basic (Declaration)
Public Function GetPanel ( _
    ByRef uGridLineId As ElementId, _
    ByRef vGridLineId As ElementId _
) As Panel
Visual C++
public:
Panel^ GetPanel(
    ElementId% uGridLineId,
    ElementId% vGridLineId
)

Parameters

uGridLineId
Type: Autodesk.Revit..::.ElementId %
The id of a grid line in the U-direction used to locate the panel.
vGridLineId
Type: Autodesk.Revit..::.ElementId %
The id of a grid line in the V-direction used to locate the panel.

Return Value

The panel, or null if the panel cannot be found at this intersection.

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


CurtainGrid Properties

[image] [image]

Revit 2010 API
CurtainGrid Properties
CurtainGrid Class See Also Send Feedback

The CurtainGrid type exposes the following members.

Properties

Name | Description
Cells | Get all the cells owned by this curtain grid.
Grid1Angle | The angle for the U grid line pattern of the curtain grid.
Grid1Justification | The justification for the U grid line pattern of the curtain grid.
Grid1Offset | The offset for the U grid line pattern of the curtain grid.
Grid2Angle | The angle for V grid line pattern of the curtain grid.
Grid2Justification | The justification for the V grid line pattern of the curtain grid.
Grid2Offset | The offset for V grid line pattern of the curtain grid.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Mullions | Get all the mullions of the curtain grid. The elements in this set are instances of Mullion.
NumPanels | The number of panels.
NumULines | Get the number of grid lines in the U direction.
NumVLines | Get the number of grid lines in the V direction.
Panels | All the panels of the curtain grid.
UGridLines | All grid lines in the U direction.
UnlockedMullions | Get all the unlocked mullions of of the curtain grid.
UnlockedPanels | Get all the unlocked panels of the curtain grid.
VGridLines | All grid lines in the V direction.

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


Cells Property

[image]

Revit 2010 API
CurtainGrid..::.Cells Property
CurtainGrid Class See Also Send Feedback
Get all the cells owned by this curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainCellSet Cells { get; }
Visual Basic (Declaration)
Public ReadOnly Property Cells As CurtainCellSet
Visual C++
public:
property CurtainCellSet^ Cells {
    CurtainCellSet^ get ();
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


Grid1Angle Property

[image]

Revit 2010 API
CurtainGrid..::.Grid1Angle Property
CurtainGrid Class See Also Send Feedback
The angle for the U grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Grid1Angle { get; set; }
Visual Basic (Declaration)
Public Property Grid1Angle As Double
Visual C++
public:
property double Grid1Angle {
    double get ();
    void set (double value);
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


Grid1Justification Property

[image]

Revit 2010 API
CurtainGrid..::.Grid1Justification Property
CurtainGrid Class See Also Send Feedback
The justification for the U grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainGridAlignType Grid1Justification { get; set; }
Visual Basic (Declaration)
Public Property Grid1Justification As CurtainGridAlignType
Visual C++
public:
property CurtainGridAlignType Grid1Justification {
    CurtainGridAlignType get ();
    void set (CurtainGridAlignType value);
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


Grid1Offset Property

[image]

Revit 2010 API
CurtainGrid..::.Grid1Offset Property
CurtainGrid Class See Also Send Feedback
The offset for the U grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Grid1Offset { get; set; }
Visual Basic (Declaration)
Public Property Grid1Offset As Double
Visual C++
public:
property double Grid1Offset {
    double get ();
    void set (double value);
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


Grid2Angle Property

[image]

Revit 2010 API
CurtainGrid..::.Grid2Angle Property
CurtainGrid Class See Also Send Feedback
The angle for V grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Grid2Angle { get; set; }
Visual Basic (Declaration)
Public Property Grid2Angle As Double
Visual C++
public:
property double Grid2Angle {
    double get ();
    void set (double value);
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


Grid2Justification Property

[image]

Revit 2010 API
CurtainGrid..::.Grid2Justification Property
CurtainGrid Class See Also Send Feedback
The justification for the V grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainGridAlignType Grid2Justification { get; set; }
Visual Basic (Declaration)
Public Property Grid2Justification As CurtainGridAlignType
Visual C++
public:
property CurtainGridAlignType Grid2Justification {
    CurtainGridAlignType get ();
    void set (CurtainGridAlignType value);
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


Grid2Offset Property

[image]

Revit 2010 API
CurtainGrid..::.Grid2Offset Property
CurtainGrid Class See Also Send Feedback
The offset for V grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Grid2Offset { get; set; }
Visual Basic (Declaration)
Public Property Grid2Offset As Double
Visual C++
public:
property double Grid2Offset {
    double get ();
    void set (double value);
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


Mullions Property

[image]

Revit 2010 API
CurtainGrid..::.Mullions Property
CurtainGrid Class See Also Send Feedback
Get all the mullions of the curtain grid. The elements in this set are instances of Mullion.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet Mullions { get; }
Visual Basic (Declaration)
Public ReadOnly Property Mullions As ElementSet
Visual C++
public:
property ElementSet^ Mullions {
    ElementSet^ get ();
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


NumPanels Property

[image]

Revit 2010 API
CurtainGrid..::.NumPanels Property
CurtainGrid Class See Also Send Feedback
The number of panels.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NumPanels { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumPanels As Integer
Visual C++
public:
property int NumPanels {
    int get ();
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


NumULines Property

[image]

Revit 2010 API
CurtainGrid..::.NumULines Property
CurtainGrid Class See Also Send Feedback
Get the number of grid lines in the U direction.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NumULines { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumULines As Integer
Visual C++
public:
property int NumULines {
    int get ();
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


NumVLines Property

[image]

Revit 2010 API
CurtainGrid..::.NumVLines Property
CurtainGrid Class See Also Send Feedback
Get the number of grid lines in the V direction.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NumVLines { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumVLines As Integer
Visual C++
public:
property int NumVLines {
    int get ();
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


Panels Property

[image]

Revit 2010 API
CurtainGrid..::.Panels Property
CurtainGrid Class See Also Send Feedback
All the panels of the curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet Panels { get; }
Visual Basic (Declaration)
Public ReadOnly Property Panels As ElementSet
Visual C++
public:
property ElementSet^ Panels {
    ElementSet^ get ();
}

Remarks

For curtain walls, the element in this set is either an instance of Panel or Wall. For curtain systems, the set contains only instances of Panel.

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


UGridLines Property

[image]

Revit 2010 API
CurtainGrid..::.UGridLines Property
CurtainGrid Class See Also Send Feedback
All grid lines in the U direction.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet UGridLines { get; }
Visual Basic (Declaration)
Public ReadOnly Property UGridLines As ElementSet
Visual C++
public:
property ElementSet^ UGridLines {
    ElementSet^ get ();
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


UnlockedMullions Property

[image]

Revit 2010 API
CurtainGrid..::.UnlockedMullions Property
CurtainGrid Class See Also Send Feedback
Get all the unlocked mullions of of the curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet UnlockedMullions { get; }
Visual Basic (Declaration)
Public ReadOnly Property UnlockedMullions As ElementSet
Visual C++
public:
property ElementSet^ UnlockedMullions {
    ElementSet^ get ();
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


UnlockedPanels Property

[image]

Revit 2010 API
CurtainGrid..::.UnlockedPanels Property
CurtainGrid Class See Also Send Feedback
Get all the unlocked panels of the curtain grid.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet UnlockedPanels { get; }
Visual Basic (Declaration)
Public ReadOnly Property UnlockedPanels As ElementSet
Visual C++
public:
property ElementSet^ UnlockedPanels {
    ElementSet^ get ();
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


VGridLines Property

[image]

Revit 2010 API
CurtainGrid..::.VGridLines Property
CurtainGrid Class See Also Send Feedback
All grid lines in the V direction.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet VGridLines { get; }
Visual Basic (Declaration)
Public ReadOnly Property VGridLines As ElementSet
Visual C++
public:
property ElementSet^ VGridLines {
    ElementSet^ get ();
}

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace


CurtainGridLine Class

[image]

Revit 2010 API
CurtainGridLine Class
Members See Also Send Feedback
Represents a CurtainGridLine within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CurtainGridLine : HostObject
Visual Basic (Declaration)
Public Class CurtainGridLine _
    Inherits HostObject
Visual C++
public ref class CurtainGridLine : public HostObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.CurtainGridLine

See Also

CurtainGridLine Members
Autodesk.Revit.Elements Namespace


CurtainGridLine Members

[image] [image]

Revit 2010 API
CurtainGridLine Members
CurtainGridLine Class Constructors Methods Properties See Also Send Feedback

The CurtainGridLine type exposes the following members.

Constructors

Name | Description
CurtainGridLine | For Internal Use Only.

Methods

Name | Description
AddAllSegments | All the segments on this grid line will be added.
AddMullions | Add mullions on the specified segments of a grid. If a segment already had mullion, just keep it and do nothing to that segment.
AddSegment | Add a segment based on the specified segment curve of the gridline.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Move | It is used to move unlocked type-driven grid lines or user defined grid lines.
RemoveSegment | Remove the segment specified by the input curve.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllSegmentCurves | Retrieve the curves of all segments.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ExistingSegmentCurves | Retrieve all the existing segment curves of the grid line.
FullCurve | Retrieve the geometry curve of the curtain grid line.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsUGridLine | Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Lock | Retrieve or change the lock state of the curtain grid line.
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SkippedSegmentCurves | Retrieve all the removed segment curves of the grid line.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


CurtainGridLine Constructor

[image]

Revit 2010 API
CurtainGridLine Constructor
CurtainGridLine Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainGridLine()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainGridLine()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


CurtainGridLine Methods

[image] [image]

Revit 2010 API
CurtainGridLine Methods
CurtainGridLine Class See Also Send Feedback

The CurtainGridLine type exposes the following members.

Methods

Name | Description
AddAllSegments | All the segments on this grid line will be added.
AddMullions | Add mullions on the specified segments of a grid. If a segment already had mullion, just keep it and do nothing to that segment.
AddSegment | Add a segment based on the specified segment curve of the gridline.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Move | It is used to move unlocked type-driven grid lines or user defined grid lines.
RemoveSegment | Remove the segment specified by the input curve.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


AddAllSegments Method

[image]

Revit 2010 API
CurtainGridLine..::.AddAllSegments Method
CurtainGridLine Class See Also Send Feedback
All the segments on this grid line will be added.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddAllSegments()
Visual Basic (Declaration)
Public Sub AddAllSegments
Visual C++
public:
void AddAllSegments()

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


AddMullions Method

[image]

Revit 2010 API
CurtainGridLine..::.AddMullions Method
CurtainGridLine Class See Also Send Feedback
Add mullions on the specified segments of a grid. If a segment already had mullion, just keep it and do nothing to that segment.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet AddMullions(
    Curve segment,
    MullionType mullionType,
    bool oneSegmentOnly
)
Visual Basic (Declaration)
Public Function AddMullions ( _
    segment As Curve, _
    mullionType As MullionType, _
    oneSegmentOnly As Boolean _
) As ElementSet
Visual C++
public:
ElementSet^ AddMullions(
    Curve^ segment,
    MullionType^ mullionType,
    bool oneSegmentOnly
)

Parameters

segment
Type: Autodesk.Revit.Geometry..::.Curve
Curve of the segment.
mullionType
Type: Autodesk.Revit.Symbols..::.MullionType
The type of the mullion.
oneSegmentOnly
Type: System..::.Boolean
If it is true, we only add one mullion to the specified segment, otherwise we add mullions to all the segments of the grid line.

Return Value

If operation succeeds, the created mullion will be returned.

Exceptions

Exception | Condition
System..::.ArgumentException | If one of the segments are not the tagged edge of the host element, this exception will be thrown.
System..::.InvalidOperationException | The operation fails to create one or several mullions as required or regeneration fails.

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


AddSegment Method

[image]

Revit 2010 API
CurtainGridLine..::.AddSegment Method
CurtainGridLine Class See Also Send Feedback
Add a segment based on the specified segment curve of the gridline.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddSegment(
    Curve curve
)
Visual Basic (Declaration)
Public Sub AddSegment ( _
    curve As Curve _
)
Visual C++
public:
void AddSegment(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
The curve used to locate the segment to be removed.

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


Move Method

[image]

Revit 2010 API
CurtainGridLine..::.Move Method
CurtainGridLine Class See Also Send Feedback
It is used to move unlocked type-driven grid lines or user defined grid lines.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Move(
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function Move ( _
    moveVec As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    XYZ^ moveVec
)

Parameters

moveVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector by which the element is to be moved.

Return Value

If the element is moved successfully then the method return true, otherwise false.

Remarks

Grid line can only move within its surface and U line can only be moved along V direction. So the move distance on grid surface will be caculated from moveVec.

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


RemoveSegment Method

[image]

Revit 2010 API
CurtainGridLine..::.RemoveSegment Method
CurtainGridLine Class See Also Send Feedback
Remove the segment specified by the input curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveSegment(
    Curve curve
)
Visual Basic (Declaration)
Public Sub RemoveSegment ( _
    curve As Curve _
)
Visual C++
public:
void RemoveSegment(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
The curve used to locate the segment to be removed.

Remarks

When a segment is removed, the neighboring two panels will be merged into one panel.

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


CurtainGridLine Properties

[image] [image]

Revit 2010 API
CurtainGridLine Properties
CurtainGridLine Class See Also Send Feedback

The CurtainGridLine type exposes the following members.

Properties

Name | Description
AllSegmentCurves | Retrieve the curves of all segments.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ExistingSegmentCurves | Retrieve all the existing segment curves of the grid line.
FullCurve | Retrieve the geometry curve of the curtain grid line.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsUGridLine | Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Lock | Retrieve or change the lock state of the curtain grid line.
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SkippedSegmentCurves | Retrieve all the removed segment curves of the grid line.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


AllSegmentCurves Property

[image]

Revit 2010 API
CurtainGridLine..::.AllSegmentCurves Property
CurtainGridLine Class See Also Send Feedback
Retrieve the curves of all segments.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray AllSegmentCurves { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllSegmentCurves As CurveArray
Visual C++
public:
property CurveArray^ AllSegmentCurves {
    CurveArray^ get ();
}

Remarks

User can get these curves and then call the method AddSegment() or RemoveSegment() to add/remove specified segments. If the specified segment is already added/removed, nothing will happen.

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


ExistingSegmentCurves Property

[image]

Revit 2010 API
CurtainGridLine..::.ExistingSegmentCurves Property
CurtainGridLine Class See Also Send Feedback
Retrieve all the existing segment curves of the grid line.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray ExistingSegmentCurves { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExistingSegmentCurves As CurveArray
Visual C++
public:
property CurveArray^ ExistingSegmentCurves {
    CurveArray^ get ();
}

Remarks

User can get these curves and call RemoveSegment() to remove the segments to the gridline or call AddMullions() to add mullions to these segments.

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


FullCurve Property

[image]

Revit 2010 API
CurtainGridLine..::.FullCurve Property
CurtainGridLine Class See Also Send Feedback
Retrieve the geometry curve of the curtain grid line.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve FullCurve { get; }
Visual Basic (Declaration)
Public ReadOnly Property FullCurve As Curve
Visual C++
public:
property Curve^ FullCurve {
    Curve^ get ();
}

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


IsUGridLine Property

[image]

Revit 2010 API
CurtainGridLine..::.IsUGridLine Property
CurtainGridLine Class See Also Send Feedback
Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsUGridLine { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsUGridLine As Boolean
Visual C++
public:
property bool IsUGridLine {
    bool get ();
}

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


Lock Property

[image]

Revit 2010 API
CurtainGridLine..::.Lock Property
CurtainGridLine Class See Also Send Feedback
Retrieve or change the lock state of the curtain grid line.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Lock { get; set; }
Visual Basic (Declaration)
Public Property Lock As Boolean
Visual C++
public:
property bool Lock {
    bool get ();
    void set (bool value);
}

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
CurtainGridLine..::.Parameter Property
CurtainGridLine Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

CurtainGridLine Class
CurtainGridLine Members
Autodesk.Revit.Elements Namespace


SkippedSegmentCurves Property

[image]

Revit 2010 API
CurtainGridLine..::.SkippedSegmentCurves Property
CurtainGridLine Class See Also Send Feedback
Retrieve all the removed segment curves of the grid line.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray SkippedSegmentCurves { get; }
Visual Basic (Declaration)
Public ReadOnly Property SkippedSegmentCurves As CurveArray
Visual C++
public:
property CurveArray^ SkippedSegmentCurves {
    CurveArray^ get ();
}

Remarks

User can get these curves and then call the method AddSegment() to add the segments to the grid line.

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace


CurtainGridSet Class

[image]

Revit 2010 API
CurtainGridSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CurtainGridSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class CurtainGridSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurtainGridSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.CurtainGridSet

See Also

CurtainGridSet Members
Autodesk.Revit.Elements Namespace


CurtainGridSet Members

[image] [image]

Revit 2010 API
CurtainGridSet Members
CurtainGridSet Class Constructors Methods Properties See Also Send Feedback

The CurtainGridSet type exposes the following members.

Constructors

Name | Description
CurtainGridSet | Initializes a new instance of the CurtainGridSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


CurtainGridSet Constructor

[image]

Revit 2010 API
CurtainGridSet Constructor
CurtainGridSet Class See Also Send Feedback
Initializes a new instance of the CurtainGridSet class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainGridSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainGridSet()

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


CurtainGridSet Methods

[image] [image]

Revit 2010 API
CurtainGridSet Methods
CurtainGridSet Class See Also Send Feedback

The CurtainGridSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


Clear Method

[image]

Revit 2010 API
CurtainGridSet..::.Clear Method
CurtainGridSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


Contains Method

[image]

Revit 2010 API
CurtainGridSet..::.Contains Method
CurtainGridSet Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    CurtainGrid item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As CurtainGrid _
) As Boolean
Visual C++
public:
virtual bool Contains(
    CurtainGrid^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.CurtainGrid

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


Erase Method

[image]

Revit 2010 API
CurtainGridSet..::.Erase Method
CurtainGridSet Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    CurtainGrid item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As CurtainGrid _
) As Integer
Visual C++
public:
virtual int Erase(
    CurtainGrid^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.CurtainGrid

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

[image]

Revit 2010 API
CurtainGridSet..::.ForwardIterator Method
CurtainGridSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CurtainGridSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CurtainGridSetIterator
Visual C++
public:
virtual CurtainGridSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

[image]

Revit 2010 API
CurtainGridSet..::.GetEnumerator Method
CurtainGridSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


Insert Method

[image]

Revit 2010 API
CurtainGridSet..::.Insert Method
CurtainGridSet Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    CurtainGrid item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As CurtainGrid _
) As Boolean
Visual C++
public:
virtual bool Insert(
    CurtainGrid^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.CurtainGrid

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

[image]

Revit 2010 API
CurtainGridSet..::.ReverseIterator Method
CurtainGridSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CurtainGridSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CurtainGridSetIterator
Visual C++
public:
virtual CurtainGridSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


CurtainGridSet Properties

[image] [image]

Revit 2010 API
CurtainGridSet Properties
CurtainGridSet Class See Also Send Feedback

The CurtainGridSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


IsEmpty Property

[image]

Revit 2010 API
CurtainGridSet..::.IsEmpty Property
CurtainGridSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


Size Property

[image]

Revit 2010 API
CurtainGridSet..::.Size Property
CurtainGridSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurtainGridSet Class
Autodesk.Revit.Elements Namespace


CurtainGridSetIterator Class

[image]

Revit 2010 API
CurtainGridSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class CurtainGridSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CurtainGridSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CurtainGridSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.CurtainGridSetIterator

See Also

CurtainGridSetIterator Members
Autodesk.Revit.Elements Namespace


CurtainGridSetIterator Members

[image] [image]

Revit 2010 API
CurtainGridSetIterator Members
CurtainGridSetIterator Class Constructors Methods Properties See Also Send Feedback

The CurtainGridSetIterator type exposes the following members.

Constructors

Name | Description
CurtainGridSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainGridSetIterator Class
Autodesk.Revit.Elements Namespace


CurtainGridSetIterator Constructor

[image]

Revit 2010 API
CurtainGridSetIterator Constructor
CurtainGridSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainGridSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainGridSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainGridSetIterator Class
Autodesk.Revit.Elements Namespace


CurtainGridSetIterator Methods

[image] [image]

Revit 2010 API
CurtainGridSetIterator Methods
CurtainGridSetIterator Class See Also Send Feedback

The CurtainGridSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainGridSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

[image]

Revit 2010 API
CurtainGridSetIterator..::.MoveNext Method
CurtainGridSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurtainGridSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

[image]

Revit 2010 API
CurtainGridSetIterator..::.Reset Method
CurtainGridSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurtainGridSetIterator Class
Autodesk.Revit.Elements Namespace


CurtainGridSetIterator Properties

[image] [image]

Revit 2010 API
CurtainGridSetIterator Properties
CurtainGridSetIterator Class See Also Send Feedback

The CurtainGridSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainGridSetIterator Class
Autodesk.Revit.Elements Namespace


Current Property

[image]

Revit 2010 API
CurtainGridSetIterator..::.Current Property
CurtainGridSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurtainGridSetIterator Class
Autodesk.Revit.Elements Namespace


CurtainSystem Class

[image]

Revit 2010 API
CurtainSystem Class
Members See Also Send Feedback
Provides access to the CurtainSystem object in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CurtainSystem : CurtainSystemBase
Visual Basic (Declaration)
Public Class CurtainSystem _
    Inherits CurtainSystemBase
Visual C++
public ref class CurtainSystem : public CurtainSystemBase

Remarks

The user can create CurtainSystem object and change the internal properties.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.CurtainSystemBase
Autodesk.Revit.Elements..::.CurtainSystem

See Also

CurtainSystem Members
Autodesk.Revit.Elements Namespace


CurtainSystem Members

[image] [image]

Revit 2010 API
CurtainSystem Members
CurtainSystem Class Constructors Methods Properties See Also Send Feedback

The CurtainSystem type exposes the following members.

Constructors

Name | Description
CurtainSystem | For Internal Use Only.

Methods

Name | Description
AddCurtainGrid | Add CurtainGrid on the specified face for the CurtainSystem.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveCurtainGrid | Remove CurtainGrid from the specified face for the CurtainSystem.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurtainGrids | Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.
CurtainSystemType | get or set the type of the CurtainSystem.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CurtainSystem Class
Autodesk.Revit.Elements Namespace


CurtainSystem Constructor

[image]

Revit 2010 API
CurtainSystem Constructor
CurtainSystem Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainSystem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainSystem()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainSystem Class
Autodesk.Revit.Elements Namespace


CurtainSystem Methods

[image] [image]

Revit 2010 API
CurtainSystem Methods
CurtainSystem Class See Also Send Feedback

The CurtainSystem type exposes the following members.

Methods

Name | Description
AddCurtainGrid | Add CurtainGrid on the specified face for the CurtainSystem.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveCurtainGrid | Remove CurtainGrid from the specified face for the CurtainSystem.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainSystem Class
Autodesk.Revit.Elements Namespace


AddCurtainGrid Method

[image]

Revit 2010 API
CurtainSystem..::.AddCurtainGrid Method
CurtainSystem Class See Also Send Feedback
Add CurtainGrid on the specified face for the CurtainSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddCurtainGrid(
    Reference face
)
Visual Basic (Declaration)
Public Sub AddCurtainGrid ( _
    face As Reference _
)
Visual C++
public:
void AddCurtainGrid(
    Reference^ face
)

Parameters

face
Type: Autodesk.Revit.Geometry..::.Reference
The face new CurtainGrid will be created on.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument face is nullptr.
System..::.InvalidOperationException | Thrown when creating CurtainGrid on the specified face fails or regenerate fails.

See Also

CurtainSystem Class
Autodesk.Revit.Elements Namespace


RemoveCurtainGrid Method

[image]

Revit 2010 API
CurtainSystem..::.RemoveCurtainGrid Method
CurtainSystem Class See Also Send Feedback
Remove CurtainGrid from the specified face for the CurtainSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveCurtainGrid(
    Reference face
)
Visual Basic (Declaration)
Public Sub RemoveCurtainGrid ( _
    face As Reference _
)
Visual C++
public:
void RemoveCurtainGrid(
    Reference^ face
)

Parameters

face
Type: Autodesk.Revit.Geometry..::.Reference
The face CurtainGrid will be removed from.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input parameter face is nullptr.
System..::.InvalidOperationException | Thrown when the CurtainGrid cannot be removed from the specified face or regenerate fails.

See Also

CurtainSystem Class
Autodesk.Revit.Elements Namespace


CurtainSystem Properties

[image] [image]

Revit 2010 API
CurtainSystem Properties
CurtainSystem Class See Also Send Feedback

The CurtainSystem type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurtainGrids | Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.
CurtainSystemType | get or set the type of the CurtainSystem.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CurtainSystem Class
Autodesk.Revit.Elements Namespace


CurtainGrids Property

[image]

Revit 2010 API
CurtainSystem..::.CurtainGrids Property
CurtainSystem Class See Also Send Feedback
Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainGridSet CurtainGrids { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurtainGrids As CurtainGridSet
Visual C++
public:
property CurtainGridSet^ CurtainGrids {
    CurtainGridSet^ get ();
}

Return Value

A CurtainGrid set will be returned if the operation succeeds. nullptr will be returned if the CurtainSystem doesn't include any CurtainGrid.

See Also

CurtainSystem Class
Autodesk.Revit.Elements Namespace


CurtainSystemType Property

[image]

Revit 2010 API
CurtainSystem..::.CurtainSystemType Property
CurtainSystem Class See Also Send Feedback
get or set the type of the CurtainSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainSystemType CurtainSystemType { get; set; }
Visual Basic (Declaration)
Public Property CurtainSystemType As CurtainSystemType
Visual C++
public:
property CurtainSystemType^ CurtainSystemType {
    CurtainSystemType^ get ();
    void set (CurtainSystemType^ value);
}

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter curtainSystemType is null.
System..::.InvalidOperationException | Thrown when the type of the CurtainSystem cannot be changed to the specified one.

See Also

CurtainSystem Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
CurtainSystem..::.Parameter Property
CurtainSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

CurtainSystem Class
CurtainSystem Members
Autodesk.Revit.Elements Namespace


CurtainSystemBase Class

[image]

Revit 2010 API
CurtainSystemBase Class
Members See Also Send Feedback
Provides access to the CurtainSystemBase object in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CurtainSystemBase : HostObject
Visual Basic (Declaration)
Public Class CurtainSystemBase _
    Inherits HostObject
Visual C++
public ref class CurtainSystemBase : public HostObject

Remarks

This is the base class of CurtainSystem.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.CurtainSystemBase
Autodesk.Revit.Elements..::.CurtainSystem

See Also

CurtainSystemBase Members
Autodesk.Revit.Elements Namespace


CurtainSystemBase Members

[image] [image]

Revit 2010 API
CurtainSystemBase Members
CurtainSystemBase Class Constructors Methods Properties See Also Send Feedback

The CurtainSystemBase type exposes the following members.

Constructors

Name | Description
CurtainSystemBase | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CurtainSystemBase Class
Autodesk.Revit.Elements Namespace


CurtainSystemBase Constructor

[image]

Revit 2010 API
CurtainSystemBase Constructor
CurtainSystemBase Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainSystemBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainSystemBase()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainSystemBase Class
Autodesk.Revit.Elements Namespace


CurtainSystemBase Methods

[image] [image]

Revit 2010 API
CurtainSystemBase Methods
CurtainSystemBase Class See Also Send Feedback

The CurtainSystemBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainSystemBase Class
Autodesk.Revit.Elements Namespace


CurtainSystemBase Properties

[image] [image]

Revit 2010 API
CurtainSystemBase Properties
CurtainSystemBase Class See Also Send Feedback

The CurtainSystemBase type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CurtainSystemBase Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
CurtainSystemBase..::.Parameter Property
CurtainSystemBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

CurtainSystemBase Class
CurtainSystemBase Members
Autodesk.Revit.Elements Namespace


CurveByPoints Class

[image]

Revit 2010 API
CurveByPoints Class
Members See Also Send Feedback
A curve interpolating two or more points.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CurveByPoints : CurveElement
Visual Basic (Declaration)
Public Class CurveByPoints _
    Inherits CurveElement
Visual C++
public ref class CurveByPoints : public CurveElement

Remarks

The points to be interpolated are represented as ReferencePoints, which must already exist in the document. In terms of appearance and graphics control, CurveByPoints behaves similarly to ModelCurve. The main difference being that a ModelCurve refers to a SketchPlane, while a CurveByPoints does not.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CurveElement
Autodesk.Revit.Elements..::.CurveByPoints

See Also

CurveByPoints Members
Autodesk.Revit.Elements Namespace


CurveByPoints Members

[image] [image]

Revit 2010 API
CurveByPoints Members
CurveByPoints Class Constructors Methods Properties See Also Send Feedback

The CurveByPoints type exposes the following members.

Constructors

Name | Description
CurveByPoints | Initializes a new instance of the CurveByPoints class

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetPoints | Get the sequence of points interpolated by this curve.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetPoints | Change the sequence of points interpolated by this curve.
SetVisibility | Sets the visibility.
SortPoints | Order a set of ReferencePoints in the same way Revit does when creating a curve from points.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsReferenceLine |
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceType | Indicates the type of reference.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | Override the SketchPlane property of CurveElement. (Overrides CurveElement..::.SketchPlane.)
Subcategory | The subcategory, or graphics style, of the CurveByPoints.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Visible | Whether the point is visible when the family is loaded into a project.

See Also

CurveByPoints Class
Autodesk.Revit.Elements Namespace


CurveByPoints Constructor

[image]

Revit 2010 API
CurveByPoints Constructor
CurveByPoints Class See Also Send Feedback
Initializes a new instance of the CurveByPoints class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveByPoints()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurveByPoints()

See Also

CurveByPoints Class
Autodesk.Revit.Elements Namespace


CurveByPoints Methods

[image] [image]

Revit 2010 API
CurveByPoints Methods
CurveByPoints Class See Also Send Feedback

The CurveByPoints type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetPoints | Get the sequence of points interpolated by this curve.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetPoints | Change the sequence of points interpolated by this curve.
SetVisibility | Sets the visibility.
SortPoints | Order a set of ReferencePoints in the same way Revit does when creating a curve from points.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveByPoints Class
Autodesk.Revit.Elements Namespace


GetPoints Method

[image]

Revit 2010 API
CurveByPoints..::.GetPoints Method
CurveByPoints Class See Also Send Feedback
Get the sequence of points interpolated by this curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferencePointArray GetPoints()
Visual Basic (Declaration)
Public Function GetPoints As ReferencePointArray
Visual C++
public:
ReferencePointArray^ GetPoints()

See Also

CurveByPoints Class
Autodesk.Revit.Elements Namespace


GetVisibility Method

[image]

Revit 2010 API
CurveByPoints..::.GetVisibility Method
CurveByPoints Class See Also Send Feedback
Gets the visibility.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic (Declaration)
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

Returns a copy of visibility settings for the curve.

See Also

CurveByPoints Class
Autodesk.Revit.Elements Namespace


SetPoints Method

[image]

Revit 2010 API
CurveByPoints..::.SetPoints Method
CurveByPoints Class See Also Send Feedback
Change the sequence of points interpolated by this curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetPoints(
    ReferencePointArray points
)
Visual Basic (Declaration)
Public Sub SetPoints ( _
    points As ReferencePointArray _
)
Visual C++
public:
void SetPoints(
    ReferencePointArray^ points
)

Parameters

points
Type: Autodesk.Revit.Elements..::.ReferencePointArray
An array of 2 or more ReferencePoints.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the array contains fewer than 2 points, when the array contains duplicates, or when adjacent points are located too close together.

See Also

CurveByPoints Class
Autodesk.Revit.Elements Namespace


SetVisibility Method

[image]

Revit 2010 API
CurveByPoints..::.SetVisibility Method
CurveByPoints Class See Also Send Feedback
Sets the visibility.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic (Declaration)
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit..::.FamilyElementVisibility

Remarks

The visibility of the CurveByPoints can be changed for different types of views and detail levels in the project.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when visibility is null.
System..::.InvalidOperationException | Thrown when regeneration failed.

See Also

CurveByPoints Class
Autodesk.Revit.Elements Namespace


SortPoints Method

[image]

Revit 2010 API
CurveByPoints..::.SortPoints Method
CurveByPoints Class See Also Send Feedback
Order a set of ReferencePoints in the same way Revit does when creating a curve from points.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static bool SortPoints(
    ReferencePointArray arr
)
Visual Basic (Declaration)
Public Shared Function SortPoints ( _
    arr As ReferencePointArray _
) As Boolean
Visual C++
public:
static bool SortPoints(
    ReferencePointArray^ arr
)

Parameters

arr
Type: Autodesk.Revit.Elements..::.ReferencePointArray
An array of ReferencePoints. The array is reordered if sortPoints returns true, and is unchanged if sortPoints returns false.

Return Value

False if the least-squares method is unable to find a solution; true otherwise.

Remarks

Finds a best-fit line to the points by the least squares method, and orders the points by their projection onto the line.

See Also

CurveByPoints Class
Autodesk.Revit.Elements Namespace


CurveByPoints Properties

[image] [image]

Revit 2010 API
CurveByPoints Properties
CurveByPoints Class See Also Send Feedback

The CurveByPoints type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsReferenceLine |
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceType | Indicates the type of reference.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | Override the SketchPlane property of CurveElement. (Overrides CurveElement..::.SketchPlane.)
Subcategory | The subcategory, or graphics style, of the CurveByPoints.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Visible | Whether the point is visible when the family is loaded into a project.

See Also

CurveByPoints Class
Autodesk.Revit.Elements Namespace


IsReferenceLine Property

[image]

Revit 2010 API
CurveByPoints..::.IsReferenceLine Property
CurveByPoints Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsReferenceLine { get; set; }
Visual Basic (Declaration)
Public Property IsReferenceLine As Boolean
Visual C++
public:
property bool IsReferenceLine {
    bool get ();
    void set (bool value);
}

See Also

CurveByPoints Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
CurveByPoints..::.Parameter Property
CurveByPoints Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

CurveByPoints Class
CurveByPoints Members
Autodesk.Revit.Elements Namespace


ReferenceType Property

[image]

Revit 2010 API
CurveByPoints..::.ReferenceType Property
CurveByPoints Class See Also Send Feedback
Indicates the type of reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferenceType ReferenceType { get; set; }
Visual Basic (Declaration)
Public Property ReferenceType As ReferenceType
Visual C++
public:
property ReferenceType ReferenceType {
    ReferenceType get ();
    void set (ReferenceType value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when argument is out of range.
System..::.InvalidOperationException | Thrown when regeneration failed.

See Also

CurveByPoints Class
Autodesk.Revit.Elements Namespace


SketchPlane Property

[image]

Revit 2010 API
CurveByPoints..::.SketchPlane Property
CurveByPoints Class See Also Send Feedback
Override the SketchPlane property of CurveElement.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override SketchPlane SketchPlane { get; set; }
Visual Basic (Declaration)
Public Overrides Property SketchPlane As SketchPlane
Visual C++
public:
virtual property SketchPlane^ SketchPlane {
    SketchPlane^ get () override;
    void set (SketchPlane^ value) override;
}

Remarks

CurveByPoints has no associated SketchPlane. Getting this property returns null. Setting it causes an InvalidOperationException.

See Also

CurveByPoints Class
Autodesk.Revit.Elements Namespace


Subcategory Property

[image]

Revit 2010 API
CurveByPoints..::.Subcategory Property
CurveByPoints Class See Also Send Feedback
The subcategory, or graphics style, of the CurveByPoints.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GraphicsStyle Subcategory { get; set; }
Visual Basic (Declaration)
Public Property Subcategory As GraphicsStyle
Visual C++
public:
property GraphicsStyle^ Subcategory {
    GraphicsStyle^ get ();
    void set (GraphicsStyle^ value);
}

Remarks

If the family category is non-cuttable, the subcategory can be set to be the family category or one of its subcategories. If the family category is cuttable, the subcategory can be set as the graphics styles of the family category, its subcategories, or the invisible lines graphics style.

See Also

CurveByPoints Class
Autodesk.Revit.Elements Namespace


Visible Property

[image]

Revit 2010 API
CurveByPoints..::.Visible Property
CurveByPoints Class See Also Send Feedback
Whether the point is visible when the family is loaded into a project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

See Also

CurveByPoints Class
Autodesk.Revit.Elements Namespace


CurveByPointsArray Class

[image]

Revit 2010 API
CurveByPointsArray Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CurveByPointsArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class CurveByPointsArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurveByPointsArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.CurveByPointsArray

See Also

CurveByPointsArray Members
Autodesk.Revit.Elements Namespace


CurveByPointsArray Members

[image] [image]

Revit 2010 API
CurveByPointsArray Members
CurveByPointsArray Class Constructors Methods Properties See Also Send Feedback

The CurveByPointsArray type exposes the following members.

Constructors

Name | Description
CurveByPointsArray | Initializes a new instance of the CurveByPointsArray class

Methods

Name | Description
Append |
Clear |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item |
Size |

See Also

CurveByPointsArray Class
Autodesk.Revit.Elements Namespace


CurveByPointsArray Constructor

[image]

Revit 2010 API
CurveByPointsArray Constructor
CurveByPointsArray Class See Also Send Feedback
Initializes a new instance of the CurveByPointsArray class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveByPointsArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurveByPointsArray()

See Also

CurveByPointsArray Class
Autodesk.Revit.Elements Namespace


CurveByPointsArray Methods

[image] [image]

Revit 2010 API
CurveByPointsArray Methods
CurveByPointsArray Class See Also Send Feedback

The CurveByPointsArray type exposes the following members.

Methods

Name | Description
Append |
Clear |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveByPointsArray Class
Autodesk.Revit.Elements Namespace


Append Method

[image]

Revit 2010 API
CurveByPointsArray..::.Append Method
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    CurveByPoints item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As CurveByPoints _
)
Visual C++
public:
virtual void Append(
    CurveByPoints^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.CurveByPoints

See Also

CurveByPointsArray Class
Autodesk.Revit.Elements Namespace


Clear Method

[image]

Revit 2010 API
CurveByPointsArray..::.Clear Method
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CurveByPointsArray Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

[image]

Revit 2010 API
CurveByPointsArray..::.ForwardIterator Method
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CurveByPointsArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CurveByPointsArrayIterator
Visual C++
public:
virtual CurveByPointsArrayIterator^ ForwardIterator()

See Also

CurveByPointsArray Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

[image]

Revit 2010 API
CurveByPointsArray..::.GetEnumerator Method
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CurveByPointsArray Class
Autodesk.Revit.Elements Namespace


Insert Method

[image]

Revit 2010 API
CurveByPointsArray..::.Insert Method
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    CurveByPoints item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As CurveByPoints, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    CurveByPoints^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Elements..::.CurveByPoints
index
Type: System..::.Int32

See Also

CurveByPointsArray Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

[image]

Revit 2010 API
CurveByPointsArray..::.ReverseIterator Method
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CurveByPointsArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CurveByPointsArrayIterator
Visual C++
public:
virtual CurveByPointsArrayIterator^ ReverseIterator()

See Also

CurveByPointsArray Class
Autodesk.Revit.Elements Namespace


CurveByPointsArray Properties

[image] [image]

Revit 2010 API
CurveByPointsArray Properties
CurveByPointsArray Class See Also Send Feedback

The CurveByPointsArray type exposes the following members.

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item |
Size |

See Also

CurveByPointsArray Class
Autodesk.Revit.Elements Namespace


IsEmpty Property

[image]

Revit 2010 API
CurveByPointsArray..::.IsEmpty Property
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

CurveByPointsArray Class
Autodesk.Revit.Elements Namespace


Item Property

[image]

Revit 2010 API
CurveByPointsArray..::.Item Property
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CurveByPoints Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As CurveByPoints
Visual C++
public:
virtual property CurveByPoints^ Item[int index] {
    CurveByPoints^ get (int index);
    void set (int index, CurveByPoints^ value);
}

Parameters

index
Type: System..::.Int32

See Also

CurveByPointsArray Class
Autodesk.Revit.Elements Namespace


Size Property

[image]

Revit 2010 API
CurveByPointsArray..::.Size Property
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurveByPointsArray Class
Autodesk.Revit.Elements Namespace


CurveByPointsArrayIterator Class

[image]

Revit 2010 API
CurveByPointsArrayIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class CurveByPointsArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CurveByPointsArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CurveByPointsArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.CurveByPointsArrayIterator

See Also

CurveByPointsArrayIterator Members
Autodesk.Revit.Elements Namespace


CurveByPointsArrayIterator Members

[image] [image]

Revit 2010 API
CurveByPointsArrayIterator Members
CurveByPointsArrayIterator Class Constructors Methods Properties See Also Send Feedback

The CurveByPointsArrayIterator type exposes the following members.

Constructors

Name | Description
CurveByPointsArrayIterator | Initializes a new instance of the CurveByPointsArrayIterator class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveByPointsArrayIterator Class
Autodesk.Revit.Elements Namespace


CurveByPointsArrayIterator Constructor

[image]

Revit 2010 API
CurveByPointsArrayIterator Constructor
CurveByPointsArrayIterator Class See Also Send Feedback
Initializes a new instance of the CurveByPointsArrayIterator class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveByPointsArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurveByPointsArrayIterator()

See Also

CurveByPointsArrayIterator Class
Autodesk.Revit.Elements Namespace


CurveByPointsArrayIterator Methods

[image] [image]

Revit 2010 API
CurveByPointsArrayIterator Methods
CurveByPointsArrayIterator Class See Also Send Feedback

The CurveByPointsArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveByPointsArrayIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

[image]

Revit 2010 API
CurveByPointsArrayIterator..::.MoveNext Method
CurveByPointsArrayIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::.MoveNext()()()

See Also

CurveByPointsArrayIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

[image]

Revit 2010 API
CurveByPointsArrayIterator..::.Reset Method
CurveByPointsArrayIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

See Also

CurveByPointsArrayIterator Class
Autodesk.Revit.Elements Namespace


CurveByPointsArrayIterator Properties

[image] [image]

Revit 2010 API
CurveByPointsArrayIterator Properties
CurveByPointsArrayIterator Class See Also Send Feedback

The CurveByPointsArrayIterator type exposes the following members.

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveByPointsArrayIterator Class
Autodesk.Revit.Elements Namespace


Current Property

[image]

Revit 2010 API
CurveByPointsArrayIterator..::.Current Property
CurveByPointsArrayIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

See Also

CurveByPointsArrayIterator Class
Autodesk.Revit.Elements Namespace


CurveElement Class

[image]

Revit 2010 API
CurveElement Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CurveElement : Element
Visual Basic (Declaration)
Public Class CurveElement _
    Inherits Element
Visual C++
public ref class CurveElement : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CurveElement
Autodesk.Revit.Elements..::.CurveByPoints
Autodesk.Revit.Elements..::.DetailCurve
Autodesk.Revit.Elements..::.ModelCurve
Autodesk.Revit.Elements..::.SymbolicCurve

See Also

CurveElement Members
Autodesk.Revit.Elements Namespace


CurveElement Members

[image] [image]

Revit 2010 API
CurveElement Members
CurveElement Class Constructors Methods Properties See Also Send Feedback

The CurveElement type exposes the following members.

Constructors

Name | Description
CurveElement | Initializes a new instance of the CurveElement class

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element.
LineStyles | All available line styles.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CurveElement Class
Autodesk.Revit.Elements Namespace


CurveElement Constructor

[image]

Revit 2010 API
CurveElement Constructor
CurveElement Class See Also Send Feedback
Initializes a new instance of the CurveElement class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveElement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurveElement()

See Also

CurveElement Class
Autodesk.Revit.Elements Namespace


CurveElement Methods

[image] [image]

Revit 2010 API
CurveElement Methods
CurveElement Class See Also Send Feedback

The CurveElement type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveElement Class
Autodesk.Revit.Elements Namespace


CurveElement Properties

[image] [image]

Revit 2010 API
CurveElement Properties
CurveElement Class See Also Send Feedback

The CurveElement type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element.
LineStyles | All available line styles.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CurveElement Class
Autodesk.Revit.Elements Namespace


GeometryCurve Property

[image]

Revit 2010 API
CurveElement..::.GeometryCurve Property
CurveElement Class See Also Send Feedback
Geometry curve of the curve element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve GeometryCurve { get; set; }
Visual Basic (Declaration)
Public Property GeometryCurve As Curve
Visual C++
public:
property Curve^ GeometryCurve {
    Curve^ get ();
    void set (Curve^ value);
}

Remarks

Because there are no corresponding geometry curve type for HermiteSpline, for this type only general Geometry::Curve object will be returned.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when argument is null.
System..::.ArgumentException | Thrown when try to set a curve of different type.

See Also

CurveElement Class
Autodesk.Revit.Elements Namespace


LineStyle Property

[image]

Revit 2010 API
CurveElement..::.LineStyle Property
CurveElement Class See Also Send Feedback
The line style of this curve element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element LineStyle { get; set; }
Visual Basic (Declaration)
Public Property LineStyle As Element
Visual C++
public:
property Element^ LineStyle {
    Element^ get ();
    void set (Element^ value);
}

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when argument is null.
System..::.InvalidOperationException | Thrown when regeneration failed. Thrown when fail to get line style.

See Also

CurveElement Class
Autodesk.Revit.Elements Namespace


LineStyles Property

[image]

Revit 2010 API
CurveElement..::.LineStyles Property
CurveElement Class See Also Send Feedback
All available line styles.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementArray LineStyles { get; }
Visual Basic (Declaration)
Public ReadOnly Property LineStyles As ElementArray
Visual C++
public:
property ElementArray^ LineStyles {
    ElementArray^ get ();
}

See Also

CurveElement Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
CurveElement..::.Parameter Property
CurveElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

CurveElement Class
CurveElement Members
Autodesk.Revit.Elements Namespace


SketchPlane Property

[image]

Revit 2010 API
CurveElement..::.SketchPlane Property
CurveElement Class See Also Send Feedback
The sketch plane the curve element lies in.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual SketchPlane SketchPlane { get; set; }
Visual Basic (Declaration)
Public Overridable Property SketchPlane As SketchPlane
Visual C++
public:
virtual property SketchPlane^ SketchPlane {
    SketchPlane^ get ();
    void set (SketchPlane^ value);
}

Remarks

The new sketch plane must be parallel to the existing sketch plane. Setting this property is not permitted for detail curves because they must be placed only on view-specific planes.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when argument is null.
System..::.InvalidOperationException | Thrown when the modification failed, when the sketch plane is not parallel to the existing plane, or when this property is set on a DetailCurve.

See Also

CurveElement Class
Autodesk.Revit.Elements Namespace


DesignOption Class

[image]

Revit 2010 API
DesignOption Class
Members See Also Send Feedback
An element that represents a design alternative.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DesignOption : Element
Visual Basic (Declaration)
Public Class DesignOption _
    Inherits Element
Visual C++
public ref class DesignOption : public Element

Remarks

Design options enable the user to add alternative designs within the same project. Each element can either be in a design option or not at all, in which case it is considered to be part of the main model and have no design alternatives.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.DesignOption

See Also

DesignOption Members
Autodesk.Revit.Elements Namespace


DesignOption Members

[image] [image]

Revit 2010 API
DesignOption Members
DesignOption Class Constructors Methods Properties See Also Send Feedback

The DesignOption type exposes the following members.

Constructors

Name | Description
DesignOption | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DesignOption Class
Autodesk.Revit.Elements Namespace


DesignOption Constructor

[image]

Revit 2010 API
DesignOption Constructor
DesignOption Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DesignOption()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DesignOption()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DesignOption Class
Autodesk.Revit.Elements Namespace


DesignOption Methods

[image] [image]

Revit 2010 API
DesignOption Methods
DesignOption Class See Also Send Feedback

The DesignOption type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DesignOption Class
Autodesk.Revit.Elements Namespace


DesignOption Properties

[image] [image]

Revit 2010 API
DesignOption Properties
DesignOption Class See Also Send Feedback

The DesignOption type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DesignOption Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
DesignOption..::.Parameter Property
DesignOption Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DesignOption Class
DesignOption Members
Autodesk.Revit.Elements Namespace


DetailArc Class

[image]

Revit 2010 API
DetailArc Class
Members See Also Send Feedback
Represents a DetailArc within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DetailArc : DetailCurve
Visual Basic (Declaration)
Public Class DetailArc _
    Inherits DetailCurve
Visual C++
public ref class DetailArc : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CurveElement
Autodesk.Revit.Elements..::.DetailCurve
Autodesk.Revit.Elements..::.DetailArc

See Also

DetailArc Members
Autodesk.Revit.Elements Namespace


DetailArc Members

[image] [image]

Revit 2010 API
DetailArc Members
DetailArc Class Constructors Methods Properties See Also Send Feedback

The DetailArc type exposes the following members.

Constructors

Name | Description
DetailArc | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DetailArc Class
Autodesk.Revit.Elements Namespace


DetailArc Constructor

[image]

Revit 2010 API
DetailArc Constructor
DetailArc Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DetailArc()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DetailArc()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DetailArc Class
Autodesk.Revit.Elements Namespace


DetailArc Methods

[image] [image]

Revit 2010 API
DetailArc Methods
DetailArc Class See Also Send Feedback

The DetailArc type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailArc Class
Autodesk.Revit.Elements Namespace


DetailArc Properties

[image] [image]

Revit 2010 API
DetailArc Properties
DetailArc Class See Also Send Feedback

The DetailArc type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DetailArc Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
DetailArc..::.Parameter Property
DetailArc Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DetailArc Class
DetailArc Members
Autodesk.Revit.Elements Namespace


DetailCurve Class

[image]

Revit 2010 API
DetailCurve Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DetailCurve : CurveElement
Visual Basic (Declaration)
Public Class DetailCurve _
    Inherits CurveElement
Visual C++
public ref class DetailCurve : public CurveElement

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CurveElement
Autodesk.Revit.Elements..::.DetailCurve
Autodesk.Revit.Elements..::.DetailArc
Autodesk.Revit.Elements..::.DetailEllipse
Autodesk.Revit.Elements..::.DetailLine
Autodesk.Revit.Elements..::.DetailNurbSpline

See Also

DetailCurve Members
Autodesk.Revit.Elements Namespace


DetailCurve Members

[image] [image]

Revit 2010 API
DetailCurve Members
DetailCurve Class Constructors Methods Properties See Also Send Feedback

The DetailCurve type exposes the following members.

Constructors

Name | Description
DetailCurve | Initializes a new instance of the DetailCurve class

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DetailCurve Class
Autodesk.Revit.Elements Namespace


DetailCurve Constructor

[image]

Revit 2010 API
DetailCurve Constructor
DetailCurve Class See Also Send Feedback
Initializes a new instance of the DetailCurve class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DetailCurve()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DetailCurve()

See Also

DetailCurve Class
Autodesk.Revit.Elements Namespace


DetailCurve Methods

[image] [image]

Revit 2010 API
DetailCurve Methods
DetailCurve Class See Also Send Feedback

The DetailCurve type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailCurve Class
Autodesk.Revit.Elements Namespace


DetailCurve Properties

[image] [image]

Revit 2010 API
DetailCurve Properties
DetailCurve Class See Also Send Feedback

The DetailCurve type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DetailCurve Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
DetailCurve..::.Parameter Property
DetailCurve Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DetailCurve Class
DetailCurve Members
Autodesk.Revit.Elements Namespace


DetailCurveArray Class

[image]

Revit 2010 API
DetailCurveArray Class
Members See Also Send Feedback
An array that can contain any type of object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DetailCurveArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class DetailCurveArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DetailCurveArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.DetailCurveArray

See Also

DetailCurveArray Members
Autodesk.Revit.Elements Namespace


DetailCurveArray Members

[image] [image]

Revit 2010 API
DetailCurveArray Members
DetailCurveArray Class Constructors Methods Properties See Also Send Feedback

The DetailCurveArray type exposes the following members.

Constructors

Name | Description
DetailCurveArray | Initializes a new instance of the DetailCurveArray class

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


DetailCurveArray Constructor

[image]

Revit 2010 API
DetailCurveArray Constructor
DetailCurveArray Class See Also Send Feedback
Initializes a new instance of the DetailCurveArray class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DetailCurveArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DetailCurveArray()

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


DetailCurveArray Methods

[image] [image]

Revit 2010 API
DetailCurveArray Methods
DetailCurveArray Class See Also Send Feedback

The DetailCurveArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


Append Method

[image]

Revit 2010 API
DetailCurveArray..::.Append Method
DetailCurveArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    DetailCurve item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As DetailCurve _
)
Visual C++
public:
virtual void Append(
    DetailCurve^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.DetailCurve

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


Clear Method

[image]

Revit 2010 API
DetailCurveArray..::.Clear Method
DetailCurveArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

[image]

Revit 2010 API
DetailCurveArray..::.ForwardIterator Method
DetailCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DetailCurveArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DetailCurveArrayIterator
Visual C++
public:
virtual DetailCurveArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

[image]

Revit 2010 API
DetailCurveArray..::.GetEnumerator Method
DetailCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


Insert Method

[image]

Revit 2010 API
DetailCurveArray..::.Insert Method
DetailCurveArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    DetailCurve item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As DetailCurve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    DetailCurve^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Elements..::.DetailCurve
index
Type: System..::.Int32

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

[image]

Revit 2010 API
DetailCurveArray..::.ReverseIterator Method
DetailCurveArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DetailCurveArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DetailCurveArrayIterator
Visual C++
public:
virtual DetailCurveArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


DetailCurveArray Properties

[image] [image]

Revit 2010 API
DetailCurveArray Properties
DetailCurveArray Class See Also Send Feedback

The DetailCurveArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


IsEmpty Property

[image]

Revit 2010 API
DetailCurveArray..::.IsEmpty Property
DetailCurveArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


Item Property

[image]

Revit 2010 API
DetailCurveArray..::.Item Property
DetailCurveArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DetailCurve Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As DetailCurve
Visual C++
public:
virtual property DetailCurve^ Item[int index] {
    DetailCurve^ get (int index);
    void set (int index, DetailCurve^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


Size Property

[image]

Revit 2010 API
DetailCurveArray..::.Size Property
DetailCurveArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DetailCurveArray Class
Autodesk.Revit.Elements Namespace


DetailCurveArrayIterator Class

[image]

Revit 2010 API
DetailCurveArrayIterator Class
Members See Also Send Feedback
An iterator to a array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class DetailCurveArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class DetailCurveArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DetailCurveArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.DetailCurveArrayIterator

See Also

DetailCurveArrayIterator Members
Autodesk.Revit.Elements Namespace


DetailCurveArrayIterator Members

[image] [image]

Revit 2010 API
DetailCurveArrayIterator Members
DetailCurveArrayIterator Class Constructors Methods Properties See Also Send Feedback

The DetailCurveArrayIterator type exposes the following members.

Constructors

Name | Description
DetailCurveArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DetailCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


DetailCurveArrayIterator Constructor

[image]

Revit 2010 API
DetailCurveArrayIterator Constructor
DetailCurveArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DetailCurveArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DetailCurveArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DetailCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


DetailCurveArrayIterator Methods

[image] [image]

Revit 2010 API
DetailCurveArrayIterator Methods
DetailCurveArrayIterator Class See Also Send Feedback

The DetailCurveArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

[image]

Revit 2010 API
DetailCurveArrayIterator..::.MoveNext Method
DetailCurveArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DetailCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

[image]

Revit 2010 API
DetailCurveArrayIterator..::.Reset Method
DetailCurveArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DetailCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


DetailCurveArrayIterator Properties

[image] [image]

Revit 2010 API
DetailCurveArrayIterator Properties
DetailCurveArrayIterator Class See Also Send Feedback

The DetailCurveArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DetailCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


Current Property

[image]

Revit 2010 API
DetailCurveArrayIterator..::.Current Property
DetailCurveArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DetailCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


DetailEllipse Class

[image]

Revit 2010 API
DetailEllipse Class
Members See Also Send Feedback
Represents a DetailEllipse within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DetailEllipse : DetailCurve
Visual Basic (Declaration)
Public Class DetailEllipse _
    Inherits DetailCurve
Visual C++
public ref class DetailEllipse : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CurveElement
Autodesk.Revit.Elements..::.DetailCurve
Autodesk.Revit.Elements..::.DetailEllipse

See Also

DetailEllipse Members
Autodesk.Revit.Elements Namespace


DetailEllipse Members

[image] [image]

Revit 2010 API
DetailEllipse Members
DetailEllipse Class Constructors Methods Properties See Also Send Feedback

The DetailEllipse type exposes the following members.

Constructors

Name | Description
DetailEllipse | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DetailEllipse Class
Autodesk.Revit.Elements Namespace


DetailEllipse Constructor

[image]

Revit 2010 API
DetailEllipse Constructor
DetailEllipse Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DetailEllipse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DetailEllipse()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DetailEllipse Class
Autodesk.Revit.Elements Namespace


DetailEllipse Methods

[image] [image]

Revit 2010 API
DetailEllipse Methods
DetailEllipse Class See Also Send Feedback

The DetailEllipse type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailEllipse Class
Autodesk.Revit.Elements Namespace


DetailEllipse Properties

[image] [image]

Revit 2010 API
DetailEllipse Properties
DetailEllipse Class See Also Send Feedback

The DetailEllipse type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DetailEllipse Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
DetailEllipse..::.Parameter Property
DetailEllipse Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DetailEllipse Class
DetailEllipse Members
Autodesk.Revit.Elements Namespace


DetailLine Class

[image]

Revit 2010 API
DetailLine Class
Members See Also Send Feedback
Represents a DetailLine within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DetailLine : DetailCurve
Visual Basic (Declaration)
Public Class DetailLine _
    Inherits DetailCurve
Visual C++
public ref class DetailLine : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CurveElement
Autodesk.Revit.Elements..::.DetailCurve
Autodesk.Revit.Elements..::.DetailLine

See Also

DetailLine Members
Autodesk.Revit.Elements Namespace


DetailLine Members

[image] [image]

Revit 2010 API
DetailLine Members
DetailLine Class Constructors Methods Properties See Also Send Feedback

The DetailLine type exposes the following members.

Constructors

Name | Description
DetailLine | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DetailLine Class
Autodesk.Revit.Elements Namespace


DetailLine Constructor

[image]

Revit 2010 API
DetailLine Constructor
DetailLine Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DetailLine()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DetailLine()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DetailLine Class
Autodesk.Revit.Elements Namespace


DetailLine Methods

[image] [image]

Revit 2010 API
DetailLine Methods
DetailLine Class See Also Send Feedback

The DetailLine type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailLine Class
Autodesk.Revit.Elements Namespace


DetailLine Properties

[image] [image]

Revit 2010 API
DetailLine Properties
DetailLine Class See Also Send Feedback

The DetailLine type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DetailLine Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
DetailLine..::.Parameter Property
DetailLine Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DetailLine Class
DetailLine Members
Autodesk.Revit.Elements Namespace


DetailNurbSpline Class

[image]

Revit 2010 API
DetailNurbSpline Class
Members See Also Send Feedback
Represents a DetailNurbSpline within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DetailNurbSpline : DetailCurve
Visual Basic (Declaration)
Public Class DetailNurbSpline _
    Inherits DetailCurve
Visual C++
public ref class DetailNurbSpline : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CurveElement
Autodesk.Revit.Elements..::.DetailCurve
Autodesk.Revit.Elements..::.DetailNurbSpline

See Also

DetailNurbSpline Members
Autodesk.Revit.Elements Namespace


DetailNurbSpline Members

[image] [image]

Revit 2010 API
DetailNurbSpline Members
DetailNurbSpline Class Constructors Methods Properties See Also Send Feedback

The DetailNurbSpline type exposes the following members.

Constructors

Name | Description
DetailNurbSpline | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DetailNurbSpline Class
Autodesk.Revit.Elements Namespace


DetailNurbSpline Constructor

[image]

Revit 2010 API
DetailNurbSpline Constructor
DetailNurbSpline Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DetailNurbSpline()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DetailNurbSpline()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DetailNurbSpline Class
Autodesk.Revit.Elements Namespace


DetailNurbSpline Methods

[image] [image]

Revit 2010 API
DetailNurbSpline Methods
DetailNurbSpline Class See Also Send Feedback

The DetailNurbSpline type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailNurbSpline Class
Autodesk.Revit.Elements Namespace


DetailNurbSpline Properties

[image] [image]

Revit 2010 API
DetailNurbSpline Properties
DetailNurbSpline Class See Also Send Feedback

The DetailNurbSpline type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DetailNurbSpline Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
DetailNurbSpline..::.Parameter Property
DetailNurbSpline Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DetailNurbSpline Class
DetailNurbSpline Members
Autodesk.Revit.Elements Namespace


Dimension Class

[image]

Revit 2010 API
Dimension Class
Members Example See Also Send Feedback
An object that represents a dimension within the Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Dimension : Element
Visual Basic (Declaration)
Public Class Dimension _
    Inherits Element
Visual C++
public ref class Dimension : public Element

Examples

CopyC#
public void GetInfo_Dimension(Dimension dimension)
{
    string message = "Dimension : ";
    // Get Dimension name
    message += "\nDimension name is : " + dimension.Name;

    // Get Dimension Curve
    Autodesk.Revit.Geometry.Curve curve = dimension.Curve;
    if (curve != null && curve.IsBound)
    {
        // Get curve start point
        message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
             + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        // Get curve end point
        message += "; Curve end point:(" + curve.get_EndPoint(1).X + ", "
             + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
    }

    // Get Dimension type name
    message += "\nDimension type name is : " + dimension.DimensionType.Name;

    // Get Dimension view name
    message += "\nDimension view name is : " + dimension.View.ViewName;

    // Get Dimension reference count
    message += "\nDimension references count is " + dimension.References.Size;

    if ((int)BuiltInCategory.OST_Dimensions == dimension.Category.Id.Value)
    {
        message += "\nDimension is a permanent dimension.";
    }
    else if ((int)BuiltInCategory.OST_Constraints == dimension.Category.Id.Value)
    {
        message += "\nDimension is a constraint element.";
    }

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_Dimension(ByVal dimension As Autodesk.Revit.Elements.Dimension)
    Dim message As String = "Dimension : "
    ' Get Dimension name
    message += vbLf & "Dimension name is : " & dimension.Name

    ' Get Dimension Curve
    Dim curve As Autodesk.Revit.Geometry.Curve = dimension.Curve
    If curve IsNot Nothing AndAlso curve.IsBound Then
        ' Get curve start point
        message += ((vbLf & "Curve start point:(" & curve.EndPoint(0).X & ", ") + curve.EndPoint(0).Y & ", ") + curve.EndPoint(0).Z & ")"
        ' Get curve end point
        message += (("; Curve end point:(" & curve.EndPoint(1).X & ", ") + curve.EndPoint(1).Y & ", ") + curve.EndPoint(1).Z & ")"
    End If

    ' Get Dimension type name
    message += vbLf & "Dimension type name is : " & dimension.DimensionType.Name

    ' Get Dimension view name
    message += vbLf & "Dimension view name is : " & dimension.View.ViewName

    ' Get Dimension reference count
    message += vbLf & "Dimension references count is " & dimension.References.Size

    If CInt(BuiltInCategory.OST_Dimensions) = dimension.Category.Id.Value Then
        message += vbLf & "Dimension is a permanent dimension."
    ElseIf CInt(BuiltInCategory.OST_Constraints) = dimension.Category.Id.Value Then
        message += vbLf & "Dimension is a constraint element."
    End If

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Dimension
Autodesk.Revit.Elements..::.SpotDimension

See Also

Dimension Members
Autodesk.Revit.Elements Namespace


Dimension Members

[image] [image]

Revit 2010 API
Dimension Members
Dimension Class Constructors Methods Properties See Also Send Feedback

The Dimension type exposes the following members.

Constructors

Name | Description
Dimension | Initializes a new instance of the Dimension class

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AreSegmentsEqual | Indicates if all segments are forced to be equal.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | A curve that represents the dimension line.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DimensionShape | The shape of this dimension.
DimensionType | The dimension style of this dimension.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsLocked | Indicates if this dimension is locked.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Label | The family parameter label of the dimension.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Retrieve or Change the name associated with the Dimension.
NumberOfSegments | The number of segments for the dimension.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
References | Returns an array of geometric references to which the dimension is attached.
Segments | The segments in the dimension.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Value | The value of the dimension.
ValueString | The dimension value as a user visible string.
View | Supplies the view that contains the dimension if the dimension is view specific.

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


Dimension Constructor

[image]

Revit 2010 API
Dimension Constructor
Dimension Class See Also Send Feedback
Initializes a new instance of the Dimension class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Dimension()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Dimension()

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


Dimension Methods

[image] [image]

Revit 2010 API
Dimension Methods
Dimension Class See Also Send Feedback

The Dimension type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


Dimension Properties

[image] [image]

Revit 2010 API
Dimension Properties
Dimension Class See Also Send Feedback

The Dimension type exposes the following members.

Properties

Name | Description
AreSegmentsEqual | Indicates if all segments are forced to be equal.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | A curve that represents the dimension line.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DimensionShape | The shape of this dimension.
DimensionType | The dimension style of this dimension.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsLocked | Indicates if this dimension is locked.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Label | The family parameter label of the dimension.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Retrieve or Change the name associated with the Dimension.
NumberOfSegments | The number of segments for the dimension.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
References | Returns an array of geometric references to which the dimension is attached.
Segments | The segments in the dimension.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Value | The value of the dimension.
ValueString | The dimension value as a user visible string.
View | Supplies the view that contains the dimension if the dimension is view specific.

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


AreSegmentsEqual Property

[image]

Revit 2010 API
Dimension..::.AreSegmentsEqual Property
Dimension Class See Also Send Feedback
Indicates if all segments are forced to be equal.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool AreSegmentsEqual { get; set; }
Visual Basic (Declaration)
Public Property AreSegmentsEqual As Boolean
Visual C++
public:
property bool AreSegmentsEqual {
    bool get ();
    void set (bool value);
}

Remarks

This property is usable only for linear dimensions with more than one segment.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the dimension is non-linear or has only one segment.

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


Curve Property

[image]

Revit 2010 API
Dimension..::.Curve Property
Dimension Class See Also Send Feedback
A curve that represents the dimension line.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


DimensionShape Property

[image]

Revit 2010 API
Dimension..::.DimensionShape Property
Dimension Class See Also Send Feedback
The shape of this dimension.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DimensionShape DimensionShape { get; }
Visual Basic (Declaration)
Public ReadOnly Property DimensionShape As DimensionShape
Visual C++
public:
property DimensionShape DimensionShape {
    DimensionShape get ();
}

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


DimensionType Property

[image]

Revit 2010 API
Dimension..::.DimensionType Property
Dimension Class See Also Send Feedback
The dimension style of this dimension.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DimensionType DimensionType { get; set; }
Visual Basic (Declaration)
Public Property DimensionType As DimensionType
Visual C++
public:
property DimensionType^ DimensionType {
    DimensionType^ get ();
    void set (DimensionType^ value);
}

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


IsLocked Property

[image]

Revit 2010 API
Dimension..::.IsLocked Property
Dimension Class See Also Send Feedback
Indicates if this dimension is locked.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsLocked { get; set; }
Visual Basic (Declaration)
Public Property IsLocked As Boolean
Visual C++
public:
property bool IsLocked {
    bool get ();
    void set (bool value);
}

Remarks

This property always returns false if the dimension is a radial or spot dimension. This property cannot be set if the dimension has been labeled, or if the dimension shape is radial or spot, or if the dimension is linear with more than one segment.

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


Label Property

[image]

Revit 2010 API
Dimension..::.Label Property
Dimension Class See Also Send Feedback
The family parameter label of the dimension.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyParameter Label { get; set; }
Visual Basic (Declaration)
Public Property Label As FamilyParameter
Visual C++
public:
property FamilyParameter^ Label {
    FamilyParameter^ get ();
    void set (FamilyParameter^ value);
}

Remarks

A dimension only can be labeled in a family document. Multi-segmented linear dimensions cannot be labeled.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the family parameter is null.
System..::.ArgumentException | Thrown when the family parameter's ParameterType is not suitable for this dimension.
System..::.NotSupportedException | Thrown when dimension can not be labeled.
System..::.InvalidOperationException | Thrown when failed to get the BuiltInParameter DIM_LABEL.

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


Name Property

[image]

Revit 2010 API
Dimension..::.Name Property
Dimension Class See Also Send Feedback
Retrieve or Change the name associated with the Dimension.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

The property inherited from element is hidden, a System.InvalidOperationException is thrown.

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


NumberOfSegments Property

[image]

Revit 2010 API
Dimension..::.NumberOfSegments Property
Dimension Class See Also Send Feedback
The number of segments for the dimension.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NumberOfSegments { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumberOfSegments As Integer
Visual C++
public:
property int NumberOfSegments {
    int get ();
}

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Dimension..::.Parameter Property
Dimension Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Dimension Class
Dimension Members
Autodesk.Revit.Elements Namespace


References Property

[image]

Revit 2010 API
Dimension..::.References Property
Dimension Class See Also Send Feedback
Returns an array of geometric references to which the dimension is attached.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferenceArray References { get; }
Visual Basic (Declaration)
Public ReadOnly Property References As ReferenceArray
Visual C++
public:
property ReferenceArray^ References {
    ReferenceArray^ get ();
}

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


Segments Property

[image]

Revit 2010 API
Dimension..::.Segments Property
Dimension Class See Also Send Feedback
The segments in the dimension.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DimensionSegmentArray Segments { get; }
Visual Basic (Declaration)
Public ReadOnly Property Segments As DimensionSegmentArray
Visual C++
public:
property DimensionSegmentArray^ Segments {
    DimensionSegmentArray^ get ();
}

Remarks

Returns a read only array of segments in the dimension. The references of the dimension can be mapped to segments in order. The first segment here wrapped by first and second references; the nth segment is wrapped by nth and n+1st references.

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


Value Property

[image]

Revit 2010 API
Dimension..::.Value Property
Dimension Class See Also Send Feedback
The value of the dimension.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Nullable<double> Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Nullable(Of Double)
Visual C++
public:
property Nullable<double> Value {
    Nullable<double> get ();
}

Remarks

This nullable property will not have a value for spot dimensions or for linear dimensions with more than one segment.

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


ValueString Property

[image]

Revit 2010 API
Dimension..::.ValueString Property
Dimension Class See Also Send Feedback
The dimension value as a user visible string.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string ValueString { get; }
Visual Basic (Declaration)
Public ReadOnly Property ValueString As String
Visual C++
public:
property String^ ValueString {
    String^ get ();
}

Remarks

This property always return null if this is a spot dimension, or it is a linear dimension with more than one segments.

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


View Property

[image]

Revit 2010 API
Dimension..::.View Property
Dimension Class See Also Send Feedback
Supplies the view that contains the dimension if the dimension is view specific.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public View View { get; }
Visual Basic (Declaration)
Public ReadOnly Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
}

See Also

Dimension Class
Autodesk.Revit.Elements Namespace


DividedSurface Class

[image]

Revit 2010 API
DividedSurface Class
Members See Also Send Feedback
An element that represents a mesh on another element's surface and a tile pattern built on that mesh.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DividedSurface : Element
Visual Basic (Declaration)
Public Class DividedSurface _
    Inherits Element
Visual C++
public ref class DividedSurface : public Element

Remarks

The ObjectType property (inherited from Element) may be set to either of two things: either a TilePattern element, or a FamilySymbol element from a Curtain Panel family.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.DividedSurface

See Also

DividedSurface Members
Autodesk.Revit.Elements Namespace


DividedSurface Members

[image] [image]

Revit 2010 API
DividedSurface Members
DividedSurface Class Constructors Methods Properties See Also Send Feedback

The DividedSurface type exposes the following members.

Constructors

Name | Description
DividedSurface | Initializes a new instance of the DividedSurface class

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetGridNodeLocation | Specify whether a particular grid node is interior to the surface, on the boundary, or outside the boundary.
GetGridNodeReference | Get a reference to the geometric point associated with a grid node.
GetGridNodeUV | Get the position of a grid node in UV coordinates in the surface.
GetGridSegmentReference | Get a reference to a line segment connecting two adjacent grid nodes.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetTileFamilyInstance | Get a reference to a tile element associated with a given seed node.
GetTileReference | Get a reference to one of the tile surfaces associated with a given seed node.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsSeedNode | Reports whether a grid node is a "seed node," a node that is associated with one or more tiles.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllGridRotation | Angle of rotation applied to the U- and V- directions together.
BorderTile | Determines the handling of tiles that overlap the surface's boundary.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ComponentRotation | The rotation of the pattern by a multiple of 90 degrees.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Host | The element whose surface has been divided.
HostReference | A reference to the divided face on the host.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsComponentFlipped | Whether the pattern is flipped.
IsComponentMirrored | Whether the pattern is mirror-imaged.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
NumberOfUGridlines | Get the number of U-gridlines used on the surface.
NumberOfVGridlines | Get the number of V-gridlines used on the surface.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the U-direction.
USpacingRule | Access to the rule for laying out the first series of equidistant parallel lines on the surface.
VPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the V-direction.
VSpacingRule | Access to the rule for laying out the second series of equidistant parallel lines on the surface.

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


DividedSurface Constructor

[image]

Revit 2010 API
DividedSurface Constructor
DividedSurface Class See Also Send Feedback
Initializes a new instance of the DividedSurface class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DividedSurface()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DividedSurface()

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


DividedSurface Methods

[image] [image]

Revit 2010 API
DividedSurface Methods
DividedSurface Class See Also Send Feedback

The DividedSurface type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetGridNodeLocation | Specify whether a particular grid node is interior to the surface, on the boundary, or outside the boundary.
GetGridNodeReference | Get a reference to the geometric point associated with a grid node.
GetGridNodeUV | Get the position of a grid node in UV coordinates in the surface.
GetGridSegmentReference | Get a reference to a line segment connecting two adjacent grid nodes.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetTileFamilyInstance | Get a reference to a tile element associated with a given seed node.
GetTileReference | Get a reference to one of the tile surfaces associated with a given seed node.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsSeedNode | Reports whether a grid node is a "seed node," a node that is associated with one or more tiles.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


GetGridNodeLocation Method

[image]

Revit 2010 API
DividedSurface..::.GetGridNodeLocation Method
DividedSurface Class See Also Send Feedback
Specify whether a particular grid node is interior to the surface, on the boundary, or outside the boundary.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GridNodeLocation GetGridNodeLocation(
    GridNode gridNode
)
Visual Basic (Declaration)
Public Function GetGridNodeLocation ( _
    gridNode As GridNode _
) As GridNodeLocation
Visual C++
public:
GridNodeLocation GetGridNodeLocation(
    GridNode gridNode
)

Parameters

gridNode
Type: Autodesk.Revit.Elements..::.GridNode

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


GetGridNodeReference Method

[image]

Revit 2010 API
DividedSurface..::.GetGridNodeReference Method
DividedSurface Class See Also Send Feedback
Get a reference to the geometric point associated with a grid node.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference GetGridNodeReference(
    GridNode gridNode
)
Visual Basic (Declaration)
Public Function GetGridNodeReference ( _
    gridNode As GridNode _
) As Reference
Visual C++
public:
Reference^ GetGridNodeReference(
    GridNode gridNode
)

Parameters

gridNode
Type: Autodesk.Revit.Elements..::.GridNode

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


GetGridNodeUV Method

[image]

Revit 2010 API
DividedSurface..::.GetGridNodeUV Method
DividedSurface Class See Also Send Feedback
Get the position of a grid node in UV coordinates in the surface.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV GetGridNodeUV(
    GridNode gridNode
)
Visual Basic (Declaration)
Public Function GetGridNodeUV ( _
    gridNode As GridNode _
) As UV
Visual C++
public:
UV^ GetGridNodeUV(
    GridNode gridNode
)

Parameters

gridNode
Type: Autodesk.Revit.Elements..::.GridNode

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


GetGridSegmentReference Method

[image]

Revit 2010 API
DividedSurface..::.GetGridSegmentReference Method
DividedSurface Class See Also Send Feedback
Get a reference to a line segment connecting two adjacent grid nodes.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference GetGridSegmentReference(
    GridNode gridNode,
    GridSegmentDirection gridSegmentDirection
)
Visual Basic (Declaration)
Public Function GetGridSegmentReference ( _
    gridNode As GridNode, _
    gridSegmentDirection As GridSegmentDirection _
) As Reference
Visual C++
public:
Reference^ GetGridSegmentReference(
    GridNode gridNode,
    GridSegmentDirection gridSegmentDirection
)

Parameters

gridNode
Type: Autodesk.Revit.Elements..::.GridNode
gridSegmentDirection
Type: Autodesk.Revit.Enums..::.GridSegmentDirection

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ], or when the adjacent grid node specified by gridSegmentDirection is out of range.

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


GetTileFamilyInstance Method

[image]

Revit 2010 API
DividedSurface..::.GetTileFamilyInstance Method
DividedSurface Class See Also Send Feedback
Get a reference to a tile element associated with a given seed node.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance GetTileFamilyInstance(
    GridNode gridNode,
    int tileIndex
)
Visual Basic (Declaration)
Public Function GetTileFamilyInstance ( _
    gridNode As GridNode, _
    tileIndex As Integer _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ GetTileFamilyInstance(
    GridNode gridNode,
    int tileIndex
)

Parameters

gridNode
Type: Autodesk.Revit.Elements..::.GridNode
tileIndex
Type: System..::.Int32

Return Value

A FamilyInstance object. Returns null if the ObjectType property is not a FamilySymbol. Returns null if the grid node is not a "seed node", or if the tile is omitted due to boundary conditions.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown if the grid node is outside of the range specified by NumberOfUGridlines and NumberOfVGridlines, or if tileIndex is outside the range [0, TilesPerSeedNode-1].

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


GetTileReference Method

[image]

Revit 2010 API
DividedSurface..::.GetTileReference Method
DividedSurface Class See Also Send Feedback
Get a reference to one of the tile surfaces associated with a given seed node.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference GetTileReference(
    GridNode gridNode,
    int tileIndex
)
Visual Basic (Declaration)
Public Function GetTileReference ( _
    gridNode As GridNode, _
    tileIndex As Integer _
) As Reference
Visual C++
public:
Reference^ GetTileReference(
    GridNode gridNode,
    int tileIndex
)

Parameters

gridNode
Type: Autodesk.Revit.Elements..::.GridNode
tileIndex
Type: System..::.Int32
An integer between 0 and T-1, where T is TilesPerSeedNode.

Return Value

A reference to a Face (surface). Returns null if the grid node is not a "seed node", or if the tile is omitted due to boundary conditions.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown if the grid node is outside of the range specified by NumberOfUGridlines and NumberOfVGridlines, or if tileIndex is outside the range [0, TilesPerSeedNode-1].

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


IsSeedNode Method

[image]

Revit 2010 API
DividedSurface..::.IsSeedNode Method
DividedSurface Class See Also Send Feedback
Reports whether a grid node is a "seed node," a node that is associated with one or more tiles.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsSeedNode(
    GridNode gridNode
)
Visual Basic (Declaration)
Public Function IsSeedNode ( _
    gridNode As GridNode _
) As Boolean
Visual C++
public:
bool IsSeedNode(
    GridNode gridNode
)

Parameters

gridNode
Type: Autodesk.Revit.Elements..::.GridNode

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


DividedSurface Properties

[image] [image]

Revit 2010 API
DividedSurface Properties
DividedSurface Class See Also Send Feedback

The DividedSurface type exposes the following members.

Properties

Name | Description
AllGridRotation | Angle of rotation applied to the U- and V- directions together.
BorderTile | Determines the handling of tiles that overlap the surface's boundary.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ComponentRotation | The rotation of the pattern by a multiple of 90 degrees.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Host | The element whose surface has been divided.
HostReference | A reference to the divided face on the host.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsComponentFlipped | Whether the pattern is flipped.
IsComponentMirrored | Whether the pattern is mirror-imaged.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
NumberOfUGridlines | Get the number of U-gridlines used on the surface.
NumberOfVGridlines | Get the number of V-gridlines used on the surface.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the U-direction.
USpacingRule | Access to the rule for laying out the first series of equidistant parallel lines on the surface.
VPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the V-direction.
VSpacingRule | Access to the rule for laying out the second series of equidistant parallel lines on the surface.

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


AllGridRotation Property

[image]

Revit 2010 API
DividedSurface..::.AllGridRotation Property
DividedSurface Class See Also Send Feedback
Angle of rotation applied to the U- and V- directions together.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double AllGridRotation { get; set; }
Visual Basic (Declaration)
Public Property AllGridRotation As Double
Visual C++
public:
property double AllGridRotation {
    double get ();
    void set (double value);
}

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


BorderTile Property

[image]

Revit 2010 API
DividedSurface..::.BorderTile Property
DividedSurface Class See Also Send Feedback
Determines the handling of tiles that overlap the surface's boundary.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BorderTile BorderTile { get; set; }
Visual Basic (Declaration)
Public Property BorderTile As BorderTile
Visual C++
public:
property BorderTile BorderTile {
    BorderTile get ();
    void set (BorderTile value);
}

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


ComponentRotation Property

[image]

Revit 2010 API
DividedSurface..::.ComponentRotation Property
DividedSurface Class See Also Send Feedback
The rotation of the pattern by a multiple of 90 degrees.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ComponentRotation ComponentRotation { get; set; }
Visual Basic (Declaration)
Public Property ComponentRotation As ComponentRotation
Visual C++
public:
property ComponentRotation ComponentRotation {
    ComponentRotation get ();
    void set (ComponentRotation value);
}

Remarks

This property has no effect unless a pattern is selected (the ObjectType property is not null).

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


Host Property

[image]

Revit 2010 API
DividedSurface..::.Host Property
DividedSurface Class See Also Send Feedback
The element whose surface has been divided.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element Host { get; }
Visual Basic (Declaration)
Public ReadOnly Property Host As Element
Visual C++
public:
property Element^ Host {
    Element^ get ();
}

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


HostReference Property

[image]

Revit 2010 API
DividedSurface..::.HostReference Property
DividedSurface Class See Also Send Feedback
A reference to the divided face on the host.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference HostReference { get; }
Visual Basic (Declaration)
Public ReadOnly Property HostReference As Reference
Visual C++
public:
property Reference^ HostReference {
    Reference^ get ();
}

Remarks

This is the same as the hostReference argument to the NewDividedSurface method of FamilyItemFactory.

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


IsComponentFlipped Property

[image]

Revit 2010 API
DividedSurface..::.IsComponentFlipped Property
DividedSurface Class See Also Send Feedback
Whether the pattern is flipped.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsComponentFlipped { get; set; }
Visual Basic (Declaration)
Public Property IsComponentFlipped As Boolean
Visual C++
public:
property bool IsComponentFlipped {
    bool get ();
    void set (bool value);
}

Remarks

This property has no effect unless a pattern is selected (the ObjectType property is not null). Changing this flag effectively reflects the component through its XY-plane, which is equivalent to reflecting it through the original surface.

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


IsComponentMirrored Property

[image]

Revit 2010 API
DividedSurface..::.IsComponentMirrored Property
DividedSurface Class See Also Send Feedback
Whether the pattern is mirror-imaged.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsComponentMirrored { get; set; }
Visual Basic (Declaration)
Public Property IsComponentMirrored As Boolean
Visual C++
public:
property bool IsComponentMirrored {
    bool get ();
    void set (bool value);
}

Remarks

This property has no effect unless a pattern is selected (the ObjectType property is not null). Changing this flag effectively reflects the component through its YZ-plane.

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


NumberOfUGridlines Property

[image]

Revit 2010 API
DividedSurface..::.NumberOfUGridlines Property
DividedSurface Class See Also Send Feedback
Get the number of U-gridlines used on the surface.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NumberOfUGridlines { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumberOfUGridlines As Integer
Visual C++
public:
property int NumberOfUGridlines {
    int get ();
}

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


NumberOfVGridlines Property

[image]

Revit 2010 API
DividedSurface..::.NumberOfVGridlines Property
DividedSurface Class See Also Send Feedback
Get the number of V-gridlines used on the surface.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NumberOfVGridlines { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumberOfVGridlines As Integer
Visual C++
public:
property int NumberOfVGridlines {
    int get ();
}

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
DividedSurface..::.Parameter Property
DividedSurface Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DividedSurface Class
DividedSurface Members
Autodesk.Revit.Elements Namespace


UPatternIndent Property

[image]

Revit 2010 API
DividedSurface..::.UPatternIndent Property
DividedSurface Class See Also Send Feedback
The offset applied to the pattern by an integral number of grid nodes in the U-direction.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int UPatternIndent { get; set; }
Visual Basic (Declaration)
Public Property UPatternIndent As Integer
Visual C++
public:
property int UPatternIndent {
    int get ();
    void set (int value);
}

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


USpacingRule Property

[image]

Revit 2010 API
DividedSurface..::.USpacingRule Property
DividedSurface Class See Also Send Feedback
Access to the rule for laying out the first series of equidistant parallel lines on the surface.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpacingRule USpacingRule { get; }
Visual Basic (Declaration)
Public ReadOnly Property USpacingRule As SpacingRule
Visual C++
public:
property SpacingRule^ USpacingRule {
    SpacingRule^ get ();
}

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


VPatternIndent Property

[image]

Revit 2010 API
DividedSurface..::.VPatternIndent Property
DividedSurface Class See Also Send Feedback
The offset applied to the pattern by an integral number of grid nodes in the V-direction.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int VPatternIndent { get; set; }
Visual Basic (Declaration)
Public Property VPatternIndent As Integer
Visual C++
public:
property int VPatternIndent {
    int get ();
    void set (int value);
}

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


VSpacingRule Property

[image]

Revit 2010 API
DividedSurface..::.VSpacingRule Property
DividedSurface Class See Also Send Feedback
Access to the rule for laying out the second series of equidistant parallel lines on the surface.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpacingRule VSpacingRule { get; }
Visual Basic (Declaration)
Public ReadOnly Property VSpacingRule As SpacingRule
Visual C++
public:
property SpacingRule^ VSpacingRule {
    SpacingRule^ get ();
}

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace


DividedSurfaceData Class

[image]

Revit 2010 API
DividedSurfaceData Class
Members See Also Send Feedback
An interface to the divided surfaces on an element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DividedSurfaceData : APIObject
Visual Basic (Declaration)
Public Class DividedSurfaceData _
    Inherits APIObject
Visual C++
public ref class DividedSurfaceData : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.DividedSurfaceData

See Also

DividedSurfaceData Members
Autodesk.Revit.Elements Namespace


DividedSurfaceData Members

[image] [image]

Revit 2010 API
DividedSurfaceData Members
DividedSurfaceData Class Constructors Methods Properties See Also Send Feedback

The DividedSurfaceData type exposes the following members.

Constructors

Name | Description
DividedSurfaceData | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceForReference | Find the DividedSurface element that is associated with a surface of this element.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetReferencesWithDividedSurfaces | Find the set of references that have associated DividedSurface elements.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DividedSurfaceData Class
Autodesk.Revit.Elements Namespace


DividedSurfaceData Constructor

[image]

Revit 2010 API
DividedSurfaceData Constructor
DividedSurfaceData Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DividedSurfaceData()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DividedSurfaceData()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DividedSurfaceData Class
Autodesk.Revit.Elements Namespace


DividedSurfaceData Methods

[image] [image]

Revit 2010 API
DividedSurfaceData Methods
DividedSurfaceData Class See Also Send Feedback

The DividedSurfaceData type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceForReference | Find the DividedSurface element that is associated with a surface of this element.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetReferencesWithDividedSurfaces | Find the set of references that have associated DividedSurface elements.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DividedSurfaceData Class
Autodesk.Revit.Elements Namespace


GetDividedSurfaceForReference Method

[image]

Revit 2010 API
DividedSurfaceData..::.GetDividedSurfaceForReference Method
DividedSurfaceData Class See Also Send Feedback
Find the DividedSurface element that is associated with a surface of this element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DividedSurface GetDividedSurfaceForReference(
    Reference reference
)
Visual Basic (Declaration)
Public Function GetDividedSurfaceForReference ( _
    reference As Reference _
) As DividedSurface
Visual C++
public:
DividedSurface^ GetDividedSurfaceForReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.Geometry..::.Reference

Return Value

A DividedSurface element, if there is one associated with this face; null if the reference is to a face without a DividedSurface.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when reference is not a face (surface) reference.

See Also

DividedSurfaceData Class
Autodesk.Revit.Elements Namespace


GetReferencesWithDividedSurfaces Method

[image]

Revit 2010 API
DividedSurfaceData..::.GetReferencesWithDividedSurfaces Method
DividedSurfaceData Class See Also Send Feedback
Find the set of references that have associated DividedSurface elements.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferenceArray GetReferencesWithDividedSurfaces()
Visual Basic (Declaration)
Public Function GetReferencesWithDividedSurfaces As ReferenceArray
Visual C++
public:
ReferenceArray^ GetReferencesWithDividedSurfaces()

See Also

DividedSurfaceData Class
Autodesk.Revit.Elements Namespace


DividedSurfaceData Properties

[image] [image]

Revit 2010 API
DividedSurfaceData Properties
DividedSurfaceData Class See Also Send Feedback

The DividedSurfaceData type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DividedSurfaceData Class
Autodesk.Revit.Elements Namespace


ExportComplexity Enumeration

[image]

Revit 2010 API
ExportComplexity Enumeration
See Also Send Feedback
An enumerate type listing all complexity of gbXML export.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ExportComplexity
Visual Basic (Declaration)
Public Enumeration ExportComplexity
Visual C++
public enum class ExportComplexity

Members

Member name | Description
Simple | Simple means that Curtain Walls and Curtain Systems are exported with one “huge” opening with the total opening area equal to all openings; a curtain wall with 50 panels gets exported as 1 opening.
ComplexWithMullionsAndShadingSurfaces | Export with complex type, shading surfaces and mullion. With Mullions mean that Mullions in Curtain Walls and Systems are exported as shading surfaces. A "simplified" analytical shading surface is produced from a mullion based on its centerline, thickness and offset.
ComplexWithShadingSurfaces | Export with complex type and shading surfaces.
Complex | Complex means that Curtain Walls and Curtain Systems are exported with several openings , panel by panel; a curtain wall with 50 panels gets exported as 50 openings.
SimpleWithShadingSurfaces | Export with simple type and shading surfaces.

See Also

Autodesk.Revit.Elements Namespace


Extrusion Class

[image]

Revit 2010 API
Extrusion Class
Members See Also Send Feedback
A extrusion solid or void form.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Extrusion : GenericForm
Visual Basic (Declaration)
Public Class Extrusion _
    Inherits GenericForm
Visual C++
public ref class Extrusion : public GenericForm

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CombinableElement
Autodesk.Revit.Elements..::.GenericForm
Autodesk.Revit.Elements..::.Extrusion

See Also

Extrusion Members
Autodesk.Revit.Elements Namespace


Extrusion Members

[image] [image]

Revit 2010 API
Extrusion Members
Extrusion Class Constructors Methods Properties See Also Send Feedback

The Extrusion type exposes the following members.

Constructors

Name | Description
Extrusion | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EndOffset | The offset of the end of the extrusion relative to the sketch plane.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Sketch | Returns the Sketch of the Extrusion.
StartOffset | The offset of the start of the extrusion relative to the sketch plane.
Subcategory | The subcategory. (Inherited from GenericForm.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Extrusion Class
Autodesk.Revit.Elements Namespace


Extrusion Constructor

[image]

Revit 2010 API
Extrusion Constructor
Extrusion Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Extrusion()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Extrusion()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Extrusion Class
Autodesk.Revit.Elements Namespace


Extrusion Methods

[image] [image]

Revit 2010 API
Extrusion Methods
Extrusion Class See Also Send Feedback

The Extrusion type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Extrusion Class
Autodesk.Revit.Elements Namespace


Extrusion Properties

[image] [image]

Revit 2010 API
Extrusion Properties
Extrusion Class See Also Send Feedback

The Extrusion type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EndOffset | The offset of the end of the extrusion relative to the sketch plane.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Sketch | Returns the Sketch of the Extrusion.
StartOffset | The offset of the start of the extrusion relative to the sketch plane.
Subcategory | The subcategory. (Inherited from GenericForm.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Extrusion Class
Autodesk.Revit.Elements Namespace


EndOffset Property

[image]

Revit 2010 API
Extrusion..::.EndOffset Property
Extrusion Class See Also Send Feedback
The offset of the end of the extrusion relative to the sketch plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double EndOffset { get; set; }
Visual Basic (Declaration)
Public Property EndOffset As Double
Visual C++
public:
property double EndOffset {
    double get ();
    void set (double value);
}

Remarks

The direction of the offset is based on the normal of the extrusion's sketch plane: a positive value is in the direction of the normal, a negative value is in the other direction.

See Also

Extrusion Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Extrusion..::.Parameter Property
Extrusion Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Extrusion Class
Extrusion Members
Autodesk.Revit.Elements Namespace


Sketch Property

[image]

Revit 2010 API
Extrusion..::.Sketch Property
Extrusion Class See Also Send Feedback
Returns the Sketch of the Extrusion.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Sketch Sketch { get; }
Visual Basic (Declaration)
Public ReadOnly Property Sketch As Sketch
Visual C++
public:
property Sketch^ Sketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the Sketchs of the Extrusion.

See Also

Extrusion Class
Autodesk.Revit.Elements Namespace


StartOffset Property

[image]

Revit 2010 API
Extrusion..::.StartOffset Property
Extrusion Class See Also Send Feedback
The offset of the start of the extrusion relative to the sketch plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double StartOffset { get; set; }
Visual Basic (Declaration)
Public Property StartOffset As Double
Visual C++
public:
property double StartOffset {
    double get ();
    void set (double value);
}

Remarks

The direction of the offset is based on the normal of the extrusion's sketch plane: a positive value is in the direction of the normal, a negative value is in the other direction.

See Also

Extrusion Class
Autodesk.Revit.Elements Namespace


ExtrusionRoof Class

[image]

Revit 2010 API
ExtrusionRoof Class
Members See Also Send Feedback
Represents some kinds of Extrusion Roofs.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ExtrusionRoof : RoofBase
Visual Basic (Declaration)
Public Class ExtrusionRoof _
    Inherits RoofBase
Visual C++
public ref class ExtrusionRoof : public RoofBase

Remarks

The ExtrusionRoof object represents some kinds of extrusion roof in Revit. The extrusion roof object is derived from the RoofBase object and hence it supports all the properties and methods of that object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.RoofBase
Autodesk.Revit.Elements..::.ExtrusionRoof

See Also

ExtrusionRoof Members
Autodesk.Revit.Elements Namespace


ExtrusionRoof Members

[image] [image]

Revit 2010 API
ExtrusionRoof Members
ExtrusionRoof Class Constructors Methods Properties See Also Send Feedback

The ExtrusionRoof type exposes the following members.

Constructors

Name | Description
ExtrusionRoof | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetProfile | Retrieve the Profile of ExtrusionRoof.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurtainGrids | Retrieve all the CurtainGrid objects of a curtain Roof.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase.)
FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RoofType | Retrieve or set the Type. (Inherited from RoofBase.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ExtrusionRoof Class
Autodesk.Revit.Elements Namespace


ExtrusionRoof Constructor

[image]

Revit 2010 API
ExtrusionRoof Constructor
ExtrusionRoof Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ExtrusionRoof()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExtrusionRoof()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ExtrusionRoof Class
Autodesk.Revit.Elements Namespace


ExtrusionRoof Methods

[image] [image]

Revit 2010 API
ExtrusionRoof Methods
ExtrusionRoof Class See Also Send Feedback

The ExtrusionRoof type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetProfile | Retrieve the Profile of ExtrusionRoof.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExtrusionRoof Class
Autodesk.Revit.Elements Namespace


GetProfile Method

[image]

Revit 2010 API
ExtrusionRoof..::.GetProfile Method
ExtrusionRoof Class See Also Send Feedback
Retrieve the Profile of ExtrusionRoof.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelCurveArray GetProfile()
Visual Basic (Declaration)
Public Function GetProfile As ModelCurveArray
Visual C++
public:
ModelCurveArray^ GetProfile()

See Also

ExtrusionRoof Class
Autodesk.Revit.Elements Namespace


ExtrusionRoof Properties

[image] [image]

Revit 2010 API
ExtrusionRoof Properties
ExtrusionRoof Class See Also Send Feedback

The ExtrusionRoof type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurtainGrids | Retrieve all the CurtainGrid objects of a curtain Roof.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase.)
FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RoofType | Retrieve or set the Type. (Inherited from RoofBase.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ExtrusionRoof Class
Autodesk.Revit.Elements Namespace


CurtainGrids Property

[image]

Revit 2010 API
ExtrusionRoof..::.CurtainGrids Property
ExtrusionRoof Class See Also Send Feedback
Retrieve all the CurtainGrid objects of a curtain Roof.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainGridSet CurtainGrids { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurtainGrids As CurtainGridSet
Visual C++
public:
property CurtainGridSet^ CurtainGrids {
    CurtainGridSet^ get ();
}

Remarks

Only when the object is a CurtainRoof, this property makes sense.

See Also

ExtrusionRoof Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
ExtrusionRoof..::.Parameter Property
ExtrusionRoof Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ExtrusionRoof Class
ExtrusionRoof Members
Autodesk.Revit.Elements Namespace


Family Class

[image]

Revit 2010 API
Family Class
Members Example See Also Send Feedback
The Family object is a Symbol that defines an entire family.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Family : FamilyBase
Visual Basic (Declaration)
Public Class Family _
    Inherits FamilyBase
Visual C++
public ref class Family : public FamilyBase

Remarks

This object is used mostly to get all the family symbols that belong to the family so that instances can be swapped from one symbol to another. The Family object is derived from the Symbol object and the Element object and as such inherits all the properties and methods of that object. Families within the Revit API represented by three objects - Family, FamilySymbol and FamilyInstance. Each object plays a significant part in the structure of Families. The Family object represents the entire family such as an 'I Beam'. You can think of that object as representing the entire family file on disk. The Family object contains a number of FamilySymbols. The FamilySymbol object represents a specific set of family settings within that Family and represents what is known in the Revit user interface as a Type, such as 'W14x32'. The FamilyInstance object represents an actual instance of that Type (FamilySymbol) within the Autodesk Revit project. For example the FamilyInstance would be a single instance of a W14x32 column within the project. Therefore: Each FamilyInstance has one FamilySymbol, e.g. an instance of a W14x32. Each FamilySymbol belongs to one Family, e.g. the W14x32 symbol belongs to an 'I Beam' family. Each Family will contain one or more FamilySymbols, e.g. the 'I Beam' family contains a W14x32 symbol, a W12x32 symbol etc.

Examples

CopyC#
public void GetInfoForSymbols(Family family)
{
    StringBuilder message = new StringBuilder("Selected element's family name is : " + family.Name);

    if (family.Symbols.IsEmpty)
    {
        message.AppendLine("Contains no family symbols.");
    }
    else
    {
        message.AppendLine("The family symbols contained in this family are : ");

        // Get family symbols which is contained in this family
        foreach (FamilySymbol familySymbol in family.Symbols)
        {
            // Get family symbol name
            message.AppendLine("\nName: " + familySymbol.Name);
            message.AppendLine("\tMaterial: " + familySymbol.Material.ToString());
        }
    }

    MessageBox.Show(message.ToString(), "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfoForSymbols(ByVal family As Autodesk.Revit.Elements.Family)
    Dim message As New StringBuilder("Selected element's family name is : " & family.Name)

    If family.Symbols.IsEmpty Then
        message.AppendLine("Contains no family symbols.")
    Else
        message.AppendLine("The family symbols contained in this family are : ")

        ' Get family symbols which is contained in this family
        For Each familySymbol As Autodesk.Revit.Symbols.FamilySymbol In family.Symbols
            ' Get family symbol name
            message.AppendLine(vbLf & "Name: " & familySymbol.Name)
            message.AppendLine(vbTab & "Material: " & familySymbol.Material.ToString())
        Next
    End If

    MessageBox.Show(message.ToString(), "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.FamilyBase
Autodesk.Revit.Elements..::.Family

See Also

Family Members
Autodesk.Revit.Elements Namespace


Family Members

[image] [image]

Revit 2010 API
Family Members
Family Class Constructors Methods Properties See Also Send Feedback

The Family type exposes the following members.

Constructors

Name | Description
Family | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurtainPanelHorizontalSpacing | For Curtain Panel families, the horizontal spacing of the driving mesh.
CurtainPanelTilePattern | For Curtain Panel families, the choice of tile pattern.
CurtainPanelVerticalSpacing | For Curtain Panel families, the vertical spacing of the driving mesh.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FamilyCategory | Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside. (Inherited from FamilyBase.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsConceptualMassFamily | Whether the Family is a Conceptual Mass family.
IsCurtainPanelFamily | Whether the Family is a Curtain Panel family. Curtain Panel family symbols are used as the ObjectTypes of DividedSurface elements.
IsInPlace | Indicates if this family is an in-place family or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Symbols | A set of all symbols (types) that belong to a Family.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Family Class
Autodesk.Revit.Elements Namespace


Family Constructor

[image]

Revit 2010 API
Family Constructor
Family Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Family()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Family()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Family Class
Autodesk.Revit.Elements Namespace


Family Methods

[image] [image]

Revit 2010 API
Family Methods
Family Class See Also Send Feedback

The Family type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Family Class
Autodesk.Revit.Elements Namespace


Family Properties

[image] [image]

Revit 2010 API
Family Properties
Family Class See Also Send Feedback

The Family type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurtainPanelHorizontalSpacing | For Curtain Panel families, the horizontal spacing of the driving mesh.
CurtainPanelTilePattern | For Curtain Panel families, the choice of tile pattern.
CurtainPanelVerticalSpacing | For Curtain Panel families, the vertical spacing of the driving mesh.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FamilyCategory | Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside. (Inherited from FamilyBase.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsConceptualMassFamily | Whether the Family is a Conceptual Mass family.
IsCurtainPanelFamily | Whether the Family is a Curtain Panel family. Curtain Panel family symbols are used as the ObjectTypes of DividedSurface elements.
IsInPlace | Indicates if this family is an in-place family or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Symbols | A set of all symbols (types) that belong to a Family.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Family Class
Autodesk.Revit.Elements Namespace


CurtainPanelHorizontalSpacing Property

[image]

Revit 2010 API
Family..::.CurtainPanelHorizontalSpacing Property
Family Class See Also Send Feedback
For Curtain Panel families, the horizontal spacing of the driving mesh.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double CurtainPanelHorizontalSpacing { get; set; }
Visual Basic (Declaration)
Public Property CurtainPanelHorizontalSpacing As Double
Visual C++
public:
property double CurtainPanelHorizontalSpacing {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if this family is not a Curtain Panel family.

See Also

Family Class
Autodesk.Revit.Elements Namespace


CurtainPanelTilePattern Property

[image]

Revit 2010 API
Family..::.CurtainPanelTilePattern Property
Family Class See Also Send Feedback
For Curtain Panel families, the choice of tile pattern.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TilePatternsBuiltIn CurtainPanelTilePattern { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurtainPanelTilePattern As TilePatternsBuiltIn
Visual C++
public:
property TilePatternsBuiltIn CurtainPanelTilePattern {
    TilePatternsBuiltIn get ();
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if this family is not a Curtain Panel family.

See Also

Family Class
Autodesk.Revit.Elements Namespace


CurtainPanelVerticalSpacing Property

[image]

Revit 2010 API
Family..::.CurtainPanelVerticalSpacing Property
Family Class See Also Send Feedback
For Curtain Panel families, the vertical spacing of the driving mesh.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double CurtainPanelVerticalSpacing { get; set; }
Visual Basic (Declaration)
Public Property CurtainPanelVerticalSpacing As Double
Visual C++
public:
property double CurtainPanelVerticalSpacing {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if this family is not a Curtain Panel family.

See Also

Family Class
Autodesk.Revit.Elements Namespace


IsConceptualMassFamily Property

[image]

Revit 2010 API
Family..::.IsConceptualMassFamily Property
Family Class See Also Send Feedback
Whether the Family is a Conceptual Mass family.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsConceptualMassFamily { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsConceptualMassFamily As Boolean
Visual C++
public:
property bool IsConceptualMassFamily {
    bool get ();
}

See Also

Family Class
Autodesk.Revit.Elements Namespace


IsCurtainPanelFamily Property

[image]

Revit 2010 API
Family..::.IsCurtainPanelFamily Property
Family Class See Also Send Feedback
Whether the Family is a Curtain Panel family. Curtain Panel family symbols are used as the ObjectTypes of DividedSurface elements.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsCurtainPanelFamily { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCurtainPanelFamily As Boolean
Visual C++
public:
property bool IsCurtainPanelFamily {
    bool get ();
}

See Also

Family Class
Autodesk.Revit.Elements Namespace


IsInPlace Property

[image]

Revit 2010 API
Family..::.IsInPlace Property
Family Class See Also Send Feedback
Indicates if this family is an in-place family or not.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsInPlace { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInPlace As Boolean
Visual C++
public:
property bool IsInPlace {
    bool get ();
}

See Also

Family Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Family..::.Parameter Property
Family Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Family Class
Family Members
Autodesk.Revit.Elements Namespace


Symbols Property

[image]

Revit 2010 API
Family..::.Symbols Property
Family Class See Also Send Feedback
A set of all symbols (types) that belong to a Family.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbolSet Symbols { get; }
Visual Basic (Declaration)
Public ReadOnly Property Symbols As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ Symbols {
    FamilySymbolSet^ get ();
}

Remarks

Returns a read only set of all the symbols that belong to a particular family. The family symbol objects within this set can be used to swap an instance from one type to another.

See Also

Family Class
Autodesk.Revit.Elements Namespace


FamilyBase Class

[image]

Revit 2010 API
FamilyBase Class
Members See Also Send Feedback
A base class for all Family objects.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FamilyBase : Element
Visual Basic (Declaration)
Public Class FamilyBase _
    Inherits Element
Visual C++
public ref class FamilyBase : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.FamilyBase
Autodesk.Revit.Elements..::.Family

See Also

FamilyBase Members
Autodesk.Revit.Elements Namespace


FamilyBase Members

[image] [image]

Revit 2010 API
FamilyBase Members
FamilyBase Class Constructors Methods Properties See Also Send Feedback

The FamilyBase type exposes the following members.

Constructors

Name | Description
FamilyBase | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FamilyCategory | Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FamilyBase Class
Autodesk.Revit.Elements Namespace


FamilyBase Constructor

[image]

Revit 2010 API
FamilyBase Constructor
FamilyBase Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilyBase()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilyBase Class
Autodesk.Revit.Elements Namespace


FamilyBase Methods

[image] [image]

Revit 2010 API
FamilyBase Methods
FamilyBase Class See Also Send Feedback

The FamilyBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyBase Class
Autodesk.Revit.Elements Namespace


FamilyBase Properties

[image] [image]

Revit 2010 API
FamilyBase Properties
FamilyBase Class See Also Send Feedback

The FamilyBase type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FamilyCategory | Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FamilyBase Class
Autodesk.Revit.Elements Namespace


FamilyCategory Property

[image]

Revit 2010 API
FamilyBase..::.FamilyCategory Property
FamilyBase Class Example See Also Send Feedback
Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Category FamilyCategory { get; }
Visual Basic (Declaration)
Public ReadOnly Property FamilyCategory As Category
Visual C++
public:
property Category^ FamilyCategory {
    Category^ get ();
}

Remarks

All category objects can be retrieved from the application by using the Categories property of the Application.Settings object.

Examples

CopyC#
public void GetBeamAndColumnSymbols(Document document)
{
    FamilySymbolSet columnTypes = new FamilySymbolSet();
    FamilySymbolSet framingTypes = new FamilySymbolSet();
    ElementIterator elemItor = document.get_Elements(typeof(Family));
    elemItor.Reset();
    while (elemItor.MoveNext())
    {
        Family tmpFamily = elemItor.Current as Family;
        Category category = tmpFamily.FamilyCategory;
        if (null != category)
        {
            if ((int)BuiltInCategory.OST_StructuralColumns == category.Id.Value)
            {
                foreach (FamilySymbol tmpSymbol in tmpFamily.Symbols)
                {
                    columnTypes.Insert(tmpSymbol);
                }
            }
            else if ((int)BuiltInCategory.OST_StructuralFraming == category.Id.Value)
            {
                foreach (FamilySymbol tmpSymbol in tmpFamily.Symbols)
                {
                    framingTypes.Insert(tmpSymbol);
                }
            }
        }
    }

    string message = "Column Types: ";
    FamilySymbolSetIterator fsItor = columnTypes.ForwardIterator();
    fsItor.Reset();
    while (fsItor.MoveNext())
    {
        FamilySymbol familySybmol = fsItor.Current as FamilySymbol;
        message += "\n" + familySybmol.Name;
    }

    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Public Sub GetBeamAndColumnSymbols(ByVal document As Document)
    Dim columnTypes As New FamilySymbolSet()
    Dim framingTypes As New FamilySymbolSet()
    Dim elemItor As ElementIterator = document.Elements(GetType(Autodesk.Revit.Elements.Family))
    elemItor.Reset()
    While elemItor.MoveNext()
        Dim tmpFamily As Autodesk.Revit.Elements.Family = TryCast(elemItor.Current, Autodesk.Revit.Elements.Family)
        Dim category As Autodesk.Revit.Category = tmpFamily.FamilyCategory
        If category IsNot Nothing Then
            If CInt(BuiltInCategory.OST_StructuralColumns) = category.Id.Value Then
                For Each tmpSymbol As Autodesk.Revit.Symbols.FamilySymbol In tmpFamily.Symbols
                    columnTypes.Insert(tmpSymbol)
                Next
            ElseIf CInt(BuiltInCategory.OST_StructuralFraming) = category.Id.Value Then
                For Each tmpSymbol As Autodesk.Revit.Symbols.FamilySymbol In tmpFamily.Symbols
                    framingTypes.Insert(tmpSymbol)
                Next
            End If
        End If
    End While

    Dim message As String = "Column Types: "
    Dim fsItor As FamilySymbolSetIterator = columnTypes.ForwardIterator()
    fsItor.Reset()
    While fsItor.MoveNext()
        Dim familySybmol As Autodesk.Revit.Symbols.FamilySymbol = TryCast(fsItor.Current, Autodesk.Revit.Symbols.FamilySymbol)
        message += vbLf & familySybmol.Name
    End While

    MessageBox.Show(message, "Revit")
End Sub

See Also

FamilyBase Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
FamilyBase..::.Parameter Property
FamilyBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FamilyBase Class
FamilyBase Members
Autodesk.Revit.Elements Namespace


FamilyInstance Class

[image]

Revit 2010 API
FamilyInstance Class
Members Example See Also Send Feedback
This object represents a single instance of a family type, such as a single I beam.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FamilyInstance : InsertableInstance
Visual Basic (Declaration)
Public Class FamilyInstance _
    Inherits InsertableInstance
Visual C++
public ref class FamilyInstance : public InsertableInstance

Remarks

Examples of FamilyInstance objects within Autodesk Revit are Beams, Columns, Braces and Desks. The FamilyInstance object provides more detailed properties that enable the type of the family instance to be changed, thus changing their appearance within the project.

Examples

CopyC#
public void GetInfo_FamilyInstance(FamilyInstance familyInstance)
{
    string message = "FamilyInstance : ";
    // Get FamilyInstance AnalyticalModel type
    if (null != familyInstance.AnalyticalModel)
    {
        message += "\nFamilyInstance AnalyticalModel is : " + familyInstance.AnalyticalModel;
    }

    // Get FamilyInstance host name
    if (familyInstance.Host != null)
    {
        message += "\nFamilyInstance host name is : " + familyInstance.Host.Name;
    }

    // Get FamilyInstance Material
    message += "\nFamilyInstance Material is : " + familyInstance.Material;

    // Get FamilyInstance room name
    if (familyInstance.Room != null)
    {
        message += "\nFamilyInstance room name is : " + familyInstance.Room.Name;
    }

    // Get FamilyInstance structural type
    message += "\nFamilyInstance structural type is : " + familyInstance.StructuralType;

    // Get FamilyInstance structural usage
    message += "\nFamilyInstance structural usage is : " + familyInstance.StructuralUsage;

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_FamilyInstance(ByVal familyInstance As Autodesk.Revit.Elements.FamilyInstance)
    Dim message As String = "FamilyInstance : "
    ' Get FamilyInstance AnalyticalModel type
    If familyInstance.AnalyticalModel IsNot Nothing Then
        message += vbLf & "FamilyInstance AnalyticalModel is : " & familyInstance.AnalyticalModel.ToString
    End If

    ' Get FamilyInstance host name
    If familyInstance.Host IsNot Nothing Then
        message += vbLf & "FamilyInstance host name is : " & familyInstance.Host.Name
    End If

    ' Get FamilyInstance Material
    message += vbLf & "FamilyInstance Material is : " & familyInstance.Material

    ' Get FamilyInstance room name
    If familyInstance.Room IsNot Nothing Then
        message += vbLf & "FamilyInstance room name is : " & familyInstance.Room.Name
    End If

    ' Get FamilyInstance structural type
    message += vbLf & "FamilyInstance structural type is : " & familyInstance.StructuralType

    ' Get FamilyInstance structural usage
    message += vbLf & "FamilyInstance structural usage is : " & familyInstance.StructuralUsage

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Instance
Autodesk.Revit.Elements..::.InsertableInstance
Autodesk.Revit.Elements..::.FamilyInstance

See Also

FamilyInstance Members
Autodesk.Revit.Elements Namespace


FamilyInstance Members

[image] [image]

Revit 2010 API
FamilyInstance Members
FamilyInstance Class Constructors Methods Properties See Also Send Feedback

The FamilyInstance type exposes the following members.

Constructors

Name | Description
FamilyInstance | For Internal Use Only.

Methods

Name | Description
AddCoping | Adds a coping (cut) to a steel beam.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
FlipFromToRoom | Change the room to which the door or window is opened.
flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
GetCopings | Lists the elements currently used as coping cutters for this element.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveCoping | Removes a coping (cut) from a steel beam.
rotate | The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true.
SetCopings | Specify the set of coping cutters on this element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AnalyticalModel | Retrieves the structural analytical model for the family instance.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped.
CanFlipHand | Property to test whether the orientation of family instance hand can be flipped.
CanRotate | Property to test whether the family instance can be rotated by 180 degree.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation.
FacingFlipped | Property to test whether the orientation of family instance facing is flipped.
FacingOrientation | Property to get the orientation of family instance facing.
FromRoom | Overloaded. The room from which the door or window is opened.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HandFlipped | Property to test whether the orientation of family instance hand is flipped.
HandOrientation | Property to get the orientation of family instance hand.
Host | If the instance is contained within another element, this property returns the containing element.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsSlantedColumn | Indicates if the family instance is a slanted column.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an instance within project. (Overrides Element..::.Location.)
Material | This property returns the physical material from which the instance is made.
Materials | Get all materials present in the element. (Inherited from Element.)
MEPModel | Retrieves the MEP model for the family instance.
Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Room | Overloaded. The room in which the instance is located.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Space | Overloaded. The space in which the instance is located.
StructuralType | Provides the primary structural type of the instance, such as beam or column etc.
StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc.
SubComponents | Property to get the sub componets of current family instance.
SuperComponent | Property to get the super componet of current family instance.
Symbol | Returns or changes the FamilySymbol object that represents the type of the instance.
ToRoom | Overloaded. The room to which the door or window is opened.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


FamilyInstance Constructor

[image]

Revit 2010 API
FamilyInstance Constructor
FamilyInstance Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilyInstance()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


FamilyInstance Methods

[image] [image]

Revit 2010 API
FamilyInstance Methods
FamilyInstance Class See Also Send Feedback

The FamilyInstance type exposes the following members.

Methods

Name | Description
AddCoping | Adds a coping (cut) to a steel beam.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
FlipFromToRoom | Change the room to which the door or window is opened.
flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
GetCopings | Lists the elements currently used as coping cutters for this element.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveCoping | Removes a coping (cut) from a steel beam.
rotate | The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true.
SetCopings | Specify the set of coping cutters on this element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


AddCoping Method

[image]

Revit 2010 API
FamilyInstance..::.AddCoping Method
FamilyInstance Class See Also Send Feedback
Adds a coping (cut) to a steel beam.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool AddCoping(
    FamilyInstance cutter
)
Visual Basic (Declaration)
Public Function AddCoping ( _
    cutter As FamilyInstance _
) As Boolean
Visual C++
public:
bool AddCoping(
    FamilyInstance^ cutter
)

Parameters

cutter
Type: Autodesk.Revit.Elements..::.FamilyInstance
A steel beam or column. May not be null or itself.

Remarks

This beam will be cut to fit another element, the cutter. The cut will include an offset determined by the parameter STRUCTURAL_COPING_DISTANCE. The parameter affects all copings on this element. This function corresponds to Tools -> Coping in Revit Structure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when 'cutter' is null.
System..::.ArgumentException | Thrown when 'cutter' refers to this instance.
System..::.InvalidOperationException | Thrown when regeneration fails.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


flipFacing Method

[image]

Revit 2010 API
FamilyInstance..::.flipFacing Method
FamilyInstance Class See Also Send Feedback
The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool flipFacing()
Visual Basic (Declaration)
Public Function flipFacing As Boolean
Visual C++
public:
bool flipFacing()

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


FlipFromToRoom Method

[image]

Revit 2010 API
FamilyInstance..::.FlipFromToRoom Method
FamilyInstance Class See Also Send Feedback
Change the room to which the door or window is opened.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void FlipFromToRoom()
Visual Basic (Declaration)
Public Sub FlipFromToRoom
Visual C++
public:
void FlipFromToRoom()

Remarks

The FromRoom and ToRoom properties of current family instance's swap after calling this method.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when current family instance is neither door nor window.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


flipHand Method

[image]

Revit 2010 API
FamilyInstance..::.flipHand Method
FamilyInstance Class See Also Send Feedback
The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool flipHand()
Visual Basic (Declaration)
Public Function flipHand As Boolean
Visual C++
public:
bool flipHand()

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


GetCopings Method

[image]

Revit 2010 API
FamilyInstance..::.GetCopings Method
FamilyInstance Class See Also Send Feedback
Lists the elements currently used as coping cutters for this element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet GetCopings()
Visual Basic (Declaration)
Public Function GetCopings As ElementSet
Visual C++
public:
ElementSet^ GetCopings()

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


RemoveCoping Method

[image]

Revit 2010 API
FamilyInstance..::.RemoveCoping Method
FamilyInstance Class See Also Send Feedback
Removes a coping (cut) from a steel beam.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool RemoveCoping(
    FamilyInstance cutter
)
Visual Basic (Declaration)
Public Function RemoveCoping ( _
    cutter As FamilyInstance _
) As Boolean
Visual C++
public:
bool RemoveCoping(
    FamilyInstance^ cutter
)

Parameters

cutter
Type: Autodesk.Revit.Elements..::.FamilyInstance
A steel beam or column for which this beam currently has a coping cut. May not be null or itself.

Remarks

This function corresponds to Tools -> Remove coping in Revit Structure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when 'cutter' is null.
System..::.ArgumentException | Thrown when 'cutter' refers to this instance.
System..::.InvalidOperationException | Thrown when regeneration fails.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


rotate Method

[image]

Revit 2010 API
FamilyInstance..::.rotate Method
FamilyInstance Class See Also Send Feedback
The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool rotate()
Visual Basic (Declaration)
Public Function rotate As Boolean
Visual C++
public:
bool rotate()

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


SetCopings Method

[image]

Revit 2010 API
FamilyInstance..::.SetCopings Method
FamilyInstance Class See Also Send Feedback
Specify the set of coping cutters on this element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SetCopings(
    ElementSet cutters
)
Visual Basic (Declaration)
Public Function SetCopings ( _
    cutters As ElementSet _
) As Boolean
Visual C++
public:
bool SetCopings(
    ElementSet^ cutters
)

Parameters

cutters
Type: Autodesk.Revit..::.ElementSet
A set of coping cutters (steel beams and steel columns).

Remarks

The set must contain elements of FamilyInstance type only. The set may be null or empty, but may not contain the element being coped.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when 'cutters' contains this instance.
System..::.InvalidOperationException | Thrown when regeneration fails.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


FamilyInstance Properties

[image] [image]

Revit 2010 API
FamilyInstance Properties
FamilyInstance Class See Also Send Feedback

The FamilyInstance type exposes the following members.

Properties

Name | Description
AnalyticalModel | Retrieves the structural analytical model for the family instance.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped.
CanFlipHand | Property to test whether the orientation of family instance hand can be flipped.
CanRotate | Property to test whether the family instance can be rotated by 180 degree.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation.
FacingFlipped | Property to test whether the orientation of family instance facing is flipped.
FacingOrientation | Property to get the orientation of family instance facing.
FromRoom | Overloaded. The room from which the door or window is opened.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HandFlipped | Property to test whether the orientation of family instance hand is flipped.
HandOrientation | Property to get the orientation of family instance hand.
Host | If the instance is contained within another element, this property returns the containing element.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsSlantedColumn | Indicates if the family instance is a slanted column.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an instance within project. (Overrides Element..::.Location.)
Material | This property returns the physical material from which the instance is made.
Materials | Get all materials present in the element. (Inherited from Element.)
MEPModel | Retrieves the MEP model for the family instance.
Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Room | Overloaded. The room in which the instance is located.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Space | Overloaded. The space in which the instance is located.
StructuralType | Provides the primary structural type of the instance, such as beam or column etc.
StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc.
SubComponents | Property to get the sub componets of current family instance.
SuperComponent | Property to get the super componet of current family instance.
Symbol | Returns or changes the FamilySymbol object that represents the type of the instance.
ToRoom | Overloaded. The room to which the door or window is opened.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


AnalyticalModel Property

[image]

Revit 2010 API
FamilyInstance..::.AnalyticalModel Property
FamilyInstance Class See Also Send Feedback
Retrieves the structural analytical model for the family instance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalModel AnalyticalModel { get; }
Visual Basic (Declaration)
Public ReadOnly Property AnalyticalModel As AnalyticalModel
Visual C++
public:
property AnalyticalModel^ AnalyticalModel {
    AnalyticalModel^ get ();
}

Remarks

If the family instance has a structural analytical model it is returned by this method, otherwise Nothing is returned. Different types of analytical model will be returned based on the type of the instance, for example - if the instance is a beam then a frame analytical model will be returned. If the instance is a footing then a location analytical model will be returned. This property will only function with the Autodesk Revit Structure product.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


CanFlipFacing Property

[image]

Revit 2010 API
FamilyInstance..::.CanFlipFacing Property
FamilyInstance Class See Also Send Feedback
Property to test whether the orientation of family instance facing can be flipped.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool CanFlipFacing { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanFlipFacing As Boolean
Visual C++
public:
property bool CanFlipFacing {
    bool get ();
}

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


CanFlipHand Property

[image]

Revit 2010 API
FamilyInstance..::.CanFlipHand Property
FamilyInstance Class See Also Send Feedback
Property to test whether the orientation of family instance hand can be flipped.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool CanFlipHand { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanFlipHand As Boolean
Visual C++
public:
property bool CanFlipHand {
    bool get ();
}

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


CanRotate Property

[image]

Revit 2010 API
FamilyInstance..::.CanRotate Property
FamilyInstance Class See Also Send Feedback
Property to test whether the family instance can be rotated by 180 degree.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool CanRotate { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanRotate As Boolean
Visual C++
public:
property bool CanRotate {
    bool get ();
}

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


ExtensionUtility Property

[image]

Revit 2010 API
FamilyInstance..::.ExtensionUtility Property
FamilyInstance Class See Also Send Feedback
Property to check whether the instance can be extended and return the interface for extension operation.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public IExtension ExtensionUtility { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExtensionUtility As IExtension
Visual C++
public:
property IExtension^ ExtensionUtility {
    IExtension^ get ();
}

Remarks

If the family instance can not support extension operation, it returns null

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


FacingFlipped Property

[image]

Revit 2010 API
FamilyInstance..::.FacingFlipped Property
FamilyInstance Class See Also Send Feedback
Property to test whether the orientation of family instance facing is flipped.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool FacingFlipped { get; }
Visual Basic (Declaration)
Public ReadOnly Property FacingFlipped As Boolean
Visual C++
public:
property bool FacingFlipped {
    bool get ();
}

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


FacingOrientation Property

[image]

Revit 2010 API
FamilyInstance..::.FacingOrientation Property
FamilyInstance Class See Also Send Feedback
Property to get the orientation of family instance facing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ FacingOrientation { get; }
Visual Basic (Declaration)
Public ReadOnly Property FacingOrientation As XYZ
Visual C++
public:
property XYZ^ FacingOrientation {
    XYZ^ get ();
}

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


FromRoom Property

[image] [image]

Revit 2010 API
FamilyInstance..::.FromRoom Property
FamilyInstance Class See Also Send Feedback
The room from which the door or window is opened.

Overload List

Name | Description
FromRoom | The room from which the door is opened at the last phase of the project.
FromRoom[([(Phase])]) |

See Also

FamilyInstance Class
FamilyInstance Members
Autodesk.Revit.Elements Namespace


FromRoom Property

[image]

Revit 2010 API
FamilyInstance..::.FromRoom Property
FamilyInstance Class See Also Send Feedback
The room from which the door is opened at the last phase of the project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Room FromRoom { get; }
Visual Basic (Declaration)
Public ReadOnly Property FromRoom As Room
Visual C++
public:
property Room^ FromRoom {
    Room^ get ();
}

Remarks

When current familyinstance is neither door nor window, this property will always return null.

See Also

FamilyInstance Class
FromRoom Overload
Autodesk.Revit.Elements Namespace


FromRoom Property (Phase)

[image]

Revit 2010 API
FamilyInstance..::.FromRoom Property (Phase)
FamilyInstance Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Room FromRoom[
    Phase phase
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property FromRoom ( _
    phase As Phase _
) As Room
Visual C++
public:
property Room^ FromRoom[Phase^ phase] {
    Room^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.Elements..::.Phase

See Also

FamilyInstance Class
FromRoom Overload
Autodesk.Revit.Elements Namespace


HandFlipped Property

[image]

Revit 2010 API
FamilyInstance..::.HandFlipped Property
FamilyInstance Class See Also Send Feedback
Property to test whether the orientation of family instance hand is flipped.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool HandFlipped { get; }
Visual Basic (Declaration)
Public ReadOnly Property HandFlipped As Boolean
Visual C++
public:
property bool HandFlipped {
    bool get ();
}

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


HandOrientation Property

[image]

Revit 2010 API
FamilyInstance..::.HandOrientation Property
FamilyInstance Class See Also Send Feedback
Property to get the orientation of family instance hand.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ HandOrientation { get; }
Visual Basic (Declaration)
Public ReadOnly Property HandOrientation As XYZ
Visual C++
public:
property XYZ^ HandOrientation {
    XYZ^ get ();
}

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


Host Property

[image]

Revit 2010 API
FamilyInstance..::.Host Property
FamilyInstance Class See Also Send Feedback
If the instance is contained within another element, this property returns the containing element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element Host { get; }
Visual Basic (Declaration)
Public ReadOnly Property Host As Element
Visual C++
public:
property Element^ Host {
    Element^ get ();
}

Remarks

An example of an instance that is contained is a window. In this case the host property would return the wall in which the window is contained.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


IsSlantedColumn Property

[image]

Revit 2010 API
FamilyInstance..::.IsSlantedColumn Property
FamilyInstance Class See Also Send Feedback
Indicates if the family instance is a slanted column.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsSlantedColumn { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSlantedColumn As Boolean
Visual C++
public:
property bool IsSlantedColumn {
    bool get ();
}

Remarks

If the family instance is a slanted column, it returns true, otherwise returns false.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


Location Property

[image]

Revit 2010 API
FamilyInstance..::.Location Property
FamilyInstance Class See Also Send Feedback
This property is used to find the physical location of an instance within project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

The Location property returns an object that can be used to find the location of an instance within the project. An instance may have a point location, such as a footing or may have a line location. A beam is an example of an instance that has a line location.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


Material Property

[image]

Revit 2010 API
FamilyInstance..::.Material Property
FamilyInstance Class See Also Send Feedback
This property returns the physical material from which the instance is made.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Material Material { get; }
Visual Basic (Declaration)
Public ReadOnly Property Material As Material
Visual C++
public:
property Material Material {
    Material get ();
}

Remarks

Values of this property can be Steel, Concrete, Wood or some other material. Different from Revit materials that geometry really consists of, this property is a family parameter defining family behavior and can not be set per instance. Its value is the same with the type of the instance's family. For example, the instances of different kind of column families(Steel, Concrete or Wood) have different material values and can't be changed int the UI or RevitAPI.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


MEPModel Property

[image]

Revit 2010 API
FamilyInstance..::.MEPModel Property
FamilyInstance Class See Also Send Feedback
Retrieves the MEP model for the family instance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MEPModel MEPModel { get; }
Visual Basic (Declaration)
Public ReadOnly Property MEPModel As MEPModel
Visual C++
public:
property MEPModel^ MEPModel {
    MEPModel^ get ();
}

Remarks

If the family instance has a MEP model it is returned by this method, otherwise Nothing is returned. Different types of MEP model will be returned based on the type of the instance, for example - if the instance is a lighting device then a lighting device model will be returned. This property will only function with the Autodesk Revit MEP product.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


Mirrored Property

[image]

Revit 2010 API
FamilyInstance..::.Mirrored Property
FamilyInstance Class See Also Send Feedback
Property to test whether the family instance is mirrored. (only one axis is flipped)

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Mirrored { get; }
Visual Basic (Declaration)
Public ReadOnly Property Mirrored As Boolean
Visual C++
public:
property bool Mirrored {
    bool get ();
}

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
FamilyInstance..::.Parameter Property
FamilyInstance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FamilyInstance Class
FamilyInstance Members
Autodesk.Revit.Elements Namespace


Room Property

[image] [image]

Revit 2010 API
FamilyInstance..::.Room Property
FamilyInstance Class See Also Send Feedback
The room in which the instance is located.

Overload List

Name | Description
Room | The room in which the instance is located (during the last phase of the project).
Room[([(Phase])]) |

See Also

FamilyInstance Class
FamilyInstance Members
Autodesk.Revit.Elements Namespace


Room Property

[image]

Revit 2010 API
FamilyInstance..::.Room Property
FamilyInstance Class See Also Send Feedback
The room in which the instance is located (during the last phase of the project).

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Room Room { get; }
Visual Basic (Declaration)
Public ReadOnly Property Room As Room
Visual C++
public:
property Room^ Room {
    Room^ get ();
}

Remarks

This property will be the first room encountered that contains the instance. If more than one room includes this point in its volume only the first one is returned. If no room is found that contains the instance, this property is NULL.

See Also

FamilyInstance Class
Room Overload
Autodesk.Revit.Elements Namespace


Room Property (Phase)

[image]

Revit 2010 API
FamilyInstance..::.Room Property (Phase)
FamilyInstance Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Room Room[
    Phase phase
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Room ( _
    phase As Phase _
) As Room
Visual C++
public:
property Room^ Room[Phase^ phase] {
    Room^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.Elements..::.Phase

See Also

FamilyInstance Class
Room Overload
Autodesk.Revit.Elements Namespace


Space Property

[image] [image]

Revit 2010 API
FamilyInstance..::.Space Property
FamilyInstance Class See Also Send Feedback
The space in which the instance is located.

Overload List

Name | Description
Space | The space in which the instance is located (during the last phase of the project).
Space[([(Phase])]) |

See Also

FamilyInstance Class
FamilyInstance Members
Autodesk.Revit.Elements Namespace


Space Property

[image]

Revit 2010 API
FamilyInstance..::.Space Property
FamilyInstance Class See Also Send Feedback
The space in which the instance is located (during the last phase of the project).

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Space Space { get; }
Visual Basic (Declaration)
Public ReadOnly Property Space As Space
Visual C++
public:
property Space^ Space {
    Space^ get ();
}

Remarks

This property will be the first space encountered that contains the instance. If more than one space includes this point in its volume only the first one is returned. If no space is found that contains the instance, this property is NULL.

See Also

FamilyInstance Class
Space Overload
Autodesk.Revit.Elements Namespace


Space Property (Phase)

[image]

Revit 2010 API
FamilyInstance..::.Space Property (Phase)
FamilyInstance Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Space Space[
    Phase phase
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Space ( _
    phase As Phase _
) As Space
Visual C++
public:
property Space^ Space[Phase^ phase] {
    Space^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.Elements..::.Phase

See Also

FamilyInstance Class
Space Overload
Autodesk.Revit.Elements Namespace


StructuralType Property

[image]

Revit 2010 API
FamilyInstance..::.StructuralType Property
FamilyInstance Class Example See Also Send Feedback
Provides the primary structural type of the instance, such as beam or column etc.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public StructuralType StructuralType { get; }
Visual Basic (Declaration)
Public ReadOnly Property StructuralType As StructuralType
Visual C++
public:
property StructuralType StructuralType {
    StructuralType get ();
}

Examples

CopyC#
public void GetStructuralType(FamilyInstance familyInstance)
{
    string message = "";
    switch (familyInstance.StructuralType)
    {
        case StructuralType.Beam:
            message = "FamilyInstance is a beam.";
            break;
        case StructuralType.Brace:
            message = "FamilyInstance is a brace.";
            break;
        case StructuralType.Column:
            message = "FamilyInstance is a column.";
            break;
        case StructuralType.Footing:
            message = "FamilyInstance is a footing.";
            break;
        default:
            message = "FamilyInstance is non-structural or unknown framing.";
            break;
    }

    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Public Sub GetStructuralType(ByVal familyInstance As Autodesk.Revit.Elements.FamilyInstance)
    Dim message As String = ""
    Select Case familyInstance.StructuralType
        Case StructuralType.Beam
            message = "FamilyInstance is a beam."
            Exit Select
        Case StructuralType.Brace
            message = "FamilyInstance is a brace."
            Exit Select
        Case StructuralType.Column
            message = "FamilyInstance is a column."
            Exit Select
        Case StructuralType.Footing
            message = "FamilyInstance is a footing."
            Exit Select
        Case Else
            message = "FamilyInstance is non-structural or unknown framing."
            Exit Select
    End Select

    MessageBox.Show(message, "Revit")
End Sub

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


StructuralUsage Property

[image]

Revit 2010 API
FamilyInstance..::.StructuralUsage Property
FamilyInstance Class See Also Send Feedback
Provides the primary structural usage of the instance, such as brace, girder etc.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InstanceUsage StructuralUsage { get; set; }
Visual Basic (Declaration)
Public Property StructuralUsage As InstanceUsage
Visual C++
public:
property InstanceUsage StructuralUsage {
    InstanceUsage get ();
    void set (InstanceUsage value);
}

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


SubComponents Property

[image]

Revit 2010 API
FamilyInstance..::.SubComponents Property
FamilyInstance Class Example See Also Send Feedback
Property to get the sub componets of current family instance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet SubComponents { get; }
Visual Basic (Declaration)
Public ReadOnly Property SubComponents As ElementSet
Visual C++
public:
property ElementSet^ SubComponents {
    ElementSet^ get ();
}

Remarks

When current familyinstance has no sub component, it returns null

Examples

CopyC#
public void GetSubAndSuperComponents(FamilyInstance familyInstance)
{
    ElementSet subElemSet = familyInstance.SubComponents;
    if (subElemSet != null)
    {
        string subElems = "";
        foreach (Autodesk.Revit.Element ee in subElemSet)
        {
            FamilyInstance f = ee as FamilyInstance;
            subElems = subElems + f.Name + "\n";
        }
        MessageBox.Show("Subcomponent count = " + subElemSet.Size + "\n" + subElems);
    }
    FamilyInstance super = familyInstance.SuperComponent as FamilyInstance;
    if (super != null)
    {
        MessageBox.Show("SUPER component: " + super.Name);
    }
}
CopyVB.NET
Public Sub GetSubAndSuperComponents(ByVal familyInstance As Autodesk.Revit.Elements.FamilyInstance)
    Dim subElemSet As ElementSet = familyInstance.SubComponents
    If subElemSet IsNot Nothing Then
        Dim subElems As String = ""
        For Each ee As Autodesk.Revit.Element In subElemSet
            Dim f As Autodesk.Revit.Elements.FamilyInstance = TryCast(ee, Autodesk.Revit.Elements.FamilyInstance)
            subElems = subElems + f.Name & vbLf
        Next
        MessageBox.Show(("Subcomponent count = " & subElemSet.Size & vbLf) + subElems)
    End If
    Dim super As Autodesk.Revit.Elements.FamilyInstance = TryCast(familyInstance.SuperComponent, Autodesk.Revit.Elements.FamilyInstance)
    If super IsNot Nothing Then
        MessageBox.Show("SUPER component: " & super.Name)
    End If
End Sub

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


SuperComponent Property

[image]

Revit 2010 API
FamilyInstance..::.SuperComponent Property
FamilyInstance Class See Also Send Feedback
Property to get the super componet of current family instance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element SuperComponent { get; }
Visual Basic (Declaration)
Public ReadOnly Property SuperComponent As Element
Visual C++
public:
property Element^ SuperComponent {
    Element^ get ();
}

Remarks

When current familyinstance has no super component, it returns null

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


Symbol Property

[image]

Revit 2010 API
FamilyInstance..::.Symbol Property
FamilyInstance Class Example See Also Send Feedback
Returns or changes the FamilySymbol object that represents the type of the instance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbol Symbol { get; set; }
Visual Basic (Declaration)
Public Property Symbol As FamilySymbol
Visual C++
public:
property FamilySymbol^ Symbol {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

Setting this property will result in the type of the instance being changed. Related types can be found by examining the Family to which the symbol belongs.

Examples

CopyC#
public void GetInfo_FamilyInstance_Symbol(FamilyInstance familyInstance)
{
    string message = "FamilyInstance symbol: ";
    if (familyInstance.Symbol != null)
    {
        // Get FamilyInstance structural symbol
        message += "\nFamilyInstance structural symbol name is : " + familyInstance.Symbol.Name;

        // Rename the Symbol used by this FamilyInstance
        familyInstance.Symbol.Name = "TestFamilyInstanceSymbolName";

        // Get FamilyInstance structural symbol
        message += "\nFamilyInstance structural symbol name after set is : " + familyInstance.Symbol.Name;
    }
    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_FamilyInstance_Symbol(ByVal familyInstance As Autodesk.Revit.Elements.FamilyInstance)
    Dim message As String = "FamilyInstance symbol: "
    If familyInstance.Symbol IsNot Nothing Then
        ' Get FamilyInstance structural symbol
        message += vbLf & "FamilyInstance structural symbol name is : " & familyInstance.Symbol.Name

        ' Rename the Symbol used by this FamilyInstance
        familyInstance.Symbol.Name = "TestFamilyInstanceSymbolName"

        ' Get FamilyInstance structural symbol
        message += vbLf & "FamilyInstance structural symbol name after set is : " & familyInstance.Symbol.Name
    End If
    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace


ToRoom Property

[image] [image]

Revit 2010 API
FamilyInstance..::.ToRoom Property
FamilyInstance Class See Also Send Feedback
The room to which the door or window is opened.

Overload List

Name | Description
ToRoom | The room to which the door is opened at the last phase of the project.
ToRoom[([(Phase])]) |

See Also

FamilyInstance Class
FamilyInstance Members
Autodesk.Revit.Elements Namespace


ToRoom Property

[image]

Revit 2010 API
FamilyInstance..::.ToRoom Property
FamilyInstance Class See Also Send Feedback
The room to which the door is opened at the last phase of the project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Room ToRoom { get; }
Visual Basic (Declaration)
Public ReadOnly Property ToRoom As Room
Visual C++
public:
property Room^ ToRoom {
    Room^ get ();
}

Remarks

When current familyinstance is neither door nor window, this property will always return null.

See Also

FamilyInstance Class
ToRoom Overload
Autodesk.Revit.Elements Namespace


ToRoom Property (Phase)

[image]

Revit 2010 API
FamilyInstance..::.ToRoom Property (Phase)
FamilyInstance Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Room ToRoom[
    Phase phase
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property ToRoom ( _
    phase As Phase _
) As Room
Visual C++
public:
property Room^ ToRoom[Phase^ phase] {
    Room^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.Elements..::.Phase

See Also

FamilyInstance Class
ToRoom Overload
Autodesk.Revit.Elements Namespace


Fascia Class

[image]

Revit 2010 API
Fascia Class
Members See Also Send Feedback
An object that represents a fascia within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Fascia : HostedSweep
Visual Basic (Declaration)
Public Class Fascia _
    Inherits HostedSweep
Visual C++
public ref class Fascia : public HostedSweep

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.HostedSweep
Autodesk.Revit.Elements..::.Fascia

See Also

Fascia Members
Autodesk.Revit.Elements Namespace


Fascia Members

[image] [image]

Revit 2010 API
Fascia Members
Fascia Class Constructors Methods Properties See Also Send Feedback

The Fascia type exposes the following members.

Constructors

Name | Description
Fascia | For Internal Use Only.

Methods

Name | Description
AddSegment | Add segments to the fascia. (Overrides HostedSweep..::.AddSegment(Reference).)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

Properties

Name | Description
Angle | Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian). (Inherited from HostedSweep.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FasciaType | Retrieves/set an object that represents the type of the Fascia.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceCurve | Retrieve the curve on which the hosted sweep object's segment is created on the corresponding. (Inherited from HostedSweep.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)

See Also

Fascia Class
Autodesk.Revit.Elements Namespace


Fascia Constructor

[image]

Revit 2010 API
Fascia Constructor
Fascia Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Fascia()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Fascia()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Fascia Class
Autodesk.Revit.Elements Namespace


Fascia Methods

[image] [image]

Revit 2010 API
Fascia Methods
Fascia Class See Also Send Feedback

The Fascia type exposes the following members.

Methods

Name | Description
AddSegment | Add segments to the fascia. (Overrides HostedSweep..::.AddSegment(Reference).)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

See Also

Fascia Class
Autodesk.Revit.Elements Namespace


AddSegment Method

[image]

Revit 2010 API
Fascia..::.AddSegment Method
Fascia Class See Also Send Feedback
Add segments to the fascia.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override void AddSegment(
    Reference targetRef
)
Visual Basic (Declaration)
Public Overrides Sub AddSegment ( _
    targetRef As Reference _
)
Visual C++
public:
virtual void AddSegment(
    Reference^ targetRef
) override

Parameters

targetRef
Type: Autodesk.Revit.Geometry..::.Reference
Segment's reference on which want to be added.

Exceptions

Exception | Condition
System..::.ArgumentNullException | This exception will be thrown in following cases: 1. Input targetRef is null. 2. Input targetRef is not null but contains nothing.
System..::.InvalidOperationException | This exception will be thrown in following cases: 1. Input targetRef has already been added into the fascia. 2. Internal code fails to create the segment object. 3. Regeneration fails.
System..::.ArgumentOutOfRangeException | This exception will be thrown if the reference is suitable for creating a fascia as required. The reference allowed is : 1. Model Line 2. Roof's horizontal edges 3. Soffit's horizontal edges 4. Other fascia's horizontal edges

See Also

Fascia Class
Autodesk.Revit.Elements Namespace


Fascia Properties

[image] [image]

Revit 2010 API
Fascia Properties
Fascia Class See Also Send Feedback

The Fascia type exposes the following members.

Properties

Name | Description
Angle | Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian). (Inherited from HostedSweep.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FasciaType | Retrieves/set an object that represents the type of the Fascia.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceCurve | Retrieve the curve on which the hosted sweep object's segment is created on the corresponding. (Inherited from HostedSweep.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)

See Also

Fascia Class
Autodesk.Revit.Elements Namespace


FasciaType Property

[image]

Revit 2010 API
Fascia..::.FasciaType Property
Fascia Class See Also Send Feedback
Retrieves/set an object that represents the type of the Fascia.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FasciaType FasciaType { get; set; }
Visual Basic (Declaration)
Public Property FasciaType As FasciaType
Visual C++
public:
property FasciaType^ FasciaType {
    FasciaType^ get ();
    void set (FasciaType^ value);
}

See Also

Fascia Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Fascia..::.Parameter Property
Fascia Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Fascia Class
Fascia Members
Autodesk.Revit.Elements Namespace


FillPattern Class

[image]

Revit 2010 API
FillPattern Class
Members See Also Send Feedback
Represents a fill pattern element within an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FillPattern : Element
Visual Basic (Declaration)
Public Class FillPattern _
    Inherits Element
Visual C++
public ref class FillPattern : public Element

Remarks

Currently the details of the fill patterns are not exposed but all the fill patterns can be found on the Document object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.FillPattern

See Also

FillPattern Members
Autodesk.Revit.Elements Namespace


FillPattern Members

[image] [image]

Revit 2010 API
FillPattern Members
FillPattern Class Constructors Methods Properties See Also Send Feedback

The FillPattern type exposes the following members.

Constructors

Name | Description
FillPattern | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FillPattern Class
Autodesk.Revit.Elements Namespace


FillPattern Constructor

[image]

Revit 2010 API
FillPattern Constructor
FillPattern Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FillPattern()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FillPattern()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FillPattern Class
Autodesk.Revit.Elements Namespace


FillPattern Methods

[image] [image]

Revit 2010 API
FillPattern Methods
FillPattern Class See Also Send Feedback

The FillPattern type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FillPattern Class
Autodesk.Revit.Elements Namespace


FillPattern Properties

[image] [image]

Revit 2010 API
FillPattern Properties
FillPattern Class See Also Send Feedback

The FillPattern type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FillPattern Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
FillPattern..::.Parameter Property
FillPattern Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FillPattern Class
FillPattern Members
Autodesk.Revit.Elements Namespace


Floor Class

[image]

Revit 2010 API
Floor Class
Members Example See Also Send Feedback
An object that represents a Floor within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Floor : HostObject
Visual Basic (Declaration)
Public Class Floor _
    Inherits HostObject
Visual C++
public ref class Floor : public HostObject

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object also supports access to a structural analytical model but this feature is only available with Autodesk Revit Structure.

Examples

CopyC#
public void ShowFloorInfo(Floor floor)
{
    string message = "Floor : ";
    // Get Floor AnalyticalModel
    message += "\nFloor AnalyticalModel is : " + floor.AnalyticalModel;

    // Get Floor type name
    message += "\nFloor type name is : " + floor.FloorType.Name;
    try
    {
        // Get Floor span direction angle
        message += "\nFloor span direction angle is : " + floor.SpanDirectionAngle;
    }
    catch (Exception)
    {
        // an exception is thrown if floor is non-structural
        message += "\nFloor is non-structural.";
    }

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);

}
CopyVB.NET
Public Sub ShowFloorInfo(ByVal floor As Autodesk.Revit.Elements.Floor)
    Dim message As String = "Floor : "
    ' Get Floor AnalyticalModel
    message += vbLf & "Floor AnalyticalModel is : " & floor.AnalyticalModel.ToString

    ' Get Floor type name
    message += vbLf & "Floor type name is : " & floor.FloorType.Name
    Try
        ' Get Floor span direction angle
        message += vbLf & "Floor span direction angle is : " & floor.SpanDirectionAngle
    Catch generatedExceptionName As Exception
        ' an exception is thrown if floor is non-structural
        message += vbLf & "Floor is non-structural."
    End Try

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)

End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.Floor

See Also

Floor Members
Autodesk.Revit.Elements Namespace


Floor Members

[image] [image]

Revit 2010 API
Floor Members
Floor Class Constructors Methods Properties See Also Send Feedback

The Floor type exposes the following members.

Constructors

Name | Description
Floor | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AnalyticalModel | Retrieves the structural analytical model for the floor object.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FloorType | Retrieves/set an object that represents the type of the floor.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.
SpanDirectionAngle | Retrieve the span direction angle of the floor
SpanDirectionSymbols | An array of span direction symbols associated with this floor.
StructuralUsage | The floors designated structural usage, such as bearing or non bearing.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Floor Class
Autodesk.Revit.Elements Namespace


Floor Constructor

[image]

Revit 2010 API
Floor Constructor
Floor Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Floor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Floor()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Floor Class
Autodesk.Revit.Elements Namespace


Floor Methods

[image] [image]

Revit 2010 API
Floor Methods
Floor Class See Also Send Feedback

The Floor type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Floor Class
Autodesk.Revit.Elements Namespace


Floor Properties

[image] [image]

Revit 2010 API
Floor Properties
Floor Class See Also Send Feedback

The Floor type exposes the following members.

Properties

Name | Description
AnalyticalModel | Retrieves the structural analytical model for the floor object.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FloorType | Retrieves/set an object that represents the type of the floor.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.
SpanDirectionAngle | Retrieve the span direction angle of the floor
SpanDirectionSymbols | An array of span direction symbols associated with this floor.
StructuralUsage | The floors designated structural usage, such as bearing or non bearing.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Floor Class
Autodesk.Revit.Elements Namespace


AnalyticalModel Property

[image]

Revit 2010 API
Floor..::.AnalyticalModel Property
Floor Class See Also Send Feedback
Retrieves the structural analytical model for the floor object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalModel AnalyticalModel { get; }
Visual Basic (Declaration)
Public ReadOnly Property AnalyticalModel As AnalyticalModel
Visual C++
public:
property AnalyticalModel^ AnalyticalModel {
    AnalyticalModel^ get ();
}

Remarks

If the floor has a structural analytical model it is returned by this method, otherwise Nothing is returned. For floors, the analytical model returned by this method can be cast to type Autodesk.Revit.Structural.AnalyticalModelFloor to be able to access details about the floor. This property will only function with the Autodesk Revit Structure product.

See Also

Floor Class
Autodesk.Revit.Elements Namespace


FloorType Property

[image]

Revit 2010 API
Floor..::.FloorType Property
Floor Class See Also Send Feedback
Retrieves/set an object that represents the type of the floor.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FloorType FloorType { get; set; }
Visual Basic (Declaration)
Public Property FloorType As FloorType
Visual C++
public:
property FloorType^ FloorType {
    FloorType^ get ();
    void set (FloorType^ value);
}

Remarks

The floor type can be used to access the multi layered structure of a floor.

See Also

Floor Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Floor..::.Parameter Property
Floor Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Floor Class
Floor Members
Autodesk.Revit.Elements Namespace


SlabShapeEditor Property

[image]

Revit 2010 API
Floor..::.SlabShapeEditor Property
Floor Class See Also Send Feedback
Get the SlabShapeEditor used for slab shape editing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabShapeEditor SlabShapeEditor { get; }
Visual Basic (Declaration)
Public ReadOnly Property SlabShapeEditor As SlabShapeEditor
Visual C++
public:
property SlabShapeEditor^ SlabShapeEditor {
    SlabShapeEditor^ get ();
}

Remarks

Only flat and horizontal floor is valid for slab shape edit.Otherwise,ShapeEditor will be nullptr.

See Also

Floor Class
Autodesk.Revit.Elements Namespace


SpanDirectionAngle Property

[image]

Revit 2010 API
Floor..::.SpanDirectionAngle Property
Floor Class See Also Send Feedback
Retrieve the span direction angle of the floor

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double SpanDirectionAngle { get; set; }
Visual Basic (Declaration)
Public Property SpanDirectionAngle As Double
Visual C++
public:
property double SpanDirectionAngle {
    double get ();
    void set (double value);
}

Remarks

The angle returned is in radians. An exception will be thrown if the floor is non structural.

See Also

Floor Class
Autodesk.Revit.Elements Namespace


SpanDirectionSymbols Property

[image]

Revit 2010 API
Floor..::.SpanDirectionSymbols Property
Floor Class Example See Also Send Feedback
An array of span direction symbols associated with this floor.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementArray SpanDirectionSymbols { get; }
Visual Basic (Declaration)
Public ReadOnly Property SpanDirectionSymbols As ElementArray
Visual C++
public:
property ElementArray^ SpanDirectionSymbols {
    ElementArray^ get ();
}

Remarks

By using the ObjecType property on these span direction symbols it is possible to read if the floor has one way or two way span direction graphics.

Examples

CopyC#
public void SpanDirectionSymbolsInfo(Floor floor)
{
    string msg = "";
    if (0 == floor.SpanDirectionSymbols.Size)
    {
        msg = "No span direction symbol!";
    }
    foreach (Element element in floor.SpanDirectionSymbols)
    {
        msg += "Span direction symbol name is : " + element.Name;
    }

    // Give the user some information.
    MessageBox.Show(msg, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub SpanDirectionSymbolsInfo(ByVal floor As Autodesk.Revit.Elements.Floor)
    Dim msg As String = ""
    If 0 = floor.SpanDirectionSymbols.Size Then
        msg = "No span direction symbol!"
    End If
    For Each element As Autodesk.Revit.Element In floor.SpanDirectionSymbols
        msg += "Span direction symbol name is : " & element.Name
    Next

    ' Give the user some information.
    MessageBox.Show(msg, "Revit", MessageBoxButtons.OK)
End Sub

See Also

Floor Class
Autodesk.Revit.Elements Namespace


StructuralUsage Property

[image]

Revit 2010 API
Floor..::.StructuralUsage Property
Floor Class See Also Send Feedback
The floors designated structural usage, such as bearing or non bearing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabFoundationType StructuralUsage { get; set; }
Visual Basic (Declaration)
Public Property StructuralUsage As SlabFoundationType
Visual C++
public:
property SlabFoundationType StructuralUsage {
    SlabFoundationType get ();
    void set (SlabFoundationType value);
}

Remarks

The StructuralUsage property is a read only property that returns the walls designated usage. Example values of this property are Non Bearing, Bearing, Shear, Combined etc.

See Also

Floor Class
Autodesk.Revit.Elements Namespace


FootPrintRoof Class

[image]

Revit 2010 API
FootPrintRoof Class
Members See Also Send Feedback
Represents kinds of FootPrintRoofs.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FootPrintRoof : RoofBase
Visual Basic (Declaration)
Public Class FootPrintRoof _
    Inherits RoofBase
Visual C++
public ref class FootPrintRoof : public RoofBase

Remarks

The FootPrintRoof object represents some kinds of FootPrintRoof in Revit. The RoofType property is used to distinguish the type of the roof. The FootPrintRoof object is derived from the HostObject object and hence it supports all the properties and methods of that object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.RoofBase
Autodesk.Revit.Elements..::.FootPrintRoof

See Also

FootPrintRoof Members
Autodesk.Revit.Elements Namespace


FootPrintRoof Members

[image] [image]

Revit 2010 API
FootPrintRoof Members
FootPrintRoof Class Constructors Methods Properties See Also Send Feedback

The FootPrintRoof type exposes the following members.

Constructors

Name | Description
FootPrintRoof | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetProfiles | Retrieve all the curveLoops of FootPrintRoof.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurtainGrids | Retrieve all the CurtainGrid objects of a FootPrintRoof.
DefinesSlope | Retrieve or set the DefinesSlope of the curve.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase.)
ExtendIntoWall | Retrieve or set whether extend into wall the curve.
FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Offset | Retrieve or set the Offset of the curve.
Overhang | Retrieve or set the Overhang of the curve.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RoofType | Retrieve or set the Type. (Inherited from RoofBase.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase.)
SlopeAngle | Retrieve or set the SlopeAngle of the curve.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FootPrintRoof Class
Autodesk.Revit.Elements Namespace


FootPrintRoof Constructor

[image]

Revit 2010 API
FootPrintRoof Constructor
FootPrintRoof Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FootPrintRoof()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FootPrintRoof()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FootPrintRoof Class
Autodesk.Revit.Elements Namespace


FootPrintRoof Methods

[image] [image]

Revit 2010 API
FootPrintRoof Methods
FootPrintRoof Class See Also Send Feedback

The FootPrintRoof type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetProfiles | Retrieve all the curveLoops of FootPrintRoof.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FootPrintRoof Class
Autodesk.Revit.Elements Namespace


GetProfiles Method

[image]

Revit 2010 API
FootPrintRoof..::.GetProfiles Method
FootPrintRoof Class See Also Send Feedback
Retrieve all the curveLoops of FootPrintRoof.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelCurveArrArray GetProfiles()
Visual Basic (Declaration)
Public Function GetProfiles As ModelCurveArrArray
Visual C++
public:
ModelCurveArrArray^ GetProfiles()

See Also

FootPrintRoof Class
Autodesk.Revit.Elements Namespace


FootPrintRoof Properties

[image] [image]

Revit 2010 API
FootPrintRoof Properties
FootPrintRoof Class See Also Send Feedback

The FootPrintRoof type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurtainGrids | Retrieve all the CurtainGrid objects of a FootPrintRoof.
DefinesSlope | Retrieve or set the DefinesSlope of the curve.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase.)
ExtendIntoWall | Retrieve or set whether extend into wall the curve.
FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Offset | Retrieve or set the Offset of the curve.
Overhang | Retrieve or set the Overhang of the curve.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RoofType | Retrieve or set the Type. (Inherited from RoofBase.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase.)
SlopeAngle | Retrieve or set the SlopeAngle of the curve.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FootPrintRoof Class
Autodesk.Revit.Elements Namespace


CurtainGrids Property

[image]

Revit 2010 API
FootPrintRoof..::.CurtainGrids Property
FootPrintRoof Class See Also Send Feedback
Retrieve all the CurtainGrid objects of a FootPrintRoof.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainGridSet CurtainGrids { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurtainGrids As CurtainGridSet
Visual C++
public:
property CurtainGridSet^ CurtainGrids {
    CurtainGridSet^ get ();
}

Remarks

Only when the object is a Curtain FootPrintRoof, this property makes sense.

See Also

FootPrintRoof Class
Autodesk.Revit.Elements Namespace


DefinesSlope Property

[image]

Revit 2010 API
FootPrintRoof..::.DefinesSlope Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set the DefinesSlope of the curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool DefinesSlope[
    ModelCurve pCurve
] { get; set; }
Visual Basic (Declaration)
Public Property DefinesSlope ( _
    pCurve As ModelCurve _
) As Boolean
Visual C++
public:
property bool DefinesSlope[ModelCurve^ pCurve] {
    bool get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, bool value);
}

Parameters

pCurve
Type: Autodesk.Revit.Elements..::.ModelCurve

See Also

FootPrintRoof Class
Autodesk.Revit.Elements Namespace


ExtendIntoWall Property

[image]

Revit 2010 API
FootPrintRoof..::.ExtendIntoWall Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set whether extend into wall the curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool ExtendIntoWall[
    ModelCurve pCurve
] { get; set; }
Visual Basic (Declaration)
Public Property ExtendIntoWall ( _
    pCurve As ModelCurve _
) As Boolean
Visual C++
public:
property bool ExtendIntoWall[ModelCurve^ pCurve] {
    bool get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, bool value);
}

Parameters

pCurve
Type: Autodesk.Revit.Elements..::.ModelCurve

Remarks

Only when the FootPrintRoof is created by pick walls, this property makes sense.

See Also

FootPrintRoof Class
Autodesk.Revit.Elements Namespace


Offset Property

[image]

Revit 2010 API
FootPrintRoof..::.Offset Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set the Offset of the curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Offset[
    ModelCurve pCurve
] { get; set; }
Visual Basic (Declaration)
Public Property Offset ( _
    pCurve As ModelCurve _
) As Double
Visual C++
public:
property double Offset[ModelCurve^ pCurve] {
    double get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, double value);
}

Parameters

pCurve
Type: Autodesk.Revit.Elements..::.ModelCurve

See Also

FootPrintRoof Class
Autodesk.Revit.Elements Namespace


Overhang Property

[image]

Revit 2010 API
FootPrintRoof..::.Overhang Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set the Overhang of the curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Overhang[
    ModelCurve pCurve
] { get; set; }
Visual Basic (Declaration)
Public Property Overhang ( _
    pCurve As ModelCurve _
) As Double
Visual C++
public:
property double Overhang[ModelCurve^ pCurve] {
    double get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, double value);
}

Parameters

pCurve
Type: Autodesk.Revit.Elements..::.ModelCurve

Remarks

Only when the FootPrintRoof is created by pick walls, this property makes sense.

See Also

FootPrintRoof Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
FootPrintRoof..::.Parameter Property
FootPrintRoof Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FootPrintRoof Class
FootPrintRoof Members
Autodesk.Revit.Elements Namespace


SlopeAngle Property

[image]

Revit 2010 API
FootPrintRoof..::.SlopeAngle Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set the SlopeAngle of the curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double SlopeAngle[
    ModelCurve pCurve
] { get; set; }
Visual Basic (Declaration)
Public Property SlopeAngle ( _
    pCurve As ModelCurve _
) As Double
Visual C++
public:
property double SlopeAngle[ModelCurve^ pCurve] {
    double get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, double value);
}

Parameters

pCurve
Type: Autodesk.Revit.Elements..::.ModelCurve

See Also

FootPrintRoof Class
Autodesk.Revit.Elements Namespace


Form Class

[image]

Revit 2010 API
Form Class
Members See Also Send Feedback
An object that represents a Form within the Autodesk Revit Massing Family.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Form : GenericForm
Visual Basic (Declaration)
Public Class Form _
    Inherits GenericForm
Visual C++
public ref class Form : public GenericForm

Remarks

This object is derived from the Element base object and as such supports all the methods of that object such as the ability to retrieve the parameters of that object. Please note that for any reference returned from a Form method, its GeometryObject will become invalid after a form modification method, e.g. MoveSubElement. Call the method on the Form object to retrieve the new reference if it is needed after the modification.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CombinableElement
Autodesk.Revit.Elements..::.GenericForm
Autodesk.Revit.Elements..::.Form

See Also

Form Members
Autodesk.Revit.Elements Namespace


Form Members

[image] [image]

Revit 2010 API
Form Members
Form Class Constructors Methods Properties See Also Send Feedback

The Form type exposes the following members.

Constructors

Name | Description
Form | For Internal Use Only.

Methods

Name | Description
AddEdge | Overloaded.
AddProfile | Add a profile into the form, by a specified edge/param.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanManipulateProfile | Tell if a profile can be deleted/moved/rotated.
CanManipulateSubElement | Tell if a sub element can be deleted/moved/rotated/scaled.
ConstrainProfiles | Constrain form profiles using the specified profile as master. This is an advanced version of property "AreProfilesConstrained", allowing specify the master profile.
DeleteProfile | Delete a profile of the form.
DeleteSubElement | Delete a face/edge/curve/vertex of the form, specified by a reference.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetControlPoints | Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).
GetCurvesAndEdgesReference | Given a point, return all edges and curves that it is lying on.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetPathCurveIndexByCurveReference | Given a reference to certain curve in the path, return its index.
GetProfileAndCurveLoopIndexFromReference | Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsAutoCreaseEdge | Tell if an edge is an auto-crease on a top/bottom cap face.
IsBeginningFace | Given a face, tell if it is a beginning cap face.
IsConnectingEdge | Tell if an edge is a connecting edge on a side face. Connecting edges connect vertices on different profiles.
IsCurveReference | Tell if the pick is the reference to a curve of the form.
IsEdgeReference | Tell if the pick is the reference to an edge of the form.
IsEndFace | Given a face, tell if it is an end cap face.
IsFaceReference | Tell if the pick is the reference to a face of the form.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsProfileEdge | Tell if an edge or curve is generated from a profile.
IsReferenceOnlyProfile | Tell if the profile is made by referencing existing geometry in the Revit model.
IsSideFace | Given a face, tell if it is a side face.
IsVertexReference | Tell if the pick is the reference to a vertex of the form.
MoveProfile | Move a profile of the form, specified by a reference, and an offset vector.
MoveSubElement | Move a face/edge/curve/vertex of the form, specified by a reference, and an offset vector.
RotateProfile | Rotate a profile of the form, by a specified number of degrees around a given axis.
RotateSubElement | Rotate a face/edge/curve/vertex of the form, by a specified number of degrees around a given axis.
ScaleProfile | Scale a profile of the form, by a specified origin and scale factor.
ScaleSubElement | Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AreProfilesConstrained | Get/set if the form's profiles are constrained.
BaseOffset | Retrieve/set the base offset of the form object. It is only valid for locked form.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
CurveLoopReferencesOnProfile | The curve references in certain curve loop, specified by profile index and curve loop index.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HasOneOrMoreReferenceProfiles | Tell if the form has any reference profile.
HasOpenGeometry | Tell if the form has an open geometry.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInXRayMode | Get/set if the form is in X-Ray mode.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PathCurveCount | The number of curves in the form path.
PathCurveReference | The curve reference in the path, specified by curve index.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProfileCount | The number of profiles in the form.
ProfileCurveLoopCount | The number of curve loops in certain profile, specified by profile index.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory. (Inherited from GenericForm.)
TopOffset | Retrieve/set the top offset of the form object. It is only valid for locked form.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Form Class
Autodesk.Revit.Elements Namespace


Form Constructor

[image]

Revit 2010 API
Form Constructor
Form Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Form()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Form()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Form Class
Autodesk.Revit.Elements Namespace


Form Methods

[image] [image]

Revit 2010 API
Form Methods
Form Class See Also Send Feedback

The Form type exposes the following members.

Methods

Name | Description
AddEdge | Overloaded.
AddProfile | Add a profile into the form, by a specified edge/param.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanManipulateProfile | Tell if a profile can be deleted/moved/rotated.
CanManipulateSubElement | Tell if a sub element can be deleted/moved/rotated/scaled.
ConstrainProfiles | Constrain form profiles using the specified profile as master. This is an advanced version of property "AreProfilesConstrained", allowing specify the master profile.
DeleteProfile | Delete a profile of the form.
DeleteSubElement | Delete a face/edge/curve/vertex of the form, specified by a reference.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetControlPoints | Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).
GetCurvesAndEdgesReference | Given a point, return all edges and curves that it is lying on.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetPathCurveIndexByCurveReference | Given a reference to certain curve in the path, return its index.
GetProfileAndCurveLoopIndexFromReference | Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsAutoCreaseEdge | Tell if an edge is an auto-crease on a top/bottom cap face.
IsBeginningFace | Given a face, tell if it is a beginning cap face.
IsConnectingEdge | Tell if an edge is a connecting edge on a side face. Connecting edges connect vertices on different profiles.
IsCurveReference | Tell if the pick is the reference to a curve of the form.
IsEdgeReference | Tell if the pick is the reference to an edge of the form.
IsEndFace | Given a face, tell if it is an end cap face.
IsFaceReference | Tell if the pick is the reference to a face of the form.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsProfileEdge | Tell if an edge or curve is generated from a profile.
IsReferenceOnlyProfile | Tell if the profile is made by referencing existing geometry in the Revit model.
IsSideFace | Given a face, tell if it is a side face.
IsVertexReference | Tell if the pick is the reference to a vertex of the form.
MoveProfile | Move a profile of the form, specified by a reference, and an offset vector.
MoveSubElement | Move a face/edge/curve/vertex of the form, specified by a reference, and an offset vector.
RotateProfile | Rotate a profile of the form, by a specified number of degrees around a given axis.
RotateSubElement | Rotate a face/edge/curve/vertex of the form, by a specified number of degrees around a given axis.
ScaleProfile | Scale a profile of the form, by a specified origin and scale factor.
ScaleSubElement | Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Form Class
Autodesk.Revit.Elements Namespace


AddEdge Method

[image] [image]

Revit 2010 API
Form..::.AddEdge Method
Form Class See Also Send Feedback

Overload List

Name | Description
AddEdge(Reference, XYZ) | Add an edge to the form, connecting two edges on different profiles, by a specified face of the form and a point on face.
AddEdge(Reference, Double, Reference, Double) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.

See Also

Form Class
Form Members
Autodesk.Revit.Elements Namespace


AddEdge Method (Reference, XYZ)

[image]

Revit 2010 API
Form..::.AddEdge Method (Reference, XYZ)
Form Class See Also Send Feedback
Add an edge to the form, connecting two edges on different profiles, by a specified face of the form and a point on face.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddEdge(
    Reference faceReference,
    XYZ point
)
Visual Basic (Declaration)
Public Sub AddEdge ( _
    faceReference As Reference, _
    point As XYZ _
)
Visual C++
public:
void AddEdge(
    Reference^ faceReference,
    XYZ^ point
)

Parameters

faceReference
Type: Autodesk.Revit.Geometry..::.Reference
The geometry reference of face
point
Type: Autodesk.Revit.Geometry..::.XYZ
A point on the face, defining the position of edge to be created.

See Also

Form Class
AddEdge Overload
Autodesk.Revit.Elements Namespace


AddEdge Method (Reference, Double, Reference, Double)

[image]

Revit 2010 API
Form..::.AddEdge Method (Reference, Double, Reference, Double)
Form Class See Also Send Feedback
Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddEdge(
    Reference startEdgeReference,
    double startParam,
    Reference endEdgeReference,
    double endParam
)
Visual Basic (Declaration)
Public Sub AddEdge ( _
    startEdgeReference As Reference, _
    startParam As Double, _
    endEdgeReference As Reference, _
    endParam As Double _
)
Visual C++
public:
void AddEdge(
    Reference^ startEdgeReference,
    double startParam,
    Reference^ endEdgeReference,
    double endParam
)

Parameters

startEdgeReference
Type: Autodesk.Revit.Geometry..::.Reference
The geometry reference of start edge
startParam
Type: System..::.Double
The param on start edge to specify the location.
endEdgeReference
Type: Autodesk.Revit.Geometry..::.Reference
The geometry reference of end edge
endParam
Type: System..::.Double
The param on end edge to specify the location.

See Also

Form Class
AddEdge Overload
Autodesk.Revit.Elements Namespace


AddProfile Method

[image]

Revit 2010 API
Form..::.AddProfile Method
Form Class See Also Send Feedback
Add a profile into the form, by a specified edge/param.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int AddProfile(
    Reference edgeReference,
    double param
)
Visual Basic (Declaration)
Public Function AddProfile ( _
    edgeReference As Reference, _
    param As Double _
) As Integer
Visual C++
public:
int AddProfile(
    Reference^ edgeReference,
    double param
)

Parameters

edgeReference
Type: Autodesk.Revit.Geometry..::.Reference
The geometry reference of edge.
param
Type: System..::.Double
The param on edge to specify the location.

Return Value

Returns the index of newly created profile.

See Also

Form Class
Autodesk.Revit.Elements Namespace


CanManipulateProfile Method

[image]

Revit 2010 API
Form..::.CanManipulateProfile Method
Form Class See Also Send Feedback
Tell if a profile can be deleted/moved/rotated.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool CanManipulateProfile(
    int profileIndex
)
Visual Basic (Declaration)
Public Function CanManipulateProfile ( _
    profileIndex As Integer _
) As Boolean
Visual C++
public:
bool CanManipulateProfile(
    int profileIndex
)

Parameters

profileIndex
Type: System..::.Int32
Index to specify the profile.

See Also

Form Class
Autodesk.Revit.Elements Namespace


CanManipulateSubElement Method

[image]

Revit 2010 API
Form..::.CanManipulateSubElement Method
Form Class See Also Send Feedback
Tell if a sub element can be deleted/moved/rotated/scaled.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool CanManipulateSubElement(
    Reference subElementReference
)
Visual Basic (Declaration)
Public Function CanManipulateSubElement ( _
    subElementReference As Reference _
) As Boolean
Visual C++
public:
bool CanManipulateSubElement(
    Reference^ subElementReference
)

Parameters

subElementReference
Type: Autodesk.Revit.Geometry..::.Reference
The geometry reference of face/edge/curve/vertex

See Also

Form Class
Autodesk.Revit.Elements Namespace


ConstrainProfiles Method

[image]

Revit 2010 API
Form..::.ConstrainProfiles Method
Form Class See Also Send Feedback
Constrain form profiles using the specified profile as master. This is an advanced version of property "AreProfilesConstrained", allowing specify the master profile.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ConstrainProfiles(
    int masterProfileIndex
)
Visual Basic (Declaration)
Public Sub ConstrainProfiles ( _
    masterProfileIndex As Integer _
)
Visual C++
public:
void ConstrainProfiles(
    int masterProfileIndex
)

Parameters

masterProfileIndex
Type: System..::.Int32
Index to specify the profile used as master profile.

See Also

Form Class
Autodesk.Revit.Elements Namespace


DeleteProfile Method

[image]

Revit 2010 API
Form..::.DeleteProfile Method
Form Class See Also Send Feedback
Delete a profile of the form.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void DeleteProfile(
    int profileIndex
)
Visual Basic (Declaration)
Public Sub DeleteProfile ( _
    profileIndex As Integer _
)
Visual C++
public:
void DeleteProfile(
    int profileIndex
)

Parameters

profileIndex
Type: System..::.Int32
Index to specify the profile.

See Also

Form Class
Autodesk.Revit.Elements Namespace


DeleteSubElement Method

[image]

Revit 2010 API
Form..::.DeleteSubElement Method
Form Class See Also Send Feedback
Delete a face/edge/curve/vertex of the form, specified by a reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void DeleteSubElement(
    Reference subElementReference
)
Visual Basic (Declaration)
Public Sub DeleteSubElement ( _
    subElementReference As Reference _
)
Visual C++
public:
void DeleteSubElement(
    Reference^ subElementReference
)

Parameters

subElementReference
Type: Autodesk.Revit.Geometry..::.Reference
The geometry reference of face/edge/curve/vertex

See Also

Form Class
Autodesk.Revit.Elements Namespace


GetControlPoints Method

[image]

Revit 2010 API
Form..::.GetControlPoints Method
Form Class See Also Send Feedback
Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferenceArray GetControlPoints(
    Reference curveOrEdgeOrFaceReference
)
Visual Basic (Declaration)
Public Function GetControlPoints ( _
    curveOrEdgeOrFaceReference As Reference _
) As ReferenceArray
Visual C++
public:
ReferenceArray^ GetControlPoints(
    Reference^ curveOrEdgeOrFaceReference
)

Parameters

curveOrEdgeOrFaceReference
Type: Autodesk.Revit.Geometry..::.Reference
The reference of an edge or curve or face.

Return Value

Returns the reference array containing all control points lying on it.

See Also

Form Class
Autodesk.Revit.Elements Namespace


GetCurvesAndEdgesReference Method

[image]

Revit 2010 API
Form..::.GetCurvesAndEdgesReference Method
Form Class See Also Send Feedback
Given a point, return all edges and curves that it is lying on.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferenceArray GetCurvesAndEdgesReference(
    Reference pointReference
)
Visual Basic (Declaration)
Public Function GetCurvesAndEdgesReference ( _
    pointReference As Reference _
) As ReferenceArray
Visual C++
public:
ReferenceArray^ GetCurvesAndEdgesReference(
    Reference^ pointReference
)

Parameters

pointReference
Type: Autodesk.Revit.Geometry..::.Reference
The reference of a point.

Return Value

Returns the reference array containing all edges and curves that the point is lying on.

See Also

Form Class
Autodesk.Revit.Elements Namespace


GetPathCurveIndexByCurveReference Method

[image]

Revit 2010 API
Form..::.GetPathCurveIndexByCurveReference Method
Form Class See Also Send Feedback
Given a reference to certain curve in the path, return its index.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int GetPathCurveIndexByCurveReference(
    Reference curveReference
)
Visual Basic (Declaration)
Public Function GetPathCurveIndexByCurveReference ( _
    curveReference As Reference _
) As Integer
Visual C++
public:
int GetPathCurveIndexByCurveReference(
    Reference^ curveReference
)

Parameters

curveReference
Type: Autodesk.Revit.Geometry..::.Reference
Reference to the curve in path

See Also

Form Class
Autodesk.Revit.Elements Namespace


GetProfileAndCurveLoopIndexFromReference Method

[image]

Revit 2010 API
Form..::.GetProfileAndCurveLoopIndexFromReference Method
Form Class See Also Send Feedback
Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void GetProfileAndCurveLoopIndexFromReference(
    Reference curveOrEdgeReference,
    ref int profileIndex,
    ref int curveLoopIndex
)
Visual Basic (Declaration)
Public Sub GetProfileAndCurveLoopIndexFromReference ( _
    curveOrEdgeReference As Reference, _
    ByRef profileIndex As Integer, _
    ByRef curveLoopIndex As Integer _
)
Visual C++
public:
void GetProfileAndCurveLoopIndexFromReference(
    Reference^ curveOrEdgeReference,
    int% profileIndex,
    int% curveLoopIndex
)

Parameters

curveOrEdgeReference
Type: Autodesk.Revit.Geometry..::.Reference
Reference to a curve/edge that is part of one profile
profileIndex
Type: System..::.Int32 %
Profile index for output
curveLoopIndex
Type: System..::.Int32 %
Curve loop index for output

See Also

Form Class
Autodesk.Revit.Elements Namespace


IsAutoCreaseEdge Method

[image]

Revit 2010 API
Form..::.IsAutoCreaseEdge Method
Form Class See Also Send Feedback
Tell if an edge is an auto-crease on a top/bottom cap face.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsAutoCreaseEdge(
    Reference edgeReference
)
Visual Basic (Declaration)
Public Function IsAutoCreaseEdge ( _
    edgeReference As Reference _
) As Boolean
Visual C++
public:
bool IsAutoCreaseEdge(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.Geometry..::.Reference
The reference of the edge to be checked.

See Also

Form Class
Autodesk.Revit.Elements Namespace


IsBeginningFace Method

[image]

Revit 2010 API
Form..::.IsBeginningFace Method
Form Class See Also Send Feedback
Given a face, tell if it is a beginning cap face.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsBeginningFace(
    Reference faceReference
)
Visual Basic (Declaration)
Public Function IsBeginningFace ( _
    faceReference As Reference _
) As Boolean
Visual C++
public:
bool IsBeginningFace(
    Reference^ faceReference
)

Parameters

faceReference
Type: Autodesk.Revit.Geometry..::.Reference
The reference of the face to be checked.

See Also

Form Class
Autodesk.Revit.Elements Namespace


IsConnectingEdge Method

[image]

Revit 2010 API
Form..::.IsConnectingEdge Method
Form Class See Also Send Feedback
Tell if an edge is a connecting edge on a side face. Connecting edges connect vertices on different profiles.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsConnectingEdge(
    Reference edgeReference
)
Visual Basic (Declaration)
Public Function IsConnectingEdge ( _
    edgeReference As Reference _
) As Boolean
Visual C++
public:
bool IsConnectingEdge(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.Geometry..::.Reference
The reference of the edge to be checked.

See Also

Form Class
Autodesk.Revit.Elements Namespace


IsCurveReference Method

[image]

Revit 2010 API
Form..::.IsCurveReference Method
Form Class See Also Send Feedback
Tell if the pick is the reference to a curve of the form.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsCurveReference(
    Reference curveReference
)
Visual Basic (Declaration)
Public Function IsCurveReference ( _
    curveReference As Reference _
) As Boolean
Visual C++
public:
bool IsCurveReference(
    Reference^ curveReference
)

Parameters

curveReference
Type: Autodesk.Revit.Geometry..::.Reference
Reference to be checked.

See Also

Form Class
Autodesk.Revit.Elements Namespace


IsEdgeReference Method

[image]

Revit 2010 API
Form..::.IsEdgeReference Method
Form Class See Also Send Feedback
Tell if the pick is the reference to an edge of the form.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsEdgeReference(
    Reference edgeReference
)
Visual Basic (Declaration)
Public Function IsEdgeReference ( _
    edgeReference As Reference _
) As Boolean
Visual C++
public:
bool IsEdgeReference(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.Geometry..::.Reference
Reference to be checked.

See Also

Form Class
Autodesk.Revit.Elements Namespace


IsEndFace Method

[image]

Revit 2010 API
Form..::.IsEndFace Method
Form Class See Also Send Feedback
Given a face, tell if it is an end cap face.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsEndFace(
    Reference faceReference
)
Visual Basic (Declaration)
Public Function IsEndFace ( _
    faceReference As Reference _
) As Boolean
Visual C++
public:
bool IsEndFace(
    Reference^ faceReference
)

Parameters

faceReference
Type: Autodesk.Revit.Geometry..::.Reference
The reference of the face to be checked.

See Also

Form Class
Autodesk.Revit.Elements Namespace


IsFaceReference Method

[image]

Revit 2010 API
Form..::.IsFaceReference Method
Form Class See Also Send Feedback
Tell if the pick is the reference to a face of the form.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsFaceReference(
    Reference faceReference
)
Visual Basic (Declaration)
Public Function IsFaceReference ( _
    faceReference As Reference _
) As Boolean
Visual C++
public:
bool IsFaceReference(
    Reference^ faceReference
)

Parameters

faceReference
Type: Autodesk.Revit.Geometry..::.Reference
Reference to be checked.

See Also

Form Class
Autodesk.Revit.Elements Namespace


IsProfileEdge Method

[image]

Revit 2010 API
Form..::.IsProfileEdge Method
Form Class See Also Send Feedback
Tell if an edge or curve is generated from a profile.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsProfileEdge(
    Reference curveOrEdgeReference
)
Visual Basic (Declaration)
Public Function IsProfileEdge ( _
    curveOrEdgeReference As Reference _
) As Boolean
Visual C++
public:
bool IsProfileEdge(
    Reference^ curveOrEdgeReference
)

Parameters

curveOrEdgeReference
Type: Autodesk.Revit.Geometry..::.Reference
The reference of the edge or curve to be checked.

See Also

Form Class
Autodesk.Revit.Elements Namespace


IsReferenceOnlyProfile Method

[image]

Revit 2010 API
Form..::.IsReferenceOnlyProfile Method
Form Class See Also Send Feedback
Tell if the profile is made by referencing existing geometry in the Revit model.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsReferenceOnlyProfile(
    int profileIndex
)
Visual Basic (Declaration)
Public Function IsReferenceOnlyProfile ( _
    profileIndex As Integer _
) As Boolean
Visual C++
public:
bool IsReferenceOnlyProfile(
    int profileIndex
)

Parameters

profileIndex
Type: System..::.Int32
Index to specify the profile to be checked.

See Also

Form Class
Autodesk.Revit.Elements Namespace


IsSideFace Method

[image]

Revit 2010 API
Form..::.IsSideFace Method
Form Class See Also Send Feedback
Given a face, tell if it is a side face.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsSideFace(
    Reference faceReference
)
Visual Basic (Declaration)
Public Function IsSideFace ( _
    faceReference As Reference _
) As Boolean
Visual C++
public:
bool IsSideFace(
    Reference^ faceReference
)

Parameters

faceReference
Type: Autodesk.Revit.Geometry..::.Reference
The reference of the face to be checked.

See Also

Form Class
Autodesk.Revit.Elements Namespace


IsVertexReference Method

[image]

Revit 2010 API
Form..::.IsVertexReference Method
Form Class See Also Send Feedback
Tell if the pick is the reference to a vertex of the form.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsVertexReference(
    Reference vertexReference
)
Visual Basic (Declaration)
Public Function IsVertexReference ( _
    vertexReference As Reference _
) As Boolean
Visual C++
public:
bool IsVertexReference(
    Reference^ vertexReference
)

Parameters

vertexReference
Type: Autodesk.Revit.Geometry..::.Reference
Reference to be checked.

See Also

Form Class
Autodesk.Revit.Elements Namespace


MoveProfile Method

[image]

Revit 2010 API
Form..::.MoveProfile Method
Form Class See Also Send Feedback
Move a profile of the form, specified by a reference, and an offset vector.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void MoveProfile(
    int profileIndex,
    XYZ offset
)
Visual Basic (Declaration)
Public Sub MoveProfile ( _
    profileIndex As Integer, _
    offset As XYZ _
)
Visual C++
public:
void MoveProfile(
    int profileIndex,
    XYZ^ offset
)

Parameters

profileIndex
Type: System..::.Int32
Index to specify the profile.
offset
Type: Autodesk.Revit.Geometry..::.XYZ
The vector by which the element is to be moved.

See Also

Form Class
Autodesk.Revit.Elements Namespace


MoveSubElement Method

[image]

Revit 2010 API
Form..::.MoveSubElement Method
Form Class See Also Send Feedback
Move a face/edge/curve/vertex of the form, specified by a reference, and an offset vector.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void MoveSubElement(
    Reference subElementReference,
    XYZ offset
)
Visual Basic (Declaration)
Public Sub MoveSubElement ( _
    subElementReference As Reference, _
    offset As XYZ _
)
Visual C++
public:
void MoveSubElement(
    Reference^ subElementReference,
    XYZ^ offset
)

Parameters

subElementReference
Type: Autodesk.Revit.Geometry..::.Reference
The geometry reference of face/edge/curve/vertex
offset
Type: Autodesk.Revit.Geometry..::.XYZ
The vector by which the element is to be moved.

See Also

Form Class
Autodesk.Revit.Elements Namespace


RotateProfile Method

[image]

Revit 2010 API
Form..::.RotateProfile Method
Form Class See Also Send Feedback
Rotate a profile of the form, by a specified number of degrees around a given axis.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RotateProfile(
    int profileIndex,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Sub RotateProfile ( _
    profileIndex As Integer, _
    axis As Line, _
    angle As Double _
)
Visual C++
public:
void RotateProfile(
    int profileIndex,
    Line^ axis,
    double angle
)

Parameters

profileIndex
Type: System..::.Int32
Index to specify the profile.
axis
Type: Autodesk.Revit.Geometry..::.Line
An unbounded line that represents the axis of rotation.
angle
Type: System..::.Double
The number of degrees, in radians, by which the element is to be rotated around the specified axis.

See Also

Form Class
Autodesk.Revit.Elements Namespace


RotateSubElement Method

[image]

Revit 2010 API
Form..::.RotateSubElement Method
Form Class See Also Send Feedback
Rotate a face/edge/curve/vertex of the form, by a specified number of degrees around a given axis.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RotateSubElement(
    Reference subElementReference,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Sub RotateSubElement ( _
    subElementReference As Reference, _
    axis As Line, _
    angle As Double _
)
Visual C++
public:
void RotateSubElement(
    Reference^ subElementReference,
    Line^ axis,
    double angle
)

Parameters

subElementReference
Type: Autodesk.Revit.Geometry..::.Reference
The geometry reference of face/edge/curve/vertex
axis
Type: Autodesk.Revit.Geometry..::.Line
An unbounded line that represents the axis of rotation.
angle
Type: System..::.Double
The number of degrees, in radians, by which the element is to be rotated around the specified axis.

See Also

Form Class
Autodesk.Revit.Elements Namespace


ScaleProfile Method

[image]

Revit 2010 API
Form..::.ScaleProfile Method
Form Class See Also Send Feedback
Scale a profile of the form, by a specified origin and scale factor.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ScaleProfile(
    int profileIndex,
    double factor,
    XYZ origin
)
Visual Basic (Declaration)
Public Sub ScaleProfile ( _
    profileIndex As Integer, _
    factor As Double, _
    origin As XYZ _
)
Visual C++
public:
void ScaleProfile(
    int profileIndex,
    double factor,
    XYZ^ origin
)

Parameters

profileIndex
Type: System..::.Int32
Index to specify the profile.
factor
Type: System..::.Double
The scale factor, it should be large than zero.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The origin where scale happens.

See Also

Form Class
Autodesk.Revit.Elements Namespace


ScaleSubElement Method

[image]

Revit 2010 API
Form..::.ScaleSubElement Method
Form Class See Also Send Feedback
Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ScaleSubElement(
    Reference subElementReference,
    double factor,
    XYZ origin
)
Visual Basic (Declaration)
Public Sub ScaleSubElement ( _
    subElementReference As Reference, _
    factor As Double, _
    origin As XYZ _
)
Visual C++
public:
void ScaleSubElement(
    Reference^ subElementReference,
    double factor,
    XYZ^ origin
)

Parameters

subElementReference
Type: Autodesk.Revit.Geometry..::.Reference
The geometry reference of face/edge/curve/vertex
factor
Type: System..::.Double
The scale factor, it should be large than zero.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The origin where scale happens.

See Also

Form Class
Autodesk.Revit.Elements Namespace


Form Properties

[image] [image]

Revit 2010 API
Form Properties
Form Class See Also Send Feedback

The Form type exposes the following members.

Properties

Name | Description
AreProfilesConstrained | Get/set if the form's profiles are constrained.
BaseOffset | Retrieve/set the base offset of the form object. It is only valid for locked form.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
CurveLoopReferencesOnProfile | The curve references in certain curve loop, specified by profile index and curve loop index.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HasOneOrMoreReferenceProfiles | Tell if the form has any reference profile.
HasOpenGeometry | Tell if the form has an open geometry.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInXRayMode | Get/set if the form is in X-Ray mode.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PathCurveCount | The number of curves in the form path.
PathCurveReference | The curve reference in the path, specified by curve index.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProfileCount | The number of profiles in the form.
ProfileCurveLoopCount | The number of curve loops in certain profile, specified by profile index.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory. (Inherited from GenericForm.)
TopOffset | Retrieve/set the top offset of the form object. It is only valid for locked form.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Form Class
Autodesk.Revit.Elements Namespace


AreProfilesConstrained Property

[image]

Revit 2010 API
Form..::.AreProfilesConstrained Property
Form Class See Also Send Feedback
Get/set if the form's profiles are constrained.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool AreProfilesConstrained { get; set; }
Visual Basic (Declaration)
Public Property AreProfilesConstrained As Boolean
Visual C++
public:
property bool AreProfilesConstrained {
    bool get ();
    void set (bool value);
}

See Also

Form Class
Autodesk.Revit.Elements Namespace


BaseOffset Property

[image]

Revit 2010 API
Form..::.BaseOffset Property
Form Class See Also Send Feedback
Retrieve/set the base offset of the form object. It is only valid for locked form.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double BaseOffset { get; set; }
Visual Basic (Declaration)
Public Property BaseOffset As Double
Visual C++
public:
property double BaseOffset {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when this is not a locked form.
System..::.ArgumentException | Thrown when the value is invalid.
System..::.Exception | Thrown when it fail to get/set BaseOffset.

See Also

Form Class
Autodesk.Revit.Elements Namespace


CurveLoopReferencesOnProfile Property

[image]

Revit 2010 API
Form..::.CurveLoopReferencesOnProfile Property
Form Class See Also Send Feedback
The curve references in certain curve loop, specified by profile index and curve loop index.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferenceArray CurveLoopReferencesOnProfile[
    int profileIndex,
    int curveLoopIndex
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurveLoopReferencesOnProfile ( _
    profileIndex As Integer, _
    curveLoopIndex As Integer _
) As ReferenceArray
Visual C++
public:
property ReferenceArray^ CurveLoopReferencesOnProfile[int profileIndex, int curveLoopIndex] {
    ReferenceArray^ get (int profileIndex, int curveLoopIndex);
}

Parameters

profileIndex
Type: System..::.Int32
Index to specify the profile, should be within 0 and (ProfileCount - 1).
curveLoopIndex
Type: System..::.Int32
Index to specify the curve loop, should be within 0 and (CurveLoopCount - 1).

See Also

Form Class
Autodesk.Revit.Elements Namespace


HasOneOrMoreReferenceProfiles Property

[image]

Revit 2010 API
Form..::.HasOneOrMoreReferenceProfiles Property
Form Class See Also Send Feedback
Tell if the form has any reference profile.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool HasOneOrMoreReferenceProfiles { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasOneOrMoreReferenceProfiles As Boolean
Visual C++
public:
property bool HasOneOrMoreReferenceProfiles {
    bool get ();
}

See Also

Form Class
Autodesk.Revit.Elements Namespace


HasOpenGeometry Property

[image]

Revit 2010 API
Form..::.HasOpenGeometry Property
Form Class See Also Send Feedback
Tell if the form has an open geometry.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool HasOpenGeometry { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasOpenGeometry As Boolean
Visual C++
public:
property bool HasOpenGeometry {
    bool get ();
}

See Also

Form Class
Autodesk.Revit.Elements Namespace


IsInXRayMode Property

[image]

Revit 2010 API
Form..::.IsInXRayMode Property
Form Class See Also Send Feedback
Get/set if the form is in X-Ray mode.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsInXRayMode { get; set; }
Visual Basic (Declaration)
Public Property IsInXRayMode As Boolean
Visual C++
public:
property bool IsInXRayMode {
    bool get ();
    void set (bool value);
}

See Also

Form Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Form..::.Parameter Property
Form Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Form Class
Form Members
Autodesk.Revit.Elements Namespace


PathCurveCount Property

[image]

Revit 2010 API
Form..::.PathCurveCount Property
Form Class See Also Send Feedback
The number of curves in the form path.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int PathCurveCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property PathCurveCount As Integer
Visual C++
public:
property int PathCurveCount {
    int get ();
}

See Also

Form Class
Autodesk.Revit.Elements Namespace


PathCurveReference Property

[image]

Revit 2010 API
Form..::.PathCurveReference Property
Form Class See Also Send Feedback
The curve reference in the path, specified by curve index.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference PathCurveReference[
    int curveIndex
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property PathCurveReference ( _
    curveIndex As Integer _
) As Reference
Visual C++
public:
property Reference^ PathCurveReference[int curveIndex] {
    Reference^ get (int curveIndex);
}

Parameters

curveIndex
Type: System..::.Int32
Index to specify the curve in path

See Also

Form Class
Autodesk.Revit.Elements Namespace


ProfileCount Property

[image]

Revit 2010 API
Form..::.ProfileCount Property
Form Class See Also Send Feedback
The number of profiles in the form.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int ProfileCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProfileCount As Integer
Visual C++
public:
property int ProfileCount {
    int get ();
}

See Also

Form Class
Autodesk.Revit.Elements Namespace


ProfileCurveLoopCount Property

[image]

Revit 2010 API
Form..::.ProfileCurveLoopCount Property
Form Class See Also Send Feedback
The number of curve loops in certain profile, specified by profile index.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int ProfileCurveLoopCount[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProfileCurveLoopCount ( _
    index As Integer _
) As Integer
Visual C++
public:
property int ProfileCurveLoopCount[int index] {
    int get (int index);
}

Parameters

index
Type: System..::.Int32
Index to specify the profile, should be within 0 and (ProfileCount - 1).

See Also

Form Class
Autodesk.Revit.Elements Namespace


TopOffset Property

[image]

Revit 2010 API
Form..::.TopOffset Property
Form Class See Also Send Feedback
Retrieve/set the top offset of the form object. It is only valid for locked form.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double TopOffset { get; set; }
Visual Basic (Declaration)
Public Property TopOffset As Double
Visual C++
public:
property double TopOffset {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when this is not a locked form.
System..::.ArgumentException | Thrown when the value is invalid.
System..::.Exception | Thrown when it fail to get/set TopOffset.

See Also

Form Class
Autodesk.Revit.Elements Namespace


gbXMLParamElem Class

[image]

Revit 2010 API
gbXMLParamElem Class
Members Example See Also Send Feedback
An object that represents the gbXML Parameters within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class gbXMLParamElem : Element
Visual Basic (Declaration)
Public Class gbXMLParamElem _
    Inherits Element
Visual C++
public ref class gbXMLParamElem : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Examples

CopyC#
public void GetInfo_gbXMLParamElem(Document document)
{
    // The gbXMLParamElem can be retrieved from ProjectInformation only
    gbXMLParamElem xmlPara = document.ProjectInformation.gbXMLSettings;

    if (null != xmlPara)
    {
        string message = "gbXMLParamElem : ";
        message += "\nBuildingType : " + xmlPara.BuildingType;
        message += "\nPostal Code : " + xmlPara.PostalCode;
        MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
    }
}
CopyVB.NET
Public Sub GetInfo_gbXMLParamElem(ByVal document As Document)
    ' The gbXMLParamElem can be retrieved from ProjectInformation only
    Dim xmlPara As Autodesk.Revit.Elements.gbXMLParamElem = document.ProjectInformation.gbXMLSettings

    If xmlPara IsNot Nothing Then
        Dim message As String = "gbXMLParamElem : "
        message += vbLf & "BuildingType : " & xmlPara.BuildingType
        message += vbLf & "Postal Code : " & xmlPara.PostalCode
        MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.gbXMLParamElem

See Also

gbXMLParamElem Members
Autodesk.Revit.Elements Namespace


gbXMLParamElem Members

[image] [image]

Revit 2010 API
gbXMLParamElem Members
gbXMLParamElem Class Constructors Methods Properties See Also Send Feedback

The gbXMLParamElem type exposes the following members.

Constructors

Name | Description
gbXMLParamElem | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
BuildingConstruction | Get the Building Construction of the Project Information.
BuildingService | Get or Set the Building Service of the Project Information.
BuildingType | Get or Set the Building Type of the Project Information.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ExportComplexity | The gbXML export complexity.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GroundPlane | Get the Ground Plane of the Project Information.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PostalCode | Get or Set the Postal Code of the Project Information.
ProjectLocation | Get the Location of the Project Information.
ProjectPhase | Get the Project Phase of the Project Information.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

gbXMLParamElem Class
Autodesk.Revit.Elements Namespace


gbXMLParamElem Constructor

[image]

Revit 2010 API
gbXMLParamElem Constructor
gbXMLParamElem Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public gbXMLParamElem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
gbXMLParamElem()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

gbXMLParamElem Class
Autodesk.Revit.Elements Namespace


gbXMLParamElem Methods

[image] [image]

Revit 2010 API
gbXMLParamElem Methods
gbXMLParamElem Class See Also Send Feedback

The gbXMLParamElem type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

gbXMLParamElem Class
Autodesk.Revit.Elements Namespace


gbXMLParamElem Properties

[image] [image]

Revit 2010 API
gbXMLParamElem Properties
gbXMLParamElem Class See Also Send Feedback

The gbXMLParamElem type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
BuildingConstruction | Get the Building Construction of the Project Information.
BuildingService | Get or Set the Building Service of the Project Information.
BuildingType | Get or Set the Building Type of the Project Information.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ExportComplexity | The gbXML export complexity.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GroundPlane | Get the Ground Plane of the Project Information.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PostalCode | Get or Set the Postal Code of the Project Information.
ProjectLocation | Get the Location of the Project Information.
ProjectPhase | Get the Project Phase of the Project Information.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

gbXMLParamElem Class
Autodesk.Revit.Elements Namespace


BuildingConstruction Property

[image]

Revit 2010 API
gbXMLParamElem..::.BuildingConstruction Property
gbXMLParamElem Class See Also Send Feedback
Get the Building Construction of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MEPBuildingConstruction BuildingConstruction { get; }
Visual Basic (Declaration)
Public ReadOnly Property BuildingConstruction As MEPBuildingConstruction
Visual C++
public:
property MEPBuildingConstruction^ BuildingConstruction {
    MEPBuildingConstruction^ get ();
}

Remarks

This property is used to get or set the Building Construction of the Project Information.

See Also

gbXMLParamElem Class
Autodesk.Revit.Elements Namespace


BuildingService Property

[image]

Revit 2010 API
gbXMLParamElem..::.BuildingService Property
gbXMLParamElem Class See Also Send Feedback
Get or Set the Building Service of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ServiceType BuildingService { get; set; }
Visual Basic (Declaration)
Public Property BuildingService As ServiceType
Visual C++
public:
property ServiceType BuildingService {
    ServiceType get ();
    void set (ServiceType value);
}

Remarks

This property is used to get or set the Building Service of the Project Information.

See Also

gbXMLParamElem Class
Autodesk.Revit.Elements Namespace


BuildingType Property

[image]

Revit 2010 API
gbXMLParamElem..::.BuildingType Property
gbXMLParamElem Class See Also Send Feedback
Get or Set the Building Type of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BuildingType BuildingType { get; set; }
Visual Basic (Declaration)
Public Property BuildingType As BuildingType
Visual C++
public:
property BuildingType BuildingType {
    BuildingType get ();
    void set (BuildingType value);
}

Remarks

This property is used to get or set the Building Type of the Project Information.

See Also

gbXMLParamElem Class
Autodesk.Revit.Elements Namespace


ExportComplexity Property

[image]

Revit 2010 API
gbXMLParamElem..::.ExportComplexity Property
gbXMLParamElem Class See Also Send Feedback
The gbXML export complexity.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ExportComplexity ExportComplexity { get; set; }
Visual Basic (Declaration)
Public Property ExportComplexity As ExportComplexity
Visual C++
public:
property ExportComplexity ExportComplexity {
    ExportComplexity get ();
    void set (ExportComplexity value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the input exportComplexity is not one of the ExportComplexity values.

See Also

gbXMLParamElem Class
Autodesk.Revit.Elements Namespace


GroundPlane Property

[image]

Revit 2010 API
gbXMLParamElem..::.GroundPlane Property
gbXMLParamElem Class See Also Send Feedback
Get the Ground Plane of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Level GroundPlane { get; set; }
Visual Basic (Declaration)
Public Property GroundPlane As Level
Visual C++
public:
property Level^ GroundPlane {
    Level^ get ();
    void set (Level^ value);
}

Remarks

This property is used to get the Ground Plane of the Project Information.

See Also

gbXMLParamElem Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
gbXMLParamElem..::.Parameter Property
gbXMLParamElem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

gbXMLParamElem Class
gbXMLParamElem Members
Autodesk.Revit.Elements Namespace


PostalCode Property

[image]

Revit 2010 API
gbXMLParamElem..::.PostalCode Property
gbXMLParamElem Class See Also Send Feedback
Get or Set the Postal Code of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string PostalCode { get; set; }
Visual Basic (Declaration)
Public Property PostalCode As String
Visual C++
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the ZIP Code of the Project Information.

See Also

gbXMLParamElem Class
Autodesk.Revit.Elements Namespace


ProjectLocation Property

[image]

Revit 2010 API
gbXMLParamElem..::.ProjectLocation Property
gbXMLParamElem Class See Also Send Feedback
Get the Location of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProjectLocation ProjectLocation { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectLocation As ProjectLocation
Visual C++
public:
property ProjectLocation^ ProjectLocation {
    ProjectLocation^ get ();
}

Remarks

This property is used to get the location of the Project Information.

See Also

gbXMLParamElem Class
Autodesk.Revit.Elements Namespace


ProjectPhase Property

[image]

Revit 2010 API
gbXMLParamElem..::.ProjectPhase Property
gbXMLParamElem Class See Also Send Feedback
Get the Project Phase of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Phase ProjectPhase { get; set; }
Visual Basic (Declaration)
Public Property ProjectPhase As Phase
Visual C++
public:
property Phase^ ProjectPhase {
    Phase^ get ();
    void set (Phase^ value);
}

Remarks

This property is used to get the Project Phase of the Project Information.

See Also

gbXMLParamElem Class
Autodesk.Revit.Elements Namespace


GenericForm Class

[image]

Revit 2010 API
GenericForm Class
Members See Also Send Feedback
Provides access to the Generic Form model in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class GenericForm : CombinableElement
Visual Basic (Declaration)
Public Class GenericForm _
    Inherits CombinableElement
Visual C++
public ref class GenericForm : public CombinableElement

Remarks

The Generic Form object can be queried for a generic form for use in family modeling and massing.it is the base class of Sweep, Blend, Extrusion, Revolution.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CombinableElement
Autodesk.Revit.Elements..::.GenericForm
Autodesk.Revit.Elements..::.Blend
Autodesk.Revit.Elements..::.Extrusion
Autodesk.Revit.Elements..::.Form
Autodesk.Revit.Elements..::.Revolution
Autodesk.Revit.Elements..::.Sweep
Autodesk.Revit.Elements..::.SweptBlend

See Also

GenericForm Members
Autodesk.Revit.Elements Namespace


GenericForm Members

[image] [image]

Revit 2010 API
GenericForm Members
GenericForm Class Constructors Methods Properties See Also Send Feedback

The GenericForm type exposes the following members.

Constructors

Name | Description
GenericForm | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the generic form.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the generic form.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsSolid | Identifies if the GenericForm is a solid or a void element.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Visible | The visibility of the GenericForm.

See Also

GenericForm Class
Autodesk.Revit.Elements Namespace


GenericForm Constructor

[image]

Revit 2010 API
GenericForm Constructor
GenericForm Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GenericForm()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GenericForm()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GenericForm Class
Autodesk.Revit.Elements Namespace


GenericForm Methods

[image] [image]

Revit 2010 API
GenericForm Methods
GenericForm Class See Also Send Feedback

The GenericForm type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the generic form.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the generic form.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GenericForm Class
Autodesk.Revit.Elements Namespace


GetVisibility Method

[image]

Revit 2010 API
GenericForm..::.GetVisibility Method
GenericForm Class See Also Send Feedback
Gets the visibility for the generic form.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic (Declaration)
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

Returns a copy of visibility settings for the generic form.

See Also

GenericForm Class
Autodesk.Revit.Elements Namespace


SetVisibility Method

[image]

Revit 2010 API
GenericForm..::.SetVisibility Method
GenericForm Class See Also Send Feedback
Sets the visibility for the generic form.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic (Declaration)
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit..::.FamilyElementVisibility

Remarks

The visibility of the generic form geometry can be changed for different types of views and detail levels in the project.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when visibility is null.
System..::.InvalidOperationException | Thrown when regeneration failed.

See Also

GenericForm Class
Autodesk.Revit.Elements Namespace


GenericForm Properties

[image] [image]

Revit 2010 API
GenericForm Properties
GenericForm Class See Also Send Feedback

The GenericForm type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsSolid | Identifies if the GenericForm is a solid or a void element.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Visible | The visibility of the GenericForm.

See Also

GenericForm Class
Autodesk.Revit.Elements Namespace


IsSolid Property

[image]

Revit 2010 API
GenericForm..::.IsSolid Property
GenericForm Class See Also Send Feedback
Identifies if the GenericForm is a solid or a void element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsSolid { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSolid As Boolean
Visual C++
public:
property bool IsSolid {
    bool get ();
}

Field Value

True if the form is a solid, false if the solid is a void element.

See Also

GenericForm Class
Autodesk.Revit.Elements Namespace


Name Property

[image]

Revit 2010 API
GenericForm..::.Name Property
GenericForm Class See Also Send Feedback
Get and Set the Name property

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The method set is override to forbid the user to change the Name. When the user tries to call the method set for GenericForm object, an InvalidOperationException will be thrown.

See Also

GenericForm Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
GenericForm..::.Parameter Property
GenericForm Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

GenericForm Class
GenericForm Members
Autodesk.Revit.Elements Namespace


Subcategory Property

[image]

Revit 2010 API
GenericForm..::.Subcategory Property
GenericForm Class See Also Send Feedback
The subcategory.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Category Subcategory { get; set; }
Visual Basic (Declaration)
Public Property Subcategory As Category
Visual C++
public:
property Category^ Subcategory {
    Category^ get ();
    void set (Category^ value);
}

Remarks

The subcategory can be set to either the family category or one of its subcategories.

See Also

GenericForm Class
Autodesk.Revit.Elements Namespace


Visible Property

[image]

Revit 2010 API
GenericForm..::.Visible Property
GenericForm Class See Also Send Feedback
The visibility of the GenericForm.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Visible { get; }
Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
}

Field Value

True if the form is visible, false if it is hidden.

See Also

GenericForm Class
Autodesk.Revit.Elements Namespace


GenericFormSet Class

[image]

Revit 2010 API
GenericFormSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class GenericFormSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class GenericFormSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GenericFormSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.GenericFormSet

See Also

GenericFormSet Members
Autodesk.Revit.Elements Namespace


GenericFormSet Members

[image] [image]

Revit 2010 API
GenericFormSet Members
GenericFormSet Class Constructors Methods Properties See Also Send Feedback

The GenericFormSet type exposes the following members.

Constructors

Name | Description
GenericFormSet | Initializes a new instance of the GenericFormSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


GenericFormSet Constructor

[image]

Revit 2010 API
GenericFormSet Constructor
GenericFormSet Class See Also Send Feedback
Initializes a new instance of the GenericFormSet class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GenericFormSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GenericFormSet()

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


GenericFormSet Methods

[image] [image]

Revit 2010 API
GenericFormSet Methods
GenericFormSet Class See Also Send Feedback

The GenericFormSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


Clear Method

[image]

Revit 2010 API
GenericFormSet..::.Clear Method
GenericFormSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


Contains Method

[image]

Revit 2010 API
GenericFormSet..::.Contains Method
GenericFormSet Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    GenericForm item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As GenericForm _
) As Boolean
Visual C++
public:
virtual bool Contains(
    GenericForm^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.GenericForm

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


Erase Method

[image]

Revit 2010 API
GenericFormSet..::.Erase Method
GenericFormSet Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    GenericForm item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As GenericForm _
) As Integer
Visual C++
public:
virtual int Erase(
    GenericForm^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.GenericForm

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

[image]

Revit 2010 API
GenericFormSet..::.ForwardIterator Method
GenericFormSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual GenericFormSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As GenericFormSetIterator
Visual C++
public:
virtual GenericFormSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

[image]

Revit 2010 API
GenericFormSet..::.GetEnumerator Method
GenericFormSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


Insert Method

[image]

Revit 2010 API
GenericFormSet..::.Insert Method
GenericFormSet Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    GenericForm item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As GenericForm _
) As Boolean
Visual C++
public:
virtual bool Insert(
    GenericForm^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.GenericForm

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

[image]

Revit 2010 API
GenericFormSet..::.ReverseIterator Method
GenericFormSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual GenericFormSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As GenericFormSetIterator
Visual C++
public:
virtual GenericFormSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


GenericFormSet Properties

[image] [image]

Revit 2010 API
GenericFormSet Properties
GenericFormSet Class See Also Send Feedback

The GenericFormSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


IsEmpty Property

[image]

Revit 2010 API
GenericFormSet..::.IsEmpty Property
GenericFormSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


Size Property

[image]

Revit 2010 API
GenericFormSet..::.Size Property
GenericFormSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GenericFormSet Class
Autodesk.Revit.Elements Namespace


GenericFormSetIterator Class

[image]

Revit 2010 API
GenericFormSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class GenericFormSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class GenericFormSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GenericFormSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.GenericFormSetIterator

See Also

GenericFormSetIterator Members
Autodesk.Revit.Elements Namespace


GenericFormSetIterator Members

[image] [image]

Revit 2010 API
GenericFormSetIterator Members
GenericFormSetIterator Class Constructors Methods Properties See Also Send Feedback

The GenericFormSetIterator type exposes the following members.

Constructors

Name | Description
GenericFormSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GenericFormSetIterator Class
Autodesk.Revit.Elements Namespace


GenericFormSetIterator Constructor

[image]

Revit 2010 API
GenericFormSetIterator Constructor
GenericFormSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GenericFormSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GenericFormSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GenericFormSetIterator Class
Autodesk.Revit.Elements Namespace


GenericFormSetIterator Methods

[image] [image]

Revit 2010 API
GenericFormSetIterator Methods
GenericFormSetIterator Class See Also Send Feedback

The GenericFormSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GenericFormSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

[image]

Revit 2010 API
GenericFormSetIterator..::.MoveNext Method
GenericFormSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GenericFormSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

[image]

Revit 2010 API
GenericFormSetIterator..::.Reset Method
GenericFormSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GenericFormSetIterator Class
Autodesk.Revit.Elements Namespace


GenericFormSetIterator Properties

[image] [image]

Revit 2010 API
GenericFormSetIterator Properties
GenericFormSetIterator Class See Also Send Feedback

The GenericFormSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GenericFormSetIterator Class
Autodesk.Revit.Elements Namespace


Current Property

[image]

Revit 2010 API
GenericFormSetIterator..::.Current Property
GenericFormSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GenericFormSetIterator Class
Autodesk.Revit.Elements Namespace


GeomCombination Class

[image]

Revit 2010 API
GeomCombination Class
Members See Also Send Feedback
An element created by Join and Cut operations applied to combinable elements in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class GeomCombination : CombinableElement
Visual Basic (Declaration)
Public Class GeomCombination _
    Inherits CombinableElement
Visual C++
public ref class GeomCombination : public CombinableElement

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CombinableElement
Autodesk.Revit.Elements..::.GeomCombination

See Also

GeomCombination Members
Autodesk.Revit.Elements Namespace


GeomCombination Members

[image] [image]

Revit 2010 API
GeomCombination Members
GeomCombination Class Constructors Methods Properties See Also Send Feedback

The GeomCombination type exposes the following members.

Constructors

Name | Description
GeomCombination | For internal use only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllMembers | All elements that are joined in this geometry combination.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

GeomCombination Class
Autodesk.Revit.Elements Namespace


GeomCombination Constructor

[image]

Revit 2010 API
GeomCombination Constructor
GeomCombination Class See Also Send Feedback
For internal use only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GeomCombination()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GeomCombination()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GeomCombination Class
Autodesk.Revit.Elements Namespace


GeomCombination Methods

[image] [image]

Revit 2010 API
GeomCombination Methods
GeomCombination Class See Also Send Feedback

The GeomCombination type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeomCombination Class
Autodesk.Revit.Elements Namespace


GeomCombination Properties

[image] [image]

Revit 2010 API
GeomCombination Properties
GeomCombination Class See Also Send Feedback

The GeomCombination type exposes the following members.

Properties

Name | Description
AllMembers | All elements that are joined in this geometry combination.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

GeomCombination Class
Autodesk.Revit.Elements Namespace


AllMembers Property

[image]

Revit 2010 API
GeomCombination..::.AllMembers Property
GeomCombination Class See Also Send Feedback
All elements that are joined in this geometry combination.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CombinableElementArray AllMembers { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllMembers As CombinableElementArray
Visual C++
public:
property CombinableElementArray^ AllMembers {
    CombinableElementArray^ get ();
}

Remarks

All members are generic forms, for more information, please refer toGenericForm.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when this geometry combination has already been deleted.

See Also

GeomCombination Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
GeomCombination..::.Parameter Property
GeomCombination Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

GeomCombination Class
GeomCombination Members
Autodesk.Revit.Elements Namespace


GeomCombinationSet Class

[image]

Revit 2010 API
GeomCombinationSet Class
Members See Also Send Feedback
A set that contains GeomCombination objects.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class GeomCombinationSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class GeomCombinationSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GeomCombinationSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.GeomCombinationSet

See Also

GeomCombinationSet Members
Autodesk.Revit.Elements Namespace


GeomCombinationSet Members

[image] [image]

Revit 2010 API
GeomCombinationSet Members
GeomCombinationSet Class Constructors Methods Properties See Also Send Feedback

The GeomCombinationSet type exposes the following members.

Constructors

Name | Description
GeomCombinationSet | Initializes a new instance of the GeomCombinationSet class

Methods

Name | Description
Clear | Removes every item GeomCombination the set, rendering it empty.
Contains | Tests for the existence of an GeomCombination within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified GeomCombination from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of GeomCombinations that are in the set.

See Also

GeomCombinationSet Class
Autodesk.Revit.Elements Namespace


GeomCombinationSet Constructor

[image]

Revit 2010 API
GeomCombinationSet Constructor
GeomCombinationSet Class See Also Send Feedback
Initializes a new instance of the GeomCombinationSet class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GeomCombinationSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GeomCombinationSet()

See Also

GeomCombinationSet Class
Autodesk.Revit.Elements Namespace


GeomCombinationSet Methods

[image] [image]

Revit 2010 API
GeomCombinationSet Methods
GeomCombinationSet Class See Also Send Feedback

The GeomCombinationSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item GeomCombination the set, rendering it empty.
Contains | Tests for the existence of an GeomCombination within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified GeomCombination from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeomCombinationSet Class
Autodesk.Revit.Elements Namespace


Clear Method

[image]

Revit 2010 API
GeomCombinationSet..::.Clear Method
GeomCombinationSet Class See Also Send Feedback
Removes every item GeomCombination the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GeomCombinationSet Class
Autodesk.Revit.Elements Namespace


Contains Method

[image]

Revit 2010 API
GeomCombinationSet..::.Contains Method
GeomCombinationSet Class See Also Send Feedback
Tests for the existence of an GeomCombination within the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    GeomCombination item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As GeomCombination _
) As Boolean
Visual C++
public:
virtual bool Contains(
    GeomCombination^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.GeomCombination
The element to be searched for.

Return Value

The Contains method returns True if the GeomCombination is within the set, otherwise False.

See Also

GeomCombinationSet Class
Autodesk.Revit.Elements Namespace


Erase Method

[image]

Revit 2010 API
GeomCombinationSet..::.Erase Method
GeomCombinationSet Class See Also Send Feedback
Removes a specified GeomCombination from the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    GeomCombination item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As GeomCombination _
) As Integer
Visual C++
public:
virtual int Erase(
    GeomCombination^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.GeomCombination
The GeomCombination to be erased.

Return Value

The number of GeomCombinations that were erased from the set.

See Also

GeomCombinationSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

[image]

Revit 2010 API
GeomCombinationSet..::.ForwardIterator Method
GeomCombinationSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual GeomCombinationSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As GeomCombinationSetIterator
Visual C++
public:
virtual GeomCombinationSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

GeomCombinationSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

[image]

Revit 2010 API
GeomCombinationSet..::.GetEnumerator Method
GeomCombinationSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

GeomCombinationSet Class
Autodesk.Revit.Elements Namespace


Insert Method

[image]

Revit 2010 API
GeomCombinationSet..::.Insert Method
GeomCombinationSet Class See Also Send Feedback
Insert the specified element into the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    GeomCombination item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As GeomCombination _
) As Boolean
Visual C++
public:
virtual bool Insert(
    GeomCombination^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.GeomCombination
The GeomCombination to be inserted into the set.

Return Value

Returns whether the GeomCombination was inserted into the set.

See Also

GeomCombinationSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

[image]

Revit 2010 API
GeomCombinationSet..::.ReverseIterator Method
GeomCombinationSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual GeomCombinationSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As GeomCombinationSetIterator
Visual C++
public:
virtual GeomCombinationSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

GeomCombinationSet Class
Autodesk.Revit.Elements Namespace


GeomCombinationSet Properties

[image] [image]

Revit 2010 API
GeomCombinationSet Properties
GeomCombinationSet Class See Also Send Feedback

The GeomCombinationSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of GeomCombinations that are in the set.

See Also

GeomCombinationSet Class
Autodesk.Revit.Elements Namespace


IsEmpty Property

[image]

Revit 2010 API
GeomCombinationSet..::.IsEmpty Property
GeomCombinationSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GeomCombinationSet Class
Autodesk.Revit.Elements Namespace


Size Property

[image]

Revit 2010 API
GeomCombinationSet..::.Size Property
GeomCombinationSet Class See Also Send Feedback
Returns the number of GeomCombinations that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GeomCombinationSet Class
Autodesk.Revit.Elements Namespace


GeomCombinationSetIterator Class

[image]

Revit 2010 API
GeomCombinationSetIterator Class
Members See Also Send Feedback
An iterator to a GeomCombination set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class GeomCombinationSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class GeomCombinationSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GeomCombinationSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.GeomCombinationSetIterator

See Also

GeomCombinationSetIterator Members
Autodesk.Revit.Elements Namespace


GeomCombinationSetIterator Members

[image] [image]

Revit 2010 API
GeomCombinationSetIterator Members
GeomCombinationSetIterator Class Constructors Methods Properties See Also Send Feedback

The GeomCombinationSetIterator type exposes the following members.

Constructors

Name | Description
GeomCombinationSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GeomCombinationSetIterator Class
Autodesk.Revit.Elements Namespace


GeomCombinationSetIterator Constructor

[image]

Revit 2010 API
GeomCombinationSetIterator Constructor
GeomCombinationSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GeomCombinationSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GeomCombinationSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GeomCombinationSetIterator Class
Autodesk.Revit.Elements Namespace


GeomCombinationSetIterator Methods

[image] [image]

Revit 2010 API
GeomCombinationSetIterator Methods
GeomCombinationSetIterator Class See Also Send Feedback

The GeomCombinationSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeomCombinationSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

[image]

Revit 2010 API
GeomCombinationSetIterator..::.MoveNext Method
GeomCombinationSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GeomCombinationSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

[image]

Revit 2010 API
GeomCombinationSetIterator..::.Reset Method
GeomCombinationSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GeomCombinationSetIterator Class
Autodesk.Revit.Elements Namespace


GeomCombinationSetIterator Properties

[image] [image]

Revit 2010 API
GeomCombinationSetIterator Properties
GeomCombinationSetIterator Class See Also Send Feedback

The GeomCombinationSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GeomCombinationSetIterator Class
Autodesk.Revit.Elements Namespace


Current Property

[image]

Revit 2010 API
GeomCombinationSetIterator..::.Current Property
GeomCombinationSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GeomCombinationSetIterator Class
Autodesk.Revit.Elements Namespace


GraphicsStyle Class

[image]

Revit 2010 API
GraphicsStyle Class
Members See Also Send Feedback
The graphics style instance in Autodesk Revit document.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class GraphicsStyle : Element
Visual Basic (Declaration)
Public Class GraphicsStyle _
    Inherits Element
Visual C++
public ref class GraphicsStyle : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.GraphicsStyle

See Also

GraphicsStyle Members
Autodesk.Revit.Elements Namespace


GraphicsStyle Members

[image] [image]

Revit 2010 API
GraphicsStyle Members
GraphicsStyle Class Constructors Methods Properties See Also Send Feedback

The GraphicsStyle type exposes the following members.

Constructors

Name | Description
GraphicsStyle | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GraphicsStyleCategory | The graphics style category.
GraphicsStyleType | The graphics style type.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

GraphicsStyle Class
Autodesk.Revit.Elements Namespace


GraphicsStyle Constructor

[image]

Revit 2010 API
GraphicsStyle Constructor
GraphicsStyle Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GraphicsStyle()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GraphicsStyle()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GraphicsStyle Class
Autodesk.Revit.Elements Namespace


GraphicsStyle Methods

[image] [image]

Revit 2010 API
GraphicsStyle Methods
GraphicsStyle Class See Also Send Feedback

The GraphicsStyle type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GraphicsStyle Class
Autodesk.Revit.Elements Namespace


GraphicsStyle Properties

[image] [image]

Revit 2010 API
GraphicsStyle Properties
GraphicsStyle Class See Also Send Feedback

The GraphicsStyle type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GraphicsStyleCategory | The graphics style category.
GraphicsStyleType | The graphics style type.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

GraphicsStyle Class
Autodesk.Revit.Elements Namespace


GraphicsStyleCategory Property

[image]

Revit 2010 API
GraphicsStyle..::.GraphicsStyleCategory Property
GraphicsStyle Class See Also Send Feedback
The graphics style category.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Category GraphicsStyleCategory { get; }
Visual Basic (Declaration)
Public ReadOnly Property GraphicsStyleCategory As Category
Visual C++
public:
property Category^ GraphicsStyleCategory {
    Category^ get ();
}

See Also

GraphicsStyle Class
Autodesk.Revit.Elements Namespace


GraphicsStyleType Property

[image]

Revit 2010 API
GraphicsStyle..::.GraphicsStyleType Property
GraphicsStyle Class See Also Send Feedback
The graphics style type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GraphicsStyleType GraphicsStyleType { get; }
Visual Basic (Declaration)
Public ReadOnly Property GraphicsStyleType As GraphicsStyleType
Visual C++
public:
property GraphicsStyleType GraphicsStyleType {
    GraphicsStyleType get ();
}

See Also

GraphicsStyle Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
GraphicsStyle..::.Parameter Property
GraphicsStyle Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

GraphicsStyle Class
GraphicsStyle Members
Autodesk.Revit.Elements Namespace


GraphicsStyleType Enumeration

[image]

Revit 2010 API
GraphicsStyleType Enumeration
See Also Send Feedback
Describes the type of graphics style.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum GraphicsStyleType
Visual Basic (Declaration)
Public Enumeration GraphicsStyleType
Visual C++
public enum class GraphicsStyleType

Members

Member name | Description
Projection | Projection.
Cut | Cut.

See Also

Autodesk.Revit.Elements Namespace


Grid Class

[image]

Revit 2010 API
Grid Class
Members Example See Also Send Feedback
Represents a single grid line within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Grid : Element
Visual Basic (Declaration)
Public Class Grid _
    Inherits Element
Visual C++
public ref class Grid : public Element

Remarks

Grid lines can either be curved or straight. The Grid object is derived from the Element object and as such contains all the properties and methods of that object. The inherited Name property can be used to retrieve the contents of the grid lines bubble.

Examples

CopyC#
public void GetInfo_Grid(Grid grid)
{
    string message = "Grid : ";

    // Show IsCurved property
    message += "\nIf grid is Arc : " + grid.IsCurved;

    // Show Curve information
    Autodesk.Revit.Geometry.Curve curve = grid.Curve;
    if (grid.IsCurved)
    {
        // if the curve is an arc, give center and radius information
        Autodesk.Revit.Geometry.Arc arc = curve as Autodesk.Revit.Geometry.Arc;
        message += "\nArc's radius: " + arc.Radius;
        message += "\nArc's center:  (" + XYZToString(arc.Center);
    }
    else
    {
        // if the curve is a line, give length information
        Autodesk.Revit.Geometry.Line line = curve as Autodesk.Revit.Geometry.Line;
        message += "\nLine's Length: " + line.Length;
    }
    // Get curve start point
    message += "\nStart point: " + XYZToString(curve.get_EndPoint(0));
    // Get curve end point
    message += "; End point: " + XYZToString(curve.get_EndPoint(0));

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}

// output the point's three coordinates
string XYZToString(Autodesk.Revit.Geometry.XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
CopyVB.NET
Public Sub GetInfo_Grid(ByVal grid As Autodesk.Revit.Elements.Grid)
    Dim message As String = "Grid : "

    ' Show IsCurved property
    message += vbLf & "If grid is Arc : " & grid.IsCurved

    ' Show Curve information
    Dim curve As Autodesk.Revit.Geometry.Curve = grid.Curve
    If grid.IsCurved Then
        ' if the curve is an arc, give center and radius information
        Dim arc As Autodesk.Revit.Geometry.Arc = TryCast(curve, Autodesk.Revit.Geometry.Arc)
        message += vbLf & "Arc's radius: " & arc.Radius
        message += vbLf & "Arc's center: (" & XYZToString(arc.Center)
    Else
        ' if the curve is a line, give length information
        Dim line As Autodesk.Revit.Geometry.Line = TryCast(curve, Autodesk.Revit.Geometry.Line)
        message += vbLf & "Line's Length: " & line.Length
    End If
    ' Get curve start point
    message += vbLf & "Start point: " & XYZToString(curve.EndPoint(0))
    ' Get curve end point
    message += "; End point: " & XYZToString(curve.EndPoint(0))

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

' output the point's three coordinates
Private Function XYZToString(ByVal point As Autodesk.Revit.Geometry.XYZ) As String
    Return (("(" & point.X & ", ") + point.Y & ", ") + point.Z & ")"
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Grid

See Also

Grid Members
Autodesk.Revit.Elements Namespace


Grid Members

[image] [image]

Revit 2010 API
Grid Members
Grid Class Constructors Methods Properties See Also Send Feedback

The Grid type exposes the following members.

Constructors

Name | Description
Grid | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtendToAllLevels | Adjust the grid to cut all levels.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | Retrieves an object that represents the geometry of the grid line.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GridType | Get and Set the type of the grid object.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsCurved | Test to see if the grid line is curved or straight.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Grid Class
Autodesk.Revit.Elements Namespace


Grid Constructor

[image]

Revit 2010 API
Grid Constructor
Grid Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Grid()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Grid()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Grid Class
Autodesk.Revit.Elements Namespace


Grid Methods

[image] [image]

Revit 2010 API
Grid Methods
Grid Class See Also Send Feedback

The Grid type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtendToAllLevels | Adjust the grid to cut all levels.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Grid Class
Autodesk.Revit.Elements Namespace


ExtendToAllLevels Method

[image]

Revit 2010 API
Grid..::.ExtendToAllLevels Method
Grid Class See Also Send Feedback
Adjust the grid to cut all levels.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ExtendToAllLevels()
Visual Basic (Declaration)
Public Sub ExtendToAllLevels
Visual C++
public:
void ExtendToAllLevels()

Remarks

Requires that at least one plan view exists in the document. If not, this will throw a NotSupportedException.

Exceptions

Exception | Condition
System..::.NotSupportedException | There is no plan view in the document.

See Also

Grid Class
Autodesk.Revit.Elements Namespace


Grid Properties

[image] [image]

Revit 2010 API
Grid Properties
Grid Class See Also Send Feedback

The Grid type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | Retrieves an object that represents the geometry of the grid line.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GridType | Get and Set the type of the grid object.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsCurved | Test to see if the grid line is curved or straight.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Grid Class
Autodesk.Revit.Elements Namespace


Curve Property

[image]

Revit 2010 API
Grid..::.Curve Property
Grid Class See Also Send Feedback
Retrieves an object that represents the geometry of the grid line.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

Remarks

The geometry can either be an arc of a curve. The IsCurved property can be used to test which.

See Also

Grid Class
Autodesk.Revit.Elements Namespace


GridType Property

[image]

Revit 2010 API
Grid..::.GridType Property
Grid Class See Also Send Feedback
Get and Set the type of the grid object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GridType GridType { get; set; }
Visual Basic (Declaration)
Public Property GridType As GridType
Visual C++
public:
property GridType^ GridType {
    GridType^ get ();
    void set (GridType^ value);
}

Remarks

When a nullptr is input for the method set, ArgumentNullException will be thrown.

See Also

Grid Class
Autodesk.Revit.Elements Namespace


IsCurved Property

[image]

Revit 2010 API
Grid..::.IsCurved Property
Grid Class See Also Send Feedback
Test to see if the grid line is curved or straight.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsCurved { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCurved As Boolean
Visual C++
public:
property bool IsCurved {
    bool get ();
}

Remarks

A value of True is returned if the grid line is an arc or False if the grid line is straight. Use the Curve property to retrieve an object that represents the geometry of the grid line.

See Also

Grid Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Grid..::.Parameter Property
Grid Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Grid Class
Grid Members
Autodesk.Revit.Elements Namespace


GridNode Structure

[image]

Revit 2010 API
GridNode Structure
Members See Also Send Feedback
An identifier for a grid node location within a DividedSurface.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[SerializableAttribute]
public struct GridNode
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure GridNode
Visual C++
[SerializableAttribute]
public value class GridNode

Remarks

This class simply wraps two integers, UIndex and VIndex. GridNode objects can be used to index into the two-dimensional array of nodes in the divided surface.

See Also

GridNode Members
Autodesk.Revit.Elements Namespace


GridNode Members

[image] [image]

Revit 2010 API
GridNode Members
GridNode Structure Constructors Methods Properties See Also Send Feedback

The GridNode type exposes the following members.

Constructors

Name | Description
GridNode | Initializes a new instance of the GridNode class

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
UIndex | The node's index along the U axis.
VIndex | The node's index along the V axis.

See Also

GridNode Structure
Autodesk.Revit.Elements Namespace


GridNode Constructor

[image]

Revit 2010 API
GridNode Constructor
GridNode Structure See Also Send Feedback
Initializes a new instance of the GridNode class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GridNode(
    int uIndex,
    int vIndex
)
Visual Basic (Declaration)
Public Sub New ( _
    uIndex As Integer, _
    vIndex As Integer _
)
Visual C++
public:
GridNode(
    int uIndex,
    int vIndex
)

Parameters

uIndex
Type: System..::.Int32
vIndex
Type: System..::.Int32

See Also

GridNode Structure
Autodesk.Revit.Elements Namespace


GridNode Methods

[image] [image]

Revit 2010 API
GridNode Methods
GridNode Structure See Also Send Feedback

The GridNode type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

GridNode Structure
Autodesk.Revit.Elements Namespace


GridNode Properties

[image] [image]

Revit 2010 API
GridNode Properties
GridNode Structure See Also Send Feedback

The GridNode type exposes the following members.

Properties

Name | Description
UIndex | The node's index along the U axis.
VIndex | The node's index along the V axis.

See Also

GridNode Structure
Autodesk.Revit.Elements Namespace


UIndex Property

[image]

Revit 2010 API
GridNode..::.UIndex Property
GridNode Structure See Also Send Feedback
The node's index along the U axis.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int UIndex { get; set; }
Visual Basic (Declaration)
Public Property UIndex As Integer
Visual C++
public:
property int UIndex {
    int get ();
    void set (int value);
}

See Also

GridNode Structure
Autodesk.Revit.Elements Namespace


VIndex Property

[image]

Revit 2010 API
GridNode..::.VIndex Property
GridNode Structure See Also Send Feedback
The node's index along the V axis.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int VIndex { get; set; }
Visual Basic (Declaration)
Public Property VIndex As Integer
Visual C++
public:
property int VIndex {
    int get ();
    void set (int value);
}

See Also

GridNode Structure
Autodesk.Revit.Elements Namespace


Group Class

[image]

Revit 2010 API
Group Class
Members Example See Also Send Feedback
This object represents a group of elements within the project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Group : Element
Visual Basic (Declaration)
Public Class Group _
    Inherits Element
Visual C++
public ref class Group : public Element

Examples

CopyC#
// Change the default group name to a new name �MyGroup�
group.GroupType.Name = "MyGroup";
CopyC#
public void GetInfo_Group(Group group)
{
    string message = "Group : ";

    // Show the group type name
    message += "\nGroup type name is : " + group.GroupType.Name;

    // Show the name of the elements contained in the group
    message += "\nThe members contained in this group are:";
    foreach (Element member in group.Members)
    {
        message += "\n\tGroup member id : " + member.Id.Value;
    }

    message += "\nAll member will now be removed from group.";
    group.Ungroup();

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
' Change the default group name to a new name “MyGroup”
group.GroupType.Name = "MyGroup"
CopyVB.NET
Public Sub GetInfo_Group(ByVal group As Group)
    Dim message As String = "Group : "

    ' Show the group type name
    message += vbLf & "Group type name is : " & group.GroupType.Name

    ' Show the name of the elements contained in the group
    message += vbLf & "The members contained in this group are:"
    For Each member As Autodesk.Revit.Element In group.Members
        message += vbLf & vbTab & "Group member id : " & member.Id.Value
    Next

    message += vbLf & "All member will now be removed from group."
    group.Ungroup()

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Group

See Also

Group Members
Autodesk.Revit.Elements Namespace


Group Members

[image] [image]

Revit 2010 API
Group Members
Group Class Constructors Methods Properties See Also Send Feedback

The Group type exposes the following members.

Constructors

Name | Description
Group | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Ungroup | Ungroup the group.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
GroupType | Get or set the type of the group.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of a group within project. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Members | Returns all the members of the group.
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Group Class
Autodesk.Revit.Elements Namespace


Group Constructor

[image]

Revit 2010 API
Group Constructor
Group Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Group()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Group()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Group Class
Autodesk.Revit.Elements Namespace


Group Methods

[image] [image]

Revit 2010 API
Group Methods
Group Class See Also Send Feedback

The Group type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Ungroup | Ungroup the group.

See Also

Group Class
Autodesk.Revit.Elements Namespace


Ungroup Method

[image]

Revit 2010 API
Group..::.Ungroup Method
Group Class See Also Send Feedback
Ungroup the group.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet Ungroup()
Visual Basic (Declaration)
Public Function Ungroup As ElementSet
Visual C++
public:
ElementSet^ Ungroup()

Return Value

If successful the removed group elements are returned in this set.

Remarks

Ungroup removed all the members from the group and then causes the group itself to be deleted. Note that the reference to this group object will become invalid once this method is called. If the group cannot be ungrouped a System.InvalidOperationException will be thrown.

See Also

Group Class
Autodesk.Revit.Elements Namespace


Group Properties

[image] [image]

Revit 2010 API
Group Properties
Group Class See Also Send Feedback

The Group type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
GroupType | Get or set the type of the group.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of a group within project. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Members | Returns all the members of the group.
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Group Class
Autodesk.Revit.Elements Namespace


GroupType Property

[image]

Revit 2010 API
Group..::.GroupType Property
Group Class See Also Send Feedback
Get or set the type of the group.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual GroupType GroupType { get; set; }
Visual Basic (Declaration)
Public Overridable Property GroupType As GroupType
Visual C++
public:
virtual property GroupType^ GroupType {
    GroupType^ get ();
    void set (GroupType^ value);
}

Remarks

By setting this property the group can be swapped to a different kind of group.

See Also

Group Class
Autodesk.Revit.Elements Namespace


Location Property

[image]

Revit 2010 API
Group..::.Location Property
Group Class See Also Send Feedback
This property is used to find the physical location of a group within project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

The Location property returns an object that can be used to find the location of an object within the project. Groups return a point location object.

See Also

Group Class
Autodesk.Revit.Elements Namespace


Members Property

[image]

Revit 2010 API
Group..::.Members Property
Group Class See Also Send Feedback
Returns all the members of the group.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementArray Members { get; }
Visual Basic (Declaration)
Public ReadOnly Property Members As ElementArray
Visual C++
public:
property ElementArray^ Members {
    ElementArray^ get ();
}

Remarks

This property returns an ordered array of the members within the group. The order of this array can be used to match members between other instances of the group.

See Also

Group Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Group..::.Parameter Property
Group Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Group Class
Group Members
Autodesk.Revit.Elements Namespace


GroupSet Class

[image]

Revit 2010 API
GroupSet Class
Members See Also Send Feedback
An set that contains groups.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class GroupSet : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class GroupSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GroupSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.GroupSet

See Also

GroupSet Members
Autodesk.Revit.Elements Namespace


GroupSet Members

[image] [image]

Revit 2010 API
GroupSet Members
GroupSet Class Constructors Methods Properties See Also Send Feedback

The GroupSet type exposes the following members.

Constructors

Name | Description
GroupSet | Initializes a new instance of the GroupSet class

Methods

Name | Description
Clear | Removes every group from the set, rendering it empty.
Contains | Tests for the existence of a group within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified group from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified group into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of groups that are in the set.

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


GroupSet Constructor

[image]

Revit 2010 API
GroupSet Constructor
GroupSet Class See Also Send Feedback
Initializes a new instance of the GroupSet class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GroupSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupSet()

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


GroupSet Methods

[image] [image]

Revit 2010 API
GroupSet Methods
GroupSet Class See Also Send Feedback

The GroupSet type exposes the following members.

Methods

Name | Description
Clear | Removes every group from the set, rendering it empty.
Contains | Tests for the existence of a group within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified group from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified group into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


Clear Method

[image]

Revit 2010 API
GroupSet..::.Clear Method
GroupSet Class See Also Send Feedback
Removes every group from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


Contains Method

[image]

Revit 2010 API
GroupSet..::.Contains Method
GroupSet Class See Also Send Feedback
Tests for the existence of a group within the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    Group item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Group _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Group^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.Group
The group to be searched for.

Return Value

The Contains method returns True if the group is within the set, otherwise False.

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


Erase Method

[image]

Revit 2010 API
GroupSet..::.Erase Method
GroupSet Class See Also Send Feedback
Removes a specified group from the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    Group item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Group _
) As Integer
Visual C++
public:
virtual int Erase(
    Group^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.Group
The group to be erased.

Return Value

The number of groups that were erased from the set.

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

[image]

Revit 2010 API
GroupSet..::.ForwardIterator Method
GroupSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual GroupSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As GroupSetIterator
Visual C++
public:
virtual GroupSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

[image]

Revit 2010 API
GroupSet..::.GetEnumerator Method
GroupSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


Insert Method

[image]

Revit 2010 API
GroupSet..::.Insert Method
GroupSet Class See Also Send Feedback
Insert the specified group into the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    Group item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Group _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Group^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.Group
The group to be inserted into the set.

Return Value

Returns whether the group was inserted into the set.

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

[image]

Revit 2010 API
GroupSet..::.ReverseIterator Method
GroupSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual GroupSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As GroupSetIterator
Visual C++
public:
virtual GroupSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


GroupSet Properties

[image] [image]

Revit 2010 API
GroupSet Properties
GroupSet Class See Also Send Feedback

The GroupSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of groups that are in the set.

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


IsEmpty Property

[image]

Revit 2010 API
GroupSet..::.IsEmpty Property
GroupSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


Size Property

[image]

Revit 2010 API
GroupSet..::.Size Property
GroupSet Class See Also Send Feedback
Returns the number of groups that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GroupSet Class
Autodesk.Revit.Elements Namespace


GroupSetIterator Class

[image]

Revit 2010 API
GroupSetIterator Class
Members See Also Send Feedback
An iterator to a group set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class GroupSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class GroupSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GroupSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.GroupSetIterator

See Also

GroupSetIterator Members
Autodesk.Revit.Elements Namespace


GroupSetIterator Members

[image] [image]

Revit 2010 API
GroupSetIterator Members
GroupSetIterator Class Constructors Methods Properties See Also Send Feedback

The GroupSetIterator type exposes the following members.

Constructors

Name | Description
GroupSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GroupSetIterator Class
Autodesk.Revit.Elements Namespace


GroupSetIterator Constructor

[image]

Revit 2010 API
GroupSetIterator Constructor
GroupSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GroupSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GroupSetIterator Class
Autodesk.Revit.Elements Namespace


GroupSetIterator Methods

[image] [image]

Revit 2010 API
GroupSetIterator Methods
GroupSetIterator Class See Also Send Feedback

The GroupSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroupSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

[image]

Revit 2010 API
GroupSetIterator..::.MoveNext Method
GroupSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GroupSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

[image]

Revit 2010 API
GroupSetIterator..::.Reset Method
GroupSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GroupSetIterator Class
Autodesk.Revit.Elements Namespace


GroupSetIterator Properties

[image] [image]

Revit 2010 API
GroupSetIterator Properties
GroupSetIterator Class See Also Send Feedback

The GroupSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GroupSetIterator Class
Autodesk.Revit.Elements Namespace


Current Property

[image]

Revit 2010 API
GroupSetIterator..::.Current Property
GroupSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GroupSetIterator Class
Autodesk.Revit.Elements Namespace


Gutter Class

[image]

Revit 2010 API
Gutter Class
Members See Also Send Feedback
An object that represents a gutter within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Gutter : HostedSweep
Visual Basic (Declaration)
Public Class Gutter _
    Inherits HostedSweep
Visual C++
public ref class Gutter : public HostedSweep

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.HostedSweep
Autodesk.Revit.Elements..::.Gutter

See Also

Gutter Members
Autodesk.Revit.Elements Namespace


Gutter Members

[image] [image]

Revit 2010 API
Gutter Members
Gutter Class Constructors Methods Properties See Also Send Feedback

The Gutter type exposes the following members.

Constructors

Name | Description
Gutter | For Internal Use Only.

Methods

Name | Description
AddSegment | Add segments to the gutter. (Overrides HostedSweep..::.AddSegment(Reference).)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

Properties

Name | Description
Angle | Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian). (Inherited from HostedSweep.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
GutterType | Retrieves/set an object that represents the type of the Gutter.
HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceCurve | Retrieve the curve on which the hosted sweep object's segment is created on the corresponding. (Inherited from HostedSweep.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)

See Also

Gutter Class
Autodesk.Revit.Elements Namespace


Gutter Constructor

[image]

Revit 2010 API
Gutter Constructor
Gutter Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Gutter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Gutter()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Gutter Class
Autodesk.Revit.Elements Namespace


Gutter Methods

[image] [image]

Revit 2010 API
Gutter Methods
Gutter Class See Also Send Feedback

The Gutter type exposes the following members.

Methods

Name | Description
AddSegment | Add segments to the gutter. (Overrides HostedSweep..::.AddSegment(Reference).)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

See Also

Gutter Class
Autodesk.Revit.Elements Namespace


AddSegment Method

[image]

Revit 2010 API
Gutter..::.AddSegment Method
Gutter Class See Also Send Feedback
Add segments to the gutter.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override void AddSegment(
    Reference targetRef
)
Visual Basic (Declaration)
Public Overrides Sub AddSegment ( _
    targetRef As Reference _
)
Visual C++
public:
virtual void AddSegment(
    Reference^ targetRef
) override

Parameters

targetRef
Type: Autodesk.Revit.Geometry..::.Reference
Segment's reference on which want to be added.

Exceptions

Exception | Condition
System..::.ArgumentNullException | This exception will be thrown in following cases: 1. Input targetRef is null. 2. Input targetRef is not null but contains nothing.
System..::.InvalidOperationException | This exception will be thrown in following cases: 1. Input targetRef has already been added into the gutter. 2. Internal code fails to create the segment object. 3. Regeneration fails.
System..::.ArgumentOutOfRangeException | This exception will be thrown if the reference is not suitable for creating a gutter as required. The reference allowed is : 1. Model Line 2. Roof's horizontal edges 3. Soffit's horizontal edges 4. Fascia's horizontal edges

See Also

Gutter Class
Autodesk.Revit.Elements Namespace


Gutter Properties

[image] [image]

Revit 2010 API
Gutter Properties
Gutter Class See Also Send Feedback

The Gutter type exposes the following members.

Properties

Name | Description
Angle | Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian). (Inherited from HostedSweep.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
GutterType | Retrieves/set an object that represents the type of the Gutter.
HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceCurve | Retrieve the curve on which the hosted sweep object's segment is created on the corresponding. (Inherited from HostedSweep.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)

See Also

Gutter Class
Autodesk.Revit.Elements Namespace


GutterType Property

[image]

Revit 2010 API
Gutter..::.GutterType Property
Gutter Class See Also Send Feedback
Retrieves/set an object that represents the type of the Gutter.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GutterType GutterType { get; set; }
Visual Basic (Declaration)
Public Property GutterType As GutterType
Visual C++
public:
property GutterType^ GutterType {
    GutterType^ get ();
    void set (GutterType^ value);
}

See Also

Gutter Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Gutter..::.Parameter Property
Gutter Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Gutter Class
Gutter Members
Autodesk.Revit.Elements Namespace


HostedSweep Class

[image]

Revit 2010 API
HostedSweep Class
Members See Also Send Feedback
An object that represents a roof within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class HostedSweep : HostObject
Visual Basic (Declaration)
Public MustInherit Class HostedSweep _
    Inherits HostObject
Visual C++
public ref class HostedSweep abstract : public HostObject

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object also supports access to a structural analytical model but this feature is only available with Autodesk Revit Structure.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.HostedSweep
Autodesk.Revit.Elements..::.Fascia
Autodesk.Revit.Elements..::.Gutter
Autodesk.Revit.Elements..::.SlabEdge

See Also

HostedSweep Members
Autodesk.Revit.Elements Namespace


HostedSweep Members

[image] [image]

Revit 2010 API
HostedSweep Members
HostedSweep Class Constructors Methods Properties See Also Send Feedback

The HostedSweep type exposes the following members.

Constructors

Name | Description
HostedSweep | For Internal Use Only.

Methods

Name | Description
AddSegment | Add segments to the hosted sweep object.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEndPointParameter | Retrieve segment's start point or end point parameter.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HorizontalFlip | Flip the hosted sweep object along horizontal line.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveSegment | Remove segments from the hosted sweep object.
SetEndPointParameter | Set segment's start point or end point parameter.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalFlip | Flip the hosted sweep object along vertical line.

Properties

Name | Description
Angle | Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian).
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object.
HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | Retrieve the length of the hosted sweep object.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceCurve | Retrieve the curve on which the hosted sweep object's segment is created on the corresponding.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object.
VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


HostedSweep Constructor

[image]

Revit 2010 API
HostedSweep Constructor
HostedSweep Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public HostedSweep()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HostedSweep()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


HostedSweep Methods

[image] [image]

Revit 2010 API
HostedSweep Methods
HostedSweep Class See Also Send Feedback

The HostedSweep type exposes the following members.

Methods

Name | Description
AddSegment | Add segments to the hosted sweep object.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEndPointParameter | Retrieve segment's start point or end point parameter.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HorizontalFlip | Flip the hosted sweep object along horizontal line.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveSegment | Remove segments from the hosted sweep object.
SetEndPointParameter | Set segment's start point or end point parameter.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalFlip | Flip the hosted sweep object along vertical line.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


AddSegment Method

[image]

Revit 2010 API
HostedSweep..::.AddSegment Method
HostedSweep Class See Also Send Feedback
Add segments to the hosted sweep object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract void AddSegment(
    Reference targetRef
)
Visual Basic (Declaration)
Public MustOverride Sub AddSegment ( _
    targetRef As Reference _
)
Visual C++
public:
virtual void AddSegment(
    Reference^ targetRef
) abstract

Parameters

targetRef
Type: Autodesk.Revit.Geometry..::.Reference

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


GetEndPointParameter Method

[image]

Revit 2010 API
HostedSweep..::.GetEndPointParameter Method
HostedSweep Class See Also Send Feedback
Retrieve segment's start point or end point parameter.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double GetEndPointParameter(
    Reference targetRef,
    int endIdx
)
Visual Basic (Declaration)
Public Function GetEndPointParameter ( _
    targetRef As Reference, _
    endIdx As Integer _
) As Double
Visual C++
public:
double GetEndPointParameter(
    Reference^ targetRef,
    int endIdx
)

Parameters

targetRef
Type: Autodesk.Revit.Geometry..::.Reference
Segment's reference whose parameter want to be get.
endIdx
Type: System..::.Int32
Start point (=0) or end point (=1).

Return Value

Start point or end point parameter.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


HorizontalFlip Method

[image]

Revit 2010 API
HostedSweep..::.HorizontalFlip Method
HostedSweep Class See Also Send Feedback
Flip the hosted sweep object along horizontal line.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void HorizontalFlip()
Visual Basic (Declaration)
Public Sub HorizontalFlip
Visual C++
public:
void HorizontalFlip()

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


RemoveSegment Method

[image]

Revit 2010 API
HostedSweep..::.RemoveSegment Method
HostedSweep Class See Also Send Feedback
Remove segments from the hosted sweep object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveSegment(
    Reference targetRef
)
Visual Basic (Declaration)
Public Sub RemoveSegment ( _
    targetRef As Reference _
)
Visual C++
public:
void RemoveSegment(
    Reference^ targetRef
)

Parameters

targetRef
Type: Autodesk.Revit.Geometry..::.Reference
Segment's reference which want to be removed.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


SetEndPointParameter Method

[image]

Revit 2010 API
HostedSweep..::.SetEndPointParameter Method
HostedSweep Class See Also Send Feedback
Set segment's start point or end point parameter.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SetEndPointParameter(
    Reference targetRef,
    int endIdx,
    double param
)
Visual Basic (Declaration)
Public Function SetEndPointParameter ( _
    targetRef As Reference, _
    endIdx As Integer, _
    param As Double _
) As Boolean
Visual C++
public:
bool SetEndPointParameter(
    Reference^ targetRef,
    int endIdx,
    double param
)

Parameters

targetRef
Type: Autodesk.Revit.Geometry..::.Reference
Segment's reference whose parameter want to be set.
endIdx
Type: System..::.Int32
Start point (=0) or end point (=1).
param
Type: System..::.Double
Value of parameter.

Return Value

true if operation success.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


VerticalFlip Method

[image]

Revit 2010 API
HostedSweep..::.VerticalFlip Method
HostedSweep Class See Also Send Feedback
Flip the hosted sweep object along vertical line.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void VerticalFlip()
Visual Basic (Declaration)
Public Sub VerticalFlip
Visual C++
public:
void VerticalFlip()

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


HostedSweep Properties

[image] [image]

Revit 2010 API
HostedSweep Properties
HostedSweep Class See Also Send Feedback

The HostedSweep type exposes the following members.

Properties

Name | Description
Angle | Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian).
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object.
HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | Retrieve the length of the hosted sweep object.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceCurve | Retrieve the curve on which the hosted sweep object's segment is created on the corresponding.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object.
VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


Angle Property

[image]

Revit 2010 API
HostedSweep..::.Angle Property
HostedSweep Class See Also Send Feedback
Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian).

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Double
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


HorizontalFlipped Property

[image]

Revit 2010 API
HostedSweep..::.HorizontalFlipped Property
HostedSweep Class See Also Send Feedback
Retrieve the horizontal flip status of the hosted sweep object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool HorizontalFlipped { get; }
Visual Basic (Declaration)
Public ReadOnly Property HorizontalFlipped As Boolean
Visual C++
public:
property bool HorizontalFlipped {
    bool get ();
}

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


HorizontalOffset Property

[image]

Revit 2010 API
HostedSweep..::.HorizontalOffset Property
HostedSweep Class See Also Send Feedback
Retrieve/set the horizontal offset of the hosted sweep object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double HorizontalOffset { get; set; }
Visual Basic (Declaration)
Public Property HorizontalOffset As Double
Visual C++
public:
property double HorizontalOffset {
    double get ();
    void set (double value);
}

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


Length Property

[image]

Revit 2010 API
HostedSweep..::.Length Property
HostedSweep Class See Also Send Feedback
Retrieve the length of the hosted sweep object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Double
Visual C++
public:
property double Length {
    double get ();
}

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
HostedSweep..::.Parameter Property
HostedSweep Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

HostedSweep Class
HostedSweep Members
Autodesk.Revit.Elements Namespace


ReferenceCurve Property

[image]

Revit 2010 API
HostedSweep..::.ReferenceCurve Property
HostedSweep Class See Also Send Feedback
Retrieve the curve on which the hosted sweep object's segment is created on the corresponding.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve ReferenceCurve[
    Reference targetRef
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReferenceCurve ( _
    targetRef As Reference _
) As Curve
Visual C++
public:
property Curve^ ReferenceCurve[Reference^ targetRef] {
    Curve^ get (Reference^ targetRef);
}

Parameters

targetRef
Type: Autodesk.Revit.Geometry..::.Reference
Segment's reference whose curve want to be retrieved.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


VerticalFlipped Property

[image]

Revit 2010 API
HostedSweep..::.VerticalFlipped Property
HostedSweep Class See Also Send Feedback
Retrieve the vertical flip status of the hosted sweep object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool VerticalFlipped { get; }
Visual Basic (Declaration)
Public ReadOnly Property VerticalFlipped As Boolean
Visual C++
public:
property bool VerticalFlipped {
    bool get ();
}

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


VerticalOffset Property

[image]

Revit 2010 API
HostedSweep..::.VerticalOffset Property
HostedSweep Class See Also Send Feedback
Retrieve/set the vertical offset of the hosted sweep object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double VerticalOffset { get; set; }
Visual Basic (Declaration)
Public Property VerticalOffset As Double
Visual C++
public:
property double VerticalOffset {
    double get ();
    void set (double value);
}

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace


HostObject Class

[image]

Revit 2010 API
HostObject Class
Members See Also Send Feedback
A base class that provides support for all objects that can host other objects, such as a wall.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class HostObject : Element
Visual Basic (Declaration)
Public Class HostObject _
    Inherits Element
Visual C++
public ref class HostObject : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.CeilingAndFloor
Autodesk.Revit.Elements..::.ContFooting
Autodesk.Revit.Elements..::.CurtainGridLine
Autodesk.Revit.Elements..::.CurtainSystemBase
Autodesk.Revit.Elements..::.Floor
Autodesk.Revit.Elements..::.HostedSweep
Autodesk.Revit.Elements..::.RoofBase
Autodesk.Revit.Elements..::.Wall
Autodesk.Revit.MEP..::.MEPCurve
Autodesk.Revit.MEP..::.Wire

See Also

HostObject Members
Autodesk.Revit.Elements Namespace


HostObject Members

[image] [image]

Revit 2010 API
HostObject Members
HostObject Class Constructors Methods Properties See Also Send Feedback

The HostObject type exposes the following members.

Constructors

Name | Description
HostObject | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

HostObject Class
Autodesk.Revit.Elements Namespace


HostObject Constructor

[image]

Revit 2010 API
HostObject Constructor
HostObject Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public HostObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HostObject()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

HostObject Class
Autodesk.Revit.Elements Namespace


HostObject Methods

[image] [image]

Revit 2010 API
HostObject Methods
HostObject Class See Also Send Feedback

The HostObject type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HostObject Class
Autodesk.Revit.Elements Namespace


HostObject Properties

[image] [image]

Revit 2010 API
HostObject Properties
HostObject Class See Also Send Feedback

The HostObject type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

HostObject Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
HostObject..::.Parameter Property
HostObject Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

HostObject Class
HostObject Members
Autodesk.Revit.Elements Namespace


ImportInstance Class

[image]

Revit 2010 API
ImportInstance Class
Members See Also Send Feedback
An element created during an import operation in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ImportInstance : Element
Visual Basic (Declaration)
Public Class ImportInstance _
    Inherits Element
Visual C++
public ref class ImportInstance : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.ImportInstance

See Also

ImportInstance Members
Autodesk.Revit.Elements Namespace


ImportInstance Members

[image] [image]

Revit 2010 API
ImportInstance Members
ImportInstance Class Constructors Methods Properties See Also Send Feedback

The ImportInstance type exposes the following members.

Constructors

Name | Description
ImportInstance | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the import instance in a family document.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the import instance in a family document.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ImportInstance Class
Autodesk.Revit.Elements Namespace


ImportInstance Constructor

[image]

Revit 2010 API
ImportInstance Constructor
ImportInstance Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ImportInstance()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ImportInstance()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ImportInstance Class
Autodesk.Revit.Elements Namespace


ImportInstance Methods

[image] [image]

Revit 2010 API
ImportInstance Methods
ImportInstance Class See Also Send Feedback

The ImportInstance type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the import instance in a family document.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the import instance in a family document.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImportInstance Class
Autodesk.Revit.Elements Namespace


GetVisibility Method

[image]

Revit 2010 API
ImportInstance..::.GetVisibility Method
ImportInstance Class See Also Send Feedback
Gets the visibility for the import instance in a family document.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic (Declaration)
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

Returns a copy of visibility settings for the import instance in a family document.

See Also

ImportInstance Class
Autodesk.Revit.Elements Namespace


SetVisibility Method

[image]

Revit 2010 API
ImportInstance..::.SetVisibility Method
ImportInstance Class See Also Send Feedback
Sets the visibility for the import instance in a family document.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic (Declaration)
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit..::.FamilyElementVisibility

Remarks

The visibility of the import instance geometry can be changed for different types of views and detail levels in the family document.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when visibility is null.
System..::.InvalidOperationException | Thrown when regeneration failed, or the import instance is in a project document.

See Also

ImportInstance Class
Autodesk.Revit.Elements Namespace


ImportInstance Properties

[image] [image]

Revit 2010 API
ImportInstance Properties
ImportInstance Class See Also Send Feedback

The ImportInstance type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ImportInstance Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
ImportInstance..::.Parameter Property
ImportInstance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ImportInstance Class
ImportInstance Members
Autodesk.Revit.Elements Namespace


Pinned Property

[image]

Revit 2010 API
ImportInstance..::.Pinned Property
ImportInstance Class See Also Send Feedback
Identifies if the element has been pinned to prevent changes.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Pinned { get; set; }
Visual Basic (Declaration)
Public Property Pinned As Boolean
Visual C++
public:
property bool Pinned {
    bool get ();
    void set (bool value);
}

Remarks

An element which is pinned may not be moved, and warnings will be issued when an attempt is made to delete it.

See Also

ImportInstance Class
Autodesk.Revit.Elements Namespace


IndependentTag Class

[image]

Revit 2010 API
IndependentTag Class
Members See Also Send Feedback
Represents an IndependentTag within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class IndependentTag : Element
Visual Basic (Declaration)
Public Class IndependentTag _
    Inherits Element
Visual C++
public ref class IndependentTag : public Element

Remarks

The IndependentTag object is derived from the Element object and as such contains all the properties and methods of that object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.IndependentTag

See Also

IndependentTag Members
Autodesk.Revit.Elements Namespace


IndependentTag Members

[image] [image]

Revit 2010 API
IndependentTag Members
IndependentTag Class Constructors Methods Properties See Also Send Feedback

The IndependentTag type exposes the following members.

Constructors

Name | Description
IndependentTag | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Leader | Returns whether the tag has a Leader, and can add a leader to tag via set function.
LeaderElbow | Returns the position of the elbow of leader.
LeaderEnd | Returns the position of the end of leader.
LeaderMode | Returns the Leader End Condition of tag.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
TagHeadPosition | Returns the position of the head of tag.
TagMode | Returns the Tag Mode of tag.
TagOrientation | Returns the Tag Orientation of tag.
TagText | Returns the text of the Tag.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

IndependentTag Class
Autodesk.Revit.Elements Namespace


IndependentTag Constructor

[image]

Revit 2010 API
IndependentTag Constructor
IndependentTag Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public IndependentTag()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
IndependentTag()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

IndependentTag Class
Autodesk.Revit.Elements Namespace


IndependentTag Methods

[image] [image]

Revit 2010 API
IndependentTag Methods
IndependentTag Class See Also Send Feedback

The IndependentTag type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndependentTag Class
Autodesk.Revit.Elements Namespace


IndependentTag Properties

[image] [image]

Revit 2010 API
IndependentTag Properties
IndependentTag Class See Also Send Feedback

The IndependentTag type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Leader | Returns whether the tag has a Leader, and can add a leader to tag via set function.
LeaderElbow | Returns the position of the elbow of leader.
LeaderEnd | Returns the position of the end of leader.
LeaderMode | Returns the Leader End Condition of tag.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
TagHeadPosition | Returns the position of the head of tag.
TagMode | Returns the Tag Mode of tag.
TagOrientation | Returns the Tag Orientation of tag.
TagText | Returns the text of the Tag.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

IndependentTag Class
Autodesk.Revit.Elements Namespace


Leader Property

[image]

Revit 2010 API
IndependentTag..::.Leader Property
IndependentTag Class See Also Send Feedback
Returns whether the tag has a Leader, and can add a leader to tag via set function.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Leader { get; set; }
Visual Basic (Declaration)
Public Property Leader As Boolean
Visual C++
public:
property bool Leader {
    bool get ();
    void set (bool value);
}

Return Value

If the tag hold a Leader, return true; if not, return false.

Remarks

This property retrieves the Leader of tag.

See Also

IndependentTag Class
Autodesk.Revit.Elements Namespace


LeaderElbow Property

[image]

Revit 2010 API
IndependentTag..::.LeaderElbow Property
IndependentTag Class See Also Send Feedback
Returns the position of the elbow of leader.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ LeaderElbow { get; set; }
Visual Basic (Declaration)
Public Property LeaderElbow As XYZ
Visual C++
public:
property XYZ^ LeaderElbow {
    XYZ^ get ();
    void set (XYZ^ value);
}

Return Value

Return the Elbow of the Tag Leader.

Remarks

This property retrieves the elbow position of Tag Leader.

Exceptions

Exception | Condition
System..::.InvalidOperationException | If there is no leader for this tag or the leader is straight, the InvalidOperationException will be thrown.

See Also

IndependentTag Class
Autodesk.Revit.Elements Namespace


LeaderEnd Property

[image]

Revit 2010 API
IndependentTag..::.LeaderEnd Property
IndependentTag Class See Also Send Feedback
Returns the position of the end of leader.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ LeaderEnd { get; set; }
Visual Basic (Declaration)
Public Property LeaderEnd As XYZ
Visual C++
public:
property XYZ^ LeaderEnd {
    XYZ^ get ();
    void set (XYZ^ value);
}

Return Value

Return the end of the Tag Leader.

Remarks

This property retrieves the end position of Tag Leader, which tie to the Host obj. And ONLY Material Tag support Set operation!

See Also

IndependentTag Class
Autodesk.Revit.Elements Namespace


LeaderMode Property

[image]

Revit 2010 API
IndependentTag..::.LeaderMode Property
IndependentTag Class See Also Send Feedback
Returns the Leader End Condition of tag.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LeaderEndCondition LeaderMode { get; set; }
Visual Basic (Declaration)
Public Property LeaderMode As LeaderEndCondition
Visual C++
public:
property LeaderEndCondition LeaderMode {
    LeaderEndCondition get ();
    void set (LeaderEndCondition value);
}

Return Value

Return the End Condition of the Tag Leader.

Remarks

This property retrieves the Leader Mode of tag.

See Also

IndependentTag Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
IndependentTag..::.Parameter Property
IndependentTag Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

IndependentTag Class
IndependentTag Members
Autodesk.Revit.Elements Namespace


TagHeadPosition Property

[image]

Revit 2010 API
IndependentTag..::.TagHeadPosition Property
IndependentTag Class See Also Send Feedback
Returns the position of the head of tag.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ TagHeadPosition { get; set; }
Visual Basic (Declaration)
Public Property TagHeadPosition As XYZ
Visual C++
public:
property XYZ^ TagHeadPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}

Return Value

Return the Head Position of the Tag.

Remarks

This property retrieves the head position of tag head.

See Also

IndependentTag Class
Autodesk.Revit.Elements Namespace


TagMode Property

[image]

Revit 2010 API
IndependentTag..::.TagMode Property
IndependentTag Class See Also Send Feedback
Returns the Tag Mode of tag.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TagMode TagMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property TagMode As TagMode
Visual C++
public:
property TagMode TagMode {
    TagMode get ();
}

Return Value

Return the Tag Mode of the Tag.

Remarks

This read only property retrieves the Mode of tag.

See Also

IndependentTag Class
Autodesk.Revit.Elements Namespace


TagOrientation Property

[image]

Revit 2010 API
IndependentTag..::.TagOrientation Property
IndependentTag Class See Also Send Feedback
Returns the Tag Orientation of tag.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TagOrientation TagOrientation { get; set; }
Visual Basic (Declaration)
Public Property TagOrientation As TagOrientation
Visual C++
public:
property TagOrientation TagOrientation {
    TagOrientation get ();
    void set (TagOrientation value);
}

Return Value

Return the Orientation of the Tag.

Remarks

This property retrieves the Tag Orientation of tag.

See Also

IndependentTag Class
Autodesk.Revit.Elements Namespace


TagText Property

[image]

Revit 2010 API
IndependentTag..::.TagText Property
IndependentTag Class See Also Send Feedback
Returns the text of the Tag.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string TagText { get; }
Visual Basic (Declaration)
Public ReadOnly Property TagText As String
Visual C++
public:
property String^ TagText {
    String^ get ();
}

Return Value

Return the text of the Tag.

Remarks

This property retrieves the text of the Tag.

See Also

IndependentTag Class
Autodesk.Revit.Elements Namespace


InsertableInstance Class

[image]

Revit 2010 API
InsertableInstance Class
Members See Also Send Feedback
A base class that provides support insertable instances.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class InsertableInstance : Instance
Visual Basic (Declaration)
Public Class InsertableInstance _
    Inherits Instance
Visual C++
public ref class InsertableInstance : public Instance

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Instance
Autodesk.Revit.Elements..::.InsertableInstance
Autodesk.Revit.Elements..::.FamilyInstance

See Also

InsertableInstance Members
Autodesk.Revit.Elements Namespace


InsertableInstance Members

[image] [image]

Revit 2010 API
InsertableInstance Members
InsertableInstance Class Constructors Methods Properties See Also Send Feedback

The InsertableInstance type exposes the following members.

Constructors

Name | Description
InsertableInstance | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

InsertableInstance Class
Autodesk.Revit.Elements Namespace


InsertableInstance Constructor

[image]

Revit 2010 API
InsertableInstance Constructor
InsertableInstance Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InsertableInstance()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InsertableInstance()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

InsertableInstance Class
Autodesk.Revit.Elements Namespace


InsertableInstance Methods

[image] [image]

Revit 2010 API
InsertableInstance Methods
InsertableInstance Class See Also Send Feedback

The InsertableInstance type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsertableInstance Class
Autodesk.Revit.Elements Namespace


InsertableInstance Properties

[image] [image]

Revit 2010 API
InsertableInstance Properties
InsertableInstance Class See Also Send Feedback

The InsertableInstance type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

InsertableInstance Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
InsertableInstance..::.Parameter Property
InsertableInstance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

InsertableInstance Class
InsertableInstance Members
Autodesk.Revit.Elements Namespace


Instance Class

[image]

Revit 2010 API
Instance Class
Members See Also Send Feedback
A base class for all instance objects.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Instance : Element
Visual Basic (Declaration)
Public Class Instance _
    Inherits Element
Visual C++
public ref class Instance : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Instance
Autodesk.Revit.Elements..::.InsertableInstance
Autodesk.Revit.Site..::.ProjectLocation

See Also

Instance Members
Autodesk.Revit.Elements Namespace


Instance Members

[image] [image]

Revit 2010 API
Instance Members
Instance Class Constructors Methods Properties See Also Send Feedback

The Instance type exposes the following members.

Constructors

Name | Description
Instance | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Instance Class
Autodesk.Revit.Elements Namespace


Instance Constructor

[image]

Revit 2010 API
Instance Constructor
Instance Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Instance()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Instance()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Instance Class
Autodesk.Revit.Elements Namespace


Instance Methods

[image] [image]

Revit 2010 API
Instance Methods
Instance Class See Also Send Feedback

The Instance type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Instance Class
Autodesk.Revit.Elements Namespace


Instance Properties

[image] [image]

Revit 2010 API
Instance Properties
Instance Class See Also Send Feedback

The Instance type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Instance Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Instance..::.Parameter Property
Instance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Instance Class
Instance Members
Autodesk.Revit.Elements Namespace


LayoutRule Class

[image]

Revit 2010 API
LayoutRule Class
Members See Also Send Feedback
The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class LayoutRule : APIObject
Visual Basic (Declaration)
Public MustInherit Class LayoutRule _
    Inherits APIObject
Visual C++
public ref class LayoutRule abstract : public APIObject

Remarks

This class just used as the base class of those concrete LayoutRule classes.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.LayoutRule
Autodesk.Revit.Elements..::.LayoutRuleClearSpacing
Autodesk.Revit.Elements..::.LayoutRuleFixedDistance
Autodesk.Revit.Elements..::.LayoutRuleFixedNumber
Autodesk.Revit.Elements..::.LayoutRuleMaximumSpacing

See Also

LayoutRule Members
Autodesk.Revit.Elements Namespace


LayoutRule Members

[image] [image]

Revit 2010 API
LayoutRule Members
LayoutRule Class Constructors Methods Properties See Also Send Feedback

The LayoutRule type exposes the following members.

Constructors

Name | Description
LayoutRule | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LayoutRule Class
Autodesk.Revit.Elements Namespace


LayoutRule Constructor

[image]

Revit 2010 API
LayoutRule Constructor
LayoutRule Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LayoutRule()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LayoutRule()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LayoutRule Class
Autodesk.Revit.Elements Namespace


LayoutRule Methods

[image] [image]

Revit 2010 API
LayoutRule Methods
LayoutRule Class See Also Send Feedback

The LayoutRule type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayoutRule Class
Autodesk.Revit.Elements Namespace


LayoutRule Properties

[image] [image]

Revit 2010 API
LayoutRule Properties
LayoutRule Class See Also Send Feedback

The LayoutRule type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LayoutRule Class
Autodesk.Revit.Elements Namespace


LayoutRuleClearSpacing Class

[image]

Revit 2010 API
LayoutRuleClearSpacing Class
Members Example See Also Send Feedback
This class indicate the layout rule of a Beam System is Clear-Spacing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LayoutRuleClearSpacing : LayoutRule
Visual Basic (Declaration)
Public Class LayoutRuleClearSpacing _
    Inherits LayoutRule
Visual C++
public ref class LayoutRuleClearSpacing : public LayoutRule

Remarks

To use this type of LayoutRule, the distance between the beams and the justify-type must be set.

Examples

CopyC#
private bool LayoutRuleClearSpacingInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.Elements.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class
    LayoutRuleClearSpacing myLayoutRuleClearSpacing =
             new LayoutRuleClearSpacing(10.0, BeamSystemJustifyType.Beginning);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleClearSpacing;

    LayoutRuleClearSpacing clearSpacing = beamSystem.LayoutRule as LayoutRuleClearSpacing;
    if (null == clearSpacing)
    {
        return false;
    }

    //try to get the property value of the beamsystem LayoutRule
    BeamSystemJustifyType justifyType = clearSpacing.JustifyType;

    double spacing = clearSpacing.Spacing;

    message += "\nNew BeamSystem layout rule: " + clearSpacing;
    message += "\nNew BeamSystem spacing: " + spacing;
    message += "\nNew BeamSystem justification: " + justifyType;

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);

    return true;
}
CopyVB.NET
Private Function LayoutRuleClearSpacingInformation(ByVal beamSystem As BeamSystem) As Boolean
    'get the layoutRule of the beamsystem
    Dim layoutRule As Autodesk.Revit.Elements.LayoutRule = beamSystem.LayoutRule

    Dim message As String = "BeamSystem layout rule : " & layoutRule.ToString

    'create a new instance of the LayoutRuleClearSpacing class
    Dim myLayoutRuleClearSpacing As New LayoutRuleClearSpacing(10.0R, BeamSystemJustifyType.Beginning)

    'set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleClearSpacing

    Dim clearSpacing As LayoutRuleClearSpacing = TryCast(beamSystem.LayoutRule, LayoutRuleClearSpacing)
    If clearSpacing Is Nothing Then
        Return False
    End If

    'try to get the property value of the beamsystem LayoutRule
    Dim justifyType As BeamSystemJustifyType = clearSpacing.JustifyType

    Dim spacing As Double = clearSpacing.Spacing

    message += vbLf & "New BeamSystem layout rule: " & clearSpacing.ToString
    message += vbLf & "New BeamSystem spacing: " & spacing
    message += vbLf & "New BeamSystem justification: " & justifyType

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)

    Return True
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.LayoutRule
Autodesk.Revit.Elements..::.LayoutRuleClearSpacing

See Also

LayoutRuleClearSpacing Members
Autodesk.Revit.Elements Namespace


LayoutRuleClearSpacing Members

[image] [image]

Revit 2010 API
LayoutRuleClearSpacing Members
LayoutRuleClearSpacing Class Constructors Methods Properties See Also Send Feedback

The LayoutRuleClearSpacing type exposes the following members.

Constructors

Name | Description
LayoutRuleClearSpacing | Overloaded.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
JustifyType | Get or set the type of justification.
Spacing | Get or set the spacing of the beam system.

See Also

LayoutRuleClearSpacing Class
Autodesk.Revit.Elements Namespace


LayoutRuleClearSpacing Constructor

[image] [image]

Revit 2010 API
LayoutRuleClearSpacing Constructor
LayoutRuleClearSpacing Class See Also Send Feedback

Overload List

Name | Description
LayoutRuleClearSpacing()()() | For Internal Use Only.
LayoutRuleClearSpacing(Double, BeamSystemJustifyType) | Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

See Also

LayoutRuleClearSpacing Class
LayoutRuleClearSpacing Members
Autodesk.Revit.Elements Namespace


LayoutRuleClearSpacing Constructor

[image]

Revit 2010 API
LayoutRuleClearSpacing Constructor
LayoutRuleClearSpacing Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LayoutRuleClearSpacing()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LayoutRuleClearSpacing()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LayoutRuleClearSpacing Class
LayoutRuleClearSpacing Overload
Autodesk.Revit.Elements Namespace


LayoutRuleClearSpacing Constructor (Double, BeamSystemJustifyType)

[image]

Revit 2010 API
LayoutRuleClearSpacing Constructor (Double, BeamSystemJustifyType)
LayoutRuleClearSpacing Class See Also Send Feedback
Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LayoutRuleClearSpacing(
    double spacing,
    BeamSystemJustifyType justifyType
)
Visual Basic (Declaration)
Public Sub New ( _
    spacing As Double, _
    justifyType As BeamSystemJustifyType _
)
Visual C++
public:
LayoutRuleClearSpacing(
    double spacing,
    BeamSystemJustifyType justifyType
)

Parameters

spacing
Type: System..::.Double
The value of spacing must be in [0, 30000).
justifyType
Type: Autodesk.Revit.Enums..::.BeamSystemJustifyType
The type of the justification, it's corresponding to the items in the element properties dialog.

Remarks

The value of spacing must be in [0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleClearSpacing Class
LayoutRuleClearSpacing Overload
Autodesk.Revit.Elements Namespace


LayoutRuleClearSpacing Methods

[image] [image]

Revit 2010 API
LayoutRuleClearSpacing Methods
LayoutRuleClearSpacing Class See Also Send Feedback

The LayoutRuleClearSpacing type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayoutRuleClearSpacing Class
Autodesk.Revit.Elements Namespace


LayoutRuleClearSpacing Properties

[image] [image]

Revit 2010 API
LayoutRuleClearSpacing Properties
LayoutRuleClearSpacing Class See Also Send Feedback

The LayoutRuleClearSpacing type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
JustifyType | Get or set the type of justification.
Spacing | Get or set the spacing of the beam system.

See Also

LayoutRuleClearSpacing Class
Autodesk.Revit.Elements Namespace


JustifyType Property

[image]

Revit 2010 API
LayoutRuleClearSpacing..::.JustifyType Property
LayoutRuleClearSpacing Class See Also Send Feedback
Get or set the type of justification.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BeamSystemJustifyType JustifyType { get; set; }
Visual Basic (Declaration)
Public Property JustifyType As BeamSystemJustifyType
Visual C++
public:
property BeamSystemJustifyType JustifyType {
    BeamSystemJustifyType get ();
    void set (BeamSystemJustifyType value);
}

Remarks

The justifyType passed in must be a valid object.

See Also

LayoutRuleClearSpacing Class
Autodesk.Revit.Elements Namespace


Spacing Property

[image]

Revit 2010 API
LayoutRuleClearSpacing..::.Spacing Property
LayoutRuleClearSpacing Class See Also Send Feedback
Get or set the spacing of the beam system.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Spacing { get; set; }
Visual Basic (Declaration)
Public Property Spacing As Double
Visual C++
public:
property double Spacing {
    double get ();
    void set (double value);
}

Remarks

The value of spacing must be in [0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleClearSpacing Class
Autodesk.Revit.Elements Namespace


LayoutRuleFixedDistance Class

[image]

Revit 2010 API
LayoutRuleFixedDistance Class
Members Example See Also Send Feedback
This class indicate the layout rule of a Beam System is Fixed-Distance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LayoutRuleFixedDistance : LayoutRule
Visual Basic (Declaration)
Public Class LayoutRuleFixedDistance _
    Inherits LayoutRule
Visual C++
public ref class LayoutRuleFixedDistance : public LayoutRule

Remarks

To use this type of LayoutRule, the distance between the beams and the justify-type must be set.

Examples

CopyC#
private bool LayoutRuleFixedDistanceInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.Elements.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class
    LayoutRuleFixedDistance myLayoutRuleFixedDistance =
                new LayoutRuleFixedDistance(10.0, BeamSystemJustifyType.End);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedDistance;

    LayoutRuleFixedDistance fixedDistance = beamSystem.LayoutRule as LayoutRuleFixedDistance;
    if (null == fixedDistance)
    {
        return false;
    }
    //try to get the property value of the beamsystem LayoutRule
    BeamSystemJustifyType justifyType = fixedDistance.JustifyType;

    double spacing = fixedDistance.Spacing;

    message += "\nNew BeamSystem layout rule: " + fixedDistance;
    message += "\nNew BeamSystem spacing: " + spacing;
    message += "\nNew BeamSystem justification: " + justifyType;

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);

    return true;
}
CopyVB.NET
Private Function LayoutRuleFixedDistanceInformation(ByVal beamSystem As BeamSystem) As Boolean
    'get the layoutRule of the beamsystem
    Dim layoutRule As Autodesk.Revit.Elements.LayoutRule = beamSystem.LayoutRule

    Dim message As String = "BeamSystem layout rule : " & layoutRule.ToString

    'create a new instance of the LayoutRuleClearSpacing class
    Dim myLayoutRuleFixedDistance As New LayoutRuleFixedDistance(10.0R, BeamSystemJustifyType.[End])

    'set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedDistance

    Dim fixedDistance As LayoutRuleFixedDistance = TryCast(beamSystem.LayoutRule, LayoutRuleFixedDistance)
    If fixedDistance Is Nothing Then
        Return False
    End If
    'try to get the property value of the beamsystem LayoutRule
    Dim justifyType As BeamSystemJustifyType = fixedDistance.JustifyType

    Dim spacing As Double = fixedDistance.Spacing

    message += vbLf & "New BeamSystem layout rule: " & fixedDistance.ToString
    message += vbLf & "New BeamSystem spacing: " & spacing
    message += vbLf & "New BeamSystem justification: " & justifyType

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)

    Return True
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.LayoutRule
Autodesk.Revit.Elements..::.LayoutRuleFixedDistance

See Also

LayoutRuleFixedDistance Members
Autodesk.Revit.Elements Namespace


LayoutRuleFixedDistance Members

[image] [image]

Revit 2010 API
LayoutRuleFixedDistance Members
LayoutRuleFixedDistance Class Constructors Methods Properties See Also Send Feedback

The LayoutRuleFixedDistance type exposes the following members.

Constructors

Name | Description
LayoutRuleFixedDistance | Overloaded.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
JustifyType | Get or set the type of justification.
Spacing | Get or set spacing of the Beam System.

See Also

LayoutRuleFixedDistance Class
Autodesk.Revit.Elements Namespace


LayoutRuleFixedDistance Constructor

[image] [image]

Revit 2010 API
LayoutRuleFixedDistance Constructor
LayoutRuleFixedDistance Class See Also Send Feedback

Overload List

Name | Description
LayoutRuleFixedDistance()()() | For Internal Use Only.
LayoutRuleFixedDistance(Double, BeamSystemJustifyType) | Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

See Also

LayoutRuleFixedDistance Class
LayoutRuleFixedDistance Members
Autodesk.Revit.Elements Namespace


LayoutRuleFixedDistance Constructor

[image]

Revit 2010 API
LayoutRuleFixedDistance Constructor
LayoutRuleFixedDistance Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LayoutRuleFixedDistance()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LayoutRuleFixedDistance()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LayoutRuleFixedDistance Class
LayoutRuleFixedDistance Overload
Autodesk.Revit.Elements Namespace


LayoutRuleFixedDistance Constructor (Double, BeamSystemJustifyType)

[image]

Revit 2010 API
LayoutRuleFixedDistance Constructor (Double, BeamSystemJustifyType)
LayoutRuleFixedDistance Class See Also Send Feedback
Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LayoutRuleFixedDistance(
    double spacing,
    BeamSystemJustifyType justifyType
)
Visual Basic (Declaration)
Public Sub New ( _
    spacing As Double, _
    justifyType As BeamSystemJustifyType _
)
Visual C++
public:
LayoutRuleFixedDistance(
    double spacing,
    BeamSystemJustifyType justifyType
)

Parameters

spacing
Type: System..::.Double
The value of spacing must be in (0, 30000).
justifyType
Type: Autodesk.Revit.Enums..::.BeamSystemJustifyType
The type of the justification, it's corresponding to the items in the element properties dialog.

Remarks

The value of spacing must be in (0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleFixedDistance Class
LayoutRuleFixedDistance Overload
Autodesk.Revit.Elements Namespace


LayoutRuleFixedDistance Methods

[image] [image]

Revit 2010 API
LayoutRuleFixedDistance Methods
LayoutRuleFixedDistance Class See Also Send Feedback

The LayoutRuleFixedDistance type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayoutRuleFixedDistance Class
Autodesk.Revit.Elements Namespace


LayoutRuleFixedDistance Properties

[image] [image]

Revit 2010 API
LayoutRuleFixedDistance Properties
LayoutRuleFixedDistance Class See Also Send Feedback

The LayoutRuleFixedDistance type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
JustifyType | Get or set the type of justification.
Spacing | Get or set spacing of the Beam System.

See Also

LayoutRuleFixedDistance Class
Autodesk.Revit.Elements Namespace


JustifyType Property

[image]

Revit 2010 API
LayoutRuleFixedDistance..::.JustifyType Property
LayoutRuleFixedDistance Class See Also Send Feedback
Get or set the type of justification.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BeamSystemJustifyType JustifyType { get; set; }
Visual Basic (Declaration)
Public Property JustifyType As BeamSystemJustifyType
Visual C++
public:
property BeamSystemJustifyType JustifyType {
    BeamSystemJustifyType get ();
    void set (BeamSystemJustifyType value);
}

Remarks

The justifyType passed in must be a valid object.

See Also

LayoutRuleFixedDistance Class
Autodesk.Revit.Elements Namespace


Spacing Property

[image]

Revit 2010 API
LayoutRuleFixedDistance..::.Spacing Property
LayoutRuleFixedDistance Class See Also Send Feedback
Get or set spacing of the Beam System.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Spacing { get; set; }
Visual Basic (Declaration)
Public Property Spacing As Double
Visual C++
public:
property double Spacing {
    double get ();
    void set (double value);
}

Remarks

The value of spacing must be in (0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleFixedDistance Class
Autodesk.Revit.Elements Namespace


LayoutRuleFixedNumber Class

[image]

Revit 2010 API
LayoutRuleFixedNumber Class
Members Example See Also Send Feedback
This class indicate the layout rule of a Beam System is Fixed-Number.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LayoutRuleFixedNumber : LayoutRule
Visual Basic (Declaration)
Public Class LayoutRuleFixedNumber _
    Inherits LayoutRule
Visual C++
public ref class LayoutRuleFixedNumber : public LayoutRule

Remarks

To use this type of LayoutRule, only the number of the beams must be set.

Examples

CopyC#
private bool LayoutRuleFixedNumberInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.Elements.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class
    LayoutRuleFixedNumber myLayoutRuleFixedNumber =
                        new LayoutRuleFixedNumber(8);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedNumber;

    LayoutRuleFixedNumber fixedNumber = beamSystem.LayoutRule as LayoutRuleFixedNumber;

    if (null == fixedNumber)
    {
        return false;
    }
    //try to get the property value of the beamsystem LayoutRule
    int numberOfLines = fixedNumber.NumberOfLines;

    message += "\nNew BeamSystem layout rule: " + fixedNumber;
    message += "\nNew BeamSystem number of beams: " + numberOfLines;

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);

    return true;
}
CopyVB.NET
Private Function LayoutRuleFixedNumberInformation(ByVal beamSystem As BeamSystem) As Boolean
    'get the layoutRule of the beamsystem
    Dim layoutRule As Autodesk.Revit.Elements.LayoutRule = beamSystem.LayoutRule

    Dim message As String = "BeamSystem layout rule : " & layoutRule.ToString

    'create a new instance of the LayoutRuleClearSpacing class
    Dim myLayoutRuleFixedNumber As New LayoutRuleFixedNumber(8)

    'set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedNumber

    Dim fixedNumber As LayoutRuleFixedNumber = TryCast(beamSystem.LayoutRule, LayoutRuleFixedNumber)

    If fixedNumber Is Nothing Then
        Return False
    End If
    'try to get the property value of the beamsystem LayoutRule
    Dim numberOfLines As Integer = fixedNumber.NumberOfLines

    message += vbLf & "New BeamSystem layout rule: " & fixedNumber.ToString
    message += vbLf & "New BeamSystem number of beams: " & numberOfLines

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)

    Return True
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.LayoutRule
Autodesk.Revit.Elements..::.LayoutRuleFixedNumber

See Also

LayoutRuleFixedNumber Members
Autodesk.Revit.Elements Namespace


LayoutRuleFixedNumber Members

[image] [image]

Revit 2010 API
LayoutRuleFixedNumber Members
LayoutRuleFixedNumber Class Constructors Methods Properties See Also Send Feedback

The LayoutRuleFixedNumber type exposes the following members.

Constructors

Name | Description
LayoutRuleFixedNumber | Overloaded.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
NumberOfLines | Get or set the number of the beams in a beam system.

See Also

LayoutRuleFixedNumber Class
Autodesk.Revit.Elements Namespace


LayoutRuleFixedNumber Constructor

[image] [image]

Revit 2010 API
LayoutRuleFixedNumber Constructor
LayoutRuleFixedNumber Class See Also Send Feedback

Overload List

Name | Description
LayoutRuleFixedNumber()()() | For Internal Use Only.
LayoutRuleFixedNumber(Int32) | Constructor of LayoutRuleFixedNumber.

See Also

LayoutRuleFixedNumber Class
LayoutRuleFixedNumber Members
Autodesk.Revit.Elements Namespace


LayoutRuleFixedNumber Constructor

[image]

Revit 2010 API
LayoutRuleFixedNumber Constructor
LayoutRuleFixedNumber Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LayoutRuleFixedNumber()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LayoutRuleFixedNumber()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LayoutRuleFixedNumber Class
LayoutRuleFixedNumber Overload
Autodesk.Revit.Elements Namespace


LayoutRuleFixedNumber Constructor (Int32)

[image]

Revit 2010 API
LayoutRuleFixedNumber Constructor (Int32)
LayoutRuleFixedNumber Class See Also Send Feedback
Constructor of LayoutRuleFixedNumber.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LayoutRuleFixedNumber(
    int numberOfLines
)
Visual Basic (Declaration)
Public Sub New ( _
    numberOfLines As Integer _
)
Visual C++
public:
LayoutRuleFixedNumber(
    int numberOfLines
)

Parameters

numberOfLines
Type: System..::.Int32
The value of numberOfLines must be positive.

Remarks

Create a LayoutRuleFixedNumber object with the number of the beams and this number must be positive.

See Also

LayoutRuleFixedNumber Class
LayoutRuleFixedNumber Overload
Autodesk.Revit.Elements Namespace


LayoutRuleFixedNumber Methods

[image] [image]

Revit 2010 API
LayoutRuleFixedNumber Methods
LayoutRuleFixedNumber Class See Also Send Feedback

The LayoutRuleFixedNumber type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayoutRuleFixedNumber Class
Autodesk.Revit.Elements Namespace


LayoutRuleFixedNumber Properties

[image] [image]

Revit 2010 API
LayoutRuleFixedNumber Properties
LayoutRuleFixedNumber Class See Also Send Feedback

The LayoutRuleFixedNumber type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
NumberOfLines | Get or set the number of the beams in a beam system.

See Also

LayoutRuleFixedNumber Class
Autodesk.Revit.Elements Namespace


NumberOfLines Property

[image]

Revit 2010 API
LayoutRuleFixedNumber..::.NumberOfLines Property
LayoutRuleFixedNumber Class See Also Send Feedback
Get or set the number of the beams in a beam system.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NumberOfLines { get; set; }
Visual Basic (Declaration)
Public Property NumberOfLines As Integer
Visual C++
public:
property int NumberOfLines {
    int get ();
    void set (int value);
}

Remarks

The number must be positive.

See Also

LayoutRuleFixedNumber Class
Autodesk.Revit.Elements Namespace


LayoutRuleMaximumSpacing Class

[image]

Revit 2010 API
LayoutRuleMaximumSpacing Class
Members Example See Also Send Feedback
This class indicate the layout rule of a Beam System is Max-Spacing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LayoutRuleMaximumSpacing : LayoutRule
Visual Basic (Declaration)
Public Class LayoutRuleMaximumSpacing _
    Inherits LayoutRule
Visual C++
public ref class LayoutRuleMaximumSpacing : public LayoutRule

Remarks

To use this type of LayoutRule, only the maximum spacing must be set and it must be in (0, 30000).

Examples

CopyC#
private bool LayoutRuleMaximumSpacingInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.Elements.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class
    LayoutRuleMaximumSpacing myLayoutRuleMaximumSpacing =
                        new LayoutRuleMaximumSpacing(10.0);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleMaximumSpacing;

    LayoutRuleMaximumSpacing maximunSpacing = beamSystem.LayoutRule as LayoutRuleMaximumSpacing;
    if (null == maximunSpacing)
    {
        return false;
    }
    //try to get the property value of the beamsystem LayoutRule
    double spacing = maximunSpacing.Spacing;

    message += "\nNew BeamSystem layout rule: " + maximunSpacing;
    message += "\nNew BeamSystem maximum spacing: " + spacing;

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);

    return true;
}
CopyVB.NET
Private Function LayoutRuleMaximumSpacingInformation(ByVal beamSystem As BeamSystem) As Boolean
    'get the layoutRule of the beamsystem
    Dim layoutRule As Autodesk.Revit.Elements.LayoutRule = beamSystem.LayoutRule

    Dim message As String = "BeamSystem layout rule : " & layoutRule.ToString

    'create a new instance of the LayoutRuleClearSpacing class
    Dim myLayoutRuleMaximumSpacing As New LayoutRuleMaximumSpacing(10.0R)

    'set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleMaximumSpacing

    Dim maximunSpacing As LayoutRuleMaximumSpacing = TryCast(beamSystem.LayoutRule, LayoutRuleMaximumSpacing)
    If maximunSpacing Is Nothing Then
        Return False
    End If
    'try to get the property value of the beamsystem LayoutRule
    Dim spacing As Double = maximunSpacing.Spacing

    message += vbLf & "New BeamSystem layout rule: " & maximunSpacing.ToString
    message += vbLf & "New BeamSystem maximum spacing: " & spacing

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)

    Return True
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.LayoutRule
Autodesk.Revit.Elements..::.LayoutRuleMaximumSpacing

See Also

LayoutRuleMaximumSpacing Members
Autodesk.Revit.Elements Namespace


LayoutRuleMaximumSpacing Members

[image] [image]

Revit 2010 API
LayoutRuleMaximumSpacing Members
LayoutRuleMaximumSpacing Class Constructors Methods Properties See Also Send Feedback

The LayoutRuleMaximumSpacing type exposes the following members.

Constructors

Name | Description
LayoutRuleMaximumSpacing | Overloaded.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Spacing | Get or set the spacing of the beam system.

See Also

LayoutRuleMaximumSpacing Class
Autodesk.Revit.Elements Namespace


LayoutRuleMaximumSpacing Constructor

[image] [image]

Revit 2010 API
LayoutRuleMaximumSpacing Constructor
LayoutRuleMaximumSpacing Class See Also Send Feedback

Overload List

Name | Description
LayoutRuleMaximumSpacing()()() | For Internal Use Only.
LayoutRuleMaximumSpacing(Double) | Constructor of LayoutRuleMaximumSpacing.

See Also

LayoutRuleMaximumSpacing Class
LayoutRuleMaximumSpacing Members
Autodesk.Revit.Elements Namespace


LayoutRuleMaximumSpacing Constructor

[image]

Revit 2010 API
LayoutRuleMaximumSpacing Constructor
LayoutRuleMaximumSpacing Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LayoutRuleMaximumSpacing()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LayoutRuleMaximumSpacing()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LayoutRuleMaximumSpacing Class
LayoutRuleMaximumSpacing Overload
Autodesk.Revit.Elements Namespace


LayoutRuleMaximumSpacing Constructor (Double)

[image]

Revit 2010 API
LayoutRuleMaximumSpacing Constructor (Double)
LayoutRuleMaximumSpacing Class See Also Send Feedback
Constructor of LayoutRuleMaximumSpacing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LayoutRuleMaximumSpacing(
    double spacing
)
Visual Basic (Declaration)
Public Sub New ( _
    spacing As Double _
)
Visual C++
public:
LayoutRuleMaximumSpacing(
    double spacing
)

Parameters

spacing
Type: System..::.Double
The value of spacing must be in (0, 30000).

Remarks

The value of spacing must be in (0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleMaximumSpacing Class
LayoutRuleMaximumSpacing Overload
Autodesk.Revit.Elements Namespace


LayoutRuleMaximumSpacing Methods

[image] [image]

Revit 2010 API
LayoutRuleMaximumSpacing Methods
LayoutRuleMaximumSpacing Class See Also Send Feedback

The LayoutRuleMaximumSpacing type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayoutRuleMaximumSpacing Class
Autodesk.Revit.Elements Namespace


LayoutRuleMaximumSpacing Properties

[image] [image]

Revit 2010 API
LayoutRuleMaximumSpacing Properties
LayoutRuleMaximumSpacing Class See Also Send Feedback

The LayoutRuleMaximumSpacing type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Spacing | Get or set the spacing of the beam system.

See Also

LayoutRuleMaximumSpacing Class
Autodesk.Revit.Elements Namespace


Spacing Property

[image]

Revit 2010 API
LayoutRuleMaximumSpacing..::.Spacing Property
LayoutRuleMaximumSpacing Class See Also Send Feedback
Get or set the spacing of the beam system.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Spacing { get; set; }
Visual Basic (Declaration)
Public Property Spacing As Double
Visual C++
public:
property double Spacing {
    double get ();
    void set (double value);
}

Remarks

The value of spacing must be in (0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleMaximumSpacing Class
Autodesk.Revit.Elements Namespace


Level Class

[image]

Revit 2010 API
Level Class
Members Example See Also Send Feedback
Represents a Level line within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Level : Element
Visual Basic (Declaration)
Public Class Level _
    Inherits Element
Visual C++
public ref class Level : public Element

Remarks

The Level object is derived from the Element object and as such contains all the properties and methods of that object. The inherited Name property can be used to retrieve the user visible name of the level that appears in the level bubble. To retrieve all the levels within a project use the Document.Elements iterator and look for objects of type Autodesk.Revit.Elements.Level.

Examples

CopyC#
private void Getinfo_Level(Document document)
{
    StringBuilder levelInformation = new StringBuilder();
    int levelNumber = 0;

    TypeFilter levelFilter = document.Application.Create.Filter.NewTypeFilter(typeof(Level));
    ElementIterator itrLevels = document.get_Elements(levelFilter);
    itrLevels.Reset();
    while (itrLevels.MoveNext())
    {
        Level level = itrLevels.Current as Level;

        if (null != level)
        {
            // keep track of number of levels
            levelNumber++;

            //get the name of the level
            levelInformation.Append("\nLevel Name: " + level.Name);

            //get the elevation of the level
            levelInformation.Append("\n\tElevation: " + level.Elevation);

            // get the project elevation of the level
            levelInformation.Append("\n\tProject Elevation: " + level.ProjectElevation);
        }
    }

    //number of total levels in current document
    levelInformation.Append("\n\n There are " + levelNumber + " levels in the document!");

    //show the level information in the messagebox
    MessageBox.Show(levelInformation.ToString(), "Revit");
}
CopyVB.NET
Private Sub Getinfo_Level(ByVal document As Document)
    Dim levelInformation As New StringBuilder()
    Dim levelNumber As Integer = 0

    Dim levelFilter As TypeFilter = document.Application.Create.Filter.NewTypeFilter(GetType(Autodesk.Revit.Elements.Level))
    Dim itrLevels As ElementIterator = document.Elements(levelFilter)
    itrLevels.Reset()
    While itrLevels.MoveNext()
        Dim level As Autodesk.Revit.Elements.Level = TryCast(itrLevels.Current, Autodesk.Revit.Elements.Level)

        If level IsNot Nothing Then
            ' keep track of number of levels
            levelNumber += 1

            'get the name of the level
            levelInformation.Append(vbLf & "Level Name: " & level.Name)

            'get the elevation of the level
            levelInformation.Append(vbLf & vbTab & "Elevation: " & level.Elevation)

            ' get the project elevation of the level
            levelInformation.Append(vbLf & vbTab & "Project Elevation: " & level.ProjectElevation)
        End If
    End While

    'number of totle level in current document
    levelInformation.Append(vbLf & vbLf & " There are " & levelNumber & " levels in the document!")

    'show the level information in the messagebox
    MessageBox.Show(levelInformation.ToString(), "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Level

See Also

Level Members
Autodesk.Revit.Elements Namespace


Level Members

[image] [image]

Revit 2010 API
Level Members
Level Class Constructors Methods Properties See Also Send Feedback

The Level type exposes the following members.

Constructors

Name | Description
Level | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elevation | Retrieve or change the elevation above or below the ground level.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelType | The level style of this level.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PlaneReference | Returns a reference to this element as a plane.
ProjectElevation | Retrieve the elevation relative to project origin, no matter what values of the Elevation Base parameter is set.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Level Class
Autodesk.Revit.Elements Namespace


Level Constructor

[image]

Revit 2010 API
Level Constructor
Level Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Level()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Level()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Level Class
Autodesk.Revit.Elements Namespace


Level Methods

[image] [image]

Revit 2010 API
Level Methods
Level Class See Also Send Feedback

The Level type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Level Class
Autodesk.Revit.Elements Namespace


Level Properties

[image] [image]

Revit 2010 API
Level Properties
Level Class See Also Send Feedback

The Level type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elevation | Retrieve or change the elevation above or below the ground level.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelType | The level style of this level.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PlaneReference | Returns a reference to this element as a plane.
ProjectElevation | Retrieve the elevation relative to project origin, no matter what values of the Elevation Base parameter is set.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Level Class
Autodesk.Revit.Elements Namespace


Elevation Property

[image]

Revit 2010 API
Level..::.Elevation Property
Level Class See Also Send Feedback
Retrieve or change the elevation above or below the ground level.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Elevation { get; set; }
Visual Basic (Declaration)
Public Property Elevation As Double
Visual C++
public:
property double Elevation {
    double get ();
    void set (double value);
}

Remarks

This property Retrieve or change the elevation above or below the ground level of the project. If the Elevation Base parameter is set to Project, the elevation is relative to project origin. If the Elevation Base parameter is set to Shared, the elevation is relative to shared origin which can be changed by relocate operation. The value is given in decimal feet.

See Also

Level Class
Autodesk.Revit.Elements Namespace


LevelType Property

[image]

Revit 2010 API
Level..::.LevelType Property
Level Class See Also Send Feedback
The level style of this level.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LevelType LevelType { get; set; }
Visual Basic (Declaration)
Public Property LevelType As LevelType
Visual C++
public:
property LevelType^ LevelType {
    LevelType^ get ();
    void set (LevelType^ value);
}

See Also

Level Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Level..::.Parameter Property
Level Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Level Class
Level Members
Autodesk.Revit.Elements Namespace


PlaneReference Property

[image]

Revit 2010 API
Level..::.PlaneReference Property
Level Class See Also Send Feedback
Returns a reference to this element as a plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference PlaneReference { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlaneReference As Reference
Visual C++
public:
property Reference^ PlaneReference {
    Reference^ get ();
}

Remarks

The object returned here can be used with the PointOnPlane class.

See Also

Level Class
Autodesk.Revit.Elements Namespace


ProjectElevation Property

[image]

Revit 2010 API
Level..::.ProjectElevation Property
Level Class See Also Send Feedback
Retrieve the elevation relative to project origin, no matter what values of the Elevation Base parameter is set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ProjectElevation { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectElevation As Double
Visual C++
public:
property double ProjectElevation {
    double get ();
}

Remarks

This read only property returns the elevation relative to project origin.

See Also

Level Class
Autodesk.Revit.Elements Namespace


LinearArray Class

[image]

Revit 2010 API
LinearArray Class
Members See Also Send Feedback
An object that represents an Array created linearly within the Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LinearArray : BaseArray
Visual Basic (Declaration)
Public Class LinearArray _
    Inherits BaseArray
Visual C++
public ref class LinearArray : public BaseArray

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.BaseArray
Autodesk.Revit.Elements..::.LinearArray

See Also

LinearArray Members
Autodesk.Revit.Elements Namespace


LinearArray Members

[image] [image]

Revit 2010 API
LinearArray Members
LinearArray Class Constructors Methods Properties See Also Send Feedback

The LinearArray type exposes the following members.

Constructors

Name | Description
LinearArray | Initializes a new instance of the LinearArray class

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CopyMembers | Retrieve the copied members of the Array. (Overrides BaseArray..::.CopyMembers.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from BaseArray.)
NumMembers | Retrieve or Change the number of the arrayed members. (Overrides BaseArray..::.NumMembers.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
OrigMembers | Retrieve the original members of the Array. (Overrides BaseArray..::.OrigMembers.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LinearArray Class
Autodesk.Revit.Elements Namespace


LinearArray Constructor

[image]

Revit 2010 API
LinearArray Constructor
LinearArray Class See Also Send Feedback
Initializes a new instance of the LinearArray class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LinearArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LinearArray()

See Also

LinearArray Class
Autodesk.Revit.Elements Namespace


LinearArray Methods

[image] [image]

Revit 2010 API
LinearArray Methods
LinearArray Class See Also Send Feedback

The LinearArray type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinearArray Class
Autodesk.Revit.Elements Namespace


LinearArray Properties

[image] [image]

Revit 2010 API
LinearArray Properties
LinearArray Class See Also Send Feedback

The LinearArray type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CopyMembers | Retrieve the copied members of the Array. (Overrides BaseArray..::.CopyMembers.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from BaseArray.)
NumMembers | Retrieve or Change the number of the arrayed members. (Overrides BaseArray..::.NumMembers.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
OrigMembers | Retrieve the original members of the Array. (Overrides BaseArray..::.OrigMembers.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LinearArray Class
Autodesk.Revit.Elements Namespace


CopyMembers Property

[image]

Revit 2010 API
LinearArray..::.CopyMembers Property
LinearArray Class See Also Send Feedback
Retrieve the copied members of the Array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override ElementArray CopyMembers { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CopyMembers As ElementArray
Visual C++
public:
virtual property ElementArray^ CopyMembers {
    ElementArray^ get () override;
}

See Also

LinearArray Class
Autodesk.Revit.Elements Namespace


NumMembers Property

[image]

Revit 2010 API
LinearArray..::.NumMembers Property
LinearArray Class See Also Send Feedback
Retrieve or Change the number of the arrayed members.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override int NumMembers { get; set; }
Visual Basic (Declaration)
Public Overrides Property NumMembers As Integer
Visual C++
public:
virtual property int NumMembers {
    int get () override;
    void set (int value) override;
}

See Also

LinearArray Class
Autodesk.Revit.Elements Namespace


OrigMembers Property

[image]

Revit 2010 API
LinearArray..::.OrigMembers Property
LinearArray Class See Also Send Feedback
Retrieve the original members of the Array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override ElementArray OrigMembers { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property OrigMembers As ElementArray
Visual C++
public:
virtual property ElementArray^ OrigMembers {
    ElementArray^ get () override;
}

See Also

LinearArray Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
LinearArray..::.Parameter Property
LinearArray Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LinearArray Class
LinearArray Members
Autodesk.Revit.Elements Namespace


LineLoad Class

[image]

Revit 2010 API
LineLoad Class
Members Example See Also Send Feedback
An object that represents a force/moment applied in a linear manner.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LineLoad : LoadBase
Visual Basic (Declaration)
Public Class LineLoad _
    Inherits LoadBase
Visual C++
public ref class LineLoad : public LoadBase

Remarks

The load/moment may be uniform or it may vary between the two ends of the line.

Examples

CopyC#
 private void LineLoadInformation(LineLoad lineLoad)
{
     StringBuilder information = new StringBuilder("Line Load: ");

     // Get the load case name
     information.Append("\nLoad case for load: " + lineLoad.LoadCaseName);

     //Get the three dimensional force applied to the start point and end point of the line load.
     information.Append("\nForce at the start of this line load: " + XYZToString(lineLoad.Force1));
     information.Append("\nForce at the end of this line load: " + XYZToString(lineLoad.Force2));

     //Get the three dimensional location of the start point and end point for the line load.
     information.Append("\nStart point of this line load: " + XYZToString(lineLoad.StartPoint));
     information.Append("\nEnd Point of this line load: " + XYZToString(lineLoad.EndPoint));

     //Get the three dimensional moment applied to the start point and end point of the line load.
     information.Append("\nMoment at the start of this line load: " + XYZToString(lineLoad.Moment1));
     information.Append("\nMoment at the end of this line load: " + XYZToString(lineLoad.Moment2));

     //Whether the load is projected or not
     if (lineLoad.ProjectedLoad)
     {
         information.Append("\nThis line load is projected.");
     }
     else
     {
         information.Append("\nThis line load is not projected");
     }

     //Report if the load is uniform
     if (0 != lineLoad.UniformLoad)
     {
         information.Append("\nThis load is uniform.");
     }
     else
     {
         information.Append("\nThis load is not uniform.");
     }

     //show information of lineload in a MessageBox.
     MessageBox.Show(information.ToString(), "Revit");
 }

 // output the point's three coordinates
 string XYZToString(XYZ point)
 {
     return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
 }
CopyVB.NET
Private Sub LineLoadInformation(ByVal lineLoad As Autodesk.Revit.Elements.LineLoad)
    Dim information As New StringBuilder("Line Load: ")

    ' Get the load case name
    information.Append(vbLf & "Load case for load: " & lineLoad.LoadCaseName)

    'Get the three dimensional force applied to the start point and end point of the line load.
    information.Append(vbLf & "Force at the start of this line load: " & XYZToString(lineLoad.Force1))
    information.Append(vbLf & "Force at the end of this line load: " & XYZToString(lineLoad.Force2))

    'Get the three dimensional location of the start point and end point for the line load.
    information.Append(vbLf & "Start point of this line load: " & XYZToString(lineLoad.StartPoint))
    information.Append(vbLf & "End Point of this line load: " & XYZToString(lineLoad.EndPoint))

    'Get the three dimensional moment applied to the start point and end point of the line load.
    information.Append(vbLf & "Moment at the start of this line load: " & XYZToString(lineLoad.Moment1))
    information.Append(vbLf & "Moment at the end of this line load: " & XYZToString(lineLoad.Moment2))

    'Whether the load is projected or not
    If lineLoad.ProjectedLoad Then
        information.Append(vbLf & "This line load is projected.")
    Else
        information.Append(vbLf & "This line load is not projected")
    End If

    'Report if the load is uniform
    If 0 <> lineLoad.UniformLoad Then
        information.Append(vbLf & "This load is uniform.")
    Else
        information.Append(vbLf & "This load is not uniform.")
    End If

    'show information of lineload in a MessageBox.
    MessageBox.Show(information.ToString(), "Revit")
End Sub

' output the point's three coordinates
Private Function XYZToString(ByVal point As Autodesk.Revit.Geometry.XYZ) As String
    Return (("(" & point.X & ", ") + point.Y & ", ") + point.Z & ")"
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.LoadBase
Autodesk.Revit.Elements..::.LineLoad

See Also

LineLoad Members
Autodesk.Revit.Elements Namespace


LineLoad Members

[image] [image]

Revit 2010 API
LineLoad Members
LineLoad Class Constructors Methods Properties See Also Send Feedback

The LineLoad type exposes the following members.

Constructors

Name | Description
LineLoad | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EndPoint | Returns the three dimensional location of the end point for the line load.
Force | Returns the three dimensional force applied to one of the points for the line load.
Force1 | Returns the three dimensional force applied to the start point of the line load.
Force2 | Returns the three dimensional force applied to the end point of the line load.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HostElement | The host element for the load. (Inherited from LoadBase.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Moment | Returns the three dimensional moment applied to one of the points for the line load.
Moment1 | Returns the three dimensional moment applied to the start point of the line load.
Moment2 | Returns the three dimensional moment applied to the end point of the line load.
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Point | Returns the three dimensional location of one of the points for the line load.
ProjectedLoad | Returns whether the load is projected or not.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
StartPoint | Returns the three dimensional location of the start point for the line load.
UniformLoad | Report if the load is uniform.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


LineLoad Constructor

[image]

Revit 2010 API
LineLoad Constructor
LineLoad Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LineLoad()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LineLoad()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


LineLoad Methods

[image] [image]

Revit 2010 API
LineLoad Methods
LineLoad Class See Also Send Feedback

The LineLoad type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


LineLoad Properties

[image] [image]

Revit 2010 API
LineLoad Properties
LineLoad Class See Also Send Feedback

The LineLoad type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EndPoint | Returns the three dimensional location of the end point for the line load.
Force | Returns the three dimensional force applied to one of the points for the line load.
Force1 | Returns the three dimensional force applied to the start point of the line load.
Force2 | Returns the three dimensional force applied to the end point of the line load.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HostElement | The host element for the load. (Inherited from LoadBase.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Moment | Returns the three dimensional moment applied to one of the points for the line load.
Moment1 | Returns the three dimensional moment applied to the start point of the line load.
Moment2 | Returns the three dimensional moment applied to the end point of the line load.
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Point | Returns the three dimensional location of one of the points for the line load.
ProjectedLoad | Returns whether the load is projected or not.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
StartPoint | Returns the three dimensional location of the start point for the line load.
UniformLoad | Report if the load is uniform.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


EndPoint Property

[image]

Revit 2010 API
LineLoad..::.EndPoint Property
LineLoad Class See Also Send Feedback
Returns the three dimensional location of the end point for the line load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ EndPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndPoint As XYZ
Visual C++
public:
property XYZ^ EndPoint {
    XYZ^ get ();
}

Remarks

The location of the end point is measured in decimal feet.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


Force Property

[image]

Revit 2010 API
LineLoad..::.Force Property
LineLoad Class See Also Send Feedback
Returns the three dimensional force applied to one of the points for the line load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Force[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Force ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Force[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32
The index of the point to return.

Remarks

An index of 0 represents the start point and 1 represents the end point. The force is measured in Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


Force1 Property

[image]

Revit 2010 API
LineLoad..::.Force1 Property
LineLoad Class See Also Send Feedback
Returns the three dimensional force applied to the start point of the line load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Force1 { get; }
Visual Basic (Declaration)
Public ReadOnly Property Force1 As XYZ
Visual C++
public:
property XYZ^ Force1 {
    XYZ^ get ();
}

Remarks

The force is measured in Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


Force2 Property

[image]

Revit 2010 API
LineLoad..::.Force2 Property
LineLoad Class See Also Send Feedback
Returns the three dimensional force applied to the end point of the line load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Force2 { get; }
Visual Basic (Declaration)
Public ReadOnly Property Force2 As XYZ
Visual C++
public:
property XYZ^ Force2 {
    XYZ^ get ();
}

Remarks

The force is measured in Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


Moment Property

[image]

Revit 2010 API
LineLoad..::.Moment Property
LineLoad Class See Also Send Feedback
Returns the three dimensional moment applied to one of the points for the line load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Moment[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Moment ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Moment[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32
The index of the point to return.

Remarks

An index of 0 represents the start point and 1 represents the end point. The moment is measured in Feet*Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


Moment1 Property

[image]

Revit 2010 API
LineLoad..::.Moment1 Property
LineLoad Class See Also Send Feedback
Returns the three dimensional moment applied to the start point of the line load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Moment1 { get; }
Visual Basic (Declaration)
Public ReadOnly Property Moment1 As XYZ
Visual C++
public:
property XYZ^ Moment1 {
    XYZ^ get ();
}

Remarks

The moment is measured in Feet*Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


Moment2 Property

[image]

Revit 2010 API
LineLoad..::.Moment2 Property
LineLoad Class See Also Send Feedback
Returns the three dimensional moment applied to the end point of the line load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Moment2 { get; }
Visual Basic (Declaration)
Public ReadOnly Property Moment2 As XYZ
Visual C++
public:
property XYZ^ Moment2 {
    XYZ^ get ();
}

Remarks

The moment is measured in Feet*Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
LineLoad..::.Parameter Property
LineLoad Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LineLoad Class
LineLoad Members
Autodesk.Revit.Elements Namespace


Point Property

[image]

Revit 2010 API
LineLoad..::.Point Property
LineLoad Class See Also Send Feedback
Returns the three dimensional location of one of the points for the line load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Point[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Point ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Point[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32
The index of the point to return.

Remarks

An index of 0 represents the start point and 1 represents the end point. The location of the point is measured in decimal feet.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


ProjectedLoad Property

[image]

Revit 2010 API
LineLoad..::.ProjectedLoad Property
LineLoad Class See Also Send Feedback
Returns whether the load is projected or not.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool ProjectedLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectedLoad As Boolean
Visual C++
public:
property bool ProjectedLoad {
    bool get ();
}

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


StartPoint Property

[image]

Revit 2010 API
LineLoad..::.StartPoint Property
LineLoad Class See Also Send Feedback
Returns the three dimensional location of the start point for the line load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ StartPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartPoint As XYZ
Visual C++
public:
property XYZ^ StartPoint {
    XYZ^ get ();
}

Remarks

The location of the start point is measured in decimal feet.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


UniformLoad Property

[image]

Revit 2010 API
LineLoad..::.UniformLoad Property
LineLoad Class See Also Send Feedback
Report if the load is uniform.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int UniformLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property UniformLoad As Integer
Visual C++
public:
property int UniformLoad {
    int get ();
}

Remarks

This property will return True is the line load is uniform, i.e. the load is that same across the entire line.

See Also

LineLoad Class
Autodesk.Revit.Elements Namespace


LinePattern Class

[image]

Revit 2010 API
LinePattern Class
Members See Also Send Feedback
Represents a line pattern element within an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LinePattern : Element
Visual Basic (Declaration)
Public Class LinePattern _
    Inherits Element
Visual C++
public ref class LinePattern : public Element

Remarks

Currently the details of the line patterns are not exposed but all the line patterns can be found on the Document object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.LinePattern

See Also

LinePattern Members
Autodesk.Revit.Elements Namespace


LinePattern Members

[image] [image]

Revit 2010 API
LinePattern Members
LinePattern Class Constructors Methods Properties See Also Send Feedback

The LinePattern type exposes the following members.

Constructors

Name | Description
LinePattern | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LinePattern Class
Autodesk.Revit.Elements Namespace


LinePattern Constructor

[image]

Revit 2010 API
LinePattern Constructor
LinePattern Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LinePattern()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LinePattern()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LinePattern Class
Autodesk.Revit.Elements Namespace


LinePattern Methods

[image] [image]

Revit 2010 API
LinePattern Methods
LinePattern Class See Also Send Feedback

The LinePattern type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinePattern Class
Autodesk.Revit.Elements Namespace


LinePattern Properties

[image] [image]

Revit 2010 API
LinePattern Properties
LinePattern Class See Also Send Feedback

The LinePattern type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LinePattern Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
LinePattern..::.Parameter Property
LinePattern Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LinePattern Class
LinePattern Members
Autodesk.Revit.Elements Namespace


LoadBase Class

[image]

Revit 2010 API
LoadBase Class
Members Example See Also Send Feedback
The LoadBase object is the base class for all load objects within the Autodesk Revit API.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LoadBase : Element
Visual Basic (Declaration)
Public Class LoadBase _
    Inherits Element
Visual C++
public ref class LoadBase : public Element

Remarks

Load objects are only available in Autodesk Revit Structure. This object contains methods that are common to all other load objects.

Examples

CopyC#
private void LoadBaseInformation(LoadBase loadBase)
{
    string message = "LoadBase data for line load: ";
    //Get the name of the load case to which this load belongs
    message += "\nLoad case name: " + loadBase.LoadCaseName;

    //Get the name of the category to which this load belongs
    message += "\nLoad category name: " + loadBase.LoadCategoryName;

    //A string representing the nature of the load
    message += "\nLoad nature name: " + loadBase.LoadNatureName;

    //show the load base information in the messagebox
    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Private Sub LoadBaseInformation(ByVal loadBase As Autodesk.Revit.Elements.LoadBase)
    Dim message As String = "LoadBase data for line load: "
    'Get the name of the load case to which this load belongs
    message += vbLf & "Load case name: " & loadBase.LoadCaseName

    'Get the name of the category to which this load belongs
    message += vbLf & "Load category name: " & loadBase.LoadCategoryName

    'A string representing the nature of the load
    message += vbLf & "Load nature name: " & loadBase.LoadNatureName

    'show the load base information in the messagebox
    MessageBox.Show(message, "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.LoadBase
Autodesk.Revit.Elements..::.AreaLoad
Autodesk.Revit.Elements..::.LineLoad
Autodesk.Revit.Elements..::.PointLoad

See Also

LoadBase Members
Autodesk.Revit.Elements Namespace


LoadBase Members

[image] [image]

Revit 2010 API
LoadBase Members
LoadBase Class Constructors Methods Properties See Also Send Feedback

The LoadBase type exposes the following members.

Constructors

Name | Description
LoadBase | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HostElement | The host element for the load.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadCaseName | The name of the load case to which this load belongs.
LoadCategoryName | The name of the category to which this load belongs.
LoadNatureName | A string representing the nature of the load.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LoadBase Class
Autodesk.Revit.Elements Namespace


LoadBase Constructor

[image]

Revit 2010 API
LoadBase Constructor
LoadBase Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadBase()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadBase Class
Autodesk.Revit.Elements Namespace


LoadBase Methods

[image] [image]

Revit 2010 API
LoadBase Methods
LoadBase Class See Also Send Feedback

The LoadBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadBase Class
Autodesk.Revit.Elements Namespace


LoadBase Properties

[image] [image]

Revit 2010 API
LoadBase Properties
LoadBase Class See Also Send Feedback

The LoadBase type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HostElement | The host element for the load.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadCaseName | The name of the load case to which this load belongs.
LoadCategoryName | The name of the category to which this load belongs.
LoadNatureName | A string representing the nature of the load.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LoadBase Class
Autodesk.Revit.Elements Namespace


HostElement Property

[image]

Revit 2010 API
LoadBase..::.HostElement Property
LoadBase Class See Also Send Feedback
The host element for the load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element HostElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property HostElement As Element
Visual C++
public:
property Element^ HostElement {
    Element^ get ();
}

Field Value

If the load is host-based this is the host element. Otherwise this property is null.

See Also

LoadBase Class
Autodesk.Revit.Elements Namespace


LoadCaseName Property

[image]

Revit 2010 API
LoadBase..::.LoadCaseName Property
LoadBase Class See Also Send Feedback
The name of the load case to which this load belongs.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string LoadCaseName { get; }
Visual Basic (Declaration)
Public ReadOnly Property LoadCaseName As String
Visual C++
public:
property String^ LoadCaseName {
    String^ get ();
}

See Also

LoadBase Class
Autodesk.Revit.Elements Namespace


LoadCategoryName Property

[image]

Revit 2010 API
LoadBase..::.LoadCategoryName Property
LoadBase Class See Also Send Feedback
The name of the category to which this load belongs.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string LoadCategoryName { get; }
Visual Basic (Declaration)
Public ReadOnly Property LoadCategoryName As String
Visual C++
public:
property String^ LoadCategoryName {
    String^ get ();
}

See Also

LoadBase Class
Autodesk.Revit.Elements Namespace


LoadNatureName Property

[image]

Revit 2010 API
LoadBase..::.LoadNatureName Property
LoadBase Class See Also Send Feedback
A string representing the nature of the load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string LoadNatureName { get; }
Visual Basic (Declaration)
Public ReadOnly Property LoadNatureName As String
Visual C++
public:
property String^ LoadNatureName {
    String^ get ();
}

See Also

LoadBase Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
LoadBase..::.Parameter Property
LoadBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LoadBase Class
LoadBase Members
Autodesk.Revit.Elements Namespace


LoadCase Class

[image]

Revit 2010 API
LoadCase Class
Members Example See Also Send Feedback
This object represents a load case within the project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LoadCase : Element
Visual Basic (Declaration)
Public Class LoadCase _
    Inherits Element
Visual C++
public ref class LoadCase : public Element

Examples

CopyC#
private void LoadCaseInfomation(Document document, LoadCase loadCase)
{
    string loadCaseNumber;   //Store the load cases number
    StringBuilder information = new StringBuilder(10);

    // first get all the load case categories in a list
    List<Category> loadCaseCategories = new List<Category>();
    GetLoadCaseCategories(document, ref loadCaseCategories);

    //get the load case name
    information.Append("\nCase Name: " + loadCase.Name);

    //get the number of the load case
    Parameter caseNumber = loadCase.get_Parameter(BuiltInParameter.LOAD_CASE_NUMBER);
    if (null == caseNumber)
    {
        loadCaseNumber = "";
    }
    else
    {
        loadCaseNumber = caseNumber.AsInteger().ToString();
    }
    information.Append("\nCase Number: " + loadCaseNumber);

    //get the category of the load case
    Parameter caseCategoryid = loadCase.get_Parameter(BuiltInParameter.LOAD_CASE_CATEGORY);
    ElementId loadCaseCategoryId = caseCategoryid.AsElementId();

    information.Append("\nCategory: " + GetCategoryName(loadCaseCategoryId, loadCaseCategories));

    //get the nature of load case
    Parameter caseNatureId = loadCase.get_Parameter(BuiltInParameter.LOAD_CASE_NATURE);
    ElementId loadCaseNatureId = caseNatureId.AsElementId();
    LoadNature loadNature = document.get_Element(ref loadCaseNatureId) as LoadNature;
    information.Append("\nNature: " + loadNature.Name + "\n");

    //show the information to the user
    MessageBox.Show(information.ToString(), "Revit");
}

private void GetLoadCaseCategories(Document document, ref List<Category> loadCaseCategories)
{
    //get all the categories of load cases
    Categories categories = document.Settings.Categories;
    Category caseCategory = categories.get_Item(BuiltInCategory.OST_LoadCases);
    CategoryNameMap categoryNameMap = caseCategory.SubCategories;
    System.Collections.IEnumerator iter = categoryNameMap.GetEnumerator();
    iter.Reset();
    while (iter.MoveNext())
    {
        Category temp = iter.Current as Category;
        if (null != temp)
        {
            loadCaseCategories.Add(temp);
        }
    }
}

/// <summary>
/// Get the category name according to the load case category id.
/// </summary>
private string GetCategoryName(ElementId loadCaseCategoryId, List<Category> loadCaseCategories)
{
    string categoryName = "";

    foreach (Category category in loadCaseCategories)
    {
        if (category.Id.Equals(loadCaseCategoryId))
        {
            categoryName = category.Name;
            break;
        }
    }
    return categoryName;
}
CopyVB.NET
Private Sub LoadCaseInfomation(ByVal document As Document, ByVal loadCase As LoadCase)
    Dim loadCaseNumber As String
    'Store the load cases number
    Dim information As New StringBuilder(10)

    ' first get all the load case categories in a list
    Dim loadCaseCategories As New List(Of Autodesk.Revit.Category)()
    GetLoadCaseCategories(document, loadCaseCategories)

    'get the load case name
    information.Append(vbLf & "Case Name: " & loadCase.Name)

    'get the number of the load case
    Dim caseNumber As Parameter = loadCase.Parameter(BuiltInParameter.LOAD_CASE_NUMBER)
    If caseNumber Is Nothing Then
        loadCaseNumber = ""
    Else
        loadCaseNumber = caseNumber.AsInteger().ToString()
    End If
    information.Append(vbLf & "Case Number: " & loadCaseNumber)

    'get the category of the load case
    Dim caseCategoryid As Parameter = loadCase.Parameter(BuiltInParameter.LOAD_CASE_CATEGORY)
    Dim loadCaseCategoryId As Autodesk.Revit.ElementId = caseCategoryid.AsElementId()

    information.Append(vbLf & "Category: " & GetCategoryName(loadCaseCategoryId, loadCaseCategories))

    'get the nature of load case
    Dim caseNatureId As Parameter = loadCase.Parameter(BuiltInParameter.LOAD_CASE_NATURE)
    Dim loadCaseNatureId As Autodesk.Revit.ElementId = caseNatureId.AsElementId()
    Dim loadNature As LoadNature = TryCast(document.Element(loadCaseNatureId), LoadNature)
    information.Append(vbLf & "Nature: " & loadNature.Name & vbLf)

    'show the information to the user
    MessageBox.Show(information.ToString(), "Revit")
End Sub

Private Sub GetLoadCaseCategories(ByVal document As Document, ByRef loadCaseCategories As List(Of Autodesk.Revit.Category))
    'get all the categories of load cases
    Dim categories As Categories = document.Settings.Categories
    Dim caseCategory As Autodesk.Revit.Category = categories.Item(BuiltInCategory.OST_LoadCases)
    Dim categoryNameMap As CategoryNameMap = caseCategory.SubCategories
    Dim iter As System.Collections.IEnumerator = categoryNameMap.GetEnumerator()
    iter.Reset()
    While iter.MoveNext()
        Dim temp As Autodesk.Revit.Category = TryCast(iter.Current, Autodesk.Revit.Category)
        If temp IsNot Nothing Then
            loadCaseCategories.Add(temp)
        End If
    End While
End Sub

' <summary>
' Get the category name according to the load case category id.
' </summary>
Private Function GetCategoryName(ByVal loadCaseCategoryId As Autodesk.Revit.ElementId, ByVal loadCaseCategories As List(Of Autodesk.Revit.Category)) As String
    Dim categoryName As String = ""

    For Each category As Autodesk.Revit.Category In loadCaseCategories
        If category.Id.Equals(loadCaseCategoryId) Then
            categoryName = category.Name
            Exit For
        End If
    Next
    Return categoryName
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.LoadCase

See Also

LoadCase Members
Autodesk.Revit.Elements Namespace


LoadCase Members

[image] [image]

Revit 2010 API
LoadCase Members
LoadCase Class Constructors Methods Properties See Also Send Feedback

The LoadCase type exposes the following members.

Constructors

Name | Description
LoadCase | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LoadCase Class
Autodesk.Revit.Elements Namespace


LoadCase Constructor

[image]

Revit 2010 API
LoadCase Constructor
LoadCase Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadCase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCase()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadCase Class
Autodesk.Revit.Elements Namespace


LoadCase Methods

[image] [image]

Revit 2010 API
LoadCase Methods
LoadCase Class See Also Send Feedback

The LoadCase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCase Class
Autodesk.Revit.Elements Namespace


LoadCase Properties

[image] [image]

Revit 2010 API
LoadCase Properties
LoadCase Class See Also Send Feedback

The LoadCase type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LoadCase Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
LoadCase..::.Parameter Property
LoadCase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LoadCase Class
LoadCase Members
Autodesk.Revit.Elements Namespace


LoadCaseArray Class

[image]

Revit 2010 API
LoadCaseArray Class
Members See Also Send Feedback
An array that contains load case objects.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LoadCaseArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class LoadCaseArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LoadCaseArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.LoadCaseArray

See Also

LoadCaseArray Members
Autodesk.Revit.Elements Namespace


LoadCaseArray Members

[image] [image]

Revit 2010 API
LoadCaseArray Members
LoadCaseArray Class Constructors Methods Properties See Also Send Feedback

The LoadCaseArray type exposes the following members.

Constructors

Name | Description
LoadCaseArray | Initializes a new instance of the LoadCaseArray class

Methods

Name | Description
Append | Add the load case to the end of the array.
Clear | Removes every load case from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified load case into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an load case at a specified index within the array.
Size | Returns the number of load cases that are in the array.

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


LoadCaseArray Constructor

[image]

Revit 2010 API
LoadCaseArray Constructor
LoadCaseArray Class See Also Send Feedback
Initializes a new instance of the LoadCaseArray class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadCaseArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCaseArray()

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


LoadCaseArray Methods

[image] [image]

Revit 2010 API
LoadCaseArray Methods
LoadCaseArray Class See Also Send Feedback

The LoadCaseArray type exposes the following members.

Methods

Name | Description
Append | Add the load case to the end of the array.
Clear | Removes every load case from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified load case into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


Append Method

[image]

Revit 2010 API
LoadCaseArray..::.Append Method
LoadCaseArray Class See Also Send Feedback
Add the load case to the end of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    LoadCase item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As LoadCase _
)
Visual C++
public:
virtual void Append(
    LoadCase^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.LoadCase
The load case to be added.

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


Clear Method

[image]

Revit 2010 API
LoadCaseArray..::.Clear Method
LoadCaseArray Class See Also Send Feedback
Removes every load case from the array, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

[image]

Revit 2010 API
LoadCaseArray..::.ForwardIterator Method
LoadCaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual LoadCaseArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LoadCaseArrayIterator
Visual C++
public:
virtual LoadCaseArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

[image]

Revit 2010 API
LoadCaseArray..::.GetEnumerator Method
LoadCaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


Insert Method

[image]

Revit 2010 API
LoadCaseArray..::.Insert Method
LoadCaseArray Class See Also Send Feedback
Insert the specified load case into the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    LoadCase item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As LoadCase, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    LoadCase^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Elements..::.LoadCase
The load case to be inserted into the array.
index
Type: System..::.Int32
The load case will be inserted before this index.

Return Value

Returns whether the load case was inserted into the array.

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

[image]

Revit 2010 API
LoadCaseArray..::.ReverseIterator Method
LoadCaseArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual LoadCaseArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LoadCaseArrayIterator
Visual C++
public:
virtual LoadCaseArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


LoadCaseArray Properties

[image] [image]

Revit 2010 API
LoadCaseArray Properties
LoadCaseArray Class See Also Send Feedback

The LoadCaseArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an load case at a specified index within the array.
Size | Returns the number of load cases that are in the array.

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


IsEmpty Property

[image]

Revit 2010 API
LoadCaseArray..::.IsEmpty Property
LoadCaseArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


Item Property

[image]

Revit 2010 API
LoadCaseArray..::.Item Property
LoadCaseArray Class See Also Send Feedback
Gets or sets an load case at a specified index within the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual LoadCase Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As LoadCase
Visual C++
public:
virtual property LoadCase^ Item[int index] {
    LoadCase^ get (int index);
    void set (int index, LoadCase^ value);
}

Parameters

index
Type: System..::.Int32
The index of the load case to be set or retrieved.

Return Value

Returns the load case at the specified index.

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


Size Property

[image]

Revit 2010 API
LoadCaseArray..::.Size Property
LoadCaseArray Class See Also Send Feedback
Returns the number of load cases that are in the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LoadCaseArray Class
Autodesk.Revit.Elements Namespace


LoadCaseArrayIterator Class

[image]

Revit 2010 API
LoadCaseArrayIterator Class
Members See Also Send Feedback
An iterator to an load case array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class LoadCaseArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class LoadCaseArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LoadCaseArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.LoadCaseArrayIterator

See Also

LoadCaseArrayIterator Members
Autodesk.Revit.Elements Namespace


LoadCaseArrayIterator Members

[image] [image]

Revit 2010 API
LoadCaseArrayIterator Members
LoadCaseArrayIterator Class Constructors Methods Properties See Also Send Feedback

The LoadCaseArrayIterator type exposes the following members.

Constructors

Name | Description
LoadCaseArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.Elements Namespace


LoadCaseArrayIterator Constructor

[image]

Revit 2010 API
LoadCaseArrayIterator Constructor
LoadCaseArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadCaseArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCaseArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.Elements Namespace


LoadCaseArrayIterator Methods

[image] [image]

Revit 2010 API
LoadCaseArrayIterator Methods
LoadCaseArrayIterator Class See Also Send Feedback

The LoadCaseArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

[image]

Revit 2010 API
LoadCaseArrayIterator..::.MoveNext Method
LoadCaseArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

[image]

Revit 2010 API
LoadCaseArrayIterator..::.Reset Method
LoadCaseArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.Elements Namespace


LoadCaseArrayIterator Properties

[image] [image]

Revit 2010 API
LoadCaseArrayIterator Properties
LoadCaseArrayIterator Class See Also Send Feedback

The LoadCaseArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.Elements Namespace


Current Property

[image]

Revit 2010 API
LoadCaseArrayIterator..::.Current Property
LoadCaseArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.Elements Namespace


LoadCaseSet Class

[image]

Revit 2010 API
LoadCaseSet Class
Members See Also Send Feedback
A set that contains load cases.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LoadCaseSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class LoadCaseSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LoadCaseSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.LoadCaseSet

See Also

LoadCaseSet Members
Autodesk.Revit.Elements Namespace


LoadCaseSet Members

[image] [image]

Revit 2010 API
LoadCaseSet Members
LoadCaseSet Class Constructors Methods Properties See Also Send Feedback

The LoadCaseSet type exposes the following members.

Constructors

Name | Description
LoadCaseSet | Initializes a new instance of the LoadCaseSet class

Methods

Name | Description
Clear | Removes every load case from the set, rendering it empty.
Contains | Tests for the existence of a load case within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified load case from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified load case into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of load cases that are in the set.

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


LoadCaseSet Constructor

[image]

Revit 2010 API
LoadCaseSet Constructor
LoadCaseSet Class See Also Send Feedback
Initializes a new instance of the LoadCaseSet class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadCaseSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCaseSet()

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


LoadCaseSet Methods

[image] [image]

Revit 2010 API
LoadCaseSet Methods
LoadCaseSet Class See Also Send Feedback

The LoadCaseSet type exposes the following members.

Methods

Name | Description
Clear | Removes every load case from the set, rendering it empty.
Contains | Tests for the existence of a load case within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified load case from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified load case into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


Clear Method

[image]

Revit 2010 API
LoadCaseSet..::.Clear Method
LoadCaseSet Class See Also Send Feedback
Removes every load case from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


Contains Method

[image]

Revit 2010 API
LoadCaseSet..::.Contains Method
LoadCaseSet Class See Also Send Feedback
Tests for the existence of a load case within the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    LoadCase item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As LoadCase _
) As Boolean
Visual C++
public:
virtual bool Contains(
    LoadCase^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.LoadCase
The load case to be searched for.

Return Value

The Contains method returns True if the load case is within the set, otherwise False.

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


Erase Method

[image]

Revit 2010 API
LoadCaseSet..::.Erase Method
LoadCaseSet Class See Also Send Feedback
Removes a specified load case from the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    LoadCase item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As LoadCase _
) As Integer
Visual C++
public:
virtual int Erase(
    LoadCase^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.LoadCase
The load case to be erased.

Return Value

The number of load cases that were erased from the set.

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

[image]

Revit 2010 API
LoadCaseSet..::.ForwardIterator Method
LoadCaseSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual LoadCaseSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LoadCaseSetIterator
Visual C++
public:
virtual LoadCaseSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

[image]

Revit 2010 API
LoadCaseSet..::.GetEnumerator Method
LoadCaseSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


Insert Method

[image]

Revit 2010 API
LoadCaseSet..::.Insert Method
LoadCaseSet Class See Also Send Feedback
Insert the specified load case into the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    LoadCase item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As LoadCase _
) As Boolean
Visual C++
public:
virtual bool Insert(
    LoadCase^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.LoadCase
The load case to be inserted into the set.

Return Value

Returns whether the load case was inserted into the set.

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

[image]

Revit 2010 API
LoadCaseSet..::.ReverseIterator Method
LoadCaseSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual LoadCaseSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LoadCaseSetIterator
Visual C++
public:
virtual LoadCaseSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


LoadCaseSet Properties

[image] [image]

Revit 2010 API
LoadCaseSet Properties
LoadCaseSet Class See Also Send Feedback

The LoadCaseSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of load cases that are in the set.

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


IsEmpty Property

[image]

Revit 2010 API
LoadCaseSet..::.IsEmpty Property
LoadCaseSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


Size Property

[image]

Revit 2010 API
LoadCaseSet..::.Size Property
LoadCaseSet Class See Also Send Feedback
Returns the number of load cases that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LoadCaseSet Class
Autodesk.Revit.Elements Namespace


LoadCaseSetIterator Class

[image]

Revit 2010 API
LoadCaseSetIterator Class
Members See Also Send Feedback
An iterator to a load case set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class LoadCaseSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class LoadCaseSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LoadCaseSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.LoadCaseSetIterator

See Also

LoadCaseSetIterator Members
Autodesk.Revit.Elements Namespace


LoadCaseSetIterator Members

[image] [image]

Revit 2010 API
LoadCaseSetIterator Members
LoadCaseSetIterator Class Constructors Methods Properties See Also Send Feedback

The LoadCaseSetIterator type exposes the following members.

Constructors

Name | Description
LoadCaseSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCaseSetIterator Class
Autodesk.Revit.Elements Namespace


LoadCaseSetIterator Constructor

[image]

Revit 2010 API
LoadCaseSetIterator Constructor
LoadCaseSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadCaseSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCaseSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadCaseSetIterator Class
Autodesk.Revit.Elements Namespace


LoadCaseSetIterator Methods

[image] [image]

Revit 2010 API
LoadCaseSetIterator Methods
LoadCaseSetIterator Class See Also Send Feedback

The LoadCaseSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCaseSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

[image]

Revit 2010 API
LoadCaseSetIterator..::.MoveNext Method
LoadCaseSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LoadCaseSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

[image]

Revit 2010 API
LoadCaseSetIterator..::.Reset Method
LoadCaseSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LoadCaseSetIterator Class
Autodesk.Revit.Elements Namespace


LoadCaseSetIterator Properties

[image] [image]

Revit 2010 API
LoadCaseSetIterator Properties
LoadCaseSetIterator Class See Also Send Feedback

The LoadCaseSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCaseSetIterator Class
Autodesk.Revit.Elements Namespace


Current Property

[image]

Revit 2010 API
LoadCaseSetIterator..::.Current Property
LoadCaseSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LoadCaseSetIterator Class
Autodesk.Revit.Elements Namespace


LoadCombination Class

[image]

Revit 2010 API
LoadCombination Class
Members Example See Also Send Feedback
An object that represents a load combination.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LoadCombination : Element
Visual Basic (Declaration)
Public Class LoadCombination _
    Inherits Element
Visual C++
public ref class LoadCombination : public Element

Examples

CopyC#
private void CombinationInformation(LoadCombination loadCombination)
{
    StringBuilder information = new StringBuilder();

    //Get the string with Load Combination Name or empty string
    information.Append("\n\nCombination Name: " + loadCombination.Name);

    //Get the string with Load Combination State
    information.Append("\nCombination state: " + loadCombination.CombinationState);

    //Load Combination State index or 0
    information.Append("\nState index : " + loadCombination.CombinationStateIndex.ToString());

    //Get the string with Load Combination Type
    information.Append("\nCombination type: " + loadCombination.CombinationType);

    //Get Load Combination Type index or 0
    information.Append("\nType index: " + loadCombination.CombinationTypeIndex.ToString());

    //Get the number of Load Combination Components
    int componentsNumber = loadCombination.NumberOfComponents;
    information.Append("\nComponents number: " + componentsNumber.ToString());
    for (int j = 0; j < componentsNumber; j++)
    {
        double factor = loadCombination.get_Factor(j);
        string caseName = loadCombination.get_CombinationCaseName(j);
        information.Append("\nCase name[" + j.ToString() + "]: " + caseName + "  factor: " +
                              factor.ToString());
    }

    //return the number of usage in the combination
    int usageNumber = loadCombination.NumberOfUsages;
    information.Append("\nNumber of usages: " + usageNumber + "\nUsage names: ");
    //get each usage name
    for (int i = 0; i < usageNumber; i++)
    {
        information.Append(loadCombination.get_UsageName(i) + "  ");
    }

    MessageBox.Show(information.ToString(), "Revit");
}
CopyVB.NET
Private Sub CombinationInformation(ByVal loadCombination As LoadCombination)
    Dim information As New StringBuilder()

    'Get the string with Load Combination Name or empty string
    information.Append(vbLf & vbLf & "Combination Name: " & loadCombination.Name)

    'Get the string with Load Combination State
    information.Append(vbLf & "Combination state: " & loadCombination.CombinationState)

    'Load Combination State index or 0
    information.Append(vbLf & "State index : " & loadCombination.CombinationStateIndex.ToString())

    'Get the string with Load Combination Type
    information.Append(vbLf & "Combination type: " & loadCombination.CombinationType)

    'Get Load Combination Type index or 0
    information.Append(vbLf & "Type index: " & loadCombination.CombinationTypeIndex.ToString())

    'Get the number of Load Combination Components
    Dim componentsNumber As Integer = loadCombination.NumberOfComponents
    information.Append(vbLf & "Components number: " & componentsNumber.ToString())
    For j As Integer = 0 To componentsNumber - 1
        Dim factor As Double = loadCombination.Factor(j)
        Dim caseName As String = loadCombination.CombinationCaseName(j)
        information.Append(((vbLf & "Case name[" & j.ToString() & "]: ") + caseName & " factor: ") + factor.ToString())
    Next

    'return the number of usage in the combination
    Dim usageNumber As Integer = loadCombination.NumberOfUsages
    information.Append(vbLf & "Number of usages: " & usageNumber & vbLf & "Usage names: ")
    'get each usage name
    For i As Integer = 0 To usageNumber - 1
        information.Append(loadCombination.UsageName(i) & " ")
    Next

    MessageBox.Show(information.ToString(), "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.LoadCombination

See Also

LoadCombination Members
Autodesk.Revit.Elements Namespace


LoadCombination Members

[image] [image]

Revit 2010 API
LoadCombination Members
LoadCombination Class Constructors Methods Properties See Also Send Feedback

The LoadCombination type exposes the following members.

Constructors

Name | Description
LoadCombination | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CombinationCaseName | Returns load combination case name.
CombinationNatureName | Returns load combination nature name of load case element.
CombinationState | Returns load combination state.
CombinationStateIndex | Returns the index in predefined load combination state array {}.
CombinationType | Returns load combination type.
CombinationTypeIndex | Returns the index in predefined load combination type array.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Factor | Returns factor value.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns load combination name.
NumberOfComponents | Returns number of factors.
NumberOfUsages | Returns number of usages.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UsageName | Returns usage value.

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


LoadCombination Constructor

[image]

Revit 2010 API
LoadCombination Constructor
LoadCombination Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadCombination()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCombination()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


LoadCombination Methods

[image] [image]

Revit 2010 API
LoadCombination Methods
LoadCombination Class See Also Send Feedback

The LoadCombination type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


LoadCombination Properties

[image] [image]

Revit 2010 API
LoadCombination Properties
LoadCombination Class See Also Send Feedback

The LoadCombination type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CombinationCaseName | Returns load combination case name.
CombinationNatureName | Returns load combination nature name of load case element.
CombinationState | Returns load combination state.
CombinationStateIndex | Returns the index in predefined load combination state array {}.
CombinationType | Returns load combination type.
CombinationTypeIndex | Returns the index in predefined load combination type array.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Factor | Returns factor value.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns load combination name.
NumberOfComponents | Returns number of factors.
NumberOfUsages | Returns number of usages.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UsageName | Returns usage value.

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


CombinationCaseName Property

[image]

Revit 2010 API
LoadCombination..::.CombinationCaseName Property
LoadCombination Class See Also Send Feedback
Returns load combination case name.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string CombinationCaseName[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property CombinationCaseName ( _
    index As Integer _
) As String
Visual C++
public:
property String^ CombinationCaseName[int index] {
    String^ get (int index);
}

Parameters

index
Type: System..::.Int32
The index of load case.

Remarks

The index should be not less then 0 and be less than load cases count.

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


CombinationNatureName Property

[image]

Revit 2010 API
LoadCombination..::.CombinationNatureName Property
LoadCombination Class See Also Send Feedback
Returns load combination nature name of load case element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string CombinationNatureName[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property CombinationNatureName ( _
    index As Integer _
) As String
Visual C++
public:
property String^ CombinationNatureName[int index] {
    String^ get (int index);
}

Parameters

index
Type: System..::.Int32
The index of load case.

Remarks

The index should be not less 0 and be less than load cases count.

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


CombinationState Property

[image]

Revit 2010 API
LoadCombination..::.CombinationState Property
LoadCombination Class See Also Send Feedback
Returns load combination state.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string CombinationState { get; }
Visual Basic (Declaration)
Public ReadOnly Property CombinationState As String
Visual C++
public:
property String^ CombinationState {
    String^ get ();
}

Remarks

The state should be "Serviceability" or "Ultimate".

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


CombinationStateIndex Property

[image]

Revit 2010 API
LoadCombination..::.CombinationStateIndex Property
LoadCombination Class See Also Send Feedback
Returns the index in predefined load combination state array {}.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int CombinationStateIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property CombinationStateIndex As Integer
Visual C++
public:
property int CombinationStateIndex {
    int get ();
}

Remarks

The index should be 0 ("Serviceability") or 1 ("Ultimate").

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


CombinationType Property

[image]

Revit 2010 API
LoadCombination..::.CombinationType Property
LoadCombination Class See Also Send Feedback
Returns load combination type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string CombinationType { get; }
Visual Basic (Declaration)
Public ReadOnly Property CombinationType As String
Visual C++
public:
property String^ CombinationType {
    String^ get ();
}

Remarks

The type should be "Combination" or "Envelope".

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


CombinationTypeIndex Property

[image]

Revit 2010 API
LoadCombination..::.CombinationTypeIndex Property
LoadCombination Class See Also Send Feedback
Returns the index in predefined load combination type array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int CombinationTypeIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property CombinationTypeIndex As Integer
Visual C++
public:
property int CombinationTypeIndex {
    int get ();
}

Remarks

The index should be 0 ("Combination") or 1 ("Envelope").

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


Factor Property

[image]

Revit 2010 API
LoadCombination..::.Factor Property
LoadCombination Class See Also Send Feedback
Returns factor value.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Factor[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Factor ( _
    index As Integer _
) As Double
Visual C++
public:
property double Factor[int index] {
    double get (int index);
}

Parameters

index
Type: System..::.Int32
The index of factor in load combination.

Remarks

The index should be not less 0 and be less than load factors count.

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


Name Property

[image]

Revit 2010 API
LoadCombination..::.Name Property
LoadCombination Class See Also Send Feedback
Returns load combination name.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


NumberOfComponents Property

[image]

Revit 2010 API
LoadCombination..::.NumberOfComponents Property
LoadCombination Class See Also Send Feedback
Returns number of factors.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NumberOfComponents { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumberOfComponents As Integer
Visual C++
public:
property int NumberOfComponents {
    int get ();
}

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


NumberOfUsages Property

[image]

Revit 2010 API
LoadCombination..::.NumberOfUsages Property
LoadCombination Class See Also Send Feedback
Returns number of usages.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NumberOfUsages { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumberOfUsages As Integer
Visual C++
public:
property int NumberOfUsages {
    int get ();
}

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
LoadCombination..::.Parameter Property
LoadCombination Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LoadCombination Class
LoadCombination Members
Autodesk.Revit.Elements Namespace


UsageName Property

[image]

Revit 2010 API
LoadCombination..::.UsageName Property
LoadCombination Class See Also Send Feedback
Returns usage value.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string UsageName[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property UsageName ( _
    index As Integer _
) As String
Visual C++
public:
property String^ UsageName[int index] {
    String^ get (int index);
}

Parameters

index
Type: System..::.Int32
The index of usage in load combination.

Remarks

The index should be not less 0 and be less than load factors count.

See Also

LoadCombination Class
Autodesk.Revit.Elements Namespace


LoadCombinationArray Class

[image]

Revit 2010 API
LoadCombinationArray Class
Members See Also Send Feedback
An array that can contain any type of object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LoadCombinationArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class LoadCombinationArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LoadCombinationArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.LoadCombinationArray

See Also

LoadCombinationArray Members
Autodesk.Revit.Elements Namespace


LoadCombinationArray Members

[image] [image]

Revit 2010 API
LoadCombinationArray Members
LoadCombinationArray Class Constructors Methods Properties See Also Send Feedback

The LoadCombinationArray type exposes the following members.

Constructors

Name | Description
LoadCombinationArray | Initializes a new instance of the LoadCombinationArray class

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


LoadCombinationArray Constructor

[image]

Revit 2010 API
LoadCombinationArray Constructor
LoadCombinationArray Class See Also Send Feedback
Initializes a new instance of the LoadCombinationArray class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadCombinationArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCombinationArray()

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


LoadCombinationArray Methods

[image] [image]

Revit 2010 API
LoadCombinationArray Methods
LoadCombinationArray Class See Also Send Feedback

The LoadCombinationArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


Append Method

[image]

Revit 2010 API
LoadCombinationArray..::.Append Method
LoadCombinationArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    LoadCombination item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As LoadCombination _
)
Visual C++
public:
virtual void Append(
    LoadCombination^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.LoadCombination

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


Clear Method

[image]

Revit 2010 API
LoadCombinationArray..::.Clear Method
LoadCombinationArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

[image]

Revit 2010 API
LoadCombinationArray..::.ForwardIterator Method
LoadCombinationArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual LoadCombinationArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LoadCombinationArrayIterator
Visual C++
public:
virtual LoadCombinationArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

[image]

Revit 2010 API
LoadCombinationArray..::.GetEnumerator Method
LoadCombinationArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


Insert Method

[image]

Revit 2010 API
LoadCombinationArray..::.Insert Method
LoadCombinationArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    LoadCombination item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As LoadCombination, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    LoadCombination^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Elements..::.LoadCombination
index
Type: System..::.Int32

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

[image]

Revit 2010 API
LoadCombinationArray..::.ReverseIterator Method
LoadCombinationArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual LoadCombinationArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LoadCombinationArrayIterator
Visual C++
public:
virtual LoadCombinationArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


LoadCombinationArray Properties

[image] [image]

Revit 2010 API
LoadCombinationArray Properties
LoadCombinationArray Class See Also Send Feedback

The LoadCombinationArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


IsEmpty Property

[image]

Revit 2010 API
LoadCombinationArray..::.IsEmpty Property
LoadCombinationArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


Item Property

[image]

Revit 2010 API
LoadCombinationArray..::.Item Property
LoadCombinationArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual LoadCombination Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As LoadCombination
Visual C++
public:
virtual property LoadCombination^ Item[int index] {
    LoadCombination^ get (int index);
    void set (int index, LoadCombination^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


Size Property

[image]

Revit 2010 API
LoadCombinationArray..::.Size Property
LoadCombinationArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LoadCombinationArray Class
Autodesk.Revit.Elements Namespace


LoadCombinationArrayIterator Class

[image]

Revit 2010 API
LoadCombinationArrayIterator Class
Members See Also Send Feedback
An iterator to a array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class LoadCombinationArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class LoadCombinationArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LoadCombinationArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.LoadCombinationArrayIterator

See Also

LoadCombinationArrayIterator Members
Autodesk.Revit.Elements Namespace


LoadCombinationArrayIterator Members

[image] [image]

Revit 2010 API
LoadCombinationArrayIterator Members
LoadCombinationArrayIterator Class Constructors Methods Properties See Also Send Feedback

The LoadCombinationArrayIterator type exposes the following members.

Constructors

Name | Description
LoadCombinationArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.Elements Namespace


LoadCombinationArrayIterator Constructor

[image]

Revit 2010 API
LoadCombinationArrayIterator Constructor
LoadCombinationArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadCombinationArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCombinationArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.Elements Namespace


LoadCombinationArrayIterator Methods

[image] [image]

Revit 2010 API
LoadCombinationArrayIterator Methods
LoadCombinationArrayIterator Class See Also Send Feedback

The LoadCombinationArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

[image]

Revit 2010 API
LoadCombinationArrayIterator..::.MoveNext Method
LoadCombinationArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

[image]

Revit 2010 API
LoadCombinationArrayIterator..::.Reset Method
LoadCombinationArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.Elements Namespace


LoadCombinationArrayIterator Properties

[image] [image]

Revit 2010 API
LoadCombinationArrayIterator Properties
LoadCombinationArrayIterator Class See Also Send Feedback

The LoadCombinationArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.Elements Namespace


Current Property

[image]

Revit 2010 API
LoadCombinationArrayIterator..::.Current Property
LoadCombinationArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.Elements Namespace


LoadNature Class

[image]

Revit 2010 API
LoadNature Class
Members See Also Send Feedback
A structural Load nature object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LoadNature : Element
Visual Basic (Declaration)
Public Class LoadNature _
    Inherits Element
Visual C++
public ref class LoadNature : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.LoadNature

See Also

LoadNature Members
Autodesk.Revit.Elements Namespace


LoadNature Members

[image] [image]

Revit 2010 API
LoadNature Members
LoadNature Class Constructors Methods Properties See Also Send Feedback

The LoadNature type exposes the following members.

Constructors

Name | Description
LoadNature | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LoadNature Class
Autodesk.Revit.Elements Namespace


LoadNature Constructor

[image]

Revit 2010 API
LoadNature Constructor
LoadNature Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadNature()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadNature()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadNature Class
Autodesk.Revit.Elements Namespace


LoadNature Methods

[image] [image]

Revit 2010 API
LoadNature Methods
LoadNature Class See Also Send Feedback

The LoadNature type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadNature Class
Autodesk.Revit.Elements Namespace


LoadNature Properties

[image] [image]

Revit 2010 API
LoadNature Properties
LoadNature Class See Also Send Feedback

The LoadNature type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LoadNature Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
LoadNature..::.Parameter Property
LoadNature Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LoadNature Class
LoadNature Members
Autodesk.Revit.Elements Namespace


LoadUsage Class

[image]

Revit 2010 API
LoadUsage Class
Members See Also Send Feedback
This object represents a load case within the project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LoadUsage : Element
Visual Basic (Declaration)
Public Class LoadUsage _
    Inherits Element
Visual C++
public ref class LoadUsage : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.LoadUsage

See Also

LoadUsage Members
Autodesk.Revit.Elements Namespace


LoadUsage Members

[image] [image]

Revit 2010 API
LoadUsage Members
LoadUsage Class Constructors Methods Properties See Also Send Feedback

The LoadUsage type exposes the following members.

Constructors

Name | Description
LoadUsage | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LoadUsage Class
Autodesk.Revit.Elements Namespace


LoadUsage Constructor

[image]

Revit 2010 API
LoadUsage Constructor
LoadUsage Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadUsage()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadUsage()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadUsage Class
Autodesk.Revit.Elements Namespace


LoadUsage Methods

[image] [image]

Revit 2010 API
LoadUsage Methods
LoadUsage Class See Also Send Feedback

The LoadUsage type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadUsage Class
Autodesk.Revit.Elements Namespace


LoadUsage Properties

[image] [image]

Revit 2010 API
LoadUsage Properties
LoadUsage Class See Also Send Feedback

The LoadUsage type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LoadUsage Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
LoadUsage..::.Parameter Property
LoadUsage Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LoadUsage Class
LoadUsage Members
Autodesk.Revit.Elements Namespace


LoadUsageArray Class

[image]

Revit 2010 API
LoadUsageArray Class
Members See Also Send Feedback
An array that contains load usage objects.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LoadUsageArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class LoadUsageArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LoadUsageArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.LoadUsageArray

See Also

LoadUsageArray Members
Autodesk.Revit.Elements Namespace


LoadUsageArray Members

[image] [image]

Revit 2010 API
LoadUsageArray Members
LoadUsageArray Class Constructors Methods Properties See Also Send Feedback

The LoadUsageArray type exposes the following members.

Constructors

Name | Description
LoadUsageArray | Initializes a new instance of the LoadUsageArray class

Methods

Name | Description
Append | Add the load usage to the end of the array.
Clear | Removes every load usage from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified load usage into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an load usage at a specified index within the array.
Size | Returns the number of load usages that are in the array.

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


LoadUsageArray Constructor

[image]

Revit 2010 API
LoadUsageArray Constructor
LoadUsageArray Class See Also Send Feedback
Initializes a new instance of the LoadUsageArray class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadUsageArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadUsageArray()

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


LoadUsageArray Methods

[image] [image]

Revit 2010 API
LoadUsageArray Methods
LoadUsageArray Class See Also Send Feedback

The LoadUsageArray type exposes the following members.

Methods

Name | Description
Append | Add the load usage to the end of the array.
Clear | Removes every load usage from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified load usage into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


Append Method

[image]

Revit 2010 API
LoadUsageArray..::.Append Method
LoadUsageArray Class See Also Send Feedback
Add the load usage to the end of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    LoadUsage item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As LoadUsage _
)
Visual C++
public:
virtual void Append(
    LoadUsage^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.LoadUsage
The load usage to be added.

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


Clear Method

[image]

Revit 2010 API
LoadUsageArray..::.Clear Method
LoadUsageArray Class See Also Send Feedback
Removes every load usage from the array, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

[image]

Revit 2010 API
LoadUsageArray..::.ForwardIterator Method
LoadUsageArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual LoadUsageArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LoadUsageArrayIterator
Visual C++
public:
virtual LoadUsageArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

[image]

Revit 2010 API
LoadUsageArray..::.GetEnumerator Method
LoadUsageArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


Insert Method

[image]

Revit 2010 API
LoadUsageArray..::.Insert Method
LoadUsageArray Class See Also Send Feedback
Insert the specified load usage into the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    LoadUsage item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As LoadUsage, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    LoadUsage^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Elements..::.LoadUsage
The load usage to be inserted into the array.
index
Type: System..::.Int32
The load usage will be inserted before this index.

Return Value

Returns whether the load usage was inserted into the array.

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

[image]

Revit 2010 API
LoadUsageArray..::.ReverseIterator Method
LoadUsageArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual LoadUsageArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LoadUsageArrayIterator
Visual C++
public:
virtual LoadUsageArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


LoadUsageArray Properties

[image] [image]

Revit 2010 API
LoadUsageArray Properties
LoadUsageArray Class See Also Send Feedback

The LoadUsageArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an load usage at a specified index within the array.
Size | Returns the number of load usages that are in the array.

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


IsEmpty Property

[image]

Revit 2010 API
LoadUsageArray..::.IsEmpty Property
LoadUsageArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


Item Property

[image]

Revit 2010 API
LoadUsageArray..::.Item Property
LoadUsageArray Class See Also Send Feedback
Gets or sets an load usage at a specified index within the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual LoadUsage Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As LoadUsage
Visual C++
public:
virtual property LoadUsage^ Item[int index] {
    LoadUsage^ get (int index);
    void set (int index, LoadUsage^ value);
}

Parameters

index
Type: System..::.Int32
The index of the load usage to be set or retrieved.

Return Value

Returns the load usage at the specified index.

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


Size Property

[image]

Revit 2010 API
LoadUsageArray..::.Size Property
LoadUsageArray Class See Also Send Feedback
Returns the number of load usages that are in the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LoadUsageArray Class
Autodesk.Revit.Elements Namespace


LoadUsageArrayIterator Class

[image]

Revit 2010 API
LoadUsageArrayIterator Class
Members See Also Send Feedback
An iterator to an load usage array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class LoadUsageArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class LoadUsageArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LoadUsageArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.LoadUsageArrayIterator

See Also

LoadUsageArrayIterator Members
Autodesk.Revit.Elements Namespace


LoadUsageArrayIterator Members

[image] [image]

Revit 2010 API
LoadUsageArrayIterator Members
LoadUsageArrayIterator Class Constructors Methods Properties See Also Send Feedback

The LoadUsageArrayIterator type exposes the following members.

Constructors

Name | Description
LoadUsageArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.Elements Namespace


LoadUsageArrayIterator Constructor

[image]

Revit 2010 API
LoadUsageArrayIterator Constructor
LoadUsageArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadUsageArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadUsageArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.Elements Namespace


LoadUsageArrayIterator Methods

[image] [image]

Revit 2010 API
LoadUsageArrayIterator Methods
LoadUsageArrayIterator Class See Also Send Feedback

The LoadUsageArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

[image]

Revit 2010 API
LoadUsageArrayIterator..::.MoveNext Method
LoadUsageArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

[image]

Revit 2010 API
LoadUsageArrayIterator..::.Reset Method
LoadUsageArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.Elements Namespace


LoadUsageArrayIterator Properties

[image] [image]

Revit 2010 API
LoadUsageArrayIterator Properties
LoadUsageArrayIterator Class See Also Send Feedback

The LoadUsageArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.Elements Namespace


Current Property

[image]

Revit 2010 API
LoadUsageArrayIterator..::.Current Property
LoadUsageArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.Elements Namespace


Material Class

[image]

Revit 2010 API
Material Class
Members Example See Also Send Feedback
Represents a material element within an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class Material : Element
Visual Basic (Declaration)
Public MustInherit Class Material _
    Inherits Element
Visual C++
public ref class Material abstract : public Element

Remarks

This is the abstract parent class for concrete material subclasses. Currently, the supported materials are wood, steel, generic, concrete and other.

Examples

CopyC#
private void GetMaterialInformation(Material material)
{
    StringBuilder message = new StringBuilder("Material : " + material.Name);
    //color of the material
    message.Append(string.Format("\nColor: Red[{0}]; Green[{1}]; Blue[{2}]",
                    material.Color.Red, material.Color.Green, material.Color.Blue));

    //cut pattern and pattern color of the material
    if (null != material.CutPattern)
    {
        message.Append("\nCut Pattern: " + material.CutPattern.Name);
        message.Append(string.Format("\nCut Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                        material.CutPatternColor.Red, material.CutPatternColor.Green, material.CutPatternColor.Blue));
    }

    //surface pattern and pattern color of the material
    if (null != material.SurfacePattern)
    {
        message.Append("\nSurface Pattern: " + material.SurfacePattern.Name);
        message.Append(string.Format("\nSurface Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                        material.SurfacePatternColor.Red, material.SurfacePatternColor.Green, material.SurfacePatternColor.Blue));
    }

    //some shading property of the material
    bool glow = material.Glow;
    message.Append("\nMaterial can glow: " + glow);
    int shininess = material.Shininess;
    message.Append("\nShininess: " + shininess);
    int smoothness = material.Smoothness;
    message.Append("\nSmoothness: " + smoothness);
    int transparency = material.Transparency;
    message.Append("\nTransparency: " + transparency);

    MessageBox.Show(message.ToString(), "Revit");
}
CopyVB.NET
Private Sub GetMaterialInformation(ByVal material As Autodesk.Revit.Elements.Material)
    Dim message As New StringBuilder("Material : " & material.Name)
    'color of the material
    message.Append(String.Format(vbLf & "Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.Color.Red, material.Color.Green, material.Color.Blue))

    'cut pattern and pattern color of the material
    If material.CutPattern IsNot Nothing Then
        message.Append(vbLf & "Cut Pattern: " & material.CutPattern.Name)
        message.Append(String.Format(vbLf & "Cut Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.CutPatternColor.Red, material.CutPatternColor.Green, material.CutPatternColor.Blue))
    End If

    'surface pattern and pattern color of the material
    If material.SurfacePattern IsNot Nothing Then
        message.Append(vbLf & "Surface Pattern: " & material.SurfacePattern.Name)
        message.Append(String.Format(vbLf & "Surface Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.SurfacePatternColor.Red, material.SurfacePatternColor.Green, material.SurfacePatternColor.Blue))
    End If

    'some shading property of the material
    Dim glow As Boolean = material.Glow
    message.Append(vbLf & "Material can glow: " & glow)
    Dim shininess As Integer = material.Shininess
    message.Append(vbLf & "Shininess: " & shininess)
    Dim smoothness As Integer = material.Smoothness
    message.Append(vbLf & "Smoothness: " & smoothness)
    Dim transparency As Integer = material.Transparency
    message.Append(vbLf & "Transparency: " & transparency)

    MessageBox.Show(message.ToString(), "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Material
Autodesk.Revit.Elements..::.MaterialConcrete
Autodesk.Revit.Elements..::.MaterialGeneric
Autodesk.Revit.Elements..::.MaterialOther
Autodesk.Revit.Elements..::.MaterialSteel
Autodesk.Revit.Elements..::.MaterialWood

See Also

Material Members
Autodesk.Revit.Elements Namespace


Material Members

[image] [image]

Revit 2010 API
Material Members
Material Class Constructors Methods Properties See Also Send Feedback

The Material type exposes the following members.

Constructors

Name | Description
Material | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicates the material.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material.
CutPattern | The cut pattern of the material.
CutPatternColor | The cut pattern color of the material.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RenderAppearance | The rendering appearance property of the material.
Shininess | The shininess of the material.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material.
SurfacePattern | The surface pattern of the material.
SurfacePatternColor | The surface pattern color of the material.
Transparency | The transparency of the material.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Material Class
Autodesk.Revit.Elements Namespace


Material Constructor

[image]

Revit 2010 API
Material Constructor
Material Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Material()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Material()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Material Class
Autodesk.Revit.Elements Namespace


Material Methods

[image] [image]

Revit 2010 API
Material Methods
Material Class See Also Send Feedback

The Material type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicates the material.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Material Class
Autodesk.Revit.Elements Namespace


Duplicate Method

[image]

Revit 2010 API
Material..::.Duplicate Method
Material Class Example See Also Send Feedback
Duplicates the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract Material Duplicate(
    string name
)
Visual Basic (Declaration)
Public MustOverride Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate(
    String^ name
) abstract

Parameters

name
Type: System..::.String
Name of the new material.

Return Value

The new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, a null pointer will be returned.

Examples

CopyC#
private bool DuplicateMaterial(Material material)
{
    bool duplicated = false;
    //try to duplicate a new instance of Material class using duplicate method
    //make sure the name of new material is unique in MaterailSet
    string newName = "new" + material.Name;
    Material myMaterial = material.Duplicate(newName);
    if (null == myMaterial)
    {
        MessageBox.Show("Failed to duplicate a material!");
    }
    else
    {
        duplicated = true;
    }

    return duplicated;
}
CopyVB.NET
Private Function DuplicateMaterial(ByVal material As Autodesk.Revit.Elements.Material) As Boolean
    Dim duplicated As Boolean = False
    'try to duplicate a new instance of Material class using duplicate method
    'make sure the name of new material is unique in MaterailSet
    Dim newName As String = "new" & material.Name
    Dim myMaterial As Autodesk.Revit.Elements.Material = material.Duplicate(newName)
    If myMaterial Is Nothing Then
        MessageBox.Show("Failed to duplicate a material!")
    Else
        duplicated = True
    End If

    Return duplicated
End Function

See Also

Material Class
Autodesk.Revit.Elements Namespace


Material Properties

[image] [image]

Revit 2010 API
Material Properties
Material Class See Also Send Feedback

The Material type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material.
CutPattern | The cut pattern of the material.
CutPatternColor | The cut pattern color of the material.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RenderAppearance | The rendering appearance property of the material.
Shininess | The shininess of the material.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material.
SurfacePattern | The surface pattern of the material.
SurfacePatternColor | The surface pattern color of the material.
Transparency | The transparency of the material.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Material Class
Autodesk.Revit.Elements Namespace


Color Property

[image]

Revit 2010 API
Material..::.Color Property
Material Class See Also Send Feedback
The color of the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}

See Also

Material Class
Autodesk.Revit.Elements Namespace


CutPattern Property

[image]

Revit 2010 API
Material..::.CutPattern Property
Material Class See Also Send Feedback
The cut pattern of the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FillPattern CutPattern { get; set; }
Visual Basic (Declaration)
Public Property CutPattern As FillPattern
Visual C++
public:
property FillPattern^ CutPattern {
    FillPattern^ get ();
    void set (FillPattern^ value);
}

Field Value

The cut pattern element, or null, if the material does not have an associated cut pattern.

See Also

Material Class
Autodesk.Revit.Elements Namespace


CutPatternColor Property

[image]

Revit 2010 API
Material..::.CutPatternColor Property
Material Class See Also Send Feedback
The cut pattern color of the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Color CutPatternColor { get; set; }
Visual Basic (Declaration)
Public Property CutPatternColor As Color
Visual C++
public:
property Color^ CutPatternColor {
    Color^ get ();
    void set (Color^ value);
}

Remarks

Changing the returned color will not change the cut pattern color for this material.

See Also

Material Class
Autodesk.Revit.Elements Namespace


Glow Property

[image]

Revit 2010 API
Material..::.Glow Property
Material Class See Also Send Feedback
Whether the material can glow.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Glow { get; set; }
Visual Basic (Declaration)
Public Property Glow As Boolean
Visual C++
public:
property bool Glow {
    bool get ();
    void set (bool value);
}

Field Value

True if the material can glow, false if it cannot.

Remarks

This value is obsolete in Autodesk Revit 2009 due to a similar change in the UI.

See Also

Material Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Material..::.Parameter Property
Material Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Material Class
Material Members
Autodesk.Revit.Elements Namespace


RenderAppearance Property

[image]

Revit 2010 API
Material..::.RenderAppearance Property
Material Class See Also Send Feedback
The rendering appearance property of the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Asset RenderAppearance { get; set; }
Visual Basic (Declaration)
Public Property RenderAppearance As Asset
Visual C++
public:
property Asset^ RenderAppearance {
    Asset^ get ();
    void set (Asset^ value);
}

Field Value

The rendering appearance property, or null, if the render library isn't available.

See Also

Material Class
Autodesk.Revit.Elements Namespace


Shininess Property

[image]

Revit 2010 API
Material..::.Shininess Property
Material Class See Also Send Feedback
The shininess of the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Shininess { get; set; }
Visual Basic (Declaration)
Public Property Shininess As Integer
Visual C++
public:
property int Shininess {
    int get ();
    void set (int value);
}

Field Value

The value ranges from 0 to 128. If trying to set the value out of the range, ArgumentException will be thrown.

See Also

Material Class
Autodesk.Revit.Elements Namespace


Smoothness Property

[image]

Revit 2010 API
Material..::.Smoothness Property
Material Class See Also Send Feedback
The smoothness of the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Smoothness { get; set; }
Visual Basic (Declaration)
Public Property Smoothness As Integer
Visual C++
public:
property int Smoothness {
    int get ();
    void set (int value);
}

Field Value

The value ranges from 0 to 100. If trying to set the value out of the range, ArgumentException will be thrown.

See Also

Material Class
Autodesk.Revit.Elements Namespace


SurfacePattern Property

[image]

Revit 2010 API
Material..::.SurfacePattern Property
Material Class See Also Send Feedback
The surface pattern of the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FillPattern SurfacePattern { get; set; }
Visual Basic (Declaration)
Public Property SurfacePattern As FillPattern
Visual C++
public:
property FillPattern^ SurfacePattern {
    FillPattern^ get ();
    void set (FillPattern^ value);
}

Field Value

The surface pattern element, or null, if the material does not have an associated surface pattern.

See Also

Material Class
Autodesk.Revit.Elements Namespace


SurfacePatternColor Property

[image]

Revit 2010 API
Material..::.SurfacePatternColor Property
Material Class See Also Send Feedback
The surface pattern color of the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Color SurfacePatternColor { get; set; }
Visual Basic (Declaration)
Public Property SurfacePatternColor As Color
Visual C++
public:
property Color^ SurfacePatternColor {
    Color^ get ();
    void set (Color^ value);
}

Remarks

Changing the returned color will not change the surface pattern color for this material

See Also

Material Class
Autodesk.Revit.Elements Namespace


Transparency Property

[image]

Revit 2010 API
Material..::.Transparency Property
Material Class See Also Send Feedback
The transparency of the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Transparency { get; set; }
Visual Basic (Declaration)
Public Property Transparency As Integer
Visual C++
public:
property int Transparency {
    int get ();
    void set (int value);
}

Field Value

The value ranges from 0 to 100. If trying to set the value out of the range, ArgumentException will be thrown.

See Also

Material Class
Autodesk.Revit.Elements Namespace


MaterialConcrete Class

[image]

Revit 2010 API
MaterialConcrete Class
Members Example See Also Send Feedback
Represents a concrete material element in an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MaterialConcrete : Material
Visual Basic (Declaration)
Public Class MaterialConcrete _
    Inherits Material
Visual C++
public ref class MaterialConcrete : public Material

Remarks

MaterialConcrete is a child class of Material.

Examples

CopyC#
private void MaterialConcreteInformation(MaterialConcrete myConcrete)
{
    StringBuilder message = new StringBuilder("Material Concrete : " + myConcrete.Name);

    //behaviour of the material
    Autodesk.Revit.Enums.MaterialBehaviourType behaviour = myConcrete.Behavior;
    message.Append("Behavior: " + behaviour);
    double compression = myConcrete.ConcreteCompression;
    message.Append("Concrete Compression: " + compression);
    double dampingRatio = myConcrete.DampingRatio;
    message.Append("Damping Ratio: " + dampingRatio);
    bool lightWeight = myConcrete.LightWeight;
    string weight = lightWeight == true ? "Yes" : "No";
    message.Append("Lightweight: " + weight);

    double poissonModulusX = myConcrete.PoissonModulusX;
    message.Append("Poisson Ratio X: " + poissonModulusX);
    double poissonModulusY = myConcrete.PoissonModulusY;
    message.Append("Poisson Ratio Y: " + poissonModulusY);
    double poissonModulusZ = myConcrete.PoissonModulusZ;
    message.Append("Poisson Ratio Z: " + poissonModulusZ);

    double shearModulusX = myConcrete.ShearModulusX;
    message.Append("Shear modulus X: " + shearModulusX);
    double shearModulusY = myConcrete.ShearModulusY;
    message.Append("Shear modulus Y: " + shearModulusY);
    double shearModulusZ = myConcrete.ShearModulusZ;
    message.Append("Shear modulus Z: " + shearModulusZ);
    double shearStrengthReduction = myConcrete.ShearStrengthReduction;
    message.Append("Shear strength modification: " + shearStrengthReduction);

    double thermalExpansionCoefficientX = myConcrete.ThermalExpansionCoefficientX;
    message.Append("Thermal Expansion coefficient X: " + thermalExpansionCoefficientX);
    double thermalExpansionCoefficientY = myConcrete.ThermalExpansionCoefficientY;
    message.Append("Thermal Expansion coefficient Y: " + thermalExpansionCoefficientY);
    double thermalExpansionCoefficientZ = myConcrete.ThermalExpansionCoefficientZ;
    message.Append("Thermal Expansion coefficient Z: " + thermalExpansionCoefficientZ);

    double unitWeight = myConcrete.UnitWeight;
    message.Append("Unit Weight: " + unitWeight);

    double youngModulusX = myConcrete.YoungModulusX;
    message.Append("Young modulus X: " + youngModulusX);
    double youngModulusY = myConcrete.YoungModulusY;
    message.Append("Young modulus Y: " + youngModulusY);
    double youngModulusZ = myConcrete.YoungModulusZ;
    message.Append("Young modulus Z: " + youngModulusZ);

    MessageBox.Show(message.ToString(), "Revit");
}
CopyVB.NET
Private Sub MaterialConcreteInformation(ByVal myConcrete As MaterialConcrete)
    Dim message As New StringBuilder("Material Concrete : " & myConcrete.Name)

    'behaviour of the material
    Dim behaviour As Autodesk.Revit.Enums.MaterialBehaviourType = myConcrete.Behavior
    message.Append("Behavior: " & behaviour)
    Dim compression As Double = myConcrete.ConcreteCompression
    message.Append("Concrete Compression: " & compression)
    Dim dampingRatio As Double = myConcrete.DampingRatio
    message.Append("Damping Ratio: " & dampingRatio)
    Dim lightWeight As Boolean = myConcrete.LightWeight
    Dim weight As String = If(lightWeight = True, "Yes", "No")
    message.Append("Lightweight: " & weight)

    Dim poissonModulusX As Double = myConcrete.PoissonModulusX
    message.Append("Poisson Ratio X: " & poissonModulusX)
    Dim poissonModulusY As Double = myConcrete.PoissonModulusY
    message.Append("Poisson Ratio Y: " & poissonModulusY)
    Dim poissonModulusZ As Double = myConcrete.PoissonModulusZ
    message.Append("Poisson Ratio Z: " & poissonModulusZ)

    Dim shearModulusX As Double = myConcrete.ShearModulusX
    message.Append("Shear modulus X: " & shearModulusX)
    Dim shearModulusY As Double = myConcrete.ShearModulusY
    message.Append("Shear modulus Y: " & shearModulusY)
    Dim shearModulusZ As Double = myConcrete.ShearModulusZ
    message.Append("Shear modulus Z: " & shearModulusZ)
    Dim shearStrengthReduction As Double = myConcrete.ShearStrengthReduction
    message.Append("Shear strength modification: " & shearStrengthReduction)

    Dim thermalExpansionCoefficientX As Double = myConcrete.ThermalExpansionCoefficientX
    message.Append("Thermal Expansion coefficient X: " & thermalExpansionCoefficientX)
    Dim thermalExpansionCoefficientY As Double = myConcrete.ThermalExpansionCoefficientY
    message.Append("Thermal Expansion coefficient Y: " & thermalExpansionCoefficientY)
    Dim thermalExpansionCoefficientZ As Double = myConcrete.ThermalExpansionCoefficientZ
    message.Append("Thermal Expansion coefficient Z: " & thermalExpansionCoefficientZ)

    Dim unitWeight As Double = myConcrete.UnitWeight
    message.Append("Unit Weight: " & unitWeight)

    Dim youngModulusX As Double = myConcrete.YoungModulusX
    message.Append("Young modulus X: " & youngModulusX)
    Dim youngModulusY As Double = myConcrete.YoungModulusY
    message.Append("Young modulus Y: " & youngModulusY)
    Dim youngModulusZ As Double = myConcrete.YoungModulusZ
    message.Append("Young modulus Z: " & youngModulusZ)

    MessageBox.Show(message.ToString(), "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Material
Autodesk.Revit.Elements..::.MaterialConcrete

See Also

MaterialConcrete Members
Autodesk.Revit.Elements Namespace


MaterialConcrete Members

[image] [image]

Revit 2010 API
MaterialConcrete Members
MaterialConcrete Class Constructors Methods Properties See Also Send Feedback

The MaterialConcrete type exposes the following members.

Constructors

Name | Description
MaterialConcrete | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this concrete material element. (Overrides Material..::.Duplicate(String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Behavior | Get or set the material behavior type of the concrete material.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
ConcreteCompression | Get or set the concrete compression of the concrete material.
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DampingRatio | Get or set the damping ratio of the concrete material.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LightWeight | Get or set whether the concrete material is lightweight.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PoissonModulusX | Get or set the x component of the Poisson modulus of the concrete material.
PoissonModulusY | Get or set the y component of the Poisson modulus of the concrete material.
PoissonModulusZ | Get or set the z component of the Poisson modulus of the concrete material.
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
ShearModulusX | Get or set the x component of the shear modulus of the concrete material.
ShearModulusY | Get or set the y component of the shear modulus of the concrete material.
ShearModulusZ | Get or set the z component of the shear modulus of the concrete material.
ShearStrengthReduction | Get or set the shear strength reduction of the concrete material.
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the concrete material.
ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the concrete material.
ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the concrete material.
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UnitWeight | Get or set the unit weight of the concrete material.
YoungModulusX | Get or set the x component of the Young modulus of the concrete material.
YoungModulusY | Get or set the y component of the Young modulus of the concrete material.
YoungModulusZ | Get or set the z component of the Young modulus of the concrete material.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


MaterialConcrete Constructor

[image]

Revit 2010 API
MaterialConcrete Constructor
MaterialConcrete Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialConcrete()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MaterialConcrete()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


MaterialConcrete Methods

[image] [image]

Revit 2010 API
MaterialConcrete Methods
MaterialConcrete Class See Also Send Feedback

The MaterialConcrete type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this concrete material element. (Overrides Material..::.Duplicate(String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


Duplicate Method

[image]

Revit 2010 API
MaterialConcrete..::.Duplicate Method
MaterialConcrete Class See Also Send Feedback
Duplicate this concrete material element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override Material Duplicate(
    string name
)
Visual Basic (Declaration)
Public Overrides Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate(
    String^ name
) override

Parameters

name
Type: System..::.String
Name of the new material.

Return Value

Pointer to the new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, null pointer will be returned.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


MaterialConcrete Properties

[image] [image]

Revit 2010 API
MaterialConcrete Properties
MaterialConcrete Class See Also Send Feedback

The MaterialConcrete type exposes the following members.

Properties

Name | Description
Behavior | Get or set the material behavior type of the concrete material.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
ConcreteCompression | Get or set the concrete compression of the concrete material.
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DampingRatio | Get or set the damping ratio of the concrete material.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LightWeight | Get or set whether the concrete material is lightweight.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PoissonModulusX | Get or set the x component of the Poisson modulus of the concrete material.
PoissonModulusY | Get or set the y component of the Poisson modulus of the concrete material.
PoissonModulusZ | Get or set the z component of the Poisson modulus of the concrete material.
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
ShearModulusX | Get or set the x component of the shear modulus of the concrete material.
ShearModulusY | Get or set the y component of the shear modulus of the concrete material.
ShearModulusZ | Get or set the z component of the shear modulus of the concrete material.
ShearStrengthReduction | Get or set the shear strength reduction of the concrete material.
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the concrete material.
ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the concrete material.
ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the concrete material.
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UnitWeight | Get or set the unit weight of the concrete material.
YoungModulusX | Get or set the x component of the Young modulus of the concrete material.
YoungModulusY | Get or set the y component of the Young modulus of the concrete material.
YoungModulusZ | Get or set the z component of the Young modulus of the concrete material.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


Behavior Property

[image]

Revit 2010 API
MaterialConcrete..::.Behavior Property
MaterialConcrete Class See Also Send Feedback
Get or set the material behavior type of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialBehaviourType Behavior { get; set; }
Visual Basic (Declaration)
Public Property Behavior As MaterialBehaviourType
Visual C++
public:
property MaterialBehaviourType Behavior {
    MaterialBehaviourType get ();
    void set (MaterialBehaviourType value);
}

Remarks

ArgumentException will be thrown if trying to set the behavior to Undefined. If the behavior is set to Isotropic, then the y and z components of Young modulus, Poisson modulus, shear modulus and thermal expansion coefficient will be changed to the value the same as their x components.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


ConcreteCompression Property

[image]

Revit 2010 API
MaterialConcrete..::.ConcreteCompression Property
MaterialConcrete Class See Also Send Feedback
Get or set the concrete compression of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ConcreteCompression { get; set; }
Visual Basic (Declaration)
Public Property ConcreteCompression As Double
Visual C++
public:
property double ConcreteCompression {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)).

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when trying to set the concrete compression to an invalid value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


DampingRatio Property

[image]

Revit 2010 API
MaterialConcrete..::.DampingRatio Property
MaterialConcrete Class See Also Send Feedback
Get or set the damping ratio of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double DampingRatio { get; set; }
Visual Basic (Declaration)
Public Property DampingRatio As Double
Visual C++
public:
property double DampingRatio {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the damping ratio to an invalid value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


LightWeight Property

[image]

Revit 2010 API
MaterialConcrete..::.LightWeight Property
MaterialConcrete Class See Also Send Feedback
Get or set whether the concrete material is lightweight.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool LightWeight { get; set; }
Visual Basic (Declaration)
Public Property LightWeight As Boolean
Visual C++
public:
property bool LightWeight {
    bool get ();
    void set (bool value);
}

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
MaterialConcrete..::.Parameter Property
MaterialConcrete Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MaterialConcrete Class
MaterialConcrete Members
Autodesk.Revit.Elements Namespace


PoissonModulusX Property

[image]

Revit 2010 API
MaterialConcrete..::.PoissonModulusX Property
MaterialConcrete Class See Also Send Feedback
Get or set the x component of the Poisson modulus of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double PoissonModulusX { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulusX As Double
Visual C++
public:
property double PoissonModulusX {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the x component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Poisson modulus will be changed to the value the same as the specified x component.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


PoissonModulusY Property

[image]

Revit 2010 API
MaterialConcrete..::.PoissonModulusY Property
MaterialConcrete Class See Also Send Feedback
Get or set the y component of the Poisson modulus of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double PoissonModulusY { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulusY As Double
Visual C++
public:
property double PoissonModulusY {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the y component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


PoissonModulusZ Property

[image]

Revit 2010 API
MaterialConcrete..::.PoissonModulusZ Property
MaterialConcrete Class See Also Send Feedback
Get or set the z component of the Poisson modulus of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double PoissonModulusZ { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulusZ As Double
Visual C++
public:
property double PoissonModulusZ {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the z component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


ShearModulusX Property

[image]

Revit 2010 API
MaterialConcrete..::.ShearModulusX Property
MaterialConcrete Class See Also Send Feedback
Get or set the x component of the shear modulus of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ShearModulusX { get; set; }
Visual Basic (Declaration)
Public Property ShearModulusX As Double
Visual C++
public:
property double ShearModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the shear modulus to an invalid value. If the behavior is Isotropic, then the y and z components of shear modulus will be changed to the value the same as the specified x component.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


ShearModulusY Property

[image]

Revit 2010 API
MaterialConcrete..::.ShearModulusY Property
MaterialConcrete Class See Also Send Feedback
Get or set the y component of the shear modulus of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ShearModulusY { get; set; }
Visual Basic (Declaration)
Public Property ShearModulusY As Double
Visual C++
public:
property double ShearModulusY {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the y component of the shear modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


ShearModulusZ Property

[image]

Revit 2010 API
MaterialConcrete..::.ShearModulusZ Property
MaterialConcrete Class See Also Send Feedback
Get or set the z component of the shear modulus of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ShearModulusZ { get; set; }
Visual Basic (Declaration)
Public Property ShearModulusZ As Double
Visual C++
public:
property double ShearModulusZ {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the z component of the shear modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


ShearStrengthReduction Property

[image]

Revit 2010 API
MaterialConcrete..::.ShearStrengthReduction Property
MaterialConcrete Class See Also Send Feedback
Get or set the shear strength reduction of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ShearStrengthReduction { get; set; }
Visual Basic (Declaration)
Public Property ShearStrengthReduction As Double
Visual C++
public:
property double ShearStrengthReduction {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the shear strength reduction to an invalid value. InvalidOperationException will be thrown if lightweight is false

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


ThermalExpansionCoefficientX Property

[image]

Revit 2010 API
MaterialConcrete..::.ThermalExpansionCoefficientX Property
MaterialConcrete Class See Also Send Feedback
Get or set the x component of the thermal expansion coefficient of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientX { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientX As Double
Visual C++
public:
property double ThermalExpansionCoefficientX {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the x component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then the y and z components of thermal expansion coefficient will be changed to the value the same as the specified x component.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


ThermalExpansionCoefficientY Property

[image]

Revit 2010 API
MaterialConcrete..::.ThermalExpansionCoefficientY Property
MaterialConcrete Class See Also Send Feedback
Get or set the y component of the thermal expansion coefficient of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientY { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientY As Double
Visual C++
public:
property double ThermalExpansionCoefficientY {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the y component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


ThermalExpansionCoefficientZ Property

[image]

Revit 2010 API
MaterialConcrete..::.ThermalExpansionCoefficientZ Property
MaterialConcrete Class See Also Send Feedback
Get or set the z component of the thermal expansion coefficient of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientZ { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientZ As Double
Visual C++
public:
property double ThermalExpansionCoefficientZ {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the z component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


UnitWeight Property

[image]

Revit 2010 API
MaterialConcrete..::.UnitWeight Property
MaterialConcrete Class See Also Send Feedback
Get or set the unit weight of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double UnitWeight { get; set; }
Visual Basic (Declaration)
Public Property UnitWeight As Double
Visual C++
public:
property double UnitWeight {
    double get ();
    void set (double value);
}

Remarks

The value is in newtons per square foot meter (N/(ft²m)). ArgumentException will be thrown if trying to set the unit weight to an invalid value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


YoungModulusX Property

[image]

Revit 2010 API
MaterialConcrete..::.YoungModulusX Property
MaterialConcrete Class See Also Send Feedback
Get or set the x component of the Young modulus of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double YoungModulusX { get; set; }
Visual Basic (Declaration)
Public Property YoungModulusX As Double
Visual C++
public:
property double YoungModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the Young modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Young modulus will be changed to the value the same as the specified x component.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


YoungModulusY Property

[image]

Revit 2010 API
MaterialConcrete..::.YoungModulusY Property
MaterialConcrete Class See Also Send Feedback
Get or set the y component of the Young modulus of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double YoungModulusY { get; set; }
Visual Basic (Declaration)
Public Property YoungModulusY As Double
Visual C++
public:
property double YoungModulusY {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the y component of the Young modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


YoungModulusZ Property

[image]

Revit 2010 API
MaterialConcrete..::.YoungModulusZ Property
MaterialConcrete Class See Also Send Feedback
Get or set the z component of the Young modulus of the concrete material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double YoungModulusZ { get; set; }
Visual Basic (Declaration)
Public Property YoungModulusZ As Double
Visual C++
public:
property double YoungModulusZ {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the z component of the Young modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class
Autodesk.Revit.Elements Namespace


MaterialGeneric Class

[image]

Revit 2010 API
MaterialGeneric Class
Members Example See Also Send Feedback
Represents a generic material element in an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MaterialGeneric : Material
Visual Basic (Declaration)
Public Class MaterialGeneric _
    Inherits Material
Visual C++
public ref class MaterialGeneric : public Material

Remarks

MaterialGeneric is a child class of Material.

Examples

CopyC#
private void MaterialGenericInformation(MaterialGeneric myGeneric)
{
    StringBuilder message = new StringBuilder("Material Generic : " + myGeneric.Name);

    //behaviour of the material
    Autodesk.Revit.Enums.MaterialBehaviourType behaviour = myGeneric.Behavior;
    message.Append("Behavior: " + behaviour);
    double dampingRatio = myGeneric.DampingRatio;
    message.Append("Damping Ratio: " + dampingRatio);
    double minimumYieldStress = myGeneric.MinimumYieldStress;
    message.Append("Minimum yield stress: " + minimumYieldStress);

    double poissonModulusX = myGeneric.PoissonModulusX;
    message.Append("Poisson Ratio X: " + poissonModulusX);
    double poissonModulusY = myGeneric.PoissonModulusY;
    message.Append("Poisson Ratio Y: " + poissonModulusY);
    double poissonModulusZ = myGeneric.PoissonModulusZ;
    message.Append("Poisson Ratio Z: " + poissonModulusZ);

    double reductionFactor = myGeneric.ReductionFactor;
    message.Append("Reduction factor for shear: " + reductionFactor);

    double shearModulusX = myGeneric.ShearModulusX;
    message.Append("Shear modulus X: " + shearModulusX);
    double shearModulusY = myGeneric.ShearModulusY;
    message.Append("Shear modulus Y: " + shearModulusY);
    double shearModulusZ = myGeneric.ShearModulusZ;
    message.Append("Shear modulus Z: " + shearModulusZ);

    double thermalExpansionCoefficientX = myGeneric.ThermalExpansionCoefficientX;
    message.Append("Thermal Expansion coefficient X: " + thermalExpansionCoefficientX);
    double thermalExpansionCoefficientY = myGeneric.ThermalExpansionCoefficientY;
    message.Append("Thermal Expansion coefficient Y: " + thermalExpansionCoefficientY);
    double thermalExpansionCoefficientZ = myGeneric.ThermalExpansionCoefficientZ;
    message.Append("Thermal Expansion coefficient Z: " + thermalExpansionCoefficientZ);

    double unitWeight = myGeneric.UnitWeight;
    message.Append("Unit Weight: " + unitWeight);

    double youngModulusX = myGeneric.YoungModulusX;
    message.Append("Young modulus X: " + youngModulusX);
    double youngModulusY = myGeneric.YoungModulusY;
    message.Append("Young modulus Y: " + youngModulusY);
    double youngModulusZ = myGeneric.YoungModulusZ;
    message.Append("Young modulus Z: " + youngModulusZ);

    MessageBox.Show(message.ToString(), "Revit");
}
CopyVB.NET
Private Sub MaterialGenericInformation(ByVal myGeneric As MaterialGeneric)
    Dim message As New StringBuilder("Material Generic : " & myGeneric.Name)

    'behaviour of the material
    Dim behaviour As Autodesk.Revit.Enums.MaterialBehaviourType = myGeneric.Behavior
    message.Append("Behavior: " & behaviour)
    Dim dampingRatio As Double = myGeneric.DampingRatio
    message.Append("Damping Ratio: " & dampingRatio)
    Dim minimumYieldStress As Double = myGeneric.MinimumYieldStress
    message.Append("Minimum yield stress: " & minimumYieldStress)

    Dim poissonModulusX As Double = myGeneric.PoissonModulusX
    message.Append("Poisson Ratio X: " & poissonModulusX)
    Dim poissonModulusY As Double = myGeneric.PoissonModulusY
    message.Append("Poisson Ratio Y: " & poissonModulusY)
    Dim poissonModulusZ As Double = myGeneric.PoissonModulusZ
    message.Append("Poisson Ratio Z: " & poissonModulusZ)

    Dim reductionFactor As Double = myGeneric.ReductionFactor
    message.Append("Reduction factor for shear: " & reductionFactor)

    Dim shearModulusX As Double = myGeneric.ShearModulusX
    message.Append("Shear modulus X: " & shearModulusX)
    Dim shearModulusY As Double = myGeneric.ShearModulusY
    message.Append("Shear modulus Y: " & shearModulusY)
    Dim shearModulusZ As Double = myGeneric.ShearModulusZ
    message.Append("Shear modulus Z: " & shearModulusZ)

    Dim thermalExpansionCoefficientX As Double = myGeneric.ThermalExpansionCoefficientX
    message.Append("Thermal Expansion coefficient X: " & thermalExpansionCoefficientX)
    Dim thermalExpansionCoefficientY As Double = myGeneric.ThermalExpansionCoefficientY
    message.Append("Thermal Expansion coefficient Y: " & thermalExpansionCoefficientY)
    Dim thermalExpansionCoefficientZ As Double = myGeneric.ThermalExpansionCoefficientZ
    message.Append("Thermal Expansion coefficient Z: " & thermalExpansionCoefficientZ)

    Dim unitWeight As Double = myGeneric.UnitWeight
    message.Append("Unit Weight: " & unitWeight)

    Dim youngModulusX As Double = myGeneric.YoungModulusX
    message.Append("Young modulus X: " & youngModulusX)
    Dim youngModulusY As Double = myGeneric.YoungModulusY
    message.Append("Young modulus Y: " & youngModulusY)
    Dim youngModulusZ As Double = myGeneric.YoungModulusZ
    message.Append("Young modulus Z: " & youngModulusZ)

    MessageBox.Show(message.ToString(), "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Material
Autodesk.Revit.Elements..::.MaterialGeneric

See Also

MaterialGeneric Members
Autodesk.Revit.Elements Namespace


MaterialGeneric Members

[image] [image]

Revit 2010 API
MaterialGeneric Members
MaterialGeneric Class Constructors Methods Properties See Also Send Feedback

The MaterialGeneric type exposes the following members.

Constructors

Name | Description
MaterialGeneric | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this generic material element. (Overrides Material..::.Duplicate(String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Behavior | Get or set the material behavior type of the generic material.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DampingRatio | Get or set the damping ratio of the generic material.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MinimumYieldStress | Get or set the minimum yield stress of the generic material.
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PoissonModulusX | Get or set the x component of the Poisson modulus of the generic material.
PoissonModulusY | Get or set the y component of the Poisson modulus of the generic material.
PoissonModulusZ | Get or set the z component of the Poisson modulus of the generic material.
ReductionFactor | Get or set the reduction factor for shear of the generic material.
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
ShearModulusX | Get or set the x component of the shear modulus of the generic material.
ShearModulusY | Get or set the y component of the shear modulus of the generic material.
ShearModulusZ | Get or set the z component of the shear modulus of the generic material.
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the generic material.
ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the generic material.
ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the generic material.
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UnitWeight | Get or set the unit weight of the generic material.
YoungModulusX | Get or set the x component of the Young modulus of the generic material.
YoungModulusY | Get or set the y component of the Young modulus of the generic material.
YoungModulusZ | Get or set the z component of the Young modulus of the generic material.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


MaterialGeneric Constructor

[image]

Revit 2010 API
MaterialGeneric Constructor
MaterialGeneric Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialGeneric()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MaterialGeneric()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


MaterialGeneric Methods

[image] [image]

Revit 2010 API
MaterialGeneric Methods
MaterialGeneric Class See Also Send Feedback

The MaterialGeneric type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this generic material element. (Overrides Material..::.Duplicate(String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


Duplicate Method

[image]

Revit 2010 API
MaterialGeneric..::.Duplicate Method
MaterialGeneric Class See Also Send Feedback
Duplicate this generic material element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override Material Duplicate(
    string name
)
Visual Basic (Declaration)
Public Overrides Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate(
    String^ name
) override

Parameters

name
Type: System..::.String
Name of the new material.

Return Value

Pointer to the new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, null pointer will be returned.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


MaterialGeneric Properties

[image] [image]

Revit 2010 API
MaterialGeneric Properties
MaterialGeneric Class See Also Send Feedback

The MaterialGeneric type exposes the following members.

Properties

Name | Description
Behavior | Get or set the material behavior type of the generic material.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DampingRatio | Get or set the damping ratio of the generic material.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MinimumYieldStress | Get or set the minimum yield stress of the generic material.
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PoissonModulusX | Get or set the x component of the Poisson modulus of the generic material.
PoissonModulusY | Get or set the y component of the Poisson modulus of the generic material.
PoissonModulusZ | Get or set the z component of the Poisson modulus of the generic material.
ReductionFactor | Get or set the reduction factor for shear of the generic material.
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
ShearModulusX | Get or set the x component of the shear modulus of the generic material.
ShearModulusY | Get or set the y component of the shear modulus of the generic material.
ShearModulusZ | Get or set the z component of the shear modulus of the generic material.
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the generic material.
ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the generic material.
ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the generic material.
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UnitWeight | Get or set the unit weight of the generic material.
YoungModulusX | Get or set the x component of the Young modulus of the generic material.
YoungModulusY | Get or set the y component of the Young modulus of the generic material.
YoungModulusZ | Get or set the z component of the Young modulus of the generic material.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


Behavior Property

[image]

Revit 2010 API
MaterialGeneric..::.Behavior Property
MaterialGeneric Class See Also Send Feedback
Get or set the material behavior type of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialBehaviourType Behavior { get; set; }
Visual Basic (Declaration)
Public Property Behavior As MaterialBehaviourType
Visual C++
public:
property MaterialBehaviourType Behavior {
    MaterialBehaviourType get ();
    void set (MaterialBehaviourType value);
}

Remarks

ArgumentException will be thrown if trying to set the behavior to Undefined. If the behavior is set to Isotropic, then the y and z components of Young modulus, Poisson modulus, shear modulus and thermal expansion coefficient will be changed to the value the same as their x components.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


DampingRatio Property

[image]

Revit 2010 API
MaterialGeneric..::.DampingRatio Property
MaterialGeneric Class See Also Send Feedback
Get or set the damping ratio of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double DampingRatio { get; set; }
Visual Basic (Declaration)
Public Property DampingRatio As Double
Visual C++
public:
property double DampingRatio {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the damping ratio to an invalid value.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


MinimumYieldStress Property

[image]

Revit 2010 API
MaterialGeneric..::.MinimumYieldStress Property
MaterialGeneric Class See Also Send Feedback
Get or set the minimum yield stress of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double MinimumYieldStress { get; set; }
Visual Basic (Declaration)
Public Property MinimumYieldStress As Double
Visual C++
public:
property double MinimumYieldStress {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the minimum yield stress to an invalid vlaue.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
MaterialGeneric..::.Parameter Property
MaterialGeneric Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MaterialGeneric Class
MaterialGeneric Members
Autodesk.Revit.Elements Namespace


PoissonModulusX Property

[image]

Revit 2010 API
MaterialGeneric..::.PoissonModulusX Property
MaterialGeneric Class See Also Send Feedback
Get or set the x component of the Poisson modulus of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double PoissonModulusX { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulusX As Double
Visual C++
public:
property double PoissonModulusX {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the x component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Poisson modulus will be changed to the value the same as the specified x component.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


PoissonModulusY Property

[image]

Revit 2010 API
MaterialGeneric..::.PoissonModulusY Property
MaterialGeneric Class See Also Send Feedback
Get or set the y component of the Poisson modulus of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double PoissonModulusY { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulusY As Double
Visual C++
public:
property double PoissonModulusY {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the y component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


PoissonModulusZ Property

[image]

Revit 2010 API
MaterialGeneric..::.PoissonModulusZ Property
MaterialGeneric Class See Also Send Feedback
Get or set the z component of the Poisson modulus of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double PoissonModulusZ { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulusZ As Double
Visual C++
public:
property double PoissonModulusZ {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the z component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


ReductionFactor Property

[image]

Revit 2010 API
MaterialGeneric..::.ReductionFactor Property
MaterialGeneric Class See Also Send Feedback
Get or set the reduction factor for shear of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ReductionFactor { get; set; }
Visual Basic (Declaration)
Public Property ReductionFactor As Double
Visual C++
public:
property double ReductionFactor {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the reduction factor for shear to an invalid vlaue.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


ShearModulusX Property

[image]

Revit 2010 API
MaterialGeneric..::.ShearModulusX Property
MaterialGeneric Class See Also Send Feedback
Get or set the x component of the shear modulus of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ShearModulusX { get; set; }
Visual Basic (Declaration)
Public Property ShearModulusX As Double
Visual C++
public:
property double ShearModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the shear modulus to an invalid value. If the behavior is Isotropic, then the y and z components of shear modulus will be changed to the value the same as the specified x component.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


ShearModulusY Property

[image]

Revit 2010 API
MaterialGeneric..::.ShearModulusY Property
MaterialGeneric Class See Also Send Feedback
Get or set the y component of the shear modulus of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ShearModulusY { get; set; }
Visual Basic (Declaration)
Public Property ShearModulusY As Double
Visual C++
public:
property double ShearModulusY {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the y component of the shear modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


ShearModulusZ Property

[image]

Revit 2010 API
MaterialGeneric..::.ShearModulusZ Property
MaterialGeneric Class See Also Send Feedback
Get or set the z component of the shear modulus of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ShearModulusZ { get; set; }
Visual Basic (Declaration)
Public Property ShearModulusZ As Double
Visual C++
public:
property double ShearModulusZ {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the z component of the shear modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


ThermalExpansionCoefficientX Property

[image]

Revit 2010 API
MaterialGeneric..::.ThermalExpansionCoefficientX Property
MaterialGeneric Class See Also Send Feedback
Get or set the x component of the thermal expansion coefficient of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientX { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientX As Double
Visual C++
public:
property double ThermalExpansionCoefficientX {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the x component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then the y and z components of thermal expansion coefficient will be changed to the value the same as the specified x component.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


ThermalExpansionCoefficientY Property

[image]

Revit 2010 API
MaterialGeneric..::.ThermalExpansionCoefficientY Property
MaterialGeneric Class See Also Send Feedback
Get or set the y component of the thermal expansion coefficient of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientY { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientY As Double
Visual C++
public:
property double ThermalExpansionCoefficientY {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the y component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


ThermalExpansionCoefficientZ Property

[image]

Revit 2010 API
MaterialGeneric..::.ThermalExpansionCoefficientZ Property
MaterialGeneric Class See Also Send Feedback
Get or set the z component of the thermal expansion coefficient of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientZ { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientZ As Double
Visual C++
public:
property double ThermalExpansionCoefficientZ {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the z component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


UnitWeight Property

[image]

Revit 2010 API
MaterialGeneric..::.UnitWeight Property
MaterialGeneric Class See Also Send Feedback
Get or set the unit weight of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double UnitWeight { get; set; }
Visual Basic (Declaration)
Public Property UnitWeight As Double
Visual C++
public:
property double UnitWeight {
    double get ();
    void set (double value);
}

Remarks

The value is in newtons per square foot meter (N/(ft²m)). ArgumentException will be thrown if trying to set the unit weight to an invalid value.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


YoungModulusX Property

[image]

Revit 2010 API
MaterialGeneric..::.YoungModulusX Property
MaterialGeneric Class See Also Send Feedback
Get or set the x component of the Young modulus of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double YoungModulusX { get; set; }
Visual Basic (Declaration)
Public Property YoungModulusX As Double
Visual C++
public:
property double YoungModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the Young modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Young modulus will be changed to the value the same as the specified x component.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


YoungModulusY Property

[image]

Revit 2010 API
MaterialGeneric..::.YoungModulusY Property
MaterialGeneric Class See Also Send Feedback
Get or set the y component of the Young modulus of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double YoungModulusY { get; set; }
Visual Basic (Declaration)
Public Property YoungModulusY As Double
Visual C++
public:
property double YoungModulusY {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the y component of the Young modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


YoungModulusZ Property

[image]

Revit 2010 API
MaterialGeneric..::.YoungModulusZ Property
MaterialGeneric Class See Also Send Feedback
Get or set the z component of the Young modulus of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double YoungModulusZ { get; set; }
Visual Basic (Declaration)
Public Property YoungModulusZ As Double
Visual C++
public:
property double YoungModulusZ {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the z component of the Young modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace


MaterialOther Class

[image]

Revit 2010 API
MaterialOther Class
Members See Also Send Feedback
Represents a material element other than concrete, generic, wood and steel in an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MaterialOther : Material
Visual Basic (Declaration)
Public Class MaterialOther _
    Inherits Material
Visual C++
public ref class MaterialOther : public Material

Remarks

MaterialOther is a child class of Material.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Material
Autodesk.Revit.Elements..::.MaterialOther

See Also

MaterialOther Members
Autodesk.Revit.Elements Namespace


MaterialOther Members

[image] [image]

Revit 2010 API
MaterialOther Members
MaterialOther Class Constructors Methods Properties See Also Send Feedback

The MaterialOther type exposes the following members.

Constructors

Name | Description
MaterialOther | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this other material element. (Overrides Material..::.Duplicate(String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

MaterialOther Class
Autodesk.Revit.Elements Namespace


MaterialOther Constructor

[image]

Revit 2010 API
MaterialOther Constructor
MaterialOther Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialOther()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MaterialOther()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MaterialOther Class
Autodesk.Revit.Elements Namespace


MaterialOther Methods

[image] [image]

Revit 2010 API
MaterialOther Methods
MaterialOther Class See Also Send Feedback

The MaterialOther type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this other material element. (Overrides Material..::.Duplicate(String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaterialOther Class
Autodesk.Revit.Elements Namespace


Duplicate Method

[image]

Revit 2010 API
MaterialOther..::.Duplicate Method
MaterialOther Class See Also Send Feedback
Duplicate this other material element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override Material Duplicate(
    string name
)
Visual Basic (Declaration)
Public Overrides Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate(
    String^ name
) override

Parameters

name
Type: System..::.String
Name of the new material.

Return Value

Pointer to the new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, null pointer will be returned.

See Also

MaterialOther Class
Autodesk.Revit.Elements Namespace


MaterialOther Properties

[image] [image]

Revit 2010 API
MaterialOther Properties
MaterialOther Class See Also Send Feedback

The MaterialOther type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

MaterialOther Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
MaterialOther..::.Parameter Property
MaterialOther Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MaterialOther Class
MaterialOther Members
Autodesk.Revit.Elements Namespace


MaterialSteel Class

[image]

Revit 2010 API
MaterialSteel Class
Members Example See Also Send Feedback
Represents a steel material element in an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MaterialSteel : Material
Visual Basic (Declaration)
Public Class MaterialSteel _
    Inherits Material
Visual C++
public ref class MaterialSteel : public Material

Remarks

MaterialSteel is a child class of Material.

Examples

CopyC#
private void MaterialSteelInformation(MaterialSteel mySteel)
{
    StringBuilder message = new StringBuilder("Material Steel : " + mySteel.Name);

    //behaviour of the material
    Autodesk.Revit.Enums.MaterialBehaviourType behaviour = mySteel.Behavior;
    message.Append("Behavior: " + behaviour);
    double dampingRatio = mySteel.DampingRatio;
    message.Append("Damping Ratio: " + dampingRatio);
    double minimumTensileStrength = mySteel.MinimumTensileStrength;
    message.Append("Minimum tensile strength: " + minimumTensileStrength);
    double minimumYieldStress = mySteel.MinimumYieldStress;
    message.Append("Minimum yield stress: " + minimumYieldStress);

    double poissonModulusX = mySteel.PoissonModulusX;
    message.Append("Poisson Ratio X: " + poissonModulusX);
    double poissonModulusY = mySteel.PoissonModulusY;
    message.Append("Poisson Ratio Y: " + poissonModulusY);
    double poissonModulusZ = mySteel.PoissonModulusZ;
    message.Append("Poisson Ratio Z: " + poissonModulusZ);

    double reductionFactor = mySteel.ReductionFactor;

    double shearModulusX = mySteel.ShearModulusX;
    message.Append("Shear modulus X: " + shearModulusX);
    double shearModulusY = mySteel.ShearModulusY;
    message.Append("Shear modulus Y: " + shearModulusY);
    double shearModulusZ = mySteel.ShearModulusZ;
    message.Append("Shear modulus Z: " + shearModulusZ);

    double thermalExpansionCoefficientX = mySteel.ThermalExpansionCoefficientX;
    message.Append("Thermal Expansion coefficient X: " + thermalExpansionCoefficientX);
    double thermalExpansionCoefficientY = mySteel.ThermalExpansionCoefficientY;
    message.Append("Thermal Expansion coefficient Y: " + thermalExpansionCoefficientY);
    double thermalExpansionCoefficientZ = mySteel.ThermalExpansionCoefficientZ;
    message.Append("Thermal Expansion coefficient Z: " + thermalExpansionCoefficientZ);

    double unitWeight = mySteel.UnitWeight;
    message.Append("Unit Weight: " + unitWeight);

    double youngModulusX = mySteel.YoungModulusX;
    message.Append("Young modulus X: " + youngModulusX);
    double youngModulusY = mySteel.YoungModulusY;
    message.Append("Young modulus Y: " + youngModulusY);
    double youngModulusZ = mySteel.YoungModulusZ;
    message.Append("Young modulus Z: " + youngModulusZ);

    MessageBox.Show(message.ToString(), "Revit");
}
CopyVB.NET
Private Sub MaterialSteelInformation(ByVal mySteel As MaterialSteel)
    Dim message As New StringBuilder("Material Steel : " & mySteel.Name)

    'behaviour of the material
    Dim behaviour As Autodesk.Revit.Enums.MaterialBehaviourType = mySteel.Behavior
    message.Append("Behavior: " & behaviour)
    Dim dampingRatio As Double = mySteel.DampingRatio
    message.Append("Damping Ratio: " & dampingRatio)
    Dim minimumTensileStrength As Double = mySteel.MinimumTensileStrength
    message.Append("Minimum tensile strength: " & minimumTensileStrength)
    Dim minimumYieldStress As Double = mySteel.MinimumYieldStress
    message.Append("Minimum yield stress: " & minimumYieldStress)

    Dim poissonModulusX As Double = mySteel.PoissonModulusX
    message.Append("Poisson Ratio X: " & poissonModulusX)
    Dim poissonModulusY As Double = mySteel.PoissonModulusY
    message.Append("Poisson Ratio Y: " & poissonModulusY)
    Dim poissonModulusZ As Double = mySteel.PoissonModulusZ
    message.Append("Poisson Ratio Z: " & poissonModulusZ)

    Dim reductionFactor As Double = mySteel.ReductionFactor

    Dim shearModulusX As Double = mySteel.ShearModulusX
    message.Append("Shear modulus X: " & shearModulusX)
    Dim shearModulusY As Double = mySteel.ShearModulusY
    message.Append("Shear modulus Y: " & shearModulusY)
    Dim shearModulusZ As Double = mySteel.ShearModulusZ
    message.Append("Shear modulus Z: " & shearModulusZ)

    Dim thermalExpansionCoefficientX As Double = mySteel.ThermalExpansionCoefficientX
    message.Append("Thermal Expansion coefficient X: " & thermalExpansionCoefficientX)
    Dim thermalExpansionCoefficientY As Double = mySteel.ThermalExpansionCoefficientY
    message.Append("Thermal Expansion coefficient Y: " & thermalExpansionCoefficientY)
    Dim thermalExpansionCoefficientZ As Double = mySteel.ThermalExpansionCoefficientZ
    message.Append("Thermal Expansion coefficient Z: " & thermalExpansionCoefficientZ)

    Dim unitWeight As Double = mySteel.UnitWeight
    message.Append("Unit Weight: " & unitWeight)

    Dim youngModulusX As Double = mySteel.YoungModulusX
    message.Append("Young modulus X: " & youngModulusX)
    Dim youngModulusY As Double = mySteel.YoungModulusY
    message.Append("Young modulus Y: " & youngModulusY)
    Dim youngModulusZ As Double = mySteel.YoungModulusZ
    message.Append("Young modulus Z: " & youngModulusZ)

    MessageBox.Show(message.ToString(), "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Material
Autodesk.Revit.Elements..::.MaterialSteel

See Also

MaterialSteel Members
Autodesk.Revit.Elements Namespace


MaterialSteel Members

[image] [image]

Revit 2010 API
MaterialSteel Members
MaterialSteel Class Constructors Methods Properties See Also Send Feedback

The MaterialSteel type exposes the following members.

Constructors

Name | Description
MaterialSteel | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this steel material element. (Overrides Material..::.Duplicate(String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Behavior | Get or set the material behavior type of the steel material.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DampingRatio | Get or set the damping ratio of the steel material.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MinimumTensileStrength | Get or set the minimum tensile strength of the steel material.
MinimumYieldStress | Get or set the minimum yield stress of the steel material.
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PoissonModulusX | Get or set the x component of the Poisson modulus of the steel material.
PoissonModulusY | Get or set the y component of the Poisson modulus of the steel material.
PoissonModulusZ | Get or set the z component of the Poisson modulus of the steel material.
ReductionFactor | Get or set the reduction factor for shear of the steel material.
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
ShearModulusX | Get or set the x component of the shear modulus of the steel material.
ShearModulusY | Get or set the y component of the shear modulus of the steel material.
ShearModulusZ | Get or set the z component of the shear modulus of the steel material.
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the steel material.
ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the steel material.
ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the steel material.
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UnitWeight | Get or set the unit weight of the steel material.
YoungModulusX | Get or set the x component of the Young modulus of the steel material.
YoungModulusY | Get or set the y component of the Young modulus of the steel material.
YoungModulusZ | Get or set the z component of the Young modulus of the steel material.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


MaterialSteel Constructor

[image]

Revit 2010 API
MaterialSteel Constructor
MaterialSteel Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialSteel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MaterialSteel()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


MaterialSteel Methods

[image] [image]

Revit 2010 API
MaterialSteel Methods
MaterialSteel Class See Also Send Feedback

The MaterialSteel type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this steel material element. (Overrides Material..::.Duplicate(String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


Duplicate Method

[image]

Revit 2010 API
MaterialSteel..::.Duplicate Method
MaterialSteel Class See Also Send Feedback
Duplicate this steel material element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override Material Duplicate(
    string name
)
Visual Basic (Declaration)
Public Overrides Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate(
    String^ name
) override

Parameters

name
Type: System..::.String
Name of the new material.

Return Value

Pointer to the new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, null pointer will be returned.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


MaterialSteel Properties

[image] [image]

Revit 2010 API
MaterialSteel Properties
MaterialSteel Class See Also Send Feedback

The MaterialSteel type exposes the following members.

Properties

Name | Description
Behavior | Get or set the material behavior type of the steel material.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DampingRatio | Get or set the damping ratio of the steel material.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MinimumTensileStrength | Get or set the minimum tensile strength of the steel material.
MinimumYieldStress | Get or set the minimum yield stress of the steel material.
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PoissonModulusX | Get or set the x component of the Poisson modulus of the steel material.
PoissonModulusY | Get or set the y component of the Poisson modulus of the steel material.
PoissonModulusZ | Get or set the z component of the Poisson modulus of the steel material.
ReductionFactor | Get or set the reduction factor for shear of the steel material.
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
ShearModulusX | Get or set the x component of the shear modulus of the steel material.
ShearModulusY | Get or set the y component of the shear modulus of the steel material.
ShearModulusZ | Get or set the z component of the shear modulus of the steel material.
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the steel material.
ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the steel material.
ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the steel material.
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UnitWeight | Get or set the unit weight of the steel material.
YoungModulusX | Get or set the x component of the Young modulus of the steel material.
YoungModulusY | Get or set the y component of the Young modulus of the steel material.
YoungModulusZ | Get or set the z component of the Young modulus of the steel material.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


Behavior Property

[image]

Revit 2010 API
MaterialSteel..::.Behavior Property
MaterialSteel Class See Also Send Feedback
Get or set the material behavior type of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialBehaviourType Behavior { get; set; }
Visual Basic (Declaration)
Public Property Behavior As MaterialBehaviourType
Visual C++
public:
property MaterialBehaviourType Behavior {
    MaterialBehaviourType get ();
    void set (MaterialBehaviourType value);
}

Remarks

ArgumentException will be thrown if trying to set the behavior to Undefined. If the behavior is set to Isotropic, then the y and z components of Young modulus, Poisson modulus, shear modulus and thermal expansion coefficient will be changed to the value the same as their x components.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


DampingRatio Property

[image]

Revit 2010 API
MaterialSteel..::.DampingRatio Property
MaterialSteel Class See Also Send Feedback
Get or set the damping ratio of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double DampingRatio { get; set; }
Visual Basic (Declaration)
Public Property DampingRatio As Double
Visual C++
public:
property double DampingRatio {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the damping ratio to an invalid value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


MinimumTensileStrength Property

[image]

Revit 2010 API
MaterialSteel..::.MinimumTensileStrength Property
MaterialSteel Class See Also Send Feedback
Get or set the minimum tensile strength of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double MinimumTensileStrength { get; set; }
Visual Basic (Declaration)
Public Property MinimumTensileStrength As Double
Visual C++
public:
property double MinimumTensileStrength {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the minimum tensile strength to an invalid value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


MinimumYieldStress Property

[image]

Revit 2010 API
MaterialSteel..::.MinimumYieldStress Property
MaterialSteel Class See Also Send Feedback
Get or set the minimum yield stress of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double MinimumYieldStress { get; set; }
Visual Basic (Declaration)
Public Property MinimumYieldStress As Double
Visual C++
public:
property double MinimumYieldStress {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the unit weight to an invalid value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
MaterialSteel..::.Parameter Property
MaterialSteel Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MaterialSteel Class
MaterialSteel Members
Autodesk.Revit.Elements Namespace


PoissonModulusX Property

[image]

Revit 2010 API
MaterialSteel..::.PoissonModulusX Property
MaterialSteel Class See Also Send Feedback
Get or set the x component of the Poisson modulus of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double PoissonModulusX { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulusX As Double
Visual C++
public:
property double PoissonModulusX {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the x component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Poisson modulus will be changed to the value the same as the specified x component.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


PoissonModulusY Property

[image]

Revit 2010 API
MaterialSteel..::.PoissonModulusY Property
MaterialSteel Class See Also Send Feedback
Get or set the y component of the Poisson modulus of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double PoissonModulusY { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulusY As Double
Visual C++
public:
property double PoissonModulusY {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the y component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


PoissonModulusZ Property

[image]

Revit 2010 API
MaterialSteel..::.PoissonModulusZ Property
MaterialSteel Class See Also Send Feedback
Get or set the z component of the Poisson modulus of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double PoissonModulusZ { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulusZ As Double
Visual C++
public:
property double PoissonModulusZ {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the z component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


ReductionFactor Property

[image]

Revit 2010 API
MaterialSteel..::.ReductionFactor Property
MaterialSteel Class See Also Send Feedback
Get or set the reduction factor for shear of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ReductionFactor { get; set; }
Visual Basic (Declaration)
Public Property ReductionFactor As Double
Visual C++
public:
property double ReductionFactor {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the reduction factor for shear to an invalid value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


ShearModulusX Property

[image]

Revit 2010 API
MaterialSteel..::.ShearModulusX Property
MaterialSteel Class See Also Send Feedback
Get or set the x component of the shear modulus of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ShearModulusX { get; set; }
Visual Basic (Declaration)
Public Property ShearModulusX As Double
Visual C++
public:
property double ShearModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the shear modulus to an invalid value. If the behavior is Isotropic, then the y and z components of shear modulus will be changed to the value the same as the specified x component.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


ShearModulusY Property

[image]

Revit 2010 API
MaterialSteel..::.ShearModulusY Property
MaterialSteel Class See Also Send Feedback
Get or set the y component of the shear modulus of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ShearModulusY { get; set; }
Visual Basic (Declaration)
Public Property ShearModulusY As Double
Visual C++
public:
property double ShearModulusY {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the y component of the shear modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


ShearModulusZ Property

[image]

Revit 2010 API
MaterialSteel..::.ShearModulusZ Property
MaterialSteel Class See Also Send Feedback
Get or set the z component of the shear modulus of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ShearModulusZ { get; set; }
Visual Basic (Declaration)
Public Property ShearModulusZ As Double
Visual C++
public:
property double ShearModulusZ {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the z component of the shear modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


ThermalExpansionCoefficientX Property

[image]

Revit 2010 API
MaterialSteel..::.ThermalExpansionCoefficientX Property
MaterialSteel Class See Also Send Feedback
Get or set the x component of the thermal expansion coefficient of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientX { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientX As Double
Visual C++
public:
property double ThermalExpansionCoefficientX {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the x component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then the y and z components of thermal expansion coefficient will be changed to the value the same as the specified x component.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


ThermalExpansionCoefficientY Property

[image]

Revit 2010 API
MaterialSteel..::.ThermalExpansionCoefficientY Property
MaterialSteel Class See Also Send Feedback
Get or set the y component of the thermal expansion coefficient of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientY { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientY As Double
Visual C++
public:
property double ThermalExpansionCoefficientY {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the y component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


ThermalExpansionCoefficientZ Property

[image]

Revit 2010 API
MaterialSteel..::.ThermalExpansionCoefficientZ Property
MaterialSteel Class See Also Send Feedback
Get or set the z component of the thermal expansion coefficient of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientZ { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientZ As Double
Visual C++
public:
property double ThermalExpansionCoefficientZ {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the z component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


UnitWeight Property

[image]

Revit 2010 API
MaterialSteel..::.UnitWeight Property
MaterialSteel Class See Also Send Feedback
Get or set the unit weight of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double UnitWeight { get; set; }
Visual Basic (Declaration)
Public Property UnitWeight As Double
Visual C++
public:
property double UnitWeight {
    double get ();
    void set (double value);
}

Remarks

The value is in newtons per square foot meter (N/(ft²m)). ArgumentException will be thrown if trying to set the unit weight to an invalid value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


YoungModulusX Property

[image]

Revit 2010 API
MaterialSteel..::.YoungModulusX Property
MaterialSteel Class See Also Send Feedback
Get or set the x component of the Young modulus of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double YoungModulusX { get; set; }
Visual Basic (Declaration)
Public Property YoungModulusX As Double
Visual C++
public:
property double YoungModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the Young modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Young modulus will be changed to the value the same as the specified x component.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


YoungModulusY Property

[image]

Revit 2010 API
MaterialSteel..::.YoungModulusY Property
MaterialSteel Class See Also Send Feedback
Get or set the y component of the Young modulus of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double YoungModulusY { get; set; }
Visual Basic (Declaration)
Public Property YoungModulusY As Double
Visual C++
public:
property double YoungModulusY {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the y component of the Young modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


YoungModulusZ Property

[image]

Revit 2010 API
MaterialSteel..::.YoungModulusZ Property
MaterialSteel Class See Also Send Feedback
Get or set the z component of the Young modulus of the steel material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double YoungModulusZ { get; set; }
Visual Basic (Declaration)
Public Property YoungModulusZ As Double
Visual C++
public:
property double YoungModulusZ {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the z component of the Young modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class
Autodesk.Revit.Elements Namespace


MaterialWood Class

[image]

Revit 2010 API
MaterialWood Class
Members Example See Also Send Feedback
Represents a wood material element in an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MaterialWood : Material
Visual Basic (Declaration)
Public Class MaterialWood _
    Inherits Material
Visual C++
public ref class MaterialWood : public Material

Remarks

MaterialWood is a child class of Material.

Examples

CopyC#
private void MaterialWoodInformation(MaterialWood myWood)
{
    StringBuilder message = new StringBuilder("Material Wood : " + myWood.Name);

    double bending = myWood.Bending;
    message.Append("Bending: " + bending);

    double compressionParallel = myWood.CompressionParallel;
    message.Append("Compression parallel to grain: " + compressionParallel);
    double compressionPerpendicular = myWood.CompressionPerpendicular;
    message.Append("Compression perpendicular to grain: " + compressionPerpendicular);
    string grade = myWood.Grade;
    message.Append("Grade: " + grade);

    double poissonModulus = myWood.PoissonModulus;
    message.Append("Poisson Ratio: " + poissonModulus);

    double shearModulus = myWood.ShearModulus;
    message.Append("Shear modulus: " + shearModulus);
    double shearParallel = myWood.ShearParallel;
    message.Append("Shear parallel to grain: " + shearParallel);
    double shearPerpendicular = myWood.ShearPerpendicular;
    message.Append("Shear perpendicular to grain: " + shearPerpendicular);

    string species = myWood.Species;
    message.Append("Species: " + species);

    double thermalExpansionCoefficient = myWood.ThermalExpansionCoefficient;
    message.Append("Thermal Expansion coefficient: " + thermalExpansionCoefficient);

    double unitWeight = myWood.UnitWeight;
    message.Append("Unit Weight: " + unitWeight);

    double youngModulus = myWood.YoungModulus;
    message.Append("Young modulus: " + youngModulus);

    MessageBox.Show(message.ToString(), "Revit");
}
CopyVB.NET
Private Sub MaterialWoodInformation(ByVal myWood As MaterialWood)
    Dim message As New StringBuilder("Material Wood : " & myWood.Name)

    Dim bending As Double = myWood.Bending
    message.Append("Bending: " & bending)

    Dim compressionParallel As Double = myWood.CompressionParallel
    message.Append("Compression parallel to grain: " & compressionParallel)
    Dim compressionPerpendicular As Double = myWood.CompressionPerpendicular
    message.Append("Compression perpendicular to grain: " & compressionPerpendicular)
    Dim grade As String = myWood.Grade
    message.Append("Grade: " & grade)

    Dim poissonModulus As Double = myWood.PoissonModulus
    message.Append("Poisson Ratio: " & poissonModulus)

    Dim shearModulus As Double = myWood.ShearModulus
    message.Append("Shear modulus: " & shearModulus)
    Dim shearParallel As Double = myWood.ShearParallel
    message.Append("Shear parallel to grain: " & shearParallel)
    Dim shearPerpendicular As Double = myWood.ShearPerpendicular
    message.Append("Shear perpendicular to grain: " & shearPerpendicular)

    Dim species As String = myWood.Species
    message.Append("Species: " & species)

    Dim thermalExpansionCoefficient As Double = myWood.ThermalExpansionCoefficient
    message.Append("Thermal Expansion coefficient: " & thermalExpansionCoefficient)

    Dim unitWeight As Double = myWood.UnitWeight
    message.Append("Unit Weight: " & unitWeight)

    Dim youngModulus As Double = myWood.YoungModulus
    message.Append("Young modulus: " & youngModulus)

    MessageBox.Show(message.ToString(), "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Material
Autodesk.Revit.Elements..::.MaterialWood

See Also

MaterialWood Members
Autodesk.Revit.Elements Namespace


MaterialWood Members

[image] [image]

Revit 2010 API
MaterialWood Members
MaterialWood Class Constructors Methods Properties See Also Send Feedback

The MaterialWood type exposes the following members.

Constructors

Name | Description
MaterialWood | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this wood material element. (Overrides Material..::.Duplicate(String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bending | Get or set the bending of the wood material.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
CompressionParallel | Get or set the compression parallel to grain of the wood material.
CompressionPerpendicular | Get or set the compression perpendicular to grain of the wood material.
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Grade | Get or set the grade of the wood material.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PoissonModulus | Get or set the Poisson modulus of the wood material.
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
ShearModulus | Get or set the shear modulus of the wood material.
ShearParallel | Get or set the shear parallel to grain of the wood material.
ShearPerpendicular | Get or set the tension perpendicular to grain of the wood material.
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
Species | Get or set the species of the wood material.
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
ThermalExpansionCoefficient | Get or set the thermal expansion coefficient of the wood material.
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UnitWeight | Get or set the unit weight of the wood material.
YoungModulus | Get or set the Young modulus of the wood material.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


MaterialWood Constructor

[image]

Revit 2010 API
MaterialWood Constructor
MaterialWood Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialWood()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MaterialWood()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


MaterialWood Methods

[image] [image]

Revit 2010 API
MaterialWood Methods
MaterialWood Class See Also Send Feedback

The MaterialWood type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this wood material element. (Overrides Material..::.Duplicate(String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


Duplicate Method

[image]

Revit 2010 API
MaterialWood..::.Duplicate Method
MaterialWood Class See Also Send Feedback
Duplicate this wood material element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override Material Duplicate(
    string name
)
Visual Basic (Declaration)
Public Overrides Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate(
    String^ name
) override

Parameters

name
Type: System..::.String
Name of the new material.

Return Value

Pointer to the new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, null pointer will be returned.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


MaterialWood Properties

[image] [image]

Revit 2010 API
MaterialWood Properties
MaterialWood Class See Also Send Feedback

The MaterialWood type exposes the following members.

Properties

Name | Description
Bending | Get or set the bending of the wood material.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
CompressionParallel | Get or set the compression parallel to grain of the wood material.
CompressionPerpendicular | Get or set the compression perpendicular to grain of the wood material.
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Grade | Get or set the grade of the wood material.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PoissonModulus | Get or set the Poisson modulus of the wood material.
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
ShearModulus | Get or set the shear modulus of the wood material.
ShearParallel | Get or set the shear parallel to grain of the wood material.
ShearPerpendicular | Get or set the tension perpendicular to grain of the wood material.
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
Species | Get or set the species of the wood material.
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
ThermalExpansionCoefficient | Get or set the thermal expansion coefficient of the wood material.
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UnitWeight | Get or set the unit weight of the wood material.
YoungModulus | Get or set the Young modulus of the wood material.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


Bending Property

[image]

Revit 2010 API
MaterialWood..::.Bending Property
MaterialWood Class See Also Send Feedback
Get or set the bending of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Bending { get; set; }
Visual Basic (Declaration)
Public Property Bending As Double
Visual C++
public:
property double Bending {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the bending to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


CompressionParallel Property

[image]

Revit 2010 API
MaterialWood..::.CompressionParallel Property
MaterialWood Class See Also Send Feedback
Get or set the compression parallel to grain of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double CompressionParallel { get; set; }
Visual Basic (Declaration)
Public Property CompressionParallel As Double
Visual C++
public:
property double CompressionParallel {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the compression parallel to grain to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


CompressionPerpendicular Property

[image]

Revit 2010 API
MaterialWood..::.CompressionPerpendicular Property
MaterialWood Class See Also Send Feedback
Get or set the compression perpendicular to grain of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double CompressionPerpendicular { get; set; }
Visual Basic (Declaration)
Public Property CompressionPerpendicular As Double
Visual C++
public:
property double CompressionPerpendicular {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the compression perpendicular to grain to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


Grade Property

[image]

Revit 2010 API
MaterialWood..::.Grade Property
MaterialWood Class See Also Send Feedback
Get or set the grade of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Grade { get; set; }
Visual Basic (Declaration)
Public Property Grade As String
Visual C++
public:
property String^ Grade {
    String^ get ();
    void set (String^ value);
}

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
MaterialWood..::.Parameter Property
MaterialWood Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MaterialWood Class
MaterialWood Members
Autodesk.Revit.Elements Namespace


PoissonModulus Property

[image]

Revit 2010 API
MaterialWood..::.PoissonModulus Property
MaterialWood Class See Also Send Feedback
Get or set the Poisson modulus of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double PoissonModulus { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulus As Double
Visual C++
public:
property double PoissonModulus {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the Poisson modulus to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


ShearModulus Property

[image]

Revit 2010 API
MaterialWood..::.ShearModulus Property
MaterialWood Class See Also Send Feedback
Get or set the shear modulus of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ShearModulus { get; set; }
Visual Basic (Declaration)
Public Property ShearModulus As Double
Visual C++
public:
property double ShearModulus {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the shear modulus to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


ShearParallel Property

[image]

Revit 2010 API
MaterialWood..::.ShearParallel Property
MaterialWood Class See Also Send Feedback
Get or set the shear parallel to grain of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ShearParallel { get; set; }
Visual Basic (Declaration)
Public Property ShearParallel As Double
Visual C++
public:
property double ShearParallel {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the shear parallel to grain to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


ShearPerpendicular Property

[image]

Revit 2010 API
MaterialWood..::.ShearPerpendicular Property
MaterialWood Class See Also Send Feedback
Get or set the tension perpendicular to grain of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ShearPerpendicular { get; set; }
Visual Basic (Declaration)
Public Property ShearPerpendicular As Double
Visual C++
public:
property double ShearPerpendicular {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the tension perpendicular to grain to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


Species Property

[image]

Revit 2010 API
MaterialWood..::.Species Property
MaterialWood Class See Also Send Feedback
Get or set the species of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Species { get; set; }
Visual Basic (Declaration)
Public Property Species As String
Visual C++
public:
property String^ Species {
    String^ get ();
    void set (String^ value);
}

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


ThermalExpansionCoefficient Property

[image]

Revit 2010 API
MaterialWood..::.ThermalExpansionCoefficient Property
MaterialWood Class See Also Send Feedback
Get or set the thermal expansion coefficient of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ThermalExpansionCoefficient { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficient As Double
Visual C++
public:
property double ThermalExpansionCoefficient {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the thermal expansion coefficient to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


UnitWeight Property

[image]

Revit 2010 API
MaterialWood..::.UnitWeight Property
MaterialWood Class See Also Send Feedback
Get or set the unit weight of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double UnitWeight { get; set; }
Visual Basic (Declaration)
Public Property UnitWeight As Double
Visual C++
public:
property double UnitWeight {
    double get ();
    void set (double value);
}

Remarks

The value is in newtons per square foot meter (N/(ft²m)). ArgumentException will be thrown if trying to set the unit weight to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


YoungModulus Property

[image]

Revit 2010 API
MaterialWood..::.YoungModulus Property
MaterialWood Class See Also Send Feedback
Get or set the Young modulus of the wood material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double YoungModulus { get; set; }
Visual Basic (Declaration)
Public Property YoungModulus As Double
Visual C++
public:
property double YoungModulus {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the Young modulus to an invalid value.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace


ModelArc Class

[image]

Revit 2010 API
ModelArc Class
Members See Also Send Feedback
Represents a ModelArc within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ModelArc : ModelCurve
Visual Basic (Declaration)
Public Class ModelArc _
    Inherits ModelCurve
Visual C++
public ref class ModelArc : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by goemetry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CurveElement
Autodesk.Revit.Elements..::.ModelCurve
Autodesk.Revit.Elements..::.ModelArc

See Also

ModelArc Members
Autodesk.Revit.Elements Namespace


ModelArc Members

[image] [image]

Revit 2010 API
ModelArc Members
ModelArc Class Constructors Methods Properties See Also Send Feedback

The ModelArc type exposes the following members.

Constructors

Name | Description
ModelArc | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve. (Inherited from ModelCurve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory. (Inherited from ModelCurve.)
TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelArc Class
Autodesk.Revit.Elements Namespace


ModelArc Constructor

[image]

Revit 2010 API
ModelArc Constructor
ModelArc Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelArc()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelArc()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelArc Class
Autodesk.Revit.Elements Namespace


ModelArc Methods

[image] [image]

Revit 2010 API
ModelArc Methods
ModelArc Class See Also Send Feedback

The ModelArc type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve. (Inherited from ModelCurve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelArc Class
Autodesk.Revit.Elements Namespace


ModelArc Properties

[image] [image]

Revit 2010 API
ModelArc Properties
ModelArc Class See Also Send Feedback

The ModelArc type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory. (Inherited from ModelCurve.)
TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelArc Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
ModelArc..::.Parameter Property
ModelArc Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ModelArc Class
ModelArc Members
Autodesk.Revit.Elements Namespace


ModelCurve Class

[image]

Revit 2010 API
ModelCurve Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ModelCurve : CurveElement
Visual Basic (Declaration)
Public Class ModelCurve _
    Inherits CurveElement
Visual C++
public ref class ModelCurve : public CurveElement

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CurveElement
Autodesk.Revit.Elements..::.ModelCurve
Autodesk.Revit.Elements..::.ModelArc
Autodesk.Revit.Elements..::.ModelEllipse
Autodesk.Revit.Elements..::.ModelHermiteSpline
Autodesk.Revit.Elements..::.ModelLine
Autodesk.Revit.Elements..::.ModelNurbSpline

See Also

ModelCurve Members
Autodesk.Revit.Elements Namespace


ModelCurve Members

[image] [image]

Revit 2010 API
ModelCurve Members
ModelCurve Class Constructors Methods Properties See Also Send Feedback

The ModelCurve type exposes the following members.

Constructors

Name | Description
ModelCurve | Initializes a new instance of the ModelCurve class

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the model curve in a family document.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsReferenceLine | Indicates if this curve is a reference curve.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory.
TrussCurveType | The truss curve type of this model curve.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace


ModelCurve Constructor

[image]

Revit 2010 API
ModelCurve Constructor
ModelCurve Class See Also Send Feedback
Initializes a new instance of the ModelCurve class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelCurve()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelCurve()

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace


ModelCurve Methods

[image] [image]

Revit 2010 API
ModelCurve Methods
ModelCurve Class See Also Send Feedback

The ModelCurve type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the model curve in a family document.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace


ChangeToReferenceLine Method

[image]

Revit 2010 API
ModelCurve..::.ChangeToReferenceLine Method
ModelCurve Class See Also Send Feedback
Changes this curve to reference curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ChangeToReferenceLine()
Visual Basic (Declaration)
Public Sub ChangeToReferenceLine
Visual C++
public:
void ChangeToReferenceLine()

Remarks

This method is applicable only to curves in conceptual mass families.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when attempting to change model curves to reference curves in non-conceptual mass families.

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace


GetVisibility Method

[image]

Revit 2010 API
ModelCurve..::.GetVisibility Method
ModelCurve Class See Also Send Feedback
Gets the visibility for the model curve in a family document.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic (Declaration)
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

Returns a copy of visibility settings for the model curve in a family document.

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace


SetVisibility Method

[image]

Revit 2010 API
ModelCurve..::.SetVisibility Method
ModelCurve Class See Also Send Feedback
Sets the visibility for the model curve in a family document.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic (Declaration)
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit..::.FamilyElementVisibility

Remarks

The visibility of the model curve geometry can be changed for different types of views and detail levels in the family document.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when visibility is null.
System..::.InvalidOperationException | Thrown when regeneration failed, or the model curve is in a project document.

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace


ModelCurve Properties

[image] [image]

Revit 2010 API
ModelCurve Properties
ModelCurve Class See Also Send Feedback

The ModelCurve type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsReferenceLine | Indicates if this curve is a reference curve.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory.
TrussCurveType | The truss curve type of this model curve.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace


IsReferenceLine Property

[image]

Revit 2010 API
ModelCurve..::.IsReferenceLine Property
ModelCurve Class See Also Send Feedback
Indicates if this curve is a reference curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsReferenceLine { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReferenceLine As Boolean
Visual C++
public:
property bool IsReferenceLine {
    bool get ();
}

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
ModelCurve..::.Parameter Property
ModelCurve Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ModelCurve Class
ModelCurve Members
Autodesk.Revit.Elements Namespace


Subcategory Property

[image]

Revit 2010 API
ModelCurve..::.Subcategory Property
ModelCurve Class See Also Send Feedback
The subcategory.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GraphicsStyle Subcategory { get; set; }
Visual Basic (Declaration)
Public Property Subcategory As GraphicsStyle
Visual C++
public:
property GraphicsStyle^ Subcategory {
    GraphicsStyle^ get ();
    void set (GraphicsStyle^ value);
}

Remarks

If the family category is non-cuttable, the subcategory can be set to be the family category or one of its subcategories. If the family category is cuttable, the subcategory can be set as the graphics styles of the family category, its subcategories, or the invisible lines graphics style.

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace


TrussCurveType Property

[image]

Revit 2010 API
ModelCurve..::.TrussCurveType Property
ModelCurve Class See Also Send Feedback
The truss curve type of this model curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TrussCurveType TrussCurveType { get; set; }
Visual Basic (Declaration)
Public Property TrussCurveType As TrussCurveType
Visual C++
public:
property TrussCurveType TrussCurveType {
    TrussCurveType get ();
    void set (TrussCurveType value);
}

Remarks

This property is applicable only to curves in Truss families.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the assigned value for TrussCurveType is invalid.
System..::.NotSupportedException | Thrown when attempting to set this property to a curve not in a truss family.
System..::.InvalidOperationException | Thrown when attempting to change truss curves to NonTrussCurve, or when the truss curve type may not be applied to curves of this shape (webs must be linear, and chords must be linear or arc).

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace


ModelCurveArrArray Class

[image]

Revit 2010 API
ModelCurveArrArray Class
Members See Also Send Feedback
An array that can contain any type of object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ModelCurveArrArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ModelCurveArrArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ModelCurveArrArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.ModelCurveArrArray

See Also

ModelCurveArrArray Members
Autodesk.Revit.Elements Namespace


ModelCurveArrArray Members

[image] [image]

Revit 2010 API
ModelCurveArrArray Members
ModelCurveArrArray Class Constructors Methods Properties See Also Send Feedback

The ModelCurveArrArray type exposes the following members.

Constructors

Name | Description
ModelCurveArrArray | Initializes a new instance of the ModelCurveArrArray class

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


ModelCurveArrArray Constructor

[image]

Revit 2010 API
ModelCurveArrArray Constructor
ModelCurveArrArray Class See Also Send Feedback
Initializes a new instance of the ModelCurveArrArray class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelCurveArrArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelCurveArrArray()

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


ModelCurveArrArray Methods

[image] [image]

Revit 2010 API
ModelCurveArrArray Methods
ModelCurveArrArray Class See Also Send Feedback

The ModelCurveArrArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


Append Method

[image]

Revit 2010 API
ModelCurveArrArray..::.Append Method
ModelCurveArrArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    ModelCurveArray item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As ModelCurveArray _
)
Visual C++
public:
virtual void Append(
    ModelCurveArray^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.ModelCurveArray

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


Clear Method

[image]

Revit 2010 API
ModelCurveArrArray..::.Clear Method
ModelCurveArrArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

[image]

Revit 2010 API
ModelCurveArrArray..::.ForwardIterator Method
ModelCurveArrArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ModelCurveArrArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ModelCurveArrArrayIterator
Visual C++
public:
virtual ModelCurveArrArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

[image]

Revit 2010 API
ModelCurveArrArray..::.GetEnumerator Method
ModelCurveArrArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


Insert Method

[image]

Revit 2010 API
ModelCurveArrArray..::.Insert Method
ModelCurveArrArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    ModelCurveArray item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As ModelCurveArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    ModelCurveArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Elements..::.ModelCurveArray
index
Type: System..::.Int32

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

[image]

Revit 2010 API
ModelCurveArrArray..::.ReverseIterator Method
ModelCurveArrArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ModelCurveArrArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ModelCurveArrArrayIterator
Visual C++
public:
virtual ModelCurveArrArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


ModelCurveArrArray Properties

[image] [image]

Revit 2010 API
ModelCurveArrArray Properties
ModelCurveArrArray Class See Also Send Feedback

The ModelCurveArrArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


IsEmpty Property

[image]

Revit 2010 API
ModelCurveArrArray..::.IsEmpty Property
ModelCurveArrArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


Item Property

[image]

Revit 2010 API
ModelCurveArrArray..::.Item Property
ModelCurveArrArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ModelCurveArray Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As ModelCurveArray
Visual C++
public:
virtual property ModelCurveArray^ Item[int index] {
    ModelCurveArray^ get (int index);
    void set (int index, ModelCurveArray^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


Size Property

[image]

Revit 2010 API
ModelCurveArrArray..::.Size Property
ModelCurveArrArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ModelCurveArrArray Class
Autodesk.Revit.Elements Namespace


ModelCurveArrArrayIterator Class

[image]

Revit 2010 API
ModelCurveArrArrayIterator Class
Members See Also Send Feedback
An iterator to a array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ModelCurveArrArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ModelCurveArrArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ModelCurveArrArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.ModelCurveArrArrayIterator

See Also

ModelCurveArrArrayIterator Members
Autodesk.Revit.Elements Namespace


ModelCurveArrArrayIterator Members

[image] [image]

Revit 2010 API
ModelCurveArrArrayIterator Members
ModelCurveArrArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ModelCurveArrArrayIterator type exposes the following members.

Constructors

Name | Description
ModelCurveArrArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ModelCurveArrArrayIterator Class
Autodesk.Revit.Elements Namespace


ModelCurveArrArrayIterator Constructor

[image]

Revit 2010 API
ModelCurveArrArrayIterator Constructor
ModelCurveArrArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelCurveArrArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelCurveArrArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelCurveArrArrayIterator Class
Autodesk.Revit.Elements Namespace


ModelCurveArrArrayIterator Methods

[image] [image]

Revit 2010 API
ModelCurveArrArrayIterator Methods
ModelCurveArrArrayIterator Class See Also Send Feedback

The ModelCurveArrArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelCurveArrArrayIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

[image]

Revit 2010 API
ModelCurveArrArrayIterator..::.MoveNext Method
ModelCurveArrArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ModelCurveArrArrayIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

[image]

Revit 2010 API
ModelCurveArrArrayIterator..::.Reset Method
ModelCurveArrArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ModelCurveArrArrayIterator Class
Autodesk.Revit.Elements Namespace


ModelCurveArrArrayIterator Properties

[image] [image]

Revit 2010 API
ModelCurveArrArrayIterator Properties
ModelCurveArrArrayIterator Class See Also Send Feedback

The ModelCurveArrArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ModelCurveArrArrayIterator Class
Autodesk.Revit.Elements Namespace


Current Property

[image]

Revit 2010 API
ModelCurveArrArrayIterator..::.Current Property
ModelCurveArrArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ModelCurveArrArrayIterator Class
Autodesk.Revit.Elements Namespace


ModelCurveArray Class

[image]

Revit 2010 API
ModelCurveArray Class
Members See Also Send Feedback
An array that contains model curves.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ModelCurveArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ModelCurveArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ModelCurveArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.ModelCurveArray

See Also

ModelCurveArray Members
Autodesk.Revit.Elements Namespace


ModelCurveArray Members

[image] [image]

Revit 2010 API
ModelCurveArray Members
ModelCurveArray Class Constructors Methods Properties See Also Send Feedback

The ModelCurveArray type exposes the following members.

Constructors

Name | Description
ModelCurveArray | Initializes a new instance of the ModelCurveArray class

Methods

Name | Description
Append | Add the model curve to the end of the array.
Clear | Removes every model curve from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified model curve into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a model curve at a specified index within the array.
Size | Returns the number of model curves that are in the array.

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


ModelCurveArray Constructor

[image]

Revit 2010 API
ModelCurveArray Constructor
ModelCurveArray Class See Also Send Feedback
Initializes a new instance of the ModelCurveArray class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelCurveArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelCurveArray()

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


ModelCurveArray Methods

[image] [image]

Revit 2010 API
ModelCurveArray Methods
ModelCurveArray Class See Also Send Feedback

The ModelCurveArray type exposes the following members.

Methods

Name | Description
Append | Add the model curve to the end of the array.
Clear | Removes every model curve from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified model curve into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


Append Method

[image]

Revit 2010 API
ModelCurveArray..::.Append Method
ModelCurveArray Class See Also Send Feedback
Add the model curve to the end of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    ModelCurve item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As ModelCurve _
)
Visual C++
public:
virtual void Append(
    ModelCurve^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.ModelCurve
The model curve to be added.

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


Clear Method

[image]

Revit 2010 API
ModelCurveArray..::.Clear Method
ModelCurveArray Class See Also Send Feedback
Removes every model curve from the array, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

[image]

Revit 2010 API
ModelCurveArray..::.ForwardIterator Method
ModelCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ModelCurveArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ModelCurveArrayIterator
Visual C++
public:
virtual ModelCurveArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

[image]

Revit 2010 API
ModelCurveArray..::.GetEnumerator Method
ModelCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


Insert Method

[image]

Revit 2010 API
ModelCurveArray..::.Insert Method
ModelCurveArray Class See Also Send Feedback
Insert the specified model curve into the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    ModelCurve item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As ModelCurve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    ModelCurve^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Elements..::.ModelCurve
The model curve to be inserted into the array.
index
Type: System..::.Int32
The model curve will be inserted before this index.

Return Value

Returns whether the model curve was inserted into the array.

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

[image]

Revit 2010 API
ModelCurveArray..::.ReverseIterator Method
ModelCurveArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ModelCurveArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ModelCurveArrayIterator
Visual C++
public:
virtual ModelCurveArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


ModelCurveArray Properties

[image] [image]

Revit 2010 API
ModelCurveArray Properties
ModelCurveArray Class See Also Send Feedback

The ModelCurveArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a model curve at a specified index within the array.
Size | Returns the number of model curves that are in the array.

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


IsEmpty Property

[image]

Revit 2010 API
ModelCurveArray..::.IsEmpty Property
ModelCurveArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


Item Property

[image]

Revit 2010 API
ModelCurveArray..::.Item Property
ModelCurveArray Class See Also Send Feedback
Gets or sets a model curve at a specified index within the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ModelCurve Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As ModelCurve
Visual C++
public:
virtual property ModelCurve^ Item[int index] {
    ModelCurve^ get (int index);
    void set (int index, ModelCurve^ value);
}

Parameters

index
Type: System..::.Int32
The index of the model curve to be set or retrieved.

Return Value

Returns the model curve at the specified index.

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


Size Property

[image]

Revit 2010 API
ModelCurveArray..::.Size Property
ModelCurveArray Class See Also Send Feedback
Returns the number of model curves that are in the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace


ModelCurveArrayIterator Class

[image]

Revit 2010 API
ModelCurveArrayIterator Class
Members See Also Send Feedback
An iterator to a model curve array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ModelCurveArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ModelCurveArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ModelCurveArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.ModelCurveArrayIterator

See Also

ModelCurveArrayIterator Members
Autodesk.Revit.Elements Namespace


ModelCurveArrayIterator Members

[image] [image]

Revit 2010 API
ModelCurveArrayIterator Members
ModelCurveArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ModelCurveArrayIterator type exposes the following members.

Constructors

Name | Description
ModelCurveArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ModelCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


ModelCurveArrayIterator Constructor

[image]

Revit 2010 API
ModelCurveArrayIterator Constructor
ModelCurveArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelCurveArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelCurveArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


ModelCurveArrayIterator Methods

[image] [image]

Revit 2010 API
ModelCurveArrayIterator Methods
ModelCurveArrayIterator Class See Also Send Feedback

The ModelCurveArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

[image]

Revit 2010 API
ModelCurveArrayIterator..::.MoveNext Method
ModelCurveArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ModelCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

[image]

Revit 2010 API
ModelCurveArrayIterator..::.Reset Method
ModelCurveArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ModelCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


ModelCurveArrayIterator Properties

[image] [image]

Revit 2010 API
ModelCurveArrayIterator Properties
ModelCurveArrayIterator Class See Also Send Feedback

The ModelCurveArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ModelCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


Current Property

[image]

Revit 2010 API
ModelCurveArrayIterator..::.Current Property
ModelCurveArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ModelCurveArrayIterator Class
Autodesk.Revit.Elements Namespace


ModelEllipse Class

[image]

Revit 2010 API
ModelEllipse Class
Members See Also Send Feedback
Represents a ModelEllipse within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ModelEllipse : ModelCurve
Visual Basic (Declaration)
Public Class ModelEllipse _
    Inherits ModelCurve
Visual C++
public ref class ModelEllipse : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by goemetry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CurveElement
Autodesk.Revit.Elements..::.ModelCurve
Autodesk.Revit.Elements..::.ModelEllipse

See Also

ModelEllipse Members
Autodesk.Revit.Elements Namespace


ModelEllipse Members

[image] [image]

Revit 2010 API
ModelEllipse Members
ModelEllipse Class Constructors Methods Properties See Also Send Feedback

The ModelEllipse type exposes the following members.

Constructors

Name | Description
ModelEllipse | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve. (Inherited from ModelCurve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory. (Inherited from ModelCurve.)
TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelEllipse Class
Autodesk.Revit.Elements Namespace


ModelEllipse Constructor

[image]

Revit 2010 API
ModelEllipse Constructor
ModelEllipse Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelEllipse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelEllipse()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelEllipse Class
Autodesk.Revit.Elements Namespace


ModelEllipse Methods

[image] [image]

Revit 2010 API
ModelEllipse Methods
ModelEllipse Class See Also Send Feedback

The ModelEllipse type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve. (Inherited from ModelCurve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelEllipse Class
Autodesk.Revit.Elements Namespace


ModelEllipse Properties

[image] [image]

Revit 2010 API
ModelEllipse Properties
ModelEllipse Class See Also Send Feedback

The ModelEllipse type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory. (Inherited from ModelCurve.)
TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelEllipse Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
ModelEllipse..::.Parameter Property
ModelEllipse Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ModelEllipse Class
ModelEllipse Members
Autodesk.Revit.Elements Namespace


ModelHermiteSpline Class

[image]

Revit 2010 API
ModelHermiteSpline Class
Members See Also Send Feedback
Represents a ModelHermiteSpline within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ModelHermiteSpline : ModelCurve
Visual Basic (Declaration)
Public Class ModelHermiteSpline _
    Inherits ModelCurve
Visual C++
public ref class ModelHermiteSpline : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by goemetry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CurveElement
Autodesk.Revit.Elements..::.ModelCurve
Autodesk.Revit.Elements..::.ModelHermiteSpline

See Also

ModelHermiteSpline Members
Autodesk.Revit.Elements Namespace


ModelHermiteSpline Members

[image] [image]

Revit 2010 API
ModelHermiteSpline Members
ModelHermiteSpline Class Constructors Methods Properties See Also Send Feedback

The ModelHermiteSpline type exposes the following members.

Constructors

Name | Description
ModelHermiteSpline | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve. (Inherited from ModelCurve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory. (Inherited from ModelCurve.)
TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelHermiteSpline Class
Autodesk.Revit.Elements Namespace


ModelHermiteSpline Constructor

[image]

Revit 2010 API
ModelHermiteSpline Constructor
ModelHermiteSpline Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelHermiteSpline()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelHermiteSpline()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelHermiteSpline Class
Autodesk.Revit.Elements Namespace


ModelHermiteSpline Methods

[image] [image]

Revit 2010 API
ModelHermiteSpline Methods
ModelHermiteSpline Class See Also Send Feedback

The ModelHermiteSpline type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve. (Inherited from ModelCurve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelHermiteSpline Class
Autodesk.Revit.Elements Namespace


ModelHermiteSpline Properties

[image] [image]

Revit 2010 API
ModelHermiteSpline Properties
ModelHermiteSpline Class See Also Send Feedback

The ModelHermiteSpline type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory. (Inherited from ModelCurve.)
TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelHermiteSpline Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
ModelHermiteSpline..::.Parameter Property
ModelHermiteSpline Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ModelHermiteSpline Class
ModelHermiteSpline Members
Autodesk.Revit.Elements Namespace


ModelLine Class

[image]

Revit 2010 API
ModelLine Class
Members See Also Send Feedback
Represents a ModelLine within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ModelLine : ModelCurve
Visual Basic (Declaration)
Public Class ModelLine _
    Inherits ModelCurve
Visual C++
public ref class ModelLine : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by goemetry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CurveElement
Autodesk.Revit.Elements..::.ModelCurve
Autodesk.Revit.Elements..::.ModelLine

See Also

ModelLine Members
Autodesk.Revit.Elements Namespace


ModelLine Members

[image] [image]

Revit 2010 API
ModelLine Members
ModelLine Class Constructors Methods Properties See Also Send Feedback

The ModelLine type exposes the following members.

Constructors

Name | Description
ModelLine | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve. (Inherited from ModelCurve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory. (Inherited from ModelCurve.)
TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelLine Class
Autodesk.Revit.Elements Namespace


ModelLine Constructor

[image]

Revit 2010 API
ModelLine Constructor
ModelLine Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelLine()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelLine()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelLine Class
Autodesk.Revit.Elements Namespace


ModelLine Methods

[image] [image]

Revit 2010 API
ModelLine Methods
ModelLine Class See Also Send Feedback

The ModelLine type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve. (Inherited from ModelCurve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelLine Class
Autodesk.Revit.Elements Namespace


ModelLine Properties

[image] [image]

Revit 2010 API
ModelLine Properties
ModelLine Class See Also Send Feedback

The ModelLine type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory. (Inherited from ModelCurve.)
TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelLine Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
ModelLine..::.Parameter Property
ModelLine Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ModelLine Class
ModelLine Members
Autodesk.Revit.Elements Namespace


ModelNurbSpline Class

[image]

Revit 2010 API
ModelNurbSpline Class
Members See Also Send Feedback
Represents a ModelNurbSpline within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ModelNurbSpline : ModelCurve
Visual Basic (Declaration)
Public Class ModelNurbSpline _
    Inherits ModelCurve
Visual C++
public ref class ModelNurbSpline : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by goemetry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CurveElement
Autodesk.Revit.Elements..::.ModelCurve
Autodesk.Revit.Elements..::.ModelNurbSpline

See Also

ModelNurbSpline Members
Autodesk.Revit.Elements Namespace


ModelNurbSpline Members

[image] [image]

Revit 2010 API
ModelNurbSpline Members
ModelNurbSpline Class Constructors Methods Properties See Also Send Feedback

The ModelNurbSpline type exposes the following members.

Constructors

Name | Description
ModelNurbSpline | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve. (Inherited from ModelCurve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory. (Inherited from ModelCurve.)
TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelNurbSpline Class
Autodesk.Revit.Elements Namespace


ModelNurbSpline Constructor

[image]

Revit 2010 API
ModelNurbSpline Constructor
ModelNurbSpline Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelNurbSpline()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelNurbSpline()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelNurbSpline Class
Autodesk.Revit.Elements Namespace


ModelNurbSpline Methods

[image] [image]

Revit 2010 API
ModelNurbSpline Methods
ModelNurbSpline Class See Also Send Feedback

The ModelNurbSpline type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve. (Inherited from ModelCurve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelNurbSpline Class
Autodesk.Revit.Elements Namespace


ModelNurbSpline Properties

[image] [image]

Revit 2010 API
ModelNurbSpline Properties
ModelNurbSpline Class See Also Send Feedback

The ModelNurbSpline type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory. (Inherited from ModelCurve.)
TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelNurbSpline Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
ModelNurbSpline..::.Parameter Property
ModelNurbSpline Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ModelNurbSpline Class
ModelNurbSpline Members
Autodesk.Revit.Elements Namespace


ModelText Class

[image]

Revit 2010 API
ModelText Class
Members See Also Send Feedback
A model text element in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ModelText : Element
Visual Basic (Declaration)
Public Class ModelText _
    Inherits Element
Visual C++
public ref class ModelText : public Element

Remarks

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.ModelText

See Also

ModelText Members
Autodesk.Revit.Elements Namespace


ModelText Members

[image] [image]

Revit 2010 API
ModelText Members
ModelText Class Constructors Methods Properties See Also Send Feedback

The ModelText type exposes the following members.

Constructors

Name | Description
ModelText | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the model text in a family document.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the model text in a family document.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Depth | The depth of the model text.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HorizontalAlignment | The horizontal alignment.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an instance within project. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
ModelTextType | The type for the model text.
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory.
Text | The text string in the model text.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelText Class
Autodesk.Revit.Elements Namespace


ModelText Constructor

[image]

Revit 2010 API
ModelText Constructor
ModelText Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelText()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelText()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelText Class
Autodesk.Revit.Elements Namespace


ModelText Methods

[image] [image]

Revit 2010 API
ModelText Methods
ModelText Class See Also Send Feedback

The ModelText type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the model text in a family document.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the model text in a family document.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelText Class
Autodesk.Revit.Elements Namespace


GetVisibility Method

[image]

Revit 2010 API
ModelText..::.GetVisibility Method
ModelText Class See Also Send Feedback
Gets the visibility for the model text in a family document.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic (Declaration)
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

Returns a copy of visibility settings for the model text in a family document.

See Also

ModelText Class
Autodesk.Revit.Elements Namespace


SetVisibility Method

[image]

Revit 2010 API
ModelText..::.SetVisibility Method
ModelText Class See Also Send Feedback
Sets the visibility for the model text in a family document.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic (Declaration)
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit..::.FamilyElementVisibility

Remarks

The visibility of the model text geometry can be changed for different types of views and detail levels in the family document.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when visibility is null.
System..::.InvalidOperationException | Thrown when regeneration failed, or the model curve is in a project document.

See Also

ModelText Class
Autodesk.Revit.Elements Namespace


ModelText Properties

[image] [image]

Revit 2010 API
ModelText Properties
ModelText Class See Also Send Feedback

The ModelText type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Depth | The depth of the model text.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HorizontalAlignment | The horizontal alignment.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an instance within project. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
ModelTextType | The type for the model text.
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory.
Text | The text string in the model text.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelText Class
Autodesk.Revit.Elements Namespace


Depth Property

[image]

Revit 2010 API
ModelText..::.Depth Property
ModelText Class See Also Send Feedback
The depth of the model text.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Depth { get; set; }
Visual Basic (Declaration)
Public Property Depth As Double
Visual C++
public:
property double Depth {
    double get ();
    void set (double value);
}

See Also

ModelText Class
Autodesk.Revit.Elements Namespace


HorizontalAlignment Property

[image]

Revit 2010 API
ModelText..::.HorizontalAlignment Property
ModelText Class See Also Send Feedback
The horizontal alignment.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public HorizontalAlign HorizontalAlignment { get; set; }
Visual Basic (Declaration)
Public Property HorizontalAlignment As HorizontalAlign
Visual C++
public:
property HorizontalAlign HorizontalAlignment {
    HorizontalAlign get ();
    void set (HorizontalAlign value);
}

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when an invalid value is assigned to the property.

See Also

ModelText Class
Autodesk.Revit.Elements Namespace


Location Property

[image]

Revit 2010 API
ModelText..::.Location Property
ModelText Class See Also Send Feedback
This property is used to find the physical location of an instance within project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

See Also

ModelText Class
Autodesk.Revit.Elements Namespace


ModelTextType Property

[image]

Revit 2010 API
ModelText..::.ModelTextType Property
ModelText Class See Also Send Feedback
The type for the model text.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelTextType ModelTextType { get; set; }
Visual Basic (Declaration)
Public Property ModelTextType As ModelTextType
Visual C++
public:
property ModelTextType^ ModelTextType {
    ModelTextType^ get ();
    void set (ModelTextType^ value);
}

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when null is assigned to this property.

See Also

ModelText Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
ModelText..::.Parameter Property
ModelText Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ModelText Class
ModelText Members
Autodesk.Revit.Elements Namespace


Subcategory Property

[image]

Revit 2010 API
ModelText..::.Subcategory Property
ModelText Class See Also Send Feedback
The subcategory.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Category Subcategory { get; set; }
Visual Basic (Declaration)
Public Property Subcategory As Category
Visual C++
public:
property Category^ Subcategory {
    Category^ get ();
    void set (Category^ value);
}

Remarks

The subcategory can be set to either the family category or one of its subcategories.

See Also

ModelText Class
Autodesk.Revit.Elements Namespace


Text Property

[image]

Revit 2010 API
ModelText..::.Text Property
ModelText Class See Also Send Feedback
The text string in the model text.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when null is assigned to text.
System..::.ArgumentException | Thrown when an empty string is assigned to text.

See Also

ModelText Class
Autodesk.Revit.Elements Namespace


Mullion Class

[image]

Revit 2010 API
Mullion Class
Members See Also Send Feedback
Represents a CurtainGrid within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Mullion : Element
Visual Basic (Declaration)
Public Class Mullion _
    Inherits Element
Visual C++
public ref class Mullion : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Mullion

See Also

Mullion Members
Autodesk.Revit.Elements Namespace


Mullion Members

[image] [image]

Revit 2010 API
Mullion Members
Mullion Class Constructors Methods Properties See Also Send Feedback

The Mullion type exposes the following members.

Constructors

Name | Description
Mullion | For Internal Use Only.

Methods

Name | Description
BreakMullion | This method is used to break the current Mullion at ends with its neighboring mullions.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
JoinMullion | This method is used to control the join condition the current Mullion with its neighboring mullions.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AsFamilyInstance | This property is used to get family instance within project.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
LocationCurve | This method get the curve location of the current Mullion.
Lock | Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.
Lockable | Get - to get whether the Mullion can be lock or unlock.
Materials | Get all materials present in the element. (Inherited from Element.)
MullionType | The MullionType style of this Mullion. Get - to access type of mullion Set - change type of mullion. If the mullion is locked, InvalidOperationException exception will be thrown.
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Mullion Class
Autodesk.Revit.Elements Namespace


Mullion Constructor

[image]

Revit 2010 API
Mullion Constructor
Mullion Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Mullion()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Mullion()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Mullion Class
Autodesk.Revit.Elements Namespace


Mullion Methods

[image] [image]

Revit 2010 API
Mullion Methods
Mullion Class See Also Send Feedback

The Mullion type exposes the following members.

Methods

Name | Description
BreakMullion | This method is used to break the current Mullion at ends with its neighboring mullions.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
JoinMullion | This method is used to control the join condition the current Mullion with its neighboring mullions.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Mullion Class
Autodesk.Revit.Elements Namespace


BreakMullion Method

[image]

Revit 2010 API
Mullion..::.BreakMullion Method
Mullion Class See Also Send Feedback
This method is used to break the current Mullion at ends with its neighboring mullions.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void BreakMullion()
Visual Basic (Declaration)
Public Sub BreakMullion
Visual C++
public:
void BreakMullion()

Remarks

The mullions being perpendicular to it will be joined accordingly.

See Also

Mullion Class
Autodesk.Revit.Elements Namespace


JoinMullion Method

[image]

Revit 2010 API
Mullion..::.JoinMullion Method
Mullion Class See Also Send Feedback
This method is used to control the join condition the current Mullion with its neighboring mullions.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void JoinMullion()
Visual Basic (Declaration)
Public Sub JoinMullion
Visual C++
public:
void JoinMullion()

Remarks

The mullions being perpendicular to it will be broken accordingly.

See Also

Mullion Class
Autodesk.Revit.Elements Namespace


Mullion Properties

[image] [image]

Revit 2010 API
Mullion Properties
Mullion Class See Also Send Feedback

The Mullion type exposes the following members.

Properties

Name | Description
AsFamilyInstance | This property is used to get family instance within project.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
LocationCurve | This method get the curve location of the current Mullion.
Lock | Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.
Lockable | Get - to get whether the Mullion can be lock or unlock.
Materials | Get all materials present in the element. (Inherited from Element.)
MullionType | The MullionType style of this Mullion. Get - to access type of mullion Set - change type of mullion. If the mullion is locked, InvalidOperationException exception will be thrown.
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Mullion Class
Autodesk.Revit.Elements Namespace


AsFamilyInstance Property

[image]

Revit 2010 API
Mullion..::.AsFamilyInstance Property
Mullion Class See Also Send Feedback
This property is used to get family instance within project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance AsFamilyInstance { get; }
Visual Basic (Declaration)
Public ReadOnly Property AsFamilyInstance As FamilyInstance
Visual C++
public:
property FamilyInstance^ AsFamilyInstance {
    FamilyInstance^ get ();
}

Remarks

The AsFamilyInstance property returns an family instance that can be used to stand for this Mullion within the project.

See Also

Mullion Class
Autodesk.Revit.Elements Namespace


LocationCurve Property

[image]

Revit 2010 API
Mullion..::.LocationCurve Property
Mullion Class See Also Send Feedback
This method get the curve location of the current Mullion.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve LocationCurve { get; }
Visual Basic (Declaration)
Public ReadOnly Property LocationCurve As Curve
Visual C++
public:
property Curve^ LocationCurve {
    Curve^ get ();
}

See Also

Mullion Class
Autodesk.Revit.Elements Namespace


Lock Property

[image]

Revit 2010 API
Mullion..::.Lock Property
Mullion Class See Also Send Feedback
Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Lock { get; set; }
Visual Basic (Declaration)
Public Property Lock As Boolean
Visual C++
public:
property bool Lock {
    bool get ();
    void set (bool value);
}

See Also

Mullion Class
Autodesk.Revit.Elements Namespace


Lockable Property

[image]

Revit 2010 API
Mullion..::.Lockable Property
Mullion Class See Also Send Feedback
Get - to get whether the Mullion can be lock or unlock.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Lockable { get; }
Visual Basic (Declaration)
Public ReadOnly Property Lockable As Boolean
Visual C++
public:
property bool Lockable {
    bool get ();
}

See Also

Mullion Class
Autodesk.Revit.Elements Namespace


MullionType Property

[image]

Revit 2010 API
Mullion..::.MullionType Property
Mullion Class See Also Send Feedback
The MullionType style of this Mullion. Get - to access type of mullion Set - change type of mullion. If the mullion is locked, InvalidOperationException exception will be thrown.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MullionType MullionType { get; set; }
Visual Basic (Declaration)
Public Property MullionType As MullionType
Visual C++
public:
property MullionType^ MullionType {
    MullionType^ get ();
    void set (MullionType^ value);
}

See Also

Mullion Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Mullion..::.Parameter Property
Mullion Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Mullion Class
Mullion Members
Autodesk.Revit.Elements Namespace


Opening Class

[image]

Revit 2010 API
Opening Class
Members Example See Also Send Feedback
An opening in an Autodesk Revit project or family document.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Opening : Element
Visual Basic (Declaration)
Public Class Opening _
    Inherits Element
Visual C++
public ref class Opening : public Element

Remarks

The object represents a variety of different types of openings:
  • A rectangular opening in a wall created by two boundary points in a revit project.
  • An opening created by a set of curves applied to a roof, floor, ceiling, beam, brace or column.
  • A vertical shaft opening extending one or more levels.
  • A simple opening created on a wall or ceiling in a family document.
Depending upon the type of opening, some of the properties of this class will not be available.

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object also supports access to a structural analytical model but this feature is only available with Autodesk Revit Structure.

Examples

CopyC#
private void Getinfo_Opening(Opening opening)
{
    string message = "Opening:";

    //get the host element of this opening
    message += "\nThe id of the opening's host element is : " + opening.Host.Id.Value;

    //get the information whether the opening has a rect boundary
    //If the opening has a rect boundary, we can get the geometry information from BoundaryRect property.
    //Otherwise we should get the geometry information from BoundaryCurves property
    if (opening.IsRectBoundary)
    {
        message += "\nThe opening has a rectangular boundary.";
        //array contains two XYZ objects: the max and min coords of boundary
        XYZArray boundaryRect = opening.BoundaryRect;

        //get the coordinate value of the min coordinate point
        XYZ point = opening.BoundaryRect.get_Item(0);
        message += "\nMin coordinate point:(" + point.X + ", "
                                + point.Y + ", " + point.Z + ")";

        //get the coordinate value of the Max coordinate point
        point = opening.BoundaryRect.get_Item(1);
        message += "\nMax coordinate point: (" + point.X + ", "
                                + point.Y + ", " + point.Z + ")";
    }
    else
    {
        message += "\nThe opening doesn't have a rectangular boundary.";
        // Get curve number
        int curves = opening.BoundaryCurves.Size;
        message += "\nNumber of curves is : " + curves;
        for (int i = 0; i < curves; i++)
        {
            Autodesk.Revit.Geometry.Curve curve = opening.BoundaryCurves.get_Item(i);
            // Get curve start point
            message += "\nCurve start point: " + XYZToString(curve.get_EndPoint(0));
            // Get curve end point
            message += "; Curve end point: " + XYZToString(curve.get_EndPoint(1));
        }
    }
    MessageBox.Show(message, "Revit");
}

// output the point's three coordinates
string XYZToString(XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
CopyVB.NET
Private Sub Getinfo_Opening(ByVal opening As Autodesk.Revit.Elements.Opening)
    Dim message As String = "Opening:"

    'get the host element of this opening
    message += vbLf & "The id of the opening's host element is : " & opening.Host.Id.Value

    'get the information whether the opening has a rect boundary
    'If the opening has a rect boundary, we can get the geometry information from BoundaryRect property.
    'Otherwise we should get the geometry information from BoundaryCurves property
    If opening.IsRectBoundary Then
        message += vbLf & "The opening has a rectangular boundary."
        'array contains two XYZ objects: the max and min coords of boundary
        Dim boundaryRect As XYZArray = opening.BoundaryRect

        'get the coordinate value of the min coordinate point
        Dim point As Autodesk.Revit.Geometry.XYZ = opening.BoundaryRect.Item(0)
        message += ((vbLf & "Min coordinate point:(" & point.X & ", ") + point.Y & ", ") + point.Z & ")"

        'get the coordinate value of the Max coordinate point
        point = opening.BoundaryRect.Item(1)
        message += ((vbLf & "Max coordinate point: (" & point.X & ", ") + point.Y & ", ") + point.Z & ")"
    Else
        message += vbLf & "The opening doesn't have a rectangular boundary."
        ' Get curve number
        Dim curves As Integer = opening.BoundaryCurves.Size
        message += vbLf & "Number of curves is : " & curves
        For i As Integer = 0 To curves - 1
            Dim curve As Autodesk.Revit.Geometry.Curve = opening.BoundaryCurves.Item(i)
            ' Get curve start point
            message += vbLf & "Curve start point: " & XYZToString(curve.EndPoint(0))
            ' Get curve end point
            message += "; Curve end point: " & XYZToString(curve.EndPoint(1))
        Next
    End If
    MessageBox.Show(message, "Revit")
End Sub

' output the point's three coordinates
Private Function XYZToString(ByVal point As Autodesk.Revit.Geometry.XYZ) As String
    Return (("(" & point.X & ", ") + point.Y & ", ") + point.Z & ")"
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Opening

See Also

Opening Members
Autodesk.Revit.Elements Namespace


Opening Members

[image] [image]

Revit 2010 API
Opening Members
Opening Class Constructors Methods Properties See Also Send Feedback

The Opening type exposes the following members.

Constructors

Name | Description
Opening | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundaryCurves | The geometry information for non-rectangular openings in project documents, or for all openings in family documents.
BoundaryRect | Retrieves the geometry information if the opening boundary is a rect.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Host | Retrieves the host element of this opening.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsRectBoundary | Retrieves the information whether the opening has a rectangular boundary.
IsTransparentIn3D | Indicates if the opening is transparent in 3D view when loaded into the project.
IsTransparentInElevation | Indicates if the opening is transparent in elevation view when loaded into the project.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Opening Class
Autodesk.Revit.Elements Namespace


Opening Constructor

[image]

Revit 2010 API
Opening Constructor
Opening Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Opening()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Opening()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Opening Class
Autodesk.Revit.Elements Namespace


Opening Methods

[image] [image]

Revit 2010 API
Opening Methods
Opening Class See Also Send Feedback

The Opening type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Opening Class
Autodesk.Revit.Elements Namespace


Opening Properties

[image] [image]

Revit 2010 API
Opening Properties
Opening Class See Also Send Feedback

The Opening type exposes the following members.

Properties

Name | Description
BoundaryCurves | The geometry information for non-rectangular openings in project documents, or for all openings in family documents.
BoundaryRect | Retrieves the geometry information if the opening boundary is a rect.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Host | Retrieves the host element of this opening.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsRectBoundary | Retrieves the information whether the opening has a rectangular boundary.
IsTransparentIn3D | Indicates if the opening is transparent in 3D view when loaded into the project.
IsTransparentInElevation | Indicates if the opening is transparent in elevation view when loaded into the project.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Opening Class
Autodesk.Revit.Elements Namespace


BoundaryCurves Property

[image]

Revit 2010 API
Opening..::.BoundaryCurves Property
Opening Class See Also Send Feedback
The geometry information for non-rectangular openings in project documents, or for all openings in family documents.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray BoundaryCurves { get; }
Visual Basic (Declaration)
Public ReadOnly Property BoundaryCurves As CurveArray
Visual C++
public:
property CurveArray^ BoundaryCurves {
    CurveArray^ get ();
}

Remarks

If IsRectBoundary is true, this value is null.

See Also

Opening Class
Autodesk.Revit.Elements Namespace


BoundaryRect Property

[image]

Revit 2010 API
Opening..::.BoundaryRect Property
Opening Class See Also Send Feedback
Retrieves the geometry information if the opening boundary is a rect.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZArray BoundaryRect { get; }
Visual Basic (Declaration)
Public ReadOnly Property BoundaryRect As XYZArray
Visual C++
public:
property XYZArray^ BoundaryRect {
    XYZArray^ get ();
}

Remarks

If IsRectBoundary is false, this value is null.

See Also

Opening Class
Autodesk.Revit.Elements Namespace


Host Property

[image]

Revit 2010 API
Opening..::.Host Property
Opening Class See Also Send Feedback
Retrieves the host element of this opening.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element Host { get; }
Visual Basic (Declaration)
Public ReadOnly Property Host As Element
Visual C++
public:
property Element^ Host {
    Element^ get ();
}

See Also

Opening Class
Autodesk.Revit.Elements Namespace


IsRectBoundary Property

[image]

Revit 2010 API
Opening..::.IsRectBoundary Property
Opening Class See Also Send Feedback
Retrieves the information whether the opening has a rectangular boundary.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsRectBoundary { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsRectBoundary As Boolean
Visual C++
public:
property bool IsRectBoundary {
    bool get ();
}

Remarks

If the opening has a rectangular boundary, we can get the geometry information from BoundaryRect property. Otherwise we should get the geometry information from BoundaryCurves property.

See Also

Opening Class
Autodesk.Revit.Elements Namespace


IsTransparentIn3D Property

[image]

Revit 2010 API
Opening..::.IsTransparentIn3D Property
Opening Class See Also Send Feedback
Indicates if the opening is transparent in 3D view when loaded into the project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsTransparentIn3D { get; set; }
Visual Basic (Declaration)
Public Property IsTransparentIn3D As Boolean
Visual C++
public:
property bool IsTransparentIn3D {
    bool get ();
    void set (bool value);
}

Remarks

This property is only valid in Revit family documents.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when access this property in an opening belonging to a Revit project document.

See Also

Opening Class
Autodesk.Revit.Elements Namespace


IsTransparentInElevation Property

[image]

Revit 2010 API
Opening..::.IsTransparentInElevation Property
Opening Class See Also Send Feedback
Indicates if the opening is transparent in elevation view when loaded into the project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsTransparentInElevation { get; set; }
Visual Basic (Declaration)
Public Property IsTransparentInElevation As Boolean
Visual C++
public:
property bool IsTransparentInElevation {
    bool get ();
    void set (bool value);
}

Remarks

This property is only valid in Revit family documents.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when access this property in an opening belonging to a Revit project document.

See Also

Opening Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Opening..::.Parameter Property
Opening Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Opening Class
Opening Members
Autodesk.Revit.Elements Namespace


Panel Class

[image]

Revit 2010 API
Panel Class
Members See Also Send Feedback
This object represents a curtain panel.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Panel : Element
Visual Basic (Declaration)
Public Class Panel _
    Inherits Element
Visual C++
public ref class Panel : public Element

Remarks

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Panel

See Also

Panel Members
Autodesk.Revit.Elements Namespace


Panel Members

[image] [image]

Revit 2010 API
Panel Members
Panel Class Constructors Methods Properties See Also Send Feedback

The Panel type exposes the following members.

Constructors

Name | Description
Panel | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetRefGridLines | This method is used to get the reference gridlines.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AsFamilyInstance | This property is used to get family instance within project.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Lock | This property is used to know whether a panel is locked and lock or unlock a panel.
Lockable | This property is used to know whether a panel can be locked.
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
PanelType | The Panel style of this Panel.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Transform | This property is used to find the transform of a curtain panel within project.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Panel Class
Autodesk.Revit.Elements Namespace


Panel Constructor

[image]

Revit 2010 API
Panel Constructor
Panel Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Panel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Panel()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Panel Class
Autodesk.Revit.Elements Namespace


Panel Methods

[image] [image]

Revit 2010 API
Panel Methods
Panel Class See Also Send Feedback

The Panel type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetRefGridLines | This method is used to get the reference gridlines.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Panel Class
Autodesk.Revit.Elements Namespace


GetRefGridLines Method

[image]

Revit 2010 API
Panel..::.GetRefGridLines Method
Panel Class See Also Send Feedback
This method is used to get the reference gridlines.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void GetRefGridLines(
    ref ElementId uGridLineId,
    ref ElementId vGridLineId
)
Visual Basic (Declaration)
Public Sub GetRefGridLines ( _
    ByRef uGridLineId As ElementId, _
    ByRef vGridLineId As ElementId _
)
Visual C++
public:
void GetRefGridLines(
    ElementId% uGridLineId,
    ElementId% vGridLineId
)

Parameters

uGridLineId
Type: Autodesk.Revit..::.ElementId %
vGridLineId
Type: Autodesk.Revit..::.ElementId %

See Also

Panel Class
Autodesk.Revit.Elements Namespace


Panel Properties

[image] [image]

Revit 2010 API
Panel Properties
Panel Class See Also Send Feedback

The Panel type exposes the following members.

Properties

Name | Description
AsFamilyInstance | This property is used to get family instance within project.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Lock | This property is used to know whether a panel is locked and lock or unlock a panel.
Lockable | This property is used to know whether a panel can be locked.
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
PanelType | The Panel style of this Panel.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Transform | This property is used to find the transform of a curtain panel within project.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Panel Class
Autodesk.Revit.Elements Namespace


AsFamilyInstance Property

[image]

Revit 2010 API
Panel..::.AsFamilyInstance Property
Panel Class See Also Send Feedback
This property is used to get family instance within project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance AsFamilyInstance { get; }
Visual Basic (Declaration)
Public ReadOnly Property AsFamilyInstance As FamilyInstance
Visual C++
public:
property FamilyInstance^ AsFamilyInstance {
    FamilyInstance^ get ();
}

Remarks

The AsFamilyInstance property returns an family instance that can be used to stand for this panel within the project.

See Also

Panel Class
Autodesk.Revit.Elements Namespace


Lock Property

[image]

Revit 2010 API
Panel..::.Lock Property
Panel Class See Also Send Feedback
This property is used to know whether a panel is locked and lock or unlock a panel.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Lock { get; set; }
Visual Basic (Declaration)
Public Property Lock As Boolean
Visual C++
public:
property bool Lock {
    bool get ();
    void set (bool value);
}

Remarks

If the panel is locked, get() returns true, else false.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when this panel can't be locked.

See Also

Panel Class
Autodesk.Revit.Elements Namespace


Lockable Property

[image]

Revit 2010 API
Panel..::.Lockable Property
Panel Class See Also Send Feedback
This property is used to know whether a panel can be locked.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Lockable { get; }
Visual Basic (Declaration)
Public ReadOnly Property Lockable As Boolean
Visual C++
public:
property bool Lockable {
    bool get ();
}

Remarks

If the panel can be locked, return true, else false.

See Also

Panel Class
Autodesk.Revit.Elements Namespace


PanelType Property

[image]

Revit 2010 API
Panel..::.PanelType Property
Panel Class See Also Send Feedback
The Panel style of this Panel.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PanelType PanelType { get; set; }
Visual Basic (Declaration)
Public Property PanelType As PanelType
Visual C++
public:
property PanelType^ PanelType {
    PanelType^ get ();
    void set (PanelType^ value);
}

Remarks

The Symbol property can be used to retrieve the kind of the panel. This property can also be used to change the type of a panel by setting it to a different type. All the panel types in the project can be found using the Document.CutainPanelTypes property.

See Also

Panel Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Panel..::.Parameter Property
Panel Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Panel Class
Panel Members
Autodesk.Revit.Elements Namespace


Transform Property

[image]

Revit 2010 API
Panel..::.Transform Property
Panel Class See Also Send Feedback
This property is used to find the transform of a curtain panel within project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Transform Transform { get; }
Visual Basic (Declaration)
Public ReadOnly Property Transform As Transform
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
}

Remarks

The Transform property returns a Geometry::Transform object that can be used to find the transfer matrix of a curtain panel within the project.

See Also

Panel Class
Autodesk.Revit.Elements Namespace


Path3d Class

[image]

Revit 2010 API
Path3d Class
Members See Also Send Feedback
Provides access to the Generic 3D path object in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Path3d : SketchBase
Visual Basic (Declaration)
Public Class Path3d _
    Inherits SketchBase
Visual C++
public ref class Path3d : public SketchBase

Remarks

This object represents a 3D path sketch of Sweep.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.SketchBase
Autodesk.Revit.Elements..::.Path3d

See Also

Path3d Members
Autodesk.Revit.Elements Namespace


Path3d Members

[image] [image]

Revit 2010 API
Path3d Members
Path3d Class Constructors Methods Properties See Also Send Feedback

The Path3d type exposes the following members.

Constructors

Name | Description
Path3d | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllCurveLoops | Get all the Curve Loops of Path3d.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveLoop | Get the Curve Loop of Path3d via index.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
NumCurveLoops | Get the Number of Curve Loops of Path3d.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Path3d Class
Autodesk.Revit.Elements Namespace


Path3d Constructor

[image]

Revit 2010 API
Path3d Constructor
Path3d Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Path3d()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Path3d()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Path3d Class
Autodesk.Revit.Elements Namespace


Path3d Methods

[image] [image]

Revit 2010 API
Path3d Methods
Path3d Class See Also Send Feedback

The Path3d type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Path3d Class
Autodesk.Revit.Elements Namespace


Path3d Properties

[image] [image]

Revit 2010 API
Path3d Properties
Path3d Class See Also Send Feedback

The Path3d type exposes the following members.

Properties

Name | Description
AllCurveLoops | Get all the Curve Loops of Path3d.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveLoop | Get the Curve Loop of Path3d via index.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
NumCurveLoops | Get the Number of Curve Loops of Path3d.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Path3d Class
Autodesk.Revit.Elements Namespace


AllCurveLoops Property

[image]

Revit 2010 API
Path3d..::.AllCurveLoops Property
Path3d Class See Also Send Feedback
Get all the Curve Loops of Path3d.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArrArray AllCurveLoops { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllCurveLoops As CurveArrArray
Visual C++
public:
property CurveArrArray^ AllCurveLoops {
    CurveArrArray^ get ();
}

Remarks

Returns all the Curve Loops of Path3d.

See Also

Path3d Class
Autodesk.Revit.Elements Namespace


CurveLoop Property

[image]

Revit 2010 API
Path3d..::.CurveLoop Property
Path3d Class See Also Send Feedback
Get the Curve Loop of Path3d via index.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray CurveLoop[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurveLoop ( _
    index As Integer _
) As CurveArray
Visual C++
public:
property CurveArray^ CurveLoop[int index] {
    CurveArray^ get (int index);
}

Parameters

index
Type: System..::.Int32

Remarks

Returns the index order Curve Loop of Path3d.

See Also

Path3d Class
Autodesk.Revit.Elements Namespace


NumCurveLoops Property

[image]

Revit 2010 API
Path3d..::.NumCurveLoops Property
Path3d Class See Also Send Feedback
Get the Number of Curve Loops of Path3d.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NumCurveLoops { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumCurveLoops As Integer
Visual C++
public:
property int NumCurveLoops {
    int get ();
}

Remarks

Returns the Number of Curve Loops of Path3d.

See Also

Path3d Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Path3d..::.Parameter Property
Path3d Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Path3d Class
Path3d Members
Autodesk.Revit.Elements Namespace


PathReinforcement Class

[image]

Revit 2010 API
PathReinforcement Class
Members Example See Also Send Feedback
An object that represents an Path Reinforcement within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PathReinforcement : Element
Visual Basic (Declaration)
Public Class PathReinforcement _
    Inherits Element
Visual C++
public ref class PathReinforcement : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Path Reinforcement element is available only in the Autodesk Revit Structure product.

Examples

CopyC#
private void Getinfo_PathReinforcement(PathReinforcement pathReinforcement)
{
    string message = "PathReinforcement : ";

    // Show the NumBarDescriptions property
    message += "\nNumber of distinct bar shapes : " + pathReinforcement.NumBarDescriptions;
    for (int i = 0; i < pathReinforcement.NumBarDescriptions; i++)
    {
       BarDescription description = pathReinforcement.get_BarDescription(i);
       message += "\nBar count : " + description.Count;
       message += "\nBar type name : " + description.BarType.Name;
       message += "\nBar layer : " + description.Layer;
       message += "\nBar length : " + description.Length;
    }

    // Show the PathReinforcement Curves information
    message += "\nPath Reinforcement has " + pathReinforcement.Curves.Size + " path curves.";
    foreach (Autodesk.Revit.Element ii in pathReinforcement.Curves)
    {
       ModelCurve pathCurve = ii as ModelCurve;
       if (null == pathCurve)
       {
          continue;
       }
       Curve curve = pathCurve.GeometryCurve;   // get the location curve
       XYZ start = curve.get_EndPoint(0);  // get the start point of the curve
       XYZ end = curve.get_EndPoint(1);    // get the end point of the curve
       message += "\nCurve: Start point (" + start.X + ", " + start.Y + ", " + start.Z + ")";
       message += "   End point (" + end.X + ", " + end.Y + ", " + end.Z + ")";
    }

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Private Sub Getinfo_PathReinforcement(ByVal pathReinforcement As PathReinforcement)
    Dim message As String = "PathReinforcement : "

    ' Show the NumBarDescriptions property
    message += vbLf & "Number of distinct bar shapes : " & pathReinforcement.NumBarDescriptions
    For i As Integer = 0 To pathReinforcement.NumBarDescriptions - 1
        Dim description As BarDescription = pathReinforcement.BarDescription(i)
        message += vbLf & "Bar count : " & description.Count
        message += vbLf & "Bar type name : " & description.BarType.Name
        message += vbLf & "Bar layer : " & description.Layer
        message += vbLf & "Bar length : " & description.Length
    Next

    ' Show the PathReinforcement Curves information
    message += vbLf & "Path Reinforcement has " & pathReinforcement.Curves.Size & " path curves."
    For Each ii As Autodesk.Revit.Element In pathReinforcement.Curves
        Dim pathCurve As ModelCurve = TryCast(ii, ModelCurve)
        If pathCurve Is Nothing Then
            Continue For
        End If
        Dim curve As Curve = pathCurve.GeometryCurve
        ' get the location curve
        Dim start As Autodesk.Revit.Geometry.XYZ = curve.EndPoint(0)
        ' get the start point of the curve
        Dim [end] As Autodesk.Revit.Geometry.XYZ = curve.EndPoint(1)
        ' get the end point of the curve
        message += ((vbLf & "Curve: Start point (" & start.X & ", ") + start.Y & ", ") + start.Z & ")"
        message += ((" End point (" & [end].X & ", ") + [end].Y & ", ") + [end].Z & ")"
    Next

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.PathReinforcement

See Also

PathReinforcement Members
Autodesk.Revit.Elements Namespace


PathReinforcement Members

[image] [image]

Revit 2010 API
PathReinforcement Members
PathReinforcement Class Constructors Methods Properties See Also Send Feedback

The PathReinforcement type exposes the following members.

Constructors

Name | Description
PathReinforcement | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BarDescription | Retrieves the Bar Table property of an Path Reinforcement element.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curves | Retrieves the array of curves forming the boundary of the Path Reinforcement.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
NumBarDescriptions | Retrieves the number of distinct bar shapes.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PathReinforcementType | Retrieves the type of the Path Reinforcement.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PathReinforcement Class
Autodesk.Revit.Elements Namespace


PathReinforcement Constructor

[image]

Revit 2010 API
PathReinforcement Constructor
PathReinforcement Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PathReinforcement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PathReinforcement()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PathReinforcement Class
Autodesk.Revit.Elements Namespace


PathReinforcement Methods

[image] [image]

Revit 2010 API
PathReinforcement Methods
PathReinforcement Class See Also Send Feedback

The PathReinforcement type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PathReinforcement Class
Autodesk.Revit.Elements Namespace


PathReinforcement Properties

[image] [image]

Revit 2010 API
PathReinforcement Properties
PathReinforcement Class See Also Send Feedback

The PathReinforcement type exposes the following members.

Properties

Name | Description
BarDescription | Retrieves the Bar Table property of an Path Reinforcement element.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curves | Retrieves the array of curves forming the boundary of the Path Reinforcement.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
NumBarDescriptions | Retrieves the number of distinct bar shapes.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PathReinforcementType | Retrieves the type of the Path Reinforcement.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PathReinforcement Class
Autodesk.Revit.Elements Namespace


BarDescription Property

[image]

Revit 2010 API
PathReinforcement..::.BarDescription Property
PathReinforcement Class See Also Send Feedback
Retrieves the Bar Table property of an Path Reinforcement element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BarDescription BarDescription[
    int idx
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarDescription ( _
    idx As Integer _
) As BarDescription
Visual C++
public:
property BarDescription^ BarDescription[int idx] {
    BarDescription^ get (int idx);
}

Parameters

idx
Type: System..::.Int32
Index of a Bar Description.

See Also

PathReinforcement Class
Autodesk.Revit.Elements Namespace


Curves Property

[image]

Revit 2010 API
PathReinforcement..::.Curves Property
PathReinforcement Class Example See Also Send Feedback
Retrieves the array of curves forming the boundary of the Path Reinforcement.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementArray Curves { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curves As ElementArray
Visual C++
public:
property ElementArray^ Curves {
    ElementArray^ get ();
}

Remarks

Each element in the array is of type ModelCurve.

Examples

CopyC#
private void Getinfo_PathReinforcementCurve(PathReinforcement pathReinforcement)
{
    string message = "Path Reinforcement Curves : ";

    // Get path reinforcement curves by iterating the Curves property
    foreach (Autodesk.Revit.Element ii in pathReinforcement.Curves)
    {
        ModelCurve pathReinforcementCurve = ii as ModelCurve;
        if (null == pathReinforcementCurve)
        {
            continue;
        }

        Autodesk.Revit.Geometry.Curve curve = pathReinforcementCurve.GeometryCurve;

        // Get curve start point
        message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
            + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        // Get curve end point
        message += "; Curve end point:(" + curve.get_EndPoint(1).X + ", "
            + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";

    }
    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);

}
CopyVB.NET
Private Sub Getinfo_PathReinforcementCurve(ByVal pathReinforcement As PathReinforcement)
    Dim message As String = "Path Reinforcement Curves : "

    ' Get path reinforcement curves by iterating the Curves property
    For Each ii As Autodesk.Revit.Element In pathReinforcement.Curves
        Dim pathReinforcementCurve As ModelCurve = TryCast(ii, ModelCurve)
        If pathReinforcementCurve Is Nothing Then
            Continue For
        End If

        Dim curve As Autodesk.Revit.Geometry.Curve = pathReinforcementCurve.GeometryCurve

        ' Get curve start point
        message += ((vbLf & "Curve start point:(" & curve.EndPoint(0).X & ", ") + curve.EndPoint(0).Y & ", ") + curve.EndPoint(0).Z & ")"
        ' Get curve end point
        message += (("; Curve end point:(" & curve.EndPoint(1).X & ", ") + curve.EndPoint(1).Y & ", ") + curve.EndPoint(1).Z & ")"

    Next
    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)

End Sub

See Also

PathReinforcement Class
Autodesk.Revit.Elements Namespace


NumBarDescriptions Property

[image]

Revit 2010 API
PathReinforcement..::.NumBarDescriptions Property
PathReinforcement Class See Also Send Feedback
Retrieves the number of distinct bar shapes.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NumBarDescriptions { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumBarDescriptions As Integer
Visual C++
public:
property int NumBarDescriptions {
    int get ();
}

See Also

PathReinforcement Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
PathReinforcement..::.Parameter Property
PathReinforcement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PathReinforcement Class
PathReinforcement Members
Autodesk.Revit.Elements Namespace


PathReinforcementType Property

[image]

Revit 2010 API
PathReinforcement..::.PathReinforcementType Property
PathReinforcement Class See Also Send Feedback
Retrieves the type of the Path Reinforcement.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PathReinforcementType PathReinforcementType { get; }
Visual Basic (Declaration)
Public ReadOnly Property PathReinforcementType As PathReinforcementType
Visual C++
public:
property PathReinforcementType^ PathReinforcementType {
    PathReinforcementType^ get ();
}

See Also

PathReinforcement Class
Autodesk.Revit.Elements Namespace


Phase Class

[image]

Revit 2010 API
Phase Class
Members See Also Send Feedback
Represents a phase in the life of a building.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Phase : Element
Visual Basic (Declaration)
Public Class Phase _
    Inherits Element
Visual C++
public ref class Phase : public Element

Remarks

The lifetime of an element within a building can be controlled by using phases. Each element will have a construction phase but only those elements that have a finite lifetime will have a destruction phase. All the phases within a project can be retrieved from the Document object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Phase

See Also

Phase Members
Autodesk.Revit.Elements Namespace


Phase Members

[image] [image]

Revit 2010 API
Phase Members
Phase Class Constructors Methods Properties See Also Send Feedback

The Phase type exposes the following members.

Constructors

Name | Description
Phase | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Phase Class
Autodesk.Revit.Elements Namespace


Phase Constructor

[image]

Revit 2010 API
Phase Constructor
Phase Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Phase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Phase()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Phase Class
Autodesk.Revit.Elements Namespace


Phase Methods

[image] [image]

Revit 2010 API
Phase Methods
Phase Class See Also Send Feedback

The Phase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Phase Class
Autodesk.Revit.Elements Namespace


Phase Properties

[image] [image]

Revit 2010 API
Phase Properties
Phase Class See Also Send Feedback

The Phase type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Phase Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Phase..::.Parameter Property
Phase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Phase Class
Phase Members
Autodesk.Revit.Elements Namespace


PhaseArray Class

[image]

Revit 2010 API
PhaseArray Class
Members See Also Send Feedback
An array that contains phase objects.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PhaseArray : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class PhaseArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PhaseArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.PhaseArray

See Also

PhaseArray Members
Autodesk.Revit.Elements Namespace


PhaseArray Members

[image] [image]

Revit 2010 API
PhaseArray Members
PhaseArray Class Constructors Methods Properties See Also Send Feedback

The PhaseArray type exposes the following members.

Constructors

Name | Description
PhaseArray | Initializes a new instance of the PhaseArray class

Methods

Name | Description
Append | Add the phase to the end of the array.
Clear | Removes every phase from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified phase into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a phase at a specified index within the array.
Size | Returns the number of phases that are in the array.

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


PhaseArray Constructor

[image]

Revit 2010 API
PhaseArray Constructor
PhaseArray Class See Also Send Feedback
Initializes a new instance of the PhaseArray class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PhaseArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PhaseArray()

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


PhaseArray Methods

[image] [image]

Revit 2010 API
PhaseArray Methods
PhaseArray Class See Also Send Feedback

The PhaseArray type exposes the following members.

Methods

Name | Description
Append | Add the phase to the end of the array.
Clear | Removes every phase from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified phase into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


Append Method

[image]

Revit 2010 API
PhaseArray..::.Append Method
PhaseArray Class See Also Send Feedback
Add the phase to the end of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    Phase item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Phase _
)
Visual C++
public:
virtual void Append(
    Phase^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.Phase
The phase to be added.

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


Clear Method

[image]

Revit 2010 API
PhaseArray..::.Clear Method
PhaseArray Class See Also Send Feedback
Removes every phase from the array, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

[image]

Revit 2010 API
PhaseArray..::.ForwardIterator Method
PhaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual PhaseArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PhaseArrayIterator
Visual C++
public:
virtual PhaseArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

[image]

Revit 2010 API
PhaseArray..::.GetEnumerator Method
PhaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


Insert Method

[image]

Revit 2010 API
PhaseArray..::.Insert Method
PhaseArray Class See Also Send Feedback
Insert the specified phase into the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    Phase item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Phase, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Phase^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Elements..::.Phase
The phase to be inserted into the array.
index
Type: System..::.Int32
The phase will be inserted before this index.

Return Value

Returns whether the phase was inserted into the array.

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

[image]

Revit 2010 API
PhaseArray..::.ReverseIterator Method
PhaseArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual PhaseArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PhaseArrayIterator
Visual C++
public:
virtual PhaseArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


PhaseArray Properties

[image] [image]

Revit 2010 API
PhaseArray Properties
PhaseArray Class See Also Send Feedback

The PhaseArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a phase at a specified index within the array.
Size | Returns the number of phases that are in the array.

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


IsEmpty Property

[image]

Revit 2010 API
PhaseArray..::.IsEmpty Property
PhaseArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


Item Property

[image]

Revit 2010 API
PhaseArray..::.Item Property
PhaseArray Class See Also Send Feedback
Gets or sets a phase at a specified index within the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Phase Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Phase
Visual C++
public:
virtual property Phase^ Item[int index] {
    Phase^ get (int index);
    void set (int index, Phase^ value);
}

Parameters

index
Type: System..::.Int32
The index of the phase to be set or retrieved.

Return Value

Returns the phase at the specified index.

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


Size Property

[image]

Revit 2010 API
PhaseArray..::.Size Property
PhaseArray Class See Also Send Feedback
Returns the number of phases that are in the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace


PhaseArrayIterator Class

[image]

Revit 2010 API
PhaseArrayIterator Class
Members See Also Send Feedback
An iterator to a phase array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class PhaseArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class PhaseArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PhaseArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.PhaseArrayIterator

See Also

PhaseArrayIterator Members
Autodesk.Revit.Elements Namespace


PhaseArrayIterator Members

[image] [image]

Revit 2010 API
PhaseArrayIterator Members
PhaseArrayIterator Class Constructors Methods Properties See Also Send Feedback

The PhaseArrayIterator type exposes the following members.

Constructors

Name | Description
PhaseArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PhaseArrayIterator Class
Autodesk.Revit.Elements Namespace


PhaseArrayIterator Constructor

[image]

Revit 2010 API
PhaseArrayIterator Constructor
PhaseArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PhaseArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PhaseArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PhaseArrayIterator Class
Autodesk.Revit.Elements Namespace


PhaseArrayIterator Methods

[image] [image]

Revit 2010 API
PhaseArrayIterator Methods
PhaseArrayIterator Class See Also Send Feedback

The PhaseArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaseArrayIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

[image]

Revit 2010 API
PhaseArrayIterator..::.MoveNext Method
PhaseArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PhaseArrayIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

[image]

Revit 2010 API
PhaseArrayIterator..::.Reset Method
PhaseArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PhaseArrayIterator Class
Autodesk.Revit.Elements Namespace


PhaseArrayIterator Properties

[image] [image]

Revit 2010 API
PhaseArrayIterator Properties
PhaseArrayIterator Class See Also Send Feedback

The PhaseArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PhaseArrayIterator Class
Autodesk.Revit.Elements Namespace


Current Property

[image]

Revit 2010 API
PhaseArrayIterator..::.Current Property
PhaseArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PhaseArrayIterator Class
Autodesk.Revit.Elements Namespace


PointElementReference Class

[image]

Revit 2010 API
PointElementReference Class
Members See Also Send Feedback
Base class for objects defining a way to constrain a ReferencePoint to one or more other objects in a document.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class PointElementReference
Visual Basic (Declaration)
Public MustInherit Class PointElementReference
Visual C++
public ref class PointElementReference abstract

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Elements..::.PointElementReference
Autodesk.Revit.Elements..::.PointOnEdge
Autodesk.Revit.Elements..::.PointOnEdgeEdgeIntersection
Autodesk.Revit.Elements..::.PointOnEdgeFaceIntersection
Autodesk.Revit.Elements..::.PointOnFace
Autodesk.Revit.Elements..::.PointOnPlane

See Also

PointElementReference Members
Autodesk.Revit.Elements Namespace


PointElementReference Members

[image] [image]

Revit 2010 API
PointElementReference Members
PointElementReference Class Constructors Methods See Also Send Feedback

The PointElementReference type exposes the following members.

Constructors

Name | Description
PointElementReference | Initializes a new instance of the PointElementReference class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointElementReference Class
Autodesk.Revit.Elements Namespace


PointElementReference Constructor

[image]

Revit 2010 API
PointElementReference Constructor
PointElementReference Class See Also Send Feedback
Initializes a new instance of the PointElementReference class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PointElementReference()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PointElementReference()

See Also

PointElementReference Class
Autodesk.Revit.Elements Namespace


PointElementReference Methods

[image] [image]

Revit 2010 API
PointElementReference Methods
PointElementReference Class See Also Send Feedback

The PointElementReference type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointElementReference Class
Autodesk.Revit.Elements Namespace


PointLoad Class

[image]

Revit 2010 API
PointLoad Class
Members Example See Also Send Feedback
An object that represents a force/moment applied to a single point.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PointLoad : LoadBase
Visual Basic (Declaration)
Public Class PointLoad _
    Inherits LoadBase
Visual C++
public ref class PointLoad : public LoadBase

Examples

CopyC#
private void Getinfo_PointLoad(PointLoad pointLoad)
{
    string message = "Point Load :";

    // Get the load case name
    message += "\nLoad case for load: " + pointLoad.LoadCaseName;

    //get the three dimensional force applied to the point load
    message += "\nForce: (" + pointLoad.Force.X + ", " +
             pointLoad.Force.Y + ", " + pointLoad.Force.Z + ")";

    //get the three dimensional moment application to the point load
    message += "\nMoment: (" + pointLoad.Moment.X + ", " +
             pointLoad.Moment.Y + ", " + pointLoad.Moment.Z + ")";

    //get the three dimensional coordinates of point load
    message += "\nPoint load location: (" + pointLoad.Point.X + ", " +
             pointLoad.Point.Y + ", " + pointLoad.Point.Z + ")";

    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Private Sub Getinfo_PointLoad(ByVal pointLoad As Autodesk.Revit.Elements.PointLoad)
    Dim message As String = "Point Load :"

    ' Get the load case name
    message += vbLf & "Load case for load: " & pointLoad.LoadCaseName

    'get the three dimensional force applied to the point load
    message += ((vbLf & "Force: (" & pointLoad.Force.X & ", ") + pointLoad.Force.Y & ", ") + pointLoad.Force.Z & ")"

    'get the three dimensional moment application to the point load
    message += ((vbLf & "Moment: (" & pointLoad.Moment.X & ", ") + pointLoad.Moment.Y & ", ") + pointLoad.Moment.Z & ")"

    'get the three dimensional coordinates of point load
    message += ((vbLf & "Point load location: (" & pointLoad.Point.X & ", ") + pointLoad.Point.Y & ", ") + pointLoad.Point.Z & ")"

    MessageBox.Show(message, "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.LoadBase
Autodesk.Revit.Elements..::.PointLoad

See Also

PointLoad Members
Autodesk.Revit.Elements Namespace


PointLoad Members

[image] [image]

Revit 2010 API
PointLoad Members
PointLoad Class Constructors Methods Properties See Also Send Feedback

The PointLoad type exposes the following members.

Constructors

Name | Description
PointLoad | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Force | Returns the three dimensional force applied to the point load.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HostElement | The host element for the load. (Inherited from LoadBase.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Moment | Returns the three dimensional moment application to the point load.
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Point | Returns the three dimensional coordinates of point load.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PointLoad Class
Autodesk.Revit.Elements Namespace


PointLoad Constructor

[image]

Revit 2010 API
PointLoad Constructor
PointLoad Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PointLoad()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PointLoad()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PointLoad Class
Autodesk.Revit.Elements Namespace


PointLoad Methods

[image] [image]

Revit 2010 API
PointLoad Methods
PointLoad Class See Also Send Feedback

The PointLoad type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointLoad Class
Autodesk.Revit.Elements Namespace


PointLoad Properties

[image] [image]

Revit 2010 API
PointLoad Properties
PointLoad Class See Also Send Feedback

The PointLoad type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Force | Returns the three dimensional force applied to the point load.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HostElement | The host element for the load. (Inherited from LoadBase.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Moment | Returns the three dimensional moment application to the point load.
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Point | Returns the three dimensional coordinates of point load.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PointLoad Class
Autodesk.Revit.Elements Namespace


Force Property

[image]

Revit 2010 API
PointLoad..::.Force Property
PointLoad Class See Also Send Feedback
Returns the three dimensional force applied to the point load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Force { get; }
Visual Basic (Declaration)
Public ReadOnly Property Force As XYZ
Visual C++
public:
property XYZ^ Force {
    XYZ^ get ();
}

Remarks

The force is measured in Feet*Kg / Sec.

See Also

PointLoad Class
Autodesk.Revit.Elements Namespace


Moment Property

[image]

Revit 2010 API
PointLoad..::.Moment Property
PointLoad Class See Also Send Feedback
Returns the three dimensional moment application to the point load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Moment { get; }
Visual Basic (Declaration)
Public ReadOnly Property Moment As XYZ
Visual C++
public:
property XYZ^ Moment {
    XYZ^ get ();
}

Remarks

The moment is measured in Feet*Kg / Sec.

See Also

PointLoad Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
PointLoad..::.Parameter Property
PointLoad Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PointLoad Class
PointLoad Members
Autodesk.Revit.Elements Namespace


Point Property

[image]

Revit 2010 API
PointLoad..::.Point Property
PointLoad Class See Also Send Feedback
Returns the three dimensional coordinates of point load.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Point { get; }
Visual Basic (Declaration)
Public ReadOnly Property Point As XYZ
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
}

Remarks

The location is measured in decimal feet.

See Also

PointLoad Class
Autodesk.Revit.Elements Namespace


PointOnEdge Class

[image]

Revit 2010 API
PointOnEdge Class
Members See Also Send Feedback
Define a ReferencePoint relative to a referenceable edge or curve on another element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PointOnEdge : PointElementReference
Visual Basic (Declaration)
Public Class PointOnEdge _
    Inherits PointElementReference
Visual C++
public ref class PointOnEdge : public PointElementReference

Remarks

The ReferencePoint's X basis vector is constrained to the tangent vector to the curve. The Y and Z vectors are free to rotate around the curve.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Elements..::.PointElementReference
Autodesk.Revit.Elements..::.PointOnEdge

See Also

PointOnEdge Members
Autodesk.Revit.Elements Namespace


PointOnEdge Members

[image] [image]

Revit 2010 API
PointOnEdge Members
PointOnEdge Class Methods Properties See Also Send Feedback

The PointOnEdge type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEdgeReference | Get a copy of the edge or curve reference.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEdgeReference | Change the edge or curve reference.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurveParameter | Parameter along the curve.

See Also

PointOnEdge Class
Autodesk.Revit.Elements Namespace


PointOnEdge Methods

[image] [image]

Revit 2010 API
PointOnEdge Methods
PointOnEdge Class See Also Send Feedback

The PointOnEdge type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEdgeReference | Get a copy of the edge or curve reference.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEdgeReference | Change the edge or curve reference.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointOnEdge Class
Autodesk.Revit.Elements Namespace


GetEdgeReference Method

[image]

Revit 2010 API
PointOnEdge..::.GetEdgeReference Method
PointOnEdge Class See Also Send Feedback
Get a copy of the edge or curve reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference GetEdgeReference()
Visual Basic (Declaration)
Public Function GetEdgeReference As Reference
Visual C++
public:
Reference^ GetEdgeReference()

See Also

PointOnEdge Class
Autodesk.Revit.Elements Namespace


SetEdgeReference Method

[image]

Revit 2010 API
PointOnEdge..::.SetEdgeReference Method
PointOnEdge Class See Also Send Feedback
Change the edge or curve reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetEdgeReference(
    Reference reference
)
Visual Basic (Declaration)
Public Sub SetEdgeReference ( _
    reference As Reference _
)
Visual C++
public:
void SetEdgeReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.Geometry..::.Reference

Remarks

The referenced element may be any model element, including FamilyInstance, FormElement, or CurveElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR.

See Also

PointOnEdge Class
Autodesk.Revit.Elements Namespace


PointOnEdge Properties

[image] [image]

Revit 2010 API
PointOnEdge Properties
PointOnEdge Class See Also Send Feedback

The PointOnEdge type exposes the following members.

Properties

Name | Description
CurveParameter | Parameter along the curve.

See Also

PointOnEdge Class
Autodesk.Revit.Elements Namespace


CurveParameter Property

[image]

Revit 2010 API
PointOnEdge..::.CurveParameter Property
PointOnEdge Class See Also Send Feedback
Parameter along the curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double CurveParameter { get; set; }
Visual Basic (Declaration)
Public Property CurveParameter As Double
Visual C++
public:
property double CurveParameter {
    double get ();
    void set (double value);
}

Remarks

Ranges from 0.0 to 1.0.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown if CurveParameter is less than 0.0 or greater than 1.0.

See Also

PointOnEdge Class
Autodesk.Revit.Elements Namespace


PointOnEdgeEdgeIntersection Class

[image]

Revit 2010 API
PointOnEdgeEdgeIntersection Class
Members See Also Send Feedback
Define a ReferencePoint at the intersection of two referenceable lines.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PointOnEdgeEdgeIntersection : PointElementReference
Visual Basic (Declaration)
Public Class PointOnEdgeEdgeIntersection _
    Inherits PointElementReference
Visual C++
public ref class PointOnEdgeEdgeIntersection : public PointElementReference

Remarks

The ReferencePoint is actually placed on the first line (Edge1) at the closest point to the second line (Edge2). Its X basis vector is constrained to be parallel to the first line.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Elements..::.PointElementReference
Autodesk.Revit.Elements..::.PointOnEdgeEdgeIntersection

See Also

PointOnEdgeEdgeIntersection Members
Autodesk.Revit.Elements Namespace


PointOnEdgeEdgeIntersection Members

[image] [image]

Revit 2010 API
PointOnEdgeEdgeIntersection Members
PointOnEdgeEdgeIntersection Class Methods See Also Send Feedback

The PointOnEdgeEdgeIntersection type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEdgeReference1 | Get a copy of the first edge or curve reference.
GetEdgeReference2 | Get a copy of the second edge or curve reference.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEdgeReference1 | Change the first edge or curve reference.
SetEdgeReference2 | Change the second edge or curve reference.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointOnEdgeEdgeIntersection Class
Autodesk.Revit.Elements Namespace


PointOnEdgeEdgeIntersection Methods

[image] [image]

Revit 2010 API
PointOnEdgeEdgeIntersection Methods
PointOnEdgeEdgeIntersection Class See Also Send Feedback

The PointOnEdgeEdgeIntersection type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEdgeReference1 | Get a copy of the first edge or curve reference.
GetEdgeReference2 | Get a copy of the second edge or curve reference.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEdgeReference1 | Change the first edge or curve reference.
SetEdgeReference2 | Change the second edge or curve reference.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointOnEdgeEdgeIntersection Class
Autodesk.Revit.Elements Namespace


GetEdgeReference1 Method

[image]

Revit 2010 API
PointOnEdgeEdgeIntersection..::.GetEdgeReference1 Method
PointOnEdgeEdgeIntersection Class See Also Send Feedback
Get a copy of the first edge or curve reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference GetEdgeReference1()
Visual Basic (Declaration)
Public Function GetEdgeReference1 As Reference
Visual C++
public:
Reference^ GetEdgeReference1()

See Also

PointOnEdgeEdgeIntersection Class
Autodesk.Revit.Elements Namespace


GetEdgeReference2 Method

[image]

Revit 2010 API
PointOnEdgeEdgeIntersection..::.GetEdgeReference2 Method
PointOnEdgeEdgeIntersection Class See Also Send Feedback
Get a copy of the second edge or curve reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference GetEdgeReference2()
Visual Basic (Declaration)
Public Function GetEdgeReference2 As Reference
Visual C++
public:
Reference^ GetEdgeReference2()

See Also

PointOnEdgeEdgeIntersection Class
Autodesk.Revit.Elements Namespace


SetEdgeReference1 Method

[image]

Revit 2010 API
PointOnEdgeEdgeIntersection..::.SetEdgeReference1 Method
PointOnEdgeEdgeIntersection Class See Also Send Feedback
Change the first edge or curve reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetEdgeReference1(
    Reference edgeReference
)
Visual Basic (Declaration)
Public Sub SetEdgeReference1 ( _
    edgeReference As Reference _
)
Visual C++
public:
void SetEdgeReference1(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.Geometry..::.Reference

Remarks

The referenced element may be any model element, including FamilyInstance, FormElement, or NonPlanarSketch. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR, and it must correspond to a straight line.

See Also

PointOnEdgeEdgeIntersection Class
Autodesk.Revit.Elements Namespace


SetEdgeReference2 Method

[image]

Revit 2010 API
PointOnEdgeEdgeIntersection..::.SetEdgeReference2 Method
PointOnEdgeEdgeIntersection Class See Also Send Feedback
Change the second edge or curve reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetEdgeReference2(
    Reference edgeReference
)
Visual Basic (Declaration)
Public Sub SetEdgeReference2 ( _
    edgeReference As Reference _
)
Visual C++
public:
void SetEdgeReference2(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.Geometry..::.Reference

Remarks

The referenced element may be any model element, including FamilyInstance, FormElement, or NonPlanarSketch. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR, and it must correspond to a straight line.

See Also

PointOnEdgeEdgeIntersection Class
Autodesk.Revit.Elements Namespace


PointOnEdgeFaceIntersection Class

[image]

Revit 2010 API
PointOnEdgeFaceIntersection Class
Members See Also Send Feedback
Define a ReferencePoint at the intersection of a referenceable edge or curve and a referenceable face.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PointOnEdgeFaceIntersection : PointElementReference
Visual Basic (Declaration)
Public Class PointOnEdgeFaceIntersection _
    Inherits PointElementReference
Visual C++
public ref class PointOnEdgeFaceIntersection : public PointElementReference

Remarks

The ReferencePoint's orientation is partially constrained either to the edge (in the manner of PointOnEdge) or to the face (in the manner of PointOnFace).

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Elements..::.PointElementReference
Autodesk.Revit.Elements..::.PointOnEdgeFaceIntersection

See Also

PointOnEdgeFaceIntersection Members
Autodesk.Revit.Elements Namespace


PointOnEdgeFaceIntersection Members

[image] [image]

Revit 2010 API
PointOnEdgeFaceIntersection Members
PointOnEdgeFaceIntersection Class Methods Properties See Also Send Feedback

The PointOnEdgeFaceIntersection type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEdgeReference | Get a copy of the edge or curve reference.
GetFaceReference | Get a copy of the face reference.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEdgeReference | Change the edge or curve reference.
SetFaceReference | Change the face reference.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
OrientWithEdge | Whether to orient the ReferencePoint to the edge or the face.

See Also

PointOnEdgeFaceIntersection Class
Autodesk.Revit.Elements Namespace


PointOnEdgeFaceIntersection Methods

[image] [image]

Revit 2010 API
PointOnEdgeFaceIntersection Methods
PointOnEdgeFaceIntersection Class See Also Send Feedback

The PointOnEdgeFaceIntersection type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEdgeReference | Get a copy of the edge or curve reference.
GetFaceReference | Get a copy of the face reference.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEdgeReference | Change the edge or curve reference.
SetFaceReference | Change the face reference.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointOnEdgeFaceIntersection Class
Autodesk.Revit.Elements Namespace


GetEdgeReference Method

[image]

Revit 2010 API
PointOnEdgeFaceIntersection..::.GetEdgeReference Method
PointOnEdgeFaceIntersection Class See Also Send Feedback
Get a copy of the edge or curve reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference GetEdgeReference()
Visual Basic (Declaration)
Public Function GetEdgeReference As Reference
Visual C++
public:
Reference^ GetEdgeReference()

See Also

PointOnEdgeFaceIntersection Class
Autodesk.Revit.Elements Namespace


GetFaceReference Method

[image]

Revit 2010 API
PointOnEdgeFaceIntersection..::.GetFaceReference Method
PointOnEdgeFaceIntersection Class See Also Send Feedback
Get a copy of the face reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference GetFaceReference()
Visual Basic (Declaration)
Public Function GetFaceReference As Reference
Visual C++
public:
Reference^ GetFaceReference()

See Also

PointOnEdgeFaceIntersection Class
Autodesk.Revit.Elements Namespace


SetEdgeReference Method

[image]

Revit 2010 API
PointOnEdgeFaceIntersection..::.SetEdgeReference Method
PointOnEdgeFaceIntersection Class See Also Send Feedback
Change the edge or curve reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetEdgeReference(
    Reference edgeReference
)
Visual Basic (Declaration)
Public Sub SetEdgeReference ( _
    edgeReference As Reference _
)
Visual C++
public:
void SetEdgeReference(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.Geometry..::.Reference

Remarks

The referenced element may be any model element, including FamilyInstance, FormElement, or CurveElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR.

See Also

PointOnEdgeFaceIntersection Class
Autodesk.Revit.Elements Namespace


SetFaceReference Method

[image]

Revit 2010 API
PointOnEdgeFaceIntersection..::.SetFaceReference Method
PointOnEdgeFaceIntersection Class See Also Send Feedback
Change the face reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetFaceReference(
    Reference reference
)
Visual Basic (Declaration)
Public Sub SetFaceReference ( _
    reference As Reference _
)
Visual C++
public:
void SetFaceReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.Geometry..::.Reference

Remarks

The referenced element may be any model element, including FamilyInstance or FormElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_SURFACE, and the surface must be of type Plane. The Reference's UVPoint property is ignored.

See Also

PointOnEdgeFaceIntersection Class
Autodesk.Revit.Elements Namespace


PointOnEdgeFaceIntersection Properties

[image] [image]

Revit 2010 API
PointOnEdgeFaceIntersection Properties
PointOnEdgeFaceIntersection Class See Also Send Feedback

The PointOnEdgeFaceIntersection type exposes the following members.

Properties

Name | Description
OrientWithEdge | Whether to orient the ReferencePoint to the edge or the face.

See Also

PointOnEdgeFaceIntersection Class
Autodesk.Revit.Elements Namespace


OrientWithEdge Property

[image]

Revit 2010 API
PointOnEdgeFaceIntersection..::.OrientWithEdge Property
PointOnEdgeFaceIntersection Class See Also Send Feedback
Whether to orient the ReferencePoint to the edge or the face.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool OrientWithEdge { get; set; }
Visual Basic (Declaration)
Public Property OrientWithEdge As Boolean
Visual C++
public:
property bool OrientWithEdge {
    bool get ();
    void set (bool value);
}

Remarks

If true, the X basis vector will be parallel to the edge. If false, the X and Y basis vectors will be parallel to the face.

See Also

PointOnEdgeFaceIntersection Class
Autodesk.Revit.Elements Namespace


PointOnFace Class

[image]

Revit 2010 API
PointOnFace Class
Members See Also Send Feedback
Define a ReferencePoint relative to a Face.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PointOnFace : PointElementReference
Visual Basic (Declaration)
Public Class PointOnFace _
    Inherits PointElementReference
Visual C++
public ref class PointOnFace : public PointElementReference

Remarks

A ReferencePoint on a Face has its X and Y basis vectors parallel to the Face, but is free to rotate around its Z basis vector. It must lie on the face (unlike PointOnPlane).

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Elements..::.PointElementReference
Autodesk.Revit.Elements..::.PointOnFace

See Also

PointOnFace Members
Autodesk.Revit.Elements Namespace


PointOnFace Members

[image] [image]

Revit 2010 API
PointOnFace Members
PointOnFace Class Methods Properties See Also Send Feedback

The PointOnFace type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetFaceReference | Get a copy of the face reference.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetFaceReference | Change the face reference.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
UV | The location of the point in the surface's coordinate system.

See Also

PointOnFace Class
Autodesk.Revit.Elements Namespace


PointOnFace Methods

[image] [image]

Revit 2010 API
PointOnFace Methods
PointOnFace Class See Also Send Feedback

The PointOnFace type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetFaceReference | Get a copy of the face reference.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetFaceReference | Change the face reference.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointOnFace Class
Autodesk.Revit.Elements Namespace


GetFaceReference Method

[image]

Revit 2010 API
PointOnFace..::.GetFaceReference Method
PointOnFace Class See Also Send Feedback
Get a copy of the face reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference GetFaceReference()
Visual Basic (Declaration)
Public Function GetFaceReference As Reference
Visual C++
public:
Reference^ GetFaceReference()

See Also

PointOnFace Class
Autodesk.Revit.Elements Namespace


SetFaceReference Method

[image]

Revit 2010 API
PointOnFace..::.SetFaceReference Method
PointOnFace Class See Also Send Feedback
Change the face reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetFaceReference(
    Reference reference
)
Visual Basic (Declaration)
Public Sub SetFaceReference ( _
    reference As Reference _
)
Visual C++
public:
void SetFaceReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.Geometry..::.Reference

Remarks

The referenced element may be any model element, including FamilyInstance or FormElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_SURFACE, and the surface must be of type Plane. The Reference's UVPoint property is ignored.

See Also

PointOnFace Class
Autodesk.Revit.Elements Namespace


PointOnFace Properties

[image] [image]

Revit 2010 API
PointOnFace Properties
PointOnFace Class See Also Send Feedback

The PointOnFace type exposes the following members.

Properties

Name | Description
UV | The location of the point in the surface's coordinate system.

See Also

PointOnFace Class
Autodesk.Revit.Elements Namespace


UV Property

[image]

Revit 2010 API
PointOnFace..::.UV Property
PointOnFace Class See Also Send Feedback
The location of the point in the surface's coordinate system.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV UV { get; set; }
Visual Basic (Declaration)
Public Property UV As UV
Visual C++
public:
property UV^ UV {
    UV^ get ();
    void set (UV^ value);
}

See Also

PointOnFace Class
Autodesk.Revit.Elements Namespace


PointOnPlane Class

[image]

Revit 2010 API
PointOnPlane Class
Members See Also Send Feedback
Define a ReferencePoint relative to a planar reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PointOnPlane : PointElementReference
Visual Basic (Declaration)
Public Class PointOnPlane _
    Inherits PointElementReference
Visual C++
public ref class PointOnPlane : public PointElementReference

Remarks

A ReferencePoint on a plane has its X and Y basis vectors parallel to the plane, but is free to rotate around its Z basis vector. It can lie on the plane or have an offset.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Elements..::.PointElementReference
Autodesk.Revit.Elements..::.PointOnPlane

See Also

PointOnPlane Members
Autodesk.Revit.Elements Namespace


PointOnPlane Members

[image] [image]

Revit 2010 API
PointOnPlane Members
PointOnPlane Class Methods Properties See Also Send Feedback

The PointOnPlane type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPlaneReference | The geometric plane reference.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValidPlaneReference | Check whether a geometry reference corresponds to a referenceable plane.
NewPointOnPlane | Construct a PointOnPlane given a reference and a location in space.
SetPlaneReference | Change the geometric plane reference.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Offset | Signed offset from the plane.
Position | The coordinates of the point (or its projection) on the plane.
XVec | The X-coordinate vector of the point, in the plane's coordinate system.

See Also

PointOnPlane Class
Autodesk.Revit.Elements Namespace


PointOnPlane Methods

[image] [image]

Revit 2010 API
PointOnPlane Methods
PointOnPlane Class See Also Send Feedback

The PointOnPlane type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPlaneReference | The geometric plane reference.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValidPlaneReference | Check whether a geometry reference corresponds to a referenceable plane.
NewPointOnPlane | Construct a PointOnPlane given a reference and a location in space.
SetPlaneReference | Change the geometric plane reference.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointOnPlane Class
Autodesk.Revit.Elements Namespace


GetPlaneReference Method

[image]

Revit 2010 API
PointOnPlane..::.GetPlaneReference Method
PointOnPlane Class See Also Send Feedback
The geometric plane reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference GetPlaneReference()
Visual Basic (Declaration)
Public Function GetPlaneReference As Reference
Visual C++
public:
Reference^ GetPlaneReference()

Return Value

A copy of the reference stored in the PointOnPlane object.

See Also

PointOnPlane Class
Autodesk.Revit.Elements Namespace


IsValidPlaneReference Method

[image]

Revit 2010 API
PointOnPlane..::.IsValidPlaneReference Method
PointOnPlane Class See Also Send Feedback
Check whether a geometry reference corresponds to a referenceable plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static bool IsValidPlaneReference(
    Document doc,
    Reference planeReference
)
Visual Basic (Declaration)
Public Shared Function IsValidPlaneReference ( _
    doc As Document, _
    planeReference As Reference _
) As Boolean
Visual C++
public:
static bool IsValidPlaneReference(
    Document^ doc,
    Reference^ planeReference
)

Parameters

doc
Type: Autodesk.Revit..::.Document
planeReference
Type: Autodesk.Revit.Geometry..::.Reference

Remarks

Valid plane references include: planar faces of solids; the PlaneReference properties of Level and SketchPlane; the Reference property of ReferencePlane.

See Also

PointOnPlane Class
Autodesk.Revit.Elements Namespace


NewPointOnPlane Method

[image]

Revit 2010 API
PointOnPlane..::.NewPointOnPlane Method
PointOnPlane Class See Also Send Feedback
Construct a PointOnPlane given a reference and a location in space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static PointOnPlane NewPointOnPlane(
    Document doc,
    Reference planeReference,
    XYZ position,
    XYZ xvec
)
Visual Basic (Declaration)
Public Shared Function NewPointOnPlane ( _
    doc As Document, _
    planeReference As Reference, _
    position As XYZ, _
    xvec As XYZ _
) As PointOnPlane
Visual C++
public:
static PointOnPlane^ NewPointOnPlane(
    Document^ doc,
    Reference^ planeReference,
    XYZ^ position,
    XYZ^ xvec
)

Parameters

doc
Type: Autodesk.Revit..::.Document
The document containing the plane reference.
planeReference
Type: Autodesk.Revit.Geometry..::.Reference
position
Type: Autodesk.Revit.Geometry..::.XYZ
A 3-dimensional position.
xvec
Type: Autodesk.Revit.Geometry..::.XYZ
The direction of the point's X-coordinate vector in the plane's coordinates. Optional; default value is the X-coordinate vector of the plane.

Return Value

A new PointOnPlane object with 2-dimensional Position, XVec, and Offset properties set to match the given 3-dimensional arguments.

See Also

PointOnPlane Class
Autodesk.Revit.Elements Namespace


SetPlaneReference Method

[image]

Revit 2010 API
PointOnPlane..::.SetPlaneReference Method
PointOnPlane Class See Also Send Feedback
Change the geometric plane reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetPlaneReference(
    Reference planeReference
)
Visual Basic (Declaration)
Public Sub SetPlaneReference ( _
    planeReference As Reference _
)
Visual C++
public:
void SetPlaneReference(
    Reference^ planeReference
)

Parameters

planeReference
Type: Autodesk.Revit.Geometry..::.Reference
A reference to some plane in the document. (Note: the reference must satisfy IsValidPlaneReference(), but this is not checked until this PointOnPlane object is assigned to a ReferencePoint.)

See Also

PointOnPlane Class
Autodesk.Revit.Elements Namespace


PointOnPlane Properties

[image] [image]

Revit 2010 API
PointOnPlane Properties
PointOnPlane Class See Also Send Feedback

The PointOnPlane type exposes the following members.

Properties

Name | Description
Offset | Signed offset from the plane.
Position | The coordinates of the point (or its projection) on the plane.
XVec | The X-coordinate vector of the point, in the plane's coordinate system.

See Also

PointOnPlane Class
Autodesk.Revit.Elements Namespace


Offset Property

[image]

Revit 2010 API
PointOnPlane..::.Offset Property
PointOnPlane Class See Also Send Feedback
Signed offset from the plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Offset { get; set; }
Visual Basic (Declaration)
Public Property Offset As Double
Visual C++
public:
property double Offset {
    double get ();
    void set (double value);
}

Remarks

The point's position is offset in the direction of the normal vector returned by the Plane.Normal property.

See Also

PointOnPlane Class
Autodesk.Revit.Elements Namespace


Position Property

[image]

Revit 2010 API
PointOnPlane..::.Position Property
PointOnPlane Class See Also Send Feedback
The coordinates of the point (or its projection) on the plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV Position { get; set; }
Visual Basic (Declaration)
Public Property Position As UV
Visual C++
public:
property UV^ Position {
    UV^ get ();
    void set (UV^ value);
}

See Also

PointOnPlane Class
Autodesk.Revit.Elements Namespace


XVec Property

[image]

Revit 2010 API
PointOnPlane..::.XVec Property
PointOnPlane Class See Also Send Feedback
The X-coordinate vector of the point, in the plane's coordinate system.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV XVec { get; set; }
Visual Basic (Declaration)
Public Property XVec As UV
Visual C++
public:
property UV^ XVec {
    UV^ get ();
    void set (UV^ value);
}

See Also

PointOnPlane Class
Autodesk.Revit.Elements Namespace


PrintSetting Class

[image]

Revit 2010 API
PrintSetting Class
Members See Also Send Feedback
Represents the Print Setup (File->Print Setup...) within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PrintSetting : Element
Visual Basic (Declaration)
Public Class PrintSetting _
    Inherits Element
Visual C++
public ref class PrintSetting : public Element

Remarks

The Print Setup object is derived from the Element object and as such contains all the properties and methods of that object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.PrintSetting

See Also

PrintSetting Members
Autodesk.Revit.Elements Namespace


PrintSetting Members

[image] [image]

Revit 2010 API
PrintSetting Members
PrintSetting Class Constructors Methods Properties See Also Send Feedback

The PrintSetting type exposes the following members.

Constructors

Name | Description
PrintSetting | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns the Name of Print Setup. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PrintParameters | Returns the Parameters of Print Setup.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PrintSetting Class
Autodesk.Revit.Elements Namespace


PrintSetting Constructor

[image]

Revit 2010 API
PrintSetting Constructor
PrintSetting Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PrintSetting()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PrintSetting()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PrintSetting Class
Autodesk.Revit.Elements Namespace


PrintSetting Methods

[image] [image]

Revit 2010 API
PrintSetting Methods
PrintSetting Class See Also Send Feedback

The PrintSetting type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrintSetting Class
Autodesk.Revit.Elements Namespace


PrintSetting Properties

[image] [image]

Revit 2010 API
PrintSetting Properties
PrintSetting Class See Also Send Feedback

The PrintSetting type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns the Name of Print Setup. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PrintParameters | Returns the Parameters of Print Setup.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PrintSetting Class
Autodesk.Revit.Elements Namespace


Name Property

[image]

Revit 2010 API
PrintSetting..::.Name Property
PrintSetting Class See Also Send Feedback
Returns the Name of Print Setup.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { get; set; }
Visual Basic (Declaration)
Public Overrides Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}

Remarks

Retrieve/set the name of Print Setup.

See Also

PrintSetting Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
PrintSetting..::.Parameter Property
PrintSetting Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PrintSetting Class
PrintSetting Members
Autodesk.Revit.Elements Namespace


PrintParameters Property

[image]

Revit 2010 API
PrintSetting..::.PrintParameters Property
PrintSetting Class See Also Send Feedback
Returns the Parameters of Print Setup.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PrintParameters PrintParameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintParameters As PrintParameters
Visual C++
public:
property PrintParameters^ PrintParameters {
    PrintParameters^ get ();
}

Remarks

The Parameters of Print Setup, you can reference the Print Setup dialog in Revit.

See Also

PrintSetting Class
Autodesk.Revit.Elements Namespace


ProfilePlaneLocation Enumeration

[image]

Revit 2010 API
ProfilePlaneLocation Enumeration
See Also Send Feedback
Indicates the location of Sweep profile plane on the path curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ProfilePlaneLocation
Visual Basic (Declaration)
Public Enumeration ProfilePlaneLocation
Visual C++
public enum class ProfilePlaneLocation

Members

Member name | Description
Start | Indicates the profile plane located at the start of the path curve.
MidPoint | Indicates the profile plane located at the Middle point of the path curve.
End | Indicates the profile plane located at the End of the path curve.

Remarks

Use this enum in NewSweep method to create generic forms.

See Also

Autodesk.Revit.Elements Namespace


ProjectInfo Class

[image]

Revit 2010 API
ProjectInfo Class
Members Example See Also Send Feedback
An object that represents a Project Information within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ProjectInfo : Element
Visual Basic (Declaration)
Public Class ProjectInfo _
    Inherits Element
Visual C++
public ref class ProjectInfo : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Examples

CopyC#
ProjectInfo projectInfo = document.ProjectInformation;

if (null != projectInfo)
{
    string message = "Project information:";
    //get the project name
    message += "\nName: " + projectInfo.Name;
    string newName = "My project";
    //set the project name
    projectInfo.Name = newName;
    message += "\nProject Name after set: " + projectInfo.Name;

    //get the project number
    message += "\nNumber: " + projectInfo.Number;
    string newNumber = "TestNumber";
    //set the project number
    projectInfo.Number = newNumber;
    message += "\nProject Number after set: " + projectInfo.Number;

    //get the status of the project
    message += "\nStatus: " + projectInfo.Status;
    string newStatus = "TestStatus";
    //set the project status
    projectInfo.Status = newStatus;
    message += "\nProject status after set: " + projectInfo.Status;

    //get the address of the project
    message += "\nAddress: " + projectInfo.Address;
    string newAddress = "TestAddress";
    //set the project address
    projectInfo.Address = newAddress;
    message += "\nProject address after set: " + projectInfo.Address;

    //get the client name of the project
    message += "\nClient Name: " + projectInfo.ClientName;
    string newClient = "TestClientName";
    //set the client name
    projectInfo.ClientName = newClient;
    message += "\nProject client name after set: " + projectInfo.ClientName;

    //get the gbXmlSetting of the project
    gbXMLParamElem xmlSetting = projectInfo.gbXMLSettings;
    message += "\nBuilding type: " + xmlSetting.BuildingType.ToString();
    message += "\nPostal Code: " + xmlSetting.PostalCode;

    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Dim projectInfo As Autodesk.Revit.Elements.ProjectInfo = document.ProjectInformation

If projectInfo IsNot Nothing Then
    Dim message As String = "Project information:"
    'get the project name
    message += vbLf & "Name: " & projectInfo.Name
    Dim newName As String = "My project"
    'set the project name
    projectInfo.Name = newName
    message += vbLf & "Project Name after set: " & projectInfo.Name

    'get the project number
    message += vbLf & "Number: " & projectInfo.Number
    Dim newNumber As String = "TestNumber"
    'set the project number
    projectInfo.Number = newNumber
    message += vbLf & "Project Number after set: " & projectInfo.Number

    'get the status of the project
    message += vbLf & "Status: " & projectInfo.Status
    Dim newStatus As String = "TestStatus"
    'set the project status
    projectInfo.Status = newStatus
    message += vbLf & "Project status after set: " & projectInfo.Status

    'get the address of the project
    message += vbLf & "Address: " & projectInfo.Address
    Dim newAddress As String = "TestAddress"
    'set the project address
    projectInfo.Address = newAddress
    message += vbLf & "Project address after set: " & projectInfo.Address

    'get the client name of the project
    message += vbLf & "Client Name: " & projectInfo.ClientName
    Dim newClient As String = "TestClientName"
    'set the client name
    projectInfo.ClientName = newClient
    message += vbLf & "Project client name after set: " & projectInfo.ClientName

    'get the gbXmlSetting of the project
    Dim xmlSetting As Autodesk.Revit.Elements.gbXMLParamElem = projectInfo.gbXMLSettings
    message += vbLf & "Building type: " & xmlSetting.BuildingType.ToString()
    message += vbLf & "Postal Code: " & xmlSetting.PostalCode

    MessageBox.Show(message, "Revit")
End If

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.ProjectInfo

See Also

ProjectInfo Members
Autodesk.Revit.Elements Namespace


ProjectInfo Members

[image] [image]

Revit 2010 API
ProjectInfo Members
ProjectInfo Class Constructors Methods Properties See Also Send Feedback

The ProjectInfo type exposes the following members.

Constructors

Name | Description
ProjectInfo | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Address | Get or Set the Project Address of the Project Information.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ClientName | Get or Set the Client Name of the Project Information.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
gbXMLSettings | Get the gbXML Settings of the Project Information.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IssueDate | Get or Set the Project Issue Date of the Project Information.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get or Set the Project Name of the Project Information.
Number | Get or Set the Project Number of the Project Information.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Status | Get or Set the Project Status of the Project Information.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ProjectInfo Class
Autodesk.Revit.Elements Namespace


ProjectInfo Constructor

[image]

Revit 2010 API
ProjectInfo Constructor
ProjectInfo Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProjectInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProjectInfo()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ProjectInfo Class
Autodesk.Revit.Elements Namespace


ProjectInfo Methods

[image] [image]

Revit 2010 API
ProjectInfo Methods
ProjectInfo Class See Also Send Feedback

The ProjectInfo type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProjectInfo Class
Autodesk.Revit.Elements Namespace


ProjectInfo Properties

[image] [image]

Revit 2010 API
ProjectInfo Properties
ProjectInfo Class See Also Send Feedback

The ProjectInfo type exposes the following members.

Properties

Name | Description
Address | Get or Set the Project Address of the Project Information.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ClientName | Get or Set the Client Name of the Project Information.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
gbXMLSettings | Get the gbXML Settings of the Project Information.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IssueDate | Get or Set the Project Issue Date of the Project Information.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get or Set the Project Name of the Project Information.
Number | Get or Set the Project Number of the Project Information.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Status | Get or Set the Project Status of the Project Information.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ProjectInfo Class
Autodesk.Revit.Elements Namespace


Address Property

[image]

Revit 2010 API
ProjectInfo..::.Address Property
ProjectInfo Class See Also Send Feedback
Get or Set the Project Address of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Address { get; set; }
Visual Basic (Declaration)
Public Property Address As String
Visual C++
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Address of the Project Information.

See Also

ProjectInfo Class
Autodesk.Revit.Elements Namespace


ClientName Property

[image]

Revit 2010 API
ProjectInfo..::.ClientName Property
ProjectInfo Class See Also Send Feedback
Get or Set the Client Name of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string ClientName { get; set; }
Visual Basic (Declaration)
Public Property ClientName As String
Visual C++
public:
property String^ ClientName {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Client Name of the Project Information.

See Also

ProjectInfo Class
Autodesk.Revit.Elements Namespace


gbXMLSettings Property

[image]

Revit 2010 API
ProjectInfo..::.gbXMLSettings Property
ProjectInfo Class See Also Send Feedback
Get the gbXML Settings of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public gbXMLParamElem gbXMLSettings { get; }
Visual Basic (Declaration)
Public ReadOnly Property gbXMLSettings As gbXMLParamElem
Visual C++
public:
property gbXMLParamElem^ gbXMLSettings {
    gbXMLParamElem^ get ();
}

Remarks

This property is used to get or set the Project gbXML Settings of the Project Information.

See Also

ProjectInfo Class
Autodesk.Revit.Elements Namespace


IssueDate Property

[image]

Revit 2010 API
ProjectInfo..::.IssueDate Property
ProjectInfo Class See Also Send Feedback
Get or Set the Project Issue Date of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string IssueDate { get; set; }
Visual Basic (Declaration)
Public Property IssueDate As String
Visual C++
public:
property String^ IssueDate {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Issue Date of the Project Information.

See Also

ProjectInfo Class
Autodesk.Revit.Elements Namespace


Name Property

[image]

Revit 2010 API
ProjectInfo..::.Name Property
ProjectInfo Class See Also Send Feedback
Get or Set the Project Name of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Name of the Project Information.

See Also

ProjectInfo Class
Autodesk.Revit.Elements Namespace


Number Property

[image]

Revit 2010 API
ProjectInfo..::.Number Property
ProjectInfo Class See Also Send Feedback
Get or Set the Project Number of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Number { get; set; }
Visual Basic (Declaration)
Public Property Number As String
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Number of the Project Information.

See Also

ProjectInfo Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
ProjectInfo..::.Parameter Property
ProjectInfo Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ProjectInfo Class
ProjectInfo Members
Autodesk.Revit.Elements Namespace


Status Property

[image]

Revit 2010 API
ProjectInfo..::.Status Property
ProjectInfo Class See Also Send Feedback
Get or Set the Project Status of the Project Information.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Status { get; set; }
Visual Basic (Declaration)
Public Property Status As String
Visual C++
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Status of the Project Information.

See Also

ProjectInfo Class
Autodesk.Revit.Elements Namespace


ProjectUnit Class

[image]

Revit 2010 API
ProjectUnit Class
Members Example See Also Send Feedback
Provides access to the Project Unit... in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ProjectUnit : Element
Visual Basic (Declaration)
Public Class ProjectUnit _
    Inherits Element
Visual C++
public ref class ProjectUnit : public Element

Remarks

The ProjectUnit object can be queried for its D in space planning tools.

Examples

CopyC#
ProjectUnit projectUnit = document.ProjectUnit;

if (null != projectUnit)
{
    string message = "Project Unit: ";

    //get the DecimalSymbolType
    message += "\nDecimal Symbol Type: " + projectUnit.DecimalSymbolType.ToString();

    //show the usage for FormatOptions property
    message += "\nFormat Options: ";
    FormatOptions formatOptions = projectUnit.get_FormatOptions(Autodesk.Revit.Enums.UnitType.UT_Length);
    message += "\n\tLength : " + formatOptions.Name;
    formatOptions = projectUnit.get_FormatOptions(Autodesk.Revit.Enums.UnitType.UT_Volume);
    message += "\n\tVolume : " + formatOptions.Name;

    //get the Digit Grouping Amount of the project
    Autodesk.Revit.Enums.DigitGroupingAmount dga = projectUnit.DigitGroupingAmount;
    message += "\nDigit Grouping Amount: " + dga.ToString();

    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Dim projectUnit As ProjectUnit = document.ProjectUnit

If projectUnit IsNot Nothing Then
    Dim message As String = "Project Unit: "

    'get the DecimalSymbolType
    message += vbLf & "Decimal Symbol Type: " & projectUnit.DecimalSymbolType.ToString()

    'show the usage for FormatOptions property
    message += vbLf & "Format Options: "
    Dim formatOptions As Autodesk.Revit.FormatOptions = projectUnit.FormatOptions(Autodesk.Revit.Enums.UnitType.UT_Length)
    message += vbLf & vbTab & "Length : " & formatOptions.Name
    formatOptions = projectUnit.FormatOptions(Autodesk.Revit.Enums.UnitType.UT_Volume)
    message += vbLf & vbTab & "Volume : " & formatOptions.Name

    'get the Digit Grouping Amount of the project
    Dim dga As Autodesk.Revit.Enums.DigitGroupingAmount = projectUnit.DigitGroupingAmount
    message += vbLf & "Digit Grouping Amount: " & dga.ToString()

    MessageBox.Show(message, "Revit")
End If

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.ProjectUnit

See Also

ProjectUnit Members
Autodesk.Revit.Elements Namespace


ProjectUnit Members

[image] [image]

Revit 2010 API
ProjectUnit Members
ProjectUnit Class Constructors Methods Properties See Also Send Feedback

The ProjectUnit type exposes the following members.

Constructors

Name | Description
ProjectUnit | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
setDigitGroupingType | Set the Digit Grouping Amount, using the three types
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DecimalSymbolType | Get the Decimal Symbol type of Project Unit Settings.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DigitGroupingAmount | Get the Digit Grouping Amount of Project Unit Settings.
DigitGroupingSymbolType | Get the Digit Grouping Symbol type of Project Unit Settings.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FormatOptions | Get the Format Options of the Project Unit Settings.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ProjectUnit Class
Autodesk.Revit.Elements Namespace


ProjectUnit Constructor

[image]

Revit 2010 API
ProjectUnit Constructor
ProjectUnit Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProjectUnit()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProjectUnit()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ProjectUnit Class
Autodesk.Revit.Elements Namespace


ProjectUnit Methods

[image] [image]

Revit 2010 API
ProjectUnit Methods
ProjectUnit Class See Also Send Feedback

The ProjectUnit type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
setDigitGroupingType | Set the Digit Grouping Amount, using the three types
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProjectUnit Class
Autodesk.Revit.Elements Namespace


setDigitGroupingType Method

[image]

Revit 2010 API
ProjectUnit..::.setDigitGroupingType Method
ProjectUnit Class See Also Send Feedback
Set the Digit Grouping Amount, using the three types

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void setDigitGroupingType(
    DecimalSymbolType dst,
    DigitGroupingSymbolType dgst,
    DigitGroupingAmount dga
)
Visual Basic (Declaration)
Public Sub setDigitGroupingType ( _
    dst As DecimalSymbolType, _
    dgst As DigitGroupingSymbolType, _
    dga As DigitGroupingAmount _
)
Visual C++
public:
void setDigitGroupingType(
    DecimalSymbolType dst,
    DigitGroupingSymbolType dgst,
    DigitGroupingAmount dga
)

Parameters

dst
Type: Autodesk.Revit.Enums..::.DecimalSymbolType
dgst
Type: Autodesk.Revit.Enums..::.DigitGroupingSymbolType
dga
Type: Autodesk.Revit.Enums..::.DigitGroupingAmount

See Also

ProjectUnit Class
Autodesk.Revit.Elements Namespace


ProjectUnit Properties

[image] [image]

Revit 2010 API
ProjectUnit Properties
ProjectUnit Class See Also Send Feedback

The ProjectUnit type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DecimalSymbolType | Get the Decimal Symbol type of Project Unit Settings.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DigitGroupingAmount | Get the Digit Grouping Amount of Project Unit Settings.
DigitGroupingSymbolType | Get the Digit Grouping Symbol type of Project Unit Settings.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FormatOptions | Get the Format Options of the Project Unit Settings.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ProjectUnit Class
Autodesk.Revit.Elements Namespace


DecimalSymbolType Property

[image]

Revit 2010 API
ProjectUnit..::.DecimalSymbolType Property
ProjectUnit Class See Also Send Feedback
Get the Decimal Symbol type of Project Unit Settings.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DecimalSymbolType DecimalSymbolType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DecimalSymbolType As DecimalSymbolType
Visual C++
public:
property DecimalSymbolType DecimalSymbolType {
    DecimalSymbolType get ();
}

Return Value

The type of the Decimal Symbol.

Remarks

The property only applies to parameters of value types. If the parameter is not a value, the get method returns Revit::Enums::DecimalSymbolType::DST_DOT.

See Also

ProjectUnit Class
Autodesk.Revit.Elements Namespace


DigitGroupingAmount Property

[image]

Revit 2010 API
ProjectUnit..::.DigitGroupingAmount Property
ProjectUnit Class See Also Send Feedback
Get the Digit Grouping Amount of Project Unit Settings.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DigitGroupingAmount DigitGroupingAmount { get; }
Visual Basic (Declaration)
Public ReadOnly Property DigitGroupingAmount As DigitGroupingAmount
Visual C++
public:
property DigitGroupingAmount DigitGroupingAmount {
    DigitGroupingAmount get ();
}

Return Value

The type of the Digit Grouping Amount.

Remarks

The property only applies to parameters of value types. If the parameter is not a value, the get method returns Revit::Enums::DigitGroupingAmount::DGA_THREE.

See Also

ProjectUnit Class
Autodesk.Revit.Elements Namespace


DigitGroupingSymbolType Property

[image]

Revit 2010 API
ProjectUnit..::.DigitGroupingSymbolType Property
ProjectUnit Class See Also Send Feedback
Get the Digit Grouping Symbol type of Project Unit Settings.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DigitGroupingSymbolType DigitGroupingSymbolType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DigitGroupingSymbolType As DigitGroupingSymbolType
Visual C++
public:
property DigitGroupingSymbolType DigitGroupingSymbolType {
    DigitGroupingSymbolType get ();
}

Return Value

The type of the Digit Grouping Symbol.

Remarks

The property only applies to parameters of value types. If the parameter is not a value, the get method returns Revit::Enums::DigitGroupingSymbolType::DGST_COMMA.

See Also

ProjectUnit Class
Autodesk.Revit.Elements Namespace


FormatOptions Property

[image]

Revit 2010 API
ProjectUnit..::.FormatOptions Property
ProjectUnit Class See Also Send Feedback
Get the Format Options of the Project Unit Settings.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FormatOptions FormatOptions[
    UnitType ut
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property FormatOptions ( _
    ut As UnitType _
) As FormatOptions
Visual C++
public:
property FormatOptions^ FormatOptions[UnitType ut] {
    FormatOptions^ get (UnitType ut);
}

Parameters

ut
Type: Autodesk.Revit.Enums..::.UnitType

Remarks

.

See Also

ProjectUnit Class
Autodesk.Revit.Elements Namespace


Name Property

[image]

Revit 2010 API
ProjectUnit..::.Name Property
ProjectUnit Class See Also Send Feedback
Get and Set the Name property

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The method set is override to forbid the user to change the Name. When the user tries to call the method set for ProjectUnit object, an InvalidOperationException will be thrown.

See Also

ProjectUnit Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
ProjectUnit..::.Parameter Property
ProjectUnit Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ProjectUnit Class
ProjectUnit Members
Autodesk.Revit.Elements Namespace


PropertyLine Class

[image]

Revit 2010 API
PropertyLine Class
Members See Also Send Feedback
Represents kinds of PropertyLines.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PropertyLine : Element
Visual Basic (Declaration)
Public Class PropertyLine _
    Inherits Element
Visual C++
public ref class PropertyLine : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.PropertyLine

See Also

PropertyLine Members
Autodesk.Revit.Elements Namespace


PropertyLine Members

[image] [image]

Revit 2010 API
PropertyLine Members
PropertyLine Class Constructors Methods Properties See Also Send Feedback

The PropertyLine type exposes the following members.

Constructors

Name | Description
PropertyLine | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PropertyLine Class
Autodesk.Revit.Elements Namespace


PropertyLine Constructor

[image]

Revit 2010 API
PropertyLine Constructor
PropertyLine Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PropertyLine()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PropertyLine()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PropertyLine Class
Autodesk.Revit.Elements Namespace


PropertyLine Methods

[image] [image]

Revit 2010 API
PropertyLine Methods
PropertyLine Class See Also Send Feedback

The PropertyLine type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PropertyLine Class
Autodesk.Revit.Elements Namespace


PropertyLine Properties

[image] [image]

Revit 2010 API
PropertyLine Properties
PropertyLine Class See Also Send Feedback

The PropertyLine type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PropertyLine Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
PropertyLine..::.Parameter Property
PropertyLine Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PropertyLine Class
PropertyLine Members
Autodesk.Revit.Elements Namespace


RadialArray Class

[image]

Revit 2010 API
RadialArray Class
Members See Also Send Feedback
An object that represents an Array created radially within the Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RadialArray : BaseArray
Visual Basic (Declaration)
Public Class RadialArray _
    Inherits BaseArray
Visual C++
public ref class RadialArray : public BaseArray

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.BaseArray
Autodesk.Revit.Elements..::.RadialArray

See Also

RadialArray Members
Autodesk.Revit.Elements Namespace


RadialArray Members

[image] [image]

Revit 2010 API
RadialArray Members
RadialArray Class Constructors Methods Properties See Also Send Feedback

The RadialArray type exposes the following members.

Constructors

Name | Description
RadialArray | Initializes a new instance of the RadialArray class

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CopyMembers | Retrieve the copied members of the Array. (Overrides BaseArray..::.CopyMembers.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from BaseArray.)
NumMembers | Retrieve or Change the number of the arrayed members. (Overrides BaseArray..::.NumMembers.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
OrigMembers | Retrieve the original members of the Array. (Overrides BaseArray..::.OrigMembers.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RadialArray Class
Autodesk.Revit.Elements Namespace


RadialArray Constructor

[image]

Revit 2010 API
RadialArray Constructor
RadialArray Class See Also Send Feedback
Initializes a new instance of the RadialArray class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RadialArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadialArray()

See Also

RadialArray Class
Autodesk.Revit.Elements Namespace


RadialArray Methods

[image] [image]

Revit 2010 API
RadialArray Methods
RadialArray Class See Also Send Feedback

The RadialArray type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RadialArray Class
Autodesk.Revit.Elements Namespace


RadialArray Properties

[image] [image]

Revit 2010 API
RadialArray Properties
RadialArray Class See Also Send Feedback

The RadialArray type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CopyMembers | Retrieve the copied members of the Array. (Overrides BaseArray..::.CopyMembers.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from BaseArray.)
NumMembers | Retrieve or Change the number of the arrayed members. (Overrides BaseArray..::.NumMembers.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
OrigMembers | Retrieve the original members of the Array. (Overrides BaseArray..::.OrigMembers.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RadialArray Class
Autodesk.Revit.Elements Namespace


CopyMembers Property

[image]

Revit 2010 API
RadialArray..::.CopyMembers Property
RadialArray Class See Also Send Feedback
Retrieve the copied members of the Array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override ElementArray CopyMembers { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CopyMembers As ElementArray
Visual C++
public:
virtual property ElementArray^ CopyMembers {
    ElementArray^ get () override;
}

See Also

RadialArray Class
Autodesk.Revit.Elements Namespace


NumMembers Property

[image]

Revit 2010 API
RadialArray..::.NumMembers Property
RadialArray Class See Also Send Feedback
Retrieve or Change the number of the arrayed members.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override int NumMembers { get; set; }
Visual Basic (Declaration)
Public Overrides Property NumMembers As Integer
Visual C++
public:
virtual property int NumMembers {
    int get () override;
    void set (int value) override;
}

See Also

RadialArray Class
Autodesk.Revit.Elements Namespace


OrigMembers Property

[image]

Revit 2010 API
RadialArray..::.OrigMembers Property
RadialArray Class See Also Send Feedback
Retrieve the original members of the Array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override ElementArray OrigMembers { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property OrigMembers As ElementArray
Visual C++
public:
virtual property ElementArray^ OrigMembers {
    ElementArray^ get () override;
}

See Also

RadialArray Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
RadialArray..::.Parameter Property
RadialArray Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

RadialArray Class
RadialArray Members
Autodesk.Revit.Elements Namespace


Rebar Class

[image]

Revit 2010 API
Rebar Class
Members Example See Also Send Feedback
An object that represents Rebar.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Rebar : Element
Visual Basic (Declaration)
Public Class Rebar _
    Inherits Element
Visual C++
public ref class Rebar : public Element

Examples

CopyC#
private void Getinfo_Rebar(Rebar rebar)
{
    string message = "Rebar: ";
    //get the bat type of the rebar
    message += "\nBar Type: " + rebar.BarType.Name;

    //get the curve information
    CurveArray curves = rebar.Curves;
    message += "\n\nThe Curves property has " + curves.Size + " curves:";
    foreach (Curve curve in curves)
    {
        // Get curve start point
        message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
            + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        // Get curve end point
        message += "; Curve end point:(" + curve.get_EndPoint(1).X + ", "
            + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
    }

    //get the host element of the rebar
    if (null != rebar.Host) //maybe some rebars don't have host
    {
        message += "\n\nThe host element ID : " + rebar.Host.Id.Value;
    }

    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Private Sub Getinfo_Rebar(ByVal rebar As Autodesk.Revit.Elements.Rebar)
    Dim message As String = "Rebar: "
    'get the bat type of the rebar
    message += vbLf & "Bar Type: " & rebar.BarType.Name

    'get the curve information
    Dim curves As CurveArray = rebar.Curves
    message += vbLf & vbLf & "The Curves property has " & curves.Size & " curves:"
    For Each curve As Curve In curves
        ' Get curve start point
        message += ((vbLf & "Curve start point:(" & curve.EndPoint(0).X & ", ") + curve.EndPoint(0).Y & ", ") + curve.EndPoint(0).Z & ")"
        ' Get curve end point
        message += (("; Curve end point:(" & curve.EndPoint(1).X & ", ") + curve.EndPoint(1).Y & ", ") + curve.EndPoint(1).Z & ")"
    Next

    'get the host element of the rebar
    If rebar.Host IsNot Nothing Then
        'maybe some rebars don't have host
        message += vbLf & vbLf & "The host element ID : " & rebar.Host.Id.Value
    End If

    MessageBox.Show(message, "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Rebar

See Also

Rebar Members
Autodesk.Revit.Elements Namespace


Rebar Members

[image] [image]

Revit 2010 API
Rebar Members
Rebar Class Constructors Methods Properties See Also Send Feedback

The Rebar type exposes the following members.

Constructors

Name | Description
Rebar | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ScaleToBox | Move and resize the bar to fit within a specified box.
SetLayoutRuleWithoutExaminingHost | Change the parameter REBAR_ELEM_LAYOUT_RULE, but extend the set in the direction of the plane's normal, instead of towards the center of the host.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ArrayLength | For Rebar with an array layout, return the length of the distribution path.
BarType | Return the type of the rebar.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curves | The centerline of the Rebar.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DistributionPath | For Rebar with an array layout, return the distribution path (a line).
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Host | The element that contains the rebar.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsShownInFrontOfGeometryInView | Control placement of the rebar graphics in the viewing planes.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RebarShape | Get/Set the RebarShape associated with the Rebar.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


Rebar Constructor

[image]

Revit 2010 API
Rebar Constructor
Rebar Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Rebar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Rebar()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


Rebar Methods

[image] [image]

Revit 2010 API
Rebar Methods
Rebar Class See Also Send Feedback

The Rebar type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ScaleToBox | Move and resize the bar to fit within a specified box.
SetLayoutRuleWithoutExaminingHost | Change the parameter REBAR_ELEM_LAYOUT_RULE, but extend the set in the direction of the plane's normal, instead of towards the center of the host.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


ScaleToBox Method

[image]

Revit 2010 API
Rebar..::.ScaleToBox Method
Rebar Class See Also Send Feedback
Move and resize the bar to fit within a specified box.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ScaleToBox(
    XYZ origin,
    XYZ xVec,
    XYZ yVec
)
Visual Basic (Declaration)
Public Sub ScaleToBox ( _
    origin As XYZ, _
    xVec As XYZ, _
    yVec As XYZ _
)
Visual C++
public:
void ScaleToBox(
    XYZ^ origin,
    XYZ^ xVec,
    XYZ^ yVec
)

Parameters

origin
Type: Autodesk.Revit.Geometry..::.XYZ
One corner of the rectangle.
xVec
Type: Autodesk.Revit.Geometry..::.XYZ
Vector representing the first edge of the rectangle. The length must be positive.
yVec
Type: Autodesk.Revit.Geometry..::.XYZ
Vector representing the second edge of the rectangle. Must be perpendicular to xVec.

Remarks

The arguments are interpreted as an arbitrary rectangle in 3D with vertices: origin, origin+xVec, origin+xVec+yVec, origin+yVec. The algorithm then proceeds as follows. First the bar is given the default values of the shape parameters from the shape definition. Then, if it is possible to do so without violating the shape definition, the parameter values are scaled so that the width and height of the shape match the lengths of xVec and yVec. If there is no way to do this within the shape definition due to overconstraining, a compromise is attempted, such as scaling the whole shape until either the width or the height is correct. Finally the shape is rotated to match the coordinate system of the box. The algorithm is the same one used in one-click placement.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


SetLayoutRuleWithoutExaminingHost Method

[image]

Revit 2010 API
Rebar..::.SetLayoutRuleWithoutExaminingHost Method
Rebar Class See Also Send Feedback
Change the parameter REBAR_ELEM_LAYOUT_RULE, but extend the set in the direction of the plane's normal, instead of towards the center of the host.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetLayoutRuleWithoutExaminingHost(
    RebarLayoutRule layoutRule
)
Visual Basic (Declaration)
Public Sub SetLayoutRuleWithoutExaminingHost ( _
    layoutRule As RebarLayoutRule _
)
Visual C++
public:
void SetLayoutRuleWithoutExaminingHost(
    RebarLayoutRule layoutRule
)

Parameters

layoutRule
Type: Autodesk.Revit.Structural.Enums..::.RebarLayoutRule
Define the rule used to layout the rebar.

Remarks

Changing the parameter REBAR_ELEM_LAYOUT_RULE attempts to extend the rebar set towards the center of the host, but depending on geometrical conditions, it can make the wrong decision. This function changes the layout rule while suppressing the geometric test for the direction of the set. The difference in behavior only occurs when changing the layout rule from None (0) to one of the other settings.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


Rebar Properties

[image] [image]

Revit 2010 API
Rebar Properties
Rebar Class See Also Send Feedback

The Rebar type exposes the following members.

Properties

Name | Description
ArrayLength | For Rebar with an array layout, return the length of the distribution path.
BarType | Return the type of the rebar.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curves | The centerline of the Rebar.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DistributionPath | For Rebar with an array layout, return the distribution path (a line).
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Host | The element that contains the rebar.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsShownInFrontOfGeometryInView | Control placement of the rebar graphics in the viewing planes.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RebarShape | Get/Set the RebarShape associated with the Rebar.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


ArrayLength Property

[image]

Revit 2010 API
Rebar..::.ArrayLength Property
Rebar Class See Also Send Feedback
For Rebar with an array layout, return the length of the distribution path.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ArrayLength { get; set; }
Visual Basic (Declaration)
Public Property ArrayLength As Double
Visual C++
public:
property double ArrayLength {
    double get ();
    void set (double value);
}

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


BarType Property

[image]

Revit 2010 API
Rebar..::.BarType Property
Rebar Class See Also Send Feedback
Return the type of the rebar.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarBarType BarType { get; set; }
Visual Basic (Declaration)
Public Property BarType As RebarBarType
Visual C++
public:
property RebarBarType^ BarType {
    RebarBarType^ get ();
    void set (RebarBarType^ value);
}

Remarks

Returns a RebarBarType element that defines bar diameter and bend radius for the rebar.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


Curves Property

[image]

Revit 2010 API
Rebar..::.Curves Property
Rebar Class See Also Send Feedback
The centerline of the Rebar.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray Curves { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

Remarks

These curves represent the centerline of the rebar, including the hooks and bends. They are the curves shown in Revit views at the coarse detail level.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


DistributionPath Property

[image]

Revit 2010 API
Rebar..::.DistributionPath Property
Rebar Class See Also Send Feedback
For Rebar with an array layout, return the distribution path (a line).

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve DistributionPath { get; }
Visual Basic (Declaration)
Public ReadOnly Property DistributionPath As Curve
Visual C++
public:
property Curve^ DistributionPath {
    Curve^ get ();
}

Remarks

This creates a new curve.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


Host Property

[image]

Revit 2010 API
Rebar..::.Host Property
Rebar Class See Also Send Feedback
The element that contains the rebar.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element Host { get; set; }
Visual Basic (Declaration)
Public Property Host As Element
Visual C++
public:
property Element^ Host {
    Element^ get ();
    void set (Element^ value);
}

Remarks

Returns the Autodesk Revit element that the rebar object belongs to, such as a structural wall, floor, foundation, beam, brace or column.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


IsShownInFrontOfGeometryInView Property

[image]

Revit 2010 API
Rebar..::.IsShownInFrontOfGeometryInView Property
Rebar Class See Also Send Feedback
Control placement of the rebar graphics in the viewing planes.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsShownInFrontOfGeometryInView[
    View dbView
] { get; set; }
Visual Basic (Declaration)
Public Property IsShownInFrontOfGeometryInView ( _
    dbView As View _
) As Boolean
Visual C++
public:
property bool IsShownInFrontOfGeometryInView[View^ dbView] {
    bool get (View^ dbView);
    void set (View^ dbView, bool value);
}

Parameters

dbView
Type: Autodesk.Revit.Elements..::.View

Remarks

Control whether the graphics are shown in front of the geometry in a view.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Rebar..::.Parameter Property
Rebar Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Rebar Class
Rebar Members
Autodesk.Revit.Elements Namespace


RebarShape Property

[image]

Revit 2010 API
Rebar..::.RebarShape Property
Rebar Class See Also Send Feedback
Get/Set the RebarShape associated with the Rebar.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarShape RebarShape { get; set; }
Visual Basic (Declaration)
Public Property RebarShape As RebarShape
Visual C++
public:
property RebarShape^ RebarShape {
    RebarShape^ get ();
    void set (RebarShape^ value);
}

Remarks

When set, the instance will choose values for its shape parameters to try to preserve its previous shape.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace


RebarHostData Class

[image]

Revit 2010 API
RebarHostData Class
Members See Also Send Feedback
Interface to rebar-specific data stored in each valid rebar host element. The cover parameters listed below are an alternative interface to the CoverType property. Each parameter simply gets or sets the cover setting associated with one or more particular faces of the host: CLEAR_COVER_EXTERIOR (walls only) CLEAR_COVER_INTERIOR (walls only) CLEAR_COVER_OTHER (all hosts except in-place families and stairs) CLEAR_COVER (in-place families and stairs) CLEAR_COVER_TOP (all hosts except walls, in-place families, and stairs) CLEAR_COVER_BOTTOM (all hosts except walls, in-place families, and stairs) RebarHostData can only be created by the factory function "getRebarHostData()" applied to an element that can be a rebar host.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RebarHostData : APIObject
Visual Basic (Declaration)
Public Class RebarHostData _
    Inherits APIObject
Visual C++
public ref class RebarHostData : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.RebarHostData

See Also

RebarHostData Members
Autodesk.Revit.Elements Namespace


RebarHostData Members

[image] [image]

Revit 2010 API
RebarHostData Members
RebarHostData Class Constructors Methods Properties See Also Send Feedback

The RebarHostData type exposes the following members.

Constructors

Name | Description
RebarHostData | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
getRebarHostData | Gets a RebarHostData object referring to the specified rebar host element.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasCoverTypeForReference | Checks whether the reference has an associated cover.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CoverType | Gets the RebarCoverType associated with a face of the element.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Valid | Returns whether the element is a valid rebar host.

See Also

RebarHostData Class
Autodesk.Revit.Elements Namespace


RebarHostData Constructor

[image]

Revit 2010 API
RebarHostData Constructor
RebarHostData Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarHostData()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarHostData()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarHostData Class
Autodesk.Revit.Elements Namespace


RebarHostData Methods

[image] [image]

Revit 2010 API
RebarHostData Methods
RebarHostData Class See Also Send Feedback

The RebarHostData type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
getRebarHostData | Gets a RebarHostData object referring to the specified rebar host element.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasCoverTypeForReference | Checks whether the reference has an associated cover.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarHostData Class
Autodesk.Revit.Elements Namespace


getRebarHostData Method

[image]

Revit 2010 API
RebarHostData..::.getRebarHostData Method
RebarHostData Class See Also Send Feedback
Gets a RebarHostData object referring to the specified rebar host element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static RebarHostData getRebarHostData(
    Element host
)
Visual Basic (Declaration)
Public Shared Function getRebarHostData ( _
    host As Element _
) As RebarHostData
Visual C++
public:
static RebarHostData^ getRebarHostData(
    Element^ host
)

Parameters

host
Type: Autodesk.Revit..::.Element
An element to host rebar.

Return Value

A RebarHostData object or null.

Remarks

Returns null for elements that cannot ever be rebar hosts, such as levels.

See Also

RebarHostData Class
Autodesk.Revit.Elements Namespace


HasCoverTypeForReference Method

[image]

Revit 2010 API
RebarHostData..::.HasCoverTypeForReference Method
RebarHostData Class See Also Send Feedback
Checks whether the reference has an associated cover.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool HasCoverTypeForReference(
    Reference face
)
Visual Basic (Declaration)
Public Function HasCoverTypeForReference ( _
    face As Reference _
) As Boolean
Visual C++
public:
bool HasCoverTypeForReference(
    Reference^ face
)

Parameters

face
Type: Autodesk.Revit.Geometry..::.Reference
Reference to a geometrical face of the host element.

Return Value

True if the face has an associated RebarCoverType; false if it does not.

Remarks

Only certain references have associated covers. The reference must be a face. Further, certain faces do not have covers, such as the top face of a beam that is joined to a slab, and the treads and risers of Stairs.

See Also

RebarHostData Class
Autodesk.Revit.Elements Namespace


RebarHostData Properties

[image] [image]

Revit 2010 API
RebarHostData Properties
RebarHostData Class See Also Send Feedback

The RebarHostData type exposes the following members.

Properties

Name | Description
CoverType | Gets the RebarCoverType associated with a face of the element.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Valid | Returns whether the element is a valid rebar host.

See Also

RebarHostData Class
Autodesk.Revit.Elements Namespace


CoverType Property

[image]

Revit 2010 API
RebarHostData..::.CoverType Property
RebarHostData Class See Also Send Feedback
Gets the RebarCoverType associated with a face of the element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarCoverType CoverType[
    Reference face
] { get; set; }
Visual Basic (Declaration)
Public Property CoverType ( _
    face As Reference _
) As RebarCoverType
Visual C++
public:
property RebarCoverType^ CoverType[Reference^ face] {
    RebarCoverType^ get (Reference^ face);
    void set (Reference^ face, RebarCoverType^ value);
}

Parameters

face
Type: Autodesk.Revit.Geometry..::.Reference
Reference to a geometrical face of the host element.

Remarks

Only certain references have associated covers. The reference must be a face. Further, certain faces do not have covers, such as the top face of a beam that is joined to a slab, and the treads and risers of Stairs.

See Also

RebarHostData Class
Autodesk.Revit.Elements Namespace


Valid Property

[image]

Revit 2010 API
RebarHostData..::.Valid Property
RebarHostData Class See Also Send Feedback
Returns whether the element is a valid rebar host.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Valid { get; }
Visual Basic (Declaration)
Public ReadOnly Property Valid As Boolean
Visual C++
public:
property bool Valid {
    bool get ();
}

Remarks

If getRebarHostData() returns an invalid RebarHostData, this means that the element can be made a valid rebar host, generally by setting a property like FLOOR_PARAM_IS_STRUCTURAL or by changing the element's physical material to concrete. On the other hand, if getRebarHostData() returns null, the element cannot be made into a rebar host.

See Also

RebarHostData Class
Autodesk.Revit.Elements Namespace


ReferencePlane Class

[image]

Revit 2010 API
ReferencePlane Class
Members Example See Also Send Feedback
Represents a reference plane of Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ReferencePlane : Element
Visual Basic (Declaration)
Public Class ReferencePlane _
    Inherits Element
Visual C++
public ref class ReferencePlane : public Element

Remarks

This object is derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object also has many methods to set the specific properties of the reference plane

Examples

CopyC#
private void Getinfo_ReferencePlane(ReferencePlane refPlane)
{
    string message = "Reference Plane: ";
    //get the bubble end of the reference plane
    XYZ bubbleEnd = refPlane.BubbleEnd;
    message += "\nBubble end: (" + bubbleEnd.X + ", "
                       + bubbleEnd.Y + ", " + bubbleEnd.Z + ")";

    //get the direction of the reference plane
    XYZ direction = refPlane.Direction;
    message += "\nDirection: (" + direction.X + ", "
                    + direction.Y + ", " + direction.Z + ")";

    //get the freeEnd of the reference plane
    XYZ freeEnd = refPlane.FreeEnd;
    message += "\nFree End: (" + freeEnd.X + ", "
                    + freeEnd.Y + ", " + freeEnd.Z + ")";

    //get the name of the reference plane
    message += "\nName: " + refPlane.Name;

    //get the normal vector of the reference plane
    XYZ normal = refPlane.Normal;
    message += "\nNormal vector: (" + normal.X + ", "
                    + normal.Y + ", " + normal.Z + ")";

    //get the geometry plane to which the reference plane assigned
    Autodesk.Revit.Geometry.Plane plane = refPlane.Plane;
    message += "\norigin of the plane: (" + plane.Origin.X + ", "
                    + plane.Origin.Y + ", " + plane.Origin.Z + ")";

    message += "\nnormal of the plane: (" + plane.Normal.X + ", "
                    + plane.Normal.Y + ", " + plane.Normal.Z + ")";

    message += "\nXvec of the plane: (" + plane.XVec.X + ", "
                    + plane.XVec.Y + ", " + plane.XVec.Z + ")";

    message += "\nYvec of the plane: (" + plane.YVec.X + ", "
                    + plane.YVec.Y + ", " + plane.YVec.Z + ")";

    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Private Sub Getinfo_ReferencePlane(ByVal refPlane As ReferencePlane)
    Dim message As String = "Reference Plane: "
    'get the bubble end of the reference plane
    Dim bubbleEnd As Autodesk.Revit.Geometry.XYZ = refPlane.BubbleEnd
    message += ((vbLf & "Bubble end: (" & bubbleEnd.X & ", ") + bubbleEnd.Y & ", ") + bubbleEnd.Z & ")"

    'get the direction of the reference plane
    Dim direction As Autodesk.Revit.Geometry.XYZ = refPlane.Direction
    message += ((vbLf & "Direction: (" & direction.X & ", ") + direction.Y & ", ") + direction.Z & ")"

    'get the freeEnd of the reference plane
    Dim freeEnd As Autodesk.Revit.Geometry.XYZ = refPlane.FreeEnd
    message += ((vbLf & "Free End: (" & freeEnd.X & ", ") + freeEnd.Y & ", ") + freeEnd.Z & ")"

    'get the name of the reference plane
    message += vbLf & "Name: " & refPlane.Name

    'get the normal vector of the reference plane
    Dim normal As Autodesk.Revit.Geometry.XYZ = refPlane.Normal
    message += ((vbLf & "Normal vector: (" & normal.X & ", ") + normal.Y & ", ") + normal.Z & ")"

    'get the geometry plane to which the reference plane assigned
    Dim plane As Autodesk.Revit.Geometry.Plane = refPlane.Plane
    message += ((vbLf & "origin of the plane: (" & plane.Origin.X & ", ") + plane.Origin.Y & ", ") + plane.Origin.Z & ")"

    message += ((vbLf & "normal of the plane: (" & plane.Normal.X & ", ") + plane.Normal.Y & ", ") + plane.Normal.Z & ")"

    message += ((vbLf & "Xvec of the plane: (" & plane.XVec.X & ", ") + plane.XVec.Y & ", ") + plane.XVec.Z & ")"

    message += ((vbLf & "Yvec of the plane: (" & plane.YVec.X & ", ") + plane.YVec.Y & ", ") + plane.YVec.Z & ")"

    MessageBox.Show(message, "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.ReferencePlane

See Also

ReferencePlane Members
Autodesk.Revit.Elements Namespace


ReferencePlane Members

[image] [image]

Revit 2010 API
ReferencePlane Members
ReferencePlane Class Constructors Methods Properties See Also Send Feedback

The ReferencePlane type exposes the following members.

Constructors

Name | Description
ReferencePlane | Initializes a new instance of the ReferencePlane class

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Flip | Flips the orientation of the reference plane.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
BubbleEnd | The bubble end of the reference plane.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Direction | The direction of the reference plane.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FreeEnd | The free end of the reference plane.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The name property of the reference plane.
Normal | The normal vector of the reference plane.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Plane | The geometry plane to which the reference plane is assigned.
Reference | The geometry reference of the reference plane.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace


ReferencePlane Constructor

[image]

Revit 2010 API
ReferencePlane Constructor
ReferencePlane Class See Also Send Feedback
Initializes a new instance of the ReferencePlane class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferencePlane()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReferencePlane()

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace


ReferencePlane Methods

[image] [image]

Revit 2010 API
ReferencePlane Methods
ReferencePlane Class See Also Send Feedback

The ReferencePlane type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Flip | Flips the orientation of the reference plane.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace


Flip Method

[image]

Revit 2010 API
ReferencePlane..::.Flip Method
ReferencePlane Class See Also Send Feedback
Flips the orientation of the reference plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Flip()
Visual Basic (Declaration)
Public Sub Flip
Visual C++
public:
void Flip()

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace


ReferencePlane Properties

[image] [image]

Revit 2010 API
ReferencePlane Properties
ReferencePlane Class See Also Send Feedback

The ReferencePlane type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
BubbleEnd | The bubble end of the reference plane.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Direction | The direction of the reference plane.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FreeEnd | The free end of the reference plane.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The name property of the reference plane.
Normal | The normal vector of the reference plane.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Plane | The geometry plane to which the reference plane is assigned.
Reference | The geometry reference of the reference plane.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace


BubbleEnd Property

[image]

Revit 2010 API
ReferencePlane..::.BubbleEnd Property
ReferencePlane Class See Also Send Feedback
The bubble end of the reference plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ BubbleEnd { get; set; }
Visual Basic (Declaration)
Public Property BubbleEnd As XYZ
Visual C++
public:
property XYZ^ BubbleEnd {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

When setting this property, an exception will be thrown if the bubble end is set to almost the same point as free end or if the vector from BubbleEnd -> FreeEnd is not perpendicular to the normal vector.

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace


Direction Property

[image]

Revit 2010 API
ReferencePlane..::.Direction Property
ReferencePlane Class See Also Send Feedback
The direction of the reference plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Direction { get; set; }
Visual Basic (Declaration)
Public Property Direction As XYZ
Visual C++
public:
property XYZ^ Direction {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

When setting this property, an exception will be thrown if the direction vector is almost zero or if it is not perpendicular to the normal vector.

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace


FreeEnd Property

[image]

Revit 2010 API
ReferencePlane..::.FreeEnd Property
ReferencePlane Class See Also Send Feedback
The free end of the reference plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ FreeEnd { get; set; }
Visual Basic (Declaration)
Public Property FreeEnd As XYZ
Visual C++
public:
property XYZ^ FreeEnd {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

When setting this property, an exception will be thrown if the free end is set to almost the same point as bubble end or if the vector from BubbleEnd -> FreeEnd is not perpendicular to the normal vector.

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace


Name Property

[image]

Revit 2010 API
ReferencePlane..::.Name Property
ReferencePlane Class See Also Send Feedback
The name property of the reference plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

This property overrides Element's default implementation.

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace


Normal Property

[image]

Revit 2010 API
ReferencePlane..::.Normal Property
ReferencePlane Class See Also Send Feedback
The normal vector of the reference plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Normal { get; }
Visual Basic (Declaration)
Public ReadOnly Property Normal As XYZ
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
ReferencePlane..::.Parameter Property
ReferencePlane Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ReferencePlane Class
ReferencePlane Members
Autodesk.Revit.Elements Namespace


Plane Property

[image]

Revit 2010 API
ReferencePlane..::.Plane Property
ReferencePlane Class See Also Send Feedback
The geometry plane to which the reference plane is assigned.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Plane Plane { get; }
Visual Basic (Declaration)
Public ReadOnly Property Plane As Plane
Visual C++
public:
property Plane^ Plane {
    Plane^ get ();
}

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace


Reference Property

[image]

Revit 2010 API
ReferencePlane..::.Reference Property
ReferencePlane Class See Also Send Feedback
The geometry reference of the reference plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference Reference { get; }
Visual Basic (Declaration)
Public ReadOnly Property Reference As Reference
Visual C++
public:
property Reference^ Reference {
    Reference^ get ();
}

See Also

ReferencePlane Class
Autodesk.Revit.Elements Namespace


ReferencePoint Class

[image]

Revit 2010 API
ReferencePoint Class
Members See Also Send Feedback
A reference point in an Autodesk Revit family.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ReferencePoint : Element
Visual Basic (Declaration)
Public Class ReferencePoint _
    Inherits Element
Visual C++
public ref class ReferencePoint : public Element

Remarks

A ReferencePoint represents a point in space together with a local coordinate system. ReferencePoints can be free, or constrained to other elements in several ways. When the point is constrained, the coordinate system is also constrained in certain ways.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.ReferencePoint

See Also

ReferencePoint Members
Autodesk.Revit.Elements Namespace


ReferencePoint Members

[image] [image]

Revit 2010 API
ReferencePoint Members
ReferencePoint Class Constructors Methods Properties See Also Send Feedback

The ReferencePoint type exposes the following members.

Constructors

Name | Description
ReferencePoint | Initializes a new instance of the ReferencePoint class

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCoordinatePlaneReferenceXY | A reference for the XY plane of the coordinate system.
GetCoordinatePlaneReferenceXZ | A reference for the XZ plane of the coordinate system.
GetCoordinatePlaneReferenceYZ | A reference for the YZ plane of the coordinate system.
GetCoordinateSystem | The position and orientation of the ReferencePoint.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInterpolatingCurves | The set of CurveByPoints elements that interpolate a ReferencePoint.
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetPointElementReference | Retrieve a copy of the rule that computes the location of the ReferencePoint relative to other elements in the document.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the point.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetCoordinateSystem | The position and orientation of the ReferencePoint.
SetPointElementReference | Change the rule for computing the location of the ReferencePoint relative to other elements in the document.
SetVisibility | Sets the visibility for the point.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoordinatePlaneVisibility | Visibility settings for the coordinate reference planes.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Position | The position of the ReferencePoint.
ShowNormalReferencePlaneOnly | Whether all three coordinate planes are shown, or only the normal (XY) plane.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Visible | Whether the point is visible when the family is loaded into a project.

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace


ReferencePoint Constructor

[image]

Revit 2010 API
ReferencePoint Constructor
ReferencePoint Class See Also Send Feedback
Initializes a new instance of the ReferencePoint class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferencePoint()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReferencePoint()

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace


ReferencePoint Methods

[image] [image]

Revit 2010 API
ReferencePoint Methods
ReferencePoint Class See Also Send Feedback

The ReferencePoint type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCoordinatePlaneReferenceXY | A reference for the XY plane of the coordinate system.
GetCoordinatePlaneReferenceXZ | A reference for the XZ plane of the coordinate system.
GetCoordinatePlaneReferenceYZ | A reference for the YZ plane of the coordinate system.
GetCoordinateSystem | The position and orientation of the ReferencePoint.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInterpolatingCurves | The set of CurveByPoints elements that interpolate a ReferencePoint.
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetPointElementReference | Retrieve a copy of the rule that computes the location of the ReferencePoint relative to other elements in the document.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the point.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetCoordinateSystem | The position and orientation of the ReferencePoint.
SetPointElementReference | Change the rule for computing the location of the ReferencePoint relative to other elements in the document.
SetVisibility | Sets the visibility for the point.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace


GetCoordinatePlaneReferenceXY Method

[image]

Revit 2010 API
ReferencePoint..::.GetCoordinatePlaneReferenceXY Method
ReferencePoint Class See Also Send Feedback
A reference for the XY plane of the coordinate system.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference GetCoordinatePlaneReferenceXY()
Visual Basic (Declaration)
Public Function GetCoordinatePlaneReferenceXY As Reference
Visual C++
public:
Reference^ GetCoordinatePlaneReferenceXY()

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace


GetCoordinatePlaneReferenceXZ Method

[image]

Revit 2010 API
ReferencePoint..::.GetCoordinatePlaneReferenceXZ Method
ReferencePoint Class See Also Send Feedback
A reference for the XZ plane of the coordinate system.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference GetCoordinatePlaneReferenceXZ()
Visual Basic (Declaration)
Public Function GetCoordinatePlaneReferenceXZ As Reference
Visual C++
public:
Reference^ GetCoordinatePlaneReferenceXZ()

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace


GetCoordinatePlaneReferenceYZ Method

[image]

Revit 2010 API
ReferencePoint..::.GetCoordinatePlaneReferenceYZ Method
ReferencePoint Class See Also Send Feedback
A reference for the YZ plane of the coordinate system.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference GetCoordinatePlaneReferenceYZ()
Visual Basic (Declaration)
Public Function GetCoordinatePlaneReferenceYZ As Reference
Visual C++
public:
Reference^ GetCoordinatePlaneReferenceYZ()

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace


GetCoordinateSystem Method

[image]

Revit 2010 API
ReferencePoint..::.GetCoordinateSystem Method
ReferencePoint Class See Also Send Feedback
The position and orientation of the ReferencePoint.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Transform GetCoordinateSystem()
Visual Basic (Declaration)
Public Function GetCoordinateSystem As Transform
Visual C++
public:
Transform^ GetCoordinateSystem()

Remarks

The position of the point is given by CoordinateSystem.Origin, and the orientation is specified by the three unit vectors CoordinateSystem.BasisX, BasisY, BasisZ.

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace


GetInterpolatingCurves Method

[image]

Revit 2010 API
ReferencePoint..::.GetInterpolatingCurves Method
ReferencePoint Class See Also Send Feedback
The set of CurveByPoints elements that interpolate a ReferencePoint.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveByPointsArray GetInterpolatingCurves()
Visual Basic (Declaration)
Public Function GetInterpolatingCurves As CurveByPointsArray
Visual C++
public:
CurveByPointsArray^ GetInterpolatingCurves()

Remarks

A CurveByPoints is in the GetInterpolatingCurves()()() array if and only if the ReferencePoint is in the Points array of CurveByPoints.

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace


GetPointElementReference Method

[image]

Revit 2010 API
ReferencePoint..::.GetPointElementReference Method
ReferencePoint Class See Also Send Feedback
Retrieve a copy of the rule that computes the location of the ReferencePoint relative to other elements in the document.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PointElementReference GetPointElementReference()
Visual Basic (Declaration)
Public Function GetPointElementReference As PointElementReference
Visual C++
public:
PointElementReference^ GetPointElementReference()

Return Value

A PointElementReference object, or null if the ReferencePoint does not have a reference.

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace


GetVisibility Method

[image]

Revit 2010 API
ReferencePoint..::.GetVisibility Method
ReferencePoint Class See Also Send Feedback
Gets the visibility for the point.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic (Declaration)
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

Returns a copy of visibility settings for the ReferencePoint.

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace


SetCoordinateSystem Method

[image]

Revit 2010 API
ReferencePoint..::.SetCoordinateSystem Method
ReferencePoint Class See Also Send Feedback
The position and orientation of the ReferencePoint.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetCoordinateSystem(
    Transform coordinateSystem
)
Visual Basic (Declaration)
Public Sub SetCoordinateSystem ( _
    coordinateSystem As Transform _
)
Visual C++
public:
void SetCoordinateSystem(
    Transform^ coordinateSystem
)

Parameters

coordinateSystem
Type: Autodesk.Revit.Geometry..::.Transform

Remarks

The position of the point is given by CoordinateSystem.Origin, and the orientation is specified by the three unit vectors CoordinateSystem.BasisX, BasisY, BasisZ. The basis vectors must be unit length and mutually perpendicular. Whenever the Reference property is not null, changing the CoordinateSystem property has a compound effect. First the point is moved to the specified location. Then the point is moved to conform to its Reference, by the shortest possible distance.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when coordinateSystem does not specify an orthonormal basis.
System..::.InvalidOperationException | Thrown when CoordinateSystem is set while the Reference property is not null, and the ReferencePoint is unable to move to the new location.

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace


SetPointElementReference Method

[image]

Revit 2010 API
ReferencePoint..::.SetPointElementReference Method
ReferencePoint Class See Also Send Feedback
Change the rule for computing the location of the ReferencePoint relative to other elements in the document.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetPointElementReference(
    PointElementReference pointElementReference
)
Visual Basic (Declaration)
Public Sub SetPointElementReference ( _
    pointElementReference As PointElementReference _
)
Visual C++
public:
void SetPointElementReference(
    PointElementReference^ pointElementReference
)

Parameters

pointElementReference
Type: Autodesk.Revit.Elements..::.PointElementReference
An object specifying a rule for the location and orientation of a ReferencePoint. (Note: The ReferencePoint object does not store the pointElementReference object after this call.)

Remarks

pointElementReference may be null, in which case the ReferencePoint does not follow any other element. When Reference is changed from null to a non-null value, the point moves and rotates to the prescribed location and orientation. Where the coordinate system has some freedom, it will remain as close to the old orientation as possible. When the reference is set to null, the point does not move or rotate.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when Reference is set to a non-null object, and the ReferencePoint is unable to move to the new reference.

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace


SetVisibility Method

[image]

Revit 2010 API
ReferencePoint..::.SetVisibility Method
ReferencePoint Class See Also Send Feedback
Sets the visibility for the point.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic (Declaration)
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit..::.FamilyElementVisibility

Remarks

The visibility of the point can be changed for different types of views and detail levels in the project.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when visibility is null.
System..::.InvalidOperationException | Thrown when regeneration failed.

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace


ReferencePoint Properties

[image] [image]

Revit 2010 API
ReferencePoint Properties
ReferencePoint Class See Also Send Feedback

The ReferencePoint type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoordinatePlaneVisibility | Visibility settings for the coordinate reference planes.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Position | The position of the ReferencePoint.
ShowNormalReferencePlaneOnly | Whether all three coordinate planes are shown, or only the normal (XY) plane.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Visible | Whether the point is visible when the family is loaded into a project.

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace


CoordinatePlaneVisibility Property

[image]

Revit 2010 API
ReferencePoint..::.CoordinatePlaneVisibility Property
ReferencePoint Class See Also Send Feedback
Visibility settings for the coordinate reference planes.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CoordinatePlaneVisibility CoordinatePlaneVisibility { get; set; }
Visual Basic (Declaration)
Public Property CoordinatePlaneVisibility As CoordinatePlaneVisibility
Visual C++
public:
property CoordinatePlaneVisibility CoordinatePlaneVisibility {
    CoordinatePlaneVisibility get ();
    void set (CoordinatePlaneVisibility value);
}

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace


Name Property

[image]

Revit 2010 API
ReferencePoint..::.Name Property
ReferencePoint Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { get; set; }
Visual Basic (Declaration)
Public Overrides Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
ReferencePoint..::.Parameter Property
ReferencePoint Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ReferencePoint Class
ReferencePoint Members
Autodesk.Revit.Elements Namespace


Position Property

[image]

Revit 2010 API
ReferencePoint..::.Position Property
ReferencePoint Class See Also Send Feedback
The position of the ReferencePoint.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Position { get; set; }
Visual Basic (Declaration)
Public Property Position As XYZ
Visual C++
public:
property XYZ^ Position {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This is an alternate interface to the property CoordinateSystem.Origin. When set, the effect is the same as setting the CoordinateSystem property to the same as its current value but with a different Origin.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when CoordinateSystem is set while the Reference property is not null, and the ReferencePoint is unable to move to the new location.

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace


ShowNormalReferencePlaneOnly Property

[image]

Revit 2010 API
ReferencePoint..::.ShowNormalReferencePlaneOnly Property
ReferencePoint Class See Also Send Feedback
Whether all three coordinate planes are shown, or only the normal (XY) plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool ShowNormalReferencePlaneOnly { get; set; }
Visual Basic (Declaration)
Public Property ShowNormalReferencePlaneOnly As Boolean
Visual C++
public:
property bool ShowNormalReferencePlaneOnly {
    bool get ();
    void set (bool value);
}

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace


Visible Property

[image]

Revit 2010 API
ReferencePoint..::.Visible Property
ReferencePoint Class See Also Send Feedback
Whether the point is visible when the family is loaded into a project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace


ReferencePointArray Class

[image]

Revit 2010 API
ReferencePointArray Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ReferencePointArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ReferencePointArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ReferencePointArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.ReferencePointArray

See Also

ReferencePointArray Members
Autodesk.Revit.Elements Namespace


ReferencePointArray Members

[image] [image]

Revit 2010 API
ReferencePointArray Members
ReferencePointArray Class Constructors Methods Properties See Also Send Feedback

The ReferencePointArray type exposes the following members.

Constructors

Name | Description
ReferencePointArray | Initializes a new instance of the ReferencePointArray class

Methods

Name | Description
Append |
Clear |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item |
Size |

See Also

ReferencePointArray Class
Autodesk.Revit.Elements Namespace


ReferencePointArray Constructor

[image]

Revit 2010 API
ReferencePointArray Constructor
ReferencePointArray Class See Also Send Feedback
Initializes a new instance of the ReferencePointArray class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferencePointArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReferencePointArray()

See Also

ReferencePointArray Class
Autodesk.Revit.Elements Namespace


ReferencePointArray Methods

[image] [image]

Revit 2010 API
ReferencePointArray Methods
ReferencePointArray Class See Also Send Feedback

The ReferencePointArray type exposes the following members.

Methods

Name | Description
Append |
Clear |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferencePointArray Class
Autodesk.Revit.Elements Namespace


Append Method

[image]

Revit 2010 API
ReferencePointArray..::.Append Method
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    ReferencePoint item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As ReferencePoint _
)
Visual C++
public:
virtual void Append(
    ReferencePoint^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.ReferencePoint

See Also

ReferencePointArray Class
Autodesk.Revit.Elements Namespace


Clear Method

[image]

Revit 2010 API
ReferencePointArray..::.Clear Method
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ReferencePointArray Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

[image]

Revit 2010 API
ReferencePointArray..::.ForwardIterator Method
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ReferencePointArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ReferencePointArrayIterator
Visual C++
public:
virtual ReferencePointArrayIterator^ ForwardIterator()

See Also

ReferencePointArray Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

[image]

Revit 2010 API
ReferencePointArray..::.GetEnumerator Method
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ReferencePointArray Class
Autodesk.Revit.Elements Namespace


Insert Method

[image]

Revit 2010 API
ReferencePointArray..::.Insert Method
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    ReferencePoint item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As ReferencePoint, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    ReferencePoint^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Elements..::.ReferencePoint
index
Type: System..::.Int32

See Also

ReferencePointArray Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

[image]

Revit 2010 API
ReferencePointArray..::.ReverseIterator Method
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ReferencePointArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ReferencePointArrayIterator
Visual C++
public:
virtual ReferencePointArrayIterator^ ReverseIterator()

See Also

ReferencePointArray Class
Autodesk.Revit.Elements Namespace


ReferencePointArray Properties

[image] [image]

Revit 2010 API
ReferencePointArray Properties
ReferencePointArray Class See Also Send Feedback

The ReferencePointArray type exposes the following members.

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item |
Size |

See Also

ReferencePointArray Class
Autodesk.Revit.Elements Namespace


IsEmpty Property

[image]

Revit 2010 API
ReferencePointArray..::.IsEmpty Property
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

ReferencePointArray Class
Autodesk.Revit.Elements Namespace


Item Property

[image]

Revit 2010 API
ReferencePointArray..::.Item Property
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ReferencePoint Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As ReferencePoint
Visual C++
public:
virtual property ReferencePoint^ Item[int index] {
    ReferencePoint^ get (int index);
    void set (int index, ReferencePoint^ value);
}

Parameters

index
Type: System..::.Int32

See Also

ReferencePointArray Class
Autodesk.Revit.Elements Namespace


Size Property

[image]

Revit 2010 API
ReferencePointArray..::.Size Property
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ReferencePointArray Class
Autodesk.Revit.Elements Namespace


ReferencePointArrayIterator Class

[image]

Revit 2010 API
ReferencePointArrayIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ReferencePointArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ReferencePointArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ReferencePointArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.ReferencePointArrayIterator

See Also

ReferencePointArrayIterator Members
Autodesk.Revit.Elements Namespace


ReferencePointArrayIterator Members

[image] [image]

Revit 2010 API
ReferencePointArrayIterator Members
ReferencePointArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ReferencePointArrayIterator type exposes the following members.

Constructors

Name | Description
ReferencePointArrayIterator | Initializes a new instance of the ReferencePointArrayIterator class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferencePointArrayIterator Class
Autodesk.Revit.Elements Namespace


ReferencePointArrayIterator Constructor

[image]

Revit 2010 API
ReferencePointArrayIterator Constructor
ReferencePointArrayIterator Class See Also Send Feedback
Initializes a new instance of the ReferencePointArrayIterator class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferencePointArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReferencePointArrayIterator()

See Also

ReferencePointArrayIterator Class
Autodesk.Revit.Elements Namespace


ReferencePointArrayIterator Methods

[image] [image]

Revit 2010 API
ReferencePointArrayIterator Methods
ReferencePointArrayIterator Class See Also Send Feedback

The ReferencePointArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferencePointArrayIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

[image]

Revit 2010 API
ReferencePointArrayIterator..::.MoveNext Method
ReferencePointArrayIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::.MoveNext()()()

See Also

ReferencePointArrayIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

[image]

Revit 2010 API
ReferencePointArrayIterator..::.Reset Method
ReferencePointArrayIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

See Also

ReferencePointArrayIterator Class
Autodesk.Revit.Elements Namespace


ReferencePointArrayIterator Properties

[image] [image]

Revit 2010 API
ReferencePointArrayIterator Properties
ReferencePointArrayIterator Class See Also Send Feedback

The ReferencePointArrayIterator type exposes the following members.

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferencePointArrayIterator Class
Autodesk.Revit.Elements Namespace


Current Property

[image]

Revit 2010 API
ReferencePointArrayIterator..::.Current Property
ReferencePointArrayIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

See Also

ReferencePointArrayIterator Class
Autodesk.Revit.Elements Namespace


Revolution Class

[image]

Revit 2010 API
Revolution Class
Members See Also Send Feedback
A revolution solid or void form.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Revolution : GenericForm
Visual Basic (Declaration)
Public Class Revolution _
    Inherits GenericForm
Visual C++
public ref class Revolution : public GenericForm

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CombinableElement
Autodesk.Revit.Elements..::.GenericForm
Autodesk.Revit.Elements..::.Revolution

See Also

Revolution Members
Autodesk.Revit.Elements Namespace


Revolution Members

[image] [image]

Revit 2010 API
Revolution Members
Revolution Class Constructors Methods Properties See Also Send Feedback

The Revolution type exposes the following members.

Constructors

Name | Description
Revolution | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Axis | Returns the Axis of the Revolution.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EndAngle | The end angle of the revolution relative to the sketch plane.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Sketch | Returns the Sketch of the Revolution.
StartAngle | The start angle of the revolution relative to the sketch plane.
Subcategory | The subcategory. (Inherited from GenericForm.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Revolution Class
Autodesk.Revit.Elements Namespace


Revolution Constructor

[image]

Revit 2010 API
Revolution Constructor
Revolution Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Revolution()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Revolution()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Revolution Class
Autodesk.Revit.Elements Namespace


Revolution Methods

[image] [image]

Revit 2010 API
Revolution Methods
Revolution Class See Also Send Feedback

The Revolution type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Revolution Class
Autodesk.Revit.Elements Namespace


Revolution Properties

[image] [image]

Revit 2010 API
Revolution Properties
Revolution Class See Also Send Feedback

The Revolution type exposes the following members.

Properties

Name | Description
Axis | Returns the Axis of the Revolution.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EndAngle | The end angle of the revolution relative to the sketch plane.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Sketch | Returns the Sketch of the Revolution.
StartAngle | The start angle of the revolution relative to the sketch plane.
Subcategory | The subcategory. (Inherited from GenericForm.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Revolution Class
Autodesk.Revit.Elements Namespace


Axis Property

[image]

Revit 2010 API
Revolution..::.Axis Property
Revolution Class See Also Send Feedback
Returns the Axis of the Revolution.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelLine Axis { get; }
Visual Basic (Declaration)
Public ReadOnly Property Axis As ModelLine
Visual C++
public:
property ModelLine^ Axis {
    ModelLine^ get ();
}

Remarks

This property is used to retrieve the Axis of the Revolution.

See Also

Revolution Class
Autodesk.Revit.Elements Namespace


EndAngle Property

[image]

Revit 2010 API
Revolution..::.EndAngle Property
Revolution Class See Also Send Feedback
The end angle of the revolution relative to the sketch plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double EndAngle { get; set; }
Visual Basic (Declaration)
Public Property EndAngle As Double
Visual C++
public:
property double EndAngle {
    double get ();
    void set (double value);
}

Remarks

The direction of the angle is based on the normal of the sketch plane. A positive angle is on the same side as the normal, a negative angle on the opposite side.

See Also

Revolution Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Revolution..::.Parameter Property
Revolution Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Revolution Class
Revolution Members
Autodesk.Revit.Elements Namespace


Sketch Property

[image]

Revit 2010 API
Revolution..::.Sketch Property
Revolution Class See Also Send Feedback
Returns the Sketch of the Revolution.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Sketch Sketch { get; }
Visual Basic (Declaration)
Public ReadOnly Property Sketch As Sketch
Visual C++
public:
property Sketch^ Sketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the Sketch of the Revolution.

See Also

Revolution Class
Autodesk.Revit.Elements Namespace


StartAngle Property

[image]

Revit 2010 API
Revolution..::.StartAngle Property
Revolution Class See Also Send Feedback
The start angle of the revolution relative to the sketch plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double StartAngle { get; set; }
Visual Basic (Declaration)
Public Property StartAngle As Double
Visual C++
public:
property double StartAngle {
    double get ();
    void set (double value);
}

Remarks

The direction of the angle is based on the normal of the sketch plane. A positive angle is on the same side as the normal, a negative angle on the opposite side.

See Also

Revolution Class
Autodesk.Revit.Elements Namespace


RoofBase Class

[image]

Revit 2010 API
RoofBase Class
Members See Also Send Feedback
Represents all kinds of Roofs.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RoofBase : HostObject
Visual Basic (Declaration)
Public Class RoofBase _
    Inherits HostObject
Visual C++
public ref class RoofBase : public HostObject

Remarks

The RoofBase object represents all kinds of roof in Revit.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.RoofBase
Autodesk.Revit.Elements..::.ExtrusionRoof
Autodesk.Revit.Elements..::.FootPrintRoof

See Also

RoofBase Members
Autodesk.Revit.Elements Namespace


RoofBase Members

[image] [image]

Revit 2010 API
RoofBase Members
RoofBase Class Constructors Methods Properties See Also Send Feedback

The RoofBase type exposes the following members.

Constructors

Name | Description
RoofBase | Initializes a new instance of the RoofBase class

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EaveCuts | Retrieve or set the EaveCutterType.
FasciaDepth | Retrieve or set the FasciaDepth.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RoofType | Retrieve or set the Type.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RoofBase Class
Autodesk.Revit.Elements Namespace


RoofBase Constructor

[image]

Revit 2010 API
RoofBase Constructor
RoofBase Class See Also Send Feedback
Initializes a new instance of the RoofBase class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RoofBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoofBase()

See Also

RoofBase Class
Autodesk.Revit.Elements Namespace


RoofBase Methods

[image] [image]

Revit 2010 API
RoofBase Methods
RoofBase Class See Also Send Feedback

The RoofBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoofBase Class
Autodesk.Revit.Elements Namespace


RoofBase Properties

[image] [image]

Revit 2010 API
RoofBase Properties
RoofBase Class See Also Send Feedback

The RoofBase type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EaveCuts | Retrieve or set the EaveCutterType.
FasciaDepth | Retrieve or set the FasciaDepth.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RoofType | Retrieve or set the Type.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RoofBase Class
Autodesk.Revit.Elements Namespace


EaveCuts Property

[image]

Revit 2010 API
RoofBase..::.EaveCuts Property
RoofBase Class See Also Send Feedback
Retrieve or set the EaveCutterType.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public EaveCutterType EaveCuts { get; set; }
Visual Basic (Declaration)
Public Property EaveCuts As EaveCutterType
Visual C++
public:
property EaveCutterType EaveCuts {
    EaveCutterType get ();
    void set (EaveCutterType value);
}

See Also

RoofBase Class
Autodesk.Revit.Elements Namespace


FasciaDepth Property

[image]

Revit 2010 API
RoofBase..::.FasciaDepth Property
RoofBase Class See Also Send Feedback
Retrieve or set the FasciaDepth.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double FasciaDepth { get; set; }
Visual Basic (Declaration)
Public Property FasciaDepth As Double
Visual C++
public:
property double FasciaDepth {
    double get ();
    void set (double value);
}

Remarks

If the EaveCutterType is PlumbCut, this property doesn't make sense.

See Also

RoofBase Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
RoofBase..::.Parameter Property
RoofBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

RoofBase Class
RoofBase Members
Autodesk.Revit.Elements Namespace


RoofType Property

[image]

Revit 2010 API
RoofBase..::.RoofType Property
RoofBase Class See Also Send Feedback
Retrieve or set the Type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RoofType RoofType { get; set; }
Visual Basic (Declaration)
Public Property RoofType As RoofType
Visual C++
public:
property RoofType^ RoofType {
    RoofType^ get ();
    void set (RoofType^ value);
}

See Also

RoofBase Class
Autodesk.Revit.Elements Namespace


SlabShapeEditor Property

[image]

Revit 2010 API
RoofBase..::.SlabShapeEditor Property
RoofBase Class See Also Send Feedback
Get the SlabShapeEditor used for slab shape editing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabShapeEditor SlabShapeEditor { get; }
Visual Basic (Declaration)
Public ReadOnly Property SlabShapeEditor As SlabShapeEditor
Visual C++
public:
property SlabShapeEditor^ SlabShapeEditor {
    SlabShapeEditor^ get ();
}

Remarks

Roofs cannot be attached to another roof, and the roof cannot be a curtain roof. If either of these conditions is not met, the ShapeEditor will be nullptr.

See Also

RoofBase Class
Autodesk.Revit.Elements Namespace


Room Class

[image]

Revit 2010 API
Room Class
Members Example See Also Send Feedback
Provides access to the room topology in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Room : Element
Visual Basic (Declaration)
Public Class Room _
    Inherits Element
Visual C++
public ref class Room : public Element

Remarks

The room object can be queried for its boundary for use in space planning tools.

Examples

CopyC#
private void Getinfo_Room(Room room)
{
    string message = "Room: ";

    //get the name of the room
    message += "\nRoom Name: " + room.Name;

    //get the room position
    LocationPoint location = room.Location as LocationPoint;
    XYZ point = location.Point;
    message += "\nRoom position: " + XYZToString(point);

    //get the room number
    message += "\nRoom number: " + room.Number;

    //get the boundary segment of the room
    if (null != room.Boundary)  //the room may not be bound
    {
        if (0 != room.Boundary.Size)
        {
            message += "\nBoundarySegment of the room: ";
            foreach (BoundarySegmentArray boundarySegmentArray in room.Boundary)
            {
                foreach (BoundarySegment boundarySegment in boundarySegmentArray)
                {
                    // Get curve start point
                    XYZ start = boundarySegment.Curve.get_EndPoint(0);
                    message += "\nCurve start point: " + XYZToString(start);
                    // Get curve end point
                    XYZ end = boundarySegment.Curve.get_EndPoint(1);
                    message += " Curve end point: " + XYZToString(end);

                    // Show the boundary elements
                    message += "\nBoundary element id: " + boundarySegment.Element.Id.Value;
                }
            }
        }
    }

    MessageBox.Show(message, "Revit");
}

// output the point's three coordinates
string XYZToString(XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
CopyVB.NET
Private Sub Getinfo_Room(ByVal room As Room)
    Dim message As String = "Room: "

    'get the name of the room
    message += vbLf & "Room Name: " & room.Name

    'get the room position
    Dim location As LocationPoint = TryCast(room.Location, LocationPoint)
    Dim point As Autodesk.Revit.Geometry.XYZ = location.Point
    message += vbLf & "Room position: " & XYZToString(point)

    'get the room number
    message += vbLf & "Room number: " & room.Number

    'get the boundary segment of the room
    If room.Boundary IsNot Nothing Then
        'the room may not be bound
        If 0 <> room.Boundary.Size Then
            message += vbLf & "BoundarySegment of the room: "
            For Each boundarySegmentArray As BoundarySegmentArray In room.Boundary
                For Each boundarySegment As BoundarySegment In boundarySegmentArray
                    ' Get curve start point
                    Dim start As Autodesk.Revit.Geometry.XYZ = boundarySegment.Curve.EndPoint(0)
                    message += vbLf & "Curve start point: " & XYZToString(start)
                    ' Get curve end point
                    Dim [end] As Autodesk.Revit.Geometry.XYZ = boundarySegment.Curve.EndPoint(1)
                    message += " Curve end point: " & XYZToString([end])

                    ' Show the boundary elements
                    message += vbLf & "Boundary element id: " & boundarySegment.Element.Id.Value
                Next
            Next
        End If
    End If

    MessageBox.Show(message, "Revit")
End Sub

' output the point's three coordinates
Private Function XYZToString(ByVal point As Autodesk.Revit.Geometry.XYZ) As String
    Return (("(" & point.X & ", ") + point.Y & ", ") + point.Z & ")"
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Room

See Also

Room Members
Autodesk.Revit.Elements Namespace


Room Members

[image] [image]

Revit 2010 API
Room Members
Room Class Constructors Methods Properties See Also Send Feedback

The Room type exposes the following members.

Constructors

Name | Description
Room | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsPointInRoom | Determines if a point lies within the volume of the room.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unplace | Remove the room from its location, but the project still contains the room. The room can be placed in another location after unplaced.

Properties

Name | Description
Area | Get the Area of the Room.
BaseOffset | Get or Set the Base Offset of the Room.
Boundary | Returns the boundary of the room.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ClosedShell | Return the closedShell of the Room.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LimitOffset | Get or Set the Limit Offset of the Room.
Location | get a location point object. The point within the location object should be get/set. This is the location of the room within the level. The Z location should be the elevation of the level and not changeable. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get or Set the Name of the room. (Overrides Element..::.Name.)
Number | Get or Set the Number of the Room.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Perimeter | Get the Perimeter of the Room.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UnboundedHeight | Get the Unbounded Height of the Room.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpperLimit | Get or Set the Upper Limit of the Room.
Volume | Get the Volume of the Room.

See Also

Room Class
Autodesk.Revit.Elements Namespace


Room Constructor

[image]

Revit 2010 API
Room Constructor
Room Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Room()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Room()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Room Class
Autodesk.Revit.Elements Namespace


Room Methods

[image] [image]

Revit 2010 API
Room Methods
Room Class See Also Send Feedback

The Room type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsPointInRoom | Determines if a point lies within the volume of the room.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unplace | Remove the room from its location, but the project still contains the room. The room can be placed in another location after unplaced.

See Also

Room Class
Autodesk.Revit.Elements Namespace


IsPointInRoom Method

[image]

Revit 2010 API
Room..::.IsPointInRoom Method
Room Class See Also Send Feedback
Determines if a point lies within the volume of the room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsPointInRoom(
    XYZ point
)
Visual Basic (Declaration)
Public Function IsPointInRoom ( _
    point As XYZ _
) As Boolean
Visual C++
public:
bool IsPointInRoom(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
Point to be checked.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the point is nullptr.
System..::.ArgumentException | The coordinates of the point is not a number.

See Also

Room Class
Autodesk.Revit.Elements Namespace


Unplace Method

[image]

Revit 2010 API
Room..::.Unplace Method
Room Class See Also Send Feedback
Remove the room from its location, but the project still contains the room. The room can be placed in another location after unplaced.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Unplace()
Visual Basic (Declaration)
Public Sub Unplace
Visual C++
public:
void Unplace()

Remarks

Note that current room is changed to unplaced and all corresponding rooms which in other group instance are deleted when in group edit mode.

See Also

Room Class
Autodesk.Revit.Elements Namespace


Room Properties

[image] [image]

Revit 2010 API
Room Properties
Room Class See Also Send Feedback

The Room type exposes the following members.

Properties

Name | Description
Area | Get the Area of the Room.
BaseOffset | Get or Set the Base Offset of the Room.
Boundary | Returns the boundary of the room.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ClosedShell | Return the closedShell of the Room.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LimitOffset | Get or Set the Limit Offset of the Room.
Location | get a location point object. The point within the location object should be get/set. This is the location of the room within the level. The Z location should be the elevation of the level and not changeable. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get or Set the Name of the room. (Overrides Element..::.Name.)
Number | Get or Set the Number of the Room.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Perimeter | Get the Perimeter of the Room.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UnboundedHeight | Get the Unbounded Height of the Room.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpperLimit | Get or Set the Upper Limit of the Room.
Volume | Get the Volume of the Room.

See Also

Room Class
Autodesk.Revit.Elements Namespace


Area Property

[image]

Revit 2010 API
Room..::.Area Property
Room Class See Also Send Feedback
Get the Area of the Room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Area { get; }
Visual Basic (Declaration)
Public ReadOnly Property Area As Double
Visual C++
public:
property double Area {
    double get ();
}

Remarks

This property is used to get the Area of the Room.

See Also

Room Class
Autodesk.Revit.Elements Namespace


BaseOffset Property

[image]

Revit 2010 API
Room..::.BaseOffset Property
Room Class See Also Send Feedback
Get or Set the Base Offset of the Room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double BaseOffset { get; set; }
Visual Basic (Declaration)
Public Property BaseOffset As Double
Visual C++
public:
property double BaseOffset {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Base Offset of the Room.

See Also

Room Class
Autodesk.Revit.Elements Namespace


Boundary Property

[image]

Revit 2010 API
Room..::.Boundary Property
Room Class See Also Send Feedback
Returns the boundary of the room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundarySegmentArrayArray Boundary { get; }
Visual Basic (Declaration)
Public ReadOnly Property Boundary As BoundarySegmentArrayArray
Visual C++
public:
property BoundarySegmentArrayArray^ Boundary {
    BoundarySegmentArrayArray^ get ();
}

Remarks

This property is used to retrieve the segments that constitute the boundary of the room. Each room may have several regions, each of which have several segments hence the data is returned in the form of an array of boundary segment arrays. See the Room.BoundarySegment object for more details about the segments that make up the room topology.

See Also

Room Class
Autodesk.Revit.Elements Namespace


ClosedShell Property

[image]

Revit 2010 API
Room..::.ClosedShell Property
Room Class See Also Send Feedback
Return the closedShell of the Room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element ClosedShell { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClosedShell As Element
Visual C++
public:
property Element^ ClosedShell {
    Element^ get ();
}

See Also

Room Class
Autodesk.Revit.Elements Namespace


LimitOffset Property

[image]

Revit 2010 API
Room..::.LimitOffset Property
Room Class See Also Send Feedback
Get or Set the Limit Offset of the Room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double LimitOffset { get; set; }
Visual Basic (Declaration)
Public Property LimitOffset As Double
Visual C++
public:
property double LimitOffset {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Limit Offset of the Room.

See Also

Room Class
Autodesk.Revit.Elements Namespace


Location Property

[image]

Revit 2010 API
Room..::.Location Property
Room Class See Also Send Feedback
get a location point object. The point within the location object should be get/set. This is the location of the room within the level. The Z location should be the elevation of the level and not changeable.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

See Also

Room Class
Autodesk.Revit.Elements Namespace


Name Property

[image]

Revit 2010 API
Room..::.Name Property
Room Class See Also Send Feedback
Get or Set the Name of the room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

This property is used to get or set the Name of the room.

See Also

Room Class
Autodesk.Revit.Elements Namespace


Number Property

[image]

Revit 2010 API
Room..::.Number Property
Room Class See Also Send Feedback
Get or Set the Number of the Room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Number { get; set; }
Visual Basic (Declaration)
Public Property Number As String
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Number of the room.

See Also

Room Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Room..::.Parameter Property
Room Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Room Class
Room Members
Autodesk.Revit.Elements Namespace


Perimeter Property

[image]

Revit 2010 API
Room..::.Perimeter Property
Room Class See Also Send Feedback
Get the Perimeter of the Room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Perimeter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Perimeter As Double
Visual C++
public:
property double Perimeter {
    double get ();
}

Remarks

This property is used to get the Perimeter of the Room.

See Also

Room Class
Autodesk.Revit.Elements Namespace


UnboundedHeight Property

[image]

Revit 2010 API
Room..::.UnboundedHeight Property
Room Class See Also Send Feedback
Get the Unbounded Height of the Room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double UnboundedHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property UnboundedHeight As Double
Visual C++
public:
property double UnboundedHeight {
    double get ();
}

Remarks

This property is used to get the Unbounded Height of the Room.

See Also

Room Class
Autodesk.Revit.Elements Namespace


UpperLimit Property

[image]

Revit 2010 API
Room..::.UpperLimit Property
Room Class See Also Send Feedback
Get or Set the Upper Limit of the Room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Level UpperLimit { get; set; }
Visual Basic (Declaration)
Public Property UpperLimit As Level
Visual C++
public:
property Level^ UpperLimit {
    Level^ get ();
    void set (Level^ value);
}

Remarks

This property is used to get or set the Upper Limit of the Room.

See Also

Room Class
Autodesk.Revit.Elements Namespace


Volume Property

[image]

Revit 2010 API
Room..::.Volume Property
Room Class See Also Send Feedback
Get the Volume of the Room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Volume { get; }
Visual Basic (Declaration)
Public ReadOnly Property Volume As Double
Visual C++
public:
property double Volume {
    double get ();
}

Remarks

This property is used to get the Volume of the Room.

See Also

Room Class
Autodesk.Revit.Elements Namespace


RoomTag Class

[image]

Revit 2010 API
RoomTag Class
Members Example See Also Send Feedback
Provides access to the room tag in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RoomTag : Element
Visual Basic (Declaration)
Public Class RoomTag _
    Inherits Element
Visual C++
public ref class RoomTag : public Element

Remarks

The roomTag object can be queried for room information.

Examples

CopyC#
private void Getinfo_RoomTag(RoomTag roomTag)
{
    string message = "Room Tag : ";
    //get the location of the roomtag
    LocationPoint location = roomTag.Location as LocationPoint;
    XYZ point = location.Point;
    message += "\nRoomTag location: (" + point.X + ", " +
                   point.Y + ", " + point.Z + ")";

    //get the name of the roomTag
    message += "\nName: " + roomTag.Name;

    //get the room that the tag is associated with
    Room room = roomTag.Room;
    message += "\nThe number of the room is : " + room.Number;

    //get the view in which the tag is placed
    Autodesk.Revit.Elements.View view = roomTag.View;
    if (null != view)
    {
        message += "\nView Name: " + view.Name;
    }
    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Private Sub Getinfo_RoomTag(ByVal roomTag As Autodesk.Revit.Elements.RoomTag)
    Dim message As String = "Room Tag : "
    'get the location of the roomtag
    Dim location As LocationPoint = TryCast(roomTag.Location, LocationPoint)
    Dim point As Autodesk.Revit.Geometry.XYZ = location.Point
    message += ((vbLf & "RoomTag location: (" & point.X & ", ") + point.Y & ", ") + point.Z & ")"

    'get the name of the roomTag
    message += vbLf & "Name: " & roomTag.Name

    'get the room that the tag is associated with
    Dim room As Room = roomTag.Room
    message += vbLf & "The number of the room is : " & room.Number

    'get the view in which the tag is placed
    Dim view As Autodesk.Revit.Elements.View = roomTag.View
    If view IsNot Nothing Then
        message += vbLf & "View Name: " & view.Name
    End If
    MessageBox.Show(message, "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.RoomTag

See Also

RoomTag Members
Autodesk.Revit.Elements Namespace


RoomTag Members

[image] [image]

Revit 2010 API
RoomTag Members
RoomTag Class Constructors Methods Properties See Also Send Feedback

The RoomTag type exposes the following members.

Constructors

Name | Description
RoomTag | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Leader | get/set the display attribute of Leader.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | get a location point object. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The name associated with the room tag. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Room | Returns the room that the tag is associated with.
RoomTagType | get/set the type.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
View | Returns the view in which the tag was place.

See Also

RoomTag Class
Autodesk.Revit.Elements Namespace


RoomTag Constructor

[image]

Revit 2010 API
RoomTag Constructor
RoomTag Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RoomTag()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoomTag()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RoomTag Class
Autodesk.Revit.Elements Namespace


RoomTag Methods

[image] [image]

Revit 2010 API
RoomTag Methods
RoomTag Class See Also Send Feedback

The RoomTag type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoomTag Class
Autodesk.Revit.Elements Namespace


RoomTag Properties

[image] [image]

Revit 2010 API
RoomTag Properties
RoomTag Class See Also Send Feedback

The RoomTag type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Leader | get/set the display attribute of Leader.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | get a location point object. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The name associated with the room tag. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Room | Returns the room that the tag is associated with.
RoomTagType | get/set the type.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
View | Returns the view in which the tag was place.

See Also

RoomTag Class
Autodesk.Revit.Elements Namespace


Leader Property

[image]

Revit 2010 API
RoomTag..::.Leader Property
RoomTag Class See Also Send Feedback
get/set the display attribute of Leader.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Leader { get; set; }
Visual Basic (Declaration)
Public Property Leader As Boolean
Visual C++
public:
property bool Leader {
    bool get ();
    void set (bool value);
}

Remarks

get/set, will be true if the leader is displayed otherwise false.

See Also

RoomTag Class
Autodesk.Revit.Elements Namespace


Location Property

[image]

Revit 2010 API
RoomTag..::.Location Property
RoomTag Class See Also Send Feedback
get a location point object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

The point within the location object should be get/set. This is the location of the room within the level. The Z location should be the elevation of the level and not changeable.

See Also

RoomTag Class
Autodesk.Revit.Elements Namespace


Name Property

[image]

Revit 2010 API
RoomTag..::.Name Property
RoomTag Class See Also Send Feedback
The name associated with the room tag.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

This overrides Element.Name to allow the API to prevent modifications to the room tag's name (because this is not permitted to be modified in the Autodesk Revit UI. Calling this method will result in a System.InvalidOperationException.

See Also

RoomTag Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
RoomTag..::.Parameter Property
RoomTag Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

RoomTag Class
RoomTag Members
Autodesk.Revit.Elements Namespace


Room Property

[image]

Revit 2010 API
RoomTag..::.Room Property
RoomTag Class See Also Send Feedback
Returns the room that the tag is associated with.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Room Room { get; }
Visual Basic (Declaration)
Public ReadOnly Property Room As Room
Visual C++
public:
property Room^ Room {
    Room^ get ();
}

Remarks

get the room that the tag is associated with

See Also

RoomTag Class
Autodesk.Revit.Elements Namespace


RoomTagType Property

[image]

Revit 2010 API
RoomTag..::.RoomTagType Property
RoomTag Class See Also Send Feedback
get/set the type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RoomTagType RoomTagType { get; set; }
Visual Basic (Declaration)
Public Property RoomTagType As RoomTagType
Visual C++
public:
property RoomTagType^ RoomTagType {
    RoomTagType^ get ();
    void set (RoomTagType^ value);
}

Remarks

get/set the type for the current RoomTag.

See Also

RoomTag Class
Autodesk.Revit.Elements Namespace


View Property

[image]

Revit 2010 API
RoomTag..::.View Property
RoomTag Class See Also Send Feedback
Returns the view in which the tag was place.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public View View { get; }
Visual Basic (Declaration)
Public ReadOnly Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
}

Remarks

get the view in which the tag was placed.

See Also

RoomTag Class
Autodesk.Revit.Elements Namespace


Sketch Class

[image]

Revit 2010 API
Sketch Class
Members See Also Send Feedback
Provides access to the Sketch in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Sketch : SketchBase
Visual Basic (Declaration)
Public Class Sketch _
    Inherits SketchBase
Visual C++
public ref class Sketch : public SketchBase

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.SketchBase
Autodesk.Revit.Elements..::.Sketch

See Also

Sketch Members
Autodesk.Revit.Elements Namespace


Sketch Members

[image] [image]

Revit 2010 API
Sketch Members
Sketch Class Constructors Methods Properties See Also Send Feedback

The Sketch type exposes the following members.

Constructors

Name | Description
Sketch | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Profile | Returns the Profile of the Sketch.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | Returns the Sketch Plane of the Sketch.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Sketch Class
Autodesk.Revit.Elements Namespace


Sketch Constructor

[image]

Revit 2010 API
Sketch Constructor
Sketch Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Sketch()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Sketch()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Sketch Class
Autodesk.Revit.Elements Namespace


Sketch Methods

[image] [image]

Revit 2010 API
Sketch Methods
Sketch Class See Also Send Feedback

The Sketch type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Sketch Class
Autodesk.Revit.Elements Namespace


Sketch Properties

[image] [image]

Revit 2010 API
Sketch Properties
Sketch Class See Also Send Feedback

The Sketch type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Profile | Returns the Profile of the Sketch.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | Returns the Sketch Plane of the Sketch.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Sketch Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Sketch..::.Parameter Property
Sketch Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Sketch Class
Sketch Members
Autodesk.Revit.Elements Namespace


Profile Property

[image]

Revit 2010 API
Sketch..::.Profile Property
Sketch Class See Also Send Feedback
Returns the Profile of the Sketch.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArrArray Profile { get; }
Visual Basic (Declaration)
Public ReadOnly Property Profile As CurveArrArray
Visual C++
public:
property CurveArrArray^ Profile {
    CurveArrArray^ get ();
}

Remarks

This property is used to retrieve the Profile of Sketch.

See Also

Sketch Class
Autodesk.Revit.Elements Namespace


SketchPlane Property

[image]

Revit 2010 API
Sketch..::.SketchPlane Property
Sketch Class See Also Send Feedback
Returns the Sketch Plane of the Sketch.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SketchPlane SketchPlane { get; }
Visual Basic (Declaration)
Public ReadOnly Property SketchPlane As SketchPlane
Visual C++
public:
property SketchPlane^ SketchPlane {
    SketchPlane^ get ();
}

Remarks

This property is used to retrieve the Sketch Plane of Sketch.

See Also

Sketch Class
Autodesk.Revit.Elements Namespace


SketchBase Class

[image]

Revit 2010 API
SketchBase Class
Members See Also Send Feedback
Provides access to the SketchBase in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SketchBase : Element
Visual Basic (Declaration)
Public Class SketchBase _
    Inherits Element
Visual C++
public ref class SketchBase : public Element

Remarks

SketchBase is the base class of Sketch.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.SketchBase
Autodesk.Revit.Elements..::.Path3d
Autodesk.Revit.Elements..::.Sketch

See Also

SketchBase Members
Autodesk.Revit.Elements Namespace


SketchBase Members

[image] [image]

Revit 2010 API
SketchBase Members
SketchBase Class Constructors Methods Properties See Also Send Feedback

The SketchBase type exposes the following members.

Constructors

Name | Description
SketchBase | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SketchBase Class
Autodesk.Revit.Elements Namespace


SketchBase Constructor

[image]

Revit 2010 API
SketchBase Constructor
SketchBase Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SketchBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SketchBase()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SketchBase Class
Autodesk.Revit.Elements Namespace


SketchBase Methods

[image] [image]

Revit 2010 API
SketchBase Methods
SketchBase Class See Also Send Feedback

The SketchBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SketchBase Class
Autodesk.Revit.Elements Namespace


SketchBase Properties

[image] [image]

Revit 2010 API
SketchBase Properties
SketchBase Class See Also Send Feedback

The SketchBase type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SketchBase Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
SketchBase..::.Parameter Property
SketchBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SketchBase Class
SketchBase Members
Autodesk.Revit.Elements Namespace


SketchPlane Class

[image]

Revit 2010 API
SketchPlane Class
Members Example See Also Send Feedback
Represents a sketch plane or work plane within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SketchPlane : Element
Visual Basic (Declaration)
Public Class SketchPlane _
    Inherits Element
Visual C++
public ref class SketchPlane : public Element

Remarks

A SketchPlane object is used as an input to creation of sketch-referencing elements such as Model Curves or sketch-owning elements such as Generic Forms. The SketchPlane can be obtained from an existing element or created from a geometric plane or planar face. Note that the sketch plane element passed as input to create an element may not be the actual sketch plane assigned to that element; Revit may look for a geometrically equivalent plane to use, or may create a new one if the input plane is already used for other purposes. Some sketch planes (such as those obtained from detail curves) are suitable only for use in creating detail elements; they will be rejected when used for other element types.

Examples

CopyC#
public void ShowSketchPlane(SketchPlane sketchPlane)
{
    // get the information of the created sketch plane
    string information = "Sketch Plane: ";
    //get the corresponding Plane
    Autodesk.Revit.Geometry.Plane plane = sketchPlane.Plane;
    //show the plane's origin point
    information += "\norigin of the plane:  " + XYZToString(plane.Origin);
    //show the plane's normal vector
    information += "\nnormal of the plane:  " + XYZToString(plane.Normal);
    //show the plane's Xvec vector
    information += "\nXvec of the plane: (" + XYZToString(plane.XVec);
    //show the plane's Yvec vector
    information += "\nYvec of the plane: (" + XYZToString(plane.YVec);

    MessageBox.Show(information, "Revit");
}

// output the point's three coordinates
string XYZToString(XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
CopyVB.NET
Public Sub ShowSketchPlane(ByVal sketchPlane As Autodesk.Revit.Elements.SketchPlane)
    ' get the information of the created sketch plane
    Dim information As String = "Sketch Plane: "
    'get the corresponding Plane
    Dim plane As Autodesk.Revit.Geometry.Plane = sketchPlane.Plane
    'show the plane's origin point
    information += vbLf & "origin of the plane: " & XYZToString(plane.Origin)
    'show the plane's normal vector
    information += vbLf & "normal of the plane: " & XYZToString(plane.Normal)
    'show the plane's Xvec vector
    information += vbLf & "Xvec of the plane: (" & XYZToString(plane.XVec)
    'show the plane's Yvec vector
    information += vbLf & "Yvec of the plane: (" & XYZToString(plane.YVec)

    MessageBox.Show(information, "Revit")
End Sub

' output the point's three coordinates
Private Function XYZToString(ByVal point As Autodesk.Revit.Geometry.XYZ) As String
    Return (("(" & point.X & ", ") + point.Y & ", ") + point.Z & ")"
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.SketchPlane

See Also

SketchPlane Members
Autodesk.Revit.Elements Namespace


SketchPlane Members

[image] [image]

Revit 2010 API
SketchPlane Members
SketchPlane Class Constructors Methods Properties See Also Send Feedback

The SketchPlane type exposes the following members.

Constructors

Name | Description
SketchPlane | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsSuitableForModelElements | Identifies if the sketch plane can be assigned to model elements.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Plane | Returns the corresponding Plane.
PlaneReference | Returns a reference to this element as a plane.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SketchPlane Class
Autodesk.Revit.Elements Namespace


SketchPlane Constructor

[image]

Revit 2010 API
SketchPlane Constructor
SketchPlane Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SketchPlane()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SketchPlane()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SketchPlane Class
Autodesk.Revit.Elements Namespace


SketchPlane Methods

[image] [image]

Revit 2010 API
SketchPlane Methods
SketchPlane Class See Also Send Feedback

The SketchPlane type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SketchPlane Class
Autodesk.Revit.Elements Namespace


SketchPlane Properties

[image] [image]

Revit 2010 API
SketchPlane Properties
SketchPlane Class See Also Send Feedback

The SketchPlane type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsSuitableForModelElements | Identifies if the sketch plane can be assigned to model elements.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Plane | Returns the corresponding Plane.
PlaneReference | Returns a reference to this element as a plane.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SketchPlane Class
Autodesk.Revit.Elements Namespace


IsSuitableForModelElements Property

[image]

Revit 2010 API
SketchPlane..::.IsSuitableForModelElements Property
SketchPlane Class See Also Send Feedback
Identifies if the sketch plane can be assigned to model elements.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsSuitableForModelElements { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSuitableForModelElements As Boolean
Visual C++
public:
property bool IsSuitableForModelElements {
    bool get ();
}

Remarks

Sketch planes with this property set to true are suitable to be used to create model elements. Planes where this property is false will be rejected when used to create model curves, symbolic curves, generic forms, or other sketched elements.

See Also

SketchPlane Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
SketchPlane..::.Parameter Property
SketchPlane Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SketchPlane Class
SketchPlane Members
Autodesk.Revit.Elements Namespace


Plane Property

[image]

Revit 2010 API
SketchPlane..::.Plane Property
SketchPlane Class See Also Send Feedback
Returns the corresponding Plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Plane Plane { get; }
Visual Basic (Declaration)
Public ReadOnly Property Plane As Plane
Visual C++
public:
property Plane^ Plane {
    Plane^ get ();
}

Remarks

This property returns the plane upon which elements created with this sketch plane will lie.

See Also

SketchPlane Class
Autodesk.Revit.Elements Namespace


PlaneReference Property

[image]

Revit 2010 API
SketchPlane..::.PlaneReference Property
SketchPlane Class See Also Send Feedback
Returns a reference to this element as a plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference PlaneReference { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlaneReference As Reference
Visual C++
public:
property Reference^ PlaneReference {
    Reference^ get ();
}

Remarks

The object returned here can be used with the PointOnPlane class.

See Also

SketchPlane Class
Autodesk.Revit.Elements Namespace


SketchSet Class

[image]

Revit 2010 API
SketchSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SketchSet : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class SketchSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SketchSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.SketchSet

See Also

SketchSet Members
Autodesk.Revit.Elements Namespace


SketchSet Members

[image] [image]

Revit 2010 API
SketchSet Members
SketchSet Class Constructors Methods Properties See Also Send Feedback

The SketchSet type exposes the following members.

Constructors

Name | Description
SketchSet | Initializes a new instance of the SketchSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


SketchSet Constructor

[image]

Revit 2010 API
SketchSet Constructor
SketchSet Class See Also Send Feedback
Initializes a new instance of the SketchSet class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SketchSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SketchSet()

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


SketchSet Methods

[image] [image]

Revit 2010 API
SketchSet Methods
SketchSet Class See Also Send Feedback

The SketchSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


Clear Method

[image]

Revit 2010 API
SketchSet..::.Clear Method
SketchSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


Contains Method

[image]

Revit 2010 API
SketchSet..::.Contains Method
SketchSet Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    Sketch item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Sketch _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Sketch^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.Sketch

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


Erase Method

[image]

Revit 2010 API
SketchSet..::.Erase Method
SketchSet Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    Sketch item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Sketch _
) As Integer
Visual C++
public:
virtual int Erase(
    Sketch^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.Sketch

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

[image]

Revit 2010 API
SketchSet..::.ForwardIterator Method
SketchSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual SketchSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SketchSetIterator
Visual C++
public:
virtual SketchSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

[image]

Revit 2010 API
SketchSet..::.GetEnumerator Method
SketchSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


Insert Method

[image]

Revit 2010 API
SketchSet..::.Insert Method
SketchSet Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    Sketch item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Sketch _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Sketch^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.Sketch

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

[image]

Revit 2010 API
SketchSet..::.ReverseIterator Method
SketchSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual SketchSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SketchSetIterator
Visual C++
public:
virtual SketchSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


SketchSet Properties

[image] [image]

Revit 2010 API
SketchSet Properties
SketchSet Class See Also Send Feedback

The SketchSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


IsEmpty Property

[image]

Revit 2010 API
SketchSet..::.IsEmpty Property
SketchSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


Size Property

[image]

Revit 2010 API
SketchSet..::.Size Property
SketchSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SketchSet Class
Autodesk.Revit.Elements Namespace


SketchSetIterator Class

[image]

Revit 2010 API
SketchSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class SketchSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class SketchSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SketchSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.SketchSetIterator

See Also

SketchSetIterator Members
Autodesk.Revit.Elements Namespace


SketchSetIterator Members

[image] [image]

Revit 2010 API
SketchSetIterator Members
SketchSetIterator Class Constructors Methods Properties See Also Send Feedback

The SketchSetIterator type exposes the following members.

Constructors

Name | Description
SketchSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SketchSetIterator Class
Autodesk.Revit.Elements Namespace


SketchSetIterator Constructor

[image]

Revit 2010 API
SketchSetIterator Constructor
SketchSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SketchSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SketchSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SketchSetIterator Class
Autodesk.Revit.Elements Namespace


SketchSetIterator Methods

[image] [image]

Revit 2010 API
SketchSetIterator Methods
SketchSetIterator Class See Also Send Feedback

The SketchSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SketchSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

[image]

Revit 2010 API
SketchSetIterator..::.MoveNext Method
SketchSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SketchSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

[image]

Revit 2010 API
SketchSetIterator..::.Reset Method
SketchSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SketchSetIterator Class
Autodesk.Revit.Elements Namespace


SketchSetIterator Properties

[image] [image]

Revit 2010 API
SketchSetIterator Properties
SketchSetIterator Class See Also Send Feedback

The SketchSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SketchSetIterator Class
Autodesk.Revit.Elements Namespace


Current Property

[image]

Revit 2010 API
SketchSetIterator..::.Current Property
SketchSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SketchSetIterator Class
Autodesk.Revit.Elements Namespace


SlabEdge Class

[image]

Revit 2010 API
SlabEdge Class
Members See Also Send Feedback
An object that represents a slab edge within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SlabEdge : HostedSweep
Visual Basic (Declaration)
Public Class SlabEdge _
    Inherits HostedSweep
Visual C++
public ref class SlabEdge : public HostedSweep

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.HostedSweep
Autodesk.Revit.Elements..::.SlabEdge

See Also

SlabEdge Members
Autodesk.Revit.Elements Namespace


SlabEdge Members

[image] [image]

Revit 2010 API
SlabEdge Members
SlabEdge Class Constructors Methods Properties See Also Send Feedback

The SlabEdge type exposes the following members.

Constructors

Name | Description
SlabEdge | For Internal Use Only.

Methods

Name | Description
AddSegment | Add segments to the slab edge. (Overrides HostedSweep..::.AddSegment(Reference).)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

Properties

Name | Description
Angle | Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian). (Inherited from HostedSweep.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceCurve | Retrieve the curve on which the hosted sweep object's segment is created on the corresponding. (Inherited from HostedSweep.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SlabEdgeType | Retrieves/set an object that represents the type of the SlabEdge.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)

See Also

SlabEdge Class
Autodesk.Revit.Elements Namespace


SlabEdge Constructor

[image]

Revit 2010 API
SlabEdge Constructor
SlabEdge Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabEdge()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabEdge()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabEdge Class
Autodesk.Revit.Elements Namespace


SlabEdge Methods

[image] [image]

Revit 2010 API
SlabEdge Methods
SlabEdge Class See Also Send Feedback

The SlabEdge type exposes the following members.

Methods

Name | Description
AddSegment | Add segments to the slab edge. (Overrides HostedSweep..::.AddSegment(Reference).)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

See Also

SlabEdge Class
Autodesk.Revit.Elements Namespace


AddSegment Method

[image]

Revit 2010 API
SlabEdge..::.AddSegment Method
SlabEdge Class See Also Send Feedback
Add segments to the slab edge.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override void AddSegment(
    Reference targetRef
)
Visual Basic (Declaration)
Public Overrides Sub AddSegment ( _
    targetRef As Reference _
)
Visual C++
public:
virtual void AddSegment(
    Reference^ targetRef
) override

Parameters

targetRef
Type: Autodesk.Revit.Geometry..::.Reference
Segment's reference on which want to be added.

Exceptions

Exception | Condition
System..::.ArgumentNullException | This exception will be thrown in following cases: 1. Input targetRef is null. 2. Input targetRef is not null but contains nothing.
System..::.InvalidOperationException | This exception will be thrown in following cases: 1. Input targetRef has already been added into the slab edge. 2. Internal code fails to create the segment object. 3. Regeneration fails.
System..::.ArgumentOutOfRangeException | This exception will be thrown if the reference is suitable for creating a slab edge as required. The reference allowed is : 1. Model Line 2. Floor's horizontal edges 3. Other slab edge's horizontal edges

See Also

SlabEdge Class
Autodesk.Revit.Elements Namespace


SlabEdge Properties

[image] [image]

Revit 2010 API
SlabEdge Properties
SlabEdge Class See Also Send Feedback

The SlabEdge type exposes the following members.

Properties

Name | Description
Angle | Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian). (Inherited from HostedSweep.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceCurve | Retrieve the curve on which the hosted sweep object's segment is created on the corresponding. (Inherited from HostedSweep.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SlabEdgeType | Retrieves/set an object that represents the type of the SlabEdge.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)

See Also

SlabEdge Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
SlabEdge..::.Parameter Property
SlabEdge Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SlabEdge Class
SlabEdge Members
Autodesk.Revit.Elements Namespace


SlabEdgeType Property

[image]

Revit 2010 API
SlabEdge..::.SlabEdgeType Property
SlabEdge Class See Also Send Feedback
Retrieves/set an object that represents the type of the SlabEdge.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabEdgeType SlabEdgeType { get; set; }
Visual Basic (Declaration)
Public Property SlabEdgeType As SlabEdgeType
Visual C++
public:
property SlabEdgeType^ SlabEdgeType {
    SlabEdgeType^ get ();
    void set (SlabEdgeType^ value);
}

See Also

SlabEdge Class
Autodesk.Revit.Elements Namespace


Space Class

[image]

Revit 2010 API
Space Class
Members See Also Send Feedback
Provides access to the space topology in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Space : Element
Visual Basic (Declaration)
Public Class Space _
    Inherits Element
Visual C++
public ref class Space : public Element

Remarks

The space object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Space

See Also

Space Members
Autodesk.Revit.Elements Namespace


Space Members

[image] [image]

Revit 2010 API
Space Members
Space Class Constructors Methods Properties See Also Send Feedback

The Space type exposes the following members.

Constructors

Name | Description
Space | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsPointInSpace | Determines if a point lies within the volume of the Space.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActualExhaustAirflow | Get the Actual Exhaust Airflow of the Space.
ActualHVACLoad | Get or set the Actual HVAC Load of the Space.
ActualLightingLoad | Get the Actual Lighting Load of the Space.
ActualOtherLoad | Get or set the Actual Other Load of the Space.
ActualPowerLoad | Get the Actual Power Load of the Space.
ActualReturnAirflow | Get or set the Actual Return Airflow of the Space.
ActualSupplyAirflow | Get or set the Actual Supply Airflow of the Space.
Area | Get the Area of the Space.
AreaperPerson | Get the Area per Person of the Space.
AverageEstimatedIllumination | Get the Average Estimated Illumination of the Space.
BaseOffset | Get or Set the Base Offset of the Space.
Boundary | Returns the boundary of the Space.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CalculatedCoolingLoad | Get the Calculated Cooling Load of the Space.
CalculatedHeatingLoad | Get the Calculated Heating Load of the Space.
CalculatedSupplyAirflow | Get or set the Calculated Supply Airflow of the Space.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CeilingReflectance | Get or set the Ceiling Reflectance of the Space.
ClosedShell | Return the closedShell of the space.
ConditionType | Get or set the Condition type of the Space.
DesignCoolingLoad | Get the Design Cooling Load of the Space.
DesignExhaustAirflow | Get or set the Specified Exhaust Airflow of the Space.
DesignHeatingLoad | Get the Design Heating Load of the Space.
DesignHVACLoadperArea | Get or set the Design HVAC Load per Area of the Space.
DesignLightingLoad | Get or set the Design Lighting Load of the Space.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DesignOtherLoadperArea | Get or set the Design Other Load per Area of the Space.
DesignPowerLoad | Get or set the Design Power Load of the Space.
DesignReturnAirflow | Get or set the Specified Return Airflow of the Space.
DesignSupplyAirflow | Get or set the Specified Supply Airflow of the Space.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FloorReflectance | Get or set the Floor Reflectance of the Space.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
LatentHeatGainperPerson | Get or set the Latent Heat Gain per Person of the Space.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LightingCalculationWorkplane | Get the Lighting Calculation Workplane of the Space.
LightingLoadUnit | Get or Set the Lighting Load Unit of the Space.
LimitOffset | Get or Set the Limit Offset of the Space.
Location | get a location point object. The point within the location object should be get/set. This is the location of the room within the level. The Z location should be the elevation of the level and not changeable. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get or Set the Name of the Space. (Overrides Element..::.Name.)
Number | Get or Set the Name of the Number.
NumberofPeople | Get the Number of People of the Space.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
OccupancyUnit | Get the Occupancy Unit of the Space.
Occupiable | Reports whether this zone is Occupiable or not.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Perimeter | Get the Perimeter of the Space.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Plenum | Reports whether this zone is Plenum or not.
PowerLoadUnit | Get or Set the Power Load Unit of the Space.
ReturnAirflow | Get or set the Return type of Supply Airflow of the Space.
Room | Return the Room of the space.
SensibleHeatGainperPerson | Get the Sensible Heat Gain per Person of the Space.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SpaceCavityRatio | Get the Space Cavity Ratio of the Space.
SpaceConstruction | Get the Space Construction of the Space.
SpaceType | Get or set the Space type of the Space.
UnboundedHeight | Get the Unbounded Height of the Space.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpperLimit | Get or Set the Upper Limit of the Space.
Volume | Get the Volume of the Space.
WallReflectance | Get or set the Wall Reflectance of the Space.
Zone | Reports this space belong to which Zone.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Space Constructor

[image]

Revit 2010 API
Space Constructor
Space Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Space()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Space()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Space Methods

[image] [image]

Revit 2010 API
Space Methods
Space Class See Also Send Feedback

The Space type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsPointInSpace | Determines if a point lies within the volume of the Space.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Space Class
Autodesk.Revit.Elements Namespace


IsPointInSpace Method

[image]

Revit 2010 API
Space..::.IsPointInSpace Method
Space Class See Also Send Feedback
Determines if a point lies within the volume of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsPointInSpace(
    XYZ point
)
Visual Basic (Declaration)
Public Function IsPointInSpace ( _
    point As XYZ _
) As Boolean
Visual C++
public:
bool IsPointInSpace(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
Point to be checked.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the point is nullptr.
System..::.ArgumentException | The coordinates of the point is not a number.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Space Properties

[image] [image]

Revit 2010 API
Space Properties
Space Class See Also Send Feedback

The Space type exposes the following members.

Properties

Name | Description
ActualExhaustAirflow | Get the Actual Exhaust Airflow of the Space.
ActualHVACLoad | Get or set the Actual HVAC Load of the Space.
ActualLightingLoad | Get the Actual Lighting Load of the Space.
ActualOtherLoad | Get or set the Actual Other Load of the Space.
ActualPowerLoad | Get the Actual Power Load of the Space.
ActualReturnAirflow | Get or set the Actual Return Airflow of the Space.
ActualSupplyAirflow | Get or set the Actual Supply Airflow of the Space.
Area | Get the Area of the Space.
AreaperPerson | Get the Area per Person of the Space.
AverageEstimatedIllumination | Get the Average Estimated Illumination of the Space.
BaseOffset | Get or Set the Base Offset of the Space.
Boundary | Returns the boundary of the Space.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CalculatedCoolingLoad | Get the Calculated Cooling Load of the Space.
CalculatedHeatingLoad | Get the Calculated Heating Load of the Space.
CalculatedSupplyAirflow | Get or set the Calculated Supply Airflow of the Space.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CeilingReflectance | Get or set the Ceiling Reflectance of the Space.
ClosedShell | Return the closedShell of the space.
ConditionType | Get or set the Condition type of the Space.
DesignCoolingLoad | Get the Design Cooling Load of the Space.
DesignExhaustAirflow | Get or set the Specified Exhaust Airflow of the Space.
DesignHeatingLoad | Get the Design Heating Load of the Space.
DesignHVACLoadperArea | Get or set the Design HVAC Load per Area of the Space.
DesignLightingLoad | Get or set the Design Lighting Load of the Space.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DesignOtherLoadperArea | Get or set the Design Other Load per Area of the Space.
DesignPowerLoad | Get or set the Design Power Load of the Space.
DesignReturnAirflow | Get or set the Specified Return Airflow of the Space.
DesignSupplyAirflow | Get or set the Specified Supply Airflow of the Space.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FloorReflectance | Get or set the Floor Reflectance of the Space.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
LatentHeatGainperPerson | Get or set the Latent Heat Gain per Person of the Space.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LightingCalculationWorkplane | Get the Lighting Calculation Workplane of the Space.
LightingLoadUnit | Get or Set the Lighting Load Unit of the Space.
LimitOffset | Get or Set the Limit Offset of the Space.
Location | get a location point object. The point within the location object should be get/set. This is the location of the room within the level. The Z location should be the elevation of the level and not changeable. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get or Set the Name of the Space. (Overrides Element..::.Name.)
Number | Get or Set the Name of the Number.
NumberofPeople | Get the Number of People of the Space.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
OccupancyUnit | Get the Occupancy Unit of the Space.
Occupiable | Reports whether this zone is Occupiable or not.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Perimeter | Get the Perimeter of the Space.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Plenum | Reports whether this zone is Plenum or not.
PowerLoadUnit | Get or Set the Power Load Unit of the Space.
ReturnAirflow | Get or set the Return type of Supply Airflow of the Space.
Room | Return the Room of the space.
SensibleHeatGainperPerson | Get the Sensible Heat Gain per Person of the Space.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SpaceCavityRatio | Get the Space Cavity Ratio of the Space.
SpaceConstruction | Get the Space Construction of the Space.
SpaceType | Get or set the Space type of the Space.
UnboundedHeight | Get the Unbounded Height of the Space.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpperLimit | Get or Set the Upper Limit of the Space.
Volume | Get the Volume of the Space.
WallReflectance | Get or set the Wall Reflectance of the Space.
Zone | Reports this space belong to which Zone.

See Also

Space Class
Autodesk.Revit.Elements Namespace


ActualExhaustAirflow Property

[image]

Revit 2010 API
Space..::.ActualExhaustAirflow Property
Space Class See Also Send Feedback
Get the Actual Exhaust Airflow of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ActualExhaustAirflow { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActualExhaustAirflow As Double
Visual C++
public:
property double ActualExhaustAirflow {
    double get ();
}

Remarks

This property is used to get the Actual Exhaust Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


ActualHVACLoad Property

[image]

Revit 2010 API
Space..::.ActualHVACLoad Property
Space Class See Also Send Feedback
Get or set the Actual HVAC Load of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ActualHVACLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActualHVACLoad As Double
Visual C++
public:
property double ActualHVACLoad {
    double get ();
}

Remarks

This property is used to get or set the Actual HVAC Load (Unit: W) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


ActualLightingLoad Property

[image]

Revit 2010 API
Space..::.ActualLightingLoad Property
Space Class See Also Send Feedback
Get the Actual Lighting Load of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ActualLightingLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActualLightingLoad As Double
Visual C++
public:
property double ActualLightingLoad {
    double get ();
}

Remarks

This property is used to get the Actual Lighting Load of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


ActualOtherLoad Property

[image]

Revit 2010 API
Space..::.ActualOtherLoad Property
Space Class See Also Send Feedback
Get or set the Actual Other Load of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ActualOtherLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActualOtherLoad As Double
Visual C++
public:
property double ActualOtherLoad {
    double get ();
}

Remarks

This property is used to get or set the Actual Other Load (Unit: W) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


ActualPowerLoad Property

[image]

Revit 2010 API
Space..::.ActualPowerLoad Property
Space Class See Also Send Feedback
Get the Actual Power Load of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ActualPowerLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActualPowerLoad As Double
Visual C++
public:
property double ActualPowerLoad {
    double get ();
}

Remarks

This property is used to get the Actual Power Load of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


ActualReturnAirflow Property

[image]

Revit 2010 API
Space..::.ActualReturnAirflow Property
Space Class See Also Send Feedback
Get or set the Actual Return Airflow of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ActualReturnAirflow { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActualReturnAirflow As Double
Visual C++
public:
property double ActualReturnAirflow {
    double get ();
}

Remarks

This property is used to get or set the Actual Return Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


ActualSupplyAirflow Property

[image]

Revit 2010 API
Space..::.ActualSupplyAirflow Property
Space Class See Also Send Feedback
Get or set the Actual Supply Airflow of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ActualSupplyAirflow { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActualSupplyAirflow As Double
Visual C++
public:
property double ActualSupplyAirflow {
    double get ();
}

Remarks

This property is used to get or set the Actual Supply Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Area Property

[image]

Revit 2010 API
Space..::.Area Property
Space Class See Also Send Feedback
Get the Area of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Area { get; }
Visual Basic (Declaration)
Public ReadOnly Property Area As Double
Visual C++
public:
property double Area {
    double get ();
}

Remarks

This property is used to get the Area of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


AreaperPerson Property

[image]

Revit 2010 API
Space..::.AreaperPerson Property
Space Class See Also Send Feedback
Get the Area per Person of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double AreaperPerson { get; set; }
Visual Basic (Declaration)
Public Property AreaperPerson As Double
Visual C++
public:
property double AreaperPerson {
    double get ();
    void set (double value);
}

Remarks

This property is used to get Area per Person of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


AverageEstimatedIllumination Property

[image]

Revit 2010 API
Space..::.AverageEstimatedIllumination Property
Space Class See Also Send Feedback
Get the Average Estimated Illumination of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double AverageEstimatedIllumination { get; }
Visual Basic (Declaration)
Public ReadOnly Property AverageEstimatedIllumination As Double
Visual C++
public:
property double AverageEstimatedIllumination {
    double get ();
}

Remarks

This property is used to get the Average Estimated Illumination of the Space. (Unit: fc)

See Also

Space Class
Autodesk.Revit.Elements Namespace


BaseOffset Property

[image]

Revit 2010 API
Space..::.BaseOffset Property
Space Class See Also Send Feedback
Get or Set the Base Offset of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double BaseOffset { get; set; }
Visual Basic (Declaration)
Public Property BaseOffset As Double
Visual C++
public:
property double BaseOffset {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Base Offset of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Boundary Property

[image]

Revit 2010 API
Space..::.Boundary Property
Space Class See Also Send Feedback
Returns the boundary of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundarySegmentArrayArray Boundary { get; }
Visual Basic (Declaration)
Public ReadOnly Property Boundary As BoundarySegmentArrayArray
Visual C++
public:
property BoundarySegmentArrayArray^ Boundary {
    BoundarySegmentArrayArray^ get ();
}

Remarks

This property is used to retrieve the segments that constitute the boundary of the Space. Each Space may have several regions, each of which have several segments hence the data is returned in the form of an array of boundary segment arrays. See the Space.BoundarySegment object for more details about the segments that make up the Space topology.

See Also

Space Class
Autodesk.Revit.Elements Namespace


CalculatedCoolingLoad Property

[image]

Revit 2010 API
Space..::.CalculatedCoolingLoad Property
Space Class See Also Send Feedback
Get the Calculated Cooling Load of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double CalculatedCoolingLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property CalculatedCoolingLoad As Double
Visual C++
public:
property double CalculatedCoolingLoad {
    double get ();
}

Remarks

This property is used to get the Calculated Cooling Load of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


CalculatedHeatingLoad Property

[image]

Revit 2010 API
Space..::.CalculatedHeatingLoad Property
Space Class See Also Send Feedback
Get the Calculated Heating Load of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double CalculatedHeatingLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property CalculatedHeatingLoad As Double
Visual C++
public:
property double CalculatedHeatingLoad {
    double get ();
}

Remarks

This property is used to get the Calculated Heating Load of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


CalculatedSupplyAirflow Property

[image]

Revit 2010 API
Space..::.CalculatedSupplyAirflow Property
Space Class See Also Send Feedback
Get or set the Calculated Supply Airflow of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double CalculatedSupplyAirflow { get; }
Visual Basic (Declaration)
Public ReadOnly Property CalculatedSupplyAirflow As Double
Visual C++
public:
property double CalculatedSupplyAirflow {
    double get ();
}

Remarks

This property is used to get or set the Calculated Supply Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


CeilingReflectance Property

[image]

Revit 2010 API
Space..::.CeilingReflectance Property
Space Class See Also Send Feedback
Get or set the Ceiling Reflectance of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double CeilingReflectance { get; set; }
Visual Basic (Declaration)
Public Property CeilingReflectance As Double
Visual C++
public:
property double CeilingReflectance {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Ceiling Reflectance of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


ClosedShell Property

[image]

Revit 2010 API
Space..::.ClosedShell Property
Space Class See Also Send Feedback
Return the closedShell of the space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element ClosedShell { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClosedShell As Element
Visual C++
public:
property Element^ ClosedShell {
    Element^ get ();
}

See Also

Space Class
Autodesk.Revit.Elements Namespace


ConditionType Property

[image]

Revit 2010 API
Space..::.ConditionType Property
Space Class See Also Send Feedback
Get or set the Condition type of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ConditionType ConditionType { get; set; }
Visual Basic (Declaration)
Public Property ConditionType As ConditionType
Visual C++
public:
property ConditionType ConditionType {
    ConditionType get ();
    void set (ConditionType value);
}

Remarks

This property is used to get or set the Condition type of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


DesignCoolingLoad Property

[image]

Revit 2010 API
Space..::.DesignCoolingLoad Property
Space Class See Also Send Feedback
Get the Design Cooling Load of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double DesignCoolingLoad { get; set; }
Visual Basic (Declaration)
Public Property DesignCoolingLoad As Double
Visual C++
public:
property double DesignCoolingLoad {
    double get ();
    void set (double value);
}

Remarks

This property is used to get the Design Cooling Load of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


DesignExhaustAirflow Property

[image]

Revit 2010 API
Space..::.DesignExhaustAirflow Property
Space Class See Also Send Feedback
Get or set the Specified Exhaust Airflow of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double DesignExhaustAirflow { get; set; }
Visual Basic (Declaration)
Public Property DesignExhaustAirflow As Double
Visual C++
public:
property double DesignExhaustAirflow {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Specified Exhaust Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


DesignHeatingLoad Property

[image]

Revit 2010 API
Space..::.DesignHeatingLoad Property
Space Class See Also Send Feedback
Get the Design Heating Load of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double DesignHeatingLoad { get; set; }
Visual Basic (Declaration)
Public Property DesignHeatingLoad As Double
Visual C++
public:
property double DesignHeatingLoad {
    double get ();
    void set (double value);
}

Remarks

This property is used to get the Design Heating Load of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


DesignHVACLoadperArea Property

[image]

Revit 2010 API
Space..::.DesignHVACLoadperArea Property
Space Class See Also Send Feedback
Get or set the Design HVAC Load per Area of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double DesignHVACLoadperArea { get; set; }
Visual Basic (Declaration)
Public Property DesignHVACLoadperArea As Double
Visual C++
public:
property double DesignHVACLoadperArea {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Design HVAC Load per Area (Unit: W/ft2) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


DesignLightingLoad Property

[image]

Revit 2010 API
Space..::.DesignLightingLoad Property
Space Class See Also Send Feedback
Get or set the Design Lighting Load of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double DesignLightingLoad { get; set; }
Visual Basic (Declaration)
Public Property DesignLightingLoad As Double
Visual C++
public:
property double DesignLightingLoad {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Design Lighting Load of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


DesignOtherLoadperArea Property

[image]

Revit 2010 API
Space..::.DesignOtherLoadperArea Property
Space Class See Also Send Feedback
Get or set the Design Other Load per Area of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double DesignOtherLoadperArea { get; set; }
Visual Basic (Declaration)
Public Property DesignOtherLoadperArea As Double
Visual C++
public:
property double DesignOtherLoadperArea {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Design Other Load per Area (Unit: W/ft2) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


DesignPowerLoad Property

[image]

Revit 2010 API
Space..::.DesignPowerLoad Property
Space Class See Also Send Feedback
Get or set the Design Power Load of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double DesignPowerLoad { get; set; }
Visual Basic (Declaration)
Public Property DesignPowerLoad As Double
Visual C++
public:
property double DesignPowerLoad {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Design Power Load of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


DesignReturnAirflow Property

[image]

Revit 2010 API
Space..::.DesignReturnAirflow Property
Space Class See Also Send Feedback
Get or set the Specified Return Airflow of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double DesignReturnAirflow { get; set; }
Visual Basic (Declaration)
Public Property DesignReturnAirflow As Double
Visual C++
public:
property double DesignReturnAirflow {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Specified Return Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


DesignSupplyAirflow Property

[image]

Revit 2010 API
Space..::.DesignSupplyAirflow Property
Space Class See Also Send Feedback
Get or set the Specified Supply Airflow of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double DesignSupplyAirflow { get; set; }
Visual Basic (Declaration)
Public Property DesignSupplyAirflow As Double
Visual C++
public:
property double DesignSupplyAirflow {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Specified Supply Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


FloorReflectance Property

[image]

Revit 2010 API
Space..::.FloorReflectance Property
Space Class See Also Send Feedback
Get or set the Floor Reflectance of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double FloorReflectance { get; set; }
Visual Basic (Declaration)
Public Property FloorReflectance As Double
Visual C++
public:
property double FloorReflectance {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Floor Reflectance of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


LatentHeatGainperPerson Property

[image]

Revit 2010 API
Space..::.LatentHeatGainperPerson Property
Space Class See Also Send Feedback
Get or set the Latent Heat Gain per Person of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double LatentHeatGainperPerson { get; set; }
Visual Basic (Declaration)
Public Property LatentHeatGainperPerson As Double
Visual C++
public:
property double LatentHeatGainperPerson {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Latent Heat Gain per Person of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


LightingCalculationWorkplane Property

[image]

Revit 2010 API
Space..::.LightingCalculationWorkplane Property
Space Class See Also Send Feedback
Get the Lighting Calculation Workplane of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double LightingCalculationWorkplane { get; set; }
Visual Basic (Declaration)
Public Property LightingCalculationWorkplane As Double
Visual C++
public:
property double LightingCalculationWorkplane {
    double get ();
    void set (double value);
}

Remarks

This property is used to get the Lighting Calculation Workplane (Unit: feet) of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


LightingLoadUnit Property

[image]

Revit 2010 API
Space..::.LightingLoadUnit Property
Space Class See Also Send Feedback
Get or Set the Lighting Load Unit of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BaseLoadOn LightingLoadUnit { get; set; }
Visual Basic (Declaration)
Public Property LightingLoadUnit As BaseLoadOn
Visual C++
public:
property BaseLoadOn LightingLoadUnit {
    BaseLoadOn get ();
    void set (BaseLoadOn value);
}

Remarks

This property is used to get or set the Lighting Load Unit of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


LimitOffset Property

[image]

Revit 2010 API
Space..::.LimitOffset Property
Space Class See Also Send Feedback
Get or Set the Limit Offset of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double LimitOffset { get; set; }
Visual Basic (Declaration)
Public Property LimitOffset As Double
Visual C++
public:
property double LimitOffset {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Limit Offset of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Location Property

[image]

Revit 2010 API
Space..::.Location Property
Space Class See Also Send Feedback
get a location point object. The point within the location object should be get/set. This is the location of the room within the level. The Z location should be the elevation of the level and not changeable.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

See Also

Space Class
Autodesk.Revit.Elements Namespace


Name Property

[image]

Revit 2010 API
Space..::.Name Property
Space Class See Also Send Feedback
Get or Set the Name of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

This property is used to get or set the Space of the room.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Number Property

[image]

Revit 2010 API
Space..::.Number Property
Space Class See Also Send Feedback
Get or Set the Name of the Number.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Number { get; set; }
Visual Basic (Declaration)
Public Property Number As String
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Number of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


NumberofPeople Property

[image]

Revit 2010 API
Space..::.NumberofPeople Property
Space Class See Also Send Feedback
Get the Number of People of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double NumberofPeople { get; set; }
Visual Basic (Declaration)
Public Property NumberofPeople As Double
Visual C++
public:
property double NumberofPeople {
    double get ();
    void set (double value);
}

Remarks

This property is used to get Number of People of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


OccupancyUnit Property

[image]

Revit 2010 API
Space..::.OccupancyUnit Property
Space Class See Also Send Feedback
Get the Occupancy Unit of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public OccupancyUnit OccupancyUnit { get; set; }
Visual Basic (Declaration)
Public Property OccupancyUnit As OccupancyUnit
Visual C++
public:
property OccupancyUnit OccupancyUnit {
    OccupancyUnit get ();
    void set (OccupancyUnit value);
}

Remarks

This property is used to get the Occupancy Unit of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Occupiable Property

[image]

Revit 2010 API
Space..::.Occupiable Property
Space Class See Also Send Feedback
Reports whether this zone is Occupiable or not.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Occupiable { get; }
Visual Basic (Declaration)
Public ReadOnly Property Occupiable As Boolean
Visual C++
public:
property bool Occupiable {
    bool get ();
}

See Also

Space Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Space..::.Parameter Property
Space Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Space Class
Space Members
Autodesk.Revit.Elements Namespace


Perimeter Property

[image]

Revit 2010 API
Space..::.Perimeter Property
Space Class See Also Send Feedback
Get the Perimeter of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Perimeter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Perimeter As Double
Visual C++
public:
property double Perimeter {
    double get ();
}

Remarks

This property is used to get the Perimeter of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Plenum Property

[image]

Revit 2010 API
Space..::.Plenum Property
Space Class See Also Send Feedback
Reports whether this zone is Plenum or not.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Plenum { get; }
Visual Basic (Declaration)
Public ReadOnly Property Plenum As Boolean
Visual C++
public:
property bool Plenum {
    bool get ();
}

See Also

Space Class
Autodesk.Revit.Elements Namespace


PowerLoadUnit Property

[image]

Revit 2010 API
Space..::.PowerLoadUnit Property
Space Class See Also Send Feedback
Get or Set the Power Load Unit of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BaseLoadOn PowerLoadUnit { get; set; }
Visual Basic (Declaration)
Public Property PowerLoadUnit As BaseLoadOn
Visual C++
public:
property BaseLoadOn PowerLoadUnit {
    BaseLoadOn get ();
    void set (BaseLoadOn value);
}

Remarks

This property is used to get or set the Power Load Unit of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


ReturnAirflow Property

[image]

Revit 2010 API
Space..::.ReturnAirflow Property
Space Class See Also Send Feedback
Get or set the Return type of Supply Airflow of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReturnAirflowType ReturnAirflow { get; set; }
Visual Basic (Declaration)
Public Property ReturnAirflow As ReturnAirflowType
Visual C++
public:
property ReturnAirflowType ReturnAirflow {
    ReturnAirflowType get ();
    void set (ReturnAirflowType value);
}

Remarks

This property is used to get or set the Return type of Supply Airflow of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Room Property

[image]

Revit 2010 API
Space..::.Room Property
Space Class See Also Send Feedback
Return the Room of the space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Room Room { get; }
Visual Basic (Declaration)
Public ReadOnly Property Room As Room
Visual C++
public:
property Room^ Room {
    Room^ get ();
}

See Also

Space Class
Autodesk.Revit.Elements Namespace


SensibleHeatGainperPerson Property

[image]

Revit 2010 API
Space..::.SensibleHeatGainperPerson Property
Space Class See Also Send Feedback
Get the Sensible Heat Gain per Person of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double SensibleHeatGainperPerson { get; set; }
Visual Basic (Declaration)
Public Property SensibleHeatGainperPerson As Double
Visual C++
public:
property double SensibleHeatGainperPerson {
    double get ();
    void set (double value);
}

Remarks

This property is used to get the Sensible Heat Gain per Person of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


SpaceCavityRatio Property

[image]

Revit 2010 API
Space..::.SpaceCavityRatio Property
Space Class See Also Send Feedback
Get the Space Cavity Ratio of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double SpaceCavityRatio { get; }
Visual Basic (Declaration)
Public ReadOnly Property SpaceCavityRatio As Double
Visual C++
public:
property double SpaceCavityRatio {
    double get ();
}

Remarks

This property is used to get the Space Cavity Ratio of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


SpaceConstruction Property

[image]

Revit 2010 API
Space..::.SpaceConstruction Property
Space Class See Also Send Feedback
Get the Space Construction of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MEPSpaceConstruction SpaceConstruction { get; }
Visual Basic (Declaration)
Public ReadOnly Property SpaceConstruction As MEPSpaceConstruction
Visual C++
public:
property MEPSpaceConstruction^ SpaceConstruction {
    MEPSpaceConstruction^ get ();
}

Remarks

This property is used to get the Space Construction of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


SpaceType Property

[image]

Revit 2010 API
Space..::.SpaceType Property
Space Class See Also Send Feedback
Get or set the Space type of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpaceType SpaceType { get; set; }
Visual Basic (Declaration)
Public Property SpaceType As SpaceType
Visual C++
public:
property SpaceType SpaceType {
    SpaceType get ();
    void set (SpaceType value);
}

Remarks

This property is used to get or set the Space type of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


UnboundedHeight Property

[image]

Revit 2010 API
Space..::.UnboundedHeight Property
Space Class See Also Send Feedback
Get the Unbounded Height of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double UnboundedHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property UnboundedHeight As Double
Visual C++
public:
property double UnboundedHeight {
    double get ();
}

Remarks

This property is used to get the Unbounded Height of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


UpperLimit Property

[image]

Revit 2010 API
Space..::.UpperLimit Property
Space Class See Also Send Feedback
Get or Set the Upper Limit of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Level UpperLimit { get; set; }
Visual Basic (Declaration)
Public Property UpperLimit As Level
Visual C++
public:
property Level^ UpperLimit {
    Level^ get ();
    void set (Level^ value);
}

Remarks

This property is used to get or set the Upper Limit of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Volume Property

[image]

Revit 2010 API
Space..::.Volume Property
Space Class See Also Send Feedback
Get the Volume of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Volume { get; }
Visual Basic (Declaration)
Public ReadOnly Property Volume As Double
Visual C++
public:
property double Volume {
    double get ();
}

Remarks

This property is used to get the Volume of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


WallReflectance Property

[image]

Revit 2010 API
Space..::.WallReflectance Property
Space Class See Also Send Feedback
Get or set the Wall Reflectance of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double WallReflectance { get; set; }
Visual Basic (Declaration)
Public Property WallReflectance As Double
Visual C++
public:
property double WallReflectance {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Wall Reflectance of the Space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


Zone Property

[image]

Revit 2010 API
Space..::.Zone Property
Space Class See Also Send Feedback
Reports this space belong to which Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Zone Zone { get; }
Visual Basic (Declaration)
Public ReadOnly Property Zone As Zone
Visual C++
public:
property Zone^ Zone {
    Zone^ get ();
}

Remarks

This property is used to retrieve the host zone of this space.

See Also

Space Class
Autodesk.Revit.Elements Namespace


SpaceSet Class

[image]

Revit 2010 API
SpaceSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SpaceSet : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class SpaceSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SpaceSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.SpaceSet

See Also

SpaceSet Members
Autodesk.Revit.Elements Namespace


SpaceSet Members

[image] [image]

Revit 2010 API
SpaceSet Members
SpaceSet Class Constructors Methods Properties See Also Send Feedback

The SpaceSet type exposes the following members.

Constructors

Name | Description
SpaceSet | Initializes a new instance of the SpaceSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


SpaceSet Constructor

[image]

Revit 2010 API
SpaceSet Constructor
SpaceSet Class See Also Send Feedback
Initializes a new instance of the SpaceSet class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpaceSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpaceSet()

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


SpaceSet Methods

[image] [image]

Revit 2010 API
SpaceSet Methods
SpaceSet Class See Also Send Feedback

The SpaceSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


Clear Method

[image]

Revit 2010 API
SpaceSet..::.Clear Method
SpaceSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


Contains Method

[image]

Revit 2010 API
SpaceSet..::.Contains Method
SpaceSet Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    Space item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Space _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Space^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.Space

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


Erase Method

[image]

Revit 2010 API
SpaceSet..::.Erase Method
SpaceSet Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    Space item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Space _
) As Integer
Visual C++
public:
virtual int Erase(
    Space^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.Space

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

[image]

Revit 2010 API
SpaceSet..::.ForwardIterator Method
SpaceSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual SpaceSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SpaceSetIterator
Visual C++
public:
virtual SpaceSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

[image]

Revit 2010 API
SpaceSet..::.GetEnumerator Method
SpaceSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


Insert Method

[image]

Revit 2010 API
SpaceSet..::.Insert Method
SpaceSet Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    Space item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Space _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Space^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.Space

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

[image]

Revit 2010 API
SpaceSet..::.ReverseIterator Method
SpaceSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual SpaceSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SpaceSetIterator
Visual C++
public:
virtual SpaceSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


SpaceSet Properties

[image] [image]

Revit 2010 API
SpaceSet Properties
SpaceSet Class See Also Send Feedback

The SpaceSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


IsEmpty Property

[image]

Revit 2010 API
SpaceSet..::.IsEmpty Property
SpaceSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


Size Property

[image]

Revit 2010 API
SpaceSet..::.Size Property
SpaceSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SpaceSet Class
Autodesk.Revit.Elements Namespace


SpaceSetIterator Class

[image]

Revit 2010 API
SpaceSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class SpaceSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class SpaceSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SpaceSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.SpaceSetIterator

See Also

SpaceSetIterator Members
Autodesk.Revit.Elements Namespace


SpaceSetIterator Members

[image] [image]

Revit 2010 API
SpaceSetIterator Members
SpaceSetIterator Class Constructors Methods Properties See Also Send Feedback

The SpaceSetIterator type exposes the following members.

Constructors

Name | Description
SpaceSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpaceSetIterator Class
Autodesk.Revit.Elements Namespace


SpaceSetIterator Constructor

[image]

Revit 2010 API
SpaceSetIterator Constructor
SpaceSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpaceSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpaceSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SpaceSetIterator Class
Autodesk.Revit.Elements Namespace


SpaceSetIterator Methods

[image] [image]

Revit 2010 API
SpaceSetIterator Methods
SpaceSetIterator Class See Also Send Feedback

The SpaceSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

[image]

Revit 2010 API
SpaceSetIterator..::.MoveNext Method
SpaceSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SpaceSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

[image]

Revit 2010 API
SpaceSetIterator..::.Reset Method
SpaceSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SpaceSetIterator Class
Autodesk.Revit.Elements Namespace


SpaceSetIterator Properties

[image] [image]

Revit 2010 API
SpaceSetIterator Properties
SpaceSetIterator Class See Also Send Feedback

The SpaceSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpaceSetIterator Class
Autodesk.Revit.Elements Namespace


Current Property

[image]

Revit 2010 API
SpaceSetIterator..::.Current Property
SpaceSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SpaceSetIterator Class
Autodesk.Revit.Elements Namespace


SpaceTag Class

[image]

Revit 2010 API
SpaceTag Class
Members See Also Send Feedback
Provides access to the space tag in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SpaceTag : Element
Visual Basic (Declaration)
Public Class SpaceTag _
    Inherits Element
Visual C++
public ref class SpaceTag : public Element

Remarks

The space Tag object can be queried for space information.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.SpaceTag

See Also

SpaceTag Members
Autodesk.Revit.Elements Namespace


SpaceTag Members

[image] [image]

Revit 2010 API
SpaceTag Members
SpaceTag Class Constructors Methods Properties See Also Send Feedback

The SpaceTag type exposes the following members.

Constructors

Name | Description
SpaceTag | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Leader | Get/set the display attribute of Leader.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | Get a location point object. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Retrieve or Change the name associated with the SpaceTag. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Space | Returns the area associated with the tag.
SpaceTagType | Get/set the type.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
View | Returns the view in which the tag was placed.

See Also

SpaceTag Class
Autodesk.Revit.Elements Namespace


SpaceTag Constructor

[image]

Revit 2010 API
SpaceTag Constructor
SpaceTag Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpaceTag()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpaceTag()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SpaceTag Class
Autodesk.Revit.Elements Namespace


SpaceTag Methods

[image] [image]

Revit 2010 API
SpaceTag Methods
SpaceTag Class See Also Send Feedback

The SpaceTag type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceTag Class
Autodesk.Revit.Elements Namespace


SpaceTag Properties

[image] [image]

Revit 2010 API
SpaceTag Properties
SpaceTag Class See Also Send Feedback

The SpaceTag type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Leader | Get/set the display attribute of Leader.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | Get a location point object. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Retrieve or Change the name associated with the SpaceTag. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Space | Returns the area associated with the tag.
SpaceTagType | Get/set the type.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
View | Returns the view in which the tag was placed.

See Also

SpaceTag Class
Autodesk.Revit.Elements Namespace


Leader Property

[image]

Revit 2010 API
SpaceTag..::.Leader Property
SpaceTag Class See Also Send Feedback
Get/set the display attribute of Leader.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Leader { get; set; }
Visual Basic (Declaration)
Public Property Leader As Boolean
Visual C++
public:
property bool Leader {
    bool get ();
    void set (bool value);
}

Remarks

Get/set, will be true if the leader is displayed, otherwise it is false.

See Also

SpaceTag Class
Autodesk.Revit.Elements Namespace


Location Property

[image]

Revit 2010 API
SpaceTag..::.Location Property
SpaceTag Class See Also Send Feedback
Get a location point object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

The point within the location object should be get/set. This is the location of the space within the level. The Z location should be the elevation of the level and not changeable.

See Also

SpaceTag Class
Autodesk.Revit.Elements Namespace


Name Property

[image]

Revit 2010 API
SpaceTag..::.Name Property
SpaceTag Class See Also Send Feedback
Retrieve or Change the name associated with the SpaceTag.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

If the property inherited from the element is hidden, a System.InvalidOperationException is thrown.

See Also

SpaceTag Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
SpaceTag..::.Parameter Property
SpaceTag Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SpaceTag Class
SpaceTag Members
Autodesk.Revit.Elements Namespace


Space Property

[image]

Revit 2010 API
SpaceTag..::.Space Property
SpaceTag Class See Also Send Feedback
Returns the area associated with the tag.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Space Space { get; }
Visual Basic (Declaration)
Public ReadOnly Property Space As Space
Visual C++
public:
property Space^ Space {
    Space^ get ();
}

Remarks

Get the area associated with the tag.

See Also

SpaceTag Class
Autodesk.Revit.Elements Namespace


SpaceTagType Property

[image]

Revit 2010 API
SpaceTag..::.SpaceTagType Property
SpaceTag Class See Also Send Feedback
Get/set the type.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpaceTagType SpaceTagType { get; set; }
Visual Basic (Declaration)
Public Property SpaceTagType As SpaceTagType
Visual C++
public:
property SpaceTagType^ SpaceTagType {
    SpaceTagType^ get ();
    void set (SpaceTagType^ value);
}

Remarks

Get/set the type for the current AreaTag.

See Also

SpaceTag Class
Autodesk.Revit.Elements Namespace


View Property

[image]

Revit 2010 API
SpaceTag..::.View Property
SpaceTag Class See Also Send Feedback
Returns the view in which the tag was placed.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public View View { get; }
Visual Basic (Declaration)
Public ReadOnly Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
}

Remarks

Get the view in which the tag was placed.

See Also

SpaceTag Class
Autodesk.Revit.Elements Namespace


SpacingRule Class

[image]

Revit 2010 API
SpacingRule Class
Members See Also Send Feedback
A rule for specifying a set of equidistant, parallel gridlines within a region.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SpacingRule : APIObject
Visual Basic (Declaration)
Public Class SpacingRule _
    Inherits APIObject
Visual C++
public ref class SpacingRule : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.SpacingRule

See Also

SpacingRule Members
Autodesk.Revit.Elements Namespace


SpacingRule Members

[image] [image]

Revit 2010 API
SpacingRule Members
SpacingRule Class Constructors Methods Properties See Also Send Feedback

The SpacingRule type exposes the following members.

Constructors

Name | Description
SpacingRule | Initializes a new instance of the SpacingRule class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetLayoutFixedDistance | Set the Layout property to FixedDistance.
SetLayoutFixedNumber | Set the Layout property to FixedNumber.
SetLayoutMaximumSpacing | Set the Layout property to MaximumSpacing.
SetLayoutMinimumSpacing | Set the Layout property to MinimumSpacing.
SetLayoutNone | Set the Layout property to None.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BeltMeasurement | On a curved surface, BeltMeasurement specifies where the grid's distances are measured.
Distance | The exact distance between layout lines.
GridlinesRotation | An additional rotation to be applied to this set of grid lines.
HasBeltMeasurement | True if the gridlines are not parallel due to surface curvature, and the BeltMeasurement property therefore applies.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Justification | The justification of the lines within the region.
Layout | A choice of several gridline layout rules.
Number | The exact number of lines in the region.
Offset | An additional offset applied to the first gridline.

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace


SpacingRule Constructor

[image]

Revit 2010 API
SpacingRule Constructor
SpacingRule Class See Also Send Feedback
Initializes a new instance of the SpacingRule class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpacingRule()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpacingRule()

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace


SpacingRule Methods

[image] [image]

Revit 2010 API
SpacingRule Methods
SpacingRule Class See Also Send Feedback

The SpacingRule type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetLayoutFixedDistance | Set the Layout property to FixedDistance.
SetLayoutFixedNumber | Set the Layout property to FixedNumber.
SetLayoutMaximumSpacing | Set the Layout property to MaximumSpacing.
SetLayoutMinimumSpacing | Set the Layout property to MinimumSpacing.
SetLayoutNone | Set the Layout property to None.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace


SetLayoutFixedDistance Method

[image]

Revit 2010 API
SpacingRule..::.SetLayoutFixedDistance Method
SpacingRule Class See Also Send Feedback
Set the Layout property to FixedDistance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetLayoutFixedDistance(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
Visual Basic (Declaration)
Public Sub SetLayoutFixedDistance ( _
    distance As Double, _
    just As SpacingRuleJustification, _
    gridlinesRotation As Double, _
    offset As Double _
)
Visual C++
public:
void SetLayoutFixedDistance(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)

Parameters

distance
Type: System..::.Double
just
Type: Autodesk.Revit.Enums..::.SpacingRuleJustification
gridlinesRotation
Type: System..::.Double
offset
Type: System..::.Double

Remarks

When changing the Layout to FixedDistance, you must also simultaneously set the Distance, Justification, GridlinesRotation, and Offset properties.

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace


SetLayoutFixedNumber Method

[image]

Revit 2010 API
SpacingRule..::.SetLayoutFixedNumber Method
SpacingRule Class See Also Send Feedback
Set the Layout property to FixedNumber.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetLayoutFixedNumber(
    int number,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
Visual Basic (Declaration)
Public Sub SetLayoutFixedNumber ( _
    number As Integer, _
    just As SpacingRuleJustification, _
    gridlinesRotation As Double, _
    offset As Double _
)
Visual C++
public:
void SetLayoutFixedNumber(
    int number,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)

Parameters

number
Type: System..::.Int32
just
Type: Autodesk.Revit.Enums..::.SpacingRuleJustification
gridlinesRotation
Type: System..::.Double
offset
Type: System..::.Double

Remarks

When changing the Layout to FixedNumber, you must also simultaneously set the Number, Justification, GridlinesRotation, and Offset properties.

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace


SetLayoutMaximumSpacing Method

[image]

Revit 2010 API
SpacingRule..::.SetLayoutMaximumSpacing Method
SpacingRule Class See Also Send Feedback
Set the Layout property to MaximumSpacing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetLayoutMaximumSpacing(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
Visual Basic (Declaration)
Public Sub SetLayoutMaximumSpacing ( _
    distance As Double, _
    just As SpacingRuleJustification, _
    gridlinesRotation As Double, _
    offset As Double _
)
Visual C++
public:
void SetLayoutMaximumSpacing(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)

Parameters

distance
Type: System..::.Double
just
Type: Autodesk.Revit.Enums..::.SpacingRuleJustification
gridlinesRotation
Type: System..::.Double
offset
Type: System..::.Double

Remarks

When changing the Layout to MaximumSpacing, you must also simultaneously set the Distance, Justification, GridlinesRotation, and Offset properties.

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace


SetLayoutMinimumSpacing Method

[image]

Revit 2010 API
SpacingRule..::.SetLayoutMinimumSpacing Method
SpacingRule Class See Also Send Feedback
Set the Layout property to MinimumSpacing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetLayoutMinimumSpacing(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
Visual Basic (Declaration)
Public Sub SetLayoutMinimumSpacing ( _
    distance As Double, _
    just As SpacingRuleJustification, _
    gridlinesRotation As Double, _
    offset As Double _
)
Visual C++
public:
void SetLayoutMinimumSpacing(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)

Parameters

distance
Type: System..::.Double
just
Type: Autodesk.Revit.Enums..::.SpacingRuleJustification
gridlinesRotation
Type: System..::.Double
offset
Type: System..::.Double

Remarks

When changing the Layout to MinimumSpacing, you must also simultaneously set the Distance, Justification, GridlinesRotation, and Offset properties.

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace


SetLayoutNone Method

[image]

Revit 2010 API
SpacingRule..::.SetLayoutNone Method
SpacingRule Class See Also Send Feedback
Set the Layout property to None.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetLayoutNone()
Visual Basic (Declaration)
Public Sub SetLayoutNone
Visual C++
public:
void SetLayoutNone()

Remarks

No internal lines will be generated, but the effect is equivalent to having two lines, one at each end of the region.

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace


SpacingRule Properties

[image] [image]

Revit 2010 API
SpacingRule Properties
SpacingRule Class See Also Send Feedback

The SpacingRule type exposes the following members.

Properties

Name | Description
BeltMeasurement | On a curved surface, BeltMeasurement specifies where the grid's distances are measured.
Distance | The exact distance between layout lines.
GridlinesRotation | An additional rotation to be applied to this set of grid lines.
HasBeltMeasurement | True if the gridlines are not parallel due to surface curvature, and the BeltMeasurement property therefore applies.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Justification | The justification of the lines within the region.
Layout | A choice of several gridline layout rules.
Number | The exact number of lines in the region.
Offset | An additional offset applied to the first gridline.

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace


BeltMeasurement Property

[image]

Revit 2010 API
SpacingRule..::.BeltMeasurement Property
SpacingRule Class See Also Send Feedback
On a curved surface, BeltMeasurement specifies where the grid's distances are measured.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double BeltMeasurement { get; set; }
Visual Basic (Declaration)
Public Property BeltMeasurement As Double
Visual C++
public:
property double BeltMeasurement {
    double get ();
    void set (double value);
}

Remarks

On a conical surface, the distance between the radial gridlines is not constant. To interpret the Distance property, a circumferential gridline is taken as the "belt." Distance is then measured along the belt. The BeltMeasurement property gives the location of the belt relative to the extremes of the surface. The belt is used whenever gridlines are not parallel. It defaults to 0.5.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when beltMeasurement is outside the range [ 0.0, 1.0 ].
System..::.InvalidOperationException | Thrown when the gridlines are guaranteed to be parallel; check the HasBeltMeasurement property before using this property.

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace


Distance Property

[image]

Revit 2010 API
SpacingRule..::.Distance Property
SpacingRule Class See Also Send Feedback
The exact distance between layout lines.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Distance { get; set; }
Visual Basic (Declaration)
Public Property Distance As Double
Visual C++
public:
property double Distance {
    double get ();
    void set (double value);
}

Remarks

This property is only available when Layout is equal to FixedDistance, MaximumSpacing, or MinimumSpacing. Must be a positive value less than 30000'.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the Layout property is None or FixedNumber.

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace


GridlinesRotation Property

[image]

Revit 2010 API
SpacingRule..::.GridlinesRotation Property
SpacingRule Class See Also Send Feedback
An additional rotation to be applied to this set of grid lines.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double GridlinesRotation { get; set; }
Visual Basic (Declaration)
Public Property GridlinesRotation As Double
Visual C++
public:
property double GridlinesRotation {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when angle is outside of the range ( -PI/2, PI/2 ).

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace


HasBeltMeasurement Property

[image]

Revit 2010 API
SpacingRule..::.HasBeltMeasurement Property
SpacingRule Class See Also Send Feedback
True if the gridlines are not parallel due to surface curvature, and the BeltMeasurement property therefore applies.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool HasBeltMeasurement { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasBeltMeasurement As Boolean
Visual C++
public:
property bool HasBeltMeasurement {
    bool get ();
}

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace


Justification Property

[image]

Revit 2010 API
SpacingRule..::.Justification Property
SpacingRule Class See Also Send Feedback
The justification of the lines within the region.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpacingRuleJustification Justification { get; set; }
Visual Basic (Declaration)
Public Property Justification As SpacingRuleJustification
Visual C++
public:
property SpacingRuleJustification Justification {
    SpacingRuleJustification get ();
    void set (SpacingRuleJustification value);
}

Remarks

This property is only available when Layout is equal to FixedDistance, FixedNumber, MaximumSpacing, or MinimumSpacing.

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace


Layout Property

[image]

Revit 2010 API
SpacingRule..::.Layout Property
SpacingRule Class See Also Send Feedback
A choice of several gridline layout rules.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpacingRuleLayout Layout { get; }
Visual Basic (Declaration)
Public ReadOnly Property Layout As SpacingRuleLayout
Visual C++
public:
property SpacingRuleLayout Layout {
    SpacingRuleLayout get ();
}

Remarks

If "None" is chosen, no internal lines will be generated, but the effect is equivalent to having two lines, one at each end of the region.

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace


Number Property

[image]

Revit 2010 API
SpacingRule..::.Number Property
SpacingRule Class See Also Send Feedback
The exact number of lines in the region.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Number { get; set; }
Visual Basic (Declaration)
Public Property Number As Integer
Visual C++
public:
property int Number {
    int get ();
    void set (int value);
}

Remarks

This property is only available when Layout is equal to FixedNumber. Lines will be placed exactly at the boundaries if possible, so if your region is 100' long and you specify Number = 11, your lines will be 10' apart. Must be between 1 and 200.

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace


Offset Property

[image]

Revit 2010 API
SpacingRule..::.Offset Property
SpacingRule Class See Also Send Feedback
An additional offset applied to the first gridline.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Offset { get; set; }
Visual Basic (Declaration)
Public Property Offset As Double
Visual C++
public:
property double Offset {
    double get ();
    void set (double value);
}

Remarks

Measured in feet. Must be between -30000' and 30000'.

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace


SpotDimension Class

[image]

Revit 2010 API
SpotDimension Class
Members Example See Also Send Feedback
An object that represents a spot dimension within the Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SpotDimension : Dimension
Visual Basic (Declaration)
Public Class SpotDimension _
    Inherits Dimension
Visual C++
public ref class SpotDimension : public Dimension

Examples

CopyC#
private void Getinfo_SpotDimension(SpotDimension spotDimension)
{
    string message = "SpotDimension's Location : ";
    Location location = spotDimension.Location;

    if (location is LocationPoint)
    {
        LocationPoint point = location as LocationPoint;

        message += "\n" + location.GetType().Name + " : ";
        message += "(" + point.Point.X + ", " + point.Point.Y + ", " + point.Point.Z + ")";
    }
    else
    {
        LocationCurve locCurve = location as LocationCurve;
        Curve curve = locCurve.Curve;
        message += "\n" + location.GetType().Name + " : ";
        message += "\nStart Point : " + "(" + curve.get_EndPoint(0).X + ", "
                    + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        message += "\nEnd point : " + "(" + curve.get_EndPoint(1).X + ", "
                    + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
    }

    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Private Sub Getinfo_SpotDimension(ByVal spotDimension As SpotDimension)
    Dim message As String = "SpotDimension's Location : "
    Dim location As Location = spotDimension.Location

    If TypeOf location Is LocationPoint Then
        Dim point As LocationPoint = TryCast(location, LocationPoint)

        message += vbLf & location.[GetType]().Name & " : "
        message += (("(" & point.Point.X & ", ") + point.Point.Y & ", ") + point.Point.Z & ")"
    Else
        Dim locCurve As LocationCurve = TryCast(location, LocationCurve)
        Dim curve As Curve = locCurve.Curve
        message += vbLf & location.[GetType]().Name & " : "
        message += (((vbLf & "Start Point : " & "(") + curve.EndPoint(0).X & ", ") + curve.EndPoint(0).Y & ", ") + curve.EndPoint(0).Z & ")"
        message += (((vbLf & "End point : " & "(") + curve.EndPoint(1).X & ", ") + curve.EndPoint(1).Y & ", ") + curve.EndPoint(1).Z & ")"
    End If

    MessageBox.Show(message, "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Dimension
Autodesk.Revit.Elements..::.SpotDimension

See Also

SpotDimension Members
Autodesk.Revit.Elements Namespace


SpotDimension Members

[image] [image]

Revit 2010 API
SpotDimension Members
SpotDimension Class Constructors Methods Properties See Also Send Feedback

The SpotDimension type exposes the following members.

Constructors

Name | Description
SpotDimension | Initializes a new instance of the SpotDimension class

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AreSegmentsEqual | Indicates if all segments are forced to be equal. (Inherited from Dimension.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | A curve that represents the dimension line. (Inherited from Dimension.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DimensionShape | The shape of this dimension. (Inherited from Dimension.)
DimensionType | The dimension style of this dimension. (Inherited from Dimension.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsLocked | Indicates if this dimension is locked. (Inherited from Dimension.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Label | The family parameter label of the dimension. (Inherited from Dimension.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | Get a location point object. This is the location of the spot dimension. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Retrieve or Change the name associated with the Dimension. (Inherited from Dimension.)
NumberOfSegments | The number of segments for the dimension. (Inherited from Dimension.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension.)
Segments | The segments in the dimension. (Inherited from Dimension.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SpotDimensionType | The dimension style of this dimension.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Value | The value of the dimension. (Inherited from Dimension.)
ValueString | The dimension value as a user visible string. (Inherited from Dimension.)
View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension.)

See Also

SpotDimension Class
Autodesk.Revit.Elements Namespace


SpotDimension Constructor

[image]

Revit 2010 API
SpotDimension Constructor
SpotDimension Class See Also Send Feedback
Initializes a new instance of the SpotDimension class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpotDimension()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpotDimension()

See Also

SpotDimension Class
Autodesk.Revit.Elements Namespace


SpotDimension Methods

[image] [image]

Revit 2010 API
SpotDimension Methods
SpotDimension Class See Also Send Feedback

The SpotDimension type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpotDimension Class
Autodesk.Revit.Elements Namespace


SpotDimension Properties

[image] [image]

Revit 2010 API
SpotDimension Properties
SpotDimension Class See Also Send Feedback

The SpotDimension type exposes the following members.

Properties

Name | Description
AreSegmentsEqual | Indicates if all segments are forced to be equal. (Inherited from Dimension.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | A curve that represents the dimension line. (Inherited from Dimension.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DimensionShape | The shape of this dimension. (Inherited from Dimension.)
DimensionType | The dimension style of this dimension. (Inherited from Dimension.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsLocked | Indicates if this dimension is locked. (Inherited from Dimension.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Label | The family parameter label of the dimension. (Inherited from Dimension.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | Get a location point object. This is the location of the spot dimension. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Retrieve or Change the name associated with the Dimension. (Inherited from Dimension.)
NumberOfSegments | The number of segments for the dimension. (Inherited from Dimension.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension.)
Segments | The segments in the dimension. (Inherited from Dimension.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SpotDimensionType | The dimension style of this dimension.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Value | The value of the dimension. (Inherited from Dimension.)
ValueString | The dimension value as a user visible string. (Inherited from Dimension.)
View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension.)

See Also

SpotDimension Class
Autodesk.Revit.Elements Namespace


Location Property

[image]

Revit 2010 API
SpotDimension..::.Location Property
SpotDimension Class See Also Send Feedback
Get a location point object. This is the location of the spot dimension.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

See Also

SpotDimension Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
SpotDimension..::.Parameter Property
SpotDimension Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SpotDimension Class
SpotDimension Members
Autodesk.Revit.Elements Namespace


SpotDimensionType Property

[image]

Revit 2010 API
SpotDimension..::.SpotDimensionType Property
SpotDimension Class See Also Send Feedback
The dimension style of this dimension.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpotDimensionType SpotDimensionType { get; set; }
Visual Basic (Declaration)
Public Property SpotDimensionType As SpotDimensionType
Visual C++
public:
property SpotDimensionType^ SpotDimensionType {
    SpotDimensionType^ get ();
    void set (SpotDimensionType^ value);
}

See Also

SpotDimension Class
Autodesk.Revit.Elements Namespace


Sweep Class

[image]

Revit 2010 API
Sweep Class
Members See Also Send Feedback
A sweep solid or void form.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Sweep : GenericForm
Visual Basic (Declaration)
Public Class Sweep _
    Inherits GenericForm
Visual C++
public ref class Sweep : public GenericForm

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CombinableElement
Autodesk.Revit.Elements..::.GenericForm
Autodesk.Revit.Elements..::.Sweep

See Also

Sweep Members
Autodesk.Revit.Elements Namespace


Sweep Members

[image] [image]

Revit 2010 API
Sweep Members
Sweep Class Constructors Methods Properties See Also Send Feedback

The Sweep type exposes the following members.

Constructors

Name | Description
Sweep | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
IsTrajectorySegmentationEnabled | The trajectory segmentation option for the sweep.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaxSegmentAngle | The maximum segment angle of the sweep in radians.
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Path3d | The selected curves used for the sweep path.
PathSketch | The sketched path for the sweep.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProfileSketch | The profile sketch of the sweep.
ProfileSymbol | The family symbol profile details for the sweep.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory. (Inherited from GenericForm.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Sweep Class
Autodesk.Revit.Elements Namespace


Sweep Constructor

[image]

Revit 2010 API
Sweep Constructor
Sweep Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Sweep()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Sweep()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Sweep Class
Autodesk.Revit.Elements Namespace


Sweep Methods

[image] [image]

Revit 2010 API
Sweep Methods
Sweep Class See Also Send Feedback

The Sweep type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Sweep Class
Autodesk.Revit.Elements Namespace


Sweep Properties

[image] [image]

Revit 2010 API
Sweep Properties
Sweep Class See Also Send Feedback

The Sweep type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
IsTrajectorySegmentationEnabled | The trajectory segmentation option for the sweep.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaxSegmentAngle | The maximum segment angle of the sweep in radians.
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Path3d | The selected curves used for the sweep path.
PathSketch | The sketched path for the sweep.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProfileSketch | The profile sketch of the sweep.
ProfileSymbol | The family symbol profile details for the sweep.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory. (Inherited from GenericForm.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Sweep Class
Autodesk.Revit.Elements Namespace


IsTrajectorySegmentationEnabled Property

[image]

Revit 2010 API
Sweep..::.IsTrajectorySegmentationEnabled Property
Sweep Class See Also Send Feedback
The trajectory segmentation option for the sweep.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsTrajectorySegmentationEnabled { get; set; }
Visual Basic (Declaration)
Public Property IsTrajectorySegmentationEnabled As Boolean
Visual C++
public:
property bool IsTrajectorySegmentationEnabled {
    bool get ();
    void set (bool value);
}

Remarks

This property is used to retrieve/set the trajectory segmentation state of the sweep. if return is true, means user can control the MaxSegmentAngle, otherwise is disable.

See Also

Sweep Class
Autodesk.Revit.Elements Namespace


MaxSegmentAngle Property

[image]

Revit 2010 API
Sweep..::.MaxSegmentAngle Property
Sweep Class See Also Send Feedback
The maximum segment angle of the sweep in radians.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double MaxSegmentAngle { get; set; }
Visual Basic (Declaration)
Public Property MaxSegmentAngle As Double
Visual C++
public:
property double MaxSegmentAngle {
    double get ();
    void set (double value);
}

Remarks

This property is used to retrieve/set the maximum segment angle of the sweep. It is settable only when the trajectory segmentation is enabled.

See Also

Sweep Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Sweep..::.Parameter Property
Sweep Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Sweep Class
Sweep Members
Autodesk.Revit.Elements Namespace


Path3d Property

[image]

Revit 2010 API
Sweep..::.Path3d Property
Sweep Class See Also Send Feedback
The selected curves used for the sweep path.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Path3d Path3d { get; }
Visual Basic (Declaration)
Public ReadOnly Property Path3d As Path3d
Visual C++
public:
property Path3d^ Path3d {
    Path3d^ get ();
}

Remarks

If the sweep is based on a sketched path, this property is null.

See Also

Sweep Class
Autodesk.Revit.Elements Namespace


PathSketch Property

[image]

Revit 2010 API
Sweep..::.PathSketch Property
Sweep Class See Also Send Feedback
The sketched path for the sweep.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Sketch PathSketch { get; }
Visual Basic (Declaration)
Public ReadOnly Property PathSketch As Sketch
Visual C++
public:
property Sketch^ PathSketch {
    Sketch^ get ();
}

Remarks

If the sweep is based on selected 3d curves, this property is null.

See Also

Sweep Class
Autodesk.Revit.Elements Namespace


ProfileSketch Property

[image]

Revit 2010 API
Sweep..::.ProfileSketch Property
Sweep Class See Also Send Feedback
The profile sketch of the sweep.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Sketch ProfileSketch { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProfileSketch As Sketch
Visual C++
public:
property Sketch^ ProfileSketch {
    Sketch^ get ();
}

Remarks

If the profile is not based on sketched curves, this property is null.

See Also

Sweep Class
Autodesk.Revit.Elements Namespace


ProfileSymbol Property

[image]

Revit 2010 API
Sweep..::.ProfileSymbol Property
Sweep Class See Also Send Feedback
The family symbol profile details for the sweep.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbolProfile ProfileSymbol { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProfileSymbol As FamilySymbolProfile
Visual C++
public:
property FamilySymbolProfile^ ProfileSymbol {
    FamilySymbolProfile^ get ();
}

Remarks

If the profile is not based on a profile family, this property is null.

See Also

Sweep Class
Autodesk.Revit.Elements Namespace


SweptBlend Class

[image]

Revit 2010 API
SweptBlend Class
Members See Also Send Feedback
A swept blend solid or void form.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SweptBlend : GenericForm
Visual Basic (Declaration)
Public Class SweptBlend _
    Inherits GenericForm
Visual C++
public ref class SweptBlend : public GenericForm

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CombinableElement
Autodesk.Revit.Elements..::.GenericForm
Autodesk.Revit.Elements..::.SweptBlend

See Also

SweptBlend Members
Autodesk.Revit.Elements Namespace


SweptBlend Members

[image] [image]

Revit 2010 API
SweptBlend Members
SweptBlend Class Constructors Methods Properties See Also Send Feedback

The SweptBlend type exposes the following members.

Constructors

Name | Description
SweptBlend | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BottomProfile | The curves which make up the bottom profile of the sketch.
BottomProfileSymbol | The bottom family symbol profile of the swept blend.
BottomSketch | The bottom profile sketch of the swept blend.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PathSketch | The sketched path for the swept blend.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SelectedPath | The selected curve used for the swept blend path.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory. (Inherited from GenericForm.)
TopProfile | The curves which make up the top profile of the sketch.
TopProfileSymbol | The top family symbol profile of the swept blend.
TopSketch | The top profile sketch of the swept blend.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

SweptBlend Class
Autodesk.Revit.Elements Namespace


SweptBlend Constructor

[image]

Revit 2010 API
SweptBlend Constructor
SweptBlend Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SweptBlend()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SweptBlend()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SweptBlend Class
Autodesk.Revit.Elements Namespace


SweptBlend Methods

[image] [image]

Revit 2010 API
SweptBlend Methods
SweptBlend Class See Also Send Feedback

The SweptBlend type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SweptBlend Class
Autodesk.Revit.Elements Namespace


GetVertexConnectionMap Method

[image]

Revit 2010 API
SweptBlend..::.GetVertexConnectionMap Method
SweptBlend Class See Also Send Feedback
Gets the mapping between the vertices in the top and bottom profiles.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public VertexIndexPairArray GetVertexConnectionMap()
Visual Basic (Declaration)
Public Function GetVertexConnectionMap As VertexIndexPairArray
Visual C++
public:
VertexIndexPairArray^ GetVertexConnectionMap()

Remarks

Each vertex refers to the start point of the curve from the top and bottom profiles.

See Also

SweptBlend Class
Autodesk.Revit.Elements Namespace


SetVertexConnectionMap Method

[image]

Revit 2010 API
SweptBlend..::.SetVertexConnectionMap Method
SweptBlend Class See Also Send Feedback
Sets the mapping between the vertices in the top and bottom profiles.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetVertexConnectionMap(
    VertexIndexPairArray vertexMap
)
Visual Basic (Declaration)
Public Sub SetVertexConnectionMap ( _
    vertexMap As VertexIndexPairArray _
)
Visual C++
public:
void SetVertexConnectionMap(
    VertexIndexPairArray^ vertexMap
)

Parameters

vertexMap
Type: Autodesk.Revit..::.VertexIndexPairArray

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"vertexMap"-is null.
System..::.ArgumentException | Thrown if the input argument-"vertexMap"-is empty.
System..::.InvalidOperationException | Thrown when the document failed to regenerate.

See Also

SweptBlend Class
Autodesk.Revit.Elements Namespace


SweptBlend Properties

[image] [image]

Revit 2010 API
SweptBlend Properties
SweptBlend Class See Also Send Feedback

The SweptBlend type exposes the following members.

Properties

Name | Description
BottomProfile | The curves which make up the bottom profile of the sketch.
BottomProfileSymbol | The bottom family symbol profile of the swept blend.
BottomSketch | The bottom profile sketch of the swept blend.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PathSketch | The sketched path for the swept blend.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SelectedPath | The selected curve used for the swept blend path.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory. (Inherited from GenericForm.)
TopProfile | The curves which make up the top profile of the sketch.
TopProfileSymbol | The top family symbol profile of the swept blend.
TopSketch | The top profile sketch of the swept blend.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

SweptBlend Class
Autodesk.Revit.Elements Namespace


BottomProfile Property

[image]

Revit 2010 API
SweptBlend..::.BottomProfile Property
SweptBlend Class See Also Send Feedback
The curves which make up the bottom profile of the sketch.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArrArray BottomProfile { get; }
Visual Basic (Declaration)
Public ReadOnly Property BottomProfile As CurveArrArray
Visual C++
public:
property CurveArrArray^ BottomProfile {
    CurveArrArray^ get ();
}

Remarks

The indices of the curves in this array match the indices used in the vertex connection map.

See Also

SweptBlend Class
Autodesk.Revit.Elements Namespace


BottomProfileSymbol Property

[image]

Revit 2010 API
SweptBlend..::.BottomProfileSymbol Property
SweptBlend Class See Also Send Feedback
The bottom family symbol profile of the swept blend.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbolProfile BottomProfileSymbol { get; }
Visual Basic (Declaration)
Public ReadOnly Property BottomProfileSymbol As FamilySymbolProfile
Visual C++
public:
property FamilySymbolProfile^ BottomProfileSymbol {
    FamilySymbolProfile^ get ();
}

Remarks

If the bottom profile is sketch-based, this property is null.

See Also

SweptBlend Class
Autodesk.Revit.Elements Namespace


BottomSketch Property

[image]

Revit 2010 API
SweptBlend..::.BottomSketch Property
SweptBlend Class See Also Send Feedback
The bottom profile sketch of the swept blend.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Sketch BottomSketch { get; }
Visual Basic (Declaration)
Public ReadOnly Property BottomSketch As Sketch
Visual C++
public:
property Sketch^ BottomSketch {
    Sketch^ get ();
}

Remarks

If the bottom profile is based on a family symbol, this property is null.

See Also

SweptBlend Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
SweptBlend..::.Parameter Property
SweptBlend Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SweptBlend Class
SweptBlend Members
Autodesk.Revit.Elements Namespace


PathSketch Property

[image]

Revit 2010 API
SweptBlend..::.PathSketch Property
SweptBlend Class See Also Send Feedback
The sketched path for the swept blend.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Sketch PathSketch { get; }
Visual Basic (Declaration)
Public ReadOnly Property PathSketch As Sketch
Visual C++
public:
property Sketch^ PathSketch {
    Sketch^ get ();
}

Remarks

If the swept blend is based on selected 3d curve, this property is null.

See Also

SweptBlend Class
Autodesk.Revit.Elements Namespace


SelectedPath Property

[image]

Revit 2010 API
SweptBlend..::.SelectedPath Property
SweptBlend Class See Also Send Feedback
The selected curve used for the swept blend path.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve SelectedPath { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedPath As Curve
Visual C++
public:
property Curve^ SelectedPath {
    Curve^ get ();
}

Remarks

If the swept blend is based on a sketched path, this property is null.

See Also

SweptBlend Class
Autodesk.Revit.Elements Namespace


TopProfile Property

[image]

Revit 2010 API
SweptBlend..::.TopProfile Property
SweptBlend Class See Also Send Feedback
The curves which make up the top profile of the sketch.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArrArray TopProfile { get; }
Visual Basic (Declaration)
Public ReadOnly Property TopProfile As CurveArrArray
Visual C++
public:
property CurveArrArray^ TopProfile {
    CurveArrArray^ get ();
}

Remarks

The indices of the curves in this array match the indices used in the vertex connection map.

See Also

SweptBlend Class
Autodesk.Revit.Elements Namespace


TopProfileSymbol Property

[image]

Revit 2010 API
SweptBlend..::.TopProfileSymbol Property
SweptBlend Class See Also Send Feedback
The top family symbol profile of the swept blend.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbolProfile TopProfileSymbol { get; }
Visual Basic (Declaration)
Public ReadOnly Property TopProfileSymbol As FamilySymbolProfile
Visual C++
public:
property FamilySymbolProfile^ TopProfileSymbol {
    FamilySymbolProfile^ get ();
}

Remarks

If the top profile is sketch-based, this property is null.

See Also

SweptBlend Class
Autodesk.Revit.Elements Namespace


TopSketch Property

[image]

Revit 2010 API
SweptBlend..::.TopSketch Property
SweptBlend Class See Also Send Feedback
The top profile sketch of the swept blend.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Sketch TopSketch { get; }
Visual Basic (Declaration)
Public ReadOnly Property TopSketch As Sketch
Visual C++
public:
property Sketch^ TopSketch {
    Sketch^ get ();
}

Remarks

If the top profile is based on a family symbol, this property is null.

See Also

SweptBlend Class
Autodesk.Revit.Elements Namespace


SymbolicCurve Class

[image]

Revit 2010 API
SymbolicCurve Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SymbolicCurve : CurveElement
Visual Basic (Declaration)
Public Class SymbolicCurve _
    Inherits CurveElement
Visual C++
public ref class SymbolicCurve : public CurveElement

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CurveElement
Autodesk.Revit.Elements..::.SymbolicCurve

See Also

SymbolicCurve Members
Autodesk.Revit.Elements Namespace


SymbolicCurve Members

[image] [image]

Revit 2010 API
SymbolicCurve Members
SymbolicCurve Class Methods Properties See Also Send Feedback

The SymbolicCurve type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the symbolic curve.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the symbolic curve.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDrawnInForeground | Indicates if this curve will be drawn in the foreground of the family instance.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceType | Indicates the type of reference.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SymbolicCurve Class
Autodesk.Revit.Elements Namespace


SymbolicCurve Methods

[image] [image]

Revit 2010 API
SymbolicCurve Methods
SymbolicCurve Class See Also Send Feedback

The SymbolicCurve type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the symbolic curve.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVisibility | Sets the visibility for the symbolic curve.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SymbolicCurve Class
Autodesk.Revit.Elements Namespace


GetVisibility Method

[image]

Revit 2010 API
SymbolicCurve..::.GetVisibility Method
SymbolicCurve Class See Also Send Feedback
Gets the visibility for the symbolic curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic (Declaration)
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

Returns a copy of visibility settings for the symbolic curve.

See Also

SymbolicCurve Class
Autodesk.Revit.Elements Namespace


SetVisibility Method

[image]

Revit 2010 API
SymbolicCurve..::.SetVisibility Method
SymbolicCurve Class See Also Send Feedback
Sets the visibility for the symbolic curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic (Declaration)
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit..::.FamilyElementVisibility

Remarks

The visibility of the symbolic curve geometry can be changed for different detail levels.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when visibility is null.
System..::.ArgumentException | Thrown when visibility is not valid for symbolic curves.
System..::.InvalidOperationException | Thrown when regeneration failed.

See Also

SymbolicCurve Class
Autodesk.Revit.Elements Namespace


SymbolicCurve Properties

[image] [image]

Revit 2010 API
SymbolicCurve Properties
SymbolicCurve Class See Also Send Feedback

The SymbolicCurve type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDrawnInForeground | Indicates if this curve will be drawn in the foreground of the family instance.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceType | Indicates the type of reference.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SymbolicCurve Class
Autodesk.Revit.Elements Namespace


IsDrawnInForeground Property

[image]

Revit 2010 API
SymbolicCurve..::.IsDrawnInForeground Property
SymbolicCurve Class See Also Send Feedback
Indicates if this curve will be drawn in the foreground of the family instance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsDrawnInForeground { get; set; }
Visual Basic (Declaration)
Public Property IsDrawnInForeground As Boolean
Visual C++
public:
property bool IsDrawnInForeground {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when regeneration failed. Thrown when the value for this property cannot be changed.

See Also

SymbolicCurve Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
SymbolicCurve..::.Parameter Property
SymbolicCurve Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SymbolicCurve Class
SymbolicCurve Members
Autodesk.Revit.Elements Namespace


ReferenceType Property

[image]

Revit 2010 API
SymbolicCurve..::.ReferenceType Property
SymbolicCurve Class See Also Send Feedback
Indicates the type of reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferenceType ReferenceType { get; set; }
Visual Basic (Declaration)
Public Property ReferenceType As ReferenceType
Visual C++
public:
property ReferenceType ReferenceType {
    ReferenceType get ();
    void set (ReferenceType value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when argument is out of range.
System..::.InvalidOperationException | Thrown when regeneration failed.

See Also

SymbolicCurve Class
Autodesk.Revit.Elements Namespace


Subcategory Property

[image]

Revit 2010 API
SymbolicCurve..::.Subcategory Property
SymbolicCurve Class See Also Send Feedback
The subcategory.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GraphicsStyle Subcategory { get; set; }
Visual Basic (Declaration)
Public Property Subcategory As GraphicsStyle
Visual C++
public:
property GraphicsStyle^ Subcategory {
    GraphicsStyle^ get ();
    void set (GraphicsStyle^ value);
}

Remarks

If the family category is non-cuttable, the subcategory can be set to be the family category or one of its subcategories. If the family category is cuttable, the subcategory can be set as the graphics styles of the family category, its subcategories, or the invisible lines graphics style.

See Also

SymbolicCurve Class
Autodesk.Revit.Elements Namespace


TextElement Class

[image]

Revit 2010 API
TextElement Class
Members See Also Send Feedback
Represents the TextElment.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class TextElement : Element
Visual Basic (Declaration)
Public Class TextElement _
    Inherits Element
Visual C++
public ref class TextElement : public Element

Remarks

This class can be parent class of TextNote and other Text related classes.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.TextElement
Autodesk.Revit.Elements..::.TextNote

See Also

TextElement Members
Autodesk.Revit.Elements Namespace


TextElement Members

[image] [image]

Revit 2010 API
TextElement Members
TextElement Class Constructors Methods Properties See Also Send Feedback

The TextElement type exposes the following members.

Constructors

Name | Description
TextElement | Initializes a new instance of the TextElement class

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Symbol | Get the type of the TextElement object.
Text | Get and set the content of the TextElement object.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

TextElement Class
Autodesk.Revit.Elements Namespace


TextElement Constructor

[image]

Revit 2010 API
TextElement Constructor
TextElement Class See Also Send Feedback
Initializes a new instance of the TextElement class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TextElement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextElement()

See Also

TextElement Class
Autodesk.Revit.Elements Namespace


TextElement Methods

[image] [image]

Revit 2010 API
TextElement Methods
TextElement Class See Also Send Feedback

The TextElement type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextElement Class
Autodesk.Revit.Elements Namespace


TextElement Properties

[image] [image]

Revit 2010 API
TextElement Properties
TextElement Class See Also Send Feedback

The TextElement type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Symbol | Get the type of the TextElement object.
Text | Get and set the content of the TextElement object.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

TextElement Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
TextElement..::.Parameter Property
TextElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

TextElement Class
TextElement Members
Autodesk.Revit.Elements Namespace


Symbol Property

[image]

Revit 2010 API
TextElement..::.Symbol Property
TextElement Class See Also Send Feedback
Get the type of the TextElement object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TextElementType Symbol { get; }
Visual Basic (Declaration)
Public ReadOnly Property Symbol As TextElementType
Visual C++
public:
property TextElementType^ Symbol {
    TextElementType^ get ();
}

Remarks

The user can call this property to get the related type.

See Also

TextElement Class
Autodesk.Revit.Elements Namespace


Text Property

[image]

Revit 2010 API
TextElement..::.Text Property
TextElement Class See Also Send Feedback
Get and set the content of the TextElement object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Remarks

The content of TextElement object can also be accessed through the Built-In parameter TEXT_TEXT.

See Also

TextElement Class
Autodesk.Revit.Elements Namespace


TextNote Class

[image]

Revit 2010 API
TextNote Class
Members See Also Send Feedback
Provides access to the TextNote object in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class TextNote : TextElement
Visual Basic (Declaration)
Public Class TextNote _
    Inherits TextElement
Visual C++
public ref class TextNote : public TextElement

Remarks

The user can create TextNote object and change the internal property as Leaders and so on.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.TextElement
Autodesk.Revit.Elements..::.TextNote

See Also

TextNote Members
Autodesk.Revit.Elements Namespace


TextNote Members

[image] [image]

Revit 2010 API
TextNote Members
TextNote Class Constructors Methods Properties See Also Send Feedback

The TextNote type exposes the following members.

Constructors

Name | Description
TextNote | For Internal Use Only.

Methods

Name | Description
AddLeader | Add a leader for the current TextNote object and return the new leader.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveLeaders | Romove all the leaders for the current TextNote object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Coord | Access the position of the TextNote object.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Leaders | Retrieves all the leaders belongs to the current TextNote object.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Symbol | Get the type of the TextElement object. (Inherited from TextElement.)
Text | Get and set the content of the TextElement object. (Inherited from TextElement.)
TextNoteType | Access the type of the TextNote object.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Width | Access the width of the TextNote object.

See Also

TextNote Class
Autodesk.Revit.Elements Namespace


TextNote Constructor

[image]

Revit 2010 API
TextNote Constructor
TextNote Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TextNote()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextNote()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TextNote Class
Autodesk.Revit.Elements Namespace


TextNote Methods

[image] [image]

Revit 2010 API
TextNote Methods
TextNote Class See Also Send Feedback

The TextNote type exposes the following members.

Methods

Name | Description
AddLeader | Add a leader for the current TextNote object and return the new leader.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveLeaders | Romove all the leaders for the current TextNote object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextNote Class
Autodesk.Revit.Elements Namespace


AddLeader Method

[image]

Revit 2010 API
TextNote..::.AddLeader Method
TextNote Class See Also Send Feedback
Add a leader for the current TextNote object and return the new leader.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Leader AddLeader(
    TextNoteLeaderTypes
)
Visual Basic (Declaration)
Public Function AddLeader ( _
     As TextNoteLeaderTypes _
) As Leader
Visual C++
public:
Leader^ AddLeader(
    TextNoteLeaderTypes
)

Parameters

Type: Autodesk.Revit.Enums..::.TextNoteLeaderTypes

Remarks

If the current leader type is not same with the input type, System::InvalidOperationException will be thrown.

See Also

TextNote Class
Autodesk.Revit.Elements Namespace


RemoveLeaders Method

[image]

Revit 2010 API
TextNote..::.RemoveLeaders Method
TextNote Class See Also Send Feedback
Romove all the leaders for the current TextNote object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveLeaders()
Visual Basic (Declaration)
Public Sub RemoveLeaders
Visual C++
public:
void RemoveLeaders()

Remarks

It is different to the method AddLeader, in which one Leader is added. Calling this method will remove all the leaders.

See Also

TextNote Class
Autodesk.Revit.Elements Namespace


TextNote Properties

[image] [image]

Revit 2010 API
TextNote Properties
TextNote Class See Also Send Feedback

The TextNote type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Coord | Access the position of the TextNote object.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Leaders | Retrieves all the leaders belongs to the current TextNote object.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Symbol | Get the type of the TextElement object. (Inherited from TextElement.)
Text | Get and set the content of the TextElement object. (Inherited from TextElement.)
TextNoteType | Access the type of the TextNote object.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Width | Access the width of the TextNote object.

See Also

TextNote Class
Autodesk.Revit.Elements Namespace


Coord Property

[image]

Revit 2010 API
TextNote..::.Coord Property
TextNote Class See Also Send Feedback
Access the position of the TextNote object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Coord { get; set; }
Visual Basic (Declaration)
Public Property Coord As XYZ
Visual C++
public:
property XYZ^ Coord {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

With this method, the position of the TextNote object can be retrieved and changed.

See Also

TextNote Class
Autodesk.Revit.Elements Namespace


Leaders Property

[image]

Revit 2010 API
TextNote..::.Leaders Property
TextNote Class See Also Send Feedback
Retrieves all the leaders belongs to the current TextNote object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LeaderArray Leaders { get; }
Visual Basic (Declaration)
Public ReadOnly Property Leaders As LeaderArray
Visual C++
public:
property LeaderArray^ Leaders {
    LeaderArray^ get ();
}

Remarks

This property is ReadOnly.

See Also

TextNote Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
TextNote..::.Parameter Property
TextNote Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

TextNote Class
TextNote Members
Autodesk.Revit.Elements Namespace


TextNoteType Property

[image]

Revit 2010 API
TextNote..::.TextNoteType Property
TextNote Class See Also Send Feedback
Access the type of the TextNote object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TextNoteType TextNoteType { get; set; }
Visual Basic (Declaration)
Public Property TextNoteType As TextNoteType
Visual C++
public:
property TextNoteType^ TextNoteType {
    TextNoteType^ get ();
    void set (TextNoteType^ value);
}

Remarks

The type of the TextNote object can be retrieved or changed.

See Also

TextNote Class
Autodesk.Revit.Elements Namespace


Width Property

[image]

Revit 2010 API
TextNote..::.Width Property
TextNote Class See Also Send Feedback
Access the width of the TextNote object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

Remarks

With this method, the width of the TextNote object can be retrieved and changed. The set method will calculate the real width of the TextNote. If the requested width is less than the real width, the real width will be set instead of the requested width.

See Also

TextNote Class
Autodesk.Revit.Elements Namespace


TopographySurface Class

[image]

Revit 2010 API
TopographySurface Class
Members See Also Send Feedback
An object that is used to represent a topography surface.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class TopographySurface : Element
Visual Basic (Declaration)
Public Class TopographySurface _
    Inherits Element
Visual C++
public ref class TopographySurface : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.TopographySurface

See Also

TopographySurface Members
Autodesk.Revit.Elements Namespace


TopographySurface Members

[image] [image]

Revit 2010 API
TopographySurface Members
TopographySurface Class Constructors Methods Properties See Also Send Feedback

The TopographySurface type exposes the following members.

Constructors

Name | Description
TopographySurface | For Internal Use Only.

Methods

Name | Description
AddPoints | Adds new points to a topography surface element.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

TopographySurface Class
Autodesk.Revit.Elements Namespace


TopographySurface Constructor

[image]

Revit 2010 API
TopographySurface Constructor
TopographySurface Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TopographySurface()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TopographySurface()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TopographySurface Class
Autodesk.Revit.Elements Namespace


TopographySurface Methods

[image] [image]

Revit 2010 API
TopographySurface Methods
TopographySurface Class See Also Send Feedback

The TopographySurface type exposes the following members.

Methods

Name | Description
AddPoints | Adds new points to a topography surface element.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TopographySurface Class
Autodesk.Revit.Elements Namespace


AddPoints Method

[image]

Revit 2010 API
TopographySurface..::.AddPoints Method
TopographySurface Class See Also Send Feedback
Adds new points to a topography surface element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddPoints(
    XYZArray points
)
Visual Basic (Declaration)
Public Sub AddPoints ( _
    points As XYZArray _
)
Visual C++
public:
void AddPoints(
    XYZArray^ points
)

Parameters

points
Type: Autodesk.Revit.Geometry..::.XYZArray
An array of points for the topography surface.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the topography surface is invalid or regeneration fails.

See Also

TopographySurface Class
Autodesk.Revit.Elements Namespace


TopographySurface Properties

[image] [image]

Revit 2010 API
TopographySurface Properties
TopographySurface Class See Also Send Feedback

The TopographySurface type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

TopographySurface Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
TopographySurface..::.Parameter Property
TopographySurface Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

TopographySurface Class
TopographySurface Members
Autodesk.Revit.Elements Namespace


Truss Class

[image]

Revit 2010 API
Truss Class
Members See Also Send Feedback
Represents all kinds of Trusses.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Truss : Element
Visual Basic (Declaration)
Public Class Truss _
    Inherits Element
Visual C++
public ref class Truss : public Element

Remarks

The Truss object represents all the kinds of Trusses in Revit. The TrussType property is used to distinguish the type of the Truss. The Truss object is derived from the Element object and hence it supports all the properties and methods of that object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Truss

See Also

Truss Members
Autodesk.Revit.Elements Namespace


Truss Members

[image] [image]

Revit 2010 API
Truss Members
Truss Class Constructors Methods Properties See Also Send Feedback

The Truss type exposes the following members.

Constructors

Name | Description
Truss | For Internal Use Only.

Methods

Name | Description
AttachTopChord | Attach truss's top to a specified element,the element should be a roof or floor.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
DetachTopChord | Detach the truss's top from a specified element.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetTrussMemberInfo | Query if a given element is a member of a truss,its lock status and its usage,etc.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveProfile | Remove the profile of a truss.
SetProfile | Add or modify the profile of a truss.
TogglePinMember | Pin/Unpin a truss member.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curves | Get all the truss curves.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Members | Get all the members of truss.
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
TrussType | Retrieve/set an object that represents the type of the truss.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Truss Class
Autodesk.Revit.Elements Namespace


Truss Constructor

[image]

Revit 2010 API
Truss Constructor
Truss Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Truss()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Truss()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Truss Class
Autodesk.Revit.Elements Namespace


Truss Methods

[image] [image]

Revit 2010 API
Truss Methods
Truss Class See Also Send Feedback

The Truss type exposes the following members.

Methods

Name | Description
AttachTopChord | Attach truss's top to a specified element,the element should be a roof or floor.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
DetachTopChord | Detach the truss's top from a specified element.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetTrussMemberInfo | Query if a given element is a member of a truss,its lock status and its usage,etc.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveProfile | Remove the profile of a truss.
SetProfile | Add or modify the profile of a truss.
TogglePinMember | Pin/Unpin a truss member.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Truss Class
Autodesk.Revit.Elements Namespace


AttachTopChord Method

[image]

Revit 2010 API
Truss..::.AttachTopChord Method
Truss Class See Also Send Feedback
Attach truss's top to a specified element,the element should be a roof or floor.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AttachTopChord(
    Element attachToElement,
    bool forceRemoveSketch
)
Visual Basic (Declaration)
Public Sub AttachTopChord ( _
    attachToElement As Element, _
    forceRemoveSketch As Boolean _
)
Visual C++
public:
void AttachTopChord(
    Element^ attachToElement,
    bool forceRemoveSketch
)

Parameters

attachToElement
Type: Autodesk.Revit..::.Element
The element that the truss's top is going to attach.
forceRemoveSketch
Type: System..::.Boolean
Whether detach the original sketch if there is one.

See Also

Truss Class
Autodesk.Revit.Elements Namespace


DetachTopChord Method

[image]

Revit 2010 API
Truss..::.DetachTopChord Method
Truss Class See Also Send Feedback
Detach the truss's top from a specified element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void DetachTopChord()
Visual Basic (Declaration)
Public Sub DetachTopChord
Visual C++
public:
void DetachTopChord()

See Also

Truss Class
Autodesk.Revit.Elements Namespace


GetTrussMemberInfo Method

[image]

Revit 2010 API
Truss..::.GetTrussMemberInfo Method
Truss Class See Also Send Feedback
Query if a given element is a member of a truss,its lock status and its usage,etc.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TrussMemberInfo GetTrussMemberInfo(
    ref ElementId elemId
)
Visual Basic (Declaration)
Public Function GetTrussMemberInfo ( _
    ByRef elemId As ElementId _
) As TrussMemberInfo
Visual C++
public:
TrussMemberInfo^ GetTrussMemberInfo(
    ElementId% elemId
)

Parameters

elemId
Type: Autodesk.Revit..::.ElementId %
The querying element.

Return Value

A struct TrussMemberInfo that contains the quering element's host truss,whether lock to the truss,usage type,etc.

See Also

Truss Class
Autodesk.Revit.Elements Namespace


RemoveProfile Method

[image]

Revit 2010 API
Truss..::.RemoveProfile Method
Truss Class See Also Send Feedback
Remove the profile of a truss.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveProfile()
Visual Basic (Declaration)
Public Sub RemoveProfile
Visual C++
public:
void RemoveProfile()

See Also

Truss Class
Autodesk.Revit.Elements Namespace


SetProfile Method

[image]

Revit 2010 API
Truss..::.SetProfile Method
Truss Class See Also Send Feedback
Add or modify the profile of a truss.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetProfile(
    CurveArray topChords,
    CurveArray bottomChords
)
Visual Basic (Declaration)
Public Sub SetProfile ( _
    topChords As CurveArray, _
    bottomChords As CurveArray _
)
Visual C++
public:
void SetProfile(
    CurveArray^ topChords,
    CurveArray^ bottomChords
)

Parameters

topChords
Type: Autodesk.Revit.Geometry..::.CurveArray
The curves serving as top chords of the truss.
bottomChords
Type: Autodesk.Revit.Geometry..::.CurveArray
The curves serving as bottom chords of the truss.

See Also

Truss Class
Autodesk.Revit.Elements Namespace


TogglePinMember Method

[image]

Revit 2010 API
Truss..::.TogglePinMember Method
Truss Class See Also Send Feedback
Pin/Unpin a truss member.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void TogglePinMember(
    ref ElementId elemId
)
Visual Basic (Declaration)
Public Sub TogglePinMember ( _
    ByRef elemId As ElementId _
)
Visual C++
public:
void TogglePinMember(
    ElementId% elemId
)

Parameters

elemId
Type: Autodesk.Revit..::.ElementId %
The member element is going to pin/unpin.

See Also

Truss Class
Autodesk.Revit.Elements Namespace


Truss Properties

[image] [image]

Revit 2010 API
Truss Properties
Truss Class See Also Send Feedback

The Truss type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curves | Get all the truss curves.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Members | Get all the members of truss.
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
TrussType | Retrieve/set an object that represents the type of the truss.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

Truss Class
Autodesk.Revit.Elements Namespace


Curves Property

[image]

Revit 2010 API
Truss..::.Curves Property
Truss Class See Also Send Feedback
Get all the truss curves.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray Curves { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

Return Value

The Curves property returns a CurveArray that contains all the truss curves.

See Also

Truss Class
Autodesk.Revit.Elements Namespace


Members Property

[image]

Revit 2010 API
Truss..::.Members Property
Truss Class See Also Send Feedback
Get all the members of truss.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementIdSet Members { get; }
Visual Basic (Declaration)
Public ReadOnly Property Members As ElementIdSet
Visual C++
public:
property ElementIdSet^ Members {
    ElementIdSet^ get ();
}

Return Value

The Members property returns an ElementIdSet that contains all the member Ids of truss.

See Also

Truss Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Truss..::.Parameter Property
Truss Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Truss Class
Truss Members
Autodesk.Revit.Elements Namespace


TrussType Property

[image]

Revit 2010 API
Truss..::.TrussType Property
Truss Class See Also Send Feedback
Retrieve/set an object that represents the type of the truss.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TrussType TrussType { get; set; }
Visual Basic (Declaration)
Public Property TrussType As TrussType
Visual C++
public:
property TrussType^ TrussType {
    TrussType^ get ();
    void set (TrussType^ value);
}

See Also

Truss Class
Autodesk.Revit.Elements Namespace


View Class

[image]

Revit 2010 API
View Class
Members Example See Also Send Feedback
Base class for all types of views in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class View : Element
Visual Basic (Declaration)
Public Class View _
    Inherits Element
Visual C++
public ref class View : public Element

Remarks

A view can display an image produced from a Revit model. Views can be graphical (e.g. plans, elevations, or 3D views) or textual (e.g. schedules). Views keep track of Elements that can be seen in them.

Examples

CopyC#
private void Getinfo_View(Autodesk.Revit.Elements.View view)
{
    string message = "View: ";

    //get the name of the view
    message += "\nView name: " + view.ViewName;

    //The crop box sets display bounds of the view
    BoundingBoxXYZ cropBox = view.CropBox;
    XYZ max = cropBox.Max; //Maximum coordinates (upper-right-front corner of the box).
    XYZ min = cropBox.Min; //Minimum coordinates (lower-left-rear corner of the box).
    message += "\nCrop Box: ";
    message += "\nMaximum coordinates: (" + max.X + ", " + max.Y + ", " + max.Z + ")";
    message += "\nMinimum coordinates: (" + min.X + ", " + min.Y + ", " + min.Z + ")";

    //Elements property stores the elements which graphics is visible in this view.
    //Some elements may still be hidden, e.g., obscured by other elements.
    ElementSet elements = view.Elements;
    message += "\nElement number: " + elements.Size;

    //get the origin of the screen
    XYZ origin = view.Origin;
    message += "\nOrigin: (" + origin.X + ", " + origin.Y + ", " + origin.Z + ")";

    //The bounds of the view in paper space (in inches).
    BoundingBoxUV outline = view.Outline;
    UV maxUv = outline.Max; //Maximum coordinates (upper-right corner of the box).
    UV minUv = outline.Min; //Minimum coordinates (lower-left corner of the box).
    message += "\nOutline: ";
    message += "\nMaximum coordinates: (" + maxUv.U + ", " + maxUv.V + ")";
    message += "\nMinimum coordinates: (" + minUv.U + ", " + minUv.V + ")";

    //The direction towards the right side of the screen
    XYZ rightDirection = view.RightDirection;
    message += "\nRight direction: (" + rightDirection.X + ", " +
                   rightDirection.Y + ", " + rightDirection.Z + ")";

    //The direction towards the top of the screen
    XYZ upDirection = view.UpDirection;
    message += "\nUp direction: (" + upDirection.X + ", " +
                   upDirection.Y + ", " + upDirection.Z + ")";

    //The direction towards the viewer
    XYZ viewDirection = view.ViewDirection;
    message += "\nView direction: (" + viewDirection.X + ", " +
                   viewDirection.Y + ", " + viewDirection.Z + ")";

    //The scale of the view
    message += "\nScale: " + view.Scale;
    // Scale is meaningless for Schedules
    if (view.ViewType != Autodesk.Revit.Enums.ViewType.Schedule)
    {
        int testScale = 5;
        //set the scale of the view
        view.Scale = testScale;
        message += "\nScale after set: " + view.Scale;
    }

    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Private Sub Getinfo_View(ByVal view As Autodesk.Revit.Elements.View)
    Dim message As String = "View: "

    'get the name of the view
    message += vbLf & "View name: " & view.ViewName

    'The crop box sets display bounds of the view
    Dim cropBox As BoundingBoxXYZ = view.CropBox
    Dim max As Autodesk.Revit.Geometry.XYZ = cropBox.Max
    'Maximum coordinates (upper-right-front corner of the box).
    Dim min As Autodesk.Revit.Geometry.XYZ = cropBox.Min
    'Minimum coordinates (lower-left-rear corner of the box).
    message += vbLf & "Crop Box: "
    message += ((vbLf & "Maximum coordinates: (" & max.X & ", ") + max.Y & ", ") + max.Z & ")"
    message += ((vbLf & "Minimum coordinates: (" & min.X & ", ") + min.Y & ", ") + min.Z & ")"

    'Elements property stores the elements which graphics is visible in this view.
    'Some elements may still be hidden, e.g., obscured by other elements.
    Dim elements As ElementSet = view.Elements
    message += vbLf & "Element number: " & elements.Size

    'get the origin of the screen
    Dim origin As Autodesk.Revit.Geometry.XYZ = view.Origin
    message += ((vbLf & "Origin: (" & origin.X & ", ") + origin.Y & ", ") + origin.Z & ")"

    'The bounds of the view in paper space (in inches).
    Dim outline As BoundingBoxUV = view.Outline
    Dim maxUv As Autodesk.Revit.Geometry.UV = outline.Max
    'Maximum coordinates (upper-right corner of the box).
    Dim minUv As Autodesk.Revit.Geometry.UV = outline.Min
    'Minimum coordinates (lower-left corner of the box).
    message += vbLf & "Outline: "
    message += (vbLf & "Maximum coordinates: (" & maxUv.U & ", ") + maxUv.V & ")"
    message += (vbLf & "Minimum coordinates: (" & minUv.U & ", ") + minUv.V & ")"

    'The direction towards the right side of the screen
    Dim rightDirection As Autodesk.Revit.Geometry.XYZ = view.RightDirection
    message += ((vbLf & "Right direction: (" & rightDirection.X & ", ") + rightDirection.Y & ", ") + rightDirection.Z & ")"

    'The direction towards the top of the screen
    Dim upDirection As Autodesk.Revit.Geometry.XYZ = view.UpDirection
    message += ((vbLf & "Up direction: (" & upDirection.X & ", ") + upDirection.Y & ", ") + upDirection.Z & ")"

    'The direction towards the viewer
    Dim viewDirection As Autodesk.Revit.Geometry.XYZ = view.ViewDirection
    message += ((vbLf & "View direction: (" & viewDirection.X & ", ") + viewDirection.Y & ", ") + viewDirection.Z & ")"

    'The scale of the view
    message += vbLf & "Scale: " & view.Scale
    ' Scale is meaningless for Schedules
    If view.ViewType <> Autodesk.Revit.Enums.ViewType.Schedule Then
        Dim testScale As Integer = 5
        'set the scale of the view
        view.Scale = testScale
        message += vbLf & "Scale after set: " & view.Scale
    End If

    MessageBox.Show(message, "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.View
Autodesk.Revit.Elements..::.View3D
Autodesk.Revit.Elements..::.ViewDrafting
Autodesk.Revit.Elements..::.ViewPlan
Autodesk.Revit.Elements..::.ViewSection
Autodesk.Revit.Elements..::.ViewSheet

See Also

View Members
Autodesk.Revit.Elements Namespace


View Members

[image] [image]

Revit 2010 API
View Members
View Class Constructors Methods Properties See Also Send Feedback

The View type exposes the following members.

Constructors

Name | Description
View | For Internal Use Only.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
getVisibility | Checks if elements of the given category are set to be visible in this view.
Hide | Sets the elements to be hidden in the view.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view.
CropBoxActive | Whether or not the the Crop Box/Region is active for the view.
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view.
CutColorOverrideByElement | Override the cut lines' color by Element in this view.
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view.
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Set of all elements that will be drawn in the view.
GenLevel | The level for the view.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen.
Outline | The bounds of the view in paper space (in inches).
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view.
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view.
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view.
RightDirection | The direction towards the right side of the screen.
Scale | The scale of the view.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen.
ViewDirection | The direction towards the viewer.
ViewName | The name of the view.
ViewType | The type of the view.

See Also

View Class
Autodesk.Revit.Elements Namespace


View Constructor

[image]

Revit 2010 API
View Constructor
View Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public View()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
View()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

View Class
Autodesk.Revit.Elements Namespace


View Methods

[image] [image]

Revit 2010 API
View Methods
View Class See Also Send Feedback

The View type exposes the following members.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
getVisibility | Checks if elements of the given category are set to be visible in this view.
Hide | Sets the elements to be hidden in the view.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden.

See Also

View Class
Autodesk.Revit.Elements Namespace


ApplyTemplate Method

[image]

Revit 2010 API
View..::.ApplyTemplate Method
View Class See Also Send Feedback
Applies a view template to the view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ApplyTemplate(
    View viewTemplate
)
Visual Basic (Declaration)
Public Sub ApplyTemplate ( _
    viewTemplate As View _
)
Visual C++
public:
void ApplyTemplate(
    View^ viewTemplate
)

Parameters

viewTemplate
Type: Autodesk.Revit.Elements..::.View
View to be used as the template.

See Also

View Class
Autodesk.Revit.Elements Namespace


getVisibility Method

[image]

Revit 2010 API
View..::.getVisibility Method
View Class See Also Send Feedback
Checks if elements of the given category are set to be visible in this view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool getVisibility(
    Category category
)
Visual Basic (Declaration)
Public Function getVisibility ( _
    category As Category _
) As Boolean
Visual C++
public:
bool getVisibility(
    Category^ category
)

Parameters

category
Type: Autodesk.Revit..::.Category
The category.

See Also

View Class
Autodesk.Revit.Elements Namespace


Hide Method

[image]

Revit 2010 API
View..::.Hide Method
View Class See Also Send Feedback
Sets the elements to be hidden in the view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Hide(
    ElementSet elemSet
)
Visual Basic (Declaration)
Public Sub Hide ( _
    elemSet As ElementSet _
)
Visual C++
public:
void Hide(
    ElementSet^ elemSet
)

Parameters

elemSet
Type: Autodesk.Revit..::.ElementSet
A set of elements to be hidden.

Remarks

This change is permanent until the elements are unhidden. All elements in the set must be currently unhidden and must be allowed to be hidden. An application can check this with IsHidden(View) and CanBeHidden(View).

Some elements cannot be hidden directly. Examples include: group, array, constraint, edit cut profile, face splitter and link to external documents. To hide a group, obtain the elements in the group from Members, and hide these elements individually. To hide an array, obtain the groups in the array from OrigMembers and CopyMembers, then hide elements in the groups individually.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when argument is null.
System..::.InvalidOperationException | Thrown when one of the elements can not be hidden or has been hidden already.

See Also

View Class
Autodesk.Revit.Elements Namespace


Print Method

[image] [image]

Revit 2010 API
View..::.Print Method
View Class See Also Send Feedback
Print this view.

Overload List

Name | Description
Print()()() | Print this view with default print settings and default view template.
Print(View) | Print this view with default print settings and specialized view template.
Print(Boolean) | Print this view with default print settings and view template.
Print(View, Boolean) | Print this view with current print settings and specialized view template.

See Also

View Class
View Members
Autodesk.Revit.Elements Namespace


Print Method

[image]

Revit 2010 API
View..::.Print Method
View Class See Also Send Feedback
Print this view with default print settings and default view template.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Print()
Visual Basic (Declaration)
Public Sub Print
Visual C++
public:
void Print()

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the view cannot be printed.

See Also

View Class
Print Overload
Autodesk.Revit.Elements Namespace


Print Method (View)

[image]

Revit 2010 API
View..::.Print Method (View)
View Class See Also Send Feedback
Print this view with default print settings and specialized view template.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Print(
    View viewTemplate
)
Visual Basic (Declaration)
Public Sub Print ( _
    viewTemplate As View _
)
Visual C++
public:
void Print(
    View^ viewTemplate
)

Parameters

viewTemplate
Type: Autodesk.Revit.Elements..::.View
The view template which apply to the view.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the view cannot be printed.

See Also

View Class
Print Overload
Autodesk.Revit.Elements Namespace


Print Method (Boolean)

[image]

Revit 2010 API
View..::.Print Method (Boolean)
View Class See Also Send Feedback
Print this view with default print settings and view template.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Print(
    bool useCurrentPrintSettings
)
Visual Basic (Declaration)
Public Sub Print ( _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print(
    bool useCurrentPrintSettings
)

Parameters

useCurrentPrintSettings
Type: System..::.Boolean
If true, print the view with the current print settings; otherwise with the print settings of the document.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the view cannot be printed.

See Also

View Class
Print Overload
Autodesk.Revit.Elements Namespace


Print Method (View, Boolean)

[image]

Revit 2010 API
View..::.Print Method (View, Boolean)
View Class See Also Send Feedback
Print this view with current print settings and specialized view template.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Print(
    View viewTemplate,
    bool useCurrentPrintSettings
)
Visual Basic (Declaration)
Public Sub Print ( _
    viewTemplate As View, _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print(
    View^ viewTemplate,
    bool useCurrentPrintSettings
)

Parameters

viewTemplate
Type: Autodesk.Revit.Elements..::.View
The view template which apply to the view.
useCurrentPrintSettings
Type: System..::.Boolean
If true, print the view with the current print settings; otherwise with the print settings of the document.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the view cannot be printed.

See Also

View Class
Print Overload
Autodesk.Revit.Elements Namespace


setVisibility Method

[image]

Revit 2010 API
View..::.setVisibility Method
View Class See Also Send Feedback
Set if elements of the given category will be visible in this view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void setVisibility(
    Category category,
    bool visible
)
Visual Basic (Declaration)
Public Sub setVisibility ( _
    category As Category, _
    visible As Boolean _
)
Visual C++
public:
void setVisibility(
    Category^ category,
    bool visible
)

Parameters

category
Type: Autodesk.Revit..::.Category
The category.
visible
Type: System..::.Boolean
True to make elements of this category visible, false to make them invisible.

See Also

View Class
Autodesk.Revit.Elements Namespace


Unhide Method

[image]

Revit 2010 API
View..::.Unhide Method
View Class See Also Send Feedback
Sets the elements to be shown in the given view if they are currently hidden.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Unhide(
    ElementSet elemSet
)
Visual Basic (Declaration)
Public Sub Unhide ( _
    elemSet As ElementSet _
)
Visual C++
public:
void Unhide(
    ElementSet^ elemSet
)

Parameters

elemSet
Type: Autodesk.Revit..::.ElementSet
A set of elements to be unhidden.

Remarks

This change is permanent until the elements are hidden again. All elements in the set must be currently hidden. An application can check this with IsHidden(View).

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when argument is null.
System..::.InvalidOperationException | Thrown when one of the elements can not be unhidden or has been unhidden already.

See Also

View Class
Autodesk.Revit.Elements Namespace


View Properties

[image] [image]

Revit 2010 API
View Properties
View Class See Also Send Feedback

The View type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view.
CropBoxActive | Whether or not the the Crop Box/Region is active for the view.
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view.
CutColorOverrideByElement | Override the cut lines' color by Element in this view.
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view.
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Set of all elements that will be drawn in the view.
GenLevel | The level for the view.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen.
Outline | The bounds of the view in paper space (in inches).
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view.
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view.
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view.
RightDirection | The direction towards the right side of the screen.
Scale | The scale of the view.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen.
ViewDirection | The direction towards the viewer.
ViewName | The name of the view.
ViewType | The type of the view.

See Also

View Class
Autodesk.Revit.Elements Namespace


CanBePrinted Property

[image]

Revit 2010 API
View..::.CanBePrinted Property
View Class See Also Send Feedback
Test whether the view can be printed.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool CanBePrinted { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanBePrinted As Boolean
Visual C++
public:
property bool CanBePrinted {
    bool get ();
}

See Also

View Class
Autodesk.Revit.Elements Namespace


CropBox Property

[image]

Revit 2010 API
View..::.CropBox Property
View Class See Also Send Feedback
The crop box applied to the view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundingBoxXYZ CropBox { get; set; }
Visual Basic (Declaration)
Public Property CropBox As BoundingBoxXYZ
Visual C++
public:
property BoundingBoxXYZ^ CropBox {
    BoundingBoxXYZ^ get ();
    void set (BoundingBoxXYZ^ value);
}

Remarks

The X direction of the box is right on screen; Y, up; Z, towards the user.

See Also

View Class
Autodesk.Revit.Elements Namespace


CropBoxActive Property

[image]

Revit 2010 API
View..::.CropBoxActive Property
View Class See Also Send Feedback
Whether or not the the Crop Box/Region is active for the view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool CropBoxActive { get; set; }
Visual Basic (Declaration)
Public Property CropBoxActive As Boolean
Visual C++
public:
property bool CropBoxActive {
    bool get ();
    void set (bool value);
}

Remarks

Identifies whether the crop region modifies the graphical appearance of elements in the view.

See Also

View Class
Autodesk.Revit.Elements Namespace


CropBoxVisible Property

[image]

Revit 2010 API
View..::.CropBoxVisible Property
View Class See Also Send Feedback
Whether or not the Crop Box/Region is visible for the view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool CropBoxVisible { get; set; }
Visual Basic (Declaration)
Public Property CropBoxVisible As Boolean
Visual C++
public:
property bool CropBoxVisible {
    bool get ();
    void set (bool value);
}

See Also

View Class
Autodesk.Revit.Elements Namespace


CutColorOverrideByElement Property

[image]

Revit 2010 API
View..::.CutColorOverrideByElement Property
View Class See Also Send Feedback
Override the cut lines' color by Element in this view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Color CutColorOverrideByElement[
    ElementIdSet ids
] { get; set; }
Visual Basic (Declaration)
Public Property CutColorOverrideByElement ( _
    ids As ElementIdSet _
) As Color
Visual C++
public:
property Color^ CutColorOverrideByElement[ElementIdSet^ ids] {
    Color^ get (ElementIdSet^ ids);
    void set (ElementIdSet^ ids, Color^ value);
}

Parameters

ids
Type: Autodesk.Revit..::.ElementIdSet
A set of element ids for the elements that are to be overridden.

Field Value

The override color of the elements that are to be overridden. null indicates that no override should be applied.

See Also

View Class
Autodesk.Revit.Elements Namespace


CutLinePatternOverrideByElement Property

[image]

Revit 2010 API
View..::.CutLinePatternOverrideByElement Property
View Class See Also Send Feedback
Override the cut lines' pattern by Element in this view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LinePattern CutLinePatternOverrideByElement[
    ElementIdSet ids
] { get; set; }
Visual Basic (Declaration)
Public Property CutLinePatternOverrideByElement ( _
    ids As ElementIdSet _
) As LinePattern
Visual C++
public:
property LinePattern^ CutLinePatternOverrideByElement[ElementIdSet^ ids] {
    LinePattern^ get (ElementIdSet^ ids);
    void set (ElementIdSet^ ids, LinePattern^ value);
}

Parameters

ids
Type: Autodesk.Revit..::.ElementIdSet
A set of element ids for the elements that are to be overridden.

Field Value

The line pattern of the elements that are to be overridden. null indicates that no override should be applied.

See Also

View Class
Autodesk.Revit.Elements Namespace


CutLineWeightOverrideByElement Property

[image]

Revit 2010 API
View..::.CutLineWeightOverrideByElement Property
View Class See Also Send Feedback
Override the cut lines' weight by Element in this view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int CutLineWeightOverrideByElement[
    ElementIdSet ids
] { get; set; }
Visual Basic (Declaration)
Public Property CutLineWeightOverrideByElement ( _
    ids As ElementIdSet _
) As Integer
Visual C++
public:
property int CutLineWeightOverrideByElement[ElementIdSet^ ids] {
    int get (ElementIdSet^ ids);
    void set (ElementIdSet^ ids, int value);
}

Parameters

ids
Type: Autodesk.Revit..::.ElementIdSet
A set of element ids for the elements that are to be overridden.

Field Value

The line pattern of the elements that are to be overridden. A negative value indicates that no override should be applied.

See Also

View Class
Autodesk.Revit.Elements Namespace


Elements Property

[image]

Revit 2010 API
View..::.Elements Property
View Class Example See Also Send Feedback
Set of all elements that will be drawn in the view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet Elements { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements As ElementSet
Visual C++
public:
property ElementSet^ Elements {
    ElementSet^ get ();
}

Remarks

Elements that belong to this set have graphics that may be visible in this view. Some elements may still be hidden because they are obscured by other elements.

Examples

CopyC#
private void CountElements(Autodesk.Revit.Document document)
{
    // Count the number of elements in the document
    int count = 0;
    ElementIterator iter = document.Elements;
    iter.Reset();
    while (iter.MoveNext())
    {
        Autodesk.Revit.Element elem = iter.Current as Autodesk.Revit.Element;
        if (null != elem)
        {
            ++count;
        }
    }
    StringBuilder message = new StringBuilder();
    message.AppendLine("Elements within Document: " + count.ToString());
    message.AppendLine("Elements within active View: "
       + document.ActiveView.Elements.Size.ToString());

    MessageBox.Show(message.ToString());
}
CopyVB.NET
Private Sub CountElements(ByVal document As Autodesk.Revit.Document)
    ' Count the number of elements in the document
    Dim count As Integer = 0
    Dim iter As ElementIterator = document.Elements
    iter.Reset()
    While iter.MoveNext()
        Dim elem As Autodesk.Revit.Element = TryCast(iter.Current, Autodesk.Revit.Element)
        If elem IsNot Nothing Then
            count += 1
        End If
    End While
    Dim message As New StringBuilder()
    message.AppendLine("Elements within Document: " & count.ToString())
    message.AppendLine("Elements within active View: " & document.ActiveView.Elements.Size.ToString())

    MessageBox.Show(message.ToString())
End Sub

See Also

View Class
Autodesk.Revit.Elements Namespace


GenLevel Property

[image]

Revit 2010 API
View..::.GenLevel Property
View Class See Also Send Feedback
The level for the view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Level GenLevel { get; }
Visual Basic (Declaration)
Public ReadOnly Property GenLevel As Level
Visual C++
public:
property Level^ GenLevel {
    Level^ get ();
}

Remarks

This will obtain the level for views related to levels, such as Plan Views. If this View is not generated by a level, this property is null.

See Also

View Class
Autodesk.Revit.Elements Namespace


Origin Property

[image]

Revit 2010 API
View..::.Origin Property
View Class See Also Send Feedback
Returns the origin of the screen.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

View Class
Autodesk.Revit.Elements Namespace


Outline Property

[image]

Revit 2010 API
View..::.Outline Property
View Class See Also Send Feedback
The bounds of the view in paper space (in inches).

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundingBoxUV Outline { get; }
Visual Basic (Declaration)
Public ReadOnly Property Outline As BoundingBoxUV
Visual C++
public:
property BoundingBoxUV^ Outline {
    BoundingBoxUV^ get ();
}

Remarks

Returns all zeros for empty views.

See Also

View Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
View..::.Parameter Property
View Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

View Class
View Members
Autodesk.Revit.Elements Namespace


ProjColorOverrideByElement Property

[image]

Revit 2010 API
View..::.ProjColorOverrideByElement Property
View Class See Also Send Feedback
Override the projection lines' color by Element in this view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Color ProjColorOverrideByElement[
    ElementIdSet ids
] { get; set; }
Visual Basic (Declaration)
Public Property ProjColorOverrideByElement ( _
    ids As ElementIdSet _
) As Color
Visual C++
public:
property Color^ ProjColorOverrideByElement[ElementIdSet^ ids] {
    Color^ get (ElementIdSet^ ids);
    void set (ElementIdSet^ ids, Color^ value);
}

Parameters

ids
Type: Autodesk.Revit..::.ElementIdSet
A set of element ids for the elements that are to be overridden.

Field Value

The override color of the elements that are to be overridden. null indicates that no override should be applied.

See Also

View Class
Autodesk.Revit.Elements Namespace


ProjLinePatternOverrideByElement Property

[image]

Revit 2010 API
View..::.ProjLinePatternOverrideByElement Property
View Class See Also Send Feedback
Override the projection lines' pattern by Element in this view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LinePattern ProjLinePatternOverrideByElement[
    ElementIdSet ids
] { get; set; }
Visual Basic (Declaration)
Public Property ProjLinePatternOverrideByElement ( _
    ids As ElementIdSet _
) As LinePattern
Visual C++
public:
property LinePattern^ ProjLinePatternOverrideByElement[ElementIdSet^ ids] {
    LinePattern^ get (ElementIdSet^ ids);
    void set (ElementIdSet^ ids, LinePattern^ value);
}

Parameters

ids
Type: Autodesk.Revit..::.ElementIdSet
A set of element ids for the elements that are to be overridden.

Field Value

The line pattern of the elements that are to be overridden. null indicates that no override should be applied.

See Also

View Class
Autodesk.Revit.Elements Namespace


ProjLineWeightOverrideByElement Property

[image]

Revit 2010 API
View..::.ProjLineWeightOverrideByElement Property
View Class See Also Send Feedback
Override the projection lines' weight by Element in this view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int ProjLineWeightOverrideByElement[
    ElementIdSet ids
] { get; set; }
Visual Basic (Declaration)
Public Property ProjLineWeightOverrideByElement ( _
    ids As ElementIdSet _
) As Integer
Visual C++
public:
property int ProjLineWeightOverrideByElement[ElementIdSet^ ids] {
    int get (ElementIdSet^ ids);
    void set (ElementIdSet^ ids, int value);
}

Parameters

ids
Type: Autodesk.Revit..::.ElementIdSet
A set of element ids for the elements that are to be overridden.

Field Value

The line pattern of the elements that are to be overridden. A negative value indicates that no override should be applied.

See Also

View Class
Autodesk.Revit.Elements Namespace


RightDirection Property

[image]

Revit 2010 API
View..::.RightDirection Property
View Class See Also Send Feedback
The direction towards the right side of the screen.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ RightDirection { get; }
Visual Basic (Declaration)
Public ReadOnly Property RightDirection As XYZ
Visual C++
public:
property XYZ^ RightDirection {
    XYZ^ get ();
}

See Also

View Class
Autodesk.Revit.Elements Namespace


Scale Property

[image]

Revit 2010 API
View..::.Scale Property
View Class See Also Send Feedback
The scale of the view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Scale { get; set; }
Visual Basic (Declaration)
Public Property Scale As Integer
Visual C++
public:
property int Scale {
    int get ();
    void set (int value);
}

Remarks

The scale is the ratio of true model size to paper size. This property is meaningless for perspective views. When setting the scale if the scale corresponds to a predefined scale, the predefined item will be applied. Otherwise, a custom scale will be applied.

See Also

View Class
Autodesk.Revit.Elements Namespace


SketchPlane Property

[image]

Revit 2010 API
View..::.SketchPlane Property
View Class See Also Send Feedback
The sketch plane assigned to the view for model curve creation.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SketchPlane SketchPlane { get; }
Visual Basic (Declaration)
Public ReadOnly Property SketchPlane As SketchPlane
Visual C++
public:
property SketchPlane^ SketchPlane {
    SketchPlane^ get ();
}

Field Value

The sketch plane, or null for views which don't allow sketching (such as schedules) or for 3D views, which have no fixed sketch plane.

See Also

View Class
Autodesk.Revit.Elements Namespace


UpDirection Property

[image]

Revit 2010 API
View..::.UpDirection Property
View Class See Also Send Feedback
The direction towards the top of the screen.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ UpDirection { get; }
Visual Basic (Declaration)
Public ReadOnly Property UpDirection As XYZ
Visual C++
public:
property XYZ^ UpDirection {
    XYZ^ get ();
}

See Also

View Class
Autodesk.Revit.Elements Namespace


ViewDirection Property

[image]

Revit 2010 API
View..::.ViewDirection Property
View Class See Also Send Feedback
The direction towards the viewer.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ ViewDirection { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewDirection As XYZ
Visual C++
public:
property XYZ^ ViewDirection {
    XYZ^ get ();
}

Remarks

In orthographic views, all objects are projected onto the screen along this direction. In perspective views, the view target point is projected along this direction, but other points are projected towards the eye along different vectors.

See Also

View Class
Autodesk.Revit.Elements Namespace


ViewName Property

[image]

Revit 2010 API
View..::.ViewName Property
View Class See Also Send Feedback
The name of the view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string ViewName { get; set; }
Visual Basic (Declaration)
Public Property ViewName As String
Visual C++
public:
property String^ ViewName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown if the name provided already exists, or is invalid for this view.

See Also

View Class
Autodesk.Revit.Elements Namespace


ViewType Property

[image]

Revit 2010 API
View..::.ViewType Property
View Class Example See Also Send Feedback
The type of the view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewType ViewType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewType As ViewType
Visual C++
public:
property ViewType ViewType {
    ViewType get ();
}

Examples

CopyC#
public void GetViewType(Autodesk.Revit.Elements.View view)
{
    // Get the view type of the given view, and format the prompt string
    String prompt = "The view is ";

    switch (view.ViewType)
    {
        case Autodesk.Revit.Enums.ViewType.AreaPlan:
            prompt += "an area view.";
            break;
        case Autodesk.Revit.Enums.ViewType.CeilingPlan:
            prompt += "a reflected ceiling plan view.";
            break;
        case Autodesk.Revit.Enums.ViewType.ColumnSchedule:
            prompt += "a column schedule view.";
            break;
        case Autodesk.Revit.Enums.ViewType.CostReport:
            prompt += "a cost report view.";
            break;
        case Autodesk.Revit.Enums.ViewType.Detail:
            prompt += "a detail view.";
            break;
        case Autodesk.Revit.Enums.ViewType.DraftingView:
            prompt += "a drafting view.";
            break;
        case Autodesk.Revit.Enums.ViewType.DrawingSheet:
            prompt += "a drawing sheet view.";
            break;
        case Autodesk.Revit.Enums.ViewType.Elevation:
            prompt += "an elevation view.";
            break;
        case Autodesk.Revit.Enums.ViewType.EngineeringPlan:
            prompt += "an engineering view.";
            break;
        case Autodesk.Revit.Enums.ViewType.FloorPlan:
            prompt += "afloor plan view.";
            break;
        case Autodesk.Revit.Enums.ViewType.Internal:
            prompt += "Revit's internal view.";
            break;
        case Autodesk.Revit.Enums.ViewType.Legend:
            prompt += "a legend view.";
            break;
        case Autodesk.Revit.Enums.ViewType.LoadsReport:
            prompt += "a loads report view.";
            break;
        case Autodesk.Revit.Enums.ViewType.PanelSchedule:
            prompt += "a panel schedule view.";
            break;
        case Autodesk.Revit.Enums.ViewType.PresureLossReport:
            prompt += "a pressure loss report view.";
            break;
        case Autodesk.Revit.Enums.ViewType.Rendering:
            prompt += "a rendering view.";
            break;
        case Autodesk.Revit.Enums.ViewType.Report:
            prompt += "a report view.";
            break;
        case Autodesk.Revit.Enums.ViewType.Schedule:
            prompt += "a schedule view.";
            break;
        case Autodesk.Revit.Enums.ViewType.Section:
            prompt += "a cross section view.";
            break;
        case Autodesk.Revit.Enums.ViewType.ThreeD:
            prompt += "a 3-D view.";
            break;
        case Autodesk.Revit.Enums.ViewType.Undefined:
            prompt += "an undefined/unspecified view.";
            break;
        case Autodesk.Revit.Enums.ViewType.Walkthrough:
            prompt += "a walkthrough view.";
            break;
        default:
            break;
    }

    // Give the user some information
    MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetViewType(ByVal view As Autodesk.Revit.Elements.View)
    ' Get the view type of the given view, and format the prompt string
    Dim prompt As String = "The view is "

    Select Case view.ViewType
        Case Autodesk.Revit.Enums.ViewType.AreaPlan
            prompt += "an area view."
            Exit Select
        Case Autodesk.Revit.Enums.ViewType.CeilingPlan
            prompt += "a reflected ceiling plan view."
            Exit Select
        Case Autodesk.Revit.Enums.ViewType.ColumnSchedule
            prompt += "a column schedule view."
            Exit Select
        Case Autodesk.Revit.Enums.ViewType.CostReport
            prompt += "a cost report view."
            Exit Select
        Case Autodesk.Revit.Enums.ViewType.Detail
            prompt += "a detail view."
            Exit Select
        Case Autodesk.Revit.Enums.ViewType.DraftingView
            prompt += "a drafting view."
            Exit Select
        Case Autodesk.Revit.Enums.ViewType.DrawingSheet
            prompt += "a drawing sheet view."
            Exit Select
        Case Autodesk.Revit.Enums.ViewType.Elevation
            prompt += "an elevation view."
            Exit Select
        Case Autodesk.Revit.Enums.ViewType.EngineeringPlan
            prompt += "an engineering view."
            Exit Select
        Case Autodesk.Revit.Enums.ViewType.FloorPlan
            prompt += "afloor plan view."
            Exit Select
        Case Autodesk.Revit.Enums.ViewType.Internal
            prompt += "Revit's internal view."
            Exit Select
        Case Autodesk.Revit.Enums.ViewType.Legend
            prompt += "a legend view."
            Exit Select
        Case Autodesk.Revit.Enums.ViewType.LoadsReport
            prompt += "a loads report view."
            Exit Select
        Case Autodesk.Revit.Enums.ViewType.PanelSchedule
            prompt += "a panel schedule view."
            Exit Select
        Case Autodesk.Revit.Enums.ViewType.PresureLossReport
            prompt += "a pressure loss report view."
            Exit Select
        Case Autodesk.Revit.Enums.ViewType.Rendering
            prompt += "a rendering view."
            Exit Select
        Case Autodesk.Revit.Enums.ViewType.Report
            prompt += "a report view."
            Exit Select
        Case Autodesk.Revit.Enums.ViewType.Schedule
            prompt += "a schedule view."
            Exit Select
        Case Autodesk.Revit.Enums.ViewType.Section
            prompt += "a cross section view."
            Exit Select
        Case Autodesk.Revit.Enums.ViewType.ThreeD
            prompt += "a 3-D view."
            Exit Select
        Case Autodesk.Revit.Enums.ViewType.Undefined
            prompt += "an undefined/unspecified view."
            Exit Select
        Case Autodesk.Revit.Enums.ViewType.Walkthrough
            prompt += "a walkthrough view."
            Exit Select
        Case Else
            Exit Select
    End Select

    ' Give the user some information
    MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)
End Sub

See Also

View Class
Autodesk.Revit.Elements Namespace


View3D Class

[image]

Revit 2010 API
View3D Class
Members Example See Also Send Feedback
A freely-oriented orthographic or perspective view of the model.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class View3D : View
Visual Basic (Declaration)
Public Class View3D _
    Inherits View
Visual C++
public ref class View3D : public View

Examples

CopyC#
private void Getinfo_View3D(View3D view3D)
{
    string message = "View3D: ";
    // The position of the camera.
    XYZ eyePosition = view3D.EyePosition;
    message += "\nCamera position: (" + eyePosition.X + ", " +
                eyePosition.Y + ", " + eyePosition.Z + ")";

    // Identifies whether this is a perspective view.
    if (view3D.IsPerspective)
    {
        message += "\nThe view is a perspective.";
    }

    // The section box of the 3D view cuts the model by its bounds.
    BoundingBoxXYZ sectionBox = view3D.SectionBox;
    XYZ max = sectionBox.Max; //Maximum coordinates (upper-right-front corner of the box).
    XYZ min = sectionBox.Min; //Minimum coordinates (lower-left-rear corner of the box).
    message += "\nSection Box: ";
    message += "\nMaximum coordinates: (" + max.X + ", " + max.Y + ", " + max.Z + ")";
    message += "\nMinimum coordinates: (" + min.X + ", " + min.Y + ", " + min.Z + ")";

    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Private Sub Getinfo_View3D(ByVal view3D As View3D)
    Dim message As String = "View3D: "
    ' The position of the camera.
    Dim eyePosition As Autodesk.Revit.Geometry.XYZ = view3D.EyePosition
    message += ((vbLf & "Camera position: (" & eyePosition.X & ", ") + eyePosition.Y & ", ") + eyePosition.Z & ")"

    ' Identifies whether this is a perspective view.
    If view3D.IsPerspective Then
        message += vbLf & "The view is a perspective."
    End If

    ' The section box of the 3D view cuts the model by its bounds.
    Dim sectionBox As BoundingBoxXYZ = view3D.SectionBox
    Dim max As Autodesk.Revit.Geometry.XYZ = sectionBox.Max
    'Maximum coordinates (upper-right-front corner of the box).
    Dim min As Autodesk.Revit.Geometry.XYZ = sectionBox.Min
    'Minimum coordinates (lower-left-rear corner of the box).
    message += vbLf & "Section Box: "
    message += ((vbLf & "Maximum coordinates: (" & max.X & ", ") + max.Y & ", ") + max.Z & ")"
    message += ((vbLf & "Minimum coordinates: (" & min.X & ", ") + min.Y & ", ") + min.Z & ")"

    MessageBox.Show(message, "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.View
Autodesk.Revit.Elements..::.View3D

See Also

View3D Members
Autodesk.Revit.Elements Namespace


View3D Members

[image] [image]

Revit 2010 API
View3D Members
View3D Class Constructors Methods Properties See Also Send Feedback

The View3D type exposes the following members.

Constructors

Name | Description
View3D | Initializes a new instance of the View3D class

Methods

Name | Description
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Set of all elements that will be drawn in the view. (Inherited from View.)
EyePosition | The position of the camera.
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsPerspective | Identifies whether this is a perspective view.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SectionBox | The section box of the 3D view cuts the model by its bounds.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
ViewType | The type of the view. (Inherited from View.)

See Also

View3D Class
Autodesk.Revit.Elements Namespace


View3D Constructor

[image]

Revit 2010 API
View3D Constructor
View3D Class See Also Send Feedback
Initializes a new instance of the View3D class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public View3D()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
View3D()

See Also

View3D Class
Autodesk.Revit.Elements Namespace


View3D Methods

[image] [image]

Revit 2010 API
View3D Methods
View3D Class See Also Send Feedback

The View3D type exposes the following members.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

View3D Class
Autodesk.Revit.Elements Namespace


Print Method

[image] [image]

Revit 2010 API
View3D..::.Print Method
View3D Class See Also Send Feedback
Print this view.

Overload List

Name | Description
Print()()() | Print this view with default print settings and default view template. (Inherited from View.)
Print(View) | Print this view with default print settings and specialized view template. (Inherited from View.)
Print(Boolean) | Print this view with default print settings and view template. (Inherited from View.)
Print(View, Boolean) | Print this view with current print settings and specialized view template. (Inherited from View.)

See Also

View3D Class
View3D Members
Autodesk.Revit.Elements Namespace


View3D Properties

[image] [image]

Revit 2010 API
View3D Properties
View3D Class See Also Send Feedback

The View3D type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Set of all elements that will be drawn in the view. (Inherited from View.)
EyePosition | The position of the camera.
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsPerspective | Identifies whether this is a perspective view.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SectionBox | The section box of the 3D view cuts the model by its bounds.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
ViewType | The type of the view. (Inherited from View.)

See Also

View3D Class
Autodesk.Revit.Elements Namespace


EyePosition Property

[image]

Revit 2010 API
View3D..::.EyePosition Property
View3D Class See Also Send Feedback
The position of the camera.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ EyePosition { get; }
Visual Basic (Declaration)
Public ReadOnly Property EyePosition As XYZ
Visual C++
public:
property XYZ^ EyePosition {
    XYZ^ get ();
}

See Also

View3D Class
Autodesk.Revit.Elements Namespace


IsPerspective Property

[image]

Revit 2010 API
View3D..::.IsPerspective Property
View3D Class See Also Send Feedback
Identifies whether this is a perspective view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsPerspective { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPerspective As Boolean
Visual C++
public:
property bool IsPerspective {
    bool get ();
}

Remarks

If this is false, the view is orthographic - the view direction is constant. In a perspective view, view direction is variable - it is the direction that connects a particular point on the model with the eye position. The view direction property becomes less meaningful - it only describes the general orientation of the camera.

See Also

View3D Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
View3D..::.Parameter Property
View3D Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

View3D Class
View3D Members
Autodesk.Revit.Elements Namespace


SectionBox Property

[image]

Revit 2010 API
View3D..::.SectionBox Property
View3D Class See Also Send Feedback
The section box of the 3D view cuts the model by its bounds.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundingBoxXYZ SectionBox { get; set; }
Visual Basic (Declaration)
Public Property SectionBox As BoundingBoxXYZ
Visual C++
public:
property BoundingBoxXYZ^ SectionBox {
    BoundingBoxXYZ^ get ();
    void set (BoundingBoxXYZ^ value);
}

Remarks

To turn off section box, pass in null or a disabled box. Individual bound enabled flags are currently ignored.

See Also

View3D Class
Autodesk.Revit.Elements Namespace


ViewDrafting Class

[image]

Revit 2010 API
ViewDrafting Class
Members See Also Send Feedback
A drafting view allows the user to draw graphics without including them in the model.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ViewDrafting : View
Visual Basic (Declaration)
Public Class ViewDrafting _
    Inherits View
Visual C++
public ref class ViewDrafting : public View

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.View
Autodesk.Revit.Elements..::.ViewDrafting

See Also

ViewDrafting Members
Autodesk.Revit.Elements Namespace


ViewDrafting Members

[image] [image]

Revit 2010 API
ViewDrafting Members
ViewDrafting Class Constructors Methods Properties See Also Send Feedback

The ViewDrafting type exposes the following members.

Constructors

Name | Description
ViewDrafting | For Internal Use Only.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Set of all elements that will be drawn in the view. (Inherited from View.)
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
ViewType | The type of the view. (Inherited from View.)

See Also

ViewDrafting Class
Autodesk.Revit.Elements Namespace


ViewDrafting Constructor

[image]

Revit 2010 API
ViewDrafting Constructor
ViewDrafting Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewDrafting()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewDrafting()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ViewDrafting Class
Autodesk.Revit.Elements Namespace


ViewDrafting Methods

[image] [image]

Revit 2010 API
ViewDrafting Methods
ViewDrafting Class See Also Send Feedback

The ViewDrafting type exposes the following members.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

ViewDrafting Class
Autodesk.Revit.Elements Namespace


Print Method

[image] [image]

Revit 2010 API
ViewDrafting..::.Print Method
ViewDrafting Class See Also Send Feedback
Print this view.

Overload List

Name | Description
Print()()() | Print this view with default print settings and default view template. (Inherited from View.)
Print(View) | Print this view with default print settings and specialized view template. (Inherited from View.)
Print(Boolean) | Print this view with default print settings and view template. (Inherited from View.)
Print(View, Boolean) | Print this view with current print settings and specialized view template. (Inherited from View.)

See Also

ViewDrafting Class
ViewDrafting Members
Autodesk.Revit.Elements Namespace


ViewDrafting Properties

[image] [image]

Revit 2010 API
ViewDrafting Properties
ViewDrafting Class See Also Send Feedback

The ViewDrafting type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Set of all elements that will be drawn in the view. (Inherited from View.)
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
ViewType | The type of the view. (Inherited from View.)

See Also

ViewDrafting Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
ViewDrafting..::.Parameter Property
ViewDrafting Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ViewDrafting Class
ViewDrafting Members
Autodesk.Revit.Elements Namespace


ViewPlan Class

[image]

Revit 2010 API
ViewPlan Class
Members See Also Send Feedback
A plan represents for floor plan or ceiling plan.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ViewPlan : View
Visual Basic (Declaration)
Public Class ViewPlan _
    Inherits View
Visual C++
public ref class ViewPlan : public View

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.View
Autodesk.Revit.Elements..::.ViewPlan

See Also

ViewPlan Members
Autodesk.Revit.Elements Namespace


ViewPlan Members

[image] [image]

Revit 2010 API
ViewPlan Members
ViewPlan Class Constructors Methods Properties See Also Send Feedback

The ViewPlan type exposes the following members.

Constructors

Name | Description
ViewPlan | For Internal Use Only.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

Name | Description
AreaScheme | The area scheme.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Set of all elements that will be drawn in the view. (Inherited from View.)
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
ViewType | The type of the view. (Inherited from View.)

See Also

ViewPlan Class
Autodesk.Revit.Elements Namespace


ViewPlan Constructor

[image]

Revit 2010 API
ViewPlan Constructor
ViewPlan Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewPlan()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewPlan()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ViewPlan Class
Autodesk.Revit.Elements Namespace


ViewPlan Methods

[image] [image]

Revit 2010 API
ViewPlan Methods
ViewPlan Class See Also Send Feedback

The ViewPlan type exposes the following members.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

ViewPlan Class
Autodesk.Revit.Elements Namespace


Print Method

[image] [image]

Revit 2010 API
ViewPlan..::.Print Method
ViewPlan Class See Also Send Feedback
Print this view.

Overload List

Name | Description
Print()()() | Print this view with default print settings and default view template. (Inherited from View.)
Print(View) | Print this view with default print settings and specialized view template. (Inherited from View.)
Print(Boolean) | Print this view with default print settings and view template. (Inherited from View.)
Print(View, Boolean) | Print this view with current print settings and specialized view template. (Inherited from View.)

See Also

ViewPlan Class
ViewPlan Members
Autodesk.Revit.Elements Namespace


ViewPlan Properties

[image] [image]

Revit 2010 API
ViewPlan Properties
ViewPlan Class See Also Send Feedback

The ViewPlan type exposes the following members.

Properties

Name | Description
AreaScheme | The area scheme.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Set of all elements that will be drawn in the view. (Inherited from View.)
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
ViewType | The type of the view. (Inherited from View.)

See Also

ViewPlan Class
Autodesk.Revit.Elements Namespace


AreaScheme Property

[image]

Revit 2010 API
ViewPlan..::.AreaScheme Property
ViewPlan Class See Also Send Feedback
The area scheme.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaScheme AreaScheme { get; }
Visual Basic (Declaration)
Public ReadOnly Property AreaScheme As AreaScheme
Visual C++
public:
property AreaScheme^ AreaScheme {
    AreaScheme^ get ();
}

Field Value

Returns null if this plan view is not an area plan.

See Also

ViewPlan Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
ViewPlan..::.Parameter Property
ViewPlan Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ViewPlan Class
ViewPlan Members
Autodesk.Revit.Elements Namespace


ViewSection Class

[image]

Revit 2010 API
ViewSection Class
Members See Also Send Feedback
A section view cuts through the model to expose its interior structure.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ViewSection : View
Visual Basic (Declaration)
Public Class ViewSection _
    Inherits View
Visual C++
public ref class ViewSection : public View

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.View
Autodesk.Revit.Elements..::.ViewSection

See Also

ViewSection Members
Autodesk.Revit.Elements Namespace


ViewSection Members

[image] [image]

Revit 2010 API
ViewSection Members
ViewSection Class Constructors Methods Properties See Also Send Feedback

The ViewSection type exposes the following members.

Constructors

Name | Description
ViewSection | For Internal Use Only.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Set of all elements that will be drawn in the view. (Inherited from View.)
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
ViewType | The type of the view. (Inherited from View.)

See Also

ViewSection Class
Autodesk.Revit.Elements Namespace


ViewSection Constructor

[image]

Revit 2010 API
ViewSection Constructor
ViewSection Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewSection()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ViewSection Class
Autodesk.Revit.Elements Namespace


ViewSection Methods

[image] [image]

Revit 2010 API
ViewSection Methods
ViewSection Class See Also Send Feedback

The ViewSection type exposes the following members.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

ViewSection Class
Autodesk.Revit.Elements Namespace


Print Method

[image] [image]

Revit 2010 API
ViewSection..::.Print Method
ViewSection Class See Also Send Feedback
Print this view.

Overload List

Name | Description
Print()()() | Print this view with default print settings and default view template. (Inherited from View.)
Print(View) | Print this view with default print settings and specialized view template. (Inherited from View.)
Print(Boolean) | Print this view with default print settings and view template. (Inherited from View.)
Print(View, Boolean) | Print this view with current print settings and specialized view template. (Inherited from View.)

See Also

ViewSection Class
ViewSection Members
Autodesk.Revit.Elements Namespace


ViewSection Properties

[image] [image]

Revit 2010 API
ViewSection Properties
ViewSection Class See Also Send Feedback

The ViewSection type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Set of all elements that will be drawn in the view. (Inherited from View.)
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
ViewType | The type of the view. (Inherited from View.)

See Also

ViewSection Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
ViewSection..::.Parameter Property
ViewSection Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ViewSection Class
ViewSection Members
Autodesk.Revit.Elements Namespace


ViewSet Class

[image]

Revit 2010 API
ViewSet Class
Members See Also Send Feedback
A set that contains views.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ViewSet : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class ViewSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ViewSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.ViewSet

See Also

ViewSet Members
Autodesk.Revit.Elements Namespace


ViewSet Members

[image] [image]

Revit 2010 API
ViewSet Members
ViewSet Class Constructors Methods Properties See Also Send Feedback

The ViewSet type exposes the following members.

Constructors

Name | Description
ViewSet | Initializes a new instance of the ViewSet class

Methods

Name | Description
Clear | Removes every view from the set, rendering it empty.
Contains | Tests for the existence of a view within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified view from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified view into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of views that are in the set.

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


ViewSet Constructor

[image]

Revit 2010 API
ViewSet Constructor
ViewSet Class See Also Send Feedback
Initializes a new instance of the ViewSet class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewSet()

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


ViewSet Methods

[image] [image]

Revit 2010 API
ViewSet Methods
ViewSet Class See Also Send Feedback

The ViewSet type exposes the following members.

Methods

Name | Description
Clear | Removes every view from the set, rendering it empty.
Contains | Tests for the existence of a view within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified view from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified view into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


Clear Method

[image]

Revit 2010 API
ViewSet..::.Clear Method
ViewSet Class See Also Send Feedback
Removes every view from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


Contains Method

[image]

Revit 2010 API
ViewSet..::.Contains Method
ViewSet Class See Also Send Feedback
Tests for the existence of a view within the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    View item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As View _
) As Boolean
Visual C++
public:
virtual bool Contains(
    View^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.View
The view to be searched for.

Return Value

The Contains method returns True if the view is within the set, otherwise False.

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


Erase Method

[image]

Revit 2010 API
ViewSet..::.Erase Method
ViewSet Class See Also Send Feedback
Removes a specified view from the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    View item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As View _
) As Integer
Visual C++
public:
virtual int Erase(
    View^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.View
The view to be erased.

Return Value

The number of views that were erased from the set.

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

[image]

Revit 2010 API
ViewSet..::.ForwardIterator Method
ViewSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ViewSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ViewSetIterator
Visual C++
public:
virtual ViewSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

[image]

Revit 2010 API
ViewSet..::.GetEnumerator Method
ViewSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


Insert Method

[image]

Revit 2010 API
ViewSet..::.Insert Method
ViewSet Class See Also Send Feedback
Insert the specified view into the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    View item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As View _
) As Boolean
Visual C++
public:
virtual bool Insert(
    View^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.View
The view to be inserted into the set.

Return Value

Returns whether the view was inserted into the set.

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

[image]

Revit 2010 API
ViewSet..::.ReverseIterator Method
ViewSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ViewSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ViewSetIterator
Visual C++
public:
virtual ViewSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


ViewSet Properties

[image] [image]

Revit 2010 API
ViewSet Properties
ViewSet Class See Also Send Feedback

The ViewSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of views that are in the set.

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


IsEmpty Property

[image]

Revit 2010 API
ViewSet..::.IsEmpty Property
ViewSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


Size Property

[image]

Revit 2010 API
ViewSet..::.Size Property
ViewSet Class See Also Send Feedback
Returns the number of views that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ViewSet Class
Autodesk.Revit.Elements Namespace


ViewSetIterator Class

[image]

Revit 2010 API
ViewSetIterator Class
Members See Also Send Feedback
An iterator to a view set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ViewSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ViewSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ViewSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.ViewSetIterator

See Also

ViewSetIterator Members
Autodesk.Revit.Elements Namespace


ViewSetIterator Members

[image] [image]

Revit 2010 API
ViewSetIterator Members
ViewSetIterator Class Constructors Methods Properties See Also Send Feedback

The ViewSetIterator type exposes the following members.

Constructors

Name | Description
ViewSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSetIterator Class
Autodesk.Revit.Elements Namespace


ViewSetIterator Constructor

[image]

Revit 2010 API
ViewSetIterator Constructor
ViewSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ViewSetIterator Class
Autodesk.Revit.Elements Namespace


ViewSetIterator Methods

[image] [image]

Revit 2010 API
ViewSetIterator Methods
ViewSetIterator Class See Also Send Feedback

The ViewSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewSetIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

[image]

Revit 2010 API
ViewSetIterator..::.MoveNext Method
ViewSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ViewSetIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

[image]

Revit 2010 API
ViewSetIterator..::.Reset Method
ViewSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ViewSetIterator Class
Autodesk.Revit.Elements Namespace


ViewSetIterator Properties

[image] [image]

Revit 2010 API
ViewSetIterator Properties
ViewSetIterator Class See Also Send Feedback

The ViewSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSetIterator Class
Autodesk.Revit.Elements Namespace


Current Property

[image]

Revit 2010 API
ViewSetIterator..::.Current Property
ViewSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ViewSetIterator Class
Autodesk.Revit.Elements Namespace


ViewSheet Class

[image]

Revit 2010 API
ViewSheet Class
Members Example See Also Send Feedback
A sheet is a view used to prepare a finished printout. It contains other views and a titleblock.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ViewSheet : View
Visual Basic (Declaration)
Public Class ViewSheet _
    Inherits View
Visual C++
public ref class ViewSheet : public View

Examples

CopyC#
private void Getinfo_ViewSheet(ViewSheet viewSheet)
{
    string message = "ViewSheet: ";
    //Get the number of the Sheet
    string sheetNumber = viewSheet.SheetNumber;
    message += "\nSheet Number: " + sheetNumber;

    //Exception occurs when set SheetNumber to a number that isn't unique
    string TestSheetNumber = "My sheet";
    viewSheet.SheetNumber = TestSheetNumber;
    message += "\nSheet Number after set: " + sheetNumber;

    ViewSet views = viewSheet.Views;
    message += "\nNumber of views in the sheet : " + views.Size;

    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Private Sub Getinfo_ViewSheet(ByVal viewSheet As ViewSheet)
    Dim message As String = "ViewSheet: "
    'Get the number of the Sheet
    Dim sheetNumber As String = viewSheet.SheetNumber
    message += vbLf & "Sheet Number: " & sheetNumber

    'Exception occurs when set SheetNumber to a number that isn't unique
    Dim TestSheetNumber As String = "My sheet"
    viewSheet.SheetNumber = TestSheetNumber
    message += vbLf & "Sheet Number after set: " & sheetNumber

    Dim views As ViewSet = viewSheet.Views
    message += vbLf & "Number of views in the sheet : " & views.Size

    MessageBox.Show(message, "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.View
Autodesk.Revit.Elements..::.ViewSheet

See Also

ViewSheet Members
Autodesk.Revit.Elements Namespace


ViewSheet Members

[image] [image]

Revit 2010 API
ViewSheet Members
ViewSheet Class Constructors Methods Properties See Also Send Feedback

The ViewSheet type exposes the following members.

Constructors

Name | Description
ViewSheet | Initializes a new instance of the ViewSheet class

Methods

Name | Description
AddView | Places view on the sheet at the given location.
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Set of all elements that will be drawn in the view. (Inherited from View.)
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SheetNumber | Sheet number is unique in the document.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
Views | Returns the set of all views on the sheet.
ViewType | The type of the view. (Inherited from View.)

See Also

ViewSheet Class
Autodesk.Revit.Elements Namespace


ViewSheet Constructor

[image]

Revit 2010 API
ViewSheet Constructor
ViewSheet Class See Also Send Feedback
Initializes a new instance of the ViewSheet class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSheet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewSheet()

See Also

ViewSheet Class
Autodesk.Revit.Elements Namespace


ViewSheet Methods

[image] [image]

Revit 2010 API
ViewSheet Methods
ViewSheet Class See Also Send Feedback

The ViewSheet type exposes the following members.

Methods

Name | Description
AddView | Places view on the sheet at the given location.
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

ViewSheet Class
Autodesk.Revit.Elements Namespace


AddView Method

[image]

Revit 2010 API
ViewSheet..::.AddView Method
ViewSheet Class Example See Also Send Feedback
Places view on the sheet at the given location.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddView(
    View newView,
    UV location
)
Visual Basic (Declaration)
Public Sub AddView ( _
    newView As View, _
    location As UV _
)
Visual C++
public:
void AddView(
    View^ newView,
    UV^ location
)

Parameters

newView
Type: Autodesk.Revit.Elements..::.View
The view to be placed.
location
Type: Autodesk.Revit.Geometry..::.UV
Sheet coordinates (in inches) of the center of the view.

Remarks

Argument exception occurs if the view is of unappropriate type (e.g. ViewSheet) or the view is already placed on another sheet. The lower left corner of the sheet has coordinates [0,0]. Empty views are not placed on the sheet but no exception occurs.

Examples

CopyC#
private void PlaceViewOnSheet(Document document, ViewSheet viewSheet)
{
    //Argument exception occurs if the view is of inappropriate type (e.g. ViewSheet)
    //or the view is already placed on another sheet.
    //The lower left corner of the sheet has coordinates [0,0].
    //Empty views are not placed on the sheet but no exception occurs.

    //put a view into the sheet
    //the location of the view in the view sheet
    UV viewLocation = new UV(1.5, 1.5);
    //get a view form the view list
    Autodesk.Revit.Elements.View tempView = document.ActiveView;
    if (null != tempView)
    {
        viewSheet.AddView(tempView, viewLocation);
        MessageBox.Show("nAdd a view to the viewSheet successfully.");
    }
}
CopyVB.NET
Private Sub PlaceViewOnSheet(ByVal document As Document, ByVal viewSheet As ViewSheet)
    'Argument exception occurs if the view is of inappropriate type (e.g. ViewSheet)
    'or the view is already placed on another sheet.
    'The lower left corner of the sheet has coordinates [0,0].
    'Empty views are not placed on the sheet but no exception occurs.

    'put a view into the sheet
    'the location of the view in the view sheet
    Dim viewLocation As New Autodesk.Revit.Geometry.UV(1.5, 1.5)
    'get a view form the view list
    Dim tempView As Autodesk.Revit.Elements.View = document.ActiveView
    If tempView IsNot Nothing Then
        viewSheet.AddView(tempView, viewLocation)
        MessageBox.Show("nAdd a view to the viewSheet successfully.")
    End If
End Sub

See Also

ViewSheet Class
Autodesk.Revit.Elements Namespace


Print Method

[image] [image]

Revit 2010 API
ViewSheet..::.Print Method
ViewSheet Class See Also Send Feedback
Print this view.

Overload List

Name | Description
Print()()() | Print this view with default print settings and default view template. (Inherited from View.)
Print(View) | Print this view with default print settings and specialized view template. (Inherited from View.)
Print(Boolean) | Print this view with default print settings and view template. (Inherited from View.)
Print(View, Boolean) | Print this view with current print settings and specialized view template. (Inherited from View.)

See Also

ViewSheet Class
ViewSheet Members
Autodesk.Revit.Elements Namespace


ViewSheet Properties

[image] [image]

Revit 2010 API
ViewSheet Properties
ViewSheet Class See Also Send Feedback

The ViewSheet type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Set of all elements that will be drawn in the view. (Inherited from View.)
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SheetNumber | Sheet number is unique in the document.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
Views | Returns the set of all views on the sheet.
ViewType | The type of the view. (Inherited from View.)

See Also

ViewSheet Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
ViewSheet..::.Parameter Property
ViewSheet Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ViewSheet Class
ViewSheet Members
Autodesk.Revit.Elements Namespace


SheetNumber Property

[image]

Revit 2010 API
ViewSheet..::.SheetNumber Property
ViewSheet Class See Also Send Feedback
Sheet number is unique in the document.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string SheetNumber { get; set; }
Visual Basic (Declaration)
Public Property SheetNumber As String
Visual C++
public:
property String^ SheetNumber {
    String^ get ();
    void set (String^ value);
}

Remarks

Exception occurs when trying to set the value that is not unique.

See Also

ViewSheet Class
Autodesk.Revit.Elements Namespace


Views Property

[image]

Revit 2010 API
ViewSheet..::.Views Property
ViewSheet Class See Also Send Feedback
Returns the set of all views on the sheet.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSet Views { get; }
Visual Basic (Declaration)
Public ReadOnly Property Views As ViewSet
Visual C++
public:
property ViewSet^ Views {
    ViewSet^ get ();
}

See Also

ViewSheet Class
Autodesk.Revit.Elements Namespace


ViewSheetSet Class

[image]

Revit 2010 API
ViewSheetSet Class
Members See Also Send Feedback
Represents all kinds of ViewSheetSets.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ViewSheetSet : Element
Visual Basic (Declaration)
Public Class ViewSheetSet _
    Inherits Element
Visual C++
public ref class ViewSheetSet : public Element

Remarks

The ViewSheetSet object is derived from the Element object and hence it supports all the properties and methods of that object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.ViewSheetSet

See Also

ViewSheetSet Members
Autodesk.Revit.Elements Namespace


ViewSheetSet Members

[image] [image]

Revit 2010 API
ViewSheetSet Members
ViewSheetSet Class Constructors Methods Properties See Also Send Feedback

The ViewSheetSet type exposes the following members.

Constructors

Name | Description
ViewSheetSet | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The view sheet set name. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Views | The views.

See Also

ViewSheetSet Class
Autodesk.Revit.Elements Namespace


ViewSheetSet Constructor

[image]

Revit 2010 API
ViewSheetSet Constructor
ViewSheetSet Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSheetSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewSheetSet()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ViewSheetSet Class
Autodesk.Revit.Elements Namespace


ViewSheetSet Methods

[image] [image]

Revit 2010 API
ViewSheetSet Methods
ViewSheetSet Class See Also Send Feedback

The ViewSheetSet type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewSheetSet Class
Autodesk.Revit.Elements Namespace


ViewSheetSet Properties

[image] [image]

Revit 2010 API
ViewSheetSet Properties
ViewSheetSet Class See Also Send Feedback

The ViewSheetSet type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The view sheet set name. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Views | The views.

See Also

ViewSheetSet Class
Autodesk.Revit.Elements Namespace


Name Property

[image]

Revit 2010 API
ViewSheetSet..::.Name Property
ViewSheetSet Class See Also Send Feedback
The view sheet set name.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { get; set; }
Visual Basic (Declaration)
Public Overrides Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when trying to set the name here, please set the name via Autodesk.Revit.PrintSetup.Rename method.

See Also

ViewSheetSet Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
ViewSheetSet..::.Parameter Property
ViewSheetSet Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ViewSheetSet Class
ViewSheetSet Members
Autodesk.Revit.Elements Namespace


Views Property

[image]

Revit 2010 API
ViewSheetSet..::.Views Property
ViewSheetSet Class See Also Send Feedback
The views.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSet Views { get; set; }
Visual Basic (Declaration)
Public Property Views As ViewSet
Visual C++
public:
property ViewSet^ Views {
    ViewSet^ get ();
    void set (ViewSet^ value);
}

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input views is null.
System..::.InvalidOperationException | Thrown when the set operation failed due to invalid view which cannot be printed.

See Also

ViewSheetSet Class
Autodesk.Revit.Elements Namespace


ViewSheetSets Class

[image]

Revit 2010 API
ViewSheetSets Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ViewSheetSets : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ViewSheetSets _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ViewSheetSets : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.ViewSheetSets

See Also

ViewSheetSets Members
Autodesk.Revit.Elements Namespace


ViewSheetSets Members

[image] [image]

Revit 2010 API
ViewSheetSets Members
ViewSheetSets Class Constructors Methods Properties See Also Send Feedback

The ViewSheetSets type exposes the following members.

Constructors

Name | Description
ViewSheetSets | Initializes a new instance of the ViewSheetSets class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


ViewSheetSets Constructor

[image]

Revit 2010 API
ViewSheetSets Constructor
ViewSheetSets Class See Also Send Feedback
Initializes a new instance of the ViewSheetSets class

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSheetSets()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewSheetSets()

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


ViewSheetSets Methods

[image] [image]

Revit 2010 API
ViewSheetSets Methods
ViewSheetSets Class See Also Send Feedback

The ViewSheetSets type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


Clear Method

[image]

Revit 2010 API
ViewSheetSets..::.Clear Method
ViewSheetSets Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


Contains Method

[image]

Revit 2010 API
ViewSheetSets..::.Contains Method
ViewSheetSets Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    ViewSheetSet item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As ViewSheetSet _
) As Boolean
Visual C++
public:
virtual bool Contains(
    ViewSheetSet^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.ViewSheetSet

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


Erase Method

[image]

Revit 2010 API
ViewSheetSets..::.Erase Method
ViewSheetSets Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    ViewSheetSet item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As ViewSheetSet _
) As Integer
Visual C++
public:
virtual int Erase(
    ViewSheetSet^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.ViewSheetSet

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


ForwardIterator Method

[image]

Revit 2010 API
ViewSheetSets..::.ForwardIterator Method
ViewSheetSets Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ViewSheetSetsIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ViewSheetSetsIterator
Visual C++
public:
virtual ViewSheetSetsIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


GetEnumerator Method

[image]

Revit 2010 API
ViewSheetSets..::.GetEnumerator Method
ViewSheetSets Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


Insert Method

[image]

Revit 2010 API
ViewSheetSets..::.Insert Method
ViewSheetSets Class See Also Send Feedback

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    ViewSheetSet item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As ViewSheetSet _
) As Boolean
Visual C++
public:
virtual bool Insert(
    ViewSheetSet^ item
)

Parameters

item
Type: Autodesk.Revit.Elements..::.ViewSheetSet

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


ReverseIterator Method

[image]

Revit 2010 API
ViewSheetSets..::.ReverseIterator Method
ViewSheetSets Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ViewSheetSetsIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ViewSheetSetsIterator
Visual C++
public:
virtual ViewSheetSetsIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


ViewSheetSets Properties

[image] [image]

Revit 2010 API
ViewSheetSets Properties
ViewSheetSets Class See Also Send Feedback

The ViewSheetSets type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


IsEmpty Property

[image]

Revit 2010 API
ViewSheetSets..::.IsEmpty Property
ViewSheetSets Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


Size Property

[image]

Revit 2010 API
ViewSheetSets..::.Size Property
ViewSheetSets Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ViewSheetSets Class
Autodesk.Revit.Elements Namespace


ViewSheetSetsIterator Class

[image]

Revit 2010 API
ViewSheetSetsIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ViewSheetSetsIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ViewSheetSetsIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ViewSheetSetsIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.ViewSheetSetsIterator

See Also

ViewSheetSetsIterator Members
Autodesk.Revit.Elements Namespace


ViewSheetSetsIterator Members

[image] [image]

Revit 2010 API
ViewSheetSetsIterator Members
ViewSheetSetsIterator Class Constructors Methods Properties See Also Send Feedback

The ViewSheetSetsIterator type exposes the following members.

Constructors

Name | Description
ViewSheetSetsIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSheetSetsIterator Class
Autodesk.Revit.Elements Namespace


ViewSheetSetsIterator Constructor

[image]

Revit 2010 API
ViewSheetSetsIterator Constructor
ViewSheetSetsIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSheetSetsIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewSheetSetsIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ViewSheetSetsIterator Class
Autodesk.Revit.Elements Namespace


ViewSheetSetsIterator Methods

[image] [image]

Revit 2010 API
ViewSheetSetsIterator Methods
ViewSheetSetsIterator Class See Also Send Feedback

The ViewSheetSetsIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewSheetSetsIterator Class
Autodesk.Revit.Elements Namespace


MoveNext Method

[image]

Revit 2010 API
ViewSheetSetsIterator..::.MoveNext Method
ViewSheetSetsIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ViewSheetSetsIterator Class
Autodesk.Revit.Elements Namespace


Reset Method

[image]

Revit 2010 API
ViewSheetSetsIterator..::.Reset Method
ViewSheetSetsIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ViewSheetSetsIterator Class
Autodesk.Revit.Elements Namespace


ViewSheetSetsIterator Properties

[image] [image]

Revit 2010 API
ViewSheetSetsIterator Properties
ViewSheetSetsIterator Class See Also Send Feedback

The ViewSheetSetsIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSheetSetsIterator Class
Autodesk.Revit.Elements Namespace


Current Property

[image]

Revit 2010 API
ViewSheetSetsIterator..::.Current Property
ViewSheetSetsIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ViewSheetSetsIterator Class
Autodesk.Revit.Elements Namespace


Wall Class

[image]

Revit 2010 API
Wall Class
Members Example See Also Send Feedback
Represents all of the different kinds of walls Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Wall : HostObject
Visual Basic (Declaration)
Public Class Wall _
    Inherits HostObject
Visual C++
public ref class Wall : public HostObject

Remarks

The wall object represents all the different kinds of wall in Revit. The WallType property is used to distinguish the type of the wall. The wall object is derived from the Element object and hence it supports all the properties and methods of that object.

Examples

CopyC#
public void GetInfo_Wall(Wall wall)
{
    string message = "Wall : ";
    // Get wall AnalyticalModel type
    AnalyticalModel model = wall.AnalyticalModel;
    if (null != model)
    {
        // For some situation(such as architecture wall or in building version),
        // this property may return null, but if it doesn't return null, it should
        // be AnalyticalModelWall.
        message += "\nWall AnalyticalModel type is : " + model;
        if (!(model is AnalyticalModelWall))
        {
            throw new InvalidCastException();
        }
    }

    wall.flip();
    message += "\nIf wall Flipped : " + wall.Flipped;
    // Get curve start point
    message += "\nWall orientation point is :(" + wall.Orientation.X + ", "
        + wall.Orientation.Y + ", " + wall.Orientation.Z + ")";
    // Get wall StructuralUsage
    message += "\nWall StructuralUsage is : " + wall.StructuralUsage;
    // Get wall type name
    message += "\nWall type name is : " + wall.WallType.Name;
    // Get wall width
    message += "\nWall width is : " + wall.Width;

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_Wall(ByVal wall As Wall)
    Dim message As String = "Wall : "
    ' Get wall AnalyticalModel type
    Dim model As Autodesk.Revit.Structural.AnalyticalModel = wall.AnalyticalModel
    If model IsNot Nothing Then
        ' For some situation(such as architecture wall or in building version),
        ' this property may return null, but if it doesn't return null, it should
        ' be AnalyticalModelWall.
        message += vbLf & "Wall AnalyticalModel type is : " & model.ToString
        If Not (TypeOf model Is AnalyticalModelWall) Then
            Throw New InvalidCastException()
        End If
    End If

    wall.flip()
    message += vbLf & "If wall Flipped : " & wall.Flipped
    ' Get curve start point
    message += ((vbLf & "Wall orientation point is :(" & wall.Orientation.X & ", ") + wall.Orientation.Y & ", ") + wall.Orientation.Z & ")"
    ' Get wall StructuralUsage
    message += vbLf & "Wall StructuralUsage is : " & wall.StructuralUsage
    ' Get wall type name
    message += vbLf & "Wall type name is : " & wall.WallType.Name
    ' Get wall width
    message += vbLf & "Wall width is : " & wall.Width

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.Wall

See Also

Wall Members
Autodesk.Revit.Elements Namespace


Wall Members

[image] [image]

Revit 2010 API
Wall Members
Wall Class Constructors Methods Properties See Also Send Feedback

The Wall type exposes the following members.

Constructors

Name | Description
Wall | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
flip | The wall orientation will be flipped.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AnalyticalModel | Retrieves the structural analytical model for this Wall.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurtainGrid | Get the grid object of a curtain wall
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Flipped | Property to test whether the wall orientation is flipped.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Orientation | Provides access to the wall's external face's orientation.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
StructuralUsage | The walls designated structural usage, such as bearing or non bearing.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
WallType | Retrieve or change the type of the wall.
Width | Returns the overall thickness of the wall.

See Also

Wall Class
Autodesk.Revit.Elements Namespace


Wall Constructor

[image]

Revit 2010 API
Wall Constructor
Wall Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Wall()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Wall()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Wall Class
Autodesk.Revit.Elements Namespace


Wall Methods

[image] [image]

Revit 2010 API
Wall Methods
Wall Class See Also Send Feedback

The Wall type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
flip | The wall orientation will be flipped.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Wall Class
Autodesk.Revit.Elements Namespace


flip Method

[image]

Revit 2010 API
Wall..::.flip Method
Wall Class See Also Send Feedback
The wall orientation will be flipped.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void flip()
Visual Basic (Declaration)
Public Sub flip
Visual C++
public:
void flip()

See Also

Wall Class
Autodesk.Revit.Elements Namespace


Wall Properties

[image] [image]

Revit 2010 API
Wall Properties
Wall Class See Also Send Feedback

The Wall type exposes the following members.

Properties

Name | Description
AnalyticalModel | Retrieves the structural analytical model for this Wall.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurtainGrid | Get the grid object of a curtain wall
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Flipped | Property to test whether the wall orientation is flipped.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Orientation | Provides access to the wall's external face's orientation.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
StructuralUsage | The walls designated structural usage, such as bearing or non bearing.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
WallType | Retrieve or change the type of the wall.
Width | Returns the overall thickness of the wall.

See Also

Wall Class
Autodesk.Revit.Elements Namespace


AnalyticalModel Property

[image]

Revit 2010 API
Wall..::.AnalyticalModel Property
Wall Class See Also Send Feedback
Retrieves the structural analytical model for this Wall.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalModel AnalyticalModel { get; }
Visual Basic (Declaration)
Public ReadOnly Property AnalyticalModel As AnalyticalModel
Visual C++
public:
property AnalyticalModel^ AnalyticalModel {
    AnalyticalModel^ get ();
}

Remarks

If the wall has a structural analytical model it is returned by this method, otherwise Nothing is returned. For Walls, the analytical model returned by this method can be cast to type Autodesk.Revit.Structural.AnalyticalModelWall to be able to access details about the wall. This property will only function with the Autodesk Revit Structure product.

See Also

Wall Class
Autodesk.Revit.Elements Namespace


CurtainGrid Property

[image]

Revit 2010 API
Wall..::.CurtainGrid Property
Wall Class See Also Send Feedback
Get the grid object of a curtain wall

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainGrid CurtainGrid { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurtainGrid As CurtainGrid
Visual C++
public:
property CurtainGrid^ CurtainGrid {
    CurtainGrid^ get ();
}

Remarks

This property is readonly.

See Also

Wall Class
Autodesk.Revit.Elements Namespace


Flipped Property

[image]

Revit 2010 API
Wall..::.Flipped Property
Wall Class See Also Send Feedback
Property to test whether the wall orientation is flipped.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Flipped { get; }
Visual Basic (Declaration)
Public ReadOnly Property Flipped As Boolean
Visual C++
public:
property bool Flipped {
    bool get ();
}

See Also

Wall Class
Autodesk.Revit.Elements Namespace


Orientation Property

[image]

Revit 2010 API
Wall..::.Orientation Property
Wall Class See Also Send Feedback
Provides access to the wall's external face's orientation.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Orientation { get; }
Visual Basic (Declaration)
Public ReadOnly Property Orientation As XYZ
Visual C++
public:
property XYZ^ Orientation {
    XYZ^ get ();
}

Remarks

First get the start point of the wall's CurveDriver, then project it to the external face side,and return the normal on this point as orientation.

See Also

Wall Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Wall..::.Parameter Property
Wall Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Wall Class
Wall Members
Autodesk.Revit.Elements Namespace


StructuralUsage Property

[image]

Revit 2010 API
Wall..::.StructuralUsage Property
Wall Class See Also Send Feedback
The walls designated structural usage, such as bearing or non bearing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WallUsage StructuralUsage { get; set; }
Visual Basic (Declaration)
Public Property StructuralUsage As WallUsage
Visual C++
public:
property WallUsage StructuralUsage {
    WallUsage get ();
    void set (WallUsage value);
}

Remarks

The StructuralUsage property is a read only property that returns the walls designated usage. Example values of this property are Non Bearing, Bearing, Shear, Combined etc.

See Also

Wall Class
Autodesk.Revit.Elements Namespace


WallType Property

[image]

Revit 2010 API
Wall..::.WallType Property
Wall Class See Also Send Feedback
Retrieve or change the type of the wall.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WallType WallType { get; set; }
Visual Basic (Declaration)
Public Property WallType As WallType
Visual C++
public:
property WallType^ WallType {
    WallType^ get ();
    void set (WallType^ value);
}

Remarks

The WallType property can be used to retrieve the kind of the wall. This property can also be used to change the type of a wall by setting it to a different wall type. All the wall types in the project can be found using the Document.WallTypes property.

See Also

Wall Class
Autodesk.Revit.Elements Namespace


Width Property

[image]

Revit 2010 API
Wall..::.Width Property
Wall Class See Also Send Feedback
Returns the overall thickness of the wall.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Width { get; }
Visual Basic (Declaration)
Public ReadOnly Property Width As Double
Visual C++
public:
property double Width {
    double get ();
}

See Also

Wall Class
Autodesk.Revit.Elements Namespace


Zone Class

[image]

Revit 2010 API
Zone Class
Members See Also Send Feedback
Provides access to the Zone Element in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Zone : Element
Visual Basic (Declaration)
Public Class Zone _
    Inherits Element
Visual C++
public ref class Zone : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object is only available in Revit MEP.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Zone

See Also

Zone Members
Autodesk.Revit.Elements Namespace


Zone Members

[image] [image]

Revit 2010 API
Zone Members
Zone Class Constructors Methods Properties See Also Send Feedback

The Zone type exposes the following members.

Constructors

Name | Description
Zone | For Internal Use Only.

Methods

Name | Description
AddSpaces | Add a set of existing spaces to Zone element.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveSpaces | Remove a set of existing spaces to the current Zone element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Area | Get the Area of the Zone.
Boundary | Returns the boundary of the Zone.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CalculatedCoolingLoad | Get the Calculated Cooling Load of the Zone.
CalculatedHeatingLoad | Get the Calculated Heating Load of the Zone.
CalculatedSupplyAirflow | Get the Calculated Supply Airflow of the Zone.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoolingAirTemperature | Get or set the Cooling Air Temperature of the Zone.
CoolingSetPoint | Get or set the Cooling Set Point of the Zone.
DehumidificationSetPoint | Get or set the DeHumidification Set Point of the Zone.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GrossArea | Get the Gross Area of the Zone.
GrossVolume | Get the Gross Volume of the Zone.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HeatingAirTemperature | Get or set the Heating Air Temperature of the Zone.
HeatingSetPoint | Get or set the Heating Set Point of the Zone.
HumidificationSetPoint | Get or set the Humidification Set Point of the Zone.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultZone | Reports whether this zone is default or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get or Set the Name of the Zone. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
OutDoorAirPerArea | Get or set the OutDoor Air Per Area of the Zone.
OutDoorAirPerPerson | Get or set the OutDoor Air Per Person of the Zone.
OutdoorAirRatePerAirChangesPerHour | Get or set the Outdoor Air Rate Per Air Changes Per Hour of the Zone.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Perimeter | Get the Perimeter of the Zone.
Phase | Get the Phase of the Zone.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ServiceType | Get or set the Service Type of the Zone.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Spaces | Get the Spaces of the Zone.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Volume | Get the Volume of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


Zone Constructor

[image]

Revit 2010 API
Zone Constructor
Zone Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Zone()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Zone()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


Zone Methods

[image] [image]

Revit 2010 API
Zone Methods
Zone Class See Also Send Feedback

The Zone type exposes the following members.

Methods

Name | Description
AddSpaces | Add a set of existing spaces to Zone element.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveSpaces | Remove a set of existing spaces to the current Zone element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Zone Class
Autodesk.Revit.Elements Namespace


AddSpaces Method

[image]

Revit 2010 API
Zone..::.AddSpaces Method
Zone Class See Also Send Feedback
Add a set of existing spaces to Zone element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool AddSpaces(
    SpaceSet spaces
)
Visual Basic (Declaration)
Public Function AddSpaces ( _
    spaces As SpaceSet _
) As Boolean
Visual C++
public:
bool AddSpaces(
    SpaceSet^ spaces
)

Parameters

spaces
Type: Autodesk.Revit.Elements..::.SpaceSet
The spaces which want to add to zone element.

Return Value

If successful the current zone element will add a set of input spaces, otherwise Nothing.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter Value is null.
System..::.InvalidOperationException | Thrown when the input spaces cannot be added to current zone element.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


RemoveSpaces Method

[image]

Revit 2010 API
Zone..::.RemoveSpaces Method
Zone Class See Also Send Feedback
Remove a set of existing spaces to the current Zone element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool RemoveSpaces(
    SpaceSet spaces
)
Visual Basic (Declaration)
Public Function RemoveSpaces ( _
    spaces As SpaceSet _
) As Boolean
Visual C++
public:
bool RemoveSpaces(
    SpaceSet^ spaces
)

Parameters

spaces
Type: Autodesk.Revit.Elements..::.SpaceSet
The spaces which want to delete from the current zone element.

Return Value

If successful the current zone element will remove a set of input spaces, otherwise Nothing.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter Value is null.
System..::.InvalidOperationException | Thrown when the input spaces cannot be deleted from current zone element.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


Zone Properties

[image] [image]

Revit 2010 API
Zone Properties
Zone Class See Also Send Feedback

The Zone type exposes the following members.

Properties

Name | Description
Area | Get the Area of the Zone.
Boundary | Returns the boundary of the Zone.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CalculatedCoolingLoad | Get the Calculated Cooling Load of the Zone.
CalculatedHeatingLoad | Get the Calculated Heating Load of the Zone.
CalculatedSupplyAirflow | Get the Calculated Supply Airflow of the Zone.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoolingAirTemperature | Get or set the Cooling Air Temperature of the Zone.
CoolingSetPoint | Get or set the Cooling Set Point of the Zone.
DehumidificationSetPoint | Get or set the DeHumidification Set Point of the Zone.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GrossArea | Get the Gross Area of the Zone.
GrossVolume | Get the Gross Volume of the Zone.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HeatingAirTemperature | Get or set the Heating Air Temperature of the Zone.
HeatingSetPoint | Get or set the Heating Set Point of the Zone.
HumidificationSetPoint | Get or set the Humidification Set Point of the Zone.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultZone | Reports whether this zone is default or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get or Set the Name of the Zone. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
OutDoorAirPerArea | Get or set the OutDoor Air Per Area of the Zone.
OutDoorAirPerPerson | Get or set the OutDoor Air Per Person of the Zone.
OutdoorAirRatePerAirChangesPerHour | Get or set the Outdoor Air Rate Per Air Changes Per Hour of the Zone.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Perimeter | Get the Perimeter of the Zone.
Phase | Get the Phase of the Zone.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ServiceType | Get or set the Service Type of the Zone.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Spaces | Get the Spaces of the Zone.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Volume | Get the Volume of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


Area Property

[image]

Revit 2010 API
Zone..::.Area Property
Zone Class See Also Send Feedback
Get the Area of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Area { get; }
Visual Basic (Declaration)
Public ReadOnly Property Area As Double
Visual C++
public:
property double Area {
    double get ();
}

Remarks

This property is used to get the Area of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


Boundary Property

[image]

Revit 2010 API
Zone..::.Boundary Property
Zone Class See Also Send Feedback
Returns the boundary of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray Boundary { get; }
Visual Basic (Declaration)
Public ReadOnly Property Boundary As CurveArray
Visual C++
public:
property CurveArray^ Boundary {
    CurveArray^ get ();
}

Remarks

This property is used to retrieve the segments that constitute the boundary of the Zone. Each Zone may have several regions, each of which have several segments hence the data is returned in the form of an array of boundary segment arrays. See the Zone.BoundarySegment object for more details about the segments that make up the Zone topology.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


CalculatedCoolingLoad Property

[image]

Revit 2010 API
Zone..::.CalculatedCoolingLoad Property
Zone Class See Also Send Feedback
Get the Calculated Cooling Load of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double CalculatedCoolingLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property CalculatedCoolingLoad As Double
Visual C++
public:
property double CalculatedCoolingLoad {
    double get ();
}

Remarks

This property is used to get the Calculated Cooling Load of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


CalculatedHeatingLoad Property

[image]

Revit 2010 API
Zone..::.CalculatedHeatingLoad Property
Zone Class See Also Send Feedback
Get the Calculated Heating Load of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double CalculatedHeatingLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property CalculatedHeatingLoad As Double
Visual C++
public:
property double CalculatedHeatingLoad {
    double get ();
}

Remarks

This property is used to get the Calculated Heating Load of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


CalculatedSupplyAirflow Property

[image]

Revit 2010 API
Zone..::.CalculatedSupplyAirflow Property
Zone Class See Also Send Feedback
Get the Calculated Supply Airflow of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double CalculatedSupplyAirflow { get; }
Visual Basic (Declaration)
Public ReadOnly Property CalculatedSupplyAirflow As Double
Visual C++
public:
property double CalculatedSupplyAirflow {
    double get ();
}

Remarks

This property is used to get the Calculated Supply Airflow (Unit: Airflow ) of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


CoolingAirTemperature Property

[image]

Revit 2010 API
Zone..::.CoolingAirTemperature Property
Zone Class See Also Send Feedback
Get or set the Cooling Air Temperature of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double CoolingAirTemperature { get; set; }
Visual Basic (Declaration)
Public Property CoolingAirTemperature As Double
Visual C++
public:
property double CoolingAirTemperature {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Cooling Air Temperature of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


CoolingSetPoint Property

[image]

Revit 2010 API
Zone..::.CoolingSetPoint Property
Zone Class See Also Send Feedback
Get or set the Cooling Set Point of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double CoolingSetPoint { get; set; }
Visual Basic (Declaration)
Public Property CoolingSetPoint As Double
Visual C++
public:
property double CoolingSetPoint {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Cooling Set Point of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


DehumidificationSetPoint Property

[image]

Revit 2010 API
Zone..::.DehumidificationSetPoint Property
Zone Class See Also Send Feedback
Get or set the DeHumidification Set Point of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double DehumidificationSetPoint { get; set; }
Visual Basic (Declaration)
Public Property DehumidificationSetPoint As Double
Visual C++
public:
property double DehumidificationSetPoint {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the DeHumidification Set Point of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


GrossArea Property

[image]

Revit 2010 API
Zone..::.GrossArea Property
Zone Class See Also Send Feedback
Get the Gross Area of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double GrossArea { get; }
Visual Basic (Declaration)
Public ReadOnly Property GrossArea As Double
Visual C++
public:
property double GrossArea {
    double get ();
}

Remarks

This property is used to get the Gross Area of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


GrossVolume Property

[image]

Revit 2010 API
Zone..::.GrossVolume Property
Zone Class See Also Send Feedback
Get the Gross Volume of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double GrossVolume { get; }
Visual Basic (Declaration)
Public ReadOnly Property GrossVolume As Double
Visual C++
public:
property double GrossVolume {
    double get ();
}

Remarks

This property is used to get the Gross Volume of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


HeatingAirTemperature Property

[image]

Revit 2010 API
Zone..::.HeatingAirTemperature Property
Zone Class See Also Send Feedback
Get or set the Heating Air Temperature of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double HeatingAirTemperature { get; set; }
Visual Basic (Declaration)
Public Property HeatingAirTemperature As Double
Visual C++
public:
property double HeatingAirTemperature {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Heating Air Temperature of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


HeatingSetPoint Property

[image]

Revit 2010 API
Zone..::.HeatingSetPoint Property
Zone Class See Also Send Feedback
Get or set the Heating Set Point of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double HeatingSetPoint { get; set; }
Visual Basic (Declaration)
Public Property HeatingSetPoint As Double
Visual C++
public:
property double HeatingSetPoint {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Heating Set Point of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


HumidificationSetPoint Property

[image]

Revit 2010 API
Zone..::.HumidificationSetPoint Property
Zone Class See Also Send Feedback
Get or set the Humidification Set Point of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double HumidificationSetPoint { get; set; }
Visual Basic (Declaration)
Public Property HumidificationSetPoint As Double
Visual C++
public:
property double HumidificationSetPoint {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Humidification Set Point of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


IsDefaultZone Property

[image]

Revit 2010 API
Zone..::.IsDefaultZone Property
Zone Class See Also Send Feedback
Reports whether this zone is default or not.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsDefaultZone { get; set; }
Visual Basic (Declaration)
Public Property IsDefaultZone As Boolean
Visual C++
public:
property bool IsDefaultZone {
    bool get ();
    void set (bool value);
}

Remarks

This property can be used to set the current zone as the default zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


Name Property

[image]

Revit 2010 API
Zone..::.Name Property
Zone Class See Also Send Feedback
Get or Set the Name of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

This property is used to get or set the Name of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


OutDoorAirPerArea Property

[image]

Revit 2010 API
Zone..::.OutDoorAirPerArea Property
Zone Class See Also Send Feedback
Get or set the OutDoor Air Per Area of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double OutDoorAirPerArea { get; set; }
Visual Basic (Declaration)
Public Property OutDoorAirPerArea As Double
Visual C++
public:
property double OutDoorAirPerArea {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Out DoorAir Per Area of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


OutDoorAirPerPerson Property

[image]

Revit 2010 API
Zone..::.OutDoorAirPerPerson Property
Zone Class See Also Send Feedback
Get or set the OutDoor Air Per Person of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double OutDoorAirPerPerson { get; set; }
Visual Basic (Declaration)
Public Property OutDoorAirPerPerson As Double
Visual C++
public:
property double OutDoorAirPerPerson {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Out DoorAir Per Person of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


OutdoorAirRatePerAirChangesPerHour Property

[image]

Revit 2010 API
Zone..::.OutdoorAirRatePerAirChangesPerHour Property
Zone Class See Also Send Feedback
Get or set the Outdoor Air Rate Per Air Changes Per Hour of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double OutdoorAirRatePerAirChangesPerHour { get; set; }
Visual Basic (Declaration)
Public Property OutdoorAirRatePerAirChangesPerHour As Double
Visual C++
public:
property double OutdoorAirRatePerAirChangesPerHour {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Outdoor Air Rate Per Air Changes Per Hour of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


Parameter Property

[image] [image]

Revit 2010 API
Zone..::.Parameter Property
Zone Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Zone Class
Zone Members
Autodesk.Revit.Elements Namespace


Perimeter Property

[image]

Revit 2010 API
Zone..::.Perimeter Property
Zone Class See Also Send Feedback
Get the Perimeter of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Perimeter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Perimeter As Double
Visual C++
public:
property double Perimeter {
    double get ();
}

Remarks

This property is used to get the Perimeter of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


Phase Property

[image]

Revit 2010 API
Zone..::.Phase Property
Zone Class See Also Send Feedback
Get the Phase of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Phase Phase { get; }
Visual Basic (Declaration)
Public ReadOnly Property Phase As Phase
Visual C++
public:
property Phase^ Phase {
    Phase^ get ();
}

Remarks

This property is used to get the Phase of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


ServiceType Property

[image]

Revit 2010 API
Zone..::.ServiceType Property
Zone Class See Also Send Feedback
Get or set the Service Type of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ServiceType ServiceType { get; set; }
Visual Basic (Declaration)
Public Property ServiceType As ServiceType
Visual C++
public:
property ServiceType ServiceType {
    ServiceType get ();
    void set (ServiceType value);
}

Remarks

This property is used to get or set the Service Type of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


Spaces Property

[image]

Revit 2010 API
Zone..::.Spaces Property
Zone Class See Also Send Feedback
Get the Spaces of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpaceSet Spaces { get; }
Visual Basic (Declaration)
Public ReadOnly Property Spaces As SpaceSet
Visual C++
public:
property SpaceSet^ Spaces {
    SpaceSet^ get ();
}

Remarks

This property is used to get the Spaces of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


Volume Property

[image]

Revit 2010 API
Zone..::.Volume Property
Zone Class See Also Send Feedback
Get the Volume of the Zone.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Volume { get; }
Visual Basic (Declaration)
Public ReadOnly Property Volume As Double
Visual C++
public:
property double Volume {
    double get ();
}

Remarks

This property is used to get the Volume of the Zone.

See Also

Zone Class
Autodesk.Revit.Elements Namespace


Autodesk.Revit.Enums Namespace

[image]

Revit 2010 API
Autodesk.Revit.Enums Namespace
Send Feedback

Enumerations

Enumeration | Description
ACADVersion | An enumerate type listing available AutoCAD versions, into which a file may be exported.
AnalyzesAsType | This enum class is used for the BuiltInParameter STRUCTURAL_ANALYZES_AS.
AreaElemType | An enumerate type to store type of AreaElement.
AssetPropertyType | An enumerate to list AssetProperty Types in Revit.
AssetType | An enumerate to list Asset Types in Revit.
BeamSystemJustifyType | Describes the justify method of beamsystem.
BorderTile | Options for controlling tiles that overlap the face boundary. See DividedSurface.
BoxPlacement | An enumerate type listing possible placement of a box (an object of rectangular shape.)
ColorDepthType | An enumerate type listing all Color Depth types of Print Setting.
ComponentRotation | ComponentRotation property of DividedSurface. See DividedSurface.
CoordinatePlaneVisibility | Visibility settings for ReferencePoint element's coordinate reference planes.
CriteriaFilterType | An enumerate type listing all relationships between element's parameter value and the specified value. It is used in defining a criterion in element retrieval by criteria filter.
CurtainGridAlignType | An enumerate to list CurtainGrid patterns.
DecimalSymbolType | An enumerate type listing two types of the Decimal Symbol types that Autodesk Revit supports.
DigitGroupingAmount | An enumerate type listing the types of the Digit Grouping Amount that Autodesk Revit supports.
DigitGroupingSymbolType | An enumerate type listing the types of the Digit Grouping Symbol types that Autodesk Revit supports.
DimensionShape | An enumerate to list dimension type.
DisplayUnit | Describes the type of Revit display unit, metric or imperial.
DisplayUnitType | An enumerate type listing Display Unit types of the Unit types that Autodesk Revit supports.
DocumentType | Types of Revit documents.
DWFImageFormat | An enumerate type listing possible image format for DWF Export.
DWFImageQuality | An enumerate type listing possible image quality for DWF Export.
EaveCutterType | An enumerate type to store type of EaveCutter.
ElementReferenceType | Element reference types.
ExportPaperFormat | Paper formats supported by DWF export
ExportUnit | An enumerate type listing possible target units for CAD Export.
GridNodeLocation | Location of a grid node relative to the face boundary. See DividedSurface.
GridSegmentDirection | Specify one of the four adjacent segments to a GridNode. See DividedSurface.
HiddenLineViewsType | An enumerate type listing all Hidden Line Views types of Print Setting.
HorizontalAlign | Horizontal alignment of model text.
ImportColorMode | An enumerate type listing how colors are handled in an import process.
ImportExportFileFormat | Formats supported import / export
ImportPlacement | An enumerate type listing possible placement modes for imported drawings.
ImportUnit | An enumerate type listing possible target units for CAD Export.
LanguageType |
LeaderEndCondition | An enumerate type listing Leader End Condition which tie to the Independent Tag that Autodesk Revit supports.
LineScaling | An enumerate type listing possible LineType scaling modes.
MarginType | An enumerate type listing all Margin types of Print Setting.
MaterialBehaviourType | An enumerate type listing all the material behavior type.
PageOrientationType | An enumerate type listing all Page Orientation types of Print Setting.
PaperPlacementType | An enumerate type listing all Paper Placement types of Print Setting.
PostedErrorType | Describes the type of a posted error.
PrintRange | An enumerate type listing all Print Range types of Print.
ProductType | An enumerate to list Revit Product Type.
PropOverrideMode | An enumerate type listing ways how overridden object styles get exported.
RasterQualityType | An enumerate type listing all Raster Quality types of Print Setting.
ReferenceType | Reference types of curve element.
SetComparisonResult | An enumerate type listing all the relationship types between two sets of arbitrary nature.
SlabShapeCreaseType | An enumerate type listing all Crease types of Slab Shape Edit.
SlabShapeVertexType | An enumerate type listing all Vertex types of Slab Shape Edit.
SlantedOrVerticalColumnType | This enum class is used for the BuiltInParameter SLANTED_COLUMN_TYPE_PARAM.
SolidGeometry | An enumerate type listing possible ways of exporting solids in 3D views.
SpacingRuleJustification | Justification property of a spacing rule. See SpacingRule.
SpacingRuleLayout | Rules for laying out a series of equidistant parallel lines. See SpacingRule.
StickSymbolLocation | Indicates the stick symbol location on the UI, which is used for the BuiltInParameter STRUCTURAL_STICK_SYMBOL_LOCATION.
StructuralReleaseType | Type of structural release, which is used for the BuiltIn parameter STRUCTURAL_END_RELEASE_TYPE.
TagMode | An enumerate type listing Tag Mode when user adding tag that Autodesk Revit supports.
TagOrientation | An enumerate type listing Tag Orientation of the Independent Tag that Autodesk Revit supports.
TextAlignFlags | An enumerate type listing all the Text align flags.
TextAlignMask | An enumerate type listing all the Text align mask.
TextElementBackground | An enumerate type listing all the background mode for the built-in parameter TEXT_BACKGROUND.
TextNoteLeaderStyles | An enumerate type listing all the Leader styles.
TextNoteLeaderTypes | An enumerate type listing all the Leader types.
TilePatternsBuiltIn | Revit's built-in tile patterns. See TilePattern.
TrussCurveType | Types of curves created in truss families.
TrussMemberType | Indicates the "kind" of a truss member.
UnitGroup | An enumerate type listing Discipline of the Unit types that Autodesk Revit supports.
UnitSymbolType | An enumerate type listing Display Unit types of the Unit types that Autodesk Revit supports.
UnitType | An enumerate type listing all the Unit types that Autodesk Revit supports.
ViewType | An enumerate type listing available view types.)
VirtualPrinterType | An enumerate to list Virtual Printer Types in Revit.
WallFunction | Indicates the function of a specified WallType, which is used for the BuiltInParameter WALL_ATTR_EXTERIOR.
ZoomType | An enumerate type listing all Zoom types of Print Setting.


ACADVersion Enumeration

[image]

Revit 2010 API
ACADVersion Enumeration
See Also Send Feedback
An enumerate type listing available AutoCAD versions, into which a file may be exported.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ACADVersion
Visual Basic (Declaration)
Public Enumeration ACADVersion
Visual C++
public enum class ACADVersion

Members

Member name | Description
R2007 | AutoCAD 2007 file format.
R2004 | AutoCAD 2004 file format.
R2000 | AutoCAD 2000 file format.
Default | Revit Building application's default export format.

See Also

Autodesk.Revit.Enums Namespace


AnalyzesAsType Enumeration

[image]

Revit 2010 API
AnalyzesAsType Enumeration
See Also Send Feedback
This enum class is used for the BuiltInParameter STRUCTURAL_ANALYZES_AS.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum AnalyzesAsType
Visual Basic (Declaration)
Public Enumeration AnalyzesAsType
Visual C++
public enum class AnalyzesAsType

Members

Member name | Description
AA_Not_For_Analysis |
AA_SlabOnGrade |
AA_Mat |
AA_Slab |
AA_Lateral |
AA_Gravity |
AA_Hanger |

See Also

Autodesk.Revit.Enums Namespace


AreaElemType Enumeration

[image]

Revit 2010 API
AreaElemType Enumeration
See Also Send Feedback
An enumerate type to store type of AreaElement.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum AreaElemType
Visual Basic (Declaration)
Public Enumeration AreaElemType
Visual C++
public enum class AreaElemType

Members

Member name | Description
BOMAArea | Office Area Scheme - uses BOMA rules for space classification.
GrossArea | Gross Area Scheme - only 2 types of spaces (internal and external).

See Also

Autodesk.Revit.Enums Namespace


AssetPropertyType Enumeration

[image]

Revit 2010 API
AssetPropertyType Enumeration
See Also Send Feedback
An enumerate to list AssetProperty Types in Revit.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum AssetPropertyType
Visual Basic (Declaration)
Public Enumeration AssetPropertyType
Visual C++
public enum class AssetPropertyType

Members

Member name | Description
APT_Last |
APT_Reference |
APT_Asset |
APT_Distance |
APT_Time |
APT_String |
APT_Double44 | AssetPropertyDoubleMatrix44.
APT_DoubleArray4d | AssetPropertyDoubleArray4d.
APT_DoubleArray3d | AssetPropertyDoubleArray3d.
APT_DoubleArray2d | AssetPropertyDoubleArray2d.
APT_Double | AssetPropertyDouble.
APT_Float |
APT_Integer |
APT_Enum |
APT_Boolean |
APT_Properties |
APT_Unknown |

See Also

Autodesk.Revit.Enums Namespace


AssetType Enumeration

[image]

Revit 2010 API
AssetType Enumeration
See Also Send Feedback
An enumerate to list Asset Types in Revit.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum AssetType
Visual Basic (Declaration)
Public Enumeration AssetType
Visual C++
public enum class AssetType

Members

Member name | Description
Appearance |

See Also

Autodesk.Revit.Enums Namespace


BeamSystemJustifyType Enumeration

[image]

Revit 2010 API
BeamSystemJustifyType Enumeration
See Also Send Feedback
Describes the justify method of beamsystem.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum BeamSystemJustifyType
Visual Basic (Declaration)
Public Enumeration BeamSystemJustifyType
Visual C++
public enum class BeamSystemJustifyType

Members

Member name | Description
Beginning | Beginning.
Center | Center.
End | End.

See Also

Autodesk.Revit.Enums Namespace


BorderTile Enumeration

[image]

Revit 2010 API
BorderTile Enumeration
See Also Send Feedback
Options for controlling tiles that overlap the face boundary. See DividedSurface.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum BorderTile
Visual Basic (Declaration)
Public Enumeration BorderTile
Visual C++
public enum class BorderTile

Members

Member name | Description
Overhanging |
Partial |
Empty |

See Also

Autodesk.Revit.Enums Namespace


BoxPlacement Enumeration

[image]

Revit 2010 API
BoxPlacement Enumeration
See Also Send Feedback
An enumerate type listing possible placement of a box (an object of rectangular shape.)

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum BoxPlacement
Visual Basic (Declaration)
Public Enumeration BoxPlacement
Visual C++
public enum class BoxPlacement

Members

Member name | Description
BottomLeft | Placement of a box by its bottom left corner.
BottomRight | Placement of a box by its bottom right corner.
TopRight | Placement of a box by its top right corner.
TopLeft | Placement of a box by its top left corner.
Center | Placement of a box by its center point.

See Also

Autodesk.Revit.Enums Namespace


ColorDepthType Enumeration

[image]

Revit 2010 API
ColorDepthType Enumeration
See Also Send Feedback
An enumerate type listing all Color Depth types of Print Setting.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ColorDepthType
Visual Basic (Declaration)
Public Enumeration ColorDepthType
Visual C++
public enum class ColorDepthType

Members

Member name | Description
Color | The type of Color Depth is Color.
GrayScale | The type of Color Depth is Gray Scale.
BlackLine | The type of Color Depth is Black Line.

See Also

Autodesk.Revit.Enums Namespace


ComponentRotation Enumeration

[image]

Revit 2010 API
ComponentRotation Enumeration
See Also Send Feedback
ComponentRotation property of DividedSurface. See DividedSurface.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ComponentRotation
Visual Basic (Declaration)
Public Enumeration ComponentRotation
Visual C++
public enum class ComponentRotation

Members

Member name | Description
Angle270 |
Angle180 |
Angle90 |
Angle0 |

See Also

Autodesk.Revit.Enums Namespace


CoordinatePlaneVisibility Enumeration

[image]

Revit 2010 API
CoordinatePlaneVisibility Enumeration
See Also Send Feedback
Visibility settings for ReferencePoint element's coordinate reference planes.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum CoordinatePlaneVisibility
Visual Basic (Declaration)
Public Enumeration CoordinatePlaneVisibility
Visual C++
public enum class CoordinatePlaneVisibility

Members

Member name | Description
Always |
WhenSelected |
Never |

See Also

Autodesk.Revit.Enums Namespace


CriteriaFilterType Enumeration

[image]

Revit 2010 API
CriteriaFilterType Enumeration
See Also Send Feedback
An enumerate type listing all relationships between element's parameter value and the specified value. It is used in defining a criterion in element retrieval by criteria filter.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum CriteriaFilterType
Visual Basic (Declaration)
Public Enumeration CriteriaFilterType
Visual C++
public enum class CriteriaFilterType

Members

Member name | Description
EndsWith | The element's parameter value ends with the specified value.
DoesNotEndWith | The element's parameter value doesn't end with specified value.
DoesNotBeginWith | The element's parameter value doesn't begin with specified value.
BeginsWith | The element's parameter value begins with the specified value.
DoesNotContain | The element's parameter value doesn't contain the specified value.
LessThanOrEqual | The element's parameter value is less than or equal to the specified value.
LessThan | The element's parameter value is less than the specified value.
GreaterThanOrEqual | The element's parameter value is greater than or equal to the specified value.
GreaterThan | The element's parameter value is greater than the specified value.
NotEqual | The element's parameter value is not equal to the specified value.
Equal | The element's parameter value is equal to the specified value.
HasParam | The element has parameter.
Invalid | Invalid filter type.
Contains | The element's parameter value contains the specified value.

See Also

Autodesk.Revit.Enums Namespace


CurtainGridAlignType Enumeration

[image]

Revit 2010 API
CurtainGridAlignType Enumeration
See Also Send Feedback
An enumerate to list CurtainGrid patterns.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum CurtainGridAlignType
Visual Basic (Declaration)
Public Enumeration CurtainGridAlignType
Visual C++
public enum class CurtainGridAlignType

Members

Member name | Description
NoJustify | NoJustify.
Center | Center pattern of CurtainGrid.
Beginning | Beginning pattern of CurtainGrid.
End | End pattern of CurtainGrid.

See Also

Autodesk.Revit.Enums Namespace


DecimalSymbolType Enumeration

[image]

Revit 2010 API
DecimalSymbolType Enumeration
See Also Send Feedback
An enumerate type listing two types of the Decimal Symbol types that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum DecimalSymbolType
Visual Basic (Declaration)
Public Enumeration DecimalSymbolType
Visual C++
public enum class DecimalSymbolType

Members

Member name | Description
DST_COMMA |
DST_DOT |

See Also

Autodesk.Revit.Enums Namespace


DigitGroupingAmount Enumeration

[image]

Revit 2010 API
DigitGroupingAmount Enumeration
See Also Send Feedback
An enumerate type listing the types of the Digit Grouping Amount that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum DigitGroupingAmount
Visual Basic (Declaration)
Public Enumeration DigitGroupingAmount
Visual C++
public enum class DigitGroupingAmount

Members

Member name | Description
DGA_THREE |
DGA_TWO |

See Also

Autodesk.Revit.Enums Namespace


DigitGroupingSymbolType Enumeration

[image]

Revit 2010 API
DigitGroupingSymbolType Enumeration
See Also Send Feedback
An enumerate type listing the types of the Digit Grouping Symbol types that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum DigitGroupingSymbolType
Visual Basic (Declaration)
Public Enumeration DigitGroupingSymbolType
Visual C++
public enum class DigitGroupingSymbolType

Members

Member name | Description
DGST_TICK |
DGST_SPACE |
DGST_COMMA |
DGST_DOT |

See Also

Autodesk.Revit.Enums Namespace


DimensionShape Enumeration

[image]

Revit 2010 API
DimensionShape Enumeration
See Also Send Feedback
An enumerate to list dimension type.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum DimensionShape
Visual Basic (Declaration)
Public Enumeration DimensionShape
Visual C++
public enum class DimensionShape

Members

Member name | Description
Unknown | Unknown type dimension.
Spot | Spot dimension.
ArcLength | ArcLength dimension.
Radial | Radial dimension.
Angular | Angular dimension.
Linear | Linear dimension.

See Also

Autodesk.Revit.Enums Namespace


DisplayUnit Enumeration

[image]

Revit 2010 API
DisplayUnit Enumeration
See Also Send Feedback
Describes the type of Revit display unit, metric or imperial.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum DisplayUnit
Visual Basic (Declaration)
Public Enumeration DisplayUnit
Visual C++
public enum class DisplayUnit

Members

Member name | Description
IMPERIAL |
METRIC |

See Also

Autodesk.Revit.Enums Namespace


DisplayUnitType Enumeration

[image]

Revit 2010 API
DisplayUnitType Enumeration
See Also Send Feedback
An enumerate type listing Display Unit types of the Unit types that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum DisplayUnitType
Visual Basic (Declaration)
Public Enumeration DisplayUnitType
Visual C++
public enum class DisplayUnitType

Members

Member name | Description
DUT_SQUARE_FEET_PER_THOUSAND_BRITISH_THERMAL_UNITS_PER_HOUR |
DUT_LUMENS_PER_WATT |
DUT_CURRENCY |
DUT_SQUARE_METERS_PER_KILOWATTS |
DUT_SQUARE_FEET_PER_TON_OF_REFRIGERATION |
DUT_LITERS_PER_SECOND_KILOWATTS |
DUT_CUBIC_FEET_PER_MINUTE_TON_OF_REFRIGERATION |
DUT_LITERS_PER_SECOND_CUBIC_METER |
DUT_CUBIC_FEET_PER_MINUTE_CUBIC_FOOT |
DUT_TON_OF_REFRIGERATION |
DUT_BRITISH_THERMAL_UNITS_PER_HOUR_CUBIC_FOOT |
DUT_BRITISH_THERMAL_UNITS_PER_HOUR_SQUARE_FOOT |
DUT_WATTS_PER_CUBIC_METER |
DUT_WATTS_PER_CUBIC_FOOT |
DUT_RISE_OVER_MMS |
DUT_RISE_OVER_FOOT |
DUT_RISE_OVER_INCHES |
DUT_SLOPE_DEGREES |
DUT_RATIO_12 |
DUT_RATIO_10 |
DUT_LITERS_PER_SECOND_SQUARE_METER |
DUT_CUBIC_FEET_PER_MINUTE_SQUARE_FOOT |
DUT_BRITISH_THERMAL_UNITS_PER_HOUR_SQUARE_FOOT_FAHRENHEIT |
DUT_WATTS_PER_SQUARE_METER_KELVIN |
DUT_KILONEWTON_METERS_PER_DEGREE_PER_METER |
DUT_KIP_FEET_PER_DEGREE_PER_FOOT |
DUT_KILONEWTON_METERS_PER_DEGREE |
DUT_KIP_FEET_PER_DEGREE |
DUT_KIPS_PER_CUBIC_FOOT |
DUT_KIPS_PER_INCH |
DUT_POUNDS_MASS_PER_FOOT_HOUR |
DUT_POUND_FORCE_FEET_PER_FOOT |
DUT_TONNE_FORCE_METERS_PER_METER |
DUT_KILOGRAM_FORCE_METERS_PER_METER |
DUT_KIP_FEET_PER_FOOT |
DUT_MEGANEWTON_METERS_PER_METER |
DUT_KILONEWTON_METERS_PER_METER |
DUT_DECANEWTON_METERS_PER_METER |
DUT_NEWTON_METERS_PER_METER |
DUT_INV_CELSIUS |
DUT_INV_FAHRENHEIT |
DUT_KIPS_PER_CUBIC_INCH |
DUT_POUNDS_FORCE_PER_CUBIC_FOOT |
DUT_KILONEWTONS_PER_CUBIC_METER |
DUT_KIPS_PER_SQUARE_INCH |
DUT_FEET_PER_SECOND |
DUT_CENTIPOISES |
DUT_POUNDS_MASS_PER_FOOT_SECOND |
DUT_PASCAL_SECONDS |
DUT_FEET_OF_WATER |
DUT_FEET_OF_WATER_PER_100FT |
DUT_INV_KIPS |
DUT_INV_KILONEWTONS |
DUT_CUBIC_FEET_PER_KIP |
DUT_CUBIC_METERS_PER_KILONEWTON |
DUT_SQUARE_FEET_PER_KIP |
DUT_SQUARE_METERS_PER_KILONEWTON |
DUT_FEET_PER_KIP |
DUT_METERS_PER_KILONEWTON |
DUT_POUND_FORCE_FEET |
DUT_TONNE_FORCE_METERS |
DUT_KILOGRAM_FORCE_METERS |
DUT_KIP_FEET |
DUT_MEGANEWTON_METERS |
DUT_KILONEWTON_METERS |
DUT_DECANEWTON_METERS |
DUT_NEWTON_METERS |
DUT_POUNDS_FORCE_PER_SQUARE_FOOT |
DUT_TONNES_FORCE_PER_SQUARE_METER |
DUT_KILOGRAMS_FORCE_PER_SQUARE_METER |
DUT_KIPS_PER_SQUARE_FOOT |
DUT_MEGANEWTONS_PER_SQUARE_METER |
DUT_KILONEWTONS_PER_SQUARE_METER |
DUT_DECANEWTONS_PER_SQUARE_METER |
DUT_NEWTONS_PER_SQUARE_METER |
DUT_POUNDS_FORCE_PER_FOOT |
DUT_TONNES_FORCE_PER_METER |
DUT_KILOGRAMS_FORCE_PER_METER |
DUT_KIPS_PER_FOOT |
DUT_MEGANEWTONS_PER_METER |
DUT_KILONEWTONS_PER_METER |
DUT_DECANEWTONS_PER_METER |
DUT_NEWTONS_PER_METER |
DUT_POUNDS_FORCE |
DUT_TONNES_FORCE |
DUT_KILOGRAMS_FORCE |
DUT_KIPS |
DUT_MEGANEWTONS |
DUT_KILONEWTONS |
DUT_DECANEWTONS |
DUT_NEWTONS |
DUT_HORSEPOWER |
DUT_KILOVOLT_AMPERES |
DUT_VOLT_AMPERES |
DUT_LUMENS |
DUT_CANDLEPOWER |
DUT_CANDELAS |
DUT_CANDELAS_PER_SQUARE_METER |
DUT_FOOTLAMBERTS |
DUT_FOOTCANDLES |
DUT_LUX |
DUT_CYCLES_PER_SECOND |
DUT_HERTZ |
DUT_MILLIVOLTS |
DUT_KILOVOLTS |
DUT_VOLTS |
DUT_MILLIAMPERES |
DUT_KILOAMPERES |
DUT_AMPERES |
DUT_GALLONS_US_PER_HOUR |
DUT_GALLONS_US_PER_MINUTE |
DUT_CUBIC_METERS_PER_HOUR |
DUT_CUBIC_METERS_PER_SECOND |
DUT_LITERS_PER_SECOND |
DUT_CUBIC_FEET_PER_MINUTE |
DUT_CENTIMETERS_PER_MINUTE |
DUT_METERS_PER_SECOND |
DUT_FEET_PER_MINUTE |
DUT_RANKINE |
DUT_KELVIN |
DUT_CELSIUS |
DUT_FAHRENHEIT |
DUT_BARS |
DUT_ATMOSPHERES |
DUT_MILLIMETERS_OF_MERCURY |
DUT_INCHES_OF_MERCURY |
DUT_POUNDS_FORCE_PER_SQUARE_INCH |
DUT_MEGAPASCALS |
DUT_KILOPASCALS |
DUT_PASCALS |
DUT_INCHES_OF_WATER |
DUT_WATTS_PER_SQUARE_METER |
DUT_WATTS_PER_SQUARE_FOOT |
DUT_KILOCALORIES_PER_SECOND |
DUT_CALORIES_PER_SECOND |
DUT_BRITISH_THERMAL_UNITS_PER_HOUR |
DUT_BRITISH_THERMAL_UNITS_PER_SECOND |
DUT_KILOWATTS |
DUT_WATTS |
DUT_PASCALS_PER_METER |
DUT_INCHES_OF_WATER_PER_100FT |
DUT_THERMS |
DUT_KILOWATT_HOURS |
DUT_JOULES |
DUT_KILOCALORIES |
DUT_CALORIES |
DUT_BRITISH_THERMAL_UNITS |
DUT_POUNDS_MASS_PER_CUBIC_INCH |
DUT_POUNDS_MASS_PER_CUBIC_FOOT |
DUT_KILOGRAMS_PER_CUBIC_METER |
DUT_PERCENTAGE |
DUT_FIXED |
DUT_GENERAL |
DUT_DEGREES_AND_MINUTES |
DUT_DECIMAL_DEGREES |
DUT_GALLONS_US |
DUT_LITERS |
DUT_CUBIC_MILLIMETERS |
DUT_CUBIC_CENTIMETERS |
DUT_CUBIC_METERS |
DUT_CUBIC_INCHES |
DUT_CUBIC_FEET |
DUT_CUBIC_YARDS |
DUT_HECTARES |
DUT_ACRES |
DUT_SQUARE_MILLIMETERS |
DUT_SQUARE_CENTIMETERS |
DUT_SQUARE_METERS |
DUT_SQUARE_INCHES |
DUT_SQUARE_FEET |
DUT_METERS_CENTIMETERS |
DUT_DECIMAL_INCHES |
DUT_FRACTIONAL_INCHES |
DUT_FEET_FRACTIONAL_INCHES |
DUT_DECIMAL_FEET |
DUT_MILLIMETERS |
DUT_CENTIMETERS |
DUT_METERS |

See Also

Autodesk.Revit.Enums Namespace


DocumentType Enumeration

[image]

Revit 2010 API
DocumentType Enumeration
See Also Send Feedback
Types of Revit documents.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum DocumentType
Visual Basic (Declaration)
Public Enumeration DocumentType
Visual C++
public enum class DocumentType

Members

Member name | Description
Template |
Project |
Family |

See Also

Autodesk.Revit.Enums Namespace


DWFImageFormat Enumeration

[image]

Revit 2010 API
DWFImageFormat Enumeration
See Also Send Feedback
An enumerate type listing possible image format for DWF Export.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum DWFImageFormat
Visual Basic (Declaration)
Public Enumeration DWFImageFormat
Visual C++
public enum class DWFImageFormat

Members

Member name | Description
Lossy |
Lossless |

See Also

Autodesk.Revit.Enums Namespace


DWFImageQuality Enumeration

[image]

Revit 2010 API
DWFImageQuality Enumeration
See Also Send Feedback
An enumerate type listing possible image quality for DWF Export.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum DWFImageQuality
Visual Basic (Declaration)
Public Enumeration DWFImageQuality
Visual C++
public enum class DWFImageQuality

Members

Member name | Description
High |
Low |
Default |
Medium |

See Also

Autodesk.Revit.Enums Namespace


EaveCutterType Enumeration

[image]

Revit 2010 API
EaveCutterType Enumeration
See Also Send Feedback
An enumerate type to store type of EaveCutter.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum EaveCutterType
Visual Basic (Declaration)
Public Enumeration EaveCutterType
Visual C++
public enum class EaveCutterType

Members

Member name | Description
TwoCutSquare | Two Cut Square type of Eave.
TwoCutPlumb | Two Cut Plumb type of Eave.
PlumbCut | Plumb Cut type of Eave.

See Also

Autodesk.Revit.Enums Namespace


ElementReferenceType Enumeration

[image]

Revit 2010 API
ElementReferenceType Enumeration
See Also Send Feedback
Element reference types.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ElementReferenceType
Visual Basic (Declaration)
Public Enumeration ElementReferenceType
Visual C++
public enum class ElementReferenceType

Members

Member name | Description
REFERENCE_TYPE_MESH | The reference is to a mesh.
REFERENCE_TYPE_CUT_EDGE | The reference is to a face that was cut (where the original pick was made on the cut edge).
REFERENCE_TYPE_INSTANCE | The reference is an instance of a symbol.
REFERENCE_TYPE_FOREIGN | The reference is to geometry or elements in linked Revit file.
REFERENCE_TYPE_SURFACE | The reference is to a face or face region.
REFERENCE_TYPE_LINEAR | The reference is to a curve of edge.
REFERENCE_TYPE_NONE |

See Also

Autodesk.Revit.Enums Namespace


ExportPaperFormat Enumeration

[image]

Revit 2010 API
ExportPaperFormat Enumeration
See Also Send Feedback
Paper formats supported by DWF export

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ExportPaperFormat
Visual Basic (Declaration)
Public Enumeration ExportPaperFormat
Visual C++
public enum class ExportPaperFormat

Members

Member name | Description
ARCH_E3 | ARCH E3, 27 x 39 in
ARCH_E2 | ARCH E2, 26 x 38 in
ARCH_E1 | ARCH E1, 30 x 42 in
ARCH_E | ARCH E, 36 x 48 in
ARCH_D | ARCH D, 24 x 36 in
ARCH_C | ARCH C, 18 x 24 in
ARCH_B | ARCH B, 12 x 18 in
ARCH_A | ARCH A, 9 x 12 in
ISO_B1 | ISO B1, 707 x 1000 mm
ISO_B2 | ISO B2, 500 x 707 mm
ISO_B3 | ISO B3, 353 x 500 mm
ISO_B4 | ISO B4, 250 x 353 mm
ISO_A0 | ISO A0, 841 x 1189 mm
ISO_A1 | ISO A1, 594 x 841 mm
ISO_A2 | ISO A2, 420 x 594 mm
ISO_A3 | ISO A3, 297 x 420 mm
ISO_A4 | ISO A4, 210 x 297 mm
ANSI_E | ANSI E, 34 x 44 in
ANSI_D | ANSI D, 22 x 34 in
ANSI_C | ANSI C, 17 x 22 in
ANSI_B | ANSI B, 11 x 17 in
ANSI_A | ANSI A, 8.5 x 11 in
Default | Default paper format.

See Also

Autodesk.Revit.Enums Namespace


ExportUnit Enumeration

[image]

Revit 2010 API
ExportUnit Enumeration
See Also Send Feedback
An enumerate type listing possible target units for CAD Export.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ExportUnit
Visual Basic (Declaration)
Public Enumeration ExportUnit
Visual C++
public enum class ExportUnit

Members

Member name | Description
Meter | Meters as decimal values.
Centimeter | Centimeters as decimal values.
Millimeter | Millimeters as decimal values.
Foot | Feet and Inches in fractional notation.
Inch | Inches in fractional notation.
Default | Default export unit. Depends on Revit's current units.

See Also

Autodesk.Revit.Enums Namespace


GridNodeLocation Enumeration

[image]

Revit 2010 API
GridNodeLocation Enumeration
See Also Send Feedback
Location of a grid node relative to the face boundary. See DividedSurface.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum GridNodeLocation
Visual Basic (Declaration)
Public Enumeration GridNodeLocation
Visual C++
public enum class GridNodeLocation

Members

Member name | Description
Exterior |
Boundary |
Interior |

See Also

Autodesk.Revit.Enums Namespace


GridSegmentDirection Enumeration

[image]

Revit 2010 API
GridSegmentDirection Enumeration
See Also Send Feedback
Specify one of the four adjacent segments to a GridNode. See DividedSurface.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum GridSegmentDirection
Visual Basic (Declaration)
Public Enumeration GridSegmentDirection
Visual C++
public enum class GridSegmentDirection

Members

Member name | Description
NegativeV |
PositiveV |
NegativeU |
PositiveU |

See Also

Autodesk.Revit.Enums Namespace


HiddenLineViewsType Enumeration

[image]

Revit 2010 API
HiddenLineViewsType Enumeration
See Also Send Feedback
An enumerate type listing all Hidden Line Views types of Print Setting.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum HiddenLineViewsType
Visual Basic (Declaration)
Public Enumeration HiddenLineViewsType
Visual C++
public enum class HiddenLineViewsType

Members

Member name | Description
RasterProcessing | The type of Hidden Line Views is Raster Processing.
VectorProcessing | The type of Hidden Line Views is Vector Processing (fast).

See Also

Autodesk.Revit.Enums Namespace


HorizontalAlign Enumeration

[image]

Revit 2010 API
HorizontalAlign Enumeration
See Also Send Feedback
Horizontal alignment of model text.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum HorizontalAlign
Visual Basic (Declaration)
Public Enumeration HorizontalAlign
Visual C++
public enum class HorizontalAlign

Members

Member name | Description
Right |
Left |
Center |

See Also

Autodesk.Revit.Enums Namespace


ImportColorMode Enumeration

[image]

Revit 2010 API
ImportColorMode Enumeration
See Also Send Feedback
An enumerate type listing how colors are handled in an import process.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ImportColorMode
Visual Basic (Declaration)
Public Enumeration ImportColorMode
Visual C++
public enum class ImportColorMode

Members

Member name | Description
BlackAndWhite | Colors in the imported drawing are converted to Black and White.
Inverted | Colors in the imported drawing are inverted.
Preserved | Colors in the imported drawing are preserved.

See Also

Autodesk.Revit.Enums Namespace


ImportExportFileFormat Enumeration

[image]

Revit 2010 API
ImportExportFileFormat Enumeration
See Also Send Feedback
Formats supported import / export

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ImportExportFileFormat
Visual Basic (Declaration)
Public Enumeration ImportExportFileFormat
Visual C++
public enum class ImportExportFileFormat

Members

Member name | Description
Inventor |
Civil3D |
DGN |
FBX |
GBXML |
DWFX |
DWF |
DWG |
Image |

See Also

Autodesk.Revit.Enums Namespace


ImportPlacement Enumeration

[image]

Revit 2010 API
ImportPlacement Enumeration
See Also Send Feedback
An enumerate type listing possible placement modes for imported drawings.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ImportPlacement
Visual Basic (Declaration)
Public Enumeration ImportPlacement
Visual C++
public enum class ImportPlacement

Members

Member name | Description
Shared | Placement with respect to the shared coordinates.
Centered | Placement at the Center.
Origin | Placement at the Origin.

See Also

Autodesk.Revit.Enums Namespace


ImportUnit Enumeration

[image]

Revit 2010 API
ImportUnit Enumeration
See Also Send Feedback
An enumerate type listing possible target units for CAD Export.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ImportUnit
Visual Basic (Declaration)
Public Enumeration ImportUnit
Visual C++
public enum class ImportUnit

Members

Member name | Description
Meter | Meters as decimal values.
Decimeter | Centimeters as decimal values.
Centimeter | Centimeters as decimal values.
Millimeter | Millimeters as decimal values.
Foot | Feet and Inches in fractional notation.
Inch | Inches in fractional notation.
Default | Unit (if available) from the document that is getting imported.

See Also

Autodesk.Revit.Enums Namespace


LanguageType Enumeration

[image]

Revit 2010 API
LanguageType Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum LanguageType
Visual Basic (Declaration)
Public Enumeration LanguageType
Visual C++
public enum class LanguageType

Members

Member name | Description
Unknown | Unknown.
Russian | Russian.
Korean | Korean.
Japanese | Japanese.
Chinese_Traditional | Chinese Traditional.
Chinese_Simplified | Chinese Simplified.
Dutch | Dutch.
Italian | Italian.
French | French.
Spanish | Spanish.
German | German.
English_USA | English USA.

See Also

Autodesk.Revit.Enums Namespace


LeaderEndCondition Enumeration

[image]

Revit 2010 API
LeaderEndCondition Enumeration
See Also Send Feedback
An enumerate type listing Leader End Condition which tie to the Independent Tag that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum LeaderEndCondition
Visual Basic (Declaration)
Public Enumeration LeaderEndCondition
Visual C++
public enum class LeaderEndCondition

Members

Member name | Description
LEC_FREE | The Leader of the tag is free.
LEC_ATTACHED | The Leader of the tag is attached.

See Also

Autodesk.Revit.Enums Namespace


LineScaling Enumeration

[image]

Revit 2010 API
LineScaling Enumeration
See Also Send Feedback
An enumerate type listing possible LineType scaling modes.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum LineScaling
Visual Basic (Declaration)
Public Enumeration LineScaling
Visual C++
public enum class LineScaling

Members

Member name | Description
PaperSpace | Paperspace scaling. Specifies the value 1 for both LTSCALE and PSLTSCALE.
ModelSpace | Modelspace scaling. LTSCALE is set to view scale and PSLTSCALE to 0.
ViewScale | Exporting lines as they were scaled by view scale. This option preserves visual fidelity.

Remarks

Whichever option is chosen, line type definitions are created so a dashed line always begins and ends with a dash.

Using these options does change the default behavior of exported DWGs. Some lines expected to be dashed may appear solid or in a different scale.

See Also

Autodesk.Revit.Enums Namespace


MarginType Enumeration

[image]

Revit 2010 API
MarginType Enumeration
See Also Send Feedback
An enumerate type listing all Margin types of Print Setting.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum MarginType
Visual Basic (Declaration)
Public Enumeration MarginType
Visual C++
public enum class MarginType

Members

Member name | Description
UserDefined | The type of Margin is User Defined .
PrinterLimit | The type of Margin is Printer Limit.
NoMargin | The type of Margin is No Margin.

See Also

Autodesk.Revit.Enums Namespace


MaterialBehaviourType Enumeration

[image]

Revit 2010 API
MaterialBehaviourType Enumeration
See Also Send Feedback
An enumerate type listing all the material behavior type.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum MaterialBehaviourType
Visual Basic (Declaration)
Public Enumeration MaterialBehaviourType
Visual C++
public enum class MaterialBehaviourType

Members

Member name | Description
Undefined | Undefined material
Orthotropic | Orthotropic material
Isotropic | Isotropic material

See Also

Autodesk.Revit.Enums Namespace


PageOrientationType Enumeration

[image]

Revit 2010 API
PageOrientationType Enumeration
See Also Send Feedback
An enumerate type listing all Page Orientation types of Print Setting.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum PageOrientationType
Visual Basic (Declaration)
Public Enumeration PageOrientationType
Visual C++
public enum class PageOrientationType

Members

Member name | Description
Landscape | The type of Page Orientation is Landscape.
Portrait | The type of Page Orientation is Portrait.

See Also

Autodesk.Revit.Enums Namespace


PaperPlacementType Enumeration

[image]

Revit 2010 API
PaperPlacementType Enumeration
See Also Send Feedback
An enumerate type listing all Paper Placement types of Print Setting.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum PaperPlacementType
Visual Basic (Declaration)
Public Enumeration PaperPlacementType
Visual C++
public enum class PaperPlacementType

Members

Member name | Description
Margins | The type of Paper Placement is Margins.
Center | The type of Paper Placement is Center.

See Also

Autodesk.Revit.Enums Namespace


PostedErrorType Enumeration

[image]

Revit 2010 API
PostedErrorType Enumeration
See Also Send Feedback
Describes the type of a posted error.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum PostedErrorType
Visual Basic (Declaration)
Public Enumeration PostedErrorType
Visual C++
public enum class PostedErrorType

Members

Member name | Description
Fatal |
Error |
Warning |
Unknown |

See Also

Autodesk.Revit.Enums Namespace


PrintRange Enumeration

[image]

Revit 2010 API
PrintRange Enumeration
See Also Send Feedback
An enumerate type listing all Print Range types of Print.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum PrintRange
Visual Basic (Declaration)
Public Enumeration PrintRange
Visual C++
public enum class PrintRange

Members

Member name | Description
Visible | The type of Print Range is Visible.
Select | The type of Print Range is Select.
Current | The type of Print Range is Current.

See Also

Autodesk.Revit.Enums Namespace


ProductType Enumeration

[image]

Revit 2010 API
ProductType Enumeration
See Also Send Feedback
An enumerate to list Revit Product Type.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ProductType
Visual Basic (Declaration)
Public Enumeration ProductType
Visual C++
public enum class ProductType

Members

Member name | Description
Unknown | Unknown.
MEP | MEP.
Structure | Structure.
Architecture | Architecture.

See Also

Autodesk.Revit.Enums Namespace


PropOverrideMode Enumeration

[image]

Revit 2010 API
PropOverrideMode Enumeration
See Also Send Feedback
An enumerate type listing ways how overridden object styles get exported.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum PropOverrideMode
Visual Basic (Declaration)
Public Enumeration PropOverrideMode
Visual C++
public enum class PropOverrideMode

Members

Member name | Description
NewLayer | All properties BYLAYER, New Layers for overrides.
ByLayer | All properties BYLAYER, no overrides.
ByEntity | Category properties BYLAYER, overrides BYENTITY.

See Also

Autodesk.Revit.Enums Namespace


RasterQualityType Enumeration

[image]

Revit 2010 API
RasterQualityType Enumeration
See Also Send Feedback
An enumerate type listing all Raster Quality types of Print Setting.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum RasterQualityType
Visual Basic (Declaration)
Public Enumeration RasterQualityType
Visual C++
public enum class RasterQualityType

Members

Member name | Description
Presentation | The type of Raster Quality is Presentation.
High | The type of Raster Quality is High.
Low | The type of Raster Quality is Low.
Medium | The type of Raster Quality is Medium.

See Also

Autodesk.Revit.Enums Namespace


ReferenceType Enumeration

[image]

Revit 2010 API
ReferenceType Enumeration
See Also Send Feedback
Reference types of curve element.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ReferenceType
Visual Basic (Declaration)
Public Enumeration ReferenceType
Visual C++
public enum class ReferenceType

Members

Member name | Description
StrongReference |
None |
WeakReference |

See Also

Autodesk.Revit.Enums Namespace


SetComparisonResult Enumeration

[image]

Revit 2010 API
SetComparisonResult Enumeration
See Also Send Feedback
An enumerate type listing all the relationship types between two sets of arbitrary nature.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum SetComparisonResult
Visual Basic (Declaration)
Public Enumeration SetComparisonResult
Visual C++
public enum class SetComparisonResult

Members

Member name | Description
Equal | Two nonempty sets are equal.
Superset | Both sets are not empty and the left set is strict superset of the right.
Subset | Both sets are not empty and the left set is strict subset of the right.
Overlap | The overlap of two sets is not empty and strict subset of both.
Disjoint | Both sets are not empty and don't overlap.
BothEmpty | Both sets are empty.
RightEmpty | The right set is empty and the left set is not.
LeftEmpty | The left set is empty and the right set is not.

See Also

Autodesk.Revit.Enums Namespace


SlabShapeCreaseType Enumeration

[image]

Revit 2010 API
SlabShapeCreaseType Enumeration
See Also Send Feedback
An enumerate type listing all Crease types of Slab Shape Edit.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum SlabShapeCreaseType
Visual Basic (Declaration)
Public Enumeration SlabShapeCreaseType
Visual C++
public enum class SlabShapeCreaseType

Members

Member name | Description
Auto | The type of Crease is Auto.
UserDrawn | The type of Crease is UserDrawn.
Boundary | The type of Crease is Boundary.
Invalid | The type of Crease is Invalid.

See Also

Autodesk.Revit.Enums Namespace


SlabShapeVertexType Enumeration

[image]

Revit 2010 API
SlabShapeVertexType Enumeration
See Also Send Feedback
An enumerate type listing all Vertex types of Slab Shape Edit.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum SlabShapeVertexType
Visual Basic (Declaration)
Public Enumeration SlabShapeVertexType
Visual C++
public enum class SlabShapeVertexType

Members

Member name | Description
Interior | The type of Vertex is Interior.
Corner | The type of Vertex is Corner.
Invalid | The type of Vertex is Invalid.
Edge | The type of Vertex is Edge.

See Also

Autodesk.Revit.Enums Namespace


SlantedOrVerticalColumnType Enumeration

[image]

Revit 2010 API
SlantedOrVerticalColumnType Enumeration
See Also Send Feedback
This enum class is used for the BuiltInParameter SLANTED_COLUMN_TYPE_PARAM.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum SlantedOrVerticalColumnType
Visual Basic (Declaration)
Public Enumeration SlantedOrVerticalColumnType
Visual C++
public enum class SlantedOrVerticalColumnType

Members

Member name | Description
CT_EndPoint |
CT_Angle |
CT_Vertical |

See Also

Autodesk.Revit.Enums Namespace


SolidGeometry Enumeration

[image]

Revit 2010 API
SolidGeometry Enumeration
See Also Send Feedback
An enumerate type listing possible ways of exporting solids in 3D views.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum SolidGeometry
Visual Basic (Declaration)
Public Enumeration SolidGeometry
Visual C++
public enum class SolidGeometry

Members

Member name | Description
ACIS | All visible Revit Building geometry is exported as ACIS 3D solids (except for any elements that are already a polymesh.)
Polymesh | All visible solids are exported as polymesh.

See Also

Autodesk.Revit.Enums Namespace


SpacingRuleJustification Enumeration

[image]

Revit 2010 API
SpacingRuleJustification Enumeration
See Also Send Feedback
Justification property of a spacing rule. See SpacingRule.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum SpacingRuleJustification
Visual Basic (Declaration)
Public Enumeration SpacingRuleJustification
Visual C++
public enum class SpacingRuleJustification

Members

Member name | Description
Beginning |
Center |
End |

See Also

Autodesk.Revit.Enums Namespace


SpacingRuleLayout Enumeration

[image]

Revit 2010 API
SpacingRuleLayout Enumeration
See Also Send Feedback
Rules for laying out a series of equidistant parallel lines. See SpacingRule.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum SpacingRuleLayout
Visual Basic (Declaration)
Public Enumeration SpacingRuleLayout
Visual C++
public enum class SpacingRuleLayout

Members

Member name | Description
MinimumSpacing |
MaximumSpacing |
FixedNumber |
FixedDistance |
None |

See Also

Autodesk.Revit.Enums Namespace


StickSymbolLocation Enumeration

[image]

Revit 2010 API
StickSymbolLocation Enumeration
See Also Send Feedback
Indicates the stick symbol location on the UI, which is used for the BuiltInParameter STRUCTURAL_STICK_SYMBOL_LOCATION.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum StickSymbolLocation
Visual Basic (Declaration)
Public Enumeration StickSymbolLocation
Visual C++
public enum class StickSymbolLocation

Members

Member name | Description
StickViewLocLine |
StickViewBottom |
StickViewTop |
StickViewCenter |

See Also

Autodesk.Revit.Enums Namespace


StructuralReleaseType Enumeration

[image]

Revit 2010 API
StructuralReleaseType Enumeration
See Also Send Feedback
Type of structural release, which is used for the BuiltIn parameter STRUCTURAL_END_RELEASE_TYPE.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum StructuralReleaseType
Visual Basic (Declaration)
Public Enumeration StructuralReleaseType
Visual C++
public enum class StructuralReleaseType

Members

Member name | Description
kUserDefined |
kBendingMoment |
kPinned |
kFixed |

See Also

Autodesk.Revit.Enums Namespace


TagMode Enumeration

[image]

Revit 2010 API
TagMode Enumeration
See Also Send Feedback
An enumerate type listing Tag Mode when user adding tag that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum TagMode
Visual Basic (Declaration)
Public Enumeration TagMode
Visual C++
public enum class TagMode

Members

Member name | Description
TM_ADDBY_MATERIAL | The Tag you add by Material.
TM_ADDBY_MULTICATEGORY | The Tag you add by Multi-Category.
TM_ADDBY_CATEGORY | The Tag you add by Category.

See Also

Autodesk.Revit.Enums Namespace


TagOrientation Enumeration

[image]

Revit 2010 API
TagOrientation Enumeration
See Also Send Feedback
An enumerate type listing Tag Orientation of the Independent Tag that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum TagOrientation
Visual Basic (Declaration)
Public Enumeration TagOrientation
Visual C++
public enum class TagOrientation

Members

Member name | Description
TAG_VERTICAL | The Orientation of tag is Vertical.
TAG_HORIZONTAL | The Orientation of tag is Horizontal.

See Also

Autodesk.Revit.Enums Namespace


TextAlignFlags Enumeration

[image]

Revit 2010 API
TextAlignFlags Enumeration
See Also Send Feedback
An enumerate type listing all the Text align flags.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum TextAlignFlags
Visual Basic (Declaration)
Public Enumeration TextAlignFlags
Visual C++
public enum class TextAlignFlags

Members

Member name | Description
TEF_ALIGN_BOTTOM | Align text bottom
TEF_ALIGN_MIDDLE | Align text middle
TEF_ALIGN_TOP | Align text top
TEF_ALIGN_RIGHT | Align text right
TEF_ALIGN_CENTER | Align text cener
TEF_ALIGN_LEFT | Align text left

See Also

Autodesk.Revit.Enums Namespace


TextAlignMask Enumeration

[image]

Revit 2010 API
TextAlignMask Enumeration
See Also Send Feedback
An enumerate type listing all the Text align mask.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum TextAlignMask
Visual Basic (Declaration)
Public Enumeration TextAlignMask
Visual C++
public enum class TextAlignMask

Members

Member name | Description
vertAlignMask | The mask of the Text object being aligned in the vertical direction.
horzAlignMask | The mask of the Text object being aligned in the horizontal direction.

See Also

Autodesk.Revit.Enums Namespace


TextElementBackground Enumeration

[image]

Revit 2010 API
TextElementBackground Enumeration
See Also Send Feedback
An enumerate type listing all the background mode for the built-in parameter TEXT_BACKGROUND.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum TextElementBackground
Visual Basic (Declaration)
Public Enumeration TextElementBackground
Visual C++
public enum class TextElementBackground

Members

Member name | Description
TBGR_TRANSPARENT | The TextElement object is transparent.
TBGR_OPAQUE | The TextElement object is opaque.

See Also

Autodesk.Revit.Enums Namespace


TextNoteLeaderStyles Enumeration

[image]

Revit 2010 API
TextNoteLeaderStyles Enumeration
See Also Send Feedback
An enumerate type listing all the Leader styles.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum TextNoteLeaderStyles
Visual Basic (Declaration)
Public Enumeration TextNoteLeaderStyles
Visual C++
public enum class TextNoteLeaderStyles

Members

Member name | Description
LCS_TWO_SEG_LINE | The leader include two line segments.
LCS_ONE_SEG_ARC | The leader is an arc.
LCS_ONE_SEG_LINE | The leader only includes one line segment.
LCS_NONE | No leader.

See Also

Autodesk.Revit.Enums Namespace


TextNoteLeaderTypes Enumeration

[image]

Revit 2010 API
TextNoteLeaderTypes Enumeration
See Also Send Feedback
An enumerate type listing all the Leader types.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum TextNoteLeaderTypes
Visual Basic (Declaration)
Public Enumeration TextNoteLeaderTypes
Visual C++
public enum class TextNoteLeaderTypes

Members

Member name | Description
TNLT_ARC_R | The leader is put at the right of the Text object and in the arc style.
TNLT_ARC_L | The leader is put at the left of the Text object and in the arc style.
TNLT_STRAIGHT_R | The leader is put at the right of the Text object and in the straight style.
TNLT_STRAIGHT_L | The leader is put at the left of the Text object and in the straight style.

See Also

Autodesk.Revit.Enums Namespace


TilePatternsBuiltIn Enumeration

[image]

Revit 2010 API
TilePatternsBuiltIn Enumeration
See Also Send Feedback
Revit's built-in tile patterns. See TilePattern.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum TilePatternsBuiltIn
Visual Basic (Declaration)
Public Enumeration TilePatternsBuiltIn
Visual C++
public enum class TilePatternsBuiltIn

Members

Member name | Description
Rectangle |
OctagonRotate |
Octagon |
ZigZag |
Arrows |
TriangleStep |
RhomboidCheckerboard |
RectangleCheckerboard |
TriangleCheckerboard |
ThirdStep |
HalfStep |
Hexagon |
Rhomboid |
Triangle |

See Also

Autodesk.Revit.Enums Namespace


TrussCurveType Enumeration

[image]

Revit 2010 API
TrussCurveType Enumeration
See Also Send Feedback
Types of curves created in truss families.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum TrussCurveType
Visual Basic (Declaration)
Public Enumeration TrussCurveType
Visual C++
public enum class TrussCurveType

Members

Member name | Description
Web |
BottomChord |
TopChord |
NonTrussCurve |

See Also

Autodesk.Revit.Enums Namespace


TrussMemberType Enumeration

[image]

Revit 2010 API
TrussMemberType Enumeration
See Also Send Feedback
Indicates the "kind" of a truss member.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum TrussMemberType
Visual Basic (Declaration)
Public Enumeration TrussMemberType
Visual C++
public enum class TrussMemberType

Members

Member name | Description
ETK_TrussDiagWeb | Truss DiagWeb.
ETK_TrussVertWeb | Truss VertWeb.
ETK_TrussBottomChord | Truss bottom chord.
ETK_TrussTopChord | Truss top chord.
ETK_Unknown | Unknown element type.

See Also

Autodesk.Revit.Enums Namespace


UnitGroup Enumeration

[image]

Revit 2010 API
UnitGroup Enumeration
See Also Send Feedback
An enumerate type listing Discipline of the Unit types that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum UnitGroup
Visual Basic (Declaration)
Public Enumeration UnitGroup
Visual C++
public enum class UnitGroup

Members

Member name | Description
UG_Piping |
UG_Electrical |
UG_HVAC |
UG_Structural |
UG_Common |

See Also

Autodesk.Revit.Enums Namespace


UnitSymbolType Enumeration

[image]

Revit 2010 API
UnitSymbolType Enumeration
See Also Send Feedback
An enumerate type listing Display Unit types of the Unit types that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum UnitSymbolType
Visual Basic (Declaration)
Public Enumeration UnitSymbolType
Visual C++
public enum class UnitSymbolType

Members

Member name | Description
UST_SQ_FT_PER_KBTU_PER_H |
UST_SQ_FT_PER_MBH |
UST_SF_PER_KBTU_PER_H |
UST_SF_PER_MBH |
UST_LM_PER_W |
UST_KRONER |
UST_BAHT |
UST_DONG |
UST_SHEQEL |
UST_WON |
UST_CHINESE_HONG_KONG_SAR |
UST_YEN |
UST_POUND |
UST_EURO_PREFIX |
UST_EURO_SUFFIX |
UST_DOLLAR |
UST_SQ_M_PER_KW |
UST_SF_PER_TON |
UST_SQ_FT_PER_TON |
UST_L_PER_S_KW |
UST_CFM_PER_TON |
UST_L_PER_S_CU_M |
UST_CFM_PER_CF |
UST_CFM_PER_CU_FT |
UST_BTU_PER_H_CU_FT |
UST_WATT_PER_CU_M |
UST_WATT_PER_CU_FT |
UST_BTU_PER_H_SQ_FT |
UST_TON |
UST_SLOPE_DEGREE_SYMBOL |
UST_COLON_12 |
UST_COLON_10 |
UST_L_PER_S_SQ_M |
UST_LPS_PER_SQ_M |
UST_CFM_PER_SF |
UST_CFM_PER_SQ_FT |
UST_BTU_PER_H_SQ_FT_DEGREE_F |
UST_WATT_PER_SQ_M_K |
UST_K_N_M_PER_DEGREE_PER_M |
UST_K_N_M_PER_DEGREE |
UST_KIP_FT_PER_DEGREE_PER_FT |
UST_KIP_FT_PER_DEGREE |
UST_KIPS_PER_CU_FT |
UST_KIPS_PER_IN |
UST_INV_DEGREE_C |
UST_INV_DEGREE_F |
UST_KIP_PER_IN_SUP_3 |
UST_LBF_PER_CU_FT |
UST_LB_FORCE_PER_CU_FT |
UST_KN_PER_M_SUP_3 |
UST_KIP_PER_SQ_IN |
UST_KSI |
UST_LBM_PER_FT_H |
UST_LB_PER_FT_H |
UST_CP |
UST_LBM_PER_FT_S |
UST_LB_PER_FT_S |
UST_PA_S |
UST_FPS |
UST_FT_PER_S |
UST_FEET_OF_WATER |
UST_FT_OF_WATER |
UST_FTH2O |
UST_FEET_OF_WATER_PER_100FT |
UST_FT_OF_WATER_PER_100FT |
UST_FTH2O_PER_100FT |
UST_INV_KIP |
UST_INV_K_N |
UST_FT_SUP_3_PER_KIP |
UST_M_SUP_3_PER_K_N |
UST_FT_SUP_2_PER_KIP |
UST_M_SUP_2_PER_K_N |
UST_FT_PER_KIP |
UST_M_PER_K_N |
UST_LBF_DASH_FT_PER_FT |
UST_LB_DASH_FT_PER_FT |
UST_TF_DASH_M_PER_M |
UST_KGF_DASH_M_PER_M |
UST_KIP_DASH_FT_PER_FT |
UST_M_N_DASH_M_PER_M |
UST_K_N_DASH_M_PER_M |
UST_DA_N_DASH_M_PER_M |
UST_N_DASH_M_PER_M |
UST_LBF_DASH_FT |
UST_LB_DASH_FT |
UST_TF_DASH_M |
UST_KGF_DASH_M |
UST_KIP_DASH_FT |
UST_M_N_DASH_M |
UST_K_N_DASH_M |
UST_DA_N_DASH_M |
UST_N_DASH_M |
UST_LBF_PER_SQ_FT |
UST_LB_PER_SQ_FT |
UST_PSF |
UST_TF_PER_M_SUP_2 |
UST_KGF_PER_M_SUP_2 |
UST_KIP_PER_SQ_FT |
UST_KSF |
UST_M_N_PER_M_SUP_2 |
UST_K_N_PER_M_SUP_2 |
UST_DA_N_PER_M_SUP_2 |
UST_N_PER_M_SUP_2 |
UST_LBF_PER_FT |
UST_LB_PER_FT |
UST_TF_PER_M |
UST_KGF_PER_M |
UST_KIP_PER_FT |
UST_M_N_PER_M |
UST_K_N_PER_M |
UST_DA_N_PER_M |
UST_N_PER_M |
UST_LBF |
UST_LB |
UST_TF |
UST_KGF |
UST_KIP |
UST_M_N |
UST_K_N |
UST_DA_N |
UST_N |
UST_HP |
UST_KILOVOLTAMPERE |
UST_VOLTAMPERE |
UST_LM |
UST_CD |
UST_CD_PER_SQ_M |
UST_FTL |
UST_FL_LOWERCASE |
UST_FL |
UST_FTC |
UST_FC |
UST_LX |
UST_CPS |
UST_HZ |
UST_MILLIVOLT |
UST_KILOVOLT |
UST_VOLT |
UST_MILLIAMPERE |
UST_KILOAMPERE |
UST_AMPERE |
UST_USGPH |
UST_GPH |
UST_GAL_PER_H |
UST_USGPM |
UST_GPM |
UST_GAL_PER_MIN |
UST_CMH |
UST_CU_M_PER_H |
UST_CMS |
UST_CU_M_PER_S |
UST_LPS |
UST_L_PER_S |
UST_CFM |
UST_CU_FT_PER_MIN |
UST_CM_PER_MIN |
UST_M_PER_S |
UST_FPM |
UST_FT_PER_MIN |
UST_DEGREE_R |
UST_KELVIN |
UST_DEGREE_C |
UST_DEGREE_F |
UST_BAR |
UST_ATM |
UST_MM_HG |
UST_IN_HG |
UST_LBF_PER_SQ_IN |
UST_PSIA |
UST_PSIG |
UST_LB_PER_SQ_IN |
UST_PSI |
UST_MEGAPASCAL |
UST_KILOPASCAL |
UST_PASCAL |
UST_IN_WG |
UST_WATT_PER_SQ_M |
UST_WATT_PER_SQ_FT |
UST_KCAL_PER_S |
UST_CAL_PER_S |
UST_BTU_PER_H |
UST_BTU_PER_S |
UST_KILOWATT |
UST_WATT |
UST_PASCAL_PER_M |
UST_IN_WG_PER_100FT |
UST_THERM |
UST_KWH |
UST_JOULE |
UST_KCAL |
UST_CAL |
UST_BTU |
UST_LBM_PER_CU_IN |
UST_LB_PER_CU_IN |
UST_LBM_PER_CU_FT |
UST_LB_MASS_PER_CU_FT |
UST_KG_PER_CU_M |
UST_PERCENT_SIGN |
UST_DEGREE_SYMBOL |
UST_GAL |
UST_L |
UST_CY |
UST_MM_CARET_3 |
UST_MM_SUP_3 |
UST_CM_CARET_3 |
UST_CM_SUP_3 |
UST_M_CARET_3 |
UST_M_SUP_3 |
UST_IN_CARET_3 |
UST_IN_SUP_3 |
UST_FT_CARET_3 |
UST_FT_SUP_3 |
UST_CF |
UST_HECTARES |
UST_ACRES |
UST_MM_CARET_2 |
UST_MM_SUP_2 |
UST_CM_CARET_2 |
UST_CM_SUP_2 |
UST_M_CARET_2 |
UST_M_SUP_2 |
UST_IN_CARET_2 |
UST_IN_SUP_2 |
UST_FT_CARET_2 |
UST_FT_SUP_2 |
UST_SF |
UST_MM |
UST_CM |
UST_M |
UST_INCH_DOUBLE_QUOTE |
UST_FOOT_SINGLE_QUOTE |
UST_LF |
UST_NONE |

See Also

Autodesk.Revit.Enums Namespace


UnitType Enumeration

[image]

Revit 2010 API
UnitType Enumeration
See Also Send Feedback
An enumerate type listing all the Unit types that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum UnitType
Visual Basic (Declaration)
Public Enumeration UnitType
Visual C++
public enum class UnitType

Members

Member name | Description
UT_HVAC_Factor |
UT_HVAC_Area_Divided_By_Heating_Load |
UT_Electrical_Luminance |
UT_Electrical_Luminous_Intensity |
UT_DecSheetLength |
UT_Color_Temperature |
UT_Electrical_Wattage |
UT_Electrical_Efficacy |
UT_Currency |
UT_Piping_Slope |
UT_HVAC_Slope |
UT_WireSize |
UT_HVAC_Area_Divided_By_Cooling_Load |
UT_HVAC_Airflow_Divided_By_Cooling_Load |
UT_HVAC_Airflow_Divided_By_Volume |
UT_HVAC_Heating_Load_Divided_By_Volume |
UT_HVAC_Heating_Load_Divided_By_Area |
UT_HVAC_Heating_Load |
UT_HVAC_Cooling_Load_Divided_By_Volume |
UT_HVAC_Cooling_Load_Divided_By_Area |
UT_HVAC_Cooling_Load |
UT_Slope |
UT_HVAC_Airflow_Density |
UT_HVAC_CoefficientOfHeatTransfer |
UT_HVAC_Viscosity |
UT_Piping_Volume |
UT_AreaForcePerLength |
UT_LinearForceLengthPerAngle |
UT_LinearForcePerLength |
UT_ForceLengthPerAngle |
UT_ForcePerLength |
UT_LinearMomentScale |
UT_LinearMoment |
UT_TemperalExp |
UT_UnitWeight |
UT_Stress |
UT_Piping_Roughness |
UT_PipeSize |
UT_Piping_Viscosity |
UT_Piping_Velocity |
UT_Piping_Temperature |
UT_Piping_Pressure |
UT_Piping_Friction |
UT_Piping_Flow |
UT_Piping_Density |
UT_Electrical_Power_Density |
UT_Electrical_Apparent_Power |
UT_MomentScale |
UT_AreaForceScale |
UT_LinearForceScale |
UT_ForceScale |
UT_Moment |
UT_AreaForce |
UT_LinearForce |
UT_Force |
UT_HVAC_Roughness |
UT_Electrical_Power |
UT_Electrical_Luminous_Flux |
UT_Electrical_Illuminance |
UT_Electrical_Frequency |
UT_Electrical_Potential |
UT_Electrical_Current |
UT_HVAC_HeatGain |
UT_HVAC_CrossSection |
UT_HVAC_DuctSize |
UT_HVAC_Airflow |
UT_HVAC_Velocity |
UT_HVAC_Temperature |
UT_HVAC_Pressure |
UT_HVAC_Power_Density |
UT_HVAC_Power |
UT_HVAC_Friction |
UT_HVAC_Energy |
UT_HVAC_Density |
UT_SiteAngle |
UT_SheetLength |
UT_Number |
UT_Angle |
UT_Volume |
UT_Area |
UT_Length |

See Also

Autodesk.Revit.Enums Namespace


ViewType Enumeration

[image]

Revit 2010 API
ViewType Enumeration
See Also Send Feedback
An enumerate type listing available view types.)

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ViewType
Visual Basic (Declaration)
Public Enumeration ViewType
Visual C++
public enum class ViewType

Members

Member name | Description
Rendering | Rendering type of view.
Walkthrough | Walk-Through type of 3D view.
ColumnSchedule | Column Schedule type of view.
PanelSchedule | Panel Schedule Report view.
PresureLossReport | Presure Loss Report view.
LoadsReport | Loads Report view.
CostReport | Cost Report view.
Report | Report type of view.
Legend | Legend type of view.
DrawingSheet | Drawing sheet type of view.
DraftingView | Drafting type of view.
Schedule | Schedule type of view.
ThreeD | 3-D type of view.
Detail | Detail type of view.
Elevation | Elevation type of view.
CeilingPlan | Reflected ceiling plan type of view.
AreaPlan | Area plan type of view.
EngineeringPlan | Engineering Floor Plan type of view.
FloorPlan | Floor plan type of view.
Internal | Revit's internal type of view
Section | Cross section type of view.
Undefined | Undefined/unspecified type of view.

See Also

Autodesk.Revit.Enums Namespace


VirtualPrinterType Enumeration

[image]

Revit 2010 API
VirtualPrinterType Enumeration
See Also Send Feedback
An enumerate to list Virtual Printer Types in Revit.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum VirtualPrinterType
Visual Basic (Declaration)
Public Enumeration VirtualPrinterType
Visual C++
public enum class VirtualPrinterType

Members

Member name | Description
XPSWriter | Microsoft XPS Document Writer.
DWFWriter | DWFWriter.
AdobePDF | AdobePDF.
None | None.

See Also

Autodesk.Revit.Enums Namespace


WallFunction Enumeration

[image]

Revit 2010 API
WallFunction Enumeration
See Also Send Feedback
Indicates the function of a specified WallType, which is used for the BuiltInParameter WALL_ATTR_EXTERIOR.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum WallFunction
Visual Basic (Declaration)
Public Enumeration WallFunction
Visual C++
public enum class WallFunction

Members

Member name | Description
Soffit |
Retaining |
Foundation |
Exterior |
Interior |

See Also

Autodesk.Revit.Enums Namespace


ZoomType Enumeration

[image]

Revit 2010 API
ZoomType Enumeration
See Also Send Feedback
An enumerate type listing all Zoom types of Print Setting.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ZoomType
Visual Basic (Declaration)
Public Enumeration ZoomType
Visual C++
public enum class ZoomType

Members

Member name | Description
Zoom | The type of Zoom is user defined.
FitToPage | The type of Zoom is Fit To Page.

See Also

Autodesk.Revit.Enums Namespace


Autodesk.Revit.Events Namespace

[image]

Revit 2010 API
Autodesk.Revit.Events Namespace
Send Feedback

Classes

Class | Description
ApplicationClosingEventArgs | The event arguments used by the ApplicationClosing event.
DialogBoxData | An object that is passed to your application when a dialog is displayed in Revit.
DialogBoxShowingEventArgs | The base class for the event arguments used by the DialogBoxShowing event.
DocumentClosedEventArgs | The event arguments used by the DocumentClosed event.
DocumentClosingEventArgs | The event arguments used by the DocumentClosing event.
DocumentCreatedEventArgs | The event arguments used by the DocumentCreated event.
DocumentCreatingEventArgs | The event arguments used by the DocumentCreating event.
DocumentOpenedEventArgs | The event arguments used by the DocumentOpened event.
DocumentOpeningEventArgs | The event arguments used by the DocumentOpening event.
DocumentPrintedEventArgs | The event arguments used by the DocumentPrinted event.
DocumentPrintingEventArgs | The event arguments used by the DocumentPrinting event.
DocumentSavedAsEventArgs | The event arguments used by the DocumentSavedAs event.
DocumentSavedEventArgs | The event arguments used by the DocumentSaved event.
DocumentSavingAsEventArgs | The event arguments used by the DocumentSavingAs event.
DocumentSavingEventArgs | The event arguments used by the DocumentSaving event.
DocumentSynchronizedWithCentralEventArgs | The event arguments used by the DocumentSynchronizedWithCentral event.
DocumentSynchronizingWithCentralEventArgs | The event arguments used by the DocumentSynchronizingWithCentral event.
FileExportedEventArgs | The event arguments used by the FileExported event.
FileExportingEventArgs | The event arguments used by the FileExporting event.
FileImportedEventArgs | The event arguments used by the FileImported event.
FileImportingEventArgs | The event arguments used by the FileImporting event.
MessageBoxData | An object that represents a simple message box that prompts the user for some action.
MessageBoxShowingEventArgs | The event arguments used by the DialogBoxShowing event when a Windows message box is about to be displayed in Revit.
PostDocEventArgs | The class is used as base class for arguments of any post-event that is associated to a particular Document.
PostEventArgs | The class is used as a base class for arguments of any post-event.
PreDocEventArgs | The class is used as base class for the arguments of any pre-event arguments that is associated to a particular Document.
PreEventArgs | The class is used as a base class for the arguments for any pre-event.
RevitEventArgs | The class is used as base class for all event argument classes.
SynchronizeWithCentralOptions | Options for save to central.
TaskDialogShowingEventArgs | The event arguments used by the DialogBoxShowing event when a Revit task dialog that prompts the user for some action is shown.
ViewActivatedEventArgs | The event arguments used by the ViewActivated event.
ViewActivatingEventArgs | The event arguments used by the ViewActivating event.
ViewPrintedEventArgs | The event arguments used by ViewPrinted event.
ViewPrintingEventArgs | The event arguments used by the ViewPrinting event.

Interfaces

Interface | Description
ApplicationEvents | An interface that supports the events from the Revit Application object.
DocumentEvents | An interface that supports the events from the Autodesk Revit Document object.

Delegates

Delegate | Description
DialogBoxEventHandler | A handler for the event that is fired when a Revit dialog box is displayed during an external API command.
DocumentClosedEventHandler | A handler for the event that is fired after a document is closed.
DocumentCloseEventHandler | A handler for the event that is fired before the current document is closed.
DocumentNewedEventHandler | A handler for the event that is fired after a new document is created.
DocumentOpenedEventHandler | A handler for the event that is fired after a document is opened.
DocumentSaveAsEventHandler | A handler for the event that is fired before the current document is saved as a file with different file name.
DocumentSavedAsEventHandler | A handler for the event that is fired after a document is saved as a file with different file name.
DocumentSavedEventHandler | A handler for the event that is fired after a document is saved.
DocumentSaveEventHandler | A handler for the event that is fired before the current document is saved.

Enumerations

Enumeration | Description
EventStatus | Describes the status of an action which triggered a post event.


ApplicationClosingEventArgs Class

[image]

Revit 2010 API
ApplicationClosingEventArgs Class
Members See Also Send Feedback
The event arguments used by the ApplicationClosing event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ApplicationClosingEventArgs : PreEventArgs
Visual Basic (Declaration)
Public Class ApplicationClosingEventArgs _
    Inherits PreEventArgs
Visual C++
public ref class ApplicationClosingEventArgs : public PreEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.ApplicationClosingEventArgs

See Also

ApplicationClosingEventArgs Members
Autodesk.Revit.Events Namespace


ApplicationClosingEventArgs Members

[image] [image]

Revit 2010 API
ApplicationClosingEventArgs Members
ApplicationClosingEventArgs Class Constructors Methods Properties See Also Send Feedback

The ApplicationClosingEventArgs type exposes the following members.

Constructors

Name | Description
ApplicationClosingEventArgs | Initializes a new instance of the ApplicationClosingEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)

See Also

ApplicationClosingEventArgs Class
Autodesk.Revit.Events Namespace


ApplicationClosingEventArgs Constructor

[image]

Revit 2010 API
ApplicationClosingEventArgs Constructor
ApplicationClosingEventArgs Class See Also Send Feedback
Initializes a new instance of the ApplicationClosingEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ApplicationClosingEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ApplicationClosingEventArgs()

See Also

ApplicationClosingEventArgs Class
Autodesk.Revit.Events Namespace


ApplicationClosingEventArgs Methods

[image] [image]

Revit 2010 API
ApplicationClosingEventArgs Methods
ApplicationClosingEventArgs Class See Also Send Feedback

The ApplicationClosingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ApplicationClosingEventArgs Class
Autodesk.Revit.Events Namespace


ApplicationClosingEventArgs Properties

[image] [image]

Revit 2010 API
ApplicationClosingEventArgs Properties
ApplicationClosingEventArgs Class See Also Send Feedback

The ApplicationClosingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)

See Also

ApplicationClosingEventArgs Class
Autodesk.Revit.Events Namespace


ApplicationEvents Interface

[image]

Revit 2010 API
ApplicationEvents Interface
Members See Also Send Feedback
An interface that supports the events from the Revit Application object.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public interface ApplicationEvents
Visual Basic (Declaration)
Public Interface ApplicationEvents
Visual C++
public interface class ApplicationEvents

See Also

ApplicationEvents Members
Autodesk.Revit.Events Namespace


ApplicationEvents Members

[image] [image]

Revit 2010 API
ApplicationEvents Members
ApplicationEvents Interface Methods See Also Send Feedback

The ApplicationEvents type exposes the following members.

Methods

Name | Description
OnDialogBox | This event is fired whenever a Revit dialog box is displayed that requires user interaction during an external api command.
OnDocumentClosed | This event is fired after a document is closed.
OnDocumentNewed | This event is fired after a new document is created.
OnDocumentOpened | This event is fired after a document is opened.
OnDocumentSaved | This event is fired after a document is saved.
OnDocumentSavedAs | This event is fired after a document is saved as another file name.

See Also

ApplicationEvents Interface
Autodesk.Revit.Events Namespace


ApplicationEvents Methods

[image] [image]

Revit 2010 API
ApplicationEvents Methods
ApplicationEvents Interface See Also Send Feedback

The ApplicationEvents type exposes the following members.

Methods

Name | Description
OnDialogBox | This event is fired whenever a Revit dialog box is displayed that requires user interaction during an external api command.
OnDocumentClosed | This event is fired after a document is closed.
OnDocumentNewed | This event is fired after a new document is created.
OnDocumentOpened | This event is fired after a document is opened.
OnDocumentSaved | This event is fired after a document is saved.
OnDocumentSavedAs | This event is fired after a document is saved as another file name.

See Also

ApplicationEvents Interface
Autodesk.Revit.Events Namespace


OnDialogBox Method

[image]

Revit 2010 API
ApplicationEvents..::.OnDialogBox Method
ApplicationEvents Interface See Also Send Feedback
This event is fired whenever a Revit dialog box is displayed that requires user interaction during an external api command.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
void OnDialogBox(
    DialogBoxData dialogBoxData
)
Visual Basic (Declaration)
Sub OnDialogBox ( _
    dialogBoxData As DialogBoxData _
)
Visual C++
void OnDialogBox(
    DialogBoxData^ dialogBoxData
)

Parameters

dialogBoxData
Type: Autodesk.Revit.Events..::.DialogBoxData
An object that describes the dialog box.

See Also

ApplicationEvents Interface
Autodesk.Revit.Events Namespace


OnDocumentClosed Method

[image]

Revit 2010 API
ApplicationEvents..::.OnDocumentClosed Method
ApplicationEvents Interface See Also Send Feedback
This event is fired after a document is closed.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
void OnDocumentClosed(
    Document document
)
Visual Basic (Declaration)
Sub OnDocumentClosed ( _
    document As Document _
)
Visual C++
void OnDocumentClosed(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit..::.Document
The specified document.

See Also

ApplicationEvents Interface
Autodesk.Revit.Events Namespace


OnDocumentNewed Method

[image]

Revit 2010 API
ApplicationEvents..::.OnDocumentNewed Method
ApplicationEvents Interface See Also Send Feedback
This event is fired after a new document is created.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
void OnDocumentNewed(
    Document document
)
Visual Basic (Declaration)
Sub OnDocumentNewed ( _
    document As Document _
)
Visual C++
void OnDocumentNewed(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit..::.Document
The specified document.

See Also

ApplicationEvents Interface
Autodesk.Revit.Events Namespace


OnDocumentOpened Method

[image]

Revit 2010 API
ApplicationEvents..::.OnDocumentOpened Method
ApplicationEvents Interface See Also Send Feedback
This event is fired after a document is opened.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
void OnDocumentOpened(
    Document document
)
Visual Basic (Declaration)
Sub OnDocumentOpened ( _
    document As Document _
)
Visual C++
void OnDocumentOpened(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit..::.Document
The specified document.

See Also

ApplicationEvents Interface
Autodesk.Revit.Events Namespace


OnDocumentSaved Method

[image]

Revit 2010 API
ApplicationEvents..::.OnDocumentSaved Method
ApplicationEvents Interface See Also Send Feedback
This event is fired after a document is saved.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
void OnDocumentSaved(
    Document document
)
Visual Basic (Declaration)
Sub OnDocumentSaved ( _
    document As Document _
)
Visual C++
void OnDocumentSaved(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit..::.Document
The specified document.

See Also

ApplicationEvents Interface
Autodesk.Revit.Events Namespace


OnDocumentSavedAs Method

[image]

Revit 2010 API
ApplicationEvents..::.OnDocumentSavedAs Method
ApplicationEvents Interface See Also Send Feedback
This event is fired after a document is saved as another file name.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
void OnDocumentSavedAs(
    Document document
)
Visual Basic (Declaration)
Sub OnDocumentSavedAs ( _
    document As Document _
)
Visual C++
void OnDocumentSavedAs(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit..::.Document
The specified document.

See Also

ApplicationEvents Interface
Autodesk.Revit.Events Namespace


DialogBoxData Class

[image]

Revit 2010 API
DialogBoxData Class
Members See Also Send Feedback
An object that is passed to your application when a dialog is displayed in Revit.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DialogBoxData : APIObject
Visual Basic (Declaration)
Public Class DialogBoxData _
    Inherits APIObject
Visual C++
public ref class DialogBoxData : public APIObject

Remarks

When the application receives this object, a dialog has been displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Events..::.DialogBoxData
Autodesk.Revit.Events..::.MessageBoxData

See Also

DialogBoxData Members
Autodesk.Revit.Events Namespace


DialogBoxData Members

[image] [image]

Revit 2010 API
DialogBoxData Members
DialogBoxData Class Constructors Methods Properties See Also Send Feedback

The DialogBoxData type exposes the following members.

Constructors

Name | Description
DialogBoxData | Initializes a new instance of the DialogBoxData class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
HelpId | An ID that represents the dialog that has been displayed.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DialogBoxData Class
Autodesk.Revit.Events Namespace


DialogBoxData Constructor

[image]

Revit 2010 API
DialogBoxData Constructor
DialogBoxData Class See Also Send Feedback
Initializes a new instance of the DialogBoxData class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DialogBoxData()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DialogBoxData()

See Also

DialogBoxData Class
Autodesk.Revit.Events Namespace


DialogBoxData Methods

[image] [image]

Revit 2010 API
DialogBoxData Methods
DialogBoxData Class See Also Send Feedback

The DialogBoxData type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DialogBoxData Class
Autodesk.Revit.Events Namespace


OverrideResult Method

[image]

Revit 2010 API
DialogBoxData..::.OverrideResult Method
DialogBoxData Class See Also Send Feedback
Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool OverrideResult(
    int result
)
Visual Basic (Declaration)
Public Function OverrideResult ( _
    result As Integer _
) As Boolean
Visual C++
public:
bool OverrideResult(
    int result
)

Parameters

result
Type: System..::.Int32
The result code you wish the Revit dialog to return.

Return Value

Returns true if the result code was accepted.

See Also

DialogBoxData Class
Autodesk.Revit.Events Namespace


DialogBoxData Properties

[image] [image]

Revit 2010 API
DialogBoxData Properties
DialogBoxData Class See Also Send Feedback

The DialogBoxData type exposes the following members.

Properties

Name | Description
HelpId | An ID that represents the dialog that has been displayed.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DialogBoxData Class
Autodesk.Revit.Events Namespace


HelpId Property

[image]

Revit 2010 API
DialogBoxData..::.HelpId Property
DialogBoxData Class See Also Send Feedback
An ID that represents the dialog that has been displayed.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int HelpId { get; }
Visual Basic (Declaration)
Public ReadOnly Property HelpId As Integer
Visual C++
public:
property int HelpId {
    int get ();
}

Remarks

Use this ID within your application to key suitable responses for the dialog. Note: this id is not guaranteed to remain stable for different builds of Autodesk Revit.

See Also

DialogBoxData Class
Autodesk.Revit.Events Namespace


DialogBoxEventHandler Delegate

[image]

Revit 2010 API
DialogBoxEventHandler Delegate
See Also Send Feedback
A handler for the event that is fired when a Revit dialog box is displayed during an external API command.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public delegate void DialogBoxEventHandler(
    DialogBoxData dialogBoxData
)
Visual Basic (Declaration)
Public Delegate Sub DialogBoxEventHandler ( _
    dialogBoxData As DialogBoxData _
)
Visual C++
public delegate void DialogBoxEventHandler(
    DialogBoxData^ dialogBoxData
)

Parameters

dialogBoxData
Type: Autodesk.Revit.Events..::.DialogBoxData
An object that describes the dialog box

See Also

Autodesk.Revit.Events Namespace


DialogBoxShowingEventArgs Class

[image]

Revit 2010 API
DialogBoxShowingEventArgs Class
Members See Also Send Feedback
The base class for the event arguments used by the DialogBoxShowing event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DialogBoxShowingEventArgs : PreEventArgs
Visual Basic (Declaration)
Public Class DialogBoxShowingEventArgs _
    Inherits PreEventArgs
Visual C++
public ref class DialogBoxShowingEventArgs : public PreEventArgs

Remarks

The actual type of the event arguments will be different depending upon the type of dialog shown. When the application receives this object, a dialog is to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.DialogBoxShowingEventArgs
Autodesk.Revit.Events..::.MessageBoxShowingEventArgs
Autodesk.Revit.Events..::.TaskDialogShowingEventArgs

See Also

DialogBoxShowingEventArgs Members
Autodesk.Revit.Events Namespace


DialogBoxShowingEventArgs Members

[image] [image]

Revit 2010 API
DialogBoxShowingEventArgs Members
DialogBoxShowingEventArgs Class Constructors Methods Properties See Also Send Feedback

The DialogBoxShowingEventArgs type exposes the following members.

Constructors

Name | Description
DialogBoxShowingEventArgs | Initializes a new instance of the DialogBoxShowingEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
HelpId | An ID that represents the dialog that has been displayed.

See Also

DialogBoxShowingEventArgs Class
Autodesk.Revit.Events Namespace


DialogBoxShowingEventArgs Constructor

[image]

Revit 2010 API
DialogBoxShowingEventArgs Constructor
DialogBoxShowingEventArgs Class See Also Send Feedback
Initializes a new instance of the DialogBoxShowingEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DialogBoxShowingEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DialogBoxShowingEventArgs()

See Also

DialogBoxShowingEventArgs Class
Autodesk.Revit.Events Namespace


DialogBoxShowingEventArgs Methods

[image] [image]

Revit 2010 API
DialogBoxShowingEventArgs Methods
DialogBoxShowingEventArgs Class See Also Send Feedback

The DialogBoxShowingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DialogBoxShowingEventArgs Class
Autodesk.Revit.Events Namespace


OverrideResult Method

[image]

Revit 2010 API
DialogBoxShowingEventArgs..::.OverrideResult Method
DialogBoxShowingEventArgs Class See Also Send Feedback
Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool OverrideResult(
    int result
)
Visual Basic (Declaration)
Public Function OverrideResult ( _
    result As Integer _
) As Boolean
Visual C++
public:
bool OverrideResult(
    int result
)

Parameters

result
Type: System..::.Int32
The result code you wish the Revit dialog to return.

Return Value

Returns true if the result code was accepted.

Remarks

The range of valid result values depends on the type of dialog as follows:
  1. DialogBox: Any non-zero value will cause a dialog to be dismissed.
  2. MessageBox: Standard Message Box IDs, such as IDOK and IDCANCEL, are accepted. For all possible IDs, please refer to the Windows API documentation. Naturally, the ID used must be relevant to the buttons in a message box.
  3. TaskDialog: Either standard Message Box IDs or Revit Custom IDs are accepted depending on the buttons used in a dialog. Standard buttons, such as OK and Cancel, have standard IDs as described in Windows API documentation. Buttons with custom text have custom IDs with incremental values starting at 1001 for the left-most or top-most button in a task dialog.

See Also

DialogBoxShowingEventArgs Class
Autodesk.Revit.Events Namespace


DialogBoxShowingEventArgs Properties

[image] [image]

Revit 2010 API
DialogBoxShowingEventArgs Properties
DialogBoxShowingEventArgs Class See Also Send Feedback

The DialogBoxShowingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
HelpId | An ID that represents the dialog that has been displayed.

See Also

DialogBoxShowingEventArgs Class
Autodesk.Revit.Events Namespace


HelpId Property

[image]

Revit 2010 API
DialogBoxShowingEventArgs..::.HelpId Property
DialogBoxShowingEventArgs Class See Also Send Feedback
An ID that represents the dialog that has been displayed.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int HelpId { get; }
Visual Basic (Declaration)
Public ReadOnly Property HelpId As Integer
Visual C++
public:
property int HelpId {
    int get ();
}

Remarks

Use this ID within your application to key suitable responses for the dialog. Note: this id is not guaranteed to remain stable for different builds of Autodesk Revit.

See Also

DialogBoxShowingEventArgs Class
Autodesk.Revit.Events Namespace


DocumentClosedEventArgs Class

[image]

Revit 2010 API
DocumentClosedEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentClosed event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DocumentClosedEventArgs : PostEventArgs
Visual Basic (Declaration)
Public Class DocumentClosedEventArgs _
    Inherits PostEventArgs
Visual C++
public ref class DocumentClosedEventArgs : public PostEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PostEventArgs
Autodesk.Revit.Events..::.DocumentClosedEventArgs

See Also

DocumentClosedEventArgs Members
Autodesk.Revit.Events Namespace


DocumentClosedEventArgs Members

[image] [image]

Revit 2010 API
DocumentClosedEventArgs Members
DocumentClosedEventArgs Class Constructors Methods Properties See Also Send Feedback

The DocumentClosedEventArgs type exposes the following members.

Constructors

Name | Description
DocumentClosedEventArgs | Initializes a new instance of the DocumentClosedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DocumentId | Id of the document that has just been closed.
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentClosedEventArgs Class
Autodesk.Revit.Events Namespace


DocumentClosedEventArgs Constructor

[image]

Revit 2010 API
DocumentClosedEventArgs Constructor
DocumentClosedEventArgs Class See Also Send Feedback
Initializes a new instance of the DocumentClosedEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DocumentClosedEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentClosedEventArgs()

See Also

DocumentClosedEventArgs Class
Autodesk.Revit.Events Namespace


DocumentClosedEventArgs Methods

[image] [image]

Revit 2010 API
DocumentClosedEventArgs Methods
DocumentClosedEventArgs Class See Also Send Feedback

The DocumentClosedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentClosedEventArgs Class
Autodesk.Revit.Events Namespace


DocumentClosedEventArgs Properties

[image] [image]

Revit 2010 API
DocumentClosedEventArgs Properties
DocumentClosedEventArgs Class See Also Send Feedback

The DocumentClosedEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DocumentId | Id of the document that has just been closed.
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentClosedEventArgs Class
Autodesk.Revit.Events Namespace


DocumentId Property

[image]

Revit 2010 API
DocumentClosedEventArgs..::.DocumentId Property
DocumentClosedEventArgs Class See Also Send Feedback
Id of the document that has just been closed.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string DocumentId { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentId As String
Visual C++
public:
property String^ DocumentId {
    String^ get ();
}

Remarks

This Id is only used to identify the document for the duration of this event and the DocumentClosing event which preceded it.

See Also

DocumentClosedEventArgs Class
Autodesk.Revit.Events Namespace


DocumentClosedEventHandler Delegate

[image]

Revit 2010 API
DocumentClosedEventHandler Delegate
See Also Send Feedback
A handler for the event that is fired after a document is closed.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public delegate void DocumentClosedEventHandler(
    Document document
)
Visual Basic (Declaration)
Public Delegate Sub DocumentClosedEventHandler ( _
    document As Document _
)
Visual C++
public delegate void DocumentClosedEventHandler(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit..::.Document
The specified document.

See Also

Autodesk.Revit.Events Namespace


DocumentCloseEventHandler Delegate

[image]

Revit 2010 API
DocumentCloseEventHandler Delegate
See Also Send Feedback
A handler for the event that is fired before the current document is closed.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public delegate void DocumentCloseEventHandler()
Visual Basic (Declaration)
Public Delegate Sub DocumentCloseEventHandler
Visual C++
public delegate void DocumentCloseEventHandler()

See Also

Autodesk.Revit.Events Namespace


DocumentClosingEventArgs Class

[image]

Revit 2010 API
DocumentClosingEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentClosing event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DocumentClosingEventArgs : PreDocEventArgs
Visual Basic (Declaration)
Public Class DocumentClosingEventArgs _
    Inherits PreDocEventArgs
Visual C++
public ref class DocumentClosingEventArgs : public PreDocEventArgs

Remarks

This event is cancellable, except when it is raised when the Revit application is closing.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.PreDocEventArgs
Autodesk.Revit.Events..::.DocumentClosingEventArgs

See Also

DocumentClosingEventArgs Members
Autodesk.Revit.Events Namespace


DocumentClosingEventArgs Members

[image] [image]

Revit 2010 API
DocumentClosingEventArgs Members
DocumentClosingEventArgs Class Constructors Methods Properties See Also Send Feedback

The DocumentClosingEventArgs type exposes the following members.

Constructors

Name | Description
DocumentClosingEventArgs | Initializes a new instance of the DocumentClosingEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
DocumentId | Id of the document that is about to be closed.

See Also

DocumentClosingEventArgs Class
Autodesk.Revit.Events Namespace


DocumentClosingEventArgs Constructor

[image]

Revit 2010 API
DocumentClosingEventArgs Constructor
DocumentClosingEventArgs Class See Also Send Feedback
Initializes a new instance of the DocumentClosingEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DocumentClosingEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentClosingEventArgs()

See Also

DocumentClosingEventArgs Class
Autodesk.Revit.Events Namespace


DocumentClosingEventArgs Methods

[image] [image]

Revit 2010 API
DocumentClosingEventArgs Methods
DocumentClosingEventArgs Class See Also Send Feedback

The DocumentClosingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentClosingEventArgs Class
Autodesk.Revit.Events Namespace


DocumentClosingEventArgs Properties

[image] [image]

Revit 2010 API
DocumentClosingEventArgs Properties
DocumentClosingEventArgs Class See Also Send Feedback

The DocumentClosingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
DocumentId | Id of the document that is about to be closed.

See Also

DocumentClosingEventArgs Class
Autodesk.Revit.Events Namespace


DocumentId Property

[image]

Revit 2010 API
DocumentClosingEventArgs..::.DocumentId Property
DocumentClosingEventArgs Class See Also Send Feedback
Id of the document that is about to be closed.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string DocumentId { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentId As String
Visual C++
public:
property String^ DocumentId {
    String^ get ();
}

Remarks

This Id is only used to identify the document for the duration of this event and the DocumentClosed event which follows.

See Also

DocumentClosingEventArgs Class
Autodesk.Revit.Events Namespace


DocumentCreatedEventArgs Class

[image]

Revit 2010 API
DocumentCreatedEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentCreated event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DocumentCreatedEventArgs : PostDocEventArgs
Visual Basic (Declaration)
Public Class DocumentCreatedEventArgs _
    Inherits PostDocEventArgs
Visual C++
public ref class DocumentCreatedEventArgs : public PostDocEventArgs

Remarks

The newly created document is supplied in these arguments.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PostEventArgs
Autodesk.Revit.Events..::.PostDocEventArgs
Autodesk.Revit.Events..::.DocumentCreatedEventArgs

See Also

DocumentCreatedEventArgs Members
Autodesk.Revit.Events Namespace


DocumentCreatedEventArgs Members

[image] [image]

Revit 2010 API
DocumentCreatedEventArgs Members
DocumentCreatedEventArgs Class Constructors Methods Properties See Also Send Feedback

The DocumentCreatedEventArgs type exposes the following members.

Constructors

Name | Description
DocumentCreatedEventArgs | Initializes a new instance of the DocumentCreatedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentCreatedEventArgs Class
Autodesk.Revit.Events Namespace


DocumentCreatedEventArgs Constructor

[image]

Revit 2010 API
DocumentCreatedEventArgs Constructor
DocumentCreatedEventArgs Class See Also Send Feedback
Initializes a new instance of the DocumentCreatedEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DocumentCreatedEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentCreatedEventArgs()

See Also

DocumentCreatedEventArgs Class
Autodesk.Revit.Events Namespace


DocumentCreatedEventArgs Methods

[image] [image]

Revit 2010 API
DocumentCreatedEventArgs Methods
DocumentCreatedEventArgs Class See Also Send Feedback

The DocumentCreatedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentCreatedEventArgs Class
Autodesk.Revit.Events Namespace


DocumentCreatedEventArgs Properties

[image] [image]

Revit 2010 API
DocumentCreatedEventArgs Properties
DocumentCreatedEventArgs Class See Also Send Feedback

The DocumentCreatedEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentCreatedEventArgs Class
Autodesk.Revit.Events Namespace


DocumentCreatingEventArgs Class

[image]

Revit 2010 API
DocumentCreatingEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentCreating event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DocumentCreatingEventArgs : PreEventArgs
Visual Basic (Declaration)
Public Class DocumentCreatingEventArgs _
    Inherits PreEventArgs
Visual C++
public ref class DocumentCreatingEventArgs : public PreEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.DocumentCreatingEventArgs

See Also

DocumentCreatingEventArgs Members
Autodesk.Revit.Events Namespace


DocumentCreatingEventArgs Members

[image] [image]

Revit 2010 API
DocumentCreatingEventArgs Members
DocumentCreatingEventArgs Class Constructors Methods Properties See Also Send Feedback

The DocumentCreatingEventArgs type exposes the following members.

Constructors

Name | Description
DocumentCreatingEventArgs | Initializes a new instance of the DocumentCreatingEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DocumentType | Type of the document which is about to be created, e.g. Project or Template.
Template | The template file path to be used for creating the new document.

See Also

DocumentCreatingEventArgs Class
Autodesk.Revit.Events Namespace


DocumentCreatingEventArgs Constructor

[image]

Revit 2010 API
DocumentCreatingEventArgs Constructor
DocumentCreatingEventArgs Class See Also Send Feedback
Initializes a new instance of the DocumentCreatingEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DocumentCreatingEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentCreatingEventArgs()

See Also

DocumentCreatingEventArgs Class
Autodesk.Revit.Events Namespace


DocumentCreatingEventArgs Methods

[image] [image]

Revit 2010 API
DocumentCreatingEventArgs Methods
DocumentCreatingEventArgs Class See Also Send Feedback

The DocumentCreatingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentCreatingEventArgs Class
Autodesk.Revit.Events Namespace


DocumentCreatingEventArgs Properties

[image] [image]

Revit 2010 API
DocumentCreatingEventArgs Properties
DocumentCreatingEventArgs Class See Also Send Feedback

The DocumentCreatingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DocumentType | Type of the document which is about to be created, e.g. Project or Template.
Template | The template file path to be used for creating the new document.

See Also

DocumentCreatingEventArgs Class
Autodesk.Revit.Events Namespace


DocumentType Property

[image]

Revit 2010 API
DocumentCreatingEventArgs..::.DocumentType Property
DocumentCreatingEventArgs Class See Also Send Feedback
Type of the document which is about to be created, e.g. Project or Template.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DocumentType DocumentType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentType As DocumentType
Visual C++
public:
property DocumentType DocumentType {
    DocumentType get ();
}

See Also

DocumentCreatingEventArgs Class
Autodesk.Revit.Events Namespace


Template Property

[image]

Revit 2010 API
DocumentCreatingEventArgs..::.Template Property
DocumentCreatingEventArgs Class See Also Send Feedback
The template file path to be used for creating the new document.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Template { get; }
Visual Basic (Declaration)
Public ReadOnly Property Template As String
Visual C++
public:
property String^ Template {
    String^ get ();
}

See Also

DocumentCreatingEventArgs Class
Autodesk.Revit.Events Namespace


DocumentEvents Interface

[image]

Revit 2010 API
DocumentEvents Interface
Members See Also Send Feedback
An interface that supports the events from the Autodesk Revit Document object.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public interface DocumentEvents
Visual Basic (Declaration)
Public Interface DocumentEvents
Visual C++
public interface class DocumentEvents

See Also

DocumentEvents Members
Autodesk.Revit.Events Namespace


DocumentEvents Members

[image] [image]

Revit 2010 API
DocumentEvents Members
DocumentEvents Interface Methods See Also Send Feedback

The DocumentEvents type exposes the following members.

Methods

Name | Description
OnClose | This event is fired before the current document is closed.
OnSave | This event is fired before the current document is saved.
OnSaveAs | This event is fired before the current document is saved as another file.

See Also

DocumentEvents Interface
Autodesk.Revit.Events Namespace


DocumentEvents Methods

[image] [image]

Revit 2010 API
DocumentEvents Methods
DocumentEvents Interface See Also Send Feedback

The DocumentEvents type exposes the following members.

Methods

Name | Description
OnClose | This event is fired before the current document is closed.
OnSave | This event is fired before the current document is saved.
OnSaveAs | This event is fired before the current document is saved as another file.

See Also

DocumentEvents Interface
Autodesk.Revit.Events Namespace


OnClose Method

[image]

Revit 2010 API
DocumentEvents..::.OnClose Method
DocumentEvents Interface See Also Send Feedback
This event is fired before the current document is closed.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
void OnClose()
Visual Basic (Declaration)
Sub OnClose
Visual C++
void OnClose()

See Also

DocumentEvents Interface
Autodesk.Revit.Events Namespace


OnSave Method

[image]

Revit 2010 API
DocumentEvents..::.OnSave Method
DocumentEvents Interface See Also Send Feedback
This event is fired before the current document is saved.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
void OnSave()
Visual Basic (Declaration)
Sub OnSave
Visual C++
void OnSave()

See Also

DocumentEvents Interface
Autodesk.Revit.Events Namespace


OnSaveAs Method

[image]

Revit 2010 API
DocumentEvents..::.OnSaveAs Method
DocumentEvents Interface See Also Send Feedback
This event is fired before the current document is saved as another file.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
void OnSaveAs()
Visual Basic (Declaration)
Sub OnSaveAs
Visual C++
void OnSaveAs()

See Also

DocumentEvents Interface
Autodesk.Revit.Events Namespace


DocumentNewedEventHandler Delegate

[image]

Revit 2010 API
DocumentNewedEventHandler Delegate
See Also Send Feedback
A handler for the event that is fired after a new document is created.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public delegate void DocumentNewedEventHandler(
    Document document
)
Visual Basic (Declaration)
Public Delegate Sub DocumentNewedEventHandler ( _
    document As Document _
)
Visual C++
public delegate void DocumentNewedEventHandler(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit..::.Document
The specified document.

See Also

Autodesk.Revit.Events Namespace


DocumentOpenedEventArgs Class

[image]

Revit 2010 API
DocumentOpenedEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentOpened event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DocumentOpenedEventArgs : PostDocEventArgs
Visual Basic (Declaration)
Public Class DocumentOpenedEventArgs _
    Inherits PostDocEventArgs
Visual C++
public ref class DocumentOpenedEventArgs : public PostDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PostEventArgs
Autodesk.Revit.Events..::.PostDocEventArgs
Autodesk.Revit.Events..::.DocumentOpenedEventArgs

See Also

DocumentOpenedEventArgs Members
Autodesk.Revit.Events Namespace


DocumentOpenedEventArgs Members

[image] [image]

Revit 2010 API
DocumentOpenedEventArgs Members
DocumentOpenedEventArgs Class Constructors Methods Properties See Also Send Feedback

The DocumentOpenedEventArgs type exposes the following members.

Constructors

Name | Description
DocumentOpenedEventArgs | Initializes a new instance of the DocumentOpenedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentOpenedEventArgs Class
Autodesk.Revit.Events Namespace


DocumentOpenedEventArgs Constructor

[image]

Revit 2010 API
DocumentOpenedEventArgs Constructor
DocumentOpenedEventArgs Class See Also Send Feedback
Initializes a new instance of the DocumentOpenedEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DocumentOpenedEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentOpenedEventArgs()

See Also

DocumentOpenedEventArgs Class
Autodesk.Revit.Events Namespace


DocumentOpenedEventArgs Methods

[image] [image]

Revit 2010 API
DocumentOpenedEventArgs Methods
DocumentOpenedEventArgs Class See Also Send Feedback

The DocumentOpenedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentOpenedEventArgs Class
Autodesk.Revit.Events Namespace


DocumentOpenedEventArgs Properties

[image] [image]

Revit 2010 API
DocumentOpenedEventArgs Properties
DocumentOpenedEventArgs Class See Also Send Feedback

The DocumentOpenedEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentOpenedEventArgs Class
Autodesk.Revit.Events Namespace


DocumentOpenedEventHandler Delegate

[image]

Revit 2010 API
DocumentOpenedEventHandler Delegate
See Also Send Feedback
A handler for the event that is fired after a document is opened.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public delegate void DocumentOpenedEventHandler(
    Document document
)
Visual Basic (Declaration)
Public Delegate Sub DocumentOpenedEventHandler ( _
    document As Document _
)
Visual C++
public delegate void DocumentOpenedEventHandler(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit..::.Document
The specified document.

See Also

Autodesk.Revit.Events Namespace


DocumentOpeningEventArgs Class

[image]

Revit 2010 API
DocumentOpeningEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentOpening event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DocumentOpeningEventArgs : PreEventArgs
Visual Basic (Declaration)
Public Class DocumentOpeningEventArgs _
    Inherits PreEventArgs
Visual C++
public ref class DocumentOpeningEventArgs : public PreEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.DocumentOpeningEventArgs

See Also

DocumentOpeningEventArgs Members
Autodesk.Revit.Events Namespace


DocumentOpeningEventArgs Members

[image] [image]

Revit 2010 API
DocumentOpeningEventArgs Members
DocumentOpeningEventArgs Class Constructors Methods Properties See Also Send Feedback

The DocumentOpeningEventArgs type exposes the following members.

Constructors

Name | Description
DocumentOpeningEventArgs | Initializes a new instance of the DocumentOpeningEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DocumentType | Type of the document, e.g. Project or Template.
PathName | Path of the document to be opened.

See Also

DocumentOpeningEventArgs Class
Autodesk.Revit.Events Namespace


DocumentOpeningEventArgs Constructor

[image]

Revit 2010 API
DocumentOpeningEventArgs Constructor
DocumentOpeningEventArgs Class See Also Send Feedback
Initializes a new instance of the DocumentOpeningEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DocumentOpeningEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentOpeningEventArgs()

See Also

DocumentOpeningEventArgs Class
Autodesk.Revit.Events Namespace


DocumentOpeningEventArgs Methods

[image] [image]

Revit 2010 API
DocumentOpeningEventArgs Methods
DocumentOpeningEventArgs Class See Also Send Feedback

The DocumentOpeningEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentOpeningEventArgs Class
Autodesk.Revit.Events Namespace


DocumentOpeningEventArgs Properties

[image] [image]

Revit 2010 API
DocumentOpeningEventArgs Properties
DocumentOpeningEventArgs Class See Also Send Feedback

The DocumentOpeningEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DocumentType | Type of the document, e.g. Project or Template.
PathName | Path of the document to be opened.

See Also

DocumentOpeningEventArgs Class
Autodesk.Revit.Events Namespace


DocumentType Property

[image]

Revit 2010 API
DocumentOpeningEventArgs..::.DocumentType Property
DocumentOpeningEventArgs Class See Also Send Feedback
Type of the document, e.g. Project or Template.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DocumentType DocumentType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentType As DocumentType
Visual C++
public:
property DocumentType DocumentType {
    DocumentType get ();
}

See Also

DocumentOpeningEventArgs Class
Autodesk.Revit.Events Namespace


PathName Property

[image]

Revit 2010 API
DocumentOpeningEventArgs..::.PathName Property
DocumentOpeningEventArgs Class See Also Send Feedback
Path of the document to be opened.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string PathName { get; }
Visual Basic (Declaration)
Public ReadOnly Property PathName As String
Visual C++
public:
property String^ PathName {
    String^ get ();
}

See Also

DocumentOpeningEventArgs Class
Autodesk.Revit.Events Namespace


DocumentPrintedEventArgs Class

[image]

Revit 2010 API
DocumentPrintedEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentPrinted event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DocumentPrintedEventArgs : PostDocEventArgs
Visual Basic (Declaration)
Public Class DocumentPrintedEventArgs _
    Inherits PostDocEventArgs
Visual C++
public ref class DocumentPrintedEventArgs : public PostDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PostEventArgs
Autodesk.Revit.Events..::.PostDocEventArgs
Autodesk.Revit.Events..::.DocumentPrintedEventArgs

See Also

DocumentPrintedEventArgs Members
Autodesk.Revit.Events Namespace


DocumentPrintedEventArgs Members

[image] [image]

Revit 2010 API
DocumentPrintedEventArgs Members
DocumentPrintedEventArgs Class Constructors Methods Properties See Also Send Feedback

The DocumentPrintedEventArgs type exposes the following members.

Constructors

Name | Description
DocumentPrintedEventArgs | Initializes a new instance of the DocumentPrintedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
FailedViews | Views that failed to print (if any).
PrintedViews | Views that printed successfully.
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentPrintedEventArgs Class
Autodesk.Revit.Events Namespace


DocumentPrintedEventArgs Constructor

[image]

Revit 2010 API
DocumentPrintedEventArgs Constructor
DocumentPrintedEventArgs Class See Also Send Feedback
Initializes a new instance of the DocumentPrintedEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DocumentPrintedEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentPrintedEventArgs()

See Also

DocumentPrintedEventArgs Class
Autodesk.Revit.Events Namespace


DocumentPrintedEventArgs Methods

[image] [image]

Revit 2010 API
DocumentPrintedEventArgs Methods
DocumentPrintedEventArgs Class See Also Send Feedback

The DocumentPrintedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentPrintedEventArgs Class
Autodesk.Revit.Events Namespace


DocumentPrintedEventArgs Properties

[image] [image]

Revit 2010 API
DocumentPrintedEventArgs Properties
DocumentPrintedEventArgs Class See Also Send Feedback

The DocumentPrintedEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
FailedViews | Views that failed to print (if any).
PrintedViews | Views that printed successfully.
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentPrintedEventArgs Class
Autodesk.Revit.Events Namespace


FailedViews Property

[image]

Revit 2010 API
DocumentPrintedEventArgs..::.FailedViews Property
DocumentPrintedEventArgs Class See Also Send Feedback
Views that failed to print (if any).

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSet FailedViews { get; }
Visual Basic (Declaration)
Public ReadOnly Property FailedViews As ViewSet
Visual C++
public:
property ViewSet^ FailedViews {
    ViewSet^ get ();
}

See Also

DocumentPrintedEventArgs Class
Autodesk.Revit.Events Namespace


PrintedViews Property

[image]

Revit 2010 API
DocumentPrintedEventArgs..::.PrintedViews Property
DocumentPrintedEventArgs Class See Also Send Feedback
Views that printed successfully.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSet PrintedViews { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintedViews As ViewSet
Visual C++
public:
property ViewSet^ PrintedViews {
    ViewSet^ get ();
}

See Also

DocumentPrintedEventArgs Class
Autodesk.Revit.Events Namespace


DocumentPrintingEventArgs Class

[image]

Revit 2010 API
DocumentPrintingEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentPrinting event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DocumentPrintingEventArgs : PreDocEventArgs
Visual Basic (Declaration)
Public Class DocumentPrintingEventArgs _
    Inherits PreDocEventArgs
Visual C++
public ref class DocumentPrintingEventArgs : public PreDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.PreDocEventArgs
Autodesk.Revit.Events..::.DocumentPrintingEventArgs

See Also

DocumentPrintingEventArgs Members
Autodesk.Revit.Events Namespace


DocumentPrintingEventArgs Members

[image] [image]

Revit 2010 API
DocumentPrintingEventArgs Members
DocumentPrintingEventArgs Class Constructors Methods Properties See Also Send Feedback

The DocumentPrintingEventArgs type exposes the following members.

Constructors

Name | Description
DocumentPrintingEventArgs | Initializes a new instance of the DocumentPrintingEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Settings | Print Settings of current project.
Views | Set of views to be printed.

See Also

DocumentPrintingEventArgs Class
Autodesk.Revit.Events Namespace


DocumentPrintingEventArgs Constructor

[image]

Revit 2010 API
DocumentPrintingEventArgs Constructor
DocumentPrintingEventArgs Class See Also Send Feedback
Initializes a new instance of the DocumentPrintingEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DocumentPrintingEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentPrintingEventArgs()

See Also

DocumentPrintingEventArgs Class
Autodesk.Revit.Events Namespace


DocumentPrintingEventArgs Methods

[image] [image]

Revit 2010 API
DocumentPrintingEventArgs Methods
DocumentPrintingEventArgs Class See Also Send Feedback

The DocumentPrintingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentPrintingEventArgs Class
Autodesk.Revit.Events Namespace


DocumentPrintingEventArgs Properties

[image] [image]

Revit 2010 API
DocumentPrintingEventArgs Properties
DocumentPrintingEventArgs Class See Also Send Feedback

The DocumentPrintingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Settings | Print Settings of current project.
Views | Set of views to be printed.

See Also

DocumentPrintingEventArgs Class
Autodesk.Revit.Events Namespace


Settings Property

[image]

Revit 2010 API
DocumentPrintingEventArgs..::.Settings Property
DocumentPrintingEventArgs Class See Also Send Feedback
Print Settings of current project.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PrintSetting Settings { get; }
Visual Basic (Declaration)
Public ReadOnly Property Settings As PrintSetting
Visual C++
public:
property PrintSetting^ Settings {
    PrintSetting^ get ();
}

See Also

DocumentPrintingEventArgs Class
Autodesk.Revit.Events Namespace


Views Property

[image]

Revit 2010 API
DocumentPrintingEventArgs..::.Views Property
DocumentPrintingEventArgs Class See Also Send Feedback
Set of views to be printed.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSet Views { get; }
Visual Basic (Declaration)
Public ReadOnly Property Views As ViewSet
Visual C++
public:
property ViewSet^ Views {
    ViewSet^ get ();
}

See Also

DocumentPrintingEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSaveAsEventHandler Delegate

[image]

Revit 2010 API
DocumentSaveAsEventHandler Delegate
See Also Send Feedback
A handler for the event that is fired before the current document is saved as a file with different file name.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public delegate void DocumentSaveAsEventHandler()
Visual Basic (Declaration)
Public Delegate Sub DocumentSaveAsEventHandler
Visual C++
public delegate void DocumentSaveAsEventHandler()

See Also

Autodesk.Revit.Events Namespace


DocumentSavedAsEventArgs Class

[image]

Revit 2010 API
DocumentSavedAsEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentSavedAs event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DocumentSavedAsEventArgs : PostDocEventArgs
Visual Basic (Declaration)
Public Class DocumentSavedAsEventArgs _
    Inherits PostDocEventArgs
Visual C++
public ref class DocumentSavedAsEventArgs : public PostDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PostEventArgs
Autodesk.Revit.Events..::.PostDocEventArgs
Autodesk.Revit.Events..::.DocumentSavedAsEventArgs

See Also

DocumentSavedAsEventArgs Members
Autodesk.Revit.Events Namespace


DocumentSavedAsEventArgs Members

[image] [image]

Revit 2010 API
DocumentSavedAsEventArgs Members
DocumentSavedAsEventArgs Class Constructors Methods Properties See Also Send Feedback

The DocumentSavedAsEventArgs type exposes the following members.

Constructors

Name | Description
DocumentSavedAsEventArgs | Initializes a new instance of the DocumentSavedAsEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
OriginalPath | Original path of the document.
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentSavedAsEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSavedAsEventArgs Constructor

[image]

Revit 2010 API
DocumentSavedAsEventArgs Constructor
DocumentSavedAsEventArgs Class See Also Send Feedback
Initializes a new instance of the DocumentSavedAsEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DocumentSavedAsEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentSavedAsEventArgs()

See Also

DocumentSavedAsEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSavedAsEventArgs Methods

[image] [image]

Revit 2010 API
DocumentSavedAsEventArgs Methods
DocumentSavedAsEventArgs Class See Also Send Feedback

The DocumentSavedAsEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSavedAsEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSavedAsEventArgs Properties

[image] [image]

Revit 2010 API
DocumentSavedAsEventArgs Properties
DocumentSavedAsEventArgs Class See Also Send Feedback

The DocumentSavedAsEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
OriginalPath | Original path of the document.
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentSavedAsEventArgs Class
Autodesk.Revit.Events Namespace


OriginalPath Property

[image]

Revit 2010 API
DocumentSavedAsEventArgs..::.OriginalPath Property
DocumentSavedAsEventArgs Class See Also Send Feedback
Original path of the document.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string OriginalPath { get; }
Visual Basic (Declaration)
Public ReadOnly Property OriginalPath As String
Visual C++
public:
property String^ OriginalPath {
    String^ get ();
}

See Also

DocumentSavedAsEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSavedAsEventHandler Delegate

[image]

Revit 2010 API
DocumentSavedAsEventHandler Delegate
See Also Send Feedback
A handler for the event that is fired after a document is saved as a file with different file name.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public delegate void DocumentSavedAsEventHandler(
    Document document
)
Visual Basic (Declaration)
Public Delegate Sub DocumentSavedAsEventHandler ( _
    document As Document _
)
Visual C++
public delegate void DocumentSavedAsEventHandler(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit..::.Document
The specified document.

See Also

Autodesk.Revit.Events Namespace


DocumentSavedEventArgs Class

[image]

Revit 2010 API
DocumentSavedEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentSaved event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DocumentSavedEventArgs : PostDocEventArgs
Visual Basic (Declaration)
Public Class DocumentSavedEventArgs _
    Inherits PostDocEventArgs
Visual C++
public ref class DocumentSavedEventArgs : public PostDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PostEventArgs
Autodesk.Revit.Events..::.PostDocEventArgs
Autodesk.Revit.Events..::.DocumentSavedEventArgs

See Also

DocumentSavedEventArgs Members
Autodesk.Revit.Events Namespace


DocumentSavedEventArgs Members

[image] [image]

Revit 2010 API
DocumentSavedEventArgs Members
DocumentSavedEventArgs Class Constructors Methods Properties See Also Send Feedback

The DocumentSavedEventArgs type exposes the following members.

Constructors

Name | Description
DocumentSavedEventArgs | Initializes a new instance of the DocumentSavedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentSavedEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSavedEventArgs Constructor

[image]

Revit 2010 API
DocumentSavedEventArgs Constructor
DocumentSavedEventArgs Class See Also Send Feedback
Initializes a new instance of the DocumentSavedEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DocumentSavedEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentSavedEventArgs()

See Also

DocumentSavedEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSavedEventArgs Methods

[image] [image]

Revit 2010 API
DocumentSavedEventArgs Methods
DocumentSavedEventArgs Class See Also Send Feedback

The DocumentSavedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSavedEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSavedEventArgs Properties

[image] [image]

Revit 2010 API
DocumentSavedEventArgs Properties
DocumentSavedEventArgs Class See Also Send Feedback

The DocumentSavedEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentSavedEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSavedEventHandler Delegate

[image]

Revit 2010 API
DocumentSavedEventHandler Delegate
See Also Send Feedback
A handler for the event that is fired after a document is saved.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public delegate void DocumentSavedEventHandler(
    Document document
)
Visual Basic (Declaration)
Public Delegate Sub DocumentSavedEventHandler ( _
    document As Document _
)
Visual C++
public delegate void DocumentSavedEventHandler(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit..::.Document
The specified document.

See Also

Autodesk.Revit.Events Namespace


DocumentSaveEventHandler Delegate

[image]

Revit 2010 API
DocumentSaveEventHandler Delegate
See Also Send Feedback
A handler for the event that is fired before the current document is saved.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public delegate void DocumentSaveEventHandler()
Visual Basic (Declaration)
Public Delegate Sub DocumentSaveEventHandler
Visual C++
public delegate void DocumentSaveEventHandler()

See Also

Autodesk.Revit.Events Namespace


DocumentSavingAsEventArgs Class

[image]

Revit 2010 API
DocumentSavingAsEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentSavingAs event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DocumentSavingAsEventArgs : PreDocEventArgs
Visual Basic (Declaration)
Public Class DocumentSavingAsEventArgs _
    Inherits PreDocEventArgs
Visual C++
public ref class DocumentSavingAsEventArgs : public PreDocEventArgs

Remarks

This event is cancellable, except when it is raised when the Revit application is closing.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.PreDocEventArgs
Autodesk.Revit.Events..::.DocumentSavingAsEventArgs

See Also

DocumentSavingAsEventArgs Members
Autodesk.Revit.Events Namespace


DocumentSavingAsEventArgs Members

[image] [image]

Revit 2010 API
DocumentSavingAsEventArgs Members
DocumentSavingAsEventArgs Class Constructors Methods Properties See Also Send Feedback

The DocumentSavingAsEventArgs type exposes the following members.

Constructors

Name | Description
DocumentSavingAsEventArgs | Initializes a new instance of the DocumentSavingAsEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
PathName | Target path to which the document is to be saved.

See Also

DocumentSavingAsEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSavingAsEventArgs Constructor

[image]

Revit 2010 API
DocumentSavingAsEventArgs Constructor
DocumentSavingAsEventArgs Class See Also Send Feedback
Initializes a new instance of the DocumentSavingAsEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DocumentSavingAsEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentSavingAsEventArgs()

See Also

DocumentSavingAsEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSavingAsEventArgs Methods

[image] [image]

Revit 2010 API
DocumentSavingAsEventArgs Methods
DocumentSavingAsEventArgs Class See Also Send Feedback

The DocumentSavingAsEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSavingAsEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSavingAsEventArgs Properties

[image] [image]

Revit 2010 API
DocumentSavingAsEventArgs Properties
DocumentSavingAsEventArgs Class See Also Send Feedback

The DocumentSavingAsEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
PathName | Target path to which the document is to be saved.

See Also

DocumentSavingAsEventArgs Class
Autodesk.Revit.Events Namespace


PathName Property

[image]

Revit 2010 API
DocumentSavingAsEventArgs..::.PathName Property
DocumentSavingAsEventArgs Class See Also Send Feedback
Target path to which the document is to be saved.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string PathName { get; }
Visual Basic (Declaration)
Public ReadOnly Property PathName As String
Visual C++
public:
property String^ PathName {
    String^ get ();
}

See Also

DocumentSavingAsEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSavingEventArgs Class

[image]

Revit 2010 API
DocumentSavingEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentSaving event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DocumentSavingEventArgs : PreDocEventArgs
Visual Basic (Declaration)
Public Class DocumentSavingEventArgs _
    Inherits PreDocEventArgs
Visual C++
public ref class DocumentSavingEventArgs : public PreDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.PreDocEventArgs
Autodesk.Revit.Events..::.DocumentSavingEventArgs

See Also

DocumentSavingEventArgs Members
Autodesk.Revit.Events Namespace


DocumentSavingEventArgs Members

[image] [image]

Revit 2010 API
DocumentSavingEventArgs Members
DocumentSavingEventArgs Class Constructors Methods Properties See Also Send Feedback

The DocumentSavingEventArgs type exposes the following members.

Constructors

Name | Description
DocumentSavingEventArgs | Initializes a new instance of the DocumentSavingEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)

See Also

DocumentSavingEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSavingEventArgs Constructor

[image]

Revit 2010 API
DocumentSavingEventArgs Constructor
DocumentSavingEventArgs Class See Also Send Feedback
Initializes a new instance of the DocumentSavingEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DocumentSavingEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentSavingEventArgs()

See Also

DocumentSavingEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSavingEventArgs Methods

[image] [image]

Revit 2010 API
DocumentSavingEventArgs Methods
DocumentSavingEventArgs Class See Also Send Feedback

The DocumentSavingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSavingEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSavingEventArgs Properties

[image] [image]

Revit 2010 API
DocumentSavingEventArgs Properties
DocumentSavingEventArgs Class See Also Send Feedback

The DocumentSavingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)

See Also

DocumentSavingEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSynchronizedWithCentralEventArgs Class

[image]

Revit 2010 API
DocumentSynchronizedWithCentralEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentSynchronizedWithCentral event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DocumentSynchronizedWithCentralEventArgs : PostDocEventArgs
Visual Basic (Declaration)
Public Class DocumentSynchronizedWithCentralEventArgs _
    Inherits PostDocEventArgs
Visual C++
public ref class DocumentSynchronizedWithCentralEventArgs : public PostDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PostEventArgs
Autodesk.Revit.Events..::.PostDocEventArgs
Autodesk.Revit.Events..::.DocumentSynchronizedWithCentralEventArgs

See Also

DocumentSynchronizedWithCentralEventArgs Members
Autodesk.Revit.Events Namespace


DocumentSynchronizedWithCentralEventArgs Members

[image] [image]

Revit 2010 API
DocumentSynchronizedWithCentralEventArgs Members
DocumentSynchronizedWithCentralEventArgs Class Constructors Methods Properties See Also Send Feedback

The DocumentSynchronizedWithCentralEventArgs type exposes the following members.

Constructors

Name | Description
DocumentSynchronizedWithCentralEventArgs | Initializes a new instance of the DocumentSynchronizedWithCentralEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentSynchronizedWithCentralEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSynchronizedWithCentralEventArgs Constructor

[image]

Revit 2010 API
DocumentSynchronizedWithCentralEventArgs Constructor
DocumentSynchronizedWithCentralEventArgs Class See Also Send Feedback
Initializes a new instance of the DocumentSynchronizedWithCentralEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DocumentSynchronizedWithCentralEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentSynchronizedWithCentralEventArgs()

See Also

DocumentSynchronizedWithCentralEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSynchronizedWithCentralEventArgs Methods

[image] [image]

Revit 2010 API
DocumentSynchronizedWithCentralEventArgs Methods
DocumentSynchronizedWithCentralEventArgs Class See Also Send Feedback

The DocumentSynchronizedWithCentralEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSynchronizedWithCentralEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSynchronizedWithCentralEventArgs Properties

[image] [image]

Revit 2010 API
DocumentSynchronizedWithCentralEventArgs Properties
DocumentSynchronizedWithCentralEventArgs Class See Also Send Feedback

The DocumentSynchronizedWithCentralEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentSynchronizedWithCentralEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSynchronizingWithCentralEventArgs Class

[image]

Revit 2010 API
DocumentSynchronizingWithCentralEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentSynchronizingWithCentral event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DocumentSynchronizingWithCentralEventArgs : PreDocEventArgs
Visual Basic (Declaration)
Public Class DocumentSynchronizingWithCentralEventArgs _
    Inherits PreDocEventArgs
Visual C++
public ref class DocumentSynchronizingWithCentralEventArgs : public PreDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.PreDocEventArgs
Autodesk.Revit.Events..::.DocumentSynchronizingWithCentralEventArgs

See Also

DocumentSynchronizingWithCentralEventArgs Members
Autodesk.Revit.Events Namespace


DocumentSynchronizingWithCentralEventArgs Members

[image] [image]

Revit 2010 API
DocumentSynchronizingWithCentralEventArgs Members
DocumentSynchronizingWithCentralEventArgs Class Constructors Methods Properties See Also Send Feedback

The DocumentSynchronizingWithCentralEventArgs type exposes the following members.

Constructors

Name | Description
DocumentSynchronizingWithCentralEventArgs | Initializes a new instance of the DocumentSynchronizingWithCentralEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Comments | User's comments for synchronization.
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Location | Full path of the central file which is to be synchronized.
Options | User's options associated with a the synchronization operation.

See Also

DocumentSynchronizingWithCentralEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSynchronizingWithCentralEventArgs Constructor

[image]

Revit 2010 API
DocumentSynchronizingWithCentralEventArgs Constructor
DocumentSynchronizingWithCentralEventArgs Class See Also Send Feedback
Initializes a new instance of the DocumentSynchronizingWithCentralEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DocumentSynchronizingWithCentralEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentSynchronizingWithCentralEventArgs()

See Also

DocumentSynchronizingWithCentralEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSynchronizingWithCentralEventArgs Methods

[image] [image]

Revit 2010 API
DocumentSynchronizingWithCentralEventArgs Methods
DocumentSynchronizingWithCentralEventArgs Class See Also Send Feedback

The DocumentSynchronizingWithCentralEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSynchronizingWithCentralEventArgs Class
Autodesk.Revit.Events Namespace


DocumentSynchronizingWithCentralEventArgs Properties

[image] [image]

Revit 2010 API
DocumentSynchronizingWithCentralEventArgs Properties
DocumentSynchronizingWithCentralEventArgs Class See Also Send Feedback

The DocumentSynchronizingWithCentralEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Comments | User's comments for synchronization.
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Location | Full path of the central file which is to be synchronized.
Options | User's options associated with a the synchronization operation.

See Also

DocumentSynchronizingWithCentralEventArgs Class
Autodesk.Revit.Events Namespace


Comments Property

[image]

Revit 2010 API
DocumentSynchronizingWithCentralEventArgs..::.Comments Property
DocumentSynchronizingWithCentralEventArgs Class See Also Send Feedback
User's comments for synchronization.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Comments { get; }
Visual Basic (Declaration)
Public ReadOnly Property Comments As String
Visual C++
public:
property String^ Comments {
    String^ get ();
}

See Also

DocumentSynchronizingWithCentralEventArgs Class
Autodesk.Revit.Events Namespace


Location Property

[image]

Revit 2010 API
DocumentSynchronizingWithCentralEventArgs..::.Location Property
DocumentSynchronizingWithCentralEventArgs Class See Also Send Feedback
Full path of the central file which is to be synchronized.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Location { get; }
Visual Basic (Declaration)
Public ReadOnly Property Location As String
Visual C++
public:
property String^ Location {
    String^ get ();
}

See Also

DocumentSynchronizingWithCentralEventArgs Class
Autodesk.Revit.Events Namespace


Options Property

[image]

Revit 2010 API
DocumentSynchronizingWithCentralEventArgs..::.Options Property
DocumentSynchronizingWithCentralEventArgs Class See Also Send Feedback
User's options associated with a the synchronization operation.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SynchronizeWithCentralOptions Options { get; }
Visual Basic (Declaration)
Public ReadOnly Property Options As SynchronizeWithCentralOptions
Visual C++
public:
property SynchronizeWithCentralOptions^ Options {
    SynchronizeWithCentralOptions^ get ();
}

See Also

DocumentSynchronizingWithCentralEventArgs Class
Autodesk.Revit.Events Namespace


EventStatus Enumeration

[image]

Revit 2010 API
EventStatus Enumeration
See Also Send Feedback
Describes the status of an action which triggered a post event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum EventStatus
Visual Basic (Declaration)
Public Enumeration EventStatus
Visual C++
public enum class EventStatus

Members

Member name | Description
Cancelled | The action that triggered this event was cancelled by an event handler from the pre-event for the action.
Succeeded | The action that triggered this event succeeded.
Failed | The action that triggered this event failed.

See Also

Autodesk.Revit.Events Namespace


FileExportedEventArgs Class

[image]

Revit 2010 API
FileExportedEventArgs Class
Members See Also Send Feedback
The event arguments used by the FileExported event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FileExportedEventArgs : PostDocEventArgs
Visual Basic (Declaration)
Public Class FileExportedEventArgs _
    Inherits PostDocEventArgs
Visual C++
public ref class FileExportedEventArgs : public PostDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PostEventArgs
Autodesk.Revit.Events..::.PostDocEventArgs
Autodesk.Revit.Events..::.FileExportedEventArgs

See Also

FileExportedEventArgs Members
Autodesk.Revit.Events Namespace


FileExportedEventArgs Members

[image] [image]

Revit 2010 API
FileExportedEventArgs Members
FileExportedEventArgs Class Constructors Methods Properties See Also Send Feedback

The FileExportedEventArgs type exposes the following members.

Constructors

Name | Description
FileExportedEventArgs | Initializes a new instance of the FileExportedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Format | Identifies the export format, e.g. DWG or image.
Path | Target path for the exported file (or files).
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

FileExportedEventArgs Class
Autodesk.Revit.Events Namespace


FileExportedEventArgs Constructor

[image]

Revit 2010 API
FileExportedEventArgs Constructor
FileExportedEventArgs Class See Also Send Feedback
Initializes a new instance of the FileExportedEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FileExportedEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FileExportedEventArgs()

See Also

FileExportedEventArgs Class
Autodesk.Revit.Events Namespace


FileExportedEventArgs Methods

[image] [image]

Revit 2010 API
FileExportedEventArgs Methods
FileExportedEventArgs Class See Also Send Feedback

The FileExportedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileExportedEventArgs Class
Autodesk.Revit.Events Namespace


FileExportedEventArgs Properties

[image] [image]

Revit 2010 API
FileExportedEventArgs Properties
FileExportedEventArgs Class See Also Send Feedback

The FileExportedEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Format | Identifies the export format, e.g. DWG or image.
Path | Target path for the exported file (or files).
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

FileExportedEventArgs Class
Autodesk.Revit.Events Namespace


Format Property

[image]

Revit 2010 API
FileExportedEventArgs..::.Format Property
FileExportedEventArgs Class See Also Send Feedback
Identifies the export format, e.g. DWG or image.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ImportExportFileFormat Format { get; }
Visual Basic (Declaration)
Public ReadOnly Property Format As ImportExportFileFormat
Visual C++
public:
property ImportExportFileFormat Format {
    ImportExportFileFormat get ();
}

See Also

FileExportedEventArgs Class
Autodesk.Revit.Events Namespace


Path Property

[image]

Revit 2010 API
FileExportedEventArgs..::.Path Property
FileExportedEventArgs Class See Also Send Feedback
Target path for the exported file (or files).

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Path { get; }
Visual Basic (Declaration)
Public ReadOnly Property Path As String
Visual C++
public:
property String^ Path {
    String^ get ();
}

Remarks

Please be aware that in some cases the path represents only the target directory or a template name. Such cases include batch export during which more than one file is exported as one event.

See Also

FileExportedEventArgs Class
Autodesk.Revit.Events Namespace


FileExportingEventArgs Class

[image]

Revit 2010 API
FileExportingEventArgs Class
Members See Also Send Feedback
The event arguments used by the FileExporting event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FileExportingEventArgs : PreDocEventArgs
Visual Basic (Declaration)
Public Class FileExportingEventArgs _
    Inherits PreDocEventArgs
Visual C++
public ref class FileExportingEventArgs : public PreDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.PreDocEventArgs
Autodesk.Revit.Events..::.FileExportingEventArgs

See Also

FileExportingEventArgs Members
Autodesk.Revit.Events Namespace


FileExportingEventArgs Members

[image] [image]

Revit 2010 API
FileExportingEventArgs Members
FileExportingEventArgs Class Constructors Methods Properties See Also Send Feedback

The FileExportingEventArgs type exposes the following members.

Constructors

Name | Description
FileExportingEventArgs | Initializes a new instance of the FileExportingEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Format | Identifies the export format, e.g. DWG or image.
Path | The target path for the export.

See Also

FileExportingEventArgs Class
Autodesk.Revit.Events Namespace


FileExportingEventArgs Constructor

[image]

Revit 2010 API
FileExportingEventArgs Constructor
FileExportingEventArgs Class See Also Send Feedback
Initializes a new instance of the FileExportingEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FileExportingEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FileExportingEventArgs()

See Also

FileExportingEventArgs Class
Autodesk.Revit.Events Namespace


FileExportingEventArgs Methods

[image] [image]

Revit 2010 API
FileExportingEventArgs Methods
FileExportingEventArgs Class See Also Send Feedback

The FileExportingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileExportingEventArgs Class
Autodesk.Revit.Events Namespace


FileExportingEventArgs Properties

[image] [image]

Revit 2010 API
FileExportingEventArgs Properties
FileExportingEventArgs Class See Also Send Feedback

The FileExportingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Format | Identifies the export format, e.g. DWG or image.
Path | The target path for the export.

See Also

FileExportingEventArgs Class
Autodesk.Revit.Events Namespace


Format Property

[image]

Revit 2010 API
FileExportingEventArgs..::.Format Property
FileExportingEventArgs Class See Also Send Feedback
Identifies the export format, e.g. DWG or image.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ImportExportFileFormat Format { get; }
Visual Basic (Declaration)
Public ReadOnly Property Format As ImportExportFileFormat
Visual C++
public:
property ImportExportFileFormat Format {
    ImportExportFileFormat get ();
}

See Also

FileExportingEventArgs Class
Autodesk.Revit.Events Namespace


Path Property

[image]

Revit 2010 API
FileExportingEventArgs..::.Path Property
FileExportingEventArgs Class See Also Send Feedback
The target path for the export.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Path { get; }
Visual Basic (Declaration)
Public ReadOnly Property Path As String
Visual C++
public:
property String^ Path {
    String^ get ();
}

Remarks

When several files are exported at the same time, 'Path' property will just report the directory instead of those full file names.

See Also

FileExportingEventArgs Class
Autodesk.Revit.Events Namespace


FileImportedEventArgs Class

[image]

Revit 2010 API
FileImportedEventArgs Class
Members See Also Send Feedback
The event arguments used by the FileImported event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FileImportedEventArgs : PostDocEventArgs
Visual Basic (Declaration)
Public Class FileImportedEventArgs _
    Inherits PostDocEventArgs
Visual C++
public ref class FileImportedEventArgs : public PostDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PostEventArgs
Autodesk.Revit.Events..::.PostDocEventArgs
Autodesk.Revit.Events..::.FileImportedEventArgs

See Also

FileImportedEventArgs Members
Autodesk.Revit.Events Namespace


FileImportedEventArgs Members

[image] [image]

Revit 2010 API
FileImportedEventArgs Members
FileImportedEventArgs Class Constructors Methods Properties See Also Send Feedback

The FileImportedEventArgs type exposes the following members.

Constructors

Name | Description
FileImportedEventArgs | Initializes a new instance of the FileImportedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Format | Identifies the import format, e.g. DWG or image.
ImportedInstance | The instance of the element that represents the imported object(s) after a successful import. It could be used for further manipulating of that instance.
Path | Path of the source file that was imported.
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

FileImportedEventArgs Class
Autodesk.Revit.Events Namespace


FileImportedEventArgs Constructor

[image]

Revit 2010 API
FileImportedEventArgs Constructor
FileImportedEventArgs Class See Also Send Feedback
Initializes a new instance of the FileImportedEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FileImportedEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FileImportedEventArgs()

See Also

FileImportedEventArgs Class
Autodesk.Revit.Events Namespace


FileImportedEventArgs Methods

[image] [image]

Revit 2010 API
FileImportedEventArgs Methods
FileImportedEventArgs Class See Also Send Feedback

The FileImportedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileImportedEventArgs Class
Autodesk.Revit.Events Namespace


FileImportedEventArgs Properties

[image] [image]

Revit 2010 API
FileImportedEventArgs Properties
FileImportedEventArgs Class See Also Send Feedback

The FileImportedEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Format | Identifies the import format, e.g. DWG or image.
ImportedInstance | The instance of the element that represents the imported object(s) after a successful import. It could be used for further manipulating of that instance.
Path | Path of the source file that was imported.
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

FileImportedEventArgs Class
Autodesk.Revit.Events Namespace


Format Property

[image]

Revit 2010 API
FileImportedEventArgs..::.Format Property
FileImportedEventArgs Class See Also Send Feedback
Identifies the import format, e.g. DWG or image.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ImportExportFileFormat Format { get; }
Visual Basic (Declaration)
Public ReadOnly Property Format As ImportExportFileFormat
Visual C++
public:
property ImportExportFileFormat Format {
    ImportExportFileFormat get ();
}

See Also

FileImportedEventArgs Class
Autodesk.Revit.Events Namespace


ImportedInstance Property

[image]

Revit 2010 API
FileImportedEventArgs..::.ImportedInstance Property
FileImportedEventArgs Class See Also Send Feedback
The instance of the element that represents the imported object(s) after a successful import. It could be used for further manipulating of that instance.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element ImportedInstance { get; }
Visual Basic (Declaration)
Public ReadOnly Property ImportedInstance As Element
Visual C++
public:
property Element^ ImportedInstance {
    Element^ get ();
}

Remarks

This property is null when the event is invoked due to import of GBXML and Inventor files.

See Also

FileImportedEventArgs Class
Autodesk.Revit.Events Namespace


Path Property

[image]

Revit 2010 API
FileImportedEventArgs..::.Path Property
FileImportedEventArgs Class See Also Send Feedback
Path of the source file that was imported.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Path { get; }
Visual Basic (Declaration)
Public ReadOnly Property Path As String
Visual C++
public:
property String^ Path {
    String^ get ();
}

See Also

FileImportedEventArgs Class
Autodesk.Revit.Events Namespace


FileImportingEventArgs Class

[image]

Revit 2010 API
FileImportingEventArgs Class
Members See Also Send Feedback
The event arguments used by the FileImporting event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FileImportingEventArgs : PreDocEventArgs
Visual Basic (Declaration)
Public Class FileImportingEventArgs _
    Inherits PreDocEventArgs
Visual C++
public ref class FileImportingEventArgs : public PreDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.PreDocEventArgs
Autodesk.Revit.Events..::.FileImportingEventArgs

See Also

FileImportingEventArgs Members
Autodesk.Revit.Events Namespace


FileImportingEventArgs Members

[image] [image]

Revit 2010 API
FileImportingEventArgs Members
FileImportingEventArgs Class Constructors Methods Properties See Also Send Feedback

The FileImportingEventArgs type exposes the following members.

Constructors

Name | Description
FileImportingEventArgs | Initializes a new instance of the FileImportingEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Format | Identifies the import format, e.g. DWG or image.
Path | Path of the source file which is about to be imported.

See Also

FileImportingEventArgs Class
Autodesk.Revit.Events Namespace


FileImportingEventArgs Constructor

[image]

Revit 2010 API
FileImportingEventArgs Constructor
FileImportingEventArgs Class See Also Send Feedback
Initializes a new instance of the FileImportingEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FileImportingEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FileImportingEventArgs()

See Also

FileImportingEventArgs Class
Autodesk.Revit.Events Namespace


FileImportingEventArgs Methods

[image] [image]

Revit 2010 API
FileImportingEventArgs Methods
FileImportingEventArgs Class See Also Send Feedback

The FileImportingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileImportingEventArgs Class
Autodesk.Revit.Events Namespace


FileImportingEventArgs Properties

[image] [image]

Revit 2010 API
FileImportingEventArgs Properties
FileImportingEventArgs Class See Also Send Feedback

The FileImportingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Format | Identifies the import format, e.g. DWG or image.
Path | Path of the source file which is about to be imported.

See Also

FileImportingEventArgs Class
Autodesk.Revit.Events Namespace


Format Property

[image]

Revit 2010 API
FileImportingEventArgs..::.Format Property
FileImportingEventArgs Class See Also Send Feedback
Identifies the import format, e.g. DWG or image.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ImportExportFileFormat Format { get; }
Visual Basic (Declaration)
Public ReadOnly Property Format As ImportExportFileFormat
Visual C++
public:
property ImportExportFileFormat Format {
    ImportExportFileFormat get ();
}

See Also

FileImportingEventArgs Class
Autodesk.Revit.Events Namespace


Path Property

[image]

Revit 2010 API
FileImportingEventArgs..::.Path Property
FileImportingEventArgs Class See Also Send Feedback
Path of the source file which is about to be imported.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Path { get; }
Visual Basic (Declaration)
Public ReadOnly Property Path As String
Visual C++
public:
property String^ Path {
    String^ get ();
}

See Also

FileImportingEventArgs Class
Autodesk.Revit.Events Namespace


MessageBoxData Class

[image]

Revit 2010 API
MessageBoxData Class
Members See Also Send Feedback
An object that represents a simple message box that prompts the user for some action.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MessageBoxData : DialogBoxData
Visual Basic (Declaration)
Public Class MessageBoxData _
    Inherits DialogBoxData
Visual C++
public ref class MessageBoxData : public DialogBoxData

Remarks

When the application receives this object, a simple message box is displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Events..::.DialogBoxData
Autodesk.Revit.Events..::.MessageBoxData

See Also

MessageBoxData Members
Autodesk.Revit.Events Namespace


MessageBoxData Members

[image] [image]

Revit 2010 API
MessageBoxData Members
MessageBoxData Class Constructors Methods Properties See Also Send Feedback

The MessageBoxData type exposes the following members.

Constructors

Name | Description
MessageBoxData | Initializes a new instance of the MessageBoxData class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxData.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DialogType | An integer that describes the standard windows type of the dialog box.
HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxData.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Message | The message that has been displayed in the dialog box.

See Also

MessageBoxData Class
Autodesk.Revit.Events Namespace


MessageBoxData Constructor

[image]

Revit 2010 API
MessageBoxData Constructor
MessageBoxData Class See Also Send Feedback
Initializes a new instance of the MessageBoxData class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MessageBoxData()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MessageBoxData()

See Also

MessageBoxData Class
Autodesk.Revit.Events Namespace


MessageBoxData Methods

[image] [image]

Revit 2010 API
MessageBoxData Methods
MessageBoxData Class See Also Send Feedback

The MessageBoxData type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxData.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MessageBoxData Class
Autodesk.Revit.Events Namespace


MessageBoxData Properties

[image] [image]

Revit 2010 API
MessageBoxData Properties
MessageBoxData Class See Also Send Feedback

The MessageBoxData type exposes the following members.

Properties

Name | Description
DialogType | An integer that describes the standard windows type of the dialog box.
HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxData.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Message | The message that has been displayed in the dialog box.

See Also

MessageBoxData Class
Autodesk.Revit.Events Namespace


DialogType Property

[image]

Revit 2010 API
MessageBoxData..::.DialogType Property
MessageBoxData Class See Also Send Feedback
An integer that describes the standard windows type of the dialog box.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int DialogType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DialogType As Integer
Visual C++
public:
property int DialogType {
    int get ();
}

See Also

MessageBoxData Class
Autodesk.Revit.Events Namespace


Message Property

[image]

Revit 2010 API
MessageBoxData..::.Message Property
MessageBoxData Class See Also Send Feedback
The message that has been displayed in the dialog box.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Message { get; }
Visual Basic (Declaration)
Public ReadOnly Property Message As String
Visual C++
public:
property String^ Message {
    String^ get ();
}

See Also

MessageBoxData Class
Autodesk.Revit.Events Namespace


MessageBoxShowingEventArgs Class

[image]

Revit 2010 API
MessageBoxShowingEventArgs Class
Members See Also Send Feedback
The event arguments used by the DialogBoxShowing event when a Windows message box is about to be displayed in Revit.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MessageBoxShowingEventArgs : DialogBoxShowingEventArgs
Visual Basic (Declaration)
Public Class MessageBoxShowingEventArgs _
    Inherits DialogBoxShowingEventArgs
Visual C++
public ref class MessageBoxShowingEventArgs : public DialogBoxShowingEventArgs

Remarks

When the application receives this object, a simple message box is about to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.DialogBoxShowingEventArgs
Autodesk.Revit.Events..::.MessageBoxShowingEventArgs

See Also

MessageBoxShowingEventArgs Members
Autodesk.Revit.Events Namespace


MessageBoxShowingEventArgs Members

[image] [image]

Revit 2010 API
MessageBoxShowingEventArgs Members
MessageBoxShowingEventArgs Class Constructors Methods Properties See Also Send Feedback

The MessageBoxShowingEventArgs type exposes the following members.

Constructors

Name | Description
MessageBoxShowingEventArgs | Initializes a new instance of the MessageBoxShowingEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxShowingEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DialogType | An integer that describes the standard Windows type of the dialog box.
HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxShowingEventArgs.)
Message | The message that has been displayed in the dialog box.

See Also

MessageBoxShowingEventArgs Class
Autodesk.Revit.Events Namespace


MessageBoxShowingEventArgs Constructor

[image]

Revit 2010 API
MessageBoxShowingEventArgs Constructor
MessageBoxShowingEventArgs Class See Also Send Feedback
Initializes a new instance of the MessageBoxShowingEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MessageBoxShowingEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MessageBoxShowingEventArgs()

See Also

MessageBoxShowingEventArgs Class
Autodesk.Revit.Events Namespace


MessageBoxShowingEventArgs Methods

[image] [image]

Revit 2010 API
MessageBoxShowingEventArgs Methods
MessageBoxShowingEventArgs Class See Also Send Feedback

The MessageBoxShowingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxShowingEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MessageBoxShowingEventArgs Class
Autodesk.Revit.Events Namespace


MessageBoxShowingEventArgs Properties

[image] [image]

Revit 2010 API
MessageBoxShowingEventArgs Properties
MessageBoxShowingEventArgs Class See Also Send Feedback

The MessageBoxShowingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DialogType | An integer that describes the standard Windows type of the dialog box.
HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxShowingEventArgs.)
Message | The message that has been displayed in the dialog box.

See Also

MessageBoxShowingEventArgs Class
Autodesk.Revit.Events Namespace


DialogType Property

[image]

Revit 2010 API
MessageBoxShowingEventArgs..::.DialogType Property
MessageBoxShowingEventArgs Class See Also Send Feedback
An integer that describes the standard Windows type of the dialog box.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int DialogType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DialogType As Integer
Visual C++
public:
property int DialogType {
    int get ();
}

See Also

MessageBoxShowingEventArgs Class
Autodesk.Revit.Events Namespace


Message Property

[image]

Revit 2010 API
MessageBoxShowingEventArgs..::.Message Property
MessageBoxShowingEventArgs Class See Also Send Feedback
The message that has been displayed in the dialog box.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Message { get; }
Visual Basic (Declaration)
Public ReadOnly Property Message As String
Visual C++
public:
property String^ Message {
    String^ get ();
}

See Also

MessageBoxShowingEventArgs Class
Autodesk.Revit.Events Namespace


PostDocEventArgs Class

[image]

Revit 2010 API
PostDocEventArgs Class
Members See Also Send Feedback
The class is used as base class for arguments of any post-event that is associated to a particular Document.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PostDocEventArgs : PostEventArgs
Visual Basic (Declaration)
Public Class PostDocEventArgs _
    Inherits PostEventArgs
Visual C++
public ref class PostDocEventArgs : public PostEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PostEventArgs
Autodesk.Revit.Events..::.PostDocEventArgs
Autodesk.Revit.Events..::.DocumentCreatedEventArgs
Autodesk.Revit.Events..::.DocumentOpenedEventArgs
Autodesk.Revit.Events..::.DocumentPrintedEventArgs
Autodesk.Revit.Events..::.DocumentSavedAsEventArgs
Autodesk.Revit.Events..::.DocumentSavedEventArgs
Autodesk.Revit.Events..::.DocumentSynchronizedWithCentralEventArgs
Autodesk.Revit.Events..::.FileExportedEventArgs
Autodesk.Revit.Events..::.FileImportedEventArgs
Autodesk.Revit.Events..::.ViewActivatedEventArgs
Autodesk.Revit.Events..::.ViewPrintedEventArgs

See Also

PostDocEventArgs Members
Autodesk.Revit.Events Namespace


PostDocEventArgs Members

[image] [image]

Revit 2010 API
PostDocEventArgs Members
PostDocEventArgs Class Constructors Methods Properties See Also Send Feedback

The PostDocEventArgs type exposes the following members.

Constructors

Name | Description
PostDocEventArgs | Initializes a new instance of the PostDocEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event.
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

PostDocEventArgs Class
Autodesk.Revit.Events Namespace


PostDocEventArgs Constructor

[image]

Revit 2010 API
PostDocEventArgs Constructor
PostDocEventArgs Class See Also Send Feedback
Initializes a new instance of the PostDocEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PostDocEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PostDocEventArgs()

See Also

PostDocEventArgs Class
Autodesk.Revit.Events Namespace


PostDocEventArgs Methods

[image] [image]

Revit 2010 API
PostDocEventArgs Methods
PostDocEventArgs Class See Also Send Feedback

The PostDocEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PostDocEventArgs Class
Autodesk.Revit.Events Namespace


PostDocEventArgs Properties

[image] [image]

Revit 2010 API
PostDocEventArgs Properties
PostDocEventArgs Class See Also Send Feedback

The PostDocEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event.
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

PostDocEventArgs Class
Autodesk.Revit.Events Namespace


Document Property

[image]

Revit 2010 API
PostDocEventArgs..::.Document Property
PostDocEventArgs Class See Also Send Feedback
The document associated with the event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

PostDocEventArgs Class
Autodesk.Revit.Events Namespace


PostEventArgs Class

[image]

Revit 2010 API
PostEventArgs Class
Members See Also Send Feedback
The class is used as a base class for arguments of any post-event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PostEventArgs : RevitEventArgs
Visual Basic (Declaration)
Public Class PostEventArgs _
    Inherits RevitEventArgs
Visual C++
public ref class PostEventArgs : public RevitEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PostEventArgs
Autodesk.Revit.Events..::.DocumentClosedEventArgs
Autodesk.Revit.Events..::.PostDocEventArgs

See Also

PostEventArgs Members
Autodesk.Revit.Events Namespace


PostEventArgs Members

[image] [image]

Revit 2010 API
PostEventArgs Members
PostEventArgs Class Constructors Methods Properties See Also Send Feedback

The PostEventArgs type exposes the following members.

Constructors

Name | Description
PostEventArgs | Initializes a new instance of the PostEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler).

See Also

PostEventArgs Class
Autodesk.Revit.Events Namespace


PostEventArgs Constructor

[image]

Revit 2010 API
PostEventArgs Constructor
PostEventArgs Class See Also Send Feedback
Initializes a new instance of the PostEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PostEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PostEventArgs()

See Also

PostEventArgs Class
Autodesk.Revit.Events Namespace


PostEventArgs Methods

[image] [image]

Revit 2010 API
PostEventArgs Methods
PostEventArgs Class See Also Send Feedback

The PostEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PostEventArgs Class
Autodesk.Revit.Events Namespace


PostEventArgs Properties

[image] [image]

Revit 2010 API
PostEventArgs Properties
PostEventArgs Class See Also Send Feedback

The PostEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler).

See Also

PostEventArgs Class
Autodesk.Revit.Events Namespace


Status Property

[image]

Revit 2010 API
PostEventArgs..::.Status Property
PostEventArgs Class See Also Send Feedback
Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler).

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public EventStatus Status { get; }
Visual Basic (Declaration)
Public ReadOnly Property Status As EventStatus
Visual C++
public:
property EventStatus Status {
    EventStatus get ();
}

See Also

PostEventArgs Class
Autodesk.Revit.Events Namespace


PreDocEventArgs Class

[image]

Revit 2010 API
PreDocEventArgs Class
Members See Also Send Feedback
The class is used as base class for the arguments of any pre-event arguments that is associated to a particular Document.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PreDocEventArgs : PreEventArgs
Visual Basic (Declaration)
Public Class PreDocEventArgs _
    Inherits PreEventArgs
Visual C++
public ref class PreDocEventArgs : public PreEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.PreDocEventArgs
Autodesk.Revit.Events..::.DocumentClosingEventArgs
Autodesk.Revit.Events..::.DocumentPrintingEventArgs
Autodesk.Revit.Events..::.DocumentSavingAsEventArgs
Autodesk.Revit.Events..::.DocumentSavingEventArgs
Autodesk.Revit.Events..::.DocumentSynchronizingWithCentralEventArgs
Autodesk.Revit.Events..::.FileExportingEventArgs
Autodesk.Revit.Events..::.FileImportingEventArgs
Autodesk.Revit.Events..::.ViewActivatingEventArgs
Autodesk.Revit.Events..::.ViewPrintingEventArgs

See Also

PreDocEventArgs Members
Autodesk.Revit.Events Namespace


PreDocEventArgs Members

[image] [image]

Revit 2010 API
PreDocEventArgs Members
PreDocEventArgs Class Constructors Methods Properties See Also Send Feedback

The PreDocEventArgs type exposes the following members.

Constructors

Name | Description
PreDocEventArgs | Initializes a new instance of the PreDocEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event.

See Also

PreDocEventArgs Class
Autodesk.Revit.Events Namespace


PreDocEventArgs Constructor

[image]

Revit 2010 API
PreDocEventArgs Constructor
PreDocEventArgs Class See Also Send Feedback
Initializes a new instance of the PreDocEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PreDocEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PreDocEventArgs()

See Also

PreDocEventArgs Class
Autodesk.Revit.Events Namespace


PreDocEventArgs Methods

[image] [image]

Revit 2010 API
PreDocEventArgs Methods
PreDocEventArgs Class See Also Send Feedback

The PreDocEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreDocEventArgs Class
Autodesk.Revit.Events Namespace


PreDocEventArgs Properties

[image] [image]

Revit 2010 API
PreDocEventArgs Properties
PreDocEventArgs Class See Also Send Feedback

The PreDocEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event.

See Also

PreDocEventArgs Class
Autodesk.Revit.Events Namespace


Document Property

[image]

Revit 2010 API
PreDocEventArgs..::.Document Property
PreDocEventArgs Class See Also Send Feedback
The document associated with the event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

PreDocEventArgs Class
Autodesk.Revit.Events Namespace


PreEventArgs Class

[image]

Revit 2010 API
PreEventArgs Class
Members See Also Send Feedback
The class is used as a base class for the arguments for any pre-event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PreEventArgs : RevitEventArgs
Visual Basic (Declaration)
Public Class PreEventArgs _
    Inherits RevitEventArgs
Visual C++
public ref class PreEventArgs : public RevitEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.ApplicationClosingEventArgs
Autodesk.Revit.Events..::.DialogBoxShowingEventArgs
Autodesk.Revit.Events..::.DocumentCreatingEventArgs
Autodesk.Revit.Events..::.DocumentOpeningEventArgs
Autodesk.Revit.Events..::.PreDocEventArgs

See Also

PreEventArgs Members
Autodesk.Revit.Events Namespace


PreEventArgs Members

[image] [image]

Revit 2010 API
PreEventArgs Members
PreEventArgs Class Constructors Methods Properties See Also Send Feedback

The PreEventArgs type exposes the following members.

Constructors

Name | Description
PreEventArgs | Initializes a new instance of the PreEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)

See Also

PreEventArgs Class
Autodesk.Revit.Events Namespace


PreEventArgs Constructor

[image]

Revit 2010 API
PreEventArgs Constructor
PreEventArgs Class See Also Send Feedback
Initializes a new instance of the PreEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PreEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PreEventArgs()

See Also

PreEventArgs Class
Autodesk.Revit.Events Namespace


PreEventArgs Methods

[image] [image]

Revit 2010 API
PreEventArgs Methods
PreEventArgs Class See Also Send Feedback

The PreEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreEventArgs Class
Autodesk.Revit.Events Namespace


PreEventArgs Properties

[image] [image]

Revit 2010 API
PreEventArgs Properties
PreEventArgs Class See Also Send Feedback

The PreEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)

See Also

PreEventArgs Class
Autodesk.Revit.Events Namespace


RevitEventArgs Class

[image]

Revit 2010 API
RevitEventArgs Class
Members See Also Send Feedback
The class is used as base class for all event argument classes.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RevitEventArgs : EventArgs
Visual Basic (Declaration)
Public Class RevitEventArgs _
    Inherits EventArgs
Visual C++
public ref class RevitEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PostEventArgs
Autodesk.Revit.Events..::.PreEventArgs

See Also

RevitEventArgs Members
Autodesk.Revit.Events Namespace


RevitEventArgs Members

[image] [image]

Revit 2010 API
RevitEventArgs Members
RevitEventArgs Class Constructors Methods Properties See Also Send Feedback

The RevitEventArgs type exposes the following members.

Constructors

Name | Description
RevitEventArgs | Initializes a new instance of the RevitEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it.
Cancellable | Indicates whether an event may be cancelled by an event delegate.

See Also

RevitEventArgs Class
Autodesk.Revit.Events Namespace


RevitEventArgs Constructor

[image]

Revit 2010 API
RevitEventArgs Constructor
RevitEventArgs Class See Also Send Feedback
Initializes a new instance of the RevitEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RevitEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RevitEventArgs()

See Also

RevitEventArgs Class
Autodesk.Revit.Events Namespace


RevitEventArgs Methods

[image] [image]

Revit 2010 API
RevitEventArgs Methods
RevitEventArgs Class See Also Send Feedback

The RevitEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitEventArgs Class
Autodesk.Revit.Events Namespace


RevitEventArgs Properties

[image] [image]

Revit 2010 API
RevitEventArgs Properties
RevitEventArgs Class See Also Send Feedback

The RevitEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it.
Cancellable | Indicates whether an event may be cancelled by an event delegate.

See Also

RevitEventArgs Class
Autodesk.Revit.Events Namespace


Cancel Property

[image]

Revit 2010 API
RevitEventArgs..::.Cancel Property
RevitEventArgs Class See Also Send Feedback
Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Cancel { get; set; }
Visual Basic (Declaration)
Public Overridable Property Cancel As Boolean
Visual C++
public:
virtual property bool Cancel {
    bool get ();
    void set (bool value);
}

Remarks

If an event delegate wishes to cancel the event, it should set the value of this property to 'true'. Not every event is cancellable. Whether or not an event may be cancelled is indicated by the value of 'Cancellable' property.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if an event delegate attempts to cancel a non-cancellable event.

See Also

RevitEventArgs Class
Autodesk.Revit.Events Namespace


Cancellable Property

[image]

Revit 2010 API
RevitEventArgs..::.Cancellable Property
RevitEventArgs Class See Also Send Feedback
Indicates whether an event may be cancelled by an event delegate.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Cancellable { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Cancellable As Boolean
Visual C++
public:
virtual property bool Cancellable {
    bool get ();
}

Remarks

If 'Cancellable' is true, event delegates may cancel the command that was announced by the event. To do so, a delegate would set the 'Cancel' property to 'true'. Typically, post-events (e.g. DocumentPrinted) are not cancellable, while most pre-events (e.g. DocumentPrinting) are cancellable, except for special conditions and situations, such as when the Revit application is being closed or if an event is raised during another event.

See Also

RevitEventArgs Class
Autodesk.Revit.Events Namespace


SynchronizeWithCentralOptions Class

[image]

Revit 2010 API
SynchronizeWithCentralOptions Class
Members See Also Send Feedback
Options for save to central.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SynchronizeWithCentralOptions
Visual Basic (Declaration)
Public Class SynchronizeWithCentralOptions
Visual C++
public ref class SynchronizeWithCentralOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Events..::.SynchronizeWithCentralOptions

See Also

SynchronizeWithCentralOptions Members
Autodesk.Revit.Events Namespace


SynchronizeWithCentralOptions Members

[image] [image]

Revit 2010 API
SynchronizeWithCentralOptions Members
SynchronizeWithCentralOptions Class Constructors Methods Properties See Also Send Feedback

The SynchronizeWithCentralOptions type exposes the following members.

Constructors

Name | Description
SynchronizeWithCentralOptions | Initializes a new instance of the SynchronizeWithCentralOptions class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CompactCentralFile | Indicates whether Revit should compact the central file while synchronizing with central. This option reduces the size of the central file but many increase the time it takes to perform the save.
RelinquishBorrowedElements | Indicates whether Revit should relinquish borrowed elements after synchronizing with central.
RelinquishFamilyWorksets | Indicates whether Revit should relinquish Family worksets after synchronizing with central.
RelinquishProjectStandardWorksets | Indicates whether Revit should relinquish Project Standard worksets after synchronizing with central.
RelinquishUserCreatedWorksets | Indicates whether Revit should relinquish user-created worksets after synchronizing with central.
RelinquishViewWorksets | Indicates whether Revit should relinquish View worksets after synchronizing with central.
SaveLocalFile | Indicates whether Revit should save the local file before and after synchronizing with central.

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.Events Namespace


SynchronizeWithCentralOptions Constructor

[image]

Revit 2010 API
SynchronizeWithCentralOptions Constructor
SynchronizeWithCentralOptions Class See Also Send Feedback
Initializes a new instance of the SynchronizeWithCentralOptions class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SynchronizeWithCentralOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SynchronizeWithCentralOptions()

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.Events Namespace


SynchronizeWithCentralOptions Methods

[image] [image]

Revit 2010 API
SynchronizeWithCentralOptions Methods
SynchronizeWithCentralOptions Class See Also Send Feedback

The SynchronizeWithCentralOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.Events Namespace


SynchronizeWithCentralOptions Properties

[image] [image]

Revit 2010 API
SynchronizeWithCentralOptions Properties
SynchronizeWithCentralOptions Class See Also Send Feedback

The SynchronizeWithCentralOptions type exposes the following members.

Properties

Name | Description
CompactCentralFile | Indicates whether Revit should compact the central file while synchronizing with central. This option reduces the size of the central file but many increase the time it takes to perform the save.
RelinquishBorrowedElements | Indicates whether Revit should relinquish borrowed elements after synchronizing with central.
RelinquishFamilyWorksets | Indicates whether Revit should relinquish Family worksets after synchronizing with central.
RelinquishProjectStandardWorksets | Indicates whether Revit should relinquish Project Standard worksets after synchronizing with central.
RelinquishUserCreatedWorksets | Indicates whether Revit should relinquish user-created worksets after synchronizing with central.
RelinquishViewWorksets | Indicates whether Revit should relinquish View worksets after synchronizing with central.
SaveLocalFile | Indicates whether Revit should save the local file before and after synchronizing with central.

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.Events Namespace


CompactCentralFile Property

[image]

Revit 2010 API
SynchronizeWithCentralOptions..::.CompactCentralFile Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should compact the central file while synchronizing with central. This option reduces the size of the central file but many increase the time it takes to perform the save.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool CompactCentralFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property CompactCentralFile As Boolean
Visual C++
public:
property bool CompactCentralFile {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.Events Namespace


RelinquishBorrowedElements Property

[image]

Revit 2010 API
SynchronizeWithCentralOptions..::.RelinquishBorrowedElements Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should relinquish borrowed elements after synchronizing with central.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool RelinquishBorrowedElements { get; }
Visual Basic (Declaration)
Public ReadOnly Property RelinquishBorrowedElements As Boolean
Visual C++
public:
property bool RelinquishBorrowedElements {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.Events Namespace


RelinquishFamilyWorksets Property

[image]

Revit 2010 API
SynchronizeWithCentralOptions..::.RelinquishFamilyWorksets Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should relinquish Family worksets after synchronizing with central.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool RelinquishFamilyWorksets { get; }
Visual Basic (Declaration)
Public ReadOnly Property RelinquishFamilyWorksets As Boolean
Visual C++
public:
property bool RelinquishFamilyWorksets {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.Events Namespace


RelinquishProjectStandardWorksets Property

[image]

Revit 2010 API
SynchronizeWithCentralOptions..::.RelinquishProjectStandardWorksets Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should relinquish Project Standard worksets after synchronizing with central.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool RelinquishProjectStandardWorksets { get; }
Visual Basic (Declaration)
Public ReadOnly Property RelinquishProjectStandardWorksets As Boolean
Visual C++
public:
property bool RelinquishProjectStandardWorksets {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.Events Namespace


RelinquishUserCreatedWorksets Property

[image]

Revit 2010 API
SynchronizeWithCentralOptions..::.RelinquishUserCreatedWorksets Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should relinquish user-created worksets after synchronizing with central.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool RelinquishUserCreatedWorksets { get; }
Visual Basic (Declaration)
Public ReadOnly Property RelinquishUserCreatedWorksets As Boolean
Visual C++
public:
property bool RelinquishUserCreatedWorksets {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.Events Namespace


RelinquishViewWorksets Property

[image]

Revit 2010 API
SynchronizeWithCentralOptions..::.RelinquishViewWorksets Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should relinquish View worksets after synchronizing with central.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool RelinquishViewWorksets { get; }
Visual Basic (Declaration)
Public ReadOnly Property RelinquishViewWorksets As Boolean
Visual C++
public:
property bool RelinquishViewWorksets {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.Events Namespace


SaveLocalFile Property

[image]

Revit 2010 API
SynchronizeWithCentralOptions..::.SaveLocalFile Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should save the local file before and after synchronizing with central.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SaveLocalFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property SaveLocalFile As Boolean
Visual C++
public:
property bool SaveLocalFile {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.Events Namespace


TaskDialogShowingEventArgs Class

[image]

Revit 2010 API
TaskDialogShowingEventArgs Class
Members See Also Send Feedback
The event arguments used by the DialogBoxShowing event when a Revit task dialog that prompts the user for some action is shown.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class TaskDialogShowingEventArgs : DialogBoxShowingEventArgs
Visual Basic (Declaration)
Public Class TaskDialogShowingEventArgs _
    Inherits DialogBoxShowingEventArgs
Visual C++
public ref class TaskDialogShowingEventArgs : public DialogBoxShowingEventArgs

Remarks

When the application receives this object, a task dialog is about to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.DialogBoxShowingEventArgs
Autodesk.Revit.Events..::.TaskDialogShowingEventArgs

See Also

TaskDialogShowingEventArgs Members
Autodesk.Revit.Events Namespace


TaskDialogShowingEventArgs Members

[image] [image]

Revit 2010 API
TaskDialogShowingEventArgs Members
TaskDialogShowingEventArgs Class Constructors Methods Properties See Also Send Feedback

The TaskDialogShowingEventArgs type exposes the following members.

Constructors

Name | Description
TaskDialogShowingEventArgs | Initializes a new instance of the TaskDialogShowingEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxShowingEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DialogId | String ID associated with the task dialog.
HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxShowingEventArgs.)
Message | The message provided by the task dialog.

See Also

TaskDialogShowingEventArgs Class
Autodesk.Revit.Events Namespace


TaskDialogShowingEventArgs Constructor

[image]

Revit 2010 API
TaskDialogShowingEventArgs Constructor
TaskDialogShowingEventArgs Class See Also Send Feedback
Initializes a new instance of the TaskDialogShowingEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TaskDialogShowingEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TaskDialogShowingEventArgs()

See Also

TaskDialogShowingEventArgs Class
Autodesk.Revit.Events Namespace


TaskDialogShowingEventArgs Methods

[image] [image]

Revit 2010 API
TaskDialogShowingEventArgs Methods
TaskDialogShowingEventArgs Class See Also Send Feedback

The TaskDialogShowingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxShowingEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaskDialogShowingEventArgs Class
Autodesk.Revit.Events Namespace


TaskDialogShowingEventArgs Properties

[image] [image]

Revit 2010 API
TaskDialogShowingEventArgs Properties
TaskDialogShowingEventArgs Class See Also Send Feedback

The TaskDialogShowingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DialogId | String ID associated with the task dialog.
HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxShowingEventArgs.)
Message | The message provided by the task dialog.

See Also

TaskDialogShowingEventArgs Class
Autodesk.Revit.Events Namespace


DialogId Property

[image]

Revit 2010 API
TaskDialogShowingEventArgs..::.DialogId Property
TaskDialogShowingEventArgs Class See Also Send Feedback
String ID associated with the task dialog.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string DialogId { get; }
Visual Basic (Declaration)
Public ReadOnly Property DialogId As String
Visual C++
public:
property String^ DialogId {
    String^ get ();
}

See Also

TaskDialogShowingEventArgs Class
Autodesk.Revit.Events Namespace


Message Property

[image]

Revit 2010 API
TaskDialogShowingEventArgs..::.Message Property
TaskDialogShowingEventArgs Class See Also Send Feedback
The message provided by the task dialog.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Message { get; }
Visual Basic (Declaration)
Public ReadOnly Property Message As String
Visual C++
public:
property String^ Message {
    String^ get ();
}

See Also

TaskDialogShowingEventArgs Class
Autodesk.Revit.Events Namespace


ViewActivatedEventArgs Class

[image]

Revit 2010 API
ViewActivatedEventArgs Class
Members See Also Send Feedback
The event arguments used by the ViewActivated event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ViewActivatedEventArgs : PostDocEventArgs
Visual Basic (Declaration)
Public Class ViewActivatedEventArgs _
    Inherits PostDocEventArgs
Visual C++
public ref class ViewActivatedEventArgs : public PostDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PostEventArgs
Autodesk.Revit.Events..::.PostDocEventArgs
Autodesk.Revit.Events..::.ViewActivatedEventArgs

See Also

ViewActivatedEventArgs Members
Autodesk.Revit.Events Namespace


ViewActivatedEventArgs Members

[image] [image]

Revit 2010 API
ViewActivatedEventArgs Members
ViewActivatedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ViewActivatedEventArgs type exposes the following members.

Constructors

Name | Description
ViewActivatedEventArgs | Initializes a new instance of the ViewActivatedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
CurrentActiveView | The view that has just become active.
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
PreviousActiveView | The previously active view.
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

ViewActivatedEventArgs Class
Autodesk.Revit.Events Namespace


ViewActivatedEventArgs Constructor

[image]

Revit 2010 API
ViewActivatedEventArgs Constructor
ViewActivatedEventArgs Class See Also Send Feedback
Initializes a new instance of the ViewActivatedEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewActivatedEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewActivatedEventArgs()

See Also

ViewActivatedEventArgs Class
Autodesk.Revit.Events Namespace


ViewActivatedEventArgs Methods

[image] [image]

Revit 2010 API
ViewActivatedEventArgs Methods
ViewActivatedEventArgs Class See Also Send Feedback

The ViewActivatedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewActivatedEventArgs Class
Autodesk.Revit.Events Namespace


ViewActivatedEventArgs Properties

[image] [image]

Revit 2010 API
ViewActivatedEventArgs Properties
ViewActivatedEventArgs Class See Also Send Feedback

The ViewActivatedEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
CurrentActiveView | The view that has just become active.
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
PreviousActiveView | The previously active view.
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

ViewActivatedEventArgs Class
Autodesk.Revit.Events Namespace


CurrentActiveView Property

[image]

Revit 2010 API
ViewActivatedEventArgs..::.CurrentActiveView Property
ViewActivatedEventArgs Class See Also Send Feedback
The view that has just become active.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public View CurrentActiveView { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentActiveView As View
Visual C++
public:
property View^ CurrentActiveView {
    View^ get ();
}

See Also

ViewActivatedEventArgs Class
Autodesk.Revit.Events Namespace


PreviousActiveView Property

[image]

Revit 2010 API
ViewActivatedEventArgs..::.PreviousActiveView Property
ViewActivatedEventArgs Class See Also Send Feedback
The previously active view.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public View PreviousActiveView { get; }
Visual Basic (Declaration)
Public ReadOnly Property PreviousActiveView As View
Visual C++
public:
property View^ PreviousActiveView {
    View^ get ();
}

Remarks

May be null if there was no previously active view.

See Also

ViewActivatedEventArgs Class
Autodesk.Revit.Events Namespace


ViewActivatingEventArgs Class

[image]

Revit 2010 API
ViewActivatingEventArgs Class
Members See Also Send Feedback
The event arguments used by the ViewActivating event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ViewActivatingEventArgs : PreDocEventArgs
Visual Basic (Declaration)
Public Class ViewActivatingEventArgs _
    Inherits PreDocEventArgs
Visual C++
public ref class ViewActivatingEventArgs : public PreDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.PreDocEventArgs
Autodesk.Revit.Events..::.ViewActivatingEventArgs

See Also

ViewActivatingEventArgs Members
Autodesk.Revit.Events Namespace


ViewActivatingEventArgs Members

[image] [image]

Revit 2010 API
ViewActivatingEventArgs Members
ViewActivatingEventArgs Class Constructors Methods Properties See Also Send Feedback

The ViewActivatingEventArgs type exposes the following members.

Constructors

Name | Description
ViewActivatingEventArgs | Initializes a new instance of the ViewActivatingEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
CurrentActiveView | The view that is currently active.
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
NewActiveView | The view that is going to become active.

See Also

ViewActivatingEventArgs Class
Autodesk.Revit.Events Namespace


ViewActivatingEventArgs Constructor

[image]

Revit 2010 API
ViewActivatingEventArgs Constructor
ViewActivatingEventArgs Class See Also Send Feedback
Initializes a new instance of the ViewActivatingEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewActivatingEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewActivatingEventArgs()

See Also

ViewActivatingEventArgs Class
Autodesk.Revit.Events Namespace


ViewActivatingEventArgs Methods

[image] [image]

Revit 2010 API
ViewActivatingEventArgs Methods
ViewActivatingEventArgs Class See Also Send Feedback

The ViewActivatingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewActivatingEventArgs Class
Autodesk.Revit.Events Namespace


ViewActivatingEventArgs Properties

[image] [image]

Revit 2010 API
ViewActivatingEventArgs Properties
ViewActivatingEventArgs Class See Also Send Feedback

The ViewActivatingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
CurrentActiveView | The view that is currently active.
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
NewActiveView | The view that is going to become active.

See Also

ViewActivatingEventArgs Class
Autodesk.Revit.Events Namespace


CurrentActiveView Property

[image]

Revit 2010 API
ViewActivatingEventArgs..::.CurrentActiveView Property
ViewActivatingEventArgs Class See Also Send Feedback
The view that is currently active.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public View CurrentActiveView { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentActiveView As View
Visual C++
public:
property View^ CurrentActiveView {
    View^ get ();
}

Remarks

May be null if there is no currently active view.

See Also

ViewActivatingEventArgs Class
Autodesk.Revit.Events Namespace


NewActiveView Property

[image]

Revit 2010 API
ViewActivatingEventArgs..::.NewActiveView Property
ViewActivatingEventArgs Class See Also Send Feedback
The view that is going to become active.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public View NewActiveView { get; }
Visual Basic (Declaration)
Public ReadOnly Property NewActiveView As View
Visual C++
public:
property View^ NewActiveView {
    View^ get ();
}

See Also

ViewActivatingEventArgs Class
Autodesk.Revit.Events Namespace


ViewPrintedEventArgs Class

[image]

Revit 2010 API
ViewPrintedEventArgs Class
Members See Also Send Feedback
The event arguments used by ViewPrinted event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ViewPrintedEventArgs : PostDocEventArgs
Visual Basic (Declaration)
Public Class ViewPrintedEventArgs _
    Inherits PostDocEventArgs
Visual C++
public ref class ViewPrintedEventArgs : public PostDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PostEventArgs
Autodesk.Revit.Events..::.PostDocEventArgs
Autodesk.Revit.Events..::.ViewPrintedEventArgs

See Also

ViewPrintedEventArgs Members
Autodesk.Revit.Events Namespace


ViewPrintedEventArgs Members

[image] [image]

Revit 2010 API
ViewPrintedEventArgs Members
ViewPrintedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ViewPrintedEventArgs type exposes the following members.

Constructors

Name | Description
ViewPrintedEventArgs | Initializes a new instance of the ViewPrintedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Index | When the view is being printed as a part of a view-set, the value of this property indicates the index of this view in the entire set. The value is 0-based.
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)
TotalViews | When the view is being printed as a part of a view-set, the value of this property indicates the number of all views in the set.
View | View that was printed.

See Also

ViewPrintedEventArgs Class
Autodesk.Revit.Events Namespace


ViewPrintedEventArgs Constructor

[image]

Revit 2010 API
ViewPrintedEventArgs Constructor
ViewPrintedEventArgs Class See Also Send Feedback
Initializes a new instance of the ViewPrintedEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewPrintedEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewPrintedEventArgs()

See Also

ViewPrintedEventArgs Class
Autodesk.Revit.Events Namespace


ViewPrintedEventArgs Methods

[image] [image]

Revit 2010 API
ViewPrintedEventArgs Methods
ViewPrintedEventArgs Class See Also Send Feedback

The ViewPrintedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewPrintedEventArgs Class
Autodesk.Revit.Events Namespace


ViewPrintedEventArgs Properties

[image] [image]

Revit 2010 API
ViewPrintedEventArgs Properties
ViewPrintedEventArgs Class See Also Send Feedback

The ViewPrintedEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Index | When the view is being printed as a part of a view-set, the value of this property indicates the index of this view in the entire set. The value is 0-based.
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)
TotalViews | When the view is being printed as a part of a view-set, the value of this property indicates the number of all views in the set.
View | View that was printed.

See Also

ViewPrintedEventArgs Class
Autodesk.Revit.Events Namespace


Index Property

[image]

Revit 2010 API
ViewPrintedEventArgs..::.Index Property
ViewPrintedEventArgs Class See Also Send Feedback
When the view is being printed as a part of a view-set, the value of this property indicates the index of this view in the entire set. The value is 0-based.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

ViewPrintedEventArgs Class
Autodesk.Revit.Events Namespace


TotalViews Property

[image]

Revit 2010 API
ViewPrintedEventArgs..::.TotalViews Property
ViewPrintedEventArgs Class See Also Send Feedback
When the view is being printed as a part of a view-set, the value of this property indicates the number of all views in the set.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int TotalViews { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalViews As Integer
Visual C++
public:
property int TotalViews {
    int get ();
}

See Also

ViewPrintedEventArgs Class
Autodesk.Revit.Events Namespace


View Property

[image]

Revit 2010 API
ViewPrintedEventArgs..::.View Property
ViewPrintedEventArgs Class See Also Send Feedback
View that was printed.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public View View { get; }
Visual Basic (Declaration)
Public ReadOnly Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
}

See Also

ViewPrintedEventArgs Class
Autodesk.Revit.Events Namespace


ViewPrintingEventArgs Class

[image]

Revit 2010 API
ViewPrintingEventArgs Class
Members See Also Send Feedback
The event arguments used by the ViewPrinting event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ViewPrintingEventArgs : PreDocEventArgs
Visual Basic (Declaration)
Public Class ViewPrintingEventArgs _
    Inherits PreDocEventArgs
Visual C++
public ref class ViewPrintingEventArgs : public PreDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.PreDocEventArgs
Autodesk.Revit.Events..::.ViewPrintingEventArgs

See Also

ViewPrintingEventArgs Members
Autodesk.Revit.Events Namespace


ViewPrintingEventArgs Members

[image] [image]

Revit 2010 API
ViewPrintingEventArgs Members
ViewPrintingEventArgs Class Constructors Methods Properties See Also Send Feedback

The ViewPrintingEventArgs type exposes the following members.

Constructors

Name | Description
ViewPrintingEventArgs | Initializes a new instance of the ViewPrintingEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Index | When the view is being printed as a part of a view-set, the value of this property indicates the index of this view in the entire set. The value is 0-based.
Settings | Print Settings of current project.
TotalViews | When the view is being printed as a part of a view-set, the value of this property indicates the number of all views in the set.
View | The view to be printed.

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.Events Namespace


ViewPrintingEventArgs Constructor

[image]

Revit 2010 API
ViewPrintingEventArgs Constructor
ViewPrintingEventArgs Class See Also Send Feedback
Initializes a new instance of the ViewPrintingEventArgs class

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewPrintingEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewPrintingEventArgs()

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.Events Namespace


ViewPrintingEventArgs Methods

[image] [image]

Revit 2010 API
ViewPrintingEventArgs Methods
ViewPrintingEventArgs Class See Also Send Feedback

The ViewPrintingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.Events Namespace


ViewPrintingEventArgs Properties

[image] [image]

Revit 2010 API
ViewPrintingEventArgs Properties
ViewPrintingEventArgs Class See Also Send Feedback

The ViewPrintingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Index | When the view is being printed as a part of a view-set, the value of this property indicates the index of this view in the entire set. The value is 0-based.
Settings | Print Settings of current project.
TotalViews | When the view is being printed as a part of a view-set, the value of this property indicates the number of all views in the set.
View | The view to be printed.

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.Events Namespace


Index Property

[image]

Revit 2010 API
ViewPrintingEventArgs..::.Index Property
ViewPrintingEventArgs Class See Also Send Feedback
When the view is being printed as a part of a view-set, the value of this property indicates the index of this view in the entire set. The value is 0-based.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.Events Namespace


Settings Property

[image]

Revit 2010 API
ViewPrintingEventArgs..::.Settings Property
ViewPrintingEventArgs Class See Also Send Feedback
Print Settings of current project.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PrintSetting Settings { get; }
Visual Basic (Declaration)
Public ReadOnly Property Settings As PrintSetting
Visual C++
public:
property PrintSetting^ Settings {
    PrintSetting^ get ();
}

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.Events Namespace


TotalViews Property

[image]

Revit 2010 API
ViewPrintingEventArgs..::.TotalViews Property
ViewPrintingEventArgs Class See Also Send Feedback
When the view is being printed as a part of a view-set, the value of this property indicates the number of all views in the set.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int TotalViews { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalViews As Integer
Visual C++
public:
property int TotalViews {
    int get ();
}

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.Events Namespace


View Property

[image]

Revit 2010 API
ViewPrintingEventArgs..::.View Property
ViewPrintingEventArgs Class See Also Send Feedback
The view to be printed.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public View View { get; }
Visual Basic (Declaration)
Public ReadOnly Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
}

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.Events Namespace


Autodesk.Revit.Geometry Namespace

[image]

Revit 2010 API
Autodesk.Revit.Geometry Namespace
Send Feedback

Classes

Class | Description
Arc | A circular arc.
BoundingBoxUV | A two-dimensional rectangle, parallel to the coordinate axes.
BoundingBoxXYZ | A three-dimensional rectangular box.
ConicalFace | A cone face of a 3d solid.
Curve | A parametric curve.
CurveArrArray | An array that can contain any type of object.
CurveArrArrayIterator | An iterator to a array.
CurveArray | An array that can contain curves.
CurveArrayIterator | An iterator to a curve array.
CylindricalFace | A cylinder face of a 3d solid.
DoubleArray | An array that contains doubles.
DoubleArrayIterator | An iterator to an array of doubles.
Edge | An edge of a 3d solid.
EdgeArray | An array that contains edges.
EdgeArrayArray | An array of edge arrays.
EdgeArrayArrayIterator | An iterator to an array or edge arrays.
EdgeArrayIterator | An iterator to an edge array.
Element | Geometric representation of an element.
Ellipse | A whole or partial ellipse.
Face | A face of a 3d solid.
FaceArray | An array that contains faces.
FaceArrayIterator | An iterator to a face array.
GeometryObject | The common base class for all geometric primitives.
GeometryObjectArray | An array that contains geometry objects.
GeometryObjectArrayIterator | An iterator to a geometry object array.
HermiteFace | A cubic hermite spline face of a 3d solid.
HermiteSpline | A Hermite spline.
Instance | An instance of another element (symbol), specially positioned by this element.
InstanceArray | An array that contains instances.
InstanceArrayIterator | An iterator to an instance array.
IntersectionResult | This class captures results of intersecting geometric entities. "Intersecting" is meant in generalized sense, so the same class will be used for projection, containment, etc. Refer to the documentation of the method providing the result for the precise meaning of properties.
IntersectionResultArray | An array that can contain any type of object.
IntersectionResultArrayIterator | An iterator to a array.
Line | A line in space.
Mesh | A triangular mesh.
MeshArray | An array that contains meshes.
MeshArrayIterator | An iterator to a mesh array.
MeshTriangle | One triangle of a mesh.
NurbSpline | A nurb spline.
Options | User preferences for parsing of geometry.
PlanarFace | A planar face of a 3d solid.
Plane | Provides access to the geometry plane object.
Point | A 3D point.
Profile | A geometric profile consisting of a loop of curves.
Reference | A stable reference to a geometric object in a Revit model.
ReferenceArray |
ReferenceArrayArray | An array that contains ReferenceArray objects.
ReferenceArrayArrayIterator | An iterator to a ReferenceArray array.
ReferenceArrayIterator | An iterator to a reference array.
RevolvedFace | A revolved face of a 3d solid.
RuledFace | A ruled face of a 3d solid.
Solid | A 3d solid.
SolidArray | An array that contains solids.
SolidArrayIterator | An iterator to a solids array.
Transform | A transformation of the affine 3-space.
UV | Object representing coordinates in 2-space.
UVArray | An array that contains UV coordinates.
UVArrayIterator | An iterator to an array of UV coordinates.
XYZ | Object representing coordinates in 3-space.
XYZArray | An array that contains XYZ coordinates.
XYZArrayIterator | An iterator to an array of XYZ coordinates.

Enumerations

Enumeration | Description
Options..::.DetailLevels | Chooses the detail level of an element's representation.
Visibility | Describes the visibility of a particular geometry object.


Arc Class

[image]

Revit 2010 API
Arc Class
Members See Also Send Feedback
A circular arc.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Arc : Curve
Visual Basic (Declaration)
Public Class Arc _
    Inherits Curve
Visual C++
public ref class Arc : public Curve

Remarks

The arc lies in the plane defined by center and normal.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Curve
Autodesk.Revit.Geometry..::.Arc

See Also

Arc Members
Autodesk.Revit.Geometry Namespace


Arc Members

[image] [image]

Revit 2010 API
Arc Members
Arc Class Constructors Methods Properties See Also Send Feedback

The Arc type exposes the following members.

Constructors

Name | Description
Arc | For Internal Use Only.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Center | Returns the center of the arc.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve. (Inherited from Curve.)
Normal | Returns the normal to the plane in which the arc is defined.
Period | The period of this curve. (Inherited from Curve.)
Radius | Returns the radius of the arc.
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Arc Class
Autodesk.Revit.Geometry Namespace


Arc Constructor

[image]

Revit 2010 API
Arc Constructor
Arc Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Arc()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Arc()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Arc Class
Autodesk.Revit.Geometry Namespace


Arc Methods

[image] [image]

Revit 2010 API
Arc Methods
Arc Class See Also Send Feedback

The Arc type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Arc Class
Autodesk.Revit.Geometry Namespace


Intersect Method

[image] [image]

Revit 2010 API
Arc..::.Intersect Method
Arc Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

Arc Class
Arc Members
Autodesk.Revit.Geometry Namespace


IsInside Method

[image] [image]

Revit 2010 API
Arc..::.IsInside Method
Arc Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

Name | Description
IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)

See Also

Arc Class
Arc Members
Autodesk.Revit.Geometry Namespace


Arc Properties

[image] [image]

Revit 2010 API
Arc Properties
Arc Class See Also Send Feedback

The Arc type exposes the following members.

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Center | Returns the center of the arc.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve. (Inherited from Curve.)
Normal | Returns the normal to the plane in which the arc is defined.
Period | The period of this curve. (Inherited from Curve.)
Radius | Returns the radius of the arc.
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Arc Class
Autodesk.Revit.Geometry Namespace


Center Property

[image]

Revit 2010 API
Arc..::.Center Property
Arc Class See Also Send Feedback
Returns the center of the arc.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Center { get; }
Visual Basic (Declaration)
Public ReadOnly Property Center As XYZ
Visual C++
public:
property XYZ^ Center {
    XYZ^ get ();
}

See Also

Arc Class
Autodesk.Revit.Geometry Namespace


Normal Property

[image]

Revit 2010 API
Arc..::.Normal Property
Arc Class See Also Send Feedback
Returns the normal to the plane in which the arc is defined.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Normal { get; }
Visual Basic (Declaration)
Public ReadOnly Property Normal As XYZ
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

Arc Class
Autodesk.Revit.Geometry Namespace


Radius Property

[image]

Revit 2010 API
Arc..::.Radius Property
Arc Class See Also Send Feedback
Returns the radius of the arc.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Radius { get; }
Visual Basic (Declaration)
Public ReadOnly Property Radius As Double
Visual C++
public:
property double Radius {
    double get ();
}

See Also

Arc Class
Autodesk.Revit.Geometry Namespace


BoundingBoxUV Class

[image]

Revit 2010 API
BoundingBoxUV Class
Members Example See Also Send Feedback
A two-dimensional rectangle, parallel to the coordinate axes.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BoundingBoxUV
Visual Basic (Declaration)
Public Class BoundingBoxUV
Visual C++
public ref class BoundingBoxUV

Examples

CopyC#
Document doc = application.ActiveDocument;
ElementIterator iterator = doc.get_Elements(typeof(Autodesk.Revit.Elements.View));
iterator.Reset();
while (iterator.MoveNext())
{
    Autodesk.Revit.Elements.View view = iterator.Current as Autodesk.Revit.Elements.View;
    if (null != view)
    {
        string messageInfo = "BoundingBoxUV : ";
        messageInfo += "\nView name : " + view.Name;
        BoundingBoxUV boundingBox = view.Outline;
        // Get max bounding box
        UV max = boundingBox.Max;
        messageInfo += "\nMax boundingbox : (" + max.U + "," + max.V + ")";
        // Get min bounding box
        UV min = boundingBox.Min;
        messageInfo += "\nMin boundingbox : (" + min.U + "," + min.V + ")";
        // Get bounds,
        // Use 0 for Min and 1 for Max
        UV bound = boundingBox.get_Bounds(0);
        messageInfo += "\nBoundingbox bounds : (" + bound.U + "," + bound.V + ")";
        MessageBox.Show(messageInfo, "Revit", MessageBoxButtons.OK);
    }
}
CopyVB.NET
Dim doc As Document = application.ActiveDocument
Dim iterator As ElementIterator = doc.Elements(GetType(Autodesk.Revit.Elements.View))
iterator.Reset()
While iterator.MoveNext()
    Dim view As Autodesk.Revit.Elements.View = TryCast(iterator.Current, Autodesk.Revit.Elements.View)
    If view IsNot Nothing Then
        Dim messageInfo As String = "BoundingBoxUV : "
        messageInfo += vbLf & "View name : " & view.Name
        Dim boundingBox As BoundingBoxUV = view.Outline
        ' Get max bounding box
        Dim max As Autodesk.Revit.Geometry.UV = boundingBox.Max
        messageInfo += (vbLf & "Max boundingbox : (" & max.U & ",") + max.V & ")"
        ' Get min bounding box
        Dim min As Autodesk.Revit.Geometry.UV = boundingBox.Min
        messageInfo += (vbLf & "Min boundingbox : (" & min.U & ",") + min.V & ")"
        ' Get bounds,
        ' Use 0 for Min and 1 for Max
        Dim bound As Autodesk.Revit.Geometry.UV = boundingBox.Bounds(0)
        messageInfo += (vbLf & "Boundingbox bounds : (" & bound.U & ",") + bound.V & ")"
        MessageBox.Show(messageInfo, "Revit", MessageBoxButtons.OK)
    End If
End While

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Geometry..::.BoundingBoxUV

See Also

BoundingBoxUV Members
Autodesk.Revit.Geometry Namespace


BoundingBoxUV Members

[image] [image]

Revit 2010 API
BoundingBoxUV Members
BoundingBoxUV Class Constructors Methods Properties See Also Send Feedback

The BoundingBoxUV type exposes the following members.

Constructors

Name | Description
BoundingBoxUV | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Max | Maximum coordinates (upper-right corner of the box).
Min | Minimum coordinates (lower-left corner of the box).

See Also

BoundingBoxUV Class
Autodesk.Revit.Geometry Namespace


BoundingBoxUV Constructor

[image] [image]

Revit 2010 API
BoundingBoxUV Constructor
BoundingBoxUV Class See Also Send Feedback

Overload List

Name | Description
BoundingBoxUV()()() | default constructor
BoundingBoxUV(Double, Double, Double, Double) | Creates object with supplied values.

See Also

BoundingBoxUV Class
BoundingBoxUV Members
Autodesk.Revit.Geometry Namespace


BoundingBoxUV Constructor

[image]

Revit 2010 API
BoundingBoxUV Constructor
BoundingBoxUV Class See Also Send Feedback
default constructor

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundingBoxUV()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundingBoxUV()

See Also

BoundingBoxUV Class
BoundingBoxUV Overload
Autodesk.Revit.Geometry Namespace


BoundingBoxUV Constructor (Double, Double, Double, Double)

[image]

Revit 2010 API
BoundingBoxUV Constructor (Double, Double, Double, Double)
BoundingBoxUV Class See Also Send Feedback
Creates object with supplied values.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)
Visual Basic (Declaration)
Public Sub New ( _
    min_u As Double, _
    min_v As Double, _
    max_u As Double, _
    max_v As Double _
)
Visual C++
public:
BoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)

Parameters

min_u
Type: System..::.Double
The first coordinate of min.
min_v
Type: System..::.Double
The second coordinate of min.
max_u
Type: System..::.Double
The first coordinate of max.
max_v
Type: System..::.Double
The second coordinate of max.

See Also

BoundingBoxUV Class
BoundingBoxUV Overload
Autodesk.Revit.Geometry Namespace


BoundingBoxUV Methods

[image] [image]

Revit 2010 API
BoundingBoxUV Methods
BoundingBoxUV Class See Also Send Feedback

The BoundingBoxUV type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundingBoxUV Class
Autodesk.Revit.Geometry Namespace


BoundingBoxUV Properties

[image] [image]

Revit 2010 API
BoundingBoxUV Properties
BoundingBoxUV Class See Also Send Feedback

The BoundingBoxUV type exposes the following members.

Properties

Name | Description
Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Max | Maximum coordinates (upper-right corner of the box).
Min | Minimum coordinates (lower-left corner of the box).

See Also

BoundingBoxUV Class
Autodesk.Revit.Geometry Namespace


Bounds Property

[image]

Revit 2010 API
BoundingBoxUV..::.Bounds Property
BoundingBoxUV Class See Also Send Feedback
Indexed access for loops. Use 0 for Min and 1 for Max.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV Bounds[
    int idx
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Bounds ( _
    idx As Integer _
) As UV
Visual C++
public:
property UV^ Bounds[int idx] {
    UV^ get (int idx);
}

Parameters

idx
Type: System..::.Int32

See Also

BoundingBoxUV Class
Autodesk.Revit.Geometry Namespace


Max Property

[image]

Revit 2010 API
BoundingBoxUV..::.Max Property
BoundingBoxUV Class See Also Send Feedback
Maximum coordinates (upper-right corner of the box).

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV Max { get; set; }
Visual Basic (Declaration)
Public Property Max As UV
Visual C++
public:
property UV^ Max {
    UV^ get ();
    void set (UV^ value);
}

See Also

BoundingBoxUV Class
Autodesk.Revit.Geometry Namespace


Min Property

[image]

Revit 2010 API
BoundingBoxUV..::.Min Property
BoundingBoxUV Class See Also Send Feedback
Minimum coordinates (lower-left corner of the box).

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV Min { get; set; }
Visual Basic (Declaration)
Public Property Min As UV
Visual C++
public:
property UV^ Min {
    UV^ get ();
    void set (UV^ value);
}

See Also

BoundingBoxUV Class
Autodesk.Revit.Geometry Namespace


BoundingBoxXYZ Class

[image]

Revit 2010 API
BoundingBoxXYZ Class
Members Example See Also Send Feedback
A three-dimensional rectangular box.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BoundingBoxXYZ : APIObject
Visual Basic (Declaration)
Public Class BoundingBoxXYZ _
    Inherits APIObject
Visual C++
public ref class BoundingBoxXYZ : public APIObject

Remarks

The box is defined as follows. A Transform specifies the coordinate system in which the box is defined. The minimum and maximum values for each coordinate in that system are specified. An alternative way to construct the box is: for each basis vector of the transform, there are two planes that are orthogonal to the vector and have their origins given by Transform.Origin + BasisVector * Bound. The entire box and each face may be turned on or off.

Examples

CopyC#
Document doc = application.ActiveDocument;
View3D view3D = null;
ElementIterator iterator = doc.get_Elements(typeof(View3D));
iterator.Reset();
while (iterator.MoveNext())
{
    view3D = iterator.Current as View3D;
    if (null != view3D)
    {
        string messageInfo = "BoundingBoxXYZ : ";
        messageInfo += "\nView name : " + view3D.Name;
        BoundingBoxXYZ boundingBox = view3D.SectionBox;
        if (!boundingBox.Enabled)
        {
            boundingBox.Enabled = true;
        }
        if (boundingBox.Enabled)
        {
            // Get max boundingbox
            XYZ max = boundingBox.Max;
            messageInfo += "\nMax boundingbox : (" + max.X + ","
                + max.Y + "," + max.Z + ")";
            // Get min boundingbox
            XYZ min = boundingBox.Min;
            messageInfo += "\nMin boundingbox : (" + min.X + ","
                + min.Y + "," + min.Z + ")";
            // Get if max boundingbox enabled,
            // use 0 for X, 1 for Y and 2 for Z
            bool bMaxEnabledX = boundingBox.get_MaxEnabled(0);
            // Get if min boundingbox enabled,
            // use 0 for X, 1 for Y and 2 for Z
            bool bMinEnabledX = boundingBox.get_MinEnabled(0);
            // Get if bound boundingbox enabled
            // For bound, use 0 for Min and 1 for Max.
            // For dimension, use 0 for X, 1 for Y and 2 for Z
            bool bBoundEnabled = boundingBox.get_BoundEnabled(0, 0);
            // Get minimum bound of boundingbox
            XYZ minBound = boundingBox.get_Bounds(0);
            // Get maximum bound of boundingbox
            XYZ maxBound = boundingBox.get_Bounds(1);
        }
        MessageBox.Show(messageInfo, "Revit", MessageBoxButtons.OK);
    }
}
CopyVB.NET
Dim doc As Document = application.ActiveDocument
Dim view3D As View3D = Nothing
Dim iterator As ElementIterator = doc.Elements(GetType(View3D))
iterator.Reset()
While iterator.MoveNext()
    view3D = TryCast(iterator.Current, View3D)
    If view3D IsNot Nothing Then
        Dim messageInfo As String = "BoundingBoxXYZ : "
        messageInfo += vbLf & "View name : " & view3D.Name
        Dim boundingBox As BoundingBoxXYZ = view3D.SectionBox
        If Not boundingBox.Enabled Then
            boundingBox.Enabled = True
        End If
        If boundingBox.Enabled Then
            ' Get max boundingbox
            Dim max As Autodesk.Revit.Geometry.XYZ = boundingBox.Max
            messageInfo += ((vbLf & "Max boundingbox : (" & max.X & ",") + max.Y & ",") + max.Z & ")"
            ' Get min boundingbox
            Dim min As Autodesk.Revit.Geometry.XYZ = boundingBox.Min
            messageInfo += ((vbLf & "Min boundingbox : (" & min.X & ",") + min.Y & ",") + min.Z & ")"
            Dim bMaxEnabledX As Boolean = boundingBox.MaxEnabled(0)
            ' Get if min boundingbox enabled,
            ' use 0 for X, 1 for Y and 2 for Z
            Dim bMinEnabledX As Boolean = boundingBox.MinEnabled(0)
            ' Get if bound boundingbox enabled
            ' For bound, use 0 for Min and 1 for Max.
            ' For dimension, use 0 for X, 1 for Y and 2 for Z
            Dim bBoundEnabled As Boolean = boundingBox.BoundEnabled(0, 0)
            ' Get minimum bound of boundingbox
            Dim minBound As Autodesk.Revit.Geometry.XYZ = boundingBox.Bounds(0)
            ' Get maximum bound of boundingbox
            Dim maxBound As Autodesk.Revit.Geometry.XYZ = boundingBox.Bounds(1)
        End If
        MessageBox.Show(messageInfo, "Revit", MessageBoxButtons.OK)
    End If
End While

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.BoundingBoxXYZ

See Also

BoundingBoxXYZ Members
Autodesk.Revit.Geometry Namespace


BoundingBoxXYZ Members

[image] [image]

Revit 2010 API
BoundingBoxXYZ Members
BoundingBoxXYZ Class Constructors Methods Properties See Also Send Feedback

The BoundingBoxXYZ type exposes the following members.

Constructors

Name | Description
BoundingBoxXYZ | Initializes a new instance of the BoundingBoxXYZ class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundEnabled | Indexed access for loops.
Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Enabled | Defines whether bounding box is turned on.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Max | Maximum coordinates (upper-right-front corner of the box).
MaxEnabled | Defines whether the maximum bound is active for given dimension.
Min | Minimum coordinates (lower-left-rear corner of the box).
MinEnabled | Defines whether the minimum bound is active for given dimension.
Transform | The transform FROM the coordinate space of the box TO the model space.

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


BoundingBoxXYZ Constructor

[image]

Revit 2010 API
BoundingBoxXYZ Constructor
BoundingBoxXYZ Class See Also Send Feedback
Initializes a new instance of the BoundingBoxXYZ class

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundingBoxXYZ()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundingBoxXYZ()

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


BoundingBoxXYZ Methods

[image] [image]

Revit 2010 API
BoundingBoxXYZ Methods
BoundingBoxXYZ Class See Also Send Feedback

The BoundingBoxXYZ type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


BoundingBoxXYZ Properties

[image] [image]

Revit 2010 API
BoundingBoxXYZ Properties
BoundingBoxXYZ Class See Also Send Feedback

The BoundingBoxXYZ type exposes the following members.

Properties

Name | Description
BoundEnabled | Indexed access for loops.
Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Enabled | Defines whether bounding box is turned on.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Max | Maximum coordinates (upper-right-front corner of the box).
MaxEnabled | Defines whether the maximum bound is active for given dimension.
Min | Minimum coordinates (lower-left-rear corner of the box).
MinEnabled | Defines whether the minimum bound is active for given dimension.
Transform | The transform FROM the coordinate space of the box TO the model space.

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


BoundEnabled Property

[image]

Revit 2010 API
BoundingBoxXYZ..::.BoundEnabled Property
BoundingBoxXYZ Class See Also Send Feedback
Indexed access for loops.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool BoundEnabled[
    int bound,
    int dim
] { get; set; }
Visual Basic (Declaration)
Public Property BoundEnabled ( _
    bound As Integer, _
    dim As Integer _
) As Boolean
Visual C++
public:
property bool BoundEnabled[int bound, int dim] {
    bool get (int bound, int dim);
    void set (int bound, int dim, bool value);
}

Parameters

bound
Type: System..::.Int32
dim
Type: System..::.Int32

Remarks

For bound, use 0 for Min and 1 for Max. For dimension, use 0 for X, 1 for Y and 2 for Z. The entire box must be enabled to enable individual bounds!

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


Bounds Property

[image]

Revit 2010 API
BoundingBoxXYZ..::.Bounds Property
BoundingBoxXYZ Class See Also Send Feedback
Indexed access for loops. Use 0 for Min and 1 for Max.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Bounds[
    int bound
] { get; set; }
Visual Basic (Declaration)
Public Property Bounds ( _
    bound As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Bounds[int bound] {
    XYZ^ get (int bound);
    void set (int bound, XYZ^ value);
}

Parameters

bound
Type: System..::.Int32

Remarks

The bounds are defined in the coordinate space of the box!

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


Enabled Property

[image]

Revit 2010 API
BoundingBoxXYZ..::.Enabled Property
BoundingBoxXYZ Class See Also Send Feedback
Defines whether bounding box is turned on.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


Max Property

[image]

Revit 2010 API
BoundingBoxXYZ..::.Max Property
BoundingBoxXYZ Class See Also Send Feedback
Maximum coordinates (upper-right-front corner of the box).

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Max { get; set; }
Visual Basic (Declaration)
Public Property Max As XYZ
Visual C++
public:
property XYZ^ Max {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The bounds are defined in the coordinate space of the box!

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


MaxEnabled Property

[image]

Revit 2010 API
BoundingBoxXYZ..::.MaxEnabled Property
BoundingBoxXYZ Class See Also Send Feedback
Defines whether the maximum bound is active for given dimension.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool MaxEnabled[
    int dim
] { get; set; }
Visual Basic (Declaration)
Public Property MaxEnabled ( _
    dim As Integer _
) As Boolean
Visual C++
public:
property bool MaxEnabled[int dim] {
    bool get (int dim);
    void set (int dim, bool value);
}

Parameters

dim
Type: System..::.Int32

Remarks

Use 0 for X, 1 for Y and 2 for Z. The entire box must be enabled to enable individual bounds!

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


Min Property

[image]

Revit 2010 API
BoundingBoxXYZ..::.Min Property
BoundingBoxXYZ Class See Also Send Feedback
Minimum coordinates (lower-left-rear corner of the box).

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Min { get; set; }
Visual Basic (Declaration)
Public Property Min As XYZ
Visual C++
public:
property XYZ^ Min {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The bounds are defined in the coordinate space of the box!

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


MinEnabled Property

[image]

Revit 2010 API
BoundingBoxXYZ..::.MinEnabled Property
BoundingBoxXYZ Class See Also Send Feedback
Defines whether the minimum bound is active for given dimension.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool MinEnabled[
    int dim
] { get; set; }
Visual Basic (Declaration)
Public Property MinEnabled ( _
    dim As Integer _
) As Boolean
Visual C++
public:
property bool MinEnabled[int dim] {
    bool get (int dim);
    void set (int dim, bool value);
}

Parameters

dim
Type: System..::.Int32

Remarks

Use 0 for X, 1 for Y and 2 for Z. The entire box must be enabled to enable individual bounds!

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


Transform Property

[image]

Revit 2010 API
BoundingBoxXYZ..::.Transform Property
BoundingBoxXYZ Class Example See Also Send Feedback
The transform FROM the coordinate space of the box TO the model space.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Transform Transform { get; set; }
Visual Basic (Declaration)
Public Property Transform As Transform
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
    void set (Transform^ value);
}

Remarks

The transform must always be right-handed and orthonormal.

Examples

CopyC#
private void RotateBoundingBox(View3D view3d)
{
    BoundingBoxXYZ box = view3d.SectionBox;
    if (false == box.Enabled)
    {
        MessageBox.Show("The section box for View3D isn't Enable.");
        return;
    }
    // Create a rotation transform,
    XYZ origin = new XYZ(0, 0, 0);
    XYZ axis = new XYZ(0, 0, 1);
    Transform rotate = Transform.get_Rotation(origin, axis, 2);
    // Transform the View3D's SectionBox with the rotation transfrom
    box.Transform = box.Transform.Multiply(rotate);
    view3d.SectionBox = box;
}
CopyVB.NET
Private Sub RotateBoundingBox(ByVal view3d As View3D)
    Dim box As BoundingBoxXYZ = view3d.SectionBox
    If False = box.Enabled Then
        MessageBox.Show("The section box for View3D isn't Enable.")
        Exit Sub
    End If
    ' Create a rotation transform,
    Dim origin As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
    Dim axis As New Autodesk.Revit.Geometry.XYZ(0, 0, 1)
    Dim rotate As Transform = Transform.Rotation(origin, axis, 2)
    ' Transform the View3D's SectionBox with the rotation transfrom
    box.Transform = box.Transform.Multiply(rotate)
    view3d.SectionBox = box
End Sub

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace


ConicalFace Class

[image]

Revit 2010 API
ConicalFace Class
Members Example See Also Send Feedback
A cone face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ConicalFace : Face
Visual Basic (Declaration)
Public Class ConicalFace _
    Inherits Face
Visual C++
public ref class ConicalFace : public Face

Remarks

Cone faces are defined by cone surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces. S(u, v) = Origin + v*[sin(HalfAngle)*(cos(u)*Radius[0] + sin(u)*Radius[1]) + cos(HalfAngle)*Axis]

Examples

CopyC#
private void GetConicalFaceInfo(Face face)
{
    ConicalFace conicalFace = face as ConicalFace;
    if (null != conicalFace)
    {
        XYZ axis = conicalFace.Axis;
        XYZ origin = conicalFace.Origin;
        double halfAngle = conicalFace.HalfAngle;
        XYZ radius = conicalFace.get_Radius(0);
    }
}
CopyVB.NET
Private Sub GetConicalFaceInfo(ByVal face As Autodesk.Revit.Geometry.Face)
    Dim conicalFace As ConicalFace = TryCast(face, ConicalFace)
    If conicalFace IsNot Nothing Then
        Dim axis As Autodesk.Revit.Geometry.XYZ = conicalFace.Axis
        Dim origin As Autodesk.Revit.Geometry.XYZ = conicalFace.Origin
        Dim halfAngle As Double = conicalFace.HalfAngle
        Dim radius As Autodesk.Revit.Geometry.XYZ = conicalFace.Radius(0)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Face
Autodesk.Revit.Geometry..::.ConicalFace

See Also

ConicalFace Members
Autodesk.Revit.Geometry Namespace


ConicalFace Members

[image] [image]

Revit 2010 API
ConicalFace Members
ConicalFace Class Constructors Methods Properties See Also Send Feedback

The ConicalFace type exposes the following members.

Constructors

Name | Description
ConicalFace | For Internal Use Only.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
Axis | Axis of the surface.
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
HalfAngle | Half angle of the surface.
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Origin | Origin of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Radius | Radii of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

ConicalFace Class
Autodesk.Revit.Geometry Namespace


ConicalFace Constructor

[image]

Revit 2010 API
ConicalFace Constructor
ConicalFace Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ConicalFace()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConicalFace()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ConicalFace Class
Autodesk.Revit.Geometry Namespace


ConicalFace Methods

[image] [image]

Revit 2010 API
ConicalFace Methods
ConicalFace Class See Also Send Feedback

The ConicalFace type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

ConicalFace Class
Autodesk.Revit.Geometry Namespace


Intersect Method

[image] [image]

Revit 2010 API
ConicalFace..::.Intersect Method
ConicalFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

ConicalFace Class
ConicalFace Members
Autodesk.Revit.Geometry Namespace


IsInside Method

[image] [image]

Revit 2010 API
ConicalFace..::.IsInside Method
ConicalFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

Name | Description
IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)

See Also

ConicalFace Class
ConicalFace Members
Autodesk.Revit.Geometry Namespace


ConicalFace Properties

[image] [image]

Revit 2010 API
ConicalFace Properties
ConicalFace Class See Also Send Feedback

The ConicalFace type exposes the following members.

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
Axis | Axis of the surface.
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
HalfAngle | Half angle of the surface.
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Origin | Origin of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Radius | Radii of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

ConicalFace Class
Autodesk.Revit.Geometry Namespace


Axis Property

[image]

Revit 2010 API
ConicalFace..::.Axis Property
ConicalFace Class See Also Send Feedback
Axis of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Axis { get; }
Visual Basic (Declaration)
Public ReadOnly Property Axis As XYZ
Visual C++
public:
property XYZ^ Axis {
    XYZ^ get ();
}

See Also

ConicalFace Class
Autodesk.Revit.Geometry Namespace


HalfAngle Property

[image]

Revit 2010 API
ConicalFace..::.HalfAngle Property
ConicalFace Class See Also Send Feedback
Half angle of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double HalfAngle { get; }
Visual Basic (Declaration)
Public ReadOnly Property HalfAngle As Double
Visual C++
public:
property double HalfAngle {
    double get ();
}

See Also

ConicalFace Class
Autodesk.Revit.Geometry Namespace


Origin Property

[image]

Revit 2010 API
ConicalFace..::.Origin Property
ConicalFace Class See Also Send Feedback
Origin of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

ConicalFace Class
Autodesk.Revit.Geometry Namespace


Radius Property

[image]

Revit 2010 API
ConicalFace..::.Radius Property
ConicalFace Class See Also Send Feedback
Radii of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Radius[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Radius ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Radius[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

ConicalFace Class
Autodesk.Revit.Geometry Namespace


Curve Class

[image]

Revit 2010 API
Curve Class
Members See Also Send Feedback
A parametric curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Curve : GeometryObject
Visual Basic (Declaration)
Public Class Curve _
    Inherits GeometryObject
Visual C++
public ref class Curve : public GeometryObject

Remarks

The concrete curves are defined by parametric equations. If the curve is bound, it is only defined for an interval in parametrization. Otherwise, it is defined for all values of the parameter.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Curve
Autodesk.Revit.Geometry..::.Arc
Autodesk.Revit.Geometry..::.Ellipse
Autodesk.Revit.Geometry..::.HermiteSpline
Autodesk.Revit.Geometry..::.Line
Autodesk.Revit.Geometry..::.NurbSpline

See Also

Curve Members
Autodesk.Revit.Geometry Namespace


Curve Members

[image] [image]

Revit 2010 API
Curve Members
Curve Class Constructors Methods Properties See Also Send Feedback

The Curve type exposes the following members.

Constructors

Name | Description
Curve | For Internal Use Only.

Methods

Name | Description
Clone | Returns a copy of this curve.
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter.
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter.
ComputeRawParameter | Computes the raw parameter from the normalized parameter.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values.
MakeUnbound | Makes this curve unbound.
Project | Projects the specified point on this curve.
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApproximateLength | The approximate length of the curve.
EndParameter | The parameter of the start or the end point of the curve.
EndPoint | The start or the end point of this curve.
EndPointReference | Returns a stable reference to the start point or the end point of the curve.
IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
IsCyclic | The boolean value that indicates whether this curve is cyclic.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve.
Period | The period of this curve.
Reference | Returns a stable reference to the curve.
Transformed | Applies the specified transformation to this curve and returns the result.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Curve Constructor

[image]

Revit 2010 API
Curve Constructor
Curve Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Curve()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Curve Methods

[image] [image]

Revit 2010 API
Curve Methods
Curve Class See Also Send Feedback

The Curve type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve.
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter.
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter.
ComputeRawParameter | Computes the raw parameter from the normalized parameter.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values.
MakeUnbound | Makes this curve unbound.
Project | Projects the specified point on this curve.
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Clone Method

[image]

Revit 2010 API
Curve..::.Clone Method
Curve Class See Also Send Feedback
Returns a copy of this curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve Clone()
Visual Basic (Declaration)
Public Function Clone As Curve
Visual C++
public:
Curve^ Clone()

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


ComputeDerivatives Method

[image]

Revit 2010 API
Curve..::.ComputeDerivatives Method
Curve Class See Also Send Feedback
Returns the moving frame around the curve at the specified parameter.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Transform ComputeDerivatives(
    double parameter,
    bool normalized
)
Visual Basic (Declaration)
Public Function ComputeDerivatives ( _
    parameter As Double, _
    normalized As Boolean _
) As Transform
Visual C++
public:
Transform^ ComputeDerivatives(
    double parameter,
    bool normalized
)

Parameters

parameter
Type: System..::.Double
The parameter to be evaluated.
normalized
Type: System..::.Boolean
Indicates that the specified parameter is normalized.

Return Value

The transformation that represents the moving frame.

Remarks

The following is the meaning of the transformation members: Origin is the point on the curve (equivalent to Evaluate); BasisX is the tangent vector (the first derivative); BasisY is the normal vector (the second derivative); BasisZ is the bi-normal vector (tangent x normal). Normal and bi-normal are zero if the curve is straight at the point. None of the vectors are normalized.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when the specified parameter is infinite.
System..::.ArgumentOutOfRangeException | Thrown when normalized is true and this curve is unbound or the parameter is not within [0, 1] interval.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


ComputeNormalizedParameter Method

[image]

Revit 2010 API
Curve..::.ComputeNormalizedParameter Method
Curve Class See Also Send Feedback
Computes the normalized curve parameter from the raw parameter.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ComputeNormalizedParameter(
    double rawParameter
)
Visual Basic (Declaration)
Public Function ComputeNormalizedParameter ( _
    rawParameter As Double _
) As Double
Visual C++
public:
double ComputeNormalizedParameter(
    double rawParameter
)

Parameters

rawParameter
Type: System..::.Double
The raw parameter.

Return Value

The real number equal to the normalized curve parameter.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when rawParameter is infinite.
System..::.InvalidOperationException | Thrown when the curve is unbound.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


ComputeRawParameter Method

[image]

Revit 2010 API
Curve..::.ComputeRawParameter Method
Curve Class See Also Send Feedback
Computes the raw parameter from the normalized parameter.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ComputeRawParameter(
    double normalizedParameter
)
Visual Basic (Declaration)
Public Function ComputeRawParameter ( _
    normalizedParameter As Double _
) As Double
Visual C++
public:
double ComputeRawParameter(
    double normalizedParameter
)

Parameters

normalizedParameter
Type: System..::.Double
The normalized parameter.

Return Value

The real number equal to the raw curve parameter.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when normalizedParameter is infinite.
System..::.InvalidOperationException | Thrown when the curve is unbound.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Distance Method

[image]

Revit 2010 API
Curve..::.Distance Method
Curve Class See Also Send Feedback
Returns the shortest distance from the specified point to this curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Distance(
    XYZ point
)
Visual Basic (Declaration)
Public Function Distance ( _
    point As XYZ _
) As Double
Visual C++
public:
double Distance(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
The specified point.

Return Value

The real number equal to the shortest distance.

Remarks

Returns the distance from the closest point on the curve to the specified point.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when failed to find the closest point on the curve.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Evaluate Method

[image]

Revit 2010 API
Curve..::.Evaluate Method
Curve Class See Also Send Feedback
Evaluates a parameter on the curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Evaluate(
    double param,
    bool normalized
)
Visual Basic (Declaration)
Public Function Evaluate ( _
    param As Double, _
    normalized As Boolean _
) As XYZ
Visual C++
public:
XYZ^ Evaluate(
    double param,
    bool normalized
)

Parameters

param
Type: System..::.Double
The parameter to be evaluated.
normalized
Type: System..::.Boolean
If false, param is interpreted as natural parametrization of the curve. If true, param is expected to be in [0,1] interval mapped to the bounds of the curve. Setting to true is valid only if the curve is bound.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Intersect Method

[image] [image]

Revit 2010 API
Curve..::.Intersect Method
Curve Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of this curve with the specified curve.
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results.

See Also

Curve Class
Curve Members
Autodesk.Revit.Geometry Namespace


Intersect Method (Curve)

[image]

Revit 2010 API
Curve..::.Intersect Method (Curve)
Curve Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve
)
Visual Basic (Declaration)
Public Function Intersect ( _
    curve As Curve _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
The specified curve to intersect with this curve.

Return Value

  • SetComparisonResult.Overlap - One or more intersections were encountered.
  • SetComparisonResult.Subset - The inputs are parallel lines with only one common intersection point, or the curve used to invoke the intersection check is a line entirely within the unbound line passed as argument curve.
  • SetComparisonResult.Superset - The input curve is entirely within the unbound line used to invoke the intersection check.
  • SetComparisonResult.Disjoint - There is no intersection found between the two curves.
  • SetComparisonResult.Equal - The two curves are identical.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The specified curve is null.
System..::.InvalidOperationException | Failed to calculate the intersection.

See Also

Curve Class
Intersect Overload
Autodesk.Revit.Geometry Namespace


Intersect Method (Curve, IntersectionResultArray)

[image]

Revit 2010 API
Curve..::.Intersect Method (Curve, IntersectionResultArray%)
Curve Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve and returns the intersection results.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve,
    out IntersectionResultArray resultArray
)
Visual Basic (Declaration)
Public Function Intersect ( _
    curve As Curve, _
    <OutAttribute> ByRef resultArray As IntersectionResultArray _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect(
    Curve^ curve,
    [OutAttribute] IntersectionResultArray^% resultArray
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
The specified curve to intersect with this curve.
resultArray
Type: Autodesk.Revit.Geometry..::.IntersectionResultArray %
Provides more information about the intersection.

Return Value

  • SetComparisonResult.Overlap - One or more intersections were encountered. The output argument has the details.
  • SetComparisonResult.Subset - The inputs are parallel lines with only one common intersection point, or the curve used to invoke the intersection check is a line entirely within the unbound line passed as argument curve. If the former, the output argument has the details of the intersection point.
  • SetComparisonResult.Superset - The input curve is entirely within the unbound line used to invoke the intersection check.
  • SetComparisonResult.Disjoint - There is no intersection found between the two curves.
  • SetComparisonResult.Equal - The two curves are identical.

Remarks

The array of the intersection results contains one entry for each point where curves intersect. The following is the meaning of IntersectionResult members:
  • XYZPoint is the evaluated intersection point
  • UVPoint.U is the unnormalized parameter on this curve (use ComputeNormalizedParameter to compute the normalized value).
  • UVPoint.V is the unnormalized parameter on the specified curve (use ComputeNormalizedParameter to compute the normalized value).

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified curve is null.
System..::.InvalidOperationException | Thrown when failed to calculate the intersection.

See Also

Curve Class
Intersect Overload
Autodesk.Revit.Geometry Namespace


IsInside Method

[image] [image]

Revit 2010 API
Curve..::.IsInside Method
Curve Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

Name | Description
IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds.
IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.

See Also

Curve Class
Curve Members
Autodesk.Revit.Geometry Namespace


IsInside Method (Double)

[image]

Revit 2010 API
Curve..::.IsInside Method (Double)
Curve Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsInside(
    double parameter
)
Visual Basic (Declaration)
Public Function IsInside ( _
    parameter As Double _
) As Boolean
Visual C++
public:
bool IsInside(
    double parameter
)

Parameters

parameter
Type: System..::.Double
The raw curve parameter to be evaluated.

Return Value

True if the parameter is within the bounds, otherwise false.

Remarks

Always returns true if this curve is unbound.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when the specified parameter is infinite.

See Also

Curve Class
IsInside Overload
Autodesk.Revit.Geometry Namespace


IsInside Method (Double, Int32)

[image]

Revit 2010 API
Curve..::.IsInside Method (Double, Int32%)
Curve Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsInside(
    double parameter,
    out int end
)
Visual Basic (Declaration)
Public Function IsInside ( _
    parameter As Double, _
    <OutAttribute> ByRef end As Integer _
) As Boolean
Visual C++
public:
bool IsInside(
    double parameter,
    [OutAttribute] int% end
)

Parameters

parameter
Type: System..::.Double
The raw curve parameter to be evaluated.
end
Type: System..::.Int32 %
The end index is equal to 0 for the start point, 1 for the end point, or -1 if the parameter is not at the end.

Return Value

True if the parameter is within the curve's bounds, otherwise false.

Remarks

Always returns true if this curve is unbound.

See Also

Curve Class
IsInside Overload
Autodesk.Revit.Geometry Namespace


MakeBound Method

[image]

Revit 2010 API
Curve..::.MakeBound Method
Curve Class See Also Send Feedback
Changes the bounds of this curve to the specified values.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void MakeBound(
    double startParameter,
    double endParameter
)
Visual Basic (Declaration)
Public Sub MakeBound ( _
    startParameter As Double, _
    endParameter As Double _
)
Visual C++
public:
void MakeBound(
    double startParameter,
    double endParameter
)

Parameters

startParameter
Type: System..::.Double
The new parameter of the start point.
endParameter
Type: System..::.Double
The new parameter of the end point.

Remarks

This method changes this curve to bound.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when the specified values are infinite.
System..::.InvalidOperationException | Thrown when endParameter is smaller than startParameter, or the object is internally marked as read-only.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


MakeUnbound Method

[image]

Revit 2010 API
Curve..::.MakeUnbound Method
Curve Class See Also Send Feedback
Makes this curve unbound.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void MakeUnbound()
Visual Basic (Declaration)
Public Sub MakeUnbound
Visual C++
public:
void MakeUnbound()

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the object is internally marked as read-only.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Project Method

[image]

Revit 2010 API
Curve..::.Project Method
Curve Class See Also Send Feedback
Projects the specified point on this curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public IntersectionResult Project(
    XYZ point
)
Visual Basic (Declaration)
Public Function Project ( _
    point As XYZ _
) As IntersectionResult
Visual C++
public:
IntersectionResult^ Project(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
The point to be projected.

Return Value

Geometric information if projection is successful.

Remarks

The following is the meaning of every IntersectionResult's members:
  • XYZPoint is the nearest point on the curve;
  • Parameter is the unnormalized parameter on the curve (use ComputeNormalizedParameter to compute the normalized value)
  • Distance is the distance from the point to the curve (equivalent to Distance).

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when failed to find the closest point on the curve.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Tessellate Method

[image]

Revit 2010 API
Curve..::.Tessellate Method
Curve Class See Also Send Feedback
Valid only if the curve is bound. Returns a polyline approximation to the curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZArray Tessellate()
Visual Basic (Declaration)
Public Function Tessellate As XYZArray
Visual C++
public:
XYZArray^ Tessellate()

Remarks

Tolerance of approximation is defined internally by Revit to be adequate for display purposes.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Curve Properties

[image] [image]

Revit 2010 API
Curve Properties
Curve Class See Also Send Feedback

The Curve type exposes the following members.

Properties

Name | Description
ApproximateLength | The approximate length of the curve.
EndParameter | The parameter of the start or the end point of the curve.
EndPoint | The start or the end point of this curve.
EndPointReference | Returns a stable reference to the start point or the end point of the curve.
IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
IsCyclic | The boolean value that indicates whether this curve is cyclic.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve.
Period | The period of this curve.
Reference | Returns a stable reference to the curve.
Transformed | Applies the specified transformation to this curve and returns the result.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


ApproximateLength Property

[image]

Revit 2010 API
Curve..::.ApproximateLength Property
Curve Class See Also Send Feedback
The approximate length of the curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ApproximateLength { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApproximateLength As Double
Visual C++
public:
property double ApproximateLength {
    double get ();
}

Remarks

Quickly estimates the length of the curve, may deviate by a factor of 2 in some cases. The computation is exact for lines and arcs.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the curve is unbound and not periodic.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


EndParameter Property

[image]

Revit 2010 API
Curve..::.EndParameter Property
Curve Class See Also Send Feedback
The parameter of the start or the end point of the curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double EndParameter[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Property EndParameter ( _
    index As Integer _
) As Double
Visual C++
public:
property double EndParameter[int index] {
    double get (int index);
    void set (int index, double value);
}

Parameters

index
Type: System..::.Int32
Use 0 for the start point; 1 for the end point.

Exceptions

Exception | Condition
System..::.IndexOutOfRangeException | Thrown when the specified index is not 0 or 1 both in the getter and setter.
System..::.InvalidOperationException | Thrown when the specified parameter is not within curve bounds in the setter, or the object is internally marked as read-only in the setter, or the curve is unbound both in the getter and setter.
System..::.NotFiniteNumberException | Thrown when the value of parameter is infinite in the setter.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


EndPoint Property

[image]

Revit 2010 API
Curve..::.EndPoint Property
Curve Class See Also Send Feedback
The start or the end point of this curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ EndPoint[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndPoint ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ EndPoint[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32
Use 0 for the start point; 1 for the end point.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when this curve is unbound.
System..::.IndexOutOfRangeException | Thrown when the specified index is not 0 or 1.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


EndPointReference Property

[image]

Revit 2010 API
Curve..::.EndPointReference Property
Curve Class See Also Send Feedback
Returns a stable reference to the start point or the end point of the curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference EndPointReference[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndPointReference ( _
    index As Integer _
) As Reference
Visual C++
public:
property Reference^ EndPointReference[int index] {
    Reference^ get (int index);
}

Parameters

index
Type: System..::.Int32
Use 0 for the start point; 1 for the end point.

Return Value

Reference to the point or nullptr if reference cannot be obtained.

Exceptions

Exception | Condition
System..::.IndexOutOfRangeException | Thrown when the specified index is not 0 or 1.
System..::.InvalidOperationException | Thrown when the object is internally marked as read-only or this curve is unbound.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


IsBound Property

[image]

Revit 2010 API
Curve..::.IsBound Property
Curve Class See Also Send Feedback
Describes whether the parameter of the curve is restricted to a particular interval.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsBound { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsBound As Boolean
Visual C++
public:
property bool IsBound {
    bool get ();
}

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


IsCyclic Property

[image]

Revit 2010 API
Curve..::.IsCyclic Property
Curve Class See Also Send Feedback
The boolean value that indicates whether this curve is cyclic.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsCyclic { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCyclic As Boolean
Visual C++
public:
property bool IsCyclic {
    bool get ();
}

Return Value

True if this curve is cyclic; otherwise, false.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Length Property

[image]

Revit 2010 API
Curve..::.Length Property
Curve Class See Also Send Feedback
The exact length of the curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Double
Visual C++
public:
property double Length {
    double get ();
}

Remarks

Computes the length of the curve using analytical or numeric integration. There is no performance hit for lines and arcs.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the curve is unbound and not periodic.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Period Property

[image]

Revit 2010 API
Curve..::.Period Property
Curve Class See Also Send Feedback
The period of this curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Period { get; }
Visual Basic (Declaration)
Public ReadOnly Property Period As Double
Visual C++
public:
property double Period {
    double get ();
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the curve is not cyclic.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Reference Property

[image]

Revit 2010 API
Curve..::.Reference Property
Curve Class See Also Send Feedback
Returns a stable reference to the curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference Reference { get; }
Visual Basic (Declaration)
Public ReadOnly Property Reference As Reference
Visual C++
public:
property Reference^ Reference {
    Reference^ get ();
}

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


Transformed Property

[image]

Revit 2010 API
Curve..::.Transformed Property
Curve Class Example See Also Send Feedback
Applies the specified transformation to this curve and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve Transformed[
    Transform transform
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Transformed ( _
    transform As Transform _
) As Curve
Visual C++
public:
property Curve^ Transformed[Transform^ transform] {
    Curve^ get (Transform^ transform);
}

Parameters

transform
Type: Autodesk.Revit.Geometry..::.Transform
The transformation to be applied.

Return Value

The transformed curve.

Examples

CopyC#
public void GetAndTransformCurve(Autodesk.Revit.Application app, Autodesk.Revit.Element element, Options geoOptions)
{
    // Get geometry element of the selected element
    Autodesk.Revit.Geometry.Element geoElement = element.get_Geometry(geoOptions);

    // Get geometry object
    foreach (GeometryObject geoObject in geoElement.Objects)
    {
        // Get the geometry instance which contains the geometry information
        Autodesk.Revit.Geometry.Instance instance = geoObject as Autodesk.Revit.Geometry.Instance;
        if (null != instance)
        {
            foreach (GeometryObject o in instance.SymbolGeometry.Objects)
            {
                // Get curve
                Curve curve = o as Curve;
                if (curve != null)
                {
                    // transfrom the curve to make it in the instance's coordinate space
                    curve = curve.get_Transformed(instance.Transform);
                }
            }
        }
    }
}
CopyVB.NET
Public Sub GetAndTransformCurve(ByVal app As Autodesk.Revit.Application, ByVal element As Autodesk.Revit.Element, ByVal geoOptions As Autodesk.Revit.Geometry.Options)
    ' Get geometry element of the selected element
    Dim geoElement As Autodesk.Revit.Geometry.Element = element.Geometry(geoOptions)

    ' Get geometry object
    For Each geoObject As GeometryObject In geoElement.Objects
        ' Get the geometry instance which contains the geometry information
        Dim instance As Autodesk.Revit.Geometry.Instance = TryCast(geoObject, Autodesk.Revit.Geometry.Instance)
        If instance IsNot Nothing Then
            For Each o As GeometryObject In instance.SymbolGeometry.Objects
                ' Get curve
                Dim curve As Curve = TryCast(o, Curve)
                If curve IsNot Nothing Then
                    ' transfrom the curve to make it in the instance's coordinate space
                    curve = curve.Transformed(instance.Transform)
                End If
            Next
        End If
    Next
End Sub

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified transformation is null.
System..::.InvalidOperationException | Thrown when the transformation is not valid or the transformation application fails.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace


CurveArrArray Class

[image]

Revit 2010 API
CurveArrArray Class
Members See Also Send Feedback
An array that can contain any type of object.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CurveArrArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class CurveArrArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurveArrArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.CurveArrArray

See Also

CurveArrArray Members
Autodesk.Revit.Geometry Namespace


CurveArrArray Members

[image] [image]

Revit 2010 API
CurveArrArray Members
CurveArrArray Class Constructors Methods Properties See Also Send Feedback

The CurveArrArray type exposes the following members.

Constructors

Name | Description
CurveArrArray | Initializes a new instance of the CurveArrArray class

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


CurveArrArray Constructor

[image]

Revit 2010 API
CurveArrArray Constructor
CurveArrArray Class See Also Send Feedback
Initializes a new instance of the CurveArrArray class

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArrArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurveArrArray()

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


CurveArrArray Methods

[image] [image]

Revit 2010 API
CurveArrArray Methods
CurveArrArray Class See Also Send Feedback

The CurveArrArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


Append Method

[image]

Revit 2010 API
CurveArrArray..::.Append Method
CurveArrArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    CurveArray item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As CurveArray _
)
Visual C++
public:
virtual void Append(
    CurveArray^ item
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.CurveArray

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

[image]

Revit 2010 API
CurveArrArray..::.Clear Method
CurveArrArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

[image]

Revit 2010 API
CurveArrArray..::.ForwardIterator Method
CurveArrArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CurveArrArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CurveArrArrayIterator
Visual C++
public:
virtual CurveArrArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

[image]

Revit 2010 API
CurveArrArray..::.GetEnumerator Method
CurveArrArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

[image]

Revit 2010 API
CurveArrArray..::.Insert Method
CurveArrArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    CurveArray item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As CurveArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    CurveArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.CurveArray
index
Type: System..::.Int32

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

[image]

Revit 2010 API
CurveArrArray..::.ReverseIterator Method
CurveArrArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CurveArrArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CurveArrArrayIterator
Visual C++
public:
virtual CurveArrArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


CurveArrArray Properties

[image] [image]

Revit 2010 API
CurveArrArray Properties
CurveArrArray Class See Also Send Feedback

The CurveArrArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


IsEmpty Property

[image]

Revit 2010 API
CurveArrArray..::.IsEmpty Property
CurveArrArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


Item Property

[image]

Revit 2010 API
CurveArrArray..::.Item Property
CurveArrArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CurveArray Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As CurveArray
Visual C++
public:
virtual property CurveArray^ Item[int index] {
    CurveArray^ get (int index);
    void set (int index, CurveArray^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


Size Property

[image]

Revit 2010 API
CurveArrArray..::.Size Property
CurveArrArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurveArrArray Class
Autodesk.Revit.Geometry Namespace


CurveArrArrayIterator Class

[image]

Revit 2010 API
CurveArrArrayIterator Class
Members See Also Send Feedback
An iterator to a array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class CurveArrArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CurveArrArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CurveArrArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.CurveArrArrayIterator

See Also

CurveArrArrayIterator Members
Autodesk.Revit.Geometry Namespace


CurveArrArrayIterator Members

[image] [image]

Revit 2010 API
CurveArrArrayIterator Members
CurveArrArrayIterator Class Constructors Methods Properties See Also Send Feedback

The CurveArrArrayIterator type exposes the following members.

Constructors

Name | Description
CurveArrArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveArrArrayIterator Class
Autodesk.Revit.Geometry Namespace


CurveArrArrayIterator Constructor

[image]

Revit 2010 API
CurveArrArrayIterator Constructor
CurveArrArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArrArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurveArrArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurveArrArrayIterator Class
Autodesk.Revit.Geometry Namespace


CurveArrArrayIterator Methods

[image] [image]

Revit 2010 API
CurveArrArrayIterator Methods
CurveArrArrayIterator Class See Also Send Feedback

The CurveArrArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveArrArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

[image]

Revit 2010 API
CurveArrArrayIterator..::.MoveNext Method
CurveArrArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurveArrArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

[image]

Revit 2010 API
CurveArrArrayIterator..::.Reset Method
CurveArrArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurveArrArrayIterator Class
Autodesk.Revit.Geometry Namespace


CurveArrArrayIterator Properties

[image] [image]

Revit 2010 API
CurveArrArrayIterator Properties
CurveArrArrayIterator Class See Also Send Feedback

The CurveArrArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveArrArrayIterator Class
Autodesk.Revit.Geometry Namespace


Current Property

[image]

Revit 2010 API
CurveArrArrayIterator..::.Current Property
CurveArrArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurveArrArrayIterator Class
Autodesk.Revit.Geometry Namespace


CurveArray Class

[image]

Revit 2010 API
CurveArray Class
Members See Also Send Feedback
An array that can contain curves.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CurveArray : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class CurveArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurveArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.CurveArray

See Also

CurveArray Members
Autodesk.Revit.Geometry Namespace


CurveArray Members

[image] [image]

Revit 2010 API
CurveArray Members
CurveArray Class Constructors Methods Properties See Also Send Feedback

The CurveArray type exposes the following members.

Constructors

Name | Description
CurveArray | Initializes a new instance of the CurveArray class

Methods

Name | Description
Append | Add the curve to the end of the array.
Clear | Removes every curve from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified curve into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a curve at a specified index within the array.
Size | Returns the number of curves that are in the array.

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


CurveArray Constructor

[image]

Revit 2010 API
CurveArray Constructor
CurveArray Class See Also Send Feedback
Initializes a new instance of the CurveArray class

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurveArray()

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


CurveArray Methods

[image] [image]

Revit 2010 API
CurveArray Methods
CurveArray Class See Also Send Feedback

The CurveArray type exposes the following members.

Methods

Name | Description
Append | Add the curve to the end of the array.
Clear | Removes every curve from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified curve into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


Append Method

[image]

Revit 2010 API
CurveArray..::.Append Method
CurveArray Class See Also Send Feedback
Add the curve to the end of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    Curve item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Curve _
)
Visual C++
public:
virtual void Append(
    Curve^ item
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.Curve
The curve to be added.

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

[image]

Revit 2010 API
CurveArray..::.Clear Method
CurveArray Class See Also Send Feedback
Removes every curve from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

[image]

Revit 2010 API
CurveArray..::.ForwardIterator Method
CurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CurveArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CurveArrayIterator
Visual C++
public:
virtual CurveArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

[image]

Revit 2010 API
CurveArray..::.GetEnumerator Method
CurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

[image]

Revit 2010 API
CurveArray..::.Insert Method
CurveArray Class See Also Send Feedback
Insert the specified curve into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    Curve item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Curve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Curve^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.Curve
The curve to be inserted into the array.
index
Type: System..::.Int32
The curve will be inserted before this index.

Return Value

Returns whether the curve was inserted into the array.

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

[image]

Revit 2010 API
CurveArray..::.ReverseIterator Method
CurveArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CurveArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CurveArrayIterator
Visual C++
public:
virtual CurveArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


CurveArray Properties

[image] [image]

Revit 2010 API
CurveArray Properties
CurveArray Class See Also Send Feedback

The CurveArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a curve at a specified index within the array.
Size | Returns the number of curves that are in the array.

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


IsEmpty Property

[image]

Revit 2010 API
CurveArray..::.IsEmpty Property
CurveArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


Item Property

[image]

Revit 2010 API
CurveArray..::.Item Property
CurveArray Class See Also Send Feedback
Gets or sets a curve at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Curve Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Curve
Visual C++
public:
virtual property Curve^ Item[int index] {
    Curve^ get (int index);
    void set (int index, Curve^ value);
}

Parameters

index
Type: System..::.Int32
The index of the curve to be set or retrieved.

Return Value

Returns the curve at the specified index.

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


Size Property

[image]

Revit 2010 API
CurveArray..::.Size Property
CurveArray Class See Also Send Feedback
Returns the number of curves that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace


CurveArrayIterator Class

[image]

Revit 2010 API
CurveArrayIterator Class
Members See Also Send Feedback
An iterator to a curve array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class CurveArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CurveArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CurveArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.CurveArrayIterator

See Also

CurveArrayIterator Members
Autodesk.Revit.Geometry Namespace


CurveArrayIterator Members

[image] [image]

Revit 2010 API
CurveArrayIterator Members
CurveArrayIterator Class Constructors Methods Properties See Also Send Feedback

The CurveArrayIterator type exposes the following members.

Constructors

Name | Description
CurveArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveArrayIterator Class
Autodesk.Revit.Geometry Namespace


CurveArrayIterator Constructor

[image]

Revit 2010 API
CurveArrayIterator Constructor
CurveArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurveArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurveArrayIterator Class
Autodesk.Revit.Geometry Namespace


CurveArrayIterator Methods

[image] [image]

Revit 2010 API
CurveArrayIterator Methods
CurveArrayIterator Class See Also Send Feedback

The CurveArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

[image]

Revit 2010 API
CurveArrayIterator..::.MoveNext Method
CurveArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurveArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

[image]

Revit 2010 API
CurveArrayIterator..::.Reset Method
CurveArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurveArrayIterator Class
Autodesk.Revit.Geometry Namespace


CurveArrayIterator Properties

[image] [image]

Revit 2010 API
CurveArrayIterator Properties
CurveArrayIterator Class See Also Send Feedback

The CurveArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveArrayIterator Class
Autodesk.Revit.Geometry Namespace


Current Property

[image]

Revit 2010 API
CurveArrayIterator..::.Current Property
CurveArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurveArrayIterator Class
Autodesk.Revit.Geometry Namespace


CylindricalFace Class

[image]

Revit 2010 API
CylindricalFace Class
Members Example See Also Send Feedback
A cylinder face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CylindricalFace : Face
Visual Basic (Declaration)
Public Class CylindricalFace _
    Inherits Face
Visual C++
public ref class CylindricalFace : public Face

Remarks

Cylinder faces are defined by cylinder surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces. S(u, v) = Origin + cos(u)*Radius[0] + sin(u)*Radius[1] + v*Axis

Examples

CopyC#
private void GetCylindricalFaceInfo(Face face)
{
    CylindricalFace cylindricalFace = face as CylindricalFace;
    if (null != cylindricalFace)
    {
        XYZ axis = cylindricalFace.Axis;
        XYZ origin = cylindricalFace.Origin;
        XYZ radius = cylindricalFace.get_Radius(0);
    }
}
CopyVB.NET
Private Sub GetCylindricalFaceInfo(ByVal face As Autodesk.Revit.Geometry.Face)
    Dim cylindricalFace As CylindricalFace = TryCast(face, CylindricalFace)
    If cylindricalFace IsNot Nothing Then
        Dim axis As Autodesk.Revit.Geometry.XYZ = cylindricalFace.Axis
        Dim origin As Autodesk.Revit.Geometry.XYZ = cylindricalFace.Origin
        Dim radius As Autodesk.Revit.Geometry.XYZ = cylindricalFace.Radius(0)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Face
Autodesk.Revit.Geometry..::.CylindricalFace

See Also

CylindricalFace Members
Autodesk.Revit.Geometry Namespace


CylindricalFace Members

[image] [image]

Revit 2010 API
CylindricalFace Members
CylindricalFace Class Constructors Methods Properties See Also Send Feedback

The CylindricalFace type exposes the following members.

Constructors

Name | Description
CylindricalFace | For Internal Use Only.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
Axis | Axis of the surface.
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Origin | Origin of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Radius | Radii of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

CylindricalFace Class
Autodesk.Revit.Geometry Namespace


CylindricalFace Constructor

[image]

Revit 2010 API
CylindricalFace Constructor
CylindricalFace Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CylindricalFace()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CylindricalFace()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CylindricalFace Class
Autodesk.Revit.Geometry Namespace


CylindricalFace Methods

[image] [image]

Revit 2010 API
CylindricalFace Methods
CylindricalFace Class See Also Send Feedback

The CylindricalFace type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

CylindricalFace Class
Autodesk.Revit.Geometry Namespace


Intersect Method

[image] [image]

Revit 2010 API
CylindricalFace..::.Intersect Method
CylindricalFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

CylindricalFace Class
CylindricalFace Members
Autodesk.Revit.Geometry Namespace


IsInside Method

[image] [image]

Revit 2010 API
CylindricalFace..::.IsInside Method
CylindricalFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

Name | Description
IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)

See Also

CylindricalFace Class
CylindricalFace Members
Autodesk.Revit.Geometry Namespace


CylindricalFace Properties

[image] [image]

Revit 2010 API
CylindricalFace Properties
CylindricalFace Class See Also Send Feedback

The CylindricalFace type exposes the following members.

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
Axis | Axis of the surface.
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Origin | Origin of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Radius | Radii of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

CylindricalFace Class
Autodesk.Revit.Geometry Namespace


Axis Property

[image]

Revit 2010 API
CylindricalFace..::.Axis Property
CylindricalFace Class See Also Send Feedback
Axis of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Axis { get; }
Visual Basic (Declaration)
Public ReadOnly Property Axis As XYZ
Visual C++
public:
property XYZ^ Axis {
    XYZ^ get ();
}

See Also

CylindricalFace Class
Autodesk.Revit.Geometry Namespace


Origin Property

[image]

Revit 2010 API
CylindricalFace..::.Origin Property
CylindricalFace Class See Also Send Feedback
Origin of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

CylindricalFace Class
Autodesk.Revit.Geometry Namespace


Radius Property

[image]

Revit 2010 API
CylindricalFace..::.Radius Property
CylindricalFace Class See Also Send Feedback
Radii of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Radius[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Radius ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Radius[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

CylindricalFace Class
Autodesk.Revit.Geometry Namespace


DoubleArray Class

[image]

Revit 2010 API
DoubleArray Class
Members See Also Send Feedback
An array that contains doubles.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DoubleArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class DoubleArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DoubleArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.DoubleArray

See Also

DoubleArray Members
Autodesk.Revit.Geometry Namespace


DoubleArray Members

[image] [image]

Revit 2010 API
DoubleArray Members
DoubleArray Class Constructors Methods Properties See Also Send Feedback

The DoubleArray type exposes the following members.

Constructors

Name | Description
DoubleArray | Initializes a new instance of the DoubleArray class

Methods

Name | Description
Append |
Clear | Removes every double from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a double at a specified index within the array.
Size | Returns the number of doubles that are in the array.

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


DoubleArray Constructor

[image]

Revit 2010 API
DoubleArray Constructor
DoubleArray Class See Also Send Feedback
Initializes a new instance of the DoubleArray class

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DoubleArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DoubleArray()

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


DoubleArray Methods

[image] [image]

Revit 2010 API
DoubleArray Methods
DoubleArray Class See Also Send Feedback

The DoubleArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every double from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


Append Method

[image]

Revit 2010 API
DoubleArray..::.Append Method
DoubleArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    ref double item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    ByRef item As Double _
)
Visual C++
public:
virtual void Append(
    double% item
)

Parameters

item
Type: System..::.Double %

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

[image]

Revit 2010 API
DoubleArray..::.Clear Method
DoubleArray Class See Also Send Feedback
Removes every double from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

[image]

Revit 2010 API
DoubleArray..::.ForwardIterator Method
DoubleArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DoubleArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DoubleArrayIterator
Visual C++
public:
virtual DoubleArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

[image]

Revit 2010 API
DoubleArray..::.GetEnumerator Method
DoubleArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

[image]

Revit 2010 API
DoubleArray..::.Insert Method
DoubleArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    ref double item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    ByRef item As Double, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    double% item,
    int index
)

Parameters

item
Type: System..::.Double %
index
Type: System..::.Int32

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

[image]

Revit 2010 API
DoubleArray..::.ReverseIterator Method
DoubleArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DoubleArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DoubleArrayIterator
Visual C++
public:
virtual DoubleArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


DoubleArray Properties

[image] [image]

Revit 2010 API
DoubleArray Properties
DoubleArray Class See Also Send Feedback

The DoubleArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a double at a specified index within the array.
Size | Returns the number of doubles that are in the array.

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


IsEmpty Property

[image]

Revit 2010 API
DoubleArray..::.IsEmpty Property
DoubleArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


Item Property

[image]

Revit 2010 API
DoubleArray..::.Item Property
DoubleArray Class See Also Send Feedback
Gets or sets a double at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual double Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Double
Visual C++
public:
virtual property double Item[int index] {
    double get (int index);
    void set (int index, double value);
}

Parameters

index
Type: System..::.Int32
The index of the double to be set or retrieved.

Return Value

Returns the double at the specified index.

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


Size Property

[image]

Revit 2010 API
DoubleArray..::.Size Property
DoubleArray Class See Also Send Feedback
Returns the number of doubles that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DoubleArray Class
Autodesk.Revit.Geometry Namespace


DoubleArrayIterator Class

[image]

Revit 2010 API
DoubleArrayIterator Class
Members See Also Send Feedback
An iterator to an array of doubles.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class DoubleArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class DoubleArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DoubleArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.DoubleArrayIterator

See Also

DoubleArrayIterator Members
Autodesk.Revit.Geometry Namespace


DoubleArrayIterator Members

[image] [image]

Revit 2010 API
DoubleArrayIterator Members
DoubleArrayIterator Class Constructors Methods Properties See Also Send Feedback

The DoubleArrayIterator type exposes the following members.

Constructors

Name | Description
DoubleArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DoubleArrayIterator Class
Autodesk.Revit.Geometry Namespace


DoubleArrayIterator Constructor

[image]

Revit 2010 API
DoubleArrayIterator Constructor
DoubleArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DoubleArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DoubleArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DoubleArrayIterator Class
Autodesk.Revit.Geometry Namespace


DoubleArrayIterator Methods

[image] [image]

Revit 2010 API
DoubleArrayIterator Methods
DoubleArrayIterator Class See Also Send Feedback

The DoubleArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DoubleArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

[image]

Revit 2010 API
DoubleArrayIterator..::.MoveNext Method
DoubleArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DoubleArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

[image]

Revit 2010 API
DoubleArrayIterator..::.Reset Method
DoubleArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DoubleArrayIterator Class
Autodesk.Revit.Geometry Namespace


DoubleArrayIterator Properties

[image] [image]

Revit 2010 API
DoubleArrayIterator Properties
DoubleArrayIterator Class See Also Send Feedback

The DoubleArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DoubleArrayIterator Class
Autodesk.Revit.Geometry Namespace


Current Property

[image]

Revit 2010 API
DoubleArrayIterator..::.Current Property
DoubleArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DoubleArrayIterator Class
Autodesk.Revit.Geometry Namespace


Edge Class

[image]

Revit 2010 API
Edge Class
Members See Also Send Feedback
An edge of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Edge : GeometryObject
Visual Basic (Declaration)
Public Class Edge _
    Inherits GeometryObject
Visual C++
public ref class Edge : public GeometryObject

Remarks

Edges are defined by intersections of surfaces that form faces of the solid. They have arbitrary parametrization that is normalized to [0,1].

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Edge

See Also

Edge Members
Autodesk.Revit.Geometry Namespace


Edge Members

[image] [image]

Revit 2010 API
Edge Members
Edge Class Constructors Methods Properties See Also Send Feedback

The Edge type exposes the following members.

Constructors

Name | Description
Edge | For Internal Use Only.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the edge at the parameter.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the edge.
EvaluateOnFace | Evaluates a parameter on the edge to produce UV coordinates on the face.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Tessellate | Returns a polyline approximation to the edge.
TessellateOnFace | Returns a polyline approximation to the edge in UV parameters of the face.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApproximateLength | Returns the approximate length of the edge.
EndPointReference | Returns a stable reference to the start or the end point of the edge.
Face | Returns one of the two faces that meet at the edge.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Reference | Returns a stable reference to the edge.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


Edge Constructor

[image]

Revit 2010 API
Edge Constructor
Edge Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Edge()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Edge()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


Edge Methods

[image] [image]

Revit 2010 API
Edge Methods
Edge Class See Also Send Feedback

The Edge type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the edge at the parameter.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the edge.
EvaluateOnFace | Evaluates a parameter on the edge to produce UV coordinates on the face.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Tessellate | Returns a polyline approximation to the edge.
TessellateOnFace | Returns a polyline approximation to the edge in UV parameters of the face.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


ComputeDerivatives Method

[image]

Revit 2010 API
Edge..::.ComputeDerivatives Method
Edge Class See Also Send Feedback
Returns the moving frame around the edge at the parameter.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Transform ComputeDerivatives(
    double parameter
)
Visual Basic (Declaration)
Public Function ComputeDerivatives ( _
    parameter As Double _
) As Transform
Visual C++
public:
Transform^ ComputeDerivatives(
    double parameter
)

Parameters

parameter
Type: System..::.Double
The parameter is the natural (or "raw") edge parameter.

Return Value

The transformation that represents the moving frame.

Remarks

The following is the meaning of the transformation memebers: Origin is the point on the edge (equivalent to Evaluate); BasisX is the tangent vector (the first derivative); BasisY is the normal vector (the second derivative); BasisZ is the binormal vector (tangent x normal). Normal and binormal are zero if the edge is straight at the point. None of the vectors are normalized.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when parameter is an infinite number.
System..::.InvalidOperationException | Thrown when failed to compute derivatives.

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


Evaluate Method

[image]

Revit 2010 API
Edge..::.Evaluate Method
Edge Class See Also Send Feedback
Evaluates a parameter on the edge.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Evaluate(
    double param
)
Visual Basic (Declaration)
Public Function Evaluate ( _
    param As Double _
) As XYZ
Visual C++
public:
XYZ^ Evaluate(
    double param
)

Parameters

param
Type: System..::.Double
The parameter to be evaluated, in [0,1].

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


EvaluateOnFace Method

[image]

Revit 2010 API
Edge..::.EvaluateOnFace Method
Edge Class See Also Send Feedback
Evaluates a parameter on the edge to produce UV coordinates on the face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV EvaluateOnFace(
    double param,
    Face face
)
Visual Basic (Declaration)
Public Function EvaluateOnFace ( _
    param As Double, _
    face As Face _
) As UV
Visual C++
public:
UV^ EvaluateOnFace(
    double param,
    Face^ face
)

Parameters

param
Type: System..::.Double
The parameter to be evaluated, in [0,1].
face
Type: Autodesk.Revit.Geometry..::.Face
The face on which to perform the evaluation. Must belong to the edge.

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


Tessellate Method

[image]

Revit 2010 API
Edge..::.Tessellate Method
Edge Class See Also Send Feedback
Returns a polyline approximation to the edge.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZArray Tessellate()
Visual Basic (Declaration)
Public Function Tessellate As XYZArray
Visual C++
public:
XYZArray^ Tessellate()

Remarks

Tolerance of approximation is defined internally by Revit to be adequate for display purposes.

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


TessellateOnFace Method

[image]

Revit 2010 API
Edge..::.TessellateOnFace Method
Edge Class See Also Send Feedback
Returns a polyline approximation to the edge in UV parameters of the face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UVArray TessellateOnFace(
    Face face
)
Visual Basic (Declaration)
Public Function TessellateOnFace ( _
    face As Face _
) As UVArray
Visual C++
public:
UVArray^ TessellateOnFace(
    Face^ face
)

Parameters

face
Type: Autodesk.Revit.Geometry..::.Face
The face on which to perform the tessellation. Must belong to the edge.

Remarks

Tolerance of approximation is defined internally by Revit to be adequate for display purposes.

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


Edge Properties

[image] [image]

Revit 2010 API
Edge Properties
Edge Class See Also Send Feedback

The Edge type exposes the following members.

Properties

Name | Description
ApproximateLength | Returns the approximate length of the edge.
EndPointReference | Returns a stable reference to the start or the end point of the edge.
Face | Returns one of the two faces that meet at the edge.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Reference | Returns a stable reference to the edge.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


ApproximateLength Property

[image]

Revit 2010 API
Edge..::.ApproximateLength Property
Edge Class See Also Send Feedback
Returns the approximate length of the edge.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ApproximateLength { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApproximateLength As Double
Visual C++
public:
property double ApproximateLength {
    double get ();
}

Remarks

Estimates the length of the edge by adding together tesselated segments, Will underestimate when the surface is curved.

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


EndPointReference Property

[image]

Revit 2010 API
Edge..::.EndPointReference Property
Edge Class See Also Send Feedback
Returns a stable reference to the start or the end point of the edge.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference EndPointReference[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndPointReference ( _
    index As Integer _
) As Reference
Visual C++
public:
property Reference^ EndPointReference[int index] {
    Reference^ get (int index);
}

Parameters

index
Type: System..::.Int32
Use 0 for the start point; 1 for the end point.

Return Value

Reference to the point or nullptr if reference cannot be obtained.

Exceptions

Exception | Condition
System..::.IndexOutOfRangeException | Thrown when the specified index is not 0 or 1.
System..::.InvalidOperationException | Thrown when the object is internally marked as read-only in the setter.

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


Face Property

[image]

Revit 2010 API
Edge..::.Face Property
Edge Class See Also Send Feedback
Returns one of the two faces that meet at the edge.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Face Face[
    int idx
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Face ( _
    idx As Integer _
) As Face
Visual C++
public:
property Face^ Face[int idx] {
    Face^ get (int idx);
}

Parameters

idx
Type: System..::.Int32
The index of the face (0 or 1).

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


Reference Property

[image]

Revit 2010 API
Edge..::.Reference Property
Edge Class See Also Send Feedback
Returns a stable reference to the edge.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference Reference { get; }
Visual Basic (Declaration)
Public ReadOnly Property Reference As Reference
Visual C++
public:
property Reference^ Reference {
    Reference^ get ();
}

See Also

Edge Class
Autodesk.Revit.Geometry Namespace


EdgeArray Class

[image]

Revit 2010 API
EdgeArray Class
Members See Also Send Feedback
An array that contains edges.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class EdgeArray : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class EdgeArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class EdgeArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.EdgeArray

See Also

EdgeArray Members
Autodesk.Revit.Geometry Namespace


EdgeArray Members

[image] [image]

Revit 2010 API
EdgeArray Members
EdgeArray Class Constructors Methods Properties See Also Send Feedback

The EdgeArray type exposes the following members.

Constructors

Name | Description
EdgeArray | Initializes a new instance of the EdgeArray class

Methods

Name | Description
Append | Add the edge to the end of the array.
Clear | Removes every edge from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified edge into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an edge at a specified index within the array.
Size | Returns the number of edges that are in the array.

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


EdgeArray Constructor

[image]

Revit 2010 API
EdgeArray Constructor
EdgeArray Class See Also Send Feedback
Initializes a new instance of the EdgeArray class

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public EdgeArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EdgeArray()

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


EdgeArray Methods

[image] [image]

Revit 2010 API
EdgeArray Methods
EdgeArray Class See Also Send Feedback

The EdgeArray type exposes the following members.

Methods

Name | Description
Append | Add the edge to the end of the array.
Clear | Removes every edge from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified edge into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


Append Method

[image]

Revit 2010 API
EdgeArray..::.Append Method
EdgeArray Class See Also Send Feedback
Add the edge to the end of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    Edge item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Edge _
)
Visual C++
public:
virtual void Append(
    Edge^ item
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.Edge
The edge to be added.

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

[image]

Revit 2010 API
EdgeArray..::.Clear Method
EdgeArray Class See Also Send Feedback
Removes every edge from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

[image]

Revit 2010 API
EdgeArray..::.ForwardIterator Method
EdgeArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual EdgeArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As EdgeArrayIterator
Visual C++
public:
virtual EdgeArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

[image]

Revit 2010 API
EdgeArray..::.GetEnumerator Method
EdgeArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

[image]

Revit 2010 API
EdgeArray..::.Insert Method
EdgeArray Class See Also Send Feedback
Insert the specified edge into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    Edge item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Edge, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Edge^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.Edge
The edge to be inserted into the array.
index
Type: System..::.Int32
The edge will be inserted before this index.

Return Value

Returns whether the edge was inserted into the array.

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

[image]

Revit 2010 API
EdgeArray..::.ReverseIterator Method
EdgeArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual EdgeArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As EdgeArrayIterator
Visual C++
public:
virtual EdgeArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


EdgeArray Properties

[image] [image]

Revit 2010 API
EdgeArray Properties
EdgeArray Class See Also Send Feedback

The EdgeArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an edge at a specified index within the array.
Size | Returns the number of edges that are in the array.

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


IsEmpty Property

[image]

Revit 2010 API
EdgeArray..::.IsEmpty Property
EdgeArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


Item Property

[image]

Revit 2010 API
EdgeArray..::.Item Property
EdgeArray Class See Also Send Feedback
Gets or sets an edge at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Edge Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Edge
Visual C++
public:
virtual property Edge^ Item[int index] {
    Edge^ get (int index);
    void set (int index, Edge^ value);
}

Parameters

index
Type: System..::.Int32
The index of the edge to be set or retrieved.

Return Value

Returns the edge at the specified index.

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


Size Property

[image]

Revit 2010 API
EdgeArray..::.Size Property
EdgeArray Class See Also Send Feedback
Returns the number of edges that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace


EdgeArrayArray Class

[image]

Revit 2010 API
EdgeArrayArray Class
Members Example See Also Send Feedback
An array of edge arrays.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class EdgeArrayArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class EdgeArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class EdgeArrayArray : public APIObject,
    IEnumerable

Examples

CopyC#
public void GetEdgeArrayArray(Autodesk.Revit.Application app, Autodesk.Revit.Element element)
{
    // Get geometry element of the selected element
    Options geoOptions = app.Create.NewGeometryOptions();
    Autodesk.Revit.Geometry.Element geoElement = element.get_Geometry(geoOptions);
    // Get geometry object
    foreach (GeometryObject o in geoElement.Objects)
    {
        Solid solid = o as Solid;
        if (null != solid)
        {
            foreach (Face face in solid.Faces)
            {
                if (face != null)
                {
                    EdgeArrayArray edgeArrays = face.EdgeLoops;
                    foreach (EdgeArray edges in edgeArrays)
                    {
                        foreach (Edge edge in edges)
                        {
                            // Get one test point
                            XYZ testPoint = edge.Evaluate(0.5);
                            string edgeInfo = string.Format("Point on edge: ({0},{1},{2})", testPoint.X, testPoint.Y, testPoint.Z);
                            MessageBox.Show(edgeInfo, "Revit");
                        }
                    }
                }
            }
        }
    }
}
CopyVB.NET
Public Sub GetEdgeArrayArray(ByVal app As Autodesk.Revit.Application, ByVal element As Autodesk.Revit.Element)
    ' Get geometry element of the selected element
    Dim geoOptions As Autodesk.Revit.Geometry.Options = app.Create.NewGeometryOptions()
    Dim geoElement As Autodesk.Revit.Geometry.Element = element.Geometry(geoOptions)
    ' Get geometry object
    For Each o As GeometryObject In geoElement.Objects
        Dim solid As Solid = TryCast(o, Solid)
        If solid IsNot Nothing Then
            For Each face As Autodesk.Revit.Geometry.Face In solid.Faces
                If face IsNot Nothing Then
                    Dim edgeArrays As EdgeArrayArray = face.EdgeLoops
                    For Each edges As EdgeArray In edgeArrays
                        For Each edge As Autodesk.Revit.Geometry.Edge In edges
                            ' Get one test point
                            Dim testPoint As Autodesk.Revit.Geometry.XYZ = edge.Evaluate(0.5)
                            Dim edgeInfo As String = String.Format("Point on edge: ({0},{1},{2})", testPoint.X, testPoint.Y, testPoint.Z)
                            MessageBox.Show(edgeInfo, "Revit")
                        Next
                    Next
                End If
            Next
        End If
    Next
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.EdgeArrayArray

See Also

EdgeArrayArray Members
Autodesk.Revit.Geometry Namespace


EdgeArrayArray Members

[image] [image]

Revit 2010 API
EdgeArrayArray Members
EdgeArrayArray Class Constructors Methods Properties See Also Send Feedback

The EdgeArrayArray type exposes the following members.

Constructors

Name | Description
EdgeArrayArray | Initializes a new instance of the EdgeArrayArray class

Methods

Name | Description
Append | Add the edge array to the end of the array.
Clear | Removes every edge array from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified edge array into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an edge array at a specified index within the array.
Size | Returns the number of edge arrays that are in the array.

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


EdgeArrayArray Constructor

[image]

Revit 2010 API
EdgeArrayArray Constructor
EdgeArrayArray Class See Also Send Feedback
Initializes a new instance of the EdgeArrayArray class

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public EdgeArrayArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EdgeArrayArray()

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


EdgeArrayArray Methods

[image] [image]

Revit 2010 API
EdgeArrayArray Methods
EdgeArrayArray Class See Also Send Feedback

The EdgeArrayArray type exposes the following members.

Methods

Name | Description
Append | Add the edge array to the end of the array.
Clear | Removes every edge array from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified edge array into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


Append Method

[image]

Revit 2010 API
EdgeArrayArray..::.Append Method
EdgeArrayArray Class See Also Send Feedback
Add the edge array to the end of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    EdgeArray item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As EdgeArray _
)
Visual C++
public:
virtual void Append(
    EdgeArray^ item
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.EdgeArray
The edge array to be added.

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

[image]

Revit 2010 API
EdgeArrayArray..::.Clear Method
EdgeArrayArray Class See Also Send Feedback
Removes every edge array from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

[image]

Revit 2010 API
EdgeArrayArray..::.ForwardIterator Method
EdgeArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual EdgeArrayArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As EdgeArrayArrayIterator
Visual C++
public:
virtual EdgeArrayArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

[image]

Revit 2010 API
EdgeArrayArray..::.GetEnumerator Method
EdgeArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

[image]

Revit 2010 API
EdgeArrayArray..::.Insert Method
EdgeArrayArray Class See Also Send Feedback
Insert the specified edge array into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    EdgeArray item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As EdgeArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    EdgeArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.EdgeArray
The edge array to be inserted into the array.
index
Type: System..::.Int32
The edge array will be inserted before this index.

Return Value

Returns whether the edge array was inserted into the array.

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

[image]

Revit 2010 API
EdgeArrayArray..::.ReverseIterator Method
EdgeArrayArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual EdgeArrayArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As EdgeArrayArrayIterator
Visual C++
public:
virtual EdgeArrayArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


EdgeArrayArray Properties

[image] [image]

Revit 2010 API
EdgeArrayArray Properties
EdgeArrayArray Class See Also Send Feedback

The EdgeArrayArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an edge array at a specified index within the array.
Size | Returns the number of edge arrays that are in the array.

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


IsEmpty Property

[image]

Revit 2010 API
EdgeArrayArray..::.IsEmpty Property
EdgeArrayArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


Item Property

[image]

Revit 2010 API
EdgeArrayArray..::.Item Property
EdgeArrayArray Class See Also Send Feedback
Gets or sets an edge array at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual EdgeArray Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As EdgeArray
Visual C++
public:
virtual property EdgeArray^ Item[int index] {
    EdgeArray^ get (int index);
    void set (int index, EdgeArray^ value);
}

Parameters

index
Type: System..::.Int32
The index of the edge array to be set or retrieved.

Return Value

Returns the edge array at the specified index.

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


Size Property

[image]

Revit 2010 API
EdgeArrayArray..::.Size Property
EdgeArrayArray Class See Also Send Feedback
Returns the number of edge arrays that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

EdgeArrayArray Class
Autodesk.Revit.Geometry Namespace


EdgeArrayArrayIterator Class

[image]

Revit 2010 API
EdgeArrayArrayIterator Class
Members See Also Send Feedback
An iterator to an array or edge arrays.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class EdgeArrayArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class EdgeArrayArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class EdgeArrayArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.EdgeArrayArrayIterator

See Also

EdgeArrayArrayIterator Members
Autodesk.Revit.Geometry Namespace


EdgeArrayArrayIterator Members

[image] [image]

Revit 2010 API
EdgeArrayArrayIterator Members
EdgeArrayArrayIterator Class Constructors Methods Properties See Also Send Feedback

The EdgeArrayArrayIterator type exposes the following members.

Constructors

Name | Description
EdgeArrayArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

EdgeArrayArrayIterator Class
Autodesk.Revit.Geometry Namespace


EdgeArrayArrayIterator Constructor

[image]

Revit 2010 API
EdgeArrayArrayIterator Constructor
EdgeArrayArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public EdgeArrayArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EdgeArrayArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

EdgeArrayArrayIterator Class
Autodesk.Revit.Geometry Namespace


EdgeArrayArrayIterator Methods

[image] [image]

Revit 2010 API
EdgeArrayArrayIterator Methods
EdgeArrayArrayIterator Class See Also Send Feedback

The EdgeArrayArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EdgeArrayArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

[image]

Revit 2010 API
EdgeArrayArrayIterator..::.MoveNext Method
EdgeArrayArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

EdgeArrayArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

[image]

Revit 2010 API
EdgeArrayArrayIterator..::.Reset Method
EdgeArrayArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

EdgeArrayArrayIterator Class
Autodesk.Revit.Geometry Namespace


EdgeArrayArrayIterator Properties

[image] [image]

Revit 2010 API
EdgeArrayArrayIterator Properties
EdgeArrayArrayIterator Class See Also Send Feedback

The EdgeArrayArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

EdgeArrayArrayIterator Class
Autodesk.Revit.Geometry Namespace


Current Property

[image]

Revit 2010 API
EdgeArrayArrayIterator..::.Current Property
EdgeArrayArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

EdgeArrayArrayIterator Class
Autodesk.Revit.Geometry Namespace


EdgeArrayIterator Class

[image]

Revit 2010 API
EdgeArrayIterator Class
Members See Also Send Feedback
An iterator to an edge array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class EdgeArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class EdgeArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class EdgeArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.EdgeArrayIterator

See Also

EdgeArrayIterator Members
Autodesk.Revit.Geometry Namespace


EdgeArrayIterator Members

[image] [image]

Revit 2010 API
EdgeArrayIterator Members
EdgeArrayIterator Class Constructors Methods Properties See Also Send Feedback

The EdgeArrayIterator type exposes the following members.

Constructors

Name | Description
EdgeArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

EdgeArrayIterator Class
Autodesk.Revit.Geometry Namespace


EdgeArrayIterator Constructor

[image]

Revit 2010 API
EdgeArrayIterator Constructor
EdgeArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public EdgeArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EdgeArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

EdgeArrayIterator Class
Autodesk.Revit.Geometry Namespace


EdgeArrayIterator Methods

[image] [image]

Revit 2010 API
EdgeArrayIterator Methods
EdgeArrayIterator Class See Also Send Feedback

The EdgeArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EdgeArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

[image]

Revit 2010 API
EdgeArrayIterator..::.MoveNext Method
EdgeArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

EdgeArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

[image]

Revit 2010 API
EdgeArrayIterator..::.Reset Method
EdgeArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

EdgeArrayIterator Class
Autodesk.Revit.Geometry Namespace


EdgeArrayIterator Properties

[image] [image]

Revit 2010 API
EdgeArrayIterator Properties
EdgeArrayIterator Class See Also Send Feedback

The EdgeArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

EdgeArrayIterator Class
Autodesk.Revit.Geometry Namespace


Current Property

[image]

Revit 2010 API
EdgeArrayIterator..::.Current Property
EdgeArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

EdgeArrayIterator Class
Autodesk.Revit.Geometry Namespace


Element Class

[image]

Revit 2010 API
Element Class
Members See Also Send Feedback
Geometric representation of an element.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Element : GeometryObject
Visual Basic (Declaration)
Public Class Element _
    Inherits GeometryObject
Visual C++
public ref class Element : public GeometryObject

Remarks

This class contains geometric primitives that are generated from the parametric description of the element.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Element

See Also

Element Members
Autodesk.Revit.Geometry Namespace


Element Members

[image] [image]

Revit 2010 API
Element Members
Element Class Constructors Methods Properties See Also Send Feedback

The Element type exposes the following members.

Constructors

Name | Description
Element | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
MaterialElement | Element describing the material from which this element is composed. (Overrides GeometryObjectMaterialElement()()().)
Objects | All geometric primitives contained in the element.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Element Class
Autodesk.Revit.Geometry Namespace


Element Constructor

[image]

Revit 2010 API
Element Constructor
Element Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Element()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Element Class
Autodesk.Revit.Geometry Namespace


Element Methods

[image] [image]

Revit 2010 API
Element Methods
Element Class See Also Send Feedback

The Element type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Element Class
Autodesk.Revit.Geometry Namespace


Element Properties

[image] [image]

Revit 2010 API
Element Properties
Element Class See Also Send Feedback

The Element type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
MaterialElement | Element describing the material from which this element is composed. (Overrides GeometryObjectMaterialElement()()().)
Objects | All geometric primitives contained in the element.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Element Class
Autodesk.Revit.Geometry Namespace


MaterialElement Property

[image]

Revit 2010 API
Element..::.MaterialElement Property
Element Class See Also Send Feedback
Element describing the material from which this element is composed.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override Material MaterialElement { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property MaterialElement As Material
Visual C++
public:
virtual property Material^ MaterialElement {
    Material^ get () override;
}

See Also

Element Class
Autodesk.Revit.Geometry Namespace


Objects Property

[image]

Revit 2010 API
Element..::.Objects Property
Element Class See Also Send Feedback
All geometric primitives contained in the element.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GeometryObjectArray Objects { get; }
Visual Basic (Declaration)
Public ReadOnly Property Objects As GeometryObjectArray
Visual C++
public:
property GeometryObjectArray^ Objects {
    GeometryObjectArray^ get ();
}

Remarks

Branching on dynamic type of the objects is advised. Faces and edges are contained in solids and never directly in an element.

See Also

Element Class
Autodesk.Revit.Geometry Namespace


Ellipse Class

[image]

Revit 2010 API
Ellipse Class
Members See Also Send Feedback
A whole or partial ellipse.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Ellipse : Curve
Visual Basic (Declaration)
Public Class Ellipse _
    Inherits Curve
Visual C++
public ref class Ellipse : public Curve

Remarks

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Curve
Autodesk.Revit.Geometry..::.Ellipse

See Also

Ellipse Members
Autodesk.Revit.Geometry Namespace


Ellipse Members

[image] [image]

Revit 2010 API
Ellipse Members
Ellipse Class Constructors Methods Properties See Also Send Feedback

The Ellipse type exposes the following members.

Constructors

Name | Description
Ellipse | For Internal Use Only.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Center | Returns the center of the ellipse.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve. (Inherited from Curve.)
Normal | Returns the normal to the plane in which the ellipse is defined.
Period | The period of this curve. (Inherited from Curve.)
RadiusX | Returns the X vector radius of the ellipse.
RadiusY | Returns the Y vector radius of the ellipse.
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Ellipse Class
Autodesk.Revit.Geometry Namespace


Ellipse Constructor

[image]

Revit 2010 API
Ellipse Constructor
Ellipse Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Ellipse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Ellipse()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Ellipse Class
Autodesk.Revit.Geometry Namespace


Ellipse Methods

[image] [image]

Revit 2010 API
Ellipse Methods
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Ellipse Class
Autodesk.Revit.Geometry Namespace


Intersect Method

[image] [image]

Revit 2010 API
Ellipse..::.Intersect Method
Ellipse Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

Ellipse Class
Ellipse Members
Autodesk.Revit.Geometry Namespace


IsInside Method

[image] [image]

Revit 2010 API
Ellipse..::.IsInside Method
Ellipse Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

Name | Description
IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)

See Also

Ellipse Class
Ellipse Members
Autodesk.Revit.Geometry Namespace


Ellipse Properties

[image] [image]

Revit 2010 API
Ellipse Properties
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Center | Returns the center of the ellipse.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve. (Inherited from Curve.)
Normal | Returns the normal to the plane in which the ellipse is defined.
Period | The period of this curve. (Inherited from Curve.)
RadiusX | Returns the X vector radius of the ellipse.
RadiusY | Returns the Y vector radius of the ellipse.
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Ellipse Class
Autodesk.Revit.Geometry Namespace


Center Property

[image]

Revit 2010 API
Ellipse..::.Center Property
Ellipse Class See Also Send Feedback
Returns the center of the ellipse.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Center { get; }
Visual Basic (Declaration)
Public ReadOnly Property Center As XYZ
Visual C++
public:
property XYZ^ Center {
    XYZ^ get ();
}

See Also

Ellipse Class
Autodesk.Revit.Geometry Namespace


Normal Property

[image]

Revit 2010 API
Ellipse..::.Normal Property
Ellipse Class See Also Send Feedback
Returns the normal to the plane in which the ellipse is defined.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Normal { get; }
Visual Basic (Declaration)
Public ReadOnly Property Normal As XYZ
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

Ellipse Class
Autodesk.Revit.Geometry Namespace


RadiusX Property

[image]

Revit 2010 API
Ellipse..::.RadiusX Property
Ellipse Class See Also Send Feedback
Returns the X vector radius of the ellipse.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double RadiusX { get; }
Visual Basic (Declaration)
Public ReadOnly Property RadiusX As Double
Visual C++
public:
property double RadiusX {
    double get ();
}

See Also

Ellipse Class
Autodesk.Revit.Geometry Namespace


RadiusY Property

[image]

Revit 2010 API
Ellipse..::.RadiusY Property
Ellipse Class See Also Send Feedback
Returns the Y vector radius of the ellipse.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double RadiusY { get; }
Visual Basic (Declaration)
Public ReadOnly Property RadiusY As Double
Visual C++
public:
property double RadiusY {
    double get ();
}

See Also

Ellipse Class
Autodesk.Revit.Geometry Namespace


Face Class

[image]

Revit 2010 API
Face Class
Members See Also Send Feedback
A face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Face : GeometryObject
Visual Basic (Declaration)
Public Class Face _
    Inherits GeometryObject
Visual C++
public ref class Face : public GeometryObject

Remarks

Faces are defined by surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Face
Autodesk.Revit.Geometry..::.ConicalFace
Autodesk.Revit.Geometry..::.CylindricalFace
Autodesk.Revit.Geometry..::.HermiteFace
Autodesk.Revit.Geometry..::.PlanarFace
Autodesk.Revit.Geometry..::.RevolvedFace
Autodesk.Revit.Geometry..::.RuledFace

See Also

Face Members
Autodesk.Revit.Geometry Namespace


Face Members

[image] [image]

Revit 2010 API
Face Members
Face Class Constructors Methods Properties See Also Send Feedback

The Face type exposes the following members.

Constructors

Name | Description
Face | For Internal Use Only.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face.

Properties

Name | Description
Area | The area of this face.
EdgeLoops | Each edge loop is a closed boundary of the face.
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate)
MaterialElement | Element describing the material from which this face is composed. (Overrides GeometryObjectMaterialElement()()().)
Period | The period of this face in the specified parametric direction.
Reference | Returns a stable reference to the face.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Face Class
Autodesk.Revit.Geometry Namespace


Face Constructor

[image]

Revit 2010 API
Face Constructor
Face Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Face()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Face()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Face Class
Autodesk.Revit.Geometry Namespace


Face Methods

[image] [image]

Revit 2010 API
Face Methods
Face Class See Also Send Feedback

The Face type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face.

See Also

Face Class
Autodesk.Revit.Geometry Namespace


ComputeDerivatives Method

[image]

Revit 2010 API
Face..::.ComputeDerivatives Method
Face Class See Also Send Feedback
Returns the moving frame around the face at the specified parameters.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Transform ComputeDerivatives(
    UV point
)
Visual Basic (Declaration)
Public Function ComputeDerivatives ( _
    point As UV _
) As Transform
Visual C++
public:
Transform^ ComputeDerivatives(
    UV^ point
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.UV
The parameters to be evaluated, in natural parametrization of the face.

Return Value

The transformation that represents the moving frame.

Remarks

The following is the meaning of the transformation members: Origin is the point on the face; (equivalent to Evaluate); BasisX is the tangent vector along the U coordinate; (partial derivative with respect to U); BasisY is the tangent vector along the V coordinate; (partial derivative with respect to V); BasisZ is the normal vector. None of the vectors are normalized.

See Also

Face Class
Autodesk.Revit.Geometry Namespace


Evaluate Method

[image]

Revit 2010 API
Face..::.Evaluate Method
Face Class See Also Send Feedback
Evaluates parameters on the face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Evaluate(
    UV params
)
Visual Basic (Declaration)
Public Function Evaluate ( _
    params As UV _
) As XYZ
Visual C++
public:
XYZ^ Evaluate(
    UV^ params
)

Parameters

params
Type: Autodesk.Revit.Geometry..::.UV
The parameters to be evaluated, in natural parametrization of the face.

See Also

Face Class
Autodesk.Revit.Geometry Namespace


Intersect Method

[image] [image]

Revit 2010 API
Face..::.Intersect Method
Face Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of the specified curve with this face.
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results.

See Also

Face Class
Face Members
Autodesk.Revit.Geometry Namespace


Intersect Method (Curve)

[image]

Revit 2010 API
Face..::.Intersect Method (Curve)
Face Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve
)
Visual Basic (Declaration)
Public Function Intersect ( _
    curve As Curve _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
The specified curve to intersect with this face.

Return Value

  • SetComparisonResult.Overlap - One or more intersections were encountered.
  • SetComparisonResult.Subset - The curve is coincident with the surface.
  • SetComparisonResult.Disjoint - There is no intersection found.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The curve is null.
System..::.InvalidOperationException | The intersection calculation fails.

See Also

Face Class
Intersect Overload
Autodesk.Revit.Geometry Namespace


Intersect Method (Curve, IntersectionResultArray)

[image]

Revit 2010 API
Face..::.Intersect Method (Curve, IntersectionResultArray%)
Face Class See Also Send Feedback
Calculates the intersection of the specified curve with this face and returns the intersection results.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve,
    out IntersectionResultArray results
)
Visual Basic (Declaration)
Public Function Intersect ( _
    curve As Curve, _
    <OutAttribute> ByRef results As IntersectionResultArray _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect(
    Curve^ curve,
    [OutAttribute] IntersectionResultArray^% results
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
The specified curve to intersect with this face.
results
Type: Autodesk.Revit.Geometry..::.IntersectionResultArray %
Provides more information about the intersection.

Return Value

  • SetComparisonResult.Overlap - One or more intersections were encountered. The output argument has the results.
  • SetComparisonResult.Subset - The curve is coincident with the surface.
  • SetComparisonResult.Disjoint - There is no intersection found.

Remarks

The array of the intersection results contains one entry for each point where this face and the curve intersect. The following is the meaning of IntersectionResult's members:
  • XYZPoint is the evaluated intersection point.
  • UVPoint is the intersection parameters on the face.
  • Parameter is the raw intersection parameter on the curve.
  • EdgeObject is the edge if the intersection happens to be near an edge of the face.
  • EdgeParameter is the parameter of the nearest point on the edge.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The curve is null.
System..::.InvalidOperationException | The intersection calculation fails.

See Also

Face Class
Intersect Overload
Autodesk.Revit.Geometry Namespace


IsInside Method

[image] [image]

Revit 2010 API
Face..::.IsInside Method
Face Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

Name | Description
IsInside(UV) | Indicates whether the specified point is within this face.
IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results.

See Also

Face Class
Face Members
Autodesk.Revit.Geometry Namespace


IsInside Method (UV)

[image]

Revit 2010 API
Face..::.IsInside Method (UV)
Face Class See Also Send Feedback
Indicates whether the specified point is within this face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsInside(
    UV point
)
Visual Basic (Declaration)
Public Function IsInside ( _
    point As UV _
) As Boolean
Visual C++
public:
bool IsInside(
    UV^ point
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.UV
The parameters to be evaluated, in natural parametrization of the face.

Return Value

True if point is within this face, otherwise false.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the parameter evaluation fails.

See Also

Face Class
IsInside Overload
Autodesk.Revit.Geometry Namespace


IsInside Method (UV, IntersectionResult)

[image]

Revit 2010 API
Face..::.IsInside Method (UV, IntersectionResult%)
Face Class See Also Send Feedback
Indicates whether the specified point is within this face and outputs additional results.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsInside(
    UV point,
    out IntersectionResult result
)
Visual Basic (Declaration)
Public Function IsInside ( _
    point As UV, _
    <OutAttribute> ByRef result As IntersectionResult _
) As Boolean
Visual C++
public:
bool IsInside(
    UV^ point,
    [OutAttribute] IntersectionResult^% result
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.UV
The parameters to be evaluated, in natural parametrization of the face.
result
Type: Autodesk.Revit.Geometry..::.IntersectionResult %
Provides more information when the point is on the edge; otherwise, nullptr.

Return Value

Returns true is within this face, otherwise false.

Remarks

The following is the meaning of the IntersectionResult members when the point is on the edge: EdgeObject is the edge that the point lies on; EdgeParameter is the parameter of the point on the edge nearest to the UV point; UV is the specified point.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the parameter evaluation fails.

See Also

Face Class
IsInside Overload
Autodesk.Revit.Geometry Namespace


Project Method

[image]

Revit 2010 API
Face..::.Project Method
Face Class See Also Send Feedback
Projects the specified point on this face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public IntersectionResult Project(
    XYZ point
)
Visual Basic (Declaration)
Public Function Project ( _
    point As XYZ _
) As IntersectionResult
Visual C++
public:
IntersectionResult^ Project(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
The point to be projected.

Return Value

Geometric information if projection is successful; if projection fails or the nearest point is outside of this face, returns null.

Remarks

The following is the meaning of IntersectionResult's members:
  • XYZPoint is the nearest point to the projected point on the face.
  • UVPoint is the UV coordinates of the nearest point on the face.
  • Distance is the distance from the point to the face.
  • EdgeObject is the edge if projected point is near an edge.
  • EdgeParameter is the parameter of the nearest point on the edge.

See Also

Face Class
Autodesk.Revit.Geometry Namespace


Triangulate Method

[image]

Revit 2010 API
Face..::.Triangulate Method
Face Class Example See Also Send Feedback
Returns a triangular mesh approximation to the face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Mesh Triangulate()
Visual Basic (Declaration)
Public Function Triangulate As Mesh
Visual C++
public:
Mesh^ Triangulate()

Remarks

Tolerance of approximation is defined internally by Revit to be adequate for display purposes.

Examples

CopyC#
private void TriangulateFace(Face face)
{
    // Get mesh
    Mesh mesh = face.Triangulate();
    for (int i = 0; i < mesh.NumTriangles; i++)
    {
        MeshTriangle triangle = mesh.get_Triangle(i);
        XYZ vertex1 = triangle.get_Vertex(0);
        XYZ vertex2 = triangle.get_Vertex(1);
        XYZ vertex3 = triangle.get_Vertex(2);
    }
}
CopyVB.NET
Private Sub TriangulateFace(ByVal face As Autodesk.Revit.Geometry.Face)
    ' Get mesh
    Dim mesh As Mesh = face.Triangulate()
    For i As Integer = 0 To mesh.NumTriangles - 1
        Dim triangle As MeshTriangle = mesh.Triangle(i)
        Dim vertex1 As Autodesk.Revit.Geometry.XYZ = triangle.Vertex(0)
        Dim vertex2 As Autodesk.Revit.Geometry.XYZ = triangle.Vertex(1)
        Dim vertex3 As Autodesk.Revit.Geometry.XYZ = triangle.Vertex(2)
    Next
End Sub

See Also

Face Class
Autodesk.Revit.Geometry Namespace


Face Properties

[image] [image]

Revit 2010 API
Face Properties
Face Class See Also Send Feedback

The Face type exposes the following members.

Properties

Name | Description
Area | The area of this face.
EdgeLoops | Each edge loop is a closed boundary of the face.
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate)
MaterialElement | Element describing the material from which this face is composed. (Overrides GeometryObjectMaterialElement()()().)
Period | The period of this face in the specified parametric direction.
Reference | Returns a stable reference to the face.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Face Class
Autodesk.Revit.Geometry Namespace


Area Property

[image]

Revit 2010 API
Face..::.Area Property
Face Class See Also Send Feedback
The area of this face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Area { get; }
Visual Basic (Declaration)
Public ReadOnly Property Area As Double
Visual C++
public:
property double Area {
    double get ();
}

Remarks

Returns zero if fails to compute the area. Estimates the area of this face by integrating tessellated edges. Will slightly underestimate when the edges are curved.

See Also

Face Class
Autodesk.Revit.Geometry Namespace


EdgeLoops Property

[image]

Revit 2010 API
Face..::.EdgeLoops Property
Face Class See Also Send Feedback
Each edge loop is a closed boundary of the face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public EdgeArrayArray EdgeLoops { get; }
Visual Basic (Declaration)
Public ReadOnly Property EdgeLoops As EdgeArrayArray
Visual C++
public:
property EdgeArrayArray^ EdgeLoops {
    EdgeArrayArray^ get ();
}

See Also

Face Class
Autodesk.Revit.Geometry Namespace


IsCyclic Property

[image]

Revit 2010 API
Face..::.IsCyclic Property
Face Class See Also Send Feedback
The boolean value that indicates whether this face is periodic in the specified parametric direction.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsCyclic[
    int paramIdx
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCyclic ( _
    paramIdx As Integer _
) As Boolean
Visual C++
public:
property bool IsCyclic[int paramIdx] {
    bool get (int paramIdx);
}

Parameters

paramIdx
Type: System..::.Int32
Use 0 for u coordinate and 1 for v coordinate.

Return Value

True if this face is cyclic; otherwise, false.

Exceptions

Exception | Condition
System..::.IndexOutOfRangeException | Thrown when an attempt is made to access the flag with an index larger than dimension.

See Also

Face Class
Autodesk.Revit.Geometry Namespace


IsTwoSided Property

[image]

Revit 2010 API
Face..::.IsTwoSided Property
Face Class See Also Send Feedback
Determines if a face is two-sided (degenerate)

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsTwoSided { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsTwoSided As Boolean
Visual C++
public:
virtual property bool IsTwoSided {
    bool get ();
}

See Also

Face Class
Autodesk.Revit.Geometry Namespace


MaterialElement Property

[image]

Revit 2010 API
Face..::.MaterialElement Property
Face Class See Also Send Feedback
Element describing the material from which this face is composed.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override Material MaterialElement { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property MaterialElement As Material
Visual C++
public:
virtual property Material^ MaterialElement {
    Material^ get () override;
}

See Also

Face Class
Autodesk.Revit.Geometry Namespace


Period Property

[image]

Revit 2010 API
Face..::.Period Property
Face Class See Also Send Feedback
The period of this face in the specified parametric direction.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Period[
    int paramIdx
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Period ( _
    paramIdx As Integer _
) As Double
Visual C++
public:
property double Period[int paramIdx] {
    double get (int paramIdx);
}

Parameters

paramIdx
Type: System..::.Int32
Use 0 for u coordinate and 1 for v coordinate.

Return Value

The real number equal to the period of this face.

Exceptions

Exception | Condition
System..::.IndexOutOfRangeException | Thrown when an attempt is made to access the flag with an index larger than dimension.
System..::.InvalidOperationException | Thrown when this face is not cyclic in the specified direction.

See Also

Face Class
Autodesk.Revit.Geometry Namespace


Reference Property

[image]

Revit 2010 API
Face..::.Reference Property
Face Class See Also Send Feedback
Returns a stable reference to the face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference Reference { get; }
Visual Basic (Declaration)
Public ReadOnly Property Reference As Reference
Visual C++
public:
property Reference^ Reference {
    Reference^ get ();
}

See Also

Face Class
Autodesk.Revit.Geometry Namespace


FaceArray Class

[image]

Revit 2010 API
FaceArray Class
Members See Also Send Feedback
An array that contains faces.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FaceArray : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class FaceArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FaceArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.FaceArray

See Also

FaceArray Members
Autodesk.Revit.Geometry Namespace


FaceArray Members

[image] [image]

Revit 2010 API
FaceArray Members
FaceArray Class Constructors Methods Properties See Also Send Feedback

The FaceArray type exposes the following members.

Constructors

Name | Description
FaceArray | Initializes a new instance of the FaceArray class

Methods

Name | Description
Append | Add the face to the end of the array.
Clear | Removes every face from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified face into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a face at a specified index within the array.
Size | Returns the number of faces that are in the array.

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


FaceArray Constructor

[image]

Revit 2010 API
FaceArray Constructor
FaceArray Class See Also Send Feedback
Initializes a new instance of the FaceArray class

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FaceArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FaceArray()

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


FaceArray Methods

[image] [image]

Revit 2010 API
FaceArray Methods
FaceArray Class See Also Send Feedback

The FaceArray type exposes the following members.

Methods

Name | Description
Append | Add the face to the end of the array.
Clear | Removes every face from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified face into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


Append Method

[image]

Revit 2010 API
FaceArray..::.Append Method
FaceArray Class See Also Send Feedback
Add the face to the end of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    Face item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Face _
)
Visual C++
public:
virtual void Append(
    Face^ item
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.Face
The face to be added.

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

[image]

Revit 2010 API
FaceArray..::.Clear Method
FaceArray Class See Also Send Feedback
Removes every face from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

[image]

Revit 2010 API
FaceArray..::.ForwardIterator Method
FaceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual FaceArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As FaceArrayIterator
Visual C++
public:
virtual FaceArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

[image]

Revit 2010 API
FaceArray..::.GetEnumerator Method
FaceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

[image]

Revit 2010 API
FaceArray..::.Insert Method
FaceArray Class See Also Send Feedback
Insert the specified face into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    Face item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Face, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Face^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.Face
The face to be inserted into the array.
index
Type: System..::.Int32
The face will be inserted before this index.

Return Value

Returns whether the face was inserted into the array.

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

[image]

Revit 2010 API
FaceArray..::.ReverseIterator Method
FaceArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual FaceArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As FaceArrayIterator
Visual C++
public:
virtual FaceArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


FaceArray Properties

[image] [image]

Revit 2010 API
FaceArray Properties
FaceArray Class See Also Send Feedback

The FaceArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a face at a specified index within the array.
Size | Returns the number of faces that are in the array.

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


IsEmpty Property

[image]

Revit 2010 API
FaceArray..::.IsEmpty Property
FaceArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


Item Property

[image]

Revit 2010 API
FaceArray..::.Item Property
FaceArray Class See Also Send Feedback
Gets or sets a face at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Face Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Face
Visual C++
public:
virtual property Face^ Item[int index] {
    Face^ get (int index);
    void set (int index, Face^ value);
}

Parameters

index
Type: System..::.Int32
The index of the face to be set or retrieved.

Return Value

Returns the face at the specified index.

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


Size Property

[image]

Revit 2010 API
FaceArray..::.Size Property
FaceArray Class See Also Send Feedback
Returns the number of faces that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace


FaceArrayIterator Class

[image]

Revit 2010 API
FaceArrayIterator Class
Members See Also Send Feedback
An iterator to a face array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class FaceArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class FaceArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FaceArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.FaceArrayIterator

See Also

FaceArrayIterator Members
Autodesk.Revit.Geometry Namespace


FaceArrayIterator Members

[image] [image]

Revit 2010 API
FaceArrayIterator Members
FaceArrayIterator Class Constructors Methods Properties See Also Send Feedback

The FaceArrayIterator type exposes the following members.

Constructors

Name | Description
FaceArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FaceArrayIterator Class
Autodesk.Revit.Geometry Namespace


FaceArrayIterator Constructor

[image]

Revit 2010 API
FaceArrayIterator Constructor
FaceArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FaceArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FaceArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FaceArrayIterator Class
Autodesk.Revit.Geometry Namespace


FaceArrayIterator Methods

[image] [image]

Revit 2010 API
FaceArrayIterator Methods
FaceArrayIterator Class See Also Send Feedback

The FaceArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FaceArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

[image]

Revit 2010 API
FaceArrayIterator..::.MoveNext Method
FaceArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FaceArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

[image]

Revit 2010 API
FaceArrayIterator..::.Reset Method
FaceArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FaceArrayIterator Class
Autodesk.Revit.Geometry Namespace


FaceArrayIterator Properties

[image] [image]

Revit 2010 API
FaceArrayIterator Properties
FaceArrayIterator Class See Also Send Feedback

The FaceArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FaceArrayIterator Class
Autodesk.Revit.Geometry Namespace


Current Property

[image]

Revit 2010 API
FaceArrayIterator..::.Current Property
FaceArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FaceArrayIterator Class
Autodesk.Revit.Geometry Namespace


GeometryObject Class

[image]

Revit 2010 API
GeometryObject Class
Members See Also Send Feedback
The common base class for all geometric primitives.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class GeometryObject : APIObject
Visual Basic (Declaration)
Public Class GeometryObject _
    Inherits APIObject
Visual C++
public ref class GeometryObject : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Curve
Autodesk.Revit.Geometry..::.Edge
Autodesk.Revit.Geometry..::.Element
Autodesk.Revit.Geometry..::.Face
Autodesk.Revit.Geometry..::.Instance
Autodesk.Revit.Geometry..::.Mesh
Autodesk.Revit.Geometry..::.Point
Autodesk.Revit.Geometry..::.Profile
Autodesk.Revit.Geometry..::.Solid

See Also

GeometryObject Members
Autodesk.Revit.Geometry Namespace


GeometryObject Members

[image] [image]

Revit 2010 API
GeometryObject Members
GeometryObject Class Constructors Methods Properties See Also Send Feedback

The GeometryObject type exposes the following members.

Constructors

Name | Description
GeometryObject | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Visibility | The visibility.

See Also

GeometryObject Class
Autodesk.Revit.Geometry Namespace


GeometryObject Constructor

[image]

Revit 2010 API
GeometryObject Constructor
GeometryObject Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GeometryObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GeometryObject()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GeometryObject Class
Autodesk.Revit.Geometry Namespace


GeometryObject Methods

[image] [image]

Revit 2010 API
GeometryObject Methods
GeometryObject Class See Also Send Feedback

The GeometryObject type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeometryObject Class
Autodesk.Revit.Geometry Namespace


GeometryObject Properties

[image] [image]

Revit 2010 API
GeometryObject Properties
GeometryObject Class See Also Send Feedback

The GeometryObject type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Visibility | The visibility.

See Also

GeometryObject Class
Autodesk.Revit.Geometry Namespace


Visibility Property

[image]

Revit 2010 API
GeometryObject..::.Visibility Property
GeometryObject Class See Also Send Feedback
The visibility.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Visibility Visibility { get; }
Visual Basic (Declaration)
Public ReadOnly Property Visibility As Visibility
Visual C++
public:
property Visibility Visibility {
    Visibility get ();
}

Remarks

The visibility of this object has no effect on the visibility of objects contained within this object. For example, the visibility of a Solid may be Contextual but the faces within that solid may still be Visible.

See Also

GeometryObject Class
Autodesk.Revit.Geometry Namespace


GeometryObjectArray Class

[image]

Revit 2010 API
GeometryObjectArray Class
Members See Also Send Feedback
An array that contains geometry objects.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class GeometryObjectArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class GeometryObjectArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GeometryObjectArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObjectArray

See Also

GeometryObjectArray Members
Autodesk.Revit.Geometry Namespace


GeometryObjectArray Members

[image] [image]

Revit 2010 API
GeometryObjectArray Members
GeometryObjectArray Class Constructors Methods Properties See Also Send Feedback

The GeometryObjectArray type exposes the following members.

Constructors

Name | Description
GeometryObjectArray | Initializes a new instance of the GeometryObjectArray class

Methods

Name | Description
Append | Add the geometry object to the end of the array.
Clear | Removes every geometry object from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified geometry object into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a geometry object at a specified index within the array.
Size | Returns the number of geometry objects that are in the array.

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


GeometryObjectArray Constructor

[image]

Revit 2010 API
GeometryObjectArray Constructor
GeometryObjectArray Class See Also Send Feedback
Initializes a new instance of the GeometryObjectArray class

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GeometryObjectArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GeometryObjectArray()

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


GeometryObjectArray Methods

[image] [image]

Revit 2010 API
GeometryObjectArray Methods
GeometryObjectArray Class See Also Send Feedback

The GeometryObjectArray type exposes the following members.

Methods

Name | Description
Append | Add the geometry object to the end of the array.
Clear | Removes every geometry object from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified geometry object into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


Append Method

[image]

Revit 2010 API
GeometryObjectArray..::.Append Method
GeometryObjectArray Class See Also Send Feedback
Add the geometry object to the end of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    GeometryObject item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As GeometryObject _
)
Visual C++
public:
virtual void Append(
    GeometryObject^ item
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.GeometryObject
The geometry object to be added.

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

[image]

Revit 2010 API
GeometryObjectArray..::.Clear Method
GeometryObjectArray Class See Also Send Feedback
Removes every geometry object from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

[image]

Revit 2010 API
GeometryObjectArray..::.ForwardIterator Method
GeometryObjectArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual GeometryObjectArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As GeometryObjectArrayIterator
Visual C++
public:
virtual GeometryObjectArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

[image]

Revit 2010 API
GeometryObjectArray..::.GetEnumerator Method
GeometryObjectArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

[image]

Revit 2010 API
GeometryObjectArray..::.Insert Method
GeometryObjectArray Class See Also Send Feedback
Insert the specified geometry object into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    GeometryObject item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As GeometryObject, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    GeometryObject^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.GeometryObject
The geometry object to be inserted into the array.
index
Type: System..::.Int32
The geometry object will be inserted before this index.

Return Value

Returns whether the geometry object was inserted into the array.

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

[image]

Revit 2010 API
GeometryObjectArray..::.ReverseIterator Method
GeometryObjectArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual GeometryObjectArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As GeometryObjectArrayIterator
Visual C++
public:
virtual GeometryObjectArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


GeometryObjectArray Properties

[image] [image]

Revit 2010 API
GeometryObjectArray Properties
GeometryObjectArray Class See Also Send Feedback

The GeometryObjectArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a geometry object at a specified index within the array.
Size | Returns the number of geometry objects that are in the array.

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


IsEmpty Property

[image]

Revit 2010 API
GeometryObjectArray..::.IsEmpty Property
GeometryObjectArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


Item Property

[image]

Revit 2010 API
GeometryObjectArray..::.Item Property
GeometryObjectArray Class See Also Send Feedback
Gets or sets a geometry object at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual GeometryObject Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As GeometryObject
Visual C++
public:
virtual property GeometryObject^ Item[int index] {
    GeometryObject^ get (int index);
    void set (int index, GeometryObject^ value);
}

Parameters

index
Type: System..::.Int32
The index of the geometry object to be set or retrieved.

Return Value

Returns the geometry object at the specified index.

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


Size Property

[image]

Revit 2010 API
GeometryObjectArray..::.Size Property
GeometryObjectArray Class See Also Send Feedback
Returns the number of geometry objects that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace


GeometryObjectArrayIterator Class

[image]

Revit 2010 API
GeometryObjectArrayIterator Class
Members See Also Send Feedback
An iterator to a geometry object array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class GeometryObjectArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class GeometryObjectArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GeometryObjectArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObjectArrayIterator

See Also

GeometryObjectArrayIterator Members
Autodesk.Revit.Geometry Namespace


GeometryObjectArrayIterator Members

[image] [image]

Revit 2010 API
GeometryObjectArrayIterator Members
GeometryObjectArrayIterator Class Constructors Methods Properties See Also Send Feedback

The GeometryObjectArrayIterator type exposes the following members.

Constructors

Name | Description
GeometryObjectArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GeometryObjectArrayIterator Class
Autodesk.Revit.Geometry Namespace


GeometryObjectArrayIterator Constructor

[image]

Revit 2010 API
GeometryObjectArrayIterator Constructor
GeometryObjectArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GeometryObjectArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GeometryObjectArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GeometryObjectArrayIterator Class
Autodesk.Revit.Geometry Namespace


GeometryObjectArrayIterator Methods

[image] [image]

Revit 2010 API
GeometryObjectArrayIterator Methods
GeometryObjectArrayIterator Class See Also Send Feedback

The GeometryObjectArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeometryObjectArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

[image]

Revit 2010 API
GeometryObjectArrayIterator..::.MoveNext Method
GeometryObjectArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GeometryObjectArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

[image]

Revit 2010 API
GeometryObjectArrayIterator..::.Reset Method
GeometryObjectArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GeometryObjectArrayIterator Class
Autodesk.Revit.Geometry Namespace


GeometryObjectArrayIterator Properties

[image] [image]

Revit 2010 API
GeometryObjectArrayIterator Properties
GeometryObjectArrayIterator Class See Also Send Feedback

The GeometryObjectArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GeometryObjectArrayIterator Class
Autodesk.Revit.Geometry Namespace


Current Property

[image]

Revit 2010 API
GeometryObjectArrayIterator..::.Current Property
GeometryObjectArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GeometryObjectArrayIterator Class
Autodesk.Revit.Geometry Namespace


HermiteFace Class

[image]

Revit 2010 API
HermiteFace Class
Members Example See Also Send Feedback
A cubic hermite spline face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class HermiteFace : Face
Visual Basic (Declaration)
Public Class HermiteFace _
    Inherits Face
Visual C++
public ref class HermiteFace : public Face

Remarks

Hermite faces are defined by cubic hermite spline surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces.

Examples

CopyC#
private void GetHermiteFaceInfo(Face face)
{
    HermiteFace hermiteFace = face as HermiteFace;
    if (null != hermiteFace)
    {
        XYZArray points = hermiteFace.Points;
        XYZArray derivs = hermiteFace.MixedDerivs;
        DoubleArray faceParams = hermiteFace.get_Params(0);
        XYZArray tangents = hermiteFace.get_Tangents(0);
    }
}
CopyVB.NET
Private Sub GetHermiteFaceInfo(ByVal face As Autodesk.Revit.Geometry.Face)
    Dim hermiteFace As HermiteFace = TryCast(face, HermiteFace)
    If hermiteFace IsNot Nothing Then
        Dim points As XYZArray = hermiteFace.Points
        Dim derivs As XYZArray = hermiteFace.MixedDerivs
        Dim faceParams As DoubleArray = hermiteFace.Params(0)
        Dim tangents As XYZArray = hermiteFace.Tangents(0)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Face
Autodesk.Revit.Geometry..::.HermiteFace

See Also

HermiteFace Members
Autodesk.Revit.Geometry Namespace


HermiteFace Members

[image] [image]

Revit 2010 API
HermiteFace Members
HermiteFace Class Constructors Methods Properties See Also Send Feedback

The HermiteFace type exposes the following members.

Constructors

Name | Description
HermiteFace | For Internal Use Only.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
MixedDerivs | Mixed derivatives of the surface.
Params | Parameters of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Points | Interpolation points of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Tangents | Tangents of the surface.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

HermiteFace Class
Autodesk.Revit.Geometry Namespace


HermiteFace Constructor

[image]

Revit 2010 API
HermiteFace Constructor
HermiteFace Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public HermiteFace()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HermiteFace()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

HermiteFace Class
Autodesk.Revit.Geometry Namespace


HermiteFace Methods

[image] [image]

Revit 2010 API
HermiteFace Methods
HermiteFace Class See Also Send Feedback

The HermiteFace type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

HermiteFace Class
Autodesk.Revit.Geometry Namespace


Intersect Method

[image] [image]

Revit 2010 API
HermiteFace..::.Intersect Method
HermiteFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

HermiteFace Class
HermiteFace Members
Autodesk.Revit.Geometry Namespace


IsInside Method

[image] [image]

Revit 2010 API
HermiteFace..::.IsInside Method
HermiteFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

Name | Description
IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)

See Also

HermiteFace Class
HermiteFace Members
Autodesk.Revit.Geometry Namespace


HermiteFace Properties

[image] [image]

Revit 2010 API
HermiteFace Properties
HermiteFace Class See Also Send Feedback

The HermiteFace type exposes the following members.

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
MixedDerivs | Mixed derivatives of the surface.
Params | Parameters of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Points | Interpolation points of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Tangents | Tangents of the surface.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

HermiteFace Class
Autodesk.Revit.Geometry Namespace


MixedDerivs Property

[image]

Revit 2010 API
HermiteFace..::.MixedDerivs Property
HermiteFace Class See Also Send Feedback
Mixed derivatives of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZArray MixedDerivs { get; }
Visual Basic (Declaration)
Public ReadOnly Property MixedDerivs As XYZArray
Visual C++
public:
property XYZArray^ MixedDerivs {
    XYZArray^ get ();
}

See Also

HermiteFace Class
Autodesk.Revit.Geometry Namespace


Params Property

[image]

Revit 2010 API
HermiteFace..::.Params Property
HermiteFace Class See Also Send Feedback
Parameters of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DoubleArray Params[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Params ( _
    index As Integer _
) As DoubleArray
Visual C++
public:
property DoubleArray^ Params[int index] {
    DoubleArray^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

HermiteFace Class
Autodesk.Revit.Geometry Namespace


Points Property

[image]

Revit 2010 API
HermiteFace..::.Points Property
HermiteFace Class See Also Send Feedback
Interpolation points of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZArray Points { get; }
Visual Basic (Declaration)
Public ReadOnly Property Points As XYZArray
Visual C++
public:
property XYZArray^ Points {
    XYZArray^ get ();
}

See Also

HermiteFace Class
Autodesk.Revit.Geometry Namespace


Tangents Property

[image]

Revit 2010 API
HermiteFace..::.Tangents Property
HermiteFace Class See Also Send Feedback
Tangents of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZArray Tangents[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tangents ( _
    index As Integer _
) As XYZArray
Visual C++
public:
property XYZArray^ Tangents[int index] {
    XYZArray^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

HermiteFace Class
Autodesk.Revit.Geometry Namespace


HermiteSpline Class

[image]

Revit 2010 API
HermiteSpline Class
Members See Also Send Feedback
A Hermite spline.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class HermiteSpline : Curve
Visual Basic (Declaration)
Public Class HermiteSpline _
    Inherits Curve
Visual C++
public ref class HermiteSpline : public Curve

Remarks

The Hermite spline lies in the plane defined by control points.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Curve
Autodesk.Revit.Geometry..::.HermiteSpline

See Also

HermiteSpline Members
Autodesk.Revit.Geometry Namespace


HermiteSpline Members

[image] [image]

Revit 2010 API
HermiteSpline Members
HermiteSpline Class Constructors Methods Properties See Also Send Feedback

The HermiteSpline type exposes the following members.

Constructors

Name | Description
HermiteSpline | For Internal Use Only.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
ControlPoints | The control points of the Hermite spline.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
IsPeriodic | Returns whether the Hermite spline is periodic or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve. (Inherited from Curve.)
Parameters | Returns the params of the Hermite spline.
Period | The period of this curve. (Inherited from Curve.)
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Tangents | Returns the tangents of the Hermite spline.
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

HermiteSpline Class
Autodesk.Revit.Geometry Namespace


HermiteSpline Constructor

[image]

Revit 2010 API
HermiteSpline Constructor
HermiteSpline Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public HermiteSpline()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HermiteSpline()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

HermiteSpline Class
Autodesk.Revit.Geometry Namespace


HermiteSpline Methods

[image] [image]

Revit 2010 API
HermiteSpline Methods
HermiteSpline Class See Also Send Feedback

The HermiteSpline type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HermiteSpline Class
Autodesk.Revit.Geometry Namespace


Intersect Method

[image] [image]

Revit 2010 API
HermiteSpline..::.Intersect Method
HermiteSpline Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

HermiteSpline Class
HermiteSpline Members
Autodesk.Revit.Geometry Namespace


IsInside Method

[image] [image]

Revit 2010 API
HermiteSpline..::.IsInside Method
HermiteSpline Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

Name | Description
IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)

See Also

HermiteSpline Class
HermiteSpline Members
Autodesk.Revit.Geometry Namespace


HermiteSpline Properties

[image] [image]

Revit 2010 API
HermiteSpline Properties
HermiteSpline Class See Also Send Feedback

The HermiteSpline type exposes the following members.

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
ControlPoints | The control points of the Hermite spline.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
IsPeriodic | Returns whether the Hermite spline is periodic or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve. (Inherited from Curve.)
Parameters | Returns the params of the Hermite spline.
Period | The period of this curve. (Inherited from Curve.)
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Tangents | Returns the tangents of the Hermite spline.
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

HermiteSpline Class
Autodesk.Revit.Geometry Namespace


ControlPoints Property

[image]

Revit 2010 API
HermiteSpline..::.ControlPoints Property
HermiteSpline Class See Also Send Feedback
The control points of the Hermite spline.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZArray ControlPoints { get; set; }
Visual Basic (Declaration)
Public Property ControlPoints As XYZArray
Visual C++
public:
property XYZArray^ ControlPoints {
    XYZArray^ get ();
    void set (XYZArray^ value);
}

See Also

HermiteSpline Class
Autodesk.Revit.Geometry Namespace


IsPeriodic Property

[image]

Revit 2010 API
HermiteSpline..::.IsPeriodic Property
HermiteSpline Class See Also Send Feedback
Returns whether the Hermite spline is periodic or not.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsPeriodic { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPeriodic As Boolean
Visual C++
public:
property bool IsPeriodic {
    bool get ();
}

See Also

HermiteSpline Class
Autodesk.Revit.Geometry Namespace


Parameters Property

[image]

Revit 2010 API
HermiteSpline..::.Parameters Property
HermiteSpline Class See Also Send Feedback
Returns the params of the Hermite spline.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DoubleArray Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As DoubleArray
Visual C++
public:
property DoubleArray^ Parameters {
    DoubleArray^ get ();
}

See Also

HermiteSpline Class
Autodesk.Revit.Geometry Namespace


Tangents Property

[image]

Revit 2010 API
HermiteSpline..::.Tangents Property
HermiteSpline Class See Also Send Feedback
Returns the tangents of the Hermite spline.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZArray Tangents { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tangents As XYZArray
Visual C++
public:
property XYZArray^ Tangents {
    XYZArray^ get ();
}

See Also

HermiteSpline Class
Autodesk.Revit.Geometry Namespace


Instance Class

[image]

Revit 2010 API
Instance Class
Members See Also Send Feedback
An instance of another element (symbol), specially positioned by this element.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Instance : GeometryObject
Visual Basic (Declaration)
Public Class Instance _
    Inherits GeometryObject
Visual C++
public ref class Instance : public GeometryObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Instance

See Also

Instance Members
Autodesk.Revit.Geometry Namespace


Instance Members

[image] [image]

Revit 2010 API
Instance Members
Instance Class Constructors Methods Properties See Also Send Feedback

The Instance type exposes the following members.

Constructors

Name | Description
Instance | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInstanceGeometry | Overloaded.
GetSymbolGeometry | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Symbol | The symbol element that this object is referring to.
SymbolGeometry | The geometric representation of the symbol which generates this instance.
Transform | The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Instance Class
Autodesk.Revit.Geometry Namespace


Instance Constructor

[image]

Revit 2010 API
Instance Constructor
Instance Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Instance()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Instance()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Instance Class
Autodesk.Revit.Geometry Namespace


Instance Methods

[image] [image]

Revit 2010 API
Instance Methods
Instance Class See Also Send Feedback

The Instance type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInstanceGeometry | Overloaded.
GetSymbolGeometry | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Instance Class
Autodesk.Revit.Geometry Namespace


GetInstanceGeometry Method

[image] [image]

Revit 2010 API
Instance..::.GetInstanceGeometry Method
Instance Class See Also Send Feedback

Overload List

Name | Description
GetInstanceGeometry()()() | Computes the geometric representation of the instance.
GetInstanceGeometry(Transform) | Computes a transformation of the geometric representation of the instance.

See Also

Instance Class
Instance Members
Autodesk.Revit.Geometry Namespace


GetInstanceGeometry Method

[image]

Revit 2010 API
Instance..::.GetInstanceGeometry Method
Instance Class See Also Send Feedback
Computes the geometric representation of the instance.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element GetInstanceGeometry()
Visual Basic (Declaration)
Public Function GetInstanceGeometry As Element
Visual C++
public:
Element^ GetInstanceGeometry()

Return Value

An element which contains the computed geometry for the instance.

Remarks

The geometry will be in the coordinate system of the model that owns this instance. The context of the instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved.

See Also

Instance Class
GetInstanceGeometry Overload
Autodesk.Revit.Geometry Namespace


GetInstanceGeometry Method (Transform)

[image]

Revit 2010 API
Instance..::.GetInstanceGeometry Method (Transform)
Instance Class See Also Send Feedback
Computes a transformation of the geometric representation of the instance.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element GetInstanceGeometry(
    Transform transform
)
Visual Basic (Declaration)
Public Function GetInstanceGeometry ( _
    transform As Transform _
) As Element
Visual C++
public:
Element^ GetInstanceGeometry(
    Transform^ transform
)

Parameters

transform
Type: Autodesk.Revit.Geometry..::.Transform
The transformation to apply to the geometry.

Return Value

An element which contains the computed geometry for the transformed instance.

Remarks

The context of the instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved.

See Also

Instance Class
GetInstanceGeometry Overload
Autodesk.Revit.Geometry Namespace


GetSymbolGeometry Method

[image] [image]

Revit 2010 API
Instance..::.GetSymbolGeometry Method
Instance Class See Also Send Feedback

Overload List

Name | Description
GetSymbolGeometry()()() | Computes the geometric representation of the symbol which generates this instance.
GetSymbolGeometry(Transform) | Computes a transformation of the geometric representation of the symbol which generates this instance.

See Also

Instance Class
Instance Members
Autodesk.Revit.Geometry Namespace


GetSymbolGeometry Method

[image]

Revit 2010 API
Instance..::.GetSymbolGeometry Method
Instance Class See Also Send Feedback
Computes the geometric representation of the symbol which generates this instance.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element GetSymbolGeometry()
Visual Basic (Declaration)
Public Function GetSymbolGeometry As Element
Visual C++
public:
Element^ GetSymbolGeometry()

Return Value

An element which contains the computed geometry for the symbol.

Remarks

The geometry will be in the the local coordinate space of the symbol. The context of this instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved. The results of the method and the value of the SymbolGeometry property are identical.

See Also

Instance Class
GetSymbolGeometry Overload
Autodesk.Revit.Geometry Namespace


GetSymbolGeometry Method (Transform)

[image]

Revit 2010 API
Instance..::.GetSymbolGeometry Method (Transform)
Instance Class See Also Send Feedback
Computes a transformation of the geometric representation of the symbol which generates this instance.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element GetSymbolGeometry(
    Transform transform
)
Visual Basic (Declaration)
Public Function GetSymbolGeometry ( _
    transform As Transform _
) As Element
Visual C++
public:
Element^ GetSymbolGeometry(
    Transform^ transform
)

Parameters

transform
Type: Autodesk.Revit.Geometry..::.Transform
The transformation to apply to the geometry.

Return Value

An element which contains the computed geometry for the transformed symbol.

Remarks

The context of this instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved.

See Also

Instance Class
GetSymbolGeometry Overload
Autodesk.Revit.Geometry Namespace


Instance Properties

[image] [image]

Revit 2010 API
Instance Properties
Instance Class See Also Send Feedback

The Instance type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Symbol | The symbol element that this object is referring to.
SymbolGeometry | The geometric representation of the symbol which generates this instance.
Transform | The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Instance Class
Autodesk.Revit.Geometry Namespace


Symbol Property

[image]

Revit 2010 API
Instance..::.Symbol Property
Instance Class See Also Send Feedback
The symbol element that this object is referring to.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element Symbol { get; }
Visual Basic (Declaration)
Public ReadOnly Property Symbol As Element
Visual C++
public:
property Element^ Symbol {
    Element^ get ();
}

See Also

Instance Class
Autodesk.Revit.Geometry Namespace


SymbolGeometry Property

[image]

Revit 2010 API
Instance..::.SymbolGeometry Property
Instance Class See Also Send Feedback
The geometric representation of the symbol which generates this instance.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element SymbolGeometry { get; }
Visual Basic (Declaration)
Public ReadOnly Property SymbolGeometry As Element
Visual C++
public:
property Element^ SymbolGeometry {
    Element^ get ();
}

Remarks

The geometry will be in the the local coordinate space of the symbol. The context of this instance object (such as effective material) will be applied to the symbol. Note that retrieving the value of this property involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved. The value of this property and the results of the method GetSymbolGeometry(void) are identical.

See Also

Instance Class
Autodesk.Revit.Geometry Namespace


Transform Property

[image]

Revit 2010 API
Instance..::.Transform Property
Instance Class See Also Send Feedback
The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Transform Transform { get; }
Visual Basic (Declaration)
Public ReadOnly Property Transform As Transform
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
}

See Also

Instance Class
Autodesk.Revit.Geometry Namespace


InstanceArray Class

[image]

Revit 2010 API
InstanceArray Class
Members See Also Send Feedback
An array that contains instances.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class InstanceArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class InstanceArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class InstanceArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.InstanceArray

See Also

InstanceArray Members
Autodesk.Revit.Geometry Namespace


InstanceArray Members

[image] [image]

Revit 2010 API
InstanceArray Members
InstanceArray Class Constructors Methods Properties See Also Send Feedback

The InstanceArray type exposes the following members.

Constructors

Name | Description
InstanceArray | Initializes a new instance of the InstanceArray class

Methods

Name | Description
Append | Add the instance to the end of the array.
Clear | Removes every instance from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified instance into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an instance at a specified index within the array.
Size | Returns the number of instances that are in the array.

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


InstanceArray Constructor

[image]

Revit 2010 API
InstanceArray Constructor
InstanceArray Class See Also Send Feedback
Initializes a new instance of the InstanceArray class

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InstanceArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InstanceArray()

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


InstanceArray Methods

[image] [image]

Revit 2010 API
InstanceArray Methods
InstanceArray Class See Also Send Feedback

The InstanceArray type exposes the following members.

Methods

Name | Description
Append | Add the instance to the end of the array.
Clear | Removes every instance from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified instance into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


Append Method

[image]

Revit 2010 API
InstanceArray..::.Append Method
InstanceArray Class See Also Send Feedback
Add the instance to the end of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    Instance item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Instance _
)
Visual C++
public:
virtual void Append(
    Instance^ item
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.Instance
The instance to be added.

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

[image]

Revit 2010 API
InstanceArray..::.Clear Method
InstanceArray Class See Also Send Feedback
Removes every instance from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

[image]

Revit 2010 API
InstanceArray..::.ForwardIterator Method
InstanceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual InstanceArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As InstanceArrayIterator
Visual C++
public:
virtual InstanceArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

[image]

Revit 2010 API
InstanceArray..::.GetEnumerator Method
InstanceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

[image]

Revit 2010 API
InstanceArray..::.Insert Method
InstanceArray Class See Also Send Feedback
Insert the specified instance into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    Instance item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Instance, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Instance^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.Instance
The instance to be inserted into the array.
index
Type: System..::.Int32
The instance will be inserted before this index.

Return Value

Returns whether the instance was inserted into the array.

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

[image]

Revit 2010 API
InstanceArray..::.ReverseIterator Method
InstanceArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual InstanceArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As InstanceArrayIterator
Visual C++
public:
virtual InstanceArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


InstanceArray Properties

[image] [image]

Revit 2010 API
InstanceArray Properties
InstanceArray Class See Also Send Feedback

The InstanceArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an instance at a specified index within the array.
Size | Returns the number of instances that are in the array.

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


IsEmpty Property

[image]

Revit 2010 API
InstanceArray..::.IsEmpty Property
InstanceArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


Item Property

[image]

Revit 2010 API
InstanceArray..::.Item Property
InstanceArray Class See Also Send Feedback
Gets or sets an instance at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Instance Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Instance
Visual C++
public:
virtual property Instance^ Item[int index] {
    Instance^ get (int index);
    void set (int index, Instance^ value);
}

Parameters

index
Type: System..::.Int32
The index of the instance to be set or retrieved.

Return Value

Returns the instance at the specified index.

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


Size Property

[image]

Revit 2010 API
InstanceArray..::.Size Property
InstanceArray Class See Also Send Feedback
Returns the number of instances that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace


InstanceArrayIterator Class

[image]

Revit 2010 API
InstanceArrayIterator Class
Members See Also Send Feedback
An iterator to an instance array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class InstanceArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class InstanceArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class InstanceArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.InstanceArrayIterator

See Also

InstanceArrayIterator Members
Autodesk.Revit.Geometry Namespace


InstanceArrayIterator Members

[image] [image]

Revit 2010 API
InstanceArrayIterator Members
InstanceArrayIterator Class Constructors Methods Properties See Also Send Feedback

The InstanceArrayIterator type exposes the following members.

Constructors

Name | Description
InstanceArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InstanceArrayIterator Class
Autodesk.Revit.Geometry Namespace


InstanceArrayIterator Constructor

[image]

Revit 2010 API
InstanceArrayIterator Constructor
InstanceArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InstanceArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InstanceArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

InstanceArrayIterator Class
Autodesk.Revit.Geometry Namespace


InstanceArrayIterator Methods

[image] [image]

Revit 2010 API
InstanceArrayIterator Methods
InstanceArrayIterator Class See Also Send Feedback

The InstanceArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstanceArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

[image]

Revit 2010 API
InstanceArrayIterator..::.MoveNext Method
InstanceArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

InstanceArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

[image]

Revit 2010 API
InstanceArrayIterator..::.Reset Method
InstanceArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

InstanceArrayIterator Class
Autodesk.Revit.Geometry Namespace


InstanceArrayIterator Properties

[image] [image]

Revit 2010 API
InstanceArrayIterator Properties
InstanceArrayIterator Class See Also Send Feedback

The InstanceArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InstanceArrayIterator Class
Autodesk.Revit.Geometry Namespace


Current Property

[image]

Revit 2010 API
InstanceArrayIterator..::.Current Property
InstanceArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

InstanceArrayIterator Class
Autodesk.Revit.Geometry Namespace


IntersectionResult Class

[image]

Revit 2010 API
IntersectionResult Class
Members See Also Send Feedback
This class captures results of intersecting geometric entities. "Intersecting" is meant in generalized sense, so the same class will be used for projection, containment, etc. Refer to the documentation of the method providing the result for the precise meaning of properties.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class IntersectionResult : APIObject
Visual Basic (Declaration)
Public Class IntersectionResult _
    Inherits APIObject
Visual C++
public ref class IntersectionResult : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.IntersectionResult

See Also

IntersectionResult Members
Autodesk.Revit.Geometry Namespace


IntersectionResult Members

[image] [image]

Revit 2010 API
IntersectionResult Members
IntersectionResult Class Constructors Methods Properties See Also Send Feedback

The IntersectionResult type exposes the following members.

Constructors

Name | Description
IntersectionResult | Initializes a new instance of the IntersectionResult class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Distance | Distance from the original object to located point.
EdgeObject | Edge of the face close to the point of intersection.
EdgeParameter | Parameter of a point on the edge closest to the point of intersection.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Parameter | 1d parameter of the point of intersection.
UVPoint | 2d (or two 1d) parameters of the point of intersection.
XYZPoint | Point of intersection in local 3d coordinates.

See Also

IntersectionResult Class
Autodesk.Revit.Geometry Namespace


IntersectionResult Constructor

[image]

Revit 2010 API
IntersectionResult Constructor
IntersectionResult Class See Also Send Feedback
Initializes a new instance of the IntersectionResult class

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public IntersectionResult()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
IntersectionResult()

See Also

IntersectionResult Class
Autodesk.Revit.Geometry Namespace


IntersectionResult Methods

[image] [image]

Revit 2010 API
IntersectionResult Methods
IntersectionResult Class See Also Send Feedback

The IntersectionResult type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IntersectionResult Class
Autodesk.Revit.Geometry Namespace


IntersectionResult Properties

[image] [image]

Revit 2010 API
IntersectionResult Properties
IntersectionResult Class See Also Send Feedback

The IntersectionResult type exposes the following members.

Properties

Name | Description
Distance | Distance from the original object to located point.
EdgeObject | Edge of the face close to the point of intersection.
EdgeParameter | Parameter of a point on the edge closest to the point of intersection.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Parameter | 1d parameter of the point of intersection.
UVPoint | 2d (or two 1d) parameters of the point of intersection.
XYZPoint | Point of intersection in local 3d coordinates.

See Also

IntersectionResult Class
Autodesk.Revit.Geometry Namespace


Distance Property

[image]

Revit 2010 API
IntersectionResult..::.Distance Property
IntersectionResult Class See Also Send Feedback
Distance from the original object to located point.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Distance { get; internal set; }
Visual Basic (Declaration)
Public Property Distance As Double
Visual C++
public:
property double Distance {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class
Autodesk.Revit.Geometry Namespace


EdgeObject Property

[image]

Revit 2010 API
IntersectionResult..::.EdgeObject Property
IntersectionResult Class See Also Send Feedback
Edge of the face close to the point of intersection.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Edge EdgeObject { get; internal set; }
Visual Basic (Declaration)
Public Property EdgeObject As Edge
Visual C++
public:
property Edge^ EdgeObject {
    Edge^ get ();
    void set (Edge^ value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class
Autodesk.Revit.Geometry Namespace


EdgeParameter Property

[image]

Revit 2010 API
IntersectionResult..::.EdgeParameter Property
IntersectionResult Class See Also Send Feedback
Parameter of a point on the edge closest to the point of intersection.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double EdgeParameter { get; internal set; }
Visual Basic (Declaration)
Public Property EdgeParameter As Double
Visual C++
public:
property double EdgeParameter {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class
Autodesk.Revit.Geometry Namespace


Parameter Property

[image]

Revit 2010 API
IntersectionResult..::.Parameter Property
IntersectionResult Class See Also Send Feedback
1d parameter of the point of intersection.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Parameter { get; internal set; }
Visual Basic (Declaration)
Public Property Parameter As Double
Visual C++
public:
property double Parameter {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class
Autodesk.Revit.Geometry Namespace


UVPoint Property

[image]

Revit 2010 API
IntersectionResult..::.UVPoint Property
IntersectionResult Class See Also Send Feedback
2d (or two 1d) parameters of the point of intersection.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV UVPoint { get; internal set; }
Visual Basic (Declaration)
Public Property UVPoint As UV
Visual C++
public:
property UV^ UVPoint {
    UV^ get ();
    void set (UV^ value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class
Autodesk.Revit.Geometry Namespace


XYZPoint Property

[image]

Revit 2010 API
IntersectionResult..::.XYZPoint Property
IntersectionResult Class See Also Send Feedback
Point of intersection in local 3d coordinates.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ XYZPoint { get; internal set; }
Visual Basic (Declaration)
Public Property XYZPoint As XYZ
Visual C++
public:
property XYZ^ XYZPoint {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class
Autodesk.Revit.Geometry Namespace


IntersectionResultArray Class

[image]

Revit 2010 API
IntersectionResultArray Class
Members See Also Send Feedback
An array that can contain any type of object.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class IntersectionResultArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class IntersectionResultArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class IntersectionResultArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.IntersectionResultArray

See Also

IntersectionResultArray Members
Autodesk.Revit.Geometry Namespace


IntersectionResultArray Members

[image] [image]

Revit 2010 API
IntersectionResultArray Members
IntersectionResultArray Class Constructors Methods Properties See Also Send Feedback

The IntersectionResultArray type exposes the following members.

Constructors

Name | Description
IntersectionResultArray | Initializes a new instance of the IntersectionResultArray class

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


IntersectionResultArray Constructor

[image]

Revit 2010 API
IntersectionResultArray Constructor
IntersectionResultArray Class See Also Send Feedback
Initializes a new instance of the IntersectionResultArray class

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public IntersectionResultArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
IntersectionResultArray()

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


IntersectionResultArray Methods

[image] [image]

Revit 2010 API
IntersectionResultArray Methods
IntersectionResultArray Class See Also Send Feedback

The IntersectionResultArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


Append Method

[image]

Revit 2010 API
IntersectionResultArray..::.Append Method
IntersectionResultArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    IntersectionResult item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As IntersectionResult _
)
Visual C++
public:
virtual void Append(
    IntersectionResult^ item
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.IntersectionResult

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

[image]

Revit 2010 API
IntersectionResultArray..::.Clear Method
IntersectionResultArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

[image]

Revit 2010 API
IntersectionResultArray..::.ForwardIterator Method
IntersectionResultArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IntersectionResultArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As IntersectionResultArrayIterator
Visual C++
public:
virtual IntersectionResultArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

[image]

Revit 2010 API
IntersectionResultArray..::.GetEnumerator Method
IntersectionResultArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

[image]

Revit 2010 API
IntersectionResultArray..::.Insert Method
IntersectionResultArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    IntersectionResult item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As IntersectionResult, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    IntersectionResult^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.IntersectionResult
index
Type: System..::.Int32

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

[image]

Revit 2010 API
IntersectionResultArray..::.ReverseIterator Method
IntersectionResultArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IntersectionResultArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As IntersectionResultArrayIterator
Visual C++
public:
virtual IntersectionResultArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


IntersectionResultArray Properties

[image] [image]

Revit 2010 API
IntersectionResultArray Properties
IntersectionResultArray Class See Also Send Feedback

The IntersectionResultArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


IsEmpty Property

[image]

Revit 2010 API
IntersectionResultArray..::.IsEmpty Property
IntersectionResultArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


Item Property

[image]

Revit 2010 API
IntersectionResultArray..::.Item Property
IntersectionResultArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IntersectionResult Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As IntersectionResult
Visual C++
public:
virtual property IntersectionResult^ Item[int index] {
    IntersectionResult^ get (int index);
    void set (int index, IntersectionResult^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


Size Property

[image]

Revit 2010 API
IntersectionResultArray..::.Size Property
IntersectionResultArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

IntersectionResultArray Class
Autodesk.Revit.Geometry Namespace


IntersectionResultArrayIterator Class

[image]

Revit 2010 API
IntersectionResultArrayIterator Class
Members See Also Send Feedback
An iterator to a array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class IntersectionResultArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class IntersectionResultArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class IntersectionResultArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.IntersectionResultArrayIterator

See Also

IntersectionResultArrayIterator Members
Autodesk.Revit.Geometry Namespace


IntersectionResultArrayIterator Members

[image] [image]

Revit 2010 API
IntersectionResultArrayIterator Members
IntersectionResultArrayIterator Class Constructors Methods Properties See Also Send Feedback

The IntersectionResultArrayIterator type exposes the following members.

Constructors

Name | Description
IntersectionResultArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

IntersectionResultArrayIterator Class
Autodesk.Revit.Geometry Namespace


IntersectionResultArrayIterator Constructor

[image]

Revit 2010 API
IntersectionResultArrayIterator Constructor
IntersectionResultArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public IntersectionResultArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
IntersectionResultArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

IntersectionResultArrayIterator Class
Autodesk.Revit.Geometry Namespace


IntersectionResultArrayIterator Methods

[image] [image]

Revit 2010 API
IntersectionResultArrayIterator Methods
IntersectionResultArrayIterator Class See Also Send Feedback

The IntersectionResultArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IntersectionResultArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

[image]

Revit 2010 API
IntersectionResultArrayIterator..::.MoveNext Method
IntersectionResultArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

IntersectionResultArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

[image]

Revit 2010 API
IntersectionResultArrayIterator..::.Reset Method
IntersectionResultArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

IntersectionResultArrayIterator Class
Autodesk.Revit.Geometry Namespace


IntersectionResultArrayIterator Properties

[image] [image]

Revit 2010 API
IntersectionResultArrayIterator Properties
IntersectionResultArrayIterator Class See Also Send Feedback

The IntersectionResultArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

IntersectionResultArrayIterator Class
Autodesk.Revit.Geometry Namespace


Current Property

[image]

Revit 2010 API
IntersectionResultArrayIterator..::.Current Property
IntersectionResultArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

IntersectionResultArrayIterator Class
Autodesk.Revit.Geometry Namespace


Line Class

[image]

Revit 2010 API
Line Class
Members See Also Send Feedback
A line in space.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Line : Curve
Visual Basic (Declaration)
Public Class Line _
    Inherits Curve
Visual C++
public ref class Line : public Curve

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Curve
Autodesk.Revit.Geometry..::.Line

See Also

Line Members
Autodesk.Revit.Geometry Namespace


Line Members

[image] [image]

Revit 2010 API
Line Members
Line Class Constructors Methods Properties See Also Send Feedback

The Line type exposes the following members.

Constructors

Name | Description
Line | For Internal Use Only.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Bound | Returns the bounded line between the specified points.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve. (Inherited from Curve.)
Period | The period of this curve. (Inherited from Curve.)
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Unbound | Returns the unbounded line that passes through the specified point in the direction of the specified vector.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Line Class
Autodesk.Revit.Geometry Namespace


Line Constructor

[image]

Revit 2010 API
Line Constructor
Line Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Line()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Line()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Line Class
Autodesk.Revit.Geometry Namespace


Line Methods

[image] [image]

Revit 2010 API
Line Methods
Line Class See Also Send Feedback

The Line type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Line Class
Autodesk.Revit.Geometry Namespace


Intersect Method

[image] [image]

Revit 2010 API
Line..::.Intersect Method
Line Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

Line Class
Line Members
Autodesk.Revit.Geometry Namespace


IsInside Method

[image] [image]

Revit 2010 API
Line..::.IsInside Method
Line Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

Name | Description
IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)

See Also

Line Class
Line Members
Autodesk.Revit.Geometry Namespace


Line Properties

[image] [image]

Revit 2010 API
Line Properties
Line Class See Also Send Feedback

The Line type exposes the following members.

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Bound | Returns the bounded line between the specified points.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve. (Inherited from Curve.)
Period | The period of this curve. (Inherited from Curve.)
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Unbound | Returns the unbounded line that passes through the specified point in the direction of the specified vector.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Line Class
Autodesk.Revit.Geometry Namespace


Bound Property

[image]

Revit 2010 API
Line..::.Bound Property
Line Class See Also Send Feedback
Returns the bounded line between the specified points.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static Line Bound[
    XYZ startPoint,
    XYZ endPoint
] { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Bound ( _
    startPoint As XYZ, _
    endPoint As XYZ _
) As Line
Visual C++
public:
static property Line^ Bound[XYZ^ startPoint, XYZ^ endPoint] {
    Line^ get (XYZ^ startPoint, XYZ^ endPoint);
}

Parameters

startPoint
Type: Autodesk.Revit.Geometry..::.XYZ
The start point of the line.
endPoint
Type: Autodesk.Revit.Geometry..::.XYZ
The end point of the line.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the specified points are almost equal.

See Also

Line Class
Autodesk.Revit.Geometry Namespace


Unbound Property

[image]

Revit 2010 API
Line..::.Unbound Property
Line Class See Also Send Feedback
Returns the unbounded line that passes through the specified point in the direction of the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static Line Unbound[
    XYZ origin,
    XYZ vector
] { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Unbound ( _
    origin As XYZ, _
    vector As XYZ _
) As Line
Visual C++
public:
static property Line^ Unbound[XYZ^ origin, XYZ^ vector] {
    Line^ get (XYZ^ origin, XYZ^ vector);
}

Parameters

origin
Type: Autodesk.Revit.Geometry..::.XYZ
The start point of the line.
vector
Type: Autodesk.Revit.Geometry..::.XYZ
The direction vector.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the specified vector is almost zero and cannot be normalized.

See Also

Line Class
Autodesk.Revit.Geometry Namespace


Mesh Class

[image]

Revit 2010 API
Mesh Class
Members See Also Send Feedback
A triangular mesh.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Mesh : GeometryObject
Visual Basic (Declaration)
Public Class Mesh _
    Inherits GeometryObject
Visual C++
public ref class Mesh : public GeometryObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Mesh

See Also

Mesh Members
Autodesk.Revit.Geometry Namespace


Mesh Members

[image] [image]

Revit 2010 API
Mesh Members
Mesh Class Constructors Methods Properties See Also Send Feedback

The Mesh type exposes the following members.

Constructors

Name | Description
Mesh | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
NumTriangles | The number of triangles that the mesh contains.
Transformed | Transforms this mesh and returns the result.
Triangle | Retrieves a specific triangle.
Vertices | Retrieves all vertices used to define this mesh. Intended for indexed access.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Mesh Class
Autodesk.Revit.Geometry Namespace


Mesh Constructor

[image]

Revit 2010 API
Mesh Constructor
Mesh Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Mesh()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Mesh()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Mesh Class
Autodesk.Revit.Geometry Namespace


Mesh Methods

[image] [image]

Revit 2010 API
Mesh Methods
Mesh Class See Also Send Feedback

The Mesh type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Mesh Class
Autodesk.Revit.Geometry Namespace


Mesh Properties

[image] [image]

Revit 2010 API
Mesh Properties
Mesh Class See Also Send Feedback

The Mesh type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
NumTriangles | The number of triangles that the mesh contains.
Transformed | Transforms this mesh and returns the result.
Triangle | Retrieves a specific triangle.
Vertices | Retrieves all vertices used to define this mesh. Intended for indexed access.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Mesh Class
Autodesk.Revit.Geometry Namespace


NumTriangles Property

[image]

Revit 2010 API
Mesh..::.NumTriangles Property
Mesh Class See Also Send Feedback
The number of triangles that the mesh contains.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NumTriangles { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumTriangles As Integer
Visual C++
public:
property int NumTriangles {
    int get ();
}

See Also

Mesh Class
Autodesk.Revit.Geometry Namespace


Transformed Property

[image]

Revit 2010 API
Mesh..::.Transformed Property
Mesh Class See Also Send Feedback
Transforms this mesh and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Mesh Transformed[
    Transform transform
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Transformed ( _
    transform As Transform _
) As Mesh
Visual C++
public:
property Mesh^ Transformed[Transform^ transform] {
    Mesh^ get (Transform^ transform);
}

Parameters

transform
Type: Autodesk.Revit.Geometry..::.Transform
The transformation used to transform the profile.

Return Value

The transformed mesh.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the handle of the specified transformation is null.

See Also

Mesh Class
Autodesk.Revit.Geometry Namespace


Triangle Property

[image]

Revit 2010 API
Mesh..::.Triangle Property
Mesh Class See Also Send Feedback
Retrieves a specific triangle.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MeshTriangle Triangle[
    int idx
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Triangle ( _
    idx As Integer _
) As MeshTriangle
Visual C++
public:
property MeshTriangle^ Triangle[int idx] {
    MeshTriangle^ get (int idx);
}

Parameters

idx
Type: System..::.Int32
Index of the triangle, must be in [0, NumTriangles).

See Also

Mesh Class
Autodesk.Revit.Geometry Namespace


Vertices Property

[image]

Revit 2010 API
Mesh..::.Vertices Property
Mesh Class See Also Send Feedback
Retrieves all vertices used to define this mesh. Intended for indexed access.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZArray Vertices { get; }
Visual Basic (Declaration)
Public ReadOnly Property Vertices As XYZArray
Visual C++
public:
property XYZArray^ Vertices {
    XYZArray^ get ();
}

See Also

Mesh Class
Autodesk.Revit.Geometry Namespace


MeshArray Class

[image]

Revit 2010 API
MeshArray Class
Members See Also Send Feedback
An array that contains meshes.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MeshArray : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class MeshArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class MeshArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.MeshArray

See Also

MeshArray Members
Autodesk.Revit.Geometry Namespace


MeshArray Members

[image] [image]

Revit 2010 API
MeshArray Members
MeshArray Class Constructors Methods Properties See Also Send Feedback

The MeshArray type exposes the following members.

Constructors

Name | Description
MeshArray | Initializes a new instance of the MeshArray class

Methods

Name | Description
Append | Add the mesh to the end of the array.
Clear | Removes every mesh from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified mesh into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a mesh at a specified index within the array.
Size | Returns the number of meshes that are in the array.

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


MeshArray Constructor

[image]

Revit 2010 API
MeshArray Constructor
MeshArray Class See Also Send Feedback
Initializes a new instance of the MeshArray class

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MeshArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MeshArray()

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


MeshArray Methods

[image] [image]

Revit 2010 API
MeshArray Methods
MeshArray Class See Also Send Feedback

The MeshArray type exposes the following members.

Methods

Name | Description
Append | Add the mesh to the end of the array.
Clear | Removes every mesh from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified mesh into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


Append Method

[image]

Revit 2010 API
MeshArray..::.Append Method
MeshArray Class See Also Send Feedback
Add the mesh to the end of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    Mesh item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Mesh _
)
Visual C++
public:
virtual void Append(
    Mesh^ item
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.Mesh
The mesh to be added.

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

[image]

Revit 2010 API
MeshArray..::.Clear Method
MeshArray Class See Also Send Feedback
Removes every mesh from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

[image]

Revit 2010 API
MeshArray..::.ForwardIterator Method
MeshArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual MeshArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As MeshArrayIterator
Visual C++
public:
virtual MeshArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

[image]

Revit 2010 API
MeshArray..::.GetEnumerator Method
MeshArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

[image]

Revit 2010 API
MeshArray..::.Insert Method
MeshArray Class See Also Send Feedback
Insert the specified mesh into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    Mesh item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Mesh, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Mesh^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.Mesh
The mesh to be inserted into the array.
index
Type: System..::.Int32
The mesh will be inserted before this index.

Return Value

Returns whether the mesh was inserted into the array.

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

[image]

Revit 2010 API
MeshArray..::.ReverseIterator Method
MeshArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual MeshArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As MeshArrayIterator
Visual C++
public:
virtual MeshArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


MeshArray Properties

[image] [image]

Revit 2010 API
MeshArray Properties
MeshArray Class See Also Send Feedback

The MeshArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a mesh at a specified index within the array.
Size | Returns the number of meshes that are in the array.

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


IsEmpty Property

[image]

Revit 2010 API
MeshArray..::.IsEmpty Property
MeshArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


Item Property

[image]

Revit 2010 API
MeshArray..::.Item Property
MeshArray Class See Also Send Feedback
Gets or sets a mesh at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Mesh Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Mesh
Visual C++
public:
virtual property Mesh^ Item[int index] {
    Mesh^ get (int index);
    void set (int index, Mesh^ value);
}

Parameters

index
Type: System..::.Int32
The index of the mesh to be set or retrieved.

Return Value

Returns the mesh at the specified index.

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


Size Property

[image]

Revit 2010 API
MeshArray..::.Size Property
MeshArray Class See Also Send Feedback
Returns the number of meshes that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

MeshArray Class
Autodesk.Revit.Geometry Namespace


MeshArrayIterator Class

[image]

Revit 2010 API
MeshArrayIterator Class
Members See Also Send Feedback
An iterator to a mesh array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class MeshArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class MeshArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class MeshArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.MeshArrayIterator

See Also

MeshArrayIterator Members
Autodesk.Revit.Geometry Namespace


MeshArrayIterator Members

[image] [image]

Revit 2010 API
MeshArrayIterator Members
MeshArrayIterator Class Constructors Methods Properties See Also Send Feedback

The MeshArrayIterator type exposes the following members.

Constructors

Name | Description
MeshArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MeshArrayIterator Class
Autodesk.Revit.Geometry Namespace


MeshArrayIterator Constructor

[image]

Revit 2010 API
MeshArrayIterator Constructor
MeshArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MeshArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MeshArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MeshArrayIterator Class
Autodesk.Revit.Geometry Namespace


MeshArrayIterator Methods

[image] [image]

Revit 2010 API
MeshArrayIterator Methods
MeshArrayIterator Class See Also Send Feedback

The MeshArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MeshArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

[image]

Revit 2010 API
MeshArrayIterator..::.MoveNext Method
MeshArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

MeshArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

[image]

Revit 2010 API
MeshArrayIterator..::.Reset Method
MeshArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

MeshArrayIterator Class
Autodesk.Revit.Geometry Namespace


MeshArrayIterator Properties

[image] [image]

Revit 2010 API
MeshArrayIterator Properties
MeshArrayIterator Class See Also Send Feedback

The MeshArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MeshArrayIterator Class
Autodesk.Revit.Geometry Namespace


Current Property

[image]

Revit 2010 API
MeshArrayIterator..::.Current Property
MeshArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

MeshArrayIterator Class
Autodesk.Revit.Geometry Namespace


MeshTriangle Class

[image]

Revit 2010 API
MeshTriangle Class
Members See Also Send Feedback
One triangle of a mesh.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MeshTriangle : APIObject
Visual Basic (Declaration)
Public Class MeshTriangle _
    Inherits APIObject
Visual C++
public ref class MeshTriangle : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.MeshTriangle

See Also

MeshTriangle Members
Autodesk.Revit.Geometry Namespace


MeshTriangle Members

[image] [image]

Revit 2010 API
MeshTriangle Members
MeshTriangle Class Constructors Methods Properties See Also Send Feedback

The MeshTriangle type exposes the following members.

Constructors

Name | Description
MeshTriangle | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Index | The index of the vertex in the Vertices array of the mesh, for indexed access.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Vertex | A vertex of the triangle.

See Also

MeshTriangle Class
Autodesk.Revit.Geometry Namespace


MeshTriangle Constructor

[image]

Revit 2010 API
MeshTriangle Constructor
MeshTriangle Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MeshTriangle()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MeshTriangle()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MeshTriangle Class
Autodesk.Revit.Geometry Namespace


MeshTriangle Methods

[image] [image]

Revit 2010 API
MeshTriangle Methods
MeshTriangle Class See Also Send Feedback

The MeshTriangle type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MeshTriangle Class
Autodesk.Revit.Geometry Namespace


MeshTriangle Properties

[image] [image]

Revit 2010 API
MeshTriangle Properties
MeshTriangle Class See Also Send Feedback

The MeshTriangle type exposes the following members.

Properties

Name | Description
Index | The index of the vertex in the Vertices array of the mesh, for indexed access.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Vertex | A vertex of the triangle.

See Also

MeshTriangle Class
Autodesk.Revit.Geometry Namespace


Index Property

[image]

Revit 2010 API
MeshTriangle..::.Index Property
MeshTriangle Class See Also Send Feedback
The index of the vertex in the Vertices array of the mesh, for indexed access.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public uint Index[
    int idx
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index ( _
    idx As Integer _
) As UInteger
Visual C++
public:
property unsigned int Index[int idx] {
    unsigned int get (int idx);
}

Parameters

idx
Type: System..::.Int32
Index of the vertex in the triangle: 0, 1 or 2.

See Also

MeshTriangle Class
Autodesk.Revit.Geometry Namespace


Vertex Property

[image]

Revit 2010 API
MeshTriangle..::.Vertex Property
MeshTriangle Class See Also Send Feedback
A vertex of the triangle.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Vertex[
    int idx
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Vertex ( _
    idx As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Vertex[int idx] {
    XYZ^ get (int idx);
}

Parameters

idx
Type: System..::.Int32
Index of the vertex in the triangle: 0, 1 or 2.

See Also

MeshTriangle Class
Autodesk.Revit.Geometry Namespace


NurbSpline Class

[image]

Revit 2010 API
NurbSpline Class
Members See Also Send Feedback
A nurb spline.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class NurbSpline : Curve
Visual Basic (Declaration)
Public Class NurbSpline _
    Inherits Curve
Visual C++
public ref class NurbSpline : public Curve

Remarks

The nurb spline lies in the plane defined by control point, weight,knots,degree.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Curve
Autodesk.Revit.Geometry..::.NurbSpline

See Also

NurbSpline Members
Autodesk.Revit.Geometry Namespace


NurbSpline Members

[image] [image]

Revit 2010 API
NurbSpline Members
NurbSpline Class Constructors Methods Properties See Also Send Feedback

The NurbSpline type exposes the following members.

Constructors

Name | Description
NurbSpline | For Internal Use Only.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
SetControlPointsAndWeights | Set the control points, weights simultaneously.
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
CtrlPoints | Returns the control points of the nurb spline.
Degree | Returns the degree of the nurb spline.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
isClosed | Return/set the nurb spline's isClosed property.
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
isRational | Returns whether the nurb spline is rational or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Knots | Return/set the knots of the nurb spline.
Length | The exact length of the curve. (Inherited from Curve.)
Period | The period of this curve. (Inherited from Curve.)
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Visibility | The visibility. (Inherited from GeometryObject.)
Weights | Returns the weights of the nurb spline.

See Also

NurbSpline Class
Autodesk.Revit.Geometry Namespace


NurbSpline Constructor

[image]

Revit 2010 API
NurbSpline Constructor
NurbSpline Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public NurbSpline()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NurbSpline()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

NurbSpline Class
Autodesk.Revit.Geometry Namespace


NurbSpline Methods

[image] [image]

Revit 2010 API
NurbSpline Methods
NurbSpline Class See Also Send Feedback

The NurbSpline type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
SetControlPointsAndWeights | Set the control points, weights simultaneously.
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NurbSpline Class
Autodesk.Revit.Geometry Namespace


Intersect Method

[image] [image]

Revit 2010 API
NurbSpline..::.Intersect Method
NurbSpline Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

NurbSpline Class
NurbSpline Members
Autodesk.Revit.Geometry Namespace


IsInside Method

[image] [image]

Revit 2010 API
NurbSpline..::.IsInside Method
NurbSpline Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

Name | Description
IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)

See Also

NurbSpline Class
NurbSpline Members
Autodesk.Revit.Geometry Namespace


SetControlPointsAndWeights Method

[image]

Revit 2010 API
NurbSpline..::.SetControlPointsAndWeights Method
NurbSpline Class See Also Send Feedback
Set the control points, weights simultaneously.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetControlPointsAndWeights(
    XYZArray ctrlPoints,
    DoubleArray weights
)
Visual Basic (Declaration)
Public Sub SetControlPointsAndWeights ( _
    ctrlPoints As XYZArray, _
    weights As DoubleArray _
)
Visual C++
public:
void SetControlPointsAndWeights(
    XYZArray^ ctrlPoints,
    DoubleArray^ weights
)

Parameters

ctrlPoints
Type: Autodesk.Revit.Geometry..::.XYZArray
weights
Type: Autodesk.Revit.Geometry..::.DoubleArray

See Also

NurbSpline Class
Autodesk.Revit.Geometry Namespace


NurbSpline Properties

[image] [image]

Revit 2010 API
NurbSpline Properties
NurbSpline Class See Also Send Feedback

The NurbSpline type exposes the following members.

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
CtrlPoints | Returns the control points of the nurb spline.
Degree | Returns the degree of the nurb spline.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
isClosed | Return/set the nurb spline's isClosed property.
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
isRational | Returns whether the nurb spline is rational or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Knots | Return/set the knots of the nurb spline.
Length | The exact length of the curve. (Inherited from Curve.)
Period | The period of this curve. (Inherited from Curve.)
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Visibility | The visibility. (Inherited from GeometryObject.)
Weights | Returns the weights of the nurb spline.

See Also

NurbSpline Class
Autodesk.Revit.Geometry Namespace


CtrlPoints Property

[image]

Revit 2010 API
NurbSpline..::.CtrlPoints Property
NurbSpline Class See Also Send Feedback
Returns the control points of the nurb spline.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZArray CtrlPoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property CtrlPoints As XYZArray
Visual C++
public:
property XYZArray^ CtrlPoints {
    XYZArray^ get ();
}

See Also

NurbSpline Class
Autodesk.Revit.Geometry Namespace


Degree Property

[image]

Revit 2010 API
NurbSpline..::.Degree Property
NurbSpline Class See Also Send Feedback
Returns the degree of the nurb spline.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Degree { get; }
Visual Basic (Declaration)
Public ReadOnly Property Degree As Integer
Visual C++
public:
property int Degree {
    int get ();
}

See Also

NurbSpline Class
Autodesk.Revit.Geometry Namespace


isClosed Property

[image]

Revit 2010 API
NurbSpline..::.isClosed Property
NurbSpline Class See Also Send Feedback
Return/set the nurb spline's isClosed property.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool isClosed { get; set; }
Visual Basic (Declaration)
Public Property isClosed As Boolean
Visual C++
public:
property bool isClosed {
    bool get ();
    void set (bool value);
}

See Also

NurbSpline Class
Autodesk.Revit.Geometry Namespace


isRational Property

[image]

Revit 2010 API
NurbSpline..::.isRational Property
NurbSpline Class See Also Send Feedback
Returns whether the nurb spline is rational or not.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool isRational { get; }
Visual Basic (Declaration)
Public ReadOnly Property isRational As Boolean
Visual C++
public:
property bool isRational {
    bool get ();
}

See Also

NurbSpline Class
Autodesk.Revit.Geometry Namespace


Knots Property

[image]

Revit 2010 API
NurbSpline..::.Knots Property
NurbSpline Class See Also Send Feedback
Return/set the knots of the nurb spline.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DoubleArray Knots { get; set; }
Visual Basic (Declaration)
Public Property Knots As DoubleArray
Visual C++
public:
property DoubleArray^ Knots {
    DoubleArray^ get ();
    void set (DoubleArray^ value);
}

See Also

NurbSpline Class
Autodesk.Revit.Geometry Namespace


Weights Property

[image]

Revit 2010 API
NurbSpline..::.Weights Property
NurbSpline Class See Also Send Feedback
Returns the weights of the nurb spline.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DoubleArray Weights { get; }
Visual Basic (Declaration)
Public ReadOnly Property Weights As DoubleArray
Visual C++
public:
property DoubleArray^ Weights {
    DoubleArray^ get ();
}

See Also

NurbSpline Class
Autodesk.Revit.Geometry Namespace


Options Class

[image]

Revit 2010 API
Options Class
Members See Also Send Feedback
User preferences for parsing of geometry.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Options : APIObject
Visual Basic (Declaration)
Public Class Options _
    Inherits APIObject
Visual C++
public ref class Options : public APIObject

Remarks

This class determines the output of the Element.Geometry property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.Options

See Also

Options Members
Autodesk.Revit.Geometry Namespace


Options Members

[image] [image]

Revit 2010 API
Options Members
Options Class Constructors Methods Properties See Also Send Feedback

The Options type exposes the following members.

Constructors

Name | Description
Options | Overloaded.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ComputeReferences | Determines whether or not references to geometric objects are computed.
DetailLevel | The detail level for the geometry extracted with these options.
IncludeNonVisibleObjects | Whether to extract element geometry objects not set as Visible. The default is false.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
View | The view used for geometry extraction.

See Also

Options Class
Autodesk.Revit.Geometry Namespace


Options Constructor

[image] [image]

Revit 2010 API
Options Constructor
Options Class See Also Send Feedback

Overload List

Name | Description
Options()()() | Creates a default Options object.
Options(Options) | Copy constructor.

See Also

Options Class
Options Members
Autodesk.Revit.Geometry Namespace


Options Constructor

[image]

Revit 2010 API
Options Constructor
Options Class See Also Send Feedback
Creates a default Options object.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Options()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Options()

Remarks

Defaults to medium detail, no references and no view.

See Also

Options Class
Options Overload
Autodesk.Revit.Geometry Namespace


Options Constructor (Options)

[image]

Revit 2010 API
Options Constructor (Options)
Options Class See Also Send Feedback
Copy constructor.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Options(
    Options pOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    pOptions As Options _
)
Visual C++
public:
Options(
    Options^ pOptions
)

Parameters

pOptions
Type: Autodesk.Revit.Geometry..::.Options

See Also

Options Class
Options Overload
Autodesk.Revit.Geometry Namespace


Options Methods

[image] [image]

Revit 2010 API
Options Methods
Options Class See Also Send Feedback

The Options type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Options Class
Autodesk.Revit.Geometry Namespace


Options Properties

[image] [image]

Revit 2010 API
Options Properties
Options Class See Also Send Feedback

The Options type exposes the following members.

Properties

Name | Description
ComputeReferences | Determines whether or not references to geometric objects are computed.
DetailLevel | The detail level for the geometry extracted with these options.
IncludeNonVisibleObjects | Whether to extract element geometry objects not set as Visible. The default is false.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
View | The view used for geometry extraction.

See Also

Options Class
Autodesk.Revit.Geometry Namespace


ComputeReferences Property

[image]

Revit 2010 API
Options..::.ComputeReferences Property
Options Class See Also Send Feedback
Determines whether or not references to geometric objects are computed.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool ComputeReferences { get; set; }
Visual Basic (Declaration)
Public Property ComputeReferences As Boolean
Visual C++
public:
property bool ComputeReferences {
    bool get ();
    void set (bool value);
}

See Also

Options Class
Autodesk.Revit.Geometry Namespace


DetailLevel Property

[image]

Revit 2010 API
Options..::.DetailLevel Property
Options Class See Also Send Feedback
The detail level for the geometry extracted with these options.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Options..::.DetailLevels DetailLevel { get; set; }
Visual Basic (Declaration)
Public Property DetailLevel As Options..::.DetailLevels
Visual C++
public:
property Options..::.DetailLevels DetailLevel {
    Options..::.DetailLevels get ();
    void set (Options..::.DetailLevels value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when setting this property, if View is already set. When View is set the detail level of the view is used.

See Also

Options Class
Autodesk.Revit.Geometry Namespace


IncludeNonVisibleObjects Property

[image]

Revit 2010 API
Options..::.IncludeNonVisibleObjects Property
Options Class See Also Send Feedback
Whether to extract element geometry objects not set as Visible. The default is false.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IncludeNonVisibleObjects { get; set; }
Visual Basic (Declaration)
Public Property IncludeNonVisibleObjects As Boolean
Visual C++
public:
property bool IncludeNonVisibleObjects {
    bool get ();
    void set (bool value);
}

See Also

Options Class
Autodesk.Revit.Geometry Namespace


View Property

[image]

Revit 2010 API
Options..::.View Property
Options Class See Also Send Feedback
The view used for geometry extraction.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public View View { get; set; }
Visual Basic (Declaration)
Public Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
    void set (View^ value);
}

Remarks

If a view-specific version of an element exists, it will be extracted in the retrieval of geometry. Also, the detail level of the geometry will be taken from the view's detail level.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when setting this property, if DetailLevel is already set. When DetailLevel is set view-specific geometry can't be extracted.

See Also

Options Class
Autodesk.Revit.Geometry Namespace


Options.DetailLevels Enumeration

[image]

Revit 2010 API
Options..::.DetailLevels Enumeration
Options Class See Also Send Feedback
Chooses the detail level of an element's representation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum DetailLevels
Visual Basic (Declaration)
Public Enumeration DetailLevels
Visual C++
public enum class DetailLevels

Members

Member name | Description
MAX | The value is used to check whether the enum is the same size as the internal one.
Fine | Corresponds to the fine view detail setting.
Medium | Corresponds to the medium view detail setting.
Coarse | Corresponds to the coarse view detail setting.
Undefined | May produce all or none of the available representations.

Remarks

This corresponds to detail levels in Revit's views and families.

See Also

Autodesk.Revit.Geometry Namespace


PlanarFace Class

[image]

Revit 2010 API
PlanarFace Class
Members Example See Also Send Feedback
A planar face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PlanarFace : Face
Visual Basic (Declaration)
Public Class PlanarFace _
    Inherits Face
Visual C++
public ref class PlanarFace : public Face

Remarks

Planar faces are defined by planes bounded by edge loops. The planes provide natural UV parametrization to the faces. S(u, v) = Origin + u*Vector[0] + v*Vector[1]

Examples

CopyC#
private void GetPlanarFaceInfo(Face face)
{
    PlanarFace planarFace = face as PlanarFace;
    if (null != planarFace)
    {
        XYZ origin = planarFace.Origin;
        XYZ normal = planarFace.Normal;
        XYZ vector = planarFace.get_Vector(0);
    }
}
CopyVB.NET
Private Sub GetPlanarFaceInfo(ByVal face As Autodesk.Revit.Geometry.Face)
    Dim planarFace As PlanarFace = TryCast(face, PlanarFace)
    If planarFace IsNot Nothing Then
        Dim origin As Autodesk.Revit.Geometry.XYZ = planarFace.Origin
        Dim normal As Autodesk.Revit.Geometry.XYZ = planarFace.Normal
        Dim vector As Autodesk.Revit.Geometry.XYZ = planarFace.Vector(0)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Face
Autodesk.Revit.Geometry..::.PlanarFace

See Also

PlanarFace Members
Autodesk.Revit.Geometry Namespace


PlanarFace Members

[image] [image]

Revit 2010 API
PlanarFace Members
PlanarFace Class Constructors Methods Properties See Also Send Feedback

The PlanarFace type exposes the following members.

Constructors

Name | Description
PlanarFace | For Internal Use Only.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Normal | Normal of the surface.
Origin | Origin of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Reference | Returns a stable reference to the face. (Inherited from Face.)
Vector | Defining vectors of the surface.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

PlanarFace Class
Autodesk.Revit.Geometry Namespace


PlanarFace Constructor

[image]

Revit 2010 API
PlanarFace Constructor
PlanarFace Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PlanarFace()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PlanarFace()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PlanarFace Class
Autodesk.Revit.Geometry Namespace


PlanarFace Methods

[image] [image]

Revit 2010 API
PlanarFace Methods
PlanarFace Class See Also Send Feedback

The PlanarFace type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

PlanarFace Class
Autodesk.Revit.Geometry Namespace


Intersect Method

[image] [image]

Revit 2010 API
PlanarFace..::.Intersect Method
PlanarFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

PlanarFace Class
PlanarFace Members
Autodesk.Revit.Geometry Namespace


IsInside Method

[image] [image]

Revit 2010 API
PlanarFace..::.IsInside Method
PlanarFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

Name | Description
IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)

See Also

PlanarFace Class
PlanarFace Members
Autodesk.Revit.Geometry Namespace


PlanarFace Properties

[image] [image]

Revit 2010 API
PlanarFace Properties
PlanarFace Class See Also Send Feedback

The PlanarFace type exposes the following members.

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Normal | Normal of the surface.
Origin | Origin of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Reference | Returns a stable reference to the face. (Inherited from Face.)
Vector | Defining vectors of the surface.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

PlanarFace Class
Autodesk.Revit.Geometry Namespace


Normal Property

[image]

Revit 2010 API
PlanarFace..::.Normal Property
PlanarFace Class See Also Send Feedback
Normal of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Normal { get; }
Visual Basic (Declaration)
Public ReadOnly Property Normal As XYZ
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

PlanarFace Class
Autodesk.Revit.Geometry Namespace


Origin Property

[image]

Revit 2010 API
PlanarFace..::.Origin Property
PlanarFace Class See Also Send Feedback
Origin of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

PlanarFace Class
Autodesk.Revit.Geometry Namespace


Vector Property

[image]

Revit 2010 API
PlanarFace..::.Vector Property
PlanarFace Class See Also Send Feedback
Defining vectors of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Vector[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Vector ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Vector[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

PlanarFace Class
Autodesk.Revit.Geometry Namespace


Plane Class

[image]

Revit 2010 API
Plane Class
Members Example See Also Send Feedback
Provides access to the geometry plane object.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Plane : APIObject
Visual Basic (Declaration)
Public Class Plane _
    Inherits APIObject
Visual C++
public ref class Plane : public APIObject

Remarks

The user can construct a plane object, get or set the vectors and origin through this class.

Examples

CopyC#
public void GetPlaneInfo(Plane plane)
{
    XYZ origin = plane.Origin;
    XYZ normal = plane.Normal;
    XYZ xVec = plane.XVec;
    XYZ yVec = plane.YVec;

    StringBuilder info = new StringBuilder();
    info.AppendLine("Plane Data:");
    info.AppendLine(string.Format("     Origin: ({0},{1},{2})", origin.X, origin.Y, origin.Z));
    info.AppendLine(string.Format("     Normal: ({0},{1},{2})", normal.X, normal.Y, normal.Z));
    info.AppendLine(string.Format("     XVec: ({0},{1},{2})", xVec.X, xVec.Y, xVec.Z));
    info.AppendLine(string.Format("     YVec: ({0},{1},{2})", yVec.X, yVec.Y, yVec.Z));

    MessageBox.Show(info.ToString(), "Revit");
}
CopyVB.NET
Public Sub GetPlaneInfo(ByVal plane As Autodesk.Revit.Geometry.Plane)
    Dim origin As Autodesk.Revit.Geometry.XYZ = plane.Origin
    Dim normal As Autodesk.Revit.Geometry.XYZ = plane.Normal
    Dim xVec As Autodesk.Revit.Geometry.XYZ = plane.XVec
    Dim yVec As Autodesk.Revit.Geometry.XYZ = plane.YVec

    Dim info As New StringBuilder()
    info.AppendLine("Plane Data:")
    info.AppendLine(String.Format(" Origin: ({0},{1},{2})", origin.X, origin.Y, origin.Z))
    info.AppendLine(String.Format(" Normal: ({0},{1},{2})", normal.X, normal.Y, normal.Z))
    info.AppendLine(String.Format(" XVec: ({0},{1},{2})", xVec.X, xVec.Y, xVec.Z))
    info.AppendLine(String.Format(" YVec: ({0},{1},{2})", yVec.X, yVec.Y, yVec.Z))

    MessageBox.Show(info.ToString(), "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.Plane

See Also

Plane Members
Autodesk.Revit.Geometry Namespace


Plane Members

[image] [image]

Revit 2010 API
Plane Members
Plane Class Constructors Methods Properties See Also Send Feedback

The Plane type exposes the following members.

Constructors

Name | Description
Plane | Overloaded.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Normal | Get the Normal of the plane.
Origin | Get the Origin of the plane.
XVec | Get the XVec of the plane.
YVec | Get the YVec of the plane.

See Also

Plane Class
Autodesk.Revit.Geometry Namespace


Plane Constructor

[image] [image]

Revit 2010 API
Plane Constructor
Plane Class See Also Send Feedback

Overload List

Name | Description
Plane()()() | For Internal Use Only.
Plane(XYZ, XYZ) | Constructor for geometry plane.
Plane(XYZ, XYZ, XYZ) | Constructor for geometry plane.

See Also

Plane Class
Plane Members
Autodesk.Revit.Geometry Namespace


Plane Constructor

[image]

Revit 2010 API
Plane Constructor
Plane Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Plane()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Plane()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Plane Class
Plane Overload
Autodesk.Revit.Geometry Namespace


Plane Constructor (XYZ, XYZ)

[image]

Revit 2010 API
Plane Constructor (XYZ, XYZ)
Plane Class See Also Send Feedback
Constructor for geometry plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Plane(
    XYZ norm,
    XYZ origin
)
Visual Basic (Declaration)
Public Sub New ( _
    norm As XYZ, _
    origin As XYZ _
)
Visual C++
public:
Plane(
    XYZ^ norm,
    XYZ^ origin
)

Parameters

norm
Type: Autodesk.Revit.Geometry..::.XYZ
The normal vector of the plane.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The coordinates for the origin.

Remarks

Used to construct a new Plane object.

See Also

Plane Class
Plane Overload
Autodesk.Revit.Geometry Namespace


Plane Constructor (XYZ, XYZ, XYZ)

[image]

Revit 2010 API
Plane Constructor (XYZ, XYZ, XYZ)
Plane Class See Also Send Feedback
Constructor for geometry plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Plane(
    XYZ xVec,
    XYZ yVec,
    XYZ origin
)
Visual Basic (Declaration)
Public Sub New ( _
    xVec As XYZ, _
    yVec As XYZ, _
    origin As XYZ _
)
Visual C++
public:
Plane(
    XYZ^ xVec,
    XYZ^ yVec,
    XYZ^ origin
)

Parameters

xVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector for x-axis.
yVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector for y-axis.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The coordinates for the origin.

Remarks

Used to construct a new Plane object.

See Also

Plane Class
Plane Overload
Autodesk.Revit.Geometry Namespace


Plane Methods

[image] [image]

Revit 2010 API
Plane Methods
Plane Class See Also Send Feedback

The Plane type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Plane Class
Autodesk.Revit.Geometry Namespace


Plane Properties

[image] [image]

Revit 2010 API
Plane Properties
Plane Class See Also Send Feedback

The Plane type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Normal | Get the Normal of the plane.
Origin | Get the Origin of the plane.
XVec | Get the XVec of the plane.
YVec | Get the YVec of the plane.

See Also

Plane Class
Autodesk.Revit.Geometry Namespace


Normal Property

[image]

Revit 2010 API
Plane..::.Normal Property
Plane Class See Also Send Feedback
Get the Normal of the plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Normal { get; }
Visual Basic (Declaration)
Public ReadOnly Property Normal As XYZ
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

Remarks

This property is used to get the Normal of the plane.

See Also

Plane Class
Autodesk.Revit.Geometry Namespace


Origin Property

[image]

Revit 2010 API
Plane..::.Origin Property
Plane Class See Also Send Feedback
Get the Origin of the plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

Remarks

This property is used to get the Origin of the plane.

See Also

Plane Class
Autodesk.Revit.Geometry Namespace


XVec Property

[image]

Revit 2010 API
Plane..::.XVec Property
Plane Class See Also Send Feedback
Get the XVec of the plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ XVec { get; }
Visual Basic (Declaration)
Public ReadOnly Property XVec As XYZ
Visual C++
public:
property XYZ^ XVec {
    XYZ^ get ();
}

Remarks

This property is used to get the XVec of the plane.

See Also

Plane Class
Autodesk.Revit.Geometry Namespace


YVec Property

[image]

Revit 2010 API
Plane..::.YVec Property
Plane Class See Also Send Feedback
Get the YVec of the plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ YVec { get; }
Visual Basic (Declaration)
Public ReadOnly Property YVec As XYZ
Visual C++
public:
property XYZ^ YVec {
    XYZ^ get ();
}

Remarks

This property is used to get the YVec of the plane.

See Also

Plane Class
Autodesk.Revit.Geometry Namespace


Point Class

[image]

Revit 2010 API
Point Class
Members See Also Send Feedback
A 3D point.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Point : GeometryObject
Visual Basic (Declaration)
Public Class Point _
    Inherits GeometryObject
Visual C++
public ref class Point : public GeometryObject

Remarks

The point lies at a given XYZ coordinate location.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Point

See Also

Point Members
Autodesk.Revit.Geometry Namespace


Point Members

[image] [image]

Revit 2010 API
Point Members
Point Class Constructors Methods Properties See Also Send Feedback

The Point type exposes the following members.

Constructors

Name | Description
Point | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Coord | Returns the coordinates of the point.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Reference | Returns a stable reference to the point.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Point Class
Autodesk.Revit.Geometry Namespace


Point Constructor

[image]

Revit 2010 API
Point Constructor
Point Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Point()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Point()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Point Class
Autodesk.Revit.Geometry Namespace


Point Methods

[image] [image]

Revit 2010 API
Point Methods
Point Class See Also Send Feedback

The Point type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Point Class
Autodesk.Revit.Geometry Namespace


Point Properties

[image] [image]

Revit 2010 API
Point Properties
Point Class See Also Send Feedback

The Point type exposes the following members.

Properties

Name | Description
Coord | Returns the coordinates of the point.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Reference | Returns a stable reference to the point.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Point Class
Autodesk.Revit.Geometry Namespace


Coord Property

[image]

Revit 2010 API
Point..::.Coord Property
Point Class See Also Send Feedback
Returns the coordinates of the point.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Coord { get; }
Visual Basic (Declaration)
Public ReadOnly Property Coord As XYZ
Visual C++
public:
property XYZ^ Coord {
    XYZ^ get ();
}

See Also

Point Class
Autodesk.Revit.Geometry Namespace


Reference Property

[image]

Revit 2010 API
Point..::.Reference Property
Point Class See Also Send Feedback
Returns a stable reference to the point.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference Reference { get; }
Visual Basic (Declaration)
Public ReadOnly Property Reference As Reference
Visual C++
public:
property Reference^ Reference {
    Reference^ get ();
}

See Also

Point Class
Autodesk.Revit.Geometry Namespace


Profile Class

[image]

Revit 2010 API
Profile Class
Members Example See Also Send Feedback
A geometric profile consisting of a loop of curves.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Profile : GeometryObject
Visual Basic (Declaration)
Public Class Profile _
    Inherits GeometryObject
Visual C++
public ref class Profile : public GeometryObject

Remarks

The profile may be filled.

Examples

CopyC#
public void GetProfile(Element element)
{
    string messageInfo = "Profile : ";
    if (element is FamilyInstance)
    {
        FamilyInstance beam = element as FamilyInstance;
        if (beam.StructuralType == Autodesk.Revit.Structural.Enums.StructuralType.Beam)
        {
            AnalyticalModelFrame modelFrame = beam.AnalyticalModel as AnalyticalModelFrame;
            Autodesk.Revit.Geometry.Curve curve = modelFrame.Curve;
            AnalyticalModelProfile modelProfile = modelFrame.Profile;
            // Get AnalyticalModelFrame swept profile
            Autodesk.Revit.Geometry.Profile profile = modelProfile.SweptProfile;
            // Get AnalyticalModelWall swept profile curves size
            messageInfo += "\nSelection name : " + beam.Name;
            messageInfo += "\nSwept Profile Driving Curve size is " + profile.Curves.Size;
            messageInfo += "\nProfile is filled :  " + profile.Filled;
            if (!profile.IsReadOnly)
            {
                profile.Filled = !profile.Filled;
                messageInfo += "\nProfile is filled after setting:  " + profile.Filled;
            }
            MessageBox.Show(messageInfo, "Revit", MessageBoxButtons.OK);
        }
    }
}
CopyVB.NET
Public Sub GetProfile(ByVal element As Autodesk.Revit.Element)
    Dim messageInfo As String = "Profile : "
    If TypeOf element Is Autodesk.Revit.Elements.FamilyInstance Then
        Dim beam As Autodesk.Revit.Elements.FamilyInstance = TryCast(element, Autodesk.Revit.Elements.FamilyInstance)
        If beam.StructuralType = Autodesk.Revit.Structural.Enums.StructuralType.Beam Then
            Dim modelFrame As AnalyticalModelFrame = TryCast(beam.AnalyticalModel, AnalyticalModelFrame)
            Dim curve As Autodesk.Revit.Geometry.Curve = modelFrame.Curve
            Dim modelProfile As AnalyticalModelProfile = modelFrame.Profile
            ' Get AnalyticalModelFrame swept profile
            Dim profile As Autodesk.Revit.Geometry.Profile = modelProfile.SweptProfile
            ' Get AnalyticalModelWall swept profile curves size
            messageInfo += vbLf & "Selection name : " & beam.Name
            messageInfo += vbLf & "Swept Profile Driving Curve size is " & profile.Curves.Size
            messageInfo += vbLf & "Profile is filled : " & profile.Filled
            If Not profile.IsReadOnly Then
                profile.Filled = Not profile.Filled
                messageInfo += vbLf & "Profile is filled after setting: " & profile.Filled
            End If
            MessageBox.Show(messageInfo, "Revit", MessageBoxButtons.OK)
        End If
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Profile

See Also

Profile Members
Autodesk.Revit.Geometry Namespace


Profile Members

[image] [image]

Revit 2010 API
Profile Members
Profile Class Constructors Methods Properties See Also Send Feedback

The Profile type exposes the following members.

Constructors

Name | Description
Profile | For Internal Use Only.

Methods

Name | Description
Clone | Returns a copy of this profile.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Curves | Retrieve the curves that make up the boundary of the profile.
Filled | Get or set whether the profile is filled.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Transformed | Transforms this profile and returns the result.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Profile Class
Autodesk.Revit.Geometry Namespace


Profile Constructor

[image]

Revit 2010 API
Profile Constructor
Profile Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Profile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Profile()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Profile Class
Autodesk.Revit.Geometry Namespace


Profile Methods

[image] [image]

Revit 2010 API
Profile Methods
Profile Class See Also Send Feedback

The Profile type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this profile.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Profile Class
Autodesk.Revit.Geometry Namespace


Clone Method

[image]

Revit 2010 API
Profile..::.Clone Method
Profile Class See Also Send Feedback
Returns a copy of this profile.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Profile Clone()
Visual Basic (Declaration)
Public Function Clone As Profile
Visual C++
public:
Profile^ Clone()

See Also

Profile Class
Autodesk.Revit.Geometry Namespace


Profile Properties

[image] [image]

Revit 2010 API
Profile Properties
Profile Class See Also Send Feedback

The Profile type exposes the following members.

Properties

Name | Description
Curves | Retrieve the curves that make up the boundary of the profile.
Filled | Get or set whether the profile is filled.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Transformed | Transforms this profile and returns the result.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Profile Class
Autodesk.Revit.Geometry Namespace


Curves Property

[image]

Revit 2010 API
Profile..::.Curves Property
Profile Class See Also Send Feedback
Retrieve the curves that make up the boundary of the profile.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray Curves { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

See Also

Profile Class
Autodesk.Revit.Geometry Namespace


Filled Property

[image]

Revit 2010 API
Profile..::.Filled Property
Profile Class See Also Send Feedback
Get or set whether the profile is filled.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Filled { get; set; }
Visual Basic (Declaration)
Public Property Filled As Boolean
Visual C++
public:
property bool Filled {
    bool get ();
    void set (bool value);
}

See Also

Profile Class
Autodesk.Revit.Geometry Namespace


Transformed Property

[image]

Revit 2010 API
Profile..::.Transformed Property
Profile Class See Also Send Feedback
Transforms this profile and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Profile Transformed[
    Transform transform
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Transformed ( _
    transform As Transform _
) As Profile
Visual C++
public:
property Profile^ Transformed[Transform^ transform] {
    Profile^ get (Transform^ transform);
}

Parameters

transform
Type: Autodesk.Revit.Geometry..::.Transform
The transformation used to transform the profile.

Return Value

The transformed profile.

Remarks

Transforms all the curves that define the boundary of this profile.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the handle of the specified transformation is null.
System..::.InvalidOperationException | Thrown when failed to transform a curve in the profile.

See Also

Profile Class
Autodesk.Revit.Geometry Namespace


Reference Class

[image]

Revit 2010 API
Reference Class
Members See Also Send Feedback
A stable reference to a geometric object in a Revit model.
An array that contains reference objects.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Reference : APIObject
Visual Basic (Declaration)
Public Class Reference _
    Inherits APIObject
Visual C++
public ref class Reference : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.Reference

See Also

Reference Members
Autodesk.Revit.Geometry Namespace


Reference Members

[image] [image]

Revit 2010 API
Reference Members
Reference Class Constructors Methods Properties See Also Send Feedback

The Reference type exposes the following members.

Constructors

Name | Description
Reference | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Element | The element for this reference.
ElementReferenceType | The type of reference referred to.
GeometryObject | The geometry item referred to by this reference.
GlobalPoint | The position on which the reference is hit.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
ProximityParameter | The proximity value to the ray's origin when the reference is returned by Autodesk::Revit::Document::FindReferencesByDirection.
Transform | The transformation of the geometry item into the coordinates of the document.
UVPoint | The UV parameters of the reference, if the reference contains a face.

See Also

Reference Class
Autodesk.Revit.Geometry Namespace


Reference Constructor

[image]

Revit 2010 API
Reference Constructor
Reference Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Reference()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Reference Class
Autodesk.Revit.Geometry Namespace


Reference Methods

[image] [image]

Revit 2010 API
Reference Methods
Reference Class See Also Send Feedback

The Reference type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reference Class
Autodesk.Revit.Geometry Namespace


Reference Properties

[image] [image]

Revit 2010 API
Reference Properties
Reference Class See Also Send Feedback

The Reference type exposes the following members.

Properties

Name | Description
Element | The element for this reference.
ElementReferenceType | The type of reference referred to.
GeometryObject | The geometry item referred to by this reference.
GlobalPoint | The position on which the reference is hit.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
ProximityParameter | The proximity value to the ray's origin when the reference is returned by Autodesk::Revit::Document::FindReferencesByDirection.
Transform | The transformation of the geometry item into the coordinates of the document.
UVPoint | The UV parameters of the reference, if the reference contains a face.

See Also

Reference Class
Autodesk.Revit.Geometry Namespace


Element Property

[image]

Revit 2010 API
Reference..::.Element Property
Reference Class See Also Send Feedback
The element for this reference.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element Element { get; }
Visual Basic (Declaration)
Public ReadOnly Property Element As Element
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

Remarks

Null will be returned for references that don't refer to a particular element.

See Also

Reference Class
Autodesk.Revit.Geometry Namespace


ElementReferenceType Property

[image]

Revit 2010 API
Reference..::.ElementReferenceType Property
Reference Class See Also Send Feedback
The type of reference referred to.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementReferenceType ElementReferenceType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElementReferenceType As ElementReferenceType
Visual C++
public:
property ElementReferenceType ElementReferenceType {
    ElementReferenceType get ();
}

See Also

Reference Class
Autodesk.Revit.Geometry Namespace


GeometryObject Property

[image]

Revit 2010 API
Reference..::.GeometryObject Property
Reference Class See Also Send Feedback
The geometry item referred to by this reference.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GeometryObject GeometryObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property GeometryObject As GeometryObject
Visual C++
public:
property GeometryObject^ GeometryObject {
    GeometryObject^ get ();
}

See Also

Reference Class
Autodesk.Revit.Geometry Namespace


GlobalPoint Property

[image]

Revit 2010 API
Reference..::.GlobalPoint Property
Reference Class See Also Send Feedback
The position on which the reference is hit.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ GlobalPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property GlobalPoint As XYZ
Visual C++
public:
property XYZ^ GlobalPoint {
    XYZ^ get ();
}

Remarks

Null is returned if the reference doesn't have global point.

See Also

Reference Class
Autodesk.Revit.Geometry Namespace


ProximityParameter Property

[image]

Revit 2010 API
Reference..::.ProximityParameter Property
Reference Class See Also Send Feedback
The proximity value to the ray's origin when the reference is returned by Autodesk::Revit::Document::FindReferencesByDirection.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ProximityParameter { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProximityParameter As Double
Visual C++
public:
property double ProximityParameter {
    double get ();
}

Remarks

This value is valid only for References returned from Autodesk::Revit::Document::FindReferencesByDirection. Returns the parameter for the reference relative to the ray input. The value increases the further away the reference is from the origin point for the ray.

See Also

Reference Class
Autodesk.Revit.Geometry Namespace


Transform Property

[image]

Revit 2010 API
Reference..::.Transform Property
Reference Class See Also Send Feedback
The transformation of the geometry item into the coordinates of the document.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Transform Transform { get; }
Visual Basic (Declaration)
Public ReadOnly Property Transform As Transform
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
}

Remarks

If the reference doesn’t contain any instances this will be the default transform.

See Also

Reference Class
Autodesk.Revit.Geometry Namespace


UVPoint Property

[image]

Revit 2010 API
Reference..::.UVPoint Property
Reference Class See Also Send Feedback
The UV parameters of the reference, if the reference contains a face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV UVPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property UVPoint As UV
Visual C++
public:
property UV^ UVPoint {
    UV^ get ();
}

Remarks

This value is valid only for references of type REFERENCE_TYPE_SURFACE. It is null for all other types.

See Also

Reference Class
Autodesk.Revit.Geometry Namespace


ReferenceArray Class

[image]

Revit 2010 API
ReferenceArray Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ReferenceArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ReferenceArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ReferenceArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.ReferenceArray

See Also

ReferenceArray Members
Autodesk.Revit.Geometry Namespace


ReferenceArray Members

[image] [image]

Revit 2010 API
ReferenceArray Members
ReferenceArray Class Constructors Methods Properties See Also Send Feedback

The ReferenceArray type exposes the following members.

Constructors

Name | Description
ReferenceArray | Initializes a new instance of the ReferenceArray class

Methods

Name | Description
Append | Add the reference to the end of the array.
Clear | Removes every reference from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified reference into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a reference at a specified index within the array.
Size | Returns the number of references that are in the array.

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


ReferenceArray Constructor

[image]

Revit 2010 API
ReferenceArray Constructor
ReferenceArray Class See Also Send Feedback
Initializes a new instance of the ReferenceArray class

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferenceArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReferenceArray()

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


ReferenceArray Methods

[image] [image]

Revit 2010 API
ReferenceArray Methods
ReferenceArray Class See Also Send Feedback

The ReferenceArray type exposes the following members.

Methods

Name | Description
Append | Add the reference to the end of the array.
Clear | Removes every reference from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified reference into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


Append Method

[image]

Revit 2010 API
ReferenceArray..::.Append Method
ReferenceArray Class See Also Send Feedback
Add the reference to the end of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    Reference item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Reference _
)
Visual C++
public:
virtual void Append(
    Reference^ item
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.Reference
The reference to be added.

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

[image]

Revit 2010 API
ReferenceArray..::.Clear Method
ReferenceArray Class See Also Send Feedback
Removes every reference from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

[image]

Revit 2010 API
ReferenceArray..::.ForwardIterator Method
ReferenceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ReferenceArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ReferenceArrayIterator
Visual C++
public:
virtual ReferenceArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

[image]

Revit 2010 API
ReferenceArray..::.GetEnumerator Method
ReferenceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

[image]

Revit 2010 API
ReferenceArray..::.Insert Method
ReferenceArray Class See Also Send Feedback
Insert the specified reference into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    Reference item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Reference, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Reference^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.Reference
The reference to be inserted into the array.
index
Type: System..::.Int32
The reference will be inserted before this index.

Return Value

Returns whether the reference was inserted into the array.

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

[image]

Revit 2010 API
ReferenceArray..::.ReverseIterator Method
ReferenceArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ReferenceArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ReferenceArrayIterator
Visual C++
public:
virtual ReferenceArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


ReferenceArray Properties

[image] [image]

Revit 2010 API
ReferenceArray Properties
ReferenceArray Class See Also Send Feedback

The ReferenceArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a reference at a specified index within the array.
Size | Returns the number of references that are in the array.

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


IsEmpty Property

[image]

Revit 2010 API
ReferenceArray..::.IsEmpty Property
ReferenceArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


Item Property

[image]

Revit 2010 API
ReferenceArray..::.Item Property
ReferenceArray Class See Also Send Feedback
Gets or sets a reference at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Reference Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Reference
Visual C++
public:
virtual property Reference^ Item[int index] {
    Reference^ get (int index);
    void set (int index, Reference^ value);
}

Parameters

index
Type: System..::.Int32
The index of the reference to be set or retrieved.

Return Value

Returns the reference at the specified index.

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


Size Property

[image]

Revit 2010 API
ReferenceArray..::.Size Property
ReferenceArray Class See Also Send Feedback
Returns the number of references that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace


ReferenceArrayArray Class

[image]

Revit 2010 API
ReferenceArrayArray Class
Members See Also Send Feedback
An array that contains ReferenceArray objects.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ReferenceArrayArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ReferenceArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ReferenceArrayArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.ReferenceArrayArray

See Also

ReferenceArrayArray Members
Autodesk.Revit.Geometry Namespace


ReferenceArrayArray Members

[image] [image]

Revit 2010 API
ReferenceArrayArray Members
ReferenceArrayArray Class Constructors Methods Properties See Also Send Feedback

The ReferenceArrayArray type exposes the following members.

Constructors

Name | Description
ReferenceArrayArray | Initializes a new instance of the ReferenceArrayArray class

Methods

Name | Description
Append |
Clear | Removes every ReferenceArray from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a ReferenceArray at a specified index within the array.
Size | Returns the number of ReferenceArrays that are in the array.

See Also

ReferenceArrayArray Class
Autodesk.Revit.Geometry Namespace


ReferenceArrayArray Constructor

[image]

Revit 2010 API
ReferenceArrayArray Constructor
ReferenceArrayArray Class See Also Send Feedback
Initializes a new instance of the ReferenceArrayArray class

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferenceArrayArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReferenceArrayArray()

See Also

ReferenceArrayArray Class
Autodesk.Revit.Geometry Namespace


ReferenceArrayArray Methods

[image] [image]

Revit 2010 API
ReferenceArrayArray Methods
ReferenceArrayArray Class See Also Send Feedback

The ReferenceArrayArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every ReferenceArray from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferenceArrayArray Class
Autodesk.Revit.Geometry Namespace


Append Method

[image]

Revit 2010 API
ReferenceArrayArray..::.Append Method
ReferenceArrayArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    ReferenceArray item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As ReferenceArray _
)
Visual C++
public:
virtual void Append(
    ReferenceArray^ item
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.ReferenceArray

See Also

ReferenceArrayArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

[image]

Revit 2010 API
ReferenceArrayArray..::.Clear Method
ReferenceArrayArray Class See Also Send Feedback
Removes every ReferenceArray from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ReferenceArrayArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

[image]

Revit 2010 API
ReferenceArrayArray..::.ForwardIterator Method
ReferenceArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ReferenceArrayArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ReferenceArrayArrayIterator
Visual C++
public:
virtual ReferenceArrayArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ReferenceArrayArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

[image]

Revit 2010 API
ReferenceArrayArray..::.GetEnumerator Method
ReferenceArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ReferenceArrayArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

[image]

Revit 2010 API
ReferenceArrayArray..::.Insert Method
ReferenceArrayArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    ReferenceArray item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As ReferenceArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    ReferenceArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.ReferenceArray
index
Type: System..::.Int32

See Also

ReferenceArrayArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

[image]

Revit 2010 API
ReferenceArrayArray..::.ReverseIterator Method
ReferenceArrayArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ReferenceArrayArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ReferenceArrayArrayIterator
Visual C++
public:
virtual ReferenceArrayArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ReferenceArrayArray Class
Autodesk.Revit.Geometry Namespace


ReferenceArrayArray Properties

[image] [image]

Revit 2010 API
ReferenceArrayArray Properties
ReferenceArrayArray Class See Also Send Feedback

The ReferenceArrayArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a ReferenceArray at a specified index within the array.
Size | Returns the number of ReferenceArrays that are in the array.

See Also

ReferenceArrayArray Class
Autodesk.Revit.Geometry Namespace


IsEmpty Property

[image]

Revit 2010 API
ReferenceArrayArray..::.IsEmpty Property
ReferenceArrayArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ReferenceArrayArray Class
Autodesk.Revit.Geometry Namespace


Item Property

[image]

Revit 2010 API
ReferenceArrayArray..::.Item Property
ReferenceArrayArray Class See Also Send Feedback
Gets or sets a ReferenceArray at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ReferenceArray Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As ReferenceArray
Visual C++
public:
virtual property ReferenceArray^ Item[int index] {
    ReferenceArray^ get (int index);
    void set (int index, ReferenceArray^ value);
}

Parameters

index
Type: System..::.Int32
The index of the ReferenceArray to be set or retrieved.

Return Value

Returns the ReferenceArray at the specified index.

See Also

ReferenceArrayArray Class
Autodesk.Revit.Geometry Namespace


Size Property

[image]

Revit 2010 API
ReferenceArrayArray..::.Size Property
ReferenceArrayArray Class See Also Send Feedback
Returns the number of ReferenceArrays that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ReferenceArrayArray Class
Autodesk.Revit.Geometry Namespace


ReferenceArrayArrayIterator Class

[image]

Revit 2010 API
ReferenceArrayArrayIterator Class
Members See Also Send Feedback
An iterator to a ReferenceArray array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ReferenceArrayArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ReferenceArrayArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ReferenceArrayArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.ReferenceArrayArrayIterator

See Also

ReferenceArrayArrayIterator Members
Autodesk.Revit.Geometry Namespace


ReferenceArrayArrayIterator Members

[image] [image]

Revit 2010 API
ReferenceArrayArrayIterator Members
ReferenceArrayArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ReferenceArrayArrayIterator type exposes the following members.

Constructors

Name | Description
ReferenceArrayArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferenceArrayArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReferenceArrayArrayIterator Constructor

[image]

Revit 2010 API
ReferenceArrayArrayIterator Constructor
ReferenceArrayArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferenceArrayArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReferenceArrayArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ReferenceArrayArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReferenceArrayArrayIterator Methods

[image] [image]

Revit 2010 API
ReferenceArrayArrayIterator Methods
ReferenceArrayArrayIterator Class See Also Send Feedback

The ReferenceArrayArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferenceArrayArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

[image]

Revit 2010 API
ReferenceArrayArrayIterator..::.MoveNext Method
ReferenceArrayArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ReferenceArrayArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

[image]

Revit 2010 API
ReferenceArrayArrayIterator..::.Reset Method
ReferenceArrayArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ReferenceArrayArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReferenceArrayArrayIterator Properties

[image] [image]

Revit 2010 API
ReferenceArrayArrayIterator Properties
ReferenceArrayArrayIterator Class See Also Send Feedback

The ReferenceArrayArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferenceArrayArrayIterator Class
Autodesk.Revit.Geometry Namespace


Current Property

[image]

Revit 2010 API
ReferenceArrayArrayIterator..::.Current Property
ReferenceArrayArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ReferenceArrayArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReferenceArrayIterator Class

[image]

Revit 2010 API
ReferenceArrayIterator Class
Members See Also Send Feedback
An iterator to a reference array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ReferenceArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ReferenceArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ReferenceArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.ReferenceArrayIterator

See Also

ReferenceArrayIterator Members
Autodesk.Revit.Geometry Namespace


ReferenceArrayIterator Members

[image] [image]

Revit 2010 API
ReferenceArrayIterator Members
ReferenceArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ReferenceArrayIterator type exposes the following members.

Constructors

Name | Description
ReferenceArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferenceArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReferenceArrayIterator Constructor

[image]

Revit 2010 API
ReferenceArrayIterator Constructor
ReferenceArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferenceArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReferenceArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ReferenceArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReferenceArrayIterator Methods

[image] [image]

Revit 2010 API
ReferenceArrayIterator Methods
ReferenceArrayIterator Class See Also Send Feedback

The ReferenceArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferenceArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

[image]

Revit 2010 API
ReferenceArrayIterator..::.MoveNext Method
ReferenceArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ReferenceArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

[image]

Revit 2010 API
ReferenceArrayIterator..::.Reset Method
ReferenceArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ReferenceArrayIterator Class
Autodesk.Revit.Geometry Namespace


ReferenceArrayIterator Properties

[image] [image]

Revit 2010 API
ReferenceArrayIterator Properties
ReferenceArrayIterator Class See Also Send Feedback

The ReferenceArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferenceArrayIterator Class
Autodesk.Revit.Geometry Namespace


Current Property

[image]

Revit 2010 API
ReferenceArrayIterator..::.Current Property
ReferenceArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ReferenceArrayIterator Class
Autodesk.Revit.Geometry Namespace


RevolvedFace Class

[image]

Revit 2010 API
RevolvedFace Class
Members Example See Also Send Feedback
A revolved face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RevolvedFace : Face
Visual Basic (Declaration)
Public Class RevolvedFace _
    Inherits Face
Visual C++
public ref class RevolvedFace : public Face

Remarks

Revoved faces are defined by revolved surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces. S(u, v) = Origin + Curve0(v)*cos(u)*Radius[0] + Curve0(v)*sin(u)*Radius[1] + Curve1(v)*Axis, where the profile curve has the parametric equation (Curve0(t), Curve1(t)).

Examples

CopyC#
private void GetRevolvedFaceInfo(Face face)
{
    RevolvedFace revolvedFace = face as RevolvedFace;
    if (null != revolvedFace)
    {
        XYZ origin = revolvedFace.Origin;
        XYZ axis = revolvedFace.Axis;
        Curve curve = revolvedFace.Curve;
        XYZ redius = revolvedFace.get_Radius(0);
    }
}
CopyVB.NET
Private Sub GetRevolvedFaceInfo(ByVal face As Autodesk.Revit.Geometry.Face)
    Dim revolvedFace As RevolvedFace = TryCast(face, RevolvedFace)
    If revolvedFace IsNot Nothing Then
        Dim origin As Autodesk.Revit.Geometry.XYZ = revolvedFace.Origin
        Dim axis As Autodesk.Revit.Geometry.XYZ = revolvedFace.Axis
        Dim curve As Curve = revolvedFace.Curve
        Dim redius As Autodesk.Revit.Geometry.XYZ = revolvedFace.Radius(0)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Face
Autodesk.Revit.Geometry..::.RevolvedFace

See Also

RevolvedFace Members
Autodesk.Revit.Geometry Namespace


RevolvedFace Members

[image] [image]

Revit 2010 API
RevolvedFace Members
RevolvedFace Class Constructors Methods Properties See Also Send Feedback

The RevolvedFace type exposes the following members.

Constructors

Name | Description
RevolvedFace | For Internal Use Only.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
Axis | Axis of the surface.
Curve | Profile curve of the surface.
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Origin | Origin of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Radius | Radius of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

RevolvedFace Class
Autodesk.Revit.Geometry Namespace


RevolvedFace Constructor

[image]

Revit 2010 API
RevolvedFace Constructor
RevolvedFace Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RevolvedFace()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RevolvedFace()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RevolvedFace Class
Autodesk.Revit.Geometry Namespace


RevolvedFace Methods

[image] [image]

Revit 2010 API
RevolvedFace Methods
RevolvedFace Class See Also Send Feedback

The RevolvedFace type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

RevolvedFace Class
Autodesk.Revit.Geometry Namespace


Intersect Method

[image] [image]

Revit 2010 API
RevolvedFace..::.Intersect Method
RevolvedFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

RevolvedFace Class
RevolvedFace Members
Autodesk.Revit.Geometry Namespace


IsInside Method

[image] [image]

Revit 2010 API
RevolvedFace..::.IsInside Method
RevolvedFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

Name | Description
IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)

See Also

RevolvedFace Class
RevolvedFace Members
Autodesk.Revit.Geometry Namespace


RevolvedFace Properties

[image] [image]

Revit 2010 API
RevolvedFace Properties
RevolvedFace Class See Also Send Feedback

The RevolvedFace type exposes the following members.

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
Axis | Axis of the surface.
Curve | Profile curve of the surface.
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Origin | Origin of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Radius | Radius of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

RevolvedFace Class
Autodesk.Revit.Geometry Namespace


Axis Property

[image]

Revit 2010 API
RevolvedFace..::.Axis Property
RevolvedFace Class See Also Send Feedback
Axis of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Axis { get; }
Visual Basic (Declaration)
Public ReadOnly Property Axis As XYZ
Visual C++
public:
property XYZ^ Axis {
    XYZ^ get ();
}

See Also

RevolvedFace Class
Autodesk.Revit.Geometry Namespace


Curve Property

[image]

Revit 2010 API
RevolvedFace..::.Curve Property
RevolvedFace Class See Also Send Feedback
Profile curve of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

RevolvedFace Class
Autodesk.Revit.Geometry Namespace


Origin Property

[image]

Revit 2010 API
RevolvedFace..::.Origin Property
RevolvedFace Class See Also Send Feedback
Origin of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

RevolvedFace Class
Autodesk.Revit.Geometry Namespace


Radius Property

[image]

Revit 2010 API
RevolvedFace..::.Radius Property
RevolvedFace Class See Also Send Feedback
Radius of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Radius[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Radius ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Radius[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

RevolvedFace Class
Autodesk.Revit.Geometry Namespace


RuledFace Class

[image]

Revit 2010 API
RuledFace Class
Members Example See Also Send Feedback
A ruled face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RuledFace : Face
Visual Basic (Declaration)
Public Class RuledFace _
    Inherits Face
Visual C++
public ref class RuledFace : public Face

Remarks

Ruled faces are defined by ruled surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces.

Examples

CopyC#
private void GetRuledFaceInfo(Face face)
{
    RuledFace ruledFace = face as RuledFace;
    if (null != ruledFace)
    {
        Curve curve = ruledFace.get_Curve(0);
        XYZ point = ruledFace.get_Point(0);
    }
}
CopyVB.NET
Private Sub GetRuledFaceInfo(ByVal face As Autodesk.Revit.Geometry.Face)
    Dim ruledFace As RuledFace = TryCast(face, RuledFace)
    If ruledFace IsNot Nothing Then
        Dim curve As Curve = ruledFace.Curve(0)
        Dim point As Autodesk.Revit.Geometry.XYZ = ruledFace.Point(0)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Face
Autodesk.Revit.Geometry..::.RuledFace

See Also

RuledFace Members
Autodesk.Revit.Geometry Namespace


RuledFace Members

[image] [image]

Revit 2010 API
RuledFace Members
RuledFace Class Constructors Methods Properties See Also Send Feedback

The RuledFace type exposes the following members.

Constructors

Name | Description
RuledFace | For Internal Use Only.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
Curve | Profile curves of the surface.
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Point | Profile points of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

RuledFace Class
Autodesk.Revit.Geometry Namespace


RuledFace Constructor

[image]

Revit 2010 API
RuledFace Constructor
RuledFace Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RuledFace()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RuledFace()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RuledFace Class
Autodesk.Revit.Geometry Namespace


RuledFace Methods

[image] [image]

Revit 2010 API
RuledFace Methods
RuledFace Class See Also Send Feedback

The RuledFace type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

RuledFace Class
Autodesk.Revit.Geometry Namespace


Intersect Method

[image] [image]

Revit 2010 API
RuledFace..::.Intersect Method
RuledFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

RuledFace Class
RuledFace Members
Autodesk.Revit.Geometry Namespace


IsInside Method

[image] [image]

Revit 2010 API
RuledFace..::.IsInside Method
RuledFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

Name | Description
IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)

See Also

RuledFace Class
RuledFace Members
Autodesk.Revit.Geometry Namespace


RuledFace Properties

[image] [image]

Revit 2010 API
RuledFace Properties
RuledFace Class See Also Send Feedback

The RuledFace type exposes the following members.

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
Curve | Profile curves of the surface.
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Point | Profile points of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

RuledFace Class
Autodesk.Revit.Geometry Namespace


Curve Property

[image]

Revit 2010 API
RuledFace..::.Curve Property
RuledFace Class See Also Send Feedback
Profile curves of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve Curve[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve ( _
    index As Integer _
) As Curve
Visual C++
public:
property Curve^ Curve[int index] {
    Curve^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

RuledFace Class
Autodesk.Revit.Geometry Namespace


Point Property

[image]

Revit 2010 API
RuledFace..::.Point Property
RuledFace Class See Also Send Feedback
Profile points of the surface.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Point[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Point ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Point[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

RuledFace Class
Autodesk.Revit.Geometry Namespace


Solid Class

[image]

Revit 2010 API
Solid Class
Members Example See Also Send Feedback
A 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Solid : GeometryObject
Visual Basic (Declaration)
Public Class Solid _
    Inherits GeometryObject
Visual C++
public ref class Solid : public GeometryObject

Remarks

A solid is defined by the faces and edges that form its boundary.

Examples

CopyC#
private void GetAndTransformSolidInfo(Autodesk.Revit.Application application, Autodesk.Revit.Element element, Options geoOptions)
{
    // Get geometry element of the selected element
    Autodesk.Revit.Geometry.Element geoElement = element.get_Geometry(geoOptions);

    // Get geometry object
    foreach (GeometryObject geoObject in geoElement.Objects)
    {
        // Get the geometry instance which contains the geometry information
        Autodesk.Revit.Geometry.Instance instance = geoObject as Autodesk.Revit.Geometry.Instance;
        if (null != instance)
        {
            foreach (GeometryObject instObj in instance.SymbolGeometry.Objects)
            {
                Solid solid = instObj as Solid;
                if (null == solid || 0 == solid.Faces.Size || 0 == solid.Edges.Size)
                {
                    continue;
                }

                Transform instTransform = instance.Transform;
                // Get the faces and edges from solid, and transform the formed points
                foreach (Face face in solid.Faces)
                {
                    Mesh mesh = face.Triangulate();
                    foreach (XYZ ii in mesh.Vertices)
                    {
                        XYZ point = ii;
                        XYZ transformedPoint = instTransform.OfPoint(point);
                    }
                }
                foreach (Edge edge in solid.Edges)
                {
                    foreach (XYZ ii in edge.Tessellate())
                    {
                        XYZ point = ii;
                        XYZ transformedPoint = instTransform.OfPoint(point);
                    }
                }
            }
        }
    }

}
CopyVB.NET
Private Sub GetAndTransformSolidInfo(ByVal application As Autodesk.Revit.Application, ByVal element As Autodesk.Revit.Element, ByVal geoOptions As Autodesk.Revit.Geometry.Options)
    ' Get geometry element of the selected element
    Dim geoElement As Autodesk.Revit.Geometry.Element = element.Geometry(geoOptions)

    ' Get geometry object
    For Each geoObject As GeometryObject In geoElement.Objects
        ' Get the geometry instance which contains the geometry information
        Dim instance As Autodesk.Revit.Geometry.Instance = TryCast(geoObject, Autodesk.Revit.Geometry.Instance)
        If instance IsNot Nothing Then
            For Each instObj As GeometryObject In instance.SymbolGeometry.Objects
                Dim solid As Solid = TryCast(instObj, Solid)
                If solid Is Nothing OrElse 0 = solid.Faces.Size OrElse 0 = solid.Edges.Size Then
                    Continue For
                End If

                Dim instTransform As Transform = instance.Transform
                ' Get the faces and edges from solid, and transform the formed points
                For Each face As Autodesk.Revit.Geometry.Face In solid.Faces
                    Dim mesh As Mesh = face.Triangulate()
                    For Each ii As Autodesk.Revit.Geometry.XYZ In mesh.Vertices
                        Dim point As Autodesk.Revit.Geometry.XYZ = ii
                        Dim transformedPoint As Autodesk.Revit.Geometry.XYZ = instTransform.OfPoint(point)
                    Next
                Next
                For Each edge As Autodesk.Revit.Geometry.Edge In solid.Edges
                    For Each ii As Autodesk.Revit.Geometry.XYZ In edge.Tessellate()
                        Dim point As Autodesk.Revit.Geometry.XYZ = ii
                        Dim transformedPoint As Autodesk.Revit.Geometry.XYZ = instTransform.OfPoint(point)
                    Next
                Next
            Next
        End If
    Next

End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Solid

See Also

Solid Members
Autodesk.Revit.Geometry Namespace


Solid Members

[image] [image]

Revit 2010 API
Solid Members
Solid Class Constructors Methods Properties See Also Send Feedback

The Solid type exposes the following members.

Constructors

Name | Description
Solid | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Edges | The edges that belong to the solid.
Faces | The faces that belong to the solid.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
SurfaceArea | Returns the total surface area of this solid.
Visibility | The visibility. (Inherited from GeometryObject.)
Volume | Returns the signed volume of this solid.

See Also

Solid Class
Autodesk.Revit.Geometry Namespace


Solid Constructor

[image]

Revit 2010 API
Solid Constructor
Solid Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Solid()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Solid()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Solid Class
Autodesk.Revit.Geometry Namespace


Solid Methods

[image] [image]

Revit 2010 API
Solid Methods
Solid Class See Also Send Feedback

The Solid type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Solid Class
Autodesk.Revit.Geometry Namespace


Solid Properties

[image] [image]

Revit 2010 API
Solid Properties
Solid Class See Also Send Feedback

The Solid type exposes the following members.

Properties

Name | Description
Edges | The edges that belong to the solid.
Faces | The faces that belong to the solid.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
SurfaceArea | Returns the total surface area of this solid.
Visibility | The visibility. (Inherited from GeometryObject.)
Volume | Returns the signed volume of this solid.

See Also

Solid Class
Autodesk.Revit.Geometry Namespace


Edges Property

[image]

Revit 2010 API
Solid..::.Edges Property
Solid Class See Also Send Feedback
The edges that belong to the solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public EdgeArray Edges { get; }
Visual Basic (Declaration)
Public ReadOnly Property Edges As EdgeArray
Visual C++
public:
property EdgeArray^ Edges {
    EdgeArray^ get ();
}

See Also

Solid Class
Autodesk.Revit.Geometry Namespace


Faces Property

[image]

Revit 2010 API
Solid..::.Faces Property
Solid Class Example See Also Send Feedback
The faces that belong to the solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FaceArray Faces { get; }
Visual Basic (Declaration)
Public ReadOnly Property Faces As FaceArray
Visual C++
public:
property FaceArray^ Faces {
    FaceArray^ get ();
}

Remarks

A face may be degenerate. This can be determined with the Face property IsTwoSided.

Examples

CopyC#
private void GetFacesAndEdges(Wall wall)
{
    String faceInfo = "";

    Autodesk.Revit.Geometry.Options opt = new Options();
    Autodesk.Revit.Geometry.Element geomElem = wall.get_Geometry(opt);
    foreach (GeometryObject geomObj in geomElem.Objects)
    {
        Solid geomSolid = geomObj as Solid;
        if (null != geomSolid)
        {
            int faces = 0;
            double totalArea = 0;
            foreach (Face geomFace in geomSolid.Faces)
            {
                faces++;
                faceInfo += "Face " + faces + " area: " + geomFace.Area.ToString() + "\n";
                totalArea += geomFace.Area;
            }
            faceInfo += "Number of faces: " + faces + "\n";
            faceInfo += "Total area: " + totalArea.ToString() + "\n";
            foreach (Edge geomEdge in geomSolid.Edges)
            {
                // get wall's geometry edges
            }
        }
    }

    MessageBox.Show(faceInfo);
}
CopyVB.NET
Private Sub GetFacesAndEdges(ByVal wall As Wall)
    Dim faceInfo As String = ""

    Dim opt As Autodesk.Revit.Geometry.Options = New Autodesk.Revit.Geometry.Options()
    Dim geomElem As Autodesk.Revit.Geometry.Element = wall.Geometry(opt)
    For Each geomObj As GeometryObject In geomElem.Objects
        Dim geomSolid As Solid = TryCast(geomObj, Solid)
        If geomSolid IsNot Nothing Then
            Dim faces As Integer = 0
            Dim totalArea As Double = 0
            For Each geomFace As Autodesk.Revit.Geometry.Face In geomSolid.Faces
                faces += 1
                faceInfo += ("Face " & faces & " area: ") + geomFace.Area.ToString() & vbLf
                totalArea += geomFace.Area
            Next
            faceInfo += "Number of faces: " & faces & vbLf
            faceInfo += "Total area: " & totalArea.ToString() & vbLf
            For Each geomEdge As Autodesk.Revit.Geometry.Edge In geomSolid.Edges
                ' get wall's geometry edges
            Next
        End If
    Next

    MessageBox.Show(faceInfo)
End Sub

See Also

Solid Class
Autodesk.Revit.Geometry Namespace


SurfaceArea Property

[image]

Revit 2010 API
Solid..::.SurfaceArea Property
Solid Class See Also Send Feedback
Returns the total surface area of this solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double SurfaceArea { get; }
Visual Basic (Declaration)
Public ReadOnly Property SurfaceArea As Double
Visual C++
public:
property double SurfaceArea {
    double get ();
}

Return Value

The real number equal to the total area of this solid.

Remarks

Calculates the surface area by adding together the areas of faces comprising this solid. Will slightly underestimate if curved surfaces are present.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when this solid is not a valid Geometry object.

See Also

Solid Class
Autodesk.Revit.Geometry Namespace


Volume Property

[image]

Revit 2010 API
Solid..::.Volume Property
Solid Class See Also Send Feedback
Returns the signed volume of this solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Volume { get; }
Visual Basic (Declaration)
Public ReadOnly Property Volume As Double
Visual C++
public:
property double Volume {
    double get ();
}

Return Value

The real number equal to the signed volume of this solid.

Remarks

Calculates the solid volume by integrating tessellated representations of faces and edges. Will slightly underestimate if curved surfaces are present.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when this solid is not a valid Geometry object or the volume calculation failed.

See Also

Solid Class
Autodesk.Revit.Geometry Namespace


SolidArray Class

[image]

Revit 2010 API
SolidArray Class
Members See Also Send Feedback
An array that contains solids.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SolidArray : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class SolidArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SolidArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.SolidArray

See Also

SolidArray Members
Autodesk.Revit.Geometry Namespace


SolidArray Members

[image] [image]

Revit 2010 API
SolidArray Members
SolidArray Class Constructors Methods Properties See Also Send Feedback

The SolidArray type exposes the following members.

Constructors

Name | Description
SolidArray | Initializes a new instance of the SolidArray class

Methods

Name | Description
Append | Add the solid to the end of the array.
Clear | Removes every solid from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified solid into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a solid at a specified index within the array.
Size | Returns the number of solids that are in the array.

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


SolidArray Constructor

[image]

Revit 2010 API
SolidArray Constructor
SolidArray Class See Also Send Feedback
Initializes a new instance of the SolidArray class

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SolidArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SolidArray()

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


SolidArray Methods

[image] [image]

Revit 2010 API
SolidArray Methods
SolidArray Class See Also Send Feedback

The SolidArray type exposes the following members.

Methods

Name | Description
Append | Add the solid to the end of the array.
Clear | Removes every solid from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified solid into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


Append Method

[image]

Revit 2010 API
SolidArray..::.Append Method
SolidArray Class See Also Send Feedback
Add the solid to the end of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    Solid item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Solid _
)
Visual C++
public:
virtual void Append(
    Solid^ item
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.Solid
The solid to be added.

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

[image]

Revit 2010 API
SolidArray..::.Clear Method
SolidArray Class See Also Send Feedback
Removes every solid from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

[image]

Revit 2010 API
SolidArray..::.ForwardIterator Method
SolidArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual SolidArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SolidArrayIterator
Visual C++
public:
virtual SolidArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

[image]

Revit 2010 API
SolidArray..::.GetEnumerator Method
SolidArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

[image]

Revit 2010 API
SolidArray..::.Insert Method
SolidArray Class See Also Send Feedback
Insert the specified solid into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    Solid item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Solid, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Solid^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.Solid
The solid to be inserted into the array.
index
Type: System..::.Int32
The solid will be inserted before this index.

Return Value

Returns whether the solid was inserted into the array.

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

[image]

Revit 2010 API
SolidArray..::.ReverseIterator Method
SolidArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual SolidArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SolidArrayIterator
Visual C++
public:
virtual SolidArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


SolidArray Properties

[image] [image]

Revit 2010 API
SolidArray Properties
SolidArray Class See Also Send Feedback

The SolidArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a solid at a specified index within the array.
Size | Returns the number of solids that are in the array.

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


IsEmpty Property

[image]

Revit 2010 API
SolidArray..::.IsEmpty Property
SolidArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


Item Property

[image]

Revit 2010 API
SolidArray..::.Item Property
SolidArray Class See Also Send Feedback
Gets or sets a solid at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Solid Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Solid
Visual C++
public:
virtual property Solid^ Item[int index] {
    Solid^ get (int index);
    void set (int index, Solid^ value);
}

Parameters

index
Type: System..::.Int32
The index of the solid to be set or retrieved.

Return Value

Returns the solid at the specified index.

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


Size Property

[image]

Revit 2010 API
SolidArray..::.Size Property
SolidArray Class See Also Send Feedback
Returns the number of solids that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace


SolidArrayIterator Class

[image]

Revit 2010 API
SolidArrayIterator Class
Members See Also Send Feedback
An iterator to a solids array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class SolidArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class SolidArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SolidArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.SolidArrayIterator

See Also

SolidArrayIterator Members
Autodesk.Revit.Geometry Namespace


SolidArrayIterator Members

[image] [image]

Revit 2010 API
SolidArrayIterator Members
SolidArrayIterator Class Constructors Methods Properties See Also Send Feedback

The SolidArrayIterator type exposes the following members.

Constructors

Name | Description
SolidArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SolidArrayIterator Class
Autodesk.Revit.Geometry Namespace


SolidArrayIterator Constructor

[image]

Revit 2010 API
SolidArrayIterator Constructor
SolidArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SolidArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SolidArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SolidArrayIterator Class
Autodesk.Revit.Geometry Namespace


SolidArrayIterator Methods

[image] [image]

Revit 2010 API
SolidArrayIterator Methods
SolidArrayIterator Class See Also Send Feedback

The SolidArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SolidArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

[image]

Revit 2010 API
SolidArrayIterator..::.MoveNext Method
SolidArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SolidArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

[image]

Revit 2010 API
SolidArrayIterator..::.Reset Method
SolidArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SolidArrayIterator Class
Autodesk.Revit.Geometry Namespace


SolidArrayIterator Properties

[image] [image]

Revit 2010 API
SolidArrayIterator Properties
SolidArrayIterator Class See Also Send Feedback

The SolidArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SolidArrayIterator Class
Autodesk.Revit.Geometry Namespace


Current Property

[image]

Revit 2010 API
SolidArrayIterator..::.Current Property
SolidArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SolidArrayIterator Class
Autodesk.Revit.Geometry Namespace


Transform Class

[image]

Revit 2010 API
Transform Class
Members Example See Also Send Feedback
A transformation of the affine 3-space.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Transform : APIObject
Visual Basic (Declaration)
Public Class Transform _
    Inherits APIObject
Visual C++
public ref class Transform : public APIObject

Examples

CopyC#
public static XYZ TransformPoint(XYZ point, Transform transform)
{
    double x = point.X;
    double y = point.Y;
    double z = point.Z;

    //transform basis of the old coordinate system in the new coordinate // system
    XYZ b0 = transform.get_Basis(0);
    XYZ b1 = transform.get_Basis(1);
    XYZ b2 = transform.get_Basis(2);
    XYZ origin = transform.Origin;

    //transform the origin of the old coordinate system in the new
    //coordinate system
    double xTemp = x * b0.X + y * b1.X + z * b2.X + origin.X;
    double yTemp = x * b0.Y + y * b1.Y + z * b2.Y + origin.Y;
    double zTemp = x * b0.Z + y * b1.Z + z * b2.Z + origin.Z;

    return new XYZ(xTemp, yTemp, zTemp);
}
CopyVB.NET
Public Shared Function TransformPoint(ByVal point As Autodesk.Revit.Geometry.XYZ, ByVal transform As Transform) As Autodesk.Revit.Geometry.XYZ
    Dim x As Double = point.X
    Dim y As Double = point.Y
    Dim z As Double = point.Z

    'transform basis of the old coordinate system in the new coordinate // system
    Dim b0 As Autodesk.Revit.Geometry.XYZ = transform.Basis(0)
    Dim b1 As Autodesk.Revit.Geometry.XYZ = transform.Basis(1)
    Dim b2 As Autodesk.Revit.Geometry.XYZ = transform.Basis(2)
    Dim origin As Autodesk.Revit.Geometry.XYZ = transform.Origin

    'transform the origin of the old coordinate system in the new
    'coordinate system
    Dim xTemp As Double = x * b0.X + y * b1.X + z * b2.X + origin.X
    Dim yTemp As Double = x * b0.Y + y * b1.Y + z * b2.Y + origin.Y
    Dim zTemp As Double = x * b0.Z + y * b1.Z + z * b2.Z + origin.Z

    Return New Autodesk.Revit.Geometry.XYZ(xTemp, yTemp, zTemp)
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.Transform

See Also

Transform Members
Autodesk.Revit.Geometry Namespace


Transform Members

[image] [image]

Revit 2010 API
Transform Members
Transform Class Constructors Methods Properties See Also Send Feedback

The Transform type exposes the following members.

Constructors

Name | Description
Transform | The copy constructor.

Methods

Name | Description
AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Multiply | Multiplies this transformation by the specified transformation and returns the result.
OfPoint | Applies the transformation to the point and returns the result.
OfVector | Applies the transform to the vector
ScaleBasis | Scales the basis vectors of this transformation and returns the result.
ScaleBasisAndOrigin | Scales the basis vectors and the origin of this transformation and returns the result.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Multiply | Multiplies the two specified transforms.

Properties

Name | Description
Basis | Defines the basis of the old coordinate system in the new coordinate system.
BasisX | The basis of the X axis of this transformation.
BasisY | The basis of the Y axis of this transformation.
BasisZ | The basis of the Z axis of this transformation.
Determinant | The determinant of this transformation.
HasReflection | The boolean value that indicates whether this transformation produces reflection.
Identity | The identity transformation.
Inverse | The inverse transformation of this transformation.
IsConformal | The boolean value that indicates whether this transformation is conformal.
IsIdentity | The boolean value that indicates whether this transformation is an identity.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTranslation | The boolean value that indicates whether this transformation is a translation.
Origin | Defines the origin of the old coordinate system in the new coordinate system.
Reflection | The transformation that reflects about the specified plane.
Rotation | The transformation that rotates by the specified angle about the specified axis and point.
Scale | The real number that represents the scale of the transformation.
Translation | The transformation that translates by the specified vector.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Transform Constructor

[image]

Revit 2010 API
Transform Constructor
Transform Class See Also Send Feedback
The copy constructor.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Transform(
    Transform source
)
Visual Basic (Declaration)
Public Sub New ( _
    source As Transform _
)
Visual C++
public:
Transform(
    Transform^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.Transform

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Transform Methods

[image] [image]

Revit 2010 API
Transform Methods
Transform Class See Also Send Feedback

The Transform type exposes the following members.

Methods

Name | Description
AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Multiply | Multiplies this transformation by the specified transformation and returns the result.
OfPoint | Applies the transformation to the point and returns the result.
OfVector | Applies the transform to the vector
ScaleBasis | Scales the basis vectors of this transformation and returns the result.
ScaleBasisAndOrigin | Scales the basis vectors and the origin of this transformation and returns the result.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Multiply | Multiplies the two specified transforms.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


AlmostEqual Method

[image]

Revit 2010 API
Transform..::.AlmostEqual Method
Transform Class See Also Send Feedback
Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool AlmostEqual(
    Transform right
)
Visual Basic (Declaration)
Public Function AlmostEqual ( _
    right As Transform _
) As Boolean
Visual C++
public:
bool AlmostEqual(
    Transform^ right
)

Parameters

right
Type: Autodesk.Revit.Geometry..::.Transform
The transformation to compare with this transformation.

Return Value

True if the two transformations are equal; otherwise, false.

Remarks

The tolerance is applied memberwise for comparison.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified transformation is null.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Multiply Method

[image]

Revit 2010 API
Transform..::.Multiply Method
Transform Class See Also Send Feedback
Multiplies this transformation by the specified transformation and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Transform Multiply(
    Transform right
)
Visual Basic (Declaration)
Public Function Multiply ( _
    right As Transform _
) As Transform
Visual C++
public:
Transform^ Multiply(
    Transform^ right
)

Parameters

right
Type: Autodesk.Revit.Geometry..::.Transform
The specified transformation.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The combined transformation has the same effect as applying the right transformation first, and the left transformation, second. So, (T1(T2(p)) = (T1 * T2) (p).

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the handle of the specified transformation is null.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Multiply Operator

[image]

Revit 2010 API
Transform..::.Multiply Operator
Transform Class See Also Send Feedback
Multiplies the two specified transforms.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static Transform operator *(
    Transform left,
    Transform right
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    left As Transform, _
    right As Transform _
) As Transform
Visual C++
public:
static Transform^ operator *(
    Transform^ left,
    Transform^ right
)

Parameters

left
Type: Autodesk.Revit.Geometry..::.Transform
The first transformation.
right
Type: Autodesk.Revit.Geometry..::.Transform
The second transformation.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The combined transformation has the same effect as applying the right transformation first, and the left transformation, second. So, (T1(T2(p)) = (T1 * T2) (p).

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the handle of the first or second transformation is null.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


OfPoint Method

[image]

Revit 2010 API
Transform..::.OfPoint Method
Transform Class See Also Send Feedback
Applies the transformation to the point and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ OfPoint(
    XYZ point
)
Visual Basic (Declaration)
Public Function OfPoint ( _
    point As XYZ _
) As XYZ
Visual C++
public:
XYZ^ OfPoint(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
The point to transform.

Return Value

The transformed point.

Remarks

Transformation of a point is affected by the translational part of the transformation.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


OfVector Method

[image]

Revit 2010 API
Transform..::.OfVector Method
Transform Class See Also Send Feedback
Applies the transform to the vector

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ OfVector(
    XYZ vec
)
Visual Basic (Declaration)
Public Function OfVector ( _
    vec As XYZ _
) As XYZ
Visual C++
public:
XYZ^ OfVector(
    XYZ^ vec
)

Parameters

vec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to be transformed

Return Value

The new vector after transform

Remarks

Transformation of a vector is not affected by the translational part of the transformation.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


ScaleBasis Method

[image]

Revit 2010 API
Transform..::.ScaleBasis Method
Transform Class See Also Send Feedback
Scales the basis vectors of this transformation and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Transform ScaleBasis(
    double scale
)
Visual Basic (Declaration)
Public Function ScaleBasis ( _
    scale As Double _
) As Transform
Visual C++
public:
Transform^ ScaleBasis(
    double scale
)

Parameters

scale
Type: System..::.Double
The scale value.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The resulting transformation is equivalent to the application of the uniform scale and then this transformation, in this order.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when the specified value is an infinite number.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


ScaleBasisAndOrigin Method

[image]

Revit 2010 API
Transform..::.ScaleBasisAndOrigin Method
Transform Class See Also Send Feedback
Scales the basis vectors and the origin of this transformation and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Transform ScaleBasisAndOrigin(
    double scale
)
Visual Basic (Declaration)
Public Function ScaleBasisAndOrigin ( _
    scale As Double _
) As Transform
Visual C++
public:
Transform^ ScaleBasisAndOrigin(
    double scale
)

Parameters

scale
Type: System..::.Double
The scale value.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The resulting transformation is equivalent to the application of this transformation and then the uniform scale, in this order.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when the specified value is an infinite number.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Transform Properties

[image] [image]

Revit 2010 API
Transform Properties
Transform Class See Also Send Feedback

The Transform type exposes the following members.

Properties

Name | Description
Basis | Defines the basis of the old coordinate system in the new coordinate system.
BasisX | The basis of the X axis of this transformation.
BasisY | The basis of the Y axis of this transformation.
BasisZ | The basis of the Z axis of this transformation.
Determinant | The determinant of this transformation.
HasReflection | The boolean value that indicates whether this transformation produces reflection.
Identity | The identity transformation.
Inverse | The inverse transformation of this transformation.
IsConformal | The boolean value that indicates whether this transformation is conformal.
IsIdentity | The boolean value that indicates whether this transformation is an identity.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTranslation | The boolean value that indicates whether this transformation is a translation.
Origin | Defines the origin of the old coordinate system in the new coordinate system.
Reflection | The transformation that reflects about the specified plane.
Rotation | The transformation that rotates by the specified angle about the specified axis and point.
Scale | The real number that represents the scale of the transformation.
Translation | The transformation that translates by the specified vector.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Basis Property

[image]

Revit 2010 API
Transform..::.Basis Property
Transform Class See Also Send Feedback
Defines the basis of the old coordinate system in the new coordinate system.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Basis[
    int idx
] { get; set; }
Visual Basic (Declaration)
Public Property Basis ( _
    idx As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Basis[int idx] {
    XYZ^ get (int idx);
    void set (int idx, XYZ^ value);
}

Parameters

idx
Type: System..::.Int32
The index of the basis vector: 0, 1 or 2.

Remarks

This corresponds to the first three column vectors of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
System..::.IndexOutOfRangeException | Thrown when the given index is larger than 2 in the getter and setter.
System..::.InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


BasisX Property

[image]

Revit 2010 API
Transform..::.BasisX Property
Transform Class See Also Send Feedback
The basis of the X axis of this transformation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ BasisX { get; set; }
Visual Basic (Declaration)
Public Property BasisX As XYZ
Visual C++
public:
property XYZ^ BasisX {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The X axis of the old coordinate system in the new coordinate system, or the 1st column of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


BasisY Property

[image]

Revit 2010 API
Transform..::.BasisY Property
Transform Class See Also Send Feedback
The basis of the Y axis of this transformation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ BasisY { get; set; }
Visual Basic (Declaration)
Public Property BasisY As XYZ
Visual C++
public:
property XYZ^ BasisY {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The Y axis of the old coordinate system in the new coordinate system, or the 2nd column of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


BasisZ Property

[image]

Revit 2010 API
Transform..::.BasisZ Property
Transform Class See Also Send Feedback
The basis of the Z axis of this transformation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ BasisZ { get; set; }
Visual Basic (Declaration)
Public Property BasisZ As XYZ
Visual C++
public:
property XYZ^ BasisZ {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The Z axis of the old coordinate system in the new coordinate system, or the 3rd column of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Determinant Property

[image]

Revit 2010 API
Transform..::.Determinant Property
Transform Class See Also Send Feedback
The determinant of this transformation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Determinant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Determinant As Double
Visual C++
public:
property double Determinant {
    double get ();
}

Remarks

The geometric meaning of a determinant is as the scale factor for volume when applied as linear transformation.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


HasReflection Property

[image]

Revit 2010 API
Transform..::.HasReflection Property
Transform Class See Also Send Feedback
The boolean value that indicates whether this transformation produces reflection.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool HasReflection { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasReflection As Boolean
Visual C++
public:
property bool HasReflection {
    bool get ();
}

Remarks

Reflection transformation changes the handedness of a coordinate system.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when this transformation is not conformal and the reflection is undefined.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Identity Property

[image]

Revit 2010 API
Transform..::.Identity Property
Transform Class See Also Send Feedback
The identity transformation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static Transform Identity { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Identity As Transform
Visual C++
public:
static property Transform^ Identity {
    Transform^ get ();
}

Remarks

The identity transformation does not change a point or a vector that it is applied to.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Inverse Property

[image]

Revit 2010 API
Transform..::.Inverse Property
Transform Class See Also Send Feedback
The inverse transformation of this transformation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Transform Inverse { get; }
Visual Basic (Declaration)
Public ReadOnly Property Inverse As Transform
Visual C++
public:
property Transform^ Inverse {
    Transform^ get ();
}

Remarks

The transformation matrix A is invertible if there exists a transformation matrix B such that A*B = B*A = I (identity).

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when this transformation is not conformal or invertible.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


IsConformal Property

[image]

Revit 2010 API
Transform..::.IsConformal Property
Transform Class See Also Send Feedback
The boolean value that indicates whether this transformation is conformal.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsConformal { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsConformal As Boolean
Visual C++
public:
property bool IsConformal {
    bool get ();
}

Remarks

This property is true if this transformation can be decomposed as the product of a rigid-body motion, uniform scale and reflection. Such transformation preserves angles between vectors.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


IsIdentity Property

[image]

Revit 2010 API
Transform..::.IsIdentity Property
Transform Class See Also Send Feedback
The boolean value that indicates whether this transformation is an identity.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsIdentity { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsIdentity As Boolean
Visual C++
public:
property bool IsIdentity {
    bool get ();
}

Remarks

The identity transformation does not change a point or a vector that it is applied to.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


IsTranslation Property

[image]

Revit 2010 API
Transform..::.IsTranslation Property
Transform Class See Also Send Feedback
The boolean value that indicates whether this transformation is a translation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsTranslation { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsTranslation As Boolean
Visual C++
public:
property bool IsTranslation {
    bool get ();
}

Remarks

This property is true if the only effect of transformation is translation. It checks that the basis of the transform is identity. The translation vector may be zero (which would make this an identity transformation) or nonzero (which would make this a non-trivial translation).

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Origin Property

[image]

Revit 2010 API
Transform..::.Origin Property
Transform Class See Also Send Feedback
Defines the origin of the old coordinate system in the new coordinate system.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Origin { get; set; }
Visual Basic (Declaration)
Public Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This corresponds to the fourth column vector of the conventional 3x4 matrix representation. Also, this is the translation component of the transformation.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Reflection Property

[image]

Revit 2010 API
Transform..::.Reflection Property
Transform Class Example See Also Send Feedback
The transformation that reflects about the specified plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static Transform Reflection[
    Plane plane
] { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Reflection ( _
    plane As Plane _
) As Transform
Visual C++
public:
static property Transform^ Reflection[Plane^ plane] {
    Transform^ get (Plane^ plane);
}

Parameters

plane
Type: Autodesk.Revit.Geometry..::.Plane
The plane to reflect about.

Examples

CopyC#
private Transform Reflect(ReferencePlane refPlane)
{
    Transform mirTrans = Transform.get_Reflection(refPlane.Plane);

    return mirTrans;
}
CopyVB.NET
Private Function Reflect(ByVal refPlane As ReferencePlane) As Transform
    Dim mirTrans As Transform = Transform.Reflection(refPlane.Plane)

    Return mirTrans
End Function

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the handle of the plane is null.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Rotation Property

[image]

Revit 2010 API
Transform..::.Rotation Property
Transform Class See Also Send Feedback
The transformation that rotates by the specified angle about the specified axis and point.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static Transform Rotation[
    XYZ origin,
    XYZ axis,
    double angle
] { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Rotation ( _
    origin As XYZ, _
    axis As XYZ, _
    angle As Double _
) As Transform
Visual C++
public:
static property Transform^ Rotation[XYZ^ origin, XYZ^ axis, double angle] {
    Transform^ get (XYZ^ origin, XYZ^ axis, double angle);
}

Parameters

origin
Type: Autodesk.Revit.Geometry..::.XYZ
The point to rotate about.
axis
Type: Autodesk.Revit.Geometry..::.XYZ
The axis vector to rotate about.
angle
Type: System..::.Double
The rotation angle in radians.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when the specified value is an infinite number.
System..::.ArgumentException | Thrown when the specified values fail to define the transformation.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Scale Property

[image]

Revit 2010 API
Transform..::.Scale Property
Transform Class See Also Send Feedback
The real number that represents the scale of the transformation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Scale { get; }
Visual Basic (Declaration)
Public ReadOnly Property Scale As Double
Visual C++
public:
property double Scale {
    double get ();
}

Remarks

When the transformation is conformal and can be decomposed as the product of a rigid-body motion, uniform scale and reflection, this property returns the scale value of the uniform scale transformation.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when this transformation is not conformal and the scale is undefined.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


Translation Property

[image]

Revit 2010 API
Transform..::.Translation Property
Transform Class See Also Send Feedback
The transformation that translates by the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static Transform Translation[
    XYZ vec
] { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Translation ( _
    vec As XYZ _
) As Transform
Visual C++
public:
static property Transform^ Translation[XYZ^ vec] {
    Transform^ get (XYZ^ vec);
}

Parameters

vec
Type: Autodesk.Revit.Geometry..::.XYZ
The translation vector.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace


UV Class

[image]

Revit 2010 API
UV Class
Members See Also Send Feedback
Object representing coordinates in 2-space.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class UV
Visual Basic (Declaration)
Public Class UV
Visual C++
public ref class UV

Remarks

Usually this means parameters on a surface. In actual use , it could be interpreted as either point or vector in the space.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Geometry..::.UV

See Also

UV Members
Autodesk.Revit.Geometry Namespace


UV Members

[image] [image]

Revit 2010 API
UV Members
UV Class Constructors Methods Properties See Also Send Feedback

The UV type exposes the following members.

Constructors

Name | Description
UV | Overloaded.

Methods

Name | Description
Add | Adds the specified 2-D vector to this 2-D vector and returns the result.
AlmostEqual | Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).
Angle | Returns the angle between this vector and the specified vector.
Cross | The cross product of this 2-D vector and the specified 2-D vector.
Distance | Returns the distance from this 2-D point to the specified 2-D point.
Divide | Divides this 2-D vector by the specified value and returns the result.
Dot | The dot product of this 2-D vector and the specified 2-D vector.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Multiply | Multiplies this 2-D vector by the specified value and returns the result.
Negate | Negates this 2-D vector.
Subtract | Subtracts the specified 2-D vector from this 2-D vector and returns the result.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Addition | Adds the two specified 2-D vectors and returns the result.
Division | Divides the specified 2-D vector by the specified value.
Multiply | Overloaded. The product of the specified number and the specified 2-D vector.
Subtraction | Subtracts the two specified 2-D vectors and returns the result.
UnaryNegation | Negates this 2-D vector and returns the result.

Properties

Name | Description
Basis | Indexed access for Basis.
BasisU | The basic of the U axis.
BasisV | The basic of the V axis.
IsNormalized | The boolean value that indicates whether this 2-D vector is a normalized vector.
IsZero | The boolean value that indicates whether this 2-D vector is a zero vector.
Item | Indexed access to coordinates.
Length | The length of this 2-D vector.
Normalized | This 2-D vector, normalized.
U | The first coordinate.
V | The second coordinate.
Zero | The coordinate origin or zero 2-D vector.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


UV Constructor

[image] [image]

Revit 2010 API
UV Constructor
UV Class See Also Send Feedback

Overload List

Name | Description
UV()()() | default constructor
UV(UV) | Creates object with supplied UV object.
UV(Double, Double) | Creates object with supplied values.

See Also

UV Class
UV Members
Autodesk.Revit.Geometry Namespace


UV Constructor

[image]

Revit 2010 API
UV Constructor
UV Class See Also Send Feedback
default constructor

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UV()

See Also

UV Class
UV Overload
Autodesk.Revit.Geometry Namespace


UV Constructor (UV)

[image]

Revit 2010 API
UV Constructor (UV)
UV Class See Also Send Feedback
Creates object with supplied UV object.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV(
    UV uv
)
Visual Basic (Declaration)
Public Sub New ( _
    uv As UV _
)
Visual C++
public:
UV(
    UV^ uv
)

Parameters

uv
Type: Autodesk.Revit.Geometry..::.UV
The supplied UV object

See Also

UV Class
UV Overload
Autodesk.Revit.Geometry Namespace


UV Constructor (Double, Double)

[image]

Revit 2010 API
UV Constructor (Double, Double)
UV Class See Also Send Feedback
Creates object with supplied values.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV(
    double u,
    double v
)
Visual Basic (Declaration)
Public Sub New ( _
    u As Double, _
    v As Double _
)
Visual C++
public:
UV(
    double u,
    double v
)

Parameters

u
Type: System..::.Double
The first coordinate.
v
Type: System..::.Double
The second coordinate.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when setting an infinite number to the U or V property.

See Also

UV Class
UV Overload
Autodesk.Revit.Geometry Namespace


UV Methods

[image] [image]

Revit 2010 API
UV Methods
UV Class See Also Send Feedback

The UV type exposes the following members.

Methods

Name | Description
Add | Adds the specified 2-D vector to this 2-D vector and returns the result.
AlmostEqual | Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).
Angle | Returns the angle between this vector and the specified vector.
Cross | The cross product of this 2-D vector and the specified 2-D vector.
Distance | Returns the distance from this 2-D point to the specified 2-D point.
Divide | Divides this 2-D vector by the specified value and returns the result.
Dot | The dot product of this 2-D vector and the specified 2-D vector.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Multiply | Multiplies this 2-D vector by the specified value and returns the result.
Negate | Negates this 2-D vector.
Subtract | Subtracts the specified 2-D vector from this 2-D vector and returns the result.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Addition | Adds the two specified 2-D vectors and returns the result.
Division | Divides the specified 2-D vector by the specified value.
Multiply | Overloaded. The product of the specified number and the specified 2-D vector.
Subtraction | Subtracts the two specified 2-D vectors and returns the result.
UnaryNegation | Negates this 2-D vector and returns the result.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Add Method

[image]

Revit 2010 API
UV..::.Add Method
UV Class See Also Send Feedback
Adds the specified 2-D vector to this 2-D vector and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV Add(
    UV source
)
Visual Basic (Declaration)
Public Function Add ( _
    source As UV _
) As UV
Visual C++
public:
UV^ Add(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.UV
The vector to add to this vector.

Return Value

The 2-D vector equal to the sum of the two vectors.

Remarks

The added vector is obtained by adding each coordinate of the specified vector to the corresponding coordinate of this vector.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Addition Operator

[image]

Revit 2010 API
UV..::.Addition Operator
UV Class See Also Send Feedback
Adds the two specified 2-D vectors and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static UV operator +(
    UV left,
    UV right
)
Visual Basic (Declaration)
Public Shared Operator + ( _
    left As UV, _
    right As UV _
) As UV
Visual C++
public:
static UV^ operator +(
    UV^ left,
    UV^ right
)

Parameters

left
Type: Autodesk.Revit.Geometry..::.UV
The first vector.
right
Type: Autodesk.Revit.Geometry..::.UV
The second vector.

Return Value

The 2-D vector equal to the sum of the two source vectors.

Remarks

The added vector is obtained by adding each coordinate of the right vector to the corresponding coordinate of the left vector.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


AlmostEqual Method

[image]

Revit 2010 API
UV..::.AlmostEqual Method
UV Class See Also Send Feedback
Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool AlmostEqual(
    UV source
)
Visual Basic (Declaration)
Public Function AlmostEqual ( _
    source As UV _
) As Boolean
Visual C++
public:
bool AlmostEqual(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.UV
The vector to compare with this vector.

Return Value

True if the vectors are the same; otherwise, false.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Angle Method

[image]

Revit 2010 API
UV..::.Angle Method
UV Class See Also Send Feedback
Returns the angle between this vector and the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Angle(
    UV source
)
Visual Basic (Declaration)
Public Function Angle ( _
    source As UV _
) As Double
Visual C++
public:
double Angle(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.UV
The specified vector.

Return Value

The real number between 0 and 2*PI equal to the angle between the two vectors.

Remarks

The angle is measured counterclockwise.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Cross Method

[image]

Revit 2010 API
UV..::.Cross Method
UV Class See Also Send Feedback
The cross product of this 2-D vector and the specified 2-D vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Cross(
    UV source
)
Visual Basic (Declaration)
Public Function Cross ( _
    source As UV _
) As Double
Visual C++
public:
double Cross(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.UV
The vector to multiply with this vector.

Return Value

The real number equal to the cross product.

Remarks

The cross product of the two vectors in 2-D space is defined as the area of the parallelogram they span.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Distance Method

[image]

Revit 2010 API
UV..::.Distance Method
UV Class See Also Send Feedback
Returns the distance from this 2-D point to the specified 2-D point.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Distance(
    UV source
)
Visual Basic (Declaration)
Public Function Distance ( _
    source As UV _
) As Double
Visual C++
public:
double Distance(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.UV
The specified point.

Return Value

The real number equal to the distance between the two points.

Remarks

The distance between the two points is equal to the length of the vector that joins the two points.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Divide Method

[image]

Revit 2010 API
UV..::.Divide Method
UV Class See Also Send Feedback
Divides this 2-D vector by the specified value and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV Divide(
    double value
)
Visual Basic (Declaration)
Public Function Divide ( _
    value As Double _
) As UV
Visual C++
public:
UV^ Divide(
    double value
)

Parameters

value
Type: System..::.Double
The value to divide this vector by.

Return Value

The divided 2-D vector.

Remarks

The divided vector is obtained by dividing each coordinate of this vector by the specified value.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when the specified value is an infinite number.
System..::.DivideByZeroException | Thrown when the specified value is zero.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Division Operator

[image]

Revit 2010 API
UV..::.Division Operator
UV Class See Also Send Feedback
Divides the specified 2-D vector by the specified value.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static UV operator /(
    UV left,
    double value
)
Visual Basic (Declaration)
Public Shared Operator / ( _
    left As UV, _
    value As Double _
) As UV
Visual C++
public:
static UV^ operator /(
    UV^ left,
    double value
)

Parameters

left
Type: Autodesk.Revit.Geometry..::.UV
The value to divide the vector by.
value
Type: System..::.Double
The vector to divide by the value.

Return Value

The divided 2-D vector.

Remarks

The divided vector is obtained by dividing each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when the specified value is an infinite number.
System..::.DivideByZeroException | Thrown when the specified value is zero.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Dot Method

[image]

Revit 2010 API
UV..::.Dot Method
UV Class See Also Send Feedback
The dot product of this 2-D vector and the specified 2-D vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Dot(
    UV source
)
Visual Basic (Declaration)
Public Function Dot ( _
    source As UV _
) As Double
Visual C++
public:
double Dot(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.UV
The vector to multiply with this vector.

Return Value

The real number equal to the dot product.

Remarks

The dot product is the sum of the respective coordinates of the two vectors: Pu*Pu + Rv*Rv.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Multiply Method

[image] [image]

Revit 2010 API
UV..::.Multiply Method
UV Class See Also Send Feedback
The product of the specified number and the specified 2-D vector.

Overload List

Name | Description
Multiply(UV, Double) | The product of the specified number and the specified 2-D vector.
Multiply(Double, UV) | The product of the specified number and the specified 2-D vector.

See Also

UV Class
UV Members
Autodesk.Revit.Geometry Namespace


Multiply Operator

[image]

Revit 2010 API
UV..::.Multiply Operator
UV Class See Also Send Feedback
The product of the specified number and the specified 2-D vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static UV operator *(
    UV left,
    double value
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    left As UV, _
    value As Double _
) As UV
Visual C++
public:
static UV^ operator *(
    UV^ left,
    double value
)

Parameters

left
Type: Autodesk.Revit.Geometry..::.UV
The vector to multiply with the value.
value
Type: System..::.Double
The value to multiply with the specified vector.

Return Value

The multiplied 2-D vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when the specified value is an infinite number.

See Also

UV Class
Multiply Overload
Autodesk.Revit.Geometry Namespace


Multiply Operator

[image]

Revit 2010 API
UV..::.Multiply Operator
UV Class See Also Send Feedback
The product of the specified number and the specified 2-D vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static UV operator *(
    double value,
    UV right
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    value As Double, _
    right As UV _
) As UV
Visual C++
public:
static UV^ operator *(
    double value,
    UV^ right
)

Parameters

value
Type: System..::.Double
The value to multiply with the specified vector.
right
Type: Autodesk.Revit.Geometry..::.UV
The vector to multiply with the value.

Return Value

The multiplied 2-D vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when the specified value is an infinite number.

See Also

UV Class
Multiply Overload
Autodesk.Revit.Geometry Namespace


Multiply Method

[image]

Revit 2010 API
UV..::.Multiply Method
UV Class See Also Send Feedback
Multiplies this 2-D vector by the specified value and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV Multiply(
    double value
)
Visual Basic (Declaration)
Public Function Multiply ( _
    value As Double _
) As UV
Visual C++
public:
UV^ Multiply(
    double value
)

Parameters

value
Type: System..::.Double
The value to multiply with this vector.

Return Value

The multiplied 2-D vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of this vector by the specified value.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when the specified value is an infinite number.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Negate Method

[image]

Revit 2010 API
UV..::.Negate Method
UV Class See Also Send Feedback
Negates this 2-D vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV Negate()
Visual Basic (Declaration)
Public Function Negate As UV
Visual C++
public:
UV^ Negate()

Return Value

The 2-D vector opposite to this vector.

Remarks

The negated vector is obtained by changing the sign of each coordinate of this vector.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Subtract Method

[image]

Revit 2010 API
UV..::.Subtract Method
UV Class See Also Send Feedback
Subtracts the specified 2-D vector from this 2-D vector and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV Subtract(
    UV source
)
Visual Basic (Declaration)
Public Function Subtract ( _
    source As UV _
) As UV
Visual C++
public:
UV^ Subtract(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.UV
The vector to subtract from this vector.

Return Value

The 2-D vector equal to the difference between the two vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the specified vector from the corresponding coordinate of this vector.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Subtraction Operator

[image]

Revit 2010 API
UV..::.Subtraction Operator
UV Class See Also Send Feedback
Subtracts the two specified 2-D vectors and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static UV operator -(
    UV left,
    UV right
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    left As UV, _
    right As UV _
) As UV
Visual C++
public:
static UV^ operator -(
    UV^ left,
    UV^ right
)

Parameters

left
Type: Autodesk.Revit.Geometry..::.UV
The first vector.
right
Type: Autodesk.Revit.Geometry..::.UV
The second vector.

Return Value

The 2-D vector equal to the difference between the two source vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the right vector from the corresponding coordinate of the left vector.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


UnaryNegation Operator

[image]

Revit 2010 API
UV..::.UnaryNegation Operator
UV Class See Also Send Feedback
Negates this 2-D vector and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static UV operator -(
    UV source
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    source As UV _
) As UV
Visual C++
public:
static UV^ operator -(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.UV

Return Value

The 2-D vector opposite to this vector.

Remarks

The negated vector is obtained by changing the sign of each coordinate of the specified vector.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


UV Properties

[image] [image]

Revit 2010 API
UV Properties
UV Class See Also Send Feedback

The UV type exposes the following members.

Properties

Name | Description
Basis | Indexed access for Basis.
BasisU | The basic of the U axis.
BasisV | The basic of the V axis.
IsNormalized | The boolean value that indicates whether this 2-D vector is a normalized vector.
IsZero | The boolean value that indicates whether this 2-D vector is a zero vector.
Item | Indexed access to coordinates.
Length | The length of this 2-D vector.
Normalized | This 2-D vector, normalized.
U | The first coordinate.
V | The second coordinate.
Zero | The coordinate origin or zero 2-D vector.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Basis Property

[image]

Revit 2010 API
UV..::.Basis Property
UV Class See Also Send Feedback
Indexed access for Basis.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static UV Basis[
    int idx
] { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Basis ( _
    idx As Integer _
) As UV
Visual C++
public:
static property UV^ Basis[int idx] {
    UV^ get (int idx);
}

Parameters

idx
Type: System..::.Int32
Use 0 for U, 1 for V.

Exceptions

Exception | Condition
System..::.IndexOutOfRangeException | Thrown when an attempt is made to access an element of the Basis array with an index that is outside the bounds of the array.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


BasisU Property

[image]

Revit 2010 API
UV..::.BasisU Property
UV Class See Also Send Feedback
The basic of the U axis.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static UV BasisU { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BasisU As UV
Visual C++
public:
static property UV^ BasisU {
    UV^ get ();
}

Remarks

The basis of the U axis is the vector (1,0), the unit vector on the U axis.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


BasisV Property

[image]

Revit 2010 API
UV..::.BasisV Property
UV Class See Also Send Feedback
The basic of the V axis.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static UV BasisV { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BasisV As UV
Visual C++
public:
static property UV^ BasisV {
    UV^ get ();
}

Remarks

The basis of the V axis is the vector (0,1), the unit vector on the V axis.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


IsNormalized Property

[image]

Revit 2010 API
UV..::.IsNormalized Property
UV Class See Also Send Feedback
The boolean value that indicates whether this 2-D vector is a normalized vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsNormalized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsNormalized As Boolean
Visual C++
public:
property bool IsNormalized {
    bool get ();
}

Remarks

Normalized vector's length equals one within the tolerance (1.0e-09), in other words, that this is a unit vector.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


IsZero Property

[image]

Revit 2010 API
UV..::.IsZero Property
UV Class See Also Send Feedback
The boolean value that indicates whether this 2-D vector is a zero vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsZero { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsZero As Boolean
Visual C++
public:
property bool IsZero {
    bool get ();
}

Remarks

The zero vector's each component is zero within the tolerance (1.0e-09).

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Item Property

[image]

Revit 2010 API
UV..::.Item Property
UV Class See Also Send Feedback
Indexed access to coordinates.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double this[
    int idx
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    idx As Integer _
) As Double
Visual C++
public:
property double default[int idx] {
    double get (int idx);
    void set (int idx, double value);
}

Parameters

idx
Type: System..::.Int32
Use 0 for U and 1 for V.

Exceptions

Exception | Condition
System..::.IndexOutOfRangeException | Thrown when an attempt is made to access coordinates with an index that is larger than 1.
System..::.NotFiniteNumberException | Thrown when setting an infinite number to the U or V property.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Length Property

[image]

Revit 2010 API
UV..::.Length Property
UV Class See Also Send Feedback
The length of this 2-D vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Double
Visual C++
public:
property double Length {
    double get ();
}

Remarks

In 2-D Euclidean space, the length of the vector is the square root of the sum of the two coordinates squared.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Normalized Property

[image]

Revit 2010 API
UV..::.Normalized Property
UV Class See Also Send Feedback
This 2-D vector, normalized.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV Normalized { get; }
Visual Basic (Declaration)
Public ReadOnly Property Normalized As UV
Visual C++
public:
property UV^ Normalized {
    UV^ get ();
}

Remarks

Normalized indicates that the length of this vector equals one, in other words, that this is a unit vector.

Exceptions

Exception | Condition
System..::.DivideByZeroException | Thrown when the length of current vector is zero.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


U Property

[image]

Revit 2010 API
UV..::.U Property
UV Class See Also Send Feedback
The first coordinate.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double U { get; set; }
Visual Basic (Declaration)
Public Property U As Double
Visual C++
public:
property double U {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when setting an infinite number to the U property.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


V Property

[image]

Revit 2010 API
UV..::.V Property
UV Class See Also Send Feedback
The second coordinate.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double V { get; set; }
Visual Basic (Declaration)
Public Property V As Double
Visual C++
public:
property double V {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when setting an infinite number to the V property.

See Also

UV Class
Autodesk.Revit.Geometry Namespace


Zero Property

[image]

Revit 2010 API
UV..::.Zero Property
UV Class See Also Send Feedback
The coordinate origin or zero 2-D vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static UV Zero { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Zero As UV
Visual C++
public:
static property UV^ Zero {
    UV^ get ();
}

Remarks

The zero vector is (0,0).

See Also

UV Class
Autodesk.Revit.Geometry Namespace


UVArray Class

[image]

Revit 2010 API
UVArray Class
Members See Also Send Feedback
An array that contains UV coordinates.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class UVArray : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class UVArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class UVArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.UVArray

See Also

UVArray Members
Autodesk.Revit.Geometry Namespace


UVArray Members

[image] [image]

Revit 2010 API
UVArray Members
UVArray Class Constructors Methods Properties See Also Send Feedback

The UVArray type exposes the following members.

Constructors

Name | Description
UVArray | Initializes a new instance of the UVArray class

Methods

Name | Description
Append |
Clear | Removes every UV coordinate from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a UV coordinate at a specified index within the array.
Size | Returns the number of UV coordinates that are in the array.

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


UVArray Constructor

[image]

Revit 2010 API
UVArray Constructor
UVArray Class See Also Send Feedback
Initializes a new instance of the UVArray class

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UVArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UVArray()

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


UVArray Methods

[image] [image]

Revit 2010 API
UVArray Methods
UVArray Class See Also Send Feedback

The UVArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every UV coordinate from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


Append Method

[image]

Revit 2010 API
UVArray..::.Append Method
UVArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    UV item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As UV _
)
Visual C++
public:
virtual void Append(
    UV^ item
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.UV

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

[image]

Revit 2010 API
UVArray..::.Clear Method
UVArray Class See Also Send Feedback
Removes every UV coordinate from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

[image]

Revit 2010 API
UVArray..::.ForwardIterator Method
UVArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual UVArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As UVArrayIterator
Visual C++
public:
virtual UVArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

[image]

Revit 2010 API
UVArray..::.GetEnumerator Method
UVArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

[image]

Revit 2010 API
UVArray..::.Insert Method
UVArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    UV item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As UV, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    UV^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.UV
index
Type: System..::.Int32

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

[image]

Revit 2010 API
UVArray..::.ReverseIterator Method
UVArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual UVArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As UVArrayIterator
Visual C++
public:
virtual UVArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


UVArray Properties

[image] [image]

Revit 2010 API
UVArray Properties
UVArray Class See Also Send Feedback

The UVArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a UV coordinate at a specified index within the array.
Size | Returns the number of UV coordinates that are in the array.

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


IsEmpty Property

[image]

Revit 2010 API
UVArray..::.IsEmpty Property
UVArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


Item Property

[image]

Revit 2010 API
UVArray..::.Item Property
UVArray Class See Also Send Feedback
Gets or sets a UV coordinate at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual UV Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As UV
Visual C++
public:
virtual property UV^ Item[int index] {
    UV^ get (int index);
    void set (int index, UV^ value);
}

Parameters

index
Type: System..::.Int32
The index of the UV coordinate to be set or retrieved.

Return Value

Returns the UV coordinate at the specified index.

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


Size Property

[image]

Revit 2010 API
UVArray..::.Size Property
UVArray Class See Also Send Feedback
Returns the number of UV coordinates that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace


UVArrayIterator Class

[image]

Revit 2010 API
UVArrayIterator Class
Members See Also Send Feedback
An iterator to an array of UV coordinates.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class UVArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class UVArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class UVArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.UVArrayIterator

See Also

UVArrayIterator Members
Autodesk.Revit.Geometry Namespace


UVArrayIterator Members

[image] [image]

Revit 2010 API
UVArrayIterator Members
UVArrayIterator Class Constructors Methods Properties See Also Send Feedback

The UVArrayIterator type exposes the following members.

Constructors

Name | Description
UVArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

UVArrayIterator Class
Autodesk.Revit.Geometry Namespace


UVArrayIterator Constructor

[image]

Revit 2010 API
UVArrayIterator Constructor
UVArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UVArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UVArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

UVArrayIterator Class
Autodesk.Revit.Geometry Namespace


UVArrayIterator Methods

[image] [image]

Revit 2010 API
UVArrayIterator Methods
UVArrayIterator Class See Also Send Feedback

The UVArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UVArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

[image]

Revit 2010 API
UVArrayIterator..::.MoveNext Method
UVArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

UVArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

[image]

Revit 2010 API
UVArrayIterator..::.Reset Method
UVArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

UVArrayIterator Class
Autodesk.Revit.Geometry Namespace


UVArrayIterator Properties

[image] [image]

Revit 2010 API
UVArrayIterator Properties
UVArrayIterator Class See Also Send Feedback

The UVArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

UVArrayIterator Class
Autodesk.Revit.Geometry Namespace


Current Property

[image]

Revit 2010 API
UVArrayIterator..::.Current Property
UVArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

UVArrayIterator Class
Autodesk.Revit.Geometry Namespace


Visibility Enumeration

[image]

Revit 2010 API
Visibility Enumeration
See Also Send Feedback
Describes the visibility of a particular geometry object.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum Visibility
Visual Basic (Declaration)
Public Enumeration Visibility
Visual C++
public enum class Visibility

Members

Member name | Description
Invisible | The geometry object is never visible. This type of geometry is never returned by Geometry[([(Options])]) but may be obtained by other API operations.
Contextual | The geometry object is visible in some contexts, but not in others. This type of geometry is always returned by Geometry[([(Options])]), even when Revit is in a context where the geometry should not be visible, but only if IncludeNonVisibleObjects is true. Examples of geometry of this class include Solids representing insulation and lining for MEP ducts and pipes.
Highlight | The geometry object is visible, but is affected by highlight or prehighlight special coloration. This type of geometry is returned by Geometry[([(Options])]) if IncludeNonVisibleObjects is true.
Visible | The geometry object is always visible. This type of geometry is always returned by Geometry[([(Options])])

See Also

Autodesk.Revit.Geometry Namespace


XYZ Class

[image]

Revit 2010 API
XYZ Class
Members See Also Send Feedback
Object representing coordinates in 3-space.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class XYZ
Visual Basic (Declaration)
Public Class XYZ
Visual C++
public ref class XYZ

Remarks

Usually this means a point or a vector in space, depending on the actual use.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Geometry..::.XYZ

See Also

XYZ Members
Autodesk.Revit.Geometry Namespace


XYZ Members

[image] [image]

Revit 2010 API
XYZ Members
XYZ Class Constructors Methods Properties See Also Send Feedback

The XYZ type exposes the following members.

Constructors

Name | Description
XYZ | Overloaded.

Methods

Name | Description
Add | Adds the specified vector to this vector and returns the result.
AlmostEqual | Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).
Angle | Returns the angle between this vector and the specified vector.
AngleAround | Returns the angle between this vector and the specified vector projected to the specified plane.
Cross | The cross product of this vector and the specified vector.
Distance | Returns the distance from this point to the specified point.
Divide | Divides this vector by the specified value and returns the result.
Dot | The dot product of this vector and the specified vector.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Multiply | Multiplies this vector by the specified value and returns the result.
Negate | Negates this vector.
Subtract | Subtracts the specified vector from this vector and returns the result.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TripleProduct | The triple product of this vector and the two specified vectors.

Operators

Name | Description
Addition | Adds the two specified vectors and returns the result.
Division | Divides the specified vector by the specified value.
Multiply | Overloaded. Multiplies the specified number and the specified vector.
Subtraction | Subtracts the two specified vectors and returns the result.
UnaryNegation | Negates the specified vector and returns the result.

Properties

Name | Description
Basis | Indexed access for Basis.
BasisX | The basis of the X axis.
BasisY | The basis of the Y axis.
BasisZ | The basis of the Z axis.
IsNormalized | The boolean value that indicates whether this vector is a normalized vector.
IsZero | The boolean value that indicates whether this vector is a zero vector.
Item | Indexed access to coordinates.
Length | The length of this vector.
Normalized | This vector, normalized.
X | The first coordinate.
Y | The second coordinate.
Z | The third coordinate.
Zero | The coordinate origin or zero vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


XYZ Constructor

[image] [image]

Revit 2010 API
XYZ Constructor
XYZ Class See Also Send Feedback

Overload List

Name | Description
XYZ()()() | default constructor
XYZ(XYZ) | Creates object with supplied XYZ object.
XYZ(Double, Double, Double) | Creates object with supplied values.

See Also

XYZ Class
XYZ Members
Autodesk.Revit.Geometry Namespace


XYZ Constructor

[image]

Revit 2010 API
XYZ Constructor
XYZ Class See Also Send Feedback
default constructor

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XYZ()

See Also

XYZ Class
XYZ Overload
Autodesk.Revit.Geometry Namespace


XYZ Constructor (XYZ)

[image]

Revit 2010 API
XYZ Constructor (XYZ)
XYZ Class See Also Send Feedback
Creates object with supplied XYZ object.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ(
    XYZ xyz
)
Visual Basic (Declaration)
Public Sub New ( _
    xyz As XYZ _
)
Visual C++
public:
XYZ(
    XYZ^ xyz
)

Parameters

xyz
Type: Autodesk.Revit.Geometry..::.XYZ
The supplied object

See Also

XYZ Class
XYZ Overload
Autodesk.Revit.Geometry Namespace


XYZ Constructor (Double, Double, Double)

[image]

Revit 2010 API
XYZ Constructor (Double, Double, Double)
XYZ Class See Also Send Feedback
Creates object with supplied values.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ(
    double x,
    double y,
    double z
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Double, _
    y As Double, _
    z As Double _
)
Visual C++
public:
XYZ(
    double x,
    double y,
    double z
)

Parameters

x
Type: System..::.Double
The first coordinate.
y
Type: System..::.Double
The second coordinate.
z
Type: System..::.Double
The third coordinate.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when setting an infinite number to the X, Y or Z property.

See Also

XYZ Class
XYZ Overload
Autodesk.Revit.Geometry Namespace


XYZ Methods

[image] [image]

Revit 2010 API
XYZ Methods
XYZ Class See Also Send Feedback

The XYZ type exposes the following members.

Methods

Name | Description
Add | Adds the specified vector to this vector and returns the result.
AlmostEqual | Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).
Angle | Returns the angle between this vector and the specified vector.
AngleAround | Returns the angle between this vector and the specified vector projected to the specified plane.
Cross | The cross product of this vector and the specified vector.
Distance | Returns the distance from this point to the specified point.
Divide | Divides this vector by the specified value and returns the result.
Dot | The dot product of this vector and the specified vector.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Multiply | Multiplies this vector by the specified value and returns the result.
Negate | Negates this vector.
Subtract | Subtracts the specified vector from this vector and returns the result.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TripleProduct | The triple product of this vector and the two specified vectors.

Operators

Name | Description
Addition | Adds the two specified vectors and returns the result.
Division | Divides the specified vector by the specified value.
Multiply | Overloaded. Multiplies the specified number and the specified vector.
Subtraction | Subtracts the two specified vectors and returns the result.
UnaryNegation | Negates the specified vector and returns the result.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Add Method

[image]

Revit 2010 API
XYZ..::.Add Method
XYZ Class See Also Send Feedback
Adds the specified vector to this vector and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Add(
    XYZ source
)
Visual Basic (Declaration)
Public Function Add ( _
    source As XYZ _
) As XYZ
Visual C++
public:
XYZ^ Add(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to add to this vector.

Return Value

The vector equal to the sum of the two vectors.

Remarks

The added vector is obtained by adding each coordinate of the specified vector to the corresponding coordinate of this vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Addition Operator

[image]

Revit 2010 API
XYZ..::.Addition Operator
XYZ Class See Also Send Feedback
Adds the two specified vectors and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static XYZ operator +(
    XYZ left,
    XYZ right
)
Visual Basic (Declaration)
Public Shared Operator + ( _
    left As XYZ, _
    right As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator +(
    XYZ^ left,
    XYZ^ right
)

Parameters

left
Type: Autodesk.Revit.Geometry..::.XYZ
The first vector.
right
Type: Autodesk.Revit.Geometry..::.XYZ
The second vector.

Return Value

The vector equal to the sum of the two source vectors.

Remarks

The added vector is obtained by adding each coordinate of the right vector to the corresponding coordinate of the left vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


AlmostEqual Method

[image]

Revit 2010 API
XYZ..::.AlmostEqual Method
XYZ Class See Also Send Feedback
Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool AlmostEqual(
    XYZ source
)
Visual Basic (Declaration)
Public Function AlmostEqual ( _
    source As XYZ _
) As Boolean
Visual C++
public:
bool AlmostEqual(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to compare with this vector.

Return Value

True if the vectors are the same; otherwise, false.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Angle Method

[image]

Revit 2010 API
XYZ..::.Angle Method
XYZ Class See Also Send Feedback
Returns the angle between this vector and the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Angle(
    XYZ source
)
Visual Basic (Declaration)
Public Function Angle ( _
    source As XYZ _
) As Double
Visual C++
public:
double Angle(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.XYZ
The specified vector.

Return Value

The real number between 0 and PI equal to the angle between the two vectors.

Remarks

The angle between the two vectors is measured in the plane spanned by them.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


AngleAround Method

[image]

Revit 2010 API
XYZ..::.AngleAround Method
XYZ Class See Also Send Feedback
Returns the angle between this vector and the specified vector projected to the specified plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double AngleAround(
    XYZ right,
    XYZ norm
)
Visual Basic (Declaration)
Public Function AngleAround ( _
    right As XYZ, _
    norm As XYZ _
) As Double
Visual C++
public:
double AngleAround(
    XYZ^ right,
    XYZ^ norm
)

Parameters

right
Type: Autodesk.Revit.Geometry..::.XYZ
The specified vector.
norm
Type: Autodesk.Revit.Geometry..::.XYZ
The normal vector that defines the plane.

Return Value

The real number between 0 and 2*PI equal to the projected angle between the two vectors.

Remarks

The angle is projected onto the plane orthogonal to the specified normal vector, counterclockwise with the normal pointing upwards.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Cross Method

[image]

Revit 2010 API
XYZ..::.Cross Method
XYZ Class See Also Send Feedback
The cross product of this vector and the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Cross(
    XYZ source
)
Visual Basic (Declaration)
Public Function Cross ( _
    source As XYZ _
) As XYZ
Visual C++
public:
XYZ^ Cross(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to multiply with this vector.

Return Value

The vector equal to the cross product.

Remarks

The cross product is defined as the vector which is perpendicular to both vectors with a magnitude equal to the area of the parallelogram they span. Also known as vector product or outer product.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Distance Method

[image]

Revit 2010 API
XYZ..::.Distance Method
XYZ Class See Also Send Feedback
Returns the distance from this point to the specified point.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Distance(
    XYZ source
)
Visual Basic (Declaration)
Public Function Distance ( _
    source As XYZ _
) As Double
Visual C++
public:
double Distance(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.XYZ
The specified point.

Return Value

The real number equal to the distance between the two points.

Remarks

The distance between the two points is equal to the length of the vector that joins the two points.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Divide Method

[image]

Revit 2010 API
XYZ..::.Divide Method
XYZ Class See Also Send Feedback
Divides this vector by the specified value and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Divide(
    double value
)
Visual Basic (Declaration)
Public Function Divide ( _
    value As Double _
) As XYZ
Visual C++
public:
XYZ^ Divide(
    double value
)

Parameters

value
Type: System..::.Double
The value to divide this vector by.

Return Value

The divided vector.

Remarks

The divided vector is obtained by dividing each coordinate of this vector by the specified value.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when the specified value is an infinite number.
System..::.DivideByZeroException | Thrown when the specified value is zero.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Division Operator

[image]

Revit 2010 API
XYZ..::.Division Operator
XYZ Class See Also Send Feedback
Divides the specified vector by the specified value.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static XYZ operator /(
    XYZ left,
    double value
)
Visual Basic (Declaration)
Public Shared Operator / ( _
    left As XYZ, _
    value As Double _
) As XYZ
Visual C++
public:
static XYZ^ operator /(
    XYZ^ left,
    double value
)

Parameters

left
Type: Autodesk.Revit.Geometry..::.XYZ
The value to divide the vector by.
value
Type: System..::.Double
The vector to divide by the value.

Return Value

The divided vector.

Remarks

The divided vector is obtained by dividing each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when the specified value is an infinite number.
System..::.DivideByZeroException | Thrown when the specified value is zero.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Dot Method

[image]

Revit 2010 API
XYZ..::.Dot Method
XYZ Class See Also Send Feedback
The dot product of this vector and the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Dot(
    XYZ source
)
Visual Basic (Declaration)
Public Function Dot ( _
    source As XYZ _
) As Double
Visual C++
public:
double Dot(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to multiply with this vector.

Return Value

The real number equal to the dot product.

Remarks

The dot product is the sum of the respective coordinates of the two vectors: Vx*Wx + Vy*Wy + Vz*Wz. Also known as scalar product or inner product.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Multiply Method

[image] [image]

Revit 2010 API
XYZ..::.Multiply Method
XYZ Class See Also Send Feedback
Multiplies the specified number and the specified vector.

Overload List

Name | Description
Multiply(XYZ, Double) | Multiplies the specified number and the specified vector.
Multiply(Double, XYZ) | Multiplies the specified number and the specified vector.

See Also

XYZ Class
XYZ Members
Autodesk.Revit.Geometry Namespace


Multiply Operator

[image]

Revit 2010 API
XYZ..::.Multiply Operator
XYZ Class See Also Send Feedback
Multiplies the specified number and the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static XYZ operator *(
    XYZ left,
    double value
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    left As XYZ, _
    value As Double _
) As XYZ
Visual C++
public:
static XYZ^ operator *(
    XYZ^ left,
    double value
)

Parameters

left
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to multiply with the value.
value
Type: System..::.Double
The value to multiply with the specified vector.

Return Value

The multiplied vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when the specified value is an infinite number.

See Also

XYZ Class
Multiply Overload
Autodesk.Revit.Geometry Namespace


Multiply Operator

[image]

Revit 2010 API
XYZ..::.Multiply Operator
XYZ Class See Also Send Feedback
Multiplies the specified number and the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static XYZ operator *(
    double value,
    XYZ right
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    value As Double, _
    right As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator *(
    double value,
    XYZ^ right
)

Parameters

value
Type: System..::.Double
The value to multiply with the specified vector.
right
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to multiply with the value.

Return Value

The multiplied vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when the specified value is an infinite number.

See Also

XYZ Class
Multiply Overload
Autodesk.Revit.Geometry Namespace


Multiply Method

[image]

Revit 2010 API
XYZ..::.Multiply Method
XYZ Class See Also Send Feedback
Multiplies this vector by the specified value and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Multiply(
    double value
)
Visual Basic (Declaration)
Public Function Multiply ( _
    value As Double _
) As XYZ
Visual C++
public:
XYZ^ Multiply(
    double value
)

Parameters

value
Type: System..::.Double
The value to multiply with this vector.

Return Value

The multiplied vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of this vector by the specified value.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when the specified value is an infinite number.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Negate Method

[image]

Revit 2010 API
XYZ..::.Negate Method
XYZ Class See Also Send Feedback
Negates this vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Negate()
Visual Basic (Declaration)
Public Function Negate As XYZ
Visual C++
public:
XYZ^ Negate()

Return Value

The vector opposite to this vector.

Remarks

The negated vector is obtained by changing the sign of each coordinate of this vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Subtract Method

[image]

Revit 2010 API
XYZ..::.Subtract Method
XYZ Class See Also Send Feedback
Subtracts the specified vector from this vector and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Subtract(
    XYZ source
)
Visual Basic (Declaration)
Public Function Subtract ( _
    source As XYZ _
) As XYZ
Visual C++
public:
XYZ^ Subtract(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to subtract from this vector.

Return Value

The vector equal to the difference between the two vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the specified vector from the corresponding coordinate of this vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Subtraction Operator

[image]

Revit 2010 API
XYZ..::.Subtraction Operator
XYZ Class See Also Send Feedback
Subtracts the two specified vectors and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static XYZ operator -(
    XYZ left,
    XYZ right
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    left As XYZ, _
    right As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator -(
    XYZ^ left,
    XYZ^ right
)

Parameters

left
Type: Autodesk.Revit.Geometry..::.XYZ
The first vector.
right
Type: Autodesk.Revit.Geometry..::.XYZ
The second vector.

Return Value

The vector equal to the difference between the two source vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the right vector from the corresponding coordinate of the left vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


TripleProduct Method

[image]

Revit 2010 API
XYZ..::.TripleProduct Method
XYZ Class See Also Send Feedback
The triple product of this vector and the two specified vectors.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double TripleProduct(
    XYZ middle,
    XYZ right
)
Visual Basic (Declaration)
Public Function TripleProduct ( _
    middle As XYZ, _
    right As XYZ _
) As Double
Visual C++
public:
double TripleProduct(
    XYZ^ middle,
    XYZ^ right
)

Parameters

middle
Type: Autodesk.Revit.Geometry..::.XYZ
The second vector.
right
Type: Autodesk.Revit.Geometry..::.XYZ
The third vector.

Return Value

The real number equal to the triple product.

Remarks

The scalar triple product is defined as the dot product of one of the vectors with the cross product of the other two. Geometrically, this product is the (signed) volume of the parallelepiped formed by the three vectors given.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


UnaryNegation Operator

[image]

Revit 2010 API
XYZ..::.UnaryNegation Operator
XYZ Class See Also Send Feedback
Negates the specified vector and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static XYZ operator -(
    XYZ source
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    source As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator -(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.XYZ

Return Value

The vector opposite to the specified vector.

Remarks

The negated vector is obtained by changing the sign of each coordinate of the specified vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


XYZ Properties

[image] [image]

Revit 2010 API
XYZ Properties
XYZ Class See Also Send Feedback

The XYZ type exposes the following members.

Properties

Name | Description
Basis | Indexed access for Basis.
BasisX | The basis of the X axis.
BasisY | The basis of the Y axis.
BasisZ | The basis of the Z axis.
IsNormalized | The boolean value that indicates whether this vector is a normalized vector.
IsZero | The boolean value that indicates whether this vector is a zero vector.
Item | Indexed access to coordinates.
Length | The length of this vector.
Normalized | This vector, normalized.
X | The first coordinate.
Y | The second coordinate.
Z | The third coordinate.
Zero | The coordinate origin or zero vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Basis Property

[image]

Revit 2010 API
XYZ..::.Basis Property
XYZ Class See Also Send Feedback
Indexed access for Basis.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static XYZ Basis[
    int idx
] { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Basis ( _
    idx As Integer _
) As XYZ
Visual C++
public:
static property XYZ^ Basis[int idx] {
    XYZ^ get (int idx);
}

Parameters

idx
Type: System..::.Int32
Use 0 for X, 1 for Y and 2 for Z.

Exceptions

Exception | Condition
System..::.IndexOutOfRangeException | Thrown when an attempt is made to access an element of the Basis array with an index that is outside the bounds of the array.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


BasisX Property

[image]

Revit 2010 API
XYZ..::.BasisX Property
XYZ Class See Also Send Feedback
The basis of the X axis.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static XYZ BasisX { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BasisX As XYZ
Visual C++
public:
static property XYZ^ BasisX {
    XYZ^ get ();
}

Remarks

The basis of the X axis is the vector (1,0,0), the unit vector on the X axis.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


BasisY Property

[image]

Revit 2010 API
XYZ..::.BasisY Property
XYZ Class See Also Send Feedback
The basis of the Y axis.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static XYZ BasisY { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BasisY As XYZ
Visual C++
public:
static property XYZ^ BasisY {
    XYZ^ get ();
}

Remarks

The basis of the Y axis is the vector (0,1,0), the unit vector on the Y axis.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


BasisZ Property

[image]

Revit 2010 API
XYZ..::.BasisZ Property
XYZ Class See Also Send Feedback
The basis of the Z axis.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static XYZ BasisZ { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BasisZ As XYZ
Visual C++
public:
static property XYZ^ BasisZ {
    XYZ^ get ();
}

Remarks

The basis of the Z axis is the vector (0,0,1), the unit vector on the Z axis.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


IsNormalized Property

[image]

Revit 2010 API
XYZ..::.IsNormalized Property
XYZ Class See Also Send Feedback
The boolean value that indicates whether this vector is a normalized vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsNormalized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsNormalized As Boolean
Visual C++
public:
property bool IsNormalized {
    bool get ();
}

Remarks

Normalized vector's length equals one within the tolerance (1.0e-09), in other words, that this is a unit vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


IsZero Property

[image]

Revit 2010 API
XYZ..::.IsZero Property
XYZ Class See Also Send Feedback
The boolean value that indicates whether this vector is a zero vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsZero { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsZero As Boolean
Visual C++
public:
property bool IsZero {
    bool get ();
}

Remarks

The zero vector's each component is zero within the tolerance (1.0e-09).

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Item Property

[image]

Revit 2010 API
XYZ..::.Item Property
XYZ Class See Also Send Feedback
Indexed access to coordinates.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double this[
    int idx
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    idx As Integer _
) As Double
Visual C++
public:
property double default[int idx] {
    double get (int idx);
    void set (int idx, double value);
}

Parameters

idx
Type: System..::.Int32
Use 0 for X, 1 for Y and 2 for Z.

Exceptions

Exception | Condition
System..::.IndexOutOfRangeException | Thrown when an attempt is made to access the coordinate with an index that is larger than 2.
System..::.NotFiniteNumberException | Thrown when setting an infinite number to the X, Y or Z property.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Length Property

[image]

Revit 2010 API
XYZ..::.Length Property
XYZ Class See Also Send Feedback
The length of this vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Double
Visual C++
public:
property double Length {
    double get ();
}

Remarks

In 3-D Euclidean space, the length of the vector is the square root of the sum of the three coordinates squared.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Normalized Property

[image]

Revit 2010 API
XYZ..::.Normalized Property
XYZ Class See Also Send Feedback
This vector, normalized.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Normalized { get; }
Visual Basic (Declaration)
Public ReadOnly Property Normalized As XYZ
Visual C++
public:
property XYZ^ Normalized {
    XYZ^ get ();
}

Remarks

Normalized indicates that the length of this vector equals one, in other words, that this is a unit vector.

Exceptions

Exception | Condition
System..::.DivideByZeroException | Thrown when the length of this vector is zero.
System..::.InvalidOperationException | Thrown when an error occurs in normalization.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


X Property

[image]

Revit 2010 API
XYZ..::.X Property
XYZ Class See Also Send Feedback
The first coordinate.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double X { get; set; }
Visual Basic (Declaration)
Public Property X As Double
Visual C++
public:
property double X {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when setting an infinite number to the X property.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Y Property

[image]

Revit 2010 API
XYZ..::.Y Property
XYZ Class See Also Send Feedback
The second coordinate.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Double
Visual C++
public:
property double Y {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when setting an infinite number to the Y property.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Z Property

[image]

Revit 2010 API
XYZ..::.Z Property
XYZ Class See Also Send Feedback
The third coordinate.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Z { get; set; }
Visual Basic (Declaration)
Public Property Z As Double
Visual C++
public:
property double Z {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when setting an infinite number to the Z property.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


Zero Property

[image]

Revit 2010 API
XYZ..::.Zero Property
XYZ Class See Also Send Feedback
The coordinate origin or zero vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static XYZ Zero { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Zero As XYZ
Visual C++
public:
static property XYZ^ Zero {
    XYZ^ get ();
}

Remarks

The zero vector is (0,0,0).

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace


XYZArray Class

[image]

Revit 2010 API
XYZArray Class
Members See Also Send Feedback
An array that contains XYZ coordinates.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class XYZArray : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class XYZArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class XYZArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.XYZArray

See Also

XYZArray Members
Autodesk.Revit.Geometry Namespace


XYZArray Members

[image] [image]

Revit 2010 API
XYZArray Members
XYZArray Class Constructors Methods Properties See Also Send Feedback

The XYZArray type exposes the following members.

Constructors

Name | Description
XYZArray | Initializes a new instance of the XYZArray class

Methods

Name | Description
Append |
Clear | Removes every XYZ coordinate from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a XYZ coordinate at a specified index within the array.
Size | Returns the number of XYZ coordinates that are in the array.

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


XYZArray Constructor

[image]

Revit 2010 API
XYZArray Constructor
XYZArray Class See Also Send Feedback
Initializes a new instance of the XYZArray class

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XYZArray()

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


XYZArray Methods

[image] [image]

Revit 2010 API
XYZArray Methods
XYZArray Class See Also Send Feedback

The XYZArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every XYZ coordinate from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


Append Method

[image]

Revit 2010 API
XYZArray..::.Append Method
XYZArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    XYZ item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As XYZ _
)
Visual C++
public:
virtual void Append(
    XYZ^ item
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.XYZ

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


Clear Method

[image]

Revit 2010 API
XYZArray..::.Clear Method
XYZArray Class See Also Send Feedback
Removes every XYZ coordinate from the array, rendering it empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


ForwardIterator Method

[image]

Revit 2010 API
XYZArray..::.ForwardIterator Method
XYZArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual XYZArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As XYZArrayIterator
Visual C++
public:
virtual XYZArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


GetEnumerator Method

[image]

Revit 2010 API
XYZArray..::.GetEnumerator Method
XYZArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


Insert Method

[image]

Revit 2010 API
XYZArray..::.Insert Method
XYZArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    XYZ item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As XYZ, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    XYZ^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.XYZ
index
Type: System..::.Int32

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


ReverseIterator Method

[image]

Revit 2010 API
XYZArray..::.ReverseIterator Method
XYZArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual XYZArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As XYZArrayIterator
Visual C++
public:
virtual XYZArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


XYZArray Properties

[image] [image]

Revit 2010 API
XYZArray Properties
XYZArray Class See Also Send Feedback

The XYZArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a XYZ coordinate at a specified index within the array.
Size | Returns the number of XYZ coordinates that are in the array.

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


IsEmpty Property

[image]

Revit 2010 API
XYZArray..::.IsEmpty Property
XYZArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


Item Property

[image]

Revit 2010 API
XYZArray..::.Item Property
XYZArray Class See Also Send Feedback
Gets or sets a XYZ coordinate at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual XYZ Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As XYZ
Visual C++
public:
virtual property XYZ^ Item[int index] {
    XYZ^ get (int index);
    void set (int index, XYZ^ value);
}

Parameters

index
Type: System..::.Int32
The index of the XYZ coordinate to be set or retrieved.

Return Value

Returns the XYZ coordinate at the specified index.

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


Size Property

[image]

Revit 2010 API
XYZArray..::.Size Property
XYZArray Class See Also Send Feedback
Returns the number of XYZ coordinates that are in the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace


XYZArrayIterator Class

[image]

Revit 2010 API
XYZArrayIterator Class
Members See Also Send Feedback
An iterator to an array of XYZ coordinates.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class XYZArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class XYZArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class XYZArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.XYZArrayIterator

See Also

XYZArrayIterator Members
Autodesk.Revit.Geometry Namespace


XYZArrayIterator Members

[image] [image]

Revit 2010 API
XYZArrayIterator Members
XYZArrayIterator Class Constructors Methods Properties See Also Send Feedback

The XYZArrayIterator type exposes the following members.

Constructors

Name | Description
XYZArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

XYZArrayIterator Class
Autodesk.Revit.Geometry Namespace


XYZArrayIterator Constructor

[image]

Revit 2010 API
XYZArrayIterator Constructor
XYZArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XYZArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

XYZArrayIterator Class
Autodesk.Revit.Geometry Namespace


XYZArrayIterator Methods

[image] [image]

Revit 2010 API
XYZArrayIterator Methods
XYZArrayIterator Class See Also Send Feedback

The XYZArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XYZArrayIterator Class
Autodesk.Revit.Geometry Namespace


MoveNext Method

[image]

Revit 2010 API
XYZArrayIterator..::.MoveNext Method
XYZArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

XYZArrayIterator Class
Autodesk.Revit.Geometry Namespace


Reset Method

[image]

Revit 2010 API
XYZArrayIterator..::.Reset Method
XYZArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

XYZArrayIterator Class
Autodesk.Revit.Geometry Namespace


XYZArrayIterator Properties

[image] [image]

Revit 2010 API
XYZArrayIterator Properties
XYZArrayIterator Class See Also Send Feedback

The XYZArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

XYZArrayIterator Class
Autodesk.Revit.Geometry Namespace


Current Property

[image]

Revit 2010 API
XYZArrayIterator..::.Current Property
XYZArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

XYZArrayIterator Class
Autodesk.Revit.Geometry Namespace


Autodesk.Revit.MEP Namespace

[image]

Revit 2010 API
Autodesk.Revit.MEP Namespace
Send Feedback

Classes

Class | Description
ConduitType | Represents a specific conduit type of wire type.
ConduitTypeSet |
ConduitTypeSetIterator |
Connector | A connector in an Autodesk Revit MEP project document.
ConnectorManager | Provides access to the Connector Manager in Autodesk Revit MEP.
ConnectorSet | A set that can contain any type of object.
ConnectorSetIterator | An iterator to a set.
CorrectionFactor | Represents electrical correction factor information.
CorrectionFactorSet | A set that contains correction factors.
CorrectionFactorSetIterator | An iterator to a correction factor set.
DemandFactor | Represents a demand factor, which let you adjust the rating of the main service for a building based on the expectation that, at any given time, not all of the electrical equipment will not be drawing at its full rated load. You can specify one or more Demand Factors, applying different Demand Factors to Lighting, Power, HVAC, or Other systems in your project based on their load.
DemandFactorData | Represents demand factor definition in a specified range.
DemandFactorDataSet | A set that can contain any type of object.
DemandFactorDataSetIterator | An iterator to a set.
DistributionSysType | Represents a specific type of distribution system.
DistributionSysTypeSet |
DistributionSysTypeSetIterator |
Duct | A duct in the Autodesk Revit MEP product.
DuctConnector | A duct connector that is assigned to a mechanical equipment or duct fitting family. Provides access to the duct connector in Autodesk Revit MEP family document.
DuctType | A duct type in the Autodesk Revit MEP product.
ElectricalConnector | An electrical connector that is assigned to an electrical equipment or device family. Provides access to the electrical connector in Autodesk Revit MEP family document.
ElectricalEquipment | Provides access to the Electrical Equipment in Autodesk Revit MEP.
ElectricalSetting | An object that represents electrical information within the Autodesk Revit project.
ElectricalSystem | Provides access to the Electrical System in Autodesk Revit MEP.
ElectricalSystemSet |
ElectricalSystemSetIterator |
FlexDuct | A flex duct in the Autodesk Revit MEP product.
FlexDuctType | A flex duct type in the Autodesk Revit MEP product.
FlexPipe | A flex pipe in the Autodesk Revit MEP product.
FlexPipeType | A flex pipe type in the Autodesk Revit MEP product.
FluidType | A fluid type symbol in the Autodesk Revit MEP product.
GroundConductorSize | Represents electrical ground conductor size definition information.
GroundConductorSizeSet | A set that contains GroundConductorSizes.
GroundConductorSizeSetIterator | An iterator to a GroundConductorSize set.
InsulationType | Represents electrical insulation type definition information.
InsulationTypeSet |
InsulationTypeSetIterator |
LightingDevice | Provides access to the Lighting Device in Autodesk Revit MEP.
LightingFixture | Provides access to the Lighting Fixture in Autodesk Revit MEP.
MechanicalEquipment | Provides access to the Mechanical Equipment in Autodesk Revit MEP.
MechanicalFitting | A mechanical fitting in the Autodesk Revit MEP product.
MechanicalSystem | A mechanical system in the Autodesk Revit MEP product.
MEPCurve | A curve object for duct or pipe blend elements.
MEPCurveType | A curve type for duct type or pipe type.
MEPModel | Supports all Analytical Models that are persistent within the Autodesk Revit project
MEPSystem | A system in the Autodesk Revit MEP product.
Pipe | A pipe in the Autodesk Revit MEP product.
PipeConnectionType | A pipe connection type in the Autodesk Revit MEP product.
PipeConnector | A pipe connector that is assigned to a mechanical equipment or pipe fitting family. Provides access to the pipe connector in Autodesk Revit MEP family document.
PipeMaterialType | A pipe material type in the Autodesk Revit MEP product.
PipeScheduleType | A pipe schedule type in the Autodesk Revit MEP product.
PipeType | A pipe type in the Autodesk Revit MEP product.
PipingSystem | A piping system in the Autodesk Revit MEP product.
TemperatureRatingType | Represents temperature rating type definition information.
TemperatureRatingTypeSet |
TemperatureRatingTypeSetIterator |
VoltageType | Represents electrical voltage type. An electrical voltage type define a range of voltages, and circuits can be created between components with rated voltages that do not precisely match the voltage definition value.
VoltageTypeSet |
VoltageTypeSetIterator |
Wire | An object to represent electrical wire in Revit MEP product.
WireMaterialType | Represents electrical wire material type definition information of wire type.
WireMaterialTypeSet |
WireMaterialTypeSetIterator |
WireSet |
WireSetIterator |
WireSize | Represents specific electrical wire size information.
WireSizeSet | A set that contains wire sizes.
WireSizeSetIterator | An iterator to a wire size set.
WireType | Represents a specific wire type.
WireTypeSet |
WireTypeSetIterator |

Interfaces

Interface | Description
IConnector | An interface which provides access to connector in Autodesk Revit MEP document.

Enumerations

Enumeration | Description
WireType..::.NeutralMode | An enumerate type to list the neutral mode for wire type.


ConduitType Class

[image]

Revit 2010 API
ConduitType Class
Members See Also Send Feedback
Represents a specific conduit type of wire type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ConduitType : Element
Visual Basic (Declaration)
Public Class ConduitType _
    Inherits Element
Visual C++
public ref class ConduitType : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.MEP..::.ConduitType

See Also

ConduitType Members
Autodesk.Revit.MEP Namespace


ConduitType Members

[image] [image]

Revit 2010 API
ConduitType Members
ConduitType Class Constructors Methods Properties See Also Send Feedback

The ConduitType type exposes the following members.

Constructors

Name | Description
ConduitType | Initializes a new instance of the ConduitType class

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get name of conduit type. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ConduitType Class
Autodesk.Revit.MEP Namespace


ConduitType Constructor

[image]

Revit 2010 API
ConduitType Constructor
ConduitType Class See Also Send Feedback
Initializes a new instance of the ConduitType class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ConduitType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConduitType()

See Also

ConduitType Class
Autodesk.Revit.MEP Namespace


ConduitType Methods

[image] [image]

Revit 2010 API
ConduitType Methods
ConduitType Class See Also Send Feedback

The ConduitType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConduitType Class
Autodesk.Revit.MEP Namespace


ConduitType Properties

[image] [image]

Revit 2010 API
ConduitType Properties
ConduitType Class See Also Send Feedback

The ConduitType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get name of conduit type. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ConduitType Class
Autodesk.Revit.MEP Namespace


Name Property

[image]

Revit 2010 API
ConduitType..::.Name Property
ConduitType Class See Also Send Feedback
Get name of conduit type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Exceptions

Exception | Condition
System..::.NotSupportedException | Set name can't be supported.

See Also

ConduitType Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
ConduitType..::.Parameter Property
ConduitType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ConduitType Class
ConduitType Members
Autodesk.Revit.MEP Namespace


ConduitTypeSet Class

[image]

Revit 2010 API
ConduitTypeSet Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ConduitTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ConduitTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ConduitTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.ConduitTypeSet

See Also

ConduitTypeSet Members
Autodesk.Revit.MEP Namespace


ConduitTypeSet Members

[image] [image]

Revit 2010 API
ConduitTypeSet Members
ConduitTypeSet Class Constructors Methods Properties See Also Send Feedback

The ConduitTypeSet type exposes the following members.

Constructors

Name | Description
ConduitTypeSet | Initializes a new instance of the ConduitTypeSet class

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

ConduitTypeSet Class
Autodesk.Revit.MEP Namespace


ConduitTypeSet Constructor

[image]

Revit 2010 API
ConduitTypeSet Constructor
ConduitTypeSet Class See Also Send Feedback
Initializes a new instance of the ConduitTypeSet class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ConduitTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConduitTypeSet()

See Also

ConduitTypeSet Class
Autodesk.Revit.MEP Namespace


ConduitTypeSet Methods

[image] [image]

Revit 2010 API
ConduitTypeSet Methods
ConduitTypeSet Class See Also Send Feedback

The ConduitTypeSet type exposes the following members.

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConduitTypeSet Class
Autodesk.Revit.MEP Namespace


Clear Method

[image]

Revit 2010 API
ConduitTypeSet..::.Clear Method
ConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ConduitTypeSet Class
Autodesk.Revit.MEP Namespace


Contains Method

[image]

Revit 2010 API
ConduitTypeSet..::.Contains Method
ConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    ConduitType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As ConduitType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    ConduitType^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.ConduitType

See Also

ConduitTypeSet Class
Autodesk.Revit.MEP Namespace


Erase Method

[image]

Revit 2010 API
ConduitTypeSet..::.Erase Method
ConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    ConduitType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As ConduitType _
) As Integer
Visual C++
public:
virtual int Erase(
    ConduitType^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.ConduitType

See Also

ConduitTypeSet Class
Autodesk.Revit.MEP Namespace


ForwardIterator Method

[image]

Revit 2010 API
ConduitTypeSet..::.ForwardIterator Method
ConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ConduitTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ConduitTypeSetIterator
Visual C++
public:
virtual ConduitTypeSetIterator^ ForwardIterator()

See Also

ConduitTypeSet Class
Autodesk.Revit.MEP Namespace


GetEnumerator Method

[image]

Revit 2010 API
ConduitTypeSet..::.GetEnumerator Method
ConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ConduitTypeSet Class
Autodesk.Revit.MEP Namespace


Insert Method

[image]

Revit 2010 API
ConduitTypeSet..::.Insert Method
ConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    ConduitType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As ConduitType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    ConduitType^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.ConduitType

See Also

ConduitTypeSet Class
Autodesk.Revit.MEP Namespace


ReverseIterator Method

[image]

Revit 2010 API
ConduitTypeSet..::.ReverseIterator Method
ConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ConduitTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ConduitTypeSetIterator
Visual C++
public:
virtual ConduitTypeSetIterator^ ReverseIterator()

See Also

ConduitTypeSet Class
Autodesk.Revit.MEP Namespace


ConduitTypeSet Properties

[image] [image]

Revit 2010 API
ConduitTypeSet Properties
ConduitTypeSet Class See Also Send Feedback

The ConduitTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

ConduitTypeSet Class
Autodesk.Revit.MEP Namespace


IsEmpty Property

[image]

Revit 2010 API
ConduitTypeSet..::.IsEmpty Property
ConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

ConduitTypeSet Class
Autodesk.Revit.MEP Namespace


Size Property

[image]

Revit 2010 API
ConduitTypeSet..::.Size Property
ConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ConduitTypeSet Class
Autodesk.Revit.MEP Namespace


ConduitTypeSetIterator Class

[image]

Revit 2010 API
ConduitTypeSetIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ConduitTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ConduitTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ConduitTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.ConduitTypeSetIterator

See Also

ConduitTypeSetIterator Members
Autodesk.Revit.MEP Namespace


ConduitTypeSetIterator Members

[image] [image]

Revit 2010 API
ConduitTypeSetIterator Members
ConduitTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The ConduitTypeSetIterator type exposes the following members.

Constructors

Name | Description
ConduitTypeSetIterator | Initializes a new instance of the ConduitTypeSetIterator class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ConduitTypeSetIterator Class
Autodesk.Revit.MEP Namespace


ConduitTypeSetIterator Constructor

[image]

Revit 2010 API
ConduitTypeSetIterator Constructor
ConduitTypeSetIterator Class See Also Send Feedback
Initializes a new instance of the ConduitTypeSetIterator class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ConduitTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConduitTypeSetIterator()

See Also

ConduitTypeSetIterator Class
Autodesk.Revit.MEP Namespace


ConduitTypeSetIterator Methods

[image] [image]

Revit 2010 API
ConduitTypeSetIterator Methods
ConduitTypeSetIterator Class See Also Send Feedback

The ConduitTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConduitTypeSetIterator Class
Autodesk.Revit.MEP Namespace


MoveNext Method

[image]

Revit 2010 API
ConduitTypeSetIterator..::.MoveNext Method
ConduitTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::.MoveNext()()()

See Also

ConduitTypeSetIterator Class
Autodesk.Revit.MEP Namespace


Reset Method

[image]

Revit 2010 API
ConduitTypeSetIterator..::.Reset Method
ConduitTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

See Also

ConduitTypeSetIterator Class
Autodesk.Revit.MEP Namespace


ConduitTypeSetIterator Properties

[image] [image]

Revit 2010 API
ConduitTypeSetIterator Properties
ConduitTypeSetIterator Class See Also Send Feedback

The ConduitTypeSetIterator type exposes the following members.

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ConduitTypeSetIterator Class
Autodesk.Revit.MEP Namespace


Current Property

[image]

Revit 2010 API
ConduitTypeSetIterator..::.Current Property
ConduitTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

See Also

ConduitTypeSetIterator Class
Autodesk.Revit.MEP Namespace


Connector Class

[image]

Revit 2010 API
Connector Class
Members See Also Send Feedback
A connector in an Autodesk Revit MEP project document.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Connector : APIObject, IConnector
Visual Basic (Declaration)
Public Class Connector _
    Inherits APIObject _
    Implements IConnector
Visual C++
public ref class Connector : public APIObject,
    IConnector

Remarks

This connector is an item that is a part of another element (duct, pipe, fitting, or equipment).
This connector does not represent the connector element that can be created inside a family;
 for that element,please refer to Revit::MEP::DuctConnector,
Revit::MEP::PipeConnector and Revit::MEP::ElectricalConnector.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.Connector

See Also

Connector Members
Autodesk.Revit.MEP Namespace


Connector Members

[image] [image]

Revit 2010 API
Connector Members
Connector Class Constructors Methods Properties See Also Send Feedback

The Connector type exposes the following members.

Constructors

Name | Description
Connector | For internal use only

Methods

Name | Description
ConnectTo | Make connection between two connectors.
DisconnectFrom | Remove connection between two connectors.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsConnectedTo | Identifies if the connector is connected to the specified connector.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllRefs | All references of the connector.
Angle | The angle of the Connector.
AssignedDuctFlowConfiguration | The assigned duct flow configuration of the connector.
AssignedDuctLossMethod | The duct loss method of the connector.
AssignedFixtureUnits | The assigned fixture units of the connector.
AssignedFlow | The assigned flow of the connector.
AssignedFlowDirection | The assigned flow direction of the connector.
AssignedFlowFactor | The assigned flow factor of this connector.
AssignedKCoefficient | The assigned kCoefficient of the connector.
AssignedLossCoefficient | The assigned loss coefficient of the connector.
AssignedPipeFlowConfiguration | The pipe flow configuration type of the connector.
AssignedPipeLossMethod | The pipe loss method of the connector.
AssignedPressureDrop | The assigned pressure drop of the connector.
Coefficient | The coefficient of the connector.
ConnectorManager | The connector manager of the connector.
ConnectorType | The connector type of the connector.
CoordinateSystem | The coordinate system of the connector.
Demand | The demand of the connector.
Direction | The direction of the connector.
Domain | The domain of the connector.
DuctSystemType | The duct system type of the connector.
ElectricalSystemType | The electrical system type of the connector.
Flow | The flow of the connector.
Height | The height of the connector.
IsConnected | Identifies if the connector is physically connected to a connector on another element.
IsMovable | whether the connector can be moved.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
MEPSystem | The system of the connector belong to.
Origin | The location of the connector.
Owner | The host of the connector.
PipeSystemType | The pipe system type of the connector.
PressureDrop | The pressure drop of the connector.
Radius | The radius of the connector.
Shape | The shape of the connector.
VelocityPressure | The velocity pressure of the connector.
Width | The width of the connector.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Connector Constructor

[image]

Revit 2010 API
Connector Constructor
Connector Class See Also Send Feedback
For internal use only

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Connector()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Connector()

Remarks

This constructor is exposed to enable support for COM interopability only. This object should not be created by the developer.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Connector Methods

[image] [image]

Revit 2010 API
Connector Methods
Connector Class See Also Send Feedback

The Connector type exposes the following members.

Methods

Name | Description
ConnectTo | Make connection between two connectors.
DisconnectFrom | Remove connection between two connectors.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsConnectedTo | Identifies if the connector is connected to the specified connector.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Connector Class
Autodesk.Revit.MEP Namespace


ConnectTo Method

[image]

Revit 2010 API
Connector..::.ConnectTo Method
Connector Class See Also Send Feedback
Make connection between two connectors.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ConnectTo(
    Connector connector
)
Visual Basic (Declaration)
Public Sub ConnectTo ( _
    connector As Connector _
)
Visual C++
public:
void ConnectTo(
    Connector^ connector
)

Parameters

connector
Type: Autodesk.Revit.MEP..::.Connector
Indicate the connector will be connected to.

Remarks

Connection success may create a new Fitting between two connectors, if necessary.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when argument is null.
System..::.ArgumentException | Argument is invalid.
System..::.InvalidOperationException | Thrown when two connectors with different domain types. Thrown when these two connectors fail to connect each other. Thrown when connection already exists.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


DisconnectFrom Method

[image]

Revit 2010 API
Connector..::.DisconnectFrom Method
Connector Class See Also Send Feedback
Remove connection between two connectors.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void DisconnectFrom(
    Connector connector
)
Visual Basic (Declaration)
Public Sub DisconnectFrom ( _
    connector As Connector _
)
Visual C++
public:
void DisconnectFrom(
    Connector^ connector
)

Parameters

connector
Type: Autodesk.Revit.MEP..::.Connector
Indicate the connector, connection will be removed from.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when argument is null.
System..::.ArgumentException | Argument is invalid.
System..::.InvalidOperationException | Thrown when no connection between these two connector. Thrown on failure to remove the connection between these two connectors.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


IsConnectedTo Method

[image]

Revit 2010 API
Connector..::.IsConnectedTo Method
Connector Class See Also Send Feedback
Identifies if the connector is connected to the specified connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsConnectedTo(
    Connector connector
)
Visual Basic (Declaration)
Public Function IsConnectedTo ( _
    connector As Connector _
) As Boolean
Visual C++
public:
bool IsConnectedTo(
    Connector^ connector
)

Parameters

connector
Type: Autodesk.Revit.MEP..::.Connector

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the argument is null.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Connector Properties

[image] [image]

Revit 2010 API
Connector Properties
Connector Class See Also Send Feedback

The Connector type exposes the following members.

Properties

Name | Description
AllRefs | All references of the connector.
Angle | The angle of the Connector.
AssignedDuctFlowConfiguration | The assigned duct flow configuration of the connector.
AssignedDuctLossMethod | The duct loss method of the connector.
AssignedFixtureUnits | The assigned fixture units of the connector.
AssignedFlow | The assigned flow of the connector.
AssignedFlowDirection | The assigned flow direction of the connector.
AssignedFlowFactor | The assigned flow factor of this connector.
AssignedKCoefficient | The assigned kCoefficient of the connector.
AssignedLossCoefficient | The assigned loss coefficient of the connector.
AssignedPipeFlowConfiguration | The pipe flow configuration type of the connector.
AssignedPipeLossMethod | The pipe loss method of the connector.
AssignedPressureDrop | The assigned pressure drop of the connector.
Coefficient | The coefficient of the connector.
ConnectorManager | The connector manager of the connector.
ConnectorType | The connector type of the connector.
CoordinateSystem | The coordinate system of the connector.
Demand | The demand of the connector.
Direction | The direction of the connector.
Domain | The domain of the connector.
DuctSystemType | The duct system type of the connector.
ElectricalSystemType | The electrical system type of the connector.
Flow | The flow of the connector.
Height | The height of the connector.
IsConnected | Identifies if the connector is physically connected to a connector on another element.
IsMovable | whether the connector can be moved.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
MEPSystem | The system of the connector belong to.
Origin | The location of the connector.
Owner | The host of the connector.
PipeSystemType | The pipe system type of the connector.
PressureDrop | The pressure drop of the connector.
Radius | The radius of the connector.
Shape | The shape of the connector.
VelocityPressure | The velocity pressure of the connector.
Width | The width of the connector.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


AllRefs Property

[image]

Revit 2010 API
Connector..::.AllRefs Property
Connector Class See Also Send Feedback
All references of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ConnectorSet AllRefs { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllRefs As ConnectorSet
Visual C++
public:
property ConnectorSet^ AllRefs {
    ConnectorSet^ get ();
}

Remarks

A set of connectors that the connectors is connected to, including both physical connection and logical connection.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Angle Property

[image]

Revit 2010 API
Connector..::.Angle Property
Connector Class See Also Send Feedback
The angle of the Connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Double
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

Remarks

Angle may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::PipeConnector and Autodesk::Revit::MEP::DuctConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainHvac or DomainPiping. Thrown when set value for the connector not in family instance.
System..::.ArgumentException | Thrown when set an invalid value.
System..::.InvalidOperationException | Thrown on failure to set angle.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


AssignedDuctFlowConfiguration Property

[image]

Revit 2010 API
Connector..::.AssignedDuctFlowConfiguration Property
Connector Class See Also Send Feedback
The assigned duct flow configuration of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DuctFlowConfigurationType AssignedDuctFlowConfiguration { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedDuctFlowConfiguration As DuctFlowConfigurationType
Visual C++
public:
property DuctFlowConfigurationType AssignedDuctFlowConfiguration {
    DuctFlowConfigurationType get ();
}

Remarks

Assigned duct flow configuration may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::DuctConnector.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainHvac. Thrown when the connector is not in a family instance.
System..::.InvalidOperationException | Thrown on failure to get duct flow configuration.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


AssignedDuctLossMethod Property

[image]

Revit 2010 API
Connector..::.AssignedDuctLossMethod Property
Connector Class See Also Send Feedback
The duct loss method of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DuctLossMethodType AssignedDuctLossMethod { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedDuctLossMethod As DuctLossMethodType
Visual C++
public:
property DuctLossMethodType AssignedDuctLossMethod {
    DuctLossMethodType get ();
}

Remarks

Assigned duct loss method may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::DuctConnector.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainHvac. Thrown when the connector is not in family instance.
System..::.InvalidOperationException | Thrown on failure to get duct loss method.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


AssignedFixtureUnits Property

[image]

Revit 2010 API
Connector..::.AssignedFixtureUnits Property
Connector Class See Also Send Feedback
The assigned fixture units of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double AssignedFixtureUnits { get; set; }
Visual Basic (Declaration)
Public Property AssignedFixtureUnits As Double
Visual C++
public:
property double AssignedFixtureUnits {
    double get ();
    void set (double value);
}

Remarks

Assigned fixture units may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::PipeConnector.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
System..::.ArgumentException | Thrown when set an invalid value.
System..::.InvalidOperationException | Thrown on failure to get or set assigned fixture units.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


AssignedFlow Property

[image]

Revit 2010 API
Connector..::.AssignedFlow Property
Connector Class See Also Send Feedback
The assigned flow of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double AssignedFlow { get; set; }
Visual Basic (Declaration)
Public Property AssignedFlow As Double
Visual C++
public:
property double AssignedFlow {
    double get ();
    void set (double value);
}

Remarks

Assigned flow may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::PipeConnector,Autodesk::Revit::MEP::DuctConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainPiping or DomainHvac. Thrown when the connector is not in a family instance.
System..::.ArgumentException | Thrown when set an invalid value.
System..::.InvalidOperationException | Thrown on failure to get or set assigned flow.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


AssignedFlowDirection Property

[image]

Revit 2010 API
Connector..::.AssignedFlowDirection Property
Connector Class See Also Send Feedback
The assigned flow direction of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlowDirectionType AssignedFlowDirection { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedFlowDirection As FlowDirectionType
Visual C++
public:
property FlowDirectionType AssignedFlowDirection {
    FlowDirectionType get ();
}

Remarks

Flow direction may be assigned for connectors of some familiy instances. For more information, seeAutodesk::Revit::MEP::DuctConnector, Autodesk::Revit::MEP::PipeConnector.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector is not in a family instance. Thrown when the connector's domain is not DomainHvac or DomainPiping.
System..::.InvalidOperationException | Thrown on failure to get assigned flow direction.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


AssignedFlowFactor Property

[image]

Revit 2010 API
Connector..::.AssignedFlowFactor Property
Connector Class See Also Send Feedback
The assigned flow factor of this connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double AssignedFlowFactor { get; set; }
Visual Basic (Declaration)
Public Property AssignedFlowFactor As Double
Visual C++
public:
property double AssignedFlowFactor {
    double get ();
    void set (double value);
}

Remarks

Assigned flow factor may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::DuctConnector,Autodesk::Revit::MEP::PipeConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when get assigned flow factor from a connector not in family instance. Thrown when the connector's domain is not DomainHvac or DomainPiping.
System..::.ArgumentException | Throw when set an invalid value.
System..::.InvalidOperationException | Thrown on failure to get or set assigned flow factor.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


AssignedKCoefficient Property

[image]

Revit 2010 API
Connector..::.AssignedKCoefficient Property
Connector Class See Also Send Feedback
The assigned kCoefficient of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double AssignedKCoefficient { get; set; }
Visual Basic (Declaration)
Public Property AssignedKCoefficient As Double
Visual C++
public:
property double AssignedKCoefficient {
    double get ();
    void set (double value);
}

Remarks

Assigned kCoefficient may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::PipeConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
System..::.ArgumentException | Thrown when set an invalid value.
System..::.InvalidOperationException | Thrown on failure to get or set kCoefficient.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


AssignedLossCoefficient Property

[image]

Revit 2010 API
Connector..::.AssignedLossCoefficient Property
Connector Class See Also Send Feedback
The assigned loss coefficient of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double AssignedLossCoefficient { get; set; }
Visual Basic (Declaration)
Public Property AssignedLossCoefficient As Double
Visual C++
public:
property double AssignedLossCoefficient {
    double get ();
    void set (double value);
}

Remarks

Assigned loss coefficient may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::DuctConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainHvac. Thrown when the connector is not in a family instance.
System..::.ArgumentException | Thrown when set an invalid value.
System..::.InvalidOperationException | Thrown on failure to get or set assigned loss coefficient.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


AssignedPipeFlowConfiguration Property

[image]

Revit 2010 API
Connector..::.AssignedPipeFlowConfiguration Property
Connector Class See Also Send Feedback
The pipe flow configuration type of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeFlowConfigurationType AssignedPipeFlowConfiguration { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedPipeFlowConfiguration As PipeFlowConfigurationType
Visual C++
public:
property PipeFlowConfigurationType AssignedPipeFlowConfiguration {
    PipeFlowConfigurationType get ();
}

Remarks

Assigned pipe flow configuration may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::PipeConnector.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
System..::.InvalidOperationException | Thrown on failure to get pipe flow configuration.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


AssignedPipeLossMethod Property

[image]

Revit 2010 API
Connector..::.AssignedPipeLossMethod Property
Connector Class See Also Send Feedback
The pipe loss method of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeLossMethodType AssignedPipeLossMethod { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedPipeLossMethod As PipeLossMethodType
Visual C++
public:
property PipeLossMethodType AssignedPipeLossMethod {
    PipeLossMethodType get ();
}

Remarks

Assigned duct pipe loss method may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::PipeConnector.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
System..::.InvalidOperationException | Thrown on failure to get pipe loss method.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


AssignedPressureDrop Property

[image]

Revit 2010 API
Connector..::.AssignedPressureDrop Property
Connector Class See Also Send Feedback
The assigned pressure drop of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double AssignedPressureDrop { get; set; }
Visual Basic (Declaration)
Public Property AssignedPressureDrop As Double
Visual C++
public:
property double AssignedPressureDrop {
    double get ();
    void set (double value);
}

Remarks

Assigned pressure drop may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::PipeConnector,Autodesk::Revit::MEP::DuctConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector is not in a family instance. Thrown when the connector's domain is not DomainHvac or DomainPiping.
System..::.ArgumentException | Thrown when set an invalid value.
System..::.InvalidOperationException | Thrown on failure to get or set assigned pressure drop.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Coefficient Property

[image]

Revit 2010 API
Connector..::.Coefficient Property
Connector Class See Also Send Feedback
The coefficient of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Coefficient { get; }
Visual Basic (Declaration)
Public ReadOnly Property Coefficient As Double
Visual C++
public:
property double Coefficient {
    double get ();
}

Remarks

Instantaneous coefficient of this connector, calculated according to system.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainHvac or DomainPiping.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


ConnectorManager Property

[image]

Revit 2010 API
Connector..::.ConnectorManager Property
Connector Class See Also Send Feedback
The connector manager of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ConnectorManager ConnectorManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConnectorManager As ConnectorManager
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown on failure to get connector manager.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


ConnectorType Property

[image]

Revit 2010 API
Connector..::.ConnectorType Property
Connector Class See Also Send Feedback
The connector type of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ConnectorType ConnectorType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConnectorType As ConnectorType
Visual C++
public:
property ConnectorType ConnectorType {
    ConnectorType get ();
}

See Also

Connector Class
Autodesk.Revit.MEP Namespace


CoordinateSystem Property

[image]

Revit 2010 API
Connector..::.CoordinateSystem Property
Connector Class See Also Send Feedback
The coordinate system of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Transform CoordinateSystem { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property CoordinateSystem As Transform
Visual C++
public:
virtual property Transform^ CoordinateSystem {
    Transform^ get ();
}

Implements

IConnector..::.CoordinateSystem

Remarks

The coordinate system's origin is the location of the connector and the Z-axis is normal to the connector.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector is of logical type.
System..::.InvalidOperationException | Thrown on failure to get coordinate system.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Demand Property

[image]

Revit 2010 API
Connector..::.Demand Property
Connector Class See Also Send Feedback
The demand of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Demand { get; }
Visual Basic (Declaration)
Public ReadOnly Property Demand As Double
Visual C++
public:
property double Demand {
    double get ();
}

Remarks

Instantaneous demand at this connector, calculated according to system.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainPiping.
System..::.InvalidOperationException | Thrown on failure to get demand.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Direction Property

[image]

Revit 2010 API
Connector..::.Direction Property
Connector Class See Also Send Feedback
The direction of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlowDirectionType Direction { get; }
Visual Basic (Declaration)
Public ReadOnly Property Direction As FlowDirectionType
Visual C++
public:
property FlowDirectionType Direction {
    FlowDirectionType get ();
}

Remarks

Instantaneous direction of this connector, calculated according to system.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainHvac or DomainPiping.
System..::.InvalidOperationException | Thrown on failure to get direction.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Domain Property

[image]

Revit 2010 API
Connector..::.Domain Property
Connector Class See Also Send Feedback
The domain of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Domain Domain { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Domain As Domain
Visual C++
public:
virtual property Domain Domain {
    Domain get ();
}

Implements

IConnector..::.Domain

See Also

Connector Class
Autodesk.Revit.MEP Namespace


DuctSystemType Property

[image]

Revit 2010 API
Connector..::.DuctSystemType Property
Connector Class See Also Send Feedback
The duct system type of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DuctSystemType DuctSystemType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DuctSystemType As DuctSystemType
Visual C++
public:
property DuctSystemType DuctSystemType {
    DuctSystemType get ();
}

Remarks

This is the instantaneous system type at this connector, calculated according to system. For unconnected connectors, the system type is undefined.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainHvac.
System..::.InvalidOperationException | Thrown on failure to get duct system type.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


ElectricalSystemType Property

[image]

Revit 2010 API
Connector..::.ElectricalSystemType Property
Connector Class See Also Send Feedback
The electrical system type of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElectricalSystemType ElectricalSystemType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElectricalSystemType As ElectricalSystemType
Visual C++
public:
property ElectricalSystemType ElectricalSystemType {
    ElectricalSystemType get ();
}

Remarks

Instantaneous system type at this connector, calculated according to system. For unconnected connectors, system type is undefined.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not of DomainElectrical.
System..::.InvalidOperationException | Thrown on failure to get electrical system type.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Flow Property

[image]

Revit 2010 API
Connector..::.Flow Property
Connector Class See Also Send Feedback
The flow of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Flow { get; }
Visual Basic (Declaration)
Public ReadOnly Property Flow As Double
Visual C++
public:
property double Flow {
    double get ();
}

Remarks

Instantaneous flow at this connector, calculated according to system.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainPiping or DomainHvac.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Height Property

[image]

Revit 2010 API
Connector..::.Height Property
Connector Class See Also Send Feedback
The height of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual double Height { get; set; }
Visual Basic (Declaration)
Public Overridable Property Height As Double
Visual C++
public:
virtual property double Height {
    double get ();
    void set (double value);
}

Implements

IConnector..::.Height

Remarks

In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's shape is not rectangular.
System..::.ArgumentException | Thrown when the argument is invalid.
System..::.InvalidOperationException | Thrown on failure to set height.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


IsConnected Property

[image]

Revit 2010 API
Connector..::.IsConnected Property
Connector Class See Also Send Feedback
Identifies if the connector is physically connected to a connector on another element.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsConnected { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsConnected As Boolean
Visual C++
public:
property bool IsConnected {
    bool get ();
}

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's type is LogicalConn.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


IsMovable Property

[image]

Revit 2010 API
Connector..::.IsMovable Property
Connector Class See Also Send Feedback
whether the connector can be moved.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsMovable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsMovable As Boolean
Visual C++
public:
property bool IsMovable {
    bool get ();
}

Remarks

Only connectors of type EndConn can be moved.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


MEPSystem Property

[image]

Revit 2010 API
Connector..::.MEPSystem Property
Connector Class See Also Send Feedback
The system of the connector belong to.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MEPSystem MEPSystem { get; }
Visual Basic (Declaration)
Public ReadOnly Property MEPSystem As MEPSystem
Visual C++
public:
property MEPSystem^ MEPSystem {
    MEPSystem^ get ();
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown on failure to get system.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Origin Property

[image]

Revit 2010 API
Connector..::.Origin Property
Connector Class See Also Send Feedback
The location of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual XYZ Origin { get; set; }
Visual Basic (Declaration)
Public Overridable Property Origin As XYZ
Visual C++
public:
virtual property XYZ^ Origin {
    XYZ^ get ();
    void set (XYZ^ value);
}

Implements

IConnector..::.Origin

Remarks

Changing the location of the connecotr may lead to changes of location and geometry for the connector's host element and the hosts for other elements the element is connected to.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when connector's type is NonEndConn. Thrown when the connector is a part of a family instance.
System..::.ArgumentException | Thrown when the assigned origin is invalid.
System..::.InvalidOperationException | Thrown on failure to set origin.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Owner Property

[image]

Revit 2010 API
Connector..::.Owner Property
Connector Class See Also Send Feedback
The host of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element Owner { get; }
Visual Basic (Declaration)
Public ReadOnly Property Owner As Element
Visual C++
public:
property Element^ Owner {
    Element^ get ();
}

Remarks

The element that contains this connector. It may also contain other connectors.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


PipeSystemType Property

[image]

Revit 2010 API
Connector..::.PipeSystemType Property
Connector Class See Also Send Feedback
The pipe system type of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeSystemType PipeSystemType { get; }
Visual Basic (Declaration)
Public ReadOnly Property PipeSystemType As PipeSystemType
Visual C++
public:
property PipeSystemType PipeSystemType {
    PipeSystemType get ();
}

Remarks

Instantaneous system type at this connector, calculated according to system. For unconnected connectors, system type is undefined.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainPiping.
System..::.InvalidOperationException | Thrown on failure to get pipe system type.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


PressureDrop Property

[image]

Revit 2010 API
Connector..::.PressureDrop Property
Connector Class See Also Send Feedback
The pressure drop of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double PressureDrop { get; }
Visual Basic (Declaration)
Public ReadOnly Property PressureDrop As Double
Visual C++
public:
property double PressureDrop {
    double get ();
}

Remarks

Instantaneous pressure drop of this connector,calculated according to system.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainHvac or DomainPiping.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Radius Property

[image]

Revit 2010 API
Connector..::.Radius Property
Connector Class See Also Send Feedback
The radius of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual double Radius { get; set; }
Visual Basic (Declaration)
Public Overridable Property Radius As Double
Visual C++
public:
virtual property double Radius {
    double get ();
    void set (double value);
}

Implements

IConnector..::.Radius

Remarks

In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's shape is not round.
System..::.ArgumentException | Thrown when the argument is invalid.
System..::.InvalidOperationException | Thrown on failure to set radius.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Shape Property

[image]

Revit 2010 API
Connector..::.Shape Property
Connector Class See Also Send Feedback
The shape of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ConnectorProfileType Shape { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Shape As ConnectorProfileType
Visual C++
public:
virtual property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}

Implements

IConnector..::.Shape

See Also

Connector Class
Autodesk.Revit.MEP Namespace


VelocityPressure Property

[image]

Revit 2010 API
Connector..::.VelocityPressure Property
Connector Class See Also Send Feedback
The velocity pressure of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double VelocityPressure { get; }
Visual Basic (Declaration)
Public ReadOnly Property VelocityPressure As Double
Visual C++
public:
property double VelocityPressure {
    double get ();
}

Remarks

Instantaneous velocity pressure of this connector,calculated according to system.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainHvac or DomainPiping.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


Width Property

[image]

Revit 2010 API
Connector..::.Width Property
Connector Class See Also Send Feedback
The width of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual double Width { get; set; }
Visual Basic (Declaration)
Public Overridable Property Width As Double
Visual C++
public:
virtual property double Width {
    double get ();
    void set (double value);
}

Implements

IConnector..::.Width

Remarks

In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's shape is not rectangular.
System..::.ArgumentException | Thrown when the argument is invalid.
System..::.InvalidOperationException | Thrown on failure to set width.

See Also

Connector Class
Autodesk.Revit.MEP Namespace


ConnectorManager Class

[image]

Revit 2010 API
ConnectorManager Class
Members See Also Send Feedback
Provides access to the Connector Manager in Autodesk Revit MEP.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ConnectorManager : APIObject
Visual Basic (Declaration)
Public Class ConnectorManager _
    Inherits APIObject
Visual C++
public ref class ConnectorManager : public APIObject

Remarks

The Connector Manager object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.ConnectorManager

See Also

ConnectorManager Members
Autodesk.Revit.MEP Namespace


ConnectorManager Members

[image] [image]

Revit 2010 API
ConnectorManager Members
ConnectorManager Class Constructors Methods Properties See Also Send Feedback

The ConnectorManager type exposes the following members.

Constructors

Name | Description
ConnectorManager | For Internal Use Only

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Connectors | Return all the Connectors of the Connector Manager.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Owner | Return the owner of the Connector Manager.
UnusedConnectors | Return all the unused Connectors of the Connector Manager.

See Also

ConnectorManager Class
Autodesk.Revit.MEP Namespace


ConnectorManager Constructor

[image]

Revit 2010 API
ConnectorManager Constructor
ConnectorManager Class See Also Send Feedback
For Internal Use Only

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ConnectorManager()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConnectorManager()

Remarks

This constructor is exposed to enable support for COM interopability only. This object should not be created by the developer.

See Also

ConnectorManager Class
Autodesk.Revit.MEP Namespace


ConnectorManager Methods

[image] [image]

Revit 2010 API
ConnectorManager Methods
ConnectorManager Class See Also Send Feedback

The ConnectorManager type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConnectorManager Class
Autodesk.Revit.MEP Namespace


ConnectorManager Properties

[image] [image]

Revit 2010 API
ConnectorManager Properties
ConnectorManager Class See Also Send Feedback

The ConnectorManager type exposes the following members.

Properties

Name | Description
Connectors | Return all the Connectors of the Connector Manager.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Owner | Return the owner of the Connector Manager.
UnusedConnectors | Return all the unused Connectors of the Connector Manager.

See Also

ConnectorManager Class
Autodesk.Revit.MEP Namespace


Connectors Property

[image]

Revit 2010 API
ConnectorManager..::.Connectors Property
ConnectorManager Class See Also Send Feedback
Return all the Connectors of the Connector Manager.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ConnectorSet Connectors { get; }
Visual Basic (Declaration)
Public ReadOnly Property Connectors As ConnectorSet
Visual C++
public:
property ConnectorSet^ Connectors {
    ConnectorSet^ get ();
}

Remarks

This property is used to retrieve the Connectors from the Connector Manager.

See Also

ConnectorManager Class
Autodesk.Revit.MEP Namespace


Owner Property

[image]

Revit 2010 API
ConnectorManager..::.Owner Property
ConnectorManager Class See Also Send Feedback
Return the owner of the Connector Manager.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element Owner { get; }
Visual Basic (Declaration)
Public ReadOnly Property Owner As Element
Visual C++
public:
property Element^ Owner {
    Element^ get ();
}

Remarks

This property is used to retrieve the owner of the Connector Manager.

See Also

ConnectorManager Class
Autodesk.Revit.MEP Namespace


UnusedConnectors Property

[image]

Revit 2010 API
ConnectorManager..::.UnusedConnectors Property
ConnectorManager Class See Also Send Feedback
Return all the unused Connectors of the Connector Manager.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ConnectorSet UnusedConnectors { get; }
Visual Basic (Declaration)
Public ReadOnly Property UnusedConnectors As ConnectorSet
Visual C++
public:
property ConnectorSet^ UnusedConnectors {
    ConnectorSet^ get ();
}

Remarks

This property is used to retrieve the unused Connectors from the Connector Manager.

See Also

ConnectorManager Class
Autodesk.Revit.MEP Namespace


ConnectorSet Class

[image]

Revit 2010 API
ConnectorSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ConnectorSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ConnectorSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ConnectorSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.ConnectorSet

See Also

ConnectorSet Members
Autodesk.Revit.MEP Namespace


ConnectorSet Members

[image] [image]

Revit 2010 API
ConnectorSet Members
ConnectorSet Class Constructors Methods Properties See Also Send Feedback

The ConnectorSet type exposes the following members.

Constructors

Name | Description
ConnectorSet | Initializes a new instance of the ConnectorSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


ConnectorSet Constructor

[image]

Revit 2010 API
ConnectorSet Constructor
ConnectorSet Class See Also Send Feedback
Initializes a new instance of the ConnectorSet class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ConnectorSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConnectorSet()

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


ConnectorSet Methods

[image] [image]

Revit 2010 API
ConnectorSet Methods
ConnectorSet Class See Also Send Feedback

The ConnectorSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


Clear Method

[image]

Revit 2010 API
ConnectorSet..::.Clear Method
ConnectorSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


Contains Method

[image]

Revit 2010 API
ConnectorSet..::.Contains Method
ConnectorSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    Connector item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Connector _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Connector^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.Connector

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


Erase Method

[image]

Revit 2010 API
ConnectorSet..::.Erase Method
ConnectorSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    Connector item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Connector _
) As Integer
Visual C++
public:
virtual int Erase(
    Connector^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.Connector

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


ForwardIterator Method

[image]

Revit 2010 API
ConnectorSet..::.ForwardIterator Method
ConnectorSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ConnectorSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ConnectorSetIterator
Visual C++
public:
virtual ConnectorSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


GetEnumerator Method

[image]

Revit 2010 API
ConnectorSet..::.GetEnumerator Method
ConnectorSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


Insert Method

[image]

Revit 2010 API
ConnectorSet..::.Insert Method
ConnectorSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    Connector item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Connector _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Connector^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.Connector

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


ReverseIterator Method

[image]

Revit 2010 API
ConnectorSet..::.ReverseIterator Method
ConnectorSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ConnectorSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ConnectorSetIterator
Visual C++
public:
virtual ConnectorSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


ConnectorSet Properties

[image] [image]

Revit 2010 API
ConnectorSet Properties
ConnectorSet Class See Also Send Feedback

The ConnectorSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


IsEmpty Property

[image]

Revit 2010 API
ConnectorSet..::.IsEmpty Property
ConnectorSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


Size Property

[image]

Revit 2010 API
ConnectorSet..::.Size Property
ConnectorSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ConnectorSet Class
Autodesk.Revit.MEP Namespace


ConnectorSetIterator Class

[image]

Revit 2010 API
ConnectorSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ConnectorSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ConnectorSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ConnectorSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.ConnectorSetIterator

See Also

ConnectorSetIterator Members
Autodesk.Revit.MEP Namespace


ConnectorSetIterator Members

[image] [image]

Revit 2010 API
ConnectorSetIterator Members
ConnectorSetIterator Class Constructors Methods Properties See Also Send Feedback

The ConnectorSetIterator type exposes the following members.

Constructors

Name | Description
ConnectorSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ConnectorSetIterator Class
Autodesk.Revit.MEP Namespace


ConnectorSetIterator Constructor

[image]

Revit 2010 API
ConnectorSetIterator Constructor
ConnectorSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ConnectorSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConnectorSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ConnectorSetIterator Class
Autodesk.Revit.MEP Namespace


ConnectorSetIterator Methods

[image] [image]

Revit 2010 API
ConnectorSetIterator Methods
ConnectorSetIterator Class See Also Send Feedback

The ConnectorSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConnectorSetIterator Class
Autodesk.Revit.MEP Namespace


MoveNext Method

[image]

Revit 2010 API
ConnectorSetIterator..::.MoveNext Method
ConnectorSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ConnectorSetIterator Class
Autodesk.Revit.MEP Namespace


Reset Method

[image]

Revit 2010 API
ConnectorSetIterator..::.Reset Method
ConnectorSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ConnectorSetIterator Class
Autodesk.Revit.MEP Namespace


ConnectorSetIterator Properties

[image] [image]

Revit 2010 API
ConnectorSetIterator Properties
ConnectorSetIterator Class See Also Send Feedback

The ConnectorSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ConnectorSetIterator Class
Autodesk.Revit.MEP Namespace


Current Property

[image]

Revit 2010 API
ConnectorSetIterator..::.Current Property
ConnectorSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ConnectorSetIterator Class
Autodesk.Revit.MEP Namespace


CorrectionFactor Class

[image]

Revit 2010 API
CorrectionFactor Class
Members See Also Send Feedback
Represents electrical correction factor information.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CorrectionFactor : APIObject
Visual Basic (Declaration)
Public Class CorrectionFactor _
    Inherits APIObject
Visual C++
public ref class CorrectionFactor : public APIObject

Remarks

Correction facotr is defined based on corresponding wire material type and temperature rating type.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.CorrectionFactor

See Also

CorrectionFactor Members
Autodesk.Revit.MEP Namespace


CorrectionFactor Members

[image] [image]

Revit 2010 API
CorrectionFactor Members
CorrectionFactor Class Constructors Methods Properties See Also Send Feedback

The CorrectionFactor type exposes the following members.

Constructors

Name | Description
CorrectionFactor | Initializes a new instance of the CorrectionFactor class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Factor | Get factor value of wire correction factor.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Temperature | Get temperature which is used for specifying correction factor.

See Also

CorrectionFactor Class
Autodesk.Revit.MEP Namespace


CorrectionFactor Constructor

[image]

Revit 2010 API
CorrectionFactor Constructor
CorrectionFactor Class See Also Send Feedback
Initializes a new instance of the CorrectionFactor class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CorrectionFactor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CorrectionFactor()

See Also

CorrectionFactor Class
Autodesk.Revit.MEP Namespace


CorrectionFactor Methods

[image] [image]

Revit 2010 API
CorrectionFactor Methods
CorrectionFactor Class See Also Send Feedback

The CorrectionFactor type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CorrectionFactor Class
Autodesk.Revit.MEP Namespace


CorrectionFactor Properties

[image] [image]

Revit 2010 API
CorrectionFactor Properties
CorrectionFactor Class See Also Send Feedback

The CorrectionFactor type exposes the following members.

Properties

Name | Description
Factor | Get factor value of wire correction factor.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Temperature | Get temperature which is used for specifying correction factor.

See Also

CorrectionFactor Class
Autodesk.Revit.MEP Namespace


Factor Property

[image]

Revit 2010 API
CorrectionFactor..::.Factor Property
CorrectionFactor Class See Also Send Feedback
Get factor value of wire correction factor.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Factor { get; }
Visual Basic (Declaration)
Public ReadOnly Property Factor As Double
Visual C++
public:
property double Factor {
    double get ();
}

See Also

CorrectionFactor Class
Autodesk.Revit.MEP Namespace


Temperature Property

[image]

Revit 2010 API
CorrectionFactor..::.Temperature Property
CorrectionFactor Class See Also Send Feedback
Get temperature which is used for specifying correction factor.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public long Temperature { get; }
Visual Basic (Declaration)
Public ReadOnly Property Temperature As Long
Visual C++
public:
property long long Temperature {
    long long get ();
}

See Also

CorrectionFactor Class
Autodesk.Revit.MEP Namespace


CorrectionFactorSet Class

[image]

Revit 2010 API
CorrectionFactorSet Class
Members See Also Send Feedback
A set that contains correction factors.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CorrectionFactorSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class CorrectionFactorSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CorrectionFactorSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.CorrectionFactorSet

See Also

CorrectionFactorSet Members
Autodesk.Revit.MEP Namespace


CorrectionFactorSet Members

[image] [image]

Revit 2010 API
CorrectionFactorSet Members
CorrectionFactorSet Class Constructors Methods Properties See Also Send Feedback

The CorrectionFactorSet type exposes the following members.

Constructors

Name | Description
CorrectionFactorSet | Initializes a new instance of the CorrectionFactorSet class

Methods

Name | Description
Clear | Removes every correction factor from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of correction factors that are in the set.

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


CorrectionFactorSet Constructor

[image]

Revit 2010 API
CorrectionFactorSet Constructor
CorrectionFactorSet Class See Also Send Feedback
Initializes a new instance of the CorrectionFactorSet class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CorrectionFactorSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CorrectionFactorSet()

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


CorrectionFactorSet Methods

[image] [image]

Revit 2010 API
CorrectionFactorSet Methods
CorrectionFactorSet Class See Also Send Feedback

The CorrectionFactorSet type exposes the following members.

Methods

Name | Description
Clear | Removes every correction factor from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


Clear Method

[image]

Revit 2010 API
CorrectionFactorSet..::.Clear Method
CorrectionFactorSet Class See Also Send Feedback
Removes every correction factor from the set, rendering it empty.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


Contains Method

[image]

Revit 2010 API
CorrectionFactorSet..::.Contains Method
CorrectionFactorSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    CorrectionFactor item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As CorrectionFactor _
) As Boolean
Visual C++
public:
virtual bool Contains(
    CorrectionFactor^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.CorrectionFactor

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


Erase Method

[image]

Revit 2010 API
CorrectionFactorSet..::.Erase Method
CorrectionFactorSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    CorrectionFactor item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As CorrectionFactor _
) As Integer
Visual C++
public:
virtual int Erase(
    CorrectionFactor^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.CorrectionFactor

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


ForwardIterator Method

[image]

Revit 2010 API
CorrectionFactorSet..::.ForwardIterator Method
CorrectionFactorSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CorrectionFactorSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CorrectionFactorSetIterator
Visual C++
public:
virtual CorrectionFactorSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


GetEnumerator Method

[image]

Revit 2010 API
CorrectionFactorSet..::.GetEnumerator Method
CorrectionFactorSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


Insert Method

[image]

Revit 2010 API
CorrectionFactorSet..::.Insert Method
CorrectionFactorSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    CorrectionFactor item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As CorrectionFactor _
) As Boolean
Visual C++
public:
virtual bool Insert(
    CorrectionFactor^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.CorrectionFactor

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


ReverseIterator Method

[image]

Revit 2010 API
CorrectionFactorSet..::.ReverseIterator Method
CorrectionFactorSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CorrectionFactorSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CorrectionFactorSetIterator
Visual C++
public:
virtual CorrectionFactorSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


CorrectionFactorSet Properties

[image] [image]

Revit 2010 API
CorrectionFactorSet Properties
CorrectionFactorSet Class See Also Send Feedback

The CorrectionFactorSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of correction factors that are in the set.

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


IsEmpty Property

[image]

Revit 2010 API
CorrectionFactorSet..::.IsEmpty Property
CorrectionFactorSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


Size Property

[image]

Revit 2010 API
CorrectionFactorSet..::.Size Property
CorrectionFactorSet Class See Also Send Feedback
Returns the number of correction factors that are in the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CorrectionFactorSet Class
Autodesk.Revit.MEP Namespace


CorrectionFactorSetIterator Class

[image]

Revit 2010 API
CorrectionFactorSetIterator Class
Members See Also Send Feedback
An iterator to a correction factor set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class CorrectionFactorSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CorrectionFactorSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CorrectionFactorSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.CorrectionFactorSetIterator

See Also

CorrectionFactorSetIterator Members
Autodesk.Revit.MEP Namespace


CorrectionFactorSetIterator Members

[image] [image]

Revit 2010 API
CorrectionFactorSetIterator Members
CorrectionFactorSetIterator Class Constructors Methods Properties See Also Send Feedback

The CorrectionFactorSetIterator type exposes the following members.

Constructors

Name | Description
CorrectionFactorSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.MEP Namespace


CorrectionFactorSetIterator Constructor

[image]

Revit 2010 API
CorrectionFactorSetIterator Constructor
CorrectionFactorSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CorrectionFactorSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CorrectionFactorSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.MEP Namespace


CorrectionFactorSetIterator Methods

[image] [image]

Revit 2010 API
CorrectionFactorSetIterator Methods
CorrectionFactorSetIterator Class See Also Send Feedback

The CorrectionFactorSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.MEP Namespace


MoveNext Method

[image]

Revit 2010 API
CorrectionFactorSetIterator..::.MoveNext Method
CorrectionFactorSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.MEP Namespace


Reset Method

[image]

Revit 2010 API
CorrectionFactorSetIterator..::.Reset Method
CorrectionFactorSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.MEP Namespace


CorrectionFactorSetIterator Properties

[image] [image]

Revit 2010 API
CorrectionFactorSetIterator Properties
CorrectionFactorSetIterator Class See Also Send Feedback

The CorrectionFactorSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.MEP Namespace


Current Property

[image]

Revit 2010 API
CorrectionFactorSetIterator..::.Current Property
CorrectionFactorSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.MEP Namespace


DemandFactor Class

[image]

Revit 2010 API
DemandFactor Class
Members See Also Send Feedback
Represents a demand factor, which let you adjust the rating of the main service for a building based on the expectation that, at any given time, not all of the electrical equipment will not be drawing at its full rated load. You can specify one or more Demand Factors, applying different Demand Factors to Lighting, Power, HVAC, or Other systems in your project based on their load.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DemandFactor : Symbol
Visual Basic (Declaration)
Public Class DemandFactor _
    Inherits Symbol
Visual C++
public ref class DemandFactor : public Symbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.DemandFactor

See Also

DemandFactor Members
Autodesk.Revit.MEP Namespace


DemandFactor Members

[image] [image]

Revit 2010 API
DemandFactor Members
DemandFactor Class Constructors Methods Properties See Also Send Feedback

The DemandFactor type exposes the following members.

Constructors

Name | Description
DemandFactor | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetPercentage | Set percentage value for the specified range.
SetPercentageToInfinity | This method is used to set percentage value for the range in [MinFactor, PositiveInfinity) specially.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DataItems | Get all data items in this demand factor, which represents demand factor percentage in a specific range.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadClassification | Get category of demand factor.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DemandFactor Class
Autodesk.Revit.MEP Namespace


DemandFactor Constructor

[image]

Revit 2010 API
DemandFactor Constructor
DemandFactor Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DemandFactor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DemandFactor()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DemandFactor Class
Autodesk.Revit.MEP Namespace


DemandFactor Methods

[image] [image]

Revit 2010 API
DemandFactor Methods
DemandFactor Class See Also Send Feedback

The DemandFactor type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetPercentage | Set percentage value for the specified range.
SetPercentageToInfinity | This method is used to set percentage value for the range in [MinFactor, PositiveInfinity) specially.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DemandFactor Class
Autodesk.Revit.MEP Namespace


SetPercentage Method

[image]

Revit 2010 API
DemandFactor..::.SetPercentage Method
DemandFactor Class See Also Send Feedback
Set percentage value for the specified range.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetPercentage(
    long minFactor,
    long maxFactor,
    double percentage
)
Visual Basic (Declaration)
Public Sub SetPercentage ( _
    minFactor As Long, _
    maxFactor As Long, _
    percentage As Double _
)
Visual C++
public:
void SetPercentage(
    long long minFactor,
    long long maxFactor,
    double percentage
)

Parameters

minFactor
Type: System..::.Int64
Lower boundary of the range.
maxFactor
Type: System..::.Int64
Upper boundary of the range.
percentage
Type: System..::.Double
Percentage value of this range.

Remarks

Demand factor data items have been obsolete after this operation, so they should be retrieved again before using. Use "SetFactorDataToInfinity" if the maxFactor value is positive infinity.

Exceptions

Exception | Condition
System..::.ArgumentException | All three parameter can't be negative, maxFactor must be greater than minFactor, and minFactor and percentage can't be positive infinity, otherwise the exception will be thrown.

See Also

DemandFactor Class
Autodesk.Revit.MEP Namespace


SetPercentageToInfinity Method

[image]

Revit 2010 API
DemandFactor..::.SetPercentageToInfinity Method
DemandFactor Class See Also Send Feedback
This method is used to set percentage value for the range in [MinFactor, PositiveInfinity) specially.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetPercentageToInfinity(
    long minFactor,
    double percentage
)
Visual Basic (Declaration)
Public Sub SetPercentageToInfinity ( _
    minFactor As Long, _
    percentage As Double _
)
Visual C++
public:
void SetPercentageToInfinity(
    long long minFactor,
    double percentage
)

Parameters

minFactor
Type: System..::.Int64
Lower boundary of the range.
percentage
Type: System..::.Double
Percentage value of this range.

Remarks

Demand factor data items have been obsolete after this operation, so they should be retrieved again before using.

Exceptions

Exception | Condition
System..::.ArgumentException | Both parameters can't be negative or positive infinity, otherwise the exception will be thrown.

See Also

DemandFactor Class
Autodesk.Revit.MEP Namespace


DemandFactor Properties

[image] [image]

Revit 2010 API
DemandFactor Properties
DemandFactor Class See Also Send Feedback

The DemandFactor type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DataItems | Get all data items in this demand factor, which represents demand factor percentage in a specific range.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadClassification | Get category of demand factor.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DemandFactor Class
Autodesk.Revit.MEP Namespace


DataItems Property

[image]

Revit 2010 API
DemandFactor..::.DataItems Property
DemandFactor Class See Also Send Feedback
Get all data items in this demand factor, which represents demand factor percentage in a specific range.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DemandFactorDataSet DataItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataItems As DemandFactorDataSet
Visual C++
public:
property DemandFactorDataSet^ DataItems {
    DemandFactorDataSet^ get ();
}

See Also

DemandFactor Class
Autodesk.Revit.MEP Namespace


LoadClassification Property

[image]

Revit 2010 API
DemandFactor..::.LoadClassification Property
DemandFactor Class See Also Send Feedback
Get category of demand factor.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadClassification LoadClassification { get; }
Visual Basic (Declaration)
Public ReadOnly Property LoadClassification As LoadClassification
Visual C++
public:
property LoadClassification LoadClassification {
    LoadClassification get ();
}

See Also

DemandFactor Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
DemandFactor..::.Parameter Property
DemandFactor Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DemandFactor Class
DemandFactor Members
Autodesk.Revit.MEP Namespace


DemandFactorData Class

[image]

Revit 2010 API
DemandFactorData Class
Members See Also Send Feedback
Represents demand factor definition in a specified range.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DemandFactorData : APIObject
Visual Basic (Declaration)
Public Class DemandFactorData _
    Inherits APIObject
Visual C++
public ref class DemandFactorData : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.DemandFactorData

See Also

DemandFactorData Members
Autodesk.Revit.MEP Namespace


DemandFactorData Members

[image] [image]

Revit 2010 API
DemandFactorData Members
DemandFactorData Class Constructors Methods Properties See Also Send Feedback

The DemandFactorData type exposes the following members.

Constructors

Name | Description
DemandFactorData | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsValid | Get value to indicate whether this data item is still valid, if yes, it can be use, otherwise it has been obsolete.
MaxFactor | Get upper limit value of the range, the unit is volt-ampere.
MinFactor | Get lower limit value of the range, the unit is volt-ampere.
Percentage | Get or set demand factor percentage that specifies the anticipated a percentage of full rated load that will exist at any given time for the specified range.

See Also

DemandFactorData Class
Autodesk.Revit.MEP Namespace


DemandFactorData Constructor

[image]

Revit 2010 API
DemandFactorData Constructor
DemandFactorData Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DemandFactorData()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DemandFactorData()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DemandFactorData Class
Autodesk.Revit.MEP Namespace


DemandFactorData Methods

[image] [image]

Revit 2010 API
DemandFactorData Methods
DemandFactorData Class See Also Send Feedback

The DemandFactorData type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DemandFactorData Class
Autodesk.Revit.MEP Namespace


DemandFactorData Properties

[image] [image]

Revit 2010 API
DemandFactorData Properties
DemandFactorData Class See Also Send Feedback

The DemandFactorData type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsValid | Get value to indicate whether this data item is still valid, if yes, it can be use, otherwise it has been obsolete.
MaxFactor | Get upper limit value of the range, the unit is volt-ampere.
MinFactor | Get lower limit value of the range, the unit is volt-ampere.
Percentage | Get or set demand factor percentage that specifies the anticipated a percentage of full rated load that will exist at any given time for the specified range.

See Also

DemandFactorData Class
Autodesk.Revit.MEP Namespace


IsValid Property

[image]

Revit 2010 API
DemandFactorData..::.IsValid Property
DemandFactorData Class See Also Send Feedback
Get value to indicate whether this data item is still valid, if yes, it can be use, otherwise it has been obsolete.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsValid { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsValid As Boolean
Visual C++
public:
property bool IsValid {
    bool get ();
}

Return Value

true if the data can still be used, otherwise false.

See Also

DemandFactorData Class
Autodesk.Revit.MEP Namespace


MaxFactor Property

[image]

Revit 2010 API
DemandFactorData..::.MaxFactor Property
DemandFactorData Class See Also Send Feedback
Get upper limit value of the range, the unit is volt-ampere.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public long MaxFactor { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxFactor As Long
Visual C++
public:
property long long MaxFactor {
    long long get ();
}

See Also

DemandFactorData Class
Autodesk.Revit.MEP Namespace


MinFactor Property

[image]

Revit 2010 API
DemandFactorData..::.MinFactor Property
DemandFactorData Class See Also Send Feedback
Get lower limit value of the range, the unit is volt-ampere.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public long MinFactor { get; set; }
Visual Basic (Declaration)
Public Property MinFactor As Long
Visual C++
public:
property long long MinFactor {
    long long get ();
    void set (long long value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Valid min factor should bigger than the min value of previous range and less than the max factor of current range.

See Also

DemandFactorData Class
Autodesk.Revit.MEP Namespace


Percentage Property

[image]

Revit 2010 API
DemandFactorData..::.Percentage Property
DemandFactorData Class See Also Send Feedback
Get or set demand factor percentage that specifies the anticipated a percentage of full rated load that will exist at any given time for the specified range.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Percentage { get; set; }
Visual Basic (Declaration)
Public Property Percentage As Double
Visual C++
public:
property double Percentage {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Throw exception when assign a negative value to percentage.

See Also

DemandFactorData Class
Autodesk.Revit.MEP Namespace


DemandFactorDataSet Class

[image]

Revit 2010 API
DemandFactorDataSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DemandFactorDataSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class DemandFactorDataSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DemandFactorDataSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.DemandFactorDataSet

See Also

DemandFactorDataSet Members
Autodesk.Revit.MEP Namespace


DemandFactorDataSet Members

[image] [image]

Revit 2010 API
DemandFactorDataSet Members
DemandFactorDataSet Class Constructors Methods Properties See Also Send Feedback

The DemandFactorDataSet type exposes the following members.

Constructors

Name | Description
DemandFactorDataSet | Initializes a new instance of the DemandFactorDataSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


DemandFactorDataSet Constructor

[image]

Revit 2010 API
DemandFactorDataSet Constructor
DemandFactorDataSet Class See Also Send Feedback
Initializes a new instance of the DemandFactorDataSet class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DemandFactorDataSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DemandFactorDataSet()

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


DemandFactorDataSet Methods

[image] [image]

Revit 2010 API
DemandFactorDataSet Methods
DemandFactorDataSet Class See Also Send Feedback

The DemandFactorDataSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


Clear Method

[image]

Revit 2010 API
DemandFactorDataSet..::.Clear Method
DemandFactorDataSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


Contains Method

[image]

Revit 2010 API
DemandFactorDataSet..::.Contains Method
DemandFactorDataSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    DemandFactorData item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As DemandFactorData _
) As Boolean
Visual C++
public:
virtual bool Contains(
    DemandFactorData^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.DemandFactorData

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


Erase Method

[image]

Revit 2010 API
DemandFactorDataSet..::.Erase Method
DemandFactorDataSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    DemandFactorData item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As DemandFactorData _
) As Integer
Visual C++
public:
virtual int Erase(
    DemandFactorData^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.DemandFactorData

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


ForwardIterator Method

[image]

Revit 2010 API
DemandFactorDataSet..::.ForwardIterator Method
DemandFactorDataSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DemandFactorDataSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DemandFactorDataSetIterator
Visual C++
public:
virtual DemandFactorDataSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


GetEnumerator Method

[image]

Revit 2010 API
DemandFactorDataSet..::.GetEnumerator Method
DemandFactorDataSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


Insert Method

[image]

Revit 2010 API
DemandFactorDataSet..::.Insert Method
DemandFactorDataSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    DemandFactorData item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As DemandFactorData _
) As Boolean
Visual C++
public:
virtual bool Insert(
    DemandFactorData^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.DemandFactorData

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


ReverseIterator Method

[image]

Revit 2010 API
DemandFactorDataSet..::.ReverseIterator Method
DemandFactorDataSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DemandFactorDataSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DemandFactorDataSetIterator
Visual C++
public:
virtual DemandFactorDataSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


DemandFactorDataSet Properties

[image] [image]

Revit 2010 API
DemandFactorDataSet Properties
DemandFactorDataSet Class See Also Send Feedback

The DemandFactorDataSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


IsEmpty Property

[image]

Revit 2010 API
DemandFactorDataSet..::.IsEmpty Property
DemandFactorDataSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


Size Property

[image]

Revit 2010 API
DemandFactorDataSet..::.Size Property
DemandFactorDataSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace


DemandFactorDataSetIterator Class

[image]

Revit 2010 API
DemandFactorDataSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class DemandFactorDataSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class DemandFactorDataSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DemandFactorDataSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.DemandFactorDataSetIterator

See Also

DemandFactorDataSetIterator Members
Autodesk.Revit.MEP Namespace


DemandFactorDataSetIterator Members

[image] [image]

Revit 2010 API
DemandFactorDataSetIterator Members
DemandFactorDataSetIterator Class Constructors Methods Properties See Also Send Feedback

The DemandFactorDataSetIterator type exposes the following members.

Constructors

Name | Description
DemandFactorDataSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DemandFactorDataSetIterator Class
Autodesk.Revit.MEP Namespace


DemandFactorDataSetIterator Constructor

[image]

Revit 2010 API
DemandFactorDataSetIterator Constructor
DemandFactorDataSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DemandFactorDataSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DemandFactorDataSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DemandFactorDataSetIterator Class
Autodesk.Revit.MEP Namespace


DemandFactorDataSetIterator Methods

[image] [image]

Revit 2010 API
DemandFactorDataSetIterator Methods
DemandFactorDataSetIterator Class See Also Send Feedback

The DemandFactorDataSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DemandFactorDataSetIterator Class
Autodesk.Revit.MEP Namespace


MoveNext Method

[image]

Revit 2010 API
DemandFactorDataSetIterator..::.MoveNext Method
DemandFactorDataSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DemandFactorDataSetIterator Class
Autodesk.Revit.MEP Namespace


Reset Method

[image]

Revit 2010 API
DemandFactorDataSetIterator..::.Reset Method
DemandFactorDataSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DemandFactorDataSetIterator Class
Autodesk.Revit.MEP Namespace


DemandFactorDataSetIterator Properties

[image] [image]

Revit 2010 API
DemandFactorDataSetIterator Properties
DemandFactorDataSetIterator Class See Also Send Feedback

The DemandFactorDataSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DemandFactorDataSetIterator Class
Autodesk.Revit.MEP Namespace


Current Property

[image]

Revit 2010 API
DemandFactorDataSetIterator..::.Current Property
DemandFactorDataSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DemandFactorDataSetIterator Class
Autodesk.Revit.MEP Namespace


DistributionSysType Class

[image]

Revit 2010 API
DistributionSysType Class
Members See Also Send Feedback
Represents a specific type of distribution system.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DistributionSysType : Symbol
Visual Basic (Declaration)
Public Class DistributionSysType _
    Inherits Symbol
Visual C++
public ref class DistributionSysType : public Symbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.DistributionSysType

See Also

DistributionSysType Members
Autodesk.Revit.MEP Namespace


DistributionSysType Members

[image] [image]

Revit 2010 API
DistributionSysType Members
DistributionSysType Class Constructors Methods Properties See Also Send Feedback

The DistributionSysType type exposes the following members.

Constructors

Name | Description
DistributionSysType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ElectricalPhase | Get or set electrical phase (single, triple or undefined) of distribution system.
ElectricalPhaseConfiguration | Get or set electrical phase configuration (Y, delta or undefined) of distribution system.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInUse | Get the value which indicates whether this distribution system is in service now.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
NumWires | Get or set number of wires of distribution system.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
VoltageLineToGround | Get or set line to ground voltage of distribution system type.
VoltageLineToLine | Get or set line to line voltage type of distribution system type.

See Also

DistributionSysType Class
Autodesk.Revit.MEP Namespace


DistributionSysType Constructor

[image]

Revit 2010 API
DistributionSysType Constructor
DistributionSysType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DistributionSysType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DistributionSysType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DistributionSysType Class
Autodesk.Revit.MEP Namespace


DistributionSysType Methods

[image] [image]

Revit 2010 API
DistributionSysType Methods
DistributionSysType Class See Also Send Feedback

The DistributionSysType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistributionSysType Class
Autodesk.Revit.MEP Namespace


DistributionSysType Properties

[image] [image]

Revit 2010 API
DistributionSysType Properties
DistributionSysType Class See Also Send Feedback

The DistributionSysType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ElectricalPhase | Get or set electrical phase (single, triple or undefined) of distribution system.
ElectricalPhaseConfiguration | Get or set electrical phase configuration (Y, delta or undefined) of distribution system.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInUse | Get the value which indicates whether this distribution system is in service now.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
NumWires | Get or set number of wires of distribution system.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
VoltageLineToGround | Get or set line to ground voltage of distribution system type.
VoltageLineToLine | Get or set line to line voltage type of distribution system type.

See Also

DistributionSysType Class
Autodesk.Revit.MEP Namespace


ElectricalPhase Property

[image]

Revit 2010 API
DistributionSysType..::.ElectricalPhase Property
DistributionSysType Class See Also Send Feedback
Get or set electrical phase (single, triple or undefined) of distribution system.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElectricalPhase ElectricalPhase { get; set; }
Visual Basic (Declaration)
Public Property ElectricalPhase As ElectricalPhase
Visual C++
public:
property ElectricalPhase ElectricalPhase {
    ElectricalPhase get ();
    void set (ElectricalPhase value);
}

See Also

DistributionSysType Class
Autodesk.Revit.MEP Namespace


ElectricalPhaseConfiguration Property

[image]

Revit 2010 API
DistributionSysType..::.ElectricalPhaseConfiguration Property
DistributionSysType Class See Also Send Feedback
Get or set electrical phase configuration (Y, delta or undefined) of distribution system.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElectricalPhaseConfiguration ElectricalPhaseConfiguration { get; set; }
Visual Basic (Declaration)
Public Property ElectricalPhaseConfiguration As ElectricalPhaseConfiguration
Visual C++
public:
property ElectricalPhaseConfiguration ElectricalPhaseConfiguration {
    ElectricalPhaseConfiguration get ();
    void set (ElectricalPhaseConfiguration value);
}

See Also

DistributionSysType Class
Autodesk.Revit.MEP Namespace


IsInUse Property

[image]

Revit 2010 API
DistributionSysType..::.IsInUse Property
DistributionSysType Class See Also Send Feedback
Get the value which indicates whether this distribution system is in service now.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsInUse { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInUse As Boolean
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

DistributionSysType Class
Autodesk.Revit.MEP Namespace


NumWires Property

[image]

Revit 2010 API
DistributionSysType..::.NumWires Property
DistributionSysType Class See Also Send Feedback
Get or set number of wires of distribution system.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NumWires { get; set; }
Visual Basic (Declaration)
Public Property NumWires As Integer
Visual C++
public:
property int NumWires {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | While assign a negative value to NumWires.

See Also

DistributionSysType Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
DistributionSysType..::.Parameter Property
DistributionSysType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DistributionSysType Class
DistributionSysType Members
Autodesk.Revit.MEP Namespace


VoltageLineToGround Property

[image]

Revit 2010 API
DistributionSysType..::.VoltageLineToGround Property
DistributionSysType Class See Also Send Feedback
Get or set line to ground voltage of distribution system type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public VoltageType VoltageLineToGround { get; set; }
Visual Basic (Declaration)
Public Property VoltageLineToGround As VoltageType
Visual C++
public:
property VoltageType^ VoltageLineToGround {
    VoltageType^ get ();
    void set (VoltageType^ value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | The voltage retrieved here is read only and actions to modify its properties it will throw an System.InvalidOperationException.

See Also

DistributionSysType Class
Autodesk.Revit.MEP Namespace


VoltageLineToLine Property

[image]

Revit 2010 API
DistributionSysType..::.VoltageLineToLine Property
DistributionSysType Class See Also Send Feedback
Get or set line to line voltage type of distribution system type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public VoltageType VoltageLineToLine { get; set; }
Visual Basic (Declaration)
Public Property VoltageLineToLine As VoltageType
Visual C++
public:
property VoltageType^ VoltageLineToLine {
    VoltageType^ get ();
    void set (VoltageType^ value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | The voltage retrieved here is read only and actions to modify its properties it will throw an System.InvalidOperationException.

See Also

DistributionSysType Class
Autodesk.Revit.MEP Namespace


DistributionSysTypeSet Class

[image]

Revit 2010 API
DistributionSysTypeSet Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DistributionSysTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class DistributionSysTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DistributionSysTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.DistributionSysTypeSet

See Also

DistributionSysTypeSet Members
Autodesk.Revit.MEP Namespace


DistributionSysTypeSet Members

[image] [image]

Revit 2010 API
DistributionSysTypeSet Members
DistributionSysTypeSet Class Constructors Methods Properties See Also Send Feedback

The DistributionSysTypeSet type exposes the following members.

Constructors

Name | Description
DistributionSysTypeSet | Initializes a new instance of the DistributionSysTypeSet class

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

DistributionSysTypeSet Class
Autodesk.Revit.MEP Namespace


DistributionSysTypeSet Constructor

[image]

Revit 2010 API
DistributionSysTypeSet Constructor
DistributionSysTypeSet Class See Also Send Feedback
Initializes a new instance of the DistributionSysTypeSet class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DistributionSysTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DistributionSysTypeSet()

See Also

DistributionSysTypeSet Class
Autodesk.Revit.MEP Namespace


DistributionSysTypeSet Methods

[image] [image]

Revit 2010 API
DistributionSysTypeSet Methods
DistributionSysTypeSet Class See Also Send Feedback

The DistributionSysTypeSet type exposes the following members.

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistributionSysTypeSet Class
Autodesk.Revit.MEP Namespace


Clear Method

[image]

Revit 2010 API
DistributionSysTypeSet..::.Clear Method
DistributionSysTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DistributionSysTypeSet Class
Autodesk.Revit.MEP Namespace


Contains Method

[image]

Revit 2010 API
DistributionSysTypeSet..::.Contains Method
DistributionSysTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    DistributionSysType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As DistributionSysType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    DistributionSysType^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.DistributionSysType

See Also

DistributionSysTypeSet Class
Autodesk.Revit.MEP Namespace


Erase Method

[image]

Revit 2010 API
DistributionSysTypeSet..::.Erase Method
DistributionSysTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    DistributionSysType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As DistributionSysType _
) As Integer
Visual C++
public:
virtual int Erase(
    DistributionSysType^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.DistributionSysType

See Also

DistributionSysTypeSet Class
Autodesk.Revit.MEP Namespace


ForwardIterator Method

[image]

Revit 2010 API
DistributionSysTypeSet..::.ForwardIterator Method
DistributionSysTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DistributionSysTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DistributionSysTypeSetIterator
Visual C++
public:
virtual DistributionSysTypeSetIterator^ ForwardIterator()

See Also

DistributionSysTypeSet Class
Autodesk.Revit.MEP Namespace


GetEnumerator Method

[image]

Revit 2010 API
DistributionSysTypeSet..::.GetEnumerator Method
DistributionSysTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DistributionSysTypeSet Class
Autodesk.Revit.MEP Namespace


Insert Method

[image]

Revit 2010 API
DistributionSysTypeSet..::.Insert Method
DistributionSysTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    DistributionSysType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As DistributionSysType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    DistributionSysType^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.DistributionSysType

See Also

DistributionSysTypeSet Class
Autodesk.Revit.MEP Namespace


ReverseIterator Method

[image]

Revit 2010 API
DistributionSysTypeSet..::.ReverseIterator Method
DistributionSysTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DistributionSysTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DistributionSysTypeSetIterator
Visual C++
public:
virtual DistributionSysTypeSetIterator^ ReverseIterator()

See Also

DistributionSysTypeSet Class
Autodesk.Revit.MEP Namespace


DistributionSysTypeSet Properties

[image] [image]

Revit 2010 API
DistributionSysTypeSet Properties
DistributionSysTypeSet Class See Also Send Feedback

The DistributionSysTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

DistributionSysTypeSet Class
Autodesk.Revit.MEP Namespace


IsEmpty Property

[image]

Revit 2010 API
DistributionSysTypeSet..::.IsEmpty Property
DistributionSysTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

DistributionSysTypeSet Class
Autodesk.Revit.MEP Namespace


Size Property

[image]

Revit 2010 API
DistributionSysTypeSet..::.Size Property
DistributionSysTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DistributionSysTypeSet Class
Autodesk.Revit.MEP Namespace


DistributionSysTypeSetIterator Class

[image]

Revit 2010 API
DistributionSysTypeSetIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class DistributionSysTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class DistributionSysTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DistributionSysTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.DistributionSysTypeSetIterator

See Also

DistributionSysTypeSetIterator Members
Autodesk.Revit.MEP Namespace


DistributionSysTypeSetIterator Members

[image] [image]

Revit 2010 API
DistributionSysTypeSetIterator Members
DistributionSysTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The DistributionSysTypeSetIterator type exposes the following members.

Constructors

Name | Description
DistributionSysTypeSetIterator | Initializes a new instance of the DistributionSysTypeSetIterator class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.MEP Namespace


DistributionSysTypeSetIterator Constructor

[image]

Revit 2010 API
DistributionSysTypeSetIterator Constructor
DistributionSysTypeSetIterator Class See Also Send Feedback
Initializes a new instance of the DistributionSysTypeSetIterator class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DistributionSysTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DistributionSysTypeSetIterator()

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.MEP Namespace


DistributionSysTypeSetIterator Methods

[image] [image]

Revit 2010 API
DistributionSysTypeSetIterator Methods
DistributionSysTypeSetIterator Class See Also Send Feedback

The DistributionSysTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.MEP Namespace


MoveNext Method

[image]

Revit 2010 API
DistributionSysTypeSetIterator..::.MoveNext Method
DistributionSysTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::.MoveNext()()()

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.MEP Namespace


Reset Method

[image]

Revit 2010 API
DistributionSysTypeSetIterator..::.Reset Method
DistributionSysTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.MEP Namespace


DistributionSysTypeSetIterator Properties

[image] [image]

Revit 2010 API
DistributionSysTypeSetIterator Properties
DistributionSysTypeSetIterator Class See Also Send Feedback

The DistributionSysTypeSetIterator type exposes the following members.

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.MEP Namespace


Current Property

[image]

Revit 2010 API
DistributionSysTypeSetIterator..::.Current Property
DistributionSysTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.MEP Namespace


Duct Class

[image]

Revit 2010 API
Duct Class
Members See Also Send Feedback
A duct in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Duct : MEPCurve
Visual Basic (Declaration)
Public Class Duct _
    Inherits MEPCurve
Visual C++
public ref class Duct : public MEPCurve

Remarks

The duct is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.MEP..::.MEPCurve
Autodesk.Revit.MEP..::.Duct

See Also

Duct Members
Autodesk.Revit.MEP Namespace


Duct Members

[image] [image]

Revit 2010 API
Duct Members
Duct Class Constructors Methods Properties See Also Send Feedback

The Duct type exposes the following members.

Constructors

Name | Description
Duct | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
DuctType | The duct type of this duct.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

Duct Class
Autodesk.Revit.MEP Namespace


Duct Constructor

[image]

Revit 2010 API
Duct Constructor
Duct Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Duct()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Duct()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Duct Class
Autodesk.Revit.MEP Namespace


Duct Methods

[image] [image]

Revit 2010 API
Duct Methods
Duct Class See Also Send Feedback

The Duct type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Duct Class
Autodesk.Revit.MEP Namespace


Duct Properties

[image] [image]

Revit 2010 API
Duct Properties
Duct Class See Also Send Feedback

The Duct type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
DuctType | The duct type of this duct.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

Duct Class
Autodesk.Revit.MEP Namespace


DuctType Property

[image]

Revit 2010 API
Duct..::.DuctType Property
Duct Class See Also Send Feedback
The duct type of this duct.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DuctType DuctType { get; set; }
Visual Basic (Declaration)
Public Property DuctType As DuctType
Visual C++
public:
property DuctType^ DuctType {
    DuctType^ get ();
    void set (DuctType^ value);
}

See Also

Duct Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
Duct..::.Parameter Property
Duct Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Duct Class
Duct Members
Autodesk.Revit.MEP Namespace


DuctConnector Class

[image]

Revit 2010 API
DuctConnector Class
Members See Also Send Feedback
A duct connector that is assigned to a mechanical equipment or duct fitting family. Provides access to the duct connector in Autodesk Revit MEP family document.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DuctConnector : Element,
    IConnector
Visual Basic (Declaration)
Public Class DuctConnector _
    Inherits Element _
    Implements IConnector
Visual C++
public ref class DuctConnector : public Element,
    IConnector

Remarks

This element type is accessible only in Autodek Revit MEP family documents. Duct connectors that accessible in MEP project documents are not elements, and are represented by Autodesk::Revit::MEP::Connector.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.MEP..::.DuctConnector

See Also

DuctConnector Members
Autodesk.Revit.MEP Namespace


DuctConnector Members

[image] [image]

Revit 2010 API
DuctConnector Members
DuctConnector Class Constructors Methods Properties See Also Send Feedback

The DuctConnector type exposes the following members.

Constructors

Name | Description
DuctConnector | For internal use only.

Methods

Name | Description
AssignAsPrimary | Assign a duct connector as a primary duct connector.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoordinateSystem | The coordinate system of the connector within the family.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Domain | The domain of the connector.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Height | The height of the connector.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsPrimary | Identifies if this is the primary connector in the family.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LinkedConnector | The linked duct connector.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Origin | The location of the connector in family document.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Radius | the radius of the connector.
Shape | The shape of the connector.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SystemType | The system type of the duct connector.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Width | The width of the connector.

See Also

DuctConnector Class
Autodesk.Revit.MEP Namespace


DuctConnector Constructor

[image]

Revit 2010 API
DuctConnector Constructor
DuctConnector Class See Also Send Feedback
For internal use only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DuctConnector()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DuctConnector()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DuctConnector Class
Autodesk.Revit.MEP Namespace


DuctConnector Methods

[image] [image]

Revit 2010 API
DuctConnector Methods
DuctConnector Class See Also Send Feedback

The DuctConnector type exposes the following members.

Methods

Name | Description
AssignAsPrimary | Assign a duct connector as a primary duct connector.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DuctConnector Class
Autodesk.Revit.MEP Namespace


AssignAsPrimary Method

[image]

Revit 2010 API
DuctConnector..::.AssignAsPrimary Method
DuctConnector Class See Also Send Feedback
Assign a duct connector as a primary duct connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AssignAsPrimary()
Visual Basic (Declaration)
Public Sub AssignAsPrimary
Visual C++
public:
void AssignAsPrimary()

Remarks

This method is used to promote this duct connector as primary, and the rest of connectors in this system will be assigned as secondary.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when fail to assign this connector as primary.

See Also

DuctConnector Class
Autodesk.Revit.MEP Namespace


DuctConnector Properties

[image] [image]

Revit 2010 API
DuctConnector Properties
DuctConnector Class See Also Send Feedback

The DuctConnector type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoordinateSystem | The coordinate system of the connector within the family.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Domain | The domain of the connector.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Height | The height of the connector.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsPrimary | Identifies if this is the primary connector in the family.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LinkedConnector | The linked duct connector.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Origin | The location of the connector in family document.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Radius | the radius of the connector.
Shape | The shape of the connector.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SystemType | The system type of the duct connector.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Width | The width of the connector.

See Also

DuctConnector Class
Autodesk.Revit.MEP Namespace


CoordinateSystem Property

[image]

Revit 2010 API
DuctConnector..::.CoordinateSystem Property
DuctConnector Class See Also Send Feedback
The coordinate system of the connector within the family.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Transform CoordinateSystem { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property CoordinateSystem As Transform
Visual C++
public:
virtual property Transform^ CoordinateSystem {
    Transform^ get ();
}

Implements

IConnector..::.CoordinateSystem

Remarks

The Z axis of the coordinate system is the normal to the plane of the connector.

See Also

DuctConnector Class
Autodesk.Revit.MEP Namespace


Domain Property

[image]

Revit 2010 API
DuctConnector..::.Domain Property
DuctConnector Class See Also Send Feedback
The domain of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Domain Domain { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Domain As Domain
Visual C++
public:
virtual property Domain Domain {
    Domain get ();
}

Implements

IConnector..::.Domain

Remarks

The domain of a duct connector is always DomainHvac.

See Also

DuctConnector Class
Autodesk.Revit.MEP Namespace


Height Property

[image]

Revit 2010 API
DuctConnector..::.Height Property
DuctConnector Class See Also Send Feedback
The height of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual double Height { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Height As Double
Visual C++
public:
virtual property double Height {
    double get ();
}

Implements

IConnector..::.Height

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the connector's shape is not rectangular.

See Also

DuctConnector Class
Autodesk.Revit.MEP Namespace


IsPrimary Property

[image]

Revit 2010 API
DuctConnector..::.IsPrimary Property
DuctConnector Class See Also Send Feedback
Identifies if this is the primary connector in the family.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsPrimary { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPrimary As Boolean
Visual C++
public:
property bool IsPrimary {
    bool get ();
}

See Also

DuctConnector Class
Autodesk.Revit.MEP Namespace


LinkedConnector Property

[image]

Revit 2010 API
DuctConnector..::.LinkedConnector Property
DuctConnector Class See Also Send Feedback
The linked duct connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DuctConnector LinkedConnector { get; set; }
Visual Basic (Declaration)
Public Property LinkedConnector As DuctConnector
Visual C++
public:
property DuctConnector^ LinkedConnector {
    DuctConnector^ get ();
    void set (DuctConnector^ value);
}

Remarks

Get this property to acquire the current linked duct connector. If the property is null, the connector has no link. Set this property to link this connector to another duct connector. Set it to null to remove the link.

See Also

DuctConnector Class
Autodesk.Revit.MEP Namespace


Origin Property

[image]

Revit 2010 API
DuctConnector..::.Origin Property
DuctConnector Class See Also Send Feedback
The location of the connector in family document.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual XYZ Origin { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Origin As XYZ
Visual C++
public:
virtual property XYZ^ Origin {
    XYZ^ get ();
}

Implements

IConnector..::.Origin

See Also

DuctConnector Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
DuctConnector..::.Parameter Property
DuctConnector Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DuctConnector Class
DuctConnector Members
Autodesk.Revit.MEP Namespace


Radius Property

[image]

Revit 2010 API
DuctConnector..::.Radius Property
DuctConnector Class See Also Send Feedback
the radius of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual double Radius { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Radius As Double
Visual C++
public:
virtual property double Radius {
    double get ();
}

Implements

IConnector..::.Radius

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the connector's shape is not circular.

See Also

DuctConnector Class
Autodesk.Revit.MEP Namespace


Shape Property

[image]

Revit 2010 API
DuctConnector..::.Shape Property
DuctConnector Class See Also Send Feedback
The shape of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ConnectorProfileType Shape { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Shape As ConnectorProfileType
Visual C++
public:
virtual property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}

Implements

IConnector..::.Shape

See Also

DuctConnector Class
Autodesk.Revit.MEP Namespace


SystemType Property

[image]

Revit 2010 API
DuctConnector..::.SystemType Property
DuctConnector Class See Also Send Feedback
The system type of the duct connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DuctSystemType SystemType { get; set; }
Visual Basic (Declaration)
Public Property SystemType As DuctSystemType
Visual C++
public:
property DuctSystemType SystemType {
    DuctSystemType get ();
    void set (DuctSystemType value);
}

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the input system type is not within the permitted range.

See Also

DuctConnector Class
Autodesk.Revit.MEP Namespace


Width Property

[image]

Revit 2010 API
DuctConnector..::.Width Property
DuctConnector Class See Also Send Feedback
The width of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual double Width { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Width As Double
Visual C++
public:
virtual property double Width {
    double get ();
}

Implements

IConnector..::.Width

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the connector's shape is not rectangular.

See Also

DuctConnector Class
Autodesk.Revit.MEP Namespace


DuctType Class

[image]

Revit 2010 API
DuctType Class
Members See Also Send Feedback
A duct type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DuctType : MEPCurveType
Visual Basic (Declaration)
Public Class DuctType _
    Inherits MEPCurveType
Visual C++
public ref class DuctType : public MEPCurveType

Remarks

The duct type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.MEPCurveType
Autodesk.Revit.MEP..::.DuctType

See Also

DuctType Members
Autodesk.Revit.MEP Namespace


DuctType Members

[image] [image]

Revit 2010 API
DuctType Members
DuctType Class Constructors Methods Properties See Also Send Feedback

The DuctType type exposes the following members.

Constructors

Name | Description
DuctType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Roughness | The roughness of the MEP curve type. (Inherited from MEPCurveType.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DuctType Class
Autodesk.Revit.MEP Namespace


DuctType Constructor

[image]

Revit 2010 API
DuctType Constructor
DuctType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DuctType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DuctType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DuctType Class
Autodesk.Revit.MEP Namespace


DuctType Methods

[image] [image]

Revit 2010 API
DuctType Methods
DuctType Class See Also Send Feedback

The DuctType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DuctType Class
Autodesk.Revit.MEP Namespace


DuctType Properties

[image] [image]

Revit 2010 API
DuctType Properties
DuctType Class See Also Send Feedback

The DuctType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Roughness | The roughness of the MEP curve type. (Inherited from MEPCurveType.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DuctType Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
DuctType..::.Parameter Property
DuctType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DuctType Class
DuctType Members
Autodesk.Revit.MEP Namespace


ElectricalConnector Class

[image]

Revit 2010 API
ElectricalConnector Class
Members See Also Send Feedback
An electrical connector that is assigned to an electrical equipment or device family. Provides access to the electrical connector in Autodesk Revit MEP family document.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ElectricalConnector : Element,
    IConnector
Visual Basic (Declaration)
Public Class ElectricalConnector _
    Inherits Element _
    Implements IConnector
Visual C++
public ref class ElectricalConnector : public Element,
    IConnector

Remarks

This element type is accessible only in Autodek Revit MEP family documents. Electrical connectors that accessible in MEP project documents are not elements, and are represented by Autodesk::Revit::MEP::Connector.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.MEP..::.ElectricalConnector

See Also

ElectricalConnector Members
Autodesk.Revit.MEP Namespace


ElectricalConnector Members

[image] [image]

Revit 2010 API
ElectricalConnector Members
ElectricalConnector Class Constructors Methods Properties See Also Send Feedback

The ElectricalConnector type exposes the following members.

Constructors

Name | Description
ElectricalConnector | For internal sse only.

Methods

Name | Description
AssignAsPrimary | Assign an electrical connector as a primary electrical connector.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoordinateSystem | The coordinate system of the connector.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Domain | The domain of the connector.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Height | The height of the connector.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsPrimary | Indicates if the connector is primary or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Origin | The location of the connector in family document.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Radius | The radius of the connector.
Shape | The shape of the connector.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SystemType | The system type of the connector.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Width | The width of the connector.

See Also

ElectricalConnector Class
Autodesk.Revit.MEP Namespace


ElectricalConnector Constructor

[image]

Revit 2010 API
ElectricalConnector Constructor
ElectricalConnector Class See Also Send Feedback
For internal sse only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElectricalConnector()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElectricalConnector()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElectricalConnector Class
Autodesk.Revit.MEP Namespace


ElectricalConnector Methods

[image] [image]

Revit 2010 API
ElectricalConnector Methods
ElectricalConnector Class See Also Send Feedback

The ElectricalConnector type exposes the following members.

Methods

Name | Description
AssignAsPrimary | Assign an electrical connector as a primary electrical connector.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalConnector Class
Autodesk.Revit.MEP Namespace


AssignAsPrimary Method

[image]

Revit 2010 API
ElectricalConnector..::.AssignAsPrimary Method
ElectricalConnector Class See Also Send Feedback
Assign an electrical connector as a primary electrical connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AssignAsPrimary()
Visual Basic (Declaration)
Public Sub AssignAsPrimary
Visual C++
public:
void AssignAsPrimary()

Remarks

This method is used to promote this electrical connector as primary, and the rest of connectors in this system will be assigned as secondary.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when fail to assign this connector as primary.

See Also

ElectricalConnector Class
Autodesk.Revit.MEP Namespace


ElectricalConnector Properties

[image] [image]

Revit 2010 API
ElectricalConnector Properties
ElectricalConnector Class See Also Send Feedback

The ElectricalConnector type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoordinateSystem | The coordinate system of the connector.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Domain | The domain of the connector.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Height | The height of the connector.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsPrimary | Indicates if the connector is primary or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Origin | The location of the connector in family document.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Radius | The radius of the connector.
Shape | The shape of the connector.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SystemType | The system type of the connector.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Width | The width of the connector.

See Also

ElectricalConnector Class
Autodesk.Revit.MEP Namespace


CoordinateSystem Property

[image]

Revit 2010 API
ElectricalConnector..::.CoordinateSystem Property
ElectricalConnector Class See Also Send Feedback
The coordinate system of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Transform CoordinateSystem { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property CoordinateSystem As Transform
Visual C++
public:
virtual property Transform^ CoordinateSystem {
    Transform^ get ();
}

Implements

IConnector..::.CoordinateSystem

Remarks

This property is used to retrieve the coordinate system of the connector.

See Also

ElectricalConnector Class
Autodesk.Revit.MEP Namespace


Domain Property

[image]

Revit 2010 API
ElectricalConnector..::.Domain Property
ElectricalConnector Class See Also Send Feedback
The domain of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Domain Domain { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Domain As Domain
Visual C++
public:
virtual property Domain Domain {
    Domain get ();
}

Implements

IConnector..::.Domain

Remarks

The Z axis of the coordinate system is the normal to the plane of the connector.

See Also

ElectricalConnector Class
Autodesk.Revit.MEP Namespace


Height Property

[image]

Revit 2010 API
ElectricalConnector..::.Height Property
ElectricalConnector Class See Also Send Feedback
The height of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual double Height { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Height As Double
Visual C++
public:
virtual property double Height {
    double get ();
}

Implements

IConnector..::.Height

Remarks

no shape for electrical connector.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Always thrown because electrical connectors don't have a shape.

See Also

ElectricalConnector Class
Autodesk.Revit.MEP Namespace


IsPrimary Property

[image]

Revit 2010 API
ElectricalConnector..::.IsPrimary Property
ElectricalConnector Class See Also Send Feedback
Indicates if the connector is primary or not.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsPrimary { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPrimary As Boolean
Visual C++
public:
property bool IsPrimary {
    bool get ();
}

See Also

ElectricalConnector Class
Autodesk.Revit.MEP Namespace


Origin Property

[image]

Revit 2010 API
ElectricalConnector..::.Origin Property
ElectricalConnector Class See Also Send Feedback
The location of the connector in family document.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual XYZ Origin { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Origin As XYZ
Visual C++
public:
virtual property XYZ^ Origin {
    XYZ^ get ();
}

Implements

IConnector..::.Origin

See Also

ElectricalConnector Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
ElectricalConnector..::.Parameter Property
ElectricalConnector Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ElectricalConnector Class
ElectricalConnector Members
Autodesk.Revit.MEP Namespace


Radius Property

[image]

Revit 2010 API
ElectricalConnector..::.Radius Property
ElectricalConnector Class See Also Send Feedback
The radius of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual double Radius { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Radius As Double
Visual C++
public:
virtual property double Radius {
    double get ();
}

Implements

IConnector..::.Radius

Remarks

no shape for electrical connector.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Always thrown because electrical connectors don't have a shape.

See Also

ElectricalConnector Class
Autodesk.Revit.MEP Namespace


Shape Property

[image]

Revit 2010 API
ElectricalConnector..::.Shape Property
ElectricalConnector Class See Also Send Feedback
The shape of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ConnectorProfileType Shape { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Shape As ConnectorProfileType
Visual C++
public:
virtual property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}

Implements

IConnector..::.Shape

Remarks

no shape for electrical connector.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Always thrown because electrical connectors don't have a shape.

See Also

ElectricalConnector Class
Autodesk.Revit.MEP Namespace


SystemType Property

[image]

Revit 2010 API
ElectricalConnector..::.SystemType Property
ElectricalConnector Class See Also Send Feedback
The system type of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElectricalSystemType SystemType { get; set; }
Visual Basic (Declaration)
Public Property SystemType As ElectricalSystemType
Visual C++
public:
property ElectricalSystemType SystemType {
    ElectricalSystemType get ();
    void set (ElectricalSystemType value);
}

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the system type is out of the permitted range of values.

See Also

ElectricalConnector Class
Autodesk.Revit.MEP Namespace


Width Property

[image]

Revit 2010 API
ElectricalConnector..::.Width Property
ElectricalConnector Class See Also Send Feedback
The width of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual double Width { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Width As Double
Visual C++
public:
virtual property double Width {
    double get ();
}

Implements

IConnector..::.Width

Remarks

no shape for electrical connector.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Always thrown because electrical connectors don't have a shape.

See Also

ElectricalConnector Class
Autodesk.Revit.MEP Namespace


ElectricalEquipment Class

[image]

Revit 2010 API
ElectricalEquipment Class
Members See Also Send Feedback
Provides access to the Electrical Equipment in Autodesk Revit MEP.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ElectricalEquipment : MEPModel
Visual Basic (Declaration)
Public Class ElectricalEquipment _
    Inherits MEPModel
Visual C++
public ref class ElectricalEquipment : public MEPModel

Remarks

The Electrical Equipment object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.MEPModel
Autodesk.Revit.MEP..::.ElectricalEquipment

See Also

ElectricalEquipment Members
Autodesk.Revit.MEP Namespace


ElectricalEquipment Members

[image] [image]

Revit 2010 API
ElectricalEquipment Members
ElectricalEquipment Class Constructors Methods Properties See Also Send Feedback

The ElectricalEquipment type exposes the following members.

Constructors

Name | Description
ElectricalEquipment | For Internal Use Only

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
DistributionSystem | get or set the Distribution System for the Electrical Equipment.
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElectricalEquipment Class
Autodesk.Revit.MEP Namespace


ElectricalEquipment Constructor

[image]

Revit 2010 API
ElectricalEquipment Constructor
ElectricalEquipment Class See Also Send Feedback
For Internal Use Only

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElectricalEquipment()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElectricalEquipment()

Remarks

This constructor is exposed to enable support for COM interopability only. This object should not be created by the developer.

See Also

ElectricalEquipment Class
Autodesk.Revit.MEP Namespace


ElectricalEquipment Methods

[image] [image]

Revit 2010 API
ElectricalEquipment Methods
ElectricalEquipment Class See Also Send Feedback

The ElectricalEquipment type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalEquipment Class
Autodesk.Revit.MEP Namespace


ElectricalEquipment Properties

[image] [image]

Revit 2010 API
ElectricalEquipment Properties
ElectricalEquipment Class See Also Send Feedback

The ElectricalEquipment type exposes the following members.

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
DistributionSystem | get or set the Distribution System for the Electrical Equipment.
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElectricalEquipment Class
Autodesk.Revit.MEP Namespace


DistributionSystem Property

[image]

Revit 2010 API
ElectricalEquipment..::.DistributionSystem Property
ElectricalEquipment Class See Also Send Feedback
get or set the Distribution System for the Electrical Equipment.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DistributionSysType DistributionSystem { get; set; }
Visual Basic (Declaration)
Public Property DistributionSystem As DistributionSysType
Visual C++
public:
property DistributionSysType^ DistributionSystem {
    DistributionSysType^ get ();
    void set (DistributionSysType^ value);
}

Remarks

This property returns a Distribution System which is assigned to the Electrical Equipment. If there are no Distribution System assigned to this Electrical Equipment, this property will be nullptr.

See Also

ElectricalEquipment Class
Autodesk.Revit.MEP Namespace


ElectricalSetting Class

[image]

Revit 2010 API
ElectricalSetting Class
Members See Also Send Feedback
An object that represents electrical information within the Autodesk Revit project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ElectricalSetting : APIObject
Visual Basic (Declaration)
Public Class ElectricalSetting _
    Inherits APIObject
Visual C++
public ref class ElectricalSetting : public APIObject

Remarks

ElectricalSetting includes voltage type, distribution system type, wire type, and demand factor setting. All basic operations of these electrical elements are supported.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.ElectricalSetting

See Also

ElectricalSetting Members
Autodesk.Revit.MEP Namespace


ElectricalSetting Members

[image] [image]

Revit 2010 API
ElectricalSetting Members
ElectricalSetting Class Constructors Methods Properties See Also Send Feedback

The ElectricalSetting type exposes the following members.

Constructors

Name | Description
ElectricalSetting | For Internal Use Only.

Methods

Name | Description
AddDistributionSysType | Add a new distribution system type to project.
AddVoltageType | Add a new type definition of voltage into project.
AddWireMaterialType | Add a new type of wire material.
AddWireType | Add a new wire type to project.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDemandFactor | Get demand factor information according to specified load classification.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
RemoveDistributionSysType | Remove an existing distribution system type from the project.
RemoveVoltageType | Remove the voltage type from project.
RemoveWireMaterialType | Remove the wire material type from project.
RemoveWireType | Remove wire type definition from project.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConduitTypes | Get electrical conduit types information of the project.
DistributionSysTypes | Get all distribution system types of the project.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
VoltageTypes | Get all voltage type definitions information of the project.
WireMaterialTypes | Get electrical wire material types information of the project.
WireTypes | Get all wire type definition information of the project.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


ElectricalSetting Constructor

[image]

Revit 2010 API
ElectricalSetting Constructor
ElectricalSetting Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElectricalSetting()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElectricalSetting()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


ElectricalSetting Methods

[image] [image]

Revit 2010 API
ElectricalSetting Methods
ElectricalSetting Class See Also Send Feedback

The ElectricalSetting type exposes the following members.

Methods

Name | Description
AddDistributionSysType | Add a new distribution system type to project.
AddVoltageType | Add a new type definition of voltage into project.
AddWireMaterialType | Add a new type of wire material.
AddWireType | Add a new wire type to project.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDemandFactor | Get demand factor information according to specified load classification.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
RemoveDistributionSysType | Remove an existing distribution system type from the project.
RemoveVoltageType | Remove the voltage type from project.
RemoveWireMaterialType | Remove the wire material type from project.
RemoveWireType | Remove wire type definition from project.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


AddDistributionSysType Method

[image]

Revit 2010 API
ElectricalSetting..::.AddDistributionSysType Method
ElectricalSetting Class See Also Send Feedback
Add a new distribution system type to project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DistributionSysType AddDistributionSysType(
    string name,
    ElectricalPhase phase,
    ElectricalPhaseConfiguration phaseConfig,
    int numWire,
    VoltageType volLineToLine,
    VoltageType volLineToGround
)
Visual Basic (Declaration)
Public Function AddDistributionSysType ( _
    name As String, _
    phase As ElectricalPhase, _
    phaseConfig As ElectricalPhaseConfiguration, _
    numWire As Integer, _
    volLineToLine As VoltageType, _
    volLineToGround As VoltageType _
) As DistributionSysType
Visual C++
public:
DistributionSysType^ AddDistributionSysType(
    String^ name,
    ElectricalPhase phase,
    ElectricalPhaseConfiguration phaseConfig,
    int numWire,
    VoltageType^ volLineToLine,
    VoltageType^ volLineToGround
)

Parameters

name
Type: System..::.String
The name of new added distribution system type
phase
Type: Autodesk.Revit.MEP.Enums..::.ElectricalPhase
Single or three phase this type is
phaseConfig
Type: Autodesk.Revit.MEP.Enums..::.ElectricalPhaseConfiguration
Configuration property of given phase
numWire
Type: System..::.Int32
Wire number of this distribution system
volLineToLine
Type: Autodesk.Revit.MEP..::.VoltageType
Type of line to line voltage in this system
volLineToGround
Type: Autodesk.Revit.MEP..::.VoltageType
Type of line to ground voltage in this system

Return Value

New added distribution system type object.

Exceptions

Exception | Condition
System..::.ArgumentException | The name can't be null, empty string, or equal with any existing one, phaseConfig should be defined and numWire can only be 3 or 4 in case of three phase, numWire can only be 2 or 3 in case of single phase, otherwise exception will be thrown.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


AddVoltageType Method

[image]

Revit 2010 API
ElectricalSetting..::.AddVoltageType Method
ElectricalSetting Class See Also Send Feedback
Add a new type definition of voltage into project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public VoltageType AddVoltageType(
    string name,
    double actualValue,
    double minValue,
    double maxValue
)
Visual Basic (Declaration)
Public Function AddVoltageType ( _
    name As String, _
    actualValue As Double, _
    minValue As Double, _
    maxValue As Double _
) As VoltageType
Visual C++
public:
VoltageType^ AddVoltageType(
    String^ name,
    double actualValue,
    double minValue,
    double maxValue
)

Parameters

name
Type: System..::.String
Specify voltage type name
actualValue
Type: System..::.Double
Specify actual value of voltage type.
minValue
Type: System..::.Double
Specify acceptable minimum value of the voltage type.
maxValue
Type: System..::.Double
Specify acceptable maximum value of the voltage type.

Return Value

New added voltage type object.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


AddWireMaterialType Method

[image]

Revit 2010 API
ElectricalSetting..::.AddWireMaterialType Method
ElectricalSetting Class See Also Send Feedback
Add a new type of wire material.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireMaterialType AddWireMaterialType(
    string name,
    WireMaterialType baseMaterial
)
Visual Basic (Declaration)
Public Function AddWireMaterialType ( _
    name As String, _
    baseMaterial As WireMaterialType _
) As WireMaterialType
Visual C++
public:
WireMaterialType^ AddWireMaterialType(
    String^ name,
    WireMaterialType^ baseMaterial
)

Parameters

name
Type: System..::.String
Name of new material type.
baseMaterial
Type: Autodesk.Revit.MEP..::.WireMaterialType
Specify an existing material type which New material will be constructed based on.

Return Value

New added wire material type object.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


AddWireType Method

[image]

Revit 2010 API
ElectricalSetting..::.AddWireType Method
ElectricalSetting Class See Also Send Feedback
Add a new wire type to project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireType AddWireType(
    string name,
    WireMaterialType materialType,
    TemperatureRatingType temperatureRating,
    InsulationType insulation,
    WireSize maxSize,
    double neutralMultiplier,
    bool neutralRequired,
    WireType..::.NeutralMode neutralMode,
    ConduitType conduit
)
Visual Basic (Declaration)
Public Function AddWireType ( _
    name As String, _
    materialType As WireMaterialType, _
    temperatureRating As TemperatureRatingType, _
    insulation As InsulationType, _
    maxSize As WireSize, _
    neutralMultiplier As Double, _
    neutralRequired As Boolean, _
    neutralMode As WireType..::.NeutralMode, _
    conduit As ConduitType _
) As WireType
Visual C++
public:
WireType^ AddWireType(
    String^ name,
    WireMaterialType^ materialType,
    TemperatureRatingType^ temperatureRating,
    InsulationType^ insulation,
    WireSize^ maxSize,
    double neutralMultiplier,
    bool neutralRequired,
    WireType..::.NeutralMode neutralMode,
    ConduitType^ conduit
)

Parameters

name
Type: System..::.String
Name of the new wire type.
materialType
Type: Autodesk.Revit.MEP..::.WireMaterialType
Wire material of new wire type.
temperatureRating
Type: Autodesk.Revit.MEP..::.TemperatureRatingType
Temperature rating type information of new wire type.
insulation
Type: Autodesk.Revit.MEP..::.InsulationType
Insulation of new wire type.
maxSize
Type: Autodesk.Revit.MEP..::.WireSize
Max wire size of new wire type.
neutralMultiplier
Type: System..::.Double
Neutral multiplier of new wire type.
neutralRequired
Type: System..::.Boolean
Specify whether neutral point is required.
neutralMode
Type: Autodesk.Revit.MEP..::.WireType..::.NeutralMode
Specify neutral mode.
conduit
Type: Autodesk.Revit.MEP..::.ConduitType
Conduit type of new wire type.

Return Value

New added wire type object.

Remarks

Param of temperatureRating should be retrieved from param of materialType, and params such as insulation, maxSize should be retrieved from temperatureRating. otherwise, this add operation is most likely to be failed.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


GetDemandFactor Method

[image]

Revit 2010 API
ElectricalSetting..::.GetDemandFactor Method
ElectricalSetting Class See Also Send Feedback
Get demand factor information according to specified load classification.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DemandFactor GetDemandFactor(
    LoadClassification loadClassification
)
Visual Basic (Declaration)
Public Function GetDemandFactor ( _
    loadClassification As LoadClassification _
) As DemandFactor
Visual C++
public:
DemandFactor^ GetDemandFactor(
    LoadClassification loadClassification
)

Parameters

loadClassification
Type: Autodesk.Revit.MEP.Enums..::.LoadClassification
Specify which category of demand factor will be retrieved.

Return Value

Demand factor object to define demand factor of specific load classification in a project.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


RemoveDistributionSysType Method

[image]

Revit 2010 API
ElectricalSetting..::.RemoveDistributionSysType Method
ElectricalSetting Class See Also Send Feedback
Remove an existing distribution system type from the project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveDistributionSysType(
    DistributionSysType distributionSysType
)
Visual Basic (Declaration)
Public Sub RemoveDistributionSysType ( _
    distributionSysType As DistributionSysType _
)
Visual C++
public:
void RemoveDistributionSysType(
    DistributionSysType^ distributionSysType
)

Parameters

distributionSysType
Type: Autodesk.Revit.MEP..::.DistributionSysType

Exceptions

Exception | Condition
System..::.InvalidOperationException | Distribution system type can be removed only if it is not currently assigned to any devices, otherwise an exception will be thrown.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


RemoveVoltageType Method

[image]

Revit 2010 API
ElectricalSetting..::.RemoveVoltageType Method
ElectricalSetting Class See Also Send Feedback
Remove the voltage type from project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveVoltageType(
    VoltageType voltageType
)
Visual Basic (Declaration)
Public Sub RemoveVoltageType ( _
    voltageType As VoltageType _
)
Visual C++
public:
void RemoveVoltageType(
    VoltageType^ voltageType
)

Parameters

voltageType
Type: Autodesk.Revit.MEP..::.VoltageType
Specify the voltage type to be removed.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Voltage type can be removed only if it isn't in service with any distribution systems.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


RemoveWireMaterialType Method

[image]

Revit 2010 API
ElectricalSetting..::.RemoveWireMaterialType Method
ElectricalSetting Class See Also Send Feedback
Remove the wire material type from project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveWireMaterialType(
    WireMaterialType materialType
)
Visual Basic (Declaration)
Public Sub RemoveWireMaterialType ( _
    materialType As WireMaterialType _
)
Visual C++
public:
void RemoveWireMaterialType(
    WireMaterialType^ materialType
)

Parameters

materialType
Type: Autodesk.Revit.MEP..::.WireMaterialType
The wire material type to be removed.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Wire material type can be removed only if it is not currently assigned to any wire type, and the last one wire material type can't be removed, otherwise an exception will be thrown.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


RemoveWireType Method

[image]

Revit 2010 API
ElectricalSetting..::.RemoveWireType Method
ElectricalSetting Class See Also Send Feedback
Remove wire type definition from project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveWireType(
    WireType wireType
)
Visual Basic (Declaration)
Public Sub RemoveWireType ( _
    wireType As WireType _
)
Visual C++
public:
void RemoveWireType(
    WireType^ wireType
)

Parameters

wireType
Type: Autodesk.Revit.MEP..::.WireType

Exceptions

Exception | Condition
System..::.InvalidOperationException | Wire type can be removed only if it is not used, otherwise an exception will be thrown.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


ElectricalSetting Properties

[image] [image]

Revit 2010 API
ElectricalSetting Properties
ElectricalSetting Class See Also Send Feedback

The ElectricalSetting type exposes the following members.

Properties

Name | Description
ConduitTypes | Get electrical conduit types information of the project.
DistributionSysTypes | Get all distribution system types of the project.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
VoltageTypes | Get all voltage type definitions information of the project.
WireMaterialTypes | Get electrical wire material types information of the project.
WireTypes | Get all wire type definition information of the project.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


ConduitTypes Property

[image]

Revit 2010 API
ElectricalSetting..::.ConduitTypes Property
ElectricalSetting Class See Also Send Feedback
Get electrical conduit types information of the project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ConduitTypeSet ConduitTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConduitTypes As ConduitTypeSet
Visual C++
public:
property ConduitTypeSet^ ConduitTypes {
    ConduitTypeSet^ get ();
}

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


DistributionSysTypes Property

[image]

Revit 2010 API
ElectricalSetting..::.DistributionSysTypes Property
ElectricalSetting Class See Also Send Feedback
Get all distribution system types of the project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DistributionSysTypeSet DistributionSysTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property DistributionSysTypes As DistributionSysTypeSet
Visual C++
public:
property DistributionSysTypeSet^ DistributionSysTypes {
    DistributionSysTypeSet^ get ();
}

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


VoltageTypes Property

[image]

Revit 2010 API
ElectricalSetting..::.VoltageTypes Property
ElectricalSetting Class See Also Send Feedback
Get all voltage type definitions information of the project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public VoltageTypeSet VoltageTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property VoltageTypes As VoltageTypeSet
Visual C++
public:
property VoltageTypeSet^ VoltageTypes {
    VoltageTypeSet^ get ();
}

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


WireMaterialTypes Property

[image]

Revit 2010 API
ElectricalSetting..::.WireMaterialTypes Property
ElectricalSetting Class See Also Send Feedback
Get electrical wire material types information of the project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireMaterialTypeSet WireMaterialTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property WireMaterialTypes As WireMaterialTypeSet
Visual C++
public:
property WireMaterialTypeSet^ WireMaterialTypes {
    WireMaterialTypeSet^ get ();
}

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


WireTypes Property

[image]

Revit 2010 API
ElectricalSetting..::.WireTypes Property
ElectricalSetting Class See Also Send Feedback
Get all wire type definition information of the project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireTypeSet WireTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property WireTypes As WireTypeSet
Visual C++
public:
property WireTypeSet^ WireTypes {
    WireTypeSet^ get ();
}

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace


ElectricalSystem Class

[image]

Revit 2010 API
ElectricalSystem Class
Members See Also Send Feedback
Provides access to the Electrical System in Autodesk Revit MEP.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ElectricalSystem : MEPSystem
Visual Basic (Declaration)
Public Class ElectricalSystem _
    Inherits MEPSystem
Visual C++
public ref class ElectricalSystem : public MEPSystem

Remarks

The Electrical System object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.MEP..::.MEPSystem
Autodesk.Revit.MEP..::.ElectricalSystem

See Also

ElectricalSystem Members
Autodesk.Revit.MEP Namespace


ElectricalSystem Members

[image] [image]

Revit 2010 API
ElectricalSystem Members
ElectricalSystem Class Constructors Methods Properties See Also Send Feedback

The ElectricalSystem type exposes the following members.

Constructors

Name | Description
ElectricalSystem | For Internal Use Only.

Methods

Name | Description
Add | Add elements into the system and connect them with the system using given connectors. (Inherited from MEPSystem.)
AddToCircuit | Add a set of exist components to the Electrical System.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
DisconnectPanel | Disconnect the panel for the Electrical System.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
NewWires | Create a bunch of wires for the electrical system.
Remove | Remove elements from system. (Inherited from MEPSystem.)
RemoveFromCircuit | remove a set of exist components from the Electrical System.
SelectPanel | Set the panel for the Electrical System.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApparentCurrent | Returns the ApparentCurrent value of the Electrical System.
ApparentCurrentPhaseA | Returns the ApparentCurrentPhaseA value of the Electrical System.
ApparentCurrentPhaseB | Returns the ApparentCurrentPhaseB value of the Electrical System.
ApparentCurrentPhaseC | Returns the ApparentCurrentPhaseC value of the Electrical System.
ApparentLoad | Returns the ApparentLoad value of the Electrical System.
ApparentLoadPhaseA | Returns the ApparentLoadPhaseA value of the Electrical System.
ApparentLoadPhaseB | Returns the ApparentLoadPhaseB value of the Electrical System.
ApparentLoadPhaseC | Returns the ApparentLoadPhaseC value of the Electrical System.
BalancedLoad | Reports whether the BalancedLoad is on or off.
BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
BaseEquipmentConnector | The connector within base equipment which is used to connect with system. (Inherited from MEPSystem.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CircuitNumber | Returns the CircuitNumber of the Electrical System.
ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GroundConductorsNumber | Returns the GroundConductors Number of the Electrical System.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HotConductorsNumber | Returns the HotConductors Number of the Electrical System.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | Returns the Length value of the Electrical System.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadClassification | Returns the LoadClassification Type of the Electrical System.
LoadName | Get/Set the LoadName of the Electrical System.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns the Name of the Electrical System. (Overrides Element..::.Name.)
NeutralConductorsNumber | Returns the NeutralConductors Number of the Electrical System.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
PanelName | Returns the Panel name of the Electrical System.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PolesNumber | Returns the Poles Number of the Electrical System.
PowerFactor | Returns the PowerFactor value of the Electrical System.
PowerFactorState | Returns the PowerFactorState type of the Electrical System.
Rating | Get/Set the Rating value of the Electrical System.
RunsNumber | Returns the Runs Number of the Electrical System.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SystemType | Returns the Electrical System Type of the Electrical System.
TrueCurrent | Returns the TrueCurrent value of the Electrical System.
TrueCurrentPhaseA | Returns the TrueCurrentPhaseA value of the Electrical System.
TrueCurrentPhaseB | Returns the TrueCurrentPhaseB value of the Electrical System.
TrueCurrentPhaseC | Returns the TrueCurrentPhaseC value of the Electrical System.
TrueLoad | Returns the TrueLoad value of the Electrical System.
TrueLoadPhaseA | Returns the TrueLoadPhaseA value of the Electrical System.
TrueLoadPhaseB | Returns the TrueLoadPhaseB value of the Electrical System.
TrueLoadPhaseC | Returns the TrueLoadPhaseC value of the Electrical System.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Voltage | Returns the Voltage value of the Electrical System.
VoltageDrop | Returns the VoltageDrop value of the Electrical System.
WireSizeString | Returns the WireSize as a String of the Electrical System.
WireType | Get/Set the wire type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


ElectricalSystem Constructor

[image]

Revit 2010 API
ElectricalSystem Constructor
ElectricalSystem Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElectricalSystem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElectricalSystem()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


ElectricalSystem Methods

[image] [image]

Revit 2010 API
ElectricalSystem Methods
ElectricalSystem Class See Also Send Feedback

The ElectricalSystem type exposes the following members.

Methods

Name | Description
Add | Add elements into the system and connect them with the system using given connectors. (Inherited from MEPSystem.)
AddToCircuit | Add a set of exist components to the Electrical System.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
DisconnectPanel | Disconnect the panel for the Electrical System.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
NewWires | Create a bunch of wires for the electrical system.
Remove | Remove elements from system. (Inherited from MEPSystem.)
RemoveFromCircuit | remove a set of exist components from the Electrical System.
SelectPanel | Set the panel for the Electrical System.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


AddToCircuit Method

[image]

Revit 2010 API
ElectricalSystem..::.AddToCircuit Method
ElectricalSystem Class See Also Send Feedback
Add a set of exist components to the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool AddToCircuit(
    ElementSet components
)
Visual Basic (Declaration)
Public Function AddToCircuit ( _
    components As ElementSet _
) As Boolean
Visual C++
public:
bool AddToCircuit(
    ElementSet^ components
)

Parameters

components
Type: Autodesk.Revit..::.ElementSet
The components added to the electrical system.

Return Value

If successful, all the components will add to the system. Otherwise nothing is returned.

Remarks

This method will only function with the Autodesk Revit MEP application.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


DisconnectPanel Method

[image]

Revit 2010 API
ElectricalSystem..::.DisconnectPanel Method
ElectricalSystem Class See Also Send Feedback
Disconnect the panel for the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void DisconnectPanel()
Visual Basic (Declaration)
Public Sub DisconnectPanel
Visual C++
public:
void DisconnectPanel()

Remarks

If successful, the system will disconnect this panel. Otherwise the exception will be thrown. This method will only function with the Autodesk Revit MEP application.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the panel parameter Value is null.
System..::.InvalidOperationException | Thrown when the panel cannot be disconnected for the electrical system.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


NewWires Method

[image]

Revit 2010 API
ElectricalSystem..::.NewWires Method
ElectricalSystem Class See Also Send Feedback
Create a bunch of wires for the electrical system.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireSet NewWires(
    View view,
    WiringType wiringType
)
Visual Basic (Declaration)
Public Function NewWires ( _
    view As View, _
    wiringType As WiringType _
) As WireSet
Visual C++
public:
WireSet^ NewWires(
    View^ view,
    WiringType wiringType
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the wire is to be visible.
wiringType
Type: Autodesk.Revit.MEP.Enums..::.WiringType
Specify the wiring type(Arc or Chamfer) that is to be applied to all new created wires.

Return Value

New created wires

Exceptions

Exception | Condition
System..::.ArgumentException | This method can just only be used to created a bunch of wires according to specific pairs of elements, so if there exists null element in any pair of familyInstancePairs, the exception will be thrown.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


RemoveFromCircuit Method

[image]

Revit 2010 API
ElectricalSystem..::.RemoveFromCircuit Method
ElectricalSystem Class See Also Send Feedback
remove a set of exist components from the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveFromCircuit(
    ElementSet components
)
Visual Basic (Declaration)
Public Sub RemoveFromCircuit ( _
    components As ElementSet _
)
Visual C++
public:
void RemoveFromCircuit(
    ElementSet^ components
)

Parameters

components
Type: Autodesk.Revit..::.ElementSet
The components removed from the electrical system.

Remarks

If successful, all the components will remove from the system. Otherwise nothing is removed. This method will only function with the Autodesk Revit MEP application.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the components parameter Value is null.
System..::.InvalidOperationException | Thrown when the components cannot be removed from the system.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


SelectPanel Method

[image]

Revit 2010 API
ElectricalSystem..::.SelectPanel Method
ElectricalSystem Class See Also Send Feedback
Set the panel for the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SelectPanel(
    FamilyInstance panel
)
Visual Basic (Declaration)
Public Sub SelectPanel ( _
    panel As FamilyInstance _
)
Visual C++
public:
void SelectPanel(
    FamilyInstance^ panel
)

Parameters

panel
Type: Autodesk.Revit.Elements..::.FamilyInstance
The panel of the electrical system.

Remarks

If successful, the panel will be set for the system. Otherwise the exception will be thrown. This method will only function with the Autodesk Revit MEP application.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the panel parameter Value is null.
System..::.InvalidOperationException | Thrown when the panel cannot be set for the electrical system.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


ElectricalSystem Properties

[image] [image]

Revit 2010 API
ElectricalSystem Properties
ElectricalSystem Class See Also Send Feedback

The ElectricalSystem type exposes the following members.

Properties

Name | Description
ApparentCurrent | Returns the ApparentCurrent value of the Electrical System.
ApparentCurrentPhaseA | Returns the ApparentCurrentPhaseA value of the Electrical System.
ApparentCurrentPhaseB | Returns the ApparentCurrentPhaseB value of the Electrical System.
ApparentCurrentPhaseC | Returns the ApparentCurrentPhaseC value of the Electrical System.
ApparentLoad | Returns the ApparentLoad value of the Electrical System.
ApparentLoadPhaseA | Returns the ApparentLoadPhaseA value of the Electrical System.
ApparentLoadPhaseB | Returns the ApparentLoadPhaseB value of the Electrical System.
ApparentLoadPhaseC | Returns the ApparentLoadPhaseC value of the Electrical System.
BalancedLoad | Reports whether the BalancedLoad is on or off.
BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
BaseEquipmentConnector | The connector within base equipment which is used to connect with system. (Inherited from MEPSystem.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CircuitNumber | Returns the CircuitNumber of the Electrical System.
ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GroundConductorsNumber | Returns the GroundConductors Number of the Electrical System.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HotConductorsNumber | Returns the HotConductors Number of the Electrical System.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | Returns the Length value of the Electrical System.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadClassification | Returns the LoadClassification Type of the Electrical System.
LoadName | Get/Set the LoadName of the Electrical System.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns the Name of the Electrical System. (Overrides Element..::.Name.)
NeutralConductorsNumber | Returns the NeutralConductors Number of the Electrical System.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
PanelName | Returns the Panel name of the Electrical System.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PolesNumber | Returns the Poles Number of the Electrical System.
PowerFactor | Returns the PowerFactor value of the Electrical System.
PowerFactorState | Returns the PowerFactorState type of the Electrical System.
Rating | Get/Set the Rating value of the Electrical System.
RunsNumber | Returns the Runs Number of the Electrical System.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SystemType | Returns the Electrical System Type of the Electrical System.
TrueCurrent | Returns the TrueCurrent value of the Electrical System.
TrueCurrentPhaseA | Returns the TrueCurrentPhaseA value of the Electrical System.
TrueCurrentPhaseB | Returns the TrueCurrentPhaseB value of the Electrical System.
TrueCurrentPhaseC | Returns the TrueCurrentPhaseC value of the Electrical System.
TrueLoad | Returns the TrueLoad value of the Electrical System.
TrueLoadPhaseA | Returns the TrueLoadPhaseA value of the Electrical System.
TrueLoadPhaseB | Returns the TrueLoadPhaseB value of the Electrical System.
TrueLoadPhaseC | Returns the TrueLoadPhaseC value of the Electrical System.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Voltage | Returns the Voltage value of the Electrical System.
VoltageDrop | Returns the VoltageDrop value of the Electrical System.
WireSizeString | Returns the WireSize as a String of the Electrical System.
WireType | Get/Set the wire type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


ApparentCurrent Property

[image]

Revit 2010 API
ElectricalSystem..::.ApparentCurrent Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentCurrent value of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ApparentCurrent { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApparentCurrent As Double
Visual C++
public:
property double ApparentCurrent {
    double get ();
}

Remarks

This property is used to retrieve the ApparentCurrent value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


ApparentCurrentPhaseA Property

[image]

Revit 2010 API
ElectricalSystem..::.ApparentCurrentPhaseA Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentCurrentPhaseA value of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ApparentCurrentPhaseA { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApparentCurrentPhaseA As Double
Visual C++
public:
property double ApparentCurrentPhaseA {
    double get ();
}

Remarks

This property is used to retrieve the ApparentCurrentPhaseA value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


ApparentCurrentPhaseB Property

[image]

Revit 2010 API
ElectricalSystem..::.ApparentCurrentPhaseB Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentCurrentPhaseB value of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ApparentCurrentPhaseB { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApparentCurrentPhaseB As Double
Visual C++
public:
property double ApparentCurrentPhaseB {
    double get ();
}

Remarks

This property is used to retrieve the ApparentCurrentPhaseB value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


ApparentCurrentPhaseC Property

[image]

Revit 2010 API
ElectricalSystem..::.ApparentCurrentPhaseC Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentCurrentPhaseC value of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ApparentCurrentPhaseC { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApparentCurrentPhaseC As Double
Visual C++
public:
property double ApparentCurrentPhaseC {
    double get ();
}

Remarks

This property is used to retrieve the ApparentCurrentPhaseC value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


ApparentLoad Property

[image]

Revit 2010 API
ElectricalSystem..::.ApparentLoad Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentLoad value of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ApparentLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApparentLoad As Double
Visual C++
public:
property double ApparentLoad {
    double get ();
}

Remarks

This property is used to retrieve the ApparentLoad value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


ApparentLoadPhaseA Property

[image]

Revit 2010 API
ElectricalSystem..::.ApparentLoadPhaseA Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentLoadPhaseA value of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ApparentLoadPhaseA { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApparentLoadPhaseA As Double
Visual C++
public:
property double ApparentLoadPhaseA {
    double get ();
}

Remarks

This property is used to retrieve the ApparentLoadPhaseA value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


ApparentLoadPhaseB Property

[image]

Revit 2010 API
ElectricalSystem..::.ApparentLoadPhaseB Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentLoadPhaseB value of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ApparentLoadPhaseB { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApparentLoadPhaseB As Double
Visual C++
public:
property double ApparentLoadPhaseB {
    double get ();
}

Remarks

This property is used to retrieve the ApparentLoadPhaseB value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


ApparentLoadPhaseC Property

[image]

Revit 2010 API
ElectricalSystem..::.ApparentLoadPhaseC Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentLoadPhaseC value of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ApparentLoadPhaseC { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApparentLoadPhaseC As Double
Visual C++
public:
property double ApparentLoadPhaseC {
    double get ();
}

Remarks

This property is used to retrieve the ApparentLoadPhaseC value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


BalancedLoad Property

[image]

Revit 2010 API
ElectricalSystem..::.BalancedLoad Property
ElectricalSystem Class See Also Send Feedback
Reports whether the BalancedLoad is on or off.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool BalancedLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property BalancedLoad As Boolean
Visual C++
public:
property bool BalancedLoad {
    bool get ();
}

Remarks

This property is used to retrieve the BalancedLoad value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


CircuitNumber Property

[image]

Revit 2010 API
ElectricalSystem..::.CircuitNumber Property
ElectricalSystem Class See Also Send Feedback
Returns the CircuitNumber of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string CircuitNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property CircuitNumber As String
Visual C++
public:
property String^ CircuitNumber {
    String^ get ();
}

Remarks

This property is used to retrieve the CircuitNumber of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


GroundConductorsNumber Property

[image]

Revit 2010 API
ElectricalSystem..::.GroundConductorsNumber Property
ElectricalSystem Class See Also Send Feedback
Returns the GroundConductors Number of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int GroundConductorsNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroundConductorsNumber As Integer
Visual C++
public:
property int GroundConductorsNumber {
    int get ();
}

Remarks

This property is used to retrieve the GroundConductors Number of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


HotConductorsNumber Property

[image]

Revit 2010 API
ElectricalSystem..::.HotConductorsNumber Property
ElectricalSystem Class See Also Send Feedback
Returns the HotConductors Number of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int HotConductorsNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property HotConductorsNumber As Integer
Visual C++
public:
property int HotConductorsNumber {
    int get ();
}

Remarks

This property is used to retrieve the HotConductors Number of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


Length Property

[image]

Revit 2010 API
ElectricalSystem..::.Length Property
ElectricalSystem Class See Also Send Feedback
Returns the Length value of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Double
Visual C++
public:
property double Length {
    double get ();
}

Remarks

This property is used to retrieve the Length value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


LoadClassification Property

[image]

Revit 2010 API
ElectricalSystem..::.LoadClassification Property
ElectricalSystem Class See Also Send Feedback
Returns the LoadClassification Type of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadClassificationType LoadClassification { get; }
Visual Basic (Declaration)
Public ReadOnly Property LoadClassification As LoadClassificationType
Visual C++
public:
property LoadClassificationType LoadClassification {
    LoadClassificationType get ();
}

Remarks

This property is used to retrieve the LoadClassification Type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


LoadName Property

[image]

Revit 2010 API
ElectricalSystem..::.LoadName Property
ElectricalSystem Class See Also Send Feedback
Get/Set the LoadName of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string LoadName { get; set; }
Visual Basic (Declaration)
Public Property LoadName As String
Visual C++
public:
property String^ LoadName {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to retrieve the LoadName of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


Name Property

[image]

Revit 2010 API
ElectricalSystem..::.Name Property
ElectricalSystem Class See Also Send Feedback
Returns the Name of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Remarks

This property is used to get or set the Name of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


NeutralConductorsNumber Property

[image]

Revit 2010 API
ElectricalSystem..::.NeutralConductorsNumber Property
ElectricalSystem Class See Also Send Feedback
Returns the NeutralConductors Number of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NeutralConductorsNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property NeutralConductorsNumber As Integer
Visual C++
public:
property int NeutralConductorsNumber {
    int get ();
}

Remarks

This property is used to retrieve the NeutralConductors Number of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


PanelName Property

[image]

Revit 2010 API
ElectricalSystem..::.PanelName Property
ElectricalSystem Class See Also Send Feedback
Returns the Panel name of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string PanelName { get; }
Visual Basic (Declaration)
Public ReadOnly Property PanelName As String
Visual C++
public:
property String^ PanelName {
    String^ get ();
}

Remarks

This property is used to retrieve the Panel name of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
ElectricalSystem..::.Parameter Property
ElectricalSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ElectricalSystem Class
ElectricalSystem Members
Autodesk.Revit.MEP Namespace


PolesNumber Property

[image]

Revit 2010 API
ElectricalSystem..::.PolesNumber Property
ElectricalSystem Class See Also Send Feedback
Returns the Poles Number of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int PolesNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property PolesNumber As Integer
Visual C++
public:
property int PolesNumber {
    int get ();
}

Remarks

This property is used to retrieve the Poles Number of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


PowerFactor Property

[image]

Revit 2010 API
ElectricalSystem..::.PowerFactor Property
ElectricalSystem Class See Also Send Feedback
Returns the PowerFactor value of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double PowerFactor { get; }
Visual Basic (Declaration)
Public ReadOnly Property PowerFactor As Double
Visual C++
public:
property double PowerFactor {
    double get ();
}

Remarks

This property is used to retrieve the PowerFactor value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


PowerFactorState Property

[image]

Revit 2010 API
ElectricalSystem..::.PowerFactorState Property
ElectricalSystem Class See Also Send Feedback
Returns the PowerFactorState type of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PowerFactorStateType PowerFactorState { get; }
Visual Basic (Declaration)
Public ReadOnly Property PowerFactorState As PowerFactorStateType
Visual C++
public:
property PowerFactorStateType PowerFactorState {
    PowerFactorStateType get ();
}

Remarks

This property is used to retrieve the PowerFactorState type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


Rating Property

[image]

Revit 2010 API
ElectricalSystem..::.Rating Property
ElectricalSystem Class See Also Send Feedback
Get/Set the Rating value of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Rating { get; set; }
Visual Basic (Declaration)
Public Property Rating As Double
Visual C++
public:
property double Rating {
    double get ();
    void set (double value);
}

Remarks

This property is used to retrieve the Rating value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


RunsNumber Property

[image]

Revit 2010 API
ElectricalSystem..::.RunsNumber Property
ElectricalSystem Class See Also Send Feedback
Returns the Runs Number of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int RunsNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property RunsNumber As Integer
Visual C++
public:
property int RunsNumber {
    int get ();
}

Remarks

This property is used to retrieve the Runs Number of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


SystemType Property

[image]

Revit 2010 API
ElectricalSystem..::.SystemType Property
ElectricalSystem Class See Also Send Feedback
Returns the Electrical System Type of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElectricalSystemType SystemType { get; }
Visual Basic (Declaration)
Public ReadOnly Property SystemType As ElectricalSystemType
Visual C++
public:
property ElectricalSystemType SystemType {
    ElectricalSystemType get ();
}

Remarks

This property is used to retrieve the Electrical System Type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


TrueCurrent Property

[image]

Revit 2010 API
ElectricalSystem..::.TrueCurrent Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueCurrent value of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double TrueCurrent { get; }
Visual Basic (Declaration)
Public ReadOnly Property TrueCurrent As Double
Visual C++
public:
property double TrueCurrent {
    double get ();
}

Remarks

This property is used to retrieve the TrueCurrent value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


TrueCurrentPhaseA Property

[image]

Revit 2010 API
ElectricalSystem..::.TrueCurrentPhaseA Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueCurrentPhaseA value of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double TrueCurrentPhaseA { get; }
Visual Basic (Declaration)
Public ReadOnly Property TrueCurrentPhaseA As Double
Visual C++
public:
property double TrueCurrentPhaseA {
    double get ();
}

Remarks

This property is used to retrieve the TrueCurrentPhaseA value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


TrueCurrentPhaseB Property

[image]

Revit 2010 API
ElectricalSystem..::.TrueCurrentPhaseB Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueCurrentPhaseB value of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double TrueCurrentPhaseB { get; }
Visual Basic (Declaration)
Public ReadOnly Property TrueCurrentPhaseB As Double
Visual C++
public:
property double TrueCurrentPhaseB {
    double get ();
}

Remarks

This property is used to retrieve the TrueCurrentPhaseB value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


TrueCurrentPhaseC Property

[image]

Revit 2010 API
ElectricalSystem..::.TrueCurrentPhaseC Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueCurrentPhaseC value of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double TrueCurrentPhaseC { get; }
Visual Basic (Declaration)
Public ReadOnly Property TrueCurrentPhaseC As Double
Visual C++
public:
property double TrueCurrentPhaseC {
    double get ();
}

Remarks

This property is used to retrieve the TrueCurrentPhaseC value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


TrueLoad Property

[image]

Revit 2010 API
ElectricalSystem..::.TrueLoad Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueLoad value of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double TrueLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property TrueLoad As Double
Visual C++
public:
property double TrueLoad {
    double get ();
}

Remarks

This property is used to retrieve the TrueLoad value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


TrueLoadPhaseA Property

[image]

Revit 2010 API
ElectricalSystem..::.TrueLoadPhaseA Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueLoadPhaseA value of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double TrueLoadPhaseA { get; }
Visual Basic (Declaration)
Public ReadOnly Property TrueLoadPhaseA As Double
Visual C++
public:
property double TrueLoadPhaseA {
    double get ();
}

Remarks

This property is used to retrieve the TrueLoadPhaseA value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


TrueLoadPhaseB Property

[image]

Revit 2010 API
ElectricalSystem..::.TrueLoadPhaseB Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueLoadPhaseB value of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double TrueLoadPhaseB { get; }
Visual Basic (Declaration)
Public ReadOnly Property TrueLoadPhaseB As Double
Visual C++
public:
property double TrueLoadPhaseB {
    double get ();
}

Remarks

This property is used to retrieve the TrueLoadPhaseB value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


TrueLoadPhaseC Property

[image]

Revit 2010 API
ElectricalSystem..::.TrueLoadPhaseC Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueLoadPhaseC value of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double TrueLoadPhaseC { get; }
Visual Basic (Declaration)
Public ReadOnly Property TrueLoadPhaseC As Double
Visual C++
public:
property double TrueLoadPhaseC {
    double get ();
}

Remarks

This property is used to retrieve the TrueLoadPhaseC value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


Voltage Property

[image]

Revit 2010 API
ElectricalSystem..::.Voltage Property
ElectricalSystem Class See Also Send Feedback
Returns the Voltage value of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Voltage { get; }
Visual Basic (Declaration)
Public ReadOnly Property Voltage As Double
Visual C++
public:
property double Voltage {
    double get ();
}

Remarks

This property is used to retrieve the Voltage value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


VoltageDrop Property

[image]

Revit 2010 API
ElectricalSystem..::.VoltageDrop Property
ElectricalSystem Class See Also Send Feedback
Returns the VoltageDrop value of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double VoltageDrop { get; }
Visual Basic (Declaration)
Public ReadOnly Property VoltageDrop As Double
Visual C++
public:
property double VoltageDrop {
    double get ();
}

Remarks

This property is used to retrieve the VoltageDrop value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


WireSizeString Property

[image]

Revit 2010 API
ElectricalSystem..::.WireSizeString Property
ElectricalSystem Class See Also Send Feedback
Returns the WireSize as a String of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string WireSizeString { get; }
Visual Basic (Declaration)
Public ReadOnly Property WireSizeString As String
Visual C++
public:
property String^ WireSizeString {
    String^ get ();
}

Remarks

This property is used to retrieve the WireSize String of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


WireType Property

[image]

Revit 2010 API
ElectricalSystem..::.WireType Property
ElectricalSystem Class See Also Send Feedback
Get/Set the wire type of the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireType WireType { get; set; }
Visual Basic (Declaration)
Public Property WireType As WireType
Visual C++
public:
property WireType^ WireType {
    WireType^ get ();
    void set (WireType^ value);
}

Remarks

This property is used to retrieve the wire type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace


ElectricalSystemSet Class

[image]

Revit 2010 API
ElectricalSystemSet Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ElectricalSystemSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ElectricalSystemSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ElectricalSystemSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.ElectricalSystemSet

See Also

ElectricalSystemSet Members
Autodesk.Revit.MEP Namespace


ElectricalSystemSet Members

[image] [image]

Revit 2010 API
ElectricalSystemSet Members
ElectricalSystemSet Class Constructors Methods Properties See Also Send Feedback

The ElectricalSystemSet type exposes the following members.

Constructors

Name | Description
ElectricalSystemSet | Initializes a new instance of the ElectricalSystemSet class

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

ElectricalSystemSet Class
Autodesk.Revit.MEP Namespace


ElectricalSystemSet Constructor

[image]

Revit 2010 API
ElectricalSystemSet Constructor
ElectricalSystemSet Class See Also Send Feedback
Initializes a new instance of the ElectricalSystemSet class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElectricalSystemSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElectricalSystemSet()

See Also

ElectricalSystemSet Class
Autodesk.Revit.MEP Namespace


ElectricalSystemSet Methods

[image] [image]

Revit 2010 API
ElectricalSystemSet Methods
ElectricalSystemSet Class See Also Send Feedback

The ElectricalSystemSet type exposes the following members.

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalSystemSet Class
Autodesk.Revit.MEP Namespace


Clear Method

[image]

Revit 2010 API
ElectricalSystemSet..::.Clear Method
ElectricalSystemSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ElectricalSystemSet Class
Autodesk.Revit.MEP Namespace


Contains Method

[image]

Revit 2010 API
ElectricalSystemSet..::.Contains Method
ElectricalSystemSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    ElectricalSystem item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As ElectricalSystem _
) As Boolean
Visual C++
public:
virtual bool Contains(
    ElectricalSystem^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.ElectricalSystem

See Also

ElectricalSystemSet Class
Autodesk.Revit.MEP Namespace


Erase Method

[image]

Revit 2010 API
ElectricalSystemSet..::.Erase Method
ElectricalSystemSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    ElectricalSystem item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As ElectricalSystem _
) As Integer
Visual C++
public:
virtual int Erase(
    ElectricalSystem^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.ElectricalSystem

See Also

ElectricalSystemSet Class
Autodesk.Revit.MEP Namespace


ForwardIterator Method

[image]

Revit 2010 API
ElectricalSystemSet..::.ForwardIterator Method
ElectricalSystemSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ElectricalSystemSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ElectricalSystemSetIterator
Visual C++
public:
virtual ElectricalSystemSetIterator^ ForwardIterator()

See Also

ElectricalSystemSet Class
Autodesk.Revit.MEP Namespace


GetEnumerator Method

[image]

Revit 2010 API
ElectricalSystemSet..::.GetEnumerator Method
ElectricalSystemSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ElectricalSystemSet Class
Autodesk.Revit.MEP Namespace


Insert Method

[image]

Revit 2010 API
ElectricalSystemSet..::.Insert Method
ElectricalSystemSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    ElectricalSystem item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As ElectricalSystem _
) As Boolean
Visual C++
public:
virtual bool Insert(
    ElectricalSystem^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.ElectricalSystem

See Also

ElectricalSystemSet Class
Autodesk.Revit.MEP Namespace


ReverseIterator Method

[image]

Revit 2010 API
ElectricalSystemSet..::.ReverseIterator Method
ElectricalSystemSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ElectricalSystemSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ElectricalSystemSetIterator
Visual C++
public:
virtual ElectricalSystemSetIterator^ ReverseIterator()

See Also

ElectricalSystemSet Class
Autodesk.Revit.MEP Namespace


ElectricalSystemSet Properties

[image] [image]

Revit 2010 API
ElectricalSystemSet Properties
ElectricalSystemSet Class See Also Send Feedback

The ElectricalSystemSet type exposes the following members.

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

ElectricalSystemSet Class
Autodesk.Revit.MEP Namespace


IsEmpty Property

[image]

Revit 2010 API
ElectricalSystemSet..::.IsEmpty Property
ElectricalSystemSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

ElectricalSystemSet Class
Autodesk.Revit.MEP Namespace


Size Property

[image]

Revit 2010 API
ElectricalSystemSet..::.Size Property
ElectricalSystemSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ElectricalSystemSet Class
Autodesk.Revit.MEP Namespace


ElectricalSystemSetIterator Class

[image]

Revit 2010 API
ElectricalSystemSetIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ElectricalSystemSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ElectricalSystemSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ElectricalSystemSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.ElectricalSystemSetIterator

See Also

ElectricalSystemSetIterator Members
Autodesk.Revit.MEP Namespace


ElectricalSystemSetIterator Members

[image] [image]

Revit 2010 API
ElectricalSystemSetIterator Members
ElectricalSystemSetIterator Class Constructors Methods Properties See Also Send Feedback

The ElectricalSystemSetIterator type exposes the following members.

Constructors

Name | Description
ElectricalSystemSetIterator | Initializes a new instance of the ElectricalSystemSetIterator class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.MEP Namespace


ElectricalSystemSetIterator Constructor

[image]

Revit 2010 API
ElectricalSystemSetIterator Constructor
ElectricalSystemSetIterator Class See Also Send Feedback
Initializes a new instance of the ElectricalSystemSetIterator class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElectricalSystemSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElectricalSystemSetIterator()

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.MEP Namespace


ElectricalSystemSetIterator Methods

[image] [image]

Revit 2010 API
ElectricalSystemSetIterator Methods
ElectricalSystemSetIterator Class See Also Send Feedback

The ElectricalSystemSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.MEP Namespace


MoveNext Method

[image]

Revit 2010 API
ElectricalSystemSetIterator..::.MoveNext Method
ElectricalSystemSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::.MoveNext()()()

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.MEP Namespace


Reset Method

[image]

Revit 2010 API
ElectricalSystemSetIterator..::.Reset Method
ElectricalSystemSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.MEP Namespace


ElectricalSystemSetIterator Properties

[image] [image]

Revit 2010 API
ElectricalSystemSetIterator Properties
ElectricalSystemSetIterator Class See Also Send Feedback

The ElectricalSystemSetIterator type exposes the following members.

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.MEP Namespace


Current Property

[image]

Revit 2010 API
ElectricalSystemSetIterator..::.Current Property
ElectricalSystemSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.MEP Namespace


FlexDuct Class

[image]

Revit 2010 API
FlexDuct Class
Members See Also Send Feedback
A flex duct in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FlexDuct : MEPCurve
Visual Basic (Declaration)
Public Class FlexDuct _
    Inherits MEPCurve
Visual C++
public ref class FlexDuct : public MEPCurve

Remarks

The flex duct is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.MEP..::.MEPCurve
Autodesk.Revit.MEP..::.FlexDuct

See Also

FlexDuct Members
Autodesk.Revit.MEP Namespace


FlexDuct Members

[image] [image]

Revit 2010 API
FlexDuct Members
FlexDuct Class Constructors Methods Properties See Also Send Feedback

The FlexDuct type exposes the following members.

Constructors

Name | Description
FlexDuct | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FlexDuctType | The flex duct type of this flex duct.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Points | The points of the flex duct.
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

FlexDuct Class
Autodesk.Revit.MEP Namespace


FlexDuct Constructor

[image]

Revit 2010 API
FlexDuct Constructor
FlexDuct Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlexDuct()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FlexDuct()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FlexDuct Class
Autodesk.Revit.MEP Namespace


FlexDuct Methods

[image] [image]

Revit 2010 API
FlexDuct Methods
FlexDuct Class See Also Send Feedback

The FlexDuct type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlexDuct Class
Autodesk.Revit.MEP Namespace


FlexDuct Properties

[image] [image]

Revit 2010 API
FlexDuct Properties
FlexDuct Class See Also Send Feedback

The FlexDuct type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FlexDuctType | The flex duct type of this flex duct.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Points | The points of the flex duct.
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

FlexDuct Class
Autodesk.Revit.MEP Namespace


FlexDuctType Property

[image]

Revit 2010 API
FlexDuct..::.FlexDuctType Property
FlexDuct Class See Also Send Feedback
The flex duct type of this flex duct.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlexDuctType FlexDuctType { get; set; }
Visual Basic (Declaration)
Public Property FlexDuctType As FlexDuctType
Visual C++
public:
property FlexDuctType^ FlexDuctType {
    FlexDuctType^ get ();
    void set (FlexDuctType^ value);
}

See Also

FlexDuct Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
FlexDuct..::.Parameter Property
FlexDuct Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FlexDuct Class
FlexDuct Members
Autodesk.Revit.MEP Namespace


Points Property

[image]

Revit 2010 API
FlexDuct..::.Points Property
FlexDuct Class See Also Send Feedback
The points of the flex duct.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZArray Points { get; set; }
Visual Basic (Declaration)
Public Property Points As XYZArray
Visual C++
public:
property XYZArray^ Points {
    XYZArray^ get ();
    void set (XYZArray^ value);
}

Remarks

This property is used to retrieve the points of flex duct, including the end points. If the end points are changed, the connection will be maintained by Revit automatically. The set operation will fail if the modification makes the connection invalid.

See Also

FlexDuct Class
Autodesk.Revit.MEP Namespace


FlexDuctType Class

[image]

Revit 2010 API
FlexDuctType Class
Members See Also Send Feedback
A flex duct type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FlexDuctType : MEPCurveType
Visual Basic (Declaration)
Public Class FlexDuctType _
    Inherits MEPCurveType
Visual C++
public ref class FlexDuctType : public MEPCurveType

Remarks

The flex duct type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.MEPCurveType
Autodesk.Revit.MEP..::.FlexDuctType

See Also

FlexDuctType Members
Autodesk.Revit.MEP Namespace


FlexDuctType Members

[image] [image]

Revit 2010 API
FlexDuctType Members
FlexDuctType Class Constructors Methods Properties See Also Send Feedback

The FlexDuctType type exposes the following members.

Constructors

Name | Description
FlexDuctType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Roughness | The roughness of the MEP curve type. (Inherited from MEPCurveType.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FlexDuctType Class
Autodesk.Revit.MEP Namespace


FlexDuctType Constructor

[image]

Revit 2010 API
FlexDuctType Constructor
FlexDuctType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlexDuctType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FlexDuctType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FlexDuctType Class
Autodesk.Revit.MEP Namespace


FlexDuctType Methods

[image] [image]

Revit 2010 API
FlexDuctType Methods
FlexDuctType Class See Also Send Feedback

The FlexDuctType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlexDuctType Class
Autodesk.Revit.MEP Namespace


FlexDuctType Properties

[image] [image]

Revit 2010 API
FlexDuctType Properties
FlexDuctType Class See Also Send Feedback

The FlexDuctType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Roughness | The roughness of the MEP curve type. (Inherited from MEPCurveType.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FlexDuctType Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
FlexDuctType..::.Parameter Property
FlexDuctType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FlexDuctType Class
FlexDuctType Members
Autodesk.Revit.MEP Namespace


FlexPipe Class

[image]

Revit 2010 API
FlexPipe Class
Members See Also Send Feedback
A flex pipe in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FlexPipe : MEPCurve
Visual Basic (Declaration)
Public Class FlexPipe _
    Inherits MEPCurve
Visual C++
public ref class FlexPipe : public MEPCurve

Remarks

The flex pipe is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.MEP..::.MEPCurve
Autodesk.Revit.MEP..::.FlexPipe

See Also

FlexPipe Members
Autodesk.Revit.MEP Namespace


FlexPipe Members

[image] [image]

Revit 2010 API
FlexPipe Members
FlexPipe Class Constructors Methods Properties See Also Send Feedback

The FlexPipe type exposes the following members.

Constructors

Name | Description
FlexPipe | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FlexPipeType | The flex pipe type of this flex pipe.
FlowState | The flow state of the pipe.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Points | The points of the flex pipe.
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

FlexPipe Class
Autodesk.Revit.MEP Namespace


FlexPipe Constructor

[image]

Revit 2010 API
FlexPipe Constructor
FlexPipe Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlexPipe()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FlexPipe()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FlexPipe Class
Autodesk.Revit.MEP Namespace


FlexPipe Methods

[image] [image]

Revit 2010 API
FlexPipe Methods
FlexPipe Class See Also Send Feedback

The FlexPipe type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlexPipe Class
Autodesk.Revit.MEP Namespace


FlexPipe Properties

[image] [image]

Revit 2010 API
FlexPipe Properties
FlexPipe Class See Also Send Feedback

The FlexPipe type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FlexPipeType | The flex pipe type of this flex pipe.
FlowState | The flow state of the pipe.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Points | The points of the flex pipe.
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

FlexPipe Class
Autodesk.Revit.MEP Namespace


FlexPipeType Property

[image]

Revit 2010 API
FlexPipe..::.FlexPipeType Property
FlexPipe Class See Also Send Feedback
The flex pipe type of this flex pipe.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlexPipeType FlexPipeType { get; set; }
Visual Basic (Declaration)
Public Property FlexPipeType As FlexPipeType
Visual C++
public:
property FlexPipeType^ FlexPipeType {
    FlexPipeType^ get ();
    void set (FlexPipeType^ value);
}

See Also

FlexPipe Class
Autodesk.Revit.MEP Namespace


FlowState Property

[image]

Revit 2010 API
FlexPipe..::.FlowState Property
FlexPipe Class See Also Send Feedback
The flow state of the pipe.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeFlowState FlowState { get; }
Visual Basic (Declaration)
Public ReadOnly Property FlowState As PipeFlowState
Visual C++
public:
property PipeFlowState FlowState {
    PipeFlowState get ();
}

See Also

FlexPipe Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
FlexPipe..::.Parameter Property
FlexPipe Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FlexPipe Class
FlexPipe Members
Autodesk.Revit.MEP Namespace


Points Property

[image]

Revit 2010 API
FlexPipe..::.Points Property
FlexPipe Class See Also Send Feedback
The points of the flex pipe.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZArray Points { get; set; }
Visual Basic (Declaration)
Public Property Points As XYZArray
Visual C++
public:
property XYZArray^ Points {
    XYZArray^ get ();
    void set (XYZArray^ value);
}

Remarks

This property is used to retrieve the points of flex pipe, including the end points. If the end points are changed, the connection will be maintained by Revit automatically. The set operation will fail if the modification makes the connection invalid.

See Also

FlexPipe Class
Autodesk.Revit.MEP Namespace


FlexPipeType Class

[image]

Revit 2010 API
FlexPipeType Class
Members See Also Send Feedback
A flex pipe type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FlexPipeType : MEPCurveType
Visual Basic (Declaration)
Public Class FlexPipeType _
    Inherits MEPCurveType
Visual C++
public ref class FlexPipeType : public MEPCurveType

Remarks

The flex pipe type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.MEPCurveType
Autodesk.Revit.MEP..::.FlexPipeType

See Also

FlexPipeType Members
Autodesk.Revit.MEP Namespace


FlexPipeType Members

[image] [image]

Revit 2010 API
FlexPipeType Members
FlexPipeType Class Constructors Methods Properties See Also Send Feedback

The FlexPipeType type exposes the following members.

Constructors

Name | Description
FlexPipeType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Roughness | The roughness of the MEP curve type. (Inherited from MEPCurveType.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FlexPipeType Class
Autodesk.Revit.MEP Namespace


FlexPipeType Constructor

[image]

Revit 2010 API
FlexPipeType Constructor
FlexPipeType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlexPipeType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FlexPipeType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FlexPipeType Class
Autodesk.Revit.MEP Namespace


FlexPipeType Methods

[image] [image]

Revit 2010 API
FlexPipeType Methods
FlexPipeType Class See Also Send Feedback

The FlexPipeType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlexPipeType Class
Autodesk.Revit.MEP Namespace


FlexPipeType Properties

[image] [image]

Revit 2010 API
FlexPipeType Properties
FlexPipeType Class See Also Send Feedback

The FlexPipeType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Roughness | The roughness of the MEP curve type. (Inherited from MEPCurveType.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FlexPipeType Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
FlexPipeType..::.Parameter Property
FlexPipeType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FlexPipeType Class
FlexPipeType Members
Autodesk.Revit.MEP Namespace


FluidType Class

[image]

Revit 2010 API
FluidType Class
Members See Also Send Feedback
A fluid type symbol in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FluidType : Symbol
Visual Basic (Declaration)
Public Class FluidType _
    Inherits Symbol
Visual C++
public ref class FluidType : public Symbol

Remarks

The object type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.FluidType

See Also

FluidType Members
Autodesk.Revit.MEP Namespace


FluidType Members

[image] [image]

Revit 2010 API
FluidType Members
FluidType Class Constructors Methods Properties See Also Send Feedback

The FluidType type exposes the following members.

Constructors

Name | Description
FluidType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FluidType Class
Autodesk.Revit.MEP Namespace


FluidType Constructor

[image]

Revit 2010 API
FluidType Constructor
FluidType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FluidType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FluidType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FluidType Class
Autodesk.Revit.MEP Namespace


FluidType Methods

[image] [image]

Revit 2010 API
FluidType Methods
FluidType Class See Also Send Feedback

The FluidType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FluidType Class
Autodesk.Revit.MEP Namespace


FluidType Properties

[image] [image]

Revit 2010 API
FluidType Properties
FluidType Class See Also Send Feedback

The FluidType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FluidType Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
FluidType..::.Parameter Property
FluidType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FluidType Class
FluidType Members
Autodesk.Revit.MEP Namespace


GroundConductorSize Class

[image]

Revit 2010 API
GroundConductorSize Class
Members See Also Send Feedback
Represents electrical ground conductor size definition information.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class GroundConductorSize : APIObject
Visual Basic (Declaration)
Public Class GroundConductorSize _
    Inherits APIObject
Visual C++
public ref class GroundConductorSize : public APIObject

Remarks

Ground conductor size is defined based on corresponding wire material type.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.GroundConductorSize

See Also

GroundConductorSize Members
Autodesk.Revit.MEP Namespace


GroundConductorSize Members

[image] [image]

Revit 2010 API
GroundConductorSize Members
GroundConductorSize Class Constructors Methods Properties See Also Send Feedback

The GroundConductorSize type exposes the following members.

Constructors

Name | Description
GroundConductorSize | Initializes a new instance of the GroundConductorSize class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Ampacity | Get ampacity which is used for specifying size, the unit is ampere.
ConductorSize | Get conductor size corresponding to specific ampacity.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
MaterialBelongTo | Get the material type which include this ground conductor size information.

See Also

GroundConductorSize Class
Autodesk.Revit.MEP Namespace


GroundConductorSize Constructor

[image]

Revit 2010 API
GroundConductorSize Constructor
GroundConductorSize Class See Also Send Feedback
Initializes a new instance of the GroundConductorSize class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GroundConductorSize()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroundConductorSize()

See Also

GroundConductorSize Class
Autodesk.Revit.MEP Namespace


GroundConductorSize Methods

[image] [image]

Revit 2010 API
GroundConductorSize Methods
GroundConductorSize Class See Also Send Feedback

The GroundConductorSize type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroundConductorSize Class
Autodesk.Revit.MEP Namespace


GroundConductorSize Properties

[image] [image]

Revit 2010 API
GroundConductorSize Properties
GroundConductorSize Class See Also Send Feedback

The GroundConductorSize type exposes the following members.

Properties

Name | Description
Ampacity | Get ampacity which is used for specifying size, the unit is ampere.
ConductorSize | Get conductor size corresponding to specific ampacity.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
MaterialBelongTo | Get the material type which include this ground conductor size information.

See Also

GroundConductorSize Class
Autodesk.Revit.MEP Namespace


Ampacity Property

[image]

Revit 2010 API
GroundConductorSize..::.Ampacity Property
GroundConductorSize Class See Also Send Feedback
Get ampacity which is used for specifying size, the unit is ampere.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public long Ampacity { get; }
Visual Basic (Declaration)
Public ReadOnly Property Ampacity As Long
Visual C++
public:
property long long Ampacity {
    long long get ();
}

See Also

GroundConductorSize Class
Autodesk.Revit.MEP Namespace


ConductorSize Property

[image]

Revit 2010 API
GroundConductorSize..::.ConductorSize Property
GroundConductorSize Class See Also Send Feedback
Get conductor size corresponding to specific ampacity.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string ConductorSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConductorSize As String
Visual C++
public:
property String^ ConductorSize {
    String^ get ();
}

See Also

GroundConductorSize Class
Autodesk.Revit.MEP Namespace


MaterialBelongTo Property

[image]

Revit 2010 API
GroundConductorSize..::.MaterialBelongTo Property
GroundConductorSize Class See Also Send Feedback
Get the material type which include this ground conductor size information.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireMaterialType MaterialBelongTo { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaterialBelongTo As WireMaterialType
Visual C++
public:
property WireMaterialType^ MaterialBelongTo {
    WireMaterialType^ get ();
}

See Also

GroundConductorSize Class
Autodesk.Revit.MEP Namespace


GroundConductorSizeSet Class

[image]

Revit 2010 API
GroundConductorSizeSet Class
Members See Also Send Feedback
A set that contains GroundConductorSizes.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class GroundConductorSizeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class GroundConductorSizeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GroundConductorSizeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.GroundConductorSizeSet

See Also

GroundConductorSizeSet Members
Autodesk.Revit.MEP Namespace


GroundConductorSizeSet Members

[image] [image]

Revit 2010 API
GroundConductorSizeSet Members
GroundConductorSizeSet Class Constructors Methods Properties See Also Send Feedback

The GroundConductorSizeSet type exposes the following members.

Constructors

Name | Description
GroundConductorSizeSet | Initializes a new instance of the GroundConductorSizeSet class

Methods

Name | Description
Clear | Removes every GroundConductorSize from the set, rendering it empty.
Contains | Tests for the existence of a GroundConductorSize within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified GroundConductorSize from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified GroundConductorSize into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of GroundConductorSizes that are in the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


GroundConductorSizeSet Constructor

[image]

Revit 2010 API
GroundConductorSizeSet Constructor
GroundConductorSizeSet Class See Also Send Feedback
Initializes a new instance of the GroundConductorSizeSet class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GroundConductorSizeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroundConductorSizeSet()

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


GroundConductorSizeSet Methods

[image] [image]

Revit 2010 API
GroundConductorSizeSet Methods
GroundConductorSizeSet Class See Also Send Feedback

The GroundConductorSizeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every GroundConductorSize from the set, rendering it empty.
Contains | Tests for the existence of a GroundConductorSize within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified GroundConductorSize from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified GroundConductorSize into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


Clear Method

[image]

Revit 2010 API
GroundConductorSizeSet..::.Clear Method
GroundConductorSizeSet Class See Also Send Feedback
Removes every GroundConductorSize from the set, rendering it empty.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


Contains Method

[image]

Revit 2010 API
GroundConductorSizeSet..::.Contains Method
GroundConductorSizeSet Class See Also Send Feedback
Tests for the existence of a GroundConductorSize within the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    GroundConductorSize item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As GroundConductorSize _
) As Boolean
Visual C++
public:
virtual bool Contains(
    GroundConductorSize^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.GroundConductorSize
The GroundConductorSize to be searched for.

Return Value

The Contains method returns True if the GroundConductorSize is within the set, otherwise False.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


Erase Method

[image]

Revit 2010 API
GroundConductorSizeSet..::.Erase Method
GroundConductorSizeSet Class See Also Send Feedback
Removes a specified GroundConductorSize from the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    GroundConductorSize item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As GroundConductorSize _
) As Integer
Visual C++
public:
virtual int Erase(
    GroundConductorSize^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.GroundConductorSize
The GroundConductorSize to be erased.

Return Value

The number of GroundConductorSizes that were erased from the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


ForwardIterator Method

[image]

Revit 2010 API
GroundConductorSizeSet..::.ForwardIterator Method
GroundConductorSizeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual GroundConductorSizeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As GroundConductorSizeSetIterator
Visual C++
public:
virtual GroundConductorSizeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


GetEnumerator Method

[image]

Revit 2010 API
GroundConductorSizeSet..::.GetEnumerator Method
GroundConductorSizeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


Insert Method

[image]

Revit 2010 API
GroundConductorSizeSet..::.Insert Method
GroundConductorSizeSet Class See Also Send Feedback
Insert the specified GroundConductorSize into the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    GroundConductorSize item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As GroundConductorSize _
) As Boolean
Visual C++
public:
virtual bool Insert(
    GroundConductorSize^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.GroundConductorSize
The GroundConductorSize to be inserted into the set.

Return Value

Returns whether the GroundConductorSize was inserted into the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


ReverseIterator Method

[image]

Revit 2010 API
GroundConductorSizeSet..::.ReverseIterator Method
GroundConductorSizeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual GroundConductorSizeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As GroundConductorSizeSetIterator
Visual C++
public:
virtual GroundConductorSizeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


GroundConductorSizeSet Properties

[image] [image]

Revit 2010 API
GroundConductorSizeSet Properties
GroundConductorSizeSet Class See Also Send Feedback

The GroundConductorSizeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of GroundConductorSizes that are in the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


IsEmpty Property

[image]

Revit 2010 API
GroundConductorSizeSet..::.IsEmpty Property
GroundConductorSizeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


Size Property

[image]

Revit 2010 API
GroundConductorSizeSet..::.Size Property
GroundConductorSizeSet Class See Also Send Feedback
Returns the number of GroundConductorSizes that are in the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GroundConductorSizeSet Class
Autodesk.Revit.MEP Namespace


GroundConductorSizeSetIterator Class

[image]

Revit 2010 API
GroundConductorSizeSetIterator Class
Members See Also Send Feedback
An iterator to a GroundConductorSize set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class GroundConductorSizeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class GroundConductorSizeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GroundConductorSizeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.GroundConductorSizeSetIterator

See Also

GroundConductorSizeSetIterator Members
Autodesk.Revit.MEP Namespace


GroundConductorSizeSetIterator Members

[image] [image]

Revit 2010 API
GroundConductorSizeSetIterator Members
GroundConductorSizeSetIterator Class Constructors Methods Properties See Also Send Feedback

The GroundConductorSizeSetIterator type exposes the following members.

Constructors

Name | Description
GroundConductorSizeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.MEP Namespace


GroundConductorSizeSetIterator Constructor

[image]

Revit 2010 API
GroundConductorSizeSetIterator Constructor
GroundConductorSizeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GroundConductorSizeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroundConductorSizeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.MEP Namespace


GroundConductorSizeSetIterator Methods

[image] [image]

Revit 2010 API
GroundConductorSizeSetIterator Methods
GroundConductorSizeSetIterator Class See Also Send Feedback

The GroundConductorSizeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.MEP Namespace


MoveNext Method

[image]

Revit 2010 API
GroundConductorSizeSetIterator..::.MoveNext Method
GroundConductorSizeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.MEP Namespace


Reset Method

[image]

Revit 2010 API
GroundConductorSizeSetIterator..::.Reset Method
GroundConductorSizeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.MEP Namespace


GroundConductorSizeSetIterator Properties

[image] [image]

Revit 2010 API
GroundConductorSizeSetIterator Properties
GroundConductorSizeSetIterator Class See Also Send Feedback

The GroundConductorSizeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.MEP Namespace


Current Property

[image]

Revit 2010 API
GroundConductorSizeSetIterator..::.Current Property
GroundConductorSizeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.MEP Namespace


IConnector Interface

[image]

Revit 2010 API
IConnector Interface
Members See Also Send Feedback
An interface which provides access to connector in Autodesk Revit MEP document.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public interface IConnector
Visual Basic (Declaration)
Public Interface IConnector
Visual C++
public interface class IConnector

Remarks

This interface is shared by Connector, DuctConnector,ElectricalConnector and PipeConnector.

See Also

IConnector Members
Autodesk.Revit.MEP Namespace


IConnector Members

[image] [image]

Revit 2010 API
IConnector Members
IConnector Interface Properties See Also Send Feedback

The IConnector type exposes the following members.

Properties

Name | Description
CoordinateSystem | The coordinate system of the connector.
Domain | The domain of the connector.
Height | The height of the connector.
Origin | The location of the connector in family document.
Radius | The radius of the connector.
Shape | The shape of the connector.
Width | The width of the connector.

See Also

IConnector Interface
Autodesk.Revit.MEP Namespace


IConnector Properties

[image] [image]

Revit 2010 API
IConnector Properties
IConnector Interface See Also Send Feedback

The IConnector type exposes the following members.

Properties

Name | Description
CoordinateSystem | The coordinate system of the connector.
Domain | The domain of the connector.
Height | The height of the connector.
Origin | The location of the connector in family document.
Radius | The radius of the connector.
Shape | The shape of the connector.
Width | The width of the connector.

See Also

IConnector Interface
Autodesk.Revit.MEP Namespace


CoordinateSystem Property

[image]

Revit 2010 API
IConnector..::.CoordinateSystem Property
IConnector Interface See Also Send Feedback
The coordinate system of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
Transform CoordinateSystem { get; }
Visual Basic (Declaration)
ReadOnly Property CoordinateSystem As Transform
Visual C++
property Transform^ CoordinateSystem {
    Transform^ get ();
}

Remarks

The Z axis of the coordinate system is the normal to the plane of the connector.

See Also

IConnector Interface
Autodesk.Revit.MEP Namespace


Domain Property

[image]

Revit 2010 API
IConnector..::.Domain Property
IConnector Interface See Also Send Feedback
The domain of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
Domain Domain { get; }
Visual Basic (Declaration)
ReadOnly Property Domain As Domain
Visual C++
property Domain Domain {
    Domain get ();
}

Remarks

This property is used to retrieve the domain of the connector.

See Also

IConnector Interface
Autodesk.Revit.MEP Namespace


Height Property

[image]

Revit 2010 API
IConnector..::.Height Property
IConnector Interface See Also Send Feedback
The height of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
double Height { get; }
Visual Basic (Declaration)
ReadOnly Property Height As Double
Visual C++
property double Height {
    double get ();
}

Remarks

This property is used to retrieve the height of the connector.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the connector's shape is not rectangular.

See Also

IConnector Interface
Autodesk.Revit.MEP Namespace


Origin Property

[image]

Revit 2010 API
IConnector..::.Origin Property
IConnector Interface See Also Send Feedback
The location of the connector in family document.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
XYZ Origin { get; }
Visual Basic (Declaration)
ReadOnly Property Origin As XYZ
Visual C++
property XYZ^ Origin {
    XYZ^ get ();
}

Remarks

This property is used to retrieve the origin of the connector.

See Also

IConnector Interface
Autodesk.Revit.MEP Namespace


Radius Property

[image]

Revit 2010 API
IConnector..::.Radius Property
IConnector Interface See Also Send Feedback
The radius of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
double Radius { get; }
Visual Basic (Declaration)
ReadOnly Property Radius As Double
Visual C++
property double Radius {
    double get ();
}

Remarks

This property is used to retrieve the radius of the connector.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the connector's shape is not round.

See Also

IConnector Interface
Autodesk.Revit.MEP Namespace


Shape Property

[image]

Revit 2010 API
IConnector..::.Shape Property
IConnector Interface See Also Send Feedback
The shape of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
ConnectorProfileType Shape { get; }
Visual Basic (Declaration)
ReadOnly Property Shape As ConnectorProfileType
Visual C++
property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}

Remarks

This property is used to retrieve the shape of the connector.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Throw when this connector has no shape.

See Also

IConnector Interface
Autodesk.Revit.MEP Namespace


Width Property

[image]

Revit 2010 API
IConnector..::.Width Property
IConnector Interface See Also Send Feedback
The width of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
double Width { get; }
Visual Basic (Declaration)
ReadOnly Property Width As Double
Visual C++
property double Width {
    double get ();
}

Remarks

This property is used to retrieve the width of the connector.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the connector's shape is not rectangular.

See Also

IConnector Interface
Autodesk.Revit.MEP Namespace


InsulationType Class

[image]

Revit 2010 API
InsulationType Class
Members See Also Send Feedback
Represents electrical insulation type definition information.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class InsulationType : Element
Visual Basic (Declaration)
Public Class InsulationType _
    Inherits Element
Visual C++
public ref class InsulationType : public Element

Remarks

Insulation type is defined based on corresponding wire material type and temperature rating type.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.MEP..::.InsulationType

See Also

InsulationType Members
Autodesk.Revit.MEP Namespace


InsulationType Members

[image] [image]

Revit 2010 API
InsulationType Members
InsulationType Class Constructors Methods Properties See Also Send Feedback

The InsulationType type exposes the following members.

Constructors

Name | Description
InsulationType | Initializes a new instance of the InsulationType class

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInUse | Indicate whether the insulation type is in use.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get name of Insulation type. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

InsulationType Class
Autodesk.Revit.MEP Namespace


InsulationType Constructor

[image]

Revit 2010 API
InsulationType Constructor
InsulationType Class See Also Send Feedback
Initializes a new instance of the InsulationType class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InsulationType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InsulationType()

See Also

InsulationType Class
Autodesk.Revit.MEP Namespace


InsulationType Methods

[image] [image]

Revit 2010 API
InsulationType Methods
InsulationType Class See Also Send Feedback

The InsulationType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsulationType Class
Autodesk.Revit.MEP Namespace


InsulationType Properties

[image] [image]

Revit 2010 API
InsulationType Properties
InsulationType Class See Also Send Feedback

The InsulationType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInUse | Indicate whether the insulation type is in use.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get name of Insulation type. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

InsulationType Class
Autodesk.Revit.MEP Namespace


IsInUse Property

[image]

Revit 2010 API
InsulationType..::.IsInUse Property
InsulationType Class See Also Send Feedback
Indicate whether the insulation type is in use.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsInUse { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInUse As Boolean
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

InsulationType Class
Autodesk.Revit.MEP Namespace


Name Property

[image]

Revit 2010 API
InsulationType..::.Name Property
InsulationType Class See Also Send Feedback
Get name of Insulation type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Exceptions

Exception | Condition
System..::.NotSupportedException | Set name can't be supported.

See Also

InsulationType Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
InsulationType..::.Parameter Property
InsulationType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

InsulationType Class
InsulationType Members
Autodesk.Revit.MEP Namespace


InsulationTypeSet Class

[image]

Revit 2010 API
InsulationTypeSet Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class InsulationTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class InsulationTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class InsulationTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.InsulationTypeSet

See Also

InsulationTypeSet Members
Autodesk.Revit.MEP Namespace


InsulationTypeSet Members

[image] [image]

Revit 2010 API
InsulationTypeSet Members
InsulationTypeSet Class Constructors Methods Properties See Also Send Feedback

The InsulationTypeSet type exposes the following members.

Constructors

Name | Description
InsulationTypeSet | Initializes a new instance of the InsulationTypeSet class

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

InsulationTypeSet Class
Autodesk.Revit.MEP Namespace


InsulationTypeSet Constructor

[image]

Revit 2010 API
InsulationTypeSet Constructor
InsulationTypeSet Class See Also Send Feedback
Initializes a new instance of the InsulationTypeSet class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InsulationTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InsulationTypeSet()

See Also

InsulationTypeSet Class
Autodesk.Revit.MEP Namespace


InsulationTypeSet Methods

[image] [image]

Revit 2010 API
InsulationTypeSet Methods
InsulationTypeSet Class See Also Send Feedback

The InsulationTypeSet type exposes the following members.

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsulationTypeSet Class
Autodesk.Revit.MEP Namespace


Clear Method

[image]

Revit 2010 API
InsulationTypeSet..::.Clear Method
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

InsulationTypeSet Class
Autodesk.Revit.MEP Namespace


Contains Method

[image]

Revit 2010 API
InsulationTypeSet..::.Contains Method
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    InsulationType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As InsulationType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    InsulationType^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.InsulationType

See Also

InsulationTypeSet Class
Autodesk.Revit.MEP Namespace


Erase Method

[image]

Revit 2010 API
InsulationTypeSet..::.Erase Method
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    InsulationType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As InsulationType _
) As Integer
Visual C++
public:
virtual int Erase(
    InsulationType^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.InsulationType

See Also

InsulationTypeSet Class
Autodesk.Revit.MEP Namespace


ForwardIterator Method

[image]

Revit 2010 API
InsulationTypeSet..::.ForwardIterator Method
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual InsulationTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As InsulationTypeSetIterator
Visual C++
public:
virtual InsulationTypeSetIterator^ ForwardIterator()

See Also

InsulationTypeSet Class
Autodesk.Revit.MEP Namespace


GetEnumerator Method

[image]

Revit 2010 API
InsulationTypeSet..::.GetEnumerator Method
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::.GetEnumerator()()()

See Also

InsulationTypeSet Class
Autodesk.Revit.MEP Namespace


Insert Method

[image]

Revit 2010 API
InsulationTypeSet..::.Insert Method
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    InsulationType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As InsulationType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    InsulationType^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.InsulationType

See Also

InsulationTypeSet Class
Autodesk.Revit.MEP Namespace


ReverseIterator Method

[image]

Revit 2010 API
InsulationTypeSet..::.ReverseIterator Method
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual InsulationTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As InsulationTypeSetIterator
Visual C++
public:
virtual InsulationTypeSetIterator^ ReverseIterator()

See Also

InsulationTypeSet Class
Autodesk.Revit.MEP Namespace


InsulationTypeSet Properties

[image] [image]

Revit 2010 API
InsulationTypeSet Properties
InsulationTypeSet Class See Also Send Feedback

The InsulationTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

InsulationTypeSet Class
Autodesk.Revit.MEP Namespace


IsEmpty Property

[image]

Revit 2010 API
InsulationTypeSet..::.IsEmpty Property
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

InsulationTypeSet Class
Autodesk.Revit.MEP Namespace


Size Property

[image]

Revit 2010 API
InsulationTypeSet..::.Size Property
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

InsulationTypeSet Class
Autodesk.Revit.MEP Namespace


InsulationTypeSetIterator Class

[image]

Revit 2010 API
InsulationTypeSetIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class InsulationTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class InsulationTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class InsulationTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.InsulationTypeSetIterator

See Also

InsulationTypeSetIterator Members
Autodesk.Revit.MEP Namespace


InsulationTypeSetIterator Members

[image] [image]

Revit 2010 API
InsulationTypeSetIterator Members
InsulationTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The InsulationTypeSetIterator type exposes the following members.

Constructors

Name | Description
InsulationTypeSetIterator | Initializes a new instance of the InsulationTypeSetIterator class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.MEP Namespace


InsulationTypeSetIterator Constructor

[image]

Revit 2010 API
InsulationTypeSetIterator Constructor
InsulationTypeSetIterator Class See Also Send Feedback
Initializes a new instance of the InsulationTypeSetIterator class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InsulationTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InsulationTypeSetIterator()

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.MEP Namespace


InsulationTypeSetIterator Methods

[image] [image]

Revit 2010 API
InsulationTypeSetIterator Methods
InsulationTypeSetIterator Class See Also Send Feedback

The InsulationTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.MEP Namespace


MoveNext Method

[image]

Revit 2010 API
InsulationTypeSetIterator..::.MoveNext Method
InsulationTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::.MoveNext()()()

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.MEP Namespace


Reset Method

[image]

Revit 2010 API
InsulationTypeSetIterator..::.Reset Method
InsulationTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.MEP Namespace


InsulationTypeSetIterator Properties

[image] [image]

Revit 2010 API
InsulationTypeSetIterator Properties
InsulationTypeSetIterator Class See Also Send Feedback

The InsulationTypeSetIterator type exposes the following members.

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.MEP Namespace


Current Property

[image]

Revit 2010 API
InsulationTypeSetIterator..::.Current Property
InsulationTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.MEP Namespace


LightingDevice Class

[image]

Revit 2010 API
LightingDevice Class
Members See Also Send Feedback
Provides access to the Lighting Device in Autodesk Revit MEP.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LightingDevice : MEPModel
Visual Basic (Declaration)
Public Class LightingDevice _
    Inherits MEPModel
Visual C++
public ref class LightingDevice : public MEPModel

Remarks

The Lighting Device object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.MEPModel
Autodesk.Revit.MEP..::.LightingDevice

See Also

LightingDevice Members
Autodesk.Revit.MEP Namespace


LightingDevice Members

[image] [image]

Revit 2010 API
LightingDevice Members
LightingDevice Class Constructors Methods Properties See Also Send Feedback

The LightingDevice type exposes the following members.

Constructors

Name | Description
LightingDevice | For Internal Use Only

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LightingDevice Class
Autodesk.Revit.MEP Namespace


LightingDevice Constructor

[image]

Revit 2010 API
LightingDevice Constructor
LightingDevice Class See Also Send Feedback
For Internal Use Only

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LightingDevice()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LightingDevice()

Remarks

This constructor is exposed to enable support for COM interopability only. This object should not be created by the developer.

See Also

LightingDevice Class
Autodesk.Revit.MEP Namespace


LightingDevice Methods

[image] [image]

Revit 2010 API
LightingDevice Methods
LightingDevice Class See Also Send Feedback

The LightingDevice type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LightingDevice Class
Autodesk.Revit.MEP Namespace


LightingDevice Properties

[image] [image]

Revit 2010 API
LightingDevice Properties
LightingDevice Class See Also Send Feedback

The LightingDevice type exposes the following members.

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LightingDevice Class
Autodesk.Revit.MEP Namespace


LightingFixture Class

[image]

Revit 2010 API
LightingFixture Class
Members See Also Send Feedback
Provides access to the Lighting Fixture in Autodesk Revit MEP.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LightingFixture : MEPModel
Visual Basic (Declaration)
Public Class LightingFixture _
    Inherits MEPModel
Visual C++
public ref class LightingFixture : public MEPModel

Remarks

The Lighting Fixture object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.MEPModel
Autodesk.Revit.MEP..::.LightingFixture

See Also

LightingFixture Members
Autodesk.Revit.MEP Namespace


LightingFixture Members

[image] [image]

Revit 2010 API
LightingFixture Members
LightingFixture Class Constructors Methods Properties See Also Send Feedback

The LightingFixture type exposes the following members.

Constructors

Name | Description
LightingFixture | For Internal Use Only

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LightingFixture Class
Autodesk.Revit.MEP Namespace


LightingFixture Constructor

[image]

Revit 2010 API
LightingFixture Constructor
LightingFixture Class See Also Send Feedback
For Internal Use Only

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LightingFixture()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LightingFixture()

Remarks

This constructor is exposed to enable support for COM interopability only. This object should not be created by the developer.

See Also

LightingFixture Class
Autodesk.Revit.MEP Namespace


LightingFixture Methods

[image] [image]

Revit 2010 API
LightingFixture Methods
LightingFixture Class See Also Send Feedback

The LightingFixture type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LightingFixture Class
Autodesk.Revit.MEP Namespace


LightingFixture Properties

[image] [image]

Revit 2010 API
LightingFixture Properties
LightingFixture Class See Also Send Feedback

The LightingFixture type exposes the following members.

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LightingFixture Class
Autodesk.Revit.MEP Namespace


MechanicalEquipment Class

[image]

Revit 2010 API
MechanicalEquipment Class
Members See Also Send Feedback
Provides access to the Mechanical Equipment in Autodesk Revit MEP.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MechanicalEquipment : MEPModel
Visual Basic (Declaration)
Public Class MechanicalEquipment _
    Inherits MEPModel
Visual C++
public ref class MechanicalEquipment : public MEPModel

Remarks

The Mechanical Equipment object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.MEPModel
Autodesk.Revit.MEP..::.MechanicalEquipment

See Also

MechanicalEquipment Members
Autodesk.Revit.MEP Namespace


MechanicalEquipment Members

[image] [image]

Revit 2010 API
MechanicalEquipment Members
MechanicalEquipment Class Constructors Methods Properties See Also Send Feedback

The MechanicalEquipment type exposes the following members.

Constructors

Name | Description
MechanicalEquipment | For Internal Use Only

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MechanicalEquipment Class
Autodesk.Revit.MEP Namespace


MechanicalEquipment Constructor

[image]

Revit 2010 API
MechanicalEquipment Constructor
MechanicalEquipment Class See Also Send Feedback
For Internal Use Only

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MechanicalEquipment()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MechanicalEquipment()

Remarks

This constructor is exposed to enable support for COM interopability only. This object should not be created by the developer.

See Also

MechanicalEquipment Class
Autodesk.Revit.MEP Namespace


MechanicalEquipment Methods

[image] [image]

Revit 2010 API
MechanicalEquipment Methods
MechanicalEquipment Class See Also Send Feedback

The MechanicalEquipment type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MechanicalEquipment Class
Autodesk.Revit.MEP Namespace


MechanicalEquipment Properties

[image] [image]

Revit 2010 API
MechanicalEquipment Properties
MechanicalEquipment Class See Also Send Feedback

The MechanicalEquipment type exposes the following members.

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MechanicalEquipment Class
Autodesk.Revit.MEP Namespace


MechanicalFitting Class

[image]

Revit 2010 API
MechanicalFitting Class
Members See Also Send Feedback
A mechanical fitting in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MechanicalFitting : MEPModel
Visual Basic (Declaration)
Public Class MechanicalFitting _
    Inherits MEPModel
Visual C++
public ref class MechanicalFitting : public MEPModel

Remarks

The mechanical fitting is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.MEPModel
Autodesk.Revit.MEP..::.MechanicalFitting

See Also

MechanicalFitting Members
Autodesk.Revit.MEP Namespace


MechanicalFitting Members

[image] [image]

Revit 2010 API
MechanicalFitting Members
MechanicalFitting Class Constructors Methods Properties See Also Send Feedback

The MechanicalFitting type exposes the following members.

Constructors

Name | Description
MechanicalFitting | For Internal Use Only

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
PartType | The part type of the mechanical fitting.

See Also

MechanicalFitting Class
Autodesk.Revit.MEP Namespace


MechanicalFitting Constructor

[image]

Revit 2010 API
MechanicalFitting Constructor
MechanicalFitting Class See Also Send Feedback
For Internal Use Only

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MechanicalFitting()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MechanicalFitting()

Remarks

This constructor is exposed to enable support for COM interopability only. This object should not be created by the developer.

See Also

MechanicalFitting Class
Autodesk.Revit.MEP Namespace


MechanicalFitting Methods

[image] [image]

Revit 2010 API
MechanicalFitting Methods
MechanicalFitting Class See Also Send Feedback

The MechanicalFitting type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MechanicalFitting Class
Autodesk.Revit.MEP Namespace


MechanicalFitting Properties

[image] [image]

Revit 2010 API
MechanicalFitting Properties
MechanicalFitting Class See Also Send Feedback

The MechanicalFitting type exposes the following members.

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
PartType | The part type of the mechanical fitting.

See Also

MechanicalFitting Class
Autodesk.Revit.MEP Namespace


PartType Property

[image]

Revit 2010 API
MechanicalFitting..::.PartType Property
MechanicalFitting Class See Also Send Feedback
The part type of the mechanical fitting.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PartType PartType { get; }
Visual Basic (Declaration)
Public ReadOnly Property PartType As PartType
Visual C++
public:
property PartType PartType {
    PartType get ();
}

See Also

MechanicalFitting Class
Autodesk.Revit.MEP Namespace


MechanicalSystem Class

[image]

Revit 2010 API
MechanicalSystem Class
Members See Also Send Feedback
A mechanical system in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MechanicalSystem : MEPSystem
Visual Basic (Declaration)
Public Class MechanicalSystem _
    Inherits MEPSystem
Visual C++
public ref class MechanicalSystem : public MEPSystem

Remarks

The mechanical system element is only available in Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.MEP..::.MEPSystem
Autodesk.Revit.MEP..::.MechanicalSystem

See Also

MechanicalSystem Members
Autodesk.Revit.MEP Namespace


MechanicalSystem Members

[image] [image]

Revit 2010 API
MechanicalSystem Members
MechanicalSystem Class Constructors Methods Properties See Also Send Feedback

The MechanicalSystem type exposes the following members.

Constructors

Name | Description
MechanicalSystem | For Internal Use Only.

Methods

Name | Description
Add | Add elements into the system and connect them with the system using given connectors. (Inherited from MEPSystem.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Remove | Remove elements from system. (Inherited from MEPSystem.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
BaseEquipmentConnector | The connector within the base equipment which is used to connect with the system.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
DuctNetwork | The ducts and fittings contained within the system.
Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Flow | The system flow.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsWellConnected | Indicates if the system is well connected or not.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
StaticPressure | The system static pressure.
SystemType | The type of this duct system.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

MechanicalSystem Class
Autodesk.Revit.MEP Namespace


MechanicalSystem Constructor

[image]

Revit 2010 API
MechanicalSystem Constructor
MechanicalSystem Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MechanicalSystem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MechanicalSystem()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MechanicalSystem Class
Autodesk.Revit.MEP Namespace


MechanicalSystem Methods

[image] [image]

Revit 2010 API
MechanicalSystem Methods
MechanicalSystem Class See Also Send Feedback

The MechanicalSystem type exposes the following members.

Methods

Name | Description
Add | Add elements into the system and connect them with the system using given connectors. (Inherited from MEPSystem.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Remove | Remove elements from system. (Inherited from MEPSystem.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MechanicalSystem Class
Autodesk.Revit.MEP Namespace


MechanicalSystem Properties

[image] [image]

Revit 2010 API
MechanicalSystem Properties
MechanicalSystem Class See Also Send Feedback

The MechanicalSystem type exposes the following members.

Properties

Name | Description
BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
BaseEquipmentConnector | The connector within the base equipment which is used to connect with the system.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
DuctNetwork | The ducts and fittings contained within the system.
Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Flow | The system flow.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsWellConnected | Indicates if the system is well connected or not.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
StaticPressure | The system static pressure.
SystemType | The type of this duct system.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

MechanicalSystem Class
Autodesk.Revit.MEP Namespace


BaseEquipmentConnector Property

[image]

Revit 2010 API
MechanicalSystem..::.BaseEquipmentConnector Property
MechanicalSystem Class See Also Send Feedback
The connector within the base equipment which is used to connect with the system.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Connector BaseEquipmentConnector { get; set; }
Visual Basic (Declaration)
Public Property BaseEquipmentConnector As Connector
Visual C++
public:
property Connector^ BaseEquipmentConnector {
    Connector^ get ();
    void set (Connector^ value);
}

Remarks

Assigning null to the base equipment connector will disconnect the base equipment from the system.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when assigning a connector which is used in a system, or when the connector's owner is not of type 'mechanical equipment'.
System..::.InvalidOperationException | Thrown when the set operation failed.

See Also

MechanicalSystem Class
Autodesk.Revit.MEP Namespace


DuctNetwork Property

[image]

Revit 2010 API
MechanicalSystem..::.DuctNetwork Property
MechanicalSystem Class See Also Send Feedback
The ducts and fittings contained within the system.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet DuctNetwork { get; }
Visual Basic (Declaration)
Public ReadOnly Property DuctNetwork As ElementSet
Visual C++
public:
property ElementSet^ DuctNetwork {
    ElementSet^ get ();
}

Remarks

The return value doesn't include terminals or equipments, the ducts and fittings are returned in no particular order.

See Also

MechanicalSystem Class
Autodesk.Revit.MEP Namespace


Flow Property

[image]

Revit 2010 API
MechanicalSystem..::.Flow Property
MechanicalSystem Class See Also Send Feedback
The system flow.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Flow { get; }
Visual Basic (Declaration)
Public ReadOnly Property Flow As Double
Visual C++
public:
property double Flow {
    double get ();
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the flow can't be computed, which means the system is not well connected.

See Also

MechanicalSystem Class
Autodesk.Revit.MEP Namespace


IsWellConnected Property

[image]

Revit 2010 API
MechanicalSystem..::.IsWellConnected Property
MechanicalSystem Class See Also Send Feedback
Indicates if the system is well connected or not.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsWellConnected { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsWellConnected As Boolean
Visual C++
public:
property bool IsWellConnected {
    bool get ();
}

Remarks

If the system is not well connected, parameters which need to be calculated are invalid.

See Also

MechanicalSystem Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
MechanicalSystem..::.Parameter Property
MechanicalSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MechanicalSystem Class
MechanicalSystem Members
Autodesk.Revit.MEP Namespace


StaticPressure Property

[image]

Revit 2010 API
MechanicalSystem..::.StaticPressure Property
MechanicalSystem Class See Also Send Feedback
The system static pressure.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double StaticPressure { get; }
Visual Basic (Declaration)
Public ReadOnly Property StaticPressure As Double
Visual C++
public:
property double StaticPressure {
    double get ();
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the static pressure can't be computed, which means the system is not well connected.

See Also

MechanicalSystem Class
Autodesk.Revit.MEP Namespace


SystemType Property

[image]

Revit 2010 API
MechanicalSystem..::.SystemType Property
MechanicalSystem Class See Also Send Feedback
The type of this duct system.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DuctSystemType SystemType { get; }
Visual Basic (Declaration)
Public ReadOnly Property SystemType As DuctSystemType
Visual C++
public:
property DuctSystemType SystemType {
    DuctSystemType get ();
}

See Also

MechanicalSystem Class
Autodesk.Revit.MEP Namespace


MEPCurve Class

[image]

Revit 2010 API
MEPCurve Class
Members See Also Send Feedback
A curve object for duct or pipe blend elements.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MEPCurve : HostObject
Visual Basic (Declaration)
Public Class MEPCurve _
    Inherits HostObject
Visual C++
public ref class MEPCurve : public HostObject

Remarks

The curve object is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.MEP..::.MEPCurve
Autodesk.Revit.MEP..::.Duct
Autodesk.Revit.MEP..::.FlexDuct
Autodesk.Revit.MEP..::.FlexPipe
Autodesk.Revit.MEP..::.Pipe

See Also

MEPCurve Members
Autodesk.Revit.MEP Namespace


MEPCurve Members

[image] [image]

Revit 2010 API
MEPCurve Members
MEPCurve Class Constructors Methods Properties See Also Send Feedback

The MEPCurve type exposes the following members.

Constructors

Name | Description
MEPCurve | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Height | The height of the MEP curve.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve.
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceLevel | The reference level of the MEP curve.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Width | The width of the MEP curve.

See Also

MEPCurve Class
Autodesk.Revit.MEP Namespace


MEPCurve Constructor

[image]

Revit 2010 API
MEPCurve Constructor
MEPCurve Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MEPCurve()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MEPCurve()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MEPCurve Class
Autodesk.Revit.MEP Namespace


MEPCurve Methods

[image] [image]

Revit 2010 API
MEPCurve Methods
MEPCurve Class See Also Send Feedback

The MEPCurve type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPCurve Class
Autodesk.Revit.MEP Namespace


MEPCurve Properties

[image] [image]

Revit 2010 API
MEPCurve Properties
MEPCurve Class See Also Send Feedback

The MEPCurve type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Height | The height of the MEP curve.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve.
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceLevel | The reference level of the MEP curve.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Width | The width of the MEP curve.

See Also

MEPCurve Class
Autodesk.Revit.MEP Namespace


ConnectorManager Property

[image]

Revit 2010 API
MEPCurve..::.ConnectorManager Property
MEPCurve Class See Also Send Feedback
The connector manager of this MEP curve.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ConnectorManager ConnectorManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConnectorManager As ConnectorManager
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

See Also

MEPCurve Class
Autodesk.Revit.MEP Namespace


Diameter Property

[image]

Revit 2010 API
MEPCurve..::.Diameter Property
MEPCurve Class See Also Send Feedback
The diameter of the MEP curve.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Diameter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Diameter As Double
Visual C++
public:
property double Diameter {
    double get ();
}

Remarks

This property is used to retrieve the diameter of the MEP curve.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the MEP curve's Shape is not round.

See Also

MEPCurve Class
Autodesk.Revit.MEP Namespace


Height Property

[image]

Revit 2010 API
MEPCurve..::.Height Property
MEPCurve Class See Also Send Feedback
The height of the MEP curve.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Height { get; }
Visual Basic (Declaration)
Public ReadOnly Property Height As Double
Visual C++
public:
property double Height {
    double get ();
}

Remarks

This property is used to retrieve the height of the MEP curve.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the MEP curve's Shape is not rectangular.

See Also

MEPCurve Class
Autodesk.Revit.MEP Namespace


LevelOffset Property

[image]

Revit 2010 API
MEPCurve..::.LevelOffset Property
MEPCurve Class See Also Send Feedback
The offset of the MEP curve.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double LevelOffset { get; set; }
Visual Basic (Declaration)
Public Property LevelOffset As Double
Visual C++
public:
property double LevelOffset {
    double get ();
    void set (double value);
}

Remarks

This property is used to retrieve the offset of the MEP curve. If the curve is not in a horizontal plane, this value will be the start point's offset.

See Also

MEPCurve Class
Autodesk.Revit.MEP Namespace


MEPSystem Property

[image]

Revit 2010 API
MEPCurve..::.MEPSystem Property
MEPCurve Class See Also Send Feedback
The system of the MEP curve.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MEPSystem MEPSystem { get; }
Visual Basic (Declaration)
Public ReadOnly Property MEPSystem As MEPSystem
Visual C++
public:
property MEPSystem^ MEPSystem {
    MEPSystem^ get ();
}

Remarks

Returns the system of this MEP curve. If the curve does not belong to any systems, the value will be null.

See Also

MEPCurve Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
MEPCurve..::.Parameter Property
MEPCurve Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MEPCurve Class
MEPCurve Members
Autodesk.Revit.MEP Namespace


ReferenceLevel Property

[image]

Revit 2010 API
MEPCurve..::.ReferenceLevel Property
MEPCurve Class See Also Send Feedback
The reference level of the MEP curve.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Level ReferenceLevel { get; set; }
Visual Basic (Declaration)
Public Property ReferenceLevel As Level
Visual C++
public:
property Level^ ReferenceLevel {
    Level^ get ();
    void set (Level^ value);
}

Remarks

This property is used to retrieve the reference level of the MEP curve. If the curve is not in a horizontal plane, this value will be the start point's reference level.

See Also

MEPCurve Class
Autodesk.Revit.MEP Namespace


Width Property

[image]

Revit 2010 API
MEPCurve..::.Width Property
MEPCurve Class See Also Send Feedback
The width of the MEP curve.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Width { get; }
Visual Basic (Declaration)
Public ReadOnly Property Width As Double
Visual C++
public:
property double Width {
    double get ();
}

Remarks

This property is used to retrieve the width of the MEP curve.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the MEP curve's shape is not rectangular.

See Also

MEPCurve Class
Autodesk.Revit.MEP Namespace


MEPCurveType Class

[image]

Revit 2010 API
MEPCurveType Class
Members See Also Send Feedback
A curve type for duct type or pipe type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MEPCurveType : Symbol
Visual Basic (Declaration)
Public Class MEPCurveType _
    Inherits Symbol
Visual C++
public ref class MEPCurveType : public Symbol

Remarks

The curve type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.MEPCurveType
Autodesk.Revit.MEP..::.DuctType
Autodesk.Revit.MEP..::.FlexDuctType
Autodesk.Revit.MEP..::.FlexPipeType
Autodesk.Revit.MEP..::.PipeType

See Also

MEPCurveType Members
Autodesk.Revit.MEP Namespace


MEPCurveType Members

[image] [image]

Revit 2010 API
MEPCurveType Members
MEPCurveType Class Constructors Methods Properties See Also Send Feedback

The MEPCurveType type exposes the following members.

Constructors

Name | Description
MEPCurveType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Cross | The default cross fitting of the MEP curve type.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type.
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type.
Roughness | The roughness of the MEP curve type.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type.
Tee | The default tee fitting of the MEP curve type.
Transition | The default transition fitting of the MEP curve type.
Union | The default union fitting of the MEP curve type.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

MEPCurveType Class
Autodesk.Revit.MEP Namespace


MEPCurveType Constructor

[image]

Revit 2010 API
MEPCurveType Constructor
MEPCurveType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MEPCurveType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MEPCurveType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MEPCurveType Class
Autodesk.Revit.MEP Namespace


MEPCurveType Methods

[image] [image]

Revit 2010 API
MEPCurveType Methods
MEPCurveType Class See Also Send Feedback

The MEPCurveType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPCurveType Class
Autodesk.Revit.MEP Namespace


MEPCurveType Properties

[image] [image]

Revit 2010 API
MEPCurveType Properties
MEPCurveType Class See Also Send Feedback

The MEPCurveType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Cross | The default cross fitting of the MEP curve type.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type.
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type.
Roughness | The roughness of the MEP curve type.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type.
Tee | The default tee fitting of the MEP curve type.
Transition | The default transition fitting of the MEP curve type.
Union | The default union fitting of the MEP curve type.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

MEPCurveType Class
Autodesk.Revit.MEP Namespace


Cross Property

[image]

Revit 2010 API
MEPCurveType..::.Cross Property
MEPCurveType Class See Also Send Feedback
The default cross fitting of the MEP curve type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbol Cross { get; set; }
Visual Basic (Declaration)
Public Property Cross As FamilySymbol
Visual C++
public:
property FamilySymbol^ Cross {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default cross fitting of the MEP curve type, and can be null if there are no default value.

See Also

MEPCurveType Class
Autodesk.Revit.MEP Namespace


Elbow Property

[image]

Revit 2010 API
MEPCurveType..::.Elbow Property
MEPCurveType Class See Also Send Feedback
The default elbow fitting of the MEP curve type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbol Elbow { get; set; }
Visual Basic (Declaration)
Public Property Elbow As FamilySymbol
Visual C++
public:
property FamilySymbol^ Elbow {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default elbow fitting of the MEP curve type, and can be null if there are no default value.

See Also

MEPCurveType Class
Autodesk.Revit.MEP Namespace


MultiShapeTransition Property

[image]

Revit 2010 API
MEPCurveType..::.MultiShapeTransition Property
MEPCurveType Class See Also Send Feedback
The default multi shape transition fitting of the MEP curve type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbol MultiShapeTransition { get; set; }
Visual Basic (Declaration)
Public Property MultiShapeTransition As FamilySymbol
Visual C++
public:
property FamilySymbol^ MultiShapeTransition {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default multi shape transition fitting of the MEP curve type, and can be null if there are no default value.

See Also

MEPCurveType Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
MEPCurveType..::.Parameter Property
MEPCurveType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MEPCurveType Class
MEPCurveType Members
Autodesk.Revit.MEP Namespace


PreferredJunctionType Property

[image]

Revit 2010 API
MEPCurveType..::.PreferredJunctionType Property
MEPCurveType Class See Also Send Feedback
The preferred junction type of the MEP curve type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public JunctionType PreferredJunctionType { get; set; }
Visual Basic (Declaration)
Public Property PreferredJunctionType As JunctionType
Visual C++
public:
property JunctionType PreferredJunctionType {
    JunctionType get ();
    void set (JunctionType value);
}

See Also

MEPCurveType Class
Autodesk.Revit.MEP Namespace


Roughness Property

[image]

Revit 2010 API
MEPCurveType..::.Roughness Property
MEPCurveType Class See Also Send Feedback
The roughness of the MEP curve type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Roughness { get; set; }
Visual Basic (Declaration)
Public Property Roughness As Double
Visual C++
public:
property double Roughness {
    double get ();
    void set (double value);
}

See Also

MEPCurveType Class
Autodesk.Revit.MEP Namespace


Tap Property

[image]

Revit 2010 API
MEPCurveType..::.Tap Property
MEPCurveType Class See Also Send Feedback
The default tap fitting of the MEP curve type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbol Tap { get; set; }
Visual Basic (Declaration)
Public Property Tap As FamilySymbol
Visual C++
public:
property FamilySymbol^ Tap {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default tap fitting of the MEP curve type, and can be null if there are no default value.

See Also

MEPCurveType Class
Autodesk.Revit.MEP Namespace


Tee Property

[image]

Revit 2010 API
MEPCurveType..::.Tee Property
MEPCurveType Class See Also Send Feedback
The default tee fitting of the MEP curve type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbol Tee { get; set; }
Visual Basic (Declaration)
Public Property Tee As FamilySymbol
Visual C++
public:
property FamilySymbol^ Tee {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default tee fitting of the MEP curve type, and can be null if there are no default value.

See Also

MEPCurveType Class
Autodesk.Revit.MEP Namespace


Transition Property

[image]

Revit 2010 API
MEPCurveType..::.Transition Property
MEPCurveType Class See Also Send Feedback
The default transition fitting of the MEP curve type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbol Transition { get; set; }
Visual Basic (Declaration)
Public Property Transition As FamilySymbol
Visual C++
public:
property FamilySymbol^ Transition {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default transition fitting of the MEP curve type, and can be null if there are no default value.

See Also

MEPCurveType Class
Autodesk.Revit.MEP Namespace


Union Property

[image]

Revit 2010 API
MEPCurveType..::.Union Property
MEPCurveType Class See Also Send Feedback
The default union fitting of the MEP curve type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbol Union { get; set; }
Visual Basic (Declaration)
Public Property Union As FamilySymbol
Visual C++
public:
property FamilySymbol^ Union {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default union fitting of the MEP curve type, and can be null if there are no default value.

See Also

MEPCurveType Class
Autodesk.Revit.MEP Namespace


MEPModel Class

[image]

Revit 2010 API
MEPModel Class
Members See Also Send Feedback
Supports all Analytical Models that are persistent within the Autodesk Revit project

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MEPModel : APIObject
Visual Basic (Declaration)
Public Class MEPModel _
    Inherits APIObject
Visual C++
public ref class MEPModel : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.MEPModel
Autodesk.Revit.MEP..::.ElectricalEquipment
Autodesk.Revit.MEP..::.LightingDevice
Autodesk.Revit.MEP..::.LightingFixture
Autodesk.Revit.MEP..::.MechanicalEquipment
Autodesk.Revit.MEP..::.MechanicalFitting

See Also

MEPModel Members
Autodesk.Revit.MEP Namespace


MEPModel Members

[image] [image]

Revit 2010 API
MEPModel Members
MEPModel Class Constructors Methods Properties See Also Send Feedback

The MEPModel type exposes the following members.

Constructors

Name | Description
MEPModel | For Internal Use Only

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel.
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MEPModel Class
Autodesk.Revit.MEP Namespace


MEPModel Constructor

[image]

Revit 2010 API
MEPModel Constructor
MEPModel Class See Also Send Feedback
For Internal Use Only

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MEPModel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MEPModel()

Remarks

This constructor is exposed to enable support for COM interopability only. This object should not be created by the developer.

See Also

MEPModel Class
Autodesk.Revit.MEP Namespace


MEPModel Methods

[image] [image]

Revit 2010 API
MEPModel Methods
MEPModel Class See Also Send Feedback

The MEPModel type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPModel Class
Autodesk.Revit.MEP Namespace


MEPModel Properties

[image] [image]

Revit 2010 API
MEPModel Properties
MEPModel Class See Also Send Feedback

The MEPModel type exposes the following members.

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel.
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MEPModel Class
Autodesk.Revit.MEP Namespace


ConnectorManager Property

[image]

Revit 2010 API
MEPModel..::.ConnectorManager Property
MEPModel Class See Also Send Feedback
Retrieves the Connector Manager from this MEPModel.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ConnectorManager ConnectorManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConnectorManager As ConnectorManager
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

Remarks

This property returns Connector Manager from this MEPModel.

See Also

MEPModel Class
Autodesk.Revit.MEP Namespace


ElectricalSystems Property

[image]

Revit 2010 API
MEPModel..::.ElectricalSystems Property
MEPModel Class See Also Send Feedback
Retrieves the electrical systems that are currently created using this MEPModel.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElectricalSystemSet ElectricalSystems { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElectricalSystems As ElectricalSystemSet
Visual C++
public:
property ElectricalSystemSet^ ElectricalSystems {
    ElectricalSystemSet^ get ();
}

Remarks

This property returns a set of Electrical Systems. If there are no electrical systems created for this model, this property will be an empty set.

See Also

MEPModel Class
Autodesk.Revit.MEP Namespace


MEPSystem Class

[image]

Revit 2010 API
MEPSystem Class
Members See Also Send Feedback
A system in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MEPSystem : Element
Visual Basic (Declaration)
Public Class MEPSystem _
    Inherits Element
Visual C++
public ref class MEPSystem : public Element

Remarks

This is the base class for electrical, mechanical and piping systems, available only in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.MEP..::.MEPSystem
Autodesk.Revit.MEP..::.ElectricalSystem
Autodesk.Revit.MEP..::.MechanicalSystem
Autodesk.Revit.MEP..::.PipingSystem

See Also

MEPSystem Members
Autodesk.Revit.MEP Namespace


MEPSystem Members

[image] [image]

Revit 2010 API
MEPSystem Members
MEPSystem Class Constructors Methods Properties See Also Send Feedback

The MEPSystem type exposes the following members.

Constructors

Name | Description
MEPSystem | For Internal Use Only.

Methods

Name | Description
Add | Add elements into the system and connect them with the system using given connectors.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Remove | Remove elements from system.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BaseEquipment | The base panel or equipment of the system.
BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | Connector manager of the system.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Terminal elements in the system.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultSystem | Indicates if the system is a default system or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

MEPSystem Class
Autodesk.Revit.MEP Namespace


MEPSystem Constructor

[image]

Revit 2010 API
MEPSystem Constructor
MEPSystem Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MEPSystem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MEPSystem()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MEPSystem Class
Autodesk.Revit.MEP Namespace


MEPSystem Methods

[image] [image]

Revit 2010 API
MEPSystem Methods
MEPSystem Class See Also Send Feedback

The MEPSystem type exposes the following members.

Methods

Name | Description
Add | Add elements into the system and connect them with the system using given connectors.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Remove | Remove elements from system.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPSystem Class
Autodesk.Revit.MEP Namespace


Add Method

[image]

Revit 2010 API
MEPSystem..::.Add Method
MEPSystem Class See Also Send Feedback
Add elements into the system and connect them with the system using given connectors.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Add(
    ConnectorSet connectors
)
Visual Basic (Declaration)
Public Overridable Sub Add ( _
    connectors As ConnectorSet _
)
Visual C++
public:
virtual void Add(
    ConnectorSet^ connectors
)

Parameters

connectors
Type: Autodesk.Revit.MEP..::.ConnectorSet
Connectors which are used to connect with the system.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument connectors is null, or any connector in that collection is null.
System..::.ArgumentException | Throw when any of the input connectors have been already used, or when they don't share the same domain or system type as the system.
System..::.InvalidOperationException | Thrown when the operation failed.

See Also

MEPSystem Class
Autodesk.Revit.MEP Namespace


Remove Method

[image]

Revit 2010 API
MEPSystem..::.Remove Method
MEPSystem Class See Also Send Feedback
Remove elements from system.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Remove(
    ElementSet elements
)
Visual Basic (Declaration)
Public Overridable Sub Remove ( _
    elements As ElementSet _
)
Visual C++
public:
virtual void Remove(
    ElementSet^ elements
)

Parameters

elements
Type: Autodesk.Revit..::.ElementSet
The elements to be removed from the system.

Remarks

It is forbidden to remove all terminal elements from system. Terminal elements will be removed from the system automatically after removing this system from document.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument elements is null, or any element in that collection is null.
System..::.ArgumentException | Thrown when some of the elements can't be removed, or when trying to remove all elements from the system. The element which connect to the base equipment can't be removed,
System..::.InvalidOperationException | Thrown when the operation failed.

See Also

MEPSystem Class
Autodesk.Revit.MEP Namespace


MEPSystem Properties

[image] [image]

Revit 2010 API
MEPSystem Properties
MEPSystem Class See Also Send Feedback

The MEPSystem type exposes the following members.

Properties

Name | Description
BaseEquipment | The base panel or equipment of the system.
BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | Connector manager of the system.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Terminal elements in the system.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultSystem | Indicates if the system is a default system or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

MEPSystem Class
Autodesk.Revit.MEP Namespace


BaseEquipment Property

[image]

Revit 2010 API
MEPSystem..::.BaseEquipment Property
MEPSystem Class See Also Send Feedback
The base panel or equipment of the system.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance BaseEquipment { get; }
Visual Basic (Declaration)
Public ReadOnly Property BaseEquipment As FamilyInstance
Visual C++
public:
property FamilyInstance^ BaseEquipment {
    FamilyInstance^ get ();
}

See Also

MEPSystem Class
Autodesk.Revit.MEP Namespace


BaseEquipmentConnector Property

[image]

Revit 2010 API
MEPSystem..::.BaseEquipmentConnector Property
MEPSystem Class See Also Send Feedback
The connector within base equipment which is used to connect with system.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Connector BaseEquipmentConnector { get; }
Visual Basic (Declaration)
Public ReadOnly Property BaseEquipmentConnector As Connector
Visual C++
public:
property Connector^ BaseEquipmentConnector {
    Connector^ get ();
}

Return Value

Returns the connector which connects with the system within base equipment if base equipment has been assigned to system, otherwise returns null.

See Also

MEPSystem Class
Autodesk.Revit.MEP Namespace


ConnectorManager Property

[image]

Revit 2010 API
MEPSystem..::.ConnectorManager Property
MEPSystem Class See Also Send Feedback
Connector manager of the system.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ConnectorManager ConnectorManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConnectorManager As ConnectorManager
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

Remarks

The connector manager includes connectors which are used to connect with terminal elements and base equipment.

See Also

MEPSystem Class
Autodesk.Revit.MEP Namespace


Elements Property

[image]

Revit 2010 API
MEPSystem..::.Elements Property
MEPSystem Class See Also Send Feedback
Terminal elements in the system.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet Elements { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements As ElementSet
Visual C++
public:
property ElementSet^ Elements {
    ElementSet^ get ();
}

Remarks

The return value is a read only collection and doesn't include the base equipment or panel.

See Also

MEPSystem Class
Autodesk.Revit.MEP Namespace


IsDefaultSystem Property

[image]

Revit 2010 API
MEPSystem..::.IsDefaultSystem Property
MEPSystem Class See Also Send Feedback
Indicates if the system is a default system or not.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsDefaultSystem { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDefaultSystem As Boolean
Visual C++
public:
property bool IsDefaultSystem {
    bool get ();
}

Return Value

True if the system is default, otherwise returns false.

Remarks

Terminals which are not assigned to a system manually in mechanical and piping system are in default systems.

See Also

MEPSystem Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
MEPSystem..::.Parameter Property
MEPSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MEPSystem Class
MEPSystem Members
Autodesk.Revit.MEP Namespace


Pipe Class

[image]

Revit 2010 API
Pipe Class
Members See Also Send Feedback
A pipe in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Pipe : MEPCurve
Visual Basic (Declaration)
Public Class Pipe _
    Inherits MEPCurve
Visual C++
public ref class Pipe : public MEPCurve

Remarks

The pipe is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.MEP..::.MEPCurve
Autodesk.Revit.MEP..::.Pipe

See Also

Pipe Members
Autodesk.Revit.MEP Namespace


Pipe Members

[image] [image]

Revit 2010 API
Pipe Members
Pipe Class Constructors Methods Properties See Also Send Feedback

The Pipe type exposes the following members.

Constructors

Name | Description
Pipe | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FlowState | The flow state of the pipe.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PipeType | The pipe type of this pipe.
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

Pipe Class
Autodesk.Revit.MEP Namespace


Pipe Constructor

[image]

Revit 2010 API
Pipe Constructor
Pipe Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Pipe()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Pipe()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Pipe Class
Autodesk.Revit.MEP Namespace


Pipe Methods

[image] [image]

Revit 2010 API
Pipe Methods
Pipe Class See Also Send Feedback

The Pipe type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Pipe Class
Autodesk.Revit.MEP Namespace


Pipe Properties

[image] [image]

Revit 2010 API
Pipe Properties
Pipe Class See Also Send Feedback

The Pipe type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FlowState | The flow state of the pipe.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PipeType | The pipe type of this pipe.
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

Pipe Class
Autodesk.Revit.MEP Namespace


FlowState Property

[image]

Revit 2010 API
Pipe..::.FlowState Property
Pipe Class See Also Send Feedback
The flow state of the pipe.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeFlowState FlowState { get; }
Visual Basic (Declaration)
Public ReadOnly Property FlowState As PipeFlowState
Visual C++
public:
property PipeFlowState FlowState {
    PipeFlowState get ();
}

See Also

Pipe Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
Pipe..::.Parameter Property
Pipe Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Pipe Class
Pipe Members
Autodesk.Revit.MEP Namespace


PipeType Property

[image]

Revit 2010 API
Pipe..::.PipeType Property
Pipe Class See Also Send Feedback
The pipe type of this pipe.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeType PipeType { get; set; }
Visual Basic (Declaration)
Public Property PipeType As PipeType
Visual C++
public:
property PipeType^ PipeType {
    PipeType^ get ();
    void set (PipeType^ value);
}

See Also

Pipe Class
Autodesk.Revit.MEP Namespace


PipeConnectionType Class

[image]

Revit 2010 API
PipeConnectionType Class
Members See Also Send Feedback
A pipe connection type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PipeConnectionType : Symbol
Visual Basic (Declaration)
Public Class PipeConnectionType _
    Inherits Symbol
Visual C++
public ref class PipeConnectionType : public Symbol

Remarks

The pipe connection type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.PipeConnectionType

See Also

PipeConnectionType Members
Autodesk.Revit.MEP Namespace


PipeConnectionType Members

[image] [image]

Revit 2010 API
PipeConnectionType Members
PipeConnectionType Class Constructors Methods Properties See Also Send Feedback

The PipeConnectionType type exposes the following members.

Constructors

Name | Description
PipeConnectionType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PipeConnectionType Class
Autodesk.Revit.MEP Namespace


PipeConnectionType Constructor

[image]

Revit 2010 API
PipeConnectionType Constructor
PipeConnectionType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeConnectionType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PipeConnectionType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PipeConnectionType Class
Autodesk.Revit.MEP Namespace


PipeConnectionType Methods

[image] [image]

Revit 2010 API
PipeConnectionType Methods
PipeConnectionType Class See Also Send Feedback

The PipeConnectionType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipeConnectionType Class
Autodesk.Revit.MEP Namespace


PipeConnectionType Properties

[image] [image]

Revit 2010 API
PipeConnectionType Properties
PipeConnectionType Class See Also Send Feedback

The PipeConnectionType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PipeConnectionType Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
PipeConnectionType..::.Parameter Property
PipeConnectionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PipeConnectionType Class
PipeConnectionType Members
Autodesk.Revit.MEP Namespace


PipeConnector Class

[image]

Revit 2010 API
PipeConnector Class
Members See Also Send Feedback
A pipe connector that is assigned to a mechanical equipment or pipe fitting family. Provides access to the pipe connector in Autodesk Revit MEP family document.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PipeConnector : Element,
    IConnector
Visual Basic (Declaration)
Public Class PipeConnector _
    Inherits Element _
    Implements IConnector
Visual C++
public ref class PipeConnector : public Element,
    IConnector

Remarks

This element type is accessible only in Autodek Revit MEP family documents. Pipe connectors that accessible in MEP project documents are not elements, and are represented by Autodesk::Revit::MEP::Connector.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.MEP..::.PipeConnector

See Also

PipeConnector Members
Autodesk.Revit.MEP Namespace


PipeConnector Members

[image] [image]

Revit 2010 API
PipeConnector Members
PipeConnector Class Constructors Methods Properties See Also Send Feedback

The PipeConnector type exposes the following members.

Constructors

Name | Description
PipeConnector | For internal use only.

Methods

Name | Description
AssignAsPrimary | Assign a pipe connector as a primary pipe connector.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoordinateSystem | The coordinate system of the connector.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Domain | The domain of the connector.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Height | The height of the connector.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsPrimary | Identifies if this is the primary connector in the family.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LinkedConnector | The linked pipe connector.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Origin | The location of the connector in family document.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Radius | The radius of the connector.
Shape | The shape of the connector.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SystemType | The system type of the pipe connector.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Width | The width of the connector.

See Also

PipeConnector Class
Autodesk.Revit.MEP Namespace


PipeConnector Constructor

[image]

Revit 2010 API
PipeConnector Constructor
PipeConnector Class See Also Send Feedback
For internal use only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeConnector()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PipeConnector()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PipeConnector Class
Autodesk.Revit.MEP Namespace


PipeConnector Methods

[image] [image]

Revit 2010 API
PipeConnector Methods
PipeConnector Class See Also Send Feedback

The PipeConnector type exposes the following members.

Methods

Name | Description
AssignAsPrimary | Assign a pipe connector as a primary pipe connector.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipeConnector Class
Autodesk.Revit.MEP Namespace


AssignAsPrimary Method

[image]

Revit 2010 API
PipeConnector..::.AssignAsPrimary Method
PipeConnector Class See Also Send Feedback
Assign a pipe connector as a primary pipe connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AssignAsPrimary()
Visual Basic (Declaration)
Public Sub AssignAsPrimary
Visual C++
public:
void AssignAsPrimary()

Remarks

This method is used to promote this pipe connector as primary, and the rest of connectors in this system will be assigned as secondary.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when fail to assign this connector as primary.

See Also

PipeConnector Class
Autodesk.Revit.MEP Namespace


PipeConnector Properties

[image] [image]

Revit 2010 API
PipeConnector Properties
PipeConnector Class See Also Send Feedback

The PipeConnector type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoordinateSystem | The coordinate system of the connector.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Domain | The domain of the connector.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Height | The height of the connector.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsPrimary | Identifies if this is the primary connector in the family.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LinkedConnector | The linked pipe connector.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Origin | The location of the connector in family document.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Radius | The radius of the connector.
Shape | The shape of the connector.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SystemType | The system type of the pipe connector.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Width | The width of the connector.

See Also

PipeConnector Class
Autodesk.Revit.MEP Namespace


CoordinateSystem Property

[image]

Revit 2010 API
PipeConnector..::.CoordinateSystem Property
PipeConnector Class See Also Send Feedback
The coordinate system of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Transform CoordinateSystem { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property CoordinateSystem As Transform
Visual C++
public:
virtual property Transform^ CoordinateSystem {
    Transform^ get ();
}

Implements

IConnector..::.CoordinateSystem

Remarks

The Z axis of the coordinate system is the normal to the plane of the connector.

See Also

PipeConnector Class
Autodesk.Revit.MEP Namespace


Domain Property

[image]

Revit 2010 API
PipeConnector..::.Domain Property
PipeConnector Class See Also Send Feedback
The domain of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Domain Domain { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Domain As Domain
Visual C++
public:
virtual property Domain Domain {
    Domain get ();
}

Implements

IConnector..::.Domain

Remarks

This property is used to retrieve the domain of the connector.

See Also

PipeConnector Class
Autodesk.Revit.MEP Namespace


Height Property

[image]

Revit 2010 API
PipeConnector..::.Height Property
PipeConnector Class See Also Send Feedback
The height of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual double Height { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Height As Double
Visual C++
public:
virtual property double Height {
    double get ();
}

Implements

IConnector..::.Height

Remarks

shape for pipe connector is round.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Always thrown because pipe connector's shape is always round.

See Also

PipeConnector Class
Autodesk.Revit.MEP Namespace


IsPrimary Property

[image]

Revit 2010 API
PipeConnector..::.IsPrimary Property
PipeConnector Class See Also Send Feedback
Identifies if this is the primary connector in the family.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsPrimary { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPrimary As Boolean
Visual C++
public:
property bool IsPrimary {
    bool get ();
}

See Also

PipeConnector Class
Autodesk.Revit.MEP Namespace


LinkedConnector Property

[image]

Revit 2010 API
PipeConnector..::.LinkedConnector Property
PipeConnector Class See Also Send Feedback
The linked pipe connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeConnector LinkedConnector { get; set; }
Visual Basic (Declaration)
Public Property LinkedConnector As PipeConnector
Visual C++
public:
property PipeConnector^ LinkedConnector {
    PipeConnector^ get ();
    void set (PipeConnector^ value);
}

Remarks

Get this property to acquire the current linked pipe connector. If the property is null, the connector has no link. Set this property to link this connector to another pipe connector. Set it to null to remove the link.

See Also

PipeConnector Class
Autodesk.Revit.MEP Namespace


Origin Property

[image]

Revit 2010 API
PipeConnector..::.Origin Property
PipeConnector Class See Also Send Feedback
The location of the connector in family document.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual XYZ Origin { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Origin As XYZ
Visual C++
public:
virtual property XYZ^ Origin {
    XYZ^ get ();
}

Implements

IConnector..::.Origin

See Also

PipeConnector Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
PipeConnector..::.Parameter Property
PipeConnector Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PipeConnector Class
PipeConnector Members
Autodesk.Revit.MEP Namespace


Radius Property

[image]

Revit 2010 API
PipeConnector..::.Radius Property
PipeConnector Class See Also Send Feedback
The radius of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual double Radius { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Radius As Double
Visual C++
public:
virtual property double Radius {
    double get ();
}

Implements

IConnector..::.Radius

Remarks

A pipe connector's shape is always round.

See Also

PipeConnector Class
Autodesk.Revit.MEP Namespace


Shape Property

[image]

Revit 2010 API
PipeConnector..::.Shape Property
PipeConnector Class See Also Send Feedback
The shape of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ConnectorProfileType Shape { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Shape As ConnectorProfileType
Visual C++
public:
virtual property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}

Implements

IConnector..::.Shape

Remarks

A pipe connector's shape is always round.

See Also

PipeConnector Class
Autodesk.Revit.MEP Namespace


SystemType Property

[image]

Revit 2010 API
PipeConnector..::.SystemType Property
PipeConnector Class See Also Send Feedback
The system type of the pipe connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeSystemType SystemType { get; set; }
Visual Basic (Declaration)
Public Property SystemType As PipeSystemType
Visual C++
public:
property PipeSystemType SystemType {
    PipeSystemType get ();
    void set (PipeSystemType value);
}

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the input system type is not within the permitted range.

See Also

PipeConnector Class
Autodesk.Revit.MEP Namespace


Width Property

[image]

Revit 2010 API
PipeConnector..::.Width Property
PipeConnector Class See Also Send Feedback
The width of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual double Width { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Width As Double
Visual C++
public:
virtual property double Width {
    double get ();
}

Implements

IConnector..::.Width

Remarks

shape for pipe connector is round.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Always thrown because pipe connector's shape is always round.

See Also

PipeConnector Class
Autodesk.Revit.MEP Namespace


PipeMaterialType Class

[image]

Revit 2010 API
PipeMaterialType Class
Members See Also Send Feedback
A pipe material type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PipeMaterialType : Symbol
Visual Basic (Declaration)
Public Class PipeMaterialType _
    Inherits Symbol
Visual C++
public ref class PipeMaterialType : public Symbol

Remarks

The pipe material type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.PipeMaterialType

See Also

PipeMaterialType Members
Autodesk.Revit.MEP Namespace


PipeMaterialType Members

[image] [image]

Revit 2010 API
PipeMaterialType Members
PipeMaterialType Class Constructors Methods Properties See Also Send Feedback

The PipeMaterialType type exposes the following members.

Constructors

Name | Description
PipeMaterialType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PipeMaterialType Class
Autodesk.Revit.MEP Namespace


PipeMaterialType Constructor

[image]

Revit 2010 API
PipeMaterialType Constructor
PipeMaterialType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeMaterialType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PipeMaterialType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PipeMaterialType Class
Autodesk.Revit.MEP Namespace


PipeMaterialType Methods

[image] [image]

Revit 2010 API
PipeMaterialType Methods
PipeMaterialType Class See Also Send Feedback

The PipeMaterialType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipeMaterialType Class
Autodesk.Revit.MEP Namespace


PipeMaterialType Properties

[image] [image]

Revit 2010 API
PipeMaterialType Properties
PipeMaterialType Class See Also Send Feedback

The PipeMaterialType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PipeMaterialType Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
PipeMaterialType..::.Parameter Property
PipeMaterialType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PipeMaterialType Class
PipeMaterialType Members
Autodesk.Revit.MEP Namespace


PipeScheduleType Class

[image]

Revit 2010 API
PipeScheduleType Class
Members See Also Send Feedback
A pipe schedule type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PipeScheduleType : Symbol
Visual Basic (Declaration)
Public Class PipeScheduleType _
    Inherits Symbol
Visual C++
public ref class PipeScheduleType : public Symbol

Remarks

The pipe schedule type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.PipeScheduleType

See Also

PipeScheduleType Members
Autodesk.Revit.MEP Namespace


PipeScheduleType Members

[image] [image]

Revit 2010 API
PipeScheduleType Members
PipeScheduleType Class Constructors Methods Properties See Also Send Feedback

The PipeScheduleType type exposes the following members.

Constructors

Name | Description
PipeScheduleType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PipeScheduleType Class
Autodesk.Revit.MEP Namespace


PipeScheduleType Constructor

[image]

Revit 2010 API
PipeScheduleType Constructor
PipeScheduleType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeScheduleType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PipeScheduleType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PipeScheduleType Class
Autodesk.Revit.MEP Namespace


PipeScheduleType Methods

[image] [image]

Revit 2010 API
PipeScheduleType Methods
PipeScheduleType Class See Also Send Feedback

The PipeScheduleType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipeScheduleType Class
Autodesk.Revit.MEP Namespace


PipeScheduleType Properties

[image] [image]

Revit 2010 API
PipeScheduleType Properties
PipeScheduleType Class See Also Send Feedback

The PipeScheduleType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PipeScheduleType Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
PipeScheduleType..::.Parameter Property
PipeScheduleType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PipeScheduleType Class
PipeScheduleType Members
Autodesk.Revit.MEP Namespace


PipeType Class

[image]

Revit 2010 API
PipeType Class
Members See Also Send Feedback
A pipe type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PipeType : MEPCurveType
Visual Basic (Declaration)
Public Class PipeType _
    Inherits MEPCurveType
Visual C++
public ref class PipeType : public MEPCurveType

Remarks

The pipe type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.MEPCurveType
Autodesk.Revit.MEP..::.PipeType

See Also

PipeType Members
Autodesk.Revit.MEP Namespace


PipeType Members

[image] [image]

Revit 2010 API
PipeType Members
PipeType Class Constructors Methods Properties See Also Send Feedback

The PipeType type exposes the following members.

Constructors

Name | Description
PipeType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Class | The schedule type of the pipe type.
ConnectionType | The connection type of the pipe type.
Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Material | The material type of the pipe type.
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Roughness | The roughness of the pipe type. (Overrides MEPCurveType..::.Roughness.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PipeType Class
Autodesk.Revit.MEP Namespace


PipeType Constructor

[image]

Revit 2010 API
PipeType Constructor
PipeType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PipeType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PipeType Class
Autodesk.Revit.MEP Namespace


PipeType Methods

[image] [image]

Revit 2010 API
PipeType Methods
PipeType Class See Also Send Feedback

The PipeType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipeType Class
Autodesk.Revit.MEP Namespace


PipeType Properties

[image] [image]

Revit 2010 API
PipeType Properties
PipeType Class See Also Send Feedback

The PipeType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Class | The schedule type of the pipe type.
ConnectionType | The connection type of the pipe type.
Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Material | The material type of the pipe type.
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Roughness | The roughness of the pipe type. (Overrides MEPCurveType..::.Roughness.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PipeType Class
Autodesk.Revit.MEP Namespace


Class Property

[image]

Revit 2010 API
PipeType..::.Class Property
PipeType Class See Also Send Feedback
The schedule type of the pipe type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeScheduleType Class { get; }
Visual Basic (Declaration)
Public ReadOnly Property Class As PipeScheduleType
Visual C++
public:
property PipeScheduleType^ Class {
    PipeScheduleType^ get ();
}

See Also

PipeType Class
Autodesk.Revit.MEP Namespace


ConnectionType Property

[image]

Revit 2010 API
PipeType..::.ConnectionType Property
PipeType Class See Also Send Feedback
The connection type of the pipe type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeConnectionType ConnectionType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConnectionType As PipeConnectionType
Visual C++
public:
property PipeConnectionType^ ConnectionType {
    PipeConnectionType^ get ();
}

See Also

PipeType Class
Autodesk.Revit.MEP Namespace


Material Property

[image]

Revit 2010 API
PipeType..::.Material Property
PipeType Class See Also Send Feedback
The material type of the pipe type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeMaterialType Material { get; }
Visual Basic (Declaration)
Public ReadOnly Property Material As PipeMaterialType
Visual C++
public:
property PipeMaterialType^ Material {
    PipeMaterialType^ get ();
}

See Also

PipeType Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
PipeType..::.Parameter Property
PipeType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PipeType Class
PipeType Members
Autodesk.Revit.MEP Namespace


Roughness Property

[image]

Revit 2010 API
PipeType..::.Roughness Property
PipeType Class See Also Send Feedback
The roughness of the pipe type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override double Roughness { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Roughness As Double
Visual C++
public:
virtual property double Roughness {
    void set (double value) override;
}

Remarks

set for this property will always throw an exception.

See Also

PipeType Class
Autodesk.Revit.MEP Namespace


PipingSystem Class

[image]

Revit 2010 API
PipingSystem Class
Members See Also Send Feedback
A piping system in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PipingSystem : MEPSystem
Visual Basic (Declaration)
Public Class PipingSystem _
    Inherits MEPSystem
Visual C++
public ref class PipingSystem : public MEPSystem

Remarks

The piping system element is only available in Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.MEP..::.MEPSystem
Autodesk.Revit.MEP..::.PipingSystem

See Also

PipingSystem Members
Autodesk.Revit.MEP Namespace


PipingSystem Members

[image] [image]

Revit 2010 API
PipingSystem Members
PipingSystem Class Constructors Methods Properties See Also Send Feedback

The PipingSystem type exposes the following members.

Constructors

Name | Description
PipingSystem | For Internal Use Only.

Methods

Name | Description
Add | Add elements into the system and connect them with the system using given connectors. (Inherited from MEPSystem.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Remove | Remove elements from system. (Inherited from MEPSystem.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Flow | The system flow.
FluidDensity | The system fluid density.
FluidTemperature | The system fluid temperature.
FluidType | The system fluid type.
FluidViscosity | The system fluid viscosity.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsWellConnected | Indicates if the system is well connected or not.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PipingNetwork | Pipes and fittings which are contained in this system.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
StaticPressure | The system static pressure.
SystemType | The type of this piping system.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PipingSystem Class
Autodesk.Revit.MEP Namespace


PipingSystem Constructor

[image]

Revit 2010 API
PipingSystem Constructor
PipingSystem Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipingSystem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PipingSystem()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PipingSystem Class
Autodesk.Revit.MEP Namespace


PipingSystem Methods

[image] [image]

Revit 2010 API
PipingSystem Methods
PipingSystem Class See Also Send Feedback

The PipingSystem type exposes the following members.

Methods

Name | Description
Add | Add elements into the system and connect them with the system using given connectors. (Inherited from MEPSystem.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Remove | Remove elements from system. (Inherited from MEPSystem.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipingSystem Class
Autodesk.Revit.MEP Namespace


PipingSystem Properties

[image] [image]

Revit 2010 API
PipingSystem Properties
PipingSystem Class See Also Send Feedback

The PipingSystem type exposes the following members.

Properties

Name | Description
BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Flow | The system flow.
FluidDensity | The system fluid density.
FluidTemperature | The system fluid temperature.
FluidType | The system fluid type.
FluidViscosity | The system fluid viscosity.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsWellConnected | Indicates if the system is well connected or not.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PipingNetwork | Pipes and fittings which are contained in this system.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
StaticPressure | The system static pressure.
SystemType | The type of this piping system.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PipingSystem Class
Autodesk.Revit.MEP Namespace


BaseEquipmentConnector Property

[image]

Revit 2010 API
PipingSystem..::.BaseEquipmentConnector Property
PipingSystem Class See Also Send Feedback
The connector within base equipment which is used to connect with system.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Connector BaseEquipmentConnector { get; set; }
Visual Basic (Declaration)
Public Property BaseEquipmentConnector As Connector
Visual C++
public:
property Connector^ BaseEquipmentConnector {
    Connector^ get ();
    void set (Connector^ value);
}

Remarks

Setting this property to null will disconnect base equipment from system.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when assigning a connector which is used in a system, or when the connector's owner is not of type 'mechanical equipment'.
System..::.InvalidOperationException | Thrown when the set operation failed.

See Also

PipingSystem Class
Autodesk.Revit.MEP Namespace


Flow Property

[image]

Revit 2010 API
PipingSystem..::.Flow Property
PipingSystem Class See Also Send Feedback
The system flow.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Flow { get; }
Visual Basic (Declaration)
Public ReadOnly Property Flow As Double
Visual C++
public:
property double Flow {
    double get ();
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Throw when the flow is not computed because the system is not well connected.

See Also

PipingSystem Class
Autodesk.Revit.MEP Namespace


FluidDensity Property

[image]

Revit 2010 API
PipingSystem..::.FluidDensity Property
PipingSystem Class See Also Send Feedback
The system fluid density.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double FluidDensity { get; }
Visual Basic (Declaration)
Public ReadOnly Property FluidDensity As Double
Visual C++
public:
property double FluidDensity {
    double get ();
}

See Also

PipingSystem Class
Autodesk.Revit.MEP Namespace


FluidTemperature Property

[image]

Revit 2010 API
PipingSystem..::.FluidTemperature Property
PipingSystem Class See Also Send Feedback
The system fluid temperature.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double FluidTemperature { get; set; }
Visual Basic (Declaration)
Public Property FluidTemperature As Double
Visual C++
public:
property double FluidTemperature {
    double get ();
    void set (double value);
}

Remarks

Only a fixed set of possible fluid temperatures are permitted by Revit MEP for each system fluid type. Setting this property will map to the nearest appropriate value used internally for the system fluid type.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when assigning a value which is not a valid positive number.

See Also

PipingSystem Class
Autodesk.Revit.MEP Namespace


FluidType Property

[image]

Revit 2010 API
PipingSystem..::.FluidType Property
PipingSystem Class See Also Send Feedback
The system fluid type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FluidType FluidType { get; set; }
Visual Basic (Declaration)
Public Property FluidType As FluidType
Visual C++
public:
property FluidType^ FluidType {
    FluidType^ get ();
    void set (FluidType^ value);
}

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when assigning a null value to fluid type.

See Also

PipingSystem Class
Autodesk.Revit.MEP Namespace


FluidViscosity Property

[image]

Revit 2010 API
PipingSystem..::.FluidViscosity Property
PipingSystem Class See Also Send Feedback
The system fluid viscosity.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double FluidViscosity { get; }
Visual Basic (Declaration)
Public ReadOnly Property FluidViscosity As Double
Visual C++
public:
property double FluidViscosity {
    double get ();
}

See Also

PipingSystem Class
Autodesk.Revit.MEP Namespace


IsWellConnected Property

[image]

Revit 2010 API
PipingSystem..::.IsWellConnected Property
PipingSystem Class See Also Send Feedback
Indicates if the system is well connected or not.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsWellConnected { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsWellConnected As Boolean
Visual C++
public:
property bool IsWellConnected {
    bool get ();
}

Remarks

If the system is not well connected, parameters which need to be calculated are invalid.

See Also

PipingSystem Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
PipingSystem..::.Parameter Property
PipingSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PipingSystem Class
PipingSystem Members
Autodesk.Revit.MEP Namespace


PipingNetwork Property

[image]

Revit 2010 API
PipingSystem..::.PipingNetwork Property
PipingSystem Class See Also Send Feedback
Pipes and fittings which are contained in this system.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet PipingNetwork { get; }
Visual Basic (Declaration)
Public ReadOnly Property PipingNetwork As ElementSet
Visual C++
public:
property ElementSet^ PipingNetwork {
    ElementSet^ get ();
}

Remarks

The return value doesn't include mechanical equipment elements. The pipes and fittings are not returned in any particular order.

See Also

PipingSystem Class
Autodesk.Revit.MEP Namespace


StaticPressure Property

[image]

Revit 2010 API
PipingSystem..::.StaticPressure Property
PipingSystem Class See Also Send Feedback
The system static pressure.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double StaticPressure { get; }
Visual Basic (Declaration)
Public ReadOnly Property StaticPressure As Double
Visual C++
public:
property double StaticPressure {
    double get ();
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Throw when the static pressure is not computed because the system is not well connected.

See Also

PipingSystem Class
Autodesk.Revit.MEP Namespace


SystemType Property

[image]

Revit 2010 API
PipingSystem..::.SystemType Property
PipingSystem Class See Also Send Feedback
The type of this piping system.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeSystemType SystemType { get; }
Visual Basic (Declaration)
Public ReadOnly Property SystemType As PipeSystemType
Visual C++
public:
property PipeSystemType SystemType {
    PipeSystemType get ();
}

See Also

PipingSystem Class
Autodesk.Revit.MEP Namespace


TemperatureRatingType Class

[image]

Revit 2010 API
TemperatureRatingType Class
Members See Also Send Feedback
Represents temperature rating type definition information.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class TemperatureRatingType : Element
Visual Basic (Declaration)
Public Class TemperatureRatingType _
    Inherits Element
Visual C++
public ref class TemperatureRatingType : public Element

Remarks

Temperature rating type is defined based on corresponding wire material type. It includes type informations such as wire size, insulation type, correction factor, etc. Only the temperature rating types which are retrieved from WireMaterialType can work well, so don't retrieve it from Revit document directly.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.MEP..::.TemperatureRatingType

See Also

TemperatureRatingType Members
Autodesk.Revit.MEP Namespace


TemperatureRatingType Members

[image] [image]

Revit 2010 API
TemperatureRatingType Members
TemperatureRatingType Class Constructors Methods Properties See Also Send Feedback

The TemperatureRatingType type exposes the following members.

Constructors

Name | Description
TemperatureRatingType | Initializes a new instance of the TemperatureRatingType class

Methods

Name | Description
AddCorrectionFactor | Add a new electrical correction factor type to this temperature rating type.
AddInsulationType | Add a new kind of insulation type into this temperature rating type.
AddWireSize | Add a new kind of wire size type into this temperature rating type.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveCorrectionFactor | Remove an existing correction factor from this temperature rating type in Revit MEP project.
RemoveInsulationType | Remove an existing insulation type from this temperature rating type.
RemoveWireSize | Remove an existing wire size type from this temperature rating type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CorrectionFactors | Get all correction factors defined in this temperature rating type and its corresponding material type.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
InsulationTypes | Get all insulation types defined in this temperature rating type and its corresponding material type.
IsInUse | Indicate whether the temperature rating type is in use.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaterialType | Get the material type information which this temperature rating type belongs to.
Name | Get name of temperature rating type. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
WireSizes | Get all electrical wire sizes defined in this temperature rating type and its corresponding material type.

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace


TemperatureRatingType Constructor

[image]

Revit 2010 API
TemperatureRatingType Constructor
TemperatureRatingType Class See Also Send Feedback
Initializes a new instance of the TemperatureRatingType class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TemperatureRatingType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TemperatureRatingType()

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace


TemperatureRatingType Methods

[image] [image]

Revit 2010 API
TemperatureRatingType Methods
TemperatureRatingType Class See Also Send Feedback

The TemperatureRatingType type exposes the following members.

Methods

Name | Description
AddCorrectionFactor | Add a new electrical correction factor type to this temperature rating type.
AddInsulationType | Add a new kind of insulation type into this temperature rating type.
AddWireSize | Add a new kind of wire size type into this temperature rating type.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveCorrectionFactor | Remove an existing correction factor from this temperature rating type in Revit MEP project.
RemoveInsulationType | Remove an existing insulation type from this temperature rating type.
RemoveWireSize | Remove an existing wire size type from this temperature rating type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace


AddCorrectionFactor Method

[image]

Revit 2010 API
TemperatureRatingType..::.AddCorrectionFactor Method
TemperatureRatingType Class See Also Send Feedback
Add a new electrical correction factor type to this temperature rating type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CorrectionFactor AddCorrectionFactor(
    long temperature,
    double factor
)
Visual Basic (Declaration)
Public Function AddCorrectionFactor ( _
    temperature As Long, _
    factor As Double _
) As CorrectionFactor
Visual C++
public:
CorrectionFactor^ AddCorrectionFactor(
    long long temperature,
    double factor
)

Parameters

temperature
Type: System..::.Int64
Temperature of correction factor to be added.
factor
Type: System..::.Double
Factor of correction factor to be added.

Return Value

New constructed correction factor.

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace


AddInsulationType Method

[image]

Revit 2010 API
TemperatureRatingType..::.AddInsulationType Method
TemperatureRatingType Class See Also Send Feedback
Add a new kind of insulation type into this temperature rating type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InsulationType AddInsulationType(
    string name
)
Visual Basic (Declaration)
Public Function AddInsulationType ( _
    name As String _
) As InsulationType
Visual C++
public:
InsulationType^ AddInsulationType(
    String^ name
)

Parameters

name
Type: System..::.String
Name of insulation type symbol to be constructed and added.

Return Value

Constructed insulation type instance.

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace


AddWireSize Method

[image]

Revit 2010 API
TemperatureRatingType..::.AddWireSize Method
TemperatureRatingType Class See Also Send Feedback
Add a new kind of wire size type into this temperature rating type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireSize AddWireSize(
    string size,
    long ampacity,
    double diameter
)
Visual Basic (Declaration)
Public Function AddWireSize ( _
    size As String, _
    ampacity As Long, _
    diameter As Double _
) As WireSize
Visual C++
public:
WireSize^ AddWireSize(
    String^ size,
    long long ampacity,
    double diameter
)

Parameters

size
Type: System..::.String
Size of wire size.
ampacity
Type: System..::.Int64
Ampacity of wire size to be added.
diameter
Type: System..::.Double
Diameter of wire size to be added.

Return Value

Constructed wire size type.

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace


RemoveCorrectionFactor Method

[image]

Revit 2010 API
TemperatureRatingType..::.RemoveCorrectionFactor Method
TemperatureRatingType Class See Also Send Feedback
Remove an existing correction factor from this temperature rating type in Revit MEP project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveCorrectionFactor(
    CorrectionFactor correctionFactor
)
Visual Basic (Declaration)
Public Sub RemoveCorrectionFactor ( _
    correctionFactor As CorrectionFactor _
)
Visual C++
public:
void RemoveCorrectionFactor(
    CorrectionFactor^ correctionFactor
)

Parameters

correctionFactor
Type: Autodesk.Revit.MEP..::.CorrectionFactor
The correction factor to be removed.

Return Value

New constructed correction factor.

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace


RemoveInsulationType Method

[image]

Revit 2010 API
TemperatureRatingType..::.RemoveInsulationType Method
TemperatureRatingType Class See Also Send Feedback
Remove an existing insulation type from this temperature rating type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveInsulationType(
    InsulationType insulationType
)
Visual Basic (Declaration)
Public Sub RemoveInsulationType ( _
    insulationType As InsulationType _
)
Visual C++
public:
void RemoveInsulationType(
    InsulationType^ insulationType
)

Parameters

insulationType
Type: Autodesk.Revit.MEP..::.InsulationType
Insulation type to be removed.

Exceptions

Exception | Condition
System..::.InvalidOperationException | The last one insulation type of project and any one which is in use by a wire type can't be removed.

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace


RemoveWireSize Method

[image]

Revit 2010 API
TemperatureRatingType..::.RemoveWireSize Method
TemperatureRatingType Class See Also Send Feedback
Remove an existing wire size type from this temperature rating type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveWireSize(
    WireSize wireSize
)
Visual Basic (Declaration)
Public Sub RemoveWireSize ( _
    wireSize As WireSize _
)
Visual C++
public:
void RemoveWireSize(
    WireSize^ wireSize
)

Parameters

wireSize
Type: Autodesk.Revit.MEP..::.WireSize
The wire size type to be removed.

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace


TemperatureRatingType Properties

[image] [image]

Revit 2010 API
TemperatureRatingType Properties
TemperatureRatingType Class See Also Send Feedback

The TemperatureRatingType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CorrectionFactors | Get all correction factors defined in this temperature rating type and its corresponding material type.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
InsulationTypes | Get all insulation types defined in this temperature rating type and its corresponding material type.
IsInUse | Indicate whether the temperature rating type is in use.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaterialType | Get the material type information which this temperature rating type belongs to.
Name | Get name of temperature rating type. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
WireSizes | Get all electrical wire sizes defined in this temperature rating type and its corresponding material type.

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace


CorrectionFactors Property

[image]

Revit 2010 API
TemperatureRatingType..::.CorrectionFactors Property
TemperatureRatingType Class See Also Send Feedback
Get all correction factors defined in this temperature rating type and its corresponding material type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CorrectionFactorSet CorrectionFactors { get; }
Visual Basic (Declaration)
Public ReadOnly Property CorrectionFactors As CorrectionFactorSet
Visual C++
public:
property CorrectionFactorSet^ CorrectionFactors {
    CorrectionFactorSet^ get ();
}

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace


InsulationTypes Property

[image]

Revit 2010 API
TemperatureRatingType..::.InsulationTypes Property
TemperatureRatingType Class See Also Send Feedback
Get all insulation types defined in this temperature rating type and its corresponding material type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InsulationTypeSet InsulationTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property InsulationTypes As InsulationTypeSet
Visual C++
public:
property InsulationTypeSet^ InsulationTypes {
    InsulationTypeSet^ get ();
}

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace


IsInUse Property

[image]

Revit 2010 API
TemperatureRatingType..::.IsInUse Property
TemperatureRatingType Class See Also Send Feedback
Indicate whether the temperature rating type is in use.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsInUse { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInUse As Boolean
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace


MaterialType Property

[image]

Revit 2010 API
TemperatureRatingType..::.MaterialType Property
TemperatureRatingType Class See Also Send Feedback
Get the material type information which this temperature rating type belongs to.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireMaterialType MaterialType { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaterialType As WireMaterialType
Visual C++
public:
property WireMaterialType^ MaterialType {
    WireMaterialType^ get ();
}

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace


Name Property

[image]

Revit 2010 API
TemperatureRatingType..::.Name Property
TemperatureRatingType Class See Also Send Feedback
Get name of temperature rating type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Exceptions

Exception | Condition
System..::.NotSupportedException | Set name can't be supported.

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
TemperatureRatingType..::.Parameter Property
TemperatureRatingType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

TemperatureRatingType Class
TemperatureRatingType Members
Autodesk.Revit.MEP Namespace


WireSizes Property

[image]

Revit 2010 API
TemperatureRatingType..::.WireSizes Property
TemperatureRatingType Class See Also Send Feedback
Get all electrical wire sizes defined in this temperature rating type and its corresponding material type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireSizeSet WireSizes { get; }
Visual Basic (Declaration)
Public ReadOnly Property WireSizes As WireSizeSet
Visual C++
public:
property WireSizeSet^ WireSizes {
    WireSizeSet^ get ();
}

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace


TemperatureRatingTypeSet Class

[image]

Revit 2010 API
TemperatureRatingTypeSet Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class TemperatureRatingTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class TemperatureRatingTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class TemperatureRatingTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.TemperatureRatingTypeSet

See Also

TemperatureRatingTypeSet Members
Autodesk.Revit.MEP Namespace


TemperatureRatingTypeSet Members

[image] [image]

Revit 2010 API
TemperatureRatingTypeSet Members
TemperatureRatingTypeSet Class Constructors Methods Properties See Also Send Feedback

The TemperatureRatingTypeSet type exposes the following members.

Constructors

Name | Description
TemperatureRatingTypeSet | Initializes a new instance of the TemperatureRatingTypeSet class

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.MEP Namespace


TemperatureRatingTypeSet Constructor

[image]

Revit 2010 API
TemperatureRatingTypeSet Constructor
TemperatureRatingTypeSet Class See Also Send Feedback
Initializes a new instance of the TemperatureRatingTypeSet class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TemperatureRatingTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TemperatureRatingTypeSet()

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.MEP Namespace


TemperatureRatingTypeSet Methods

[image] [image]

Revit 2010 API
TemperatureRatingTypeSet Methods
TemperatureRatingTypeSet Class See Also Send Feedback

The TemperatureRatingTypeSet type exposes the following members.

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.MEP Namespace


Clear Method

[image]

Revit 2010 API
TemperatureRatingTypeSet..::.Clear Method
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.MEP Namespace


Contains Method

[image]

Revit 2010 API
TemperatureRatingTypeSet..::.Contains Method
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    TemperatureRatingType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As TemperatureRatingType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    TemperatureRatingType^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.TemperatureRatingType

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.MEP Namespace


Erase Method

[image]

Revit 2010 API
TemperatureRatingTypeSet..::.Erase Method
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    TemperatureRatingType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As TemperatureRatingType _
) As Integer
Visual C++
public:
virtual int Erase(
    TemperatureRatingType^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.TemperatureRatingType

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.MEP Namespace


ForwardIterator Method

[image]

Revit 2010 API
TemperatureRatingTypeSet..::.ForwardIterator Method
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual TemperatureRatingTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As TemperatureRatingTypeSetIterator
Visual C++
public:
virtual TemperatureRatingTypeSetIterator^ ForwardIterator()

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.MEP Namespace


GetEnumerator Method

[image]

Revit 2010 API
TemperatureRatingTypeSet..::.GetEnumerator Method
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::.GetEnumerator()()()

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.MEP Namespace


Insert Method

[image]

Revit 2010 API
TemperatureRatingTypeSet..::.Insert Method
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    TemperatureRatingType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As TemperatureRatingType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    TemperatureRatingType^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.TemperatureRatingType

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.MEP Namespace


ReverseIterator Method

[image]

Revit 2010 API
TemperatureRatingTypeSet..::.ReverseIterator Method
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual TemperatureRatingTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As TemperatureRatingTypeSetIterator
Visual C++
public:
virtual TemperatureRatingTypeSetIterator^ ReverseIterator()

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.MEP Namespace


TemperatureRatingTypeSet Properties

[image] [image]

Revit 2010 API
TemperatureRatingTypeSet Properties
TemperatureRatingTypeSet Class See Also Send Feedback

The TemperatureRatingTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.MEP Namespace


IsEmpty Property

[image]

Revit 2010 API
TemperatureRatingTypeSet..::.IsEmpty Property
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.MEP Namespace


Size Property

[image]

Revit 2010 API
TemperatureRatingTypeSet..::.Size Property
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.MEP Namespace


TemperatureRatingTypeSetIterator Class

[image]

Revit 2010 API
TemperatureRatingTypeSetIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class TemperatureRatingTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class TemperatureRatingTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class TemperatureRatingTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.TemperatureRatingTypeSetIterator

See Also

TemperatureRatingTypeSetIterator Members
Autodesk.Revit.MEP Namespace


TemperatureRatingTypeSetIterator Members

[image] [image]

Revit 2010 API
TemperatureRatingTypeSetIterator Members
TemperatureRatingTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The TemperatureRatingTypeSetIterator type exposes the following members.

Constructors

Name | Description
TemperatureRatingTypeSetIterator | Initializes a new instance of the TemperatureRatingTypeSetIterator class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.MEP Namespace


TemperatureRatingTypeSetIterator Constructor

[image]

Revit 2010 API
TemperatureRatingTypeSetIterator Constructor
TemperatureRatingTypeSetIterator Class See Also Send Feedback
Initializes a new instance of the TemperatureRatingTypeSetIterator class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TemperatureRatingTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TemperatureRatingTypeSetIterator()

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.MEP Namespace


TemperatureRatingTypeSetIterator Methods

[image] [image]

Revit 2010 API
TemperatureRatingTypeSetIterator Methods
TemperatureRatingTypeSetIterator Class See Also Send Feedback

The TemperatureRatingTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.MEP Namespace


MoveNext Method

[image]

Revit 2010 API
TemperatureRatingTypeSetIterator..::.MoveNext Method
TemperatureRatingTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::.MoveNext()()()

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.MEP Namespace


Reset Method

[image]

Revit 2010 API
TemperatureRatingTypeSetIterator..::.Reset Method
TemperatureRatingTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.MEP Namespace


TemperatureRatingTypeSetIterator Properties

[image] [image]

Revit 2010 API
TemperatureRatingTypeSetIterator Properties
TemperatureRatingTypeSetIterator Class See Also Send Feedback

The TemperatureRatingTypeSetIterator type exposes the following members.

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.MEP Namespace


Current Property

[image]

Revit 2010 API
TemperatureRatingTypeSetIterator..::.Current Property
TemperatureRatingTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.MEP Namespace


VoltageType Class

[image]

Revit 2010 API
VoltageType Class
Members See Also Send Feedback
Represents electrical voltage type. An electrical voltage type define a range of voltages, and circuits can be created between components with rated voltages that do not precisely match the voltage definition value.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class VoltageType : Symbol
Visual Basic (Declaration)
Public Class VoltageType _
    Inherits Symbol
Visual C++
public ref class VoltageType : public Symbol

Remarks

Actual, minimum and maximum value of voltage type can retrieved through properties, but only can be modified through SetVoltageValue method. All the unit of voltage properties in this class is volt.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.VoltageType

See Also

VoltageType Members
Autodesk.Revit.MEP Namespace


VoltageType Members

[image] [image]

Revit 2010 API
VoltageType Members
VoltageType Class Constructors Methods Properties See Also Send Feedback

The VoltageType type exposes the following members.

Constructors

Name | Description
VoltageType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVoltageValue | Assign new values to modify voltage type, all of the unit are volt.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActualValue | Get actual voltage value of this voltage definition, the unit is volt.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInUse | Indicates whether this voltage type is in service now, such as by other distribution system.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaxValue | Get upper boundary of voltage value of this voltage definition, the unit is volt.
MinValue | Get lower boundary of voltage value of this voltage definition, the unit is volt.
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

VoltageType Class
Autodesk.Revit.MEP Namespace


VoltageType Constructor

[image]

Revit 2010 API
VoltageType Constructor
VoltageType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public VoltageType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VoltageType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

VoltageType Class
Autodesk.Revit.MEP Namespace


VoltageType Methods

[image] [image]

Revit 2010 API
VoltageType Methods
VoltageType Class See Also Send Feedback

The VoltageType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetVoltageValue | Assign new values to modify voltage type, all of the unit are volt.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VoltageType Class
Autodesk.Revit.MEP Namespace


SetVoltageValue Method

[image]

Revit 2010 API
VoltageType..::.SetVoltageValue Method
VoltageType Class See Also Send Feedback
Assign new values to modify voltage type, all of the unit are volt.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetVoltageValue(
    double actualValue,
    double minValue,
    double maxValue
)
Visual Basic (Declaration)
Public Sub SetVoltageValue ( _
    actualValue As Double, _
    minValue As Double, _
    maxValue As Double _
)
Visual C++
public:
void SetVoltageValue(
    double actualValue,
    double minValue,
    double maxValue
)

Parameters

actualValue
Type: System..::.Double
minValue
Type: System..::.Double
maxValue
Type: System..::.Double

Exceptions

Exception | Condition
System..::.ArgumentException | Actual value can't be more than minValue or less than maxValue, and all of them can't be negative, otherwise the exception will be thrown.

See Also

VoltageType Class
Autodesk.Revit.MEP Namespace


VoltageType Properties

[image] [image]

Revit 2010 API
VoltageType Properties
VoltageType Class See Also Send Feedback

The VoltageType type exposes the following members.

Properties

Name | Description
ActualValue | Get actual voltage value of this voltage definition, the unit is volt.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInUse | Indicates whether this voltage type is in service now, such as by other distribution system.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaxValue | Get upper boundary of voltage value of this voltage definition, the unit is volt.
MinValue | Get lower boundary of voltage value of this voltage definition, the unit is volt.
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

VoltageType Class
Autodesk.Revit.MEP Namespace


ActualValue Property

[image]

Revit 2010 API
VoltageType..::.ActualValue Property
VoltageType Class See Also Send Feedback
Get actual voltage value of this voltage definition, the unit is volt.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ActualValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActualValue As Double
Visual C++
public:
property double ActualValue {
    double get ();
}

See Also

VoltageType Class
Autodesk.Revit.MEP Namespace


IsInUse Property

[image]

Revit 2010 API
VoltageType..::.IsInUse Property
VoltageType Class See Also Send Feedback
Indicates whether this voltage type is in service now, such as by other distribution system.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsInUse { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInUse As Boolean
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

VoltageType Class
Autodesk.Revit.MEP Namespace


MaxValue Property

[image]

Revit 2010 API
VoltageType..::.MaxValue Property
VoltageType Class See Also Send Feedback
Get upper boundary of voltage value of this voltage definition, the unit is volt.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double MaxValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxValue As Double
Visual C++
public:
property double MaxValue {
    double get ();
}

See Also

VoltageType Class
Autodesk.Revit.MEP Namespace


MinValue Property

[image]

Revit 2010 API
VoltageType..::.MinValue Property
VoltageType Class See Also Send Feedback
Get lower boundary of voltage value of this voltage definition, the unit is volt.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double MinValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinValue As Double
Visual C++
public:
property double MinValue {
    double get ();
}

See Also

VoltageType Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
VoltageType..::.Parameter Property
VoltageType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

VoltageType Class
VoltageType Members
Autodesk.Revit.MEP Namespace


VoltageTypeSet Class

[image]

Revit 2010 API
VoltageTypeSet Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class VoltageTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class VoltageTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class VoltageTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.VoltageTypeSet

See Also

VoltageTypeSet Members
Autodesk.Revit.MEP Namespace


VoltageTypeSet Members

[image] [image]

Revit 2010 API
VoltageTypeSet Members
VoltageTypeSet Class Constructors Methods Properties See Also Send Feedback

The VoltageTypeSet type exposes the following members.

Constructors

Name | Description
VoltageTypeSet | Initializes a new instance of the VoltageTypeSet class

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

VoltageTypeSet Class
Autodesk.Revit.MEP Namespace


VoltageTypeSet Constructor

[image]

Revit 2010 API
VoltageTypeSet Constructor
VoltageTypeSet Class See Also Send Feedback
Initializes a new instance of the VoltageTypeSet class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public VoltageTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VoltageTypeSet()

See Also

VoltageTypeSet Class
Autodesk.Revit.MEP Namespace


VoltageTypeSet Methods

[image] [image]

Revit 2010 API
VoltageTypeSet Methods
VoltageTypeSet Class See Also Send Feedback

The VoltageTypeSet type exposes the following members.

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VoltageTypeSet Class
Autodesk.Revit.MEP Namespace


Clear Method

[image]

Revit 2010 API
VoltageTypeSet..::.Clear Method
VoltageTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

VoltageTypeSet Class
Autodesk.Revit.MEP Namespace


Contains Method

[image]

Revit 2010 API
VoltageTypeSet..::.Contains Method
VoltageTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    VoltageType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As VoltageType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    VoltageType^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.VoltageType

See Also

VoltageTypeSet Class
Autodesk.Revit.MEP Namespace


Erase Method

[image]

Revit 2010 API
VoltageTypeSet..::.Erase Method
VoltageTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    VoltageType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As VoltageType _
) As Integer
Visual C++
public:
virtual int Erase(
    VoltageType^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.VoltageType

See Also

VoltageTypeSet Class
Autodesk.Revit.MEP Namespace


ForwardIterator Method

[image]

Revit 2010 API
VoltageTypeSet..::.ForwardIterator Method
VoltageTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual VoltageTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As VoltageTypeSetIterator
Visual C++
public:
virtual VoltageTypeSetIterator^ ForwardIterator()

See Also

VoltageTypeSet Class
Autodesk.Revit.MEP Namespace


GetEnumerator Method

[image]

Revit 2010 API
VoltageTypeSet..::.GetEnumerator Method
VoltageTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::.GetEnumerator()()()

See Also

VoltageTypeSet Class
Autodesk.Revit.MEP Namespace


Insert Method

[image]

Revit 2010 API
VoltageTypeSet..::.Insert Method
VoltageTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    VoltageType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As VoltageType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    VoltageType^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.VoltageType

See Also

VoltageTypeSet Class
Autodesk.Revit.MEP Namespace


ReverseIterator Method

[image]

Revit 2010 API
VoltageTypeSet..::.ReverseIterator Method
VoltageTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual VoltageTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As VoltageTypeSetIterator
Visual C++
public:
virtual VoltageTypeSetIterator^ ReverseIterator()

See Also

VoltageTypeSet Class
Autodesk.Revit.MEP Namespace


VoltageTypeSet Properties

[image] [image]

Revit 2010 API
VoltageTypeSet Properties
VoltageTypeSet Class See Also Send Feedback

The VoltageTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

VoltageTypeSet Class
Autodesk.Revit.MEP Namespace


IsEmpty Property

[image]

Revit 2010 API
VoltageTypeSet..::.IsEmpty Property
VoltageTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

VoltageTypeSet Class
Autodesk.Revit.MEP Namespace


Size Property

[image]

Revit 2010 API
VoltageTypeSet..::.Size Property
VoltageTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

VoltageTypeSet Class
Autodesk.Revit.MEP Namespace


VoltageTypeSetIterator Class

[image]

Revit 2010 API
VoltageTypeSetIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class VoltageTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class VoltageTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class VoltageTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.VoltageTypeSetIterator

See Also

VoltageTypeSetIterator Members
Autodesk.Revit.MEP Namespace


VoltageTypeSetIterator Members

[image] [image]

Revit 2010 API
VoltageTypeSetIterator Members
VoltageTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The VoltageTypeSetIterator type exposes the following members.

Constructors

Name | Description
VoltageTypeSetIterator | Initializes a new instance of the VoltageTypeSetIterator class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.MEP Namespace


VoltageTypeSetIterator Constructor

[image]

Revit 2010 API
VoltageTypeSetIterator Constructor
VoltageTypeSetIterator Class See Also Send Feedback
Initializes a new instance of the VoltageTypeSetIterator class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public VoltageTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VoltageTypeSetIterator()

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.MEP Namespace


VoltageTypeSetIterator Methods

[image] [image]

Revit 2010 API
VoltageTypeSetIterator Methods
VoltageTypeSetIterator Class See Also Send Feedback

The VoltageTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.MEP Namespace


MoveNext Method

[image]

Revit 2010 API
VoltageTypeSetIterator..::.MoveNext Method
VoltageTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::.MoveNext()()()

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.MEP Namespace


Reset Method

[image]

Revit 2010 API
VoltageTypeSetIterator..::.Reset Method
VoltageTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.MEP Namespace


VoltageTypeSetIterator Properties

[image] [image]

Revit 2010 API
VoltageTypeSetIterator Properties
VoltageTypeSetIterator Class See Also Send Feedback

The VoltageTypeSetIterator type exposes the following members.

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.MEP Namespace


Current Property

[image]

Revit 2010 API
VoltageTypeSetIterator..::.Current Property
VoltageTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.MEP Namespace


Wire Class

[image]

Revit 2010 API
Wire Class
Members See Also Send Feedback
An object to represent electrical wire in Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Wire : HostObject
Visual Basic (Declaration)
Public Class Wire _
    Inherits HostObject
Visual C++
public ref class Wire : public HostObject

Remarks

Adding wiring to a project is optional. you can create circuits and maintain the information associated with them without adding wiring to the project.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.MEP..::.Wire

See Also

Wire Members
Autodesk.Revit.MEP Namespace


Wire Members

[image] [image]

Revit 2010 API
Wire Members
Wire Class Constructors Methods Properties See Also Send Feedback

The Wire type exposes the following members.

Constructors

Name | Description
Wire | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | Get connector manager of the wire.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GroundConductorNum | Get of set ground conductor number. Its default value is zero after created.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HotConductorNum | Get or set hot conductor number. Its default value is zero after created.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
NeutralConductorNum | Get of set neutral conductor number. Its default value is zero after created.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
WiringType | Get or set wiring type(Arc or chamfer) for the wire.

See Also

Wire Class
Autodesk.Revit.MEP Namespace


Wire Constructor

[image]

Revit 2010 API
Wire Constructor
Wire Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Wire()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Wire()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Wire Class
Autodesk.Revit.MEP Namespace


Wire Methods

[image] [image]

Revit 2010 API
Wire Methods
Wire Class See Also Send Feedback

The Wire type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Wire Class
Autodesk.Revit.MEP Namespace


Wire Properties

[image] [image]

Revit 2010 API
Wire Properties
Wire Class See Also Send Feedback

The Wire type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | Get connector manager of the wire.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GroundConductorNum | Get of set ground conductor number. Its default value is zero after created.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HotConductorNum | Get or set hot conductor number. Its default value is zero after created.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
NeutralConductorNum | Get of set neutral conductor number. Its default value is zero after created.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
WiringType | Get or set wiring type(Arc or chamfer) for the wire.

See Also

Wire Class
Autodesk.Revit.MEP Namespace


ConnectorManager Property

[image]

Revit 2010 API
Wire..::.ConnectorManager Property
Wire Class See Also Send Feedback
Get connector manager of the wire.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ConnectorManager ConnectorManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConnectorManager As ConnectorManager
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

See Also

Wire Class
Autodesk.Revit.MEP Namespace


GroundConductorNum Property

[image]

Revit 2010 API
Wire..::.GroundConductorNum Property
Wire Class See Also Send Feedback
Get of set ground conductor number. Its default value is zero after created.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int GroundConductorNum { get; set; }
Visual Basic (Declaration)
Public Property GroundConductorNum As Integer
Visual C++
public:
property int GroundConductorNum {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentException | Exception is thrown when trying to assign a negative value.

See Also

Wire Class
Autodesk.Revit.MEP Namespace


HotConductorNum Property

[image]

Revit 2010 API
Wire..::.HotConductorNum Property
Wire Class See Also Send Feedback
Get or set hot conductor number. Its default value is zero after created.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int HotConductorNum { get; set; }
Visual Basic (Declaration)
Public Property HotConductorNum As Integer
Visual C++
public:
property int HotConductorNum {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentException | Exception is thrown when trying to assign a negative value.

See Also

Wire Class
Autodesk.Revit.MEP Namespace


NeutralConductorNum Property

[image]

Revit 2010 API
Wire..::.NeutralConductorNum Property
Wire Class See Also Send Feedback
Get of set neutral conductor number. Its default value is zero after created.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NeutralConductorNum { get; set; }
Visual Basic (Declaration)
Public Property NeutralConductorNum As Integer
Visual C++
public:
property int NeutralConductorNum {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentException | Exception is thrown when trying to assign a negative value.

See Also

Wire Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
Wire..::.Parameter Property
Wire Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Wire Class
Wire Members
Autodesk.Revit.MEP Namespace


WiringType Property

[image]

Revit 2010 API
Wire..::.WiringType Property
Wire Class See Also Send Feedback
Get or set wiring type(Arc or chamfer) for the wire.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WiringType WiringType { get; set; }
Visual Basic (Declaration)
Public Property WiringType As WiringType
Visual C++
public:
property WiringType WiringType {
    WiringType get ();
    void set (WiringType value);
}

See Also

Wire Class
Autodesk.Revit.MEP Namespace


WireMaterialType Class

[image]

Revit 2010 API
WireMaterialType Class
Members See Also Send Feedback
Represents electrical wire material type definition information of wire type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class WireMaterialType : Element
Visual Basic (Declaration)
Public Class WireMaterialType _
    Inherits Element
Visual C++
public ref class WireMaterialType : public Element

Remarks

All the other properties of wire type are based on wire material type. Only the wire material types which are retrieved from ElectricalSetting can work well, so don't retrieve it from Revit project directly.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.MEP..::.WireMaterialType

See Also

WireMaterialType Members
Autodesk.Revit.MEP Namespace


WireMaterialType Members

[image] [image]

Revit 2010 API
WireMaterialType Members
WireMaterialType Class Constructors Methods Properties See Also Send Feedback

The WireMaterialType type exposes the following members.

Constructors

Name | Description
WireMaterialType | Initializes a new instance of the WireMaterialType class

Methods

Name | Description
AddGroundConductorSize | Add new electrical ground conductor size type into this material type.
AddTemperatureRatingType | Add a new temperature rating type into material type.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveGroundConductorSize | Remove an existing ground conductor size from this material type.
RemoveTemperatureRatingType | Remove an existing temperature rating type from this material type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GroundConductorSizes | Get all ground conductor size types defined in this wire material type.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInUse | Indicate whether the wire material type is in use.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get name of wire material type. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
TemperatureRatings | Get all temperature rating type definitions defined in this wire material type.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

WireMaterialType Class
Autodesk.Revit.MEP Namespace


WireMaterialType Constructor

[image]

Revit 2010 API
WireMaterialType Constructor
WireMaterialType Class See Also Send Feedback
Initializes a new instance of the WireMaterialType class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireMaterialType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireMaterialType()

See Also

WireMaterialType Class
Autodesk.Revit.MEP Namespace


WireMaterialType Methods

[image] [image]

Revit 2010 API
WireMaterialType Methods
WireMaterialType Class See Also Send Feedback

The WireMaterialType type exposes the following members.

Methods

Name | Description
AddGroundConductorSize | Add new electrical ground conductor size type into this material type.
AddTemperatureRatingType | Add a new temperature rating type into material type.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveGroundConductorSize | Remove an existing ground conductor size from this material type.
RemoveTemperatureRatingType | Remove an existing temperature rating type from this material type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireMaterialType Class
Autodesk.Revit.MEP Namespace


AddGroundConductorSize Method

[image]

Revit 2010 API
WireMaterialType..::.AddGroundConductorSize Method
WireMaterialType Class See Also Send Feedback
Add new electrical ground conductor size type into this material type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GroundConductorSize AddGroundConductorSize(
    long ampacity,
    string size
)
Visual Basic (Declaration)
Public Function AddGroundConductorSize ( _
    ampacity As Long, _
    size As String _
) As GroundConductorSize
Visual C++
public:
GroundConductorSize^ AddGroundConductorSize(
    long long ampacity,
    String^ size
)

Parameters

ampacity
Type: System..::.Int64
Ampacity of ground conductor size to be added.
size
Type: System..::.String
Size of ground conductor size to be added.

Return Value

New added ground conductor size.

See Also

WireMaterialType Class
Autodesk.Revit.MEP Namespace


AddTemperatureRatingType Method

[image]

Revit 2010 API
WireMaterialType..::.AddTemperatureRatingType Method
WireMaterialType Class See Also Send Feedback
Add a new temperature rating type into material type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TemperatureRatingType AddTemperatureRatingType(
    string name,
    TemperatureRatingType baseOn
)
Visual Basic (Declaration)
Public Function AddTemperatureRatingType ( _
    name As String, _
    baseOn As TemperatureRatingType _
) As TemperatureRatingType
Visual C++
public:
TemperatureRatingType^ AddTemperatureRatingType(
    String^ name,
    TemperatureRatingType^ baseOn
)

Parameters

name
Type: System..::.String
Name of temperature type to be added.
baseOn
Type: Autodesk.Revit.MEP..::.TemperatureRatingType
The new temperature rating will be created base on this existing temperature rating type.

Return Value

New constructed temperature rating type.

See Also

WireMaterialType Class
Autodesk.Revit.MEP Namespace


RemoveGroundConductorSize Method

[image]

Revit 2010 API
WireMaterialType..::.RemoveGroundConductorSize Method
WireMaterialType Class See Also Send Feedback
Remove an existing ground conductor size from this material type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveGroundConductorSize(
    GroundConductorSize grdConductorSize
)
Visual Basic (Declaration)
Public Sub RemoveGroundConductorSize ( _
    grdConductorSize As GroundConductorSize _
)
Visual C++
public:
void RemoveGroundConductorSize(
    GroundConductorSize^ grdConductorSize
)

Parameters

grdConductorSize
Type: Autodesk.Revit.MEP..::.GroundConductorSize
The ground size type to be removed.

See Also

WireMaterialType Class
Autodesk.Revit.MEP Namespace


RemoveTemperatureRatingType Method

[image]

Revit 2010 API
WireMaterialType..::.RemoveTemperatureRatingType Method
WireMaterialType Class See Also Send Feedback
Remove an existing temperature rating type from this material type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveTemperatureRatingType(
    TemperatureRatingType temperatureRating
)
Visual Basic (Declaration)
Public Sub RemoveTemperatureRatingType ( _
    temperatureRating As TemperatureRatingType _
)
Visual C++
public:
void RemoveTemperatureRatingType(
    TemperatureRatingType^ temperatureRating
)

Parameters

temperatureRating
Type: Autodesk.Revit.MEP..::.TemperatureRatingType
The temperature rating type to be removed.

Exceptions

Exception | Condition
System..::.InvalidOperationException | The last temperature rating type of project and any one used by a wire type can't be removed.

See Also

WireMaterialType Class
Autodesk.Revit.MEP Namespace


WireMaterialType Properties

[image] [image]

Revit 2010 API
WireMaterialType Properties
WireMaterialType Class See Also Send Feedback

The WireMaterialType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GroundConductorSizes | Get all ground conductor size types defined in this wire material type.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInUse | Indicate whether the wire material type is in use.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get name of wire material type. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
TemperatureRatings | Get all temperature rating type definitions defined in this wire material type.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

WireMaterialType Class
Autodesk.Revit.MEP Namespace


GroundConductorSizes Property

[image]

Revit 2010 API
WireMaterialType..::.GroundConductorSizes Property
WireMaterialType Class See Also Send Feedback
Get all ground conductor size types defined in this wire material type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GroundConductorSizeSet GroundConductorSizes { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroundConductorSizes As GroundConductorSizeSet
Visual C++
public:
property GroundConductorSizeSet^ GroundConductorSizes {
    GroundConductorSizeSet^ get ();
}

See Also

WireMaterialType Class
Autodesk.Revit.MEP Namespace


IsInUse Property

[image]

Revit 2010 API
WireMaterialType..::.IsInUse Property
WireMaterialType Class See Also Send Feedback
Indicate whether the wire material type is in use.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsInUse { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInUse As Boolean
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

WireMaterialType Class
Autodesk.Revit.MEP Namespace


Name Property

[image]

Revit 2010 API
WireMaterialType..::.Name Property
WireMaterialType Class See Also Send Feedback
Get name of wire material type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Exceptions

Exception | Condition
System..::.NotSupportedException | Set name can't be supported.

See Also

WireMaterialType Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
WireMaterialType..::.Parameter Property
WireMaterialType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

WireMaterialType Class
WireMaterialType Members
Autodesk.Revit.MEP Namespace


TemperatureRatings Property

[image]

Revit 2010 API
WireMaterialType..::.TemperatureRatings Property
WireMaterialType Class See Also Send Feedback
Get all temperature rating type definitions defined in this wire material type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TemperatureRatingTypeSet TemperatureRatings { get; }
Visual Basic (Declaration)
Public ReadOnly Property TemperatureRatings As TemperatureRatingTypeSet
Visual C++
public:
property TemperatureRatingTypeSet^ TemperatureRatings {
    TemperatureRatingTypeSet^ get ();
}

See Also

WireMaterialType Class
Autodesk.Revit.MEP Namespace


WireMaterialTypeSet Class

[image]

Revit 2010 API
WireMaterialTypeSet Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class WireMaterialTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class WireMaterialTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class WireMaterialTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.WireMaterialTypeSet

See Also

WireMaterialTypeSet Members
Autodesk.Revit.MEP Namespace


WireMaterialTypeSet Members

[image] [image]

Revit 2010 API
WireMaterialTypeSet Members
WireMaterialTypeSet Class Constructors Methods Properties See Also Send Feedback

The WireMaterialTypeSet type exposes the following members.

Constructors

Name | Description
WireMaterialTypeSet | Initializes a new instance of the WireMaterialTypeSet class

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

WireMaterialTypeSet Class
Autodesk.Revit.MEP Namespace


WireMaterialTypeSet Constructor

[image]

Revit 2010 API
WireMaterialTypeSet Constructor
WireMaterialTypeSet Class See Also Send Feedback
Initializes a new instance of the WireMaterialTypeSet class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireMaterialTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireMaterialTypeSet()

See Also

WireMaterialTypeSet Class
Autodesk.Revit.MEP Namespace


WireMaterialTypeSet Methods

[image] [image]

Revit 2010 API
WireMaterialTypeSet Methods
WireMaterialTypeSet Class See Also Send Feedback

The WireMaterialTypeSet type exposes the following members.

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireMaterialTypeSet Class
Autodesk.Revit.MEP Namespace


Clear Method

[image]

Revit 2010 API
WireMaterialTypeSet..::.Clear Method
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

WireMaterialTypeSet Class
Autodesk.Revit.MEP Namespace


Contains Method

[image]

Revit 2010 API
WireMaterialTypeSet..::.Contains Method
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    WireMaterialType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As WireMaterialType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    WireMaterialType^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.WireMaterialType

See Also

WireMaterialTypeSet Class
Autodesk.Revit.MEP Namespace


Erase Method

[image]

Revit 2010 API
WireMaterialTypeSet..::.Erase Method
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    WireMaterialType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As WireMaterialType _
) As Integer
Visual C++
public:
virtual int Erase(
    WireMaterialType^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.WireMaterialType

See Also

WireMaterialTypeSet Class
Autodesk.Revit.MEP Namespace


ForwardIterator Method

[image]

Revit 2010 API
WireMaterialTypeSet..::.ForwardIterator Method
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual WireMaterialTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As WireMaterialTypeSetIterator
Visual C++
public:
virtual WireMaterialTypeSetIterator^ ForwardIterator()

See Also

WireMaterialTypeSet Class
Autodesk.Revit.MEP Namespace


GetEnumerator Method

[image]

Revit 2010 API
WireMaterialTypeSet..::.GetEnumerator Method
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::.GetEnumerator()()()

See Also

WireMaterialTypeSet Class
Autodesk.Revit.MEP Namespace


Insert Method

[image]

Revit 2010 API
WireMaterialTypeSet..::.Insert Method
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    WireMaterialType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As WireMaterialType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    WireMaterialType^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.WireMaterialType

See Also

WireMaterialTypeSet Class
Autodesk.Revit.MEP Namespace


ReverseIterator Method

[image]

Revit 2010 API
WireMaterialTypeSet..::.ReverseIterator Method
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual WireMaterialTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As WireMaterialTypeSetIterator
Visual C++
public:
virtual WireMaterialTypeSetIterator^ ReverseIterator()

See Also

WireMaterialTypeSet Class
Autodesk.Revit.MEP Namespace


WireMaterialTypeSet Properties

[image] [image]

Revit 2010 API
WireMaterialTypeSet Properties
WireMaterialTypeSet Class See Also Send Feedback

The WireMaterialTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

WireMaterialTypeSet Class
Autodesk.Revit.MEP Namespace


IsEmpty Property

[image]

Revit 2010 API
WireMaterialTypeSet..::.IsEmpty Property
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

WireMaterialTypeSet Class
Autodesk.Revit.MEP Namespace


Size Property

[image]

Revit 2010 API
WireMaterialTypeSet..::.Size Property
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WireMaterialTypeSet Class
Autodesk.Revit.MEP Namespace


WireMaterialTypeSetIterator Class

[image]

Revit 2010 API
WireMaterialTypeSetIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class WireMaterialTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class WireMaterialTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class WireMaterialTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.WireMaterialTypeSetIterator

See Also

WireMaterialTypeSetIterator Members
Autodesk.Revit.MEP Namespace


WireMaterialTypeSetIterator Members

[image] [image]

Revit 2010 API
WireMaterialTypeSetIterator Members
WireMaterialTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The WireMaterialTypeSetIterator type exposes the following members.

Constructors

Name | Description
WireMaterialTypeSetIterator | Initializes a new instance of the WireMaterialTypeSetIterator class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.MEP Namespace


WireMaterialTypeSetIterator Constructor

[image]

Revit 2010 API
WireMaterialTypeSetIterator Constructor
WireMaterialTypeSetIterator Class See Also Send Feedback
Initializes a new instance of the WireMaterialTypeSetIterator class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireMaterialTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireMaterialTypeSetIterator()

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.MEP Namespace


WireMaterialTypeSetIterator Methods

[image] [image]

Revit 2010 API
WireMaterialTypeSetIterator Methods
WireMaterialTypeSetIterator Class See Also Send Feedback

The WireMaterialTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.MEP Namespace


MoveNext Method

[image]

Revit 2010 API
WireMaterialTypeSetIterator..::.MoveNext Method
WireMaterialTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::.MoveNext()()()

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.MEP Namespace


Reset Method

[image]

Revit 2010 API
WireMaterialTypeSetIterator..::.Reset Method
WireMaterialTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.MEP Namespace


WireMaterialTypeSetIterator Properties

[image] [image]

Revit 2010 API
WireMaterialTypeSetIterator Properties
WireMaterialTypeSetIterator Class See Also Send Feedback

The WireMaterialTypeSetIterator type exposes the following members.

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.MEP Namespace


Current Property

[image]

Revit 2010 API
WireMaterialTypeSetIterator..::.Current Property
WireMaterialTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.MEP Namespace


WireSet Class

[image]

Revit 2010 API
WireSet Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class WireSet : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class WireSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class WireSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.WireSet

See Also

WireSet Members
Autodesk.Revit.MEP Namespace


WireSet Members

[image] [image]

Revit 2010 API
WireSet Members
WireSet Class Constructors Methods Properties See Also Send Feedback

The WireSet type exposes the following members.

Constructors

Name | Description
WireSet | Initializes a new instance of the WireSet class

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

WireSet Class
Autodesk.Revit.MEP Namespace


WireSet Constructor

[image]

Revit 2010 API
WireSet Constructor
WireSet Class See Also Send Feedback
Initializes a new instance of the WireSet class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireSet()

See Also

WireSet Class
Autodesk.Revit.MEP Namespace


WireSet Methods

[image] [image]

Revit 2010 API
WireSet Methods
WireSet Class See Also Send Feedback

The WireSet type exposes the following members.

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireSet Class
Autodesk.Revit.MEP Namespace


Clear Method

[image]

Revit 2010 API
WireSet..::.Clear Method
WireSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

WireSet Class
Autodesk.Revit.MEP Namespace


Contains Method

[image]

Revit 2010 API
WireSet..::.Contains Method
WireSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    Wire item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Wire _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Wire^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.Wire

See Also

WireSet Class
Autodesk.Revit.MEP Namespace


Erase Method

[image]

Revit 2010 API
WireSet..::.Erase Method
WireSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    Wire item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Wire _
) As Integer
Visual C++
public:
virtual int Erase(
    Wire^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.Wire

See Also

WireSet Class
Autodesk.Revit.MEP Namespace


ForwardIterator Method

[image]

Revit 2010 API
WireSet..::.ForwardIterator Method
WireSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual WireSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As WireSetIterator
Visual C++
public:
virtual WireSetIterator^ ForwardIterator()

See Also

WireSet Class
Autodesk.Revit.MEP Namespace


GetEnumerator Method

[image]

Revit 2010 API
WireSet..::.GetEnumerator Method
WireSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::.GetEnumerator()()()

See Also

WireSet Class
Autodesk.Revit.MEP Namespace


Insert Method

[image]

Revit 2010 API
WireSet..::.Insert Method
WireSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    Wire item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Wire _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Wire^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.Wire

See Also

WireSet Class
Autodesk.Revit.MEP Namespace


ReverseIterator Method

[image]

Revit 2010 API
WireSet..::.ReverseIterator Method
WireSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual WireSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As WireSetIterator
Visual C++
public:
virtual WireSetIterator^ ReverseIterator()

See Also

WireSet Class
Autodesk.Revit.MEP Namespace


WireSet Properties

[image] [image]

Revit 2010 API
WireSet Properties
WireSet Class See Also Send Feedback

The WireSet type exposes the following members.

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

WireSet Class
Autodesk.Revit.MEP Namespace


IsEmpty Property

[image]

Revit 2010 API
WireSet..::.IsEmpty Property
WireSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

WireSet Class
Autodesk.Revit.MEP Namespace


Size Property

[image]

Revit 2010 API
WireSet..::.Size Property
WireSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WireSet Class
Autodesk.Revit.MEP Namespace


WireSetIterator Class

[image]

Revit 2010 API
WireSetIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class WireSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class WireSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class WireSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.WireSetIterator

See Also

WireSetIterator Members
Autodesk.Revit.MEP Namespace


WireSetIterator Members

[image] [image]

Revit 2010 API
WireSetIterator Members
WireSetIterator Class Constructors Methods Properties See Also Send Feedback

The WireSetIterator type exposes the following members.

Constructors

Name | Description
WireSetIterator | Initializes a new instance of the WireSetIterator class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireSetIterator Class
Autodesk.Revit.MEP Namespace


WireSetIterator Constructor

[image]

Revit 2010 API
WireSetIterator Constructor
WireSetIterator Class See Also Send Feedback
Initializes a new instance of the WireSetIterator class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireSetIterator()

See Also

WireSetIterator Class
Autodesk.Revit.MEP Namespace


WireSetIterator Methods

[image] [image]

Revit 2010 API
WireSetIterator Methods
WireSetIterator Class See Also Send Feedback

The WireSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireSetIterator Class
Autodesk.Revit.MEP Namespace


MoveNext Method

[image]

Revit 2010 API
WireSetIterator..::.MoveNext Method
WireSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::.MoveNext()()()

See Also

WireSetIterator Class
Autodesk.Revit.MEP Namespace


Reset Method

[image]

Revit 2010 API
WireSetIterator..::.Reset Method
WireSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

See Also

WireSetIterator Class
Autodesk.Revit.MEP Namespace


WireSetIterator Properties

[image] [image]

Revit 2010 API
WireSetIterator Properties
WireSetIterator Class See Also Send Feedback

The WireSetIterator type exposes the following members.

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireSetIterator Class
Autodesk.Revit.MEP Namespace


Current Property

[image]

Revit 2010 API
WireSetIterator..::.Current Property
WireSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

See Also

WireSetIterator Class
Autodesk.Revit.MEP Namespace


WireSize Class

[image]

Revit 2010 API
WireSize Class
Members See Also Send Feedback
Represents specific electrical wire size information.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class WireSize : APIObject
Visual Basic (Declaration)
Public Class WireSize _
    Inherits APIObject
Visual C++
public ref class WireSize : public APIObject

Remarks

Wire size is defined based on corresponding wire material type and temperature rating type.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.WireSize

See Also

WireSize Members
Autodesk.Revit.MEP Namespace


WireSize Members

[image] [image]

Revit 2010 API
WireSize Members
WireSize Class Constructors Methods Properties See Also Send Feedback

The WireSize type exposes the following members.

Constructors

Name | Description
WireSize | Initializes a new instance of the WireSize class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Ampacity | Get ampacity which be used for specifying size, the unit is ampere.
Diameter | Get diameter of wire.
InUse | Get or set whether the size can be used in sizing.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Get size symbol of wire.

See Also

WireSize Class
Autodesk.Revit.MEP Namespace


WireSize Constructor

[image]

Revit 2010 API
WireSize Constructor
WireSize Class See Also Send Feedback
Initializes a new instance of the WireSize class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireSize()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireSize()

See Also

WireSize Class
Autodesk.Revit.MEP Namespace


WireSize Methods

[image] [image]

Revit 2010 API
WireSize Methods
WireSize Class See Also Send Feedback

The WireSize type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireSize Class
Autodesk.Revit.MEP Namespace


WireSize Properties

[image] [image]

Revit 2010 API
WireSize Properties
WireSize Class See Also Send Feedback

The WireSize type exposes the following members.

Properties

Name | Description
Ampacity | Get ampacity which be used for specifying size, the unit is ampere.
Diameter | Get diameter of wire.
InUse | Get or set whether the size can be used in sizing.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Get size symbol of wire.

See Also

WireSize Class
Autodesk.Revit.MEP Namespace


Ampacity Property

[image]

Revit 2010 API
WireSize..::.Ampacity Property
WireSize Class See Also Send Feedback
Get ampacity which be used for specifying size, the unit is ampere.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public long Ampacity { get; }
Visual Basic (Declaration)
Public ReadOnly Property Ampacity As Long
Visual C++
public:
property long long Ampacity {
    long long get ();
}

See Also

WireSize Class
Autodesk.Revit.MEP Namespace


Diameter Property

[image]

Revit 2010 API
WireSize..::.Diameter Property
WireSize Class See Also Send Feedback
Get diameter of wire.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Diameter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Diameter As Double
Visual C++
public:
property double Diameter {
    double get ();
}

See Also

WireSize Class
Autodesk.Revit.MEP Namespace


InUse Property

[image]

Revit 2010 API
WireSize..::.InUse Property
WireSize Class See Also Send Feedback
Get or set whether the size can be used in sizing.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool InUse { get; set; }
Visual Basic (Declaration)
Public Property InUse As Boolean
Visual C++
public:
property bool InUse {
    bool get ();
    void set (bool value);
}

See Also

WireSize Class
Autodesk.Revit.MEP Namespace


Size Property

[image]

Revit 2010 API
WireSize..::.Size Property
WireSize Class See Also Send Feedback
Get size symbol of wire.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Size { get; }
Visual Basic (Declaration)
Public ReadOnly Property Size As String
Visual C++
public:
property String^ Size {
    String^ get ();
}

See Also

WireSize Class
Autodesk.Revit.MEP Namespace


WireSizeSet Class

[image]

Revit 2010 API
WireSizeSet Class
Members See Also Send Feedback
A set that contains wire sizes.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class WireSizeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class WireSizeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class WireSizeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.WireSizeSet

See Also

WireSizeSet Members
Autodesk.Revit.MEP Namespace


WireSizeSet Members

[image] [image]

Revit 2010 API
WireSizeSet Members
WireSizeSet Class Constructors Methods Properties See Also Send Feedback

The WireSizeSet type exposes the following members.

Constructors

Name | Description
WireSizeSet | Initializes a new instance of the WireSizeSet class

Methods

Name | Description
Clear | Removes every wire size from the set, rendering it empty.
Contains | Tests for the existence of a wire size within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified wire size from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified wire size into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of wire sizes that are in the set.

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


WireSizeSet Constructor

[image]

Revit 2010 API
WireSizeSet Constructor
WireSizeSet Class See Also Send Feedback
Initializes a new instance of the WireSizeSet class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireSizeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireSizeSet()

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


WireSizeSet Methods

[image] [image]

Revit 2010 API
WireSizeSet Methods
WireSizeSet Class See Also Send Feedback

The WireSizeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every wire size from the set, rendering it empty.
Contains | Tests for the existence of a wire size within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified wire size from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified wire size into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


Clear Method

[image]

Revit 2010 API
WireSizeSet..::.Clear Method
WireSizeSet Class See Also Send Feedback
Removes every wire size from the set, rendering it empty.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


Contains Method

[image]

Revit 2010 API
WireSizeSet..::.Contains Method
WireSizeSet Class See Also Send Feedback
Tests for the existence of a wire size within the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    WireSize item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As WireSize _
) As Boolean
Visual C++
public:
virtual bool Contains(
    WireSize^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.WireSize
The wire size to be searched for.

Return Value

The Contains method returns True if the wire size is within the set, otherwise False.

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


Erase Method

[image]

Revit 2010 API
WireSizeSet..::.Erase Method
WireSizeSet Class See Also Send Feedback
Removes a specified wire size from the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    WireSize item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As WireSize _
) As Integer
Visual C++
public:
virtual int Erase(
    WireSize^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.WireSize
The wire size to be erased.

Return Value

The number of wire sizes that were erased from the set.

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


ForwardIterator Method

[image]

Revit 2010 API
WireSizeSet..::.ForwardIterator Method
WireSizeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual WireSizeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As WireSizeSetIterator
Visual C++
public:
virtual WireSizeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


GetEnumerator Method

[image]

Revit 2010 API
WireSizeSet..::.GetEnumerator Method
WireSizeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


Insert Method

[image]

Revit 2010 API
WireSizeSet..::.Insert Method
WireSizeSet Class See Also Send Feedback
Insert the specified wire size into the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    WireSize item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As WireSize _
) As Boolean
Visual C++
public:
virtual bool Insert(
    WireSize^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.WireSize
The wire size to be inserted into the set.

Return Value

Returns whether the wire size was inserted into the set.

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


ReverseIterator Method

[image]

Revit 2010 API
WireSizeSet..::.ReverseIterator Method
WireSizeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual WireSizeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As WireSizeSetIterator
Visual C++
public:
virtual WireSizeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


WireSizeSet Properties

[image] [image]

Revit 2010 API
WireSizeSet Properties
WireSizeSet Class See Also Send Feedback

The WireSizeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of wire sizes that are in the set.

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


IsEmpty Property

[image]

Revit 2010 API
WireSizeSet..::.IsEmpty Property
WireSizeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


Size Property

[image]

Revit 2010 API
WireSizeSet..::.Size Property
WireSizeSet Class See Also Send Feedback
Returns the number of wire sizes that are in the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WireSizeSet Class
Autodesk.Revit.MEP Namespace


WireSizeSetIterator Class

[image]

Revit 2010 API
WireSizeSetIterator Class
Members See Also Send Feedback
An iterator to a wire size set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class WireSizeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class WireSizeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class WireSizeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.WireSizeSetIterator

See Also

WireSizeSetIterator Members
Autodesk.Revit.MEP Namespace


WireSizeSetIterator Members

[image] [image]

Revit 2010 API
WireSizeSetIterator Members
WireSizeSetIterator Class Constructors Methods Properties See Also Send Feedback

The WireSizeSetIterator type exposes the following members.

Constructors

Name | Description
WireSizeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireSizeSetIterator Class
Autodesk.Revit.MEP Namespace


WireSizeSetIterator Constructor

[image]

Revit 2010 API
WireSizeSetIterator Constructor
WireSizeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireSizeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireSizeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

WireSizeSetIterator Class
Autodesk.Revit.MEP Namespace


WireSizeSetIterator Methods

[image] [image]

Revit 2010 API
WireSizeSetIterator Methods
WireSizeSetIterator Class See Also Send Feedback

The WireSizeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireSizeSetIterator Class
Autodesk.Revit.MEP Namespace


MoveNext Method

[image]

Revit 2010 API
WireSizeSetIterator..::.MoveNext Method
WireSizeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

WireSizeSetIterator Class
Autodesk.Revit.MEP Namespace


Reset Method

[image]

Revit 2010 API
WireSizeSetIterator..::.Reset Method
WireSizeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

WireSizeSetIterator Class
Autodesk.Revit.MEP Namespace


WireSizeSetIterator Properties

[image] [image]

Revit 2010 API
WireSizeSetIterator Properties
WireSizeSetIterator Class See Also Send Feedback

The WireSizeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireSizeSetIterator Class
Autodesk.Revit.MEP Namespace


Current Property

[image]

Revit 2010 API
WireSizeSetIterator..::.Current Property
WireSizeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

WireSizeSetIterator Class
Autodesk.Revit.MEP Namespace


WireType Class

[image]

Revit 2010 API
WireType Class
Members See Also Send Feedback
Represents a specific wire type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class WireType : Symbol
Visual Basic (Declaration)
Public Class WireType _
    Inherits Symbol
Visual C++
public ref class WireType : public Symbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.WireType

See Also

WireType Members
Autodesk.Revit.MEP Namespace


WireType Members

[image] [image]

Revit 2010 API
WireType Members
WireType Class Constructors Methods Properties See Also Send Feedback

The WireType type exposes the following members.

Constructors

Name | Description
WireType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Conduit | Get of set conduit type of wire type.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Insulation | Get of set insulation type.
IsInUse | Indicate whether the wire type is in use.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaxSize | Get of set max size of wire type.
Name | set name for a symbol (Inherited from Symbol.)
NeutralMultiplier | Get of set neutral multiplier type of wire type.
NeutralRequired | Get of set whether the neutral point is required.
NeutralSize | Get of set maximum neutral size of wire type.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
TemperatureRating | Get of set temperature rating type of wire type.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
WireMaterial | Get of set material type of wire type.

See Also

WireType Class
Autodesk.Revit.MEP Namespace


WireType Constructor

[image]

Revit 2010 API
WireType Constructor
WireType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

WireType Class
Autodesk.Revit.MEP Namespace


WireType Methods

[image] [image]

Revit 2010 API
WireType Methods
WireType Class See Also Send Feedback

The WireType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireType Class
Autodesk.Revit.MEP Namespace


WireType Properties

[image] [image]

Revit 2010 API
WireType Properties
WireType Class See Also Send Feedback

The WireType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Conduit | Get of set conduit type of wire type.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Insulation | Get of set insulation type.
IsInUse | Indicate whether the wire type is in use.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaxSize | Get of set max size of wire type.
Name | set name for a symbol (Inherited from Symbol.)
NeutralMultiplier | Get of set neutral multiplier type of wire type.
NeutralRequired | Get of set whether the neutral point is required.
NeutralSize | Get of set maximum neutral size of wire type.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
TemperatureRating | Get of set temperature rating type of wire type.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
WireMaterial | Get of set material type of wire type.

See Also

WireType Class
Autodesk.Revit.MEP Namespace


Conduit Property

[image]

Revit 2010 API
WireType..::.Conduit Property
WireType Class See Also Send Feedback
Get of set conduit type of wire type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ConduitType Conduit { get; set; }
Visual Basic (Declaration)
Public Property Conduit As ConduitType
Visual C++
public:
property ConduitType^ Conduit {
    ConduitType^ get ();
    void set (ConduitType^ value);
}

See Also

WireType Class
Autodesk.Revit.MEP Namespace


Insulation Property

[image]

Revit 2010 API
WireType..::.Insulation Property
WireType Class See Also Send Feedback
Get of set insulation type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InsulationType Insulation { get; set; }
Visual Basic (Declaration)
Public Property Insulation As InsulationType
Visual C++
public:
property InsulationType^ Insulation {
    InsulationType^ get ();
    void set (InsulationType^ value);
}

See Also

WireType Class
Autodesk.Revit.MEP Namespace


IsInUse Property

[image]

Revit 2010 API
WireType..::.IsInUse Property
WireType Class See Also Send Feedback
Indicate whether the wire type is in use.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsInUse { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInUse As Boolean
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

WireType Class
Autodesk.Revit.MEP Namespace


MaxSize Property

[image]

Revit 2010 API
WireType..::.MaxSize Property
WireType Class See Also Send Feedback
Get of set max size of wire type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireSize MaxSize { get; set; }
Visual Basic (Declaration)
Public Property MaxSize As WireSize
Visual C++
public:
property WireSize^ MaxSize {
    WireSize^ get ();
    void set (WireSize^ value);
}

See Also

WireType Class
Autodesk.Revit.MEP Namespace


NeutralMultiplier Property

[image]

Revit 2010 API
WireType..::.NeutralMultiplier Property
WireType Class See Also Send Feedback
Get of set neutral multiplier type of wire type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double NeutralMultiplier { get; set; }
Visual Basic (Declaration)
Public Property NeutralMultiplier As Double
Visual C++
public:
property double NeutralMultiplier {
    double get ();
    void set (double value);
}

See Also

WireType Class
Autodesk.Revit.MEP Namespace


NeutralRequired Property

[image]

Revit 2010 API
WireType..::.NeutralRequired Property
WireType Class See Also Send Feedback
Get of set whether the neutral point is required.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool NeutralRequired { get; set; }
Visual Basic (Declaration)
Public Property NeutralRequired As Boolean
Visual C++
public:
property bool NeutralRequired {
    bool get ();
    void set (bool value);
}

See Also

WireType Class
Autodesk.Revit.MEP Namespace


NeutralSize Property

[image]

Revit 2010 API
WireType..::.NeutralSize Property
WireType Class See Also Send Feedback
Get of set maximum neutral size of wire type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireType..::.NeutralMode NeutralSize { get; set; }
Visual Basic (Declaration)
Public Property NeutralSize As WireType..::.NeutralMode
Visual C++
public:
property WireType..::.NeutralMode NeutralSize {
    WireType..::.NeutralMode get ();
    void set (WireType..::.NeutralMode value);
}

See Also

WireType Class
Autodesk.Revit.MEP Namespace


Parameter Property

[image] [image]

Revit 2010 API
WireType..::.Parameter Property
WireType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

WireType Class
WireType Members
Autodesk.Revit.MEP Namespace


TemperatureRating Property

[image]

Revit 2010 API
WireType..::.TemperatureRating Property
WireType Class See Also Send Feedback
Get of set temperature rating type of wire type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TemperatureRatingType TemperatureRating { get; set; }
Visual Basic (Declaration)
Public Property TemperatureRating As TemperatureRatingType
Visual C++
public:
property TemperatureRatingType^ TemperatureRating {
    TemperatureRatingType^ get ();
    void set (TemperatureRatingType^ value);
}

Remarks

Should retrieved from rellevant WireMaterial object.

See Also

WireType Class
Autodesk.Revit.MEP Namespace


WireMaterial Property

[image]

Revit 2010 API
WireType..::.WireMaterial Property
WireType Class See Also Send Feedback
Get of set material type of wire type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireMaterialType WireMaterial { get; set; }
Visual Basic (Declaration)
Public Property WireMaterial As WireMaterialType
Visual C++
public:
property WireMaterialType^ WireMaterial {
    WireMaterialType^ get ();
    void set (WireMaterialType^ value);
}

See Also

WireType Class
Autodesk.Revit.MEP Namespace


WireType.NeutralMode Enumeration

[image]

Revit 2010 API
WireType..::.NeutralMode Enumeration
WireType Class See Also Send Feedback
An enumerate type to list the neutral mode for wire type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum NeutralMode
Visual Basic (Declaration)
Public Enumeration NeutralMode
Visual C++
public enum class NeutralMode

Members

Member name | Description
UnbalancedCurrent | Neutral Mode is UnbalancedCurrent.
HotConductorSize | Neutral Mode is HotConductorSize.

See Also

Autodesk.Revit.MEP Namespace


WireTypeSet Class

[image]

Revit 2010 API
WireTypeSet Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class WireTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class WireTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class WireTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.WireTypeSet

See Also

WireTypeSet Members
Autodesk.Revit.MEP Namespace


WireTypeSet Members

[image] [image]

Revit 2010 API
WireTypeSet Members
WireTypeSet Class Constructors Methods Properties See Also Send Feedback

The WireTypeSet type exposes the following members.

Constructors

Name | Description
WireTypeSet | Initializes a new instance of the WireTypeSet class

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

WireTypeSet Class
Autodesk.Revit.MEP Namespace


WireTypeSet Constructor

[image]

Revit 2010 API
WireTypeSet Constructor
WireTypeSet Class See Also Send Feedback
Initializes a new instance of the WireTypeSet class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireTypeSet()

See Also

WireTypeSet Class
Autodesk.Revit.MEP Namespace


WireTypeSet Methods

[image] [image]

Revit 2010 API
WireTypeSet Methods
WireTypeSet Class See Also Send Feedback

The WireTypeSet type exposes the following members.

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireTypeSet Class
Autodesk.Revit.MEP Namespace


Clear Method

[image]

Revit 2010 API
WireTypeSet..::.Clear Method
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

WireTypeSet Class
Autodesk.Revit.MEP Namespace


Contains Method

[image]

Revit 2010 API
WireTypeSet..::.Contains Method
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    WireType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As WireType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    WireType^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.WireType

See Also

WireTypeSet Class
Autodesk.Revit.MEP Namespace


Erase Method

[image]

Revit 2010 API
WireTypeSet..::.Erase Method
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    WireType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As WireType _
) As Integer
Visual C++
public:
virtual int Erase(
    WireType^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.WireType

See Also

WireTypeSet Class
Autodesk.Revit.MEP Namespace


ForwardIterator Method

[image]

Revit 2010 API
WireTypeSet..::.ForwardIterator Method
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual WireTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As WireTypeSetIterator
Visual C++
public:
virtual WireTypeSetIterator^ ForwardIterator()

See Also

WireTypeSet Class
Autodesk.Revit.MEP Namespace


GetEnumerator Method

[image]

Revit 2010 API
WireTypeSet..::.GetEnumerator Method
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::.GetEnumerator()()()

See Also

WireTypeSet Class
Autodesk.Revit.MEP Namespace


Insert Method

[image]

Revit 2010 API
WireTypeSet..::.Insert Method
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    WireType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As WireType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    WireType^ item
)

Parameters

item
Type: Autodesk.Revit.MEP..::.WireType

See Also

WireTypeSet Class
Autodesk.Revit.MEP Namespace


ReverseIterator Method

[image]

Revit 2010 API
WireTypeSet..::.ReverseIterator Method
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual WireTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As WireTypeSetIterator
Visual C++
public:
virtual WireTypeSetIterator^ ReverseIterator()

See Also

WireTypeSet Class
Autodesk.Revit.MEP Namespace


WireTypeSet Properties

[image] [image]

Revit 2010 API
WireTypeSet Properties
WireTypeSet Class See Also Send Feedback

The WireTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

WireTypeSet Class
Autodesk.Revit.MEP Namespace


IsEmpty Property

[image]

Revit 2010 API
WireTypeSet..::.IsEmpty Property
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

WireTypeSet Class
Autodesk.Revit.MEP Namespace


Size Property

[image]

Revit 2010 API
WireTypeSet..::.Size Property
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WireTypeSet Class
Autodesk.Revit.MEP Namespace


WireTypeSetIterator Class

[image]

Revit 2010 API
WireTypeSetIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class WireTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class WireTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class WireTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.WireTypeSetIterator

See Also

WireTypeSetIterator Members
Autodesk.Revit.MEP Namespace


WireTypeSetIterator Members

[image] [image]

Revit 2010 API
WireTypeSetIterator Members
WireTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The WireTypeSetIterator type exposes the following members.

Constructors

Name | Description
WireTypeSetIterator | Initializes a new instance of the WireTypeSetIterator class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireTypeSetIterator Class
Autodesk.Revit.MEP Namespace


WireTypeSetIterator Constructor

[image]

Revit 2010 API
WireTypeSetIterator Constructor
WireTypeSetIterator Class See Also Send Feedback
Initializes a new instance of the WireTypeSetIterator class

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireTypeSetIterator()

See Also

WireTypeSetIterator Class
Autodesk.Revit.MEP Namespace


WireTypeSetIterator Methods

[image] [image]

Revit 2010 API
WireTypeSetIterator Methods
WireTypeSetIterator Class See Also Send Feedback

The WireTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireTypeSetIterator Class
Autodesk.Revit.MEP Namespace


MoveNext Method

[image]

Revit 2010 API
WireTypeSetIterator..::.MoveNext Method
WireTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::.MoveNext()()()

See Also

WireTypeSetIterator Class
Autodesk.Revit.MEP Namespace


Reset Method

[image]

Revit 2010 API
WireTypeSetIterator..::.Reset Method
WireTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

See Also

WireTypeSetIterator Class
Autodesk.Revit.MEP Namespace


WireTypeSetIterator Properties

[image] [image]

Revit 2010 API
WireTypeSetIterator Properties
WireTypeSetIterator Class See Also Send Feedback

The WireTypeSetIterator type exposes the following members.

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireTypeSetIterator Class
Autodesk.Revit.MEP Namespace


Current Property

[image]

Revit 2010 API
WireTypeSetIterator..::.Current Property
WireTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

See Also

WireTypeSetIterator Class
Autodesk.Revit.MEP Namespace


Autodesk.Revit.MEP.Enums Namespace

[image]

Revit 2010 API
Autodesk.Revit.MEP.Enums Namespace
Send Feedback

Enumerations

Enumeration | Description
BaseLoadOn | An enumerate type listing all the possible Power Load Unit for a Space object.
ConditionType | An enumerate type listing all the possible Return Airflow Type for a Space object.
ConnectorProfileType | An enumerate type listing all the Connector type for the Connection.
ConnectorType | An enumerate type listing all the Connector type for the Connection.
Domain | An enumerate type listing all the Domain type for the Connector.
DuctFlowConfigurationType | An enumerate type listing all Duct Load Configuration type for the connector
DuctLossMethodType | An enumerate type listing all duct loss calculation methods for the connector
DuctSystemType | An enumerate type listing all the possible Duct System Types for a Duct Connector object.
ElectricalPhase | An enumerate type to specify whether the electrical system is single phase or three phase.
ElectricalPhaseConfiguration | An enumerate type to specify electrical phase configuration.
ElectricalSystemType | An enumerate type listing all the possible Electrical System Types for an Electrical Connector object.
FlowDirectionType | An enumerate type listing all direction type for the connector
JunctionType | An enumerate type listing all the junction type for the MEP curve types.
LoadClassification | An enumerate type to list all demond factor classification.
LoadClassificationType | An enumerate type listing all the possible Load Classification Type for a Connector object.
OccupancyUnit | An enumerate type listing all the possible Occupancy Unit for a Space object.
PartType | An enumerate type listing all the part type for the mechanical fittings.
PipeFlowConfigurationType | An enumerate type listing all Pipe Load Configuration type for the connector
PipeFlowState | An enumerate type listing all the pipe flow state for the pipes.
PipeLossMethodType | An enumerate type listing all Pipe Load Configuration type for the connector
PipeSystemType | An enumerate type listing all the possible Pipe System Types for a Duct Connector object.
PowerFactorStateType | An enumerate type listing all the possible Power Factor State Type for a Connector object.
ReturnAirflowType | An enumerate type listing all the possible Return Airflow Type for a Space object.
SpaceType | An enumerate type listing all the possible Space Type for a Space object.
WiringType | An enumerate type to list all wiring type.


BaseLoadOn Enumeration

[image]

Revit 2010 API
BaseLoadOn Enumeration
See Also Send Feedback
An enumerate type listing all the possible Power Load Unit for a Space object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum BaseLoadOn
Visual Basic (Declaration)
Public Enumeration BaseLoadOn
Visual C++
public enum class BaseLoadOn

Members

Member name | Description
kNoOfBaseLoadOnMethods | Return BaseLoadOn is NoOfBaseLoadOnMethods.
kUseActualLoad | Return BaseLoadOn is UseActualLoad.
kUseCalculatedLoad | Return BaseLoadOn is UseCalculatedLoad.
kUseEnteredLoad | Return BaseLoadOn is UseEnteredLoad.
kUseDefaultLoad | Return BaseLoadOn is UseDefaultLoad.

See Also

Autodesk.Revit.MEP.Enums Namespace


ConditionType Enumeration

[image]

Revit 2010 API
ConditionType Enumeration
See Also Send Feedback
An enumerate type listing all the possible Return Airflow Type for a Space object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ConditionType
Visual Basic (Declaration)
Public Enumeration ConditionType
Visual C++
public enum class ConditionType

Members

Member name | Description
NoOfConditionTypes | Condition Type is NoOfConditionTypes.
NaturallyVentedOnly | Condition Type is NaturallyVentedOnly.
Vented | Condition Type is Vented.
Unconditioned | Condition Type is Unconditioned.
HeatedAndCooled | Condition Type is HeatedAndCooled.
Cooled | Condition Type is Cooled.
Heated | Condition Type is Heated.

See Also

Autodesk.Revit.MEP.Enums Namespace


ConnectorProfileType Enumeration

[image]

Revit 2010 API
ConnectorProfileType Enumeration
See Also Send Feedback
An enumerate type listing all the Connector type for the Connection.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ConnectorProfileType
Visual Basic (Declaration)
Public Enumeration ConnectorProfileType
Visual C++
public enum class ConnectorProfileType

Members

Member name | Description
OvalProfile | Connection Profile Type is Oval.
RectProfile | Connection Profile Type is Rect.
RoundProfile | Connection Profile Type is Round.
InvalidProfile | Connection Profile Type is Invalid.

See Also

Autodesk.Revit.MEP.Enums Namespace


ConnectorType Enumeration

[image]

Revit 2010 API
ConnectorType Enumeration
See Also Send Feedback
An enumerate type listing all the Connector type for the Connection.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ConnectorType
Visual Basic (Declaration)
Public Enumeration ConnectorType
Visual C++
public enum class ConnectorType

Members

Member name | Description
AllConnectorModes | Connection Type is All Connector Modes.
NonEndConn | Connection Type is Non End Connection.
PhysicalConn | Connection Type is Physical Connection.
LogicalConn | Connection Type is Logical Connection.
CurveConn | Connection Type is Curve Connection.
EndConn | Connection Type is End Connection.
InvalidConnectorType | Connection Type is Invalid.

See Also

Autodesk.Revit.MEP.Enums Namespace


Domain Enumeration

[image]

Revit 2010 API
Domain Enumeration
See Also Send Feedback
An enumerate type listing all the Domain type for the Connector.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum Domain
Visual Basic (Declaration)
Public Enumeration Domain
Visual C++
public enum class Domain

Members

Member name | Description
DomainPiping | Domain is Piping.
DomainElectrical | Domain is Electrical.
DomainHvac | Domain is Hvac.
DomainUndefined | Domain is Undefined.

See Also

Autodesk.Revit.MEP.Enums Namespace


DuctFlowConfigurationType Enumeration

[image]

Revit 2010 API
DuctFlowConfigurationType Enumeration
See Also Send Feedback
An enumerate type listing all Duct Load Configuration type for the connector

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum DuctFlowConfigurationType
Visual Basic (Declaration)
Public Enumeration DuctFlowConfigurationType
Visual C++
public enum class DuctFlowConfigurationType

Members

Member name | Description
Preset | Duct flow configuration is preset.
Calculated | Duct flow configuration is calculated.
System | Duct flow configuration depends on system.

See Also

Autodesk.Revit.MEP.Enums Namespace


DuctLossMethodType Enumeration

[image]

Revit 2010 API
DuctLossMethodType Enumeration
See Also Send Feedback
An enumerate type listing all duct loss calculation methods for the connector

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum DuctLossMethodType
Visual Basic (Declaration)
Public Enumeration DuctLossMethodType
Visual C++
public enum class DuctLossMethodType

Members

Member name | Description
Coefficient | Duct loss method depends on the loss coefficient.
SpecificLoss | Duct loss method is specified.
NotDefined | Duct loss method is undefined.

See Also

Autodesk.Revit.MEP.Enums Namespace


DuctSystemType Enumeration

[image]

Revit 2010 API
DuctSystemType Enumeration
See Also Send Feedback
An enumerate type listing all the possible Duct System Types for a Duct Connector object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum DuctSystemType
Visual Basic (Declaration)
Public Enumeration DuctSystemType
Visual C++
public enum class DuctSystemType

Members

Member name | Description
Fitting | Duct System Type is Fitting.
OtherAir | Duct System Type is OtherAir.
ExhaustAir | Duct System Type is ExhaustAir.
ReturnAir | Duct System Type is ReturnAir.
SupplyAir | Duct System Type is SupplyAir.
UndefinedSystemType | Undefined system type
Global | Duct System Type is Global.

See Also

Autodesk.Revit.MEP.Enums Namespace


ElectricalPhase Enumeration

[image]

Revit 2010 API
ElectricalPhase Enumeration
See Also Send Feedback
An enumerate type to specify whether the electrical system is single phase or three phase.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ElectricalPhase
Visual Basic (Declaration)
Public Enumeration ElectricalPhase
Visual C++
public enum class ElectricalPhase

Members

Member name | Description
ThreePhase | Electrical phase is three phase.
SinglePhase | Electrical phase is single phase.

See Also

Autodesk.Revit.MEP.Enums Namespace


ElectricalPhaseConfiguration Enumeration

[image]

Revit 2010 API
ElectricalPhaseConfiguration Enumeration
See Also Send Feedback
An enumerate type to specify electrical phase configuration.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ElectricalPhaseConfiguration
Visual Basic (Declaration)
Public Enumeration ElectricalPhaseConfiguration
Visual C++
public enum class ElectricalPhaseConfiguration

Members

Member name | Description
Delta | Electrical phase configuration is delta.
Wye | Electrical phase configuration is Y.
Undefined | Electrical phase configuration is undefined.

See Also

Autodesk.Revit.MEP.Enums Namespace


ElectricalSystemType Enumeration

[image]

Revit 2010 API
ElectricalSystemType Enumeration
See Also Send Feedback
An enumerate type listing all the possible Electrical System Types for an Electrical Connector object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ElectricalSystemType
Visual Basic (Declaration)
Public Enumeration ElectricalSystemType
Visual C++
public enum class ElectricalSystemType

Members

Member name | Description
PowerUnBalanced | Electrical System Type is PowerUnBalanced.
PowerBalanced | Electrical System Type is PowerBalanced.
Communication | Electrical System Type is Communication.
NurseCall | Electrical System Type is NurseCall.
FireAlarm | Electrical System Type is FireAlarm.
Security | Electrical System Type is Security.
Telephone | Electrical System Type is Telephone.
PowerCircuit | Electrical System Type is PowerCircuit.
UndefinedSystemType | Unknown system type
Controls | Electrical System Type is Controls.
Data | Electrical System Type is Data.

See Also

Autodesk.Revit.MEP.Enums Namespace


FlowDirectionType Enumeration

[image]

Revit 2010 API
FlowDirectionType Enumeration
See Also Send Feedback
An enumerate type listing all direction type for the connector

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum FlowDirectionType
Visual Basic (Declaration)
Public Enumeration FlowDirectionType
Visual C++
public enum class FlowDirectionType

Members

Member name | Description
In | flow in
Bidirectional | flow bidirectional
Out | flow out

See Also

Autodesk.Revit.MEP.Enums Namespace


JunctionType Enumeration

[image]

Revit 2010 API
JunctionType Enumeration
See Also Send Feedback
An enumerate type listing all the junction type for the MEP curve types.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum JunctionType
Visual Basic (Declaration)
Public Enumeration JunctionType
Visual C++
public enum class JunctionType

Members

Member name | Description
Tee | The junction type is tee.
Tap | The junction type is tap.

See Also

Autodesk.Revit.MEP.Enums Namespace


LoadClassification Enumeration

[image]

Revit 2010 API
LoadClassification Enumeration
See Also Send Feedback
An enumerate type to list all demond factor classification.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum LoadClassification
Visual Basic (Declaration)
Public Enumeration LoadClassification
Visual C++
public enum class LoadClassification

Members

Member name | Description
Hvac | Load classification is HVAC.
Lighting | Load classification is lighting.
Power | Load classification is power.
Undefined | Load classification is undefined.

See Also

Autodesk.Revit.MEP.Enums Namespace


LoadClassificationType Enumeration

[image]

Revit 2010 API
LoadClassificationType Enumeration
See Also Send Feedback
An enumerate type listing all the possible Load Classification Type for a Connector object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum LoadClassificationType
Visual Basic (Declaration)
Public Enumeration LoadClassificationType
Visual C++
public enum class LoadClassificationType

Members

Member name | Description
HVAC | Load Classification Type is HVAC.
Lighting | Load Classification Type is Lighting.
Power | Load Classification Type is Power.
Other | Load Classification Type is Other.

See Also

Autodesk.Revit.MEP.Enums Namespace


OccupancyUnit Enumeration

[image]

Revit 2010 API
OccupancyUnit Enumeration
See Also Send Feedback
An enumerate type listing all the possible Occupancy Unit for a Space object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum OccupancyUnit
Visual Basic (Declaration)
Public Enumeration OccupancyUnit
Visual C++
public enum class OccupancyUnit

Members

Member name | Description
AreaPerPerson | OccupancyUnit is AreaPerPerson.
NumberOfPeople | OccupancyUnit is NumberOfPeople.
UseDefaultValues | OccupancyUnit is UseDefaultValues.

See Also

Autodesk.Revit.MEP.Enums Namespace


PartType Enumeration

[image]

Revit 2010 API
PartType Enumeration
See Also Send Feedback
An enumerate type listing all the part type for the mechanical fittings.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum PartType
Visual Basic (Declaration)
Public Enumeration PartType
Visual C++
public enum class PartType

Members

Member name | Description
ValveNormal | The part type is valve normal.
MultiPort | The part type is multi port.
Pants | The part type is pants.
LateralCross | The part type is lateral cross.
LateralTee | The part type is lateral tee.
Wye | The part type is wye.
Damper | The part type is damper.
SpudAdjustable | The part type is spud adjustable.
SpudPerpendicular | The part type is spud perpendicular.
ValveBreaksInto | The part type is valve breaks into.
EquipmentSwitch | The part type is equipment switch.
OtherPanel | The part type is other panel.
SwitchBoard | The part type is switch board.
Transformer | The part type is transformer.
PanelBoard | The part type is panel board.
Union | The part type is union.
Offset | The part type is offset.
TapAdjustable | The part type is tap adjustable.
TapPerpendicular | The part type is tap perpendicular.
Cap | The part type is cap.
Tee | The part type is tee.
Elbow | The part type is elbow.
BreaksInto | The part type is breaks into.
AttachesTo | The part type is attaches to.
JunctionBox | The part type is junction box.
DuctMounted | The part type is duct mounted.
Normal | The part type is normal.
UndefinedPartType | The part type is undifined.
Switch | The part type is switch.
Cross | The part type is cross.
Transition | The part type is transition.

See Also

Autodesk.Revit.MEP.Enums Namespace


PipeFlowConfigurationType Enumeration

[image]

Revit 2010 API
PipeFlowConfigurationType Enumeration
See Also Send Feedback
An enumerate type listing all Pipe Load Configuration type for the connector

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum PipeFlowConfigurationType
Visual Basic (Declaration)
Public Enumeration PipeFlowConfigurationType
Visual C++
public enum class PipeFlowConfigurationType

Members

Member name | Description
Demand | pipe flow configuration depends on demand.
Preset | pipe flow configuration is Preset.
Calculated | pipe flow configuration is calculated.
System | pipe flow configuration depends on system.

See Also

Autodesk.Revit.MEP.Enums Namespace


PipeFlowState Enumeration

[image]

Revit 2010 API
PipeFlowState Enumeration
See Also Send Feedback
An enumerate type listing all the pipe flow state for the pipes.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum PipeFlowState
Visual Basic (Declaration)
Public Enumeration PipeFlowState
Visual C++
public enum class PipeFlowState

Members

Member name | Description
TurbulentState | The flow state is Turbulent.
TransitionState | The flow state is Transition.
LaminarState | The flow state is Laminar.

See Also

Autodesk.Revit.MEP.Enums Namespace


PipeLossMethodType Enumeration

[image]

Revit 2010 API
PipeLossMethodType Enumeration
See Also Send Feedback
An enumerate type listing all Pipe Load Configuration type for the connector

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum PipeLossMethodType
Visual Basic (Declaration)
Public Enumeration PipeLossMethodType
Visual C++
public enum class PipeLossMethodType

Members

Member name | Description
Coefficient | pipe loss method depend on coefficient.
SpecificLoss | pipe loss method is specified.
NotDefined | pipe loss method is undefined.
Table | pipe loss method is depend on the coefficient from table.

See Also

Autodesk.Revit.MEP.Enums Namespace


PipeSystemType Enumeration

[image]

Revit 2010 API
PipeSystemType Enumeration
See Also Send Feedback
An enumerate type listing all the possible Pipe System Types for a Duct Connector object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum PipeSystemType
Visual Basic (Declaration)
Public Enumeration PipeSystemType
Visual C++
public enum class PipeSystemType

Members

Member name | Description
Fitting | Pipe System Type is Fitting.
FireProtectOther | Pipe System Type is FireProtectOther.
FireProtectPreaction | Pipe System Type is FireProtectPreaction.
FireProtectDry | Pipe System Type is FireProtectDry.
FireProtectWet | Pipe System Type is FireProtectWet.
OtherPipe | Pipe System Type is OtherPipe.
DomesticColdWater | Pipe System Type is DomesticColdWater.
DomesticHotWater | Pipe System Type is DomesticHotWater.
Sanitary | Pipe System Type is Sanitary.
ReturnHydronic | Pipe System Type is ReturnHydronic.
SupplyHydronic | Pipe System Type is SupplyHydronic.
UndefinedSystemType | Undefined system type
Global | Pipe System Type is Global.

See Also

Autodesk.Revit.MEP.Enums Namespace


PowerFactorStateType Enumeration

[image]

Revit 2010 API
PowerFactorStateType Enumeration
See Also Send Feedback
An enumerate type listing all the possible Power Factor State Type for a Connector object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum PowerFactorStateType
Visual Basic (Declaration)
Public Enumeration PowerFactorStateType
Visual C++
public enum class PowerFactorStateType

Members

Member name | Description
Lagging | Power FactorState Type is Lagging.
Leading | Power FactorState Type is Leading.

See Also

Autodesk.Revit.MEP.Enums Namespace


ReturnAirflowType Enumeration

[image]

Revit 2010 API
ReturnAirflowType Enumeration
See Also Send Feedback
An enumerate type listing all the possible Return Airflow Type for a Space object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ReturnAirflowType
Visual Basic (Declaration)
Public Enumeration ReturnAirflowType
Visual C++
public enum class ReturnAirflowType

Members

Member name | Description
ActualSupplyAirflow | Return Airflow Type is ActualSupplyAirflow.
CalculatedSupplyAirflow | Return Airflow Type is CalculatedSupplyAirflow.
SpecifiedSupplyAirflow | Return Airflow Type is SpecifiedSupplyAirflow.
Specified | Return Airflow Type is Specified.

See Also

Autodesk.Revit.MEP.Enums Namespace


SpaceType Enumeration

[image]

Revit 2010 API
SpaceType Enumeration
See Also Send Feedback
An enumerate type listing all the possible Space Type for a Space object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum SpaceType
Visual Basic (Declaration)
Public Enumeration SpaceType
Visual C++
public enum class SpaceType

Members

Member name | Description
kNoOfSpaceTypes | Space Type is NoOfSpaceTypes.
kWorshipPulpitChoirReligious | Space Type is WorshipPulpitChoirReligious.
kWorkshopWorkshop | Space Type is WorkshopWorkshop.
kTerminalTicketCounterTransportation | Space Type is TerminalTicketCounterTransportation.
kSupermarketSalesAreaRetail | Space Type is SupermarketSalesAreaRetail.
kStairway | Space Type is Stairway.
kStairsInactive | Space Type is StairsInactive.
kStacksLibrary | Space Type is StacksLibrary.
kSpecialtyStoreSalesAreaRetail | Space Type is SpecialtyStoreSalesAreaRetail.
kSortingAreaPostOffice | Space Type is SortingAreaPostOffice.
kSleepingQuartersPoliceOrFireStation | Space Type is SleepingQuartersPoliceOrFireStation.
kRingSportsAreaSportsArena | Space Type is RingSportsAreaSportsArena.
kRestrooms | Space Type is Restrooms.
kRestorationMuseum | Space Type is RestorationMuseum.
kRecoveryHospitalOrHealthcare | Space Type is RecoveryHospitalOrHealthcare.
kReceptionOrWaitingHotel | Space Type is ReceptionOrWaitingHotel.
kReceptionOrWaitingMotel | Space Type is ReceptionOrWaitingMotel.
kReceptionOrWaitingTransportation | Space Type is ReceptionOrWaitingTransportation.
kReadingAreaLibrary | Space Type is ReadingAreaLibrary.
kPublicAndStaffLoungeHospitalOrHealthcare | Space Type is PublicAndStaffLoungeHospitalOrHealthcare.
kPlenum | Space Type is Plenum.
kPoliceStationLaboratoryPoliceOrFireStations | Space Type is PoliceStationLaboratoryPoliceOrFireStations.
kPlayingAreaGymnasium | Space Type is PlayingAreaGymnasium.
kPhysicalTherapyHospitalOrHealthcare | Space Type is PhysicalTherapyHospitalOrHealthcare.
kPharmacyHospitalOrHealthcare | Space Type is PharmacyHospitalOrHealthcare.
kPersonalServicesSalesAreaRetail | Space Type is PersonalServicesSalesAreaRetail.
kPatientRoomHospitalOrHealthcare | Space Type is PatientRoomHospitalOrHealthcare.
kParkingAreaPedestrianParkingGarage | Space Type is ParkingAreaPedestrianParkingGarage.
kParkingAreaAttendantOnlyParkingGarage | Space Type is ParkingAreaAttendantOnlyParkingGarage.
kOtherTelevisedPlayingAreaSportsArena | Space Type is OtherTelevisedPlayingAreaSportsArena.
kOperatingRoomHospitalOrHealthcare | Space Type is OperatingRoomHospitalOrHealthcare.
kOfficeCommonActivityAreasInactiveStorage | Space Type is OfficeCommonActivityAreasInactiveStorage.
kOfficeOpenPlan | Space Type is OfficeOpenPlan.
kOfficeEnclosed | Space Type is OfficeEnclosed.
kNurseStationHospitalOrHealthcare | Space Type is NurseStationHospitalOrHealthcare.
kMuseumAndGalleryStorage | Space Type is MuseumAndGalleryStorage.
kMerchandisingSalesAreaRetail | Space Type is MerchandisingSalesAreaRetail.
kMediumOrBulkyMaterialWarehouse | Space Type is MediumOrBulkyMaterialWarehouse.
kMassMerchandisingSalesAreaRetail | Space Type is MassMerchandisingSalesAreaRetail.
kMallConcourseSalesAreaRetail | Space Type is MallConcourseSalesAreaRetail.
kLoungeOrRecreation | Space Type is LoungeOrRecreation.
kLobbyHotel | Space Type is LobbyHotel.
kLobbyPostOffice | Space Type is LobbyPostOffice.
kLobbyPerformingArtsTheatre | Space Type is LobbyPerformingArtsTheatre.
kLobbyAuditorium | Space Type is LobbyAuditorium.
kLobbyMotionPictureTheatre | Space Type is LobbyMotionPictureTheatre.
kLobbyReligiousBuildings | Space Type is LobbyReligiousBuildings.
kLobby | Space Type is Lobby.
kLivingQuartersHotel | Space Type is LivingQuartersHotel.
kLivingQuartersMotel | Space Type is LivingQuartersMotel.
kLivingQuartersDormitory | Space Type is LivingQuartersDormitory.
kLibraryAudioVisualLibraryAudioVisual | Space Type is LibraryAudioVisualLibraryAudioVisual.
kLaundryWashingHospitalOrHealthcare | Space Type is LaundryWashingHospitalOrHealthcare.
kLaundryIroningAndSorting | Space Type is LaundryIroningAndSorting.
kLaboratoryOffice | Space Type is LaboratoryOffice.
kJudgesChambersCourtHouse | Space Type is JudgesChambersCourtHouse.
kInactiveStorage | Space Type is InactiveStorage.
kHotelOrConferenceCenterConferenceOrMeeting | Space Type is HotelOrConferenceCenterConferenceOrMeeting.
kHospitalOrRadiologyHospitalOrHealthcare | Space Type is HospitalOrRadiologyHospitalOrHealthcare.
kHospitalOrMedicalSuppliesHospitalOrHealthcare | Space Type is HospitalOrMedicalSuppliesHospitalOrHealthcare.
kHospitalNurseryHospitalOrHealthcare | Space Type is HospitalNurseryHospitalOrHealthcare.
kGeneralExhibitionMuseum | Space Type is GeneralExhibitionMuseum.
kGeneralLowBayManufacturingFacility | Space Type is GeneralLowBayManufacturingFacility.
kGeneralHighBayManufacturingFacility | Space Type is GeneralHighBayManufacturingFacility.
kGarageServiceOrRepairAutomotiveFacility | Space Type is GarageServiceOrRepairAutomotiveFacility.
kFoodPreparation | Space Type is FoodPreparation.
kFireStationEngineRoomPoliceOrFireStation | Space Type is FireStationEngineRoomPoliceOrFireStation.
kFineMerchandiseSalesAreaRetail | Space Type is FineMerchandiseSalesAreaRetail.
kFineMaterialWarehouse | Space Type is FineMaterialWarehouse.
kFellowshipHallReligiousBuildings | Space Type is FellowshipHallReligiousBuildings.
kExhibitSpaceConventionCenter | Space Type is ExhibitSpaceConventionCenter.
kExerciseAreaGymnasium | Space Type is ExerciseAreaGymnasium.
kExerciseAreaExerciseCenter | Space Type is ExerciseAreaExerciseCenter.
kExamOrTreatmentHospitalOrHealthcare | Space Type is ExamOrTreatmentHospitalOrHealthcare.
kEquipmentRoomManufacturingFacility | Space Type is EquipmentRoomManufacturingFacility.
kEmergencyHospitalOrHealthcare | Space Type is EmergencyHospitalOrHealthcare.
kElevatorLobbies | Space Type is ElevatorLobbies.
kElectricalOrMechanical | Space Type is ElectricalOrMechanical.
kDressingOrLockerOrFittingRoomExerciseCenter | Space Type is DressingOrLockerOrFittingRoomExerciseCenter.
kDressingOrLockerOrFittingRoomAuditorium | Space Type is DressingOrLockerOrFittingRoomAuditorium.
kDressingOrLockerOrFittingRoomPerformingArtsTheatre | Space Type is DressingOrLockerOrFittingRoomPerformingArtsTheatre.
kDressingOrLockerOrFittingRoomCourtHouse | Space Type is DressingOrLockerOrFittingRoomCourtHouse.
kDressingOrLockerOrFittingRoomGymnasium | Space Type is DressingOrLockerOrFittingRoomGymnasium.
kDormitoryStudyHall | Space Type is DormitoryStudyHall.
kDormitoryBedroom | Space Type is DormitoryBedroom.
kDiningAreaCivilServices | Space Type is DiningAreaCivilServices.
kDiningAreaPenitentiary | Space Type is DiningAreaPenitentiary.
kDiningAreaTransportation | Space Type is DiningAreaTransportation.
kDiningAreaMotel | Space Type is DiningAreaMotel.
kDiningAreaLoungeOrLeisureDining | Space Type is DiningAreaLoungeOrLeisureDining.
kDiningAreaFamilyDining | Space Type is DiningAreaFamilyDining.
kDiningAreaHotel | Space Type is DiningAreaHotel.
kDiningArea | Space Type is DiningArea.
kDetailedManufacturingFacility | Space Type is DetailedManufacturingFacility.
kDepartmentStoreSalesAreaRetail | Space Type is DepartmentStoreSalesAreaRetail.
kCourtroomCourtHouse | Space Type is CourtroomCourtHouse.
kCourtSportsAreaSportsArena | Space Type is CourtSportsAreaSportsArena.
kCorridorsWithPatientWaitingExamHospitalOrHealthcare | Space Type is CorridorsWithPatientWaitingExamHospitalOrHealthcare.
kCorridorOrTransitionManufacturingFacility | Space Type is CorridorOrTransitionManufacturingFacility.
kCorridorOrTransition | Space Type is CorridorOrTransition.
kConferenceMeetingOrMultipurpose | Space Type is ConferenceMeetingOrMultipurpose.
kComfinementCellsCourtHouse | Space Type is ComfinementCellsCourtHouse.
kComfinementCellsPenitentiary | Space Type is ComfinementCellsPenitentiary.
kClassroomOrLectureOrTraining | Space Type is ClassroomOrLectureOrTraining.
kClassroomOrLectureOrTrainingPenitentiary | Space Type is ClassroomOrLectureOrTrainingPenitentiary.
kCardFileAndCataloguingLibrary | Space Type is CardFileAndCataloguingLibrary.
kBarberAndBeautyParlor | Space Type is BarberAndBeautyParlor.
kBankingActivityAreaOffice | Space Type is BankingActivityAreaOffice.
kBankCustomerArea | Space Type is BankCustomerArea.
kAudienceOrSeatingAreaAuditorium | Space Type is AudienceOrSeatingAreaAuditorium.
kAudienceOrSeatingAreaCourtHouse | Space Type is AudienceOrSeatingAreaCourtHouse.
kAudienceOrSeatingAreaPoliceOrFireStations | Space Type is AudienceOrSeatingAreaPoliceOrFireStations.
kAudienceOrSeatingAreaReligious | Space Type is AudienceOrSeatingAreaReligious.
kAudienceOrSeatingAreaPerformingArtsTheatre | Space Type is AudienceOrSeatingAreaPerformingArtsTheatre.
kAudienceOrSeatingAreaMotionPictureTheatre | Space Type is AudienceOrSeatingAreaMotionPictureTheatre.
kAudienceOrSeatingAreaConventionCenter | Space Type is AudienceOrSeatingAreaConventionCenter.
kAudienceOrSeatingAreaSportsArena | Space Type is AudienceOrSeatingAreaSportsArena.
kAudienceOrSeatingAreaGymnasium | Space Type is AudienceOrSeatingAreaGymnasium.
kAudienceOrSeatingAreaExerciseCenter | Space Type is AudienceOrSeatingAreaExerciseCenter.
kAudienceOrSeatingAreaPenitentiary | Space Type is AudienceOrSeatingAreaPenitentiary.
kAtriumFirstThreeFloors | Space Type is AtriumFirstThreeFloors.
kAtriumEachAdditionalFloor | Space Type is AtriumEachAdditionalFloor.
kAirportConcourse | Space Type is AirportConcourse.
kAirOrTrainOrBusBaggageArea | Space Type is AirOrTrainOrBusBaggageArea.
kActiveStorageHospitalOrHealthcare | Space Type is ActiveStorageHospitalOrHealthcare.
kActiveStorage | Space Type is ActiveStorage.
kNoSpaceType | Space Type is NoSpaceType.

See Also

Autodesk.Revit.MEP.Enums Namespace


WiringType Enumeration

[image]

Revit 2010 API
WiringType Enumeration
See Also Send Feedback
An enumerate type to list all wiring type.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum WiringType
Visual Basic (Declaration)
Public Enumeration WiringType
Visual C++
public enum class WiringType

Members

Member name | Description
Chamfer | Chamfered wiring can be used to indicate wiring that is exposed.
Arc | Arc wiring is used to indicate wiring that is concealed within walls, ceilings, or floors.

See Also

Autodesk.Revit.MEP.Enums Namespace


Autodesk.Revit.Options Namespace

[image]

Revit 2010 API
Autodesk.Revit.Options Namespace
Send Feedback

Classes

Class | Description
Application | The Application Options object provides access to application wide settings.


Application Class

[image]

Revit 2010 API
Application Class
Members See Also Send Feedback
The Application Options object provides access to application wide settings.

Namespace: Autodesk.Revit.Options
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Application : APIObject
Visual Basic (Declaration)
Public Class Application _
    Inherits APIObject
Visual C++
public ref class Application : public APIObject

Remarks

This object provides access to variables that are located in the Settings dialog within Autodesk Revit.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Options..::.Application

See Also

Application Members
Autodesk.Revit.Options Namespace


Application Members

[image] [image]

Revit 2010 API
Application Members
Application Class Constructors Methods Properties See Also Send Feedback

The Application type exposes the following members.

Constructors

Name | Description
Application | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
LibraryPaths | Retrieves path information for where content is stored on disk.
SharedParametersFilename | Contains the fully qualified path to a shared parameters file.

See Also

Application Class
Autodesk.Revit.Options Namespace


Application Constructor

[image]

Revit 2010 API
Application Constructor
Application Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Options
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Application()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Application()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Application Class
Autodesk.Revit.Options Namespace


Application Methods

[image] [image]

Revit 2010 API
Application Methods
Application Class See Also Send Feedback

The Application type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Application Class
Autodesk.Revit.Options Namespace


Application Properties

[image] [image]

Revit 2010 API
Application Properties
Application Class See Also Send Feedback

The Application type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
LibraryPaths | Retrieves path information for where content is stored on disk.
SharedParametersFilename | Contains the fully qualified path to a shared parameters file.

See Also

Application Class
Autodesk.Revit.Options Namespace


LibraryPaths Property

[image]

Revit 2010 API
Application..::.LibraryPaths Property
Application Class Example See Also Send Feedback
Retrieves path information for where content is stored on disk.

Namespace: Autodesk.Revit.Options
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public StringStringMap LibraryPaths { get; set; }
Visual Basic (Declaration)
Public Property LibraryPaths As StringStringMap
Visual C++
public:
property StringStringMap^ LibraryPaths {
    StringStringMap^ get ();
    void set (StringStringMap^ value);
}

Remarks

This property is used to control where Autodesk Revit searches for content. The map that is returned contains a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path that is used for that search path.

Examples

CopyC#
string strLibPaths = "";
foreach (String path in application.Options.LibraryPaths)
{
    strLibPaths += path + "\n";
}
CopyVB.NET
Dim strLibPaths As String = ""
For Each path As String In application.Options.LibraryPaths
    strLibPaths += path & vbLf
Next

See Also

Application Class
Autodesk.Revit.Options Namespace


SharedParametersFilename Property

[image]

Revit 2010 API
Application..::.SharedParametersFilename Property
Application Class See Also Send Feedback
Contains the fully qualified path to a shared parameters file.

Namespace: Autodesk.Revit.Options
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string SharedParametersFilename { get; set; }
Visual Basic (Declaration)
Public Property SharedParametersFilename As String
Visual C++
public:
property String^ SharedParametersFilename {
    String^ get ();
    void set (String^ value);
}

Remarks

This path can be read and set via this property. By default Autodesk Revit does not have a shared parameters file so this property must be set before access is made to the shared parameters file object otherwise an exception will be thrown.

See Also

Application Class
Autodesk.Revit.Options Namespace


Autodesk.Revit.Parameters Namespace

[image]

Revit 2010 API
Autodesk.Revit.Parameters Namespace
Send Feedback

Classes

Class | Description
Binding | Binding objects are used to take a parameter definition and bind it to one or more categories.
BindingMap | The parameters BindingMap contains all the parameter bindings that exist in the Autodesk Revit project.
Definition | The Definition object is a base object for all type of parameter definitions within the Autodesk Revit API.
DefinitionFile | The DefinitionFile object represents a shared parameters file on disk.
DefinitionGroup | The DefinitionGroup is a container that is used to hold shared parameter definitions on disk.
DefinitionGroups | A specialised set of definition groups that allows creation of new groups.
DefinitionGroupsBase | A set that contains definition groups.
DefinitionGroupsBaseIterator | An iterator to a definition group set.
Definitions | A base class that supports the addition of new parameter definitions.
DefinitionsBase | A set that contains definitions.
DefinitionsBaseIterator | An iterator to a definition set.
ElementBinding | A base class for all types of binding that attach to an element.
ExternalDefinition | The ExternalDefinition object adds properties specific to Autodesk Revit shared parameter definitions.
ExternalDefinitions | Supports the creation of new shared parameters definitions.
InstanceBinding | The InstanceBinding object is used to signify a binding between a parameter definition and a parameter on each instance of an element, such as a wall.
InternalDefinition | This object represents a parameter definition in Autodesk Revit.
InternalDefinitions | This object blocks attempts to create new internal definitions as they are not permitted.
ParameterListItem | Object representing list item of external list parameter.
ParameterListItemArray | An array that can contain any type of object.
ParameterListItemArrayIterator | An iterator to a array.
TypeBinding | TypeBinding objects are used to bind a property to a Revit type, such as a wall type.

Enumerations

Enumeration | Description
BuildingType | An enumerated type listing all of the built-in building types supported by Autodesk Revit.
BuiltInParameter | An enumerate type listing all of the built-in parameter ids supported by Autodesk Revit.
BuiltInParameterGroup | An enumerate type listing all of the built-in parameter groups supported by Autodesk Revit.
ConstructionType | An enumerate type listing all of the built-in construction types supported by Autodesk Revit.
ParameterType | An enumerate type listing all of the data type interpretation that Autodesk Revit supports.
ServiceType | An enumerate type listing all of the built-in service types supported by Autodesk Revit.
StorageType | An enumerate type listing all of the internal parameter data storage types that Autodesk Revit supports.


Binding Class

[image]

Revit 2010 API
Binding Class
Members See Also Send Feedback
Binding objects are used to take a parameter definition and bind it to one or more categories.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class Binding : APIObject
Visual Basic (Declaration)
Public MustInherit Class Binding _
    Inherits APIObject
Visual C++
public ref class Binding abstract : public APIObject

Remarks

This class is a base class for all types of parameter binding within Autodesk Revit. Once the binging objects are created and added to the document parameters will be added to elements in those categories specified in the binding. There are currently two types of binding available, Instance binding and Type binding. The key difference between the two is that the instance bound parameters appear on all instances of the elements in those categories. Changing the parameter on one does not effect the other instances of the parameter. The Type bound parameters appear only on the type object and is shared by all the instances that use that type. Changing the type bound parameter affects all instances of the elements that use that type. Note, a definition can only be bound to an instance or a type and not both.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.Binding
Autodesk.Revit.Parameters..::.ElementBinding

See Also

Binding Members
Autodesk.Revit.Parameters Namespace


Binding Members

[image] [image]

Revit 2010 API
Binding Members
Binding Class Constructors Methods Properties See Also Send Feedback

The Binding type exposes the following members.

Constructors

Name | Description
Binding | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Binding Class
Autodesk.Revit.Parameters Namespace


Binding Constructor

[image]

Revit 2010 API
Binding Constructor
Binding Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Binding()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Binding()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Binding Class
Autodesk.Revit.Parameters Namespace


Binding Methods

[image] [image]

Revit 2010 API
Binding Methods
Binding Class See Also Send Feedback

The Binding type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Binding Class
Autodesk.Revit.Parameters Namespace


Binding Properties

[image] [image]

Revit 2010 API
Binding Properties
Binding Class See Also Send Feedback

The Binding type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Binding Class
Autodesk.Revit.Parameters Namespace


BindingMap Class

[image]

Revit 2010 API
BindingMap Class
Members See Also Send Feedback
The parameters BindingMap contains all the parameter bindings that exist in the Autodesk Revit project.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BindingMap : DefinitionBindingMap
Visual Basic (Declaration)
Public Class BindingMap _
    Inherits DefinitionBindingMap
Visual C++
public ref class BindingMap : public DefinitionBindingMap

Remarks

The ParameterBindingsMap is available from the Document.ParameterBindings property. A parameter binding is the way that a parameter definition is bound to elements within one or more categories. This map can be used to interrogate existing bindings, but it can also be used to generate new parameter bindings by using the Insert method.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Collections..::.DefinitionBindingMap
Autodesk.Revit.Parameters..::.BindingMap

See Also

BindingMap Members
Autodesk.Revit.Parameters Namespace


BindingMap Members

[image] [image]

Revit 2010 API
BindingMap Members
BindingMap Class Constructors Methods Properties See Also Send Feedback

The BindingMap type exposes the following members.

Constructors

Name | Description
BindingMap | For Internal Use Only.

Methods

Name | Description
Clear | This method is used to remove all the items in the map. (Overrides DefinitionBindingMap..::.Clear()()().)
Contains | The Contains method is used to check if the parameter binding exists for one definition. (Overrides DefinitionBindingMap..::.Contains(Definition).)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | This method is used to erase one item in the map. (Overrides DefinitionBindingMap..::.Erase(Definition).)
ForwardIterator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
GetEnumerator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Overloaded. Creates a new parameter binding.
ReInsert | Overloaded. Removes an existing parameter and creates a new binding for a given parameter.
Remove | The Remove method is used to remove a parameter binding.
ReverseIterator | Retrieve a backward moving iterator to the map. (Inherited from DefinitionBindingMap.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the map is empty. (Inherited from DefinitionBindingMap.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | The get_Item method will get the binding item related to the input key. (Overrides DefinitionBindingMap..::.Item[([(Definition])]).)
Size | Returns the number of bindings that are in the map. (Inherited from DefinitionBindingMap.)

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace


BindingMap Constructor

[image]

Revit 2010 API
BindingMap Constructor
BindingMap Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BindingMap()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BindingMap()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace


BindingMap Methods

[image] [image]

Revit 2010 API
BindingMap Methods
BindingMap Class See Also Send Feedback

The BindingMap type exposes the following members.

Methods

Name | Description
Clear | This method is used to remove all the items in the map. (Overrides DefinitionBindingMap..::.Clear()()().)
Contains | The Contains method is used to check if the parameter binding exists for one definition. (Overrides DefinitionBindingMap..::.Contains(Definition).)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | This method is used to erase one item in the map. (Overrides DefinitionBindingMap..::.Erase(Definition).)
ForwardIterator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
GetEnumerator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Overloaded. Creates a new parameter binding.
ReInsert | Overloaded. Removes an existing parameter and creates a new binding for a given parameter.
Remove | The Remove method is used to remove a parameter binding.
ReverseIterator | Retrieve a backward moving iterator to the map. (Inherited from DefinitionBindingMap.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace


Clear Method

[image]

Revit 2010 API
BindingMap..::.Clear Method
BindingMap Class See Also Send Feedback
This method is used to remove all the items in the map.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override void Clear()
Visual Basic (Declaration)
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

Remarks

The method Clear inherited from base class is not permitted for this class. A NotSupportedException will be thrown.

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace


Contains Method

[image]

Revit 2010 API
BindingMap..::.Contains Method
BindingMap Class See Also Send Feedback
The Contains method is used to check if the parameter binding exists for one definition.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override bool Contains(
    Definition key
)
Visual Basic (Declaration)
Public Overrides Function Contains ( _
    key As Definition _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Definition^ key
) override

Parameters

key
Type: Autodesk.Revit.Parameters..::.Definition
A parameter definition which can be an existing definition or one from a shared parameters file.

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace


Erase Method

[image]

Revit 2010 API
BindingMap..::.Erase Method
BindingMap Class See Also Send Feedback
This method is used to erase one item in the map.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override int Erase(
    Definition key
)
Visual Basic (Declaration)
Public Overrides Function Erase ( _
    key As Definition _
) As Integer
Visual C++
public:
virtual int Erase(
    Definition^ key
) override

Parameters

key
Type: Autodesk.Revit.Parameters..::.Definition

Remarks

The method Erase inherited from base class is not permitted for this class. A NotSupportedException will be thrown. Use Remove() instead to remove the binding from the Revit session and from the map.

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace


Insert Method

[image] [image]

Revit 2010 API
BindingMap..::.Insert Method
BindingMap Class See Also Send Feedback
Creates a new parameter binding.

Overload List

Name | Description
Insert(Definition, Binding) | Creates a new parameter binding between a parameter and a set of categories. (Overrides DefinitionBindingMap..::.Insert(Definition, Binding).)
Insert(Definition, Binding, BuiltInParameterGroup) | Creates a new parameter binding between a parameter and a set of categories in a specified group.

See Also

BindingMap Class
BindingMap Members
Autodesk.Revit.Parameters Namespace


Insert Method (Definition, Binding)

[image]

Revit 2010 API
BindingMap..::.Insert Method (Definition, Binding)
BindingMap Class See Also Send Feedback
Creates a new parameter binding between a parameter and a set of categories.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override bool Insert(
    Definition key,
    Binding item
)
Visual Basic (Declaration)
Public Overrides Function Insert ( _
    key As Definition, _
    item As Binding _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Definition^ key,
    Binding^ item
) override

Parameters

key
Type: Autodesk.Revit.Parameters..::.Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Type: Autodesk.Revit.Parameters..::.Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, post an error and return false.

See Also

BindingMap Class
Insert Overload
Autodesk.Revit.Parameters Namespace


Insert Method (Definition, Binding, BuiltInParameterGroup)

[image]

Revit 2010 API
BindingMap..::.Insert Method (Definition, Binding, BuiltInParameterGroup)
BindingMap Class See Also Send Feedback
Creates a new parameter binding between a parameter and a set of categories in a specified group.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    Definition key,
    Binding item,
    BuiltInParameterGroup parameterGroup
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As Definition, _
    item As Binding, _
    parameterGroup As BuiltInParameterGroup _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Definition^ key,
    Binding^ item,
    BuiltInParameterGroup parameterGroup
)

Parameters

key
Type: Autodesk.Revit.Parameters..::.Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Type: Autodesk.Revit.Parameters..::.Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
parameterGroup
Type: Autodesk.Revit.Parameters..::.BuiltInParameterGroup
The GroupID of the parameter definition.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the Parameter binding already exists, post an error and return false

See Also

BindingMap Class
Insert Overload
Autodesk.Revit.Parameters Namespace


ReInsert Method

[image] [image]

Revit 2010 API
BindingMap..::.ReInsert Method
BindingMap Class See Also Send Feedback
Removes an existing parameter and creates a new binding for a given parameter.

Overload List

Name | Description
ReInsert(Definition, Binding) | Removes an existing parameter and creates a new binding for a given parameter.
ReInsert(Definition, Binding, BuiltInParameterGroup) | Removes an existing parameter and creates a new binding for a given parameter in a specified group.

See Also

BindingMap Class
BindingMap Members
Autodesk.Revit.Parameters Namespace


ReInsert Method (Definition, Binding)

[image]

Revit 2010 API
BindingMap..::.ReInsert Method (Definition, Binding)
BindingMap Class See Also Send Feedback
Removes an existing parameter and creates a new binding for a given parameter.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool ReInsert(
    Definition key,
    Binding item
)
Visual Basic (Declaration)
Public Overridable Function ReInsert ( _
    key As Definition, _
    item As Binding _
) As Boolean
Visual C++
public:
virtual bool ReInsert(
    Definition^ key,
    Binding^ item
)

Parameters

key
Type: Autodesk.Revit.Parameters..::.Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Type: Autodesk.Revit.Parameters..::.Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, remove the binding, create a new parameter binding.

See Also

BindingMap Class
ReInsert Overload
Autodesk.Revit.Parameters Namespace


ReInsert Method (Definition, Binding, BuiltInParameterGroup)

[image]

Revit 2010 API
BindingMap..::.ReInsert Method (Definition, Binding, BuiltInParameterGroup)
BindingMap Class See Also Send Feedback
Removes an existing parameter and creates a new binding for a given parameter in a specified group.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool ReInsert(
    Definition key,
    Binding item,
    BuiltInParameterGroup parameterGroup
)
Visual Basic (Declaration)
Public Overridable Function ReInsert ( _
    key As Definition, _
    item As Binding, _
    parameterGroup As BuiltInParameterGroup _
) As Boolean
Visual C++
public:
virtual bool ReInsert(
    Definition^ key,
    Binding^ item,
    BuiltInParameterGroup parameterGroup
)

Parameters

key
Type: Autodesk.Revit.Parameters..::.Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Type: Autodesk.Revit.Parameters..::.Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
parameterGroup
Type: Autodesk.Revit.Parameters..::.BuiltInParameterGroup
The GroupID of the parameter definition.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, remove the binding, create a new parameter binding. If the parameter binding related to the input key doesn't exist in the database, ReInsert will fail and false will be returned. In this case, Insert should be called.

See Also

BindingMap Class
ReInsert Overload
Autodesk.Revit.Parameters Namespace


Remove Method

[image]

Revit 2010 API
BindingMap..::.Remove Method
BindingMap Class See Also Send Feedback
The Remove method is used to remove a parameter binding.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Remove(
    Definition key
)
Visual Basic (Declaration)
Public Overridable Function Remove ( _
    key As Definition _
) As Boolean
Visual C++
public:
virtual bool Remove(
    Definition^ key
)

Parameters

key
Type: Autodesk.Revit.Parameters..::.Definition
A parameter definition which can be an existing definition or one from a shared parameters file.

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace


BindingMap Properties

[image] [image]

Revit 2010 API
BindingMap Properties
BindingMap Class See Also Send Feedback

The BindingMap type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the map is empty. (Inherited from DefinitionBindingMap.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | The get_Item method will get the binding item related to the input key. (Overrides DefinitionBindingMap..::.Item[([(Definition])]).)
Size | Returns the number of bindings that are in the map. (Inherited from DefinitionBindingMap.)

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace


Item Property

[image]

Revit 2010 API
BindingMap..::.Item Property
BindingMap Class See Also Send Feedback
The get_Item method will get the binding item related to the input key.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override Binding Item[
    Definition key
] { get; set; }
Visual Basic (Declaration)
Public Overrides Property Item ( _
    key As Definition _
) As Binding
Visual C++
public:
virtual property Binding^ Item[Definition^ key] {
    Binding^ get (Definition^ key) override;
    void set (Definition^ key, Binding^ value) override;
}

Parameters

key
Type: Autodesk.Revit.Parameters..::.Definition
A parameter definition which can be an existing definition or one from a shared parameters file.

Field Value

The returned value of get_Item is an InstanceBinding or TypeBinding object that contains the set of categories to which the parameter is bound. The input item is an InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.

Remarks

set_Item is not permitted for this class. A NotSupportedException will be thrown. Instead use Insert, Remove and ReInsert to modify the bindings in the document.

See Also

BindingMap Class
Autodesk.Revit.Parameters Namespace


BuildingType Enumeration

[image]

Revit 2010 API
BuildingType Enumeration
See Also Send Feedback
An enumerated type listing all of the built-in building types supported by Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum BuildingType
Visual Basic (Declaration)
Public Enumeration BuildingType
Visual C++
public enum class BuildingType

Members

Member name | Description
kWorkshop | Building Type is Workshop.
kWarehouse | Building Type is Warehouse.
kTransportation | Building Type is Transportation.
kTownHall | Building Type is TownHall.
kSportsArena | Building Type is SportsArena.
kSchoolOrUniversity | Building Type is SchoolOrUniversity.
kRetail | Building Type is Retail.
kReligiousBuilding | Building Type is ReligiousBuilding.
kPostOffice | Building Type is PostOffice.
kPoliceStation | Building Type is PoliceStation.
kPerformingArtsTheater | Building Type is PerformingArtsTheater.
kPenitentiary | Building Type is Penitentiary.
kParkingGarage | Building Type is ParkingGarage.
kOffice | Building Type is Office.
kMuseum | Building Type is Museum.
kMultiFamily | Building Type is MultiFamily.
kMotionPictureTheatre | Building Type is MotionPictureTheatre.
kMotel | Building Type is Motel.
kManufacturing | Building Type is Manufacturing.
kLibrary | Building Type is Library.
kHotel | Building Type is Hotel.
kHospitalOrHealthcare | Building Type is HospitalOrHealthcare.
kGymnasium | Building Type is Gymnasium.
kFireStation | Building Type is FireStation.
kExerciseCenter | Building Type is ExerciseCenter.
kDormitory | Building Type is Dormitory.
kDiningFamily | Building Type is DiningFamily.
kDiningCafeteriaFastFood | Building Type is DiningCafeteriaFastFood.
kDiningBarLoungeOrLeisure | Building Type is DiningBarLoungeOrLeisure.
kCourthouse | Building Type is Courthouse.
kConventionCenter | Building Type is ConventionCenter.
kAutomotiveFacility | Building Type is AutomotiveFacility.
kNoOfBuildingTypes | Building Type is NoOfBuildingTypes.

See Also

Autodesk.Revit.Parameters Namespace


BuiltInParameter Enumeration

[image]

Revit 2010 API
BuiltInParameter Enumeration
See Also Send Feedback
An enumerate type listing all of the built-in parameter ids supported by Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum BuiltInParameter
Visual Basic (Declaration)
Public Enumeration BuiltInParameter
Visual C++
public enum class BuiltInParameter

Members

Member name | Description
RBS_ELEC_PANEL_TOTALLOAD_POWER_PARAM |
RBS_ELEC_PANEL_TOTALESTLOAD_OTHER_PARAM |
RBS_ELEC_PANEL_TOTALLOAD_OTHER_PARAM |
RBS_ELEC_PANEL_TOTALESTLOAD_PARAM |
RBS_ELEC_PANEL_TOTALLOAD_PARAM |
RBS_ELEC_DEMANDFACTOR_LOADCLASSIFICATION_PARAM |
RBS_ELEC_DEMANDFACTOR_LOAD_PARAM |
RBS_ELEC_DEMANDFACTOR_DEMANDLOAD_PARAM |
RBS_FAMILY_CONTENT_DISTRIBUTION_SYSTEM |
RBS_DISTRIBUTIONSYS_VLL_PARAM |
RBS_DISTRIBUTIONSYS_VLG_PARAM |
RBS_DISTRIBUTIONSYS_PHASE_PARAM |
RBS_DISTRIBUTIONSYS_CONFIG_PARAM |
RBS_DISTRIBUTIONSYS_NUMWIRES_PARAM |
RBS_VOLTAGETYPE_VOLTAGE_PARAM |
RBS_VOLTAGETYPE_MINVOLTAGE_PARAM |
RBS_VOLTAGETYPE_MAXVOLTAGE_PARAM |
RBS_ELEC_APPARENT_LOAD_PHASEC |
RBS_ELEC_APPARENT_LOAD_PHASEB |
RBS_ELEC_APPARENT_LOAD_PHASEA |
RBS_ELEC_TRUE_LOAD_PHASEC |
RBS_ELEC_TRUE_LOAD_PHASEB |
RBS_ELEC_TRUE_LOAD_PHASEA |
RBS_ELEC_TRUE_CURRENT_PARAM |
RBS_ELEC_TRUE_CURRENT_PHASEA_PARAM |
RBS_ELEC_TRUE_CURRENT_PHASEB_PARAM |
RBS_ELEC_TRUE_CURRENT_PHASEC_PARAM |
RBS_ELEC_APPARENT_CURRENT_PARAM |
RBS_ELEC_APPARENT_CURRENT_PHASEA_PARAM |
RBS_ELEC_APPARENT_CURRENT_PHASEB_PARAM |
RBS_ELEC_APPARENT_CURRENT_PHASEC_PARAM |
RBS_ELEC_VOLTAGE_DROP_PARAM |
RBS_ELEC_CALC_COEFFICIENT_UTILIZATION |
RBS_ELEC_CIRCUIT_LENGTH_PARAM |
RBS_ELEC_CIRCUIT_RATING_PARAM |
RBS_ELEC_CIRCUIT_WIRE_SIZE_PARAM |
RBS_ELEC_CIRCUIT_WIRE_TYPE_PARAM |
RBS_ELEC_ROOM_CAVITY_RATIO |
RBS_ELEC_ROOM_AVERAGE_ILLUMINATION |
RBS_ELEC_ROOM_REFLECTIVITY_FLOOR |
RBS_ELEC_ROOM_REFLECTIVITY_WALLS |
RBS_ELEC_ROOM_REFLECTIVITY_CEILING |
RBS_ELEC_ROOM_LIGHTING_CALC_WORKPLANE |
RBS_WIRE_MATERIAL_PARAM |
RBS_WIRE_TEMPERATURE_RATING_PARAM |
RBS_WIRE_INSULATION_PARAM |
RBS_WIRE_MAX_CONDUCTOR_SIZE_PARAM |
RBS_WIRE_NEUTRAL_MULTIPLIER_PARAM |
RBS_WIRE_NEUTRAL_INCLUDED_IN_BALANCED_LOAD_PARAM |
RBS_WIRE_NEUTRAL_MODE_PARAM |
RBS_WIRE_CONDUIT_TYPE_PARAM |
RBS_ELEC_AMBIENT_TEMPERATURE |
RBS_EDIT_CIRCUITS_PARAM |
RBS_ELEC_CIRCUIT_TYPE |
RBS_ELEC_SERVICE |
RBS_ELEC_PANEL |
RBS_ELEC_CIRCUIT |
RBS_ELEC_LOAD_CLASSIFICATION |
RBS_ELEC_TRUE_LOAD_PHASE3 |
RBS_ELEC_TRUE_LOAD_PHASE2 |
RBS_ELEC_TRUE_LOAD_PHASE1 |
RBS_ELEC_TRUE_LOAD |
RBS_ELEC_POWER_FACTOR_STATE |
RBS_ELEC_POWER_FACTOR |
RBS_ELEC_APPARENT_LOAD_PHASE3 |
RBS_ELEC_APPARENT_LOAD_PHASE2 |
RBS_ELEC_APPARENT_LOAD_PHASE1 |
RBS_ELEC_APPARENT_LOAD |
RBS_ELEC_BALANCED_LOAD |
RBS_ELEC_VOLTAGE |
RBS_ELEC_NUMBER_OF_POLES |
RBS_CONNECTOR_DESCRIPTION |
MARKUPS_PRIVATE |
MARKUPS_NOTES |
MARKUPS_HISTORY |
MARKUPS_STATUS |
MARKUPS_LABEL |
MARKUPS_CREATOR |
MARKUPS_CREATED |
MARKUPS_MODIFIED |
LEGEND_COMPONENT_DETAIL_LEVEL |
LEGEND_COMPONENT_LENGTH |
LEGEND_COMPONENT_VIEW |
LEGEND_COMPONENT |
OPTION_SET_ID |
OPTION_NAME |
PRIMARY_OPTION_ID |
OPTION_SET_NAME |
GROUP_ATTACHED_PARENT_NAME |
GROUP_ALLOWED_VIEW_TYPES |
GROUP_OFFSET_FROM_LEVEL |
GROUP_LEVEL |
RBS_CONNECTOR_ISPRIMARY |
CONNECTOR_REFERENCE_INDEX |
RBS_PIPE_SYSTEM_TYPE |
CONNECTOR_ANGLE |
RBS_DUCT_SYSTEM_TYPE |
CONNECTOR_IS_EDGELOOP_CENTERED_OBSOLETE |
CONNECTOR_INDEX |
CONNECTOR_VISIBLE_SIZE |
CONNECTOR_HEIGHT |
CONNECTOR_WIDTH |
CONNECTOR_SIZE |
CONNECTOR_RADIUS |
CONNECTOR_PROFILE_TYPE |
RBS_ENERGY_ANALYSIS_EXPORT_COMPLEXITY_PARAM |
SPACE_ZONE_NAME |
RBS_ENERGY_ANALYSIS_EXPORT_GBXML_DEFAULTS_PARAM |
RBS_HVACLOAD_PLENUM_COOLING_LOAD_PARAM |
RBS_HVACLOAD_SKYLIGHT_COOLING_LOAD_PARAM |
RBS_HVACLOAD_PARTITION_COOLING_LOAD_PARAM |
RBS_HVACLOAD_DOOR_COOLING_LOAD_PARAM |
RBS_HVACLOAD_WINDOW_COOLING_LOAD_PARAM |
RBS_HVACLOAD_WALL_COOLING_LOAD_PARAM |
RBS_HVACLOAD_ROOF_COOLING_LOAD_PARAM |
RBS_HVACLOAD_SKYLIGHT_AREA_PARAM |
RBS_HVACLOAD_PARTITION_AREA_PARAM |
RBS_HVACLOAD_FLOOR_AREA_PARAM |
RBS_HVACLOAD_DOOR_AREA_PARAM |
RBS_HVACLOAD_WINDOW_AREA_PARAM |
RBS_HVACLOAD_WALL_AREA_PARAM |
RBS_HVACLOAD_ROOF_AREA_PARAM |
RBS_ENERGY_ANALYSIS_VIEW_COORD_AXIS_MODE |
RBS_ENERGY_ANALYSIS_VIEW_RBE_MODE |
RBS_ENERGY_ANALYSIS_VIEW_SHADING_SURFACES_MODE |
RBS_ENERGY_ANALYSIS_VIEW_TRANSPARENT_MODE |
RBS_ENERGY_ANALYSIS_VIEW_SURFACES_MODE |
RBS_ENERGY_ANALYSIS_VIEW_INNER_SHELL_MODE |
RBS_ENERGY_ANALYSIS_VIEW_OUTER_SHELL_MODE |
RBS_ENERGY_ANALYSIS_VIEW_BUILDING_SHELL_MODE |
RBS_LINING_THICKNESS_FOR_DUCT |
RBS_INSULATION_THICKNESS_FOR_PIPE |
RBS_INSULATION_THICKNESS_FOR_DUCT |
BUILDING_UNOCCUPIED_COOLING_SET_POINT_PARAM |
BUILDING_CLOSING_TIME_PARAM |
BUILDING_OPENING_TIME_PARAM |
SPACE_PEOPLE_ACTIVITY_LEVEL_PARAM |
SPACE_ELEC_EQUIPMENT_RADIANT_PERCENTAGE_PARAM |
SPACE_CONSTRUCTION_WEIGHT_PARAM |
SPACE_POWER_SCHEDULE_PARAM |
SPACE_LIGHTING_SCHEDULE_PARAM |
SPACE_OCCUPANCY_SCHEDULE_PARAM |
SPACE_INFILTRATION_PARAM |
SPACE_CARPETING_PARAM |
SPACE_LIGHTING_TYPE_PARAM |
ZONE_AIR_VOLUME_CALCULATION_TYPE_PARAM |
ZONE_COIL_BYPASS_PERCENTAGE_PARAM |
ZONE_CALCULATED_AREA_PER_COOLING_LOAD_PARAM |
ZONE_CALCULATED_AREA_PER_HEATING_LOAD_PARAM |
ZONE_USE_AIR_CHANGES_PER_HOUR_PARAM |
ZONE_USE_OUTSIDE_AIR_PER_AREA_PARAM |
ZONE_USE_OUTSIDE_AIR_PER_PERSON_PARAM |
ZONE_USE_DEHUMIDIFICATION_SETPOINT_PARAM |
ZONE_USE_HUMIDIFICATION_SETPOINT_PARAM |
ZONE_OUTDOOR_AIR_INFORMATION_PARAM |
ZONE_COOLING_INFORMATION_PARAM |
ZONE_HEATING_INFORMATION_PARAM |
RBS_ENERGY_ANALYSIS_SLIVER_SPACE_TOLERANCE |
ZONE_AREA_GROSS |
ZONE_VOLUME_GROSS |
SPACE_IS_PLENUM |
SPACE_IS_OCCUPIABLE |
SPACE_ASSOC_ROOM_NUMBER |
SPACE_ASSOC_ROOM_NAME |
ZONE_PHASE |
ZONE_PHASE_ID |
RBS_ENERGY_ANALYSIS_PROJECT_PHASE_PARAM |
ROOM_CALCULATED_SUPPLY_AIRFLOW_PER_AREA_PARAM |
ROOM_CALCULATED_COOLING_LOAD_PER_AREA_PARAM |
ROOM_CALCULATED_HEATING_LOAD_PER_AREA_PARAM |
ZONE_CALCULATED_SUPPLY_AIRFLOW_PER_AREA_PARAM |
ZONE_CALCULATED_COOLING_LOAD_PER_AREA_PARAM |
ZONE_CALCULATED_HEATING_LOAD_PER_AREA_PARAM |
ZONE_LEVEL_ID |
ZONE_OA_RATE_PER_ACH_PARAM |
ZONE_OUTSIDE_AIR_PER_AREA_PARAM |
ZONE_OUTSIDE_AIR_PER_PERSON_PARAM |
ZONE_DEHUMIDIFICATION_SET_POINT_PARAM |
ZONE_HUMIDIFICATION_SET_POINT_PARAM |
ZONE_COOLING_AIR_TEMPERATURE_PARAM |
ZONE_HEATING_AIR_TEMPERATURE_PARAM |
ZONE_COOLING_SET_POINT_PARAM |
ZONE_HEATING_SET_POINT_PARAM |
ZONE_CALCULATED_SUPPLY_AIRFLOW_PARAM |
ZONE_CALCULATED_COOLING_LOAD_PARAM |
ZONE_CALCULATED_HEATING_LOAD_PARAM |
ZONE_SERVICE_TYPE_PARAM |
ZONE_VOLUME |
ZONE_PERIMETER |
ZONE_AREA |
ZONE_NAME |
RBS_PROJECT_CONSTRUCTION_TYPE_FLOOR_PARAM |
RBS_CONSTRUCTION_TYPE_FLOOR_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_SHADINGFACTOR_PARAM |
RBS_CONSTRUCTION_TYPE_SHADINGFACTOR_PARAM |
RBS_ENERGY_ANALYSIS_SHADING_SURFACES_PARAM |
RBS_ENERGY_ANALYSIS_GROUND_PLANE_PARAM |
RBS_ENERGY_ANALYSIS_SURFACE_ORIGIN_Z |
RBS_ENERGY_ANALYSIS_SURFACE_ORIGIN_Y |
RBS_ENERGY_ANALYSIS_SURFACE_ORIGIN_X |
RBS_ENERGY_ANALYSIS_SURFACE_AZIMUTH |
RBS_ENERGY_ANALYSIS_SURFACE_TILT |
RBS_ENERGY_ANALYSIS_SURFACE_CADOBJECTID |
RBS_ENERGY_ANALYSIS_SURFACE_ADJACENT_SPACE_ID2 |
RBS_ENERGY_ANALYSIS_SURFACE_ADJACENT_SPACE_ID1 |
ROOM_EDIT_ELECTRICAL_LOADS_PARAM |
ROOM_EDIT_PEOPLE_LOADS_PARAM |
RBS_PROJECT_LOCATION_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_ROOFLIGHT_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_INTERNAL_WINDOW_PARAM |
REBAR_SYSTEM_SPACING_BOTTOM_DIR_1 |
REBAR_SYSTEM_SPACING_TOP_DIR_2 |
REBAR_SYSTEM_SPACING_TOP_DIR_1 |
REBAR_SYSTEM_NUMBER_OF_LINES_BOTTOM_DIR_2 |
REBAR_SYSTEM_NUMBER_OF_LINES_BOTTOM_DIR_1 |
REBAR_SYSTEM_NUMBER_OF_LINES_TOP_DIR_2 |
REBAR_SYSTEM_NUMBER_OF_LINES_TOP_DIR_1 |
REBAR_SYSTEM_HOOK_TYPE_BOTTOM_DIR_2 |
REBAR_SYSTEM_HOOK_TYPE_BOTTOM_DIR_1 |
REBAR_SYSTEM_HOOK_TYPE_TOP_DIR_2 |
REBAR_SYSTEM_HOOK_TYPE_TOP_DIR_1 |
REBAR_SYSTEM_HOOK_ORIENT_BOTTOM_DIR_2 |
REBAR_SYSTEM_HOOK_ORIENT_BOTTOM_DIR_1 |
REBAR_SYSTEM_HOOK_ORIENT_TOP_DIR_2 |
REBAR_SYSTEM_HOOK_ORIENT_TOP_DIR_1 |
REBAR_SYSTEM_BAR_TYPE_BOTTOM_DIR_2 |
REBAR_SYSTEM_BAR_TYPE_BOTTOM_DIR_1 |
REBAR_SYSTEM_BAR_TYPE_TOP_DIR_2 |
REBAR_SYSTEM_BAR_TYPE_TOP_DIR_1 |
REBAR_SYSTEM_ACTIVE_BOTTOM_DIR_2 |
REBAR_SYSTEM_ACTIVE_BOTTOM_DIR_1 |
REBAR_SYSTEM_ACTIVE_TOP_DIR_2 |
REBAR_SYSTEM_ACTIVE_TOP_DIR_1 |
REBAR_SYSTEM_SPANHOOK_TOP_DIR_2 |
REBAR_SYSTEM_SPANHOOK_BOTTOM_DIR_2 |
REBAR_SYSTEM_SPANHOOK_RIGHT_DIR_1 |
REBAR_SYSTEM_SPANHOOK_LEFT_DIR_1 |
REBAR_SYSTEM_SPANACTIVE_DIR_2 |
REBAR_SYSTEM_SPANACTIVE_DIR_1 |
REBAR_SYSTEM_ADDL_BOTTOM_OFFSET |
REBAR_SYSTEM_ADDL_TOP_OFFSET |
REBAR_SYSTEM_TOP_MINOR_MATCHES_BOTTOM_MINOR |
REBAR_SYSTEM_TOP_MAJOR_MATCHES_BOTTOM_MAJOR |
REBAR_SYSTEM_BOTTOM_MAJOR_MATCHES_BOTTOM_MINOR |
REBAR_SYSTEM_TOP_MAJOR_MATCHES_TOP_MINOR |
REBAR_SYSTEM_LAYER_SUMMARY_DIR_2_NO_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_DIR_2_WITH_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_DIR_1_NO_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_DIR_1_WITH_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_BOTTOM_DIR_2_NO_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_BOTTOM_DIR_2_WITH_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_BOTTOM_DIR_1_NO_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_BOTTOM_DIR_1_WITH_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_TOP_DIR_2_NO_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_TOP_DIR_2_WITH_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_TOP_DIR_1_NO_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_TOP_DIR_1_WITH_SPACING |
REBAR_SYSTEM_COVER_BOTTOM |
REBAR_SYSTEM_COVER_TOP |
REBAR_SYSTEM_OVERRIDE |
REBAR_SYSTEM_LAYER_SUMMARY_NO_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_WITH_SPACING |
REBAR_SYSTEM_LAYOUT_RULE |
REBAR_SYSTEM_COVER_SIDE |
REBAR_INSTANCE_BEND_DIAMETER |
REBAR_INSTANCE_BAR_DIAMETER |
REBAR_SHAPE_END_HOOK_OFFSET |
REBAR_SHAPE_END_HOOK_LENGTH |
REBAR_SHAPE_START_HOOK_OFFSET |
REBAR_SHAPE_START_HOOK_LENGTH |
REBAR_ELEM_SCHEDULE_MARK |
REBAR_ELEM_HOOK_STYLE |
REBAR_ELEM_SHAPE |
REBAR_SHAPE_HOOK_END_TYPE |
REBAR_SHAPE_HOOK_START_TYPE |
REBAR_SHAPE_HOOK_STYLE |
REBAR_BAR_ALLOWED_BAR_TYPES |
REBAR_BAR_MAXIMUM_BEND_RADIUS |
REBAR_BAR_STIRRUP_BEND_DIAMETER |
REBAR_BAR_HOOK_LENGTHS |
REBAR_HOOK_STYLE |
REBAR_ELEM_LENGTH |
REBAR_SHAPE |
REBAR_ELEMENT_VISIBILITY |
REBAR_ELEM_BAR_SPACING |
REBAR_ELEM_QUANTITY_OF_BARS |
REBAR_ELEM_LAYOUT_RULE |
REBAR_STANDARD_BEND_DIAMETER |
REBAR_ELEM_HOOK_END_ORIENT |
REBAR_ELEM_HOOK_END_TYPE |
REBAR_ELEM_HOOK_START_ORIENT |
REBAR_ELEM_HOOK_START_TYPE |
REBAR_ELEM_TOTAL_LENGTH |
REBAR_HOOK_LINE_LEN_FACTOR |
REBAR_HOOK_ANGLE |
REBAR_BAR_STYLE |
REBAR_BAR_BEND_RADIUS |
REBAR_BAR_DIAMETER |
CWP_COPY_ROOF_INSERTS |
CWP_COPY_FLOOR_INSERTS |
CWP_COPY_WALL_INSERTS |
CWP_LINKED_ROOM_PARAMS |
CWP_LINKED_ROOM_PHASES |
CWP_ORIG_Z |
CWP_ORIG_Y |
CWP_ORIG_X |
CWP_REUSE_GRIDS_SAME_NAME |
CWP_REUSE_LEVELS_SAME_NAME |
CWP_SPLIT_COLUMNS_AT_LEVELS |
CWP_REUSE_EXISTING_GRIDS |
CWP_REUSE_EXISTING_LEVELS |
CWP_LEVEL_OFFSET |
CWP_ADD_LEVEL_SUFFIX |
CWP_ADD_LEVEL_PREFIX |
CWP_ADD_GRID_SUFFIX |
CWP_ADD_GRID_PREFIX |
CWP_DONT_COPY_TYPE |
CWP_COPY_ORIGINAL_TYPE |
LOAD_USAGE_NAME |
LOAD_COMBINATION_STATE |
LOAD_COMBINATION_TYPE |
LOAD_COMBINATION_FACTOR |
LOAD_COMBINATION_NAME |
LOAD_NATURE_NAME |
LOAD_CASE_CATEGORY |
LOAD_CASE_NATURE |
LOAD_CASE_NUMBER |
LOAD_CASE_NAME |
LOAD_ATTR_AREA_FORCE_SCALE_FACTOR |
LOAD_ATTR_LINEAR_FORCE_SCALE_FACTOR |
LOAD_ARROW_SEPARATION |
LOAD_ATTR_MOMENT_SCALE_FACTOR |
LOAD_ATTR_MOMENT_ARROW_LINE |
LOAD_ATTR_MOMENT_ARROW_ARC |
LOAD_ATTR_FORCE_SCALE_FACTOR |
LOAD_ATTR_FORCE_ARROW_TYPE |
LOAD_DESCRIPTION |
LOAD_COMMENTS |
LOAD_CASE_NATURE_TEXT |
LOAD_COMMENT_TEXT |
LOAD_ALL_NON_0_LOADS |
LOAD_AREA_AREA |
LOAD_AREA_FORCE_FZ3 |
LOAD_AREA_FORCE_FY3 |
LOAD_AREA_FORCE_FX3 |
LOAD_AREA_FORCE_FZ2 |
LOAD_AREA_FORCE_FY2 |
LOAD_AREA_FORCE_FX2 |
LOAD_AREA_FORCE_FZ1 |
LOAD_AREA_FORCE_FY1 |
LOAD_AREA_FORCE_FX1 |
LOAD_LINEAR_LENGTH |
LOAD_IS_PROJECTED |
LOAD_MOMENT_MZ2 |
LOAD_MOMENT_MY2 |
LOAD_MOMENT_MX2 |
LOAD_MOMENT_MZ1 |
LOAD_MOMENT_MY1 |
LOAD_MOMENT_MX1 |
LOAD_LINEAR_FORCE_FZ2 |
LOAD_LINEAR_FORCE_FY2 |
LOAD_LINEAR_FORCE_FX2 |
LOAD_LINEAR_FORCE_FZ1 |
LOAD_LINEAR_FORCE_FY1 |
LOAD_LINEAR_FORCE_FX1 |
LOAD_MOMENT_MZ |
LOAD_MOMENT_MY |
LOAD_MOMENT_MX |
LOAD_FORCE_FZ |
LOAD_FORCE_FY |
LOAD_FORCE_FX |
LOAD_IS_REACTION |
LOAD_IS_CREATED_BY_API |
LOAD_IS_UNIFORM |
LOAD_USE_LOCAL_COORDINATE_SYSTEM_HOSTED |
LOAD_USE_LOCAL_COORDINATE_SYSTEM |
LOAD_CASE_ID |
SPAN_DIR_SYM_PARAM_RIGHT |
SPAN_DIR_SYM_PARAM_LEFT |
SPAN_DIR_SYM_PARAM_BOTTOM |
SPAN_DIR_SYM_PARAM_TOP |
SPAN_DIR_INST_PARAM_ANGLE |
CLEAR_COVER |
CLEAR_COVER_BOTTOM |
CLEAR_COVER_TOP |
CLEAR_COVER_OTHER |
CLEAR_COVER_INTERIOR |
CLEAR_COVER_EXTERIOR |
COVER_TYPE_LENGTH |
COVER_TYPE_NAME |
JOIST_SYSTEM_CLEAR_SPACING_PARAM |
JOIST_SYSTEM_FIXED_SPACING_PARAM |
JOIST_SYSTEM_MAXIMUM_SPACING_PARAM |
CURVE_EDGE_OFFSET |
TRUSS_TYPE_EDIT |
BEAM_SYSTEM_3D_PARAM |
TRUSS_BEAM_TYPE_FOR_TRAN_PAR |
TRUSS_BEAM_TYPE_FOR_DIAG_PAR |
TRUSS_BEAM_TYPE_FOR_VERT_PAR |
TRUSS_BEAM_TYPE_FOR_BOT_CHORD_PAR |
TRUSS_BEAM_TYPE_FOR_TOP_CHORD_PAR |
TRUSS_BEAM_TYPE_FOR_CHORDS_PAR |
TRUSS_HEIGHT_PARAM |
JOIST_SYSTEM_NEW_BEAM_TYPE_NO_FAM_NAME_PARAM |
BEAM_SYSTEM_TAG_INST_PARAM_ANGLE |
BEAM_SYSTEM_TAG_PARAM_RIGHT |
BEAM_SYSTEM_TAG_PARAM_LEFT |
JOIST_SYSTEM_NUM_BEAMS_SAME_TYPE |
BEAM_H_JUSTIFICATION |
BEAM_V_JUSTIFICATION |
CURVE_SUPPORT_OFFSET |
JOIST_SYSTEM_NEW_BEAM_TYPE_PARAM |
JOIST_SYSTEM_LAYOUT_RULE_PARAM |
JOIST_SYSTEM_JUSTIFICATION_PARAM |
JOIST_SYSTEM_SPACING_PARAM |
JOIST_SYSTEM_NUMBER_OF_LINES_PARAM |
RBS_DUCT_FLOW_PARAM |
CURTAINGRID_BELT_RATIO_V |
CURTAINGRID_BELT_RATIO_U |
CURTAINGRID_USE_CURVE_DIST_V |
CURTAINGRID_USE_CURVE_DIST_U |
CURTAINGRID_ADJUST_BORDER_V |
CURTAINGRID_ADJUST_BORDER_U |
CURTAINGRID_BELT_V |
CURTAINGRID_BELT_U |
CURTAINGRID_ORIGIN_V |
CURTAINGRID_ORIGIN_U |
CURTAINGRID_ANGLE_V |
CURTAINGRID_ANGLE_U |
SPACING_NUM_DIVISIONS_V |
SPACING_NUM_DIVISIONS_U |
SPACING_JUSTIFICATION_V |
SPACING_JUSTIFICATION_U |
SPACING_LENGTH_V |
SPACING_LENGTH_U |
SPACING_LAYOUT_V |
SPACING_LAYOUT_U |
CURTAINGRID_BELT_RATIO_2 |
CURTAINGRID_BELT_RATIO_1 |
CURTAIN_VERSION_PARAM |
PADDING_LENGTH |
ELEM_ARRAY_ROLL |
ELEM_ARRAY_PITCH |
ELEM_ARRAY_ROTATION |
ELEM_ARRAY_Z_OFFSET |
ELEM_ARRAY_Y_OFFSET |
ELEM_ARRAY_X_OFFSET |
ELEM_ARRAY_ROLL_PROG |
ELEM_ARRAY_PITCH_PROG |
ELEM_ARRAY_ROTATION_PROG |
ELEM_ARRAY_ALWAYS_VERTICAL |
ELEM_ARRAY_ANCHORS_VISIBLE |
CURTAINGRID_USE_CURVE_DIST |
SPACING_JUSTIFICATION |
SPACING_NUM_DIVISIONS |
SPACING_LENGTH |
SPACING_LAYOUT |
CURTAINGRID_USE_CURVE_DIST_2 |
CURTAINGRID_USE_CURVE_DIST_1 |
CURTAINGRID_ADJUST_BORDER_2 |
CURTAINGRID_ADJUST_BORDER_1 |
CURTAINGRID_BELT_2 |
CURTAINGRID_BELT_1 |
CURTAINGRID_ORIGIN_2 |
CURTAINGRID_ORIGIN_1 |
CURTAINGRID_ANGLE_2 |
CURTAINGRID_ANGLE_1 |
SPACING_NUM_DIVISIONS_2 |
SPACING_NUM_DIVISIONS_1 |
SPACING_JUSTIFICATION_2 |
SPACING_JUSTIFICATION_1 |
SPACING_LENGTH_2 |
SPACING_LENGTH_1 |
SPACING_LAYOUT_2 |
SPACING_LAYOUT_1 |
CURTAINGRID_USE_CURVE_DIST_HORIZ |
CURTAINGRID_USE_CURVE_DIST_VERT |
CURTAINGRID_ADJUST_BORDER_HORIZ |
CURTAINGRID_ADJUST_BORDER_VERT |
CURTAINGRID_BELT_HORIZ |
CURTAINGRID_BELT_VERT |
CURTAINGRID_ORIGIN_HORIZ |
CURTAINGRID_ORIGIN_VERT |
CURTAINGRID_ANGLE_HORIZ |
CURTAINGRID_ANGLE_VERT |
GRIDLINE_SPEC_STATUS |
SPACING_NUM_DIVISIONS_HORIZ |
SPACING_NUM_DIVISIONS_VERT |
SPACING_JUSTIFICATION_HORIZ |
SPACING_JUSTIFICATION_VERT |
SPACING_LENGTH_HORIZ |
SPACING_LENGTH_VERT |
SPACING_LAYOUT_HORIZ |
SPACING_LAYOUT_VERT |
SCHEDULE_VISIBLE_DESIGN_OPTION_PARAM |
DESIGN_OPTION_ID |
DESIGN_OPTION_PARAM |
PLAN_REGION_VIEW_RANGE |
PLAN_REGION_TOP_CLIP_PLANE_OFFSET |
PLAN_REGION_BOTTOM_CLIP_PLANE_OFFSET |
PLAN_REGION_CUT_PLANE_OFFSET |
SKETCH_GRID_SPACING_PARAM |
HOSTFIN_PARAM_VOLUME_COMPUTED |
HOSTFIN_PARAM_AREA_COMPUTED |
HOSTFIN_PARAM_MATERIAL |
HOSTFIN_PARAM_THICKNESS |
HOSTFIN_PARAM_OFFSET |
JOIN_STRENGTH_ORDER |
FAMILY_USE_PRECUT_SHAPE |
WALL_SWEEP_DEFAULT_SETBACK_PARAM |
WALL_SWEEP_CUTS_WALL_PARAM |
WALL_SWEEP_CUT_BY_INSERTS_PARAM |
SLAB_EDGE_PROFILE_PARAM |
GUTTER_PROFILE_PARAM |
REVEAL_PROFILE_PARAM |
FAMILY_SHARED |
FAMILY_WORK_PLANE_BASED |
FAMILY_AUTOJOIN |
FAMILY_IS_PARAMETRIC |
FAMILY_KEEP_TEXT_READABLE |
WALL_BOTTOM_EXTENSION_DIST_PARAM |
WALL_TOP_EXTENSION_DIST_PARAM |
SWEEP_BASE_VERT_OFFSET |
SWEEP_BASE_ROTATION_ANGLE |
SWEEP_BASE_OFFSET |
SLAB_EDGE_MATERIAL_PARAM |
GUTTER_MATERIAL_PARAM |
FASCIA_MATERIAL_PARAM |
SWEEP_BASE_FLOOR_SUBCATEGORY_ID |
SWEEP_BASE_ROOF_SUBCATEGORY_ID |
FASCIA_PROFILE_PARAM |
DECAL_SUBCATEGORY_ID |
DECAL_HEIGHT_PIXELS |
DECAL_WIDTH_PIXELS |
DECAL_HEIGHT |
DECAL_WIDTH |
DECAL_LOCK_PROPORTIONS |
DECAL_ATTRIBUTES |
FAMILY_KEY_EXT_PARAM |
WALL_SWEEP_WALL_SUBCATEGORY_ID |
FAMILY_ALWAYS_VERTICAL |
FAMILY_ROTATE_WITH_COMPONENT |
HOST_VOLUME_COMPUTED |
HOST_AREA_COMPUTED |
WALL_SWEEP_WALL_OFFSET_PARAM |
CORNICE_MATERIAL_PARAM |
WALL_SWEEP_OFFSET_PARAM |
WALL_SWEEP_LEVEL_PARAM |
WALL_SWEEP_PROFILE_PARAM |
AREA_SCHEME_NAME |
AREA_SCHEME_ID |
AREA_TYPE_TEXT |
AREA_TYPE_NAME |
AREA_TYPE |
VIEW_AREA_SCHEME |
CONTOUR_LABELS_RELATIVE_BASE |
CONTOUR_LABELS_ELEV_BASE_TYPE |
PROPERTY_SEGMENT_SUBCATEGORY_ID |
PROPERTY_SEGMENT_L_R |
PROPERTY_SEGMENT_RADIUS |
PROPERTY_SEGMENT_E_W |
PROPERTY_SEGMENT_BEARING |
PROPERTY_SEGMENT_N_S |
PROPERTY_SEGMENT_DISTANCE |
PROPERTY_LENGTH_UNITS |
PROPERTY_AREA_UNITS |
VOLUME_NET |
PROJECTED_SURFACE_AREA |
CONTOUR_LABELS_LINEAR_UNITS |
CONTOUR_LABELS_PRIMARY_ONLY |
PROPERTY_SUBCATEGORY_ID |
PROPERTY_AREA_OPEN |
POCHE_DEPTH |
VOLUME_FILL |
VOLUME_CUT |
SURFACE_PERIMETER |
SURFACE_AREA |
PROPERTY_AREA |
BUILDINGPAD_HEIGHTABOVELEVEL_PARAM |
BUILDINGPAD_THICKNESS |
BOUNDARY_RADIUS |
BOUNDARY_INC_ANGLE |
CONTOUR_SUBCATEGORY_ID |
BOUNDARY_BEARING |
BOUNDARY_DISTANCE |
CONTOUR_ELEVATION_STEP |
CONTOUR_ELEVATION |
POINT_ELEVATION |
VOLUME_OF_INTEREST_NAME |
VIEWER_VOLUME_OF_INTEREST_3D |
VOLUME_OF_INTEREST_VIEWS_VISIBLE |
VIEWER_VOLUME_OF_INTEREST_CROP |
DATUM_VOLUME_OF_INTEREST |
ORIENT_BY_VIEW |
ROOM_PHASE |
ROOM_PHASE_ID |
PHASE_SEQUENCE_NUMBER |
PHASE_NAME |
VIEW_FAMILY |
ROOM_PHASE_NAME |
PRINT_SET |
VIEW_TYPE |
PHASE_DEMOLISHED_NAME |
PHASE_CREATED_NAME |
VIEW_PHASE_FILTER |
VIEW_PHASE |
PHASE_DEMOLISHED |
PHASE_CREATED |
LEVEL_DATA_MASS_TYPE_DESCRIPTION |
LEVEL_DATA_MASS_INSTANCE_COMMENTS |
LEVEL_DATA_MASS_TYPE_COMMENTS |
LEVEL_DATA_MASS_FAMILY_AND_TYPE_PARAM |
LEVEL_DATA_MASS_FAMILY_PARAM |
LEVEL_DATA_SPACE_USAGE |
LEVEL_DATA_OWNING_LEVEL |
LEVEL_DATA_MASS_TYPE_PARAM |
LEVEL_DATA_VOLUME |
LEVEL_DATA_SURFACE_AREA |
LEVEL_DATA_FLOOR_AREA |
LEVEL_DATA_FLOOR_PERIMETER |
MASS_FUNCTION |
MASS_GROSS_VOLUME |
MASS_GROSS_SURFACE_AREA |
MASS_FLOOR_AREA_LEVELS |
MASS_GROSS_AREA |
MASSING_DEFAULT_ROOF_TYPE |
MASSING_DEFAULT_WALL_TYPE |
MASSING_DEFAULT_FLOOR_TYPE |
MASSING_INTEGRATION_LEVEL |
PROJECT_REVISION_REVISION_ISSUED_BY |
PROJECT_REVISION_REVISION_ISSUED_TO |
PROJECT_REVISION_REVISION_DATE |
PROJECT_REVISION_REVISION_DESCRIPTION |
PROJECT_REVISION_REVISION_NUM |
PROJECT_REVISION_SEQUENCE_NUM |
REVISION_CLOUD_REVISION_ISSUED_BY |
REVISIONS_ARE_BY_SHEET |
REVISION_CLOUD_REVISION_ISSUED_TO |
REVISION_CLOUD_REVISION_DATE |
REVISION_CLOUD_REVISION_DESCRIPTION |
REVISION_CLOUD_REVISION_NUM |
REVISION_CLOUD_REVISION |
HELIX_PITCH |
HELIX_LENGTH |
CURVE_PATTERN_CLOUD |
REPEATING_DETAIL_ROTATION |
CURVE_PATTERN_REPEATING_DETAIL |
REPEATING_DETAIL_INSIDE |
REPEATING_DETAIL_ELEMENT |
REPEATING_DETAIL_LAYOUT |
REPEATING_DETAIL_SPACING |
REPEATING_DETAIL_NUMBER |
CURVE_PATTERN_INSULATION |
INSULATION_SCALE |
INSULATION_WIDTH |
VIEW_DETAIL_LEVEL |
DETAIL_LEVEL_PULLDOWN_IMPERIAL |
DETAIL_LEVEL_PULLDOWN_METRIC |
TAG_SELECT_END |
TAG_SELECT_START |
FURNITURE_THICKNESS |
FURNITURE_WIDTH |
FURNITURE_HEIGHT |
PLUMBING_FIXTURES_VENT_CONNECTION |
PLUMBING_FIXTURES_WASTE_CONNECTION |
PLUMBING_FIXTURES_CW_CONNECTION |
PLUMBING_FIXTURES_HW_CONNECTION |
PLUMBING_FIXTURES_TRAP |
PLUMBING_FIXTURES_DRAIN |
PLUMBING_FIXTURES_SUPPLY_PIPE |
PLUMBING_FIXTURES_SUPPLY_FITTING |
LIGHTING_FIXTURE_LIGHT_EMITTER |
LIGHTING_FIXTURE_DIMMER |
LIGHTING_FIXTURE_ON |
LIGHTING_FIXTURE_LAMP |
LIGHTING_FIXTURE_WATTAGE |
ELECTICAL_EQUIP_VOLTAGE |
ELECTICAL_EQUIP_WATTAGE |
CURTAIN_WALL_PANEL_HOST_ID |
CURTAIN_WALL_SYSPANEL_OFFSET |
CURTAIN_WALL_SYSPANEL_THICKNESS |
CURTAIN_WALL_PANELS_CONSTRUCTION_TYPE |
CURTAIN_WALL_PANELS_FINISH |
CURTAIN_WALL_PANELS_WIDTH |
CURTAIN_WALL_PANELS_HEIGHT |
CASEWORK_HEIGHT |
CASEWORK_DEPTH |
CASEWORK_WIDTH |
CASEWORK_FINISH |
CASEWORK_CONSTRUCTION_TYPE |
ALL_MODEL_SYSTEM |
ALL_MODEL_FAMILY_NAME |
ALL_MODEL_MODEL |
ALL_MODEL_MANUFACTURER |
ALL_MODEL_COST |
ALL_MODEL_INSTANCE_COMMENTS |
ALL_MODEL_TYPE_COMMENTS |
ALL_MODEL_URL |
ALL_MODEL_DESCRIPTION |
ALL_MODEL_TYPE_NAME |
ALL_MODEL_TYPE_MARK |
ALL_MODEL_MARK |
GENERIC_THICKNESS |
GENERIC_HEIGHT |
GENERIC_DEPTH |
GENERIC_WIDTH |
GENERIC_FINISH |
GENERIC_CONSTRUCTION_TYPE |
ELEMENT_LOCKED_PARAM |
STAIRS_RAILING_BALUSTER_IS_POST |
STAIRS_RAILING_CONNECTION |
STAIRS_RAILING_ANGLED_CONNECTION |
STAIRS_RAILING_TANGENT_CONNECTION |
STAIRS_RAILING_HEIGHT_SHIFT_VAL |
STAIRS_RAILING_HEIGHT_SHIFT_TYPE |
STAIRS_RAILING_RAIL_NAME |
STAIRS_RAILING_BALUSTER_PLACEMENT |
STAIRS_RAILING_BALUSTER_SLOPE_ANGLE |
STAIRS_RAILING_BALUSTER_BOTTOM_ANGLE |
STAIRS_RAILING_BALUSTER_TOP_ANGLE |
STAIRS_RAILING_BALUSTER_HEIGHT |
STAIRS_RAILING_HEIGHT_OFFSET |
STAIRS_RAILING_BASE_LEVEL_PARAM |
STAIRS_RAILING_BALUSTER_OFFSET |
STAIRS_RAILING_BALUSTER_FAMILY |
STAIRS_RAILING_RAIL_OFFSET |
STAIRS_RAILING_RAIL_HEIGHT |
STAIRS_RAILING_RAIL_STRUCTURE |
STAIRS_RAILING_SHAPE |
STAIRS_RAILING_BALUSTER_TREAD_OFFSET |
STAIRS_RAILING_BALUSTER_LENGTH |
STAIRS_RAILING_BALUSTER_WIDTH |
STAIRS_RAILING_BALUSTERS_PER_TREAD |
STAIRS_RAILING_BALUSTER_SPACING |
STAIRS_RAILING_BALUSTER_SPACING_TYPE |
STAIRS_RAILING_BOTTOM_EXT |
STAIRS_RAILING_TOP_EXT |
STAIRS_RAILING_BALUSTER_SHAPE |
STAIRS_RAILING_THICKNESS |
STAIRS_RAILING_WIDTH |
STAIRS_RAILING_HEIGHT |
STAIRS_RAILING_BALUSTER_ATTACH_PT |
STAIRS_RAILING_NUM_BALUSTERS |
PARAMS_TITLE_LAST |
SWEPTBLEND_PARAMS_TITLE |
ELEM_ARRAY_PARAMS_TITLE |
AREA_LOAD_PARAMS_TITLE |
REBAR_PARAMS_TITLE |
HOSTFIN_PARAMS_TITLE |
BUILDINGPAD_PARAMS_TITLE |
STAIRS_RAILING_PARAMS_TITLE |
RAMP_PARAMS_TITLE |
RAILING_PARAMS_TITLE |
OPENING_PARAMS_TITLE |
REVOLUTION_PARAMS_TITLE |
BLEND_PARAMS_TITLE |
SWEEP_PARAMS_TITLE |
EXTRUSION_PARAMS_TITLE |
REGION_PARAMS_TITLE |
WALL_PARAMS_TITLE |
CEILING_PARAMS_TITLE |
FLOOR_PARAMS_TITLE |
ROOF_PARAMS_TITLE |
STAIRS_PARAMS_TITLE |
CURVE_PARAMS_TITLE |
DEFAULT_PARAMS_TITLE |
PARAMS_TITLE_FIRST |
RAMP_ATTR_TEXT_SIZE |
RAMP_ATTR_TEXT_FONT |
RAMP_ATTR_MATERIAL |
RAMP_ATTR_RIGHT_BALUSTER_ATTACH_PT |
RAMP_ATTR_LEFT_BALUSTER_ATTACH_PT |
RAMP_ATTR_SHAPE |
RAMP_ATTR_THICKNESS |
RAMP_MAX_RUN_LENGTH |
RAMP_SLOPE |
RAMP_ATTR_MIN_INV_SLOPE |
RAMP_ATTR_WIDTH |
PLAN_VIEW_VIEW_DIR |
POCHE_MAT_ID |
ELEVATN_TAG |
CALLOUT_TAG |
SECTION_TAG |
CALLOUT_SYNCRONIZE_VIEW_DEPTH |
CALLOUT_SYNCRONIZE_BOUND_OFFSET_FAR |
LEADER_LINE_PEN |
CALLOUT_CORNER_SHEET_RADIUS |
CALLOUT_ATTR_HEAD_TAG |
SYMBOL_USER_PARAM_LAST |
SYMBOL_USER_PARAM_FIRST |
ELEMENT_USER_PARAM_LAST |
ELEMENT_USER_PARAM_FIRST |
GRID_BUBBLE_END_2 |
GRID_BUBBLE_END_1 |
DATUM_BUBBLE_LOCATION_IN_ELEV |
DATUM_BUBBLE_END_1 |
DATUM_BUBBLE_END_2 |
DATUM_TEXT |
ELLIPSE_FOCUS_MRK_VISIBLE |
UNBOUND_CURVE_SPLIT_PARAM |
ARC_CURVE_CNTR_MRK_SZ_PARAM |
ARC_CURVE_CNTR_MRK_VISIBLE |
ARC_CURVE_CNTR_MRK_VISIBLE_OBSOLETE |
ARC_WALL_CNTR_MRK_SZ_PARAM |
ARC_WALL_CNTR_MRK_VISIBLE |
REF_TABLE_PARAM_NAME |
REF_TABLE_ELEM_NAME |
RBS_PANEL_SCHEDULE_SHEET_APPEARANCE_INST_PARAM |
RBS_PANEL_SCHEDULE_SHEET_APPEARANCE_PARAM |
SCHEDULE_EMBEDDED_PARAM |
SCHEDULE_SHEET_APPEARANCE_PARAM |
SCHEDULE_FORMAT_PARAM |
SCHEDULE_GROUP_PARAM |
SCHEDULE_SORT_PARAM |
SCHEDULE_FILTER_PARAM |
TILE_PATTERN_FAMREF_COMPONENT_EXTENTS |
TILE_PATTERN_GRID_CELLS_Y |
TILE_PATTERN_GRID_CELLS_X |
TILE_PATTERN_GRID_UNIT_Y |
TILE_PATTERN_GRID_UNIT_X |
POINT_ELEMENT_SHOW_NORMAL_PLANE_ONLY |
LEVEL_GROUND_PLANE |
LEVEL_IS_GROUND_PLANE |
BASEPOINT_ANGLETON_PARAM |
BASEPOINT_ELEVATION_PARAM |
BASEPOINT_EASTWEST_PARAM |
BASEPOINT_NORTHSOUTH_PARAM |
ROOM_PLENUM_LIGHTING_PARAM |
SLANTED_COLUMN_GEOMETRY_TREATMENT_BASE |
SLANTED_COLUMN_GEOMETRY_TREATMENT_TOP |
SC_BOTTOM_LEVEL_ID_RECORD |
SC_TOP_LEVEL_ID_RECORD |
SC_BOTTOM_LEVEL_OFFSET_RECORD |
SC_TOP_LEVEL_OFFSET_RECORD |
STRUCTURAL_ATTACHMENT_TOP_REFERENCEDEND |
STRUCTURAL_ATTACHMENT_TOP_RATIO |
STRUCTURAL_ATTACHMENT_TOP_DISTANCE |
STRUCTURAL_ATTACHMENT_TOP_TYPE |
STRUCTURAL_ATTACHMENT_BASE_REFERENCEDEND |
STRUCTURAL_ATTACHMENT_BASE_RATIO |
STRUCTURAL_ATTACHMENT_BASE_DISTANCE |
STRUCTURAL_ATTACHMENT_BASE_TYPE |
SLANTED_COLUMN_LEVEL_OFFSET_TOP |
SLANTED_COLUMN_LEVEL_OFFSET_BASE |
INSTANCE_MOVE_BASE_WITH_GRIDS |
INSTANCE_MOVE_TOP_WITH_GRIDS |
SLANTED_COLUMN_TYPE_PARAM |
VIEW_SLANTED_COLUMN_SYMBOL_OFFSET |
POINT_ELEMENT_HOSTED_ON_FACE_V_PARAM |
POINT_ELEMENT_HOSTED_ON_FACE_U_PARAM |
LOCKED_END_OFFSET |
LOCKED_START_OFFSET |
LOCKED_BASE_OFFSET |
LOCKED_TOP_OFFSET |
RBS_PROJECT_REPORTTYPE_PARAM |
RBS_BUILDING_CONSTRUCTIONCLASS |
CONNECTOR_UTILITY_PARAM |
FAMILY_PLACE_BY_REFERENCE |
POINT_NAME_PARAM |
POINT_IS_REF_PARAM |
SPOT_DIM_STYLE_SLOPE_UNITS |
POINT_ELEMENT_DRIVING |
SPOT_SLOPE_LEADER_LENGTH |
SPOT_SLOPE_SUFFIX |
SPOT_SLOPE_PREFIX |
POINT_VISIBILITY_PARAM |
POINT_ELEMENT_SHOW_PLANES |
CURVE_IS_REFERENCE_LINE |
POINT_ELEMENT_HOSTED_PARAM |
POINT_ELEMENT_DRIVEN |
POINT_ELEMENT_OFFSET |
FBX_LIGHT_PHOTOMETRIC_FILE_CACHE |
FBX_LIGHT_PHOTOMETRICS_FAM |
FAMILY_CURVE_ATTACHMENT_PROPORTION |
FBX_LIGHT_SOURCE_LENGTH |
FBX_LIGHT_SOURCE_DIAMETER |
FBX_LIGHT_EMIT_CIRCLE_DIAMETER |
FBX_LIGHT_EMIT_RECTANGLE_LENGTH |
FBX_LIGHT_EMIT_RECTANGLE_WIDTH |
FBX_LIGHT_EMIT_LINE_LENGTH |
FBX_LIGHT_Z_ROTATION_OFFSET_OOPS |
FBX_LIGHT_Y_ROTATION_OFFSET_OOPS |
FBX_LIGHT_X_ROTATION_OFFSET_OOPS |
FBX_LIGHT_PHOTOMETRIC_FILE_OOPS |
FBX_LIGHT_PHOTOMETRIC_FILE |
FBX_LIGHT_SPOT_TILT_ANGLE_OOPS |
FBX_LIGHT_SPOT_FIELD_ANGLE_OOPS |
RBS_PROJECT_CONSTRUCTION_TYPE_EXTERNAL_WINDOW_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_PARTITION_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_DOOR_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_CEILING_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_ROOF_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_SOLID_GROUND_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_EXTERNAL_WALL_PARAM |
RBS_CONSTRUCTION_TYPE_ROOFLIGHT_PARAM |
RBS_CONSTRUCTION_TYPE_INTERNAL_WINDOW_PARAM |
RBS_CONSTRUCTION_TYPE_EXTERNAL_WINDOW_PARAM |
RBS_CONSTRUCTION_TYPE_PARTITION_PARAM |
RBS_CONSTRUCTION_TYPE_DOOR_PARAM |
RBS_CONSTRUCTION_TYPE_CEILING_PARAM |
RBS_CONSTRUCTION_TYPE_ROOF_PARAM |
RBS_CONSTRUCTION_TYPE_SOLID_GROUND_PARAM |
RBS_CONSTRUCTION_TYPE_EXTERNAL_WALL_PARAM |
ROOM_ACTUAL_LIGHTING_LOAD_PER_AREA_PARAM |
ROOM_ACTUAL_POWER_LOAD_PER_AREA_PARAM |
ROOM_BASE_HEAT_LOAD_ON_PARAM |
ROOM_LIGHTING_LOAD_UNITS_PARAM |
ROOM_POWER_LOAD_UNITS_PARAM |
ROOM_DESIGN_COOLING_LOAD_PARAM |
ROOM_CALCULATED_COOLING_LOAD_PARAM |
ROOM_DESIGN_HEATING_LOAD_PARAM |
ROOM_CALCULATED_HEATING_LOAD_PARAM |
ROOM_BASE_RETURN_AIRFLOW_ON_PARAM |
ROOM_CONSTRUCTION_SET_PARAM |
ROOM_SERVICE_TYPE_PARAM_OBSOLETE |
RBS_CONSTRUCTION_SET_PARAM |
RBS_SERVICE_TYPE_PARAM |
RBS_GBXML_SURFACE_AREA |
RBS_GBXML_SURFACE_TYPE |
RBS_GBXML_SURFACE_NAME |
FAMILY_ELECTRICAL_MAINTAIN_ANNOTATION_ORIENTATION |
RBS_FAMILY_CONTENT_ANNOTATION_DISPLAY |
RBS_ELECTRICAL_DATA |
RBS_CALCULATED_SIZE |
ROOM_PEOPLE_SENSIBLE_HEAT_GAIN_PER_PERSON_PARAM |
RBS_IS_CUSTOM_FITTING |
RBS_CONNECTOR_OFFSET_OBSOLETE |
RBS_LOOKUP_TABLE_NAME |
GBXML_PREDEF_CONSTRUCTION_SLABS_ON_GRADE_PARAM |
GBXML_PREDEF_CONSTRUCTION_UNDERGROUND_WALLS_PARAM |
GBXML_PREDEF_CONSTRUCTION_SHADE_WALLS_PARAM |
RBS_COLOR_FILL_CONTOUR_AT_SIZE_PARAM |
RBS_COLOR_FILL_WIDTH_PARAM |
ROOM_DESIGN_LIGHTING_LOAD_PARAM |
ROOM_DESIGN_POWER_LOAD_PARAM |
ROOM_ACTUAL_OTHER_LOAD_PARAM |
ROOM_ACTUAL_MECHANICAL_LOAD_PARAM |
ROOM_ACTUAL_LIGHTING_LOAD_PARAM |
ROOM_ACTUAL_POWER_LOAD_PARAM |
ROOM_BASE_LIGHTING_LOAD_ON_PARAM |
ROOM_BASE_POWER_LOAD_ON_PARAM |
ROOM_DESIGN_OTHER_LOAD_PER_AREA_PARAM |
ROOM_DESIGN_MECHANICAL_LOAD_PER_AREA_PARAM |
ROOM_DESIGN_LIGHTING_LOAD_PER_AREA_PARAM |
ROOM_DESIGN_POWER_LOAD_PER_AREA_PARAM |
RBS_ROOM_COEFFICIENT_UTILIZATION |
RBS_FAMILY_CONTENT_TAKEOFF_FIXED_LENGTH |
RBS_FAMILY_CONTENT_TAKEOFF_PROJLENGTH |
RBS_FAMILY_CONTENT_TAKEOFF_LENGTH |
RBS_FAMILY_CONTENT_OFFSET_HEIGHT |
RBS_FAMILY_CONTENT_OFFSET_WIDTH |
FAMILY_TABLE_OBSOLETE |
FAMILY_INLINE_FITTING_CALCULATION_MODE_OBSOLETE |
FAMILY_CONTENT_PART_TYPE |
GBXML_PREDEF_CONSTRUCTION_OPERABLE_WINDOWS_PARAM |
GBXML_PREDEF_CONSTRUCTION_NON_SLIDING_DOOR_PARAM |
GBXML_PREDEF_CONSTRUCTION_UNDERGROUND_SLABS_PARAM |
GBXML_PREDEF_CONSTRUCTION_INTERIOR_FLOORS_PARAM |
GBXML_PREDEF_CONSTRUCTION_INTERIOR_WALLS_PARAM |
GBXML_PREDEF_CONSTRUCTION_EXTERIOR_WALLS_PARAM |
GBXML_PREDEF_CONSTRUCTION_CEILINGS_PARAM |
GBXML_PREDEF_CONSTRUCTION_ROOFS_PARAM |
GBXML_EDIT_DATA_PARAM |
ROOM_ACTUAL_EXHAUST_AIRFLOW_PARAM |
ROOM_ACTUAL_RETURN_AIRFLOW_PARAM |
ROOM_ACTUAL_SUPPLY_AIRFLOW_PARAM |
ROOM_RETURN_EQUAL_SUPPLY_AIRFLOW_PARAM_OBSOLETE |
ROOM_TEMPERATURE_PARAM_OBSOLETE |
ROOM_DESIGN_COOLING_TEMP_PARAM_OBSOLETE |
ROOM_DESIGN_HEATING_TEMP_PARAM_OBSOLETE |
ROOM_PEOPLE_LATENT_HEAT_GAIN_PER_PERSON_PARAM |
ROOM_PEOPLE_TOTAL_HEAT_GAIN_PER_PERSON_PARAM |
ROOM_LIGHTING_POWER_PER_AREA_PARAM_OBSOLETE |
ROOM_EQUIPMENT_POWER_PER_AREA_PARAM_OBSOLETE |
ROOM_USE_DATA_IN_ENERGY_ANALYSIS_PARAM_OBSOLETE |
ROOM_OUTSIDE_AIR_PER_PERSON_PARAM_OBSOLETE |
ROOM_OUTSIDE_AIR_PER_AREA_PARAM_OBSOLETE |
ROOM_AIR_CHANGES_PARAM_OBSOLETE |
ROOM_CALCULATED_EXHAUST_AIRFLOW_PARAM |
ROOM_CALCULATED_SUPPLY_AIRFLOW_PARAM |
ROOM_BASE_SUPPLY_AIRFLOW_ON_PARAM_OBSOLETE |
ROOM_DESIGN_EXHAUST_AIRFLOW_PARAM |
ROOM_DESIGN_RETURN_AIRFLOW_PARAM |
ROOM_DESIGN_SUPPLY_AIRFLOW_PARAM |
ROOM_AREA_PER_PERSON_PARAM |
ROOM_NUMBER_OF_PEOPLE_PARAM |
ROOM_OCCUPANCY_UNIT_PARAM |
ROOM_SPACE_TYPE_PARAM |
ROOM_CONDITION_TYPE_PARAM |
PROJECT_POSTAL_CODE |
PROJECT_BUILDING_TYPE |
RBS_SIZE_LOCK |
RBS_ADDITIONAL_FLOW |
RBS_CURVETYPE_MAX_WIDTH_PARAM |
ROOM_ZONE_PARAM_OBSOLETE |
RBS_PIPE_SIZE_FORMATTED_PARAM |
RBS_DUCT_SIZE_FORMATTED_PARAM |
RBS_DUCT_STATIC_PRESSURE |
RBS_FLEX_PIPE_TYPE_PARAM |
RBS_PIPE_TYPE_PARAM |
RBS_FLEX_DUCT_TYPE_PARAM |
RBS_DUCT_TYPE_PARAM |
RBS_DUCT_FITTING_LOSS_TABLE_PARAM |
RBS_DUCT_FITTING_LOSS_METHOD_PARAM |
RBS_FLEXDUCT_ROUNDTYPE_PARAM |
RBS_CURVETYPE_PREFERRED_BRANCH_PARAM |
RBS_CURVETYPE_DEFAULT_TAKEOFF_PARAM |
RBS_OFFSET_PARAM |
RBS_CURVETYPE_DEFAULT_UNION_PARAM |
RBS_REQUIRED_FLOW |
RBS_HYDRAULIC_DIAMETER_PARAM |
RBS_REYNOLDSNUMBER_PARAM |
RBS_EQ_DIAMETER_PARAM |
RBS_CURVETYPE_MULTISHAPE_TRANSITION_PARAM |
RBS_SECTION |
RBS_LOSS_COEFFICIENT |
RBS_MAX_FLOW |
RBS_MIN_FLOW |
RBS_VELOCITY_PRESSURE |
RBS_CURVE_SURFACE_AREA |
RBS_CURVETYPE_MAX_HEIGHT_PARAM |
RBS_LINING_THICKNESS |
RBS_INSULATION_THICKNESS |
RBS_FRICTION |
RBS_CURVETYPE_RISEDROP_TYPE_PARAM |
RBS_CURVETYPE_ROUGHNESS_PARAM |
RBS_CURVETYPE_DEFAULT_TRANSITION_PARAM |
RBS_CURVETYPE_DEFAULT_CROSS_PARAM |
RBS_CURVETYPE_DEFAULT_TEE_PARAM |
RBS_CURVETYPE_DEFAULT_ELBOW_PARAM |
RBS_FLOW_DIRECTION_OBSOLETE |
RBS_PRESSURE_DROP |
RBS_VELOCITY |
RBS_CURVE_VERT_OFFSET_PARAM |
RBS_CURVE_HOR_OFFSET_PARAM |
RBS_FLOW_OBSOLETE |
RBS_CURVE_DIAMETER_PARAM |
RBS_CURVE_HEIGHT_PARAM |
RBS_CURVE_WIDTH_PARAM |
RBS_CURVETYPE_PROFILE_PARAM |
RBS_FLEX_PATTERN_PARAM |
RBS_SYSTEM_CATEGORY_PARAM |
RBS_END_OFFSET_PARAM |
RBS_START_OFFSET_PARAM |
RBS_END_LEVEL_PARAM |
RBS_START_LEVEL_PARAM |
IFC_TYPE_GUID |
IFC_GUID |
REIN_EST_BAR_VOLUME |
REIN_EST_BAR_LENGTH |
REIN_EST_NUMBER_OF_BARS |
PATH_REIN_SPANLENGTH_ALT_OFFSET |
PATH_REIN_SPANLENGTH_BARLENGTH_ALT |
PATH_REIN_SPANLENGTH_BARLENGTH_PRIM |
PATH_REIN_SPANLENGTH_TOP_ALT |
PATH_REIN_END_SPANHOOK_ALT |
PATH_REIN_END_SPANHOOK_PRIM |
PATH_REIN_SUMMARY |
PATH_REIN_SPANLENGTH_BOTTOM_ALT |
PATH_REIN_SPANLENGTH_BOTTOM_PRIM |
PATH_REIN_SPANHOOK_ALT |
PATH_REIN_SPANHOOK_PRIM |
PATH_REIN_ADDL_OFFSET |
PATH_REIN_ALT_OFFSET |
PATH_REIN_END_HOOK_ORIENT_2_WALL |
PATH_REIN_END_HOOK_ORIENT_1_WALL |
PATH_REIN_END_HOOK_ORIENT_2_SLAB |
PATH_REIN_END_HOOK_ORIENT_1_SLAB |
PATH_REIN_END_HOOK_TYPE_2 |
PATH_REIN_END_HOOK_TYPE_1 |
PATH_REIN_HOOK_ORIENT_2_WALL |
PATH_REIN_HOOK_ORIENT_1_WALL |
PATH_REIN_HOOK_ORIENT_2_SLAB |
PATH_REIN_HOOK_ORIENT_1_SLAB |
PATH_REIN_HOOK_TYPE_2 |
PATH_REIN_HOOK_TYPE_1 |
PATH_REIN_LENGTH_2 |
PATH_REIN_LENGTH_1 |
PATH_REIN_TYPE_2 |
PATH_REIN_TYPE_1 |
PATH_REIN_ALTERNATING |
PATH_REIN_NUMBER_OF_BARS |
PATH_REIN_SPACING |
PATH_REIN_FACE_WALL |
PATH_REIN_FACE_SLAB |
REBAR_SYSTEM_NUMBER_OF_LINES_BOTTOM_DIR_2_GENERIC |
REBAR_SYSTEM_NUMBER_OF_LINES_BOTTOM_DIR_1_GENERIC |
REBAR_SYSTEM_NUMBER_OF_LINES_TOP_DIR_2_GENERIC |
REBAR_SYSTEM_NUMBER_OF_LINES_TOP_DIR_1_GENERIC |
REBAR_SYSTEM_BAR_TYPE_BOTTOM_DIR_2_GENERIC |
REBAR_SYSTEM_BAR_TYPE_BOTTOM_DIR_1_GENERIC |
REBAR_SYSTEM_BAR_TYPE_TOP_DIR_2_GENERIC |
REBAR_SYSTEM_BAR_TYPE_TOP_DIR_1_GENERIC |
REBAR_SYSTEM_ACTIVE_BOTTOM_DIR_2_GENERIC |
REBAR_SYSTEM_ACTIVE_BOTTOM_DIR_1_GENERIC |
REBAR_SYSTEM_ACTIVE_TOP_DIR_2_GENERIC |
REBAR_SYSTEM_ACTIVE_TOP_DIR_1_GENERIC |
REBAR_SYSTEM_SPACING_BACK_DIR_2 |
REBAR_SYSTEM_SPACING_BACK_DIR_1 |
REBAR_SYSTEM_SPACING_FRONT_DIR_2 |
REBAR_SYSTEM_SPACING_FRONT_DIR_1 |
REBAR_SYSTEM_NUMBER_OF_LINES_BACK_DIR_2 |
REBAR_SYSTEM_NUMBER_OF_LINES_BACK_DIR_1 |
REBAR_SYSTEM_NUMBER_OF_LINES_FRONT_DIR_2 |
REBAR_SYSTEM_NUMBER_OF_LINES_FRONT_DIR_1 |
REBAR_SYSTEM_HOOK_TYPE_BACK_DIR_2 |
REBAR_SYSTEM_HOOK_TYPE_BACK_DIR_1 |
REBAR_SYSTEM_HOOK_TYPE_FRONT_DIR_2 |
REBAR_SYSTEM_HOOK_TYPE_FRONT_DIR_1 |
REBAR_SYSTEM_HOOK_ORIENT_BACK_DIR_2 |
REBAR_SYSTEM_HOOK_ORIENT_BACK_DIR_1 |
REBAR_SYSTEM_HOOK_ORIENT_FRONT_DIR_2 |
REBAR_SYSTEM_HOOK_ORIENT_FRONT_DIR_1 |
REBAR_SYSTEM_BAR_TYPE_BACK_DIR_2 |
REBAR_SYSTEM_BAR_TYPE_BACK_DIR_1 |
REBAR_SYSTEM_BAR_TYPE_FRONT_DIR_2 |
REBAR_SYSTEM_BAR_TYPE_FRONT_DIR_1 |
REBAR_SYSTEM_ACTIVE_BACK_DIR_2 |
REBAR_SYSTEM_ACTIVE_BACK_DIR_1 |
REBAR_SYSTEM_ACTIVE_FRONT_DIR_2 |
REBAR_SYSTEM_ACTIVE_FRONT_DIR_1 |
REBAR_SYSTEM_SPACING_BOTTOM_DIR_2 |
RADIAL_TICK_TYPE |
LINEAR_TICK_TYPE |
ARROW_SIZE |
ARROW_TYPE |
TICK_MARK_PEN |
TEXT_POSITION |
SUPPRESS_0_IN |
SUPPRESS_0_FT |
RADIUS_PREFIX |
CENTER_MARK_SIZE |
ARC_CENTER_MARK |
WITNS_LINE_GAP_TO_ELT |
WITNS_LINE_EXTENSION |
TICK_SIZE |
TICK_TYPE |
TEXT_DIST_TO_LINE |
TEXT_ALIGNMENT |
MODEL_TEXT_SIZE |
TEXT_STYLE_SIZE |
TEXT_STYLE_FONT |
SHOW_TITLE |
TITLE_STYLE_UNDERLINE |
TITLE_STYLE_ITALIC |
TITLE_STYLE_BOLD |
TITLE_SIZE |
TITLE_FONT |
TEXT_WIDTH_SCALE |
TEXT_TAB_SIZE |
ARC_LEADER_PARAM |
TEXT_MODEL_TEXT |
DIM_LEADER_ARROWHEAD |
SHEET_ISSUE_DATE |
PROJECT_ISSUE_DATE |
PROJECT_STATUS |
CLIENT_NAME |
PROJECT_ADDRESS |
PROJECT_NAME |
PROJECT_NUMBER |
LEADER_ARROWHEAD |
TEXT_BACKGROUND |
TEXT_STYLE_UNDERLINE |
TEXT_STYLE_ITALIC |
TEXT_STYLE_BOLD |
CURVE_IS_FILLED |
TEXT_ALIGN_VERT |
TEXT_ALIGN_HORZ |
TEXT_TEXT |
HEAD_STYLE |
LINE_PATTERN |
LINE_COLOR |
LINE_PEN |
TEXT_COLOR |
TEXT_SIZE |
TEXT_FONT |
FACE_TYPE_NON_CAPPED_END |
FACE_TYPE_CAPPED_END |
FACE_TYPE_INTERIOR |
FACE_TYPE_EXTERIOR |
FACE_TYPE |
CLINE_SUBCATEGORY |
EDGE_LINEWORK |
BUILDING_CURVE_GSTYLE_PLUS_INVISIBLE |
BUILDING_CURVE_GSTYLE |
FAMILY_CURVE_GSTYLE_FOR_2010_MASS |
HEAD_ON_PLACEMENT_METHOD |
IS_VISIBLE_PARAM |
FAMILY_CURVE_GSTYLE_PLUS_INVISIBLE_PLUS_STICK_SYM_MINUS_ANALYTICAL |
FAMILY_CURVE_GSTYLE_PLUS_INVISIBLE_MINUS_ANALYTICAL |
FAMILY_CURVE_GSTYLE_PLUS_INVISIBLE_PLUS_STICK_SYM |
FAMILY_CURVE_GSTYLE_PLUS_INVISIBLE |
FAMILY_ELEM_SUBCATEGORY |
STAIRS_CURVE_TAG |
STAIRS_CURVE_FACE_TAG |
STAIRS_CURVE_RISER_SEGMENT_NUM |
STAIRS_CURVE_ORIENTATION |
STAIRS_CURVE_BOUNDARY_SIDE |
STAIRS_CURVE_RISER_NUM |
STAIRS_CURVE_RUN_ID2 |
STAIRS_CURVE_RUN_ID1 |
STAIRS_CURVE_TYPE |
ROOF_SLOPE |
CURVE_PARAM_STEEL_CANTILEVER |
CURVE_PARAM_CONCRETE_CANTILEVER |
CURVE_NUMBER_OF_SEGMENTS |
SPECIFY_SLOPE_OR_OFFSET |
SLOPE_ARROW_LEVEL_END |
SLOPE_ARROW_LEVEL_START |
CURVE_LEVEL |
CURVE_HEIGHT_OFFSET |
CURVE_IS_SLOPE_DEFINING |
DEFINES_CONSTANT_HEIGHT |
ROOF_CURVE_HEIGHT_AT_WALL |
ROOF_RISE_RUN_IMPERIAL |
ROOF_RISE_RUN_METRIC |
ROOF_SLOPE_ANGLE |
ROOF_CURVE_HEIGHT_OFFSET |
ROOF_CURVE_IS_SLOPE_DEFINING |
VIEW_DESIGN_OPTIONS_CONFIG |
VIEW_GRAPH_SCHED_LEVEL_RELATIVE_BASE_TYPE |
VIEW_GRAPH_SCHED_HIDDEN_LEVELS |
VIEW_GRAPH_SCHED_TOTAL_ROWS |
VIEW_GRAPH_SCHED_ROWS_COUNT |
VIEW_GRAPH_SCHED_GRID_APPEARANCE |
VIEW_GRAPH_SCHED_TEXT_APPEARANCE |
VIEW_GRAPH_SCHED_TITLE |
VIEW_GRAPH_SCHED_HEIGHT_BETWEEN |
VIEW_GRAPH_SCHED_HEIGHT_BELOW |
VIEW_GRAPH_SCHED_HEIGHT_ABOVE |
VIEW_GRAPH_SCHED_SIDE_WIDTH |
VIEW_GRAPH_SCHED_ROWS_FROM |
VIEW_GRAPH_SCHED_GROUP_SIMILAR |
VIEW_GRAPH_SCHED_MATERIAL_TYPES |
VIEW_GRAPH_SCHED_LOCATIONS_HIGH |
VIEW_GRAPH_SCHED_LOCATIONS_LOW |
VIEW_GRAPH_SCHED_BOTTOM_LEVEL |
VIEW_GRAPH_SCHED_TOP_LEVEL |
LIGHT_POS_Z |
LIGHT_POS_Y |
LIGHT_POS_X |
LIGHT_ON |
VIEWPORT_ATTR_ORIENTATION_ON_SHEET |
VIEWPORT_ATTR_SHOW_BOX |
VIEWPORT_ATTR_SHOW_EXTENSION_LINE |
VIEWPORT_ATTR_SHOW_LABEL |
VIEWPORT_ATTR_LABEL_TAG |
VIEW_SCALE_HAVENAME |
VIEW_SCALE_CUSTOMNAME |
VIEW_GRAPH_SCHED_OFF_GRID |
VIEW_GRAPH_SCHED_UNITS_FORMAT |
VIEWPORT_SHEET_NAME |
VIEWPORT_SHEET_NUMBER |
FBX_LIGHT_SPOT_BEAM_ANGLE_OOPS |
FBX_LIGHT_SPOT_TILT_ANGLE |
FBX_LIGHT_SPOT_FIELD_ANGLE |
FBX_LIGHT_SPOT_BEAM_ANGLE |
FBX_LIGHT_EMIT_SHAPE_VISIBLE |
FBX_LIGHT_DIMMING_LIGHT_COLOR |
FBX_LIGHT_TOTAL_LIGHT_LOSS_OOPS |
FBX_LIGHT_TOTAL_LIGHT_LOSS |
FBX_LIGHT_LUMENAIRE_DIRT |
FBX_LIGHT_LAMP_LUMEN_DEPR |
FBX_LIGHT_SURFACE_LOSS |
FBX_LIGHT_LAMP_TILT_LOSS |
FBX_LIGHT_BALLAST_LOSS_OOPS |
FBX_LIGHT_BALLAST_LOSS |
FBX_LIGHT_VOLTAGE_LOSS |
FBX_LIGHT_TEMPERATURE_LOSS |
FBX_LIGHT_LOSS_FACTOR_METOD |
FBX_LIGHT_LOSS_FACTOR_CTRL |
FBX_LIGHT_COLOR_FILTER |
FBX_LIGHT_INITIAL_COLOR_NAME |
FBX_LIGHT_INITIAL_COLOR_TEMPERATURE |
FBX_LIGHT_INITIAL_COLOR_CTRL |
FBX_LIGHT_AT_A_DISTANCE |
FBX_LIGHT_ILLUMINANCE |
FBX_LIGHT_LIMUNOUS_FLUX |
FBX_LIGHT_LIMUNOUS_INTENSITY |
FBX_LIGHT_EFFICACY |
FBX_LIGHT_WATTAGE |
FBX_LIGHT_INITIAL_INTENSITY_INPUT_METOD |
FBX_LIGHT_INITIAL_INTENSITY |
FBX_LIGHT_PHOTOMETRICS |
FBX_ASSET_TYPE |
DIVIDED_SURFACE_COMPONENT_TRIM_TYPE |
DIVIDED_SURFACE_PATTERN_MIRROR |
DIVIDED_SURFACE_RULE_2_SUSPENSION |
DIVIDED_SURFACE_RULE_1_SUSPENSION |
DIVIDED_SURFACE_DISPLAY_COMPONENTS |
DIVIDED_SURFACE_PATTERN_FILL_MATERIAL |
DIVIDED_SURFACE_DISPLAY_PATTERN_FILL |
DIVIDED_SURFACE_PATTERN_LINES_STYLE |
DIVIDED_SURFACE_DISPLAY_PATTERN_LINES |
DIVIDED_SURFACE_GRIDLINES_STYLE |
DIVIDED_SURFACE_DISPLAY_GRIDLINES |
DIVIDED_SURFACE_DISPLAY_NODES |
DIVIDED_SURFACE_ORIGINAL_SURFACE_MATERIAL |
DIVIDED_SURFACE_DISPLAY_ORIGINAL_SURFACE |
DIVIDED_SURFACE_DISPLAY_SURFACE_OPTION |
DIVIDED_SURFACE_ALL_GRID_ROTATION |
DIVIDED_SURFACE_TILE_BORDER |
CURTAIN_MESH_SYSTEM_PANEL_FLIP |
CURTAIN_MESH_SYSTEM_PANEL_FAILURE |
CURTAIN_MESH_SYSTEM_PANEL_INCOMPLETE |
CURTAIN_MESH_SYSTEM_PANEL_PRIMARY |
DIVIDED_SURFACE_ALL_POINTS |
DIVIDED_SURFACE_PATTERN |
DIVIDED_SURFACE_PATTERN_FLIP |
DIVIDED_SURFACE_PATTERN_ROTATION_ANGLE |
DIVIDED_SURFACE_PATTERN_INDENT_2 |
DIVIDED_SURFACE_PATTERN_INDENT_1 |
DIVIDED_SURFACE_COVER_FACE_COMPLETELY |
DIVIDED_SURFACE_OFFSET_FROM_SURFACE |
DIVIDED_SURFACE_TOTAL_EDGE_LENGTH |
DIVIDED_SURFACE_EDGE_NUMBER |
DIVIDED_SURFACE_POINT_NUMBER |
DIVIDED_SURFACE_FACET_NUMBER |
DIVIDED_SURFACE_SURFACE_AREA |
GB_RECYCLED_HOST_ASSEMBLY |
GB_RENEWABLE_ENERGY_SOURCE |
GB_RECYCLED_COMPONENT |
GB_FCS_CERTIFIED_WOOD |
GB_GREEN_SEAL_PAINT_STD |
GB_GREEN_LABEL_PLUS_STD |
GB_OUTGAS_FORMALDEHYDE |
GB_RAPIDLY_RENEWABLE_PLANT_MATERIAL |
GB_LINK_TO_COMPONENT_DOCUMENTATION |
GB_LINK_TO_MATERIAL_DOCUMENTATION |
GB_FIXTURE_FLOW_RATE |
GB_EQUIPMENT_REFRIGERANT_LIFESPAN |
GB_REFRIGERANT_LB_PER_COOLING_TON |
GB_MINIMUM_EFFICIENCY_REPORTING_VALUE |
GB_SOLAR_REFLECTIVE_INDEX |
GB_GLOBAL_WARMING_POTENTIAL |
GB_ATMOSPHERIC_LIFETIME |
GB_OZONE_DEPLETION_POTENTIAL |
GB_VISIBLE_LIGHT_TRANSMITTANCE |
GB_NEW_MATERIAL_COST |
GB_RECYCLED_MATERIAL_COST |
GB_R_VALUE |
GB_RECYCLED_MATERIAL_PERCENT |
GB_U_VALUE |
GB_SOURCE_DISTANCE |
GB_REFRIGERANT_USED |
GB_OPERATIONAL_RECYCLED_MATERIAL |
GB_WASTE_WATER_TYPE_GENERATED |
GB_BUILDING_OCCUPANCY |
GB_ANNUAL_RENEWABLE_ENERGY_PRODUCED |
GB_ANNUAL_RAINFALL |
GB_ANNUAL_ELECTICAL_CONSUMPTION |
LABEL_MULTI_PARAMETER |
JOIST_SYSTEM_ELEM_TAG_NEW_MEMBERS_VIEW |
REFERENCE_VIEWER_ATTR_TAG |
REFERENCE_VIEWER_TARGET_VIEW |
MATCHLINE_BOTTOM_PLANE |
MATCHLINE_TOP_PLANE |
MATCHLINE_BOTTOM_OFFSET |
MATCHLINE_TOP_OFFSET |
TRUSS_FAMILY_BOTTOM_CHORD_STRUCTURAL_TYPES_PARAM |
TRUSS_FAMILY_BOTTOM_CHORD_ANGLE_PARAM |
TRUSS_FAMILY_BOTTOM_CHORD_VERTICAL_PROJECTION_PARAM |
TRUSS_FAMILY_BOTTOM_CHORD_START_RELEASE_TYPE |
TRUSS_FAMILY_BOTTOM_CHORD_END_RELEASE_TYPE |
TRUSS_FAMILY_TOP_CHORD_STRUCTURAL_TYPES_PARAM |
TRUSS_FAMILY_TOP_CHORD_ANGLE_PARAM |
TRUSS_FAMILY_TOP_CHORD_VERTICAL_PROJECTION_PARAM |
TRUSS_FAMILY_TOP_CHORD_START_RELEASE_TYPE |
TRUSS_FAMILY_TOP_CHORD_END_RELEASE_TYPE |
TRUSS_FAMILY_DIAG_WEB_STRUCTURAL_TYPES_PARAM |
TRUSS_FAMILY_DIAG_WEB_ANGLE_PARAM |
TRUSS_FAMILY_DIAG_WEB_START_RELEASE_TYPE |
TRUSS_FAMILY_DIAG_WEB_END_RELEASE_TYPE |
TRUSS_FAMILY_VERT_WEB_STRUCTURAL_TYPES_PARAM |
TRUSS_FAMILY_VERT_WEB_ANGLE_PARAM |
TRUSS_FAMILY_VERT_WEB_START_RELEASE_TYPE |
TRUSS_FAMILY_VERT_WEB_END_RELEASE_TYPE |
TRUSS_ELEMENT_TAG_NEW_MEMBERS_VIEW |
TRUSS_NON_BEARING_OFFSET_PARAM |
TRUSS_BEARING_CHORD_TOP_BOTTOM_PARAM |
TRUSS_ELEMENT_SPAN_PARAM |
TRUSS_ELEMENT_STICK_JUST_PARAM |
TRUSS_FAMILY_WEBS_HAVE_SYMBOLIC_CUTBACK_PARAM |
TRUSS_HEIGHT |
TRUSS_FAMILY_TRANSFORMATION_PARAM |
TRUSS_ELEMENT_REFERENCE_LEVEL_PARAM |
TRUSS_ELEMENT_END1_ELEVATION |
TRUSS_ELEMENT_END0_ELEVATION |
TRUSS_ELEMENT_BEARING_JUST_PARAM |
TRUSS_ELEMENT_CREATE_BOTTOM_PARAM |
TRUSS_ELEMENT_CREATE_TOP_PARAM |
TRUSS_ELEMENT_ANGLE_PARAM |
TRUSS_ELEMENT_CLASS_PARAM |
TRUSS_FAMILY_SYMBOL_ID |
TRUSS_LENGTH |
BOUNDARY_PARAM_PRESET_AREA |
BOUNDARY_PARAM_PRESET_LINEAR |
BOUNDARY_PARAM_PRESET |
BOUNDARY_Z_TRANSLATION_SPRING |
BOUNDARY_Z_TRANSLATION_FIXED |
BOUNDARY_Z_ROTATION_SPRING |
BOUNDARY_Z_ROTATION_FIXED |
BOUNDARY_Y_TRANSLATION_SPRING |
BOUNDARY_Y_TRANSLATION_FIXED |
BOUNDARY_Y_ROTATION_SPRING |
BOUNDARY_Y_ROTATION_FIXED |
BOUNDARY_X_TRANSLATION_SPRING |
BOUNDARY_X_TRANSLATION_FIXED |
BOUNDARY_X_ROTATION_SPRING |
BOUNDARY_X_ROTATION_FIXED |
BOUNDARY_AREA_RESTRAINT_Z |
BOUNDARY_AREA_RESTRAINT_Y |
BOUNDARY_AREA_RESTRAINT_X |
BOUNDARY_LINEAR_RESTRAINT_ROT_X |
BOUNDARY_LINEAR_RESTRAINT_Z |
BOUNDARY_LINEAR_RESTRAINT_Y |
BOUNDARY_LINEAR_RESTRAINT_X |
BOUNDARY_RESTRAINT_ROT_Z |
BOUNDARY_RESTRAINT_ROT_Y |
BOUNDARY_RESTRAINT_ROT_X |
BOUNDARY_RESTRAINT_Z |
BOUNDARY_RESTRAINT_Y |
BOUNDARY_RESTRAINT_X |
BOUNDARY_DIRECTION_ROT_Z |
BOUNDARY_DIRECTION_ROT_Y |
BOUNDARY_DIRECTION_ROT_X |
BOUNDARY_DIRECTION_Z |
BOUNDARY_DIRECTION_Y |
BOUNDARY_DIRECTION_X |
BOUNDARY_CONDITIONS_IS_EXT |
BOUNDARY_CONDITIONS_TYPE |
KEYNOTE_SYSTEM |
KEY_SOURCE_PARAM |
KEYNOTE_PARAM |
KEYNOTE_NUMBER |
SHEET_KEY_NUMBER |
KEYNOTE_TEXT |
KEY_VALUE |
PHY_MATERIAL_PARAM_GRADE |
PHY_MATERIAL_PARAM_SPECIES |
PHY_MATERIAL_PARAM_EXP_COEFF |
PHY_MATERIAL_PARAM_BENDING |
PHY_MATERIAL_PARAM_SHEAR_MOD |
PHY_MATERIAL_PARAM_POISSON_MOD |
PHY_MATERIAL_PARAM_SHEAR_PERPENDICULAR |
PHY_MATERIAL_PARAM_SHEAR_PARALLEL |
PHY_MATERIAL_PARAM_COMPRESSION_PERPENDICULAR |
PHY_MATERIAL_PARAM_COMPRESSION_PARALLEL |
PHY_MATERIAL_PARAM_YOUNG_MOD |
PHY_MATERIAL_PARAM_TYPE |
ELEM_CATEGORY_PARAM_MT |
ELEM_CATEGORY_PARAM |
MATERIAL_VOLUME |
MATERIAL_AREA |
MATERIAL_NAME |
RBS_SYSTEM_FLOW_CONVERSION_METHOD_PARAM |
RBS_SYSTEM_NUM_ELEMENTS_PARAM |
RBS_SYSTEM_BASE_ELEMENT_PARAM |
RBS_SYSTEM_TYPE_PARAM |
RBS_SYSTEM_NAME_PARAM |
PHY_MATERIAL_PARAM_LIGHT_WEIGHT |
PHY_MATERIAL_PARAM_BEHAVIOR |
PHY_MATERIAL_PARAM_RESISTANCE_CALC_STRENGTH |
PHY_MATERIAL_PARAM_REDUCTION_FACTOR |
PHY_MATERIAL_PARAM_MINIMUM_TENSILE_STRENGTH |
PHY_MATERIAL_PARAM_MINIMUM_YIELD_STRESS |
PHY_MATERIAL_PARAM_SHEAR_STRENGTH_REDUCTION |
PHY_MATERIAL_PARAM_SHEAR_REINFORCEMENT |
PHY_MATERIAL_PARAM_BENDING_REINFORCEMENT |
PHY_MATERIAL_PARAM_CONCRETE_COMPRESSION |
PHY_MATERIAL_PARAM_DAMPING_RATIO |
PHY_MATERIAL_PARAM_EXP_COEFF3 |
PHY_MATERIAL_PARAM_EXP_COEFF2 |
PHY_MATERIAL_PARAM_EXP_COEFF1 |
PHY_MATERIAL_PARAM_UNIT_WEIGHT |
PHY_MATERIAL_PARAM_SHEAR_MOD3 |
PHY_MATERIAL_PARAM_SHEAR_MOD2 |
PHY_MATERIAL_PARAM_SHEAR_MOD1 |
PHY_MATERIAL_PARAM_POISSON_MOD3 |
PHY_MATERIAL_PARAM_POISSON_MOD2 |
PHY_MATERIAL_PARAM_POISSON_MOD1 |
PHY_MATERIAL_PARAM_YOUNG_MOD3 |
PHY_MATERIAL_PARAM_YOUNG_MOD2 |
PHY_MATERIAL_PARAM_YOUNG_MOD1 |
RBS_FP_SPRINKLER_ORIFICE_SIZE_PARAM |
RBS_FP_SPRINKLER_TEMPERATURE_RATING_PARAM |
RBS_FP_SPRINKLER_K_FACTOR_PARAM |
RBS_FP_SPRINKLER_PRESSURE_CLASS_PARAM |
RBS_FP_SPRINKLER_ORIFICE_PARAM |
RBS_FP_SPRINKLER_COVERAGE_PARAM |
RBS_FP_SPRINKLER_RESPONSE_PARAM |
RBS_SHOW_PROFILE_TYPE |
RBS_PIPE_SYSTEM_FIXTURE_UNIT_PARAM |
RBS_PIPE_SLOPE |
RBS_DUCT_SLOPE |
RBS_CURVE_UTSLOPE |
RBS_PIPE_VOLUME_PARAM |
RBS_PIPE_WFU_PARAM |
RBS_PIPE_HWFU_PARAM |
RBS_PIPE_CWFU_PARAM |
RBS_PIPE_FLOW_CONFIGURATION_PARAM |
RBS_PIPE_FLOW_DIRECTION_PARAM |
RBS_PIPE_TOTAL_FIXTURE_UNITS_PARAM_OBSOLETE |
RBS_PIPE_FIXTURE_UNITS_PARAM |
RBS_CURVE_SLOPE_RISE_RUN_METRIC |
RBS_CURVE_SLOPE_RISE_RUN_IMPERIAL |
RBS_CURVE_SLOPE_ANGLE |
RBS_PIPE_STATIC_PRESSURE |
RBS_PIPE_INSULATION_THICKNESS |
RBS_DUCT_BOTTOM_ELEVATION |
RBS_DUCT_TOP_ELEVATION |
RBS_PIPE_OUTER_DIAMETER |
RBS_PIPE_INVERT_ELEVATION |
RBS_PIPE_TYPE_FITTING_LOSS_METHOD_PARAM |
RBS_PIPE_TYPE_FITTING_LOSS_TABLE_PARAM |
RBS_PIPE_TYPE_FITTING_LOSS_KFACTOR_PARAM |
RBS_PIPE_TYPE_VALVE_LOSS_CVFACTOR_PARAM |
RBS_PIPE_FITTING_LOSS_METHOD_PARAM |
RBS_PIPE_FITTING_LOSS_TABLE_PARAM |
RBS_PIPE_FITTING_LOSS_KFACTOR_PARAM |
RBS_PIPE_VALVE_LOSS_CVFACTOR_PARAM |
RBS_PIPE_ADDITIONAL_FLOW_PARAM |
RBS_PIPE_DIAMETER_PARAM |
RBS_CURVE_SLOPE |
RBS_ADJUSTABLE_CONNECTOR |
RBS_FLOW_FACTOR_PARAM |
RBS_DUCT_FLOW_CONFIGURATION_PARAM |
RBS_DUCT_FLOW_DIRECTION_PARAM |
RBS_PIPE_FLUID_TYPE_PARAM |
RBS_PIPE_FLUID_TEMPERATURE_PARAM |
RBS_PIPE_FLUID_VISCOSITY_PARAM |
RBS_PIPE_FLUID_DENSITY_PARAM |
RBS_PIPE_FLOW_PARAM |
RBS_PIPE_INNER_DIAM_PARAM |
RBS_PIPE_REYNOLDS_NUMBER_PARAM |
RBS_PIPE_RELATIVE_ROUGHNESS_PARAM |
RBS_PIPE_FLOW_STATE_PARAM |
RBS_PIPE_FRICTION_FACTOR_PARAM |
RBS_PIPE_VELOCITY_PARAM |
RBS_PIPE_FRICTION_PARAM |
RBS_PIPE_PRESSUREDROP_PARAM |
RBS_PIPE_ROUGHNESS_PARAM |
RBS_SYSTEM_PARAM |
RBS_PIPE_MATERIAL_PARAM |
RBS_PIPE_CONNECTIONTYPE_PARAM |
RBS_PIPE_CLASS_PARAM |
RBS_ELEC_SWITCH_ID_PARAM |
RBS_WIRE_CIRCUIT_DESCRIPTION |
RBS_WIRE_CIRCUIT_LOAD_NAME |
RBS_WIRE_NUM_CONDUCTORS_PARAM |
RBS_ELEC_WIRE_TICKMARK_STATE |
RBS_CIRCUIT_DIRECTION |
RBS_ELEC_CIRCUIT_PANEL_PARAM |
RBS_ELEC_CIRCUIT_NUMBER |
RBS_ELEC_WIRE_CIRCUITS |
RBS_ELEC_CIRCUIT_WIRE_NUM_RUNS_PARAM |
RBS_ELEC_CIRCUIT_WIRE_NUM_HOTS_PARAM |
RBS_ELEC_CIRCUIT_WIRE_NUM_NEUTRALS_PARAM |
RBS_ELEC_CIRCUIT_WIRE_NUM_GROUNDS_PARAM |
RBS_ELEC_WIRE_TYPE |
RBS_ELEC_WIRE_ELEVATION |
RBS_ELEC_WIRE_SHOW_TICKMARKS |
RBS_ELEC_WIRE_HOT_ADJUSTMENT |
RBS_ELEC_WIRE_NEUTRAL_ADJUSTMENT |
RBS_ELEC_WIRE_GROUND_ADJUSTMENT |
RBS_ELEC_WIRE_SHARE_NEUTRAL |
RBS_ELEC_WIRE_SHARE_GROUND |
RBS_ELEC_CIRCUIT_NAME |
RBS_FAMILY_CONTENT_SECONDARY_DISTRIBSYS |
RBS_ELEC_CIRCUIT_NAMING |
RBS_ELEC_CIRCUIT_PREFIX_SEPARATOR |
RBS_ELEC_CIRCUIT_PREFIX |
RBS_ELEC_MODIFICATIONS |
RBS_ELEC_ENCLOSURE |
RBS_ELEC_MAINS |
RBS_ELEC_MOUNTING |
RBS_ELEC_SHORT_CIRCUIT_RATING |
RBS_ELEC_MAX_POLE_BREAKERS |
RBS_ELEC_PANEL_NAME |
RBS_ELEC_PANEL_TOTALESTLOAD_HVAC_PARAM |
RBS_ELEC_PANEL_TOTALLOAD_HVAC_PARAM |
RBS_ELEC_PANEL_TOTALESTLOAD_LIGHT_PARAM |
RBS_ELEC_PANEL_TOTALLOAD_LIGHT_PARAM |
RBS_ELEC_PANEL_TOTALESTLOAD_POWER_PARAM |
SCHEDULE_FIELDS_PARAM |
RASTER_HORIZONTAL_SCALE |
RASTER_VERTICAL_SCALE |
RASTER_SYMBOL_HEIGHT |
RASTER_SYMBOL_WIDTH |
RASTER_SYMBOL_RESOLUTION |
RASTER_SYMBOL_FILENAME |
RASTER_SYMBOL_VIEWNAME |
RASTER_SYMBOL_PIXELHEIGHT |
RASTER_SYMBOL_PIXELWIDTH |
RASTER_MAINTAIN_ASPECT_RATIO |
RASTER_SHEETHEIGHT |
RASTER_SHEETWIDTH |
IMPORT_ADT_ENTITY_ROLL |
IMPORT_ADT_ENTITY_THICKNESS |
IMPORT_ADT_ENTITY_LENGTH |
IMPORT_ADT_ENTITY_WIDTH |
IMPORT_ADT_ENTITY_HEIGHT |
IMPORT_ADT_COMPONENTS_DESC |
IMPORT_ADT_ENTITY_STYLE |
IMPORT_ADT_ENTITY_STRUCT_TYPE |
IMPORT_ADT_ENTITY_TYPE |
RVT_LINK_PHASE_MAP |
RVT_LINK_REFERENCE_TYPE |
RVT_LINK_FILE_NAME_WITHOUT_EXT |
RVT_LEVEL_OFFSET |
RVT_HOST_LEVEL |
RVT_SOURCE_LEVEL |
RVT_LEVEL_MAP |
RVT_LINK_INSTANCE_NAME |
GEO_LOCATION |
IMPORT_INSTANCE_SCALE |
IMPORT_BACKGROUND |
IMPORT_DISPLAY_UNITS |
IMPORT_BASE_LEVEL_OFFSET |
IMPORT_BASE_LEVEL |
IMPORT_SCALE |
IMPORT_SYMBOL_NAME |
ELEV_REFERENCE_LABEL_POS |
ELEV_ASSOC_DATUM |
ELEV_VIEW_NAME_POS |
ELEV_SHOW_VIEW_NAME |
ELEV_TEXT_POS |
ELEV_ARROW_FILLED |
ELEV_ARROW_ANGLE |
ELEV_SHAPE |
ELEV_WIDTH |
COLOR_FILL_SWATCH_HEIGHT_PARAM |
COLOR_FILL_SWATCH_WIDTH_PARAM |
COLOR_FILL_FILTERED_PARAM |
COLOR_FILL_SYMBOL_SIZE_PARAM |
COLOR_FILL_SCHEMA_PARAM |
DETAIL_ARRAY_GROUP_ELEMENT_INST |
DETAIL_ARRAY_GROUP_ELEMENT |
SPACING_ORIENTATION_STEP_ALL |
SPACING_INITIAL_ROTATION |
SPACING_ORIENTATION_STEP2 |
SPACING_ORIENTATION_STEP1_INST |
SHEET_CURRENT_REVISION_DESCRIPTION |
SHEET_REVISIONS_ON_SHEET |
SHEET_CURRENT_REVISION |
SHEET_HEIGHT |
SHEET_WIDTH |
SHEET_FILE_PATH |
SHEET_APPROVED_BY |
SHEET_DESIGNED_BY |
SHEET_SCHEDULED |
SHEET_CHECKED_BY |
SHEET_DRAWN_BY |
SHEET_DATE |
SHEET_SCALE |
SHEET_NUMBER |
SHEET_NAME |
MODEL_ARRAY_GROUP_ELEMENT_INST |
SPACING_APPEND |
SPACING_ORIENTATION_STEP1 |
MODEL_ARRAY_GROUP_ELEMENT |
AUTO_JOIN_CONDITION_WALL |
AUTO_MULLION_BORDER2_HORIZ |
AUTO_MULLION_BORDER1_HORIZ |
AUTO_MULLION_BORDER2_VERT |
AUTO_MULLION_BORDER1_VERT |
AUTO_MULLION_INTERIOR_HORIZ |
AUTO_MULLION_INTERIOR_VERT |
AUTO_PANEL_WALL |
AUTO_JOIN_CONDITION |
AUTO_PANEL |
AUTO_MULLION_BORDER2_GRID2 |
AUTO_MULLION_BORDER1_GRID2 |
AUTO_MULLION_BORDER2_GRID1 |
AUTO_MULLION_BORDER1_GRID1 |
AUTO_MULLION_INTERIOR_GRID2 |
AUTO_MULLION_INTERIOR_GRID1 |
CURTAIN_GRID_BASE_ORIENTATION |
MULLION_ANGLE |
MULLION_POSITION |
MULLION_PROFILE |
MAXIMUM_MULLION_LENGTH |
TRAP_MULL_WIDTH |
MULLION_DEPTH2 |
MULLION_DEPTH1 |
MULLION_DEPTH |
LV_MULLION_LEG2 |
LV_MULLION_LEG1 |
MULLION_CORNER_TYPE |
MULLION_FAM_TYPE |
MULLION_OFFSET |
CIRC_MULLION_RADIUS |
CUST_MULLION_THICK |
CUST_MULLION_WIDTH2 |
CUST_MULLION_WIDTH1 |
RECT_MULLION_THICK |
RECT_MULLION_BACK |
RECT_MULLION_FRONT |
RECT_MULLION_WIDTH2 |
RECT_MULLION_WIDTH1 |
STAIRS_RAILINGS_TYPE_NONE |
STAIRS_RAILINGS_TYPE_SYSTEM_DEFAULT |
STAIRS_INST_ALWAYS_UP |
STAIRS_ATTR_TRIM_TOP |
STAIRS_INST_DOWN_ARROW_ON |
STAIRS_INST_DOWN_LABEL_TEXT |
STAIRS_INST_DOWN_LABEL_ON |
STAIRS_INST_UP_ARROW_ON |
STAIRS_INST_UP_LABEL_TEXT |
STAIRS_INST_UP_LABEL_ON |
STAIRS_ATTR_TEXT_SIZE |
STAIRS_ATTR_TEXT_FONT |
STAIRS_ATTR_BODY_MATERIAL |
STAIRS_ATTR_LANDING_CARRIAGE |
STAIRS_ATTR_LANDINGS_OVERLAPPING |
STAIRS_ATTR_RIGHT_SIDE_STRINGER |
STAIRS_ATTR_LEFT_SIDE_STRINGER |
STAIRS_ATTR_NOSING_PLACEMENT |
STAIRS_ATTR_RISER_TREAD_CONNECT |
STAIRS_ATTR_RISER_THICKNESS |
STAIRS_ATTR_NUM_MID_STRINGERS |
STAIRS_ATTR_STAIRS_CUT_OFFSET |
STAIRS_ATTR_LAST_RISER |
STAIRS_ATTR_FIRST_RISER |
STAIRS_ATTR_STAIRS_BOTTOM |
STAIRS_ATTR_MONOLITHIC_STAIRS |
STAIRS_ATTR_CALC_ENABLED |
STAIRS_ATTR_CALC_MAX |
STAIRS_ATTR_CALC_MIN |
STAIRS_ATTR_EQ_RESULT |
STAIRS_ACTUAL_TREAD_DEPTH |
STAIRS_ATTR_TREAD_MULT |
STAIRS_ATTR_RISER_MULT |
STAIRS_ATTR_STAIR_CALCULATOR |
STAIRS_ACTUAL_NUM_RISERS |
STAIRS_ATTR_BREAK_SYM_IN_CUTLINE |
STAIRS_ATTR_RISER_MATERIAL |
STAIRS_ATTR_RISER_TYPE |
STAIRS_ATTR_TREAD_MATERIAL |
STAIRS_ATTR_NOSING_LENGTH |
STAIRS_ATTR_TREAD_FRONT_PROFILE |
STAIRS_ATTR_STRINGER_MATERIAL |
STAIRS_ATTR_STRINGER_OFFSET |
STAIRS_ATTR_STRINGER_CARRIAGE |
STAIRS_ATTR_SIDE_STRINGER_TYPE_PARAM |
STAIRS_MULTISTORY_TOP_LEVEL_PARAM |
STAIRS_STRINGERS_PRESENT |
STAIRS_BALUSTER_TREAD_OFFSET |
STAIRS_RIGHT_RAIL_BOTTOM_EXT |
STAIRS_RIGHT_RAIL_TOP_EXT |
STAIRS_ATTR_BALUSTER_LENGTH |
STAIRS_ATTR_BALUSTER_WIDTH |
STAIRS_ATTR_BALUSTERS_PER_TREAD |
STAIRS_ATTR_BALUSTER_SPACING |
STAIRS_ATTR_BALUSTER_SPACING_TYPE |
STAIRS_LEFT_RAIL_BOTTOM_EXT |
STAIRS_LEFT_RAIL_TOP_EXT |
STAIRS_ATTR_BALUSTER_SHAPE |
STAIRS_RIGHT_BALUSTER_ATTACH_PT |
STAIRS_ATTR_RIGHT_RAILING_PRESENT |
STAIRS_ATTR_LEFT_RAILING_PRESENT |
STAIRS_TOP_OFFSET |
STAIRS_BASE_OFFSET |
STAIRS_ATTR_RAILING_THICKNESS |
STAIRS_ATTR_RAILING_WIDTH |
STAIRS_ATTR_RAILING_HEIGHT |
STAIRS_ATTR_LEFT_BALUSTER_ATTACH_PT |
STAIRS_ATTR_BALUSTER_ATTACH_PT |
STAIRS_ATTR_NUM_BALUSTERS |
STAIRS_ATTR_RISER_ANGLE |
STAIRS_ATTR_TREAD_THICKNESS |
STAIRS_ATTR_STRINGER_THICKNESS |
STAIRS_ATTR_STRINGER_HEIGHT |
STAIRS_ATTR_RISERS_PRESENT |
STAIRS_TREAD_LENGTH |
STAIRS_ACTUAL_RISER_HEIGHT |
STAIRS_DESIRED_NUM_RISERS |
STAIRS_ATTR_TREAD_WIDTH |
STAIRS_ATTR_TREAD_LENGTH |
STAIRS_ATTR_MAX_RISER_HEIGHT |
STAIRS_TOP_LEVEL_PARAM |
STAIRS_BASE_LEVEL_PARAM |
LEVEL_RELATIVE_BASE_TYPE |
LEVEL_HORIZONTAL_TEXT_OFFSET |
LEVEL_VERTICAL_ELEV_OFFSET |
LEVEL_VERTICAL_TEXT_OFFSET |
LEVEL_IS_DATUM |
LEVEL_MAKE_PLAN_VIEW |
LEVEL_HEAD_RADIUS |
LEVEL_ELEV |
LEVEL_NAME |
LEVEL_HEAD_TAG |
TAG_NO_BREAK_PARAM_STRINGS |
ROOM_TAG_ORIENTATION_PARAM |
TAG_ORIENTATION_PARAM |
TAG_FORMAT_OPTIONS |
TAG_SAMPLE_TEXT |
TAG_TAG |
VIS_GRAPHICS_DESIGNOPTIONS |
VIS_GRAPHICS_RVT_LINKS |
VIS_GRAPHICS_FILTERS |
VIS_GRAPHICS_IMPORT |
VIS_GRAPHICS_ANNOTATION |
VIS_GRAPHICS_MODEL |
ROOM_USER_PARAM_LAST |
ROOM_USER_PARAM_FIRST |
LEVEL_ATTR_ROOM_COMPUTATION_AUTOMATIC |
LEVEL_ATTR_ROOM_COMPUTATION_HEIGHT |
ALWAYS_ZERO_LENGTH |
ROOM_COMPUTATION_METHOD |
ROOM_LOWER_OFFSET |
ROOM_UPPER_OFFSET |
ROOM_UPPER_LEVEL |
ROOM_VOLUME |
ROOM_HEIGHT |
TO_ROOM_NAME |
FROM_ROOM_NAME |
ROOM_PERIMETER |
ROOM_LEVEL_ID |
TO_WHICH_ROOM |
FROM_WHICH_ROOM |
TO_ROOM_ID |
FROM_ROOM_ID |
TO_ROOM_NUMBER |
FROM_ROOM_NUMBER |
ROOM_OCCUPANCY |
ROOM_OCCUPANT |
ROOM_DEPARTMENT |
ROOM_FINISH_BASE |
ROOM_FINISH_CEILING |
ROOM_FINISH_WALL |
ROOM_FINISH_FLOOR |
ROOM_AREA |
ROOM_NUMBER |
ROOM_NAME |
FILLED_REGION_BACKGROUND |
GRID_END_SEGMENTS_LENGTH |
GRID_END_SEGMENT_PATTERN |
GRID_END_SEGMENT_COLOR |
GRID_END_SEGMENT_WEIGHT |
GRID_CENTER_SEGMENT_PATTERN |
GRID_CENTER_SEGMENT_COLOR |
GRID_CENTER_SEGMENT_WEIGHT |
GRID_CENTER_SEGMENT_STYLE |
GRID_BUBBLE_LINE_PEN |
GRID_BUBBLE_RADIUS |
GRID_LABEL |
GRID_HEAD_TAG |
SECTION_BROKEN_DISPLAY_STYLE |
SECTION_COARSER_SCALE_PULLDOWN_IMPERIAL |
SECTION_COARSER_SCALE_PULLDOWN_METRIC |
SECTION_PARENT_VIEW_NAME |
SECTION_SHOW_IN_ONE_VIEW_ONLY |
SECTION_ATTR_TAIL_TAG |
SECTION_HIDE_LINE_PARAM |
SECTION_END2_MARK_PARAM |
SECTION_END1_MARK_PARAM |
SECTION_ATTR_TAIL_WIDTH |
SECTION_ATTR_TAIL_LENGTH |
SECTION_ATTR_HEAD_TAG |
KEEP_READABLE |
LEADER_LINE |
LEADER_OFFSET_SHEET |
SPOT_SLOPE_OFFSET_FROM_REFERENCE |
SPOT_SLOPE_SLOPE_REPRESENTATION |
SPOT_SLOPE_SLOPE_DIRECTION |
SPOT_ELEV_LOWER_VALUE |
SPOT_ELEV_SINGLE_OR_UPPER_VALUE |
SPOT_ELEV_IND_TYPE_ELEVATION |
SPOT_COORDINATE_INCLUDE_ELEVATION |
SPOT_COORDINATE_ELEVATION_SUFFIX |
SPOT_COORDINATE_ELEVATION_PREFIX |
SPOT_COORDINATE_BOTTOM_SUFFIX |
SPOT_COORDINATE_BOTTOM_PREFIX |
SPOT_COORDINATE_TOP_SUFFIX |
SPOT_COORDINATE_TOP_PREFIX |
SPOT_ELEV_LOWER_SUFFIX |
SPOT_ELEV_LOWER_PREFIX |
SPOT_ELEV_SINGLE_OR_UPPER_SUFFIX |
SPOT_ELEV_SINGLE_OR_UPPER_PREFIX |
BASELINE_DIM_OFFSET |
SPOT_ELEV_BEND_LEADER |
SPOT_ELEV_IND_TYPE_BOTTOM |
SPOT_ELEV_IND_TYPE_TOP |
SPOT_ELEV_IND_BOTTOM |
SPOT_ELEV_IND_TOP |
SPOT_ELEV_TEXT_LOCATION |
SPOT_ELEV_ROTATE_WITH_COMPONENT |
SPOT_ELEV_DISPLAY_ELEVATIONS |
ORDINATE_DIM_SETTING |
LINEAR_DIM_TYPE |
SPOT_DIM_LEADER |
DIM_STYLE_FLIPPED_DIM_LINE_EXTENSION |
DIM_STYLE_INTERIOR_TICK_MARK |
SPOT_COORDINATE_TEXT_ORIENTATION |
SPOT_TEXT_FROM_LEADER |
SPOT_COORDINATE_BASE |
SPOT_ELEV_READ_CONVENTION |
SPOT_ELEV_IND_TYPE |
SPOT_ELEV_BOT_VALUE |
SPOT_ELEV_TOP_VALUE |
SPOT_ELEV_TEXT_ORIENTATION |
SPOT_ELEV_IND_ELEVATION |
SPOT_ELEV_IND_EW |
SPOT_ELEV_IND_NS |
DIM_STYLE_READ_CONVENTION |
HEAVY_END_PEN |
DIM_STYLE_DIM_LINE_SNAP_DIST |
DIM_STYLE_CENTERLINE_TICK_MARK |
SPOT_ELEV_LINE_PEN |
SPOT_ELEV_TICK_MARK_PEN |
SPOT_ELEV_LEADER_ARROWHEAD |
SPOT_ELEV_RELATIVE_BASE |
SPOT_ELEV_FLIP_TEXT_VERT |
SPOT_ELEV_TEXT_HORIZ_OFFSET |
SPOT_ELEV_LEADER |
SPOT_ELEV_BASE |
SPOT_ELEV_SYMBOL |
DIM_STYLE_SHOW_OPENING_HT |
DIM_STYLE_CENTERLINE_PATTERN |
DIM_WITNS_LINE_EXTENSION_BELOW |
DIM_WITNS_LINE_CNTRL |
DIM_LINE_EXTENSION |
DIM_STYLE_CENTERLINE_SYMBOL |
DIM_TEXT_BACKGROUND |
DIM_STYLE_ANGULAR_UNITS |
DIM_STYLE_LINEAR_UNITS |
LEADER_ARROW_WIDTH |
ARROW_FILLED |
RADIAL_FILLED_TICK |
LINEAR_FILLED_TICK |
RADIAL_ARROW_WIDTH |
LINEAR_ARROW_WIDTH |
HEAVY_TICK_MARK_PEN |
DIM_VISIBLE |
RADIAL_TICK_SIZE |
LINEAR_TICK_SIZE |
VIEWPORT_STRETCH_FACTOR |
VIEWPORT_SCALE |
VIEWPORT_VIEW_NAME |
VIEWPORT_DETAIL_NUMBER |
VIEWPORT_CLIPPING |
RENDER_RPC_PROPERTIES |
FAMILY_SYMBOLIC_REP |
FAMILY_RENDERING_TYPE |
RENDER_RPC_FILENAME |
RENDER_PLANT_TRIM_HEIGHT |
RENDER_PLANT_HEIGHT |
RENDER_PLANT_NAME |
RENDER_ENVIRONMENT |
RENDER_TIMEDATEPLACE |
RENDER_SETTING_UPGRADE_USER_SET |
RENDER_SETTING_UPGRADE_DPI |
RENDER_SETTING_UPGRADE_SIZEY |
RENDER_SETTING_UPGRADE_SIZEX |
RENDER_SETTING_UPGRADE_BTYPE |
COLOR_SCHEME_LOCATION |
VIEW_DEPENDENCY |
VIEW_BACK_CLIPPING |
VIEW_GRAPH_SCHED_TOTAL_COLUMNS |
VIEW_UNDERLAY_ORIENTATION |
VIEW_DEFAULT_TEMPLATE |
VIEW_GRAPH_SCHED_NUMBER_COLUMNS |
VIEW_GRAPH_SCHED_GRID_WIDTH |
GRAPHIC_DISPLAY_OPTIONS |
MODEL_GRAPHICS_STYLE_ANON_DRAFT |
VIEW_REFERENCING_DETAIL |
VIEW_REFERENCING_SHEET |
VIEW_CAMERA_POSITION |
PLAN_VIEW_NORTH |
WALKTHROUGH_FRAMES_COUNT |
PLAN_VIEW_LEVEL |
MODEL_GRAPHICS_STYLE |
VIEW_VISIBLE_CATEGORIES |
VIEW_DISCIPLINE |
PLAN_VIEW_RANGE |
VIEW_MODEL_DISPLAY_MODE |
VIEW_SHOW_MASSING |
PLAN_VIEW_TOP_CLIP_HEIGHT |
VIEW_CLEAN_JOINS |
VIEW_SHEET_VIEWPORT_INFO |
PLAN_VIEW_SHOW_ELEMS_ABOVE |
PLAN_VIEW_CUT_PLANE_HEIGHT |
VIEW_DEPTH |
VIEW_UNDERLAY_ID |
VIEW_SCALE_PULLDOWN_IMPERIAL |
VIEW_SCALE_PULLDOWN_METRIC |
VIEW_SCALE |
VIEW_SCHEMA_SETTING_FOR_SYSTEM |
VIEW_SCHEMA_SETTING_FOR_BUILDING |
VIEW_FIXED_SKETCH_PLANE |
VIEW_NAME_DISABLED |
VIEW_DESCRIPTION |
VIEW_NAME |
VIEWER3D_RENDER_SETTINGS |
VIEWER3D_IMAGE_SETTINGS |
VIEWER3D_RAY_QUALITY_UPGRADE |
VIEWER3D_ARE_ELEMENT_UPGRADE |
VIEWER3D_TDP_ELEMENT_UPGRADE |
VIEWER_REFERENCE_LABEL_TEXT |
VIEWER_IS_REFERENCE |
VIEWER_REFERENCE_LABEL |
VIEWER_MODEL_CLIP_BOX_ACTIVE |
VIEWER_DETAIL_NUMBER |
VIEWER_SHEET_NUMBER |
VIEWER_BOUND_ACTIVE_NEAR |
VIEWER_BOUND_FAR_CLIPPING |
VIEWER_BOUND_ACTIVE_FAR |
VIEWER_BOUND_ACTIVE_BOTTOM |
VIEWER_BOUND_ACTIVE_TOP |
VIEWER_BOUND_ACTIVE_LEFT |
VIEWER_BOUND_ACTIVE_RIGHT |
VIEWER_BOUND_OFFSET_NEAR |
VIEWER_BOUND_OFFSET_FAR |
VIEWER_BOUND_OFFSET_BOTTOM |
VIEWER_BOUND_OFFSET_TOP |
VIEWER_BOUND_OFFSET_LEFT |
VIEWER_BOUND_OFFSET_RIGHT |
VIEWER_ANNOTATION_CROP_ACTIVE |
VIEWER_SHOW_UNCROPPED |
VIEWER_CROP_REGION_VISIBLE |
VIEWER_CROP_REGION_DISABLED |
VIEWER_CROP_REGION |
VIEWER_PERSPECTIVE_DISABLED |
VIEWER_PERSPECTIVE |
VIEWER_TARGET_ELEVATION |
VIEWER_OPTION_VISIBILITY |
VIEWER_EYE_ELEVATION |
DIM_DISPLAY_EQ |
DIM_NOT_MODIFIABLE |
DIM_SUFFIX |
DIM_PREFIX |
DIM_LABEL |
DIM_VALUE_ANGLE |
DIM_VALUE_LENGTH |
ELEM_REFERENCE_NAME_2D_XZ |
CURVE_ELEM_DEFINES_SLOPE |
RADIAL_ARRAY_ARC_RADIUS |
CURVE_DETERMINES_ORIENTATION |
DATUM_PLANE_DEFINES_WALL_CLOSURE |
CURVE_IS_DETAIL |
CURVE_ELEM_ARC_RADIUS |
CURVE_ELEM_ARC_RANGE |
CURVE_ELEM_ARC_END_ANGLE |
CURVE_ELEM_ARC_START_ANGLE |
CURVE_ELEM_LINE_ANGLE |
CURVE_ELEM_LENGTH |
ELEM_DELETABLE_IN_FAMILY |
ELEM_REFERENCE_NAME |
DATUM_PLANE_DEFINES_ORIGIN |
ELEM_IS_REFERENCE |
CURVE_ELEM_VISIBLE_TYPE |
FAMILY_PARAM_END |
FAMILY_PARAM_START |
COLUMN_LOCATION_MARK |
COLUMN_TOP_ATTACH_CUT_PARAM |
COLUMN_BASE_ATTACH_CUT_PARAM |
COLUMN_BASE_ATTACHED_PARAM |
COLUMN_TOP_ATTACHED_PARAM |
COLUMN_BASE_ATTACHMENT_OFFSET_PARAM |
COLUMN_TOP_ATTACHMENT_OFFSET_PARAM |
COLUMN_BASE_ATTACH_JUSTIFICATION_PARAM |
COLUMN_TOP_ATTACH_JUSTIFICATION_PARAM |
MATERIAL_PARAM_SHININESS |
MATERIAL_PARAM_SMOOTHNESS |
MATERIAL_PARAM_GLOW |
MATERIAL_PARAM_TRANSPARENCY |
MATERIAL_PARAM_COLOR |
SEEK_ITEM_ID |
OMNICLASS_DESCRIPTION |
OMNICLASS_CODE |
UNIFORMAT_DESCRIPTION |
UNIFORMAT_CODE |
CONTOUR_HEIGHT |
SLOPE_END_HEIGHT |
SLOPE_START_HEIGHT |
CEILING_HAS_THICKNESS_PARAM |
CEILING_THICKNESS_PARAM |
CEILING_HEIGHTABOVELEVEL_PARAM |
CEILING_THICKNESS |
CEILING_ATTR_COST_PARAM |
CEILING_ATTR_SYSTEMNAME_PARAM |
CEILING_ATTR_SPACING2_PARAM |
CEILING_ATTR_SPACING1_PARAM |
CEILING_ATTR_PATTERN_PARAM |
CEILING_ATTR_DEFAULT_HEIGHT_PARAM |
ANY_PATTERN_ID_PARAM_NO_NO |
FILL_PATTERN_ID_PARAM_NO_NO |
OBJECT_STYLE_MATERIAL_ID_PARAM |
WRAPPING_AT_INSERTS_PARAM |
WRAPPING_AT_ENDS_PARAM |
COARSE_SCALE_FILL_PATTERN_COLOR |
MODEL_CATEGORY_ID_PARAM |
HOST_ID_PARAM |
MATERIAL_ID_PARAM |
COARSE_SCALE_FILL_PATTERN_ID_PARAM |
ANY_PATTERN_ID_PARAM |
FILL_PATTERN_TYPE_PARAM |
WALL_STRUCTURE_ID_PARAM |
SURFACE_PATTERN_ID_PARAM |
FILL_PATTERN_ID_PARAM |
ID_PARAM |
ELEM_FAMILY_AND_TYPE_NAMES_PARAM |
ELEM_FAMILY_NAME_PARAM |
ELEM_TYPE_NAME_PARAM |
SCHEDULE_ROOM_PHASE_PARAM |
EDITED_BY |
SCHEDULE_TOP_LEVEL_OFFSET_PARAM |
SCHEDULE_BASE_LEVEL_OFFSET_PARAM |
SCHEDULE_TOP_LEVEL_PARAM |
SCHEDULE_BASE_LEVEL_PARAM |
SCHEDULE_LEVEL_PARAM |
ELEM_ROOM_ID |
ELEM_ROOM_NAME |
ELEM_ROOM_NUMBER |
ROOM_PARTITION_PARAM_DISABLED |
ROOM_PARTITION_PARAM |
ROOM_TAG_PARTITION_PARAM_DISABLED |
ROOM_TAG_PARTITION_PARAM |
ELEM_PARTITION_PARAM_DISABLED |
ELEM_PARTITION_PARAM |
ELEM_FAMILY_AND_TYPE_PARAM |
ELEM_FAMILY_PARAM |
ELEM_TYPE_PARAM |
ELEM_TYPE_LABEL |
BR_ORG_FILTER |
BR_ORG_FOLDERS |
ELEM_NAME_READONLY_PARAM |
ELEM_NAME_PARAM |
SYMBOL_FAMILY_AND_TYPE_NAMES_PARAM |
SYMBOL_FAMILY_NAME_PARAM |
SYMBOL_NAME_PARAM |
SYMBOL_ID_PARAM |
FLOOR_PARAM_SPAN_DIRECTION |
FLOOR_PARAM_IS_STRUCTURAL |
HOST_PERIMETER_COMPUTED |
LEVEL_PARAM |
FLOOR_HEIGHTABOVELEVEL_PARAM |
FLOOR_THICKNESS_PARAM |
FLOOR_ATTR_SCALLOP_EDGES_PARAM |
FLOOR_ATTR_DEFAULT_HEIGHT_PARAM |
FLOOR_ATTR_DEFAULT_THICKNESS_PARAM |
FLOOR_ATTR_HEIGHTABOVELEVEL_PARAM |
FLOOR_ATTR_THICKNESS_PARAM |
PROFILE_PARAM_ALONG_PATH |
PROFILE_FAM_TYPE_PLUS_NONE |
PROFILE2_ANGLE |
PROFILE2_FAM_TYPE |
PROFILE2_FLIPPED_HOR |
PROFILE2_OFFSET_Y |
PROFILE2_OFFSET_X |
PROFILE1_ANGLE |
PROFILE1_FAM_TYPE |
PROFILE1_FLIPPED_HOR |
PROFILE1_OFFSET_Y |
PROFILE1_OFFSET_X |
FAM_PROFILE_USAGE |
SWEEP_TRAJ_SEGMENTED |
SWEEP_MAX_SEG_ANGLE |
MODEL_OR_SYMBOLIC |
PROFILE_ANGLE |
PROFILE_FAM_TYPE |
PROFILE_FLIPPED_HOR |
PROFILE_OFFSET_Y |
PROFILE_OFFSET_X |
EXTRUSION_LENGTH |
MATERIAL_OR_PARAM_ID |
ELEMENT_IS_CUTTING_DISABLED |
CURVE_VISIBILITY_PARAM |
GEOM_VISIBILITY_PARAM |
ELEMENT_IS_CUTTING |
EXTRUSION_AUTO_PARAMS |
BLEND_END_PARAM |
BLEND_START_PARAM |
REVOLUTION_END_ANGLE |
REVOLUTION_START_ANGLE |
EXTRUSION_END_PARAM |
EXTRUSION_START_PARAM |
FACEROOF_OFFSET_PARAM |
FACEROOF_LEVEL_PARAM |
ROOF_FACES_LOCATION |
RELATED_TO_MASS |
ROOF_RAFTER_OR_TRUSS_TEXT_PARAM |
FASCIA_DEPTH_PARAM |
ROOF_EAVE_CUT_PARAM |
ROOF_RAFTER_OR_TRUSS_PARAM |
ROOF_BASE_LEVEL_PARAM |
CURVE_WALL_OFFSET_ROOFS |
CURVE_WALL_OFFSET |
ACTUAL_MAX_RIDGE_HEIGHT_PARAM |
ALLOW_MAX_RIDGE_HEIGHT_PARAM |
ROOF_UPTO_LEVEL_OFFSET_PARAM |
ROOF_UPTO_LEVEL_PARAM |
ROOF_LEVEL_OFFSET_PARAM |
ROOF_WIDTH_PARAM |
ROOF_CONSTRAINT_OFFSET_PARAM |
ROOF_CONSTRAINT_LEVEL_PARAM |
HOST_SSE_CURVED_EDGE_CONDITION_PARAM |
ROOF_ATTR_SCALLOP_EDGES_PARAM |
ROOF_ATTR_THICKNESS_PARAM |
ROOF_ATTR_DEFAULT_THICKNESS_PARAM |
CONTINUOUS_FOOTING_BREAK_AT_INSERTS_DISABLE |
CONTINUOUS_FOOTING_DEFAULT_END_EXTENSION_LENGTH |
STRUCTURAL_ANALYTICAL_TESSELLATE |
STRUCTURAL_ANALYTICAL_TESS_DEVIATION |
STRUCTURAL_ANALYTICAL_HARD_POINTS |
STRUCTURAL_BEND_DIR_ANGLE |
STRUCTURAL_DISPLAY_IN_HIDDEN_VIEWS_COLUMN |
STRUCTURAL_DISPLAY_IN_HIDDEN_VIEWS_FRAMING |
STRUCTURAL_ANALYTICAL_SKETCH_XY_AUTODETECT |
STRUCTURAL_ANALYTICAL_AUTODETECT |
STRUCTURAL_CONT_FOOTING_ANALYZES_AS |
STRUCTURAL_FOOTING_ANALYZES_AS |
STRUCTURAL_BRACE_ANALYZES_AS |
STRUCTURAL_BEAM_ANALYZES_AS |
STRUCTURAL_FLOOR_ANALYZES_AS |
STRUCTURAL_ANALYZES_AS |
STRUCTURAL_BEAM_CUTBACK_FOR_COLUMN |
BEAM_V_JUSTIFICATION_OTHER_VALUE |
STRUCTURAL_BEAM_ORIENTATION |
STRUCTURAL_BEAM_END1_ELEVATION |
STRUCTURAL_BEAM_END0_ELEVATION |
FAMILY_EXPORT_AS_GEOMETRY |
STRUCTURAL_FOUNDATION_LENGTH |
STRUCTURAL_FOUNDATION_WIDTH |
CONTINUOUS_FOOTING_LENGTH |
STRUCTURAL_PLATE_CONNECTION |
STRUCTURAL_WELD_CONNECTION |
CONTINUOUS_FOOTING_ECCENTRICITY |
CONTINUOUS_FOOTING_STRUCTURAL_USAGE |
CONTINUOUS_FOOTING_BEARING_WIDTH |
STRUCTURAL_FOOTING_BOTTOM_ELEVATION |
FAMILY_STRUCT_FOOTING_USE_CAP_TOP |
STRUCTURAL_COPING_DISTANCE |
CONTINUOUS_FOOTING_WIDTH |
CONTINUOUS_FOOTING_THICKNESS |
CONTINUOUS_FOOTING_BOTTOM_HEEL |
CONTINUOUS_FOOTING_TOP_HEEL |
CONTINUOUS_FOOTING_BOTTOM_TOE |
CONTINUOUS_FOOTING_TOP_TOE |
STRUCTURAL_ANALYTICAL_MODEL |
STRUCTURAL_ANALYTICAL_RIGID_LINK |
FAMILY_STRUCT_MATERIAL_TYPE |
STRUCTURAL_BOTTOM_RELEASE_MZ |
STRUCTURAL_BOTTOM_RELEASE_MY |
STRUCTURAL_BOTTOM_RELEASE_MX |
STRUCTURAL_BOTTOM_RELEASE_FZ |
STRUCTURAL_BOTTOM_RELEASE_FY |
STRUCTURAL_BOTTOM_RELEASE_FX |
STRUCTURAL_TOP_RELEASE_MZ |
STRUCTURAL_TOP_RELEASE_MY |
STRUCTURAL_TOP_RELEASE_MX |
STRUCTURAL_TOP_RELEASE_FZ |
STRUCTURAL_TOP_RELEASE_FY |
STRUCTURAL_TOP_RELEASE_FX |
STRUCTURAL_BOTTOM_RELEASE_TYPE |
STRUCTURAL_TOP_RELEASE_TYPE |
STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE_COLUMN_BOTTOM |
STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE_COLUMN_TOP |
STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE_WALL_BOTTOM |
STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE_WALL_TOP |
STRUCTURAL_MATERIAL_TYPE |
STRUCTURAL_CAMBER |
STRUCTURAL_NUMBER_OF_STUDS |
STRUCTURAL_END_RELEASE_MZ |
STRUCTURAL_END_RELEASE_MY |
STRUCTURAL_END_RELEASE_MX |
STRUCTURAL_END_RELEASE_FZ |
STRUCTURAL_END_RELEASE_FY |
STRUCTURAL_END_RELEASE_FX |
STRUCTURAL_START_RELEASE_MZ |
STRUCTURAL_START_RELEASE_MY |
STRUCTURAL_START_RELEASE_MX |
STRUCTURAL_START_RELEASE_FZ |
STRUCTURAL_START_RELEASE_FY |
STRUCTURAL_START_RELEASE_FX |
STRUCTURAL_END_RELEASE_TYPE |
STRUCTURAL_START_RELEASE_TYPE |
STRUCTURAL_WALL_BOTTOM_PROJECTION_PLANE |
STRUCTURAL_WALL_TOP_PROJECTION_PLANE |
STRUCTURAL_WALL_PROJECTION_SURFACE |
STRUCTURAL_COLUMN_ANALYTICAL_OFFSET |
STRUCTURAL_ANALYTICAL_PROJECT_FLOOR_PLANE |
STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE_BOTTOM |
STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE |
STRUCTURAL_BRACE_REPRESENTATION |
STRUCTURAL_CONNECTION_TYPE |
STRUCTURAL_MOMENT_CONN_END |
STRUCTURAL_MOMENT_CONN_START |
STRUCTURAL_STICK_SYMBOL_LOCATION |
STRUCTURAL_BEAM_END_SUPPORT |
STRUCTURAL_BEAM_START_SUPPORT |
WINDOW_INSET_PARAM |
WINDOW_TYPE_USER_PARAM_LAST |
WINDOW_TYPE_USER_PARAM_FIRST |
WINDOW_OPERATION_TYPE |
WINDOW_CONSTRUCTION_TYPE |
WINDOW_INSET |
WINDOW_THICKNESS |
WINDOW_WIDTH |
WINDOW_HEIGHT |
WINDOW_TYPE_ID |
WINDOW_DEFAULT_SILL_HEIGHT_PARAM |
WINDOW_OPENING_HEIGHT_PARAM |
WINDOW_JAMB_DEPTH_PARAM |
WINDOW_JAMB_WIDTH_PARAM |
WINDOW_OPENING_WIDTH_PARAM |
STRUCTURAL_ATTACHMENT_END_VALUE_ELEVATION |
STRUCTURAL_ATTACHMENT_START_VALUE_ELEVATION |
STRUCTURAL_ATTACHMENT_END_LEVEL_REFERENCE |
STRUCTURAL_ATTACHMENT_START_LEVEL_REFERENCE |
STRUCTURAL_ATTACHMENT_END_VALUE_RATIO |
STRUCTURAL_ATTACHMENT_START_VALUE_RATIO |
STRUCTURAL_ATTACHMENT_END_REFELEMENT_END |
TYPE_WALL_CLOSURE |
STRUCTURAL_ATTACHMENT_START_REFELEMENT_END |
STRUCTURAL_ATTACHMENT_END_VALUE_DISTANCE |
STRUCTURAL_ATTACHMENT_START_VALUE_DISTANCE |
STRUCTURAL_ATTACHMENT_END_TYPE |
STRUCTURAL_ATTACHMENT_START_TYPE |
STRUCTURAL_FRAME_CUT_LENGTH |
INSTANCE_REFERENCE_LEVEL_PARAM |
INSTANCE_STRUCT_USAGE_TEXT_PARAM |
INSTANCE_STRUCT_USAGE_PARAM |
SKETCH_PLANE_PARAM |
INSTANCE_STRUCT_INSERTION_PARAM |
INSTANCE_STRUCT_SETBACK1_PARAM |
INSTANCE_STRUCT_SETBACK0_PARAM |
INSTANCE_LENGTH_PARAM |
INSTANCE_MOVES_WITH_GRID_PARAM |
INSTANCE_OFFSET_POS_PARAM |
INSTANCE_SCHEDULE_ONLY_LEVEL_PARAM |
INSTANCE_FREE_HOST_OFFSET_PARAM |
INSTANCE_FREE_HOST_PARAM |
INSTANCE_HEAD_HEIGHT_PARAM |
INSTANCE_SILL_HEIGHT_PARAM |
INSTANCE_ELEVATION_PARAM |
FAMILY_TOP_LEVEL_OFFSET_PARAM_DISABLED |
FAMILY_TOP_LEVEL_OFFSET_PARAM |
FAMILY_BASE_LEVEL_OFFSET_PARAM |
TEMP_SCHEDULE_CATEGORY_PARAM |
FAMILY_LEVEL_PARAM_DISABLED |
FAMILY_TOP_LEVEL_PARAM_DISABLED |
FAMILY_BASE_LEVEL_PARAM_DISABLED |
FAMILY_LEVEL_PARAM |
FAMILY_TOP_LEVEL_PARAM |
FAMILY_BASE_LEVEL_PARAM |
FAMILY_RFA_PATH_PSEUDO_PARAM |
FAMILY_CATEGORY_PSEUDO_PARAM |
FAMILY_NAME_PSEUDO_PARAM |
FAMILY_USAGE_PSEUDO_PARAM |
FAMILY_KEYWORD2 |
FAMILY_KEYWORD1 |
FAMILY_CLASS_CODE |
FAMILY_DESCRIPTION |
FAMILY_MANUFACTURER |
FAMILY_WPB_DEFAULT_ELEVATION |
FAMILY_LINE_LENGTH_PARAM |
FAMILY_ROUGH_WIDTH_PARAM |
FAMILY_ROUGH_HEIGHT_PARAM |
FAMILY_WINDOW_INSET_PARAM |
FAMILY_THICKNESS_PARAM |
FAMILY_WIDTH_PARAM |
FAMILY_HEIGHT_PARAM |
DOOR_THICKNESS |
DOOR_WIDTH |
DOOR_HEIGHT |
DOOR_USER_PARAM_LAST |
DOOR_USER_PARAM_FIRST |
DOOR_OPERATION_TYPE |
DOOR_FRAME_MATERIAL |
DOOR_FRAME_TYPE |
DOOR_FINISH |
DOOR_CONSTRUCTION_TYPE |
DOOR_FIRE_RATING |
DOOR_COST |
DOOR_SYMBOL_ID |
DOOR_NUMBER |
DOOR_HEIGHT_PARAM_OBSOLETE |
DOOR_THICKNESS_PARAM_OBSOLETE |
DOOR_WIDTH_PARAM_OBSOLETE |
HOST_PANEL_SCHEDULE_AS_PANEL_PARAM |
WALL_LOCATION_LINE_OFFSET_PARAM |
WALL_KEY_REF_PARAM |
WALL_STRUCTURAL_USAGE_TEXT_PARAM |
MEASURE_FROM_STRUCTURE |
WALL_STRUCTURAL_USAGE_PARAM |
WALL_BOTTOM_IS_ATTACHED |
WALL_TOP_IS_ATTACHED |
CWALL_FAKE_END_PARAM_1 |
CWALL_FAKE_END_PARAM_0 |
WALL_ADDITIONAL_HEIGHT_CONSTRAINT_UPGRADE |
WALL_HEIGHT_CONSTRAINT_UPGRADE |
WALL_BASE_CONSTRAINT_UPGRADE |
WALL_BASE_OFFSET_COMPUTED |
WALL_ADDITIONAL_TOP_REF |
WALL_TOP_OFFSET |
WALL_BASE_OFFSET |
WALL_BASE_CONSTRAINT |
WALL_TYPE_ID |
WALL_USER_HEIGHT_PARAM |
WALL_UP_TO_LEVEL_ID |
WALL_HEIGHT_TYPE |
WALL_BASE_HEIGHT_PARAM |
WALL_HEIGHT_PARAM |
WALL_WIDTH_PARAM |
ALLOW_AUTO_EMBED |
WALL_FLOOR_ATTACHMENT_TYPE |
WALL_ATTR_ROOM_BOUNDING |
FUNCTION_PARAM |
WALL_DEF_CNSTR_HEIGHT_TYPE_ALT |
WALL_DEF_CNSTR_HEIGHT_TYPE |
WALL_ATTR_HEIGHT_TYPE |
WALL_ATTR_DEFHEIGHT_PARAM |
WALL_ATTR_HEIGHT_PARAM |
WALL_ATTR_WIDTH_PARAM |
RENDER_STYLE_PARAM |
INVALID |

Remarks

Revit has a large number of built-in parameters. Given the large number of built in parameters please contact Autodesk ADN support for details on a particular parameter. The ID of the parameter can be used to retrieve the specific parameter from an Element, if it exists, by using the Element.Parameter property.

See Also

Autodesk.Revit.Parameters Namespace


BuiltInParameterGroup Enumeration

[image]

Revit 2010 API
BuiltInParameterGroup Enumeration
See Also Send Feedback
An enumerate type listing all of the built-in parameter groups supported by Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum BuiltInParameterGroup
Visual Basic (Declaration)
Public Enumeration BuiltInParameterGroup
Visual C++
public enum class BuiltInParameterGroup

Members

Member name | Description
PG_AREA |
PG_ADSK_MODEL_PROPERTIES |
PG_PATTERN_GRID_V |
PG_PATTERN_GRID_U |
PG_DISPLAY |
PG_ANALYSIS_RESULTS |
PG_SLAB_SHAPE_EDIT |
PG_LIGHT_PHOTOMETRICS |
PG_PATTERN_APPLICATION |
PG_GREEN_BUILDING |
PG_PROFILE_2 |
PG_PROFILE_1 |
PG_PROFILE |
PG_TRUSS_FAMILY_BOTTOM_CHORD |
PG_TRUSS_FAMILY_TOP_CHORD |
PG_TRUSS_FAMILY_DIAG_WEB |
PG_TRUSS_FAMILY_VERT_WEB |
PG_TITLE |
PG_FIRE_PROTECTION |
PG_ROTATION_ABOUT |
PG_TRANSLATION_IN |
PG_ANALYTICAL_MODEL |
PG_REBAR_ARRAY |
PG_REBAR_SYSTEM_LAYERS |
PG_ORIENTATION |
PG_PATTERN_GRID |
PG_PATTERN_MULLION_2 |
PG_PATTERN_MULLION_HORIZ |
PG_PATTERN_MULLION_1 |
PG_PATTERN_MULLION_VERT |
PG_PATTERN_GRID_2 |
PG_PATTERN_GRID_HORIZ |
PG_PATTERN_GRID_1 |
PG_PATTERN_GRID_VERT |
PG_IFC |
PG_AELECTRICAL |
PG_ENERGY_ANALYSIS |
PG_STRUCTURAL_ANALYSIS |
PG_MECHANICAL_AIRFLOW |
PG_MECHANICAL_LOADS |
PG_ELECTRICAL_LOADS |
PG_ELECTRICAL_LIGHTING |
PG_TEXT |
PG_VIEW_CAMERA |
PG_VIEW_EXTENTS |
PG_PATTERN |
PG_CONSTRAINTS |
PG_PHASING |
PG_MECHANICAL |
PG_STRUCTURAL |
PG_PLUMBING |
PG_ELECTRICAL |
PG_STAIR_STRINGERS |
PG_STAIR_RISERS |
PG_STAIR_TREADS |
PG_MATERIALS |
PG_GRAPHICS |
PG_CONSTRUCTION |
PG_GEOMETRY |
PG_IDENTITY_DATA |
INVALID |

Remarks

Parameter groups are used to sort parameters within the Element Properties dialog.

See Also

Autodesk.Revit.Parameters Namespace


ConstructionType Enumeration

[image]

Revit 2010 API
ConstructionType Enumeration
See Also Send Feedback
An enumerate type listing all of the built-in construction types supported by Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ConstructionType
Visual Basic (Declaration)
Public Enumeration ConstructionType
Visual C++
public enum class ConstructionType

Members

Member name | Description
Skylights | Construction Type is Skylights.
InteriorWindows | Construction Type is InteriorWindows.
ExteriorWindows | Construction Type is ExteriorWindows.
Doors | Construction Type is Doors.
Floors | Construction Type is Floors.
Roofs | Construction Type is Roofs.
Slabs | Construction Type is Slabs.
InteriorWalls | Construction Type is InteriorWalls.
ExteriorWalls | Construction Type is ExteriorWalls.

See Also

Autodesk.Revit.Parameters Namespace


Definition Class

[image]

Revit 2010 API
Definition Class
Members See Also Send Feedback
The Definition object is a base object for all type of parameter definitions within the Autodesk Revit API.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class Definition : APIObject
Visual Basic (Declaration)
Public MustInherit Class Definition _
    Inherits APIObject
Visual C++
public ref class Definition abstract : public APIObject

Remarks

This object supports properties and methods that report the name and type of a particular parameter. There are two kinds of definition object derived from this: InternalDefinition which represents all kinds of definitions existing entirely within the Autodesk Revit database. ExternalDefinitions represent definitions stored on disk in a shared parameters file. Most of the time code should be written to utilise this Definition base class as then the code will be applicable to both internal and external parameter definitions.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.Definition
Autodesk.Revit.Parameters..::.ExternalDefinition
Autodesk.Revit.Parameters..::.InternalDefinition

See Also

Definition Members
Autodesk.Revit.Parameters Namespace


Definition Members

[image] [image]

Revit 2010 API
Definition Members
Definition Class Constructors Methods Properties See Also Send Feedback

The Definition type exposes the following members.

Constructors

Name | Description
Definition | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | The user visible name for the parameter.
ParameterGroup | Returns the group ID of the parameter definition.
ParameterType | Returns the user visible interpretation of the parameter data.

See Also

Definition Class
Autodesk.Revit.Parameters Namespace


Definition Constructor

[image]

Revit 2010 API
Definition Constructor
Definition Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Definition()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Definition()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Definition Class
Autodesk.Revit.Parameters Namespace


Definition Methods

[image] [image]

Revit 2010 API
Definition Methods
Definition Class See Also Send Feedback

The Definition type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Definition Class
Autodesk.Revit.Parameters Namespace


Definition Properties

[image] [image]

Revit 2010 API
Definition Properties
Definition Class See Also Send Feedback

The Definition type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | The user visible name for the parameter.
ParameterGroup | Returns the group ID of the parameter definition.
ParameterType | Returns the user visible interpretation of the parameter data.

See Also

Definition Class
Autodesk.Revit.Parameters Namespace


Name Property

[image]

Revit 2010 API
Definition..::.Name Property
Definition Class See Also Send Feedback
The user visible name for the parameter.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract string Name { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () abstract;
}

See Also

Definition Class
Autodesk.Revit.Parameters Namespace


ParameterGroup Property

[image]

Revit 2010 API
Definition..::.ParameterGroup Property
Definition Class See Also Send Feedback
Returns the group ID of the parameter definition.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract BuiltInParameterGroup ParameterGroup { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property ParameterGroup As BuiltInParameterGroup
Visual C++
public:
virtual property BuiltInParameterGroup ParameterGroup {
    BuiltInParameterGroup get () abstract;
}

See Also

Definition Class
Autodesk.Revit.Parameters Namespace


ParameterType Property

[image]

Revit 2010 API
Definition..::.ParameterType Property
Definition Class Example See Also Send Feedback
Returns the user visible interpretation of the parameter data.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract ParameterType ParameterType { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property ParameterType As ParameterType
Visual C++
public:
virtual property ParameterType ParameterType {
    ParameterType get () abstract;
}

Remarks

The data within the parameter is stored in a very simple manner as an integer, double, string or an element id, but to the user these values may be more meaningful as Length, Volume, Mass etc. This parameter returns the interpretation that should be used for the data.

Examples

CopyC#
//Find parameter using the Parameter�s definition type.
public Parameter FindParameter(Element element)
{
    Parameter foundParameter = null;
    // This will find the first parameter that measures length
    foreach (Parameter parameter in element.Parameters)
    {
        if (parameter.Definition.ParameterType == ParameterType.Length)
        {
            foundParameter = parameter;
            break;
        }
    }
    return foundParameter;
}
CopyVB.NET
'Find parameter using the Parameter’s definition type.
Public Function FindParameter(ByVal element As Autodesk.Revit.Element) As Parameter
    Dim foundParameter As Parameter = Nothing
    ' This will find the first parameter that measures length
    For Each parameter As Parameter In element.Parameters
        If parameter.Definition.ParameterType = ParameterType.Length Then
            foundParameter = parameter
            Exit For
        End If
    Next
    Return foundParameter
End Function

See Also

Definition Class
Autodesk.Revit.Parameters Namespace


DefinitionFile Class

[image]

Revit 2010 API
DefinitionFile Class
Members Example See Also Send Feedback
The DefinitionFile object represents a shared parameters file on disk.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DefinitionFile : APIObject
Visual Basic (Declaration)
Public Class DefinitionFile _
    Inherits APIObject
Visual C++
public ref class DefinitionFile : public APIObject

Remarks

Shared Parameters are parameter definitions that are stored in a text file external to the Autodesk Revit project. These definitions can be used in multiple projects and are identifiable by a unique identifier generated when they are created. API access to shared parameters consist of a number of objects, the first of which is an object that represents the shared parameters file on disk. That object then contains a number of Group objects. Shared parameters are grouped for easier management. These groups then contain the shared parameter definitions. The groups support the ability to create new shared parameter definitions. The DefinitionFile object can be retrieved by the Document.OpenSharedParameterFile method.

Examples

CopyC#
private void ShowDefinitionFileInfo(DefinitionFile myDefinitionFile)
{
    StringBuilder fileInformation = new StringBuilder(500);

    // get the file name
    fileInformation.AppendLine("File Name: " + myDefinitionFile.Filename);

    // iterate the Definition groups of this file
    foreach (DefinitionGroup myGroup in myDefinitionFile.Groups)
    {
        // get the group name
        fileInformation.AppendLine("Group Name: " + myGroup.Name);

        // iterate the difinitions
        foreach (Definition definition in myGroup.Definitions)
        {
            // get definition name
            fileInformation.AppendLine("Definition Name: " + definition.Name);
        }
    }
    MessageBox.Show(fileInformation.ToString(), "Revit");
}
CopyVB.NET
Private Sub ShowDefinitionFileInfo(ByVal myDefinitionFile As DefinitionFile)
    Dim fileInformation As New StringBuilder(500)

    ' get the file name
    fileInformation.AppendLine("File Name: " & myDefinitionFile.Filename)

    ' iterate the Definition groups of this file
    For Each myGroup As DefinitionGroup In myDefinitionFile.Groups
        ' get the group name
        fileInformation.AppendLine("Group Name: " & myGroup.Name)

        ' iterate the difinitions
        For Each definition As Definition In myGroup.Definitions
            ' get definition name
            fileInformation.AppendLine("Definition Name: " & definition.Name)
        Next
    Next
    MessageBox.Show(fileInformation.ToString(), "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.DefinitionFile

See Also

DefinitionFile Members
Autodesk.Revit.Parameters Namespace


DefinitionFile Members

[image] [image]

Revit 2010 API
DefinitionFile Members
DefinitionFile Class Constructors Methods Properties See Also Send Feedback

The DefinitionFile type exposes the following members.

Constructors

Name | Description
DefinitionFile | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Filename | This property returns the physical filename of the shared parameters file on disk.
Groups | Return a map of shared parameter definition groups contained within the file.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionFile Class
Autodesk.Revit.Parameters Namespace


DefinitionFile Constructor

[image]

Revit 2010 API
DefinitionFile Constructor
DefinitionFile Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DefinitionFile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionFile()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DefinitionFile Class
Autodesk.Revit.Parameters Namespace


DefinitionFile Methods

[image] [image]

Revit 2010 API
DefinitionFile Methods
DefinitionFile Class See Also Send Feedback

The DefinitionFile type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionFile Class
Autodesk.Revit.Parameters Namespace


DefinitionFile Properties

[image] [image]

Revit 2010 API
DefinitionFile Properties
DefinitionFile Class See Also Send Feedback

The DefinitionFile type exposes the following members.

Properties

Name | Description
Filename | This property returns the physical filename of the shared parameters file on disk.
Groups | Return a map of shared parameter definition groups contained within the file.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionFile Class
Autodesk.Revit.Parameters Namespace


Filename Property

[image]

Revit 2010 API
DefinitionFile..::.Filename Property
DefinitionFile Class See Also Send Feedback
This property returns the physical filename of the shared parameters file on disk.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Filename { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filename As String
Visual C++
public:
property String^ Filename {
    String^ get ();
}

See Also

DefinitionFile Class
Autodesk.Revit.Parameters Namespace


Groups Property

[image]

Revit 2010 API
DefinitionFile..::.Groups Property
DefinitionFile Class See Also Send Feedback
Return a map of shared parameter definition groups contained within the file.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DefinitionGroups Groups { get; }
Visual Basic (Declaration)
Public ReadOnly Property Groups As DefinitionGroups
Visual C++
public:
property DefinitionGroups^ Groups {
    DefinitionGroups^ get ();
}

Remarks

A particular group can be found by Name, using the Item property on the DefinitionGroups object. A new group can be created by using the Create method on the DefinitionGroups Object. The Create method takes the name of the new group, as a string, as its input parameter, returning a reference to a new definition group object as its result.

See Also

DefinitionFile Class
Autodesk.Revit.Parameters Namespace


DefinitionGroup Class

[image]

Revit 2010 API
DefinitionGroup Class
Members See Also Send Feedback
The DefinitionGroup is a container that is used to hold shared parameter definitions on disk.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DefinitionGroup : APIObject
Visual Basic (Declaration)
Public Class DefinitionGroup _
    Inherits APIObject
Visual C++
public ref class DefinitionGroup : public APIObject

Remarks

Groups are used for logical arrangement of the shared parameters into meaningful sets. Through the DefinitionGroup object new shared parameter definitions can be made.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.DefinitionGroup

See Also

DefinitionGroup Members
Autodesk.Revit.Parameters Namespace


DefinitionGroup Members

[image] [image]

Revit 2010 API
DefinitionGroup Members
DefinitionGroup Class Constructors Methods Properties See Also Send Feedback

The DefinitionGroup type exposes the following members.

Constructors

Name | Description
DefinitionGroup | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Definitions | The Definitions property returns an object that contains all the shared parameter definitions within the group.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Returns the name of the parameter group.

See Also

DefinitionGroup Class
Autodesk.Revit.Parameters Namespace


DefinitionGroup Constructor

[image]

Revit 2010 API
DefinitionGroup Constructor
DefinitionGroup Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DefinitionGroup()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionGroup()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DefinitionGroup Class
Autodesk.Revit.Parameters Namespace


DefinitionGroup Methods

[image] [image]

Revit 2010 API
DefinitionGroup Methods
DefinitionGroup Class See Also Send Feedback

The DefinitionGroup type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionGroup Class
Autodesk.Revit.Parameters Namespace


DefinitionGroup Properties

[image] [image]

Revit 2010 API
DefinitionGroup Properties
DefinitionGroup Class See Also Send Feedback

The DefinitionGroup type exposes the following members.

Properties

Name | Description
Definitions | The Definitions property returns an object that contains all the shared parameter definitions within the group.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Returns the name of the parameter group.

See Also

DefinitionGroup Class
Autodesk.Revit.Parameters Namespace


Definitions Property

[image]

Revit 2010 API
DefinitionGroup..::.Definitions Property
DefinitionGroup Class See Also Send Feedback
The Definitions property returns an object that contains all the shared parameter definitions within the group.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Definitions Definitions { get; }
Visual Basic (Declaration)
Public ReadOnly Property Definitions As Definitions
Visual C++
public:
property Definitions^ Definitions {
    Definitions^ get ();
}

Remarks

A known definition can be retrieved, by name, using the Item property on the Definitions object. A new definition can be created by using the Create method. The Create method takes two parameters, a string for name and a type. If the creation of the definition was successful then an object representing the definition is returned by the Create method.

See Also

DefinitionGroup Class
Autodesk.Revit.Parameters Namespace


Name Property

[image]

Revit 2010 API
DefinitionGroup..::.Name Property
DefinitionGroup Class See Also Send Feedback
Returns the name of the parameter group.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

DefinitionGroup Class
Autodesk.Revit.Parameters Namespace


DefinitionGroups Class

[image]

Revit 2010 API
DefinitionGroups Class
Members See Also Send Feedback
A specialised set of definition groups that allows creation of new groups.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DefinitionGroups : DefinitionGroupsBase
Visual Basic (Declaration)
Public Class DefinitionGroups _
    Inherits DefinitionGroupsBase
Visual C++
public ref class DefinitionGroups : public DefinitionGroupsBase

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.DefinitionGroupsBase
Autodesk.Revit.Parameters..::.DefinitionGroups

See Also

DefinitionGroups Members
Autodesk.Revit.Parameters Namespace


DefinitionGroups Members

[image] [image]

Revit 2010 API
DefinitionGroups Members
DefinitionGroups Class Constructors Methods Properties See Also Send Feedback

The DefinitionGroups type exposes the following members.

Constructors

Name | Description
DefinitionGroups | For Internal Use Only.

Methods

Name | Description
Clear | Removes every definition group from the set, rendering it empty. (Inherited from DefinitionGroupsBase.)
Contains | Tests for the existence of a definition group within the set. (Inherited from DefinitionGroupsBase.)
Create | Create a new parameter definition group using the name provided.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from DefinitionGroupsBase.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Retrieve a definition group by name.
Size | Returns the number of definition groups that are in the set. (Inherited from DefinitionGroupsBase.)

See Also

DefinitionGroups Class
Autodesk.Revit.Parameters Namespace


DefinitionGroups Constructor

[image]

Revit 2010 API
DefinitionGroups Constructor
DefinitionGroups Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DefinitionGroups()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionGroups()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DefinitionGroups Class
Autodesk.Revit.Parameters Namespace


DefinitionGroups Methods

[image] [image]

Revit 2010 API
DefinitionGroups Methods
DefinitionGroups Class See Also Send Feedback

The DefinitionGroups type exposes the following members.

Methods

Name | Description
Clear | Removes every definition group from the set, rendering it empty. (Inherited from DefinitionGroupsBase.)
Contains | Tests for the existence of a definition group within the set. (Inherited from DefinitionGroupsBase.)
Create | Create a new parameter definition group using the name provided.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionGroups Class
Autodesk.Revit.Parameters Namespace


Create Method

[image]

Revit 2010 API
DefinitionGroups..::.Create Method
DefinitionGroups Class See Also Send Feedback
Create a new parameter definition group using the name provided.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DefinitionGroup Create(
    string name
)
Visual Basic (Declaration)
Public Function Create ( _
    name As String _
) As DefinitionGroup
Visual C++
public:
DefinitionGroup^ Create(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the group to be created.

Return Value

If successful a reference to the new parameter group is returned, otherwise Nothing.

Remarks

If a group with the same name already exists then an exception will be thrown.

See Also

DefinitionGroups Class
Autodesk.Revit.Parameters Namespace


DefinitionGroups Properties

[image] [image]

Revit 2010 API
DefinitionGroups Properties
DefinitionGroups Class See Also Send Feedback

The DefinitionGroups type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from DefinitionGroupsBase.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Retrieve a definition group by name.
Size | Returns the number of definition groups that are in the set. (Inherited from DefinitionGroupsBase.)

See Also

DefinitionGroups Class
Autodesk.Revit.Parameters Namespace


Item Property

[image]

Revit 2010 API
DefinitionGroups..::.Item Property
DefinitionGroups Class See Also Send Feedback
Retrieve a definition group by name.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DefinitionGroup Item[
    string groupName
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Item ( _
    groupName As String _
) As DefinitionGroup
Visual C++
public:
property DefinitionGroup^ Item[String^ groupName] {
    DefinitionGroup^ get (String^ groupName);
}

Parameters

groupName
Type: System..::.String
The name of the group for which to search.

Remarks

If the group is not found then Nothing will be returned.

See Also

DefinitionGroups Class
Autodesk.Revit.Parameters Namespace


DefinitionGroupsBase Class

[image]

Revit 2010 API
DefinitionGroupsBase Class
Members See Also Send Feedback
A set that contains definition groups.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DefinitionGroupsBase : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class DefinitionGroupsBase _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DefinitionGroupsBase : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.DefinitionGroupsBase
Autodesk.Revit.Parameters..::.DefinitionGroups

See Also

DefinitionGroupsBase Members
Autodesk.Revit.Parameters Namespace


DefinitionGroupsBase Members

[image] [image]

Revit 2010 API
DefinitionGroupsBase Members
DefinitionGroupsBase Class Constructors Methods Properties See Also Send Feedback

The DefinitionGroupsBase type exposes the following members.

Constructors

Name | Description
DefinitionGroupsBase | Initializes a new instance of the DefinitionGroupsBase class

Methods

Name | Description
Clear | Removes every definition group from the set, rendering it empty.
Contains | Tests for the existence of a definition group within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of definition groups that are in the set.

See Also

DefinitionGroupsBase Class
Autodesk.Revit.Parameters Namespace


DefinitionGroupsBase Constructor

[image]

Revit 2010 API
DefinitionGroupsBase Constructor
DefinitionGroupsBase Class See Also Send Feedback
Initializes a new instance of the DefinitionGroupsBase class

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DefinitionGroupsBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionGroupsBase()

See Also

DefinitionGroupsBase Class
Autodesk.Revit.Parameters Namespace


DefinitionGroupsBase Methods

[image] [image]

Revit 2010 API
DefinitionGroupsBase Methods
DefinitionGroupsBase Class See Also Send Feedback

The DefinitionGroupsBase type exposes the following members.

Methods

Name | Description
Clear | Removes every definition group from the set, rendering it empty.
Contains | Tests for the existence of a definition group within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionGroupsBase Class
Autodesk.Revit.Parameters Namespace


Clear Method

[image]

Revit 2010 API
DefinitionGroupsBase..::.Clear Method
DefinitionGroupsBase Class See Also Send Feedback
Removes every definition group from the set, rendering it empty.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DefinitionGroupsBase Class
Autodesk.Revit.Parameters Namespace


Contains Method

[image]

Revit 2010 API
DefinitionGroupsBase..::.Contains Method
DefinitionGroupsBase Class See Also Send Feedback
Tests for the existence of a definition group within the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    DefinitionGroup item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As DefinitionGroup _
) As Boolean
Visual C++
public:
virtual bool Contains(
    DefinitionGroup^ item
)

Parameters

item
Type: Autodesk.Revit.Parameters..::.DefinitionGroup
The definition group to be searched for.

Return Value

The Contains method returns True if the definition group is within the set, otherwise False.

See Also

DefinitionGroupsBase Class
Autodesk.Revit.Parameters Namespace


ForwardIterator Method

[image]

Revit 2010 API
DefinitionGroupsBase..::.ForwardIterator Method
DefinitionGroupsBase Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DefinitionGroupsBaseIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DefinitionGroupsBaseIterator
Visual C++
public:
virtual DefinitionGroupsBaseIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

DefinitionGroupsBase Class
Autodesk.Revit.Parameters Namespace


GetEnumerator Method

[image]

Revit 2010 API
DefinitionGroupsBase..::.GetEnumerator Method
DefinitionGroupsBase Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DefinitionGroupsBase Class
Autodesk.Revit.Parameters Namespace


ReverseIterator Method

[image]

Revit 2010 API
DefinitionGroupsBase..::.ReverseIterator Method
DefinitionGroupsBase Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DefinitionGroupsBaseIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DefinitionGroupsBaseIterator
Visual C++
public:
virtual DefinitionGroupsBaseIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

DefinitionGroupsBase Class
Autodesk.Revit.Parameters Namespace


DefinitionGroupsBase Properties

[image] [image]

Revit 2010 API
DefinitionGroupsBase Properties
DefinitionGroupsBase Class See Also Send Feedback

The DefinitionGroupsBase type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of definition groups that are in the set.

See Also

DefinitionGroupsBase Class
Autodesk.Revit.Parameters Namespace


IsEmpty Property

[image]

Revit 2010 API
DefinitionGroupsBase..::.IsEmpty Property
DefinitionGroupsBase Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

DefinitionGroupsBase Class
Autodesk.Revit.Parameters Namespace


Size Property

[image]

Revit 2010 API
DefinitionGroupsBase..::.Size Property
DefinitionGroupsBase Class See Also Send Feedback
Returns the number of definition groups that are in the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DefinitionGroupsBase Class
Autodesk.Revit.Parameters Namespace


DefinitionGroupsBaseIterator Class

[image]

Revit 2010 API
DefinitionGroupsBaseIterator Class
Members See Also Send Feedback
An iterator to a definition group set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class DefinitionGroupsBaseIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class DefinitionGroupsBaseIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DefinitionGroupsBaseIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.DefinitionGroupsBaseIterator

See Also

DefinitionGroupsBaseIterator Members
Autodesk.Revit.Parameters Namespace


DefinitionGroupsBaseIterator Members

[image] [image]

Revit 2010 API
DefinitionGroupsBaseIterator Members
DefinitionGroupsBaseIterator Class Constructors Methods Properties See Also Send Feedback

The DefinitionGroupsBaseIterator type exposes the following members.

Constructors

Name | Description
DefinitionGroupsBaseIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionGroupsBaseIterator Class
Autodesk.Revit.Parameters Namespace


DefinitionGroupsBaseIterator Constructor

[image]

Revit 2010 API
DefinitionGroupsBaseIterator Constructor
DefinitionGroupsBaseIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DefinitionGroupsBaseIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionGroupsBaseIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DefinitionGroupsBaseIterator Class
Autodesk.Revit.Parameters Namespace


DefinitionGroupsBaseIterator Methods

[image] [image]

Revit 2010 API
DefinitionGroupsBaseIterator Methods
DefinitionGroupsBaseIterator Class See Also Send Feedback

The DefinitionGroupsBaseIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionGroupsBaseIterator Class
Autodesk.Revit.Parameters Namespace


MoveNext Method

[image]

Revit 2010 API
DefinitionGroupsBaseIterator..::.MoveNext Method
DefinitionGroupsBaseIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DefinitionGroupsBaseIterator Class
Autodesk.Revit.Parameters Namespace


Reset Method

[image]

Revit 2010 API
DefinitionGroupsBaseIterator..::.Reset Method
DefinitionGroupsBaseIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DefinitionGroupsBaseIterator Class
Autodesk.Revit.Parameters Namespace


DefinitionGroupsBaseIterator Properties

[image] [image]

Revit 2010 API
DefinitionGroupsBaseIterator Properties
DefinitionGroupsBaseIterator Class See Also Send Feedback

The DefinitionGroupsBaseIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionGroupsBaseIterator Class
Autodesk.Revit.Parameters Namespace


Current Property

[image]

Revit 2010 API
DefinitionGroupsBaseIterator..::.Current Property
DefinitionGroupsBaseIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DefinitionGroupsBaseIterator Class
Autodesk.Revit.Parameters Namespace


Definitions Class

[image]

Revit 2010 API
Definitions Class
Members See Also Send Feedback
A base class that supports the addition of new parameter definitions.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Definitions : DefinitionsBase
Visual Basic (Declaration)
Public Class Definitions _
    Inherits DefinitionsBase
Visual C++
public ref class Definitions : public DefinitionsBase

Remarks

There are two derivations of this class, one of which handles external parameters and another which handles internal parameters.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.DefinitionsBase
Autodesk.Revit.Parameters..::.Definitions
Autodesk.Revit.Parameters..::.ExternalDefinitions
Autodesk.Revit.Parameters..::.InternalDefinitions

See Also

Definitions Members
Autodesk.Revit.Parameters Namespace


Definitions Members

[image] [image]

Revit 2010 API
Definitions Members
Definitions Class Constructors Methods Properties See Also Send Feedback

The Definitions type exposes the following members.

Constructors

Name | Description
Definitions | Construct an empty set of parameter definitions.

Methods

Name | Description
Clear | Removes every definition from the set, rendering it empty. (Inherited from DefinitionsBase.)
Contains | Tests for the existence of a definition within the set. (Inherited from DefinitionsBase.)
Create | Overloaded. Creates a new parameter definition.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified definition from the set. (Inherited from DefinitionsBase.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified definition into the set. (Inherited from DefinitionsBase.)
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from DefinitionsBase.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Retrieve a definition by a given name.
Size | Returns the number of definitions that are in the set. (Inherited from DefinitionsBase.)

See Also

Definitions Class
Autodesk.Revit.Parameters Namespace


Definitions Constructor

[image]

Revit 2010 API
Definitions Constructor
Definitions Class See Also Send Feedback
Construct an empty set of parameter definitions.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Definitions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Definitions()

See Also

Definitions Class
Autodesk.Revit.Parameters Namespace


Definitions Methods

[image] [image]

Revit 2010 API
Definitions Methods
Definitions Class See Also Send Feedback

The Definitions type exposes the following members.

Methods

Name | Description
Clear | Removes every definition from the set, rendering it empty. (Inherited from DefinitionsBase.)
Contains | Tests for the existence of a definition within the set. (Inherited from DefinitionsBase.)
Create | Overloaded. Creates a new parameter definition.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified definition from the set. (Inherited from DefinitionsBase.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified definition into the set. (Inherited from DefinitionsBase.)
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Definitions Class
Autodesk.Revit.Parameters Namespace


Create Method

[image] [image]

Revit 2010 API
Definitions..::.Create Method
Definitions Class See Also Send Feedback
Creates a new parameter definition.

Overload List

Name | Description
Create(String, ParameterType) | Creates a new parameter definition using name, type and visibility.
Create(String, ParameterType, Boolean) | Creates a new user visible parameter definition using name and type.

See Also

Definitions Class
Definitions Members
Autodesk.Revit.Parameters Namespace


Create Method (String, ParameterType)

[image]

Revit 2010 API
Definitions..::.Create Method (String, ParameterType)
Definitions Class See Also Send Feedback
Creates a new parameter definition using name, type and visibility.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Definition Create(
    string name,
    ParameterType type
)
Visual Basic (Declaration)
Public Function Create ( _
    name As String, _
    type As ParameterType _
) As Definition
Visual C++
public:
Definition^ Create(
    String^ name,
    ParameterType type
)

Parameters

name
Type: System..::.String
The name of the parameter definition to be created.
type
Type: Autodesk.Revit.Parameters..::.ParameterType
The name of the parameter type for the new definition.

Return Value

If successful a reference to the new parameter definition is returned, otherwise Nothing.

Remarks

If an attempt is made to create a new internal definition an exception will be thrown. Only external (shared) parameter definitions can be made.

See Also

Definitions Class
Create Overload
Autodesk.Revit.Parameters Namespace


Create Method (String, ParameterType, Boolean)

[image]

Revit 2010 API
Definitions..::.Create Method (String, ParameterType, Boolean)
Definitions Class See Also Send Feedback
Creates a new user visible parameter definition using name and type.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Definition Create(
    string name,
    ParameterType type,
    bool visible
)
Visual Basic (Declaration)
Public Function Create ( _
    name As String, _
    type As ParameterType, _
    visible As Boolean _
) As Definition
Visual C++
public:
Definition^ Create(
    String^ name,
    ParameterType type,
    bool visible
)

Parameters

name
Type: System..::.String
The name of the parameter definition to be created.
type
Type: Autodesk.Revit.Parameters..::.ParameterType
The name of the parameter type for the new definition.
visible
Type: System..::.Boolean

Return Value

If successful a reference to the new parameter definition is returned, otherwise Nothing.

Remarks

If an attempt is made to create a new internal definition an exception will be thrown. Only external (shared) parameter definitions can be made.

See Also

Definitions Class
Create Overload
Autodesk.Revit.Parameters Namespace


Definitions Properties

[image] [image]

Revit 2010 API
Definitions Properties
Definitions Class See Also Send Feedback

The Definitions type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from DefinitionsBase.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Retrieve a definition by a given name.
Size | Returns the number of definitions that are in the set. (Inherited from DefinitionsBase.)

See Also

Definitions Class
Autodesk.Revit.Parameters Namespace


Item Property

[image]

Revit 2010 API
Definitions..::.Item Property
Definitions Class See Also Send Feedback
Retrieve a definition by a given name.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Definition Item[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Item ( _
    name As String _
) As Definition
Visual C++
public:
property Definition^ Item[String^ name] {
    Definition^ get (String^ name);
}

Parameters

name
Type: System..::.String
The name of the parameter definition for which to search.

Remarks

If the definition is not found then Nothing will be returned.

See Also

Definitions Class
Autodesk.Revit.Parameters Namespace


DefinitionsBase Class

[image]

Revit 2010 API
DefinitionsBase Class
Members See Also Send Feedback
A set that contains definitions.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DefinitionsBase : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class DefinitionsBase _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DefinitionsBase : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.DefinitionsBase
Autodesk.Revit.Parameters..::.Definitions

See Also

DefinitionsBase Members
Autodesk.Revit.Parameters Namespace


DefinitionsBase Members

[image] [image]

Revit 2010 API
DefinitionsBase Members
DefinitionsBase Class Constructors Methods Properties See Also Send Feedback

The DefinitionsBase type exposes the following members.

Constructors

Name | Description
DefinitionsBase | Initializes a new instance of the DefinitionsBase class

Methods

Name | Description
Clear | Removes every definition from the set, rendering it empty.
Contains | Tests for the existence of a definition within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified definition from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified definition into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of definitions that are in the set.

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


DefinitionsBase Constructor

[image]

Revit 2010 API
DefinitionsBase Constructor
DefinitionsBase Class See Also Send Feedback
Initializes a new instance of the DefinitionsBase class

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DefinitionsBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionsBase()

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


DefinitionsBase Methods

[image] [image]

Revit 2010 API
DefinitionsBase Methods
DefinitionsBase Class See Also Send Feedback

The DefinitionsBase type exposes the following members.

Methods

Name | Description
Clear | Removes every definition from the set, rendering it empty.
Contains | Tests for the existence of a definition within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified definition from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified definition into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


Clear Method

[image]

Revit 2010 API
DefinitionsBase..::.Clear Method
DefinitionsBase Class See Also Send Feedback
Removes every definition from the set, rendering it empty.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


Contains Method

[image]

Revit 2010 API
DefinitionsBase..::.Contains Method
DefinitionsBase Class See Also Send Feedback
Tests for the existence of a definition within the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    Definition item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Definition _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Definition^ item
)

Parameters

item
Type: Autodesk.Revit.Parameters..::.Definition
The definition to be searched for.

Return Value

The Contains method returns True if the definition is within the set, otherwise False.

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


Erase Method

[image]

Revit 2010 API
DefinitionsBase..::.Erase Method
DefinitionsBase Class See Also Send Feedback
Removes a specified definition from the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    Definition item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Definition _
) As Integer
Visual C++
public:
virtual int Erase(
    Definition^ item
)

Parameters

item
Type: Autodesk.Revit.Parameters..::.Definition
The definition to be erased.

Return Value

The number of definitions that were erased from the set.

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


ForwardIterator Method

[image]

Revit 2010 API
DefinitionsBase..::.ForwardIterator Method
DefinitionsBase Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DefinitionsBaseIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DefinitionsBaseIterator
Visual C++
public:
virtual DefinitionsBaseIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


GetEnumerator Method

[image]

Revit 2010 API
DefinitionsBase..::.GetEnumerator Method
DefinitionsBase Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


Insert Method

[image]

Revit 2010 API
DefinitionsBase..::.Insert Method
DefinitionsBase Class See Also Send Feedback
Insert the specified definition into the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    Definition item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Definition _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Definition^ item
)

Parameters

item
Type: Autodesk.Revit.Parameters..::.Definition
The definition to be inserted into the set.

Return Value

Returns whether the definition was inserted into the set.

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


ReverseIterator Method

[image]

Revit 2010 API
DefinitionsBase..::.ReverseIterator Method
DefinitionsBase Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DefinitionsBaseIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DefinitionsBaseIterator
Visual C++
public:
virtual DefinitionsBaseIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


DefinitionsBase Properties

[image] [image]

Revit 2010 API
DefinitionsBase Properties
DefinitionsBase Class See Also Send Feedback

The DefinitionsBase type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of definitions that are in the set.

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


IsEmpty Property

[image]

Revit 2010 API
DefinitionsBase..::.IsEmpty Property
DefinitionsBase Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


Size Property

[image]

Revit 2010 API
DefinitionsBase..::.Size Property
DefinitionsBase Class See Also Send Feedback
Returns the number of definitions that are in the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DefinitionsBase Class
Autodesk.Revit.Parameters Namespace


DefinitionsBaseIterator Class

[image]

Revit 2010 API
DefinitionsBaseIterator Class
Members See Also Send Feedback
An iterator to a definition set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class DefinitionsBaseIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class DefinitionsBaseIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DefinitionsBaseIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.DefinitionsBaseIterator

See Also

DefinitionsBaseIterator Members
Autodesk.Revit.Parameters Namespace


DefinitionsBaseIterator Members

[image] [image]

Revit 2010 API
DefinitionsBaseIterator Members
DefinitionsBaseIterator Class Constructors Methods Properties See Also Send Feedback

The DefinitionsBaseIterator type exposes the following members.

Constructors

Name | Description
DefinitionsBaseIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionsBaseIterator Class
Autodesk.Revit.Parameters Namespace


DefinitionsBaseIterator Constructor

[image]

Revit 2010 API
DefinitionsBaseIterator Constructor
DefinitionsBaseIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DefinitionsBaseIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionsBaseIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DefinitionsBaseIterator Class
Autodesk.Revit.Parameters Namespace


DefinitionsBaseIterator Methods

[image] [image]

Revit 2010 API
DefinitionsBaseIterator Methods
DefinitionsBaseIterator Class See Also Send Feedback

The DefinitionsBaseIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionsBaseIterator Class
Autodesk.Revit.Parameters Namespace


MoveNext Method

[image]

Revit 2010 API
DefinitionsBaseIterator..::.MoveNext Method
DefinitionsBaseIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DefinitionsBaseIterator Class
Autodesk.Revit.Parameters Namespace


Reset Method

[image]

Revit 2010 API
DefinitionsBaseIterator..::.Reset Method
DefinitionsBaseIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DefinitionsBaseIterator Class
Autodesk.Revit.Parameters Namespace


DefinitionsBaseIterator Properties

[image] [image]

Revit 2010 API
DefinitionsBaseIterator Properties
DefinitionsBaseIterator Class See Also Send Feedback

The DefinitionsBaseIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionsBaseIterator Class
Autodesk.Revit.Parameters Namespace


Current Property

[image]

Revit 2010 API
DefinitionsBaseIterator..::.Current Property
DefinitionsBaseIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DefinitionsBaseIterator Class
Autodesk.Revit.Parameters Namespace


ElementBinding Class

[image]

Revit 2010 API
ElementBinding Class
Members See Also Send Feedback
A base class for all types of binding that attach to an element.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ElementBinding : Binding
Visual Basic (Declaration)
Public MustInherit Class ElementBinding _
    Inherits Binding
Visual C++
public ref class ElementBinding abstract : public Binding

Remarks

This base class provides methods that are common to all types of binding that work with elements.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.Binding
Autodesk.Revit.Parameters..::.ElementBinding
Autodesk.Revit.Parameters..::.InstanceBinding
Autodesk.Revit.Parameters..::.TypeBinding

See Also

ElementBinding Members
Autodesk.Revit.Parameters Namespace


ElementBinding Members

[image] [image]

Revit 2010 API
ElementBinding Members
ElementBinding Class Constructors Methods Properties See Also Send Feedback

The ElementBinding type exposes the following members.

Constructors

Name | Description
ElementBinding | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Categories | Retrieve or set the categories to which a parameter definition will be bound.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementBinding Class
Autodesk.Revit.Parameters Namespace


ElementBinding Constructor

[image]

Revit 2010 API
ElementBinding Constructor
ElementBinding Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementBinding()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementBinding()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElementBinding Class
Autodesk.Revit.Parameters Namespace


ElementBinding Methods

[image] [image]

Revit 2010 API
ElementBinding Methods
ElementBinding Class See Also Send Feedback

The ElementBinding type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementBinding Class
Autodesk.Revit.Parameters Namespace


ElementBinding Properties

[image] [image]

Revit 2010 API
ElementBinding Properties
ElementBinding Class See Also Send Feedback

The ElementBinding type exposes the following members.

Properties

Name | Description
Categories | Retrieve or set the categories to which a parameter definition will be bound.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementBinding Class
Autodesk.Revit.Parameters Namespace


Categories Property

[image]

Revit 2010 API
ElementBinding..::.Categories Property
ElementBinding Class See Also Send Feedback
Retrieve or set the categories to which a parameter definition will be bound.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CategorySet Categories { get; set; }
Visual Basic (Declaration)
Public Property Categories As CategorySet
Visual C++
public:
property CategorySet^ Categories {
    CategorySet^ get ();
    void set (CategorySet^ value);
}

Remarks

The Categories property is used to set the categories to which the definition will be bound when it is added to the document bindings. This property can also be read from existing bindings to interrogate to which categories a parameter has been bound.

See Also

ElementBinding Class
Autodesk.Revit.Parameters Namespace


ExternalDefinition Class

[image]

Revit 2010 API
ExternalDefinition Class
Members Example See Also Send Feedback
The ExternalDefinition object adds properties specific to Autodesk Revit shared parameter definitions.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ExternalDefinition : Definition
Visual Basic (Declaration)
Public Class ExternalDefinition _
    Inherits Definition
Visual C++
public ref class ExternalDefinition : public Definition

Remarks

The ExternalDefinition object is derived from the Definition object and therefore supports all the properties and methods of that object. The ExternalDefinition object can be created by a definition Group object from a shared parameters file. External parameter definition must belong to a Group which is nothing more than a collection of shared parameter definitions. The following process should be followed to add a parameter to an element: Open the shared parameters file, via the Document.OpenSharedParameterFile method. Access an existing or create a new group, via the DefinitionFile.Groups property. Access an existing or create a new external parameter definition, via the DefinitionGroup.Definitions property. Create a new Binding object with the categories to which the parameter will be bound using an InstanceBinding or a TypeBinding object. Finally add the binding and definition to the document using the Document.ParameterBindings object.

Examples

CopyC#
private void ReadEditExternalParam(DefinitionFile file)
{
    // get ExternalDefinition from shared parameter file
    DefinitionGroups myGroups = file.Groups;
    DefinitionGroup myGroup = myGroups.get_Item("MyGroup");
    if (null == myGroup)
        return;

    Definitions myDefinitions = myGroup.Definitions;
    ExternalDefinition myExtDef =
        myDefinitions.get_Item("MyParam") as ExternalDefinition;
    if (null == myExtDef)
        return;

    StringBuilder strBuilder = new StringBuilder();
    // iterate every property of the ExternalDefinition
    strBuilder.AppendLine("GUID: " + myExtDef.GUID.ToString())
        .AppendLine("Name: " + myExtDef.Name)
        .AppendLine("OwnerGroup: " + myExtDef.OwnerGroup.Name)
        .AppendLine("Parameter Group" + myExtDef.ParameterGroup.ToString())
        .AppendLine("Parameter Type" + myExtDef.ParameterType.ToString())
        .AppendLine("Is Visible: " + myExtDef.Visible.ToString());

    MessageBox.Show(strBuilder.ToString());

    // change the OwnerGroup of the ExternalDefinition
    myExtDef.OwnerGroup = myGroups.get_Item("AnotherGroup");
}
CopyVB.NET
Private Sub ReadEditExternalParam(ByVal file As DefinitionFile)
    ' get ExternalDefinition from shared parameter file
    Dim myGroups As DefinitionGroups = file.Groups
    Dim myGroup As DefinitionGroup = myGroups.Item("MyGroup")
    If myGroup Is Nothing Then
        Exit Sub
    End If

    Dim myDefinitions As Definitions = myGroup.Definitions
    Dim myExtDef As ExternalDefinition = TryCast(myDefinitions.Item("MyParam"), ExternalDefinition)
    If myExtDef Is Nothing Then
        Exit Sub
    End If

    Dim strBuilder As New StringBuilder()
    ' iterate every property of the ExternalDefinition
    strBuilder.AppendLine("GUID: " & myExtDef.GUID.ToString()).AppendLine("Name: " & myExtDef.Name).AppendLine("OwnerGroup: " & myExtDef.OwnerGroup.Name).AppendLine("Parameter Group" & myExtDef.ParameterGroup.ToString()).AppendLine("Parameter Type" & myExtDef.ParameterType.ToString()).AppendLine("Is Visible: " & myExtDef.Visible.ToString())

    MessageBox.Show(strBuilder.ToString())

    ' change the OwnerGroup of the ExternalDefinition
    myExtDef.OwnerGroup = myGroups.Item("AnotherGroup")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.Definition
Autodesk.Revit.Parameters..::.ExternalDefinition

See Also

ExternalDefinition Members
Autodesk.Revit.Parameters Namespace


ExternalDefinition Members

[image] [image]

Revit 2010 API
ExternalDefinition Members
ExternalDefinition Class Constructors Methods Properties See Also Send Feedback

The ExternalDefinition type exposes the following members.

Constructors

Name | Description
ExternalDefinition | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
GUID | Returns the GUID associated with the shared parameter definition.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | The user visible name for the parameter. (Overrides Definition..::.Name.)
OwnerGroup | Returns or change the group ID of the external parameter definition.
ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition..::.ParameterGroup.)
ParameterType | Returns the user visible interpretation of the parameter data. (Overrides Definition..::.ParameterType.)
Visible | Tells the developer is the parameter should be visible within the user interface of their application or Autodesk Revit. (Overrides DefinitionVisible()()().)

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace


ExternalDefinition Constructor

[image]

Revit 2010 API
ExternalDefinition Constructor
ExternalDefinition Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ExternalDefinition()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExternalDefinition()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace


ExternalDefinition Methods

[image] [image]

Revit 2010 API
ExternalDefinition Methods
ExternalDefinition Class See Also Send Feedback

The ExternalDefinition type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace


ExternalDefinition Properties

[image] [image]

Revit 2010 API
ExternalDefinition Properties
ExternalDefinition Class See Also Send Feedback

The ExternalDefinition type exposes the following members.

Properties

Name | Description
GUID | Returns the GUID associated with the shared parameter definition.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | The user visible name for the parameter. (Overrides Definition..::.Name.)
OwnerGroup | Returns or change the group ID of the external parameter definition.
ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition..::.ParameterGroup.)
ParameterType | Returns the user visible interpretation of the parameter data. (Overrides Definition..::.ParameterType.)
Visible | Tells the developer is the parameter should be visible within the user interface of their application or Autodesk Revit. (Overrides DefinitionVisible()()().)

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace


GUID Property

[image]

Revit 2010 API
ExternalDefinition..::.GUID Property
ExternalDefinition Class See Also Send Feedback
Returns the GUID associated with the shared parameter definition.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Guid GUID { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property GUID As Guid
Visual C++
public:
virtual property Guid GUID {
    Guid get ();
}

Remarks

Each shared parameter when created is issued a unique identifier. This identifier can then be used at a later time to retrieve the parameter from the Element ensuring that the correct parameter is always retrieved.

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace


Name Property

[image]

Revit 2010 API
ExternalDefinition..::.Name Property
ExternalDefinition Class See Also Send Feedback
The user visible name for the parameter.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace


OwnerGroup Property

[image]

Revit 2010 API
ExternalDefinition..::.OwnerGroup Property
ExternalDefinition Class See Also Send Feedback
Returns or change the group ID of the external parameter definition.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DefinitionGroup OwnerGroup { get; set; }
Visual Basic (Declaration)
Public Overridable Property OwnerGroup As DefinitionGroup
Visual C++
public:
virtual property DefinitionGroup^ OwnerGroup {
    DefinitionGroup^ get ();
    void set (DefinitionGroup^ value);
}

Remarks

If failed When set the group, an InvalidOperationException will be throwed.

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace


ParameterGroup Property

[image]

Revit 2010 API
ExternalDefinition..::.ParameterGroup Property
ExternalDefinition Class See Also Send Feedback
Returns the group ID of the parameter definition.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override BuiltInParameterGroup ParameterGroup { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ParameterGroup As BuiltInParameterGroup
Visual C++
public:
virtual property BuiltInParameterGroup ParameterGroup {
    BuiltInParameterGroup get () override;
}

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace


ParameterType Property

[image]

Revit 2010 API
ExternalDefinition..::.ParameterType Property
ExternalDefinition Class See Also Send Feedback
Returns the user visible interpretation of the parameter data.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override ParameterType ParameterType { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ParameterType As ParameterType
Visual C++
public:
virtual property ParameterType ParameterType {
    ParameterType get () override;
}

Remarks

The data within the parameter is stored in a very simple manner as an integer, double, string or an element id, but to the user these values may be more meaningful as Length, Volume, Mass etc. This parameter returns the interpretation that should be used for the data.

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace


Visible Property

[image]

Revit 2010 API
ExternalDefinition..::.Visible Property
ExternalDefinition Class See Also Send Feedback
Tells the developer is the parameter should be visible within the user interface of their application or Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override bool Visible { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Visible As Boolean
Visual C++
public:
virtual property bool Visible {
    bool get () override;
}

Remarks

The visible property controls whether a shared parameter is hidden from the user. This is useful if you wish to add data to an element that is only meaningful to your application and not to the user. This value can only be set when the shared parameter definition is created.

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace


ExternalDefinitions Class

[image]

Revit 2010 API
ExternalDefinitions Class
Members See Also Send Feedback
Supports the creation of new shared parameters definitions.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ExternalDefinitions : Definitions
Visual Basic (Declaration)
Public Class ExternalDefinitions _
    Inherits Definitions
Visual C++
public ref class ExternalDefinitions : public Definitions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.DefinitionsBase
Autodesk.Revit.Parameters..::.Definitions
Autodesk.Revit.Parameters..::.ExternalDefinitions

See Also

ExternalDefinitions Members
Autodesk.Revit.Parameters Namespace


ExternalDefinitions Members

[image] [image]

Revit 2010 API
ExternalDefinitions Members
ExternalDefinitions Class Constructors Methods Properties See Also Send Feedback

The ExternalDefinitions type exposes the following members.

Constructors

Name | Description
ExternalDefinitions | For Internal Use Only.

Methods

Name | Description
Clear | Removes every definition from the set, rendering it empty. (Inherited from DefinitionsBase.)
Contains | Tests for the existence of a definition within the set. (Inherited from DefinitionsBase.)
Create | Overloaded. Creates a new parameter definition.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified definition from the set. (Inherited from DefinitionsBase.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified definition into the set. (Inherited from DefinitionsBase.)
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from DefinitionsBase.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Retrieve a definition by a given name. (Inherited from Definitions.)
Size | Returns the number of definitions that are in the set. (Inherited from DefinitionsBase.)

See Also

ExternalDefinitions Class
Autodesk.Revit.Parameters Namespace


ExternalDefinitions Constructor

[image]

Revit 2010 API
ExternalDefinitions Constructor
ExternalDefinitions Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ExternalDefinitions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExternalDefinitions()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ExternalDefinitions Class
Autodesk.Revit.Parameters Namespace


ExternalDefinitions Methods

[image] [image]

Revit 2010 API
ExternalDefinitions Methods
ExternalDefinitions Class See Also Send Feedback

The ExternalDefinitions type exposes the following members.

Methods

Name | Description
Clear | Removes every definition from the set, rendering it empty. (Inherited from DefinitionsBase.)
Contains | Tests for the existence of a definition within the set. (Inherited from DefinitionsBase.)
Create | Overloaded. Creates a new parameter definition.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified definition from the set. (Inherited from DefinitionsBase.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified definition into the set. (Inherited from DefinitionsBase.)
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalDefinitions Class
Autodesk.Revit.Parameters Namespace


Create Method

[image] [image]

Revit 2010 API
ExternalDefinitions..::.Create Method
ExternalDefinitions Class See Also Send Feedback
Creates a new parameter definition.

Overload List

Name | Description
Create(String, ParameterType) | Creates a new parameter definition using name, type and visibility. (Inherited from Definitions.)
Create(String, ParameterType, Boolean) | Creates a new user visible parameter definition using name and type. (Inherited from Definitions.)

See Also

ExternalDefinitions Class
ExternalDefinitions Members
Autodesk.Revit.Parameters Namespace


ExternalDefinitions Properties

[image] [image]

Revit 2010 API
ExternalDefinitions Properties
ExternalDefinitions Class See Also Send Feedback

The ExternalDefinitions type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from DefinitionsBase.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Retrieve a definition by a given name. (Inherited from Definitions.)
Size | Returns the number of definitions that are in the set. (Inherited from DefinitionsBase.)

See Also

ExternalDefinitions Class
Autodesk.Revit.Parameters Namespace


InstanceBinding Class

[image]

Revit 2010 API
InstanceBinding Class
Members Example See Also Send Feedback
The InstanceBinding object is used to signify a binding between a parameter definition and a parameter on each instance of an element, such as a wall.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class InstanceBinding : ElementBinding
Visual Basic (Declaration)
Public Class InstanceBinding _
    Inherits ElementBinding
Visual C++
public ref class InstanceBinding : public ElementBinding

Remarks

Once bound the parameter will appear on all instance of the element and changing the parameter on any one single instance will not change the value on any other instance.

Examples

CopyC#
public bool SetNewParameterToInsanceWall(Autodesk.Revit.Application app, DefinitionFile myDefinitionFile)
{
    // create a new group in the shared parameters file
    DefinitionGroups myGroups = myDefinitionFile.Groups;
    DefinitionGroup myGroup = myGroups.Create("MyParameters1");

    // create an instance definition in definition group MyParameters
    Definition myDefinition_ProductDate =
       myGroup.Definitions.Create("Instance_ProductDate", ParameterType.Text);

    // create a category set and insert category of wall to it
    CategorySet myCategories = app.Create.NewCategorySet();
    // use BuiltInCategory to get category of wall
    Category myCategory = app.ActiveDocument.Settings.Categories.get_Item(
                                BuiltInCategory.OST_Walls);
    myCategories.Insert(myCategory);

    //Create an instance of InstanceBinding
    InstanceBinding instanceBinding = app.Create.NewInstanceBinding(myCategories);

    // Get the BingdingMap of current document.
    BindingMap bindingMap = app.ActiveDocument.ParameterBindings;

    // Bind the definitions to the document
    bool instanceBindOK = bindingMap.Insert(myDefinition_ProductDate,
                                    instanceBinding, BuiltInParameterGroup.PG_TEXT);
    return instanceBindOK;
}
CopyVB.NET
Public Function SetNewParameterToInsanceWall(ByVal app As Autodesk.Revit.Application, ByVal myDefinitionFile As DefinitionFile) As Boolean
    ' create a new group in the shared parameters file
    Dim myGroups As DefinitionGroups = myDefinitionFile.Groups
    Dim myGroup As DefinitionGroup = myGroups.Create("MyParameters1")

    ' create an instance definition in definition group MyParameters
    Dim myDefinition_ProductDate As Definition = myGroup.Definitions.Create("Instance_ProductDate", ParameterType.Text)

    ' create a category set and insert category of wall to it
    Dim myCategories As CategorySet = app.Create.NewCategorySet()
    ' use BuiltInCategory to get category of wall
    Dim myCategory As Autodesk.Revit.Category = app.ActiveDocument.Settings.Categories.Item(BuiltInCategory.OST_Walls)
    myCategories.Insert(myCategory)

    'Create an instance of InstanceBinding
    Dim instanceBinding As InstanceBinding = app.Create.NewInstanceBinding(myCategories)

    ' Get the BingdingMap of current document.
    Dim bindingMap As BindingMap = app.ActiveDocument.ParameterBindings

    ' Bind the definitions to the document
    Dim instanceBindOK As Boolean = bindingMap.Insert(myDefinition_ProductDate, instanceBinding, BuiltInParameterGroup.PG_TEXT)
    Return instanceBindOK
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.Binding
Autodesk.Revit.Parameters..::.ElementBinding
Autodesk.Revit.Parameters..::.InstanceBinding

See Also

InstanceBinding Members
Autodesk.Revit.Parameters Namespace


InstanceBinding Members

[image] [image]

Revit 2010 API
InstanceBinding Members
InstanceBinding Class Constructors Methods Properties See Also Send Feedback

The InstanceBinding type exposes the following members.

Constructors

Name | Description
InstanceBinding | Overloaded.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InstanceBinding Class
Autodesk.Revit.Parameters Namespace


InstanceBinding Constructor

[image] [image]

Revit 2010 API
InstanceBinding Constructor
InstanceBinding Class See Also Send Feedback

Overload List

Name | Description
InstanceBinding()()() | Constructs an empty instance binding.
InstanceBinding(CategorySet) | Constructs an instance binding with the set of categories passed.

See Also

InstanceBinding Class
InstanceBinding Members
Autodesk.Revit.Parameters Namespace


InstanceBinding Constructor

[image]

Revit 2010 API
InstanceBinding Constructor
InstanceBinding Class See Also Send Feedback
Constructs an empty instance binding.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InstanceBinding()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InstanceBinding()

Remarks

Categories can be set a later time by using the Categories property of this object.

See Also

InstanceBinding Class
InstanceBinding Overload
Autodesk.Revit.Parameters Namespace


InstanceBinding Constructor (CategorySet)

[image]

Revit 2010 API
InstanceBinding Constructor (CategorySet)
InstanceBinding Class See Also Send Feedback
Constructs an instance binding with the set of categories passed.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InstanceBinding(
    CategorySet categories
)
Visual Basic (Declaration)
Public Sub New ( _
    categories As CategorySet _
)
Visual C++
public:
InstanceBinding(
    CategorySet^ categories
)

Parameters

categories
Type: Autodesk.Revit..::.CategorySet

Remarks

Categories can be set or changed at a later time by using the Categories property of this object.

See Also

InstanceBinding Class
InstanceBinding Overload
Autodesk.Revit.Parameters Namespace


InstanceBinding Methods

[image] [image]

Revit 2010 API
InstanceBinding Methods
InstanceBinding Class See Also Send Feedback

The InstanceBinding type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstanceBinding Class
Autodesk.Revit.Parameters Namespace


InstanceBinding Properties

[image] [image]

Revit 2010 API
InstanceBinding Properties
InstanceBinding Class See Also Send Feedback

The InstanceBinding type exposes the following members.

Properties

Name | Description
Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InstanceBinding Class
Autodesk.Revit.Parameters Namespace


InternalDefinition Class

[image]

Revit 2010 API
InternalDefinition Class
Members See Also Send Feedback
This object represents a parameter definition in Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class InternalDefinition : Definition
Visual Basic (Declaration)
Public Class InternalDefinition _
    Inherits Definition
Visual C++
public ref class InternalDefinition : public Definition

Remarks

The InternalDefinition object is derived from the Definition object and hence includes all properties and methods of the Definition object. This object adds no other properties and methods and is used purely for type identification.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.Definition
Autodesk.Revit.Parameters..::.InternalDefinition

See Also

InternalDefinition Members
Autodesk.Revit.Parameters Namespace


InternalDefinition Members

[image] [image]

Revit 2010 API
InternalDefinition Members
InternalDefinition Class Constructors Methods Properties See Also Send Feedback

The InternalDefinition type exposes the following members.

Constructors

Name | Description
InternalDefinition | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BuiltInParameter | Identifies if the parameter is a BuiltIn parameter.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | The user-visible name for the parameter. (Overrides Definition..::.Name.)
ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition..::.ParameterGroup.)
ParameterType | Returns the user-visible interpretation of the parameter data. (Overrides Definition..::.ParameterType.)

See Also

InternalDefinition Class
Autodesk.Revit.Parameters Namespace


InternalDefinition Constructor

[image]

Revit 2010 API
InternalDefinition Constructor
InternalDefinition Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InternalDefinition()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InternalDefinition()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

InternalDefinition Class
Autodesk.Revit.Parameters Namespace


InternalDefinition Methods

[image] [image]

Revit 2010 API
InternalDefinition Methods
InternalDefinition Class See Also Send Feedback

The InternalDefinition type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InternalDefinition Class
Autodesk.Revit.Parameters Namespace


InternalDefinition Properties

[image] [image]

Revit 2010 API
InternalDefinition Properties
InternalDefinition Class See Also Send Feedback

The InternalDefinition type exposes the following members.

Properties

Name | Description
BuiltInParameter | Identifies if the parameter is a BuiltIn parameter.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | The user-visible name for the parameter. (Overrides Definition..::.Name.)
ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition..::.ParameterGroup.)
ParameterType | Returns the user-visible interpretation of the parameter data. (Overrides Definition..::.ParameterType.)

See Also

InternalDefinition Class
Autodesk.Revit.Parameters Namespace


BuiltInParameter Property

[image]

Revit 2010 API
InternalDefinition..::.BuiltInParameter Property
InternalDefinition Class See Also Send Feedback
Identifies if the parameter is a BuiltIn parameter.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BuiltInParameter BuiltInParameter { get; }
Visual Basic (Declaration)
Public ReadOnly Property BuiltInParameter As BuiltInParameter
Visual C++
public:
property BuiltInParameter BuiltInParameter {
    BuiltInParameter get ();
}

Remarks

If the parameter is not a BuiltIn parameter, a Nullable object without value will be returned.

See Also

InternalDefinition Class
Autodesk.Revit.Parameters Namespace


Name Property

[image]

Revit 2010 API
InternalDefinition..::.Name Property
InternalDefinition Class See Also Send Feedback
The user-visible name for the parameter.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

See Also

InternalDefinition Class
Autodesk.Revit.Parameters Namespace


ParameterGroup Property

[image]

Revit 2010 API
InternalDefinition..::.ParameterGroup Property
InternalDefinition Class See Also Send Feedback
Returns the group ID of the parameter definition.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override BuiltInParameterGroup ParameterGroup { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ParameterGroup As BuiltInParameterGroup
Visual C++
public:
virtual property BuiltInParameterGroup ParameterGroup {
    BuiltInParameterGroup get () override;
}

See Also

InternalDefinition Class
Autodesk.Revit.Parameters Namespace


ParameterType Property

[image]

Revit 2010 API
InternalDefinition..::.ParameterType Property
InternalDefinition Class See Also Send Feedback
Returns the user-visible interpretation of the parameter data.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override ParameterType ParameterType { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ParameterType As ParameterType
Visual C++
public:
virtual property ParameterType ParameterType {
    ParameterType get () override;
}

Remarks

The data within the parameter is stored as an integer, double, string or an element id. To the user these values may be more meaningful as Length, Volume, Mass etc. This parameter returns the interpretation that should be used for the data.

See Also

InternalDefinition Class
Autodesk.Revit.Parameters Namespace


InternalDefinitions Class

[image]

Revit 2010 API
InternalDefinitions Class
Members See Also Send Feedback
This object blocks attempts to create new internal definitions as they are not permitted.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class InternalDefinitions : Definitions
Visual Basic (Declaration)
Public Class InternalDefinitions _
    Inherits Definitions
Visual C++
public ref class InternalDefinitions : public Definitions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.DefinitionsBase
Autodesk.Revit.Parameters..::.Definitions
Autodesk.Revit.Parameters..::.InternalDefinitions

See Also

InternalDefinitions Members
Autodesk.Revit.Parameters Namespace


InternalDefinitions Members

[image] [image]

Revit 2010 API
InternalDefinitions Members
InternalDefinitions Class Constructors Methods Properties See Also Send Feedback

The InternalDefinitions type exposes the following members.

Constructors

Name | Description
InternalDefinitions | For Internal Use Only.

Methods

Name | Description
Clear | Removes every definition from the set, rendering it empty. (Inherited from DefinitionsBase.)
Contains | Tests for the existence of a definition within the set. (Inherited from DefinitionsBase.)
Create | Overloaded. Creates a new parameter definition.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified definition from the set. (Inherited from DefinitionsBase.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified definition into the set. (Inherited from DefinitionsBase.)
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from DefinitionsBase.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Retrieve a definition by a given name. (Inherited from Definitions.)
Size | Returns the number of definitions that are in the set. (Inherited from DefinitionsBase.)

See Also

InternalDefinitions Class
Autodesk.Revit.Parameters Namespace


InternalDefinitions Constructor

[image]

Revit 2010 API
InternalDefinitions Constructor
InternalDefinitions Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InternalDefinitions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InternalDefinitions()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

InternalDefinitions Class
Autodesk.Revit.Parameters Namespace


InternalDefinitions Methods

[image] [image]

Revit 2010 API
InternalDefinitions Methods
InternalDefinitions Class See Also Send Feedback

The InternalDefinitions type exposes the following members.

Methods

Name | Description
Clear | Removes every definition from the set, rendering it empty. (Inherited from DefinitionsBase.)
Contains | Tests for the existence of a definition within the set. (Inherited from DefinitionsBase.)
Create | Overloaded. Creates a new parameter definition.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified definition from the set. (Inherited from DefinitionsBase.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified definition into the set. (Inherited from DefinitionsBase.)
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InternalDefinitions Class
Autodesk.Revit.Parameters Namespace


Create Method

[image] [image]

Revit 2010 API
InternalDefinitions..::.Create Method
InternalDefinitions Class See Also Send Feedback
Creates a new parameter definition.

Overload List

Name | Description
Create(String, ParameterType) | Creates a new parameter definition using name, type and visibility. (Inherited from Definitions.)
Create(String, ParameterType, Boolean) | Creates a new user visible parameter definition using name and type. (Inherited from Definitions.)

See Also

InternalDefinitions Class
InternalDefinitions Members
Autodesk.Revit.Parameters Namespace


InternalDefinitions Properties

[image] [image]

Revit 2010 API
InternalDefinitions Properties
InternalDefinitions Class See Also Send Feedback

The InternalDefinitions type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from DefinitionsBase.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Retrieve a definition by a given name. (Inherited from Definitions.)
Size | Returns the number of definitions that are in the set. (Inherited from DefinitionsBase.)

See Also

InternalDefinitions Class
Autodesk.Revit.Parameters Namespace


ParameterListItem Class

[image]

Revit 2010 API
ParameterListItem Class
Members See Also Send Feedback
Object representing list item of external list parameter.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ParameterListItem : APIObject
Visual Basic (Declaration)
Public Class ParameterListItem _
    Inherits APIObject
Visual C++
public ref class ParameterListItem : public APIObject

Remarks

Usually this includes two properties: item string and item value.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.ParameterListItem

See Also

ParameterListItem Members
Autodesk.Revit.Parameters Namespace


ParameterListItem Members

[image] [image]

Revit 2010 API
ParameterListItem Members
ParameterListItem Class Constructors Methods Properties See Also Send Feedback

The ParameterListItem type exposes the following members.

Constructors

Name | Description
ParameterListItem | Overloaded.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
String | Item string.
Value | Item value.

See Also

ParameterListItem Class
Autodesk.Revit.Parameters Namespace


ParameterListItem Constructor

[image] [image]

Revit 2010 API
ParameterListItem Constructor
ParameterListItem Class See Also Send Feedback

Overload List

Name | Description
ParameterListItem()()() | For Internal Use Only.
ParameterListItem(String, ElementId) | Creates object with supplied item string and elementid value.
ParameterListItem(String, Double) | Creates object with supplied item string and double value.
ParameterListItem(String, Int32) | Creates object with supplied item string and integer value.
ParameterListItem(String, String) | Creates object with supplied item string and string value.

See Also

ParameterListItem Class
ParameterListItem Members
Autodesk.Revit.Parameters Namespace


ParameterListItem Constructor

[image]

Revit 2010 API
ParameterListItem Constructor
ParameterListItem Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterListItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterListItem()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ParameterListItem Class
ParameterListItem Overload
Autodesk.Revit.Parameters Namespace


ParameterListItem Constructor (String, ElementId)

[image]

Revit 2010 API
ParameterListItem Constructor (String, ElementId)
ParameterListItem Class See Also Send Feedback
Creates object with supplied item string and elementid value.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterListItem(
    string itemStr,
    ElementId itemValue
)
Visual Basic (Declaration)
Public Sub New ( _
    itemStr As String, _
    itemValue As ElementId _
)
Visual C++
public:
ParameterListItem(
    String^ itemStr,
    ElementId itemValue
)

Parameters

itemStr
Type: System..::.String
The item string.
itemValue
Type: Autodesk.Revit..::.ElementId
The item value.

See Also

ParameterListItem Class
ParameterListItem Overload
Autodesk.Revit.Parameters Namespace


ParameterListItem Constructor (String, Double)

[image]

Revit 2010 API
ParameterListItem Constructor (String, Double)
ParameterListItem Class See Also Send Feedback
Creates object with supplied item string and double value.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterListItem(
    string itemStr,
    double itemValue
)
Visual Basic (Declaration)
Public Sub New ( _
    itemStr As String, _
    itemValue As Double _
)
Visual C++
public:
ParameterListItem(
    String^ itemStr,
    double itemValue
)

Parameters

itemStr
Type: System..::.String
The item string.
itemValue
Type: System..::.Double
The item value.

See Also

ParameterListItem Class
ParameterListItem Overload
Autodesk.Revit.Parameters Namespace


ParameterListItem Constructor (String, Int32)

[image]

Revit 2010 API
ParameterListItem Constructor (String, Int32)
ParameterListItem Class See Also Send Feedback
Creates object with supplied item string and integer value.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterListItem(
    string itemStr,
    int itemValue
)
Visual Basic (Declaration)
Public Sub New ( _
    itemStr As String, _
    itemValue As Integer _
)
Visual C++
public:
ParameterListItem(
    String^ itemStr,
    int itemValue
)

Parameters

itemStr
Type: System..::.String
The item string.
itemValue
Type: System..::.Int32
The item value.

See Also

ParameterListItem Class
ParameterListItem Overload
Autodesk.Revit.Parameters Namespace


ParameterListItem Constructor (String, String)

[image]

Revit 2010 API
ParameterListItem Constructor (String, String)
ParameterListItem Class See Also Send Feedback
Creates object with supplied item string and string value.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterListItem(
    string itemStr,
    string itemValue
)
Visual Basic (Declaration)
Public Sub New ( _
    itemStr As String, _
    itemValue As String _
)
Visual C++
public:
ParameterListItem(
    String^ itemStr,
    String^ itemValue
)

Parameters

itemStr
Type: System..::.String
The item string.
itemValue
Type: System..::.String
The item value.

See Also

ParameterListItem Class
ParameterListItem Overload
Autodesk.Revit.Parameters Namespace


ParameterListItem Methods

[image] [image]

Revit 2010 API
ParameterListItem Methods
ParameterListItem Class See Also Send Feedback

The ParameterListItem type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterListItem Class
Autodesk.Revit.Parameters Namespace


ParameterListItem Properties

[image] [image]

Revit 2010 API
ParameterListItem Properties
ParameterListItem Class See Also Send Feedback

The ParameterListItem type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
String | Item string.
Value | Item value.

See Also

ParameterListItem Class
Autodesk.Revit.Parameters Namespace


String Property

[image]

Revit 2010 API
ParameterListItem..::.String Property
ParameterListItem Class See Also Send Feedback
Item string.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string String { get; set; }
Visual Basic (Declaration)
Public Property String As String
Visual C++
public:
property String^ String {
    String^ get ();
    void set (String^ value);
}

See Also

ParameterListItem Class
Autodesk.Revit.Parameters Namespace


Value Property

[image]

Revit 2010 API
ParameterListItem..::.Value Property
ParameterListItem Class See Also Send Feedback
Item value.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

ParameterListItem Class
Autodesk.Revit.Parameters Namespace


ParameterListItemArray Class

[image]

Revit 2010 API
ParameterListItemArray Class
Members See Also Send Feedback
An array that can contain any type of object.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ParameterListItemArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ParameterListItemArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ParameterListItemArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.ParameterListItemArray

See Also

ParameterListItemArray Members
Autodesk.Revit.Parameters Namespace


ParameterListItemArray Members

[image] [image]

Revit 2010 API
ParameterListItemArray Members
ParameterListItemArray Class Constructors Methods Properties See Also Send Feedback

The ParameterListItemArray type exposes the following members.

Constructors

Name | Description
ParameterListItemArray | Initializes a new instance of the ParameterListItemArray class

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


ParameterListItemArray Constructor

[image]

Revit 2010 API
ParameterListItemArray Constructor
ParameterListItemArray Class See Also Send Feedback
Initializes a new instance of the ParameterListItemArray class

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterListItemArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterListItemArray()

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


ParameterListItemArray Methods

[image] [image]

Revit 2010 API
ParameterListItemArray Methods
ParameterListItemArray Class See Also Send Feedback

The ParameterListItemArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


Append Method

[image]

Revit 2010 API
ParameterListItemArray..::.Append Method
ParameterListItemArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    ParameterListItem item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As ParameterListItem _
)
Visual C++
public:
virtual void Append(
    ParameterListItem^ item
)

Parameters

item
Type: Autodesk.Revit.Parameters..::.ParameterListItem

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


Clear Method

[image]

Revit 2010 API
ParameterListItemArray..::.Clear Method
ParameterListItemArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


ForwardIterator Method

[image]

Revit 2010 API
ParameterListItemArray..::.ForwardIterator Method
ParameterListItemArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ParameterListItemArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ParameterListItemArrayIterator
Visual C++
public:
virtual ParameterListItemArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


GetEnumerator Method

[image]

Revit 2010 API
ParameterListItemArray..::.GetEnumerator Method
ParameterListItemArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


Insert Method

[image]

Revit 2010 API
ParameterListItemArray..::.Insert Method
ParameterListItemArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    ParameterListItem item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As ParameterListItem, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    ParameterListItem^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Parameters..::.ParameterListItem
index
Type: System..::.Int32

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


ReverseIterator Method

[image]

Revit 2010 API
ParameterListItemArray..::.ReverseIterator Method
ParameterListItemArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ParameterListItemArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ParameterListItemArrayIterator
Visual C++
public:
virtual ParameterListItemArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


ParameterListItemArray Properties

[image] [image]

Revit 2010 API
ParameterListItemArray Properties
ParameterListItemArray Class See Also Send Feedback

The ParameterListItemArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


IsEmpty Property

[image]

Revit 2010 API
ParameterListItemArray..::.IsEmpty Property
ParameterListItemArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


Item Property

[image]

Revit 2010 API
ParameterListItemArray..::.Item Property
ParameterListItemArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ParameterListItem Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As ParameterListItem
Visual C++
public:
virtual property ParameterListItem^ Item[int index] {
    ParameterListItem^ get (int index);
    void set (int index, ParameterListItem^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


Size Property

[image]

Revit 2010 API
ParameterListItemArray..::.Size Property
ParameterListItemArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace


ParameterListItemArrayIterator Class

[image]

Revit 2010 API
ParameterListItemArrayIterator Class
Members See Also Send Feedback
An iterator to a array.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ParameterListItemArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ParameterListItemArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ParameterListItemArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.ParameterListItemArrayIterator

See Also

ParameterListItemArrayIterator Members
Autodesk.Revit.Parameters Namespace


ParameterListItemArrayIterator Members

[image] [image]

Revit 2010 API
ParameterListItemArrayIterator Members
ParameterListItemArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ParameterListItemArrayIterator type exposes the following members.

Constructors

Name | Description
ParameterListItemArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ParameterListItemArrayIterator Class
Autodesk.Revit.Parameters Namespace


ParameterListItemArrayIterator Constructor

[image]

Revit 2010 API
ParameterListItemArrayIterator Constructor
ParameterListItemArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterListItemArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterListItemArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ParameterListItemArrayIterator Class
Autodesk.Revit.Parameters Namespace


ParameterListItemArrayIterator Methods

[image] [image]

Revit 2010 API
ParameterListItemArrayIterator Methods
ParameterListItemArrayIterator Class See Also Send Feedback

The ParameterListItemArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterListItemArrayIterator Class
Autodesk.Revit.Parameters Namespace


MoveNext Method

[image]

Revit 2010 API
ParameterListItemArrayIterator..::.MoveNext Method
ParameterListItemArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ParameterListItemArrayIterator Class
Autodesk.Revit.Parameters Namespace


Reset Method

[image]

Revit 2010 API
ParameterListItemArrayIterator..::.Reset Method
ParameterListItemArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ParameterListItemArrayIterator Class
Autodesk.Revit.Parameters Namespace


ParameterListItemArrayIterator Properties

[image] [image]

Revit 2010 API
ParameterListItemArrayIterator Properties
ParameterListItemArrayIterator Class See Also Send Feedback

The ParameterListItemArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ParameterListItemArrayIterator Class
Autodesk.Revit.Parameters Namespace


Current Property

[image]

Revit 2010 API
ParameterListItemArrayIterator..::.Current Property
ParameterListItemArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ParameterListItemArrayIterator Class
Autodesk.Revit.Parameters Namespace


ParameterType Enumeration

[image]

Revit 2010 API
ParameterType Enumeration
See Also Send Feedback
An enumerate type listing all of the data type interpretation that Autodesk Revit supports.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ParameterType
Visual Basic (Declaration)
Public Enumeration ParameterType
Visual C++
public enum class ParameterType

Members

Member name | Description
Material | The value of this property is considered to be a material.
URL | A text string that represents a web address.
Text | The parameter data should be interpreted as a string of text.
HVACFactor | The data value will be represented as a HVACFactor.
HVACAreaDividedByHeatingLoad | The data value will be represented as a HVACAreaDividedByHeatingLoad.
ElectricalLuminance | The data value will be represented as an ElectricalLuminance.
ElectricalLuminousIntensity | The data value will be represented as an ElectricalLuminousIntensity.
ColorTemperature | The data value will be represented as a ColorTemperature.
ElectricalWattage | The data value will be represented as an ElectricalWattage.
ElectricalEfficacy | The data value will be represented as an ElectricalEfficacy.
PipingSlope | The data value will be represented as a PipingSlope.
HVACSlope | The data value will be represented as a HVACSlope.
WireSize | The data value will be represented as a WireSize.
HVACAreaDividedByCoolingLoad | The data value will be represented as a HVACAreaDividedByCoolingLoad.
HVACAirflowDividedByCoolingLoad | The data value will be represented as a HVACAirflowDividedByCoolingLoad.
HVACAirflowDividedByVolume | The data value will be represented as a HVACAirflowDividedByVolume.
HVACHeatingLoadDividedByVolume | The data value will be represented as a HVACHeatingLoadDividedByVolume.
HVACHeatingLoadDividedByArea | The data value will be represented as a HVACHeatingLoadDividedByArea.
HVACHeatingLoad | The data value will be represented as a HVACHeatingLoad.
HVACCoolingLoadDividedByVolume | The data value will be represented as a HVACCoolingLoadDividedByVolume.
HVACCoolingLoadDividedByArea | The data value will be represented as a HVACCoolingLoadDividedByArea.
HVACCoolingLoad | The data value will be represented as a HVACCoolingLoad.
Slope | The data value will be represented as a Slope.
HVACAirflowDensity | The data value will be represented as a HVACAirflowDensity.
HVACCoefficientOfHeatTransfer | The data value will be represented as a HVACCoefficientOfHeatTransfer.
HVACViscosity | The data value will be represented as a HVACViscosity.
PipingVolume | The data value will be represented as a PipingVolume.
AreaForcePerLength | The data value will be represented as an AreaForcePerLength.
LinearForceLengthPerAngle | The data value will be represented as a LinearForceLengthPerAngle.
LinearForcePerLength | The data value will be represented as a LinearForcePerLength.
ForceLengthPerAngle | The data value will be represented as a ForceLengthPerAngle.
ForcePerLength | The data value will be represented as a ForcePerLength.
LinearMoment | The data value will be represented as a LinearMoment.
TemperalExp | The data value will be represented as a TemperalExp.
UnitWeight | The data value will be represented as a UnitWeight.
Stress | The data value will be represented as a Stress.
PipingRoughness | The data value will be represented as a PipingRoughness.
PipeSize | The data value will be represented as a PipeSize.
PipingViscosity | The data value will be represented as a PipingViscosity.
PipingVelocity | The data value will be represented as a PipingVelocity.
PipingTemperature | The data value will be represented as a PipingTemperature.
PipingPressure | The data value will be represented as a PipingPressure.
PipingFriction | The data value will be represented as a PipingFriction.
PipingFlow | The data value will be represented as a PipingFlow.
PipingDensity | The data value will be represented as a PipingDensity.
ElectricalPowerDensity | The data value will be represented as an ElectricalPowerDensity.
ElectricalApparentPower | The data value will be represented as an ElectricalApparentPower.
HVACRoughness | The data value will be represented as a HVACRoughness.
ElectricalPower | The data value will be represented as an ElectricalPower.
ElectricalLuminousFlux | The data value will be represented as an ElectricalLuminousFlux.
ElectricalIlluminance | The data value will be represented as an ElectricalIlluminance.
ElectricalFrequency | The data value will be represented as an ElectricalFrequency.
ElectricalPotential | The data value will be represented as an ElectricalPotential.
ElectricalCurrent | The data value will be represented as an ElectricalCurrent.
HVACHeatGain | The data value will be represented as a HVACHeatGain.
HVACCrossSection | The data value will be represented as a HVACCrossSection.
HVACDuctSize | The data value will be represented as a HVACDuctSize.
HVACAirflow | The data value will be represented as a HVACAirflow.
HVACVelocity | The data value will be represented as a HVACVelocity.
HVACTemperature | The data value will be represented as a HVACTemperature.
HVACPressure | The data value will be represented as a HVACPressure.
HVACPowerDensity | The data value will be represented as a HVACPowerDensity.
HVACPower | The data value will be represented as a HVACPower.
HVACFriction | The data value will be represented as a HVACFriction.
HVACEnergy | The data value will be represented as a HVACEnergy.
HVACDensity | The data value will be represented as a HVACDensity.
FamilyType | A parameter used to control the type of a family nested within another family.
FixtureUnit | A parameter value that represents the fixture units, as used in piping disciplines.
NumberOfPoles | A parameter value that represents the number of poles, as used in electrical disciplines.
Moment | The data value will be represented as a moment.
AreaForce | The data value will be represented as an area force.
LinearForce | The data value will be represented as a linear force.
Force | The data value will be represented as a force.
YesNo | A boolean value that will be represented as Yes or No.
Angle | The parameter data represents an angle.
Volume | The parameter data represents a volume.
Area | The parameter data represents an area.
Integer | The parameter data should be interpreted as a whole number, positive or negative.
Invalid | The parameter type is invalid. This value should not be used.
Length | The parameter data represents a length.
Currency | The data value will be represented as a Currency.
Number | The parameter data should be interpreted as a real number, possibly including decimal points.

See Also

Autodesk.Revit.Parameters Namespace


ServiceType Enumeration

[image]

Revit 2010 API
ServiceType Enumeration
See Also Send Feedback
An enumerate type listing all of the built-in service types supported by Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ServiceType
Visual Basic (Declaration)
Public Enumeration ServiceType
Visual C++
public enum class ServiceType

Members

Member name | Description
kSplitSystemsWithMechanicalVentilationWithCooling | Service Type is SplitSystemsWithMechanicalVentilationWithCooling.
kSplitSystemsWithMechanicalVentilation | Service Type is SplitSystemsWithMechanicalVentilation.
kSplitSystemsWithNaturalVentilation | Service Type is SplitSystemsWithNaturalVentilation.
kVariableRefrigerantFlow | Service Type is VariableRefrigerantFlow.
kWaterLoopHeatPump | Service Type is WaterLoopHeatPump.
kActiveChilledBeams | Service Type is ActiveChilledBeams.
kRadiantCooledCeilings | Service Type is RadiantCooledCeilings.
kConstantVolumeDualDuct | Service Type is ConstantVolumeDualDuct.
kMultizoneHotDeckColdDeck | Service Type is MultizoneHotDeckColdDeck.
kConstantVolumeTerminalReheat | Service Type is ConstantVolumeTerminalReheat.
kConstantVolumeVariableOA | Service Type is ConstantVolumeVariableOA.
kConstantVolumeFixedOA | Service Type is ConstantVolumeFixedOA.
kInductionSystem | Service Type is InductionSystem.
kFanCoilSystem | Service Type is FanCoilSystem.
kVAVTerminalReheat | Service Type is VAVTerminalReheat.
kVAVIndoorPackagedCabinet | Service Type is VAVIndoorPackagedCabinet.
kVAVDualDuct | Service Type is VAVDualDuct.
kVAVSingleDuct | Service Type is VAVSingleDuct.
kForcedConvectionHeaterNoFlue | Service Type is ForcedConvectionHeaterNoFlue.
kForcedConvectionHeaterFlue | Service Type is ForcedConvectionHeaterFlue.
kRadiantHeaterMultiburner | Service Type is RadiantHeaterMultiburner.
kRadiantHeaterNoFlue | Service Type is RadiantHeaterNoFlue.
kRadiantHeaterFlue | Service Type is RadiantHeaterFlue.
kOtherRoomHeater | Service Type is OtherRoomHeater.
kCentralHeatingHotAir | Service Type is CentralHeatingHotAir.
kCentralHeatingRadiantFloor | Service Type is CentralHeatingRadiantFloor.
kCentralHeatingConvectors | Service Type is CentralHeatingConvectors.
kCentralHeatingRadiators | Service Type is CentralHeatingRadiators.
kNoServiceType | Service Type is NoServiceType.

See Also

Autodesk.Revit.Parameters Namespace


StorageType Enumeration

[image]

Revit 2010 API
StorageType Enumeration
See Also Send Feedback
An enumerate type listing all of the internal parameter data storage types that Autodesk Revit supports.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum StorageType
Visual Basic (Declaration)
Public Enumeration StorageType
Visual C++
public enum class StorageType

Members

Member name | Description
ElementId | The data type represents an element and is stored as the id of the element.
String | The internal data will be stored in the form of a string of characters.
Integer | The internal data is stored in the form of a signed 32 bit integer.
Double | The data will be stored internaly in the form of an 8 byte floating point number.
None | None represents an invalid storage type. This value should not be used.

See Also

Autodesk.Revit.Parameters Namespace


TypeBinding Class

[image]

Revit 2010 API
TypeBinding Class
Members Example See Also Send Feedback
TypeBinding objects are used to bind a property to a Revit type, such as a wall type.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class TypeBinding : ElementBinding
Visual Basic (Declaration)
Public Class TypeBinding _
    Inherits ElementBinding
Visual C++
public ref class TypeBinding : public ElementBinding

Remarks

This differs from Instance bindings in that the property is then shared by all instances that use that type. Changing the parameter for one type affects all other instances that use that type.

Examples

CopyC#
public bool SetNewParameterToTypeWall(Autodesk.Revit.Application app, DefinitionFile myDefinitionFile)
{
    // Create a new group in the shared parameters file
    DefinitionGroups myGroups = myDefinitionFile.Groups;
    DefinitionGroup myGroup = myGroups.Create("MyParameters");

    // Create a type definition
    Definition myDefinition_CompanyName =
       myGroup.Definitions.Create("CompanyName", ParameterType.Text);

    // Create a category set and insert category of wall to it
    CategorySet myCategories = app.Create.NewCategorySet();
    // Use BuiltInCategory to get category of wall
    Category myCategory = app.ActiveDocument.Settings.Categories.get_Item(
                                    BuiltInCategory.OST_Walls);
    myCategories.Insert(myCategory);

    //Create an object of TypeBinding according to the Categories
    TypeBinding typeBinding = app.Create.NewTypeBinding(myCategories);

    // Get the BingdingMap of current document.
    BindingMap bindingMap = app.ActiveDocument.ParameterBindings;

    // Bind the definitions to the document
    bool typeBindOK = bindingMap.Insert(myDefinition_CompanyName, typeBinding,
      BuiltInParameterGroup.PG_TEXT);
    return typeBindOK;
}
CopyVB.NET
Public Function SetNewParameterToTypeWall(ByVal app As Autodesk.Revit.Application, ByVal myDefinitionFile As DefinitionFile) As Boolean
    ' Create a new group in the shared parameters file
    Dim myGroups As DefinitionGroups = myDefinitionFile.Groups
    Dim myGroup As DefinitionGroup = myGroups.Create("MyParameters")

    ' Create a type definition
    Dim myDefinition_CompanyName As Definition = myGroup.Definitions.Create("CompanyName", ParameterType.Text)

    ' Create a category set and insert category of wall to it
    Dim myCategories As CategorySet = app.Create.NewCategorySet()
    ' Use BuiltInCategory to get category of wall
    Dim myCategory As Autodesk.Revit.Category = app.ActiveDocument.Settings.Categories.Item(BuiltInCategory.OST_Walls)
    myCategories.Insert(myCategory)

    'Create an object of TypeBinding according to the Categories
    Dim typeBinding As TypeBinding = app.Create.NewTypeBinding(myCategories)

    ' Get the BingdingMap of current document.
    Dim bindingMap As BindingMap = app.ActiveDocument.ParameterBindings

    ' Bind the definitions to the document
    Dim typeBindOK As Boolean = bindingMap.Insert(myDefinition_CompanyName, typeBinding, BuiltInParameterGroup.PG_TEXT)
    Return typeBindOK
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.Binding
Autodesk.Revit.Parameters..::.ElementBinding
Autodesk.Revit.Parameters..::.TypeBinding

See Also

TypeBinding Members
Autodesk.Revit.Parameters Namespace


TypeBinding Members

[image] [image]

Revit 2010 API
TypeBinding Members
TypeBinding Class Constructors Methods Properties See Also Send Feedback

The TypeBinding type exposes the following members.

Constructors

Name | Description
TypeBinding | Overloaded.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TypeBinding Class
Autodesk.Revit.Parameters Namespace


TypeBinding Constructor

[image] [image]

Revit 2010 API
TypeBinding Constructor
TypeBinding Class See Also Send Feedback

Overload List

Name | Description
TypeBinding()()() | Constructs an empty type binding.
TypeBinding(CategorySet) | Constructs a type binding with the set of categories passed.

See Also

TypeBinding Class
TypeBinding Members
Autodesk.Revit.Parameters Namespace


TypeBinding Constructor

[image]

Revit 2010 API
TypeBinding Constructor
TypeBinding Class See Also Send Feedback
Constructs an empty type binding.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TypeBinding()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TypeBinding()

Remarks

Categories can be set a later time by using the Categories property of this object.

See Also

TypeBinding Class
TypeBinding Overload
Autodesk.Revit.Parameters Namespace


TypeBinding Constructor (CategorySet)

[image]

Revit 2010 API
TypeBinding Constructor (CategorySet)
TypeBinding Class See Also Send Feedback
Constructs a type binding with the set of categories passed.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TypeBinding(
    CategorySet categories
)
Visual Basic (Declaration)
Public Sub New ( _
    categories As CategorySet _
)
Visual C++
public:
TypeBinding(
    CategorySet^ categories
)

Parameters

categories
Type: Autodesk.Revit..::.CategorySet

Remarks

Categories can be set or changed at a later time by using the Categories property of this object.

See Also

TypeBinding Class
TypeBinding Overload
Autodesk.Revit.Parameters Namespace


TypeBinding Methods

[image] [image]

Revit 2010 API
TypeBinding Methods
TypeBinding Class See Also Send Feedback

The TypeBinding type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TypeBinding Class
Autodesk.Revit.Parameters Namespace


TypeBinding Properties

[image] [image]

Revit 2010 API
TypeBinding Properties
TypeBinding Class See Also Send Feedback

The TypeBinding type exposes the following members.

Properties

Name | Description
Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TypeBinding Class
Autodesk.Revit.Parameters Namespace


Autodesk.Revit.Rooms Namespace

[image]

Revit 2010 API
Autodesk.Revit.Rooms Namespace
Send Feedback

Classes

Class | Description
BoundarySegment | An object that represents a segment of a room boundary.
BoundarySegmentArray | An array that contains boundary segments.
BoundarySegmentArrayArray | An array that contains boundary segment arrays.
BoundarySegmentArrayArrayIterator | An iterator to a array of boundary segment arrays.
BoundarySegmentArrayIterator | An iterator to a boundary segment array.

Enumerations

Enumeration | Description
BoundaryLocationType | An enumerated type listing the options for volume computation in Autodesk Revit.


BoundaryLocationType Enumeration

[image]

Revit 2010 API
BoundaryLocationType Enumeration
See Also Send Feedback
An enumerated type listing the options for volume computation in Autodesk Revit.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum BoundaryLocationType
Visual Basic (Declaration)
Public Enumeration BoundaryLocationType
Visual C++
public enum class BoundaryLocationType

Members

Member name | Description
WallCoreCenter | Room area is computed at wall core center.
WallCoreLayer | Room area is computed at wall core layer.
WallCenter | Room area is computed at wall center.
WallFinish | Room area is computed at wall finish.

See Also

Autodesk.Revit.Rooms Namespace


BoundarySegment Class

[image]

Revit 2010 API
BoundarySegment Class
Members Example See Also Send Feedback
An object that represents a segment of a room boundary.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BoundarySegment : APIObject
Visual Basic (Declaration)
Public Class BoundarySegment _
    Inherits APIObject
Visual C++
public ref class BoundarySegment : public APIObject

Remarks

These objects define the the exterior boundary of a room. The geometry of the segment can be retrieved along with the element that is responsible for producing that boundary.

Examples

CopyC#
public void GetInfo_BoundarySegment(Room room)
{
    if (room.Boundary != null)
    {
        string message = "BoundarySegment";
        foreach (BoundarySegmentArray boundarySegmentArray in room.Boundary)
        {
            foreach (BoundarySegment boundarySegment in boundarySegmentArray)
            {
                // Get curve start point
                message += "\nCurve start point:(" + boundarySegment.Curve.get_EndPoint(0).X + ","
                               + boundarySegment.Curve.get_EndPoint(0).Y + "," +
                              boundarySegment.Curve.get_EndPoint(0).Z + ")";
                // Get curve end point
                message += "; Curve end point:(" + boundarySegment.Curve.get_EndPoint(1).X + ","
                     + boundarySegment.Curve.get_EndPoint(1).Y + "," +
                     boundarySegment.Curve.get_EndPoint(1).Z + ")";
                // Get document path name
                message += "; Document path name:" + boundarySegment.Document.PathName;
                // Get boundary segment element name
                message += "; Element name:" + boundarySegment.Element.Name;
            }
        }
        MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
    }
}
CopyVB.NET
Public Sub GetInfo_BoundarySegment(ByVal room As Room)
    If room.Boundary IsNot Nothing Then
        Dim message As String = "BoundarySegment"
        For Each boundarySegmentArray As BoundarySegmentArray In room.Boundary
            For Each boundarySegment As BoundarySegment In boundarySegmentArray
                ' Get curve start point
                message += ((vbLf & "Curve start point:(" & boundarySegment.Curve.EndPoint(0).X & ",") + boundarySegment.Curve.EndPoint(0).Y & ",") + boundarySegment.Curve.EndPoint(0).Z & ")"
                ' Get curve end point
                message += (("; Curve end point:(" & boundarySegment.Curve.EndPoint(1).X & ",") + boundarySegment.Curve.EndPoint(1).Y & ",") + boundarySegment.Curve.EndPoint(1).Z & ")"
                ' Get document path name
                message += "; Document path name:" & boundarySegment.Document.PathName
                ' Get boundary segment element name
                message += "; Element name:" & boundarySegment.Element.Name
            Next
        Next
        MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Rooms..::.BoundarySegment

See Also

BoundarySegment Members
Autodesk.Revit.Rooms Namespace


BoundarySegment Members

[image] [image]

Revit 2010 API
BoundarySegment Members
BoundarySegment Class Constructors Methods Properties See Also Send Feedback

The BoundarySegment type exposes the following members.

Constructors

Name | Description
BoundarySegment | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Curve | Get the curve that is formed by the element that defines the edge of this room.
Document | Provides the document in which the element that created this segment resides.
Element | Retrieve the element that is responsible for producing this boundary segment.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment Class
Autodesk.Revit.Rooms Namespace


BoundarySegment Constructor

[image]

Revit 2010 API
BoundarySegment Constructor
BoundarySegment Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundarySegment()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegment()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegment Class
Autodesk.Revit.Rooms Namespace


BoundarySegment Methods

[image] [image]

Revit 2010 API
BoundarySegment Methods
BoundarySegment Class See Also Send Feedback

The BoundarySegment type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegment Class
Autodesk.Revit.Rooms Namespace


BoundarySegment Properties

[image] [image]

Revit 2010 API
BoundarySegment Properties
BoundarySegment Class See Also Send Feedback

The BoundarySegment type exposes the following members.

Properties

Name | Description
Curve | Get the curve that is formed by the element that defines the edge of this room.
Document | Provides the document in which the element that created this segment resides.
Element | Retrieve the element that is responsible for producing this boundary segment.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment Class
Autodesk.Revit.Rooms Namespace


Curve Property

[image]

Revit 2010 API
BoundarySegment..::.Curve Property
BoundarySegment Class See Also Send Feedback
Get the curve that is formed by the element that defines the edge of this room.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

BoundarySegment Class
Autodesk.Revit.Rooms Namespace


Document Property

[image]

Revit 2010 API
BoundarySegment..::.Document Property
BoundarySegment Class See Also Send Feedback
Provides the document in which the element that created this segment resides.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

BoundarySegment Class
Autodesk.Revit.Rooms Namespace


Element Property

[image]

Revit 2010 API
BoundarySegment..::.Element Property
BoundarySegment Class See Also Send Feedback
Retrieve the element that is responsible for producing this boundary segment.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element Element { get; }
Visual Basic (Declaration)
Public ReadOnly Property Element As Element
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

Remarks

The element property is useful for finding all the elements that bound a specific room.

See Also

BoundarySegment Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArray Class

[image]

Revit 2010 API
BoundarySegmentArray Class
Members See Also Send Feedback
An array that contains boundary segments.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BoundarySegmentArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class BoundarySegmentArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class BoundarySegmentArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Rooms..::.BoundarySegmentArray

See Also

BoundarySegmentArray Members
Autodesk.Revit.Rooms Namespace


BoundarySegmentArray Members

[image] [image]

Revit 2010 API
BoundarySegmentArray Members
BoundarySegmentArray Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Constructors

Name | Description
BoundarySegmentArray | Initializes a new instance of the BoundarySegmentArray class

Methods

Name | Description
Append | Add the boundary segment to the end of the array.
Clear | Removes every boundary segment from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified boundary segment into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment at a specified index within the array.
Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArray Constructor

[image]

Revit 2010 API
BoundarySegmentArray Constructor
BoundarySegmentArray Class See Also Send Feedback
Initializes a new instance of the BoundarySegmentArray class

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundarySegmentArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArray()

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArray Methods

[image] [image]

Revit 2010 API
BoundarySegmentArray Methods
BoundarySegmentArray Class See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Methods

Name | Description
Append | Add the boundary segment to the end of the array.
Clear | Removes every boundary segment from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified boundary segment into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


Append Method

[image]

Revit 2010 API
BoundarySegmentArray..::.Append Method
BoundarySegmentArray Class See Also Send Feedback
Add the boundary segment to the end of the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    BoundarySegment item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As BoundarySegment _
)
Visual C++
public:
virtual void Append(
    BoundarySegment^ item
)

Parameters

item
Type: Autodesk.Revit.Rooms..::.BoundarySegment
The boundary segment to be added.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


Clear Method

[image]

Revit 2010 API
BoundarySegmentArray..::.Clear Method
BoundarySegmentArray Class See Also Send Feedback
Removes every boundary segment from the array, rendering it empty.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


ForwardIterator Method

[image]

Revit 2010 API
BoundarySegmentArray..::.ForwardIterator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


GetEnumerator Method

[image]

Revit 2010 API
BoundarySegmentArray..::.GetEnumerator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


Insert Method

[image]

Revit 2010 API
BoundarySegmentArray..::.Insert Method
BoundarySegmentArray Class See Also Send Feedback
Insert the specified boundary segment into the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    BoundarySegment item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As BoundarySegment, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    BoundarySegment^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Rooms..::.BoundarySegment
The boundary segment to be inserted into the array.
index
Type: System..::.Int32
The boundary segment will be inserted before this index.

Return Value

Returns whether the boundary segment was inserted into the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


ReverseIterator Method

[image]

Revit 2010 API
BoundarySegmentArray..::.ReverseIterator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArray Properties

[image] [image]

Revit 2010 API
BoundarySegmentArray Properties
BoundarySegmentArray Class See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment at a specified index within the array.
Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


IsEmpty Property

[image]

Revit 2010 API
BoundarySegmentArray..::.IsEmpty Property
BoundarySegmentArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


Item Property

[image]

Revit 2010 API
BoundarySegmentArray..::.Item Property
BoundarySegmentArray Class See Also Send Feedback
Gets or sets a boundary segment at a specified index within the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual BoundarySegment Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegment
Visual C++
public:
virtual property BoundarySegment^ Item[int index] {
    BoundarySegment^ get (int index);
    void set (int index, BoundarySegment^ value);
}

Parameters

index
Type: System..::.Int32
The index of the boundary segment to be set or retrieved.

Return Value

Returns the boundary segment at the specified index.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


Size Property

[image]

Revit 2010 API
BoundarySegmentArray..::.Size Property
BoundarySegmentArray Class See Also Send Feedback
Returns the number of boundary segments that are in the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArray Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayArray Class

[image]

Revit 2010 API
BoundarySegmentArrayArray Class
Members See Also Send Feedback
An array that contains boundary segment arrays.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BoundarySegmentArrayArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class BoundarySegmentArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class BoundarySegmentArrayArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Rooms..::.BoundarySegmentArrayArray

See Also

BoundarySegmentArrayArray Members
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayArray Members

[image] [image]

Revit 2010 API
BoundarySegmentArrayArray Members
BoundarySegmentArrayArray Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Constructors

Name | Description
BoundarySegmentArrayArray | Initializes a new instance of the BoundarySegmentArrayArray class

Methods

Name | Description
Append | Add the boundary segment array to the end of the array.
Clear | Removes every boundary segment array from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified boundary segment array into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment array at a specified index within the array.
Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayArray Constructor

[image]

Revit 2010 API
BoundarySegmentArrayArray Constructor
BoundarySegmentArrayArray Class See Also Send Feedback
Initializes a new instance of the BoundarySegmentArrayArray class

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundarySegmentArrayArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayArray()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayArray Methods

[image] [image]

Revit 2010 API
BoundarySegmentArrayArray Methods
BoundarySegmentArrayArray Class See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Methods

Name | Description
Append | Add the boundary segment array to the end of the array.
Clear | Removes every boundary segment array from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified boundary segment array into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


Append Method

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.Append Method
BoundarySegmentArrayArray Class See Also Send Feedback
Add the boundary segment array to the end of the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    BoundarySegmentArray item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As BoundarySegmentArray _
)
Visual C++
public:
virtual void Append(
    BoundarySegmentArray^ item
)

Parameters

item
Type: Autodesk.Revit.Rooms..::.BoundarySegmentArray
The boundary segment array to be added.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


Clear Method

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.Clear Method
BoundarySegmentArrayArray Class See Also Send Feedback
Removes every boundary segment array from the array, rendering it empty.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


ForwardIterator Method

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.ForwardIterator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


GetEnumerator Method

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.GetEnumerator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


Insert Method

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.Insert Method
BoundarySegmentArrayArray Class See Also Send Feedback
Insert the specified boundary segment array into the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    BoundarySegmentArray item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As BoundarySegmentArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    BoundarySegmentArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Rooms..::.BoundarySegmentArray
The boundary segment array to be inserted into the array.
index
Type: System..::.Int32
The boundary segment array will be inserted before this index.

Return Value

Returns whether the boundary segment array was inserted into the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


ReverseIterator Method

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.ReverseIterator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayArray Properties

[image] [image]

Revit 2010 API
BoundarySegmentArrayArray Properties
BoundarySegmentArrayArray Class See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment array at a specified index within the array.
Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


IsEmpty Property

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.IsEmpty Property
BoundarySegmentArrayArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


Item Property

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.Item Property
BoundarySegmentArrayArray Class See Also Send Feedback
Gets or sets a boundary segment array at a specified index within the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual BoundarySegmentArray Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegmentArray
Visual C++
public:
virtual property BoundarySegmentArray^ Item[int index] {
    BoundarySegmentArray^ get (int index);
    void set (int index, BoundarySegmentArray^ value);
}

Parameters

index
Type: System..::.Int32
The index of the boundary segment array to be set or retrieved.

Return Value

Returns the boundary segment array at the specified index.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


Size Property

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.Size Property
BoundarySegmentArrayArray Class See Also Send Feedback
Returns the number of boundary segment arrays that are in the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayArrayIterator Class

[image]

Revit 2010 API
BoundarySegmentArrayArrayIterator Class
Members See Also Send Feedback
An iterator to a array of boundary segment arrays.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class BoundarySegmentArrayArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class BoundarySegmentArrayArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Rooms..::.BoundarySegmentArrayArrayIterator

See Also

BoundarySegmentArrayArrayIterator Members
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayArrayIterator Members

[image] [image]

Revit 2010 API
BoundarySegmentArrayArrayIterator Members
BoundarySegmentArrayArrayIterator Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Constructors

Name | Description
BoundarySegmentArrayArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayArrayIterator Constructor

[image]

Revit 2010 API
BoundarySegmentArrayArrayIterator Constructor
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundarySegmentArrayArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayArrayIterator Methods

[image] [image]

Revit 2010 API
BoundarySegmentArrayArrayIterator Methods
BoundarySegmentArrayArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Rooms Namespace


MoveNext Method

[image]

Revit 2010 API
BoundarySegmentArrayArrayIterator..::.MoveNext Method
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Rooms Namespace


Reset Method

[image]

Revit 2010 API
BoundarySegmentArrayArrayIterator..::.Reset Method
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayArrayIterator Properties

[image] [image]

Revit 2010 API
BoundarySegmentArrayArrayIterator Properties
BoundarySegmentArrayArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Rooms Namespace


Current Property

[image]

Revit 2010 API
BoundarySegmentArrayArrayIterator..::.Current Property
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayIterator Class

[image]

Revit 2010 API
BoundarySegmentArrayIterator Class
Members See Also Send Feedback
An iterator to a boundary segment array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class BoundarySegmentArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class BoundarySegmentArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Rooms..::.BoundarySegmentArrayIterator

See Also

BoundarySegmentArrayIterator Members
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayIterator Members

[image] [image]

Revit 2010 API
BoundarySegmentArrayIterator Members
BoundarySegmentArrayIterator Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Constructors

Name | Description
BoundarySegmentArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayIterator Constructor

[image]

Revit 2010 API
BoundarySegmentArrayIterator Constructor
BoundarySegmentArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundarySegmentArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayIterator Methods

[image] [image]

Revit 2010 API
BoundarySegmentArrayIterator Methods
BoundarySegmentArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Rooms Namespace


MoveNext Method

[image]

Revit 2010 API
BoundarySegmentArrayIterator..::.MoveNext Method
BoundarySegmentArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Rooms Namespace


Reset Method

[image]

Revit 2010 API
BoundarySegmentArrayIterator..::.Reset Method
BoundarySegmentArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Rooms Namespace


BoundarySegmentArrayIterator Properties

[image] [image]

Revit 2010 API
BoundarySegmentArrayIterator Properties
BoundarySegmentArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Rooms Namespace


Current Property

[image]

Revit 2010 API
BoundarySegmentArrayIterator..::.Current Property
BoundarySegmentArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Rooms Namespace


Autodesk.Revit.Site Namespace

[image]

Revit 2010 API
Autodesk.Revit.Site Namespace
Send Feedback

Classes

Class | Description
City | An object that contains geographical locational informaiton for a known city.
CitySet | An set that contains cities.
CitySetIterator | An iterator to a city set.
ProjectLocation | An object that represents a named location in a project.
ProjectLocationSet | An set that contains project locations.
ProjectLocationSetIterator | An iterator to a project location set.
ProjectPosition | An object that is used to represent a geographical offset and rotation.
SiteLocation | Contains the geographical location information for the project's site.


City Class

[image]

Revit 2010 API
City Class
Members Example See Also Send Feedback
An object that contains geographical locational informaiton for a known city.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class City : APIObject
Visual Basic (Declaration)
Public Class City _
    Inherits APIObject
Visual C++
public ref class City : public APIObject

Remarks

This object contains longitude, latitude, timezone information for a city already known by Revit. Currently Revit does not the ability to add cities to the existing list. The list of known cities can be retrieved using the Cities property on the application object.

Examples

CopyC#
double angleRatio = Math.PI / 180;   // ratio of Angle

// Get the Latitude information
double latiude = city.Latitude / angleRatio;
String latiudeInfo = "Latitude:      " + latiude.ToString();

// Get the Longitude information
double longitude = city.Longitude / angleRatio;
String longitudeInfo = "Longitude:   " + longitude.ToString();

// Get the TimeZone information
String timeZoneInfo = "TimeZone:   " + city.TimeZone.ToString();

// Set the information text box.
string cityInfo = latiudeInfo + "\n" + longitudeInfo
                            + "\n" + timeZoneInfo;
CopyVB.NET
Dim angleRatio As Double = Math.PI / 180
' ratio of Angle
' Get the Latitude information
Dim latiude As Double = city.Latitude / angleRatio
Dim latiudeInfo As String = "Latitude: " & latiude.ToString()

' Get the Longitude information
Dim longitude As Double = city.Longitude / angleRatio
Dim longitudeInfo As String = "Longitude: " & longitude.ToString()

' Get the TimeZone information
Dim timeZoneInfo As String = "TimeZone: " & city.TimeZone.ToString()

' Set the information text box.
Dim cityInfo As String = ((latiudeInfo & vbLf) + longitudeInfo & vbLf) + timeZoneInfo

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Site..::.City

See Also

City Members
Autodesk.Revit.Site Namespace


City Members

[image] [image]

Revit 2010 API
City Members
City Class Constructors Methods Properties See Also Send Feedback

The City type exposes the following members.

Constructors

Name | Description
City | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Latitude | Latitde of the city
Longitude | Longitude of the city
Name | The name of the city
TimeZone | Timezone in which the city resides

See Also

City Class
Autodesk.Revit.Site Namespace


City Constructor

[image]

Revit 2010 API
City Constructor
City Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public City()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
City()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

City Class
Autodesk.Revit.Site Namespace


City Methods

[image] [image]

Revit 2010 API
City Methods
City Class See Also Send Feedback

The City type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

City Class
Autodesk.Revit.Site Namespace


City Properties

[image] [image]

Revit 2010 API
City Properties
City Class See Also Send Feedback

The City type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Latitude | Latitde of the city
Longitude | Longitude of the city
Name | The name of the city
TimeZone | Timezone in which the city resides

See Also

City Class
Autodesk.Revit.Site Namespace


Latitude Property

[image]

Revit 2010 API
City..::.Latitude Property
City Class See Also Send Feedback
Latitde of the city

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Latitude { get; }
Visual Basic (Declaration)
Public ReadOnly Property Latitude As Double
Visual C++
public:
property double Latitude {
    double get ();
}

Remarks

A read only property that contains the latitude of the city. The value returned is in radians, ranging from -PI to +PI.

See Also

City Class
Autodesk.Revit.Site Namespace


Longitude Property

[image]

Revit 2010 API
City..::.Longitude Property
City Class See Also Send Feedback
Longitude of the city

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Longitude { get; }
Visual Basic (Declaration)
Public ReadOnly Property Longitude As Double
Visual C++
public:
property double Longitude {
    double get ();
}

Remarks

A read only property that contains the longitude of the city. The value returned is in radians, ranging from -PI to +PI.

See Also

City Class
Autodesk.Revit.Site Namespace


Name Property

[image]

Revit 2010 API
City..::.Name Property
City Class See Also Send Feedback
The name of the city

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

Remarks

A read only string property that contains the name of the city, such as Boston.

See Also

City Class
Autodesk.Revit.Site Namespace


TimeZone Property

[image]

Revit 2010 API
City..::.TimeZone Property
City Class See Also Send Feedback
Timezone in which the city resides

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double TimeZone { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeZone As Double
Visual C++
public:
property double TimeZone {
    double get ();
}

Remarks

A read only property that returns the time zone in which the city resides. The value is in hours, ranging from +12 hours to -12 hours with 0 being GMT.

See Also

City Class
Autodesk.Revit.Site Namespace


CitySet Class

[image]

Revit 2010 API
CitySet Class
Members See Also Send Feedback
An set that contains cities.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CitySet : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class CitySet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CitySet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Site..::.CitySet

See Also

CitySet Members
Autodesk.Revit.Site Namespace


CitySet Members

[image] [image]

Revit 2010 API
CitySet Members
CitySet Class Constructors Methods Properties See Also Send Feedback

The CitySet type exposes the following members.

Constructors

Name | Description
CitySet | Initializes a new instance of the CitySet class

Methods

Name | Description
Clear | Removes every city from the set, rendering it empty.
Contains | Tests for the existence of a city within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified city from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified city into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of cities that are in the set.

See Also

CitySet Class
Autodesk.Revit.Site Namespace


CitySet Constructor

[image]

Revit 2010 API
CitySet Constructor
CitySet Class See Also Send Feedback
Initializes a new instance of the CitySet class

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CitySet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CitySet()

See Also

CitySet Class
Autodesk.Revit.Site Namespace


CitySet Methods

[image] [image]

Revit 2010 API
CitySet Methods
CitySet Class See Also Send Feedback

The CitySet type exposes the following members.

Methods

Name | Description
Clear | Removes every city from the set, rendering it empty.
Contains | Tests for the existence of a city within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified city from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified city into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CitySet Class
Autodesk.Revit.Site Namespace


Clear Method

[image]

Revit 2010 API
CitySet..::.Clear Method
CitySet Class See Also Send Feedback
Removes every city from the set, rendering it empty.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CitySet Class
Autodesk.Revit.Site Namespace


Contains Method

[image]

Revit 2010 API
CitySet..::.Contains Method
CitySet Class See Also Send Feedback
Tests for the existence of a city within the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    City item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As City _
) As Boolean
Visual C++
public:
virtual bool Contains(
    City^ item
)

Parameters

item
Type: Autodesk.Revit.Site..::.City
The city to be searched for.

Return Value

The Contains method returns True if the city is within the set, otherwise False.

See Also

CitySet Class
Autodesk.Revit.Site Namespace


Erase Method

[image]

Revit 2010 API
CitySet..::.Erase Method
CitySet Class See Also Send Feedback
Removes a specified city from the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    City item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As City _
) As Integer
Visual C++
public:
virtual int Erase(
    City^ item
)

Parameters

item
Type: Autodesk.Revit.Site..::.City
The city to be erased.

Return Value

The number of cities that were erased from the set.

See Also

CitySet Class
Autodesk.Revit.Site Namespace


ForwardIterator Method

[image]

Revit 2010 API
CitySet..::.ForwardIterator Method
CitySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CitySetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CitySetIterator
Visual C++
public:
virtual CitySetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

CitySet Class
Autodesk.Revit.Site Namespace


GetEnumerator Method

[image]

Revit 2010 API
CitySet..::.GetEnumerator Method
CitySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CitySet Class
Autodesk.Revit.Site Namespace


Insert Method

[image]

Revit 2010 API
CitySet..::.Insert Method
CitySet Class See Also Send Feedback
Insert the specified city into the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    City item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As City _
) As Boolean
Visual C++
public:
virtual bool Insert(
    City^ item
)

Parameters

item
Type: Autodesk.Revit.Site..::.City
The city to be inserted into the set.

Return Value

Returns whether the city was inserted into the set.

See Also

CitySet Class
Autodesk.Revit.Site Namespace


ReverseIterator Method

[image]

Revit 2010 API
CitySet..::.ReverseIterator Method
CitySet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CitySetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CitySetIterator
Visual C++
public:
virtual CitySetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

CitySet Class
Autodesk.Revit.Site Namespace


CitySet Properties

[image] [image]

Revit 2010 API
CitySet Properties
CitySet Class See Also Send Feedback

The CitySet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of cities that are in the set.

See Also

CitySet Class
Autodesk.Revit.Site Namespace


IsEmpty Property

[image]

Revit 2010 API
CitySet..::.IsEmpty Property
CitySet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CitySet Class
Autodesk.Revit.Site Namespace


Size Property

[image]

Revit 2010 API
CitySet..::.Size Property
CitySet Class See Also Send Feedback
Returns the number of cities that are in the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CitySet Class
Autodesk.Revit.Site Namespace


CitySetIterator Class

[image]

Revit 2010 API
CitySetIterator Class
Members See Also Send Feedback
An iterator to a city set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class CitySetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CitySetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CitySetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Site..::.CitySetIterator

See Also

CitySetIterator Members
Autodesk.Revit.Site Namespace


CitySetIterator Members

[image] [image]

Revit 2010 API
CitySetIterator Members
CitySetIterator Class Constructors Methods Properties See Also Send Feedback

The CitySetIterator type exposes the following members.

Constructors

Name | Description
CitySetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CitySetIterator Class
Autodesk.Revit.Site Namespace


CitySetIterator Constructor

[image]

Revit 2010 API
CitySetIterator Constructor
CitySetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CitySetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CitySetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CitySetIterator Class
Autodesk.Revit.Site Namespace


CitySetIterator Methods

[image] [image]

Revit 2010 API
CitySetIterator Methods
CitySetIterator Class See Also Send Feedback

The CitySetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CitySetIterator Class
Autodesk.Revit.Site Namespace


MoveNext Method

[image]

Revit 2010 API
CitySetIterator..::.MoveNext Method
CitySetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CitySetIterator Class
Autodesk.Revit.Site Namespace


Reset Method

[image]

Revit 2010 API
CitySetIterator..::.Reset Method
CitySetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CitySetIterator Class
Autodesk.Revit.Site Namespace


CitySetIterator Properties

[image] [image]

Revit 2010 API
CitySetIterator Properties
CitySetIterator Class See Also Send Feedback

The CitySetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CitySetIterator Class
Autodesk.Revit.Site Namespace


Current Property

[image]

Revit 2010 API
CitySetIterator..::.Current Property
CitySetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CitySetIterator Class
Autodesk.Revit.Site Namespace


ProjectLocation Class

[image]

Revit 2010 API
ProjectLocation Class
Members Example See Also Send Feedback
An object that represents a named location in a project.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ProjectLocation : Instance
Visual Basic (Declaration)
Public Class ProjectLocation _
    Inherits Instance
Visual C++
public ref class ProjectLocation : public Instance

Remarks

Revit Architecture projects can have named locations. A named location is the position of a model instance in a Revit Architecture project. By default, each Revit Architecture project contains at least one named location, called Internal. Existing ProjectLocation objects can be found by using the ProjectLocations property on the Document object. New project locations can be created by duplicating an existing project location using the Duplicate method, and modifying the location's project position.

Examples

CopyC#
public void ShowActiveProjectLocationUsage(Autodesk.Revit.Document document)
{
    // Get the project location handle
    ProjectLocation projectLocation = document.ActiveProjectLocation;

    // Show the information of current project location
    XYZ origin = new XYZ(0, 0, 0);
    ProjectPosition position = projectLocation.get_ProjectPosition(origin);
    if (null == position)
    {
        throw new Exception("No project position in origin point.");
    }

    // Format the prompt string to show the message.
    String prompt = "Current project location information:\n";
    prompt += "\n\t" + "Origin point position:";
    prompt += "\n\t\t" + "Angle: " + position.Angle;
    prompt += "\n\t\t" + "East to West offset: " + position.EastWest;
    prompt += "\n\t\t" + "Elevation: " + position.Elevation;
    prompt += "\n\t\t" + "North to South offset: " + position.NorthSouth;

    // Angles are in radians when coming from Revit API, so we
    // convert to degrees for display
    const double angleRatio = Math.PI / 180;   // angle conversion factor

    SiteLocation site = projectLocation.SiteLocation;
    prompt += "\n\t" + "Site location:";
    prompt += "\n\t\t" + "Latitude: " + site.Latitude / angleRatio + "��";
    prompt += "\n\t\t" + "Longitude: " + site.Longitude / angleRatio + "��";
    prompt += "\n\t\t" + "TimeZone: " + site.TimeZone;

    // Give the user some information
    MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub ShowActiveProjectLocationUsage(ByVal document As Autodesk.Revit.Document)
    ' Get the project location handle
    Dim projectLocation As ProjectLocation = document.ActiveProjectLocation

    ' Show the information of current project location
    Dim origin As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
    Dim position As ProjectPosition = projectLocation.ProjectPosition(origin)
    If position Is Nothing Then
        Throw New Exception("No project position in origin point.")
    End If

    ' Format the prompt string to show the message.
    Dim prompt As String = "Current project location information:" & vbLf
    prompt += vbLf & vbTab & "Origin point position:"
    prompt += (vbLf & vbTab & vbTab & "Angle: ") + position.Angle
    prompt += (vbLf & vbTab & vbTab & "East to West offset: ") + position.EastWest
    prompt += (vbLf & vbTab & vbTab & "Elevation: ") + position.Elevation
    prompt += (vbLf & vbTab & vbTab & "North to South offset: ") + position.NorthSouth

    ' Angles are in radians when coming from Revit API, so we
    ' convert to degrees for display
    Const angleRatio As Double = Math.PI / 180
    ' angle conversion factor
    Dim site As SiteLocation = projectLocation.SiteLocation
    prompt += vbLf & vbTab & "Site location:"
    prompt += (vbLf & vbTab & vbTab & "Latitude: ") + site.Latitude / angleRatio & "¡ã"
    prompt += (vbLf & vbTab & vbTab & "Longitude: ") + site.Longitude / angleRatio & "¡ã"
    prompt += (vbLf & vbTab & vbTab & "TimeZone: ") + site.TimeZone

    ' Give the user some information
    MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Instance
Autodesk.Revit.Site..::.ProjectLocation

See Also

ProjectLocation Members
Autodesk.Revit.Site Namespace


ProjectLocation Members

[image] [image]

Revit 2010 API
ProjectLocation Members
ProjectLocation Class Constructors Methods Properties See Also Send Feedback

The ProjectLocation type exposes the following members.

Constructors

Name | Description
ProjectLocation | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Generate a copy of this project location with the specified name.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The name of the project location. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjectPosition | Gets or sets the coordinates of a point in the project location coordinate system.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SiteLocation | The site location to which this project location refers.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ProjectLocation Class
Autodesk.Revit.Site Namespace


ProjectLocation Constructor

[image]

Revit 2010 API
ProjectLocation Constructor
ProjectLocation Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProjectLocation()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProjectLocation()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ProjectLocation Class
Autodesk.Revit.Site Namespace


ProjectLocation Methods

[image] [image]

Revit 2010 API
ProjectLocation Methods
ProjectLocation Class See Also Send Feedback

The ProjectLocation type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Generate a copy of this project location with the specified name.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProjectLocation Class
Autodesk.Revit.Site Namespace


Duplicate Method

[image]

Revit 2010 API
ProjectLocation..::.Duplicate Method
ProjectLocation Class Example See Also Send Feedback
Generate a copy of this project location with the specified name.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProjectLocation Duplicate(
    string name
)
Visual Basic (Declaration)
Public Function Duplicate ( _
    name As String _
) As ProjectLocation
Visual C++
public:
ProjectLocation^ Duplicate(
    String^ name
)

Parameters

name
Type: System..::.String
The name to be assigned to the duplicated project location.

Return Value

If successful a duplicate of this project location object with the specified name.

Remarks

The name must not be the same as any existing site location objects.

Examples

CopyC#
public ProjectLocation DuplicateLocation(Autodesk.Revit.Document document, string newName)
{
    ProjectLocation currentLocation = document.ActiveProjectLocation;
    ProjectLocationSet locations = document.ProjectLocations;
    foreach (ProjectLocation projectLocation in locations)
    {
        if (projectLocation.Name == newName)
        {
            throw new Exception("The name is same as a project location's name, please change one.");
        }
    }
    return currentLocation.Duplicate(newName);
}
CopyVB.NET
Public Function DuplicateLocation(ByVal document As Autodesk.Revit.Document, ByVal newName As String) As ProjectLocation
    Dim currentLocation As ProjectLocation = document.ActiveProjectLocation
    Dim locations As ProjectLocationSet = document.ProjectLocations
    For Each projectLocation As ProjectLocation In locations
        If projectLocation.Name = newName Then
            Throw New Exception("The name is same as a project location's name, please change one.")
        End If
    Next
    Return currentLocation.Duplicate(newName)
End Function

See Also

ProjectLocation Class
Autodesk.Revit.Site Namespace


ProjectLocation Properties

[image] [image]

Revit 2010 API
ProjectLocation Properties
ProjectLocation Class See Also Send Feedback

The ProjectLocation type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The name of the project location. (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjectPosition | Gets or sets the coordinates of a point in the project location coordinate system.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SiteLocation | The site location to which this project location refers.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ProjectLocation Class
Autodesk.Revit.Site Namespace


Name Property

[image]

Revit 2010 API
ProjectLocation..::.Name Property
ProjectLocation Class See Also Send Feedback
The name of the project location.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override string Name { get; set; }
Visual Basic (Declaration)
Public Overrides Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}

Remarks

This property is used to get or set the name of the project location.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when failing to set the name (for example, because it is not unique).

See Also

ProjectLocation Class
Autodesk.Revit.Site Namespace


Parameter Property

[image] [image]

Revit 2010 API
ProjectLocation..::.Parameter Property
ProjectLocation Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ProjectLocation Class
ProjectLocation Members
Autodesk.Revit.Site Namespace


ProjectPosition Property

[image]

Revit 2010 API
ProjectLocation..::.ProjectPosition Property
ProjectLocation Class Example See Also Send Feedback
Gets or sets the coordinates of a point in the project location coordinate system.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProjectPosition ProjectPosition[
    XYZ point
] { get; set; }
Visual Basic (Declaration)
Public Property ProjectPosition ( _
    point As XYZ _
) As ProjectPosition
Visual C++
public:
property ProjectPosition^ ProjectPosition[XYZ^ point] {
    ProjectPosition^ get (XYZ^ point);
    void set (XYZ^ point, ProjectPosition^ value);
}

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
The point in model coordinates.

Remarks

When getting this property, the North/South, East/West, and Elevation values report the coordinates of the point similar to the Revit command "Report Shared Coordinates". To get the values of the transformations applied by this project location, pass XYZ.Zero.

If the project has acquired shared coordinates from a linked model, the shared coordinate transformation will be reflected in the coordinates of the transformed point returned by this property.

When setting this property, the transformations applied to the location are modified such that the passed point becomes the specified North/South, East/West and Elevation, and the coordinate transform will have the designated angular rotation. This is similar to the Revit command "Specify Coordinates at Point".

Examples

CopyC#
//get and set the value of the projectlocation
public ProjectLocation GetProjectLocation(Autodesk.Revit.Document document)
{
    ProjectLocation currentLocation = document.ActiveProjectLocation;

    //get the project position
    XYZ origin = new XYZ(0, 0, 0);

    const double angleRatio = Math.PI / 180;   // angle conversion factor

    ProjectPosition projectPosition = currentLocation.get_ProjectPosition(origin);
    //Angle from True North
    double angle = 30.0 * angleRatio;   // convert degrees to radian
    double eastWest = 30.0;     //East to West offset
    double northSouth = 23.32;   //North to South offset
    double elevation = 22.14;    //Elevation above ground level

    //create a new project position
    ProjectPosition newPosition =
      document.Application.Create.NewProjectPosition(eastWest, northSouth, elevation, angle);

    if (null != newPosition)
    {
        //set the value of the project position
        currentLocation.set_ProjectPosition(origin, newPosition);
    }

    return currentLocation;
}
CopyVB.NET
'get and set the value of the projectlocation
Public Function GetProjectLocation(ByVal document As Autodesk.Revit.Document) As ProjectLocation
    Dim currentLocation As ProjectLocation = document.ActiveProjectLocation

    'get the project position
    Dim origin As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)

    Const angleRatio As Double = Math.PI / 180
    ' angle conversion factor
    Dim projectPosition As ProjectPosition = currentLocation.ProjectPosition(origin)
    'Angle from True North
    Dim angle As Double = 30.0R * angleRatio
    ' convert degrees to radian
    Dim eastWest As Double = 30.0R
    'East to West offset
    Dim northSouth As Double = 23.32
    'North to South offset
    Dim elevation As Double = 22.14
    'Elevation above ground level
    'create a new project position
    Dim newPosition As ProjectPosition = document.Application.Create.NewProjectPosition(eastWest, northSouth, elevation, angle)

    If newPosition IsNot Nothing Then
        'set the value of the project position
        currentLocation.ProjectPosition(origin) = newPosition
    End If

    Return currentLocation
End Function

See Also

ProjectLocation Class
Autodesk.Revit.Site Namespace


SiteLocation Property

[image]

Revit 2010 API
ProjectLocation..::.SiteLocation Property
ProjectLocation Class See Also Send Feedback
The site location to which this project location refers.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SiteLocation SiteLocation { get; }
Visual Basic (Declaration)
Public ReadOnly Property SiteLocation As SiteLocation
Visual C++
public:
property SiteLocation^ SiteLocation {
    SiteLocation^ get ();
}

Remarks

The site location object contains the longitude, latitude and timezone of the entire project site.

See Also

ProjectLocation Class
Autodesk.Revit.Site Namespace


ProjectLocationSet Class

[image]

Revit 2010 API
ProjectLocationSet Class
Members See Also Send Feedback
An set that contains project locations.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ProjectLocationSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ProjectLocationSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ProjectLocationSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Site..::.ProjectLocationSet

See Also

ProjectLocationSet Members
Autodesk.Revit.Site Namespace


ProjectLocationSet Members

[image] [image]

Revit 2010 API
ProjectLocationSet Members
ProjectLocationSet Class Constructors Methods Properties See Also Send Feedback

The ProjectLocationSet type exposes the following members.

Constructors

Name | Description
ProjectLocationSet | Initializes a new instance of the ProjectLocationSet class

Methods

Name | Description
Clear | Removes every project location from the set, rendering it empty.
Contains | Tests for the existence of a project location within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified project location from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified project location into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of project locations that are in the set.

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


ProjectLocationSet Constructor

[image]

Revit 2010 API
ProjectLocationSet Constructor
ProjectLocationSet Class See Also Send Feedback
Initializes a new instance of the ProjectLocationSet class

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProjectLocationSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProjectLocationSet()

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


ProjectLocationSet Methods

[image] [image]

Revit 2010 API
ProjectLocationSet Methods
ProjectLocationSet Class See Also Send Feedback

The ProjectLocationSet type exposes the following members.

Methods

Name | Description
Clear | Removes every project location from the set, rendering it empty.
Contains | Tests for the existence of a project location within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified project location from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified project location into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


Clear Method

[image]

Revit 2010 API
ProjectLocationSet..::.Clear Method
ProjectLocationSet Class See Also Send Feedback
Removes every project location from the set, rendering it empty.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


Contains Method

[image]

Revit 2010 API
ProjectLocationSet..::.Contains Method
ProjectLocationSet Class See Also Send Feedback
Tests for the existence of a project location within the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    ProjectLocation item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As ProjectLocation _
) As Boolean
Visual C++
public:
virtual bool Contains(
    ProjectLocation^ item
)

Parameters

item
Type: Autodesk.Revit.Site..::.ProjectLocation
The project location to be searched for.

Return Value

The Contains method returns True if the project location is within the set, otherwise False.

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


Erase Method

[image]

Revit 2010 API
ProjectLocationSet..::.Erase Method
ProjectLocationSet Class See Also Send Feedback
Removes a specified project location from the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    ProjectLocation item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As ProjectLocation _
) As Integer
Visual C++
public:
virtual int Erase(
    ProjectLocation^ item
)

Parameters

item
Type: Autodesk.Revit.Site..::.ProjectLocation
The project location to be erased.

Return Value

The number of project locations that were erased from the set.

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


ForwardIterator Method

[image]

Revit 2010 API
ProjectLocationSet..::.ForwardIterator Method
ProjectLocationSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ProjectLocationSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ProjectLocationSetIterator
Visual C++
public:
virtual ProjectLocationSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


GetEnumerator Method

[image]

Revit 2010 API
ProjectLocationSet..::.GetEnumerator Method
ProjectLocationSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


Insert Method

[image]

Revit 2010 API
ProjectLocationSet..::.Insert Method
ProjectLocationSet Class See Also Send Feedback
Insert the specified project location into the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    ProjectLocation item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As ProjectLocation _
) As Boolean
Visual C++
public:
virtual bool Insert(
    ProjectLocation^ item
)

Parameters

item
Type: Autodesk.Revit.Site..::.ProjectLocation
The project location to be inserted into the set.

Return Value

Returns whether the project location was inserted into the set.

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


ReverseIterator Method

[image]

Revit 2010 API
ProjectLocationSet..::.ReverseIterator Method
ProjectLocationSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ProjectLocationSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ProjectLocationSetIterator
Visual C++
public:
virtual ProjectLocationSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


ProjectLocationSet Properties

[image] [image]

Revit 2010 API
ProjectLocationSet Properties
ProjectLocationSet Class See Also Send Feedback

The ProjectLocationSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of project locations that are in the set.

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


IsEmpty Property

[image]

Revit 2010 API
ProjectLocationSet..::.IsEmpty Property
ProjectLocationSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


Size Property

[image]

Revit 2010 API
ProjectLocationSet..::.Size Property
ProjectLocationSet Class See Also Send Feedback
Returns the number of project locations that are in the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ProjectLocationSet Class
Autodesk.Revit.Site Namespace


ProjectLocationSetIterator Class

[image]

Revit 2010 API
ProjectLocationSetIterator Class
Members See Also Send Feedback
An iterator to a project location set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ProjectLocationSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ProjectLocationSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ProjectLocationSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Site..::.ProjectLocationSetIterator

See Also

ProjectLocationSetIterator Members
Autodesk.Revit.Site Namespace


ProjectLocationSetIterator Members

[image] [image]

Revit 2010 API
ProjectLocationSetIterator Members
ProjectLocationSetIterator Class Constructors Methods Properties See Also Send Feedback

The ProjectLocationSetIterator type exposes the following members.

Constructors

Name | Description
ProjectLocationSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ProjectLocationSetIterator Class
Autodesk.Revit.Site Namespace


ProjectLocationSetIterator Constructor

[image]

Revit 2010 API
ProjectLocationSetIterator Constructor
ProjectLocationSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProjectLocationSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProjectLocationSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ProjectLocationSetIterator Class
Autodesk.Revit.Site Namespace


ProjectLocationSetIterator Methods

[image] [image]

Revit 2010 API
ProjectLocationSetIterator Methods
ProjectLocationSetIterator Class See Also Send Feedback

The ProjectLocationSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProjectLocationSetIterator Class
Autodesk.Revit.Site Namespace


MoveNext Method

[image]

Revit 2010 API
ProjectLocationSetIterator..::.MoveNext Method
ProjectLocationSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ProjectLocationSetIterator Class
Autodesk.Revit.Site Namespace


Reset Method

[image]

Revit 2010 API
ProjectLocationSetIterator..::.Reset Method
ProjectLocationSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ProjectLocationSetIterator Class
Autodesk.Revit.Site Namespace


ProjectLocationSetIterator Properties

[image] [image]

Revit 2010 API
ProjectLocationSetIterator Properties
ProjectLocationSetIterator Class See Also Send Feedback

The ProjectLocationSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ProjectLocationSetIterator Class
Autodesk.Revit.Site Namespace


Current Property

[image]

Revit 2010 API
ProjectLocationSetIterator..::.Current Property
ProjectLocationSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ProjectLocationSetIterator Class
Autodesk.Revit.Site Namespace


ProjectPosition Class

[image]

Revit 2010 API
ProjectPosition Class
Members See Also Send Feedback
An object that is used to represent a geographical offset and rotation.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ProjectPosition : APIObject
Visual Basic (Declaration)
Public Class ProjectPosition _
    Inherits APIObject
Visual C++
public ref class ProjectPosition : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Site..::.ProjectPosition

See Also

ProjectPosition Members
Autodesk.Revit.Site Namespace


ProjectPosition Members

[image] [image]

Revit 2010 API
ProjectPosition Members
ProjectPosition Class Constructors Methods Properties See Also Send Feedback

The ProjectPosition type exposes the following members.

Constructors

Name | Description
ProjectPosition | Overloaded.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Angle | Angle from True North
EastWest | East/West offset
Elevation | Elevation above ground level.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
NorthSouth | North/South offset

See Also

ProjectPosition Class
Autodesk.Revit.Site Namespace


ProjectPosition Constructor

[image] [image]

Revit 2010 API
ProjectPosition Constructor
ProjectPosition Class See Also Send Feedback

Overload List

Name | Description
ProjectPosition()()() | For Internal Use Only.
ProjectPosition(Double, Double, Double, Double) | Construct a new ProjectPosition object with the specified East/West offset, North/South offset, elevation offset and angle of rotation

See Also

ProjectPosition Class
ProjectPosition Members
Autodesk.Revit.Site Namespace


ProjectPosition Constructor

[image]

Revit 2010 API
ProjectPosition Constructor
ProjectPosition Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProjectPosition()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProjectPosition()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ProjectPosition Class
ProjectPosition Overload
Autodesk.Revit.Site Namespace


ProjectPosition Constructor (Double, Double, Double, Double)

[image]

Revit 2010 API
ProjectPosition Constructor (Double, Double, Double, Double)
ProjectPosition Class See Also Send Feedback
Construct a new ProjectPosition object with the specified East/West offset, North/South offset, elevation offset and angle of rotation

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)
Visual Basic (Declaration)
Public Sub New ( _
    ew As Double, _
    ns As Double, _
    elevation As Double, _
    angle As Double _
)
Visual C++
public:
ProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)

Parameters

ew
Type: System..::.Double
East/West offset
ns
Type: System..::.Double
North/South offset
elevation
Type: System..::.Double
Elevation offset
angle
Type: System..::.Double
Rotation from true north, in radians.

Remarks

The angle can be in the range of +PI to -PI

See Also

ProjectPosition Class
ProjectPosition Overload
Autodesk.Revit.Site Namespace


ProjectPosition Methods

[image] [image]

Revit 2010 API
ProjectPosition Methods
ProjectPosition Class See Also Send Feedback

The ProjectPosition type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProjectPosition Class
Autodesk.Revit.Site Namespace


ProjectPosition Properties

[image] [image]

Revit 2010 API
ProjectPosition Properties
ProjectPosition Class See Also Send Feedback

The ProjectPosition type exposes the following members.

Properties

Name | Description
Angle | Angle from True North
EastWest | East/West offset
Elevation | Elevation above ground level.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
NorthSouth | North/South offset

See Also

ProjectPosition Class
Autodesk.Revit.Site Namespace


Angle Property

[image]

Revit 2010 API
ProjectPosition..::.Angle Property
ProjectPosition Class See Also Send Feedback
Angle from True North

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Double
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

Remarks

This is the angle difference between project north and true north measured in radians. It can have a value from -PI to +PI.

See Also

ProjectPosition Class
Autodesk.Revit.Site Namespace


EastWest Property

[image]

Revit 2010 API
ProjectPosition..::.EastWest Property
ProjectPosition Class See Also Send Feedback
East/West offset

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double EastWest { get; set; }
Visual Basic (Declaration)
Public Property EastWest As Double
Visual C++
public:
property double EastWest {
    double get ();
    void set (double value);
}

Remarks

The offset of the project location from the site location in the east/west direction. Measured in decimal feet.

See Also

ProjectPosition Class
Autodesk.Revit.Site Namespace


Elevation Property

[image]

Revit 2010 API
ProjectPosition..::.Elevation Property
ProjectPosition Class See Also Send Feedback
Elevation above ground level.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Elevation { get; set; }
Visual Basic (Declaration)
Public Property Elevation As Double
Visual C++
public:
property double Elevation {
    double get ();
    void set (double value);
}

Remarks

Measured in decimal feet.

See Also

ProjectPosition Class
Autodesk.Revit.Site Namespace


NorthSouth Property

[image]

Revit 2010 API
ProjectPosition..::.NorthSouth Property
ProjectPosition Class See Also Send Feedback
North/South offset

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double NorthSouth { get; set; }
Visual Basic (Declaration)
Public Property NorthSouth As Double
Visual C++
public:
property double NorthSouth {
    double get ();
    void set (double value);
}

Remarks

The offset of the project location from the site location in the north/south direction. Measured in decimal feet.

See Also

ProjectPosition Class
Autodesk.Revit.Site Namespace


SiteLocation Class

[image]

Revit 2010 API
SiteLocation Class
Members Example See Also Send Feedback
Contains the geographical location information for the project's site.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SiteLocation : Symbol
Visual Basic (Declaration)
Public Class SiteLocation _
    Inherits Symbol
Visual C++
public ref class SiteLocation : public Symbol

Remarks

Each project may have one site which dictates where in the world the project is based. On this site there may be several locations of the same project. These are represented by ProjectLocation objects. The site location object can be found by using the SiteLocation property on the Document object. The properties of this object can be changed such that it represents any location on the planet or to a known city. Cities already programmed into Revit can be found from the Cities property on the Application object.

Examples

CopyC#
// Get the SiteLocation instance.
Autodesk.Revit.Site.SiteLocation site = document.SiteLocation;

// Angles are in radians when coming from Revit API, so we
// convert to degrees for display
const double angleRatio = Math.PI / 180;   // angle conversion factor

// Format the prompt information.
String prompt = "Current project's Site location information:";
prompt += "\n\t" + "Latitude: " + site.Latitude / angleRatio + "��";
prompt += "\n\t" + "Longitude: " + site.Longitude / angleRatio + "��";
prompt += "\n\t" + "TimeZone: " + site.TimeZone;

// Give the user some information.
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);

// Change the SiteLocation property data.
site.Latitude = 0.5;    // latitude information
site.Longitude = 0.5;   // longitude information
site.TimeZone = -5;     // TimeZone information
CopyVB.NET
' Get the SiteLocation instance.
Dim site As Autodesk.Revit.Site.SiteLocation = document.SiteLocation

' Angles are in radians when coming from Revit API, so we
' convert to degrees for display
Const angleRatio As Double = Math.PI / 180
' angle conversion factor
' Format the prompt information.
Dim prompt As String = "Current project's Site location information:"
prompt += (vbLf & vbTab & "Latitude: ") + site.Latitude / angleRatio & "¡ã"
prompt += (vbLf & vbTab & "Longitude: ") + site.Longitude / angleRatio & "¡ã"
prompt += (vbLf & vbTab & "TimeZone: ") + site.TimeZone

' Give the user some information.
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)

' Change the SiteLocation property data.
site.Latitude = 0.5
' latitude information
site.Longitude = 0.5
' longitude information
site.TimeZone = -5
' TimeZone information

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Site..::.SiteLocation

See Also

SiteLocation Members
Autodesk.Revit.Site Namespace


SiteLocation Members

[image] [image]

Revit 2010 API
SiteLocation Members
SiteLocation Class Constructors Methods Properties See Also Send Feedback

The SiteLocation type exposes the following members.

Constructors

Name | Description
SiteLocation | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Latitude | The latitude of the site location
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Longitude | The longitude of the site location
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
TimeZone | Timezone that contains the site
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SiteLocation Class
Autodesk.Revit.Site Namespace


SiteLocation Constructor

[image]

Revit 2010 API
SiteLocation Constructor
SiteLocation Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SiteLocation()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SiteLocation()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SiteLocation Class
Autodesk.Revit.Site Namespace


SiteLocation Methods

[image] [image]

Revit 2010 API
SiteLocation Methods
SiteLocation Class See Also Send Feedback

The SiteLocation type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SiteLocation Class
Autodesk.Revit.Site Namespace


SiteLocation Properties

[image] [image]

Revit 2010 API
SiteLocation Properties
SiteLocation Class See Also Send Feedback

The SiteLocation type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Latitude | The latitude of the site location
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Longitude | The longitude of the site location
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
TimeZone | Timezone that contains the site
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SiteLocation Class
Autodesk.Revit.Site Namespace


Latitude Property

[image]

Revit 2010 API
SiteLocation..::.Latitude Property
SiteLocation Class See Also Send Feedback
The latitude of the site location

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Latitude { get; set; }
Visual Basic (Declaration)
Public Property Latitude As Double
Visual C++
public:
property double Latitude {
    double get ();
    void set (double value);
}

Remarks

A property that contains the latitude of the site location for the entire project. Note that the project may have several locations within that site which are set by using the SiteLocation objects. The value of this property is in radians between +PI and -PI.If this property is read only an exception will be thrown if an attempt is made to set the property.

See Also

SiteLocation Class
Autodesk.Revit.Site Namespace


Longitude Property

[image]

Revit 2010 API
SiteLocation..::.Longitude Property
SiteLocation Class See Also Send Feedback
The longitude of the site location

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Longitude { get; set; }
Visual Basic (Declaration)
Public Property Longitude As Double
Visual C++
public:
property double Longitude {
    double get ();
    void set (double value);
}

Remarks

A property that contains the longitude of the site location for the entire project. Note that the project may have several locations within that site which are set by using the SiteLocation objects. The value of this property is in radians between +PI and -PI.If this property is read only an exception will be thrown if an attempt is made to set the property.

See Also

SiteLocation Class
Autodesk.Revit.Site Namespace


Parameter Property

[image] [image]

Revit 2010 API
SiteLocation..::.Parameter Property
SiteLocation Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SiteLocation Class
SiteLocation Members
Autodesk.Revit.Site Namespace


TimeZone Property

[image]

Revit 2010 API
SiteLocation..::.TimeZone Property
SiteLocation Class See Also Send Feedback
Timezone that contains the site

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double TimeZone { get; set; }
Visual Basic (Declaration)
Public Property TimeZone As Double
Visual C++
public:
property double TimeZone {
    double get ();
    void set (double value);
}

Remarks

A property that returns the time zone in which the site resides. The value is in hours, ranging from +12 hours to -12 hours with 0 being GMT. If this property is read only an exception will be thrown if an attempt is made to set the property.

See Also

SiteLocation Class
Autodesk.Revit.Site Namespace


Autodesk.Revit.Spaces Namespace

[image]

Revit 2010 API
Autodesk.Revit.Spaces Namespace
Send Feedback

Classes

Class | Description
BoundarySegment | An object that represents a segment of an area boundary.
BoundarySegmentArray | An array that contains boundary segments.
BoundarySegmentArrayArray | An array that contains boundary segment arrays.
BoundarySegmentArrayArrayIterator | An iterator to a array of boundary segment arrays.
BoundarySegmentArrayIterator | An iterator to a boundary segment array.


BoundarySegment Class

[image]

Revit 2010 API
BoundarySegment Class
Members See Also Send Feedback
An object that represents a segment of an area boundary.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BoundarySegment : APIObject
Visual Basic (Declaration)
Public Class BoundarySegment _
    Inherits APIObject
Visual C++
public ref class BoundarySegment : public APIObject

Remarks

These objects define the the exterior boundary of an area. The geometry of the segment can be retrieved along with the element that is responsible for producing that boundary.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Spaces..::.BoundarySegment

See Also

BoundarySegment Members
Autodesk.Revit.Spaces Namespace


BoundarySegment Members

[image] [image]

Revit 2010 API
BoundarySegment Members
BoundarySegment Class Constructors Methods Properties See Also Send Feedback

The BoundarySegment type exposes the following members.

Constructors

Name | Description
BoundarySegment | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Curve | Get the curve that is formed by the element that defines the edge of this area.
Document | Provides the document in which the element that created this segment resides.
Element | Retrieve the element that is responsible for producing this boundary segment.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment Class
Autodesk.Revit.Spaces Namespace


BoundarySegment Constructor

[image]

Revit 2010 API
BoundarySegment Constructor
BoundarySegment Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundarySegment()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegment()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegment Class
Autodesk.Revit.Spaces Namespace


BoundarySegment Methods

[image] [image]

Revit 2010 API
BoundarySegment Methods
BoundarySegment Class See Also Send Feedback

The BoundarySegment type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegment Class
Autodesk.Revit.Spaces Namespace


BoundarySegment Properties

[image] [image]

Revit 2010 API
BoundarySegment Properties
BoundarySegment Class See Also Send Feedback

The BoundarySegment type exposes the following members.

Properties

Name | Description
Curve | Get the curve that is formed by the element that defines the edge of this area.
Document | Provides the document in which the element that created this segment resides.
Element | Retrieve the element that is responsible for producing this boundary segment.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment Class
Autodesk.Revit.Spaces Namespace


Curve Property

[image]

Revit 2010 API
BoundarySegment..::.Curve Property
BoundarySegment Class See Also Send Feedback
Get the curve that is formed by the element that defines the edge of this area.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

BoundarySegment Class
Autodesk.Revit.Spaces Namespace


Document Property

[image]

Revit 2010 API
BoundarySegment..::.Document Property
BoundarySegment Class See Also Send Feedback
Provides the document in which the element that created this segment resides.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

BoundarySegment Class
Autodesk.Revit.Spaces Namespace


Element Property

[image]

Revit 2010 API
BoundarySegment..::.Element Property
BoundarySegment Class See Also Send Feedback
Retrieve the element that is responsible for producing this boundary segment.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element Element { get; }
Visual Basic (Declaration)
Public ReadOnly Property Element As Element
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

Remarks

The element property is useful for finding all the elements that bound a specific area.

See Also

BoundarySegment Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArray Class

[image]

Revit 2010 API
BoundarySegmentArray Class
Members See Also Send Feedback
An array that contains boundary segments.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BoundarySegmentArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class BoundarySegmentArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class BoundarySegmentArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Spaces..::.BoundarySegmentArray

See Also

BoundarySegmentArray Members
Autodesk.Revit.Spaces Namespace


BoundarySegmentArray Members

[image] [image]

Revit 2010 API
BoundarySegmentArray Members
BoundarySegmentArray Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Constructors

Name | Description
BoundarySegmentArray | Initializes a new instance of the BoundarySegmentArray class

Methods

Name | Description
Append | Add the boundary segment to the end of the array.
Clear | Removes every boundary segment from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified boundary segment into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment at a specified index within the array.
Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArray Constructor

[image]

Revit 2010 API
BoundarySegmentArray Constructor
BoundarySegmentArray Class See Also Send Feedback
Initializes a new instance of the BoundarySegmentArray class

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundarySegmentArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArray()

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArray Methods

[image] [image]

Revit 2010 API
BoundarySegmentArray Methods
BoundarySegmentArray Class See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Methods

Name | Description
Append | Add the boundary segment to the end of the array.
Clear | Removes every boundary segment from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified boundary segment into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


Append Method

[image]

Revit 2010 API
BoundarySegmentArray..::.Append Method
BoundarySegmentArray Class See Also Send Feedback
Add the boundary segment to the end of the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    BoundarySegment item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As BoundarySegment _
)
Visual C++
public:
virtual void Append(
    BoundarySegment^ item
)

Parameters

item
Type: Autodesk.Revit.Spaces..::.BoundarySegment
The boundary segment to be added.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


Clear Method

[image]

Revit 2010 API
BoundarySegmentArray..::.Clear Method
BoundarySegmentArray Class See Also Send Feedback
Removes every boundary segment from the array, rendering it empty.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


ForwardIterator Method

[image]

Revit 2010 API
BoundarySegmentArray..::.ForwardIterator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


GetEnumerator Method

[image]

Revit 2010 API
BoundarySegmentArray..::.GetEnumerator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


Insert Method

[image]

Revit 2010 API
BoundarySegmentArray..::.Insert Method
BoundarySegmentArray Class See Also Send Feedback
Insert the specified boundary segment into the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    BoundarySegment item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As BoundarySegment, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    BoundarySegment^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Spaces..::.BoundarySegment
The boundary segment to be inserted into the array.
index
Type: System..::.Int32
The boundary segment will be inserted before this index.

Return Value

Returns whether the boundary segment was inserted into the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


ReverseIterator Method

[image]

Revit 2010 API
BoundarySegmentArray..::.ReverseIterator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArray Properties

[image] [image]

Revit 2010 API
BoundarySegmentArray Properties
BoundarySegmentArray Class See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment at a specified index within the array.
Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


IsEmpty Property

[image]

Revit 2010 API
BoundarySegmentArray..::.IsEmpty Property
BoundarySegmentArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


Item Property

[image]

Revit 2010 API
BoundarySegmentArray..::.Item Property
BoundarySegmentArray Class See Also Send Feedback
Gets or sets a boundary segment at a specified index within the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual BoundarySegment Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegment
Visual C++
public:
virtual property BoundarySegment^ Item[int index] {
    BoundarySegment^ get (int index);
    void set (int index, BoundarySegment^ value);
}

Parameters

index
Type: System..::.Int32
The index of the boundary segment to be set or retrieved.

Return Value

Returns the boundary segment at the specified index.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


Size Property

[image]

Revit 2010 API
BoundarySegmentArray..::.Size Property
BoundarySegmentArray Class See Also Send Feedback
Returns the number of boundary segments that are in the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArray Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayArray Class

[image]

Revit 2010 API
BoundarySegmentArrayArray Class
Members See Also Send Feedback
An array that contains boundary segment arrays.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BoundarySegmentArrayArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class BoundarySegmentArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class BoundarySegmentArrayArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Spaces..::.BoundarySegmentArrayArray

See Also

BoundarySegmentArrayArray Members
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayArray Members

[image] [image]

Revit 2010 API
BoundarySegmentArrayArray Members
BoundarySegmentArrayArray Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Constructors

Name | Description
BoundarySegmentArrayArray | Initializes a new instance of the BoundarySegmentArrayArray class

Methods

Name | Description
Append | Add the boundary segment array to the end of the array.
Clear | Removes every boundary segment array from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment array at a specified index within the array.
Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayArray Constructor

[image]

Revit 2010 API
BoundarySegmentArrayArray Constructor
BoundarySegmentArrayArray Class See Also Send Feedback
Initializes a new instance of the BoundarySegmentArrayArray class

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundarySegmentArrayArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayArray()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayArray Methods

[image] [image]

Revit 2010 API
BoundarySegmentArrayArray Methods
BoundarySegmentArrayArray Class See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Methods

Name | Description
Append | Add the boundary segment array to the end of the array.
Clear | Removes every boundary segment array from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


Append Method

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.Append Method
BoundarySegmentArrayArray Class See Also Send Feedback
Add the boundary segment array to the end of the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    BoundarySegmentArray item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As BoundarySegmentArray _
)
Visual C++
public:
virtual void Append(
    BoundarySegmentArray^ item
)

Parameters

item
Type: Autodesk.Revit.Spaces..::.BoundarySegmentArray
The boundary segment array to be added.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


Clear Method

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.Clear Method
BoundarySegmentArrayArray Class See Also Send Feedback
Removes every boundary segment array from the array, rendering it empty.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


ForwardIterator Method

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.ForwardIterator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


GetEnumerator Method

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.GetEnumerator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


Insert Method

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.Insert Method
BoundarySegmentArrayArray Class See Also Send Feedback

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    BoundarySegmentArray item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As BoundarySegmentArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    BoundarySegmentArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Spaces..::.BoundarySegmentArray
index
Type: System..::.Int32

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


ReverseIterator Method

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.ReverseIterator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayArray Properties

[image] [image]

Revit 2010 API
BoundarySegmentArrayArray Properties
BoundarySegmentArrayArray Class See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment array at a specified index within the array.
Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


IsEmpty Property

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.IsEmpty Property
BoundarySegmentArrayArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


Item Property

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.Item Property
BoundarySegmentArrayArray Class See Also Send Feedback
Gets or sets a boundary segment array at a specified index within the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual BoundarySegmentArray Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegmentArray
Visual C++
public:
virtual property BoundarySegmentArray^ Item[int index] {
    BoundarySegmentArray^ get (int index);
    void set (int index, BoundarySegmentArray^ value);
}

Parameters

index
Type: System..::.Int32
The index of the boundary segment array to be set or retrieved.

Return Value

Returns the boundary segment array at the specified index.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


Size Property

[image]

Revit 2010 API
BoundarySegmentArrayArray..::.Size Property
BoundarySegmentArrayArray Class See Also Send Feedback
Returns the number of boundary segment arrays that are in the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayArrayIterator Class

[image]

Revit 2010 API
BoundarySegmentArrayArrayIterator Class
Members See Also Send Feedback
An iterator to a array of boundary segment arrays.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class BoundarySegmentArrayArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class BoundarySegmentArrayArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Spaces..::.BoundarySegmentArrayArrayIterator

See Also

BoundarySegmentArrayArrayIterator Members
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayArrayIterator Members

[image] [image]

Revit 2010 API
BoundarySegmentArrayArrayIterator Members
BoundarySegmentArrayArrayIterator Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Constructors

Name | Description
BoundarySegmentArrayArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayArrayIterator Constructor

[image]

Revit 2010 API
BoundarySegmentArrayArrayIterator Constructor
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundarySegmentArrayArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayArrayIterator Methods

[image] [image]

Revit 2010 API
BoundarySegmentArrayArrayIterator Methods
BoundarySegmentArrayArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Spaces Namespace


MoveNext Method

[image]

Revit 2010 API
BoundarySegmentArrayArrayIterator..::.MoveNext Method
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Spaces Namespace


Reset Method

[image]

Revit 2010 API
BoundarySegmentArrayArrayIterator..::.Reset Method
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayArrayIterator Properties

[image] [image]

Revit 2010 API
BoundarySegmentArrayArrayIterator Properties
BoundarySegmentArrayArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Spaces Namespace


Current Property

[image]

Revit 2010 API
BoundarySegmentArrayArrayIterator..::.Current Property
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayIterator Class

[image]

Revit 2010 API
BoundarySegmentArrayIterator Class
Members See Also Send Feedback
An iterator to a boundary segment array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class BoundarySegmentArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class BoundarySegmentArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Spaces..::.BoundarySegmentArrayIterator

See Also

BoundarySegmentArrayIterator Members
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayIterator Members

[image] [image]

Revit 2010 API
BoundarySegmentArrayIterator Members
BoundarySegmentArrayIterator Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Constructors

Name | Description
BoundarySegmentArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayIterator Constructor

[image]

Revit 2010 API
BoundarySegmentArrayIterator Constructor
BoundarySegmentArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundarySegmentArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayIterator Methods

[image] [image]

Revit 2010 API
BoundarySegmentArrayIterator Methods
BoundarySegmentArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Spaces Namespace


MoveNext Method

[image]

Revit 2010 API
BoundarySegmentArrayIterator..::.MoveNext Method
BoundarySegmentArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Spaces Namespace


Reset Method

[image]

Revit 2010 API
BoundarySegmentArrayIterator..::.Reset Method
BoundarySegmentArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Spaces Namespace


BoundarySegmentArrayIterator Properties

[image] [image]

Revit 2010 API
BoundarySegmentArrayIterator Properties
BoundarySegmentArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Spaces Namespace


Current Property

[image]

Revit 2010 API
BoundarySegmentArrayIterator..::.Current Property
BoundarySegmentArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Spaces
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.Spaces Namespace


Autodesk.Revit.Structural Namespace

[image]

Revit 2010 API
Autodesk.Revit.Structural Namespace
Send Feedback

Classes

Class | Description
AnalyticalModel | Supports all Analytical Models that are persistent within the Autodesk Revit project
AnalyticalModel3D | Supports all Analytical Models that have more than two dimensions within the Autodesk Revit project
AnalyticalModelFloor | Supports all Floor Analytical Models that are persistent within the Autodesk Revit project
AnalyticalModelFrame | Supports Framing Analytical Models (e.g., Beam) that are persistent within the Autodesk Revit project
AnalyticalModelLocation | Supports Location Analytical Models (e.g., Structural Footings) that are persistent within the Autodesk Revit project
AnalyticalModelProfile | Represents an extruded profile.
AnalyticalModelWall | Supports all Wall Analytical Models that are persistent within the Autodesk Revit project
AnalyticalSupportData | Information for one support of another Structural Element.
AnalyticalSupportInfo | Information for one support of another Structural Element.
AnalyticalSupportInfoArray | An array that contains support information objects.
AnalyticalSupportInfoArrayIterator | An iterator to a support information array.
BarDescription | An object that represents an Area Reinforcement within the Autodesk Revit project.
CompoundStructure | An object that describes the multi layered construction of walls or floors.
CompoundStructureLayer | An object that describes a single layer of multi-layered object.
CompoundStructureLayerArray | An array that contains layer objects.
CompoundStructureLayerArrayIterator | An iterator to a layer array.


AnalyticalModel Class

[image]

Revit 2010 API
AnalyticalModel Class
Members See Also Send Feedback
Supports all Analytical Models that are persistent within the Autodesk Revit project

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AnalyticalModel : APIObject
Visual Basic (Declaration)
Public Class AnalyticalModel _
    Inherits APIObject
Visual C++
public ref class AnalyticalModel : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Structural..::.AnalyticalModel
Autodesk.Revit.Structural..::.AnalyticalModel3D
Autodesk.Revit.Structural..::.AnalyticalModelFloor
Autodesk.Revit.Structural..::.AnalyticalModelFrame
Autodesk.Revit.Structural..::.AnalyticalModelLocation
Autodesk.Revit.Structural..::.AnalyticalModelProfile
Autodesk.Revit.Structural..::.AnalyticalModelWall

See Also

AnalyticalModel Members
Autodesk.Revit.Structural Namespace


AnalyticalModel Members

[image] [image]

Revit 2010 API
AnalyticalModel Members
AnalyticalModel Class Constructors Methods Properties See Also Send Feedback

The AnalyticalModel type exposes the following members.

Constructors

Name | Description
AnalyticalModel | For Internal Use Only

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AnalyticalModel Class
Autodesk.Revit.Structural Namespace


AnalyticalModel Constructor

[image]

Revit 2010 API
AnalyticalModel Constructor
AnalyticalModel Class See Also Send Feedback
For Internal Use Only

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalModel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalModel()

Remarks

This constructor is exposed to enable support for COM interopability only. This object should not be created by the developer.

See Also

AnalyticalModel Class
Autodesk.Revit.Structural Namespace


AnalyticalModel Methods

[image] [image]

Revit 2010 API
AnalyticalModel Methods
AnalyticalModel Class See Also Send Feedback

The AnalyticalModel type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModel Class
Autodesk.Revit.Structural Namespace


AnalyticalModel Properties

[image] [image]

Revit 2010 API
AnalyticalModel Properties
AnalyticalModel Class See Also Send Feedback

The AnalyticalModel type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AnalyticalModel Class
Autodesk.Revit.Structural Namespace


AnalyticalModel3D Class

[image]

Revit 2010 API
AnalyticalModel3D Class
Members See Also Send Feedback
Supports all Analytical Models that have more than two dimensions within the Autodesk Revit project

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AnalyticalModel3D : AnalyticalModel
Visual Basic (Declaration)
Public Class AnalyticalModel3D _
    Inherits AnalyticalModel
Visual C++
public ref class AnalyticalModel3D : public AnalyticalModel

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Structural..::.AnalyticalModel
Autodesk.Revit.Structural..::.AnalyticalModel3D

See Also

AnalyticalModel3D Members
Autodesk.Revit.Structural Namespace


AnalyticalModel3D Members

[image] [image]

Revit 2010 API
AnalyticalModel3D Members
AnalyticalModel3D Class Constructors Methods Properties See Also Send Feedback

The AnalyticalModel3D type exposes the following members.

Constructors

Name | Description
AnalyticalModel3D | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Curves | Returns curves that define the Analytical Model of the associated Element.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModel3D Class
Autodesk.Revit.Structural Namespace


AnalyticalModel3D Constructor

[image]

Revit 2010 API
AnalyticalModel3D Constructor
AnalyticalModel3D Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalModel3D()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalModel3D()

Remarks

This constructor is exposed to enable support for COM interop only. This object must not be created by the developer.

See Also

AnalyticalModel3D Class
Autodesk.Revit.Structural Namespace


AnalyticalModel3D Methods

[image] [image]

Revit 2010 API
AnalyticalModel3D Methods
AnalyticalModel3D Class See Also Send Feedback

The AnalyticalModel3D type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModel3D Class
Autodesk.Revit.Structural Namespace


AnalyticalModel3D Properties

[image] [image]

Revit 2010 API
AnalyticalModel3D Properties
AnalyticalModel3D Class See Also Send Feedback

The AnalyticalModel3D type exposes the following members.

Properties

Name | Description
Curves | Returns curves that define the Analytical Model of the associated Element.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModel3D Class
Autodesk.Revit.Structural Namespace


Curves Property

[image]

Revit 2010 API
AnalyticalModel3D..::.Curves Property
AnalyticalModel3D Class See Also Send Feedback
Returns curves that define the Analytical Model of the associated Element.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray Curves { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

Return Value

Returns a CurveArray containing the Analytical Model.

Remarks

There are no significant restrictions on the curves; they may not be coplanar, and they may not be even connected.

See Also

AnalyticalModel3D Class
Autodesk.Revit.Structural Namespace


SupportData Property

[image]

Revit 2010 API
AnalyticalModel3D..::.SupportData Property
AnalyticalModel3D Class See Also Send Feedback
Provides access to the Support Data for this floor.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalSupportData SupportData { get; }
Visual Basic (Declaration)
Public ReadOnly Property SupportData As AnalyticalSupportData
Visual C++
public:
property AnalyticalSupportData^ SupportData {
    AnalyticalSupportData^ get ();
}

Return Value

Analytical Support Data, containing support information.

See Also

AnalyticalModel3D Class
Autodesk.Revit.Structural Namespace


AnalyticalModelFloor Class

[image]

Revit 2010 API
AnalyticalModelFloor Class
Members See Also Send Feedback
Supports all Floor Analytical Models that are persistent within the Autodesk Revit project

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AnalyticalModelFloor : AnalyticalModel
Visual Basic (Declaration)
Public Class AnalyticalModelFloor _
    Inherits AnalyticalModel
Visual C++
public ref class AnalyticalModelFloor : public AnalyticalModel

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Structural..::.AnalyticalModel
Autodesk.Revit.Structural..::.AnalyticalModelFloor

See Also

AnalyticalModelFloor Members
Autodesk.Revit.Structural Namespace


AnalyticalModelFloor Members

[image] [image]

Revit 2010 API
AnalyticalModelFloor Members
AnalyticalModelFloor Class Constructors Methods Properties See Also Send Feedback

The AnalyticalModelFloor type exposes the following members.

Constructors

Name | Description
AnalyticalModelFloor | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Curves | Provides access to the Floor Analytical Model.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModelFloor Class
Autodesk.Revit.Structural Namespace


AnalyticalModelFloor Constructor

[image]

Revit 2010 API
AnalyticalModelFloor Constructor
AnalyticalModelFloor Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalModelFloor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalModelFloor()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnalyticalModelFloor Class
Autodesk.Revit.Structural Namespace


AnalyticalModelFloor Methods

[image] [image]

Revit 2010 API
AnalyticalModelFloor Methods
AnalyticalModelFloor Class See Also Send Feedback

The AnalyticalModelFloor type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModelFloor Class
Autodesk.Revit.Structural Namespace


AnalyticalModelFloor Properties

[image] [image]

Revit 2010 API
AnalyticalModelFloor Properties
AnalyticalModelFloor Class See Also Send Feedback

The AnalyticalModelFloor type exposes the following members.

Properties

Name | Description
Curves | Provides access to the Floor Analytical Model.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModelFloor Class
Autodesk.Revit.Structural Namespace


Curves Property

[image]

Revit 2010 API
AnalyticalModelFloor..::.Curves Property
AnalyticalModelFloor Class See Also Send Feedback
Provides access to the Floor Analytical Model.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray Curves { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

Return Value

Curves that define the Floor's Analytical Model.

Remarks

The curves are all coplanar.

See Also

AnalyticalModelFloor Class
Autodesk.Revit.Structural Namespace


SupportData Property

[image]

Revit 2010 API
AnalyticalModelFloor..::.SupportData Property
AnalyticalModelFloor Class See Also Send Feedback
Provides access to the Support Data for this floor.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalSupportData SupportData { get; }
Visual Basic (Declaration)
Public ReadOnly Property SupportData As AnalyticalSupportData
Visual C++
public:
property AnalyticalSupportData^ SupportData {
    AnalyticalSupportData^ get ();
}

Return Value

Analytical Support Data, containing support information.

See Also

AnalyticalModelFloor Class
Autodesk.Revit.Structural Namespace


AnalyticalModelFrame Class

[image]

Revit 2010 API
AnalyticalModelFrame Class
Members See Also Send Feedback
Supports Framing Analytical Models (e.g., Beam) that are persistent within the Autodesk Revit project

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AnalyticalModelFrame : AnalyticalModel
Visual Basic (Declaration)
Public Class AnalyticalModelFrame _
    Inherits AnalyticalModel
Visual C++
public ref class AnalyticalModelFrame : public AnalyticalModel

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Structural..::.AnalyticalModel
Autodesk.Revit.Structural..::.AnalyticalModelFrame

See Also

AnalyticalModelFrame Members
Autodesk.Revit.Structural Namespace


AnalyticalModelFrame Members

[image] [image]

Revit 2010 API
AnalyticalModelFrame Members
AnalyticalModelFrame Class Constructors Methods Properties See Also Send Feedback

The AnalyticalModelFrame type exposes the following members.

Constructors

Name | Description
AnalyticalModelFrame | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Curve | Provides access to Structural Framing Analytical Model.
Curves | Returns curves that define the Analytical Model of the associated Element.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Profile | This property will return an object that represents a cross section of the beam or column and a curve along which the profile is swept.
RigidLink | Provides access to Rigid Links component of Structural Framing Element.
SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModelFrame Class
Autodesk.Revit.Structural Namespace


AnalyticalModelFrame Constructor

[image]

Revit 2010 API
AnalyticalModelFrame Constructor
AnalyticalModelFrame Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalModelFrame()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalModelFrame()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnalyticalModelFrame Class
Autodesk.Revit.Structural Namespace


AnalyticalModelFrame Methods

[image] [image]

Revit 2010 API
AnalyticalModelFrame Methods
AnalyticalModelFrame Class See Also Send Feedback

The AnalyticalModelFrame type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModelFrame Class
Autodesk.Revit.Structural Namespace


AnalyticalModelFrame Properties

[image] [image]

Revit 2010 API
AnalyticalModelFrame Properties
AnalyticalModelFrame Class See Also Send Feedback

The AnalyticalModelFrame type exposes the following members.

Properties

Name | Description
Curve | Provides access to Structural Framing Analytical Model.
Curves | Returns curves that define the Analytical Model of the associated Element.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Profile | This property will return an object that represents a cross section of the beam or column and a curve along which the profile is swept.
RigidLink | Provides access to Rigid Links component of Structural Framing Element.
SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModelFrame Class
Autodesk.Revit.Structural Namespace


Curve Property

[image]

Revit 2010 API
AnalyticalModelFrame..::.Curve Property
AnalyticalModelFrame Class See Also Send Feedback
Provides access to Structural Framing Analytical Model.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

Return Value

Returns a Curve containing the Analytical Model of the Structural Framing Element.

Remarks

The curve returned will not contain any Rigid Links. Use associated Rigid Links property to get Rigid Links.

See Also

AnalyticalModelFrame Class
Autodesk.Revit.Structural Namespace


Curves Property

[image]

Revit 2010 API
AnalyticalModelFrame..::.Curves Property
AnalyticalModelFrame Class See Also Send Feedback
Returns curves that define the Analytical Model of the associated Element.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray Curves { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

Return Value

Returns a CurveArray containing the Analytical Model.

Remarks

There are no significant restrictions on the curves; they may not be coplanar, and they may not be even connected.

See Also

AnalyticalModelFrame Class
Autodesk.Revit.Structural Namespace


Profile Property

[image]

Revit 2010 API
AnalyticalModelFrame..::.Profile Property
AnalyticalModelFrame Class See Also Send Feedback
This property will return an object that represents a cross section of the beam or column and a curve along which the profile is swept.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalModelProfile Profile { get; }
Visual Basic (Declaration)
Public ReadOnly Property Profile As AnalyticalModelProfile
Visual C++
public:
property AnalyticalModelProfile^ Profile {
    AnalyticalModelProfile^ get ();
}

Return Value

Returns a profile analytical model object if possible.

Remarks

Some elements may not be able to return a profile. In that case Nothing will be returned.

See Also

AnalyticalModelFrame Class
Autodesk.Revit.Structural Namespace


RigidLink Property

[image]

Revit 2010 API
AnalyticalModelFrame..::.RigidLink Property
AnalyticalModelFrame Class See Also Send Feedback
Provides access to Rigid Links component of Structural Framing Element.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve RigidLink[
    int nEnd
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property RigidLink ( _
    nEnd As Integer _
) As Curve
Visual C++
public:
property Curve^ RigidLink[int nEnd] {
    Curve^ get (int nEnd);
}

Parameters

nEnd
Type: System..::.Int32
An integer that represents the end of beam or column, 0 for the start and 1 for the end.

Return Value

Returns a Curve that is the Rigid Links component of the Structural Framing Element. End is determined by the input parameter.

Remarks

This is only meaningful for Beams.

See Also

AnalyticalModelFrame Class
Autodesk.Revit.Structural Namespace


SupportData Property

[image]

Revit 2010 API
AnalyticalModelFrame..::.SupportData Property
AnalyticalModelFrame Class See Also Send Feedback
Provides access to the Support Data for this floor.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalSupportData SupportData { get; }
Visual Basic (Declaration)
Public ReadOnly Property SupportData As AnalyticalSupportData
Visual C++
public:
property AnalyticalSupportData^ SupportData {
    AnalyticalSupportData^ get ();
}

Return Value

Analytical Support Data, containing support information.

See Also

AnalyticalModelFrame Class
Autodesk.Revit.Structural Namespace


AnalyticalModelLocation Class

[image]

Revit 2010 API
AnalyticalModelLocation Class
Members See Also Send Feedback
Supports Location Analytical Models (e.g., Structural Footings) that are persistent within the Autodesk Revit project

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AnalyticalModelLocation : AnalyticalModel
Visual Basic (Declaration)
Public Class AnalyticalModelLocation _
    Inherits AnalyticalModel
Visual C++
public ref class AnalyticalModelLocation : public AnalyticalModel

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Structural..::.AnalyticalModel
Autodesk.Revit.Structural..::.AnalyticalModelLocation

See Also

AnalyticalModelLocation Members
Autodesk.Revit.Structural Namespace


AnalyticalModelLocation Members

[image] [image]

Revit 2010 API
AnalyticalModelLocation Members
AnalyticalModelLocation Class Constructors Methods Properties See Also Send Feedback

The AnalyticalModelLocation type exposes the following members.

Constructors

Name | Description
AnalyticalModelLocation | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Curves | Returns curves that define the Analytical Model of the associated Element.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Point | Provides access to the location of the Analytical Model, in the case of Structural Foundations.
SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModelLocation Class
Autodesk.Revit.Structural Namespace


AnalyticalModelLocation Constructor

[image]

Revit 2010 API
AnalyticalModelLocation Constructor
AnalyticalModelLocation Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalModelLocation()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalModelLocation()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnalyticalModelLocation Class
Autodesk.Revit.Structural Namespace


AnalyticalModelLocation Methods

[image] [image]

Revit 2010 API
AnalyticalModelLocation Methods
AnalyticalModelLocation Class See Also Send Feedback

The AnalyticalModelLocation type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModelLocation Class
Autodesk.Revit.Structural Namespace


AnalyticalModelLocation Properties

[image] [image]

Revit 2010 API
AnalyticalModelLocation Properties
AnalyticalModelLocation Class See Also Send Feedback

The AnalyticalModelLocation type exposes the following members.

Properties

Name | Description
Curves | Returns curves that define the Analytical Model of the associated Element.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Point | Provides access to the location of the Analytical Model, in the case of Structural Foundations.
SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModelLocation Class
Autodesk.Revit.Structural Namespace


Curves Property

[image]

Revit 2010 API
AnalyticalModelLocation..::.Curves Property
AnalyticalModelLocation Class See Also Send Feedback
Returns curves that define the Analytical Model of the associated Element.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray Curves { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

Return Value

Returns a CurveArray containing the Analytical Model.

Remarks

There are no significant restrictions on the curves; they may not be coplanar, and they may not be even connected.

See Also

AnalyticalModelLocation Class
Autodesk.Revit.Structural Namespace


Point Property

[image]

Revit 2010 API
AnalyticalModelLocation..::.Point Property
AnalyticalModelLocation Class See Also Send Feedback
Provides access to the location of the Analytical Model, in the case of Structural Foundations.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Point { get; }
Visual Basic (Declaration)
Public ReadOnly Property Point As XYZ
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
}

Return Value

Returns a point object containing the location of this Analytical Model.

Remarks

The Location point is on the "top" of the Structural Foundation.

See Also

AnalyticalModelLocation Class
Autodesk.Revit.Structural Namespace


SupportData Property

[image]

Revit 2010 API
AnalyticalModelLocation..::.SupportData Property
AnalyticalModelLocation Class See Also Send Feedback
Provides access to the Support Data for this floor.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalSupportData SupportData { get; }
Visual Basic (Declaration)
Public ReadOnly Property SupportData As AnalyticalSupportData
Visual C++
public:
property AnalyticalSupportData^ SupportData {
    AnalyticalSupportData^ get ();
}

Return Value

Analytical Support Data, containing support information.

See Also

AnalyticalModelLocation Class
Autodesk.Revit.Structural Namespace


AnalyticalModelProfile Class

[image]

Revit 2010 API
AnalyticalModelProfile Class
Members See Also Send Feedback
Represents an extruded profile.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AnalyticalModelProfile : AnalyticalModel
Visual Basic (Declaration)
Public Class AnalyticalModelProfile _
    Inherits AnalyticalModel
Visual C++
public ref class AnalyticalModelProfile : public AnalyticalModel

Remarks

Elements, such as beams, may be formed from a profile that has been swept along a curve. This analytical model represents such a form and is used to access the cross section and the underlying curve that make up the element.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Structural..::.AnalyticalModel
Autodesk.Revit.Structural..::.AnalyticalModelProfile

See Also

AnalyticalModelProfile Members
Autodesk.Revit.Structural Namespace


AnalyticalModelProfile Members

[image] [image]

Revit 2010 API
AnalyticalModelProfile Members
AnalyticalModelProfile Class Constructors Methods Properties See Also Send Feedback

The AnalyticalModelProfile type exposes the following members.

Constructors

Name | Description
AnalyticalModelProfile | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DrivingCurve | Provides access to the curve that dictates the path of the swept profile.
EndSetBack | Returns the distance from the end of the driving curve that the sweep actually finishes.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
StartSetBack | Returns the distance from the start of the driving curve that the sweep actually begins.
SweptProfile | Returns an object that describes the profile that is swept along the driving curve.

See Also

AnalyticalModelProfile Class
Autodesk.Revit.Structural Namespace


AnalyticalModelProfile Constructor

[image]

Revit 2010 API
AnalyticalModelProfile Constructor
AnalyticalModelProfile Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalModelProfile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalModelProfile()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnalyticalModelProfile Class
Autodesk.Revit.Structural Namespace


AnalyticalModelProfile Methods

[image] [image]

Revit 2010 API
AnalyticalModelProfile Methods
AnalyticalModelProfile Class See Also Send Feedback

The AnalyticalModelProfile type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModelProfile Class
Autodesk.Revit.Structural Namespace


AnalyticalModelProfile Properties

[image] [image]

Revit 2010 API
AnalyticalModelProfile Properties
AnalyticalModelProfile Class See Also Send Feedback

The AnalyticalModelProfile type exposes the following members.

Properties

Name | Description
DrivingCurve | Provides access to the curve that dictates the path of the swept profile.
EndSetBack | Returns the distance from the end of the driving curve that the sweep actually finishes.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
StartSetBack | Returns the distance from the start of the driving curve that the sweep actually begins.
SweptProfile | Returns an object that describes the profile that is swept along the driving curve.

See Also

AnalyticalModelProfile Class
Autodesk.Revit.Structural Namespace


DrivingCurve Property

[image]

Revit 2010 API
AnalyticalModelProfile..::.DrivingCurve Property
AnalyticalModelProfile Class See Also Send Feedback
Provides access to the curve that dictates the path of the swept profile.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve DrivingCurve { get; }
Visual Basic (Declaration)
Public ReadOnly Property DrivingCurve As Curve
Visual C++
public:
property Curve^ DrivingCurve {
    Curve^ get ();
}

Return Value

A curve that defines the path of the swept profile.

Remarks

The profile may not be swept the entire length of this curve. One should check the set back properties on this object to locate how far the the actual sweep is from the ends of the curve.

See Also

AnalyticalModelProfile Class
Autodesk.Revit.Structural Namespace


EndSetBack Property

[image]

Revit 2010 API
AnalyticalModelProfile..::.EndSetBack Property
AnalyticalModelProfile Class See Also Send Feedback
Returns the distance from the end of the driving curve that the sweep actually finishes.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double EndSetBack { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndSetBack As Double
Visual C++
public:
property double EndSetBack {
    double get ();
}

Return Value

A distance from the end point of the driving curve.

Remarks

The distance is measured in decimal feet.

See Also

AnalyticalModelProfile Class
Autodesk.Revit.Structural Namespace


StartSetBack Property

[image]

Revit 2010 API
AnalyticalModelProfile..::.StartSetBack Property
AnalyticalModelProfile Class See Also Send Feedback
Returns the distance from the start of the driving curve that the sweep actually begins.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double StartSetBack { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartSetBack As Double
Visual C++
public:
property double StartSetBack {
    double get ();
}

Return Value

A distance from the start point of the driving curve.

Remarks

The distance is measured in decimal feet.

See Also

AnalyticalModelProfile Class
Autodesk.Revit.Structural Namespace


SweptProfile Property

[image]

Revit 2010 API
AnalyticalModelProfile..::.SweptProfile Property
AnalyticalModelProfile Class See Also Send Feedback
Returns an object that describes the profile that is swept along the driving curve.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Profile SweptProfile { get; }
Visual Basic (Declaration)
Public ReadOnly Property SweptProfile As Profile
Visual C++
public:
property Profile^ SweptProfile {
    Profile^ get ();
}

Return Value

A geometric profile object.

Remarks

The profile is swept perpendicular to the driving curve.

See Also

AnalyticalModelProfile Class
Autodesk.Revit.Structural Namespace


AnalyticalModelWall Class

[image]

Revit 2010 API
AnalyticalModelWall Class
Members See Also Send Feedback
Supports all Wall Analytical Models that are persistent within the Autodesk Revit project

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AnalyticalModelWall : AnalyticalModel
Visual Basic (Declaration)
Public Class AnalyticalModelWall _
    Inherits AnalyticalModel
Visual C++
public ref class AnalyticalModelWall : public AnalyticalModel

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Structural..::.AnalyticalModel
Autodesk.Revit.Structural..::.AnalyticalModelWall

See Also

AnalyticalModelWall Members
Autodesk.Revit.Structural Namespace


AnalyticalModelWall Members

[image] [image]

Revit 2010 API
AnalyticalModelWall Members
AnalyticalModelWall Class Constructors Methods Properties See Also Send Feedback

The AnalyticalModelWall type exposes the following members.

Constructors

Name | Description
AnalyticalModelWall | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Curves | Provides access to the Wall Analytical Model.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModelWall Class
Autodesk.Revit.Structural Namespace


AnalyticalModelWall Constructor

[image]

Revit 2010 API
AnalyticalModelWall Constructor
AnalyticalModelWall Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalModelWall()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalModelWall()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnalyticalModelWall Class
Autodesk.Revit.Structural Namespace


AnalyticalModelWall Methods

[image] [image]

Revit 2010 API
AnalyticalModelWall Methods
AnalyticalModelWall Class See Also Send Feedback

The AnalyticalModelWall type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModelWall Class
Autodesk.Revit.Structural Namespace


AnalyticalModelWall Properties

[image] [image]

Revit 2010 API
AnalyticalModelWall Properties
AnalyticalModelWall Class See Also Send Feedback

The AnalyticalModelWall type exposes the following members.

Properties

Name | Description
Curves | Provides access to the Wall Analytical Model.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModelWall Class
Autodesk.Revit.Structural Namespace


Curves Property

[image]

Revit 2010 API
AnalyticalModelWall..::.Curves Property
AnalyticalModelWall Class See Also Send Feedback
Provides access to the Wall Analytical Model.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray Curves { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

Return Value

Curves that define the Wall's Analytical Model.

Remarks

The curves are all coplanar.

See Also

AnalyticalModelWall Class
Autodesk.Revit.Structural Namespace


SupportData Property

[image]

Revit 2010 API
AnalyticalModelWall..::.SupportData Property
AnalyticalModelWall Class See Also Send Feedback
Provides access to the Support Data for this floor.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalSupportData SupportData { get; }
Visual Basic (Declaration)
Public ReadOnly Property SupportData As AnalyticalSupportData
Visual C++
public:
property AnalyticalSupportData^ SupportData {
    AnalyticalSupportData^ get ();
}

Return Value

Analytical Support Data, containing support information.

See Also

AnalyticalModelWall Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportData Class

[image]

Revit 2010 API
AnalyticalSupportData Class
Members See Also Send Feedback
Information for one support of another Structural Element.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AnalyticalSupportData : APIObject
Visual Basic (Declaration)
Public Class AnalyticalSupportData _
    Inherits APIObject
Visual C++
public ref class AnalyticalSupportData : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Structural..::.AnalyticalSupportData

See Also

AnalyticalSupportData Members
Autodesk.Revit.Structural Namespace


AnalyticalSupportData Members

[image] [image]

Revit 2010 API
AnalyticalSupportData Members
AnalyticalSupportData Class Constructors Methods Properties See Also Send Feedback

The AnalyticalSupportData type exposes the following members.

Constructors

Name | Description
AnalyticalSupportData | Initializes a new instance of the AnalyticalSupportData class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
InfoArray | Gets support information array for Element.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Supported | Test to see if the Element is supported.

See Also

AnalyticalSupportData Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportData Constructor

[image]

Revit 2010 API
AnalyticalSupportData Constructor
AnalyticalSupportData Class See Also Send Feedback
Initializes a new instance of the AnalyticalSupportData class

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalSupportData()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalSupportData()

See Also

AnalyticalSupportData Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportData Methods

[image] [image]

Revit 2010 API
AnalyticalSupportData Methods
AnalyticalSupportData Class See Also Send Feedback

The AnalyticalSupportData type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalSupportData Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportData Properties

[image] [image]

Revit 2010 API
AnalyticalSupportData Properties
AnalyticalSupportData Class See Also Send Feedback

The AnalyticalSupportData type exposes the following members.

Properties

Name | Description
InfoArray | Gets support information array for Element.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Supported | Test to see if the Element is supported.

See Also

AnalyticalSupportData Class
Autodesk.Revit.Structural Namespace


InfoArray Property

[image]

Revit 2010 API
AnalyticalSupportData..::.InfoArray Property
AnalyticalSupportData Class See Also Send Feedback
Gets support information array for Element.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalSupportInfoArray InfoArray { get; }
Visual Basic (Declaration)
Public ReadOnly Property InfoArray As AnalyticalSupportInfoArray
Visual C++
public:
property AnalyticalSupportInfoArray^ InfoArray {
    AnalyticalSupportInfoArray^ get ();
}

Remarks

If the Element is a Foundation, this may be empty even though the Supported Flag is True.

See Also

AnalyticalSupportData Class
Autodesk.Revit.Structural Namespace


Supported Property

[image]

Revit 2010 API
AnalyticalSupportData..::.Supported Property
AnalyticalSupportData Class See Also Send Feedback
Test to see if the Element is supported.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Supported { get; }
Visual Basic (Declaration)
Public ReadOnly Property Supported As Boolean
Visual C++
public:
property bool Supported {
    bool get ();
}

Remarks

If the Element is supported, then True will be returned, otherwise False.

See Also

AnalyticalSupportData Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfo Class

[image]

Revit 2010 API
AnalyticalSupportInfo Class
Members See Also Send Feedback
Information for one support of another Structural Element.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AnalyticalSupportInfo : APIObject
Visual Basic (Declaration)
Public Class AnalyticalSupportInfo _
    Inherits APIObject
Visual C++
public ref class AnalyticalSupportInfo : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Structural..::.AnalyticalSupportInfo

See Also

AnalyticalSupportInfo Members
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfo Members

[image] [image]

Revit 2010 API
AnalyticalSupportInfo Members
AnalyticalSupportInfo Class Constructors Methods Properties See Also Send Feedback

The AnalyticalSupportInfo type exposes the following members.

Constructors

Name | Description
AnalyticalSupportInfo | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Element | Gets the Structural Element providing support.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
SupportType | Returns the type of support provided by the other Element.

See Also

AnalyticalSupportInfo Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfo Constructor

[image]

Revit 2010 API
AnalyticalSupportInfo Constructor
AnalyticalSupportInfo Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalSupportInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalSupportInfo()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnalyticalSupportInfo Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfo Methods

[image] [image]

Revit 2010 API
AnalyticalSupportInfo Methods
AnalyticalSupportInfo Class See Also Send Feedback

The AnalyticalSupportInfo type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalSupportInfo Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfo Properties

[image] [image]

Revit 2010 API
AnalyticalSupportInfo Properties
AnalyticalSupportInfo Class See Also Send Feedback

The AnalyticalSupportInfo type exposes the following members.

Properties

Name | Description
Element | Gets the Structural Element providing support.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
SupportType | Returns the type of support provided by the other Element.

See Also

AnalyticalSupportInfo Class
Autodesk.Revit.Structural Namespace


Element Property

[image]

Revit 2010 API
AnalyticalSupportInfo..::.Element Property
AnalyticalSupportInfo Class See Also Send Feedback
Gets the Structural Element providing support.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element Element { get; }
Visual Basic (Declaration)
Public ReadOnly Property Element As Element
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

See Also

AnalyticalSupportInfo Class
Autodesk.Revit.Structural Namespace


SupportType Property

[image]

Revit 2010 API
AnalyticalSupportInfo..::.SupportType Property
AnalyticalSupportInfo Class See Also Send Feedback
Returns the type of support provided by the other Element.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalSupportType SupportType { get; }
Visual Basic (Declaration)
Public ReadOnly Property SupportType As AnalyticalSupportType
Visual C++
public:
property AnalyticalSupportType SupportType {
    AnalyticalSupportType get ();
}

See Also

AnalyticalSupportInfo Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfoArray Class

[image]

Revit 2010 API
AnalyticalSupportInfoArray Class
Members See Also Send Feedback
An array that contains support information objects.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AnalyticalSupportInfoArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class AnalyticalSupportInfoArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class AnalyticalSupportInfoArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Structural..::.AnalyticalSupportInfoArray

See Also

AnalyticalSupportInfoArray Members
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfoArray Members

[image] [image]

Revit 2010 API
AnalyticalSupportInfoArray Members
AnalyticalSupportInfoArray Class Constructors Methods Properties See Also Send Feedback

The AnalyticalSupportInfoArray type exposes the following members.

Constructors

Name | Description
AnalyticalSupportInfoArray | Initializes a new instance of the AnalyticalSupportInfoArray class

Methods

Name | Description
Append | Add the support to the end of the array.
Clear | Removes every support from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified support into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets support information at a specified index within the array.
Size | Returns the number of supports that are in the array.

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfoArray Constructor

[image]

Revit 2010 API
AnalyticalSupportInfoArray Constructor
AnalyticalSupportInfoArray Class See Also Send Feedback
Initializes a new instance of the AnalyticalSupportInfoArray class

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalSupportInfoArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalSupportInfoArray()

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfoArray Methods

[image] [image]

Revit 2010 API
AnalyticalSupportInfoArray Methods
AnalyticalSupportInfoArray Class See Also Send Feedback

The AnalyticalSupportInfoArray type exposes the following members.

Methods

Name | Description
Append | Add the support to the end of the array.
Clear | Removes every support from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified support into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


Append Method

[image]

Revit 2010 API
AnalyticalSupportInfoArray..::.Append Method
AnalyticalSupportInfoArray Class See Also Send Feedback
Add the support to the end of the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    AnalyticalSupportInfo item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As AnalyticalSupportInfo _
)
Visual C++
public:
virtual void Append(
    AnalyticalSupportInfo^ item
)

Parameters

item
Type: Autodesk.Revit.Structural..::.AnalyticalSupportInfo
The support to be added.

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


Clear Method

[image]

Revit 2010 API
AnalyticalSupportInfoArray..::.Clear Method
AnalyticalSupportInfoArray Class See Also Send Feedback
Removes every support from the array, rendering it empty.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


ForwardIterator Method

[image]

Revit 2010 API
AnalyticalSupportInfoArray..::.ForwardIterator Method
AnalyticalSupportInfoArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual AnalyticalSupportInfoArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As AnalyticalSupportInfoArrayIterator
Visual C++
public:
virtual AnalyticalSupportInfoArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


GetEnumerator Method

[image]

Revit 2010 API
AnalyticalSupportInfoArray..::.GetEnumerator Method
AnalyticalSupportInfoArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


Insert Method

[image]

Revit 2010 API
AnalyticalSupportInfoArray..::.Insert Method
AnalyticalSupportInfoArray Class See Also Send Feedback
Insert the specified support into the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    AnalyticalSupportInfo item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As AnalyticalSupportInfo, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    AnalyticalSupportInfo^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Structural..::.AnalyticalSupportInfo
The support to be inserted into the array.
index
Type: System..::.Int32
The support will be inserted before this index.

Return Value

Returns whether the support was inserted into the array.

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


ReverseIterator Method

[image]

Revit 2010 API
AnalyticalSupportInfoArray..::.ReverseIterator Method
AnalyticalSupportInfoArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual AnalyticalSupportInfoArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As AnalyticalSupportInfoArrayIterator
Visual C++
public:
virtual AnalyticalSupportInfoArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfoArray Properties

[image] [image]

Revit 2010 API
AnalyticalSupportInfoArray Properties
AnalyticalSupportInfoArray Class See Also Send Feedback

The AnalyticalSupportInfoArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets support information at a specified index within the array.
Size | Returns the number of supports that are in the array.

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


IsEmpty Property

[image]

Revit 2010 API
AnalyticalSupportInfoArray..::.IsEmpty Property
AnalyticalSupportInfoArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


Item Property

[image]

Revit 2010 API
AnalyticalSupportInfoArray..::.Item Property
AnalyticalSupportInfoArray Class See Also Send Feedback
Gets or sets support information at a specified index within the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual AnalyticalSupportInfo Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As AnalyticalSupportInfo
Visual C++
public:
virtual property AnalyticalSupportInfo^ Item[int index] {
    AnalyticalSupportInfo^ get (int index);
    void set (int index, AnalyticalSupportInfo^ value);
}

Parameters

index
Type: System..::.Int32
The index of the support information to be set or retrieved.

Return Value

Returns the support information at the specified index.

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


Size Property

[image]

Revit 2010 API
AnalyticalSupportInfoArray..::.Size Property
AnalyticalSupportInfoArray Class See Also Send Feedback
Returns the number of supports that are in the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfoArrayIterator Class

[image]

Revit 2010 API
AnalyticalSupportInfoArrayIterator Class
Members See Also Send Feedback
An iterator to a support information array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class AnalyticalSupportInfoArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class AnalyticalSupportInfoArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class AnalyticalSupportInfoArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Structural..::.AnalyticalSupportInfoArrayIterator

See Also

AnalyticalSupportInfoArrayIterator Members
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfoArrayIterator Members

[image] [image]

Revit 2010 API
AnalyticalSupportInfoArrayIterator Members
AnalyticalSupportInfoArrayIterator Class Constructors Methods Properties See Also Send Feedback

The AnalyticalSupportInfoArrayIterator type exposes the following members.

Constructors

Name | Description
AnalyticalSupportInfoArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AnalyticalSupportInfoArrayIterator Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfoArrayIterator Constructor

[image]

Revit 2010 API
AnalyticalSupportInfoArrayIterator Constructor
AnalyticalSupportInfoArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalSupportInfoArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalSupportInfoArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnalyticalSupportInfoArrayIterator Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfoArrayIterator Methods

[image] [image]

Revit 2010 API
AnalyticalSupportInfoArrayIterator Methods
AnalyticalSupportInfoArrayIterator Class See Also Send Feedback

The AnalyticalSupportInfoArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalSupportInfoArrayIterator Class
Autodesk.Revit.Structural Namespace


MoveNext Method

[image]

Revit 2010 API
AnalyticalSupportInfoArrayIterator..::.MoveNext Method
AnalyticalSupportInfoArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

AnalyticalSupportInfoArrayIterator Class
Autodesk.Revit.Structural Namespace


Reset Method

[image]

Revit 2010 API
AnalyticalSupportInfoArrayIterator..::.Reset Method
AnalyticalSupportInfoArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

AnalyticalSupportInfoArrayIterator Class
Autodesk.Revit.Structural Namespace


AnalyticalSupportInfoArrayIterator Properties

[image] [image]

Revit 2010 API
AnalyticalSupportInfoArrayIterator Properties
AnalyticalSupportInfoArrayIterator Class See Also Send Feedback

The AnalyticalSupportInfoArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AnalyticalSupportInfoArrayIterator Class
Autodesk.Revit.Structural Namespace


Current Property

[image]

Revit 2010 API
AnalyticalSupportInfoArrayIterator..::.Current Property
AnalyticalSupportInfoArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

AnalyticalSupportInfoArrayIterator Class
Autodesk.Revit.Structural Namespace


BarDescription Class

[image]

Revit 2010 API
BarDescription Class
Members See Also Send Feedback
An object that represents an Area Reinforcement within the Autodesk Revit project.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BarDescription : APIObject
Visual Basic (Declaration)
Public Class BarDescription _
    Inherits APIObject
Visual C++
public ref class BarDescription : public APIObject

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Area Reinforcement element is available only in the Autodesk Revit Structure product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Structural..::.BarDescription

See Also

BarDescription Members
Autodesk.Revit.Structural Namespace


BarDescription Members

[image] [image]

Revit 2010 API
BarDescription Members
BarDescription Class Constructors Methods Properties See Also Send Feedback

The BarDescription type exposes the following members.

Constructors

Name | Description
BarDescription | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BarType | Retrieves the Rebar Bar Type property of a Bar Description.
Count | Retrieves the number of bars of this shape.
HooksInSameDirection | Retrieves the Rebar Hooks In Same Direction property of a Bar Description. If true, both hooks are bent in the same direction; if false, the hooks are bent in opposite directions.
HookType | Retrieves the Rebar Hook Type property of a Bar Description.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Layer | Retrieves the layer index (0, 1, 2, or 3) for this Bar Description.
Length | Retrieves the length of a Bar Description.

See Also

BarDescription Class
Autodesk.Revit.Structural Namespace


BarDescription Constructor

[image]

Revit 2010 API
BarDescription Constructor
BarDescription Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BarDescription()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BarDescription()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BarDescription Class
Autodesk.Revit.Structural Namespace


BarDescription Methods

[image] [image]

Revit 2010 API
BarDescription Methods
BarDescription Class See Also Send Feedback

The BarDescription type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarDescription Class
Autodesk.Revit.Structural Namespace


BarDescription Properties

[image] [image]

Revit 2010 API
BarDescription Properties
BarDescription Class See Also Send Feedback

The BarDescription type exposes the following members.

Properties

Name | Description
BarType | Retrieves the Rebar Bar Type property of a Bar Description.
Count | Retrieves the number of bars of this shape.
HooksInSameDirection | Retrieves the Rebar Hooks In Same Direction property of a Bar Description. If true, both hooks are bent in the same direction; if false, the hooks are bent in opposite directions.
HookType | Retrieves the Rebar Hook Type property of a Bar Description.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Layer | Retrieves the layer index (0, 1, 2, or 3) for this Bar Description.
Length | Retrieves the length of a Bar Description.

See Also

BarDescription Class
Autodesk.Revit.Structural Namespace


BarType Property

[image]

Revit 2010 API
BarDescription..::.BarType Property
BarDescription Class See Also Send Feedback
Retrieves the Rebar Bar Type property of a Bar Description.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarBarType BarType { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarType As RebarBarType
Visual C++
public:
property RebarBarType^ BarType {
    RebarBarType^ get ();
}

See Also

BarDescription Class
Autodesk.Revit.Structural Namespace


Count Property

[image]

Revit 2010 API
BarDescription..::.Count Property
BarDescription Class See Also Send Feedback
Retrieves the number of bars of this shape.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
}

See Also

BarDescription Class
Autodesk.Revit.Structural Namespace


HooksInSameDirection Property

[image]

Revit 2010 API
BarDescription..::.HooksInSameDirection Property
BarDescription Class See Also Send Feedback
Retrieves the Rebar Hooks In Same Direction property of a Bar Description. If true, both hooks are bent in the same direction; if false, the hooks are bent in opposite directions.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool HooksInSameDirection { get; }
Visual Basic (Declaration)
Public ReadOnly Property HooksInSameDirection As Boolean
Visual C++
public:
property bool HooksInSameDirection {
    bool get ();
}

See Also

BarDescription Class
Autodesk.Revit.Structural Namespace


HookType Property

[image]

Revit 2010 API
BarDescription..::.HookType Property
BarDescription Class See Also Send Feedback
Retrieves the Rebar Hook Type property of a Bar Description.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarHookType HookType[
    int end
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property HookType ( _
    end As Integer _
) As RebarHookType
Visual C++
public:
property RebarHookType^ HookType[int end] {
    RebarHookType^ get (int end);
}

Parameters

end
Type: System..::.Int32
Which end of the bar: 0 or 1.

See Also

BarDescription Class
Autodesk.Revit.Structural Namespace


Layer Property

[image]

Revit 2010 API
BarDescription..::.Layer Property
BarDescription Class See Also Send Feedback
Retrieves the layer index (0, 1, 2, or 3) for this Bar Description.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Layer { get; }
Visual Basic (Declaration)
Public ReadOnly Property Layer As Integer
Visual C++
public:
property int Layer {
    int get ();
}

Remarks

For floors, layer 0 is Top Major; layer 1 is Top Minor; layer 2 is Bottom Major; layer 3 is Bottom Minor. For walls, layer 0 is Front Major; layer 1 is Front Minor; layer 2 is Back Major; layer 3 is Back Minor.

See Also

BarDescription Class
Autodesk.Revit.Structural Namespace


Length Property

[image]

Revit 2010 API
BarDescription..::.Length Property
BarDescription Class See Also Send Feedback
Retrieves the length of a Bar Description.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Double
Visual C++
public:
property double Length {
    double get ();
}

See Also

BarDescription Class
Autodesk.Revit.Structural Namespace


CompoundStructure Class

[image]

Revit 2010 API
CompoundStructure Class
Members See Also Send Feedback
An object that describes the multi layered construction of walls or floors.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CompoundStructure : APIObject
Visual Basic (Declaration)
Public Class CompoundStructure _
    Inherits APIObject
Visual C++
public ref class CompoundStructure : public APIObject

Remarks

The CompoundStructure object exposes the layers of elements, such as walls. These layers can be of varying thickness and material, each of which has a dedicated function.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Structural..::.CompoundStructure

See Also

CompoundStructure Members
Autodesk.Revit.Structural Namespace


CompoundStructure Members

[image] [image]

Revit 2010 API
CompoundStructure Members
CompoundStructure Class Constructors Methods Properties See Also Send Feedback

The CompoundStructure type exposes the following members.

Constructors

Name | Description
CompoundStructure | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Layers | Returns the layers that make up the compound structure of the object.

See Also

CompoundStructure Class
Autodesk.Revit.Structural Namespace


CompoundStructure Constructor

[image]

Revit 2010 API
CompoundStructure Constructor
CompoundStructure Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CompoundStructure()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CompoundStructure()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CompoundStructure Class
Autodesk.Revit.Structural Namespace


CompoundStructure Methods

[image] [image]

Revit 2010 API
CompoundStructure Methods
CompoundStructure Class See Also Send Feedback

The CompoundStructure type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompoundStructure Class
Autodesk.Revit.Structural Namespace


CompoundStructure Properties

[image] [image]

Revit 2010 API
CompoundStructure Properties
CompoundStructure Class See Also Send Feedback

The CompoundStructure type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Layers | Returns the layers that make up the compound structure of the object.

See Also

CompoundStructure Class
Autodesk.Revit.Structural Namespace


Layers Property

[image]

Revit 2010 API
CompoundStructure..::.Layers Property
CompoundStructure Class See Also Send Feedback
Returns the layers that make up the compound structure of the object.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CompoundStructureLayerArray Layers { get; }
Visual Basic (Declaration)
Public ReadOnly Property Layers As CompoundStructureLayerArray
Visual C++
public:
property CompoundStructureLayerArray^ Layers {
    CompoundStructureLayerArray^ get ();
}

Remarks

For walls, the layers are ordered from exterior to interior. For floors, the layers are ordered from top to bottom.

See Also

CompoundStructure Class
Autodesk.Revit.Structural Namespace


CompoundStructureLayer Class

[image]

Revit 2010 API
CompoundStructureLayer Class
Members See Also Send Feedback
An object that describes a single layer of multi-layered object.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CompoundStructureLayer : APIObject
Visual Basic (Declaration)
Public Class CompoundStructureLayer _
    Inherits APIObject
Visual C++
public ref class CompoundStructureLayer : public APIObject

Remarks

A wall or floor may have several layers. Each layer contains information about its thickness, intended purpose (function), and the material from which it is made.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Structural..::.CompoundStructureLayer

See Also

CompoundStructureLayer Members
Autodesk.Revit.Structural Namespace


CompoundStructureLayer Members

[image] [image]

Revit 2010 API
CompoundStructureLayer Members
CompoundStructureLayer Class Constructors Methods Properties See Also Send Feedback

The CompoundStructureLayer type exposes the following members.

Constructors

Name | Description
CompoundStructureLayer | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeckProfile | Returns or set the family symbol of the deck profile of the layer within the structure.
DeckUsage | Returns usage of the deck layer within the structure.
Function | Returns the purpose/function of the layer within the structure.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Material | Get or set the material from which the layer is made.
Thickness | Retrieve or modify the thickness of the layer.
Variable | Returns or set whether the layer thickness is vrariable.

See Also

CompoundStructureLayer Class
Autodesk.Revit.Structural Namespace


CompoundStructureLayer Constructor

[image]

Revit 2010 API
CompoundStructureLayer Constructor
CompoundStructureLayer Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CompoundStructureLayer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CompoundStructureLayer()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CompoundStructureLayer Class
Autodesk.Revit.Structural Namespace


CompoundStructureLayer Methods

[image] [image]

Revit 2010 API
CompoundStructureLayer Methods
CompoundStructureLayer Class See Also Send Feedback

The CompoundStructureLayer type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompoundStructureLayer Class
Autodesk.Revit.Structural Namespace


CompoundStructureLayer Properties

[image] [image]

Revit 2010 API
CompoundStructureLayer Properties
CompoundStructureLayer Class See Also Send Feedback

The CompoundStructureLayer type exposes the following members.

Properties

Name | Description
DeckProfile | Returns or set the family symbol of the deck profile of the layer within the structure.
DeckUsage | Returns usage of the deck layer within the structure.
Function | Returns the purpose/function of the layer within the structure.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Material | Get or set the material from which the layer is made.
Thickness | Retrieve or modify the thickness of the layer.
Variable | Returns or set whether the layer thickness is vrariable.

See Also

CompoundStructureLayer Class
Autodesk.Revit.Structural Namespace


DeckProfile Property

[image]

Revit 2010 API
CompoundStructureLayer..::.DeckProfile Property
CompoundStructureLayer Class See Also Send Feedback
Returns or set the family symbol of the deck profile of the layer within the structure.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbol DeckProfile { get; set; }
Visual Basic (Declaration)
Public Property DeckProfile As FamilySymbol
Visual C++
public:
property FamilySymbol^ DeckProfile {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

See Also

CompoundStructureLayer Class
Autodesk.Revit.Structural Namespace


DeckUsage Property

[image]

Revit 2010 API
CompoundStructureLayer..::.DeckUsage Property
CompoundStructureLayer Class See Also Send Feedback
Returns usage of the deck layer within the structure.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CompoundStructureDeckUsage DeckUsage { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeckUsage As CompoundStructureDeckUsage
Visual C++
public:
property CompoundStructureDeckUsage DeckUsage {
    CompoundStructureDeckUsage get ();
}

See Also

CompoundStructureLayer Class
Autodesk.Revit.Structural Namespace


Function Property

[image]

Revit 2010 API
CompoundStructureLayer..::.Function Property
CompoundStructureLayer Class See Also Send Feedback
Returns the purpose/function of the layer within the structure.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CompoundStructureLayerFunction Function { get; }
Visual Basic (Declaration)
Public ReadOnly Property Function As CompoundStructureLayerFunction
Visual C++
public:
property CompoundStructureLayerFunction Function {
    CompoundStructureLayerFunction get ();
}

See Also

CompoundStructureLayer Class
Autodesk.Revit.Structural Namespace


Material Property

[image]

Revit 2010 API
CompoundStructureLayer..::.Material Property
CompoundStructureLayer Class Example See Also Send Feedback
Get or set the material from which the layer is made.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Material Material { get; set; }
Visual Basic (Declaration)
Public Property Material As Material
Visual C++
public:
property Material^ Material {
    Material^ get ();
    void set (Material^ value);
}

Examples

CopyC#
public void GetWallLayerMaterial(Autodesk.Revit.Document document, Wall wall)
{
    // get WallType of wall
    WallType aWallType = wall.WallType;
    // Only Basic Wall has compoundStructure
    if (WallType.WallKind.Basic == aWallType.Kind)
    {
        // Get CompoundStructure
        CompoundStructure comStruct = aWallType.CompoundStructure;
        Categories allCategories = document.Settings.Categories;

        // Get the category OST_Walls default Material;
        // use if that layer's default Material is <By Category>
        Category wallCategory = allCategories.get_Item(BuiltInCategory.OST_Walls);
        Autodesk.Revit.Elements.Material wallMaterial = wallCategory.Material;

        foreach (CompoundStructureLayer structLayer in comStruct.Layers)
        {
            Autodesk.Revit.Elements.Material layerMaterial = structLayer.Material;
            // If CompoundStructureLayer's Material is specified, use default
            // Material of its Category
            if (null == layerMaterial)
            {
                switch (structLayer.Function)
                {
                    case CompoundStructureLayerFunction.Finish1:
                        layerMaterial = allCategories.get_Item(BuiltInCategory.OST_WallsFinish1).Material;
                        break;
                    case CompoundStructureLayerFunction.Finish2:
                        layerMaterial = allCategories.get_Item(BuiltInCategory.OST_WallsFinish2).Material;
                        break;
                    case CompoundStructureLayerFunction.MembraneLayer:
                        layerMaterial = allCategories.get_Item(BuiltInCategory.OST_WallsMembrane).Material;
                        break;
                    case CompoundStructureLayerFunction.Structure:
                        layerMaterial =  allCategories.get_Item(BuiltInCategory.OST_WallsStructure).Material;
                        break;
                    case CompoundStructureLayerFunction.Substrate:
                        layerMaterial = allCategories.get_Item(BuiltInCategory.OST_WallsSubstrate).Material;
                        break;
                    case CompoundStructureLayerFunction.ThermalOrAir:
                        layerMaterial = allCategories.get_Item(BuiltInCategory.OST_WallsInsulation).Material;
                        break;
                    default:
                        // It is impossible to reach here
                        break;
                }
                if (null == layerMaterial)
                {
                    // CompoundStructureLayer's default Material is its SubCategory
                    layerMaterial = wallMaterial;
                }
            }
            MessageBox.Show("Layer Material: " + layerMaterial, "Revit");
        }
    }
}
CopyVB.NET
Public Sub GetWallLayerMaterial(ByVal document As Autodesk.Revit.Document, ByVal wall As Wall)
    ' get WallType of wall
    Dim aWallType As Autodesk.Revit.Symbols.WallType = wall.WallType
    ' Only Basic Wall has compoundStructure
    If Autodesk.Revit.Symbols.WallType.WallKind.Basic = aWallType.Kind Then
        ' Get CompoundStructure
        Dim comStruct As Autodesk.Revit.Structural.CompoundStructure = aWallType.CompoundStructure
        Dim allCategories As Categories = document.Settings.Categories

        ' Get the category OST_Walls default Material;
        ' use if that layer's default Material is <By Category>
        Dim wallCategory As Autodesk.Revit.Category = allCategories.Item(BuiltInCategory.OST_Walls)
        Dim wallMaterial As Autodesk.Revit.Elements.Material = wallCategory.Material

        For Each structLayer As CompoundStructureLayer In comStruct.Layers
            Dim layerMaterial As Autodesk.Revit.Elements.Material = structLayer.Material
            ' If CompoundStructureLayer's Material is specified, use default
            ' Material of its Category
            If layerMaterial Is Nothing Then
                Select Case structLayer.[Function]
                    Case CompoundStructureLayerFunction.Finish1
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsFinish1).Material
                        Exit Select
                    Case CompoundStructureLayerFunction.Finish2
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsFinish2).Material
                        Exit Select
                    Case CompoundStructureLayerFunction.MembraneLayer
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsMembrane).Material
                        Exit Select
                    Case CompoundStructureLayerFunction.[Structure]
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsStructure).Material
                        Exit Select
                    Case CompoundStructureLayerFunction.Substrate
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsSubstrate).Material
                        Exit Select
                    Case CompoundStructureLayerFunction.ThermalOrAir
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsInsulation).Material
                        Exit Select
                    Case Else
                        ' It is impossible to reach here
                        Exit Select
                End Select
                If layerMaterial Is Nothing Then
                    ' CompoundStructureLayer's default Material is its SubCategory
                    layerMaterial = wallMaterial
                End If
            End If
            MessageBox.Show("Layer Material: " & layerMaterial.ToString, "Revit")
        Next
    End If
End Sub

See Also

CompoundStructureLayer Class
Autodesk.Revit.Structural Namespace


Thickness Property

[image]

Revit 2010 API
CompoundStructureLayer..::.Thickness Property
CompoundStructureLayer Class See Also Send Feedback
Retrieve or modify the thickness of the layer.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Thickness { get; set; }
Visual Basic (Declaration)
Public Property Thickness As Double
Visual C++
public:
property double Thickness {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the input argument thickness is invalid for the layer in set method.
System..::.ArgumentOutOfRangeException | Thrown when the input argument thickness is less than 0 in set method.
System..::.InvalidOperationException | Thrown when set operation failed.

See Also

CompoundStructureLayer Class
Autodesk.Revit.Structural Namespace


Variable Property

[image]

Revit 2010 API
CompoundStructureLayer..::.Variable Property
CompoundStructureLayer Class See Also Send Feedback
Returns or set whether the layer thickness is vrariable.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Variable { get; set; }
Visual Basic (Declaration)
Public Property Variable As Boolean
Visual C++
public:
property bool Variable {
    bool get ();
    void set (bool value);
}

See Also

CompoundStructureLayer Class
Autodesk.Revit.Structural Namespace


CompoundStructureLayerArray Class

[image]

Revit 2010 API
CompoundStructureLayerArray Class
Members See Also Send Feedback
An array that contains layer objects.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CompoundStructureLayerArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class CompoundStructureLayerArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CompoundStructureLayerArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Structural..::.CompoundStructureLayerArray

See Also

CompoundStructureLayerArray Members
Autodesk.Revit.Structural Namespace


CompoundStructureLayerArray Members

[image] [image]

Revit 2010 API
CompoundStructureLayerArray Members
CompoundStructureLayerArray Class Constructors Methods Properties See Also Send Feedback

The CompoundStructureLayerArray type exposes the following members.

Constructors

Name | Description
CompoundStructureLayerArray | Initializes a new instance of the CompoundStructureLayerArray class

Methods

Name | Description
Append | Add the layer to the end of the array.
Clear | Removes every layer from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified layer into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a layer at a specified index within the array.
Size | Returns the number of layers that are in the array.

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


CompoundStructureLayerArray Constructor

[image]

Revit 2010 API
CompoundStructureLayerArray Constructor
CompoundStructureLayerArray Class See Also Send Feedback
Initializes a new instance of the CompoundStructureLayerArray class

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CompoundStructureLayerArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CompoundStructureLayerArray()

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


CompoundStructureLayerArray Methods

[image] [image]

Revit 2010 API
CompoundStructureLayerArray Methods
CompoundStructureLayerArray Class See Also Send Feedback

The CompoundStructureLayerArray type exposes the following members.

Methods

Name | Description
Append | Add the layer to the end of the array.
Clear | Removes every layer from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified layer into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


Append Method

[image]

Revit 2010 API
CompoundStructureLayerArray..::.Append Method
CompoundStructureLayerArray Class See Also Send Feedback
Add the layer to the end of the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Append(
    CompoundStructureLayer item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As CompoundStructureLayer _
)
Visual C++
public:
virtual void Append(
    CompoundStructureLayer^ item
)

Parameters

item
Type: Autodesk.Revit.Structural..::.CompoundStructureLayer
The phase to be added.

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


Clear Method

[image]

Revit 2010 API
CompoundStructureLayerArray..::.Clear Method
CompoundStructureLayerArray Class See Also Send Feedback
Removes every layer from the array, rendering it empty.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


ForwardIterator Method

[image]

Revit 2010 API
CompoundStructureLayerArray..::.ForwardIterator Method
CompoundStructureLayerArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CompoundStructureLayerArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CompoundStructureLayerArrayIterator
Visual C++
public:
virtual CompoundStructureLayerArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


GetEnumerator Method

[image]

Revit 2010 API
CompoundStructureLayerArray..::.GetEnumerator Method
CompoundStructureLayerArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


Insert Method

[image]

Revit 2010 API
CompoundStructureLayerArray..::.Insert Method
CompoundStructureLayerArray Class See Also Send Feedback
Insert the specified layer into the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    CompoundStructureLayer item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As CompoundStructureLayer, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    CompoundStructureLayer^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Structural..::.CompoundStructureLayer
The layer to be inserted into the array.
index
Type: System..::.Int32
The layer will be inserted before this index.

Return Value

Returns whether the layer was inserted into the array.

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


ReverseIterator Method

[image]

Revit 2010 API
CompoundStructureLayerArray..::.ReverseIterator Method
CompoundStructureLayerArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CompoundStructureLayerArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CompoundStructureLayerArrayIterator
Visual C++
public:
virtual CompoundStructureLayerArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


CompoundStructureLayerArray Properties

[image] [image]

Revit 2010 API
CompoundStructureLayerArray Properties
CompoundStructureLayerArray Class See Also Send Feedback

The CompoundStructureLayerArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a layer at a specified index within the array.
Size | Returns the number of layers that are in the array.

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


IsEmpty Property

[image]

Revit 2010 API
CompoundStructureLayerArray..::.IsEmpty Property
CompoundStructureLayerArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


Item Property

[image]

Revit 2010 API
CompoundStructureLayerArray..::.Item Property
CompoundStructureLayerArray Class See Also Send Feedback
Gets or sets a layer at a specified index within the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CompoundStructureLayer Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As CompoundStructureLayer
Visual C++
public:
virtual property CompoundStructureLayer^ Item[int index] {
    CompoundStructureLayer^ get (int index);
    void set (int index, CompoundStructureLayer^ value);
}

Parameters

index
Type: System..::.Int32
The index of the layer to be set or retrieved.

Return Value

Returns the layer at the specified index.

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


Size Property

[image]

Revit 2010 API
CompoundStructureLayerArray..::.Size Property
CompoundStructureLayerArray Class See Also Send Feedback
Returns the number of layers that are in the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CompoundStructureLayerArray Class
Autodesk.Revit.Structural Namespace


CompoundStructureLayerArrayIterator Class

[image]

Revit 2010 API
CompoundStructureLayerArrayIterator Class
Members See Also Send Feedback
An iterator to a layer array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class CompoundStructureLayerArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CompoundStructureLayerArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CompoundStructureLayerArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Structural..::.CompoundStructureLayerArrayIterator

See Also

CompoundStructureLayerArrayIterator Members
Autodesk.Revit.Structural Namespace


CompoundStructureLayerArrayIterator Members

[image] [image]

Revit 2010 API
CompoundStructureLayerArrayIterator Members
CompoundStructureLayerArrayIterator Class Constructors Methods Properties See Also Send Feedback

The CompoundStructureLayerArrayIterator type exposes the following members.

Constructors

Name | Description
CompoundStructureLayerArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CompoundStructureLayerArrayIterator Class
Autodesk.Revit.Structural Namespace


CompoundStructureLayerArrayIterator Constructor

[image]

Revit 2010 API
CompoundStructureLayerArrayIterator Constructor
CompoundStructureLayerArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CompoundStructureLayerArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CompoundStructureLayerArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CompoundStructureLayerArrayIterator Class
Autodesk.Revit.Structural Namespace


CompoundStructureLayerArrayIterator Methods

[image] [image]

Revit 2010 API
CompoundStructureLayerArrayIterator Methods
CompoundStructureLayerArrayIterator Class See Also Send Feedback

The CompoundStructureLayerArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompoundStructureLayerArrayIterator Class
Autodesk.Revit.Structural Namespace


MoveNext Method

[image]

Revit 2010 API
CompoundStructureLayerArrayIterator..::.MoveNext Method
CompoundStructureLayerArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CompoundStructureLayerArrayIterator Class
Autodesk.Revit.Structural Namespace


Reset Method

[image]

Revit 2010 API
CompoundStructureLayerArrayIterator..::.Reset Method
CompoundStructureLayerArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CompoundStructureLayerArrayIterator Class
Autodesk.Revit.Structural Namespace


CompoundStructureLayerArrayIterator Properties

[image] [image]

Revit 2010 API
CompoundStructureLayerArrayIterator Properties
CompoundStructureLayerArrayIterator Class See Also Send Feedback

The CompoundStructureLayerArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CompoundStructureLayerArrayIterator Class
Autodesk.Revit.Structural Namespace


Current Property

[image]

Revit 2010 API
CompoundStructureLayerArrayIterator..::.Current Property
CompoundStructureLayerArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CompoundStructureLayerArrayIterator Class
Autodesk.Revit.Structural Namespace


Autodesk.Revit.Structural.Enums Namespace

[image]

Revit 2010 API
Autodesk.Revit.Structural.Enums Namespace
Send Feedback

Enumerations

Enumeration | Description
AnalyticalSupportType | Describes the type of support given by another structural element.
CompoundStructureDeckUsage | Describes how the deck relates to the surrounding layers.
CompoundStructureLayerFunction | Describes the purpose of the layer within a compound structure, such as a wall or floor.
InstanceUsage | An enumerate type listing all the possible structural usage cases for a FamilyInstance object.
Material | Basic solid structural object material types.
RebarHookOrientation | Orientation of a rebar hook relative to the path of the Rebar Shape.
RebarLayoutRule | The rule for how the rebars in rebar set are laid out.
RebarShapeArcReferenceType | A Rebar Shape Definition constraint that is measured to a bend must take the bar diameter into account, by specifying whether it measures to the exterior, centerline, or interior of the bend.
RebarShapeBendAngle | A bend in a rebar shape has an angular range specified by one of these values. The angles refer to the angle swept out by one segment as it is bent relative to another. That is, an "Obtuse" bend results in two segments that meet at an angle that is less than 90 degrees when measured internally. Put another way, to create an equilateral triangle, you would need two "Obtuse" bends.
RebarShapeDefinitionByArcType | A RebarShapeDefinitionByArc takes one of three forms.
RebarStyle | Describes the usage style of a RebarShape. The style affects the bend radius and the set of allowable hooks. It also affects Rebar instance auto-constraining behavior.
SlabFoundationType | SlabFoundation type.
StructuralType | Fundamental structural component category.
TranslationRotationValue | Values for BoundaryConditions Translation and Rotation parameters.
WallUsage | An enumerate type listing all the possible structural usage cases for a Wall object.


AnalyticalSupportType Enumeration

[image]

Revit 2010 API
AnalyticalSupportType Enumeration
See Also Send Feedback
Describes the type of support given by another structural element.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum AnalyticalSupportType
Visual Basic (Declaration)
Public Enumeration AnalyticalSupportType
Visual C++
public enum class AnalyticalSupportType

Members

Member name | Description
MAX | The value is used to check whether the enum is the same size as the internal one.
Surface_Support | A Surface support type.
Line_Support | A Line support type.
Point_Support | A Point support type.
Unknown_Support | An unknown support type.

See Also

Autodesk.Revit.Structural.Enums Namespace


CompoundStructureDeckUsage Enumeration

[image]

Revit 2010 API
CompoundStructureDeckUsage Enumeration
See Also Send Feedback
Describes how the deck relates to the surrounding layers.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum CompoundStructureDeckUsage
Visual Basic (Declaration)
Public Enumeration CompoundStructureDeckUsage
Visual C++
public enum class CompoundStructureDeckUsage

Members

Member name | Description
MergeWithLayerBelow | Deck is merged with the layer below.
Standalone | Deck is independent of other layers.
MergeWithLayerAbove | Deck is merged with the layer above.
Invalid | Invalid.

See Also

Autodesk.Revit.Structural.Enums Namespace


CompoundStructureLayerFunction Enumeration

[image]

Revit 2010 API
CompoundStructureLayerFunction Enumeration
See Also Send Feedback
Describes the purpose of the layer within a compound structure, such as a wall or floor.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum CompoundStructureLayerFunction
Visual Basic (Declaration)
Public Enumeration CompoundStructureLayerFunction
Visual C++
public enum class CompoundStructureLayerFunction

Members

Member name | Description
StructuralDeck | A special layer considered to be structural decking.
MembraneLayer | A membrane layer.
Finish2 | A finish layer.
Finish1 | A finish layer.
ThermalOrAir | A thermal or air insulating layer.
Substrate | A substrate layer.
Structure | A structural layer.

See Also

Autodesk.Revit.Structural.Enums Namespace


InstanceUsage Enumeration

[image]

Revit 2010 API
InstanceUsage Enumeration
See Also Send Feedback
An enumerate type listing all the possible structural usage cases for a FamilyInstance object.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum InstanceUsage
Visual Basic (Declaration)
Public Enumeration InstanceUsage
Visual C++
public enum class InstanceUsage

Members

Member name | Description
MAX | The value is used to check whether the enum is the same size as the internal one.
TrussWeb | The instance should be considered to be truss web for the purpose of structural analysis.
TrussChord | The instance should be considered to be truss chord for the purpose of structural analysis.
Automatic | The instance should be considered to be automatic for the purpose of structural analysis.
KickerBracing | The instance should be considered to be kicker bracing for the purpose of structural analysis.
HorizontalBracing | The instance should be considered to be horizontal bracing for the purpose of structural analysis.
Brace | The instance should be considered to be a brace for the purpose of structural analysis.
Other | The instance should be considered for the structural analysis but its purpose is not clearly defined.
Purlin | The instance should be considered to be a purlin for the purpose of structural analysis.
Joist | The instance should be considered to be a joist for the purpose of structural analysis.
Girder | The instance should be considered to be a girder for the purpose of structural analysis.
Column | The instance should be considered to be a column for the purpose of structural analysis.
Wall | The instance should be considered to be a wall for the purpose of structural analysis.
Undefined | The instance has no predefined usage.

See Also

Autodesk.Revit.Structural.Enums Namespace


Material Enumeration

[image]

Revit 2010 API
Material Enumeration
See Also Send Feedback
Basic solid structural object material types.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum Material
Visual Basic (Declaration)
Public Enumeration Material
Visual C++
public enum class Material

Members

Member name | Description
MAX | The value is used to check whether the enum is the same size as the internal one.
PrecastConcrete | The object is considered to be made of precast concrete.
Other | The material is defined, but it is not steel, concrete , wood or precast concrete.
Wood | The object is considered to be made of wood.
Concrete | The object is considered to be made of concrete.
Steel | The object is considered to be made of steel.
Undefined | The material for this object has not been defined.

See Also

Autodesk.Revit.Structural.Enums Namespace


RebarHookOrientation Enumeration

[image]

Revit 2010 API
RebarHookOrientation Enumeration
See Also Send Feedback
Orientation of a rebar hook relative to the path of the Rebar Shape.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum RebarHookOrientation
Visual Basic (Declaration)
Public Enumeration RebarHookOrientation
Visual C++
public enum class RebarHookOrientation

Members

Member name | Description
Right | Hook towards the right of a segment-based shape (RebarShapeDefinitionBySegments), or to the exterior of an arc-based shape (RebarShapeDefinitionByArc).
Left | Hook towards the left of a segment-based shape (RebarShapeDefinitionBySegments), or to the interior of an arc-based shape (RebarShapeDefinitionByArc).

See Also

Autodesk.Revit.Structural.Enums Namespace


RebarLayoutRule Enumeration

[image]

Revit 2010 API
RebarLayoutRule Enumeration
See Also Send Feedback
The rule for how the rebars in rebar set are laid out.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum RebarLayoutRule
Visual Basic (Declaration)
Public Enumeration RebarLayoutRule
Visual C++
public enum class RebarLayoutRule

Members

Member name | Description
MinimumClearSpacing | You specify the minimum distance between rebar, and the quantity of rebar changes based on the distance between the first and last bars. This spacing is maintained even if the rebar size changes.
NumberWithSpacing | You specify constant values for quantity and spacing.
MaximumSpacing | You specify the maximum distance between rebar, but the number of rebar changes based on the distance between the first and last bars.
FixedNumber | The spacing between the rebar is adjustable, but the number of bars is constant based on your input.
Single | It is a single rebar and not a rebar set.

See Also

Autodesk.Revit.Structural.Enums Namespace


RebarShapeArcReferenceType Enumeration

[image]

Revit 2010 API
RebarShapeArcReferenceType Enumeration
See Also Send Feedback
A Rebar Shape Definition constraint that is measured to a bend must take the bar diameter into account, by specifying whether it measures to the exterior, centerline, or interior of the bend.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum RebarShapeArcReferenceType
Visual Basic (Declaration)
Public Enumeration RebarShapeArcReferenceType
Visual C++
public enum class RebarShapeArcReferenceType

Members

Member name | Description
External | Measure to the exterior of the bend.
Centerline | Measure to the centerline of the bar.
Internal | Measure to the interior of the bend.

See Also

Autodesk.Revit.Structural.Enums Namespace


RebarShapeBendAngle Enumeration

[image]

Revit 2010 API
RebarShapeBendAngle Enumeration
See Also Send Feedback
A bend in a rebar shape has an angular range specified by one of these values. The angles refer to the angle swept out by one segment as it is bent relative to another. That is, an "Obtuse" bend results in two segments that meet at an angle that is less than 90 degrees when measured internally. Put another way, to create an equilateral triangle, you would need two "Obtuse" bends.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum RebarShapeBendAngle
Visual Basic (Declaration)
Public Enumeration RebarShapeBendAngle
Visual C++
public enum class RebarShapeBendAngle

Members

Member name | Description
Reversal | The angle is 180 degrees; the bar bends back on itself.
Obtuse | The angle is between 90 and 180 degrees.
Acute | The angle is less than 90 degrees.
Right | The angle is 90 degrees.

See Also

Autodesk.Revit.Structural.Enums Namespace


RebarShapeDefinitionByArcType Enumeration

[image]

Revit 2010 API
RebarShapeDefinitionByArcType Enumeration
See Also Send Feedback
A RebarShapeDefinitionByArc takes one of three forms.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum RebarShapeDefinitionByArcType
Visual Basic (Declaration)
Public Enumeration RebarShapeDefinitionByArcType
Visual C++
public enum class RebarShapeDefinitionByArcType

Members

Member name | Description
LappedCircle | A full circle, subtending an angle more than 360 degrees and less than 720 degrees. The behavior in Revit is the same as Arc, but an extra complete circle is included in the rebar.
Arc | An arc, subtending an angle less than 360 degrees.

See Also

Autodesk.Revit.Structural.Enums Namespace


RebarStyle Enumeration

[image]

Revit 2010 API
RebarStyle Enumeration
See Also Send Feedback
Describes the usage style of a RebarShape. The style affects the bend radius and the set of allowable hooks. It also affects Rebar instance auto-constraining behavior.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum RebarStyle
Visual Basic (Declaration)
Public Enumeration RebarStyle
Visual C++
public enum class RebarStyle

Members

Member name | Description
StirrupTie | A stirrup or tie bar.
Standard | A standard or longitudinal bar.

See Also

Autodesk.Revit.Structural.Enums Namespace


SlabFoundationType Enumeration

[image]

Revit 2010 API
SlabFoundationType Enumeration
See Also Send Feedback
SlabFoundation type.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum SlabFoundationType
Visual Basic (Declaration)
Public Enumeration SlabFoundationType
Visual C++
public enum class SlabFoundationType

Members

Member name | Description
SlabOnGrade | SlabFoundationType is SlabOnGrade.
SlabFoundation | SlabFoundationType is SlabFoundation.
Slab | SlabFoundationType is Slab.

See Also

Autodesk.Revit.Structural.Enums Namespace


StructuralType Enumeration

[image]

Revit 2010 API
StructuralType Enumeration
See Also Send Feedback
Fundamental structural component category.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum StructuralType
Visual Basic (Declaration)
Public Enumeration StructuralType
Visual C++
public enum class StructuralType

Members

Member name | Description
MAX | The value is used to check whether the enum is the same size as the internal one.
UnknownFraming | The structural type of the object is unknow.
Footing | The object is considered to be a footing.
Column | The object is considered too be a column.
Brace | The object is considered to be a brace.
Beam | The object is considered to be a beam.
NonStructural | The object is considered to be non structural in nature.

See Also

Autodesk.Revit.Structural.Enums Namespace


TranslationRotationValue Enumeration

[image]

Revit 2010 API
TranslationRotationValue Enumeration
See Also Send Feedback
Values for BoundaryConditions Translation and Rotation parameters.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum TranslationRotationValue
Visual Basic (Declaration)
Public Enumeration TranslationRotationValue
Visual C++
public enum class TranslationRotationValue

Members

Member name | Description
Spring | TranslationRotationValue is Spring.
Fixed | TranslationRotationValue is Fixed.
Release | TranslationRotationValue is Release.

See Also

Autodesk.Revit.Structural.Enums Namespace


WallUsage Enumeration

[image]

Revit 2010 API
WallUsage Enumeration
See Also Send Feedback
An enumerate type listing all the possible structural usage cases for a Wall object.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum WallUsage
Visual Basic (Declaration)
Public Enumeration WallUsage
Visual C++
public enum class WallUsage

Members

Member name | Description
MAX | The value is used to check whether the enum is the same size as the internal one.
Combined | The wall is subject to combined loads.
Shear | The wall is subject to shear loads.
Bearing | The wall is to be consisdered as load bearing for structural analysis.
NonBearing | The wall is considered non load bearing for structural analysis.

See Also

Autodesk.Revit.Structural.Enums Namespace


Autodesk.Revit.Symbols Namespace

[image]

Revit 2010 API
Autodesk.Revit.Symbols Namespace
Send Feedback

Classes

Class | Description
AnnotationSymbolType | An object that represents an annotation style.
AnnotationSymbolTypeSet | A set that contains AnnotationSymbol types.
AnnotationSymbolTypeSetIterator | An iterator to a AnnotationSymbol type set.
AreaLoadType | An object that represents a Load type.
AreaLoadTypeSet | A set that contains areaload types.
AreaLoadTypeSetIterator | An iterator to a areaload type set.
AreaReinforcementType | An object that specifies the type of a Structural Area Reinforcement element in Autodesk Revit.
AreaTagType | An object that represents an Area Tag style.
AreaTagTypeSet | A set that contains areatag types.
AreaTagTypeSetIterator | An iterator to a areatag type set.
BeamSystemType | An object that specifies the type of a beam system in Autodesk Revit.
BeamSystemTypeSet | A set that contains BeamSystem types.
BeamSystemTypeSetIterator | An iterator to a BeamSystem type set.
ContFootingType | An object that specifies the type of a continuous footing in Autodesk Revit.
ContFootingTypeSet | A set that contains ContFooting types.
ContFootingTypeSetIterator | An iterator to a ContFooting type set.
CurtainSystemType | An object that represents CurtainSystem type.
CurtainSystemTypeSet | A set that contains CurtainSystem types.
CurtainSystemTypeSetIterator | An iterator to a CurtainSystem type set.
DimensionType | An object that represents a dimension style.
DimensionTypeSet | A set that contains dimension types.
DimensionTypeSetIterator | An iterator to a dimension type set.
FamilySymbol | Represents a single Type within a Family.
FamilySymbolSet | A set that can contain family symbols.
FamilySymbolSetIterator | An iterator to a family symbol set.
FasciaType | An object that represents the fascia type in Autodesk Revit.
FasciaTypeSet | A set that contains fascia types.
FasciaTypeSetIterator | An iterator to a fascia type set.
FloorType | An object that specifies the type of a floor in Autodesk Revit.
FloorTypeSet | A set that contains floor types.
FloorTypeSetIterator | An iterator to a floor type set.
GridType | An object that represents a grid type.
GridTypeSet | A set that contains grid types.
GridTypeSetIterator | An iterator to a grid type set.
GroupType | Represents a type of a user defined group.
GutterType | An object that represents the gutter type in Autodesk Revit.
GutterTypeSet | A set that contains gutter types.
GutterTypeSetIterator | An iterator to a gutter type set.
HostedSweepType | An object that represents the attributes for sweep host objects in Autodesk Revit.
HostObjAttributes | An object that represents characteristics of several kinds of type.
InsertableObject | A base class you all types that are insertable.
LevelType | An object that represents a Level type.
LevelTypeSet | A set that contains level types.
LevelTypeSetIterator | An iterator to a level type set.
LineAndTextAttrSymbol | An object that represents a dimension style.
LineLoadType | An object that represents a Load type.
LineLoadTypeSet | A set that contains lineload types.
LineLoadTypeSetIterator | An iterator to a lineload type set.
LoadTypeBase | An object that represents a Load type.
LoadTypeBaseSet | A set that contains load type bases.
LoadTypeBaseSetIterator | An iterator to a load type base set.
MEPBuildingConstruction | Construction definition for Project Information.
MEPBuildingConstructionSet | A set that contains MEPBuildingConstructions.
MEPBuildingConstructionSetIterator | An iterator to a MEPBuildingConstruction set.
ModelTextType | A model text type symbol in the Autodesk Revit Family document.
MullionType | An object that represents a mullion type.
MullionTypeSet | A set that contains mullion types.
MullionTypeSetIterator | An iterator to a mullion type set.
PanelType | An object that represents a curtain panel type.
PanelTypeSet | A set that contains panel types.
PanelTypeSetIterator | An iterator to a panel type set.
PathReinforcementType | An object that specifies the type of a Structural Path Reinforcement element in Autodesk Revit.
PointLoadType | An object that represents a Load type.
PointLoadTypeSet | A set that contains pointload types.
PointLoadTypeSetIterator | An iterator to a pointload type set.
RebarBarType | A Rebar type object that is used in the generation of Rebar.
RebarBarTypeSet | A set that contains RebarBar types.
RebarBarTypeSetIterator | An iterator to a RebarBar type set.
RebarCoverType | A Rebar Cover setting. This element functions as a name-value pair for Rebar Cover Settings.
RebarCoverTypeSet | A set that contains RebarCover types.
RebarCoverTypeSetIterator | An iterator to a RebarCover type set.
RebarHookType | A Rebar Hook type object that is used in the generation of Rebar.
RebarHookTypeSet | A set that contains RebarHook types.
RebarHookTypeSetIterator | An iterator to a RebarHook type set.
RebarShape | RebarShape specifies the shape type for a Rebar instance.
RebarShapeDefinition | A class to assist in defining rebar shapes. A RebarShape element needs exactly one RebarShapeDefinition. The definition object is created by one of the factory methods on RebarShape.
RebarShapeDefinitionByArc | Definition of a shape whose size and position can determined by a single arc.
RebarShapeDefinitionBySegments | Definition of a shape in terms of one or more straight segments of rebar, with arc bends between the segments.
RebarShapeSet | An set that contains rebar shapes.
RebarShapeSetIterator | An iterator to a rebar shape set.
RoofType | Represents a specific type of roof.
RoofTypeSet | A set that contains roof types.
RoofTypeSetIterator | An iterator to a roof type set.
RoomTagType | An object that represents a Room Tag type.
RoomTagTypeSet | A set that contains room tag types.
RoomTagTypeSetIterator | An iterator to a room tag type set.
SlabEdgeType | An object that represents the slab edge type in Autodesk Revit.
SlabEdgeTypeSet | A set that contains slab edge types.
SlabEdgeTypeSetIterator | An iterator to a slab edge type set.
SpaceTagType | An object that represents a Space Tag style.
SpaceTagTypeSet | A set that contains space tag types.
SpaceTagTypeSetIterator | An iterator to a space tag type set.
SpotDimensionType | An object that specifies the type of a spot dimension in Autodesk Revit.
SpotDimensionTypeSet | A set that contains spotdimension types.
SpotDimensionTypeSetIterator | An iterator to a spotdimension type set.
TextElementType | An object that represents a text style.
TextNoteType | An object that represents a text note style.
TextNoteTypeSet | A set that contains textnote types.
TextNoteTypeSetIterator | An iterator to a textnote type set.
TilePattern | An object representing a tile pattern that may be applied to a DividedSurface.
TrussType | Represents a specific type of truss.
TrussTypeSet | A set that contains Truss types.
TrussTypeSetIterator | An iterator to a Truss type set.
WallType | Represents a specific type of wall, such as 'Generic -8" '.
WallTypeSet | A set that contains wall types.
WallTypeSetIterator | An iterator to a wall type set.

Enumerations

Enumeration | Description
WallType..::.WallKind | Describes the fundamental type of wall, such as curtain wall or stacked wall.


AnnotationSymbolType Class

[image]

Revit 2010 API
AnnotationSymbolType Class
Members See Also Send Feedback
An object that represents an annotation style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AnnotationSymbolType : FamilySymbol
Visual Basic (Declaration)
Public Class AnnotationSymbolType _
    Inherits FamilySymbol
Visual C++
public ref class AnnotationSymbolType : public FamilySymbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.InsertableObject
Autodesk.Revit.Symbols..::.FamilySymbol
Autodesk.Revit.Symbols..::.AnnotationSymbolType

See Also

AnnotationSymbolType Members
Autodesk.Revit.Symbols Namespace


AnnotationSymbolType Members

[image] [image]

Revit 2010 API
AnnotationSymbolType Members
AnnotationSymbolType Class Constructors Methods Properties See Also Send Feedback

The AnnotationSymbolType type exposes the following members.

Constructors

Name | Description
AnnotationSymbolType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Material | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AnnotationSymbolType Class
Autodesk.Revit.Symbols Namespace


AnnotationSymbolType Constructor

[image]

Revit 2010 API
AnnotationSymbolType Constructor
AnnotationSymbolType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnnotationSymbolType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnnotationSymbolType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnnotationSymbolType Class
Autodesk.Revit.Symbols Namespace


AnnotationSymbolType Methods

[image] [image]

Revit 2010 API
AnnotationSymbolType Methods
AnnotationSymbolType Class See Also Send Feedback

The AnnotationSymbolType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnnotationSymbolType Class
Autodesk.Revit.Symbols Namespace


AnnotationSymbolType Properties

[image] [image]

Revit 2010 API
AnnotationSymbolType Properties
AnnotationSymbolType Class See Also Send Feedback

The AnnotationSymbolType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Material | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AnnotationSymbolType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
AnnotationSymbolType..::.Parameter Property
AnnotationSymbolType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AnnotationSymbolType Class
AnnotationSymbolType Members
Autodesk.Revit.Symbols Namespace


AnnotationSymbolTypeSet Class

[image]

Revit 2010 API
AnnotationSymbolTypeSet Class
Members See Also Send Feedback
A set that contains AnnotationSymbol types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AnnotationSymbolTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class AnnotationSymbolTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class AnnotationSymbolTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.AnnotationSymbolTypeSet

See Also

AnnotationSymbolTypeSet Members
Autodesk.Revit.Symbols Namespace


AnnotationSymbolTypeSet Members

[image] [image]

Revit 2010 API
AnnotationSymbolTypeSet Members
AnnotationSymbolTypeSet Class Constructors Methods Properties See Also Send Feedback

The AnnotationSymbolTypeSet type exposes the following members.

Constructors

Name | Description
AnnotationSymbolTypeSet | Initializes a new instance of the AnnotationSymbolTypeSet class

Methods

Name | Description
Clear | Removes every AnnotationSymbol type from the set, rendering it empty.
Contains | Tests for the existence of a AnnotationSymbol type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified AnnotationSymbol type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified AnnotationSymbol type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of AnnotationSymbol types that are in the set.

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


AnnotationSymbolTypeSet Constructor

[image]

Revit 2010 API
AnnotationSymbolTypeSet Constructor
AnnotationSymbolTypeSet Class See Also Send Feedback
Initializes a new instance of the AnnotationSymbolTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnnotationSymbolTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnnotationSymbolTypeSet()

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


AnnotationSymbolTypeSet Methods

[image] [image]

Revit 2010 API
AnnotationSymbolTypeSet Methods
AnnotationSymbolTypeSet Class See Also Send Feedback

The AnnotationSymbolTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every AnnotationSymbol type from the set, rendering it empty.
Contains | Tests for the existence of a AnnotationSymbol type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified AnnotationSymbol type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified AnnotationSymbol type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
AnnotationSymbolTypeSet..::.Clear Method
AnnotationSymbolTypeSet Class See Also Send Feedback
Removes every AnnotationSymbol type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
AnnotationSymbolTypeSet..::.Contains Method
AnnotationSymbolTypeSet Class See Also Send Feedback
Tests for the existence of a AnnotationSymbol type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    AnnotationSymbolType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As AnnotationSymbolType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    AnnotationSymbolType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.AnnotationSymbolType
The AnnotationSymbol type to be searched for.

Return Value

The Contains method returns True if the AnnotationSymbol type is within the set, otherwise False.

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
AnnotationSymbolTypeSet..::.Erase Method
AnnotationSymbolTypeSet Class See Also Send Feedback
Removes a specified AnnotationSymbol type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    AnnotationSymbolType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As AnnotationSymbolType _
) As Integer
Visual C++
public:
virtual int Erase(
    AnnotationSymbolType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.AnnotationSymbolType
The AnnotationSymbol type to be erased.

Return Value

The number of AnnotationSymbol types that were erased from the set.

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
AnnotationSymbolTypeSet..::.ForwardIterator Method
AnnotationSymbolTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual AnnotationSymbolTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As AnnotationSymbolTypeSetIterator
Visual C++
public:
virtual AnnotationSymbolTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
AnnotationSymbolTypeSet..::.GetEnumerator Method
AnnotationSymbolTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
AnnotationSymbolTypeSet..::.Insert Method
AnnotationSymbolTypeSet Class See Also Send Feedback
Insert the specified AnnotationSymbol type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    AnnotationSymbolType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As AnnotationSymbolType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    AnnotationSymbolType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.AnnotationSymbolType
The AnnotationSymbol type to be inserted into the set.

Return Value

Returns whether the AnnotationSymbol type was inserted into the set.

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
AnnotationSymbolTypeSet..::.ReverseIterator Method
AnnotationSymbolTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual AnnotationSymbolTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As AnnotationSymbolTypeSetIterator
Visual C++
public:
virtual AnnotationSymbolTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


AnnotationSymbolTypeSet Properties

[image] [image]

Revit 2010 API
AnnotationSymbolTypeSet Properties
AnnotationSymbolTypeSet Class See Also Send Feedback

The AnnotationSymbolTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of AnnotationSymbol types that are in the set.

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
AnnotationSymbolTypeSet..::.IsEmpty Property
AnnotationSymbolTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
AnnotationSymbolTypeSet..::.Size Property
AnnotationSymbolTypeSet Class See Also Send Feedback
Returns the number of AnnotationSymbol types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

AnnotationSymbolTypeSet Class
Autodesk.Revit.Symbols Namespace


AnnotationSymbolTypeSetIterator Class

[image]

Revit 2010 API
AnnotationSymbolTypeSetIterator Class
Members See Also Send Feedback
An iterator to a AnnotationSymbol type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class AnnotationSymbolTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class AnnotationSymbolTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class AnnotationSymbolTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.AnnotationSymbolTypeSetIterator

See Also

AnnotationSymbolTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


AnnotationSymbolTypeSetIterator Members

[image] [image]

Revit 2010 API
AnnotationSymbolTypeSetIterator Members
AnnotationSymbolTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The AnnotationSymbolTypeSetIterator type exposes the following members.

Constructors

Name | Description
AnnotationSymbolTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AnnotationSymbolTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


AnnotationSymbolTypeSetIterator Constructor

[image]

Revit 2010 API
AnnotationSymbolTypeSetIterator Constructor
AnnotationSymbolTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnnotationSymbolTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnnotationSymbolTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnnotationSymbolTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


AnnotationSymbolTypeSetIterator Methods

[image] [image]

Revit 2010 API
AnnotationSymbolTypeSetIterator Methods
AnnotationSymbolTypeSetIterator Class See Also Send Feedback

The AnnotationSymbolTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnnotationSymbolTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
AnnotationSymbolTypeSetIterator..::.MoveNext Method
AnnotationSymbolTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

AnnotationSymbolTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
AnnotationSymbolTypeSetIterator..::.Reset Method
AnnotationSymbolTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

AnnotationSymbolTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


AnnotationSymbolTypeSetIterator Properties

[image] [image]

Revit 2010 API
AnnotationSymbolTypeSetIterator Properties
AnnotationSymbolTypeSetIterator Class See Also Send Feedback

The AnnotationSymbolTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AnnotationSymbolTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
AnnotationSymbolTypeSetIterator..::.Current Property
AnnotationSymbolTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

AnnotationSymbolTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


AreaLoadType Class

[image]

Revit 2010 API
AreaLoadType Class
Members See Also Send Feedback
An object that represents a Load type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AreaLoadType : LoadTypeBase
Visual Basic (Declaration)
Public Class AreaLoadType _
    Inherits LoadTypeBase
Visual C++
public ref class AreaLoadType : public LoadTypeBase

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.LoadTypeBase
Autodesk.Revit.Symbols..::.AreaLoadType

See Also

AreaLoadType Members
Autodesk.Revit.Symbols Namespace


AreaLoadType Members

[image] [image]

Revit 2010 API
AreaLoadType Members
AreaLoadType Class Constructors Methods Properties See Also Send Feedback

The AreaLoadType type exposes the following members.

Constructors

Name | Description
AreaLoadType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaLoadType Class
Autodesk.Revit.Symbols Namespace


AreaLoadType Constructor

[image]

Revit 2010 API
AreaLoadType Constructor
AreaLoadType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaLoadType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaLoadType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaLoadType Class
Autodesk.Revit.Symbols Namespace


AreaLoadType Methods

[image] [image]

Revit 2010 API
AreaLoadType Methods
AreaLoadType Class See Also Send Feedback

The AreaLoadType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaLoadType Class
Autodesk.Revit.Symbols Namespace


AreaLoadType Properties

[image] [image]

Revit 2010 API
AreaLoadType Properties
AreaLoadType Class See Also Send Feedback

The AreaLoadType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaLoadType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
AreaLoadType..::.Parameter Property
AreaLoadType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AreaLoadType Class
AreaLoadType Members
Autodesk.Revit.Symbols Namespace


AreaLoadTypeSet Class

[image]

Revit 2010 API
AreaLoadTypeSet Class
Members See Also Send Feedback
A set that contains areaload types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AreaLoadTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class AreaLoadTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class AreaLoadTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.AreaLoadTypeSet

See Also

AreaLoadTypeSet Members
Autodesk.Revit.Symbols Namespace


AreaLoadTypeSet Members

[image] [image]

Revit 2010 API
AreaLoadTypeSet Members
AreaLoadTypeSet Class Constructors Methods Properties See Also Send Feedback

The AreaLoadTypeSet type exposes the following members.

Constructors

Name | Description
AreaLoadTypeSet | Initializes a new instance of the AreaLoadTypeSet class

Methods

Name | Description
Clear | Removes every areaload type from the set, rendering it empty.
Contains | Tests for the existence of a areaload type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified areaload type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified areaload type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of areaload types that are in the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


AreaLoadTypeSet Constructor

[image]

Revit 2010 API
AreaLoadTypeSet Constructor
AreaLoadTypeSet Class See Also Send Feedback
Initializes a new instance of the AreaLoadTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaLoadTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaLoadTypeSet()

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


AreaLoadTypeSet Methods

[image] [image]

Revit 2010 API
AreaLoadTypeSet Methods
AreaLoadTypeSet Class See Also Send Feedback

The AreaLoadTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every areaload type from the set, rendering it empty.
Contains | Tests for the existence of a areaload type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified areaload type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified areaload type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
AreaLoadTypeSet..::.Clear Method
AreaLoadTypeSet Class See Also Send Feedback
Removes every areaload type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
AreaLoadTypeSet..::.Contains Method
AreaLoadTypeSet Class See Also Send Feedback
Tests for the existence of a areaload type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    AreaLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As AreaLoadType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    AreaLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.AreaLoadType
The areaload type to be searched for.

Return Value

The Contains method returns True if the areaload type is within the set, otherwise False.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
AreaLoadTypeSet..::.Erase Method
AreaLoadTypeSet Class See Also Send Feedback
Removes a specified areaload type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    AreaLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As AreaLoadType _
) As Integer
Visual C++
public:
virtual int Erase(
    AreaLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.AreaLoadType
The areaload type to be erased.

Return Value

The number of areaload types that were erased from the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
AreaLoadTypeSet..::.ForwardIterator Method
AreaLoadTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual AreaLoadTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As AreaLoadTypeSetIterator
Visual C++
public:
virtual AreaLoadTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
AreaLoadTypeSet..::.GetEnumerator Method
AreaLoadTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
AreaLoadTypeSet..::.Insert Method
AreaLoadTypeSet Class See Also Send Feedback
Insert the specified areaload type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    AreaLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As AreaLoadType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    AreaLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.AreaLoadType
The areaload type to be inserted into the set.

Return Value

Returns whether the areaload type was inserted into the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
AreaLoadTypeSet..::.ReverseIterator Method
AreaLoadTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual AreaLoadTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As AreaLoadTypeSetIterator
Visual C++
public:
virtual AreaLoadTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


AreaLoadTypeSet Properties

[image] [image]

Revit 2010 API
AreaLoadTypeSet Properties
AreaLoadTypeSet Class See Also Send Feedback

The AreaLoadTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of areaload types that are in the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
AreaLoadTypeSet..::.IsEmpty Property
AreaLoadTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
AreaLoadTypeSet..::.Size Property
AreaLoadTypeSet Class See Also Send Feedback
Returns the number of areaload types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

AreaLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


AreaLoadTypeSetIterator Class

[image]

Revit 2010 API
AreaLoadTypeSetIterator Class
Members See Also Send Feedback
An iterator to a areaload type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class AreaLoadTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class AreaLoadTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class AreaLoadTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.AreaLoadTypeSetIterator

See Also

AreaLoadTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


AreaLoadTypeSetIterator Members

[image] [image]

Revit 2010 API
AreaLoadTypeSetIterator Members
AreaLoadTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The AreaLoadTypeSetIterator type exposes the following members.

Constructors

Name | Description
AreaLoadTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


AreaLoadTypeSetIterator Constructor

[image]

Revit 2010 API
AreaLoadTypeSetIterator Constructor
AreaLoadTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaLoadTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaLoadTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


AreaLoadTypeSetIterator Methods

[image] [image]

Revit 2010 API
AreaLoadTypeSetIterator Methods
AreaLoadTypeSetIterator Class See Also Send Feedback

The AreaLoadTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
AreaLoadTypeSetIterator..::.MoveNext Method
AreaLoadTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
AreaLoadTypeSetIterator..::.Reset Method
AreaLoadTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


AreaLoadTypeSetIterator Properties

[image] [image]

Revit 2010 API
AreaLoadTypeSetIterator Properties
AreaLoadTypeSetIterator Class See Also Send Feedback

The AreaLoadTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
AreaLoadTypeSetIterator..::.Current Property
AreaLoadTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


AreaReinforcementType Class

[image]

Revit 2010 API
AreaReinforcementType Class
Members See Also Send Feedback
An object that specifies the type of a Structural Area Reinforcement element in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AreaReinforcementType : Symbol
Visual Basic (Declaration)
Public Class AreaReinforcementType _
    Inherits Symbol
Visual C++
public ref class AreaReinforcementType : public Symbol

Remarks

The clear cover settings can be accessed via this object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.AreaReinforcementType

See Also

AreaReinforcementType Members
Autodesk.Revit.Symbols Namespace


AreaReinforcementType Members

[image] [image]

Revit 2010 API
AreaReinforcementType Members
AreaReinforcementType Class Constructors Methods Properties See Also Send Feedback

The AreaReinforcementType type exposes the following members.

Constructors

Name | Description
AreaReinforcementType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaReinforcementType Class
Autodesk.Revit.Symbols Namespace


AreaReinforcementType Constructor

[image]

Revit 2010 API
AreaReinforcementType Constructor
AreaReinforcementType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaReinforcementType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaReinforcementType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaReinforcementType Class
Autodesk.Revit.Symbols Namespace


AreaReinforcementType Methods

[image] [image]

Revit 2010 API
AreaReinforcementType Methods
AreaReinforcementType Class See Also Send Feedback

The AreaReinforcementType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaReinforcementType Class
Autodesk.Revit.Symbols Namespace


AreaReinforcementType Properties

[image] [image]

Revit 2010 API
AreaReinforcementType Properties
AreaReinforcementType Class See Also Send Feedback

The AreaReinforcementType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaReinforcementType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
AreaReinforcementType..::.Parameter Property
AreaReinforcementType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AreaReinforcementType Class
AreaReinforcementType Members
Autodesk.Revit.Symbols Namespace


AreaTagType Class

[image]

Revit 2010 API
AreaTagType Class
Members See Also Send Feedback
An object that represents an Area Tag style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AreaTagType : FamilySymbol
Visual Basic (Declaration)
Public Class AreaTagType _
    Inherits FamilySymbol
Visual C++
public ref class AreaTagType : public FamilySymbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.InsertableObject
Autodesk.Revit.Symbols..::.FamilySymbol
Autodesk.Revit.Symbols..::.AreaTagType

See Also

AreaTagType Members
Autodesk.Revit.Symbols Namespace


AreaTagType Members

[image] [image]

Revit 2010 API
AreaTagType Members
AreaTagType Class Constructors Methods Properties See Also Send Feedback

The AreaTagType type exposes the following members.

Constructors

Name | Description
AreaTagType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Material | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaTagType Class
Autodesk.Revit.Symbols Namespace


AreaTagType Constructor

[image]

Revit 2010 API
AreaTagType Constructor
AreaTagType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaTagType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaTagType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaTagType Class
Autodesk.Revit.Symbols Namespace


AreaTagType Methods

[image] [image]

Revit 2010 API
AreaTagType Methods
AreaTagType Class See Also Send Feedback

The AreaTagType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaTagType Class
Autodesk.Revit.Symbols Namespace


AreaTagType Properties

[image] [image]

Revit 2010 API
AreaTagType Properties
AreaTagType Class See Also Send Feedback

The AreaTagType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Material | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

AreaTagType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
AreaTagType..::.Parameter Property
AreaTagType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AreaTagType Class
AreaTagType Members
Autodesk.Revit.Symbols Namespace


AreaTagTypeSet Class

[image]

Revit 2010 API
AreaTagTypeSet Class
Members See Also Send Feedback
A set that contains areatag types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AreaTagTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class AreaTagTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class AreaTagTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.AreaTagTypeSet

See Also

AreaTagTypeSet Members
Autodesk.Revit.Symbols Namespace


AreaTagTypeSet Members

[image] [image]

Revit 2010 API
AreaTagTypeSet Members
AreaTagTypeSet Class Constructors Methods Properties See Also Send Feedback

The AreaTagTypeSet type exposes the following members.

Constructors

Name | Description
AreaTagTypeSet | Initializes a new instance of the AreaTagTypeSet class

Methods

Name | Description
Clear | Removes every areatag type from the set, rendering it empty.
Contains | Tests for the existence of a areatag type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified areatag type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified areatag type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of areatag types that are in the set.

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


AreaTagTypeSet Constructor

[image]

Revit 2010 API
AreaTagTypeSet Constructor
AreaTagTypeSet Class See Also Send Feedback
Initializes a new instance of the AreaTagTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaTagTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaTagTypeSet()

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


AreaTagTypeSet Methods

[image] [image]

Revit 2010 API
AreaTagTypeSet Methods
AreaTagTypeSet Class See Also Send Feedback

The AreaTagTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every areatag type from the set, rendering it empty.
Contains | Tests for the existence of a areatag type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified areatag type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified areatag type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
AreaTagTypeSet..::.Clear Method
AreaTagTypeSet Class See Also Send Feedback
Removes every areatag type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
AreaTagTypeSet..::.Contains Method
AreaTagTypeSet Class See Also Send Feedback
Tests for the existence of a areatag type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    AreaTagType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As AreaTagType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    AreaTagType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.AreaTagType
The areatag type to be searched for.

Return Value

The Contains method returns True if the areatag type is within the set, otherwise False.

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
AreaTagTypeSet..::.Erase Method
AreaTagTypeSet Class See Also Send Feedback
Removes a specified areatag type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    AreaTagType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As AreaTagType _
) As Integer
Visual C++
public:
virtual int Erase(
    AreaTagType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.AreaTagType
The areatag type to be erased.

Return Value

The number of areatag types that were erased from the set.

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
AreaTagTypeSet..::.ForwardIterator Method
AreaTagTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual AreaTagTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As AreaTagTypeSetIterator
Visual C++
public:
virtual AreaTagTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
AreaTagTypeSet..::.GetEnumerator Method
AreaTagTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
AreaTagTypeSet..::.Insert Method
AreaTagTypeSet Class See Also Send Feedback
Insert the specified areatag type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    AreaTagType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As AreaTagType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    AreaTagType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.AreaTagType
The areatag type to be inserted into the set.

Return Value

Returns whether the areatag type was inserted into the set.

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
AreaTagTypeSet..::.ReverseIterator Method
AreaTagTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual AreaTagTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As AreaTagTypeSetIterator
Visual C++
public:
virtual AreaTagTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


AreaTagTypeSet Properties

[image] [image]

Revit 2010 API
AreaTagTypeSet Properties
AreaTagTypeSet Class See Also Send Feedback

The AreaTagTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of areatag types that are in the set.

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
AreaTagTypeSet..::.IsEmpty Property
AreaTagTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
AreaTagTypeSet..::.Size Property
AreaTagTypeSet Class See Also Send Feedback
Returns the number of areatag types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

AreaTagTypeSet Class
Autodesk.Revit.Symbols Namespace


AreaTagTypeSetIterator Class

[image]

Revit 2010 API
AreaTagTypeSetIterator Class
Members See Also Send Feedback
An iterator to a areatag type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class AreaTagTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class AreaTagTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class AreaTagTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.AreaTagTypeSetIterator

See Also

AreaTagTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


AreaTagTypeSetIterator Members

[image] [image]

Revit 2010 API
AreaTagTypeSetIterator Members
AreaTagTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The AreaTagTypeSetIterator type exposes the following members.

Constructors

Name | Description
AreaTagTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AreaTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


AreaTagTypeSetIterator Constructor

[image]

Revit 2010 API
AreaTagTypeSetIterator Constructor
AreaTagTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaTagTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaTagTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


AreaTagTypeSetIterator Methods

[image] [image]

Revit 2010 API
AreaTagTypeSetIterator Methods
AreaTagTypeSetIterator Class See Also Send Feedback

The AreaTagTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
AreaTagTypeSetIterator..::.MoveNext Method
AreaTagTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

AreaTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
AreaTagTypeSetIterator..::.Reset Method
AreaTagTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

AreaTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


AreaTagTypeSetIterator Properties

[image] [image]

Revit 2010 API
AreaTagTypeSetIterator Properties
AreaTagTypeSetIterator Class See Also Send Feedback

The AreaTagTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AreaTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
AreaTagTypeSetIterator..::.Current Property
AreaTagTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

AreaTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


BeamSystemType Class

[image]

Revit 2010 API
BeamSystemType Class
Members See Also Send Feedback
An object that specifies the type of a beam system in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BeamSystemType : Symbol
Visual Basic (Declaration)
Public Class BeamSystemType _
    Inherits Symbol
Visual C++
public ref class BeamSystemType : public Symbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.BeamSystemType

See Also

BeamSystemType Members
Autodesk.Revit.Symbols Namespace


BeamSystemType Members

[image] [image]

Revit 2010 API
BeamSystemType Members
BeamSystemType Class Constructors Methods Properties See Also Send Feedback

The BeamSystemType type exposes the following members.

Constructors

Name | Description
BeamSystemType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

BeamSystemType Class
Autodesk.Revit.Symbols Namespace


BeamSystemType Constructor

[image]

Revit 2010 API
BeamSystemType Constructor
BeamSystemType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BeamSystemType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamSystemType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BeamSystemType Class
Autodesk.Revit.Symbols Namespace


BeamSystemType Methods

[image] [image]

Revit 2010 API
BeamSystemType Methods
BeamSystemType Class See Also Send Feedback

The BeamSystemType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSystemType Class
Autodesk.Revit.Symbols Namespace


BeamSystemType Properties

[image] [image]

Revit 2010 API
BeamSystemType Properties
BeamSystemType Class See Also Send Feedback

The BeamSystemType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

BeamSystemType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
BeamSystemType..::.Parameter Property
BeamSystemType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

BeamSystemType Class
BeamSystemType Members
Autodesk.Revit.Symbols Namespace


BeamSystemTypeSet Class

[image]

Revit 2010 API
BeamSystemTypeSet Class
Members See Also Send Feedback
A set that contains BeamSystem types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BeamSystemTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class BeamSystemTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class BeamSystemTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.BeamSystemTypeSet

See Also

BeamSystemTypeSet Members
Autodesk.Revit.Symbols Namespace


BeamSystemTypeSet Members

[image] [image]

Revit 2010 API
BeamSystemTypeSet Members
BeamSystemTypeSet Class Constructors Methods Properties See Also Send Feedback

The BeamSystemTypeSet type exposes the following members.

Constructors

Name | Description
BeamSystemTypeSet | Initializes a new instance of the BeamSystemTypeSet class

Methods

Name | Description
Clear | Removes every BeamSystem type from the set, rendering it empty.
Contains | Tests for the existence of a BeamSystem type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified BeamSystem type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified BeamSystem type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of BeamSystem types that are in the set.

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


BeamSystemTypeSet Constructor

[image]

Revit 2010 API
BeamSystemTypeSet Constructor
BeamSystemTypeSet Class See Also Send Feedback
Initializes a new instance of the BeamSystemTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BeamSystemTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamSystemTypeSet()

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


BeamSystemTypeSet Methods

[image] [image]

Revit 2010 API
BeamSystemTypeSet Methods
BeamSystemTypeSet Class See Also Send Feedback

The BeamSystemTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every BeamSystem type from the set, rendering it empty.
Contains | Tests for the existence of a BeamSystem type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified BeamSystem type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified BeamSystem type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
BeamSystemTypeSet..::.Clear Method
BeamSystemTypeSet Class See Also Send Feedback
Removes every BeamSystem type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
BeamSystemTypeSet..::.Contains Method
BeamSystemTypeSet Class See Also Send Feedback
Tests for the existence of a BeamSystem type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    BeamSystemType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As BeamSystemType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    BeamSystemType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.BeamSystemType
The BeamSystem type to be searched for.

Return Value

The Contains method returns True if the BeamSystem type is within the set, otherwise False.

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
BeamSystemTypeSet..::.Erase Method
BeamSystemTypeSet Class See Also Send Feedback
Removes a specified BeamSystem type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    BeamSystemType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As BeamSystemType _
) As Integer
Visual C++
public:
virtual int Erase(
    BeamSystemType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.BeamSystemType
The BeamSystem type to be erased.

Return Value

The number of BeamSystem types that were erased from the set.

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
BeamSystemTypeSet..::.ForwardIterator Method
BeamSystemTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual BeamSystemTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As BeamSystemTypeSetIterator
Visual C++
public:
virtual BeamSystemTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
BeamSystemTypeSet..::.GetEnumerator Method
BeamSystemTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
BeamSystemTypeSet..::.Insert Method
BeamSystemTypeSet Class See Also Send Feedback
Insert the specified BeamSystem type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    BeamSystemType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As BeamSystemType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    BeamSystemType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.BeamSystemType
The BeamSystem type to be inserted into the set.

Return Value

Returns whether the BeamSystem type was inserted into the set.

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
BeamSystemTypeSet..::.ReverseIterator Method
BeamSystemTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual BeamSystemTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As BeamSystemTypeSetIterator
Visual C++
public:
virtual BeamSystemTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


BeamSystemTypeSet Properties

[image] [image]

Revit 2010 API
BeamSystemTypeSet Properties
BeamSystemTypeSet Class See Also Send Feedback

The BeamSystemTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of BeamSystem types that are in the set.

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
BeamSystemTypeSet..::.IsEmpty Property
BeamSystemTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
BeamSystemTypeSet..::.Size Property
BeamSystemTypeSet Class See Also Send Feedback
Returns the number of BeamSystem types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


BeamSystemTypeSetIterator Class

[image]

Revit 2010 API
BeamSystemTypeSetIterator Class
Members See Also Send Feedback
An iterator to a BeamSystem type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class BeamSystemTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class BeamSystemTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class BeamSystemTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.BeamSystemTypeSetIterator

See Also

BeamSystemTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


BeamSystemTypeSetIterator Members

[image] [image]

Revit 2010 API
BeamSystemTypeSetIterator Members
BeamSystemTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The BeamSystemTypeSetIterator type exposes the following members.

Constructors

Name | Description
BeamSystemTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BeamSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


BeamSystemTypeSetIterator Constructor

[image]

Revit 2010 API
BeamSystemTypeSetIterator Constructor
BeamSystemTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BeamSystemTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamSystemTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BeamSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


BeamSystemTypeSetIterator Methods

[image] [image]

Revit 2010 API
BeamSystemTypeSetIterator Methods
BeamSystemTypeSetIterator Class See Also Send Feedback

The BeamSystemTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
BeamSystemTypeSetIterator..::.MoveNext Method
BeamSystemTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BeamSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
BeamSystemTypeSetIterator..::.Reset Method
BeamSystemTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BeamSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


BeamSystemTypeSetIterator Properties

[image] [image]

Revit 2010 API
BeamSystemTypeSetIterator Properties
BeamSystemTypeSetIterator Class See Also Send Feedback

The BeamSystemTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BeamSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
BeamSystemTypeSetIterator..::.Current Property
BeamSystemTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BeamSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ContFootingType Class

[image]

Revit 2010 API
ContFootingType Class
Members See Also Send Feedback
An object that specifies the type of a continuous footing in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ContFootingType : HostObjAttributes
Visual Basic (Declaration)
Public Class ContFootingType _
    Inherits HostObjAttributes
Visual C++
public ref class ContFootingType : public HostObjAttributes

Remarks

The structural layers of the continuous footing can be accessed via this object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.HostObjAttributes
Autodesk.Revit.Symbols..::.ContFootingType

See Also

ContFootingType Members
Autodesk.Revit.Symbols Namespace


ContFootingType Members

[image] [image]

Revit 2010 API
ContFootingType Members
ContFootingType Class Constructors Methods Properties See Also Send Feedback

The ContFootingType type exposes the following members.

Constructors

Name | Description
ContFootingType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ContFootingType Class
Autodesk.Revit.Symbols Namespace


ContFootingType Constructor

[image]

Revit 2010 API
ContFootingType Constructor
ContFootingType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ContFootingType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ContFootingType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ContFootingType Class
Autodesk.Revit.Symbols Namespace


ContFootingType Methods

[image] [image]

Revit 2010 API
ContFootingType Methods
ContFootingType Class See Also Send Feedback

The ContFootingType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContFootingType Class
Autodesk.Revit.Symbols Namespace


ContFootingType Properties

[image] [image]

Revit 2010 API
ContFootingType Properties
ContFootingType Class See Also Send Feedback

The ContFootingType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ContFootingType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
ContFootingType..::.Parameter Property
ContFootingType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ContFootingType Class
ContFootingType Members
Autodesk.Revit.Symbols Namespace


ContFootingTypeSet Class

[image]

Revit 2010 API
ContFootingTypeSet Class
Members See Also Send Feedback
A set that contains ContFooting types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ContFootingTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ContFootingTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ContFootingTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.ContFootingTypeSet

See Also

ContFootingTypeSet Members
Autodesk.Revit.Symbols Namespace


ContFootingTypeSet Members

[image] [image]

Revit 2010 API
ContFootingTypeSet Members
ContFootingTypeSet Class Constructors Methods Properties See Also Send Feedback

The ContFootingTypeSet type exposes the following members.

Constructors

Name | Description
ContFootingTypeSet | Initializes a new instance of the ContFootingTypeSet class

Methods

Name | Description
Clear | Removes every ContFooting type from the set, rendering it empty.
Contains | Tests for the existence of a ContFooting type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified ContFooting type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified ContFooting type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of ContFooting types that are in the set.

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


ContFootingTypeSet Constructor

[image]

Revit 2010 API
ContFootingTypeSet Constructor
ContFootingTypeSet Class See Also Send Feedback
Initializes a new instance of the ContFootingTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ContFootingTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ContFootingTypeSet()

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


ContFootingTypeSet Methods

[image] [image]

Revit 2010 API
ContFootingTypeSet Methods
ContFootingTypeSet Class See Also Send Feedback

The ContFootingTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every ContFooting type from the set, rendering it empty.
Contains | Tests for the existence of a ContFooting type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified ContFooting type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified ContFooting type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
ContFootingTypeSet..::.Clear Method
ContFootingTypeSet Class See Also Send Feedback
Removes every ContFooting type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
ContFootingTypeSet..::.Contains Method
ContFootingTypeSet Class See Also Send Feedback
Tests for the existence of a ContFooting type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    ContFootingType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As ContFootingType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    ContFootingType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.ContFootingType
The ContFooting type to be searched for.

Return Value

The Contains method returns True if the ContFooting type is within the set, otherwise False.

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
ContFootingTypeSet..::.Erase Method
ContFootingTypeSet Class See Also Send Feedback
Removes a specified ContFooting type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    ContFootingType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As ContFootingType _
) As Integer
Visual C++
public:
virtual int Erase(
    ContFootingType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.ContFootingType
The ContFooting type to be erased.

Return Value

The number of ContFooting types that were erased from the set.

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
ContFootingTypeSet..::.ForwardIterator Method
ContFootingTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ContFootingTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ContFootingTypeSetIterator
Visual C++
public:
virtual ContFootingTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
ContFootingTypeSet..::.GetEnumerator Method
ContFootingTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
ContFootingTypeSet..::.Insert Method
ContFootingTypeSet Class See Also Send Feedback
Insert the specified ContFooting type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    ContFootingType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As ContFootingType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    ContFootingType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.ContFootingType
The ContFooting type to be inserted into the set.

Return Value

Returns whether the ContFooting type was inserted into the set.

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
ContFootingTypeSet..::.ReverseIterator Method
ContFootingTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ContFootingTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ContFootingTypeSetIterator
Visual C++
public:
virtual ContFootingTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


ContFootingTypeSet Properties

[image] [image]

Revit 2010 API
ContFootingTypeSet Properties
ContFootingTypeSet Class See Also Send Feedback

The ContFootingTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of ContFooting types that are in the set.

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
ContFootingTypeSet..::.IsEmpty Property
ContFootingTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
ContFootingTypeSet..::.Size Property
ContFootingTypeSet Class See Also Send Feedback
Returns the number of ContFooting types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ContFootingTypeSet Class
Autodesk.Revit.Symbols Namespace


ContFootingTypeSetIterator Class

[image]

Revit 2010 API
ContFootingTypeSetIterator Class
Members See Also Send Feedback
An iterator to a ContFooting type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ContFootingTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ContFootingTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ContFootingTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.ContFootingTypeSetIterator

See Also

ContFootingTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


ContFootingTypeSetIterator Members

[image] [image]

Revit 2010 API
ContFootingTypeSetIterator Members
ContFootingTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The ContFootingTypeSetIterator type exposes the following members.

Constructors

Name | Description
ContFootingTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ContFootingTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ContFootingTypeSetIterator Constructor

[image]

Revit 2010 API
ContFootingTypeSetIterator Constructor
ContFootingTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ContFootingTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ContFootingTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ContFootingTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ContFootingTypeSetIterator Methods

[image] [image]

Revit 2010 API
ContFootingTypeSetIterator Methods
ContFootingTypeSetIterator Class See Also Send Feedback

The ContFootingTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContFootingTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
ContFootingTypeSetIterator..::.MoveNext Method
ContFootingTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ContFootingTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
ContFootingTypeSetIterator..::.Reset Method
ContFootingTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ContFootingTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


ContFootingTypeSetIterator Properties

[image] [image]

Revit 2010 API
ContFootingTypeSetIterator Properties
ContFootingTypeSetIterator Class See Also Send Feedback

The ContFootingTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ContFootingTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
ContFootingTypeSetIterator..::.Current Property
ContFootingTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ContFootingTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


CurtainSystemType Class

[image]

Revit 2010 API
CurtainSystemType Class
Members See Also Send Feedback
An object that represents CurtainSystem type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CurtainSystemType : HostObjAttributes
Visual Basic (Declaration)
Public Class CurtainSystemType _
    Inherits HostObjAttributes
Visual C++
public ref class CurtainSystemType : public HostObjAttributes

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.HostObjAttributes
Autodesk.Revit.Symbols..::.CurtainSystemType

See Also

CurtainSystemType Members
Autodesk.Revit.Symbols Namespace


CurtainSystemType Members

[image] [image]

Revit 2010 API
CurtainSystemType Members
CurtainSystemType Class Constructors Methods Properties See Also Send Feedback

The CurtainSystemType type exposes the following members.

Constructors

Name | Description
CurtainSystemType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CurtainSystemType Class
Autodesk.Revit.Symbols Namespace


CurtainSystemType Constructor

[image]

Revit 2010 API
CurtainSystemType Constructor
CurtainSystemType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainSystemType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainSystemType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainSystemType Class
Autodesk.Revit.Symbols Namespace


CurtainSystemType Methods

[image] [image]

Revit 2010 API
CurtainSystemType Methods
CurtainSystemType Class See Also Send Feedback

The CurtainSystemType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainSystemType Class
Autodesk.Revit.Symbols Namespace


CurtainSystemType Properties

[image] [image]

Revit 2010 API
CurtainSystemType Properties
CurtainSystemType Class See Also Send Feedback

The CurtainSystemType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

CurtainSystemType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
CurtainSystemType..::.Parameter Property
CurtainSystemType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

CurtainSystemType Class
CurtainSystemType Members
Autodesk.Revit.Symbols Namespace


CurtainSystemTypeSet Class

[image]

Revit 2010 API
CurtainSystemTypeSet Class
Members See Also Send Feedback
A set that contains CurtainSystem types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CurtainSystemTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class CurtainSystemTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurtainSystemTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.CurtainSystemTypeSet

See Also

CurtainSystemTypeSet Members
Autodesk.Revit.Symbols Namespace


CurtainSystemTypeSet Members

[image] [image]

Revit 2010 API
CurtainSystemTypeSet Members
CurtainSystemTypeSet Class Constructors Methods Properties See Also Send Feedback

The CurtainSystemTypeSet type exposes the following members.

Constructors

Name | Description
CurtainSystemTypeSet | Initializes a new instance of the CurtainSystemTypeSet class

Methods

Name | Description
Clear | Removes every CurtainSystem type from the set, rendering it empty.
Contains | Tests for the existence of a CurtainSystem type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified CurtainSystem type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified CurtainSystem type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of CurtainSystem types that are in the set.

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


CurtainSystemTypeSet Constructor

[image]

Revit 2010 API
CurtainSystemTypeSet Constructor
CurtainSystemTypeSet Class See Also Send Feedback
Initializes a new instance of the CurtainSystemTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainSystemTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainSystemTypeSet()

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


CurtainSystemTypeSet Methods

[image] [image]

Revit 2010 API
CurtainSystemTypeSet Methods
CurtainSystemTypeSet Class See Also Send Feedback

The CurtainSystemTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every CurtainSystem type from the set, rendering it empty.
Contains | Tests for the existence of a CurtainSystem type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified CurtainSystem type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified CurtainSystem type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
CurtainSystemTypeSet..::.Clear Method
CurtainSystemTypeSet Class See Also Send Feedback
Removes every CurtainSystem type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
CurtainSystemTypeSet..::.Contains Method
CurtainSystemTypeSet Class See Also Send Feedback
Tests for the existence of a CurtainSystem type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    CurtainSystemType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As CurtainSystemType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    CurtainSystemType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.CurtainSystemType
The CurtainSystem type to be searched for.

Return Value

The Contains method returns True if the CurtainSystem type is within the set, otherwise False.

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
CurtainSystemTypeSet..::.Erase Method
CurtainSystemTypeSet Class See Also Send Feedback
Removes a specified CurtainSystem type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    CurtainSystemType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As CurtainSystemType _
) As Integer
Visual C++
public:
virtual int Erase(
    CurtainSystemType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.CurtainSystemType
The CurtainSystem type to be erased.

Return Value

The number of CurtainSystem types that were erased from the set.

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
CurtainSystemTypeSet..::.ForwardIterator Method
CurtainSystemTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CurtainSystemTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CurtainSystemTypeSetIterator
Visual C++
public:
virtual CurtainSystemTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
CurtainSystemTypeSet..::.GetEnumerator Method
CurtainSystemTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
CurtainSystemTypeSet..::.Insert Method
CurtainSystemTypeSet Class See Also Send Feedback
Insert the specified CurtainSystem type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    CurtainSystemType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As CurtainSystemType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    CurtainSystemType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.CurtainSystemType
The CurtainSystem type to be inserted into the set.

Return Value

Returns whether the CurtainSystem type was inserted into the set.

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
CurtainSystemTypeSet..::.ReverseIterator Method
CurtainSystemTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual CurtainSystemTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CurtainSystemTypeSetIterator
Visual C++
public:
virtual CurtainSystemTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


CurtainSystemTypeSet Properties

[image] [image]

Revit 2010 API
CurtainSystemTypeSet Properties
CurtainSystemTypeSet Class See Also Send Feedback

The CurtainSystemTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of CurtainSystem types that are in the set.

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
CurtainSystemTypeSet..::.IsEmpty Property
CurtainSystemTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
CurtainSystemTypeSet..::.Size Property
CurtainSystemTypeSet Class See Also Send Feedback
Returns the number of CurtainSystem types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurtainSystemTypeSet Class
Autodesk.Revit.Symbols Namespace


CurtainSystemTypeSetIterator Class

[image]

Revit 2010 API
CurtainSystemTypeSetIterator Class
Members See Also Send Feedback
An iterator to a CurtainSystem type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class CurtainSystemTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CurtainSystemTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CurtainSystemTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.CurtainSystemTypeSetIterator

See Also

CurtainSystemTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


CurtainSystemTypeSetIterator Members

[image] [image]

Revit 2010 API
CurtainSystemTypeSetIterator Members
CurtainSystemTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The CurtainSystemTypeSetIterator type exposes the following members.

Constructors

Name | Description
CurtainSystemTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


CurtainSystemTypeSetIterator Constructor

[image]

Revit 2010 API
CurtainSystemTypeSetIterator Constructor
CurtainSystemTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainSystemTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainSystemTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


CurtainSystemTypeSetIterator Methods

[image] [image]

Revit 2010 API
CurtainSystemTypeSetIterator Methods
CurtainSystemTypeSetIterator Class See Also Send Feedback

The CurtainSystemTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
CurtainSystemTypeSetIterator..::.MoveNext Method
CurtainSystemTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurtainSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
CurtainSystemTypeSetIterator..::.Reset Method
CurtainSystemTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurtainSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


CurtainSystemTypeSetIterator Properties

[image] [image]

Revit 2010 API
CurtainSystemTypeSetIterator Properties
CurtainSystemTypeSetIterator Class See Also Send Feedback

The CurtainSystemTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
CurtainSystemTypeSetIterator..::.Current Property
CurtainSystemTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurtainSystemTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


DimensionType Class

[image]

Revit 2010 API
DimensionType Class
Members See Also Send Feedback
An object that represents a dimension style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DimensionType : Symbol
Visual Basic (Declaration)
Public Class DimensionType _
    Inherits Symbol
Visual C++
public ref class DimensionType : public Symbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.DimensionType
Autodesk.Revit.Symbols..::.SpotDimensionType

See Also

DimensionType Members
Autodesk.Revit.Symbols Namespace


DimensionType Members

[image] [image]

Revit 2010 API
DimensionType Members
DimensionType Class Constructors Methods Properties See Also Send Feedback

The DimensionType type exposes the following members.

Constructors

Name | Description
DimensionType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DimensionType Class
Autodesk.Revit.Symbols Namespace


DimensionType Constructor

[image]

Revit 2010 API
DimensionType Constructor
DimensionType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DimensionType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DimensionType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DimensionType Class
Autodesk.Revit.Symbols Namespace


DimensionType Methods

[image] [image]

Revit 2010 API
DimensionType Methods
DimensionType Class See Also Send Feedback

The DimensionType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionType Class
Autodesk.Revit.Symbols Namespace


DimensionType Properties

[image] [image]

Revit 2010 API
DimensionType Properties
DimensionType Class See Also Send Feedback

The DimensionType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

DimensionType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
DimensionType..::.Parameter Property
DimensionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DimensionType Class
DimensionType Members
Autodesk.Revit.Symbols Namespace


DimensionTypeSet Class

[image]

Revit 2010 API
DimensionTypeSet Class
Members See Also Send Feedback
A set that contains dimension types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DimensionTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class DimensionTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DimensionTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.DimensionTypeSet

See Also

DimensionTypeSet Members
Autodesk.Revit.Symbols Namespace


DimensionTypeSet Members

[image] [image]

Revit 2010 API
DimensionTypeSet Members
DimensionTypeSet Class Constructors Methods Properties See Also Send Feedback

The DimensionTypeSet type exposes the following members.

Constructors

Name | Description
DimensionTypeSet | Initializes a new instance of the DimensionTypeSet class

Methods

Name | Description
Clear | Removes every dimension type from the set, rendering it empty.
Contains | Tests for the existence of a dimension type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified dimension type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified dimension type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of dimension types that are in the set.

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


DimensionTypeSet Constructor

[image]

Revit 2010 API
DimensionTypeSet Constructor
DimensionTypeSet Class See Also Send Feedback
Initializes a new instance of the DimensionTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DimensionTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DimensionTypeSet()

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


DimensionTypeSet Methods

[image] [image]

Revit 2010 API
DimensionTypeSet Methods
DimensionTypeSet Class See Also Send Feedback

The DimensionTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every dimension type from the set, rendering it empty.
Contains | Tests for the existence of a dimension type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified dimension type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified dimension type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
DimensionTypeSet..::.Clear Method
DimensionTypeSet Class See Also Send Feedback
Removes every dimension type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
DimensionTypeSet..::.Contains Method
DimensionTypeSet Class See Also Send Feedback
Tests for the existence of a dimension type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    DimensionType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As DimensionType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    DimensionType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.DimensionType
The dimension type to be searched for.

Return Value

The Contains method returns True if the dimension type is within the set, otherwise False.

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
DimensionTypeSet..::.Erase Method
DimensionTypeSet Class See Also Send Feedback
Removes a specified dimension type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    DimensionType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As DimensionType _
) As Integer
Visual C++
public:
virtual int Erase(
    DimensionType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.DimensionType
The dimension type to be erased.

Return Value

The number of dimension types that were erased from the set.

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
DimensionTypeSet..::.ForwardIterator Method
DimensionTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DimensionTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DimensionTypeSetIterator
Visual C++
public:
virtual DimensionTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
DimensionTypeSet..::.GetEnumerator Method
DimensionTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
DimensionTypeSet..::.Insert Method
DimensionTypeSet Class See Also Send Feedback
Insert the specified dimension type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    DimensionType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As DimensionType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    DimensionType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.DimensionType
The dimension type to be inserted into the set.

Return Value

Returns whether the dimension type was inserted into the set.

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
DimensionTypeSet..::.ReverseIterator Method
DimensionTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual DimensionTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DimensionTypeSetIterator
Visual C++
public:
virtual DimensionTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


DimensionTypeSet Properties

[image] [image]

Revit 2010 API
DimensionTypeSet Properties
DimensionTypeSet Class See Also Send Feedback

The DimensionTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of dimension types that are in the set.

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
DimensionTypeSet..::.IsEmpty Property
DimensionTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
DimensionTypeSet..::.Size Property
DimensionTypeSet Class See Also Send Feedback
Returns the number of dimension types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


DimensionTypeSetIterator Class

[image]

Revit 2010 API
DimensionTypeSetIterator Class
Members See Also Send Feedback
An iterator to a dimension type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class DimensionTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class DimensionTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DimensionTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.DimensionTypeSetIterator

See Also

DimensionTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


DimensionTypeSetIterator Members

[image] [image]

Revit 2010 API
DimensionTypeSetIterator Members
DimensionTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The DimensionTypeSetIterator type exposes the following members.

Constructors

Name | Description
DimensionTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


DimensionTypeSetIterator Constructor

[image]

Revit 2010 API
DimensionTypeSetIterator Constructor
DimensionTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DimensionTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DimensionTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


DimensionTypeSetIterator Methods

[image] [image]

Revit 2010 API
DimensionTypeSetIterator Methods
DimensionTypeSetIterator Class See Also Send Feedback

The DimensionTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
DimensionTypeSetIterator..::.MoveNext Method
DimensionTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
DimensionTypeSetIterator..::.Reset Method
DimensionTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


DimensionTypeSetIterator Properties

[image] [image]

Revit 2010 API
DimensionTypeSetIterator Properties
DimensionTypeSetIterator Class See Also Send Feedback

The DimensionTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
DimensionTypeSetIterator..::.Current Property
DimensionTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


FamilySymbol Class

[image]

Revit 2010 API
FamilySymbol Class
Members Example See Also Send Feedback
Represents a single Type within a Family.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FamilySymbol : InsertableObject
Visual Basic (Declaration)
Public Class FamilySymbol _
    Inherits InsertableObject
Visual C++
public ref class FamilySymbol : public InsertableObject

Remarks

The FamilySymbol object represents a Type within a Family. Each family can contain one or more family symbols. The FamilySymbol object is derived from the Symbol object and also the Element object and as such inherits all the properties and methods of those objects.

Examples

CopyC#
public void GetInfo_FamilySymbol(FamilySymbol familySymbol)
{
    string message;
    // Get FamilySymbol family name
    message = "Family name is : " + familySymbol.Family.Name;

    // Get FamilySymbol material
    message += "\nFamilySymbol material is : " + familySymbol.Material.ToString();

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_FamilySymbol(ByVal familySymbol As Autodesk.Revit.Symbols.FamilySymbol)
    Dim message As String
    ' Get FamilySymbol family name
    message = "Family name is : " & familySymbol.Family.Name

    ' Get FamilySymbol material
    message += vbLf & "FamilySymbol material is : " & familySymbol.Material.ToString()

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.InsertableObject
Autodesk.Revit.Symbols..::.FamilySymbol
Autodesk.Revit.Symbols..::.AnnotationSymbolType
Autodesk.Revit.Symbols..::.AreaTagType
Autodesk.Revit.Symbols..::.MullionType
Autodesk.Revit.Symbols..::.PanelType
Autodesk.Revit.Symbols..::.RoomTagType
Autodesk.Revit.Symbols..::.SpaceTagType

See Also

FamilySymbol Members
Autodesk.Revit.Symbols Namespace


FamilySymbol Members

[image] [image]

Revit 2010 API
FamilySymbol Members
FamilySymbol Class Constructors Methods Properties See Also Send Feedback

The FamilySymbol type exposes the following members.

Constructors

Name | Description
FamilySymbol | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Material | This property returns the physical material from which the type is made.
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FamilySymbol Class
Autodesk.Revit.Symbols Namespace


FamilySymbol Constructor

[image]

Revit 2010 API
FamilySymbol Constructor
FamilySymbol Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbol()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilySymbol()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilySymbol Class
Autodesk.Revit.Symbols Namespace


FamilySymbol Methods

[image] [image]

Revit 2010 API
FamilySymbol Methods
FamilySymbol Class See Also Send Feedback

The FamilySymbol type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilySymbol Class
Autodesk.Revit.Symbols Namespace


FamilySymbol Properties

[image] [image]

Revit 2010 API
FamilySymbol Properties
FamilySymbol Class See Also Send Feedback

The FamilySymbol type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Material | This property returns the physical material from which the type is made.
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FamilySymbol Class
Autodesk.Revit.Symbols Namespace


Family Property

[image]

Revit 2010 API
FamilySymbol..::.Family Property
FamilySymbol Class See Also Send Feedback
Returns the Family object to which the symbol belongs.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Family Family { get; }
Visual Basic (Declaration)
Public ReadOnly Property Family As Family
Visual C++
public:
property Family^ Family {
    Family^ get ();
}

See Also

FamilySymbol Class
Autodesk.Revit.Symbols Namespace


Material Property

[image]

Revit 2010 API
FamilySymbol..::.Material Property
FamilySymbol Class See Also Send Feedback
This property returns the physical material from which the type is made.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Material Material { get; }
Visual Basic (Declaration)
Public ReadOnly Property Material As Material
Visual C++
public:
property Material Material {
    Material get ();
}

Remarks

Values of this property can be Steel, Concrete, Wood or some other material.

See Also

FamilySymbol Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
FamilySymbol..::.Parameter Property
FamilySymbol Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FamilySymbol Class
FamilySymbol Members
Autodesk.Revit.Symbols Namespace


FamilySymbolSet Class

[image]

Revit 2010 API
FamilySymbolSet Class
Members See Also Send Feedback
A set that can contain family symbols.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FamilySymbolSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class FamilySymbolSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FamilySymbolSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.FamilySymbolSet

See Also

FamilySymbolSet Members
Autodesk.Revit.Symbols Namespace


FamilySymbolSet Members

[image] [image]

Revit 2010 API
FamilySymbolSet Members
FamilySymbolSet Class Constructors Methods Properties See Also Send Feedback

The FamilySymbolSet type exposes the following members.

Constructors

Name | Description
FamilySymbolSet | Initializes a new instance of the FamilySymbolSet class

Methods

Name | Description
Clear | Removes every symbol from the set, rendering it empty.
Contains | Tests for the existence of a family symbol within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified family symbol from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified family symbol into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of family symbols that are in the set.

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


FamilySymbolSet Constructor

[image]

Revit 2010 API
FamilySymbolSet Constructor
FamilySymbolSet Class See Also Send Feedback
Initializes a new instance of the FamilySymbolSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbolSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilySymbolSet()

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


FamilySymbolSet Methods

[image] [image]

Revit 2010 API
FamilySymbolSet Methods
FamilySymbolSet Class See Also Send Feedback

The FamilySymbolSet type exposes the following members.

Methods

Name | Description
Clear | Removes every symbol from the set, rendering it empty.
Contains | Tests for the existence of a family symbol within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified family symbol from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified family symbol into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
FamilySymbolSet..::.Clear Method
FamilySymbolSet Class See Also Send Feedback
Removes every symbol from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
FamilySymbolSet..::.Contains Method
FamilySymbolSet Class See Also Send Feedback
Tests for the existence of a family symbol within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    FamilySymbol item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As FamilySymbol _
) As Boolean
Visual C++
public:
virtual bool Contains(
    FamilySymbol^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.FamilySymbol
The symbol to be searched for.

Return Value

The Contains method returns True if the symbol is within the set, otherwise False.

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
FamilySymbolSet..::.Erase Method
FamilySymbolSet Class See Also Send Feedback
Removes a specified family symbol from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    FamilySymbol item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As FamilySymbol _
) As Integer
Visual C++
public:
virtual int Erase(
    FamilySymbol^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.FamilySymbol
The symbol to be erased.

Return Value

The number of symbols that were erased from the set.

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
FamilySymbolSet..::.ForwardIterator Method
FamilySymbolSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual FamilySymbolSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As FamilySymbolSetIterator
Visual C++
public:
virtual FamilySymbolSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
FamilySymbolSet..::.GetEnumerator Method
FamilySymbolSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
FamilySymbolSet..::.Insert Method
FamilySymbolSet Class See Also Send Feedback
Insert the specified family symbol into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    FamilySymbol item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As FamilySymbol _
) As Boolean
Visual C++
public:
virtual bool Insert(
    FamilySymbol^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.FamilySymbol
The symbol to be inserted into the set.

Return Value

Returns whether the symbol was inserted into the set.

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
FamilySymbolSet..::.ReverseIterator Method
FamilySymbolSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual FamilySymbolSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As FamilySymbolSetIterator
Visual C++
public:
virtual FamilySymbolSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


FamilySymbolSet Properties

[image] [image]

Revit 2010 API
FamilySymbolSet Properties
FamilySymbolSet Class See Also Send Feedback

The FamilySymbolSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of family symbols that are in the set.

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
FamilySymbolSet..::.IsEmpty Property
FamilySymbolSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
FamilySymbolSet..::.Size Property
FamilySymbolSet Class See Also Send Feedback
Returns the number of family symbols that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FamilySymbolSet Class
Autodesk.Revit.Symbols Namespace


FamilySymbolSetIterator Class

[image]

Revit 2010 API
FamilySymbolSetIterator Class
Members See Also Send Feedback
An iterator to a family symbol set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class FamilySymbolSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class FamilySymbolSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FamilySymbolSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.FamilySymbolSetIterator

See Also

FamilySymbolSetIterator Members
Autodesk.Revit.Symbols Namespace


FamilySymbolSetIterator Members

[image] [image]

Revit 2010 API
FamilySymbolSetIterator Members
FamilySymbolSetIterator Class Constructors Methods Properties See Also Send Feedback

The FamilySymbolSetIterator type exposes the following members.

Constructors

Name | Description
FamilySymbolSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilySymbolSetIterator Class
Autodesk.Revit.Symbols Namespace


FamilySymbolSetIterator Constructor

[image]

Revit 2010 API
FamilySymbolSetIterator Constructor
FamilySymbolSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbolSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilySymbolSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilySymbolSetIterator Class
Autodesk.Revit.Symbols Namespace


FamilySymbolSetIterator Methods

[image] [image]

Revit 2010 API
FamilySymbolSetIterator Methods
FamilySymbolSetIterator Class See Also Send Feedback

The FamilySymbolSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilySymbolSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
FamilySymbolSetIterator..::.MoveNext Method
FamilySymbolSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FamilySymbolSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
FamilySymbolSetIterator..::.Reset Method
FamilySymbolSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FamilySymbolSetIterator Class
Autodesk.Revit.Symbols Namespace


FamilySymbolSetIterator Properties

[image] [image]

Revit 2010 API
FamilySymbolSetIterator Properties
FamilySymbolSetIterator Class See Also Send Feedback

The FamilySymbolSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilySymbolSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
FamilySymbolSetIterator..::.Current Property
FamilySymbolSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FamilySymbolSetIterator Class
Autodesk.Revit.Symbols Namespace


FasciaType Class

[image]

Revit 2010 API
FasciaType Class
Members See Also Send Feedback
An object that represents the fascia type in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FasciaType : HostedSweepType
Visual Basic (Declaration)
Public Class FasciaType _
    Inherits HostedSweepType
Visual C++
public ref class FasciaType : public HostedSweepType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.HostObjAttributes
Autodesk.Revit.Symbols..::.HostedSweepType
Autodesk.Revit.Symbols..::.FasciaType

See Also

FasciaType Members
Autodesk.Revit.Symbols Namespace


FasciaType Members

[image] [image]

Revit 2010 API
FasciaType Members
FasciaType Class Constructors Methods Properties See Also Send Feedback

The FasciaType type exposes the following members.

Constructors

Name | Description
FasciaType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FasciaType Class
Autodesk.Revit.Symbols Namespace


FasciaType Constructor

[image]

Revit 2010 API
FasciaType Constructor
FasciaType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FasciaType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FasciaType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FasciaType Class
Autodesk.Revit.Symbols Namespace


FasciaType Methods

[image] [image]

Revit 2010 API
FasciaType Methods
FasciaType Class See Also Send Feedback

The FasciaType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FasciaType Class
Autodesk.Revit.Symbols Namespace


FasciaType Properties

[image] [image]

Revit 2010 API
FasciaType Properties
FasciaType Class See Also Send Feedback

The FasciaType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FasciaType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
FasciaType..::.Parameter Property
FasciaType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FasciaType Class
FasciaType Members
Autodesk.Revit.Symbols Namespace


FasciaTypeSet Class

[image]

Revit 2010 API
FasciaTypeSet Class
Members See Also Send Feedback
A set that contains fascia types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FasciaTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class FasciaTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FasciaTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.FasciaTypeSet

See Also

FasciaTypeSet Members
Autodesk.Revit.Symbols Namespace


FasciaTypeSet Members

[image] [image]

Revit 2010 API
FasciaTypeSet Members
FasciaTypeSet Class Constructors Methods Properties See Also Send Feedback

The FasciaTypeSet type exposes the following members.

Constructors

Name | Description
FasciaTypeSet | Initializes a new instance of the FasciaTypeSet class

Methods

Name | Description
Clear | Removes every fascia type from the set, rendering it empty.
Contains | Tests for the existence of a fascia type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified fascia type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified fascia type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of fascia types that are in the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


FasciaTypeSet Constructor

[image]

Revit 2010 API
FasciaTypeSet Constructor
FasciaTypeSet Class See Also Send Feedback
Initializes a new instance of the FasciaTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FasciaTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FasciaTypeSet()

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


FasciaTypeSet Methods

[image] [image]

Revit 2010 API
FasciaTypeSet Methods
FasciaTypeSet Class See Also Send Feedback

The FasciaTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every fascia type from the set, rendering it empty.
Contains | Tests for the existence of a fascia type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified fascia type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified fascia type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
FasciaTypeSet..::.Clear Method
FasciaTypeSet Class See Also Send Feedback
Removes every fascia type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
FasciaTypeSet..::.Contains Method
FasciaTypeSet Class See Also Send Feedback
Tests for the existence of a fascia type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    FasciaType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As FasciaType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    FasciaType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.FasciaType
The fascia type to be searched for.

Return Value

The Contains method returns True if the fascia type is within the set, otherwise False.

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
FasciaTypeSet..::.Erase Method
FasciaTypeSet Class See Also Send Feedback
Removes a specified fascia type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    FasciaType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As FasciaType _
) As Integer
Visual C++
public:
virtual int Erase(
    FasciaType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.FasciaType
The fascia type to be erased.

Return Value

The number of fascia types that were erased from the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
FasciaTypeSet..::.ForwardIterator Method
FasciaTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual FasciaTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As FasciaTypeSetIterator
Visual C++
public:
virtual FasciaTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
FasciaTypeSet..::.GetEnumerator Method
FasciaTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
FasciaTypeSet..::.Insert Method
FasciaTypeSet Class See Also Send Feedback
Insert the specified fascia type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    FasciaType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As FasciaType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    FasciaType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.FasciaType
The fascia type to be inserted into the set.

Return Value

Returns whether the fascia type was inserted into the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
FasciaTypeSet..::.ReverseIterator Method
FasciaTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual FasciaTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As FasciaTypeSetIterator
Visual C++
public:
virtual FasciaTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


FasciaTypeSet Properties

[image] [image]

Revit 2010 API
FasciaTypeSet Properties
FasciaTypeSet Class See Also Send Feedback

The FasciaTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of fascia types that are in the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
FasciaTypeSet..::.IsEmpty Property
FasciaTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
FasciaTypeSet..::.Size Property
FasciaTypeSet Class See Also Send Feedback
Returns the number of fascia types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FasciaTypeSet Class
Autodesk.Revit.Symbols Namespace


FasciaTypeSetIterator Class

[image]

Revit 2010 API
FasciaTypeSetIterator Class
Members See Also Send Feedback
An iterator to a fascia type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class FasciaTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class FasciaTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FasciaTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.FasciaTypeSetIterator

See Also

FasciaTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


FasciaTypeSetIterator Members

[image] [image]

Revit 2010 API
FasciaTypeSetIterator Members
FasciaTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The FasciaTypeSetIterator type exposes the following members.

Constructors

Name | Description
FasciaTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


FasciaTypeSetIterator Constructor

[image]

Revit 2010 API
FasciaTypeSetIterator Constructor
FasciaTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FasciaTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FasciaTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


FasciaTypeSetIterator Methods

[image] [image]

Revit 2010 API
FasciaTypeSetIterator Methods
FasciaTypeSetIterator Class See Also Send Feedback

The FasciaTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
FasciaTypeSetIterator..::.MoveNext Method
FasciaTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
FasciaTypeSetIterator..::.Reset Method
FasciaTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


FasciaTypeSetIterator Properties

[image] [image]

Revit 2010 API
FasciaTypeSetIterator Properties
FasciaTypeSetIterator Class See Also Send Feedback

The FasciaTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
FasciaTypeSetIterator..::.Current Property
FasciaTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


FloorType Class

[image]

Revit 2010 API
FloorType Class
Members Example See Also Send Feedback
An object that specifies the type of a floor in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FloorType : HostObjAttributes
Visual Basic (Declaration)
Public Class FloorType _
    Inherits HostObjAttributes
Visual C++
public ref class FloorType : public HostObjAttributes

Remarks

The structural layers of the floor can be accessed via this object.

Examples

CopyC#
public void GetInfo_FloorType(FloorType floorType)
{
    string message;
    // Get whether FloorType is a foundation slab
    message = "If is foundation slab : " + floorType.IsFoundationSlab;
    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_FloorType(ByVal floorType As FloorType)
    Dim message As String
    ' Get whether FloorType is a foundation slab
    message = "If is foundation slab : " & floorType.IsFoundationSlab
    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.HostObjAttributes
Autodesk.Revit.Symbols..::.FloorType

See Also

FloorType Members
Autodesk.Revit.Symbols Namespace


FloorType Members

[image] [image]

Revit 2010 API
FloorType Members
FloorType Class Constructors Methods Properties See Also Send Feedback

The FloorType type exposes the following members.

Constructors

Name | Description
FloorType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsFoundationSlab | Returns whether the element FloorAttributes type is FoundationSlab.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FloorType Class
Autodesk.Revit.Symbols Namespace


FloorType Constructor

[image]

Revit 2010 API
FloorType Constructor
FloorType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FloorType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FloorType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FloorType Class
Autodesk.Revit.Symbols Namespace


FloorType Methods

[image] [image]

Revit 2010 API
FloorType Methods
FloorType Class See Also Send Feedback

The FloorType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FloorType Class
Autodesk.Revit.Symbols Namespace


FloorType Properties

[image] [image]

Revit 2010 API
FloorType Properties
FloorType Class See Also Send Feedback

The FloorType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsFoundationSlab | Returns whether the element FloorAttributes type is FoundationSlab.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

FloorType Class
Autodesk.Revit.Symbols Namespace


IsFoundationSlab Property

[image]

Revit 2010 API
FloorType..::.IsFoundationSlab Property
FloorType Class See Also Send Feedback
Returns whether the element FloorAttributes type is FoundationSlab.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsFoundationSlab { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFoundationSlab As Boolean
Visual C++
public:
property bool IsFoundationSlab {
    bool get ();
}

See Also

FloorType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
FloorType..::.Parameter Property
FloorType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FloorType Class
FloorType Members
Autodesk.Revit.Symbols Namespace


FloorTypeSet Class

[image]

Revit 2010 API
FloorTypeSet Class
Members See Also Send Feedback
A set that contains floor types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FloorTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class FloorTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FloorTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.FloorTypeSet

See Also

FloorTypeSet Members
Autodesk.Revit.Symbols Namespace


FloorTypeSet Members

[image] [image]

Revit 2010 API
FloorTypeSet Members
FloorTypeSet Class Constructors Methods Properties See Also Send Feedback

The FloorTypeSet type exposes the following members.

Constructors

Name | Description
FloorTypeSet | Initializes a new instance of the FloorTypeSet class

Methods

Name | Description
Clear | Removes every floor type from the set, rendering it empty.
Contains | Tests for the existence of a floor type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified floor type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified floor type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of floor types that are in the set.

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


FloorTypeSet Constructor

[image]

Revit 2010 API
FloorTypeSet Constructor
FloorTypeSet Class See Also Send Feedback
Initializes a new instance of the FloorTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FloorTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FloorTypeSet()

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


FloorTypeSet Methods

[image] [image]

Revit 2010 API
FloorTypeSet Methods
FloorTypeSet Class See Also Send Feedback

The FloorTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every floor type from the set, rendering it empty.
Contains | Tests for the existence of a floor type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified floor type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified floor type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
FloorTypeSet..::.Clear Method
FloorTypeSet Class See Also Send Feedback
Removes every floor type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
FloorTypeSet..::.Contains Method
FloorTypeSet Class See Also Send Feedback
Tests for the existence of a floor type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    FloorType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As FloorType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    FloorType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.FloorType
The floor type to be searched for.

Return Value

The Contains method returns True if the floor type is within the set, otherwise False.

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
FloorTypeSet..::.Erase Method
FloorTypeSet Class See Also Send Feedback
Removes a specified floor type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    FloorType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As FloorType _
) As Integer
Visual C++
public:
virtual int Erase(
    FloorType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.FloorType
The floor type to be erased.

Return Value

The number of floor types that were erased from the set.

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
FloorTypeSet..::.ForwardIterator Method
FloorTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual FloorTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As FloorTypeSetIterator
Visual C++
public:
virtual FloorTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
FloorTypeSet..::.GetEnumerator Method
FloorTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
FloorTypeSet..::.Insert Method
FloorTypeSet Class See Also Send Feedback
Insert the specified floor type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    FloorType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As FloorType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    FloorType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.FloorType
The floor type to be inserted into the set.

Return Value

Returns whether the floor type was inserted into the set.

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
FloorTypeSet..::.ReverseIterator Method
FloorTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual FloorTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As FloorTypeSetIterator
Visual C++
public:
virtual FloorTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


FloorTypeSet Properties

[image] [image]

Revit 2010 API
FloorTypeSet Properties
FloorTypeSet Class See Also Send Feedback

The FloorTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of floor types that are in the set.

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
FloorTypeSet..::.IsEmpty Property
FloorTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
FloorTypeSet..::.Size Property
FloorTypeSet Class See Also Send Feedback
Returns the number of floor types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FloorTypeSet Class
Autodesk.Revit.Symbols Namespace


FloorTypeSetIterator Class

[image]

Revit 2010 API
FloorTypeSetIterator Class
Members See Also Send Feedback
An iterator to a floor type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class FloorTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class FloorTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FloorTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.FloorTypeSetIterator

See Also

FloorTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


FloorTypeSetIterator Members

[image] [image]

Revit 2010 API
FloorTypeSetIterator Members
FloorTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The FloorTypeSetIterator type exposes the following members.

Constructors

Name | Description
FloorTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FloorTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


FloorTypeSetIterator Constructor

[image]

Revit 2010 API
FloorTypeSetIterator Constructor
FloorTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FloorTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FloorTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FloorTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


FloorTypeSetIterator Methods

[image] [image]

Revit 2010 API
FloorTypeSetIterator Methods
FloorTypeSetIterator Class See Also Send Feedback

The FloorTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FloorTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
FloorTypeSetIterator..::.MoveNext Method
FloorTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FloorTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
FloorTypeSetIterator..::.Reset Method
FloorTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FloorTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


FloorTypeSetIterator Properties

[image] [image]

Revit 2010 API
FloorTypeSetIterator Properties
FloorTypeSetIterator Class See Also Send Feedback

The FloorTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FloorTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
FloorTypeSetIterator..::.Current Property
FloorTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FloorTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


GridType Class

[image]

Revit 2010 API
GridType Class
Members See Also Send Feedback
An object that represents a grid type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class GridType : LineAndTextAttrSymbol
Visual Basic (Declaration)
Public Class GridType _
    Inherits LineAndTextAttrSymbol
Visual C++
public ref class GridType : public LineAndTextAttrSymbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.LineAndTextAttrSymbol
Autodesk.Revit.Symbols..::.GridType

See Also

GridType Members
Autodesk.Revit.Symbols Namespace


GridType Members

[image] [image]

Revit 2010 API
GridType Members
GridType Class Constructors Methods Properties See Also Send Feedback

The GridType type exposes the following members.

Constructors

Name | Description
GridType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

GridType Class
Autodesk.Revit.Symbols Namespace


GridType Constructor

[image]

Revit 2010 API
GridType Constructor
GridType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GridType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GridType Class
Autodesk.Revit.Symbols Namespace


GridType Methods

[image] [image]

Revit 2010 API
GridType Methods
GridType Class See Also Send Feedback

The GridType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridType Class
Autodesk.Revit.Symbols Namespace


GridType Properties

[image] [image]

Revit 2010 API
GridType Properties
GridType Class See Also Send Feedback

The GridType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

GridType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
GridType..::.Parameter Property
GridType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

GridType Class
GridType Members
Autodesk.Revit.Symbols Namespace


GridTypeSet Class

[image]

Revit 2010 API
GridTypeSet Class
Members See Also Send Feedback
A set that contains grid types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class GridTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class GridTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GridTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.GridTypeSet

See Also

GridTypeSet Members
Autodesk.Revit.Symbols Namespace


GridTypeSet Members

[image] [image]

Revit 2010 API
GridTypeSet Members
GridTypeSet Class Constructors Methods Properties See Also Send Feedback

The GridTypeSet type exposes the following members.

Constructors

Name | Description
GridTypeSet | Initializes a new instance of the GridTypeSet class

Methods

Name | Description
Clear | Removes every grid type from the set, rendering it empty.
Contains | Tests for the existence of a grid type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified grid type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified grid type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of grid types that are in the set.

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


GridTypeSet Constructor

[image]

Revit 2010 API
GridTypeSet Constructor
GridTypeSet Class See Also Send Feedback
Initializes a new instance of the GridTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GridTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridTypeSet()

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


GridTypeSet Methods

[image] [image]

Revit 2010 API
GridTypeSet Methods
GridTypeSet Class See Also Send Feedback

The GridTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every grid type from the set, rendering it empty.
Contains | Tests for the existence of a grid type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified grid type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified grid type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
GridTypeSet..::.Clear Method
GridTypeSet Class See Also Send Feedback
Removes every grid type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
GridTypeSet..::.Contains Method
GridTypeSet Class See Also Send Feedback
Tests for the existence of a grid type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    GridType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As GridType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    GridType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.GridType
The grid type to be searched for.

Return Value

The Contains method returns True if the grid type is within the set, otherwise False.

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
GridTypeSet..::.Erase Method
GridTypeSet Class See Also Send Feedback
Removes a specified grid type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    GridType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As GridType _
) As Integer
Visual C++
public:
virtual int Erase(
    GridType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.GridType
The grid type to be erased.

Return Value

The number of grid types that were erased from the set.

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
GridTypeSet..::.ForwardIterator Method
GridTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual GridTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As GridTypeSetIterator
Visual C++
public:
virtual GridTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
GridTypeSet..::.GetEnumerator Method
GridTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
GridTypeSet..::.Insert Method
GridTypeSet Class See Also Send Feedback
Insert the specified grid type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    GridType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As GridType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    GridType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.GridType
The grid type to be inserted into the set.

Return Value

Returns whether the grid type was inserted into the set.

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
GridTypeSet..::.ReverseIterator Method
GridTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual GridTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As GridTypeSetIterator
Visual C++
public:
virtual GridTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


GridTypeSet Properties

[image] [image]

Revit 2010 API
GridTypeSet Properties
GridTypeSet Class See Also Send Feedback

The GridTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of grid types that are in the set.

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
GridTypeSet..::.IsEmpty Property
GridTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
GridTypeSet..::.Size Property
GridTypeSet Class See Also Send Feedback
Returns the number of grid types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GridTypeSet Class
Autodesk.Revit.Symbols Namespace


GridTypeSetIterator Class

[image]

Revit 2010 API
GridTypeSetIterator Class
Members See Also Send Feedback
An iterator to a grid type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class GridTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class GridTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GridTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.GridTypeSetIterator

See Also

GridTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


GridTypeSetIterator Members

[image] [image]

Revit 2010 API
GridTypeSetIterator Members
GridTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The GridTypeSetIterator type exposes the following members.

Constructors

Name | Description
GridTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GridTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


GridTypeSetIterator Constructor

[image]

Revit 2010 API
GridTypeSetIterator Constructor
GridTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GridTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GridTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


GridTypeSetIterator Methods

[image] [image]

Revit 2010 API
GridTypeSetIterator Methods
GridTypeSetIterator Class See Also Send Feedback

The GridTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
GridTypeSetIterator..::.MoveNext Method
GridTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GridTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
GridTypeSetIterator..::.Reset Method
GridTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GridTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


GridTypeSetIterator Properties

[image] [image]

Revit 2010 API
GridTypeSetIterator Properties
GridTypeSetIterator Class See Also Send Feedback

The GridTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GridTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
GridTypeSetIterator..::.Current Property
GridTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GridTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


GroupType Class

[image]

Revit 2010 API
GroupType Class
Members Example See Also Send Feedback
Represents a type of a user defined group.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class GroupType : Symbol
Visual Basic (Declaration)
Public Class GroupType _
    Inherits Symbol
Visual C++
public ref class GroupType : public Symbol

Remarks

The GroupType object can be used to swap the type of an existing group or to place an new instance of a group.

Examples

CopyC#
public void GetInfo_GroupType(GroupType groupType)
{
    string message = "GroupType";
    //Retrieve a set of all the groups that have this type.
    foreach (Group group in groupType.Groups)
    {
        // Get GroupType group name
        message = "\nThe group type name is : " + groupType.Name;
        //Returns all the members of the group.
        message += "\nThe types and ids of the group members are : ";
        foreach (Element element in group.Members)
        {
            // Get GroupType group element id
            message += "\n\t" + element.GetType().Name + " : " + element.Id.Value;
        }
    }
    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_GroupType(ByVal groupType As GroupType)
    Dim message As String = "GroupType"
    'Retrieve a set of all the groups that have this type.
    For Each group As Group In groupType.Groups
        ' Get GroupType group name
        message = vbLf & "The group type name is : " & groupType.Name
        'Returns all the members of the group.
        message += vbLf & "The types and ids of the group members are : "
        For Each element As Autodesk.Revit.Element In group.Members
            ' Get GroupType group element id
            message += (vbLf & vbTab & element.[GetType]().Name & " : ") + element.Id.Value
        Next
    Next
    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.GroupType

See Also

GroupType Members
Autodesk.Revit.Symbols Namespace


GroupType Members

[image] [image]

Revit 2010 API
GroupType Members
GroupType Class Constructors Methods Properties See Also Send Feedback

The GroupType type exposes the following members.

Constructors

Name | Description
GroupType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Groups | Retrieve a set of all the groups that have this type.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

GroupType Class
Autodesk.Revit.Symbols Namespace


GroupType Constructor

[image]

Revit 2010 API
GroupType Constructor
GroupType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GroupType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GroupType Class
Autodesk.Revit.Symbols Namespace


GroupType Methods

[image] [image]

Revit 2010 API
GroupType Methods
GroupType Class See Also Send Feedback

The GroupType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroupType Class
Autodesk.Revit.Symbols Namespace


GroupType Properties

[image] [image]

Revit 2010 API
GroupType Properties
GroupType Class See Also Send Feedback

The GroupType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Groups | Retrieve a set of all the groups that have this type.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

GroupType Class
Autodesk.Revit.Symbols Namespace


Groups Property

[image]

Revit 2010 API
GroupType..::.Groups Property
GroupType Class See Also Send Feedback
Retrieve a set of all the groups that have this type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GroupSet Groups { get; }
Visual Basic (Declaration)
Public ReadOnly Property Groups As GroupSet
Visual C++
public:
property GroupSet^ Groups {
    GroupSet^ get ();
}

Return Value

A set of group objects that all share this group type.

Remarks

All groups returned by this property belong to this group type. A groups type can be changed by using the GroupType property on the group object, in which case it will no longer belong to this type but it will belong to the new type instead.

See Also

GroupType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
GroupType..::.Parameter Property
GroupType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

GroupType Class
GroupType Members
Autodesk.Revit.Symbols Namespace


GutterType Class

[image]

Revit 2010 API
GutterType Class
Members See Also Send Feedback
An object that represents the gutter type in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class GutterType : HostedSweepType
Visual Basic (Declaration)
Public Class GutterType _
    Inherits HostedSweepType
Visual C++
public ref class GutterType : public HostedSweepType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.HostObjAttributes
Autodesk.Revit.Symbols..::.HostedSweepType
Autodesk.Revit.Symbols..::.GutterType

See Also

GutterType Members
Autodesk.Revit.Symbols Namespace


GutterType Members

[image] [image]

Revit 2010 API
GutterType Members
GutterType Class Constructors Methods Properties See Also Send Feedback

The GutterType type exposes the following members.

Constructors

Name | Description
GutterType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

GutterType Class
Autodesk.Revit.Symbols Namespace


GutterType Constructor

[image]

Revit 2010 API
GutterType Constructor
GutterType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GutterType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GutterType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GutterType Class
Autodesk.Revit.Symbols Namespace


GutterType Methods

[image] [image]

Revit 2010 API
GutterType Methods
GutterType Class See Also Send Feedback

The GutterType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GutterType Class
Autodesk.Revit.Symbols Namespace


GutterType Properties

[image] [image]

Revit 2010 API
GutterType Properties
GutterType Class See Also Send Feedback

The GutterType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

GutterType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
GutterType..::.Parameter Property
GutterType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

GutterType Class
GutterType Members
Autodesk.Revit.Symbols Namespace


GutterTypeSet Class

[image]

Revit 2010 API
GutterTypeSet Class
Members See Also Send Feedback
A set that contains gutter types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class GutterTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class GutterTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GutterTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.GutterTypeSet

See Also

GutterTypeSet Members
Autodesk.Revit.Symbols Namespace


GutterTypeSet Members

[image] [image]

Revit 2010 API
GutterTypeSet Members
GutterTypeSet Class Constructors Methods Properties See Also Send Feedback

The GutterTypeSet type exposes the following members.

Constructors

Name | Description
GutterTypeSet | Initializes a new instance of the GutterTypeSet class

Methods

Name | Description
Clear | Removes every gutter type from the set, rendering it empty.
Contains | Tests for the existence of a gutter type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified gutter type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified gutter type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of gutter types that are in the set.

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


GutterTypeSet Constructor

[image]

Revit 2010 API
GutterTypeSet Constructor
GutterTypeSet Class See Also Send Feedback
Initializes a new instance of the GutterTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GutterTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GutterTypeSet()

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


GutterTypeSet Methods

[image] [image]

Revit 2010 API
GutterTypeSet Methods
GutterTypeSet Class See Also Send Feedback

The GutterTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every gutter type from the set, rendering it empty.
Contains | Tests for the existence of a gutter type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified gutter type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified gutter type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
GutterTypeSet..::.Clear Method
GutterTypeSet Class See Also Send Feedback
Removes every gutter type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
GutterTypeSet..::.Contains Method
GutterTypeSet Class See Also Send Feedback
Tests for the existence of a gutter type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    GutterType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As GutterType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    GutterType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.GutterType
The gutter type to be searched for.

Return Value

The Contains method returns True if the gutter type is within the set, otherwise False.

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
GutterTypeSet..::.Erase Method
GutterTypeSet Class See Also Send Feedback
Removes a specified gutter type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    GutterType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As GutterType _
) As Integer
Visual C++
public:
virtual int Erase(
    GutterType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.GutterType
The gutter type to be erased.

Return Value

The number of gutter types that were erased from the set.

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
GutterTypeSet..::.ForwardIterator Method
GutterTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual GutterTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As GutterTypeSetIterator
Visual C++
public:
virtual GutterTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
GutterTypeSet..::.GetEnumerator Method
GutterTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
GutterTypeSet..::.Insert Method
GutterTypeSet Class See Also Send Feedback
Insert the specified gutter type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    GutterType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As GutterType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    GutterType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.GutterType
The gutter type to be inserted into the set.

Return Value

Returns whether the gutter type was inserted into the set.

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
GutterTypeSet..::.ReverseIterator Method
GutterTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual GutterTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As GutterTypeSetIterator
Visual C++
public:
virtual GutterTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


GutterTypeSet Properties

[image] [image]

Revit 2010 API
GutterTypeSet Properties
GutterTypeSet Class See Also Send Feedback

The GutterTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of gutter types that are in the set.

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
GutterTypeSet..::.IsEmpty Property
GutterTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
GutterTypeSet..::.Size Property
GutterTypeSet Class See Also Send Feedback
Returns the number of gutter types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GutterTypeSet Class
Autodesk.Revit.Symbols Namespace


GutterTypeSetIterator Class

[image]

Revit 2010 API
GutterTypeSetIterator Class
Members See Also Send Feedback
An iterator to a gutter type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class GutterTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class GutterTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GutterTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.GutterTypeSetIterator

See Also

GutterTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


GutterTypeSetIterator Members

[image] [image]

Revit 2010 API
GutterTypeSetIterator Members
GutterTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The GutterTypeSetIterator type exposes the following members.

Constructors

Name | Description
GutterTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GutterTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


GutterTypeSetIterator Constructor

[image]

Revit 2010 API
GutterTypeSetIterator Constructor
GutterTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GutterTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GutterTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GutterTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


GutterTypeSetIterator Methods

[image] [image]

Revit 2010 API
GutterTypeSetIterator Methods
GutterTypeSetIterator Class See Also Send Feedback

The GutterTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GutterTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
GutterTypeSetIterator..::.MoveNext Method
GutterTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GutterTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
GutterTypeSetIterator..::.Reset Method
GutterTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GutterTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


GutterTypeSetIterator Properties

[image] [image]

Revit 2010 API
GutterTypeSetIterator Properties
GutterTypeSetIterator Class See Also Send Feedback

The GutterTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GutterTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
GutterTypeSetIterator..::.Current Property
GutterTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GutterTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


HostedSweepType Class

[image]

Revit 2010 API
HostedSweepType Class
Members See Also Send Feedback
An object that represents the attributes for sweep host objects in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class HostedSweepType : HostObjAttributes
Visual Basic (Declaration)
Public Class HostedSweepType _
    Inherits HostObjAttributes
Visual C++
public ref class HostedSweepType : public HostObjAttributes

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.HostObjAttributes
Autodesk.Revit.Symbols..::.HostedSweepType
Autodesk.Revit.Symbols..::.FasciaType
Autodesk.Revit.Symbols..::.GutterType
Autodesk.Revit.Symbols..::.SlabEdgeType

See Also

HostedSweepType Members
Autodesk.Revit.Symbols Namespace


HostedSweepType Members

[image] [image]

Revit 2010 API
HostedSweepType Members
HostedSweepType Class Constructors Methods Properties See Also Send Feedback

The HostedSweepType type exposes the following members.

Constructors

Name | Description
HostedSweepType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

HostedSweepType Class
Autodesk.Revit.Symbols Namespace


HostedSweepType Constructor

[image]

Revit 2010 API
HostedSweepType Constructor
HostedSweepType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public HostedSweepType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HostedSweepType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

HostedSweepType Class
Autodesk.Revit.Symbols Namespace


HostedSweepType Methods

[image] [image]

Revit 2010 API
HostedSweepType Methods
HostedSweepType Class See Also Send Feedback

The HostedSweepType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HostedSweepType Class
Autodesk.Revit.Symbols Namespace


HostedSweepType Properties

[image] [image]

Revit 2010 API
HostedSweepType Properties
HostedSweepType Class See Also Send Feedback

The HostedSweepType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

HostedSweepType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
HostedSweepType..::.Parameter Property
HostedSweepType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

HostedSweepType Class
HostedSweepType Members
Autodesk.Revit.Symbols Namespace


HostObjAttributes Class

[image]

Revit 2010 API
HostObjAttributes Class
Members See Also Send Feedback
An object that represents characteristics of several kinds of type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class HostObjAttributes : Symbol
Visual Basic (Declaration)
Public Class HostObjAttributes _
    Inherits Symbol
Visual C++
public ref class HostObjAttributes : public Symbol

Remarks

This object provides access to structural layering components for any object derived from it, such as wall types and floor types.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.HostObjAttributes
Autodesk.Revit.Symbols..::.ContFootingType
Autodesk.Revit.Symbols..::.CurtainSystemType
Autodesk.Revit.Symbols..::.FloorType
Autodesk.Revit.Symbols..::.HostedSweepType
Autodesk.Revit.Symbols..::.RoofType
Autodesk.Revit.Symbols..::.WallType

See Also

HostObjAttributes Members
Autodesk.Revit.Symbols Namespace


HostObjAttributes Members

[image] [image]

Revit 2010 API
HostObjAttributes Members
HostObjAttributes Class Constructors Methods Properties See Also Send Feedback

The HostObjAttributes type exposes the following members.

Constructors

Name | Description
HostObjAttributes | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

HostObjAttributes Class
Autodesk.Revit.Symbols Namespace


HostObjAttributes Constructor

[image]

Revit 2010 API
HostObjAttributes Constructor
HostObjAttributes Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public HostObjAttributes()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HostObjAttributes()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

HostObjAttributes Class
Autodesk.Revit.Symbols Namespace


HostObjAttributes Methods

[image] [image]

Revit 2010 API
HostObjAttributes Methods
HostObjAttributes Class See Also Send Feedback

The HostObjAttributes type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HostObjAttributes Class
Autodesk.Revit.Symbols Namespace


HostObjAttributes Properties

[image] [image]

Revit 2010 API
HostObjAttributes Properties
HostObjAttributes Class See Also Send Feedback

The HostObjAttributes type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

HostObjAttributes Class
Autodesk.Revit.Symbols Namespace


CompoundStructure Property

[image]

Revit 2010 API
HostObjAttributes..::.CompoundStructure Property
HostObjAttributes Class See Also Send Feedback
Returns an object that represents the compound structure of the element.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CompoundStructure CompoundStructure { get; }
Visual Basic (Declaration)
Public ReadOnly Property CompoundStructure As CompoundStructure
Visual C++
public:
property CompoundStructure^ CompoundStructure {
    CompoundStructure^ get ();
}

Remarks

From this object the layers of a compound structure can be accessed. If the element does not have a compound structure then this method will return Nothing.

See Also

HostObjAttributes Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
HostObjAttributes..::.Parameter Property
HostObjAttributes Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

HostObjAttributes Class
HostObjAttributes Members
Autodesk.Revit.Symbols Namespace


InsertableObject Class

[image]

Revit 2010 API
InsertableObject Class
Members See Also Send Feedback
A base class you all types that are insertable.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class InsertableObject : Symbol
Visual Basic (Declaration)
Public Class InsertableObject _
    Inherits Symbol
Visual C++
public ref class InsertableObject : public Symbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.InsertableObject
Autodesk.Revit.Symbols..::.FamilySymbol

See Also

InsertableObject Members
Autodesk.Revit.Symbols Namespace


InsertableObject Members

[image] [image]

Revit 2010 API
InsertableObject Members
InsertableObject Class Constructors Methods Properties See Also Send Feedback

The InsertableObject type exposes the following members.

Constructors

Name | Description
InsertableObject | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

InsertableObject Class
Autodesk.Revit.Symbols Namespace


InsertableObject Constructor

[image]

Revit 2010 API
InsertableObject Constructor
InsertableObject Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InsertableObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InsertableObject()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

InsertableObject Class
Autodesk.Revit.Symbols Namespace


InsertableObject Methods

[image] [image]

Revit 2010 API
InsertableObject Methods
InsertableObject Class See Also Send Feedback

The InsertableObject type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsertableObject Class
Autodesk.Revit.Symbols Namespace


InsertableObject Properties

[image] [image]

Revit 2010 API
InsertableObject Properties
InsertableObject Class See Also Send Feedback

The InsertableObject type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

InsertableObject Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
InsertableObject..::.Parameter Property
InsertableObject Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

InsertableObject Class
InsertableObject Members
Autodesk.Revit.Symbols Namespace


LevelType Class

[image]

Revit 2010 API
LevelType Class
Members See Also Send Feedback
An object that represents a Level type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LevelType : Symbol
Visual Basic (Declaration)
Public Class LevelType _
    Inherits Symbol
Visual C++
public ref class LevelType : public Symbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.LevelType

See Also

LevelType Members
Autodesk.Revit.Symbols Namespace


LevelType Members

[image] [image]

Revit 2010 API
LevelType Members
LevelType Class Constructors Methods Properties See Also Send Feedback

The LevelType type exposes the following members.

Constructors

Name | Description
LevelType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LevelType Class
Autodesk.Revit.Symbols Namespace


LevelType Constructor

[image]

Revit 2010 API
LevelType Constructor
LevelType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LevelType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LevelType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LevelType Class
Autodesk.Revit.Symbols Namespace


LevelType Methods

[image] [image]

Revit 2010 API
LevelType Methods
LevelType Class See Also Send Feedback

The LevelType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LevelType Class
Autodesk.Revit.Symbols Namespace


LevelType Properties

[image] [image]

Revit 2010 API
LevelType Properties
LevelType Class See Also Send Feedback

The LevelType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LevelType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
LevelType..::.Parameter Property
LevelType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LevelType Class
LevelType Members
Autodesk.Revit.Symbols Namespace


LevelTypeSet Class

[image]

Revit 2010 API
LevelTypeSet Class
Members See Also Send Feedback
A set that contains level types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LevelTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class LevelTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LevelTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.LevelTypeSet

See Also

LevelTypeSet Members
Autodesk.Revit.Symbols Namespace


LevelTypeSet Members

[image] [image]

Revit 2010 API
LevelTypeSet Members
LevelTypeSet Class Constructors Methods Properties See Also Send Feedback

The LevelTypeSet type exposes the following members.

Constructors

Name | Description
LevelTypeSet | Initializes a new instance of the LevelTypeSet class

Methods

Name | Description
Clear | Removes every level type from the set, rendering it empty.
Contains | Tests for the existence of a level type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified level type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified level type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of level types that are in the set.

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


LevelTypeSet Constructor

[image]

Revit 2010 API
LevelTypeSet Constructor
LevelTypeSet Class See Also Send Feedback
Initializes a new instance of the LevelTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LevelTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LevelTypeSet()

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


LevelTypeSet Methods

[image] [image]

Revit 2010 API
LevelTypeSet Methods
LevelTypeSet Class See Also Send Feedback

The LevelTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every level type from the set, rendering it empty.
Contains | Tests for the existence of a level type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified level type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified level type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
LevelTypeSet..::.Clear Method
LevelTypeSet Class See Also Send Feedback
Removes every level type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
LevelTypeSet..::.Contains Method
LevelTypeSet Class See Also Send Feedback
Tests for the existence of a level type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    LevelType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As LevelType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    LevelType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.LevelType
The level type to be searched for.

Return Value

The Contains method returns True if the level type is within the set, otherwise False.

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
LevelTypeSet..::.Erase Method
LevelTypeSet Class See Also Send Feedback
Removes a specified level type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    LevelType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As LevelType _
) As Integer
Visual C++
public:
virtual int Erase(
    LevelType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.LevelType
The level type to be erased.

Return Value

The number of level types that were erased from the set.

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
LevelTypeSet..::.ForwardIterator Method
LevelTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual LevelTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LevelTypeSetIterator
Visual C++
public:
virtual LevelTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
LevelTypeSet..::.GetEnumerator Method
LevelTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
LevelTypeSet..::.Insert Method
LevelTypeSet Class See Also Send Feedback
Insert the specified level type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    LevelType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As LevelType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    LevelType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.LevelType
The level type to be inserted into the set.

Return Value

Returns whether the level type was inserted into the set.

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
LevelTypeSet..::.ReverseIterator Method
LevelTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual LevelTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LevelTypeSetIterator
Visual C++
public:
virtual LevelTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


LevelTypeSet Properties

[image] [image]

Revit 2010 API
LevelTypeSet Properties
LevelTypeSet Class See Also Send Feedback

The LevelTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of level types that are in the set.

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
LevelTypeSet..::.IsEmpty Property
LevelTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
LevelTypeSet..::.Size Property
LevelTypeSet Class See Also Send Feedback
Returns the number of level types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LevelTypeSet Class
Autodesk.Revit.Symbols Namespace


LevelTypeSetIterator Class

[image]

Revit 2010 API
LevelTypeSetIterator Class
Members See Also Send Feedback
An iterator to a level type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class LevelTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class LevelTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LevelTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.LevelTypeSetIterator

See Also

LevelTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


LevelTypeSetIterator Members

[image] [image]

Revit 2010 API
LevelTypeSetIterator Members
LevelTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The LevelTypeSetIterator type exposes the following members.

Constructors

Name | Description
LevelTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LevelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


LevelTypeSetIterator Constructor

[image]

Revit 2010 API
LevelTypeSetIterator Constructor
LevelTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LevelTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LevelTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LevelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


LevelTypeSetIterator Methods

[image] [image]

Revit 2010 API
LevelTypeSetIterator Methods
LevelTypeSetIterator Class See Also Send Feedback

The LevelTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LevelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
LevelTypeSetIterator..::.MoveNext Method
LevelTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LevelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
LevelTypeSetIterator..::.Reset Method
LevelTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LevelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


LevelTypeSetIterator Properties

[image] [image]

Revit 2010 API
LevelTypeSetIterator Properties
LevelTypeSetIterator Class See Also Send Feedback

The LevelTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LevelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
LevelTypeSetIterator..::.Current Property
LevelTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LevelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


LineAndTextAttrSymbol Class

[image]

Revit 2010 API
LineAndTextAttrSymbol Class
Members See Also Send Feedback
An object that represents a dimension style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LineAndTextAttrSymbol : Symbol
Visual Basic (Declaration)
Public Class LineAndTextAttrSymbol _
    Inherits Symbol
Visual C++
public ref class LineAndTextAttrSymbol : public Symbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.LineAndTextAttrSymbol
Autodesk.Revit.Symbols..::.GridType
Autodesk.Revit.Symbols..::.TextElementType

See Also

LineAndTextAttrSymbol Members
Autodesk.Revit.Symbols Namespace


LineAndTextAttrSymbol Members

[image] [image]

Revit 2010 API
LineAndTextAttrSymbol Members
LineAndTextAttrSymbol Class Constructors Methods Properties See Also Send Feedback

The LineAndTextAttrSymbol type exposes the following members.

Constructors

Name | Description
LineAndTextAttrSymbol | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LineAndTextAttrSymbol Class
Autodesk.Revit.Symbols Namespace


LineAndTextAttrSymbol Constructor

[image]

Revit 2010 API
LineAndTextAttrSymbol Constructor
LineAndTextAttrSymbol Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LineAndTextAttrSymbol()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LineAndTextAttrSymbol()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LineAndTextAttrSymbol Class
Autodesk.Revit.Symbols Namespace


LineAndTextAttrSymbol Methods

[image] [image]

Revit 2010 API
LineAndTextAttrSymbol Methods
LineAndTextAttrSymbol Class See Also Send Feedback

The LineAndTextAttrSymbol type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineAndTextAttrSymbol Class
Autodesk.Revit.Symbols Namespace


LineAndTextAttrSymbol Properties

[image] [image]

Revit 2010 API
LineAndTextAttrSymbol Properties
LineAndTextAttrSymbol Class See Also Send Feedback

The LineAndTextAttrSymbol type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LineAndTextAttrSymbol Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
LineAndTextAttrSymbol..::.Parameter Property
LineAndTextAttrSymbol Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LineAndTextAttrSymbol Class
LineAndTextAttrSymbol Members
Autodesk.Revit.Symbols Namespace


LineLoadType Class

[image]

Revit 2010 API
LineLoadType Class
Members See Also Send Feedback
An object that represents a Load type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LineLoadType : LoadTypeBase
Visual Basic (Declaration)
Public Class LineLoadType _
    Inherits LoadTypeBase
Visual C++
public ref class LineLoadType : public LoadTypeBase

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.LoadTypeBase
Autodesk.Revit.Symbols..::.LineLoadType

See Also

LineLoadType Members
Autodesk.Revit.Symbols Namespace


LineLoadType Members

[image] [image]

Revit 2010 API
LineLoadType Members
LineLoadType Class Constructors Methods Properties See Also Send Feedback

The LineLoadType type exposes the following members.

Constructors

Name | Description
LineLoadType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LineLoadType Class
Autodesk.Revit.Symbols Namespace


LineLoadType Constructor

[image]

Revit 2010 API
LineLoadType Constructor
LineLoadType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LineLoadType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LineLoadType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LineLoadType Class
Autodesk.Revit.Symbols Namespace


LineLoadType Methods

[image] [image]

Revit 2010 API
LineLoadType Methods
LineLoadType Class See Also Send Feedback

The LineLoadType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineLoadType Class
Autodesk.Revit.Symbols Namespace


LineLoadType Properties

[image] [image]

Revit 2010 API
LineLoadType Properties
LineLoadType Class See Also Send Feedback

The LineLoadType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LineLoadType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
LineLoadType..::.Parameter Property
LineLoadType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LineLoadType Class
LineLoadType Members
Autodesk.Revit.Symbols Namespace


LineLoadTypeSet Class

[image]

Revit 2010 API
LineLoadTypeSet Class
Members See Also Send Feedback
A set that contains lineload types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LineLoadTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class LineLoadTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LineLoadTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.LineLoadTypeSet

See Also

LineLoadTypeSet Members
Autodesk.Revit.Symbols Namespace


LineLoadTypeSet Members

[image] [image]

Revit 2010 API
LineLoadTypeSet Members
LineLoadTypeSet Class Constructors Methods Properties See Also Send Feedback

The LineLoadTypeSet type exposes the following members.

Constructors

Name | Description
LineLoadTypeSet | Initializes a new instance of the LineLoadTypeSet class

Methods

Name | Description
Clear | Removes every lineload type from the set, rendering it empty.
Contains | Tests for the existence of a lineload type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified lineload type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified lineload type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of lineload types that are in the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


LineLoadTypeSet Constructor

[image]

Revit 2010 API
LineLoadTypeSet Constructor
LineLoadTypeSet Class See Also Send Feedback
Initializes a new instance of the LineLoadTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LineLoadTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LineLoadTypeSet()

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


LineLoadTypeSet Methods

[image] [image]

Revit 2010 API
LineLoadTypeSet Methods
LineLoadTypeSet Class See Also Send Feedback

The LineLoadTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every lineload type from the set, rendering it empty.
Contains | Tests for the existence of a lineload type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified lineload type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified lineload type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
LineLoadTypeSet..::.Clear Method
LineLoadTypeSet Class See Also Send Feedback
Removes every lineload type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
LineLoadTypeSet..::.Contains Method
LineLoadTypeSet Class See Also Send Feedback
Tests for the existence of a lineload type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    LineLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As LineLoadType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    LineLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.LineLoadType
The lineload type to be searched for.

Return Value

The Contains method returns True if the lineload type is within the set, otherwise False.

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
LineLoadTypeSet..::.Erase Method
LineLoadTypeSet Class See Also Send Feedback
Removes a specified lineload type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    LineLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As LineLoadType _
) As Integer
Visual C++
public:
virtual int Erase(
    LineLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.LineLoadType
The lineload type to be erased.

Return Value

The number of lineload types that were erased from the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
LineLoadTypeSet..::.ForwardIterator Method
LineLoadTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual LineLoadTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LineLoadTypeSetIterator
Visual C++
public:
virtual LineLoadTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
LineLoadTypeSet..::.GetEnumerator Method
LineLoadTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
LineLoadTypeSet..::.Insert Method
LineLoadTypeSet Class See Also Send Feedback
Insert the specified lineload type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    LineLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As LineLoadType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    LineLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.LineLoadType
The lineload type to be inserted into the set.

Return Value

Returns whether the lineload type was inserted into the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
LineLoadTypeSet..::.ReverseIterator Method
LineLoadTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual LineLoadTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LineLoadTypeSetIterator
Visual C++
public:
virtual LineLoadTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


LineLoadTypeSet Properties

[image] [image]

Revit 2010 API
LineLoadTypeSet Properties
LineLoadTypeSet Class See Also Send Feedback

The LineLoadTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of lineload types that are in the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
LineLoadTypeSet..::.IsEmpty Property
LineLoadTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
LineLoadTypeSet..::.Size Property
LineLoadTypeSet Class See Also Send Feedback
Returns the number of lineload types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LineLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


LineLoadTypeSetIterator Class

[image]

Revit 2010 API
LineLoadTypeSetIterator Class
Members See Also Send Feedback
An iterator to a lineload type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class LineLoadTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class LineLoadTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LineLoadTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.LineLoadTypeSetIterator

See Also

LineLoadTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


LineLoadTypeSetIterator Members

[image] [image]

Revit 2010 API
LineLoadTypeSetIterator Members
LineLoadTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The LineLoadTypeSetIterator type exposes the following members.

Constructors

Name | Description
LineLoadTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


LineLoadTypeSetIterator Constructor

[image]

Revit 2010 API
LineLoadTypeSetIterator Constructor
LineLoadTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LineLoadTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LineLoadTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


LineLoadTypeSetIterator Methods

[image] [image]

Revit 2010 API
LineLoadTypeSetIterator Methods
LineLoadTypeSetIterator Class See Also Send Feedback

The LineLoadTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
LineLoadTypeSetIterator..::.MoveNext Method
LineLoadTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
LineLoadTypeSetIterator..::.Reset Method
LineLoadTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


LineLoadTypeSetIterator Properties

[image] [image]

Revit 2010 API
LineLoadTypeSetIterator Properties
LineLoadTypeSetIterator Class See Also Send Feedback

The LineLoadTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
LineLoadTypeSetIterator..::.Current Property
LineLoadTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


LoadTypeBase Class

[image]

Revit 2010 API
LoadTypeBase Class
Members See Also Send Feedback
An object that represents a Load type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LoadTypeBase : Symbol
Visual Basic (Declaration)
Public Class LoadTypeBase _
    Inherits Symbol
Visual C++
public ref class LoadTypeBase : public Symbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.LoadTypeBase
Autodesk.Revit.Symbols..::.AreaLoadType
Autodesk.Revit.Symbols..::.LineLoadType
Autodesk.Revit.Symbols..::.PointLoadType

See Also

LoadTypeBase Members
Autodesk.Revit.Symbols Namespace


LoadTypeBase Members

[image] [image]

Revit 2010 API
LoadTypeBase Members
LoadTypeBase Class Constructors Methods Properties See Also Send Feedback

The LoadTypeBase type exposes the following members.

Constructors

Name | Description
LoadTypeBase | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LoadTypeBase Class
Autodesk.Revit.Symbols Namespace


LoadTypeBase Constructor

[image]

Revit 2010 API
LoadTypeBase Constructor
LoadTypeBase Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadTypeBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadTypeBase()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadTypeBase Class
Autodesk.Revit.Symbols Namespace


LoadTypeBase Methods

[image] [image]

Revit 2010 API
LoadTypeBase Methods
LoadTypeBase Class See Also Send Feedback

The LoadTypeBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadTypeBase Class
Autodesk.Revit.Symbols Namespace


LoadTypeBase Properties

[image] [image]

Revit 2010 API
LoadTypeBase Properties
LoadTypeBase Class See Also Send Feedback

The LoadTypeBase type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

LoadTypeBase Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
LoadTypeBase..::.Parameter Property
LoadTypeBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LoadTypeBase Class
LoadTypeBase Members
Autodesk.Revit.Symbols Namespace


LoadTypeBaseSet Class

[image]

Revit 2010 API
LoadTypeBaseSet Class
Members See Also Send Feedback
A set that contains load type bases.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LoadTypeBaseSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class LoadTypeBaseSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LoadTypeBaseSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.LoadTypeBaseSet

See Also

LoadTypeBaseSet Members
Autodesk.Revit.Symbols Namespace


LoadTypeBaseSet Members

[image] [image]

Revit 2010 API
LoadTypeBaseSet Members
LoadTypeBaseSet Class Constructors Methods Properties See Also Send Feedback

The LoadTypeBaseSet type exposes the following members.

Constructors

Name | Description
LoadTypeBaseSet | Initializes a new instance of the LoadTypeBaseSet class

Methods

Name | Description
Clear | Removes every load type base from the set, rendering it empty.
Contains | Tests for the existence of a load type base within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified load type base from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified load type base into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of load type bases that are in the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


LoadTypeBaseSet Constructor

[image]

Revit 2010 API
LoadTypeBaseSet Constructor
LoadTypeBaseSet Class See Also Send Feedback
Initializes a new instance of the LoadTypeBaseSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadTypeBaseSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadTypeBaseSet()

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


LoadTypeBaseSet Methods

[image] [image]

Revit 2010 API
LoadTypeBaseSet Methods
LoadTypeBaseSet Class See Also Send Feedback

The LoadTypeBaseSet type exposes the following members.

Methods

Name | Description
Clear | Removes every load type base from the set, rendering it empty.
Contains | Tests for the existence of a load type base within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified load type base from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified load type base into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
LoadTypeBaseSet..::.Clear Method
LoadTypeBaseSet Class See Also Send Feedback
Removes every load type base from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
LoadTypeBaseSet..::.Contains Method
LoadTypeBaseSet Class See Also Send Feedback
Tests for the existence of a load type base within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    LoadTypeBase item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As LoadTypeBase _
) As Boolean
Visual C++
public:
virtual bool Contains(
    LoadTypeBase^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.LoadTypeBase
The load type base to be searched for.

Return Value

The Contains method returns True if the load type base is within the set, otherwise False.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
LoadTypeBaseSet..::.Erase Method
LoadTypeBaseSet Class See Also Send Feedback
Removes a specified load type base from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    LoadTypeBase item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As LoadTypeBase _
) As Integer
Visual C++
public:
virtual int Erase(
    LoadTypeBase^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.LoadTypeBase
The load type base to be erased.

Return Value

The number of load type bases that were erased from the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
LoadTypeBaseSet..::.ForwardIterator Method
LoadTypeBaseSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual LoadTypeBaseSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LoadTypeBaseSetIterator
Visual C++
public:
virtual LoadTypeBaseSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
LoadTypeBaseSet..::.GetEnumerator Method
LoadTypeBaseSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
LoadTypeBaseSet..::.Insert Method
LoadTypeBaseSet Class See Also Send Feedback
Insert the specified load type base into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    LoadTypeBase item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As LoadTypeBase _
) As Boolean
Visual C++
public:
virtual bool Insert(
    LoadTypeBase^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.LoadTypeBase
The load type base to be inserted into the set.

Return Value

Returns whether the load type base was inserted into the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
LoadTypeBaseSet..::.ReverseIterator Method
LoadTypeBaseSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual LoadTypeBaseSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LoadTypeBaseSetIterator
Visual C++
public:
virtual LoadTypeBaseSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


LoadTypeBaseSet Properties

[image] [image]

Revit 2010 API
LoadTypeBaseSet Properties
LoadTypeBaseSet Class See Also Send Feedback

The LoadTypeBaseSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of load type bases that are in the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
LoadTypeBaseSet..::.IsEmpty Property
LoadTypeBaseSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
LoadTypeBaseSet..::.Size Property
LoadTypeBaseSet Class See Also Send Feedback
Returns the number of load type bases that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LoadTypeBaseSet Class
Autodesk.Revit.Symbols Namespace


LoadTypeBaseSetIterator Class

[image]

Revit 2010 API
LoadTypeBaseSetIterator Class
Members See Also Send Feedback
An iterator to a load type base set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class LoadTypeBaseSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class LoadTypeBaseSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LoadTypeBaseSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.LoadTypeBaseSetIterator

See Also

LoadTypeBaseSetIterator Members
Autodesk.Revit.Symbols Namespace


LoadTypeBaseSetIterator Members

[image] [image]

Revit 2010 API
LoadTypeBaseSetIterator Members
LoadTypeBaseSetIterator Class Constructors Methods Properties See Also Send Feedback

The LoadTypeBaseSetIterator type exposes the following members.

Constructors

Name | Description
LoadTypeBaseSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.Symbols Namespace


LoadTypeBaseSetIterator Constructor

[image]

Revit 2010 API
LoadTypeBaseSetIterator Constructor
LoadTypeBaseSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadTypeBaseSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadTypeBaseSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.Symbols Namespace


LoadTypeBaseSetIterator Methods

[image] [image]

Revit 2010 API
LoadTypeBaseSetIterator Methods
LoadTypeBaseSetIterator Class See Also Send Feedback

The LoadTypeBaseSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
LoadTypeBaseSetIterator..::.MoveNext Method
LoadTypeBaseSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
LoadTypeBaseSetIterator..::.Reset Method
LoadTypeBaseSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.Symbols Namespace


LoadTypeBaseSetIterator Properties

[image] [image]

Revit 2010 API
LoadTypeBaseSetIterator Properties
LoadTypeBaseSetIterator Class See Also Send Feedback

The LoadTypeBaseSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
LoadTypeBaseSetIterator..::.Current Property
LoadTypeBaseSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.Symbols Namespace


MEPBuildingConstruction Class

[image]

Revit 2010 API
MEPBuildingConstruction Class
Members See Also Send Feedback
Construction definition for Project Information.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MEPBuildingConstruction : Symbol
Visual Basic (Declaration)
Public Class MEPBuildingConstruction _
    Inherits Symbol
Visual C++
public ref class MEPBuildingConstruction : public Symbol

Remarks

This is used to define the information in Constructions.xml.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.MEPBuildingConstruction

See Also

MEPBuildingConstruction Members
Autodesk.Revit.Symbols Namespace


MEPBuildingConstruction Members

[image] [image]

Revit 2010 API
MEPBuildingConstruction Members
MEPBuildingConstruction Class Constructors Methods Properties See Also Send Feedback

The MEPBuildingConstruction type exposes the following members.

Constructors

Name | Description
MEPBuildingConstruction | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
BuildingConstruction | Get or Set the Building Construction of the Project Information.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Constructions | Get all the Building Constructions according to the specific Construction type.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

MEPBuildingConstruction Class
Autodesk.Revit.Symbols Namespace


MEPBuildingConstruction Constructor

[image]

Revit 2010 API
MEPBuildingConstruction Constructor
MEPBuildingConstruction Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MEPBuildingConstruction()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MEPBuildingConstruction()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MEPBuildingConstruction Class
Autodesk.Revit.Symbols Namespace


MEPBuildingConstruction Methods

[image] [image]

Revit 2010 API
MEPBuildingConstruction Methods
MEPBuildingConstruction Class See Also Send Feedback

The MEPBuildingConstruction type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPBuildingConstruction Class
Autodesk.Revit.Symbols Namespace


MEPBuildingConstruction Properties

[image] [image]

Revit 2010 API
MEPBuildingConstruction Properties
MEPBuildingConstruction Class See Also Send Feedback

The MEPBuildingConstruction type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
BuildingConstruction | Get or Set the Building Construction of the Project Information.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Constructions | Get all the Building Constructions according to the specific Construction type.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

MEPBuildingConstruction Class
Autodesk.Revit.Symbols Namespace


BuildingConstruction Property

[image]

Revit 2010 API
MEPBuildingConstruction..::.BuildingConstruction Property
MEPBuildingConstruction Class See Also Send Feedback
Get or Set the Building Construction of the Project Information.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Construction BuildingConstruction[
    ConstructionType constructionType
] { get; set; }
Visual Basic (Declaration)
Public Property BuildingConstruction ( _
    constructionType As ConstructionType _
) As Construction
Visual C++
public:
property Construction^ BuildingConstruction[ConstructionType constructionType] {
    Construction^ get (ConstructionType constructionType);
    void set (ConstructionType constructionType, Construction^ value);
}

Parameters

constructionType
Type: Autodesk.Revit.Parameters..::.ConstructionType
The Construction Type to be set the Building Construction.

Remarks

This property is used to get or set the Building Construction of the Project Information.

See Also

MEPBuildingConstruction Class
Autodesk.Revit.Symbols Namespace


Constructions Property

[image]

Revit 2010 API
MEPBuildingConstruction..::.Constructions Property
MEPBuildingConstruction Class See Also Send Feedback
Get all the Building Constructions according to the specific Construction type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Set Constructions[
    ConstructionType constructionType
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Constructions ( _
    constructionType As ConstructionType _
) As Set
Visual C++
public:
property Set^ Constructions[ConstructionType constructionType] {
    Set^ get (ConstructionType constructionType);
}

Parameters

constructionType
Type: Autodesk.Revit.Parameters..::.ConstructionType
The Construction Type to be set the Building Construction.

Remarks

This property is used to get or set the Building Service of the Project Information.

See Also

MEPBuildingConstruction Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
MEPBuildingConstruction..::.Parameter Property
MEPBuildingConstruction Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MEPBuildingConstruction Class
MEPBuildingConstruction Members
Autodesk.Revit.Symbols Namespace


MEPBuildingConstructionSet Class

[image]

Revit 2010 API
MEPBuildingConstructionSet Class
Members See Also Send Feedback
A set that contains MEPBuildingConstructions.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MEPBuildingConstructionSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class MEPBuildingConstructionSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class MEPBuildingConstructionSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.MEPBuildingConstructionSet

See Also

MEPBuildingConstructionSet Members
Autodesk.Revit.Symbols Namespace


MEPBuildingConstructionSet Members

[image] [image]

Revit 2010 API
MEPBuildingConstructionSet Members
MEPBuildingConstructionSet Class Constructors Methods Properties See Also Send Feedback

The MEPBuildingConstructionSet type exposes the following members.

Constructors

Name | Description
MEPBuildingConstructionSet | Initializes a new instance of the MEPBuildingConstructionSet class

Methods

Name | Description
Clear | Removes every MEPBuildingConstruction from the set, rendering it empty.
Contains | Tests for the existence of a MEPBuildingConstruction within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified MEPBuildingConstruction from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified MEPBuildingConstruction into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of MEPBuildingConstructions that are in the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


MEPBuildingConstructionSet Constructor

[image]

Revit 2010 API
MEPBuildingConstructionSet Constructor
MEPBuildingConstructionSet Class See Also Send Feedback
Initializes a new instance of the MEPBuildingConstructionSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MEPBuildingConstructionSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MEPBuildingConstructionSet()

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


MEPBuildingConstructionSet Methods

[image] [image]

Revit 2010 API
MEPBuildingConstructionSet Methods
MEPBuildingConstructionSet Class See Also Send Feedback

The MEPBuildingConstructionSet type exposes the following members.

Methods

Name | Description
Clear | Removes every MEPBuildingConstruction from the set, rendering it empty.
Contains | Tests for the existence of a MEPBuildingConstruction within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified MEPBuildingConstruction from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified MEPBuildingConstruction into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
MEPBuildingConstructionSet..::.Clear Method
MEPBuildingConstructionSet Class See Also Send Feedback
Removes every MEPBuildingConstruction from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
MEPBuildingConstructionSet..::.Contains Method
MEPBuildingConstructionSet Class See Also Send Feedback
Tests for the existence of a MEPBuildingConstruction within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    MEPBuildingConstruction item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As MEPBuildingConstruction _
) As Boolean
Visual C++
public:
virtual bool Contains(
    MEPBuildingConstruction^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.MEPBuildingConstruction
The MEPBuildingConstruction to be searched for.

Return Value

The Contains method returns True if the MEPBuildingConstruction is within the set, otherwise False.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
MEPBuildingConstructionSet..::.Erase Method
MEPBuildingConstructionSet Class See Also Send Feedback
Removes a specified MEPBuildingConstruction from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    MEPBuildingConstruction item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As MEPBuildingConstruction _
) As Integer
Visual C++
public:
virtual int Erase(
    MEPBuildingConstruction^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.MEPBuildingConstruction
The MEPBuildingConstruction to be erased.

Return Value

The number of MEPBuildingConstructions that were erased from the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
MEPBuildingConstructionSet..::.ForwardIterator Method
MEPBuildingConstructionSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual MEPBuildingConstructionSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As MEPBuildingConstructionSetIterator
Visual C++
public:
virtual MEPBuildingConstructionSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
MEPBuildingConstructionSet..::.GetEnumerator Method
MEPBuildingConstructionSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
MEPBuildingConstructionSet..::.Insert Method
MEPBuildingConstructionSet Class See Also Send Feedback
Insert the specified MEPBuildingConstruction into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    MEPBuildingConstruction item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As MEPBuildingConstruction _
) As Boolean
Visual C++
public:
virtual bool Insert(
    MEPBuildingConstruction^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.MEPBuildingConstruction
The MEPBuildingConstruction to be inserted into the set.

Return Value

Returns whether the MEPBuildingConstruction was inserted into the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
MEPBuildingConstructionSet..::.ReverseIterator Method
MEPBuildingConstructionSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual MEPBuildingConstructionSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As MEPBuildingConstructionSetIterator
Visual C++
public:
virtual MEPBuildingConstructionSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


MEPBuildingConstructionSet Properties

[image] [image]

Revit 2010 API
MEPBuildingConstructionSet Properties
MEPBuildingConstructionSet Class See Also Send Feedback

The MEPBuildingConstructionSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of MEPBuildingConstructions that are in the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
MEPBuildingConstructionSet..::.IsEmpty Property
MEPBuildingConstructionSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
MEPBuildingConstructionSet..::.Size Property
MEPBuildingConstructionSet Class See Also Send Feedback
Returns the number of MEPBuildingConstructions that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.Symbols Namespace


MEPBuildingConstructionSetIterator Class

[image]

Revit 2010 API
MEPBuildingConstructionSetIterator Class
Members See Also Send Feedback
An iterator to a MEPBuildingConstruction set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class MEPBuildingConstructionSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class MEPBuildingConstructionSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class MEPBuildingConstructionSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.MEPBuildingConstructionSetIterator

See Also

MEPBuildingConstructionSetIterator Members
Autodesk.Revit.Symbols Namespace


MEPBuildingConstructionSetIterator Members

[image] [image]

Revit 2010 API
MEPBuildingConstructionSetIterator Members
MEPBuildingConstructionSetIterator Class Constructors Methods Properties See Also Send Feedback

The MEPBuildingConstructionSetIterator type exposes the following members.

Constructors

Name | Description
MEPBuildingConstructionSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.Symbols Namespace


MEPBuildingConstructionSetIterator Constructor

[image]

Revit 2010 API
MEPBuildingConstructionSetIterator Constructor
MEPBuildingConstructionSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MEPBuildingConstructionSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MEPBuildingConstructionSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.Symbols Namespace


MEPBuildingConstructionSetIterator Methods

[image] [image]

Revit 2010 API
MEPBuildingConstructionSetIterator Methods
MEPBuildingConstructionSetIterator Class See Also Send Feedback

The MEPBuildingConstructionSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
MEPBuildingConstructionSetIterator..::.MoveNext Method
MEPBuildingConstructionSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
MEPBuildingConstructionSetIterator..::.Reset Method
MEPBuildingConstructionSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.Symbols Namespace


MEPBuildingConstructionSetIterator Properties

[image] [image]

Revit 2010 API
MEPBuildingConstructionSetIterator Properties
MEPBuildingConstructionSetIterator Class See Also Send Feedback

The MEPBuildingConstructionSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
MEPBuildingConstructionSetIterator..::.Current Property
MEPBuildingConstructionSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.Symbols Namespace


ModelTextType Class

[image]

Revit 2010 API
ModelTextType Class
Members See Also Send Feedback
A model text type symbol in the Autodesk Revit Family document.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ModelTextType : Symbol
Visual Basic (Declaration)
Public Class ModelTextType _
    Inherits Symbol
Visual C++
public ref class ModelTextType : public Symbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.ModelTextType

See Also

ModelTextType Members
Autodesk.Revit.Symbols Namespace


ModelTextType Members

[image] [image]

Revit 2010 API
ModelTextType Members
ModelTextType Class Constructors Methods Properties See Also Send Feedback

The ModelTextType type exposes the following members.

Constructors

Name | Description
ModelTextType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelTextType Class
Autodesk.Revit.Symbols Namespace


ModelTextType Constructor

[image]

Revit 2010 API
ModelTextType Constructor
ModelTextType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelTextType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelTextType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelTextType Class
Autodesk.Revit.Symbols Namespace


ModelTextType Methods

[image] [image]

Revit 2010 API
ModelTextType Methods
ModelTextType Class See Also Send Feedback

The ModelTextType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelTextType Class
Autodesk.Revit.Symbols Namespace


ModelTextType Properties

[image] [image]

Revit 2010 API
ModelTextType Properties
ModelTextType Class See Also Send Feedback

The ModelTextType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

ModelTextType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
ModelTextType..::.Parameter Property
ModelTextType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ModelTextType Class
ModelTextType Members
Autodesk.Revit.Symbols Namespace


MullionType Class

[image]

Revit 2010 API
MullionType Class
Members See Also Send Feedback
An object that represents a mullion type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MullionType : FamilySymbol
Visual Basic (Declaration)
Public Class MullionType _
    Inherits FamilySymbol
Visual C++
public ref class MullionType : public FamilySymbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.InsertableObject
Autodesk.Revit.Symbols..::.FamilySymbol
Autodesk.Revit.Symbols..::.MullionType

See Also

MullionType Members
Autodesk.Revit.Symbols Namespace


MullionType Members

[image] [image]

Revit 2010 API
MullionType Members
MullionType Class Constructors Methods Properties See Also Send Feedback

The MullionType type exposes the following members.

Constructors

Name | Description
MullionType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Material | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

MullionType Class
Autodesk.Revit.Symbols Namespace


MullionType Constructor

[image]

Revit 2010 API
MullionType Constructor
MullionType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MullionType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MullionType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MullionType Class
Autodesk.Revit.Symbols Namespace


MullionType Methods

[image] [image]

Revit 2010 API
MullionType Methods
MullionType Class See Also Send Feedback

The MullionType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MullionType Class
Autodesk.Revit.Symbols Namespace


MullionType Properties

[image] [image]

Revit 2010 API
MullionType Properties
MullionType Class See Also Send Feedback

The MullionType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Material | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

MullionType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
MullionType..::.Parameter Property
MullionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MullionType Class
MullionType Members
Autodesk.Revit.Symbols Namespace


MullionTypeSet Class

[image]

Revit 2010 API
MullionTypeSet Class
Members See Also Send Feedback
A set that contains mullion types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MullionTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class MullionTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class MullionTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.MullionTypeSet

See Also

MullionTypeSet Members
Autodesk.Revit.Symbols Namespace


MullionTypeSet Members

[image] [image]

Revit 2010 API
MullionTypeSet Members
MullionTypeSet Class Constructors Methods Properties See Also Send Feedback

The MullionTypeSet type exposes the following members.

Constructors

Name | Description
MullionTypeSet | Initializes a new instance of the MullionTypeSet class

Methods

Name | Description
Clear | Removes every mullion type from the set, rendering it empty.
Contains | Tests for the existence of a mullion type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified mullion type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified mullion type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of mullion types that are in the set.

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


MullionTypeSet Constructor

[image]

Revit 2010 API
MullionTypeSet Constructor
MullionTypeSet Class See Also Send Feedback
Initializes a new instance of the MullionTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MullionTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MullionTypeSet()

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


MullionTypeSet Methods

[image] [image]

Revit 2010 API
MullionTypeSet Methods
MullionTypeSet Class See Also Send Feedback

The MullionTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every mullion type from the set, rendering it empty.
Contains | Tests for the existence of a mullion type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified mullion type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified mullion type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
MullionTypeSet..::.Clear Method
MullionTypeSet Class See Also Send Feedback
Removes every mullion type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
MullionTypeSet..::.Contains Method
MullionTypeSet Class See Also Send Feedback
Tests for the existence of a mullion type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    MullionType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As MullionType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    MullionType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.MullionType
The mullion type to be searched for.

Return Value

The Contains method returns True if the mullion type is within the set, otherwise False.

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
MullionTypeSet..::.Erase Method
MullionTypeSet Class See Also Send Feedback
Removes a specified mullion type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    MullionType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As MullionType _
) As Integer
Visual C++
public:
virtual int Erase(
    MullionType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.MullionType
The mullion type to be erased.

Return Value

The number of mullion types that were erased from the set.

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
MullionTypeSet..::.ForwardIterator Method
MullionTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual MullionTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As MullionTypeSetIterator
Visual C++
public:
virtual MullionTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
MullionTypeSet..::.GetEnumerator Method
MullionTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
MullionTypeSet..::.Insert Method
MullionTypeSet Class See Also Send Feedback
Insert the specified mullion type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    MullionType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As MullionType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    MullionType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.MullionType
The mullion type to be inserted into the set.

Return Value

Returns whether the mullion type was inserted into the set.

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
MullionTypeSet..::.ReverseIterator Method
MullionTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual MullionTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As MullionTypeSetIterator
Visual C++
public:
virtual MullionTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


MullionTypeSet Properties

[image] [image]

Revit 2010 API
MullionTypeSet Properties
MullionTypeSet Class See Also Send Feedback

The MullionTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of mullion types that are in the set.

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
MullionTypeSet..::.IsEmpty Property
MullionTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
MullionTypeSet..::.Size Property
MullionTypeSet Class See Also Send Feedback
Returns the number of mullion types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

MullionTypeSet Class
Autodesk.Revit.Symbols Namespace


MullionTypeSetIterator Class

[image]

Revit 2010 API
MullionTypeSetIterator Class
Members See Also Send Feedback
An iterator to a mullion type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class MullionTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class MullionTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class MullionTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.MullionTypeSetIterator

See Also

MullionTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


MullionTypeSetIterator Members

[image] [image]

Revit 2010 API
MullionTypeSetIterator Members
MullionTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The MullionTypeSetIterator type exposes the following members.

Constructors

Name | Description
MullionTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MullionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MullionTypeSetIterator Constructor

[image]

Revit 2010 API
MullionTypeSetIterator Constructor
MullionTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MullionTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MullionTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MullionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MullionTypeSetIterator Methods

[image] [image]

Revit 2010 API
MullionTypeSetIterator Methods
MullionTypeSetIterator Class See Also Send Feedback

The MullionTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MullionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
MullionTypeSetIterator..::.MoveNext Method
MullionTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

MullionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
MullionTypeSetIterator..::.Reset Method
MullionTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

MullionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MullionTypeSetIterator Properties

[image] [image]

Revit 2010 API
MullionTypeSetIterator Properties
MullionTypeSetIterator Class See Also Send Feedback

The MullionTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MullionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
MullionTypeSetIterator..::.Current Property
MullionTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

MullionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


PanelType Class

[image]

Revit 2010 API
PanelType Class
Members See Also Send Feedback
An object that represents a curtain panel type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PanelType : FamilySymbol
Visual Basic (Declaration)
Public Class PanelType _
    Inherits FamilySymbol
Visual C++
public ref class PanelType : public FamilySymbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.InsertableObject
Autodesk.Revit.Symbols..::.FamilySymbol
Autodesk.Revit.Symbols..::.PanelType

See Also

PanelType Members
Autodesk.Revit.Symbols Namespace


PanelType Members

[image] [image]

Revit 2010 API
PanelType Members
PanelType Class Constructors Methods Properties See Also Send Feedback

The PanelType type exposes the following members.

Constructors

Name | Description
PanelType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Material | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PanelType Class
Autodesk.Revit.Symbols Namespace


PanelType Constructor

[image]

Revit 2010 API
PanelType Constructor
PanelType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PanelType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PanelType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PanelType Class
Autodesk.Revit.Symbols Namespace


PanelType Methods

[image] [image]

Revit 2010 API
PanelType Methods
PanelType Class See Also Send Feedback

The PanelType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PanelType Class
Autodesk.Revit.Symbols Namespace


PanelType Properties

[image] [image]

Revit 2010 API
PanelType Properties
PanelType Class See Also Send Feedback

The PanelType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Material | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PanelType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
PanelType..::.Parameter Property
PanelType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PanelType Class
PanelType Members
Autodesk.Revit.Symbols Namespace


PanelTypeSet Class

[image]

Revit 2010 API
PanelTypeSet Class
Members See Also Send Feedback
A set that contains panel types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PanelTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class PanelTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PanelTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.PanelTypeSet

See Also

PanelTypeSet Members
Autodesk.Revit.Symbols Namespace


PanelTypeSet Members

[image] [image]

Revit 2010 API
PanelTypeSet Members
PanelTypeSet Class Constructors Methods Properties See Also Send Feedback

The PanelTypeSet type exposes the following members.

Constructors

Name | Description
PanelTypeSet | Initializes a new instance of the PanelTypeSet class

Methods

Name | Description
Clear | Removes every panel type from the set, rendering it empty.
Contains | Tests for the existence of a panel type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified panel type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified panel type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of panel types that are in the set.

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


PanelTypeSet Constructor

[image]

Revit 2010 API
PanelTypeSet Constructor
PanelTypeSet Class See Also Send Feedback
Initializes a new instance of the PanelTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PanelTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PanelTypeSet()

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


PanelTypeSet Methods

[image] [image]

Revit 2010 API
PanelTypeSet Methods
PanelTypeSet Class See Also Send Feedback

The PanelTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every panel type from the set, rendering it empty.
Contains | Tests for the existence of a panel type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified panel type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified panel type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
PanelTypeSet..::.Clear Method
PanelTypeSet Class See Also Send Feedback
Removes every panel type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
PanelTypeSet..::.Contains Method
PanelTypeSet Class See Also Send Feedback
Tests for the existence of a panel type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    PanelType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As PanelType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PanelType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.PanelType
The panel type to be searched for.

Return Value

The Contains method returns True if the panel type is within the set, otherwise False.

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
PanelTypeSet..::.Erase Method
PanelTypeSet Class See Also Send Feedback
Removes a specified panel type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    PanelType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As PanelType _
) As Integer
Visual C++
public:
virtual int Erase(
    PanelType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.PanelType
The panel type to be erased.

Return Value

The number of panel types that were erased from the set.

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
PanelTypeSet..::.ForwardIterator Method
PanelTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual PanelTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PanelTypeSetIterator
Visual C++
public:
virtual PanelTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
PanelTypeSet..::.GetEnumerator Method
PanelTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
PanelTypeSet..::.Insert Method
PanelTypeSet Class See Also Send Feedback
Insert the specified panel type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    PanelType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As PanelType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PanelType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.PanelType
The panel type to be inserted into the set.

Return Value

Returns whether the panel type was inserted into the set.

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
PanelTypeSet..::.ReverseIterator Method
PanelTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual PanelTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PanelTypeSetIterator
Visual C++
public:
virtual PanelTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


PanelTypeSet Properties

[image] [image]

Revit 2010 API
PanelTypeSet Properties
PanelTypeSet Class See Also Send Feedback

The PanelTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of panel types that are in the set.

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
PanelTypeSet..::.IsEmpty Property
PanelTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
PanelTypeSet..::.Size Property
PanelTypeSet Class See Also Send Feedback
Returns the number of panel types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PanelTypeSet Class
Autodesk.Revit.Symbols Namespace


PanelTypeSetIterator Class

[image]

Revit 2010 API
PanelTypeSetIterator Class
Members See Also Send Feedback
An iterator to a panel type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class PanelTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class PanelTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PanelTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.PanelTypeSetIterator

See Also

PanelTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


PanelTypeSetIterator Members

[image] [image]

Revit 2010 API
PanelTypeSetIterator Members
PanelTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The PanelTypeSetIterator type exposes the following members.

Constructors

Name | Description
PanelTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PanelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


PanelTypeSetIterator Constructor

[image]

Revit 2010 API
PanelTypeSetIterator Constructor
PanelTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PanelTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PanelTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PanelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


PanelTypeSetIterator Methods

[image] [image]

Revit 2010 API
PanelTypeSetIterator Methods
PanelTypeSetIterator Class See Also Send Feedback

The PanelTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PanelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
PanelTypeSetIterator..::.MoveNext Method
PanelTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PanelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
PanelTypeSetIterator..::.Reset Method
PanelTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PanelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


PanelTypeSetIterator Properties

[image] [image]

Revit 2010 API
PanelTypeSetIterator Properties
PanelTypeSetIterator Class See Also Send Feedback

The PanelTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PanelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
PanelTypeSetIterator..::.Current Property
PanelTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PanelTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


PathReinforcementType Class

[image]

Revit 2010 API
PathReinforcementType Class
Members See Also Send Feedback
An object that specifies the type of a Structural Path Reinforcement element in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PathReinforcementType : Symbol
Visual Basic (Declaration)
Public Class PathReinforcementType _
    Inherits Symbol
Visual C++
public ref class PathReinforcementType : public Symbol

Remarks

The clear cover settings can be accessed via this object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.PathReinforcementType

See Also

PathReinforcementType Members
Autodesk.Revit.Symbols Namespace


PathReinforcementType Members

[image] [image]

Revit 2010 API
PathReinforcementType Members
PathReinforcementType Class Constructors Methods Properties See Also Send Feedback

The PathReinforcementType type exposes the following members.

Constructors

Name | Description
PathReinforcementType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PathReinforcementType Class
Autodesk.Revit.Symbols Namespace


PathReinforcementType Constructor

[image]

Revit 2010 API
PathReinforcementType Constructor
PathReinforcementType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PathReinforcementType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PathReinforcementType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PathReinforcementType Class
Autodesk.Revit.Symbols Namespace


PathReinforcementType Methods

[image] [image]

Revit 2010 API
PathReinforcementType Methods
PathReinforcementType Class See Also Send Feedback

The PathReinforcementType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PathReinforcementType Class
Autodesk.Revit.Symbols Namespace


PathReinforcementType Properties

[image] [image]

Revit 2010 API
PathReinforcementType Properties
PathReinforcementType Class See Also Send Feedback

The PathReinforcementType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PathReinforcementType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
PathReinforcementType..::.Parameter Property
PathReinforcementType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PathReinforcementType Class
PathReinforcementType Members
Autodesk.Revit.Symbols Namespace


PointLoadType Class

[image]

Revit 2010 API
PointLoadType Class
Members See Also Send Feedback
An object that represents a Load type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PointLoadType : LoadTypeBase
Visual Basic (Declaration)
Public Class PointLoadType _
    Inherits LoadTypeBase
Visual C++
public ref class PointLoadType : public LoadTypeBase

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.LoadTypeBase
Autodesk.Revit.Symbols..::.PointLoadType

See Also

PointLoadType Members
Autodesk.Revit.Symbols Namespace


PointLoadType Members

[image] [image]

Revit 2010 API
PointLoadType Members
PointLoadType Class Constructors Methods Properties See Also Send Feedback

The PointLoadType type exposes the following members.

Constructors

Name | Description
PointLoadType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PointLoadType Class
Autodesk.Revit.Symbols Namespace


PointLoadType Constructor

[image]

Revit 2010 API
PointLoadType Constructor
PointLoadType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PointLoadType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PointLoadType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PointLoadType Class
Autodesk.Revit.Symbols Namespace


PointLoadType Methods

[image] [image]

Revit 2010 API
PointLoadType Methods
PointLoadType Class See Also Send Feedback

The PointLoadType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointLoadType Class
Autodesk.Revit.Symbols Namespace


PointLoadType Properties

[image] [image]

Revit 2010 API
PointLoadType Properties
PointLoadType Class See Also Send Feedback

The PointLoadType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

PointLoadType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
PointLoadType..::.Parameter Property
PointLoadType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PointLoadType Class
PointLoadType Members
Autodesk.Revit.Symbols Namespace


PointLoadTypeSet Class

[image]

Revit 2010 API
PointLoadTypeSet Class
Members See Also Send Feedback
A set that contains pointload types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PointLoadTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class PointLoadTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PointLoadTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.PointLoadTypeSet

See Also

PointLoadTypeSet Members
Autodesk.Revit.Symbols Namespace


PointLoadTypeSet Members

[image] [image]

Revit 2010 API
PointLoadTypeSet Members
PointLoadTypeSet Class Constructors Methods Properties See Also Send Feedback

The PointLoadTypeSet type exposes the following members.

Constructors

Name | Description
PointLoadTypeSet | Initializes a new instance of the PointLoadTypeSet class

Methods

Name | Description
Clear | Removes every pointload type from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of pointload types that are in the set.

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


PointLoadTypeSet Constructor

[image]

Revit 2010 API
PointLoadTypeSet Constructor
PointLoadTypeSet Class See Also Send Feedback
Initializes a new instance of the PointLoadTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PointLoadTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PointLoadTypeSet()

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


PointLoadTypeSet Methods

[image] [image]

Revit 2010 API
PointLoadTypeSet Methods
PointLoadTypeSet Class See Also Send Feedback

The PointLoadTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every pointload type from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
PointLoadTypeSet..::.Clear Method
PointLoadTypeSet Class See Also Send Feedback
Removes every pointload type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
PointLoadTypeSet..::.Contains Method
PointLoadTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    PointLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As PointLoadType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PointLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.PointLoadType

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
PointLoadTypeSet..::.Erase Method
PointLoadTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    PointLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As PointLoadType _
) As Integer
Visual C++
public:
virtual int Erase(
    PointLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.PointLoadType

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
PointLoadTypeSet..::.ForwardIterator Method
PointLoadTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual PointLoadTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PointLoadTypeSetIterator
Visual C++
public:
virtual PointLoadTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
PointLoadTypeSet..::.GetEnumerator Method
PointLoadTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
PointLoadTypeSet..::.Insert Method
PointLoadTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    PointLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As PointLoadType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PointLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.PointLoadType

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
PointLoadTypeSet..::.ReverseIterator Method
PointLoadTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual PointLoadTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PointLoadTypeSetIterator
Visual C++
public:
virtual PointLoadTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


PointLoadTypeSet Properties

[image] [image]

Revit 2010 API
PointLoadTypeSet Properties
PointLoadTypeSet Class See Also Send Feedback

The PointLoadTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of pointload types that are in the set.

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
PointLoadTypeSet..::.IsEmpty Property
PointLoadTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
PointLoadTypeSet..::.Size Property
PointLoadTypeSet Class See Also Send Feedback
Returns the number of pointload types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PointLoadTypeSet Class
Autodesk.Revit.Symbols Namespace


PointLoadTypeSetIterator Class

[image]

Revit 2010 API
PointLoadTypeSetIterator Class
Members See Also Send Feedback
An iterator to a pointload type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class PointLoadTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class PointLoadTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PointLoadTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.PointLoadTypeSetIterator

See Also

PointLoadTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


PointLoadTypeSetIterator Members

[image] [image]

Revit 2010 API
PointLoadTypeSetIterator Members
PointLoadTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The PointLoadTypeSetIterator type exposes the following members.

Constructors

Name | Description
PointLoadTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


PointLoadTypeSetIterator Constructor

[image]

Revit 2010 API
PointLoadTypeSetIterator Constructor
PointLoadTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PointLoadTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PointLoadTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


PointLoadTypeSetIterator Methods

[image] [image]

Revit 2010 API
PointLoadTypeSetIterator Methods
PointLoadTypeSetIterator Class See Also Send Feedback

The PointLoadTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
PointLoadTypeSetIterator..::.MoveNext Method
PointLoadTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
PointLoadTypeSetIterator..::.Reset Method
PointLoadTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


PointLoadTypeSetIterator Properties

[image] [image]

Revit 2010 API
PointLoadTypeSetIterator Properties
PointLoadTypeSetIterator Class See Also Send Feedback

The PointLoadTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
PointLoadTypeSetIterator..::.Current Property
PointLoadTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarBarType Class

[image]

Revit 2010 API
RebarBarType Class
Members See Also Send Feedback
A Rebar type object that is used in the generation of Rebar.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RebarBarType : Symbol
Visual Basic (Declaration)
Public Class RebarBarType _
    Inherits Symbol
Visual C++
public ref class RebarBarType : public Symbol

Remarks

The RebarBarType object contains information about Rebar. Access to these details is made available through built in parameters. The following are parameters that can be used: REBAR_BAR_DIAMETER - diameter of bar, REBAR_BAR_BEND_RADIUS - minimal bend radius of the rebar, MATERIAL_ID_PARAM - identifies the material of which the rebar is made, REBAR_BAR_STYLE - category that is used to represent the Rebar in drawings.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.RebarBarType

See Also

RebarBarType Members
Autodesk.Revit.Symbols Namespace


RebarBarType Members

[image] [image]

Revit 2010 API
RebarBarType Members
RebarBarType Class Constructors Methods Properties See Also Send Feedback

The RebarBarType type exposes the following members.

Constructors

Name | Description
RebarBarType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAutoCalcHookLengths | Whether hook lengths are automatically calculated.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetAutoCalcHookLengths | Specify whether hook lengths are automatically calculated.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HookLength | Access to length data in the hook lengths map.
HookOffsetLength | Access to offset length data in the hook lengths map.
HookPermission | Access to permission data in the hook lengths map.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace


RebarBarType Constructor

[image]

Revit 2010 API
RebarBarType Constructor
RebarBarType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarBarType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarBarType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace


RebarBarType Methods

[image] [image]

Revit 2010 API
RebarBarType Methods
RebarBarType Class See Also Send Feedback

The RebarBarType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAutoCalcHookLengths | Whether hook lengths are automatically calculated.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetAutoCalcHookLengths | Specify whether hook lengths are automatically calculated.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace


GetAutoCalcHookLengths Method

[image]

Revit 2010 API
RebarBarType..::.GetAutoCalcHookLengths Method
RebarBarType Class See Also Send Feedback
Whether hook lengths are automatically calculated.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool GetAutoCalcHookLengths(
    RebarHookType hookType
)
Visual Basic (Declaration)
Public Function GetAutoCalcHookLengths ( _
    hookType As RebarHookType _
) As Boolean
Visual C++
public:
bool GetAutoCalcHookLengths(
    RebarHookType^ hookType
)

Parameters

hookType
Type: Autodesk.Revit.Symbols..::.RebarHookType
A hook type in the same document as this bar type.

Return Value

True if hook lengths are automatically calculated.

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace


SetAutoCalcHookLengths Method

[image]

Revit 2010 API
RebarBarType..::.SetAutoCalcHookLengths Method
RebarBarType Class See Also Send Feedback
Specify whether hook lengths are automatically calculated.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetAutoCalcHookLengths(
    RebarHookType hookType,
    bool autoCalc
)
Visual Basic (Declaration)
Public Sub SetAutoCalcHookLengths ( _
    hookType As RebarHookType, _
    autoCalc As Boolean _
)
Visual C++
public:
void SetAutoCalcHookLengths(
    RebarHookType^ hookType,
    bool autoCalc
)

Parameters

hookType
Type: Autodesk.Revit.Symbols..::.RebarHookType
A hook type in the same document as this bar type.
autoCalc
Type: System..::.Boolean
Setting this value to true discards the current value set by set_HookLength().

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace


RebarBarType Properties

[image] [image]

Revit 2010 API
RebarBarType Properties
RebarBarType Class See Also Send Feedback

The RebarBarType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HookLength | Access to length data in the hook lengths map.
HookOffsetLength | Access to offset length data in the hook lengths map.
HookPermission | Access to permission data in the hook lengths map.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace


HookLength Property

[image]

Revit 2010 API
RebarBarType..::.HookLength Property
RebarBarType Class See Also Send Feedback
Access to length data in the hook lengths map.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double HookLength[
    RebarHookType hookType
] { get; set; }
Visual Basic (Declaration)
Public Property HookLength ( _
    hookType As RebarHookType _
) As Double
Visual C++
public:
property double HookLength[RebarHookType^ hookType] {
    double get (RebarHookType^ hookType);
    void set (RebarHookType^ hookType, double value);
}

Parameters

hookType
Type: Autodesk.Revit.Symbols..::.RebarHookType
A hook type in the same document as this bar type.

Remarks

Setting this property implicitly turns off the AutoCalcHookLengths property for this hook.

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace


HookOffsetLength Property

[image]

Revit 2010 API
RebarBarType..::.HookOffsetLength Property
RebarBarType Class See Also Send Feedback
Access to offset length data in the hook lengths map.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double HookOffsetLength[
    RebarHookType hookType
] { get; set; }
Visual Basic (Declaration)
Public Property HookOffsetLength ( _
    hookType As RebarHookType _
) As Double
Visual C++
public:
property double HookOffsetLength[RebarHookType^ hookType] {
    double get (RebarHookType^ hookType);
    void set (RebarHookType^ hookType, double value);
}

Parameters

hookType
Type: Autodesk.Revit.Symbols..::.RebarHookType
A hook type in the same document as this bar type.

Remarks

Setting this property implicitly turns off the AutoCalcHookLengths property for this hook. It is only possible to set the offset length for hooks greater than 90 degrees.

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace


HookPermission Property

[image]

Revit 2010 API
RebarBarType..::.HookPermission Property
RebarBarType Class See Also Send Feedback
Access to permission data in the hook lengths map.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool HookPermission[
    RebarHookType hookType
] { get; set; }
Visual Basic (Declaration)
Public Property HookPermission ( _
    hookType As RebarHookType _
) As Boolean
Visual C++
public:
property bool HookPermission[RebarHookType^ hookType] {
    bool get (RebarHookType^ hookType);
    void set (RebarHookType^ hookType, bool value);
}

Parameters

hookType
Type: Autodesk.Revit.Symbols..::.RebarHookType
A hook type in the same document as this bar type.

Remarks

This determines whether the hooks may be used with this bar type.

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
RebarBarType..::.Parameter Property
RebarBarType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

RebarBarType Class
RebarBarType Members
Autodesk.Revit.Symbols Namespace


RebarBarTypeSet Class

[image]

Revit 2010 API
RebarBarTypeSet Class
Members See Also Send Feedback
A set that contains RebarBar types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RebarBarTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class RebarBarTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class RebarBarTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.RebarBarTypeSet

See Also

RebarBarTypeSet Members
Autodesk.Revit.Symbols Namespace


RebarBarTypeSet Members

[image] [image]

Revit 2010 API
RebarBarTypeSet Members
RebarBarTypeSet Class Constructors Methods Properties See Also Send Feedback

The RebarBarTypeSet type exposes the following members.

Constructors

Name | Description
RebarBarTypeSet | Initializes a new instance of the RebarBarTypeSet class

Methods

Name | Description
Clear | Removes every RebarBar type from the set, rendering it empty.
Contains | Tests for the existence of a RebarBar type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified RebarBar type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified RebarBar type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of RebarBar types that are in the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


RebarBarTypeSet Constructor

[image]

Revit 2010 API
RebarBarTypeSet Constructor
RebarBarTypeSet Class See Also Send Feedback
Initializes a new instance of the RebarBarTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarBarTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarBarTypeSet()

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


RebarBarTypeSet Methods

[image] [image]

Revit 2010 API
RebarBarTypeSet Methods
RebarBarTypeSet Class See Also Send Feedback

The RebarBarTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every RebarBar type from the set, rendering it empty.
Contains | Tests for the existence of a RebarBar type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified RebarBar type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified RebarBar type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
RebarBarTypeSet..::.Clear Method
RebarBarTypeSet Class See Also Send Feedback
Removes every RebarBar type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
RebarBarTypeSet..::.Contains Method
RebarBarTypeSet Class See Also Send Feedback
Tests for the existence of a RebarBar type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    RebarBarType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As RebarBarType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    RebarBarType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.RebarBarType
The RebarBar type to be searched for.

Return Value

The Contains method returns True if the RebarBar type is within the set, otherwise False.

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
RebarBarTypeSet..::.Erase Method
RebarBarTypeSet Class See Also Send Feedback
Removes a specified RebarBar type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    RebarBarType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As RebarBarType _
) As Integer
Visual C++
public:
virtual int Erase(
    RebarBarType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.RebarBarType
The RebarBar type to be erased.

Return Value

The number of RebarBar types that were erased from the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
RebarBarTypeSet..::.ForwardIterator Method
RebarBarTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual RebarBarTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As RebarBarTypeSetIterator
Visual C++
public:
virtual RebarBarTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
RebarBarTypeSet..::.GetEnumerator Method
RebarBarTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
RebarBarTypeSet..::.Insert Method
RebarBarTypeSet Class See Also Send Feedback
Insert the specified RebarBar type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    RebarBarType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As RebarBarType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    RebarBarType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.RebarBarType
The RebarBar type to be inserted into the set.

Return Value

Returns whether the RebarBar type was inserted into the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
RebarBarTypeSet..::.ReverseIterator Method
RebarBarTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual RebarBarTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As RebarBarTypeSetIterator
Visual C++
public:
virtual RebarBarTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


RebarBarTypeSet Properties

[image] [image]

Revit 2010 API
RebarBarTypeSet Properties
RebarBarTypeSet Class See Also Send Feedback

The RebarBarTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of RebarBar types that are in the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
RebarBarTypeSet..::.IsEmpty Property
RebarBarTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
RebarBarTypeSet..::.Size Property
RebarBarTypeSet Class See Also Send Feedback
Returns the number of RebarBar types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RebarBarTypeSet Class
Autodesk.Revit.Symbols Namespace


RebarBarTypeSetIterator Class

[image]

Revit 2010 API
RebarBarTypeSetIterator Class
Members See Also Send Feedback
An iterator to a RebarBar type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class RebarBarTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class RebarBarTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class RebarBarTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.RebarBarTypeSetIterator

See Also

RebarBarTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


RebarBarTypeSetIterator Members

[image] [image]

Revit 2010 API
RebarBarTypeSetIterator Members
RebarBarTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The RebarBarTypeSetIterator type exposes the following members.

Constructors

Name | Description
RebarBarTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarBarTypeSetIterator Constructor

[image]

Revit 2010 API
RebarBarTypeSetIterator Constructor
RebarBarTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarBarTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarBarTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarBarTypeSetIterator Methods

[image] [image]

Revit 2010 API
RebarBarTypeSetIterator Methods
RebarBarTypeSetIterator Class See Also Send Feedback

The RebarBarTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
RebarBarTypeSetIterator..::.MoveNext Method
RebarBarTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
RebarBarTypeSetIterator..::.Reset Method
RebarBarTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarBarTypeSetIterator Properties

[image] [image]

Revit 2010 API
RebarBarTypeSetIterator Properties
RebarBarTypeSetIterator Class See Also Send Feedback

The RebarBarTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
RebarBarTypeSetIterator..::.Current Property
RebarBarTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarCoverType Class

[image]

Revit 2010 API
RebarCoverType Class
Members See Also Send Feedback
A Rebar Cover setting. This element functions as a name-value pair for Rebar Cover Settings.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RebarCoverType : Symbol
Visual Basic (Declaration)
Public Class RebarCoverType _
    Inherits Symbol
Visual C++
public ref class RebarCoverType : public Symbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.RebarCoverType

See Also

RebarCoverType Members
Autodesk.Revit.Symbols Namespace


RebarCoverType Members

[image] [image]

Revit 2010 API
RebarCoverType Members
RebarCoverType Class Constructors Methods Properties See Also Send Feedback

The RebarCoverType type exposes the following members.

Constructors

Name | Description
RebarCoverType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoverDistance | A distance that can be used as a concrete cover value in a document.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RebarCoverType Class
Autodesk.Revit.Symbols Namespace


RebarCoverType Constructor

[image]

Revit 2010 API
RebarCoverType Constructor
RebarCoverType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarCoverType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarCoverType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarCoverType Class
Autodesk.Revit.Symbols Namespace


RebarCoverType Methods

[image] [image]

Revit 2010 API
RebarCoverType Methods
RebarCoverType Class See Also Send Feedback

The RebarCoverType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarCoverType Class
Autodesk.Revit.Symbols Namespace


RebarCoverType Properties

[image] [image]

Revit 2010 API
RebarCoverType Properties
RebarCoverType Class See Also Send Feedback

The RebarCoverType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoverDistance | A distance that can be used as a concrete cover value in a document.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RebarCoverType Class
Autodesk.Revit.Symbols Namespace


CoverDistance Property

[image]

Revit 2010 API
RebarCoverType..::.CoverDistance Property
RebarCoverType Class See Also Send Feedback
A distance that can be used as a concrete cover value in a document.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double CoverDistance { get; set; }
Visual Basic (Declaration)
Public Property CoverDistance As Double
Visual C++
public:
property double CoverDistance {
    double get ();
    void set (double value);
}

See Also

RebarCoverType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
RebarCoverType..::.Parameter Property
RebarCoverType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

RebarCoverType Class
RebarCoverType Members
Autodesk.Revit.Symbols Namespace


RebarCoverTypeSet Class

[image]

Revit 2010 API
RebarCoverTypeSet Class
Members See Also Send Feedback
A set that contains RebarCover types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RebarCoverTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class RebarCoverTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class RebarCoverTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.RebarCoverTypeSet

See Also

RebarCoverTypeSet Members
Autodesk.Revit.Symbols Namespace


RebarCoverTypeSet Members

[image] [image]

Revit 2010 API
RebarCoverTypeSet Members
RebarCoverTypeSet Class Constructors Methods Properties See Also Send Feedback

The RebarCoverTypeSet type exposes the following members.

Constructors

Name | Description
RebarCoverTypeSet | Initializes a new instance of the RebarCoverTypeSet class

Methods

Name | Description
Clear | Removes every RebarCover type from the set, rendering it empty.
Contains | Tests for the existence of a RebarCover type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified RebarCover type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified RebarCover type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of RebarCover types that are in the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


RebarCoverTypeSet Constructor

[image]

Revit 2010 API
RebarCoverTypeSet Constructor
RebarCoverTypeSet Class See Also Send Feedback
Initializes a new instance of the RebarCoverTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarCoverTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarCoverTypeSet()

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


RebarCoverTypeSet Methods

[image] [image]

Revit 2010 API
RebarCoverTypeSet Methods
RebarCoverTypeSet Class See Also Send Feedback

The RebarCoverTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every RebarCover type from the set, rendering it empty.
Contains | Tests for the existence of a RebarCover type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified RebarCover type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified RebarCover type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
RebarCoverTypeSet..::.Clear Method
RebarCoverTypeSet Class See Also Send Feedback
Removes every RebarCover type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
RebarCoverTypeSet..::.Contains Method
RebarCoverTypeSet Class See Also Send Feedback
Tests for the existence of a RebarCover type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    RebarCoverType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As RebarCoverType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    RebarCoverType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.RebarCoverType
The RebarCover type to be searched for.

Return Value

The Contains method returns True if the RebarCover type is within the set, otherwise False.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
RebarCoverTypeSet..::.Erase Method
RebarCoverTypeSet Class See Also Send Feedback
Removes a specified RebarCover type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    RebarCoverType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As RebarCoverType _
) As Integer
Visual C++
public:
virtual int Erase(
    RebarCoverType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.RebarCoverType
The RebarCover type to be erased.

Return Value

The number of RebarCover types that were erased from the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
RebarCoverTypeSet..::.ForwardIterator Method
RebarCoverTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual RebarCoverTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As RebarCoverTypeSetIterator
Visual C++
public:
virtual RebarCoverTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
RebarCoverTypeSet..::.GetEnumerator Method
RebarCoverTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
RebarCoverTypeSet..::.Insert Method
RebarCoverTypeSet Class See Also Send Feedback
Insert the specified RebarCover type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    RebarCoverType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As RebarCoverType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    RebarCoverType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.RebarCoverType
The RebarCover type to be inserted into the set.

Return Value

Returns whether the RebarCover type was inserted into the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
RebarCoverTypeSet..::.ReverseIterator Method
RebarCoverTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual RebarCoverTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As RebarCoverTypeSetIterator
Visual C++
public:
virtual RebarCoverTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


RebarCoverTypeSet Properties

[image] [image]

Revit 2010 API
RebarCoverTypeSet Properties
RebarCoverTypeSet Class See Also Send Feedback

The RebarCoverTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of RebarCover types that are in the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
RebarCoverTypeSet..::.IsEmpty Property
RebarCoverTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
RebarCoverTypeSet..::.Size Property
RebarCoverTypeSet Class See Also Send Feedback
Returns the number of RebarCover types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RebarCoverTypeSet Class
Autodesk.Revit.Symbols Namespace


RebarCoverTypeSetIterator Class

[image]

Revit 2010 API
RebarCoverTypeSetIterator Class
Members See Also Send Feedback
An iterator to a RebarCover type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class RebarCoverTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class RebarCoverTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class RebarCoverTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.RebarCoverTypeSetIterator

See Also

RebarCoverTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


RebarCoverTypeSetIterator Members

[image] [image]

Revit 2010 API
RebarCoverTypeSetIterator Members
RebarCoverTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The RebarCoverTypeSetIterator type exposes the following members.

Constructors

Name | Description
RebarCoverTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarCoverTypeSetIterator Constructor

[image]

Revit 2010 API
RebarCoverTypeSetIterator Constructor
RebarCoverTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarCoverTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarCoverTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarCoverTypeSetIterator Methods

[image] [image]

Revit 2010 API
RebarCoverTypeSetIterator Methods
RebarCoverTypeSetIterator Class See Also Send Feedback

The RebarCoverTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
RebarCoverTypeSetIterator..::.MoveNext Method
RebarCoverTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
RebarCoverTypeSetIterator..::.Reset Method
RebarCoverTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarCoverTypeSetIterator Properties

[image] [image]

Revit 2010 API
RebarCoverTypeSetIterator Properties
RebarCoverTypeSetIterator Class See Also Send Feedback

The RebarCoverTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
RebarCoverTypeSetIterator..::.Current Property
RebarCoverTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarHookType Class

[image]

Revit 2010 API
RebarHookType Class
Members See Also Send Feedback
A Rebar Hook type object that is used in the generation of Rebar.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RebarHookType : Symbol
Visual Basic (Declaration)
Public Class RebarHookType _
    Inherits Symbol
Visual C++
public ref class RebarHookType : public Symbol

Remarks

This object contains the definition of the hooks that may be created at the ends of the rebar. The specifics of these hooks are contained within parameters that are accessible from this object. REBAR_HOOK_ANGLE - angle (range 0-PI) between first/last segment of rebar and the straight segment of the hook, REBAR_HOOK_LINE_LEN_FACTOR - a multiplier used to compute the length of the straight segment of the hook. The Length is computed as the bar diameter * the multiplier.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.RebarHookType

See Also

RebarHookType Members
Autodesk.Revit.Symbols Namespace


RebarHookType Members

[image] [image]

Revit 2010 API
RebarHookType Members
RebarHookType Class Constructors Methods Properties See Also Send Feedback

The RebarHookType type exposes the following members.

Constructors

Name | Description
RebarHookType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RebarHookType Class
Autodesk.Revit.Symbols Namespace


RebarHookType Constructor

[image]

Revit 2010 API
RebarHookType Constructor
RebarHookType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarHookType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarHookType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarHookType Class
Autodesk.Revit.Symbols Namespace


RebarHookType Methods

[image] [image]

Revit 2010 API
RebarHookType Methods
RebarHookType Class See Also Send Feedback

The RebarHookType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarHookType Class
Autodesk.Revit.Symbols Namespace


RebarHookType Properties

[image] [image]

Revit 2010 API
RebarHookType Properties
RebarHookType Class See Also Send Feedback

The RebarHookType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RebarHookType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
RebarHookType..::.Parameter Property
RebarHookType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

RebarHookType Class
RebarHookType Members
Autodesk.Revit.Symbols Namespace


RebarHookTypeSet Class

[image]

Revit 2010 API
RebarHookTypeSet Class
Members See Also Send Feedback
A set that contains RebarHook types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RebarHookTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class RebarHookTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class RebarHookTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.RebarHookTypeSet

See Also

RebarHookTypeSet Members
Autodesk.Revit.Symbols Namespace


RebarHookTypeSet Members

[image] [image]

Revit 2010 API
RebarHookTypeSet Members
RebarHookTypeSet Class Constructors Methods Properties See Also Send Feedback

The RebarHookTypeSet type exposes the following members.

Constructors

Name | Description
RebarHookTypeSet | Initializes a new instance of the RebarHookTypeSet class

Methods

Name | Description
Clear | Removes every RebarHook type from the set, rendering it empty.
Contains | Tests for the existence of a RebarHook type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified RebarHook type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified RebarHook type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of RebarHook types that are in the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


RebarHookTypeSet Constructor

[image]

Revit 2010 API
RebarHookTypeSet Constructor
RebarHookTypeSet Class See Also Send Feedback
Initializes a new instance of the RebarHookTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarHookTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarHookTypeSet()

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


RebarHookTypeSet Methods

[image] [image]

Revit 2010 API
RebarHookTypeSet Methods
RebarHookTypeSet Class See Also Send Feedback

The RebarHookTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every RebarHook type from the set, rendering it empty.
Contains | Tests for the existence of a RebarHook type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified RebarHook type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified RebarHook type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
RebarHookTypeSet..::.Clear Method
RebarHookTypeSet Class See Also Send Feedback
Removes every RebarHook type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
RebarHookTypeSet..::.Contains Method
RebarHookTypeSet Class See Also Send Feedback
Tests for the existence of a RebarHook type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    RebarHookType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As RebarHookType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    RebarHookType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.RebarHookType
The RebarHook type to be searched for.

Return Value

The Contains method returns True if the RebarHook type is within the set, otherwise False.

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
RebarHookTypeSet..::.Erase Method
RebarHookTypeSet Class See Also Send Feedback
Removes a specified RebarHook type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    RebarHookType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As RebarHookType _
) As Integer
Visual C++
public:
virtual int Erase(
    RebarHookType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.RebarHookType
The RebarHook type to be erased.

Return Value

The number of RebarHook types that were erased from the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
RebarHookTypeSet..::.ForwardIterator Method
RebarHookTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual RebarHookTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As RebarHookTypeSetIterator
Visual C++
public:
virtual RebarHookTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
RebarHookTypeSet..::.GetEnumerator Method
RebarHookTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
RebarHookTypeSet..::.Insert Method
RebarHookTypeSet Class See Also Send Feedback
Insert the specified RebarHook type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    RebarHookType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As RebarHookType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    RebarHookType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.RebarHookType
The RebarHook type to be inserted into the set.

Return Value

Returns whether the RebarHook type was inserted into the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
RebarHookTypeSet..::.ReverseIterator Method
RebarHookTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual RebarHookTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As RebarHookTypeSetIterator
Visual C++
public:
virtual RebarHookTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


RebarHookTypeSet Properties

[image] [image]

Revit 2010 API
RebarHookTypeSet Properties
RebarHookTypeSet Class See Also Send Feedback

The RebarHookTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of RebarHook types that are in the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
RebarHookTypeSet..::.IsEmpty Property
RebarHookTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
RebarHookTypeSet..::.Size Property
RebarHookTypeSet Class See Also Send Feedback
Returns the number of RebarHook types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace


RebarHookTypeSetIterator Class

[image]

Revit 2010 API
RebarHookTypeSetIterator Class
Members See Also Send Feedback
An iterator to a RebarHook type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class RebarHookTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class RebarHookTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class RebarHookTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.RebarHookTypeSetIterator

See Also

RebarHookTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


RebarHookTypeSetIterator Members

[image] [image]

Revit 2010 API
RebarHookTypeSetIterator Members
RebarHookTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The RebarHookTypeSetIterator type exposes the following members.

Constructors

Name | Description
RebarHookTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarHookTypeSetIterator Constructor

[image]

Revit 2010 API
RebarHookTypeSetIterator Constructor
RebarHookTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarHookTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarHookTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarHookTypeSetIterator Methods

[image] [image]

Revit 2010 API
RebarHookTypeSetIterator Methods
RebarHookTypeSetIterator Class See Also Send Feedback

The RebarHookTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
RebarHookTypeSetIterator..::.MoveNext Method
RebarHookTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
RebarHookTypeSetIterator..::.Reset Method
RebarHookTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarHookTypeSetIterator Properties

[image] [image]

Revit 2010 API
RebarHookTypeSetIterator Properties
RebarHookTypeSetIterator Class See Also Send Feedback

The RebarHookTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
RebarHookTypeSetIterator..::.Current Property
RebarHookTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarShape Class

[image]

Revit 2010 API
RebarShape Class
Members See Also Send Feedback
RebarShape specifies the shape type for a Rebar instance.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RebarShape : Symbol
Visual Basic (Declaration)
Public Class RebarShape _
    Inherits Symbol
Visual C++
public ref class RebarShape : public Symbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.RebarShape

See Also

RebarShape Members
Autodesk.Revit.Symbols Namespace


RebarShape Members

[image] [image]

Revit 2010 API
RebarShape Members
RebarShape Class Constructors Methods Properties See Also Send Feedback

The RebarShape type exposes the following members.

Constructors

Name | Description
RebarShape | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllowed | Check whether a bar type can be used with this RebarShape. Bar types are allowed by default.
GetAllRebarShapeParameters | List all shape parameters used by all the existing RebarShapes in the document.
GetCurvesForBrowser | Generate curves for the shape, as used in the shape browser.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
NewDefinitionByArc | Create a shape definition by arc, and associate it with this shape.
NewDefinitionBySegments | Create a shape definition by segments, and associate it with this shape.
SetAllowed | Specify which bar types can be used with this RebarShape. Bar types are allowed by default.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Definition | Get the shape definition object associated with this shape.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HookAngle | Get and set the hook angle.
HookOrientation | Get and set the hook orientation.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RebarStyle | Access the rebar style.
SameShapeIgnoringHooks | Test whether two shapes have equivalent definitions.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SimpleArc | Check whether this shape consists of a single arc, possibly with hooks.
SimpleLine | Check whether this shape consists of a single straight segment, possibly with hooks.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


RebarShape Constructor

[image]

Revit 2010 API
RebarShape Constructor
RebarShape Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarShape()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarShape()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


RebarShape Methods

[image] [image]

Revit 2010 API
RebarShape Methods
RebarShape Class See Also Send Feedback

The RebarShape type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllowed | Check whether a bar type can be used with this RebarShape. Bar types are allowed by default.
GetAllRebarShapeParameters | List all shape parameters used by all the existing RebarShapes in the document.
GetCurvesForBrowser | Generate curves for the shape, as used in the shape browser.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
NewDefinitionByArc | Create a shape definition by arc, and associate it with this shape.
NewDefinitionBySegments | Create a shape definition by segments, and associate it with this shape.
SetAllowed | Specify which bar types can be used with this RebarShape. Bar types are allowed by default.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


GetAllowed Method

[image]

Revit 2010 API
RebarShape..::.GetAllowed Method
RebarShape Class See Also Send Feedback
Check whether a bar type can be used with this RebarShape. Bar types are allowed by default.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool GetAllowed(
    RebarBarType barType
)
Visual Basic (Declaration)
Public Function GetAllowed ( _
    barType As RebarBarType _
) As Boolean
Visual C++
public:
bool GetAllowed(
    RebarBarType^ barType
)

Parameters

barType
Type: Autodesk.Revit.Symbols..::.RebarBarType
A bar type in the same document as this shape.

Return Value

True if this shape may be combined with this barType.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


GetAllRebarShapeParameters Method

[image]

Revit 2010 API
RebarShape..::.GetAllRebarShapeParameters Method
RebarShape Class See Also Send Feedback
List all shape parameters used by all the existing RebarShapes in the document.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static DefinitionsBase GetAllRebarShapeParameters(
    Document doc
)
Visual Basic (Declaration)
Public Shared Function GetAllRebarShapeParameters ( _
    doc As Document _
) As DefinitionsBase
Visual C++
public:
static DefinitionsBase^ GetAllRebarShapeParameters(
    Document^ doc
)

Parameters

doc
Type: Autodesk.Revit..::.Document
A Revit document.

Return Value

A list of parameters.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


GetCurvesForBrowser Method

[image]

Revit 2010 API
RebarShape..::.GetCurvesForBrowser Method
RebarShape Class See Also Send Feedback
Generate curves for the shape, as used in the shape browser.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray GetCurvesForBrowser()
Visual Basic (Declaration)
Public Function GetCurvesForBrowser As CurveArray
Visual C++
public:
CurveArray^ GetCurvesForBrowser()

Return Value

An array of curves representing the shape with its default parameters.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


NewDefinitionByArc Method

[image]

Revit 2010 API
RebarShape..::.NewDefinitionByArc Method
RebarShape Class See Also Send Feedback
Create a shape definition by arc, and associate it with this shape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarShapeDefinitionByArc NewDefinitionByArc()
Visual Basic (Declaration)
Public Function NewDefinitionByArc As RebarShapeDefinitionByArc
Visual C++
public:
RebarShapeDefinitionByArc^ NewDefinitionByArc()

Remarks

The returned value of this function and the returned value from Definition::get() are references to the same object.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


NewDefinitionBySegments Method

[image]

Revit 2010 API
RebarShape..::.NewDefinitionBySegments Method
RebarShape Class See Also Send Feedback
Create a shape definition by segments, and associate it with this shape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarShapeDefinitionBySegments NewDefinitionBySegments(
    int numSegments
)
Visual Basic (Declaration)
Public Function NewDefinitionBySegments ( _
    numSegments As Integer _
) As RebarShapeDefinitionBySegments
Visual C++
public:
RebarShapeDefinitionBySegments^ NewDefinitionBySegments(
    int numSegments
)

Parameters

numSegments
Type: System..::.Int32
The number of straight segments in the shape definition. This cannot be changed after the definition object is created.

Remarks

The returned value of this function and the returned value from Definition::get() are references to the same object.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


SetAllowed Method

[image]

Revit 2010 API
RebarShape..::.SetAllowed Method
RebarShape Class See Also Send Feedback
Specify which bar types can be used with this RebarShape. Bar types are allowed by default.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetAllowed(
    RebarBarType barType,
    bool allowed
)
Visual Basic (Declaration)
Public Sub SetAllowed ( _
    barType As RebarBarType, _
    allowed As Boolean _
)
Visual C++
public:
void SetAllowed(
    RebarBarType^ barType,
    bool allowed
)

Parameters

barType
Type: Autodesk.Revit.Symbols..::.RebarBarType
A bar type in the same document as this shape.
allowed
Type: System..::.Boolean
Whether this shape may be combined with barType.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


RebarShape Properties

[image] [image]

Revit 2010 API
RebarShape Properties
RebarShape Class See Also Send Feedback

The RebarShape type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Definition | Get the shape definition object associated with this shape.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HookAngle | Get and set the hook angle.
HookOrientation | Get and set the hook orientation.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RebarStyle | Access the rebar style.
SameShapeIgnoringHooks | Test whether two shapes have equivalent definitions.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SimpleArc | Check whether this shape consists of a single arc, possibly with hooks.
SimpleLine | Check whether this shape consists of a single straight segment, possibly with hooks.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


Definition Property

[image]

Revit 2010 API
RebarShape..::.Definition Property
RebarShape Class See Also Send Feedback
Get the shape definition object associated with this shape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarShapeDefinition Definition { get; }
Visual Basic (Declaration)
Public ReadOnly Property Definition As RebarShapeDefinition
Visual C++
public:
property RebarShapeDefinition^ Definition {
    RebarShapeDefinition^ get ();
}

Remarks

Returns null until one of the factory methods (e.g. NewDefinitionBySegments()) is called.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


HookAngle Property

[image]

Revit 2010 API
RebarShape..::.HookAngle Property
RebarShape Class See Also Send Feedback
Get and set the hook angle.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int HookAngle[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Property HookAngle ( _
    index As Integer _
) As Integer
Visual C++
public:
property int HookAngle[int index] {
    int get (int index);
    void set (int index, int value);
}

Parameters

index
Type: System..::.Int32
0 for the starting hook, 1 for the ending hook.

Remarks

The hook angle is expressed as an integral number of degrees (common values are 0, 90, 135, and 180).

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


HookOrientation Property

[image]

Revit 2010 API
RebarShape..::.HookOrientation Property
RebarShape Class See Also Send Feedback
Get and set the hook orientation.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarHookOrientation HookOrientation[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Property HookOrientation ( _
    index As Integer _
) As RebarHookOrientation
Visual C++
public:
property RebarHookOrientation HookOrientation[int index] {
    RebarHookOrientation get (int index);
    void set (int index, RebarHookOrientation value);
}

Parameters

index
Type: System..::.Int32
0 for the starting hook, 1 for the ending hook.

Remarks

Orientation is 1 for the left side of the shape or -1 for the right side. For arc-driven shapes, 1 is for the inside of the arc, -1 for the outside.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
RebarShape..::.Parameter Property
RebarShape Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

RebarShape Class
RebarShape Members
Autodesk.Revit.Symbols Namespace


RebarStyle Property

[image]

Revit 2010 API
RebarShape..::.RebarStyle Property
RebarShape Class See Also Send Feedback
Access the rebar style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarStyle RebarStyle { get; set; }
Visual Basic (Declaration)
Public Property RebarStyle As RebarStyle
Visual C++
public:
property RebarStyle RebarStyle {
    RebarStyle get ();
    void set (RebarStyle value);
}

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


SameShapeIgnoringHooks Property

[image]

Revit 2010 API
RebarShape..::.SameShapeIgnoringHooks Property
RebarShape Class See Also Send Feedback
Test whether two shapes have equivalent definitions.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SameShapeIgnoringHooks[
    RebarShape otherShape
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property SameShapeIgnoringHooks ( _
    otherShape As RebarShape _
) As Boolean
Visual C++
public:
property bool SameShapeIgnoringHooks[RebarShape^ otherShape] {
    bool get (RebarShape^ otherShape);
}

Parameters

otherShape
Type: Autodesk.Revit.Symbols..::.RebarShape
Another shape to be compared to this one.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


SimpleArc Property

[image]

Revit 2010 API
RebarShape..::.SimpleArc Property
RebarShape Class See Also Send Feedback
Check whether this shape consists of a single arc, possibly with hooks.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SimpleArc { get; }
Visual Basic (Declaration)
Public ReadOnly Property SimpleArc As Boolean
Visual C++
public:
property bool SimpleArc {
    bool get ();
}

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


SimpleLine Property

[image]

Revit 2010 API
RebarShape..::.SimpleLine Property
RebarShape Class See Also Send Feedback
Check whether this shape consists of a single straight segment, possibly with hooks.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SimpleLine { get; }
Visual Basic (Declaration)
Public ReadOnly Property SimpleLine As Boolean
Visual C++
public:
property bool SimpleLine {
    bool get ();
}

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace


RebarShapeDefinition Class

[image]

Revit 2010 API
RebarShapeDefinition Class
Members See Also Send Feedback
A class to assist in defining rebar shapes. A RebarShape element needs exactly one RebarShapeDefinition. The definition object is created by one of the factory methods on RebarShape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RebarShapeDefinition : APIObject
Visual Basic (Declaration)
Public Class RebarShapeDefinition _
    Inherits APIObject
Visual C++
public ref class RebarShapeDefinition : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.RebarShapeDefinition
Autodesk.Revit.Symbols..::.RebarShapeDefinitionByArc
Autodesk.Revit.Symbols..::.RebarShapeDefinitionBySegments

See Also

RebarShapeDefinition Members
Autodesk.Revit.Symbols Namespace


RebarShapeDefinition Members

[image] [image]

Revit 2010 API
RebarShapeDefinition Members
RebarShapeDefinition Class Constructors Methods Properties See Also Send Feedback

The RebarShapeDefinition type exposes the following members.

Constructors

Name | Description
RebarShapeDefinition | For Internal Use Only.

Methods

Name | Description
AddFormulaParameter | Add a formula-driven parameter to the shape definition.
AddParameter | Add a parameter to the shape definition.
CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values.
Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Complete | Report whether the shape definition is fully constrained.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarShapeDefinition Class
Autodesk.Revit.Symbols Namespace


RebarShapeDefinition Constructor

[image]

Revit 2010 API
RebarShapeDefinition Constructor
RebarShapeDefinition Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarShapeDefinition()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarShapeDefinition()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarShapeDefinition Class
Autodesk.Revit.Symbols Namespace


RebarShapeDefinition Methods

[image] [image]

Revit 2010 API
RebarShapeDefinition Methods
RebarShapeDefinition Class See Also Send Feedback

The RebarShapeDefinition type exposes the following members.

Methods

Name | Description
AddFormulaParameter | Add a formula-driven parameter to the shape definition.
AddParameter | Add a parameter to the shape definition.
CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values.
Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeDefinition Class
Autodesk.Revit.Symbols Namespace


AddFormulaParameter Method

[image]

Revit 2010 API
RebarShapeDefinition..::.AddFormulaParameter Method
RebarShapeDefinition Class See Also Send Feedback
Add a formula-driven parameter to the shape definition.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Parameter AddFormulaParameter(
    ExternalDefinition param,
    string formula
)
Visual Basic (Declaration)
Public Function AddFormulaParameter ( _
    param As ExternalDefinition, _
    formula As String _
) As Parameter
Visual C++
public:
Parameter^ AddFormulaParameter(
    ExternalDefinition^ param,
    String^ formula
)

Parameters

param
Type: Autodesk.Revit.Parameters..::.ExternalDefinition
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
formula
Type: System..::.String

Return Value

The new formula-driven shape parameter.

Remarks

Like AddParameter(), this function introduces a parameter into the shape definition, but the parameter's value is driven by a formula. Formula parameters cannot be used in constraints to drive the shape. The formula is in the same format as in Revit families. The formula is allowed to refer to other parameters that are already in the definition, plus the builtin parameters REBAR_INSTANCE_BAR_DIAMETER, REBAR_INSTANCE_BEND_DIAMETER, REBAR_SHAPE_START_HOOK_LENGTH, REBAR_SHAPE_START_HOOK_OFFSET, REBAR_SHAPE_END_HOOK_LENGTH, REBAR_SHAPE_END_HOOK_OFFSET, REBAR_ELEM_LENGTH, REBAR_ELEM_TOTAL_LENGTH, and REBAR_ELEM_QUANTITY_OF_BARS.

See Also

RebarShapeDefinition Class
Autodesk.Revit.Symbols Namespace


AddParameter Method

[image]

Revit 2010 API
RebarShapeDefinition..::.AddParameter Method
RebarShapeDefinition Class See Also Send Feedback
Add a parameter to the shape definition.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Parameter AddParameter(
    ExternalDefinition param,
    double defaultValue
)
Visual Basic (Declaration)
Public Function AddParameter ( _
    param As ExternalDefinition, _
    defaultValue As Double _
) As Parameter
Visual C++
public:
Parameter^ AddParameter(
    ExternalDefinition^ param,
    double defaultValue
)

Parameters

param
Type: Autodesk.Revit.Parameters..::.ExternalDefinition
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
defaultValue
Type: System..::.Double
A default value for this parameter in shapes. The default values should be chosen carefully, because they are required to be consistent as a set of constraints.

Remarks

Shape parameters must be shared parameters and have value type double. A parameter must be added with AddParameter() before it can be used to drive the shape with the various AddConstraint() functions. A parameter that does not drive a constraint is legal and will simply become an editable parameter on any Rebar that is an instance of this RebarShape.

See Also

RebarShapeDefinition Class
Autodesk.Revit.Symbols Namespace


CheckDefaultParameterValues Method

[image]

Revit 2010 API
RebarShapeDefinition..::.CheckDefaultParameterValues Method
RebarShapeDefinition Class See Also Send Feedback
Check that the shape can be solved with the default parameter values.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool CheckDefaultParameterValues(
    double bendRadius,
    double barDiam
)
Visual Basic (Declaration)
Public Function CheckDefaultParameterValues ( _
    bendRadius As Double, _
    barDiam As Double _
) As Boolean
Visual C++
public:
bool CheckDefaultParameterValues(
    double bendRadius,
    double barDiam
)

Parameters

bendRadius
Type: System..::.Double
A value for the Bend Radius parameter. Zero is allowed.
barDiam
Type: System..::.Double
A value for the Bar Diameter parameter. Zero is allowed.

Return Value

True if the rebar can be solved with the default parameter values and the given bend radius and bar diameter; false if it cannot.

Remarks

This function runs the rebar solver with the default parameter values. If it fails (returns false), rebar instances of this shape will not work. This may be from the default parameters being inconsistent, or from some error in the shape definition. The solver requires a specific bend radius and bar diameter, and the result depends on these values, but in practice they usually do not affect the result of this function as long as they are small. It is legal to pass 0.0 for both arguments. The definition must be Complete in order for this function to succeed. This function can be called before or after Commit().

See Also

RebarShapeDefinition Class
Autodesk.Revit.Symbols Namespace


Commit Method

[image]

Revit 2010 API
RebarShapeDefinition..::.Commit Method
RebarShapeDefinition Class See Also Send Feedback
Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Commit()
Visual Basic (Declaration)
Public Sub Commit
Visual C++
public:
void Commit()

See Also

RebarShapeDefinition Class
Autodesk.Revit.Symbols Namespace


RebarShapeDefinition Properties

[image] [image]

Revit 2010 API
RebarShapeDefinition Properties
RebarShapeDefinition Class See Also Send Feedback

The RebarShapeDefinition type exposes the following members.

Properties

Name | Description
Complete | Report whether the shape definition is fully constrained.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarShapeDefinition Class
Autodesk.Revit.Symbols Namespace


Complete Property

[image]

Revit 2010 API
RebarShapeDefinition..::.Complete Property
RebarShapeDefinition Class See Also Send Feedback
Report whether the shape definition is fully constrained.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Complete { get; }
Visual Basic (Declaration)
Public ReadOnly Property Complete As Boolean
Visual C++
public:
property bool Complete {
    bool get ();
}

See Also

RebarShapeDefinition Class
Autodesk.Revit.Symbols Namespace


RebarShapeDefinitionByArc Class

[image]

Revit 2010 API
RebarShapeDefinitionByArc Class
Members See Also Send Feedback
Definition of a shape whose size and position can determined by a single arc.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RebarShapeDefinitionByArc : RebarShapeDefinition
Visual Basic (Declaration)
Public Class RebarShapeDefinitionByArc _
    Inherits RebarShapeDefinition
Visual C++
public ref class RebarShapeDefinitionByArc : public RebarShapeDefinition

Remarks

In this shape definition, all dimensions are allowed to be driving dimensions.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.RebarShapeDefinition
Autodesk.Revit.Symbols..::.RebarShapeDefinitionByArc

See Also

RebarShapeDefinitionByArc Members
Autodesk.Revit.Symbols Namespace


RebarShapeDefinitionByArc Members

[image] [image]

Revit 2010 API
RebarShapeDefinitionByArc Members
RebarShapeDefinitionByArc Class Constructors Methods Properties See Also Send Feedback

The RebarShapeDefinitionByArc type exposes the following members.

Constructors

Name | Description
RebarShapeDefinitionByArc | For Internal Use Only.

Methods

Name | Description
AddConstraintArcLength | Specify a parameter to drive the arc length of the shape.
AddConstraintChordLength | Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).
AddConstraintCircumference | Specify a parameter to drive the circumference of the shape.
AddConstraintDiameter | Specify a parameter to drive the diameter of the shape.
AddConstraintRadius | Specify a parameter to drive the radius of the shape.
AddConstraintSagittaLength | Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).
AddFormulaParameter | Add a formula-driven parameter to the shape definition. (Inherited from RebarShapeDefinition.)
AddParameter | Add a parameter to the shape definition. (Inherited from RebarShapeDefinition.)
CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values. (Inherited from RebarShapeDefinition.)
Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed. (Inherited from RebarShapeDefinition.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Complete | Report whether the shape definition is fully constrained. (Inherited from RebarShapeDefinition.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Type | Among those rebar shapes defined by an arc, specify which kind.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace


RebarShapeDefinitionByArc Constructor

[image]

Revit 2010 API
RebarShapeDefinitionByArc Constructor
RebarShapeDefinitionByArc Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarShapeDefinitionByArc()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarShapeDefinitionByArc()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace


RebarShapeDefinitionByArc Methods

[image] [image]

Revit 2010 API
RebarShapeDefinitionByArc Methods
RebarShapeDefinitionByArc Class See Also Send Feedback

The RebarShapeDefinitionByArc type exposes the following members.

Methods

Name | Description
AddConstraintArcLength | Specify a parameter to drive the arc length of the shape.
AddConstraintChordLength | Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).
AddConstraintCircumference | Specify a parameter to drive the circumference of the shape.
AddConstraintDiameter | Specify a parameter to drive the diameter of the shape.
AddConstraintRadius | Specify a parameter to drive the radius of the shape.
AddConstraintSagittaLength | Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).
AddFormulaParameter | Add a formula-driven parameter to the shape definition. (Inherited from RebarShapeDefinition.)
AddParameter | Add a parameter to the shape definition. (Inherited from RebarShapeDefinition.)
CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values. (Inherited from RebarShapeDefinition.)
Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed. (Inherited from RebarShapeDefinition.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace


AddConstraintArcLength Method

[image]

Revit 2010 API
RebarShapeDefinitionByArc..::.AddConstraintArcLength Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the arc length of the shape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddConstraintArcLength(
    Parameter param
)
Visual Basic (Declaration)
Public Sub AddConstraintArcLength ( _
    param As Parameter _
)
Visual C++
public:
void AddConstraintArcLength(
    Parameter^ param
)

Parameters

param
Type: Autodesk.Revit..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace


AddConstraintChordLength Method

[image]

Revit 2010 API
RebarShapeDefinitionByArc..::.AddConstraintChordLength Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddConstraintChordLength(
    Parameter param
)
Visual Basic (Declaration)
Public Sub AddConstraintChordLength ( _
    param As Parameter _
)
Visual C++
public:
void AddConstraintChordLength(
    Parameter^ param
)

Parameters

param
Type: Autodesk.Revit..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().

Remarks

The chord length is measured on the centerline of the bar.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace


AddConstraintCircumference Method

[image]

Revit 2010 API
RebarShapeDefinitionByArc..::.AddConstraintCircumference Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the circumference of the shape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddConstraintCircumference(
    Parameter param,
    RebarShapeArcReferenceType arcRefType
)
Visual Basic (Declaration)
Public Sub AddConstraintCircumference ( _
    param As Parameter, _
    arcRefType As RebarShapeArcReferenceType _
)
Visual C++
public:
void AddConstraintCircumference(
    Parameter^ param,
    RebarShapeArcReferenceType arcRefType
)

Parameters

param
Type: Autodesk.Revit..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
arcRefType
Type: Autodesk.Revit.Structural.Enums..::.RebarShapeArcReferenceType
Specify along which circle the circumference is measured--to the interior of the bar, the centerline, or the exterior.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace


AddConstraintDiameter Method

[image]

Revit 2010 API
RebarShapeDefinitionByArc..::.AddConstraintDiameter Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the diameter of the shape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddConstraintDiameter(
    Parameter param,
    RebarShapeArcReferenceType arcRefType
)
Visual Basic (Declaration)
Public Sub AddConstraintDiameter ( _
    param As Parameter, _
    arcRefType As RebarShapeArcReferenceType _
)
Visual C++
public:
void AddConstraintDiameter(
    Parameter^ param,
    RebarShapeArcReferenceType arcRefType
)

Parameters

param
Type: Autodesk.Revit..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
arcRefType
Type: Autodesk.Revit.Structural.Enums..::.RebarShapeArcReferenceType
Specify how the diameter should be measured--to the interior of the bend, the centerline of the bar, or the exterior.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace


AddConstraintRadius Method

[image]

Revit 2010 API
RebarShapeDefinitionByArc..::.AddConstraintRadius Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the radius of the shape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddConstraintRadius(
    Parameter param,
    RebarShapeArcReferenceType arcRefType
)
Visual Basic (Declaration)
Public Sub AddConstraintRadius ( _
    param As Parameter, _
    arcRefType As RebarShapeArcReferenceType _
)
Visual C++
public:
void AddConstraintRadius(
    Parameter^ param,
    RebarShapeArcReferenceType arcRefType
)

Parameters

param
Type: Autodesk.Revit..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
arcRefType
Type: Autodesk.Revit.Structural.Enums..::.RebarShapeArcReferenceType
Specify how the radius should be measured--to the interior of the bend, the centerline of the bar, or the exterior.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace


AddConstraintSagittaLength Method

[image]

Revit 2010 API
RebarShapeDefinitionByArc..::.AddConstraintSagittaLength Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddConstraintSagittaLength(
    Parameter param
)
Visual Basic (Declaration)
Public Sub AddConstraintSagittaLength ( _
    param As Parameter _
)
Visual C++
public:
void AddConstraintSagittaLength(
    Parameter^ param
)

Parameters

param
Type: Autodesk.Revit..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().

Remarks

The sagitta will be measured on the centerline of the bar.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace


RebarShapeDefinitionByArc Properties

[image] [image]

Revit 2010 API
RebarShapeDefinitionByArc Properties
RebarShapeDefinitionByArc Class See Also Send Feedback

The RebarShapeDefinitionByArc type exposes the following members.

Properties

Name | Description
Complete | Report whether the shape definition is fully constrained. (Inherited from RebarShapeDefinition.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Type | Among those rebar shapes defined by an arc, specify which kind.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace


Type Property

[image]

Revit 2010 API
RebarShapeDefinitionByArc..::.Type Property
RebarShapeDefinitionByArc Class See Also Send Feedback
Among those rebar shapes defined by an arc, specify which kind.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarShapeDefinitionByArcType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As RebarShapeDefinitionByArcType
Visual C++
public:
property RebarShapeDefinitionByArcType Type {
    RebarShapeDefinitionByArcType get ();
    void set (RebarShapeDefinitionByArcType value);
}

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace


RebarShapeDefinitionBySegments Class

[image]

Revit 2010 API
RebarShapeDefinitionBySegments Class
Members See Also Send Feedback
Definition of a shape in terms of one or more straight segments of rebar, with arc bends between the segments.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RebarShapeDefinitionBySegments : RebarShapeDefinition
Visual Basic (Declaration)
Public Class RebarShapeDefinitionBySegments _
    Inherits RebarShapeDefinition
Visual C++
public ref class RebarShapeDefinitionBySegments : public RebarShapeDefinition

Remarks

The segments are numbered starting with 0, and they have a direction; so the beginning of the shape is end 0 of segment 0, and the end of the shape is end 1 of segment (n-1). Each segment must have enough constraints to determine its position. Overconstraining is allowed. The most common combinations are: (1) A fixed direction together with a parallel length constraint; (2) A parallel length constraint plus another length constraint parallel to the x-axis or y-axis; (3) A parallel length constraint plus length constraints parallel to both the x-axis and y-axis. Multiple constraints may be driven by the same parameter, even on the same segment. Length constraints may be measured in two ways. For "measured to the outside of the bend," the reference is a tangent to the exterior face of the bar; the thickness of the bar is included. For "measured to the inside," the reference is the center of the arc of the bend; this is the point where the bend begins, if the constraint is parallel to the segment. A bend may have the default radius of the bar type referenced by the Rebar element, or it may have a radius defined by a parameter. A 180-degree bend is described by introducing an extra segment in between the two straight segments, tangent to the midpoint of the bend.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.RebarShapeDefinition
Autodesk.Revit.Symbols..::.RebarShapeDefinitionBySegments

See Also

RebarShapeDefinitionBySegments Members
Autodesk.Revit.Symbols Namespace


RebarShapeDefinitionBySegments Members

[image] [image]

Revit 2010 API
RebarShapeDefinitionBySegments Members
RebarShapeDefinitionBySegments Class Constructors Methods Properties See Also Send Feedback

The RebarShapeDefinitionBySegments type exposes the following members.

Constructors

Name | Description
RebarShapeDefinitionBySegments | For Internal Use Only.

Methods

Name | Description
AddBendDefaultRadius | Specify a default-radius bend.
AddBendVariableRadius | Specify a variable-radius bend.
AddConstraintParallelToSegment | Constrain the length of a segment by parametrizing its length.
AddConstraintToSegment | Add a constraint that helps determine the length of a segment.
AddFormulaParameter | Add a formula-driven parameter to the shape definition. (Inherited from RebarShapeDefinition.)
AddListeningDimensionBendToBend | Specify a dimension between two bends, measured by a read-only parameter.
AddListeningDimensionSegmentToBend | Specify a dimension perpendicular to one fixed-direction segment, referring to that segment and some other bend in the shape, measured by a read-only parameter.
AddListeningDimensionSegmentToSegment | Specify a dimension perpendicular to two fixed-direction segments, measured by a read-only parameter.
AddParameter | Add a parameter to the shape definition. (Inherited from RebarShapeDefinition.)
CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values. (Inherited from RebarShapeDefinition.)
Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed. (Inherited from RebarShapeDefinition.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
RemoveParameterFromSegment | Remove constraints from a segment.
SetSegmentAs180DegreeBend | Overloaded. Indicates that a segment is a "virtual" segment introduced to describe a 180-degree bend.
SetSegmentFixedDirection | Fix the direction of a segment.
SetSegmentVariableDirection | Remove the fixed direction from a segment.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Complete | Report whether the shape definition is fully constrained. (Inherited from RebarShapeDefinition.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
NumberOfSegments | The number of straight segments in this shape.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


RebarShapeDefinitionBySegments Constructor

[image]

Revit 2010 API
RebarShapeDefinitionBySegments Constructor
RebarShapeDefinitionBySegments Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarShapeDefinitionBySegments()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarShapeDefinitionBySegments()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


RebarShapeDefinitionBySegments Methods

[image] [image]

Revit 2010 API
RebarShapeDefinitionBySegments Methods
RebarShapeDefinitionBySegments Class See Also Send Feedback

The RebarShapeDefinitionBySegments type exposes the following members.

Methods

Name | Description
AddBendDefaultRadius | Specify a default-radius bend.
AddBendVariableRadius | Specify a variable-radius bend.
AddConstraintParallelToSegment | Constrain the length of a segment by parametrizing its length.
AddConstraintToSegment | Add a constraint that helps determine the length of a segment.
AddFormulaParameter | Add a formula-driven parameter to the shape definition. (Inherited from RebarShapeDefinition.)
AddListeningDimensionBendToBend | Specify a dimension between two bends, measured by a read-only parameter.
AddListeningDimensionSegmentToBend | Specify a dimension perpendicular to one fixed-direction segment, referring to that segment and some other bend in the shape, measured by a read-only parameter.
AddListeningDimensionSegmentToSegment | Specify a dimension perpendicular to two fixed-direction segments, measured by a read-only parameter.
AddParameter | Add a parameter to the shape definition. (Inherited from RebarShapeDefinition.)
CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values. (Inherited from RebarShapeDefinition.)
Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed. (Inherited from RebarShapeDefinition.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
RemoveParameterFromSegment | Remove constraints from a segment.
SetSegmentAs180DegreeBend | Overloaded. Indicates that a segment is a "virtual" segment introduced to describe a 180-degree bend.
SetSegmentFixedDirection | Fix the direction of a segment.
SetSegmentVariableDirection | Remove the fixed direction from a segment.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


AddBendDefaultRadius Method

[image]

Revit 2010 API
RebarShapeDefinitionBySegments..::.AddBendDefaultRadius Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a default-radius bend.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddBendDefaultRadius(
    int iSegmentFollowingBend,
    int turn,
    RebarShapeBendAngle angle
)
Visual Basic (Declaration)
Public Sub AddBendDefaultRadius ( _
    iSegmentFollowingBend As Integer, _
    turn As Integer, _
    angle As RebarShapeBendAngle _
)
Visual C++
public:
void AddBendDefaultRadius(
    int iSegmentFollowingBend,
    int turn,
    RebarShapeBendAngle angle
)

Parameters

iSegmentFollowingBend
Type: System..::.Int32
Index of the segment after the bend (1 to NumberOfSegments - 1).
turn
Type: System..::.Int32
Specify 1 for a left turn, -1 for a right turn.
angle
Type: Autodesk.Revit.Structural.Enums..::.RebarShapeBendAngle
Specify whether the bend is acute, obtuse, etc.

Remarks

You must add a bend between each two segments.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


AddBendVariableRadius Method

[image]

Revit 2010 API
RebarShapeDefinitionBySegments..::.AddBendVariableRadius Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a variable-radius bend.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddBendVariableRadius(
    int iSegmentFollowingBend,
    int turn,
    RebarShapeBendAngle angle,
    Parameter radiusParam,
    bool measureIncludingBarThickness
)
Visual Basic (Declaration)
Public Sub AddBendVariableRadius ( _
    iSegmentFollowingBend As Integer, _
    turn As Integer, _
    angle As RebarShapeBendAngle, _
    radiusParam As Parameter, _
    measureIncludingBarThickness As Boolean _
)
Visual C++
public:
void AddBendVariableRadius(
    int iSegmentFollowingBend,
    int turn,
    RebarShapeBendAngle angle,
    Parameter^ radiusParam,
    bool measureIncludingBarThickness
)

Parameters

iSegmentFollowingBend
Type: System..::.Int32
Index of the segment after the bend (1 to NumberOfSegments - 1).
turn
Type: System..::.Int32
Specify 1 for a left turn, -1 for a right turn.
angle
Type: Autodesk.Revit.Structural.Enums..::.RebarShapeBendAngle
Specify whether the bend is acute, obtuse, etc.
radiusParam
Type: Autodesk.Revit..::.Parameter
A parameter defining the radius. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
measureIncludingBarThickness
Type: System..::.Boolean
If false, the radius is measured to the inside of the bend; if false, it is measured to the outside.

Remarks

You must add a bend between each two segments.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


AddConstraintParallelToSegment Method

[image]

Revit 2010 API
RebarShapeDefinitionBySegments..::.AddConstraintParallelToSegment Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Constrain the length of a segment by parametrizing its length.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddConstraintParallelToSegment(
    int iSegment,
    Parameter param,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)
Visual Basic (Declaration)
Public Sub AddConstraintParallelToSegment ( _
    iSegment As Integer, _
    param As Parameter, _
    measureToOutsideOfBend0 As Boolean, _
    measureToOutsideOfBend1 As Boolean _
)
Visual C++
public:
void AddConstraintParallelToSegment(
    int iSegment,
    Parameter^ param,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)

Parameters

iSegment
Type: System..::.Int32
Index of the segment (0 to NumberOfSegments - 1).
param
Type: Autodesk.Revit..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
measureToOutsideOfBend0
Type: System..::.Boolean
Choose between two possibilities for the first reference of the length dimension. If false, the reference is at the point where the bend begins; equivalently, at the projection of the bend centerpoint onto the segment. If true, the reference is moved outward by a distance equal to the bend radius plus the bar diameter; if the bend is a right angle or greater, this is equivalent to putting the reference at the outer face of the bend.
measureToOutsideOfBend1
Type: System..::.Boolean
Choose between two possibilities for the second reference of the length dimension.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


AddConstraintToSegment Method

[image]

Revit 2010 API
RebarShapeDefinitionBySegments..::.AddConstraintToSegment Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Add a constraint that helps determine the length of a segment.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddConstraintToSegment(
    int iSegment,
    Parameter param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int signOfZCoordOfCrossProductOfConstraintDirBySegmentDir,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)
Visual Basic (Declaration)
Public Sub AddConstraintToSegment ( _
    iSegment As Integer, _
    param As Parameter, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    signOfZCoordOfCrossProductOfConstraintDirBySegmentDir As Integer, _
    measureToOutsideOfBend0 As Boolean, _
    measureToOutsideOfBend1 As Boolean _
)
Visual C++
public:
void AddConstraintToSegment(
    int iSegment,
    Parameter^ param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int signOfZCoordOfCrossProductOfConstraintDirBySegmentDir,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)

Parameters

iSegment
Type: System..::.Int32
Index of the segment (0 to NumberOfSegments - 1).
param
Type: Autodesk.Revit..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
constraintDirCoordX
Type: System..::.Double
The x-coordinate of a 2D vector specifying the constraint direction.
constraintDirCoordY
Type: System..::.Double
The y-coordinate of a 2D vector specifying the constraint direction.
signOfZCoordOfCrossProductOfConstraintDirBySegmentDir
Type: System..::.Int32
Legal values are 1 and -1. For a fixed-direction segment, this value is ignored. For a variable-direction segment, this value is combined with the constraint length (the nonnegative value associated with 'param') to determine the direction of the segment. For example, a segment whose direction vector lies in the upper-right quadrant of the plane, and whose x-axis projected length is A and whose y-axis projected length is B, could be created by calling: AddConstraintToSegment(iSegment, paramA, 1.0, 0.0, 1, ...) AddConstraintToSegment(iSegment, paramB, 0.0, 1.0, -1, ...)
measureToOutsideOfBend0
Type: System..::.Boolean
Choose between two possibilities for the first reference of the length dimension. If false, the reference is at the point where the bend begins; equivalently, at the projection of the bend centerpoint onto the segment. If true, the reference is moved outward by a distance equal to the bend radius plus the bar diameter; if the bend is a right angle or greater, this is equivalent to putting the reference at the outer face of the bend.
measureToOutsideOfBend1
Type: System..::.Boolean
Choose between two possibilities for the second reference of the length dimension.

Remarks

The vector defined by (constraintDirCoordX, constraintDirCoordY) must have a positive dot product with the desired direction of the segment. This restriction, combined with the value of signOfZCoordOfCrossProductOfConstraintDirBySegmentDir, defines a quadrant of the plane that limits the variable-angle segment.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


AddListeningDimensionBendToBend Method

[image]

Revit 2010 API
RebarShapeDefinitionBySegments..::.AddListeningDimensionBendToBend Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a dimension between two bends, measured by a read-only parameter.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddListeningDimensionBendToBend(
    Parameter param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iEnd0,
    int iSegment1,
    int iEnd1
)
Visual Basic (Declaration)
Public Sub AddListeningDimensionBendToBend ( _
    param As Parameter, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    iSegment0 As Integer, _
    iEnd0 As Integer, _
    iSegment1 As Integer, _
    iEnd1 As Integer _
)
Visual C++
public:
void AddListeningDimensionBendToBend(
    Parameter^ param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iEnd0,
    int iSegment1,
    int iEnd1
)

Parameters

param
Type: Autodesk.Revit..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
constraintDirCoordX
Type: System..::.Double
The x-coordinate of a 2D vector specifying the constraint direction.
constraintDirCoordY
Type: System..::.Double
The y-coordinate of a 2D vector specifying the constraint direction.
iSegment0
Type: System..::.Int32
Index of the first segment.
iEnd0
Type: System..::.Int32
End (0 or 1) of the first segment.
iSegment1
Type: System..::.Int32
Index of the second segment.
iEnd1
Type: System..::.Int32
End (0 or 1) of the second segment.

Remarks

Each reference is at the outside of the bend, perpendicular to the specified segment. So the overall length of a shape with 5 segments might be defined by calling this function with iSegment0=0, iEnd0=0, iSegment1=4, iEnd1=1.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


AddListeningDimensionSegmentToBend Method

[image]

Revit 2010 API
RebarShapeDefinitionBySegments..::.AddListeningDimensionSegmentToBend Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a dimension perpendicular to one fixed-direction segment, referring to that segment and some other bend in the shape, measured by a read-only parameter.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddListeningDimensionSegmentToBend(
    Parameter param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1,
    int iEnd1
)
Visual Basic (Declaration)
Public Sub AddListeningDimensionSegmentToBend ( _
    param As Parameter, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    iSegment0 As Integer, _
    iSegment1 As Integer, _
    iEnd1 As Integer _
)
Visual C++
public:
void AddListeningDimensionSegmentToBend(
    Parameter^ param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1,
    int iEnd1
)

Parameters

param
Type: Autodesk.Revit..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
constraintDirCoordX
Type: System..::.Double
The x-coordinate of a 2D vector specifying the constraint direction.
constraintDirCoordY
Type: System..::.Double
The y-coordinate of a 2D vector specifying the constraint direction.
iSegment0
Type: System..::.Int32
Index of the first segment, which must be perpendicular to the constraint direction.
iSegment1
Type: System..::.Int32
Index of the second segment.
iEnd1
Type: System..::.Int32
End (0 or 1) of the second segment.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


AddListeningDimensionSegmentToSegment Method

[image]

Revit 2010 API
RebarShapeDefinitionBySegments..::.AddListeningDimensionSegmentToSegment Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a dimension perpendicular to two fixed-direction segments, measured by a read-only parameter.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddListeningDimensionSegmentToSegment(
    Parameter param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1
)
Visual Basic (Declaration)
Public Sub AddListeningDimensionSegmentToSegment ( _
    param As Parameter, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    iSegment0 As Integer, _
    iSegment1 As Integer _
)
Visual C++
public:
void AddListeningDimensionSegmentToSegment(
    Parameter^ param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1
)

Parameters

param
Type: Autodesk.Revit..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
constraintDirCoordX
Type: System..::.Double
The x-coordinate of a 2D vector specifying the constraint direction.
constraintDirCoordY
Type: System..::.Double
The y-coordinate of a 2D vector specifying the constraint direction.
iSegment0
Type: System..::.Int32
Index of the first segment (0 to NumberOfSegments - 1).
iSegment1
Type: System..::.Int32
Index of the second segment (0 to NumberOfSegments - 1).

Remarks

RebarShapeDefinitionBySegments supports driving (read-write) dimensions only when they are associated with a single segment. Non-driving dimensions can involve multiple segments.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


RemoveParameterFromSegment Method

[image]

Revit 2010 API
RebarShapeDefinitionBySegments..::.RemoveParameterFromSegment Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Remove constraints from a segment.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveParameterFromSegment(
    int iSegment,
    Parameter param
)
Visual Basic (Declaration)
Public Sub RemoveParameterFromSegment ( _
    iSegment As Integer, _
    param As Parameter _
)
Visual C++
public:
void RemoveParameterFromSegment(
    int iSegment,
    Parameter^ param
)

Parameters

iSegment
Type: System..::.Int32
Index of the segment (0 to NumberOfSegments - 1).
param
Type: Autodesk.Revit..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().

Remarks

This reverses the effect of any AddConstraint and SetSegmentAs180DegreeBend operations involving the specified segment and parameter.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


SetSegmentAs180DegreeBend Method

[image] [image]

Revit 2010 API
RebarShapeDefinitionBySegments..::.SetSegmentAs180DegreeBend Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Indicates that a segment is a "virtual" segment introduced to describe a 180-degree bend.

Overload List

Name | Description
SetSegmentAs180DegreeBend(Int32) | Indicates that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be taken from the Bar Type.
SetSegmentAs180DegreeBend(Int32, Parameter, Boolean) | Indicate that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be driven by radiusParam.

See Also

RebarShapeDefinitionBySegments Class
RebarShapeDefinitionBySegments Members
Autodesk.Revit.Symbols Namespace


SetSegmentAs180DegreeBend Method (Int32)

[image]

Revit 2010 API
RebarShapeDefinitionBySegments..::.SetSegmentAs180DegreeBend Method (Int32)
RebarShapeDefinitionBySegments Class See Also Send Feedback
Indicates that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be taken from the Bar Type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetSegmentAs180DegreeBend(
    int iSegment
)
Visual Basic (Declaration)
Public Sub SetSegmentAs180DegreeBend ( _
    iSegment As Integer _
)
Visual C++
public:
void SetSegmentAs180DegreeBend(
    int iSegment
)

Parameters

iSegment
Type: System..::.Int32
Index of the segment (0 to NumberOfSegments - 1).

See Also

RebarShapeDefinitionBySegments Class
SetSegmentAs180DegreeBend Overload
Autodesk.Revit.Symbols Namespace


SetSegmentAs180DegreeBend Method (Int32, Parameter, Boolean)

[image]

Revit 2010 API
RebarShapeDefinitionBySegments..::.SetSegmentAs180DegreeBend Method (Int32, Parameter, Boolean)
RebarShapeDefinitionBySegments Class See Also Send Feedback
Indicate that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be driven by radiusParam.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetSegmentAs180DegreeBend(
    int iSegment,
    Parameter radiusParam,
    bool measureToOutsideOfBend
)
Visual Basic (Declaration)
Public Sub SetSegmentAs180DegreeBend ( _
    iSegment As Integer, _
    radiusParam As Parameter, _
    measureToOutsideOfBend As Boolean _
)
Visual C++
public:
void SetSegmentAs180DegreeBend(
    int iSegment,
    Parameter^ radiusParam,
    bool measureToOutsideOfBend
)

Parameters

iSegment
Type: System..::.Int32
Index of the segment (0 to NumberOfSegments - 1).
radiusParam
Type: Autodesk.Revit..::.Parameter
A parameter to define the radius. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
measureToOutsideOfBend
Type: System..::.Boolean
Choose between two possibilities for the references of the length dimension. If false, the references is at the point where the bend begins; equivalently, at the projection of the bend centerpoint onto the segment. If true, the reference is moved outward by a distance equal to the bend radius plus the bar diameter; if the bend is a right angle or greater, this is equivalent to putting the reference at the outer face of the bend.

See Also

RebarShapeDefinitionBySegments Class
SetSegmentAs180DegreeBend Overload
Autodesk.Revit.Symbols Namespace


SetSegmentFixedDirection Method

[image]

Revit 2010 API
RebarShapeDefinitionBySegments..::.SetSegmentFixedDirection Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Fix the direction of a segment.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetSegmentFixedDirection(
    int iSegment,
    double vecCoordX,
    double vecCoordY
)
Visual Basic (Declaration)
Public Sub SetSegmentFixedDirection ( _
    iSegment As Integer, _
    vecCoordX As Double, _
    vecCoordY As Double _
)
Visual C++
public:
void SetSegmentFixedDirection(
    int iSegment,
    double vecCoordX,
    double vecCoordY
)

Parameters

iSegment
Type: System..::.Int32
Index of the segment (0 to NumberOfSegments - 1).
vecCoordX
Type: System..::.Double
The x-coordinate of a 2D vector specifying the segment direction.
vecCoordY
Type: System..::.Double
The y-coordinate of a 2D vector specifying the segment direction.

Remarks

The centerline of the segment will be constrained to be parallel to the vector. The line must have at least one constraint.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


SetSegmentVariableDirection Method

[image]

Revit 2010 API
RebarShapeDefinitionBySegments..::.SetSegmentVariableDirection Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Remove the fixed direction from a segment.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetSegmentVariableDirection(
    int iSegment
)
Visual Basic (Declaration)
Public Sub SetSegmentVariableDirection ( _
    iSegment As Integer _
)
Visual C++
public:
void SetSegmentVariableDirection(
    int iSegment
)

Parameters

iSegment
Type: System..::.Int32
Index of the segment (0 to NumberOfSegments - 1).

Remarks

The segment's angle will be allowed to vary, with a range of 90 degrees. The line must have at least two constraints.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


RebarShapeDefinitionBySegments Properties

[image] [image]

Revit 2010 API
RebarShapeDefinitionBySegments Properties
RebarShapeDefinitionBySegments Class See Also Send Feedback

The RebarShapeDefinitionBySegments type exposes the following members.

Properties

Name | Description
Complete | Report whether the shape definition is fully constrained. (Inherited from RebarShapeDefinition.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
NumberOfSegments | The number of straight segments in this shape.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


NumberOfSegments Property

[image]

Revit 2010 API
RebarShapeDefinitionBySegments..::.NumberOfSegments Property
RebarShapeDefinitionBySegments Class See Also Send Feedback
The number of straight segments in this shape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NumberOfSegments { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumberOfSegments As Integer
Visual C++
public:
property int NumberOfSegments {
    int get ();
}

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.Symbols Namespace


RebarShapeSet Class

[image]

Revit 2010 API
RebarShapeSet Class
Members See Also Send Feedback
An set that contains rebar shapes.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RebarShapeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class RebarShapeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class RebarShapeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.RebarShapeSet

See Also

RebarShapeSet Members
Autodesk.Revit.Symbols Namespace


RebarShapeSet Members

[image] [image]

Revit 2010 API
RebarShapeSet Members
RebarShapeSet Class Constructors Methods Properties See Also Send Feedback

The RebarShapeSet type exposes the following members.

Constructors

Name | Description
RebarShapeSet | Initializes a new instance of the RebarShapeSet class

Methods

Name | Description
Clear | Removes every rebar shape from the set, rendering it empty.
Contains | Tests for the existence of a rebar shape within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified rebar shape from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified rebar shape into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of rebar shapes that are in the set.

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


RebarShapeSet Constructor

[image]

Revit 2010 API
RebarShapeSet Constructor
RebarShapeSet Class See Also Send Feedback
Initializes a new instance of the RebarShapeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarShapeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarShapeSet()

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


RebarShapeSet Methods

[image] [image]

Revit 2010 API
RebarShapeSet Methods
RebarShapeSet Class See Also Send Feedback

The RebarShapeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every rebar shape from the set, rendering it empty.
Contains | Tests for the existence of a rebar shape within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified rebar shape from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified rebar shape into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
RebarShapeSet..::.Clear Method
RebarShapeSet Class See Also Send Feedback
Removes every rebar shape from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
RebarShapeSet..::.Contains Method
RebarShapeSet Class See Also Send Feedback
Tests for the existence of a rebar shape within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    RebarShape item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As RebarShape _
) As Boolean
Visual C++
public:
virtual bool Contains(
    RebarShape^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.RebarShape
The rebar shape to be searched for.

Return Value

The Contains method returns True if the rebar shape is within the set, otherwise False.

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
RebarShapeSet..::.Erase Method
RebarShapeSet Class See Also Send Feedback
Removes a specified rebar shape from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    RebarShape item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As RebarShape _
) As Integer
Visual C++
public:
virtual int Erase(
    RebarShape^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.RebarShape
The rebar shape to be erased.

Return Value

The number of rebar shapes that were erased from the set.

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
RebarShapeSet..::.ForwardIterator Method
RebarShapeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual RebarShapeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As RebarShapeSetIterator
Visual C++
public:
virtual RebarShapeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
RebarShapeSet..::.GetEnumerator Method
RebarShapeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
RebarShapeSet..::.Insert Method
RebarShapeSet Class See Also Send Feedback
Insert the specified rebar shape into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    RebarShape item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As RebarShape _
) As Boolean
Visual C++
public:
virtual bool Insert(
    RebarShape^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.RebarShape
The rebar shape to be inserted into the set.

Return Value

Returns whether the rebar shape was inserted into the set.

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
RebarShapeSet..::.ReverseIterator Method
RebarShapeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual RebarShapeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As RebarShapeSetIterator
Visual C++
public:
virtual RebarShapeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


RebarShapeSet Properties

[image] [image]

Revit 2010 API
RebarShapeSet Properties
RebarShapeSet Class See Also Send Feedback

The RebarShapeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of rebar shapes that are in the set.

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
RebarShapeSet..::.IsEmpty Property
RebarShapeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
RebarShapeSet..::.Size Property
RebarShapeSet Class See Also Send Feedback
Returns the number of rebar shapes that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RebarShapeSet Class
Autodesk.Revit.Symbols Namespace


RebarShapeSetIterator Class

[image]

Revit 2010 API
RebarShapeSetIterator Class
Members See Also Send Feedback
An iterator to a rebar shape set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class RebarShapeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class RebarShapeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class RebarShapeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.RebarShapeSetIterator

See Also

RebarShapeSetIterator Members
Autodesk.Revit.Symbols Namespace


RebarShapeSetIterator Members

[image] [image]

Revit 2010 API
RebarShapeSetIterator Members
RebarShapeSetIterator Class Constructors Methods Properties See Also Send Feedback

The RebarShapeSetIterator type exposes the following members.

Constructors

Name | Description
RebarShapeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarShapeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarShapeSetIterator Constructor

[image]

Revit 2010 API
RebarShapeSetIterator Constructor
RebarShapeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarShapeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarShapeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarShapeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarShapeSetIterator Methods

[image] [image]

Revit 2010 API
RebarShapeSetIterator Methods
RebarShapeSetIterator Class See Also Send Feedback

The RebarShapeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
RebarShapeSetIterator..::.MoveNext Method
RebarShapeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RebarShapeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
RebarShapeSetIterator..::.Reset Method
RebarShapeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RebarShapeSetIterator Class
Autodesk.Revit.Symbols Namespace


RebarShapeSetIterator Properties

[image] [image]

Revit 2010 API
RebarShapeSetIterator Properties
RebarShapeSetIterator Class See Also Send Feedback

The RebarShapeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarShapeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
RebarShapeSetIterator..::.Current Property
RebarShapeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RebarShapeSetIterator Class
Autodesk.Revit.Symbols Namespace


RoofType Class

[image]

Revit 2010 API
RoofType Class
Members See Also Send Feedback
Represents a specific type of roof.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RoofType : HostObjAttributes
Visual Basic (Declaration)
Public Class RoofType _
    Inherits HostObjAttributes
Visual C++
public ref class RoofType : public HostObjAttributes

Remarks

All roof type objects available in the project can be retrieved from the Document object via the RoofTypes property. Every Roof object has a RoofType property that returns a RoofType object representing the type. This same RoofType property can also be used to change the type of the roof by setting it to a different type.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.HostObjAttributes
Autodesk.Revit.Symbols..::.RoofType

See Also

RoofType Members
Autodesk.Revit.Symbols Namespace


RoofType Members

[image] [image]

Revit 2010 API
RoofType Members
RoofType Class Constructors Methods Properties See Also Send Feedback

The RoofType type exposes the following members.

Constructors

Name | Description
RoofType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RoofType Class
Autodesk.Revit.Symbols Namespace


RoofType Constructor

[image]

Revit 2010 API
RoofType Constructor
RoofType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RoofType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoofType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RoofType Class
Autodesk.Revit.Symbols Namespace


RoofType Methods

[image] [image]

Revit 2010 API
RoofType Methods
RoofType Class See Also Send Feedback

The RoofType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoofType Class
Autodesk.Revit.Symbols Namespace


RoofType Properties

[image] [image]

Revit 2010 API
RoofType Properties
RoofType Class See Also Send Feedback

The RoofType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RoofType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
RoofType..::.Parameter Property
RoofType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

RoofType Class
RoofType Members
Autodesk.Revit.Symbols Namespace


RoofTypeSet Class

[image]

Revit 2010 API
RoofTypeSet Class
Members See Also Send Feedback
A set that contains roof types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RoofTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class RoofTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class RoofTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.RoofTypeSet

See Also

RoofTypeSet Members
Autodesk.Revit.Symbols Namespace


RoofTypeSet Members

[image] [image]

Revit 2010 API
RoofTypeSet Members
RoofTypeSet Class Constructors Methods Properties See Also Send Feedback

The RoofTypeSet type exposes the following members.

Constructors

Name | Description
RoofTypeSet | Initializes a new instance of the RoofTypeSet class

Methods

Name | Description
Clear | Removes every roof type from the set, rendering it empty.
Contains | Tests for the existence of a roof type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified roof type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified roof type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of roof types that are in the set.

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


RoofTypeSet Constructor

[image]

Revit 2010 API
RoofTypeSet Constructor
RoofTypeSet Class See Also Send Feedback
Initializes a new instance of the RoofTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RoofTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoofTypeSet()

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


RoofTypeSet Methods

[image] [image]

Revit 2010 API
RoofTypeSet Methods
RoofTypeSet Class See Also Send Feedback

The RoofTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every roof type from the set, rendering it empty.
Contains | Tests for the existence of a roof type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified roof type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified roof type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
RoofTypeSet..::.Clear Method
RoofTypeSet Class See Also Send Feedback
Removes every roof type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
RoofTypeSet..::.Contains Method
RoofTypeSet Class See Also Send Feedback
Tests for the existence of a roof type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    RoofType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As RoofType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    RoofType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.RoofType
The roof type to be searched for.

Return Value

The Contains method returns True if the roof type is within the set, otherwise False.

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
RoofTypeSet..::.Erase Method
RoofTypeSet Class See Also Send Feedback
Removes a specified roof type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    RoofType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As RoofType _
) As Integer
Visual C++
public:
virtual int Erase(
    RoofType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.RoofType
The roof type to be erased.

Return Value

The number of roof types that were erased from the set.

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
RoofTypeSet..::.ForwardIterator Method
RoofTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual RoofTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As RoofTypeSetIterator
Visual C++
public:
virtual RoofTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
RoofTypeSet..::.GetEnumerator Method
RoofTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
RoofTypeSet..::.Insert Method
RoofTypeSet Class See Also Send Feedback
Insert the specified roof type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    RoofType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As RoofType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    RoofType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.RoofType
The roof type to be inserted into the set.

Return Value

Returns whether the roof type was inserted into the set.

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
RoofTypeSet..::.ReverseIterator Method
RoofTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual RoofTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As RoofTypeSetIterator
Visual C++
public:
virtual RoofTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


RoofTypeSet Properties

[image] [image]

Revit 2010 API
RoofTypeSet Properties
RoofTypeSet Class See Also Send Feedback

The RoofTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of roof types that are in the set.

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
RoofTypeSet..::.IsEmpty Property
RoofTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
RoofTypeSet..::.Size Property
RoofTypeSet Class See Also Send Feedback
Returns the number of roof types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace


RoofTypeSetIterator Class

[image]

Revit 2010 API
RoofTypeSetIterator Class
Members See Also Send Feedback
An iterator to a roof type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class RoofTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class RoofTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class RoofTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.RoofTypeSetIterator

See Also

RoofTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


RoofTypeSetIterator Members

[image] [image]

Revit 2010 API
RoofTypeSetIterator Members
RoofTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The RoofTypeSetIterator type exposes the following members.

Constructors

Name | Description
RoofTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RoofTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RoofTypeSetIterator Constructor

[image]

Revit 2010 API
RoofTypeSetIterator Constructor
RoofTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RoofTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoofTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RoofTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RoofTypeSetIterator Methods

[image] [image]

Revit 2010 API
RoofTypeSetIterator Methods
RoofTypeSetIterator Class See Also Send Feedback

The RoofTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoofTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
RoofTypeSetIterator..::.MoveNext Method
RoofTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RoofTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
RoofTypeSetIterator..::.Reset Method
RoofTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RoofTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RoofTypeSetIterator Properties

[image] [image]

Revit 2010 API
RoofTypeSetIterator Properties
RoofTypeSetIterator Class See Also Send Feedback

The RoofTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RoofTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
RoofTypeSetIterator..::.Current Property
RoofTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RoofTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RoomTagType Class

[image]

Revit 2010 API
RoomTagType Class
Members See Also Send Feedback
An object that represents a Room Tag type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RoomTagType : FamilySymbol
Visual Basic (Declaration)
Public Class RoomTagType _
    Inherits FamilySymbol
Visual C++
public ref class RoomTagType : public FamilySymbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.InsertableObject
Autodesk.Revit.Symbols..::.FamilySymbol
Autodesk.Revit.Symbols..::.RoomTagType

See Also

RoomTagType Members
Autodesk.Revit.Symbols Namespace


RoomTagType Members

[image] [image]

Revit 2010 API
RoomTagType Members
RoomTagType Class Constructors Methods Properties See Also Send Feedback

The RoomTagType type exposes the following members.

Constructors

Name | Description
RoomTagType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Material | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RoomTagType Class
Autodesk.Revit.Symbols Namespace


RoomTagType Constructor

[image]

Revit 2010 API
RoomTagType Constructor
RoomTagType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RoomTagType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoomTagType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RoomTagType Class
Autodesk.Revit.Symbols Namespace


RoomTagType Methods

[image] [image]

Revit 2010 API
RoomTagType Methods
RoomTagType Class See Also Send Feedback

The RoomTagType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoomTagType Class
Autodesk.Revit.Symbols Namespace


RoomTagType Properties

[image] [image]

Revit 2010 API
RoomTagType Properties
RoomTagType Class See Also Send Feedback

The RoomTagType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Material | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

RoomTagType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
RoomTagType..::.Parameter Property
RoomTagType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

RoomTagType Class
RoomTagType Members
Autodesk.Revit.Symbols Namespace


RoomTagTypeSet Class

[image]

Revit 2010 API
RoomTagTypeSet Class
Members See Also Send Feedback
A set that contains room tag types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RoomTagTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class RoomTagTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class RoomTagTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.RoomTagTypeSet

See Also

RoomTagTypeSet Members
Autodesk.Revit.Symbols Namespace


RoomTagTypeSet Members

[image] [image]

Revit 2010 API
RoomTagTypeSet Members
RoomTagTypeSet Class Constructors Methods Properties See Also Send Feedback

The RoomTagTypeSet type exposes the following members.

Constructors

Name | Description
RoomTagTypeSet | Initializes a new instance of the RoomTagTypeSet class

Methods

Name | Description
Clear | Removes every room tag type from the set, rendering it empty.
Contains | Tests for the existence of a room tag type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified room tag type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified room tag type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of room tag types that are in the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


RoomTagTypeSet Constructor

[image]

Revit 2010 API
RoomTagTypeSet Constructor
RoomTagTypeSet Class See Also Send Feedback
Initializes a new instance of the RoomTagTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RoomTagTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoomTagTypeSet()

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


RoomTagTypeSet Methods

[image] [image]

Revit 2010 API
RoomTagTypeSet Methods
RoomTagTypeSet Class See Also Send Feedback

The RoomTagTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every room tag type from the set, rendering it empty.
Contains | Tests for the existence of a room tag type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified room tag type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified room tag type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
RoomTagTypeSet..::.Clear Method
RoomTagTypeSet Class See Also Send Feedback
Removes every room tag type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
RoomTagTypeSet..::.Contains Method
RoomTagTypeSet Class See Also Send Feedback
Tests for the existence of a room tag type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    RoomTagType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As RoomTagType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    RoomTagType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.RoomTagType
The room tag type to be searched for.

Return Value

The Contains method returns True if the room tag type is within the set, otherwise False.

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
RoomTagTypeSet..::.Erase Method
RoomTagTypeSet Class See Also Send Feedback
Removes a specified room tag type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    RoomTagType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As RoomTagType _
) As Integer
Visual C++
public:
virtual int Erase(
    RoomTagType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.RoomTagType
The room tag type to be erased.

Return Value

The number of room tag types that were erased from the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
RoomTagTypeSet..::.ForwardIterator Method
RoomTagTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual RoomTagTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As RoomTagTypeSetIterator
Visual C++
public:
virtual RoomTagTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
RoomTagTypeSet..::.GetEnumerator Method
RoomTagTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
RoomTagTypeSet..::.Insert Method
RoomTagTypeSet Class See Also Send Feedback
Insert the specified room tag type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    RoomTagType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As RoomTagType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    RoomTagType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.RoomTagType
The room tag type to be inserted into the set.

Return Value

Returns whether the room tag type was inserted into the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
RoomTagTypeSet..::.ReverseIterator Method
RoomTagTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual RoomTagTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As RoomTagTypeSetIterator
Visual C++
public:
virtual RoomTagTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


RoomTagTypeSet Properties

[image] [image]

Revit 2010 API
RoomTagTypeSet Properties
RoomTagTypeSet Class See Also Send Feedback

The RoomTagTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of room tag types that are in the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
RoomTagTypeSet..::.IsEmpty Property
RoomTagTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
RoomTagTypeSet..::.Size Property
RoomTagTypeSet Class See Also Send Feedback
Returns the number of room tag types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RoomTagTypeSet Class
Autodesk.Revit.Symbols Namespace


RoomTagTypeSetIterator Class

[image]

Revit 2010 API
RoomTagTypeSetIterator Class
Members See Also Send Feedback
An iterator to a room tag type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class RoomTagTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class RoomTagTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class RoomTagTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.RoomTagTypeSetIterator

See Also

RoomTagTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


RoomTagTypeSetIterator Members

[image] [image]

Revit 2010 API
RoomTagTypeSetIterator Members
RoomTagTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The RoomTagTypeSetIterator type exposes the following members.

Constructors

Name | Description
RoomTagTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RoomTagTypeSetIterator Constructor

[image]

Revit 2010 API
RoomTagTypeSetIterator Constructor
RoomTagTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RoomTagTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoomTagTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RoomTagTypeSetIterator Methods

[image] [image]

Revit 2010 API
RoomTagTypeSetIterator Methods
RoomTagTypeSetIterator Class See Also Send Feedback

The RoomTagTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
RoomTagTypeSetIterator..::.MoveNext Method
RoomTagTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
RoomTagTypeSetIterator..::.Reset Method
RoomTagTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


RoomTagTypeSetIterator Properties

[image] [image]

Revit 2010 API
RoomTagTypeSetIterator Properties
RoomTagTypeSetIterator Class See Also Send Feedback

The RoomTagTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
RoomTagTypeSetIterator..::.Current Property
RoomTagTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


SlabEdgeType Class

[image]

Revit 2010 API
SlabEdgeType Class
Members See Also Send Feedback
An object that represents the slab edge type in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SlabEdgeType : HostedSweepType
Visual Basic (Declaration)
Public Class SlabEdgeType _
    Inherits HostedSweepType
Visual C++
public ref class SlabEdgeType : public HostedSweepType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.HostObjAttributes
Autodesk.Revit.Symbols..::.HostedSweepType
Autodesk.Revit.Symbols..::.SlabEdgeType

See Also

SlabEdgeType Members
Autodesk.Revit.Symbols Namespace


SlabEdgeType Members

[image] [image]

Revit 2010 API
SlabEdgeType Members
SlabEdgeType Class Constructors Methods Properties See Also Send Feedback

The SlabEdgeType type exposes the following members.

Constructors

Name | Description
SlabEdgeType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SlabEdgeType Class
Autodesk.Revit.Symbols Namespace


SlabEdgeType Constructor

[image]

Revit 2010 API
SlabEdgeType Constructor
SlabEdgeType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabEdgeType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabEdgeType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabEdgeType Class
Autodesk.Revit.Symbols Namespace


SlabEdgeType Methods

[image] [image]

Revit 2010 API
SlabEdgeType Methods
SlabEdgeType Class See Also Send Feedback

The SlabEdgeType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabEdgeType Class
Autodesk.Revit.Symbols Namespace


SlabEdgeType Properties

[image] [image]

Revit 2010 API
SlabEdgeType Properties
SlabEdgeType Class See Also Send Feedback

The SlabEdgeType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SlabEdgeType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
SlabEdgeType..::.Parameter Property
SlabEdgeType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SlabEdgeType Class
SlabEdgeType Members
Autodesk.Revit.Symbols Namespace


SlabEdgeTypeSet Class

[image]

Revit 2010 API
SlabEdgeTypeSet Class
Members See Also Send Feedback
A set that contains slab edge types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SlabEdgeTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class SlabEdgeTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SlabEdgeTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.SlabEdgeTypeSet

See Also

SlabEdgeTypeSet Members
Autodesk.Revit.Symbols Namespace


SlabEdgeTypeSet Members

[image] [image]

Revit 2010 API
SlabEdgeTypeSet Members
SlabEdgeTypeSet Class Constructors Methods Properties See Also Send Feedback

The SlabEdgeTypeSet type exposes the following members.

Constructors

Name | Description
SlabEdgeTypeSet | Initializes a new instance of the SlabEdgeTypeSet class

Methods

Name | Description
Clear | Removes every slab edge type from the set, rendering it empty.
Contains | Tests for the existence of a slab edge type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified slab edge type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified slab edge type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of slab edge types that are in the set.

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


SlabEdgeTypeSet Constructor

[image]

Revit 2010 API
SlabEdgeTypeSet Constructor
SlabEdgeTypeSet Class See Also Send Feedback
Initializes a new instance of the SlabEdgeTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabEdgeTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabEdgeTypeSet()

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


SlabEdgeTypeSet Methods

[image] [image]

Revit 2010 API
SlabEdgeTypeSet Methods
SlabEdgeTypeSet Class See Also Send Feedback

The SlabEdgeTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every slab edge type from the set, rendering it empty.
Contains | Tests for the existence of a slab edge type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified slab edge type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified slab edge type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
SlabEdgeTypeSet..::.Clear Method
SlabEdgeTypeSet Class See Also Send Feedback
Removes every slab edge type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
SlabEdgeTypeSet..::.Contains Method
SlabEdgeTypeSet Class See Also Send Feedback
Tests for the existence of a slab edge type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    SlabEdgeType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As SlabEdgeType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    SlabEdgeType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.SlabEdgeType
The slab edge type to be searched for.

Return Value

The Contains method returns True if the slab edge type is within the set, otherwise False.

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
SlabEdgeTypeSet..::.Erase Method
SlabEdgeTypeSet Class See Also Send Feedback
Removes a specified slab edge type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    SlabEdgeType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As SlabEdgeType _
) As Integer
Visual C++
public:
virtual int Erase(
    SlabEdgeType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.SlabEdgeType
The slab edge type to be erased.

Return Value

The number of slab edge types that were erased from the set.

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
SlabEdgeTypeSet..::.ForwardIterator Method
SlabEdgeTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual SlabEdgeTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SlabEdgeTypeSetIterator
Visual C++
public:
virtual SlabEdgeTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
SlabEdgeTypeSet..::.GetEnumerator Method
SlabEdgeTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
SlabEdgeTypeSet..::.Insert Method
SlabEdgeTypeSet Class See Also Send Feedback
Insert the specified slab edge type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    SlabEdgeType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As SlabEdgeType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    SlabEdgeType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.SlabEdgeType
The slab edge type to be inserted into the set.

Return Value

Returns whether the slab edge type was inserted into the set.

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
SlabEdgeTypeSet..::.ReverseIterator Method
SlabEdgeTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual SlabEdgeTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SlabEdgeTypeSetIterator
Visual C++
public:
virtual SlabEdgeTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


SlabEdgeTypeSet Properties

[image] [image]

Revit 2010 API
SlabEdgeTypeSet Properties
SlabEdgeTypeSet Class See Also Send Feedback

The SlabEdgeTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of slab edge types that are in the set.

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
SlabEdgeTypeSet..::.IsEmpty Property
SlabEdgeTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
SlabEdgeTypeSet..::.Size Property
SlabEdgeTypeSet Class See Also Send Feedback
Returns the number of slab edge types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SlabEdgeTypeSet Class
Autodesk.Revit.Symbols Namespace


SlabEdgeTypeSetIterator Class

[image]

Revit 2010 API
SlabEdgeTypeSetIterator Class
Members See Also Send Feedback
An iterator to a slab edge type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class SlabEdgeTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class SlabEdgeTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SlabEdgeTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.SlabEdgeTypeSetIterator

See Also

SlabEdgeTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


SlabEdgeTypeSetIterator Members

[image] [image]

Revit 2010 API
SlabEdgeTypeSetIterator Members
SlabEdgeTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The SlabEdgeTypeSetIterator type exposes the following members.

Constructors

Name | Description
SlabEdgeTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabEdgeTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


SlabEdgeTypeSetIterator Constructor

[image]

Revit 2010 API
SlabEdgeTypeSetIterator Constructor
SlabEdgeTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabEdgeTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabEdgeTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabEdgeTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


SlabEdgeTypeSetIterator Methods

[image] [image]

Revit 2010 API
SlabEdgeTypeSetIterator Methods
SlabEdgeTypeSetIterator Class See Also Send Feedback

The SlabEdgeTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabEdgeTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
SlabEdgeTypeSetIterator..::.MoveNext Method
SlabEdgeTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SlabEdgeTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
SlabEdgeTypeSetIterator..::.Reset Method
SlabEdgeTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SlabEdgeTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


SlabEdgeTypeSetIterator Properties

[image] [image]

Revit 2010 API
SlabEdgeTypeSetIterator Properties
SlabEdgeTypeSetIterator Class See Also Send Feedback

The SlabEdgeTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabEdgeTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
SlabEdgeTypeSetIterator..::.Current Property
SlabEdgeTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SlabEdgeTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


SpaceTagType Class

[image]

Revit 2010 API
SpaceTagType Class
Members See Also Send Feedback
An object that represents a Space Tag style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SpaceTagType : FamilySymbol
Visual Basic (Declaration)
Public Class SpaceTagType _
    Inherits FamilySymbol
Visual C++
public ref class SpaceTagType : public FamilySymbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.InsertableObject
Autodesk.Revit.Symbols..::.FamilySymbol
Autodesk.Revit.Symbols..::.SpaceTagType

See Also

SpaceTagType Members
Autodesk.Revit.Symbols Namespace


SpaceTagType Members

[image] [image]

Revit 2010 API
SpaceTagType Members
SpaceTagType Class Constructors Methods Properties See Also Send Feedback

The SpaceTagType type exposes the following members.

Constructors

Name | Description
SpaceTagType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Material | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SpaceTagType Class
Autodesk.Revit.Symbols Namespace


SpaceTagType Constructor

[image]

Revit 2010 API
SpaceTagType Constructor
SpaceTagType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpaceTagType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpaceTagType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SpaceTagType Class
Autodesk.Revit.Symbols Namespace


SpaceTagType Methods

[image] [image]

Revit 2010 API
SpaceTagType Methods
SpaceTagType Class See Also Send Feedback

The SpaceTagType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceTagType Class
Autodesk.Revit.Symbols Namespace


SpaceTagType Properties

[image] [image]

Revit 2010 API
SpaceTagType Properties
SpaceTagType Class See Also Send Feedback

The SpaceTagType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Material | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SpaceTagType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
SpaceTagType..::.Parameter Property
SpaceTagType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SpaceTagType Class
SpaceTagType Members
Autodesk.Revit.Symbols Namespace


SpaceTagTypeSet Class

[image]

Revit 2010 API
SpaceTagTypeSet Class
Members See Also Send Feedback
A set that contains space tag types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SpaceTagTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class SpaceTagTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SpaceTagTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.SpaceTagTypeSet

See Also

SpaceTagTypeSet Members
Autodesk.Revit.Symbols Namespace


SpaceTagTypeSet Members

[image] [image]

Revit 2010 API
SpaceTagTypeSet Members
SpaceTagTypeSet Class Constructors Methods Properties See Also Send Feedback

The SpaceTagTypeSet type exposes the following members.

Constructors

Name | Description
SpaceTagTypeSet | Initializes a new instance of the SpaceTagTypeSet class

Methods

Name | Description
Clear | Removes every space tag type from the set, rendering it empty.
Contains | Tests for the existence of a space tag type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified space tag type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified space tag type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of space tag types that are in the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


SpaceTagTypeSet Constructor

[image]

Revit 2010 API
SpaceTagTypeSet Constructor
SpaceTagTypeSet Class See Also Send Feedback
Initializes a new instance of the SpaceTagTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpaceTagTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpaceTagTypeSet()

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


SpaceTagTypeSet Methods

[image] [image]

Revit 2010 API
SpaceTagTypeSet Methods
SpaceTagTypeSet Class See Also Send Feedback

The SpaceTagTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every space tag type from the set, rendering it empty.
Contains | Tests for the existence of a space tag type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified space tag type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified space tag type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
SpaceTagTypeSet..::.Clear Method
SpaceTagTypeSet Class See Also Send Feedback
Removes every space tag type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
SpaceTagTypeSet..::.Contains Method
SpaceTagTypeSet Class See Also Send Feedback
Tests for the existence of a space tag type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    SpaceTagType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As SpaceTagType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    SpaceTagType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.SpaceTagType
The space tag type to be searched for.

Return Value

The Contains method returns True if the space tag type is within the set, otherwise False.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
SpaceTagTypeSet..::.Erase Method
SpaceTagTypeSet Class See Also Send Feedback
Removes a specified space tag type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    SpaceTagType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As SpaceTagType _
) As Integer
Visual C++
public:
virtual int Erase(
    SpaceTagType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.SpaceTagType
The space tag type to be erased.

Return Value

The number of space tag types that were erased from the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
SpaceTagTypeSet..::.ForwardIterator Method
SpaceTagTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual SpaceTagTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SpaceTagTypeSetIterator
Visual C++
public:
virtual SpaceTagTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
SpaceTagTypeSet..::.GetEnumerator Method
SpaceTagTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
SpaceTagTypeSet..::.Insert Method
SpaceTagTypeSet Class See Also Send Feedback
Insert the specified space tag type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    SpaceTagType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As SpaceTagType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    SpaceTagType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.SpaceTagType
The space tag type to be inserted into the set.

Return Value

Returns whether the space tag type was inserted into the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
SpaceTagTypeSet..::.ReverseIterator Method
SpaceTagTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual SpaceTagTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SpaceTagTypeSetIterator
Visual C++
public:
virtual SpaceTagTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


SpaceTagTypeSet Properties

[image] [image]

Revit 2010 API
SpaceTagTypeSet Properties
SpaceTagTypeSet Class See Also Send Feedback

The SpaceTagTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of space tag types that are in the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
SpaceTagTypeSet..::.IsEmpty Property
SpaceTagTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
SpaceTagTypeSet..::.Size Property
SpaceTagTypeSet Class See Also Send Feedback
Returns the number of space tag types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SpaceTagTypeSet Class
Autodesk.Revit.Symbols Namespace


SpaceTagTypeSetIterator Class

[image]

Revit 2010 API
SpaceTagTypeSetIterator Class
Members See Also Send Feedback
An iterator to a space tag type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class SpaceTagTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class SpaceTagTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SpaceTagTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.SpaceTagTypeSetIterator

See Also

SpaceTagTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


SpaceTagTypeSetIterator Members

[image] [image]

Revit 2010 API
SpaceTagTypeSetIterator Members
SpaceTagTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The SpaceTagTypeSetIterator type exposes the following members.

Constructors

Name | Description
SpaceTagTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


SpaceTagTypeSetIterator Constructor

[image]

Revit 2010 API
SpaceTagTypeSetIterator Constructor
SpaceTagTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpaceTagTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpaceTagTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


SpaceTagTypeSetIterator Methods

[image] [image]

Revit 2010 API
SpaceTagTypeSetIterator Methods
SpaceTagTypeSetIterator Class See Also Send Feedback

The SpaceTagTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
SpaceTagTypeSetIterator..::.MoveNext Method
SpaceTagTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
SpaceTagTypeSetIterator..::.Reset Method
SpaceTagTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


SpaceTagTypeSetIterator Properties

[image] [image]

Revit 2010 API
SpaceTagTypeSetIterator Properties
SpaceTagTypeSetIterator Class See Also Send Feedback

The SpaceTagTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
SpaceTagTypeSetIterator..::.Current Property
SpaceTagTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


SpotDimensionType Class

[image]

Revit 2010 API
SpotDimensionType Class
Members See Also Send Feedback
An object that specifies the type of a spot dimension in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SpotDimensionType : DimensionType
Visual Basic (Declaration)
Public Class SpotDimensionType _
    Inherits DimensionType
Visual C++
public ref class SpotDimensionType : public DimensionType

Remarks

The types of a spot dimension can be accessed via this object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.DimensionType
Autodesk.Revit.Symbols..::.SpotDimensionType

See Also

SpotDimensionType Members
Autodesk.Revit.Symbols Namespace


SpotDimensionType Members

[image] [image]

Revit 2010 API
SpotDimensionType Members
SpotDimensionType Class Constructors Methods Properties See Also Send Feedback

The SpotDimensionType type exposes the following members.

Constructors

Name | Description
SpotDimensionType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SpotDimensionType Class
Autodesk.Revit.Symbols Namespace


SpotDimensionType Constructor

[image]

Revit 2010 API
SpotDimensionType Constructor
SpotDimensionType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpotDimensionType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpotDimensionType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SpotDimensionType Class
Autodesk.Revit.Symbols Namespace


SpotDimensionType Methods

[image] [image]

Revit 2010 API
SpotDimensionType Methods
SpotDimensionType Class See Also Send Feedback

The SpotDimensionType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpotDimensionType Class
Autodesk.Revit.Symbols Namespace


SpotDimensionType Properties

[image] [image]

Revit 2010 API
SpotDimensionType Properties
SpotDimensionType Class See Also Send Feedback

The SpotDimensionType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

SpotDimensionType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
SpotDimensionType..::.Parameter Property
SpotDimensionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SpotDimensionType Class
SpotDimensionType Members
Autodesk.Revit.Symbols Namespace


SpotDimensionTypeSet Class

[image]

Revit 2010 API
SpotDimensionTypeSet Class
Members See Also Send Feedback
A set that contains spotdimension types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SpotDimensionTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class SpotDimensionTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SpotDimensionTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.SpotDimensionTypeSet

See Also

SpotDimensionTypeSet Members
Autodesk.Revit.Symbols Namespace


SpotDimensionTypeSet Members

[image] [image]

Revit 2010 API
SpotDimensionTypeSet Members
SpotDimensionTypeSet Class Constructors Methods Properties See Also Send Feedback

The SpotDimensionTypeSet type exposes the following members.

Constructors

Name | Description
SpotDimensionTypeSet | Initializes a new instance of the SpotDimensionTypeSet class

Methods

Name | Description
Clear | Removes every spotdimension type from the set, rendering it empty.
Contains | Tests for the existence of a spotdimension type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified spotdimension type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified spotdimension type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of spotdimension types that are in the set.

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


SpotDimensionTypeSet Constructor

[image]

Revit 2010 API
SpotDimensionTypeSet Constructor
SpotDimensionTypeSet Class See Also Send Feedback
Initializes a new instance of the SpotDimensionTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpotDimensionTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpotDimensionTypeSet()

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


SpotDimensionTypeSet Methods

[image] [image]

Revit 2010 API
SpotDimensionTypeSet Methods
SpotDimensionTypeSet Class See Also Send Feedback

The SpotDimensionTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every spotdimension type from the set, rendering it empty.
Contains | Tests for the existence of a spotdimension type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified spotdimension type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified spotdimension type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
SpotDimensionTypeSet..::.Clear Method
SpotDimensionTypeSet Class See Also Send Feedback
Removes every spotdimension type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
SpotDimensionTypeSet..::.Contains Method
SpotDimensionTypeSet Class See Also Send Feedback
Tests for the existence of a spotdimension type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    SpotDimensionType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As SpotDimensionType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    SpotDimensionType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.SpotDimensionType
The spotdimension type to be searched for.

Return Value

The Contains method returns True if the spotdimension type is within the set, otherwise False.

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
SpotDimensionTypeSet..::.Erase Method
SpotDimensionTypeSet Class See Also Send Feedback
Removes a specified spotdimension type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    SpotDimensionType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As SpotDimensionType _
) As Integer
Visual C++
public:
virtual int Erase(
    SpotDimensionType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.SpotDimensionType
The spotdimension type to be erased.

Return Value

The number of spotdimension types that were erased from the set.

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
SpotDimensionTypeSet..::.ForwardIterator Method
SpotDimensionTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual SpotDimensionTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SpotDimensionTypeSetIterator
Visual C++
public:
virtual SpotDimensionTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
SpotDimensionTypeSet..::.GetEnumerator Method
SpotDimensionTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
SpotDimensionTypeSet..::.Insert Method
SpotDimensionTypeSet Class See Also Send Feedback
Insert the specified spotdimension type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    SpotDimensionType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As SpotDimensionType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    SpotDimensionType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.SpotDimensionType
The spotdimension type to be inserted into the set.

Return Value

Returns whether the spotdimension type was inserted into the set.

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
SpotDimensionTypeSet..::.ReverseIterator Method
SpotDimensionTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual SpotDimensionTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SpotDimensionTypeSetIterator
Visual C++
public:
virtual SpotDimensionTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


SpotDimensionTypeSet Properties

[image] [image]

Revit 2010 API
SpotDimensionTypeSet Properties
SpotDimensionTypeSet Class See Also Send Feedback

The SpotDimensionTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of spotdimension types that are in the set.

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
SpotDimensionTypeSet..::.IsEmpty Property
SpotDimensionTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
SpotDimensionTypeSet..::.Size Property
SpotDimensionTypeSet Class See Also Send Feedback
Returns the number of spotdimension types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SpotDimensionTypeSet Class
Autodesk.Revit.Symbols Namespace


SpotDimensionTypeSetIterator Class

[image]

Revit 2010 API
SpotDimensionTypeSetIterator Class
Members See Also Send Feedback
An iterator to a spotdimension type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class SpotDimensionTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class SpotDimensionTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SpotDimensionTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.SpotDimensionTypeSetIterator

See Also

SpotDimensionTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


SpotDimensionTypeSetIterator Members

[image] [image]

Revit 2010 API
SpotDimensionTypeSetIterator Members
SpotDimensionTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The SpotDimensionTypeSetIterator type exposes the following members.

Constructors

Name | Description
SpotDimensionTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpotDimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


SpotDimensionTypeSetIterator Constructor

[image]

Revit 2010 API
SpotDimensionTypeSetIterator Constructor
SpotDimensionTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpotDimensionTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpotDimensionTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SpotDimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


SpotDimensionTypeSetIterator Methods

[image] [image]

Revit 2010 API
SpotDimensionTypeSetIterator Methods
SpotDimensionTypeSetIterator Class See Also Send Feedback

The SpotDimensionTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpotDimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
SpotDimensionTypeSetIterator..::.MoveNext Method
SpotDimensionTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SpotDimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
SpotDimensionTypeSetIterator..::.Reset Method
SpotDimensionTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SpotDimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


SpotDimensionTypeSetIterator Properties

[image] [image]

Revit 2010 API
SpotDimensionTypeSetIterator Properties
SpotDimensionTypeSetIterator Class See Also Send Feedback

The SpotDimensionTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpotDimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
SpotDimensionTypeSetIterator..::.Current Property
SpotDimensionTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SpotDimensionTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


TextElementType Class

[image]

Revit 2010 API
TextElementType Class
Members See Also Send Feedback
An object that represents a text style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class TextElementType : LineAndTextAttrSymbol
Visual Basic (Declaration)
Public Class TextElementType _
    Inherits LineAndTextAttrSymbol
Visual C++
public ref class TextElementType : public LineAndTextAttrSymbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.LineAndTextAttrSymbol
Autodesk.Revit.Symbols..::.TextElementType
Autodesk.Revit.Symbols..::.TextNoteType

See Also

TextElementType Members
Autodesk.Revit.Symbols Namespace


TextElementType Members

[image] [image]

Revit 2010 API
TextElementType Members
TextElementType Class Constructors Methods Properties See Also Send Feedback

The TextElementType type exposes the following members.

Constructors

Name | Description
TextElementType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

TextElementType Class
Autodesk.Revit.Symbols Namespace


TextElementType Constructor

[image]

Revit 2010 API
TextElementType Constructor
TextElementType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TextElementType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextElementType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TextElementType Class
Autodesk.Revit.Symbols Namespace


TextElementType Methods

[image] [image]

Revit 2010 API
TextElementType Methods
TextElementType Class See Also Send Feedback

The TextElementType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextElementType Class
Autodesk.Revit.Symbols Namespace


TextElementType Properties

[image] [image]

Revit 2010 API
TextElementType Properties
TextElementType Class See Also Send Feedback

The TextElementType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

TextElementType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
TextElementType..::.Parameter Property
TextElementType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

TextElementType Class
TextElementType Members
Autodesk.Revit.Symbols Namespace


TextNoteType Class

[image]

Revit 2010 API
TextNoteType Class
Members See Also Send Feedback
An object that represents a text note style.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class TextNoteType : TextElementType
Visual Basic (Declaration)
Public Class TextNoteType _
    Inherits TextElementType
Visual C++
public ref class TextNoteType : public TextElementType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.LineAndTextAttrSymbol
Autodesk.Revit.Symbols..::.TextElementType
Autodesk.Revit.Symbols..::.TextNoteType

See Also

TextNoteType Members
Autodesk.Revit.Symbols Namespace


TextNoteType Members

[image] [image]

Revit 2010 API
TextNoteType Members
TextNoteType Class Constructors Methods Properties See Also Send Feedback

The TextNoteType type exposes the following members.

Constructors

Name | Description
TextNoteType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

TextNoteType Class
Autodesk.Revit.Symbols Namespace


TextNoteType Constructor

[image]

Revit 2010 API
TextNoteType Constructor
TextNoteType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TextNoteType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextNoteType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TextNoteType Class
Autodesk.Revit.Symbols Namespace


TextNoteType Methods

[image] [image]

Revit 2010 API
TextNoteType Methods
TextNoteType Class See Also Send Feedback

The TextNoteType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextNoteType Class
Autodesk.Revit.Symbols Namespace


TextNoteType Properties

[image] [image]

Revit 2010 API
TextNoteType Properties
TextNoteType Class See Also Send Feedback

The TextNoteType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

TextNoteType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
TextNoteType..::.Parameter Property
TextNoteType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

TextNoteType Class
TextNoteType Members
Autodesk.Revit.Symbols Namespace


TextNoteTypeSet Class

[image]

Revit 2010 API
TextNoteTypeSet Class
Members See Also Send Feedback
A set that contains textnote types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class TextNoteTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class TextNoteTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class TextNoteTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.TextNoteTypeSet

See Also

TextNoteTypeSet Members
Autodesk.Revit.Symbols Namespace


TextNoteTypeSet Members

[image] [image]

Revit 2010 API
TextNoteTypeSet Members
TextNoteTypeSet Class Constructors Methods Properties See Also Send Feedback

The TextNoteTypeSet type exposes the following members.

Constructors

Name | Description
TextNoteTypeSet | Initializes a new instance of the TextNoteTypeSet class

Methods

Name | Description
Clear | Removes every textnote type from the set, rendering it empty.
Contains | Tests for the existence of a textnote type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified textnote type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified textnote type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of textnote types that are in the set.

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


TextNoteTypeSet Constructor

[image]

Revit 2010 API
TextNoteTypeSet Constructor
TextNoteTypeSet Class See Also Send Feedback
Initializes a new instance of the TextNoteTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TextNoteTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextNoteTypeSet()

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


TextNoteTypeSet Methods

[image] [image]

Revit 2010 API
TextNoteTypeSet Methods
TextNoteTypeSet Class See Also Send Feedback

The TextNoteTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every textnote type from the set, rendering it empty.
Contains | Tests for the existence of a textnote type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified textnote type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified textnote type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
TextNoteTypeSet..::.Clear Method
TextNoteTypeSet Class See Also Send Feedback
Removes every textnote type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
TextNoteTypeSet..::.Contains Method
TextNoteTypeSet Class See Also Send Feedback
Tests for the existence of a textnote type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    TextNoteType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As TextNoteType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    TextNoteType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.TextNoteType
The textnote type to be searched for.

Return Value

The Contains method returns True if the textnote type is within the set, otherwise False.

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
TextNoteTypeSet..::.Erase Method
TextNoteTypeSet Class See Also Send Feedback
Removes a specified textnote type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    TextNoteType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As TextNoteType _
) As Integer
Visual C++
public:
virtual int Erase(
    TextNoteType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.TextNoteType
The textnote type to be erased.

Return Value

The number of textnote types that were erased from the set.

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
TextNoteTypeSet..::.ForwardIterator Method
TextNoteTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual TextNoteTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As TextNoteTypeSetIterator
Visual C++
public:
virtual TextNoteTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
TextNoteTypeSet..::.GetEnumerator Method
TextNoteTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
TextNoteTypeSet..::.Insert Method
TextNoteTypeSet Class See Also Send Feedback
Insert the specified textnote type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    TextNoteType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As TextNoteType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    TextNoteType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.TextNoteType
The textnote type to be inserted into the set.

Return Value

Returns whether the textnote type was inserted into the set.

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
TextNoteTypeSet..::.ReverseIterator Method
TextNoteTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual TextNoteTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As TextNoteTypeSetIterator
Visual C++
public:
virtual TextNoteTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


TextNoteTypeSet Properties

[image] [image]

Revit 2010 API
TextNoteTypeSet Properties
TextNoteTypeSet Class See Also Send Feedback

The TextNoteTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of textnote types that are in the set.

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
TextNoteTypeSet..::.IsEmpty Property
TextNoteTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
TextNoteTypeSet..::.Size Property
TextNoteTypeSet Class See Also Send Feedback
Returns the number of textnote types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

TextNoteTypeSet Class
Autodesk.Revit.Symbols Namespace


TextNoteTypeSetIterator Class

[image]

Revit 2010 API
TextNoteTypeSetIterator Class
Members See Also Send Feedback
An iterator to a textnote type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class TextNoteTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class TextNoteTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class TextNoteTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.TextNoteTypeSetIterator

See Also

TextNoteTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


TextNoteTypeSetIterator Members

[image] [image]

Revit 2010 API
TextNoteTypeSetIterator Members
TextNoteTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The TextNoteTypeSetIterator type exposes the following members.

Constructors

Name | Description
TextNoteTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TextNoteTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


TextNoteTypeSetIterator Constructor

[image]

Revit 2010 API
TextNoteTypeSetIterator Constructor
TextNoteTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TextNoteTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextNoteTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TextNoteTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


TextNoteTypeSetIterator Methods

[image] [image]

Revit 2010 API
TextNoteTypeSetIterator Methods
TextNoteTypeSetIterator Class See Also Send Feedback

The TextNoteTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextNoteTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
TextNoteTypeSetIterator..::.MoveNext Method
TextNoteTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

TextNoteTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
TextNoteTypeSetIterator..::.Reset Method
TextNoteTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

TextNoteTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


TextNoteTypeSetIterator Properties

[image] [image]

Revit 2010 API
TextNoteTypeSetIterator Properties
TextNoteTypeSetIterator Class See Also Send Feedback

The TextNoteTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TextNoteTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
TextNoteTypeSetIterator..::.Current Property
TextNoteTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

TextNoteTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


TilePattern Class

[image]

Revit 2010 API
TilePattern Class
Members See Also Send Feedback
An object representing a tile pattern that may be applied to a DividedSurface.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class TilePattern : Symbol
Visual Basic (Declaration)
Public Class TilePattern _
    Inherits Symbol
Visual C++
public ref class TilePattern : public Symbol

Remarks

TilePatterns cannot be created. A fixed selection is built into each Conceptual Mass family. TilePatterns can be retrieved by key from the Revit::Document::Settings::TilePatternTable object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.TilePattern

See Also

TilePattern Members
Autodesk.Revit.Symbols Namespace


TilePattern Members

[image] [image]

Revit 2010 API
TilePattern Members
TilePattern Class Constructors Methods Properties See Also Send Feedback

The TilePattern type exposes the following members.

Constructors

Name | Description
TilePattern | Initializes a new instance of the TilePattern class

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
TilePatternType | The built-in system tile pattern specified by this object.
TilesPerSeedNode | Get the number of tiles located at each seed node.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

TilePattern Class
Autodesk.Revit.Symbols Namespace


TilePattern Constructor

[image]

Revit 2010 API
TilePattern Constructor
TilePattern Class See Also Send Feedback
Initializes a new instance of the TilePattern class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TilePattern()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TilePattern()

See Also

TilePattern Class
Autodesk.Revit.Symbols Namespace


TilePattern Methods

[image] [image]

Revit 2010 API
TilePattern Methods
TilePattern Class See Also Send Feedback

The TilePattern type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TilePattern Class
Autodesk.Revit.Symbols Namespace


TilePattern Properties

[image] [image]

Revit 2010 API
TilePattern Properties
TilePattern Class See Also Send Feedback

The TilePattern type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
TilePatternType | The built-in system tile pattern specified by this object.
TilesPerSeedNode | Get the number of tiles located at each seed node.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

TilePattern Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
TilePattern..::.Parameter Property
TilePattern Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

TilePattern Class
TilePattern Members
Autodesk.Revit.Symbols Namespace


TilePatternType Property

[image]

Revit 2010 API
TilePattern..::.TilePatternType Property
TilePattern Class See Also Send Feedback
The built-in system tile pattern specified by this object.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TilePatternsBuiltIn TilePatternType { get; }
Visual Basic (Declaration)
Public ReadOnly Property TilePatternType As TilePatternsBuiltIn
Visual C++
public:
property TilePatternsBuiltIn TilePatternType {
    TilePatternsBuiltIn get ();
}

See Also

TilePattern Class
Autodesk.Revit.Symbols Namespace


TilesPerSeedNode Property

[image]

Revit 2010 API
TilePattern..::.TilesPerSeedNode Property
TilePattern Class See Also Send Feedback
Get the number of tiles located at each seed node.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int TilesPerSeedNode { get; }
Visual Basic (Declaration)
Public ReadOnly Property TilesPerSeedNode As Integer
Visual C++
public:
property int TilesPerSeedNode {
    int get ();
}

Remarks

Currently the number of tiles per seed node is always either 1 or 2.

See Also

TilePattern Class
Autodesk.Revit.Symbols Namespace


TrussType Class

[image]

Revit 2010 API
TrussType Class
Members See Also Send Feedback
Represents a specific type of truss.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class TrussType : Symbol
Visual Basic (Declaration)
Public Class TrussType _
    Inherits Symbol
Visual C++
public ref class TrussType : public Symbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.TrussType

See Also

TrussType Members
Autodesk.Revit.Symbols Namespace


TrussType Members

[image] [image]

Revit 2010 API
TrussType Members
TrussType Class Constructors Methods Properties See Also Send Feedback

The TrussType type exposes the following members.

Constructors

Name | Description
TrussType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

TrussType Class
Autodesk.Revit.Symbols Namespace


TrussType Constructor

[image]

Revit 2010 API
TrussType Constructor
TrussType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TrussType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrussType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TrussType Class
Autodesk.Revit.Symbols Namespace


TrussType Methods

[image] [image]

Revit 2010 API
TrussType Methods
TrussType Class See Also Send Feedback

The TrussType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrussType Class
Autodesk.Revit.Symbols Namespace


TrussType Properties

[image] [image]

Revit 2010 API
TrussType Properties
TrussType Class See Also Send Feedback

The TrussType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

TrussType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
TrussType..::.Parameter Property
TrussType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

TrussType Class
TrussType Members
Autodesk.Revit.Symbols Namespace


TrussTypeSet Class

[image]

Revit 2010 API
TrussTypeSet Class
Members See Also Send Feedback
A set that contains Truss types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class TrussTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class TrussTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class TrussTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.TrussTypeSet

See Also

TrussTypeSet Members
Autodesk.Revit.Symbols Namespace


TrussTypeSet Members

[image] [image]

Revit 2010 API
TrussTypeSet Members
TrussTypeSet Class Constructors Methods Properties See Also Send Feedback

The TrussTypeSet type exposes the following members.

Constructors

Name | Description
TrussTypeSet | Initializes a new instance of the TrussTypeSet class

Methods

Name | Description
Clear | Removes every Truss type from the set, rendering it empty.
Contains | Tests for the existence of a Truss type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified Truss type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified Truss type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of Truss types that are in the set.

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


TrussTypeSet Constructor

[image]

Revit 2010 API
TrussTypeSet Constructor
TrussTypeSet Class See Also Send Feedback
Initializes a new instance of the TrussTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TrussTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrussTypeSet()

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


TrussTypeSet Methods

[image] [image]

Revit 2010 API
TrussTypeSet Methods
TrussTypeSet Class See Also Send Feedback

The TrussTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every Truss type from the set, rendering it empty.
Contains | Tests for the existence of a Truss type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified Truss type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified Truss type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
TrussTypeSet..::.Clear Method
TrussTypeSet Class See Also Send Feedback
Removes every Truss type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
TrussTypeSet..::.Contains Method
TrussTypeSet Class See Also Send Feedback
Tests for the existence of a Truss type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    TrussType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As TrussType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    TrussType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.TrussType
The Truss type to be searched for.

Return Value

The Contains method returns True if the Truss type is within the set, otherwise False.

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
TrussTypeSet..::.Erase Method
TrussTypeSet Class See Also Send Feedback
Removes a specified Truss type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    TrussType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As TrussType _
) As Integer
Visual C++
public:
virtual int Erase(
    TrussType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.TrussType
The Truss type to be erased.

Return Value

The number of Truss types that were erased from the set.

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
TrussTypeSet..::.ForwardIterator Method
TrussTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual TrussTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As TrussTypeSetIterator
Visual C++
public:
virtual TrussTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
TrussTypeSet..::.GetEnumerator Method
TrussTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
TrussTypeSet..::.Insert Method
TrussTypeSet Class See Also Send Feedback
Insert the specified Truss type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    TrussType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As TrussType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    TrussType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.TrussType
The Truss type to be inserted into the set.

Return Value

Returns whether the Truss type was inserted into the set.

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
TrussTypeSet..::.ReverseIterator Method
TrussTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual TrussTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As TrussTypeSetIterator
Visual C++
public:
virtual TrussTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


TrussTypeSet Properties

[image] [image]

Revit 2010 API
TrussTypeSet Properties
TrussTypeSet Class See Also Send Feedback

The TrussTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of Truss types that are in the set.

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
TrussTypeSet..::.IsEmpty Property
TrussTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
TrussTypeSet..::.Size Property
TrussTypeSet Class See Also Send Feedback
Returns the number of Truss types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

TrussTypeSet Class
Autodesk.Revit.Symbols Namespace


TrussTypeSetIterator Class

[image]

Revit 2010 API
TrussTypeSetIterator Class
Members See Also Send Feedback
An iterator to a Truss type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class TrussTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class TrussTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class TrussTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.TrussTypeSetIterator

See Also

TrussTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


TrussTypeSetIterator Members

[image] [image]

Revit 2010 API
TrussTypeSetIterator Members
TrussTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The TrussTypeSetIterator type exposes the following members.

Constructors

Name | Description
TrussTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TrussTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


TrussTypeSetIterator Constructor

[image]

Revit 2010 API
TrussTypeSetIterator Constructor
TrussTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TrussTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrussTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TrussTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


TrussTypeSetIterator Methods

[image] [image]

Revit 2010 API
TrussTypeSetIterator Methods
TrussTypeSetIterator Class See Also Send Feedback

The TrussTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrussTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
TrussTypeSetIterator..::.MoveNext Method
TrussTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

TrussTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
TrussTypeSetIterator..::.Reset Method
TrussTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

TrussTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


TrussTypeSetIterator Properties

[image] [image]

Revit 2010 API
TrussTypeSetIterator Properties
TrussTypeSetIterator Class See Also Send Feedback

The TrussTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TrussTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
TrussTypeSetIterator..::.Current Property
TrussTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

TrussTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


WallType Class

[image]

Revit 2010 API
WallType Class
Members Example See Also Send Feedback
Represents a specific type of wall, such as 'Generic -8" '.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class WallType : HostObjAttributes
Visual Basic (Declaration)
Public Class WallType _
    Inherits HostObjAttributes
Visual C++
public ref class WallType : public HostObjAttributes

Remarks

All wall type objects available in the project can be retrieved from the Document object via the WallTypes property. Every Wall object has a WallType property that returns the a WallType object representing the type. This same WallType property can also be used to change the type of the wall by setting it to a different type.

Examples

CopyC#
public void GetInfo_WallType(WallType wallType)
{
    string message;
    // Reports the nature of the wall
    message = "The wall type kind is : " + wallType.Kind.ToString();

    // Get the overall thickness of this type of wall.
    message += "\nThe wall type Width is : " + wallType.Width.ToString();

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_WallType(ByVal wallType As Autodesk.Revit.Symbols.WallType)
    Dim message As String
    ' Reports the nature of the wall
    message = "The wall type kind is : " & wallType.Kind.ToString()

    ' Get the overall thickness of this type of wall.
    message += vbLf & "The wall type Width is : " & wallType.Width.ToString()

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.HostObjAttributes
Autodesk.Revit.Symbols..::.WallType

See Also

WallType Members
Autodesk.Revit.Symbols Namespace


WallType Members

[image] [image]

Revit 2010 API
WallType Members
WallType Class Constructors Methods Properties See Also Send Feedback

The WallType type exposes the following members.

Constructors

Name | Description
WallType | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Kind | Reports the nature of the wall
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Width | Returns the overall thickness of this type of wall.

See Also

WallType Class
Autodesk.Revit.Symbols Namespace


WallType Constructor

[image]

Revit 2010 API
WallType Constructor
WallType Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WallType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WallType()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

WallType Class
Autodesk.Revit.Symbols Namespace


WallType Methods

[image] [image]

Revit 2010 API
WallType Methods
WallType Class See Also Send Feedback

The WallType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Duplicate | Duplicate this object. (Inherited from Symbol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WallType Class
Autodesk.Revit.Symbols Namespace


WallType Properties

[image] [image]

Revit 2010 API
WallType Properties
WallType Class See Also Send Feedback

The WallType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Kind | Reports the nature of the wall
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | set name for a symbol (Inherited from Symbol.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Width | Returns the overall thickness of this type of wall.

See Also

WallType Class
Autodesk.Revit.Symbols Namespace


Kind Property

[image]

Revit 2010 API
WallType..::.Kind Property
WallType Class See Also Send Feedback
Reports the nature of the wall

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WallType..::.WallKind Kind { get; }
Visual Basic (Declaration)
Public ReadOnly Property Kind As WallType..::.WallKind
Visual C++
public:
property WallType..::.WallKind Kind {
    WallType..::.WallKind get ();
}

See Also

WallType Class
Autodesk.Revit.Symbols Namespace


Parameter Property

[image] [image]

Revit 2010 API
WallType..::.Parameter Property
WallType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

WallType Class
WallType Members
Autodesk.Revit.Symbols Namespace


Width Property

[image]

Revit 2010 API
WallType..::.Width Property
WallType Class See Also Send Feedback
Returns the overall thickness of this type of wall.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Width { get; }
Visual Basic (Declaration)
Public ReadOnly Property Width As Double
Visual C++
public:
property double Width {
    double get ();
}

See Also

WallType Class
Autodesk.Revit.Symbols Namespace


WallType.WallKind Enumeration

[image]

Revit 2010 API
WallType..::.WallKind Enumeration
WallType Class See Also Send Feedback
Describes the fundamental type of wall, such as curtain wall or stacked wall.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum WallKind
Visual Basic (Declaration)
Public Enumeration WallKind
Visual C++
public enum class WallKind

Members

Member name | Description
Stacked | A stacked wall of several wall types.
Curtain | A curtain wall.
Basic | A standard wall.
Unknown | The basic type is not known.

See Also

Autodesk.Revit.Symbols Namespace


WallTypeSet Class

[image]

Revit 2010 API
WallTypeSet Class
Members See Also Send Feedback
A set that contains wall types.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class WallTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class WallTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class WallTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.WallTypeSet

See Also

WallTypeSet Members
Autodesk.Revit.Symbols Namespace


WallTypeSet Members

[image] [image]

Revit 2010 API
WallTypeSet Members
WallTypeSet Class Constructors Methods Properties See Also Send Feedback

The WallTypeSet type exposes the following members.

Constructors

Name | Description
WallTypeSet | Initializes a new instance of the WallTypeSet class

Methods

Name | Description
Clear | Removes every wall type from the set, rendering it empty.
Contains | Tests for the existence of a wall type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified wall type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified wall type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of wall types that are in the set.

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


WallTypeSet Constructor

[image]

Revit 2010 API
WallTypeSet Constructor
WallTypeSet Class See Also Send Feedback
Initializes a new instance of the WallTypeSet class

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WallTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WallTypeSet()

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


WallTypeSet Methods

[image] [image]

Revit 2010 API
WallTypeSet Methods
WallTypeSet Class See Also Send Feedback

The WallTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every wall type from the set, rendering it empty.
Contains | Tests for the existence of a wall type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified wall type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified wall type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


Clear Method

[image]

Revit 2010 API
WallTypeSet..::.Clear Method
WallTypeSet Class See Also Send Feedback
Removes every wall type from the set, rendering it empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


Contains Method

[image]

Revit 2010 API
WallTypeSet..::.Contains Method
WallTypeSet Class See Also Send Feedback
Tests for the existence of a wall type within the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    WallType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As WallType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    WallType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.WallType
The wall type to be searched for.

Return Value

The Contains method returns True if the wall type is within the set, otherwise False.

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


Erase Method

[image]

Revit 2010 API
WallTypeSet..::.Erase Method
WallTypeSet Class See Also Send Feedback
Removes a specified wall type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    WallType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As WallType _
) As Integer
Visual C++
public:
virtual int Erase(
    WallType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.WallType
The wall type to be erased.

Return Value

The number of wall types that were erased from the set.

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


ForwardIterator Method

[image]

Revit 2010 API
WallTypeSet..::.ForwardIterator Method
WallTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual WallTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As WallTypeSetIterator
Visual C++
public:
virtual WallTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


GetEnumerator Method

[image]

Revit 2010 API
WallTypeSet..::.GetEnumerator Method
WallTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


Insert Method

[image]

Revit 2010 API
WallTypeSet..::.Insert Method
WallTypeSet Class See Also Send Feedback
Insert the specified wall type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    WallType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As WallType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    WallType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.WallType
The wall type to be inserted into the set.

Return Value

Returns whether the wall type was inserted into the set.

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


ReverseIterator Method

[image]

Revit 2010 API
WallTypeSet..::.ReverseIterator Method
WallTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual WallTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As WallTypeSetIterator
Visual C++
public:
virtual WallTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


WallTypeSet Properties

[image] [image]

Revit 2010 API
WallTypeSet Properties
WallTypeSet Class See Also Send Feedback

The WallTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of wall types that are in the set.

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


IsEmpty Property

[image]

Revit 2010 API
WallTypeSet..::.IsEmpty Property
WallTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


Size Property

[image]

Revit 2010 API
WallTypeSet..::.Size Property
WallTypeSet Class See Also Send Feedback
Returns the number of wall types that are in the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WallTypeSet Class
Autodesk.Revit.Symbols Namespace


WallTypeSetIterator Class

[image]

Revit 2010 API
WallTypeSetIterator Class
Members See Also Send Feedback
An iterator to a wall type set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class WallTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class WallTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class WallTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.WallTypeSetIterator

See Also

WallTypeSetIterator Members
Autodesk.Revit.Symbols Namespace


WallTypeSetIterator Members

[image] [image]

Revit 2010 API
WallTypeSetIterator Members
WallTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The WallTypeSetIterator type exposes the following members.

Constructors

Name | Description
WallTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WallTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


WallTypeSetIterator Constructor

[image]

Revit 2010 API
WallTypeSetIterator Constructor
WallTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WallTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WallTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

WallTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


WallTypeSetIterator Methods

[image] [image]

Revit 2010 API
WallTypeSetIterator Methods
WallTypeSetIterator Class See Also Send Feedback

The WallTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WallTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


MoveNext Method

[image]

Revit 2010 API
WallTypeSetIterator..::.MoveNext Method
WallTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

WallTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Reset Method

[image]

Revit 2010 API
WallTypeSetIterator..::.Reset Method
WallTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

WallTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


WallTypeSetIterator Properties

[image] [image]

Revit 2010 API
WallTypeSetIterator Properties
WallTypeSetIterator Class See Also Send Feedback

The WallTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WallTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Current Property

[image]

Revit 2010 API
WallTypeSetIterator..::.Current Property
WallTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

WallTypeSetIterator Class
Autodesk.Revit.Symbols Namespace


Autodesk.Revit.Utility Namespace

[image]

Revit 2010 API
Autodesk.Revit.Utility Namespace
Send Feedback

Classes

Class | Description
Asset |
AssetProperties | A set of asset properties.
AssetProperty |
AssetPropertyBoolean |
AssetPropertyDistance |
AssetPropertyDouble |
AssetPropertyDoubleArray2d |
AssetPropertyDoubleArray3d |
AssetPropertyDoubleArray4d |
AssetPropertyDoubleMatrix44 |
AssetPropertyEnum |
AssetPropertyFloat |
AssetPropertyInteger |
AssetPropertyReference |
AssetPropertyString |
AssetPropertyTime |
AssetSet | A set that contains assets.
AssetSetIterator | An iterator to a asset set.


Asset Class

[image]

Revit 2010 API
Asset Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Asset : AssetProperties
Visual Basic (Declaration)
Public Class Asset _
    Inherits AssetProperties
Visual C++
public ref class Asset : public AssetProperties

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetProperties
Autodesk.Revit.Utility..::.Asset

See Also

Asset Members
Autodesk.Revit.Utility Namespace


Asset Members

[image] [image]

Revit 2010 API
Asset Members
Asset Class Constructors Methods Properties See Also Send Feedback

The Asset type exposes the following members.

Constructors

Name | Description
Asset | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssetType | Get the object's AssetPropertyType
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Overloaded. Gets a property by an identifier.
LibraryName | Get the library name
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Size | Gets the number of the AssetProperty(s) in the object. (Inherited from AssetProperties.)
Title | Get the asset's title
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)

See Also

Asset Class
Autodesk.Revit.Utility Namespace


Asset Constructor

[image]

Revit 2010 API
Asset Constructor
Asset Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Asset()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Asset()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

Asset Class
Autodesk.Revit.Utility Namespace


Asset Methods

[image] [image]

Revit 2010 API
Asset Methods
Asset Class See Also Send Feedback

The Asset type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Asset Class
Autodesk.Revit.Utility Namespace


Asset Properties

[image] [image]

Revit 2010 API
Asset Properties
Asset Class See Also Send Feedback

The Asset type exposes the following members.

Properties

Name | Description
AssetType | Get the object's AssetPropertyType
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Overloaded. Gets a property by an identifier.
LibraryName | Get the library name
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Size | Gets the number of the AssetProperty(s) in the object. (Inherited from AssetProperties.)
Title | Get the asset's title
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)

See Also

Asset Class
Autodesk.Revit.Utility Namespace


AssetType Property

[image]

Revit 2010 API
Asset..::.AssetType Property
Asset Class See Also Send Feedback
Get the object's AssetPropertyType

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AssetType AssetType { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssetType As AssetType
Visual C++
public:
property AssetType AssetType {
    AssetType get ();
}

See Also

Asset Class
Autodesk.Revit.Utility Namespace


Item Property

[image] [image]

Revit 2010 API
Asset..::.Item Property
Asset Class See Also Send Feedback
Gets a property by an identifier.

Overload List

Name | Description
Item[([(Int32])]) | (Inherited from AssetProperties.)
Item[([(String])]) | Gets the one property that the current object contains with the given name. (Inherited from AssetProperties.)

See Also

Asset Class
Asset Members
Autodesk.Revit.Utility Namespace


LibraryName Property

[image]

Revit 2010 API
Asset..::.LibraryName Property
Asset Class See Also Send Feedback
Get the library name

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string LibraryName { get; }
Visual Basic (Declaration)
Public ReadOnly Property LibraryName As String
Visual C++
public:
property String^ LibraryName {
    String^ get ();
}

See Also

Asset Class
Autodesk.Revit.Utility Namespace


Title Property

[image]

Revit 2010 API
Asset..::.Title Property
Asset Class See Also Send Feedback
Get the asset's title

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

Asset Class
Autodesk.Revit.Utility Namespace


AssetProperties Class

[image]

Revit 2010 API
AssetProperties Class
Members See Also Send Feedback
A set of asset properties.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AssetProperties : AssetProperty
Visual Basic (Declaration)
Public Class AssetProperties _
    Inherits AssetProperty
Visual C++
public ref class AssetProperties : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetProperties
Autodesk.Revit.Utility..::.Asset

See Also

AssetProperties Members
Autodesk.Revit.Utility Namespace


AssetProperties Members

[image] [image]

Revit 2010 API
AssetProperties Members
AssetProperties Class Constructors Methods Properties See Also Send Feedback

The AssetProperties type exposes the following members.

Constructors

Name | Description
AssetProperties | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Overloaded. Gets a property by an identifier.
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Size | Gets the number of the AssetProperty(s) in the object.
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)

See Also

AssetProperties Class
Autodesk.Revit.Utility Namespace


AssetProperties Constructor

[image]

Revit 2010 API
AssetProperties Constructor
AssetProperties Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AssetProperties()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetProperties()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetProperties Class
Autodesk.Revit.Utility Namespace


AssetProperties Methods

[image] [image]

Revit 2010 API
AssetProperties Methods
AssetProperties Class See Also Send Feedback

The AssetProperties type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetProperties Class
Autodesk.Revit.Utility Namespace


AssetProperties Properties

[image] [image]

Revit 2010 API
AssetProperties Properties
AssetProperties Class See Also Send Feedback

The AssetProperties type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Overloaded. Gets a property by an identifier.
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Size | Gets the number of the AssetProperty(s) in the object.
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)

See Also

AssetProperties Class
Autodesk.Revit.Utility Namespace


Item Property

[image] [image]

Revit 2010 API
AssetProperties..::.Item Property
AssetProperties Class See Also Send Feedback
Gets a property by an identifier.

Overload List

Name | Description
Item[([(Int32])]) |
Item[([(String])]) | Gets the one property that the current object contains with the given name.

See Also

AssetProperties Class
AssetProperties Members
Autodesk.Revit.Utility Namespace


Item Property (Int32)

[image]

Revit 2010 API
AssetProperties..::.Item Property (Int32)
AssetProperties Class See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AssetProperty this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As AssetProperty
Visual C++
public:
property AssetProperty^ default[int index] {
    AssetProperty^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

AssetProperties Class
Item Overload
Autodesk.Revit.Utility Namespace


Item Property (String)

[image]

Revit 2010 API
AssetProperties..::.Item Property (String)
AssetProperties Class See Also Send Feedback
Gets the one property that the current object contains with the given name.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AssetProperty this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As AssetProperty
Visual C++
public:
property AssetProperty^ default[String^ name] {
    AssetProperty^ get (String^ name);
}

Parameters

name
Type: System..::.String

See Also

AssetProperties Class
Item Overload
Autodesk.Revit.Utility Namespace


Size Property

[image]

Revit 2010 API
AssetProperties..::.Size Property
AssetProperties Class See Also Send Feedback
Gets the number of the AssetProperty(s) in the object.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Size { get; }
Visual Basic (Declaration)
Public ReadOnly Property Size As Integer
Visual C++
public:
property int Size {
    int get ();
}

See Also

AssetProperties Class
Autodesk.Revit.Utility Namespace


AssetProperty Class

[image]

Revit 2010 API
AssetProperty Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AssetProperty : APIObject
Visual Basic (Declaration)
Public Class AssetProperty _
    Inherits APIObject
Visual C++
public ref class AssetProperty : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetProperties
Autodesk.Revit.Utility..::.AssetPropertyBoolean
Autodesk.Revit.Utility..::.AssetPropertyDistance
Autodesk.Revit.Utility..::.AssetPropertyDouble
Autodesk.Revit.Utility..::.AssetPropertyDoubleArray2d
Autodesk.Revit.Utility..::.AssetPropertyDoubleArray3d
Autodesk.Revit.Utility..::.AssetPropertyDoubleArray4d
Autodesk.Revit.Utility..::.AssetPropertyDoubleMatrix44
Autodesk.Revit.Utility..::.AssetPropertyEnum
Autodesk.Revit.Utility..::.AssetPropertyFloat
Autodesk.Revit.Utility..::.AssetPropertyInteger
Autodesk.Revit.Utility..::.AssetPropertyReference
Autodesk.Revit.Utility..::.AssetPropertyString
Autodesk.Revit.Utility..::.AssetPropertyTime

See Also

AssetProperty Members
Autodesk.Revit.Utility Namespace


AssetProperty Members

[image] [image]

Revit 2010 API
AssetProperty Members
AssetProperty Class Constructors Methods Properties See Also Send Feedback

The AssetProperty type exposes the following members.

Constructors

Name | Description
AssetProperty | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeName | Get the name of the AssetProperty
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty
Type | Returns the Type of the AssetProperty

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


AssetProperty Constructor

[image]

Revit 2010 API
AssetProperty Constructor
AssetProperty Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AssetProperty()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetProperty()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


AssetProperty Methods

[image] [image]

Revit 2010 API
AssetProperty Methods
AssetProperty Class See Also Send Feedback

The AssetProperty type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeName | Get the name of the AssetProperty
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


GetTypeName Method

[image]

Revit 2010 API
AssetProperty..::.GetTypeName Method
AssetProperty Class See Also Send Feedback
Get the name of the AssetProperty

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static string GetTypeName(
    AssetPropertyType type
)
Visual Basic (Declaration)
Public Shared Function GetTypeName ( _
    type As AssetPropertyType _
) As String
Visual C++
public:
static String^ GetTypeName(
    AssetPropertyType type
)

Parameters

type
Type: Autodesk.Revit.Enums..::.AssetPropertyType

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when type is AssetPropertyType::APT_Unknown or AssetPropertyType::APT_Last.

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


AssetProperty Properties

[image] [image]

Revit 2010 API
AssetProperty Properties
AssetProperty Class See Also Send Feedback

The AssetProperty type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty
Type | Returns the Type of the AssetProperty

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


Name Property

[image]

Revit 2010 API
AssetProperty..::.Name Property
AssetProperty Class See Also Send Feedback
Get the name of the AssetProperty

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


Type Property

[image]

Revit 2010 API
AssetProperty..::.Type Property
AssetProperty Class See Also Send Feedback
Returns the Type of the AssetProperty

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual AssetPropertyType Type { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Type As AssetPropertyType
Visual C++
public:
virtual property AssetPropertyType Type {
    AssetPropertyType get ();
}

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


AssetPropertyBoolean Class

[image]

Revit 2010 API
AssetPropertyBoolean Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AssetPropertyBoolean : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyBoolean _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyBoolean : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyBoolean

See Also

AssetPropertyBoolean Members
Autodesk.Revit.Utility Namespace


AssetPropertyBoolean Members

[image] [image]

Revit 2010 API
AssetPropertyBoolean Members
AssetPropertyBoolean Class Constructors Methods Properties See Also Send Feedback

The AssetPropertyBoolean type exposes the following members.

Constructors

Name | Description
AssetPropertyBoolean | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyBoolean Class
Autodesk.Revit.Utility Namespace


AssetPropertyBoolean Constructor

[image]

Revit 2010 API
AssetPropertyBoolean Constructor
AssetPropertyBoolean Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AssetPropertyBoolean()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyBoolean()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyBoolean Class
Autodesk.Revit.Utility Namespace


AssetPropertyBoolean Methods

[image] [image]

Revit 2010 API
AssetPropertyBoolean Methods
AssetPropertyBoolean Class See Also Send Feedback

The AssetPropertyBoolean type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyBoolean Class
Autodesk.Revit.Utility Namespace


AssetPropertyBoolean Properties

[image] [image]

Revit 2010 API
AssetPropertyBoolean Properties
AssetPropertyBoolean Class See Also Send Feedback

The AssetPropertyBoolean type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyBoolean Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2010 API
AssetPropertyBoolean..::.Value Property
AssetPropertyBoolean Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Boolean
Visual C++
public:
property bool Value {
    bool get ();
}

See Also

AssetPropertyBoolean Class
Autodesk.Revit.Utility Namespace


AssetPropertyDistance Class

[image]

Revit 2010 API
AssetPropertyDistance Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AssetPropertyDistance : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyDistance _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyDistance : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyDistance

See Also

AssetPropertyDistance Members
Autodesk.Revit.Utility Namespace


AssetPropertyDistance Members

[image] [image]

Revit 2010 API
AssetPropertyDistance Members
AssetPropertyDistance Class Constructors Methods Properties See Also Send Feedback

The AssetPropertyDistance type exposes the following members.

Constructors

Name | Description
AssetPropertyDistance | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DisplayUnitType |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDistance Class
Autodesk.Revit.Utility Namespace


AssetPropertyDistance Constructor

[image]

Revit 2010 API
AssetPropertyDistance Constructor
AssetPropertyDistance Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AssetPropertyDistance()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyDistance()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyDistance Class
Autodesk.Revit.Utility Namespace


AssetPropertyDistance Methods

[image] [image]

Revit 2010 API
AssetPropertyDistance Methods
AssetPropertyDistance Class See Also Send Feedback

The AssetPropertyDistance type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyDistance Class
Autodesk.Revit.Utility Namespace


AssetPropertyDistance Properties

[image] [image]

Revit 2010 API
AssetPropertyDistance Properties
AssetPropertyDistance Class See Also Send Feedback

The AssetPropertyDistance type exposes the following members.

Properties

Name | Description
DisplayUnitType |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDistance Class
Autodesk.Revit.Utility Namespace


DisplayUnitType Property

[image]

Revit 2010 API
AssetPropertyDistance..::.DisplayUnitType Property
AssetPropertyDistance Class See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DisplayUnitType DisplayUnitType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayUnitType As DisplayUnitType
Visual C++
public:
property DisplayUnitType DisplayUnitType {
    DisplayUnitType get ();
}

See Also

AssetPropertyDistance Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2010 API
AssetPropertyDistance..::.Value Property
AssetPropertyDistance Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Double
Visual C++
public:
property double Value {
    double get ();
}

See Also

AssetPropertyDistance Class
Autodesk.Revit.Utility Namespace


AssetPropertyDouble Class

[image]

Revit 2010 API
AssetPropertyDouble Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AssetPropertyDouble : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyDouble _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyDouble : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyDouble

See Also

AssetPropertyDouble Members
Autodesk.Revit.Utility Namespace


AssetPropertyDouble Members

[image] [image]

Revit 2010 API
AssetPropertyDouble Members
AssetPropertyDouble Class Constructors Methods Properties See Also Send Feedback

The AssetPropertyDouble type exposes the following members.

Constructors

Name | Description
AssetPropertyDouble | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDouble Class
Autodesk.Revit.Utility Namespace


AssetPropertyDouble Constructor

[image]

Revit 2010 API
AssetPropertyDouble Constructor
AssetPropertyDouble Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AssetPropertyDouble()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyDouble()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyDouble Class
Autodesk.Revit.Utility Namespace


AssetPropertyDouble Methods

[image] [image]

Revit 2010 API
AssetPropertyDouble Methods
AssetPropertyDouble Class See Also Send Feedback

The AssetPropertyDouble type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyDouble Class
Autodesk.Revit.Utility Namespace


AssetPropertyDouble Properties

[image] [image]

Revit 2010 API
AssetPropertyDouble Properties
AssetPropertyDouble Class See Also Send Feedback

The AssetPropertyDouble type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDouble Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2010 API
AssetPropertyDouble..::.Value Property
AssetPropertyDouble Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Double
Visual C++
public:
property double Value {
    double get ();
}

See Also

AssetPropertyDouble Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray2d Class

[image]

Revit 2010 API
AssetPropertyDoubleArray2d Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AssetPropertyDoubleArray2d : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyDoubleArray2d _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyDoubleArray2d : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyDoubleArray2d

See Also

AssetPropertyDoubleArray2d Members
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray2d Members

[image] [image]

Revit 2010 API
AssetPropertyDoubleArray2d Members
AssetPropertyDoubleArray2d Class Constructors Methods Properties See Also Send Feedback

The AssetPropertyDoubleArray2d type exposes the following members.

Constructors

Name | Description
AssetPropertyDoubleArray2d | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDoubleArray2d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray2d Constructor

[image]

Revit 2010 API
AssetPropertyDoubleArray2d Constructor
AssetPropertyDoubleArray2d Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AssetPropertyDoubleArray2d()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyDoubleArray2d()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyDoubleArray2d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray2d Methods

[image] [image]

Revit 2010 API
AssetPropertyDoubleArray2d Methods
AssetPropertyDoubleArray2d Class See Also Send Feedback

The AssetPropertyDoubleArray2d type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyDoubleArray2d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray2d Properties

[image] [image]

Revit 2010 API
AssetPropertyDoubleArray2d Properties
AssetPropertyDoubleArray2d Class See Also Send Feedback

The AssetPropertyDoubleArray2d type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDoubleArray2d Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2010 API
AssetPropertyDoubleArray2d..::.Value Property
AssetPropertyDoubleArray2d Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DoubleArray Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As DoubleArray
Visual C++
public:
property DoubleArray^ Value {
    DoubleArray^ get ();
}

See Also

AssetPropertyDoubleArray2d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray3d Class

[image]

Revit 2010 API
AssetPropertyDoubleArray3d Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AssetPropertyDoubleArray3d : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyDoubleArray3d _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyDoubleArray3d : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyDoubleArray3d

See Also

AssetPropertyDoubleArray3d Members
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray3d Members

[image] [image]

Revit 2010 API
AssetPropertyDoubleArray3d Members
AssetPropertyDoubleArray3d Class Constructors Methods Properties See Also Send Feedback

The AssetPropertyDoubleArray3d type exposes the following members.

Constructors

Name | Description
AssetPropertyDoubleArray3d | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDoubleArray3d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray3d Constructor

[image]

Revit 2010 API
AssetPropertyDoubleArray3d Constructor
AssetPropertyDoubleArray3d Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AssetPropertyDoubleArray3d()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyDoubleArray3d()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyDoubleArray3d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray3d Methods

[image] [image]

Revit 2010 API
AssetPropertyDoubleArray3d Methods
AssetPropertyDoubleArray3d Class See Also Send Feedback

The AssetPropertyDoubleArray3d type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyDoubleArray3d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray3d Properties

[image] [image]

Revit 2010 API
AssetPropertyDoubleArray3d Properties
AssetPropertyDoubleArray3d Class See Also Send Feedback

The AssetPropertyDoubleArray3d type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDoubleArray3d Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2010 API
AssetPropertyDoubleArray3d..::.Value Property
AssetPropertyDoubleArray3d Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DoubleArray Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As DoubleArray
Visual C++
public:
property DoubleArray^ Value {
    DoubleArray^ get ();
}

See Also

AssetPropertyDoubleArray3d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray4d Class

[image]

Revit 2010 API
AssetPropertyDoubleArray4d Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AssetPropertyDoubleArray4d : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyDoubleArray4d _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyDoubleArray4d : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyDoubleArray4d

See Also

AssetPropertyDoubleArray4d Members
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray4d Members

[image] [image]

Revit 2010 API
AssetPropertyDoubleArray4d Members
AssetPropertyDoubleArray4d Class Constructors Methods Properties See Also Send Feedback

The AssetPropertyDoubleArray4d type exposes the following members.

Constructors

Name | Description
AssetPropertyDoubleArray4d | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDoubleArray4d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray4d Constructor

[image]

Revit 2010 API
AssetPropertyDoubleArray4d Constructor
AssetPropertyDoubleArray4d Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AssetPropertyDoubleArray4d()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyDoubleArray4d()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyDoubleArray4d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray4d Methods

[image] [image]

Revit 2010 API
AssetPropertyDoubleArray4d Methods
AssetPropertyDoubleArray4d Class See Also Send Feedback

The AssetPropertyDoubleArray4d type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyDoubleArray4d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray4d Properties

[image] [image]

Revit 2010 API
AssetPropertyDoubleArray4d Properties
AssetPropertyDoubleArray4d Class See Also Send Feedback

The AssetPropertyDoubleArray4d type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDoubleArray4d Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2010 API
AssetPropertyDoubleArray4d..::.Value Property
AssetPropertyDoubleArray4d Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DoubleArray Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As DoubleArray
Visual C++
public:
property DoubleArray^ Value {
    DoubleArray^ get ();
}

See Also

AssetPropertyDoubleArray4d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleMatrix44 Class

[image]

Revit 2010 API
AssetPropertyDoubleMatrix44 Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AssetPropertyDoubleMatrix44 : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyDoubleMatrix44 _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyDoubleMatrix44 : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyDoubleMatrix44

See Also

AssetPropertyDoubleMatrix44 Members
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleMatrix44 Members

[image] [image]

Revit 2010 API
AssetPropertyDoubleMatrix44 Members
AssetPropertyDoubleMatrix44 Class Constructors Methods Properties See Also Send Feedback

The AssetPropertyDoubleMatrix44 type exposes the following members.

Constructors

Name | Description
AssetPropertyDoubleMatrix44 | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDoubleMatrix44 Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleMatrix44 Constructor

[image]

Revit 2010 API
AssetPropertyDoubleMatrix44 Constructor
AssetPropertyDoubleMatrix44 Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AssetPropertyDoubleMatrix44()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyDoubleMatrix44()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyDoubleMatrix44 Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleMatrix44 Methods

[image] [image]

Revit 2010 API
AssetPropertyDoubleMatrix44 Methods
AssetPropertyDoubleMatrix44 Class See Also Send Feedback

The AssetPropertyDoubleMatrix44 type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyDoubleMatrix44 Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleMatrix44 Properties

[image] [image]

Revit 2010 API
AssetPropertyDoubleMatrix44 Properties
AssetPropertyDoubleMatrix44 Class See Also Send Feedback

The AssetPropertyDoubleMatrix44 type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDoubleMatrix44 Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2010 API
AssetPropertyDoubleMatrix44..::.Value Property
AssetPropertyDoubleMatrix44 Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DoubleArray Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As DoubleArray
Visual C++
public:
property DoubleArray^ Value {
    DoubleArray^ get ();
}

See Also

AssetPropertyDoubleMatrix44 Class
Autodesk.Revit.Utility Namespace


AssetPropertyEnum Class

[image]

Revit 2010 API
AssetPropertyEnum Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AssetPropertyEnum : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyEnum _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyEnum : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyEnum

See Also

AssetPropertyEnum Members
Autodesk.Revit.Utility Namespace


AssetPropertyEnum Members

[image] [image]

Revit 2010 API
AssetPropertyEnum Members
AssetPropertyEnum Class Constructors Methods Properties See Also Send Feedback

The AssetPropertyEnum type exposes the following members.

Constructors

Name | Description
AssetPropertyEnum | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyEnum Class
Autodesk.Revit.Utility Namespace


AssetPropertyEnum Constructor

[image]

Revit 2010 API
AssetPropertyEnum Constructor
AssetPropertyEnum Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AssetPropertyEnum()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyEnum()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyEnum Class
Autodesk.Revit.Utility Namespace


AssetPropertyEnum Methods

[image] [image]

Revit 2010 API
AssetPropertyEnum Methods
AssetPropertyEnum Class See Also Send Feedback

The AssetPropertyEnum type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyEnum Class
Autodesk.Revit.Utility Namespace


AssetPropertyEnum Properties

[image] [image]

Revit 2010 API
AssetPropertyEnum Properties
AssetPropertyEnum Class See Also Send Feedback

The AssetPropertyEnum type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyEnum Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2010 API
AssetPropertyEnum..::.Value Property
AssetPropertyEnum Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Integer
Visual C++
public:
property int Value {
    int get ();
}

See Also

AssetPropertyEnum Class
Autodesk.Revit.Utility Namespace


AssetPropertyFloat Class

[image]

Revit 2010 API
AssetPropertyFloat Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AssetPropertyFloat : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyFloat _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyFloat : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyFloat

See Also

AssetPropertyFloat Members
Autodesk.Revit.Utility Namespace


AssetPropertyFloat Members

[image] [image]

Revit 2010 API
AssetPropertyFloat Members
AssetPropertyFloat Class Constructors Methods Properties See Also Send Feedback

The AssetPropertyFloat type exposes the following members.

Constructors

Name | Description
AssetPropertyFloat | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyFloat Class
Autodesk.Revit.Utility Namespace


AssetPropertyFloat Constructor

[image]

Revit 2010 API
AssetPropertyFloat Constructor
AssetPropertyFloat Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AssetPropertyFloat()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyFloat()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyFloat Class
Autodesk.Revit.Utility Namespace


AssetPropertyFloat Methods

[image] [image]

Revit 2010 API
AssetPropertyFloat Methods
AssetPropertyFloat Class See Also Send Feedback

The AssetPropertyFloat type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyFloat Class
Autodesk.Revit.Utility Namespace


AssetPropertyFloat Properties

[image] [image]

Revit 2010 API
AssetPropertyFloat Properties
AssetPropertyFloat Class See Also Send Feedback

The AssetPropertyFloat type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyFloat Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2010 API
AssetPropertyFloat..::.Value Property
AssetPropertyFloat Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public float Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Single
Visual C++
public:
property float Value {
    float get ();
}

See Also

AssetPropertyFloat Class
Autodesk.Revit.Utility Namespace


AssetPropertyInteger Class

[image]

Revit 2010 API
AssetPropertyInteger Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AssetPropertyInteger : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyInteger _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyInteger : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyInteger

See Also

AssetPropertyInteger Members
Autodesk.Revit.Utility Namespace


AssetPropertyInteger Members

[image] [image]

Revit 2010 API
AssetPropertyInteger Members
AssetPropertyInteger Class Constructors Methods Properties See Also Send Feedback

The AssetPropertyInteger type exposes the following members.

Constructors

Name | Description
AssetPropertyInteger | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyInteger Class
Autodesk.Revit.Utility Namespace


AssetPropertyInteger Constructor

[image]

Revit 2010 API
AssetPropertyInteger Constructor
AssetPropertyInteger Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AssetPropertyInteger()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyInteger()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyInteger Class
Autodesk.Revit.Utility Namespace


AssetPropertyInteger Methods

[image] [image]

Revit 2010 API
AssetPropertyInteger Methods
AssetPropertyInteger Class See Also Send Feedback

The AssetPropertyInteger type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyInteger Class
Autodesk.Revit.Utility Namespace


AssetPropertyInteger Properties

[image] [image]

Revit 2010 API
AssetPropertyInteger Properties
AssetPropertyInteger Class See Also Send Feedback

The AssetPropertyInteger type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyInteger Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2010 API
AssetPropertyInteger..::.Value Property
AssetPropertyInteger Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Integer
Visual C++
public:
property int Value {
    int get ();
}

See Also

AssetPropertyInteger Class
Autodesk.Revit.Utility Namespace


AssetPropertyReference Class

[image]

Revit 2010 API
AssetPropertyReference Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AssetPropertyReference : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyReference _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyReference : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyReference

See Also

AssetPropertyReference Members
Autodesk.Revit.Utility Namespace


AssetPropertyReference Members

[image] [image]

Revit 2010 API
AssetPropertyReference Members
AssetPropertyReference Class Constructors Methods Properties See Also Send Feedback

The AssetPropertyReference type exposes the following members.

Constructors

Name | Description
AssetPropertyReference | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)

See Also

AssetPropertyReference Class
Autodesk.Revit.Utility Namespace


AssetPropertyReference Constructor

[image]

Revit 2010 API
AssetPropertyReference Constructor
AssetPropertyReference Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AssetPropertyReference()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyReference()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyReference Class
Autodesk.Revit.Utility Namespace


AssetPropertyReference Methods

[image] [image]

Revit 2010 API
AssetPropertyReference Methods
AssetPropertyReference Class See Also Send Feedback

The AssetPropertyReference type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyReference Class
Autodesk.Revit.Utility Namespace


AssetPropertyReference Properties

[image] [image]

Revit 2010 API
AssetPropertyReference Properties
AssetPropertyReference Class See Also Send Feedback

The AssetPropertyReference type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)

See Also

AssetPropertyReference Class
Autodesk.Revit.Utility Namespace


AssetPropertyString Class

[image]

Revit 2010 API
AssetPropertyString Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AssetPropertyString : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyString _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyString : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyString

See Also

AssetPropertyString Members
Autodesk.Revit.Utility Namespace


AssetPropertyString Members

[image] [image]

Revit 2010 API
AssetPropertyString Members
AssetPropertyString Class Constructors Methods Properties See Also Send Feedback

The AssetPropertyString type exposes the following members.

Constructors

Name | Description
AssetPropertyString | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyString Class
Autodesk.Revit.Utility Namespace


AssetPropertyString Constructor

[image]

Revit 2010 API
AssetPropertyString Constructor
AssetPropertyString Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AssetPropertyString()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyString()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyString Class
Autodesk.Revit.Utility Namespace


AssetPropertyString Methods

[image] [image]

Revit 2010 API
AssetPropertyString Methods
AssetPropertyString Class See Also Send Feedback

The AssetPropertyString type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyString Class
Autodesk.Revit.Utility Namespace


AssetPropertyString Properties

[image] [image]

Revit 2010 API
AssetPropertyString Properties
AssetPropertyString Class See Also Send Feedback

The AssetPropertyString type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyString Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2010 API
AssetPropertyString..::.Value Property
AssetPropertyString Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
}

See Also

AssetPropertyString Class
Autodesk.Revit.Utility Namespace


AssetPropertyTime Class

[image]

Revit 2010 API
AssetPropertyTime Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AssetPropertyTime : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyTime _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyTime : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyTime

See Also

AssetPropertyTime Members
Autodesk.Revit.Utility Namespace


AssetPropertyTime Members

[image] [image]

Revit 2010 API
AssetPropertyTime Members
AssetPropertyTime Class Constructors Methods Properties See Also Send Feedback

The AssetPropertyTime type exposes the following members.

Constructors

Name | Description
AssetPropertyTime | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyTime Class
Autodesk.Revit.Utility Namespace


AssetPropertyTime Constructor

[image]

Revit 2010 API
AssetPropertyTime Constructor
AssetPropertyTime Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AssetPropertyTime()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetPropertyTime()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetPropertyTime Class
Autodesk.Revit.Utility Namespace


AssetPropertyTime Methods

[image] [image]

Revit 2010 API
AssetPropertyTime Methods
AssetPropertyTime Class See Also Send Feedback

The AssetPropertyTime type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyTime Class
Autodesk.Revit.Utility Namespace


AssetPropertyTime Properties

[image] [image]

Revit 2010 API
AssetPropertyTime Properties
AssetPropertyTime Class See Also Send Feedback

The AssetPropertyTime type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyTime Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2010 API
AssetPropertyTime..::.Value Property
AssetPropertyTime Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DateTime Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As DateTime
Visual C++
public:
property DateTime Value {
    DateTime get ();
}

See Also

AssetPropertyTime Class
Autodesk.Revit.Utility Namespace


AssetSet Class

[image]

Revit 2010 API
AssetSet Class
Members See Also Send Feedback
A set that contains assets.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AssetSet : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class AssetSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class AssetSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Utility..::.AssetSet

See Also

AssetSet Members
Autodesk.Revit.Utility Namespace


AssetSet Members

[image] [image]

Revit 2010 API
AssetSet Members
AssetSet Class Constructors Methods Properties See Also Send Feedback

The AssetSet type exposes the following members.

Constructors

Name | Description
AssetSet | Initializes a new instance of the AssetSet class

Methods

Name | Description
Clear | Removes every asset from the set, rendering it empty.
Contains | Tests for the existence of a asset within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified asset from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified asset into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of assets that are in the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


AssetSet Constructor

[image]

Revit 2010 API
AssetSet Constructor
AssetSet Class See Also Send Feedback
Initializes a new instance of the AssetSet class

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AssetSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetSet()

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


AssetSet Methods

[image] [image]

Revit 2010 API
AssetSet Methods
AssetSet Class See Also Send Feedback

The AssetSet type exposes the following members.

Methods

Name | Description
Clear | Removes every asset from the set, rendering it empty.
Contains | Tests for the existence of a asset within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified asset from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified asset into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


Clear Method

[image]

Revit 2010 API
AssetSet..::.Clear Method
AssetSet Class See Also Send Feedback
Removes every asset from the set, rendering it empty.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


Contains Method

[image]

Revit 2010 API
AssetSet..::.Contains Method
AssetSet Class See Also Send Feedback
Tests for the existence of a asset within the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Contains(
    Asset item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Asset _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Asset^ item
)

Parameters

item
Type: Autodesk.Revit.Utility..::.Asset
The asset to be searched for.

Return Value

The Contains method returns True if the asset is within the set, otherwise False.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


Erase Method

[image]

Revit 2010 API
AssetSet..::.Erase Method
AssetSet Class See Also Send Feedback
Removes a specified asset from the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    Asset item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Asset _
) As Integer
Visual C++
public:
virtual int Erase(
    Asset^ item
)

Parameters

item
Type: Autodesk.Revit.Utility..::.Asset
The asset to be erased.

Return Value

The number of assets that were erased from the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


ForwardIterator Method

[image]

Revit 2010 API
AssetSet..::.ForwardIterator Method
AssetSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual AssetSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As AssetSetIterator
Visual C++
public:
virtual AssetSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


GetEnumerator Method

[image]

Revit 2010 API
AssetSet..::.GetEnumerator Method
AssetSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


Insert Method

[image]

Revit 2010 API
AssetSet..::.Insert Method
AssetSet Class See Also Send Feedback
Insert the specified asset into the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    Asset item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Asset _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Asset^ item
)

Parameters

item
Type: Autodesk.Revit.Utility..::.Asset
The asset to be inserted into the set.

Return Value

Returns whether the asset was inserted into the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


ReverseIterator Method

[image]

Revit 2010 API
AssetSet..::.ReverseIterator Method
AssetSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual AssetSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As AssetSetIterator
Visual C++
public:
virtual AssetSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


AssetSet Properties

[image] [image]

Revit 2010 API
AssetSet Properties
AssetSet Class See Also Send Feedback

The AssetSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of assets that are in the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


IsEmpty Property

[image]

Revit 2010 API
AssetSet..::.IsEmpty Property
AssetSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


Size Property

[image]

Revit 2010 API
AssetSet..::.Size Property
AssetSet Class See Also Send Feedback
Returns the number of assets that are in the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


AssetSetIterator Class

[image]

Revit 2010 API
AssetSetIterator Class
Members See Also Send Feedback
An iterator to a asset set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class AssetSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class AssetSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class AssetSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Utility..::.AssetSetIterator

See Also

AssetSetIterator Members
Autodesk.Revit.Utility Namespace


AssetSetIterator Members

[image] [image]

Revit 2010 API
AssetSetIterator Members
AssetSetIterator Class Constructors Methods Properties See Also Send Feedback

The AssetSetIterator type exposes the following members.

Constructors

Name | Description
AssetSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


AssetSetIterator Constructor

[image]

Revit 2010 API
AssetSetIterator Constructor
AssetSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AssetSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


AssetSetIterator Methods

[image] [image]

Revit 2010 API
AssetSetIterator Methods
AssetSetIterator Class See Also Send Feedback

The AssetSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


MoveNext Method

[image]

Revit 2010 API
AssetSetIterator..::.MoveNext Method
AssetSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


Reset Method

[image]

Revit 2010 API
AssetSetIterator..::.Reset Method
AssetSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


AssetSetIterator Properties

[image] [image]

Revit 2010 API
AssetSetIterator Properties
AssetSetIterator Class See Also Send Feedback

The AssetSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


Current Property

[image]

Revit 2010 API
AssetSetIterator..::.Current Property
AssetSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace