Revit 2010 API
DWFExportOptions Members
DWFExportOptions Class Constructors Methods Properties See Also

The DWFExportOptions type exposes the following members.

Constructors

Name | Description
DWFExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExportingAreas | Whether to also export areas and rooms' geometry.
ExportObjectData | Whether to include properties associated with elements.
MergedViews | Whether to merge all views in one file.
StopOnError | Whether export process should stop when a view fails to export.

See Also

DWFExportOptions Class
Autodesk.Revit Namespace