Revit 2010 API
BarDescription Members
BarDescription Class Constructors Methods Properties See Also

The BarDescription type exposes the following members.

Constructors

Name | Description
BarDescription | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BarType | Retrieves the Rebar Bar Type property of a Bar Description.
Count | Retrieves the number of bars of this shape.
HooksInSameDirection | Retrieves the Rebar Hooks In Same Direction property of a Bar Description. If true, both hooks are bent in the same direction; if false, the hooks are bent in opposite directions.
HookType | Retrieves the Rebar Hook Type property of a Bar Description.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Layer | Retrieves the layer index (0, 1, 2, or 3) for this Bar Description.
Length | Retrieves the length of a Bar Description.

See Also

BarDescription Class
Autodesk.Revit.Structural Namespace