Revit 2010 API
Filter Members
Filter Class Constructors Methods Properties See Also

The Filter type exposes the following members.

Constructors

Name | Description
Filter | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewCategoryFilter | Overloaded. Creates a new category filter object.
NewFamilyFilter | Creates a FamilyFilter object.
NewInstanceUsageFilter | Creates an InstanceUsageFilter object.
NewLogicAndFilter | Creates a new LogicAndFilter object.
NewLogicNotFilter | Creates a new LogicNotFilter object.
NewLogicOrFilter | Creates a new LogicOrFilter object.
NewMaterialFilter | Creates a MaterialFilter object.
NewParameterFilter | Overloaded. Creates a new parameter filter.
NewStructuralTypeFilter | Creates a StructuralTypeFilter object.
NewSymbolFilter | Creates a SymbolFilter object.
NewTypeFilter | Overloaded. Creates a new TypeFilter object.
NewWallUsageFilter | Creates a new WallUsageFilter object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Filter Class
Autodesk.Revit.Creation Namespace