Revit 2010 API
FillPatternSet Members
FillPatternSet Class Constructors Methods Properties See Also

The FillPatternSet type exposes the following members.

Constructors

Name | Description
FillPatternSet | Initializes a new instance of the FillPatternSet class

Methods

Name | Description
Clear | Removes every fill pattern from the set, rendering it empty.
Contains | Tests for the existence of a fill pattern within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified fill pattern from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified fill pattern into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of fill patterns that are in the set.

See Also

FillPatternSet Class
Autodesk.Revit Namespace