Revit 2010 API
Document..::.ArrayWithoutAssociate Method (ElementSet, Int32, Boolean, Double)
Document Class See Also
Creates a radial array of several elements using a specified number of degrees where the elements created will not be grouped and associated.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    ElementSet elements,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    elements As ElementSet, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate(
    ElementSet^ elements,
    int number,
    bool moveToLast,
    double angle
)

Parameters

elements
Type: Autodesk.Revit..::.ElementSet
A set of elements that are to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Type: System..::.Double
The number of degrees, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped.

See Also

Document Class
ArrayWithoutAssociate Overload
Autodesk.Revit Namespace