Revit 2010 API
DemandFactorData Members
DemandFactorData Class Constructors Methods Properties See Also

The DemandFactorData type exposes the following members.

Constructors

Name | Description
DemandFactorData | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsValid | Get value to indicate whether this data item is still valid, if yes, it can be use, otherwise it has been obsolete.
MaxFactor | Get upper limit value of the range, the unit is volt-ampere.
MinFactor | Get lower limit value of the range, the unit is volt-ampere.
Percentage | Get or set demand factor percentage that specifies the anticipated a percentage of full rated load that will exist at any given time for the specified range.

See Also

DemandFactorData Class
Autodesk.Revit.MEP Namespace