Revit 2010 API
BoundarySegment Members
BoundarySegment Class Constructors Methods Properties See Also

The BoundarySegment type exposes the following members.

Constructors

Name | Description
BoundarySegment | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Curve | Get the curve that is formed by the element that defines the edge of this room.
Document | Provides the document in which the element that created this segment resides.
Element | Retrieve the element that is responsible for producing this boundary segment.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment Class
Autodesk.Revit.Rooms Namespace