Revit 2010 API
FamilySymbolProfile Members
FamilySymbolProfile Class Constructors Methods Properties See Also

The FamilySymbolProfile type exposes the following members.

Constructors

Name | Description
FamilySymbolProfile | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Angle | The angle of the rotation of the profile in radians.
IsFlipped | Indicates if the symbol profile is flipped or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Profile | Returns the family symbol of the profile.
XOffset | The offset of the profile to the origin of the sketch plane in the X direction.
YOffset | The offset of the profile to the origin of the sketch plane in the Y direction.

See Also

FamilySymbolProfile Class
Autodesk.Revit Namespace