Revit 2010 API
FamilyItemFactory..::.NewFormByCap Method
FamilyItemFactory Class See Also
Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Form NewFormByCap(
    bool isSolid,
    ReferenceArray profile
)
Visual Basic (Declaration)
Public Function NewFormByCap ( _
    isSolid As Boolean, _
    profile As ReferenceArray _
) As Form
Visual C++
public:
Form^ NewFormByCap(
    bool isSolid,
    ReferenceArray^ profile
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Form is Solid or Void.
profile
Type: Autodesk.Revit.Geometry..::.ReferenceArray
The profile of the newly created cap. It should consist of only one curve loop. The input profile must be in one plane.

Return Value

If creation was successful new form is returned.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace