Revit 2010 API
RebarHookTypeSet Methods
RebarHookTypeSet Class See Also

The RebarHookTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every RebarHook type from the set, rendering it empty.
Contains | Tests for the existence of a RebarHook type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified RebarHook type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified RebarHook type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarHookTypeSet Class
Autodesk.Revit.Symbols Namespace