Revit 2010 API
AnalyticalModelProfile Properties
AnalyticalModelProfile Class See Also

The AnalyticalModelProfile type exposes the following members.

Properties

Name | Description
DrivingCurve | Provides access to the curve that dictates the path of the swept profile.
EndSetBack | Returns the distance from the end of the driving curve that the sweep actually finishes.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
StartSetBack | Returns the distance from the start of the driving curve that the sweep actually begins.
SweptProfile | Returns an object that describes the profile that is swept along the driving curve.

See Also

AnalyticalModelProfile Class
Autodesk.Revit.Structural Namespace