Revit 2010 API
ViewPrintedEventArgs Members
ViewPrintedEventArgs Class Constructors Methods Properties See Also

The ViewPrintedEventArgs type exposes the following members.

Constructors

Name | Description
ViewPrintedEventArgs | Initializes a new instance of the ViewPrintedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Index | When the view is being printed as a part of a view-set, the value of this property indicates the index of this view in the entire set. The value is 0-based.
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)
TotalViews | When the view is being printed as a part of a view-set, the value of this property indicates the number of all views in the set.
View | View that was printed.

See Also

ViewPrintedEventArgs Class
Autodesk.Revit.Events Namespace