Revit 2010 API
RebarShapeDefinitionByArc Members
RebarShapeDefinitionByArc Class Constructors Methods Properties See Also

The RebarShapeDefinitionByArc type exposes the following members.

Constructors

Name | Description
RebarShapeDefinitionByArc | For Internal Use Only.

Methods

Name | Description
AddConstraintArcLength | Specify a parameter to drive the arc length of the shape.
AddConstraintChordLength | Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).
AddConstraintCircumference | Specify a parameter to drive the circumference of the shape.
AddConstraintDiameter | Specify a parameter to drive the diameter of the shape.
AddConstraintRadius | Specify a parameter to drive the radius of the shape.
AddConstraintSagittaLength | Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).
AddFormulaParameter | Add a formula-driven parameter to the shape definition. (Inherited from RebarShapeDefinition.)
AddParameter | Add a parameter to the shape definition. (Inherited from RebarShapeDefinition.)
CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values. (Inherited from RebarShapeDefinition.)
Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed. (Inherited from RebarShapeDefinition.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Complete | Report whether the shape definition is fully constrained. (Inherited from RebarShapeDefinition.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Type | Among those rebar shapes defined by an arc, specify which kind.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace