Revit 2010 API
ExternalDefinition..::.ParameterType Property
ExternalDefinition Class See Also
Returns the user visible interpretation of the parameter data.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override ParameterType ParameterType { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ParameterType As ParameterType
Visual C++
public:
virtual property ParameterType ParameterType {
    ParameterType get () override;
}

Remarks

The data within the parameter is stored in a very simple manner as an integer, double, string or an element id, but to the user these values may be more meaningful as Length, Volume, Mass etc. This parameter returns the interpretation that should be used for the data.

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace