Revit 2010 API
ElementIterator Members
ElementIterator Class Constructors Methods Properties See Also

The ElementIterator type exposes the following members.

Constructors

Name | Description
ElementIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one element forward.
Reset | Bring the iterator back to the start of the database.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | The object that represents the current element in the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementIterator Class
Autodesk.Revit Namespace