Revit 2010 API
TemperatureRatingType..::.AddWireSize Method
TemperatureRatingType Class See Also
Add a new kind of wire size type into this temperature rating type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireSize AddWireSize(
    string size,
    long ampacity,
    double diameter
)
Visual Basic (Declaration)
Public Function AddWireSize ( _
    size As String, _
    ampacity As Long, _
    diameter As Double _
) As WireSize
Visual C++
public:
WireSize^ AddWireSize(
    String^ size,
    long long ampacity,
    double diameter
)

Parameters

size
Type: System..::.String
Size of wire size.
ampacity
Type: System..::.Int64
Ampacity of wire size to be added.
diameter
Type: System..::.Double
Diameter of wire size to be added.

Return Value

Constructed wire size type.

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace