Revit 2010 API
PushButton Members
PushButton Class Constructors Methods Properties See Also

The PushButton type exposes the following members.

Constructors

Name | Description
PushButton | Initializes a new instance of the PushButton class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Returns a value whether the RibbonItem equals to another RibbonItem. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssemblyName | The assembly path of the button.
ClassName | The name of the class containing the implementation for the command.
Enabled | Gets or sets a value indicating whether the button is enabled. (Inherited from RibbonItem.)
Image | The image of the button.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
ItemText | Gets or sets the text displayed on the button. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LargeImage | The large image shown on the button.
Name | The name of the button.
ToolTip | The description that appears as a ToolTip for the button. (Inherited from RibbonItem.)

See Also

PushButton Class
Autodesk.Revit Namespace