Revit 2010 API
Application..::.NewRectangularWallCreationData Method (Curve, Level, Boolean)
Application Class See Also
Creates an object which wraps the arguments of NewWall() for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RectangularWallCreationData NewRectangularWallCreationData(
    Curve curve,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Function NewRectangularWallCreationData ( _
    curve As Curve, _
    level As Level, _
    structural As Boolean _
) As RectangularWallCreationData
Visual C++
public:
RectangularWallCreationData^ NewRectangularWallCreationData(
    Curve^ curve,
    Level^ level,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
An arc or line representing the base line of the wall.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

See Also

Application Class
NewRectangularWallCreationData Overload
Autodesk.Revit.Creation Namespace