Revit 2010 API
MaterialWood Class
Members Example See Also
Represents a wood material element in an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MaterialWood : Material
Visual Basic (Declaration)
Public Class MaterialWood _
    Inherits Material
Visual C++
public ref class MaterialWood : public Material

Remarks

MaterialWood is a child class of Material.

Examples

CopyC#
private void MaterialWoodInformation(MaterialWood myWood)
{
    StringBuilder message = new StringBuilder("Material Wood : " + myWood.Name);

    double bending = myWood.Bending;
    message.Append("Bending: " + bending);

    double compressionParallel = myWood.CompressionParallel;
    message.Append("Compression parallel to grain: " + compressionParallel);
    double compressionPerpendicular = myWood.CompressionPerpendicular;
    message.Append("Compression perpendicular to grain: " + compressionPerpendicular);
    string grade = myWood.Grade;
    message.Append("Grade: " + grade);

    double poissonModulus = myWood.PoissonModulus;
    message.Append("Poisson Ratio: " + poissonModulus);

    double shearModulus = myWood.ShearModulus;
    message.Append("Shear modulus: " + shearModulus);
    double shearParallel = myWood.ShearParallel;
    message.Append("Shear parallel to grain: " + shearParallel);
    double shearPerpendicular = myWood.ShearPerpendicular;
    message.Append("Shear perpendicular to grain: " + shearPerpendicular);

    string species = myWood.Species;
    message.Append("Species: " + species);

    double thermalExpansionCoefficient = myWood.ThermalExpansionCoefficient;
    message.Append("Thermal Expansion coefficient: " + thermalExpansionCoefficient);

    double unitWeight = myWood.UnitWeight;
    message.Append("Unit Weight: " + unitWeight);

    double youngModulus = myWood.YoungModulus;
    message.Append("Young modulus: " + youngModulus);

    MessageBox.Show(message.ToString(), "Revit");
}
CopyVB.NET
Private Sub MaterialWoodInformation(ByVal myWood As MaterialWood)
    Dim message As New StringBuilder("Material Wood : " & myWood.Name)

    Dim bending As Double = myWood.Bending
    message.Append("Bending: " & bending)

    Dim compressionParallel As Double = myWood.CompressionParallel
    message.Append("Compression parallel to grain: " & compressionParallel)
    Dim compressionPerpendicular As Double = myWood.CompressionPerpendicular
    message.Append("Compression perpendicular to grain: " & compressionPerpendicular)
    Dim grade As String = myWood.Grade
    message.Append("Grade: " & grade)

    Dim poissonModulus As Double = myWood.PoissonModulus
    message.Append("Poisson Ratio: " & poissonModulus)

    Dim shearModulus As Double = myWood.ShearModulus
    message.Append("Shear modulus: " & shearModulus)
    Dim shearParallel As Double = myWood.ShearParallel
    message.Append("Shear parallel to grain: " & shearParallel)
    Dim shearPerpendicular As Double = myWood.ShearPerpendicular
    message.Append("Shear perpendicular to grain: " & shearPerpendicular)

    Dim species As String = myWood.Species
    message.Append("Species: " & species)

    Dim thermalExpansionCoefficient As Double = myWood.ThermalExpansionCoefficient
    message.Append("Thermal Expansion coefficient: " & thermalExpansionCoefficient)

    Dim unitWeight As Double = myWood.UnitWeight
    message.Append("Unit Weight: " & unitWeight)

    Dim youngModulus As Double = myWood.YoungModulus
    message.Append("Young modulus: " & youngModulus)

    MessageBox.Show(message.ToString(), "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Material
Autodesk.Revit.Elements..::.MaterialWood

See Also

MaterialWood Members
Autodesk.Revit.Elements Namespace