Revit 2010 API
CurtainGridLine..::.ExistingSegmentCurves Property
CurtainGridLine Class See Also
Retrieve all the existing segment curves of the grid line.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray ExistingSegmentCurves { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExistingSegmentCurves As CurveArray
Visual C++
public:
property CurveArray^ ExistingSegmentCurves {
    CurveArray^ get ();
}

Remarks

User can get these curves and call RemoveSegment() to remove the segments to the gridline or call AddMullions() to add mullions to these segments.

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace