Revit 2010 API
Application..::.NewPointOnEdgeFaceIntersection Method
Application Class See Also
Construct a PointOnEdgeFaceIntersection object which is used to define the placement of a ReferencePoint given a references to edge and a reference to face.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PointOnEdgeFaceIntersection NewPointOnEdgeFaceIntersection(
    Reference edgeReference,
    Reference faceReference,
    bool orientWithEdge
)
Visual Basic (Declaration)
Public Function NewPointOnEdgeFaceIntersection ( _
    edgeReference As Reference, _
    faceReference As Reference, _
    orientWithEdge As Boolean _
) As PointOnEdgeFaceIntersection
Visual C++
public:
PointOnEdgeFaceIntersection^ NewPointOnEdgeFaceIntersection(
    Reference^ edgeReference,
    Reference^ faceReference,
    bool orientWithEdge
)

Parameters

edgeReference
Type: Autodesk.Revit.Geometry..::.Reference
The edge reference.
faceReference
Type: Autodesk.Revit.Geometry..::.Reference
The face reference.
orientWithEdge
Type: System..::.Boolean

Return Value

A new PointOnEdgeFaceIntersection object.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument edgeReference or faceReference is null.

See Also

Application Class
Autodesk.Revit.Creation Namespace