Revit 2010 API
Curve..::.IsInside Method (Double, Int32%)
Curve Class See Also
Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsInside(
    double parameter,
    out int end
)
Visual Basic (Declaration)
Public Function IsInside ( _
    parameter As Double, _
    <OutAttribute> ByRef end As Integer _
) As Boolean
Visual C++
public:
bool IsInside(
    double parameter,
    [OutAttribute] int% end
)

Parameters

parameter
Type: System..::.Double
The raw curve parameter to be evaluated.
end
Type: System..::.Int32 %
The end index is equal to 0 for the start point, 1 for the end point, or -1 if the parameter is not at the end.

Return Value

True if the parameter is within the curve's bounds, otherwise false.

Remarks

Always returns true if this curve is unbound.

See Also

Curve Class
IsInside Overload
Autodesk.Revit.Geometry Namespace