Revit 2010 API
FamilyItemFactory..::.NewReferencePoint Method (PointElementReference)
FamilyItemFactory Class See Also
Create a reference point on an existing reference in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferencePoint NewReferencePoint(
    PointElementReference
)
Visual Basic (Declaration)
Public Function NewReferencePoint ( _
     As PointElementReference _
) As ReferencePoint
Visual C++
public:
ReferencePoint^ NewReferencePoint(
    PointElementReference^
)

Parameters

Type: Autodesk.Revit.Elements..::.PointElementReference

Return Value

The newly created ReferencePoint.

Remarks

The location and coordinate system of the point is determined by the particular PointReference subclass, and the point will remain constrained to that reference.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the argument is null.
System..::.InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.

See Also

FamilyItemFactory Class
NewReferencePoint Overload
Autodesk.Revit.Creation Namespace