Revit 2010 API
SynchronizeWithCentralOptions Members
SynchronizeWithCentralOptions Class Constructors Methods Properties See Also

The SynchronizeWithCentralOptions type exposes the following members.

Constructors

Name | Description
SynchronizeWithCentralOptions | Initializes a new instance of the SynchronizeWithCentralOptions class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CompactCentralFile | Indicates whether Revit should compact the central file while synchronizing with central. This option reduces the size of the central file but many increase the time it takes to perform the save.
RelinquishBorrowedElements | Indicates whether Revit should relinquish borrowed elements after synchronizing with central.
RelinquishFamilyWorksets | Indicates whether Revit should relinquish Family worksets after synchronizing with central.
RelinquishProjectStandardWorksets | Indicates whether Revit should relinquish Project Standard worksets after synchronizing with central.
RelinquishUserCreatedWorksets | Indicates whether Revit should relinquish user-created worksets after synchronizing with central.
RelinquishViewWorksets | Indicates whether Revit should relinquish View worksets after synchronizing with central.
SaveLocalFile | Indicates whether Revit should save the local file before and after synchronizing with central.

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.Events Namespace