Revit 2010 API
SuspendUpdating Members
SuspendUpdating Class Constructors Methods Properties See Also

The SuspendUpdating type exposes the following members.

Constructors

Name | Description
SuspendUpdating | Create a new instance of the SuspendUpdating object and begin suspension of consistency updates.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Nested | A property that reports if updating has already been suspended before

See Also

SuspendUpdating Class
Autodesk.Revit Namespace