Revit 2010 API
MechanicalSystem Members
MechanicalSystem Class Constructors Methods Properties See Also

The MechanicalSystem type exposes the following members.

Constructors

Name | Description
MechanicalSystem | For Internal Use Only.

Methods

Name | Description
Add | Add elements into the system and connect them with the system using given connectors. (Inherited from MEPSystem.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Remove | Remove elements from system. (Inherited from MEPSystem.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
BaseEquipmentConnector | The connector within the base equipment which is used to connect with the system.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
DuctNetwork | The ducts and fittings contained within the system.
Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Flow | The system flow.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsWellConnected | Indicates if the system is well connected or not.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
StaticPressure | The system static pressure.
SystemType | The type of this duct system.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)

See Also

MechanicalSystem Class
Autodesk.Revit.MEP Namespace