Revit 2010 API
Document Members
Document Class Constructors Methods Properties See Also

The Document type exposes the following members.

Constructors

Name | Description
Document | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase.)
NewAnnotationSymbol | Add a new instance of an Annotation Symbol into the Autodesk Revit document, using a location and a symbol. (Inherited from ItemFactoryBase.)
NewArea | Creates a new area
NewAreaBoundaryConditions | Overloaded. Creates a new Area BoundaryConditions element.
NewAreaBoundaryLine | Creates a new boundary line as an Area border.
NewAreaLoad | Overloaded. Creates a new area load in the project.
NewAreaReinforcement | Creates a new instance of an Area Reinforcement element within the project
NewAreas | Creates new areas
NewAreaTag | Creates a new area tag.
NewAreaViewPlan | Creates a new view for the new area.
NewBeamSystem | Overloaded. Creates a new BeamSystem.
NewCrossFitting | Add a new family instance of a cross fitting into the Autodesk Revit document, using four connectors.
NewCurtainSystem | Overloaded. Creates a new CurtainSystem element.
NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase.)
NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase.)
NewDimension | Overloaded. Creates a new linear dimension object.
NewDuct | Overloaded. Adds a new duct into the document.
NewElbowFitting | Add a new family instance of an elbow fitting into the Autodesk Revit document, using two connectors.
NewElectricalSystem | Overloaded. Creates a new MEP Electrical System element.
NewExtrusionRoof | Creates a new Extrusion Roof.
NewFamilyInstance | Overloaded. Inserts a new instance of a family into the document. Inserts a new instance of a family into the document.
NewFamilyInstances | Creates Family instances within the document. (Inherited from ItemFactoryBase.)
NewFascia | Overloaded. Creates a fascia.
NewFlexDuct | Overloaded. Adds a new duct into the document.
NewFlexPipe | Overloaded. Adds a new flex pipe into the document.
NewFloor | Overloaded. Creates a floor within the project.
NewFootPrintRoof | Creates a new FootPrintRoof element.
NewFoundationSlab | Creates a foundation slab within the project with the given horizontal profile and floor style on the specified level.
NewFoundationWall | Creates a new continuous footing object.
NewGrid | Overloaded. Creates a new grid line.
NewGrids | Creates new grid lines.
NewGroup | Creates a new type of group. (Inherited from ItemFactoryBase.)
NewGutter | Overloaded. Creates a gutter.
NewLevel | Creates a new level. (Inherited from ItemFactoryBase.)
NewLineBoundaryConditions | Overloaded. Creates a new Line BoundaryConditions element.
NewLineLoad | Overloaded. Creates a new line load within the project.
NewLoadCase | Creates a new instance of a LoadCase element within the project.
NewLoadCombination | Creates a new instance of a LoadCombination element within the project.
NewLoadNature | Creates a new instance of a LoadNature element within the project.
NewLoadUsage | Creates a new instance of a LoadUsage element within the project.
NewMechanicalSystem | Creates a new MEP mechanical system element.
NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase.)
NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase.)
NewOpening | Overloaded. Creates a new opening.
NewPathReinforcement | Creates a new instance of a Path Reinforcement element within the project
NewPipe | Overloaded. Adds a new pipe into the document.
NewPipingSystem | Creates a new MEP piping system element.
NewPointBoundaryConditions | Creates a new Point BoundaryConditions Element.
NewPointLoad | Overloaded. Creates a new point load within the project.
NewRebar | Overloaded. Creates a new instance of a Rebar element within the project.
NewRebarShape | Creates a new instance of a Rebar Shape, which defines the shape of the rebar.
NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
NewRoom | Overloaded. Creates a new room.
NewRoomBoundaryLines | Creates a new boundary line as an Room border.
NewRooms | Overloaded. Creates one or more rooms.
NewRoomTag | Creates a new RoomTag.
NewSketchPlane | Overloaded. Creates a new sketch plane.
NewSlab | Creates a slab within the project with the given horizontal profile using the default floor style.
NewSlabEdge | Overloaded. Creates a slab edge.
NewSpace | Overloaded. Creates a new space.
NewSpaceBoundaryLines | Creates a new boundary line as an Space border.
NewSpaces | Overloaded. Creates one or more spaces.
NewSpaceTag | Creates a new SpaceTag.
NewSpotCoordinate | Generate a new spot coordinate object within the project.
NewSpotElevation | Generate a new spot elevation object within the project.
NewTag | Creates a new IndependentTag Element.
NewTakeoffFitting | Add a new family instance of an takeoff fitting into the Autodesk Revit document, using one connector and one MEP curve.
NewTeeFitting | Add a new family instance of a tee fitting into the Autodesk Revit document, using three connectors.
NewTextNote | Overloaded. Creates a new TextNote object.
NewTextNotes | Creates TextNotes with the specified data. (Inherited from ItemFactoryBase.)
NewTopographySurface | Creates a new TopographySurface element in the document, and initializes it with a set of points.
NewTransitionFitting | Add a new family instance of an transition fitting into the Autodesk Revit document, using two connectors.
NewTruss | Creates a New Truss.
NewUnionFitting | Add a new family instance of an union fitting into the Autodesk Revit document, using two connectors.
NewView3D | Creates a new 3D view. (Inherited from ItemFactoryBase.)
NewViewDrafting | Creates a new drafting view.
NewViewPlan | Creates a plan view based on the specified level. (Inherited from ItemFactoryBase.)
NewViewSection | Creates a new section view. (Inherited from ItemFactoryBase.)
NewViewSheet | Creates a new sheet view.
NewWall | Overloaded. Creates a new wall within the project.
NewWalls | Overloaded. Creates walls within the project.
NewWire | Creates a new wire element.
NewZone | Creates a new Zone element.
PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Document Class
Autodesk.Revit.Creation Namespace