Revit 2010 API
Dimension Properties
Dimension Class See Also

The Dimension type exposes the following members.

Properties

Name | Description
AreSegmentsEqual | Indicates if all segments are forced to be equal.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | A curve that represents the dimension line.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DimensionShape | The shape of this dimension.
DimensionType | The dimension style of this dimension.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsLocked | Indicates if this dimension is locked.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Label | The family parameter label of the dimension.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Retrieve or Change the name associated with the Dimension.
NumberOfSegments | The number of segments for the dimension.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
References | Returns an array of geometric references to which the dimension is attached.
Segments | The segments in the dimension.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Value | The value of the dimension.
ValueString | The dimension value as a user visible string.
View | Supplies the view that contains the dimension if the dimension is view specific.

See Also

Dimension Class
Autodesk.Revit.Elements Namespace