Revit 2010 API
FamilyType Members
FamilyType Class Constructors Methods Properties See Also

The FamilyType type exposes the following members.

Constructors

Name | Description
FamilyType | For Internal Use Only.

Methods

Name | Description
AsDouble | Provides access to the double precision number of the given family parameter.
AsElementId | Provides access to the ElementId stored in the given family parameter.
AsInteger | Provides access to the integer number of the given family parameter.
AsString | Provides access to the string contents of the given family parameter.
AsValueString | Provides access to value as a string with unit in the given family parameter.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasValue | Indicates if this family parameter has an assigned value or not.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | The name of the family type.

See Also

FamilyType Class
Autodesk.Revit Namespace