Revit 2010 API
DocumentPrintedEventArgs Members
DocumentPrintedEventArgs Class Constructors Methods Properties See Also

The DocumentPrintedEventArgs type exposes the following members.

Constructors

Name | Description
DocumentPrintedEventArgs | Initializes a new instance of the DocumentPrintedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
FailedViews | Views that failed to print (if any).
PrintedViews | Views that printed successfully.
Status | Indicates whether the the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentPrintedEventArgs Class
Autodesk.Revit.Events Namespace