Revit 2010 API
PlanTopology Members
PlanTopology Class Constructors Methods Properties See Also

The PlanTopology type exposes the following members.

Constructors

Name | Description
PlanTopology | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Circuits | Retrieves Circuits of the PlanTopology.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | Retrieves Level of the PlanTopology.
Phase | Retrieves the phase of the PlanTopology.
Rooms | Retrieves rooms of the PlanTopology in the last phase.

See Also

PlanTopology Class
Autodesk.Revit Namespace