Revit 2010 API
SelElementSet Methods
SelElementSet Class See Also

The SelElementSet type exposes the following members.

Methods

Name | Description
Add | Add an element into the selected element set.
Clear | Clear the selected element set. (Overrides ElementSet..::.Clear()()().)
Contains | Tests for the existence of an element within the set. (Inherited from ElementSet.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Remove an element from the selected element set. (Overrides ElementSet..::.Erase(Element).)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element into the set. (Inherited from ElementSet.)
Remove | Remove an element from the selected element set.
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from ElementSet.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelElementSet Class
Autodesk.Revit Namespace