Revit 2010 API
WireSize Members
WireSize Class Constructors Methods Properties See Also

The WireSize type exposes the following members.

Constructors

Name | Description
WireSize | Initializes a new instance of the WireSize class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Ampacity | Get ampacity which be used for specifying size, the unit is ampere.
Diameter | Get diameter of wire.
InUse | Get or set whether the size can be used in sizing.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Get size symbol of wire.

See Also

WireSize Class
Autodesk.Revit.MEP Namespace