Revit 2010 API
ReferencePoint Members
ReferencePoint Class Constructors Methods Properties See Also

The ReferencePoint type exposes the following members.

Constructors

Name | Description
ReferencePoint | Initializes a new instance of the ReferencePoint class

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCoordinatePlaneReferenceXY | A reference for the XY plane of the coordinate system.
GetCoordinatePlaneReferenceXZ | A reference for the XZ plane of the coordinate system.
GetCoordinatePlaneReferenceYZ | A reference for the YZ plane of the coordinate system.
GetCoordinateSystem | The position and orientation of the ReferencePoint.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInterpolatingCurves | The set of CurveByPoints elements that interpolate a ReferencePoint.
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetPointElementReference | Retrieve a copy of the rule that computes the location of the ReferencePoint relative to other elements in the document.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the point.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetCoordinateSystem | The position and orientation of the ReferencePoint.
SetPointElementReference | Change the rule for computing the location of the ReferencePoint relative to other elements in the document.
SetVisibility | Sets the visibility for the point.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoordinatePlaneVisibility | Visibility settings for the coordinate reference planes.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | (Overrides Element..::.Name.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Position | The position of the ReferencePoint.
ShowNormalReferencePlaneOnly | Whether all three coordinate planes are shown, or only the normal (XY) plane.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Visible | Whether the point is visible when the family is loaded into a project.

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace