Revit 2010 API
RibbonItem Members
RibbonItem Class Constructors Methods Properties See Also

The RibbonItem type exposes the following members.

Constructors

Name | Description
RibbonItem | Initializes a new instance of the RibbonItem class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Returns a value whether the RibbonItem equals to another RibbonItem. (Overrides Object..::.Equals(Object).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the button is enabled.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
ItemText | Gets or sets the text displayed on the button.
ItemType | Gets the item type.
ToolTip | The description that appears as a ToolTip for the button.

See Also

RibbonItem Class
Autodesk.Revit Namespace