Revit 2010 API
City Members
City Class Constructors Methods Properties See Also

The City type exposes the following members.

Constructors

Name | Description
City | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Latitude | Latitde of the city
Longitude | Longitude of the city
Name | The name of the city
TimeZone | Timezone in which the city resides

See Also

City Class
Autodesk.Revit.Site Namespace