Revit 2010 API
RibbonPanel Methods
RibbonPanel Class See Also

The RibbonPanel type exposes the following members.

Methods

Name | Description
AddButton | Adds a button to the panel.
AddPulldownButton | Adds a PulldownButton to the panel.
AddPushButton | Adds a PushButton to the panel.
AddSeparator | Adds a new Separator to the panel.
AddStackedButtons | Overloaded.
AddToPulldown | Adds a pushbutton to the existing PulldownButton.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Returns a value whether the panel equals to another panel. (Overrides Object..::.Equals(Object).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RibbonPanel Class
Autodesk.Revit Namespace