Revit 2010 API
APIObject Members
APIObject Class Constructors Methods Properties See Also

The APIObject type exposes the following members.

Constructors

Name | Description
APIObject | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable.

See Also

APIObject Class
Autodesk.Revit Namespace