Revit 2010 API
Room Properties
Room Class See Also

The Room type exposes the following members.

Properties

Name | Description
Area | Get the Area of the Room.
BaseOffset | Get or Set the Base Offset of the Room.
Boundary | Returns the boundary of the room.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ClosedShell | Return the closedShell of the Room.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LimitOffset | Get or Set the Limit Offset of the Room.
Location | get a location point object. The point within the location object should be get/set. This is the location of the room within the level. The Z location should be the elevation of the level and not changeable. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get or Set the Name of the room. (Overrides Element..::.Name.)
Number | Get or Set the Number of the Room.
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Perimeter | Get the Perimeter of the Room.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UnboundedHeight | Get the Unbounded Height of the Room.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpperLimit | Get or Set the Upper Limit of the Room.
Volume | Get the Volume of the Room.

See Also

Room Class
Autodesk.Revit.Elements Namespace