Revit 2010 API
LocationPoint Members
LocationPoint Class Constructors Methods Properties See Also

The LocationPoint type exposes the following members.

Constructors

Name | Description
LocationPoint | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Move | Move the element within the project by a specified vector. (Inherited from Location.)
Rotate | Rotate the element within the project by a specified number of degrees around a given axis. (Inherited from Location.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Point | Get and set the physical location of the element.
Rotation | Retrieve the angle of rotation around the insertion point.

See Also

LocationPoint Class
Autodesk.Revit Namespace