Revit 2010 API
Form..::.GetProfileAndCurveLoopIndexFromReference Method
Form Class See Also
Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void GetProfileAndCurveLoopIndexFromReference(
    Reference curveOrEdgeReference,
    ref int profileIndex,
    ref int curveLoopIndex
)
Visual Basic (Declaration)
Public Sub GetProfileAndCurveLoopIndexFromReference ( _
    curveOrEdgeReference As Reference, _
    ByRef profileIndex As Integer, _
    ByRef curveLoopIndex As Integer _
)
Visual C++
public:
void GetProfileAndCurveLoopIndexFromReference(
    Reference^ curveOrEdgeReference,
    int% profileIndex,
    int% curveLoopIndex
)

Parameters

curveOrEdgeReference
Type: Autodesk.Revit.Geometry..::.Reference
Reference to a curve/edge that is part of one profile
profileIndex
Type: System..::.Int32 %
Profile index for output
curveLoopIndex
Type: System..::.Int32 %
Curve loop index for output

See Also

Form Class
Autodesk.Revit.Elements Namespace