Revit 2010 API
ProfiledWallCreationData Constructor (CurveArray, WallType, Level, Boolean, XYZ)
ProfiledWallCreationData Class See Also
Initializes a new instance of the ProfiledWallCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProfiledWallCreationData(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic (Declaration)
Public Sub New ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
)
Visual C++
public:
ProfiledWallCreationData(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.Symbols..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.
normal
Type: Autodesk.Revit.Geometry..::.XYZ
A vector that must be perpendicular to the profile which dictates which side of the wall is considered.

See Also

ProfiledWallCreationData Class
ProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace