Revit 2010 API
UV Methods
UV Class See Also

The UV type exposes the following members.

Methods

Name | Description
Add | Adds the specified 2-D vector to this 2-D vector and returns the result.
AlmostEqual | Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).
Angle | Returns the angle between this vector and the specified vector.
Cross | The cross product of this 2-D vector and the specified 2-D vector.
Distance | Returns the distance from this 2-D point to the specified 2-D point.
Divide | Divides this 2-D vector by the specified value and returns the result.
Dot | The dot product of this 2-D vector and the specified 2-D vector.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Multiply | Multiplies this 2-D vector by the specified value and returns the result.
Negate | Negates this 2-D vector.
Subtract | Subtracts the specified 2-D vector from this 2-D vector and returns the result.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Addition | Adds the two specified 2-D vectors and returns the result.
Division | Divides the specified 2-D vector by the specified value.
Multiply | Overloaded. The product of the specified number and the specified 2-D vector.
Subtraction | Subtracts the two specified 2-D vectors and returns the result.
UnaryNegation | Negates this 2-D vector and returns the result.

See Also

UV Class
Autodesk.Revit.Geometry Namespace