Revit 2010 API
CylindricalFace Properties
CylindricalFace Class See Also

The CylindricalFace type exposes the following members.

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
Axis | Axis of the surface.
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Origin | Origin of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Radius | Radii of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

CylindricalFace Class
Autodesk.Revit.Geometry Namespace