Revit 2010 API
ReferencePoint Methods
ReferencePoint Class See Also

The ReferencePoint type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCoordinatePlaneReferenceXY | A reference for the XY plane of the coordinate system.
GetCoordinatePlaneReferenceXZ | A reference for the XZ plane of the coordinate system.
GetCoordinatePlaneReferenceYZ | A reference for the YZ plane of the coordinate system.
GetCoordinateSystem | The position and orientation of the ReferencePoint.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInterpolatingCurves | The set of CurveByPoints elements that interpolate a ReferencePoint.
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetPointElementReference | Retrieve a copy of the rule that computes the location of the ReferencePoint relative to other elements in the document.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility for the point.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetCoordinateSystem | The position and orientation of the ReferencePoint.
SetPointElementReference | Change the rule for computing the location of the ReferencePoint relative to other elements in the document.
SetVisibility | Sets the visibility for the point.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace