Revit 2010 API
PulldownButton Members
PulldownButton Class Constructors Methods Properties See Also

The PulldownButton type exposes the following members.

Constructors

Name | Description
PulldownButton | Initializes a new instance of the PulldownButton class

Methods

Name | Description
AddItem | Adds a new pushbutton to the pulldown button and associates it to an ExternalCommand.
AddPushButton | Adds a new pushbutton to the pulldown button and associates it with an ExternalCommand.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Returns a value whether the RibbonItem equals to another RibbonItem. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the button is enabled. (Inherited from RibbonItem.)
Image | The image shown on the pulldown button.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Items | The collection of items assigned to the pulldown button.
ItemText | Gets or sets the text displayed on the button. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LargeImage | The large image shown on the pulldown button.
Name | Gets the name of the button.
ToolTip | The description that appears as a ToolTip for the button. (Inherited from RibbonItem.)

See Also

PulldownButton Class
Autodesk.Revit Namespace