Revit 2010 API
MEPSystem Methods
MEPSystem Class See Also

The MEPSystem type exposes the following members.

Methods

Name | Description
Add | Add elements into the system and connect them with the system using given connectors.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Remove | Remove elements from system.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPSystem Class
Autodesk.Revit.MEP Namespace