Revit 2010 API
FootPrintRoof..::.Overhang Property
FootPrintRoof Class See Also
Retrieve or set the Overhang of the curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Overhang[
    ModelCurve pCurve
] { get; set; }
Visual Basic (Declaration)
Public Property Overhang ( _
    pCurve As ModelCurve _
) As Double
Visual C++
public:
property double Overhang[ModelCurve^ pCurve] {
    double get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, double value);
}

Parameters

pCurve
Type: Autodesk.Revit.Elements..::.ModelCurve

Remarks

Only when the FootPrintRoof is created by pick walls, this property makes sense.

See Also

FootPrintRoof Class
Autodesk.Revit.Elements Namespace