Revit 2010 API
ElectricalSetting..::.AddDistributionSysType Method
ElectricalSetting Class See Also
Add a new distribution system type to project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DistributionSysType AddDistributionSysType(
    string name,
    ElectricalPhase phase,
    ElectricalPhaseConfiguration phaseConfig,
    int numWire,
    VoltageType volLineToLine,
    VoltageType volLineToGround
)
Visual Basic (Declaration)
Public Function AddDistributionSysType ( _
    name As String, _
    phase As ElectricalPhase, _
    phaseConfig As ElectricalPhaseConfiguration, _
    numWire As Integer, _
    volLineToLine As VoltageType, _
    volLineToGround As VoltageType _
) As DistributionSysType
Visual C++
public:
DistributionSysType^ AddDistributionSysType(
    String^ name,
    ElectricalPhase phase,
    ElectricalPhaseConfiguration phaseConfig,
    int numWire,
    VoltageType^ volLineToLine,
    VoltageType^ volLineToGround
)

Parameters

name
Type: System..::.String
The name of new added distribution system type
phase
Type: Autodesk.Revit.MEP.Enums..::.ElectricalPhase
Single or three phase this type is
phaseConfig
Type: Autodesk.Revit.MEP.Enums..::.ElectricalPhaseConfiguration
Configuration property of given phase
numWire
Type: System..::.Int32
Wire number of this distribution system
volLineToLine
Type: Autodesk.Revit.MEP..::.VoltageType
Type of line to line voltage in this system
volLineToGround
Type: Autodesk.Revit.MEP..::.VoltageType
Type of line to ground voltage in this system

Return Value

New added distribution system type object.

Exceptions

Exception | Condition
System..::.ArgumentException | The name can't be null, empty string, or equal with any existing one, phaseConfig should be defined and numWire can only be 3 or 4 in case of three phase, numWire can only be 2 or 3 in case of single phase, otherwise exception will be thrown.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace