Revit 2010 API
ExternalDefinition Members
ExternalDefinition Class Constructors Methods Properties See Also

The ExternalDefinition type exposes the following members.

Constructors

Name | Description
ExternalDefinition | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
GUID | Returns the GUID associated with the shared parameter definition.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | The user visible name for the parameter. (Overrides Definition..::.Name.)
OwnerGroup | Returns or change the group ID of the external parameter definition.
ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition..::.ParameterGroup.)
ParameterType | Returns the user visible interpretation of the parameter data. (Overrides Definition..::.ParameterType.)
Visible | Tells the developer is the parameter should be visible within the user interface of their application or Autodesk Revit. (Overrides DefinitionVisible()()().)

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace