Revit 2010 API
DefinitionFile Class
Members Example See Also
The DefinitionFile object represents a shared parameters file on disk.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DefinitionFile : APIObject
Visual Basic (Declaration)
Public Class DefinitionFile _
    Inherits APIObject
Visual C++
public ref class DefinitionFile : public APIObject

Remarks

Shared Parameters are parameter definitions that are stored in a text file external to the Autodesk Revit project. These definitions can be used in multiple projects and are identifiable by a unique identifier generated when they are created. API access to shared parameters consist of a number of objects, the first of which is an object that represents the shared parameters file on disk. That object then contains a number of Group objects. Shared parameters are grouped for easier management. These groups then contain the shared parameter definitions. The groups support the ability to create new shared parameter definitions. The DefinitionFile object can be retrieved by the Document.OpenSharedParameterFile method.

Examples

CopyC#
private void ShowDefinitionFileInfo(DefinitionFile myDefinitionFile)
{
    StringBuilder fileInformation = new StringBuilder(500);

    // get the file name
    fileInformation.AppendLine("File Name: " + myDefinitionFile.Filename);

    // iterate the Definition groups of this file
    foreach (DefinitionGroup myGroup in myDefinitionFile.Groups)
    {
        // get the group name
        fileInformation.AppendLine("Group Name: " + myGroup.Name);

        // iterate the difinitions
        foreach (Definition definition in myGroup.Definitions)
        {
            // get definition name
            fileInformation.AppendLine("Definition Name: " + definition.Name);
        }
    }
    MessageBox.Show(fileInformation.ToString(), "Revit");
}
CopyVB.NET
Private Sub ShowDefinitionFileInfo(ByVal myDefinitionFile As DefinitionFile)
    Dim fileInformation As New StringBuilder(500)

    ' get the file name
    fileInformation.AppendLine("File Name: " & myDefinitionFile.Filename)

    ' iterate the Definition groups of this file
    For Each myGroup As DefinitionGroup In myDefinitionFile.Groups
        ' get the group name
        fileInformation.AppendLine("Group Name: " & myGroup.Name)

        ' iterate the difinitions
        For Each definition As Definition In myGroup.Definitions
            ' get definition name
            fileInformation.AppendLine("Definition Name: " & definition.Name)
        Next
    Next
    MessageBox.Show(fileInformation.ToString(), "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.DefinitionFile

See Also

DefinitionFile Members
Autodesk.Revit.Parameters Namespace