Revit 2010 API
ExternalCommandData Members
ExternalCommandData Class Constructors Methods Properties See Also

The ExternalCommandData type exposes the following members.

Constructors

Name | Description
ExternalCommandData | Initializes a new instance of the ExternalCommandData class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Application | Retrieves an object that represents the current Application for external command.
Data | A data map that can be used to read and write data to the Autodesk Revit journal file.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
View | Retrieves an object that represents the View external command work on.

See Also

ExternalCommandData Class
Autodesk.Revit Namespace