Revit 2010 API
Application..::.NewPointOnEdge Method
Application Class See Also
Create a PointOnEdge object which is used to define the placement of a ReferencePoint.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PointOnEdge NewPointOnEdge(
    Reference edgeReference,
    double edgeParam
)
Visual Basic (Declaration)
Public Function NewPointOnEdge ( _
    edgeReference As Reference, _
    edgeParam As Double _
) As PointOnEdge
Visual C++
public:
PointOnEdge^ NewPointOnEdge(
    Reference^ edgeReference,
    double edgeParam
)

Parameters

edgeReference
Type: Autodesk.Revit.Geometry..::.Reference
The reference whose edge the object will be created on.
edgeParam
Type: System..::.Double
The parameter on the edge.

Return Value

If creation was successful then a new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument edgeReference is null or edgeParam is not a valid dobule value.

See Also

Application Class
Autodesk.Revit.Creation Namespace