Revit 2010 API
RectangularWallCreationData Constructor (Curve, WallType, Level, Double, Double, Boolean, Boolean)
RectangularWallCreationData Class See Also
Initializes a new instance of the RectangularWallCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RectangularWallCreationData(
    Curve curve,
    WallType wallType,
    Level level,
    double height,
    double offset,
    bool flip,
    bool structural
)
Visual Basic (Declaration)
Public Sub New ( _
    curve As Curve, _
    wallType As WallType, _
    level As Level, _
    height As Double, _
    offset As Double, _
    flip As Boolean, _
    structural As Boolean _
)
Visual C++
public:
RectangularWallCreationData(
    Curve^ curve,
    WallType^ wallType,
    Level^ level,
    double height,
    double offset,
    bool flip,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
An arc or line representing the base line of the wall.
wallType
Type: Autodesk.Revit.Symbols..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the wall is to be placed.
height
Type: System..::.Double
The height of the wall.
offset
Type: System..::.Double
An offset distance, in feet from the specified baseline. The wall will be placed that distance from the baseline.
flip
Type: System..::.Boolean
Change which side of the wall is considered to be the inside and outside of the wall.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

See Also

RectangularWallCreationData Class
RectangularWallCreationData Overload
Autodesk.Revit.Creation Namespace