Revit 2010 API
DimensionSegment Members
DimensionSegment Class Constructors Methods Properties See Also

The DimensionSegment type exposes the following members.

Constructors

Name | Description
DimensionSegment | Initializes a new instance of the DimensionSegment class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsLocked | Indicates if this segment is locked.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Origin | The segment origin.
Value | The length of the segment.
ValueString | The displayed value shown for the dimension segment.

See Also

DimensionSegment Class
Autodesk.Revit Namespace