Revit 2010 API
Application..::.NewPointOnEdgeEdgeIntersection Method
Application Class See Also
Construct a PointOnEdgeEdgeIntersection object which is used to define the placement of a ReferencePoint given two references to edge.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PointOnEdgeEdgeIntersection NewPointOnEdgeEdgeIntersection(
    Reference edgeReference1,
    Reference edgeReference2
)
Visual Basic (Declaration)
Public Function NewPointOnEdgeEdgeIntersection ( _
    edgeReference1 As Reference, _
    edgeReference2 As Reference _
) As PointOnEdgeEdgeIntersection
Visual C++
public:
PointOnEdgeEdgeIntersection^ NewPointOnEdgeEdgeIntersection(
    Reference^ edgeReference1,
    Reference^ edgeReference2
)

Parameters

edgeReference1
Type: Autodesk.Revit.Geometry..::.Reference
The first edge reference.
edgeReference2
Type: Autodesk.Revit.Geometry..::.Reference
The second edge reference.

Return Value

A new PointOnEdgeEdgeIntersection object.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument edgeReference1 or edgeReference2 is null.

See Also

Application Class
Autodesk.Revit.Creation Namespace