Revit 2010 API
CurveByPoints Members
CurveByPoints Class Constructors Methods Properties See Also

The CurveByPoints type exposes the following members.

Constructors

Name | Description
CurveByPoints | Initializes a new instance of the CurveByPoints class

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetPoints | Get the sequence of points interpolated by this curve.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVisibility | Gets the visibility.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
SetPoints | Change the sequence of points interpolated by this curve.
SetVisibility | Sets the visibility.
SortPoints | Order a set of ReferencePoints in the same way Revit does when creating a curve from points.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsReferenceLine |
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceType | Indicates the type of reference.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | Override the SketchPlane property of CurveElement. (Overrides CurveElement..::.SketchPlane.)
Subcategory | The subcategory, or graphics style, of the CurveByPoints.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Visible | Whether the point is visible when the family is loaded into a project.

See Also

CurveByPoints Class
Autodesk.Revit.Elements Namespace