Revit 2010 API
BoundaryConditions..::.NumCurves Property
BoundaryConditions Class See Also
Returns the number of curves represent the Boundary Conditions Element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NumCurves { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumCurves As Integer
Visual C++
public:
property int NumCurves {
    int get ();
}

Remarks

For Point Boundary Conditions returns 0, for Line Boundary Conditions returns 1, for Area Boundary Conditions returns value > 0.

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace