Revit 2010 API
ControlledApplication Methods
ControlledApplication Class See Also

The ControlledApplication type exposes the following members.

Methods

Name | Description
CreateRibbonPanel | Create a new RibbonPanel.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRibbonPanels | Get all the custom Panels on Add-Ins tab of Revit.
GetType | Gets the Type of the current instance. (Inherited from Object.)
OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ControlledApplication Class
Autodesk.Revit Namespace