Revit 2010 API
RebarShapeDefinition Members
RebarShapeDefinition Class Constructors Methods Properties See Also

The RebarShapeDefinition type exposes the following members.

Constructors

Name | Description
RebarShapeDefinition | For Internal Use Only.

Methods

Name | Description
AddFormulaParameter | Add a formula-driven parameter to the shape definition.
AddParameter | Add a parameter to the shape definition.
CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values.
Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Complete | Report whether the shape definition is fully constrained.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarShapeDefinition Class
Autodesk.Revit.Symbols Namespace