Revit 2010 API
Document..::.Mirror Method (ElementSet, Line)
Document Class See Also
Mirrors several elements about an arbitrary geometric line.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Mirror(
    ElementSet elements,
    Line line
)
Visual Basic (Declaration)
Public Function Mirror ( _
    elements As ElementSet, _
    line As Line _
) As Boolean
Visual C++
public:
bool Mirror(
    ElementSet^ elements,
    Line^ line
)

Parameters

elements
Type: Autodesk.Revit..::.ElementSet
A set of elements that are to be mirrored.
line
Type: Autodesk.Revit.Geometry..::.Line
The line by which the elements will mirror.

Return Value

If the elements are mirrored successfully then the method returns true.

See Also

Document Class
Mirror Overload
Autodesk.Revit Namespace