Revit 2010 API
Face Properties
Face Class See Also

The Face type exposes the following members.

Properties

Name | Description
Area | The area of this face.
EdgeLoops | Each edge loop is a closed boundary of the face.
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate)
MaterialElement | Element describing the material from which this face is composed. (Overrides GeometryObjectMaterialElement()()().)
Period | The period of this face in the specified parametric direction.
Reference | Returns a stable reference to the face.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Face Class
Autodesk.Revit.Geometry Namespace