Revit 2010 API
AnalyticalModelFrame Members
AnalyticalModelFrame Class Constructors Methods Properties See Also

The AnalyticalModelFrame type exposes the following members.

Constructors

Name | Description
AnalyticalModelFrame | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Curve | Provides access to Structural Framing Analytical Model.
Curves | Returns curves that define the Analytical Model of the associated Element.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Profile | This property will return an object that represents a cross section of the beam or column and a curve along which the profile is swept.
RigidLink | Provides access to Rigid Links component of Structural Framing Element.
SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModelFrame Class
Autodesk.Revit.Structural Namespace