Revit 2010 API
Solid Members
Solid Class Constructors Methods Properties See Also

The Solid type exposes the following members.

Constructors

Name | Description
Solid | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Edges | The edges that belong to the solid.
Faces | The faces that belong to the solid.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
SurfaceArea | Returns the total surface area of this solid.
Visibility | The visibility. (Inherited from GeometryObject.)
Volume | Returns the signed volume of this solid.

See Also

Solid Class
Autodesk.Revit.Geometry Namespace