Revit 2010 API
City Class
Members Example See Also
An object that contains geographical locational informaiton for a known city.

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class City : APIObject
Visual Basic (Declaration)
Public Class City _
    Inherits APIObject
Visual C++
public ref class City : public APIObject

Remarks

This object contains longitude, latitude, timezone information for a city already known by Revit. Currently Revit does not the ability to add cities to the existing list. The list of known cities can be retrieved using the Cities property on the application object.

Examples

CopyC#
double angleRatio = Math.PI / 180;   // ratio of Angle

// Get the Latitude information
double latiude = city.Latitude / angleRatio;
String latiudeInfo = "Latitude:      " + latiude.ToString();

// Get the Longitude information
double longitude = city.Longitude / angleRatio;
String longitudeInfo = "Longitude:   " + longitude.ToString();

// Get the TimeZone information
String timeZoneInfo = "TimeZone:   " + city.TimeZone.ToString();

// Set the information text box.
string cityInfo = latiudeInfo + "\n" + longitudeInfo
                            + "\n" + timeZoneInfo;
CopyVB.NET
Dim angleRatio As Double = Math.PI / 180
' ratio of Angle
' Get the Latitude information
Dim latiude As Double = city.Latitude / angleRatio
Dim latiudeInfo As String = "Latitude: " & latiude.ToString()

' Get the Longitude information
Dim longitude As Double = city.Longitude / angleRatio
Dim longitudeInfo As String = "Longitude: " & longitude.ToString()

' Get the TimeZone information
Dim timeZoneInfo As String = "TimeZone: " & city.TimeZone.ToString()

' Set the information text box.
Dim cityInfo As String = ((latiudeInfo & vbLf) + longitudeInfo & vbLf) + timeZoneInfo

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Site..::.City

See Also

City Members
Autodesk.Revit.Site Namespace