Revit 2010 API
SpacingRule..::.SetLayoutFixedNumber Method
SpacingRule Class See Also
Set the Layout property to FixedNumber.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetLayoutFixedNumber(
    int number,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
Visual Basic (Declaration)
Public Sub SetLayoutFixedNumber ( _
    number As Integer, _
    just As SpacingRuleJustification, _
    gridlinesRotation As Double, _
    offset As Double _
)
Visual C++
public:
void SetLayoutFixedNumber(
    int number,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)

Parameters

number
Type: System..::.Int32
just
Type: Autodesk.Revit.Enums..::.SpacingRuleJustification
gridlinesRotation
Type: System..::.Double
offset
Type: System..::.Double

Remarks

When changing the Layout to FixedNumber, you must also simultaneously set the Number, Justification, GridlinesRotation, and Offset properties.

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace