Revit 2010 API
FilterCriterion Members
FilterCriterion Class Constructors Methods Properties See Also

The FilterCriterion type exposes the following members.

Constructors

Name | Description
FilterCriterion | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FilterType | Gets or sets the filter type of this criterion.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Parameter | Gets or sets the parameter of this criterion by builtin parameter.
ParameterID | Gets or sets the parameter of this criterion by parameter id.
ParameterValue | Gets or sets the parameter value of this criterion.

See Also

FilterCriterion Class
Autodesk.Revit Namespace