Revit 2010 API
MaterialWood Properties
MaterialWood Class See Also

The MaterialWood type exposes the following members.

Properties

Name | Description
Bending | Get or set the bending of the wood material.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
CompressionParallel | Get or set the compression parallel to grain of the wood material.
CompressionPerpendicular | Get or set the compression perpendicular to grain of the wood material.
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Grade | Get or set the grade of the wood material.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PoissonModulus | Get or set the Poisson modulus of the wood material.
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
ShearModulus | Get or set the shear modulus of the wood material.
ShearParallel | Get or set the shear parallel to grain of the wood material.
ShearPerpendicular | Get or set the tension perpendicular to grain of the wood material.
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
Species | Get or set the species of the wood material.
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
ThermalExpansionCoefficient | Get or set the thermal expansion coefficient of the wood material.
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UnitWeight | Get or set the unit weight of the wood material.
YoungModulus | Get or set the Young modulus of the wood material.

See Also

MaterialWood Class
Autodesk.Revit.Elements Namespace