Revit 2010 API
Element..::.ParametersMap Property
Element Class See Also
Retrieves a map containing all of the parameters that are contained within the element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterMap ParametersMap { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParametersMap As ParameterMap
Visual C++
public:
property ParameterMap^ ParametersMap {
    ParameterMap^ get ();
}

Remarks

The Parameters can be rapidly accessed by parameter name as a key. These parameters are displayed in the Element properties dialog in the Autodesk Revit interface. These parameters can be retrieved and set via the parameter objects stored in this map.

See Also

Element Class
Autodesk.Revit Namespace