Revit 2010 API
PushButton Properties
PushButton Class See Also

The PushButton type exposes the following members.

Properties

Name | Description
AssemblyName | The assembly path of the button.
ClassName | The name of the class containing the implementation for the command.
Enabled | Gets or sets a value indicating whether the button is enabled. (Inherited from RibbonItem.)
Image | The image of the button.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
ItemText | Gets or sets the text displayed on the button. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LargeImage | The large image shown on the button.
Name | The name of the button.
ToolTip | The description that appears as a ToolTip for the button. (Inherited from RibbonItem.)

See Also

PushButton Class
Autodesk.Revit Namespace