Revit 2010 API
AnalyticalModelProfile Members
AnalyticalModelProfile Class Constructors Methods Properties See Also

The AnalyticalModelProfile type exposes the following members.

Constructors

Name | Description
AnalyticalModelProfile | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DrivingCurve | Provides access to the curve that dictates the path of the swept profile.
EndSetBack | Returns the distance from the end of the driving curve that the sweep actually finishes.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
StartSetBack | Returns the distance from the start of the driving curve that the sweep actually begins.
SweptProfile | Returns an object that describes the profile that is swept along the driving curve.

See Also

AnalyticalModelProfile Class
Autodesk.Revit.Structural Namespace