Revit 2010 API
PrintSetup Members
PrintSetup Class Constructors Methods Properties See Also

The PrintSetup type exposes the following members.

Constructors

Name | Description
PrintSetup | For Internal Use Only.

Methods

Name | Description
Delete | Delete the current print setting, and make the In-Session setting as the current one.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Rename | Rename the current print setting with the specified name.
Revert | Revert the current print setting.
Save | Save the changes for the current print setting.
SaveAs | Save the current print setting to another print setting with the specified name.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurrentPrintSetting | The current Print Setting of Print Setup.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PrintSetup Class
Autodesk.Revit Namespace