Revit 2010 API
DocumentCreatingEventArgs Members
DocumentCreatingEventArgs Class Constructors Methods Properties See Also

The DocumentCreatingEventArgs type exposes the following members.

Constructors

Name | Description
DocumentCreatingEventArgs | Initializes a new instance of the DocumentCreatingEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DocumentType | Type of the document which is about to be created, e.g. Project or Template.
Template | The template file path to be used for creating the new document.

See Also

DocumentCreatingEventArgs Class
Autodesk.Revit.Events Namespace