Revit 2010 API
InstanceArray Members
InstanceArray Class Constructors Methods Properties See Also

The InstanceArray type exposes the following members.

Constructors

Name | Description
InstanceArray | Initializes a new instance of the InstanceArray class

Methods

Name | Description
Append | Add the instance to the end of the array.
Clear | Removes every instance from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified instance into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an instance at a specified index within the array.
Size | Returns the number of instances that are in the array.

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace