Revit 2010 API
LoadCombination Class
Members Example See Also
An object that represents a load combination.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LoadCombination : Element
Visual Basic (Declaration)
Public Class LoadCombination _
    Inherits Element
Visual C++
public ref class LoadCombination : public Element

Examples

CopyC#
private void CombinationInformation(LoadCombination loadCombination)
{
    StringBuilder information = new StringBuilder();

    //Get the string with Load Combination Name or empty string
    information.Append("\n\nCombination Name: " + loadCombination.Name);

    //Get the string with Load Combination State
    information.Append("\nCombination state: " + loadCombination.CombinationState);

    //Load Combination State index or 0
    information.Append("\nState index : " + loadCombination.CombinationStateIndex.ToString());

    //Get the string with Load Combination Type
    information.Append("\nCombination type: " + loadCombination.CombinationType);

    //Get Load Combination Type index or 0
    information.Append("\nType index: " + loadCombination.CombinationTypeIndex.ToString());

    //Get the number of Load Combination Components
    int componentsNumber = loadCombination.NumberOfComponents;
    information.Append("\nComponents number: " + componentsNumber.ToString());
    for (int j = 0; j < componentsNumber; j++)
    {
        double factor = loadCombination.get_Factor(j);
        string caseName = loadCombination.get_CombinationCaseName(j);
        information.Append("\nCase name[" + j.ToString() + "]: " + caseName + "  factor: " +
                              factor.ToString());
    }

    //return the number of usage in the combination
    int usageNumber = loadCombination.NumberOfUsages;
    information.Append("\nNumber of usages: " + usageNumber + "\nUsage names: ");
    //get each usage name
    for (int i = 0; i < usageNumber; i++)
    {
        information.Append(loadCombination.get_UsageName(i) + "  ");
    }

    MessageBox.Show(information.ToString(), "Revit");
}
CopyVB.NET
Private Sub CombinationInformation(ByVal loadCombination As LoadCombination)
    Dim information As New StringBuilder()

    'Get the string with Load Combination Name or empty string
    information.Append(vbLf & vbLf & "Combination Name: " & loadCombination.Name)

    'Get the string with Load Combination State
    information.Append(vbLf & "Combination state: " & loadCombination.CombinationState)

    'Load Combination State index or 0
    information.Append(vbLf & "State index : " & loadCombination.CombinationStateIndex.ToString())

    'Get the string with Load Combination Type
    information.Append(vbLf & "Combination type: " & loadCombination.CombinationType)

    'Get Load Combination Type index or 0
    information.Append(vbLf & "Type index: " & loadCombination.CombinationTypeIndex.ToString())

    'Get the number of Load Combination Components
    Dim componentsNumber As Integer = loadCombination.NumberOfComponents
    information.Append(vbLf & "Components number: " & componentsNumber.ToString())
    For j As Integer = 0 To componentsNumber - 1
        Dim factor As Double = loadCombination.Factor(j)
        Dim caseName As String = loadCombination.CombinationCaseName(j)
        information.Append(((vbLf & "Case name[" & j.ToString() & "]: ") + caseName & " factor: ") + factor.ToString())
    Next

    'return the number of usage in the combination
    Dim usageNumber As Integer = loadCombination.NumberOfUsages
    information.Append(vbLf & "Number of usages: " & usageNumber & vbLf & "Usage names: ")
    'get each usage name
    For i As Integer = 0 To usageNumber - 1
        information.Append(loadCombination.UsageName(i) & " ")
    Next

    MessageBox.Show(information.ToString(), "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.LoadCombination

See Also

LoadCombination Members
Autodesk.Revit.Elements Namespace