Revit 2010 API
ElementIdSet Members
ElementIdSet Class Constructors Methods Properties See Also

The ElementIdSet type exposes the following members.

Constructors

Name | Description
ElementIdSet | Initializes a new instance of the ElementIdSet class

Methods

Name | Description
Clear | Removes every element id from the set, rendering it empty.
Contains | Tests for the existence of an element id within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified element id from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element id into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of element ids that are in the set.

See Also

ElementIdSet Class
Autodesk.Revit Namespace