Revit 2010 API
Reference Members
Reference Class Constructors Methods Properties See Also

The Reference type exposes the following members.

Constructors

Name | Description
Reference | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Element | The element for this reference.
ElementReferenceType | The type of reference referred to.
GeometryObject | The geometry item referred to by this reference.
GlobalPoint | The position on which the reference is hit.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
ProximityParameter | The proximity value to the ray's origin when the reference is returned by Autodesk::Revit::Document::FindReferencesByDirection.
Transform | The transformation of the geometry item into the coordinates of the document.
UVPoint | The UV parameters of the reference, if the reference contains a face.

See Also

Reference Class
Autodesk.Revit.Geometry Namespace