Revit 2010 API
AnalyticalSupportInfo Members
AnalyticalSupportInfo Class Constructors Methods Properties See Also

The AnalyticalSupportInfo type exposes the following members.

Constructors

Name | Description
AnalyticalSupportInfo | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Element | Gets the Structural Element providing support.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
SupportType | Returns the type of support provided by the other Element.

See Also

AnalyticalSupportInfo Class
Autodesk.Revit.Structural Namespace