Revit 2010 API
DefinitionGroup..::.Definitions Property
DefinitionGroup Class See Also
The Definitions property returns an object that contains all the shared parameter definitions within the group.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Definitions Definitions { get; }
Visual Basic (Declaration)
Public ReadOnly Property Definitions As Definitions
Visual C++
public:
property Definitions^ Definitions {
    Definitions^ get ();
}

Remarks

A known definition can be retrieved, by name, using the Item property on the Definitions object. A new definition can be created by using the Create method. The Create method takes two parameters, a string for name and a type. If the creation of the definition was successful then an object representing the definition is returned by the Create method.

See Also

DefinitionGroup Class
Autodesk.Revit.Parameters Namespace