Revit 2010 API
CurtainGridLine Methods
CurtainGridLine Class See Also

The CurtainGridLine type exposes the following members.

Methods

Name | Description
AddAllSegments | All the segments on this grid line will be added.
AddMullions | Add mullions on the specified segments of a grid. If a segment already had mullion, just keep it and do nothing to that segment.
AddSegment | Add a segment based on the specified segment curve of the gridline.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Move | It is used to move unlocked type-driven grid lines or user defined grid lines.
RemoveSegment | Remove the segment specified by the input curve.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace