Revit 2010 API
Document..::.NewGutter Method (GutterType, ReferenceArray)
Document Class See Also
Creates a gutter along a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Gutter NewGutter(
    GutterType GutterType,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewGutter ( _
    GutterType As GutterType, _
    references As ReferenceArray _
) As Gutter
Visual C++
public:
Gutter^ NewGutter(
    GutterType^ GutterType,
    ReferenceArray^ references
)

Parameters

GutterType
Type: Autodesk.Revit.Symbols..::.GutterType
The type of the gutter to create
references
Type: Autodesk.Revit.Geometry..::.ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the gutter.

Return Value

If successful a new gutter object within the project, otherwise Nothing.

See Also

Document Class
NewGutter Overload
Autodesk.Revit.Creation Namespace