Revit 2010 API
Materials Methods
Materials Class See Also

The Materials type exposes the following members.

Methods

Name | Description
AddConcrete | Add a concrete material with the given name .
AddGeneric | Add a generic material with the given name .
AddOther | Add an other material with the given name .
AddSteel | Add a steel material with the given name .
AddWood | Add a wood material with the given name .
Clear | Removes every material from the set, rendering it empty. (Inherited from MaterialSet.)
Contains | Overloaded. Checks if the material set contains the material with the specified identifier.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified material from the set. (Inherited from MaterialSet.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from MaterialSet.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from MaterialSet.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified material into the set. (Inherited from MaterialSet.)
Remove | Remove the material with the speicified name .
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from MaterialSet.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Materials Class
Autodesk.Revit Namespace