Revit 2010 API
FamilyManager..::.Types Property
FamilyManager Class Example See Also
All family types in the family.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyTypeSet Types { get; }
Visual Basic (Declaration)
Public ReadOnly Property Types As FamilyTypeSet
Visual C++
public:
property FamilyTypeSet^ Types {
    FamilyTypeSet^ get ();
}

Examples

CopyC#
public void GetFamilyTypesInFamily(Document familyDoc)
{
    if (familyDoc.IsFamilyDocument == true)
    {
        FamilyManager familyManager = familyDoc.FamilyManager;

        // get types in family
        string types = "Family Types: ";
        FamilyTypeSet familyTypes = familyManager.Types;
        FamilyTypeSetIterator familyTypesItor = familyTypes.ForwardIterator();
        familyTypesItor.Reset();
        while (familyTypesItor.MoveNext())
        {
            FamilyType familyType = familyTypesItor.Current as FamilyType;
            types += "\n" + familyType.Name;
        }
        MessageBox.Show(types, "Revit");
    }
}
CopyVB.NET
Public Sub GetFamilyTypesInFamily(ByVal familyDoc As Document)
    If familyDoc.IsFamilyDocument = True Then
        Dim familyManager As FamilyManager = familyDoc.FamilyManager

        ' get types in family
        Dim types As String = "Family Types: "
        Dim familyTypes As FamilyTypeSet = familyManager.Types
        Dim familyTypesItor As FamilyTypeSetIterator = familyTypes.ForwardIterator()
        familyTypesItor.Reset()
        While familyTypesItor.MoveNext()
            Dim familyType As FamilyType = TryCast(familyTypesItor.Current, FamilyType)
            types += vbLf & familyType.Name
        End While
        MessageBox.Show(types, "Revit")
    End If
End Sub

See Also

FamilyManager Class
Autodesk.Revit Namespace