Revit 2010 API
ItemFactoryBase..::.NewModelCurve Method
ItemFactoryBase Class Example See Also
Creates a new model line element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelCurve NewModelCurve(
    Curve geometryCurve,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Function NewModelCurve ( _
    geometryCurve As Curve, _
    sketchPlane As SketchPlane _
) As ModelCurve
Visual C++
public:
ModelCurve^ NewModelCurve(
    Curve^ geometryCurve,
    SketchPlane^ sketchPlane
)

Parameters

geometryCurve
Type: Autodesk.Revit.Geometry..::.Curve
The internal geometry curve for model line.
sketchPlane
Type: Autodesk.Revit.Elements..::.SketchPlane
The sketch plane this new model line resides in.

Return Value

If successful a new model line element. Otherwise null pointer.

Remarks

Different type of model curve element will be returned according to the type of geometry curve.

Examples

CopyC#
// get handle to application from document
Autodesk.Revit.Application application = document.Application;

// Create a geometry line in revit application
XYZ startPoint = new XYZ(0, 0, 0);
XYZ endPoint = new XYZ(10, 10, 0);
Line geomLine = application.Create.NewLine(startPoint, endPoint, true);

// Create a geometry arc in revit application
XYZ end0 = new XYZ(1, 0, 0);
XYZ end1 = new XYZ(10, 10, 10);
XYZ pointOnCurve = new XYZ(10, 0, 0);
Arc geomArc = application.Create.NewArc(end0, end1, pointOnCurve);

// Create a geometry plane in revit application
XYZ origin = new XYZ(0, 0, 0);
XYZ normal = new XYZ(1, 1, 0);
Plane geomPlane = application.Create.NewPlane(normal, origin);

// Create a sketch plane in current document
SketchPlane sketch = document.Create.NewSketchPlane(geomPlane);

// Create a ModelLine element using the created geometry line and sketch plane
ModelLine line = document.Create.NewModelCurve(geomLine, sketch) as ModelLine;

// Create a ModelArc element using the created geometry arc and sketch plane
ModelArc arc = document.Create.NewModelCurve(geomArc, sketch) as ModelArc;
CopyVB.NET
' get handle to application from document
Dim application As Autodesk.Revit.Application = document.Application

' Create a geometry line in revit application
Dim startPoint As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
Dim endPoint As New Autodesk.Revit.Geometry.XYZ(10, 10, 0)
Dim geomLine As Line = application.Create.NewLine(startPoint, endPoint, True)

' Create a geometry arc in revit application
Dim end0 As New Autodesk.Revit.Geometry.XYZ(1, 0, 0)
Dim end1 As New Autodesk.Revit.Geometry.XYZ(10, 10, 10)
Dim pointOnCurve As New Autodesk.Revit.Geometry.XYZ(10, 0, 0)
Dim geomArc As Arc = application.Create.NewArc(end0, end1, pointOnCurve)

' Create a geometry plane in revit application
Dim origin As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
Dim normal As New Autodesk.Revit.Geometry.XYZ(1, 1, 0)
Dim geomPlane As Autodesk.Revit.Geometry.Plane = application.Create.NewPlane(normal, origin)

' Create a sketch plane in current document
Dim sketch As Autodesk.Revit.Elements.SketchPlane = document.Create.NewSketchPlane(geomPlane)

' Create a ModelLine element using the created geometry line and sketch plane
Dim line As ModelLine = TryCast(document.Create.NewModelCurve(geomLine, sketch), ModelLine)

' Create a ModelArc element using the created geometry arc and sketch plane
Dim arc As ModelArc = TryCast(document.Create.NewModelCurve(geomArc, sketch), ModelArc)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace