Revit 2010 API
SlabShapeEditor Members
SlabShapeEditor Class Constructors Methods Properties See Also

The SlabShapeEditor type exposes the following members.

Constructors

Name | Description
SlabShapeEditor | For Internal Use Only.

Methods

Name | Description
DrawPoint | Adds a point to the corresponding slab, roof or floor.
DrawSplitLine | Draws a split line on the corresponding slab, roof or floor.
Enable | Enables the slab shape editing functionality.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ModifySubElement | Overloaded. Manipulates an entity on the corresponding slab, roof or floor.
PickSupport | Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.
ResetSlabShape | Removes the modifications made during editing and resets the element geometry back to the un-modified state.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEnabled | Identifies if the slab shape editing functionality is enabled.
SlabShapeCreases | All of the creases that can be edited.
SlabShapeVertices | All of the vertices that can be edited.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace