Revit 2010 API
Application..::.NewInstanceBinding Method (CategorySet)
Application Class See Also
Creates a new instance binding object containing the categories passed as a parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InstanceBinding NewInstanceBinding(
    CategorySet categorySet
)
Visual Basic (Declaration)
Public Function NewInstanceBinding ( _
    categorySet As CategorySet _
) As InstanceBinding
Visual C++
public:
InstanceBinding^ NewInstanceBinding(
    CategorySet^ categorySet
)

Parameters

categorySet
Type: Autodesk.Revit..::.CategorySet
A set of categories that will be added to the binding.

Return Value

Returns a new instance binding object.

Remarks

Instance binding objects are used for attaching shared parameter definitions to all instances of an element within a category.

See Also

Application Class
NewInstanceBinding Overload
Autodesk.Revit.Creation Namespace