Revit 2010 API
DefinitionBindingMap Methods
DefinitionBindingMap Class See Also

The DefinitionBindingMap type exposes the following members.

Methods

Name | Description
Clear | Removes every binding from the map, rendering it empty.
Contains | Tests for the existence of a definition within the map.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a binding with the specified definition from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified binding with the specified definition into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace