Revit 2010 API
Application..::.NewTypeBinding Method (CategorySet)
Application Class See Also
Creates a new type binding object containing the categories passed as a parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TypeBinding NewTypeBinding(
    CategorySet categorySet
)
Visual Basic (Declaration)
Public Function NewTypeBinding ( _
    categorySet As CategorySet _
) As TypeBinding
Visual C++
public:
TypeBinding^ NewTypeBinding(
    CategorySet^ categorySet
)

Parameters

categorySet
Type: Autodesk.Revit..::.CategorySet
A set of categories that will be added to the binding.

Return Value

Returns a new type binding object.

Remarks

Type binding objects are used for attaching shared parameter definitions to a type within a category.

See Also

Application Class
NewTypeBinding Overload
Autodesk.Revit.Creation Namespace