Revit 2010 API
BoundarySegmentArray..::.Insert Method
BoundarySegmentArray Class See Also
Insert the specified boundary segment into the array.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    BoundarySegment item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As BoundarySegment, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    BoundarySegment^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Areas..::.BoundarySegment
The boundary segment to be inserted into the array.
index
Type: System..::.Int32
The boundary segment will be inserted before this index.

Return Value

Returns whether the boundary segment was inserted into the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.Areas Namespace