Revit 2010 API
ElectricalSetting..::.AddVoltageType Method
ElectricalSetting Class See Also
Add a new type definition of voltage into project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public VoltageType AddVoltageType(
    string name,
    double actualValue,
    double minValue,
    double maxValue
)
Visual Basic (Declaration)
Public Function AddVoltageType ( _
    name As String, _
    actualValue As Double, _
    minValue As Double, _
    maxValue As Double _
) As VoltageType
Visual C++
public:
VoltageType^ AddVoltageType(
    String^ name,
    double actualValue,
    double minValue,
    double maxValue
)

Parameters

name
Type: System..::.String
Specify voltage type name
actualValue
Type: System..::.Double
Specify actual value of voltage type.
minValue
Type: System..::.Double
Specify acceptable minimum value of the voltage type.
maxValue
Type: System..::.Double
Specify acceptable maximum value of the voltage type.

Return Value

New added voltage type object.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace