Revit 2010 API
Form..::.AddEdge Method (Reference, Double, Reference, Double)
Form Class See Also
Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddEdge(
    Reference startEdgeReference,
    double startParam,
    Reference endEdgeReference,
    double endParam
)
Visual Basic (Declaration)
Public Sub AddEdge ( _
    startEdgeReference As Reference, _
    startParam As Double, _
    endEdgeReference As Reference, _
    endParam As Double _
)
Visual C++
public:
void AddEdge(
    Reference^ startEdgeReference,
    double startParam,
    Reference^ endEdgeReference,
    double endParam
)

Parameters

startEdgeReference
Type: Autodesk.Revit.Geometry..::.Reference
The geometry reference of start edge
startParam
Type: System..::.Double
The param on start edge to specify the location.
endEdgeReference
Type: Autodesk.Revit.Geometry..::.Reference
The geometry reference of end edge
endParam
Type: System..::.Double
The param on end edge to specify the location.

See Also

Form Class
AddEdge Overload
Autodesk.Revit.Elements Namespace