Revit 2010 API
HostedSweep Members
HostedSweep Class Constructors Methods Properties See Also

The HostedSweep type exposes the following members.

Constructors

Name | Description
HostedSweep | For Internal Use Only.

Methods

Name | Description
AddSegment | Add segments to the hosted sweep object.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEndPointParameter | Retrieve segment's start point or end point parameter.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HorizontalFlip | Flip the hosted sweep object along horizontal line.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
RemoveSegment | Remove segments from the hosted sweep object.
SetEndPointParameter | Set segment's start point or end point parameter.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalFlip | Flip the hosted sweep object along vertical line.

Properties

Name | Description
Angle | Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian).
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing. (Inherited from Element.)
HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object.
HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | Retrieve the length of the hosted sweep object.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns a human readable name for the Element. (Inherited from Element.)
ObjectType | Returns the instance type of this object. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceCurve | Retrieve the curve on which the hosted sweep object's segment is created on the corresponding.
SimilarObjectTypes | Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object.
VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace