Revit 2010 API
ReferencePoint..::.SetCoordinateSystem Method
ReferencePoint Class See Also Send Feedback
The position and orientation of the ReferencePoint.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetCoordinateSystem(
    Transform coordinateSystem
)
Visual Basic (Declaration)
Public Sub SetCoordinateSystem ( _
    coordinateSystem As Transform _
)
Visual C++
public:
void SetCoordinateSystem(
    Transform^ coordinateSystem
)

Parameters

coordinateSystem
Type: Autodesk.Revit.Geometry..::.Transform

Remarks

The position of the point is given by CoordinateSystem.Origin, and the orientation is specified by the three unit vectors CoordinateSystem.BasisX, BasisY, BasisZ. The basis vectors must be unit length and mutually perpendicular. Whenever the Reference property is not null, changing the CoordinateSystem property has a compound effect. First the point is moved to the specified location. Then the point is moved to conform to its Reference, by the shortest possible distance.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when coordinateSystem does not specify an orthonormal basis.
System..::.InvalidOperationException | Thrown when CoordinateSystem is set while the Reference property is not null, and the ReferencePoint is unable to move to the new location.

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace

SetPointElementReference Method

[image]