Revit 2010 API
AnalyticalModelFrame Properties
AnalyticalModelFrame Class See Also Send Feedback

The AnalyticalModelFrame type exposes the following members.

Properties

Name | Description
Curve | Provides access to Structural Framing Analytical Model.
Curves | Returns curves that define the Analytical Model of the associated Element.
Profile | This property will return an object that represents a cross section of the beam or column and a curve along which the profile is swept.
RigidLink | Provides access to Rigid Links component of Structural Framing Element.
SupportData | Provides access to the Support Data for this floor.

See Also

AnalyticalModelFrame Class
Autodesk.Revit.Structural Namespace

Curve Property

[image]