Revit 2010 API
GenericForm..::.IsSolid Property
GenericForm Class See Also Send Feedback
Identifies if the GenericForm is a solid or a void element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsSolid { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSolid As Boolean
Visual C++
public:
property bool IsSolid {
    bool get ();
}

Field Value

True if the form is a solid, false if the solid is a void element.

See Also

GenericForm Class
Autodesk.Revit.Elements Namespace

Name Property

[image]