Revit 2010 API
HostObjAttributes Class
Members See Also Send Feedback
An object that represents characteristics of several kinds of type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class HostObjAttributes : Symbol
Visual Basic (Declaration)
Public Class HostObjAttributes _
    Inherits Symbol
Visual C++
public ref class HostObjAttributes : public Symbol

Remarks

This object provides access to structural layering components for any object derived from it, such as wall types and floor types.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.HostObjAttributes
Autodesk.Revit.Symbols..::.ContFootingType
Autodesk.Revit.Symbols..::.CurtainSystemType
Autodesk.Revit.Symbols..::.FloorType
Autodesk.Revit.Symbols..::.HostedSweepType
Autodesk.Revit.Symbols..::.RoofType
Autodesk.Revit.Symbols..::.WallType

See Also

HostObjAttributes Members
Autodesk.Revit.Symbols Namespace

HostObjAttributes Members

[image] [image]