Revit 2010 API
BoundaryConditions Class
Members Example See Also Send Feedback
An object that represents a force applied across an area.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BoundaryConditions : Element
Visual Basic (Declaration)
Public Class BoundaryConditions _
    Inherits Element
Visual C++
public ref class BoundaryConditions : public Element

Examples

CopyC#
public void GetInfo_BoundaryConditions(BoundaryConditions boundaryConditions)
{
    string message = "BoundaryConditions : ";

    Parameter param = boundaryConditions.get_Parameter(BuiltInParameter.BOUNDARY_CONDITIONS_TYPE);
    switch (param.AsInteger())
    {
        case 0:
            XYZ point = boundaryConditions.Point;
            message += "\nThis BoundaryConditions is a Point Boundary Conditions.";
            message += "\nLocation point: (" + point.X + ", "
                        + point.Y + ", " + point.Z + ")";
            break;
        case 1:
            message += "\nThis BoundaryConditions is a Line Boundary Conditions.";
            Curve curve = boundaryConditions.get_Curve(0);
            // Get curve start point
            message += "\nLocation Line: start point: (" + curve.get_EndPoint(0).X + ", "
                    + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
            // Get curve end point
            message += ";  end point:(" + curve.get_EndPoint(1).X + ", "
                    + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
            break;
        case 2:
            message += "\nThis BoundaryConditions is an Area Boundary Conditions.";
            for (int i = 0; i < boundaryConditions.NumCurves; i++)
            {
                Autodesk.Revit.Geometry.Curve areaCurve = boundaryConditions.get_Curve(i);
                // Get curve start point
                message += "\nCurve start point:(" + areaCurve.get_EndPoint(0).X + ", "
                     + areaCurve.get_EndPoint(0).Y + ", " + areaCurve.get_EndPoint(0).Z + ")";
                // Get curve end point
                message += "; Curve end point:(" + areaCurve.get_EndPoint(1).X + ", "
                     + areaCurve.get_EndPoint(1).Y + ", " + areaCurve.get_EndPoint(1).Z + ")";
            }
            break;
        default:
            break;
    }

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_BoundaryConditions(ByVal boundaryConditions As Autodesk.Revit.Elements.BoundaryConditions)
    Dim message As String = "BoundaryConditions : "

    Dim param As Parameter = boundaryConditions.Parameter(BuiltInParameter.BOUNDARY_CONDITIONS_TYPE)
    Select Case param.AsInteger()
        Case 0
            Dim point As Autodesk.Revit.Geometry.XYZ = boundaryConditions.Point
            message += vbLf & "This BoundaryConditions is a Point Boundary Conditions."
            message += ((vbLf & "Location point: (" & point.X & ", ") + point.Y & ", ") + point.Z & ")"
            Exit Select
        Case 1
            message += vbLf & "This BoundaryConditions is a Line Boundary Conditions."
            Dim curve As Curve = boundaryConditions.Curve(0)
            ' Get curve start point
            message += ((vbLf & "Location Line: start point: (" & curve.EndPoint(0).X & ", ") + curve.EndPoint(0).Y & ", ") + curve.EndPoint(0).Z & ")"
            ' Get curve end point
            message += (("; end point:(" & curve.EndPoint(1).X & ", ") + curve.EndPoint(1).Y & ", ") + curve.EndPoint(1).Z & ")"
            Exit Select
        Case 2
            message += vbLf & "This BoundaryConditions is an Area Boundary Conditions."
            For i As Integer = 0 To boundaryConditions.NumCurves - 1
                Dim areaCurve As Autodesk.Revit.Geometry.Curve = boundaryConditions.Curve(i)
                ' Get curve start point
                message += ((vbLf & "Curve start point:(" & areaCurve.EndPoint(0).X & ", ") + areaCurve.EndPoint(0).Y & ", ") + areaCurve.EndPoint(0).Z & ")"
                ' Get curve end point
                message += (("; Curve end point:(" & areaCurve.EndPoint(1).X & ", ") + areaCurve.EndPoint(1).Y & ", ") + areaCurve.EndPoint(1).Z & ")"
            Next
            Exit Select
        Case Else
            Exit Select
    End Select

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.BoundaryConditions

See Also

BoundaryConditions Members
Autodesk.Revit.Elements Namespace

BoundaryConditions Members

[image] [image]