Revit 2010 API
AnalyticalModelProfile..::.SweptProfile Property
AnalyticalModelProfile Class See Also Send Feedback
Returns an object that describes the profile that is swept along the driving curve.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Profile SweptProfile { get; }
Visual Basic (Declaration)
Public ReadOnly Property SweptProfile As Profile
Visual C++
public:
property Profile^ SweptProfile {
    Profile^ get ();
}

Return Value

A geometric profile object.

Remarks

The profile is swept perpendicular to the driving curve.

See Also

AnalyticalModelProfile Class
Autodesk.Revit.Structural Namespace

AnalyticalModelWall Class

[image]