Revit 2010 API
Selection..::.WindowSelect Method
Selection Class Example See Also Send Feedback
Allows the user to select elements by a rectangle.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool WindowSelect()
Visual Basic (Declaration)
Public Function WindowSelect As Boolean
Visual C++
public:
bool WindowSelect()

Return Value

True if the user selected one or more elements, false if the user selected elsewhere in the UI

Remarks

Newly selected elements will be added to the active set of selected elements.

Examples

CopyC#
int selectionCount = choices.Elements.Size;
// Choose objects from Revit.
bool hasPickSome = choices.WindowSelect();
if (true == hasPickSome)
{
    int newSelectionCount = choices.Elements.Size;
    string prompt = string.Format("{0} elements added to Selection.", newSelectionCount - selectionCount);
    MessageBox.Show(prompt, "Revit");
}
CopyVB.NET
Dim selectionCount As Integer = choices.Elements.Size
' Choose objects from Revit.
Dim hasPickSome As Boolean = choices.WindowSelect()
If True = hasPickSome Then
    Dim newSelectionCount As Integer = choices.Elements.Size
    Dim prompt As String = String.Format("{0} elements added to Selection.", newSelectionCount - selectionCount)
    MessageBox.Show(prompt, "Revit")
End If

See Also

Selection Class
Autodesk.Revit Namespace

Selection Properties

[image] [image]