Revit 2010 API
Document..::.Export Method (String, String, View3D, ViewPlan, BuildingSiteExportOptions)
Document Class See Also Send Feedback
Exports the document in the format of Civil Engineering design applications.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    View3D view,
    ViewPlan grossAreaPlan,
    BuildingSiteExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    view As View3D, _
    grossAreaPlan As ViewPlan, _
    options As BuildingSiteExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    View3D^ view,
    ViewPlan^ grossAreaPlan,
    BuildingSiteExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file will be exported. The folder must exist.
name
Type: System..::.String
The name for the exported civil file. If nullptr or empty, automatic naming will be used."
view
Type: Autodesk.Revit.Elements..::.View3D
3D View to be exported. If nullptr or empty, the active view will be exported. If the active view is not a 3D view, an ArgumentException will be thrown.
grossAreaPlan
Type: Autodesk.Revit.Elements..::.ViewPlan
All the areas on the view plan will be exported, it must be 'Gross Building' area plan. It must not be null. To check whether its area scheme is Gross Building, use IsGrossBuildingArea property of AreaScheme.
options
Type: Autodesk.Revit..::.BuildingSiteExportOptions
Various options applicable to the format of Civil Engineering design applications. If nullptr, all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

See Also

Document Class
Export Overload
Autodesk.Revit Namespace

FindReferencesByDirection Method

[image]