Revit 2010 API
AssetProperty..::.GetTypeName Method
AssetProperty Class See Also Send Feedback
Get the name of the AssetProperty

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static string GetTypeName(
    AssetPropertyType type
)
Visual Basic (Declaration)
Public Shared Function GetTypeName ( _
    type As AssetPropertyType _
) As String
Visual C++
public:
static String^ GetTypeName(
    AssetPropertyType type
)

Parameters

type
Type: Autodesk.Revit.Enums..::.AssetPropertyType

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when type is AssetPropertyType::APT_Unknown or AssetPropertyType::APT_Last.

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace

AssetProperty Properties

[image] [image]