Revit 2010 API
LightingFixture Class
Members See Also Send Feedback
Provides access to the Lighting Fixture in Autodesk Revit MEP.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LightingFixture : MEPModel
Visual Basic (Declaration)
Public Class LightingFixture _
    Inherits MEPModel
Visual C++
public ref class LightingFixture : public MEPModel

Remarks

The Lighting Fixture object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.MEPModel
Autodesk.Revit.MEP..::.LightingFixture

See Also

LightingFixture Members
Autodesk.Revit.MEP Namespace

LightingFixture Members

[image] [image]