Revit 2010 API
GeometryObjectArray..::.Insert Method
GeometryObjectArray Class See Also Send Feedback
Insert the specified geometry object into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    GeometryObject item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As GeometryObject, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    GeometryObject^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.GeometryObject
The geometry object to be inserted into the array.
index
Type: System..::.Int32
The geometry object will be inserted before this index.

Return Value

Returns whether the geometry object was inserted into the array.

See Also

GeometryObjectArray Class
Autodesk.Revit.Geometry Namespace

ReverseIterator Method

[image]