Revit 2010 API
ItemFactoryBase..::.NewAnnotationSymbol Method
ItemFactoryBase Class See Also Send Feedback
Add a new instance of an Annotation Symbol into the Autodesk Revit document, using a location and a symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnnotationSymbol NewAnnotationSymbol(
    XYZ location,
    AnnotationSymbolType annotationSymbolType,
    View specView
)
Visual Basic (Declaration)
Public Function NewAnnotationSymbol ( _
    location As XYZ, _
    annotationSymbolType As AnnotationSymbolType, _
    specView As View _
) As AnnotationSymbol
Visual C++
public:
AnnotationSymbol^ NewAnnotationSymbol(
    XYZ^ location,
    AnnotationSymbolType^ annotationSymbolType,
    View^ specView
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the annotation symbol is to be placed.
annotationSymbolType
Type: Autodesk.Revit.Symbols..::.AnnotationSymbolType
A annotation symbol type object that represents the type of the instance that is to be inserted.
specView
Type: Autodesk.Revit.Elements..::.View
a 2D view which display the annotation symbol.

Return Value

If creation was successful then an instance to the new object is returned, otherwise Nothing.

Remarks

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace

NewDetailCurve Method

[image]