Revit 2010 API
Document..::.NewCurtainSystem Method (ReferenceArray, CurtainSystemType)
Document Class See Also Send Feedback
Creates a new CurtainSystem element from a set of face references.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewCurtainSystem(
    ReferenceArray faces,
    CurtainSystemType curtainSystemType
)
Visual Basic (Declaration)
Public Function NewCurtainSystem ( _
    faces As ReferenceArray, _
    curtainSystemType As CurtainSystemType _
) As ElementSet
Visual C++
public:
ElementSet^ NewCurtainSystem(
    ReferenceArray^ faces,
    CurtainSystemType^ curtainSystemType
)

Parameters

faces
Type: Autodesk.Revit.Geometry..::.ReferenceArray
The faces new CurtainSystem will be created on.
curtainSystemType
Type: Autodesk.Revit.Symbols..::.CurtainSystemType
The Type of CurtainSystem to be created.

Return Value

A set of CurtainSystems will be returned when the operation succeeds.

Remarks

The faces can belong to different masses or generic models. The number of CurtainSystems will be equal to the number of masses and generic models.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown in following cases: The input argument faces or curtainSystemType is null. The size of faces is zero.
System..::.InvalidOperationException | Thrown when the CurtainSystem cannot be created, for example, the input faces don't belong to same mass or generic model. Or regenerate fails.

See Also

Document Class
NewCurtainSystem Overload
Autodesk.Revit.Creation Namespace

NewDimension Method

[image] [image]