Revit 2010 API
Grid Class
Members Example See Also Send Feedback
Represents a single grid line within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Grid : Element
Visual Basic (Declaration)
Public Class Grid _
    Inherits Element
Visual C++
public ref class Grid : public Element

Remarks

Grid lines can either be curved or straight. The Grid object is derived from the Element object and as such contains all the properties and methods of that object. The inherited Name property can be used to retrieve the contents of the grid lines bubble.

Examples

CopyC#
public void GetInfo_Grid(Grid grid)
{
    string message = "Grid : ";

    // Show IsCurved property
    message += "\nIf grid is Arc : " + grid.IsCurved;

    // Show Curve information
    Autodesk.Revit.Geometry.Curve curve = grid.Curve;
    if (grid.IsCurved)
    {
        // if the curve is an arc, give center and radius information
        Autodesk.Revit.Geometry.Arc arc = curve as Autodesk.Revit.Geometry.Arc;
        message += "\nArc's radius: " + arc.Radius;
        message += "\nArc's center:  (" + XYZToString(arc.Center);
    }
    else
    {
        // if the curve is a line, give length information
        Autodesk.Revit.Geometry.Line line = curve as Autodesk.Revit.Geometry.Line;
        message += "\nLine's Length: " + line.Length;
    }
    // Get curve start point
    message += "\nStart point: " + XYZToString(curve.get_EndPoint(0));
    // Get curve end point
    message += "; End point: " + XYZToString(curve.get_EndPoint(0));

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}

// output the point's three coordinates
string XYZToString(Autodesk.Revit.Geometry.XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
CopyVB.NET
Public Sub GetInfo_Grid(ByVal grid As Autodesk.Revit.Elements.Grid)
    Dim message As String = "Grid : "

    ' Show IsCurved property
    message += vbLf & "If grid is Arc : " & grid.IsCurved

    ' Show Curve information
    Dim curve As Autodesk.Revit.Geometry.Curve = grid.Curve
    If grid.IsCurved Then
        ' if the curve is an arc, give center and radius information
        Dim arc As Autodesk.Revit.Geometry.Arc = TryCast(curve, Autodesk.Revit.Geometry.Arc)
        message += vbLf & "Arc's radius: " & arc.Radius
        message += vbLf & "Arc's center: (" & XYZToString(arc.Center)
    Else
        ' if the curve is a line, give length information
        Dim line As Autodesk.Revit.Geometry.Line = TryCast(curve, Autodesk.Revit.Geometry.Line)
        message += vbLf & "Line's Length: " & line.Length
    End If
    ' Get curve start point
    message += vbLf & "Start point: " & XYZToString(curve.EndPoint(0))
    ' Get curve end point
    message += "; End point: " & XYZToString(curve.EndPoint(0))

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

' output the point's three coordinates
Private Function XYZToString(ByVal point As Autodesk.Revit.Geometry.XYZ) As String
    Return (("(" & point.X & ", ") + point.Y & ", ") + point.Z & ")"
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Grid

See Also

Grid Members
Autodesk.Revit.Elements Namespace

Grid Members

[image] [image]