Revit 2010 API
Filter..::.NewInstanceUsageFilter Method
Filter Class See Also Send Feedback
Creates an InstanceUsageFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public InstanceUsageFilter NewInstanceUsageFilter(
    InstanceUsage instanceUsage
)
Visual Basic (Declaration)
Public Function NewInstanceUsageFilter ( _
    instanceUsage As InstanceUsage _
) As InstanceUsageFilter
Visual C++
public:
InstanceUsageFilter^ NewInstanceUsageFilter(
    InstanceUsage instanceUsage
)

Parameters

instanceUsage
Type: Autodesk.Revit.Structural.Enums..::.InstanceUsage
Filter elements by the instance usage.

Return Value

Returns a new instance usage filter object with given instance usage.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace

NewLogicAndFilter Method

[image]