Revit 2010 API
FamilyInstance..::.FromRoom Property
FamilyInstance Class See Also Send Feedback
The room from which the door is opened at the last phase of the project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Room FromRoom { get; }
Visual Basic (Declaration)
Public ReadOnly Property FromRoom As Room
Visual C++
public:
property Room^ FromRoom {
    Room^ get ();
}

Remarks

When current familyinstance is neither door nor window, this property will always return null.

See Also

FamilyInstance Class
FromRoom Overload
Autodesk.Revit.Elements Namespace

FromRoom Property (Phase)

[image]