Revit 2010 API
XYZ Constructor (Double, Double, Double)
XYZ Class See Also Send Feedback
Creates object with supplied values.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ(
    double x,
    double y,
    double z
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Double, _
    y As Double, _
    z As Double _
)
Visual C++
public:
XYZ(
    double x,
    double y,
    double z
)

Parameters

x
Type: System..::.Double
The first coordinate.
y
Type: System..::.Double
The second coordinate.
z
Type: System..::.Double
The third coordinate.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when setting an infinite number to the X, Y or Z property.

See Also

XYZ Class
XYZ Overload
Autodesk.Revit.Geometry Namespace

XYZ Methods

[image] [image]