Revit 2010 API
BarDescription..::.HookType Property
BarDescription Class See Also Send Feedback
Retrieves the Rebar Hook Type property of a Bar Description.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarHookType HookType[
    int end
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property HookType ( _
    end As Integer _
) As RebarHookType
Visual C++
public:
property RebarHookType^ HookType[int end] {
    RebarHookType^ get (int end);
}

Parameters

end
Type: System..::.Int32
Which end of the bar: 0 or 1.

See Also

BarDescription Class
Autodesk.Revit.Structural Namespace

Layer Property

[image]