Revit 2010 API
Document..::.FamilyCreate Property
Document Class See Also Send Feedback
An object that can be used to create new instances of Autodesk Revit API elements within a family document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyItemFactory FamilyCreate { get; }
Visual Basic (Declaration)
Public ReadOnly Property FamilyCreate As FamilyItemFactory
Visual C++
public:
property FamilyItemFactory^ FamilyCreate {
    FamilyItemFactory^ get ();
}

Field Value

This object is used to create new instances of family elements within the Autodesk Revit API, such as Extrusion or Reference lines.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the current document is project document.

See Also

Document Class
Autodesk.Revit Namespace

FamilyManager Property

[image]