Revit 2010 API
Connector..::.AssignedPipeLossMethod Property
Connector Class See Also Send Feedback
The pipe loss method of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeLossMethodType AssignedPipeLossMethod { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedPipeLossMethod As PipeLossMethodType
Visual C++
public:
property PipeLossMethodType AssignedPipeLossMethod {
    PipeLossMethodType get ();
}

Remarks

Assigned duct pipe loss method may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::PipeConnector.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
System..::.InvalidOperationException | Thrown on failure to get pipe loss method.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

AssignedPressureDrop Property

[image]