Revit 2010 API
Form..::.ScaleProfile Method
Form Class See Also Send Feedback
Scale a profile of the form, by a specified origin and scale factor.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ScaleProfile(
    int profileIndex,
    double factor,
    XYZ origin
)
Visual Basic (Declaration)
Public Sub ScaleProfile ( _
    profileIndex As Integer, _
    factor As Double, _
    origin As XYZ _
)
Visual C++
public:
void ScaleProfile(
    int profileIndex,
    double factor,
    XYZ^ origin
)

Parameters

profileIndex
Type: System..::.Int32
Index to specify the profile.
factor
Type: System..::.Double
The scale factor, it should be large than zero.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The origin where scale happens.

See Also

Form Class
Autodesk.Revit.Elements Namespace

ScaleSubElement Method

[image]