Revit 2010 API
Parameter..::.Set Method (ElementId%)
Parameter Class See Also Send Feedback
Sets the parameter to a new element id.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Set(
    ref ElementId value
)
Visual Basic (Declaration)
Public Function Set ( _
    ByRef value As ElementId _
) As Boolean
Visual C++
public:
bool Set(
    ElementId% value
)

Parameters

value
Type: Autodesk.Revit..::.ElementId %
The new element id to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as an ElementId.

See Also

Parameter Class
Set Overload
Autodesk.Revit Namespace

Set Method (Double)

[image]