Revit 2010 API
Element..::.CanBeHidden Method
Element Class See Also Send Feedback
Indicates if the element can be hidden in the view.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool CanBeHidden(
    View pView
)
Visual Basic (Declaration)
Public Function CanBeHidden ( _
    pView As View _
) As Boolean
Visual C++
public:
bool CanBeHidden(
    View^ pView
)

Parameters

pView
Type: Autodesk.Revit.Elements..::.View

Return Value

If the element is not permitted to be hidden, false is returned.

Remarks

See discussion for some types of elements which may not be hidden.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when argument is null.

See Also

Element Class
Autodesk.Revit Namespace

GetDividedSurfaceData Method

[image]