Revit 2010 API
Application..::.OpenDocumentFile Method (String, PostedErrorArray)
Application Class See Also Send Feedback
Opens a document from disk.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Document OpenDocumentFile(
    string fileName,
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Overridable Function OpenDocumentFile ( _
    fileName As String, _
    postedErrors As PostedErrorArray _
) As Document
Visual C++
public:
virtual Document^ OpenDocumentFile(
    String^ fileName,
    PostedErrorArray^ postedErrors
)

Parameters

fileName
Type: System..::.String
The file to be opened.
postedErrors
Type: Autodesk.Revit..::.PostedErrorArray
Would contain list of failures posted during the process.

Remarks

This method corresponds to the File->Open... menu command.

The 'postedErrors' parameter is used only when running Revit in UI-less mode.

Exceptions

Exception | Condition
System..::.ArgumentException | if 'fileName' is a null object or an empty string.
System..::.InvalidOperationException | if can not open a file.

See Also

Application Class
OpenDocumentFile Overload
Autodesk.Revit Namespace

OpenSharedParameterFile Method

[image]