Revit 2010 API
ModelCurve..::.SetVisibility Method
ModelCurve Class See Also Send Feedback
Sets the visibility for the model curve in a family document.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic (Declaration)
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit..::.FamilyElementVisibility

Remarks

The visibility of the model curve geometry can be changed for different types of views and detail levels in the family document.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when visibility is null.
System..::.InvalidOperationException | Thrown when regeneration failed, or the model curve is in a project document.

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace

ModelCurve Properties

[image] [image]