Revit 2010 API
RibbonPanel..::.AddPulldownButton Method
RibbonPanel Class See Also Send Feedback
Adds a PulldownButton to the panel.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PulldownButton AddPulldownButton(
    string name,
    string text
)
Visual Basic (Declaration)
Public Function AddPulldownButton ( _
    name As String, _
    text As String _
) As PulldownButton
Visual C++
public:
PulldownButton^ AddPulldownButton(
    String^ name,
    String^ text
)

Parameters

name
Type: System..::.String
The name of the button.
text
Type: System..::.String
The text of the button.

Return Value

The added PulldownButton.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the name or text is null.
System..::.ArgumentException | Thrown when the name or text is empty.

See Also

RibbonPanel Class
Autodesk.Revit Namespace

AddPushButton Method

[image]