Revit 2010 API
Rebar Properties
Rebar Class See Also Send Feedback

The Rebar type exposes the following members.

Properties

Name | Description
ArrayLength | For Rebar with an array layout, return the length of the distribution path.
BarType | Return the type of the rebar.
Curves | The centerline of the Rebar.
DistributionPath | For Rebar with an array layout, return the distribution path (a line).
Host | The element that contains the rebar.
IsShownInFrontOfGeometryInView | Control placement of the rebar graphics in the viewing planes.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
RebarShape | Get/Set the RebarShape associated with the Rebar.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace

ArrayLength Property

[image]