Revit 2010 API
PipeConnector..::.SystemType Property
PipeConnector Class See Also Send Feedback
The system type of the pipe connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeSystemType SystemType { get; set; }
Visual Basic (Declaration)
Public Property SystemType As PipeSystemType
Visual C++
public:
property PipeSystemType SystemType {
    PipeSystemType get ();
    void set (PipeSystemType value);
}

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the input system type is not within the permitted range.

See Also

PipeConnector Class
Autodesk.Revit.MEP Namespace

Width Property

[image]