Revit 2010 API
AssetPropertyType Enumeration
See Also Send Feedback
An enumerate to list AssetProperty Types in Revit.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum AssetPropertyType
Visual Basic (Declaration)
Public Enumeration AssetPropertyType
Visual C++
public enum class AssetPropertyType

Members

Member name | Description
APT_Last |
APT_Reference |
APT_Asset |
APT_Distance |
APT_Time |
APT_String |
APT_Double44 | AssetPropertyDoubleMatrix44.
APT_DoubleArray4d | AssetPropertyDoubleArray4d.
APT_DoubleArray3d | AssetPropertyDoubleArray3d.
APT_DoubleArray2d | AssetPropertyDoubleArray2d.
APT_Double | AssetPropertyDouble.
APT_Float |
APT_Integer |
APT_Enum |
APT_Boolean |
APT_Properties |
APT_Unknown |

See Also

Autodesk.Revit.Enums Namespace

AssetType Enumeration

[image]