Revit 2010 API
MEPSystem..::.Add Method
MEPSystem Class See Also Send Feedback
Add elements into the system and connect them with the system using given connectors.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Add(
    ConnectorSet connectors
)
Visual Basic (Declaration)
Public Overridable Sub Add ( _
    connectors As ConnectorSet _
)
Visual C++
public:
virtual void Add(
    ConnectorSet^ connectors
)

Parameters

connectors
Type: Autodesk.Revit.MEP..::.ConnectorSet
Connectors which are used to connect with the system.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument connectors is null, or any connector in that collection is null.
System..::.ArgumentException | Throw when any of the input connectors have been already used, or when they don't share the same domain or system type as the system.
System..::.InvalidOperationException | Thrown when the operation failed.

See Also

MEPSystem Class
Autodesk.Revit.MEP Namespace

Remove Method

[image]