Revit 2010 API
Curve..::.IsInside Method (Double)
Curve Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsInside(
    double parameter
)
Visual Basic (Declaration)
Public Function IsInside ( _
    parameter As Double _
) As Boolean
Visual C++
public:
bool IsInside(
    double parameter
)

Parameters

parameter
Type: System..::.Double
The raw curve parameter to be evaluated.

Return Value

True if the parameter is within the bounds, otherwise false.

Remarks

Always returns true if this curve is unbound.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when the specified parameter is infinite.

See Also

Curve Class
IsInside Overload
Autodesk.Revit.Geometry Namespace

IsInside Method (Double, Int32)

[image]