Revit 2010 API
SpacingRule..::.Distance Property
SpacingRule Class See Also Send Feedback
The exact distance between layout lines.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Distance { get; set; }
Visual Basic (Declaration)
Public Property Distance As Double
Visual C++
public:
property double Distance {
    double get ();
    void set (double value);
}

Remarks

This property is only available when Layout is equal to FixedDistance, MaximumSpacing, or MinimumSpacing. Must be a positive value less than 30000'.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the Layout property is None or FixedNumber.

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace

GridlinesRotation Property

[image]