Revit 2010 API
FamilyElementVisibility Class
Members Example See Also Send Feedback
Provides access to the visibility parameters of family elements in family document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FamilyElementVisibility : APIObject
Visual Basic (Declaration)
Public Class FamilyElementVisibility _
    Inherits APIObject
Visual C++
public ref class FamilyElementVisibility : public APIObject

Examples

CopyC#
public void CreateAndSetVisibility(Autodesk.Revit.Document familyDocument, SketchPlane sketchPlane)
{
    // create a new ModelCurve in the family document
    XYZ p0 = new XYZ(1, 1, 0);
    XYZ p1 = new XYZ(5, 1, 0);
    Line line1 = familyDocument.Application.Create.NewLineBound(p0, p1);

    ModelCurve modelCurve1 = familyDocument.FamilyCreate.NewModelCurve(line1, sketchPlane);

    // create a new ModelText along ModelCurve line
    ModelText text = familyDocument.FamilyCreate.NewModelText("Hello World", null, sketchPlane, p0, Autodesk.Revit.Enums.HorizontalAlign.Center, 0.1);

    // set visibility for text
    FamilyElementVisibility textVisibility = new FamilyElementVisibility(FamilyElementVisibilityType.Model);
    textVisibility.IsShownInTopBottom = false;
    text.SetVisibility(textVisibility);

    // set visibility for line
    FamilyElementVisibility curveVisibility = new FamilyElementVisibility(FamilyElementVisibilityType.Model);
    curveVisibility.IsShownInCoarse = false;
    modelCurve1.SetVisibility(curveVisibility);

}
CopyVB.NET
Public Sub CreateAndSetVisibility(ByVal familyDocument As Autodesk.Revit.Document, ByVal sketchPlane As Autodesk.Revit.Elements.SketchPlane)
    ' create a new ModelCurve in the family document
    Dim p0 As New Autodesk.Revit.Geometry.XYZ(1, 1, 0)
    Dim p1 As New Autodesk.Revit.Geometry.XYZ(5, 1, 0)
    Dim line1 As Line = familyDocument.Application.Create.NewLineBound(p0, p1)

    Dim modelCurve1 As ModelCurve = familyDocument.FamilyCreate.NewModelCurve(line1, sketchPlane)

    ' create a new ModelText along ModelCurve line
    Dim text As ModelText = familyDocument.FamilyCreate.NewModelText("Hello World", Nothing, sketchPlane, p0, Autodesk.Revit.Enums.HorizontalAlign.Center, 0.1)

    ' set visibility for text
    Dim textVisibility As New FamilyElementVisibility(FamilyElementVisibilityType.Model)
    textVisibility.IsShownInTopBottom = False
    text.SetVisibility(textVisibility)

    ' set visibility for line
    Dim curveVisibility As New FamilyElementVisibility(FamilyElementVisibilityType.Model)
    curveVisibility.IsShownInCoarse = False
    modelCurve1.SetVisibility(curveVisibility)

End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.FamilyElementVisibility

See Also

FamilyElementVisibility Members
Autodesk.Revit Namespace

FamilyElementVisibility Members

[image] [image]