Revit 2010 API
Element Class
Members See Also Send Feedback
Supports all classes that are persistent within the Autodesk Revit project providing low-level services to derived classes.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Element : APIObject
Visual Basic (Declaration)
Public Class Element _
    Inherits APIObject
Visual C++
public ref class Element : public APIObject

Remarks

The Element object is base class for all elements that can persist inside the Autodesk Revit project database. Element objects can be retrieved from the Document.Element or Document.Elements properties.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Areas..::.AreaScheme
Autodesk.Revit.Elements..::.Alignment
Autodesk.Revit.Elements..::.AnnotationSymbol
Autodesk.Revit.Elements..::.Area
Autodesk.Revit.Elements..::.AreaReinforcement
Autodesk.Revit.Elements..::.AreaReinforcementCurve
Autodesk.Revit.Elements..::.AreaTag
Autodesk.Revit.Elements..::.BaseArray
Autodesk.Revit.Elements..::.BasePoint
Autodesk.Revit.Elements..::.BeamSystem
Autodesk.Revit.Elements..::.BoundaryConditions
Autodesk.Revit.Elements..::.CombinableElement
Autodesk.Revit.Elements..::.Control
Autodesk.Revit.Elements..::.CurveElement
Autodesk.Revit.Elements..::.DesignOption
Autodesk.Revit.Elements..::.Dimension
Autodesk.Revit.Elements..::.DividedSurface
Autodesk.Revit.Elements..::.FamilyBase
Autodesk.Revit.Elements..::.FillPattern
Autodesk.Revit.Elements..::.gbXMLParamElem
Autodesk.Revit.Elements..::.GraphicsStyle
Autodesk.Revit.Elements..::.Grid
Autodesk.Revit.Elements..::.Group
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.ImportInstance
Autodesk.Revit.Elements..::.IndependentTag
Autodesk.Revit.Elements..::.Instance
Autodesk.Revit.Elements..::.Level
Autodesk.Revit.Elements..::.LinePattern
Autodesk.Revit.Elements..::.LoadBase
Autodesk.Revit.Elements..::.LoadCase
Autodesk.Revit.Elements..::.LoadCombination
Autodesk.Revit.Elements..::.LoadNature
Autodesk.Revit.Elements..::.LoadUsage
Autodesk.Revit.Elements..::.Material
Autodesk.Revit.Elements..::.ModelText
Autodesk.Revit.Elements..::.Mullion
Autodesk.Revit.Elements..::.Opening
Autodesk.Revit.Elements..::.Panel
Autodesk.Revit.Elements..::.PathReinforcement
Autodesk.Revit.Elements..::.Phase
Autodesk.Revit.Elements..::.PrintSetting
Autodesk.Revit.Elements..::.ProjectInfo
Autodesk.Revit.Elements..::.ProjectUnit
Autodesk.Revit.Elements..::.PropertyLine
Autodesk.Revit.Elements..::.Rebar
Autodesk.Revit.Elements..::.ReferencePlane
Autodesk.Revit.Elements..::.ReferencePoint
Autodesk.Revit.Elements..::.Room
Autodesk.Revit.Elements..::.RoomTag
Autodesk.Revit.Elements..::.SketchBase
Autodesk.Revit.Elements..::.SketchPlane
Autodesk.Revit.Elements..::.Space
Autodesk.Revit.Elements..::.SpaceTag
Autodesk.Revit.Elements..::.TextElement
Autodesk.Revit.Elements..::.TopographySurface
Autodesk.Revit.Elements..::.Truss
Autodesk.Revit.Elements..::.View
Autodesk.Revit.Elements..::.ViewSheetSet
Autodesk.Revit.Elements..::.Zone
Autodesk.Revit.MEP..::.ConduitType
Autodesk.Revit.MEP..::.DuctConnector
Autodesk.Revit.MEP..::.ElectricalConnector
Autodesk.Revit.MEP..::.InsulationType
Autodesk.Revit.MEP..::.MEPSystem
Autodesk.Revit.MEP..::.PipeConnector
Autodesk.Revit.MEP..::.TemperatureRatingType
Autodesk.Revit.MEP..::.WireMaterialType
Autodesk.Revit..::.Symbol

See Also

Element Members
Autodesk.Revit Namespace

Element Members

[image] [image]