Revit 2010 API
Transform..::.Reflection Property
Transform Class Example See Also Send Feedback
The transformation that reflects about the specified plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static Transform Reflection[
    Plane plane
] { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Reflection ( _
    plane As Plane _
) As Transform
Visual C++
public:
static property Transform^ Reflection[Plane^ plane] {
    Transform^ get (Plane^ plane);
}

Parameters

plane
Type: Autodesk.Revit.Geometry..::.Plane
The plane to reflect about.

Examples

CopyC#
private Transform Reflect(ReferencePlane refPlane)
{
    Transform mirTrans = Transform.get_Reflection(refPlane.Plane);

    return mirTrans;
}
CopyVB.NET
Private Function Reflect(ByVal refPlane As ReferencePlane) As Transform
    Dim mirTrans As Transform = Transform.Reflection(refPlane.Plane)

    Return mirTrans
End Function

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the handle of the plane is null.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace

Rotation Property

[image]