Revit 2010 API
DefinitionGroup Class
Members See Also Send Feedback
The DefinitionGroup is a container that is used to hold shared parameter definitions on disk.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DefinitionGroup : APIObject
Visual Basic (Declaration)
Public Class DefinitionGroup _
    Inherits APIObject
Visual C++
public ref class DefinitionGroup : public APIObject

Remarks

Groups are used for logical arrangement of the shared parameters into meaningful sets. Through the DefinitionGroup object new shared parameter definitions can be made.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.DefinitionGroup

See Also

DefinitionGroup Members
Autodesk.Revit.Parameters Namespace

DefinitionGroup Members

[image] [image]