Revit 2010 API
Room Properties
Room Class See Also Send Feedback

The Room type exposes the following members.

Properties

Name | Description
Area | Get the Area of the Room.
BaseOffset | Get or Set the Base Offset of the Room.
Boundary | Returns the boundary of the room.
ClosedShell | Return the closedShell of the Room.
LimitOffset | Get or Set the Limit Offset of the Room.
Location | get a location point object. The point within the location object should be get/set. This is the location of the room within the level. The Z location should be the elevation of the level and not changeable. (Overrides Element..::.Location.)
Name | Get or Set the Name of the room. (Overrides Element..::.Name.)
Number | Get or Set the Number of the Room.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Perimeter | Get the Perimeter of the Room.
UnboundedHeight | Get the Unbounded Height of the Room.
UpperLimit | Get or Set the Upper Limit of the Room.
Volume | Get the Volume of the Room.

See Also

Room Class
Autodesk.Revit.Elements Namespace

Area Property

[image]