Revit 2010 API
Document..::.NewFoundationSlab Method
Document Class See Also Send Feedback
Creates a foundation slab within the project with the given horizontal profile and floor style on the specified level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Floor NewFoundationSlab(
    CurveArray profile,
    FloorType floorType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic (Declaration)
Public Function NewFoundationSlab ( _
    profile As CurveArray, _
    floorType As FloorType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
) As Floor
Visual C++
public:
Floor^ NewFoundationSlab(
    CurveArray^ profile,
    FloorType^ floorType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of planar lines and arcs that represent the horizontal profile of the floor.
floorType
Type: Autodesk.Revit.Symbols..::.FloorType
A floor type to be used by the new floor instead of the default type.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the floor is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the floor is structural in nature.
normal
Type: Autodesk.Revit.Geometry..::.XYZ
A vector that must be perpendicular to the profile which dictates which side of the floor is considered to be upper and down.

Return Value

if successful, a new foundation slab object within the project, otherwise Nothing.

Remarks

The Face formed by profile should be suitable to create floor, otherwise an exception thrown.

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewFoundationWall Method

[image]