Revit 2010 API
Profile Class
Members Example See Also Send Feedback
A geometric profile consisting of a loop of curves.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Profile : GeometryObject
Visual Basic (Declaration)
Public Class Profile _
    Inherits GeometryObject
Visual C++
public ref class Profile : public GeometryObject

Remarks

The profile may be filled.

Examples

CopyC#
public void GetProfile(Element element)
{
    string messageInfo = "Profile : ";
    if (element is FamilyInstance)
    {
        FamilyInstance beam = element as FamilyInstance;
        if (beam.StructuralType == Autodesk.Revit.Structural.Enums.StructuralType.Beam)
        {
            AnalyticalModelFrame modelFrame = beam.AnalyticalModel as AnalyticalModelFrame;
            Autodesk.Revit.Geometry.Curve curve = modelFrame.Curve;
            AnalyticalModelProfile modelProfile = modelFrame.Profile;
            // Get AnalyticalModelFrame swept profile
            Autodesk.Revit.Geometry.Profile profile = modelProfile.SweptProfile;
            // Get AnalyticalModelWall swept profile curves size
            messageInfo += "\nSelection name : " + beam.Name;
            messageInfo += "\nSwept Profile Driving Curve size is " + profile.Curves.Size;
            messageInfo += "\nProfile is filled :  " + profile.Filled;
            if (!profile.IsReadOnly)
            {
                profile.Filled = !profile.Filled;
                messageInfo += "\nProfile is filled after setting:  " + profile.Filled;
            }
            MessageBox.Show(messageInfo, "Revit", MessageBoxButtons.OK);
        }
    }
}
CopyVB.NET
Public Sub GetProfile(ByVal element As Autodesk.Revit.Element)
    Dim messageInfo As String = "Profile : "
    If TypeOf element Is Autodesk.Revit.Elements.FamilyInstance Then
        Dim beam As Autodesk.Revit.Elements.FamilyInstance = TryCast(element, Autodesk.Revit.Elements.FamilyInstance)
        If beam.StructuralType = Autodesk.Revit.Structural.Enums.StructuralType.Beam Then
            Dim modelFrame As AnalyticalModelFrame = TryCast(beam.AnalyticalModel, AnalyticalModelFrame)
            Dim curve As Autodesk.Revit.Geometry.Curve = modelFrame.Curve
            Dim modelProfile As AnalyticalModelProfile = modelFrame.Profile
            ' Get AnalyticalModelFrame swept profile
            Dim profile As Autodesk.Revit.Geometry.Profile = modelProfile.SweptProfile
            ' Get AnalyticalModelWall swept profile curves size
            messageInfo += vbLf & "Selection name : " & beam.Name
            messageInfo += vbLf & "Swept Profile Driving Curve size is " & profile.Curves.Size
            messageInfo += vbLf & "Profile is filled : " & profile.Filled
            If Not profile.IsReadOnly Then
                profile.Filled = Not profile.Filled
                messageInfo += vbLf & "Profile is filled after setting: " & profile.Filled
            End If
            MessageBox.Show(messageInfo, "Revit", MessageBoxButtons.OK)
        End If
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Profile

See Also

Profile Members
Autodesk.Revit.Geometry Namespace

Profile Members

[image] [image]