Revit 2010 API
Element..::.Group Property
Element Class Example See Also Send Feedback
Return to group to which an element belongs. If it is not in a group then this will return Nothing.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Group Group { get; }
Visual Basic (Declaration)
Public ReadOnly Property Group As Group
Visual C++
public:
property Group^ Group {
    Group^ get ();
}

Examples

CopyC#
private void ShowGroupInformation(Autodesk.Revit.Document document, Autodesk.Revit.Element element)
{
    // Get group information for the selected element
    String prompt = null;
    Autodesk.Revit.Elements.Group group = element.Group;
    if (null == group)
    {
        prompt = "The element isn't in any group.";
    }
    else
    {
        prompt = "The element " + element.Id.Value + " is in a group.";
        prompt += "\nThe group id is " + group.Id.Value;
        prompt += "\nThe group's category is " + group.Category.Name;
        prompt += "\nAll group contained element ids are:";
        Autodesk.Revit.ElementArray groupMembers = group.Members;
        foreach (Autodesk.Revit.Element e in groupMembers)
        {
            prompt += "\n\t" + e.Id.Value;
        }
    }

    MessageBox.Show(prompt);
}
CopyVB.NET
Private Sub ShowGroupInformation(ByVal document As Autodesk.Revit.Document, ByVal element As Autodesk.Revit.Element)
    ' Get group information for the selected element
    Dim prompt As String = Nothing
    Dim group As Autodesk.Revit.Elements.Group = element.Group
    If group Is Nothing Then
        prompt = "The element isn't in any group."
    Else
        prompt = "The element " & element.Id.Value & " is in a group."
        prompt += vbLf & "The group id is " & group.Id.Value
        prompt += vbLf & "The group's category is " & group.Category.Name
        prompt += vbLf & "All group contained element ids are:"
        Dim groupMembers As Autodesk.Revit.ElementArray = group.Members
        For Each e As Autodesk.Revit.Element In groupMembers
            prompt += vbLf & vbTab & e.Id.Value
        Next
    End If

    MessageBox.Show(prompt)
End Sub

See Also

Element Class
Autodesk.Revit Namespace

Id Property

[image]