Revit 2010 API
Element..::.Materials Property
Element Class See Also Send Feedback
Get all materials present in the element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialSet Materials { get; }
Visual Basic (Declaration)
Public ReadOnly Property Materials As MaterialSet
Visual C++
public:
property MaterialSet^ Materials {
    MaterialSet^ get ();
}

Remarks

The set will be empty for elements where the HasMaterialQuantities property of the element's Category is false. The set will also be empty for elements whose category supports material quantities (the HasMaterialQuantities property of the element's Category is true), but where the element has not been assigned materials.

See Also

Element Class
Autodesk.Revit Namespace

Name Property

[image]