Revit 2010 API
Wall Properties
Wall Class See Also Send Feedback

The Wall type exposes the following members.

Properties

Name | Description
AnalyticalModel | Retrieves the structural analytical model for this Wall.
CurtainGrid | Get the grid object of a curtain wall
Flipped | Property to test whether the wall orientation is flipped.
Orientation | Provides access to the wall's external face's orientation.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
StructuralUsage | The walls designated structural usage, such as bearing or non bearing.
WallType | Retrieve or change the type of the wall.
Width | Returns the overall thickness of the wall.

See Also

Wall Class
Autodesk.Revit.Elements Namespace

AnalyticalModel Property

[image]