Revit 2010 API
AnalyticalModel Class
Members See Also Send Feedback
Supports all Analytical Models that are persistent within the Autodesk Revit project

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AnalyticalModel : APIObject
Visual Basic (Declaration)
Public Class AnalyticalModel _
    Inherits APIObject
Visual C++
public ref class AnalyticalModel : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Structural..::.AnalyticalModel
Autodesk.Revit.Structural..::.AnalyticalModel3D
Autodesk.Revit.Structural..::.AnalyticalModelFloor
Autodesk.Revit.Structural..::.AnalyticalModelFrame
Autodesk.Revit.Structural..::.AnalyticalModelLocation
Autodesk.Revit.Structural..::.AnalyticalModelProfile
Autodesk.Revit.Structural..::.AnalyticalModelWall

See Also

AnalyticalModel Members
Autodesk.Revit.Structural Namespace

AnalyticalModel Members

[image] [image]