Revit 2010 API
Wall Class
Members Example See Also Send Feedback
Represents all of the different kinds of walls Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Wall : HostObject
Visual Basic (Declaration)
Public Class Wall _
    Inherits HostObject
Visual C++
public ref class Wall : public HostObject

Remarks

The wall object represents all the different kinds of wall in Revit. The WallType property is used to distinguish the type of the wall. The wall object is derived from the Element object and hence it supports all the properties and methods of that object.

Examples

CopyC#
public void GetInfo_Wall(Wall wall)
{
    string message = "Wall : ";
    // Get wall AnalyticalModel type
    AnalyticalModel model = wall.AnalyticalModel;
    if (null != model)
    {
        // For some situation(such as architecture wall or in building version),
        // this property may return null, but if it doesn't return null, it should
        // be AnalyticalModelWall.
        message += "\nWall AnalyticalModel type is : " + model;
        if (!(model is AnalyticalModelWall))
        {
            throw new InvalidCastException();
        }
    }

    wall.flip();
    message += "\nIf wall Flipped : " + wall.Flipped;
    // Get curve start point
    message += "\nWall orientation point is :(" + wall.Orientation.X + ", "
        + wall.Orientation.Y + ", " + wall.Orientation.Z + ")";
    // Get wall StructuralUsage
    message += "\nWall StructuralUsage is : " + wall.StructuralUsage;
    // Get wall type name
    message += "\nWall type name is : " + wall.WallType.Name;
    // Get wall width
    message += "\nWall width is : " + wall.Width;

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_Wall(ByVal wall As Wall)
    Dim message As String = "Wall : "
    ' Get wall AnalyticalModel type
    Dim model As Autodesk.Revit.Structural.AnalyticalModel = wall.AnalyticalModel
    If model IsNot Nothing Then
        ' For some situation(such as architecture wall or in building version),
        ' this property may return null, but if it doesn't return null, it should
        ' be AnalyticalModelWall.
        message += vbLf & "Wall AnalyticalModel type is : " & model.ToString
        If Not (TypeOf model Is AnalyticalModelWall) Then
            Throw New InvalidCastException()
        End If
    End If

    wall.flip()
    message += vbLf & "If wall Flipped : " & wall.Flipped
    ' Get curve start point
    message += ((vbLf & "Wall orientation point is :(" & wall.Orientation.X & ", ") + wall.Orientation.Y & ", ") + wall.Orientation.Z & ")"
    ' Get wall StructuralUsage
    message += vbLf & "Wall StructuralUsage is : " & wall.StructuralUsage
    ' Get wall type name
    message += vbLf & "Wall type name is : " & wall.WallType.Name
    ' Get wall width
    message += vbLf & "Wall width is : " & wall.Width

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.Wall

See Also

Wall Members
Autodesk.Revit.Elements Namespace

Wall Members

[image] [image]