Revit 2010 API
MEPCurve..::.Width Property
MEPCurve Class See Also Send Feedback
The width of the MEP curve.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Width { get; }
Visual Basic (Declaration)
Public ReadOnly Property Width As Double
Visual C++
public:
property double Width {
    double get ();
}

Remarks

This property is used to retrieve the width of the MEP curve.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the MEP curve's shape is not rectangular.

See Also

MEPCurve Class
Autodesk.Revit.MEP Namespace

MEPCurveType Class

[image]