Revit 2010 API
Application..::.ViewActivating Event
Application Class See Also Send Feedback
Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<ViewActivatingEventArgs> ViewActivating
Visual Basic (Declaration)
Public Event ViewActivating As EventHandler(Of ViewActivatingEventArgs)
Visual C++
public:
 event EventHandler<ViewActivatingEventArgs^>^ ViewActivating {
    void add (EventHandler<ViewActivatingEventArgs^>^ value);
    void remove (EventHandler<ViewActivatingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to activate a view of the document.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to 'true'. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may not be modified during this event.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another ViewActivated event will be raised immediately after view activating is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace

ViewPrinted Event

[image]