Revit 2010 API
SlabShapeEditor..::.PickSupport Method
SlabShapeEditor Class See Also Send Feedback
Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void PickSupport(
    Line gLine
)
Visual Basic (Declaration)
Public Sub PickSupport ( _
    gLine As Line _
)
Visual C++
public:
void PickSupport(
    Line^ gLine
)

Parameters

gLine
Type: Autodesk.Revit.Geometry..::.Line
A line from a support element such as a beam.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input line is nullptr.
System..::.ArgumentException | Thrown when the input line is invalid.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace

ResetSlabShape Method

[image]