Revit 2010 API
HostedSweep Properties
HostedSweep Class See Also Send Feedback

The HostedSweep type exposes the following members.

Properties

Name | Description
Angle | Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian).
HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object.
HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object.
Length | Retrieve the length of the hosted sweep object.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
ReferenceCurve | Retrieve the curve on which the hosted sweep object's segment is created on the corresponding.
VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object.
VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace

Angle Property

[image]