Revit 2010 API
RevitEventArgs..::.Cancellable Property
RevitEventArgs Class See Also Send Feedback
Indicates whether an event may be cancelled by an event delegate.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Cancellable { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Cancellable As Boolean
Visual C++
public:
virtual property bool Cancellable {
    bool get ();
}

Remarks

If 'Cancellable' is true, event delegates may cancel the command that was announced by the event. To do so, a delegate would set the 'Cancel' property to 'true'. Typically, post-events (e.g. DocumentPrinted) are not cancellable, while most pre-events (e.g. DocumentPrinting) are cancellable, except for special conditions and situations, such as when the Revit application is being closed or if an event is raised during another event.

See Also

RevitEventArgs Class
Autodesk.Revit.Events Namespace

SynchronizeWithCentralOptions Class

[image]