Revit 2010 API
CurveLoopsProfile Class
Members See Also Send Feedback
Represents a curve loop based profile for sweep or swept blend elements.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CurveLoopsProfile : SweepProfile
Visual Basic (Declaration)
Public Class CurveLoopsProfile _
    Inherits SweepProfile
Visual C++
public ref class CurveLoopsProfile : public SweepProfile

Remarks

Use objects of this type in methods as NewSweep and NewSweptBlend to create the profile.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.SweepProfile
Autodesk.Revit..::.CurveLoopsProfile

See Also

CurveLoopsProfile Members
Autodesk.Revit Namespace

CurveLoopsProfile Members

[image] [image]