Revit 2010 API
Application..::.OpenDocumentFile Method (String)
Application Class See Also Send Feedback
Opens a document from disk.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Document OpenDocumentFile(
    string fileName
)
Visual Basic (Declaration)
Public Overridable Function OpenDocumentFile ( _
    fileName As String _
) As Document
Visual C++
public:
virtual Document^ OpenDocumentFile(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The file to be opened.

Remarks

It is correspond to the File->Open....

Exceptions

Exception | Condition
System..::.ArgumentException | if 'fileName' is a null object or an empty string.
System..::.InvalidOperationException | if can not open a file.

See Also

Application Class
OpenDocumentFile Overload
Autodesk.Revit Namespace

OpenDocumentFile Method (String, PostedErrorArray)

[image]