Revit 2010 API
Document..::.NewViewSheet Method
Document Class Example See Also Send Feedback
Creates a new sheet view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSheet NewViewSheet(
    FamilySymbol titleBlock
)
Visual Basic (Declaration)
Public Function NewViewSheet ( _
    titleBlock As FamilySymbol _
) As ViewSheet
Visual C++
public:
ViewSheet^ NewViewSheet(
    FamilySymbol^ titleBlock
)

Parameters

titleBlock
Type: Autodesk.Revit.Symbols..::.FamilySymbol
The titleblock family symbol to apply to this sheet.

Return Value

The newly created sheet view.

Remarks

Use the TitleBlocks property of Document to choose a titleblock.

Examples

CopyC#
private void CreateSheetView(Autodesk.Revit.Document document, View3D view3D)
{

    // Get an available title block from document
    FamilySymbolSet fsSet = document.TitleBlocks;
    if (fsSet.Size == 0)
    {
        throw new Exception("No title blocks");
    }

    FamilySymbol fs = null;
    foreach (FamilySymbol f in fsSet)
    {
        if (null != f)
        {
            fs = f;
            break;
        }
    }

    // Create a sheet view
    ViewSheet viewSheet = document.Create.NewViewSheet(fs);
    if (null == viewSheet)
    {
        throw new Exception("Failed to create new ViewSheet.");
    }

    // Add passed in view onto the center of the sheet
    UV location = new UV((viewSheet.Outline.Max.U - viewSheet.Outline.Min.U) / 2,
                         (viewSheet.Outline.Max.V - viewSheet.Outline.Min.V) / 2);

    viewSheet.AddView(view3D, location);

    // Print the sheet out
    if (viewSheet.CanBePrinted)
    {
        if (MessageBox.Show("Print the sheet?", "Revit", MessageBoxButtons.YesNo) == DialogResult.Yes)
        {
            viewSheet.Print();
        }
    }
}
CopyVB.NET
Private Sub CreateSheetView(ByVal document As Autodesk.Revit.Document, ByVal view3D As View3D)

    ' Get an available title block from document
    Dim fsSet As FamilySymbolSet = document.TitleBlocks
    If fsSet.Size = 0 Then
        Throw New Exception("No title blocks")
    End If

    Dim fs As Autodesk.Revit.Symbols.FamilySymbol = Nothing
    For Each f As Autodesk.Revit.Symbols.FamilySymbol In fsSet
        If f IsNot Nothing Then
            fs = f
            Exit For
        End If
    Next

    ' Create a sheet view
    Dim viewSheet As ViewSheet = document.Create.NewViewSheet(fs)
    If viewSheet Is Nothing Then
        Throw New Exception("Failed to create new ViewSheet.")
    End If

    ' Add passed in view onto the center of the sheet
    Dim location As New Autodesk.Revit.Geometry.UV((viewSheet.Outline.Max.U - viewSheet.Outline.Min.U) / 2, (viewSheet.Outline.Max.V - viewSheet.Outline.Min.V) / 2)

    viewSheet.AddView(view3D, location)

    ' Print the sheet out
    If viewSheet.CanBePrinted Then
        If MessageBox.Show("Print the sheet?", "Revit", MessageBoxButtons.YesNo) = DialogResult.Yes Then
            viewSheet.Print()
        End If
    End If
End Sub

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewWall Method

[image] [image]