Revit 2010 API
Document..::.IsModifiable Property
Document Class See Also Send Feedback
The document's state of modifiability.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsModifiable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsModifiable As Boolean
Visual C++
public:
property bool IsModifiable {
    bool get ();
}

Field Value

True if the document is currently in a state of accepting modifications, False otherwise.

Remarks

This is not a permanent state such as, for example IsReadOnlyFile. Regardless of the mode a document is opened with, it can sometimes be in a state at which no modifications may be allowed to it. Though this is rather a rare situation, it can happen, most likely during model regeneration or some events. An attempt to modify a non-modifiable document will result in an exception.

See Also

Document Class
Autodesk.Revit Namespace

IsModified Property

[image]