Revit 2010 API
CurtainSystem..::.RemoveCurtainGrid Method
CurtainSystem Class See Also Send Feedback
Remove CurtainGrid from the specified face for the CurtainSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveCurtainGrid(
    Reference face
)
Visual Basic (Declaration)
Public Sub RemoveCurtainGrid ( _
    face As Reference _
)
Visual C++
public:
void RemoveCurtainGrid(
    Reference^ face
)

Parameters

face
Type: Autodesk.Revit.Geometry..::.Reference
The face CurtainGrid will be removed from.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input parameter face is nullptr.
System..::.InvalidOperationException | Thrown when the CurtainGrid cannot be removed from the specified face or regenerate fails.

See Also

CurtainSystem Class
Autodesk.Revit.Elements Namespace

CurtainSystem Properties

[image] [image]