Revit 2010 API
Document..::.GetRoomAtPoint Method (XYZ, Phase)
Document Class See Also Send Feedback
Gets a room containing the point.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Room GetRoomAtPoint(
    XYZ point,
    Phase phase
)
Visual Basic (Declaration)
Public Function GetRoomAtPoint ( _
    point As XYZ, _
    phase As Phase _
) As Room
Visual C++
public:
Room^ GetRoomAtPoint(
    XYZ^ point,
    Phase^ phase
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
Point to be checked.
phase
Type: Autodesk.Revit.Elements..::.Phase
Phase in which the room exists.

Return Value

The room containing the point.

Remarks

If phase is null, it will get the room of the last phase.The first one found will be returned. If there is no room containing the point, it returns null.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the point is nullptr.
System..::.ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.

See Also

Document Class
GetRoomAtPoint Overload
Autodesk.Revit Namespace

GetSpaceAtPoint Method

[image] [image]