Revit 2010 API
UnitType Enumeration
See Also Send Feedback
An enumerate type listing all the Unit types that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum UnitType
Visual Basic (Declaration)
Public Enumeration UnitType
Visual C++
public enum class UnitType

Members

Member name | Description
UT_HVAC_Factor |
UT_HVAC_Area_Divided_By_Heating_Load |
UT_Electrical_Luminance |
UT_Electrical_Luminous_Intensity |
UT_DecSheetLength |
UT_Color_Temperature |
UT_Electrical_Wattage |
UT_Electrical_Efficacy |
UT_Currency |
UT_Piping_Slope |
UT_HVAC_Slope |
UT_WireSize |
UT_HVAC_Area_Divided_By_Cooling_Load |
UT_HVAC_Airflow_Divided_By_Cooling_Load |
UT_HVAC_Airflow_Divided_By_Volume |
UT_HVAC_Heating_Load_Divided_By_Volume |
UT_HVAC_Heating_Load_Divided_By_Area |
UT_HVAC_Heating_Load |
UT_HVAC_Cooling_Load_Divided_By_Volume |
UT_HVAC_Cooling_Load_Divided_By_Area |
UT_HVAC_Cooling_Load |
UT_Slope |
UT_HVAC_Airflow_Density |
UT_HVAC_CoefficientOfHeatTransfer |
UT_HVAC_Viscosity |
UT_Piping_Volume |
UT_AreaForcePerLength |
UT_LinearForceLengthPerAngle |
UT_LinearForcePerLength |
UT_ForceLengthPerAngle |
UT_ForcePerLength |
UT_LinearMomentScale |
UT_LinearMoment |
UT_TemperalExp |
UT_UnitWeight |
UT_Stress |
UT_Piping_Roughness |
UT_PipeSize |
UT_Piping_Viscosity |
UT_Piping_Velocity |
UT_Piping_Temperature |
UT_Piping_Pressure |
UT_Piping_Friction |
UT_Piping_Flow |
UT_Piping_Density |
UT_Electrical_Power_Density |
UT_Electrical_Apparent_Power |
UT_MomentScale |
UT_AreaForceScale |
UT_LinearForceScale |
UT_ForceScale |
UT_Moment |
UT_AreaForce |
UT_LinearForce |
UT_Force |
UT_HVAC_Roughness |
UT_Electrical_Power |
UT_Electrical_Luminous_Flux |
UT_Electrical_Illuminance |
UT_Electrical_Frequency |
UT_Electrical_Potential |
UT_Electrical_Current |
UT_HVAC_HeatGain |
UT_HVAC_CrossSection |
UT_HVAC_DuctSize |
UT_HVAC_Airflow |
UT_HVAC_Velocity |
UT_HVAC_Temperature |
UT_HVAC_Pressure |
UT_HVAC_Power_Density |
UT_HVAC_Power |
UT_HVAC_Friction |
UT_HVAC_Energy |
UT_HVAC_Density |
UT_SiteAngle |
UT_SheetLength |
UT_Number |
UT_Angle |
UT_Volume |
UT_Area |
UT_Length |

See Also

Autodesk.Revit.Enums Namespace

ViewType Enumeration

[image]