Revit 2010 API
Element..::.GetMaterialArea Method
Element Class See Also Send Feedback
Get the area of the given material on this element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double GetMaterialArea(
    Material material
)
Visual Basic (Declaration)
Public Function GetMaterialArea ( _
    material As Material _
) As Double
Visual C++
public:
double GetMaterialArea(
    Material^ material
)

Parameters

material
Type: Autodesk.Revit.Elements..::.Material

Return Value

The area, or 0.0 if the input material is not a member of Materials.

Remarks

This value is calculated by Revit to show in material takeoff schedules. In some cases the value may be approximate.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The input material was null.
System..::.ArgumentException | The material comes from a different document than this element.

See Also

Element Class
Autodesk.Revit Namespace

GetMaterialVolume Method

[image]