Revit 2010 API
ButtonData Class
Members See Also Send Feedback
Base class used to contain information necessary to construct a button in the Ribbon.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ButtonData
Visual Basic (Declaration)
Public Class ButtonData
Visual C++
public ref class ButtonData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.ButtonData
Autodesk.Revit..::.PulldownButtonData
Autodesk.Revit..::.PushButtonData

See Also

ButtonData Members
Autodesk.Revit Namespace

ButtonData Members

[image] [image]