Revit 2010 API
ParameterMap..::.Insert Method
ParameterMap Class See Also Send Feedback
Insert the specified item with the specified key into the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    string key,
    Parameter item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As String, _
    item As Parameter _
) As Boolean
Visual C++
public:
virtual bool Insert(
    String^ key,
    Parameter^ item
)

Parameters

key
Type: System..::.String
The key to be used for inserting the item into the map.
item
Type: Autodesk.Revit..::.Parameter
The item to be inserted into the map.

Return Value

Returns whether the item was inserted into the map.

See Also

ParameterMap Class
Autodesk.Revit Namespace

ReverseIterator Method

[image]