Revit 2010 API
Document..::.NewAreaLoad Method (Element, XYZ, Boolean, AreaLoadType)
Document Class See Also Send Feedback
Creates a new uniform hosted area load with polygonal shape within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AreaLoad NewAreaLoad(
    Element host,
    XYZ force,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic (Declaration)
Public Function NewAreaLoad ( _
    host As Element, _
    force As XYZ, _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad(
    Element^ host,
    XYZ^ force,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

host
Type: Autodesk.Revit..::.Element
The host element (Floor or Wall) of the AreaLoad application.
force
Type: Autodesk.Revit.Geometry..::.XYZ
The 3d area force applied to the first reference point.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.Symbols..::.AreaLoadType
The symbol of the AreaLoad.

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
NewAreaLoad Overload
Autodesk.Revit.Creation Namespace

NewAreaLoad Method (XYZArray, XYZ, Boolean, AreaLoadType)

[image]