Revit 2010 API
LogicAndFilter Class
Members See Also Send Feedback
The LogicAndFilter is used to implement Logic-AND operation of Filters.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LogicAndFilter : Filter
Visual Basic (Declaration)
Public Class LogicAndFilter _
    Inherits Filter
Visual C++
public ref class LogicAndFilter : public Filter

Remarks

This filter represents a combined filter consists of two sub-filters by Logic-AND relationship, use it to filter elements which satisfy both sub-filters.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Filter
Autodesk.Revit..::.LogicAndFilter

See Also

LogicAndFilter Members
Autodesk.Revit Namespace

LogicAndFilter Members

[image] [image]