Revit 2010 API
Application..::.OnDocumentClosed Event
Application Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentClosed event instead. Subscribe to the OnDocumentClosed event to be notified after a document is closed.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentClosed event instead.")]
public event DocumentClosedEventHandler OnDocumentClosed
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentClosed event instead.")> _
Public Event OnDocumentClosed As DocumentClosedEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentClosed event instead.")]
public:
 event DocumentClosedEventHandler^ OnDocumentClosed {
    void add (DocumentClosedEventHandler^ value);
    void remove (DocumentClosedEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document has been closed during an API command. By subscribing to this event the application will be notified after such an event and can perform an action in response.

See Also

Application Class
Autodesk.Revit Namespace

OnDocumentNewed Event

[image]