Revit 2010 API
DemandFactor Class
Members See Also Send Feedback
Represents a demand factor, which let you adjust the rating of the main service for a building based on the expectation that, at any given time, not all of the electrical equipment will not be drawing at its full rated load. You can specify one or more Demand Factors, applying different Demand Factors to Lighting, Power, HVAC, or Other systems in your project based on their load.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DemandFactor : Symbol
Visual Basic (Declaration)
Public Class DemandFactor _
    Inherits Symbol
Visual C++
public ref class DemandFactor : public Symbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.DemandFactor

See Also

DemandFactor Members
Autodesk.Revit.MEP Namespace

DemandFactor Members

[image] [image]