Revit 2010 API
Document..::.NewElectricalSystem Method (ElementSet, ElectricalSystemType)
Document Class See Also Send Feedback
Creates a new MEP Electrical System element from a set of electrical components.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElectricalSystem NewElectricalSystem(
    ElementSet electComponents,
    ElectricalSystemType elecSysType
)
Visual Basic (Declaration)
Public Function NewElectricalSystem ( _
    electComponents As ElementSet, _
    elecSysType As ElectricalSystemType _
) As ElectricalSystem
Visual C++
public:
ElectricalSystem^ NewElectricalSystem(
    ElementSet^ electComponents,
    ElectricalSystemType elecSysType
)

Parameters

electComponents
Type: Autodesk.Revit..::.ElementSet
The electrical components in this system.
elecSysType
Type: Autodesk.Revit.MEP.Enums..::.ElectricalSystemType
The System Type of electrical system.

Return Value

If successful a new MEP Electrical System element within the project, otherwise Nothing.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter Value is null.
System..::.ArgumentOutOfRangeException | Thrown when the elecSysType parameter Value is out of the range of ElectricalSystemType.
System..::.InvalidOperationException | Thrown when the electrical system cannot be created by these input electrical components.

See Also

Document Class
NewElectricalSystem Overload
Autodesk.Revit.Creation Namespace

NewElectricalSystem Method (Connector, ElectricalSystemType)

[image]