Revit 2010 API
PipeSystemType Enumeration
See Also Send Feedback
An enumerate type listing all the possible Pipe System Types for a Duct Connector object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum PipeSystemType
Visual Basic (Declaration)
Public Enumeration PipeSystemType
Visual C++
public enum class PipeSystemType

Members

Member name | Description
Fitting | Pipe System Type is Fitting.
FireProtectOther | Pipe System Type is FireProtectOther.
FireProtectPreaction | Pipe System Type is FireProtectPreaction.
FireProtectDry | Pipe System Type is FireProtectDry.
FireProtectWet | Pipe System Type is FireProtectWet.
OtherPipe | Pipe System Type is OtherPipe.
DomesticColdWater | Pipe System Type is DomesticColdWater.
DomesticHotWater | Pipe System Type is DomesticHotWater.
Sanitary | Pipe System Type is Sanitary.
ReturnHydronic | Pipe System Type is ReturnHydronic.
SupplyHydronic | Pipe System Type is SupplyHydronic.
UndefinedSystemType | Undefined system type
Global | Pipe System Type is Global.

See Also

Autodesk.Revit.MEP.Enums Namespace

PowerFactorStateType Enumeration

[image]