Revit 2010 API
ObjectFactory..::.CreateInstance Method
ObjectFactory Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public APIObject CreateInstance(
    IntPtr pRuntimeClass,
    IntPtr pData,
    IntPtr tag
)
Visual Basic (Declaration)
Public Function CreateInstance ( _
    pRuntimeClass As IntPtr, _
    pData As IntPtr, _
    tag As IntPtr _
) As APIObject
Visual C++
public:
APIObject^ CreateInstance(
    IntPtr pRuntimeClass,
    IntPtr pData,
    IntPtr tag
)

Parameters

pRuntimeClass
Type: System..::.IntPtr
pData
Type: System..::.IntPtr
tag
Type: System..::.IntPtr

Return Value

See Also

ObjectFactory Class
Autodesk.Revit Namespace

Dispose Method

[image]