Revit 2010 API
SolidArray..::.Insert Method
SolidArray Class See Also Send Feedback
Insert the specified solid into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    Solid item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Solid, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Solid^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.Solid
The solid to be inserted into the array.
index
Type: System..::.Int32
The solid will be inserted before this index.

Return Value

Returns whether the solid was inserted into the array.

See Also

SolidArray Class
Autodesk.Revit.Geometry Namespace

ReverseIterator Method

[image]