Revit 2010 API
Document..::.Delete Method (Element)
Document Class Example See Also Send Feedback
Deletes an element from the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementIdSet Delete(
    Element element
)
Visual Basic (Declaration)
Public Function Delete ( _
    element As Element _
) As ElementIdSet
Visual C++
public:
ElementIdSet^ Delete(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit..::.Element
The element that is to be deleted.

Remarks

This method will delete the element and any elements that are totally dependent upon that element. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

Examples

CopyC#
private void DeleteElement(Autodesk.Revit.Document document, Element element)
{
    // Delete a selected element.
    ElementIdSet deletedIdSet = document.Delete(element);

    if (0 == deletedIdSet.Size)
    {
        throw new Exception("Deleting the selected element in revit failed.");
    }

    String prompt = "The selected element has been removed and ";
    prompt += deletedIdSet.Size - 1;
    prompt += " more dependent elements have also been removed.";

    // Give the user some information
    MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);

}
CopyVB.NET
Private Sub DeleteElement(ByVal document As Autodesk.Revit.Document, ByVal element As Autodesk.Revit.Element)
    ' Delete a selected element.
    Dim deletedIdSet As ElementIdSet = document.Delete(element)

    If 0 = deletedIdSet.Size Then
        Throw New Exception("Deleting the selected element in revit failed.")
    End If

    Dim prompt As String = "The selected element has been removed and "
    prompt += deletedIdSet.Size - 1
    prompt += " more dependent elements have also been removed."

    ' Give the user some information
    MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)
End Sub

See Also

Document Class
Delete Overload
Autodesk.Revit Namespace

Delete Method (ElementId)

[image]