Revit 2010 API
View..::.Print Method (View)
View Class See Also Send Feedback
Print this view with default print settings and specialized view template.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Print(
    View viewTemplate
)
Visual Basic (Declaration)
Public Sub Print ( _
    viewTemplate As View _
)
Visual C++
public:
void Print(
    View^ viewTemplate
)

Parameters

viewTemplate
Type: Autodesk.Revit.Elements..::.View
The view template which apply to the view.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the view cannot be printed.

See Also

View Class
Print Overload
Autodesk.Revit.Elements Namespace

Print Method (Boolean)

[image]