Revit 2010 API
AnalyticalSupportInfoArray..::.Insert Method
AnalyticalSupportInfoArray Class See Also Send Feedback
Insert the specified support into the array.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    AnalyticalSupportInfo item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As AnalyticalSupportInfo, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    AnalyticalSupportInfo^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Structural..::.AnalyticalSupportInfo
The support to be inserted into the array.
index
Type: System..::.Int32
The support will be inserted before this index.

Return Value

Returns whether the support was inserted into the array.

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace

ReverseIterator Method

[image]