Revit 2010 API
XYZ..::.X Property
XYZ Class See Also Send Feedback
The first coordinate.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double X { get; set; }
Visual Basic (Declaration)
Public Property X As Double
Visual C++
public:
property double X {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when setting an infinite number to the X property.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace

Y Property

[image]