Revit 2010 API
ProjectUnit Class
Members Example See Also Send Feedback
Provides access to the Project Unit... in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ProjectUnit : Element
Visual Basic (Declaration)
Public Class ProjectUnit _
    Inherits Element
Visual C++
public ref class ProjectUnit : public Element

Remarks

The ProjectUnit object can be queried for its D in space planning tools.

Examples

CopyC#
ProjectUnit projectUnit = document.ProjectUnit;

if (null != projectUnit)
{
    string message = "Project Unit: ";

    //get the DecimalSymbolType
    message += "\nDecimal Symbol Type: " + projectUnit.DecimalSymbolType.ToString();

    //show the usage for FormatOptions property
    message += "\nFormat Options: ";
    FormatOptions formatOptions = projectUnit.get_FormatOptions(Autodesk.Revit.Enums.UnitType.UT_Length);
    message += "\n\tLength : " + formatOptions.Name;
    formatOptions = projectUnit.get_FormatOptions(Autodesk.Revit.Enums.UnitType.UT_Volume);
    message += "\n\tVolume : " + formatOptions.Name;

    //get the Digit Grouping Amount of the project
    Autodesk.Revit.Enums.DigitGroupingAmount dga = projectUnit.DigitGroupingAmount;
    message += "\nDigit Grouping Amount: " + dga.ToString();

    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Dim projectUnit As ProjectUnit = document.ProjectUnit

If projectUnit IsNot Nothing Then
    Dim message As String = "Project Unit: "

    'get the DecimalSymbolType
    message += vbLf & "Decimal Symbol Type: " & projectUnit.DecimalSymbolType.ToString()

    'show the usage for FormatOptions property
    message += vbLf & "Format Options: "
    Dim formatOptions As Autodesk.Revit.FormatOptions = projectUnit.FormatOptions(Autodesk.Revit.Enums.UnitType.UT_Length)
    message += vbLf & vbTab & "Length : " & formatOptions.Name
    formatOptions = projectUnit.FormatOptions(Autodesk.Revit.Enums.UnitType.UT_Volume)
    message += vbLf & vbTab & "Volume : " & formatOptions.Name

    'get the Digit Grouping Amount of the project
    Dim dga As Autodesk.Revit.Enums.DigitGroupingAmount = projectUnit.DigitGroupingAmount
    message += vbLf & "Digit Grouping Amount: " & dga.ToString()

    MessageBox.Show(message, "Revit")
End If

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.ProjectUnit

See Also

ProjectUnit Members
Autodesk.Revit.Elements Namespace

ProjectUnit Members

[image] [image]