Revit 2010 API
ModelArc Class
Members See Also Send Feedback
Represents a ModelArc within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ModelArc : ModelCurve
Visual Basic (Declaration)
Public Class ModelArc _
    Inherits ModelCurve
Visual C++
public ref class ModelArc : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by goemetry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CurveElement
Autodesk.Revit.Elements..::.ModelCurve
Autodesk.Revit.Elements..::.ModelArc

See Also

ModelArc Members
Autodesk.Revit.Elements Namespace

ModelArc Members

[image] [image]