Revit 2010 API
LineScaling Enumeration
See Also Send Feedback
An enumerate type listing possible LineType scaling modes.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum LineScaling
Visual Basic (Declaration)
Public Enumeration LineScaling
Visual C++
public enum class LineScaling

Members

Member name | Description
PaperSpace | Paperspace scaling. Specifies the value 1 for both LTSCALE and PSLTSCALE.
ModelSpace | Modelspace scaling. LTSCALE is set to view scale and PSLTSCALE to 0.
ViewScale | Exporting lines as they were scaled by view scale. This option preserves visual fidelity.

Remarks

Whichever option is chosen, line type definitions are created so a dashed line always begins and ends with a dash.

Using these options does change the default behavior of exported DWGs. Some lines expected to be dashed may appear solid or in a different scale.

See Also

Autodesk.Revit.Enums Namespace

MarginType Enumeration

[image]