Revit 2010 API
FillPatternSet Members
FillPatternSet Class Constructors Methods Properties See Also Send Feedback

The FillPatternSet type exposes the following members.

Constructors

Name | Description
FillPatternSet | Initializes a new instance of the FillPatternSet class

Methods

Name | Description
Clear | Removes every fill pattern from the set, rendering it empty.
Contains | Tests for the existence of a fill pattern within the set.
Erase | Removes a specified fill pattern from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
Insert | Insert the specified fill pattern into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
Size | Returns the number of fill patterns that are in the set.

See Also

FillPatternSet Class
Autodesk.Revit Namespace

FillPatternSet Constructor

[image]