Revit 2010 API
AnalyzesAsType Enumeration
See Also Send Feedback
This enum class is used for the BuiltInParameter STRUCTURAL_ANALYZES_AS.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum AnalyzesAsType
Visual Basic (Declaration)
Public Enumeration AnalyzesAsType
Visual C++
public enum class AnalyzesAsType

Members

Member name | Description
AA_Not_For_Analysis |
AA_SlabOnGrade |
AA_Mat |
AA_Slab |
AA_Lateral |
AA_Gravity |
AA_Hanger |

See Also

Autodesk.Revit.Enums Namespace

AreaElemType Enumeration

[image]