Revit 2010 API
MEPSystem Class
Members See Also Send Feedback
A system in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MEPSystem : Element
Visual Basic (Declaration)
Public Class MEPSystem _
    Inherits Element
Visual C++
public ref class MEPSystem : public Element

Remarks

This is the base class for electrical, mechanical and piping systems, available only in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.MEP..::.MEPSystem
Autodesk.Revit.MEP..::.ElectricalSystem
Autodesk.Revit.MEP..::.MechanicalSystem
Autodesk.Revit.MEP..::.PipingSystem

See Also

MEPSystem Members
Autodesk.Revit.MEP Namespace

MEPSystem Members

[image] [image]