Revit 2010 API
Document..::.Close Method (Boolean, PostedErrorArray)
Document Class See Also Send Feedback
Closes the document with the option to save.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Close(
    bool saveModified,
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function Close ( _
    saveModified As Boolean, _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool Close(
    bool saveModified,
    PostedErrorArray^ postedErrors
)

Parameters

saveModified
Type: System..::.Boolean
Indicates if the current document should be saved before close operation.
postedErrors
Type: Autodesk.Revit..::.PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns 'false' if closing procedure fails or if saving of a modified document was requested (saveModified = 'true') but failed. Also returns 'false' if closing is cancelled by an external application during 'DocumentClosing' event. When function succeeds, 'true' is returned.

Remarks

This function can not be called on the active document. If the user tries to close the active document with this function, it will return false.

The 'postedErrors' parameter is used only when running Revit in UI-less mode.

See Also

Document Class
Close Overload
Autodesk.Revit Namespace

CombineElements Method

[image]