Revit 2010 API
Document..::.EndTransaction Method (PostedErrorArray)
Document Class See Also Send Feedback
Ends a transaction with an attempt to commit the set of changes.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool EndTransaction(
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function EndTransaction ( _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool EndTransaction(
    PostedErrorArray^ postedErrors
)

Parameters

postedErrors
Type: Autodesk.Revit..::.PostedErrorArray
Would contain list of failures posted during the process.

Return Value

true is returned if the transaction is ended successfully, otherwise false will be returned.

Remarks

The transaction can ensure all the operations between BeginTransaction and EndTransaction can be fulfilled at one time successfully.

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
EndTransaction Overload
Autodesk.Revit Namespace

Export Method

[image] [image]