Revit 2010 API
Ellipse Class
Members See Also Send Feedback
A whole or partial ellipse.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Ellipse : Curve
Visual Basic (Declaration)
Public Class Ellipse _
    Inherits Curve
Visual C++
public ref class Ellipse : public Curve

Remarks

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Curve
Autodesk.Revit.Geometry..::.Ellipse

See Also

Ellipse Members
Autodesk.Revit.Geometry Namespace

Ellipse Members

[image] [image]