Revit 2010 API
RibbonPanel Methods
RibbonPanel Class See Also Send Feedback

The RibbonPanel type exposes the following members.

Methods

Name | Description
AddButton | Adds a button to the panel.
AddPulldownButton | Adds a PulldownButton to the panel.
AddPushButton | Adds a PushButton to the panel.
AddSeparator | Adds a new Separator to the panel.
AddStackedButtons | Overloaded.
AddToPulldown | Adds a pushbutton to the existing PulldownButton.
Equals | Returns a value whether the panel equals to another panel. (Overrides Object..::.Equals(Object).)

See Also

RibbonPanel Class
Autodesk.Revit Namespace

AddButton Method

[image]