Revit 2010 API
MechanicalSystem Class
Members See Also Send Feedback
A mechanical system in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MechanicalSystem : MEPSystem
Visual Basic (Declaration)
Public Class MechanicalSystem _
    Inherits MEPSystem
Visual C++
public ref class MechanicalSystem : public MEPSystem

Remarks

The mechanical system element is only available in Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.MEP..::.MEPSystem
Autodesk.Revit.MEP..::.MechanicalSystem

See Also

MechanicalSystem Members
Autodesk.Revit.MEP Namespace

MechanicalSystem Members

[image] [image]