Revit 2010 API
Truss..::.GetTrussMemberInfo Method
Truss Class See Also Send Feedback
Query if a given element is a member of a truss,its lock status and its usage,etc.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TrussMemberInfo GetTrussMemberInfo(
    ref ElementId elemId
)
Visual Basic (Declaration)
Public Function GetTrussMemberInfo ( _
    ByRef elemId As ElementId _
) As TrussMemberInfo
Visual C++
public:
TrussMemberInfo^ GetTrussMemberInfo(
    ElementId% elemId
)

Parameters

elemId
Type: Autodesk.Revit..::.ElementId %
The querying element.

Return Value

A struct TrussMemberInfo that contains the quering element's host truss,whether lock to the truss,usage type,etc.

See Also

Truss Class
Autodesk.Revit.Elements Namespace

RemoveProfile Method

[image]