Revit 2010 API
ParameterListItemArray Members
ParameterListItemArray Class Constructors Methods Properties See Also Send Feedback

The ParameterListItemArray type exposes the following members.

Constructors

Name | Description
ParameterListItemArray | Initializes a new instance of the ParameterListItemArray class

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

ParameterListItemArray Class
Autodesk.Revit.Parameters Namespace

ParameterListItemArray Constructor

[image]