Revit 2010 API
Document..::.Move Method (ElementIdSet, XYZ)
Document Class See Also Send Feedback
Moves several elements, specified by a set of ids, within the document by a specified vector.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Move(
    ElementIdSet ids,
    XYZ translationVec
)
Visual Basic (Declaration)
Public Function Move ( _
    ids As ElementIdSet, _
    translationVec As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    ElementIdSet^ ids,
    XYZ^ translationVec
)

Parameters

ids
Type: Autodesk.Revit..::.ElementIdSet
A set of element ids specifying which elements are to be moved.
translationVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector by which the elements are to be moved.

Return Value

If the elements are moved successfully then the method returns True, otherwise False.

Remarks

The move method is used to move several elements within the project. Other elements may also be moved when these elements are moved, for example: if the elements are structural columns, all the beams joined to those columns will also be moved or resized.

See Also

Document Class
Move Overload
Autodesk.Revit Namespace

Move Method (ElementSet, XYZ)

[image]