Revit 2010 API
Document..::.Mirror Method (Element, Reference)
Document Class Example See Also Send Feedback
Mirrors an element about a reference.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Mirror(
    Element element,
    Reference reference
)
Visual Basic (Declaration)
Public Function Mirror ( _
    element As Element, _
    reference As Reference _
) As Boolean
Visual C++
public:
bool Mirror(
    Element^ element,
    Reference^ reference
)

Parameters

element
Type: Autodesk.Revit..::.Element
A element that is to be mirrored.
reference
Type: Autodesk.Revit.Geometry..::.Reference
The reference by which the elements will mirror.

Return Value

If the elements are mirrored successfully then the method returns true.

Examples

CopyC#
public void MirrorColumn(Autodesk.Revit.Document document, FamilyInstance column)
{
    AnalyticalModelFrame analytical = column.AnalyticalModel as AnalyticalModelFrame;
    Reference lineReference = analytical.Curve.Reference;
    document.Mirror(column, lineReference);

    //The selected element is changed after the Mirror operation.
    foreach (Autodesk.Revit.Elements.FamilyInstance newColumn in document.Selection.Elements)
    {
        bool isMirror = newColumn.Mirrored;

        MessageBox.Show("Column is mirrored: " + isMirror, "Revit");

        //Offset the new column
        XYZ translationVec = new XYZ(10, 20, 30);
        newColumn.Location.Move(translationVec);
    }
}
CopyVB.NET
Public Sub MirrorColumn(ByVal document As Autodesk.Revit.Document, ByVal column As Autodesk.Revit.Elements.FamilyInstance)
    Dim analytical As AnalyticalModelFrame = TryCast(column.AnalyticalModel, AnalyticalModelFrame)
    Dim lineReference As Reference = analytical.Curve.Reference
    document.Mirror(column, lineReference)

    'The selected element is changed after the Mirror operation.
    For Each newColumn As Autodesk.Revit.Elements.FamilyInstance In document.Selection.Elements
        Dim isMirror As Boolean = newColumn.Mirrored

        MessageBox.Show("Column is mirrored: " & isMirror, "Revit")

        'Offset the new column
        Dim translationVec As New Autodesk.Revit.Geometry.XYZ(10, 20, 30)
        newColumn.Location.Move(translationVec)
    Next
End Sub

See Also

Document Class
Mirror Overload
Autodesk.Revit Namespace

Mirror Method (ElementId, Reference)

[image]