Revit 2010 API
AnalyticalSupportType Enumeration
See Also Send Feedback
Describes the type of support given by another structural element.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum AnalyticalSupportType
Visual Basic (Declaration)
Public Enumeration AnalyticalSupportType
Visual C++
public enum class AnalyticalSupportType

Members

Member name | Description
MAX | The value is used to check whether the enum is the same size as the internal one.
Surface_Support | A Surface support type.
Line_Support | A Line support type.
Point_Support | A Point support type.
Unknown_Support | An unknown support type.

See Also

Autodesk.Revit.Structural.Enums Namespace

CompoundStructureDeckUsage Enumeration

[image]