Revit 2010 API
Filter Class
Members See Also Send Feedback
Base class that represents all filters of other sub classes (such as TypeFilter, CategoryFilter, FamilyFilter, SymbolFilter, ParameterFilter, InstanceUsageFilter, WallUsageFilter, MaterialFilter or StructuralTypeFilter), this filter can be used to create single filter or filters combination. User can use overloaded &&, || and ! operators to create combination of filters. e.g. FamilyFilter && SymbolFilter && ParameterFilter, (FamilyFilter1 || FamilyFilter2) && ParameterFilter. Use this filter to retrieve elements which satisfy specified filter criterion within current document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class Filter : APIObject
Visual Basic (Declaration)
Public MustInherit Class Filter _
    Inherits APIObject
Visual C++
public ref class Filter abstract : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Filter
Autodesk.Revit..::.CategoryFilter
Autodesk.Revit..::.FamilyFilter
Autodesk.Revit..::.InstanceUsageFilter
Autodesk.Revit..::.LogicAndFilter
Autodesk.Revit..::.LogicNotFilter
Autodesk.Revit..::.LogicOrFilter
Autodesk.Revit..::.MaterialFilter
Autodesk.Revit..::.ParameterFilter
Autodesk.Revit..::.StructuralTypeFilter
Autodesk.Revit..::.SymbolFilter
Autodesk.Revit..::.TypeFilter
Autodesk.Revit..::.WallUsageFilter

See Also

Filter Members
Autodesk.Revit Namespace

Filter Members

[image] [image]