Revit 2010 API
FamilyManager..::.MakeType Method
FamilyManager Class See Also Send Feedback
Set the family parameter as a type parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void MakeType(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Sub MakeType ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void MakeType(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.

See Also

FamilyManager Class
Autodesk.Revit Namespace

NewType Method

[image]