Revit 2010 API
Document..::.NewWalls Method (List<(Of <(RectangularWallCreationData>)>))
Document Class See Also Send Feedback
Creates rectangular walls within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewWalls(
    List<RectangularWallCreationData> dataList
)
Visual Basic (Declaration)
Public Function NewWalls ( _
    dataList As List(Of RectangularWallCreationData) _
) As ElementSet
Visual C++
public:
ElementSet^ NewWalls(
    List<RectangularWallCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::.List <(Of <( RectangularWallCreationData >)>)
A list of RectangularWallCreationData which wraps the creation arguments of the walls to be created.

Return Value

If the creation is successful an ElementSet which contains the walls should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
System..::.ArgumentException | Either of 'curve', 'wallType', 'level' or 'height' is less than 0, or the 'curve' is not horizontal, or the neither of the curve's type is CURVE_TYPE_LINE or CURVE_TYPE_ARC.
System..::.InvalidOperationException | If regeneration fails at the end of the batch creation.

See Also

Document Class
NewWalls Overload
Autodesk.Revit.Creation Namespace

NewWire Method

[image]