Revit 2010 API
VoltageType..::.SetVoltageValue Method
VoltageType Class See Also Send Feedback
Assign new values to modify voltage type, all of the unit are volt.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetVoltageValue(
    double actualValue,
    double minValue,
    double maxValue
)
Visual Basic (Declaration)
Public Sub SetVoltageValue ( _
    actualValue As Double, _
    minValue As Double, _
    maxValue As Double _
)
Visual C++
public:
void SetVoltageValue(
    double actualValue,
    double minValue,
    double maxValue
)

Parameters

actualValue
Type: System..::.Double
minValue
Type: System..::.Double
maxValue
Type: System..::.Double

Exceptions

Exception | Condition
System..::.ArgumentException | Actual value can't be more than minValue or less than maxValue, and all of them can't be negative, otherwise the exception will be thrown.

See Also

VoltageType Class
Autodesk.Revit.MEP Namespace

VoltageType Properties

[image] [image]