Revit 2010 API
ItemFactoryBase..::.NewTextNotes Method
ItemFactoryBase Class See Also Send Feedback
Creates TextNotes with the specified data.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewTextNotes(
    List<TextNoteCreationData> dataList
)
Visual Basic (Declaration)
Public Function NewTextNotes ( _
    dataList As List(Of TextNoteCreationData) _
) As ElementSet
Visual C++
public:
ElementSet^ NewTextNotes(
    List<TextNoteCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::.List <(Of <( TextNoteCreationData >)>)
A list of TextNoteCreationData which wraps the creation arguments of the TextNotes to be created.

Return Value

If the creation is successful an ElementSet which contains the TextNotes should be returned, otherwise System::InvalidOperationException will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when (1) Any one of theView, origin, baseVec, upVec, strText in TextNoteCreationData is null. (2) Any one of leaderEnd is null in TextNoteCreationData when leaderStyle != Autodesk::Revit::Enums::TextNoteLeaderStyles::LCS_NONE . (3) Any one of leaderElbow is null TextNoteCreationData when leaderStyle == Autodesk::Revit::Enums::TextNoteLeaderStyles::LCS_TWO_SEG_LINE.
System..::.NotFiniteNumberException | Thrown when one lineWidth in textNoteCreationData is not a finite number.
System..::.ArgumentOutOfRangeException | Thrown when (1) Any one textAlign in TextNoteCreationData is not a valid Autodesk::Revit::Enums::TextAlignFlags or it is not a valid bitwise OR of Autodesk::Revit::Enums::TextAlignFlags. (2) Any one leaderStyle in TextNoteCreationData is not a valid Autodesk::Revit::Enums::TextNoteLeaderTypes or any one leaderType in TextNoteCreationData is not a valid Autodesk::Revit::Enums::TextNoteLeaderTypes when leaderStyle != Autodesk::Revit::Enums::TextNoteLeaderStyles::LCS_NONE
System..::.InvalidOperationException | If the phase is invalid or regeneration fails at the end of the batch creation.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace

NewView3D Method

[image]