Revit 2010 API
FamilyManager..::.GetAssociatedFamilyParameter Method
FamilyManager Class See Also Send Feedback
Gets the associated family parameter of an element parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyParameter GetAssociatedFamilyParameter(
    Parameter elementParameter
)
Visual Basic (Declaration)
Public Function GetAssociatedFamilyParameter ( _
    elementParameter As Parameter _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ GetAssociatedFamilyParameter(
    Parameter^ elementParameter
)

Parameters

elementParameter
Type: Autodesk.Revit..::.Parameter
The parameter of an element in family.

Return Value

Returns the associated family parameter if there is an association between them, returns null if not.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"elementParameter"-is null.

See Also

FamilyManager Class
Autodesk.Revit Namespace

IsParameterLockable Method

[image]