Revit 2010 API
Element..::.IsHidden Method
Element Class See Also Send Feedback
Identifies if the element has been permanently hidden in the view.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsHidden(
    View pView
)
Visual Basic (Declaration)
Public Function IsHidden ( _
    pView As View _
) As Boolean
Visual C++
public:
bool IsHidden(
    View^ pView
)

Parameters

pView
Type: Autodesk.Revit.Elements..::.View

Remarks

This does not determine if the element is hidden as a result of temporary hide/isolate, view sectioning, view crop box, or other operations that can cause elements not to be visible. To hide or unhide an element, use the Hide() and Unhide() method of View.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when argument is null.

See Also

Element Class
Autodesk.Revit Namespace

Element Properties

[image] [image]