Revit 2010 API
Document..::.NewGrids Method
Document Class See Also Send Feedback
Creates new grid lines.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewGrids(
    CurveArray curves
)
Visual Basic (Declaration)
Public Function NewGrids ( _
    curves As CurveArray _
) As ElementSet
Visual C++
public:
ElementSet^ NewGrids(
    CurveArray^ curves
)

Parameters

curves
Type: Autodesk.Revit.Geometry..::.CurveArray
The curves which represent the new grid lines. These curves must be lines or bounded arcs.

Return Value

An Element set that contains the Grids.

Remarks

All input curves should lie on horizontal planes.

Exceptions

Exception | Condition
System..::.ArgumentException | If the curve is an unbounded arc (a circle).
System..::.ArgumentNullException | If any curve supplied in the input is null.
System..::.InvalidOperationException | If any grid line is not created successfully or regeneration fails at the end of the batch creation.

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewGutter Method

[image] [image]