Revit 2010 API
TaskDialogShowingEventArgs Class
Members See Also Send Feedback
The event arguments used by the DialogBoxShowing event when a Revit task dialog that prompts the user for some action is shown.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class TaskDialogShowingEventArgs : DialogBoxShowingEventArgs
Visual Basic (Declaration)
Public Class TaskDialogShowingEventArgs _
    Inherits DialogBoxShowingEventArgs
Visual C++
public ref class TaskDialogShowingEventArgs : public DialogBoxShowingEventArgs

Remarks

When the application receives this object, a task dialog is about to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.DialogBoxShowingEventArgs
Autodesk.Revit.Events..::.TaskDialogShowingEventArgs

See Also

TaskDialogShowingEventArgs Members
Autodesk.Revit.Events Namespace

TaskDialogShowingEventArgs Members

[image] [image]