Revit 2010 API
ControlledApplication..::.CreateRibbonPanel Method
ControlledApplication Class Example See Also Send Feedback
Create a new RibbonPanel.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
    string panelName
)
Visual Basic (Declaration)
Public Overridable Function CreateRibbonPanel ( _
    panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
    String^ panelName
)

Parameters

panelName
Type: System..::.String

Remarks

This method will create a custom panel appending to the Revit AddIns tab.

Examples

CopyC#
public IExternalApplication.Result OnStartup(ControlledApplication application)
{
    // add new ribbon panel
    RibbonPanel ribbonPanel = application.CreateRibbonPanel("NewRibbonPanel");

    //Create a push button in the ribbon panel “NewRibbonPanel”
    //the add-in application “HelloWorld” will be triggered when button is pushed

    PushButton pushButton = ribbonPanel.AddPushButton("HelloWorld", "HelloWorld", @"D:\HelloWorld.dll", "HelloWorld.CsHelloWorld");

    // Set the large image shown on button
    Uri uriImage = new Uri(@"D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png");
    BitmapImage largeImage = new BitmapImage(uriImage);
    pushButton.LargeImage = largeImage;

    return IExternalApplication.Result.Succeeded;
}
CopyVB.NET
Public Function OnStartup(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnStartup
    ' add new ribbon panel
    Dim ribbonPanel As RibbonPanel = application.CreateRibbonPanel("NewRibbonPanel")

    'Create a push button in the ribbon panel “NewRibbonPanel”
    'the add-in application “HelloWorld” will be triggered when button is pushed

    Dim pushButton As PushButton = ribbonPanel.AddPushButton("HelloWorld", "HelloWorld", "D:\HelloWorld.dll", "HelloWorld.CsHelloWorld")

    ' Set the large image shown on button
    Dim uriImage As New Uri("D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png")
    Dim largeImage As New BitmapImage(uriImage)
    pushButton.LargeImage = largeImage

    Return IExternalApplication.Result.Succeeded
End Function

Exceptions

Exception | Condition
System..::.ArgumentNullException | panelName is null.
System..::.ArgumentException | panelName is Empty.
System..::.InvalidOperationException | If more than 100 panels were created.

See Also

ControlledApplication Class
Autodesk.Revit Namespace

GetRibbonPanels Method

[image]