Revit 2010 API
ItemFactoryBase..::.NewViewPlan Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a plan view based on the specified level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewPlan NewViewPlan(
    string pViewName,
    Level pLevel,
    ViewType viewType
)
Visual Basic (Declaration)
Public Function NewViewPlan ( _
    pViewName As String, _
    pLevel As Level, _
    viewType As ViewType _
) As ViewPlan
Visual C++
public:
ViewPlan^ NewViewPlan(
    String^ pViewName,
    Level^ pLevel,
    ViewType viewType
)

Parameters

pViewName
Type: System..::.String
The name for the new plan view, must be unique or null pointer.
pLevel
Type: Autodesk.Revit.Elements..::.Level
The level on which the plan view is to be associated.
viewType
Type: Autodesk.Revit.Enums..::.ViewType
The type of plan view to be created, must be Floor Plan or Ceiling Plan (Structural Plan in Structure).

Return Value

if successful, a new plan view object within the project, otherwise Nothing.

Remarks

if pViewName is null, the pLevel's name will be use as new plan view's name. if the name is not unique, an Exception will be thrown.

Examples

CopyC#
// Create a Level and a Floor Plan based on it
double elevation = 10.0;
Level level1 = document.Create.NewLevel(elevation);
ViewPlan floorView = document.Create.NewViewPlan(null, level1, ViewType.FloorPlan);

// Create another Level and a Ceiling Plan based on it
elevation += 10.0;
Level level2 = document.Create.NewLevel(elevation);
ViewPlan ceilingView = document.Create.NewViewPlan(null, level2, ViewType.CeilingPlan);
CopyVB.NET
' Create a Level and a Floor Plan based on it
Dim elevation As Double = 10.0R
Dim level1 As Autodesk.Revit.Elements.Level = document.Create.NewLevel(elevation)
Dim floorView As ViewPlan = document.Create.NewViewPlan(Nothing, level1, Autodesk.Revit.Enums.ViewType.FloorPlan)

' Create another Level and a Ceiling Plan based on it
elevation += 10.0R
Dim level2 As Autodesk.Revit.Elements.Level = document.Create.NewLevel(elevation)
Dim ceilingView As ViewPlan = document.Create.NewViewPlan(Nothing, level2, Autodesk.Revit.Enums.ViewType.CeilingPlan)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace

NewViewSection Method

[image]