Revit 2010 API
SlabShapeEditor..::.ModifySubElement Method (SlabShapeVertex, Double)
SlabShapeEditor Class See Also Send Feedback
Manipulates the vertex on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ModifySubElement(
    SlabShapeVertex vertex,
    double offset
)
Visual Basic (Declaration)
Public Sub ModifySubElement ( _
    vertex As SlabShapeVertex, _
    offset As Double _
)
Visual C++
public:
void ModifySubElement(
    SlabShapeVertex^ vertex,
    double offset
)

Parameters

vertex
Type: Autodesk.Revit.Editor..::.SlabShapeVertex
The vertex.
offset
Type: System..::.Double
The new value of the vertex offset.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the vertex is nullptr.
System..::.ArgumentException | Thrown when the vertex is invalid.

See Also

SlabShapeEditor Class
ModifySubElement Overload
Autodesk.Revit.Editor Namespace

PickSupport Method

[image]