Revit 2010 API
DividedSurface..::.GetGridNodeUV Method
DividedSurface Class See Also Send Feedback
Get the position of a grid node in UV coordinates in the surface.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UV GetGridNodeUV(
    GridNode gridNode
)
Visual Basic (Declaration)
Public Function GetGridNodeUV ( _
    gridNode As GridNode _
) As UV
Visual C++
public:
UV^ GetGridNodeUV(
    GridNode gridNode
)

Parameters

gridNode
Type: Autodesk.Revit.Elements..::.GridNode

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace

GetGridSegmentReference Method

[image]