Revit 2010 API
AnalyticalModelFrame..::.Curve Property
AnalyticalModelFrame Class See Also Send Feedback
Provides access to Structural Framing Analytical Model.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

Return Value

Returns a Curve containing the Analytical Model of the Structural Framing Element.

Remarks

The curve returned will not contain any Rigid Links. Use associated Rigid Links property to get Rigid Links.

See Also

AnalyticalModelFrame Class
Autodesk.Revit.Structural Namespace

Curves Property

[image]