Revit 2010 API
InstanceUsageFilter Class
Members See Also Send Feedback
Represents a filter to filter elements with the given InstanceUsage/StructuralUsage.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class InstanceUsageFilter : Filter
Visual Basic (Declaration)
Public Class InstanceUsageFilter _
    Inherits Filter
Visual C++
public ref class InstanceUsageFilter : public Filter

Remarks

The InstanceUsageFilter object is to filter all the elements with the given InstanceUsage/StructuralUsage in the active document. FamilyInstance (only brace and beam) has the property StructuralUsage.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Filter
Autodesk.Revit..::.InstanceUsageFilter

See Also

InstanceUsageFilter Members
Autodesk.Revit Namespace

InstanceUsageFilter Members

[image] [image]