Revit 2010 API
APIObject..::.IsReadOnly Property
APIObject Class Example See Also Send Feedback
Identifies if the object is read-only or modifiable.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

If true, the object may not be modified. If false, the object's contents may be modified.

Examples

CopyC#
Document project = application.ActiveDocument;
Settings settings = project.Settings;
MessageBox.Show("Categories: " + settings.Categories.IsReadOnly.ToString());
MessageBox.Show("Materials: " + settings.Materials.IsReadOnly.ToString());
CopyVB.NET
Dim project As Document = application.ActiveDocument
Dim settings As Settings = project.Settings
MessageBox.Show("Categories: " & settings.Categories.IsReadOnly.ToString())
MessageBox.Show("Materials: " & settings.Materials.IsReadOnly.ToString())

See Also

APIObject Class
Autodesk.Revit Namespace

Application Class

[image]