Revit 2010 API
ViewSheetSetting..::.SaveAs Method
ViewSheetSetting Class See Also Send Feedback
Save the current view sheet set to another view sheet set with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SaveAs(
    string newName
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    newName As String _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ newName
)

Parameters

newName
Type: System..::.String
View sheet set name to be saved as.

Return Value

Returns false if saveas operation fails, otherwise, returns true.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the input name is already existed in current view sheet set list.

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace

ViewSheetSetting Properties

[image] [image]