Revit 2010 API
XYZ Properties
XYZ Class See Also Send Feedback

The XYZ type exposes the following members.

Properties

Name | Description
Basis | Indexed access for Basis.
BasisX | The basis of the X axis.
BasisY | The basis of the Y axis.
BasisZ | The basis of the Z axis.
IsNormalized | The boolean value that indicates whether this vector is a normalized vector.
IsZero | The boolean value that indicates whether this vector is a zero vector.
Item | Indexed access to coordinates.
Length | The length of this vector.
Normalized | This vector, normalized.
X | The first coordinate.
Y | The second coordinate.
Z | The third coordinate.
Zero | The coordinate origin or zero vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace

Basis Property

[image]