Revit 2010 API
Curve..::.ApproximateLength Property
Curve Class See Also Send Feedback
The approximate length of the curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ApproximateLength { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApproximateLength As Double
Visual C++
public:
property double ApproximateLength {
    double get ();
}

Remarks

Quickly estimates the length of the curve, may deviate by a factor of 2 in some cases. The computation is exact for lines and arcs.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the curve is unbound and not periodic.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace

EndParameter Property

[image]