Revit 2010 API
Element..::.Id Property
Element Class Example See Also Send Feedback
Provides a way of uniquely identifying an Element within an Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementId Id { get; }
Visual Basic (Declaration)
Public ReadOnly Property Id As ElementId
Visual C++
public:
property ElementId Id {
    ElementId get ();
}

Remarks

Returns an ElementId object containing the project wide unique identifier for this Element. The identifier with the ElementId is only unique for the project, it is not unique across separate Autodesk Revit projects.

Examples

CopyC#
private void CheckElementId(Autodesk.Revit.Document document, Autodesk.Revit.Element element)
{
    // Get the id of the element
    ElementId selectedId = element.Id;
    int idInteger = selectedId.Value;

    // create a new id and set the value
    ElementId id = new ElementId();
    id.Value = idInteger;

    // Get the element
    Autodesk.Revit.Element first = document.get_Element(ref id);

    // And get the element using the original Id (they should be the same)
    Autodesk.Revit.Element second = document.get_Element(ref selectedId);

    String prompt = "Get an element twice. They should be the same element.";
    // Use the Equal method to check two elements. It is not a good way.
    bool isSame = first.Equals(second);
    prompt += "\nUsing Equal method on elements, the result is: " + isSame;
    isSame = first.Id.Equals(second.Id);
    prompt += "\nUsing Equal method on element's Id properties, the result is: " + isSame;

    MessageBox.Show(prompt);
}
CopyVB.NET
Private Sub CheckElementId(ByVal document As Autodesk.Revit.Document, ByVal element As Autodesk.Revit.Element)
    ' Get the id of the element
    Dim selectedId As Autodesk.Revit.ElementId = element.Id
    Dim idInteger As Integer = selectedId.Value

    ' create a new id and set the value
    Dim id As New Autodesk.Revit.ElementId()
    id.Value = idInteger

    ' Get the element
    Dim first As Autodesk.Revit.Element = document.Element(id)

    ' And get the element using the original Id (they should be the same)
    Dim second As Autodesk.Revit.Element = document.Element(selectedId)

    Dim prompt As String = "Get an element twice. They should be the same element."
    ' Use the Equal method to check two elements. It is not a good way.
    Dim isSame As Boolean = first.Equals(second)
    prompt += vbLf & "Using Equal method on elements, the result is: " & isSame
    isSame = first.Id.Equals(second.Id)
    prompt += vbLf & "Using Equal method on element's Id properties, the result is: " & isSame

    MessageBox.Show(prompt)
End Sub

See Also

Element Class
Autodesk.Revit Namespace

Level Property

[image]