Revit 2010 API
Document..::.NewLineLoad Method (XYZ, XYZ, XYZ, XYZ, XYZ, XYZ, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)
Document Class See Also Send Feedback
Creates a new unhosted line load within the project using data at two points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LineLoad NewLineLoad(
    XYZ point,
    XYZ force,
    XYZ moment,
    XYZ point1,
    XYZ force1,
    XYZ moment1,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewLineLoad ( _
    point As XYZ, _
    force As XYZ, _
    moment As XYZ, _
    point1 As XYZ, _
    force1 As XYZ, _
    moment1 As XYZ, _
    uniform As Boolean, _
    projected As Boolean, _
    isReaction As Boolean, _
    symbol As LineLoadType, _
    plane As SketchPlane _
) As LineLoad
Visual C++
public:
LineLoad^ NewLineLoad(
    XYZ^ point,
    XYZ^ force,
    XYZ^ moment,
    XYZ^ point1,
    XYZ^ force1,
    XYZ^ moment1,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
The first point of the LineLoad application.
force
Type: Autodesk.Revit.Geometry..::.XYZ
The applied 3d linear force in the first point.
moment
Type: Autodesk.Revit.Geometry..::.XYZ
The applied 3d linear moment in the first point.
point1
Type: Autodesk.Revit.Geometry..::.XYZ
The second point of the LineLoad application.
force1
Type: Autodesk.Revit.Geometry..::.XYZ
The applied 3d linear force in the second point.
moment1
Type: Autodesk.Revit.Geometry..::.XYZ
The applied 3d linear moment in the second point.
uniform
Type: System..::.Boolean
Set to True if you wish to create the uniform load.
projected
Type: System..::.Boolean
Set to True if you wish to create the projected load.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.Symbols..::.LineLoadType
The symbol of the LineLoad.
plane
Type: Autodesk.Revit.Elements..::.SketchPlane
Indicate the work plane of the LineLoad.

Return Value

If successful, NewLineLOad returns an object for the newly created LineLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
NewLineLoad Overload
Autodesk.Revit.Creation Namespace

NewLineLoad Method (Element, XYZArray, XYZArray, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)

[image]