Revit 2010 API
MEPCurve..::.Diameter Property
MEPCurve Class See Also Send Feedback
The diameter of the MEP curve.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Diameter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Diameter As Double
Visual C++
public:
property double Diameter {
    double get ();
}

Remarks

This property is used to retrieve the diameter of the MEP curve.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the MEP curve's Shape is not round.

See Also

MEPCurve Class
Autodesk.Revit.MEP Namespace

Height Property

[image]