Revit 2010 API
PrintManager..::.ViewSheetSetting Property
PrintManager Class See Also Send Feedback
The ViewSheetSetting which manages the view/sheet set information of current document, and you can change the default view/sheet set for current project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSheetSetting ViewSheetSetting { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewSheetSetting As ViewSheetSetting
Visual C++
public:
property ViewSheetSetting^ ViewSheetSetting {
    ViewSheetSetting^ get ();
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the print range is not selected views/sheets.

See Also

PrintManager Class
Autodesk.Revit Namespace

PrintParameters Class

[image]