Revit 2010 API
Face..::.Project Method
Face Class See Also Send Feedback
Projects the specified point on this face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public IntersectionResult Project(
    XYZ point
)
Visual Basic (Declaration)
Public Function Project ( _
    point As XYZ _
) As IntersectionResult
Visual C++
public:
IntersectionResult^ Project(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
The point to be projected.

Return Value

Geometric information if projection is successful; if projection fails or the nearest point is outside of this face, returns null.

Remarks

The following is the meaning of IntersectionResult's members:
  • XYZPoint is the nearest point to the projected point on the face.
  • UVPoint is the UV coordinates of the nearest point on the face.
  • Distance is the distance from the point to the face.
  • EdgeObject is the edge if projected point is near an edge.
  • EdgeParameter is the parameter of the nearest point on the edge.

See Also

Face Class
Autodesk.Revit.Geometry Namespace

Triangulate Method

[image]