Revit 2010 API
Transform..::.HasReflection Property
Transform Class See Also Send Feedback
The boolean value that indicates whether this transformation produces reflection.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool HasReflection { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasReflection As Boolean
Visual C++
public:
property bool HasReflection {
    bool get ();
}

Remarks

Reflection transformation changes the handedness of a coordinate system.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when this transformation is not conformal and the reflection is undefined.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace

Identity Property

[image]