Revit 2010 API
Document..::.Close Method (Boolean)
Document Class See Also Send Feedback
Closes the document with the option to save.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Close(
    bool saveModified
)
Visual Basic (Declaration)
Public Function Close ( _
    saveModified As Boolean _
) As Boolean
Visual C++
public:
bool Close(
    bool saveModified
)

Parameters

saveModified
Type: System..::.Boolean
Indicates if the current document should be saved before close operation.

Return Value

Returns 'false' if closing procedure fails or if saving of a modified document was requested (saveModified = 'true') but failed. Also returns 'false' if closing is cancelled by an external application during 'DocumentClosing' event. When function succeeds, 'true' is returned.

Remarks

This function can not be called on the active document. If the user tries to close the active document with this function, it will return false.

See Also

Document Class
Close Overload
Autodesk.Revit Namespace

Close Method (Boolean, PostedErrorArray)

[image]