Revit 2010 API
Edge..::.EndPointReference Property
Edge Class See Also Send Feedback
Returns a stable reference to the start or the end point of the edge.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference EndPointReference[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndPointReference ( _
    index As Integer _
) As Reference
Visual C++
public:
property Reference^ EndPointReference[int index] {
    Reference^ get (int index);
}

Parameters

index
Type: System..::.Int32
Use 0 for the start point; 1 for the end point.

Return Value

Reference to the point or nullptr if reference cannot be obtained.

Exceptions

Exception | Condition
System..::.IndexOutOfRangeException | Thrown when the specified index is not 0 or 1.
System..::.InvalidOperationException | Thrown when the object is internally marked as read-only in the setter.

See Also

Edge Class
Autodesk.Revit.Geometry Namespace

Face Property

[image]