Revit 2010 API
Pipe Class
Members See Also Send Feedback
A pipe in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Pipe : MEPCurve
Visual Basic (Declaration)
Public Class Pipe _
    Inherits MEPCurve
Visual C++
public ref class Pipe : public MEPCurve

Remarks

The pipe is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.MEP..::.MEPCurve
Autodesk.Revit.MEP..::.Pipe

See Also

Pipe Members
Autodesk.Revit.MEP Namespace

Pipe Members

[image] [image]