Revit 2010 API
View..::.Hide Method
View Class See Also Send Feedback
Sets the elements to be hidden in the view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Hide(
    ElementSet elemSet
)
Visual Basic (Declaration)
Public Sub Hide ( _
    elemSet As ElementSet _
)
Visual C++
public:
void Hide(
    ElementSet^ elemSet
)

Parameters

elemSet
Type: Autodesk.Revit..::.ElementSet
A set of elements to be hidden.

Remarks

This change is permanent until the elements are unhidden. All elements in the set must be currently unhidden and must be allowed to be hidden. An application can check this with IsHidden(View) and CanBeHidden(View).

Some elements cannot be hidden directly. Examples include: group, array, constraint, edit cut profile, face splitter and link to external documents. To hide a group, obtain the elements in the group from Members, and hide these elements individually. To hide an array, obtain the groups in the array from OrigMembers and CopyMembers, then hide elements in the groups individually.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when argument is null.
System..::.InvalidOperationException | Thrown when one of the elements can not be hidden or has been hidden already.

See Also

View Class
Autodesk.Revit.Elements Namespace

Print Method

[image] [image]