Revit 2010 API
FamilyInstance..::.SubComponents Property
FamilyInstance Class Example See Also Send Feedback
Property to get the sub componets of current family instance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet SubComponents { get; }
Visual Basic (Declaration)
Public ReadOnly Property SubComponents As ElementSet
Visual C++
public:
property ElementSet^ SubComponents {
    ElementSet^ get ();
}

Remarks

When current familyinstance has no sub component, it returns null

Examples

CopyC#
public void GetSubAndSuperComponents(FamilyInstance familyInstance)
{
    ElementSet subElemSet = familyInstance.SubComponents;
    if (subElemSet != null)
    {
        string subElems = "";
        foreach (Autodesk.Revit.Element ee in subElemSet)
        {
            FamilyInstance f = ee as FamilyInstance;
            subElems = subElems + f.Name + "\n";
        }
        MessageBox.Show("Subcomponent count = " + subElemSet.Size + "\n" + subElems);
    }
    FamilyInstance super = familyInstance.SuperComponent as FamilyInstance;
    if (super != null)
    {
        MessageBox.Show("SUPER component: " + super.Name);
    }
}
CopyVB.NET
Public Sub GetSubAndSuperComponents(ByVal familyInstance As Autodesk.Revit.Elements.FamilyInstance)
    Dim subElemSet As ElementSet = familyInstance.SubComponents
    If subElemSet IsNot Nothing Then
        Dim subElems As String = ""
        For Each ee As Autodesk.Revit.Element In subElemSet
            Dim f As Autodesk.Revit.Elements.FamilyInstance = TryCast(ee, Autodesk.Revit.Elements.FamilyInstance)
            subElems = subElems + f.Name & vbLf
        Next
        MessageBox.Show(("Subcomponent count = " & subElemSet.Size & vbLf) + subElems)
    End If
    Dim super As Autodesk.Revit.Elements.FamilyInstance = TryCast(familyInstance.SuperComponent, Autodesk.Revit.Elements.FamilyInstance)
    If super IsNot Nothing Then
        MessageBox.Show("SUPER component: " & super.Name)
    End If
End Sub

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace

SuperComponent Property

[image]