Revit 2010 API
FamilyManager..::.IsParameterLockable Method
FamilyManager Class See Also Send Feedback
For Conceptual Mass and Curtain Panel families, indicate whether the specified parameter can be locked.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsParameterLockable(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function IsParameterLockable ( _
    familyParameter As FamilyParameter _
) As Boolean
Visual C++
public:
bool IsParameterLockable(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter

Return Value

True if the family is a Conceptual Mass or Curtain Panel Family and the parameter drives one or more dimensions; false otherwise.

See Also

FamilyManager Class
Autodesk.Revit Namespace

IsParameterLocked Method

[image]