Revit 2010 API
InternalDefinition Class
Members See Also Send Feedback
This object represents a parameter definition in Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class InternalDefinition : Definition
Visual Basic (Declaration)
Public Class InternalDefinition _
    Inherits Definition
Visual C++
public ref class InternalDefinition : public Definition

Remarks

The InternalDefinition object is derived from the Definition object and hence includes all properties and methods of the Definition object. This object adds no other properties and methods and is used purely for type identification.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.Definition
Autodesk.Revit.Parameters..::.InternalDefinition

See Also

InternalDefinition Members
Autodesk.Revit.Parameters Namespace

InternalDefinition Members

[image] [image]