Revit 2010 API
ViewType Enumeration
See Also Send Feedback
An enumerate type listing available view types.)

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ViewType
Visual Basic (Declaration)
Public Enumeration ViewType
Visual C++
public enum class ViewType

Members

Member name | Description
Rendering | Rendering type of view.
Walkthrough | Walk-Through type of 3D view.
ColumnSchedule | Column Schedule type of view.
PanelSchedule | Panel Schedule Report view.
PresureLossReport | Presure Loss Report view.
LoadsReport | Loads Report view.
CostReport | Cost Report view.
Report | Report type of view.
Legend | Legend type of view.
DrawingSheet | Drawing sheet type of view.
DraftingView | Drafting type of view.
Schedule | Schedule type of view.
ThreeD | 3-D type of view.
Detail | Detail type of view.
Elevation | Elevation type of view.
CeilingPlan | Reflected ceiling plan type of view.
AreaPlan | Area plan type of view.
EngineeringPlan | Engineering Floor Plan type of view.
FloorPlan | Floor plan type of view.
Internal | Revit's internal type of view
Section | Cross section type of view.
Undefined | Undefined/unspecified type of view.

See Also

Autodesk.Revit.Enums Namespace

VirtualPrinterType Enumeration

[image]