Revit 2010 API
Document..::.MechanicalEquipmentTypes Property
Document Class See Also Send Feedback
Returns an object that contains all of the avaible mechanical equipment types currently loaded to this project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbolSet MechanicalEquipmentTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property MechanicalEquipmentTypes As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ MechanicalEquipmentTypes {
    FamilySymbolSet^ get ();
}

Remarks

The MechanicalEquipmentTypes property returns an object that contains the mechanical equipment types which can be used to change the type of a mechanical equipment from one type to another.

See Also

Document Class
Autodesk.Revit Namespace

MullionTypes Property

[image]