Revit 2010 API
ElementIterator..::.Reset Method
ElementIterator Class See Also Send Feedback
Bring the iterator back to the start of the database.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the Autodesk Revit project database in line with the definition of IEnumerator. Note that you must call MoveNext before the first element can be accessed via the Current property.

See Also

ElementIterator Class
Autodesk.Revit Namespace

ElementIterator Properties

[image] [image]