Revit 2010 API
CurtainGrid..::.GetPanel Method
CurtainGrid Class See Also Send Feedback
Get the specified panel located by the intersection of the grid lines.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Panel GetPanel(
    ref ElementId uGridLineId,
    ref ElementId vGridLineId
)
Visual Basic (Declaration)
Public Function GetPanel ( _
    ByRef uGridLineId As ElementId, _
    ByRef vGridLineId As ElementId _
) As Panel
Visual C++
public:
Panel^ GetPanel(
    ElementId% uGridLineId,
    ElementId% vGridLineId
)

Parameters

uGridLineId
Type: Autodesk.Revit..::.ElementId %
The id of a grid line in the U-direction used to locate the panel.
vGridLineId
Type: Autodesk.Revit..::.ElementId %
The id of a grid line in the V-direction used to locate the panel.

Return Value

The panel, or null if the panel cannot be found at this intersection.

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace

CurtainGrid Properties

[image] [image]