Revit 2010 API
Visibility Enumeration
See Also Send Feedback
Describes the visibility of a particular geometry object.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum Visibility
Visual Basic (Declaration)
Public Enumeration Visibility
Visual C++
public enum class Visibility

Members

Member name | Description
Invisible | The geometry object is never visible. This type of geometry is never returned by Geometry[([(Options])]) but may be obtained by other API operations.
Contextual | The geometry object is visible in some contexts, but not in others. This type of geometry is always returned by Geometry[([(Options])]), even when Revit is in a context where the geometry should not be visible, but only if IncludeNonVisibleObjects is true. Examples of geometry of this class include Solids representing insulation and lining for MEP ducts and pipes.
Highlight | The geometry object is visible, but is affected by highlight or prehighlight special coloration. This type of geometry is returned by Geometry[([(Options])]) if IncludeNonVisibleObjects is true.
Visible | The geometry object is always visible. This type of geometry is always returned by Geometry[([(Options])])

See Also

Autodesk.Revit.Geometry Namespace

XYZ Class

[image]