Revit 2010 API
ItemFactoryBase..::.NewSketchPlane Method (PlanarFace)
ItemFactoryBase Class See Also Send Feedback
Creates a new sketch plane on a planar face of existing geometry.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SketchPlane NewSketchPlane(
    PlanarFace planarFace
)
Visual Basic (Declaration)
Public Function NewSketchPlane ( _
    planarFace As PlanarFace _
) As SketchPlane
Visual C++
public:
SketchPlane^ NewSketchPlane(
    PlanarFace^ planarFace
)

Parameters

planarFace
Type: Autodesk.Revit.Geometry..::.PlanarFace
The geometry planar face to locate sketch plane.

Return Value

If successful a new sketch plane will be returned. otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the argument is null.
System..::.ArgumentException | Thrown when the argument is an invalid object, or reference of the argument is null, or the host of this face is invalid.

See Also

ItemFactoryBase Class
NewSketchPlane Overload
Autodesk.Revit.Creation Namespace

NewSketchPlane Method (Plane)

[image]