Revit 2010 API
Options..::.DetailLevels Enumeration
Options Class See Also Send Feedback
Chooses the detail level of an element's representation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum DetailLevels
Visual Basic (Declaration)
Public Enumeration DetailLevels
Visual C++
public enum class DetailLevels

Members

Member name | Description
MAX | The value is used to check whether the enum is the same size as the internal one.
Fine | Corresponds to the fine view detail setting.
Medium | Corresponds to the medium view detail setting.
Coarse | Corresponds to the coarse view detail setting.
Undefined | May produce all or none of the available representations.

Remarks

This corresponds to detail levels in Revit's views and families.

See Also

Autodesk.Revit.Geometry Namespace

PlanarFace Class

[image]