Revit 2010 API
Connector..::.AssignedFixtureUnits Property
Connector Class See Also Send Feedback
The assigned fixture units of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double AssignedFixtureUnits { get; set; }
Visual Basic (Declaration)
Public Property AssignedFixtureUnits As Double
Visual C++
public:
property double AssignedFixtureUnits {
    double get ();
    void set (double value);
}

Remarks

Assigned fixture units may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::PipeConnector.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
System..::.ArgumentException | Thrown when set an invalid value.
System..::.InvalidOperationException | Thrown on failure to get or set assigned fixture units.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

AssignedFlow Property

[image]