Revit 2010 API
Document Class
Members See Also Send Feedback
The Document Creation object is used to create new instances of elements within the Autodesk Revit project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Document : ItemFactoryBase
Visual Basic (Declaration)
Public Class Document _
    Inherits ItemFactoryBase
Visual C++
public ref class Document : public ItemFactoryBase

Remarks

The Document Creation object is a utility object that is used to create new instances of elements within the Autodesk Revit project. This object, available from the Document.Create property should be used to create elements instead of using New. This object ensures that the elements created are added to the document correctly. The object can create a limited number of types, which is expected to increase as the API matures.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Creation..::.ItemFactoryBase
Autodesk.Revit.Creation..::.Document

See Also

Document Members
Autodesk.Revit.Creation Namespace

Document Members

[image] [image]