Revit 2010 API
XYZ..::.AlmostEqual Method
XYZ Class See Also Send Feedback
Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool AlmostEqual(
    XYZ source
)
Visual Basic (Declaration)
Public Function AlmostEqual ( _
    source As XYZ _
) As Boolean
Visual C++
public:
bool AlmostEqual(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to compare with this vector.

Return Value

True if the vectors are the same; otherwise, false.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace

Angle Method

[image]