Revit 2010 API
Parameter..::.AsValueString Method
Parameter Class Example See Also Send Feedback
Get the parameter value as a string with unit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string AsValueString()
Visual Basic (Declaration)
Public Function AsValueString As String
Visual C++
public:
String^ AsValueString()

Return Value

The string that represents the parameter value.

Remarks

The method only applies to parameters of value types. If the parameter is not a value, the method returns a null pointer.

Examples

CopyC#
String ShowValueParameterInformation(Parameter attribute)
{
    string paramValue = null;
    switch (attribute.StorageType)
    {
        case Autodesk.Revit.Parameters.StorageType.Integer:
            if (Autodesk.Revit.Parameters.ParameterType.YesNo
                                == attribute.Definition.ParameterType)
            {
                paramValue = null;
            }
            else
            {
                paramValue = attribute.AsValueString();
            }
            break;
        case Autodesk.Revit.Parameters.StorageType.Double:
            paramValue = attribute.AsValueString();
            break;
        default:
            paramValue = null;
            break;
    }

    return paramValue;
}
CopyVB.NET
Private Function ShowValueParameterInformation(ByVal attribute As Parameter) As String
    Dim paramValue As String = Nothing
    Select Case attribute.StorageType
        Case Autodesk.Revit.Parameters.StorageType.[Integer]
            If Autodesk.Revit.Parameters.ParameterType.YesNo = attribute.Definition.ParameterType Then
                paramValue = Nothing
            Else
                paramValue = attribute.AsValueString()
            End If
            Exit Select
        Case Autodesk.Revit.Parameters.StorageType.[Double]
            paramValue = attribute.AsValueString()
            Exit Select
        Case Else
            paramValue = Nothing
            Exit Select
    End Select

    Return paramValue
End Function

See Also

Parameter Class
Autodesk.Revit Namespace

Set Method

[image] [image]