Revit 2010 API
FamilyType..::.AsDouble Method
FamilyType Class See Also Send Feedback
Provides access to the double precision number of the given family parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Nullable<double> AsDouble(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function AsDouble ( _
    familyParameter As FamilyParameter _
) As Nullable(Of Double)
Visual C++
public:
Nullable<double> AsDouble(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter

Return Value

The double value contained in the parameter. Returns a nullable object without value if the storage type of the input argument is not double type or this parameter has no value.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,

See Also

FamilyType Class
Autodesk.Revit Namespace

AsElementId Method

[image]