Revit 2010 API
PulldownButtonData Constructor
PulldownButtonData Class See Also Send Feedback
Constructs a new instance of PulldownButtonData.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PulldownButtonData(
    string name,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    text As String _
)
Visual C++
public:
PulldownButtonData(
    String^ name,
    String^ text
)

Parameters

name
Type: System..::.String
The internal name of the new button.
text
Type: System..::.String

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when null is passed for one or more arguments.
System..::.ArgumentException | Thrown when an empty string is passed for one or more arguments.

See Also

PulldownButtonData Class
Autodesk.Revit Namespace

PulldownButtonData Methods

[image] [image]