Revit 2010 API
RibbonItem..::.RibbonItemType Enumeration
RibbonItem Class See Also Send Feedback
An enumerate type listing all the toolbar item styles.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum RibbonItemType
Visual Basic (Declaration)
Public Enumeration RibbonItemType
Visual C++
public enum class RibbonItemType

Members

Member name | Description
PulldownButton | A button with a pull-down menu list.
PushButton | A standard button with text and image.

See Also

Autodesk.Revit Namespace

RibbonPanel Class

[image]