Revit 2010 API
Family..::.Symbols Property
Family Class See Also Send Feedback
A set of all symbols (types) that belong to a Family.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbolSet Symbols { get; }
Visual Basic (Declaration)
Public ReadOnly Property Symbols As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ Symbols {
    FamilySymbolSet^ get ();
}

Remarks

Returns a read only set of all the symbols that belong to a particular family. The family symbol objects within this set can be used to swap an instance from one type to another.

See Also

Family Class
Autodesk.Revit.Elements Namespace

FamilyBase Class

[image]