Revit 2010 API
FamilyItemFactory..::.NewElectricalConnector Method
FamilyItemFactory Class See Also Send Feedback
Add a new Electrical connector into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElectricalConnector NewElectricalConnector(
    Reference planarFaceReference,
    ElectricalSystemType systemType
)
Visual Basic (Declaration)
Public Function NewElectricalConnector ( _
    planarFaceReference As Reference, _
    systemType As ElectricalSystemType _
) As ElectricalConnector
Visual C++
public:
ElectricalConnector^ NewElectricalConnector(
    Reference^ planarFaceReference,
    ElectricalSystemType systemType
)

Parameters

planarFaceReference
Type: Autodesk.Revit.Geometry..::.Reference
A reference to a planar face where the connector will be placed.
systemType
Type: Autodesk.Revit.MEP.Enums..::.ElectricalSystemType
Indicates the system type of this new Electrical connector.

Return Value

If creation was successful the new Electrical Connector is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates an Electrical Connector in a family document. The electrical connector will be placed at the centroid of the planar face.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the argument planarFaceReference is invalid.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace

NewExtrusion Method

[image]