Revit 2010 API
Application..::.NewFamilyInstanceCreationData Method (Face, XYZ, XYZ, FamilySymbol)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Face face,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    face As Face, _
    location As XYZ, _
    referenceDirection As XYZ, _
    symbol As FamilySymbol _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    Face^ face,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.Geometry..::.Face
A face of a geometry object.
location
Type: Autodesk.Revit.Geometry..::.XYZ
Point on the face where the instance is to be placed.
referenceDirection
Type: Autodesk.Revit.Geometry..::.XYZ
A vector that defines the direction of the family instance.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace

NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Element, StructuralType)

[image]