Revit 2010 API
XYZ..::.Normalized Property
XYZ Class See Also Send Feedback
This vector, normalized.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Normalized { get; }
Visual Basic (Declaration)
Public ReadOnly Property Normalized As XYZ
Visual C++
public:
property XYZ^ Normalized {
    XYZ^ get ();
}

Remarks

Normalized indicates that the length of this vector equals one, in other words, that this is a unit vector.

Exceptions

Exception | Condition
System..::.DivideByZeroException | Thrown when the length of this vector is zero.
System..::.InvalidOperationException | Thrown when an error occurs in normalization.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace

X Property

[image]