Revit 2010 API
APIObject Class
Members See Also Send Feedback
Supports all objects in the Autodesk Revit API hierarchy.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class APIObject : IDisposable
Visual Basic (Declaration)
Public Class APIObject _
    Implements IDisposable
Visual C++
public ref class APIObject : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Application
Autodesk.Revit.Areas..::.BoundarySegment
Autodesk.Revit.Areas..::.BoundarySegmentArray
Autodesk.Revit.Areas..::.BoundarySegmentArrayArray
Autodesk.Revit.Areas..::.BoundarySegmentArrayArrayIterator
Autodesk.Revit.Areas..::.BoundarySegmentArrayIterator
Autodesk.Revit..::.Category
Autodesk.Revit..::.CategoryNameMap
Autodesk.Revit..::.CategoryNameMapIterator
Autodesk.Revit..::.CategorySet
Autodesk.Revit..::.CategorySetIterator
Autodesk.Revit.Collections..::.Array
Autodesk.Revit.Collections..::.ArrayIterator
Autodesk.Revit.Collections..::.DefinitionBindingMap
Autodesk.Revit.Collections..::.DefinitionBindingMapIterator
Autodesk.Revit.Collections..::.Map
Autodesk.Revit.Collections..::.MapIterator
Autodesk.Revit.Collections..::.Set
Autodesk.Revit.Collections..::.SetIterator
Autodesk.Revit.Collections..::.StringStringMap
Autodesk.Revit.Collections..::.StringStringMapIterator
Autodesk.Revit..::.Color
Autodesk.Revit.Creation..::.Application
Autodesk.Revit.Creation..::.Filter
Autodesk.Revit.Creation..::.ItemFactoryBase
Autodesk.Revit..::.DimensionSegment
Autodesk.Revit..::.DimensionSegmentArray
Autodesk.Revit..::.DimensionSegmentArrayIterator
Autodesk.Revit..::.Document
Autodesk.Revit..::.DocumentSet
Autodesk.Revit..::.DocumentSetIterator
Autodesk.Revit.Editor..::.SlabShapeCreaseArray
Autodesk.Revit.Editor..::.SlabShapeCreaseArrayIterator
Autodesk.Revit.Editor..::.SlabShapeVertexArray
Autodesk.Revit.Editor..::.SlabShapeVertexArrayIterator
Autodesk.Revit..::.Element
Autodesk.Revit..::.ElementArray
Autodesk.Revit..::.ElementArrayIterator
Autodesk.Revit..::.ElementIdSet
Autodesk.Revit..::.ElementIdSetIterator
Autodesk.Revit..::.ElementIterator
Autodesk.Revit.Elements..::.CombinableElementArray
Autodesk.Revit.Elements..::.CombinableElementArrayIterator
Autodesk.Revit.Elements..::.CurtainCell
Autodesk.Revit.Elements..::.CurtainCellSet
Autodesk.Revit.Elements..::.CurtainCellSetIterator
Autodesk.Revit.Elements..::.CurtainGrid
Autodesk.Revit.Elements..::.CurtainGridSet
Autodesk.Revit.Elements..::.CurtainGridSetIterator
Autodesk.Revit.Elements..::.CurveByPointsArray
Autodesk.Revit.Elements..::.CurveByPointsArrayIterator
Autodesk.Revit.Elements..::.DetailCurveArray
Autodesk.Revit.Elements..::.DetailCurveArrayIterator
Autodesk.Revit.Elements..::.DividedSurfaceData
Autodesk.Revit.Elements..::.GenericFormSet
Autodesk.Revit.Elements..::.GenericFormSetIterator
Autodesk.Revit.Elements..::.GeomCombinationSet
Autodesk.Revit.Elements..::.GeomCombinationSetIterator
Autodesk.Revit.Elements..::.GroupSet
Autodesk.Revit.Elements..::.GroupSetIterator
Autodesk.Revit.Elements..::.LayoutRule
Autodesk.Revit.Elements..::.LoadCaseArray
Autodesk.Revit.Elements..::.LoadCaseArrayIterator
Autodesk.Revit.Elements..::.LoadCaseSet
Autodesk.Revit.Elements..::.LoadCaseSetIterator
Autodesk.Revit.Elements..::.LoadCombinationArray
Autodesk.Revit.Elements..::.LoadCombinationArrayIterator
Autodesk.Revit.Elements..::.LoadUsageArray
Autodesk.Revit.Elements..::.LoadUsageArrayIterator
Autodesk.Revit.Elements..::.ModelCurveArrArray
Autodesk.Revit.Elements..::.ModelCurveArrArrayIterator
Autodesk.Revit.Elements..::.ModelCurveArray
Autodesk.Revit.Elements..::.ModelCurveArrayIterator
Autodesk.Revit.Elements..::.PhaseArray
Autodesk.Revit.Elements..::.PhaseArrayIterator
Autodesk.Revit.Elements..::.RebarHostData
Autodesk.Revit.Elements..::.ReferencePointArray
Autodesk.Revit.Elements..::.ReferencePointArrayIterator
Autodesk.Revit.Elements..::.SketchSet
Autodesk.Revit.Elements..::.SketchSetIterator
Autodesk.Revit.Elements..::.SpaceSet
Autodesk.Revit.Elements..::.SpaceSetIterator
Autodesk.Revit.Elements..::.SpacingRule
Autodesk.Revit.Elements..::.ViewSet
Autodesk.Revit.Elements..::.ViewSetIterator
Autodesk.Revit.Elements..::.ViewSheetSets
Autodesk.Revit.Elements..::.ViewSheetSetsIterator
Autodesk.Revit..::.ElementSet
Autodesk.Revit..::.ElementSetIterator
Autodesk.Revit.Events..::.DialogBoxData
Autodesk.Revit..::.ExternalApplicationArray
Autodesk.Revit..::.ExternalApplicationArrayIterator
Autodesk.Revit..::.ExternalCommandData
Autodesk.Revit..::.FamilyElementVisibility
Autodesk.Revit..::.FamilyManager
Autodesk.Revit..::.FamilyParameter
Autodesk.Revit..::.FamilyParameterSet
Autodesk.Revit..::.FamilyParameterSetIterator
Autodesk.Revit..::.FamilyType
Autodesk.Revit..::.FamilyTypeSet
Autodesk.Revit..::.FamilyTypeSetIterator
Autodesk.Revit..::.FillPatternSet
Autodesk.Revit..::.FillPatternSetIterator
Autodesk.Revit..::.Filter
Autodesk.Revit..::.FilterCriterion
Autodesk.Revit..::.FormArray
Autodesk.Revit..::.FormArrayIterator
Autodesk.Revit..::.FormatOptions
Autodesk.Revit.Geometry..::.BoundingBoxXYZ
Autodesk.Revit.Geometry..::.CurveArrArray
Autodesk.Revit.Geometry..::.CurveArrArrayIterator
Autodesk.Revit.Geometry..::.CurveArray
Autodesk.Revit.Geometry..::.CurveArrayIterator
Autodesk.Revit.Geometry..::.DoubleArray
Autodesk.Revit.Geometry..::.DoubleArrayIterator
Autodesk.Revit.Geometry..::.EdgeArray
Autodesk.Revit.Geometry..::.EdgeArrayArray
Autodesk.Revit.Geometry..::.EdgeArrayArrayIterator
Autodesk.Revit.Geometry..::.EdgeArrayIterator
Autodesk.Revit.Geometry..::.FaceArray
Autodesk.Revit.Geometry..::.FaceArrayIterator
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.GeometryObjectArray
Autodesk.Revit.Geometry..::.GeometryObjectArrayIterator
Autodesk.Revit.Geometry..::.InstanceArray
Autodesk.Revit.Geometry..::.InstanceArrayIterator
Autodesk.Revit.Geometry..::.IntersectionResult
Autodesk.Revit.Geometry..::.IntersectionResultArray
Autodesk.Revit.Geometry..::.IntersectionResultArrayIterator
Autodesk.Revit.Geometry..::.MeshArray
Autodesk.Revit.Geometry..::.MeshArrayIterator
Autodesk.Revit.Geometry..::.MeshTriangle
Autodesk.Revit.Geometry..::.Options
Autodesk.Revit.Geometry..::.Plane
Autodesk.Revit.Geometry..::.Reference
Autodesk.Revit.Geometry..::.ReferenceArray
Autodesk.Revit.Geometry..::.ReferenceArrayArray
Autodesk.Revit.Geometry..::.ReferenceArrayArrayIterator
Autodesk.Revit.Geometry..::.ReferenceArrayIterator
Autodesk.Revit.Geometry..::.SolidArray
Autodesk.Revit.Geometry..::.SolidArrayIterator
Autodesk.Revit.Geometry..::.Transform
Autodesk.Revit.Geometry..::.UVArray
Autodesk.Revit.Geometry..::.UVArrayIterator
Autodesk.Revit.Geometry..::.XYZArray
Autodesk.Revit.Geometry..::.XYZArrayIterator
Autodesk.Revit..::.Leader
Autodesk.Revit..::.LeaderArray
Autodesk.Revit..::.LeaderArrayIterator
Autodesk.Revit..::.LinePatternSet
Autodesk.Revit..::.LinePatternSetIterator
Autodesk.Revit..::.Location
Autodesk.Revit..::.MaterialSet
Autodesk.Revit..::.MaterialSetIterator
Autodesk.Revit.MEP..::.ConduitTypeSet
Autodesk.Revit.MEP..::.ConduitTypeSetIterator
Autodesk.Revit.MEP..::.Connector
Autodesk.Revit.MEP..::.ConnectorManager
Autodesk.Revit.MEP..::.ConnectorSet
Autodesk.Revit.MEP..::.ConnectorSetIterator
Autodesk.Revit.MEP..::.CorrectionFactor
Autodesk.Revit.MEP..::.CorrectionFactorSet
Autodesk.Revit.MEP..::.CorrectionFactorSetIterator
Autodesk.Revit.MEP..::.DemandFactorData
Autodesk.Revit.MEP..::.DemandFactorDataSet
Autodesk.Revit.MEP..::.DemandFactorDataSetIterator
Autodesk.Revit.MEP..::.DistributionSysTypeSet
Autodesk.Revit.MEP..::.DistributionSysTypeSetIterator
Autodesk.Revit.MEP..::.ElectricalSetting
Autodesk.Revit.MEP..::.ElectricalSystemSet
Autodesk.Revit.MEP..::.ElectricalSystemSetIterator
Autodesk.Revit.MEP..::.GroundConductorSize
Autodesk.Revit.MEP..::.GroundConductorSizeSet
Autodesk.Revit.MEP..::.GroundConductorSizeSetIterator
Autodesk.Revit.MEP..::.InsulationTypeSet
Autodesk.Revit.MEP..::.InsulationTypeSetIterator
Autodesk.Revit.MEP..::.MEPModel
Autodesk.Revit.MEP..::.TemperatureRatingTypeSet
Autodesk.Revit.MEP..::.TemperatureRatingTypeSetIterator
Autodesk.Revit.MEP..::.VoltageTypeSet
Autodesk.Revit.MEP..::.VoltageTypeSetIterator
Autodesk.Revit.MEP..::.WireMaterialTypeSet
Autodesk.Revit.MEP..::.WireMaterialTypeSetIterator
Autodesk.Revit.MEP..::.WireSet
Autodesk.Revit.MEP..::.WireSetIterator
Autodesk.Revit.MEP..::.WireSize
Autodesk.Revit.MEP..::.WireSizeSet
Autodesk.Revit.MEP..::.WireSizeSetIterator
Autodesk.Revit.MEP..::.WireTypeSet
Autodesk.Revit.MEP..::.WireTypeSetIterator
Autodesk.Revit.Options..::.Application
Autodesk.Revit..::.PaperSize
Autodesk.Revit..::.PaperSizeSet
Autodesk.Revit..::.PaperSizeSetIterator
Autodesk.Revit..::.PaperSource
Autodesk.Revit..::.PaperSourceSet
Autodesk.Revit..::.PaperSourceSetIterator
Autodesk.Revit..::.Parameter
Autodesk.Revit..::.ParameterMap
Autodesk.Revit..::.ParameterMapIterator
Autodesk.Revit.Parameters..::.Binding
Autodesk.Revit.Parameters..::.Definition
Autodesk.Revit.Parameters..::.DefinitionFile
Autodesk.Revit.Parameters..::.DefinitionGroup
Autodesk.Revit.Parameters..::.DefinitionGroupsBase
Autodesk.Revit.Parameters..::.DefinitionGroupsBaseIterator
Autodesk.Revit.Parameters..::.DefinitionsBase
Autodesk.Revit.Parameters..::.DefinitionsBaseIterator
Autodesk.Revit.Parameters..::.ParameterListItem
Autodesk.Revit.Parameters..::.ParameterListItemArray
Autodesk.Revit.Parameters..::.ParameterListItemArrayIterator
Autodesk.Revit..::.ParameterSet
Autodesk.Revit..::.ParameterSetIterator
Autodesk.Revit..::.ParameterStorage
Autodesk.Revit..::.PlanCircuit
Autodesk.Revit..::.PlanCircuitSet
Autodesk.Revit..::.PlanCircuitSetIterator
Autodesk.Revit..::.PlanTopology
Autodesk.Revit..::.PlanTopologySet
Autodesk.Revit..::.PlanTopologySetIterator
Autodesk.Revit..::.PostedError
Autodesk.Revit..::.PostedErrorArray
Autodesk.Revit..::.PostedErrorArrayIterator
Autodesk.Revit..::.PrintManager
Autodesk.Revit..::.PrintParameters
Autodesk.Revit..::.PrintSetup
Autodesk.Revit..::.RibbonItem
Autodesk.Revit..::.RibbonPanel
Autodesk.Revit.Rooms..::.BoundarySegment
Autodesk.Revit.Rooms..::.BoundarySegmentArray
Autodesk.Revit.Rooms..::.BoundarySegmentArrayArray
Autodesk.Revit.Rooms..::.BoundarySegmentArrayArrayIterator
Autodesk.Revit.Rooms..::.BoundarySegmentArrayIterator
Autodesk.Revit..::.Selection
Autodesk.Revit..::.Settings
Autodesk.Revit.Site..::.City
Autodesk.Revit.Site..::.CitySet
Autodesk.Revit.Site..::.CitySetIterator
Autodesk.Revit.Site..::.ProjectLocationSet
Autodesk.Revit.Site..::.ProjectLocationSetIterator
Autodesk.Revit.Site..::.ProjectPosition
Autodesk.Revit.Spaces..::.BoundarySegment
Autodesk.Revit.Spaces..::.BoundarySegmentArray
Autodesk.Revit.Spaces..::.BoundarySegmentArrayArray
Autodesk.Revit.Spaces..::.BoundarySegmentArrayArrayIterator
Autodesk.Revit.Spaces..::.BoundarySegmentArrayIterator
Autodesk.Revit.Structural..::.AnalyticalModel
Autodesk.Revit.Structural..::.AnalyticalSupportData
Autodesk.Revit.Structural..::.AnalyticalSupportInfo
Autodesk.Revit.Structural..::.AnalyticalSupportInfoArray
Autodesk.Revit.Structural..::.AnalyticalSupportInfoArrayIterator
Autodesk.Revit.Structural..::.BarDescription
Autodesk.Revit.Structural..::.CompoundStructure
Autodesk.Revit.Structural..::.CompoundStructureLayer
Autodesk.Revit.Structural..::.CompoundStructureLayerArray
Autodesk.Revit.Structural..::.CompoundStructureLayerArrayIterator
Autodesk.Revit..::.SuspendUpdating
Autodesk.Revit..::.SweepProfile
Autodesk.Revit.Symbols..::.AnnotationSymbolTypeSet
Autodesk.Revit.Symbols..::.AnnotationSymbolTypeSetIterator
Autodesk.Revit.Symbols..::.AreaLoadTypeSet
Autodesk.Revit.Symbols..::.AreaLoadTypeSetIterator
Autodesk.Revit.Symbols..::.AreaTagTypeSet
Autodesk.Revit.Symbols..::.AreaTagTypeSetIterator
Autodesk.Revit.Symbols..::.BeamSystemTypeSet
Autodesk.Revit.Symbols..::.BeamSystemTypeSetIterator
Autodesk.Revit.Symbols..::.ContFootingTypeSet
Autodesk.Revit.Symbols..::.ContFootingTypeSetIterator
Autodesk.Revit.Symbols..::.CurtainSystemTypeSet
Autodesk.Revit.Symbols..::.CurtainSystemTypeSetIterator
Autodesk.Revit.Symbols..::.DimensionTypeSet
Autodesk.Revit.Symbols..::.DimensionTypeSetIterator
Autodesk.Revit.Symbols..::.FamilySymbolSet
Autodesk.Revit.Symbols..::.FamilySymbolSetIterator
Autodesk.Revit.Symbols..::.FasciaTypeSet
Autodesk.Revit.Symbols..::.FasciaTypeSetIterator
Autodesk.Revit.Symbols..::.FloorTypeSet
Autodesk.Revit.Symbols..::.FloorTypeSetIterator
Autodesk.Revit.Symbols..::.GridTypeSet
Autodesk.Revit.Symbols..::.GridTypeSetIterator
Autodesk.Revit.Symbols..::.GutterTypeSet
Autodesk.Revit.Symbols..::.GutterTypeSetIterator
Autodesk.Revit.Symbols..::.LevelTypeSet
Autodesk.Revit.Symbols..::.LevelTypeSetIterator
Autodesk.Revit.Symbols..::.LineLoadTypeSet
Autodesk.Revit.Symbols..::.LineLoadTypeSetIterator
Autodesk.Revit.Symbols..::.LoadTypeBaseSet
Autodesk.Revit.Symbols..::.LoadTypeBaseSetIterator
Autodesk.Revit.Symbols..::.MEPBuildingConstructionSet
Autodesk.Revit.Symbols..::.MEPBuildingConstructionSetIterator
Autodesk.Revit.Symbols..::.MullionTypeSet
Autodesk.Revit.Symbols..::.MullionTypeSetIterator
Autodesk.Revit.Symbols..::.PanelTypeSet
Autodesk.Revit.Symbols..::.PanelTypeSetIterator
Autodesk.Revit.Symbols..::.PointLoadTypeSet
Autodesk.Revit.Symbols..::.PointLoadTypeSetIterator
Autodesk.Revit.Symbols..::.RebarBarTypeSet
Autodesk.Revit.Symbols..::.RebarBarTypeSetIterator
Autodesk.Revit.Symbols..::.RebarCoverTypeSet
Autodesk.Revit.Symbols..::.RebarCoverTypeSetIterator
Autodesk.Revit.Symbols..::.RebarHookTypeSet
Autodesk.Revit.Symbols..::.RebarHookTypeSetIterator
Autodesk.Revit.Symbols..::.RebarShapeDefinition
Autodesk.Revit.Symbols..::.RebarShapeSet
Autodesk.Revit.Symbols..::.RebarShapeSetIterator
Autodesk.Revit.Symbols..::.RoofTypeSet
Autodesk.Revit.Symbols..::.RoofTypeSetIterator
Autodesk.Revit.Symbols..::.RoomTagTypeSet
Autodesk.Revit.Symbols..::.RoomTagTypeSetIterator
Autodesk.Revit.Symbols..::.SlabEdgeTypeSet
Autodesk.Revit.Symbols..::.SlabEdgeTypeSetIterator
Autodesk.Revit.Symbols..::.SpaceTagTypeSet
Autodesk.Revit.Symbols..::.SpaceTagTypeSetIterator
Autodesk.Revit.Symbols..::.SpotDimensionTypeSet
Autodesk.Revit.Symbols..::.SpotDimensionTypeSetIterator
Autodesk.Revit.Symbols..::.TextNoteTypeSet
Autodesk.Revit.Symbols..::.TextNoteTypeSetIterator
Autodesk.Revit.Symbols..::.TrussTypeSet
Autodesk.Revit.Symbols..::.TrussTypeSetIterator
Autodesk.Revit.Symbols..::.WallTypeSet
Autodesk.Revit.Symbols..::.WallTypeSetIterator
Autodesk.Revit..::.TilePatterns
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetSet
Autodesk.Revit.Utility..::.AssetSetIterator
Autodesk.Revit..::.VertexIndexPairArray
Autodesk.Revit..::.VertexIndexPairArrayIterator
Autodesk.Revit..::.ViewSheetSetting

See Also

APIObject Members
Autodesk.Revit Namespace

APIObject Members

[image] [image]