Revit 2010 API
Curve Class
Members See Also Send Feedback
A parametric curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Curve : GeometryObject
Visual Basic (Declaration)
Public Class Curve _
    Inherits GeometryObject
Visual C++
public ref class Curve : public GeometryObject

Remarks

The concrete curves are defined by parametric equations. If the curve is bound, it is only defined for an interval in parametrization. Otherwise, it is defined for all values of the parameter.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Curve
Autodesk.Revit.Geometry..::.Arc
Autodesk.Revit.Geometry..::.Ellipse
Autodesk.Revit.Geometry..::.HermiteSpline
Autodesk.Revit.Geometry..::.Line
Autodesk.Revit.Geometry..::.NurbSpline

See Also

Curve Members
Autodesk.Revit.Geometry Namespace

Curve Members

[image] [image]