Revit 2010 API
EdgeArray..::.Insert Method
EdgeArray Class See Also Send Feedback
Insert the specified edge into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    Edge item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Edge, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Edge^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.Edge
The edge to be inserted into the array.
index
Type: System..::.Int32
The edge will be inserted before this index.

Return Value

Returns whether the edge was inserted into the array.

See Also

EdgeArray Class
Autodesk.Revit.Geometry Namespace

ReverseIterator Method

[image]