Revit 2010 API
Application..::.NewFamilySymbolProfile Method
Application Class See Also Send Feedback
Creates a new FamilySymbolProfile object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbolProfile NewFamilySymbolProfile(
    FamilySymbol familySymbol
)
Visual Basic (Declaration)
Public Function NewFamilySymbolProfile ( _
    familySymbol As FamilySymbol _
) As FamilySymbolProfile
Visual C++
public:
FamilySymbolProfile^ NewFamilySymbolProfile(
    FamilySymbol^ familySymbol
)

Parameters

familySymbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
The family symbol of the Profile.

Return Value

The new FamilySymbolProfile object.

Remarks

Use the return of this methods as NewSweep and NewSweptBlend to create generic forms.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the argument fmailySymbol is Null.

See Also

Application Class
Autodesk.Revit.Creation Namespace

NewFBXExportOptions Method

[image]