Revit 2010 API
XYZ..::.Dot Method
XYZ Class See Also Send Feedback
The dot product of this vector and the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Dot(
    XYZ source
)
Visual Basic (Declaration)
Public Function Dot ( _
    source As XYZ _
) As Double
Visual C++
public:
double Dot(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to multiply with this vector.

Return Value

The real number equal to the dot product.

Remarks

The dot product is the sum of the respective coordinates of the two vectors: Vx*Wx + Vy*Wy + Vz*Wz. Also known as scalar product or inner product.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace

Multiply Method

[image] [image]