Revit 2010 API
ElectricalSetting..::.RemoveVoltageType Method
ElectricalSetting Class See Also Send Feedback
Remove the voltage type from project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveVoltageType(
    VoltageType voltageType
)
Visual Basic (Declaration)
Public Sub RemoveVoltageType ( _
    voltageType As VoltageType _
)
Visual C++
public:
void RemoveVoltageType(
    VoltageType^ voltageType
)

Parameters

voltageType
Type: Autodesk.Revit.MEP..::.VoltageType
Specify the voltage type to be removed.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Voltage type can be removed only if it isn't in service with any distribution systems.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace

RemoveWireMaterialType Method

[image]