Revit 2010 API
ElectricalSetting Class
Members See Also Send Feedback
An object that represents electrical information within the Autodesk Revit project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ElectricalSetting : APIObject
Visual Basic (Declaration)
Public Class ElectricalSetting _
    Inherits APIObject
Visual C++
public ref class ElectricalSetting : public APIObject

Remarks

ElectricalSetting includes voltage type, distribution system type, wire type, and demand factor setting. All basic operations of these electrical elements are supported.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.ElectricalSetting

See Also

ElectricalSetting Members
Autodesk.Revit.MEP Namespace

ElectricalSetting Members

[image] [image]