Revit 2010 API
AreaReinforcementCurve Class
Members Example See Also Send Feedback
An object that specifies the type of a floor in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AreaReinforcementCurve : Element
Visual Basic (Declaration)
Public Class AreaReinforcementCurve _
    Inherits Element
Visual C++
public ref class AreaReinforcementCurve : public Element

Remarks

The structural layers of the floor can be accessed via this object.

Examples

CopyC#
public void GetInfo_AreaReinforcementCurve(AreaReinforcement areaReinforcement)
{
    string message = "Area Reinforcement Curves : ";

    // Get area reinforcement curves by iterating the Curves property
    foreach (Element ii in areaReinforcement.Curves)
    {
        AreaReinforcementCurve areaReinforcementCurve = ii as AreaReinforcementCurve;
        if (null == areaReinforcementCurve)
        {
            continue;
        }
        Autodesk.Revit.Geometry.Curve curve = areaReinforcementCurve.Curve;

        // Get curve start point
        message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
                       + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        // Get curve end point
        message += "\nCurve end point:(" + curve.get_EndPoint(1).X + ", "
                       + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
    }

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_AreaReinforcementCurve(ByVal areaReinforcement As AreaReinforcement)
    Dim message As String = "Area Reinforcement Curves : "

    ' Get area reinforcement curves by iterating the Curves property
    For Each ii As Autodesk.Revit.Element In areaReinforcement.Curves
        Dim areaReinforcementCurve As AreaReinforcementCurve = TryCast(ii, AreaReinforcementCurve)
        If areaReinforcementCurve Is Nothing Then
            Continue For
        End If
        Dim curve As Autodesk.Revit.Geometry.Curve = areaReinforcementCurve.Curve

        ' Get curve start point
        message += ((vbLf & "Curve start point:(" & curve.EndPoint(0).X & ", ") + curve.EndPoint(0).Y & ", ") + curve.EndPoint(0).Z & ")"
        ' Get curve end point
        message += ((vbLf & "Curve end point:(" & curve.EndPoint(1).X & ", ") + curve.EndPoint(1).Y & ", ") + curve.EndPoint(1).Z & ")"
    Next

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.AreaReinforcementCurve

See Also

AreaReinforcementCurve Members
Autodesk.Revit.Elements Namespace

AreaReinforcementCurve Members

[image] [image]