Revit 2010 API
Document..::.NewRoomTag Method
Document Class Example See Also Send Feedback
Creates a new RoomTag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RoomTag NewRoomTag(
    Room room,
    UV point,
    View view
)
Visual Basic (Declaration)
Public Function NewRoomTag ( _
    room As Room, _
    point As UV, _
    view As View _
) As RoomTag
Visual C++
public:
RoomTag^ NewRoomTag(
    Room^ room,
    UV^ point,
    View^ view
)

Parameters

room
Type: Autodesk.Revit.Elements..::.Room
The Room which the tag refers.
point
Type: Autodesk.Revit.Geometry..::.UV
A 2D point that dictates the location on the level of the room.
view
Type: Autodesk.Revit.Elements..::.View
The view where the tag will lie.

Return Value

If successful a RoomTag object will be returned, otherwise nothing. Suitable exceptions will be fired if the parameters are invalid.

Examples

CopyC#
RoomTag CreateRoomTag(Autodesk.Revit.Document document, Room room)
{
    // Create a UV structure which determine the room tag location
    UV roomTagLocation = new UV(0, 0);

    // Create a new room tag in the created room
    RoomTag roomTag = document.Create.NewRoomTag(room, roomTagLocation, null);
    if (null == roomTag)
    {
        throw new Exception("Create a new room tag failed.");
    }

    // Give the user some information
    MessageBox.Show("Room tag created successfully.", "Revit");

    return roomTag;
}
CopyVB.NET
Private Function CreateRoomTag(ByVal document As Autodesk.Revit.Document, ByVal room As Room) As Autodesk.Revit.Elements.RoomTag
    ' Create a UV structure which determine the room tag location
    Dim roomTagLocation As New Autodesk.Revit.Geometry.UV(0, 0)

    ' Create a new room tag in the created room
    Dim roomTag As Autodesk.Revit.Elements.RoomTag = document.Create.NewRoomTag(room, roomTagLocation, Nothing)
    If roomTag Is Nothing Then
        Throw New Exception("Create a new room tag failed.")
    End If

    ' Give the user some information
    MessageBox.Show("Room tag created successfully.", "Revit")

    Return roomTag
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewSketchPlane Method

[image] [image]