Revit 2010 API
ReferenceArray..::.Insert Method
ReferenceArray Class See Also Send Feedback
Insert the specified reference into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    Reference item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Reference, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Reference^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.Reference
The reference to be inserted into the array.
index
Type: System..::.Int32
The reference will be inserted before this index.

Return Value

Returns whether the reference was inserted into the array.

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace

ReverseIterator Method

[image]