Revit 2010 API
DialogBoxData Class
Members See Also Send Feedback
An object that is passed to your application when a dialog is displayed in Revit.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DialogBoxData : APIObject
Visual Basic (Declaration)
Public Class DialogBoxData _
    Inherits APIObject
Visual C++
public ref class DialogBoxData : public APIObject

Remarks

When the application receives this object, a dialog has been displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Events..::.DialogBoxData
Autodesk.Revit.Events..::.MessageBoxData

See Also

DialogBoxData Members
Autodesk.Revit.Events Namespace

DialogBoxData Members

[image] [image]