Revit 2010 API
FamilyInstance..::.Space Property
FamilyInstance Class See Also Send Feedback
The space in which the instance is located (during the last phase of the project).

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Space Space { get; }
Visual Basic (Declaration)
Public ReadOnly Property Space As Space
Visual C++
public:
property Space^ Space {
    Space^ get ();
}

Remarks

This property will be the first space encountered that contains the instance. If more than one space includes this point in its volume only the first one is returned. If no space is found that contains the instance, this property is NULL.

See Also

FamilyInstance Class
Space Overload
Autodesk.Revit.Elements Namespace

Space Property (Phase)

[image]