Revit 2010 API
ReferencePoint..::.SetPointElementReference Method
ReferencePoint Class See Also Send Feedback
Change the rule for computing the location of the ReferencePoint relative to other elements in the document.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetPointElementReference(
    PointElementReference pointElementReference
)
Visual Basic (Declaration)
Public Sub SetPointElementReference ( _
    pointElementReference As PointElementReference _
)
Visual C++
public:
void SetPointElementReference(
    PointElementReference^ pointElementReference
)

Parameters

pointElementReference
Type: Autodesk.Revit.Elements..::.PointElementReference
An object specifying a rule for the location and orientation of a ReferencePoint. (Note: The ReferencePoint object does not store the pointElementReference object after this call.)

Remarks

pointElementReference may be null, in which case the ReferencePoint does not follow any other element. When Reference is changed from null to a non-null value, the point moves and rotates to the prescribed location and orientation. Where the coordinate system has some freedom, it will remain as close to the old orientation as possible. When the reference is set to null, the point does not move or rotate.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when Reference is set to a non-null object, and the ReferencePoint is unable to move to the new reference.

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace

SetVisibility Method

[image]