Revit 2010 API
Document..::.NewPointLoad Method (Reference, XYZ, XYZ, Boolean, PointLoadType, SketchPlane)
Document Class See Also Send Feedback
Creates a new hosted point load within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PointLoad NewPointLoad(
    Reference reference,
    XYZ force,
    XYZ moment,
    bool isReaction,
    PointLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewPointLoad ( _
    reference As Reference, _
    force As XYZ, _
    moment As XYZ, _
    isReaction As Boolean, _
    symbol As PointLoadType, _
    plane As SketchPlane _
) As PointLoad
Visual C++
public:
PointLoad^ NewPointLoad(
    Reference^ reference,
    XYZ^ force,
    XYZ^ moment,
    bool isReaction,
    PointLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

reference
Type: Autodesk.Revit.Geometry..::.Reference
The Geometry reference to Beam's, Brace's, Column's, analytical line's end.
force
Type: Autodesk.Revit.Geometry..::.XYZ
The 3d force.
moment
Type: Autodesk.Revit.Geometry..::.XYZ
The 3d moment.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.Symbols..::.PointLoadType
The symbol of the PointLoad.
plane
Type: Autodesk.Revit.Elements..::.SketchPlane
Indicate the work plane of the PointLoad.

Return Value

If successful, NewPointLoad returns an object for the newly created PointLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
NewPointLoad Overload
Autodesk.Revit.Creation Namespace

NewPointLoad Method (XYZ, XYZ, XYZ, Boolean, PointLoadType, SketchPlane)

[image]