Revit 2010 API
AnalyticalModelProfile Class
Members See Also Send Feedback
Represents an extruded profile.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AnalyticalModelProfile : AnalyticalModel
Visual Basic (Declaration)
Public Class AnalyticalModelProfile _
    Inherits AnalyticalModel
Visual C++
public ref class AnalyticalModelProfile : public AnalyticalModel

Remarks

Elements, such as beams, may be formed from a profile that has been swept along a curve. This analytical model represents such a form and is used to access the cross section and the underlying curve that make up the element.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Structural..::.AnalyticalModel
Autodesk.Revit.Structural..::.AnalyticalModelProfile

See Also

AnalyticalModelProfile Members
Autodesk.Revit.Structural Namespace

AnalyticalModelProfile Members

[image] [image]