Revit 2010 API
FamilyManager..::.Parameter Property (Definition)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given definition.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyParameter Parameter[
    Definition definition
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    definition As Definition _
) As FamilyParameter
Visual C++
public:
property FamilyParameter^ Parameter[Definition^ definition] {
    FamilyParameter^ get (Definition^ definition);
}

Parameters

definition
Type: Autodesk.Revit.Parameters..::.Definition

Remarks

Returns null if the parameter is not found.

See Also

FamilyManager Class
Parameter Overload
Autodesk.Revit Namespace

Parameter Property (Guid)

[image]