Revit 2010 API
ParameterStorage..::.AsString Method
ParameterStorage Class See Also Send Feedback
Provides access to the string contents of the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual string AsString()
Visual Basic (Declaration)
Public Overridable Function AsString As String
Visual C++
public:
virtual String^ AsString()

Return Value

The string contained in the parameter.

Remarks

The AsString method should only be used if the StorageType property returns that the internal contents of the parameter is a string.

Exceptions

Exception | Condition
InvalidOperationException..::.InvalidOperationException()()() | Thrown when the StorageType is not String

See Also

ParameterStorage Class
Autodesk.Revit Namespace

Set Method

[image] [image]