Revit 2010 API
Document..::.NewFamilyInstance Method (XYZ, FamilySymbol, Element, Level, StructuralType)
Document Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the instance is to be placed on the specified level.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit..::.Element
A host object into which the instance will be embedded
level
Type: Autodesk.Revit.Elements..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise Nothing.

Remarks

This form of NewFamilyInstance is the most commonly used in Autodesk Revit since there are a large number of elements that use levels, such as Walls, Columns etc. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

All levels within the document can be found by iterating over the entire document and searching for objects of type Autodesk.Revit.Elements.Level.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Examples

CopyC#
void CreateDoorsInWall(Autodesk.Revit.Document document, Wall wall)
{
    String fileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Doors\Single-Decorative 2.rfa";

    Family family = null;
    if (!document.LoadFamily(fileName, out family))
    {
        throw new Exception("Unable to load " + fileName);
    }

    // get the active view's level for beam creation
    Level level = document.Application.ActiveDocument.ActiveView.Level;

    FamilySymbolSetIterator symbolItor = family.Symbols.ForwardIterator();
    double x = 0, y = 0, z = 0;
    while (symbolItor.MoveNext())
    {
        FamilySymbol symbol = symbolItor.Current as FamilySymbol;
        XYZ location = new XYZ(x, y, z);
        FamilyInstance instance = document.Create.NewFamilyInstance(location, symbol, wall, level, StructuralType.NonStructural);
        x += 10;
        y += 10;
        z += 1.5;
    }
}
CopyVB.NET
Private Sub CreateDoorsInWall(ByVal document As Autodesk.Revit.Document, ByVal wall As Wall)
    Dim fileName As String = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Doors\Single-Decorative 2.rfa"

    Dim family As Autodesk.Revit.Elements.Family = Nothing
    If Not document.LoadFamily(fileName, family) Then
        Throw New Exception("Unable to load " & fileName)
    End If

    ' get the active view's level for beam creation
    Dim level As Autodesk.Revit.Elements.Level = document.Application.ActiveDocument.ActiveView.Level

    Dim symbolItor As FamilySymbolSetIterator = family.Symbols.ForwardIterator()
    Dim x As Double = 0, y As Double = 0, z As Double = 0
    While symbolItor.MoveNext()
        Dim symbol As Autodesk.Revit.Symbols.FamilySymbol = TryCast(symbolItor.Current, Autodesk.Revit.Symbols.FamilySymbol)
        Dim location As New Autodesk.Revit.Geometry.XYZ(x, y, z)
        Dim instance As Autodesk.Revit.Elements.FamilyInstance = document.Create.NewFamilyInstance(location, symbol, wall, level, StructuralType.NonStructural)
        x += 10
        y += 10
        z += 1.5
    End While
End Sub

See Also

Document Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace

NewFascia Method

[image] [image]