Revit 2010 API
Document..::.Export Method
Document Class See Also Send Feedback
Exports the document to another file format.

Overload List

Name | Description
Export(String, String, GBXMLExportOptions) | Exports the document in Green-Building XML format.
Export(String, String, ViewSet, DGNExportOptions) | Exports the current view or a selection of views in DGN format.
Export(String, String, ViewSet, DWF2DExportOptions) | Exports the current view or a selection of views in DWF-2D format.
Export(String, String, ViewSet, DWF3DExportOptions) | Exports the current view or a selection of views in DWF-3D format.
Export(String, String, ViewSet, DWFX2DExportOptions) | Exports the current view or a selection of views in DWFX-2D format.
Export(String, String, ViewSet, DWFX3DExportOptions) | Exports the current view or a selection of views in DWFX-3D format.
Export(String, String, ViewSet, DWGExportOptions) | Exports the current view or a selection of views in DWG format.
Export(String, String, ViewSet, FBXExportOptions) | Exports the document in 3D-Studio Max (FBX) format.
Export(String, String, View3D, ViewPlan, BuildingSiteExportOptions) | Exports the document in the format of Civil Engineering design applications.

See Also

Document Class
Document Members
Autodesk.Revit Namespace

Export Method (String, String, GBXMLExportOptions)

[image]