Revit 2010 API
ControlledApplication..::.DocumentCreated Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentCreatedEventArgs> DocumentCreated
Visual Basic (Declaration)
Public Event DocumentCreated As EventHandler(Of DocumentCreatedEventArgs)
Visual C++
public:
 event EventHandler<DocumentCreatedEventArgs^>^ DocumentCreated {
    void add (EventHandler<DocumentCreatedEventArgs^>^ value);
    void remove (EventHandler<DocumentCreatedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished creating a new document. It is raised even when document creation failed or was cancelled (during DocumentCreating event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not. This event is not cancellable, for the process of document creation has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

The DocumentCreated event is meant to replace the older OnDocumentNewed event, which is now Obsolete.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace

DocumentCreating Event

[image]