Revit 2010 API
RebarShape..::.Definition Property
RebarShape Class See Also Send Feedback
Get the shape definition object associated with this shape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RebarShapeDefinition Definition { get; }
Visual Basic (Declaration)
Public ReadOnly Property Definition As RebarShapeDefinition
Visual C++
public:
property RebarShapeDefinition^ Definition {
    RebarShapeDefinition^ get ();
}

Remarks

Returns null until one of the factory methods (e.g. NewDefinitionBySegments()) is called.

See Also

RebarShape Class
Autodesk.Revit.Symbols Namespace

HookAngle Property

[image]