Revit 2010 API
InstanceArray..::.Item Property
InstanceArray Class See Also Send Feedback
Gets or sets an instance at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Instance Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Instance
Visual C++
public:
virtual property Instance^ Item[int index] {
    Instance^ get (int index);
    void set (int index, Instance^ value);
}

Parameters

index
Type: System..::.Int32
The index of the instance to be set or retrieved.

Return Value

Returns the instance at the specified index.

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace

Size Property

[image]