Revit 2010 API
LogicOrFilter Class
Members See Also Send Feedback
The LogicOrFilter is used to implement Logic-OR operation of Filters.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LogicOrFilter : Filter
Visual Basic (Declaration)
Public Class LogicOrFilter _
    Inherits Filter
Visual C++
public ref class LogicOrFilter : public Filter

Remarks

This filter represents a combined filter consists of two sub-filters by Logic-OR relationship, use it to filter elements which satisfy one of two sub-filters.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Filter
Autodesk.Revit..::.LogicOrFilter

See Also

LogicOrFilter Members
Autodesk.Revit Namespace

LogicOrFilter Members

[image] [image]