Revit 2010 API
Document Members
Document Class Constructors Methods Properties Events See Also Send Feedback

The Document type exposes the following members.

Constructors

Name | Description
Document | For Internal Use Only.

Methods

Name | Description
AbortTransaction | Aborts a transaction for specified document.
Array | Overloaded. Creates an array of one or more elements.
ArrayWithoutAssociate | Overloaded. Creates an array of one or more elements where the elements created will not be grouped and associated.
BeginTransaction | Overloaded. Begins a transaction to encompass a set of changes.
Close | Overloaded. Closes the document.
CombineElements | Combine a set of combinable elements into a geometry combination.
Delete | Overloaded. Deletes one or more elements from the document.
EditFamily | Edits a family loaded in the document.
EndTransaction | Overloaded. Ends a transaction with an attempt to commit the set of changes.
Export | Overloaded. Exports the document to another file format.
FindReferencesByDirection | Finds the references that intersect a line extended in a certain direction from an origin point.
GetRoomAtPoint | Overloaded. Gets a room containing the point.
GetSpaceAtPoint | Overloaded. Gets a space containing the point.
Import | Overloaded. Imports the contents of an external file into the document.
LoadFamily | Overloaded. Loads a family and all its types/symbols.
LoadFamilySymbol | Overloaded. Loads only a specified family type/symbol from a family file into the document.
Mirror | Overloaded. Mirrors one or more elements.
Move | Overloaded. Moves one or more elements within the document by a specified vector.
Print | Overloaded. Prints a set of views.
Rotate | Overloaded. Rotates one or more elements within the document by a specified number of degrees around a given axis.
Save | Overloaded. Saves the document.
SaveAs | Overloaded. Saves the document to a new file name.
SeparateElements | Separate a set of combinable elements out of combinations they currently belong to.
ShowElements | Overloaded. Shows one or more elements by zoom to fit.

Properties

Name | Description
ActiveProjectLocation | Retrieve the active project location.
ActiveView | The document's active view.
AnnotationSymbolTypes | Retrieves an object that contains all the annotation types that are currently loaded into the project.
Application | Returns the Application in which the Document resides.
BeamSystemTypes | Retrieves an object that contains all of beam system types that are currently loaded into the project.
ContFootingTypes | Retrieves an object that contains all of continuous footing types that are currently loaded into the project.
Create | An object that can be used to create new instances of Autodesk Revit API elements within a project.
CurtainSystemTypes | This property is used to retrieve all the CurtainSystem types in current system.
DeckProfiles | Returns an object that contains all of the avaible deck profiles currently loaded to this project.
DimensionTypes | Retrieves an object that contains all of dimension types that are currently loaded into the project.
DisplayUnitSystem | Provides access to display unit type with in the document.
ElectricalEquipmentTypes | Returns an object that contains all of the avaible electrical equipment types currently loaded to this project.
Element | Overloaded. Retrieves an element from the document given an identifier.
Elements | Overloaded. Provides access to a set of elements from the document.
FamilyCreate | An object that can be used to create new instances of Autodesk Revit API elements within a family document.
FamilyManager | The family manager object provides access to family types and parameters.
FasciaTypes | Retrieves an object that contains all the Fascia types that are currently loaded into the project.
FilterTypeSupported | Boolean value which indicates whether the specified builtin parameter supports the specifed filter type.
FloorTypes | Retrieves an object that contains all the floor types that are currently loaded into the project.
GridTypes | Retrieves an object that contains all of Grid types that are currently loaded into the project.
GutterTypes | Retrieves an object that contains all the Gutter types that are currently loaded into the project.
IsFamilyDocument | Identifies if the current document is a family document.
IsModifiable | The document's state of modifiability.
IsModified | The state of changes made to the document.
IsReadOnlyFile | Signals whether the document was opened in read-only mode or not.
IsWorkshared | Identifies if worksets have been enabled in the document.
LevelTypes | Retrieves an object that contains all the level types that are currently loaded into the project.
LightingDeviceTypes | Returns an object that contains all of the avaible lighting device types currently loaded to this project.
LightingFixtureTypes | Returns an object that contains all of the avaible lighting fixture types currently loaded to this project.
MechanicalEquipmentTypes | Returns an object that contains all of the avaible mechanical equipment types currently loaded to this project.
MullionTypes | This property is used to retrieve all the mullion types in current system.
OwnerFamily | Get the Family of this Family Document.
PanelTypes | Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.
ParameterBindings | Retrieves an object from which mappings between parameter definitions and categories can be found.
PathName | Call this function to get the fully qualified path of the document's disk file.
Phases | Retrieves all the object that represent phases within the project.
PlanTopologies | Overloaded. Gets the PlanTopologies of the current project.
PlanTopology | Overloaded. Gets the PlanTopology of a given level.
PrintManager | Retrieve the PrintManager of current project.
PrintSettings | Retrieve all Print Settings of current project.
ProjectInformation | Return the Project Information of the current project.
ProjectLocations | Retrieve all the project locations associated with this project
ProjectUnit | Provides access to Project Unit Setting with in the document.
ReactionsAreUpToDate | Reports if the analytical model has regenerated in a document with reaction loads.
RebarBarTypes | Retrieves an object that contains all the rebar bar types that are currently loaded into the project.
RebarCoverTypes | Retrieves an object that contains all the rebar cover types that are currently loaded into the project.
RebarHookTypes | Retrieves an object that contains all the rebar hook types that are currently loaded into the project.
RebarShapes | Retrieves an object that contains all the rebar shape types that are currently loaded into the project.
RoofTypes | Retrieves an object that contains all the roof types that are currently loaded into the project.
RoomTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
Selection | Retrieve the currently selected Elements in Autodesk Revit.
Settings | Provides access to general application settings, such as Categories.
SiteLocation | Returns the site location information.
SlabEdgeTypes | Retrieves an object that contains all the SlabEdge types that are currently loaded into the project.
SpaceTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
SpotDimensionTypes | Retrieves an object that contains all of SpotDimension types that are currently loaded into the project.
TextNoteTypes | Retrieves an object that contains all of TextNote types that are currently loaded into the project.
Title | Call this function to get the project's title, which is usually derived from the project's filename.
TitleBlocks | Titleblocks currently loaded into the document.
TrussTypes | Retrieves an object that contains all the truss types that are currently loaded into the project.
TypeOfStorage | Get the storage type of the specified builtin parameter.
ViewSheetSets | The view sheet sets stored in the document.
WallTypes | Retrieves an object that contains all the wall types that are currently loaded into the project.
WorksharingCentralFilename | The name and path of the central file name for a workshared document.

Events

Name | Description
DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving document.
DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save the document.
DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
OnClose | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentClosing event instead. Subscribe to the OnClose event to be notified before the current document is closed.
OnSave | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentSaving event instead. Subscribe to the OnSave event to be notified before a document is saved.
OnSaveAs | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentSavingAs event instead. Subscribe to the OnSaveAs event to be notified before the current document is saved as a file with another name.
ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

Document Class
Autodesk.Revit Namespace

Document Constructor

[image]