Revit 2010 API
ContFooting..::.AnalyticalModel Property
ContFooting Class See Also Send Feedback
Retrieves the structural analytical model for this footing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalModel AnalyticalModel { get; }
Visual Basic (Declaration)
Public ReadOnly Property AnalyticalModel As AnalyticalModel
Visual C++
public:
property AnalyticalModel^ AnalyticalModel {
    AnalyticalModel^ get ();
}

Remarks

If the footing has a structural analytical model it is returned by this method, otherwise Nothing is returned. For this kind of footing, the analytical model returned by this method can be cast to type Autodesk.Revit.Structural.AnalyticalModel3D to be able to access details about the footing. This property will only function with the Autodesk Revit Structure product.

See Also

ContFooting Class
Autodesk.Revit.Elements Namespace

FootingType Property

[image]