Revit 2010 API
Curve..::.Length Property
Curve Class See Also Send Feedback
The exact length of the curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Double
Visual C++
public:
property double Length {
    double get ();
}

Remarks

Computes the length of the curve using analytical or numeric integration. There is no performance hit for lines and arcs.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the curve is unbound and not periodic.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace

Period Property

[image]