Revit 2010 API
Document..::.DocumentPrinted Event
Document Class See Also Send Feedback
Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentPrintedEventArgs> DocumentPrinted
Visual Basic (Declaration)
Public Event DocumentPrinted As EventHandler(Of DocumentPrintedEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintedEventArgs^>^ DocumentPrinted {
    void add (EventHandler<DocumentPrintedEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view or ViewSet of the document. This document-level event precedes the application-level event of the same name. It is raised even when document printing failed or was cancelled (during DocumentPriting event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of printing has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need for creating another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Document Class
Autodesk.Revit Namespace

DocumentPrinting Event

[image]