Revit 2010 API
XYZ..::.Subtract Method
XYZ Class See Also Send Feedback
Subtracts the specified vector from this vector and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Subtract(
    XYZ source
)
Visual Basic (Declaration)
Public Function Subtract ( _
    source As XYZ _
) As XYZ
Visual C++
public:
XYZ^ Subtract(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to subtract from this vector.

Return Value

The vector equal to the difference between the two vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the specified vector from the corresponding coordinate of this vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace

Subtraction Operator

[image]