Revit 2010 API
DocumentSavingAsEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentSavingAs event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DocumentSavingAsEventArgs : PreDocEventArgs
Visual Basic (Declaration)
Public Class DocumentSavingAsEventArgs _
    Inherits PreDocEventArgs
Visual C++
public ref class DocumentSavingAsEventArgs : public PreDocEventArgs

Remarks

This event is cancellable, except when it is raised when the Revit application is closing.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.PreDocEventArgs
Autodesk.Revit.Events..::.DocumentSavingAsEventArgs

See Also

DocumentSavingAsEventArgs Members
Autodesk.Revit.Events Namespace

DocumentSavingAsEventArgs Members

[image] [image]