Revit 2010 API
Category..::.GetLineWeight Method
Category Class See Also Send Feedback
Retrieves the line weight assigned to the category for the given graphics style type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Nullable<int> GetLineWeight(
    GraphicsStyleType graphicsStyleType
)
Visual Basic (Declaration)
Public Function GetLineWeight ( _
    graphicsStyleType As GraphicsStyleType _
) As Nullable(Of Integer)
Visual C++
public:
Nullable<int> GetLineWeight(
    GraphicsStyleType graphicsStyleType
)

Parameters

graphicsStyleType
Type: Autodesk.Revit.Elements..::.GraphicsStyleType
The type of graphics style.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the input argument-"graphicsStyleType"-is out of range.

See Also

Category Class
Autodesk.Revit Namespace

SetLineWeight Method

[image]