Revit 2010 API
ButtonData..::.Text Property
ButtonData Class See Also Send Feedback
The user-visible text of the button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when setting the value to null.
System..::.ArgumentException | Thrown when setting the value to an empty string, or when the value contains invalid characters.

See Also

ButtonData Class
Autodesk.Revit Namespace

ToolTip Property

[image]