Revit 2010 API
FilterCriterion..::.ParameterID Property
FilterCriterion Class See Also Send Feedback
Gets or sets the parameter of this criterion by parameter id.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementId ParameterID { get; set; }
Visual Basic (Declaration)
Public Property ParameterID As ElementId
Visual C++
public:
property ElementId ParameterID {
    ElementId get ();
    void set (ElementId value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the Filter Criterion is internally marked as read-only.

See Also

FilterCriterion Class
Autodesk.Revit Namespace

ParameterValue Property

[image]