Revit 2010 API
Document..::.eRefFace Enumeration
Document Class See Also Send Feedback
Indicates the reference face. The Opening will be created at the direction perpendicular to the reference face.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum eRefFace
Visual Basic (Declaration)
Public Enumeration eRefFace
Visual C++
public enum class eRefFace

Members

Member name | Description
CenterZ | The reference face is at the middle of the element in the direction of z-axis and its normal is parallel to z-axis.
CenterY | The reference face is at the middle of the element in the direction of y-axis and its normal is parallel to y-axis.
CenterX | The reference face is at the middle of the element in the direction of x-axis and its normal is parallel to x-axis.

Remarks

Direction of the opening.

See Also

Autodesk.Revit.Creation Namespace

FamilyInstanceCreationData Class

[image]