Revit 2010 API
LinePattern Class
Members See Also Send Feedback
Represents a line pattern element within an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LinePattern : Element
Visual Basic (Declaration)
Public Class LinePattern _
    Inherits Element
Visual C++
public ref class LinePattern : public Element

Remarks

Currently the details of the line patterns are not exposed but all the line patterns can be found on the Document object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.LinePattern

See Also

LinePattern Members
Autodesk.Revit.Elements Namespace

LinePattern Members

[image] [image]