Revit 2010 API
Face..::.IsInside Method (UV)
Face Class See Also Send Feedback
Indicates whether the specified point is within this face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsInside(
    UV point
)
Visual Basic (Declaration)
Public Function IsInside ( _
    point As UV _
) As Boolean
Visual C++
public:
bool IsInside(
    UV^ point
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.UV
The parameters to be evaluated, in natural parametrization of the face.

Return Value

True if point is within this face, otherwise false.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the parameter evaluation fails.

See Also

Face Class
IsInside Overload
Autodesk.Revit.Geometry Namespace

IsInside Method (UV, IntersectionResult)

[image]