Revit 2010 API
PreDocEventArgs Class
Members See Also Send Feedback
The class is used as base class for the arguments of any pre-event arguments that is associated to a particular Document.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PreDocEventArgs : PreEventArgs
Visual Basic (Declaration)
Public Class PreDocEventArgs _
    Inherits PreEventArgs
Visual C++
public ref class PreDocEventArgs : public PreEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.PreDocEventArgs
Autodesk.Revit.Events..::.DocumentClosingEventArgs
Autodesk.Revit.Events..::.DocumentPrintingEventArgs
Autodesk.Revit.Events..::.DocumentSavingAsEventArgs
Autodesk.Revit.Events..::.DocumentSavingEventArgs
Autodesk.Revit.Events..::.DocumentSynchronizingWithCentralEventArgs
Autodesk.Revit.Events..::.FileExportingEventArgs
Autodesk.Revit.Events..::.FileImportingEventArgs
Autodesk.Revit.Events..::.ViewActivatingEventArgs
Autodesk.Revit.Events..::.ViewPrintingEventArgs

See Also

PreDocEventArgs Members
Autodesk.Revit.Events Namespace

PreDocEventArgs Members

[image] [image]