Revit 2010 API
PrintManager..::.Apply Method
PrintManager Class See Also Send Feedback
Apply the local print settings to global for all documents.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Apply()
Visual Basic (Declaration)
Public Sub Apply
Visual C++
public:
void Apply()

Remarks

This method will change the settings for the current printer to match what is set in the Print Manager. When the user attempts to print with this printer in the future, the changes made by the API session will be visible.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when this operation is not allowed in the current application mode, or the print resource is occupied by others.

See Also

PrintManager Class
Autodesk.Revit Namespace

SelectNewPrintDriver Method

[image]