Revit 2010 API
IConnector..::.Shape Property
IConnector Interface See Also Send Feedback
The shape of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
ConnectorProfileType Shape { get; }
Visual Basic (Declaration)
ReadOnly Property Shape As ConnectorProfileType
Visual C++
property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}

Remarks

This property is used to retrieve the shape of the connector.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Throw when this connector has no shape.

See Also

IConnector Interface
Autodesk.Revit.MEP Namespace

Width Property

[image]