Revit 2010 API
Edge..::.TessellateOnFace Method
Edge Class See Also Send Feedback
Returns a polyline approximation to the edge in UV parameters of the face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public UVArray TessellateOnFace(
    Face face
)
Visual Basic (Declaration)
Public Function TessellateOnFace ( _
    face As Face _
) As UVArray
Visual C++
public:
UVArray^ TessellateOnFace(
    Face^ face
)

Parameters

face
Type: Autodesk.Revit.Geometry..::.Face
The face on which to perform the tessellation. Must belong to the edge.

Remarks

Tolerance of approximation is defined internally by Revit to be adequate for display purposes.

See Also

Edge Class
Autodesk.Revit.Geometry Namespace

Edge Properties

[image] [image]