Revit 2010 API
Document..::.Move Method (ElementSet, XYZ)
Document Class See Also Send Feedback
Moves several elements within the document by a specified vector.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Move(
    ElementSet elements,
    XYZ translationVec
)
Visual Basic (Declaration)
Public Function Move ( _
    elements As ElementSet, _
    translationVec As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    ElementSet^ elements,
    XYZ^ translationVec
)

Parameters

elements
Type: Autodesk.Revit..::.ElementSet
A set of element which are to be moved.
translationVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector by which the elements are to be moved.

Return Value

If the elements are moved successfully then the method returns True, otherwise False.

Remarks

The move method is used to move several elements within the project. Other elements may also be moved when these elements are moved, for example: if the elements are floors, the openings within those floors will also be moved.

See Also

Document Class
Move Overload
Autodesk.Revit Namespace

Print Method

[image] [image]