Revit 2010 API
Curve..::.EndPoint Property
Curve Class See Also Send Feedback
The start or the end point of this curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ EndPoint[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndPoint ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ EndPoint[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32
Use 0 for the start point; 1 for the end point.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when this curve is unbound.
System..::.IndexOutOfRangeException | Thrown when the specified index is not 0 or 1.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace

EndPointReference Property

[image]