Revit 2010 API
DuctConnector Class
Members See Also Send Feedback
A duct connector that is assigned to a mechanical equipment or duct fitting family. Provides access to the duct connector in Autodesk Revit MEP family document.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DuctConnector : Element,
    IConnector
Visual Basic (Declaration)
Public Class DuctConnector _
    Inherits Element _
    Implements IConnector
Visual C++
public ref class DuctConnector : public Element,
    IConnector

Remarks

This element type is accessible only in Autodek Revit MEP family documents. Duct connectors that accessible in MEP project documents are not elements, and are represented by Autodesk::Revit::MEP::Connector.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.MEP..::.DuctConnector

See Also

DuctConnector Members
Autodesk.Revit.MEP Namespace

DuctConnector Members

[image] [image]