Revit 2010 API
AnalyticalModelProfile..::.DrivingCurve Property
AnalyticalModelProfile Class See Also Send Feedback
Provides access to the curve that dictates the path of the swept profile.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve DrivingCurve { get; }
Visual Basic (Declaration)
Public ReadOnly Property DrivingCurve As Curve
Visual C++
public:
property Curve^ DrivingCurve {
    Curve^ get ();
}

Return Value

A curve that defines the path of the swept profile.

Remarks

The profile may not be swept the entire length of this curve. One should check the set back properties on this object to locate how far the the actual sweep is from the ends of the curve.

See Also

AnalyticalModelProfile Class
Autodesk.Revit.Structural Namespace

EndSetBack Property

[image]