Revit 2010 API
Document..::.NewWalls Method (List<(Of <(ProfiledWallCreationData>)>))
Document Class See Also Send Feedback
Creates profile walls within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewWalls(
    List<ProfiledWallCreationData> dataList
)
Visual Basic (Declaration)
Public Function NewWalls ( _
    dataList As List(Of ProfiledWallCreationData) _
) As ElementSet
Visual C++
public:
ElementSet^ NewWalls(
    List<ProfiledWallCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::.List <(Of <( ProfiledWallCreationData >)>)
A list of ProfiledWallCreationData which wraps the creation arguments of the walls to be created.

Return Value

If the creation is successful an ElementSet which contains the walls should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
System..::.ArgumentException | If ProfiledWallCreationData's profile is null object.
System..::.InvalidOperationException | If regeneration fails at the end of the batch creation.

See Also

Document Class
NewWalls Overload
Autodesk.Revit.Creation Namespace

NewWalls Method (List(RectangularWallCreationData))

[image]