Revit 2010 API
Document..::.ViewPrinted Event
Document Class See Also Send Feedback
Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<ViewPrintedEventArgs> ViewPrinted
Visual Basic (Declaration)
Public Event ViewPrinted As EventHandler(Of ViewPrintedEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintedEventArgs^>^ ViewPrinted {
    void add (EventHandler<ViewPrintedEventArgs^>^ value);
    void remove (EventHandler<ViewPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view of the document. This document-level event precedes the application-level event of the same name. It is raised even when view printing failed.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of view printing has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need for creating another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Document Class
Autodesk.Revit Namespace

ViewPrinting Event

[image]