Revit 2010 API
ParameterStorage..::.AsDouble Method
ParameterStorage Class See Also Send Feedback
Provides access to the double precision number within the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual double AsDouble()
Visual Basic (Declaration)
Public Overridable Function AsDouble As Double
Visual C++
public:
virtual double AsDouble()

Return Value

The double value contained in the parameter.

Remarks

The AsDouble method should only be used if the StorageType property returns that the internal contents of the parameter is a double.

Exceptions

Exception | Condition
InvalidOperationException..::.InvalidOperationException()()() | Thrown when the StorageType is not Double

See Also

ParameterStorage Class
Autodesk.Revit Namespace

AsElementId Method

[image]