Revit 2010 API
Application..::.FileExporting Event
Application Class See Also Send Feedback
Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<FileExportingEventArgs> FileExporting
Visual Basic (Declaration)
Public Event FileExporting As EventHandler(Of FileExportingEventArgs)
Visual C++
public:
 event EventHandler<FileExportingEventArgs^>^ FileExporting {
    void add (EventHandler<FileExportingEventArgs^>^ value);
    void remove (EventHandler<FileExportingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to export files of formats supported by the API.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to 'true'. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Export(String, String, GBXMLExportOptions) and similar overloads.
  • Autodesk.Revit.Document.Print()
  • Print()()() and similar overloads.
  • SubmitPrint()()() and similar overloads.
  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileExported event will be raised immediately after file exporting is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace

FileImported Event

[image]