Revit 2010 API
XYZ..::.BasisZ Property
XYZ Class See Also Send Feedback
The basis of the Z axis.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static XYZ BasisZ { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BasisZ As XYZ
Visual C++
public:
static property XYZ^ BasisZ {
    XYZ^ get ();
}

Remarks

The basis of the Z axis is the vector (0,0,1), the unit vector on the Z axis.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace

IsNormalized Property

[image]