Revit 2010 API
DetailEllipse Class
Members See Also Send Feedback
Represents a DetailEllipse within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DetailEllipse : DetailCurve
Visual Basic (Declaration)
Public Class DetailEllipse _
    Inherits DetailCurve
Visual C++
public ref class DetailEllipse : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CurveElement
Autodesk.Revit.Elements..::.DetailCurve
Autodesk.Revit.Elements..::.DetailEllipse

See Also

DetailEllipse Members
Autodesk.Revit.Elements Namespace

DetailEllipse Members

[image] [image]