Revit 2010 API
ItemFactoryBase..::.NewReferencePlane2 Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new instance of ReferencePlane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferencePlane NewReferencePlane2(
    XYZ bubbleEnd,
    XYZ freeEnd,
    XYZ thirdPnt,
    View pView
)
Visual Basic (Declaration)
Public Function NewReferencePlane2 ( _
    bubbleEnd As XYZ, _
    freeEnd As XYZ, _
    thirdPnt As XYZ, _
    pView As View _
) As ReferencePlane
Visual C++
public:
ReferencePlane^ NewReferencePlane2(
    XYZ^ bubbleEnd,
    XYZ^ freeEnd,
    XYZ^ thirdPnt,
    View^ pView
)

Parameters

bubbleEnd
Type: Autodesk.Revit.Geometry..::.XYZ
The bubble end applied to reference plane.
freeEnd
Type: Autodesk.Revit.Geometry..::.XYZ
The free end applied to reference plane.
thirdPnt
Type: Autodesk.Revit.Geometry..::.XYZ
A third point needed to define the reference plane.
pView
Type: Autodesk.Revit.Elements..::.View
The specific view apply to the Reference plane.

Return Value

The newly created reference plane.

Examples

CopyC#
// Build now data before creation
XYZ bubbleEnd = new XYZ(1, 0, 0);   // bubble end applied to reference plane
XYZ freeEnd = new XYZ(-5, 0, 0);    // free end applied to reference plane
// Third point should not be on the bubbleEnd-freeEnd line
XYZ thirdPnt = new XYZ(0, 15, 0);   // 3rd point to define reference plane

// Create the reference plane in X-Y, applying the active view
ReferencePlane refPlane = document.Create.NewReferencePlane2(bubbleEnd, freeEnd, thirdPnt, document.ActiveView);
CopyVB.NET
' Build now data before creation
Dim bubbleEnd As New Autodesk.Revit.Geometry.XYZ(1, 0, 0)
' bubble end applied to reference plane
Dim freeEnd As New Autodesk.Revit.Geometry.XYZ(-5, 0, 0)
' free end applied to reference plane
' Third point should not be on the bubbleEnd-freeEnd line
Dim thirdPnt As New Autodesk.Revit.Geometry.XYZ(0, 15, 0)
' 3rd point to define reference plane
' Create the reference plane in X-Y, applying the active view
Dim refPlane As ReferencePlane = document.Create.NewReferencePlane2(bubbleEnd, freeEnd, thirdPnt, document.ActiveView)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace

NewSketchPlane Method

[image] [image]