Revit 2010 API
TypeBinding Class
Members Example See Also Send Feedback
TypeBinding objects are used to bind a property to a Revit type, such as a wall type.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class TypeBinding : ElementBinding
Visual Basic (Declaration)
Public Class TypeBinding _
    Inherits ElementBinding
Visual C++
public ref class TypeBinding : public ElementBinding

Remarks

This differs from Instance bindings in that the property is then shared by all instances that use that type. Changing the parameter for one type affects all other instances that use that type.

Examples

CopyC#
public bool SetNewParameterToTypeWall(Autodesk.Revit.Application app, DefinitionFile myDefinitionFile)
{
    // Create a new group in the shared parameters file
    DefinitionGroups myGroups = myDefinitionFile.Groups;
    DefinitionGroup myGroup = myGroups.Create("MyParameters");

    // Create a type definition
    Definition myDefinition_CompanyName =
       myGroup.Definitions.Create("CompanyName", ParameterType.Text);

    // Create a category set and insert category of wall to it
    CategorySet myCategories = app.Create.NewCategorySet();
    // Use BuiltInCategory to get category of wall
    Category myCategory = app.ActiveDocument.Settings.Categories.get_Item(
                                    BuiltInCategory.OST_Walls);
    myCategories.Insert(myCategory);

    //Create an object of TypeBinding according to the Categories
    TypeBinding typeBinding = app.Create.NewTypeBinding(myCategories);

    // Get the BingdingMap of current document.
    BindingMap bindingMap = app.ActiveDocument.ParameterBindings;

    // Bind the definitions to the document
    bool typeBindOK = bindingMap.Insert(myDefinition_CompanyName, typeBinding,
      BuiltInParameterGroup.PG_TEXT);
    return typeBindOK;
}
CopyVB.NET
Public Function SetNewParameterToTypeWall(ByVal app As Autodesk.Revit.Application, ByVal myDefinitionFile As DefinitionFile) As Boolean
    ' Create a new group in the shared parameters file
    Dim myGroups As DefinitionGroups = myDefinitionFile.Groups
    Dim myGroup As DefinitionGroup = myGroups.Create("MyParameters")

    ' Create a type definition
    Dim myDefinition_CompanyName As Definition = myGroup.Definitions.Create("CompanyName", ParameterType.Text)

    ' Create a category set and insert category of wall to it
    Dim myCategories As CategorySet = app.Create.NewCategorySet()
    ' Use BuiltInCategory to get category of wall
    Dim myCategory As Autodesk.Revit.Category = app.ActiveDocument.Settings.Categories.Item(BuiltInCategory.OST_Walls)
    myCategories.Insert(myCategory)

    'Create an object of TypeBinding according to the Categories
    Dim typeBinding As TypeBinding = app.Create.NewTypeBinding(myCategories)

    ' Get the BingdingMap of current document.
    Dim bindingMap As BindingMap = app.ActiveDocument.ParameterBindings

    ' Bind the definitions to the document
    Dim typeBindOK As Boolean = bindingMap.Insert(myDefinition_CompanyName, typeBinding, BuiltInParameterGroup.PG_TEXT)
    Return typeBindOK
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.Binding
Autodesk.Revit.Parameters..::.ElementBinding
Autodesk.Revit.Parameters..::.TypeBinding

See Also

TypeBinding Members
Autodesk.Revit.Parameters Namespace

TypeBinding Members

[image] [image]