Revit 2010 API
ItemFactoryBase..::.NewFamilyInstances Method
ItemFactoryBase Class Example See Also Send Feedback
Creates Family instances within the document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewFamilyInstances(
    List<FamilyInstanceCreationData> dataList
)
Visual Basic (Declaration)
Public Function NewFamilyInstances ( _
    dataList As List(Of FamilyInstanceCreationData) _
) As ElementSet
Visual C++
public:
ElementSet^ NewFamilyInstances(
    List<FamilyInstanceCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::.List <(Of <( FamilyInstanceCreationData >)>)
A list of FamilyInstanceCreationData which wraps the creation arguments of the families to be created.

Return Value

If the creation is successful an ElementSet which contains the Family instances should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Examples

CopyC#
ElementSet BatchCreateColumns(Autodesk.Revit.Document document, Level level)
{
    List<FamilyInstanceCreationData> fiCreationDatas = new List<FamilyInstanceCreationData>();

    ElementSet elementSet = null;

    //Try to get a FamilySymbol
    FamilySymbol familySymbol = null;
    ElementIterator iter = document.get_Elements(typeof(FamilySymbol));
    iter.Reset();
    while (iter.MoveNext())
    {
        familySymbol = iter.Current as FamilySymbol;
        if (null != familySymbol && null != familySymbol.Category)
        {
            if ("Structural Columns" == familySymbol.Category.Name)
            {
                break;
            }
        }
    }

    if (null != familySymbol)
    {
        //Create 10 FamilyInstanceCreationData items for batch creation
        for (int i = 1; i < 11; i++)
        {
            XYZ location = new XYZ(i * 10, 100, 0);
            FamilyInstanceCreationData fiCreationData =
                new FamilyInstanceCreationData(location, familySymbol, level, Autodesk.Revit.Structural.Enums.StructuralType.Column);

            if (null != fiCreationData)
            {
                fiCreationDatas.Add(fiCreationData);
            }
        }

        if (fiCreationDatas.Count > 0)
        {
            // Create Columns
            elementSet = document.Create.NewFamilyInstances(fiCreationDatas);
        }
        else
        {
            throw new Exception("Batch creation failed.");
        }
    }
    else
    {
        throw new Exception("No column types found.");
    }

    return elementSet;
}
CopyVB.NET
Private Function BatchCreateColumns(ByVal document As Autodesk.Revit.Document, ByVal level As Autodesk.Revit.Elements.Level) As ElementSet

    Dim fiCreationDatas As New List(Of FamilyInstanceCreationData)()

    Dim elementSet As ElementSet = Nothing

    'Try to get a FamilySymbol
    Dim familySymbol As Autodesk.Revit.Symbols.FamilySymbol = Nothing
    Dim iter As ElementIterator = document.Elements(GetType(Autodesk.Revit.Symbols.FamilySymbol))
    iter.Reset()
    While iter.MoveNext()
        familySymbol = TryCast(iter.Current, Autodesk.Revit.Symbols.FamilySymbol)
        If familySymbol IsNot Nothing AndAlso familySymbol.Category IsNot Nothing Then
            If "Structural Columns" = familySymbol.Category.Name Then
                Exit While
            End If
        End If
    End While

    If familySymbol IsNot Nothing Then
        'Create 10 FamilyInstanceCreationData items for batch creation
        For i As Integer = 1 To 10
            Dim location As New Autodesk.Revit.Geometry.XYZ(i * 10, 100, 0)
            Dim fiCreationData As New FamilyInstanceCreationData(location, familySymbol, level, Autodesk.Revit.Structural.Enums.StructuralType.Column)

            If fiCreationData IsNot Nothing Then
                fiCreationDatas.Add(fiCreationData)
            End If
        Next

        If fiCreationDatas.Count > 0 Then
            ' Create Columns
            elementSet = document.Create.NewFamilyInstances(fiCreationDatas)
        Else
            Throw New Exception("Batch creation failed.")
        End If
    Else
        Throw New Exception("No column types found.")
    End If

    Return elementSet
End Function

Exceptions

Exception | Condition
System..::.ArgumentNullException | If FamilyInstanceCreationData's 'curve' or 'symbol' member is constructed with null object.
System..::.InvalidOperationException | If regeneration fails at the end of the batch creation.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace

NewGroup Method

[image]