Revit 2010 API
DividedSurface Methods
DividedSurface Class See Also Send Feedback

The DividedSurface type exposes the following members.

Methods

Name | Description
GetGridNodeLocation | Specify whether a particular grid node is interior to the surface, on the boundary, or outside the boundary.
GetGridNodeReference | Get a reference to the geometric point associated with a grid node.
GetGridNodeUV | Get the position of a grid node in UV coordinates in the surface.
GetGridSegmentReference | Get a reference to a line segment connecting two adjacent grid nodes.
GetTileFamilyInstance | Get a reference to a tile element associated with a given seed node.
GetTileReference | Get a reference to one of the tile surfaces associated with a given seed node.
IsSeedNode | Reports whether a grid node is a "seed node," a node that is associated with one or more tiles.

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace

GetGridNodeLocation Method

[image]