Revit 2010 API
RebarBarType..::.SetAutoCalcHookLengths Method
RebarBarType Class See Also Send Feedback
Specify whether hook lengths are automatically calculated.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetAutoCalcHookLengths(
    RebarHookType hookType,
    bool autoCalc
)
Visual Basic (Declaration)
Public Sub SetAutoCalcHookLengths ( _
    hookType As RebarHookType, _
    autoCalc As Boolean _
)
Visual C++
public:
void SetAutoCalcHookLengths(
    RebarHookType^ hookType,
    bool autoCalc
)

Parameters

hookType
Type: Autodesk.Revit.Symbols..::.RebarHookType
A hook type in the same document as this bar type.
autoCalc
Type: System..::.Boolean
Setting this value to true discards the current value set by set_HookLength().

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace

RebarBarType Properties

[image] [image]