Revit 2010 API
Document..::.Selection Property
Document Class Example See Also Send Feedback
Retrieve the currently selected Elements in Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Selection Selection { get; }
Visual Basic (Declaration)
Public ReadOnly Property Selection As Selection
Visual C++
public:
property Selection^ Selection {
    Selection^ get ();
}

Remarks

Returns an object that represents the active selection. The Selection property returns an object that represents the active selection when the command was started.

Examples

CopyC#
public class Document_Selection : IExternalCommand
{
    public IExternalCommand.Result Execute(ExternalCommandData commandData,
        ref string message, ElementSet elements)
    {
        try
        {
            // Select some elements in Revit before invoking this command

            // Get the handle of current document.
            Document document = commandData.Application.ActiveDocument;

            // Get the element selection of current document.
            Selection selection = document.Selection;
            ElementSet collection = selection.Elements;

            if (0 == collection.Size)
            {
                // If no elements selected.
                MessageBox.Show("You haven't selected any elements.", "Revit");
            }
            else
            {
                String info = "Ids of selected elements in the document are: ";
                foreach (Element elem in collection)
                {
                    info += "\n\t" + elem.Id.Value;
                }

                MessageBox.Show(info, "Revit", MessageBoxButtons.OK);
            }
        }
        catch (Exception e)
        {
            message = e.Message;
            return IExternalCommand.Result.Failed;
        }

        return IExternalCommand.Result.Succeeded;
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Document_Selection
    Implements IExternalCommand
    Public Function Execute(ByVal commandData As ExternalCommandData, ByRef message As String, ByVal elements As ElementSet) As IExternalCommand.Result Implements IExternalCommand.Execute
        Try
            ' Select some elements in Revit before invoking this command

            ' Get the handle of current document.
            Dim document As Document = commandData.Application.ActiveDocument

            ' Get the element selection of current document.
            Dim selection As Autodesk.Revit.Selection = document.Selection
            Dim collection As ElementSet = selection.Elements

            If 0 = collection.Size Then
                ' If no elements selected.
                MessageBox.Show("You haven't selected any elements.", "Revit")
            Else
                Dim info As String = "Ids of selected elements in the document are: "
                For Each elem As Autodesk.Revit.Element In collection
                    info += vbLf & vbTab & elem.Id.Value
                Next

                MessageBox.Show(info, "Revit", MessageBoxButtons.OK)
            End If
        Catch e As Exception
            message = e.Message
            Return IExternalCommand.Result.Failed
        End Try

        Return IExternalCommand.Result.Succeeded
    End Function
End Class

See Also

Document Class
Autodesk.Revit Namespace

Settings Property

[image]