Revit 2010 API
Document..::.PlanTopologies Property (Phase)
Document Class See Also Send Feedback
Gets the PlanTopologies of the current project in a given phase.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PlanTopologySet PlanTopologies[
    Phase phase
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlanTopologies ( _
    phase As Phase _
) As PlanTopologySet
Visual C++
public:
property PlanTopologySet^ PlanTopologies[Phase^ phase] {
    PlanTopologySet^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.Elements..::.Phase
The phase of the Plan Topology.

Remarks

The Plan Topologies you get here is in the phase you assigned.

See Also

Document Class
PlanTopologies Overload
Autodesk.Revit Namespace

PlanTopology Property

[image] [image]