Revit 2010 API
DefinitionBindingMap..::.Insert Method
DefinitionBindingMap Class See Also Send Feedback
Insert the specified binding with the specified definition into the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    Definition key,
    Binding item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As Definition, _
    item As Binding _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Definition^ key,
    Binding^ item
)

Parameters

key
Type: Autodesk.Revit.Parameters..::.Definition
The definition to be used for inserting the binding into the map.
item
Type: Autodesk.Revit.Parameters..::.Binding
The binding to be inserted into the map.

Return Value

Returns whether the binding was inserted into the map.

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace

ReverseIterator Method

[image]