Revit 2010 API
Filter..::.NewLogicNotFilter Method
Filter Class See Also Send Feedback
Creates a new LogicNotFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LogicNotFilter NewLogicNotFilter(
    Filter subFilter
)
Visual Basic (Declaration)
Public Function NewLogicNotFilter ( _
    subFilter As Filter _
) As LogicNotFilter
Visual C++
public:
LogicNotFilter^ NewLogicNotFilter(
    Filter^ subFilter
)

Parameters

subFilter
Type: Autodesk.Revit..::.Filter
subFilter is an operand of logic-not operator

Return Value

Returns a new LogicNotFilter object.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter is nullptr.

See Also

Filter Class
Autodesk.Revit.Creation Namespace

NewLogicOrFilter Method

[image]