Revit 2010 API
FamilyItemFactory..::.NewControl Method
FamilyItemFactory Class See Also Send Feedback
Add a new control into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Control NewControl(
    ControlShape controlShape,
    View view,
    XYZ origin
)
Visual Basic (Declaration)
Public Function NewControl ( _
    controlShape As ControlShape, _
    view As View, _
    origin As XYZ _
) As Control
Visual C++
public:
Control^ NewControl(
    ControlShape controlShape,
    View^ view,
    XYZ^ origin
)

Parameters

controlShape
Type: Autodesk.Revit.Elements..::.ControlShape
The shape of the control.
view
Type: Autodesk.Revit.Elements..::.View
The view in which the control is to be visible. It must be a FloorPlan view or a CeilingPlan view.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The origin of the control.

Return Value

If successful, the newly created control is returned, otherwise an exception with error information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"view" or "position"-is null.
System..::.ArgumentException | Thrown when the input argument-"view"-is invalid.
System..::.ArgumentOutOfRangeException | Thrown when the input argument-"controlType"-is out of range.
System..::.InvalidOperationException | Thrown when control creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace

NewCurveByPoints Method

[image]