Revit 2010 API
MaterialGeneric..::.ReductionFactor Property
MaterialGeneric Class See Also Send Feedback
Get or set the reduction factor for shear of the generic material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ReductionFactor { get; set; }
Visual Basic (Declaration)
Public Property ReductionFactor As Double
Visual C++
public:
property double ReductionFactor {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the reduction factor for shear to an invalid vlaue.

See Also

MaterialGeneric Class
Autodesk.Revit.Elements Namespace

ShearModulusX Property

[image]