Revit 2010 API
LocationPoint..::.Point Property
LocationPoint Class Example See Also Send Feedback
Get and set the physical location of the element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Point { get; set; }
Visual Basic (Declaration)
Public Property Point As XYZ
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
    void set (XYZ^ value);
}

Examples

CopyC#
void LocationMove(FamilyInstance column)
{
    LocationPoint columnPoint = column.Location as LocationPoint;
    if (null != columnPoint)
    {
        XYZ newLocation = new XYZ(10, 20, 0);
        // Move the column to the new location
        columnPoint.Point = newLocation;
    }
}
CopyVB.NET
Private Sub LocationMove(ByVal column As Autodesk.Revit.Elements.FamilyInstance)
    Dim columnPoint As LocationPoint = TryCast(column.Location, LocationPoint)
    If columnPoint IsNot Nothing Then
        Dim newLocation As New Autodesk.Revit.Geometry.XYZ(10, 20, 0)
        ' Move the column to the new location
        columnPoint.Point = newLocation
    End If
End Sub

See Also

LocationPoint Class
Autodesk.Revit Namespace

Rotation Property

[image]