Revit 2010 API
WallUsage Enumeration
See Also Send Feedback
An enumerate type listing all the possible structural usage cases for a Wall object.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum WallUsage
Visual Basic (Declaration)
Public Enumeration WallUsage
Visual C++
public enum class WallUsage

Members

Member name | Description
MAX | The value is used to check whether the enum is the same size as the internal one.
Combined | The wall is subject to combined loads.
Shear | The wall is subject to shear loads.
Bearing | The wall is to be consisdered as load bearing for structural analysis.
NonBearing | The wall is considered non load bearing for structural analysis.

See Also

Autodesk.Revit.Structural.Enums Namespace

Autodesk.Revit.Symbols Namespace

[image]