Revit 2010 API
TemperatureRatingType Class
Members See Also Send Feedback
Represents temperature rating type definition information.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class TemperatureRatingType : Element
Visual Basic (Declaration)
Public Class TemperatureRatingType _
    Inherits Element
Visual C++
public ref class TemperatureRatingType : public Element

Remarks

Temperature rating type is defined based on corresponding wire material type. It includes type informations such as wire size, insulation type, correction factor, etc. Only the temperature rating types which are retrieved from WireMaterialType can work well, so don't retrieve it from Revit document directly.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.MEP..::.TemperatureRatingType

See Also

TemperatureRatingType Members
Autodesk.Revit.MEP Namespace

TemperatureRatingType Members

[image] [image]