Revit 2010 API
Element..::.SimilarObjectTypes Property
Element Class See Also Send Feedback
Returns the types being similar to the current instance.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ElementSet SimilarObjectTypes { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property SimilarObjectTypes As ElementSet
Visual C++
public:
virtual property ElementSet^ SimilarObjectTypes {
    ElementSet^ get ();
}

Remarks

The returned types include all the similar types to current instance, which means the type of the current instance can be swapped to the type included in the returned set.

See Also

Element Class
Autodesk.Revit Namespace

UniqueId Property

[image]