Revit 2010 API
DialogBoxShowingEventArgs Class
Members See Also Send Feedback
The base class for the event arguments used by the DialogBoxShowing event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DialogBoxShowingEventArgs : PreEventArgs
Visual Basic (Declaration)
Public Class DialogBoxShowingEventArgs _
    Inherits PreEventArgs
Visual C++
public ref class DialogBoxShowingEventArgs : public PreEventArgs

Remarks

The actual type of the event arguments will be different depending upon the type of dialog shown. When the application receives this object, a dialog is to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.DialogBoxShowingEventArgs
Autodesk.Revit.Events..::.MessageBoxShowingEventArgs
Autodesk.Revit.Events..::.TaskDialogShowingEventArgs

See Also

DialogBoxShowingEventArgs Members
Autodesk.Revit.Events Namespace

DialogBoxShowingEventArgs Members

[image] [image]