Revit 2010 API
AnalyticalSupportInfoArray Members
AnalyticalSupportInfoArray Class Constructors Methods Properties See Also Send Feedback

The AnalyticalSupportInfoArray type exposes the following members.

Constructors

Name | Description
AnalyticalSupportInfoArray | Initializes a new instance of the AnalyticalSupportInfoArray class

Methods

Name | Description
Append | Add the support to the end of the array.
Clear | Removes every support from the array, rendering it empty.
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
Insert | Insert the specified support into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
Item | Gets or sets support information at a specified index within the array.
Size | Returns the number of supports that are in the array.

See Also

AnalyticalSupportInfoArray Class
Autodesk.Revit.Structural Namespace

AnalyticalSupportInfoArray Constructor

[image]