Revit 2010 API
Categories..::.Item Property (String)
Categories Class See Also Send Feedback
Gets a category which has the specified name from this list of top-level categories.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override Category Item[
    string name
] { get; set; }
Visual Basic (Declaration)
Public Overrides Property Item ( _
    name As String _
) As Category
Visual C++
public:
virtual property Category^ Item[String^ name] {
    Category^ get (String^ name) override;
    void set (String^ name, Category^ value) override;
}

Parameters

name
Type: System..::.String
The name of the category to be retrieved.

Field Value

The category with the specified name.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the category list does not contain the category with this name. Thrown when trying to set an item to this list of categories; this list is read only.

See Also

Categories Class
Item Overload
Autodesk.Revit Namespace

Size Property

[image]