Revit 2010 API
Document..::.NewRoom Method (Level, UV)
Document Class Example See Also Send Feedback
Creates a new room on a level at a specified point.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Room NewRoom(
    Level level,
    UV point
)
Visual Basic (Declaration)
Public Function NewRoom ( _
    level As Level, _
    point As UV _
) As Room
Visual C++
public:
Room^ NewRoom(
    Level^ level,
    UV^ point
)

Parameters

level
Type: Autodesk.Revit.Elements..::.Level
The level on which the room is to exist.
point
Type: Autodesk.Revit.Geometry..::.UV
A 2D point that dictates the location of the room on that specified level.

Return Value

If successful a the new room will be returned, otherwise null.

Examples

CopyC#
Room CreateRoom(Autodesk.Revit.Document document, Level level)
{
    // Create a UV structure which determines the room location
    UV roomLocation = new UV(0, 0);

    // Create a new room
    Room room = document.Create.NewRoom(level, roomLocation);
    if (null == room)
    {
        throw new Exception("Create a new room failed.");
    }

    return room;
}
CopyVB.NET
Private Function CreateRoom(ByVal document As Autodesk.Revit.Document, ByVal level As Autodesk.Revit.Elements.Level) As Room
    ' Create a UV structure which determines the room location
    Dim roomLocation As New Autodesk.Revit.Geometry.UV(0, 0)

    ' Create a new room
    Dim room As Room = document.Create.NewRoom(level, roomLocation)
    If room Is Nothing Then
        Throw New Exception("Create a new room failed.")
    End If

    Return room
End Function

See Also

Document Class
NewRoom Overload
Autodesk.Revit.Creation Namespace

NewRoom Method (Room, PlanCircuit)

[image]