Revit 2010 API
PathReinforcement Class
Members Example See Also Send Feedback
An object that represents an Path Reinforcement within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PathReinforcement : Element
Visual Basic (Declaration)
Public Class PathReinforcement _
    Inherits Element
Visual C++
public ref class PathReinforcement : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Path Reinforcement element is available only in the Autodesk Revit Structure product.

Examples

CopyC#
private void Getinfo_PathReinforcement(PathReinforcement pathReinforcement)
{
    string message = "PathReinforcement : ";

    // Show the NumBarDescriptions property
    message += "\nNumber of distinct bar shapes : " + pathReinforcement.NumBarDescriptions;
    for (int i = 0; i < pathReinforcement.NumBarDescriptions; i++)
    {
       BarDescription description = pathReinforcement.get_BarDescription(i);
       message += "\nBar count : " + description.Count;
       message += "\nBar type name : " + description.BarType.Name;
       message += "\nBar layer : " + description.Layer;
       message += "\nBar length : " + description.Length;
    }

    // Show the PathReinforcement Curves information
    message += "\nPath Reinforcement has " + pathReinforcement.Curves.Size + " path curves.";
    foreach (Autodesk.Revit.Element ii in pathReinforcement.Curves)
    {
       ModelCurve pathCurve = ii as ModelCurve;
       if (null == pathCurve)
       {
          continue;
       }
       Curve curve = pathCurve.GeometryCurve;   // get the location curve
       XYZ start = curve.get_EndPoint(0);  // get the start point of the curve
       XYZ end = curve.get_EndPoint(1);    // get the end point of the curve
       message += "\nCurve: Start point (" + start.X + ", " + start.Y + ", " + start.Z + ")";
       message += "   End point (" + end.X + ", " + end.Y + ", " + end.Z + ")";
    }

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Private Sub Getinfo_PathReinforcement(ByVal pathReinforcement As PathReinforcement)
    Dim message As String = "PathReinforcement : "

    ' Show the NumBarDescriptions property
    message += vbLf & "Number of distinct bar shapes : " & pathReinforcement.NumBarDescriptions
    For i As Integer = 0 To pathReinforcement.NumBarDescriptions - 1
        Dim description As BarDescription = pathReinforcement.BarDescription(i)
        message += vbLf & "Bar count : " & description.Count
        message += vbLf & "Bar type name : " & description.BarType.Name
        message += vbLf & "Bar layer : " & description.Layer
        message += vbLf & "Bar length : " & description.Length
    Next

    ' Show the PathReinforcement Curves information
    message += vbLf & "Path Reinforcement has " & pathReinforcement.Curves.Size & " path curves."
    For Each ii As Autodesk.Revit.Element In pathReinforcement.Curves
        Dim pathCurve As ModelCurve = TryCast(ii, ModelCurve)
        If pathCurve Is Nothing Then
            Continue For
        End If
        Dim curve As Curve = pathCurve.GeometryCurve
        ' get the location curve
        Dim start As Autodesk.Revit.Geometry.XYZ = curve.EndPoint(0)
        ' get the start point of the curve
        Dim [end] As Autodesk.Revit.Geometry.XYZ = curve.EndPoint(1)
        ' get the end point of the curve
        message += ((vbLf & "Curve: Start point (" & start.X & ", ") + start.Y & ", ") + start.Z & ")"
        message += ((" End point (" & [end].X & ", ") + [end].Y & ", ") + [end].Z & ")"
    Next

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.PathReinforcement

See Also

PathReinforcement Members
Autodesk.Revit.Elements Namespace

PathReinforcement Members

[image] [image]