Revit 2010 API
Document..::.NewTopographySurface Method
Document Class See Also Send Feedback
Creates a new TopographySurface element in the document, and initializes it with a set of points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TopographySurface NewTopographySurface(
    XYZArray points
)
Visual Basic (Declaration)
Public Function NewTopographySurface ( _
    points As XYZArray _
) As TopographySurface
Visual C++
public:
TopographySurface^ NewTopographySurface(
    XYZArray^ points
)

Parameters

points
Type: Autodesk.Revit.Geometry..::.XYZArray
An array of initial points for the surface.

Return Value

The TopographySurface element.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when input argument 'points' is null.
System..::.ArgumentException | Thrown when points.Size is less than 3, to create a TopographySurface needs at least 3 points.
System..::.InvalidOperationException | Thrown when regeneration fails.

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewTransitionFitting Method

[image]