Revit 2010 API
Face Class
Members See Also Send Feedback
A face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Face : GeometryObject
Visual Basic (Declaration)
Public Class Face _
    Inherits GeometryObject
Visual C++
public ref class Face : public GeometryObject

Remarks

Faces are defined by surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Face
Autodesk.Revit.Geometry..::.ConicalFace
Autodesk.Revit.Geometry..::.CylindricalFace
Autodesk.Revit.Geometry..::.HermiteFace
Autodesk.Revit.Geometry..::.PlanarFace
Autodesk.Revit.Geometry..::.RevolvedFace
Autodesk.Revit.Geometry..::.RuledFace

See Also

Face Members
Autodesk.Revit.Geometry Namespace

Face Members

[image] [image]