Revit 2010 API
ElectricalConnector..::.AssignAsPrimary Method
ElectricalConnector Class See Also Send Feedback
Assign an electrical connector as a primary electrical connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AssignAsPrimary()
Visual Basic (Declaration)
Public Sub AssignAsPrimary
Visual C++
public:
void AssignAsPrimary()

Remarks

This method is used to promote this electrical connector as primary, and the rest of connectors in this system will be assigned as secondary.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when fail to assign this connector as primary.

See Also

ElectricalConnector Class
Autodesk.Revit.MEP Namespace

ElectricalConnector Properties

[image] [image]