Revit 2010 API
FamilyItemFactory..::.NewSweep Method (Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation)
FamilyItemFactory Class See Also Send Feedback
Adds a new sweep form into the family document, using an array of selected references as a 3D path.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Sweep NewSweep(
    bool isSolid,
    ReferenceArray path,
    SweepProfile profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)
Visual Basic (Declaration)
Public Function NewSweep ( _
    isSolid As Boolean, _
    path As ReferenceArray, _
    profile As SweepProfile, _
    profileLocationCurveIndex As Integer, _
    profilePlaneLocation As ProfilePlaneLocation _
) As Sweep
Visual C++
public:
Sweep^ NewSweep(
    bool isSolid,
    ReferenceArray^ path,
    SweepProfile^ profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Sweep is Solid or Void.
path
Type: Autodesk.Revit.Geometry..::.ReferenceArray
The path of the sweep. The path should be reference of curve or edge obtained from existing geometry.
profile
Type: Autodesk.Revit..::.SweepProfile
The profile of the newly created Sweep. This may contain more than one curve loop or a profile family. Each loop must be a fully closed curve loop and the loops must not intersect. All loops must lie in the same plane. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy reqiurements for sketches used in extrusions.
profileLocationCurveIndex
Type: System..::.Int32
The index of the path curves. The curve upon which the profile plane will be determined.
profilePlaneLocation
Type: Autodesk.Revit.Elements..::.ProfilePlaneLocation
The location on the profileLocationCurve where the profile plane will be determined.

Return Value

If creation was successful the new Sweep is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a sweep in a family document. The sweep will trace the profile along the path.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the input argument-path-is null or empty.
System..::.ArgumentNullException | Thrown when the input argument-profile-is null.
System..::.ArgumentOutOfRangeException | Thrown when the input argument-profileLocationCurveIndex-is out of index bounds.
System..::.ArgumentOutOfRangeException | Thrown when the input argument-profilePlaneLocation-does not exist in ProfilePlaneLocation enumeration.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewSweep Overload
Autodesk.Revit.Creation Namespace

NewSweep Method (Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation)

[image]