Revit 2010 API
ControlledApplication..::.OnDocumentSavedAs Event
ControlledApplication Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentSavedAs event instead. Subscribe to the OnDocumentSavedAs event to be notified when a document is saved as a file with another name during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSavedAs event instead.")]
public event DocumentSavedAsEventHandler OnDocumentSavedAs
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSavedAs event instead.")> _
Public Event OnDocumentSavedAs As DocumentSavedAsEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentSavedAs event instead.")]
public:
 event DocumentSavedAsEventHandler^ OnDocumentSavedAs {
    void add (DocumentSavedAsEventHandler^ value);
    void remove (DocumentSavedAsEventHandler^ value);
}

Remarks

Sometimes a document will be saved to a file with another name during an API command. By subscribing to this event your application will be notified of such an event and perform an action, such as do some external checking etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace

ViewActivated Event

[image]