Revit 2010 API
RibbonPanel..::.Enabled Property
RibbonPanel Class See Also Send Feedback
Gets or sets a value indicating whether the RibbonPanel can respond to user interaction.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Remarks

With the Enabled property, you can enable or disable controls at run time.

See Also

RibbonPanel Class
Autodesk.Revit Namespace

Items Property

[image]