Revit 2010 API
Document..::.NewPipe Method (Connector, Connector, PipeType)
Document Class See Also Send Feedback
Adds a new pipe into the document, using two connectors and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Pipe NewPipe(
    Connector connector1,
    Connector connector2,
    PipeType pipeType
)
Visual Basic (Declaration)
Public Function NewPipe ( _
    connector1 As Connector, _
    connector2 As Connector, _
    pipeType As PipeType _
) As Pipe
Visual C++
public:
Pipe^ NewPipe(
    Connector^ connector1,
    Connector^ connector2,
    PipeType^ pipeType
)

Parameters

connector1
Type: Autodesk.Revit.MEP..::.Connector
The first connector to be connected to the pipe.
connector2
Type: Autodesk.Revit.MEP..::.Connector
The second connector to be connected to the pipe.
pipeType
Type: Autodesk.Revit.MEP..::.PipeType
The type of the pipe.

Return Value

If creation was successful then a new pipe is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connectors are fitting or equipment connectors of the correct domain, and if the connectors’ direction match the direction of the pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, or direction does not match the direction of the duct to be created, the position of the input connectors will govern the endpoints of the pipe, but no connection will be established.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument connector1 or connector2 is null.
System..::.InvalidOperationException | Thrown when the pipe cannot be created or regenerate fails.

See Also

Document Class
NewPipe Overload
Autodesk.Revit.Creation Namespace

NewPipingSystem Method

[image]