Revit 2010 API
Floor..::.SlabShapeEditor Property
Floor Class See Also Send Feedback
Get the SlabShapeEditor used for slab shape editing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabShapeEditor SlabShapeEditor { get; }
Visual Basic (Declaration)
Public ReadOnly Property SlabShapeEditor As SlabShapeEditor
Visual C++
public:
property SlabShapeEditor^ SlabShapeEditor {
    SlabShapeEditor^ get ();
}

Remarks

Only flat and horizontal floor is valid for slab shape edit.Otherwise,ShapeEditor will be nullptr.

See Also

Floor Class
Autodesk.Revit.Elements Namespace

SpanDirectionAngle Property

[image]