Revit 2010 API
Truss..::.SetProfile Method
Truss Class See Also Send Feedback
Add or modify the profile of a truss.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetProfile(
    CurveArray topChords,
    CurveArray bottomChords
)
Visual Basic (Declaration)
Public Sub SetProfile ( _
    topChords As CurveArray, _
    bottomChords As CurveArray _
)
Visual C++
public:
void SetProfile(
    CurveArray^ topChords,
    CurveArray^ bottomChords
)

Parameters

topChords
Type: Autodesk.Revit.Geometry..::.CurveArray
The curves serving as top chords of the truss.
bottomChords
Type: Autodesk.Revit.Geometry..::.CurveArray
The curves serving as bottom chords of the truss.

See Also

Truss Class
Autodesk.Revit.Elements Namespace

TogglePinMember Method

[image]