Revit 2010 API
Element Members
Element Class Constructors Methods Properties See Also Send Feedback

The Element type exposes the following members.

Constructors

Name | Description
Element | For Internal Use Only.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element.
GetMaterialArea | Get the area of the given material on this element.
GetMaterialVolume | Get the volume of the given material on this element.
IsHidden | Identifies if the element has been permanently hidden in the view.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element.
Category | Retrieves a Category object that represents the category or sub category in which the element resides.
DesignOption | Returns the design option to which the element belongs.
Document | Returns the Document in which the Element resides.
Geometry | Retrieves the geometric representation of the element.
Group | Return to group to which an element belongs. If it is not in a group then this will return Nothing.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project.
Level | If the element is level based then level to which the element is assigned is returned.
Location | This property is used to find the physical location of an element within a project.
Materials | Get all materials present in the element.
Name | Returns a human readable name for the Element.
ObjectType | Returns the instance type of this object.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element.
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element.
PhaseCreated | An object representing the phase when the element is created.
PhaseDemolished | An object representing the phase for when the element is to be demolished.
Pinned | Identifies if the element has been pinned to prevent changes.
SimilarObjectTypes | Returns the types being similar to the current instance.
UniqueId | A stable unique identifier for an element within the document.

See Also

Element Class
Autodesk.Revit Namespace

Element Constructor

[image]