Revit 2010 API
Connector..::.ElectricalSystemType Property
Connector Class See Also Send Feedback
The electrical system type of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElectricalSystemType ElectricalSystemType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElectricalSystemType As ElectricalSystemType
Visual C++
public:
property ElectricalSystemType ElectricalSystemType {
    ElectricalSystemType get ();
}

Remarks

Instantaneous system type at this connector, calculated according to system. For unconnected connectors, system type is undefined.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not of DomainElectrical.
System..::.InvalidOperationException | Thrown on failure to get electrical system type.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

Flow Property

[image]