Revit 2010 API
CompoundStructureDeckUsage Enumeration
See Also Send Feedback
Describes how the deck relates to the surrounding layers.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum CompoundStructureDeckUsage
Visual Basic (Declaration)
Public Enumeration CompoundStructureDeckUsage
Visual C++
public enum class CompoundStructureDeckUsage

Members

Member name | Description
MergeWithLayerBelow | Deck is merged with the layer below.
Standalone | Deck is independent of other layers.
MergeWithLayerAbove | Deck is merged with the layer above.
Invalid | Invalid.

See Also

Autodesk.Revit.Structural.Enums Namespace

CompoundStructureLayerFunction Enumeration

[image]