Revit 2010 API
Transform..::.Multiply Operator
Transform Class See Also Send Feedback
Multiplies the two specified transforms.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static Transform operator *(
    Transform left,
    Transform right
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    left As Transform, _
    right As Transform _
) As Transform
Visual C++
public:
static Transform^ operator *(
    Transform^ left,
    Transform^ right
)

Parameters

left
Type: Autodesk.Revit.Geometry..::.Transform
The first transformation.
right
Type: Autodesk.Revit.Geometry..::.Transform
The second transformation.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The combined transformation has the same effect as applying the right transformation first, and the left transformation, second. So, (T1(T2(p)) = (T1 * T2) (p).

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the handle of the first or second transformation is null.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace

OfPoint Method

[image]