Revit 2010 API
Document..::.NewWall Method (CurveArray, WallType, Level, Boolean, XYZ)
Document Class Example See Also Send Feedback
Creates a non rectangular profile wall within the project using the specified wall type and normal vector.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Wall NewWall(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic (Declaration)
Public Function NewWall ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
) As Wall
Visual C++
public:
Wall^ NewWall(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.Symbols..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.
normal
Type: Autodesk.Revit.Geometry..::.XYZ
A vector that must be perpendicular to the profile which dictates which side of the wall is considered to be inside and outside.

Return Value

If successful a new wall object within the project, otherwise Nothing.

Examples

CopyC#
public Wall CreateWallUsingProfile(Autodesk.Revit.Document document, Level level, WallType wallType)
{
    // Build a wall profile for the wall creation
    XYZ first = new XYZ(0, 0, 0);
    XYZ second = new XYZ(20, 0, 0);
    XYZ third = new XYZ(20, 0, 15);
    XYZ fourth = new XYZ(0, 0, 15);
    CurveArray profile = new CurveArray();

    // Get application creation object
    Autodesk.Revit.Creation.Application appCreation = document.Application.Create;

    profile.Append(appCreation.NewLineBound(first, second));
    profile.Append(appCreation.NewLineBound(second, third));
    profile.Append(appCreation.NewLineBound(third, fourth));
    profile.Append(appCreation.NewLineBound(fourth, first));

    XYZ normal = new XYZ(0, 1, 0);

    // Create a wall
    return document.Create.NewWall(profile, wallType, level, true, normal);
}
CopyVB.NET
Public Function CreateWallUsingProfile(ByVal document As Autodesk.Revit.Document, ByVal level As Autodesk.Revit.Elements.Level, ByVal wallType As Autodesk.Revit.Symbols.WallType) As Wall
    ' Build a wall profile for the wall creation
    Dim first As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
    Dim second As New Autodesk.Revit.Geometry.XYZ(20, 0, 0)
    Dim third As New Autodesk.Revit.Geometry.XYZ(20, 0, 15)
    Dim fourth As New Autodesk.Revit.Geometry.XYZ(0, 0, 15)
    Dim profile As New CurveArray()

    ' Get application creation object
    Dim appCreation As Autodesk.Revit.Creation.Application = document.Application.Create

    profile.Append(appCreation.NewLineBound(first, second))
    profile.Append(appCreation.NewLineBound(second, third))
    profile.Append(appCreation.NewLineBound(third, fourth))
    profile.Append(appCreation.NewLineBound(fourth, first))

    Dim normal As New Autodesk.Revit.Geometry.XYZ(0, 1, 0)

    ' Create a wall
    Return document.Create.NewWall(profile, wallType, level, True, normal)
End Function

See Also

Document Class
NewWall Overload
Autodesk.Revit.Creation Namespace

NewWall Method (Curve, WallType, Level, Double, Double, Boolean, Boolean)

[image]