Revit 2010 API
Wall..::.Orientation Property
Wall Class See Also Send Feedback
Provides access to the wall's external face's orientation.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Orientation { get; }
Visual Basic (Declaration)
Public ReadOnly Property Orientation As XYZ
Visual C++
public:
property XYZ^ Orientation {
    XYZ^ get ();
}

Remarks

First get the start point of the wall's CurveDriver, then project it to the external face side,and return the normal on this point as orientation.

See Also

Wall Class
Autodesk.Revit.Elements Namespace

Parameter Property

[image] [image]