Revit 2010 API
Wire Class
Members See Also Send Feedback
An object to represent electrical wire in Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Wire : HostObject
Visual Basic (Declaration)
Public Class Wire _
    Inherits HostObject
Visual C++
public ref class Wire : public HostObject

Remarks

Adding wiring to a project is optional. you can create circuits and maintain the information associated with them without adding wiring to the project.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.MEP..::.Wire

See Also

Wire Members
Autodesk.Revit.MEP Namespace

Wire Members

[image] [image]