Revit 2010 API
ControlledApplication..::.DocumentSynchronizingWithCentral Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentSynchronizingWithCentralEventArgs> DocumentSynchronizingWithCentral
Visual Basic (Declaration)
Public Event DocumentSynchronizingWithCentral As EventHandler(Of DocumentSynchronizingWithCentralEventArgs)
Visual C++
public:
 event EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ DocumentSynchronizingWithCentral {
    void add (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to synchronize a document with central file.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to 'true'. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentSynchronizedWithCentral event will be raised immediately after document synchronizing with central file is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace

FileExported Event

[image]