Revit 2010 API
FloorType Class
Members Example See Also Send Feedback
An object that specifies the type of a floor in Autodesk Revit.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FloorType : HostObjAttributes
Visual Basic (Declaration)
Public Class FloorType _
    Inherits HostObjAttributes
Visual C++
public ref class FloorType : public HostObjAttributes

Remarks

The structural layers of the floor can be accessed via this object.

Examples

CopyC#
public void GetInfo_FloorType(FloorType floorType)
{
    string message;
    // Get whether FloorType is a foundation slab
    message = "If is foundation slab : " + floorType.IsFoundationSlab;
    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_FloorType(ByVal floorType As FloorType)
    Dim message As String
    ' Get whether FloorType is a foundation slab
    message = "If is foundation slab : " & floorType.IsFoundationSlab
    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.HostObjAttributes
Autodesk.Revit.Symbols..::.FloorType

See Also

FloorType Members
Autodesk.Revit.Symbols Namespace

FloorType Members

[image] [image]