Revit 2010 API
Instance..::.GetInstanceGeometry Method (Transform)
Instance Class See Also Send Feedback
Computes a transformation of the geometric representation of the instance.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element GetInstanceGeometry(
    Transform transform
)
Visual Basic (Declaration)
Public Function GetInstanceGeometry ( _
    transform As Transform _
) As Element
Visual C++
public:
Element^ GetInstanceGeometry(
    Transform^ transform
)

Parameters

transform
Type: Autodesk.Revit.Geometry..::.Transform
The transformation to apply to the geometry.

Return Value

An element which contains the computed geometry for the transformed instance.

Remarks

The context of the instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved.

See Also

Instance Class
GetInstanceGeometry Overload
Autodesk.Revit.Geometry Namespace

GetSymbolGeometry Method

[image] [image]