Revit 2010 API
Connector..::.PipeSystemType Property
Connector Class See Also Send Feedback
The pipe system type of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeSystemType PipeSystemType { get; }
Visual Basic (Declaration)
Public ReadOnly Property PipeSystemType As PipeSystemType
Visual C++
public:
property PipeSystemType PipeSystemType {
    PipeSystemType get ();
}

Remarks

Instantaneous system type at this connector, calculated according to system. For unconnected connectors, system type is undefined.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainPiping.
System..::.InvalidOperationException | Thrown on failure to get pipe system type.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

PressureDrop Property

[image]