Revit 2010 API
Face..::.Triangulate Method
Face Class Example See Also Send Feedback
Returns a triangular mesh approximation to the face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Mesh Triangulate()
Visual Basic (Declaration)
Public Function Triangulate As Mesh
Visual C++
public:
Mesh^ Triangulate()

Remarks

Tolerance of approximation is defined internally by Revit to be adequate for display purposes.

Examples

CopyC#
private void TriangulateFace(Face face)
{
    // Get mesh
    Mesh mesh = face.Triangulate();
    for (int i = 0; i < mesh.NumTriangles; i++)
    {
        MeshTriangle triangle = mesh.get_Triangle(i);
        XYZ vertex1 = triangle.get_Vertex(0);
        XYZ vertex2 = triangle.get_Vertex(1);
        XYZ vertex3 = triangle.get_Vertex(2);
    }
}
CopyVB.NET
Private Sub TriangulateFace(ByVal face As Autodesk.Revit.Geometry.Face)
    ' Get mesh
    Dim mesh As Mesh = face.Triangulate()
    For i As Integer = 0 To mesh.NumTriangles - 1
        Dim triangle As MeshTriangle = mesh.Triangle(i)
        Dim vertex1 As Autodesk.Revit.Geometry.XYZ = triangle.Vertex(0)
        Dim vertex2 As Autodesk.Revit.Geometry.XYZ = triangle.Vertex(1)
        Dim vertex3 As Autodesk.Revit.Geometry.XYZ = triangle.Vertex(2)
    Next
End Sub

See Also

Face Class
Autodesk.Revit.Geometry Namespace

Face Properties

[image] [image]