Revit 2010 API
Instance..::.GetInstanceGeometry Method
Instance Class See Also Send Feedback
Computes the geometric representation of the instance.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element GetInstanceGeometry()
Visual Basic (Declaration)
Public Function GetInstanceGeometry As Element
Visual C++
public:
Element^ GetInstanceGeometry()

Return Value

An element which contains the computed geometry for the instance.

Remarks

The geometry will be in the coordinate system of the model that owns this instance. The context of the instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved.

See Also

Instance Class
GetInstanceGeometry Overload
Autodesk.Revit.Geometry Namespace

GetInstanceGeometry Method (Transform)

[image]