Revit 2010 API
FilterCriterion..::.Parameter Property
FilterCriterion Class See Also Send Feedback
Gets or sets the parameter of this criterion by builtin parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BuiltInParameter Parameter { get; set; }
Visual Basic (Declaration)
Public Property Parameter As BuiltInParameter
Visual C++
public:
property BuiltInParameter Parameter {
    BuiltInParameter get ();
    void set (BuiltInParameter value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the Filter Criterion is internally marked as read-only.

See Also

FilterCriterion Class
Autodesk.Revit Namespace

ParameterID Property

[image]