Revit 2010 API
FamilyItemFactory..::.NewReferencePoint Method (XYZ)
FamilyItemFactory Class See Also Send Feedback
Create a reference point at a given location in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferencePoint NewReferencePoint(
    XYZ
)
Visual Basic (Declaration)
Public Function NewReferencePoint ( _
     As XYZ _
) As ReferencePoint
Visual C++
public:
ReferencePoint^ NewReferencePoint(
    XYZ^
)

Parameters

Type: Autodesk.Revit.Geometry..::.XYZ

Return Value

The newly created ReferencePoint.

Remarks

The ReferencePoint will have a default coordinate system corresponding to the global coordinate system.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the argument is null.
System..::.InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.

See Also

FamilyItemFactory Class
NewReferencePoint Overload
Autodesk.Revit.Creation Namespace

NewRevolution Method

[image]