Revit 2010 API
DetailNurbSpline Class
Members See Also Send Feedback
Represents a DetailNurbSpline within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DetailNurbSpline : DetailCurve
Visual Basic (Declaration)
Public Class DetailNurbSpline _
    Inherits DetailCurve
Visual C++
public ref class DetailNurbSpline : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CurveElement
Autodesk.Revit.Elements..::.DetailCurve
Autodesk.Revit.Elements..::.DetailNurbSpline

See Also

DetailNurbSpline Members
Autodesk.Revit.Elements Namespace

DetailNurbSpline Members

[image] [image]