Revit 2010 API
PrintParameters..::.PageOrientation Property
PrintParameters Class See Also Send Feedback
The Page Orientation of the Print Setting.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PageOrientationType PageOrientation { get; set; }
Visual Basic (Declaration)
Public Property PageOrientation As PageOrientationType
Visual C++
public:
property PageOrientationType PageOrientation {
    PageOrientationType get ();
    void set (PageOrientationType value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the input argument is out of range.

See Also

PrintParameters Class
Autodesk.Revit Namespace

PaperPlacement Property

[image]