Revit 2010 API
TextNote..::.AddLeader Method
TextNote Class See Also Send Feedback
Add a leader for the current TextNote object and return the new leader.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Leader AddLeader(
    TextNoteLeaderTypes
)
Visual Basic (Declaration)
Public Function AddLeader ( _
     As TextNoteLeaderTypes _
) As Leader
Visual C++
public:
Leader^ AddLeader(
    TextNoteLeaderTypes
)

Parameters

Type: Autodesk.Revit.Enums..::.TextNoteLeaderTypes

Remarks

If the current leader type is not same with the input type, System::InvalidOperationException will be thrown.

See Also

TextNote Class
Autodesk.Revit.Elements Namespace

RemoveLeaders Method

[image]