Revit 2010 API
XYZ..::.IsNormalized Property
XYZ Class See Also Send Feedback
The boolean value that indicates whether this vector is a normalized vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsNormalized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsNormalized As Boolean
Visual C++
public:
property bool IsNormalized {
    bool get ();
}

Remarks

Normalized vector's length equals one within the tolerance (1.0e-09), in other words, that this is a unit vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace

IsZero Property

[image]