Revit 2010 API
Selection Class
Members See Also Send Feedback
Contains the current user selection of elements within the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Selection : APIObject
Visual Basic (Declaration)
Public Class Selection _
    Inherits APIObject
Visual C++
public ref class Selection : public APIObject

Remarks

The Selection object is used to retrieve the current user selected elements when an external API command is executed.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Selection

See Also

Selection Members
Autodesk.Revit Namespace

Selection Members

[image] [image]