Revit 2010 API
Document Methods
Document Class See Also Send Feedback

The Document type exposes the following members.

Methods

Name | Description
AbortTransaction | Aborts a transaction for specified document.
Array | Overloaded. Creates an array of one or more elements.
ArrayWithoutAssociate | Overloaded. Creates an array of one or more elements where the elements created will not be grouped and associated.
BeginTransaction | Overloaded. Begins a transaction to encompass a set of changes.
Close | Overloaded. Closes the document.
CombineElements | Combine a set of combinable elements into a geometry combination.
Delete | Overloaded. Deletes one or more elements from the document.
EditFamily | Edits a family loaded in the document.
EndTransaction | Overloaded. Ends a transaction with an attempt to commit the set of changes.
Export | Overloaded. Exports the document to another file format.
FindReferencesByDirection | Finds the references that intersect a line extended in a certain direction from an origin point.
GetRoomAtPoint | Overloaded. Gets a room containing the point.
GetSpaceAtPoint | Overloaded. Gets a space containing the point.
Import | Overloaded. Imports the contents of an external file into the document.
LoadFamily | Overloaded. Loads a family and all its types/symbols.
LoadFamilySymbol | Overloaded. Loads only a specified family type/symbol from a family file into the document.
Mirror | Overloaded. Mirrors one or more elements.
Move | Overloaded. Moves one or more elements within the document by a specified vector.
Print | Overloaded. Prints a set of views.
Rotate | Overloaded. Rotates one or more elements within the document by a specified number of degrees around a given axis.
Save | Overloaded. Saves the document.
SaveAs | Overloaded. Saves the document to a new file name.
SeparateElements | Separate a set of combinable elements out of combinations they currently belong to.
ShowElements | Overloaded. Shows one or more elements by zoom to fit.

See Also

Document Class
Autodesk.Revit Namespace

AbortTransaction Method

[image]