Revit 2010 API
LayoutRule Class
Members See Also Send Feedback
The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class LayoutRule : APIObject
Visual Basic (Declaration)
Public MustInherit Class LayoutRule _
    Inherits APIObject
Visual C++
public ref class LayoutRule abstract : public APIObject

Remarks

This class just used as the base class of those concrete LayoutRule classes.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Elements..::.LayoutRule
Autodesk.Revit.Elements..::.LayoutRuleClearSpacing
Autodesk.Revit.Elements..::.LayoutRuleFixedDistance
Autodesk.Revit.Elements..::.LayoutRuleFixedNumber
Autodesk.Revit.Elements..::.LayoutRuleMaximumSpacing

See Also

LayoutRule Members
Autodesk.Revit.Elements Namespace

LayoutRule Members

[image] [image]