Revit 2010 API
SlabShapeEditor..::.ModifySubElement Method (SlabShapeCrease, Double)
SlabShapeEditor Class See Also Send Feedback
Manipulates the crease on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ModifySubElement(
    SlabShapeCrease crease,
    double offset
)
Visual Basic (Declaration)
Public Sub ModifySubElement ( _
    crease As SlabShapeCrease, _
    offset As Double _
)
Visual C++
public:
void ModifySubElement(
    SlabShapeCrease^ crease,
    double offset
)

Parameters

crease
Type: Autodesk.Revit.Editor..::.SlabShapeCrease
The crease.
offset
Type: System..::.Double
The new value of the crease offset, which is the average of offsets of its ends.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the crease is nullptr.
System..::.ArgumentException | Thrown when the crease is invalid.

See Also

SlabShapeEditor Class
ModifySubElement Overload
Autodesk.Revit.Editor Namespace

ModifySubElement Method (SlabShapeVertex, Double)

[image]