Revit 2010 API
ModelHermiteSpline Class
Members See Also Send Feedback
Represents a ModelHermiteSpline within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ModelHermiteSpline : ModelCurve
Visual Basic (Declaration)
Public Class ModelHermiteSpline _
    Inherits ModelCurve
Visual C++
public ref class ModelHermiteSpline : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by goemetry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CurveElement
Autodesk.Revit.Elements..::.ModelCurve
Autodesk.Revit.Elements..::.ModelHermiteSpline

See Also

ModelHermiteSpline Members
Autodesk.Revit.Elements Namespace

ModelHermiteSpline Members

[image] [image]