Revit 2010 API
HostedSweep..::.RemoveSegment Method
HostedSweep Class See Also Send Feedback
Remove segments from the hosted sweep object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveSegment(
    Reference targetRef
)
Visual Basic (Declaration)
Public Sub RemoveSegment ( _
    targetRef As Reference _
)
Visual C++
public:
void RemoveSegment(
    Reference^ targetRef
)

Parameters

targetRef
Type: Autodesk.Revit.Geometry..::.Reference
Segment's reference which want to be removed.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace

SetEndPointParameter Method

[image]