Revit 2010 API
ItemFactoryBase..::.PlaceGroup Method
ItemFactoryBase Class See Also Send Feedback
Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Group PlaceGroup(
    XYZ location,
    GroupType groupType
)
Visual Basic (Declaration)
Public Function PlaceGroup ( _
    location As XYZ, _
    groupType As GroupType _
) As Group
Visual C++
public:
Group^ PlaceGroup(
    XYZ^ location,
    GroupType^ groupType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the group is to be placed.
groupType
Type: Autodesk.Revit.Symbols..::.GroupType
A GroupType object that represents the type of group that is to be placed.

Return Value

If creation was successful then an instance to the new group is returned, otherwise Nothing.

Remarks

This method is used to place a new instance of an existing group type within the document. The group's origin will placed at the point specified by the location. All group types within the document can be found by iterating over the document and looking for elements of type Autodesk.Revit.Symbols.GroupType.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace

ItemFactoryBase Properties

[image] [image]