Revit 2010 API
SetComparisonResult Enumeration
See Also Send Feedback
An enumerate type listing all the relationship types between two sets of arbitrary nature.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum SetComparisonResult
Visual Basic (Declaration)
Public Enumeration SetComparisonResult
Visual C++
public enum class SetComparisonResult

Members

Member name | Description
Equal | Two nonempty sets are equal.
Superset | Both sets are not empty and the left set is strict superset of the right.
Subset | Both sets are not empty and the left set is strict subset of the right.
Overlap | The overlap of two sets is not empty and strict subset of both.
Disjoint | Both sets are not empty and don't overlap.
BothEmpty | Both sets are empty.
RightEmpty | The right set is empty and the left set is not.
LeftEmpty | The left set is empty and the right set is not.

See Also

Autodesk.Revit.Enums Namespace

SlabShapeCreaseType Enumeration

[image]