Revit 2010 API
ControlledApplication..::.OnDocumentSaved Event
ControlledApplication Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentSaved event instead. Subscribe to the OnDocumentSaved event to be notified when a document is saved during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSaved event instead.")]
public event DocumentSavedEventHandler OnDocumentSaved
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSaved event instead.")> _
Public Event OnDocumentSaved As DocumentSavedEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentSaved event instead.")]
public:
 event DocumentSavedEventHandler^ OnDocumentSaved {
    void add (DocumentSavedEventHandler^ value);
    void remove (DocumentSavedEventHandler^ value);
}

Remarks

Sometimes a document will be saved during an API command. By subscribing to this event your application will be notified of such an event and perform an action, such as do some external checking etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace

OnDocumentSavedAs Event

[image]