Revit 2010 API
Definitions..::.Create Method (String, ParameterType)
Definitions Class See Also Send Feedback
Creates a new parameter definition using name, type and visibility.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Definition Create(
    string name,
    ParameterType type
)
Visual Basic (Declaration)
Public Function Create ( _
    name As String, _
    type As ParameterType _
) As Definition
Visual C++
public:
Definition^ Create(
    String^ name,
    ParameterType type
)

Parameters

name
Type: System..::.String
The name of the parameter definition to be created.
type
Type: Autodesk.Revit.Parameters..::.ParameterType
The name of the parameter type for the new definition.

Return Value

If successful a reference to the new parameter definition is returned, otherwise Nothing.

Remarks

If an attempt is made to create a new internal definition an exception will be thrown. Only external (shared) parameter definitions can be made.

See Also

Definitions Class
Create Overload
Autodesk.Revit.Parameters Namespace

Create Method (String, ParameterType, Boolean)

[image]