Revit 2010 API
Element..::.Parameters Property
Element Class Example See Also Send Feedback
Retrieves a set containing all of the parameters that are contained within the element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterSet Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterSet
Visual C++
public:
property ParameterSet^ Parameters {
    ParameterSet^ get ();
}

Remarks

The Parameters property contains a set of all the parameters that the element supports. These parameters are displayed in the Element properties dialog in the Autodesk Revit interface. These parameters can be retrieved and set via the parameter objects stored in this set.

Examples

CopyC#
void GetElementParameterInformation(Document document, Element element)
{
    // Format the prompt information string
    String prompt = "Show parameters in selected Element:";

    StringBuilder st = new StringBuilder();
    // iterate element's parameters
    foreach (Parameter para in element.Parameters)
    {
        st.AppendLine(GetParameterInformation(para, document));
    }

    // Give the user some information
    MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);
}

String GetParameterInformation(Parameter para, Document document)
{
    string defName = para.Definition.Name + @"\t";
    // Use different method to get parameter data according to the storage type
    switch (para.StorageType)
    {
        case StorageType.Double:
            //covert the number into Metric
            defName += " : " + para.AsValueString();
            break;
        case StorageType.ElementId:
            //find out the name of the element
            ElementId id = para.AsElementId();
            if (id.Value >= 0)
            {
                defName += " : " + document.get_Element(ref id).Name;
            }
            else
            {
                defName += " : " + id.Value.ToString();
            }
            break;
        case StorageType.Integer:
            if (ParameterType.YesNo == para.Definition.ParameterType)
            {
                if (para.AsInteger() == 0)
                {
                    defName += " : " + "False";
                }
                else
                {
                    defName += " : " + "True";
                }
            }
            else
            {
                defName += " : " + para.AsInteger().ToString();
            }
            break;
        case StorageType.String:
            defName += " : " + para.AsString();
            break;
        default:
            defName = "Unexposed parameter.";
            break;
    }

    return defName;
}
CopyVB.NET
Private Sub GetElementParameterInformation(ByVal document As Document, ByVal element As Autodesk.Revit.Element)
    ' Format the prompt information string
    Dim prompt As String = "Show parameters in selected Element:"

    Dim st As New StringBuilder()
    ' iterate element's parameters
    For Each para As Parameter In element.Parameters
        st.AppendLine(GetParameterInformation(para, document))
    Next

    ' Give the user some information
    MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)
End Sub

Private Function GetParameterInformation(ByVal para As Parameter, ByVal document As Document) As String
    Dim defName As String = para.Definition.Name & "\t"
    ' Use different method to get parameter data according to the storage type
    Select Case para.StorageType
        Case StorageType.[Double]
            'covert the number into Metric
            defName += " : " & para.AsValueString()
            Exit Select
        Case StorageType.ElementId
            'find out the name of the element
            Dim id As Autodesk.Revit.ElementId = para.AsElementId()
            If id.Value >= 0 Then
                defName += " : " & document.Element(id).Name
            Else
                defName += " : " & id.Value.ToString()
            End If
            Exit Select
        Case StorageType.[Integer]
            If ParameterType.YesNo = para.Definition.ParameterType Then
                If para.AsInteger() = 0 Then
                    defName += " : " & "False"
                Else
                    defName += " : " & "True"
                End If
            Else
                defName += " : " & para.AsInteger().ToString()
            End If
            Exit Select
        Case StorageType.[String]
            defName += " : " & para.AsString()
            Exit Select
        Case Else
            defName = "Unexposed parameter."
            Exit Select
    End Select

    Return defName
End Function

See Also

Element Class
Autodesk.Revit Namespace

ParametersMap Property

[image]