Revit 2010 API
RebarHookOrientation Enumeration
See Also Send Feedback
Orientation of a rebar hook relative to the path of the Rebar Shape.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum RebarHookOrientation
Visual Basic (Declaration)
Public Enumeration RebarHookOrientation
Visual C++
public enum class RebarHookOrientation

Members

Member name | Description
Right | Hook towards the right of a segment-based shape (RebarShapeDefinitionBySegments), or to the exterior of an arc-based shape (RebarShapeDefinitionByArc).
Left | Hook towards the left of a segment-based shape (RebarShapeDefinitionBySegments), or to the interior of an arc-based shape (RebarShapeDefinitionByArc).

See Also

Autodesk.Revit.Structural.Enums Namespace

RebarLayoutRule Enumeration

[image]