Revit 2010 API
FamilyItemFactory..::.NewSweptBlend Method (Boolean, Curve, SketchPlane, SweepProfile, SweepProfile)
FamilyItemFactory Class Example See Also Send Feedback
Add a new swept blend into the family document, using a curve as the path.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SweptBlend NewSweptBlend(
    bool isSolid,
    Curve path,
    SketchPlane pathPlane,
    SweepProfile bottomProfile,
    SweepProfile topProfile
)
Visual Basic (Declaration)
Public Function NewSweptBlend ( _
    isSolid As Boolean, _
    path As Curve, _
    pathPlane As SketchPlane, _
    bottomProfile As SweepProfile, _
    topProfile As SweepProfile _
) As SweptBlend
Visual C++
public:
SweptBlend^ NewSweptBlend(
    bool isSolid,
    Curve^ path,
    SketchPlane^ pathPlane,
    SweepProfile^ bottomProfile,
    SweepProfile^ topProfile
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the swept blend is Solid or Void.
path
Type: Autodesk.Revit.Geometry..::.Curve
The path of the swept blend. The path should be a single curve. Or the path can be a single sketched curve, and the curve is not required to reference existing geometry.
pathPlane
Type: Autodesk.Revit.Elements..::.SketchPlane
The sketch plane for the path. Use this when you want to create a 2D path that resides on an existing planar face. Optional, can be null for a path curve obtained from geometry or for 2D paths where the path should not reference an existing edge.
bottomProfile
Type: Autodesk.Revit..::.SweepProfile
The bottom profile of the newly created Swept blend. It should consist of only one curve loop. the input profile must be in one plane.
topProfile
Type: Autodesk.Revit..::.SweepProfile
The top profile of the newly created Swept blend. It should consist of only one curve loop. the input profile must be in one plane.

Return Value

If creation was successful the new Swept blend is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a swept blend in a family document. The swept blend will trace from bottom profile to the top along the path. Revit will determine an appropriate default mapping for the vertices of the two profiles. If the input profile is to be a cyclic profile (curve or ellipse) it must be split into at least two segments, so that Revit can find vertices to use for mapping the swept blend.

Examples

CopyC#
private SweptBlend CreateSweptBlend(Autodesk.Revit.Document document, SketchPlane sketchPlane)
{
    SweptBlend newSweptBlend = null;

    // make sure we have a family document
    if (true == document.IsFamilyDocument)
    {
        // Create top and bottom profiles and path curve
        XYZ pnt1 = new XYZ(0, 0, 0);
        XYZ pnt2 = new XYZ(1, 0, 0);
        XYZ pnt3 = new XYZ(1, 1, 0);
        XYZ pnt4 = new XYZ(0, 1, 0);
        XYZ pnt5 = new XYZ(0, 0, 1);

        CurveArrArray arrarr1 = new CurveArrArray();
        CurveArray arr1 = new CurveArray();
        arr1.Append(document.Application.Create.NewLineBound(pnt1, pnt2));
        arr1.Append(document.Application.Create.NewLineBound(pnt2, pnt3));
        arr1.Append(document.Application.Create.NewLineBound(pnt3, pnt4));
        arr1.Append(document.Application.Create.NewLineBound(pnt4, pnt1));
        arrarr1.Append(arr1);

        XYZ pnt6 = new XYZ(0.5, 0, 0);
        XYZ pnt7 = new XYZ(1, 0.5, 0);
        XYZ pnt8 = new XYZ(0.5, 1, 0);
        XYZ pnt9 = new XYZ(0, 0.5, 0);
        CurveArrArray arrarr2 = new CurveArrArray();
        CurveArray arr2 = new CurveArray();
        arr2.Append(document.Application.Create.NewLineBound(pnt6, pnt7));
        arr2.Append(document.Application.Create.NewLineBound(pnt7, pnt8));
        arr2.Append(document.Application.Create.NewLineBound(pnt8, pnt9));
        arr2.Append(document.Application.Create.NewLineBound(pnt9, pnt6));
        arrarr2.Append(arr2);

        SweepProfile bottomProfile = document.Application.Create.NewCurveLoopsProfile(arrarr1);
        SweepProfile topProfile = document.Application.Create.NewCurveLoopsProfile(arrarr2);

        XYZ pnt10 = new XYZ(5, 0, 0);
        XYZ pnt11 = new XYZ(0, 20, 0);
        Curve curve = document.Application.Create.NewLineBound(pnt10, pnt11);

        // here create rectangular swept blend
        newSweptBlend = document.FamilyCreate.NewSweptBlend(true, curve, sketchPlane, bottomProfile, topProfile);
        if (null != newSweptBlend)
        {
            // move to proper place
            XYZ transPoint1 = new XYZ(11, 32, 0);
            document.Move(newSweptBlend, transPoint1);
        }
        else
        {
            throw new Exception("Failed to create new SweptBlend.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }
    return newSweptBlend;
}
CopyVB.NET
Private Function CreateSweptBlend(ByVal document As Autodesk.Revit.Document, ByVal sketchPlane As Autodesk.Revit.Elements.SketchPlane) As SweptBlend
    Dim newSweptBlend As SweptBlend = Nothing

    ' make sure we have a family document
    If True = document.IsFamilyDocument Then
        ' Create top and bottom profiles and path curve
        Dim pnt1 As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
        Dim pnt2 As New Autodesk.Revit.Geometry.XYZ(1, 0, 0)
        Dim pnt3 As New Autodesk.Revit.Geometry.XYZ(1, 1, 0)
        Dim pnt4 As New Autodesk.Revit.Geometry.XYZ(0, 1, 0)
        Dim pnt5 As New Autodesk.Revit.Geometry.XYZ(0, 0, 1)

        Dim arrarr1 As New CurveArrArray()
        Dim arr1 As New CurveArray()
        arr1.Append(document.Application.Create.NewLineBound(pnt1, pnt2))
        arr1.Append(document.Application.Create.NewLineBound(pnt2, pnt3))
        arr1.Append(document.Application.Create.NewLineBound(pnt3, pnt4))
        arr1.Append(document.Application.Create.NewLineBound(pnt4, pnt1))
        arrarr1.Append(arr1)

        Dim pnt6 As New Autodesk.Revit.Geometry.XYZ(0.5, 0, 0)
        Dim pnt7 As New Autodesk.Revit.Geometry.XYZ(1, 0.5, 0)
        Dim pnt8 As New Autodesk.Revit.Geometry.XYZ(0.5, 1, 0)
        Dim pnt9 As New Autodesk.Revit.Geometry.XYZ(0, 0.5, 0)
        Dim arrarr2 As New CurveArrArray()
        Dim arr2 As New CurveArray()
        arr2.Append(document.Application.Create.NewLineBound(pnt6, pnt7))
        arr2.Append(document.Application.Create.NewLineBound(pnt7, pnt8))
        arr2.Append(document.Application.Create.NewLineBound(pnt8, pnt9))
        arr2.Append(document.Application.Create.NewLineBound(pnt9, pnt6))
        arrarr2.Append(arr2)

        Dim bottomProfile As SweepProfile = document.Application.Create.NewCurveLoopsProfile(arrarr1)
        Dim topProfile As SweepProfile = document.Application.Create.NewCurveLoopsProfile(arrarr2)

        Dim pnt10 As New Autodesk.Revit.Geometry.XYZ(5, 0, 0)
        Dim pnt11 As New Autodesk.Revit.Geometry.XYZ(0, 20, 0)
        Dim curve As Curve = document.Application.Create.NewLineBound(pnt10, pnt11)

        ' here create rectangular swept blend
        newSweptBlend = document.FamilyCreate.NewSweptBlend(True, curve, sketchPlane, bottomProfile, topProfile)
        If newSweptBlend IsNot Nothing Then
            ' move to proper place
            Dim transPoint1 As New Autodesk.Revit.Geometry.XYZ(11, 32, 0)
            document.Move(newSweptBlend, transPoint1)
        Else
            Throw New Exception("Failed to create new SweptBlend.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If
    Return newSweptBlend
End Function

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input arguments-path/bottomProfile/topProfile-are null.
System..::.ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile is null.
System..::.ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile contains nothing or more than one curve loops.
System..::.ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a family symbol based profile and the family symbol profile is null.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewSweptBlend Overload
Autodesk.Revit.Creation Namespace

NewSweptBlendForm Method

[image]