Revit 2010 API
Document..::.NewTag Method
Document Class Example See Also Send Feedback
Creates a new IndependentTag Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public IndependentTag NewTag(
    View dbview,
    Element objelem,
    bool leader,
    TagMode tagmode,
    TagOrientation tagorn,
    XYZ pnt
)
Visual Basic (Declaration)
Public Function NewTag ( _
    dbview As View, _
    objelem As Element, _
    leader As Boolean, _
    tagmode As TagMode, _
    tagorn As TagOrientation, _
    pnt As XYZ _
) As IndependentTag
Visual C++
public:
IndependentTag^ NewTag(
    View^ dbview,
    Element^ objelem,
    bool leader,
    TagMode tagmode,
    TagOrientation tagorn,
    XYZ^ pnt
)

Parameters

dbview
Type: Autodesk.Revit.Elements..::.View
The view in which the dimension is to be visible.
objelem
Type: Autodesk.Revit..::.Element
The host object of tag
leader
Type: System..::.Boolean
whether have leader
tagmode
Type: Autodesk.Revit.Enums..::.TagMode
the mode of tag. Add by Category, add by Multi-Category and add by material
tagorn
Type: Autodesk.Revit.Enums..::.TagOrientation
The Orientation of the Tag
pnt
Type: Autodesk.Revit.Geometry..::.XYZ
The position of the Tag

Return Value

If successful, an IndependentTag object is returned.

Remarks

This method forms an Tag tie to the host object.

Examples

CopyC#
private IndependentTag CreateIndependentTag(Autodesk.Revit.Document document, Wall wall)
{
    // make sure active view is not a 3D view
    Autodesk.Revit.Elements.View view = document.ActiveView;

    // define tag mode and tag orientation for new tag
    TagMode tagMode = TagMode.TM_ADDBY_CATEGORY;
    TagOrientation tagorn = TagOrientation.TAG_HORIZONTAL;

    // Add the tag to the middle of the wall
    LocationCurve wallLoc = wall.Location as LocationCurve;
    XYZ wallStart = wallLoc.Curve.get_EndPoint(0);
    XYZ wallEnd = wallLoc.Curve.get_EndPoint(1);
    XYZ wallMid = wallLoc.Curve.Evaluate(0.5, true);

    IndependentTag newTag = document.Create.NewTag(view, wall, true, tagMode, tagorn, wallMid);
    if (null == newTag)
    {
        throw new Exception("Create IndependentTag Failed.");
    }

    // newTag.TagText is read-only, so we change the Type Mark type parameter to
    // set the tag text.  The label parameter for the tag family determines
    // what type parameter is used for the tag text.

    WallType type = wall.WallType;

    Parameter foundParameter = type.get_Parameter("Type Mark");
    bool result = foundParameter.Set("Hello");

    // set leader mode free
    // otherwise leader end point move with elbow point

    newTag.LeaderMode = LeaderEndCondition.LEC_FREE;
    XYZ elbowPnt = wallMid + new XYZ(5.0, 5.0, 0.0);
    newTag.LeaderElbow = elbowPnt;
    XYZ headerPnt = wallMid + new XYZ(10.0, 10.0, 0.0);
    newTag.TagHeadPosition = headerPnt;

    return newTag;
}
CopyVB.NET
Private Function CreateIndependentTag(ByVal document As Autodesk.Revit.Document, ByVal wall As Wall) As Autodesk.Revit.Elements.IndependentTag
    ' make sure active view is not a 3D view
    Dim view As Autodesk.Revit.Elements.View = document.ActiveView

    ' define tag mode and tag orientation for new tag
    Dim tagMode__1 As TagMode = TagMode.TM_ADDBY_CATEGORY
    Dim tagorn As Autodesk.Revit.Enums.TagOrientation = Autodesk.Revit.Enums.TagOrientation.TAG_HORIZONTAL

    ' Add the tag to the middle of the wall
    Dim wallLoc As LocationCurve = TryCast(wall.Location, LocationCurve)
    Dim wallStart As Autodesk.Revit.Geometry.XYZ = wallLoc.Curve.EndPoint(0)
    Dim wallEnd As Autodesk.Revit.Geometry.XYZ = wallLoc.Curve.EndPoint(1)
    Dim wallMid As Autodesk.Revit.Geometry.XYZ = wallLoc.Curve.Evaluate(0.5, True)

    Dim newTag As Autodesk.Revit.Elements.IndependentTag = document.Create.NewTag(view, wall, True, tagMode__1, tagorn, wallMid)
    If newTag Is Nothing Then
        Throw New Exception("Create IndependentTag Failed.")
    End If

    ' newTag.TagText is read-only, so we change the Type Mark type parameter to
    ' set the tag text. The label parameter for the tag family determines
    ' what type parameter is used for the tag text.

    Dim type As Autodesk.Revit.Symbols.WallType = wall.WallType

    Dim foundParameter As Parameter = type.Parameter("Type Mark")
    Dim result As Boolean = foundParameter.[Set]("Hello")

    ' set leader mode free
    ' otherwise leader end point move with elbow point

    newTag.LeaderMode = Autodesk.Revit.Enums.LeaderEndCondition.LEC_FREE
    Dim elbowPnt As Autodesk.Revit.Geometry.XYZ = wallMid + New Autodesk.Revit.Geometry.XYZ(5.0R, 5.0R, 0.0R)
    newTag.LeaderElbow = elbowPnt
    Dim headerPnt As Autodesk.Revit.Geometry.XYZ = wallMid + New Autodesk.Revit.Geometry.XYZ(10.0R, 10.0R, 0.0R)
    newTag.TagHeadPosition = headerPnt

    Return newTag
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewTakeoffFitting Method

[image]