Revit 2010 API
Mullion Members
Mullion Class Constructors Methods Properties See Also Send Feedback

The Mullion type exposes the following members.

Constructors

Name | Description
Mullion | For Internal Use Only.

Methods

Name | Description
BreakMullion | This method is used to break the current Mullion at ends with its neighboring mullions.
JoinMullion | This method is used to control the join condition the current Mullion with its neighboring mullions.

Properties

Name | Description
AsFamilyInstance | This property is used to get family instance within project.
LocationCurve | This method get the curve location of the current Mullion.
Lock | Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.
Lockable | Get - to get whether the Mullion can be lock or unlock.
MullionType | The MullionType style of this Mullion. Get - to access type of mullion Set - change type of mullion. If the mullion is locked, InvalidOperationException exception will be thrown.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.

See Also

Mullion Class
Autodesk.Revit.Elements Namespace

Mullion Constructor

[image]