Revit 2010 API
ContFooting Class
Members Example See Also Send Feedback
An object that represents a Continuous Footing within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ContFooting : HostObject
Visual Basic (Declaration)
Public Class ContFooting _
    Inherits HostObject
Visual C++
public ref class ContFooting : public HostObject

Examples

CopyC#
public void GetInfo_ContFooting(ContFooting contFooting)
{
    string message = "Wall Foundation : ";

    // Get Analytical model
    if (null != contFooting.AnalyticalModel)
    {
        message += "\nAnalytical model : " + contFooting.AnalyticalModel;
    }

    // Get Footing type name
    message += "\nFooting type name is : " + contFooting.FootingType.Name;

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_ContFooting(ByVal contFooting As Autodesk.Revit.Elements.ContFooting)
    Dim message As String = "Wall Foundation : "

    ' Get Analytical model
    If contFooting.AnalyticalModel IsNot Nothing Then
        message += vbLf & "Analytical model : " & contFooting.AnalyticalModel.ToString
    End If

    ' Get Footing type name
    message += vbLf & "Footing type name is : " & contFooting.FootingType.Name

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.ContFooting

See Also

ContFooting Members
Autodesk.Revit.Elements Namespace

ContFooting Members

[image] [image]