Revit 2010 API
ElectricalSystem..::.AddToCircuit Method
ElectricalSystem Class See Also Send Feedback
Add a set of exist components to the Electrical System.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool AddToCircuit(
    ElementSet components
)
Visual Basic (Declaration)
Public Function AddToCircuit ( _
    components As ElementSet _
) As Boolean
Visual C++
public:
bool AddToCircuit(
    ElementSet^ components
)

Parameters

components
Type: Autodesk.Revit..::.ElementSet
The components added to the electrical system.

Return Value

If successful, all the components will add to the system. Otherwise nothing is returned.

Remarks

This method will only function with the Autodesk Revit MEP application.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace

DisconnectPanel Method

[image]