Revit 2010 API
Document..::.NewFlexPipe Method (Connector, XYZArray, FlexPipeType)
Document Class See Also Send Feedback
Adds a new flex pipe into the document, using a connector, point array and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlexPipe NewFlexPipe(
    Connector connector,
    XYZArray points,
    FlexPipeType pipeType
)
Visual Basic (Declaration)
Public Function NewFlexPipe ( _
    connector As Connector, _
    points As XYZArray, _
    pipeType As FlexPipeType _
) As FlexPipe
Visual C++
public:
FlexPipe^ NewFlexPipe(
    Connector^ connector,
    XYZArray^ points,
    FlexPipeType^ pipeType
)

Parameters

connector
Type: Autodesk.Revit.MEP..::.Connector
The connector to be connected to the flex pipe, including the end points.
points
Type: Autodesk.Revit.Geometry..::.XYZArray
The point array indicating the path of the flex duct.
pipeType
Type: Autodesk.Revit.MEP..::.FlexPipeType
The type of the flex pipe.

Return Value

If creation was successful then a new flex pipe is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connector is a fitting or equipment connector of the correct domain, and if the connector’s direction matches the direction of the flex pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument connector or points is null.
System..::.InvalidOperationException | Thrown when the flex pipe cannot be created or regenerate fails.

See Also

Document Class
NewFlexPipe Overload
Autodesk.Revit.Creation Namespace

NewFlexPipe Method (Connector, Connector, FlexPipeType)

[image]