Revit 2010 API
ElementReferenceType Enumeration
See Also Send Feedback
Element reference types.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ElementReferenceType
Visual Basic (Declaration)
Public Enumeration ElementReferenceType
Visual C++
public enum class ElementReferenceType

Members

Member name | Description
REFERENCE_TYPE_MESH | The reference is to a mesh.
REFERENCE_TYPE_CUT_EDGE | The reference is to a face that was cut (where the original pick was made on the cut edge).
REFERENCE_TYPE_INSTANCE | The reference is an instance of a symbol.
REFERENCE_TYPE_FOREIGN | The reference is to geometry or elements in linked Revit file.
REFERENCE_TYPE_SURFACE | The reference is to a face or face region.
REFERENCE_TYPE_LINEAR | The reference is to a curve of edge.
REFERENCE_TYPE_NONE |

See Also

Autodesk.Revit.Enums Namespace

ExportPaperFormat Enumeration

[image]