Revit 2010 API
PipeConnector Class
Members See Also Send Feedback
A pipe connector that is assigned to a mechanical equipment or pipe fitting family. Provides access to the pipe connector in Autodesk Revit MEP family document.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PipeConnector : Element,
    IConnector
Visual Basic (Declaration)
Public Class PipeConnector _
    Inherits Element _
    Implements IConnector
Visual C++
public ref class PipeConnector : public Element,
    IConnector

Remarks

This element type is accessible only in Autodek Revit MEP family documents. Pipe connectors that accessible in MEP project documents are not elements, and are represented by Autodesk::Revit::MEP::Connector.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.MEP..::.PipeConnector

See Also

PipeConnector Members
Autodesk.Revit.MEP Namespace

PipeConnector Members

[image] [image]