Revit 2010 API
PreEventArgs Class
Members See Also Send Feedback
The class is used as a base class for the arguments for any pre-event.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PreEventArgs : RevitEventArgs
Visual Basic (Declaration)
Public Class PreEventArgs _
    Inherits RevitEventArgs
Visual C++
public ref class PreEventArgs : public RevitEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.ApplicationClosingEventArgs
Autodesk.Revit.Events..::.DialogBoxShowingEventArgs
Autodesk.Revit.Events..::.DocumentCreatingEventArgs
Autodesk.Revit.Events..::.DocumentOpeningEventArgs
Autodesk.Revit.Events..::.PreDocEventArgs

See Also

PreEventArgs Members
Autodesk.Revit.Events Namespace

PreEventArgs Members

[image] [image]