Revit 2010 API
Application..::.OnDocumentNewed Event
Application Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentCreated event instead. Subscribe to the OnDocumentNewed event to be notified after a new document has been created.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentCreated event instead.")]
public event DocumentNewedEventHandler OnDocumentNewed
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentCreated event instead.")> _
Public Event OnDocumentNewed As DocumentNewedEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentCreated event instead.")]
public:
 event DocumentNewedEventHandler^ OnDocumentNewed {
    void add (DocumentNewedEventHandler^ value);
    void remove (DocumentNewedEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a new document has been created. By subscribing to this event the application will be notified after such an event and can perform an action in response.

See Also

Application Class
Autodesk.Revit Namespace

OnDocumentOpened Event

[image]