Revit 2010 API
RibbonItem Members
RibbonItem Class Constructors Methods Properties See Also Send Feedback

The RibbonItem type exposes the following members.

Constructors

Name | Description
RibbonItem | Initializes a new instance of the RibbonItem class

Methods

Name | Description
Equals | Returns a value whether the RibbonItem equals to another RibbonItem. (Overrides Object..::.Equals(Object).)

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the button is enabled.
ItemText | Gets or sets the text displayed on the button.
ItemType | Gets the item type.
ToolTip | The description that appears as a ToolTip for the button.

See Also

RibbonItem Class
Autodesk.Revit Namespace

RibbonItem Constructor

[image]