Revit 2010 API
Document..::.SaveAs Method (String, Boolean, PostedErrorArray)
Document Class See Also Send Feedback
Saves the document to a given file name with the option to change the document's name in Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SaveAs(
    string fileName,
    bool changeDocumentFilename,
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    fileName As String, _
    changeDocumentFilename As Boolean, _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ fileName,
    bool changeDocumentFilename,
    PostedErrorArray^ postedErrors
)

Parameters

fileName
Type: System..::.String
File name to be saved as.
changeDocumentFilename
Type: System..::.Boolean
Indicates if the current file name on the title bar of Revit will be changed accordingly.
postedErrors
Type: Autodesk.Revit..::.PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns 'false' if save operation fails. Also returns 'false' if saving as is cancelled by an external application during 'DocumentSavingAs' event. When function succeeds, 'true' is returned.

Remarks

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
SaveAs Overload
Autodesk.Revit Namespace

SeparateElements Method

[image]