Revit 2010 API
Document..::.Save Method (PostedErrorArray)
Document Class See Also Send Feedback
Saves the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Save(
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function Save ( _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool Save(
    PostedErrorArray^ postedErrors
)

Parameters

postedErrors
Type: Autodesk.Revit..::.PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns 'false' if save operation fails. Also returns 'false' if saving is cancelled by an external application during 'DocumentSaving' event. When function succeeds, 'true' is returned.

Remarks

The trial version of Revit doesn't support this function. If the user tries to call this function in a trial version, InvalidOperationException will be thrown.

The 'postedErrors' parameter is used only when runing Revit in UI-less mode.

See Also

Document Class
Save Overload
Autodesk.Revit Namespace

SaveAs Method

[image] [image]