Revit 2010 API
CylindricalFace Class
Members Example See Also Send Feedback
A cylinder face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CylindricalFace : Face
Visual Basic (Declaration)
Public Class CylindricalFace _
    Inherits Face
Visual C++
public ref class CylindricalFace : public Face

Remarks

Cylinder faces are defined by cylinder surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces. S(u, v) = Origin + cos(u)*Radius[0] + sin(u)*Radius[1] + v*Axis

Examples

CopyC#
private void GetCylindricalFaceInfo(Face face)
{
    CylindricalFace cylindricalFace = face as CylindricalFace;
    if (null != cylindricalFace)
    {
        XYZ axis = cylindricalFace.Axis;
        XYZ origin = cylindricalFace.Origin;
        XYZ radius = cylindricalFace.get_Radius(0);
    }
}
CopyVB.NET
Private Sub GetCylindricalFaceInfo(ByVal face As Autodesk.Revit.Geometry.Face)
    Dim cylindricalFace As CylindricalFace = TryCast(face, CylindricalFace)
    If cylindricalFace IsNot Nothing Then
        Dim axis As Autodesk.Revit.Geometry.XYZ = cylindricalFace.Axis
        Dim origin As Autodesk.Revit.Geometry.XYZ = cylindricalFace.Origin
        Dim radius As Autodesk.Revit.Geometry.XYZ = cylindricalFace.Radius(0)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Face
Autodesk.Revit.Geometry..::.CylindricalFace

See Also

CylindricalFace Members
Autodesk.Revit.Geometry Namespace

CylindricalFace Members

[image] [image]