Revit 2010 API
XYZ..::.Angle Method
XYZ Class See Also Send Feedback
Returns the angle between this vector and the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Angle(
    XYZ source
)
Visual Basic (Declaration)
Public Function Angle ( _
    source As XYZ _
) As Double
Visual C++
public:
double Angle(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.XYZ
The specified vector.

Return Value

The real number between 0 and PI equal to the angle between the two vectors.

Remarks

The angle between the two vectors is measured in the plane spanned by them.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace

AngleAround Method

[image]