Revit 2010 API
PushButton Class
Members See Also Send Feedback
The RibbonItem object represents an item on a RibbonPanel. It can be a push-button or a pull-down which contains the information for creating one RibbonItem.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PushButton : RibbonItem
Visual Basic (Declaration)
Public Class PushButton _
    Inherits RibbonItem
Visual C++
public ref class PushButton : public RibbonItem

Remarks

All the properties and methods are not supported in VSTA.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.RibbonItem
Autodesk.Revit..::.PushButton

See Also

PushButton Members
Autodesk.Revit Namespace

PushButton Members

[image] [image]