Revit 2010 API
FootPrintRoof Members
FootPrintRoof Class Constructors Methods Properties See Also Send Feedback

The FootPrintRoof type exposes the following members.

Constructors

Name | Description
FootPrintRoof | For Internal Use Only.

Methods

Name | Description
GetProfiles | Retrieve all the curveLoops of FootPrintRoof.

Properties

Name | Description
CurtainGrids | Retrieve all the CurtainGrid objects of a FootPrintRoof.
DefinesSlope | Retrieve or set the DefinesSlope of the curve.
ExtendIntoWall | Retrieve or set whether extend into wall the curve.
Offset | Retrieve or set the Offset of the curve.
Overhang | Retrieve or set the Overhang of the curve.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
SlopeAngle | Retrieve or set the SlopeAngle of the curve.

See Also

FootPrintRoof Class
Autodesk.Revit.Elements Namespace

FootPrintRoof Constructor

[image]