Revit 2010 API
FilterCriterion..::.ParameterValue Property
FilterCriterion Class See Also Send Feedback
Gets or sets the parameter value of this criterion.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterStorage ParameterValue { get; set; }
Visual Basic (Declaration)
Public Property ParameterValue As ParameterStorage
Visual C++
public:
property ParameterStorage^ ParameterValue {
    ParameterStorage^ get ();
    void set (ParameterStorage^ value);
}

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter of ParameterStorage is null.
System..::.InvalidOperationException | Thrown when the Filter Criterion is internally marked as read-only.

See Also

FilterCriterion Class
Autodesk.Revit Namespace

FormArray Class

[image]