Revit 2010 API
Filter..::.NewTypeFilter Method (Type)
Filter Class See Also Send Feedback
Creates a new TypeFilter object which filters based on exact type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TypeFilter NewTypeFilter(
    Type givenType
)
Visual Basic (Declaration)
Public Function NewTypeFilter ( _
    givenType As Type _
) As TypeFilter
Visual C++
public:
TypeFilter^ NewTypeFilter(
    Type^ givenType
)

Parameters

givenType
Type: System..::.Type
Filter elements by the given type.

Return Value

Returns a new type filter object within given type.

Remarks

It will not find out the elements which is given type's derived classes.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified givenType is nullptr.

See Also

Filter Class
NewTypeFilter Overload
Autodesk.Revit.Creation Namespace

NewTypeFilter Method (Type, Boolean)

[image]