Revit 2010 API
Application..::.FileImported Event
Application Class See Also Send Feedback
Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<FileImportedEventArgs> FileImported
Visual Basic (Declaration)
Public Event FileImported As EventHandler(Of FileImportedEventArgs)
Visual C++
public:
 event EventHandler<FileImportedEventArgs^>^ FileImported {
    void add (EventHandler<FileImportedEventArgs^>^ value);
    void remove (EventHandler<FileImportedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished importing a file of format supported by the API. It is raised even when file importing failed or was cancelled (during FileImporting event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of importing has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace

FileImporting Event

[image]