Revit 2010 API
PointOnPlane..::.NewPointOnPlane Method
PointOnPlane Class See Also Send Feedback
Construct a PointOnPlane given a reference and a location in space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static PointOnPlane NewPointOnPlane(
    Document doc,
    Reference planeReference,
    XYZ position,
    XYZ xvec
)
Visual Basic (Declaration)
Public Shared Function NewPointOnPlane ( _
    doc As Document, _
    planeReference As Reference, _
    position As XYZ, _
    xvec As XYZ _
) As PointOnPlane
Visual C++
public:
static PointOnPlane^ NewPointOnPlane(
    Document^ doc,
    Reference^ planeReference,
    XYZ^ position,
    XYZ^ xvec
)

Parameters

doc
Type: Autodesk.Revit..::.Document
The document containing the plane reference.
planeReference
Type: Autodesk.Revit.Geometry..::.Reference
position
Type: Autodesk.Revit.Geometry..::.XYZ
A 3-dimensional position.
xvec
Type: Autodesk.Revit.Geometry..::.XYZ
The direction of the point's X-coordinate vector in the plane's coordinates. Optional; default value is the X-coordinate vector of the plane.

Return Value

A new PointOnPlane object with 2-dimensional Position, XVec, and Offset properties set to match the given 3-dimensional arguments.

See Also

PointOnPlane Class
Autodesk.Revit.Elements Namespace

SetPlaneReference Method

[image]