Revit 2010 API
Materials Members
Materials Class Constructors Methods Properties See Also Send Feedback

The Materials type exposes the following members.

Constructors

Name | Description
Materials | For Internal Use Only.

Methods

Name | Description
AddConcrete | Add a concrete material with the given name .
AddGeneric | Add a generic material with the given name .
AddOther | Add an other material with the given name .
AddSteel | Add a steel material with the given name .
AddWood | Add a wood material with the given name .
Contains | Overloaded. Checks if the material set contains the material with the specified identifier.
Remove | Remove the material with the speicified name .

Properties

Name | Description
Item | Overloaded. Gets the material with the specified identifier.

See Also

Materials Class
Autodesk.Revit Namespace

Materials Constructor

[image]