Revit 2010 API
Document..::.GetSpaceAtPoint Method (XYZ)
Document Class See Also Send Feedback
Gets a space containing the point.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Space GetSpaceAtPoint(
    XYZ point
)
Visual Basic (Declaration)
Public Function GetSpaceAtPoint ( _
    point As XYZ _
) As Space
Visual C++
public:
Space^ GetSpaceAtPoint(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
Point to be checked.

Return Value

The space containing the point.

Remarks

Surveys only the spaces from the final phase of the project. The first one found will be returned. If there is no space containing the point, it returns null.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the point is nullptr.
System..::.ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.

See Also

Document Class
GetSpaceAtPoint Overload
Autodesk.Revit Namespace

GetSpaceAtPoint Method (XYZ, Phase)

[image]