Revit 2010 API
FamilyInstance..::.SuperComponent Property
FamilyInstance Class See Also Send Feedback
Property to get the super componet of current family instance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element SuperComponent { get; }
Visual Basic (Declaration)
Public ReadOnly Property SuperComponent As Element
Visual C++
public:
property Element^ SuperComponent {
    Element^ get ();
}

Remarks

When current familyinstance has no super component, it returns null

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace

Symbol Property

[image]