Revit 2010 API
FamilyInstance..::.ExtensionUtility Property
FamilyInstance Class See Also Send Feedback
Property to check whether the instance can be extended and return the interface for extension operation.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public IExtension ExtensionUtility { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExtensionUtility As IExtension
Visual C++
public:
property IExtension^ ExtensionUtility {
    IExtension^ get ();
}

Remarks

If the family instance can not support extension operation, it returns null

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace

FacingFlipped Property

[image]