Revit 2010 API
ConicalFace Class
Members Example See Also Send Feedback
A cone face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ConicalFace : Face
Visual Basic (Declaration)
Public Class ConicalFace _
    Inherits Face
Visual C++
public ref class ConicalFace : public Face

Remarks

Cone faces are defined by cone surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces. S(u, v) = Origin + v*[sin(HalfAngle)*(cos(u)*Radius[0] + sin(u)*Radius[1]) + cos(HalfAngle)*Axis]

Examples

CopyC#
private void GetConicalFaceInfo(Face face)
{
    ConicalFace conicalFace = face as ConicalFace;
    if (null != conicalFace)
    {
        XYZ axis = conicalFace.Axis;
        XYZ origin = conicalFace.Origin;
        double halfAngle = conicalFace.HalfAngle;
        XYZ radius = conicalFace.get_Radius(0);
    }
}
CopyVB.NET
Private Sub GetConicalFaceInfo(ByVal face As Autodesk.Revit.Geometry.Face)
    Dim conicalFace As ConicalFace = TryCast(face, ConicalFace)
    If conicalFace IsNot Nothing Then
        Dim axis As Autodesk.Revit.Geometry.XYZ = conicalFace.Axis
        Dim origin As Autodesk.Revit.Geometry.XYZ = conicalFace.Origin
        Dim halfAngle As Double = conicalFace.HalfAngle
        Dim radius As Autodesk.Revit.Geometry.XYZ = conicalFace.Radius(0)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Face
Autodesk.Revit.Geometry..::.ConicalFace

See Also

ConicalFace Members
Autodesk.Revit.Geometry Namespace

ConicalFace Members

[image] [image]