Revit 2010 API
JoinType Enumeration
See Also Send Feedback
The type of join at the end of an element. The join type affects only the graphic treatment, i.e. cleaning of the end, not the physical join behavior.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum JoinType
Visual Basic (Declaration)
Public Enumeration JoinType
Visual C++
public enum class JoinType

Members

Member name | Description
Extension | Extension Join
SquareOff | Square-off Join
Miter | Miter Join
Abut | Abut Join
None | No join type

See Also

Autodesk.Revit Namespace

Leader Class

[image]