Revit 2010 API
RibbonPanel..::.Items Property
RibbonPanel Class See Also Send Feedback
Gets the collection of RibbonItems assigned to the RibbonPanel.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public List<RibbonItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As List(Of RibbonItem)
Visual C++
public:
property List<RibbonItem^>^ Items {
    List<RibbonItem^>^ get ();
}

Remarks

The Items property is a zero-based indexed collection used to hold the button items assigned to the RibbonPanel. Because the property is read-only, it can not be assigned a collection of RibbonPanel items directly. Items can be added by using the methods AddItem.

See Also

RibbonPanel Class
Autodesk.Revit Namespace

Name Property

[image]