Revit 2010 API
Document..::.Mirror Method (ElementId%, Reference)
Document Class See Also Send Feedback
Mirrors an element, specified by id, about a reference.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Mirror(
    ref ElementId id,
    Reference reference
)
Visual Basic (Declaration)
Public Function Mirror ( _
    ByRef id As ElementId, _
    reference As Reference _
) As Boolean
Visual C++
public:
bool Mirror(
    ElementId% id,
    Reference^ reference
)

Parameters

id
Type: Autodesk.Revit..::.ElementId %
The ElementId for the element that is to be mirrored.
reference
Type: Autodesk.Revit.Geometry..::.Reference
The reference by which the elements will mirror.

Return Value

If the elements are mirrored successfully then the method returns true.

See Also

Document Class
Mirror Overload
Autodesk.Revit Namespace

Mirror Method (ElementIdSet, Reference)

[image]