Revit 2010 API
DemandFactorDataSet Members
DemandFactorDataSet Class Constructors Methods Properties See Also Send Feedback

The DemandFactorDataSet type exposes the following members.

Constructors

Name | Description
DemandFactorDataSet | Initializes a new instance of the DemandFactorDataSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
Size | Returns the number of objects that are in the set.

See Also

DemandFactorDataSet Class
Autodesk.Revit.MEP Namespace

DemandFactorDataSet Constructor

[image]