Revit 2010 API
Application..::.NewHermiteSpline Method
Application Class See Also Send Feedback
Creates a new geometric Hermite spline object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public HermiteSpline NewHermiteSpline(
    XYZArray ctrlPoints,
    bool bPeriodic
)
Visual Basic (Declaration)
Public Function NewHermiteSpline ( _
    ctrlPoints As XYZArray, _
    bPeriodic As Boolean _
) As HermiteSpline
Visual C++
public:
HermiteSpline^ NewHermiteSpline(
    XYZArray^ ctrlPoints,
    bool bPeriodic
)

Parameters

ctrlPoints
Type: Autodesk.Revit.Geometry..::.XYZArray
The control points of the Hermite spline.
bPeriodic
Type: System..::.Boolean
True if the Hermite spline is to be periodic.

Remarks

See Also

Application Class
Autodesk.Revit.Creation Namespace

NewImageImportOptions Method

[image]