Revit 2010 API
SpotDimension Class
Members Example See Also Send Feedback
An object that represents a spot dimension within the Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SpotDimension : Dimension
Visual Basic (Declaration)
Public Class SpotDimension _
    Inherits Dimension
Visual C++
public ref class SpotDimension : public Dimension

Examples

CopyC#
private void Getinfo_SpotDimension(SpotDimension spotDimension)
{
    string message = "SpotDimension's Location : ";
    Location location = spotDimension.Location;

    if (location is LocationPoint)
    {
        LocationPoint point = location as LocationPoint;

        message += "\n" + location.GetType().Name + " : ";
        message += "(" + point.Point.X + ", " + point.Point.Y + ", " + point.Point.Z + ")";
    }
    else
    {
        LocationCurve locCurve = location as LocationCurve;
        Curve curve = locCurve.Curve;
        message += "\n" + location.GetType().Name + " : ";
        message += "\nStart Point : " + "(" + curve.get_EndPoint(0).X + ", "
                    + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        message += "\nEnd point : " + "(" + curve.get_EndPoint(1).X + ", "
                    + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
    }

    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Private Sub Getinfo_SpotDimension(ByVal spotDimension As SpotDimension)
    Dim message As String = "SpotDimension's Location : "
    Dim location As Location = spotDimension.Location

    If TypeOf location Is LocationPoint Then
        Dim point As LocationPoint = TryCast(location, LocationPoint)

        message += vbLf & location.[GetType]().Name & " : "
        message += (("(" & point.Point.X & ", ") + point.Point.Y & ", ") + point.Point.Z & ")"
    Else
        Dim locCurve As LocationCurve = TryCast(location, LocationCurve)
        Dim curve As Curve = locCurve.Curve
        message += vbLf & location.[GetType]().Name & " : "
        message += (((vbLf & "Start Point : " & "(") + curve.EndPoint(0).X & ", ") + curve.EndPoint(0).Y & ", ") + curve.EndPoint(0).Z & ")"
        message += (((vbLf & "End point : " & "(") + curve.EndPoint(1).X & ", ") + curve.EndPoint(1).Y & ", ") + curve.EndPoint(1).Z & ")"
    End If

    MessageBox.Show(message, "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Dimension
Autodesk.Revit.Elements..::.SpotDimension

See Also

SpotDimension Members
Autodesk.Revit.Elements Namespace

SpotDimension Members

[image] [image]