Revit 2010 API
Grid..::.IsCurved Property
Grid Class See Also Send Feedback
Test to see if the grid line is curved or straight.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsCurved { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCurved As Boolean
Visual C++
public:
property bool IsCurved {
    bool get ();
}

Remarks

A value of True is returned if the grid line is an arc or False if the grid line is straight. Use the Curve property to retrieve an object that represents the geometry of the grid line.

See Also

Grid Class
Autodesk.Revit.Elements Namespace

Parameter Property

[image] [image]