Revit 2010 API
ParameterStorage..::.Set Method (Double)
ParameterStorage Class See Also Send Feedback
Sets the parameter to a new real number value.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Set(
    double value
)
Visual Basic (Declaration)
Public Overridable Function Set ( _
    value As Double _
) As Boolean
Visual C++
public:
virtual bool Set(
    double value
)

Parameters

value
Type: System..::.Double
The new double value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as a Double.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown System::ArgumentNullException when the value is infinite.

See Also

ParameterStorage Class
Set Overload
Autodesk.Revit Namespace

Set Method (Int32)

[image]