Revit 2010 API
Symbol..::.Duplicate Method
Symbol Class See Also Send Feedback
Duplicate this object.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Symbol Duplicate(
    string name
)
Visual Basic (Declaration)
Public Function Duplicate ( _
    name As String _
) As Symbol
Visual C++
public:
Symbol^ Duplicate(
    String^ name
)

Parameters

name
Type: System..::.String
The new name that will be assigned to the duplicated object.

Return Value

If successful the duplicated object is returned, otherwise Nothing.

Remarks

This method attempts to duplicate the object and assign it the specified name. In some cases the name must be unique, i.e. not already exist in the project. If the name is required to be unique and the name is not a System.ArgumentException will be thrown. If for some reason the object cannot be duplicated a System.NullReferenceException will be thrown.

See Also

Symbol Class
Autodesk.Revit Namespace

Symbol Properties

[image] [image]