Revit 2010 API
Filter..::.NewStructuralTypeFilter Method
Filter Class See Also Send Feedback
Creates a StructuralTypeFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public StructuralTypeFilter NewStructuralTypeFilter(
    StructuralType structType
)
Visual Basic (Declaration)
Public Function NewStructuralTypeFilter ( _
    structType As StructuralType _
) As StructuralTypeFilter
Visual C++
public:
StructuralTypeFilter^ NewStructuralTypeFilter(
    StructuralType structType
)

Parameters

structType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
Filter elements by the structural type.

Return Value

Returns a new structural type filter object with given structural type.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace

NewSymbolFilter Method

[image]