Revit 2010 API
Application..::.Cities Property
Application Class Example See Also Send Feedback
Returns a set of all the known city locations within Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CitySet Cities { get; }
Visual Basic (Declaration)
Public ReadOnly Property Cities As CitySet
Visual C++
public:
property CitySet^ Cities {
    CitySet^ get ();
}

Remarks

Each city has information about longitude, latitude etc.

Examples

CopyC#
// Get all revit support cities
Autodesk.Revit.Site.CitySet cities = application.Cities;

// Set all Revit support cities into an ArrayList
System.Collections.ArrayList cityList = new System.Collections.ArrayList();
foreach (Autodesk.Revit.Site.City city in cities)
{
    cityList.Add(city);
}
CopyVB.NET
' Get all revit support cities
Dim cities As Autodesk.Revit.Site.CitySet = application.Cities

' Set all Revit support cities into an ArrayList
Dim cityList As New System.Collections.ArrayList()
For Each city As Autodesk.Revit.Site.City In cities
    cityList.Add(city)
Next

See Also

Application Class
Autodesk.Revit Namespace

Create Property

[image]