Revit 2010 API
MEPSpaceConstruction..::.NewConstruction Method
MEPSpaceConstruction Class See Also Send Feedback
Create a new construction for Space constructions.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MEPBuildingConstruction NewConstruction(
    string pName
)
Visual Basic (Declaration)
Public Function NewConstruction ( _
    pName As String _
) As MEPBuildingConstruction
Visual C++
public:
MEPBuildingConstruction^ NewConstruction(
    String^ pName
)

Parameters

pName
Type: System..::.String
The name of the new Construction.

Remarks

If the name is same as an existing one, an exception will be thrown.

See Also

MEPSpaceConstruction Class
Autodesk.Revit Namespace

MEPSpaceConstruction Properties

[image] [image]