Revit 2010 API
FamilySymbolProfile Class
Members See Also Send Feedback
Represents a family symbol based profile for sweep or swept blend elements.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FamilySymbolProfile : SweepProfile
Visual Basic (Declaration)
Public Class FamilySymbolProfile _
    Inherits SweepProfile
Visual C++
public ref class FamilySymbolProfile : public SweepProfile

Remarks

Use objects of this type in methods as NewSweep and NewSweptBlend to create the profile.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.SweepProfile
Autodesk.Revit..::.FamilySymbolProfile

See Also

FamilySymbolProfile Members
Autodesk.Revit Namespace

FamilySymbolProfile Members

[image] [image]