Revit 2010 API
Document..::.Mirror Method (ElementIdSet, Reference)
Document Class See Also Send Feedback
Mirrors several elements, specified by ids, about a reference.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Mirror(
    ElementIdSet ids,
    Reference reference
)
Visual Basic (Declaration)
Public Function Mirror ( _
    ids As ElementIdSet, _
    reference As Reference _
) As Boolean
Visual C++
public:
bool Mirror(
    ElementIdSet^ ids,
    Reference^ reference
)

Parameters

ids
Type: Autodesk.Revit..::.ElementIdSet
A set of elements that are to be mirrored.
reference
Type: Autodesk.Revit.Geometry..::.Reference
The reference by which the elements will mirror.

Return Value

If the elements are mirrored successfully then the method returns true.

See Also

Document Class
Mirror Overload
Autodesk.Revit Namespace

Mirror Method (ElementSet, Line)

[image]