Revit 2010 API
ElementIterator..::.Current Property
ElementIterator Class See Also Send Feedback
The object that represents the current element in the iterator.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Field Value

This object will be derived from Autodesk.Revit.Element.

Implements

IEnumerator..::.Current

Remarks

In order for this property to return a valid element after the iterator is first obtained or reset, the iterator must have MoveNext called upon it once.

See Also

ElementIterator Class
Autodesk.Revit Namespace

ElementSet Class

[image]