Revit 2010 API
Document..::.LoadFamily Method (Document, IFamilyLoadOptions)
Document Class See Also Send Feedback
Loads the contents of this family document into another document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Family LoadFamily(
    Document targetDocument,
    IFamilyLoadOptions familyLoadOptions
)
Visual Basic (Declaration)
Public Function LoadFamily ( _
    targetDocument As Document, _
    familyLoadOptions As IFamilyLoadOptions _
) As Family
Visual C++
public:
Family^ LoadFamily(
    Document^ targetDocument,
    IFamilyLoadOptions^ familyLoadOptions
)

Parameters

targetDocument
Type: Autodesk.Revit..::.Document
The target document which the family will be loaded into.
familyLoadOptions
Type: Autodesk.Revit..::.IFamilyLoadOptions
The interface implementation to use when loading the family into document.

Return Value

Returns the reference of the family in the target document.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"targetDocument" or "familyLoadOptions"-is null.
System..::.InvalidOperationException | Thrown when the current document is not a family document, or the target document doesn't support load of this family. or the load was cancelled due to the response from one of the interface methods.

See Also

Document Class
LoadFamily Overload
Autodesk.Revit Namespace

LoadFamily Method (String, Family)

[image]