Revit 2010 API
Application..::.NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
Specify if the family instance is structural.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace

NewFamilyInstanceCreationData Method (Curve, FamilySymbol, Level, StructuralType)

[image]