Revit 2010 API
ControlledApplication..::.OnDocumentClosed Event
ControlledApplication Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentClosed event instead. Subscribe to the OnDocumentClosed event to be notified when a document is closed during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentClosed event instead.")]
public event DocumentClosedEventHandler OnDocumentClosed
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentClosed event instead.")> _
Public Event OnDocumentClosed As DocumentClosedEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentClosed event instead.")]
public:
 event DocumentClosedEventHandler^ OnDocumentClosed {
    void add (DocumentClosedEventHandler^ value);
    void remove (DocumentClosedEventHandler^ value);
}

Remarks

Sometimes a document will be closed during an API command. By subscribing to this event your application will be notified of such an event and perform an action, such as do some external checking etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace

OnDocumentNewed Event

[image]