Revit 2010 API
Form..::.MoveSubElement Method
Form Class See Also Send Feedback
Move a face/edge/curve/vertex of the form, specified by a reference, and an offset vector.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void MoveSubElement(
    Reference subElementReference,
    XYZ offset
)
Visual Basic (Declaration)
Public Sub MoveSubElement ( _
    subElementReference As Reference, _
    offset As XYZ _
)
Visual C++
public:
void MoveSubElement(
    Reference^ subElementReference,
    XYZ^ offset
)

Parameters

subElementReference
Type: Autodesk.Revit.Geometry..::.Reference
The geometry reference of face/edge/curve/vertex
offset
Type: Autodesk.Revit.Geometry..::.XYZ
The vector by which the element is to be moved.

See Also

Form Class
Autodesk.Revit.Elements Namespace

RotateProfile Method

[image]