Revit 2010 API
LayoutRuleClearSpacing Constructor (Double, BeamSystemJustifyType)
LayoutRuleClearSpacing Class See Also Send Feedback
Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LayoutRuleClearSpacing(
    double spacing,
    BeamSystemJustifyType justifyType
)
Visual Basic (Declaration)
Public Sub New ( _
    spacing As Double, _
    justifyType As BeamSystemJustifyType _
)
Visual C++
public:
LayoutRuleClearSpacing(
    double spacing,
    BeamSystemJustifyType justifyType
)

Parameters

spacing
Type: System..::.Double
The value of spacing must be in [0, 30000).
justifyType
Type: Autodesk.Revit.Enums..::.BeamSystemJustifyType
The type of the justification, it's corresponding to the items in the element properties dialog.

Remarks

The value of spacing must be in [0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleClearSpacing Class
LayoutRuleClearSpacing Overload
Autodesk.Revit.Elements Namespace

LayoutRuleClearSpacing Methods

[image] [image]