Revit 2010 API
ParameterStorage..::.StorageType Property
ParameterStorage Class See Also Send Feedback
Describes the type that contains parameter's value.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public StorageType StorageType { get; }
Visual Basic (Declaration)
Public ReadOnly Property StorageType As StorageType
Visual C++
public:
property StorageType StorageType {
    StorageType get ();
}

Remarks

The parameter's value stored here is not associated to the contents of a particular Element while the value stored in the class Parameter is; The property will return one of the following possibilities: String, Integer, Double or ElementId. Based on the value of this property the correct access and set methods should be used to retrieve and set the parameter's data value.

See Also

ParameterStorage Class
Autodesk.Revit Namespace

PlanCircuit Class

[image]