Revit 2010 API
Filter..::.NewParameterFilter Method (BuiltInParameter, CriteriaFilterType, Int32)
Filter Class See Also Send Feedback
Creates a parameter filter object based on an integer built-in parameter type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterFilter NewParameterFilter(
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    int parameterValue
)
Visual Basic (Declaration)
Public Function NewParameterFilter ( _
    builtinParameter As BuiltInParameter, _
    filterType As CriteriaFilterType, _
    parameterValue As Integer _
) As ParameterFilter
Visual C++
public:
ParameterFilter^ NewParameterFilter(
    BuiltInParameter builtinParameter,
    CriteriaFilterType filterType,
    int parameterValue
)

Parameters

builtinParameter
Type: Autodesk.Revit.Parameters..::.BuiltInParameter
The built-in parameter id of the parameter to be retrieved.
filterType
Type: Autodesk.Revit.Enums..::.CriteriaFilterType
The relationship between element's parameter value and the specified value.
parameterValue
Type: System..::.Int32
The parameter value that is stored as Integer.

Return Value

Returns a new parameter filter object with given Integer value.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
NewParameterFilter Overload
Autodesk.Revit.Creation Namespace

NewParameterFilter Method (BuiltInParameter, CriteriaFilterType, String)

[image]