Revit 2010 API
RoofTypeSet..::.Insert Method
RoofTypeSet Class See Also Send Feedback
Insert the specified roof type into the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Insert(
    RoofType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As RoofType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    RoofType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.RoofType
The roof type to be inserted into the set.

Return Value

Returns whether the roof type was inserted into the set.

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace

ReverseIterator Method

[image]