Revit 2010 API
Document..::.Elements Property (Type)
Document Class Example See Also Send Feedback
Provides access to all elements of specified type from the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementIterator Elements[
    Type
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements ( _
     As Type _
) As ElementIterator
Visual C++
public:
property ElementIterator^ Elements[Type^ ] {
    ElementIterator^ get (Type^ );
}

Parameters

Type: System..::.Type

Remarks

Returns a forward moving iterator that will traverse the entire Autodesk Revit element database. The Elements property provides an iterator that enables iteration of the entire Revit database of Elements of specified type. The iterator supports the standard COM iterator methods and behavior of IEnumerator.

Examples

CopyC#
ElementIterator iterator = document.get_Elements(typeof(Wall));
String prompt = "The walls in the current document are:\n";
iterator.Reset();
while (iterator.MoveNext())
{
    Element e = iterator.Current as Element;
    prompt += e.Name + "\n";
}
MessageBox.Show(prompt, "Revit");
CopyVB.NET
Dim iterator As ElementIterator = document.Elements(GetType(Wall))
Dim prompt As String = "The walls in the current document are:" & vbLf
iterator.Reset()
While iterator.MoveNext()
    Dim e As Autodesk.Revit.Element = TryCast(iterator.Current, Autodesk.Revit.Element)
    prompt += e.Name & vbLf
End While
MessageBox.Show(prompt, "Revit")

See Also

Document Class
Elements Overload
Autodesk.Revit Namespace

Elements Property (Filter, ElementArray)

[image]