Revit 2010 API
Connector..::.AssignedFlowFactor Property
Connector Class See Also Send Feedback
The assigned flow factor of this connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double AssignedFlowFactor { get; set; }
Visual Basic (Declaration)
Public Property AssignedFlowFactor As Double
Visual C++
public:
property double AssignedFlowFactor {
    double get ();
    void set (double value);
}

Remarks

Assigned flow factor may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::DuctConnector,Autodesk::Revit::MEP::PipeConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when get assigned flow factor from a connector not in family instance. Thrown when the connector's domain is not DomainHvac or DomainPiping.
System..::.ArgumentException | Throw when set an invalid value.
System..::.InvalidOperationException | Thrown on failure to get or set assigned flow factor.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

AssignedKCoefficient Property

[image]