Revit 2010 API
ControlledApplication..::.OnDocumentOpened Event
ControlledApplication Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentOpened event instead. Subscribe to the OnDocumentOpened event to be notified when a document is opened during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentOpened event instead.")]
public event DocumentOpenedEventHandler OnDocumentOpened
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentOpened event instead.")> _
Public Event OnDocumentOpened As DocumentOpenedEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentOpened event instead.")]
public:
 event DocumentOpenedEventHandler^ OnDocumentOpened {
    void add (DocumentOpenedEventHandler^ value);
    void remove (DocumentOpenedEventHandler^ value);
}

Remarks

Sometimes a document will be opened during an API command. By subscribing to this event your application will be notified of such an event and perform an action, such as get some elements from the opened document etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace

OnDocumentSaved Event

[image]