Revit 2010 API
Application..::.NewCurveLoopsProfile Method
Application Class See Also Send Feedback
Creates a new CurveLoopsProfile object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveLoopsProfile NewCurveLoopsProfile(
    CurveArrArray curveLoops
)
Visual Basic (Declaration)
Public Function NewCurveLoopsProfile ( _
    curveLoops As CurveArrArray _
) As CurveLoopsProfile
Visual C++
public:
CurveLoopsProfile^ NewCurveLoopsProfile(
    CurveArrArray^ curveLoops
)

Parameters

curveLoops
Type: Autodesk.Revit.Geometry..::.CurveArrArray
The curve loops of the Profile.

Return Value

The new CurveLoopsProfile object.

Remarks

Use the return of this methods as NewSweep and NewSweptBlend to create generic forms.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the argument is Null.

See Also

Application Class
Autodesk.Revit.Creation Namespace

NewDGNExportOptions Method

[image]