Revit 2010 API
RoofTypeSet..::.Erase Method
RoofTypeSet Class See Also Send Feedback
Removes a specified roof type from the set.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    RoofType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As RoofType _
) As Integer
Visual C++
public:
virtual int Erase(
    RoofType^ item
)

Parameters

item
Type: Autodesk.Revit.Symbols..::.RoofType
The roof type to be erased.

Return Value

The number of roof types that were erased from the set.

See Also

RoofTypeSet Class
Autodesk.Revit.Symbols Namespace

ForwardIterator Method

[image]