Revit 2010 API
Plane Class
Members Example See Also Send Feedback
Provides access to the geometry plane object.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Plane : APIObject
Visual Basic (Declaration)
Public Class Plane _
    Inherits APIObject
Visual C++
public ref class Plane : public APIObject

Remarks

The user can construct a plane object, get or set the vectors and origin through this class.

Examples

CopyC#
public void GetPlaneInfo(Plane plane)
{
    XYZ origin = plane.Origin;
    XYZ normal = plane.Normal;
    XYZ xVec = plane.XVec;
    XYZ yVec = plane.YVec;

    StringBuilder info = new StringBuilder();
    info.AppendLine("Plane Data:");
    info.AppendLine(string.Format("     Origin: ({0},{1},{2})", origin.X, origin.Y, origin.Z));
    info.AppendLine(string.Format("     Normal: ({0},{1},{2})", normal.X, normal.Y, normal.Z));
    info.AppendLine(string.Format("     XVec: ({0},{1},{2})", xVec.X, xVec.Y, xVec.Z));
    info.AppendLine(string.Format("     YVec: ({0},{1},{2})", yVec.X, yVec.Y, yVec.Z));

    MessageBox.Show(info.ToString(), "Revit");
}
CopyVB.NET
Public Sub GetPlaneInfo(ByVal plane As Autodesk.Revit.Geometry.Plane)
    Dim origin As Autodesk.Revit.Geometry.XYZ = plane.Origin
    Dim normal As Autodesk.Revit.Geometry.XYZ = plane.Normal
    Dim xVec As Autodesk.Revit.Geometry.XYZ = plane.XVec
    Dim yVec As Autodesk.Revit.Geometry.XYZ = plane.YVec

    Dim info As New StringBuilder()
    info.AppendLine("Plane Data:")
    info.AppendLine(String.Format(" Origin: ({0},{1},{2})", origin.X, origin.Y, origin.Z))
    info.AppendLine(String.Format(" Normal: ({0},{1},{2})", normal.X, normal.Y, normal.Z))
    info.AppendLine(String.Format(" XVec: ({0},{1},{2})", xVec.X, xVec.Y, xVec.Z))
    info.AppendLine(String.Format(" YVec: ({0},{1},{2})", yVec.X, yVec.Y, yVec.Z))

    MessageBox.Show(info.ToString(), "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.Plane

See Also

Plane Members
Autodesk.Revit.Geometry Namespace

Plane Members

[image] [image]