Revit 2010 API
CurtainSystem Members
CurtainSystem Class Constructors Methods Properties See Also Send Feedback

The CurtainSystem type exposes the following members.

Constructors

Name | Description
CurtainSystem | For Internal Use Only.

Methods

Name | Description
AddCurtainGrid | Add CurtainGrid on the specified face for the CurtainSystem.
RemoveCurtainGrid | Remove CurtainGrid from the specified face for the CurtainSystem.

Properties

Name | Description
CurtainGrids | Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.
CurtainSystemType | get or set the type of the CurtainSystem.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.

See Also

CurtainSystem Class
Autodesk.Revit.Elements Namespace

CurtainSystem Constructor

[image]