Revit 2010 API
ItemFactoryBase..::.NewTextNote Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)
ItemFactoryBase Class See Also Send Feedback
Creates a new TextNote object without a leader.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TextNote NewTextNote(
    View pView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    string strText
)
Visual Basic (Declaration)
Public Function NewTextNote ( _
    pView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    strText As String _
) As TextNote
Visual C++
public:
TextNote^ NewTextNote(
    View^ pView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    String^ strText
)

Parameters

pView
Type: Autodesk.Revit.Elements..::.View
The view where the text note object will be visible.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The origin of the text note.
baseVec
Type: Autodesk.Revit.Geometry..::.XYZ
The horizontal direction for text in the text note.
upVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vertical direction for text in the text note.
lineWidth
Type: System..::.Double
The width of the rectangle bounding the note text.
textAlign
Type: Autodesk.Revit.Enums..::.TextAlignFlags
Flags indicating the alignment of the note. This should be a bitwise OR including one of TEF_ALIGN_TOP, TEF_ALIGN_MIDDLE and TEF_ALIGN_BOTTOM and one of TEF_ALIGN_LEFT, TEF_ALIGN_CENTER and TEF_ALIGN_RIGHT. The defaults for this flag are TEF_ALIGN_TOP | TEF_ALIGN_LEFT.
strText
Type: System..::.String
Text to display in the text note. Include new line characters to force a multiple line note to be created. Notes may also wrap automatically based on the width of the note rectangle.

Return Value

If successful, a TextNote object is returned.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when any one of pView, origin, baseVec, upVec, strText is null.
System..::.NotFiniteNumberException | Thrown when the input lineWidth is not a finite number.
System..::.ArgumentOutOfRangeException | Thrown when the input textAlign is not a valid Autodesk::Revit::Enums::TextAlignFlags or it is not a valid bitwise OR of the align flags.
System..::.InvalidOperationException | If the regeneration fails when creating the text note.

See Also

ItemFactoryBase Class
NewTextNote Overload
Autodesk.Revit.Creation Namespace

NewTextNotes Method

[image]