Revit 2010 API
Application..::.OnDocumentSaved Event
Application Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentSaved event instead. Subscribe to the OnDocumentSaved event to be notified after a document is saved.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSaved event instead.")]
public event DocumentSavedEventHandler OnDocumentSaved
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSaved event instead.")> _
Public Event OnDocumentSaved As DocumentSavedEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentSaved event instead.")]
public:
 event DocumentSavedEventHandler^ OnDocumentSaved {
    void add (DocumentSavedEventHandler^ value);
    void remove (DocumentSavedEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document has been saved. By subscribing to this event the application will be notified after such an event and can perform an action in response.

See Also

Application Class
Autodesk.Revit Namespace

OnDocumentSavedAs Event

[image]