Revit 2010 API
Floor..::.AnalyticalModel Property
Floor Class See Also Send Feedback
Retrieves the structural analytical model for the floor object.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalModel AnalyticalModel { get; }
Visual Basic (Declaration)
Public ReadOnly Property AnalyticalModel As AnalyticalModel
Visual C++
public:
property AnalyticalModel^ AnalyticalModel {
    AnalyticalModel^ get ();
}

Remarks

If the floor has a structural analytical model it is returned by this method, otherwise Nothing is returned. For floors, the analytical model returned by this method can be cast to type Autodesk.Revit.Structural.AnalyticalModelFloor to be able to access details about the floor. This property will only function with the Autodesk Revit Structure product.

See Also

Floor Class
Autodesk.Revit.Elements Namespace

FloorType Property

[image]