Revit 2010 API
FamilyItemFactory..::.NewLinearDimension Method (View, Line, ReferenceArray)
FamilyItemFactory Class Example See Also Send Feedback
Generate a new linear dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Dimension NewLinearDimension(
    View view,
    Line line,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewLinearDimension ( _
    view As View, _
    line As Line, _
    references As ReferenceArray _
) As Dimension
Visual C++
public:
Dimension^ NewLinearDimension(
    View^ view,
    Line^ line,
    ReferenceArray^ references
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the dimension is to be visible.
line
Type: Autodesk.Revit.Geometry..::.Line
The extension line of the dimension.
references
Type: Autodesk.Revit.Geometry..::.ReferenceArray
An array of geometric references to which the dimension is to be bound. You must supply at least two references, and all references supplied must be parallel to each other and perpendicular to the extension line.

Return Value

If creation was successful the new linear dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The currently user set default style is used for the created dimension.

Examples

CopyC#
public Dimension CreateLinearDimension(Document document)
{
    // first create two lines
    XYZ pt1 = new XYZ(5, 5, 0);
    XYZ pt2 = new XYZ(5, 10, 0);
    Line line = document.Application.Create.NewLine(pt1, pt2, true);
    Plane plane = document.Application.Create.NewPlane(pt1.Cross(pt2), pt2);
    SketchPlane skplane = document.FamilyCreate.NewSketchPlane(plane);
    ModelCurve modelcurve1 = document.FamilyCreate.NewModelCurve(line, skplane);

    pt1 = new XYZ(10, 5, 0);
    pt2 = new XYZ(10, 10, 0);
    line = document.Application.Create.NewLine(pt1, pt2, true);
    plane = document.Application.Create.NewPlane(pt1.Cross(pt2), pt2);
    skplane = document.FamilyCreate.NewSketchPlane(plane);
    ModelCurve modelcurve2 = document.FamilyCreate.NewModelCurve(line, skplane);

    // now create a linear dimension between them
    ReferenceArray ra = new ReferenceArray();
    ra.Append(modelcurve1.GeometryCurve.Reference);
    ra.Append(modelcurve2.GeometryCurve.Reference);

    pt1 = new XYZ(5, 10, 0);
    pt2 = new XYZ(10, 10, 0);
    line = document.Application.Create.NewLine(pt1, pt2, true);

    Dimension dim = document.FamilyCreate.NewLinearDimension(document.ActiveView, line, ra);

    // create a label for the dimension called "width"
    FamilyParameter param = document.FamilyManager.AddParameter("width",
        Autodesk.Revit.Parameters.BuiltInParameterGroup.PG_CONSTRAINTS,
        Autodesk.Revit.Parameters.ParameterType.Length, false);

    dim.Label = param;

    return dim;
}
CopyVB.NET
Public Function CreateLinearDimension(ByVal document As Document) As Autodesk.Revit.Elements.Dimension
    ' first create two lines
    Dim pt1 As New Autodesk.Revit.Geometry.XYZ(5, 5, 0)
    Dim pt2 As New Autodesk.Revit.Geometry.XYZ(5, 10, 0)
    Dim line As Line = document.Application.Create.NewLine(pt1, pt2, True)
    Dim plane As Autodesk.Revit.Geometry.Plane = document.Application.Create.NewPlane(pt1.Cross(pt2), pt2)
    Dim skplane As Autodesk.Revit.Elements.SketchPlane = document.FamilyCreate.NewSketchPlane(plane)
    Dim modelcurve1 As ModelCurve = document.FamilyCreate.NewModelCurve(line, skplane)

    pt1 = New Autodesk.Revit.Geometry.XYZ(10, 5, 0)
    pt2 = New Autodesk.Revit.Geometry.XYZ(10, 10, 0)
    line = document.Application.Create.NewLine(pt1, pt2, True)
    plane = document.Application.Create.NewPlane(pt1.Cross(pt2), pt2)
    skplane = document.FamilyCreate.NewSketchPlane(plane)
    Dim modelcurve2 As ModelCurve = document.FamilyCreate.NewModelCurve(line, skplane)

    ' now create a linear dimension between them
    Dim ra As New ReferenceArray()
    ra.Append(modelcurve1.GeometryCurve.Reference)
    ra.Append(modelcurve2.GeometryCurve.Reference)

    pt1 = New Autodesk.Revit.Geometry.XYZ(5, 10, 0)
    pt2 = New Autodesk.Revit.Geometry.XYZ(10, 10, 0)
    line = document.Application.Create.NewLine(pt1, pt2, True)

    Dim [dim] As Autodesk.Revit.Elements.Dimension = document.FamilyCreate.NewLinearDimension(document.ActiveView, line, ra)

    ' create a label for the dimension called "width"
    Dim param As FamilyParameter = document.FamilyManager.AddParameter("width", Autodesk.Revit.Parameters.BuiltInParameterGroup.PG_CONSTRAINTS, Autodesk.Revit.Parameters.ParameterType.Length, False)

    [dim].Label = param

    Return [dim]
End Function

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when any input argument is null.
System..::.ArgumentException | Thrown when the argument "references" is invalid.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewLinearDimension Overload
Autodesk.Revit.Creation Namespace

NewLinearDimension Method (View, Line, ReferenceArray, DimensionType)

[image]