Revit 2010 API
RevolvedFace Class
Members Example See Also Send Feedback
A revolved face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RevolvedFace : Face
Visual Basic (Declaration)
Public Class RevolvedFace _
    Inherits Face
Visual C++
public ref class RevolvedFace : public Face

Remarks

Revoved faces are defined by revolved surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces. S(u, v) = Origin + Curve0(v)*cos(u)*Radius[0] + Curve0(v)*sin(u)*Radius[1] + Curve1(v)*Axis, where the profile curve has the parametric equation (Curve0(t), Curve1(t)).

Examples

CopyC#
private void GetRevolvedFaceInfo(Face face)
{
    RevolvedFace revolvedFace = face as RevolvedFace;
    if (null != revolvedFace)
    {
        XYZ origin = revolvedFace.Origin;
        XYZ axis = revolvedFace.Axis;
        Curve curve = revolvedFace.Curve;
        XYZ redius = revolvedFace.get_Radius(0);
    }
}
CopyVB.NET
Private Sub GetRevolvedFaceInfo(ByVal face As Autodesk.Revit.Geometry.Face)
    Dim revolvedFace As RevolvedFace = TryCast(face, RevolvedFace)
    If revolvedFace IsNot Nothing Then
        Dim origin As Autodesk.Revit.Geometry.XYZ = revolvedFace.Origin
        Dim axis As Autodesk.Revit.Geometry.XYZ = revolvedFace.Axis
        Dim curve As Curve = revolvedFace.Curve
        Dim redius As Autodesk.Revit.Geometry.XYZ = revolvedFace.Radius(0)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Face
Autodesk.Revit.Geometry..::.RevolvedFace

See Also

RevolvedFace Members
Autodesk.Revit.Geometry Namespace

RevolvedFace Members

[image] [image]