Revit 2010 API
Connector Class
Members See Also Send Feedback
A connector in an Autodesk Revit MEP project document.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Connector : APIObject, IConnector
Visual Basic (Declaration)
Public Class Connector _
    Inherits APIObject _
    Implements IConnector
Visual C++
public ref class Connector : public APIObject,
    IConnector

Remarks

This connector is an item that is a part of another element (duct, pipe, fitting, or equipment).
This connector does not represent the connector element that can be created inside a family;
 for that element,please refer to Revit::MEP::DuctConnector,
Revit::MEP::PipeConnector and Revit::MEP::ElectricalConnector.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.Connector

See Also

Connector Members
Autodesk.Revit.MEP Namespace

Connector Members

[image] [image]