Revit 2010 API
ItemFactoryBase..::.NewAlignment Method
ItemFactoryBase Class See Also Send Feedback
Add a new locked alignment into the Autodesk Revit document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Alignment NewAlignment(
    View view,
    Reference reference1,
    Reference reference2
)
Visual Basic (Declaration)
Public Function NewAlignment ( _
    view As View, _
    reference1 As Reference, _
    reference2 As Reference _
) As Alignment
Visual C++
public:
Alignment^ NewAlignment(
    View^ view,
    Reference^ reference1,
    Reference^ reference2
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view that determines the orientation of the alignment.
reference1
Type: Autodesk.Revit.Geometry..::.Reference
The first reference.
reference2
Type: Autodesk.Revit.Geometry..::.Reference
The second reference.

Return Value

If creation was successful the new locked alignment is returned, otherwise an exception with failure information will be thrown.

Remarks

These two references must be one of the following combinations:
  • 2 planar faces
  • 2 lines
  • line and point
  • 2 arcs
  • 2 cylindrical faces
These references must be already geometrically aligned (this function will not force them to become aligned).

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"view" or "headerReference" or "otherReference"-is null.
System..::.ArgumentException | Thrown when the input argument-"headerReference" or "otherReference"-is invalid.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace

NewAnnotationSymbol Method

[image]