Revit 2010 API
ElectricalConnector Class
Members See Also Send Feedback
An electrical connector that is assigned to an electrical equipment or device family. Provides access to the electrical connector in Autodesk Revit MEP family document.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ElectricalConnector : Element,
    IConnector
Visual Basic (Declaration)
Public Class ElectricalConnector _
    Inherits Element _
    Implements IConnector
Visual C++
public ref class ElectricalConnector : public Element,
    IConnector

Remarks

This element type is accessible only in Autodek Revit MEP family documents. Electrical connectors that accessible in MEP project documents are not elements, and are represented by Autodesk::Revit::MEP::Connector.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.MEP..::.ElectricalConnector

See Also

ElectricalConnector Members
Autodesk.Revit.MEP Namespace

ElectricalConnector Members

[image] [image]