Revit 2010 API
ModelCurve..::.TrussCurveType Property
ModelCurve Class See Also Send Feedback
The truss curve type of this model curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TrussCurveType TrussCurveType { get; set; }
Visual Basic (Declaration)
Public Property TrussCurveType As TrussCurveType
Visual C++
public:
property TrussCurveType TrussCurveType {
    TrussCurveType get ();
    void set (TrussCurveType value);
}

Remarks

This property is applicable only to curves in Truss families.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the assigned value for TrussCurveType is invalid.
System..::.NotSupportedException | Thrown when attempting to set this property to a curve not in a truss family.
System..::.InvalidOperationException | Thrown when attempting to change truss curves to NonTrussCurve, or when the truss curve type may not be applied to curves of this shape (webs must be linear, and chords must be linear or arc).

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace

ModelCurveArrArray Class

[image]