Revit 2010 API
Transform..::.Multiply Method
Transform Class See Also Send Feedback
Multiplies this transformation by the specified transformation and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Transform Multiply(
    Transform right
)
Visual Basic (Declaration)
Public Function Multiply ( _
    right As Transform _
) As Transform
Visual C++
public:
Transform^ Multiply(
    Transform^ right
)

Parameters

right
Type: Autodesk.Revit.Geometry..::.Transform
The specified transformation.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The combined transformation has the same effect as applying the right transformation first, and the left transformation, second. So, (T1(T2(p)) = (T1 * T2) (p).

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the handle of the specified transformation is null.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace

Multiply Operator

[image]