Revit 2010 API
FamilyManager..::.Parameter Property (Guid)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given GUID for a shared parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyParameter Parameter[
    Guid guid
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    guid As Guid _
) As FamilyParameter
Visual C++
public:
property FamilyParameter^ Parameter[Guid guid] {
    FamilyParameter^ get (Guid guid);
}

Parameters

guid
Type: System..::.Guid

Remarks

Returns null if the parameter is not found. This method is used to retrieve a family parameter for a known shared parameter. When a shared parameter is created it is ssigned a Guid awhich will not change. This guid can be used to retrieve the piece of data from the element at a later time.

See Also

FamilyManager Class
Parameter Overload
Autodesk.Revit Namespace

Parameter Property (String)

[image]