Revit 2010 API
Document..::.Print Method (ViewSet, View, Boolean)
Document Class See Also Send Feedback
Prints a set of views with a specified view template and default print settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Print(
    ViewSet views,
    View viewTemplate,
    bool useCurrentPrintSettings
)
Visual Basic (Declaration)
Public Sub Print ( _
    views As ViewSet, _
    viewTemplate As View, _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print(
    ViewSet^ views,
    View^ viewTemplate,
    bool useCurrentPrintSettings
)

Parameters

views
Type: Autodesk.Revit.Elements..::.ViewSet
The set of views which need to be printed.
viewTemplate
Type: Autodesk.Revit.Elements..::.View
The view template which apply to the set of views.
useCurrentPrintSettings
Type: System..::.Boolean
If true, print the view with the current print setting, otherwise with the print setting of the document of the view.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
System..::.ArgumentNullException | Thrown when the view set to be printed is null.
System..::.ArgumentException | Thrown when the view set contains a null element.
System..::.ApplicationException | Thrown when at least one view from the view set could not be printed.
System..::.OperationCanceledException | Thrown when print is cancelled by event handler.

See Also

Document Class
Print Overload
Autodesk.Revit Namespace

Rotate Method

[image] [image]