Revit 2010 API
CurveByPoints Members
CurveByPoints Class Constructors Methods Properties See Also Send Feedback

The CurveByPoints type exposes the following members.

Constructors

Name | Description
CurveByPoints | Initializes a new instance of the CurveByPoints class

Methods

Name | Description
GetPoints | Get the sequence of points interpolated by this curve.
GetVisibility | Gets the visibility.
SetPoints | Change the sequence of points interpolated by this curve.
SetVisibility | Sets the visibility.
SortPoints | Order a set of ReferencePoints in the same way Revit does when creating a curve from points.

Properties

Name | Description
IsReferenceLine |
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
ReferenceType | Indicates the type of reference.
SketchPlane | Override the SketchPlane property of CurveElement. (Overrides CurveElement..::.SketchPlane.)
Subcategory | The subcategory, or graphics style, of the CurveByPoints.
Visible | Whether the point is visible when the family is loaded into a project.

See Also

CurveByPoints Class
Autodesk.Revit.Elements Namespace

CurveByPoints Constructor

[image]