Revit 2010 API
ElectricalSystem Class
Members See Also Send Feedback
Provides access to the Electrical System in Autodesk Revit MEP.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ElectricalSystem : MEPSystem
Visual Basic (Declaration)
Public Class ElectricalSystem _
    Inherits MEPSystem
Visual C++
public ref class ElectricalSystem : public MEPSystem

Remarks

The Electrical System object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.MEP..::.MEPSystem
Autodesk.Revit.MEP..::.ElectricalSystem

See Also

ElectricalSystem Members
Autodesk.Revit.MEP Namespace

ElectricalSystem Members

[image] [image]