Revit 2010 API
FamilyManager..::.Parameter Property (String)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyParameter Parameter[
    string parameterName
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    parameterName As String _
) As FamilyParameter
Visual C++
public:
property FamilyParameter^ Parameter[String^ parameterName] {
    FamilyParameter^ get (String^ parameterName);
}

Parameters

parameterName
Type: System..::.String

Remarks

Returns null if the parameter is not found.

See Also

FamilyManager Class
Parameter Overload
Autodesk.Revit Namespace

Parameters Property

[image]