Revit 2010 API
Document..::.BeginTransaction Method
Document Class Example See Also Send Feedback
Begins a transaction to encompass a set of changes.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool BeginTransaction()
Visual Basic (Declaration)
Public Function BeginTransaction As Boolean
Visual C++
public:
bool BeginTransaction()

Return Value

true is returned if the transaction is started successfully, otherwise false will be returned.

Remarks

To begin a new transaction before a series of operation can ensure all the following operations will be done in same transaction, which can avoid inconsistency.

Examples

CopyC#
// Get the document
Autodesk.Revit.Document document = application.ActiveDocument;

// Create a geometry line in revit application
XYZ Point1 = new XYZ(0, 0, 0);
XYZ Point2 = new XYZ(10, 0, 0);
XYZ Point3 = new XYZ(10, 10, 0);
XYZ Point4 = new XYZ(0, 10, 0);

// Transient Elements,so they are not managed by transactions
document.BeginTransaction();
Line geomLine1 = application.Create.NewLine(Point1, Point2, true);
Line geomLine2 = application.Create.NewLine(Point4, Point3, true);
Line geomLine3 = application.Create.NewLine(Point1, Point4, true);

// Create a geometry plane in revit application
XYZ origin = new XYZ(0, 0, 0);
XYZ normal = new XYZ(1, 1, 0);
Plane geomPlane = application.Create.NewPlane(normal, origin);

// Create a sketch plane in current document
SketchPlane sketch = document.Create.NewSketchPlane(geomPlane);

// non-transient elements,so they are grouped into transaction as atomic user actions
document.BeginTransaction();
// Create a ModelLine element using the created geometry line and sketch plane
ModelLine line1 = document.Create.NewModelCurve(geomLine1, sketch) as ModelLine;
ModelLine line2 = document.Create.NewModelCurve(geomLine2, sketch) as ModelLine;
ModelLine line3 = document.Create.NewModelCurve(geomLine3, sketch) as ModelLine;

if (DialogResult.OK == MessageBox.Show("Click OK to call EndTransaction, otherwise AbortTransaction.", "Revit", MessageBoxButtons.OKCancel))
{
    document.EndTransaction();
}
else
{
    document.AbortTransaction();
}
CopyVB.NET
' Get the document
Dim document As Autodesk.Revit.Document = application.ActiveDocument

' Create a geometry line in revit application
Dim Point1 As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
Dim Point2 As New Autodesk.Revit.Geometry.XYZ(10, 0, 0)
Dim Point3 As New Autodesk.Revit.Geometry.XYZ(10, 10, 0)
Dim Point4 As New Autodesk.Revit.Geometry.XYZ(0, 10, 0)

' Transient Elements,so they are not managed by transactions
document.BeginTransaction()
Dim geomLine1 As Line = application.Create.NewLine(Point1, Point2, True)
Dim geomLine2 As Line = application.Create.NewLine(Point4, Point3, True)
Dim geomLine3 As Line = application.Create.NewLine(Point1, Point4, True)

' Create a geometry plane in revit application
Dim origin As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
Dim normal As New Autodesk.Revit.Geometry.XYZ(1, 1, 0)
Dim geomPlane As Autodesk.Revit.Geometry.Plane = application.Create.NewPlane(normal, origin)

' Create a sketch plane in current document
Dim sketch As Autodesk.Revit.Elements.SketchPlane = document.Create.NewSketchPlane(geomPlane)

' non-transient elements,so they are grouped into transaction as atomic user actions
document.BeginTransaction()
' Create a ModelLine element using the created geometry line and sketch plane
Dim line1 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine1, sketch), ModelLine)
Dim line2 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine2, sketch), ModelLine)
Dim line3 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine3, sketch), ModelLine)

If DialogResult.OK = MessageBox.Show("Click OK to call EndTransaction, otherwise AbortTransaction.", "Revit", MessageBoxButtons.OKCancel) Then
    document.EndTransaction()
Else
    document.AbortTransaction()
End If

See Also

Document Class
BeginTransaction Overload
Autodesk.Revit Namespace

BeginTransaction Method (PostedErrorArray)

[image]