Revit 2010 API
FamilyInstance..::.StructuralType Property
FamilyInstance Class Example See Also Send Feedback
Provides the primary structural type of the instance, such as beam or column etc.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public StructuralType StructuralType { get; }
Visual Basic (Declaration)
Public ReadOnly Property StructuralType As StructuralType
Visual C++
public:
property StructuralType StructuralType {
    StructuralType get ();
}

Examples

CopyC#
public void GetStructuralType(FamilyInstance familyInstance)
{
    string message = "";
    switch (familyInstance.StructuralType)
    {
        case StructuralType.Beam:
            message = "FamilyInstance is a beam.";
            break;
        case StructuralType.Brace:
            message = "FamilyInstance is a brace.";
            break;
        case StructuralType.Column:
            message = "FamilyInstance is a column.";
            break;
        case StructuralType.Footing:
            message = "FamilyInstance is a footing.";
            break;
        default:
            message = "FamilyInstance is non-structural or unknown framing.";
            break;
    }

    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Public Sub GetStructuralType(ByVal familyInstance As Autodesk.Revit.Elements.FamilyInstance)
    Dim message As String = ""
    Select Case familyInstance.StructuralType
        Case StructuralType.Beam
            message = "FamilyInstance is a beam."
            Exit Select
        Case StructuralType.Brace
            message = "FamilyInstance is a brace."
            Exit Select
        Case StructuralType.Column
            message = "FamilyInstance is a column."
            Exit Select
        Case StructuralType.Footing
            message = "FamilyInstance is a footing."
            Exit Select
        Case Else
            message = "FamilyInstance is non-structural or unknown framing."
            Exit Select
    End Select

    MessageBox.Show(message, "Revit")
End Sub

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace

StructuralUsage Property

[image]