Revit 2010 API
Application..::.DocumentSaved Event
Application Class See Also Send Feedback
Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentSavedEventArgs> DocumentSaved
Visual Basic (Declaration)
Public Event DocumentSaved As EventHandler(Of DocumentSavedEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedEventArgs^>^ DocumentSaved {
    void add (EventHandler<DocumentSavedEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving a document. Note that the first save of a newly created document will raise DocumentSavedAs rather than the DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSaving event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

The DocumentSaved event is meant to replace the older OnDocumentSaved event, which is now Obsolete.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace

DocumentSavedAs Event

[image]