Revit 2010 API
XYZArray..::.ForwardIterator Method
XYZArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual XYZArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As XYZArrayIterator
Visual C++
public:
virtual XYZArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace

GetEnumerator Method

[image]