Revit 2010 API
Connector..::.Angle Property
Connector Class See Also Send Feedback
The angle of the Connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Double
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

Remarks

Angle may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::PipeConnector and Autodesk::Revit::MEP::DuctConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainHvac or DomainPiping. Thrown when set value for the connector not in family instance.
System..::.ArgumentException | Thrown when set an invalid value.
System..::.InvalidOperationException | Thrown on failure to set angle.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

AssignedDuctFlowConfiguration Property

[image]