Revit 2010 API
RebarBarType..::.HookLength Property
RebarBarType Class See Also Send Feedback
Access to length data in the hook lengths map.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double HookLength[
    RebarHookType hookType
] { get; set; }
Visual Basic (Declaration)
Public Property HookLength ( _
    hookType As RebarHookType _
) As Double
Visual C++
public:
property double HookLength[RebarHookType^ hookType] {
    double get (RebarHookType^ hookType);
    void set (RebarHookType^ hookType, double value);
}

Parameters

hookType
Type: Autodesk.Revit.Symbols..::.RebarHookType
A hook type in the same document as this bar type.

Remarks

Setting this property implicitly turns off the AutoCalcHookLengths property for this hook.

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace

HookOffsetLength Property

[image]