Revit 2010 API
XYZ..::.Basis Property
XYZ Class See Also Send Feedback
Indexed access for Basis.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static XYZ Basis[
    int idx
] { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Basis ( _
    idx As Integer _
) As XYZ
Visual C++
public:
static property XYZ^ Basis[int idx] {
    XYZ^ get (int idx);
}

Parameters

idx
Type: System..::.Int32
Use 0 for X, 1 for Y and 2 for Z.

Exceptions

Exception | Condition
System..::.IndexOutOfRangeException | Thrown when an attempt is made to access an element of the Basis array with an index that is outside the bounds of the array.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace

BasisX Property

[image]