Revit 2010 API
Opening..::.BoundaryCurves Property
Opening Class See Also Send Feedback
The geometry information for non-rectangular openings in project documents, or for all openings in family documents.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray BoundaryCurves { get; }
Visual Basic (Declaration)
Public ReadOnly Property BoundaryCurves As CurveArray
Visual C++
public:
property CurveArray^ BoundaryCurves {
    CurveArray^ get ();
}

Remarks

If IsRectBoundary is true, this value is null.

See Also

Opening Class
Autodesk.Revit.Elements Namespace

BoundaryRect Property

[image]