Revit 2010 API
Document..::.NewSpaces Method (Level, Phase, View)
Document Class See Also Send Feedback
Creates new spaces on the available plan circuits of a the given level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewSpaces(
    Level level,
    Phase phase,
    View view
)
Visual Basic (Declaration)
Public Function NewSpaces ( _
    level As Level, _
    phase As Phase, _
    view As View _
) As ElementSet
Visual C++
public:
ElementSet^ NewSpaces(
    Level^ level,
    Phase^ phase,
    View^ view
)

Parameters

level
Type: Autodesk.Revit.Elements..::.Level
The level on which the spaces is to exist.
phase
Type: Autodesk.Revit.Elements..::.Phase
The phase in which the spaces is to exist.
view
Type: Autodesk.Revit.Elements..::.View
The view on which the space tags for the spaces are to display.

Return Value

If successful an Element set which contains the rooms should be returned, otherwise the exception will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The view of the relevant level can not be retrieved.
System..::.InvalidOperationException | The phase is invalid or regeneration fails at the end of the creation.

See Also

Document Class
NewSpaces Overload
Autodesk.Revit.Creation Namespace

NewSpaceTag Method

[image]