Revit 2010 API
MechanicalFitting Class
Members See Also Send Feedback
A mechanical fitting in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MechanicalFitting : MEPModel
Visual Basic (Declaration)
Public Class MechanicalFitting _
    Inherits MEPModel
Visual C++
public ref class MechanicalFitting : public MEPModel

Remarks

The mechanical fitting is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.MEPModel
Autodesk.Revit.MEP..::.MechanicalFitting

See Also

MechanicalFitting Members
Autodesk.Revit.MEP Namespace

MechanicalFitting Members

[image] [image]