Revit 2010 API
SpacingRule..::.GridlinesRotation Property
SpacingRule Class See Also Send Feedback
An additional rotation to be applied to this set of grid lines.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double GridlinesRotation { get; set; }
Visual Basic (Declaration)
Public Property GridlinesRotation As Double
Visual C++
public:
property double GridlinesRotation {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when angle is outside of the range ( -PI/2, PI/2 ).

See Also

SpacingRule Class
Autodesk.Revit.Elements Namespace

HasBeltMeasurement Property

[image]