Revit 2010 API
Document..::.OnClose Event
Document Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentClosing event instead. Subscribe to the OnClose event to be notified before the current document is closed.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentClosing event instead.")]
public event DocumentCloseEventHandler OnClose
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentClosing event instead.")> _
Public Event OnClose As DocumentCloseEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentClosing event instead.")]
public:
 event DocumentCloseEventHandler^ OnClose {
    void add (DocumentCloseEventHandler^ value);
    void remove (DocumentCloseEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document will be closed. By subscribing to this event the application will be notified before such an event and can perform an action in response.

See Also

Document Class
Autodesk.Revit Namespace

OnSave Event

[image]