Revit 2010 API
HostObject Class
Members See Also Send Feedback
A base class that provides support for all objects that can host other objects, such as a wall.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class HostObject : Element
Visual Basic (Declaration)
Public Class HostObject _
    Inherits Element
Visual C++
public ref class HostObject : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.CeilingAndFloor
Autodesk.Revit.Elements..::.ContFooting
Autodesk.Revit.Elements..::.CurtainGridLine
Autodesk.Revit.Elements..::.CurtainSystemBase
Autodesk.Revit.Elements..::.Floor
Autodesk.Revit.Elements..::.HostedSweep
Autodesk.Revit.Elements..::.RoofBase
Autodesk.Revit.Elements..::.Wall
Autodesk.Revit.MEP..::.MEPCurve
Autodesk.Revit.MEP..::.Wire

See Also

HostObject Members
Autodesk.Revit.Elements Namespace

HostObject Members

[image] [image]