Revit 2010 API
PointOnPlane Class
Members See Also Send Feedback
Define a ReferencePoint relative to a planar reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PointOnPlane : PointElementReference
Visual Basic (Declaration)
Public Class PointOnPlane _
    Inherits PointElementReference
Visual C++
public ref class PointOnPlane : public PointElementReference

Remarks

A ReferencePoint on a plane has its X and Y basis vectors parallel to the plane, but is free to rotate around its Z basis vector. It can lie on the plane or have an offset.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Elements..::.PointElementReference
Autodesk.Revit.Elements..::.PointOnPlane

See Also

PointOnPlane Members
Autodesk.Revit.Elements Namespace

PointOnPlane Members

[image] [image]