Revit 2010 API
Application..::.ObjectFactory Property
Application Class See Also Send Feedback
Provides an object that can be used to create other instances of Autodesk Revit API objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ObjectFactory ObjectFactory { get; }
Visual Basic (Declaration)
Public ReadOnly Property ObjectFactory As ObjectFactory
Visual C++
public:
property ObjectFactory^ ObjectFactory {
    ObjectFactory^ get ();
}

Remarks

Returns an object factory object that can create other objects. This property is available for advanced use cases only. For general purpose creation of Autodesk Revit API objects use the Application.Create object.

See Also

Application Class
Autodesk.Revit Namespace

Options Property

[image]