Revit 2010 API
SlabShapeEditor..::.ResetSlabShape Method
SlabShapeEditor Class Example See Also Send Feedback
Removes the modifications made during editing and resets the element geometry back to the un-modified state.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ResetSlabShape()
Visual Basic (Declaration)
Public Sub ResetSlabShape
Visual C++
public:
void ResetSlabShape()

Remarks

Calling this method will reset the slab back to its original state and disable Slab Shape Editing. If further editing is needed, call Enable again.

Examples

CopyC#
private void ResetSlabShapes(Autodesk.Revit.Document document)
{
    Selection choices = document.Selection;
    ElementSet collection = choices.Elements;
    foreach (Autodesk.Revit.Element elem in collection)
    {
        Floor floor = elem as Floor;
        if (floor != null)
        {
            SlabShapeEditor slabShapeEditor = floor.SlabShapeEditor;
            slabShapeEditor.ResetSlabShape();
        }
    }

}
CopyVB.NET
Private Sub ResetSlabShapes(ByVal document As Autodesk.Revit.Document)
    Dim choices As Autodesk.Revit.Selection = document.Selection
    Dim collection As ElementSet = choices.Elements
    For Each elem As Autodesk.Revit.Element In collection
        Dim floor As Autodesk.Revit.Elements.Floor = TryCast(elem, Autodesk.Revit.Elements.Floor)
        If floor IsNot Nothing Then
            Dim slabShapeEditor As SlabShapeEditor = floor.SlabShapeEditor
            slabShapeEditor.ResetSlabShape()
        End If
    Next

End Sub

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace

SlabShapeEditor Properties

[image] [image]