Revit 2010 API
Document..::.GetSpaceAtPoint Method (XYZ, Phase)
Document Class See Also Send Feedback
Gets a space containing the point.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Space GetSpaceAtPoint(
    XYZ point,
    Phase phase
)
Visual Basic (Declaration)
Public Function GetSpaceAtPoint ( _
    point As XYZ, _
    phase As Phase _
) As Space
Visual C++
public:
Space^ GetSpaceAtPoint(
    XYZ^ point,
    Phase^ phase
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
Point to be checked.
phase
Type: Autodesk.Revit.Elements..::.Phase
Phase in which the space exists.

Return Value

The space containing the point.

Remarks

If phase is null, it will get the space of the last phase.The first one found will be returned. If there is no space containing the point, it returns null.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the point is nullptr.
System..::.ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.

See Also

Document Class
GetSpaceAtPoint Overload
Autodesk.Revit Namespace

Import Method

[image] [image]