Revit 2010 API
FamilyItemFactory..::.NewReferencePoint Method (Transform)
FamilyItemFactory Class See Also Send Feedback
Create a reference point at a given location and with a given coordinate system in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferencePoint NewReferencePoint(
    Transform
)
Visual Basic (Declaration)
Public Function NewReferencePoint ( _
     As Transform _
) As ReferencePoint
Visual C++
public:
ReferencePoint^ NewReferencePoint(
    Transform^
)

Parameters

Type: Autodesk.Revit.Geometry..::.Transform

Return Value

The newly created ReferencePoint.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the argument is null.
System..::.InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.

See Also

FamilyItemFactory Class
NewReferencePoint Overload
Autodesk.Revit.Creation Namespace

NewReferencePoint Method (XYZ)

[image]