Revit 2010 API
DividedSurface..::.ComponentRotation Property
DividedSurface Class See Also Send Feedback
The rotation of the pattern by a multiple of 90 degrees.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ComponentRotation ComponentRotation { get; set; }
Visual Basic (Declaration)
Public Property ComponentRotation As ComponentRotation
Visual C++
public:
property ComponentRotation ComponentRotation {
    ComponentRotation get ();
    void set (ComponentRotation value);
}

Remarks

This property has no effect unless a pattern is selected (the ObjectType property is not null).

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace

Host Property

[image]