Revit 2010 API
ReferencePoint..::.Position Property
ReferencePoint Class See Also Send Feedback
The position of the ReferencePoint.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Position { get; set; }
Visual Basic (Declaration)
Public Property Position As XYZ
Visual C++
public:
property XYZ^ Position {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This is an alternate interface to the property CoordinateSystem.Origin. When set, the effect is the same as setting the CoordinateSystem property to the same as its current value but with a different Origin.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when CoordinateSystem is set while the Reference property is not null, and the ReferencePoint is unable to move to the new location.

See Also

ReferencePoint Class
Autodesk.Revit.Elements Namespace

ShowNormalReferencePlaneOnly Property

[image]