Revit 2010 API
MessageBoxShowingEventArgs Class
Members See Also Send Feedback
The event arguments used by the DialogBoxShowing event when a Windows message box is about to be displayed in Revit.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MessageBoxShowingEventArgs : DialogBoxShowingEventArgs
Visual Basic (Declaration)
Public Class MessageBoxShowingEventArgs _
    Inherits DialogBoxShowingEventArgs
Visual C++
public ref class MessageBoxShowingEventArgs : public DialogBoxShowingEventArgs

Remarks

When the application receives this object, a simple message box is about to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.Events..::.RevitEventArgs
Autodesk.Revit.Events..::.PreEventArgs
Autodesk.Revit.Events..::.DialogBoxShowingEventArgs
Autodesk.Revit.Events..::.MessageBoxShowingEventArgs

See Also

MessageBoxShowingEventArgs Members
Autodesk.Revit.Events Namespace

MessageBoxShowingEventArgs Members

[image] [image]