Revit 2010 API
Sweep Members
Sweep Class Constructors Methods Properties See Also Send Feedback

The Sweep type exposes the following members.

Constructors

Name | Description
Sweep | For Internal Use Only.

Methods

Name | Description

Properties

Name | Description
IsTrajectorySegmentationEnabled | The trajectory segmentation option for the sweep.
MaxSegmentAngle | The maximum segment angle of the sweep in radians.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Path3d | The selected curves used for the sweep path.
PathSketch | The sketched path for the sweep.
ProfileSketch | The profile sketch of the sweep.
ProfileSymbol | The family symbol profile details for the sweep.

See Also

Sweep Class
Autodesk.Revit.Elements Namespace

Sweep Constructor

[image]