Revit 2010 API
DividedSurface..::.GetTileFamilyInstance Method
DividedSurface Class See Also Send Feedback
Get a reference to a tile element associated with a given seed node.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance GetTileFamilyInstance(
    GridNode gridNode,
    int tileIndex
)
Visual Basic (Declaration)
Public Function GetTileFamilyInstance ( _
    gridNode As GridNode, _
    tileIndex As Integer _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ GetTileFamilyInstance(
    GridNode gridNode,
    int tileIndex
)

Parameters

gridNode
Type: Autodesk.Revit.Elements..::.GridNode
tileIndex
Type: System..::.Int32

Return Value

A FamilyInstance object. Returns null if the ObjectType property is not a FamilySymbol. Returns null if the grid node is not a "seed node", or if the tile is omitted due to boundary conditions.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown if the grid node is outside of the range specified by NumberOfUGridlines and NumberOfVGridlines, or if tileIndex is outside the range [0, TilesPerSeedNode-1].

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace

GetTileReference Method

[image]