Revit 2010 API
Connector..::.CoordinateSystem Property
Connector Class See Also Send Feedback
The coordinate system of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Transform CoordinateSystem { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property CoordinateSystem As Transform
Visual C++
public:
virtual property Transform^ CoordinateSystem {
    Transform^ get ();
}

Implements

IConnector..::.CoordinateSystem

Remarks

The coordinate system's origin is the location of the connector and the Z-axis is normal to the connector.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector is of logical type.
System..::.InvalidOperationException | Thrown on failure to get coordinate system.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

Demand Property

[image]