Revit 2010 API
HostedSweep..::.SetEndPointParameter Method
HostedSweep Class See Also Send Feedback
Set segment's start point or end point parameter.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SetEndPointParameter(
    Reference targetRef,
    int endIdx,
    double param
)
Visual Basic (Declaration)
Public Function SetEndPointParameter ( _
    targetRef As Reference, _
    endIdx As Integer, _
    param As Double _
) As Boolean
Visual C++
public:
bool SetEndPointParameter(
    Reference^ targetRef,
    int endIdx,
    double param
)

Parameters

targetRef
Type: Autodesk.Revit.Geometry..::.Reference
Segment's reference whose parameter want to be set.
endIdx
Type: System..::.Int32
Start point (=0) or end point (=1).
param
Type: System..::.Double
Value of parameter.

Return Value

true if operation success.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace

VerticalFlip Method

[image]