Revit 2010 API
Application..::.OnDocumentOpened Event
Application Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentOpened event instead. Subscribe to the OnDocumentOpened event to be notified when a document is opened.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentOpened event instead.")]
public event DocumentOpenedEventHandler OnDocumentOpened
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentOpened event instead.")> _
Public Event OnDocumentOpened As DocumentOpenedEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentOpened event instead.")]
public:
 event DocumentOpenedEventHandler^ OnDocumentOpened {
    void add (DocumentOpenedEventHandler^ value);
    void remove (DocumentOpenedEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document has been opened. By subscribing to this event the application will be notified after such an event and can perform an action in response.

See Also

Application Class
Autodesk.Revit Namespace

OnDocumentSaved Event

[image]