Revit 2010 API
XYZArray Members
XYZArray Class Constructors Methods Properties See Also Send Feedback

The XYZArray type exposes the following members.

Constructors

Name | Description
XYZArray | Initializes a new instance of the XYZArray class

Methods

Name | Description
Append |
Clear | Removes every XYZ coordinate from the array, rendering it empty.
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
Item | Gets or sets a XYZ coordinate at a specified index within the array.
Size | Returns the number of XYZ coordinates that are in the array.

See Also

XYZArray Class
Autodesk.Revit.Geometry Namespace

XYZArray Constructor

[image]