Revit 2010 API
Document..::.NewTruss Method
Document Class Example See Also Send Feedback
Creates a New Truss.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Truss NewTruss(
    TrussType trussType,
    SketchPlane sketchPlane,
    Curve baseCurve,
    View dbView
)
Visual Basic (Declaration)
Public Function NewTruss ( _
    trussType As TrussType, _
    sketchPlane As SketchPlane, _
    baseCurve As Curve, _
    dbView As View _
) As Truss
Visual C++
public:
Truss^ NewTruss(
    TrussType^ trussType,
    SketchPlane^ sketchPlane,
    Curve^ baseCurve,
    View^ dbView
)

Parameters

trussType
Type: Autodesk.Revit.Symbols..::.TrussType
The type for truss.
sketchPlane
Type: Autodesk.Revit.Elements..::.SketchPlane
The sketch plane the truss is going to be reside in.It could be nullptr.
baseCurve
Type: Autodesk.Revit.Geometry..::.Curve
The curve that represents truss's base curve. It must be a line, must not be a vertical line, must be within the sketch plane if sketchPlane is valid.
dbView
Type: Autodesk.Revit.Elements..::.View
The DBView where truss's tag going to be placed. A valid dbViewId must be a Plan view or RPlan view, or an elevation view paralleling to the truss base curve.

Examples

CopyC#
Truss CreateTruss(Autodesk.Revit.Document document, FamilyInstance column1, FamilyInstance column2)
{
    //sketchPlane
    XYZ origin = new XYZ(0, 0, 0);
    XYZ xDirection = new XYZ(1, 0, 0);
    XYZ yDirection = new XYZ(0, 1, 0);
    Plane plane = document.Application.Create.NewPlane(xDirection, yDirection, origin);
    SketchPlane sketchPlane = document.Create.NewSketchPlane(plane);

    //new base Line - use line that spans two selected columns
    AnalyticalModelFrame frame1 = column1.AnalyticalModel as AnalyticalModelFrame;
    XYZ centerPoint1 = (frame1.Curve as Line).get_EndPoint(0);

    AnalyticalModelFrame frame2 = column2.AnalyticalModel as AnalyticalModelFrame;
    XYZ centerPoint2 = (frame2.Curve as Line).get_EndPoint(0);

    XYZ startPoint = new XYZ(centerPoint1.X, centerPoint1.Y, 0);
    XYZ endPoint = new XYZ(centerPoint2.X, centerPoint2.Y, 0);
    Autodesk.Revit.Geometry.Line baseLine = null;

    try
    {
        baseLine = document.Application.Create.NewLineBound(startPoint, endPoint);
    }
    catch (System.ArgumentException)
    {
        throw new Exception("Selected columns are too close to create truss.");
    }

    // use the active view for where the truss's tag will be placed; View used in
    // NewTruss should be plan or elevation view parallel to the truss's base line
    Autodesk.Revit.Elements.View view = document.ActiveView;

    // Get a truss type for the truss
    TrussType trussType = null;
    foreach (TrussType currentType in document.TrussTypes)
    {
        if (null != currentType)
        {
            trussType = currentType;
            break;
        }
    }

    Truss truss = null;
    if (null != trussType)
    {
        truss = document.Create.NewTruss(trussType, sketchPlane, baseLine, view);
    }
    else
    {
        throw new Exception("No truss types found in document.");
    }

    return truss;
}
CopyVB.NET
Private Function CreateTruss(ByVal document As Autodesk.Revit.Document, ByVal column1 As Autodesk.Revit.Elements.FamilyInstance, ByVal column2 As Autodesk.Revit.Elements.FamilyInstance) As Truss
    'sketchPlane
    Dim origin As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
    Dim xDirection As New Autodesk.Revit.Geometry.XYZ(1, 0, 0)
    Dim yDirection As New Autodesk.Revit.Geometry.XYZ(0, 1, 0)
    Dim plane As Autodesk.Revit.Geometry.Plane = document.Application.Create.NewPlane(xDirection, yDirection, origin)
    Dim sketchPlane As Autodesk.Revit.Elements.SketchPlane = document.Create.NewSketchPlane(plane)

    'new base Line - use line that spans two selected columns
    Dim frame1 As AnalyticalModelFrame = TryCast(column1.AnalyticalModel, AnalyticalModelFrame)
    Dim centerPoint1 As Autodesk.Revit.Geometry.XYZ = TryCast(frame1.Curve, Line).EndPoint(0)

    Dim frame2 As AnalyticalModelFrame = TryCast(column2.AnalyticalModel, AnalyticalModelFrame)
    Dim centerPoint2 As Autodesk.Revit.Geometry.XYZ = TryCast(frame2.Curve, Line).EndPoint(0)

    Dim startPoint As New Autodesk.Revit.Geometry.XYZ(centerPoint1.X, centerPoint1.Y, 0)
    Dim endPoint As New Autodesk.Revit.Geometry.XYZ(centerPoint2.X, centerPoint2.Y, 0)
    Dim baseLine As Autodesk.Revit.Geometry.Line = Nothing

    Try
        baseLine = document.Application.Create.NewLineBound(startPoint, endPoint)
    Catch generatedExceptionName As System.ArgumentException
        Throw New Exception("Selected columns are too close to create truss.")
    End Try

    ' use the active view for where the truss's tag will be placed; View used in
    ' NewTruss should be plan or elevation view parallel to the truss's base line
    Dim view As Autodesk.Revit.Elements.View = document.ActiveView

    ' Get a truss type for the truss
    Dim trussType As TrussType = Nothing
    For Each currentType As TrussType In document.TrussTypes
        If currentType IsNot Nothing Then
            trussType = currentType
            Exit For
        End If
    Next

    Dim truss As Truss = Nothing
    If trussType IsNot Nothing Then
        truss = document.Create.NewTruss(trussType, sketchPlane, baseLine, view)
    Else
        Throw New Exception("No truss types found in document.")
    End If

    Return truss
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewUnionFitting Method

[image]