Revit 2010 API
XYZ Members
XYZ Class Constructors Methods Properties See Also Send Feedback

The XYZ type exposes the following members.

Constructors

Name | Description
XYZ | Overloaded.

Methods

Name | Description
Add | Adds the specified vector to this vector and returns the result.
AlmostEqual | Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).
Angle | Returns the angle between this vector and the specified vector.
AngleAround | Returns the angle between this vector and the specified vector projected to the specified plane.
Cross | The cross product of this vector and the specified vector.
Distance | Returns the distance from this point to the specified point.
Divide | Divides this vector by the specified value and returns the result.
Dot | The dot product of this vector and the specified vector.
Multiply | Multiplies this vector by the specified value and returns the result.
Negate | Negates this vector.
Subtract | Subtracts the specified vector from this vector and returns the result.
TripleProduct | The triple product of this vector and the two specified vectors.

Operators

Name | Description
Addition | Adds the two specified vectors and returns the result.
Division | Divides the specified vector by the specified value.
Multiply | Overloaded. Multiplies the specified number and the specified vector.
Subtraction | Subtracts the two specified vectors and returns the result.
UnaryNegation | Negates the specified vector and returns the result.

Properties

Name | Description
Basis | Indexed access for Basis.
BasisX | The basis of the X axis.
BasisY | The basis of the Y axis.
BasisZ | The basis of the Z axis.
IsNormalized | The boolean value that indicates whether this vector is a normalized vector.
IsZero | The boolean value that indicates whether this vector is a zero vector.
Item | Indexed access to coordinates.
Length | The length of this vector.
Normalized | This vector, normalized.
X | The first coordinate.
Y | The second coordinate.
Z | The third coordinate.
Zero | The coordinate origin or zero vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace

XYZ Constructor

[image] [image]