Revit 2010 API
CurveElement Members
CurveElement Class Constructors Methods Properties See Also Send Feedback

The CurveElement type exposes the following members.

Constructors

Name | Description
CurveElement | Initializes a new instance of the CurveElement class

Methods

Name | Description

Properties

Name | Description
GeometryCurve | Geometry curve of the curve element.
LineStyle | The line style of this curve element.
LineStyles | All available line styles.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
SketchPlane | The sketch plane the curve element lies in.

See Also

CurveElement Class
Autodesk.Revit.Elements Namespace

CurveElement Constructor

[image]