Revit 2010 API
RoofBase Class
Members See Also Send Feedback
Represents all kinds of Roofs.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RoofBase : HostObject
Visual Basic (Declaration)
Public Class RoofBase _
    Inherits HostObject
Visual C++
public ref class RoofBase : public HostObject

Remarks

The RoofBase object represents all kinds of roof in Revit.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.RoofBase
Autodesk.Revit.Elements..::.ExtrusionRoof
Autodesk.Revit.Elements..::.FootPrintRoof

See Also

RoofBase Members
Autodesk.Revit.Elements Namespace

RoofBase Members

[image] [image]