Revit 2010 API
Wall..::.StructuralUsage Property
Wall Class See Also Send Feedback
The walls designated structural usage, such as bearing or non bearing.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WallUsage StructuralUsage { get; set; }
Visual Basic (Declaration)
Public Property StructuralUsage As WallUsage
Visual C++
public:
property WallUsage StructuralUsage {
    WallUsage get ();
    void set (WallUsage value);
}

Remarks

The StructuralUsage property is a read only property that returns the walls designated usage. Example values of this property are Non Bearing, Bearing, Shear, Combined etc.

See Also

Wall Class
Autodesk.Revit.Elements Namespace

WallType Property

[image]