Revit 2010 API
RebarShapeArcReferenceType Enumeration
See Also Send Feedback
A Rebar Shape Definition constraint that is measured to a bend must take the bar diameter into account, by specifying whether it measures to the exterior, centerline, or interior of the bend.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum RebarShapeArcReferenceType
Visual Basic (Declaration)
Public Enumeration RebarShapeArcReferenceType
Visual C++
public enum class RebarShapeArcReferenceType

Members

Member name | Description
External | Measure to the exterior of the bend.
Centerline | Measure to the centerline of the bar.
Internal | Measure to the interior of the bend.

See Also

Autodesk.Revit.Structural.Enums Namespace

RebarShapeBendAngle Enumeration

[image]