Revit 2010 API
Options..::.DetailLevel Property
Options Class See Also Send Feedback
The detail level for the geometry extracted with these options.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Options..::.DetailLevels DetailLevel { get; set; }
Visual Basic (Declaration)
Public Property DetailLevel As Options..::.DetailLevels
Visual C++
public:
property Options..::.DetailLevels DetailLevel {
    Options..::.DetailLevels get ();
    void set (Options..::.DetailLevels value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when setting this property, if View is already set. When View is set the detail level of the view is used.

See Also

Options Class
Autodesk.Revit.Geometry Namespace

IncludeNonVisibleObjects Property

[image]