Revit 2010 API
ProjectInfo Class
Members Example See Also Send Feedback
An object that represents a Project Information within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ProjectInfo : Element
Visual Basic (Declaration)
Public Class ProjectInfo _
    Inherits Element
Visual C++
public ref class ProjectInfo : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Examples

CopyC#
ProjectInfo projectInfo = document.ProjectInformation;

if (null != projectInfo)
{
    string message = "Project information:";
    //get the project name
    message += "\nName: " + projectInfo.Name;
    string newName = "My project";
    //set the project name
    projectInfo.Name = newName;
    message += "\nProject Name after set: " + projectInfo.Name;

    //get the project number
    message += "\nNumber: " + projectInfo.Number;
    string newNumber = "TestNumber";
    //set the project number
    projectInfo.Number = newNumber;
    message += "\nProject Number after set: " + projectInfo.Number;

    //get the status of the project
    message += "\nStatus: " + projectInfo.Status;
    string newStatus = "TestStatus";
    //set the project status
    projectInfo.Status = newStatus;
    message += "\nProject status after set: " + projectInfo.Status;

    //get the address of the project
    message += "\nAddress: " + projectInfo.Address;
    string newAddress = "TestAddress";
    //set the project address
    projectInfo.Address = newAddress;
    message += "\nProject address after set: " + projectInfo.Address;

    //get the client name of the project
    message += "\nClient Name: " + projectInfo.ClientName;
    string newClient = "TestClientName";
    //set the client name
    projectInfo.ClientName = newClient;
    message += "\nProject client name after set: " + projectInfo.ClientName;

    //get the gbXmlSetting of the project
    gbXMLParamElem xmlSetting = projectInfo.gbXMLSettings;
    message += "\nBuilding type: " + xmlSetting.BuildingType.ToString();
    message += "\nPostal Code: " + xmlSetting.PostalCode;

    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Dim projectInfo As Autodesk.Revit.Elements.ProjectInfo = document.ProjectInformation

If projectInfo IsNot Nothing Then
    Dim message As String = "Project information:"
    'get the project name
    message += vbLf & "Name: " & projectInfo.Name
    Dim newName As String = "My project"
    'set the project name
    projectInfo.Name = newName
    message += vbLf & "Project Name after set: " & projectInfo.Name

    'get the project number
    message += vbLf & "Number: " & projectInfo.Number
    Dim newNumber As String = "TestNumber"
    'set the project number
    projectInfo.Number = newNumber
    message += vbLf & "Project Number after set: " & projectInfo.Number

    'get the status of the project
    message += vbLf & "Status: " & projectInfo.Status
    Dim newStatus As String = "TestStatus"
    'set the project status
    projectInfo.Status = newStatus
    message += vbLf & "Project status after set: " & projectInfo.Status

    'get the address of the project
    message += vbLf & "Address: " & projectInfo.Address
    Dim newAddress As String = "TestAddress"
    'set the project address
    projectInfo.Address = newAddress
    message += vbLf & "Project address after set: " & projectInfo.Address

    'get the client name of the project
    message += vbLf & "Client Name: " & projectInfo.ClientName
    Dim newClient As String = "TestClientName"
    'set the client name
    projectInfo.ClientName = newClient
    message += vbLf & "Project client name after set: " & projectInfo.ClientName

    'get the gbXmlSetting of the project
    Dim xmlSetting As Autodesk.Revit.Elements.gbXMLParamElem = projectInfo.gbXMLSettings
    message += vbLf & "Building type: " & xmlSetting.BuildingType.ToString()
    message += vbLf & "Postal Code: " & xmlSetting.PostalCode

    MessageBox.Show(message, "Revit")
End If

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.ProjectInfo

See Also

ProjectInfo Members
Autodesk.Revit.Elements Namespace

ProjectInfo Members

[image] [image]