Revit 2010 API
DuctConnector..::.SystemType Property
DuctConnector Class See Also Send Feedback
The system type of the duct connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DuctSystemType SystemType { get; set; }
Visual Basic (Declaration)
Public Property SystemType As DuctSystemType
Visual C++
public:
property DuctSystemType SystemType {
    DuctSystemType get ();
    void set (DuctSystemType value);
}

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the input system type is not within the permitted range.

See Also

DuctConnector Class
Autodesk.Revit.MEP Namespace

Width Property

[image]