Revit 2010 API
Application..::.DocumentOpened Event
Application Class See Also Send Feedback
Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentOpenedEventArgs> DocumentOpened
Visual Basic (Declaration)
Public Event DocumentOpened As EventHandler(Of DocumentOpenedEventArgs)
Visual C++
public:
 event EventHandler<DocumentOpenedEventArgs^>^ DocumentOpened {
    void add (EventHandler<DocumentOpenedEventArgs^>^ value);
    void remove (EventHandler<DocumentOpenedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished opening a document. It is raised even when document opening failed or was cancelled (during DocumentOpening event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of opening document has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

The DocumentOpened event is meant to replace the older OnDocumentOpened event, which is now Obsolete.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace

DocumentOpening Event

[image]