Revit 2010 API
ApplicationEvents..::.OnDialogBox Method
ApplicationEvents Interface See Also Send Feedback
This event is fired whenever a Revit dialog box is displayed that requires user interaction during an external api command.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
void OnDialogBox(
    DialogBoxData dialogBoxData
)
Visual Basic (Declaration)
Sub OnDialogBox ( _
    dialogBoxData As DialogBoxData _
)
Visual C++
void OnDialogBox(
    DialogBoxData^ dialogBoxData
)

Parameters

dialogBoxData
Type: Autodesk.Revit.Events..::.DialogBoxData
An object that describes the dialog box.

See Also

ApplicationEvents Interface
Autodesk.Revit.Events Namespace

OnDocumentClosed Method

[image]