Revit 2010 API
Settings..::.ElectricalSetting Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElectricalSetting ElectricalSetting { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElectricalSetting As ElectricalSetting
Visual C++
public:
property ElectricalSetting^ ElectricalSetting {
    ElectricalSetting^ get ();
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Electrical settings can be accessed only if Revit MEP product is available.

See Also

Settings Class
Autodesk.Revit Namespace

FillPatterns Property

[image]