Revit 2010 API
Phase Class
Members See Also Send Feedback
Represents a phase in the life of a building.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Phase : Element
Visual Basic (Declaration)
Public Class Phase _
    Inherits Element
Visual C++
public ref class Phase : public Element

Remarks

The lifetime of an element within a building can be controlled by using phases. Each element will have a construction phase but only those elements that have a finite lifetime will have a destruction phase. All the phases within a project can be retrieved from the Document object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Phase

See Also

Phase Members
Autodesk.Revit.Elements Namespace

Phase Members

[image] [image]