Revit 2010 API
PrintParameters..::.PaperSize Property
PrintParameters Class See Also Send Feedback
The page size.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PaperSize PaperSize { get; set; }
Visual Basic (Declaration)
Public Property PaperSize As PaperSize
Visual C++
public:
property PaperSize^ PaperSize {
    PaperSize^ get ();
    void set (PaperSize^ value);
}

Remarks

User can select the candidate via PaperSizes and then set the Page source of the Print Setting.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument is null.
System..::.ArgumentException | Thrown when the input argument is invalid for current printer.

See Also

PrintParameters Class
Autodesk.Revit Namespace

PaperSource Property

[image]