Revit 2010 API
Truss Methods
Truss Class See Also Send Feedback

The Truss type exposes the following members.

Methods

Name | Description
AttachTopChord | Attach truss's top to a specified element,the element should be a roof or floor.
DetachTopChord | Detach the truss's top from a specified element.
GetTrussMemberInfo | Query if a given element is a member of a truss,its lock status and its usage,etc.
RemoveProfile | Remove the profile of a truss.
SetProfile | Add or modify the profile of a truss.
TogglePinMember | Pin/Unpin a truss member.

See Also

Truss Class
Autodesk.Revit.Elements Namespace

AttachTopChord Method

[image]