Revit 2010 API
FamilySymbol Class
Members Example See Also Send Feedback
Represents a single Type within a Family.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FamilySymbol : InsertableObject
Visual Basic (Declaration)
Public Class FamilySymbol _
    Inherits InsertableObject
Visual C++
public ref class FamilySymbol : public InsertableObject

Remarks

The FamilySymbol object represents a Type within a Family. Each family can contain one or more family symbols. The FamilySymbol object is derived from the Symbol object and also the Element object and as such inherits all the properties and methods of those objects.

Examples

CopyC#
public void GetInfo_FamilySymbol(FamilySymbol familySymbol)
{
    string message;
    // Get FamilySymbol family name
    message = "Family name is : " + familySymbol.Family.Name;

    // Get FamilySymbol material
    message += "\nFamilySymbol material is : " + familySymbol.Material.ToString();

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_FamilySymbol(ByVal familySymbol As Autodesk.Revit.Symbols.FamilySymbol)
    Dim message As String
    ' Get FamilySymbol family name
    message = "Family name is : " & familySymbol.Family.Name

    ' Get FamilySymbol material
    message += vbLf & "FamilySymbol material is : " & familySymbol.Material.ToString()

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.InsertableObject
Autodesk.Revit.Symbols..::.FamilySymbol
Autodesk.Revit.Symbols..::.AnnotationSymbolType
Autodesk.Revit.Symbols..::.AreaTagType
Autodesk.Revit.Symbols..::.MullionType
Autodesk.Revit.Symbols..::.PanelType
Autodesk.Revit.Symbols..::.RoomTagType
Autodesk.Revit.Symbols..::.SpaceTagType

See Also

FamilySymbol Members
Autodesk.Revit.Symbols Namespace

FamilySymbol Members

[image] [image]