Revit 2010 API
RibbonPanel..::.AddToPulldown Method
RibbonPanel Class See Also Send Feedback
Adds a pushbutton to the existing PulldownButton.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PushButton AddToPulldown(
    string pulldownName,
    string text,
    string assembly,
    string className
)
Visual Basic (Declaration)
Public Function AddToPulldown ( _
    pulldownName As String, _
    text As String, _
    assembly As String, _
    className As String _
) As PushButton
Visual C++
public:
PushButton^ AddToPulldown(
    String^ pulldownName,
    String^ text,
    String^ assembly,
    String^ className
)

Parameters

pulldownName
Type: System..::.String
The name of the PulldownButton.
text
Type: System..::.String
The text of the menu item.
assembly
Type: System..::.String
The assembly path which contains the corresponding external command.
className
Type: System..::.String
The class name which implements the interface IExternalCommand.

Return Value

The added pushbutton.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when pulldownName, text, assembly or classname is null.
System..::.ArgumentException | Thrown when pulldownName, text, assembly or classname is empty, or when the pulldown cannot be found in the panel.

See Also

RibbonPanel Class
Autodesk.Revit Namespace

Equals Method

[image]