Revit 2010 API
FamilyType..::.HasValue Method
FamilyType Class See Also Send Feedback
Indicates if this family parameter has an assigned value or not.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool HasValue(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function HasValue ( _
    familyParameter As FamilyParameter _
) As Boolean
Visual C++
public:
bool HasValue(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.ArgumentException | Thrown if the input argument-"familyParameter"-is invalid.

See Also

FamilyType Class
Autodesk.Revit Namespace

FamilyType Properties

[image] [image]