Revit 2010 API
XYZ..::.Multiply Operator
XYZ Class See Also Send Feedback
Multiplies the specified number and the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static XYZ operator *(
    XYZ left,
    double value
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    left As XYZ, _
    value As Double _
) As XYZ
Visual C++
public:
static XYZ^ operator *(
    XYZ^ left,
    double value
)

Parameters

left
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to multiply with the value.
value
Type: System..::.Double
The value to multiply with the specified vector.

Return Value

The multiplied vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when the specified value is an infinite number.

See Also

XYZ Class
Multiply Overload
Autodesk.Revit.Geometry Namespace

Multiply Operator

[image]