Revit 2010 API
Document..::.Elements Property (Type, ElementArray)
Document Class Example See Also Send Feedback
Collects all elements which satisfy specified type within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Elements[
    Type type,
    ElementArray elementArray
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements ( _
    type As Type, _
    elementArray As ElementArray _
) As Integer
Visual C++
public:
property int Elements[Type^ type, ElementArray^ elementArray] {
    int get (Type^ type, ElementArray^ elementArray);
}

Parameters

type
Type: System..::.Type
Type used to determine the elements to add.
elementArray
Type: Autodesk.Revit..::.ElementArray
An array of elements which contains the elements found.

Remarks

If the element array provided already contains elements, new elements added to the element array will be checked against the contents of the element array, and elements already in the input will not be added to the element array again. Because of the overhead required to perform these checks, to obtain the best performance from this property pass an empty element array. This method won't find elements whose type is derived from the specified type.

Examples

CopyC#
ElementArray levelArray = new ElementArray();
int levels = document.get_Elements(typeof(Level), levelArray);

if (null != levelArray)
{
    string prompt = "There are " + levels + " levels in the project.\n";
    foreach (Element level in levelArray)
    {
        prompt += level.Name + "\n";
    }

    MessageBox.Show(prompt, "Revit");
}
CopyVB.NET
Dim levelArray As New ElementArray()
Dim levels As Integer = document.Elements(GetType(Autodesk.Revit.Elements.Level), levelArray)

If levelArray IsNot Nothing Then
    Dim prompt As String = "There are " & levels & " levels in the project." & vbLf
    For Each level As Autodesk.Revit.Element In levelArray
        prompt += level.Name & vbLf
    Next

    MessageBox.Show(prompt, "Revit")
End If

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter of type or elementArray is null.

See Also

Document Class
Elements Overload
Autodesk.Revit Namespace

Elements Property (Type, ICollection(Element))

[image]