Revit 2010 API
FamilyItemFactory Class
Members See Also Send Feedback
The Family Item Factory object is used to create new instances of elements within the Autodesk Revit Family.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FamilyItemFactory : ItemFactoryBase
Visual Basic (Declaration)
Public Class FamilyItemFactory _
    Inherits ItemFactoryBase
Visual C++
public ref class FamilyItemFactory : public ItemFactoryBase

Remarks

The Family Item Factory object is a utility object that is used to create new instances of elements within the Autodesk Revit Family Document. This object, available from the Autodesk.Revit.Document.FamilyCreate property should be used to create elements instead of using New. This object ensures that the elements created are added to the family document correctly. The object can create a limited number of types, which is expected to increase as the API matures.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Creation..::.ItemFactoryBase
Autodesk.Revit.Creation..::.FamilyItemFactory

See Also

FamilyItemFactory Members
Autodesk.Revit.Creation Namespace

FamilyItemFactory Members

[image] [image]