Revit 2010 API
FamilyElementVisibilityType Enumeration
See Also Send Feedback
Indicates the Visiblity type of generic forms.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum FamilyElementVisibilityType
Visual Basic (Declaration)
Public Enumeration FamilyElementVisibilityType
Visual C++
public enum class FamilyElementVisibilityType

Members

Member name | Description
Model | The element will be displayed in 3D views and model other model views.
ViewSpecific | The element will be displayed only in the view where it is created. This applies to items like detail components, annotations, and view-specific imports.

Remarks

Use this enum in NewExtrusion, NewBlend, NewRevolution, NewSweep, and NewSweptBlend methods to indicate the visibility type of new forms.

See Also

Autodesk.Revit Namespace

FamilyFilter Class

[image]