Revit 2010 API
Curve..::.Project Method
Curve Class See Also Send Feedback
Projects the specified point on this curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public IntersectionResult Project(
    XYZ point
)
Visual Basic (Declaration)
Public Function Project ( _
    point As XYZ _
) As IntersectionResult
Visual C++
public:
IntersectionResult^ Project(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
The point to be projected.

Return Value

Geometric information if projection is successful.

Remarks

The following is the meaning of every IntersectionResult's members:
  • XYZPoint is the nearest point on the curve;
  • Parameter is the unnormalized parameter on the curve (use ComputeNormalizedParameter to compute the normalized value)
  • Distance is the distance from the point to the curve (equivalent to Distance).

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when failed to find the closest point on the curve.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace

Tessellate Method

[image]