Revit 2010 API
Document..::.SaveAs Method
Document Class See Also Send Feedback
Saves the document to a file name obtained from the Revit user.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SaveAs()
Visual Basic (Declaration)
Public Function SaveAs As Boolean
Visual C++
public:
bool SaveAs()

Return Value

Returns 'false' if save operation fails. Also returns 'false' if saving as is cancelled by an external application during 'DocumentSavingAs' event. When function succeeds, 'true' is returned.

Remarks

Because the argument list is null, a SaveAs dialog will be shown to query the file name.

See Also

Document Class
SaveAs Overload
Autodesk.Revit Namespace

SaveAs Method (PostedErrorArray)

[image]