Revit 2010 API
HostedSweep Members
HostedSweep Class Constructors Methods Properties See Also Send Feedback

The HostedSweep type exposes the following members.

Constructors

Name | Description
HostedSweep | For Internal Use Only.

Methods

Name | Description
AddSegment | Add segments to the hosted sweep object.
GetEndPointParameter | Retrieve segment's start point or end point parameter.
HorizontalFlip | Flip the hosted sweep object along horizontal line.
RemoveSegment | Remove segments from the hosted sweep object.
SetEndPointParameter | Set segment's start point or end point parameter.
VerticalFlip | Flip the hosted sweep object along vertical line.

Properties

Name | Description
Angle | Retrieve/set the angle of the hosted sweep object relatives it's reference(s) (Unit : Radian).
HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object.
HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object.
Length | Retrieve the length of the hosted sweep object.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
ReferenceCurve | Retrieve the curve on which the hosted sweep object's segment is created on the corresponding.
VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object.
VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace

HostedSweep Constructor

[image]