Revit 2010 API
ControlledApplication..::.OnDialogBox Event
ControlledApplication Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DialogBoxShowing event instead. Subscribe to the OnDialogBox event to be notified when a Reivt dialog box is displayed during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DialogBoxShowing event instead.")]
public event DialogBoxEventHandler OnDialogBox
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DialogBoxShowing event instead.")> _
Public Event OnDialogBox As DialogBoxEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DialogBoxShowing event instead.")]
public:
 event DialogBoxEventHandler^ OnDialogBox {
    void add (DialogBoxEventHandler^ value);
    void remove (DialogBoxEventHandler^ value);
}

Remarks

Sometimes a Revit dialog box may be displayed during an API external application. By subscribing to this event you application will be notified of such an event and perform an action, such as causing the dialog to be ok'd or cancelled etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace

OnDocumentClosed Event

[image]