Revit 2010 API
IExternalApplication..::.Result Enumeration
IExternalApplication Interface See Also Send Feedback
Informs Autodesk Revit of the status of your application after execution.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum Result
Visual Basic (Declaration)
Public Enumeration Result
Visual C++
public enum class Result

Members

Member name | Description
Cancelled | Signifies that the external application is cancelled.
Succeeded | The external application completed successfully. Autodesk Revit will keep this object during the entire Revit session.
Failed | The external application was unable to complete its task.

See Also

Autodesk.Revit Namespace

IExternalCommand Interface

[image]