Revit 2010 API
MEPBuildingConstruction..::.Constructions Property
MEPBuildingConstruction Class See Also Send Feedback
Get all the Building Constructions according to the specific Construction type.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Set Constructions[
    ConstructionType constructionType
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Constructions ( _
    constructionType As ConstructionType _
) As Set
Visual C++
public:
property Set^ Constructions[ConstructionType constructionType] {
    Set^ get (ConstructionType constructionType);
}

Parameters

constructionType
Type: Autodesk.Revit.Parameters..::.ConstructionType
The Construction Type to be set the Building Construction.

Remarks

This property is used to get or set the Building Service of the Project Information.

See Also

MEPBuildingConstruction Class
Autodesk.Revit.Symbols Namespace

Parameter Property

[image] [image]