Revit 2010 API
CurveArray..::.Insert Method
CurveArray Class See Also Send Feedback
Insert the specified curve into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    Curve item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Curve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Curve^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.Curve
The curve to be inserted into the array.
index
Type: System..::.Int32
The curve will be inserted before this index.

Return Value

Returns whether the curve was inserted into the array.

See Also

CurveArray Class
Autodesk.Revit.Geometry Namespace

ReverseIterator Method

[image]