Revit 2010 API
AnalyticalModelFrame..::.Curves Property
AnalyticalModelFrame Class See Also Send Feedback
Returns curves that define the Analytical Model of the associated Element.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray Curves { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

Return Value

Returns a CurveArray containing the Analytical Model.

Remarks

There are no significant restrictions on the curves; they may not be coplanar, and they may not be even connected.

See Also

AnalyticalModelFrame Class
Autodesk.Revit.Structural Namespace

Profile Property

[image]