Revit 2010 API
PrintManager..::.PrintToFileName Property
PrintManager Class See Also Send Feedback
The file name when printing to file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string PrintToFileName { get; set; }
Visual Basic (Declaration)
Public Property PrintToFileName As String
Visual C++
public:
property String^ PrintToFileName {
    String^ get ();
    void set (String^ value);
}

Remarks

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input file name is null.
System..::.ArgumentException | Thrown when the input file name is an invalid string.

See Also

PrintManager Class
Autodesk.Revit Namespace

ViewSheetSetting Property

[image]