Revit 2010 API
Form..::.TopOffset Property
Form Class See Also Send Feedback
Retrieve/set the top offset of the form object. It is only valid for locked form.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double TopOffset { get; set; }
Visual Basic (Declaration)
Public Property TopOffset As Double
Visual C++
public:
property double TopOffset {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when this is not a locked form.
System..::.ArgumentException | Thrown when the value is invalid.
System..::.Exception | Thrown when it fail to get/set TopOffset.

See Also

Form Class
Autodesk.Revit.Elements Namespace

gbXMLParamElem Class

[image]