Revit 2010 API
RebarBarType..::.GetAutoCalcHookLengths Method
RebarBarType Class See Also Send Feedback
Whether hook lengths are automatically calculated.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool GetAutoCalcHookLengths(
    RebarHookType hookType
)
Visual Basic (Declaration)
Public Function GetAutoCalcHookLengths ( _
    hookType As RebarHookType _
) As Boolean
Visual C++
public:
bool GetAutoCalcHookLengths(
    RebarHookType^ hookType
)

Parameters

hookType
Type: Autodesk.Revit.Symbols..::.RebarHookType
A hook type in the same document as this bar type.

Return Value

True if hook lengths are automatically calculated.

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace

SetAutoCalcHookLengths Method

[image]