Revit 2010 API
ElectricalConnector..::.Width Property
ElectricalConnector Class See Also Send Feedback
The width of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual double Width { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Width As Double
Visual C++
public:
virtual property double Width {
    double get ();
}

Implements

IConnector..::.Width

Remarks

no shape for electrical connector.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Always thrown because electrical connectors don't have a shape.

See Also

ElectricalConnector Class
Autodesk.Revit.MEP Namespace

ElectricalEquipment Class

[image]