Revit 2010 API
ReferencePoint Class
Members See Also Send Feedback
A reference point in an Autodesk Revit family.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ReferencePoint : Element
Visual Basic (Declaration)
Public Class ReferencePoint _
    Inherits Element
Visual C++
public ref class ReferencePoint : public Element

Remarks

A ReferencePoint represents a point in space together with a local coordinate system. ReferencePoints can be free, or constrained to other elements in several ways. When the point is constrained, the coordinate system is also constrained in certain ways.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.ReferencePoint

See Also

ReferencePoint Members
Autodesk.Revit.Elements Namespace

ReferencePoint Members

[image] [image]