Revit 2010 API
Document..::.Elements Property
Document Class See Also Send Feedback
Provides access to a set of elements from the document.

Overload List

Name | Description
Elements | Provides access to all elements within the Document.
Elements[([(Filter])]) | Provides access to all elements which satisfy specified filter within the Document.
Elements[([(Type])]) | Provides access to all elements of specified type from the document.
Elements[([(Filter, ElementArray])]) | Collects all elements which satisfy specified filter within the Document.
Elements[([(Filter, ICollection<(Of <(Element>)>)])]) | Collects all elements which satisfy specified filter within the Document.
Elements[([(Type, ElementArray])]) | Collects all elements which satisfy specified type within the Document.
Elements[([(Type, ICollection<(Of <(Element>)>)])]) | Collects all elements which satisfy specified type within the Document.

See Also

Document Class
Document Members
Autodesk.Revit Namespace

Elements Property

[image]