Revit 2010 API
LocationCurve..::.JoinType Property
LocationCurve Class See Also Send Feedback
Get/change the type of the join at the specified end.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public JoinType JoinType[
    int end
] { get; set; }
Visual Basic (Declaration)
Public Property JoinType ( _
    end As Integer _
) As JoinType
Visual C++
public:
property JoinType JoinType[int end] {
    JoinType get (int end);
    void set (int end, JoinType value);
}

Parameters

end
Type: System..::.Int32
The end of the location curve driver under question.

Remarks

This property allows to get join type of wall and concrete beam and to set wall's join type. The new join type is expected to be different from the current one for this end.

Exceptions

Exception | Condition
System..::.NotSupportedException | The element is neither a wall nor a concrete beam when it tries to get the property. The element is not a wall when it tries to set the property.
System..::.InvalidOperationException | A failure occurred while attempting to set the new type.

See Also

LocationCurve Class
Autodesk.Revit Namespace

LocationPoint Class

[image]