Revit 2010 API
CurtainSystem..::.AddCurtainGrid Method
CurtainSystem Class See Also Send Feedback
Add CurtainGrid on the specified face for the CurtainSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddCurtainGrid(
    Reference face
)
Visual Basic (Declaration)
Public Sub AddCurtainGrid ( _
    face As Reference _
)
Visual C++
public:
void AddCurtainGrid(
    Reference^ face
)

Parameters

face
Type: Autodesk.Revit.Geometry..::.Reference
The face new CurtainGrid will be created on.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument face is nullptr.
System..::.InvalidOperationException | Thrown when creating CurtainGrid on the specified face fails or regenerate fails.

See Also

CurtainSystem Class
Autodesk.Revit.Elements Namespace

RemoveCurtainGrid Method

[image]