Revit 2010 API
PipeType Members
PipeType Class Constructors Methods Properties See Also Send Feedback

The PipeType type exposes the following members.

Constructors

Name | Description
PipeType | For Internal Use Only.

Methods

Name | Description

Properties

Name | Description
Class | The schedule type of the pipe type.
ConnectionType | The connection type of the pipe type.
Material | The material type of the pipe type.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Roughness | The roughness of the pipe type. (Overrides MEPCurveType..::.Roughness.)

See Also

PipeType Class
Autodesk.Revit.MEP Namespace

PipeType Constructor

[image]