Revit 2010 API
Filter Class
Members See Also Send Feedback
The Filter creation object is used to create new instances of element filter utility objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Filter : APIObject
Visual Basic (Declaration)
Public Class Filter _
    Inherits APIObject
Visual C++
public ref class Filter : public APIObject

Remarks

Elements filter related objects can be generated by this creation object. Creating objects via this object ensures that they will be correctly constructed and will reside in the Autodesk Revit memory space.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Creation..::.Filter

See Also

Filter Members
Autodesk.Revit.Creation Namespace

Filter Members

[image] [image]