Revit 2010 API
Document..::.Delete Method (ElementId%)
Document Class Example See Also Send Feedback
Deletes an element from the document given the id of that element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementIdSet Delete(
    ref ElementId id
)
Visual Basic (Declaration)
Public Function Delete ( _
    ByRef id As ElementId _
) As ElementIdSet
Visual C++
public:
ElementIdSet^ Delete(
    ElementId% id
)

Parameters

id
Type: Autodesk.Revit..::.ElementId %
The ElementId for the element that is to be deleted.

Remarks

This method will delete the element and any elements that are totally dependent upon that element. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

Examples

CopyC#
private void DeleteElement(Autodesk.Revit.Document document, Element element)
{
    // Delete an element via its id
    ElementId elementId = element.Id;
    ElementIdSet deletedIdSet = document.Delete(ref elementId);

    if (0 == deletedIdSet.Size)
    {
        throw new Exception("Deleting the selected element in revit failed.");
    }

    String prompt = "The selected element has been removed and ";
    prompt += deletedIdSet.Size - 1;
    prompt += " more dependent elements have also been removed.";

    // Give the user some information
    MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
' Delete an element via its id
Dim elementId As Autodesk.Revit.ElementId = element.Id
Dim deletedIdSet As ElementIdSet = document.Delete(elementId)

If 0 = deletedIdSet.Size Then
    Throw New Exception("Deleting the selected element in revit failed.")
End If

Dim prompt As String = "The selected element has been removed and "
prompt += deletedIdSet.Size - 1
prompt += " more dependent elements have also been removed."

' Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)

See Also

Document Class
Delete Overload
Autodesk.Revit Namespace

Delete Method (ElementIdSet)

[image]