Revit 2010 API
ControlledApplication..::.FileExported Event
ControlledApplication Class See Also Send Feedback
Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<FileExportedEventArgs> FileExported
Visual Basic (Declaration)
Public Event FileExported As EventHandler(Of FileExportedEventArgs)
Visual C++
public:
 event EventHandler<FileExportedEventArgs^>^ FileExported {
    void add (EventHandler<FileExportedEventArgs^>^ value);
    void remove (EventHandler<FileExportedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished exporting files of formats supported by the API. It is raised even when file exporting failed or was cancelled (during FileExporting event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not. If export is a part of ‘Publish to Buzzsaw’ command which consists of two parts – export of a document followed by publishing it to a BuzzSaw server, the event status only reflects the result of the Export action. The publishing part of the command could still be cancelled or could fail after FileExported event is raised.

This event is not cancellable, for the process of exporting file has already been finished.

If the Export action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace

FileExporting Event

[image]