Revit 2010 API
Profile..::.Transformed Property
Profile Class See Also Send Feedback
Transforms this profile and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Profile Transformed[
    Transform transform
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Transformed ( _
    transform As Transform _
) As Profile
Visual C++
public:
property Profile^ Transformed[Transform^ transform] {
    Profile^ get (Transform^ transform);
}

Parameters

transform
Type: Autodesk.Revit.Geometry..::.Transform
The transformation used to transform the profile.

Return Value

The transformed profile.

Remarks

Transforms all the curves that define the boundary of this profile.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the handle of the specified transformation is null.
System..::.InvalidOperationException | Thrown when failed to transform a curve in the profile.

See Also

Profile Class
Autodesk.Revit.Geometry Namespace

Reference Class

[image]