Revit 2010 API
Connector..::.DisconnectFrom Method
Connector Class See Also Send Feedback
Remove connection between two connectors.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void DisconnectFrom(
    Connector connector
)
Visual Basic (Declaration)
Public Sub DisconnectFrom ( _
    connector As Connector _
)
Visual C++
public:
void DisconnectFrom(
    Connector^ connector
)

Parameters

connector
Type: Autodesk.Revit.MEP..::.Connector
Indicate the connector, connection will be removed from.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when argument is null.
System..::.ArgumentException | Argument is invalid.
System..::.InvalidOperationException | Thrown when no connection between these two connector. Thrown on failure to remove the connection between these two connectors.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

IsConnectedTo Method

[image]