Revit 2010 API
View Properties
View Class See Also Send Feedback

The View type exposes the following members.

Properties

Name | Description
CanBePrinted | Test whether the view can be printed.
CropBox | The crop box applied to the view.
CropBoxActive | Whether or not the the Crop Box/Region is active for the view.
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view.
CutColorOverrideByElement | Override the cut lines' color by Element in this view.
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view.
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view.
Elements | Set of all elements that will be drawn in the view.
GenLevel | The level for the view.
Origin | Returns the origin of the screen.
Outline | The bounds of the view in paper space (in inches).
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
ProjColorOverrideByElement | Override the projection lines' color by Element in this view.
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view.
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view.
RightDirection | The direction towards the right side of the screen.
Scale | The scale of the view.
SketchPlane | The sketch plane assigned to the view for model curve creation.
UpDirection | The direction towards the top of the screen.
ViewDirection | The direction towards the viewer.
ViewName | The name of the view.
ViewType | The type of the view.

See Also

View Class
Autodesk.Revit.Elements Namespace

CanBePrinted Property

[image]