Revit 2010 API
Application..::.NewProjectTemplateDocument Method
Application Class See Also Send Feedback
New project template document

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Document NewProjectTemplateDocument(
    string templateFilename
)
Visual Basic (Declaration)
Public Overridable Function NewProjectTemplateDocument ( _
    templateFilename As String _
) As Document
Visual C++
public:
virtual Document^ NewProjectTemplateDocument(
    String^ templateFilename
)

Parameters

templateFilename
Type: System..::.String
The template file name.

Remarks

It is correspond to the File->New->Project....

Exceptions

Exception | Condition
System..::.ArgumentException | if 'templateFileName' is a null object or an empty string.
System..::.InvalidOperationException | if can not new a project template document.

See Also

Application Class
Autodesk.Revit Namespace

OpenDocumentFile Method

[image] [image]