Revit 2010 API
Document..::.NewRooms Method (List<(Of <(RoomCreationData>)>))
Document Class See Also Send Feedback
Creates new rooms using the specified placement data.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewRooms(
    List<RoomCreationData> dataList
)
Visual Basic (Declaration)
Public Function NewRooms ( _
    dataList As List(Of RoomCreationData) _
) As ElementSet
Visual C++
public:
ElementSet^ NewRooms(
    List<RoomCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::.List <(Of <( RoomCreationData >)>)
A list of RoomCreationData which wraps the creation arguments of the rooms to be created.

Return Value

If successful an ElementSet contains the rooms should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
System..::.ArgumentNullException | One or more of the RoomCreationData's level or point is null.
System..::.InvalidOperationException | The relevant room tag is not created successfully, or regeneration fails at the end of the batch creation.

See Also

Document Class
NewRooms Overload
Autodesk.Revit.Creation Namespace

NewRooms Method (Level, Phase)

[image]