Revit 2010 API
TemperatureRatingType..::.RemoveInsulationType Method
TemperatureRatingType Class See Also Send Feedback
Remove an existing insulation type from this temperature rating type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveInsulationType(
    InsulationType insulationType
)
Visual Basic (Declaration)
Public Sub RemoveInsulationType ( _
    insulationType As InsulationType _
)
Visual C++
public:
void RemoveInsulationType(
    InsulationType^ insulationType
)

Parameters

insulationType
Type: Autodesk.Revit.MEP..::.InsulationType
Insulation type to be removed.

Exceptions

Exception | Condition
System..::.InvalidOperationException | The last one insulation type of project and any one which is in use by a wire type can't be removed.

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace

RemoveWireSize Method

[image]