Revit 2010 API
CompoundStructureLayer Members
CompoundStructureLayer Class Constructors Methods Properties See Also Send Feedback

The CompoundStructureLayer type exposes the following members.

Constructors

Name | Description
CompoundStructureLayer | For Internal Use Only.

Methods

Name | Description

Properties

Name | Description
DeckProfile | Returns or set the family symbol of the deck profile of the layer within the structure.
DeckUsage | Returns usage of the deck layer within the structure.
Function | Returns the purpose/function of the layer within the structure.
Material | Get or set the material from which the layer is made.
Thickness | Retrieve or modify the thickness of the layer.
Variable | Returns or set whether the layer thickness is vrariable.

See Also

CompoundStructureLayer Class
Autodesk.Revit.Structural Namespace

CompoundStructureLayer Constructor

[image]