Revit 2010 API
LayoutRuleFixedNumber..::.NumberOfLines Property
LayoutRuleFixedNumber Class See Also Send Feedback
Get or set the number of the beams in a beam system.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int NumberOfLines { get; set; }
Visual Basic (Declaration)
Public Property NumberOfLines As Integer
Visual C++
public:
property int NumberOfLines {
    int get ();
    void set (int value);
}

Remarks

The number must be positive.

See Also

LayoutRuleFixedNumber Class
Autodesk.Revit.Elements Namespace

LayoutRuleMaximumSpacing Class

[image]