Revit 2010 API
XYZ Methods
XYZ Class See Also Send Feedback

The XYZ type exposes the following members.

Methods

Name | Description
Add | Adds the specified vector to this vector and returns the result.
AlmostEqual | Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).
Angle | Returns the angle between this vector and the specified vector.
AngleAround | Returns the angle between this vector and the specified vector projected to the specified plane.
Cross | The cross product of this vector and the specified vector.
Distance | Returns the distance from this point to the specified point.
Divide | Divides this vector by the specified value and returns the result.
Dot | The dot product of this vector and the specified vector.
Multiply | Multiplies this vector by the specified value and returns the result.
Negate | Negates this vector.
Subtract | Subtracts the specified vector from this vector and returns the result.
TripleProduct | The triple product of this vector and the two specified vectors.

Operators

Name | Description
Addition | Adds the two specified vectors and returns the result.
Division | Divides the specified vector by the specified value.
Multiply | Overloaded. Multiplies the specified number and the specified vector.
Subtraction | Subtracts the two specified vectors and returns the result.
UnaryNegation | Negates the specified vector and returns the result.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace

Add Method

[image]