Revit 2010 API
FamilyItemFactory..::.NewLoftForm Method
FamilyItemFactory Class See Also Send Feedback
Create new Form element by Loft operation, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Form NewLoftForm(
    bool isSolid,
    ReferenceArrayArray profiles
)
Visual Basic (Declaration)
Public Function NewLoftForm ( _
    isSolid As Boolean, _
    profiles As ReferenceArrayArray _
) As Form
Visual C++
public:
Form^ NewLoftForm(
    bool isSolid,
    ReferenceArrayArray^ profiles
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Form is Solid or Void.
profiles
Type: Autodesk.Revit.Geometry..::.ReferenceArrayArray
The profile set of the newly created loft. Each profile should consist of only one curve loop. The input profile must be in one plane.

Return Value

If creation was successful form is are returned.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace

NewModelText Method

[image]