Revit 2010 API
Document..::.LightingDeviceTypes Property
Document Class See Also Send Feedback
Returns an object that contains all of the avaible lighting device types currently loaded to this project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbolSet LightingDeviceTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property LightingDeviceTypes As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ LightingDeviceTypes {
    FamilySymbolSet^ get ();
}

Remarks

The LightingDeviceTypes property returns an object that contains the lighting device types which can be used to change the type of a lighting device from one type to another.

See Also

Document Class
Autodesk.Revit Namespace

LightingFixtureTypes Property

[image]