Revit 2010 API
Document..::.NewPathReinforcement Method
Document Class Example See Also Send Feedback
Creates a new instance of a Path Reinforcement element within the project

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PathReinforcement NewPathReinforcement(
    Element host,
    CurveArray curves,
    bool flip
)
Visual Basic (Declaration)
Public Function NewPathReinforcement ( _
    host As Element, _
    curves As CurveArray, _
    flip As Boolean _
) As PathReinforcement
Visual C++
public:
PathReinforcement^ NewPathReinforcement(
    Element^ host,
    CurveArray^ curves,
    bool flip
)

Parameters

host
Type: Autodesk.Revit..::.Element
The element to which the Path Reinforcement belongs. The element must be a structural floor or wall.
curves
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of curves forming a chain. Bars will be placed orthogonal to the chain with their hook ends near the chain, offset by the side cover setting. The curves must belong to the top face of the floor or the exterior face of the wall.
flip
Type: System..::.Boolean
A flag controlling the bars relative to the curves. If the curves are given in order and with consistent orientation, the bars will lie to the right of the chain if flip=false, to the left if flip=true, when viewed from above the floor or outside the wall.

Return Value

If successful, NewPathReinforcement returns an object for the newly created Rebar. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
PathReinforcement CreatePathReinforcement(Autodesk.Revit.Document document, Wall wall)
{
    // Create a geometry line in the selected wall as the path
    CurveArray curves = new CurveArray();
    LocationCurve location = wall.Location as LocationCurve;
    XYZ start = location.Curve.get_EndPoint(0);
    XYZ end = location.Curve.get_EndPoint(1);
    end.Z = end.Z;
    curves.Append(document.Application.Create.NewLineBound(start, end));

    // Begin to create the path reinforcement
    PathReinforcement rein = document.Create.NewPathReinforcement(wall, curves, true);
    if (null == rein)
    {
        throw new Exception("Create path reinforcement failed.");
    }

    // Give the user some information
    MessageBox.Show("Create path reinforcement succeed.", "Revit");

    return rein;
}
CopyVB.NET
Private Function CreatePathReinforcement(ByVal document As Autodesk.Revit.Document, ByVal wall As Wall) As PathReinforcement
    ' Create a geometry line in the selected wall as the path
    Dim curves As New CurveArray()
    Dim location As LocationCurve = TryCast(wall.Location, LocationCurve)
    Dim start As Autodesk.Revit.Geometry.XYZ = location.Curve.EndPoint(0)
    Dim [end] As Autodesk.Revit.Geometry.XYZ = location.Curve.EndPoint(1)
    [end].Z = [end].Z
    curves.Append(document.Application.Create.NewLineBound(start, [end]))

    ' Begin to create the path reinforcement
    Dim rein As PathReinforcement = document.Create.NewPathReinforcement(wall, curves, True)
    If rein Is Nothing Then
        Throw New Exception("Create path reinforcement failed.")
    End If

    ' Give the user some information
    MessageBox.Show("Create path reinforcement succeed.", "Revit")

    Return rein
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewPipe Method

[image] [image]