Revit 2010 API
Filter..::.NewCategoryFilter Method (Category)
Filter Class See Also Send Feedback
Creates a new category filter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CategoryFilter NewCategoryFilter(
    Category category
)
Visual Basic (Declaration)
Public Function NewCategoryFilter ( _
    category As Category _
) As CategoryFilter
Visual C++
public:
CategoryFilter^ NewCategoryFilter(
    Category^ category
)

Parameters

category
Type: Autodesk.Revit..::.Category
Filter elements by the category related to a category.

Return Value

Returns a new category filter object with given category.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter is invalid.

See Also

Filter Class
NewCategoryFilter Overload
Autodesk.Revit.Creation Namespace

NewFamilyFilter Method

[image]