Revit 2010 API
Application..::.NewColor Method
Application Class Example See Also Send Feedback
Returns a new color object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Color NewColor()
Visual Basic (Declaration)
Public Function NewColor As Color
Visual C++
public:
Color^ NewColor()

Return Value

The new color oject.

Examples

CopyC#
Color NewColorInfo(Autodesk.Revit.Creation.Application appCreation)
{
    // Create a new color
    Autodesk.Revit.Color color = appCreation.NewColor();

    // Set its RGB values
    color.Red = (byte)127;
    color.Green = (byte)64;
    color.Blue = (byte)32;

    // Display the color info
    StringBuilder info = new StringBuilder();
    info.AppendLine("Red:\t" + color.Red.ToString());
    info.AppendLine("Green:\t" + color.Green.ToString());
    info.AppendLine("Blue:\t" + color.Blue.ToString());

    MessageBox.Show(info.ToString(), "Color information");

    return color;
}
CopyVB.NET
Private Function NewColorInfo(ByVal appCreation As Autodesk.Revit.Creation.Application) As Color
    ' Create a new color
    Dim color As Autodesk.Revit.Color = appCreation.NewColor()

    ' Set its RGB values
    color.Red = CByte(127)
    color.Green = CByte(64)
    color.Blue = CByte(32)

    ' Display the color info
    Dim info As New StringBuilder()
    info.AppendLine("Red:" & vbTab & color.Red.ToString())
    info.AppendLine("Green:" & vbTab & color.Green.ToString())
    info.AppendLine("Blue:" & vbTab & color.Blue.ToString())

    MessageBox.Show(info.ToString(), "Color information")

    Return color
End Function

See Also

Application Class
Autodesk.Revit.Creation Namespace

NewCombinableElementArray Method

[image]