Revit 2010 API
Extrusion Members
Extrusion Class Constructors Methods Properties See Also Send Feedback

The Extrusion type exposes the following members.

Constructors

Name | Description
Extrusion | For Internal Use Only.

Methods

Name | Description

Properties

Name | Description
EndOffset | The offset of the end of the extrusion relative to the sketch plane.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Sketch | Returns the Sketch of the Extrusion.
StartOffset | The offset of the start of the extrusion relative to the sketch plane.

See Also

Extrusion Class
Autodesk.Revit.Elements Namespace

Extrusion Constructor

[image]