Revit 2010 API
Category..::.GetGraphicsStyle Method
Category Class See Also Send Feedback
Gets the graphics style associated with this category for the given graphics style type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GraphicsStyle GetGraphicsStyle(
    GraphicsStyleType graphicsStyleType
)
Visual Basic (Declaration)
Public Function GetGraphicsStyle ( _
    graphicsStyleType As GraphicsStyleType _
) As GraphicsStyle
Visual C++
public:
GraphicsStyle^ GetGraphicsStyle(
    GraphicsStyleType graphicsStyleType
)

Parameters

graphicsStyleType
Type: Autodesk.Revit.Elements..::.GraphicsStyleType
The type of graphics style.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the input argument-"graphicsStyleType"-is out of range.

See Also

Category Class
Autodesk.Revit Namespace

GetHashCode Method

[image]