Revit 2010 API
DividedSurface Members
DividedSurface Class Constructors Methods Properties See Also Send Feedback

The DividedSurface type exposes the following members.

Constructors

Name | Description
DividedSurface | Initializes a new instance of the DividedSurface class

Methods

Name | Description
GetGridNodeLocation | Specify whether a particular grid node is interior to the surface, on the boundary, or outside the boundary.
GetGridNodeReference | Get a reference to the geometric point associated with a grid node.
GetGridNodeUV | Get the position of a grid node in UV coordinates in the surface.
GetGridSegmentReference | Get a reference to a line segment connecting two adjacent grid nodes.
GetTileFamilyInstance | Get a reference to a tile element associated with a given seed node.
GetTileReference | Get a reference to one of the tile surfaces associated with a given seed node.
IsSeedNode | Reports whether a grid node is a "seed node," a node that is associated with one or more tiles.

Properties

Name | Description
AllGridRotation | Angle of rotation applied to the U- and V- directions together.
BorderTile | Determines the handling of tiles that overlap the surface's boundary.
ComponentRotation | The rotation of the pattern by a multiple of 90 degrees.
Host | The element whose surface has been divided.
HostReference | A reference to the divided face on the host.
IsComponentFlipped | Whether the pattern is flipped.
IsComponentMirrored | Whether the pattern is mirror-imaged.
NumberOfUGridlines | Get the number of U-gridlines used on the surface.
NumberOfVGridlines | Get the number of V-gridlines used on the surface.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
UPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the U-direction.
USpacingRule | Access to the rule for laying out the first series of equidistant parallel lines on the surface.
VPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the V-direction.
VSpacingRule | Access to the rule for laying out the second series of equidistant parallel lines on the surface.

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace

DividedSurface Constructor

[image]