Revit 2010 API
Filter..::.NewFamilyFilter Method
Filter Class See Also Send Feedback
Creates a FamilyFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyFilter NewFamilyFilter(
    string familyName
)
Visual Basic (Declaration)
Public Function NewFamilyFilter ( _
    familyName As String _
) As FamilyFilter
Visual C++
public:
FamilyFilter^ NewFamilyFilter(
    String^ familyName
)

Parameters

familyName
Type: System..::.String
Filter elements by the family name.

Return Value

Returns a new family filter object with given family.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the familyName is nullptr or empty.

See Also

Filter Class
Autodesk.Revit.Creation Namespace

NewInstanceUsageFilter Method

[image]