Revit 2010 API
SketchBase Class
Members See Also Send Feedback
Provides access to the SketchBase in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SketchBase : Element
Visual Basic (Declaration)
Public Class SketchBase _
    Inherits Element
Visual C++
public ref class SketchBase : public Element

Remarks

SketchBase is the base class of Sketch.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.SketchBase
Autodesk.Revit.Elements..::.Path3d
Autodesk.Revit.Elements..::.Sketch

See Also

SketchBase Members
Autodesk.Revit.Elements Namespace

SketchBase Members

[image] [image]