Revit 2010 API
FamilyInstance..::.Host Property
FamilyInstance Class See Also Send Feedback
If the instance is contained within another element, this property returns the containing element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element Host { get; }
Visual Basic (Declaration)
Public ReadOnly Property Host As Element
Visual C++
public:
property Element^ Host {
    Element^ get ();
}

Remarks

An example of an instance that is contained is a window. In this case the host property would return the wall in which the window is contained.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace

IsSlantedColumn Property

[image]