Revit 2010 API
Application..::.NewGeometryOptions Method
Application Class Example See Also Send Feedback
Creates an object to specify user preferences in parsing of geometry.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Options NewGeometryOptions()
Visual Basic (Declaration)
Public Function NewGeometryOptions As Options
Visual C++
public:
Options^ NewGeometryOptions()

Return Value

Examples

CopyC#
Autodesk.Revit.Geometry.Options geomOption = application.Create.NewGeometryOptions();
if (null != geomOption)
{
    geomOption.ComputeReferences = true;
    geomOption.DetailLevel = Autodesk.Revit.Geometry.Options.DetailLevels.Fine;

    // Either the DetailLevel or the View can be set, but not both
    //geomOption.View = commandData.Application.ActiveDocument.ActiveView;

    MessageBox.Show("Geometry Option created successfully.", "Revit");
}
CopyVB.NET
Dim geomOption As Autodesk.Revit.Geometry.Options = application.Create.NewGeometryOptions()
If geomOption IsNot Nothing Then
    geomOption.ComputeReferences = True
    geomOption.DetailLevel = Autodesk.Revit.Geometry.Options.DetailLevels.Fine

    ' Either the DetailLevel or the View can be set, but not both
    'geomOption.View = commandData.Application.ActiveDocument.ActiveView;

    MessageBox.Show("Geometry Option created successfully.", "Revit")
End If

See Also

Application Class
Autodesk.Revit.Creation Namespace

NewHermiteSpline Method

[image]