Revit 2010 API
Connector..::.AssignedLossCoefficient Property
Connector Class See Also Send Feedback
The assigned loss coefficient of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double AssignedLossCoefficient { get; set; }
Visual Basic (Declaration)
Public Property AssignedLossCoefficient As Double
Visual C++
public:
property double AssignedLossCoefficient {
    double get ();
    void set (double value);
}

Remarks

Assigned loss coefficient may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::DuctConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainHvac. Thrown when the connector is not in a family instance.
System..::.ArgumentException | Thrown when set an invalid value.
System..::.InvalidOperationException | Thrown on failure to get or set assigned loss coefficient.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

AssignedPipeFlowConfiguration Property

[image]