Revit 2010 API
PushButton..::.ClassName Property
PushButton Class See Also Send Feedback
The name of the class containing the implementation for the command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string ClassName { get; set; }
Visual Basic (Declaration)
Public Property ClassName As String
Visual C++
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}

Remarks

The class name which implements the interface IExternalCommand.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when setting the value to null.
System..::.ArgumentException | Thrown when setting the value to an empty string.

See Also

PushButton Class
Autodesk.Revit Namespace

Image Property

[image]