Revit 2010 API
FamilyItemFactory..::.NewArcLengthDimension Method (View, Arc, Reference, Reference, Reference, DimensionType)
FamilyItemFactory Class See Also Send Feedback
Creates a new arc length dimension object using the specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Dimension NewArcLengthDimension(
    View view,
    Arc arc,
    Reference arcRef,
    Reference firstRef,
    Reference secondRef,
    DimensionType dimensionType
)
Visual Basic (Declaration)
Public Function NewArcLengthDimension ( _
    view As View, _
    arc As Arc, _
    arcRef As Reference, _
    firstRef As Reference, _
    secondRef As Reference, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewArcLengthDimension(
    View^ view,
    Arc^ arc,
    Reference^ arcRef,
    Reference^ firstRef,
    Reference^ secondRef,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the dimension is to be visible.
arc
Type: Autodesk.Revit.Geometry..::.Arc
The extension arc of the dimension.
arcRef
Type: Autodesk.Revit.Geometry..::.Reference
Geometric reference of the arc to which the dimension is to be bound. This reference must be parallel to the extension arc.
firstRef
Type: Autodesk.Revit.Geometry..::.Reference
The first geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
secondRef
Type: Autodesk.Revit.Geometry..::.Reference
The second geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
dimensionType
Type: Autodesk.Revit.Symbols..::.DimensionType
The dimension style to be used for the dimension.

Return Value

If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when any input argument is null.
System..::.ArgumentException | Thrown when the argument arcRef/ref1/ref2/dimensionType is invalid.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewArcLengthDimension Overload
Autodesk.Revit.Creation Namespace

NewBlend Method

[image]