Revit 2010 API
Rebar Members
Rebar Class Constructors Methods Properties See Also Send Feedback

The Rebar type exposes the following members.

Constructors

Name | Description
Rebar | For Internal Use Only.

Methods

Name | Description
ScaleToBox | Move and resize the bar to fit within a specified box.
SetLayoutRuleWithoutExaminingHost | Change the parameter REBAR_ELEM_LAYOUT_RULE, but extend the set in the direction of the plane's normal, instead of towards the center of the host.

Properties

Name | Description
ArrayLength | For Rebar with an array layout, return the length of the distribution path.
BarType | Return the type of the rebar.
Curves | The centerline of the Rebar.
DistributionPath | For Rebar with an array layout, return the distribution path (a line).
Host | The element that contains the rebar.
IsShownInFrontOfGeometryInView | Control placement of the rebar graphics in the viewing planes.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
RebarShape | Get/Set the RebarShape associated with the Rebar.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace

Rebar Constructor

[image]