Revit 2010 API
MEPSpaceConstruction..::.DuplicateConstruction Method
MEPSpaceConstruction Class See Also Send Feedback
Create a new construction for Space constructions.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MEPBuildingConstruction DuplicateConstruction(
    MEPBuildingConstruction pCurrentConstruction,
    string pName
)
Visual Basic (Declaration)
Public Function DuplicateConstruction ( _
    pCurrentConstruction As MEPBuildingConstruction, _
    pName As String _
) As MEPBuildingConstruction
Visual C++
public:
MEPBuildingConstruction^ DuplicateConstruction(
    MEPBuildingConstruction^ pCurrentConstruction,
    String^ pName
)

Parameters

pCurrentConstruction
Type: Autodesk.Revit.Symbols..::.MEPBuildingConstruction
The existing construction to be duplicated.
pName
Type: System..::.String
The name of the new construction.

Remarks

If the name is same with the existing one, an exception will be thrown.

See Also

MEPSpaceConstruction Class
Autodesk.Revit Namespace

NewConstruction Method

[image]