Revit 2010 API
RebarShapeDefinitionByArc Class
Members See Also Send Feedback
Definition of a shape whose size and position can determined by a single arc.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RebarShapeDefinitionByArc : RebarShapeDefinition
Visual Basic (Declaration)
Public Class RebarShapeDefinitionByArc _
    Inherits RebarShapeDefinition
Visual C++
public ref class RebarShapeDefinitionByArc : public RebarShapeDefinition

Remarks

In this shape definition, all dimensions are allowed to be driving dimensions.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.RebarShapeDefinition
Autodesk.Revit.Symbols..::.RebarShapeDefinitionByArc

See Also

RebarShapeDefinitionByArc Members
Autodesk.Revit.Symbols Namespace

RebarShapeDefinitionByArc Members

[image] [image]