Revit 2010 API
ElectricalSetting..::.RemoveDistributionSysType Method
ElectricalSetting Class See Also Send Feedback
Remove an existing distribution system type from the project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveDistributionSysType(
    DistributionSysType distributionSysType
)
Visual Basic (Declaration)
Public Sub RemoveDistributionSysType ( _
    distributionSysType As DistributionSysType _
)
Visual C++
public:
void RemoveDistributionSysType(
    DistributionSysType^ distributionSysType
)

Parameters

distributionSysType
Type: Autodesk.Revit.MEP..::.DistributionSysType

Exceptions

Exception | Condition
System..::.InvalidOperationException | Distribution system type can be removed only if it is not currently assigned to any devices, otherwise an exception will be thrown.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace

RemoveVoltageType Method

[image]