Revit 2010 API
RebarBarType..::.HookPermission Property
RebarBarType Class See Also Send Feedback
Access to permission data in the hook lengths map.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool HookPermission[
    RebarHookType hookType
] { get; set; }
Visual Basic (Declaration)
Public Property HookPermission ( _
    hookType As RebarHookType _
) As Boolean
Visual C++
public:
property bool HookPermission[RebarHookType^ hookType] {
    bool get (RebarHookType^ hookType);
    void set (RebarHookType^ hookType, bool value);
}

Parameters

hookType
Type: Autodesk.Revit.Symbols..::.RebarHookType
A hook type in the same document as this bar type.

Remarks

This determines whether the hooks may be used with this bar type.

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace

Parameter Property

[image] [image]