Revit 2010 API
FamilyInstance..::.AddCoping Method
FamilyInstance Class See Also Send Feedback
Adds a coping (cut) to a steel beam.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool AddCoping(
    FamilyInstance cutter
)
Visual Basic (Declaration)
Public Function AddCoping ( _
    cutter As FamilyInstance _
) As Boolean
Visual C++
public:
bool AddCoping(
    FamilyInstance^ cutter
)

Parameters

cutter
Type: Autodesk.Revit.Elements..::.FamilyInstance
A steel beam or column. May not be null or itself.

Remarks

This beam will be cut to fit another element, the cutter. The cut will include an offset determined by the parameter STRUCTURAL_COPING_DISTANCE. The parameter affects all copings on this element. This function corresponds to Tools -> Coping in Revit Structure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when 'cutter' is null.
System..::.ArgumentException | Thrown when 'cutter' refers to this instance.
System..::.InvalidOperationException | Thrown when regeneration fails.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace

flipFacing Method

[image]