Revit 2010 API
Truss Members
Truss Class Constructors Methods Properties See Also Send Feedback

The Truss type exposes the following members.

Constructors

Name | Description
Truss | For Internal Use Only.

Methods

Name | Description
AttachTopChord | Attach truss's top to a specified element,the element should be a roof or floor.
DetachTopChord | Detach the truss's top from a specified element.
GetTrussMemberInfo | Query if a given element is a member of a truss,its lock status and its usage,etc.
RemoveProfile | Remove the profile of a truss.
SetProfile | Add or modify the profile of a truss.
TogglePinMember | Pin/Unpin a truss member.

Properties

Name | Description
Curves | Get all the truss curves.
Members | Get all the members of truss.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
TrussType | Retrieve/set an object that represents the type of the truss.

See Also

Truss Class
Autodesk.Revit.Elements Namespace

Truss Constructor

[image]