Revit 2010 API
CurveByPoints..::.SetPoints Method
CurveByPoints Class See Also Send Feedback
Change the sequence of points interpolated by this curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetPoints(
    ReferencePointArray points
)
Visual Basic (Declaration)
Public Sub SetPoints ( _
    points As ReferencePointArray _
)
Visual C++
public:
void SetPoints(
    ReferencePointArray^ points
)

Parameters

points
Type: Autodesk.Revit.Elements..::.ReferencePointArray
An array of 2 or more ReferencePoints.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the array contains fewer than 2 points, when the array contains duplicates, or when adjacent points are located too close together.

See Also

CurveByPoints Class
Autodesk.Revit.Elements Namespace

SetVisibility Method

[image]