Revit 2010 API
Application..::.NewPlane Method (XYZ, XYZ, XYZ)
Application Class See Also Send Feedback
Creates a new geometric plane object based on two coordinate vectors and an origin.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Plane NewPlane(
    XYZ xVec,
    XYZ yVec,
    XYZ origin
)
Visual Basic (Declaration)
Public Function NewPlane ( _
    xVec As XYZ, _
    yVec As XYZ, _
    origin As XYZ _
) As Plane
Visual C++
public:
Plane^ NewPlane(
    XYZ^ xVec,
    XYZ^ yVec,
    XYZ^ origin
)

Parameters

xVec
Type: Autodesk.Revit.Geometry..::.XYZ
X vector of the plane coordinate system.
yVec
Type: Autodesk.Revit.Geometry..::.XYZ
Y vector of the plane coordinate system.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
Origin of the plane coordinate system.

Return Value

Returns a new plane object.

See Also

Application Class
NewPlane Overload
Autodesk.Revit.Creation Namespace

NewPoint Method

[image]