Revit 2010 API
DemandFactor..::.SetPercentageToInfinity Method
DemandFactor Class See Also Send Feedback
This method is used to set percentage value for the range in [MinFactor, PositiveInfinity) specially.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetPercentageToInfinity(
    long minFactor,
    double percentage
)
Visual Basic (Declaration)
Public Sub SetPercentageToInfinity ( _
    minFactor As Long, _
    percentage As Double _
)
Visual C++
public:
void SetPercentageToInfinity(
    long long minFactor,
    double percentage
)

Parameters

minFactor
Type: System..::.Int64
Lower boundary of the range.
percentage
Type: System..::.Double
Percentage value of this range.

Remarks

Demand factor data items have been obsolete after this operation, so they should be retrieved again before using.

Exceptions

Exception | Condition
System..::.ArgumentException | Both parameters can't be negative or positive infinity, otherwise the exception will be thrown.

See Also

DemandFactor Class
Autodesk.Revit.MEP Namespace

DemandFactor Properties

[image] [image]