Revit 2010 API
IFamilyLoadOptions..::.OnSharedFamilyFound Method
IFamilyLoadOptions Interface See Also Send Feedback
This is the method called when the shared family was found in the target document already.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
bool OnSharedFamilyFound(
    Family sharedFamily,
    bool familyInUse,
    ref FamilySource source,
    ref bool overwriteParameterValues
)
Visual Basic (Declaration)
Function OnSharedFamilyFound ( _
    sharedFamily As Family, _
    familyInUse As Boolean, _
    ByRef source As FamilySource, _
    ByRef overwriteParameterValues As Boolean _
) As Boolean
Visual C++
bool OnSharedFamilyFound(
    Family^ sharedFamily,
    bool familyInUse,
    FamilySource% source,
    bool% overwriteParameterValues
)

Parameters

sharedFamily
Type: Autodesk.Revit.Elements..::.Family
The shared family in the current family document.
familyInUse
Type: System..::.Boolean
Indicates if at least one instance of the family is placed in the project or not.
source
Type: Autodesk.Revit..::.FamilySource %
This is an output enum argument which indicates if the family will load from the project or the current family.
overwriteParameterValues
Type: System..::.Boolean %
This is an output boolean argument which indicates if overwrite the parameter values of existing types.

Return Value

Return true to continue loading the family, false to cancel.

See Also

IFamilyLoadOptions Interface
Autodesk.Revit Namespace

ImageImportOptions Class

[image]