Revit 2010 API
FootPrintRoof Class
Members See Also Send Feedback
Represents kinds of FootPrintRoofs.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FootPrintRoof : RoofBase
Visual Basic (Declaration)
Public Class FootPrintRoof _
    Inherits RoofBase
Visual C++
public ref class FootPrintRoof : public RoofBase

Remarks

The FootPrintRoof object represents some kinds of FootPrintRoof in Revit. The RoofType property is used to distinguish the type of the roof. The FootPrintRoof object is derived from the HostObject object and hence it supports all the properties and methods of that object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.RoofBase
Autodesk.Revit.Elements..::.FootPrintRoof

See Also

FootPrintRoof Members
Autodesk.Revit.Elements Namespace

FootPrintRoof Members

[image] [image]