Revit 2010 API
Application..::.DialogBoxShowing Event
Application Class See Also Send Feedback
Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DialogBoxShowingEventArgs> DialogBoxShowing
Visual Basic (Declaration)
Public Event DialogBoxShowing As EventHandler(Of DialogBoxShowingEventArgs)
Visual C++
public:
 event EventHandler<DialogBoxShowingEventArgs^>^ DialogBoxShowing {
    void add (EventHandler<DialogBoxShowingEventArgs^>^ value);
    void remove (EventHandler<DialogBoxShowingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to show a dialog box or a message box.

Event is not cancellable. The 'Cancellable' property of event’s argument is always 'false'.

Depending on the type of the dialog that is being shown, the event's argument's type varies as follows: When it is a dialog box, the event’s argument is an object of DialogBoxShowingEventArgs. When it is a message box, the event’s argument is an object of MessageBoxShowingEventArgs,which is subclass of DialogBoxShowingEventArgs. When it is a task dialog, the event’s argument is an object of TaskDialogShowingEventArgs,which is subclass of DialogBoxShowingEventArgs.

No document may be modified during this event.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

The DialogBoxShowing event is meant to replace the older OnDialogBox event, which is now Obsolete.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace

DocumentClosed Event

[image]