Revit 2010 API
Application..::.NewPlane Method (CurveArray)
Application Class See Also Send Feedback
Creates a new geometric plane from a loop of planar curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Plane NewPlane(
    CurveArray curveloop
)
Visual Basic (Declaration)
Public Function NewPlane ( _
    curveloop As CurveArray _
) As Plane
Visual C++
public:
Plane^ NewPlane(
    CurveArray^ curveloop
)

Parameters

curveloop
Type: Autodesk.Revit.Geometry..::.CurveArray
The closed loop of planar curves to locate plane.

Return Value

If successful a new geometric plane will be returned. Otherwise null pointer.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the input curve loop is null or empty.
System..::.ArgumentException | Thrown when the input curve loop does not lie in a plane.
System..::.ArgumentException | Thrown when the input curve loop is not closed.

See Also

Application Class
NewPlane Overload
Autodesk.Revit.Creation Namespace

NewPlane Method (XYZ, XYZ)

[image]