Revit 2010 API
FamilyInstance Class
Members Example See Also Send Feedback
This object represents a single instance of a family type, such as a single I beam.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FamilyInstance : InsertableInstance
Visual Basic (Declaration)
Public Class FamilyInstance _
    Inherits InsertableInstance
Visual C++
public ref class FamilyInstance : public InsertableInstance

Remarks

Examples of FamilyInstance objects within Autodesk Revit are Beams, Columns, Braces and Desks. The FamilyInstance object provides more detailed properties that enable the type of the family instance to be changed, thus changing their appearance within the project.

Examples

CopyC#
public void GetInfo_FamilyInstance(FamilyInstance familyInstance)
{
    string message = "FamilyInstance : ";
    // Get FamilyInstance AnalyticalModel type
    if (null != familyInstance.AnalyticalModel)
    {
        message += "\nFamilyInstance AnalyticalModel is : " + familyInstance.AnalyticalModel;
    }

    // Get FamilyInstance host name
    if (familyInstance.Host != null)
    {
        message += "\nFamilyInstance host name is : " + familyInstance.Host.Name;
    }

    // Get FamilyInstance Material
    message += "\nFamilyInstance Material is : " + familyInstance.Material;

    // Get FamilyInstance room name
    if (familyInstance.Room != null)
    {
        message += "\nFamilyInstance room name is : " + familyInstance.Room.Name;
    }

    // Get FamilyInstance structural type
    message += "\nFamilyInstance structural type is : " + familyInstance.StructuralType;

    // Get FamilyInstance structural usage
    message += "\nFamilyInstance structural usage is : " + familyInstance.StructuralUsage;

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_FamilyInstance(ByVal familyInstance As Autodesk.Revit.Elements.FamilyInstance)
    Dim message As String = "FamilyInstance : "
    ' Get FamilyInstance AnalyticalModel type
    If familyInstance.AnalyticalModel IsNot Nothing Then
        message += vbLf & "FamilyInstance AnalyticalModel is : " & familyInstance.AnalyticalModel.ToString
    End If

    ' Get FamilyInstance host name
    If familyInstance.Host IsNot Nothing Then
        message += vbLf & "FamilyInstance host name is : " & familyInstance.Host.Name
    End If

    ' Get FamilyInstance Material
    message += vbLf & "FamilyInstance Material is : " & familyInstance.Material

    ' Get FamilyInstance room name
    If familyInstance.Room IsNot Nothing Then
        message += vbLf & "FamilyInstance room name is : " & familyInstance.Room.Name
    End If

    ' Get FamilyInstance structural type
    message += vbLf & "FamilyInstance structural type is : " & familyInstance.StructuralType

    ' Get FamilyInstance structural usage
    message += vbLf & "FamilyInstance structural usage is : " & familyInstance.StructuralUsage

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Instance
Autodesk.Revit.Elements..::.InsertableInstance
Autodesk.Revit.Elements..::.FamilyInstance

See Also

FamilyInstance Members
Autodesk.Revit.Elements Namespace

FamilyInstance Members

[image] [image]