Revit 2010 API
Connector..::.Height Property
Connector Class See Also Send Feedback
The height of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual double Height { get; set; }
Visual Basic (Declaration)
Public Overridable Property Height As Double
Visual C++
public:
virtual property double Height {
    double get ();
    void set (double value);
}

Implements

IConnector..::.Height

Remarks

In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's shape is not rectangular.
System..::.ArgumentException | Thrown when the argument is invalid.
System..::.InvalidOperationException | Thrown on failure to set height.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

IsConnected Property

[image]