Revit 2010 API
DuctSystemType Enumeration
See Also Send Feedback
An enumerate type listing all the possible Duct System Types for a Duct Connector object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum DuctSystemType
Visual Basic (Declaration)
Public Enumeration DuctSystemType
Visual C++
public enum class DuctSystemType

Members

Member name | Description
Fitting | Duct System Type is Fitting.
OtherAir | Duct System Type is OtherAir.
ExhaustAir | Duct System Type is ExhaustAir.
ReturnAir | Duct System Type is ReturnAir.
SupplyAir | Duct System Type is SupplyAir.
UndefinedSystemType | Undefined system type
Global | Duct System Type is Global.

See Also

Autodesk.Revit.MEP.Enums Namespace

ElectricalPhase Enumeration

[image]