Revit 2010 API
BuildingType Enumeration
See Also Send Feedback
An enumerated type listing all of the built-in building types supported by Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum BuildingType
Visual Basic (Declaration)
Public Enumeration BuildingType
Visual C++
public enum class BuildingType

Members

Member name | Description
kWorkshop | Building Type is Workshop.
kWarehouse | Building Type is Warehouse.
kTransportation | Building Type is Transportation.
kTownHall | Building Type is TownHall.
kSportsArena | Building Type is SportsArena.
kSchoolOrUniversity | Building Type is SchoolOrUniversity.
kRetail | Building Type is Retail.
kReligiousBuilding | Building Type is ReligiousBuilding.
kPostOffice | Building Type is PostOffice.
kPoliceStation | Building Type is PoliceStation.
kPerformingArtsTheater | Building Type is PerformingArtsTheater.
kPenitentiary | Building Type is Penitentiary.
kParkingGarage | Building Type is ParkingGarage.
kOffice | Building Type is Office.
kMuseum | Building Type is Museum.
kMultiFamily | Building Type is MultiFamily.
kMotionPictureTheatre | Building Type is MotionPictureTheatre.
kMotel | Building Type is Motel.
kManufacturing | Building Type is Manufacturing.
kLibrary | Building Type is Library.
kHotel | Building Type is Hotel.
kHospitalOrHealthcare | Building Type is HospitalOrHealthcare.
kGymnasium | Building Type is Gymnasium.
kFireStation | Building Type is FireStation.
kExerciseCenter | Building Type is ExerciseCenter.
kDormitory | Building Type is Dormitory.
kDiningFamily | Building Type is DiningFamily.
kDiningCafeteriaFastFood | Building Type is DiningCafeteriaFastFood.
kDiningBarLoungeOrLeisure | Building Type is DiningBarLoungeOrLeisure.
kCourthouse | Building Type is Courthouse.
kConventionCenter | Building Type is ConventionCenter.
kAutomotiveFacility | Building Type is AutomotiveFacility.
kNoOfBuildingTypes | Building Type is NoOfBuildingTypes.

See Also

Autodesk.Revit.Parameters Namespace

BuiltInParameter Enumeration

[image]