Revit 2010 API
ParameterMap..::.Erase Method
ParameterMap Class See Also Send Feedback
Removes a object with the specified key from the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int Erase(
    string key
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    key As String _
) As Integer
Visual C++
public:
virtual int Erase(
    String^ key
)

Parameters

key
Type: System..::.String
The key of the item to be erased.

Return Value

The number of items that were erased from the map.

See Also

ParameterMap Class
Autodesk.Revit Namespace

ForwardIterator Method

[image]