Revit 2010 API
Application..::.NewSelElementSet Method
Application Class See Also Send Feedback
Creates a new instance of a set specifically for holding selected elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SelElementSet NewSelElementSet()
Visual Basic (Declaration)
Public Function NewSelElementSet As SelElementSet
Visual C++
public:
SelElementSet^ NewSelElementSet()

Return Value

Returns a new Element Set.

Remarks

If the user wants to change the selected Element with the API, the instance SelElementSet must be created to do the operation of Add and Remove.

See Also

Application Class
Autodesk.Revit.Creation Namespace

NewSet Method

[image]