Revit 2010 API
Document..::.NewFlexPipe Method (XYZArray, FlexPipeType)
Document Class See Also Send Feedback
Adds a new flex pipe into the document, using a point array and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlexPipe NewFlexPipe(
    XYZArray points,
    FlexPipeType pipeType
)
Visual Basic (Declaration)
Public Function NewFlexPipe ( _
    points As XYZArray, _
    pipeType As FlexPipeType _
) As FlexPipe
Visual C++
public:
FlexPipe^ NewFlexPipe(
    XYZArray^ points,
    FlexPipeType^ pipeType
)

Parameters

points
Type: Autodesk.Revit.Geometry..::.XYZArray
The point array indicating the path of the flex pipe, including the end points.
pipeType
Type: Autodesk.Revit.MEP..::.FlexPipeType
The type of the flex pipe.

Return Value

If creation was successful then a new flex pipe is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument points is null.
System..::.InvalidOperationException | Thrown when the flex pipe cannot be created or regenerate fails.

See Also

Document Class
NewFlexPipe Overload
Autodesk.Revit.Creation Namespace

NewFlexPipe Method (Connector, XYZArray, FlexPipeType)

[image]