Revit 2010 API
PointOnPlane..::.IsValidPlaneReference Method
PointOnPlane Class See Also Send Feedback
Check whether a geometry reference corresponds to a referenceable plane.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static bool IsValidPlaneReference(
    Document doc,
    Reference planeReference
)
Visual Basic (Declaration)
Public Shared Function IsValidPlaneReference ( _
    doc As Document, _
    planeReference As Reference _
) As Boolean
Visual C++
public:
static bool IsValidPlaneReference(
    Document^ doc,
    Reference^ planeReference
)

Parameters

doc
Type: Autodesk.Revit..::.Document
planeReference
Type: Autodesk.Revit.Geometry..::.Reference

Remarks

Valid plane references include: planar faces of solids; the PlaneReference properties of Level and SketchPlane; the Reference property of ReferencePlane.

See Also

PointOnPlane Class
Autodesk.Revit.Elements Namespace

NewPointOnPlane Method

[image]