Revit 2010 API
RoofType Class
Members See Also Send Feedback
Represents a specific type of roof.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RoofType : HostObjAttributes
Visual Basic (Declaration)
Public Class RoofType _
    Inherits HostObjAttributes
Visual C++
public ref class RoofType : public HostObjAttributes

Remarks

All roof type objects available in the project can be retrieved from the Document object via the RoofTypes property. Every Roof object has a RoofType property that returns a RoofType object representing the type. This same RoofType property can also be used to change the type of the roof by setting it to a different type.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.HostObjAttributes
Autodesk.Revit.Symbols..::.RoofType

See Also

RoofType Members
Autodesk.Revit.Symbols Namespace

RoofType Members

[image] [image]