Revit 2010 API
Document..::.NewFamilyInstance Method (XYZ, FamilySymbol, Level, StructuralType)
Document Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol and a base level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.Elements..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise Nothing.

Remarks

This method is used to add a family instance that doesn't require a host element, but that can be associated to a level. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

All levels within the document can be found by iterating over the entire document and searching for objects of type Autodesk.Revit.Elements.Level.

Some families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Examples

CopyC#
FamilyInstance CreateColumn(Autodesk.Revit.Document document, Level level)
{
    // Get a Column type from revit
    FamilySymbol columnType = null;
    ElementIterator iter = document.get_Elements(typeof(FamilySymbol));;
    iter.Reset();
    while (iter.MoveNext())
    {
        columnType = iter.Current as FamilySymbol;
        if (null != columnType && null != columnType.Category)
        {
            if ("Structural Columns" == columnType.Category.Name)
            {
                break;
            }
        }
    }

    FamilyInstance instance;
    if (null != columnType)
    {
        // Create a column at the origin
        XYZ origin = new XYZ(0, 0, 0);

        instance = document.Create.NewFamilyInstance(origin, columnType, level,
                                                      StructuralType.Column);
    }
    else
    {
        throw new Exception("No column types found.");
    }

    return instance;
}
CopyVB.NET
Private Function CreateColumn(ByVal document As Autodesk.Revit.Document, ByVal level As Autodesk.Revit.Elements.Level) As Autodesk.Revit.Elements.FamilyInstance
    ' Get a Column type from revit
    Dim columnType As Autodesk.Revit.Symbols.FamilySymbol = Nothing
    Dim iter As ElementIterator = document.Elements(GetType(Autodesk.Revit.Symbols.FamilySymbol))

    iter.Reset()
    While iter.MoveNext()
        columnType = TryCast(iter.Current, Autodesk.Revit.Symbols.FamilySymbol)
        If columnType IsNot Nothing AndAlso columnType.Category IsNot Nothing Then
            If "Structural Columns" = columnType.Category.Name Then
                Exit While
            End If
        End If
    End While

    Dim instance As Autodesk.Revit.Elements.FamilyInstance
    If columnType IsNot Nothing Then
        ' Create a column at the origin
        Dim origin As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)

        instance = document.Create.NewFamilyInstance(origin, columnType, level, StructuralType.Column)
    Else
        Throw New Exception("No column types found.")
    End If

    Return instance
End Function

See Also

Document Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace

NewFamilyInstance Method (XYZ, FamilySymbol, Element, Level, StructuralType)

[image]