Revit 2010 API
ImportInstance..::.SetVisibility Method
ImportInstance Class See Also Send Feedback
Sets the visibility for the import instance in a family document.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic (Declaration)
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit..::.FamilyElementVisibility

Remarks

The visibility of the import instance geometry can be changed for different types of views and detail levels in the family document.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when visibility is null.
System..::.InvalidOperationException | Thrown when regeneration failed, or the import instance is in a project document.

See Also

ImportInstance Class
Autodesk.Revit.Elements Namespace

ImportInstance Properties

[image] [image]