Revit 2010 API
Filter..::.NewWallUsageFilter Method
Filter Class See Also Send Feedback
Creates a new WallUsageFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WallUsageFilter NewWallUsageFilter(
    WallUsage wallUsage
)
Visual Basic (Declaration)
Public Function NewWallUsageFilter ( _
    wallUsage As WallUsage _
) As WallUsageFilter
Visual C++
public:
WallUsageFilter^ NewWallUsageFilter(
    WallUsage wallUsage
)

Parameters

wallUsage
Type: Autodesk.Revit.Structural.Enums..::.WallUsage
Filter elements by the wall usage.

Return Value

Returns a new wall usage filter object with given wall usage.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace

Filter Properties

[image] [image]