Revit 2010 API
Document..::.NewZone Method
Document Class See Also Send Feedback
Creates a new Zone element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Zone NewZone(
    Level level,
    Phase phase
)
Visual Basic (Declaration)
Public Function NewZone ( _
    level As Level, _
    phase As Phase _
) As Zone
Visual C++
public:
Zone^ NewZone(
    Level^ level,
    Phase^ phase
)

Parameters

level
Type: Autodesk.Revit.Elements..::.Level
The level on which the Zone is to exist.
phase
Type: Autodesk.Revit.Elements..::.Phase
The associative phase on which the Zone is to exist.

Return Value

If successful a new Zone element within the project, otherwise Nothing.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter Value is null.
System..::.InvalidOperationException | Thrown when the electrical system cannot be created by these input phase and level.

See Also

Document Class
Autodesk.Revit.Creation Namespace

Document Properties

[image] [image]