Revit 2010 API
ParameterStorage Members
ParameterStorage Class Constructors Methods Properties See Also Send Feedback

The ParameterStorage type exposes the following members.

Constructors

Name | Description
ParameterStorage | For Internal Use Only.

Methods

Name | Description
AsDouble | Provides access to the double precision number within the parameter.
AsElementId | Provides access to the ElementId stored within the parameter.
AsInteger | Provides access to the integer number within the parameter.
AsString | Provides access to the string contents of the parameter.
Set | Overloaded. Sets the parameter.

Properties

Name | Description
IsReadOnly | (Overrides APIObject..::.IsReadOnly.)
StorageType | Describes the type that contains parameter's value.

See Also

ParameterStorage Class
Autodesk.Revit Namespace

ParameterStorage Constructor

[image]