Revit 2010 API
XYZ..::.Subtraction Operator
XYZ Class See Also Send Feedback
Subtracts the two specified vectors and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static XYZ operator -(
    XYZ left,
    XYZ right
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    left As XYZ, _
    right As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator -(
    XYZ^ left,
    XYZ^ right
)

Parameters

left
Type: Autodesk.Revit.Geometry..::.XYZ
The first vector.
right
Type: Autodesk.Revit.Geometry..::.XYZ
The second vector.

Return Value

The vector equal to the difference between the two source vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the right vector from the corresponding coordinate of the left vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace

TripleProduct Method

[image]