Revit 2010 API
RebarShapeDefinitionByArc Methods
RebarShapeDefinitionByArc Class See Also Send Feedback

The RebarShapeDefinitionByArc type exposes the following members.

Methods

Name | Description
AddConstraintArcLength | Specify a parameter to drive the arc length of the shape.
AddConstraintChordLength | Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).
AddConstraintCircumference | Specify a parameter to drive the circumference of the shape.
AddConstraintDiameter | Specify a parameter to drive the diameter of the shape.
AddConstraintRadius | Specify a parameter to drive the radius of the shape.
AddConstraintSagittaLength | Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace

AddConstraintArcLength Method

[image]