Revit 2010 API
Document..::.OnSaveAs Event
Document Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentSavingAs event instead. Subscribe to the OnSaveAs event to be notified before the current document is saved as a file with another name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSavingAs event instead.")]
public event DocumentSaveAsEventHandler OnSaveAs
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSavingAs event instead.")> _
Public Event OnSaveAs As DocumentSaveAsEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentSavingAs event instead.")]
public:
 event DocumentSaveAsEventHandler^ OnSaveAs {
    void add (DocumentSaveAsEventHandler^ value);
    void remove (DocumentSaveAsEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document will be saved as a file with another name. By subscribing to this event the application will be notified before such an event and can perform an action in response.

See Also

Document Class
Autodesk.Revit Namespace

ViewPrinted Event

[image]