Revit 2010 API
WireMaterialType..::.RemoveTemperatureRatingType Method
WireMaterialType Class See Also Send Feedback
Remove an existing temperature rating type from this material type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveTemperatureRatingType(
    TemperatureRatingType temperatureRating
)
Visual Basic (Declaration)
Public Sub RemoveTemperatureRatingType ( _
    temperatureRating As TemperatureRatingType _
)
Visual C++
public:
void RemoveTemperatureRatingType(
    TemperatureRatingType^ temperatureRating
)

Parameters

temperatureRating
Type: Autodesk.Revit.MEP..::.TemperatureRatingType
The temperature rating type to be removed.

Exceptions

Exception | Condition
System..::.InvalidOperationException | The last temperature rating type of project and any one used by a wire type can't be removed.

See Also

WireMaterialType Class
Autodesk.Revit.MEP Namespace

WireMaterialType Properties

[image] [image]