Revit 2010 API
XYZ..::.Cross Method
XYZ Class See Also Send Feedback
The cross product of this vector and the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Cross(
    XYZ source
)
Visual Basic (Declaration)
Public Function Cross ( _
    source As XYZ _
) As XYZ
Visual C++
public:
XYZ^ Cross(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to multiply with this vector.

Return Value

The vector equal to the cross product.

Remarks

The cross product is defined as the vector which is perpendicular to both vectors with a magnitude equal to the area of the parallelogram they span. Also known as vector product or outer product.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace

Distance Method

[image]