Revit 2010 API
PrintManager..::.SelectNewPrintDriver Method
PrintManager Class See Also Send Feedback
Select a new printer.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SelectNewPrintDriver(
    string strPrinterName
)
Visual Basic (Declaration)
Public Sub SelectNewPrintDriver ( _
    strPrinterName As String _
)
Visual C++
public:
void SelectNewPrintDriver(
    String^ strPrinterName
)

Parameters

strPrinterName
Type: System..::.String
The name string of new printer.

Remarks

This property is the global print setting property for all documents.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-strPrinterName-is null.
System..::.InvalidOperationException | Thrown when the assigned new printer is invalid, or the print resource is occupied by others.

See Also

PrintManager Class
Autodesk.Revit Namespace

SubmitPrint Method

[image] [image]