Revit 2010 API
DefinitionGroups..::.Create Method
DefinitionGroups Class See Also Send Feedback
Create a new parameter definition group using the name provided.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DefinitionGroup Create(
    string name
)
Visual Basic (Declaration)
Public Function Create ( _
    name As String _
) As DefinitionGroup
Visual C++
public:
DefinitionGroup^ Create(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the group to be created.

Return Value

If successful a reference to the new parameter group is returned, otherwise Nothing.

Remarks

If a group with the same name already exists then an exception will be thrown.

See Also

DefinitionGroups Class
Autodesk.Revit.Parameters Namespace

DefinitionGroups Properties

[image] [image]