Revit 2010 API
Filter..::.NewTypeFilter Method (Type, Boolean)
Filter Class See Also Send Feedback
Creates a new TypeFilter object with the option to find elements derived from the type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TypeFilter NewTypeFilter(
    Type givenType,
    bool includeDerivedTypes
)
Visual Basic (Declaration)
Public Function NewTypeFilter ( _
    givenType As Type, _
    includeDerivedTypes As Boolean _
) As TypeFilter
Visual C++
public:
TypeFilter^ NewTypeFilter(
    Type^ givenType,
    bool includeDerivedTypes
)

Parameters

givenType
Type: System..::.Type
Filter elements by the given type.
includeDerivedTypes
Type: System..::.Boolean
Indicates if find out the elements which are given type's derived classes or not. If includeDerivedTypes is true, will filter derived class elements; false, don't filter derived class elements.

Return Value

Returns a new type filter object within given type.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified givenType is nullptr.

See Also

Filter Class
NewTypeFilter Overload
Autodesk.Revit.Creation Namespace

NewWallUsageFilter Method

[image]