Revit 2010 API
ElementIdSet Members
ElementIdSet Class Constructors Methods Properties See Also Send Feedback

The ElementIdSet type exposes the following members.

Constructors

Name | Description
ElementIdSet | Initializes a new instance of the ElementIdSet class

Methods

Name | Description
Clear | Removes every element id from the set, rendering it empty.
Contains | Tests for the existence of an element id within the set.
Erase | Removes a specified element id from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
Insert | Insert the specified element id into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
Size | Returns the number of element ids that are in the set.

See Also

ElementIdSet Class
Autodesk.Revit Namespace

ElementIdSet Constructor

[image]