Revit 2010 API
ExportComplexity Enumeration
See Also Send Feedback
An enumerate type listing all complexity of gbXML export.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ExportComplexity
Visual Basic (Declaration)
Public Enumeration ExportComplexity
Visual C++
public enum class ExportComplexity

Members

Member name | Description
Simple | Simple means that Curtain Walls and Curtain Systems are exported with one “huge” opening with the total opening area equal to all openings; a curtain wall with 50 panels gets exported as 1 opening.
ComplexWithMullionsAndShadingSurfaces | Export with complex type, shading surfaces and mullion. With Mullions mean that Mullions in Curtain Walls and Systems are exported as shading surfaces. A "simplified" analytical shading surface is produced from a mullion based on its centerline, thickness and offset.
ComplexWithShadingSurfaces | Export with complex type and shading surfaces.
Complex | Complex means that Curtain Walls and Curtain Systems are exported with several openings , panel by panel; a curtain wall with 50 panels gets exported as 50 openings.
SimpleWithShadingSurfaces | Export with simple type and shading surfaces.

See Also

Autodesk.Revit.Elements Namespace

Extrusion Class

[image]