Revit 2010 API
ExternalDefinition..::.Visible Property
ExternalDefinition Class See Also Send Feedback
Tells the developer is the parameter should be visible within the user interface of their application or Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override bool Visible { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Visible As Boolean
Visual C++
public:
virtual property bool Visible {
    bool get () override;
}

Remarks

The visible property controls whether a shared parameter is hidden from the user. This is useful if you wish to add data to an element that is only meaningful to your application and not to the user. This value can only be set when the shared parameter definition is created.

See Also

ExternalDefinition Class
Autodesk.Revit.Parameters Namespace

ExternalDefinitions Class

[image]