Revit 2010 API
Element..::.Level Property
Element Class Example See Also Send Feedback
If the element is level based then level to which the element is assigned is returned.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Level Level { get; }
Visual Basic (Declaration)
Public ReadOnly Property Level As Level
Visual C++
public:
property Level^ Level {
    Level^ get ();
}

Remarks

A number of elements use a level as a base reference, such as a column.

Examples

CopyC#
private void GetLevelInformation(Autodesk.Revit.Element element)
{
    // Get the level object to which the element is assigned.
    Level level = element.Level;
    if (null == level)
    {
        MessageBox.Show("The element isn't based on a level.", "Revit");
    }
    else
    {
        // Format the prompt information(Name and elevation)
        String prompt = "The element is based on a level.";
        prompt += "\nThe level name is:  " + level.Name;
        prompt += "\nThe level elevation is:  " + level.Elevation;

        // Show the information to the user.
        MessageBox.Show(prompt, "Revit");
    }
}
CopyVB.NET
Private Sub GetLevelInformation(ByVal element As Autodesk.Revit.Element)
    ' Get the level object to which the element is assigned.
    Dim level As Autodesk.Revit.Elements.Level = element.Level
    If level Is Nothing Then
        MessageBox.Show("The element isn't based on a level.", "Revit")
    Else
        ' Format the prompt information(Name and elevation)
        Dim prompt As String = "The element is based on a level."
        prompt += vbLf & "The level name is: " & level.Name
        prompt += vbLf & "The level elevation is: " & level.Elevation

        ' Show the information to the user.
        MessageBox.Show(prompt, "Revit")
    End If
End Sub

See Also

Element Class
Autodesk.Revit Namespace

Location Property

[image]