Revit 2010 API
Document..::.Import Method (String, InventorImportOptions)
Document Class See Also Send Feedback
Imports an Inventor file into the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Import(
    string file,
    InventorImportOptions options
)
Visual Basic (Declaration)
Public Function Import ( _
    file As String, _
    options As InventorImportOptions _
) As Boolean
Visual C++
public:
bool Import(
    String^ file,
    InventorImportOptions^ options
)

Parameters

file
Type: System..::.String
Full path of the file to import. File must exist.
options
Type: Autodesk.Revit..::.InventorImportOptions
Various options applicable to Inventor import. If nullptr, all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

A file with "adsk" extension is expected. Though the 'options' argument is not currently used, an object still must be provided (may be null).

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when 'file' argument is null or empty.
System.IO..::.FileNotFoundException | Thrown when the file specified does not exist.
System..::.ArgumentException | Thrown when the file is not an inventor file.

See Also

Document Class
Import Overload
Autodesk.Revit Namespace

Import Method (String, DWGImportOptions, Element)

[image]