Revit 2010 API
Document..::.NewElbowFitting Method
Document Class See Also Send Feedback
Add a new family instance of an elbow fitting into the Autodesk Revit document, using two connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance NewElbowFitting(
    Connector connector1,
    Connector connector2
)
Visual Basic (Declaration)
Public Function NewElbowFitting ( _
    connector1 As Connector, _
    connector2 As Connector _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewElbowFitting(
    Connector^ connector1,
    Connector^ connector2
)

Parameters

connector1
Type: Autodesk.Revit.MEP..::.Connector
The first connector to be connected to the elbow.
connector2
Type: Autodesk.Revit.MEP..::.Connector
The second connector to be connected to the elbow.

Return Value

If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument connector1 or connector2 is null.
System..::.ArgumentException | Thrown when the connectors cannot be used for the elbow creation. For example, they cannot be from the same element, they must be of the same domain, and the angle between them must fall within the valid range (typically 2 to 95 degrees).
System..::.InvalidOperationException | Thrown when elbow fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewElectricalSystem Method

[image] [image]