Revit 2010 API
FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Level, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.Elements..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace

FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Element, Level, StructuralType)

[image]