Revit 2010 API
FaceArray..::.Insert Method
FaceArray Class See Also Send Feedback
Insert the specified face into the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    Face item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Face, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Face^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Geometry..::.Face
The face to be inserted into the array.
index
Type: System..::.Int32
The face will be inserted before this index.

Return Value

Returns whether the face was inserted into the array.

See Also

FaceArray Class
Autodesk.Revit.Geometry Namespace

ReverseIterator Method

[image]