Revit 2010 API
ControlledApplication..::.ViewPrinting Event
ControlledApplication Class Example See Also Send Feedback
Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<ViewPrintingEventArgs> ViewPrinting
Visual Basic (Declaration)
Public Event ViewPrinting As EventHandler(Of ViewPrintingEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintingEventArgs^>^ ViewPrinting {
    void add (EventHandler<ViewPrintingEventArgs^>^ value);
    void remove (EventHandler<ViewPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view of the document.

Event is not cancellable. The 'Cancellable' property of event’s argument is always 'false'.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Export(String, String, GBXMLExportOptions) and similar overloads.
  • Autodesk.Revit.Document.Print()
  • Print()()() and similar overloads.
  • SubmitPrint()()() and similar overloads.
  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewPrinted will be raised immediately after view printing is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

Examples

CopyC#
public class Application_ViewPrinting : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public IExternalApplication.Result OnStartup(ControlledApplication application)
    {
        // Register related events
        application.ViewPrinting += new EventHandler<Autodesk.Revit.Events.ViewPrintingEventArgs>(AppViewPrinting);
        return IExternalApplication.Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public IExternalApplication.Result OnShutdown(ControlledApplication application)
    {
        // unregister events
        application.ViewPrinting -= new EventHandler<Autodesk.Revit.Events.ViewPrintingEventArgs>(AppViewPrinting);
        return IExternalApplication.Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For ViewPrinting class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for ViewPrinting event, it will display some event arguments.
    /// </summary>
    public void AppViewPrinting(object sender, Autodesk.Revit.Events.ViewPrintingEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("ViewPrintingEventArgs Parameters ------>");
        info.AppendLine("    Event Cancellable   : " + args.Cancellable);
        info.AppendLine("    TotalViews          : " + args.TotalViews);
        info.AppendLine("    View Index          : " + args.Index);
        info.AppendLine("    View Information    :"); // View
        DumpViewInfo(args.View, "      ", ref info);

        MessageBox.Show(info.ToString(), "ViewPrinting Info");
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box string.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.Elements.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.Value, view.ViewName, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_ViewPrinting
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ViewPrinting, AddressOf AppViewPrinting
        Return IExternalApplication.Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ViewPrinting, AddressOf AppViewPrinting
        Return IExternalApplication.Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For ViewPrinting class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for ViewPrinting event, it will display some event arguments.
    ' </summary>
    Public Sub AppViewPrinting(ByVal sender As Object, ByVal args As Autodesk.Revit.Events.ViewPrintingEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("ViewPrintingEventArgs Parameters ------>")
        info.AppendLine(" Event Cancellable : " & args.Cancellable)
        info.AppendLine(" TotalViews : " & args.TotalViews)
        info.AppendLine(" View Index : " & args.Index)
        info.AppendLine(" View Information :")
        ' View
        DumpViewInfo(args.View, " ", info)

        MessageBox.Show(info.ToString(), "ViewPrinting Info")
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box string.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(ByVal view As Autodesk.Revit.Elements.View, ByVal prefix As String, ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.Value, view.ViewName, view.ViewType))
    End Sub
End Class

See Also

ControlledApplication Class
Autodesk.Revit Namespace

CurveLoopsProfile Class

[image]