Revit 2010 API
Document..::.FamilyManager Property
Document Class See Also Send Feedback
The family manager object provides access to family types and parameters.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyManager FamilyManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property FamilyManager As FamilyManager
Visual C++
public:
property FamilyManager^ FamilyManager {
    FamilyManager^ get ();
}

Remarks

This property is available when the document is a family document.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the current document is project document.

See Also

Document Class
Autodesk.Revit Namespace

FasciaTypes Property

[image]