Revit 2010 API
ModelCurve..::.ChangeToReferenceLine Method
ModelCurve Class See Also Send Feedback
Changes this curve to reference curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ChangeToReferenceLine()
Visual Basic (Declaration)
Public Sub ChangeToReferenceLine
Visual C++
public:
void ChangeToReferenceLine()

Remarks

This method is applicable only to curves in conceptual mass families.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when attempting to change model curves to reference curves in non-conceptual mass families.

See Also

ModelCurve Class
Autodesk.Revit.Elements Namespace

GetVisibility Method

[image]