Revit 2010 API
ItemFactoryBase..::.NewModelCurveArray Method
ItemFactoryBase Class See Also Send Feedback
Creates an array of new model line elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ModelCurveArray NewModelCurveArray(
    CurveArray geometryCurveArray,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Function NewModelCurveArray ( _
    geometryCurveArray As CurveArray, _
    sketchPlane As SketchPlane _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ NewModelCurveArray(
    CurveArray^ geometryCurveArray,
    SketchPlane^ sketchPlane
)

Parameters

geometryCurveArray
Type: Autodesk.Revit.Geometry..::.CurveArray
An array containing the internal geometry curves for model lines.
sketchPlane
Type: Autodesk.Revit.Elements..::.SketchPlane

Return Value

If successful an array of new model line elements. Otherwise null pointer.

Remarks

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace

NewReferencePlane Method

[image]