Revit 2010 API
Parameter..::.AsElementId Method
Parameter Class See Also Send Feedback
Provides access to the ElementId stored within the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementId AsElementId()
Visual Basic (Declaration)
Public Function AsElementId As ElementId
Visual C++
public:
ElementId AsElementId()

Return Value

The ElementId contained in the parameter.

Remarks

The AsElementId method should only be used if the StorageType property returns that the internal contents of the parameter is an ElementId.

See Also

Parameter Class
Autodesk.Revit Namespace

AsInteger Method

[image]