Revit 2010 API
Solid..::.Faces Property
Solid Class Example See Also Send Feedback
The faces that belong to the solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FaceArray Faces { get; }
Visual Basic (Declaration)
Public ReadOnly Property Faces As FaceArray
Visual C++
public:
property FaceArray^ Faces {
    FaceArray^ get ();
}

Remarks

A face may be degenerate. This can be determined with the Face property IsTwoSided.

Examples

CopyC#
private void GetFacesAndEdges(Wall wall)
{
    String faceInfo = "";

    Autodesk.Revit.Geometry.Options opt = new Options();
    Autodesk.Revit.Geometry.Element geomElem = wall.get_Geometry(opt);
    foreach (GeometryObject geomObj in geomElem.Objects)
    {
        Solid geomSolid = geomObj as Solid;
        if (null != geomSolid)
        {
            int faces = 0;
            double totalArea = 0;
            foreach (Face geomFace in geomSolid.Faces)
            {
                faces++;
                faceInfo += "Face " + faces + " area: " + geomFace.Area.ToString() + "\n";
                totalArea += geomFace.Area;
            }
            faceInfo += "Number of faces: " + faces + "\n";
            faceInfo += "Total area: " + totalArea.ToString() + "\n";
            foreach (Edge geomEdge in geomSolid.Edges)
            {
                // get wall's geometry edges
            }
        }
    }

    MessageBox.Show(faceInfo);
}
CopyVB.NET
Private Sub GetFacesAndEdges(ByVal wall As Wall)
    Dim faceInfo As String = ""

    Dim opt As Autodesk.Revit.Geometry.Options = New Autodesk.Revit.Geometry.Options()
    Dim geomElem As Autodesk.Revit.Geometry.Element = wall.Geometry(opt)
    For Each geomObj As GeometryObject In geomElem.Objects
        Dim geomSolid As Solid = TryCast(geomObj, Solid)
        If geomSolid IsNot Nothing Then
            Dim faces As Integer = 0
            Dim totalArea As Double = 0
            For Each geomFace As Autodesk.Revit.Geometry.Face In geomSolid.Faces
                faces += 1
                faceInfo += ("Face " & faces & " area: ") + geomFace.Area.ToString() & vbLf
                totalArea += geomFace.Area
            Next
            faceInfo += "Number of faces: " & faces & vbLf
            faceInfo += "Total area: " & totalArea.ToString() & vbLf
            For Each geomEdge As Autodesk.Revit.Geometry.Edge In geomSolid.Edges
                ' get wall's geometry edges
            Next
        End If
    Next

    MessageBox.Show(faceInfo)
End Sub

See Also

Solid Class
Autodesk.Revit.Geometry Namespace

SurfaceArea Property

[image]