Revit 2010 API
MEPCurveType Class
Members See Also Send Feedback
A curve type for duct type or pipe type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MEPCurveType : Symbol
Visual Basic (Declaration)
Public Class MEPCurveType _
    Inherits Symbol
Visual C++
public ref class MEPCurveType : public Symbol

Remarks

The curve type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.MEPCurveType
Autodesk.Revit.MEP..::.DuctType
Autodesk.Revit.MEP..::.FlexDuctType
Autodesk.Revit.MEP..::.FlexPipeType
Autodesk.Revit.MEP..::.PipeType

See Also

MEPCurveType Members
Autodesk.Revit.MEP Namespace

MEPCurveType Members

[image] [image]