Revit 2010 API
Form..::.GetControlPoints Method
Form Class See Also Send Feedback
Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferenceArray GetControlPoints(
    Reference curveOrEdgeOrFaceReference
)
Visual Basic (Declaration)
Public Function GetControlPoints ( _
    curveOrEdgeOrFaceReference As Reference _
) As ReferenceArray
Visual C++
public:
ReferenceArray^ GetControlPoints(
    Reference^ curveOrEdgeOrFaceReference
)

Parameters

curveOrEdgeOrFaceReference
Type: Autodesk.Revit.Geometry..::.Reference
The reference of an edge or curve or face.

Return Value

Returns the reference array containing all control points lying on it.

See Also

Form Class
Autodesk.Revit.Elements Namespace

GetCurvesAndEdgesReference Method

[image]