Revit 2010 API
Instance..::.GetSymbolGeometry Method
Instance Class See Also Send Feedback
Computes the geometric representation of the symbol which generates this instance.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element GetSymbolGeometry()
Visual Basic (Declaration)
Public Function GetSymbolGeometry As Element
Visual C++
public:
Element^ GetSymbolGeometry()

Return Value

An element which contains the computed geometry for the symbol.

Remarks

The geometry will be in the the local coordinate space of the symbol. The context of this instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved. The results of the method and the value of the SymbolGeometry property are identical.

See Also

Instance Class
GetSymbolGeometry Overload
Autodesk.Revit.Geometry Namespace

GetSymbolGeometry Method (Transform)

[image]