Revit 2010 API
Document Class
Members See Also Send Feedback
An object that represents an open Autodesk Revit project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Document : APIObject
Visual Basic (Declaration)
Public Class Document _
    Inherits APIObject
Visual C++
public ref class Document : public APIObject

Remarks

The Document object represents an Autodesk Revit project. Revit can have multiple projects open and multiple views to those projects. The active or top most view will be the active project and hence the active document which is available from the Application object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Document

See Also

Document Members
Autodesk.Revit Namespace

Document Members

[image] [image]