Revit 2010 API
Document..::.Rotate Method (ElementSet, Line, Double)
Document Class See Also Send Feedback
Rotates several elements within the document by a specified number of degrees around a given axis.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Rotate(
    ElementSet elements,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    elements As ElementSet, _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate(
    ElementSet^ elements,
    Line^ axis,
    double angle
)

Parameters

elements
Type: Autodesk.Revit..::.ElementSet
A set of elements that are to be rotated.
axis
Type: Autodesk.Revit.Geometry..::.Line
A line that represents the axis of rotation, which can be either bounded or unbounded line.
angle
Type: System..::.Double
The number of degrees, in radians, by which the elements are to be rotated around the specified axis.

Return Value

If the elements are rotate successfully then the method returns True, otherwise False.

Remarks

The rotate method is used to rotate several elements within the project. Other elements may also be rotated when these elements are rotated because they are dependent upon the elements being rotated. A line used as the axis can be created by using the Application.Create object and its methods.

See Also

Document Class
Rotate Overload
Autodesk.Revit Namespace

Save Method

[image] [image]