Revit 2010 API
FlexDuct..::.Points Property
FlexDuct Class See Also Send Feedback
The points of the flex duct.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZArray Points { get; set; }
Visual Basic (Declaration)
Public Property Points As XYZArray
Visual C++
public:
property XYZArray^ Points {
    XYZArray^ get ();
    void set (XYZArray^ value);
}

Remarks

This property is used to retrieve the points of flex duct, including the end points. If the end points are changed, the connection will be maintained by Revit automatically. The set operation will fail if the modification makes the connection invalid.

See Also

FlexDuct Class
Autodesk.Revit.MEP Namespace

FlexDuctType Class

[image]