Revit 2010 API
RebarStyle Enumeration
See Also Send Feedback
Describes the usage style of a RebarShape. The style affects the bend radius and the set of allowable hooks. It also affects Rebar instance auto-constraining behavior.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum RebarStyle
Visual Basic (Declaration)
Public Enumeration RebarStyle
Visual C++
public enum class RebarStyle

Members

Member name | Description
StirrupTie | A stirrup or tie bar.
Standard | A standard or longitudinal bar.

See Also

Autodesk.Revit.Structural.Enums Namespace

SlabFoundationType Enumeration

[image]