Revit 2010 API
Rebar Class
Members Example See Also Send Feedback
An object that represents Rebar.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Rebar : Element
Visual Basic (Declaration)
Public Class Rebar _
    Inherits Element
Visual C++
public ref class Rebar : public Element

Examples

CopyC#
private void Getinfo_Rebar(Rebar rebar)
{
    string message = "Rebar: ";
    //get the bat type of the rebar
    message += "\nBar Type: " + rebar.BarType.Name;

    //get the curve information
    CurveArray curves = rebar.Curves;
    message += "\n\nThe Curves property has " + curves.Size + " curves:";
    foreach (Curve curve in curves)
    {
        // Get curve start point
        message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
            + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        // Get curve end point
        message += "; Curve end point:(" + curve.get_EndPoint(1).X + ", "
            + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
    }

    //get the host element of the rebar
    if (null != rebar.Host) //maybe some rebars don't have host
    {
        message += "\n\nThe host element ID : " + rebar.Host.Id.Value;
    }

    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Private Sub Getinfo_Rebar(ByVal rebar As Autodesk.Revit.Elements.Rebar)
    Dim message As String = "Rebar: "
    'get the bat type of the rebar
    message += vbLf & "Bar Type: " & rebar.BarType.Name

    'get the curve information
    Dim curves As CurveArray = rebar.Curves
    message += vbLf & vbLf & "The Curves property has " & curves.Size & " curves:"
    For Each curve As Curve In curves
        ' Get curve start point
        message += ((vbLf & "Curve start point:(" & curve.EndPoint(0).X & ", ") + curve.EndPoint(0).Y & ", ") + curve.EndPoint(0).Z & ")"
        ' Get curve end point
        message += (("; Curve end point:(" & curve.EndPoint(1).X & ", ") + curve.EndPoint(1).Y & ", ") + curve.EndPoint(1).Z & ")"
    Next

    'get the host element of the rebar
    If rebar.Host IsNot Nothing Then
        'maybe some rebars don't have host
        message += vbLf & vbLf & "The host element ID : " & rebar.Host.Id.Value
    End If

    MessageBox.Show(message, "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Rebar

See Also

Rebar Members
Autodesk.Revit.Elements Namespace

Rebar Members

[image] [image]