Revit 2010 API
XYZ..::.Add Method
XYZ Class See Also Send Feedback
Adds the specified vector to this vector and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Add(
    XYZ source
)
Visual Basic (Declaration)
Public Function Add ( _
    source As XYZ _
) As XYZ
Visual C++
public:
XYZ^ Add(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to add to this vector.

Return Value

The vector equal to the sum of the two vectors.

Remarks

The added vector is obtained by adding each coordinate of the specified vector to the corresponding coordinate of this vector.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace

Addition Operator

[image]