Revit 2010 API
Application..::.OnDocumentSavedAs Event
Application Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentSavedAs event instead. Subscribe to the OnDocumentSavedAs event to be notified after a document is saved as a file with another name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSavedAs event instead.")]
public event DocumentSavedAsEventHandler OnDocumentSavedAs
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSavedAs event instead.")> _
Public Event OnDocumentSavedAs As DocumentSavedAsEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentSavedAs event instead.")]
public:
 event DocumentSavedAsEventHandler^ OnDocumentSavedAs {
    void add (DocumentSavedAsEventHandler^ value);
    void remove (DocumentSavedAsEventHandler^ value);
}

Remarks

Sometimes an application needs to know when a document has been saved to a file with another name. By subscribing to this event the application will be notified after such an event and can perform an action in response.

See Also

Application Class
Autodesk.Revit Namespace

ViewActivated Event

[image]