Revit 2010 API
Selection..::.Elements Property
Selection Class Example See Also Send Feedback
The elements that are currently selected.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SelElementSet Elements { get; set; }
Visual Basic (Declaration)
Public Property Elements As SelElementSet
Visual C++
public:
property SelElementSet^ Elements {
    SelElementSet^ get ();
    void set (SelElementSet^ value);
}

Field Value

The set of elements that are actively selected.

Remarks

This set will contain the results after the user makes selections due to a PickOne or WindowSelect call.

Examples

CopyC#
private void ChangeSelection(Document document)
{
    // Get selected elements form current document.
    Autodesk.Revit.SelElementSet collection = document.Selection.Elements;

    // Display current number of selected elements
    MessageBox.Show("Number of selected elements: " + collection.Size.ToString());

    //Create a new SelElementSet
    SelElementSet newSelectedElementSet = document.Application.Create.NewSelElementSet();

    // Add wall into the created element set.
    foreach (Autodesk.Revit.Element elements in collection)
    {
        if (elements is Wall)
        {
            newSelectedElementSet.Add(elements);
        }
    }

    // Set the created element set as current select element set.
    document.Selection.Elements = newSelectedElementSet;

    // Give the user some information.
    if (0 != newSelectedElementSet.Size)
    {
        MessageBox.Show(document.Selection.Elements.Size.ToString() + " Walls are selected!");
    }
    else
    {
        MessageBox.Show("No Walls have been selected!");
    }
}
CopyVB.NET
Private Sub ChangeSelection(ByVal document As Document)
    ' Get selected elements form current document.
    Dim collection As Autodesk.Revit.SelElementSet = document.Selection.Elements

    ' Display current number of selected elements
    MessageBox.Show("Number of selected elements: " & collection.Size.ToString())

    'Create a new SelElementSet
    Dim newSelectedElementSet As SelElementSet = document.Application.Create.NewSelElementSet()

    ' Add wall into the created element set.
    For Each elements As Autodesk.Revit.Element In collection
        If TypeOf elements Is Wall Then
            newSelectedElementSet.Add(elements)
        End If
    Next

    ' Set the created element set as current select element set.
    document.Selection.Elements = newSelectedElementSet

    ' Give the user some information.
    If 0 <> newSelectedElementSet.Size Then
        MessageBox.Show(document.Selection.Elements.Size.ToString() & " Walls are selected!")
    Else
        MessageBox.Show("No Walls have been selected!")
    End If
End Sub

See Also

Selection Class
Autodesk.Revit Namespace

StatusbarTip Property

[image]