Revit 2010 API
Document..::.Close Method
Document Class See Also Send Feedback
Closes the document with the possibility to ask the user whether or not to save.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Close()
Visual Basic (Declaration)
Public Function Close As Boolean
Visual C++
public:
bool Close()

Return Value

Returns 'false' if either closing procedure fails or if saving of a modified document failed. Also returns 'false' if closing is cancelled by an external application during 'DocumentClosing' event. When function succeeds, 'true' is returned.

Remarks

This function can not be called on the active document.

If the document is modified, the user will be asked if the document should be saved.

See Also

Document Class
Close Overload
Autodesk.Revit Namespace

Close Method (PostedErrorArray)

[image]