Revit 2010 API
Curve..::.Evaluate Method
Curve Class See Also Send Feedback
Evaluates a parameter on the curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Evaluate(
    double param,
    bool normalized
)
Visual Basic (Declaration)
Public Function Evaluate ( _
    param As Double, _
    normalized As Boolean _
) As XYZ
Visual C++
public:
XYZ^ Evaluate(
    double param,
    bool normalized
)

Parameters

param
Type: System..::.Double
The parameter to be evaluated.
normalized
Type: System..::.Boolean
If false, param is interpreted as natural parametrization of the curve. If true, param is expected to be in [0,1] interval mapped to the bounds of the curve. Setting to true is valid only if the curve is bound.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace

Intersect Method

[image] [image]