Revit 2010 API
Document..::.NewFoundationWall Method
Document Class See Also Send Feedback
Creates a new continuous footing object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ContFooting NewFoundationWall(
    ContFootingType contFootingType,
    Wall wall
)
Visual Basic (Declaration)
Public Function NewFoundationWall ( _
    contFootingType As ContFootingType, _
    wall As Wall _
) As ContFooting
Visual C++
public:
ContFooting^ NewFoundationWall(
    ContFootingType^ contFootingType,
    Wall^ wall
)

Parameters

contFootingType
Type: Autodesk.Revit.Symbols..::.ContFootingType
The ContFooting type.
wall
Type: Autodesk.Revit.Elements..::.Wall
The Wall to append a ContFooting.

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewGrid Method

[image] [image]