Revit 2010 API
DividedSurface Class
Members See Also Send Feedback
An element that represents a mesh on another element's surface and a tile pattern built on that mesh.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DividedSurface : Element
Visual Basic (Declaration)
Public Class DividedSurface _
    Inherits Element
Visual C++
public ref class DividedSurface : public Element

Remarks

The ObjectType property (inherited from Element) may be set to either of two things: either a TilePattern element, or a FamilySymbol element from a Curtain Panel family.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.DividedSurface

See Also

DividedSurface Members
Autodesk.Revit.Elements Namespace

DividedSurface Members

[image] [image]