Revit 2010 API
Document..::.PlanTopology Property (Level, Phase)
Document Class See Also Send Feedback
Get the PlanTopology of a given level in a given phase.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PlanTopology PlanTopology[
    Level level,
    Phase phase
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlanTopology ( _
    level As Level, _
    phase As Phase _
) As PlanTopology
Visual C++
public:
property PlanTopology^ PlanTopology[Level^ level, Phase^ phase] {
    PlanTopology^ get (Level^ level, Phase^ phase);
}

Parameters

level
Type: Autodesk.Revit.Elements..::.Level
The level of the Plan Topology.
phase
Type: Autodesk.Revit.Elements..::.Phase
The phase of the Plan Topology.

Remarks

The Plan Topology you get here is in the phase you assigned.

See Also

Document Class
PlanTopology Overload
Autodesk.Revit Namespace

PrintManager Property

[image]