Revit 2010 API
Category Class
Members Example See Also Send Feedback
Represents the category or subcategory to which an element belongs.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Category : APIObject
Visual Basic (Declaration)
Public Class Category _
    Inherits APIObject
Visual C++
public ref class Category : public APIObject

Remarks

Categories are an import tool within Revit for identifying the inferred type of an element, such as anything in the Walls category should be considered as a wall. The API exposes access to the built in categories within Revit via the Document.Settings.Categories property.

Examples

CopyC#
Element selectedElement = null;
foreach (Element e in document.Selection.Elements)
{
    selectedElement = e;
    break;  // just get one selected element
}

// Get the category instance from the Category property
Category category = selectedElement.Category;

BuiltInCategory enumCategory = (BuiltInCategory)category.Id.Value;

// Format the prompt string, which contains the category information
String prompt = "The category information of the selected element is: ";
prompt += "\n\tName:\t" + category.Name;   // Name information

prompt += "\n\tId:\t" + enumCategory.ToString();    // Id information
prompt += "\n\tParent:\t";
if (null == category.Parent)
{
    prompt += "No Parent Category";   // Parent information, it may be null
}
else
{
    prompt += category.Parent.Name;
}

prompt += "\n\tSubCategories:"; // SubCategories information,
CategoryNameMap subCategories = category.SubCategories;
if (null == subCategories || 0 == subCategories.Size) // It may be null or has no item in it
{
    prompt += "No SubCategories;";
}
else
{
    foreach (Category ii in subCategories)
    {
        prompt += "\n\t\t" + ii.Name;
    }
}

// Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);
CopyVB.NET
Dim selectedElement As Autodesk.Revit.Element = Nothing
For Each e As Autodesk.Revit.Element In document.Selection.Elements
    selectedElement = e
    Exit For
    ' just get one selected element
Next

' Get the category instance from the Category property
Dim category As Autodesk.Revit.Category = selectedElement.Category

Dim enumCategory As BuiltInCategory = DirectCast(category.Id.Value, BuiltInCategory)

' Format the prompt string, which contains the category information
Dim prompt As String = "The category information of the selected element is: "
prompt += vbLf & vbTab & "Name:" & vbTab & category.Name
' Name information
prompt += vbLf & vbTab & "Id:" & vbTab & enumCategory.ToString()
' Id information
prompt += vbLf & vbTab & "Parent:" & vbTab
If category.Parent Is Nothing Then
    prompt += "No Parent Category"
    ' Parent information, it may be null
Else
    prompt += category.Parent.Name
End If

prompt += vbLf & vbTab & "SubCategories:"
' SubCategories information,
Dim subCategories As CategoryNameMap = category.SubCategories
If subCategories Is Nothing OrElse 0 = subCategories.Size Then
    ' It may be null or has no item in it
    prompt += "No SubCategories;"
Else
    For Each ii As Autodesk.Revit.Category In subCategories
        prompt += vbLf & vbTab & vbTab & ii.Name
    Next
End If

' Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Category

See Also

Category Members
Autodesk.Revit Namespace

Category Members

[image] [image]