Revit 2010 API
Material Class
Members Example See Also Send Feedback
Represents a material element within an Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class Material : Element
Visual Basic (Declaration)
Public MustInherit Class Material _
    Inherits Element
Visual C++
public ref class Material abstract : public Element

Remarks

This is the abstract parent class for concrete material subclasses. Currently, the supported materials are wood, steel, generic, concrete and other.

Examples

CopyC#
private void GetMaterialInformation(Material material)
{
    StringBuilder message = new StringBuilder("Material : " + material.Name);
    //color of the material
    message.Append(string.Format("\nColor: Red[{0}]; Green[{1}]; Blue[{2}]",
                    material.Color.Red, material.Color.Green, material.Color.Blue));

    //cut pattern and pattern color of the material
    if (null != material.CutPattern)
    {
        message.Append("\nCut Pattern: " + material.CutPattern.Name);
        message.Append(string.Format("\nCut Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                        material.CutPatternColor.Red, material.CutPatternColor.Green, material.CutPatternColor.Blue));
    }

    //surface pattern and pattern color of the material
    if (null != material.SurfacePattern)
    {
        message.Append("\nSurface Pattern: " + material.SurfacePattern.Name);
        message.Append(string.Format("\nSurface Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                        material.SurfacePatternColor.Red, material.SurfacePatternColor.Green, material.SurfacePatternColor.Blue));
    }

    //some shading property of the material
    bool glow = material.Glow;
    message.Append("\nMaterial can glow: " + glow);
    int shininess = material.Shininess;
    message.Append("\nShininess: " + shininess);
    int smoothness = material.Smoothness;
    message.Append("\nSmoothness: " + smoothness);
    int transparency = material.Transparency;
    message.Append("\nTransparency: " + transparency);

    MessageBox.Show(message.ToString(), "Revit");
}
CopyVB.NET
Private Sub GetMaterialInformation(ByVal material As Autodesk.Revit.Elements.Material)
    Dim message As New StringBuilder("Material : " & material.Name)
    'color of the material
    message.Append(String.Format(vbLf & "Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.Color.Red, material.Color.Green, material.Color.Blue))

    'cut pattern and pattern color of the material
    If material.CutPattern IsNot Nothing Then
        message.Append(vbLf & "Cut Pattern: " & material.CutPattern.Name)
        message.Append(String.Format(vbLf & "Cut Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.CutPatternColor.Red, material.CutPatternColor.Green, material.CutPatternColor.Blue))
    End If

    'surface pattern and pattern color of the material
    If material.SurfacePattern IsNot Nothing Then
        message.Append(vbLf & "Surface Pattern: " & material.SurfacePattern.Name)
        message.Append(String.Format(vbLf & "Surface Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.SurfacePatternColor.Red, material.SurfacePatternColor.Green, material.SurfacePatternColor.Blue))
    End If

    'some shading property of the material
    Dim glow As Boolean = material.Glow
    message.Append(vbLf & "Material can glow: " & glow)
    Dim shininess As Integer = material.Shininess
    message.Append(vbLf & "Shininess: " & shininess)
    Dim smoothness As Integer = material.Smoothness
    message.Append(vbLf & "Smoothness: " & smoothness)
    Dim transparency As Integer = material.Transparency
    message.Append(vbLf & "Transparency: " & transparency)

    MessageBox.Show(message.ToString(), "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Material
Autodesk.Revit.Elements..::.MaterialConcrete
Autodesk.Revit.Elements..::.MaterialGeneric
Autodesk.Revit.Elements..::.MaterialOther
Autodesk.Revit.Elements..::.MaterialSteel
Autodesk.Revit.Elements..::.MaterialWood

See Also

Material Members
Autodesk.Revit.Elements Namespace

Material Members

[image] [image]