Revit 2010 API
FamilyItemFactory..::.NewRadialDimension Method (View, Reference, XYZ)
FamilyItemFactory Class See Also Send Feedback
Creates a new radial dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Dimension NewRadialDimension(
    View view,
    Reference arcRef,
    XYZ origin
)
Visual Basic (Declaration)
Public Function NewRadialDimension ( _
    view As View, _
    arcRef As Reference, _
    origin As XYZ _
) As Dimension
Visual C++
public:
Dimension^ NewRadialDimension(
    View^ view,
    Reference^ arcRef,
    XYZ^ origin
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the dimension is to be visible.
arcRef
Type: Autodesk.Revit.Geometry..::.Reference
Geometric reference of the arc to which the dimension is to be bound.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The point where the witness line of the radial dimension will lie.

Return Value

If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The currently user set default style is used for the created dimension.

Remarks

The dimension will be created on default place.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when any input argument is null.
System..::.ArgumentException | Thrown when the argument arcRef is invalid.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewRadialDimension Overload
Autodesk.Revit.Creation Namespace

NewRadialDimension Method (View, Reference, XYZ, DimensionType)

[image]