Revit 2010 API
FlexDuctType Class
Members See Also Send Feedback
A flex duct type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FlexDuctType : MEPCurveType
Visual Basic (Declaration)
Public Class FlexDuctType _
    Inherits MEPCurveType
Visual C++
public ref class FlexDuctType : public MEPCurveType

Remarks

The flex duct type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.MEPCurveType
Autodesk.Revit.MEP..::.FlexDuctType

See Also

FlexDuctType Members
Autodesk.Revit.MEP Namespace

FlexDuctType Members

[image] [image]