Revit 2010 API
ParameterStorage..::.Set Method (String)
ParameterStorage Class See Also Send Feedback
Sets the parameter to a new string of text.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Set(
    string value
)
Visual Basic (Declaration)
Public Overridable Function Set ( _
    value As String _
) As Boolean
Visual C++
public:
virtual bool Set(
    String^ value
)

Parameters

value
Type: System..::.String
The new text value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as a String.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown System::ArgumentNullException when the value is null.

See Also

ParameterStorage Class
Set Overload
Autodesk.Revit Namespace

ParameterStorage Properties

[image] [image]