Revit 2010 API
RibbonItem..::.Enabled Property
RibbonItem Class See Also Send Feedback
Gets or sets a value indicating whether the button is enabled.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Remarks

When the Enabled property is set to false, the button cannot be clicked, and the item's appearance changes. The Image and Text assigned to the button appear grayed out. If the relevant external command cannot be executed, set Enabled = true won't take effect.

See Also

RibbonItem Class
Autodesk.Revit Namespace

ItemText Property

[image]