Revit 2010 API
PrintManager..::.SubmitPrint Method
PrintManager Class See Also Send Feedback
Print the views and sheets defined in the current local PrintManager settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SubmitPrint()
Visual Basic (Declaration)
Public Function SubmitPrint As Boolean
Visual C++
public:
bool SubmitPrint()

Return Value

Returns 'true' if successful, otherwise returns 'false'.

Remarks

PrintManager will apply the local settings to global and print the view/views/sheets which user defined with the current settings.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when this operation is not allowed in the current application mode, or the print resource is occupied by others.

See Also

PrintManager Class
SubmitPrint Overload
Autodesk.Revit Namespace

SubmitPrint Method (View)

[image]