Revit 2010 API
FamilyItemFactory..::.NewLinearDimension Method (View, Line, ReferenceArray, DimensionType)
FamilyItemFactory Class See Also Send Feedback
Creates a new linear dimension object using the specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Dimension NewLinearDimension(
    View view,
    Line line,
    ReferenceArray references,
    DimensionType dimensionType
)
Visual Basic (Declaration)
Public Function NewLinearDimension ( _
    view As View, _
    line As Line, _
    references As ReferenceArray, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewLinearDimension(
    View^ view,
    Line^ line,
    ReferenceArray^ references,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the dimension is to be visible.
line
Type: Autodesk.Revit.Geometry..::.Line
The extension line of the dimension.
references
Type: Autodesk.Revit.Geometry..::.ReferenceArray
An array of geometric references to which the dimension is to be bound. You must supply at least two references, and all references supplied must be parallel to each other and perpendicular to the extension line.
dimensionType
Type: Autodesk.Revit.Symbols..::.DimensionType
The dimension style to be used for the dimension.

Return Value

If creation was successful the new linear dimension is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when any input argument is null.
System..::.ArgumentException | Thrown when the argument is invalid.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewLinearDimension Overload
Autodesk.Revit.Creation Namespace

NewLoftForm Method

[image]