Revit 2010 API
Curve..::.Transformed Property
Curve Class Example See Also Send Feedback
Applies the specified transformation to this curve and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve Transformed[
    Transform transform
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Transformed ( _
    transform As Transform _
) As Curve
Visual C++
public:
property Curve^ Transformed[Transform^ transform] {
    Curve^ get (Transform^ transform);
}

Parameters

transform
Type: Autodesk.Revit.Geometry..::.Transform
The transformation to be applied.

Return Value

The transformed curve.

Examples

CopyC#
public void GetAndTransformCurve(Autodesk.Revit.Application app, Autodesk.Revit.Element element, Options geoOptions)
{
    // Get geometry element of the selected element
    Autodesk.Revit.Geometry.Element geoElement = element.get_Geometry(geoOptions);

    // Get geometry object
    foreach (GeometryObject geoObject in geoElement.Objects)
    {
        // Get the geometry instance which contains the geometry information
        Autodesk.Revit.Geometry.Instance instance = geoObject as Autodesk.Revit.Geometry.Instance;
        if (null != instance)
        {
            foreach (GeometryObject o in instance.SymbolGeometry.Objects)
            {
                // Get curve
                Curve curve = o as Curve;
                if (curve != null)
                {
                    // transfrom the curve to make it in the instance's coordinate space
                    curve = curve.get_Transformed(instance.Transform);
                }
            }
        }
    }
}
CopyVB.NET
Public Sub GetAndTransformCurve(ByVal app As Autodesk.Revit.Application, ByVal element As Autodesk.Revit.Element, ByVal geoOptions As Autodesk.Revit.Geometry.Options)
    ' Get geometry element of the selected element
    Dim geoElement As Autodesk.Revit.Geometry.Element = element.Geometry(geoOptions)

    ' Get geometry object
    For Each geoObject As GeometryObject In geoElement.Objects
        ' Get the geometry instance which contains the geometry information
        Dim instance As Autodesk.Revit.Geometry.Instance = TryCast(geoObject, Autodesk.Revit.Geometry.Instance)
        If instance IsNot Nothing Then
            For Each o As GeometryObject In instance.SymbolGeometry.Objects
                ' Get curve
                Dim curve As Curve = TryCast(o, Curve)
                If curve IsNot Nothing Then
                    ' transfrom the curve to make it in the instance's coordinate space
                    curve = curve.Transformed(instance.Transform)
                End If
            Next
        End If
    Next
End Sub

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified transformation is null.
System..::.InvalidOperationException | Thrown when the transformation is not valid or the transformation application fails.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace

CurveArrArray Class

[image]