Revit 2010 API
Document..::.NewPipe Method (XYZ, Connector, PipeType)
Document Class See Also Send Feedback
Adds a new pipe into the document, using a point, connector and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Pipe NewPipe(
    XYZ point,
    Connector connector,
    PipeType pipeType
)
Visual Basic (Declaration)
Public Function NewPipe ( _
    point As XYZ, _
    connector As Connector, _
    pipeType As PipeType _
) As Pipe
Visual C++
public:
Pipe^ NewPipe(
    XYZ^ point,
    Connector^ connector,
    PipeType^ pipeType
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
The first point of the pipe.
connector
Type: Autodesk.Revit.MEP..::.Connector
The connector to be connected to the pipe.
pipeType
Type: Autodesk.Revit.MEP..::.PipeType
The type of the pipe.

Return Value

If creation was successful then a new pipe is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connector is a fitting or equipment connector of the correct domain, and if the connector’s direction matches the direction of the pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector if necessary. If the connector's type, domain, or direction does not match the direction of the duct to be created, the position of the input connector will govern the endpoints of the pipe, but no connection will be established.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument point or connector is null.
System..::.InvalidOperationException | Thrown when the pipe cannot be created or regenerate fails.

See Also

Document Class
NewPipe Overload
Autodesk.Revit.Creation Namespace

NewPipe Method (Connector, Connector, PipeType)

[image]