Revit 2010 API
Document..::.Element Property (ElementId%)
Document Class See Also Send Feedback
Retrieves an element from the document given a Revit element id.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element Element[
    ref ElementId id
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Element ( _
    ByRef id As ElementId _
) As Element
Visual C++
public:
property Element^ Element[ElementId% id] {
    Element^ get (ElementId% id);
}

Parameters

id
Type: Autodesk.Revit..::.ElementId %
The ElementId of the element to be retrieved from the Document.

Remarks

Returns the element corresponding to the id that was passed. The Element property is used to retrieve a known Element from the Revit database within the Document. If the Element specified by the ElementId does not exist then an empty reference will be returned.

See Also

Document Class
Element Overload
Autodesk.Revit Namespace

Element Property (String)

[image]