Revit 2010 API
SymbolFilter Class
Members See Also Send Feedback
A filter object that used to filter symbol elements which satisfy specified criterion, filter elements by specifying symbol name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SymbolFilter : Filter
Visual Basic (Declaration)
Public Class SymbolFilter _
    Inherits Filter
Visual C++
public ref class SymbolFilter : public Filter

Remarks

The filtered elements include: Symbol type elements, FamilyInstance type elements and other types instances(such as Door, Wall, etc) whose symbol is specified symbol. These elements should belong to main model, active design option or primary design option.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Filter
Autodesk.Revit..::.SymbolFilter

See Also

SymbolFilter Members
Autodesk.Revit Namespace

SymbolFilter Members

[image] [image]