Revit 2010 API
Application Properties
Application Class See Also Send Feedback

The Application type exposes the following members.

Properties

Name | Description
ActiveDocument | Provides access to an object that represents the currently active project.
Assets |
Cities | Returns a set of all the known city locations within Revit.
Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Documents | Returns a set of documents within Revit.
IsQuiescent | Returns if the current application is quiescent.
Language | The language used in the current session of Revit.
LoadedApplications | Returns an array of successfully loaded external applications.
ObjectFactory | Provides an object that can be used to create other instances of Autodesk Revit API objects.
Options | Provides access to an object that represents the application wide settings available in Autodesk Revit.
Product | The product type for the current session of Revit.
RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
VersionBuild | Returns the internal build number of the Autodesk Revit application.
VersionName | Returns the name of the Revit application.
VersionNumber | Return the primary version of the Revit application.

See Also

Application Class
Autodesk.Revit Namespace

ActiveDocument Property

[image]