Revit 2010 API
BeamSystem..::.BeamSystemType Property
BeamSystem Class Example See Also Send Feedback
Retrieve or change the type of the BeamSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BeamSystemType BeamSystemType { get; set; }
Visual Basic (Declaration)
Public Property BeamSystemType As BeamSystemType
Visual C++
public:
property BeamSystemType^ BeamSystemType {
    BeamSystemType^ get ();
    void set (BeamSystemType^ value);
}

Examples

CopyC#
public void GetInfo_BeamSystemType(BeamSystem beamSystem)
{
    string message = "BeamSystem : ";
    // Get BeamSystem type name
    message += "\nBeamSystem type name : " + beamSystem.BeamSystemType.Name;

    // Rename the BeamSystem type used by this BeamSystem
    beamSystem.BeamSystemType.Name = "TestBeamSystemTypeName";
    // Get BeamSystem type name
    message += "\nBeamSystem type name after set: " + beamSystem.BeamSystemType.Name;

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_BeamSystemType(ByVal beamSystem As BeamSystem)
    Dim message As String = "BeamSystem : "
    ' Get BeamSystem type name
    message += vbLf & "BeamSystem type name : " & beamSystem.BeamSystemType.Name

    ' Rename the BeamSystem type used by this BeamSystem
    beamSystem.BeamSystemType.Name = "TestBeamSystemTypeName"
    ' Get BeamSystem type name
    message += vbLf & "BeamSystem type name after set: " & beamSystem.BeamSystemType.Name

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace

BeamType Property

[image]