Revit 2010 API
Document..::.NewMechanicalSystem Method
Document Class See Also Send Feedback
Creates a new MEP mechanical system element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MechanicalSystem NewMechanicalSystem(
    Connector baseEquipmentConnector,
    ConnectorSet connectors,
    DuctSystemType ductSystemType
)
Visual Basic (Declaration)
Public Function NewMechanicalSystem ( _
    baseEquipmentConnector As Connector, _
    connectors As ConnectorSet, _
    ductSystemType As DuctSystemType _
) As MechanicalSystem
Visual C++
public:
MechanicalSystem^ NewMechanicalSystem(
    Connector^ baseEquipmentConnector,
    ConnectorSet^ connectors,
    DuctSystemType ductSystemType
)

Parameters

baseEquipmentConnector
Type: Autodesk.Revit.MEP..::.Connector
One connector within base equipment which is used to connect with the system. The base equipment is optional for the system, so this argument may be null. The baseEquipmentConnector should not be included in the connectors.
connectors
Type: Autodesk.Revit.MEP..::.ConnectorSet
Connectors that will connect to the system. The owner elements of these connectors will be added into system as its elements.
ductSystemType
Type: Autodesk.Revit.MEP.Enums..::.DuctSystemType
The system type.

Return Value

If creation was successful then an instance of mechanical system is returned, otherwise an exception with information will be thrown.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when calling this function outside of the Autodesk Revit MEP product.
System..::.ArgumentNullException | Thrown when the input connectors parameter value is null.
System..::.ArgumentOutOfRangeException | Thrown when the ductSystemType parameter is out of permitted scope.
System..::.ArgumentException | Thrown when some connectors can't be used to create the mechanical system. All the input connectors and base equipment connector should match system type and domain with the system, and they should not have been used in another system. The owner of BaseConnector should be a mechanical equipment, and the owner of other connectors should be a mechanical equipment or air terminal.
System..::.InvalidOperationException | Thrown when the mechanical system creation failed.

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewOpening Method

[image] [image]