Revit 2010 API
Category..::.SetLineWeight Method
Category Class See Also Send Feedback
Sets the line weight for the given graphics style type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetLineWeight(
    int lineWeight,
    GraphicsStyleType graphicsStyleType
)
Visual Basic (Declaration)
Public Sub SetLineWeight ( _
    lineWeight As Integer, _
    graphicsStyleType As GraphicsStyleType _
)
Visual C++
public:
void SetLineWeight(
    int lineWeight,
    GraphicsStyleType graphicsStyleType
)

Parameters

lineWeight
Type: System..::.Int32
graphicsStyleType
Type: Autodesk.Revit.Elements..::.GraphicsStyleType
The type of graphics style.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the input argument-"lineWeigh" or "graphicsStyleType"-is out of range.

See Also

Category Class
Autodesk.Revit Namespace

Category Properties

[image] [image]