Revit 2010 API
ItemFactoryBase..::.NewFamilyInstance Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)
ItemFactoryBase Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    XYZ referenceDirection,
    Element host,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    referenceDirection As XYZ, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    XYZ^ referenceDirection,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
referenceDirection
Type: Autodesk.Revit.Geometry..::.XYZ
A vector that dictates the direction of certains family instances.
host
Type: Autodesk.Revit..::.Element
A host object into which the instance will be embedded
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise Nothing.

Remarks

This method allows you to create FamilyInstance objects that require both a location and direction. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Examples

CopyC#
String fileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Furniture\Bed-Box.rfa";

Autodesk.Revit.Elements.Family family = null;
if (!document.LoadFamily(fileName, out family))
{
    throw new Exception("Couldn't load " + fileName);
}

Floor floor = null;

ElementIterator elemItor = document.get_Elements(typeof(Floor));
elemItor.Reset();
while (elemItor.MoveNext())
{
    Floor currentFloor = elemItor.Current as Floor;
    if (null != currentFloor)
    {
        floor = currentFloor;
        break;
    }
}

if (null != floor)
{
    FamilySymbolSetIterator symbolItor = family.Symbols.ForwardIterator();
    int x = 0, y = 0;
    int i = 0;
    while (symbolItor.MoveNext())
    {
        FamilySymbol symbol = symbolItor.Current as FamilySymbol;
        XYZ location = new XYZ(x, y, 0);
        XYZ direction = new XYZ();
        switch (i % 3)
        {
            case 0:
                direction = new XYZ(1, 1, 0);
                break;
            case 1:
                direction = new XYZ(0, 1, 1);
                break;
            case 2:
                direction = new XYZ(1, 0, 1);
                break;
        }
        FamilyInstance instance = document.Create.NewFamilyInstance(location, symbol, direction, floor, StructuralType.NonStructural);
        x += 10;
        i++;
    }
}
else
{
    throw new Exception("Please open a model with at least one floor element before invoking this command.");
}
CopyVB.NET
Dim fileName As String = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Furniture\Bed-Box.rfa"

Dim family As Autodesk.Revit.Elements.Family = Nothing
If Not document.LoadFamily(fileName, family) Then
    Throw New Exception("Couldn't load " & fileName)
End If

Dim floor As Autodesk.Revit.Elements.Floor = Nothing

Dim elemItor As ElementIterator = document.Elements(GetType(Autodesk.Revit.Elements.Floor))
elemItor.Reset()
While elemItor.MoveNext()
    Dim currentFloor As Autodesk.Revit.Elements.Floor = TryCast(elemItor.Current, Autodesk.Revit.Elements.Floor)
    If currentFloor IsNot Nothing Then
        floor = currentFloor
        Exit While
    End If
End While

If floor IsNot Nothing Then
    Dim symbolItor As FamilySymbolSetIterator = family.Symbols.ForwardIterator()
    Dim x As Integer = 0, y As Integer = 0
    Dim i As Integer = 0
    While symbolItor.MoveNext()
        Dim symbol As Autodesk.Revit.Symbols.FamilySymbol = TryCast(symbolItor.Current, Autodesk.Revit.Symbols.FamilySymbol)
        Dim location As New Autodesk.Revit.Geometry.XYZ(x, y, 0)
        Dim direction As New Autodesk.Revit.Geometry.XYZ()
        Select Case i Mod 3
            Case 0
                direction = New Autodesk.Revit.Geometry.XYZ(1, 1, 0)
                Exit Select
            Case 1
                direction = New Autodesk.Revit.Geometry.XYZ(0, 1, 1)
                Exit Select
            Case 2
                direction = New Autodesk.Revit.Geometry.XYZ(1, 0, 1)
                Exit Select
        End Select
        Dim instance As Autodesk.Revit.Elements.FamilyInstance = document.Create.NewFamilyInstance(location, symbol, direction, floor, StructuralType.NonStructural)
        x += 10
        i += 1
    End While
Else
    Throw New Exception("Please open a model with at least one floor element before invoking this command.")
End If

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace

NewFamilyInstances Method

[image]