Revit 2010 API
ReferenceArray..::.ForwardIterator Method
ReferenceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ReferenceArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ReferenceArrayIterator
Visual C++
public:
virtual ReferenceArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ReferenceArray Class
Autodesk.Revit.Geometry Namespace

GetEnumerator Method

[image]