Revit 2010 API
Filter..::.NewSymbolFilter Method
Filter Class See Also Send Feedback
Creates a SymbolFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SymbolFilter NewSymbolFilter(
    string symbolName
)
Visual Basic (Declaration)
Public Function NewSymbolFilter ( _
    symbolName As String _
) As SymbolFilter
Visual C++
public:
SymbolFilter^ NewSymbolFilter(
    String^ symbolName
)

Parameters

symbolName
Type: System..::.String
Filter elements by the symbol name.

Return Value

Returns a new symbol filter object with given symbol.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the symbolName is nullptr or empty.

See Also

Filter Class
Autodesk.Revit.Creation Namespace

NewTypeFilter Method

[image] [image]