Revit 2010 API
FamilyInstance..::.RemoveCoping Method
FamilyInstance Class See Also Send Feedback
Removes a coping (cut) from a steel beam.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool RemoveCoping(
    FamilyInstance cutter
)
Visual Basic (Declaration)
Public Function RemoveCoping ( _
    cutter As FamilyInstance _
) As Boolean
Visual C++
public:
bool RemoveCoping(
    FamilyInstance^ cutter
)

Parameters

cutter
Type: Autodesk.Revit.Elements..::.FamilyInstance
A steel beam or column for which this beam currently has a coping cut. May not be null or itself.

Remarks

This function corresponds to Tools -> Remove coping in Revit Structure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when 'cutter' is null.
System..::.ArgumentException | Thrown when 'cutter' refers to this instance.
System..::.InvalidOperationException | Thrown when regeneration fails.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace

rotate Method

[image]