Revit 2010 API
HostedSweep Class
Members See Also Send Feedback
An object that represents a roof within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class HostedSweep : HostObject
Visual Basic (Declaration)
Public MustInherit Class HostedSweep _
    Inherits HostObject
Visual C++
public ref class HostedSweep abstract : public HostObject

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object also supports access to a structural analytical model but this feature is only available with Autodesk Revit Structure.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.HostedSweep
Autodesk.Revit.Elements..::.Fascia
Autodesk.Revit.Elements..::.Gutter
Autodesk.Revit.Elements..::.SlabEdge

See Also

HostedSweep Members
Autodesk.Revit.Elements Namespace

HostedSweep Members

[image] [image]