Revit 2010 API
Filter..::.NewLogicOrFilter Method
Filter Class See Also Send Feedback
Creates a new LogicOrFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LogicOrFilter NewLogicOrFilter(
    Filter leftFilter,
    Filter rightFilter
)
Visual Basic (Declaration)
Public Function NewLogicOrFilter ( _
    leftFilter As Filter, _
    rightFilter As Filter _
) As LogicOrFilter
Visual C++
public:
LogicOrFilter^ NewLogicOrFilter(
    Filter^ leftFilter,
    Filter^ rightFilter
)

Parameters

leftFilter
Type: Autodesk.Revit..::.Filter
leftFilter is left operand of logic-or operator.
rightFilter
Type: Autodesk.Revit..::.Filter
rightFilter is right operand of logic-or operator.

Return Value

Returns a new LogicOrFilter object.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter is nullptr.

See Also

Filter Class
Autodesk.Revit.Creation Namespace

NewMaterialFilter Method

[image]