Revit 2010 API
PrintSetup..::.SaveAs Method
PrintSetup Class See Also Send Feedback
Save the current print setting to another print setting with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SaveAs(
    string newName
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    newName As String _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ newName
)

Parameters

newName
Type: System..::.String
print setting name to be saved as.

Return Value

Returns false if saveas operation fails, otherwise, returns true.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the input newName already exists in current print setting list.

See Also

PrintSetup Class
Autodesk.Revit Namespace

PrintSetup Properties

[image] [image]