Revit 2010 API
FamilyInstance..::.Symbol Property
FamilyInstance Class Example See Also Send Feedback
Returns or changes the FamilySymbol object that represents the type of the instance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbol Symbol { get; set; }
Visual Basic (Declaration)
Public Property Symbol As FamilySymbol
Visual C++
public:
property FamilySymbol^ Symbol {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

Setting this property will result in the type of the instance being changed. Related types can be found by examining the Family to which the symbol belongs.

Examples

CopyC#
public void GetInfo_FamilyInstance_Symbol(FamilyInstance familyInstance)
{
    string message = "FamilyInstance symbol: ";
    if (familyInstance.Symbol != null)
    {
        // Get FamilyInstance structural symbol
        message += "\nFamilyInstance structural symbol name is : " + familyInstance.Symbol.Name;

        // Rename the Symbol used by this FamilyInstance
        familyInstance.Symbol.Name = "TestFamilyInstanceSymbolName";

        // Get FamilyInstance structural symbol
        message += "\nFamilyInstance structural symbol name after set is : " + familyInstance.Symbol.Name;
    }
    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_FamilyInstance_Symbol(ByVal familyInstance As Autodesk.Revit.Elements.FamilyInstance)
    Dim message As String = "FamilyInstance symbol: "
    If familyInstance.Symbol IsNot Nothing Then
        ' Get FamilyInstance structural symbol
        message += vbLf & "FamilyInstance structural symbol name is : " & familyInstance.Symbol.Name

        ' Rename the Symbol used by this FamilyInstance
        familyInstance.Symbol.Name = "TestFamilyInstanceSymbolName"

        ' Get FamilyInstance structural symbol
        message += vbLf & "FamilyInstance structural symbol name after set is : " & familyInstance.Symbol.Name
    End If
    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace

ToRoom Property

[image] [image]