Revit 2010 API
FamilyItemFactory..::.NewExtrusionForm Method
FamilyItemFactory Class See Also Send Feedback
Create new Form element by Extrude operation, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Form NewExtrusionForm(
    bool isSolid,
    ReferenceArray profile,
    XYZ direction
)
Visual Basic (Declaration)
Public Function NewExtrusionForm ( _
    isSolid As Boolean, _
    profile As ReferenceArray, _
    direction As XYZ _
) As Form
Visual C++
public:
Form^ NewExtrusionForm(
    bool isSolid,
    ReferenceArray^ profile,
    XYZ^ direction
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Form is Solid or Void.
profile
Type: Autodesk.Revit.Geometry..::.ReferenceArray
The profile of extrusion. It should consist of only one curve loop. The input profile must be in one plane.
direction
Type: Autodesk.Revit.Geometry..::.XYZ
The direction of extrusion, with its length the length of the extrusion. The direction must be perpendicular to the plane determined by profile. The length of vector must be non-zero.

Return Value

If creation was successful new form is returned.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace

NewFamilyInstance Method

[image] [image]