Revit 2010 API
Document..::.NewLineBoundaryConditions Method (Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)
Document Class Example See Also Send Feedback
Creates a new Line BoundaryConditions element on a host element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundaryConditions NewLineBoundaryConditions(
    Element hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)
Visual Basic (Declaration)
Public Function NewLineBoundaryConditions ( _
    hostElement As Element, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double, _
    X_Rotation As TranslationRotationValue, _
    X_RotationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewLineBoundaryConditions(
    Element^ hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)

Parameters

hostElement
Type: Autodesk.Revit..::.Element
A Beam.
X_Translation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".
X_Rotation
Type: Autodesk.Revit.Structural.Enums..::.TranslationRotationValue
A value indicating the option for rotation about the X axis.
X_RotationSpringModulus
Type: System..::.Double
Rotation Spring Modulus for X axis. Ignored if X_Rotation is not "Spring"

Return Value

If successful, NewLineBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 1 - "Line". Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
bool CreateLineConditionsWithElement(FamilyInstance column, Autodesk.Revit.Creation.Document docCreation)
{
    if (Autodesk.Revit.Structural.Enums.StructuralType.Column != column.StructuralType)
    {
        throw new Exception("This sample only works for columns.");
    }

    // Create the new line boundary conditions
    BoundaryConditions condition = docCreation.NewLineBoundaryConditions(column, TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0);
    return (null != condition);
}
CopyVB.NET
Private Function CreateLineConditionsWithElement(ByVal column As Autodesk.Revit.Elements.FamilyInstance, ByVal docCreation As Autodesk.Revit.Creation.Document) As Boolean
    If Autodesk.Revit.Structural.Enums.StructuralType.Column <> column.StructuralType Then
        Throw New Exception("This sample only works for columns.")
    End If

    ' Create the new line boundary conditions
    Dim condition As Autodesk.Revit.Elements.BoundaryConditions = docCreation.NewLineBoundaryConditions(column, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
    0, TranslationRotationValue.Fixed, 0)
    Return (condition IsNot Nothing)
End Function

See Also

Document Class
NewLineBoundaryConditions Overload
Autodesk.Revit.Creation Namespace

NewLineBoundaryConditions Method (Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)

[image]