Revit 2010 API
Element..::.GetDividedSurfaceData Method
Element Class See Also Send Feedback
Get an interface to the divided surfaces on this element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DividedSurfaceData GetDividedSurfaceData()
Visual Basic (Declaration)
Public Function GetDividedSurfaceData As DividedSurfaceData
Visual C++
public:
DividedSurfaceData^ GetDividedSurfaceData()

Return Value

An object that can be used to find information about this element's divided surfaces. Divided surfaces are only supported in Conceptual Massing families; outside of that environment, this method returns null.

Remarks

Divided surfaces are supported on the following element types: Form, GeomCombination, FamilyInstance, and ImportInstance.

See Also

Element Class
Autodesk.Revit Namespace

GetMaterialArea Method

[image]