Revit 2010 API
Form..::.GetCurvesAndEdgesReference Method
Form Class See Also Send Feedback
Given a point, return all edges and curves that it is lying on.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferenceArray GetCurvesAndEdgesReference(
    Reference pointReference
)
Visual Basic (Declaration)
Public Function GetCurvesAndEdgesReference ( _
    pointReference As Reference _
) As ReferenceArray
Visual C++
public:
ReferenceArray^ GetCurvesAndEdgesReference(
    Reference^ pointReference
)

Parameters

pointReference
Type: Autodesk.Revit.Geometry..::.Reference
The reference of a point.

Return Value

Returns the reference array containing all edges and curves that the point is lying on.

See Also

Form Class
Autodesk.Revit.Elements Namespace

GetPathCurveIndexByCurveReference Method

[image]