Revit 2010 API
FamilyManager..::.Parameter Property (BuiltInParameter)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given parameter id.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyParameter Parameter[
    BuiltInParameter parameterId
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    parameterId As BuiltInParameter _
) As FamilyParameter
Visual C++
public:
property FamilyParameter^ Parameter[BuiltInParameter parameterId] {
    FamilyParameter^ get (BuiltInParameter parameterId);
}

Parameters

parameterId
Type: Autodesk.Revit.Parameters..::.BuiltInParameter

Remarks

Returns null if the parameter is not found.

See Also

FamilyManager Class
Parameter Overload
Autodesk.Revit Namespace

Parameter Property (Definition)

[image]