Revit 2010 API
ControlledApplication..::.DialogBoxShowing Event
ControlledApplication Class Example See Also Send Feedback
Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DialogBoxShowingEventArgs> DialogBoxShowing
Visual Basic (Declaration)
Public Event DialogBoxShowing As EventHandler(Of DialogBoxShowingEventArgs)
Visual C++
public:
 event EventHandler<DialogBoxShowingEventArgs^>^ DialogBoxShowing {
    void add (EventHandler<DialogBoxShowingEventArgs^>^ value);
    void remove (EventHandler<DialogBoxShowingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to show a dialog box or a message box.

Event is not cancellable. The 'Cancellable' property of event’s argument is always 'false'.

Depending on the type of the dialog that is being shown, the event's argument's type varies as follows: When it is a dialog box, the event’s argument is an object of DialogBoxShowingEventArgs. When it is a message box, the event’s argument is an object of MessageBoxShowingEventArgs,which is subclass of DialogBoxShowingEventArgs. When it is a task dialog, the event’s argument is an object of TaskDialogShowingEventArgs,which is subclass of DialogBoxShowingEventArgs.

No document may be modified during this event.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

The DialogBoxShowing event is meant to replace the older OnDialogBox event, which is now Obsolete.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

Examples

CopyC#
public class Application_DialogBoxShowing : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public IExternalApplication.Result OnStartup(ControlledApplication application)
    {
        // Register related events
        application.DialogBoxShowing += new EventHandler<Autodesk.Revit.Events.DialogBoxShowingEventArgs>(AppDialogShowing);
        return IExternalApplication.Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public IExternalApplication.Result OnShutdown(ControlledApplication application)
    {
        // unregister events
        application.DialogBoxShowing -= new EventHandler<Autodesk.Revit.Events.DialogBoxShowingEventArgs>(AppDialogShowing);
        return IExternalApplication.Result.Succeeded;
    }

    /// <summary>
    /// The DialogBoxShowing event handler, which allow you to do some work before the dialog shows
    /// </summary>
    void AppDialogShowing(object sender, Autodesk.Revit.Events.DialogBoxShowingEventArgs args)
    {
        // Get the help id of the showing dialog
        int dialogId = args.HelpId;

        // Format the prompt information string
        String promptInfo = "A revit dialog will be opened.\n";
        promptInfo += "The help id of this dialog is " + dialogId.ToString() + "\n";
        promptInfo += "If you don't want the dialog to open, please press cancel button";

        // Show the prompt message, and allow the user to close the dialog directly.
        DialogResult result = MessageBox.Show(promptInfo, "Revit", MessageBoxButtons.OKCancel);
        if (DialogResult.Cancel == result)
        {
            // Do not show the revit dialog
            args.OverrideResult(1);
        }
        else
        {
            // Continue to show the revit dialog
            args.OverrideResult(0);
        }
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_DialogBoxShowing
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.DialogBoxShowing, AddressOf AppDialogShowing
        Return IExternalApplication.Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.DialogBoxShowing, AddressOf AppDialogShowing
        Return IExternalApplication.Result.Succeeded
    End Function

    ' <summary>
    ' The DialogBoxShowing event handler, which allow you to do some work before the dialog shows
    ' </summary>
    Private Sub AppDialogShowing(ByVal sender As Object, ByVal args As Autodesk.Revit.Events.DialogBoxShowingEventArgs)
        ' Get the help id of the showing dialog
        Dim dialogId As Integer = args.HelpId

        ' Format the prompt information string
        Dim promptInfo As String = "A revit dialog will be opened." & vbLf
        promptInfo += "The help id of this dialog is " & dialogId.ToString() & vbLf
        promptInfo += "If you don't want the dialog to open, please press cancel button"

        ' Show the prompt message, and allow the user to close the dialog directly.
        Dim result As DialogResult = MessageBox.Show(promptInfo, "Revit", MessageBoxButtons.OKCancel)
        If DialogResult.Cancel = result Then
            ' Do not show the revit dialog
            args.OverrideResult(1)
        Else
            ' Continue to show the revit dialog
            args.OverrideResult(0)
        End If
    End Sub
End Class

See Also

ControlledApplication Class
Autodesk.Revit Namespace

DocumentClosed Event

[image]