Revit 2010 API
ControlledApplication..::.GetRibbonPanels Method
ControlledApplication Class See Also Send Feedback
Get all the custom Panels on Add-Ins tab of Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual List<RibbonPanel> GetRibbonPanels()
Visual Basic (Declaration)
Public Overridable Function GetRibbonPanels As List(Of RibbonPanel)
Visual C++
public:
virtual List<RibbonPanel^>^ GetRibbonPanels()

Remarks

The build-in panels won't be included.

See Also

ControlledApplication Class
Autodesk.Revit Namespace

OpenSharedParameterFile Method

[image]