Revit 2010 API
InstanceArray Methods
InstanceArray Class See Also Send Feedback

The InstanceArray type exposes the following members.

Methods

Name | Description
Append | Add the instance to the end of the array.
Clear | Removes every instance from the array, rendering it empty.
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
Insert | Insert the specified instance into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.

See Also

InstanceArray Class
Autodesk.Revit.Geometry Namespace

Append Method

[image]