Revit 2010 API
Connector..::.AssignedFlow Property
Connector Class See Also Send Feedback
The assigned flow of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double AssignedFlow { get; set; }
Visual Basic (Declaration)
Public Property AssignedFlow As Double
Visual C++
public:
property double AssignedFlow {
    double get ();
    void set (double value);
}

Remarks

Assigned flow may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::PipeConnector,Autodesk::Revit::MEP::DuctConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainPiping or DomainHvac. Thrown when the connector is not in a family instance.
System..::.ArgumentException | Thrown when set an invalid value.
System..::.InvalidOperationException | Thrown on failure to get or set assigned flow.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

AssignedFlowDirection Property

[image]