Revit 2010 API
Document..::.NewFlexDuct Method (Connector, Connector, FlexDuctType)
Document Class See Also Send Feedback
Adds a new flex duct into the document, using two connector, and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlexDuct NewFlexDuct(
    Connector connector1,
    Connector connector2,
    FlexDuctType ductType
)
Visual Basic (Declaration)
Public Function NewFlexDuct ( _
    connector1 As Connector, _
    connector2 As Connector, _
    ductType As FlexDuctType _
) As FlexDuct
Visual C++
public:
FlexDuct^ NewFlexDuct(
    Connector^ connector1,
    Connector^ connector2,
    FlexDuctType^ ductType
)

Parameters

connector1
Type: Autodesk.Revit.MEP..::.Connector
The first connector to be connected to the duct.
connector2
Type: Autodesk.Revit.MEP..::.Connector
The second connector to be connected to the duct.
ductType
Type: Autodesk.Revit.MEP..::.FlexDuctType
The type of the flex duct.

Return Value

If creation was successful then a new flex duct is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connectors are fitting or equipment connectors of the correct domain, and if the connectors’ direction match the direction of the flex duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument connector1 or connector2 is null.
System..::.InvalidOperationException | Thrown when the flex duct cannot be created or regenerate fails.

See Also

Document Class
NewFlexDuct Overload
Autodesk.Revit.Creation Namespace

NewFlexPipe Method

[image] [image]