Revit 2010 API
Solid Members
Solid Class Constructors Methods Properties See Also Send Feedback

The Solid type exposes the following members.

Constructors

Name | Description
Solid | For Internal Use Only.

Methods

Name | Description

Properties

Name | Description
Edges | The edges that belong to the solid.
Faces | The faces that belong to the solid.
SurfaceArea | Returns the total surface area of this solid.
Volume | Returns the signed volume of this solid.

See Also

Solid Class
Autodesk.Revit.Geometry Namespace

Solid Constructor

[image]