Revit 2010 API
Room..::.IsPointInRoom Method
Room Class See Also Send Feedback
Determines if a point lies within the volume of the room.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsPointInRoom(
    XYZ point
)
Visual Basic (Declaration)
Public Function IsPointInRoom ( _
    point As XYZ _
) As Boolean
Visual C++
public:
bool IsPointInRoom(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
Point to be checked.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the point is nullptr.
System..::.ArgumentException | The coordinates of the point is not a number.

See Also

Room Class
Autodesk.Revit.Elements Namespace

Unplace Method

[image]