Revit 2010 API
XYZ..::.Multiply Method
XYZ Class See Also Send Feedback
Multiplies this vector by the specified value and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ Multiply(
    double value
)
Visual Basic (Declaration)
Public Function Multiply ( _
    value As Double _
) As XYZ
Visual C++
public:
XYZ^ Multiply(
    double value
)

Parameters

value
Type: System..::.Double
The value to multiply with this vector.

Return Value

The multiplied vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of this vector by the specified value.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when the specified value is an infinite number.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace

Negate Method

[image]