Revit 2010 API
Application..::.NewPointOnFace Method
Application Class See Also Send Feedback
Construct a PointOnFace object which is used to define the placement of a ReferencePoint given a reference and a location on the face.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PointOnFace NewPointOnFace(
    Reference faceReference,
    UV uv
)
Visual Basic (Declaration)
Public Function NewPointOnFace ( _
    faceReference As Reference, _
    uv As UV _
) As PointOnFace
Visual C++
public:
PointOnFace^ NewPointOnFace(
    Reference^ faceReference,
    UV^ uv
)

Parameters

faceReference
Type: Autodesk.Revit.Geometry..::.Reference
The reference whose face the object will be created on.
uv
Type: Autodesk.Revit.Geometry..::.UV
A 2-dimensional position.

Return Value

A new PointOnFace object.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument faceReference or uv is null.

See Also

Application Class
Autodesk.Revit.Creation Namespace

NewPointOnPlane Method

[image]