Revit 2010 API
SuspendUpdating Class
Members Example See Also Send Feedback
Temporarily delay Revit's automatic updating and consistency operations.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SuspendUpdating : APIObject
Visual Basic (Declaration)
Public Class SuspendUpdating _
    Inherits APIObject
Visual C++
public ref class SuspendUpdating : public APIObject

Remarks

Creating an instance of this object will cause Autodesk Revit to suspend certain updating and consistency operations, thereby enabling increased performance of large changes via the API. After the object is disposed, updating will take place if required. The object should be disposed explicitly using the Dispose method to ensure known points of consistency within your application. Note that while this object is active the Revit model data may be inconsistent hence values retrieved cannot necessarily be trusted. The object may be nested and the Nested property will return if such an object is already nested. During nesting the final updating will only happen when all SuspendUpdating objects are disposed. Currently suspend updating functionality works primarily with object transformation operations such as move and rotate. Note: This functionality is not available through the Revit COM API. Following methods(properties) support SuspendUpdating:
  • Autodesk.Revit.Document.Move
  • Autodesk.Revit.Document.Rotate
  • Autodesk.Revit.Document.Mirror
  • Autodesk.Revit.Location.Move
  • Autodesk.Revit.Location.Rotate
  • Autodesk.Revit.Creation.Document.NewAnnotationSymbol
  • Autodesk.Revit.Elements.FamilyInstance.flipHand
  • Autodesk.Revit.Elements.FamilyInstance.flipFacing
  • Autodesk.Revit.Elements.FamilyInstance.rotate
  • Autodesk.Revit.Elements.FamilyInstance.FlipFromToRoom
  • Autodesk.Revit.Elements.CurtainGridLine.Move
  • property Autodesk.Revit.LocationPoint.Point.set
  • property Autodesk.Revit.Elements.FamilyInstance.Symbol.set
  • property Autodesk.Revit.Elements.FamilyInstance.StructuralUsage.set
  • property Autodesk.Revit.Elements.Wall.WallType.set
  • property Autodesk.Revit.Elements.TextNote.Coord.set
  • property Autodesk.Revit.Elements.TextNote.Width.set
  • property Autodesk.Revit.Elements.IndependentTag.TagHeadPosition.set
  • property Autodesk.Revit.Elements.IndependentTag.LeaderElbow.set
  • property Autodesk.Revit.Elements.IndependentTag.LeaderEnd.set
  • property Autodesk.Revit.Leader.End.set
  • property Autodesk.Revit.Leader.Elbow.set
  • property Autodesk.Revit.Elements.CurtainGrid.Grid1Justification.set
  • property Autodesk.Revit.Elements.CurtainGrid.Grid1Angle.set
  • property Autodesk.Revit.Elements.CurtainGrid.Grid1Offset.set
  • property Autodesk.Revit.Elements.CurtainGrid.Grid2Justification.set
  • property Autodesk.Revit.Elements.CurtainGrid.Grid2Angle.set
  • property Autodesk.Revit.Elements.CurtainGrid.Grid2Offset.set

Examples

CopyC#
public void MoveElements(Autodesk.Revit.Document document)
{
    Selection choices = document.Selection;
    ElementSet collection = choices.Elements;
    // Using statement defines a scope at the end of which the suspandUpdating
    // object is disposed.
    using (SuspendUpdating aSuspendUpdating = new SuspendUpdating(document))
    {
        // Suspend these operations.
        foreach (FamilyInstance element in collection)
        {
            MoveRotateElement(document, element);
        }
    }
    // Move() operations only update when aSuspendUpdating and
    // bSuspendUpdating (in MoveRotateElement()) are disposed
}

private bool MoveRotateElement(Document document, Autodesk.Revit.Element elem)
{
    // Operations suspended until SuspendUpdating object is disposed
    using (SuspendUpdating bSuspendUpdating = new SuspendUpdating(document))
    {
        // Move Element
        XYZ translation3D = new XYZ(0.0, 0.0, 0.0);
        bool successful1 = document.Move(elem, translation3D);

        // Rotate Element
        XYZ point1 = new XYZ(10, 20, 0);
        XYZ point2 = new XYZ(10, 20, 30);
        Line axis = document.Application.Create.NewLineUnbound(point1, point2);
        bool successful2 = document.Rotate(elem, axis, Math.PI / 3.0);

        return (successful1 && successful2);
    }
}
CopyVB.NET
Public Sub MoveElements(ByVal document As Autodesk.Revit.Document)
    Dim choices As Autodesk.Revit.Selection = document.Selection
    Dim collection As ElementSet = choices.Elements
    ' Using statement defines a scope at the end of which the suspandUpdating
    ' object is disposed.
    Using aSuspendUpdating As New SuspendUpdating(document)
        ' Suspend these operations.
        For Each element As Autodesk.Revit.Elements.FamilyInstance In collection
            MoveRotateElement(document, element)
        Next
    End Using
    ' Move() operations only update when aSuspendUpdating and
    ' bSuspendUpdating (in MoveRotateElement()) are disposed
End Sub

Private Function MoveRotateElement(ByVal document As Document, ByVal elem As Autodesk.Revit.Element) As Boolean
    ' Operations suspended until SuspendUpdating object is disposed
    Using bSuspendUpdating As New SuspendUpdating(document)
        ' Move Element
        Dim translation3D As New Autodesk.Revit.Geometry.XYZ(0.0R, 0.0R, 0.0R)
        Dim successful1 As Boolean = document.Move(elem, translation3D)

        ' Rotate Element
        Dim point1 As New Autodesk.Revit.Geometry.XYZ(10, 20, 0)
        Dim point2 As New Autodesk.Revit.Geometry.XYZ(10, 20, 30)
        Dim axis As Line = document.Application.Create.NewLineUnbound(point1, point2)
        Dim successful2 As Boolean = document.Rotate(elem, axis, Math.PI / 3.0R)

        Return (successful1 AndAlso successful2)
    End Using
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.SuspendUpdating

See Also

SuspendUpdating Members
Autodesk.Revit Namespace

SuspendUpdating Members

[image] [image]