Revit 2010 API
Document..::.BeamSystemTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of beam system types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BeamSystemTypeSet BeamSystemTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property BeamSystemTypes As BeamSystemTypeSet
Visual C++
public:
property BeamSystemTypeSet^ BeamSystemTypes {
    BeamSystemTypeSet^ get ();
}

Remarks

This property returns a set of BeamSystemType objects. These objects can be used change the type of a BeamSystem from one type to another.

See Also

Document Class
Autodesk.Revit Namespace

ContFootingTypes Property

[image]