Revit 2010 API
Application..::.NewXYZArray Method
Application Class Example See Also Send Feedback
Generate an empty array that can hold XYZ point objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZArray NewXYZArray()
Visual Basic (Declaration)
Public Function NewXYZArray As XYZArray
Visual C++
public:
XYZArray^ NewXYZArray()

Return Value

An empty array capable of holding XYZ points or vectors.

Remarks

This method can be used to create an array that can be used for representing ordered points, such as those for the outline of a piece of geometry..

Examples

CopyC#
XYZArray xyzArray = application.Create.NewXYZArray();

// Append points to the array
int count = 20;
for (int ii = 0; ii < count; ++ii)
{
    XYZ xyz = new XYZ(ii, ii * ii, 0);
    xyzArray.Append(xyz);
}
CopyVB.NET
Dim xyzArray As XYZArray = application.Create.NewXYZArray()

' Append points to the array
Dim count As Integer = 20
For ii As Integer = 0 To count - 1
    Dim xyz As New Autodesk.Revit.Geometry.XYZ(ii, ii * ii, 0)
    xyzArray.Append(xyz)
Next

See Also

Application Class
Autodesk.Revit.Creation Namespace

Application Properties

[image] [image]