Revit 2010 API
View..::.SketchPlane Property
View Class See Also Send Feedback
The sketch plane assigned to the view for model curve creation.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SketchPlane SketchPlane { get; }
Visual Basic (Declaration)
Public ReadOnly Property SketchPlane As SketchPlane
Visual C++
public:
property SketchPlane^ SketchPlane {
    SketchPlane^ get ();
}

Field Value

The sketch plane, or null for views which don't allow sketching (such as schedules) or for 3D views, which have no fixed sketch plane.

See Also

View Class
Autodesk.Revit.Elements Namespace

UpDirection Property

[image]