Revit 2010 API
PointOnEdgeFaceIntersection..::.SetEdgeReference Method
PointOnEdgeFaceIntersection Class See Also Send Feedback
Change the edge or curve reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetEdgeReference(
    Reference edgeReference
)
Visual Basic (Declaration)
Public Sub SetEdgeReference ( _
    edgeReference As Reference _
)
Visual C++
public:
void SetEdgeReference(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.Geometry..::.Reference

Remarks

The referenced element may be any model element, including FamilyInstance, FormElement, or CurveElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR.

See Also

PointOnEdgeFaceIntersection Class
Autodesk.Revit.Elements Namespace

SetFaceReference Method

[image]