Revit 2010 API
Selection..::.PickOne Method
Selection Class Example See Also Send Feedback
Allows the user to select one element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool PickOne()
Visual Basic (Declaration)
Public Function PickOne As Boolean
Visual C++
public:
bool PickOne()

Return Value

True if the user selected an element, false if the user selected elsewhere in the UI

Remarks

One more element will be added to the active set of selected elements if user selects an element that is not in the active set of selected elements.

Examples

CopyC#
Selection choices = document.Selection;
// Pick one object from Revit.
bool hasPickOne = choices.PickOne();
if (true == hasPickOne)
{
    MessageBox.Show("One element added to Selection.", "Revit");
}
CopyVB.NET
Dim choices As Autodesk.Revit.Selection = document.Selection
' Pick one object from Revit.
Dim hasPickOne As Boolean = choices.PickOne()
If True = hasPickOne Then
    MessageBox.Show("One element added to Selection.", "Revit")
End If

See Also

Selection Class
Autodesk.Revit Namespace

WindowSelect Method

[image]