Revit 2010 API
ElementArray..::.ForwardIterator Method
ElementArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ElementArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ElementArrayIterator
Visual C++
public:
virtual ElementArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ElementArray Class
Autodesk.Revit Namespace

GetEnumerator Method

[image]