Revit 2010 API
Document..::.NewOpening Method
Document Class See Also Send Feedback
Creates a new opening.

Overload List

Name | Description
NewOpening(Element, CurveArray, Document..::.eRefFace) | Creates a new opening in a beam, brace and column.
NewOpening(Element, CurveArray, Boolean) | Creates a new opening in a roof, floor and ceiling.
NewOpening(Level, Level, CurveArray) | Creates a new shaft opening between a set of levels.
NewOpening(Wall, XYZ, XYZ) | Creates a rectangular opening on a wall.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace

NewOpening Method (Element, CurveArray, Document.eRefFace)

[image]