Revit 2010 API
ElectricalConnector..::.Shape Property
ElectricalConnector Class See Also Send Feedback
The shape of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ConnectorProfileType Shape { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Shape As ConnectorProfileType
Visual C++
public:
virtual property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}

Implements

IConnector..::.Shape

Remarks

no shape for electrical connector.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Always thrown because electrical connectors don't have a shape.

See Also

ElectricalConnector Class
Autodesk.Revit.MEP Namespace

SystemType Property

[image]