Revit 2010 API
Document..::.NewFlexPipe Method (Connector, Connector, FlexPipeType)
Document Class See Also Send Feedback
Adds a new flex pipe into the document, using two connector, and flex pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlexPipe NewFlexPipe(
    Connector connector1,
    Connector connector2,
    FlexPipeType pipeType
)
Visual Basic (Declaration)
Public Function NewFlexPipe ( _
    connector1 As Connector, _
    connector2 As Connector, _
    pipeType As FlexPipeType _
) As FlexPipe
Visual C++
public:
FlexPipe^ NewFlexPipe(
    Connector^ connector1,
    Connector^ connector2,
    FlexPipeType^ pipeType
)

Parameters

connector1
Type: Autodesk.Revit.MEP..::.Connector
The first connector to be connected to the pipe.
connector2
Type: Autodesk.Revit.MEP..::.Connector
The second connector to be connected to the pipe.
pipeType
Type: Autodesk.Revit.MEP..::.FlexPipeType
The type of the flex pipe.

Return Value

If creation was successful then a new flex pipe is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connectors are fitting or equipment connectors of the correct domain, and if the connectors’ direction match the direction of the flex pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connectors, no connection will be established.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument connector1 or connector2 is null.
System..::.InvalidOperationException | Thrown when the flex pipe cannot be created or regenerate fails.

See Also

Document Class
NewFlexPipe Overload
Autodesk.Revit.Creation Namespace

NewFloor Method

[image] [image]