Revit 2010 API
ControlledApplication..::.DocumentSavingAs Event
ControlledApplication Class Example See Also Send Feedback
Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentSavingAsEventArgs> DocumentSavingAs
Visual Basic (Declaration)
Public Event DocumentSavingAs As EventHandler(Of DocumentSavingAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingAsEventArgs^>^ DocumentSavingAs {
    void add (EventHandler<DocumentSavingAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingAsEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document with a new file name. Note that the first save of a newly created document will raise DocumentSavingAs rather than DocumentSaving event.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to 'true' to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSavedAs will be raised immediately after the document has been saved with a new file name.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

Examples

CopyC#
public class DocumentSavingAs : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// This method subscribes to DocumentSavingAs event.
    /// </summary>
    public IExternalApplication.Result OnStartup(ControlledApplication application)
    {
        application.DocumentSavingAs += new EventHandler<DocumentSavingAsEventArgs>(CheckProjectStatusInitial);
        return IExternalApplication.Result.Succeeded;
    }

    /// <summary>
    /// Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    /// </summary>
    public IExternalApplication.Result OnShutdown(ControlledApplication application)
    {
        // unregister subscribed event
        application.DocumentSavingAs -= new EventHandler<DocumentSavingAsEventArgs>(CheckProjectStatusInitial);
        return IExternalApplication.Result.Succeeded;
    }

    /// <summary>
    /// Event handler method for DocumentSavingAs event. This method will check the "Project Status" value,
    /// if it is null or empty string cancel the save as process.
    /// </summary>
    /// <param name="sender">The source of the event.</param>
    /// <param name="args">Event arguments that contains the event data.</param>
    private void CheckProjectStatusInitial(Object sender, DocumentSavingAsEventArgs args)
    {
        Document doc = args.Document;
        ProjectInfo proInfo = doc.ProjectInformation;

        // Project information is only available for project document.
        if (null != proInfo)
        {
            if (string.IsNullOrEmpty(proInfo.Status))
            {
                // cancel the save as process.
                args.Cancel = true;
                MessageBox.Show("Status project parameter is not set.  Save is aborted.");
            }
        }
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class DocumentSavingAs
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' This method subscribes to DocumentSavingAs event.
    ' </summary>
    Public Function OnStartup(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnStartup
        AddHandler application.DocumentSavingAs, AddressOf CheckProjectStatusInitial
        Return IExternalApplication.Result.Succeeded
    End Function

    ' <summary>
    ' Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    ' </summary>
    Public Function OnShutdown(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnShutdown
        ' unregister subscribed event
        RemoveHandler application.DocumentSavingAs, AddressOf CheckProjectStatusInitial
        Return IExternalApplication.Result.Succeeded
    End Function

    ' <summary>
    ' Event handler method for DocumentSavingAs event. This method will check the "Project Status" value,
    ' if it is null or empty string cancel the save as process.
    ' </summary>
    ' <param name="sender">The source of the event.</param>
    ' <param name="args">Event arguments that contains the event data.</param>
    Private Sub CheckProjectStatusInitial(ByVal sender As Object, ByVal args As Autodesk.Revit.Events.DocumentSavingAsEventArgs)
        Dim doc As Document = args.Document
        Dim proInfo As Autodesk.Revit.Elements.ProjectInfo = doc.ProjectInformation

        ' Project information is only available for project document.
        If proInfo IsNot Nothing Then
            If String.IsNullOrEmpty(proInfo.Status) Then
                ' cancel the save as process.
                args.Cancel = True
            End If
        End If
    End Sub
End Class

See Also

ControlledApplication Class
Autodesk.Revit Namespace

DocumentSynchronizedWithCentral Event

[image]