Revit 2010 API
ItemFactoryBase..::.NewDetailCurveArray Method
ItemFactoryBase Class See Also Send Feedback
Creates an array of new detail curve elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DetailCurveArray NewDetailCurveArray(
    View view,
    CurveArray geometryCurveArray
)
Visual Basic (Declaration)
Public Function NewDetailCurveArray ( _
    view As View, _
    geometryCurveArray As CurveArray _
) As DetailCurveArray
Visual C++
public:
DetailCurveArray^ NewDetailCurveArray(
    View^ view,
    CurveArray^ geometryCurveArray
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the detail curves are to be visible.
geometryCurveArray
Type: Autodesk.Revit.Geometry..::.CurveArray
An array containing the internal geometry curves for detail lines. The curve in array should be bound curve.

Return Value

If successful an array of new detail curve elements. Otherwise null pointer.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace

NewDimension Method

[image] [image]