Revit 2010 API
Connector..::.Width Property
Connector Class See Also Send Feedback
The width of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual double Width { get; set; }
Visual Basic (Declaration)
Public Overridable Property Width As Double
Visual C++
public:
virtual property double Width {
    double get ();
    void set (double value);
}

Implements

IConnector..::.Width

Remarks

In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's shape is not rectangular.
System..::.ArgumentException | Thrown when the argument is invalid.
System..::.InvalidOperationException | Thrown on failure to set width.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

ConnectorManager Class

[image]