Revit 2010 API
FlexPipe Class
Members See Also Send Feedback
A flex pipe in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FlexPipe : MEPCurve
Visual Basic (Declaration)
Public Class FlexPipe _
    Inherits MEPCurve
Visual C++
public ref class FlexPipe : public MEPCurve

Remarks

The flex pipe is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.MEP..::.MEPCurve
Autodesk.Revit.MEP..::.FlexPipe

See Also

FlexPipe Members
Autodesk.Revit.MEP Namespace

FlexPipe Members

[image] [image]