Revit 2010 API
FormatOptions..::.Rounding Property
FormatOptions Class See Also Send Feedback
Retrieves the Rounding/Accuracy of Units Type that are currently selected.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Rounding { get; set; }
Visual Basic (Declaration)
Public Property Rounding As Double
Visual C++
public:
property double Rounding {
    double get ();
    void set (double value);
}

Remarks

You can set a non-negative double value to Rounding property, if there is no this type in UI Combox, it will show us Custom value. and if you input a negative value, it will correct to 1.

See Also

FormatOptions Class
Autodesk.Revit Namespace

Units Property

[image]