Revit 2010 API
FamilyManager..::.IsParameterLocked Method
FamilyManager Class See Also Send Feedback
For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsParameterLocked(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function IsParameterLocked ( _
    familyParameter As FamilyParameter _
) As Boolean
Visual C++
public:
bool IsParameterLocked(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter

Return Value

True if the parameter is lockable and is locked; false otherwise.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if this family is not a Conceptual Mass or Curtain Panel family.

See Also

FamilyManager Class
Autodesk.Revit Namespace

MakeInstance Method

[image]