Revit 2010 API
Materials..::.Item Property (ElementId)
Materials Class See Also Send Feedback
Gets the material with the specified ID.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Material Item[
    ElementId itemId
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Item ( _
    itemId As ElementId _
) As Material
Visual C++
public:
property Material^ Item[ElementId itemId] {
    Material^ get (ElementId itemId);
}

Parameters

itemId
Type: Autodesk.Revit..::.ElementId
The ID of the material to be found.

Remarks

If the material with the specified ID does not exist, null pointer will be returned.

See Also

Materials Class
Item Overload
Autodesk.Revit Namespace

Item Property (String)

[image]