Revit 2010 API
CurveByPoints..::.SetVisibility Method
CurveByPoints Class See Also Send Feedback
Sets the visibility.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic (Declaration)
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit..::.FamilyElementVisibility

Remarks

The visibility of the CurveByPoints can be changed for different types of views and detail levels in the project.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when visibility is null.
System..::.InvalidOperationException | Thrown when regeneration failed.

See Also

CurveByPoints Class
Autodesk.Revit.Elements Namespace

SortPoints Method

[image]