Revit 2010 API
ElectricalSystem..::.NewWires Method
ElectricalSystem Class See Also Send Feedback
Create a bunch of wires for the electrical system.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireSet NewWires(
    View view,
    WiringType wiringType
)
Visual Basic (Declaration)
Public Function NewWires ( _
    view As View, _
    wiringType As WiringType _
) As WireSet
Visual C++
public:
WireSet^ NewWires(
    View^ view,
    WiringType wiringType
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the wire is to be visible.
wiringType
Type: Autodesk.Revit.MEP.Enums..::.WiringType
Specify the wiring type(Arc or Chamfer) that is to be applied to all new created wires.

Return Value

New created wires

Exceptions

Exception | Condition
System..::.ArgumentException | This method can just only be used to created a bunch of wires according to specific pairs of elements, so if there exists null element in any pair of familyInstancePairs, the exception will be thrown.

See Also

ElectricalSystem Class
Autodesk.Revit.MEP Namespace

RemoveFromCircuit Method

[image]