Revit 2010 API
ItemFactoryBase..::.NewLevel Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Level NewLevel(
    double elevation
)
Visual Basic (Declaration)
Public Function NewLevel ( _
    elevation As Double _
) As Level
Visual C++
public:
Level^ NewLevel(
    double elevation
)

Parameters

elevation
Type: System..::.Double
The elevation to apply to the new level.

Return Value

The newly created level.

Remarks

Default level attributes will apply to this new model.

Examples

CopyC#
Level CreateLevel(Autodesk.Revit.Document document)
{
    // The elevation to apply to the new level
    double elevation = 20.0;

    // Begin to create a level
    Level level = document.Create.NewLevel(elevation);
    if (null == level)
    {
        throw new Exception("Create a new level failed.");
    }

    // Change the level name
    level.Name = "New level";

    return level;
}
CopyVB.NET
Private Function CreateLevel(ByVal document As Autodesk.Revit.Document) As Autodesk.Revit.Elements.Level
    ' The elevation to apply to the new level
    Dim elevation As Double = 20.0R

    ' Begin to create a level
    Dim level As Autodesk.Revit.Elements.Level = document.Create.NewLevel(elevation)
    If level Is Nothing Then
        Throw New Exception("Create a new level failed.")
    End If

    ' Change the level name
    level.Name = "New level"

    Return level
End Function

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace

NewModelCurve Method

[image]