Revit 2010 API
ControlledApplication Members
ControlledApplication Class Constructors Methods Properties Events See Also Send Feedback

The ControlledApplication type exposes the following members.

Constructors

Name | Description
ControlledApplication | For Internal Use Only.

Methods

Name | Description
CreateRibbonPanel | Create a new RibbonPanel.
GetRibbonPanels | Get all the custom Panels on Add-Ins tab of Revit.
OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.

Properties

Name | Description
Cities | Returns a set of all the known city locations within Revit.
Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
IsQuiescent | Returns if the current application is quiescent.
Language | The language used in the Revit application.
LoadedApplications | Returns an array of successfully loaded external applications.
Options | Provides access to an object that represents the application wide settings available in Autodesk Revit.
Product | The product type for the Revit application.
VersionBuild | Returns the internal build number of the Revit application.
VersionName | Returns the name of the Revit application.
VersionNumber | Return the primary version of the Revit application.

Events

Name | Description
ApplicationClosing | Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
DialogBoxShowing | Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
DocumentClosed | Subscribe to the DocumentClosed event to be notified immediately after Revit has finished closing a document.
DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central file.
DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central file.
FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
OnDialogBox | Obsolete. This event is deprecated since Revit version 2010. Please use DialogBoxShowing event instead. Subscribe to the OnDialogBox event to be notified when a Reivt dialog box is displayed during an API external command.
OnDocumentClosed | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentClosed event instead. Subscribe to the OnDocumentClosed event to be notified when a document is closed during an API external command.
OnDocumentNewed | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentCreated event instead. Subscribe to the OnDocumentNewed event to be notified when a new document is created during an API external command.
OnDocumentOpened | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentOpened event instead. Subscribe to the OnDocumentOpened event to be notified when a document is opened during an API external command.
OnDocumentSaved | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentSaved event instead. Subscribe to the OnDocumentSaved event to be notified when a document is saved during an API external command.
OnDocumentSavedAs | Obsolete. This event is deprecated since Revit version 2010. Please use DocumentSavedAs event instead. Subscribe to the OnDocumentSavedAs event to be notified when a document is saved as a file with another name during an API external command.
ViewActivated | Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
ViewActivating | Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.
ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

ControlledApplication Class
Autodesk.Revit Namespace

ControlledApplication Constructor

[image]