Revit 2010 API
FamilyParameter Members
FamilyParameter Class Constructors Methods Properties See Also Send Feedback

The FamilyParameter type exposes the following members.

Constructors

Name | Description
FamilyParameter | For Internal Use Only.

Methods

Name | Description

Properties

Name | Description
AssociatedParameters | The parameters from elements in the family which are associated to this parameter.
CanAssignFormula | Indicates if this parameter can be assigned a formula.
Definition | The definition.
DisplayUnitType | The display unit type.
Formula | The formula.
IsDeterminedByFormula | Indicates if the parameter is determined by formula.
IsInstance | Indicates if the parameter is instance or type.
StorageType | The storage type describes the type that is used internally within the parameter to store its value.

See Also

FamilyParameter Class
Autodesk.Revit Namespace

FamilyParameter Constructor

[image]