Revit 2010 API
Material..::.Duplicate Method
Material Class Example See Also Send Feedback
Duplicates the material.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract Material Duplicate(
    string name
)
Visual Basic (Declaration)
Public MustOverride Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate(
    String^ name
) abstract

Parameters

name
Type: System..::.String
Name of the new material.

Return Value

The new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, a null pointer will be returned.

Examples

CopyC#
private bool DuplicateMaterial(Material material)
{
    bool duplicated = false;
    //try to duplicate a new instance of Material class using duplicate method
    //make sure the name of new material is unique in MaterailSet
    string newName = "new" + material.Name;
    Material myMaterial = material.Duplicate(newName);
    if (null == myMaterial)
    {
        MessageBox.Show("Failed to duplicate a material!");
    }
    else
    {
        duplicated = true;
    }

    return duplicated;
}
CopyVB.NET
Private Function DuplicateMaterial(ByVal material As Autodesk.Revit.Elements.Material) As Boolean
    Dim duplicated As Boolean = False
    'try to duplicate a new instance of Material class using duplicate method
    'make sure the name of new material is unique in MaterailSet
    Dim newName As String = "new" & material.Name
    Dim myMaterial As Autodesk.Revit.Elements.Material = material.Duplicate(newName)
    If myMaterial Is Nothing Then
        MessageBox.Show("Failed to duplicate a material!")
    Else
        duplicated = True
    End If

    Return duplicated
End Function

See Also

Material Class
Autodesk.Revit.Elements Namespace

Material Properties

[image] [image]