Revit 2010 API
DimensionSegmentArray..::.Insert Method
DimensionSegmentArray Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    DimensionSegment item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As DimensionSegment, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    DimensionSegment^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit..::.DimensionSegment
The item to be inserted into the array.
index
Type: System..::.Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

DimensionSegmentArray Class
Autodesk.Revit Namespace

ReverseIterator Method

[image]