Revit 2010 API
PartType Enumeration
See Also Send Feedback
An enumerate type listing all the part type for the mechanical fittings.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum PartType
Visual Basic (Declaration)
Public Enumeration PartType
Visual C++
public enum class PartType

Members

Member name | Description
ValveNormal | The part type is valve normal.
MultiPort | The part type is multi port.
Pants | The part type is pants.
LateralCross | The part type is lateral cross.
LateralTee | The part type is lateral tee.
Wye | The part type is wye.
Damper | The part type is damper.
SpudAdjustable | The part type is spud adjustable.
SpudPerpendicular | The part type is spud perpendicular.
ValveBreaksInto | The part type is valve breaks into.
EquipmentSwitch | The part type is equipment switch.
OtherPanel | The part type is other panel.
SwitchBoard | The part type is switch board.
Transformer | The part type is transformer.
PanelBoard | The part type is panel board.
Union | The part type is union.
Offset | The part type is offset.
TapAdjustable | The part type is tap adjustable.
TapPerpendicular | The part type is tap perpendicular.
Cap | The part type is cap.
Tee | The part type is tee.
Elbow | The part type is elbow.
BreaksInto | The part type is breaks into.
AttachesTo | The part type is attaches to.
JunctionBox | The part type is junction box.
DuctMounted | The part type is duct mounted.
Normal | The part type is normal.
UndefinedPartType | The part type is undifined.
Switch | The part type is switch.
Cross | The part type is cross.
Transition | The part type is transition.

See Also

Autodesk.Revit.MEP.Enums Namespace

PipeFlowConfigurationType Enumeration

[image]