Revit 2010 API
FamilyItemFactory..::.NewDuctConnector Method
FamilyItemFactory Class See Also Send Feedback
Add a new duct connector into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DuctConnector NewDuctConnector(
    Reference planarFaceReference,
    DuctSystemType systemType
)
Visual Basic (Declaration)
Public Function NewDuctConnector ( _
    planarFaceReference As Reference, _
    systemType As DuctSystemType _
) As DuctConnector
Visual C++
public:
DuctConnector^ NewDuctConnector(
    Reference^ planarFaceReference,
    DuctSystemType systemType
)

Parameters

planarFaceReference
Type: Autodesk.Revit.Geometry..::.Reference
A reference to a planar face where the connector will be placed.
systemType
Type: Autodesk.Revit.MEP.Enums..::.DuctSystemType
Indicates the system type of this new duct connector.

Return Value

If creation was successful the new Duct Connector is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a duct connector in a family document. The duct connector will be placed at the centroid of the planar face.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the argument planarFaceReference is invalid.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace

NewElectricalConnector Method

[image]