Revit 2010 API
ParameterStorage..::.AsElementId Method
ParameterStorage Class See Also Send Feedback
Provides access to the ElementId stored within the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ElementId AsElementId()
Visual Basic (Declaration)
Public Overridable Function AsElementId As ElementId
Visual C++
public:
virtual ElementId AsElementId()

Return Value

The ElementId contained in the parameter.

Remarks

The AsElementId method should only be used if the StorageType property returns that the internal contents of the parameter is an ElementId.

Exceptions

Exception | Condition
InvalidOperationException..::.InvalidOperationException()()() | Thrown when the StorageType is not ElementId

See Also

ParameterStorage Class
Autodesk.Revit Namespace

AsInteger Method

[image]