Revit 2010 API
Document..::.LoadFamily Method (Document)
Document Class See Also Send Feedback
Loads the contents of this family document into another document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Family LoadFamily(
    Document targetDocument
)
Visual Basic (Declaration)
Public Function LoadFamily ( _
    targetDocument As Document _
) As Family
Visual C++
public:
Family^ LoadFamily(
    Document^ targetDocument
)

Parameters

targetDocument
Type: Autodesk.Revit..::.Document
The target document where the family will be loaded.

Return Value

Returns the reference of the family in the target document.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"targetDocument"-is null.
System..::.InvalidOperationException | Thrown when the current document is not a family document, or the target document doesn't support load of this family, or this family was found in the target document already and need to solve the conflict, or a shared family in this family was found in the target document already and need to choose the source version.

See Also

Document Class
LoadFamily Overload
Autodesk.Revit Namespace

LoadFamily Method (String)

[image]