Revit 2010 API
RebarBarType Class
Members See Also Send Feedback
A Rebar type object that is used in the generation of Rebar.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RebarBarType : Symbol
Visual Basic (Declaration)
Public Class RebarBarType _
    Inherits Symbol
Visual C++
public ref class RebarBarType : public Symbol

Remarks

The RebarBarType object contains information about Rebar. Access to these details is made available through built in parameters. The following are parameters that can be used: REBAR_BAR_DIAMETER - diameter of bar, REBAR_BAR_BEND_RADIUS - minimal bend radius of the rebar, MATERIAL_ID_PARAM - identifies the material of which the rebar is made, REBAR_BAR_STYLE - category that is used to represent the Rebar in drawings.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.Symbols..::.RebarBarType

See Also

RebarBarType Members
Autodesk.Revit.Symbols Namespace

RebarBarType Members

[image] [image]