Revit 2010 API
Application..::.DocumentOpening Event
Application Class See Also Send Feedback
Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentOpeningEventArgs> DocumentOpening
Visual Basic (Declaration)
Public Event DocumentOpening As EventHandler(Of DocumentOpeningEventArgs)
Visual C++
public:
 event EventHandler<DocumentOpeningEventArgs^>^ DocumentOpening {
    void add (EventHandler<DocumentOpeningEventArgs^>^ value);
    void remove (EventHandler<DocumentOpeningEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to open a document.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to 'true'. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document cannot be modified, for it is not opened yet at the time of the event.

Another DocumentOpened event will be raised immediately after document is opened.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace

DocumentPrinted Event

[image]