Revit 2010 API
RebarShapeDefinition Class
Members See Also Send Feedback
A class to assist in defining rebar shapes. A RebarShape element needs exactly one RebarShapeDefinition. The definition object is created by one of the factory methods on RebarShape.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RebarShapeDefinition : APIObject
Visual Basic (Declaration)
Public Class RebarShapeDefinition _
    Inherits APIObject
Visual C++
public ref class RebarShapeDefinition : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Symbols..::.RebarShapeDefinition
Autodesk.Revit.Symbols..::.RebarShapeDefinitionByArc
Autodesk.Revit.Symbols..::.RebarShapeDefinitionBySegments

See Also

RebarShapeDefinition Members
Autodesk.Revit.Symbols Namespace

RebarShapeDefinition Members

[image] [image]