Revit 2010 API
Panel..::.Lock Property
Panel Class See Also Send Feedback
This property is used to know whether a panel is locked and lock or unlock a panel.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Lock { get; set; }
Visual Basic (Declaration)
Public Property Lock As Boolean
Visual C++
public:
property bool Lock {
    bool get ();
    void set (bool value);
}

Remarks

If the panel is locked, get() returns true, else false.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when this panel can't be locked.

See Also

Panel Class
Autodesk.Revit.Elements Namespace

Lockable Property

[image]