Revit 2010 API
LocationCurve Class
Members See Also Send Feedback
Provides location functionality for all elements that are based upon a curve.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LocationCurve : Location
Visual Basic (Declaration)
Public Class LocationCurve _
    Inherits Location
Visual C++
public ref class LocationCurve : public Location

Remarks

The location line objects adds additional functionality to its base location object class. This includes reading and writing the curve contained within the element.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Location
Autodesk.Revit..::.LocationCurve

See Also

LocationCurve Members
Autodesk.Revit Namespace

LocationCurve Members

[image] [image]