Revit 2010 API
StructuralType Enumeration
See Also Send Feedback
Fundamental structural component category.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum StructuralType
Visual Basic (Declaration)
Public Enumeration StructuralType
Visual C++
public enum class StructuralType

Members

Member name | Description
MAX | The value is used to check whether the enum is the same size as the internal one.
UnknownFraming | The structural type of the object is unknow.
Footing | The object is considered to be a footing.
Column | The object is considered too be a column.
Brace | The object is considered to be a brace.
Beam | The object is considered to be a beam.
NonStructural | The object is considered to be non structural in nature.

See Also

Autodesk.Revit.Structural.Enums Namespace

TranslationRotationValue Enumeration

[image]