Revit 2010 API
Document..::.SaveAs Method (String, Boolean)
Document Class See Also Send Feedback
Saves the document to a given file name with the option to change the document's name in Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SaveAs(
    string fileName,
    bool changeDocumentFilename
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    fileName As String, _
    changeDocumentFilename As Boolean _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ fileName,
    bool changeDocumentFilename
)

Parameters

fileName
Type: System..::.String
File name and path to be saved as.
changeDocumentFilename
Type: System..::.Boolean
Indicates if the current file name on the title bar of Revit will be changed accordingly.

Return Value

Returns 'false' if save operation fails. Also returns 'false' if saving as is cancelled by an external application during 'DocumentSavingAs' event. When function succeeds, 'true' is returned.

Remarks

None.

See Also

Document Class
SaveAs Overload
Autodesk.Revit Namespace

SaveAs Method (String, Boolean, PostedErrorArray)

[image]