Revit 2010 API
Curve..::.Intersect Method (Curve)
Curve Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve
)
Visual Basic (Declaration)
Public Function Intersect ( _
    curve As Curve _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
The specified curve to intersect with this curve.

Return Value

  • SetComparisonResult.Overlap - One or more intersections were encountered.
  • SetComparisonResult.Subset - The inputs are parallel lines with only one common intersection point, or the curve used to invoke the intersection check is a line entirely within the unbound line passed as argument curve.
  • SetComparisonResult.Superset - The input curve is entirely within the unbound line used to invoke the intersection check.
  • SetComparisonResult.Disjoint - There is no intersection found between the two curves.
  • SetComparisonResult.Equal - The two curves are identical.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The specified curve is null.
System..::.InvalidOperationException | Failed to calculate the intersection.

See Also

Curve Class
Intersect Overload
Autodesk.Revit.Geometry Namespace

Intersect Method (Curve, IntersectionResultArray)

[image]