Revit 2010 API
PointOnEdge Class
Members See Also Send Feedback
Define a ReferencePoint relative to a referenceable edge or curve on another element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PointOnEdge : PointElementReference
Visual Basic (Declaration)
Public Class PointOnEdge _
    Inherits PointElementReference
Visual C++
public ref class PointOnEdge : public PointElementReference

Remarks

The ReferencePoint's X basis vector is constrained to the tangent vector to the curve. The Y and Z vectors are free to rotate around the curve.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Elements..::.PointElementReference
Autodesk.Revit.Elements..::.PointOnEdge

See Also

PointOnEdge Members
Autodesk.Revit.Elements Namespace

PointOnEdge Members

[image] [image]