Revit 2010 API
Plane Constructor (XYZ, XYZ, XYZ)
Plane Class See Also Send Feedback
Constructor for geometry plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Plane(
    XYZ xVec,
    XYZ yVec,
    XYZ origin
)
Visual Basic (Declaration)
Public Sub New ( _
    xVec As XYZ, _
    yVec As XYZ, _
    origin As XYZ _
)
Visual C++
public:
Plane(
    XYZ^ xVec,
    XYZ^ yVec,
    XYZ^ origin
)

Parameters

xVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector for x-axis.
yVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector for y-axis.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The coordinates for the origin.

Remarks

Used to construct a new Plane object.

See Also

Plane Class
Plane Overload
Autodesk.Revit.Geometry Namespace

Plane Methods

[image] [image]