Revit 2010 API
FamilyManager..::.SetFormula Method
FamilyManager Class See Also Send Feedback
Set the formula of a family parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetFormula(
    FamilyParameter familyParameter,
    string formula
)
Visual Basic (Declaration)
Public Sub SetFormula ( _
    familyParameter As FamilyParameter, _
    formula As String _
)
Visual C++
public:
void SetFormula(
    FamilyParameter^ familyParameter,
    String^ formula
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter
The family parameter.
formula
Type: System..::.String
The formula string, input null to clean the formula of the parameter.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.InvalidOperationException | Thrown when the parameter cannot be assigned a formula, or the operation make a circular chain of references among the formulas.

See Also

FamilyManager Class
Autodesk.Revit Namespace

SetParameterLocked Method

[image]