Revit 2010 API
BindingMap Class
Members See Also Send Feedback
The parameters BindingMap contains all the parameter bindings that exist in the Autodesk Revit project.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BindingMap : DefinitionBindingMap
Visual Basic (Declaration)
Public Class BindingMap _
    Inherits DefinitionBindingMap
Visual C++
public ref class BindingMap : public DefinitionBindingMap

Remarks

The ParameterBindingsMap is available from the Document.ParameterBindings property. A parameter binding is the way that a parameter definition is bound to elements within one or more categories. This map can be used to interrogate existing bindings, but it can also be used to generate new parameter bindings by using the Insert method.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Collections..::.DefinitionBindingMap
Autodesk.Revit.Parameters..::.BindingMap

See Also

BindingMap Members
Autodesk.Revit.Parameters Namespace

BindingMap Members

[image] [image]