Revit 2010 API
Document..::.GutterTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the Gutter types that are currently loaded into the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GutterTypeSet GutterTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property GutterTypes As GutterTypeSet
Visual C++
public:
property GutterTypeSet^ GutterTypes {
    GutterTypeSet^ get ();
}

Remarks

This property returns a set of GutterType objects. These objects can be used change the type of a floor from one type to another.

See Also

Document Class
Autodesk.Revit Namespace

IsFamilyDocument Property

[image]