Revit 2010 API
Application Class
Members Example See Also Send Feedback
Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Application : APIObject
Visual Basic (Declaration)
Public Class Application _
    Inherits APIObject
Visual C++
public ref class Application : public APIObject

Examples

CopyC#
string versionInfo = application.VersionBuild + "\n"
                    + application.VersionName + "\n"
                    + application.VersionNumber;
CopyVB.NET
Dim versionInfo As String = ((application.VersionBuild & vbLf) + application.VersionName & vbLf) + application.VersionNumber

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Application

See Also

Application Members
Autodesk.Revit Namespace

Application Members

[image] [image]