Revit 2010 API
Application..::.NewPlane Method (XYZ, XYZ)
Application Class Example See Also Send Feedback
Creates a new geometric plane object based on a normal vector and an origin.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Plane NewPlane(
    XYZ norm,
    XYZ origin
)
Visual Basic (Declaration)
Public Function NewPlane ( _
    norm As XYZ, _
    origin As XYZ _
) As Plane
Visual C++
public:
Plane^ NewPlane(
    XYZ^ norm,
    XYZ^ origin
)

Parameters

norm
Type: Autodesk.Revit.Geometry..::.XYZ
Z vector of the plane coordinate system.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
Origin of the plane coordinate system.

Return Value

Returns a new plane object.

Examples

CopyC#
// Create a geometry plane in revit application
XYZ normal = XYZ.BasisZ;    // use basis of the z-axis (0,0,1) for normal vector
XYZ origin = XYZ.Zero;  // origin is (0,0,0)
Plane geomPlane = application.Create.NewPlane(normal, origin);
CopyVB.NET
' Create a geometry plane in revit application
Dim normal As Autodesk.Revit.Geometry.XYZ = Autodesk.Revit.Geometry.XYZ.BasisZ
' use basis of the z-axis (0,0,1) for normal vector
Dim origin As Autodesk.Revit.Geometry.XYZ = Autodesk.Revit.Geometry.XYZ.Zero
' origin is (0,0,0)
Dim geomPlane As Autodesk.Revit.Geometry.Plane = application.Create.NewPlane(normal, origin)

See Also

Application Class
NewPlane Overload
Autodesk.Revit.Creation Namespace

NewPlane Method (XYZ, XYZ, XYZ)

[image]