Revit 2010 API
FamilyItemFactory..::.NewArcLengthDimension Method (View, Arc, Reference, Reference, Reference)
FamilyItemFactory Class Example See Also Send Feedback
Creates a new arc length dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Dimension NewArcLengthDimension(
    View view,
    Arc arc,
    Reference arcRef,
    Reference firstRef,
    Reference secondRef
)
Visual Basic (Declaration)
Public Function NewArcLengthDimension ( _
    view As View, _
    arc As Arc, _
    arcRef As Reference, _
    firstRef As Reference, _
    secondRef As Reference _
) As Dimension
Visual C++
public:
Dimension^ NewArcLengthDimension(
    View^ view,
    Arc^ arc,
    Reference^ arcRef,
    Reference^ firstRef,
    Reference^ secondRef
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the dimension is to be visible.
arc
Type: Autodesk.Revit.Geometry..::.Arc
The extension arc of the dimension.
arcRef
Type: Autodesk.Revit.Geometry..::.Reference
Geometric reference of the arc to which the dimension is to be bound. This reference must be parallel to the extension arc.
firstRef
Type: Autodesk.Revit.Geometry..::.Reference
The first geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
secondRef
Type: Autodesk.Revit.Geometry..::.Reference
The second geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.

Return Value

If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The currently user set default style is used for the created dimension.

Examples

CopyC#
public Dimension CreateArcDimension(Document document, SketchPlane sketchPlane)
{
    Autodesk.Revit.Creation.Application appCreate = document.Application.Create;
    Line gLine1 = appCreate.NewLine(new XYZ(0, 2, 0), new XYZ(2, 2, 0), true);
    Line gLine2 = appCreate.NewLine(new XYZ(0, 2, 0), new XYZ(2, 4, 0), true);
    Arc arctoDim = appCreate.NewArc(new XYZ(1, 2, 0), new XYZ(-1, 2, 0), new XYZ(0, 3, 0));
    Arc arcofDim = appCreate.NewArc(new XYZ(0, 3, 0), new XYZ(1, 2, 0), new XYZ(0.8, 2.8, 0));

    Autodesk.Revit.Creation.FamilyItemFactory creationFamily = document.FamilyCreate;
    ModelCurve modelCurve1 = creationFamily.NewModelCurve(gLine1, sketchPlane);
    ModelCurve modelCurve2 = creationFamily.NewModelCurve(gLine2, sketchPlane);
    ModelCurve modelCurve3 = creationFamily.NewModelCurve(arctoDim, sketchPlane);
    //get their reference
    Reference ref1 = modelCurve1.GeometryCurve.Reference;
    Reference ref2 = modelCurve2.GeometryCurve.Reference;
    Reference arcRef = modelCurve3.GeometryCurve.Reference;

    Dimension newArcDim = creationFamily.NewArcLengthDimension(document.ActiveView, arcofDim, arcRef, ref1, ref2);
    if (newArcDim == null)
    {
        throw new Exception("Failed to create new arc length dimension.");
    }

    return newArcDim;
}
CopyVB.NET
Public Function CreateArcDimension(ByVal document As Document, ByVal sketchPlane As Autodesk.Revit.Elements.SketchPlane) As Autodesk.Revit.Elements.Dimension
    Dim appCreate As Autodesk.Revit.Creation.Application = document.Application.Create
    Dim gLine1 As Line = appCreate.NewLine(New Autodesk.Revit.Geometry.XYZ(0, 2, 0), _
                                           New Autodesk.Revit.Geometry.XYZ(2, 2, 0), True)
    Dim gLine2 As Line = appCreate.NewLine(New Autodesk.Revit.Geometry.XYZ(0, 2, 0), _
                                           New Autodesk.Revit.Geometry.XYZ(2, 4, 0), True)
    Dim arctoDim As Arc = appCreate.NewArc(New Autodesk.Revit.Geometry.XYZ(1, 2, 0), _
                                           New Autodesk.Revit.Geometry.XYZ(-1, 2, 0), _
                                           New Autodesk.Revit.Geometry.XYZ(0, 3, 0))
    Dim arcofDim As Arc = appCreate.NewArc(New Autodesk.Revit.Geometry.XYZ(0, 3, 0), _
                                           New Autodesk.Revit.Geometry.XYZ(1, 2, 0), _
                                           New Autodesk.Revit.Geometry.XYZ(0.8, 2.8, 0))

    Dim creationFamily As Autodesk.Revit.Creation.FamilyItemFactory = document.FamilyCreate
    Dim modelCurve1 As ModelCurve = creationFamily.NewModelCurve(gLine1, sketchPlane)
    Dim modelCurve2 As ModelCurve = creationFamily.NewModelCurve(gLine2, sketchPlane)
    Dim modelCurve3 As ModelCurve = creationFamily.NewModelCurve(arctoDim, sketchPlane)
    'get their reference
    Dim ref1 As Reference = modelCurve1.GeometryCurve.Reference
    Dim ref2 As Reference = modelCurve2.GeometryCurve.Reference
    Dim arcRef As Reference = modelCurve3.GeometryCurve.Reference

    Dim newArcDim As Autodesk.Revit.Elements.Dimension = creationFamily.NewArcLengthDimension(document.ActiveView, arcofDim, arcRef, ref1, ref2)
    If newArcDim Is Nothing Then
        Throw New Exception("Failed to create new arc length dimension.")
    End If

    Return newArcDim
End Function

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when any input argument is null.
System..::.ArgumentException | Thrown when the argument arcRef/ref1/ref2 is invalid.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewArcLengthDimension Overload
Autodesk.Revit.Creation Namespace

NewArcLengthDimension Method (View, Arc, Reference, Reference, Reference, DimensionType)

[image]