Revit 2010 API
PushButtonData Constructor
PushButtonData Class See Also Send Feedback
Constructs a new instance of PushButtonData.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PushButtonData(
    string name,
    string text,
    string assemblyName,
    string className
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    text As String, _
    assemblyName As String, _
    className As String _
)
Visual C++
public:
PushButtonData(
    String^ name,
    String^ text,
    String^ assemblyName,
    String^ className
)

Parameters

name
Type: System..::.String
The internal name of the new button.
text
Type: System..::.String
The user visible text seen on the new button.
assemblyName
Type: System..::.String
The assembly path of the button.
className
Type: System..::.String
The name of the class containing the implementation for the command.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when null is passed for one or more arguments.
System..::.ArgumentException | Thrown when an empty string is passed for one or more arguments.

See Also

PushButtonData Class
Autodesk.Revit Namespace

PushButtonData Methods

[image] [image]