Revit 2010 API
Document..::.NewFlexDuct Method (Connector, XYZArray, FlexDuctType)
Document Class See Also Send Feedback
Adds a new flex duct into the document, using a connector, point array and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlexDuct NewFlexDuct(
    Connector connector,
    XYZArray points,
    FlexDuctType ductType
)
Visual Basic (Declaration)
Public Function NewFlexDuct ( _
    connector As Connector, _
    points As XYZArray, _
    ductType As FlexDuctType _
) As FlexDuct
Visual C++
public:
FlexDuct^ NewFlexDuct(
    Connector^ connector,
    XYZArray^ points,
    FlexDuctType^ ductType
)

Parameters

connector
Type: Autodesk.Revit.MEP..::.Connector
The connector to be connected to the duct, including the end points.
points
Type: Autodesk.Revit.Geometry..::.XYZArray
The point array indicating the path of the flex duct.
ductType
Type: Autodesk.Revit.MEP..::.FlexDuctType
The type of the flex duct.

Return Value

If creation was successful then a new flex duct is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connector is a fitting or equipment connector of the correct domain, and if the connector’s direction matches the direction of the flex duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument connector or points is null.
System..::.InvalidOperationException | Thrown when the flex duct cannot be created or regenerate fails.

See Also

Document Class
NewFlexDuct Overload
Autodesk.Revit.Creation Namespace

NewFlexDuct Method (Connector, Connector, FlexDuctType)

[image]