Revit 2010 API
MessageBoxData Class
Members See Also Send Feedback
An object that represents a simple message box that prompts the user for some action.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MessageBoxData : DialogBoxData
Visual Basic (Declaration)
Public Class MessageBoxData _
    Inherits DialogBoxData
Visual C++
public ref class MessageBoxData : public DialogBoxData

Remarks

When the application receives this object, a simple message box is displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Events..::.DialogBoxData
Autodesk.Revit.Events..::.MessageBoxData

See Also

MessageBoxData Members
Autodesk.Revit.Events Namespace

MessageBoxData Members

[image] [image]