Revit 2010 API
Connector..::.AssignedPressureDrop Property
Connector Class See Also Send Feedback
The assigned pressure drop of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double AssignedPressureDrop { get; set; }
Visual Basic (Declaration)
Public Property AssignedPressureDrop As Double
Visual C++
public:
property double AssignedPressureDrop {
    double get ();
    void set (double value);
}

Remarks

Assigned pressure drop may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::PipeConnector,Autodesk::Revit::MEP::DuctConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector is not in a family instance. Thrown when the connector's domain is not DomainHvac or DomainPiping.
System..::.ArgumentException | Thrown when set an invalid value.
System..::.InvalidOperationException | Thrown on failure to get or set assigned pressure drop.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

Coefficient Property

[image]