Revit 2010 API
BuiltInCategory Enumeration
See Also Send Feedback
A list of all the built in categories within Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum BuiltInCategory
Visual Basic (Declaration)
Public Enumeration BuiltInCategory
Visual C++
public enum class BuiltInCategory

Members

Member name | Description
OST_IOSTilePatternGrid |
OST_ControlLocal |
OST_ControlAxisZ |
OST_ControlAxisY |
OST_ControlAxisX |
OST_XRayConstrainedProfileEdge |
OST_XRayImplicitPathCurve |
OST_XRayPathPoint |
OST_XRayPathCurve |
OST_XRaySideEdge |
OST_XRayProfileEdge |
OST_ReferencePoints_HiddenLines |
OST_ReferencePoints_Lines |
OST_ReferencePoints_Planes |
OST_ReferencePoints_Points |
OST_ReferencePoints |
OST_IOSNavWheelPivotBall |
OST_IOSRoomComputationHeight |
OST_IOSRoomUpperLowerLines |
OST_IOSDragBoxInverted |
OST_IOSDragBox |
OST_Phases |
OST_IOS_GeoSite |
OST_IOS_GeoLocations |
OST_EPS_Future |
OST_EPS_Temporary |
OST_EPS_New |
OST_EPS_Demolished |
OST_EPS_Existing |
OST_IOSMeasureLineScreenSize |
OST_IOSRebarSystemSpanSymbolCtrl |
OST_IOSRoomTagToRoomLines |
OST_IOSAttachedDetailGroups |
OST_IOSDetailGroups |
OST_IOSModelGroups |
OST_IOSSuspendedSketch |
OST_IOSWallCoreBoundary |
OST_IOSMeasureLine |
OST_IOSArrays |
OST_Curtain_Systems |
OST_IOSBBoxScreenSize |
OST_IOSSlabShapeEditorPointInterior |
OST_IOSSlabShapeEditorPointBoundary |
OST_IOSSlabShapeEditorBoundary |
OST_IOSSlabShapeEditorAutoCrease |
OST_IOSSlabShapeEditorExplitCrease |
OST_IOSNotSilhouette |
OST_IOSRoomPerimeterLines |
OST_IOSCuttingGeometry |
OST_IOSCrashGraphics |
OST_IOSGroups |
OST_IOSGhost |
OST_IOSThinPixel_DashDot |
OST_IOSThinPixel_Dash |
OST_IOSThinPixel_Dot |
OST_IOSThinPixel |
OST_IOSFlipControl |
OST_IOSSketchGrid |
OST_IOSSuspendedSketch_obsolete |
OST_IOSFreeSnapLine |
OST_IOSDatumPlane |
OST_IOSConstructionLine |
OST_IOSAlignmentGraphics |
OST_IOSAligningLine |
OST_IOSBackedUpElements |
OST_IOSRegeneratedElements |
OST_IOSRegenerationFailure |
OST_IOS |
OST_CutOutlines |
OST_StructuralTrussStickSymbols |
OST_StructuralTrussHiddenLines |
OST_TrussChord |
OST_TrussWeb |
OST_TrussBottomChordCurve |
OST_TrussTopChordCurve |
OST_TrussVertWebCurve |
OST_TrussDiagWebCurve |
OST_Truss |
OST_TrussDummy |
OST_MassHiddenLines |
OST_CurtaSystemHiddenLines |
OST_OBSOLETE_ElemArrayHiddenLines |
OST_EntourageHiddenLines |
OST_PlantingHiddenLines |
OST_SpecialityEquipmentHiddenLines |
OST_TopographyHiddenLines |
OST_StructuralFramingSystemHiddenLines |
OST_SiteHiddenLines |
OST_RoadsHiddenLines |
OST_ParkingHiddenLines |
OST_PlumbingFixturesHiddenLines |
OST_MechanicalEquipmentHiddenLines |
OST_LightingFixturesHiddenLines |
OST_FurnitureSystemsHiddenLines |
OST_ElectricalFixturesHiddenLines |
OST_ElectricalEquipmentHiddenLines |
OST_CaseworkHiddenLines |
OST_DetailComponentsHiddenLines |
OST_ShaftOpeningHiddenLines |
OST_GenericModelHiddenLines |
OST_CurtainWallMullionsHiddenLines |
OST_CurtainWallPanelsHiddenLines |
OST_RampsHiddenLines |
OST_StairsRailingHiddenLines |
OST_StairsHiddenLines |
OST_ColumnsHiddenLines |
OST_FurnitureHiddenLines |
OST_LinesHiddenLines |
OST_CeilingsHiddenLines |
OST_RoofsHiddenLines |
OST_DoorsHiddenLines |
OST_WindowsHiddenLines |
OST_StructConnectionTags |
OST_StructWeldLines |
OST_StructConnections |
OST_AreaReinTags |
OST_RebarTags |
OST_CoverType |
OST_RebarShape |
OST_PathReinBoundary |
OST_PathReinTags |
OST_PathReinSpanSymbol |
OST_PathRein |
OST_Cage |
OST_AreaReinXVisibility |
OST_AreaReinBoundary |
OST_AreaReinSpanSymbol |
OST_AreaReinSketchOverride |
OST_AreaRein |
OST_RebarLines |
OST_RebarSketchLines |
OST_Rebar |
OST_DuctLinings |
OST_DuctInsulations |
OST_PipeInsulations |
OST_HVAC_Load_Schedules |
OST_HVAC_Load_Building_Types |
OST_HVAC_Load_Space_Types |
OST_HVAC_Zones_Reference_Visibility |
OST_HVAC_Zones_InteriorFill_Visibility |
OST_HVAC_Zones_ColorFill |
OST_ZoneTags |
OST_LayoutPath_Bases |
OST_WireTemperatureRatings |
OST_WireInsulations |
OST_WireMaterials |
OST_HVAC_Zones_Reference |
OST_HVAC_Zones_InteriorFill |
OST_HVAC_Zones_Boundary |
OST_HVAC_Zones |
OST_Fluids |
OST_PipeSchedules |
OST_PipeMaterials |
OST_PipeConnections |
OST_EAConstructions |
OST_SwitchSystem |
OST_SprinklerTags |
OST_Sprinklers |
OST_RouteCurveBranch |
OST_RouteCurveMain |
OST_RouteCurve |
OST_GbXML_Opening |
OST_GbXML_SType_Underground |
OST_GbXML_SType_Shade |
OST_GbXML_SType_Exterior |
OST_GbXML_SType_Interior |
OST_GbXMLFaces |
OST_WireHomeRunArrows |
OST_LightingDeviceTags |
OST_LightingDevices |
OST_FireAlarmDeviceTags |
OST_FireAlarmDevices |
OST_DataDeviceTags |
OST_DataDevices |
OST_CommunicationDeviceTags |
OST_CommunicationDevices |
OST_SecurityDeviceTags |
OST_SecurityDevices |
OST_NurseCallDeviceTags |
OST_NurseCallDevices |
OST_TelephoneDeviceTags |
OST_TelephoneDevices |
OST_WireTickMarks |
OST_PipeFittingInsulation |
OST_PipeFittingCenterLine |
OST_FlexPipeCurvesInsulation |
OST_PipeCurvesInsulation |
OST_PipeCurvesDrop |
OST_DuctFittingLining |
OST_DuctFittingInsulation |
OST_DuctFittingCenterLine |
OST_FlexDuctCurvesInsulation |
OST_DuctCurvesLining |
OST_DuctCurvesInsulation |
OST_DuctCurvesDrop |
OST_DuctFittingTags |
OST_PipeFittingTags |
OST_PipeColorFills |
OST_PipeColorFillLegends |
OST_WireTags |
OST_PipeAccessoryTags |
OST_PipeAccessory |
OST_PipeCurvesRiseDrop |
OST_FlexPipeCurvesPattern |
OST_FlexPipeCurvesContour |
OST_FlexPipeCurvesCenterLine |
OST_FlexPipeCurves |
OST_PipeFitting |
OST_FlexPipeTags |
OST_PipeTags |
OST_PipeCurvesContour |
OST_PipeCurvesCenterLine |
OST_PipeCurves |
OST_PipingSystem |
OST_ElectricalDemandFactor |
OST_ElecDistributionSys |
OST_ElectricalVoltage |
OST_Wire |
OST_ElectricalCircuitTags |
OST_ElectricalCircuit |
OST_DuctCurvesRiseDrop |
OST_FlexDuctCurvesPattern |
OST_FlexDuctCurvesContour |
OST_FlexDuctCurvesCenterLine |
OST_FlexDuctCurves |
OST_DuctAccessoryTags |
OST_DuctAccessory |
OST_DuctSystem |
OST_DuctTerminalTags |
OST_DuctTerminal |
OST_DuctFitting |
OST_FlexDuctTags |
OST_DuctTags |
OST_DuctCurvesContour |
OST_DuctCurvesCenterLine |
OST_DuctCurves |
OST_DuctColorFills |
OST_DuctColorFillLegends |
OST_ConnectorElemZAxis |
OST_ConnectorElemYAxis |
OST_ConnectorElemXAxis |
OST_ConnectorElem |
OST_DesignOptions |
OST_DesignOptionSets |
OST_StructuralBracePlanReps |
OST_StructuralConnections |
OST_StructuralAnnotations |
OST_RevisionCloudTags |
OST_Revisions |
OST_RevisionClouds |
OST_EditCutProfile |
OST_GridHeads |
OST_LevelHeads |
OST_DecalType |
OST_DecalElement |
OST_VolumeOfInterest |
OST_BoundaryConditions |
OST_InternalAreaLoadTags |
OST_InternalLineLoadTags |
OST_InternalPointLoadTags |
OST_AreaLoadTags |
OST_LineLoadTags |
OST_PointLoadTags |
OST_LoadCasesSeismic |
OST_LoadCasesTemperature |
OST_LoadCasesAccidental |
OST_LoadCasesRoofLive |
OST_LoadCasesSnow |
OST_LoadCasesWind |
OST_LoadCasesLive |
OST_LoadCasesDead |
OST_LoadCases |
OST_InternalAreaLoads |
OST_InternalLineLoads |
OST_InternalPointLoads |
OST_InternalLoads |
OST_AreaLoads |
OST_LineLoads |
OST_PointLoads |
OST_Loads |
OST_BeamSystemTags |
OST_FootingSpanDirectionSymbol |
OST_SpanDirectionSymbol |
OST_SpotSlopesSymbols |
OST_SpotCoordinateSymbols |
OST_SpotElevSymbols |
OST_TrussTags |
OST_KeynoteTags |
OST_DetailComponentTags |
OST_MaterialTags |
OST_FloorTags |
OST_CurtaSystemTags |
OST_HostFinTags |
OST_StairTags |
OST_MultiCategoryTags |
OST_PlantingTags |
OST_AreaTags |
OST_StructuralFoundationTags |
OST_StructuralColumnTags |
OST_ParkingTags |
OST_SiteTags |
OST_StructuralFramingTags |
OST_SpecialityEquipmentTags |
OST_GenericModelTags |
OST_CurtainWallPanelTags |
OST_WallTags |
OST_PlumbingFixtureTags |
OST_MechanicalEquipmentTags |
OST_LightingFixtureTags |
OST_FurnitureSystemTags |
OST_FurnitureTags |
OST_ElectricalFixtureTags |
OST_ElectricalEquipmentTags |
OST_CeilingTags |
OST_CaseworkTags |
OST_Tags |
OST_PreviewLegendComponents |
OST_LegendComponents |
OST_ScheduleGraphics |
OST_RasterImages |
OST_ColorFillSchema |
OST_RoomColorFill |
OST_ColorFillLegends |
OST_AnnotationCropSpecial |
OST_CropBoundarySpecial |
OST_AnnotationCrop |
OST_CalloutLeaderLine |
OST_CalloutBoundary |
OST_CalloutHeads |
OST_Callouts |
OST_CropBoundary |
OST_Elev |
OST_AxisZ |
OST_AxisY |
OST_AxisX |
OST_ReferenceLines |
OST_CLines |
OST_Lights |
OST_ViewportLabel |
OST_Viewports |
OST_Camera_Lines |
OST_Cameras |
OST_MEPSpaceTags |
OST_RoomTags |
OST_DoorTags |
OST_WindowTags |
OST_SectionHeadWideLines |
OST_SectionHeadMediumLines |
OST_SectionHeadThinLines |
OST_SectionHeads |
OST_ContourLabels |
OST_RenderRegions |
OST_SectionBox |
OST_TextNotes |
OST_Catalogs |
OST_DirectionEdgeLines |
OST_CenterLines |
OST_LinesBeyond |
OST_HiddenLines |
OST_DemolishedLines |
OST_OverheadLines |
OST_TitleBlockWideLines |
OST_TitleBlockMediumLines |
OST_TitleBlockThinLines |
OST_TitleBlocks |
OST_Views |
OST_Viewers |
OST_RoofTags |
OST_SpotSlopes |
OST_SpotCoordinates |
OST_SpotElevations |
OST_Constraints |
OST_WeakDims |
OST_Dimensions |
OST_DatumLevels |
OST_Levels |
OST_Grids |
OST_BrokenSectionLine |
OST_SectionLine |
OST_Sections |
OST_MEPSpaceColorFill |
OST_MEPSpaceReference |
OST_MEPSpaceInteriorFill |
OST_MEPSpaceReferenceVisibility |
OST_MEPSpaceInteriorFillVisibility |
OST_MEPSpaces |
OST_StackedWalls |
OST_StackedWalls_Obsolete_IdInWrongRange |
OST_MassAreaFaceTags |
OST_HostTemplate |
OST_MassFaceSplitter |
OST_MassCutter |
OST_ZoningEnvelope |
OST_MassTags |
OST_MassSurface |
OST_MassAreaFaces |
OST_Mass |
OST_MassTags_Obsolete_IdInWrongRange |
OST_MassSurface_Obsolete_IdInWrongRange |
OST_MassAreaFaces_Obsolete_IdInWrongRange |
OST_Mass_Obsolete_IdInWrongRange |
OST_ZoneSchemes |
OST_AreaSchemes |
OST_Areas |
OST_ProjectInformation |
OST_Sheets |
OST_ProfileFamilies |
OST_DetailComponents |
OST_RoofSoffit |
OST_EdgeSlab |
OST_Gutter |
OST_Fascia |
OST_Entourage |
OST_Planting |
OST_StructuralStiffenerTags |
OST_StructuralStiffener |
OST_FootingAnalyticalGeometry |
OST_RvtLinks |
OST_Automatic |
OST_SpecialityEquipment |
OST_ColumnAnalyticalRigidLinks |
OST_SecondaryTopographyContours |
OST_TopographyContours |
OST_TopographySurface |
OST_Topography |
OST_StructuralTruss |
OST_StructuralColumnStickSymbols |
OST_HiddenStructuralColumnLines |
OST_AnalyticalRigidLinks |
OST_ColumnAnalyticalGeometry |
OST_FramingAnalyticalGeometry |
OST_StructuralColumns |
OST_HiddenStructuralFramingLines |
OST_KickerBracing |
OST_StructuralFramingSystem |
OST_VerticalBracing |
OST_HorizontalBracing |
OST_Purlin |
OST_Joist |
OST_Girder |
OST_StructuralFramingOther |
OST_StructuralFraming |
OST_HiddenStructuralFoundationLines |
OST_StructuralFoundation |
OST_BasePointAxisZ |
OST_BasePointAxisY |
OST_BasePointAxisX |
OST_SharedBasePoint |
OST_ProjectBasePoint |
OST_SiteRegion |
OST_SitePropertyLineSegmentTags |
OST_SitePropertyLineSegment |
OST_SitePropertyTags |
OST_SitePointBoundary |
OST_SiteProperty |
OST_BuildingPad |
OST_SitePoint |
OST_SiteSurface |
OST_Site |
OST_HiddenBuildingUnitLines |
OST_BuildingUnits |
OST_Sewer |
OST_Roads |
OST_Property |
OST_Parking |
OST_PlumbingFixtures |
OST_MechanicalEquipment |
OST_LightingFixtureSource |
OST_LightingFixtures |
OST_FurnitureSystems |
OST_ElectricalFixtures |
OST_ElectricalEquipment |
OST_Casework |
OST_GenericModel |
OST_GenericAnnotation |
OST_Materials |
OST_AreaReport_Arc_Minus |
OST_AreaReport_Arc_Plus |
OST_AreaReport_Boundary |
OST_AreaReport_Triangle |
OST_CurtaSystemFaceManager |
OST_CurtaSystem |
OST_DetailArray |
OST_ModelArray |
OST_HostFinHF |
OST_HostFinWall |
OST_HostFinCeiling |
OST_HostFinRoof |
OST_HostFinFloor |
OST_HostFin |
OST_ReferenceViewer |
OST_ReferenceViewerSymbol |
OST_ImportObjectStyles |
OST_ModelText |
OST_MaskingRegion |
OST_Matchline |
OST_FaceSplitter |
OST_PlanRegion |
OST_FilledRegion |
OST_MassingProjectionOutlines |
OST_MassingCutOutlines |
OST_Massing |
OST_Reveals |
OST_Cornices |
OST_RampsDownArrow |
OST_RampsUpArrow |
OST_RampsDownText |
OST_RampsUpText |
OST_RampsStringerAboveCut |
OST_RampsStringer |
OST_RampsAboveCut |
OST_RampsIncomplete |
OST_Ramps |
OST_RailingBalusterRailCut |
OST_RailingBalusterRail |
OST_Railings |
OST_CurtainGridsCurtaSystem |
OST_CurtainGridsSystem |
OST_CurtainGridsWall |
OST_CurtainGridsRoof |
OST_CurtainGrids |
OST_CurtainWallMullionsCut |
OST_CurtainWallMullions |
OST_CurtainWallPanels |
OST_AreaReference |
OST_AreaInteriorFill |
OST_RoomReference |
OST_RoomInteriorFill |
OST_AreaColorFill |
OST_AreaReferenceVisibility |
OST_AreaInteriorFillVisibility |
OST_RoomReferenceVisibility |
OST_RoomInteriorFillVisibility |
OST_Rooms |
OST_Fixtures |
OST_StairsRailingTags |
OST_StairsRailingAboveCut |
OST_StairsRailingRail |
OST_StairsRailingBaluster |
OST_StairsRailing |
OST_StairsDownArrow |
OST_StairsUpArrow |
OST_StairsDownText |
OST_StairsUpText |
OST_StairsStringerAboveCut |
OST_StairsStringer |
OST_StairsAboveCut |
OST_StairsIncomplete |
OST_Stairs |
OST_Columns |
OST_Furniture |
OST_Extrusions |
OST_FillPatterns |
OST_DividedSurfaceBelt |
OST_TilePatterns |
OST_AlwaysExcludedInAllViews |
OST_DividedSurface_TransparentFace |
OST_DividedSurface_PreDividedSurface |
OST_DividedSurface_PatternFill |
OST_DividedSurface_PatternLines |
OST_DividedSurface_Gridlines |
OST_DividedSurface_Nodes |
OST_DividedSurface |
OST_MEPSpaceSeparationLines |
OST_AreaPolylines |
OST_RoomPolylines |
OST_InstanceDrivenLineStyle |
OST_StickSymbols_Obsolete_IdInWrongRange |
OST_RemovedGridSeg |
OST_RemovedGridSeg_Obsolete_IdInWrongRange |
OST_RepeatingDetailLines |
OST_AreaSchemeLines |
OST_GenericLines |
OST_InsulationLines |
OST_CloudLines |
OST_StairsLandingCenterLines |
OST_StairsRunLines |
OST_StairsRiserLines |
OST_StairsBoundaryLines |
OST_AreaSeparationLines |
OST_AxisOfRotation |
OST_InvisibleLines |
OST_SketchLines |
OST_CurvesWideLines |
OST_CurvesMediumLines |
OST_CurvesThinLines |
OST_Curves |
OST_Lines |
OST_CeilingsSurfacePattern |
OST_CeilingsProjection |
OST_CeilingsCut |
OST_Ceilings |
OST_RoofsSurfacePattern |
OST_RoofsProjection |
OST_RoofsCut |
OST_Roofs |
OST_FloorsAnalyticalGeometry |
OST_FloorsSurfacePattern |
OST_FloorsProjection |
OST_FloorsCut |
OST_Floors |
OST_DoorsGlassProjection |
OST_DoorsGlassCut |
OST_DoorsFrameMullionProjection |
OST_DoorsFrameMullionCut |
OST_DoorsOpeningProjection |
OST_DoorsOpeningCut |
OST_DoorsPanelProjection |
OST_DoorsPanelCut |
OST_Doors |
OST_WindowsOpeningProjection |
OST_WindowsOpeningCut |
OST_WindowsSillHeadProjection |
OST_WindowsSillHeadCut |
OST_WindowsFrameMullionProjection |
OST_WindowsFrameMullionCut |
OST_WindowsGlassProjection |
OST_WindowsGlassCut |
OST_Windows |
OST_ColumnOpening |
OST_StructuralFramingOpening |
OST_ShaftOpening |
OST_CeilingOpening |
OST_FloorOpening |
OST_DormerOpeningIncomplete |
OST_RoofOpening |
OST_SWallRectOpening |
OST_ArcWallRectOpening |
OST_WallRefPlanes |
OST_WallRefPlanes_Obsolete_IdInWrongRange |
OST_CeilingsCutPattern |
OST_CeilingsDefault |
OST_CeilingsFinish2 |
OST_CeilingsFinish1 |
OST_CeilingsSubstrate |
OST_CeilingsInsulation |
OST_CeilingsStructure |
OST_CeilingsMembrane |
OST_FloorsInteriorEdges |
OST_FloorsCutPattern |
OST_HiddenFloorLines |
OST_FloorsDefault |
OST_FloorsFinish2 |
OST_FloorsFinish1 |
OST_FloorsSubstrate |
OST_FloorsInsulation |
OST_FloorsStructure |
OST_FloorsMembrane |
OST_RoofsInteriorEdges |
OST_RoofsCutPattern |
OST_RoofsDefault |
OST_RoofsFinish2 |
OST_RoofsFinish1 |
OST_RoofsSubstrate |
OST_RoofsInsulation |
OST_RoofsStructure |
OST_RoofsMembrane |
OST_WallsCutPattern |
OST_HiddenWallLines |
OST_WallsDefault |
OST_WallsFinish2 |
OST_WallsFinish1 |
OST_WallsSubstrate |
OST_WallsInsulation |
OST_WallsStructure |
OST_WallsMembrane |
OST_WallsSurfacePattern |
OST_WallsAnalyticalGeometry |
OST_WallsProjectionOutlines |
OST_WallsCutOutlines |
OST_Walls |
OST_MatchSiteComponent |
OST_MatchProfile |
OST_MatchDetail |
OST_MatchAnnotation |
OST_MatchModel |
OST_MatchAll |
INVALID |

See Also

Autodesk.Revit Namespace

ButtonData Class

[image]