Revit 2010 API
TemperatureRatingType Properties
TemperatureRatingType Class See Also Send Feedback

The TemperatureRatingType type exposes the following members.

Properties

Name | Description
CorrectionFactors | Get all correction factors defined in this temperature rating type and its corresponding material type.
InsulationTypes | Get all insulation types defined in this temperature rating type and its corresponding material type.
IsInUse | Indicate whether the temperature rating type is in use.
MaterialType | Get the material type information which this temperature rating type belongs to.
Name | Get name of temperature rating type. (Overrides Element..::.Name.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
WireSizes | Get all electrical wire sizes defined in this temperature rating type and its corresponding material type.

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace

CorrectionFactors Property

[image]