Revit 2010 API
BoundaryConditions..::.Curve Property
BoundaryConditions Class See Also Send Feedback
Returns the geometric curve within a geometric loop that defines the area.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve Curve[
    int curveIndex
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve ( _
    curveIndex As Integer _
) As Curve
Visual C++
public:
property Curve^ Curve[int curveIndex] {
    Curve^ get (int curveIndex);
}

Parameters

curveIndex
Type: System..::.Int32
The index curve in the BoundaryConditions.

Return Value

If successful, returns the curve pointer. Otherwise returns nullptr.

Remarks

The curve index should be between 0 and NumCurves-1.

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace

HostElement Property

[image]