Revit 2010 API
CurveByPoints..::.SketchPlane Property
CurveByPoints Class See Also Send Feedback
Override the SketchPlane property of CurveElement.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override SketchPlane SketchPlane { get; set; }
Visual Basic (Declaration)
Public Overrides Property SketchPlane As SketchPlane
Visual C++
public:
virtual property SketchPlane^ SketchPlane {
    SketchPlane^ get () override;
    void set (SketchPlane^ value) override;
}

Remarks

CurveByPoints has no associated SketchPlane. Getting this property returns null. Setting it causes an InvalidOperationException.

See Also

CurveByPoints Class
Autodesk.Revit.Elements Namespace

Subcategory Property

[image]