Revit 2010 API
FamilyInstance..::.AnalyticalModel Property
FamilyInstance Class See Also Send Feedback
Retrieves the structural analytical model for the family instance.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public AnalyticalModel AnalyticalModel { get; }
Visual Basic (Declaration)
Public ReadOnly Property AnalyticalModel As AnalyticalModel
Visual C++
public:
property AnalyticalModel^ AnalyticalModel {
    AnalyticalModel^ get ();
}

Remarks

If the family instance has a structural analytical model it is returned by this method, otherwise Nothing is returned. Different types of analytical model will be returned based on the type of the instance, for example - if the instance is a beam then a frame analytical model will be returned. If the instance is a footing then a location analytical model will be returned. This property will only function with the Autodesk Revit Structure product.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace

CanFlipFacing Property

[image]