Revit 2010 API
Family Members
Family Class Constructors Methods Properties See Also Send Feedback

The Family type exposes the following members.

Constructors

Name | Description
Family | For Internal Use Only.

Methods

Name | Description

Properties

Name | Description
CurtainPanelHorizontalSpacing | For Curtain Panel families, the horizontal spacing of the driving mesh.
CurtainPanelTilePattern | For Curtain Panel families, the choice of tile pattern.
CurtainPanelVerticalSpacing | For Curtain Panel families, the vertical spacing of the driving mesh.
IsConceptualMassFamily | Whether the Family is a Conceptual Mass family.
IsCurtainPanelFamily | Whether the Family is a Curtain Panel family. Curtain Panel family symbols are used as the ObjectTypes of DividedSurface elements.
IsInPlace | Indicates if this family is an in-place family or not.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Symbols | A set of all symbols (types) that belong to a Family.

See Also

Family Class
Autodesk.Revit.Elements Namespace

Family Constructor

[image]