Revit 2010 API
UV..::.Item Property
UV Class See Also Send Feedback
Indexed access to coordinates.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double this[
    int idx
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    idx As Integer _
) As Double
Visual C++
public:
property double default[int idx] {
    double get (int idx);
    void set (int idx, double value);
}

Parameters

idx
Type: System..::.Int32
Use 0 for U and 1 for V.

Exceptions

Exception | Condition
System..::.IndexOutOfRangeException | Thrown when an attempt is made to access coordinates with an index that is larger than 1.
System..::.NotFiniteNumberException | Thrown when setting an infinite number to the U or V property.

See Also

UV Class
Autodesk.Revit.Geometry Namespace

Length Property

[image]