Revit 2010 API
SlabShapeEditor..::.DrawSplitLine Method
SlabShapeEditor Class See Also Send Feedback
Draws a split line on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabShapeCreaseArray DrawSplitLine(
    SlabShapeVertex startVertex,
    SlabShapeVertex endVertex
)
Visual Basic (Declaration)
Public Function DrawSplitLine ( _
    startVertex As SlabShapeVertex, _
    endVertex As SlabShapeVertex _
) As SlabShapeCreaseArray
Visual C++
public:
SlabShapeCreaseArray^ DrawSplitLine(
    SlabShapeVertex^ startVertex,
    SlabShapeVertex^ endVertex
)

Parameters

startVertex
Type: Autodesk.Revit.Editor..::.SlabShapeVertex
The vertex to start the split line.
endVertex
Type: Autodesk.Revit.Editor..::.SlabShapeVertex
The vertex to end the split line.

Return Value

The newly created creases.

Remarks

Drawing a split line may result in multiple creases, for example when the line crosses existing creases or boundary edges.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input vertex is nullptr.
System..::.ArgumentException | Thrown when the input vertex is invalid.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace

Enable Method

[image]