Revit 2010 API
Document..::.Rotate Method (Element, Line, Double)
Document Class Example See Also Send Feedback
Rotates an element within the document by a specified number of degrees around a given axis.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Rotate(
    Element element,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    element As Element, _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate(
    Element^ element,
    Line^ axis,
    double angle
)

Parameters

element
Type: Autodesk.Revit..::.Element
The element that is to be rotated.
axis
Type: Autodesk.Revit.Geometry..::.Line
A line that represents the axis of rotation, which can be either bounded or unbounded line.
angle
Type: System..::.Double
The number of degrees, in radians, by which the element is to be rotated around the specified axis.

Return Value

If the element is rotate successfully then the method returns True, otherwise False.

Remarks

The rotate method is used to rotate an element within the project. Other elements may also be rotated when this element is rotated because they are dependent upon the element being rotated. The line used as the axis can be created by using the Application.Create object and its methods.

Examples

CopyC#
public bool RotateColumn(Autodesk.Revit.Document document, Autodesk.Revit.Element element)
{
    XYZ point1 = new XYZ(10, 20, 0);
    XYZ point2 = new XYZ(10, 20, 30);
    // The axis should be a bound line.
    Line axis = document.Application.Create.NewLineBound(point1, point2);
    bool successful = document.Rotate(element, axis, Math.PI / 3.0);

    return successful;
}
CopyVB.NET
Public Function RotateColumn(ByVal document As Autodesk.Revit.Document, ByVal element As Autodesk.Revit.Element) As Boolean
    Dim point1 As New Autodesk.Revit.Geometry.XYZ(10, 20, 0)
    Dim point2 As New Autodesk.Revit.Geometry.XYZ(10, 20, 30)
    ' The axis should be a bound line.
    Dim axis As Line = document.Application.Create.NewLineBound(point1, point2)
    Dim successful As Boolean = document.Rotate(element, axis, Math.PI / 3.0R)

    Return successful
End Function

See Also

Document Class
Rotate Overload
Autodesk.Revit Namespace

Rotate Method (ElementId, Line, Double)

[image]