Revit 2010 API
Opening Class
Members Example See Also Send Feedback
An opening in an Autodesk Revit project or family document.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Opening : Element
Visual Basic (Declaration)
Public Class Opening _
    Inherits Element
Visual C++
public ref class Opening : public Element

Remarks

The object represents a variety of different types of openings:
  • A rectangular opening in a wall created by two boundary points in a revit project.
  • An opening created by a set of curves applied to a roof, floor, ceiling, beam, brace or column.
  • A vertical shaft opening extending one or more levels.
  • A simple opening created on a wall or ceiling in a family document.
Depending upon the type of opening, some of the properties of this class will not be available.

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object also supports access to a structural analytical model but this feature is only available with Autodesk Revit Structure.

Examples

CopyC#
private void Getinfo_Opening(Opening opening)
{
    string message = "Opening:";

    //get the host element of this opening
    message += "\nThe id of the opening's host element is : " + opening.Host.Id.Value;

    //get the information whether the opening has a rect boundary
    //If the opening has a rect boundary, we can get the geometry information from BoundaryRect property.
    //Otherwise we should get the geometry information from BoundaryCurves property
    if (opening.IsRectBoundary)
    {
        message += "\nThe opening has a rectangular boundary.";
        //array contains two XYZ objects: the max and min coords of boundary
        XYZArray boundaryRect = opening.BoundaryRect;

        //get the coordinate value of the min coordinate point
        XYZ point = opening.BoundaryRect.get_Item(0);
        message += "\nMin coordinate point:(" + point.X + ", "
                                + point.Y + ", " + point.Z + ")";

        //get the coordinate value of the Max coordinate point
        point = opening.BoundaryRect.get_Item(1);
        message += "\nMax coordinate point: (" + point.X + ", "
                                + point.Y + ", " + point.Z + ")";
    }
    else
    {
        message += "\nThe opening doesn't have a rectangular boundary.";
        // Get curve number
        int curves = opening.BoundaryCurves.Size;
        message += "\nNumber of curves is : " + curves;
        for (int i = 0; i < curves; i++)
        {
            Autodesk.Revit.Geometry.Curve curve = opening.BoundaryCurves.get_Item(i);
            // Get curve start point
            message += "\nCurve start point: " + XYZToString(curve.get_EndPoint(0));
            // Get curve end point
            message += "; Curve end point: " + XYZToString(curve.get_EndPoint(1));
        }
    }
    MessageBox.Show(message, "Revit");
}

// output the point's three coordinates
string XYZToString(XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
CopyVB.NET
Private Sub Getinfo_Opening(ByVal opening As Autodesk.Revit.Elements.Opening)
    Dim message As String = "Opening:"

    'get the host element of this opening
    message += vbLf & "The id of the opening's host element is : " & opening.Host.Id.Value

    'get the information whether the opening has a rect boundary
    'If the opening has a rect boundary, we can get the geometry information from BoundaryRect property.
    'Otherwise we should get the geometry information from BoundaryCurves property
    If opening.IsRectBoundary Then
        message += vbLf & "The opening has a rectangular boundary."
        'array contains two XYZ objects: the max and min coords of boundary
        Dim boundaryRect As XYZArray = opening.BoundaryRect

        'get the coordinate value of the min coordinate point
        Dim point As Autodesk.Revit.Geometry.XYZ = opening.BoundaryRect.Item(0)
        message += ((vbLf & "Min coordinate point:(" & point.X & ", ") + point.Y & ", ") + point.Z & ")"

        'get the coordinate value of the Max coordinate point
        point = opening.BoundaryRect.Item(1)
        message += ((vbLf & "Max coordinate point: (" & point.X & ", ") + point.Y & ", ") + point.Z & ")"
    Else
        message += vbLf & "The opening doesn't have a rectangular boundary."
        ' Get curve number
        Dim curves As Integer = opening.BoundaryCurves.Size
        message += vbLf & "Number of curves is : " & curves
        For i As Integer = 0 To curves - 1
            Dim curve As Autodesk.Revit.Geometry.Curve = opening.BoundaryCurves.Item(i)
            ' Get curve start point
            message += vbLf & "Curve start point: " & XYZToString(curve.EndPoint(0))
            ' Get curve end point
            message += "; Curve end point: " & XYZToString(curve.EndPoint(1))
        Next
    End If
    MessageBox.Show(message, "Revit")
End Sub

' output the point's three coordinates
Private Function XYZToString(ByVal point As Autodesk.Revit.Geometry.XYZ) As String
    Return (("(" & point.X & ", ") + point.Y & ", ") + point.Z & ")"
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Opening

See Also

Opening Members
Autodesk.Revit.Elements Namespace

Opening Members

[image] [image]