Revit 2010 API
RebarBarType Members
RebarBarType Class Constructors Methods Properties See Also Send Feedback

The RebarBarType type exposes the following members.

Constructors

Name | Description
RebarBarType | For Internal Use Only.

Methods

Name | Description
GetAutoCalcHookLengths | Whether hook lengths are automatically calculated.
SetAutoCalcHookLengths | Specify whether hook lengths are automatically calculated.

Properties

Name | Description
HookLength | Access to length data in the hook lengths map.
HookOffsetLength | Access to offset length data in the hook lengths map.
HookPermission | Access to permission data in the hook lengths map.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.

See Also

RebarBarType Class
Autodesk.Revit.Symbols Namespace

RebarBarType Constructor

[image]