Revit 2010 API
Line..::.Bound Property
Line Class See Also Send Feedback
Returns the bounded line between the specified points.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static Line Bound[
    XYZ startPoint,
    XYZ endPoint
] { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Bound ( _
    startPoint As XYZ, _
    endPoint As XYZ _
) As Line
Visual C++
public:
static property Line^ Bound[XYZ^ startPoint, XYZ^ endPoint] {
    Line^ get (XYZ^ startPoint, XYZ^ endPoint);
}

Parameters

startPoint
Type: Autodesk.Revit.Geometry..::.XYZ
The start point of the line.
endPoint
Type: Autodesk.Revit.Geometry..::.XYZ
The end point of the line.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the specified points are almost equal.

See Also

Line Class
Autodesk.Revit.Geometry Namespace

Unbound Property

[image]