Revit 2010 API
RibbonPanel Members
RibbonPanel Class Methods Properties See Also Send Feedback

The RibbonPanel type exposes the following members.

Methods

Name | Description
AddButton | Adds a button to the panel.
AddPulldownButton | Adds a PulldownButton to the panel.
AddPushButton | Adds a PushButton to the panel.
AddSeparator | Adds a new Separator to the panel.
AddStackedButtons | Overloaded.
AddToPulldown | Adds a pushbutton to the existing PulldownButton.
Equals | Returns a value whether the panel equals to another panel. (Overrides Object..::.Equals(Object).)

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the RibbonPanel can respond to user interaction.
Items | Gets the collection of RibbonItems assigned to the RibbonPanel.
Name | Gets or sets the name of the RibbonPanel.
Title | Gets or sets the text of the RibbonPanel.
Visible | Gets or sets a value indicating whether the RibbonPanel is displayed.

See Also

RibbonPanel Class
Autodesk.Revit Namespace

RibbonPanel Methods

[image] [image]