Revit 2010 API
Transform..::.OfVector Method
Transform Class See Also Send Feedback
Applies the transform to the vector

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ OfVector(
    XYZ vec
)
Visual Basic (Declaration)
Public Function OfVector ( _
    vec As XYZ _
) As XYZ
Visual C++
public:
XYZ^ OfVector(
    XYZ^ vec
)

Parameters

vec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector to be transformed

Return Value

The new vector after transform

Remarks

Transformation of a vector is not affected by the translational part of the transformation.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace

ScaleBasis Method

[image]