Revit 2010 API
BeamSystem..::.GetAllBeams Method
BeamSystem Class See Also Send Feedback
Get all the beams of the BeamSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet GetAllBeams()
Visual Basic (Declaration)
Public Function GetAllBeams As ElementSet
Visual C++
public:
ElementSet^ GetAllBeams()

Return Value

The beams.

Remarks

Beam is a FamilyInstance.

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace

BeamSystem Properties

[image] [image]