Revit 2010 API
LightingDevice Class
Members See Also Send Feedback
Provides access to the Lighting Device in Autodesk Revit MEP.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LightingDevice : MEPModel
Visual Basic (Declaration)
Public Class LightingDevice _
    Inherits MEPModel
Visual C++
public ref class LightingDevice : public MEPModel

Remarks

The Lighting Device object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.MEP..::.MEPModel
Autodesk.Revit.MEP..::.LightingDevice

See Also

LightingDevice Members
Autodesk.Revit.MEP Namespace

LightingDevice Members

[image] [image]