Revit 2010 API
CompoundStructureLayer..::.Thickness Property
CompoundStructureLayer Class See Also Send Feedback
Retrieve or modify the thickness of the layer.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Thickness { get; set; }
Visual Basic (Declaration)
Public Property Thickness As Double
Visual C++
public:
property double Thickness {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the input argument thickness is invalid for the layer in set method.
System..::.ArgumentOutOfRangeException | Thrown when the input argument thickness is less than 0 in set method.
System..::.InvalidOperationException | Thrown when set operation failed.

See Also

CompoundStructureLayer Class
Autodesk.Revit.Structural Namespace

Variable Property

[image]