Revit 2010 API
ProjectPosition Constructor (Double, Double, Double, Double)
ProjectPosition Class See Also Send Feedback
Construct a new ProjectPosition object with the specified East/West offset, North/South offset, elevation offset and angle of rotation

Namespace: Autodesk.Revit.Site
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)
Visual Basic (Declaration)
Public Sub New ( _
    ew As Double, _
    ns As Double, _
    elevation As Double, _
    angle As Double _
)
Visual C++
public:
ProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)

Parameters

ew
Type: System..::.Double
East/West offset
ns
Type: System..::.Double
North/South offset
elevation
Type: System..::.Double
Elevation offset
angle
Type: System..::.Double
Rotation from true north, in radians.

Remarks

The angle can be in the range of +PI to -PI

See Also

ProjectPosition Class
ProjectPosition Overload
Autodesk.Revit.Site Namespace

ProjectPosition Methods

[image] [image]