Revit 2010 API
SuspendUpdating Constructor
SuspendUpdating Class See Also Send Feedback
Create a new instance of the SuspendUpdating object and begin suspension of consistency updates.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SuspendUpdating(
    Document document
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document _
)
Visual C++
public:
SuspendUpdating(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit..::.Document
The document for which updating will be suspended.

Remarks

During suspension of updating, consistency will not be maintained. When all SuspendUpdating objects have been disposed, Revit will make the document consistent again.

See Also

SuspendUpdating Class
Autodesk.Revit Namespace

SuspendUpdating Methods

[image] [image]