Revit 2010 API
Blend..::.SetVertexConnectionMap Method
Blend Class See Also Send Feedback
Sets the mapping between the vertices in the top and bottom profiles.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetVertexConnectionMap(
    VertexIndexPairArray vertexMap
)
Visual Basic (Declaration)
Public Sub SetVertexConnectionMap ( _
    vertexMap As VertexIndexPairArray _
)
Visual C++
public:
void SetVertexConnectionMap(
    VertexIndexPairArray^ vertexMap
)

Parameters

vertexMap
Type: Autodesk.Revit..::.VertexIndexPairArray

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"vertexMap"-is null.
System..::.ArgumentException | Thrown if the input argument-"vertexMap"-is empty.
System..::.InvalidOperationException | Thrown when the document failed to regenerate.

See Also

Blend Class
Autodesk.Revit.Elements Namespace

Blend Properties

[image] [image]