Revit 2010 API
ReferenceArrayArray..::.Item Property
ReferenceArrayArray Class See Also Send Feedback
Gets or sets a ReferenceArray at a specified index within the array.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual ReferenceArray Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As ReferenceArray
Visual C++
public:
virtual property ReferenceArray^ Item[int index] {
    ReferenceArray^ get (int index);
    void set (int index, ReferenceArray^ value);
}

Parameters

index
Type: System..::.Int32
The index of the ReferenceArray to be set or retrieved.

Return Value

Returns the ReferenceArray at the specified index.

See Also

ReferenceArrayArray Class
Autodesk.Revit.Geometry Namespace

Size Property

[image]