Revit 2010 API
GenericForm Class
Members See Also Send Feedback
Provides access to the Generic Form model in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class GenericForm : CombinableElement
Visual Basic (Declaration)
Public Class GenericForm _
    Inherits CombinableElement
Visual C++
public ref class GenericForm : public CombinableElement

Remarks

The Generic Form object can be queried for a generic form for use in family modeling and massing.it is the base class of Sweep, Blend, Extrusion, Revolution.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CombinableElement
Autodesk.Revit.Elements..::.GenericForm
Autodesk.Revit.Elements..::.Blend
Autodesk.Revit.Elements..::.Extrusion
Autodesk.Revit.Elements..::.Form
Autodesk.Revit.Elements..::.Revolution
Autodesk.Revit.Elements..::.Sweep
Autodesk.Revit.Elements..::.SweptBlend

See Also

GenericForm Members
Autodesk.Revit.Elements Namespace

GenericForm Members

[image] [image]