Revit 2010 API
Document..::.SaveAs Method (String)
Document Class See Also Send Feedback
Saves the document to a given file name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SaveAs(
    string fileName
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    fileName As String _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
File name to be saved as.

Return Value

Returns 'false' if save operation fails. Also returns 'false' if saving as is cancelled by an external application during 'DocumentSavingAs' event. When function succeeds, 'true' is returned.

Remarks

None.

See Also

Document Class
SaveAs Overload
Autodesk.Revit Namespace

SaveAs Method (String, PostedErrorArray)

[image]