Revit 2010 API
Document..::.NewLineLoad Method (Element, XYZArray, XYZArray, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)
Document Class See Also Send Feedback
Creates a new hosted line load within the project using data at two points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LineLoad NewLineLoad(
    Element host,
    XYZArray forces,
    XYZArray moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewLineLoad ( _
    host As Element, _
    forces As XYZArray, _
    moments As XYZArray, _
    uniform As Boolean, _
    projected As Boolean, _
    isReaction As Boolean, _
    symbol As LineLoadType, _
    plane As SketchPlane _
) As LineLoad
Visual C++
public:
LineLoad^ NewLineLoad(
    Element^ host,
    XYZArray^ forces,
    XYZArray^ moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

host
Type: Autodesk.Revit..::.Element
The host element (Beam, Brace or Column) of the LineLoad application.
forces
Type: Autodesk.Revit.Geometry..::.XYZArray
The applied 3d linear forces in the end points.
moments
Type: Autodesk.Revit.Geometry..::.XYZArray
The applied 3d linear moments in the end points.
uniform
Type: System..::.Boolean
Set to True if you wish to create the uniform load.
projected
Type: System..::.Boolean
Set to True if you wish to create the projected load.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.Symbols..::.LineLoadType
The symbol of the LineLoad.
plane
Type: Autodesk.Revit.Elements..::.SketchPlane
Indicate the work plane of the LineLoad.

Return Value

If successful, NewLineLOad returns an object for the newly created LineLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

See Also

Document Class
NewLineLoad Overload
Autodesk.Revit.Creation Namespace

NewLineLoad Method (Reference, XYZArray, XYZArray, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)

[image]