Revit 2010 API
Materials..::.AddOther Method
Materials Class Example See Also Send Feedback
Add an other material with the given name .

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialOther AddOther(
    string name
)
Visual Basic (Declaration)
Public Function AddOther ( _
    name As String _
) As MaterialOther
Visual C++
public:
MaterialOther^ AddOther(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the other material to be added.

Return Value

The pointer to the added other material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

Examples

CopyC#
private bool CreateOtherMaterial(Autodesk.Revit.Document document)
{
    string oldName = "myOtherMaterial";
    MaterialOther myOther = document.Settings.Materials.AddOther(oldName);
    if (null == myOther)
    {
        return false;
    }

    //try to duplicate a new instance using duplicate method
    //make sure the name of new material is unique in MaterailSet
    string newName = "new" + myOther.Name;
    MaterialOther newOther = myOther.Duplicate(newName) as MaterialOther;
    if (null == newOther)
    {
        MessageBox.Show("Failed to duplicate an other material!");
        return false;
    }
    else
    {
        MessageBox.Show("Duplicated other material.");
    }

    // Remove the original created material
    document.Settings.Materials.Remove(oldName);

    if (document.Settings.Materials.Contains(oldName) == false)
    {
        MessageBox.Show("Material (myOtherMaterial) removed successfully!", "Revit");
    }

    return true;
}
CopyVB.NET
Private Function CreateOtherMaterial(ByVal document As Autodesk.Revit.Document) As Boolean
    Dim oldName As String = "myOtherMaterial"
    Dim myOther As MaterialOther = document.Settings.Materials.AddOther(oldName)
    If myOther Is Nothing Then
        Return False
    End If

    'try to duplicate a new instance using duplicate method
    'make sure the name of new material is unique in MaterailSet
    Dim newName As String = "new" & myOther.Name
    Dim newOther As MaterialOther = TryCast(myOther.Duplicate(newName), MaterialOther)
    If newOther Is Nothing Then
        MessageBox.Show("Failed to duplicate an other material!")
        Return False
    Else
        MessageBox.Show("Duplicated other material.")
    End If

    ' Remove the original created material
    document.Settings.Materials.Remove(oldName)

    If document.Settings.Materials.Contains(oldName) = False Then
        MessageBox.Show("Material (myOtherMaterial) removed successfully!", "Revit")
    End If

    Return True
End Function

See Also

Materials Class
Autodesk.Revit Namespace

AddSteel Method

[image]