Revit 2010 API
Transform..::.AlmostEqual Method
Transform Class See Also Send Feedback
Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool AlmostEqual(
    Transform right
)
Visual Basic (Declaration)
Public Function AlmostEqual ( _
    right As Transform _
) As Boolean
Visual C++
public:
bool AlmostEqual(
    Transform^ right
)

Parameters

right
Type: Autodesk.Revit.Geometry..::.Transform
The transformation to compare with this transformation.

Return Value

True if the two transformations are equal; otherwise, false.

Remarks

The tolerance is applied memberwise for comparison.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified transformation is null.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace

Multiply Method

[image]