Revit 2010 API
Document..::.NewLoadCase Method
Document Class Example See Also Send Feedback
Creates a new instance of a LoadCase element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LoadCase NewLoadCase(
    string name,
    LoadNature nature,
    Category category
)
Visual Basic (Declaration)
Public Function NewLoadCase ( _
    name As String, _
    nature As LoadNature, _
    category As Category _
) As LoadCase
Visual C++
public:
LoadCase^ NewLoadCase(
    String^ name,
    LoadNature^ nature,
    Category^ category
)

Parameters

name
Type: System..::.String
The not empty name for the Load Case Element to create.
nature
Type: Autodesk.Revit.Elements..::.LoadNature
The Load Case nature.
category
Type: Autodesk.Revit..::.Category
The Load Case category.

Return Value

If successful, NewLoadCase and there isn’t the Load Case Element with the same name returns an object for the newly created LoadCase. If such element exist and match desired one (has the same nature and number), returns existing element. Otherwise nothing is returned.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
LoadCase CreateLoadCase(Autodesk.Revit.Document document, Category category, LoadNature nature)
{
    // Create a load case
    // Category should be of type OST_LoadCases
    LoadCase loadCase = document.Create.NewLoadCase("new case", nature, category);
    if (null == loadCase)
    {
        throw new Exception("Create a new load case failed.");
    }

    // Give the user some information
    MessageBox.Show("Successfully created a load case.", "Revit");

    return loadCase;
}
CopyVB.NET
Private Function CreateLoadCase(ByVal document As Autodesk.Revit.Document, ByVal category As Autodesk.Revit.Category, ByVal nature As LoadNature) As LoadCase
    ' Create a load case
    ' Category should be of type OST_LoadCases
    Dim loadCase As LoadCase = document.Create.NewLoadCase("new case", nature, category)
    If loadCase Is Nothing Then
        Throw New Exception("Create a new load case failed.")
    End If

    ' Give the user some information
    MessageBox.Show("Successfully created a load case.", "Revit")

    Return loadCase
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewLoadCombination Method

[image]