Revit 2010 API
BoundaryConditions Members
BoundaryConditions Class Constructors Methods Properties See Also Send Feedback

The BoundaryConditions type exposes the following members.

Constructors

Name | Description
BoundaryConditions | For Internal Use Only.

Methods

Name | Description
associateWithLoad | Sets the ElementId of Load to associate.

Properties

Name | Description
AssociatedLoad | Retrieve the AssociatedLoad.
Curve | Returns the geometric curve within a geometric loop that defines the area.
HostElement | Retrieve the HostElementId.
NumCurves | Returns the number of curves represent the Boundary Conditions Element.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Point | If successful, returns the point represetns Boundary Conditions.

See Also

BoundaryConditions Class
Autodesk.Revit.Elements Namespace

BoundaryConditions Constructor

[image]