Revit 2010 API
Document..::.OnSave Event
Document Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentSaving event instead. Subscribe to the OnSave event to be notified before a document is saved.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSaving event instead.")]
public event DocumentSaveEventHandler OnSave
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentSaving event instead.")> _
Public Event OnSave As DocumentSaveEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentSaving event instead.")]
public:
 event DocumentSaveEventHandler^ OnSave {
    void add (DocumentSaveEventHandler^ value);
    void remove (DocumentSaveEventHandler^ value);
}

Remarks

Sometimes an application needs to know when the document will be saved. By subscribing to this event the application will be notified before such an event and can perform an action in response.

See Also

Document Class
Autodesk.Revit Namespace

OnSaveAs Event

[image]