Revit 2010 API
BoundingBoxXYZ..::.Transform Property
BoundingBoxXYZ Class Example See Also Send Feedback
The transform FROM the coordinate space of the box TO the model space.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Transform Transform { get; set; }
Visual Basic (Declaration)
Public Property Transform As Transform
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
    void set (Transform^ value);
}

Remarks

The transform must always be right-handed and orthonormal.

Examples

CopyC#
private void RotateBoundingBox(View3D view3d)
{
    BoundingBoxXYZ box = view3d.SectionBox;
    if (false == box.Enabled)
    {
        MessageBox.Show("The section box for View3D isn't Enable.");
        return;
    }
    // Create a rotation transform,
    XYZ origin = new XYZ(0, 0, 0);
    XYZ axis = new XYZ(0, 0, 1);
    Transform rotate = Transform.get_Rotation(origin, axis, 2);
    // Transform the View3D's SectionBox with the rotation transfrom
    box.Transform = box.Transform.Multiply(rotate);
    view3d.SectionBox = box;
}
CopyVB.NET
Private Sub RotateBoundingBox(ByVal view3d As View3D)
    Dim box As BoundingBoxXYZ = view3d.SectionBox
    If False = box.Enabled Then
        MessageBox.Show("The section box for View3D isn't Enable.")
        Exit Sub
    End If
    ' Create a rotation transform,
    Dim origin As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
    Dim axis As New Autodesk.Revit.Geometry.XYZ(0, 0, 1)
    Dim rotate As Transform = Transform.Rotation(origin, axis, 2)
    ' Transform the View3D's SectionBox with the rotation transfrom
    box.Transform = box.Transform.Multiply(rotate)
    view3d.SectionBox = box
End Sub

See Also

BoundingBoxXYZ Class
Autodesk.Revit.Geometry Namespace

ConicalFace Class

[image]