Revit 2010 API
Form..::.CurveLoopReferencesOnProfile Property
Form Class See Also Send Feedback
The curve references in certain curve loop, specified by profile index and curve loop index.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferenceArray CurveLoopReferencesOnProfile[
    int profileIndex,
    int curveLoopIndex
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurveLoopReferencesOnProfile ( _
    profileIndex As Integer, _
    curveLoopIndex As Integer _
) As ReferenceArray
Visual C++
public:
property ReferenceArray^ CurveLoopReferencesOnProfile[int profileIndex, int curveLoopIndex] {
    ReferenceArray^ get (int profileIndex, int curveLoopIndex);
}

Parameters

profileIndex
Type: System..::.Int32
Index to specify the profile, should be within 0 and (ProfileCount - 1).
curveLoopIndex
Type: System..::.Int32
Index to specify the curve loop, should be within 0 and (CurveLoopCount - 1).

See Also

Form Class
Autodesk.Revit.Elements Namespace

HasOneOrMoreReferenceProfiles Property

[image]