Revit 2010 API
Zone..::.RemoveSpaces Method
Zone Class See Also Send Feedback
Remove a set of existing spaces to the current Zone element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool RemoveSpaces(
    SpaceSet spaces
)
Visual Basic (Declaration)
Public Function RemoveSpaces ( _
    spaces As SpaceSet _
) As Boolean
Visual C++
public:
bool RemoveSpaces(
    SpaceSet^ spaces
)

Parameters

spaces
Type: Autodesk.Revit.Elements..::.SpaceSet
The spaces which want to delete from the current zone element.

Return Value

If successful the current zone element will remove a set of input spaces, otherwise Nothing.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter Value is null.
System..::.InvalidOperationException | Thrown when the input spaces cannot be deleted from current zone element.

See Also

Zone Class
Autodesk.Revit.Elements Namespace

Zone Properties

[image] [image]