Revit 2010 API
Gutter..::.AddSegment Method
Gutter Class See Also Send Feedback
Add segments to the gutter.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override void AddSegment(
    Reference targetRef
)
Visual Basic (Declaration)
Public Overrides Sub AddSegment ( _
    targetRef As Reference _
)
Visual C++
public:
virtual void AddSegment(
    Reference^ targetRef
) override

Parameters

targetRef
Type: Autodesk.Revit.Geometry..::.Reference
Segment's reference on which want to be added.

Exceptions

Exception | Condition
System..::.ArgumentNullException | This exception will be thrown in following cases: 1. Input targetRef is null. 2. Input targetRef is not null but contains nothing.
System..::.InvalidOperationException | This exception will be thrown in following cases: 1. Input targetRef has already been added into the gutter. 2. Internal code fails to create the segment object. 3. Regeneration fails.
System..::.ArgumentOutOfRangeException | This exception will be thrown if the reference is not suitable for creating a gutter as required. The reference allowed is : 1. Model Line 2. Roof's horizontal edges 3. Soffit's horizontal edges 4. Fascia's horizontal edges

See Also

Gutter Class
Autodesk.Revit.Elements Namespace

Gutter Properties

[image] [image]