Revit 2010 API
IExternalCommand..::.Result Enumeration
IExternalCommand Interface See Also Send Feedback
Informs Autodesk Revit of the status of your command after execution.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum Result
Visual Basic (Declaration)
Public Enumeration Result
Visual C++
public enum class Result

Members

Member name | Description
Succeeded | The external command completed successfully. Autodesk Revit will keep any changes made by the external command.
Failed | The external command was unable to complete its task. Autodesk Revit should undo any operations that the external command performed and signal a failure.
Cancelled | Signifies that the user cancelled the external command. Autodesk Revit should undo any changes made by the external command but not signal a failure.

See Also

Autodesk.Revit Namespace

IFamilyLoadOptions Interface

[image]