Revit 2010 API
Parameter Properties
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Properties

Name | Description
Definition | Returns the Definition object that describes the data type, name and other details of the parameter.
DisplayUnitType | Get the display unit type of the parameter object.
Element | The element to which this parameter belongs.
IsReadOnly | Get the readonly property of the parameter. (Overrides APIObject..::.IsReadOnly.)
StorageType | Describes the type that is used internally within the parameter to store its value.

See Also

Parameter Class
Autodesk.Revit Namespace

Definition Property

[image]