Revit 2010 API
Document..::.Delete Method (ElementIdSet)
Document Class Example See Also Send Feedback
Deletes several elements from the document given their ids.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementIdSet Delete(
    ElementIdSet ids
)
Visual Basic (Declaration)
Public Function Delete ( _
    ids As ElementIdSet _
) As ElementIdSet
Visual C++
public:
ElementIdSet^ Delete(
    ElementIdSet^ ids
)

Parameters

ids
Type: Autodesk.Revit..::.ElementIdSet
A set of element ids for the elements that are to be deleted.

Remarks

This method will delete the elements and any other elements that are totally dependent upon those elements. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

Examples

CopyC#
// Delete all the selected elements via the set of element ids.
ElementIdSet idSelection = new ElementIdSet();
foreach (Autodesk.Revit.Element elem in document.Selection.Elements)
{
    ElementId id = elem.Id;
    idSelection.Insert(ref id);
}
ElementIdSet deletedIdSet = document.Delete(idSelection);

if (0 == deletedIdSet.Size)
{
    throw new Exception("Deleting the selected elements in revit failed.");
}

MessageBox.Show("The selected element has been removed.", "Revit");
CopyVB.NET
' Delete all the selected elements via the set of element ids.
Dim idSelection As New ElementIdSet()
For Each elem As Autodesk.Revit.Element In document.Selection.Elements
    Dim id As Autodesk.Revit.ElementId = elem.Id
    idSelection.Insert(id)
Next
Dim deletedIdSet As ElementIdSet = document.Delete(idSelection)

If 0 = deletedIdSet.Size Then
    Throw New Exception("Deleting the selected elements in revit failed.")
End If

MessageBox.Show("The selected element has been removed.", "Revit")

See Also

Document Class
Delete Overload
Autodesk.Revit Namespace

Delete Method (ElementSet)

[image]