Revit 2010 API
Path3d Class
Members See Also Send Feedback
Provides access to the Generic 3D path object in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Path3d : SketchBase
Visual Basic (Declaration)
Public Class Path3d _
    Inherits SketchBase
Visual C++
public ref class Path3d : public SketchBase

Remarks

This object represents a 3D path sketch of Sweep.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.SketchBase
Autodesk.Revit.Elements..::.Path3d

See Also

Path3d Members
Autodesk.Revit.Elements Namespace

Path3d Members

[image] [image]