Revit 2010 API
AnalyticalModelFloor..::.Curves Property
AnalyticalModelFloor Class See Also Send Feedback
Provides access to the Floor Analytical Model.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArray Curves { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

Return Value

Curves that define the Floor's Analytical Model.

Remarks

The curves are all coplanar.

See Also

AnalyticalModelFloor Class
Autodesk.Revit.Structural Namespace

SupportData Property

[image]