Revit 2010 API
Document..::.GetRoomAtPoint Method (XYZ)
Document Class See Also Send Feedback
Gets a room containing the point.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Room GetRoomAtPoint(
    XYZ point
)
Visual Basic (Declaration)
Public Function GetRoomAtPoint ( _
    point As XYZ _
) As Room
Visual C++
public:
Room^ GetRoomAtPoint(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
Point to be checked.

Return Value

The room containing the point.

Remarks

Surveys only the rooms from the final phase of the project. The first one found will be returned. If there is no room containing the point, it returns null.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the point is nullptr.
System..::.ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.

See Also

Document Class
GetRoomAtPoint Overload
Autodesk.Revit Namespace

GetRoomAtPoint Method (XYZ, Phase)

[image]