Revit 2010 API
PipeType Class
Members See Also Send Feedback
A pipe type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PipeType : MEPCurveType
Visual Basic (Declaration)
Public Class PipeType _
    Inherits MEPCurveType
Visual C++
public ref class PipeType : public MEPCurveType

Remarks

The pipe type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.MEPCurveType
Autodesk.Revit.MEP..::.PipeType

See Also

PipeType Members
Autodesk.Revit.MEP Namespace

PipeType Members

[image] [image]