Revit 2010 API
SpaceType Enumeration
See Also Send Feedback
An enumerate type listing all the possible Space Type for a Space object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum SpaceType
Visual Basic (Declaration)
Public Enumeration SpaceType
Visual C++
public enum class SpaceType

Members

Member name | Description
kNoOfSpaceTypes | Space Type is NoOfSpaceTypes.
kWorshipPulpitChoirReligious | Space Type is WorshipPulpitChoirReligious.
kWorkshopWorkshop | Space Type is WorkshopWorkshop.
kTerminalTicketCounterTransportation | Space Type is TerminalTicketCounterTransportation.
kSupermarketSalesAreaRetail | Space Type is SupermarketSalesAreaRetail.
kStairway | Space Type is Stairway.
kStairsInactive | Space Type is StairsInactive.
kStacksLibrary | Space Type is StacksLibrary.
kSpecialtyStoreSalesAreaRetail | Space Type is SpecialtyStoreSalesAreaRetail.
kSortingAreaPostOffice | Space Type is SortingAreaPostOffice.
kSleepingQuartersPoliceOrFireStation | Space Type is SleepingQuartersPoliceOrFireStation.
kRingSportsAreaSportsArena | Space Type is RingSportsAreaSportsArena.
kRestrooms | Space Type is Restrooms.
kRestorationMuseum | Space Type is RestorationMuseum.
kRecoveryHospitalOrHealthcare | Space Type is RecoveryHospitalOrHealthcare.
kReceptionOrWaitingHotel | Space Type is ReceptionOrWaitingHotel.
kReceptionOrWaitingMotel | Space Type is ReceptionOrWaitingMotel.
kReceptionOrWaitingTransportation | Space Type is ReceptionOrWaitingTransportation.
kReadingAreaLibrary | Space Type is ReadingAreaLibrary.
kPublicAndStaffLoungeHospitalOrHealthcare | Space Type is PublicAndStaffLoungeHospitalOrHealthcare.
kPlenum | Space Type is Plenum.
kPoliceStationLaboratoryPoliceOrFireStations | Space Type is PoliceStationLaboratoryPoliceOrFireStations.
kPlayingAreaGymnasium | Space Type is PlayingAreaGymnasium.
kPhysicalTherapyHospitalOrHealthcare | Space Type is PhysicalTherapyHospitalOrHealthcare.
kPharmacyHospitalOrHealthcare | Space Type is PharmacyHospitalOrHealthcare.
kPersonalServicesSalesAreaRetail | Space Type is PersonalServicesSalesAreaRetail.
kPatientRoomHospitalOrHealthcare | Space Type is PatientRoomHospitalOrHealthcare.
kParkingAreaPedestrianParkingGarage | Space Type is ParkingAreaPedestrianParkingGarage.
kParkingAreaAttendantOnlyParkingGarage | Space Type is ParkingAreaAttendantOnlyParkingGarage.
kOtherTelevisedPlayingAreaSportsArena | Space Type is OtherTelevisedPlayingAreaSportsArena.
kOperatingRoomHospitalOrHealthcare | Space Type is OperatingRoomHospitalOrHealthcare.
kOfficeCommonActivityAreasInactiveStorage | Space Type is OfficeCommonActivityAreasInactiveStorage.
kOfficeOpenPlan | Space Type is OfficeOpenPlan.
kOfficeEnclosed | Space Type is OfficeEnclosed.
kNurseStationHospitalOrHealthcare | Space Type is NurseStationHospitalOrHealthcare.
kMuseumAndGalleryStorage | Space Type is MuseumAndGalleryStorage.
kMerchandisingSalesAreaRetail | Space Type is MerchandisingSalesAreaRetail.
kMediumOrBulkyMaterialWarehouse | Space Type is MediumOrBulkyMaterialWarehouse.
kMassMerchandisingSalesAreaRetail | Space Type is MassMerchandisingSalesAreaRetail.
kMallConcourseSalesAreaRetail | Space Type is MallConcourseSalesAreaRetail.
kLoungeOrRecreation | Space Type is LoungeOrRecreation.
kLobbyHotel | Space Type is LobbyHotel.
kLobbyPostOffice | Space Type is LobbyPostOffice.
kLobbyPerformingArtsTheatre | Space Type is LobbyPerformingArtsTheatre.
kLobbyAuditorium | Space Type is LobbyAuditorium.
kLobbyMotionPictureTheatre | Space Type is LobbyMotionPictureTheatre.
kLobbyReligiousBuildings | Space Type is LobbyReligiousBuildings.
kLobby | Space Type is Lobby.
kLivingQuartersHotel | Space Type is LivingQuartersHotel.
kLivingQuartersMotel | Space Type is LivingQuartersMotel.
kLivingQuartersDormitory | Space Type is LivingQuartersDormitory.
kLibraryAudioVisualLibraryAudioVisual | Space Type is LibraryAudioVisualLibraryAudioVisual.
kLaundryWashingHospitalOrHealthcare | Space Type is LaundryWashingHospitalOrHealthcare.
kLaundryIroningAndSorting | Space Type is LaundryIroningAndSorting.
kLaboratoryOffice | Space Type is LaboratoryOffice.
kJudgesChambersCourtHouse | Space Type is JudgesChambersCourtHouse.
kInactiveStorage | Space Type is InactiveStorage.
kHotelOrConferenceCenterConferenceOrMeeting | Space Type is HotelOrConferenceCenterConferenceOrMeeting.
kHospitalOrRadiologyHospitalOrHealthcare | Space Type is HospitalOrRadiologyHospitalOrHealthcare.
kHospitalOrMedicalSuppliesHospitalOrHealthcare | Space Type is HospitalOrMedicalSuppliesHospitalOrHealthcare.
kHospitalNurseryHospitalOrHealthcare | Space Type is HospitalNurseryHospitalOrHealthcare.
kGeneralExhibitionMuseum | Space Type is GeneralExhibitionMuseum.
kGeneralLowBayManufacturingFacility | Space Type is GeneralLowBayManufacturingFacility.
kGeneralHighBayManufacturingFacility | Space Type is GeneralHighBayManufacturingFacility.
kGarageServiceOrRepairAutomotiveFacility | Space Type is GarageServiceOrRepairAutomotiveFacility.
kFoodPreparation | Space Type is FoodPreparation.
kFireStationEngineRoomPoliceOrFireStation | Space Type is FireStationEngineRoomPoliceOrFireStation.
kFineMerchandiseSalesAreaRetail | Space Type is FineMerchandiseSalesAreaRetail.
kFineMaterialWarehouse | Space Type is FineMaterialWarehouse.
kFellowshipHallReligiousBuildings | Space Type is FellowshipHallReligiousBuildings.
kExhibitSpaceConventionCenter | Space Type is ExhibitSpaceConventionCenter.
kExerciseAreaGymnasium | Space Type is ExerciseAreaGymnasium.
kExerciseAreaExerciseCenter | Space Type is ExerciseAreaExerciseCenter.
kExamOrTreatmentHospitalOrHealthcare | Space Type is ExamOrTreatmentHospitalOrHealthcare.
kEquipmentRoomManufacturingFacility | Space Type is EquipmentRoomManufacturingFacility.
kEmergencyHospitalOrHealthcare | Space Type is EmergencyHospitalOrHealthcare.
kElevatorLobbies | Space Type is ElevatorLobbies.
kElectricalOrMechanical | Space Type is ElectricalOrMechanical.
kDressingOrLockerOrFittingRoomExerciseCenter | Space Type is DressingOrLockerOrFittingRoomExerciseCenter.
kDressingOrLockerOrFittingRoomAuditorium | Space Type is DressingOrLockerOrFittingRoomAuditorium.
kDressingOrLockerOrFittingRoomPerformingArtsTheatre | Space Type is DressingOrLockerOrFittingRoomPerformingArtsTheatre.
kDressingOrLockerOrFittingRoomCourtHouse | Space Type is DressingOrLockerOrFittingRoomCourtHouse.
kDressingOrLockerOrFittingRoomGymnasium | Space Type is DressingOrLockerOrFittingRoomGymnasium.
kDormitoryStudyHall | Space Type is DormitoryStudyHall.
kDormitoryBedroom | Space Type is DormitoryBedroom.
kDiningAreaCivilServices | Space Type is DiningAreaCivilServices.
kDiningAreaPenitentiary | Space Type is DiningAreaPenitentiary.
kDiningAreaTransportation | Space Type is DiningAreaTransportation.
kDiningAreaMotel | Space Type is DiningAreaMotel.
kDiningAreaLoungeOrLeisureDining | Space Type is DiningAreaLoungeOrLeisureDining.
kDiningAreaFamilyDining | Space Type is DiningAreaFamilyDining.
kDiningAreaHotel | Space Type is DiningAreaHotel.
kDiningArea | Space Type is DiningArea.
kDetailedManufacturingFacility | Space Type is DetailedManufacturingFacility.
kDepartmentStoreSalesAreaRetail | Space Type is DepartmentStoreSalesAreaRetail.
kCourtroomCourtHouse | Space Type is CourtroomCourtHouse.
kCourtSportsAreaSportsArena | Space Type is CourtSportsAreaSportsArena.
kCorridorsWithPatientWaitingExamHospitalOrHealthcare | Space Type is CorridorsWithPatientWaitingExamHospitalOrHealthcare.
kCorridorOrTransitionManufacturingFacility | Space Type is CorridorOrTransitionManufacturingFacility.
kCorridorOrTransition | Space Type is CorridorOrTransition.
kConferenceMeetingOrMultipurpose | Space Type is ConferenceMeetingOrMultipurpose.
kComfinementCellsCourtHouse | Space Type is ComfinementCellsCourtHouse.
kComfinementCellsPenitentiary | Space Type is ComfinementCellsPenitentiary.
kClassroomOrLectureOrTraining | Space Type is ClassroomOrLectureOrTraining.
kClassroomOrLectureOrTrainingPenitentiary | Space Type is ClassroomOrLectureOrTrainingPenitentiary.
kCardFileAndCataloguingLibrary | Space Type is CardFileAndCataloguingLibrary.
kBarberAndBeautyParlor | Space Type is BarberAndBeautyParlor.
kBankingActivityAreaOffice | Space Type is BankingActivityAreaOffice.
kBankCustomerArea | Space Type is BankCustomerArea.
kAudienceOrSeatingAreaAuditorium | Space Type is AudienceOrSeatingAreaAuditorium.
kAudienceOrSeatingAreaCourtHouse | Space Type is AudienceOrSeatingAreaCourtHouse.
kAudienceOrSeatingAreaPoliceOrFireStations | Space Type is AudienceOrSeatingAreaPoliceOrFireStations.
kAudienceOrSeatingAreaReligious | Space Type is AudienceOrSeatingAreaReligious.
kAudienceOrSeatingAreaPerformingArtsTheatre | Space Type is AudienceOrSeatingAreaPerformingArtsTheatre.
kAudienceOrSeatingAreaMotionPictureTheatre | Space Type is AudienceOrSeatingAreaMotionPictureTheatre.
kAudienceOrSeatingAreaConventionCenter | Space Type is AudienceOrSeatingAreaConventionCenter.
kAudienceOrSeatingAreaSportsArena | Space Type is AudienceOrSeatingAreaSportsArena.
kAudienceOrSeatingAreaGymnasium | Space Type is AudienceOrSeatingAreaGymnasium.
kAudienceOrSeatingAreaExerciseCenter | Space Type is AudienceOrSeatingAreaExerciseCenter.
kAudienceOrSeatingAreaPenitentiary | Space Type is AudienceOrSeatingAreaPenitentiary.
kAtriumFirstThreeFloors | Space Type is AtriumFirstThreeFloors.
kAtriumEachAdditionalFloor | Space Type is AtriumEachAdditionalFloor.
kAirportConcourse | Space Type is AirportConcourse.
kAirOrTrainOrBusBaggageArea | Space Type is AirOrTrainOrBusBaggageArea.
kActiveStorageHospitalOrHealthcare | Space Type is ActiveStorageHospitalOrHealthcare.
kActiveStorage | Space Type is ActiveStorage.
kNoSpaceType | Space Type is NoSpaceType.

See Also

Autodesk.Revit.MEP.Enums Namespace

WiringType Enumeration

[image]