Revit 2010 API
InternalDefinition..::.ParameterType Property
InternalDefinition Class See Also Send Feedback
Returns the user-visible interpretation of the parameter data.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override ParameterType ParameterType { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ParameterType As ParameterType
Visual C++
public:
virtual property ParameterType ParameterType {
    ParameterType get () override;
}

Remarks

The data within the parameter is stored as an integer, double, string or an element id. To the user these values may be more meaningful as Length, Volume, Mass etc. This parameter returns the interpretation that should be used for the data.

See Also

InternalDefinition Class
Autodesk.Revit.Parameters Namespace

InternalDefinitions Class

[image]