Revit 2010 API
Document..::.NewWall Method (CurveArray, WallType, Level, Boolean)
Document Class See Also Send Feedback
Creates a non rectangular profile wall within the project using the specified wall type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Wall NewWall(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Function NewWall ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean _
) As Wall
Visual C++
public:
Wall^ NewWall(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.Symbols..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise Nothing.

See Also

Document Class
NewWall Overload
Autodesk.Revit.Creation Namespace

NewWall Method (CurveArray, WallType, Level, Boolean, XYZ)

[image]