Revit 2010 API
Color Constructor (Byte, Byte, Byte)
Color Class See Also Send Feedback
Constructor that takes the red, green and blue channels of the color.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Color(
    byte red,
    byte green,
    byte blue
)
Visual Basic (Declaration)
Public Sub New ( _
    red As Byte, _
    green As Byte, _
    blue As Byte _
)
Visual C++
public:
Color(
    unsigned char red,
    unsigned char green,
    unsigned char blue
)

Parameters

red
Type: System..::.Byte
The red channel of the color that ranges from 0 to 255.
green
Type: System..::.Byte
The green channel of the color that ranges from 0 to 255.
blue
Type: System..::.Byte
The blue channel of the color that ranges from 0 to 255.

See Also

Color Class
Color Overload
Autodesk.Revit Namespace

Color Methods

[image] [image]