Revit 2010 API
PrintManager..::.PrintSetup Property
PrintManager Class See Also Send Feedback
The PrintSetup which manages the print settings of current doucment.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PrintSetup PrintSetup { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintSetup As PrintSetup
Visual C++
public:
property PrintSetup^ PrintSetup {
    PrintSetup^ get ();
}

Remarks

PrintSetup is an interface cluster just like File->Print->Settings->Setup or File->Print Setup in UI.

See Also

PrintManager Class
Autodesk.Revit Namespace

PrintToFile Property

[image]