Revit 2010 API
ControlledApplication..::.DocumentOpened Event
ControlledApplication Class Example See Also Send Feedback
Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentOpenedEventArgs> DocumentOpened
Visual Basic (Declaration)
Public Event DocumentOpened As EventHandler(Of DocumentOpenedEventArgs)
Visual C++
public:
 event EventHandler<DocumentOpenedEventArgs^>^ DocumentOpened {
    void add (EventHandler<DocumentOpenedEventArgs^>^ value);
    void remove (EventHandler<DocumentOpenedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished opening a document. It is raised even when document opening failed or was cancelled (during DocumentOpening event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of opening document has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

The DocumentOpened event is meant to replace the older OnDocumentOpened event, which is now Obsolete.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

Examples

CopyC#
public class Application_DocumentOpened : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement this method to subscribe to event.
    /// </summary>
    public IExternalApplication.Result OnStartup(ControlledApplication application)
    {
        try
        {
            // Register event.
            application.DocumentOpened += new EventHandler
                <Autodesk.Revit.Events.DocumentOpenedEventArgs>(application_DocumentOpened);
        }
        catch (Exception)
        {
            return IExternalApplication.Result.Failed;
        }

        return IExternalApplication.Result.Succeeded;
    }

    /// <summary>
    /// Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    /// </summary>
    public IExternalApplication.Result OnShutdown(ControlledApplication application)
    {
        // remove the event.
        application.DocumentOpened -= application_DocumentOpened;
        return IExternalApplication.Result.Succeeded;
    }

    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentOpened class description
    /// </TrivialCode>

    /// <description>
    /// This sample demonstrates how to subscribe to the DocumentOpened event and modify the model in the event handler method.
    /// </description>
    /// <summary>
    /// This is the event handler. We modify the model.
    /// </summary>
    /// <param name="sender">Event sender.</param>
    /// <param name="args"></param>
    public void application_DocumentOpened(object sender, DocumentOpenedEventArgs args)
    {
        // get document from event args.
        Document doc = args.Document;

        // Following code snippet demonstrates support of DocumentOpened event to modify the model.
        // Because DocumentOpened supports model changes, it allows user to update document data.
        // Here, this sample assigns a specified value to ProjectInformation.Address property.
        // User can change other properties of document or create(delete) something as he likes.
        //
        // Please note that ProjectInformation property is empty for family document.
        // So please don't run this sample on family document.
        doc.ProjectInformation.Address =
            "United States - Massachusetts - Waltham - 1560 Trapelo Road";
    }

    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_DocumentOpened
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement this method to subscribe to event.
    ' </summary>
    Public Function OnStartup(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnStartup
        Try
            ' Register event.
            AddHandler application.DocumentOpened, AddressOf application_DocumentOpened
        Catch generatedExceptionName As Exception
            Return IExternalApplication.Result.Failed
        End Try

        Return IExternalApplication.Result.Succeeded
    End Function

    ' <summary>
    ' Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    ' </summary>
    Public Function OnShutdown(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnShutdown
        ' remove the event.
        RemoveHandler application.DocumentOpened, AddressOf application_DocumentOpened
        Return IExternalApplication.Result.Succeeded
    End Function

    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentOpened class description
    ' </TrivialCode>

    ' <description>
    ' This sample demonstrates how to subscribe to the DocumentOpened event and modify the model in the event handler method.
    ' </description>
    ' <summary>
    ' This is the event handler. We modify the model.
    ' </summary>
    ' <param name="sender">Event sender.</param>
    ' <param name="args"></param>
    Public Sub application_DocumentOpened(ByVal sender As Object, ByVal args As Autodesk.Revit.Events.DocumentOpenedEventArgs)
        ' get document from event args.
        Dim doc As Document = args.Document

        ' Following code snippet demonstrates support of DocumentOpened event to modify the model.
        ' Because DocumentOpened supports model changes, it allows user to update document data.
        ' Here, this sample assigns a specified value to ProjectInformation.Address property.
        ' User can change other properties of document or create(delete) something as he likes.
        '
        ' Please note that ProjectInformation property is empty for family document.
        ' So please don't run this sample on family document.
        doc.ProjectInformation.Address = "United States - Massachusetts - Waltham - 610 Lincoln St"
    End Sub
End Class

' </ExampleMethod>

See Also

ControlledApplication Class
Autodesk.Revit Namespace

DocumentOpening Event

[image]