Revit 2010 API
BoundarySegment Class
Members Example See Also Send Feedback
An object that represents a segment of a room boundary.

Namespace: Autodesk.Revit.Rooms
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BoundarySegment : APIObject
Visual Basic (Declaration)
Public Class BoundarySegment _
    Inherits APIObject
Visual C++
public ref class BoundarySegment : public APIObject

Remarks

These objects define the the exterior boundary of a room. The geometry of the segment can be retrieved along with the element that is responsible for producing that boundary.

Examples

CopyC#
public void GetInfo_BoundarySegment(Room room)
{
    if (room.Boundary != null)
    {
        string message = "BoundarySegment";
        foreach (BoundarySegmentArray boundarySegmentArray in room.Boundary)
        {
            foreach (BoundarySegment boundarySegment in boundarySegmentArray)
            {
                // Get curve start point
                message += "\nCurve start point:(" + boundarySegment.Curve.get_EndPoint(0).X + ","
                               + boundarySegment.Curve.get_EndPoint(0).Y + "," +
                              boundarySegment.Curve.get_EndPoint(0).Z + ")";
                // Get curve end point
                message += "; Curve end point:(" + boundarySegment.Curve.get_EndPoint(1).X + ","
                     + boundarySegment.Curve.get_EndPoint(1).Y + "," +
                     boundarySegment.Curve.get_EndPoint(1).Z + ")";
                // Get document path name
                message += "; Document path name:" + boundarySegment.Document.PathName;
                // Get boundary segment element name
                message += "; Element name:" + boundarySegment.Element.Name;
            }
        }
        MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
    }
}
CopyVB.NET
Public Sub GetInfo_BoundarySegment(ByVal room As Room)
    If room.Boundary IsNot Nothing Then
        Dim message As String = "BoundarySegment"
        For Each boundarySegmentArray As BoundarySegmentArray In room.Boundary
            For Each boundarySegment As BoundarySegment In boundarySegmentArray
                ' Get curve start point
                message += ((vbLf & "Curve start point:(" & boundarySegment.Curve.EndPoint(0).X & ",") + boundarySegment.Curve.EndPoint(0).Y & ",") + boundarySegment.Curve.EndPoint(0).Z & ")"
                ' Get curve end point
                message += (("; Curve end point:(" & boundarySegment.Curve.EndPoint(1).X & ",") + boundarySegment.Curve.EndPoint(1).Y & ",") + boundarySegment.Curve.EndPoint(1).Z & ")"
                ' Get document path name
                message += "; Document path name:" & boundarySegment.Document.PathName
                ' Get boundary segment element name
                message += "; Element name:" & boundarySegment.Element.Name
            Next
        Next
        MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Rooms..::.BoundarySegment

See Also

BoundarySegment Members
Autodesk.Revit.Rooms Namespace

BoundarySegment Members

[image] [image]