Revit 2010 API
DividedSurfaceData..::.GetDividedSurfaceForReference Method
DividedSurfaceData Class See Also Send Feedback
Find the DividedSurface element that is associated with a surface of this element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DividedSurface GetDividedSurfaceForReference(
    Reference reference
)
Visual Basic (Declaration)
Public Function GetDividedSurfaceForReference ( _
    reference As Reference _
) As DividedSurface
Visual C++
public:
DividedSurface^ GetDividedSurfaceForReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.Geometry..::.Reference

Return Value

A DividedSurface element, if there is one associated with this face; null if the reference is to a face without a DividedSurface.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when reference is not a face (surface) reference.

See Also

DividedSurfaceData Class
Autodesk.Revit.Elements Namespace

GetReferencesWithDividedSurfaces Method

[image]