Revit 2010 API
FamilyManager..::.SetValueString Method
FamilyManager Class See Also Send Feedback
Set the string value of a family parameter of the current family type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetValueString(
    FamilyParameter familyParameter,
    string value
)
Visual Basic (Declaration)
Public Sub SetValueString ( _
    familyParameter As FamilyParameter, _
    value As String _
)
Visual C++
public:
void SetValueString(
    FamilyParameter^ familyParameter,
    String^ value
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter
The family parameter of current type.
value
Type: System..::.String
The new value string for family parameter.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the input argument-"familyParameter" or "value"-is null.
System..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter. or the input argument-"value"-is an illegal string.
System..::.ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
System..::.InvalidOperationException | Thrown when the family parameter is determined by formula, or it is not a value type, or the current family type is invalid.

See Also

FamilyManager Class
Autodesk.Revit Namespace

FamilyManager Properties

[image] [image]