Revit 2010 API
VolumeCalculationOptions..::.VolumeComputationEnable Property
VolumeCalculationOptions Class Example See Also Send Feedback
True to enable volume computation in Revit. False to disable it.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool VolumeComputationEnable { get; set; }
Visual Basic (Declaration)
Public Property VolumeComputationEnable As Boolean
Visual C++
public:
property bool VolumeComputationEnable {
    bool get ();
    void set (bool value);
}

Examples

CopyC#
public void GetRoomDimensions(Document doc, Room room)
{
    String roominfo = "Room dimensions:\n";
    // turn on volume calculations:
    doc.Settings.VolumeCalculationSetting.VolumeCalculationOptions.VolumeComputationEnable = true;
    roominfo += "Vol: " + room.Volume + "\n";
    roominfo += "Area: " + room.Area + "\n";
    roominfo += "Perimiter: " + room.Perimeter + "\n";
    roominfo += "Unbounded height: " + room.UnboundedHeight + "\n";
    MessageBox.Show(roominfo);
}
CopyVB.NET
Public Sub GetRoomDimensions(ByVal doc As Document, ByVal room As Room)
    Dim roominfo As String = "Room dimensions:" & vbLf
    ' turn on volume calculations:
    doc.Settings.VolumeCalculationSetting.VolumeCalculationOptions.VolumeComputationEnable = True
    roominfo += "Vol: " & room.Volume & vbLf
    roominfo += "Area: " & room.Area & vbLf
    roominfo += "Perimiter: " & room.Perimeter & vbLf
    roominfo += "Unbounded height: " & room.UnboundedHeight & vbLf
    MessageBox.Show(roominfo)
End Sub

See Also

VolumeCalculationOptions Class
Autodesk.Revit Namespace

VolumeCalculationSetting Class

[image]