Revit 2010 API
Document..::.NewWall Method (Curve, Level, Boolean)
Document Class Example See Also Send Feedback
Creates a new rectangular profile wall within the project using the default wall style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Wall NewWall(
    Curve curve,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Function NewWall ( _
    curve As Curve, _
    level As Level, _
    structural As Boolean _
) As Wall
Visual C++
public:
Wall^ NewWall(
    Curve^ curve,
    Level^ level,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
An arc or line representing the base line of the wall.
level
Type: Autodesk.Revit.Elements..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise Nothing.

Examples

CopyC#
public Wall CreateWallUsingCurve1(Autodesk.Revit.Document document, Level level)
{
    // Build a location line for the wall creation
    XYZ start = new XYZ(0, 0, 0);
    XYZ end = new XYZ(10, 10, 0);
    Line geomLine = document.Application.Create.NewLineBound(start, end);

    // Create a wall using the location line
    return document.Create.NewWall(geomLine, level, true);
}
CopyVB.NET
Public Function CreateWallUsingCurve1(ByVal document As Autodesk.Revit.Document, ByVal level As Autodesk.Revit.Elements.Level) As Wall
    ' Build a location line for the wall creation
    Dim start As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
    Dim [end] As New Autodesk.Revit.Geometry.XYZ(10, 10, 0)
    Dim geomLine As Line = document.Application.Create.NewLineBound(start, [end])

    ' Create a wall using the location line
    Return document.Create.NewWall(geomLine, level, True)
End Function

See Also

Document Class
NewWall Overload
Autodesk.Revit.Creation Namespace

NewWall Method (CurveArray, WallType, Level, Boolean)

[image]