Revit 2010 API
FamilyManager..::.AssociateElementParameterToFamilyParameter Method
FamilyManager Class See Also Send Feedback
Associates or disassociates the element parameter to an existing family parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AssociateElementParameterToFamilyParameter(
    Parameter elementParameter,
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Sub AssociateElementParameterToFamilyParameter ( _
    elementParameter As Parameter, _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void AssociateElementParameterToFamilyParameter(
    Parameter^ elementParameter,
    FamilyParameter^ familyParameter
)

Parameters

elementParameter
Type: Autodesk.Revit..::.Parameter
The parameter of an element in family.
familyParameter
Type: Autodesk.Revit..::.FamilyParameter
The existing family parameter. If the input to this argument is null, it will disassociate the element parameter from any family parameters.

Remarks

The parameter types of these two input parameter should be same, if not an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"elementParameter"-is null.
System..::.ArgumentException | Thrown when the input argument-"elementParameter" or "familyParameter"-is an invalid parameter, or the input argument-"elementParameter"-cannot be associated.
System..::.InvalidOperationException | Thrown when the family parameter binding failed.

See Also

FamilyManager Class
Autodesk.Revit Namespace

CanElementParameterBeAssociated Method

[image]