Revit 2010 API
Application..::.NewCurveArrArray Method
Application Class See Also Send Feedback
Creates an empty array that can store geometric curve loops.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveArrArray NewCurveArrArray()
Visual Basic (Declaration)
Public Function NewCurveArrArray As CurveArrArray
Visual C++
public:
CurveArrArray^ NewCurveArrArray()

Return Value

The empty array of curve loops.

Remarks

Use the return of this method in methods as NewExtrusion and NewSweep to create geometry.

See Also

Application Class
Autodesk.Revit.Creation Namespace

NewCurveArray Method

[image]