Revit 2010 API
FlexDuct Class
Members See Also Send Feedback
A flex duct in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FlexDuct : MEPCurve
Visual Basic (Declaration)
Public Class FlexDuct _
    Inherits MEPCurve
Visual C++
public ref class FlexDuct : public MEPCurve

Remarks

The flex duct is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.MEP..::.MEPCurve
Autodesk.Revit.MEP..::.FlexDuct

See Also

FlexDuct Members
Autodesk.Revit.MEP Namespace

FlexDuct Members

[image] [image]