Revit 2010 API
FamilyType..::.AsString Method
FamilyType Class See Also Send Feedback
Provides access to the string contents of the given family parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string AsString(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function AsString ( _
    familyParameter As FamilyParameter _
) As String
Visual C++
public:
String^ AsString(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter

Return Value

The string contained in the parameter. Returns null if the storage type of the input argument is not string type or this parameter has no value.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,

See Also

FamilyType Class
Autodesk.Revit Namespace

AsValueString Method

[image]