Revit 2010 API
RebarShapeDefinitionByArcType Enumeration
See Also Send Feedback
A RebarShapeDefinitionByArc takes one of three forms.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum RebarShapeDefinitionByArcType
Visual Basic (Declaration)
Public Enumeration RebarShapeDefinitionByArcType
Visual C++
public enum class RebarShapeDefinitionByArcType

Members

Member name | Description
LappedCircle | A full circle, subtending an angle more than 360 degrees and less than 720 degrees. The behavior in Revit is the same as Arc, but an extra complete circle is included in the rebar.
Arc | An arc, subtending an angle less than 360 degrees.

See Also

Autodesk.Revit.Structural.Enums Namespace

RebarStyle Enumeration

[image]