Revit 2010 API
Filter..::.NewCategoryFilter Method (BuiltInCategory)
Filter Class See Also Send Feedback
Creates a new category filter object related to a built-in category id.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CategoryFilter NewCategoryFilter(
    BuiltInCategory builtInCat
)
Visual Basic (Declaration)
Public Function NewCategoryFilter ( _
    builtInCat As BuiltInCategory _
) As CategoryFilter
Visual C++
public:
CategoryFilter^ NewCategoryFilter(
    BuiltInCategory builtInCat
)

Parameters

builtInCat
Type: Autodesk.Revit..::.BuiltInCategory
Filter elements by the built-in category.

Return Value

Returns a new category filter object with given built-in category.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
NewCategoryFilter Overload
Autodesk.Revit.Creation Namespace

NewCategoryFilter Method (Category)

[image]