Revit 2010 API
Instance Members
Instance Class Constructors Methods Properties See Also Send Feedback

The Instance type exposes the following members.

Constructors

Name | Description
Instance | For Internal Use Only.

Methods

Name | Description
GetInstanceGeometry | Overloaded.
GetSymbolGeometry | Overloaded.

Properties

Name | Description
Symbol | The symbol element that this object is referring to.
SymbolGeometry | The geometric representation of the symbol which generates this instance.
Transform | The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.

See Also

Instance Class
Autodesk.Revit.Geometry Namespace

Instance Constructor

[image]