Revit 2010 API
CurveByPoints Class
Members See Also Send Feedback
A curve interpolating two or more points.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CurveByPoints : CurveElement
Visual Basic (Declaration)
Public Class CurveByPoints _
    Inherits CurveElement
Visual C++
public ref class CurveByPoints : public CurveElement

Remarks

The points to be interpolated are represented as ReferencePoints, which must already exist in the document. In terms of appearance and graphics control, CurveByPoints behaves similarly to ModelCurve. The main difference being that a ModelCurve refers to a SketchPlane, while a CurveByPoints does not.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CurveElement
Autodesk.Revit.Elements..::.CurveByPoints

See Also

CurveByPoints Members
Autodesk.Revit.Elements Namespace

CurveByPoints Members

[image] [image]