Revit 2010 API
FamilyManager..::.RemoveParameter Method
FamilyManager Class See Also Send Feedback
Remove an existing family parameter from the family.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveParameter(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Sub RemoveParameter ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void RemoveParameter(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter
The family parameter.

Remarks

Only family and shared parameters may be removed, built-in parameters may not be removed. If the parameter is used in any formulas, those formulas will be automatically removed along with the parameter.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.
System..::.InvalidOperationException | Thrown when the family parameter deletion failed.

See Also

FamilyManager Class
Autodesk.Revit Namespace

RenameCurrentType Method

[image]