Revit 2010 API
Fascia Class
Members See Also Send Feedback
An object that represents a fascia within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Fascia : HostedSweep
Visual Basic (Declaration)
Public Class Fascia _
    Inherits HostedSweep
Visual C++
public ref class Fascia : public HostedSweep

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.Elements..::.HostedSweep
Autodesk.Revit.Elements..::.Fascia

See Also

Fascia Members
Autodesk.Revit.Elements Namespace

Fascia Members

[image] [image]