Revit 2010 API
Document..::.NewDuct Method (XYZ, XYZ, DuctType)
Document Class See Also Send Feedback
Adds a new duct into the document, using two points and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Duct NewDuct(
    XYZ point1,
    XYZ point2,
    DuctType ductType
)
Visual Basic (Declaration)
Public Function NewDuct ( _
    point1 As XYZ, _
    point2 As XYZ, _
    ductType As DuctType _
) As Duct
Visual C++
public:
Duct^ NewDuct(
    XYZ^ point1,
    XYZ^ point2,
    DuctType^ ductType
)

Parameters

point1
Type: Autodesk.Revit.Geometry..::.XYZ
The first point of the duct.
point2
Type: Autodesk.Revit.Geometry..::.XYZ
The second point of the duct.
ductType
Type: Autodesk.Revit.MEP..::.DuctType
The type of the duct.

Return Value

If creation was successful then a new duct is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument point1 or point2 is null.
System..::.InvalidOperationException | Thrown when the duct cannot be created or regenerate fails.

See Also

Document Class
NewDuct Overload
Autodesk.Revit.Creation Namespace

NewDuct Method (XYZ, Connector, DuctType)

[image]