Revit 2010 API
Document..::.Elements Property (Filter)
Document Class Example See Also Send Feedback
Provides access to all elements which satisfy specified filter within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementIterator Elements[
    Filter filter
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements ( _
    filter As Filter _
) As ElementIterator
Visual C++
public:
property ElementIterator^ Elements[Filter^ filter] {
    ElementIterator^ get (Filter^ filter);
}

Parameters

filter
Type: Autodesk.Revit..::.Filter
Filter specified by user.

Remarks

The input filter parameter can be one of: TypeFilter, CategoryFilter, FamilyFilter, SymbolFilter, ParameterFilter, InstanceUsageFilter, WallUsageFilter, MaterialFilter or StructuralTypeFilter; This filter can be combination of more than one filters by using logical And and Or filters.

Examples

CopyC#
// Create a Filter to get all the doors in the document
Autodesk.Revit.Creation.Filter filterCreator = document.Application.Create.Filter;
TypeFilter familyInstanceFilter = filterCreator.NewTypeFilter(typeof(FamilyInstance), true);
CategoryFilter doorsCategoryfilter = filterCreator.NewCategoryFilter(BuiltInCategory.OST_Doors);
Filter doorInstancesFilter = filterCreator.NewLogicAndFilter(familyInstanceFilter, doorsCategoryfilter);

// Apply the filter to the elements in the active document
ElementIterator iterator = document.get_Elements(doorInstancesFilter);

String prompt = "The ids of the doors in the current document are:";
iterator.Reset();
while (iterator.MoveNext())
{
    FamilyInstance door = iterator.Current as FamilyInstance;
    // output the id of the doors
    prompt += "\n\t" + door.Id.Value;
}

// Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);
CopyVB.NET
' Create a Filter to get all the doors in the document
Dim filterCreator As Autodesk.Revit.Creation.Filter = document.Application.Create.Filter
Dim familyInstanceFilter As TypeFilter = filterCreator.NewTypeFilter(GetType(Autodesk.Revit.Elements.FamilyInstance), True)
Dim doorsCategoryfilter As CategoryFilter = filterCreator.NewCategoryFilter(BuiltInCategory.OST_Doors)
Dim doorInstancesFilter As Filter = filterCreator.NewLogicAndFilter(familyInstanceFilter, doorsCategoryfilter)

' Apply the filter to the elements in the active document
Dim iterator As ElementIterator = document.Elements(doorInstancesFilter)

Dim prompt As String = "The ids of the doors in the current document are:"
iterator.Reset()
While iterator.MoveNext()
    Dim door As Autodesk.Revit.Elements.FamilyInstance = TryCast(iterator.Current, Autodesk.Revit.Elements.FamilyInstance)
    ' output the id of the doors
    prompt += vbLf & vbTab & door.Id.Value
End While

' Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter of Filter is null.

See Also

Document Class
Elements Overload
Autodesk.Revit Namespace

Elements Property (Type)

[image]