Revit 2010 API
Document..::.NewFootPrintRoof Method
Document Class Example See Also Send Feedback
Creates a new FootPrintRoof element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FootPrintRoof NewFootPrintRoof(
    CurveArray footPrint,
    Level level,
    RoofType roofType,
    ElementIdSet footPrintToModelCurvesMapping
)
Visual Basic (Declaration)
Public Function NewFootPrintRoof ( _
    footPrint As CurveArray, _
    level As Level, _
    roofType As RoofType, _
    footPrintToModelCurvesMapping As ElementIdSet _
) As FootPrintRoof
Visual C++
public:
FootPrintRoof^ NewFootPrintRoof(
    CurveArray^ footPrint,
    Level^ level,
    RoofType^ roofType,
    ElementIdSet^ footPrintToModelCurvesMapping
)

Parameters

footPrint
Type: Autodesk.Revit.Geometry..::.CurveArray
The footprint of the FootPrintRoof.
level
Type: Autodesk.Revit.Elements..::.Level
The level of the FootPrintRoof.
roofType
Type: Autodesk.Revit.Symbols..::.RoofType
Type of the FootPrintRoof.
footPrintToModelCurvesMapping
Type: Autodesk.Revit..::.ElementIdSet
Map footprint to Model Curves.

Examples

CopyC#
// Before invoking this sample, select some walls to add a roof over.
// Make sure there is a level named "Roof" in the document.

// find the Roof level
Level level = null;
ElementIterator elemItor = document.get_Elements(typeof(Level));
elemItor.Reset();
while (elemItor.MoveNext())
{
    Level currentLevel = elemItor.Current as Level;
    if (currentLevel.Name == "Roof")
    {
        level = currentLevel;
    }
}

RoofType rooftype = null;
// select the first rooftype
foreach (RoofType rt in document.RoofTypes)
{
    rooftype = rt;
    break;
}

// Get the handle of the application
Autodesk.Revit.Application application = document.Application;

// Define the footprint for the roof based on user selection
CurveArray footprint = application.Create.NewCurveArray();

if (document.Selection.Elements.Size != 0)
{
    foreach (Autodesk.Revit.Element element in document.Selection.Elements)
    {
        Wall wall = element as Wall;
        if (wall != null)
        {
            LocationCurve wallCurve = wall.Location as LocationCurve;
            footprint.Append(wallCurve.Curve);
            continue;
        }

        ModelCurve modelCurve = element as ModelCurve;
        if (modelCurve != null)
        {
            footprint.Append(modelCurve.GeometryCurve);
        }
    }

}
else
{
    throw new Exception("You should select a curve loop, or a wall loop, or loops combination \nof walls and curves to create a footprint roof.");
}

FootPrintRoof footprintRoof = document.Create.NewFootPrintRoof(footprint, level, rooftype, application.Create.NewElementIdSet());
CopyVB.NET
' Before invoking this sample, select some walls to add a roof over.
' Make sure there is a level named "Roof" in the document.

' find the Roof level
Dim level As Autodesk.Revit.Elements.Level = Nothing
Dim elemItor As ElementIterator = document.Elements(GetType(Autodesk.Revit.Elements.Level))
elemItor.Reset()
While elemItor.MoveNext()
    Dim currentLevel As Autodesk.Revit.Elements.Level = TryCast(elemItor.Current, Autodesk.Revit.Elements.Level)
    If currentLevel.Name = "Roof" Then
        level = currentLevel
    End If
End While

Dim rooftype As RoofType = Nothing
' select the first rooftype
For Each rt As RoofType In document.RoofTypes
    rooftype = rt
    Exit For
Next

' Get the handle of the application
Dim application As Autodesk.Revit.Application = document.Application

' Define the footprint for the roof based on user selection
Dim footprint As CurveArray = application.Create.NewCurveArray()

If document.Selection.Elements.Size <> 0 Then
    For Each element As Autodesk.Revit.Element In document.Selection.Elements
        Dim wall As Wall = TryCast(element, Wall)
        If wall IsNot Nothing Then
            Dim wallCurve As LocationCurve = TryCast(wall.Location, LocationCurve)
            footprint.Append(wallCurve.Curve)
            Continue For
        End If

        Dim modelCurve As ModelCurve = TryCast(element, ModelCurve)
        If modelCurve IsNot Nothing Then
            footprint.Append(modelCurve.GeometryCurve)
        End If
    Next

Else
    Throw New Exception("You should select a curve loop, or a wall loop, or loops combination " & vbLf & "of walls and curves to create a footprint roof.")
End If

Dim footprintRoof As FootPrintRoof = document.Create.NewFootPrintRoof(footprint, level, rooftype, application.Create.NewElementIdSet())

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewFoundationSlab Method

[image]