Revit 2010 API
Application..::.NewFamilyInstanceCreationData Method (Curve, FamilySymbol, Level, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    curve As Curve, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
The curve where the instance is based.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.Elements..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace

NewFamilyInstanceCreationData Method (Face, XYZ, XYZ, FamilySymbol)

[image]