Revit 2010 API
ControlledApplication..::.DocumentPrinted Event
ControlledApplication Class Example See Also Send Feedback
Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentPrintedEventArgs> DocumentPrinted
Visual Basic (Declaration)
Public Event DocumentPrinted As EventHandler(Of DocumentPrintedEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintedEventArgs^>^ DocumentPrinted {
    void add (EventHandler<DocumentPrintedEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view or ViewSet of the document. It is raised even when document printing failed or was cancelled (during DocumentPriting event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of printing has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

Examples

CopyC#
public class Application_DocumentPrinted : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public IExternalApplication.Result OnStartup(ControlledApplication application)
    {
        // Register related events
        application.DocumentPrinted += new EventHandler<Autodesk.Revit.Events.DocumentPrintedEventArgs>(AppDocumentPrinted);
        return IExternalApplication.Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public IExternalApplication.Result OnShutdown(ControlledApplication application)
    {
        // unregister events
        application.DocumentPrinted -= new EventHandler<Autodesk.Revit.Events.DocumentPrintedEventArgs>(AppDocumentPrinted);
        return IExternalApplication.Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentPrinted class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for DocumentPrinted event, it will display some event arguments.
    /// </summary>
    public void AppDocumentPrinted(object sender, Autodesk.Revit.Events.DocumentPrintedEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("DocumentPrintedEventArgs Parameters ------>");
        info.AppendLine("    Event Status      : " + args.Status.ToString());
        info.AppendLine("    Event Cancellable : " + args.Cancellable);
        //
        // PrintedViews
        if (null == args.FailedViews || 0 == args.PrintedViews.Size)
        {
            info.AppendLine("    Views been printed: <null>");
        }
        else
        {
            info.AppendLine("    Views been printed: ");
            DumpViewsInfo(args.PrintedViews, "      ", ref info);
        }
        //
        // FailedViews
        if (null == args.FailedViews || 0 == args.FailedViews.Size)
        {
            info.AppendLine("    Views failed: <null>");
        }
        else
        {
            info.AppendLine("    Views Failed : ");
            DumpViewsInfo(args.FailedViews, "      ", ref info);
        }

        MessageBox.Show(info.ToString(), "DocumentPrinted Info");
    }

    /// <summary>
    /// Dump information of views: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="views">Views to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewsInfo(ViewSet views, String prefix, ref StringBuilder info)
    {
        int index = 0;
        ViewSetIterator vsi = views.ForwardIterator();
        vsi.Reset();
        while (vsi.MoveNext())
        {
            Autodesk.Revit.Elements.View curView = vsi.Current as Autodesk.Revit.Elements.View;
            if (null != curView)
            {
                DumpViewInfo(curView, String.Format("{0}#{1}", prefix, index++), ref info);
            }
        }
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.Elements.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.Value, view.ViewName, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_DocumentPrinted
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.DocumentPrinted, AddressOf AppDocumentPrinted
        Return IExternalApplication.Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.DocumentPrinted, AddressOf AppDocumentPrinted
        Return IExternalApplication.Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentPrinted class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for DocumentPrinted event, it will display some event arguments.
    ' </summary>
    Public Sub AppDocumentPrinted(ByVal sender As Object, ByVal args As Autodesk.Revit.Events.DocumentPrintedEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("DocumentPrintedEventArgs Parameters ------>")
        info.AppendLine(" Event Status : " & args.Status.ToString())
        info.AppendLine(" Event Cancellable : " & args.Cancellable)
        '
        ' PrintedViews
        If args.FailedViews Is Nothing OrElse 0 = args.PrintedViews.Size Then
            info.AppendLine(" Views been printed: <null>")
        Else
            info.AppendLine(" Views been printed: ")
            DumpViewsInfo(args.PrintedViews, " ", info)
        End If
        '
        ' FailedViews
        If args.FailedViews Is Nothing OrElse 0 = args.FailedViews.Size Then
            info.AppendLine(" Views failed: <null>")
        Else
            info.AppendLine(" Views Failed : ")
            DumpViewsInfo(args.FailedViews, " ", info)
        End If

        MessageBox.Show(info.ToString(), "DocumentPrinted Info")
    End Sub

    ' <summary>
    ' Dump information of views: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="views">Views to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewsInfo(ByVal views As ViewSet, ByVal prefix As String, ByRef info As StringBuilder)
        Dim index As Integer = 0
        Dim vsi As ViewSetIterator = views.ForwardIterator()
        vsi.Reset()
        While vsi.MoveNext()
            Dim curView As Autodesk.Revit.Elements.View = TryCast(vsi.Current, Autodesk.Revit.Elements.View)
            If curView IsNot Nothing Then
                DumpViewInfo(curView, [String].Format("{0}#{1}", prefix, System.Math.Max(System.Threading.Interlocked.Increment(index), index - 1)), info)
            End If
        End While
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(ByVal view As Autodesk.Revit.Elements.View, ByVal prefix As String, ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.Value, view.ViewName, view.ViewType))
    End Sub
End Class

See Also

ControlledApplication Class
Autodesk.Revit Namespace

DocumentPrinting Event

[image]