Revit 2010 API
Truss Class
Members See Also Send Feedback
Represents all kinds of Trusses.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Truss : Element
Visual Basic (Declaration)
Public Class Truss _
    Inherits Element
Visual C++
public ref class Truss : public Element

Remarks

The Truss object represents all the kinds of Trusses in Revit. The TrussType property is used to distinguish the type of the Truss. The Truss object is derived from the Element object and hence it supports all the properties and methods of that object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Truss

See Also

Truss Members
Autodesk.Revit.Elements Namespace

Truss Members

[image] [image]