Revit 2010 API
Document..::.CombineElements Method
Document Class See Also Send Feedback
Combine a set of combinable elements into a geometry combination.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GeomCombination CombineElements(
    CombinableElementArray members
)
Visual Basic (Declaration)
Public Function CombineElements ( _
    members As CombinableElementArray _
) As GeomCombination
Visual C++
public:
GeomCombination^ CombineElements(
    CombinableElementArray^ members
)

Parameters

members
Type: Autodesk.Revit.Elements..::.CombinableElementArray
A list of combinable elements to be combined.

Return Value

If successful, the newly created geometry combination is returned, otherwise an exception with error information will be thrown.

Remarks

If one or more existing geometry combinations are included as input, the return value may be one of those pre-existing combinations. The rest of the pre-existing geometry combinations will be consumed into the new combination; those handles are no longer valid.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument is null.
System..::.ArgumentException | Thrown when members contains less than two elements. Thrown when members contains null elements.
System..::.InvalidOperationException | Thrown when creation of the combination failed.

See Also

Document Class
Autodesk.Revit Namespace

Delete Method

[image] [image]