Revit 2010 API
FamilyManager..::.DeleteCurrentType Method
FamilyManager Class See Also Send Feedback
Remove the current family type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void DeleteCurrentType()
Visual Basic (Declaration)
Public Sub DeleteCurrentType
Visual C++
public:
void DeleteCurrentType()

Remarks

If successfully removed, the first available type will become the current type, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when there is only one family type in current document.

See Also

FamilyManager Class
Autodesk.Revit Namespace

GetAssociatedFamilyParameter Method

[image]