Revit 2010 API
FlexPipeType Class
Members See Also Send Feedback
A flex pipe type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FlexPipeType : MEPCurveType
Visual Basic (Declaration)
Public Class FlexPipeType _
    Inherits MEPCurveType
Visual C++
public ref class FlexPipeType : public MEPCurveType

Remarks

The flex pipe type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.MEPCurveType
Autodesk.Revit.MEP..::.FlexPipeType

See Also

FlexPipeType Members
Autodesk.Revit.MEP Namespace

FlexPipeType Members

[image] [image]