Revit 2010 API
DuctType Class
Members See Also Send Feedback
A duct type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class DuctType : MEPCurveType
Visual Basic (Declaration)
Public Class DuctType _
    Inherits MEPCurveType
Visual C++
public ref class DuctType : public MEPCurveType

Remarks

The duct type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.MEPCurveType
Autodesk.Revit.MEP..::.DuctType

See Also

DuctType Members
Autodesk.Revit.MEP Namespace

DuctType Members

[image] [image]