Revit 2010 API
Application Methods
Application Class See Also Send Feedback

The Application type exposes the following members.

Methods

Name | Description
CreateRibbonPanel | Create a new RibbonPanel.
ExtractPartAtomFromFamilyFile | Writes a PartAtom XML from the contents of a family file.
GetRibbonPanels | Get all the custom Panels on Add-Ins tab of Revit.
NewFamilyDocument | New family document, including family, titleblock, and annotation symbol
NewProjectDocument | New project document
NewProjectTemplateDocument | New project template document
OpenDocumentFile | Overloaded. Opens a document from disk.
OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.

See Also

Application Class
Autodesk.Revit Namespace

CreateRibbonPanel Method

[image]