Revit 2010 API
Element..::.Location Property
Element Class Example See Also Send Feedback
This property is used to find the physical location of an element within a project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Location Location { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get ();
}

Remarks

The Location property returns an object that can be used to find the location of an object within the project. An object may have a point location, such as a table or may have a line location. A wall is an example of an element that has a line location.

Examples

CopyC#
void GetLocationInformation(Autodesk.Revit.Element element)
{
    // Get the Location property and judge whether it exists
    Autodesk.Revit.Location position = element.Location;

    String prompt = null;
    if (null == position)
    {
        prompt = "No location can be found in element.";
    }
    else
    {
        // If the location is a point location, give the user information
        Autodesk.Revit.LocationPoint positionPoint = position as Autodesk.Revit.LocationPoint;
        if (null != positionPoint)
        {
            prompt = "Element has a point location.";
        }
        else
        {

            // If the location is a curve location, give the user information
            Autodesk.Revit.LocationCurve positionCurve = position as Autodesk.Revit.LocationCurve;
            if (null != positionCurve)
            {
                prompt = "Element has a curve location.";
            }
        }
    }

    if (null != prompt)
    {
        MessageBox.Show(prompt, "Revit");
    }
}
CopyVB.NET
Private Sub GetLocationInformation(ByVal element As Autodesk.Revit.Element)
    ' Get the Location property and judge whether it exists
    Dim position As Autodesk.Revit.Location = element.Location

    Dim prompt As String = Nothing
    If position Is Nothing Then
        prompt = "No location can be found in element."
    Else
        ' If the location is a point location, give the user information
        Dim positionPoint As Autodesk.Revit.LocationPoint = TryCast(position, Autodesk.Revit.LocationPoint)
        If positionPoint IsNot Nothing Then
            prompt = "Element has a point location."
        Else

            ' If the location is a curve location, give the user information
            Dim positionCurve As Autodesk.Revit.LocationCurve = TryCast(position, Autodesk.Revit.LocationCurve)
            If positionCurve IsNot Nothing Then
                prompt = "Element has a curve location."
            End If
        End If
    End If

    If prompt IsNot Nothing Then
        MessageBox.Show(prompt, "Revit")
    End If
End Sub

See Also

Element Class
Autodesk.Revit Namespace

Materials Property

[image]