Revit 2010 API
Document..::.NewPointLoad Method (XYZ, XYZ, XYZ, Boolean, PointLoadType, SketchPlane)
Document Class Example See Also Send Feedback
Creates a new unhosted point load within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PointLoad NewPointLoad(
    XYZ point,
    XYZ force,
    XYZ moment,
    bool isReaction,
    PointLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewPointLoad ( _
    point As XYZ, _
    force As XYZ, _
    moment As XYZ, _
    isReaction As Boolean, _
    symbol As PointLoadType, _
    plane As SketchPlane _
) As PointLoad
Visual C++
public:
PointLoad^ NewPointLoad(
    XYZ^ point,
    XYZ^ force,
    XYZ^ moment,
    bool isReaction,
    PointLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
The point of the PointLoad application.
force
Type: Autodesk.Revit.Geometry..::.XYZ
The 3d force.
moment
Type: Autodesk.Revit.Geometry..::.XYZ
The 3d moment.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.Symbols..::.PointLoadType
The symbol of the PointLoad.
plane
Type: Autodesk.Revit.Elements..::.SketchPlane
Indicate the work plane of the PointLoad.

Return Value

If successful, NewPointLoad returns an object for the newly created PointLoad. Nothing is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
//Define the location at which the PointLoad is applied.
XYZ point = new XYZ(0, 0, 4);
//Define the 3d force.
XYZ force = new XYZ(0, 0, -1);
//Define the 3d moment.
XYZ moment = new XYZ(0, 0, 0);
//Set to True if you wish to create the reaction
System.Boolean isReaction = true;

PointLoad pointLoad = document.Create.NewPointLoad(point, force, moment, isReaction, null, null);
CopyVB.NET
'Define the location at which the PointLoad is applied.
Dim point As New Autodesk.Revit.Geometry.XYZ(0, 0, 4)
'Define the 3d force.
Dim force As New Autodesk.Revit.Geometry.XYZ(0, 0, -1)
'Define the 3d moment.
Dim moment As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
'Set to True if you wish to create the reaction
Dim isReaction As Boolean = True

Dim pointLoad As Autodesk.Revit.Elements.PointLoad = document.Create.NewPointLoad(point, force, moment, isReaction, Nothing, Nothing)

See Also

Document Class
NewPointLoad Overload
Autodesk.Revit.Creation Namespace

NewRebar Method

[image] [image]