Revit 2010 API
ReferencePlane Class
Members Example See Also Send Feedback
Represents a reference plane of Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ReferencePlane : Element
Visual Basic (Declaration)
Public Class ReferencePlane _
    Inherits Element
Visual C++
public ref class ReferencePlane : public Element

Remarks

This object is derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object also has many methods to set the specific properties of the reference plane

Examples

CopyC#
private void Getinfo_ReferencePlane(ReferencePlane refPlane)
{
    string message = "Reference Plane: ";
    //get the bubble end of the reference plane
    XYZ bubbleEnd = refPlane.BubbleEnd;
    message += "\nBubble end: (" + bubbleEnd.X + ", "
                       + bubbleEnd.Y + ", " + bubbleEnd.Z + ")";

    //get the direction of the reference plane
    XYZ direction = refPlane.Direction;
    message += "\nDirection: (" + direction.X + ", "
                    + direction.Y + ", " + direction.Z + ")";

    //get the freeEnd of the reference plane
    XYZ freeEnd = refPlane.FreeEnd;
    message += "\nFree End: (" + freeEnd.X + ", "
                    + freeEnd.Y + ", " + freeEnd.Z + ")";

    //get the name of the reference plane
    message += "\nName: " + refPlane.Name;

    //get the normal vector of the reference plane
    XYZ normal = refPlane.Normal;
    message += "\nNormal vector: (" + normal.X + ", "
                    + normal.Y + ", " + normal.Z + ")";

    //get the geometry plane to which the reference plane assigned
    Autodesk.Revit.Geometry.Plane plane = refPlane.Plane;
    message += "\norigin of the plane: (" + plane.Origin.X + ", "
                    + plane.Origin.Y + ", " + plane.Origin.Z + ")";

    message += "\nnormal of the plane: (" + plane.Normal.X + ", "
                    + plane.Normal.Y + ", " + plane.Normal.Z + ")";

    message += "\nXvec of the plane: (" + plane.XVec.X + ", "
                    + plane.XVec.Y + ", " + plane.XVec.Z + ")";

    message += "\nYvec of the plane: (" + plane.YVec.X + ", "
                    + plane.YVec.Y + ", " + plane.YVec.Z + ")";

    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Private Sub Getinfo_ReferencePlane(ByVal refPlane As ReferencePlane)
    Dim message As String = "Reference Plane: "
    'get the bubble end of the reference plane
    Dim bubbleEnd As Autodesk.Revit.Geometry.XYZ = refPlane.BubbleEnd
    message += ((vbLf & "Bubble end: (" & bubbleEnd.X & ", ") + bubbleEnd.Y & ", ") + bubbleEnd.Z & ")"

    'get the direction of the reference plane
    Dim direction As Autodesk.Revit.Geometry.XYZ = refPlane.Direction
    message += ((vbLf & "Direction: (" & direction.X & ", ") + direction.Y & ", ") + direction.Z & ")"

    'get the freeEnd of the reference plane
    Dim freeEnd As Autodesk.Revit.Geometry.XYZ = refPlane.FreeEnd
    message += ((vbLf & "Free End: (" & freeEnd.X & ", ") + freeEnd.Y & ", ") + freeEnd.Z & ")"

    'get the name of the reference plane
    message += vbLf & "Name: " & refPlane.Name

    'get the normal vector of the reference plane
    Dim normal As Autodesk.Revit.Geometry.XYZ = refPlane.Normal
    message += ((vbLf & "Normal vector: (" & normal.X & ", ") + normal.Y & ", ") + normal.Z & ")"

    'get the geometry plane to which the reference plane assigned
    Dim plane As Autodesk.Revit.Geometry.Plane = refPlane.Plane
    message += ((vbLf & "origin of the plane: (" & plane.Origin.X & ", ") + plane.Origin.Y & ", ") + plane.Origin.Z & ")"

    message += ((vbLf & "normal of the plane: (" & plane.Normal.X & ", ") + plane.Normal.Y & ", ") + plane.Normal.Z & ")"

    message += ((vbLf & "Xvec of the plane: (" & plane.XVec.X & ", ") + plane.XVec.Y & ", ") + plane.XVec.Z & ")"

    message += ((vbLf & "Yvec of the plane: (" & plane.YVec.X & ", ") + plane.YVec.Y & ", ") + plane.YVec.Z & ")"

    MessageBox.Show(message, "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.ReferencePlane

See Also

ReferencePlane Members
Autodesk.Revit.Elements Namespace

ReferencePlane Members

[image] [image]