Revit 2010 API
SymbolicCurve..::.SetVisibility Method
SymbolicCurve Class See Also Send Feedback
Sets the visibility for the symbolic curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic (Declaration)
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit..::.FamilyElementVisibility

Remarks

The visibility of the symbolic curve geometry can be changed for different detail levels.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when visibility is null.
System..::.ArgumentException | Thrown when visibility is not valid for symbolic curves.
System..::.InvalidOperationException | Thrown when regeneration failed.

See Also

SymbolicCurve Class
Autodesk.Revit.Elements Namespace

SymbolicCurve Properties

[image] [image]