Revit 2010 API
Level Class
Members Example See Also Send Feedback
Represents a Level line within Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Level : Element
Visual Basic (Declaration)
Public Class Level _
    Inherits Element
Visual C++
public ref class Level : public Element

Remarks

The Level object is derived from the Element object and as such contains all the properties and methods of that object. The inherited Name property can be used to retrieve the user visible name of the level that appears in the level bubble. To retrieve all the levels within a project use the Document.Elements iterator and look for objects of type Autodesk.Revit.Elements.Level.

Examples

CopyC#
private void Getinfo_Level(Document document)
{
    StringBuilder levelInformation = new StringBuilder();
    int levelNumber = 0;

    TypeFilter levelFilter = document.Application.Create.Filter.NewTypeFilter(typeof(Level));
    ElementIterator itrLevels = document.get_Elements(levelFilter);
    itrLevels.Reset();
    while (itrLevels.MoveNext())
    {
        Level level = itrLevels.Current as Level;

        if (null != level)
        {
            // keep track of number of levels
            levelNumber++;

            //get the name of the level
            levelInformation.Append("\nLevel Name: " + level.Name);

            //get the elevation of the level
            levelInformation.Append("\n\tElevation: " + level.Elevation);

            // get the project elevation of the level
            levelInformation.Append("\n\tProject Elevation: " + level.ProjectElevation);
        }
    }

    //number of total levels in current document
    levelInformation.Append("\n\n There are " + levelNumber + " levels in the document!");

    //show the level information in the messagebox
    MessageBox.Show(levelInformation.ToString(), "Revit");
}
CopyVB.NET
Private Sub Getinfo_Level(ByVal document As Document)
    Dim levelInformation As New StringBuilder()
    Dim levelNumber As Integer = 0

    Dim levelFilter As TypeFilter = document.Application.Create.Filter.NewTypeFilter(GetType(Autodesk.Revit.Elements.Level))
    Dim itrLevels As ElementIterator = document.Elements(levelFilter)
    itrLevels.Reset()
    While itrLevels.MoveNext()
        Dim level As Autodesk.Revit.Elements.Level = TryCast(itrLevels.Current, Autodesk.Revit.Elements.Level)

        If level IsNot Nothing Then
            ' keep track of number of levels
            levelNumber += 1

            'get the name of the level
            levelInformation.Append(vbLf & "Level Name: " & level.Name)

            'get the elevation of the level
            levelInformation.Append(vbLf & vbTab & "Elevation: " & level.Elevation)

            ' get the project elevation of the level
            levelInformation.Append(vbLf & vbTab & "Project Elevation: " & level.ProjectElevation)
        End If
    End While

    'number of totle level in current document
    levelInformation.Append(vbLf & vbLf & " There are " & levelNumber & " levels in the document!")

    'show the level information in the messagebox
    MessageBox.Show(levelInformation.ToString(), "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Level

See Also

Level Members
Autodesk.Revit.Elements Namespace

Level Members

[image] [image]