Revit 2010 API
Form Class
Members See Also Send Feedback
An object that represents a Form within the Autodesk Revit Massing Family.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Form : GenericForm
Visual Basic (Declaration)
Public Class Form _
    Inherits GenericForm
Visual C++
public ref class Form : public GenericForm

Remarks

This object is derived from the Element base object and as such supports all the methods of that object such as the ability to retrieve the parameters of that object. Please note that for any reference returned from a Form method, its GeometryObject will become invalid after a form modification method, e.g. MoveSubElement. Call the method on the Form object to retrieve the new reference if it is needed after the modification.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.CombinableElement
Autodesk.Revit.Elements..::.GenericForm
Autodesk.Revit.Elements..::.Form

See Also

Form Members
Autodesk.Revit.Elements Namespace

Form Members

[image] [image]