Revit 2010 API
FamilyManager..::.SetParameterLocked Method
FamilyManager Class See Also Send Feedback
For Conceptual Mass and Curtain Panel families, lock or unlock a dimension-driving parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetParameterLocked(
    FamilyParameter familyParameter,
    bool locked
)
Visual Basic (Declaration)
Public Sub SetParameterLocked ( _
    familyParameter As FamilyParameter, _
    locked As Boolean _
)
Visual C++
public:
void SetParameterLocked(
    FamilyParameter^ familyParameter,
    bool locked
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter
locked
Type: System..::.Boolean

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if this family is not a Conceptual Mass or Curtain Panel family.
System..::.ArgumentException | Thrown if the parameter is not lockable.

See Also

FamilyManager Class
Autodesk.Revit Namespace

SetValueString Method

[image]