Revit 2010 API
FamilyInstance..::.ToRoom Property
FamilyInstance Class See Also Send Feedback
The room to which the door is opened at the last phase of the project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Room ToRoom { get; }
Visual Basic (Declaration)
Public ReadOnly Property ToRoom As Room
Visual C++
public:
property Room^ ToRoom {
    Room^ get ();
}

Remarks

When current familyinstance is neither door nor window, this property will always return null.

See Also

FamilyInstance Class
ToRoom Overload
Autodesk.Revit.Elements Namespace

ToRoom Property (Phase)

[image]