Revit 2010 API
ElementSet Class
Members Example See Also Send Feedback
A set that contains element objects.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class ElementSet : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class ElementSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ElementSet : public APIObject,
    IEnumerable

Examples

CopyC#
ElementSet elems = document.Selection.Elements;

string info = "Selected elements:\n";
foreach (Autodesk.Revit.Element elem in elems)
{
    info += elem.Name + "\n";
}

MessageBox.Show(info, "Revit");
CopyVB.NET
Dim elems As ElementSet = document.Selection.Elements

Dim info As String = "Selected elements:" & vbLf
For Each elem As Autodesk.Revit.Element In elems
    info += elem.Name & vbLf
Next

MessageBox.Show(info, "Revit")

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.ElementSet
Autodesk.Revit..::.SelElementSet

See Also

ElementSet Members
Autodesk.Revit Namespace

ElementSet Members

[image] [image]