Revit 2010 API
Document..::.NewOpening Method (Element, CurveArray, Boolean)
Document Class See Also Send Feedback
Creates a new opening in a roof, floor and ceiling.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Opening NewOpening(
    Element hostElement,
    CurveArray profile,
    bool bPerpendicularFace
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    hostElement As Element, _
    profile As CurveArray, _
    bPerpendicularFace As Boolean _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Element^ hostElement,
    CurveArray^ profile,
    bool bPerpendicularFace
)

Parameters

hostElement
Type: Autodesk.Revit..::.Element
Host element of the opening, can be a roof,floor or ceiling.
profile
Type: Autodesk.Revit.Geometry..::.CurveArray
Profile of the opening.
bPerpendicularFace
Type: System..::.Boolean
True if the profile is cut perpendicular to the intersecting face of the host. False if the profile is cut vertically.

Return Value

If successful, an Opening object is returned.

See Also

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace

NewOpening Method (Level, Level, CurveArray)

[image]