Revit 2010 API
Mesh..::.Transformed Property
Mesh Class See Also Send Feedback
Transforms this mesh and returns the result.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Mesh Transformed[
    Transform transform
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Transformed ( _
    transform As Transform _
) As Mesh
Visual C++
public:
property Mesh^ Transformed[Transform^ transform] {
    Mesh^ get (Transform^ transform);
}

Parameters

transform
Type: Autodesk.Revit.Geometry..::.Transform
The transformation used to transform the profile.

Return Value

The transformed mesh.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the handle of the specified transformation is null.

See Also

Mesh Class
Autodesk.Revit.Geometry Namespace

Triangle Property

[image]