Revit 2010 API
Element..::.DesignOption Property
Element Class Example See Also Send Feedback
Returns the design option to which the element belongs.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DesignOption DesignOption { get; }
Visual Basic (Declaration)
Public ReadOnly Property DesignOption As DesignOption
Visual C++
public:
property DesignOption^ DesignOption {
    DesignOption^ get ();
}

Remarks

If the element is not in a design option, i.e. in the main model, then this property will return Nothing.

Examples

CopyC#
void Getinfo_DesignOption(Document document)
{
    // Get the selected Elements in the Active Document
    ElementSet selection = document.Selection.Elements;

    foreach (Autodesk.Revit.Element element in selection)
    {
        //Use the DesignOption property of Element
        if (element.DesignOption != null)
        {
            MessageBox.Show(element.DesignOption.Name.ToString());
        }
    }
}
CopyVB.NET
Private Sub Getinfo_DesignOption(ByVal document As Document)
    ' Get the selected Elements in the Active Document
    Dim selection As ElementSet = document.Selection.Elements

    For Each element As Autodesk.Revit.Element In selection
        'Use the DesignOption property of Element
        If element.DesignOption IsNot Nothing Then
            MessageBox.Show(element.DesignOption.Name.ToString())
        End If
    Next
End Sub

See Also

Element Class
Autodesk.Revit Namespace

Document Property

[image]