Revit 2010 API
FamilyManager..::.NewType Method
FamilyManager Class Example See Also Send Feedback
Add a new family type with a given name and makes it be the current type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyType NewType(
    string typeName
)
Visual Basic (Declaration)
Public Function NewType ( _
    typeName As String _
) As FamilyType
Visual C++
public:
FamilyType^ NewType(
    String^ typeName
)

Parameters

typeName
Type: System..::.String
The name of new family type.

Examples

CopyC#
public void EditFamilyTypes(Document document, FamilyInstance familyInstance)
{
    // example works best when familyInstance is a rectangular concrete element
    if (null != familyInstance.Symbol)
    {
        // Get family associated with this
        Family family = familyInstance.Symbol.Family;

        // Get Family document for family
        Document familyDoc = document.EditFamily(family);
        if (null != familyDoc)
        {
            FamilyManager familyManager = familyDoc.FamilyManager;

            // add a new type and edit its parameters
            FamilyType newFamilyType = familyManager.NewType("2X2");

            // look for 'b' and 'h' parameters and set them to 2 feet
            FamilyParameter familyParam = familyManager.get_Parameter("b");
            if (null != familyParam)
            {
                familyManager.Set(familyParam, 2.0);
            }
            familyParam = familyManager.get_Parameter("h");
            if (null != familyParam)
            {
                familyManager.Set(familyParam, 2.0);
            }

            // now update the Revit project with Family which has a new type
            family = familyDoc.LoadFamily(document);
            // find the new type and assign it to FamilyInstance
            FamilySymbolSetIterator symbolsItor = family.Symbols.ForwardIterator();
            symbolsItor.Reset();
            while (symbolsItor.MoveNext())
            {
                FamilySymbol familySymbol = symbolsItor.Current as FamilySymbol;
                if (familySymbol.Name == "2X2")
                {
                    familyInstance.Symbol = familySymbol;
                    break;
                }
            }
        }
    }
}
CopyVB.NET
Public Sub EditFamilyTypes(ByVal document As Document, ByVal familyInstance As Autodesk.Revit.Elements.FamilyInstance)
    ' example works best when familyInstance is a rectangular concrete element
    If familyInstance.Symbol IsNot Nothing Then
        ' Get family associated with this
        Dim family As Autodesk.Revit.Elements.Family = familyInstance.Symbol.Family

        ' Get Family document for family
        Dim familyDoc As Document = document.EditFamily(family)
        If familyDoc IsNot Nothing AndAlso familyDoc.IsFamilyDocument = True Then
            Dim familyManager As FamilyManager = familyDoc.FamilyManager

            ' add a new type and edit its parameters
            Dim newFamilyType As FamilyType = familyManager.NewType("50X50")

            ' look for 'b' and 'h' parameters and set them to 50
            Dim familyParam As FamilyParameter = familyManager.Parameter("b")
            If familyParam IsNot Nothing Then
                familyManager.[Set](familyParam, 50.0R)
            End If
            familyParam = familyManager.Parameter("h")
            If familyParam IsNot Nothing Then
                familyManager.[Set](familyParam, 50.0R)
            End If

            ' now update the Revit project with Family which has a new type
            family = familyDoc.LoadFamily(document)
            ' find the new type and assign it to FamilyInstance
            Dim symbolsItor As FamilySymbolSetIterator = family.Symbols.ForwardIterator()
            symbolsItor.Reset()
            While symbolsItor.MoveNext()
                Dim familySymbol As Autodesk.Revit.Symbols.FamilySymbol = TryCast(symbolsItor.Current, Autodesk.Revit.Symbols.FamilySymbol)
                If familySymbol.Name = "50X50" Then
                    familyInstance.Symbol = familySymbol
                    Exit While
                End If
            End While
        End If
    End If
End Sub

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"typeName"-is null.
System..::.ArgumentException | Thrown when the input argument-"typeName"-is already in use.
System..::.InvalidOperationException | Thrown when the famiy type creation failed.

See Also

FamilyManager Class
Autodesk.Revit Namespace

RemoveParameter Method

[image]