Revit 2010 API
RebarHostData..::.getRebarHostData Method
RebarHostData Class See Also Send Feedback
Gets a RebarHostData object referring to the specified rebar host element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static RebarHostData getRebarHostData(
    Element host
)
Visual Basic (Declaration)
Public Shared Function getRebarHostData ( _
    host As Element _
) As RebarHostData
Visual C++
public:
static RebarHostData^ getRebarHostData(
    Element^ host
)

Parameters

host
Type: Autodesk.Revit..::.Element
An element to host rebar.

Return Value

A RebarHostData object or null.

Remarks

Returns null for elements that cannot ever be rebar hosts, such as levels.

See Also

RebarHostData Class
Autodesk.Revit.Elements Namespace

HasCoverTypeForReference Method

[image]