Revit 2010 API
Transform..::.Inverse Property
Transform Class See Also Send Feedback
The inverse transformation of this transformation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Transform Inverse { get; }
Visual Basic (Declaration)
Public ReadOnly Property Inverse As Transform
Visual C++
public:
property Transform^ Inverse {
    Transform^ get ();
}

Remarks

The transformation matrix A is invertible if there exists a transformation matrix B such that A*B = B*A = I (identity).

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when this transformation is not conformal or invertible.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace

IsConformal Property

[image]