Revit 2010 API
Rebar..::.SetLayoutRuleWithoutExaminingHost Method
Rebar Class See Also Send Feedback
Change the parameter REBAR_ELEM_LAYOUT_RULE, but extend the set in the direction of the plane's normal, instead of towards the center of the host.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetLayoutRuleWithoutExaminingHost(
    RebarLayoutRule layoutRule
)
Visual Basic (Declaration)
Public Sub SetLayoutRuleWithoutExaminingHost ( _
    layoutRule As RebarLayoutRule _
)
Visual C++
public:
void SetLayoutRuleWithoutExaminingHost(
    RebarLayoutRule layoutRule
)

Parameters

layoutRule
Type: Autodesk.Revit.Structural.Enums..::.RebarLayoutRule
Define the rule used to layout the rebar.

Remarks

Changing the parameter REBAR_ELEM_LAYOUT_RULE attempts to extend the rebar set towards the center of the host, but depending on geometrical conditions, it can make the wrong decision. This function changes the layout rule while suppressing the geometric test for the direction of the set. The difference in behavior only occurs when changing the layout rule from None (0) to one of the other settings.

See Also

Rebar Class
Autodesk.Revit.Elements Namespace

Rebar Properties

[image] [image]