Revit 2010 API
FamilyItemFactory..::.NewSymbolicCurve Method
FamilyItemFactory Class See Also Send Feedback
Create a symbolic curve in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SymbolicCurve NewSymbolicCurve(
    Curve curve,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Function NewSymbolicCurve ( _
    curve As Curve, _
    sketchPlane As SketchPlane _
) As SymbolicCurve
Visual C++
public:
SymbolicCurve^ NewSymbolicCurve(
    Curve^ curve,
    SketchPlane^ sketchPlane
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
The geometry curve of the newly created symbolic curve.
sketchPlane
Type: Autodesk.Revit.Elements..::.SketchPlane
The sketch plane for the symbolic curve.

Return Value

The newly created symbolic curve.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when argument is null.
System..::.InvalidOperationException | Thrown when regeneration failed. Thrown when symbolic curve creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace

NewTextNote Method

[image] [image]