Revit 2010 API
DividedSurface..::.GetGridNodeReference Method
DividedSurface Class See Also Send Feedback
Get a reference to the geometric point associated with a grid node.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference GetGridNodeReference(
    GridNode gridNode
)
Visual Basic (Declaration)
Public Function GetGridNodeReference ( _
    gridNode As GridNode _
) As Reference
Visual C++
public:
Reference^ GetGridNodeReference(
    GridNode gridNode
)

Parameters

gridNode
Type: Autodesk.Revit.Elements..::.GridNode

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace

GetGridNodeUV Method

[image]