Revit 2010 API
CompoundStructureLayerFunction Enumeration
See Also Send Feedback
Describes the purpose of the layer within a compound structure, such as a wall or floor.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum CompoundStructureLayerFunction
Visual Basic (Declaration)
Public Enumeration CompoundStructureLayerFunction
Visual C++
public enum class CompoundStructureLayerFunction

Members

Member name | Description
StructuralDeck | A special layer considered to be structural decking.
MembraneLayer | A membrane layer.
Finish2 | A finish layer.
Finish1 | A finish layer.
ThermalOrAir | A thermal or air insulating layer.
Substrate | A substrate layer.
Structure | A structural layer.

See Also

Autodesk.Revit.Structural.Enums Namespace

InstanceUsage Enumeration

[image]