Revit 2010 API
Application..::.OnDialogBox Event
Application Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DialogBoxShowing event instead. Subscribe to the OnDialogBox event to be notified when an Autodesk Revit dialog box is displayed during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DialogBoxShowing event instead.")]
public event DialogBoxEventHandler OnDialogBox
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DialogBoxShowing event instead.")> _
Public Event OnDialogBox As DialogBoxEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DialogBoxShowing event instead.")]
public:
 event DialogBoxEventHandler^ OnDialogBox {
    void add (DialogBoxEventHandler^ value);
    void remove (DialogBoxEventHandler^ value);
}

Remarks

Sometimes an Autodesk Revit dialog box may be displayed during an API command. By subscribing to this event the application will be notified of such an event and can perform an action, such as dismissing the dialog automatically.

See Also

Application Class
Autodesk.Revit Namespace

OnDocumentClosed Event

[image]