Revit 2010 API
ViewSheet..::.AddView Method
ViewSheet Class Example See Also Send Feedback
Places view on the sheet at the given location.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddView(
    View newView,
    UV location
)
Visual Basic (Declaration)
Public Sub AddView ( _
    newView As View, _
    location As UV _
)
Visual C++
public:
void AddView(
    View^ newView,
    UV^ location
)

Parameters

newView
Type: Autodesk.Revit.Elements..::.View
The view to be placed.
location
Type: Autodesk.Revit.Geometry..::.UV
Sheet coordinates (in inches) of the center of the view.

Remarks

Argument exception occurs if the view is of unappropriate type (e.g. ViewSheet) or the view is already placed on another sheet. The lower left corner of the sheet has coordinates [0,0]. Empty views are not placed on the sheet but no exception occurs.

Examples

CopyC#
private void PlaceViewOnSheet(Document document, ViewSheet viewSheet)
{
    //Argument exception occurs if the view is of inappropriate type (e.g. ViewSheet)
    //or the view is already placed on another sheet.
    //The lower left corner of the sheet has coordinates [0,0].
    //Empty views are not placed on the sheet but no exception occurs.

    //put a view into the sheet
    //the location of the view in the view sheet
    UV viewLocation = new UV(1.5, 1.5);
    //get a view form the view list
    Autodesk.Revit.Elements.View tempView = document.ActiveView;
    if (null != tempView)
    {
        viewSheet.AddView(tempView, viewLocation);
        MessageBox.Show("nAdd a view to the viewSheet successfully.");
    }
}
CopyVB.NET
Private Sub PlaceViewOnSheet(ByVal document As Document, ByVal viewSheet As ViewSheet)
    'Argument exception occurs if the view is of inappropriate type (e.g. ViewSheet)
    'or the view is already placed on another sheet.
    'The lower left corner of the sheet has coordinates [0,0].
    'Empty views are not placed on the sheet but no exception occurs.

    'put a view into the sheet
    'the location of the view in the view sheet
    Dim viewLocation As New Autodesk.Revit.Geometry.UV(1.5, 1.5)
    'get a view form the view list
    Dim tempView As Autodesk.Revit.Elements.View = document.ActiveView
    If tempView IsNot Nothing Then
        viewSheet.AddView(tempView, viewLocation)
        MessageBox.Show("nAdd a view to the viewSheet successfully.")
    End If
End Sub

See Also

ViewSheet Class
Autodesk.Revit.Elements Namespace

Print Method

[image] [image]