Revit 2010 API
SymbolicCurve..::.ReferenceType Property
SymbolicCurve Class See Also Send Feedback
Indicates the type of reference.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ReferenceType ReferenceType { get; set; }
Visual Basic (Declaration)
Public Property ReferenceType As ReferenceType
Visual C++
public:
property ReferenceType ReferenceType {
    ReferenceType get ();
    void set (ReferenceType value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when argument is out of range.
System..::.InvalidOperationException | Thrown when regeneration failed.

See Also

SymbolicCurve Class
Autodesk.Revit.Elements Namespace

Subcategory Property

[image]