Revit 2010 API
View Class
Members Example See Also Send Feedback
Base class for all types of views in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class View : Element
Visual Basic (Declaration)
Public Class View _
    Inherits Element
Visual C++
public ref class View : public Element

Remarks

A view can display an image produced from a Revit model. Views can be graphical (e.g. plans, elevations, or 3D views) or textual (e.g. schedules). Views keep track of Elements that can be seen in them.

Examples

CopyC#
private void Getinfo_View(Autodesk.Revit.Elements.View view)
{
    string message = "View: ";

    //get the name of the view
    message += "\nView name: " + view.ViewName;

    //The crop box sets display bounds of the view
    BoundingBoxXYZ cropBox = view.CropBox;
    XYZ max = cropBox.Max; //Maximum coordinates (upper-right-front corner of the box).
    XYZ min = cropBox.Min; //Minimum coordinates (lower-left-rear corner of the box).
    message += "\nCrop Box: ";
    message += "\nMaximum coordinates: (" + max.X + ", " + max.Y + ", " + max.Z + ")";
    message += "\nMinimum coordinates: (" + min.X + ", " + min.Y + ", " + min.Z + ")";

    //Elements property stores the elements which graphics is visible in this view.
    //Some elements may still be hidden, e.g., obscured by other elements.
    ElementSet elements = view.Elements;
    message += "\nElement number: " + elements.Size;

    //get the origin of the screen
    XYZ origin = view.Origin;
    message += "\nOrigin: (" + origin.X + ", " + origin.Y + ", " + origin.Z + ")";

    //The bounds of the view in paper space (in inches).
    BoundingBoxUV outline = view.Outline;
    UV maxUv = outline.Max; //Maximum coordinates (upper-right corner of the box).
    UV minUv = outline.Min; //Minimum coordinates (lower-left corner of the box).
    message += "\nOutline: ";
    message += "\nMaximum coordinates: (" + maxUv.U + ", " + maxUv.V + ")";
    message += "\nMinimum coordinates: (" + minUv.U + ", " + minUv.V + ")";

    //The direction towards the right side of the screen
    XYZ rightDirection = view.RightDirection;
    message += "\nRight direction: (" + rightDirection.X + ", " +
                   rightDirection.Y + ", " + rightDirection.Z + ")";

    //The direction towards the top of the screen
    XYZ upDirection = view.UpDirection;
    message += "\nUp direction: (" + upDirection.X + ", " +
                   upDirection.Y + ", " + upDirection.Z + ")";

    //The direction towards the viewer
    XYZ viewDirection = view.ViewDirection;
    message += "\nView direction: (" + viewDirection.X + ", " +
                   viewDirection.Y + ", " + viewDirection.Z + ")";

    //The scale of the view
    message += "\nScale: " + view.Scale;
    // Scale is meaningless for Schedules
    if (view.ViewType != Autodesk.Revit.Enums.ViewType.Schedule)
    {
        int testScale = 5;
        //set the scale of the view
        view.Scale = testScale;
        message += "\nScale after set: " + view.Scale;
    }

    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Private Sub Getinfo_View(ByVal view As Autodesk.Revit.Elements.View)
    Dim message As String = "View: "

    'get the name of the view
    message += vbLf & "View name: " & view.ViewName

    'The crop box sets display bounds of the view
    Dim cropBox As BoundingBoxXYZ = view.CropBox
    Dim max As Autodesk.Revit.Geometry.XYZ = cropBox.Max
    'Maximum coordinates (upper-right-front corner of the box).
    Dim min As Autodesk.Revit.Geometry.XYZ = cropBox.Min
    'Minimum coordinates (lower-left-rear corner of the box).
    message += vbLf & "Crop Box: "
    message += ((vbLf & "Maximum coordinates: (" & max.X & ", ") + max.Y & ", ") + max.Z & ")"
    message += ((vbLf & "Minimum coordinates: (" & min.X & ", ") + min.Y & ", ") + min.Z & ")"

    'Elements property stores the elements which graphics is visible in this view.
    'Some elements may still be hidden, e.g., obscured by other elements.
    Dim elements As ElementSet = view.Elements
    message += vbLf & "Element number: " & elements.Size

    'get the origin of the screen
    Dim origin As Autodesk.Revit.Geometry.XYZ = view.Origin
    message += ((vbLf & "Origin: (" & origin.X & ", ") + origin.Y & ", ") + origin.Z & ")"

    'The bounds of the view in paper space (in inches).
    Dim outline As BoundingBoxUV = view.Outline
    Dim maxUv As Autodesk.Revit.Geometry.UV = outline.Max
    'Maximum coordinates (upper-right corner of the box).
    Dim minUv As Autodesk.Revit.Geometry.UV = outline.Min
    'Minimum coordinates (lower-left corner of the box).
    message += vbLf & "Outline: "
    message += (vbLf & "Maximum coordinates: (" & maxUv.U & ", ") + maxUv.V & ")"
    message += (vbLf & "Minimum coordinates: (" & minUv.U & ", ") + minUv.V & ")"

    'The direction towards the right side of the screen
    Dim rightDirection As Autodesk.Revit.Geometry.XYZ = view.RightDirection
    message += ((vbLf & "Right direction: (" & rightDirection.X & ", ") + rightDirection.Y & ", ") + rightDirection.Z & ")"

    'The direction towards the top of the screen
    Dim upDirection As Autodesk.Revit.Geometry.XYZ = view.UpDirection
    message += ((vbLf & "Up direction: (" & upDirection.X & ", ") + upDirection.Y & ", ") + upDirection.Z & ")"

    'The direction towards the viewer
    Dim viewDirection As Autodesk.Revit.Geometry.XYZ = view.ViewDirection
    message += ((vbLf & "View direction: (" & viewDirection.X & ", ") + viewDirection.Y & ", ") + viewDirection.Z & ")"

    'The scale of the view
    message += vbLf & "Scale: " & view.Scale
    ' Scale is meaningless for Schedules
    If view.ViewType <> Autodesk.Revit.Enums.ViewType.Schedule Then
        Dim testScale As Integer = 5
        'set the scale of the view
        view.Scale = testScale
        message += vbLf & "Scale after set: " & view.Scale
    End If

    MessageBox.Show(message, "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.View
Autodesk.Revit.Elements..::.View3D
Autodesk.Revit.Elements..::.ViewDrafting
Autodesk.Revit.Elements..::.ViewPlan
Autodesk.Revit.Elements..::.ViewSection
Autodesk.Revit.Elements..::.ViewSheet

See Also

View Members
Autodesk.Revit.Elements Namespace

View Members

[image] [image]