Revit 2010 API
PathReinforcement..::.Curves Property
PathReinforcement Class Example See Also Send Feedback
Retrieves the array of curves forming the boundary of the Path Reinforcement.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementArray Curves { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curves As ElementArray
Visual C++
public:
property ElementArray^ Curves {
    ElementArray^ get ();
}

Remarks

Each element in the array is of type ModelCurve.

Examples

CopyC#
private void Getinfo_PathReinforcementCurve(PathReinforcement pathReinforcement)
{
    string message = "Path Reinforcement Curves : ";

    // Get path reinforcement curves by iterating the Curves property
    foreach (Autodesk.Revit.Element ii in pathReinforcement.Curves)
    {
        ModelCurve pathReinforcementCurve = ii as ModelCurve;
        if (null == pathReinforcementCurve)
        {
            continue;
        }

        Autodesk.Revit.Geometry.Curve curve = pathReinforcementCurve.GeometryCurve;

        // Get curve start point
        message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
            + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        // Get curve end point
        message += "; Curve end point:(" + curve.get_EndPoint(1).X + ", "
            + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";

    }
    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);

}
CopyVB.NET
Private Sub Getinfo_PathReinforcementCurve(ByVal pathReinforcement As PathReinforcement)
    Dim message As String = "Path Reinforcement Curves : "

    ' Get path reinforcement curves by iterating the Curves property
    For Each ii As Autodesk.Revit.Element In pathReinforcement.Curves
        Dim pathReinforcementCurve As ModelCurve = TryCast(ii, ModelCurve)
        If pathReinforcementCurve Is Nothing Then
            Continue For
        End If

        Dim curve As Autodesk.Revit.Geometry.Curve = pathReinforcementCurve.GeometryCurve

        ' Get curve start point
        message += ((vbLf & "Curve start point:(" & curve.EndPoint(0).X & ", ") + curve.EndPoint(0).Y & ", ") + curve.EndPoint(0).Z & ")"
        ' Get curve end point
        message += (("; Curve end point:(" & curve.EndPoint(1).X & ", ") + curve.EndPoint(1).Y & ", ") + curve.EndPoint(1).Z & ")"

    Next
    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)

End Sub

See Also

PathReinforcement Class
Autodesk.Revit.Elements Namespace

NumBarDescriptions Property

[image]