Revit 2010 API
WireMaterialType..::.AddTemperatureRatingType Method
WireMaterialType Class See Also Send Feedback
Add a new temperature rating type into material type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public TemperatureRatingType AddTemperatureRatingType(
    string name,
    TemperatureRatingType baseOn
)
Visual Basic (Declaration)
Public Function AddTemperatureRatingType ( _
    name As String, _
    baseOn As TemperatureRatingType _
) As TemperatureRatingType
Visual C++
public:
TemperatureRatingType^ AddTemperatureRatingType(
    String^ name,
    TemperatureRatingType^ baseOn
)

Parameters

name
Type: System..::.String
Name of temperature type to be added.
baseOn
Type: Autodesk.Revit.MEP..::.TemperatureRatingType
The new temperature rating will be created base on this existing temperature rating type.

Return Value

New constructed temperature rating type.

See Also

WireMaterialType Class
Autodesk.Revit.MEP Namespace

RemoveGroundConductorSize Method

[image]