Revit 2010 API
CurveElement..::.GeometryCurve Property
CurveElement Class See Also Send Feedback
Geometry curve of the curve element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve GeometryCurve { get; set; }
Visual Basic (Declaration)
Public Property GeometryCurve As Curve
Visual C++
public:
property Curve^ GeometryCurve {
    Curve^ get ();
    void set (Curve^ value);
}

Remarks

Because there are no corresponding geometry curve type for HermiteSpline, for this type only general Geometry::Curve object will be returned.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when argument is null.
System..::.ArgumentException | Thrown when try to set a curve of different type.

See Also

CurveElement Class
Autodesk.Revit.Elements Namespace

LineStyle Property

[image]