Revit 2010 API
XYZ..::.TripleProduct Method
XYZ Class See Also Send Feedback
The triple product of this vector and the two specified vectors.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double TripleProduct(
    XYZ middle,
    XYZ right
)
Visual Basic (Declaration)
Public Function TripleProduct ( _
    middle As XYZ, _
    right As XYZ _
) As Double
Visual C++
public:
double TripleProduct(
    XYZ^ middle,
    XYZ^ right
)

Parameters

middle
Type: Autodesk.Revit.Geometry..::.XYZ
The second vector.
right
Type: Autodesk.Revit.Geometry..::.XYZ
The third vector.

Return Value

The real number equal to the triple product.

Remarks

The scalar triple product is defined as the dot product of one of the vectors with the cross product of the other two. Geometrically, this product is the (signed) volume of the parallelepiped formed by the three vectors given.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace

UnaryNegation Operator

[image]