Revit 2010 API
FamilyType..::.AsInteger Method
FamilyType Class See Also Send Feedback
Provides access to the integer number of the given family parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Nullable<int> AsInteger(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function AsInteger ( _
    familyParameter As FamilyParameter _
) As Nullable(Of Integer)
Visual C++
public:
Nullable<int> AsInteger(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter

Return Value

The integer value contained in the parameter. Returns a nullable object without value if the storage type of the input argument is not integer type or this parameter has no value.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,

See Also

FamilyType Class
Autodesk.Revit Namespace

AsString Method

[image]