Revit 2010 API
Document..::.NewUnionFitting Method
Document Class See Also Send Feedback
Add a new family instance of an union fitting into the Autodesk Revit document, using two connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance NewUnionFitting(
    Connector connector1,
    Connector connector2
)
Visual Basic (Declaration)
Public Function NewUnionFitting ( _
    connector1 As Connector, _
    connector2 As Connector _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewUnionFitting(
    Connector^ connector1,
    Connector^ connector2
)

Parameters

connector1
Type: Autodesk.Revit.MEP..::.Connector
The first connector to be connected to the union.
connector2
Type: Autodesk.Revit.MEP..::.Connector
The second connector to be connected to the union.

Return Value

If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument connector1 or connector2 is null.
System..::.ArgumentException | Thrown when the connectors cannot be used for union creation. For example, they cannot be from the same element, they must be of the same domain and and shape, and the owner of the connector1 should be a (flex) duct or pipe.
System..::.InvalidOperationException | Thrown when union fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewViewDrafting Method

[image]