Revit 2010 API
DividedSurface..::.IsComponentMirrored Property
DividedSurface Class See Also Send Feedback
Whether the pattern is mirror-imaged.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsComponentMirrored { get; set; }
Visual Basic (Declaration)
Public Property IsComponentMirrored As Boolean
Visual C++
public:
property bool IsComponentMirrored {
    bool get ();
    void set (bool value);
}

Remarks

This property has no effect unless a pattern is selected (the ObjectType property is not null). Changing this flag effectively reflects the component through its YZ-plane.

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace

NumberOfUGridlines Property

[image]