Revit 2010 API
Location..::.Rotate Method
Location Class Example See Also Send Feedback
Rotate the element within the project by a specified number of degrees around a given axis.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Rotate(
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate(
    Line^ axis,
    double angle
)

Parameters

axis
Type: Autodesk.Revit.Geometry..::.Line
An unbounded line that represents the axis of rotation.
angle
Type: System..::.Double
The number of degrees, in radians, by which the element is to be rotated around the specified axis.

Return Value

If the element is rotate successfully then the method returns True, otherwise False.

Remarks

The rotate method is used to rotate an element within the project. Other elements may also be rotated when this element is rotated because they are dependent upon the element being rotated. An unbounded line for the axis can be created by using the Application.Create object and its methods.

Examples

CopyC#
bool LocationRotate(Autodesk.Revit.Application application, Autodesk.Revit.Element element)
{
    bool rotated = false;
    // Rotate the element via its location curve.
    LocationCurve curve = element.Location as LocationCurve;
    if (null != curve)
    {
        Curve line = curve.Curve;
        XYZ aa = line.get_EndPoint(0);
        XYZ cc = new XYZ(aa.X, aa.Y, aa.Z + 10);
        Line axis = application.Create.NewLineBound(aa, cc);
        rotated = curve.Rotate(axis, Math.PI / 2.0);
    }

    return rotated;
}
CopyVB.NET
Private Function LocationRotate(ByVal application As Autodesk.Revit.Application, ByVal element As Autodesk.Revit.Element) As Boolean
    Dim rotated As Boolean = False
    ' Rotate the element via its location curve.
    Dim curve As LocationCurve = TryCast(element.Location, LocationCurve)
    If curve IsNot Nothing Then
        Dim line As Curve = curve.Curve
        Dim aa As Autodesk.Revit.Geometry.XYZ = line.EndPoint(0)
        Dim cc As New Autodesk.Revit.Geometry.XYZ(aa.X, aa.Y, aa.Z + 10)
        Dim axis As Line = application.Create.NewLineBound(aa, cc)
        rotated = curve.Rotate(axis, Math.PI / 2.0R)
    End If

    Return rotated
End Function

See Also

Location Class
Autodesk.Revit Namespace

Location Properties

[image] [image]