Revit 2010 API
FamilyManager..::.Set Method (FamilyParameter, String)
FamilyManager Class See Also Send Feedback
Set the string value of a family parameter of the current family type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Set(
    FamilyParameter familyParameter,
    string value
)
Visual Basic (Declaration)
Public Sub Set ( _
    familyParameter As FamilyParameter, _
    value As String _
)
Visual C++
public:
void Set(
    FamilyParameter^ familyParameter,
    String^ value
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter
The family parameter of current type.
value
Type: System..::.String
The new value for family parameter.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter.
System..::.ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
System..::.InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid.

See Also

FamilyManager Class
Set Overload
Autodesk.Revit Namespace

SetFormula Method

[image]