Revit 2010 API
ServiceType Enumeration
See Also Send Feedback
An enumerate type listing all of the built-in service types supported by Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ServiceType
Visual Basic (Declaration)
Public Enumeration ServiceType
Visual C++
public enum class ServiceType

Members

Member name | Description
kSplitSystemsWithMechanicalVentilationWithCooling | Service Type is SplitSystemsWithMechanicalVentilationWithCooling.
kSplitSystemsWithMechanicalVentilation | Service Type is SplitSystemsWithMechanicalVentilation.
kSplitSystemsWithNaturalVentilation | Service Type is SplitSystemsWithNaturalVentilation.
kVariableRefrigerantFlow | Service Type is VariableRefrigerantFlow.
kWaterLoopHeatPump | Service Type is WaterLoopHeatPump.
kActiveChilledBeams | Service Type is ActiveChilledBeams.
kRadiantCooledCeilings | Service Type is RadiantCooledCeilings.
kConstantVolumeDualDuct | Service Type is ConstantVolumeDualDuct.
kMultizoneHotDeckColdDeck | Service Type is MultizoneHotDeckColdDeck.
kConstantVolumeTerminalReheat | Service Type is ConstantVolumeTerminalReheat.
kConstantVolumeVariableOA | Service Type is ConstantVolumeVariableOA.
kConstantVolumeFixedOA | Service Type is ConstantVolumeFixedOA.
kInductionSystem | Service Type is InductionSystem.
kFanCoilSystem | Service Type is FanCoilSystem.
kVAVTerminalReheat | Service Type is VAVTerminalReheat.
kVAVIndoorPackagedCabinet | Service Type is VAVIndoorPackagedCabinet.
kVAVDualDuct | Service Type is VAVDualDuct.
kVAVSingleDuct | Service Type is VAVSingleDuct.
kForcedConvectionHeaterNoFlue | Service Type is ForcedConvectionHeaterNoFlue.
kForcedConvectionHeaterFlue | Service Type is ForcedConvectionHeaterFlue.
kRadiantHeaterMultiburner | Service Type is RadiantHeaterMultiburner.
kRadiantHeaterNoFlue | Service Type is RadiantHeaterNoFlue.
kRadiantHeaterFlue | Service Type is RadiantHeaterFlue.
kOtherRoomHeater | Service Type is OtherRoomHeater.
kCentralHeatingHotAir | Service Type is CentralHeatingHotAir.
kCentralHeatingRadiantFloor | Service Type is CentralHeatingRadiantFloor.
kCentralHeatingConvectors | Service Type is CentralHeatingConvectors.
kCentralHeatingRadiators | Service Type is CentralHeatingRadiators.
kNoServiceType | Service Type is NoServiceType.

See Also

Autodesk.Revit.Parameters Namespace

StorageType Enumeration

[image]