Revit 2010 API
PrintSetup..::.Rename Method
PrintSetup Class See Also Send Feedback
Rename the current print setting with the specified name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Rename(
    string newName
)
Visual Basic (Declaration)
Public Function Rename ( _
    newName As String _
) As Boolean
Visual C++
public:
bool Rename(
    String^ newName
)

Parameters

newName
Type: System..::.String
print setting name to be renamed as.

Return Value

Returns false if Rename operation fails, otherwise, returns true.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the input newName already exists in current print setting list.

See Also

PrintSetup Class
Autodesk.Revit Namespace

Revert Method

[image]