Revit 2010 API
Application..::.NewRoomCreationData Method
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewRoom() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RoomCreationData NewRoomCreationData(
    Level level,
    UV point
)
Visual Basic (Declaration)
Public Function NewRoomCreationData ( _
    level As Level, _
    point As UV _
) As RoomCreationData
Visual C++
public:
RoomCreationData^ NewRoomCreationData(
    Level^ level,
    UV^ point
)

Parameters

level
Type: Autodesk.Revit.Elements..::.Level
- The level on which the room is to exist.
point
Type: Autodesk.Revit.Geometry..::.UV
A 2D point the dictates the location on that specified level.

See Also

Application Class
Autodesk.Revit.Creation Namespace

NewSelElementSet Method

[image]