Revit 2010 API
RibbonPanel..::.AddPushButton Method
RibbonPanel Class See Also Send Feedback
Adds a PushButton to the panel.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PushButton AddPushButton(
    string name,
    string text,
    string assembly,
    string className
)
Visual Basic (Declaration)
Public Function AddPushButton ( _
    name As String, _
    text As String, _
    assembly As String, _
    className As String _
) As PushButton
Visual C++
public:
PushButton^ AddPushButton(
    String^ name,
    String^ text,
    String^ assembly,
    String^ className
)

Parameters

name
Type: System..::.String
The name of the button.
text
Type: System..::.String
The text of the button.
assembly
Type: System..::.String
The assembly path which contains the corresponding external command.
className
Type: System..::.String
The class name which implements the interface IExternalCommand.

Return Value

The added PushButton.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the name, text, assembly or classname is null.
System..::.ArgumentException | Thrown when the name, text, assembly or classname is empty or text contains an invalid character.

See Also

RibbonPanel Class
Autodesk.Revit Namespace

AddSeparator Method

[image]