Revit 2010 API
Document..::.NewFamilyInstance Method (Curve, FamilySymbol, Level, StructuralType)
Document Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a curve, type/symbol and reference level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    curve As Curve, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
The curve where the instance is based.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.Elements..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise Nothing.

Remarks

This method is used to insert one family instance into another element along the geometry of a curve. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must be one that supports insertion of instances otherwise this method will fail. All levels within the document can be found by iterating over the entire document and searching for objects of type Autodesk.Revit.Elements.Level.

Examples

CopyC#
// get the active view's level for beam creation
Level level = document.Application.ActiveDocument.ActiveView.Level;

// load a family symbol from file
FamilySymbol gotSymbol = null;
String fileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Structural\Framing\Steel\W-Wide Flange.rfa";
String name = "W10X54";

FamilyInstance instance = null;

if (document.LoadFamilySymbol(fileName, name, out gotSymbol))
{
    // look for a model line in the list of selected elements
    ElementSet sel = document.Selection.Elements;
    ModelLine modelLine = null;
    foreach (Autodesk.Revit.Element elem in sel)
    {
        if (elem is ModelLine)
        {
            modelLine = elem as ModelLine;
            break;
        }
    }
    if (null != modelLine)
    {
        // create a new beam
        instance = document.Create.NewFamilyInstance(modelLine.GeometryCurve, gotSymbol,
                                                      level, StructuralType.Beam);
    }
    else
    {
        throw new Exception("Please select a model line before invoking this command");
    }

}
else
{
    throw new Exception("Couldn't load " + fileName);
}
CopyVB.NET
' get the active view's level for beam creation
Dim level As Autodesk.Revit.Elements.Level = document.Application.ActiveDocument.ActiveView.Level

' load a family symbol from file
Dim gotSymbol As Autodesk.Revit.Symbols.FamilySymbol = Nothing
Dim fileName As String = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Structural\Framing\Steel\W-Wide Flange.rfa"
Dim name As String = "W10X54"

Dim instance As Autodesk.Revit.Elements.FamilyInstance = Nothing

If document.LoadFamilySymbol(fileName, name, gotSymbol) Then
    ' look for a model line in the list of selected elements
    Dim sel As ElementSet = document.Selection.Elements
    Dim modelLine As ModelLine = Nothing
    For Each elem As Autodesk.Revit.Element In sel
        If TypeOf elem Is ModelLine Then
            modelLine = TryCast(elem, ModelLine)
            Exit For
        End If
    Next
    If modelLine IsNot Nothing Then
        ' create a new beam
        instance = document.Create.NewFamilyInstance(modelLine.GeometryCurve, gotSymbol, level, StructuralType.Beam)
    Else
        Throw New Exception("Please select a model line before invoking this command")
    End If

Else
    Throw New Exception("Couldn't load " & fileName)
End If

See Also

Document Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace

NewFamilyInstance Method (XYZ, FamilySymbol, Level, StructuralType)

[image]