Revit 2010 API
RibbonPanel..::.AddButton Method
RibbonPanel Class See Also Send Feedback
Adds a button to the panel.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RibbonItem AddButton(
    ButtonData buttonData
)
Visual Basic (Declaration)
Public Function AddButton ( _
    buttonData As ButtonData _
) As RibbonItem
Visual C++
public:
RibbonItem^ AddButton(
    ButtonData^ buttonData
)

Parameters

buttonData
Type: Autodesk.Revit..::.ButtonData
Data containing information about the new button.

Return Value

The added button.

Remarks

The new button will either be a PushButton or PulldownButton, depending upon the type of data passed in. The new button will be created as a large-size vertical button in the panel.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when buttonData is null.

See Also

RibbonPanel Class
Autodesk.Revit Namespace

AddPulldownButton Method

[image]