Revit 2010 API
RevitEventArgs..::.Cancel Property
RevitEventArgs Class See Also Send Feedback
Indicates whether the event is being cancelled. When the event is cancellable, set the property to 'true' to cancel it.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool Cancel { get; set; }
Visual Basic (Declaration)
Public Overridable Property Cancel As Boolean
Visual C++
public:
virtual property bool Cancel {
    bool get ();
    void set (bool value);
}

Remarks

If an event delegate wishes to cancel the event, it should set the value of this property to 'true'. Not every event is cancellable. Whether or not an event may be cancelled is indicated by the value of 'Cancellable' property.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if an event delegate attempts to cancel a non-cancellable event.

See Also

RevitEventArgs Class
Autodesk.Revit.Events Namespace

Cancellable Property

[image]