Revit 2010 API
Document..::.OwnerFamily Property
Document Class Example See Also Send Feedback
Get the Family of this Family Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Family OwnerFamily { get; }
Visual Basic (Declaration)
Public ReadOnly Property OwnerFamily As Family
Visual C++
public:
property Family^ OwnerFamily {
    Family^ get ();
}

Remarks

Only available if the current document is family document.

Examples

CopyC#
string categoryName = familyDoc.OwnerFamily.FamilyCategory.Name;
CopyVB.NET
Dim categoryName As String = familyDoc.OwnerFamily.FamilyCategory.Name

See Also

Document Class
Autodesk.Revit Namespace

PanelTypes Property

[image]