Revit 2010 API
ControlledApplication..::.ViewPrinted Event
ControlledApplication Class Example See Also Send Feedback
Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<ViewPrintedEventArgs> ViewPrinted
Visual Basic (Declaration)
Public Event ViewPrinted As EventHandler(Of ViewPrintedEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintedEventArgs^>^ ViewPrinted {
    void add (EventHandler<ViewPrintedEventArgs^>^ value);
    void remove (EventHandler<ViewPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view of the document. It is raised even when view printing failed.

Check the 'Status' field in event’s argument to see whether the action was successful or not.

This event is not cancellable, for the process of view printing has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

Examples

CopyC#
public class Application_ViewPrinted : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public IExternalApplication.Result OnStartup(ControlledApplication application)
    {
        // Register related events
        application.ViewPrinted += new EventHandler<Autodesk.Revit.Events.ViewPrintedEventArgs>(AppViewPrinted);
        return IExternalApplication.Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public IExternalApplication.Result OnShutdown(ControlledApplication application)
    {
        // unregister events
        application.ViewPrinted -= new EventHandler<Autodesk.Revit.Events.ViewPrintedEventArgs>(AppViewPrinted);
        return IExternalApplication.Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For ViewPrinted class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for ViewPrinting event, it will dump some event arguments.
    /// </summary>
    public void AppViewPrinted(object sender, Autodesk.Revit.Events.ViewPrintedEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("ViewPrintedEventArgs Parameters ------>");
        info.AppendLine("    Event Status        : " + args.Status);
        info.AppendLine("    TotalViews          : " + args.TotalViews);
        info.AppendLine("    View Index          : " + args.Index);
        info.AppendLine("    View Information    :");
        DumpViewInfo(args.View, "      ", ref info);

        MessageBox.Show(info.ToString(), "ViewPrinted Info");
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box string.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.Elements.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.Value, view.ViewName, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_ViewPrinted
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ViewPrinted, AddressOf AppViewPrinted
        Return IExternalApplication.Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ViewPrinted, AddressOf AppViewPrinted
        Return IExternalApplication.Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For ViewPrinted class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for ViewPrinting event, it will dump some event arguments.
    ' </summary>
    Public Sub AppViewPrinted(ByVal sender As Object, ByVal args As Autodesk.Revit.Events.ViewPrintedEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("ViewPrintedEventArgs Parameters ------>")
        info.AppendLine(" Event Status : " & args.Status)
        info.AppendLine(" TotalViews : " & args.TotalViews)
        info.AppendLine(" View Index : " & args.Index)
        info.AppendLine(" View Information :")
        DumpViewInfo(args.View, " ", info)

        MessageBox.Show(info.ToString(), "ViewPrinted Info")
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box string.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(ByVal view As Autodesk.Revit.Elements.View, ByVal prefix As String, ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.Value, view.ViewName, view.ViewType))
    End Sub
End Class

See Also

ControlledApplication Class
Autodesk.Revit Namespace

ViewPrinting Event

[image]