Revit 2010 API
Connector..::.Radius Property
Connector Class See Also Send Feedback
The radius of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual double Radius { get; set; }
Visual Basic (Declaration)
Public Overridable Property Radius As Double
Visual C++
public:
virtual property double Radius {
    double get ();
    void set (double value);
}

Implements

IConnector..::.Radius

Remarks

In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's shape is not round.
System..::.ArgumentException | Thrown when the argument is invalid.
System..::.InvalidOperationException | Thrown on failure to set radius.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

Shape Property

[image]