Revit 2010 API
PushButtonData..::.AssemblyName Property
PushButtonData Class See Also Send Feedback
The assembly path of the button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string AssemblyName { get; set; }
Visual Basic (Declaration)
Public Property AssemblyName As String
Visual C++
public:
property String^ AssemblyName {
    String^ get ();
    void set (String^ value);
}

Remarks

The path of the assembly which contains the corresponding external command.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when setting the value to null.
System..::.ArgumentException | Thrown when setting the value to an empty string.

See Also

PushButtonData Class
Autodesk.Revit Namespace

ClassName Property

[image]