Revit 2010 API
gbXMLParamElem Class
Members Example See Also Send Feedback
An object that represents the gbXML Parameters within the Autodesk Revit project.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class gbXMLParamElem : Element
Visual Basic (Declaration)
Public Class gbXMLParamElem _
    Inherits Element
Visual C++
public ref class gbXMLParamElem : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Examples

CopyC#
public void GetInfo_gbXMLParamElem(Document document)
{
    // The gbXMLParamElem can be retrieved from ProjectInformation only
    gbXMLParamElem xmlPara = document.ProjectInformation.gbXMLSettings;

    if (null != xmlPara)
    {
        string message = "gbXMLParamElem : ";
        message += "\nBuildingType : " + xmlPara.BuildingType;
        message += "\nPostal Code : " + xmlPara.PostalCode;
        MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
    }
}
CopyVB.NET
Public Sub GetInfo_gbXMLParamElem(ByVal document As Document)
    ' The gbXMLParamElem can be retrieved from ProjectInformation only
    Dim xmlPara As Autodesk.Revit.Elements.gbXMLParamElem = document.ProjectInformation.gbXMLSettings

    If xmlPara IsNot Nothing Then
        Dim message As String = "gbXMLParamElem : "
        message += vbLf & "BuildingType : " & xmlPara.BuildingType
        message += vbLf & "Postal Code : " & xmlPara.PostalCode
        MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.gbXMLParamElem

See Also

gbXMLParamElem Members
Autodesk.Revit.Elements Namespace

gbXMLParamElem Members

[image] [image]