Revit 2010 API
ParameterType Enumeration
See Also Send Feedback
An enumerate type listing all of the data type interpretation that Autodesk Revit supports.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ParameterType
Visual Basic (Declaration)
Public Enumeration ParameterType
Visual C++
public enum class ParameterType

Members

Member name | Description
Material | The value of this property is considered to be a material.
URL | A text string that represents a web address.
Text | The parameter data should be interpreted as a string of text.
HVACFactor | The data value will be represented as a HVACFactor.
HVACAreaDividedByHeatingLoad | The data value will be represented as a HVACAreaDividedByHeatingLoad.
ElectricalLuminance | The data value will be represented as an ElectricalLuminance.
ElectricalLuminousIntensity | The data value will be represented as an ElectricalLuminousIntensity.
ColorTemperature | The data value will be represented as a ColorTemperature.
ElectricalWattage | The data value will be represented as an ElectricalWattage.
ElectricalEfficacy | The data value will be represented as an ElectricalEfficacy.
PipingSlope | The data value will be represented as a PipingSlope.
HVACSlope | The data value will be represented as a HVACSlope.
WireSize | The data value will be represented as a WireSize.
HVACAreaDividedByCoolingLoad | The data value will be represented as a HVACAreaDividedByCoolingLoad.
HVACAirflowDividedByCoolingLoad | The data value will be represented as a HVACAirflowDividedByCoolingLoad.
HVACAirflowDividedByVolume | The data value will be represented as a HVACAirflowDividedByVolume.
HVACHeatingLoadDividedByVolume | The data value will be represented as a HVACHeatingLoadDividedByVolume.
HVACHeatingLoadDividedByArea | The data value will be represented as a HVACHeatingLoadDividedByArea.
HVACHeatingLoad | The data value will be represented as a HVACHeatingLoad.
HVACCoolingLoadDividedByVolume | The data value will be represented as a HVACCoolingLoadDividedByVolume.
HVACCoolingLoadDividedByArea | The data value will be represented as a HVACCoolingLoadDividedByArea.
HVACCoolingLoad | The data value will be represented as a HVACCoolingLoad.
Slope | The data value will be represented as a Slope.
HVACAirflowDensity | The data value will be represented as a HVACAirflowDensity.
HVACCoefficientOfHeatTransfer | The data value will be represented as a HVACCoefficientOfHeatTransfer.
HVACViscosity | The data value will be represented as a HVACViscosity.
PipingVolume | The data value will be represented as a PipingVolume.
AreaForcePerLength | The data value will be represented as an AreaForcePerLength.
LinearForceLengthPerAngle | The data value will be represented as a LinearForceLengthPerAngle.
LinearForcePerLength | The data value will be represented as a LinearForcePerLength.
ForceLengthPerAngle | The data value will be represented as a ForceLengthPerAngle.
ForcePerLength | The data value will be represented as a ForcePerLength.
LinearMoment | The data value will be represented as a LinearMoment.
TemperalExp | The data value will be represented as a TemperalExp.
UnitWeight | The data value will be represented as a UnitWeight.
Stress | The data value will be represented as a Stress.
PipingRoughness | The data value will be represented as a PipingRoughness.
PipeSize | The data value will be represented as a PipeSize.
PipingViscosity | The data value will be represented as a PipingViscosity.
PipingVelocity | The data value will be represented as a PipingVelocity.
PipingTemperature | The data value will be represented as a PipingTemperature.
PipingPressure | The data value will be represented as a PipingPressure.
PipingFriction | The data value will be represented as a PipingFriction.
PipingFlow | The data value will be represented as a PipingFlow.
PipingDensity | The data value will be represented as a PipingDensity.
ElectricalPowerDensity | The data value will be represented as an ElectricalPowerDensity.
ElectricalApparentPower | The data value will be represented as an ElectricalApparentPower.
HVACRoughness | The data value will be represented as a HVACRoughness.
ElectricalPower | The data value will be represented as an ElectricalPower.
ElectricalLuminousFlux | The data value will be represented as an ElectricalLuminousFlux.
ElectricalIlluminance | The data value will be represented as an ElectricalIlluminance.
ElectricalFrequency | The data value will be represented as an ElectricalFrequency.
ElectricalPotential | The data value will be represented as an ElectricalPotential.
ElectricalCurrent | The data value will be represented as an ElectricalCurrent.
HVACHeatGain | The data value will be represented as a HVACHeatGain.
HVACCrossSection | The data value will be represented as a HVACCrossSection.
HVACDuctSize | The data value will be represented as a HVACDuctSize.
HVACAirflow | The data value will be represented as a HVACAirflow.
HVACVelocity | The data value will be represented as a HVACVelocity.
HVACTemperature | The data value will be represented as a HVACTemperature.
HVACPressure | The data value will be represented as a HVACPressure.
HVACPowerDensity | The data value will be represented as a HVACPowerDensity.
HVACPower | The data value will be represented as a HVACPower.
HVACFriction | The data value will be represented as a HVACFriction.
HVACEnergy | The data value will be represented as a HVACEnergy.
HVACDensity | The data value will be represented as a HVACDensity.
FamilyType | A parameter used to control the type of a family nested within another family.
FixtureUnit | A parameter value that represents the fixture units, as used in piping disciplines.
NumberOfPoles | A parameter value that represents the number of poles, as used in electrical disciplines.
Moment | The data value will be represented as a moment.
AreaForce | The data value will be represented as an area force.
LinearForce | The data value will be represented as a linear force.
Force | The data value will be represented as a force.
YesNo | A boolean value that will be represented as Yes or No.
Angle | The parameter data represents an angle.
Volume | The parameter data represents a volume.
Area | The parameter data represents an area.
Integer | The parameter data should be interpreted as a whole number, positive or negative.
Invalid | The parameter type is invalid. This value should not be used.
Length | The parameter data represents a length.
Currency | The data value will be represented as a Currency.
Number | The parameter data should be interpreted as a real number, possibly including decimal points.

See Also

Autodesk.Revit.Parameters Namespace

ServiceType Enumeration

[image]