Revit 2010 API
Element Class
Members See Also Send Feedback
Geometric representation of an element.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Element : GeometryObject
Visual Basic (Declaration)
Public Class Element _
    Inherits GeometryObject
Visual C++
public ref class Element : public GeometryObject

Remarks

This class contains geometric primitives that are generated from the parametric description of the element.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Element

See Also

Element Members
Autodesk.Revit.Geometry Namespace

Element Members

[image] [image]