Revit 2010 API
AreaLoad Class
Members Example See Also Send Feedback
An object that represents a force applied across an area.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class AreaLoad : LoadBase
Visual Basic (Declaration)
Public Class AreaLoad _
    Inherits LoadBase
Visual C++
public ref class AreaLoad : public LoadBase

Examples

CopyC#
public void GetInfo_AreaLoad(AreaLoad areaLoad)
{
    string message = "AreaLoad Force : ";
    // Get areaload force1 position
    message += "\nAreaLoad Force1 position :(" + areaLoad.Force1.X + ", "
        + areaLoad.Force1.Y + ", " + areaLoad.Force1.Z + ")";
    // Get areaload force2 position
    message += "\nAreaLoad Force2 position :(" + areaLoad.Force2.X + ", "
        + areaLoad.Force2.Y + ", " + areaLoad.Force2.Z + ")";
    // Get areaload force3 position
    message += "\nAreaLoad Force3 position :(" + areaLoad.Force3.X + ", "
        + areaLoad.Force3.Y + ", " + areaLoad.Force3.Z + ")";

    // Get loop number
    message += "\nLoop number is :" + areaLoad.NumLoops;
    for (int i = 0; i < areaLoad.NumLoops; i++)
    {
        // Get curve number
        message += "\nCurve number is : " + areaLoad.get_NumCurves(i);
        for (int j = 0; j < areaLoad.get_NumCurves(i); j++)
        {
            Autodesk.Revit.Geometry.Curve curve = areaLoad.get_Curve(i, j);
            // Get curve start point
            message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
                + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
            // Get curve end point
            message += "; Curve end point:(" + curve.get_EndPoint(1).X + ", "
                + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
        }
    }

    // Get ref points information
    for (int k = 0; k < areaLoad.NumRefPoints; k++)
    {
        // Get areaload Ref point
        message += "\nAreaLoad Ref point :(" + areaLoad.get_RefPoint(k).X + ", "
            + areaLoad.get_RefPoint(k).Y + ", " + areaLoad.get_RefPoint(k).Z + ")";
    }
    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_AreaLoad(ByVal areaLoad As Autodesk.Revit.Elements.AreaLoad)
    Dim message As String = "AreaLoad Force : "
    ' Get areaload force1 position
    message += ((vbLf & "AreaLoad Force1 position :(" & areaLoad.Force1.X & ", ") + areaLoad.Force1.Y & ", ") + areaLoad.Force1.Z & ")"
    ' Get areaload force2 position
    message += ((vbLf & "AreaLoad Force2 position :(" & areaLoad.Force2.X & ", ") + areaLoad.Force2.Y & ", ") + areaLoad.Force2.Z & ")"
    ' Get areaload force3 position
    message += ((vbLf & "AreaLoad Force3 position :(" & areaLoad.Force3.X & ", ") + areaLoad.Force3.Y & ", ") + areaLoad.Force3.Z & ")"

    ' Get loop number
    message += vbLf & "Loop number is :" & areaLoad.NumLoops
    For i As Integer = 0 To areaLoad.NumLoops - 1
        ' Get curve number
        message += vbLf & "Curve number is : " & areaLoad.NumCurves(i)
        For j As Integer = 0 To areaLoad.NumCurves(i) - 1
            Dim curve As Autodesk.Revit.Geometry.Curve = areaLoad.Curve(i, j)
            ' Get curve start point
            message += ((vbLf & "Curve start point:(" & curve.EndPoint(0).X & ", ") + curve.EndPoint(0).Y & ", ") + curve.EndPoint(0).Z & ")"
            ' Get curve end point
            message += (("; Curve end point:(" & curve.EndPoint(1).X & ", ") + curve.EndPoint(1).Y & ", ") + curve.EndPoint(1).Z & ")"
        Next
    Next

    ' Get ref points information
    For k As Integer = 0 To areaLoad.NumRefPoints - 1
        ' Get areaload Ref point
        message += ((vbLf & "AreaLoad Ref point :(" & areaLoad.RefPoint(k).X & ", ") + areaLoad.RefPoint(k).Y & ", ") + areaLoad.RefPoint(k).Z & ")"
    Next
    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.LoadBase
Autodesk.Revit.Elements..::.AreaLoad

See Also

AreaLoad Members
Autodesk.Revit.Elements Namespace

AreaLoad Members

[image] [image]