Revit 2010 API
UV Members
UV Class Constructors Methods Properties See Also Send Feedback

The UV type exposes the following members.

Constructors

Name | Description
UV | Overloaded.

Methods

Name | Description
Add | Adds the specified 2-D vector to this 2-D vector and returns the result.
AlmostEqual | Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).
Angle | Returns the angle between this vector and the specified vector.
Cross | The cross product of this 2-D vector and the specified 2-D vector.
Distance | Returns the distance from this 2-D point to the specified 2-D point.
Divide | Divides this 2-D vector by the specified value and returns the result.
Dot | The dot product of this 2-D vector and the specified 2-D vector.
Multiply | Multiplies this 2-D vector by the specified value and returns the result.
Negate | Negates this 2-D vector.
Subtract | Subtracts the specified 2-D vector from this 2-D vector and returns the result.

Operators

Name | Description
Addition | Adds the two specified 2-D vectors and returns the result.
Division | Divides the specified 2-D vector by the specified value.
Multiply | Overloaded. The product of the specified number and the specified 2-D vector.
Subtraction | Subtracts the two specified 2-D vectors and returns the result.
UnaryNegation | Negates this 2-D vector and returns the result.

Properties

Name | Description
Basis | Indexed access for Basis.
BasisU | The basic of the U axis.
BasisV | The basic of the V axis.
IsNormalized | The boolean value that indicates whether this 2-D vector is a normalized vector.
IsZero | The boolean value that indicates whether this 2-D vector is a zero vector.
Item | Indexed access to coordinates.
Length | The length of this 2-D vector.
Normalized | This 2-D vector, normalized.
U | The first coordinate.
V | The second coordinate.
Zero | The coordinate origin or zero 2-D vector.

See Also

UV Class
Autodesk.Revit.Geometry Namespace

UV Constructor

[image] [image]