Revit 2010 API
Document..::.NewPipingSystem Method
Document Class See Also Send Feedback
Creates a new MEP piping system element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipingSystem NewPipingSystem(
    Connector baseEquipmentConnector,
    ConnectorSet connectors,
    PipeSystemType pipingSystemType
)
Visual Basic (Declaration)
Public Function NewPipingSystem ( _
    baseEquipmentConnector As Connector, _
    connectors As ConnectorSet, _
    pipingSystemType As PipeSystemType _
) As PipingSystem
Visual C++
public:
PipingSystem^ NewPipingSystem(
    Connector^ baseEquipmentConnector,
    ConnectorSet^ connectors,
    PipeSystemType pipingSystemType
)

Parameters

baseEquipmentConnector
Type: Autodesk.Revit.MEP..::.Connector
One connector within base equipment which is used to connect with the system. The base equipment is optional for the system, so this argument may be null. The baseEquipmentConnector should not be included in the connectors.
connectors
Type: Autodesk.Revit.MEP..::.ConnectorSet
Connectors that will connect to the system. The owner elements of these connectors will be added into system as its elements.
pipingSystemType
Type: Autodesk.Revit.MEP.Enums..::.PipeSystemType
The System type.

Return Value

If creation was successful then an instance of piping system is returned, otherwise an exception with information will be thrown.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when calling this function outside of the Autodesk Revit MEP product.
System..::.ArgumentNullException | Thrown when the connectors parameter value is null.
System..::.ArgumentOutOfRangeException | Thrown when the pipingSystemType parameter value is out of permitted scope.
System..::.ArgumentException | Thrown when some connectors can't be used to create the mechanical system. All the input connectors and base equipment connector should match system type and domain with the system, and they should not have been used in another system.
System..::.InvalidOperationException | Thrown when the piping system creation failed.

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewPointBoundaryConditions Method

[image]