Revit 2010 API
ViewPrintingEventArgs Members
ViewPrintingEventArgs Class Constructors Methods Properties See Also Send Feedback

The ViewPrintingEventArgs type exposes the following members.

Constructors

Name | Description
ViewPrintingEventArgs | Initializes a new instance of the ViewPrintingEventArgs class

Methods

Name | Description

Properties

Name | Description
Index | When the view is being printed as a part of a view-set, the value of this property indicates the index of this view in the entire set. The value is 0-based.
Settings | Print Settings of current project.
TotalViews | When the view is being printed as a part of a view-set, the value of this property indicates the number of all views in the set.
View | The view to be printed.

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.Events Namespace

ViewPrintingEventArgs Constructor

[image]