Revit 2010 API
NurbSpline Class
Members See Also Send Feedback
A nurb spline.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class NurbSpline : Curve
Visual Basic (Declaration)
Public Class NurbSpline _
    Inherits Curve
Visual C++
public ref class NurbSpline : public Curve

Remarks

The nurb spline lies in the plane defined by control point, weight,knots,degree.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Curve
Autodesk.Revit.Geometry..::.NurbSpline

See Also

NurbSpline Members
Autodesk.Revit.Geometry Namespace

NurbSpline Members

[image] [image]