Revit 2010 API
Floor..::.SpanDirectionSymbols Property
Floor Class Example See Also Send Feedback
An array of span direction symbols associated with this floor.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementArray SpanDirectionSymbols { get; }
Visual Basic (Declaration)
Public ReadOnly Property SpanDirectionSymbols As ElementArray
Visual C++
public:
property ElementArray^ SpanDirectionSymbols {
    ElementArray^ get ();
}

Remarks

By using the ObjecType property on these span direction symbols it is possible to read if the floor has one way or two way span direction graphics.

Examples

CopyC#
public void SpanDirectionSymbolsInfo(Floor floor)
{
    string msg = "";
    if (0 == floor.SpanDirectionSymbols.Size)
    {
        msg = "No span direction symbol!";
    }
    foreach (Element element in floor.SpanDirectionSymbols)
    {
        msg += "Span direction symbol name is : " + element.Name;
    }

    // Give the user some information.
    MessageBox.Show(msg, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub SpanDirectionSymbolsInfo(ByVal floor As Autodesk.Revit.Elements.Floor)
    Dim msg As String = ""
    If 0 = floor.SpanDirectionSymbols.Size Then
        msg = "No span direction symbol!"
    End If
    For Each element As Autodesk.Revit.Element In floor.SpanDirectionSymbols
        msg += "Span direction symbol name is : " & element.Name
    Next

    ' Give the user some information.
    MessageBox.Show(msg, "Revit", MessageBoxButtons.OK)
End Sub

See Also

Floor Class
Autodesk.Revit.Elements Namespace

StructuralUsage Property

[image]