Revit 2010 API
RuledFace Class
Members Example See Also Send Feedback
A ruled face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RuledFace : Face
Visual Basic (Declaration)
Public Class RuledFace _
    Inherits Face
Visual C++
public ref class RuledFace : public Face

Remarks

Ruled faces are defined by ruled surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces.

Examples

CopyC#
private void GetRuledFaceInfo(Face face)
{
    RuledFace ruledFace = face as RuledFace;
    if (null != ruledFace)
    {
        Curve curve = ruledFace.get_Curve(0);
        XYZ point = ruledFace.get_Point(0);
    }
}
CopyVB.NET
Private Sub GetRuledFaceInfo(ByVal face As Autodesk.Revit.Geometry.Face)
    Dim ruledFace As RuledFace = TryCast(face, RuledFace)
    If ruledFace IsNot Nothing Then
        Dim curve As Curve = ruledFace.Curve(0)
        Dim point As Autodesk.Revit.Geometry.XYZ = ruledFace.Point(0)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Face
Autodesk.Revit.Geometry..::.RuledFace

See Also

RuledFace Members
Autodesk.Revit.Geometry Namespace

RuledFace Members

[image] [image]