Revit 2010 API
Document..::.FilterTypeSupported Property
Document Class See Also Send Feedback
Boolean value which indicates whether the specified builtin parameter supports the specifed filter type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool FilterTypeSupported[
    BuiltInParameter ,
    CriteriaFilterType
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property FilterTypeSupported ( _
     As BuiltInParameter, _
     As CriteriaFilterType _
) As Boolean
Visual C++
public:
property bool FilterTypeSupported[BuiltInParameter , CriteriaFilterType ] {
    bool get (BuiltInParameter , CriteriaFilterType );
}

Parameters

Type: Autodesk.Revit.Parameters..::.BuiltInParameter
Type: Autodesk.Revit.Enums..::.CriteriaFilterType

Remarks

This property is useful in element retrieval. It can be used to provide correct options of filter types for the FilterCriterion object.

See Also

Document Class
Autodesk.Revit Namespace

FloorTypes Property

[image]