Revit 2010 API
FamilyItemFactory..::.NewAngularDimension Method (View, Arc, Reference, Reference, DimensionType)
FamilyItemFactory Class See Also Send Feedback
Creates a new angular dimension object using the specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Dimension NewAngularDimension(
    View view,
    Arc arc,
    Reference firstRef,
    Reference secondRef,
    DimensionType dimensionType
)
Visual Basic (Declaration)
Public Function NewAngularDimension ( _
    view As View, _
    arc As Arc, _
    firstRef As Reference, _
    secondRef As Reference, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewAngularDimension(
    View^ view,
    Arc^ arc,
    Reference^ firstRef,
    Reference^ secondRef,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the dimension is to be visible.
arc
Type: Autodesk.Revit.Geometry..::.Arc
The extension arc of the dimension.
firstRef
Type: Autodesk.Revit.Geometry..::.Reference
The first geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
secondRef
Type: Autodesk.Revit.Geometry..::.Reference
The second geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
dimensionType
Type: Autodesk.Revit.Symbols..::.DimensionType
The dimension style to be used for the dimension.

Return Value

If creation was successful the new angular dimension is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when any input argument is null.
System..::.ArgumentException | Thrown when the argument firstRef/secondRef/dimensionType is invalid.
System..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewAngularDimension Overload
Autodesk.Revit.Creation Namespace

NewArcLengthDimension Method

[image] [image]