Revit 2010 API
Document..::.NewRooms Method (Level, Phase)
Document Class See Also Send Feedback
Creates new rooms in each plan circuit found in the given level in the given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewRooms(
    Level level,
    Phase phase
)
Visual Basic (Declaration)
Public Function NewRooms ( _
    level As Level, _
    phase As Phase _
) As ElementSet
Visual C++
public:
ElementSet^ NewRooms(
    Level^ level,
    Phase^ phase
)

Parameters

level
Type: Autodesk.Revit.Elements..::.Level
The level from which the circuits are found.
phase
Type: Autodesk.Revit.Elements..::.Phase
The phase on which the room is to exist.

Return Value

If successful an Element set which contains the rooms should be returned, otherwise the exception will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved.
System..::.InvalidOperationException | If the phase is invalid, or regeneration fails at the end of the creation.

See Also

Document Class
NewRooms Overload
Autodesk.Revit.Creation Namespace

NewRooms Method (Phase, Int32)

[image]