Revit 2010 API
RibbonItem..::.ItemType Property
RibbonItem Class See Also Send Feedback
Gets the item type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public RibbonItem..::.RibbonItemType ItemType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemType As RibbonItem..::.RibbonItemType
Visual C++
public:
property RibbonItem..::.RibbonItemType ItemType {
    RibbonItem..::.RibbonItemType get ();
}

Remarks

Push button or Pull-down button or Menu item.

See Also

RibbonItem Class
Autodesk.Revit Namespace

ToolTip Property

[image]