Revit 2010 API
PrintManager..::.PrintRange Property
PrintManager Class See Also Send Feedback
The print range.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PrintRange PrintRange { get; set; }
Visual Basic (Declaration)
Public Property PrintRange As PrintRange
Visual C++
public:
property PrintRange PrintRange {
    PrintRange get ();
    void set (PrintRange value);
}

Remarks

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the argument is out of range.

See Also

PrintManager Class
Autodesk.Revit Namespace

PrintSetup Property

[image]