Revit 2010 API
MechanicalSystem..::.BaseEquipmentConnector Property
MechanicalSystem Class See Also Send Feedback
The connector within the base equipment which is used to connect with the system.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Connector BaseEquipmentConnector { get; set; }
Visual Basic (Declaration)
Public Property BaseEquipmentConnector As Connector
Visual C++
public:
property Connector^ BaseEquipmentConnector {
    Connector^ get ();
    void set (Connector^ value);
}

Remarks

Assigning null to the base equipment connector will disconnect the base equipment from the system.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when assigning a connector which is used in a system, or when the connector's owner is not of type 'mechanical equipment'.
System..::.InvalidOperationException | Thrown when the set operation failed.

See Also

MechanicalSystem Class
Autodesk.Revit.MEP Namespace

DuctNetwork Property

[image]