Revit 2010 API
Panel Members
Panel Class Constructors Methods Properties See Also Send Feedback

The Panel type exposes the following members.

Constructors

Name | Description
Panel | For Internal Use Only.

Methods

Name | Description
GetRefGridLines | This method is used to get the reference gridlines.

Properties

Name | Description
AsFamilyInstance | This property is used to get family instance within project.
Lock | This property is used to know whether a panel is locked and lock or unlock a panel.
Lockable | This property is used to know whether a panel can be locked.
PanelType | The Panel style of this Panel.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Transform | This property is used to find the transform of a curtain panel within project.

See Also

Panel Class
Autodesk.Revit.Elements Namespace

Panel Constructor

[image]