Revit 2010 API
Document..::.Import Method (String, GBXMLImportOptions)
Document Class See Also Send Feedback
Imports a Green-Building XML file into the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Import(
    string file,
    GBXMLImportOptions options
)
Visual Basic (Declaration)
Public Function Import ( _
    file As String, _
    options As GBXMLImportOptions _
) As Boolean
Visual C++
public:
bool Import(
    String^ file,
    GBXMLImportOptions^ options
)

Parameters

file
Type: System..::.String
Full path of the file to import. File must exist.
options
Type: Autodesk.Revit..::.GBXMLImportOptions
Various options applicable to GBXml import.If nullptr, all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

This method is available only in MEP. Though the 'options' argument is not currently used, an object still must be provided (may be null). The method will return 'false' if not succeed. e.g when the input xml file does not contain any result elements.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when file argument is null or empty.
System.IO..::.FileNotFoundException | Thrown when the file specified does not exist.
System..::.ArgumentException | Thrown when no file is specified or if the file is not a valid gbXML file or does not contain any result elements.

See Also

Document Class
Import Overload
Autodesk.Revit Namespace

Import Method (String, InventorImportOptions)

[image]