Revit 2010 API
Filter..::.NewParameterFilter Method
Filter Class See Also Send Feedback
Creates a new parameter filter.

Overload List

Name | Description
NewParameterFilter(BuiltInParameter, CriteriaFilterType, ElementId) | Creates a parameter filter object based on an ElementId built-in parameter type.
NewParameterFilter(BuiltInParameter, CriteriaFilterType, Double) | Creates a parameter filter object based on a double built-in parameter type.
NewParameterFilter(BuiltInParameter, CriteriaFilterType, Int32) | Creates a parameter filter object based on an integer built-in parameter type.
NewParameterFilter(BuiltInParameter, CriteriaFilterType, String) | Creates a parameter filter object based on a string built-in parameter type.
NewParameterFilter(String, CriteriaFilterType, ElementId) | Creates a parameter filter object based on the name of an ElementId parameter.
NewParameterFilter(String, CriteriaFilterType, Double) | Creates a parameter filter object based on the name of a double parameter.
NewParameterFilter(String, CriteriaFilterType, Int32) | Creates a parameter filter object based on the name of an integer parameter .
NewParameterFilter(String, CriteriaFilterType, String) | Creates a parameter filter object based on the name of a string parameter.

See Also

Filter Class
Filter Members
Autodesk.Revit.Creation Namespace

NewParameterFilter Method (BuiltInParameter, CriteriaFilterType, ElementId)

[image]