Revit 2010 API
Filter..::.NewMaterialFilter Method
Filter Class See Also Send Feedback
Creates a MaterialFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public MaterialFilter NewMaterialFilter(
    Material material
)
Visual Basic (Declaration)
Public Function NewMaterialFilter ( _
    material As Material _
) As MaterialFilter
Visual C++
public:
MaterialFilter^ NewMaterialFilter(
    Material material
)

Parameters

material
Type: Autodesk.Revit.Structural.Enums..::.Material
Filter elements by the material.

Return Value

Returns a new material filter object with given material.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the specified enumeration value is invalid.

See Also

Filter Class
Autodesk.Revit.Creation Namespace

NewParameterFilter Method

[image] [image]