Revit 2010 API
DemandFactor Members
DemandFactor Class Constructors Methods Properties See Also Send Feedback

The DemandFactor type exposes the following members.

Constructors

Name | Description
DemandFactor | For Internal Use Only.

Methods

Name | Description
SetPercentage | Set percentage value for the specified range.
SetPercentageToInfinity | This method is used to set percentage value for the range in [MinFactor, PositiveInfinity) specially.

Properties

Name | Description
DataItems | Get all data items in this demand factor, which represents demand factor percentage in a specific range.
LoadClassification | Get category of demand factor.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.

See Also

DemandFactor Class
Autodesk.Revit.MEP Namespace

DemandFactor Constructor

[image]