Revit 2010 API
Document..::.Elements Property (Filter, ICollection<(Of <(Element>)>))
Document Class See Also Send Feedback
Collects all elements which satisfy specified filter within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Elements[
    Filter filter,
    ICollection<Element> collection
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements ( _
    filter As Filter, _
    collection As ICollection(Of Element) _
) As Integer
Visual C++
public:
property int Elements[Filter^ filter, ICollection<Element^>^ collection] {
    int get (Filter^ filter, ICollection<Element^>^ collection);
}

Parameters

filter
Type: Autodesk.Revit..::.Filter
Filter used to determine the elements to add.
collection
Type: System.Collections.Generic..::.ICollection <(Of <( Element >)>)
An element collection to contain the elements found.

Remarks

The input filter parameter can be one of: TypeFilter, CategoryFilter, FamilyFilter, SymbolFilter, ParameterFilter, InstanceUsageFilter, WallUsageFilter, MaterialFilter or StructuralTypeFilter; This filter can be combination of more than one filters by using logical And and Or filters. If the collection provided already contains elements, new elements added to the collection will be checked against the contents of the collection, and elements already in the input will not be added to the collection again. Because of the overhead required to perform these checks, to obtain the best performance from this property pass an empty collection. This method is not supported in VSTA, use the variation accepting an ElementArray instead.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter of filter or collection is null.

See Also

Document Class
Elements Overload
Autodesk.Revit Namespace

Elements Property (Type, ElementArray)

[image]