Revit 2010 API
DisplayUnitType Enumeration
See Also Send Feedback
An enumerate type listing Display Unit types of the Unit types that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum DisplayUnitType
Visual Basic (Declaration)
Public Enumeration DisplayUnitType
Visual C++
public enum class DisplayUnitType

Members

Member name | Description
DUT_SQUARE_FEET_PER_THOUSAND_BRITISH_THERMAL_UNITS_PER_HOUR |
DUT_LUMENS_PER_WATT |
DUT_CURRENCY |
DUT_SQUARE_METERS_PER_KILOWATTS |
DUT_SQUARE_FEET_PER_TON_OF_REFRIGERATION |
DUT_LITERS_PER_SECOND_KILOWATTS |
DUT_CUBIC_FEET_PER_MINUTE_TON_OF_REFRIGERATION |
DUT_LITERS_PER_SECOND_CUBIC_METER |
DUT_CUBIC_FEET_PER_MINUTE_CUBIC_FOOT |
DUT_TON_OF_REFRIGERATION |
DUT_BRITISH_THERMAL_UNITS_PER_HOUR_CUBIC_FOOT |
DUT_BRITISH_THERMAL_UNITS_PER_HOUR_SQUARE_FOOT |
DUT_WATTS_PER_CUBIC_METER |
DUT_WATTS_PER_CUBIC_FOOT |
DUT_RISE_OVER_MMS |
DUT_RISE_OVER_FOOT |
DUT_RISE_OVER_INCHES |
DUT_SLOPE_DEGREES |
DUT_RATIO_12 |
DUT_RATIO_10 |
DUT_LITERS_PER_SECOND_SQUARE_METER |
DUT_CUBIC_FEET_PER_MINUTE_SQUARE_FOOT |
DUT_BRITISH_THERMAL_UNITS_PER_HOUR_SQUARE_FOOT_FAHRENHEIT |
DUT_WATTS_PER_SQUARE_METER_KELVIN |
DUT_KILONEWTON_METERS_PER_DEGREE_PER_METER |
DUT_KIP_FEET_PER_DEGREE_PER_FOOT |
DUT_KILONEWTON_METERS_PER_DEGREE |
DUT_KIP_FEET_PER_DEGREE |
DUT_KIPS_PER_CUBIC_FOOT |
DUT_KIPS_PER_INCH |
DUT_POUNDS_MASS_PER_FOOT_HOUR |
DUT_POUND_FORCE_FEET_PER_FOOT |
DUT_TONNE_FORCE_METERS_PER_METER |
DUT_KILOGRAM_FORCE_METERS_PER_METER |
DUT_KIP_FEET_PER_FOOT |
DUT_MEGANEWTON_METERS_PER_METER |
DUT_KILONEWTON_METERS_PER_METER |
DUT_DECANEWTON_METERS_PER_METER |
DUT_NEWTON_METERS_PER_METER |
DUT_INV_CELSIUS |
DUT_INV_FAHRENHEIT |
DUT_KIPS_PER_CUBIC_INCH |
DUT_POUNDS_FORCE_PER_CUBIC_FOOT |
DUT_KILONEWTONS_PER_CUBIC_METER |
DUT_KIPS_PER_SQUARE_INCH |
DUT_FEET_PER_SECOND |
DUT_CENTIPOISES |
DUT_POUNDS_MASS_PER_FOOT_SECOND |
DUT_PASCAL_SECONDS |
DUT_FEET_OF_WATER |
DUT_FEET_OF_WATER_PER_100FT |
DUT_INV_KIPS |
DUT_INV_KILONEWTONS |
DUT_CUBIC_FEET_PER_KIP |
DUT_CUBIC_METERS_PER_KILONEWTON |
DUT_SQUARE_FEET_PER_KIP |
DUT_SQUARE_METERS_PER_KILONEWTON |
DUT_FEET_PER_KIP |
DUT_METERS_PER_KILONEWTON |
DUT_POUND_FORCE_FEET |
DUT_TONNE_FORCE_METERS |
DUT_KILOGRAM_FORCE_METERS |
DUT_KIP_FEET |
DUT_MEGANEWTON_METERS |
DUT_KILONEWTON_METERS |
DUT_DECANEWTON_METERS |
DUT_NEWTON_METERS |
DUT_POUNDS_FORCE_PER_SQUARE_FOOT |
DUT_TONNES_FORCE_PER_SQUARE_METER |
DUT_KILOGRAMS_FORCE_PER_SQUARE_METER |
DUT_KIPS_PER_SQUARE_FOOT |
DUT_MEGANEWTONS_PER_SQUARE_METER |
DUT_KILONEWTONS_PER_SQUARE_METER |
DUT_DECANEWTONS_PER_SQUARE_METER |
DUT_NEWTONS_PER_SQUARE_METER |
DUT_POUNDS_FORCE_PER_FOOT |
DUT_TONNES_FORCE_PER_METER |
DUT_KILOGRAMS_FORCE_PER_METER |
DUT_KIPS_PER_FOOT |
DUT_MEGANEWTONS_PER_METER |
DUT_KILONEWTONS_PER_METER |
DUT_DECANEWTONS_PER_METER |
DUT_NEWTONS_PER_METER |
DUT_POUNDS_FORCE |
DUT_TONNES_FORCE |
DUT_KILOGRAMS_FORCE |
DUT_KIPS |
DUT_MEGANEWTONS |
DUT_KILONEWTONS |
DUT_DECANEWTONS |
DUT_NEWTONS |
DUT_HORSEPOWER |
DUT_KILOVOLT_AMPERES |
DUT_VOLT_AMPERES |
DUT_LUMENS |
DUT_CANDLEPOWER |
DUT_CANDELAS |
DUT_CANDELAS_PER_SQUARE_METER |
DUT_FOOTLAMBERTS |
DUT_FOOTCANDLES |
DUT_LUX |
DUT_CYCLES_PER_SECOND |
DUT_HERTZ |
DUT_MILLIVOLTS |
DUT_KILOVOLTS |
DUT_VOLTS |
DUT_MILLIAMPERES |
DUT_KILOAMPERES |
DUT_AMPERES |
DUT_GALLONS_US_PER_HOUR |
DUT_GALLONS_US_PER_MINUTE |
DUT_CUBIC_METERS_PER_HOUR |
DUT_CUBIC_METERS_PER_SECOND |
DUT_LITERS_PER_SECOND |
DUT_CUBIC_FEET_PER_MINUTE |
DUT_CENTIMETERS_PER_MINUTE |
DUT_METERS_PER_SECOND |
DUT_FEET_PER_MINUTE |
DUT_RANKINE |
DUT_KELVIN |
DUT_CELSIUS |
DUT_FAHRENHEIT |
DUT_BARS |
DUT_ATMOSPHERES |
DUT_MILLIMETERS_OF_MERCURY |
DUT_INCHES_OF_MERCURY |
DUT_POUNDS_FORCE_PER_SQUARE_INCH |
DUT_MEGAPASCALS |
DUT_KILOPASCALS |
DUT_PASCALS |
DUT_INCHES_OF_WATER |
DUT_WATTS_PER_SQUARE_METER |
DUT_WATTS_PER_SQUARE_FOOT |
DUT_KILOCALORIES_PER_SECOND |
DUT_CALORIES_PER_SECOND |
DUT_BRITISH_THERMAL_UNITS_PER_HOUR |
DUT_BRITISH_THERMAL_UNITS_PER_SECOND |
DUT_KILOWATTS |
DUT_WATTS |
DUT_PASCALS_PER_METER |
DUT_INCHES_OF_WATER_PER_100FT |
DUT_THERMS |
DUT_KILOWATT_HOURS |
DUT_JOULES |
DUT_KILOCALORIES |
DUT_CALORIES |
DUT_BRITISH_THERMAL_UNITS |
DUT_POUNDS_MASS_PER_CUBIC_INCH |
DUT_POUNDS_MASS_PER_CUBIC_FOOT |
DUT_KILOGRAMS_PER_CUBIC_METER |
DUT_PERCENTAGE |
DUT_FIXED |
DUT_GENERAL |
DUT_DEGREES_AND_MINUTES |
DUT_DECIMAL_DEGREES |
DUT_GALLONS_US |
DUT_LITERS |
DUT_CUBIC_MILLIMETERS |
DUT_CUBIC_CENTIMETERS |
DUT_CUBIC_METERS |
DUT_CUBIC_INCHES |
DUT_CUBIC_FEET |
DUT_CUBIC_YARDS |
DUT_HECTARES |
DUT_ACRES |
DUT_SQUARE_MILLIMETERS |
DUT_SQUARE_CENTIMETERS |
DUT_SQUARE_METERS |
DUT_SQUARE_INCHES |
DUT_SQUARE_FEET |
DUT_METERS_CENTIMETERS |
DUT_DECIMAL_INCHES |
DUT_FRACTIONAL_INCHES |
DUT_FEET_FRACTIONAL_INCHES |
DUT_DECIMAL_FEET |
DUT_MILLIMETERS |
DUT_CENTIMETERS |
DUT_METERS |

See Also

Autodesk.Revit.Enums Namespace

DocumentType Enumeration

[image]