Revit 2010 API
RibbonItem..::.ItemText Property
RibbonItem Class See Also Send Feedback
Gets or sets the text displayed on the button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual string ItemText { get; set; }
Visual Basic (Declaration)
Public Overridable Property ItemText As String
Visual C++
public:
virtual property String^ ItemText {
    String^ get ();
    void set (String^ value);
}

Remarks

The text can be changed at run time. Null or empty string is not allowed. If the item is a button in a pulldown, its name will also be changed, because these items' name and text must be the same.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when set the text to empty or to the string contains "%".
System..::.ArgumentNullException | Thrown when set the text to null.

See Also

RibbonItem Class
Autodesk.Revit Namespace

ItemType Property

[image]