Revit 2010 API
View..::.Unhide Method
View Class See Also Send Feedback
Sets the elements to be shown in the given view if they are currently hidden.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void Unhide(
    ElementSet elemSet
)
Visual Basic (Declaration)
Public Sub Unhide ( _
    elemSet As ElementSet _
)
Visual C++
public:
void Unhide(
    ElementSet^ elemSet
)

Parameters

elemSet
Type: Autodesk.Revit..::.ElementSet
A set of elements to be unhidden.

Remarks

This change is permanent until the elements are hidden again. All elements in the set must be currently hidden. An application can check this with IsHidden(View).

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when argument is null.
System..::.InvalidOperationException | Thrown when one of the elements can not be unhidden or has been unhidden already.

See Also

View Class
Autodesk.Revit.Elements Namespace

View Properties

[image] [image]