Revit 2010 API
ControlledApplication..::.DocumentPrinting Event
ControlledApplication Class Example See Also Send Feedback
Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentPrintingEventArgs> DocumentPrinting
Visual Basic (Declaration)
Public Event DocumentPrinting As EventHandler(Of DocumentPrintingEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintingEventArgs^>^ DocumentPrinting {
    void add (EventHandler<DocumentPrintingEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view or ViewSet of the document.

This event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to 'true'. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Export(String, String, GBXMLExportOptions) and similar overloads.
  • Autodesk.Revit.Document.Print()
  • Print()()() and similar overloads.
  • SubmitPrint()()() and similar overloads.
  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

After this event, for each view being printed,ViewPrinting and ViewPrinted events will be raised. Another event DocumentPrinted will be raised immediately after document printing is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

Examples

CopyC#
public class Application_DocumentPrinting : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public IExternalApplication.Result OnStartup(ControlledApplication application)
    {
        // Register related events
        application.DocumentPrinting += new EventHandler<Autodesk.Revit.Events.DocumentPrintingEventArgs>(AppDocumentPrinting);
        return IExternalApplication.Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public IExternalApplication.Result OnShutdown(ControlledApplication application)
    {
        // unregister events
        application.DocumentPrinting -= new EventHandler<Autodesk.Revit.Events.DocumentPrintingEventArgs>(AppDocumentPrinting);
        return IExternalApplication.Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentPrinting class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for DocumentPrinting event, it will display some event arguments.
    /// </summary>
    public void AppDocumentPrinting(object sender, Autodesk.Revit.Events.DocumentPrintingEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("DocumentPrintingEventArgs Parameters ------>");

        info.AppendLine("    Event Cancellable   : " + args.Cancellable);
        info.AppendLine("    Views to be printed : "); // Views
        DumpViewsInfo(args.Views, "    ", ref info);

        MessageBox.Show(info.ToString(), "DocumentPrinting Info");
    }

    /// <summary>
    /// Dump information of views: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="views">Views to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewsInfo(ViewSet views, String prefix, ref StringBuilder info)
    {
        int index = 0;
        ViewSetIterator vsi = views.ForwardIterator();
        vsi.Reset();
        while (vsi.MoveNext())
        {
            Autodesk.Revit.Elements.View curView = vsi.Current as Autodesk.Revit.Elements.View;
            if (null != curView)
            {
                DumpViewInfo(curView, String.Format("{0}#{1}", prefix, index++), ref info);
            }
        }
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line sent to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.Elements.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.Value, view.ViewName, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_DocumentPrinting
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.DocumentPrinting, AddressOf AppDocumentPrinting
        Return IExternalApplication.Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As ControlledApplication) As IExternalApplication.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.DocumentPrinting, AddressOf AppDocumentPrinting
        Return IExternalApplication.Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentPrinting class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for DocumentPrinting event, it will display some event arguments.
    ' </summary>
    Public Sub AppDocumentPrinting(ByVal sender As Object, ByVal args As Autodesk.Revit.Events.DocumentPrintingEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("DocumentPrintingEventArgs Parameters ------>")

        info.AppendLine(" Event Cancellable : " & args.Cancellable)
        info.AppendLine(" Views to be printed : ")
        ' Views
        DumpViewsInfo(args.Views, " ", info)

        MessageBox.Show(info.ToString(), "DocumentPrinting Info")
    End Sub

    ' <summary>
    ' Dump information of views: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="views">Views to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewsInfo(ByVal views As ViewSet, ByVal prefix As String, ByRef info As StringBuilder)
        Dim index As Integer = 0
        Dim vsi As ViewSetIterator = views.ForwardIterator()
        vsi.Reset()
        While vsi.MoveNext()
            Dim curView As Autodesk.Revit.Elements.View = TryCast(vsi.Current, Autodesk.Revit.Elements.View)
            If curView IsNot Nothing Then
                DumpViewInfo(curView, [String].Format("{0}#{1}", prefix, System.Math.Max(System.Threading.Interlocked.Increment(index), index - 1)), info)
            End If
        End While
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line sent to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(ByVal view As Autodesk.Revit.Elements.View, ByVal prefix As String, ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.Value, view.ViewName, view.ViewType))
    End Sub
End Class

See Also

ControlledApplication Class
Autodesk.Revit Namespace

DocumentSaved Event

[image]