Revit 2010 API
Element..::.UniqueId Property
Element Class Example See Also Send Feedback
A stable unique identifier for an element within the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string UniqueId { get; }
Visual Basic (Declaration)
Public ReadOnly Property UniqueId As String
Visual C++
public:
property String^ UniqueId {
    String^ get ();
}

Remarks

The UniqueId can be used to store an identifier in and external database and then be used to retrieve the exact same element in the future if it still exists. This id can be passed the Document's Element property to retrieve the element. The UniqueId is stable across upgrades and workset operations such as save to central whereas the ElementId property may change.

Examples

CopyC#
private void CheckElementUniqueId(Autodesk.Revit.Document document, Autodesk.Revit.Element element)
{
    String uniqueId = element.UniqueId;

    // Get the element using the UniqueId
    Autodesk.Revit.Element elem = document.get_Element(uniqueId);

    String prompt = "UniqueId of element is: " + uniqueId;
    prompt += "\nUniqueID of elem is: " + elem.UniqueId;
}
CopyVB.NET
Private Sub CheckElementUniqueId(ByVal document As Autodesk.Revit.Document, ByVal element As Autodesk.Revit.Element)
    Dim uniqueId As String = element.UniqueId

    ' Get the element using the UniqueId
    Dim elem As Autodesk.Revit.Element = document.Element(uniqueId)

    Dim prompt As String = "UniqueId of element is: " & uniqueId
    prompt += vbLf & "UniqueID of elem is: " & elem.UniqueId
End Sub

See Also

Element Class
Autodesk.Revit Namespace

ElementArray Class

[image]