Revit 2010 API
WireMaterialType Class
Members See Also Send Feedback
Represents electrical wire material type definition information of wire type.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class WireMaterialType : Element
Visual Basic (Declaration)
Public Class WireMaterialType _
    Inherits Element
Visual C++
public ref class WireMaterialType : public Element

Remarks

All the other properties of wire type are based on wire material type. Only the wire material types which are retrieved from ElectricalSetting can work well, so don't retrieve it from Revit project directly.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.MEP..::.WireMaterialType

See Also

WireMaterialType Members
Autodesk.Revit.MEP Namespace

WireMaterialType Members

[image] [image]