Revit 2010 API
StorageType Enumeration
See Also Send Feedback
An enumerate type listing all of the internal parameter data storage types that Autodesk Revit supports.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum StorageType
Visual Basic (Declaration)
Public Enumeration StorageType
Visual C++
public enum class StorageType

Members

Member name | Description
ElementId | The data type represents an element and is stored as the id of the element.
String | The internal data will be stored in the form of a string of characters.
Integer | The internal data is stored in the form of a signed 32 bit integer.
Double | The data will be stored internaly in the form of an 8 byte floating point number.
None | None represents an invalid storage type. This value should not be used.

See Also

Autodesk.Revit.Parameters Namespace

TypeBinding Class

[image]