Revit 2010 API
FamilyType..::.AsElementId Method
FamilyType Class See Also Send Feedback
Provides access to the ElementId stored in the given family parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementId AsElementId(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function AsElementId ( _
    familyParameter As FamilyParameter _
) As ElementId
Visual C++
public:
ElementId AsElementId(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter

Return Value

The ElementId contained in the parameter.Returns an invalid element id if the storage type of the input argument is ElementId type or this parameter has no value.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,

See Also

FamilyType Class
Autodesk.Revit Namespace

AsInteger Method

[image]