Revit 2010 API
CurtainGrid..::.GetCell Method
CurtainGrid Class See Also Send Feedback
Get the specified cell located by the intersection of the grid lines.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurtainCell GetCell(
    ref ElementId uGridLineId,
    ref ElementId vGridLineId
)
Visual Basic (Declaration)
Public Function GetCell ( _
    ByRef uGridLineId As ElementId, _
    ByRef vGridLineId As ElementId _
) As CurtainCell
Visual C++
public:
CurtainCell^ GetCell(
    ElementId% uGridLineId,
    ElementId% vGridLineId
)

Parameters

uGridLineId
Type: Autodesk.Revit..::.ElementId %
The id of a grid line in the U-direction used to locate the cell.
vGridLineId
Type: Autodesk.Revit..::.ElementId %
The id of a grid line in the V-direction used to locate the cell.

Return Value

The cell.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown if the grid line ids are not part of this curtain grid.

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace

GetPanel Method

[image]