Revit 2010 API
Filter Methods
Filter Class See Also Send Feedback

The Filter type exposes the following members.

Methods

Name | Description
NewCategoryFilter | Overloaded. Creates a new category filter object.
NewFamilyFilter | Creates a FamilyFilter object.
NewInstanceUsageFilter | Creates an InstanceUsageFilter object.
NewLogicAndFilter | Creates a new LogicAndFilter object.
NewLogicNotFilter | Creates a new LogicNotFilter object.
NewLogicOrFilter | Creates a new LogicOrFilter object.
NewMaterialFilter | Creates a MaterialFilter object.
NewParameterFilter | Overloaded. Creates a new parameter filter.
NewStructuralTypeFilter | Creates a StructuralTypeFilter object.
NewSymbolFilter | Creates a SymbolFilter object.
NewTypeFilter | Overloaded. Creates a new TypeFilter object.
NewWallUsageFilter | Creates a new WallUsageFilter object.

See Also

Filter Class
Autodesk.Revit.Creation Namespace

NewCategoryFilter Method

[image] [image]