Revit 2010 API
Control Class
Members See Also Send Feedback
A control in Autodesk Revit family document.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Control : Element
Visual Basic (Declaration)
Public Class Control _
    Inherits Element
Visual C++
public ref class Control : public Element

Remarks

The object represents a variety of different shapes of controls in family document. The different shapes of controls can handle the family instance in different ways.
  • A vertical/horizontal arrow control rotates the instance by 180 degrees.
  • A double vertical arrow control mirrors the instance geometry vertically.
  • A double horizontal arrow control mirrors the instance geometry horizontally.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Control

See Also

Control Members
Autodesk.Revit.Elements Namespace

Control Members

[image] [image]