Revit 2010 API
SelElementSet Class
Members See Also Send Feedback
This class contains the current user selection of elements within the project.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class SelElementSet : ElementSet
Visual Basic (Declaration)
Public Class SelElementSet _
    Inherits ElementSet
Visual C++
public ref class SelElementSet : public ElementSet

Remarks

Because the ModScope is transfered into the constructor, the SelElementSet can be used to Add or Remove element from the selected element set directly.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.ElementSet
Autodesk.Revit..::.SelElementSet

See Also

SelElementSet Members
Autodesk.Revit Namespace

SelElementSet Members

[image] [image]