Revit 2010 API
LogicNotFilter Class
Members See Also Send Feedback
The LogicNotFilter is used to implement Logic-NOT operation of Filters.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LogicNotFilter : Filter
Visual Basic (Declaration)
Public Class LogicNotFilter _
    Inherits Filter
Visual C++
public ref class LogicNotFilter : public Filter

Remarks

This filter represents a combined filter consists of one sub-filter by Logic-NOT relationship, use it to filter elements which don't satisfy the sub-filter.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Filter
Autodesk.Revit..::.LogicNotFilter

See Also

LogicNotFilter Members
Autodesk.Revit Namespace

LogicNotFilter Members

[image] [image]