Revit 2010 API
PulldownButton Class
Members See Also Send Feedback
The RibbonItem object represents an item on RibbonPanel. It can be a push-button or a pull-down that contains the information for creating one RibbonItem.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PulldownButton : RibbonItem
Visual Basic (Declaration)
Public Class PulldownButton _
    Inherits RibbonItem
Visual C++
public ref class PulldownButton : public RibbonItem

Remarks

All the properties and methods are not supported in VSTA.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.RibbonItem
Autodesk.Revit..::.PulldownButton

See Also

PulldownButton Members
Autodesk.Revit Namespace

PulldownButton Members

[image] [image]