Revit 2010 API
Element..::.BoundingBox Property
Element Class Example See Also Send Feedback
Retrieves a box that circumscribes all geometry of the element.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public BoundingBoxXYZ BoundingBox[
    View
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property BoundingBox ( _
     As View _
) As BoundingBoxXYZ
Visual C++
public:
property BoundingBoxXYZ^ BoundingBox[View^ ] {
    BoundingBoxXYZ^ get (View^ );
}

Parameters

Type: Autodesk.Revit.Elements..::.View

Remarks

Pass in a view to query view-specific (e.g., cut) geometry or null for model geometry. If view box is not known, will return model box; if model box is not known, will return null.

Examples

CopyC#
private void GetElementBoundingBox(Autodesk.Revit.Document document, Autodesk.Revit.Element element)
{
    // Get the BoundingBox instance for current view.
    BoundingBoxXYZ box = element.get_BoundingBox(document.ActiveView);
    if (null == box)
    {
        throw new Exception("Selected element doesn't contain a bounding box.");
    }

    string info = "Bounding box is enabled: " + box.Enabled.ToString();

    // Give the user some information.
    MessageBox.Show(info, "Revit");
}
CopyVB.NET
Private Sub GetElementBoundingBox(ByVal document As Autodesk.Revit.Document, ByVal element As Autodesk.Revit.Element)
    ' Get the BoundingBox instance for current view.
    Dim box As BoundingBoxXYZ = element.BoundingBox(document.ActiveView)
    If box Is Nothing Then
        Throw New Exception("Selected element doesn't contain a bounding box.")
    End If

    Dim info As String = "Bounding box is enabled: " & box.Enabled.ToString()

    ' Give the user some information.
    MessageBox.Show(info, "Revit")
End Sub

See Also

Element Class
Autodesk.Revit Namespace

Category Property

[image]