Revit 2010 API
XYZ..::.Distance Method
XYZ Class See Also Send Feedback
Returns the distance from this point to the specified point.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Distance(
    XYZ source
)
Visual Basic (Declaration)
Public Function Distance ( _
    source As XYZ _
) As Double
Visual C++
public:
double Distance(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.XYZ
The specified point.

Return Value

The real number equal to the distance between the two points.

Remarks

The distance between the two points is equal to the length of the vector that joins the two points.

See Also

XYZ Class
Autodesk.Revit.Geometry Namespace

Divide Method

[image]