Revit 2010 API
Application..::.ExtractPartAtomFromFamilyFile Method
Application Class See Also Send Feedback
Writes a PartAtom XML from the contents of a family file.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void ExtractPartAtomFromFamilyFile(
    string familyFilePath,
    string xmlFilePath
)
Visual Basic (Declaration)
Public Sub ExtractPartAtomFromFamilyFile ( _
    familyFilePath As String, _
    xmlFilePath As String _
)
Visual C++
public:
void ExtractPartAtomFromFamilyFile(
    String^ familyFilePath,
    String^ xmlFilePath
)

Parameters

familyFilePath
Type: System..::.String
The family file to be processed.
xmlFilePath
Type: System..::.String
The xml file to be saved.

Remarks

If there is a TXT type catalog next to the family file (a TXT file with the same name as the RFA file), the function will read it as well and process its contents into PartAtom.

Exceptions

Exception | Condition
System..::.ArgumentException | If 'familyFilePath' or 'xmlFilePath' is a null object or an empty string.
System..::.InvalidOperationException | If failed to extract PartAtom from the family file.

See Also

Application Class
Autodesk.Revit Namespace

GetRibbonPanels Method

[image]