Revit 2010 API
DividedSurface..::.GetGridNodeLocation Method
DividedSurface Class See Also Send Feedback
Specify whether a particular grid node is interior to the surface, on the boundary, or outside the boundary.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GridNodeLocation GetGridNodeLocation(
    GridNode gridNode
)
Visual Basic (Declaration)
Public Function GetGridNodeLocation ( _
    gridNode As GridNode _
) As GridNodeLocation
Visual C++
public:
GridNodeLocation GetGridNodeLocation(
    GridNode gridNode
)

Parameters

gridNode
Type: Autodesk.Revit.Elements..::.GridNode

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace

GetGridNodeReference Method

[image]