Revit 2010 API
Document..::.NewSpace Method (Level, Phase, UV)
Document Class See Also Send Feedback
Creates a new space element on the given level, at the given location, and assigned to the given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Space NewSpace(
    Level level,
    Phase phase,
    UV point
)
Visual Basic (Declaration)
Public Function NewSpace ( _
    level As Level, _
    phase As Phase, _
    point As UV _
) As Space
Visual C++
public:
Space^ NewSpace(
    Level^ level,
    Phase^ phase,
    UV^ point
)

Parameters

level
Type: Autodesk.Revit.Elements..::.Level
The level on which the room is to exist.
phase
Type: Autodesk.Revit.Elements..::.Phase
The phase in which the room is to exist.
point
Type: Autodesk.Revit.Geometry..::.UV
A 2D point that dictates the location on that specified level.

Return Value

If successful a new Space element within the project, otherwise null.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when level, phase or point is null.
System..::.InvalidOperationException | Thrown when the space cannot be created.

See Also

Document Class
NewSpace Overload
Autodesk.Revit.Creation Namespace

NewSpaceBoundaryLines Method

[image]