Revit 2010 API
FamilyInstanceCreationData Constructor (Curve, FamilySymbol, Level, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    curve As Curve, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
The curve where the instance is based.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.Elements..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.Structural.Enums..::.StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace

FamilyInstanceCreationData Constructor (Face, XYZ, XYZ, FamilySymbol)

[image]