Revit 2010 API
DialogBoxEventHandler Delegate
See Also Send Feedback
A handler for the event that is fired when a Revit dialog box is displayed during an external API command.

Namespace: Autodesk.Revit.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public delegate void DialogBoxEventHandler(
    DialogBoxData dialogBoxData
)
Visual Basic (Declaration)
Public Delegate Sub DialogBoxEventHandler ( _
    dialogBoxData As DialogBoxData _
)
Visual C++
public delegate void DialogBoxEventHandler(
    DialogBoxData^ dialogBoxData
)

Parameters

dialogBoxData
Type: Autodesk.Revit.Events..::.DialogBoxData
An object that describes the dialog box

See Also

Autodesk.Revit.Events Namespace

DialogBoxShowingEventArgs Class

[image]