Revit 2010 API
FamilyBase Class
Members See Also Send Feedback
A base class for all Family objects.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class FamilyBase : Element
Visual Basic (Declaration)
Public Class FamilyBase _
    Inherits Element
Visual C++
public ref class FamilyBase : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.FamilyBase
Autodesk.Revit.Elements..::.Family

See Also

FamilyBase Members
Autodesk.Revit.Elements Namespace

FamilyBase Members

[image] [image]