Revit 2010 API
Document..::.Close Method (PostedErrorArray)
Document Class See Also Send Feedback
Closes the document with the possibility to ask the user whether or not to save.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Close(
    PostedErrorArray postedErrors
)
Visual Basic (Declaration)
Public Function Close ( _
    postedErrors As PostedErrorArray _
) As Boolean
Visual C++
public:
bool Close(
    PostedErrorArray^ postedErrors
)

Parameters

postedErrors
Type: Autodesk.Revit..::.PostedErrorArray
Would contain list of failures posted during the process.

Return Value

Returns 'false' if either closing procedure fails or if saving of a modified document failed. Also returns 'false' if closing is cancelled by an external application during 'DocumentClosing' event. When function succeeds, 'true' is returned.

Remarks

This function can not be called on the active document.

If the document is modified, the user will be asked if the document should be saved.

The 'postedErrors' parameter is used only when running Revit in UI-less mode.

See Also

Document Class
Close Overload
Autodesk.Revit Namespace

Close Method (Boolean)

[image]