Revit 2010 API
ItemFactoryBase..::.NewViewSection Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new section view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ViewSection NewViewSection(
    BoundingBoxXYZ box
)
Visual Basic (Declaration)
Public Function NewViewSection ( _
    box As BoundingBoxXYZ _
) As ViewSection
Visual C++
public:
ViewSection^ NewViewSection(
    BoundingBoxXYZ^ box
)

Parameters

box
Type: Autodesk.Revit.Geometry..::.BoundingBoxXYZ
The orientation and bounds of the view. The X direction of the box is right on screen; Y, up; Z, towards the user.

Return Value

The newly created section view.

Examples

CopyC#
// Get a BoundingBoxXYZ instance from revit
BoundingBoxXYZ box = document.ActiveView.CropBox;
if (null == box)
{
    throw new Exception("No BoundingBoxXYZ instance found.");
}

// Create a new view section.
ViewSection viewSection = document.Create.NewViewSection(box);
CopyVB.NET
' Get a BoundingBoxXYZ instance from revit
Dim box As BoundingBoxXYZ = document.ActiveView.CropBox
If box Is Nothing Then
    Throw New Exception("No BoundingBoxXYZ instance found.")
End If

' Create a new view section.
Dim viewSection As ViewSection = document.Create.NewViewSection(box)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace

PlaceGroup Method

[image]