Revit 2010 API
Element..::.PhaseCreated Property
Element Class Example See Also Send Feedback
An object representing the phase when the element is created.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Phase PhaseCreated { get; }
Visual Basic (Declaration)
Public ReadOnly Property PhaseCreated As Phase
Visual C++
public:
property Phase^ PhaseCreated {
    Phase^ get ();
}

Remarks

Elements always have a phase for when they are created.

Examples

CopyC#
void ShowPhaseCreatedName(Element element)
{
    // Get the Phase Create property, and assert it should not be null
    Autodesk.Revit.Elements.Phase phaseCreated = element.PhaseCreated;
    if (null == phaseCreated)
    {
        throw new Exception("Elements always have a phase for when they are created.");
    }
    else
    {
        // Show the Phase Create name to the user.
        String prompt = "The phase created is: " + phaseCreated.Name;
        MessageBox.Show(prompt, "Revit");
    }
}
CopyVB.NET
Private Sub ShowPhaseCreatedName(ByVal element As Autodesk.Revit.Element)
    ' Get the Phase Create property, and assert it should not be null
    Dim phaseCreated As Autodesk.Revit.Elements.Phase = element.PhaseCreated
    If phaseCreated Is Nothing Then
        Throw New Exception("Elements always have a phase for when they are created.")
    Else
        ' Show the Phase Create name to the user.
        Dim prompt As String = "The phase created is: " & phaseCreated.Name
        MessageBox.Show(prompt, "Revit")
    End If
End Sub

See Also

Element Class
Autodesk.Revit Namespace

PhaseDemolished Property

[image]