Revit 2010 API
Element..::.PhaseDemolished Property
Element Class Example See Also Send Feedback
An object representing the phase for when the element is to be demolished.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Phase PhaseDemolished { get; }
Visual Basic (Declaration)
Public ReadOnly Property PhaseDemolished As Phase
Visual C++
public:
property Phase^ PhaseDemolished {
    Phase^ get ();
}

Remarks

The element may not have a demolition phase. If it does not then this property will return nothing.

Examples

CopyC#
void ShowPhaseDemolishedName(Element element)
{
    // Get the Phase Demolished property, and check whether it be null
    Autodesk.Revit.Elements.Phase phaseDemolished = element.PhaseDemolished;
    if (null == phaseDemolished)
    {
        MessageBox.Show("This Element doesn't have Phase Demolished parameter.", "Revit");
    }
    else
    {
        // Show the Phase Demolished name to the user.
        String prompt = "The phase demolished is: " + phaseDemolished.Name;
        MessageBox.Show(prompt, "Revit");
    }
}
CopyVB.NET
Private Sub ShowPhaseDemolishedName(ByVal element As Autodesk.Revit.Element)
    ' Get the Phase Demolished property, and check whether it be null
    Dim phaseDemolished As Autodesk.Revit.Elements.Phase = element.PhaseDemolished
    If phaseDemolished Is Nothing Then
        MessageBox.Show("This Element doesn't have Phase Demolished parameter.", "Revit")
    Else
        ' Show the Phase Demolished name to the user.
        Dim prompt As String = "The phase demolished is: " & phaseDemolished.Name
        MessageBox.Show(prompt, "Revit")
    End If
End Sub

See Also

Element Class
Autodesk.Revit Namespace

Pinned Property

[image]