Revit 2010 API
PulldownButton..::.AddPushButton Method
PulldownButton Class See Also Send Feedback
Adds a new pushbutton to the pulldown button and associates it with an ExternalCommand.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PushButton AddPushButton(
    PushButtonData buttonData
)
Visual Basic (Declaration)
Public Function AddPushButton ( _
    buttonData As PushButtonData _
) As PushButton
Visual C++
public:
PushButton^ AddPushButton(
    PushButtonData^ buttonData
)

Parameters

buttonData
Type: Autodesk.Revit..::.PushButtonData
An object containing the data needed to construct the pushbutton.

Return Value

The newly added pushbutton.

Remarks

The new button will display its large image if PushButton.LargeImage is set.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when buttonData is null.
System..::.ArgumentException | Thrown when buttonData.Name and buttonData.Text are not identical.

See Also

PulldownButton Class
Autodesk.Revit Namespace

PulldownButton Properties

[image] [image]