Revit 2010 API
HermiteFace Class
Members Example See Also Send Feedback
A cubic hermite spline face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class HermiteFace : Face
Visual Basic (Declaration)
Public Class HermiteFace _
    Inherits Face
Visual C++
public ref class HermiteFace : public Face

Remarks

Hermite faces are defined by cubic hermite spline surfaces bounded by edge loops. The surfaces provide natural UV parametrization to the faces.

Examples

CopyC#
private void GetHermiteFaceInfo(Face face)
{
    HermiteFace hermiteFace = face as HermiteFace;
    if (null != hermiteFace)
    {
        XYZArray points = hermiteFace.Points;
        XYZArray derivs = hermiteFace.MixedDerivs;
        DoubleArray faceParams = hermiteFace.get_Params(0);
        XYZArray tangents = hermiteFace.get_Tangents(0);
    }
}
CopyVB.NET
Private Sub GetHermiteFaceInfo(ByVal face As Autodesk.Revit.Geometry.Face)
    Dim hermiteFace As HermiteFace = TryCast(face, HermiteFace)
    If hermiteFace IsNot Nothing Then
        Dim points As XYZArray = hermiteFace.Points
        Dim derivs As XYZArray = hermiteFace.MixedDerivs
        Dim faceParams As DoubleArray = hermiteFace.Params(0)
        Dim tangents As XYZArray = hermiteFace.Tangents(0)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Face
Autodesk.Revit.Geometry..::.HermiteFace

See Also

HermiteFace Members
Autodesk.Revit.Geometry Namespace

HermiteFace Members

[image] [image]