Revit 2010 API
ElementBinding Class
Members See Also Send Feedback
A base class for all types of binding that attach to an element.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public abstract class ElementBinding : Binding
Visual Basic (Declaration)
Public MustInherit Class ElementBinding _
    Inherits Binding
Visual C++
public ref class ElementBinding abstract : public Binding

Remarks

This base class provides methods that are common to all types of binding that work with elements.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.Binding
Autodesk.Revit.Parameters..::.ElementBinding
Autodesk.Revit.Parameters..::.InstanceBinding
Autodesk.Revit.Parameters..::.TypeBinding

See Also

ElementBinding Members
Autodesk.Revit.Parameters Namespace

ElementBinding Members

[image] [image]