Revit 2010 API
Document..::.Delete Method (ElementSet)
Document Class Example See Also Send Feedback
Deletes several elements from the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementIdSet Delete(
    ElementSet elements
)
Visual Basic (Declaration)
Public Function Delete ( _
    elements As ElementSet _
) As ElementIdSet
Visual C++
public:
ElementIdSet^ Delete(
    ElementSet^ elements
)

Parameters

elements
Type: Autodesk.Revit..::.ElementSet
A set of elements that are to be deleted.

Remarks

This method will delete the elements and any other elements that are totally dependent upon those elements. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

Examples

CopyC#
// Delete all the selected elements via the set of elements
ElementSet elementSet = document.Selection.Elements;
ElementIdSet deletedIdSet = document.Delete(elementSet);

if (0 == deletedIdSet.Size)
{
    throw new Exception("Deleting the selected elements in revit failed.");
}

MessageBox.Show("The selected element has been removed.", "Revit");
CopyVB.NET
' Delete all the selected elements via the set of elements
Dim elementSet As ElementSet = document.Selection.Elements
Dim deletedIdSet As ElementIdSet = document.Delete(elementSet)

If 0 = deletedIdSet.Size Then
    Throw New Exception("Deleting the selected elements in revit failed.")
End If

MessageBox.Show("The selected element has been removed.", "Revit")

See Also

Document Class
Delete Overload
Autodesk.Revit Namespace

EditFamily Method

[image]