Revit 2010 API
ElectricalSetting..::.AddWireMaterialType Method
ElectricalSetting Class See Also Send Feedback
Add a new type of wire material.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireMaterialType AddWireMaterialType(
    string name,
    WireMaterialType baseMaterial
)
Visual Basic (Declaration)
Public Function AddWireMaterialType ( _
    name As String, _
    baseMaterial As WireMaterialType _
) As WireMaterialType
Visual C++
public:
WireMaterialType^ AddWireMaterialType(
    String^ name,
    WireMaterialType^ baseMaterial
)

Parameters

name
Type: System..::.String
Name of new material type.
baseMaterial
Type: Autodesk.Revit.MEP..::.WireMaterialType
Specify an existing material type which New material will be constructed based on.

Return Value

New added wire material type object.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace

AddWireType Method

[image]