Revit 2010 API
DividedSurface..::.IsComponentFlipped Property
DividedSurface Class See Also Send Feedback
Whether the pattern is flipped.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsComponentFlipped { get; set; }
Visual Basic (Declaration)
Public Property IsComponentFlipped As Boolean
Visual C++
public:
property bool IsComponentFlipped {
    bool get ();
    void set (bool value);
}

Remarks

This property has no effect unless a pattern is selected (the ObjectType property is not null). Changing this flag effectively reflects the component through its XY-plane, which is equivalent to reflecting it through the original surface.

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace

IsComponentMirrored Property

[image]