Revit 2010 API
Form..::.CanManipulateSubElement Method
Form Class See Also Send Feedback
Tell if a sub element can be deleted/moved/rotated/scaled.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool CanManipulateSubElement(
    Reference subElementReference
)
Visual Basic (Declaration)
Public Function CanManipulateSubElement ( _
    subElementReference As Reference _
) As Boolean
Visual C++
public:
bool CanManipulateSubElement(
    Reference^ subElementReference
)

Parameters

subElementReference
Type: Autodesk.Revit.Geometry..::.Reference
The geometry reference of face/edge/curve/vertex

See Also

Form Class
Autodesk.Revit.Elements Namespace

ConstrainProfiles Method

[image]