Revit 2010 API
Document..::.NewPipe Method (XYZ, XYZ, PipeType)
Document Class See Also Send Feedback
Adds a new pipe into the document, using two points and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Pipe NewPipe(
    XYZ point1,
    XYZ point2,
    PipeType pipeType
)
Visual Basic (Declaration)
Public Function NewPipe ( _
    point1 As XYZ, _
    point2 As XYZ, _
    pipeType As PipeType _
) As Pipe
Visual C++
public:
Pipe^ NewPipe(
    XYZ^ point1,
    XYZ^ point2,
    PipeType^ pipeType
)

Parameters

point1
Type: Autodesk.Revit.Geometry..::.XYZ
The first point of the pipe.
point2
Type: Autodesk.Revit.Geometry..::.XYZ
The second point of the pipe.
pipeType
Type: Autodesk.Revit.MEP..::.PipeType
The type of the pipe.

Return Value

If creation was successful then a new pipe is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument point1 or point2 is null.
System..::.InvalidOperationException | Thrown when the pipe cannot be created or regenerate fails.

See Also

Document Class
NewPipe Overload
Autodesk.Revit.Creation Namespace

NewPipe Method (XYZ, Connector, PipeType)

[image]