Revit 2010 API
Application..::.DocumentSavingAs Event
Application Class See Also Send Feedback
Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentSavingAsEventArgs> DocumentSavingAs
Visual Basic (Declaration)
Public Event DocumentSavingAs As EventHandler(Of DocumentSavingAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingAsEventArgs^>^ DocumentSavingAs {
    void add (EventHandler<DocumentSavingAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingAsEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document with a new file name. Note that the first save of a newly created document will raise DocumentSavingAs rather than DocumentSaving event.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to 'true' to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSavedAs will be raised immediately after the document has been saved with a new file name.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace

DocumentSynchronizedWithCentral Event

[image]