Revit 2010 API
UV..::.Angle Method
UV Class See Also Send Feedback
Returns the angle between this vector and the specified vector.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Angle(
    UV source
)
Visual Basic (Declaration)
Public Function Angle ( _
    source As UV _
) As Double
Visual C++
public:
double Angle(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.Geometry..::.UV
The specified vector.

Return Value

The real number between 0 and 2*PI equal to the angle between the two vectors.

Remarks

The angle is measured counterclockwise.

See Also

UV Class
Autodesk.Revit.Geometry Namespace

Cross Method

[image]