Revit 2010 API
Connector..::.AssignedDuctFlowConfiguration Property
Connector Class See Also Send Feedback
The assigned duct flow configuration of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DuctFlowConfigurationType AssignedDuctFlowConfiguration { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedDuctFlowConfiguration As DuctFlowConfigurationType
Visual C++
public:
property DuctFlowConfigurationType AssignedDuctFlowConfiguration {
    DuctFlowConfigurationType get ();
}

Remarks

Assigned duct flow configuration may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::DuctConnector.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainHvac. Thrown when the connector is not in a family instance.
System..::.InvalidOperationException | Thrown on failure to get duct flow configuration.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

AssignedDuctLossMethod Property

[image]