Revit 2010 API
View..::.Elements Property
View Class Example See Also Send Feedback
Set of all elements that will be drawn in the view.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet Elements { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements As ElementSet
Visual C++
public:
property ElementSet^ Elements {
    ElementSet^ get ();
}

Remarks

Elements that belong to this set have graphics that may be visible in this view. Some elements may still be hidden because they are obscured by other elements.

Examples

CopyC#
private void CountElements(Autodesk.Revit.Document document)
{
    // Count the number of elements in the document
    int count = 0;
    ElementIterator iter = document.Elements;
    iter.Reset();
    while (iter.MoveNext())
    {
        Autodesk.Revit.Element elem = iter.Current as Autodesk.Revit.Element;
        if (null != elem)
        {
            ++count;
        }
    }
    StringBuilder message = new StringBuilder();
    message.AppendLine("Elements within Document: " + count.ToString());
    message.AppendLine("Elements within active View: "
       + document.ActiveView.Elements.Size.ToString());

    MessageBox.Show(message.ToString());
}
CopyVB.NET
Private Sub CountElements(ByVal document As Autodesk.Revit.Document)
    ' Count the number of elements in the document
    Dim count As Integer = 0
    Dim iter As ElementIterator = document.Elements
    iter.Reset()
    While iter.MoveNext()
        Dim elem As Autodesk.Revit.Element = TryCast(iter.Current, Autodesk.Revit.Element)
        If elem IsNot Nothing Then
            count += 1
        End If
    End While
    Dim message As New StringBuilder()
    message.AppendLine("Elements within Document: " & count.ToString())
    message.AppendLine("Elements within active View: " & document.ActiveView.Elements.Size.ToString())

    MessageBox.Show(message.ToString())
End Sub

See Also

View Class
Autodesk.Revit.Elements Namespace

GenLevel Property

[image]