Revit 2010 API
ControlledApplication Properties
ControlledApplication Class See Also Send Feedback

The ControlledApplication type exposes the following members.

Properties

Name | Description
Cities | Returns a set of all the known city locations within Revit.
Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
IsQuiescent | Returns if the current application is quiescent.
Language | The language used in the Revit application.
LoadedApplications | Returns an array of successfully loaded external applications.
Options | Provides access to an object that represents the application wide settings available in Autodesk Revit.
Product | The product type for the Revit application.
VersionBuild | Returns the internal build number of the Revit application.
VersionName | Returns the name of the Revit application.
VersionNumber | Return the primary version of the Revit application.

See Also

ControlledApplication Class
Autodesk.Revit Namespace

Cities Property

[image]