Revit 2010 API
FamilyManager..::.MakeInstance Method
FamilyManager Class See Also Send Feedback
Set the family parameter as an instance parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void MakeInstance(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Sub MakeInstance ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void MakeInstance(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.
System..::.InvalidOperationException | Thrown when there is Type family parameter driven by this parameter.

See Also

FamilyManager Class
Autodesk.Revit Namespace

MakeType Method

[image]