Revit 2010 API
Reference..::.ProximityParameter Property
Reference Class See Also Send Feedback
The proximity value to the ray's origin when the reference is returned by Autodesk::Revit::Document::FindReferencesByDirection.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ProximityParameter { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProximityParameter As Double
Visual C++
public:
property double ProximityParameter {
    double get ();
}

Remarks

This value is valid only for References returned from Autodesk::Revit::Document::FindReferencesByDirection. Returns the parameter for the reference relative to the ray input. The value increases the further away the reference is from the origin point for the ray.

See Also

Reference Class
Autodesk.Revit.Geometry Namespace

Transform Property

[image]