Revit 2010 API
Transform..::.BasisX Property
Transform Class See Also Send Feedback
The basis of the X axis of this transformation.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public XYZ BasisX { get; set; }
Visual Basic (Declaration)
Public Property BasisX As XYZ
Visual C++
public:
property XYZ^ BasisX {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The X axis of the old coordinate system in the new coordinate system, or the 1st column of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class
Autodesk.Revit.Geometry Namespace

BasisY Property

[image]