Revit 2010 API
Form..::.MoveProfile Method
Form Class See Also Send Feedback
Move a profile of the form, specified by a reference, and an offset vector.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void MoveProfile(
    int profileIndex,
    XYZ offset
)
Visual Basic (Declaration)
Public Sub MoveProfile ( _
    profileIndex As Integer, _
    offset As XYZ _
)
Visual C++
public:
void MoveProfile(
    int profileIndex,
    XYZ^ offset
)

Parameters

profileIndex
Type: System..::.Int32
Index to specify the profile.
offset
Type: Autodesk.Revit.Geometry..::.XYZ
The vector by which the element is to be moved.

See Also

Form Class
Autodesk.Revit.Elements Namespace

MoveSubElement Method

[image]