Revit 2010 API
Document..::.NewOpening Method (Wall, XYZ, XYZ)
Document Class See Also Send Feedback
Creates a rectangular opening on a wall.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Opening NewOpening(
    Wall wall,
    XYZ pntStart,
    XYZ pntEnd
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    wall As Wall, _
    pntStart As XYZ, _
    pntEnd As XYZ _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Wall^ wall,
    XYZ^ pntStart,
    XYZ^ pntEnd
)

Parameters

wall
Type: Autodesk.Revit.Elements..::.Wall
Host element of the opening.
pntStart
Type: Autodesk.Revit.Geometry..::.XYZ
One corner of the rectangle.
pntEnd
Type: Autodesk.Revit.Geometry..::.XYZ
The opposite corner of the rectangle.

Return Value

If successful, an Opening object is returned.

See Also

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace

NewPathReinforcement Method

[image]