Revit 2010 API
Document..::.NewSpaceTag Method
Document Class See Also Send Feedback
Creates a new SpaceTag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpaceTag NewSpaceTag(
    Space space,
    UV point,
    View view
)
Visual Basic (Declaration)
Public Function NewSpaceTag ( _
    space As Space, _
    point As UV, _
    view As View _
) As SpaceTag
Visual C++
public:
SpaceTag^ NewSpaceTag(
    Space^ space,
    UV^ point,
    View^ view
)

Parameters

space
Type: Autodesk.Revit.Elements..::.Space
The Space which the tag refers.
point
Type: Autodesk.Revit.Geometry..::.UV
A 2D point that dictates the location on the level of the space.
view
Type: Autodesk.Revit.Elements..::.View
The view where the tag will lie.

Return Value

If successful a SpaceTag object will be returned, otherwise nothing. Suitable exceptions will be fired if the parameters are invalid.

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewSpotCoordinate Method

[image]