Revit 2010 API
Element..::.ObjectType Property
Element Class Example See Also Send Feedback
Returns the instance type of this object.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Symbol ObjectType { get; set; }
Visual Basic (Declaration)
Public Property ObjectType As Symbol
Visual C++
public:
property Symbol^ ObjectType {
    Symbol^ get ();
    void set (Symbol^ value);
}

Remarks

The type of the object returned by this method depends upon the type of this instance, for example - if this object is a wall then a wall type object will be returned. Not all objects have an instance type in which case Nothing is returned.

Examples

CopyC#
void GetStairType(Autodesk.Revit.Document document)
{
    // Create a Filter to get all the stairs in the document
    Autodesk.Revit.Creation.Filter filterCreator = document.Application.Create.Filter;
    // Stairs are type Element, so we don't need to include derived types
    TypeFilter elementOnlyFilter = filterCreator.NewTypeFilter(typeof(Element), false);
    CategoryFilter stairsCategoryfilter = filterCreator.NewCategoryFilter(BuiltInCategory.OST_Stairs);
    Filter stairsFilter = filterCreator.NewLogicAndFilter(elementOnlyFilter, stairsCategoryfilter);

    // Apply the filter to the elements in the active document
    ElementIterator iterator = document.get_Elements(stairsFilter);

    iterator.Reset();
    while (iterator.MoveNext())
    {
        Element stair = iterator.Current as Element;

        if (null == stair.ObjectType)
        {
            MessageBox.Show("No symbol found in stair element: " + stair.Name, "Revit");
        }
        else
        {
            string info = "Stair type is: " + stair.ObjectType.Name;
            MessageBox.Show(info, "Revit");
        }
    }
}
CopyVB.NET
Private Sub GetStairType(ByVal document As Autodesk.Revit.Document)
    ' Create a Filter to get all the stairs in the document
    Dim filterCreator As Autodesk.Revit.Creation.Filter = document.Application.Create.Filter
    ' Stairs are type Element, so we don't need to include derived types
    Dim elementOnlyFilter As TypeFilter = filterCreator.NewTypeFilter(GetType(Autodesk.Revit.Element), False)
    Dim stairsCategoryfilter As CategoryFilter = filterCreator.NewCategoryFilter(BuiltInCategory.OST_Stairs)
    Dim stairsFilter As Filter = filterCreator.NewLogicAndFilter(elementOnlyFilter, stairsCategoryfilter)

    ' Apply the filter to the elements in the active document
    Dim iterator As ElementIterator = document.Elements(stairsFilter)

    iterator.Reset()
    While iterator.MoveNext()
        Dim stair As Autodesk.Revit.Element = TryCast(iterator.Current, Autodesk.Revit.Element)

        If stair.ObjectType Is Nothing Then
            MessageBox.Show("No symbol found in stair element: " & stair.Name, "Revit")
        Else
            Dim info As String = "Stair type is: " & stair.ObjectType.Name
            MessageBox.Show(info, "Revit")
        End If
    End While
End Sub

See Also

Element Class
Autodesk.Revit Namespace

Parameter Property

[image] [image]