Revit 2010 API
CategoryFilter Class
Members See Also Send Feedback
Represents a filter to filter elements with specific category.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class CategoryFilter : Filter
Visual Basic (Declaration)
Public Class CategoryFilter _
    Inherits Filter
Visual C++
public ref class CategoryFilter : public Filter

Remarks

The category filter object is used to filter all the elements in the document of which the category is the appointed one.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Filter
Autodesk.Revit..::.CategoryFilter

See Also

CategoryFilter Members
Autodesk.Revit Namespace

CategoryFilter Members

[image] [image]