Revit 2010 API
ConnectorType Enumeration
See Also Send Feedback
An enumerate type listing all the Connector type for the Connection.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ConnectorType
Visual Basic (Declaration)
Public Enumeration ConnectorType
Visual C++
public enum class ConnectorType

Members

Member name | Description
AllConnectorModes | Connection Type is All Connector Modes.
NonEndConn | Connection Type is Non End Connection.
PhysicalConn | Connection Type is Physical Connection.
LogicalConn | Connection Type is Logical Connection.
CurveConn | Connection Type is Curve Connection.
EndConn | Connection Type is End Connection.
InvalidConnectorType | Connection Type is Invalid.

See Also

Autodesk.Revit.MEP.Enums Namespace

Domain Enumeration

[image]