Revit 2010 API
AnalyticalModelProfile Members
AnalyticalModelProfile Class Constructors Methods Properties See Also Send Feedback

The AnalyticalModelProfile type exposes the following members.

Constructors

Name | Description
AnalyticalModelProfile | For Internal Use Only.

Methods

Name | Description

Properties

Name | Description
DrivingCurve | Provides access to the curve that dictates the path of the swept profile.
EndSetBack | Returns the distance from the end of the driving curve that the sweep actually finishes.
StartSetBack | Returns the distance from the start of the driving curve that the sweep actually begins.
SweptProfile | Returns an object that describes the profile that is swept along the driving curve.

See Also

AnalyticalModelProfile Class
Autodesk.Revit.Structural Namespace

AnalyticalModelProfile Constructor

[image]