Revit 2010 API
Form..::.IsProfileEdge Method
Form Class See Also Send Feedback
Tell if an edge or curve is generated from a profile.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsProfileEdge(
    Reference curveOrEdgeReference
)
Visual Basic (Declaration)
Public Function IsProfileEdge ( _
    curveOrEdgeReference As Reference _
) As Boolean
Visual C++
public:
bool IsProfileEdge(
    Reference^ curveOrEdgeReference
)

Parameters

curveOrEdgeReference
Type: Autodesk.Revit.Geometry..::.Reference
The reference of the edge or curve to be checked.

See Also

Form Class
Autodesk.Revit.Elements Namespace

IsReferenceOnlyProfile Method

[image]