Revit 2010 API
MEPCurve Class
Members See Also Send Feedback
A curve object for duct or pipe blend elements.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MEPCurve : HostObject
Visual Basic (Declaration)
Public Class MEPCurve _
    Inherits HostObject
Visual C++
public ref class MEPCurve : public HostObject

Remarks

The curve object is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.MEP..::.MEPCurve
Autodesk.Revit.MEP..::.Duct
Autodesk.Revit.MEP..::.FlexDuct
Autodesk.Revit.MEP..::.FlexPipe
Autodesk.Revit.MEP..::.Pipe

See Also

MEPCurve Members
Autodesk.Revit.MEP Namespace

MEPCurve Members

[image] [image]