Revit 2010 API
PulldownButton..::.AddItem Method
PulldownButton Class See Also Send Feedback
Adds a new pushbutton to the pulldown button and associates it to an ExternalCommand.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PushButton AddItem(
    string text,
    string assembly,
    string className
)
Visual Basic (Declaration)
Public Function AddItem ( _
    text As String, _
    assembly As String, _
    className As String _
) As PushButton
Visual C++
public:
PushButton^ AddItem(
    String^ text,
    String^ assembly,
    String^ className
)

Parameters

text
Type: System..::.String
The user-visible text for the new push button.
assembly
Type: System..::.String
The path to the assembly containing the ExternalCommand.
className
Type: System..::.String
The name of the class (implementing IExternalCommand) to execute when the button is pressed.

Return Value

The newly added pushbutton.

Remarks

The new button will display its large image if PushButton.LargeImage is set.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when text, assembly or className is null.
System..::.ArgumentException | Thrown when text, assembly or className is empty, or text contains an invalid character.

See Also

PulldownButton Class
Autodesk.Revit Namespace

AddPushButton Method

[image]