Revit 2010 API
RibbonItem Class
Members See Also Send Feedback
The RibbonItem object represents an item on RibbonPanel, can be a push-button or a pull-down which should contain the information for creating one RibbonItem.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RibbonItem : APIObject
Visual Basic (Declaration)
Public Class RibbonItem _
    Inherits APIObject
Visual C++
public ref class RibbonItem : public APIObject

Remarks

All the properties and methods are not supported in VSTA.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.RibbonItem
Autodesk.Revit..::.PulldownButton
Autodesk.Revit..::.PushButton

See Also

RibbonItem Members
Autodesk.Revit Namespace

RibbonItem Members

[image] [image]