Revit 2010 API
ControlledApplication Methods
ControlledApplication Class See Also Send Feedback

The ControlledApplication type exposes the following members.

Methods

Name | Description
CreateRibbonPanel | Create a new RibbonPanel.
GetRibbonPanels | Get all the custom Panels on Add-Ins tab of Revit.
OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.

See Also

ControlledApplication Class
Autodesk.Revit Namespace

CreateRibbonPanel Method

[image]