Revit 2010 API
Space..::.IsPointInSpace Method
Space Class See Also Send Feedback
Determines if a point lies within the volume of the Space.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool IsPointInSpace(
    XYZ point
)
Visual Basic (Declaration)
Public Function IsPointInSpace ( _
    point As XYZ _
) As Boolean
Visual C++
public:
bool IsPointInSpace(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
Point to be checked.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the point is nullptr.
System..::.ArgumentException | The coordinates of the point is not a number.

See Also

Space Class
Autodesk.Revit.Elements Namespace

Space Properties

[image] [image]