Revit 2010 API
Categories..::.Insert Method
Categories Class See Also Send Feedback
Inserts the specified category with the specified name into the map.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public override bool Insert(
    string key,
    Category item
)
Visual Basic (Declaration)
Public Overrides Function Insert ( _
    key As String, _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Insert(
    String^ key,
    Category^ item
) override

Parameters

key
Type: System..::.String
The name to be used for inserting the category into the map.
item
Type: Autodesk.Revit..::.Category
The category to be inserted into the map.

Return Value

Returns whether the category was inserted into the map.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Always thrown; this list is read only.

See Also

Categories Class
Autodesk.Revit Namespace

NewSubcategory Method

[image]