Revit 2010 API
Dimension..::.Label Property
Dimension Class See Also Send Feedback
The family parameter label of the dimension.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyParameter Label { get; set; }
Visual Basic (Declaration)
Public Property Label As FamilyParameter
Visual C++
public:
property FamilyParameter^ Label {
    FamilyParameter^ get ();
    void set (FamilyParameter^ value);
}

Remarks

A dimension only can be labeled in a family document. Multi-segmented linear dimensions cannot be labeled.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the family parameter is null.
System..::.ArgumentException | Thrown when the family parameter's ParameterType is not suitable for this dimension.
System..::.NotSupportedException | Thrown when dimension can not be labeled.
System..::.InvalidOperationException | Thrown when failed to get the BuiltInParameter DIM_LABEL.

See Also

Dimension Class
Autodesk.Revit.Elements Namespace

Name Property

[image]