Revit 2010 API
Application..::.ApplicationClosing Event
Application Class See Also Send Feedback
Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<ApplicationClosingEventArgs> ApplicationClosing
Visual Basic (Declaration)
Public Event ApplicationClosing As EventHandler(Of ApplicationClosingEventArgs)
Visual C++
public:
 event EventHandler<ApplicationClosingEventArgs^>^ ApplicationClosing {
    void add (EventHandler<ApplicationClosingEventArgs^>^ value);
    void remove (EventHandler<ApplicationClosingEventArgs^>^ value);
}

Remarks

This event is raised when the Revit application is just about to be closed.

Event is not cancellable. The 'Cancellable' property of event’s argument is always 'false'.

No document may be modified at the time of the event.

The sender object of this event is Application object.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace

DialogBoxShowing Event

[image]