Revit 2010 API
Application..::.FileImporting Event
Application Class See Also Send Feedback
Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<FileImportingEventArgs> FileImporting
Visual Basic (Declaration)
Public Event FileImporting As EventHandler(Of FileImportingEventArgs)
Visual C++
public:
 event EventHandler<FileImportingEventArgs^>^ FileImporting {
    void add (EventHandler<FileImportingEventArgs^>^ value);
    void remove (EventHandler<FileImportingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to import a file of format supported by the API.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to 'true'. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event. A transaction is already created at the time of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Import(String, GBXMLImportOptions) and similar overloads.
  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileImported event will be raised immediately after file importing is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace

OnDialogBox Event

[image]