Revit 2010 API
WallType..::.WallKind Enumeration
WallType Class See Also Send Feedback
Describes the fundamental type of wall, such as curtain wall or stacked wall.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum WallKind
Visual Basic (Declaration)
Public Enumeration WallKind
Visual C++
public enum class WallKind

Members

Member name | Description
Stacked | A stacked wall of several wall types.
Curtain | A curtain wall.
Basic | A standard wall.
Unknown | The basic type is not known.

See Also

Autodesk.Revit.Symbols Namespace

WallTypeSet Class

[image]