Revit 2010 API
VoltageType Class
Members See Also Send Feedback
Represents electrical voltage type. An electrical voltage type define a range of voltages, and circuits can be created between components with rated voltages that do not precisely match the voltage definition value.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class VoltageType : Symbol
Visual Basic (Declaration)
Public Class VoltageType _
    Inherits Symbol
Visual C++
public ref class VoltageType : public Symbol

Remarks

Actual, minimum and maximum value of voltage type can retrieved through properties, but only can be modified through SetVoltageValue method. All the unit of voltage properties in this class is volt.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.VoltageType

See Also

VoltageType Members
Autodesk.Revit.MEP Namespace

VoltageType Members

[image] [image]