Revit 2010 API
TemperatureRatingType Members
TemperatureRatingType Class Constructors Methods Properties See Also Send Feedback

The TemperatureRatingType type exposes the following members.

Constructors

Name | Description
TemperatureRatingType | Initializes a new instance of the TemperatureRatingType class

Methods

Name | Description
AddCorrectionFactor | Add a new electrical correction factor type to this temperature rating type.
AddInsulationType | Add a new kind of insulation type into this temperature rating type.
AddWireSize | Add a new kind of wire size type into this temperature rating type.
RemoveCorrectionFactor | Remove an existing correction factor from this temperature rating type in Revit MEP project.
RemoveInsulationType | Remove an existing insulation type from this temperature rating type.
RemoveWireSize | Remove an existing wire size type from this temperature rating type.

Properties

Name | Description
CorrectionFactors | Get all correction factors defined in this temperature rating type and its corresponding material type.
InsulationTypes | Get all insulation types defined in this temperature rating type and its corresponding material type.
IsInUse | Indicate whether the temperature rating type is in use.
MaterialType | Get the material type information which this temperature rating type belongs to.
Name | Get name of temperature rating type. (Overrides Element..::.Name.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
WireSizes | Get all electrical wire sizes defined in this temperature rating type and its corresponding material type.

See Also

TemperatureRatingType Class
Autodesk.Revit.MEP Namespace

TemperatureRatingType Constructor

[image]