Revit 2010 API
FamilyManager..::.RenameCurrentType Method
FamilyManager Class See Also Send Feedback
Rename the current family type.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RenameCurrentType(
    string typeName
)
Visual Basic (Declaration)
Public Sub RenameCurrentType ( _
    typeName As String _
)
Visual C++
public:
void RenameCurrentType(
    String^ typeName
)

Parameters

typeName
Type: System..::.String
The new name of the current family type.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"typeName"-is null.
System..::.ArgumentException | Thrown when the input argument-"typeName"-is already in use.
System..::.InvalidOperationException | Thrown when the famiy type rename failed.

See Also

FamilyManager Class
Autodesk.Revit Namespace

Set Method

[image] [image]