Revit 2010 API
Connector..::.AssignedKCoefficient Property
Connector Class See Also Send Feedback
The assigned kCoefficient of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double AssignedKCoefficient { get; set; }
Visual Basic (Declaration)
Public Property AssignedKCoefficient As Double
Visual C++
public:
property double AssignedKCoefficient {
    double get ();
    void set (double value);
}

Remarks

Assigned kCoefficient may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::PipeConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
System..::.ArgumentException | Thrown when set an invalid value.
System..::.InvalidOperationException | Thrown on failure to get or set kCoefficient.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

AssignedLossCoefficient Property

[image]