Revit 2010 API
ParameterListItem Constructor (String, ElementId)
ParameterListItem Class See Also Send Feedback
Creates object with supplied item string and elementid value.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ParameterListItem(
    string itemStr,
    ElementId itemValue
)
Visual Basic (Declaration)
Public Sub New ( _
    itemStr As String, _
    itemValue As ElementId _
)
Visual C++
public:
ParameterListItem(
    String^ itemStr,
    ElementId itemValue
)

Parameters

itemStr
Type: System..::.String
The item string.
itemValue
Type: Autodesk.Revit..::.ElementId
The item value.

See Also

ParameterListItem Class
ParameterListItem Overload
Autodesk.Revit.Parameters Namespace

ParameterListItem Constructor (String, Double)

[image]