Revit 2010 API
Location Class
Members Example See Also Send Feedback
Provides location functionality for all elements.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Location : APIObject
Visual Basic (Declaration)
Public Class Location _
    Inherits APIObject
Visual C++
public ref class Location : public APIObject

Remarks

The location object provides the ability to translate and rotate elements. More detailed location information and control can be found by using the derivatives of this object, such as LocationPoint or LocationCurve.

Examples

CopyC#
void ShowLocationUsage(Autodesk.Revit.Application application, Wall wall)
{
    // Get the location instance.
    Autodesk.Revit.Location position = wall.Location;

    // Check whether the wall is pinned.
    if (wall.Pinned)
    {
        throw new Exception("The wall has been pinned.");
    }

    // Move the wall location, it provides same fuction as Move method of Document class.
    Autodesk.Revit.Geometry.XYZ direction = new Autodesk.Revit.Geometry.XYZ(10, 0, 0);
    bool result = position.Move(direction);
    if (!result)
    {
        throw new Exception("Move wall location failed.");
    }

    // Rotate the wall location, it provides same fuction as Rotate method of Document class.
    XYZ axisStart = new XYZ(0, 0, 0);
    XYZ axisEnd = new XYZ(0, 0, 1);
    Line axis = application.Create.NewLineUnbound(axisStart, axisEnd);
    result = position.Rotate(axis, 30);
    if (!result)
    {
        throw new Exception("Rotate wall location failed.");
    }
}
CopyVB.NET
Private Sub ShowLocationUsage(ByVal application As Autodesk.Revit.Application, ByVal wall As Wall)
    ' Get the location instance.
    Dim position As Autodesk.Revit.Location = wall.Location

    ' Check whether the wall is pinned.
    If wall.Pinned Then
        Throw New Exception("The wall has been pinned.")
    End If

    ' Move the wall location, it provides same fuction as Move method of Document class.
    Dim direction As New Autodesk.Revit.Geometry.XYZ(10, 0, 0)
    Dim result As Boolean = position.Move(direction)
    If Not result Then
        Throw New Exception("Move wall location failed.")
    End If

    ' Rotate the wall location, it provides same fuction as Rotate method of Document class.
    Dim axisStart As New Autodesk.Revit.Geometry.XYZ(0, 0, 0)
    Dim axisEnd As New Autodesk.Revit.Geometry.XYZ(0, 0, 1)
    Dim axis As Line = application.Create.NewLineUnbound(axisStart, axisEnd)
    result = position.Rotate(axis, 30)
    If Not result Then
        Throw New Exception("Rotate wall location failed.")
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Location
Autodesk.Revit..::.LocationCurve
Autodesk.Revit..::.LocationPoint

See Also

Location Members
Autodesk.Revit Namespace

Location Members

[image] [image]