Revit 2010 API
BeamSystem..::.BeamType Property
BeamSystem Class Example See Also Send Feedback
Retrieve or change the Beam Type of the BeamSystem.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilySymbol BeamType { get; set; }
Visual Basic (Declaration)
Public Property BeamType As FamilySymbol
Visual C++
public:
property FamilySymbol^ BeamType {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Examples

CopyC#
public void GetInfo_BeamType(BeamSystem beamSystem)
{
    string message = "BeamSystem : ";
    // Get BeamSystem type name
    message += "\nBeam type name : " + beamSystem.BeamType.Name;
    // Get BeamSystem type material
    message += "\nBeam type material : " + beamSystem.BeamType.Material;
    // Get BeamSystem family name
    message += "\nBeam family name : " + beamSystem.BeamType.Family.Name;

    // Rename BeamType used by this BeamSystem
    beamSystem.BeamType.Name = "TestBeamTypeName";
    // Rename the Family used by the BeamType that is used by this BeamSystem
    beamSystem.BeamType.Family.Name = "TestBeamTypeFamilyName";

    // Get BeamSystem type name
    message += "\nBeam type name after set : " + beamSystem.BeamType.Name;
    // Get BeamSystem family name
    message += "\nBeam family name after set : " + beamSystem.BeamType.Family.Name;

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK);
}
CopyVB.NET
Public Sub GetInfo_BeamType(ByVal beamSystem As BeamSystem)
    Dim message As String = "BeamSystem : "
    ' Get BeamSystem type name
    message += vbLf & "Beam type name : " & beamSystem.BeamType.Name
    ' Get BeamSystem type material
    message += vbLf & "Beam type material : " & beamSystem.BeamType.Material
    ' Get BeamSystem family name
    message += vbLf & "Beam family name : " & beamSystem.BeamType.Family.Name

    ' Rename BeamType used by this BeamSystem
    beamSystem.BeamType.Name = "TestBeamTypeName"
    ' Rename the Family used by the BeamType that is used by this BeamSystem
    beamSystem.BeamType.Family.Name = "TestBeamTypeFamilyName"

    ' Get BeamSystem type name
    message += vbLf & "Beam type name after set : " & beamSystem.BeamType.Name
    ' Get BeamSystem family name
    message += vbLf & "Beam family name after set : " & beamSystem.BeamType.Family.Name

    MessageBox.Show(message, "Revit", MessageBoxButtons.OK)
End Sub

See Also

BeamSystem Class
Autodesk.Revit.Elements Namespace

Direction Property

[image]