Revit 2010 API
Document..::.NewSpotCoordinate Method
Document Class See Also Send Feedback
Generate a new spot coordinate object within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SpotDimension NewSpotCoordinate(
    View view,
    Reference reference,
    XYZ origin,
    XYZ bend,
    XYZ end,
    XYZ refPt,
    bool hasLeader
)
Visual Basic (Declaration)
Public Function NewSpotCoordinate ( _
    view As View, _
    reference As Reference, _
    origin As XYZ, _
    bend As XYZ, _
    end As XYZ, _
    refPt As XYZ, _
    hasLeader As Boolean _
) As SpotDimension
Visual C++
public:
SpotDimension^ NewSpotCoordinate(
    View^ view,
    Reference^ reference,
    XYZ^ origin,
    XYZ^ bend,
    XYZ^ end,
    XYZ^ refPt,
    bool hasLeader
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The view in which the spot coordinate is to be visible.
reference
Type: Autodesk.Revit.Geometry..::.Reference
The reference to which the spot coordinate is to be bound.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The point which the spot coordinate evaluate.
bend
Type: Autodesk.Revit.Geometry..::.XYZ
The bend point for the spot coordinate.
end
Type: Autodesk.Revit.Geometry..::.XYZ
The end point for the spot coordinate.
refPt
Type: Autodesk.Revit.Geometry..::.XYZ
The actual point on the reference which the spot coordinate evaluate.
hasLeader
Type: System..::.Boolean
Indicate if it has leader or not.

Return Value

If successful a new spot dimension object, otherwise Nothing.

Remarks

If the origin point is not on the reference, it'll be projected to the reference automatically. And the refPt is projected point. If the reference is not valid or the point cannot be projected to reference correctly, an exception will be thrown

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewSpotElevation Method

[image]