Revit 2010 API
Document..::.Move Method (ElementId%, XYZ)
Document Class See Also Send Feedback
Moves an element, specified by id, within the document by a specified vector.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Move(
    ref ElementId id,
    XYZ translationVec
)
Visual Basic (Declaration)
Public Function Move ( _
    ByRef id As ElementId, _
    translationVec As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    ElementId% id,
    XYZ^ translationVec
)

Parameters

id
Type: Autodesk.Revit..::.ElementId %
The ElementId for the element that is to be moved.
translationVec
Type: Autodesk.Revit.Geometry..::.XYZ
The vector by which the element is to be moved.

Return Value

If the element is moved successfully then the method return True, otherwise False.

Remarks

The move method is used to move an element within the project. Other elements may also be moved when this element is moved, for example: if the element is wall and it contains windows, the windows will also be moved.

See Also

Document Class
Move Overload
Autodesk.Revit Namespace

Move Method (ElementIdSet, XYZ)

[image]