Revit 2010 API
Instance..::.SymbolGeometry Property
Instance Class See Also Send Feedback
The geometric representation of the symbol which generates this instance.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element SymbolGeometry { get; }
Visual Basic (Declaration)
Public ReadOnly Property SymbolGeometry As Element
Visual C++
public:
property Element^ SymbolGeometry {
    Element^ get ();
}

Remarks

The geometry will be in the the local coordinate space of the symbol. The context of this instance object (such as effective material) will be applied to the symbol. Note that retrieving the value of this property involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved. The value of this property and the results of the method GetSymbolGeometry(void) are identical.

See Also

Instance Class
Autodesk.Revit.Geometry Namespace

Transform Property

[image]