Revit 2010 API
Duct Class
Members See Also Send Feedback
A duct in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Duct : MEPCurve
Visual Basic (Declaration)
Public Class Duct _
    Inherits MEPCurve
Visual C++
public ref class Duct : public MEPCurve

Remarks

The duct is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.HostObject
Autodesk.Revit.MEP..::.MEPCurve
Autodesk.Revit.MEP..::.Duct

See Also

Duct Members
Autodesk.Revit.MEP Namespace

Duct Members

[image] [image]