Revit 2010 API
Edge Class
Members See Also Send Feedback
An edge of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Edge : GeometryObject
Visual Basic (Declaration)
Public Class Edge _
    Inherits GeometryObject
Visual C++
public ref class Edge : public GeometryObject

Remarks

Edges are defined by intersections of surfaces that form faces of the solid. They have arbitrary parametrization that is normalized to [0,1].

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Edge

See Also

Edge Members
Autodesk.Revit.Geometry Namespace

Edge Members

[image] [image]