Revit 2010 API
ElementIterator..::.MoveNext Method
ElementIterator Class See Also Send Feedback
Move the iterator one element forward.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one element and the Current property will return a valid Element. False will be returned it the iterator has reached the end of the project database.

Implements

IEnumerator..::.MoveNext()()()

See Also

ElementIterator Class
Autodesk.Revit Namespace

Reset Method

[image]