Revit 2010 API
ElectricalSetting..::.AddWireType Method
ElectricalSetting Class See Also Send Feedback
Add a new wire type to project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public WireType AddWireType(
    string name,
    WireMaterialType materialType,
    TemperatureRatingType temperatureRating,
    InsulationType insulation,
    WireSize maxSize,
    double neutralMultiplier,
    bool neutralRequired,
    WireType..::.NeutralMode neutralMode,
    ConduitType conduit
)
Visual Basic (Declaration)
Public Function AddWireType ( _
    name As String, _
    materialType As WireMaterialType, _
    temperatureRating As TemperatureRatingType, _
    insulation As InsulationType, _
    maxSize As WireSize, _
    neutralMultiplier As Double, _
    neutralRequired As Boolean, _
    neutralMode As WireType..::.NeutralMode, _
    conduit As ConduitType _
) As WireType
Visual C++
public:
WireType^ AddWireType(
    String^ name,
    WireMaterialType^ materialType,
    TemperatureRatingType^ temperatureRating,
    InsulationType^ insulation,
    WireSize^ maxSize,
    double neutralMultiplier,
    bool neutralRequired,
    WireType..::.NeutralMode neutralMode,
    ConduitType^ conduit
)

Parameters

name
Type: System..::.String
Name of the new wire type.
materialType
Type: Autodesk.Revit.MEP..::.WireMaterialType
Wire material of new wire type.
temperatureRating
Type: Autodesk.Revit.MEP..::.TemperatureRatingType
Temperature rating type information of new wire type.
insulation
Type: Autodesk.Revit.MEP..::.InsulationType
Insulation of new wire type.
maxSize
Type: Autodesk.Revit.MEP..::.WireSize
Max wire size of new wire type.
neutralMultiplier
Type: System..::.Double
Neutral multiplier of new wire type.
neutralRequired
Type: System..::.Boolean
Specify whether neutral point is required.
neutralMode
Type: Autodesk.Revit.MEP..::.WireType..::.NeutralMode
Specify neutral mode.
conduit
Type: Autodesk.Revit.MEP..::.ConduitType
Conduit type of new wire type.

Return Value

New added wire type object.

Remarks

Param of temperatureRating should be retrieved from param of materialType, and params such as insulation, maxSize should be retrieved from temperatureRating. otherwise, this add operation is most likely to be failed.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace

GetDemandFactor Method

[image]