Revit 2010 API
RoomTag Class
Members Example See Also Send Feedback
Provides access to the room tag in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class RoomTag : Element
Visual Basic (Declaration)
Public Class RoomTag _
    Inherits Element
Visual C++
public ref class RoomTag : public Element

Remarks

The roomTag object can be queried for room information.

Examples

CopyC#
private void Getinfo_RoomTag(RoomTag roomTag)
{
    string message = "Room Tag : ";
    //get the location of the roomtag
    LocationPoint location = roomTag.Location as LocationPoint;
    XYZ point = location.Point;
    message += "\nRoomTag location: (" + point.X + ", " +
                   point.Y + ", " + point.Z + ")";

    //get the name of the roomTag
    message += "\nName: " + roomTag.Name;

    //get the room that the tag is associated with
    Room room = roomTag.Room;
    message += "\nThe number of the room is : " + room.Number;

    //get the view in which the tag is placed
    Autodesk.Revit.Elements.View view = roomTag.View;
    if (null != view)
    {
        message += "\nView Name: " + view.Name;
    }
    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Private Sub Getinfo_RoomTag(ByVal roomTag As Autodesk.Revit.Elements.RoomTag)
    Dim message As String = "Room Tag : "
    'get the location of the roomtag
    Dim location As LocationPoint = TryCast(roomTag.Location, LocationPoint)
    Dim point As Autodesk.Revit.Geometry.XYZ = location.Point
    message += ((vbLf & "RoomTag location: (" & point.X & ", ") + point.Y & ", ") + point.Z & ")"

    'get the name of the roomTag
    message += vbLf & "Name: " & roomTag.Name

    'get the room that the tag is associated with
    Dim room As Room = roomTag.Room
    message += vbLf & "The number of the room is : " & room.Number

    'get the view in which the tag is placed
    Dim view As Autodesk.Revit.Elements.View = roomTag.View
    If view IsNot Nothing Then
        message += vbLf & "View Name: " & view.Name
    End If
    MessageBox.Show(message, "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.RoomTag

See Also

RoomTag Members
Autodesk.Revit.Elements Namespace

RoomTag Members

[image] [image]