Revit 2010 API
NurbSpline..::.SetControlPointsAndWeights Method
NurbSpline Class See Also Send Feedback
Set the control points, weights simultaneously.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetControlPointsAndWeights(
    XYZArray ctrlPoints,
    DoubleArray weights
)
Visual Basic (Declaration)
Public Sub SetControlPointsAndWeights ( _
    ctrlPoints As XYZArray, _
    weights As DoubleArray _
)
Visual C++
public:
void SetControlPointsAndWeights(
    XYZArray^ ctrlPoints,
    DoubleArray^ weights
)

Parameters

ctrlPoints
Type: Autodesk.Revit.Geometry..::.XYZArray
weights
Type: Autodesk.Revit.Geometry..::.DoubleArray

See Also

NurbSpline Class
Autodesk.Revit.Geometry Namespace

NurbSpline Properties

[image] [image]