Revit 2010 API
BarDescription Class
Members See Also Send Feedback
An object that represents an Area Reinforcement within the Autodesk Revit project.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BarDescription : APIObject
Visual Basic (Declaration)
Public Class BarDescription _
    Inherits APIObject
Visual C++
public ref class BarDescription : public APIObject

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Area Reinforcement element is available only in the Autodesk Revit Structure product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Structural..::.BarDescription

See Also

BarDescription Members
Autodesk.Revit.Structural Namespace

BarDescription Members

[image] [image]