Revit 2010 API
Solid Class
Members Example See Also Send Feedback
A 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Solid : GeometryObject
Visual Basic (Declaration)
Public Class Solid _
    Inherits GeometryObject
Visual C++
public ref class Solid : public GeometryObject

Remarks

A solid is defined by the faces and edges that form its boundary.

Examples

CopyC#
private void GetAndTransformSolidInfo(Autodesk.Revit.Application application, Autodesk.Revit.Element element, Options geoOptions)
{
    // Get geometry element of the selected element
    Autodesk.Revit.Geometry.Element geoElement = element.get_Geometry(geoOptions);

    // Get geometry object
    foreach (GeometryObject geoObject in geoElement.Objects)
    {
        // Get the geometry instance which contains the geometry information
        Autodesk.Revit.Geometry.Instance instance = geoObject as Autodesk.Revit.Geometry.Instance;
        if (null != instance)
        {
            foreach (GeometryObject instObj in instance.SymbolGeometry.Objects)
            {
                Solid solid = instObj as Solid;
                if (null == solid || 0 == solid.Faces.Size || 0 == solid.Edges.Size)
                {
                    continue;
                }

                Transform instTransform = instance.Transform;
                // Get the faces and edges from solid, and transform the formed points
                foreach (Face face in solid.Faces)
                {
                    Mesh mesh = face.Triangulate();
                    foreach (XYZ ii in mesh.Vertices)
                    {
                        XYZ point = ii;
                        XYZ transformedPoint = instTransform.OfPoint(point);
                    }
                }
                foreach (Edge edge in solid.Edges)
                {
                    foreach (XYZ ii in edge.Tessellate())
                    {
                        XYZ point = ii;
                        XYZ transformedPoint = instTransform.OfPoint(point);
                    }
                }
            }
        }
    }

}
CopyVB.NET
Private Sub GetAndTransformSolidInfo(ByVal application As Autodesk.Revit.Application, ByVal element As Autodesk.Revit.Element, ByVal geoOptions As Autodesk.Revit.Geometry.Options)
    ' Get geometry element of the selected element
    Dim geoElement As Autodesk.Revit.Geometry.Element = element.Geometry(geoOptions)

    ' Get geometry object
    For Each geoObject As GeometryObject In geoElement.Objects
        ' Get the geometry instance which contains the geometry information
        Dim instance As Autodesk.Revit.Geometry.Instance = TryCast(geoObject, Autodesk.Revit.Geometry.Instance)
        If instance IsNot Nothing Then
            For Each instObj As GeometryObject In instance.SymbolGeometry.Objects
                Dim solid As Solid = TryCast(instObj, Solid)
                If solid Is Nothing OrElse 0 = solid.Faces.Size OrElse 0 = solid.Edges.Size Then
                    Continue For
                End If

                Dim instTransform As Transform = instance.Transform
                ' Get the faces and edges from solid, and transform the formed points
                For Each face As Autodesk.Revit.Geometry.Face In solid.Faces
                    Dim mesh As Mesh = face.Triangulate()
                    For Each ii As Autodesk.Revit.Geometry.XYZ In mesh.Vertices
                        Dim point As Autodesk.Revit.Geometry.XYZ = ii
                        Dim transformedPoint As Autodesk.Revit.Geometry.XYZ = instTransform.OfPoint(point)
                    Next
                Next
                For Each edge As Autodesk.Revit.Geometry.Edge In solid.Edges
                    For Each ii As Autodesk.Revit.Geometry.XYZ In edge.Tessellate()
                        Dim point As Autodesk.Revit.Geometry.XYZ = ii
                        Dim transformedPoint As Autodesk.Revit.Geometry.XYZ = instTransform.OfPoint(point)
                    Next
                Next
            Next
        End If
    Next

End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Solid

See Also

Solid Members
Autodesk.Revit.Geometry Namespace

Solid Members

[image] [image]