Revit 2010 API
ControlledApplication..::.ViewActivated Event
ControlledApplication Class See Also Send Feedback
Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<ViewActivatedEventArgs> ViewActivated
Visual Basic (Declaration)
Public Event ViewActivated As EventHandler(Of ViewActivatedEventArgs)
Visual C++
public:
 event EventHandler<ViewActivatedEventArgs^>^ ViewActivated {
    void add (EventHandler<ViewActivatedEventArgs^>^ value);
    void remove (EventHandler<ViewActivatedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished activating a view of the document. It is raised even when view activating failed or was cancelled (during ViewActivating event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of view activating has already been finished.

The document may not be modified during this event.

Please be aware that the following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

ControlledApplication Class
Autodesk.Revit Namespace

ViewActivating Event

[image]