Revit 2010 API
Categories Members
Categories Class Constructors Methods Properties See Also Send Feedback

The Categories type exposes the following members.

Constructors

Name | Description
Categories | For Internal Use Only.

Methods

Name | Description
Contains | Identifies if a category which has the specified name is in the list of top-level categories. (Overrides CategoryNameMap..::.Contains(String).)
ForwardIterator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMap..::.ForwardIterator()()().)
GetEnumerator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMap..::.GetEnumerator()()().)
Insert | Inserts the specified category with the specified name into the map. (Overrides CategoryNameMap..::.Insert(String, Category).)
NewSubcategory | Add a new subcategory into the Autodesk Revit document.
ReverseIterator | Retrieves a backward moving iterator to the map. (Overrides CategoryNameMap..::.ReverseIterator()()().)

Properties

Name | Description
IsEmpty | Whether or not the list of top-level categories is empty. (Overrides CategoryNameMap..::.IsEmpty.)
Item | Overloaded. Retrieves a category object matching an identifier.
Size | The total number of top-level categories in the document. (Overrides CategoryNameMap..::.Size.)

See Also

Categories Class
Autodesk.Revit Namespace

Categories Constructor

[image]