Revit 2010 API
ElectricalSystemType Enumeration
See Also Send Feedback
An enumerate type listing all the possible Electrical System Types for an Electrical Connector object.

Namespace: Autodesk.Revit.MEP.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ElectricalSystemType
Visual Basic (Declaration)
Public Enumeration ElectricalSystemType
Visual C++
public enum class ElectricalSystemType

Members

Member name | Description
PowerUnBalanced | Electrical System Type is PowerUnBalanced.
PowerBalanced | Electrical System Type is PowerBalanced.
Communication | Electrical System Type is Communication.
NurseCall | Electrical System Type is NurseCall.
FireAlarm | Electrical System Type is FireAlarm.
Security | Electrical System Type is Security.
Telephone | Electrical System Type is Telephone.
PowerCircuit | Electrical System Type is PowerCircuit.
UndefinedSystemType | Unknown system type
Controls | Electrical System Type is Controls.
Data | Electrical System Type is Data.

See Also

Autodesk.Revit.MEP.Enums Namespace

FlowDirectionType Enumeration

[image]