Revit 2010 API
FamilyType..::.AsValueString Method
FamilyType Class See Also Send Feedback
Provides access to value as a string with unit in the given family parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string AsValueString(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function AsValueString ( _
    familyParameter As FamilyParameter _
) As String
Visual C++
public:
String^ AsValueString(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit..::.FamilyParameter

Return Value

The string that represents the parameter value with unit.

Remarks

The method only applies to parameters of value types. If the parameter has no value or does not contain a numeric value, the method returns a null pointer.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is null.
System..::.ArgumentException | Thrown if the input argument-"familyParameter"-is invalid.

See Also

FamilyType Class
Autodesk.Revit Namespace

HasValue Method

[image]