Revit 2010 API
LoadBase Class
Members Example See Also Send Feedback
The LoadBase object is the base class for all load objects within the Autodesk Revit API.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LoadBase : Element
Visual Basic (Declaration)
Public Class LoadBase _
    Inherits Element
Visual C++
public ref class LoadBase : public Element

Remarks

Load objects are only available in Autodesk Revit Structure. This object contains methods that are common to all other load objects.

Examples

CopyC#
private void LoadBaseInformation(LoadBase loadBase)
{
    string message = "LoadBase data for line load: ";
    //Get the name of the load case to which this load belongs
    message += "\nLoad case name: " + loadBase.LoadCaseName;

    //Get the name of the category to which this load belongs
    message += "\nLoad category name: " + loadBase.LoadCategoryName;

    //A string representing the nature of the load
    message += "\nLoad nature name: " + loadBase.LoadNatureName;

    //show the load base information in the messagebox
    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Private Sub LoadBaseInformation(ByVal loadBase As Autodesk.Revit.Elements.LoadBase)
    Dim message As String = "LoadBase data for line load: "
    'Get the name of the load case to which this load belongs
    message += vbLf & "Load case name: " & loadBase.LoadCaseName

    'Get the name of the category to which this load belongs
    message += vbLf & "Load category name: " & loadBase.LoadCategoryName

    'A string representing the nature of the load
    message += vbLf & "Load nature name: " & loadBase.LoadNatureName

    'show the load base information in the messagebox
    MessageBox.Show(message, "Revit")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.LoadBase
Autodesk.Revit.Elements..::.AreaLoad
Autodesk.Revit.Elements..::.LineLoad
Autodesk.Revit.Elements..::.PointLoad

See Also

LoadBase Members
Autodesk.Revit.Elements Namespace

LoadBase Members

[image] [image]