Revit 2010 API
PipeConnector..::.Width Property
PipeConnector Class See Also Send Feedback
The width of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual double Width { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Width As Double
Visual C++
public:
virtual property double Width {
    double get ();
}

Implements

IConnector..::.Width

Remarks

shape for pipe connector is round.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Always thrown because pipe connector's shape is always round.

See Also

PipeConnector Class
Autodesk.Revit.MEP Namespace

PipeMaterialType Class

[image]