Revit 2010 API
MaterialFilter Class
Members See Also Send Feedback
Represents a filter to filter elements with the given material.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class MaterialFilter : Filter
Visual Basic (Declaration)
Public Class MaterialFilter _
    Inherits Filter
Visual C++
public ref class MaterialFilter : public Filter

Remarks

The MaterialFilter object is to filter all the elements with the given material in the active document. Both FamilyInstance and FamilySymbol with the material property will be searched through.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Filter
Autodesk.Revit..::.MaterialFilter

See Also

MaterialFilter Members
Autodesk.Revit Namespace

MaterialFilter Members

[image] [image]