Revit 2010 API
ElectricalSetting..::.RemoveWireMaterialType Method
ElectricalSetting Class See Also Send Feedback
Remove the wire material type from project.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RemoveWireMaterialType(
    WireMaterialType materialType
)
Visual Basic (Declaration)
Public Sub RemoveWireMaterialType ( _
    materialType As WireMaterialType _
)
Visual C++
public:
void RemoveWireMaterialType(
    WireMaterialType^ materialType
)

Parameters

materialType
Type: Autodesk.Revit.MEP..::.WireMaterialType
The wire material type to be removed.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Wire material type can be removed only if it is not currently assigned to any wire type, and the last one wire material type can't be removed, otherwise an exception will be thrown.

See Also

ElectricalSetting Class
Autodesk.Revit.MEP Namespace

RemoveWireType Method

[image]