Revit 2010 API
ApplicationEvents Methods
ApplicationEvents Interface See Also Send Feedback

The ApplicationEvents type exposes the following members.

Methods

Name | Description
OnDialogBox | This event is fired whenever a Revit dialog box is displayed that requires user interaction during an external api command.
OnDocumentClosed | This event is fired after a document is closed.
OnDocumentNewed | This event is fired after a new document is created.
OnDocumentOpened | This event is fired after a document is opened.
OnDocumentSaved | This event is fired after a document is saved.
OnDocumentSavedAs | This event is fired after a document is saved as another file name.

See Also

ApplicationEvents Interface
Autodesk.Revit.Events Namespace

OnDialogBox Method

[image]