Revit 2010 API
UVArray Members
UVArray Class Constructors Methods Properties See Also Send Feedback

The UVArray type exposes the following members.

Constructors

Name | Description
UVArray | Initializes a new instance of the UVArray class

Methods

Name | Description
Append |
Clear | Removes every UV coordinate from the array, rendering it empty.
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
Item | Gets or sets a UV coordinate at a specified index within the array.
Size | Returns the number of UV coordinates that are in the array.

See Also

UVArray Class
Autodesk.Revit.Geometry Namespace

UVArray Constructor

[image]