Revit 2010 API
PlanarFace Class
Members Example See Also Send Feedback
A planar face of a 3d solid.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PlanarFace : Face
Visual Basic (Declaration)
Public Class PlanarFace _
    Inherits Face
Visual C++
public ref class PlanarFace : public Face

Remarks

Planar faces are defined by planes bounded by edge loops. The planes provide natural UV parametrization to the faces. S(u, v) = Origin + u*Vector[0] + v*Vector[1]

Examples

CopyC#
private void GetPlanarFaceInfo(Face face)
{
    PlanarFace planarFace = face as PlanarFace;
    if (null != planarFace)
    {
        XYZ origin = planarFace.Origin;
        XYZ normal = planarFace.Normal;
        XYZ vector = planarFace.get_Vector(0);
    }
}
CopyVB.NET
Private Sub GetPlanarFaceInfo(ByVal face As Autodesk.Revit.Geometry.Face)
    Dim planarFace As PlanarFace = TryCast(face, PlanarFace)
    If planarFace IsNot Nothing Then
        Dim origin As Autodesk.Revit.Geometry.XYZ = planarFace.Origin
        Dim normal As Autodesk.Revit.Geometry.XYZ = planarFace.Normal
        Dim vector As Autodesk.Revit.Geometry.XYZ = planarFace.Vector(0)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Face
Autodesk.Revit.Geometry..::.PlanarFace

See Also

PlanarFace Members
Autodesk.Revit.Geometry Namespace

PlanarFace Members

[image] [image]