Revit 2010 API
HostedSweep..::.GetEndPointParameter Method
HostedSweep Class See Also Send Feedback
Retrieve segment's start point or end point parameter.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double GetEndPointParameter(
    Reference targetRef,
    int endIdx
)
Visual Basic (Declaration)
Public Function GetEndPointParameter ( _
    targetRef As Reference, _
    endIdx As Integer _
) As Double
Visual C++
public:
double GetEndPointParameter(
    Reference^ targetRef,
    int endIdx
)

Parameters

targetRef
Type: Autodesk.Revit.Geometry..::.Reference
Segment's reference whose parameter want to be get.
endIdx
Type: System..::.Int32
Start point (=0) or end point (=1).

Return Value

Start point or end point parameter.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class
Autodesk.Revit.Elements Namespace

HorizontalFlip Method

[image]