Revit 2010 API
Connector..::.Demand Property
Connector Class See Also Send Feedback
The demand of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double Demand { get; }
Visual Basic (Declaration)
Public ReadOnly Property Demand As Double
Visual C++
public:
property double Demand {
    double get ();
}

Remarks

Instantaneous demand at this connector, calculated according to system.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainPiping.
System..::.InvalidOperationException | Thrown on failure to get demand.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

Direction Property

[image]