Revit 2010 API
Room Class
Members Example See Also Send Feedback
Provides access to the room topology in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Room : Element
Visual Basic (Declaration)
Public Class Room _
    Inherits Element
Visual C++
public ref class Room : public Element

Remarks

The room object can be queried for its boundary for use in space planning tools.

Examples

CopyC#
private void Getinfo_Room(Room room)
{
    string message = "Room: ";

    //get the name of the room
    message += "\nRoom Name: " + room.Name;

    //get the room position
    LocationPoint location = room.Location as LocationPoint;
    XYZ point = location.Point;
    message += "\nRoom position: " + XYZToString(point);

    //get the room number
    message += "\nRoom number: " + room.Number;

    //get the boundary segment of the room
    if (null != room.Boundary)  //the room may not be bound
    {
        if (0 != room.Boundary.Size)
        {
            message += "\nBoundarySegment of the room: ";
            foreach (BoundarySegmentArray boundarySegmentArray in room.Boundary)
            {
                foreach (BoundarySegment boundarySegment in boundarySegmentArray)
                {
                    // Get curve start point
                    XYZ start = boundarySegment.Curve.get_EndPoint(0);
                    message += "\nCurve start point: " + XYZToString(start);
                    // Get curve end point
                    XYZ end = boundarySegment.Curve.get_EndPoint(1);
                    message += " Curve end point: " + XYZToString(end);

                    // Show the boundary elements
                    message += "\nBoundary element id: " + boundarySegment.Element.Id.Value;
                }
            }
        }
    }

    MessageBox.Show(message, "Revit");
}

// output the point's three coordinates
string XYZToString(XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
CopyVB.NET
Private Sub Getinfo_Room(ByVal room As Room)
    Dim message As String = "Room: "

    'get the name of the room
    message += vbLf & "Room Name: " & room.Name

    'get the room position
    Dim location As LocationPoint = TryCast(room.Location, LocationPoint)
    Dim point As Autodesk.Revit.Geometry.XYZ = location.Point
    message += vbLf & "Room position: " & XYZToString(point)

    'get the room number
    message += vbLf & "Room number: " & room.Number

    'get the boundary segment of the room
    If room.Boundary IsNot Nothing Then
        'the room may not be bound
        If 0 <> room.Boundary.Size Then
            message += vbLf & "BoundarySegment of the room: "
            For Each boundarySegmentArray As BoundarySegmentArray In room.Boundary
                For Each boundarySegment As BoundarySegment In boundarySegmentArray
                    ' Get curve start point
                    Dim start As Autodesk.Revit.Geometry.XYZ = boundarySegment.Curve.EndPoint(0)
                    message += vbLf & "Curve start point: " & XYZToString(start)
                    ' Get curve end point
                    Dim [end] As Autodesk.Revit.Geometry.XYZ = boundarySegment.Curve.EndPoint(1)
                    message += " Curve end point: " & XYZToString([end])

                    ' Show the boundary elements
                    message += vbLf & "Boundary element id: " & boundarySegment.Element.Id.Value
                Next
            Next
        End If
    End If

    MessageBox.Show(message, "Revit")
End Sub

' output the point's three coordinates
Private Function XYZToString(ByVal point As Autodesk.Revit.Geometry.XYZ) As String
    Return (("(" & point.X & ", ") + point.Y & ", ") + point.Z & ")"
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Room

See Also

Room Members
Autodesk.Revit.Elements Namespace

Room Members

[image] [image]