Revit 2010 API
Element..::.Objects Property
Element Class See Also Send Feedback
All geometric primitives contained in the element.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public GeometryObjectArray Objects { get; }
Visual Basic (Declaration)
Public ReadOnly Property Objects As GeometryObjectArray
Visual C++
public:
property GeometryObjectArray^ Objects {
    GeometryObjectArray^ get ();
}

Remarks

Branching on dynamic type of the objects is advised. Faces and edges are contained in solids and never directly in an element.

See Also

Element Class
Autodesk.Revit.Geometry Namespace

Ellipse Class

[image]