Revit 2010 API
Connector..::.AssignedFlowDirection Property
Connector Class See Also Send Feedback
The assigned flow direction of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlowDirectionType AssignedFlowDirection { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedFlowDirection As FlowDirectionType
Visual C++
public:
property FlowDirectionType AssignedFlowDirection {
    FlowDirectionType get ();
}

Remarks

Flow direction may be assigned for connectors of some familiy instances. For more information, seeAutodesk::Revit::MEP::DuctConnector, Autodesk::Revit::MEP::PipeConnector.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector is not in a family instance. Thrown when the connector's domain is not DomainHvac or DomainPiping.
System..::.InvalidOperationException | Thrown on failure to get assigned flow direction.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

AssignedFlowFactor Property

[image]