Revit 2010 API
Plane Constructor (XYZ, XYZ)
Plane Class See Also Send Feedback
Constructor for geometry plane.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Plane(
    XYZ norm,
    XYZ origin
)
Visual Basic (Declaration)
Public Sub New ( _
    norm As XYZ, _
    origin As XYZ _
)
Visual C++
public:
Plane(
    XYZ^ norm,
    XYZ^ origin
)

Parameters

norm
Type: Autodesk.Revit.Geometry..::.XYZ
The normal vector of the plane.
origin
Type: Autodesk.Revit.Geometry..::.XYZ
The coordinates for the origin.

Remarks

Used to construct a new Plane object.

See Also

Plane Class
Plane Overload
Autodesk.Revit.Geometry Namespace

Plane Constructor (XYZ, XYZ, XYZ)

[image]