Revit 2010 API
UnitSymbolType Enumeration
See Also Send Feedback
An enumerate type listing Display Unit types of the Unit types that Autodesk Revit supports.

Namespace: Autodesk.Revit.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum UnitSymbolType
Visual Basic (Declaration)
Public Enumeration UnitSymbolType
Visual C++
public enum class UnitSymbolType

Members

Member name | Description
UST_SQ_FT_PER_KBTU_PER_H |
UST_SQ_FT_PER_MBH |
UST_SF_PER_KBTU_PER_H |
UST_SF_PER_MBH |
UST_LM_PER_W |
UST_KRONER |
UST_BAHT |
UST_DONG |
UST_SHEQEL |
UST_WON |
UST_CHINESE_HONG_KONG_SAR |
UST_YEN |
UST_POUND |
UST_EURO_PREFIX |
UST_EURO_SUFFIX |
UST_DOLLAR |
UST_SQ_M_PER_KW |
UST_SF_PER_TON |
UST_SQ_FT_PER_TON |
UST_L_PER_S_KW |
UST_CFM_PER_TON |
UST_L_PER_S_CU_M |
UST_CFM_PER_CF |
UST_CFM_PER_CU_FT |
UST_BTU_PER_H_CU_FT |
UST_WATT_PER_CU_M |
UST_WATT_PER_CU_FT |
UST_BTU_PER_H_SQ_FT |
UST_TON |
UST_SLOPE_DEGREE_SYMBOL |
UST_COLON_12 |
UST_COLON_10 |
UST_L_PER_S_SQ_M |
UST_LPS_PER_SQ_M |
UST_CFM_PER_SF |
UST_CFM_PER_SQ_FT |
UST_BTU_PER_H_SQ_FT_DEGREE_F |
UST_WATT_PER_SQ_M_K |
UST_K_N_M_PER_DEGREE_PER_M |
UST_K_N_M_PER_DEGREE |
UST_KIP_FT_PER_DEGREE_PER_FT |
UST_KIP_FT_PER_DEGREE |
UST_KIPS_PER_CU_FT |
UST_KIPS_PER_IN |
UST_INV_DEGREE_C |
UST_INV_DEGREE_F |
UST_KIP_PER_IN_SUP_3 |
UST_LBF_PER_CU_FT |
UST_LB_FORCE_PER_CU_FT |
UST_KN_PER_M_SUP_3 |
UST_KIP_PER_SQ_IN |
UST_KSI |
UST_LBM_PER_FT_H |
UST_LB_PER_FT_H |
UST_CP |
UST_LBM_PER_FT_S |
UST_LB_PER_FT_S |
UST_PA_S |
UST_FPS |
UST_FT_PER_S |
UST_FEET_OF_WATER |
UST_FT_OF_WATER |
UST_FTH2O |
UST_FEET_OF_WATER_PER_100FT |
UST_FT_OF_WATER_PER_100FT |
UST_FTH2O_PER_100FT |
UST_INV_KIP |
UST_INV_K_N |
UST_FT_SUP_3_PER_KIP |
UST_M_SUP_3_PER_K_N |
UST_FT_SUP_2_PER_KIP |
UST_M_SUP_2_PER_K_N |
UST_FT_PER_KIP |
UST_M_PER_K_N |
UST_LBF_DASH_FT_PER_FT |
UST_LB_DASH_FT_PER_FT |
UST_TF_DASH_M_PER_M |
UST_KGF_DASH_M_PER_M |
UST_KIP_DASH_FT_PER_FT |
UST_M_N_DASH_M_PER_M |
UST_K_N_DASH_M_PER_M |
UST_DA_N_DASH_M_PER_M |
UST_N_DASH_M_PER_M |
UST_LBF_DASH_FT |
UST_LB_DASH_FT |
UST_TF_DASH_M |
UST_KGF_DASH_M |
UST_KIP_DASH_FT |
UST_M_N_DASH_M |
UST_K_N_DASH_M |
UST_DA_N_DASH_M |
UST_N_DASH_M |
UST_LBF_PER_SQ_FT |
UST_LB_PER_SQ_FT |
UST_PSF |
UST_TF_PER_M_SUP_2 |
UST_KGF_PER_M_SUP_2 |
UST_KIP_PER_SQ_FT |
UST_KSF |
UST_M_N_PER_M_SUP_2 |
UST_K_N_PER_M_SUP_2 |
UST_DA_N_PER_M_SUP_2 |
UST_N_PER_M_SUP_2 |
UST_LBF_PER_FT |
UST_LB_PER_FT |
UST_TF_PER_M |
UST_KGF_PER_M |
UST_KIP_PER_FT |
UST_M_N_PER_M |
UST_K_N_PER_M |
UST_DA_N_PER_M |
UST_N_PER_M |
UST_LBF |
UST_LB |
UST_TF |
UST_KGF |
UST_KIP |
UST_M_N |
UST_K_N |
UST_DA_N |
UST_N |
UST_HP |
UST_KILOVOLTAMPERE |
UST_VOLTAMPERE |
UST_LM |
UST_CD |
UST_CD_PER_SQ_M |
UST_FTL |
UST_FL_LOWERCASE |
UST_FL |
UST_FTC |
UST_FC |
UST_LX |
UST_CPS |
UST_HZ |
UST_MILLIVOLT |
UST_KILOVOLT |
UST_VOLT |
UST_MILLIAMPERE |
UST_KILOAMPERE |
UST_AMPERE |
UST_USGPH |
UST_GPH |
UST_GAL_PER_H |
UST_USGPM |
UST_GPM |
UST_GAL_PER_MIN |
UST_CMH |
UST_CU_M_PER_H |
UST_CMS |
UST_CU_M_PER_S |
UST_LPS |
UST_L_PER_S |
UST_CFM |
UST_CU_FT_PER_MIN |
UST_CM_PER_MIN |
UST_M_PER_S |
UST_FPM |
UST_FT_PER_MIN |
UST_DEGREE_R |
UST_KELVIN |
UST_DEGREE_C |
UST_DEGREE_F |
UST_BAR |
UST_ATM |
UST_MM_HG |
UST_IN_HG |
UST_LBF_PER_SQ_IN |
UST_PSIA |
UST_PSIG |
UST_LB_PER_SQ_IN |
UST_PSI |
UST_MEGAPASCAL |
UST_KILOPASCAL |
UST_PASCAL |
UST_IN_WG |
UST_WATT_PER_SQ_M |
UST_WATT_PER_SQ_FT |
UST_KCAL_PER_S |
UST_CAL_PER_S |
UST_BTU_PER_H |
UST_BTU_PER_S |
UST_KILOWATT |
UST_WATT |
UST_PASCAL_PER_M |
UST_IN_WG_PER_100FT |
UST_THERM |
UST_KWH |
UST_JOULE |
UST_KCAL |
UST_CAL |
UST_BTU |
UST_LBM_PER_CU_IN |
UST_LB_PER_CU_IN |
UST_LBM_PER_CU_FT |
UST_LB_MASS_PER_CU_FT |
UST_KG_PER_CU_M |
UST_PERCENT_SIGN |
UST_DEGREE_SYMBOL |
UST_GAL |
UST_L |
UST_CY |
UST_MM_CARET_3 |
UST_MM_SUP_3 |
UST_CM_CARET_3 |
UST_CM_SUP_3 |
UST_M_CARET_3 |
UST_M_SUP_3 |
UST_IN_CARET_3 |
UST_IN_SUP_3 |
UST_FT_CARET_3 |
UST_FT_SUP_3 |
UST_CF |
UST_HECTARES |
UST_ACRES |
UST_MM_CARET_2 |
UST_MM_SUP_2 |
UST_CM_CARET_2 |
UST_CM_SUP_2 |
UST_M_CARET_2 |
UST_M_SUP_2 |
UST_IN_CARET_2 |
UST_IN_SUP_2 |
UST_FT_CARET_2 |
UST_FT_SUP_2 |
UST_SF |
UST_MM |
UST_CM |
UST_M |
UST_INCH_DOUBLE_QUOTE |
UST_FOOT_SINGLE_QUOTE |
UST_LF |
UST_NONE |

See Also

Autodesk.Revit.Enums Namespace

UnitType Enumeration

[image]