Revit 2010 API
Document..::.LoadFamily Method (String, Family%)
Document Class Example See Also Send Feedback
Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool LoadFamily(
    string filename,
    out Family family
)
Visual Basic (Declaration)
Public Function LoadFamily ( _
    filename As String, _
    <OutAttribute> ByRef family As Family _
) As Boolean
Visual C++
public:
bool LoadFamily(
    String^ filename,
    [OutAttribute] Family^% family
)

Parameters

filename
Type: System..::.String
The fully qualified filename of the Family file, usually ending in .rfa.
family
Type: Autodesk.Revit.Elements..::.Family %
A reference to the family that was loaded if successful, otherwise Nothing.

Return Value

Returns True if the entire family was loaded successfully into the project, otherwise false.

Remarks

Loading an entire family may take a considerable amount of time and memory. It is recommended that you use LoadFamilySymbol and only load those symbols that you need. The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods.

Examples

CopyC#
// Get the revit library path.
String libraryPath = application.Options.LibraryPaths.get_Item("Imperial Library");
if (String.IsNullOrEmpty(libraryPath))
{
    libraryPath = "c:\\";   // If not have, use a default path.
}

// Allow the user to select a family file.
OpenFileDialog openFileDialog1 = new OpenFileDialog();
openFileDialog1.InitialDirectory = libraryPath;
openFileDialog1.Filter = "Family Files (*.rfa)|*.rfa";

// Load the family file using LoadFamily method and then give information.
if (DialogResult.OK == openFileDialog1.ShowDialog())
{
    Autodesk.Revit.Elements.Family family = null;
    if (document.LoadFamily(openFileDialog1.FileName, out family))
    {
        String name = family.Name;
        MessageBox.Show("Family file has been loaded. Its name is " + name, "Revit");
    }
    else
    {
        MessageBox.Show("Can't load the family file.", "Revit");
    }
}
CopyVB.NET
' Get the revit library path.
Dim libraryPath As String = application.Options.LibraryPaths.Item("Imperial Library")
If [String].IsNullOrEmpty(libraryPath) Then
    libraryPath = "c:\"
    ' If not have, use a default path.
End If

' Allow the user to select a family file.
Dim openFileDialog1 As New OpenFileDialog()
openFileDialog1.InitialDirectory = libraryPath
openFileDialog1.Filter = "Family Files (*.rfa)|*.rfa"

' Load the family file using LoadFamily method and then give information.
If DialogResult.OK = openFileDialog1.ShowDialog() Then
    Dim family As Autodesk.Revit.Elements.Family = Nothing
    If document.LoadFamily(openFileDialog1.FileName, family) Then
        Dim name As String = family.Name
        MessageBox.Show("Family file has been loaded. Its name is " & name, "Revit")
    Else
        MessageBox.Show("Can't load the family file.", "Revit")
    End If
End If

Exceptions

Exception | Condition
System..::.ArgumentNullException | filename is null.

See Also

Document Class
LoadFamily Overload
Autodesk.Revit Namespace

LoadFamilySymbol Method

[image] [image]