Revit 2010 API
Wire Members
Wire Class Constructors Methods Properties See Also Send Feedback

The Wire type exposes the following members.

Constructors

Name | Description
Wire | For Internal Use Only.

Methods

Name | Description

Properties

Name | Description
ConnectorManager | Get connector manager of the wire.
GroundConductorNum | Get of set ground conductor number. Its default value is zero after created.
HotConductorNum | Get or set hot conductor number. Its default value is zero after created.
NeutralConductorNum | Get of set neutral conductor number. Its default value is zero after created.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
WiringType | Get or set wiring type(Arc or chamfer) for the wire.

See Also

Wire Class
Autodesk.Revit.MEP Namespace

Wire Constructor

[image]