Revit 2010 API
Symbol Class
Members See Also Send Feedback
Base class for all Symbols and Types within Autodesk Revit.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Symbol : Element
Visual Basic (Declaration)
Public Class Symbol _
    Inherits Element
Visual C++
public ref class Symbol : public Element

Remarks

Symbols are usually non user visible elements that define instances. For example a wall type is a symbol that is not visible until an instance of the wall is created.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit..::.Symbol
Autodesk.Revit.MEP..::.DemandFactor
Autodesk.Revit.MEP..::.DistributionSysType
Autodesk.Revit.MEP..::.FluidType
Autodesk.Revit.MEP..::.MEPCurveType
Autodesk.Revit.MEP..::.PipeConnectionType
Autodesk.Revit.MEP..::.PipeMaterialType
Autodesk.Revit.MEP..::.PipeScheduleType
Autodesk.Revit.MEP..::.VoltageType
Autodesk.Revit.MEP..::.WireType
Autodesk.Revit.Site..::.SiteLocation
Autodesk.Revit.Symbols..::.AreaReinforcementType
Autodesk.Revit.Symbols..::.BeamSystemType
Autodesk.Revit.Symbols..::.DimensionType
Autodesk.Revit.Symbols..::.GroupType
Autodesk.Revit.Symbols..::.HostObjAttributes
Autodesk.Revit.Symbols..::.InsertableObject
Autodesk.Revit.Symbols..::.LevelType
Autodesk.Revit.Symbols..::.LineAndTextAttrSymbol
Autodesk.Revit.Symbols..::.LoadTypeBase
Autodesk.Revit.Symbols..::.MEPBuildingConstruction
Autodesk.Revit.Symbols..::.ModelTextType
Autodesk.Revit.Symbols..::.PathReinforcementType
Autodesk.Revit.Symbols..::.RebarBarType
Autodesk.Revit.Symbols..::.RebarCoverType
Autodesk.Revit.Symbols..::.RebarHookType
Autodesk.Revit.Symbols..::.RebarShape
Autodesk.Revit.Symbols..::.TilePattern
Autodesk.Revit.Symbols..::.TrussType

See Also

Symbol Members
Autodesk.Revit Namespace

Symbol Members

[image] [image]