Revit 2010 API
Connector..::.DuctSystemType Property
Connector Class See Also Send Feedback
The duct system type of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DuctSystemType DuctSystemType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DuctSystemType As DuctSystemType
Visual C++
public:
property DuctSystemType DuctSystemType {
    DuctSystemType get ();
}

Remarks

This is the instantaneous system type at this connector, calculated according to system. For unconnected connectors, the system type is undefined.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainHvac.
System..::.InvalidOperationException | Thrown on failure to get duct system type.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

ElectricalSystemType Property

[image]