Revit 2010 API
PointOnFace Class
Members See Also Send Feedback
Define a ReferencePoint relative to a Face.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PointOnFace : PointElementReference
Visual Basic (Declaration)
Public Class PointOnFace _
    Inherits PointElementReference
Visual C++
public ref class PointOnFace : public PointElementReference

Remarks

A ReferencePoint on a Face has its X and Y basis vectors parallel to the Face, but is free to rotate around its Z basis vector. It must lie on the face (unlike PointOnPlane).

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Elements..::.PointElementReference
Autodesk.Revit.Elements..::.PointOnFace

See Also

PointOnFace Members
Autodesk.Revit.Elements Namespace

PointOnFace Members

[image] [image]