Revit 2010 API
Document..::.NewExtrusionRoof Method
Document Class See Also Send Feedback
Creates a new Extrusion Roof.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ExtrusionRoof NewExtrusionRoof(
    CurveArray profile,
    ReferencePlane refPlane,
    Level level,
    RoofType roofType,
    double extrusionStart,
    double extrusionEnd
)
Visual Basic (Declaration)
Public Function NewExtrusionRoof ( _
    profile As CurveArray, _
    refPlane As ReferencePlane, _
    level As Level, _
    roofType As RoofType, _
    extrusionStart As Double, _
    extrusionEnd As Double _
) As ExtrusionRoof
Visual C++
public:
ExtrusionRoof^ NewExtrusionRoof(
    CurveArray^ profile,
    ReferencePlane^ refPlane,
    Level^ level,
    RoofType^ roofType,
    double extrusionStart,
    double extrusionEnd
)

Parameters

profile
Type: Autodesk.Revit.Geometry..::.CurveArray
The profile of the extrusion roof.
refPlane
Type: Autodesk.Revit.Elements..::.ReferencePlane
The work plane for the extrusion roof.
level
Type: Autodesk.Revit.Elements..::.Level
The level of the extrusion roof.
roofType
Type: Autodesk.Revit.Symbols..::.RoofType
Type of the extrusion roof.
extrusionStart
Type: System..::.Double
Start the extrusion.
extrusionEnd
Type: System..::.Double
End the extrusion.

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewFamilyInstance Method

[image] [image]