Revit 2010 API
Document..::.NewDuct Method (XYZ, Connector, DuctType)
Document Class See Also Send Feedback
Adds a new duct into the document, using a point, connector and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Duct NewDuct(
    XYZ point,
    Connector connector,
    DuctType ductType
)
Visual Basic (Declaration)
Public Function NewDuct ( _
    point As XYZ, _
    connector As Connector, _
    ductType As DuctType _
) As Duct
Visual C++
public:
Duct^ NewDuct(
    XYZ^ point,
    Connector^ connector,
    DuctType^ ductType
)

Parameters

point
Type: Autodesk.Revit.Geometry..::.XYZ
The first point of the duct.
connector
Type: Autodesk.Revit.MEP..::.Connector
The connector to be connected to the duct.
ductType
Type: Autodesk.Revit.MEP..::.DuctType
The type of the duct.

Return Value

If creation was successful then a new duct is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connector is a fitting or equipment connector of the correct domain, and if the connector’s direction matches the direction of the duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector if necessary. If the connector's type, domain, or direction does not match the direction of the duct to be created, the position of the input connector will govern the endpoints of the duct, but no connection will be established.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument point or connector is null.
System..::.InvalidOperationException | Thrown when the duct cannot be created or regenerate fails.

See Also

Document Class
NewDuct Overload
Autodesk.Revit.Creation Namespace

NewDuct Method (Connector, Connector, DuctType)

[image]