Revit 2010 API
Document..::.Elements Property (Filter, ElementArray)
Document Class See Also Send Feedback
Collects all elements which satisfy specified filter within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Elements[
    Filter filter,
    ElementArray elementArray
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements ( _
    filter As Filter, _
    elementArray As ElementArray _
) As Integer
Visual C++
public:
property int Elements[Filter^ filter, ElementArray^ elementArray] {
    int get (Filter^ filter, ElementArray^ elementArray);
}

Parameters

filter
Type: Autodesk.Revit..::.Filter
Filter used to determine the elements to add.
elementArray
Type: Autodesk.Revit..::.ElementArray
An array of elements which contains the elements found.

Remarks

The input filter parameter can be one of: TypeFilter, CategoryFilter, FamilyFilter, SymbolFilter, ParameterFilter, InstanceUsageFilter, WallUsageFilter, MaterialFilter or StructuralTypeFilter; This filter can be combination of more than one filters by using logical And and Or filters. If the element array provided already contains elements, new elements added to the element array will be checked against the contents of the element array, and elements already in the input will not be added to the element array again. Because of the overhead required to perform these checks, to obtain the best performance from this property pass an empty element array.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter of filter or elementArray is null.

See Also

Document Class
Elements Overload
Autodesk.Revit Namespace

Elements Property (Filter, ICollection(Element))

[image]