Revit 2010 API
Arc Class
Members See Also Send Feedback
A circular arc.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Arc : Curve
Visual Basic (Declaration)
Public Class Arc _
    Inherits Curve
Visual C++
public ref class Arc : public Curve

Remarks

The arc lies in the plane defined by center and normal.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Curve
Autodesk.Revit.Geometry..::.Arc

See Also

Arc Members
Autodesk.Revit.Geometry Namespace

Arc Members

[image] [image]