Revit 2010 API
Document..::.EndTransaction Method
Document Class See Also Send Feedback
Ends a transaction with an attempt to commit the set of changes.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool EndTransaction()
Visual Basic (Declaration)
Public Function EndTransaction As Boolean
Visual C++
public:
bool EndTransaction()

Return Value

true is returned if the transaction is ended successfully, otherwise false will be returned.

Remarks

The transaction can ensure all the operations between BeginTransaction and EndTransaction can be fulfilled at one time successfully.

See Also

Document Class
EndTransaction Overload
Autodesk.Revit Namespace

EndTransaction Method (PostedErrorArray)

[image]