Revit 2010 API
Filter..::.LogicalNot Operator
Filter Class See Also Send Feedback
Overload operator ! for new Logic-Not filter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public static LogicNotFilter operator !(
    Filter subFilter
)
Visual Basic (Declaration)
Public Shared Operator Not ( _
    subFilter As Filter _
) As LogicNotFilter
Visual C++
public:
static LogicNotFilter^ operator !(
    Filter^ subFilter
)

Parameters

subFilter
Type: Autodesk.Revit..::.Filter
subFilter which is an operand of Logic-NOT operator.

Return Value

Returns a new LogicNotFilter object.

See Also

Filter Class
Autodesk.Revit Namespace

LogicalOr Operator

[image]