Revit 2010 API
SlabShapeEditor..::.DrawPoint Method
SlabShapeEditor Class See Also Send Feedback
Adds a point to the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.Editor
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SlabShapeVertex DrawPoint(
    XYZ location
)
Visual Basic (Declaration)
Public Function DrawPoint ( _
    location As XYZ _
) As SlabShapeVertex
Visual C++
public:
SlabShapeVertex^ DrawPoint(
    XYZ^ location
)

Parameters

location
Type: Autodesk.Revit.Geometry..::.XYZ
The location of the point.

Return Value

The newly created vertex.

Remarks

If the input location is not on the top face of the slab, this function will return null. Drawing a point on boundary crease may increase the number of creases.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the location is nullptr.

See Also

SlabShapeEditor Class
Autodesk.Revit.Editor Namespace

DrawSplitLine Method

[image]