Revit 2010 API
BoundarySegment Class
Members See Also Send Feedback
An object that represents a segment of an area boundary.

Namespace: Autodesk.Revit.Areas
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BoundarySegment : APIObject
Visual Basic (Declaration)
Public Class BoundarySegment _
    Inherits APIObject
Visual C++
public ref class BoundarySegment : public APIObject

Remarks

These objects define the the exterior boundary of an area. The geometry of the segment can be retrieved along with the element that is responsible for producing that boundary.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Areas..::.BoundarySegment

See Also

BoundarySegment Members
Autodesk.Revit.Areas Namespace

BoundarySegment Members

[image] [image]