Revit 2010 API
PhaseArray..::.Insert Method
PhaseArray Class See Also Send Feedback
Insert the specified phase into the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    Phase item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Phase, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Phase^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Elements..::.Phase
The phase to be inserted into the array.
index
Type: System..::.Int32
The phase will be inserted before this index.

Return Value

Returns whether the phase was inserted into the array.

See Also

PhaseArray Class
Autodesk.Revit.Elements Namespace

ReverseIterator Method

[image]