Revit 2010 API
Space Class
Members See Also Send Feedback
Provides access to the space topology in Autodesk Revit.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Space : Element
Visual Basic (Declaration)
Public Class Space _
    Inherits Element
Visual C++
public ref class Space : public Element

Remarks

The space object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Element
Autodesk.Revit.Elements..::.Space

See Also

Space Members
Autodesk.Revit.Elements Namespace

Space Members

[image] [image]