Revit 2010 API
BeamSystemTypeSet Members
BeamSystemTypeSet Class Constructors Methods Properties See Also Send Feedback

The BeamSystemTypeSet type exposes the following members.

Constructors

Name | Description
BeamSystemTypeSet | Initializes a new instance of the BeamSystemTypeSet class

Methods

Name | Description
Clear | Removes every BeamSystem type from the set, rendering it empty.
Contains | Tests for the existence of a BeamSystem type within the set.
Erase | Removes a specified BeamSystem type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
Insert | Insert the specified BeamSystem type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
Size | Returns the number of BeamSystem types that are in the set.

See Also

BeamSystemTypeSet Class
Autodesk.Revit.Symbols Namespace

BeamSystemTypeSet Constructor

[image]