Revit 2010 API
Connector..::.AssignedPipeFlowConfiguration Property
Connector Class See Also Send Feedback
The pipe flow configuration type of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeFlowConfigurationType AssignedPipeFlowConfiguration { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedPipeFlowConfiguration As PipeFlowConfigurationType
Visual C++
public:
property PipeFlowConfigurationType AssignedPipeFlowConfiguration {
    PipeFlowConfigurationType get ();
}

Remarks

Assigned pipe flow configuration may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::PipeConnector.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
System..::.InvalidOperationException | Thrown on failure to get pipe flow configuration.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

AssignedPipeLossMethod Property

[image]