Revit 2010 API
Document..::.Save Method
Document Class See Also Send Feedback
Saves the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Save()
Visual Basic (Declaration)
Public Function Save As Boolean
Visual C++
public:
bool Save()

Return Value

Returns 'false' if save operation fails. Also returns 'false' if saving is cancelled by an external application during 'DocumentSaving' event. When function succeeds, 'true' is returned.

Remarks

The trial version of Revit doesn't support this function. If the user tries to call this function in a trial version, InvalidOperationException will be thrown.

See Also

Document Class
Save Overload
Autodesk.Revit Namespace

Save Method (PostedErrorArray)

[image]