Revit 2010 API
Document..::.DocumentSavedAs Event
Document Class See Also Send Feedback
Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<DocumentSavedAsEventArgs> DocumentSavedAs
Visual Basic (Declaration)
Public Event DocumentSavedAs As EventHandler(Of DocumentSavedAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedAsEventArgs^>^ DocumentSavedAs {
    void add (EventHandler<DocumentSavedAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedAsEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving document with a new file name. This document-level event precedes the application-level event of the same name. Note that the first save of a newly created document will raise DocumentSavedAs rather than DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSavingAs event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

If the action was successful, the document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need for creating another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for current document during this event:

  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Document Class
Autodesk.Revit Namespace

DocumentSaving Event

[image]