Revit 2010 API
RebarShapeDefinitionByArc Members
RebarShapeDefinitionByArc Class Constructors Methods Properties See Also Send Feedback

The RebarShapeDefinitionByArc type exposes the following members.

Constructors

Name | Description
RebarShapeDefinitionByArc | For Internal Use Only.

Methods

Name | Description
AddConstraintArcLength | Specify a parameter to drive the arc length of the shape.
AddConstraintChordLength | Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).
AddConstraintCircumference | Specify a parameter to drive the circumference of the shape.
AddConstraintDiameter | Specify a parameter to drive the diameter of the shape.
AddConstraintRadius | Specify a parameter to drive the radius of the shape.
AddConstraintSagittaLength | Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).

Properties

Name | Description
Type | Among those rebar shapes defined by an arc, specify which kind.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.Symbols Namespace

RebarShapeDefinitionByArc Constructor

[image]