Revit 2010 API
Document..::.ActiveView Property
Document Class Example See Also Send Feedback
The document's active view.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public View ActiveView { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActiveView As View
Visual C++
public:
property View^ ActiveView {
    View^ get ();
}

Field Value

The active view is the view that last had focus in the UI. null if no view is considered active.

Examples

CopyC#
// Get the active view of the current document.
Autodesk.Revit.Elements.View view = document.ActiveView;

// Get the class type of the active view, and format the prompt string
String prompt = "Revit is currently in ";
if (view is Autodesk.Revit.Elements.View3D)
{
    prompt += "3D view.";
}
else if (view is Autodesk.Revit.Elements.ViewSection)
{
    prompt += "section view.";
}
else if (view is Autodesk.Revit.Elements.ViewSheet)
{
    prompt += "sheet view.";
}
else if (view is Autodesk.Revit.Elements.ViewDrafting)
{
    prompt += "drafting view.";
}
else
{
    prompt += "normal view, the view name is " + view.Name;
}

// Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);
CopyVB.NET
' Get the active view of the current document.
Dim view As Autodesk.Revit.Elements.View = document.ActiveView

' Get the class type of the active view, and format the prompt string
Dim prompt As String = "Revit is currently in "
If TypeOf view Is Autodesk.Revit.Elements.View3D Then
    prompt += "3D view."
ElseIf TypeOf view Is Autodesk.Revit.Elements.ViewSection Then
    prompt += "section view."
ElseIf TypeOf view Is Autodesk.Revit.Elements.ViewSheet Then
    prompt += "sheet view."
ElseIf TypeOf view Is Autodesk.Revit.Elements.ViewDrafting Then
    prompt += "drafting view."
Else
    prompt += "normal view, the view name is " & view.Name
End If

' Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)

See Also

Document Class
Autodesk.Revit Namespace

AnnotationSymbolTypes Property

[image]