Revit 2010 API
CurtainGridLine..::.AddSegment Method
CurtainGridLine Class See Also Send Feedback
Add a segment based on the specified segment curve of the gridline.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddSegment(
    Curve curve
)
Visual Basic (Declaration)
Public Sub AddSegment ( _
    curve As Curve _
)
Visual C++
public:
void AddSegment(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
The curve used to locate the segment to be removed.

See Also

CurtainGridLine Class
Autodesk.Revit.Elements Namespace

Move Method

[image]