Revit 2010 API
ParameterStorage..::.AsInteger Method
ParameterStorage Class See Also Send Feedback
Provides access to the integer number within the parameter.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual int AsInteger()
Visual Basic (Declaration)
Public Overridable Function AsInteger As Integer
Visual C++
public:
virtual int AsInteger()

Return Value

The integer value contained in the parameter.

Remarks

The AsInteger method should only be used if the StorageType property returns that the internal contents of the parameter is an integer.

Exceptions

Exception | Condition
InvalidOperationException..::.InvalidOperationException()()() | Thrown when the StorageType is not Integer

See Also

ParameterStorage Class
Autodesk.Revit Namespace

AsString Method

[image]