Revit 2010 API
Autodesk.Revit Namespace

Classes

Class | Description
ACADExportOptions | Export options specific to AutoCAD file formats.
ACADImportOptions | Import options specific to AutoCAD file formats.
APIObject | Supports all objects in the Autodesk Revit API hierarchy.
Application | Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.
BuildingSiteExportOptions | Building Site Export options.
ButtonData | Base class used to contain information necessary to construct a button in the Ribbon.
CADExportOptions | Generic CAD Export options.
CADImportOptions | Generic CAD Import options.
Categories | The Categories object is a map that contains all the top-level Category objects within the Document.
Category | Represents the category or subcategory to which an element belongs.
CategoryFilter | Represents a filter to filter elements with specific category.
CategoryNameMap | A map that contains a mapping of category name to its category object.
CategoryNameMapIterator | An iterator to a category name map.
CategorySet | A set that can contains Category objects.
CategorySetIterator | An iterator to a category set.
Color | Represents a color in Autodesk Revit.
Construction | Construction definition for Project Information.
ControlledApplication | Represents the Autodesk Revit Application with no access to documents. It provides options and other application wide data and settings for external applications OnStartup/OnShutdown.
CurveLoopsProfile | Represents a curve loop based profile for sweep or swept blend elements.
DGNExportOptions | DGN Export options.
DimensionSegment | A segment of a dimension within the Autodesk Revit project.
DimensionSegmentArray | An array that can contain any number of DimensionSegment objects.
DimensionSegmentArrayIterator | An iterator to an array of DimensionSegment objects..
Document | An object that represents an open Autodesk Revit project.
DocumentSet | A set that can contain any documents.
DocumentSetIterator | An iterator to a set of documents.
DWF2DExportOptions | DWF2D Export options.
DWF3DExportOptions | DWF3D Export options.
DWFExportOptions | DWF Export options.
DWFX2DExportOptions | DWFX2D Export options.
DWFX3DExportOptions | DWFX3D Export options.
DWGExportOptions | DWG Export options.
DWGImportOptions | Import options specific to AutoCAD's DWG file formats.
Element | Supports all classes that are persistent within the Autodesk Revit project providing low-level services to derived classes.
ElementArray | An array that contains element objects.
ElementArrayIterator | An iterator to an element array.
ElementIdSet | A set that can contain Element Ids.
ElementIdSetIterator | An iterator to a element id set.
ElementIterator | An iterator object that enable access to every element within the Autodesk Revit project.
ElementSet | A set that contains element objects.
ElementSetIterator | An iterator to an element set.
ExternalApplicationArray | An array that can contain any number of IExternalApplication objects.
ExternalApplicationArrayIterator | An iterator to an array of IExternalApplication objects..
ExternalCommandData | A class contains reference to Application and View which are needed by external command.
FamilyElementVisibility | Provides access to the visibility parameters of family elements in family document.
FamilyFilter | A filter object that used to filter family elements which satisfy specified criterion, filter elements via specifying family name.
FamilyManager | The family manager object to manage the family types and parameters in family document.
FamilyParameter | The family parameter object.
FamilyParameterSet | A set that contains FamilyParameter objects.
FamilyParameterSetIterator | An iterator to a FamilyParameter set.
FamilySymbolProfile | Represents a family symbol based profile for sweep or swept blend elements.
FamilyType | The family type object provides read access to the values of family parameters for this type.
FamilyTypeSet | A set that contains FamilyType objects.
FamilyTypeSetIterator | An iterator to a FamilyType set.
FBXExportOptions | 3D-Studio Max (FBX) Export options.
FillPatternSet | A set that contains FillPatterns.
FillPatternSetIterator | An iterator to a FillPattern set.
Filter | Base class that represents all filters of other sub classes (such as TypeFilter, CategoryFilter, FamilyFilter, SymbolFilter, ParameterFilter, InstanceUsageFilter, WallUsageFilter, MaterialFilter or StructuralTypeFilter), this filter can be used to create single filter or filters combination. User can use overloaded &&, || and ! operators to create combination of filters. e.g. FamilyFilter && SymbolFilter && ParameterFilter, (FamilyFilter1 || FamilyFilter2) && ParameterFilter. Use this filter to retrieve elements which satisfy specified filter criterion within current document.
FilterCriterion | An object that defines the criteria as the filter for retrieving certain needed elements.
FormArray | An array that contains form objects.
FormArrayIterator | An iterator to a form array.
FormatOptions | Contains the Unit information of current user selection of Unit within the project.
GBXMLExportOptions | Green-Building XML Export options.
GBXMLImportOptions | Import options for Green-Building XML format.
GenericImportOptions | Generic Import options.
ImageImportOptions | Import options specific image (bitmap) formats.
InstanceUsageFilter | Represents a filter to filter elements with the given InstanceUsage/StructuralUsage.
InventorImportOptions | Import options for Inventor format.
Leader | An object that represents a Leader within the Autodesk Revit project.
LeaderArray | An array that can contain any number of leaders.
LeaderArrayIterator | An iterator to an array of leaders.
LinePatternSet | A set that can contain any number of line patterns.
LinePatternSetIterator | An iterator to a set.
Location | Provides location functionality for all elements.
LocationCurve | Provides location functionality for all elements that are based upon a curve.
LocationPoint | Provides location functionality for all elements that have a single insertion point.
LogicAndFilter | The LogicAndFilter is used to implement Logic-AND operation of Filters.
LogicNotFilter | The LogicNotFilter is used to implement Logic-NOT operation of Filters.
LogicOrFilter | The LogicOrFilter is used to implement Logic-OR operation of Filters.
MaterialFilter | Represents a filter to filter elements with the given material.
Materials | A set of materials that provides access to the materials in an Autodesk Revit project.
MaterialSet | An set that contains materials.
MaterialSetIterator | An iterator to a material set.
MEPSpaceConstruction | Construction definition for Space.
ObjectFactory | For Internal Use Only.
PaperSize | An object that represents a Paper Size of Print Setup within the Autodesk Revit project.
PaperSizeSet | A set that can contain any number of paper size objects.
PaperSizeSetIterator | An iterator to a set of paper size objects.
PaperSource | An object that represents a Paper Source of Print Setup within the Autodesk Revit project.
PaperSourceSet | A set that can contain any number of paper source objects.
PaperSourceSetIterator | An iterator to a set of paper source objects.
Parameter | The parameter object contains the value data assigned to that parameter.
ParameterFilter | To filter elements with specific parameter criterion.
ParameterMap | A map that can contain a mapping of a parameter name (a String) to a parameter.
ParameterMapIterator | An iterator to a map relating a parameter name (the key, a String) to a parameter.
ParameterSet | A set that contains parameters.
ParameterSetIterator | An iterator to a parameter set.
ParameterStorage | An object that contains details for the value of a parameter. This class is mainly used with the class FilterCriterion to retrieve Elements according to certain criteria.
PlanCircuit | An object that represents an enclosed area in a plan view within the Autodesk Revit project.
PlanCircuitSet | A set that can contain any number of plan circuit objects.
PlanCircuitSetIterator | An iterator to a set of plan circuit objects.
PlanTopology | An object that represents a Plan Topology within the Autodesk Revit project.
PlanTopologySet | A set that can contain any number of plan topology objects.
PlanTopologySetIterator | An iterator to a set of plan topology objects.
PostedError | A class that holds information about a posted error.
PostedErrorArray | An array that can contain any number of posted errors.
PostedErrorArrayIterator | A class that holds an array of posted errors.
PrintManager | The PrintManager object is used to configure the global print settings.
PrintParameters | An object that contains settings used for printing the document.
PrintSetup | Represents the Print Setup (File->Print Setup...) within Autodesk Revit.
PulldownButton | The RibbonItem object represents an item on RibbonPanel. It can be a push-button or a pull-down that contains the information for creating one RibbonItem.
PulldownButtonData | This class contains information necessary to construct a pulldown button in the Ribbon.
PushButton | The RibbonItem object represents an item on a RibbonPanel. It can be a push-button or a pull-down which contains the information for creating one RibbonItem.
PushButtonData | This class contains information necessary to construct a push button in the Ribbon.
RevitUIFamilyLoadOptions | Allows you to use Revit's dialog boxes to let the user respond to questions that arise during loading of families.
RibbonItem | The RibbonItem object represents an item on RibbonPanel, can be a push-button or a pull-down which should contain the information for creating one RibbonItem.
RibbonPanel | The Panel object represents a panel in AddIns tab, which should contains an array of RibbonItems.
Selection | Contains the current user selection of elements within the project.
SelElementSet | This class contains the current user selection of elements within the project.
Settings | The settings object provides access to general components of the Autodesk Revit application, such as Categories.
StructuralTypeFilter | A Filter object that represents StructuralType, used to retrieve family instances whose structural type is specified structural type.
SuspendUpdating | Temporarily delay Revit's automatic updating and consistency operations.
SweepProfile | Represents a profile for sweep or swept blend elements.
Symbol | Base class for all Symbols and Types within Autodesk Revit.
SymbolFilter | A filter object that used to filter symbol elements which satisfy specified criterion, filter elements by specifying symbol name.
TilePatterns | The TilePatterns object is an interface for retrieving the TilePattern objects within the Document.
TrussMemberInfo | Provides access to the information of a truss member in Autodesk Revit.
TypeFilter | Represents a filter to filter elements with the given type.
VertexIndexPair | Represents a connection between vertices in the top and bottom profile of a blend.
VertexIndexPairArray |
VertexIndexPairArrayIterator |
ViewSheetSetting | Represents the View/Sheet Set (File->Print) within Autodesk Revit.
VolumeCalculationOptions | This class provides access to options related to room volume and area computations.
VolumeCalculationSetting | This class provides access to settings related to room volume and area computations.
WallUsageFilter | A Filter object that represents Structural WallUsage, used to retrieve Wall elements whose structural WallUsage is specified WallUsage type.

Structures

Structure | Description
ElementId | The ElementId object is used as a unique identification for an element within a single project.

Interfaces

Interface | Description
IExtension | An interface that supports the additonal operation for Extension Status
IExternalApplication | An interface that when support provides additional applications within Autodesk Revit implemented by external applications.
IExternalCommand | An interface that when support provides additional commands within Autodesk Revit implemented by external applications.
IFamilyLoadOptions | An interface class which provide the callback for family load options.

Enumerations

Enumeration | Description
BuiltInCategory | A list of all the built in categories within Revit.
FamilyElementVisibilityType | Indicates the Visiblity type of generic forms.
FamilySource | Describes which version of the family to be loaded.
IExternalApplication..::.Result | Informs Autodesk Revit of the status of your application after execution.
IExternalCommand..::.Result | Informs Autodesk Revit of the status of your command after execution.
JoinType | The type of join at the end of an element. The join type affects only the graphic treatment, i.e. cleaning of the end, not the physical join behavior.
RibbonItem..::.RibbonItemType | An enumerate type listing all the toolbar item styles.

ACADExportOptions Class

[image]