Revit 2010 API
Connector..::.Direction Property
Connector Class See Also Send Feedback
The direction of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlowDirectionType Direction { get; }
Visual Basic (Declaration)
Public ReadOnly Property Direction As FlowDirectionType
Visual C++
public:
property FlowDirectionType Direction {
    FlowDirectionType get ();
}

Remarks

Instantaneous direction of this connector, calculated according to system.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainHvac or DomainPiping.
System..::.InvalidOperationException | Thrown on failure to get direction.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

Domain Property

[image]