Revit 2010 API
ViewSheetSetting..::.Delete Method
ViewSheetSetting Class See Also Send Feedback
Delete the current view sheet set, and make the In-Session set as the current one.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Delete()
Visual Basic (Declaration)
Public Function Delete As Boolean
Visual C++
public:
bool Delete()

Return Value

Returns false if Delete operation fails, otherwise, returns true.

Remarks

If the current view sheet set is In-Session, an InvalidOperationException will be thrown.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the current view sheet set is In-Session.

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace

Rename Method

[image]