Revit 2010 API
Form..::.RotateProfile Method
Form Class See Also Send Feedback
Rotate a profile of the form, by a specified number of degrees around a given axis.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RotateProfile(
    int profileIndex,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Sub RotateProfile ( _
    profileIndex As Integer, _
    axis As Line, _
    angle As Double _
)
Visual C++
public:
void RotateProfile(
    int profileIndex,
    Line^ axis,
    double angle
)

Parameters

profileIndex
Type: System..::.Int32
Index to specify the profile.
axis
Type: Autodesk.Revit.Geometry..::.Line
An unbounded line that represents the axis of rotation.
angle
Type: System..::.Double
The number of degrees, in radians, by which the element is to be rotated around the specified axis.

See Also

Form Class
Autodesk.Revit.Elements Namespace

RotateSubElement Method

[image]