Revit 2010 API
FamilyItemFactory..::.NewPipeConnector Method
FamilyItemFactory Class See Also Send Feedback
Add a new pipe connector into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public PipeConnector NewPipeConnector(
    Reference planarFaceReference,
    PipeSystemType systemType
)
Visual Basic (Declaration)
Public Function NewPipeConnector ( _
    planarFaceReference As Reference, _
    systemType As PipeSystemType _
) As PipeConnector
Visual C++
public:
PipeConnector^ NewPipeConnector(
    Reference^ planarFaceReference,
    PipeSystemType systemType
)

Parameters

planarFaceReference
Type: Autodesk.Revit.Geometry..::.Reference
A reference to a planar face where the connector will be placed.
systemType
Type: Autodesk.Revit.MEP.Enums..::.PipeSystemType
Indicates the system type of this new Pipe connector.

Return Value

If creation was successful the new pipe connector is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a Pipe Connector in a family document. The pipe connector will be placed at the centroid of the planar face.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when the argument planarFaceReference is invalid.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace

NewRadialDimension Method

[image] [image]