Revit 2010 API
PrintManager..::.SubmitPrint Method (View)
PrintManager Class See Also Send Feedback
Print a view with the current PrintManager settings.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool SubmitPrint(
    View view
)
Visual Basic (Declaration)
Public Function SubmitPrint ( _
    view As View _
) As Boolean
Visual C++
public:
bool SubmitPrint(
    View^ view
)

Parameters

view
Type: Autodesk.Revit.Elements..::.View
The User-assigned view.

Return Value

Returns 'true' if successful, otherwise returns 'false'.

Remarks

PrintManager will apply the local settings to global and print the user-assigned view with the current settings.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when this operation is not allowed in the current application mode, or the print resource is occupied by others.

See Also

PrintManager Class
SubmitPrint Overload
Autodesk.Revit Namespace

PrintManager Properties

[image] [image]