Revit 2010 API
Element..::.Parameter Property (Definition)
Element Class See Also Send Feedback
Retrieves a parameter from the element based on its definition.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Parameter Parameter[
    Definition definition
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    definition As Definition _
) As Parameter
Visual C++
public:
property Parameter^ Parameter[Definition^ definition] {
    Parameter^ get (Definition^ definition);
}

Parameters

definition
Type: Autodesk.Revit.Parameters..::.Definition
The internal or external definition of the parameter.

Remarks

Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. An element can only have one instance of a parameter with a specific definition. By using this method you can retrieve that parameter based on definition.

See Also

Element Class
Parameter Overload
Autodesk.Revit Namespace

Parameter Property (Guid)

[image]