Revit 2010 API
TopographySurface..::.AddPoints Method
TopographySurface Class See Also Send Feedback
Adds new points to a topography surface element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void AddPoints(
    XYZArray points
)
Visual Basic (Declaration)
Public Sub AddPoints ( _
    points As XYZArray _
)
Visual C++
public:
void AddPoints(
    XYZArray^ points
)

Parameters

points
Type: Autodesk.Revit.Geometry..::.XYZArray
An array of points for the topography surface.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the topography surface is invalid or regeneration fails.

See Also

TopographySurface Class
Autodesk.Revit.Elements Namespace

TopographySurface Properties

[image] [image]