Revit 2010 API
Document..::.Elements Property
Document Class Example See Also Send Feedback
Provides access to all elements within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementIterator Elements { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements As ElementIterator
Visual C++
public:
property ElementIterator^ Elements {
    ElementIterator^ get ();
}

Remarks

Returns a forward moving iterator that will traverse the entire Autodesk Revit element database. The Elements property provides an iterator that enables iteration of the entire Revit database of Elements. The iterator supports the standard COM iterator methods and behavior of IEnumerator.

Examples

CopyC#
// Get all the walls in current document.
System.Collections.ArrayList walls = new System.Collections.ArrayList();

ElementIterator iterator = document.Elements;
iterator.Reset();
while (iterator.MoveNext())
{
    if (iterator.Current is Autodesk.Revit.Elements.Wall)
    {
        walls.Add(iterator.Current);
    }
}

// Format the prompt string
String prompt = null;
if (0 == walls.Count)   // if there are not any wall
{
    prompt = "No walls in current document.";
}
else
{
    prompt = "The ids of the walls in the current document are:";
    foreach (Autodesk.Revit.Elements.Wall wall in walls)
    {
        // output the id of the walls
        prompt += "\n\t" + wall.Id.Value;
    }
}

// Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);
CopyVB.NET
' Get all the walls in current document.
Dim walls As New System.Collections.ArrayList()

Dim iterator As ElementIterator = document.Elements
iterator.Reset()
While iterator.MoveNext()
    If TypeOf iterator.Current Is Autodesk.Revit.Elements.Wall Then
        walls.Add(iterator.Current)
    End If
End While

' Format the prompt string
Dim prompt As String = Nothing
If 0 = walls.Count Then
    ' if there are not any wall
    prompt = "No walls in current document."
Else
    prompt = "The ids of the walls in the current document are:"
    For Each wall As Autodesk.Revit.Elements.Wall In walls
        ' output the id of the walls
        prompt += vbLf & vbTab & wall.Id.Value
    Next
End If

' Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)

See Also

Document Class
Elements Overload
Autodesk.Revit Namespace

Elements Property (Filter)

[image]