Revit 2010 API
ConstructionType Enumeration
See Also Send Feedback
An enumerate type listing all of the built-in construction types supported by Autodesk Revit.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ConstructionType
Visual Basic (Declaration)
Public Enumeration ConstructionType
Visual C++
public enum class ConstructionType

Members

Member name | Description
Skylights | Construction Type is Skylights.
InteriorWindows | Construction Type is InteriorWindows.
ExteriorWindows | Construction Type is ExteriorWindows.
Doors | Construction Type is Doors.
Floors | Construction Type is Floors.
Roofs | Construction Type is Roofs.
Slabs | Construction Type is Slabs.
InteriorWalls | Construction Type is InteriorWalls.
ExteriorWalls | Construction Type is ExteriorWalls.

See Also

Autodesk.Revit.Parameters Namespace

Definition Class

[image]