Revit 2010 API
Definitions Class
Members See Also Send Feedback
A base class that supports the addition of new parameter definitions.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Definitions : DefinitionsBase
Visual Basic (Declaration)
Public Class Definitions _
    Inherits DefinitionsBase
Visual C++
public ref class Definitions : public DefinitionsBase

Remarks

There are two derivations of this class, one of which handles external parameters and another which handles internal parameters.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.DefinitionsBase
Autodesk.Revit.Parameters..::.Definitions
Autodesk.Revit.Parameters..::.ExternalDefinitions
Autodesk.Revit.Parameters..::.InternalDefinitions

See Also

Definitions Members
Autodesk.Revit.Parameters Namespace

Definitions Members

[image] [image]