Revit 2010 API
BoundingBoxUV Class
Members Example See Also Send Feedback
A two-dimensional rectangle, parallel to the coordinate axes.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class BoundingBoxUV
Visual Basic (Declaration)
Public Class BoundingBoxUV
Visual C++
public ref class BoundingBoxUV

Examples

CopyC#
Document doc = application.ActiveDocument;
ElementIterator iterator = doc.get_Elements(typeof(Autodesk.Revit.Elements.View));
iterator.Reset();
while (iterator.MoveNext())
{
    Autodesk.Revit.Elements.View view = iterator.Current as Autodesk.Revit.Elements.View;
    if (null != view)
    {
        string messageInfo = "BoundingBoxUV : ";
        messageInfo += "\nView name : " + view.Name;
        BoundingBoxUV boundingBox = view.Outline;
        // Get max bounding box
        UV max = boundingBox.Max;
        messageInfo += "\nMax boundingbox : (" + max.U + "," + max.V + ")";
        // Get min bounding box
        UV min = boundingBox.Min;
        messageInfo += "\nMin boundingbox : (" + min.U + "," + min.V + ")";
        // Get bounds,
        // Use 0 for Min and 1 for Max
        UV bound = boundingBox.get_Bounds(0);
        messageInfo += "\nBoundingbox bounds : (" + bound.U + "," + bound.V + ")";
        MessageBox.Show(messageInfo, "Revit", MessageBoxButtons.OK);
    }
}
CopyVB.NET
Dim doc As Document = application.ActiveDocument
Dim iterator As ElementIterator = doc.Elements(GetType(Autodesk.Revit.Elements.View))
iterator.Reset()
While iterator.MoveNext()
    Dim view As Autodesk.Revit.Elements.View = TryCast(iterator.Current, Autodesk.Revit.Elements.View)
    If view IsNot Nothing Then
        Dim messageInfo As String = "BoundingBoxUV : "
        messageInfo += vbLf & "View name : " & view.Name
        Dim boundingBox As BoundingBoxUV = view.Outline
        ' Get max bounding box
        Dim max As Autodesk.Revit.Geometry.UV = boundingBox.Max
        messageInfo += (vbLf & "Max boundingbox : (" & max.U & ",") + max.V & ")"
        ' Get min bounding box
        Dim min As Autodesk.Revit.Geometry.UV = boundingBox.Min
        messageInfo += (vbLf & "Min boundingbox : (" & min.U & ",") + min.V & ")"
        ' Get bounds,
        ' Use 0 for Min and 1 for Max
        Dim bound As Autodesk.Revit.Geometry.UV = boundingBox.Bounds(0)
        messageInfo += (vbLf & "Boundingbox bounds : (" & bound.U & ",") + bound.V & ")"
        MessageBox.Show(messageInfo, "Revit", MessageBoxButtons.OK)
    End If
End While

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Geometry..::.BoundingBoxUV

See Also

BoundingBoxUV Members
Autodesk.Revit.Geometry Namespace

BoundingBoxUV Members

[image] [image]