Revit 2010 API
Face..::.Intersect Method (Curve)
Face Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve
)
Visual Basic (Declaration)
Public Function Intersect ( _
    curve As Curve _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
The specified curve to intersect with this face.

Return Value

  • SetComparisonResult.Overlap - One or more intersections were encountered.
  • SetComparisonResult.Subset - The curve is coincident with the surface.
  • SetComparisonResult.Disjoint - There is no intersection found.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The curve is null.
System..::.InvalidOperationException | The intersection calculation fails.

See Also

Face Class
Intersect Overload
Autodesk.Revit.Geometry Namespace

Intersect Method (Curve, IntersectionResultArray)

[image]