Revit 2010 API
Location..::.Move Method
Location Class Example See Also Send Feedback
Move the element within the project by a specified vector.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Move(
    XYZ translation
)
Visual Basic (Declaration)
Public Function Move ( _
    translation As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    XYZ^ translation
)

Parameters

translation
Type: Autodesk.Revit.Geometry..::.XYZ
The vector by which the element is to be moved.

Return Value

If the element is moved successfully then the method return True, otherwise False.

Remarks

The move method is used to move an element within the project. Other elements may also be moved when this element is moved, for example: if the element is wall and it contains windows, the windows will also be moved.

Examples

CopyC#
bool MoveUsingLocationCurve(Autodesk.Revit.Application application, Wall wall)
{
    LocationCurve wallLine = wall.Location as LocationCurve;
    XYZ translationVec = new XYZ(10, 20, 0);
    return (wallLine.Move(translationVec));
}
CopyVB.NET
Private Function MoveUsingLocationCurve(ByVal application As Autodesk.Revit.Application, ByVal wall As Wall) As Boolean
    Dim wallLine As LocationCurve = TryCast(wall.Location, LocationCurve)
    Dim translationVec As New Autodesk.Revit.Geometry.XYZ(10, 20, 0)
    Return (wallLine.Move(translationVec))
End Function

See Also

Location Class
Autodesk.Revit Namespace

Rotate Method

[image]