Revit 2010 API
GeometryObject Class
Members See Also Send Feedback
The common base class for all geometric primitives.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class GeometryObject : APIObject
Visual Basic (Declaration)
Public Class GeometryObject _
    Inherits APIObject
Visual C++
public ref class GeometryObject : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Geometry..::.GeometryObject
Autodesk.Revit.Geometry..::.Curve
Autodesk.Revit.Geometry..::.Edge
Autodesk.Revit.Geometry..::.Element
Autodesk.Revit.Geometry..::.Face
Autodesk.Revit.Geometry..::.Instance
Autodesk.Revit.Geometry..::.Mesh
Autodesk.Revit.Geometry..::.Point
Autodesk.Revit.Geometry..::.Profile
Autodesk.Revit.Geometry..::.Solid

See Also

GeometryObject Members
Autodesk.Revit.Geometry Namespace

GeometryObject Members

[image] [image]