Revit 2010 API
Document..::.Export Method (String, String, ViewSet, FBXExportOptions)
Document Class See Also Send Feedback
Exports the document in 3D-Studio Max (FBX) format.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    FBXExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As FBXExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    FBXExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::.String
Either the name of a single file or a prefix for a set of files. If nullptr or empty, automatic naming will be used.
views
Type: Autodesk.Revit.Elements..::.ViewSet
options
Type: Autodesk.Revit..::.FBXExportOptions
Options applicable to the FBX format.

Return Value

Function returns true only if all specified views are exported successfully. The function returns false if exporting of any view fails, even if some views might have been exported successfully.

Remarks

Though the 'options' argument is not currently used, an object still must be provided (may be null).

See Also

Document Class
Export Overload
Autodesk.Revit Namespace

Export Method (String, String, View3D, ViewPlan, BuildingSiteExportOptions)

[image]