Revit 2010 API
RibbonPanel..::.AddStackedButtons Method (ButtonData, ButtonData)
RibbonPanel Class See Also Send Feedback
Adds two stacked buttons to the panel.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public List<RibbonItem> AddStackedButtons(
    ButtonData button1,
    ButtonData button2
)
Visual Basic (Declaration)
Public Function AddStackedButtons ( _
    button1 As ButtonData, _
    button2 As ButtonData _
) As List(Of RibbonItem)
Visual C++
public:
List<RibbonItem^>^ AddStackedButtons(
    ButtonData^ button1,
    ButtonData^ button2
)

Parameters

button1
Type: Autodesk.Revit..::.ButtonData
Data containing information about the first button.
button2
Type: Autodesk.Revit..::.ButtonData
Data containing information about the second button.

Return Value

A collection containing the added buttons.

Remarks

Each new button will either be a PushButton or PulldownButton, depending upon the type of data passed in for each argument. The new buttons will be created as small-size horizontal buttons, with the first stacked on top of the second in the panel.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when button1 or button2 is null.

See Also

RibbonPanel Class
AddStackedButtons Overload
Autodesk.Revit Namespace

AddStackedButtons Method (ButtonData, ButtonData, ButtonData)

[image]