Revit 2010 API
FamilyBase..::.FamilyCategory Property
FamilyBase Class Example See Also Send Feedback
Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Category FamilyCategory { get; }
Visual Basic (Declaration)
Public ReadOnly Property FamilyCategory As Category
Visual C++
public:
property Category^ FamilyCategory {
    Category^ get ();
}

Remarks

All category objects can be retrieved from the application by using the Categories property of the Application.Settings object.

Examples

CopyC#
public void GetBeamAndColumnSymbols(Document document)
{
    FamilySymbolSet columnTypes = new FamilySymbolSet();
    FamilySymbolSet framingTypes = new FamilySymbolSet();
    ElementIterator elemItor = document.get_Elements(typeof(Family));
    elemItor.Reset();
    while (elemItor.MoveNext())
    {
        Family tmpFamily = elemItor.Current as Family;
        Category category = tmpFamily.FamilyCategory;
        if (null != category)
        {
            if ((int)BuiltInCategory.OST_StructuralColumns == category.Id.Value)
            {
                foreach (FamilySymbol tmpSymbol in tmpFamily.Symbols)
                {
                    columnTypes.Insert(tmpSymbol);
                }
            }
            else if ((int)BuiltInCategory.OST_StructuralFraming == category.Id.Value)
            {
                foreach (FamilySymbol tmpSymbol in tmpFamily.Symbols)
                {
                    framingTypes.Insert(tmpSymbol);
                }
            }
        }
    }

    string message = "Column Types: ";
    FamilySymbolSetIterator fsItor = columnTypes.ForwardIterator();
    fsItor.Reset();
    while (fsItor.MoveNext())
    {
        FamilySymbol familySybmol = fsItor.Current as FamilySymbol;
        message += "\n" + familySybmol.Name;
    }

    MessageBox.Show(message, "Revit");
}
CopyVB.NET
Public Sub GetBeamAndColumnSymbols(ByVal document As Document)
    Dim columnTypes As New FamilySymbolSet()
    Dim framingTypes As New FamilySymbolSet()
    Dim elemItor As ElementIterator = document.Elements(GetType(Autodesk.Revit.Elements.Family))
    elemItor.Reset()
    While elemItor.MoveNext()
        Dim tmpFamily As Autodesk.Revit.Elements.Family = TryCast(elemItor.Current, Autodesk.Revit.Elements.Family)
        Dim category As Autodesk.Revit.Category = tmpFamily.FamilyCategory
        If category IsNot Nothing Then
            If CInt(BuiltInCategory.OST_StructuralColumns) = category.Id.Value Then
                For Each tmpSymbol As Autodesk.Revit.Symbols.FamilySymbol In tmpFamily.Symbols
                    columnTypes.Insert(tmpSymbol)
                Next
            ElseIf CInt(BuiltInCategory.OST_StructuralFraming) = category.Id.Value Then
                For Each tmpSymbol As Autodesk.Revit.Symbols.FamilySymbol In tmpFamily.Symbols
                    framingTypes.Insert(tmpSymbol)
                Next
            End If
        End If
    End While

    Dim message As String = "Column Types: "
    Dim fsItor As FamilySymbolSetIterator = columnTypes.ForwardIterator()
    fsItor.Reset()
    While fsItor.MoveNext()
        Dim familySybmol As Autodesk.Revit.Symbols.FamilySymbol = TryCast(fsItor.Current, Autodesk.Revit.Symbols.FamilySymbol)
        message += vbLf & familySybmol.Name
    End While

    MessageBox.Show(message, "Revit")
End Sub

See Also

FamilyBase Class
Autodesk.Revit.Elements Namespace

Parameter Property

[image] [image]