Revit 2010 API
Document..::.NewWire Method
Document Class See Also Send Feedback
Creates a new wire element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Wire NewWire(
    Curve curve,
    View view,
    Connector startConnector,
    Connector endConnector,
    WireType wireType,
    WiringType wiringType
)
Visual Basic (Declaration)
Public Function NewWire ( _
    curve As Curve, _
    view As View, _
    startConnector As Connector, _
    endConnector As Connector, _
    wireType As WireType, _
    wiringType As WiringType _
) As Wire
Visual C++
public:
Wire^ NewWire(
    Curve^ curve,
    View^ view,
    Connector^ startConnector,
    Connector^ endConnector,
    WireType^ wireType,
    WiringType wiringType
)

Parameters

curve
Type: Autodesk.Revit.Geometry..::.Curve
The base line of the wire.
view
Type: Autodesk.Revit.Elements..::.View
The view in which the wire is to be visible.
startConnector
Type: Autodesk.Revit.MEP..::.Connector
The connector which connects with the start point connector of wire, if it is null, the start point connects with nothing.
endConnector
Type: Autodesk.Revit.MEP..::.Connector
The connector which connects with the end point connector of wire, if it is null, the end point connects with nothing.
wireType
Type: Autodesk.Revit.MEP..::.WireType
Specify wire type of new created wire.
wiringType
Type: Autodesk.Revit.MEP.Enums..::.WiringType
Specify wiring type(Arc or chamfer) of new created wire.

Return Value

If successful a new wire element within the project, otherwise Nothing.

Exceptions

Exception | Condition
System..::.InvalidOperationException | An InvalidOperationException will to be thrown when Revit MEP product is unavailable.

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewZone Method

[image]