Revit 2010 API
Curve..::.ComputeRawParameter Method
Curve Class See Also Send Feedback
Computes the raw parameter from the normalized parameter.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public double ComputeRawParameter(
    double normalizedParameter
)
Visual Basic (Declaration)
Public Function ComputeRawParameter ( _
    normalizedParameter As Double _
) As Double
Visual C++
public:
double ComputeRawParameter(
    double normalizedParameter
)

Parameters

normalizedParameter
Type: System..::.Double
The normalized parameter.

Return Value

The real number equal to the raw curve parameter.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when normalizedParameter is infinite.
System..::.InvalidOperationException | Thrown when the curve is unbound.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace

Distance Method

[image]