Revit 2010 API
InstanceBinding Class
Members Example See Also Send Feedback
The InstanceBinding object is used to signify a binding between a parameter definition and a parameter on each instance of an element, such as a wall.

Namespace: Autodesk.Revit.Parameters
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class InstanceBinding : ElementBinding
Visual Basic (Declaration)
Public Class InstanceBinding _
    Inherits ElementBinding
Visual C++
public ref class InstanceBinding : public ElementBinding

Remarks

Once bound the parameter will appear on all instance of the element and changing the parameter on any one single instance will not change the value on any other instance.

Examples

CopyC#
public bool SetNewParameterToInsanceWall(Autodesk.Revit.Application app, DefinitionFile myDefinitionFile)
{
    // create a new group in the shared parameters file
    DefinitionGroups myGroups = myDefinitionFile.Groups;
    DefinitionGroup myGroup = myGroups.Create("MyParameters1");

    // create an instance definition in definition group MyParameters
    Definition myDefinition_ProductDate =
       myGroup.Definitions.Create("Instance_ProductDate", ParameterType.Text);

    // create a category set and insert category of wall to it
    CategorySet myCategories = app.Create.NewCategorySet();
    // use BuiltInCategory to get category of wall
    Category myCategory = app.ActiveDocument.Settings.Categories.get_Item(
                                BuiltInCategory.OST_Walls);
    myCategories.Insert(myCategory);

    //Create an instance of InstanceBinding
    InstanceBinding instanceBinding = app.Create.NewInstanceBinding(myCategories);

    // Get the BingdingMap of current document.
    BindingMap bindingMap = app.ActiveDocument.ParameterBindings;

    // Bind the definitions to the document
    bool instanceBindOK = bindingMap.Insert(myDefinition_ProductDate,
                                    instanceBinding, BuiltInParameterGroup.PG_TEXT);
    return instanceBindOK;
}
CopyVB.NET
Public Function SetNewParameterToInsanceWall(ByVal app As Autodesk.Revit.Application, ByVal myDefinitionFile As DefinitionFile) As Boolean
    ' create a new group in the shared parameters file
    Dim myGroups As DefinitionGroups = myDefinitionFile.Groups
    Dim myGroup As DefinitionGroup = myGroups.Create("MyParameters1")

    ' create an instance definition in definition group MyParameters
    Dim myDefinition_ProductDate As Definition = myGroup.Definitions.Create("Instance_ProductDate", ParameterType.Text)

    ' create a category set and insert category of wall to it
    Dim myCategories As CategorySet = app.Create.NewCategorySet()
    ' use BuiltInCategory to get category of wall
    Dim myCategory As Autodesk.Revit.Category = app.ActiveDocument.Settings.Categories.Item(BuiltInCategory.OST_Walls)
    myCategories.Insert(myCategory)

    'Create an instance of InstanceBinding
    Dim instanceBinding As InstanceBinding = app.Create.NewInstanceBinding(myCategories)

    ' Get the BingdingMap of current document.
    Dim bindingMap As BindingMap = app.ActiveDocument.ParameterBindings

    ' Bind the definitions to the document
    Dim instanceBindOK As Boolean = bindingMap.Insert(myDefinition_ProductDate, instanceBinding, BuiltInParameterGroup.PG_TEXT)
    Return instanceBindOK
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit.Parameters..::.Binding
Autodesk.Revit.Parameters..::.ElementBinding
Autodesk.Revit.Parameters..::.InstanceBinding

See Also

InstanceBinding Members
Autodesk.Revit.Parameters Namespace

InstanceBinding Members

[image] [image]