Revit 2010 API
Application..::.NewProjectDocument Method
Application Class See Also Send Feedback
New project document

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual Document NewProjectDocument(
    string templateFileName
)
Visual Basic (Declaration)
Public Overridable Function NewProjectDocument ( _
    templateFileName As String _
) As Document
Visual C++
public:
virtual Document^ NewProjectDocument(
    String^ templateFileName
)

Parameters

templateFileName
Type: System..::.String
The template file name.

Remarks

This API command corresponds to the user-interface command File->New->Project....

Exceptions

Exception | Condition
System..::.ArgumentException | if 'templateFileName' is a null object or an empty string.
System..::.InvalidOperationException | if can not new a project document.

See Also

Application Class
Autodesk.Revit Namespace

NewProjectTemplateDocument Method

[image]