Revit 2010 API
FamilyInstance..::.Material Property
FamilyInstance Class See Also Send Feedback
This property returns the physical material from which the instance is made.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Material Material { get; }
Visual Basic (Declaration)
Public ReadOnly Property Material As Material
Visual C++
public:
property Material Material {
    Material get ();
}

Remarks

Values of this property can be Steel, Concrete, Wood or some other material. Different from Revit materials that geometry really consists of, this property is a family parameter defining family behavior and can not be set per instance. Its value is the same with the type of the instance's family. For example, the instances of different kind of column families(Steel, Concrete or Wood) have different material values and can't be changed int the UI or RevitAPI.

See Also

FamilyInstance Class
Autodesk.Revit.Elements Namespace

MEPModel Property

[image]