Revit 2010 API
WireMaterialType Members
WireMaterialType Class Constructors Methods Properties See Also Send Feedback

The WireMaterialType type exposes the following members.

Constructors

Name | Description
WireMaterialType | Initializes a new instance of the WireMaterialType class

Methods

Name | Description
AddGroundConductorSize | Add new electrical ground conductor size type into this material type.
AddTemperatureRatingType | Add a new temperature rating type into material type.
RemoveGroundConductorSize | Remove an existing ground conductor size from this material type.
RemoveTemperatureRatingType | Remove an existing temperature rating type from this material type.

Properties

Name | Description
GroundConductorSizes | Get all ground conductor size types defined in this wire material type.
IsInUse | Indicate whether the wire material type is in use.
Name | Get name of wire material type. (Overrides Element..::.Name.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
TemperatureRatings | Get all temperature rating type definitions defined in this wire material type.

See Also

WireMaterialType Class
Autodesk.Revit.MEP Namespace

WireMaterialType Constructor

[image]