Revit 2010 API
IExternalCommand Interface
Members Example See Also Send Feedback
An interface that when support provides additional commands within Autodesk Revit implemented by external applications.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public interface IExternalCommand
Visual Basic (Declaration)
Public Interface IExternalCommand
Visual C++
public interface class IExternalCommand

Remarks

To add an external command to Autodesk Revit the developer should implement an object that supports the IExternalCommand interface.

Examples

CopyC#
public IExternalCommand.Result Execute(ExternalCommandData commandData,
    ref string message, ElementSet elements)
{
    try
    {
        Document doc = commandData.Application.ActiveDocument;

        // Delete selected elements
        ElementIdSet ids = doc.Delete(doc.Selection.Elements);

        DialogResult result = MessageBox.Show(
           "Click Yes to return Succeeded. Selected members will be deleted.\n" +
           "Click No to return Failed.  Selected members will not be deleted.\n" +
           "Click Cancel to return Cancelled.  Selected members will not be deleted.",
           "Revit", MessageBoxButtons.YesNoCancel);

        if (DialogResult.Yes == result)
        {
            return IExternalCommand.Result.Succeeded;
        }
        else if (DialogResult.No == result)
        {
            elements = doc.Selection.Elements;
            message = "Failed to delete selection.";
            return IExternalCommand.Result.Failed;
        }
        else
        {
            return IExternalCommand.Result.Cancelled;
        }
    }
    catch
    {
        message = "Unexpected Exception thrown.";
        return IExternalCommand.Result.Failed;
    }

}
CopyVB.NET
Public Function Execute(ByVal commandData As ExternalCommandData, ByRef message As String, ByVal elements As ElementSet) As IExternalCommand.Result Implements IExternalCommand.Execute
    Try
        Dim doc As Document = commandData.Application.ActiveDocument

        ' Delete selected elements
        Dim ids As ElementIdSet = doc.Delete(doc.Selection.Elements)

        Dim result As DialogResult = MessageBox.Show("Click Yes to return Succeeded. Selected members will be deleted." & vbLf & "Click No to return Failed. Selected members will not be deleted." & vbLf & "Click Cancel to return Cancelled. Selected members will not be deleted.", "Revit", MessageBoxButtons.YesNoCancel)

        If DialogResult.Yes = result Then
            Return IExternalCommand.Result.Succeeded
        ElseIf DialogResult.No = result Then
            elements = doc.Selection.Elements
            message = "Failed to delete selection."
            Return IExternalCommand.Result.Failed
        Else
            Return IExternalCommand.Result.Cancelled
        End If
    Catch
        message = "Unexpected Exception thrown."
        Return IExternalCommand.Result.Failed
    End Try

End Function

See Also

IExternalCommand Members
Autodesk.Revit Namespace

IExternalCommand Members

[image] [image]