Revit 2010 API
DefinitionBindingMap Members
DefinitionBindingMap Class Constructors Methods Properties See Also Send Feedback

The DefinitionBindingMap type exposes the following members.

Constructors

Name | Description
DefinitionBindingMap | Initializes a new instance of the DefinitionBindingMap class

Methods

Name | Description
Clear | Removes every binding from the map, rendering it empty.
Contains | Tests for the existence of a definition within the map.
Erase | Removes a binding with the specified definition from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
Insert | Insert the specified binding with the specified definition into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
Item | Gets or sets a parameter binding for a specified parameter definition within the map.
Size | Returns the number of bindings that are in the map.

See Also

DefinitionBindingMap Class
Autodesk.Revit.Collections Namespace

DefinitionBindingMap Constructor

[image]