Revit 2010 API
Curve..::.MakeBound Method
Curve Class See Also Send Feedback
Changes the bounds of this curve to the specified values.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void MakeBound(
    double startParameter,
    double endParameter
)
Visual Basic (Declaration)
Public Sub MakeBound ( _
    startParameter As Double, _
    endParameter As Double _
)
Visual C++
public:
void MakeBound(
    double startParameter,
    double endParameter
)

Parameters

startParameter
Type: System..::.Double
The new parameter of the start point.
endParameter
Type: System..::.Double
The new parameter of the end point.

Remarks

This method changes this curve to bound.

Exceptions

Exception | Condition
System..::.NotFiniteNumberException | Thrown when the specified values are infinite.
System..::.InvalidOperationException | Thrown when endParameter is smaller than startParameter, or the object is internally marked as read-only.

See Also

Curve Class
Autodesk.Revit.Geometry Namespace

MakeUnbound Method

[image]