Revit 2010 API
Application..::.CreateRibbonPanel Method
Application Class See Also Send Feedback
Create a new RibbonPanel.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
    string panelName
)
Visual Basic (Declaration)
Public Overridable Function CreateRibbonPanel ( _
    panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
    String^ panelName
)

Parameters

panelName
Type: System..::.String

Remarks

This method will create a custom panel appending to the Revit AddIns tab. This method is not supported in VSTA.

Exceptions

Exception | Condition
System..::.ArgumentNullException | panelName is null.
System..::.ArgumentException | panelName is Empty.
System..::.InvalidOperationException | If more than 100 panels were created.

See Also

Application Class
Autodesk.Revit Namespace

ExtractPartAtomFromFamilyFile Method

[image]