Revit 2010 API
Application..::.ViewPrinting Event
Application Class See Also Send Feedback
Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public event EventHandler<ViewPrintingEventArgs> ViewPrinting
Visual Basic (Declaration)
Public Event ViewPrinting As EventHandler(Of ViewPrintingEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintingEventArgs^>^ ViewPrinting {
    void add (EventHandler<ViewPrintingEventArgs^>^ value);
    void remove (EventHandler<ViewPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view of the document.

Event is not cancellable. The 'Cancellable' property of event’s argument is always 'false'.

The document may be modified during this event. A transaction is already created at the time of the event and will be automatically closed at the end of the event. There is no need to create another transaction during this event and it is, in fact, prohibited.

Please be aware that the following API functions are not available for the current document during this event:

  • Export(String, String, GBXMLExportOptions) and similar overloads.
  • Autodesk.Revit.Document.Print()
  • Print()()() and similar overloads.
  • SubmitPrint()()() and similar overloads.
  • Close()()() and similar overloads.
  • BeginTransaction()()() and similar overloads.
  • AbortTransaction()()()
  • EndTransaction()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewPrinted will be raised immediately after view printing is finished.

Note: this event is not supported from Visual Studio Tools for Applications for Revit.

See Also

Application Class
Autodesk.Revit Namespace

BuildingSiteExportOptions Class

[image]