Revit 2010 API
FamilyInstanceCreationData Constructor (Face, Line, FamilySymbol)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    Face face,
    Line position,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Sub New ( _
    face As Face, _
    position As Line, _
    symbol As FamilySymbol _
)
Visual C++
public:
FamilyInstanceCreationData(
    Face^ face,
    Line^ position,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.Geometry..::.Face
A face of a geometry object.
position
Type: Autodesk.Revit.Geometry..::.Line
A line on the face defining where the symbol is to be placed.
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace

FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, StructuralType)

[image]