Revit 2010 API
FamilyItemFactory..::.NewCurveByPoints Method
FamilyItemFactory Class See Also Send Feedback
Create a 3d curve through two or more points in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CurveByPoints NewCurveByPoints(
    ReferencePointArray points
)
Visual Basic (Declaration)
Public Function NewCurveByPoints ( _
    points As ReferencePointArray _
) As CurveByPoints
Visual C++
public:
CurveByPoints^ NewCurveByPoints(
    ReferencePointArray^ points
)

Parameters

points
Type: Autodesk.Revit.Elements..::.ReferencePointArray
Two or more PointElements. The curve will interpolate these points.

Return Value

The newly created curve.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when points is null.
System..::.ArgumentException | Thrown when points does not contain at least two PointElements.
System..::.InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace

NewDimension Method

[image] [image]