Revit 2010 API
CurveElement..::.LineStyle Property
CurveElement Class See Also Send Feedback
The line style of this curve element.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element LineStyle { get; set; }
Visual Basic (Declaration)
Public Property LineStyle As Element
Visual C++
public:
property Element^ LineStyle {
    Element^ get ();
    void set (Element^ value);
}

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when argument is null.
System..::.InvalidOperationException | Thrown when regeneration failed. Thrown when fail to get line style.

See Also

CurveElement Class
Autodesk.Revit.Elements Namespace

LineStyles Property

[image]