Revit 2010 API
ButtonData..::.Name Property
ButtonData Class See Also Send Feedback
The name of the button.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when setting the value to null.
System..::.ArgumentException | Thrown when setting the value to an empty string.

See Also

ButtonData Class
Autodesk.Revit Namespace

Text Property

[image]