Revit 2010 API
FamilyItemFactory..::.NewRevolveForms Method
FamilyItemFactory Class See Also Send Feedback
Create new Form elements by revolve operation, and add them into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FormArray NewRevolveForms(
    bool isSolid,
    ReferenceArray profile,
    Reference axis,
    double startAngle,
    double endAngle
)
Visual Basic (Declaration)
Public Function NewRevolveForms ( _
    isSolid As Boolean, _
    profile As ReferenceArray, _
    axis As Reference, _
    startAngle As Double, _
    endAngle As Double _
) As FormArray
Visual C++
public:
FormArray^ NewRevolveForms(
    bool isSolid,
    ReferenceArray^ profile,
    Reference^ axis,
    double startAngle,
    double endAngle
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Form is Solid or Void.
profile
Type: Autodesk.Revit.Geometry..::.ReferenceArray
The profile of the newly created revolution. It should consist of only one curve loop. The input profile must be in one plane.
axis
Type: Autodesk.Revit.Geometry..::.Reference
The axis of revolution. This axis must lie in the same plane as the curve loops.
startAngle
Type: System..::.Double
The start angle of Revolution in radians.
endAngle
Type: System..::.Double
The end angle of Revolution in radians.

Return Value

If creation was successful new forms are returned.

Remarks

Typically this operation produces only a single form, but some combinations of arguments will create multiple froms from a single profile.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace

NewSketchPlane Method

[image] [image]