Revit 2010 API
Categories Class
Members Example See Also Send Feedback
The Categories object is a map that contains all the top-level Category objects within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class Categories : CategoryNameMap
Visual Basic (Declaration)
Public Class Categories _
    Inherits CategoryNameMap
Visual C++
public ref class Categories : public CategoryNameMap

Remarks

Use this object to retrieve categories by name or by BuiltInCategory id.

Examples

CopyC#
// Get settings of current document
Settings documentSettings = document.Settings;

// Get all categories of current document
Categories groups = documentSettings.Categories;

// Show the number of all the categories to the user
String prompt = "Number of all categories in current Revit document:" + groups.Size;

// get Floor category according to OST_Floors and show its name
Category floorCategory = groups.get_Item(BuiltInCategory.OST_Floors);
prompt += floorCategory.Name;

// Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);
CopyVB.NET
' Get settings of current document
Dim documentSettings As Settings = document.Settings

' Get all categories of current document
Dim groups As Categories = documentSettings.Categories

' Show the number of all the categories to the user
Dim prompt As String = "Number of all categories in current Revit document:" & groups.Size

' get Floor category according to OST_Floors and show its name
Dim floorCategory As Autodesk.Revit.Category = groups.Item(BuiltInCategory.OST_Floors)
prompt += floorCategory.Name

' Give the user some information
MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.CategoryNameMap
Autodesk.Revit..::.Categories

See Also

Categories Members
Autodesk.Revit Namespace

Categories Members

[image] [image]