Revit 2010 API
Document..::.LoadFamilySymbol Method (String, String, FamilySymbol%)
Document Class See Also Send Feedback
Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool LoadFamilySymbol(
    string filename,
    string name,
    out FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function LoadFamilySymbol ( _
    filename As String, _
    name As String, _
    <OutAttribute> ByRef symbol As FamilySymbol _
) As Boolean
Visual C++
public:
bool LoadFamilySymbol(
    String^ filename,
    String^ name,
    [OutAttribute] FamilySymbol^% symbol
)

Parameters

filename
Type: System..::.String
The fully qualified filename of the Family file, usually ending in .rfa.
name
Type: System..::.String
The name of the type/symbol to be loaded, such as "W11x14".
symbol
Type: Autodesk.Revit.Symbols..::.FamilySymbol %
A reference to the family symbol that was loaded if successful, otherwise Nothing.

Return Value

Returns True if the family type/symbol was loaded successfully into the project, otherwise false.

Remarks

The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods. The name of the family type/symbol is the same name as returned by the Name property on the FamilySymbol object.

Exceptions

Exception | Condition
System..::.ArgumentNullException | filename or name is null.

See Also

Document Class
LoadFamilySymbol Overload
Autodesk.Revit Namespace

Mirror Method

[image] [image]