Revit 2010 API
AnalyticalModelFrame..::.RigidLink Property
AnalyticalModelFrame Class See Also Send Feedback
Provides access to Rigid Links component of Structural Framing Element.

Namespace: Autodesk.Revit.Structural
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Curve RigidLink[
    int nEnd
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property RigidLink ( _
    nEnd As Integer _
) As Curve
Visual C++
public:
property Curve^ RigidLink[int nEnd] {
    Curve^ get (int nEnd);
}

Parameters

nEnd
Type: System..::.Int32
An integer that represents the end of beam or column, 0 for the start and 1 for the end.

Return Value

Returns a Curve that is the Rigid Links component of the Structural Framing Element. End is determined by the input parameter.

Remarks

This is only meaningful for Beams.

See Also

AnalyticalModelFrame Class
Autodesk.Revit.Structural Namespace

SupportData Property

[image]