Revit 2010 API
CurtainGrid..::.ChangePanelType Method
CurtainGrid Class See Also Send Feedback
Change the type of a curtain panel.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Element ChangePanelType(
    Element panel,
    Symbol newSymbol
)
Visual Basic (Declaration)
Public Function ChangePanelType ( _
    panel As Element, _
    newSymbol As Symbol _
) As Element
Visual C++
public:
Element^ ChangePanelType(
    Element^ panel,
    Symbol^ newSymbol
)

Parameters

panel
Type: Autodesk.Revit..::.Element
The panel to be changed, it can be a type of Panel or Wall.
newSymbol
Type: Autodesk.Revit..::.Symbol
The new symbol, it may be of PanelType or WallType when the panel is hosted in a curtain wall. The new symbol can only be of type PanelType if the Panel is hosted in a curtain system.

Return Value

If operation succeeds, the modified panel element is returned.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown if the input input symbol can't be used for the panel.
System..::.InvalidOperationException | Thrown when the type change failed.

See Also

CurtainGrid Class
Autodesk.Revit.Elements Namespace

GetCell Method

[image]