Revit 2010 API
RebarLayoutRule Enumeration
See Also Send Feedback
The rule for how the rebars in rebar set are laid out.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum RebarLayoutRule
Visual Basic (Declaration)
Public Enumeration RebarLayoutRule
Visual C++
public enum class RebarLayoutRule

Members

Member name | Description
MinimumClearSpacing | You specify the minimum distance between rebar, and the quantity of rebar changes based on the distance between the first and last bars. This spacing is maintained even if the rebar size changes.
NumberWithSpacing | You specify constant values for quantity and spacing.
MaximumSpacing | You specify the maximum distance between rebar, but the number of rebar changes based on the distance between the first and last bars.
FixedNumber | The spacing between the rebar is adjustable, but the number of bars is constant based on your input.
Single | It is a single rebar and not a rebar set.

See Also

Autodesk.Revit.Structural.Enums Namespace

RebarShapeArcReferenceType Enumeration

[image]