Revit 2010 API
Connector..::.AssignedDuctLossMethod Property
Connector Class See Also Send Feedback
The duct loss method of the connector.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DuctLossMethodType AssignedDuctLossMethod { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedDuctLossMethod As DuctLossMethodType
Visual C++
public:
property DuctLossMethodType AssignedDuctLossMethod {
    DuctLossMethodType get ();
}

Remarks

Assigned duct loss method may be assigned for connectors of some familiy instances, for more information, refer to Autodesk::Revit::MEP::DuctConnector.

Exceptions

Exception | Condition
System..::.NotSupportedException | Thrown when the connector's domain is not DomainHvac. Thrown when the connector is not in family instance.
System..::.InvalidOperationException | Thrown on failure to get duct loss method.

See Also

Connector Class
Autodesk.Revit.MEP Namespace

AssignedFixtureUnits Property

[image]