Revit 2010 API
Options..::.View Property
Options Class See Also Send Feedback
The view used for geometry extraction.

Namespace: Autodesk.Revit.Geometry
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public View View { get; set; }
Visual Basic (Declaration)
Public Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
    void set (View^ value);
}

Remarks

If a view-specific version of an element exists, it will be extracted in the retrieval of geometry. Also, the detail level of the geometry will be taken from the view's detail level.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when setting this property, if DetailLevel is already set. When DetailLevel is set view-specific geometry can't be extracted.

See Also

Options Class
Autodesk.Revit.Geometry Namespace

Options.DetailLevels Enumeration

[image]