Revit 2010 API
PointOnEdgeFaceIntersection Class
Members See Also Send Feedback
Define a ReferencePoint at the intersection of a referenceable edge or curve and a referenceable face.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class PointOnEdgeFaceIntersection : PointElementReference
Visual Basic (Declaration)
Public Class PointOnEdgeFaceIntersection _
    Inherits PointElementReference
Visual C++
public ref class PointOnEdgeFaceIntersection : public PointElementReference

Remarks

The ReferencePoint's orientation is partially constrained either to the edge (in the manner of PointOnEdge) or to the face (in the manner of PointOnFace).

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Elements..::.PointElementReference
Autodesk.Revit.Elements..::.PointOnEdgeFaceIntersection

See Also

PointOnEdgeFaceIntersection Members
Autodesk.Revit.Elements Namespace

PointOnEdgeFaceIntersection Members

[image] [image]