Revit 2010 API
ViewSheetSetting..::.Rename Method
ViewSheetSetting Class See Also Send Feedback
Rename the current view sheet set.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Rename(
    string newName
)
Visual Basic (Declaration)
Public Function Rename ( _
    newName As String _
) As Boolean
Visual C++
public:
bool Rename(
    String^ newName
)

Parameters

newName
Type: System..::.String
View sheet set name to be renamed as.

Return Value

Returns false if Rename operation fails, otherwise, returns true.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the input name is already existed in current view sheet set list.

See Also

ViewSheetSetting Class
Autodesk.Revit Namespace

Revert Method

[image]