Revit 2010 API
Document..::.Elements Property (Type, ICollection<(Of <(Element>)>))
Document Class See Also Send Feedback
Collects all elements which satisfy specified type within the Document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public int Elements[
    Type type,
    ICollection<Element> collection
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements ( _
    type As Type, _
    collection As ICollection(Of Element) _
) As Integer
Visual C++
public:
property int Elements[Type^ type, ICollection<Element^>^ collection] {
    int get (Type^ type, ICollection<Element^>^ collection);
}

Parameters

type
Type: System..::.Type
Type used to determine the elements to add.
collection
Type: System.Collections.Generic..::.ICollection <(Of <( Element >)>)
An element collection to contain the elements found.

Remarks

If the collection provided already contains elements, new elements added to the collection will be checked against the contents of the collection, and elements already in the input will not be added to the collection again. Because of the overhead required to perform these checks, to obtain the best performance from this property pass an empty collection. This method won't find elements whose type is derived from the specified type. This method is not supported in VSTA, use the variation accepting an ElementArray instead.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter of type or collection is null.

See Also

Document Class
Elements Overload
Autodesk.Revit Namespace

FamilyCreate Property

[image]