Revit 2010 API
ControlledApplication..::.OnDocumentNewed Event
ControlledApplication Class See Also Send Feedback
This event is deprecated since Revit version 2010. Please use DocumentCreated event instead. Subscribe to the OnDocumentNewed event to be notified when a new document is created during an API external command.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
[ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentCreated event instead.")]
public event DocumentNewedEventHandler OnDocumentNewed
Visual Basic (Declaration)
<ObsoleteAttribute("This event is deprecated since Revit version 2010. Please use DocumentCreated event instead.")> _
Public Event OnDocumentNewed As DocumentNewedEventHandler
Visual C++
[ObsoleteAttribute(L"This event is deprecated since Revit version 2010. Please use DocumentCreated event instead.")]
public:
 event DocumentNewedEventHandler^ OnDocumentNewed {
    void add (DocumentNewedEventHandler^ value);
    void remove (DocumentNewedEventHandler^ value);
}

Remarks

Sometimes a new document will be created during an API command. By subscribing to this event your application will be notified of such an event and perform an action, such as create some elements for this document etc.

See Also

ControlledApplication Class
Autodesk.Revit Namespace

OnDocumentOpened Event

[image]