Revit 2010 API
ProfilePlaneLocation Enumeration
See Also Send Feedback
Indicates the location of Sweep profile plane on the path curve.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum ProfilePlaneLocation
Visual Basic (Declaration)
Public Enumeration ProfilePlaneLocation
Visual C++
public enum class ProfilePlaneLocation

Members

Member name | Description
Start | Indicates the profile plane located at the start of the path curve.
MidPoint | Indicates the profile plane located at the Middle point of the path curve.
End | Indicates the profile plane located at the End of the path curve.

Remarks

Use this enum in NewSweep method to create generic forms.

See Also

Autodesk.Revit.Elements Namespace

ProjectInfo Class

[image]