Revit 2010 API
Form..::.RotateSubElement Method
Form Class See Also Send Feedback
Rotate a face/edge/curve/vertex of the form, by a specified number of degrees around a given axis.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void RotateSubElement(
    Reference subElementReference,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Sub RotateSubElement ( _
    subElementReference As Reference, _
    axis As Line, _
    angle As Double _
)
Visual C++
public:
void RotateSubElement(
    Reference^ subElementReference,
    Line^ axis,
    double angle
)

Parameters

subElementReference
Type: Autodesk.Revit.Geometry..::.Reference
The geometry reference of face/edge/curve/vertex
axis
Type: Autodesk.Revit.Geometry..::.Line
An unbounded line that represents the axis of rotation.
angle
Type: System..::.Double
The number of degrees, in radians, by which the element is to be rotated around the specified axis.

See Also

Form Class
Autodesk.Revit.Elements Namespace

ScaleProfile Method

[image]