Revit 2010 API
Material Enumeration
See Also Send Feedback
Basic solid structural object material types.

Namespace: Autodesk.Revit.Structural.Enums
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public enum Material
Visual Basic (Declaration)
Public Enumeration Material
Visual C++
public enum class Material

Members

Member name | Description
MAX | The value is used to check whether the enum is the same size as the internal one.
PrecastConcrete | The object is considered to be made of precast concrete.
Other | The material is defined, but it is not steel, concrete , wood or precast concrete.
Wood | The object is considered to be made of wood.
Concrete | The object is considered to be made of concrete.
Steel | The object is considered to be made of steel.
Undefined | The material for this object has not been defined.

See Also

Autodesk.Revit.Structural.Enums Namespace

RebarHookOrientation Enumeration

[image]