Revit 2010 API
ModelCurveArray..::.Insert Method
ModelCurveArray Class See Also Send Feedback
Insert the specified model curve into the array.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public virtual void Insert(
    ModelCurve item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As ModelCurve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    ModelCurve^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.Elements..::.ModelCurve
The model curve to be inserted into the array.
index
Type: System..::.Int32
The model curve will be inserted before this index.

Return Value

Returns whether the model curve was inserted into the array.

See Also

ModelCurveArray Class
Autodesk.Revit.Elements Namespace

ReverseIterator Method

[image]