Revit 2010 API
Document..::.Rotate Method
Document Class See Also Send Feedback
Rotates one or more elements within the document by a specified number of degrees around a given axis.

Overload List

Name | Description
Rotate(Element, Line, Double) | Rotates an element within the document by a specified number of degrees around a given axis.
Rotate(ElementId%, Line, Double) | Rotates an element, specified by id, within the document by a specified number of degrees around a given axis.
Rotate(ElementIdSet, Line, Double) | Rotates several elements, specified by a set of ids, within the document by a specified number of degrees around a given axis.
Rotate(ElementSet, Line, Double) | Rotates several elements within the document by a specified number of degrees around a given axis.

See Also

Document Class
Document Members
Autodesk.Revit Namespace

Rotate Method (Element, Line, Double)

[image]