Revit 2010 API
Document..::.NewRooms Method (Level)
Document Class See Also Send Feedback
Creates new rooms in each plan circuit found in the given level in the last phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public ElementSet NewRooms(
    Level level
)
Visual Basic (Declaration)
Public Function NewRooms ( _
    level As Level _
) As ElementSet
Visual C++
public:
ElementSet^ NewRooms(
    Level^ level
)

Parameters

level
Type: Autodesk.Revit.Elements..::.Level
The level from which the circuits are found.

Return Value

If successful an Element set which contain the rooms created should be returned, otherwise null.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved.
System..::.InvalidOperationException | If the phase is invalid, or regeneration fails at the end of the creation.

See Also

Document Class
NewRooms Overload
Autodesk.Revit.Creation Namespace

NewRooms Method (List(RoomCreationData))

[image]