Revit 2010 API
DividedSurface..::.GetGridSegmentReference Method
DividedSurface Class See Also Send Feedback
Get a reference to a line segment connecting two adjacent grid nodes.

Namespace: Autodesk.Revit.Elements
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Reference GetGridSegmentReference(
    GridNode gridNode,
    GridSegmentDirection gridSegmentDirection
)
Visual Basic (Declaration)
Public Function GetGridSegmentReference ( _
    gridNode As GridNode, _
    gridSegmentDirection As GridSegmentDirection _
) As Reference
Visual C++
public:
Reference^ GetGridSegmentReference(
    GridNode gridNode,
    GridSegmentDirection gridSegmentDirection
)

Parameters

gridNode
Type: Autodesk.Revit.Elements..::.GridNode
gridSegmentDirection
Type: Autodesk.Revit.Enums..::.GridSegmentDirection

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ], or when the adjacent grid node specified by gridSegmentDirection is out of range.

See Also

DividedSurface Class
Autodesk.Revit.Elements Namespace

GetTileFamilyInstance Method

[image]