Revit 2010 API
HostObjAttributes..::.CompoundStructure Property
HostObjAttributes Class See Also Send Feedback
Returns an object that represents the compound structure of the element.

Namespace: Autodesk.Revit.Symbols
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public CompoundStructure CompoundStructure { get; }
Visual Basic (Declaration)
Public ReadOnly Property CompoundStructure As CompoundStructure
Visual C++
public:
property CompoundStructure^ CompoundStructure {
    CompoundStructure^ get ();
}

Remarks

From this object the layers of a compound structure can be accessed. If the element does not have a compound structure then this method will return Nothing.

See Also

HostObjAttributes Class
Autodesk.Revit.Symbols Namespace

Parameter Property

[image] [image]