Revit 2010 API
Document..::.Rotate Method (ElementId%, Line, Double)
Document Class See Also Send Feedback
Rotates an element, specified by id, within the document by a specified number of degrees around a given axis.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public bool Rotate(
    ref ElementId id,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    ByRef id As ElementId, _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate(
    ElementId% id,
    Line^ axis,
    double angle
)

Parameters

id
Type: Autodesk.Revit..::.ElementId %
The ElementId for the element that is to be rotated.
axis
Type: Autodesk.Revit.Geometry..::.Line
A line that represents the axis of rotation, which can be either bounded or unbounded line.
angle
Type: System..::.Double
The number of degrees, in radians, by which the element is to be rotated around the specified axis.

Return Value

If the element is rotate successfully then the method returns True, otherwise False.

Remarks

The rotate method is used to rotate an element within the project. Other elements may also be rotated when this element is rotated because they are dependent upon the element being rotated. The line used as the axis can be created by using the Application.Create object and its methods.

See Also

Document Class
Rotate Overload
Autodesk.Revit Namespace

Rotate Method (ElementIdSet, Line, Double)

[image]