Revit 2010 API
Document..::.EditFamily Method
Document Class Example See Also Send Feedback
Edits a family loaded in the document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Document EditFamily(
    Family loadedFamily
)
Visual Basic (Declaration)
Public Function EditFamily ( _
    loadedFamily As Family _
) As Document
Visual C++
public:
Document^ EditFamily(
    Family^ loadedFamily
)

Parameters

loadedFamily
Type: Autodesk.Revit.Elements..::.Family
The loaded family in current document.

Return Value

Returns the reference of the document of the family.

Remarks

This creates an independent copy of the family for editing. To apply the changes to the family stored in the document, use LoadFamily.

Examples

CopyC#
public void GetLoadedSymbols(Autodesk.Revit.Document document, FamilyInstance familyInstance)
{
    if (null != familyInstance.Symbol)
    {
        // Get family associated with this
        Family family = familyInstance.Symbol.Family;

        // Get Family document for family
        Document familyDoc = document.EditFamily(family);
        if (null != familyDoc && familyDoc.IsFamilyDocument == true)
        {
            String loadedFamilies = "FamilySymbols in " + family.Name + ":\n";

            ElementIterator itrFamilySymbols = familyDoc.get_Elements(typeof(FamilySymbol));

            itrFamilySymbols.Reset();

            while (itrFamilySymbols.MoveNext())
            {
                FamilySymbol fs = itrFamilySymbols.Current as FamilySymbol;

                loadedFamilies += "\t" + fs.Name + "\n";
            }

            MessageBox.Show(loadedFamilies, "Revit");
        }
    }
}
CopyVB.NET
Public Sub GetLoadedSymbols(ByVal document As Autodesk.Revit.Document, ByVal familyInstance As Autodesk.Revit.Elements.FamilyInstance)
    If familyInstance.Symbol IsNot Nothing Then
        ' Get family associated with this
        Dim family As Autodesk.Revit.Elements.Family = familyInstance.Symbol.Family

        ' Get Family document for family
        Dim familyDoc As Document = document.EditFamily(family)
        If familyDoc IsNot Nothing AndAlso familyDoc.IsFamilyDocument = True Then
            Dim loadedFamilies As String = "FamilySymbols in " & family.Name & ":" & vbLf

            Dim itrFamilySymbols As ElementIterator = familyDoc.Elements(GetType(Autodesk.Revit.Symbols.FamilySymbol))

            itrFamilySymbols.Reset()

            While itrFamilySymbols.MoveNext()
                Dim fs As Autodesk.Revit.Symbols.FamilySymbol = TryCast(itrFamilySymbols.Current, Autodesk.Revit.Symbols.FamilySymbol)

                loadedFamilies += vbTab & fs.Name & vbLf
            End While

            MessageBox.Show(loadedFamilies, "Revit")
        End If
    End If
End Sub

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"loadedFamily"-is null.
System..::.ArgumentException | Thrown when the input argument-"loadedFamily"-is an in-place family.
System..::.InvalidOperationException | Thrown when the family is already being edited.

See Also

Document Class
Autodesk.Revit Namespace

EndTransaction Method

[image] [image]