Revit 2010 API
ControlledApplication..::.Language Property
ControlledApplication Class See Also Send Feedback
The language used in the Revit application.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LanguageType Language { get; }
Visual Basic (Declaration)
Public ReadOnly Property Language As LanguageType
Visual C++
public:
property LanguageType Language {
    LanguageType get ();
}

Remarks

Use this property to determine the language used by Revit; this can allow your application to load the appropriate resources.

See Also

ControlledApplication Class
Autodesk.Revit Namespace

LoadedApplications Property

[image]