Revit 2010 API
DemandFactor..::.SetPercentage Method
DemandFactor Class See Also Send Feedback
Set percentage value for the specified range.

Namespace: Autodesk.Revit.MEP
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public void SetPercentage(
    long minFactor,
    long maxFactor,
    double percentage
)
Visual Basic (Declaration)
Public Sub SetPercentage ( _
    minFactor As Long, _
    maxFactor As Long, _
    percentage As Double _
)
Visual C++
public:
void SetPercentage(
    long long minFactor,
    long long maxFactor,
    double percentage
)

Parameters

minFactor
Type: System..::.Int64
Lower boundary of the range.
maxFactor
Type: System..::.Int64
Upper boundary of the range.
percentage
Type: System..::.Double
Percentage value of this range.

Remarks

Demand factor data items have been obsolete after this operation, so they should be retrieved again before using. Use "SetFactorDataToInfinity" if the maxFactor value is positive infinity.

Exceptions

Exception | Condition
System..::.ArgumentException | All three parameter can't be negative, maxFactor must be greater than minFactor, and minFactor and percentage can't be positive infinity, otherwise the exception will be thrown.

See Also

DemandFactor Class
Autodesk.Revit.MEP Namespace

SetPercentageToInfinity Method

[image]