Revit 2010 API
FamilyItemFactory..::.NewDividedSurface Method
FamilyItemFactory Class See Also Send Feedback
Create a DividedSurface element on one surface of another element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public DividedSurface NewDividedSurface(
    Reference hostReference
)
Visual Basic (Declaration)
Public Function NewDividedSurface ( _
    hostReference As Reference _
) As DividedSurface
Visual C++
public:
DividedSurface^ NewDividedSurface(
    Reference^ hostReference
)

Parameters

hostReference
Type: Autodesk.Revit.Geometry..::.Reference
Reference to a surface on an existing element. The element must be one of the following: Form, GeomCombination, FamilyInstance, or ImportInstance.

Return Value

The newly created DividedSurface element.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when surface is not a reference to a surface, or when the referenced element does not support divided surfaces.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace

NewDuctConnector Method

[image]