Revit 2010 API
Document..::.NewFlexDuct Method (XYZArray, FlexDuctType)
Document Class See Also Send Feedback
Adds a new flex duct into the document, using a point array and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public FlexDuct NewFlexDuct(
    XYZArray points,
    FlexDuctType ductType
)
Visual Basic (Declaration)
Public Function NewFlexDuct ( _
    points As XYZArray, _
    ductType As FlexDuctType _
) As FlexDuct
Visual C++
public:
FlexDuct^ NewFlexDuct(
    XYZArray^ points,
    FlexDuctType^ ductType
)

Parameters

points
Type: Autodesk.Revit.Geometry..::.XYZArray
The point array indicating the path of the flex duct, including the end points.
ductType
Type: Autodesk.Revit.MEP..::.FlexDuctType
The type of the flex duct.

Return Value

If creation was successful then a new flex duct is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument points is null.
System..::.InvalidOperationException | Thrown when the flex duct cannot be created or regenerate fails.

See Also

Document Class
NewFlexDuct Overload
Autodesk.Revit.Creation Namespace

NewFlexDuct Method (Connector, XYZArray, FlexDuctType)

[image]