Revit 2010 API
Filter..::.NewLogicAndFilter Method
Filter Class Example See Also Send Feedback
Creates a new LogicAndFilter object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public LogicAndFilter NewLogicAndFilter(
    Filter leftFilter,
    Filter rightFilter
)
Visual Basic (Declaration)
Public Function NewLogicAndFilter ( _
    leftFilter As Filter, _
    rightFilter As Filter _
) As LogicAndFilter
Visual C++
public:
LogicAndFilter^ NewLogicAndFilter(
    Filter^ leftFilter,
    Filter^ rightFilter
)

Parameters

leftFilter
Type: Autodesk.Revit..::.Filter
leftFilter is left operand of logic-and operator
rightFilter
Type: Autodesk.Revit..::.Filter
rightFilter is right operand of logic-and operator

Return Value

Returns a new LogicAndFilter object.

Examples

CopyC#
// get Filter Creation object
Autodesk.Revit.Creation.Filter filterCreator = document.Application.Create.Filter;

// Create a type filter for FamilyInstance, including derived types
TypeFilter familyInstanceFilter = filterCreator.NewTypeFilter(typeof(FamilyInstance), true);

// Create a category filter for Doors
CategoryFilter doorsCategoryfilter = filterCreator.NewCategoryFilter(BuiltInCategory.OST_Doors);

// Create a logic And filter for all Door FamilyInstances
Filter doorInstancesFilter = filterCreator.NewLogicAndFilter(familyInstanceFilter, doorsCategoryfilter);

// Apply the filter to the elements in the active document
ElementIterator iter = document.get_Elements(doorInstancesFilter);
CopyVB.NET
' get Filter Creation object
Dim filterCreator As Autodesk.Revit.Creation.Filter = document.Application.Create.Filter

' Create a type filter for FamilyInstance, including derived types
Dim familyInstanceFilter As TypeFilter = filterCreator.NewTypeFilter(GetType(Autodesk.Revit.Elements.FamilyInstance), True)

' Create a category filter for Doors
Dim doorsCategoryfilter As CategoryFilter = filterCreator.NewCategoryFilter(BuiltInCategory.OST_Doors)

' Create a logic And filter for all Door FamilyInstances
Dim doorInstancesFilter As Filter = filterCreator.NewLogicAndFilter(familyInstanceFilter, doorsCategoryfilter)

' Apply the filter to the elements in the active document
Dim iter As ElementIterator = document.Elements(doorInstancesFilter)

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the specified parameter is nullptr.

See Also

Filter Class
Autodesk.Revit.Creation Namespace

NewLogicNotFilter Method

[image]