Revit 2010 API
LocationPoint Class
Members Example See Also Send Feedback
Provides location functionality for all elements that have a single insertion point.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public class LocationPoint : Location
Visual Basic (Declaration)
Public Class LocationPoint _
    Inherits Location
Visual C++
public ref class LocationPoint : public Location

Remarks

The location point objects adds additional functionality to its base location object class. This includes setting the elements location to a specific point and retrieving its rotation around its insertion point.

Examples

CopyC#
void LocationInformation(LocationPoint position)
{
    String prompt = "The selected column location information:";
    prompt += "\nPoint:  (" + position.Point.X + ", "
            + position.Point.Y + ", " + position.Point.Z + ")";
    prompt += "\nRotation: " + position.Rotation;

    MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK);
}

bool LocationRotate(Autodesk.Revit.Application application, Autodesk.Revit.Element element)
{
    bool rotated = false;
    LocationPoint location = element.Location as LocationPoint;

    if (null != location)
    {
        XYZ aa = location.Point;
        XYZ cc = new XYZ(aa.X, aa.Y, aa.Z + 10);
        Line axis = application.Create.NewLineBound(aa, cc);
        rotated = location.Rotate(axis, Math.PI / 2.0);
    }

    return rotated;
}
CopyVB.NET
Private Sub LocationInformation(ByVal position As LocationPoint)
    Dim prompt As String = "The selected column location information:"
    prompt += ((vbLf & "Point: (" & position.Point.X & ", ") + position.Point.Y & ", ") + position.Point.Z & ")"
    prompt += vbLf & "Rotation: " & position.Rotation

    MessageBox.Show(prompt, "Revit", MessageBoxButtons.OK)
End Sub

Private Function LocationRotate(ByVal application As Autodesk.Revit.Application, ByVal element As Autodesk.Revit.Element) As Boolean
    Dim rotated As Boolean = False
    Dim location As LocationPoint = TryCast(element.Location, LocationPoint)

    If location IsNot Nothing Then
        Dim aa As Autodesk.Revit.Geometry.XYZ = location.Point
        Dim cc As New Autodesk.Revit.Geometry.XYZ(aa.X, aa.Y, aa.Z + 10)
        Dim axis As Line = application.Create.NewLineBound(aa, cc)
        rotated = location.Rotate(axis, Math.PI / 2.0R)
    End If

    Return rotated
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit..::.APIObject
Autodesk.Revit..::.Location
Autodesk.Revit..::.LocationPoint

See Also

LocationPoint Members
Autodesk.Revit Namespace

LocationPoint Members

[image] [image]