Revit 2010 API
Categories..::.NewSubcategory Method
Categories Class Example See Also Send Feedback
Add a new subcategory into the Autodesk Revit document.

Namespace: Autodesk.Revit
Assembly: RevitAPI (in RevitAPI.dll) Version: 2010.0.0.0

Syntax

C#
public Category NewSubcategory(
    Category parentCategory,
    string name
)
Visual Basic (Declaration)
Public Function NewSubcategory ( _
    parentCategory As Category, _
    name As String _
) As Category
Visual C++
public:
Category^ NewSubcategory(
    Category^ parentCategory,
    String^ name
)

Parameters

parentCategory
Type: Autodesk.Revit..::.Category
The parent category.
name
Type: System..::.String
The new category name.

Return Value

If successful, the newly created subcategory is returned, otherwise an exception with error information will be thrown.

Examples

CopyC#
public void AssignSubCategory(Document document, GenericForm extrusion)
{
    // create a new subcategory
    Category cat = document.OwnerFamily.FamilyCategory;
    Category subCat = document.Settings.Categories.NewSubcategory(cat, "NewSubCat");

    // create a new material and assign it to the subcategory
    MaterialWood woodMaterial = document.Settings.Materials.AddWood("Wood Material");
    subCat.Material = woodMaterial;

    // assign the subcategory to the element
    extrusion.Subcategory = subCat;
}
CopyVB.NET
Public Sub AssignSubCategory(ByVal document As Document, ByVal extrusion As GenericForm)
    ' create a new subcategory
    Dim cat As Autodesk.Revit.Category = document.OwnerFamily.FamilyCategory
    Dim subCat As Autodesk.Revit.Category = document.Settings.Categories.NewSubcategory(cat, "NewSubCat")

    ' create a new material and assign it to the subcategory
    Dim woodMaterial As MaterialWood = document.Settings.Materials.AddWood("Wood Material")
    subCat.Material = woodMaterial

    ' assign the subcategory to the element
    extrusion.Subcategory = subCat
End Sub

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument-"parentCategory" or "name"-is null.
System..::.ArgumentException | Thrown when the input argument-"parentCategory"-cannot add subcategory. Thrown when the input argument-"name"-is an illegal name.
System..::.InvalidOperationException | Thrown when subcategory creation failed.

See Also

Categories Class
Autodesk.Revit Namespace

ReverseIterator Method

[image]