Revit Add-In Utility Reference

[image]

Revit Add-In Utility 2011
Revit Add-In Utility Reference
Send Feedback

Namespaces

Namespace | Description
Autodesk.RevitAddIns |

Send comments on this topic to Autodesk


Autodesk.RevitAddIns Namespace

[image]

Revit Add-In Utility 2011
Autodesk.RevitAddIns Namespace
Send Feedback

Classes

Class | Description
AddInManifestUtility | This static class provides access to read the contents of manifests from Revit .addin files.
RevitAddInApplication | Represents a Revit external application.
RevitAddInCommand | Represents a Revit external command.
RevitAddInItem | Represents a single Revit Add-In.
RevitAddInManifest | Represents the contents of a single .addin file.
RevitProduct | Represents an installed instance of Revit on the local machine.
RevitProductUtility | Provides access to installed versions of Revit on the local machine.

Enumerations

Enumeration | Description
AddInArchitecture | Defines the operating system architectures recognized by the Add-In utility.
LanguageType | Defines the language type of Revit Add-In.
RevitVersion | Defines the versions of Revit supported by the Add-In utility.
VisibilityMode | Describes the conditions under which a particular external command will be visible in the Revit UI.
WarningType | Defines types of warnings issued by Revit related to Add-In failures.


AddInArchitecture Enumeration

[image]

Revit Add-In Utility 2011
AddInArchitecture Enumeration
See Also Send Feedback
Defines the operating system architectures recognized by the Add-In utility.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public enum AddInArchitecture
Visual Basic (Declaration)
Public Enumeration AddInArchitecture
Visual C++
public enum class AddInArchitecture

Members

Member name | Description
OS32bit | 32-bit operating system.
OS64bit | 64-bit operating system.

See Also

Autodesk.RevitAddIns Namespace


AddInManifestUtility Class

[image]

Revit Add-In Utility 2011
AddInManifestUtility Class
Members See Also Send Feedback
This static class provides access to read the contents of manifests from Revit .addin files.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public static class AddInManifestUtility
Visual Basic (Declaration)
Public NotInheritable Class AddInManifestUtility
Visual C++
public ref class AddInManifestUtility abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.RevitAddIns..::.AddInManifestUtility

See Also

AddInManifestUtility Members


AddInManifestUtility Members

[image] [image]

Revit Add-In Utility 2011
AddInManifestUtility Members
AddInManifestUtility Class Methods See Also Send Feedback

The AddInManifestUtility type exposes the following members.

Methods

Name | Description
GetRevitAddInManifest | Reads an AddInManifest from the input .addin file.
GetRevitAddInManifests | Reads all AddInManifests from the .addin files available in a folder.

See Also

AddInManifestUtility Class


AddInManifestUtility Methods

[image] [image]

Revit Add-In Utility 2011
AddInManifestUtility Methods
AddInManifestUtility Class See Also Send Feedback

The AddInManifestUtility type exposes the following members.

Methods

Name | Description
GetRevitAddInManifest | Reads an AddInManifest from the input .addin file.
GetRevitAddInManifests | Reads all AddInManifests from the .addin files available in a folder.

See Also

AddInManifestUtility Class


GetRevitAddInManifest Method

[image]

Revit Add-In Utility 2011
AddInManifestUtility..::.GetRevitAddInManifest Method
AddInManifestUtility Class See Also Send Feedback
Reads an AddInManifest from the input .addin file.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public static RevitAddInManifest GetRevitAddInManifest(
    string fileName
)
Visual Basic (Declaration)
Public Shared Function GetRevitAddInManifest ( _
    fileName As String _
) As RevitAddInManifest
Visual C++
public:
static RevitAddInManifest^ GetRevitAddInManifest(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The full path to a .addin file.

Return Value

The AddInManifest read from the file.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::.ArgumentException | Thrown when file name is incorrect (it is not a .addin file), or when the .addin file has an unrecognized format.

See Also

AddInManifestUtility Class


GetRevitAddInManifests Method

[image]

Revit Add-In Utility 2011
AddInManifestUtility..::.GetRevitAddInManifests Method
AddInManifestUtility Class See Also Send Feedback
Reads all AddInManifests from the .addin files available in a folder.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public static List<RevitAddInManifest> GetRevitAddInManifests(
    string folderPath
)
Visual Basic (Declaration)
Public Shared Function GetRevitAddInManifests ( _
    folderPath As String _
) As List(Of RevitAddInManifest)
Visual C++
public:
static List<RevitAddInManifest^>^ GetRevitAddInManifests(
    String^ folderPath
)

Parameters

folderPath
Type: System..::.String
The folder that contains some .addin files.

Return Value

The collection of AddInManifests read from the file(s).

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

AddInManifestUtility Class


LanguageType Enumeration

[image]

Revit Add-In Utility 2011
LanguageType Enumeration
See Also Send Feedback
Defines the language type of Revit Add-In.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public enum LanguageType
Visual Basic (Declaration)
Public Enumeration LanguageType
Visual C++
public enum class LanguageType

Members

Member name | Description
Unknown | Unknown.
English_USA | English USA.
German | German.
Spanish | Spanish.
French | French.
Italian | Italian.
Dutch | Dutch.
Chinese_Simplified | Chinese Simplified.
Chinese_Traditional | Chinese Traditional.
Japanese | Japanese.
Korean | Korean.
Russian | Russian.

See Also

Autodesk.RevitAddIns Namespace

Send comments on this topic to Autodesk


RevitAddInApplication Class

[image]

Revit Add-In Utility 2011
RevitAddInApplication Class
Members See Also Send Feedback
Represents a Revit external application.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public class RevitAddInApplication : RevitAddInItem
Visual Basic (Declaration)
Public Class RevitAddInApplication _
    Inherits RevitAddInItem
Visual C++
public ref class RevitAddInApplication : public RevitAddInItem

Inheritance Hierarchy

System..::.Object
Autodesk.RevitAddIns..::.RevitAddInItem
Autodesk.RevitAddIns..::.RevitAddInApplication

See Also

RevitAddInApplication Members


RevitAddInApplication Members

[image] [image]

Revit Add-In Utility 2011
RevitAddInApplication Members
RevitAddInApplication Class Constructors Methods Properties See Also Send Feedback

The RevitAddInApplication type exposes the following members.

Constructors

Name | Description
RevitAddInApplication | Creates a new instance of the external application info class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier. (Inherited from RevitAddInItem.)
Assembly | The file path for the assembly which defines the Add-In. (Inherited from RevitAddInItem.)
FullClassName | The full class name for the class providing the entry point into the Add-In. (Inherited from RevitAddInItem.)
Name | Application name.
SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user. (Inherited from RevitAddInItem.)

See Also

RevitAddInApplication Class


RevitAddInApplication Constructor

[image]

Revit Add-In Utility 2011
RevitAddInApplication Constructor
RevitAddInApplication Class See Also Send Feedback
Creates a new instance of the external application info class.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public RevitAddInApplication(
    string name,
    string assembly,
    Guid addInId,
    string fullClassName
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    assembly As String, _
    addInId As Guid, _
    fullClassName As String _
)
Visual C++
public:
RevitAddInApplication(
    String^ name,
    String^ assembly,
    Guid addInId,
    String^ fullClassName
)

Parameters

name
Type: System..::.String
The application name.
assembly
Type: System..::.String
The path and file name for the application assembly.
addInId
Type: System..::.Guid
The unique identifier for the application.
fullClassName
Type: System..::.String
The class name that implements IExternalApplication.

See Also

RevitAddInApplication Class


RevitAddInApplication Methods

[image] [image]

Revit Add-In Utility 2011
RevitAddInApplication Methods
RevitAddInApplication Class See Also Send Feedback

The RevitAddInApplication type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitAddInApplication Class


RevitAddInApplication Properties

[image] [image]

Revit Add-In Utility 2011
RevitAddInApplication Properties
RevitAddInApplication Class See Also Send Feedback

The RevitAddInApplication type exposes the following members.

Properties

Name | Description
AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier. (Inherited from RevitAddInItem.)
Assembly | The file path for the assembly which defines the Add-In. (Inherited from RevitAddInItem.)
FullClassName | The full class name for the class providing the entry point into the Add-In. (Inherited from RevitAddInItem.)
Name | Application name.
SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user. (Inherited from RevitAddInItem.)

See Also

RevitAddInApplication Class


Name Property

[image]

Revit Add-In Utility 2011
RevitAddInApplication..::.Name Property
RevitAddInApplication Class See Also Send Feedback
Application name.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInApplication Class


RevitAddInCommand Class

[image]

Revit Add-In Utility 2011
RevitAddInCommand Class
Members See Also Send Feedback
Represents a Revit external command.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public class RevitAddInCommand : RevitAddInItem
Visual Basic (Declaration)
Public Class RevitAddInCommand _
    Inherits RevitAddInItem
Visual C++
public ref class RevitAddInCommand : public RevitAddInItem

Inheritance Hierarchy

System..::.Object
Autodesk.RevitAddIns..::.RevitAddInItem
Autodesk.RevitAddIns..::.RevitAddInCommand

See Also

RevitAddInCommand Members


RevitAddInCommand Members

[image] [image]

Revit Add-In Utility 2011
RevitAddInCommand Members
RevitAddInCommand Class Constructors Methods Properties See Also Send Feedback

The RevitAddInCommand type exposes the following members.

Constructors

Name | Description
RevitAddInCommand | Creates a new instance of the Add-In command info class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier. (Inherited from RevitAddInItem.)
Assembly | The file path for the assembly which defines the Add-In. (Inherited from RevitAddInItem.)
AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this command.
Description | The short description and short tooltip for the command.
FullClassName | The full class name for the class providing the entry point into the Add-In. (Inherited from RevitAddInItem.)
LanguageType |
LargeImage | The path to the large image for the command button.
LongDescription | The text shown in the extended command tooltip.
SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user. (Inherited from RevitAddInItem.)
Text | The text displayed on the external command button.
TooltipImage | The image shown in the extended command tooltip.
VisibilityMode | The modes in which the external command will be visible.

See Also

RevitAddInCommand Class


RevitAddInCommand Constructor

[image]

Revit Add-In Utility 2011
RevitAddInCommand Constructor
RevitAddInCommand Class See Also Send Feedback
Creates a new instance of the Add-In command info class.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public RevitAddInCommand(
    string assembly,
    Guid addInId,
    string fullClassName
)
Visual Basic (Declaration)
Public Sub New ( _
    assembly As String, _
    addInId As Guid, _
    fullClassName As String _
)
Visual C++
public:
RevitAddInCommand(
    String^ assembly,
    Guid addInId,
    String^ fullClassName
)

Parameters

assembly
Type: System..::.String
The path and file name for the command assembly.
addInId
Type: System..::.Guid
The unique identifier for the command.
fullClassName
Type: System..::.String
The class name that implements IExternalCommand.

See Also

RevitAddInCommand Class


RevitAddInCommand Methods

[image] [image]

Revit Add-In Utility 2011
RevitAddInCommand Methods
RevitAddInCommand Class See Also Send Feedback

The RevitAddInCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitAddInCommand Class


RevitAddInCommand Properties

[image] [image]

Revit Add-In Utility 2011
RevitAddInCommand Properties
RevitAddInCommand Class See Also Send Feedback

The RevitAddInCommand type exposes the following members.

Properties

Name | Description
AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier. (Inherited from RevitAddInItem.)
Assembly | The file path for the assembly which defines the Add-In. (Inherited from RevitAddInItem.)
AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this command.
Description | The short description and short tooltip for the command.
FullClassName | The full class name for the class providing the entry point into the Add-In. (Inherited from RevitAddInItem.)
LanguageType |
LargeImage | The path to the large image for the command button.
LongDescription | The text shown in the extended command tooltip.
SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user. (Inherited from RevitAddInItem.)
Text | The text displayed on the external command button.
TooltipImage | The image shown in the extended command tooltip.
VisibilityMode | The modes in which the external command will be visible.

See Also

RevitAddInCommand Class


AvailabilityClassName Property

[image]

Revit Add-In Utility 2011
RevitAddInCommand..::.AvailabilityClassName Property
RevitAddInCommand Class See Also Send Feedback
The full class name for the class providing the entry point to decide availability of this command.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public string AvailabilityClassName { get; set; }
Visual Basic (Declaration)
Public Property AvailabilityClassName As String
Visual C++
public:
property String^ AvailabilityClassName {
    String^ get ();
    void set (String^ value);
}

Remarks

This is the class implementing IExternalCommandAvailability interface.

See Also

RevitAddInCommand Class


Description Property

[image]

Revit Add-In Utility 2011
RevitAddInCommand..::.Description Property
RevitAddInCommand Class See Also Send Feedback
The short description and short tooltip for the command.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInCommand Class


LanguageType Property

[image]

Revit Add-In Utility 2011
RevitAddInCommand..::.LanguageType Property
RevitAddInCommand Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public LanguageType LanguageType { get; set; }
Visual Basic (Declaration)
Public Property LanguageType As LanguageType
Visual C++
public:
property LanguageType LanguageType {
    LanguageType get ();
    void set (LanguageType value);
}

See Also

RevitAddInCommand Class


LargeImage Property

[image]

Revit Add-In Utility 2011
RevitAddInCommand..::.LargeImage Property
RevitAddInCommand Class See Also Send Feedback
The path to the large image for the command button.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public string LargeImage { get; set; }
Visual Basic (Declaration)
Public Property LargeImage As String
Visual C++
public:
property String^ LargeImage {
    String^ get ();
    void set (String^ value);
}

Remarks

This image will be shown on the button in the External Tools pulldown. The image should be 32 x 32 pixels. If the image is larger it will be adjusted to fit the button.

See Also

RevitAddInCommand Class


LongDescription Property

[image]

Revit Add-In Utility 2011
RevitAddInCommand..::.LongDescription Property
RevitAddInCommand Class See Also Send Feedback
The text shown in the extended command tooltip.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public string LongDescription { get; set; }
Visual Basic (Declaration)
Public Property LongDescription As String
Visual C++
public:
property String^ LongDescription {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInCommand Class


Text Property

[image]

Revit Add-In Utility 2011
RevitAddInCommand..::.Text Property
RevitAddInCommand Class See Also Send Feedback
The text displayed on the external command button.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInCommand Class


TooltipImage Property

[image]

Revit Add-In Utility 2011
RevitAddInCommand..::.TooltipImage Property
RevitAddInCommand Class See Also Send Feedback
The image shown in the extended command tooltip.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public string TooltipImage { get; set; }
Visual Basic (Declaration)
Public Property TooltipImage As String
Visual C++
public:
property String^ TooltipImage {
    String^ get ();
    void set (String^ value);
}

Remarks

Recommended image size is 304 * 188 pixels.

See Also

RevitAddInCommand Class


VisibilityMode Property

[image]

Revit Add-In Utility 2011
RevitAddInCommand..::.VisibilityMode Property
RevitAddInCommand Class See Also Send Feedback
The modes in which the external command will be visible.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public VisibilityMode VisibilityMode { get; set; }
Visual Basic (Declaration)
Public Property VisibilityMode As VisibilityMode
Visual C++
public:
property VisibilityMode VisibilityMode {
    VisibilityMode get ();
    void set (VisibilityMode value);
}

Remarks

There are three sets of modes where visibility can be set:
  1. Visibility affected by the type of active document.
  2. Visibility affected by the availability of a certain discipline.
  3. Visibility affected by the active selection.

See Also

RevitAddInCommand Class


RevitAddInItem Class

[image]

Revit Add-In Utility 2011
RevitAddInItem Class
Members See Also Send Feedback
Represents a single Revit Add-In.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public class RevitAddInItem
Visual Basic (Declaration)
Public Class RevitAddInItem
Visual C++
public ref class RevitAddInItem

Inheritance Hierarchy

System..::.Object
Autodesk.RevitAddIns..::.RevitAddInItem
Autodesk.RevitAddIns..::.RevitAddInApplication
Autodesk.RevitAddIns..::.RevitAddInCommand

See Also

RevitAddInItem Members


RevitAddInItem Members

[image] [image]

Revit Add-In Utility 2011
RevitAddInItem Members
RevitAddInItem Class Methods Properties See Also Send Feedback

The RevitAddInItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier.
Assembly | The file path for the assembly which defines the Add-In.
FullClassName | The full class name for the class providing the entry point into the Add-In.
SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user.

See Also

RevitAddInItem Class


RevitAddInItem Methods

[image] [image]

Revit Add-In Utility 2011
RevitAddInItem Methods
RevitAddInItem Class See Also Send Feedback

The RevitAddInItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitAddInItem Class


RevitAddInItem Properties

[image] [image]

Revit Add-In Utility 2011
RevitAddInItem Properties
RevitAddInItem Class See Also Send Feedback

The RevitAddInItem type exposes the following members.

Properties

Name | Description
AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier.
Assembly | The file path for the assembly which defines the Add-In.
FullClassName | The full class name for the class providing the entry point into the Add-In.
SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user.

See Also

RevitAddInItem Class


AddInId Property

[image]

Revit Add-In Utility 2011
RevitAddInItem..::.AddInId Property
RevitAddInItem Class See Also Send Feedback
The id for the Add-In. Each add-in must be assigned a unique identifier.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public Guid AddInId { get; set; }
Visual Basic (Declaration)
Public Property AddInId As Guid
Visual C++
public:
property Guid AddInId {
    Guid get ();
    void set (Guid value);
}

See Also

RevitAddInItem Class


Assembly Property

[image]

Revit Add-In Utility 2011
RevitAddInItem..::.Assembly Property
RevitAddInItem Class See Also Send Feedback
The file path for the assembly which defines the Add-In.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public string Assembly { get; set; }
Visual Basic (Declaration)
Public Property Assembly As String
Visual C++
public:
property String^ Assembly {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInItem Class


FullClassName Property

[image]

Revit Add-In Utility 2011
RevitAddInItem..::.FullClassName Property
RevitAddInItem Class See Also Send Feedback
The full class name for the class providing the entry point into the Add-In.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public string FullClassName { get; set; }
Visual Basic (Declaration)
Public Property FullClassName As String
Visual C++
public:
property String^ FullClassName {
    String^ get ();
    void set (String^ value);
}

Remarks

This is the class implementing IExternalCommand or IExternalApplication.

See Also

RevitAddInItem Class


SuppressedWarning Property

[image]

Revit Add-In Utility 2011
RevitAddInItem..::.SuppressedWarning Property
RevitAddInItem Class See Also Send Feedback
A startup failure which, if it occurs, will be suppressed from the user.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public WarningType SuppressedWarning { get; set; }
Visual Basic (Declaration)
Public Property SuppressedWarning As WarningType
Visual C++
public:
property WarningType SuppressedWarning {
    WarningType get ();
    void set (WarningType value);
}

Remarks

When Revit attempts to start an Add-In and fails to do so, it will show a message to the user about the error. Users have the option to ignore that error in the future. This property is used to represent the user's choice to ignore an error. Note that if a different error occurs for the Add-In, it will still be shown to the user.

See Also

RevitAddInItem Class


RevitAddInManifest Class

[image]

Revit Add-In Utility 2011
RevitAddInManifest Class
Members See Also Send Feedback
Represents the contents of a single .addin file.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public class RevitAddInManifest
Visual Basic (Declaration)
Public Class RevitAddInManifest
Visual C++
public ref class RevitAddInManifest

Remarks

The manifest contains a collection of external commands and external applications listed in the .addin file.

Inheritance Hierarchy

System..::.Object
Autodesk.RevitAddIns..::.RevitAddInManifest

See Also

RevitAddInManifest Members


RevitAddInManifest Members

[image] [image]

Revit Add-In Utility 2011
RevitAddInManifest Members
RevitAddInManifest Class Constructors Methods Properties See Also Send Feedback

The RevitAddInManifest type exposes the following members.

Constructors

Name | Description
RevitAddInManifest | Constructs a new empty manifest.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Save | Saves the information in the manifest to its associated .addin file location.
SaveAs | Saves the information in the manifest as a new .addin file..
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AddInApplications | The collection of all external applications in the manifest.
AddInCommands | The collection of all external commands in the manifest.
FullName | The full path and file name which is associated with the manifest.
Name | The file name which is associated with the manifest.

See Also

RevitAddInManifest Class


RevitAddInManifest Constructor

[image]

Revit Add-In Utility 2011
RevitAddInManifest Constructor
RevitAddInManifest Class See Also Send Feedback
Constructs a new empty manifest.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public RevitAddInManifest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RevitAddInManifest()

See Also

RevitAddInManifest Class


RevitAddInManifest Methods

[image] [image]

Revit Add-In Utility 2011
RevitAddInManifest Methods
RevitAddInManifest Class See Also Send Feedback

The RevitAddInManifest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Save | Saves the information in the manifest to its associated .addin file location.
SaveAs | Saves the information in the manifest as a new .addin file..
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitAddInManifest Class


Save Method

[image]

Revit Add-In Utility 2011
RevitAddInManifest..::.Save Method
RevitAddInManifest Class See Also Send Feedback
Saves the information in the manifest to its associated .addin file location.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public void Save()
Visual Basic (Declaration)
Public Sub Save
Visual C++
public:
void Save()

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when FullName is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.
System..::.ArgumentException | Thrown when FullName is incorrect (it is not a .addin file). Or there are no external commands or applications to write to manifest file.
System.Xml..::.XmlException | The operation would not result in a well formed XML document (for example, no document element or duplicate XML declarations).

See Also

RevitAddInManifest Class


SaveAs Method

[image]

Revit Add-In Utility 2011
RevitAddInManifest..::.SaveAs Method
RevitAddInManifest Class See Also Send Feedback
Saves the information in the manifest as a new .addin file..

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public void SaveAs(
    string fileName
)
Visual Basic (Declaration)
Public Sub SaveAs ( _
    fileName As String _
)
Visual C++
public:
void SaveAs(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The full path and file name which is associated with the manifest.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when file name argument is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.
System..::.ArgumentException | Thrown when file name is incorrect (it is not a .addin file). Or there are no external commands or applications to write to manifest file.
System.Xml..::.XmlException | The operation would not result in a well formed XML document (for example, no document element or duplicate XML declarations).

See Also

RevitAddInManifest Class


RevitAddInManifest Properties

[image] [image]

Revit Add-In Utility 2011
RevitAddInManifest Properties
RevitAddInManifest Class See Also Send Feedback

The RevitAddInManifest type exposes the following members.

Properties

Name | Description
AddInApplications | The collection of all external applications in the manifest.
AddInCommands | The collection of all external commands in the manifest.
FullName | The full path and file name which is associated with the manifest.
Name | The file name which is associated with the manifest.

See Also

RevitAddInManifest Class


AddInApplications Property

[image]

Revit Add-In Utility 2011
RevitAddInManifest..::.AddInApplications Property
RevitAddInManifest Class See Also Send Feedback
The collection of all external applications in the manifest.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public List<RevitAddInApplication> AddInApplications { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddInApplications As List(Of RevitAddInApplication)
Visual C++
public:
property List<RevitAddInApplication^>^ AddInApplications {
    List<RevitAddInApplication^>^ get ();
}

See Also

RevitAddInManifest Class


AddInCommands Property

[image]

Revit Add-In Utility 2011
RevitAddInManifest..::.AddInCommands Property
RevitAddInManifest Class See Also Send Feedback
The collection of all external commands in the manifest.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public List<RevitAddInCommand> AddInCommands { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddInCommands As List(Of RevitAddInCommand)
Visual C++
public:
property List<RevitAddInCommand^>^ AddInCommands {
    List<RevitAddInCommand^>^ get ();
}

See Also

RevitAddInManifest Class


FullName Property

[image]

Revit Add-In Utility 2011
RevitAddInManifest..::.FullName Property
RevitAddInManifest Class See Also Send Feedback
The full path and file name which is associated with the manifest.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public string FullName { get; }
Visual Basic (Declaration)
Public ReadOnly Property FullName As String
Visual C++
public:
property String^ FullName {
    String^ get ();
}

See Also

RevitAddInManifest Class


Name Property

[image]

Revit Add-In Utility 2011
RevitAddInManifest..::.Name Property
RevitAddInManifest Class See Also Send Feedback
The file name which is associated with the manifest.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

RevitAddInManifest Class


RevitProduct Class

[image]

Revit Add-In Utility 2011
RevitProduct Class
Members See Also Send Feedback
Represents an installed instance of Revit on the local machine.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public class RevitProduct
Visual Basic (Declaration)
Public Class RevitProduct
Visual C++
public ref class RevitProduct

Inheritance Hierarchy

System..::.Object
Autodesk.RevitAddIns..::.RevitProduct

See Also

RevitProduct Members


RevitProduct Members

[image] [image]

Revit Add-In Utility 2011
RevitProduct Members
RevitProduct Class Methods Properties See Also Send Feedback

The RevitProduct type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllUsersAddInFolder | The folder path in which .addin files associated to all users will be located for this product.
Architecture | The system architecture of this Revit product installation.
Build | Build information for this Revit product. Such as: ’09.03.16211’.
CurrentUserAddInFolder | The folder path in which .addin files associated to the current user will be located for this product.
InstallLocation | The folder path where this Revit product is installed.
Name | User-visible name for this Revit product. such as : ‘Autodesk Revit Architecture 2010’.
ProductCode | The id used to locate and identify the Revit product from the registry.
Version | The version for this Revit product. Such as: ’2010’.

See Also

RevitProduct Class


RevitProduct Methods

[image] [image]

Revit Add-In Utility 2011
RevitProduct Methods
RevitProduct Class See Also Send Feedback

The RevitProduct type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitProduct Class


RevitProduct Properties

[image] [image]

Revit Add-In Utility 2011
RevitProduct Properties
RevitProduct Class See Also Send Feedback

The RevitProduct type exposes the following members.

Properties

Name | Description
AllUsersAddInFolder | The folder path in which .addin files associated to all users will be located for this product.
Architecture | The system architecture of this Revit product installation.
Build | Build information for this Revit product. Such as: ’09.03.16211’.
CurrentUserAddInFolder | The folder path in which .addin files associated to the current user will be located for this product.
InstallLocation | The folder path where this Revit product is installed.
Name | User-visible name for this Revit product. such as : ‘Autodesk Revit Architecture 2010’.
ProductCode | The id used to locate and identify the Revit product from the registry.
Version | The version for this Revit product. Such as: ’2010’.

See Also

RevitProduct Class


AllUsersAddInFolder Property

[image]

Revit Add-In Utility 2011
RevitProduct..::.AllUsersAddInFolder Property
RevitProduct Class See Also Send Feedback
The folder path in which .addin files associated to all users will be located for this product.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public string AllUsersAddInFolder { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllUsersAddInFolder As String
Visual C++
public:
property String^ AllUsersAddInFolder {
    String^ get ();
}

See Also

RevitProduct Class


Architecture Property

[image]

Revit Add-In Utility 2011
RevitProduct..::.Architecture Property
RevitProduct Class See Also Send Feedback
The system architecture of this Revit product installation.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public AddInArchitecture Architecture { get; }
Visual Basic (Declaration)
Public ReadOnly Property Architecture As AddInArchitecture
Visual C++
public:
property AddInArchitecture Architecture {
    AddInArchitecture get ();
}

See Also

RevitProduct Class


Build Property

[image]

Revit Add-In Utility 2011
RevitProduct..::.Build Property
RevitProduct Class See Also Send Feedback
Build information for this Revit product. Such as: ’09.03.16211’.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public string Build { get; }
Visual Basic (Declaration)
Public ReadOnly Property Build As String
Visual C++
public:
property String^ Build {
    String^ get ();
}

See Also

RevitProduct Class


CurrentUserAddInFolder Property

[image]

Revit Add-In Utility 2011
RevitProduct..::.CurrentUserAddInFolder Property
RevitProduct Class See Also Send Feedback
The folder path in which .addin files associated to the current user will be located for this product.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public string CurrentUserAddInFolder { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentUserAddInFolder As String
Visual C++
public:
property String^ CurrentUserAddInFolder {
    String^ get ();
}

See Also

RevitProduct Class


InstallLocation Property

[image]

Revit Add-In Utility 2011
RevitProduct..::.InstallLocation Property
RevitProduct Class See Also Send Feedback
The folder path where this Revit product is installed.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public string InstallLocation { get; }
Visual Basic (Declaration)
Public ReadOnly Property InstallLocation As String
Visual C++
public:
property String^ InstallLocation {
    String^ get ();
}

See Also

RevitProduct Class


Name Property

[image]

Revit Add-In Utility 2011
RevitProduct..::.Name Property
RevitProduct Class See Also Send Feedback
User-visible name for this Revit product. such as : ‘Autodesk Revit Architecture 2010’.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

RevitProduct Class


ProductCode Property

[image]

Revit Add-In Utility 2011
RevitProduct..::.ProductCode Property
RevitProduct Class See Also Send Feedback
The id used to locate and identify the Revit product from the registry.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public Guid ProductCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProductCode As Guid
Visual C++
public:
property Guid ProductCode {
    Guid get ();
}

See Also

RevitProduct Class


Version Property

[image]

Revit Add-In Utility 2011
RevitProduct..::.Version Property
RevitProduct Class See Also Send Feedback
The version for this Revit product. Such as: ’2010’.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public RevitVersion Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As RevitVersion
Visual C++
public:
property RevitVersion Version {
    RevitVersion get ();
}

See Also

RevitProduct Class


RevitProductUtility Class

[image]

Revit Add-In Utility 2011
RevitProductUtility Class
Members See Also Send Feedback
Provides access to installed versions of Revit on the local machine.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public static class RevitProductUtility
Visual Basic (Declaration)
Public NotInheritable Class RevitProductUtility
Visual C++
public ref class RevitProductUtility abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.RevitAddIns..::.RevitProductUtility

See Also

RevitProductUtility Members


RevitProductUtility Members

[image] [image]

Revit Add-In Utility 2011
RevitProductUtility Members
RevitProductUtility Class Methods See Also Send Feedback

The RevitProductUtility type exposes the following members.

Methods

Name | Description
GetAllInstalledRevitProducts | Gets a list of Revit products installed on this machine.

See Also

RevitProductUtility Class


RevitProductUtility Methods

[image] [image]

Revit Add-In Utility 2011
RevitProductUtility Methods
RevitProductUtility Class See Also Send Feedback

The RevitProductUtility type exposes the following members.

Methods

Name | Description
GetAllInstalledRevitProducts | Gets a list of Revit products installed on this machine.

See Also

RevitProductUtility Class


GetAllInstalledRevitProducts Method

[image]

Revit Add-In Utility 2011
RevitProductUtility..::.GetAllInstalledRevitProducts Method
RevitProductUtility Class See Also Send Feedback
Gets a list of Revit products installed on this machine.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public static List<RevitProduct> GetAllInstalledRevitProducts()
Visual Basic (Declaration)
Public Shared Function GetAllInstalledRevitProducts As List(Of RevitProduct)
Visual C++
public:
static List<RevitProduct^>^ GetAllInstalledRevitProducts()

Remarks

This operation parses the registry for necessary information about the installation(s). An incomplete or incorrect installation of Revit may not be returned correctly by this utility.

See Also

RevitProductUtility Class


RevitVersion Enumeration

[image]

Revit Add-In Utility 2011
RevitVersion Enumeration
See Also Send Feedback
Defines the versions of Revit supported by the Add-In utility.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public enum RevitVersion
Visual Basic (Declaration)
Public Enumeration RevitVersion
Visual C++
public enum class RevitVersion

Members

Member name | Description
Revit2011 | Revit 2011.

See Also

Autodesk.RevitAddIns Namespace

Send comments on this topic to Autodesk


VisibilityMode Enumeration

[image]

Revit Add-In Utility 2011
VisibilityMode Enumeration
See Also Send Feedback
Describes the conditions under which a particular external command will be visible in the Revit UI.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
[FlagsAttribute]
public enum VisibilityMode
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration VisibilityMode
Visual C++
[FlagsAttribute]
public enum class VisibilityMode

Members

Member name | Description
AlwaysVisible | The command is available in all possible modes supported by the Revit API.
NotVisibleInProject | The command is invisible when there is a project document active.
NotVisibleInFamily | The command is invisible when there is a family document active.
NotVisibleWhenNoActiveDocument | The command is invisible when there is no active document.
NotVisibleInArchitecture | The command is invisible in Autodesk Revit Architecture.
NotVisibleInStructure | The command is invisible in Autodesk Revit Structure
NotVisibleInMechanical | The command is invisible when the Mechanical discipline editing tools are available, e.g. in Autodesk Revit MEP.
NotVisibleInElectrical | The command is invisible when the Electrical discipline editing tools are available, e.g. in Autodesk Revit MEP.
NotVisibleInPlumbing | The command is invisible when the Plumbing discipline editing tools are available, e.g. in Autodesk Revit MEP.
NotVisibleInMEP | The command is invisible in Autodesk Revit MEP

Remarks

Note that there are a few conditions where the Revit API framework prevents commands from being available always:
  1. When the user has another Revit command active, e.g. creating Windows, Doors, or editing sketches.
  2. When the active view is in perspective mode, or when the view is a Legend, Schedule, Walkthrough, Material Takeoffs, Drawings Lists, View Lists, Note Blocks, View Lists, etc.
  3. When the user is editing an in-place family.

See Also

Autodesk.RevitAddIns Namespace

Send comments on this topic to Autodesk


WarningType Enumeration

[image]

Revit Add-In Utility 2011
WarningType Enumeration
See Also Send Feedback
Defines types of warnings issued by Revit related to Add-In failures.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 2011.0.0.0

Syntax

C#
public enum WarningType
Visual Basic (Declaration)
Public Enumeration WarningType
Visual C++
public enum class WarningType

Members

Member name | Description
NoWarning | There is no warning in this AddIn.
ClassNotFound | Revit could not find the indicated class in the assembly file.
WrongAssemblyPath | Revit could not find the assembly file.
UncaughtException | Unhandled exceptions were caught when the AddIn was executed.
GUIDConflict | There is another add-in which registered the same Id (GUID).
NoFullClassName | Missing the require value of FullClassName node.
NoClientId | Missing the require value of ClientId node.
NoAssembly | Missing the require value of Assembly node.
NoApplicationName | Missing the require value of Name node for application add-in.
InvalidFormatClientId | Revit could not interop.
WrongAvailabilityClass | Revit could not invoke IExternalCommandAvailability correctly.
UncaughtExceptionInAvailabilityClass | Unhandled exceptions were caught when the availability command was executed.
InvalidTransactionAttributeError | Not a valid transaction attribute.
InvalidRegenerationAttributeError | Not a valid regeneration attribute.

See Also

Autodesk.RevitAddIns Namespace

Send comments on this topic to Autodesk