Namespaces
Send Feedback

Namespaces

Namespace | Description
Autodesk.RevitAddIns |

Send comments on this topic to Autodesk


Autodesk.RevitAddIns Namespace

[image]

RevitAddInUtility 2018 API
Autodesk.RevitAddIns Namespace
Send Feedback

Classes

 | Class | Description
Public class | AddInManifestUtility | This static class provides access to read the contents of manifests from Revit .addin files.
Public class | RevitAddInApplication | Represents a Revit external application.
Public class | RevitAddInCommand | Represents a Revit external command.
Public class | RevitAddInDBApplication | Represents a Revit DB external application.
Public class | RevitAddInItem | Represents a single Revit Add-In.
Public class | RevitAddInManifest | Represents the contents of a single .addin file.
Public class | RevitProduct | Represents an installed instance of Revit on the local machine.
Public class | RevitProductUtility | Provides access to installed versions of Revit on the local machine.

Enumerations

 | Enumeration | Description
Public enumeration | AddInArchitecture | Defines the operating system architectures recognized by the Add-In utility.
Public enumeration | Discipline | Describes the conditions under which a particular external command will be visible in the Revit UI.
Public enumeration | LanguageType | Defines the language type of Revit Add-In.
Public enumeration | ProductType | An enumerated type containing the possible Revit product types.
Public enumeration | RevitVersion | Defines the versions of Revit supported by the Add-In utility.
Public enumeration | VisibilityMode | Describes the conditions under which a particular external command will be visible in the Revit UI.
Public enumeration | WarningType | Defines types of warnings issued by Revit related to Add-In failures.


AddInArchitecture Enumeration

[image]

RevitAddInUtility 2018 API
AddInArchitecture Enumeration
See Also Send Feedback
Defines the operating system architectures recognized by the Add-In utility.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public enum AddInArchitecture
Visual Basic
Public Enumeration AddInArchitecture
Visual C++
public enum class AddInArchitecture

Members

Member name | Description
OS32bit | 32-bit operating system.
OS64bit | 64-bit operating system.

See Also

Autodesk.RevitAddIns Namespace


AddInManifestUtility Class

[image]

RevitAddInUtility 2018 API
AddInManifestUtility Class
Members See Also Send Feedback
This static class provides access to read the contents of manifests from Revit .addin files.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public static class AddInManifestUtility
Visual Basic
Public NotInheritable Class AddInManifestUtility
Visual C++
public ref class AddInManifestUtility abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.RevitAddIns..::..AddInManifestUtility

See Also

AddInManifestUtility Members


AddInManifestUtility Members

[image] [image]

RevitAddInUtility 2018 API
AddInManifestUtility Members
AddInManifestUtility Class Methods See Also Send Feedback

The AddInManifestUtility type exposes the following members.

Methods

Name | Description
GetRevitAddInBundleManifests |
GetRevitAddInManifest | Reads an AddInManifest from the input .addin file.
GetRevitAddInManifests |

See Also

AddInManifestUtility Class


AddInManifestUtility Methods

[image] [image]

RevitAddInUtility 2018 API
AddInManifestUtility Methods
AddInManifestUtility Class See Also Send Feedback

The AddInManifestUtility type exposes the following members.

Methods

Name | Description
GetRevitAddInBundleManifests |
GetRevitAddInManifest | Reads an AddInManifest from the input .addin file.
GetRevitAddInManifests |

See Also

AddInManifestUtility Class


GetRevitAddInBundleManifests Method

[image]

RevitAddInUtility 2018 API
AddInManifestUtility..::..GetRevitAddInBundleManifests Method
AddInManifestUtility Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public static List<RevitAddInManifest> GetRevitAddInBundleManifests(
    string revitVersion,
    string osString,
    Dictionary<string, string> invalidFormatManifestDictionary
)
Visual Basic
Public Shared Function GetRevitAddInBundleManifests ( _
    revitVersion As String, _
    osString As String, _
    invalidFormatManifestDictionary As Dictionary(Of String, String) _
) As List(Of RevitAddInManifest)
Visual C++
public:
static List<RevitAddInManifest^>^ GetRevitAddInBundleManifests(
    String^ revitVersion,
    String^ osString,
    Dictionary<String^, String^>^ invalidFormatManifestDictionary
)

Parameters

revitVersion
Type: System..::..String
osString
Type: System..::..String
invalidFormatManifestDictionary
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>

See Also

AddInManifestUtility Class


GetRevitAddInManifest Method

[image]

RevitAddInUtility 2018 API
AddInManifestUtility..::..GetRevitAddInManifest Method
AddInManifestUtility Class See Also Send Feedback
Reads an AddInManifest from the input .addin file.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public static RevitAddInManifest GetRevitAddInManifest(
    string fileName
)
Visual Basic
Public Shared Function GetRevitAddInManifest ( _
    fileName As String _
) As RevitAddInManifest
Visual C++
public:
static RevitAddInManifest^ GetRevitAddInManifest(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The full path to a .addin file.

Return Value

The AddInManifest read from the file.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown when input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | Thrown when file name is incorrect (it is not a .addin file), or when the .addin file has an unrecognized format.

See Also

AddInManifestUtility Class


GetRevitAddInManifests Method

[image]

RevitAddInUtility 2018 API
AddInManifestUtility..::..GetRevitAddInManifests Method
AddInManifestUtility Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public static List<RevitAddInManifest> GetRevitAddInManifests(
    string folderPath,
    Dictionary<string, string> invalidFormatManifestDictionary
)
Visual Basic
Public Shared Function GetRevitAddInManifests ( _
    folderPath As String, _
    invalidFormatManifestDictionary As Dictionary(Of String, String) _
) As List(Of RevitAddInManifest)
Visual C++
public:
static List<RevitAddInManifest^>^ GetRevitAddInManifests(
    String^ folderPath,
    Dictionary<String^, String^>^ invalidFormatManifestDictionary
)

Parameters

folderPath
Type: System..::..String
invalidFormatManifestDictionary
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>

See Also

AddInManifestUtility Class


Discipline Enumeration

[image]

RevitAddInUtility 2018 API
Discipline Enumeration
See Also Send Feedback
Describes the conditions under which a particular external command will be visible in the Revit UI.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2013

Syntax

C#
public enum Discipline
Visual Basic
Public Enumeration Discipline
Visual C++
public enum class Discipline

Members

Member name | Description
Any | The command is available in all possible disciplines.
Architecture | The command is available in the Architecture discipline.
Structure | The command is available in the Structure discipline.
StructuralAnalysis | The command is available in the StructuralAnalysis discipline.
MassingAndSite | The command is available in the Massing and Site discipline.
EnergyAnalysis | The command is available in the EnergyAnalysis discipline.
Mechanical | The command is available in the Mechanical discipline.
Electrical | The command is available in the Electrical discipline.
Piping | The command is available in the Piping discipline.
MechanicalAnalysis | The command is available in the MechanicalAnalysis discipline.
PipingAnalysis | The command is available in the PipingAnalysis discipline.
ElectricalAnalysis | The command is available in the ElectricalAnalysis discipline.

Remarks

Note that there are a few conditions where the Revit API framework prevents commands from being available always:
  1. When the user has another Revit command active, e.g. creating Windows, Doors, or editing sketches.
  2. When the active view is in perspective mode, or when the view is a Walkthrough, Drawings Lists, View Lists, Note Blocks, View Lists, etc.

See Also

Autodesk.RevitAddIns Namespace

Send comments on this topic to Autodesk


LanguageType Enumeration

[image]

RevitAddInUtility 2018 API
LanguageType Enumeration
See Also Send Feedback
Defines the language type of Revit Add-In.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public enum LanguageType
Visual Basic
Public Enumeration LanguageType
Visual C++
public enum class LanguageType

Members

Member name | Description
Unknown | Unknown.
English_USA | English USA.
German | German.
Spanish | Spanish.
French | French.
Italian | Italian.
Dutch | Dutch.
Chinese_Simplified | Chinese Simplified.
Chinese_Traditional | Chinese Traditional.
Japanese | Japanese.
Korean | Korean.
Russian | Russian.
Czech | Czech.
Polish | Polish.
Hungarian | Hungarian.
Brazilian_Portuguese | Brazilian Portuguese.
English_GB | English GB.

See Also

Autodesk.RevitAddIns Namespace

Send comments on this topic to Autodesk


ProductType Enumeration

[image]

RevitAddInUtility 2018 API
ProductType Enumeration
See Also Send Feedback
An enumerated type containing the possible Revit product types.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2012

Syntax

C#
public enum ProductType
Visual Basic
Public Enumeration ProductType
Visual C++
public enum class ProductType

Members

Member name | Description
Architecture | Architecture.
Structure | Structure.
MEP | MEP.
Revit | Revit.
Unknown | Unknown.

See Also

Autodesk.RevitAddIns Namespace

Send comments on this topic to Autodesk


RevitAddInApplication Class

[image]

RevitAddInUtility 2018 API
RevitAddInApplication Class
Members See Also Send Feedback
Represents a Revit external application.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public class RevitAddInApplication : RevitAddInItem
Visual Basic
Public Class RevitAddInApplication _
    Inherits RevitAddInItem
Visual C++
public ref class RevitAddInApplication : public RevitAddInItem

Inheritance Hierarchy

System..::..Object
Autodesk.RevitAddIns..::..RevitAddInItem
Autodesk.RevitAddIns..::..RevitAddInApplication

See Also

RevitAddInApplication Members


RevitAddInApplication Members

[image] [image]

RevitAddInUtility 2018 API
RevitAddInApplication Members
RevitAddInApplication Class Constructors Methods Properties See Also Send Feedback

The RevitAddInApplication type exposes the following members.

Constructors

 | Name | Description
Public method | RevitAddInApplication | Creates a new instance of the external application info class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier. (Inherited from RevitAddInItem.)
Public property | AllowLoadingIntoExistingSession | The flag of loading permission. (Inherited from RevitAddInItem.)
Public property | Assembly | The file path for the assembly which defines the Add-In. (Inherited from RevitAddInItem.)
Public property | FullClassName | The full class name for the class providing the entry point into the Add-In. (Inherited from RevitAddInItem.)
Public property | Name | Application name.
Public property | ProductDescription | The product description. (Inherited from RevitAddInItem.)
Public property | ProductImage | The product image. (Inherited from RevitAddInItem.)
Public property | ProductVersion | The product version. (Inherited from RevitAddInItem.)
Public property | SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user. (Inherited from RevitAddInItem.)
Public property | VendorDescription | The vendor description. (Inherited from RevitAddInItem.)
Public property | VendorId | The vendor id. (Inherited from RevitAddInItem.)

See Also

RevitAddInApplication Class


RevitAddInApplication Constructor

[image]

RevitAddInUtility 2018 API
RevitAddInApplication Constructor
RevitAddInApplication Class See Also Send Feedback
Creates a new instance of the external application info class.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public RevitAddInApplication(
    string name,
    string assembly,
    Guid addInId,
    string fullClassName,
    string vendorId
)
Visual Basic
Public Sub New ( _
    name As String, _
    assembly As String, _
    addInId As Guid, _
    fullClassName As String, _
    vendorId As String _
)
Visual C++
public:
RevitAddInApplication(
    String^ name,
    String^ assembly,
    Guid addInId,
    String^ fullClassName,
    String^ vendorId
)

Parameters

name
Type: System..::..String
The application name.
assembly
Type: System..::..String
The path and file name for the application assembly.
addInId
Type: System..::..Guid
The unique identifier for the application.
fullClassName
Type: System..::..String
The class name that implements IExternalApplication.
vendorId
Type: System..::..String
The vendor id.

See Also

RevitAddInApplication Class


RevitAddInApplication Methods

[image] [image]

RevitAddInUtility 2018 API
RevitAddInApplication Methods
RevitAddInApplication Class See Also Send Feedback

The RevitAddInApplication type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RevitAddInApplication Class


RevitAddInApplication Properties

[image] [image]

RevitAddInUtility 2018 API
RevitAddInApplication Properties
RevitAddInApplication Class See Also Send Feedback

The RevitAddInApplication type exposes the following members.

Properties

 | Name | Description
Public property | AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier. (Inherited from RevitAddInItem.)
Public property | AllowLoadingIntoExistingSession | The flag of loading permission. (Inherited from RevitAddInItem.)
Public property | Assembly | The file path for the assembly which defines the Add-In. (Inherited from RevitAddInItem.)
Public property | FullClassName | The full class name for the class providing the entry point into the Add-In. (Inherited from RevitAddInItem.)
Public property | Name | Application name.
Public property | ProductDescription | The product description. (Inherited from RevitAddInItem.)
Public property | ProductImage | The product image. (Inherited from RevitAddInItem.)
Public property | ProductVersion | The product version. (Inherited from RevitAddInItem.)
Public property | SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user. (Inherited from RevitAddInItem.)
Public property | VendorDescription | The vendor description. (Inherited from RevitAddInItem.)
Public property | VendorId | The vendor id. (Inherited from RevitAddInItem.)

See Also

RevitAddInApplication Class


Name Property

[image]

RevitAddInUtility 2018 API
RevitAddInApplication..::..Name Property
RevitAddInApplication Class See Also Send Feedback
Application name.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInApplication Class


RevitAddInCommand Class

[image]

RevitAddInUtility 2018 API
RevitAddInCommand Class
Members See Also Send Feedback
Represents a Revit external command.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public class RevitAddInCommand : RevitAddInItem
Visual Basic
Public Class RevitAddInCommand _
    Inherits RevitAddInItem
Visual C++
public ref class RevitAddInCommand : public RevitAddInItem

Inheritance Hierarchy

System..::..Object
Autodesk.RevitAddIns..::..RevitAddInItem
Autodesk.RevitAddIns..::..RevitAddInCommand

See Also

RevitAddInCommand Members


RevitAddInCommand Members

[image] [image]

RevitAddInUtility 2018 API
RevitAddInCommand Members
RevitAddInCommand Class Constructors Methods Properties See Also Send Feedback

The RevitAddInCommand type exposes the following members.

Constructors

 | Name | Description
Public method | RevitAddInCommand | Creates a new instance of the Add-In command info class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier. (Inherited from RevitAddInItem.)
Public property | AllowLoadingIntoExistingSession | The flag of loading permission. (Inherited from RevitAddInItem.)
Public property | Assembly | The file path for the assembly which defines the Add-In. (Inherited from RevitAddInItem.)
Public property | AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this command.
Public property | Description | The short description and short tooltip for the command.
Public property | Discipline | The modes in which the external command will be visible.
Public property | FullClassName | The full class name for the class providing the entry point into the Add-In. (Inherited from RevitAddInItem.)
Public property | LanguageType |
Public property | LargeImage | The path to the large image for the command button.
Public property | LongDescription | The text shown in the extended command tooltip.
Public property | ProductDescription | The product description. (Inherited from RevitAddInItem.)
Public property | ProductImage | The product image. (Inherited from RevitAddInItem.)
Public property | ProductVersion | The product version. (Inherited from RevitAddInItem.)
Public property | SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user. (Inherited from RevitAddInItem.)
Public property | Text | The text displayed on the external command button.
Public property | TooltipImage | The image shown in the extended command tooltip.
Public property | VendorDescription | The vendor description. (Inherited from RevitAddInItem.)
Public property | VendorId | The vendor id. (Inherited from RevitAddInItem.)
Public property | VisibilityMode | The modes in which the external command will be visible.

See Also

RevitAddInCommand Class


RevitAddInCommand Constructor

[image]

RevitAddInUtility 2018 API
RevitAddInCommand Constructor
RevitAddInCommand Class See Also Send Feedback
Creates a new instance of the Add-In command info class.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public RevitAddInCommand(
    string assembly,
    Guid addInId,
    string fullClassName,
    string vendorId
)
Visual Basic
Public Sub New ( _
    assembly As String, _
    addInId As Guid, _
    fullClassName As String, _
    vendorId As String _
)
Visual C++
public:
RevitAddInCommand(
    String^ assembly,
    Guid addInId,
    String^ fullClassName,
    String^ vendorId
)

Parameters

assembly
Type: System..::..String
The path and file name for the command assembly.
addInId
Type: System..::..Guid
The unique identifier for the command.
fullClassName
Type: System..::..String
The class name that implements IExternalCommand.
vendorId
Type: System..::..String
The vendor id.

See Also

RevitAddInCommand Class


RevitAddInCommand Methods

[image] [image]

RevitAddInUtility 2018 API
RevitAddInCommand Methods
RevitAddInCommand Class See Also Send Feedback

The RevitAddInCommand type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RevitAddInCommand Class


RevitAddInCommand Properties

[image] [image]

RevitAddInUtility 2018 API
RevitAddInCommand Properties
RevitAddInCommand Class See Also Send Feedback

The RevitAddInCommand type exposes the following members.

Properties

 | Name | Description
Public property | AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier. (Inherited from RevitAddInItem.)
Public property | AllowLoadingIntoExistingSession | The flag of loading permission. (Inherited from RevitAddInItem.)
Public property | Assembly | The file path for the assembly which defines the Add-In. (Inherited from RevitAddInItem.)
Public property | AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this command.
Public property | Description | The short description and short tooltip for the command.
Public property | Discipline | The modes in which the external command will be visible.
Public property | FullClassName | The full class name for the class providing the entry point into the Add-In. (Inherited from RevitAddInItem.)
Public property | LanguageType |
Public property | LargeImage | The path to the large image for the command button.
Public property | LongDescription | The text shown in the extended command tooltip.
Public property | ProductDescription | The product description. (Inherited from RevitAddInItem.)
Public property | ProductImage | The product image. (Inherited from RevitAddInItem.)
Public property | ProductVersion | The product version. (Inherited from RevitAddInItem.)
Public property | SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user. (Inherited from RevitAddInItem.)
Public property | Text | The text displayed on the external command button.
Public property | TooltipImage | The image shown in the extended command tooltip.
Public property | VendorDescription | The vendor description. (Inherited from RevitAddInItem.)
Public property | VendorId | The vendor id. (Inherited from RevitAddInItem.)
Public property | VisibilityMode | The modes in which the external command will be visible.

See Also

RevitAddInCommand Class


AvailabilityClassName Property

[image]

RevitAddInUtility 2018 API
RevitAddInCommand..::..AvailabilityClassName Property
RevitAddInCommand Class See Also Send Feedback
The full class name for the class providing the entry point to decide availability of this command.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public string AvailabilityClassName { get; set; }
Visual Basic
Public Property AvailabilityClassName As String
    Get
    Set
Visual C++
public:
property String^ AvailabilityClassName {
    String^ get ();
    void set (String^ value);
}

Remarks

This is the class implementing IExternalCommandAvailability interface.

See Also

RevitAddInCommand Class


Description Property

[image]

RevitAddInUtility 2018 API
RevitAddInCommand..::..Description Property
RevitAddInCommand Class See Also Send Feedback
The short description and short tooltip for the command.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInCommand Class


Discipline Property

[image]

RevitAddInUtility 2018 API
RevitAddInCommand..::..Discipline Property
RevitAddInCommand Class See Also Send Feedback
The modes in which the external command will be visible.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2013

Syntax

C#
public Discipline Discipline { get; set; }
Visual Basic
Public Property Discipline As Discipline
    Get
    Set
Visual C++
public:
property Discipline Discipline {
    Discipline get ();
    void set (Discipline value);
}

Remarks

There is 1 set of mode where visibility can be set: Visibility affected by the availability of a certain discipline.

See Also

RevitAddInCommand Class


LanguageType Property

[image]

RevitAddInUtility 2018 API
RevitAddInCommand..::..LanguageType Property
RevitAddInCommand Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public LanguageType LanguageType { get; set; }
Visual Basic
Public Property LanguageType As LanguageType
    Get
    Set
Visual C++
public:
property LanguageType LanguageType {
    LanguageType get ();
    void set (LanguageType value);
}

See Also

RevitAddInCommand Class


LargeImage Property

[image]

RevitAddInUtility 2018 API
RevitAddInCommand..::..LargeImage Property
RevitAddInCommand Class See Also Send Feedback
The path to the large image for the command button.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public string LargeImage { get; set; }
Visual Basic
Public Property LargeImage As String
    Get
    Set
Visual C++
public:
property String^ LargeImage {
    String^ get ();
    void set (String^ value);
}

Remarks

This image will be shown on the button in the External Tools pulldown. The image should be 32 x 32 pixels. If the image is larger it will be adjusted to fit the button.

See Also

RevitAddInCommand Class


LongDescription Property

[image]

RevitAddInUtility 2018 API
RevitAddInCommand..::..LongDescription Property
RevitAddInCommand Class See Also Send Feedback
The text shown in the extended command tooltip.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public string LongDescription { get; set; }
Visual Basic
Public Property LongDescription As String
    Get
    Set
Visual C++
public:
property String^ LongDescription {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInCommand Class


Text Property

[image]

RevitAddInUtility 2018 API
RevitAddInCommand..::..Text Property
RevitAddInCommand Class See Also Send Feedback
The text displayed on the external command button.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInCommand Class


TooltipImage Property

[image]

RevitAddInUtility 2018 API
RevitAddInCommand..::..TooltipImage Property
RevitAddInCommand Class See Also Send Feedback
The image shown in the extended command tooltip.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public string TooltipImage { get; set; }
Visual Basic
Public Property TooltipImage As String
    Get
    Set
Visual C++
public:
property String^ TooltipImage {
    String^ get ();
    void set (String^ value);
}

Remarks

Recommended image size is 304 * 188 pixels.

See Also

RevitAddInCommand Class


VisibilityMode Property

[image]

RevitAddInUtility 2018 API
RevitAddInCommand..::..VisibilityMode Property
RevitAddInCommand Class See Also Send Feedback
The modes in which the external command will be visible.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public VisibilityMode VisibilityMode { get; set; }
Visual Basic
Public Property VisibilityMode As VisibilityMode
    Get
    Set
Visual C++
public:
property VisibilityMode VisibilityMode {
    VisibilityMode get ();
    void set (VisibilityMode value);
}

Remarks

There are 2 sets of modes where visibility can be set: Visibility affected by the type of active document.

See Also

RevitAddInCommand Class


RevitAddInDBApplication Class

[image]

RevitAddInUtility 2018 API
RevitAddInDBApplication Class
Members See Also Send Feedback
Represents a Revit DB external application.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public class RevitAddInDBApplication : RevitAddInItem
Visual Basic
Public Class RevitAddInDBApplication _
    Inherits RevitAddInItem
Visual C++
public ref class RevitAddInDBApplication : public RevitAddInItem

Inheritance Hierarchy

System..::..Object
Autodesk.RevitAddIns..::..RevitAddInItem
Autodesk.RevitAddIns..::..RevitAddInDBApplication

See Also

RevitAddInDBApplication Members


RevitAddInDBApplication Members

[image] [image]

RevitAddInUtility 2018 API
RevitAddInDBApplication Members
RevitAddInDBApplication Class Constructors Methods Properties See Also Send Feedback

The RevitAddInDBApplication type exposes the following members.

Constructors

 | Name | Description
Public method | RevitAddInDBApplication | Creates a new instance of the external DB application info class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier. (Inherited from RevitAddInItem.)
Public property | AllowLoadingIntoExistingSession | The flag of loading permission. (Inherited from RevitAddInItem.)
Public property | Assembly | The file path for the assembly which defines the Add-In. (Inherited from RevitAddInItem.)
Public property | FullClassName | The full class name for the class providing the entry point into the Add-In. (Inherited from RevitAddInItem.)
Public property | LoadInRevitWorker | Indicates whether or not a RevitWorker process will load this add-in.
Public property | Name | DB Application name.
Public property | ProductDescription | The product description. (Inherited from RevitAddInItem.)
Public property | ProductImage | The product image. (Inherited from RevitAddInItem.)
Public property | ProductVersion | The product version. (Inherited from RevitAddInItem.)
Public property | SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user. (Inherited from RevitAddInItem.)
Public property | VendorDescription | The vendor description. (Inherited from RevitAddInItem.)
Public property | VendorId | The vendor id. (Inherited from RevitAddInItem.)

See Also

RevitAddInDBApplication Class


RevitAddInDBApplication Constructor

[image]

RevitAddInUtility 2018 API
RevitAddInDBApplication Constructor
RevitAddInDBApplication Class See Also Send Feedback
Creates a new instance of the external DB application info class.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public RevitAddInDBApplication(
    string name,
    string assembly,
    Guid addInId,
    string fullClassName,
    string vendorId
)
Visual Basic
Public Sub New ( _
    name As String, _
    assembly As String, _
    addInId As Guid, _
    fullClassName As String, _
    vendorId As String _
)
Visual C++
public:
RevitAddInDBApplication(
    String^ name,
    String^ assembly,
    Guid addInId,
    String^ fullClassName,
    String^ vendorId
)

Parameters

name
Type: System..::..String
The DB application name.
assembly
Type: System..::..String
The path and file name for the DB application assembly.
addInId
Type: System..::..Guid
The unique identifier for the application.
fullClassName
Type: System..::..String
The class name that implements IExternalDBApplication.
vendorId
Type: System..::..String
The vendor id.

See Also

RevitAddInDBApplication Class


RevitAddInDBApplication Methods

[image] [image]

RevitAddInUtility 2018 API
RevitAddInDBApplication Methods
RevitAddInDBApplication Class See Also Send Feedback

The RevitAddInDBApplication type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RevitAddInDBApplication Class


RevitAddInDBApplication Properties

[image] [image]

RevitAddInUtility 2018 API
RevitAddInDBApplication Properties
RevitAddInDBApplication Class See Also Send Feedback

The RevitAddInDBApplication type exposes the following members.

Properties

 | Name | Description
Public property | AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier. (Inherited from RevitAddInItem.)
Public property | AllowLoadingIntoExistingSession | The flag of loading permission. (Inherited from RevitAddInItem.)
Public property | Assembly | The file path for the assembly which defines the Add-In. (Inherited from RevitAddInItem.)
Public property | FullClassName | The full class name for the class providing the entry point into the Add-In. (Inherited from RevitAddInItem.)
Public property | LoadInRevitWorker | Indicates whether or not a RevitWorker process will load this add-in.
Public property | Name | DB Application name.
Public property | ProductDescription | The product description. (Inherited from RevitAddInItem.)
Public property | ProductImage | The product image. (Inherited from RevitAddInItem.)
Public property | ProductVersion | The product version. (Inherited from RevitAddInItem.)
Public property | SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user. (Inherited from RevitAddInItem.)
Public property | VendorDescription | The vendor description. (Inherited from RevitAddInItem.)
Public property | VendorId | The vendor id. (Inherited from RevitAddInItem.)

See Also

RevitAddInDBApplication Class


LoadInRevitWorker Property

[image]

RevitAddInUtility 2018 API
RevitAddInDBApplication..::..LoadInRevitWorker Property
RevitAddInDBApplication Class See Also Send Feedback
Indicates whether or not a RevitWorker process will load this add-in.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2017

Syntax

C#
public bool LoadInRevitWorker { get; set; }
Visual Basic
Public Property LoadInRevitWorker As Boolean
    Get
    Set
Visual C++
public:
property bool LoadInRevitWorker {
    bool get ();
    void set (bool value);
}

Remarks

The default is false.

See Also

RevitAddInDBApplication Class


Name Property

[image]

RevitAddInUtility 2018 API
RevitAddInDBApplication..::..Name Property
RevitAddInDBApplication Class See Also Send Feedback
DB Application name.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInDBApplication Class


RevitAddInItem Class

[image]

RevitAddInUtility 2018 API
RevitAddInItem Class
Members See Also Send Feedback
Represents a single Revit Add-In.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public class RevitAddInItem
Visual Basic
Public Class RevitAddInItem
Visual C++
public ref class RevitAddInItem

Inheritance Hierarchy

System..::..Object
Autodesk.RevitAddIns..::..RevitAddInItem
Autodesk.RevitAddIns..::..RevitAddInApplication
Autodesk.RevitAddIns..::..RevitAddInCommand
Autodesk.RevitAddIns..::..RevitAddInDBApplication

See Also

RevitAddInItem Members


RevitAddInItem Members

[image] [image]

RevitAddInUtility 2018 API
RevitAddInItem Members
RevitAddInItem Class Methods Properties See Also Send Feedback

The RevitAddInItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier.
Public property | AllowLoadingIntoExistingSession | The flag of loading permission.
Public property | Assembly | The file path for the assembly which defines the Add-In.
Public property | FullClassName | The full class name for the class providing the entry point into the Add-In.
Public property | ProductDescription | The product description.
Public property | ProductImage | The product image.
Public property | ProductVersion | The product version.
Public property | SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user.
Public property | VendorDescription | The vendor description.
Public property | VendorId | The vendor id.

See Also

RevitAddInItem Class


RevitAddInItem Methods

[image] [image]

RevitAddInUtility 2018 API
RevitAddInItem Methods
RevitAddInItem Class See Also Send Feedback

The RevitAddInItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RevitAddInItem Class


RevitAddInItem Properties

[image] [image]

RevitAddInUtility 2018 API
RevitAddInItem Properties
RevitAddInItem Class See Also Send Feedback

The RevitAddInItem type exposes the following members.

Properties

 | Name | Description
Public property | AddInId | The id for the Add-In. Each add-in must be assigned a unique identifier.
Public property | AllowLoadingIntoExistingSession | The flag of loading permission.
Public property | Assembly | The file path for the assembly which defines the Add-In.
Public property | FullClassName | The full class name for the class providing the entry point into the Add-In.
Public property | ProductDescription | The product description.
Public property | ProductImage | The product image.
Public property | ProductVersion | The product version.
Public property | SuppressedWarning | A startup failure which, if it occurs, will be suppressed from the user.
Public property | VendorDescription | The vendor description.
Public property | VendorId | The vendor id.

See Also

RevitAddInItem Class


AddInId Property

[image]

RevitAddInUtility 2018 API
RevitAddInItem..::..AddInId Property
RevitAddInItem Class See Also Send Feedback
The id for the Add-In. Each add-in must be assigned a unique identifier.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public Guid AddInId { get; set; }
Visual Basic
Public Property AddInId As Guid
    Get
    Set
Visual C++
public:
property Guid AddInId {
    Guid get ();
    void set (Guid value);
}

See Also

RevitAddInItem Class


AllowLoadingIntoExistingSession Property

[image]

RevitAddInUtility 2018 API
RevitAddInItem..::..AllowLoadingIntoExistingSession Property
RevitAddInItem Class See Also Send Feedback
The flag of loading permission.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2014

Syntax

C#
public bool AllowLoadingIntoExistingSession { get; set; }
Visual Basic
Public Property AllowLoadingIntoExistingSession As Boolean
    Get
    Set
Visual C++
public:
property bool AllowLoadingIntoExistingSession {
    bool get ();
    void set (bool value);
}

See Also

RevitAddInItem Class


Assembly Property

[image]

RevitAddInUtility 2018 API
RevitAddInItem..::..Assembly Property
RevitAddInItem Class See Also Send Feedback
The file path for the assembly which defines the Add-In.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public string Assembly { get; set; }
Visual Basic
Public Property Assembly As String
    Get
    Set
Visual C++
public:
property String^ Assembly {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInItem Class


FullClassName Property

[image]

RevitAddInUtility 2018 API
RevitAddInItem..::..FullClassName Property
RevitAddInItem Class See Also Send Feedback
The full class name for the class providing the entry point into the Add-In.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public string FullClassName { get; set; }
Visual Basic
Public Property FullClassName As String
    Get
    Set
Visual C++
public:
property String^ FullClassName {
    String^ get ();
    void set (String^ value);
}

Remarks

This is the class implementing IExternalCommand or IExternalApplication.

See Also

RevitAddInItem Class


ProductDescription Property

[image]

RevitAddInUtility 2018 API
RevitAddInItem..::..ProductDescription Property
RevitAddInItem Class See Also Send Feedback
The product description.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2014

Syntax

C#
public string ProductDescription { get; set; }
Visual Basic
Public Property ProductDescription As String
    Get
    Set
Visual C++
public:
property String^ ProductDescription {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInItem Class


ProductImage Property

[image]

RevitAddInUtility 2018 API
RevitAddInItem..::..ProductImage Property
RevitAddInItem Class See Also Send Feedback
The product image.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2014

Syntax

C#
public string ProductImage { get; set; }
Visual Basic
Public Property ProductImage As String
    Get
    Set
Visual C++
public:
property String^ ProductImage {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInItem Class


ProductVersion Property

[image]

RevitAddInUtility 2018 API
RevitAddInItem..::..ProductVersion Property
RevitAddInItem Class See Also Send Feedback
The product version.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2014

Syntax

C#
public string ProductVersion { get; set; }
Visual Basic
Public Property ProductVersion As String
    Get
    Set
Visual C++
public:
property String^ ProductVersion {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInItem Class


SuppressedWarning Property

[image]

RevitAddInUtility 2018 API
RevitAddInItem..::..SuppressedWarning Property
RevitAddInItem Class See Also Send Feedback
A startup failure which, if it occurs, will be suppressed from the user.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public WarningType SuppressedWarning { get; set; }
Visual Basic
Public Property SuppressedWarning As WarningType
    Get
    Set
Visual C++
public:
property WarningType SuppressedWarning {
    WarningType get ();
    void set (WarningType value);
}

Remarks

When Revit attempts to start an Add-In and fails to do so, it will show a message to the user about the error. Users have the option to ignore that error in the future. This property is used to represent the user's choice to ignore an error. Note that if a different error occurs for the Add-In, it will still be shown to the user.

See Also

RevitAddInItem Class


VendorDescription Property

[image]

RevitAddInUtility 2018 API
RevitAddInItem..::..VendorDescription Property
RevitAddInItem Class See Also Send Feedback
The vendor description.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public string VendorDescription { get; set; }
Visual Basic
Public Property VendorDescription As String
    Get
    Set
Visual C++
public:
property String^ VendorDescription {
    String^ get ();
    void set (String^ value);
}

Remarks

This should be a string that the user can use to identify the vendor.

See Also

RevitAddInItem Class


VendorId Property

[image]

RevitAddInUtility 2018 API
RevitAddInItem..::..VendorId Property
RevitAddInItem Class See Also Send Feedback
The vendor id.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public string VendorId { get; set; }
Visual Basic
Public Property VendorId As String
    Get
    Set
Visual C++
public:
property String^ VendorId {
    String^ get ();
    void set (String^ value);
}

Remarks

This is required by add-in application.

See Also

RevitAddInItem Class


RevitAddInManifest Class

[image]

RevitAddInUtility 2018 API
RevitAddInManifest Class
Members See Also Send Feedback
Represents the contents of a single .addin file.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public class RevitAddInManifest
Visual Basic
Public Class RevitAddInManifest
Visual C++
public ref class RevitAddInManifest

Remarks

The manifest contains a collection of external commands and external applications listed in the .addin file.

Inheritance Hierarchy

System..::..Object
Autodesk.RevitAddIns..::..RevitAddInManifest

See Also

RevitAddInManifest Members


RevitAddInManifest Members

[image] [image]

RevitAddInUtility 2018 API
RevitAddInManifest Members
RevitAddInManifest Class Constructors Methods Properties See Also Send Feedback

The RevitAddInManifest type exposes the following members.

Constructors

 | Name | Description
Public method | RevitAddInManifest | Constructs a new empty manifest.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Save | Saves the information in the manifest to its associated .addin file location.
Public method | SaveAs | Saves the information in the manifest as a new .addin file..
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddInApplications | The collection of all external applications in the manifest.
Public property | AddInCommands | The collection of all external commands in the manifest.
Public property | AddInDBApplications | The collection of all external DB applications in the manifest.
Public property | FullName | The full path and file name which is associated with the manifest.
Public property | Name | The file name which is associated with the manifest.

See Also

RevitAddInManifest Class


RevitAddInManifest Constructor

[image]

RevitAddInUtility 2018 API
RevitAddInManifest Constructor
RevitAddInManifest Class See Also Send Feedback
Constructs a new empty manifest.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public RevitAddInManifest()
Visual Basic
Public Sub New
Visual C++
public:
RevitAddInManifest()

See Also

RevitAddInManifest Class


RevitAddInManifest Methods

[image] [image]

RevitAddInUtility 2018 API
RevitAddInManifest Methods
RevitAddInManifest Class See Also Send Feedback

The RevitAddInManifest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Save | Saves the information in the manifest to its associated .addin file location.
Public method | SaveAs | Saves the information in the manifest as a new .addin file..
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RevitAddInManifest Class


Save Method

[image]

RevitAddInUtility 2018 API
RevitAddInManifest..::..Save Method
RevitAddInManifest Class See Also Send Feedback
Saves the information in the manifest to its associated .addin file location.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public void Save()
Visual Basic
Public Sub Save
Visual C++
public:
void Save()

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown when FullName is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.
System..::..ArgumentException | Thrown when FullName is incorrect (it is not a .addin file). Or there are no external commands or applications to write to manifest file.
System.Xml..::..XmlException | The operation would not result in a well formed XML document (for example, no document element or duplicate XML declarations).

See Also

RevitAddInManifest Class


SaveAs Method

[image]

RevitAddInUtility 2018 API
RevitAddInManifest..::..SaveAs Method
RevitAddInManifest Class See Also Send Feedback
Saves the information in the manifest as a new .addin file..

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public void SaveAs(
    string fileName
)
Visual Basic
Public Sub SaveAs ( _
    fileName As String _
)
Visual C++
public:
void SaveAs(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The full path and file name which is associated with the manifest.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown when file name argument is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.
System..::..ArgumentException | Thrown when file name is incorrect (it is not a .addin file). Or there are no external commands or applications to write to manifest file.
System.Xml..::..XmlException | The operation would not result in a well formed XML document (for example, no document element or duplicate XML declarations).

See Also

RevitAddInManifest Class


RevitAddInManifest Properties

[image] [image]

RevitAddInUtility 2018 API
RevitAddInManifest Properties
RevitAddInManifest Class See Also Send Feedback

The RevitAddInManifest type exposes the following members.

Properties

 | Name | Description
Public property | AddInApplications | The collection of all external applications in the manifest.
Public property | AddInCommands | The collection of all external commands in the manifest.
Public property | AddInDBApplications | The collection of all external DB applications in the manifest.
Public property | FullName | The full path and file name which is associated with the manifest.
Public property | Name | The file name which is associated with the manifest.

See Also

RevitAddInManifest Class


AddInApplications Property

[image]

RevitAddInUtility 2018 API
RevitAddInManifest..::..AddInApplications Property
RevitAddInManifest Class See Also Send Feedback
The collection of all external applications in the manifest.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public List<RevitAddInApplication> AddInApplications { get; }
Visual Basic
Public ReadOnly Property AddInApplications As List(Of RevitAddInApplication)
    Get
Visual C++
public:
property List<RevitAddInApplication^>^ AddInApplications {
    List<RevitAddInApplication^>^ get ();
}

See Also

RevitAddInManifest Class


AddInCommands Property

[image]

RevitAddInUtility 2018 API
RevitAddInManifest..::..AddInCommands Property
RevitAddInManifest Class See Also Send Feedback
The collection of all external commands in the manifest.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public List<RevitAddInCommand> AddInCommands { get; }
Visual Basic
Public ReadOnly Property AddInCommands As List(Of RevitAddInCommand)
    Get
Visual C++
public:
property List<RevitAddInCommand^>^ AddInCommands {
    List<RevitAddInCommand^>^ get ();
}

See Also

RevitAddInManifest Class


AddInDBApplications Property

[image]

RevitAddInUtility 2018 API
RevitAddInManifest..::..AddInDBApplications Property
RevitAddInManifest Class See Also Send Feedback
The collection of all external DB applications in the manifest.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public List<RevitAddInDBApplication> AddInDBApplications { get; }
Visual Basic
Public ReadOnly Property AddInDBApplications As List(Of RevitAddInDBApplication)
    Get
Visual C++
public:
property List<RevitAddInDBApplication^>^ AddInDBApplications {
    List<RevitAddInDBApplication^>^ get ();
}

See Also

RevitAddInManifest Class


FullName Property

[image]

RevitAddInUtility 2018 API
RevitAddInManifest..::..FullName Property
RevitAddInManifest Class See Also Send Feedback
The full path and file name which is associated with the manifest.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public string FullName { get; }
Visual Basic
Public ReadOnly Property FullName As String
    Get
Visual C++
public:
property String^ FullName {
    String^ get ();
}

See Also

RevitAddInManifest Class


Name Property

[image]

RevitAddInUtility 2018 API
RevitAddInManifest..::..Name Property
RevitAddInManifest Class See Also Send Feedback
The file name which is associated with the manifest.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

RevitAddInManifest Class


RevitProduct Class

[image]

RevitAddInUtility 2018 API
RevitProduct Class
Members See Also Send Feedback
Represents an installed instance of Revit on the local machine.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public class RevitProduct
Visual Basic
Public Class RevitProduct
Visual C++
public ref class RevitProduct

Inheritance Hierarchy

System..::..Object
Autodesk.RevitAddIns..::..RevitProduct

See Also

RevitProduct Members


RevitProduct Members

[image] [image]

RevitAddInUtility 2018 API
RevitProduct Members
RevitProduct Class Methods Properties See Also Send Feedback

The RevitProduct type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInstalledLanguages | Gets the installed language types.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllUsersAddInFolder | The folder path in which .addin files associated to all users will be located for this product.
Public property | Architecture | The system architecture of this Revit product installation.
Public property | CurrentUserAddInFolder | The folder path in which .addin files associated to the current user will be located for this product.
Public property | InstallLocation | The folder path where this Revit product is installed.
Public property | IsSubscriptionUpdate | Obsolete. True if this version of Revit is a subscription update.
Public property | Name | User-visible name for this Revit product. such as : 'Autodesk Revit Architecture 2010'.
Public property | Product | The product type.
Public property | ProductCode | The id used to locate and identify the Revit product from the registry.
Public property | ReleaseSubVersion | The string for the release sub versions.
Public property | Subversion | The release subversion.
Public property | Version | The version for this Revit product. Such as: '2010'.

See Also

RevitProduct Class


RevitProduct Methods

[image] [image]

RevitAddInUtility 2018 API
RevitProduct Methods
RevitProduct Class See Also Send Feedback

The RevitProduct type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInstalledLanguages | Gets the installed language types.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RevitProduct Class


GetInstalledLanguages Method

[image]

RevitAddInUtility 2018 API
RevitProduct..::..GetInstalledLanguages Method
RevitProduct Class See Also Send Feedback
Gets the installed language types.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2014

Syntax

C#
public ICollection<LanguageType> GetInstalledLanguages()
Visual Basic
Public Function GetInstalledLanguages As ICollection(Of LanguageType)
Visual C++
public:
ICollection<LanguageType>^ GetInstalledLanguages()

Return Value

The installed language types.

See Also

RevitProduct Class


RevitProduct Properties

[image] [image]

RevitAddInUtility 2018 API
RevitProduct Properties
RevitProduct Class See Also Send Feedback

The RevitProduct type exposes the following members.

Properties

 | Name | Description
Public property | AllUsersAddInFolder | The folder path in which .addin files associated to all users will be located for this product.
Public property | Architecture | The system architecture of this Revit product installation.
Public property | CurrentUserAddInFolder | The folder path in which .addin files associated to the current user will be located for this product.
Public property | InstallLocation | The folder path where this Revit product is installed.
Public property | IsSubscriptionUpdate | Obsolete. True if this version of Revit is a subscription update.
Public property | Name | User-visible name for this Revit product. such as : 'Autodesk Revit Architecture 2010'.
Public property | Product | The product type.
Public property | ProductCode | The id used to locate and identify the Revit product from the registry.
Public property | ReleaseSubVersion | The string for the release sub versions.
Public property | Subversion | The release subversion.
Public property | Version | The version for this Revit product. Such as: '2010'.

See Also

RevitProduct Class


AllUsersAddInFolder Property

[image]

RevitAddInUtility 2018 API
RevitProduct..::..AllUsersAddInFolder Property
RevitProduct Class See Also Send Feedback
The folder path in which .addin files associated to all users will be located for this product.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public string AllUsersAddInFolder { get; }
Visual Basic
Public ReadOnly Property AllUsersAddInFolder As String
    Get
Visual C++
public:
property String^ AllUsersAddInFolder {
    String^ get ();
}

See Also

RevitProduct Class


Architecture Property

[image]

RevitAddInUtility 2018 API
RevitProduct..::..Architecture Property
RevitProduct Class See Also Send Feedback
The system architecture of this Revit product installation.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public AddInArchitecture Architecture { get; }
Visual Basic
Public ReadOnly Property Architecture As AddInArchitecture
    Get
Visual C++
public:
property AddInArchitecture Architecture {
    AddInArchitecture get ();
}

See Also

RevitProduct Class


CurrentUserAddInFolder Property

[image]

RevitAddInUtility 2018 API
RevitProduct..::..CurrentUserAddInFolder Property
RevitProduct Class See Also Send Feedback
The folder path in which .addin files associated to the current user will be located for this product.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public string CurrentUserAddInFolder { get; }
Visual Basic
Public ReadOnly Property CurrentUserAddInFolder As String
    Get
Visual C++
public:
property String^ CurrentUserAddInFolder {
    String^ get ();
}

See Also

RevitProduct Class


InstallLocation Property

[image]

RevitAddInUtility 2018 API
RevitProduct..::..InstallLocation Property
RevitProduct Class See Also Send Feedback
The folder path where this Revit product is installed.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public string InstallLocation { get; }
Visual Basic
Public ReadOnly Property InstallLocation As String
    Get
Visual C++
public:
property String^ InstallLocation {
    String^ get ();
}

See Also

RevitProduct Class


IsSubscriptionUpdate Property

[image]

RevitAddInUtility 2018 API
RevitProduct..::..IsSubscriptionUpdate Property
RevitProduct Class See Also Send Feedback
True if this version of Revit is a subscription update.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2015 Subscription Update

Syntax

C#
[ObsoleteAttribute("This property is deprecated in Revit 2018 and will be removed in the next version of Revit. We suggest you use the ReleaseSubVersion property instead.")]
public bool IsSubscriptionUpdate { get; }
Visual Basic
<ObsoleteAttribute("This property is deprecated in Revit 2018 and will be removed in the next version of Revit. We suggest you use the ReleaseSubVersion property instead.")> _
Public ReadOnly Property IsSubscriptionUpdate As Boolean
    Get
Visual C++
[ObsoleteAttribute(L"This property is deprecated in Revit 2018 and will be removed in the next version of Revit. We suggest you use the ReleaseSubVersion property instead.")]
public:
property bool IsSubscriptionUpdate {
    bool get ();
}

Remarks

Subscription update releases may have additional APIs and functionality not available in the standard customer releases. Add-ins written to support standard Revit releases should be compatible with subscription updates, but add-ins written specifically targeting new features in subscription updates would not be compatible with the standard releases.

See Also

RevitProduct Class


Name Property

[image]

RevitAddInUtility 2018 API
RevitProduct..::..Name Property
RevitProduct Class See Also Send Feedback
User-visible name for this Revit product. such as : 'Autodesk Revit Architecture 2010'.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

RevitProduct Class


Product Property

[image]

RevitAddInUtility 2018 API
RevitProduct..::..Product Property
RevitProduct Class See Also Send Feedback
The product type.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2012

Syntax

C#
public ProductType Product { get; }
Visual Basic
Public ReadOnly Property Product As ProductType
    Get
Visual C++
public:
property ProductType Product {
    ProductType get ();
}

See Also

RevitProduct Class


ProductCode Property

[image]

RevitAddInUtility 2018 API
RevitProduct..::..ProductCode Property
RevitProduct Class See Also Send Feedback
The id used to locate and identify the Revit product from the registry.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public Guid ProductCode { get; }
Visual Basic
Public ReadOnly Property ProductCode As Guid
    Get
Visual C++
public:
property Guid ProductCode {
    Guid get ();
}

See Also

RevitProduct Class


ReleaseSubVersion Property

[image]

RevitAddInUtility 2018 API
RevitProduct..::..ReleaseSubVersion Property
RevitProduct Class See Also Send Feedback
The string for the release sub versions.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2018

Syntax

C#
public string ReleaseSubVersion { get; }
Visual Basic
Public ReadOnly Property ReleaseSubVersion As String
    Get
Visual C++
public:
property String^ ReleaseSubVersion {
    String^ get ();
}

Remarks

SubVersion releases may have additional APIs and functionality not available in the standard customer releases. Add-ins written to support standard Revit releases should be compatible with Subversion releases, but add-ins written specifically targeting new features in Subversion releases would not be compatible with the standard releases.

See Also

RevitProduct Class


Subversion Property

[image]

RevitAddInUtility 2018 API
RevitProduct..::..Subversion Property
RevitProduct Class See Also Send Feedback
The release subversion.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2012

Syntax

C#
public uint Subversion { get; }
Visual Basic
Public ReadOnly Property Subversion As UInteger
    Get
Visual C++
public:
property unsigned int Subversion {
    unsigned int get ();
}

See Also

RevitProduct Class


Version Property

[image]

RevitAddInUtility 2018 API
RevitProduct..::..Version Property
RevitProduct Class See Also Send Feedback
The version for this Revit product. Such as: '2010'.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public RevitVersion Version { get; }
Visual Basic
Public ReadOnly Property Version As RevitVersion
    Get
Visual C++
public:
property RevitVersion Version {
    RevitVersion get ();
}

See Also

RevitProduct Class


RevitProductUtility Class

[image]

RevitAddInUtility 2018 API
RevitProductUtility Class
Members See Also Send Feedback
Provides access to installed versions of Revit on the local machine.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public static class RevitProductUtility
Visual Basic
Public NotInheritable Class RevitProductUtility
Visual C++
public ref class RevitProductUtility abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.RevitAddIns..::..RevitProductUtility

See Also

RevitProductUtility Members


RevitProductUtility Members

[image] [image]

RevitAddInUtility 2018 API
RevitProductUtility Members
RevitProductUtility Class Methods See Also Send Feedback

The RevitProductUtility type exposes the following members.

Methods

Name | Description
GetAllInstalledRevitProducts | Gets a list of Revit products installed on this machine.

See Also

RevitProductUtility Class


RevitProductUtility Methods

[image] [image]

RevitAddInUtility 2018 API
RevitProductUtility Methods
RevitProductUtility Class See Also Send Feedback

The RevitProductUtility type exposes the following members.

Methods

Name | Description
GetAllInstalledRevitProducts | Gets a list of Revit products installed on this machine.

See Also

RevitProductUtility Class


GetAllInstalledRevitProducts Method

[image]

RevitAddInUtility 2018 API
RevitProductUtility..::..GetAllInstalledRevitProducts Method
RevitProductUtility Class See Also Send Feedback
Gets a list of Revit products installed on this machine.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public static List<RevitProduct> GetAllInstalledRevitProducts()
Visual Basic
Public Shared Function GetAllInstalledRevitProducts As List(Of RevitProduct)
Visual C++
public:
static List<RevitProduct^>^ GetAllInstalledRevitProducts()

Remarks

This operation parses the registry for necessary information about the installation(s). An incomplete or incorrect installation of Revit may not be returned correctly by this utility.

See Also

RevitProductUtility Class


RevitVersion Enumeration

[image]

RevitAddInUtility 2018 API
RevitVersion Enumeration
See Also Send Feedback
Defines the versions of Revit supported by the Add-In utility.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public enum RevitVersion
Visual Basic
Public Enumeration RevitVersion
Visual C++
public enum class RevitVersion

Members

Member name | Description
Unknown | Unknown.
Revit2011 | Revit 2011.
Revit2012 | Revit 2012.
Revit2013 | Revit 2013.
Revit2014 | Revit 2014.
Revit2015 | Revit 2015.
Revit2016 | Revit 2016.
Revit2017 | Revit 2017.
Revit2018 | Revit 2018.

See Also

Autodesk.RevitAddIns Namespace

Send comments on this topic to Autodesk


VisibilityMode Enumeration

[image]

RevitAddInUtility 2018 API
VisibilityMode Enumeration
See Also Send Feedback
Describes the conditions under which a particular external command will be visible in the Revit UI.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
[FlagsAttribute]
public enum VisibilityMode
Visual Basic
<FlagsAttribute> _
Public Enumeration VisibilityMode
Visual C++
[FlagsAttribute]
public enum class VisibilityMode

Members

Member name | Description
AlwaysVisible | The command is available in all possible modes supported by the Revit API.
NotVisibleInProject | The command is invisible when there is a project document active.
NotVisibleInFamily | The command is invisible when there is a family document active.
NotVisibleWhenNoActiveDocument | The command is invisible when there is no active document.

Remarks

Note that there are a few conditions where the Revit API framework prevents commands from being available always:
  1. When the user has another Revit command active, e.g. creating Windows, Doors, or editing sketches.
  2. When the active view is in perspective mode, or when the view is a Walkthrough, Drawings Lists, View Lists, Note Blocks, View Lists, etc.
  3. When the user is editing an in-place family.

See Also

Autodesk.RevitAddIns Namespace

Send comments on this topic to Autodesk


WarningType Enumeration

[image]

RevitAddInUtility 2018 API
WarningType Enumeration
See Also Send Feedback
Defines types of warnings issued by Revit related to Add-In failures.

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public enum WarningType
Visual Basic
Public Enumeration WarningType
Visual C++
public enum class WarningType

Members

Member name | Description
NoWarning | There is no warning in this AddIn.
ClassNotFound | Revit could not find the indicated class in the assembly file.
WrongAssemblyPath | Revit could not find the assembly file.
UncaughtException | Unhandled exceptions were caught when the AddIn was executed.
GUIDConflict | There is another add-in which registered the same Id (GUID).
NoFullClassName | Missing the required value of the FullClassName node.
NoClientId | Missing the required value of the ClientId node.
NoAssembly | Missing the required value of the Assembly node.
NoApplicationName | Missing the required value of the Name node for application add-in.
InvalidFormatClientId | Revit could not interop.
WrongAvailabilityClass | Revit could not invoke IExternalCommandAvailability correctly.
UncaughtExceptionInAvailabilityClass | Unhandled exceptions were caught when the availability command was executed.
InvalidTransactionAttributeError | Not a valid transaction attribute.
InvalidRegenerationAttributeError | Not a valid regeneration attribute.
NoVendorId | Missing the required value of the VendorId node.

See Also

Autodesk.RevitAddIns Namespace

Send comments on this topic to Autodesk