Namespaces
Send Feedback

Namespaces

Namespace | Description
Autodesk.RevitAddIns |

Send comments on this topic to Autodesk


Autodesk.RevitAddIns Namespace

[image]

RevitAddInUtility 2019 API
Autodesk.RevitAddIns Namespace
Send Feedback

Classes

 | Class | Description
Public class | AddInManifestUtility |
Public class | RevitAddInApplication |
Public class | RevitAddInCommand |
Public class | RevitAddInDBApplication |
Public class | RevitAddInItem |
Public class | RevitAddInManifest |
Public class | RevitProduct |
Public class | RevitProductUtility |

Enumerations

 | Enumeration | Description
Public enumeration | AddInArchitecture |
Public enumeration | Discipline |
Public enumeration | LanguageType |
Public enumeration | ProductType |
Public enumeration | RevitVersion |
Public enumeration | VisibilityMode |
Public enumeration | WarningType |


AddInArchitecture Enumeration

[image]

RevitAddInUtility 2019 API
AddInArchitecture Enumeration
See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public enum AddInArchitecture
Visual Basic
Public Enumeration AddInArchitecture
Visual C++
public enum class AddInArchitecture

Members

Member name | Description
OS32bit |
OS64bit |

See Also

Autodesk.RevitAddIns Namespace


AddInManifestUtility Class

[image]

RevitAddInUtility 2019 API
AddInManifestUtility Class
Members See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public sealed class AddInManifestUtility
Visual Basic
Public NotInheritable Class AddInManifestUtility
Visual C++
public ref class AddInManifestUtility sealed

Inheritance Hierarchy

System..::..Object
Autodesk.RevitAddIns..::..AddInManifestUtility

See Also

AddInManifestUtility Members


AddInManifestUtility Members

[image] [image]

RevitAddInUtility 2019 API
AddInManifestUtility Members
AddInManifestUtility Class Constructors Methods See Also Send Feedback

The AddInManifestUtility type exposes the following members.

Constructors

 | Name | Description
Public method | AddInManifestUtility | Initializes a new instance of the AddInManifestUtility class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRevitAddInBundleManifests |
 | GetRevitAddInManifest |
 | GetRevitAddInManifests |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AddInManifestUtility Class


AddInManifestUtility Constructor

[image]

RevitAddInUtility 2019 API
AddInManifestUtility Constructor
AddInManifestUtility Class See Also Send Feedback
Initializes a new instance of the AddInManifestUtility class

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public AddInManifestUtility()
Visual Basic
Public Sub New
Visual C++
public:
AddInManifestUtility()

See Also

AddInManifestUtility Class


AddInManifestUtility Methods

[image] [image]

RevitAddInUtility 2019 API
AddInManifestUtility Methods
AddInManifestUtility Class See Also Send Feedback

The AddInManifestUtility type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRevitAddInBundleManifests |
 | GetRevitAddInManifest |
 | GetRevitAddInManifests |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AddInManifestUtility Class


GetRevitAddInBundleManifests Method

[image]

RevitAddInUtility 2019 API
AddInManifestUtility..::..GetRevitAddInBundleManifests Method
AddInManifestUtility Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public static List<RevitAddInManifest> GetRevitAddInBundleManifests(
    string revitVersion,
    string osString,
    Dictionary<string, string> invalidFormatManifestDictionary
)
Visual Basic
Public Shared Function GetRevitAddInBundleManifests ( _
    revitVersion As String, _
    osString As String, _
    invalidFormatManifestDictionary As Dictionary(Of String, String) _
) As List(Of RevitAddInManifest)
Visual C++
public:
static List<RevitAddInManifest^>^ GetRevitAddInBundleManifests(
    String^ revitVersion,
    String^ osString,
    Dictionary<String^, String^>^ invalidFormatManifestDictionary
)

Parameters

revitVersion
Type: System..::..String
osString
Type: System..::..String
invalidFormatManifestDictionary
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>

See Also

AddInManifestUtility Class


GetRevitAddInManifest Method

[image]

RevitAddInUtility 2019 API
AddInManifestUtility..::..GetRevitAddInManifest Method
AddInManifestUtility Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public static RevitAddInManifest GetRevitAddInManifest(
    string fileName
)
Visual Basic
Public Shared Function GetRevitAddInManifest ( _
    fileName As String _
) As RevitAddInManifest
Visual C++
public:
static RevitAddInManifest^ GetRevitAddInManifest(
    String^ fileName
)

Parameters

fileName
Type: System..::..String

See Also

AddInManifestUtility Class


GetRevitAddInManifests Method

[image]

RevitAddInUtility 2019 API
AddInManifestUtility..::..GetRevitAddInManifests Method
AddInManifestUtility Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public static List<RevitAddInManifest> GetRevitAddInManifests(
    string folderPath,
    Dictionary<string, string> invalidFormatManifestDictionary
)
Visual Basic
Public Shared Function GetRevitAddInManifests ( _
    folderPath As String, _
    invalidFormatManifestDictionary As Dictionary(Of String, String) _
) As List(Of RevitAddInManifest)
Visual C++
public:
static List<RevitAddInManifest^>^ GetRevitAddInManifests(
    String^ folderPath,
    Dictionary<String^, String^>^ invalidFormatManifestDictionary
)

Parameters

folderPath
Type: System..::..String
invalidFormatManifestDictionary
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>

See Also

AddInManifestUtility Class


Discipline Enumeration

[image]

RevitAddInUtility 2019 API
Discipline Enumeration
See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public enum Discipline
Visual Basic
Public Enumeration Discipline
Visual C++
public enum class Discipline

Members

Member name | Description
Any |
Architecture |
Structure |
StructuralAnalysis |
MassingAndSite |
EnergyAnalysis |
Mechanical |
Electrical |
Piping |
MechanicalAnalysis |
PipingAnalysis |
ElectricalAnalysis |

See Also

Autodesk.RevitAddIns Namespace

Send comments on this topic to Autodesk


LanguageType Enumeration

[image]

RevitAddInUtility 2019 API
LanguageType Enumeration
See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public enum LanguageType
Visual Basic
Public Enumeration LanguageType
Visual C++
public enum class LanguageType

Members

Member name | Description
Unknown |
English_USA |
German |
Spanish |
French |
Italian |
Dutch |
Chinese_Simplified |
Chinese_Traditional |
Japanese |
Korean |
Russian |
Czech |
Polish |
Hungarian |
Brazilian_Portuguese |
English_GB |

See Also

Autodesk.RevitAddIns Namespace

Send comments on this topic to Autodesk


ProductType Enumeration

[image]

RevitAddInUtility 2019 API
ProductType Enumeration
See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public enum ProductType
Visual Basic
Public Enumeration ProductType
Visual C++
public enum class ProductType

Members

Member name | Description
Architecture |
Structure |
MEP |
Revit |
Unknown |

See Also

Autodesk.RevitAddIns Namespace

Send comments on this topic to Autodesk


RevitAddInApplication Class

[image]

RevitAddInUtility 2019 API
RevitAddInApplication Class
Members See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public class RevitAddInApplication : RevitAddInItem
Visual Basic
Public Class RevitAddInApplication _
    Inherits RevitAddInItem
Visual C++
public ref class RevitAddInApplication : public RevitAddInItem

Inheritance Hierarchy

System..::..Object
Autodesk.RevitAddIns..::..RevitAddInItem
Autodesk.RevitAddIns..::..RevitAddInApplication

See Also

RevitAddInApplication Members


RevitAddInApplication Members

[image] [image]

RevitAddInUtility 2019 API
RevitAddInApplication Members
RevitAddInApplication Class Constructors Methods Properties See Also Send Feedback

The RevitAddInApplication type exposes the following members.

Constructors

 | Name | Description
Public method | RevitAddInApplication | Initializes a new instance of the RevitAddInApplication class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddInId | (Inherited from RevitAddInItem.)
Public property | AllowLoadingIntoExistingSession | (Inherited from RevitAddInItem.)
Public property | Assembly | (Inherited from RevitAddInItem.)
Public property | FullClassName | (Inherited from RevitAddInItem.)
Public property | Name |
Public property | ProductDescription | (Inherited from RevitAddInItem.)
Public property | ProductImage | (Inherited from RevitAddInItem.)
Public property | ProductVersion | (Inherited from RevitAddInItem.)
Public property | SuppressedWarning | (Inherited from RevitAddInItem.)
Public property | VendorDescription | (Inherited from RevitAddInItem.)
Public property | VendorId | (Inherited from RevitAddInItem.)

See Also

RevitAddInApplication Class


RevitAddInApplication Constructor

[image]

RevitAddInUtility 2019 API
RevitAddInApplication Constructor
RevitAddInApplication Class See Also Send Feedback
Initializes a new instance of the RevitAddInApplication class

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public RevitAddInApplication(
    string name,
    string assembly,
    Guid addInId,
    string fullClassName,
    string vendorId
)
Visual Basic
Public Sub New ( _
    name As String, _
    assembly As String, _
    addInId As Guid, _
    fullClassName As String, _
    vendorId As String _
)
Visual C++
public:
RevitAddInApplication(
    String^ name,
    String^ assembly,
    Guid addInId,
    String^ fullClassName,
    String^ vendorId
)

Parameters

name
Type: System..::..String
assembly
Type: System..::..String
addInId
Type: System..::..Guid
fullClassName
Type: System..::..String
vendorId
Type: System..::..String

See Also

RevitAddInApplication Class


RevitAddInApplication Methods

[image] [image]

RevitAddInUtility 2019 API
RevitAddInApplication Methods
RevitAddInApplication Class See Also Send Feedback

The RevitAddInApplication type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RevitAddInApplication Class


RevitAddInApplication Properties

[image] [image]

RevitAddInUtility 2019 API
RevitAddInApplication Properties
RevitAddInApplication Class See Also Send Feedback

The RevitAddInApplication type exposes the following members.

Properties

 | Name | Description
Public property | AddInId | (Inherited from RevitAddInItem.)
Public property | AllowLoadingIntoExistingSession | (Inherited from RevitAddInItem.)
Public property | Assembly | (Inherited from RevitAddInItem.)
Public property | FullClassName | (Inherited from RevitAddInItem.)
Public property | Name |
Public property | ProductDescription | (Inherited from RevitAddInItem.)
Public property | ProductImage | (Inherited from RevitAddInItem.)
Public property | ProductVersion | (Inherited from RevitAddInItem.)
Public property | SuppressedWarning | (Inherited from RevitAddInItem.)
Public property | VendorDescription | (Inherited from RevitAddInItem.)
Public property | VendorId | (Inherited from RevitAddInItem.)

See Also

RevitAddInApplication Class


Name Property

[image]

RevitAddInUtility 2019 API
RevitAddInApplication..::..Name Property
RevitAddInApplication Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInApplication Class


RevitAddInCommand Class

[image]

RevitAddInUtility 2019 API
RevitAddInCommand Class
Members See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public class RevitAddInCommand : RevitAddInItem
Visual Basic
Public Class RevitAddInCommand _
    Inherits RevitAddInItem
Visual C++
public ref class RevitAddInCommand : public RevitAddInItem

Inheritance Hierarchy

System..::..Object
Autodesk.RevitAddIns..::..RevitAddInItem
Autodesk.RevitAddIns..::..RevitAddInCommand

See Also

RevitAddInCommand Members


RevitAddInCommand Members

[image] [image]

RevitAddInUtility 2019 API
RevitAddInCommand Members
RevitAddInCommand Class Constructors Methods Properties See Also Send Feedback

The RevitAddInCommand type exposes the following members.

Constructors

 | Name | Description
Public method | RevitAddInCommand | Initializes a new instance of the RevitAddInCommand class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddInId | (Inherited from RevitAddInItem.)
Public property | AllowLoadingIntoExistingSession | (Inherited from RevitAddInItem.)
Public property | Assembly | (Inherited from RevitAddInItem.)
Public property | AvailabilityClassName |
Public property | Description |
Public property | Discipline |
Public property | FullClassName | (Inherited from RevitAddInItem.)
Public property | LanguageType |
Public property | LargeImage |
Public property | LongDescription |
Public property | ProductDescription | (Inherited from RevitAddInItem.)
Public property | ProductImage | (Inherited from RevitAddInItem.)
Public property | ProductVersion | (Inherited from RevitAddInItem.)
Public property | SuppressedWarning | (Inherited from RevitAddInItem.)
Public property | Text |
Public property | TooltipImage |
Public property | VendorDescription | (Inherited from RevitAddInItem.)
Public property | VendorId | (Inherited from RevitAddInItem.)
Public property | VisibilityMode |

See Also

RevitAddInCommand Class


RevitAddInCommand Constructor

[image]

RevitAddInUtility 2019 API
RevitAddInCommand Constructor
RevitAddInCommand Class See Also Send Feedback
Initializes a new instance of the RevitAddInCommand class

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public RevitAddInCommand(
    string assembly,
    Guid addInId,
    string fullClassName,
    string vendorId
)
Visual Basic
Public Sub New ( _
    assembly As String, _
    addInId As Guid, _
    fullClassName As String, _
    vendorId As String _
)
Visual C++
public:
RevitAddInCommand(
    String^ assembly,
    Guid addInId,
    String^ fullClassName,
    String^ vendorId
)

Parameters

assembly
Type: System..::..String
addInId
Type: System..::..Guid
fullClassName
Type: System..::..String
vendorId
Type: System..::..String

See Also

RevitAddInCommand Class


RevitAddInCommand Methods

[image] [image]

RevitAddInUtility 2019 API
RevitAddInCommand Methods
RevitAddInCommand Class See Also Send Feedback

The RevitAddInCommand type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RevitAddInCommand Class


RevitAddInCommand Properties

[image] [image]

RevitAddInUtility 2019 API
RevitAddInCommand Properties
RevitAddInCommand Class See Also Send Feedback

The RevitAddInCommand type exposes the following members.

Properties

 | Name | Description
Public property | AddInId | (Inherited from RevitAddInItem.)
Public property | AllowLoadingIntoExistingSession | (Inherited from RevitAddInItem.)
Public property | Assembly | (Inherited from RevitAddInItem.)
Public property | AvailabilityClassName |
Public property | Description |
Public property | Discipline |
Public property | FullClassName | (Inherited from RevitAddInItem.)
Public property | LanguageType |
Public property | LargeImage |
Public property | LongDescription |
Public property | ProductDescription | (Inherited from RevitAddInItem.)
Public property | ProductImage | (Inherited from RevitAddInItem.)
Public property | ProductVersion | (Inherited from RevitAddInItem.)
Public property | SuppressedWarning | (Inherited from RevitAddInItem.)
Public property | Text |
Public property | TooltipImage |
Public property | VendorDescription | (Inherited from RevitAddInItem.)
Public property | VendorId | (Inherited from RevitAddInItem.)
Public property | VisibilityMode |

See Also

RevitAddInCommand Class


AvailabilityClassName Property

[image]

RevitAddInUtility 2019 API
RevitAddInCommand..::..AvailabilityClassName Property
RevitAddInCommand Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string AvailabilityClassName { get; set; }
Visual Basic
Public Property AvailabilityClassName As String
    Get
    Set
Visual C++
public:
property String^ AvailabilityClassName {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInCommand Class


Description Property

[image]

RevitAddInUtility 2019 API
RevitAddInCommand..::..Description Property
RevitAddInCommand Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInCommand Class


Discipline Property

[image]

RevitAddInUtility 2019 API
RevitAddInCommand..::..Discipline Property
RevitAddInCommand Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public Discipline Discipline { get; set; }
Visual Basic
Public Property Discipline As Discipline
    Get
    Set
Visual C++
public:
property Discipline Discipline {
    Discipline get ();
    void set (Discipline value);
}

See Also

RevitAddInCommand Class


LanguageType Property

[image]

RevitAddInUtility 2019 API
RevitAddInCommand..::..LanguageType Property
RevitAddInCommand Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public LanguageType LanguageType { get; set; }
Visual Basic
Public Property LanguageType As LanguageType
    Get
    Set
Visual C++
public:
property LanguageType LanguageType {
    LanguageType get ();
    void set (LanguageType value);
}

See Also

RevitAddInCommand Class


LargeImage Property

[image]

RevitAddInUtility 2019 API
RevitAddInCommand..::..LargeImage Property
RevitAddInCommand Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string LargeImage { get; set; }
Visual Basic
Public Property LargeImage As String
    Get
    Set
Visual C++
public:
property String^ LargeImage {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInCommand Class


LongDescription Property

[image]

RevitAddInUtility 2019 API
RevitAddInCommand..::..LongDescription Property
RevitAddInCommand Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string LongDescription { get; set; }
Visual Basic
Public Property LongDescription As String
    Get
    Set
Visual C++
public:
property String^ LongDescription {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInCommand Class


Text Property

[image]

RevitAddInUtility 2019 API
RevitAddInCommand..::..Text Property
RevitAddInCommand Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInCommand Class


TooltipImage Property

[image]

RevitAddInUtility 2019 API
RevitAddInCommand..::..TooltipImage Property
RevitAddInCommand Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string TooltipImage { get; set; }
Visual Basic
Public Property TooltipImage As String
    Get
    Set
Visual C++
public:
property String^ TooltipImage {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInCommand Class


VisibilityMode Property

[image]

RevitAddInUtility 2019 API
RevitAddInCommand..::..VisibilityMode Property
RevitAddInCommand Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public VisibilityMode VisibilityMode { get; set; }
Visual Basic
Public Property VisibilityMode As VisibilityMode
    Get
    Set
Visual C++
public:
property VisibilityMode VisibilityMode {
    VisibilityMode get ();
    void set (VisibilityMode value);
}

See Also

RevitAddInCommand Class


RevitAddInDBApplication Class

[image]

RevitAddInUtility 2019 API
RevitAddInDBApplication Class
Members See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public class RevitAddInDBApplication : RevitAddInItem
Visual Basic
Public Class RevitAddInDBApplication _
    Inherits RevitAddInItem
Visual C++
public ref class RevitAddInDBApplication : public RevitAddInItem

Inheritance Hierarchy

System..::..Object
Autodesk.RevitAddIns..::..RevitAddInItem
Autodesk.RevitAddIns..::..RevitAddInDBApplication

See Also

RevitAddInDBApplication Members


RevitAddInDBApplication Members

[image] [image]

RevitAddInUtility 2019 API
RevitAddInDBApplication Members
RevitAddInDBApplication Class Constructors Methods Properties See Also Send Feedback

The RevitAddInDBApplication type exposes the following members.

Constructors

 | Name | Description
Public method | RevitAddInDBApplication | Initializes a new instance of the RevitAddInDBApplication class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddInId | (Inherited from RevitAddInItem.)
Public property | AllowLoadingIntoExistingSession | (Inherited from RevitAddInItem.)
Public property | Assembly | (Inherited from RevitAddInItem.)
Public property | FullClassName | (Inherited from RevitAddInItem.)
Public property | LoadInRevitWorker |
Public property | Name |
Public property | ProductDescription | (Inherited from RevitAddInItem.)
Public property | ProductImage | (Inherited from RevitAddInItem.)
Public property | ProductVersion | (Inherited from RevitAddInItem.)
Public property | SuppressedWarning | (Inherited from RevitAddInItem.)
Public property | VendorDescription | (Inherited from RevitAddInItem.)
Public property | VendorId | (Inherited from RevitAddInItem.)

See Also

RevitAddInDBApplication Class


RevitAddInDBApplication Constructor

[image]

RevitAddInUtility 2019 API
RevitAddInDBApplication Constructor
RevitAddInDBApplication Class See Also Send Feedback
Initializes a new instance of the RevitAddInDBApplication class

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public RevitAddInDBApplication(
    string name,
    string assembly,
    Guid addInId,
    string fullClassName,
    string vendorId
)
Visual Basic
Public Sub New ( _
    name As String, _
    assembly As String, _
    addInId As Guid, _
    fullClassName As String, _
    vendorId As String _
)
Visual C++
public:
RevitAddInDBApplication(
    String^ name,
    String^ assembly,
    Guid addInId,
    String^ fullClassName,
    String^ vendorId
)

Parameters

name
Type: System..::..String
assembly
Type: System..::..String
addInId
Type: System..::..Guid
fullClassName
Type: System..::..String
vendorId
Type: System..::..String

See Also

RevitAddInDBApplication Class


RevitAddInDBApplication Methods

[image] [image]

RevitAddInUtility 2019 API
RevitAddInDBApplication Methods
RevitAddInDBApplication Class See Also Send Feedback

The RevitAddInDBApplication type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RevitAddInDBApplication Class


RevitAddInDBApplication Properties

[image] [image]

RevitAddInUtility 2019 API
RevitAddInDBApplication Properties
RevitAddInDBApplication Class See Also Send Feedback

The RevitAddInDBApplication type exposes the following members.

Properties

 | Name | Description
Public property | AddInId | (Inherited from RevitAddInItem.)
Public property | AllowLoadingIntoExistingSession | (Inherited from RevitAddInItem.)
Public property | Assembly | (Inherited from RevitAddInItem.)
Public property | FullClassName | (Inherited from RevitAddInItem.)
Public property | LoadInRevitWorker |
Public property | Name |
Public property | ProductDescription | (Inherited from RevitAddInItem.)
Public property | ProductImage | (Inherited from RevitAddInItem.)
Public property | ProductVersion | (Inherited from RevitAddInItem.)
Public property | SuppressedWarning | (Inherited from RevitAddInItem.)
Public property | VendorDescription | (Inherited from RevitAddInItem.)
Public property | VendorId | (Inherited from RevitAddInItem.)

See Also

RevitAddInDBApplication Class


LoadInRevitWorker Property

[image]

RevitAddInUtility 2019 API
RevitAddInDBApplication..::..LoadInRevitWorker Property
RevitAddInDBApplication Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public bool LoadInRevitWorker { get; set; }
Visual Basic
Public Property LoadInRevitWorker As Boolean
    Get
    Set
Visual C++
public:
property bool LoadInRevitWorker {
    bool get ();
    void set (bool value);
}

See Also

RevitAddInDBApplication Class


Name Property

[image]

RevitAddInUtility 2019 API
RevitAddInDBApplication..::..Name Property
RevitAddInDBApplication Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInDBApplication Class


RevitAddInItem Class

[image]

RevitAddInUtility 2019 API
RevitAddInItem Class
Members See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public class RevitAddInItem
Visual Basic
Public Class RevitAddInItem
Visual C++
public ref class RevitAddInItem

Inheritance Hierarchy

System..::..Object
Autodesk.RevitAddIns..::..RevitAddInItem
Autodesk.RevitAddIns..::..RevitAddInApplication
Autodesk.RevitAddIns..::..RevitAddInCommand
Autodesk.RevitAddIns..::..RevitAddInDBApplication

See Also

RevitAddInItem Members


RevitAddInItem Members

[image] [image]

RevitAddInUtility 2019 API
RevitAddInItem Members
RevitAddInItem Class Methods Properties See Also Send Feedback

The RevitAddInItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddInId |
Public property | AllowLoadingIntoExistingSession |
Public property | Assembly |
Public property | FullClassName |
Public property | ProductDescription |
Public property | ProductImage |
Public property | ProductVersion |
Public property | SuppressedWarning |
Public property | VendorDescription |
Public property | VendorId |

See Also

RevitAddInItem Class


RevitAddInItem Methods

[image] [image]

RevitAddInUtility 2019 API
RevitAddInItem Methods
RevitAddInItem Class See Also Send Feedback

The RevitAddInItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RevitAddInItem Class


RevitAddInItem Properties

[image] [image]

RevitAddInUtility 2019 API
RevitAddInItem Properties
RevitAddInItem Class See Also Send Feedback

The RevitAddInItem type exposes the following members.

Properties

 | Name | Description
Public property | AddInId |
Public property | AllowLoadingIntoExistingSession |
Public property | Assembly |
Public property | FullClassName |
Public property | ProductDescription |
Public property | ProductImage |
Public property | ProductVersion |
Public property | SuppressedWarning |
Public property | VendorDescription |
Public property | VendorId |

See Also

RevitAddInItem Class


AddInId Property

[image]

RevitAddInUtility 2019 API
RevitAddInItem..::..AddInId Property
RevitAddInItem Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public Guid AddInId { get; set; }
Visual Basic
Public Property AddInId As Guid
    Get
    Set
Visual C++
public:
property Guid AddInId {
    Guid get ();
    void set (Guid value);
}

See Also

RevitAddInItem Class


AllowLoadingIntoExistingSession Property

[image]

RevitAddInUtility 2019 API
RevitAddInItem..::..AllowLoadingIntoExistingSession Property
RevitAddInItem Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public bool AllowLoadingIntoExistingSession { get; set; }
Visual Basic
Public Property AllowLoadingIntoExistingSession As Boolean
    Get
    Set
Visual C++
public:
property bool AllowLoadingIntoExistingSession {
    bool get ();
    void set (bool value);
}

See Also

RevitAddInItem Class


Assembly Property

[image]

RevitAddInUtility 2019 API
RevitAddInItem..::..Assembly Property
RevitAddInItem Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string Assembly { get; set; }
Visual Basic
Public Property Assembly As String
    Get
    Set
Visual C++
public:
property String^ Assembly {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInItem Class


FullClassName Property

[image]

RevitAddInUtility 2019 API
RevitAddInItem..::..FullClassName Property
RevitAddInItem Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string FullClassName { get; set; }
Visual Basic
Public Property FullClassName As String
    Get
    Set
Visual C++
public:
property String^ FullClassName {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInItem Class


ProductDescription Property

[image]

RevitAddInUtility 2019 API
RevitAddInItem..::..ProductDescription Property
RevitAddInItem Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string ProductDescription { get; set; }
Visual Basic
Public Property ProductDescription As String
    Get
    Set
Visual C++
public:
property String^ ProductDescription {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInItem Class


ProductImage Property

[image]

RevitAddInUtility 2019 API
RevitAddInItem..::..ProductImage Property
RevitAddInItem Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string ProductImage { get; set; }
Visual Basic
Public Property ProductImage As String
    Get
    Set
Visual C++
public:
property String^ ProductImage {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInItem Class


ProductVersion Property

[image]

RevitAddInUtility 2019 API
RevitAddInItem..::..ProductVersion Property
RevitAddInItem Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string ProductVersion { get; set; }
Visual Basic
Public Property ProductVersion As String
    Get
    Set
Visual C++
public:
property String^ ProductVersion {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInItem Class


SuppressedWarning Property

[image]

RevitAddInUtility 2019 API
RevitAddInItem..::..SuppressedWarning Property
RevitAddInItem Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public WarningType SuppressedWarning { get; set; }
Visual Basic
Public Property SuppressedWarning As WarningType
    Get
    Set
Visual C++
public:
property WarningType SuppressedWarning {
    WarningType get ();
    void set (WarningType value);
}

See Also

RevitAddInItem Class


VendorDescription Property

[image]

RevitAddInUtility 2019 API
RevitAddInItem..::..VendorDescription Property
RevitAddInItem Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string VendorDescription { get; set; }
Visual Basic
Public Property VendorDescription As String
    Get
    Set
Visual C++
public:
property String^ VendorDescription {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInItem Class


VendorId Property

[image]

RevitAddInUtility 2019 API
RevitAddInItem..::..VendorId Property
RevitAddInItem Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string VendorId { get; set; }
Visual Basic
Public Property VendorId As String
    Get
    Set
Visual C++
public:
property String^ VendorId {
    String^ get ();
    void set (String^ value);
}

See Also

RevitAddInItem Class


RevitAddInManifest Class

[image]

RevitAddInUtility 2019 API
RevitAddInManifest Class
Members See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public class RevitAddInManifest
Visual Basic
Public Class RevitAddInManifest
Visual C++
public ref class RevitAddInManifest

Inheritance Hierarchy

System..::..Object
Autodesk.RevitAddIns..::..RevitAddInManifest

See Also

RevitAddInManifest Members


RevitAddInManifest Members

[image] [image]

RevitAddInUtility 2019 API
RevitAddInManifest Members
RevitAddInManifest Class Constructors Methods Properties See Also Send Feedback

The RevitAddInManifest type exposes the following members.

Constructors

 | Name | Description
Public method | RevitAddInManifest | Initializes a new instance of the RevitAddInManifest class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Save |
Public method | SaveAs |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddInApplications |
Public property | AddInCommands |
Public property | AddInDBApplications |
Public property | FullName |
Public property | Name |

See Also

RevitAddInManifest Class


RevitAddInManifest Constructor

[image]

RevitAddInUtility 2019 API
RevitAddInManifest Constructor
RevitAddInManifest Class See Also Send Feedback
Initializes a new instance of the RevitAddInManifest class

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public RevitAddInManifest()
Visual Basic
Public Sub New
Visual C++
public:
RevitAddInManifest()

See Also

RevitAddInManifest Class


RevitAddInManifest Methods

[image] [image]

RevitAddInUtility 2019 API
RevitAddInManifest Methods
RevitAddInManifest Class See Also Send Feedback

The RevitAddInManifest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Save |
Public method | SaveAs |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RevitAddInManifest Class


Save Method

[image]

RevitAddInUtility 2019 API
RevitAddInManifest..::..Save Method
RevitAddInManifest Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public void Save()
Visual Basic
Public Sub Save
Visual C++
public:
void Save()

See Also

RevitAddInManifest Class


SaveAs Method

[image]

RevitAddInUtility 2019 API
RevitAddInManifest..::..SaveAs Method
RevitAddInManifest Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public void SaveAs(
    string fileName
)
Visual Basic
Public Sub SaveAs ( _
    fileName As String _
)
Visual C++
public:
void SaveAs(
    String^ fileName
)

Parameters

fileName
Type: System..::..String

See Also

RevitAddInManifest Class


RevitAddInManifest Properties

[image] [image]

RevitAddInUtility 2019 API
RevitAddInManifest Properties
RevitAddInManifest Class See Also Send Feedback

The RevitAddInManifest type exposes the following members.

Properties

 | Name | Description
Public property | AddInApplications |
Public property | AddInCommands |
Public property | AddInDBApplications |
Public property | FullName |
Public property | Name |

See Also

RevitAddInManifest Class


AddInApplications Property

[image]

RevitAddInUtility 2019 API
RevitAddInManifest..::..AddInApplications Property
RevitAddInManifest Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public List<RevitAddInApplication> AddInApplications { get; }
Visual Basic
Public ReadOnly Property AddInApplications As List(Of RevitAddInApplication)
    Get
Visual C++
public:
property List<RevitAddInApplication^>^ AddInApplications {
    List<RevitAddInApplication^>^ get ();
}

See Also

RevitAddInManifest Class


AddInCommands Property

[image]

RevitAddInUtility 2019 API
RevitAddInManifest..::..AddInCommands Property
RevitAddInManifest Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public List<RevitAddInCommand> AddInCommands { get; }
Visual Basic
Public ReadOnly Property AddInCommands As List(Of RevitAddInCommand)
    Get
Visual C++
public:
property List<RevitAddInCommand^>^ AddInCommands {
    List<RevitAddInCommand^>^ get ();
}

See Also

RevitAddInManifest Class


AddInDBApplications Property

[image]

RevitAddInUtility 2019 API
RevitAddInManifest..::..AddInDBApplications Property
RevitAddInManifest Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public List<RevitAddInDBApplication> AddInDBApplications { get; }
Visual Basic
Public ReadOnly Property AddInDBApplications As List(Of RevitAddInDBApplication)
    Get
Visual C++
public:
property List<RevitAddInDBApplication^>^ AddInDBApplications {
    List<RevitAddInDBApplication^>^ get ();
}

See Also

RevitAddInManifest Class


FullName Property

[image]

RevitAddInUtility 2019 API
RevitAddInManifest..::..FullName Property
RevitAddInManifest Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string FullName { get; }
Visual Basic
Public ReadOnly Property FullName As String
    Get
Visual C++
public:
property String^ FullName {
    String^ get ();
}

See Also

RevitAddInManifest Class


Name Property

[image]

RevitAddInUtility 2019 API
RevitAddInManifest..::..Name Property
RevitAddInManifest Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

RevitAddInManifest Class


RevitProduct Class

[image]

RevitAddInUtility 2019 API
RevitProduct Class
Members See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public class RevitProduct
Visual Basic
Public Class RevitProduct
Visual C++
public ref class RevitProduct

Inheritance Hierarchy

System..::..Object
Autodesk.RevitAddIns..::..RevitProduct

See Also

RevitProduct Members


RevitProduct Members

[image] [image]

RevitAddInUtility 2019 API
RevitProduct Members
RevitProduct Class Methods Properties See Also Send Feedback

The RevitProduct type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllUsersAddInFolder |
Public property | Architecture |
Public property | CurrentUserAddInFolder |
Public property | InstallLocation |
Public property | IsSubscriptionUpdate | Obsolete.
Public property | Name |
Public property | Product |
Public property | ProductCode |
Public property | ReleaseSubVersion |
Public property | Subversion |
Public property | Version |

See Also

RevitProduct Class


RevitProduct Methods

[image] [image]

RevitAddInUtility 2019 API
RevitProduct Methods
RevitProduct Class See Also Send Feedback

The RevitProduct type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RevitProduct Class


RevitProduct Properties

[image] [image]

RevitAddInUtility 2019 API
RevitProduct Properties
RevitProduct Class See Also Send Feedback

The RevitProduct type exposes the following members.

Properties

 | Name | Description
Public property | AllUsersAddInFolder |
Public property | Architecture |
Public property | CurrentUserAddInFolder |
Public property | InstallLocation |
Public property | IsSubscriptionUpdate | Obsolete.
Public property | Name |
Public property | Product |
Public property | ProductCode |
Public property | ReleaseSubVersion |
Public property | Subversion |
Public property | Version |

See Also

RevitProduct Class


AllUsersAddInFolder Property

[image]

RevitAddInUtility 2019 API
RevitProduct..::..AllUsersAddInFolder Property
RevitProduct Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string AllUsersAddInFolder { get; }
Visual Basic
Public ReadOnly Property AllUsersAddInFolder As String
    Get
Visual C++
public:
property String^ AllUsersAddInFolder {
    String^ get ();
}

See Also

RevitProduct Class


Architecture Property

[image]

RevitAddInUtility 2019 API
RevitProduct..::..Architecture Property
RevitProduct Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public AddInArchitecture Architecture { get; }
Visual Basic
Public ReadOnly Property Architecture As AddInArchitecture
    Get
Visual C++
public:
property AddInArchitecture Architecture {
    AddInArchitecture get ();
}

See Also

RevitProduct Class


CurrentUserAddInFolder Property

[image]

RevitAddInUtility 2019 API
RevitProduct..::..CurrentUserAddInFolder Property
RevitProduct Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string CurrentUserAddInFolder { get; }
Visual Basic
Public ReadOnly Property CurrentUserAddInFolder As String
    Get
Visual C++
public:
property String^ CurrentUserAddInFolder {
    String^ get ();
}

See Also

RevitProduct Class


InstallLocation Property

[image]

RevitAddInUtility 2019 API
RevitProduct..::..InstallLocation Property
RevitProduct Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string InstallLocation { get; }
Visual Basic
Public ReadOnly Property InstallLocation As String
    Get
Visual C++
public:
property String^ InstallLocation {
    String^ get ();
}

See Also

RevitProduct Class


IsSubscriptionUpdate Property

[image]

RevitAddInUtility 2019 API
RevitProduct..::..IsSubscriptionUpdate Property
RevitProduct Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
[ObsoleteAttribute("This property is deprecated in Revit 2018 and will be removed in the next version of Revit. We suggest you use the ReleaseSubVersion property instead.")]
public bool IsSubscriptionUpdate { get; }
Visual Basic
<ObsoleteAttribute("This property is deprecated in Revit 2018 and will be removed in the next version of Revit. We suggest you use the ReleaseSubVersion property instead.")> _
Public ReadOnly Property IsSubscriptionUpdate As Boolean
    Get
Visual C++
[ObsoleteAttribute(L"This property is deprecated in Revit 2018 and will be removed in the next version of Revit. We suggest you use the ReleaseSubVersion property instead.")]
public:
property bool IsSubscriptionUpdate {
    bool get ();
}

See Also

RevitProduct Class


Name Property

[image]

RevitAddInUtility 2019 API
RevitProduct..::..Name Property
RevitProduct Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

RevitProduct Class


Product Property

[image]

RevitAddInUtility 2019 API
RevitProduct..::..Product Property
RevitProduct Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public ProductType Product { get; }
Visual Basic
Public ReadOnly Property Product As ProductType
    Get
Visual C++
public:
property ProductType Product {
    ProductType get ();
}

See Also

RevitProduct Class


ProductCode Property

[image]

RevitAddInUtility 2019 API
RevitProduct..::..ProductCode Property
RevitProduct Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public Guid ProductCode { get; }
Visual Basic
Public ReadOnly Property ProductCode As Guid
    Get
Visual C++
public:
property Guid ProductCode {
    Guid get ();
}

See Also

RevitProduct Class


ReleaseSubVersion Property

[image]

RevitAddInUtility 2019 API
RevitProduct..::..ReleaseSubVersion Property
RevitProduct Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public string ReleaseSubVersion { get; }
Visual Basic
Public ReadOnly Property ReleaseSubVersion As String
    Get
Visual C++
public:
property String^ ReleaseSubVersion {
    String^ get ();
}

See Also

RevitProduct Class


Subversion Property

[image]

RevitAddInUtility 2019 API
RevitProduct..::..Subversion Property
RevitProduct Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public uint Subversion { get; }
Visual Basic
Public ReadOnly Property Subversion As UInteger
    Get
Visual C++
public:
property unsigned int Subversion {
    unsigned int get ();
}

See Also

RevitProduct Class


Version Property

[image]

RevitAddInUtility 2019 API
RevitProduct..::..Version Property
RevitProduct Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public RevitVersion Version { get; }
Visual Basic
Public ReadOnly Property Version As RevitVersion
    Get
Visual C++
public:
property RevitVersion Version {
    RevitVersion get ();
}

See Also

RevitProduct Class


RevitProductUtility Class

[image]

RevitAddInUtility 2019 API
RevitProductUtility Class
Members See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public sealed class RevitProductUtility
Visual Basic
Public NotInheritable Class RevitProductUtility
Visual C++
public ref class RevitProductUtility sealed

Inheritance Hierarchy

System..::..Object
Autodesk.RevitAddIns..::..RevitProductUtility

See Also

RevitProductUtility Members


RevitProductUtility Members

[image] [image]

RevitAddInUtility 2019 API
RevitProductUtility Members
RevitProductUtility Class Constructors Methods See Also Send Feedback

The RevitProductUtility type exposes the following members.

Constructors

 | Name | Description
Public method | RevitProductUtility | Initializes a new instance of the RevitProductUtility class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetAllInstalledRevitProducts |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RevitProductUtility Class


RevitProductUtility Constructor

[image]

RevitAddInUtility 2019 API
RevitProductUtility Constructor
RevitProductUtility Class See Also Send Feedback
Initializes a new instance of the RevitProductUtility class

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public RevitProductUtility()
Visual Basic
Public Sub New
Visual C++
public:
RevitProductUtility()

See Also

RevitProductUtility Class


RevitProductUtility Methods

[image] [image]

RevitAddInUtility 2019 API
RevitProductUtility Methods
RevitProductUtility Class See Also Send Feedback

The RevitProductUtility type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetAllInstalledRevitProducts |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RevitProductUtility Class


GetAllInstalledRevitProducts Method

[image]

RevitAddInUtility 2019 API
RevitProductUtility..::..GetAllInstalledRevitProducts Method
RevitProductUtility Class See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public static List<RevitProduct> GetAllInstalledRevitProducts()
Visual Basic
Public Shared Function GetAllInstalledRevitProducts As List(Of RevitProduct)
Visual C++
public:
static List<RevitProduct^>^ GetAllInstalledRevitProducts()

See Also

RevitProductUtility Class


RevitVersion Enumeration

[image]

RevitAddInUtility 2019 API
RevitVersion Enumeration
See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public enum RevitVersion
Visual Basic
Public Enumeration RevitVersion
Visual C++
public enum class RevitVersion

Members

Member name | Description
Unknown |
Revit2011 |
Revit2012 |
Revit2013 |
Revit2014 |
Revit2015 |
Revit2016 |
Revit2017 |
Revit2018 |
Revit2019 |

See Also

Autodesk.RevitAddIns Namespace

Send comments on this topic to Autodesk


VisibilityMode Enumeration

[image]

RevitAddInUtility 2019 API
VisibilityMode Enumeration
See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
[FlagsAttribute]
public enum VisibilityMode
Visual Basic
<FlagsAttribute> _
Public Enumeration VisibilityMode
Visual C++
[FlagsAttribute]
public enum class VisibilityMode

Members

Member name | Description
AlwaysVisible |
NotVisibleInProject |
NotVisibleInFamily |
NotVisibleWhenNoActiveDocument |

See Also

Autodesk.RevitAddIns Namespace

Send comments on this topic to Autodesk


WarningType Enumeration

[image]

RevitAddInUtility 2019 API
WarningType Enumeration
See Also Send Feedback

Namespace: Autodesk.RevitAddIns
Assembly: RevitAddInUtility (in RevitAddInUtility.dll) Version: 19.0.0.0 (19.0.0.0)

Syntax

C#
public enum WarningType
Visual Basic
Public Enumeration WarningType
Visual C++
public enum class WarningType

Members

Member name | Description
NoWarning |
ClassNotFound |
WrongAssemblyPath |
UncaughtException |
GUIDConflict |
NoFullClassName |
NoClientId |
NoAssembly |
NoApplicationName |
InvalidFormatClientId |
WrongAvailabilityClass |
UncaughtExceptionInAvailabilityClass |
InvalidTransactionAttributeError |
InvalidRegenerationAttributeError |
NoVendorId |

See Also

Autodesk.RevitAddIns Namespace

Send comments on this topic to Autodesk